Lucene.Net Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net"]

Classes

 | Class | Description
Public class | LucenePackage | Lucene's package information, including version. *


LucenePackage Class

[image]

Lucene.Net Class Libraries
LucenePackage Class
Members See Also Send Feedback
Lucene's package information, including version. *

Namespace: Lucene.Net
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class LucenePackage
Visual Basic
Public NotInheritable Class LucenePackage
Visual C++
public ref class LucenePackage sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net..::..LucenePackage

See Also

LucenePackage Members
Lucene.Net Namespace


LucenePackage Members

[image] [image]

Lucene.Net Class Libraries
LucenePackage Members
LucenePackage Class Methods See Also Send Feedback

The LucenePackage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LucenePackage Class
Lucene.Net Namespace


LucenePackage Methods

[image] [image]

Lucene.Net Class Libraries
LucenePackage Methods
LucenePackage Class See Also Send Feedback

The LucenePackage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LucenePackage Class
Lucene.Net Namespace


Lucene.Net.Analysis Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis"]

Classes

Class | Description
Public class Analyzer
An Analyzer builds TokenStreams, which analyze text. It thus represents a policy for extracting index terms from text.

Typical implementations first build a Tokenizer, which breaks the stream of characters from the Reader into raw Tokens. One or more TokenFilters may then be applied to the output of the Tokenizer.

Public class ASCIIFoldingFilter
This class converts alphabetic, numeric, and symbolic Unicode characters which are not in the first 127 ASCII characters (the "Basic Latin" Unicode block) into their ASCII equivalents, if one exists. Characters from the following Unicode blocks are converted; however, only those characters with reasonable ASCII alternatives are converted:
  • C1 Controls and Latin-1 Supplement: http://www.unicode.org/charts/PDF/U0080.pdf
  • Latin Extended-A: http://www.unicode.org/charts/PDF/U0100.pdf
  • Latin Extended-B: http://www.unicode.org/charts/PDF/U0180.pdf
  • Latin Extended Additional: http://www.unicode.org/charts/PDF/U1E00.pdf
  • Latin Extended-C: http://www.unicode.org/charts/PDF/U2C60.pdf
  • Latin Extended-D: http://www.unicode.org/charts/PDF/UA720.pdf
  • IPA Extensions: http://www.unicode.org/charts/PDF/U0250.pdf
  • Phonetic Extensions: http://www.unicode.org/charts/PDF/U1D00.pdf
  • Phonetic Extensions Supplement: http://www.unicode.org/charts/PDF/U1D80.pdf
  • General Punctuation: http://www.unicode.org/charts/PDF/U2000.pdf
  • Superscripts and Subscripts: http://www.unicode.org/charts/PDF/U2070.pdf
  • Enclosed Alphanumerics: http://www.unicode.org/charts/PDF/U2460.pdf
  • Dingbats: http://www.unicode.org/charts/PDF/U2700.pdf
  • Supplemental Punctuation: http://www.unicode.org/charts/PDF/U2E00.pdf
  • Alphabetic Presentation Forms: http://www.unicode.org/charts/PDF/UFB00.pdf
  • Halfwidth and Fullwidth Forms: http://www.unicode.org/charts/PDF/UFF00.pdf
See: http://en.wikipedia.org/wiki/Latin_characters_in_Unicode The set of character conversions supported by this class is a superset of those supported by Lucene's {@link ISOLatin1AccentFilter} which strips accents from Latin1 characters. For example, 'À' will be replaced by 'a'.
Public class BaseCharFilter
* Base utility class for implementing a {@link CharFilter}. * You subclass this, and then record mappings by calling * {@link #addOffCorrectMap}, and then invoke the correct * method to correct an offset.
Public class CachingTokenFilter
This class can be used if the token attributes of a TokenStream are intended to be consumed more than once. It caches all token attribute states locally in a List.

CachingTokenFilter implements the optional method {@link TokenStream#Reset()}, which repositions the stream to the first Token.

Public class CharacterCache Obsolete.
Replacement for Java 1.5 Character.valueOf()
Public class CharArraySet
A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.
Public class CharArraySet..::..CharArraySetIterator
The Iterator<String> for this set. Strings are constructed on the fly, so use
CopyC#
nextCharArray
 for more efficient access.
Public class CharFilter
Subclasses of CharFilter can be chained to filter CharStream. They can be used as {@link java.io.Reader} with additional offset correction. {@link Tokenizer}s will automatically use {@link #CorrectOffset} if a CharFilter/CharStream subclass is used.
Public class CharReader
CharReader is a Reader wrapper. It reads chars from Reader and outputs {@link CharStream}, defining an identify function {@link #CorrectOffset} method that simply returns the provided offset.
Public class CharStream
CharStream adds {@link #CorrectOffset} functionality over {@link Reader}. All Tokenizers accept a CharStream instead of {@link Reader} as input, which enables arbitrary character based filtering before tokenization. The {@link #CorrectOffset} method fixed offsets to account for removal or insertion of characters, so that the offsets reported in the tokens match the character offsets of the original Reader.
Public class CharTokenizer
An abstract base class for simple, character-oriented tokenizers.
Public class ISOLatin1AccentFilter Obsolete.
A filter that replaces accented characters in the ISO Latin 1 character set (ISO-8859-1) by their unaccented equivalent. The case will not be altered.

For instance, 'À' will be replaced by 'a'.

Public class KeywordAnalyzer
"Tokenizes" the entire stream as a single token. This is useful for data like zip codes, ids, and some product names.
Public class KeywordTokenizer
Emits the entire input as a single token.
Public class LengthFilter
Removes words that are too long or too short from the stream.
Public class LetterTokenizer
A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.
Public class LowerCaseFilter
Normalizes token text to lower case.
Public class LowerCaseTokenizer
LowerCaseTokenizer performs the function of LetterTokenizer and LowerCaseFilter together. It divides text at non-letters and converts them to lower case. While it is functionally equivalent to the combination of LetterTokenizer and LowerCaseFilter, there is a performance advantage to doing the two tasks at once, hence this (redundant) implementation.

Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.

Public class MappingCharFilter
Simplistic {@link CharFilter} that applies the mappings contained in a {@link NormalizeCharMap} to the character stream, and correcting the resulting changes to the offsets.
Public class NormalizeCharMap
Holds a map of String input to String output, to be used with {@link MappingCharFilter}.
Public class NumericTokenStream
Expert: This class provides a {@link TokenStream} for indexing numeric values that can be used by {@link NumericRangeQuery} or {@link NumericRangeFilter}.

Note that for simple usage, {@link NumericField} is recommended. {@link NumericField} disables norms and term freqs, as they are not usually needed during searching. If you need to change these settings, you should use this class.

See {@link NumericField} for capabilities of fields indexed numerically.

Here's an example usage, for an

CopyC#
int
field:
             Field field = new Field(name, new NumericTokenStream(precisionStep).setIntValue(value));
             field.setOmitNorms(true);
             field.setOmitTermFreqAndPositions(true);
             document.add(field);

For optimal performance, re-use the TokenStream and Field instance for more than one document:

             NumericTokenStream stream = new NumericTokenStream(precisionStep);
             Field field = new Field(name, stream);
             field.setOmitNorms(true);
             field.setOmitTermFreqAndPositions(true);
             Document document = new Document();
             document.add(field);

             for(all documents) {
               stream.setIntValue(value)
               writer.addDocument(document);
             }

This stream is not intended to be used in analyzers; it's more for iterating the different precisions during indexing a specific numeric value.

NOTE: as token streams are only consumed once the document is added to the index, if you index more than one numeric field, use a separate

CopyC#
NumericTokenStream
instance for each.

See {@link NumericRangeQuery} for more details on the

CopyC#
precisionStep
parameter as well as how numeric fields work under the hood.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class PerFieldAnalyzerWrapper
This analyzer is used to facilitate scenarios where different fields require different analysis techniques. Use {@link #addAnalyzer} to add a non-default analyzer on a field name basis.

Example usage:

            PerFieldAnalyzerWrapper aWrapper =
            new PerFieldAnalyzerWrapper(new StandardAnalyzer());
            aWrapper.addAnalyzer("firstname", new KeywordAnalyzer());
            aWrapper.addAnalyzer("lastname", new KeywordAnalyzer());

In this example, StandardAnalyzer will be used for all fields except "firstname" and "lastname", for which KeywordAnalyzer will be used.

A PerFieldAnalyzerWrapper can be used like any other analyzer, for both indexing and query parsing.

Public class PorterStemFilter
Transforms the token stream as per the Porter stemming algorithm. Note: the input to the stemming filter must already be in lower case, so you will need to use LowerCaseFilter or LowerCaseTokenizer farther down the Tokenizer chain in order for this to work properly!

To use this filter with other analyzers, you'll want to write an Analyzer class that sets up the TokenStream chain as you want it. To use this with LowerCaseTokenizer, for example, you'd write an analyzer like this:

class MyAnalyzer extends Analyzer {
public final TokenStream tokenStream(String fieldName, Reader reader) {
return new PorterStemFilter(new LowerCaseTokenizer(reader));
}
}

Public class SimpleAnalyzer
An {@link Analyzer} that filters {@link LetterTokenizer} with {@link LowerCaseFilter}
Public class SinkTokenizer Obsolete.
A SinkTokenizer can be used to cache Tokens for use in an Analyzer

WARNING: {@link TeeTokenFilter} and {@link SinkTokenizer} only work with the old TokenStream API. If you switch to the new API, you need to use {@link TeeSinkTokenFilter} instead, which offers the same functionality.

Public class StopAnalyzer
Filters {@link LetterTokenizer} with {@link LowerCaseFilter} and {@link StopFilter}.

You must specify the required {@link Version} compatibility when creating StopAnalyzer:

  • As of 2.9, position increments are preserved
Public class StopFilter
Removes stop words from a token stream.
Public class TeeSinkTokenFilter
This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
            TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
            TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
            TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
            source2.addSinkTokenStream(sink1);
            source2.addSinkTokenStream(sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using {@link #consumeAllTokens}. This TokenFilter is exhausted after this. In the above example, change the example above to:
            ...
            TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
            TokenStream final2 = source2.newSinkTokenStream();
            sink1.consumeAllTokens();
            sink2.consumeAllTokens();
            ...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

Public class | TeeSinkTokenFilter..::..AnonymousClassSinkFilter
Public class TeeSinkTokenFilter..::..SinkFilter
A filter that decides which {@link AttributeSource} states to store in the sink.
Public class | TeeSinkTokenFilter..::..SinkTokenStream
Public class TeeTokenFilter Obsolete.
Works in conjunction with the SinkTokenizer to provide the ability to set aside tokens that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            SinkTokenizer sink1 = new SinkTokenizer();
            SinkTokenizer sink2 = new SinkTokenizer();
            TokenStream source1 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader1), sink1), sink2);
            TokenStream source2 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader2), sink1), sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene

See LUCENE-1058.

WARNING: {@link TeeTokenFilter} and {@link SinkTokenizer} only work with the old TokenStream API. If you switch to the new API, you need to use {@link TeeSinkTokenFilter} instead, which offers the same functionality.

Public class Token
A Token is an occurrence of a term from the text of a field. It consists of a term's text, the start and end offset of the term in the text of the field, and a type string.

The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC display, etc.

The type is a string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".

A Token can optionally have metadata (a.k.a. Payload) in the form of a variable length byte array. Use {@link TermPositions#GetPayloadLength()} and {@link TermPositions#GetPayload(byte[], int)} to retrieve the payloads from the index.

Public class TokenFilter
A TokenFilter is a TokenStream whose input is another TokenStream.

This is an abstract class; subclasses must override {@link #IncrementToken()}.

Public class Tokenizer
A Tokenizer is a TokenStream whose input is a Reader.

This is an abstract class; subclasses must override {@link #IncrementToken()}

NOTE: Subclasses overriding {@link #next(Token)} must call
{@link AttributeSource#ClearAttributes()} before setting attributes.
Subclasses overriding {@link #IncrementToken()} must call
{@link Token#Clear()} before setting Token attributes.

Public class TokenStream
A
CopyC#
TokenStream
 enumerates the sequence of tokens, either from {@link Field}s of a {@link Document} or from query text.

This is an abstract class. Concrete subclasses are:

  • {@link Tokenizer}, a
    CopyC#
    TokenStream
     whose input is a Reader; and
  • {@link TokenFilter}, a
    CopyC#
    TokenStream
     whose input is another
    CopyC#
    TokenStream
    .
A new
CopyC#
TokenStream
 API has been introduced with Lucene 2.9. This API has moved from being {@link Token} based to {@link Attribute} based. While {@link Token} still exists in 2.9 as a convenience class, the preferred way to store the information of a {@link Token} is to use {@link AttributeImpl}s.

CopyC#
TokenStream
now extends {@link AttributeSource}, which provides access to all of the token {@link Attribute}s for the
CopyC#
TokenStream
. Note that only one instance per {@link AttributeImpl} is created and reused for every token. This approach reduces object creation and allows local caching of references to the {@link AttributeImpl}s. See {@link #IncrementToken()} for further details.

The workflow of the new

CopyC#
TokenStream
API is as follows:
  1. Instantiation of
    CopyC#
    TokenStream
    /{@link TokenFilter}s which add/get attributes to/from the {@link AttributeSource}.
  2. The consumer calls {@link TokenStream#Reset()}.
  3. The consumer retrieves attributes from the stream and stores local references to all attributes it wants to access
  4. The consumer calls {@link #IncrementToken()} until it returns false and consumes the attributes after each call.
  5. The consumer calls {@link #End()} so that any end-of-stream operations can be performed.
  6. The consumer calls {@link #Close()} to release any resource when finished using the
    CopyC#
    TokenStream
To make sure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.

You can find some example code for the new API in the analysis package level Javadoc.

Sometimes it is desirable to capture a current state of a

CopyC#
TokenStream
, e. g. for buffering purposes (see {@link CachingTokenFilter}, {@link TeeSinkTokenFilter}). For this usecase {@link AttributeSource#CaptureState} and {@link AttributeSource#RestoreState} can be used.
Public class TokenWrapper Obsolete.
This class wraps a Token and supplies a single attribute instance where the delegate token can be replaced.
Public class WhitespaceAnalyzer
An Analyzer that uses {@link WhitespaceTokenizer}.
Public class WhitespaceTokenizer
A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.
Public class WordlistLoader
Loads a text file and adds every line as an entry to a Hashtable. Every line should contain only one word. If the file is not found or on any error, an empty table is returned.


Analyzer Class

[image]

Lucene.Net Class Libraries
Analyzer Class
Members See Also Send Feedback
An Analyzer builds TokenStreams, which analyze text. It thus represents a policy for extracting index terms from text.

Typical implementations first build a Tokenizer, which breaks the stream of characters from the Reader into raw Tokens. One or more TokenFilters may then be applied to the output of the Tokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Analyzer
Visual Basic
Public MustInherit Class Analyzer
Visual C++
public ref class Analyzer abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.AR..::..ArabicAnalyzer
Lucene.Net.Analysis.BR..::..BrazilianAnalyzer
Lucene.Net.Analysis.CJK..::..CJKAnalyzer
Lucene.Net.Analysis.Cn..::..ChineseAnalyzer
Lucene.Net.Analysis.Cz..::..CzechAnalyzer
Lucene.Net.Analysis.De..::..GermanAnalyzer
Lucene.Net.Analysis.Ext..::..SingleCharTokenAnalyzer
Lucene.Net.Analysis.Ext..::..UnaccentedWordAnalyzer
Lucene.Net.Analysis.Fr..::..FrenchAnalyzer
Lucene.Net.Analysis..::..KeywordAnalyzer
Lucene.Net.Analysis.Nl..::..DutchAnalyzer
Lucene.Net.Analysis..::..PerFieldAnalyzerWrapper
Lucene.Net.Analysis.Ru..::..RussianAnalyzer
Lucene.Net.Analysis..::..SimpleAnalyzer
Lucene.Net.Analysis.Snowball..::..SnowballAnalyzer
Lucene.Net.Analysis.Standard..::..StandardAnalyzer
Lucene.Net.Analysis..::..StopAnalyzer
Lucene.Net.Analysis..::..WhitespaceAnalyzer
Lucene.Net.Analyzers.Shingle..::..ShingleAnalyzerWrapper

See Also

Analyzer Members
Lucene.Net.Analysis Namespace


Analyzer Members

[image] [image]

Lucene.Net Class Libraries
Analyzer Members
Analyzer Class Constructors Methods Fields See Also Send Feedback

The Analyzer type exposes the following members.

Constructors

 | Name | Description
Protected method | Analyzer | Initializes a new instance of the Analyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing.
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.
Protected method | SetOverridesTokenStreamMethod | Obsolete.
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod |

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


Analyzer Constructor

[image]

Lucene.Net Class Libraries
Analyzer Constructor
Analyzer Class See Also Send Feedback
Initializes a new instance of the Analyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Analyzer()
Visual Basic
Protected Sub New
Visual C++
protected:
Analyzer()

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


Analyzer Fields

[image] [image]

Lucene.Net Class Libraries
Analyzer Fields
Analyzer Class See Also Send Feedback

The Analyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod |

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


overridesTokenStreamMethod Field

[image]

Lucene.Net Class Libraries
Analyzer..::..overridesTokenStreamMethod Field
Analyzer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Analyzer.overridesTokenStreamMethod"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool overridesTokenStreamMethod
Visual Basic
Protected Friend overridesTokenStreamMethod As Boolean
Visual C++
protected public:
bool overridesTokenStreamMethod

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


Analyzer Methods

[image] [image]

Lucene.Net Class Libraries
Analyzer Methods
Analyzer Class See Also Send Feedback

The Analyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing.
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.
Protected method | SetOverridesTokenStreamMethod | Obsolete.
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
Analyzer..::..Close Method
Analyzer Class See Also Send Feedback
Frees persistent resources used by this Analyzer

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


GetOffsetGap Method

[image]

Lucene.Net Class Libraries
Analyzer..::..GetOffsetGap Method
Analyzer Class See Also Send Feedback
Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetOffsetGap(
    Fieldable field
)
Visual Basic
Public Overridable Function GetOffsetGap ( _
    field As Fieldable _
) As Integer
Visual C++
public:
virtual int GetOffsetGap(
    Fieldable^ field
)

Parameters

field
Type: Lucene.Net.Documents..::..Fieldable
the field just indexed

Return Value

offset gap, added to the next token emitted from {@link #TokenStream(String,Reader)}

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


GetPositionIncrementGap Method

[image]

Lucene.Net Class Libraries
Analyzer..::..GetPositionIncrementGap Method
Analyzer Class See Also Send Feedback
Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPositionIncrementGap(
    string fieldName
)
Visual Basic
Public Overridable Function GetPositionIncrementGap ( _
    fieldName As String _
) As Integer
Visual C++
public:
virtual int GetPositionIncrementGap(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Fieldable name being indexed.

Return Value

position increment gap, added to the next token emitted from {@link #TokenStream(String,Reader)}

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


GetPreviousTokenStream Method

[image]

Lucene.Net Class Libraries
Analyzer..::..GetPreviousTokenStream Method
Analyzer Class See Also Send Feedback
Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Object GetPreviousTokenStream()
Visual Basic
Protected Friend Overridable Function GetPreviousTokenStream As Object
Visual C++
protected public:
virtual Object^ GetPreviousTokenStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Analyzer.GetPreviousTokenStream"]

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
Analyzer..::..ReusableTokenStream Method
Analyzer Class See Also Send Feedback
Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overridable Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Analyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Analyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Analyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


SetOverridesTokenStreamMethod Method

[image]

Lucene.Net Class Libraries
Analyzer..::..SetOverridesTokenStreamMethod Method
Analyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Analyzer.SetOverridesTokenStreamMethod(System.Type)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")]
protected internal virtual void SetOverridesTokenStreamMethod(
    Type baseClass
)
Visual Basic
<ObsoleteAttribute("This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")> _
Protected Friend Overridable Sub SetOverridesTokenStreamMethod ( _
    baseClass As Type _
)
Visual C++
[ObsoleteAttribute(L"This is only present to preserve back-compat of classes that subclass a core analyzer and override tokenStream but not reusableTokenStream ")]
protected public:
virtual void SetOverridesTokenStreamMethod(
    Type^ baseClass
)

Parameters

baseClass
Type: System..::..Type

[Missing <param name="baseClass"/> documentation for "M:Lucene.Net.Analysis.Analyzer.SetOverridesTokenStreamMethod(System.Type)"]

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


SetPreviousTokenStream Method

[image]

Lucene.Net Class Libraries
Analyzer..::..SetPreviousTokenStream Method
Analyzer Class See Also Send Feedback
Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void SetPreviousTokenStream(
    Object obj
)
Visual Basic
Protected Friend Overridable Sub SetPreviousTokenStream ( _
    obj As Object _
)
Visual C++
protected public:
virtual void SetPreviousTokenStream(
    Object^ obj
)

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Analysis.Analyzer.SetPreviousTokenStream(System.Object)"]

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
Analyzer..::..TokenStream Method
Analyzer Class See Also Send Feedback
Creates a TokenStream which tokenizes all the text in the provided Reader. Must be able to handle null field name for backward compatibility.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public MustOverride Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) abstract

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Analyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Analyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Analyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

Analyzer Class
Lucene.Net.Analysis Namespace


ASCIIFoldingFilter Class

[image]

Lucene.Net Class Libraries
ASCIIFoldingFilter Class
Members See Also Send Feedback
This class converts alphabetic, numeric, and symbolic Unicode characters which are not in the first 127 ASCII characters (the "Basic Latin" Unicode block) into their ASCII equivalents, if one exists. Characters from the following Unicode blocks are converted; however, only those characters with reasonable ASCII alternatives are converted:
  • C1 Controls and Latin-1 Supplement: http://www.unicode.org/charts/PDF/U0080.pdf
  • Latin Extended-A: http://www.unicode.org/charts/PDF/U0100.pdf
  • Latin Extended-B: http://www.unicode.org/charts/PDF/U0180.pdf
  • Latin Extended Additional: http://www.unicode.org/charts/PDF/U1E00.pdf
  • Latin Extended-C: http://www.unicode.org/charts/PDF/U2C60.pdf
  • Latin Extended-D: http://www.unicode.org/charts/PDF/UA720.pdf
  • IPA Extensions: http://www.unicode.org/charts/PDF/U0250.pdf
  • Phonetic Extensions: http://www.unicode.org/charts/PDF/U1D00.pdf
  • Phonetic Extensions Supplement: http://www.unicode.org/charts/PDF/U1D80.pdf
  • General Punctuation: http://www.unicode.org/charts/PDF/U2000.pdf
  • Superscripts and Subscripts: http://www.unicode.org/charts/PDF/U2070.pdf
  • Enclosed Alphanumerics: http://www.unicode.org/charts/PDF/U2460.pdf
  • Dingbats: http://www.unicode.org/charts/PDF/U2700.pdf
  • Supplemental Punctuation: http://www.unicode.org/charts/PDF/U2E00.pdf
  • Alphabetic Presentation Forms: http://www.unicode.org/charts/PDF/UFB00.pdf
  • Halfwidth and Fullwidth Forms: http://www.unicode.org/charts/PDF/UFF00.pdf
See: http://en.wikipedia.org/wiki/Latin_characters_in_Unicode The set of character conversions supported by this class is a superset of those supported by Lucene's {@link ISOLatin1AccentFilter} which strips accents from Latin1 characters. For example, 'À' will be replaced by 'a'.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ASCIIFoldingFilter : TokenFilter
Visual Basic
Public NotInheritable Class ASCIIFoldingFilter _
    Inherits TokenFilter
Visual C++
public ref class ASCIIFoldingFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..ASCIIFoldingFilter

See Also

ASCIIFoldingFilter Members
Lucene.Net.Analysis Namespace


ASCIIFoldingFilter Members

[image] [image]

Lucene.Net Class Libraries
ASCIIFoldingFilter Members
ASCIIFoldingFilter Class Constructors Methods Fields See Also Send Feedback

The ASCIIFoldingFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ASCIIFoldingFilter | Initializes a new instance of the ASCIIFoldingFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FoldToASCII
Converts characters above ASCII to their ASCII equivalents. For example, accents are removed from accented characters.
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace


ASCIIFoldingFilter Constructor

[image]

Lucene.Net Class Libraries
ASCIIFoldingFilter Constructor
ASCIIFoldingFilter Class See Also Send Feedback
Initializes a new instance of the ASCIIFoldingFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ASCIIFoldingFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
ASCIIFoldingFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.ASCIIFoldingFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace


ASCIIFoldingFilter Fields

[image] [image]

Lucene.Net Class Libraries
ASCIIFoldingFilter Fields
ASCIIFoldingFilter Class See Also Send Feedback

The ASCIIFoldingFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace


ASCIIFoldingFilter Methods

[image] [image]

Lucene.Net Class Libraries
ASCIIFoldingFilter Methods
ASCIIFoldingFilter Class See Also Send Feedback

The ASCIIFoldingFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FoldToASCII
Converts characters above ASCII to their ASCII equivalents. For example, accents are removed from accented characters.
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace


FoldToASCII Method

[image]

Lucene.Net Class Libraries
ASCIIFoldingFilter..::..FoldToASCII Method
ASCIIFoldingFilter Class See Also Send Feedback
Converts characters above ASCII to their ASCII equivalents. For example, accents are removed from accented characters.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void FoldToASCII(
    char[] input,
    int length
)
Visual Basic
Public Sub FoldToASCII ( _
    input As Char(), _
    length As Integer _
)
Visual C++
public:
void FoldToASCII(
    array<wchar_t>^ input,
    int length
)

Parameters

input
Type: array< System..::..Char >[]()[][]
The string to fold
length
Type: System..::..Int32
The number of characters in the input string

See Also

ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
ASCIIFoldingFilter..::..IncrementToken Method
ASCIIFoldingFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.ASCIIFoldingFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.ASCIIFoldingFilter.IncrementToken"]

See Also

ASCIIFoldingFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ASCIIFoldingFilter..::..Next Method
ASCIIFoldingFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

ASCIIFoldingFilter Class
ASCIIFoldingFilter Members
Lucene.Net.Analysis Namespace


BaseCharFilter Class

[image]

Lucene.Net Class Libraries
BaseCharFilter Class
Members See Also Send Feedback
* Base utility class for implementing a {@link CharFilter}. * You subclass this, and then record mappings by calling * {@link #addOffCorrectMap}, and then invoke the correct * method to correct an offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class BaseCharFilter : CharFilter
Visual Basic
Public MustInherit Class BaseCharFilter _
    Inherits CharFilter
Visual C++
public ref class BaseCharFilter abstract : public CharFilter

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextReader
System.IO..::..StreamReader
Lucene.Net.Analysis..::..CharStream
Lucene.Net.Analysis..::..CharFilter
Lucene.Net.Analysis..::..BaseCharFilter
Lucene.Net.Analysis..::..MappingCharFilter

See Also

BaseCharFilter Members
Lucene.Net.Analysis Namespace


BaseCharFilter Members

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter Members
BaseCharFilter Class Constructors Methods Fields Properties See Also Send Feedback

The BaseCharFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BaseCharFilter | Initializes a new instance of the BaseCharFilter class

Methods

 | Name | Description
Protected method | AddOffCorrectMap |
Public method | Close | (Inherited from CharFilter.)
Public method | Correct | (Overrides CharFilter..::..Correct(Int32).)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLastCumulativeDiff |
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Inherited from CharFilter.)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | input | (Inherited from CharFilter.)

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


BaseCharFilter Constructor

[image]

Lucene.Net Class Libraries
BaseCharFilter Constructor
BaseCharFilter Class See Also Send Feedback
Initializes a new instance of the BaseCharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BaseCharFilter(
    CharStream in
)
Visual Basic
Public Sub New ( _
    in As CharStream _
)
Visual C++
public:
BaseCharFilter(
    CharStream^ in
)

Parameters

in
Type: Lucene.Net.Analysis..::..CharStream

[Missing <param name="in"/> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.#ctor(Lucene.Net.Analysis.CharStream)"]

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


BaseCharFilter Fields

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter Fields
BaseCharFilter Class See Also Send Feedback

The BaseCharFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | (Inherited from CharFilter.)

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


BaseCharFilter Methods

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter Methods
BaseCharFilter Class See Also Send Feedback

The BaseCharFilter type exposes the following members.

Methods

 | Name | Description
Protected method | AddOffCorrectMap |
Public method | Close | (Inherited from CharFilter.)
Public method | Correct | (Overrides CharFilter..::..Correct(Int32).)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLastCumulativeDiff |
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Inherited from CharFilter.)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


AddOffCorrectMap Method

[image]

Lucene.Net Class Libraries
BaseCharFilter..::..AddOffCorrectMap Method
BaseCharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.AddOffCorrectMap(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected void AddOffCorrectMap(
    int off,
    int cumulativeDiff
)
Visual Basic
Protected Sub AddOffCorrectMap ( _
    off As Integer, _
    cumulativeDiff As Integer _
)
Visual C++
protected:
void AddOffCorrectMap(
    int off,
    int cumulativeDiff
)

Parameters

off
Type: System..::..Int32

[Missing <param name="off"/> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.AddOffCorrectMap(System.Int32,System.Int32)"]

cumulativeDiff
Type: System..::..Int32

[Missing <param name="cumulativeDiff"/> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.AddOffCorrectMap(System.Int32,System.Int32)"]

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


Correct Method

[image]

Lucene.Net Class Libraries
BaseCharFilter..::..Correct Method
BaseCharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.Correct(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Correct(
    int currentOff
)
Visual Basic
Public Overrides Function Correct ( _
    currentOff As Integer _
) As Integer
Visual C++
public:
virtual int Correct(
    int currentOff
) override

Parameters

currentOff
Type: System..::..Int32

[Missing <param name="currentOff"/> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.Correct(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.Correct(System.Int32)"]

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter..::..Dispose Method
BaseCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)

See Also

BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace


GetLastCumulativeDiff Method

[image]

Lucene.Net Class Libraries
BaseCharFilter..::..GetLastCumulativeDiff Method
BaseCharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.GetLastCumulativeDiff"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected int GetLastCumulativeDiff()
Visual Basic
Protected Function GetLastCumulativeDiff As Integer
Visual C++
protected:
int GetLastCumulativeDiff()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.BaseCharFilter.GetLastCumulativeDiff"]

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter..::..MemberwiseClone Method
BaseCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter..::..Read Method
BaseCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Inherited from CharFilter.)

See Also

BaseCharFilter Class
BaseCharFilter Members
Lucene.Net.Analysis Namespace


BaseCharFilter Properties

[image] [image]

Lucene.Net Class Libraries
BaseCharFilter Properties
BaseCharFilter Class See Also Send Feedback

The BaseCharFilter type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

BaseCharFilter Class
Lucene.Net.Analysis Namespace


CachingTokenFilter Class

[image]

Lucene.Net Class Libraries
CachingTokenFilter Class
Members See Also Send Feedback
This class can be used if the token attributes of a TokenStream are intended to be consumed more than once. It caches all token attribute states locally in a List.

CachingTokenFilter implements the optional method {@link TokenStream#Reset()}, which repositions the stream to the first Token.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CachingTokenFilter : TokenFilter
Visual Basic
Public Class CachingTokenFilter _
    Inherits TokenFilter
Visual C++
public ref class CachingTokenFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..CachingTokenFilter

See Also

CachingTokenFilter Members
Lucene.Net.Analysis Namespace


CachingTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
CachingTokenFilter Members
CachingTokenFilter Class Constructors Methods Fields See Also Send Feedback

The CachingTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CachingTokenFilter | Initializes a new instance of the CachingTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method | End | (Overrides TokenFilter..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


CachingTokenFilter Constructor

[image]

Lucene.Net Class Libraries
CachingTokenFilter Constructor
CachingTokenFilter Class See Also Send Feedback
Initializes a new instance of the CachingTokenFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CachingTokenFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
CachingTokenFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


CachingTokenFilter Fields

[image] [image]

Lucene.Net Class Libraries
CachingTokenFilter Fields
CachingTokenFilter Class See Also Send Feedback

The CachingTokenFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


CachingTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
CachingTokenFilter Methods
CachingTokenFilter Class See Also Send Feedback

The CachingTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method | End | (Overrides TokenFilter..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
CachingTokenFilter..::..End Method
CachingTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.End"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
CachingTokenFilter..::..IncrementToken Method
CachingTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.IncrementToken"]

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
CachingTokenFilter..::..Next Method
CachingTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

CachingTokenFilter Class
CachingTokenFilter Members
Lucene.Net.Analysis Namespace


Next Method

[image]

Lucene.Net Class Libraries
CachingTokenFilter..::..Next Method
CachingTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.Next"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.Next"]

See Also

CachingTokenFilter Class
Next Overload
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
CachingTokenFilter..::..Next Method (Token)
CachingTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

CachingTokenFilter Class
Next Overload
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
CachingTokenFilter..::..Reset Method
CachingTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CachingTokenFilter.Reset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

CachingTokenFilter Class
Lucene.Net.Analysis Namespace


CharacterCache Class

[image]

Lucene.Net Class Libraries
CharacterCache Class
Members See Also Send Feedback
Replacement for Java 1.5 Character.valueOf()

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Move to Character.valueOf() in 3.0")]
public class CharacterCache
Visual Basic
<ObsoleteAttribute("Move to Character.valueOf() in 3.0")> _
Public Class CharacterCache
Visual C++
[ObsoleteAttribute(L"Move to Character.valueOf() in 3.0")]
public ref class CharacterCache

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..CharacterCache

See Also

CharacterCache Members
Lucene.Net.Analysis Namespace


CharacterCache Members

[image] [image]

Lucene.Net Class Libraries
CharacterCache Members
CharacterCache Class Constructors Methods See Also Send Feedback

The CharacterCache type exposes the following members.

Constructors

 | Name | Description
Public method | CharacterCache | Initializes a new instance of the CharacterCache class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueOf | Returns a Character instance representing the given char value

See Also

CharacterCache Class
Lucene.Net.Analysis Namespace


CharacterCache Constructor

[image]

Lucene.Net Class Libraries
CharacterCache Constructor
CharacterCache Class See Also Send Feedback
Initializes a new instance of the CharacterCache class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharacterCache()
Visual Basic
Public Sub New
Visual C++
public:
CharacterCache()

See Also

CharacterCache Class
Lucene.Net.Analysis Namespace


CharacterCache Methods

[image] [image]

Lucene.Net Class Libraries
CharacterCache Methods
CharacterCache Class See Also Send Feedback

The CharacterCache type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueOf | Returns a Character instance representing the given char value

See Also

CharacterCache Class
Lucene.Net.Analysis Namespace


ValueOf Method

[image]

Lucene.Net Class Libraries
CharacterCache..::..ValueOf Method
CharacterCache Class See Also Send Feedback
Returns a Character instance representing the given char value

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static char ValueOf(
    char c
)
Visual Basic
Public Shared Function ValueOf ( _
    c As Char _
) As Char
Visual C++
public:
static wchar_t ValueOf(
    wchar_t c
)

Parameters

c
Type: System..::..Char
a char value

Return Value

a Character representation of the given char value.

See Also

CharacterCache Class
Lucene.Net.Analysis Namespace


CharArraySet Class

[image]

Lucene.Net Class Libraries
CharArraySet Class
Members See Also Send Feedback
A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CharArraySet : Hashtable
Visual Basic
Public Class CharArraySet _
    Inherits Hashtable
Visual C++
public ref class CharArraySet : public Hashtable

Inheritance Hierarchy

System..::..Object
System.Collections..::..Hashtable
Lucene.Net.Analysis..::..CharArraySet

See Also

CharArraySet Members
Lucene.Net.Analysis Namespace


CharArraySet Members

[image] [image]

Lucene.Net Class Libraries
CharArraySet Members
CharArraySet Class Constructors Methods Properties See Also Send Feedback

The CharArraySet type exposes the following members.

Constructors

 | Name | Description
Public method | CharArraySet(ICollection, Boolean) | Create set from a Collection of char[] or String
Public method | CharArraySet(Int32, Boolean) | Create set with enough capacity to hold startSize terms

Methods

Name | Description
Public method Add(array<Char>[]()[][])
Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.
Public method | Add(Object)
Public method Add(String)
Add this String into the set
Public method | Add(Object, Object)
Public method AddAll
Adds all of the elements in the specified collection to this collection
Public method Clear
Removes all elements from the set
Public method Clone
Creates a shallow copy of the Hashtable.
(Inherited from Hashtable.)
Public method | Contains(Object) | (Overrides Hashtable..::..Contains(Object).)
Public method Contains(String)
true if the
CopyC#
System.String
 is in the set
Public method Contains(array<Char>[]()[][], Int32, Int32)
true if the
CopyC#
len
 chars of
CopyC#
text
 starting at
CopyC#
off
 are in the set
Public method ContainsKey
Determines whether the Hashtable contains a specific key.
(Inherited from Hashtable.)
Public method ContainsValue
Determines whether the Hashtable contains a specific value.
(Inherited from Hashtable.)
Public method CopyTo
Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
(Inherited from Hashtable.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetEnumerator
Protected method GetHash
Returns the hash code for the specified key.
(Inherited from Hashtable.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetObjectData
Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
(Inherited from Hashtable.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | IsEmpty
Protected method KeyEquals
Compares a specific Object with a specific key in the Hashtable.
(Inherited from Hashtable.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method OnDeserialization
Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
(Inherited from Hashtable.)
Public method Remove
Removes the element with the specified key from the Hashtable.
(Inherited from Hashtable.)
Public method RemoveAll
Removes from this set all of its elements that are contained in the specified collection
Public method RetainAll
Retains only the elements in this set that are contained in the specified collection
Public method | Size
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
UnmodifiableSet
Returns an unmodifiable {@link CharArraySet}. This allows to provide unmodifiable views of internal sets for "read-only" use.

Properties

 | Name | Description
Protected property | comparer | Obsolete. Gets or sets the IComparer to use for the Hashtable. (Inherited from Hashtable.)
Public property | Count | (Overrides Hashtable..::..Count.)
Protected property | EqualityComparer | Gets the IEqualityComparer to use for the Hashtable. (Inherited from Hashtable.)
Protected property | hcp | Obsolete. Gets or sets the object that can dispense hash codes. (Inherited from Hashtable.)
Public property | IsFixedSize | Gets a value indicating whether the Hashtable has a fixed size. (Inherited from Hashtable.)
Public property | IsReadOnly | Gets a value indicating whether the Hashtable is read-only. (Inherited from Hashtable.)
Public property | IsSynchronized | Gets a value indicating whether access to the Hashtable is synchronized (thread safe). (Inherited from Hashtable.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Hashtable.)
Public property | Keys | Gets an ICollection containing the keys in the Hashtable. (Inherited from Hashtable.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Hashtable. (Inherited from Hashtable.)
Public property | Values | Gets an ICollection containing the values in the Hashtable. (Inherited from Hashtable.)

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


CharArraySet Constructor

[image] [image]

Lucene.Net Class Libraries
CharArraySet Constructor
CharArraySet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CharArraySet(ICollection, Boolean) | Create set from a Collection of char[] or String
Public method | CharArraySet(Int32, Boolean) | Create set with enough capacity to hold startSize terms

See Also

CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace


CharArraySet Constructor (ICollection, Boolean)

[image]

Lucene.Net Class Libraries
CharArraySet Constructor (ICollection, Boolean)
CharArraySet Class See Also Send Feedback
Create set from a Collection of char[] or String

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharArraySet(
    ICollection c,
    bool ignoreCase
)
Visual Basic
Public Sub New ( _
    c As ICollection, _
    ignoreCase As Boolean _
)
Visual C++
public:
CharArraySet(
    ICollection^ c,
    bool ignoreCase
)

Parameters

c
Type: System.Collections..::..ICollection

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.#ctor(System.Collections.ICollection,System.Boolean)"]

ignoreCase
Type: System..::..Boolean

[Missing <param name="ignoreCase"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.#ctor(System.Collections.ICollection,System.Boolean)"]

See Also

CharArraySet Class
CharArraySet Overload
Lucene.Net.Analysis Namespace


CharArraySet Constructor (Int32, Boolean)

[image]

Lucene.Net Class Libraries
CharArraySet Constructor (Int32, Boolean)
CharArraySet Class See Also Send Feedback
Create set with enough capacity to hold startSize terms

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharArraySet(
    int startSize,
    bool ignoreCase
)
Visual Basic
Public Sub New ( _
    startSize As Integer, _
    ignoreCase As Boolean _
)
Visual C++
public:
CharArraySet(
    int startSize,
    bool ignoreCase
)

Parameters

startSize
Type: System..::..Int32

[Missing <param name="startSize"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.#ctor(System.Int32,System.Boolean)"]

ignoreCase
Type: System..::..Boolean

[Missing <param name="ignoreCase"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.#ctor(System.Int32,System.Boolean)"]

See Also

CharArraySet Class
CharArraySet Overload
Lucene.Net.Analysis Namespace


CharArraySet Methods

[image] [image]

Lucene.Net Class Libraries
CharArraySet Methods
CharArraySet Class See Also Send Feedback

The CharArraySet type exposes the following members.

Methods

Name | Description
Public method Add(array<Char>[]()[][])
Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.
Public method | Add(Object)
Public method Add(String)
Add this String into the set
Public method | Add(Object, Object)
Public method AddAll
Adds all of the elements in the specified collection to this collection
Public method Clear
Removes all elements from the set
Public method Clone
Creates a shallow copy of the Hashtable.
(Inherited from Hashtable.)
Public method | Contains(Object) | (Overrides Hashtable..::..Contains(Object).)
Public method Contains(String)
true if the
CopyC#
System.String
 is in the set
Public method Contains(array<Char>[]()[][], Int32, Int32)
true if the
CopyC#
len
 chars of
CopyC#
text
 starting at
CopyC#
off
 are in the set
Public method ContainsKey
Determines whether the Hashtable contains a specific key.
(Inherited from Hashtable.)
Public method ContainsValue
Determines whether the Hashtable contains a specific value.
(Inherited from Hashtable.)
Public method CopyTo
Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
(Inherited from Hashtable.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetEnumerator
Protected method GetHash
Returns the hash code for the specified key.
(Inherited from Hashtable.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetObjectData
Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
(Inherited from Hashtable.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | IsEmpty
Protected method KeyEquals
Compares a specific Object with a specific key in the Hashtable.
(Inherited from Hashtable.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method OnDeserialization
Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
(Inherited from Hashtable.)
Public method Remove
Removes the element with the specified key from the Hashtable.
(Inherited from Hashtable.)
Public method RemoveAll
Removes from this set all of its elements that are contained in the specified collection
Public method RetainAll
Retains only the elements in this set that are contained in the specified collection
Public method | Size
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
UnmodifiableSet
Returns an unmodifiable {@link CharArraySet}. This allows to provide unmodifiable views of internal sets for "read-only" use.

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
CharArraySet..::..Add Method
CharArraySet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(array<Char>[]()[][]) | Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.
Public method | Add(Object) |
Public method | Add(String) | Add this String into the set
Public method | Add(Object, Object) |

See Also

CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace


Add Method (Char[])

[image]

Lucene.Net Class Libraries
CharArraySet..::..Add Method (array<Char>[]()[][])
CharArraySet Class See Also Send Feedback
Add this char[] directly to the set. If ignoreCase is true for this Set, the text array will be directly modified. The user should never modify this text array after calling this method.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Add(
    char[] text
)
Visual Basic
Public Overridable Function Add ( _
    text As Char() _
) As Boolean
Visual C++
public:
virtual bool Add(
    array<wchar_t>^ text
)

Parameters

text
Type: array< System..::..Char >[]()[][]

[Missing <param name="text"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Char[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Char[])"]

See Also

CharArraySet Class
Add Overload
Lucene.Net.Analysis Namespace


Add Method (Object)

[image]

Lucene.Net Class Libraries
CharArraySet..::..Add Method (Object)
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Add(
    Object o
)
Visual Basic
Public Overridable Function Add ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Add(
    Object^ o
)

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object)"]

See Also

CharArraySet Class
Add Overload
Lucene.Net.Analysis Namespace


Add Method (String)

[image]

Lucene.Net Class Libraries
CharArraySet..::..Add Method (String)
CharArraySet Class See Also Send Feedback
Add this String into the set

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Add(
    string text
)
Visual Basic
Public Overridable Function Add ( _
    text As String _
) As Boolean
Visual C++
public:
virtual bool Add(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.String)"]

See Also

CharArraySet Class
Add Overload
Lucene.Net.Analysis Namespace


Add Method (Object, Object)

[image]

Lucene.Net Class Libraries
CharArraySet..::..Add Method (Object, Object)
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object,System.Object)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Add(
    Object key,
    Object value
)
Visual Basic
Public Overridable Function Add ( _
    key As Object, _
    value As Object _
) As Boolean
Visual C++
public:
virtual bool Add(
    Object^ key,
    Object^ value
)

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object,System.Object)"]

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Add(System.Object,System.Object)"]

See Also

CharArraySet Class
Add Overload
Lucene.Net.Analysis Namespace


AddAll Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..AddAll Method
CharArraySet Class See Also Send Feedback
Adds all of the elements in the specified collection to this collection

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool AddAll(
    ICollection items
)
Visual Basic
Public Overridable Function AddAll ( _
    items As ICollection _
) As Boolean
Visual C++
public:
virtual bool AddAll(
    ICollection^ items
)

Parameters

items
Type: System.Collections..::..ICollection

[Missing <param name="items"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.AddAll(System.Collections.ICollection)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.AddAll(System.Collections.ICollection)"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


Clear Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..Clear Method
CharArraySet Class See Also Send Feedback
Removes all elements from the set

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Clear()
Visual Basic
Public Overridable Function Clear As Boolean
Visual C++
public:
virtual bool Clear()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Clear"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


Contains Method

[image] [image]

Lucene.Net Class Libraries
CharArraySet..::..Contains Method
CharArraySet Class See Also Send Feedback

Overload List

Name | Description
Public method | Contains(Object) | (Overrides Hashtable..::..Contains(Object).)
Public method Contains(String)
true if the
CopyC#
System.String
 is in the set
Public method Contains(array<Char>[]()[][], Int32, Int32)
true if the
CopyC#
len
 chars of
CopyC#
text
 starting at
CopyC#
off
 are in the set

See Also

CharArraySet Class
CharArraySet Members
Lucene.Net.Analysis Namespace


Contains Method (Object)

[image]

Lucene.Net Class Libraries
CharArraySet..::..Contains Method (Object)
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Object)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Contains(
    Object o
)
Visual Basic
Public Overrides Function Contains ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Object)"]

Implements

IDictionary..::..Contains(Object)

See Also

CharArraySet Class
Contains Overload
Lucene.Net.Analysis Namespace


Contains Method (String)

[image]

Lucene.Net Class Libraries
CharArraySet..::..Contains Method (String)
CharArraySet Class See Also Send Feedback
true if the
CopyC#
System.String
 is in the set

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Contains(
    string cs
)
Visual Basic
Public Overridable Function Contains ( _
    cs As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.String)"]

See Also

CharArraySet Class
Contains Overload
Lucene.Net.Analysis Namespace


Contains Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
CharArraySet..::..Contains Method (array<Char>[]()[][], Int32, Int32)
CharArraySet Class See Also Send Feedback
true if the
CopyC#
len
 chars of
CopyC#
text
 starting at
CopyC#
off
 are in the set

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Contains(
    char[] text,
    int off,
    int len
)
Visual Basic
Public Overridable Function Contains ( _
    text As Char(), _
    off As Integer, _
    len As Integer _
) As Boolean
Visual C++
public:
virtual bool Contains(
    array<wchar_t>^ text,
    int off,
    int len
)

Parameters

text
Type: array< System..::..Char >[]()[][]

[Missing <param name="text"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Char[],System.Int32,System.Int32)"]

off
Type: System..::..Int32

[Missing <param name="off"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Contains(System.Char[],System.Int32,System.Int32)"]

See Also

CharArraySet Class
Contains Overload
Lucene.Net.Analysis Namespace


GetEnumerator Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..GetEnumerator Method
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.GetEnumerator"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
IEnumerator^ GetEnumerator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.GetEnumerator"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


IsEmpty Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..IsEmpty Method
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.IsEmpty"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsEmpty()
Visual Basic
Public Overridable Function IsEmpty As Boolean
Visual C++
public:
virtual bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.IsEmpty"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


RemoveAll Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..RemoveAll Method
CharArraySet Class See Also Send Feedback
Removes from this set all of its elements that are contained in the specified collection

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool RemoveAll(
    ICollection items
)
Visual Basic
Public Overridable Function RemoveAll ( _
    items As ICollection _
) As Boolean
Visual C++
public:
virtual bool RemoveAll(
    ICollection^ items
)

Parameters

items
Type: System.Collections..::..ICollection

[Missing <param name="items"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.RemoveAll(System.Collections.ICollection)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.RemoveAll(System.Collections.ICollection)"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


RetainAll Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..RetainAll Method
CharArraySet Class See Also Send Feedback
Retains only the elements in this set that are contained in the specified collection

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool RetainAll(
    ICollection coll
)
Visual Basic
Public Function RetainAll ( _
    coll As ICollection _
) As Boolean
Visual C++
public:
bool RetainAll(
    ICollection^ coll
)

Parameters

coll
Type: System.Collections..::..ICollection

[Missing <param name="coll"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.RetainAll(System.Collections.ICollection)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.RetainAll(System.Collections.ICollection)"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


Size Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..Size Method
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.Size"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Size()
Visual Basic
Public Overridable Function Size As Integer
Visual C++
public:
virtual int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.Size"]

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


UnmodifiableSet Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..UnmodifiableSet Method
CharArraySet Class See Also Send Feedback
Returns an unmodifiable {@link CharArraySet}. This allows to provide unmodifiable views of internal sets for "read-only" use.
if the given set is
CopyC#
null
.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static CharArraySet UnmodifiableSet(
    CharArraySet set_Renamed
)
Visual Basic
Public Shared Function UnmodifiableSet ( _
    set_Renamed As CharArraySet _
) As CharArraySet
Visual C++
public:
static CharArraySet^ UnmodifiableSet(
    CharArraySet^ set_Renamed
)

Parameters

set_Renamed
Type: Lucene.Net.Analysis..::..CharArraySet

[Missing <param name="set_Renamed"/> documentation for "M:Lucene.Net.Analysis.CharArraySet.UnmodifiableSet(Lucene.Net.Analysis.CharArraySet)"]

Return Value

an new unmodifiable {@link CharArraySet}.

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


CharArraySet Properties

[image] [image]

Lucene.Net Class Libraries
CharArraySet Properties
CharArraySet Class See Also Send Feedback

The CharArraySet type exposes the following members.

Properties

 | Name | Description
Protected property | comparer | Obsolete. Gets or sets the IComparer to use for the Hashtable. (Inherited from Hashtable.)
Public property | Count | (Overrides Hashtable..::..Count.)
Protected property | EqualityComparer | Gets the IEqualityComparer to use for the Hashtable. (Inherited from Hashtable.)
Protected property | hcp | Obsolete. Gets or sets the object that can dispense hash codes. (Inherited from Hashtable.)
Public property | IsFixedSize | Gets a value indicating whether the Hashtable has a fixed size. (Inherited from Hashtable.)
Public property | IsReadOnly | Gets a value indicating whether the Hashtable is read-only. (Inherited from Hashtable.)
Public property | IsSynchronized | Gets a value indicating whether access to the Hashtable is synchronized (thread safe). (Inherited from Hashtable.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Hashtable.)
Public property | Keys | Gets an ICollection containing the keys in the Hashtable. (Inherited from Hashtable.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Hashtable. (Inherited from Hashtable.)
Public property | Values | Gets an ICollection containing the values in the Hashtable. (Inherited from Hashtable.)

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


Count Property

[image]

Lucene.Net Class Libraries
CharArraySet..::..Count Property
CharArraySet Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analysis.CharArraySet.Count"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Count { get; }
Visual Basic
Public Overrides ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () override;
}

Implements

ICollection..::..Count

See Also

CharArraySet Class
Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Class

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator Class
CharArraySet Class Members See Also Send Feedback
The Iterator<String> for this set. Strings are constructed on the fly, so use
CopyC#
nextCharArray
 for more efficient access.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CharArraySetIterator : IEnumerator
Visual Basic
Public Class CharArraySetIterator _
    Implements IEnumerator
Visual C++
public ref class CharArraySetIterator : IEnumerator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..CharArraySet..::..CharArraySetIterator

See Also

CharArraySet..::..CharArraySetIterator Members
Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Members

[image] [image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator Members
CharArraySet..::..CharArraySetIterator Class Methods Properties See Also Send Feedback

A simple class that stores Strings as char[]'s in a hash table. Note that this is not a general purpose class. For example, it cannot remove items from the set, nor does it resize its hash table to be smaller, etc. It is designed to be quick to test if a char[] is in the set without the necessity of converting it to a String first.

The CharArraySet..::..CharArraySetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | NextCharArray | do not modify the returned char[]
Public method | Remove |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Returns the next String, as a Set<String> would... use nextCharArray() for better efficiency.
Public property | Enclosing_Instance |

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Methods

[image] [image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator Methods
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback

The CharArraySet..::..CharArraySetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | NextCharArray | do not modify the returned char[]
Public method | Remove |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


MoveNext Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator..::..MoveNext Method
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.CharArraySetIterator.MoveNext"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.CharArraySetIterator.MoveNext"]

Implements

IEnumerator..::..MoveNext()()()()

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


NextCharArray Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator..::..NextCharArray Method
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback
do not modify the returned char[]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual char[] NextCharArray()
Visual Basic
Public Overridable Function NextCharArray As Char()
Visual C++
public:
virtual array<wchar_t>^ NextCharArray()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharArraySet.CharArraySetIterator.NextCharArray"]

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


Remove Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator..::..Remove Method
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.CharArraySetIterator.Remove"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Remove()
Visual Basic
Public Overridable Sub Remove
Visual C++
public:
virtual void Remove()

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator..::..Reset Method
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharArraySet.CharArraySetIterator.Reset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


CharArraySet.CharArraySetIterator Properties

[image] [image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator Properties
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback

The CharArraySet..::..CharArraySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Returns the next String, as a Set<String> would... use nextCharArray() for better efficiency.
Public property | Enclosing_Instance |

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


Current Property

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator..::..Current Property
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback
Returns the next String, as a Set<String> would... use nextCharArray() for better efficiency.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
CharArraySet..::..CharArraySetIterator..::..Enclosing_Instance Property
CharArraySet..::..CharArraySetIterator Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analysis.CharArraySet.CharArraySetIterator.Enclosing_Instance"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharArraySet Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As CharArraySet
    Get
Visual C++
public:
property CharArraySet^ Enclosing_Instance {
    CharArraySet^ get ();
}

See Also

CharArraySet..::..CharArraySetIterator Class
Lucene.Net.Analysis Namespace


CharFilter Class

[image]

Lucene.Net Class Libraries
CharFilter Class
Members See Also Send Feedback
Subclasses of CharFilter can be chained to filter CharStream. They can be used as {@link java.io.Reader} with additional offset correction. {@link Tokenizer}s will automatically use {@link #CorrectOffset} if a CharFilter/CharStream subclass is used.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class CharFilter : CharStream
Visual Basic
Public MustInherit Class CharFilter _
    Inherits CharStream
Visual C++
public ref class CharFilter abstract : public CharStream

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextReader
System.IO..::..StreamReader
Lucene.Net.Analysis..::..CharStream
Lucene.Net.Analysis..::..CharFilter
Lucene.Net.Analysis..::..BaseCharFilter

See Also

CharFilter Members
Lucene.Net.Analysis Namespace


CharFilter Members

[image] [image]

Lucene.Net Class Libraries
CharFilter Members
CharFilter Class Constructors Methods Fields Properties See Also Send Feedback

The CharFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | CharFilter | Initializes a new instance of the CharFilter class

Methods

 | Name | Description
Public method | Close | (Overrides StreamReader..::..Close()()()().)
Public method | Correct | Subclass may want to override to correct the current offset.
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Overrides CharStream..::..CorrectOffset(Int32).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides StreamReader..::..Read(array<Char>[]()[][], Int32, Int32).)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | input |

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


CharFilter Constructor

[image]

Lucene.Net Class Libraries
CharFilter Constructor
CharFilter Class See Also Send Feedback
Initializes a new instance of the CharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal CharFilter(
    CharStream in_Renamed
)
Visual Basic
Protected Friend Sub New ( _
    in_Renamed As CharStream _
)
Visual C++
protected public:
CharFilter(
    CharStream^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..CharStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.CharFilter.#ctor(Lucene.Net.Analysis.CharStream)"]

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


CharFilter Fields

[image] [image]

Lucene.Net Class Libraries
CharFilter Fields
CharFilter Class See Also Send Feedback

The CharFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input |

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


input Field

[image]

Lucene.Net Class Libraries
CharFilter..::..input Field
CharFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.CharFilter.input"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal CharStream input
Visual Basic
Protected Friend input As CharStream
Visual C++
protected public:
CharStream^ input

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


CharFilter Methods

[image] [image]

Lucene.Net Class Libraries
CharFilter Methods
CharFilter Class See Also Send Feedback

The CharFilter type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides StreamReader..::..Close()()()().)
Public method | Correct | Subclass may want to override to correct the current offset.
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Overrides CharStream..::..CorrectOffset(Int32).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides StreamReader..::..Read(array<Char>[]()[][], Int32, Int32).)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
CharFilter..::..Close Method
CharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharFilter.Close"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


Correct Method

[image]

Lucene.Net Class Libraries
CharFilter..::..Correct Method
CharFilter Class See Also Send Feedback
Subclass may want to override to correct the current offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Correct(
    int currentOff
)
Visual Basic
Public Overridable Function Correct ( _
    currentOff As Integer _
) As Integer
Visual C++
public:
virtual int Correct(
    int currentOff
)

Parameters

currentOff
Type: System..::..Int32
current offset

Return Value

corrected offset

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


CorrectOffset Method

[image]

Lucene.Net Class Libraries
CharFilter..::..CorrectOffset Method
CharFilter Class See Also Send Feedback
Chains the corrected offset through the input CharFilter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CorrectOffset(
    int currentOff
)
Visual Basic
Public Overrides Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Visual C++
public:
virtual int CorrectOffset(
    int currentOff
) override

Parameters

currentOff
Type: System..::..Int32

[Missing <param name="currentOff"/> documentation for "M:Lucene.Net.Analysis.CharFilter.CorrectOffset(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharFilter.CorrectOffset(System.Int32)"]

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
CharFilter..::..Dispose Method
CharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)

See Also

CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace


Mark Method

[image]

Lucene.Net Class Libraries
CharFilter..::..Mark Method
CharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharFilter.Mark(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Mark(
    int readAheadLimit
)
Visual Basic
Public Sub Mark ( _
    readAheadLimit As Integer _
)
Visual C++
public:
void Mark(
    int readAheadLimit
)

Parameters

readAheadLimit
Type: System..::..Int32

[Missing <param name="readAheadLimit"/> documentation for "M:Lucene.Net.Analysis.CharFilter.Mark(System.Int32)"]

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


MarkSupported Method

[image]

Lucene.Net Class Libraries
CharFilter..::..MarkSupported Method
CharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharFilter.MarkSupported"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool MarkSupported()
Visual Basic
Public Function MarkSupported As Boolean
Visual C++
public:
bool MarkSupported()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharFilter.MarkSupported"]

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
CharFilter..::..MemberwiseClone Method
CharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
CharFilter..::..Read Method
CharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides StreamReader..::..Read(array<Char>[]()[][], Int32, Int32).)

See Also

CharFilter Class
CharFilter Members
Lucene.Net.Analysis Namespace


Read Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
CharFilter..::..Read Method (array<Char>[]()[][], Int32, Int32)
CharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharFilter.Read(System.Char[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Read(
    char[] cbuf,
    int off,
    int len
)
Visual Basic
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
Visual C++
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override

Parameters

cbuf
Type: array< System..::..Char >[]()[][]

[Missing <param name="cbuf"/> documentation for "M:Lucene.Net.Analysis.CharFilter.Read(System.Char[],System.Int32,System.Int32)"]

off
Type: System..::..Int32

[Missing <param name="off"/> documentation for "M:Lucene.Net.Analysis.CharFilter.Read(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.CharFilter.Read(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharFilter.Read(System.Char[],System.Int32,System.Int32)"]

See Also

CharFilter Class
Read Overload
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
CharFilter..::..Reset Method
CharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharFilter.Reset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


CharFilter Properties

[image] [image]

Lucene.Net Class Libraries
CharFilter Properties
CharFilter Class See Also Send Feedback

The CharFilter type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

CharFilter Class
Lucene.Net.Analysis Namespace


CharReader Class

[image]

Lucene.Net Class Libraries
CharReader Class
Members See Also Send Feedback
CharReader is a Reader wrapper. It reads chars from Reader and outputs {@link CharStream}, defining an identify function {@link #CorrectOffset} method that simply returns the provided offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class CharReader : CharStream
Visual Basic
Public NotInheritable Class CharReader _
    Inherits CharStream
Visual C++
public ref class CharReader sealed : public CharStream

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextReader
System.IO..::..StreamReader
Lucene.Net.Analysis..::..CharStream
Lucene.Net.Analysis..::..CharReader

See Also

CharReader Members
Lucene.Net.Analysis Namespace


CharReader Members

[image] [image]

Lucene.Net Class Libraries
CharReader Members
CharReader Class Methods Properties See Also Send Feedback

The CharReader type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides StreamReader..::..Close()()()().)
Public method | CorrectOffset | (Overrides CharStream..::..CorrectOffset(Int32).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides StreamReader..::..Read(array<Char>[]()[][], Int32, Int32).)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

CharReader Class
Lucene.Net.Analysis Namespace


CharReader Methods

[image] [image]

Lucene.Net Class Libraries
CharReader Methods
CharReader Class See Also Send Feedback

The CharReader type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides StreamReader..::..Close()()()().)
Public method | CorrectOffset | (Overrides CharStream..::..CorrectOffset(Int32).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark |
Public method | MarkSupported |
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides StreamReader..::..Read(array<Char>[]()[][], Int32, Int32).)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CharReader Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
CharReader..::..Close Method
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.Close"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

CharReader Class
Lucene.Net.Analysis Namespace


CorrectOffset Method

[image]

Lucene.Net Class Libraries
CharReader..::..CorrectOffset Method
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.CorrectOffset(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CorrectOffset(
    int currentOff
)
Visual Basic
Public Overrides Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Visual C++
public:
virtual int CorrectOffset(
    int currentOff
) override

Parameters

currentOff
Type: System..::..Int32

[Missing <param name="currentOff"/> documentation for "M:Lucene.Net.Analysis.CharReader.CorrectOffset(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharReader.CorrectOffset(System.Int32)"]

See Also

CharReader Class
Lucene.Net.Analysis Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
CharReader..::..Dispose Method
CharReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)

See Also

CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace


Get Method

[image]

Lucene.Net Class Libraries
CharReader..::..Get Method
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.Get(System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static CharStream Get(
    TextReader input
)
Visual Basic
Public Shared Function Get ( _
    input As TextReader _
) As CharStream
Visual C++
public:
static CharStream^ Get(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.CharReader.Get(System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharReader.Get(System.IO.TextReader)"]

See Also

CharReader Class
Lucene.Net.Analysis Namespace


Mark Method

[image]

Lucene.Net Class Libraries
CharReader..::..Mark Method
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.Mark(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Mark(
    int readAheadLimit
)
Visual Basic
Public Sub Mark ( _
    readAheadLimit As Integer _
)
Visual C++
public:
void Mark(
    int readAheadLimit
)

Parameters

readAheadLimit
Type: System..::..Int32

[Missing <param name="readAheadLimit"/> documentation for "M:Lucene.Net.Analysis.CharReader.Mark(System.Int32)"]

See Also

CharReader Class
Lucene.Net.Analysis Namespace


MarkSupported Method

[image]

Lucene.Net Class Libraries
CharReader..::..MarkSupported Method
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.MarkSupported"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool MarkSupported()
Visual Basic
Public Function MarkSupported As Boolean
Visual C++
public:
bool MarkSupported()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharReader.MarkSupported"]

See Also

CharReader Class
Lucene.Net.Analysis Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
CharReader..::..MemberwiseClone Method
CharReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
CharReader..::..Read Method
CharReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides StreamReader..::..Read(array<Char>[]()[][], Int32, Int32).)

See Also

CharReader Class
CharReader Members
Lucene.Net.Analysis Namespace


Read Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
CharReader..::..Read Method (array<Char>[]()[][], Int32, Int32)
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.Read(System.Char[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Read(
    char[] cbuf,
    int off,
    int len
)
Visual Basic
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
Visual C++
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override

Parameters

cbuf
Type: array< System..::..Char >[]()[][]

[Missing <param name="cbuf"/> documentation for "M:Lucene.Net.Analysis.CharReader.Read(System.Char[],System.Int32,System.Int32)"]

off
Type: System..::..Int32

[Missing <param name="off"/> documentation for "M:Lucene.Net.Analysis.CharReader.Read(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.CharReader.Read(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharReader.Read(System.Char[],System.Int32,System.Int32)"]

See Also

CharReader Class
Read Overload
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
CharReader..::..Reset Method
CharReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharReader.Reset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

CharReader Class
Lucene.Net.Analysis Namespace


CharReader Properties

[image] [image]

Lucene.Net Class Libraries
CharReader Properties
CharReader Class See Also Send Feedback

The CharReader type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

CharReader Class
Lucene.Net.Analysis Namespace


CharStream Class

[image]

Lucene.Net Class Libraries
CharStream Class
Members See Also Send Feedback
CharStream adds {@link #CorrectOffset} functionality over {@link Reader}. All Tokenizers accept a CharStream instead of {@link Reader} as input, which enables arbitrary character based filtering before tokenization. The {@link #CorrectOffset} method fixed offsets to account for removal or insertion of characters, so that the offsets reported in the tokens match the character offsets of the original Reader.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class CharStream : StreamReader
Visual Basic
Public MustInherit Class CharStream _
    Inherits StreamReader
Visual C++
public ref class CharStream abstract : public StreamReader

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextReader
System.IO..::..StreamReader
Lucene.Net.Analysis..::..CharStream
Lucene.Net.Analysis..::..CharFilter
Lucene.Net.Analysis..::..CharReader

See Also

CharStream Members
Lucene.Net.Analysis Namespace


CharStream Members

[image] [image]

Lucene.Net Class Libraries
CharStream Members
CharStream Class Constructors Methods Properties See Also Send Feedback

The CharStream type exposes the following members.

Constructors

 | Name | Description
Public method | CharStream | Initializes a new instance of the CharStream class

Methods

 | Name | Description
Public method | Close | Closes the StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from StreamReader.)
Public method | CorrectOffset | Called by CharFilter(s) and Tokenizer to correct token offset.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads a maximum of count characters from the current stream into buffer, beginning at index. (Inherited from StreamReader.)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

CharStream Class
Lucene.Net.Analysis Namespace


CharStream Constructor

[image]

Lucene.Net Class Libraries
CharStream Constructor
CharStream Class See Also Send Feedback
Initializes a new instance of the CharStream class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharStream(
    StreamReader reader
)
Visual Basic
Public Sub New ( _
    reader As StreamReader _
)
Visual C++
public:
CharStream(
    StreamReader^ reader
)

Parameters

reader
Type: System.IO..::..StreamReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.CharStream.#ctor(System.IO.StreamReader)"]

See Also

CharStream Class
Lucene.Net.Analysis Namespace


CharStream Methods

[image] [image]

Lucene.Net Class Libraries
CharStream Methods
CharStream Class See Also Send Feedback

The CharStream type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from StreamReader.)
Public method | CorrectOffset | Called by CharFilter(s) and Tokenizer to correct token offset.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads a maximum of count characters from the current stream into buffer, beginning at index. (Inherited from StreamReader.)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CharStream Class
Lucene.Net.Analysis Namespace


CorrectOffset Method

[image]

Lucene.Net Class Libraries
CharStream..::..CorrectOffset Method
CharStream Class See Also Send Feedback
Called by CharFilter(s) and Tokenizer to correct token offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int CorrectOffset(
    int currentOff
)
Visual Basic
Public MustOverride Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Visual C++
public:
virtual int CorrectOffset(
    int currentOff
) abstract

Parameters

currentOff
Type: System..::..Int32
offset as seen in the output

Return Value

corrected offset based on the input

See Also

CharStream Class
Lucene.Net.Analysis Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
CharStream..::..Dispose Method
CharStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)

See Also

CharStream Class
CharStream Members
Lucene.Net.Analysis Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
CharStream..::..MemberwiseClone Method
CharStream Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CharStream Class
CharStream Members
Lucene.Net.Analysis Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
CharStream..::..Read Method
CharStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads a maximum of count characters from the current stream into buffer, beginning at index. (Inherited from StreamReader.)

See Also

CharStream Class
CharStream Members
Lucene.Net.Analysis Namespace


CharStream Properties

[image] [image]

Lucene.Net Class Libraries
CharStream Properties
CharStream Class See Also Send Feedback

The CharStream type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

CharStream Class
Lucene.Net.Analysis Namespace


CharTokenizer Class

[image]

Lucene.Net Class Libraries
CharTokenizer Class
Members See Also Send Feedback
An abstract base class for simple, character-oriented tokenizers.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class CharTokenizer : Tokenizer
Visual Basic
Public MustInherit Class CharTokenizer _
    Inherits Tokenizer
Visual C++
public ref class CharTokenizer abstract : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis.Ext..::..LetterOrDigitTokenizer
Lucene.Net.Analysis..::..LetterTokenizer
Lucene.Net.Analysis.Ru..::..RussianLetterTokenizer
Lucene.Net.Analysis..::..WhitespaceTokenizer

See Also

CharTokenizer Members
Lucene.Net.Analysis Namespace


CharTokenizer Members

[image] [image]

Lucene.Net Class Libraries
CharTokenizer Members
CharTokenizer Class Constructors Methods Fields See Also Send Feedback

The CharTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | CharTokenizer(TextReader) | Initializes a new instance of the CharTokenizer class
Public method | CharTokenizer(AttributeSource, TextReader) | Initializes a new instance of the CharTokenizer class
Public method | CharTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Initializes a new instance of the CharTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method IsTokenChar
Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


CharTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
CharTokenizer Constructor
CharTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CharTokenizer(TextReader) | Initializes a new instance of the CharTokenizer class
Public method | CharTokenizer(AttributeSource, TextReader) | Initializes a new instance of the CharTokenizer class
Public method | CharTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Initializes a new instance of the CharTokenizer class

See Also

CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace


CharTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
CharTokenizer Constructor (TextReader)
CharTokenizer Class See Also Send Feedback
Initializes a new instance of the CharTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharTokenizer(
    TextReader input
)
Visual Basic
Public Sub New ( _
    input As TextReader _
)
Visual C++
public:
CharTokenizer(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.#ctor(System.IO.TextReader)"]

See Also

CharTokenizer Class
CharTokenizer Overload
Lucene.Net.Analysis Namespace


CharTokenizer Constructor (AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
CharTokenizer Constructor (AttributeSource, TextReader)
CharTokenizer Class See Also Send Feedback
Initializes a new instance of the CharTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharTokenizer(
    AttributeSource source,
    TextReader input
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader _
)
Visual C++
public:
CharTokenizer(
    AttributeSource^ source,
    TextReader^ input
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

CharTokenizer Class
CharTokenizer Overload
Lucene.Net.Analysis Namespace


CharTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
CharTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader)
CharTokenizer Class See Also Send Feedback
Initializes a new instance of the CharTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CharTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
Visual C++
public:
CharTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

CharTokenizer Class
CharTokenizer Overload
Lucene.Net.Analysis Namespace


CharTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
CharTokenizer Fields
CharTokenizer Class See Also Send Feedback

The CharTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


CharTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
CharTokenizer Methods
CharTokenizer Class See Also Send Feedback

The CharTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method IsTokenChar
Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
CharTokenizer..::..End Method
CharTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharTokenizer.End"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
CharTokenizer..::..IncrementToken Method
CharTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharTokenizer.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharTokenizer.IncrementToken"]

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


IsTokenChar Method

[image]

Lucene.Net Class Libraries
CharTokenizer..::..IsTokenChar Method
CharTokenizer Class See Also Send Feedback
Returns true iff a character should be included in a token. This tokenizer generates as tokens adjacent sequences of characters which satisfy this predicate. Characters for which this is false are used to define token boundaries and are not included in tokens.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract bool IsTokenChar(
    char c
)
Visual Basic
Protected Friend MustOverride Function IsTokenChar ( _
    c As Char _
) As Boolean
Visual C++
protected public:
virtual bool IsTokenChar(
    wchar_t c
) abstract

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.IsTokenChar(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharTokenizer.IsTokenChar(System.Char)"]

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
CharTokenizer..::..Next Method
CharTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace


Next Method

[image]

Lucene.Net Class Libraries
CharTokenizer..::..Next Method
CharTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Next"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Next"]

See Also

CharTokenizer Class
Next Overload
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
CharTokenizer..::..Next Method (Token)
CharTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Next(Lucene.Net.Analysis.Token)"]

See Also

CharTokenizer Class
Next Overload
Lucene.Net.Analysis Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
CharTokenizer..::..Normalize Method
CharTokenizer Class See Also Send Feedback
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual char Normalize(
    char c
)
Visual Basic
Protected Friend Overridable Function Normalize ( _
    c As Char _
) As Char
Visual C++
protected public:
virtual wchar_t Normalize(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Normalize(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Normalize(System.Char)"]

See Also

CharTokenizer Class
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
CharTokenizer..::..Reset Method
CharTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)

See Also

CharTokenizer Class
CharTokenizer Members
Lucene.Net.Analysis Namespace


Reset Method (TextReader)

[image]

Lucene.Net Class Libraries
CharTokenizer..::..Reset Method (TextReader)
CharTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Reset(System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset(
    TextReader input
)
Visual Basic
Public Overrides Sub Reset ( _
    input As TextReader _
)
Visual C++
public:
virtual void Reset(
    TextReader^ input
) override

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.CharTokenizer.Reset(System.IO.TextReader)"]

See Also

CharTokenizer Class
Reset Overload
Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Class

[image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter Class
Members See Also Send Feedback
A filter that replaces accented characters in the ISO Latin 1 character set (ISO-8859-1) by their unaccented equivalent. The case will not be altered.

For instance, 'À' will be replaced by 'a'.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("in favor of ASCIIFoldingFilter which covers a superset of Latin 1. This class will be removed in Lucene 3.0.")]
public class ISOLatin1AccentFilter : TokenFilter
Visual Basic
<ObsoleteAttribute("in favor of ASCIIFoldingFilter which covers a superset of Latin 1. This class will be removed in Lucene 3.0.")> _
Public Class ISOLatin1AccentFilter _
    Inherits TokenFilter
Visual C++
[ObsoleteAttribute(L"in favor of ASCIIFoldingFilter which covers a superset of Latin 1. This class will be removed in Lucene 3.0.")]
public ref class ISOLatin1AccentFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..ISOLatin1AccentFilter

See Also

ISOLatin1AccentFilter Members
Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Members

[image] [image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter Members
ISOLatin1AccentFilter Class Constructors Methods Fields See Also Send Feedback

The ISOLatin1AccentFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ISOLatin1AccentFilter | Initializes a new instance of the ISOLatin1AccentFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method RemoveAccents
To replace accented characters in a String by unaccented equivalents.
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Constructor

[image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter Constructor
ISOLatin1AccentFilter Class See Also Send Feedback
Initializes a new instance of the ISOLatin1AccentFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ISOLatin1AccentFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
ISOLatin1AccentFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Fields

[image] [image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter Fields
ISOLatin1AccentFilter Class See Also Send Feedback

The ISOLatin1AccentFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace


ISOLatin1AccentFilter Methods

[image] [image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter Methods
ISOLatin1AccentFilter Class See Also Send Feedback

The ISOLatin1AccentFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method RemoveAccents
To replace accented characters in a String by unaccented equivalents.
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter..::..IncrementToken Method
ISOLatin1AccentFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.IncrementToken"]

See Also

ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter..::..Next Method
ISOLatin1AccentFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

ISOLatin1AccentFilter Class
ISOLatin1AccentFilter Members
Lucene.Net.Analysis Namespace


Next Method

[image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter..::..Next Method
ISOLatin1AccentFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.Next"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.Next"]

See Also

ISOLatin1AccentFilter Class
Next Overload
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter..::..Next Method (Token)
ISOLatin1AccentFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

ISOLatin1AccentFilter Class
Next Overload
Lucene.Net.Analysis Namespace


RemoveAccents Method

[image]

Lucene.Net Class Libraries
ISOLatin1AccentFilter..::..RemoveAccents Method
ISOLatin1AccentFilter Class See Also Send Feedback
To replace accented characters in a String by unaccented equivalents.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void RemoveAccents(
    char[] input,
    int length
)
Visual Basic
Public Sub RemoveAccents ( _
    input As Char(), _
    length As Integer _
)
Visual C++
public:
void RemoveAccents(
    array<wchar_t>^ input,
    int length
)

Parameters

input
Type: array< System..::..Char >[]()[][]

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.RemoveAccents(System.Char[],System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.ISOLatin1AccentFilter.RemoveAccents(System.Char[],System.Int32)"]

See Also

ISOLatin1AccentFilter Class
Lucene.Net.Analysis Namespace


KeywordAnalyzer Class

[image]

Lucene.Net Class Libraries
KeywordAnalyzer Class
Members See Also Send Feedback
"Tokenizes" the entire stream as a single token. This is useful for data like zip codes, ids, and some product names.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class KeywordAnalyzer : Analyzer
Visual Basic
Public Class KeywordAnalyzer _
    Inherits Analyzer
Visual C++
public ref class KeywordAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis..::..KeywordAnalyzer

See Also

KeywordAnalyzer Members
Lucene.Net.Analysis Namespace


KeywordAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
KeywordAnalyzer Members
KeywordAnalyzer Class Constructors Methods Fields See Also Send Feedback

The KeywordAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | KeywordAnalyzer | Initializes a new instance of the KeywordAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

KeywordAnalyzer Class
Lucene.Net.Analysis Namespace


KeywordAnalyzer Constructor

[image]

Lucene.Net Class Libraries
KeywordAnalyzer Constructor
KeywordAnalyzer Class See Also Send Feedback
Initializes a new instance of the KeywordAnalyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public KeywordAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
KeywordAnalyzer()

See Also

KeywordAnalyzer Class
Lucene.Net.Analysis Namespace


KeywordAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
KeywordAnalyzer Fields
KeywordAnalyzer Class See Also Send Feedback

The KeywordAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

KeywordAnalyzer Class
Lucene.Net.Analysis Namespace


KeywordAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
KeywordAnalyzer Methods
KeywordAnalyzer Class See Also Send Feedback

The KeywordAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeywordAnalyzer Class
Lucene.Net.Analysis Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
KeywordAnalyzer..::..ReusableTokenStream Method
KeywordAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

KeywordAnalyzer Class
Lucene.Net.Analysis Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
KeywordAnalyzer..::..TokenStream Method
KeywordAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.KeywordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

KeywordAnalyzer Class
Lucene.Net.Analysis Namespace


KeywordTokenizer Class

[image]

Lucene.Net Class Libraries
KeywordTokenizer Class
Members See Also Send Feedback
Emits the entire input as a single token.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class KeywordTokenizer : Tokenizer
Visual Basic
Public Class KeywordTokenizer _
    Inherits Tokenizer
Visual C++
public ref class KeywordTokenizer : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..KeywordTokenizer

See Also

KeywordTokenizer Members
Lucene.Net.Analysis Namespace


KeywordTokenizer Members

[image] [image]

Lucene.Net Class Libraries
KeywordTokenizer Members
KeywordTokenizer Class Constructors Methods Fields See Also Send Feedback

The KeywordTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | KeywordTokenizer(TextReader) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource..::..AttributeFactory, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

KeywordTokenizer Class
Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
KeywordTokenizer Constructor
KeywordTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KeywordTokenizer(TextReader) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class
Public method | KeywordTokenizer(AttributeSource..::..AttributeFactory, TextReader, Int32) | Initializes a new instance of the KeywordTokenizer class

See Also

KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
KeywordTokenizer Constructor (TextReader)
KeywordTokenizer Class See Also Send Feedback
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public KeywordTokenizer(
    TextReader input
)
Visual Basic
Public Sub New ( _
    input As TextReader _
)
Visual C++
public:
KeywordTokenizer(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(System.IO.TextReader)"]

See Also

KeywordTokenizer Class
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor (TextReader, Int32)

[image]

Lucene.Net Class Libraries
KeywordTokenizer Constructor (TextReader, Int32)
KeywordTokenizer Class See Also Send Feedback
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public KeywordTokenizer(
    TextReader input,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    input As TextReader, _
    bufferSize As Integer _
)
Visual C++
public:
KeywordTokenizer(
    TextReader^ input,
    int bufferSize
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(System.IO.TextReader,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(System.IO.TextReader,System.Int32)"]

See Also

KeywordTokenizer Class
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor (AttributeSource, TextReader, Int32)

[image]

Lucene.Net Class Libraries
KeywordTokenizer Constructor (AttributeSource, TextReader, Int32)
KeywordTokenizer Class See Also Send Feedback
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public KeywordTokenizer(
    AttributeSource source,
    TextReader input,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    bufferSize As Integer _
)
Visual C++
public:
KeywordTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    int bufferSize
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32)"]

See Also

KeywordTokenizer Class
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace


KeywordTokenizer Constructor (AttributeSource.AttributeFactory, TextReader, Int32)

[image]

Lucene.Net Class Libraries
KeywordTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader, Int32)
KeywordTokenizer Class See Also Send Feedback
Initializes a new instance of the KeywordTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public KeywordTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    bufferSize As Integer _
)
Visual C++
public:
KeywordTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    int bufferSize
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32)"]

See Also

KeywordTokenizer Class
KeywordTokenizer Overload
Lucene.Net.Analysis Namespace


KeywordTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
KeywordTokenizer Fields
KeywordTokenizer Class See Also Send Feedback

The KeywordTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

KeywordTokenizer Class
Lucene.Net.Analysis Namespace


KeywordTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
KeywordTokenizer Methods
KeywordTokenizer Class See Also Send Feedback

The KeywordTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

KeywordTokenizer Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
KeywordTokenizer..::..End Method
KeywordTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.End"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

KeywordTokenizer Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
KeywordTokenizer..::..IncrementToken Method
KeywordTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.IncrementToken"]

See Also

KeywordTokenizer Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
KeywordTokenizer..::..Next Method
KeywordTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace


Next Method

[image]

Lucene.Net Class Libraries
KeywordTokenizer..::..Next Method
KeywordTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Next"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Next"]

See Also

KeywordTokenizer Class
Next Overload
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
KeywordTokenizer..::..Next Method (Token)
KeywordTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Next(Lucene.Net.Analysis.Token)"]

See Also

KeywordTokenizer Class
Next Overload
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
KeywordTokenizer..::..Reset Method
KeywordTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)

See Also

KeywordTokenizer Class
KeywordTokenizer Members
Lucene.Net.Analysis Namespace


Reset Method (TextReader)

[image]

Lucene.Net Class Libraries
KeywordTokenizer..::..Reset Method (TextReader)
KeywordTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Reset(System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset(
    TextReader input
)
Visual Basic
Public Overrides Sub Reset ( _
    input As TextReader _
)
Visual C++
public:
virtual void Reset(
    TextReader^ input
) override

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.KeywordTokenizer.Reset(System.IO.TextReader)"]

See Also

KeywordTokenizer Class
Reset Overload
Lucene.Net.Analysis Namespace


LengthFilter Class

[image]

Lucene.Net Class Libraries
LengthFilter Class
Members See Also Send Feedback
Removes words that are too long or too short from the stream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class LengthFilter : TokenFilter
Visual Basic
Public NotInheritable Class LengthFilter _
    Inherits TokenFilter
Visual C++
public ref class LengthFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..LengthFilter

See Also

LengthFilter Members
Lucene.Net.Analysis Namespace


LengthFilter Members

[image] [image]

Lucene.Net Class Libraries
LengthFilter Members
LengthFilter Class Constructors Methods Fields See Also Send Feedback

The LengthFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LengthFilter | Build a filter that removes words that are too long or too short from the text.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Returns the next input Token whose term() is the right len
(Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

LengthFilter Class
Lucene.Net.Analysis Namespace


LengthFilter Constructor

[image]

Lucene.Net Class Libraries
LengthFilter Constructor
LengthFilter Class See Also Send Feedback
Build a filter that removes words that are too long or too short from the text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LengthFilter(
    TokenStream in_Renamed,
    int min,
    int max
)
Visual Basic
Public Sub New ( _
    in_Renamed As TokenStream, _
    min As Integer, _
    max As Integer _
)
Visual C++
public:
LengthFilter(
    TokenStream^ in_Renamed,
    int min,
    int max
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LengthFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Int32,System.Int32)"]

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:Lucene.Net.Analysis.LengthFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:Lucene.Net.Analysis.LengthFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Int32,System.Int32)"]

See Also

LengthFilter Class
Lucene.Net.Analysis Namespace


LengthFilter Fields

[image] [image]

Lucene.Net Class Libraries
LengthFilter Fields
LengthFilter Class See Also Send Feedback

The LengthFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

LengthFilter Class
Lucene.Net.Analysis Namespace


LengthFilter Methods

[image] [image]

Lucene.Net Class Libraries
LengthFilter Methods
LengthFilter Class See Also Send Feedback

The LengthFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Returns the next input Token whose term() is the right len
(Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

LengthFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
LengthFilter..::..IncrementToken Method
LengthFilter Class See Also Send Feedback
Returns the next input Token whose term() is the right len

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.LengthFilter.IncrementToken"]

See Also

LengthFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
LengthFilter..::..Next Method
LengthFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

LengthFilter Class
LengthFilter Members
Lucene.Net.Analysis Namespace


LetterTokenizer Class

[image]

Lucene.Net Class Libraries
LetterTokenizer Class
Members See Also Send Feedback
A LetterTokenizer is a tokenizer that divides text at non-letters. That's to say, it defines tokens as maximal strings of adjacent letters, as defined by java.lang.Character.isLetter() predicate. Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class LetterTokenizer : CharTokenizer
Visual Basic
Public Class LetterTokenizer _
    Inherits CharTokenizer
Visual C++
public ref class LetterTokenizer : public CharTokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis..::..LetterTokenizer
Lucene.Net.Analysis.AR..::..ArabicLetterTokenizer
Lucene.Net.Analysis..::..LowerCaseTokenizer

See Also

LetterTokenizer Members
Lucene.Net.Analysis Namespace


LetterTokenizer Members

[image] [image]

Lucene.Net Class Libraries
LetterTokenizer Members
LetterTokenizer Class Constructors Methods Fields See Also Send Feedback

The LetterTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | LetterTokenizer(TextReader) | Construct a new LetterTokenizer.
Public method | LetterTokenizer(AttributeSource, TextReader) | Construct a new LetterTokenizer using a given {@link AttributeSource}.
Public method | LetterTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a new LetterTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which satisfy {@link Character#isLetter(char)}.
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

LetterTokenizer Class
Lucene.Net.Analysis Namespace


LetterTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
LetterTokenizer Constructor
LetterTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LetterTokenizer(TextReader) | Construct a new LetterTokenizer.
Public method | LetterTokenizer(AttributeSource, TextReader) | Construct a new LetterTokenizer using a given {@link AttributeSource}.
Public method | LetterTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a new LetterTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

See Also

LetterTokenizer Class
LetterTokenizer Members
Lucene.Net.Analysis Namespace


LetterTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
LetterTokenizer Constructor (TextReader)
LetterTokenizer Class See Also Send Feedback
Construct a new LetterTokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LetterTokenizer(
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TextReader _
)
Visual C++
public:
LetterTokenizer(
    TextReader^ in_Renamed
)

Parameters

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.#ctor(System.IO.TextReader)"]

See Also

LetterTokenizer Class
LetterTokenizer Overload
Lucene.Net.Analysis Namespace


LetterTokenizer Constructor (AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
LetterTokenizer Constructor (AttributeSource, TextReader)
LetterTokenizer Class See Also Send Feedback
Construct a new LetterTokenizer using a given {@link AttributeSource}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LetterTokenizer(
    AttributeSource source,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    in_Renamed As TextReader _
)
Visual C++
public:
LetterTokenizer(
    AttributeSource^ source,
    TextReader^ in_Renamed
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

LetterTokenizer Class
LetterTokenizer Overload
Lucene.Net.Analysis Namespace


LetterTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
LetterTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader)
LetterTokenizer Class See Also Send Feedback
Construct a new LetterTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LetterTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in_Renamed As TextReader _
)
Visual C++
public:
LetterTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in_Renamed
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

LetterTokenizer Class
LetterTokenizer Overload
Lucene.Net.Analysis Namespace


LetterTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
LetterTokenizer Fields
LetterTokenizer Class See Also Send Feedback

The LetterTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

LetterTokenizer Class
Lucene.Net.Analysis Namespace


LetterTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
LetterTokenizer Methods
LetterTokenizer Class See Also Send Feedback

The LetterTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which satisfy {@link Character#isLetter(char)}.
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

LetterTokenizer Class
Lucene.Net.Analysis Namespace


IsTokenChar Method

[image]

Lucene.Net Class Libraries
LetterTokenizer..::..IsTokenChar Method
LetterTokenizer Class See Also Send Feedback
Collects only characters which satisfy {@link Character#isLetter(char)}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override bool IsTokenChar(
    char c
)
Visual Basic
Protected Friend Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Visual C++
protected public:
virtual bool IsTokenChar(
    wchar_t c
) override

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.IsTokenChar(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.LetterTokenizer.IsTokenChar(System.Char)"]

See Also

LetterTokenizer Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
LetterTokenizer..::..Next Method
LetterTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)

See Also

LetterTokenizer Class
LetterTokenizer Members
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
LetterTokenizer..::..Reset Method
LetterTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)

See Also

LetterTokenizer Class
LetterTokenizer Members
Lucene.Net.Analysis Namespace


LowerCaseFilter Class

[image]

Lucene.Net Class Libraries
LowerCaseFilter Class
Members See Also Send Feedback
Normalizes token text to lower case.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class LowerCaseFilter : TokenFilter
Visual Basic
Public NotInheritable Class LowerCaseFilter _
    Inherits TokenFilter
Visual C++
public ref class LowerCaseFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..LowerCaseFilter

See Also

LowerCaseFilter Members
Lucene.Net.Analysis Namespace


LowerCaseFilter Members

[image] [image]

Lucene.Net Class Libraries
LowerCaseFilter Members
LowerCaseFilter Class Constructors Methods Fields See Also Send Feedback

The LowerCaseFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LowerCaseFilter | Initializes a new instance of the LowerCaseFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

LowerCaseFilter Class
Lucene.Net.Analysis Namespace


LowerCaseFilter Constructor

[image]

Lucene.Net Class Libraries
LowerCaseFilter Constructor
LowerCaseFilter Class See Also Send Feedback
Initializes a new instance of the LowerCaseFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LowerCaseFilter(
    TokenStream in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TokenStream _
)
Visual C++
public:
LowerCaseFilter(
    TokenStream^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LowerCaseFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

LowerCaseFilter Class
Lucene.Net.Analysis Namespace


LowerCaseFilter Fields

[image] [image]

Lucene.Net Class Libraries
LowerCaseFilter Fields
LowerCaseFilter Class See Also Send Feedback

The LowerCaseFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

LowerCaseFilter Class
Lucene.Net.Analysis Namespace


LowerCaseFilter Methods

[image] [image]

Lucene.Net Class Libraries
LowerCaseFilter Methods
LowerCaseFilter Class See Also Send Feedback

The LowerCaseFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

LowerCaseFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
LowerCaseFilter..::..IncrementToken Method
LowerCaseFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.LowerCaseFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.LowerCaseFilter.IncrementToken"]

See Also

LowerCaseFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
LowerCaseFilter..::..Next Method
LowerCaseFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

LowerCaseFilter Class
LowerCaseFilter Members
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Class

[image]

Lucene.Net Class Libraries
LowerCaseTokenizer Class
Members See Also Send Feedback
LowerCaseTokenizer performs the function of LetterTokenizer and LowerCaseFilter together. It divides text at non-letters and converts them to lower case. While it is functionally equivalent to the combination of LetterTokenizer and LowerCaseFilter, there is a performance advantage to doing the two tasks at once, hence this (redundant) implementation.

Note: this does a decent job for most European languages, but does a terrible job for some Asian languages, where words are not separated by spaces.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class LowerCaseTokenizer : LetterTokenizer
Visual Basic
Public NotInheritable Class LowerCaseTokenizer _
    Inherits LetterTokenizer
Visual C++
public ref class LowerCaseTokenizer sealed : public LetterTokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis..::..LetterTokenizer
Lucene.Net.Analysis..::..LowerCaseTokenizer

See Also

LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Members

[image] [image]

Lucene.Net Class Libraries
LowerCaseTokenizer Members
LowerCaseTokenizer Class Constructors Methods Fields See Also Send Feedback

The LowerCaseTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | LowerCaseTokenizer(TextReader) | Construct a new LowerCaseTokenizer.
Public method | LowerCaseTokenizer(AttributeSource, TextReader) | Construct a new LowerCaseTokenizer using a given {@link AttributeSource}.
Public method | LowerCaseTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a new LowerCaseTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which satisfy {@link Character#isLetter(char)}.
(Inherited from LetterTokenizer.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Converts char to lower case {@link Character#toLowerCase(char)}.
(Overrides CharTokenizer..::..Normalize(Char).)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
LowerCaseTokenizer Constructor
LowerCaseTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LowerCaseTokenizer(TextReader) | Construct a new LowerCaseTokenizer.
Public method | LowerCaseTokenizer(AttributeSource, TextReader) | Construct a new LowerCaseTokenizer using a given {@link AttributeSource}.
Public method | LowerCaseTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a new LowerCaseTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

See Also

LowerCaseTokenizer Class
LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
LowerCaseTokenizer Constructor (TextReader)
LowerCaseTokenizer Class See Also Send Feedback
Construct a new LowerCaseTokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LowerCaseTokenizer(
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TextReader _
)
Visual C++
public:
LowerCaseTokenizer(
    TextReader^ in_Renamed
)

Parameters

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.#ctor(System.IO.TextReader)"]

See Also

LowerCaseTokenizer Class
LowerCaseTokenizer Overload
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Constructor (AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
LowerCaseTokenizer Constructor (AttributeSource, TextReader)
LowerCaseTokenizer Class See Also Send Feedback
Construct a new LowerCaseTokenizer using a given {@link AttributeSource}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LowerCaseTokenizer(
    AttributeSource source,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    in_Renamed As TextReader _
)
Visual C++
public:
LowerCaseTokenizer(
    AttributeSource^ source,
    TextReader^ in_Renamed
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

LowerCaseTokenizer Class
LowerCaseTokenizer Overload
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
LowerCaseTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader)
LowerCaseTokenizer Class See Also Send Feedback
Construct a new LowerCaseTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LowerCaseTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in_Renamed As TextReader _
)
Visual C++
public:
LowerCaseTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in_Renamed
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

LowerCaseTokenizer Class
LowerCaseTokenizer Overload
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
LowerCaseTokenizer Fields
LowerCaseTokenizer Class See Also Send Feedback

The LowerCaseTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace


LowerCaseTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
LowerCaseTokenizer Methods
LowerCaseTokenizer Class See Also Send Feedback

The LowerCaseTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which satisfy {@link Character#isLetter(char)}.
(Inherited from LetterTokenizer.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Converts char to lower case {@link Character#toLowerCase(char)}.
(Overrides CharTokenizer..::..Normalize(Char).)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
LowerCaseTokenizer..::..Next Method
LowerCaseTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)

See Also

LowerCaseTokenizer Class
LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
LowerCaseTokenizer..::..Normalize Method
LowerCaseTokenizer Class See Also Send Feedback
Converts char to lower case {@link Character#toLowerCase(char)}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override char Normalize(
    char c
)
Visual Basic
Protected Friend Overrides Function Normalize ( _
    c As Char _
) As Char
Visual C++
protected public:
virtual wchar_t Normalize(
    wchar_t c
) override

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.Normalize(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.LowerCaseTokenizer.Normalize(System.Char)"]

See Also

LowerCaseTokenizer Class
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
LowerCaseTokenizer..::..Reset Method
LowerCaseTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)

See Also

LowerCaseTokenizer Class
LowerCaseTokenizer Members
Lucene.Net.Analysis Namespace


MappingCharFilter Class

[image]

Lucene.Net Class Libraries
MappingCharFilter Class
Members See Also Send Feedback
Simplistic {@link CharFilter} that applies the mappings contained in a {@link NormalizeCharMap} to the character stream, and correcting the resulting changes to the offsets.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MappingCharFilter : BaseCharFilter
Visual Basic
Public Class MappingCharFilter _
    Inherits BaseCharFilter
Visual C++
public ref class MappingCharFilter : public BaseCharFilter

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextReader
System.IO..::..StreamReader
Lucene.Net.Analysis..::..CharStream
Lucene.Net.Analysis..::..CharFilter
Lucene.Net.Analysis..::..BaseCharFilter
Lucene.Net.Analysis..::..MappingCharFilter

See Also

MappingCharFilter Members
Lucene.Net.Analysis Namespace


MappingCharFilter Members

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter Members
MappingCharFilter Class Constructors Methods Fields Properties See Also Send Feedback

The MappingCharFilter type exposes the following members.

Constructors

 | Name | Description
Public method | MappingCharFilter(NormalizeCharMap, CharStream) | Initializes a new instance of the MappingCharFilter class
Public method | MappingCharFilter(NormalizeCharMap, TextReader) | Initializes a new instance of the MappingCharFilter class

Methods

 | Name | Description
Protected method | AddOffCorrectMap | (Inherited from BaseCharFilter.)
Public method | Close | (Inherited from CharFilter.)
Public method | Correct | (Inherited from BaseCharFilter.)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLastCumulativeDiff | (Inherited from BaseCharFilter.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | (Overrides StreamReader..::..Read()()()().)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides CharFilter..::..Read(array<Char>[]()[][], Int32, Int32).)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | input | (Inherited from CharFilter.)

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

MappingCharFilter Class
Lucene.Net.Analysis Namespace


MappingCharFilter Constructor

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter Constructor
MappingCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MappingCharFilter(NormalizeCharMap, CharStream) | Initializes a new instance of the MappingCharFilter class
Public method | MappingCharFilter(NormalizeCharMap, TextReader) | Initializes a new instance of the MappingCharFilter class

See Also

MappingCharFilter Class
MappingCharFilter Members
Lucene.Net.Analysis Namespace


MappingCharFilter Constructor (NormalizeCharMap, CharStream)

[image]

Lucene.Net Class Libraries
MappingCharFilter Constructor (NormalizeCharMap, CharStream)
MappingCharFilter Class See Also Send Feedback
Initializes a new instance of the MappingCharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MappingCharFilter(
    NormalizeCharMap normMap,
    CharStream in_Renamed
)
Visual Basic
Public Sub New ( _
    normMap As NormalizeCharMap, _
    in_Renamed As CharStream _
)
Visual C++
public:
MappingCharFilter(
    NormalizeCharMap^ normMap,
    CharStream^ in_Renamed
)

Parameters

normMap
Type: Lucene.Net.Analysis..::..NormalizeCharMap

[Missing <param name="normMap"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.#ctor(Lucene.Net.Analysis.NormalizeCharMap,Lucene.Net.Analysis.CharStream)"]

in_Renamed
Type: Lucene.Net.Analysis..::..CharStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.#ctor(Lucene.Net.Analysis.NormalizeCharMap,Lucene.Net.Analysis.CharStream)"]

See Also

MappingCharFilter Class
MappingCharFilter Overload
Lucene.Net.Analysis Namespace


MappingCharFilter Constructor (NormalizeCharMap, TextReader)

[image]

Lucene.Net Class Libraries
MappingCharFilter Constructor (NormalizeCharMap, TextReader)
MappingCharFilter Class See Also Send Feedback
Initializes a new instance of the MappingCharFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MappingCharFilter(
    NormalizeCharMap normMap,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    normMap As NormalizeCharMap, _
    in_Renamed As TextReader _
)
Visual C++
public:
MappingCharFilter(
    NormalizeCharMap^ normMap,
    TextReader^ in_Renamed
)

Parameters

normMap
Type: Lucene.Net.Analysis..::..NormalizeCharMap

[Missing <param name="normMap"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.#ctor(Lucene.Net.Analysis.NormalizeCharMap,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.#ctor(Lucene.Net.Analysis.NormalizeCharMap,System.IO.TextReader)"]

See Also

MappingCharFilter Class
MappingCharFilter Overload
Lucene.Net.Analysis Namespace


MappingCharFilter Fields

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter Fields
MappingCharFilter Class See Also Send Feedback

The MappingCharFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | (Inherited from CharFilter.)

See Also

MappingCharFilter Class
Lucene.Net.Analysis Namespace


MappingCharFilter Methods

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter Methods
MappingCharFilter Class See Also Send Feedback

The MappingCharFilter type exposes the following members.

Methods

 | Name | Description
Protected method | AddOffCorrectMap | (Inherited from BaseCharFilter.)
Public method | Close | (Inherited from CharFilter.)
Public method | Correct | (Inherited from BaseCharFilter.)
Public method | CorrectOffset | Chains the corrected offset through the input CharFilter. (Inherited from CharFilter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Allows a StreamReader object to discard its current data. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLastCumulativeDiff | (Inherited from BaseCharFilter.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Mark | (Inherited from CharFilter.)
Public method | MarkSupported | (Inherited from CharFilter.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | (Overrides StreamReader..::..Read()()()().)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides CharFilter..::..Read(array<Char>[]()[][], Int32, Int32).)
Public method | ReadBlock | Reads a maximum of count characters from the current stream, and writes the data to buffer, beginning at index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | Reset | (Inherited from CharFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MappingCharFilter Class
Lucene.Net.Analysis Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter..::..Dispose Method
MappingCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)

See Also

MappingCharFilter Class
MappingCharFilter Members
Lucene.Net.Analysis Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter..::..MemberwiseClone Method
MappingCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MappingCharFilter Class
MappingCharFilter Members
Lucene.Net.Analysis Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter..::..Read Method
MappingCharFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | (Overrides StreamReader..::..Read()()()().)
Public method | Read(array<Char>[]()[][], Int32, Int32) | (Overrides CharFilter..::..Read(array<Char>[]()[][], Int32, Int32).)

See Also

MappingCharFilter Class
MappingCharFilter Members
Lucene.Net.Analysis Namespace


Read Method

[image]

Lucene.Net Class Libraries
MappingCharFilter..::..Read Method
MappingCharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Read()
Visual Basic
Public Overrides Function Read As Integer
Visual C++
public:
virtual int Read() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read"]

See Also

MappingCharFilter Class
Read Overload
Lucene.Net.Analysis Namespace


Read Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
MappingCharFilter..::..Read Method (array<Char>[]()[][], Int32, Int32)
MappingCharFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read(System.Char[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Read(
    char[] cbuf,
    int off,
    int len
)
Visual Basic
Public Overrides Function Read ( _
    cbuf As Char(), _
    off As Integer, _
    len As Integer _
) As Integer
Visual C++
public:
virtual int Read(
    array<wchar_t>^ cbuf,
    int off,
    int len
) override

Parameters

cbuf
Type: array< System..::..Char >[]()[][]

[Missing <param name="cbuf"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read(System.Char[],System.Int32,System.Int32)"]

off
Type: System..::..Int32

[Missing <param name="off"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.MappingCharFilter.Read(System.Char[],System.Int32,System.Int32)"]

See Also

MappingCharFilter Class
Read Overload
Lucene.Net.Analysis Namespace


MappingCharFilter Properties

[image] [image]

Lucene.Net Class Libraries
MappingCharFilter Properties
MappingCharFilter Class See Also Send Feedback

The MappingCharFilter type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current StreamReader object is using. (Inherited from StreamReader.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

MappingCharFilter Class
Lucene.Net.Analysis Namespace


NormalizeCharMap Class

[image]

Lucene.Net Class Libraries
NormalizeCharMap Class
Members See Also Send Feedback
Holds a map of String input to String output, to be used with {@link MappingCharFilter}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NormalizeCharMap
Visual Basic
Public Class NormalizeCharMap
Visual C++
public ref class NormalizeCharMap

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..NormalizeCharMap

See Also

NormalizeCharMap Members
Lucene.Net.Analysis Namespace


NormalizeCharMap Members

[image] [image]

Lucene.Net Class Libraries
NormalizeCharMap Members
NormalizeCharMap Class Constructors Methods See Also Send Feedback

The NormalizeCharMap type exposes the following members.

Constructors

 | Name | Description
Public method | NormalizeCharMap | Initializes a new instance of the NormalizeCharMap class

Methods

Name Description
Public method Add
Records a replacement to be applied to the inputs stream. Whenever
CopyC#
singleMatch
 occurs in the input, it will be replaced with
CopyC#
replacement
.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

NormalizeCharMap Class
Lucene.Net.Analysis Namespace


NormalizeCharMap Constructor

[image]

Lucene.Net Class Libraries
NormalizeCharMap Constructor
NormalizeCharMap Class See Also Send Feedback
Initializes a new instance of the NormalizeCharMap class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NormalizeCharMap()
Visual Basic
Public Sub New
Visual C++
public:
NormalizeCharMap()

See Also

NormalizeCharMap Class
Lucene.Net.Analysis Namespace


NormalizeCharMap Methods

[image] [image]

Lucene.Net Class Libraries
NormalizeCharMap Methods
NormalizeCharMap Class See Also Send Feedback

The NormalizeCharMap type exposes the following members.

Methods

Name Description
Public method Add
Records a replacement to be applied to the inputs stream. Whenever
CopyC#
singleMatch
 occurs in the input, it will be replaced with
CopyC#
replacement
.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

NormalizeCharMap Class
Lucene.Net.Analysis Namespace


Add Method

[image]

Lucene.Net Class Libraries
NormalizeCharMap..::..Add Method
NormalizeCharMap Class See Also Send Feedback
Records a replacement to be applied to the inputs stream. Whenever
CopyC#
singleMatch
 occurs in the input, it will be replaced with
CopyC#
replacement
.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    string singleMatch,
    string replacement
)
Visual Basic
Public Overridable Sub Add ( _
    singleMatch As String, _
    replacement As String _
)
Visual C++
public:
virtual void Add(
    String^ singleMatch,
    String^ replacement
)

Parameters

singleMatch
Type: System..::..String
input String to be replaced
replacement
Type: System..::..String
output String

See Also

NormalizeCharMap Class
Lucene.Net.Analysis Namespace


NumericTokenStream Class

[image]

Lucene.Net Class Libraries
NumericTokenStream Class
Members See Also Send Feedback
Expert: This class provides a {@link TokenStream} for indexing numeric values that can be used by {@link NumericRangeQuery} or {@link NumericRangeFilter}.

Note that for simple usage, {@link NumericField} is recommended. {@link NumericField} disables norms and term freqs, as they are not usually needed during searching. If you need to change these settings, you should use this class.

See {@link NumericField} for capabilities of fields indexed numerically.

Here's an example usage, for an

CopyC#
int
field:
             Field field = new Field(name, new NumericTokenStream(precisionStep).setIntValue(value));
             field.setOmitNorms(true);
             field.setOmitTermFreqAndPositions(true);
             document.add(field);

For optimal performance, re-use the TokenStream and Field instance for more than one document:

             NumericTokenStream stream = new NumericTokenStream(precisionStep);
             Field field = new Field(name, stream);
             field.setOmitNorms(true);
             field.setOmitTermFreqAndPositions(true);
             Document document = new Document();
             document.add(field);

             for(all documents) {
               stream.setIntValue(value)
               writer.addDocument(document);
             }

This stream is not intended to be used in analyzers; it's more for iterating the different precisions during indexing a specific numeric value.

NOTE: as token streams are only consumed once the document is added to the index, if you index more than one numeric field, use a separate

CopyC#
NumericTokenStream
instance for each.

See {@link NumericRangeQuery} for more details on the

CopyC#
precisionStep
parameter as well as how numeric fields work under the hood.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class NumericTokenStream : TokenStream
Visual Basic
Public NotInheritable Class NumericTokenStream _
    Inherits TokenStream
Visual C++
public ref class NumericTokenStream sealed : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..NumericTokenStream

See Also

NumericTokenStream Members
Lucene.Net.Analysis Namespace


NumericTokenStream Members

[image] [image]

Lucene.Net Class Libraries
NumericTokenStream Members
NumericTokenStream Class Constructors Methods Fields See Also Send Feedback

The NumericTokenStream type exposes the following members.

Constructors

Name Description
Public method NumericTokenStream()()()()
Creates a token stream for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method NumericTokenStream(Int32)
Creates a token stream for numeric values with the specified
CopyC#
precisionStep
. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method NumericTokenStream(AttributeSource, Int32)
Expert: Creates a token stream for numeric values with the specified
CopyC#
precisionStep
 using the given {@link AttributeSource}. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method NumericTokenStream(AttributeSource..::..AttributeFactory, Int32)
Expert: Creates a token stream for numeric values with the specified
CopyC#
precisionStep
 using the given {@link org.apache.lucene.util.AttributeSource.AttributeFactory}. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetDoubleValue
Initializes the token stream with the supplied
CopyC#
double
 value.
Public method SetFloatValue
Initializes the token stream with the supplied
CopyC#
float
 value.
Public method SetIntValue
Initializes the token stream with the supplied
CopyC#
int
 value.
Public method SetLongValue
Initializes the token stream with the supplied
CopyC#
long
 value.
Public method | ToString | (Overrides AttributeSource..::..ToString()()()().)

Fields

Name | Description
TOKEN_TYPE_FULL_PREC | The full precision token gets this token type assigned.
TOKEN_TYPE_LOWER_PREC | The lower precision tokens gets this token type assigned.

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


NumericTokenStream Constructor

[image] [image]

Lucene.Net Class Libraries
NumericTokenStream Constructor
NumericTokenStream Class See Also Send Feedback

Overload List

Name Description
Public method NumericTokenStream()()()()
Creates a token stream for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method NumericTokenStream(Int32)
Creates a token stream for numeric values with the specified
CopyC#
precisionStep
. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method NumericTokenStream(AttributeSource, Int32)
Expert: Creates a token stream for numeric values with the specified
CopyC#
precisionStep
 using the given {@link AttributeSource}. The stream is not yet initialized, before using set a value using the various set???Value() methods.
Public method NumericTokenStream(AttributeSource..::..AttributeFactory, Int32)
Expert: Creates a token stream for numeric values with the specified
CopyC#
precisionStep
 using the given {@link org.apache.lucene.util.AttributeSource.AttributeFactory}. The stream is not yet initialized, before using set a value using the various set???Value() methods.

See Also

NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace


NumericTokenStream Constructor

[image]

Lucene.Net Class Libraries
NumericTokenStream Constructor
NumericTokenStream Class See Also Send Feedback
Creates a token stream for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream()
Visual Basic
Public Sub New
Visual C++
public:
NumericTokenStream()

See Also

NumericTokenStream Class
NumericTokenStream Overload
Lucene.Net.Analysis Namespace


NumericTokenStream Constructor (Int32)

[image]

Lucene.Net Class Libraries
NumericTokenStream Constructor (Int32)
NumericTokenStream Class See Also Send Feedback
Creates a token stream for numeric values with the specified
CopyC#
precisionStep
. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream(
    int precisionStep
)
Visual Basic
Public Sub New ( _
    precisionStep As Integer _
)
Visual C++
public:
NumericTokenStream(
    int precisionStep
)

Parameters

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.#ctor(System.Int32)"]

See Also

NumericTokenStream Class
NumericTokenStream Overload
Lucene.Net.Analysis Namespace


NumericTokenStream Constructor (AttributeSource, Int32)

[image]

Lucene.Net Class Libraries
NumericTokenStream Constructor (AttributeSource, Int32)
NumericTokenStream Class See Also Send Feedback
Expert: Creates a token stream for numeric values with the specified
CopyC#
precisionStep
 using the given {@link AttributeSource}. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream(
    AttributeSource source,
    int precisionStep
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    precisionStep As Integer _
)
Visual C++
public:
NumericTokenStream(
    AttributeSource^ source,
    int precisionStep
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.#ctor(Lucene.Net.Util.AttributeSource,System.Int32)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.#ctor(Lucene.Net.Util.AttributeSource,System.Int32)"]

See Also

NumericTokenStream Class
NumericTokenStream Overload
Lucene.Net.Analysis Namespace


NumericTokenStream Constructor (AttributeSource.AttributeFactory, Int32)

[image]

Lucene.Net Class Libraries
NumericTokenStream Constructor (AttributeSource..::..AttributeFactory, Int32)
NumericTokenStream Class See Also Send Feedback
Expert: Creates a token stream for numeric values with the specified
CopyC#
precisionStep
 using the given {@link org.apache.lucene.util.AttributeSource.AttributeFactory}. The stream is not yet initialized, before using set a value using the various set???Value() methods.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream(
    AttributeSource..::..AttributeFactory factory,
    int precisionStep
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    precisionStep As Integer _
)
Visual C++
public:
NumericTokenStream(
    AttributeSource..::..AttributeFactory^ factory,
    int precisionStep
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.Int32)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.Int32)"]

See Also

NumericTokenStream Class
NumericTokenStream Overload
Lucene.Net.Analysis Namespace


NumericTokenStream Fields

[image] [image]

Lucene.Net Class Libraries
NumericTokenStream Fields
NumericTokenStream Class See Also Send Feedback

The NumericTokenStream type exposes the following members.

Fields

Name | Description
TOKEN_TYPE_FULL_PREC | The full precision token gets this token type assigned.
TOKEN_TYPE_LOWER_PREC | The lower precision tokens gets this token type assigned.

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


TOKEN_TYPE_FULL_PREC Field

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..TOKEN_TYPE_FULL_PREC Field
NumericTokenStream Class See Also Send Feedback
The full precision token gets this token type assigned.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string TOKEN_TYPE_FULL_PREC
Visual Basic
Public Const TOKEN_TYPE_FULL_PREC As String
Visual C++
public:
literal String^ TOKEN_TYPE_FULL_PREC

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


TOKEN_TYPE_LOWER_PREC Field

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..TOKEN_TYPE_LOWER_PREC Field
NumericTokenStream Class See Also Send Feedback
The lower precision tokens gets this token type assigned.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string TOKEN_TYPE_LOWER_PREC
Visual Basic
Public Const TOKEN_TYPE_LOWER_PREC As String
Visual C++
public:
literal String^ TOKEN_TYPE_LOWER_PREC

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


NumericTokenStream Methods

[image] [image]

Lucene.Net Class Libraries
NumericTokenStream Methods
NumericTokenStream Class See Also Send Feedback

The NumericTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetDoubleValue
Initializes the token stream with the supplied
CopyC#
double
 value.
Public method SetFloatValue
Initializes the token stream with the supplied
CopyC#
float
 value.
Public method SetIntValue
Initializes the token stream with the supplied
CopyC#
int
 value.
Public method SetLongValue
Initializes the token stream with the supplied
CopyC#
long
 value.
Public method | ToString | (Overrides AttributeSource..::..ToString()()()().)

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..IncrementToken Method
NumericTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.IncrementToken"]

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
NumericTokenStream..::..Next Method
NumericTokenStream Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

NumericTokenStream Class
NumericTokenStream Members
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..Reset Method
NumericTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.Reset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


SetDoubleValue Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..SetDoubleValue Method
NumericTokenStream Class See Also Send Feedback
Initializes the token stream with the supplied
CopyC#
double
 value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream SetDoubleValue(
    double value_Renamed
)
Visual Basic
Public Function SetDoubleValue ( _
    value_Renamed As Double _
) As NumericTokenStream
Visual C++
public:
NumericTokenStream^ SetDoubleValue(
    double value_Renamed
)

Parameters

value_Renamed
Type: System..::..Double

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.SetDoubleValue(System.Double)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
new Field(name, new NumericTokenStream(precisionStep).SetDoubleValue(value))

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


SetFloatValue Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..SetFloatValue Method
NumericTokenStream Class See Also Send Feedback
Initializes the token stream with the supplied
CopyC#
float
 value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream SetFloatValue(
    float value_Renamed
)
Visual Basic
Public Function SetFloatValue ( _
    value_Renamed As Single _
) As NumericTokenStream
Visual C++
public:
NumericTokenStream^ SetFloatValue(
    float value_Renamed
)

Parameters

value_Renamed
Type: System..::..Single

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.SetFloatValue(System.Single)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
new Field(name, new NumericTokenStream(precisionStep).SetFloatValue(value))

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


SetIntValue Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..SetIntValue Method
NumericTokenStream Class See Also Send Feedback
Initializes the token stream with the supplied
CopyC#
int
 value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream SetIntValue(
    int value_Renamed
)
Visual Basic
Public Function SetIntValue ( _
    value_Renamed As Integer _
) As NumericTokenStream
Visual C++
public:
NumericTokenStream^ SetIntValue(
    int value_Renamed
)

Parameters

value_Renamed
Type: System..::..Int32

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.SetIntValue(System.Int32)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
new Field(name, new NumericTokenStream(precisionStep).SetIntValue(value))

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


SetLongValue Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..SetLongValue Method
NumericTokenStream Class See Also Send Feedback
Initializes the token stream with the supplied
CopyC#
long
 value.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericTokenStream SetLongValue(
    long value_Renamed
)
Visual Basic
Public Function SetLongValue ( _
    value_Renamed As Long _
) As NumericTokenStream
Visual C++
public:
NumericTokenStream^ SetLongValue(
    long long value_Renamed
)

Parameters

value_Renamed
Type: System..::..Int64

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.SetLongValue(System.Int64)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
new Field(name, new NumericTokenStream(precisionStep).SetLongValue(value))

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


ToString Method

[image]

Lucene.Net Class Libraries
NumericTokenStream..::..ToString Method
NumericTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.ToString"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NumericTokenStream.ToString"]

See Also

NumericTokenStream Class
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Class

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Class
Members See Also Send Feedback
This analyzer is used to facilitate scenarios where different fields require different analysis techniques. Use {@link #addAnalyzer} to add a non-default analyzer on a field name basis.

Example usage:

            PerFieldAnalyzerWrapper aWrapper =
            new PerFieldAnalyzerWrapper(new StandardAnalyzer());
            aWrapper.addAnalyzer("firstname", new KeywordAnalyzer());
            aWrapper.addAnalyzer("lastname", new KeywordAnalyzer());

In this example, StandardAnalyzer will be used for all fields except "firstname" and "lastname", for which KeywordAnalyzer will be used.

A PerFieldAnalyzerWrapper can be used like any other analyzer, for both indexing and query parsing.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PerFieldAnalyzerWrapper : Analyzer
Visual Basic
Public Class PerFieldAnalyzerWrapper _
    Inherits Analyzer
Visual C++
public ref class PerFieldAnalyzerWrapper : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis..::..PerFieldAnalyzerWrapper

See Also

PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Members

[image] [image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Members
PerFieldAnalyzerWrapper Class Constructors Methods Fields See Also Send Feedback

The PerFieldAnalyzerWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | PerFieldAnalyzerWrapper(Analyzer) | Constructs with default analyzer.
Public method | PerFieldAnalyzerWrapper(Analyzer, IDictionary) | Constructs with default analyzer and a map of analyzers to use for specific fields.

Methods

 | Name | Description
Public method | AddAnalyzer | Defines an analyzer to use for the specified field.
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Return the offsetGap from the analyzer assigned to field (Overrides Analyzer..::..GetOffsetGap(Fieldable).)
Public method | GetPositionIncrementGap | Return the positionIncrementGap from the analyzer assigned to fieldName (Overrides Analyzer..::..GetPositionIncrementGap(String).)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Constructor

[image] [image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Constructor
PerFieldAnalyzerWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerFieldAnalyzerWrapper(Analyzer) | Constructs with default analyzer.
Public method | PerFieldAnalyzerWrapper(Analyzer, IDictionary) | Constructs with default analyzer and a map of analyzers to use for specific fields.

See Also

PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Members
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Constructor (Analyzer)

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Constructor (Analyzer)
PerFieldAnalyzerWrapper Class See Also Send Feedback
Constructs with default analyzer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PerFieldAnalyzerWrapper(
    Analyzer defaultAnalyzer
)
Visual Basic
Public Sub New ( _
    defaultAnalyzer As Analyzer _
)
Visual C++
public:
PerFieldAnalyzerWrapper(
    Analyzer^ defaultAnalyzer
)

Parameters

defaultAnalyzer
Type: Lucene.Net.Analysis..::..Analyzer
Any fields not specifically defined to use a different analyzer will use the one provided here.

See Also

PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Overload
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Constructor (Analyzer, IDictionary)

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Constructor (Analyzer, IDictionary)
PerFieldAnalyzerWrapper Class See Also Send Feedback
Constructs with default analyzer and a map of analyzers to use for specific fields.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PerFieldAnalyzerWrapper(
    Analyzer defaultAnalyzer,
    IDictionary fieldAnalyzers
)
Visual Basic
Public Sub New ( _
    defaultAnalyzer As Analyzer, _
    fieldAnalyzers As IDictionary _
)
Visual C++
public:
PerFieldAnalyzerWrapper(
    Analyzer^ defaultAnalyzer,
    IDictionary^ fieldAnalyzers
)

Parameters

defaultAnalyzer
Type: Lucene.Net.Analysis..::..Analyzer
Any fields not specifically defined to use a different analyzer will use the one provided here.
fieldAnalyzers
Type: System.Collections..::..IDictionary
a Map (String field name to the Analyzer) to be used for those fields

See Also

PerFieldAnalyzerWrapper Class
PerFieldAnalyzerWrapper Overload
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Fields

[image] [image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Fields
PerFieldAnalyzerWrapper Class See Also Send Feedback

The PerFieldAnalyzerWrapper type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


PerFieldAnalyzerWrapper Methods

[image] [image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper Methods
PerFieldAnalyzerWrapper Class See Also Send Feedback

The PerFieldAnalyzerWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AddAnalyzer | Defines an analyzer to use for the specified field.
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Return the offsetGap from the analyzer assigned to field (Overrides Analyzer..::..GetOffsetGap(Fieldable).)
Public method | GetPositionIncrementGap | Return the positionIncrementGap from the analyzer assigned to fieldName (Overrides Analyzer..::..GetPositionIncrementGap(String).)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


AddAnalyzer Method

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper..::..AddAnalyzer Method
PerFieldAnalyzerWrapper Class See Also Send Feedback
Defines an analyzer to use for the specified field.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddAnalyzer(
    string fieldName,
    Analyzer analyzer
)
Visual Basic
Public Overridable Sub AddAnalyzer ( _
    fieldName As String, _
    analyzer As Analyzer _
)
Visual C++
public:
virtual void AddAnalyzer(
    String^ fieldName,
    Analyzer^ analyzer
)

Parameters

fieldName
Type: System..::..String
field name requiring a non-default analyzer
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
non-default analyzer to use for field

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


GetOffsetGap Method

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper..::..GetOffsetGap Method
PerFieldAnalyzerWrapper Class See Also Send Feedback
Return the offsetGap from the analyzer assigned to field

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetOffsetGap(
    Fieldable field
)
Visual Basic
Public Overrides Function GetOffsetGap ( _
    field As Fieldable _
) As Integer
Visual C++
public:
virtual int GetOffsetGap(
    Fieldable^ field
) override

Parameters

field
Type: Lucene.Net.Documents..::..Fieldable

[Missing <param name="field"/> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.GetOffsetGap(Lucene.Net.Documents.Fieldable)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.GetOffsetGap(Lucene.Net.Documents.Fieldable)"]

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


GetPositionIncrementGap Method

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper..::..GetPositionIncrementGap Method
PerFieldAnalyzerWrapper Class See Also Send Feedback
Return the positionIncrementGap from the analyzer assigned to fieldName

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetPositionIncrementGap(
    string fieldName
)
Visual Basic
Public Overrides Function GetPositionIncrementGap ( _
    fieldName As String _
) As Integer
Visual C++
public:
virtual int GetPositionIncrementGap(
    String^ fieldName
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.GetPositionIncrementGap(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.GetPositionIncrementGap(System.String)"]

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper..::..ReusableTokenStream Method
PerFieldAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper..::..TokenStream Method
PerFieldAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


ToString Method

[image]

Lucene.Net Class Libraries
PerFieldAnalyzerWrapper..::..ToString Method
PerFieldAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.ToString"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.PerFieldAnalyzerWrapper.ToString"]

See Also

PerFieldAnalyzerWrapper Class
Lucene.Net.Analysis Namespace


PorterStemFilter Class

[image]

Lucene.Net Class Libraries
PorterStemFilter Class
Members See Also Send Feedback
Transforms the token stream as per the Porter stemming algorithm. Note: the input to the stemming filter must already be in lower case, so you will need to use LowerCaseFilter or LowerCaseTokenizer farther down the Tokenizer chain in order for this to work properly!

To use this filter with other analyzers, you'll want to write an Analyzer class that sets up the TokenStream chain as you want it. To use this with LowerCaseTokenizer, for example, you'd write an analyzer like this:

class MyAnalyzer extends Analyzer {
public final TokenStream tokenStream(String fieldName, Reader reader) {
return new PorterStemFilter(new LowerCaseTokenizer(reader));
}
}

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class PorterStemFilter : TokenFilter
Visual Basic
Public NotInheritable Class PorterStemFilter _
    Inherits TokenFilter
Visual C++
public ref class PorterStemFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..PorterStemFilter

See Also

PorterStemFilter Members
Lucene.Net.Analysis Namespace


PorterStemFilter Members

[image] [image]

Lucene.Net Class Libraries
PorterStemFilter Members
PorterStemFilter Class Constructors Methods Fields See Also Send Feedback

The PorterStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PorterStemFilter | Initializes a new instance of the PorterStemFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

PorterStemFilter Class
Lucene.Net.Analysis Namespace


PorterStemFilter Constructor

[image]

Lucene.Net Class Libraries
PorterStemFilter Constructor
PorterStemFilter Class See Also Send Feedback
Initializes a new instance of the PorterStemFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PorterStemFilter(
    TokenStream in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TokenStream _
)
Visual C++
public:
PorterStemFilter(
    TokenStream^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.PorterStemFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

PorterStemFilter Class
Lucene.Net.Analysis Namespace


PorterStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
PorterStemFilter Fields
PorterStemFilter Class See Also Send Feedback

The PorterStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

PorterStemFilter Class
Lucene.Net.Analysis Namespace


PorterStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
PorterStemFilter Methods
PorterStemFilter Class See Also Send Feedback

The PorterStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

PorterStemFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
PorterStemFilter..::..IncrementToken Method
PorterStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.PorterStemFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.PorterStemFilter.IncrementToken"]

See Also

PorterStemFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
PorterStemFilter..::..Next Method
PorterStemFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

PorterStemFilter Class
PorterStemFilter Members
Lucene.Net.Analysis Namespace


SimpleAnalyzer Class

[image]

Lucene.Net Class Libraries
SimpleAnalyzer Class
Members See Also Send Feedback
An {@link Analyzer} that filters {@link LetterTokenizer} with {@link LowerCaseFilter}

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class SimpleAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class SimpleAnalyzer _
    Inherits Analyzer
Visual C++
public ref class SimpleAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis..::..SimpleAnalyzer

See Also

SimpleAnalyzer Members
Lucene.Net.Analysis Namespace


SimpleAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
SimpleAnalyzer Members
SimpleAnalyzer Class Constructors Methods Fields See Also Send Feedback

The SimpleAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleAnalyzer | Initializes a new instance of the SimpleAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

SimpleAnalyzer Class
Lucene.Net.Analysis Namespace


SimpleAnalyzer Constructor

[image]

Lucene.Net Class Libraries
SimpleAnalyzer Constructor
SimpleAnalyzer Class See Also Send Feedback
Initializes a new instance of the SimpleAnalyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
SimpleAnalyzer()

See Also

SimpleAnalyzer Class
Lucene.Net.Analysis Namespace


SimpleAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
SimpleAnalyzer Fields
SimpleAnalyzer Class See Also Send Feedback

The SimpleAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

SimpleAnalyzer Class
Lucene.Net.Analysis Namespace


SimpleAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
SimpleAnalyzer Methods
SimpleAnalyzer Class See Also Send Feedback

The SimpleAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleAnalyzer Class
Lucene.Net.Analysis Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
SimpleAnalyzer..::..ReusableTokenStream Method
SimpleAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

SimpleAnalyzer Class
Lucene.Net.Analysis Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
SimpleAnalyzer..::..TokenStream Method
SimpleAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.SimpleAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

SimpleAnalyzer Class
Lucene.Net.Analysis Namespace


SinkTokenizer Class

[image]

Lucene.Net Class Libraries
SinkTokenizer Class
Members See Also Send Feedback
A SinkTokenizer can be used to cache Tokens for use in an Analyzer

WARNING: {@link TeeTokenFilter} and {@link SinkTokenizer} only work with the old TokenStream API. If you switch to the new API, you need to use {@link TeeSinkTokenFilter} instead, which offers the same functionality.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use TeeSinkTokenFilter instead")]
public class SinkTokenizer : Tokenizer
Visual Basic
<ObsoleteAttribute("Use TeeSinkTokenFilter instead")> _
Public Class SinkTokenizer _
    Inherits Tokenizer
Visual C++
[ObsoleteAttribute(L"Use TeeSinkTokenFilter instead")]
public ref class SinkTokenizer : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..SinkTokenizer

See Also

SinkTokenizer Members
Lucene.Net.Analysis Namespace
Lucene.Net.Analysis..::..TeeTokenFilter


SinkTokenizer Members

[image] [image]

Lucene.Net Class Libraries
SinkTokenizer Members
SinkTokenizer Class Constructors Methods Fields See Also Send Feedback

The SinkTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | SinkTokenizer()()()() | Initializes a new instance of the SinkTokenizer class
Public method | SinkTokenizer(IList) | Initializes a new instance of the SinkTokenizer class
Public method | SinkTokenizer(Int32) | Initializes a new instance of the SinkTokenizer class

Methods

Name | Description
Public method Add
Override this method to cache only certain tokens, or new tokens based on the old tokens.
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Overrides Tokenizer..::..Close()()()().)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetTokens
Get the tokens in the internal List.

WARNING: Adding tokens to this list requires the {@link #Reset()} method to be called in order for them to be made available. Also, this Tokenizer does nothing to protect against {@link java.util.ConcurrentModificationException}s in the case of adds happening while {@link #Next(Lucene.Net.Analysis.Token)} is being called.

WARNING: Since this SinkTokenizer can be reset and the cached tokens made available again, do not modify them. Modify clones instead.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token out of the list of cached tokens
(Overrides TokenStream..::..Next(Token).)
Public method Reset()()()()
Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}
(Overrides TokenStream..::..Reset()()()().)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Protected field | iter |
Protected field | lst |

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


SinkTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
SinkTokenizer Constructor
SinkTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SinkTokenizer()()()() | Initializes a new instance of the SinkTokenizer class
Public method | SinkTokenizer(IList) | Initializes a new instance of the SinkTokenizer class
Public method | SinkTokenizer(Int32) | Initializes a new instance of the SinkTokenizer class

See Also

SinkTokenizer Class
SinkTokenizer Members
Lucene.Net.Analysis Namespace


SinkTokenizer Constructor

[image]

Lucene.Net Class Libraries
SinkTokenizer Constructor
SinkTokenizer Class See Also Send Feedback
Initializes a new instance of the SinkTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SinkTokenizer()
Visual Basic
Public Sub New
Visual C++
public:
SinkTokenizer()

See Also

SinkTokenizer Class
SinkTokenizer Overload
Lucene.Net.Analysis Namespace


SinkTokenizer Constructor (IList)

[image]

Lucene.Net Class Libraries
SinkTokenizer Constructor (IList)
SinkTokenizer Class See Also Send Feedback
Initializes a new instance of the SinkTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SinkTokenizer(
    IList input
)
Visual Basic
Public Sub New ( _
    input As IList _
)
Visual C++
public:
SinkTokenizer(
    IList^ input
)

Parameters

input
Type: System.Collections..::..IList

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.SinkTokenizer.#ctor(System.Collections.IList)"]

See Also

SinkTokenizer Class
SinkTokenizer Overload
Lucene.Net.Analysis Namespace


SinkTokenizer Constructor (Int32)

[image]

Lucene.Net Class Libraries
SinkTokenizer Constructor (Int32)
SinkTokenizer Class See Also Send Feedback
Initializes a new instance of the SinkTokenizer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SinkTokenizer(
    int initCap
)
Visual Basic
Public Sub New ( _
    initCap As Integer _
)
Visual C++
public:
SinkTokenizer(
    int initCap
)

Parameters

initCap
Type: System..::..Int32

[Missing <param name="initCap"/> documentation for "M:Lucene.Net.Analysis.SinkTokenizer.#ctor(System.Int32)"]

See Also

SinkTokenizer Class
SinkTokenizer Overload
Lucene.Net.Analysis Namespace


SinkTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
SinkTokenizer Fields
SinkTokenizer Class See Also Send Feedback

The SinkTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
Protected field | iter |
Protected field | lst |

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


iter Field

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..iter Field
SinkTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.SinkTokenizer.iter"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IEnumerator iter
Visual Basic
Protected Friend iter As IEnumerator
Visual C++
protected public:
IEnumerator^ iter

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


lst Field

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..lst Field
SinkTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.SinkTokenizer.lst"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IList lst
Visual Basic
Protected Friend lst As IList
Visual C++
protected public:
IList^ lst

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


SinkTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
SinkTokenizer Methods
SinkTokenizer Class See Also Send Feedback

The SinkTokenizer type exposes the following members.

Methods

Name | Description
Public method Add
Override this method to cache only certain tokens, or new tokens based on the old tokens.
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Overrides Tokenizer..::..Close()()()().)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetTokens
Get the tokens in the internal List.

WARNING: Adding tokens to this list requires the {@link #Reset()} method to be called in order for them to be made available. Also, this Tokenizer does nothing to protect against {@link java.util.ConcurrentModificationException}s in the case of adds happening while {@link #Next(Lucene.Net.Analysis.Token)} is being called.

WARNING: Since this SinkTokenizer can be reset and the cached tokens made available again, do not modify them. Modify clones instead.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token out of the list of cached tokens
(Overrides TokenStream..::..Next(Token).)
Public method Reset()()()()
Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}
(Overrides TokenStream..::..Reset()()()().)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


Add Method

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..Add Method
SinkTokenizer Class See Also Send Feedback
Override this method to cache only certain tokens, or new tokens based on the old tokens.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Token t
)
Visual Basic
Public Overridable Sub Add ( _
    t As Token _
)
Visual C++
public:
virtual void Add(
    Token^ t
)

Parameters

t
Type: Lucene.Net.Analysis..::..Token
The {@link Lucene.Net.Analysis.Token} to add to the sink

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..Close Method
SinkTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.SinkTokenizer.Close"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


GetTokens Method

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..GetTokens Method
SinkTokenizer Class See Also Send Feedback
Get the tokens in the internal List.

WARNING: Adding tokens to this list requires the {@link #Reset()} method to be called in order for them to be made available. Also, this Tokenizer does nothing to protect against {@link java.util.ConcurrentModificationException}s in the case of adds happening while {@link #Next(Lucene.Net.Analysis.Token)} is being called.

WARNING: Since this SinkTokenizer can be reset and the cached tokens made available again, do not modify them. Modify clones instead.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList GetTokens()
Visual Basic
Public Overridable Function GetTokens As IList
Visual C++
public:
virtual IList^ GetTokens()

Return Value

A List of {@link Lucene.Net.Analysis.Token}s

See Also

SinkTokenizer Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
SinkTokenizer..::..Next Method
SinkTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. Returns the next {@link Token} in the stream, or null at EOS. (Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. Returns the next token out of the list of cached tokens (Overrides TokenStream..::..Next(Token).)

See Also

SinkTokenizer Class
SinkTokenizer Members
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..Next Method (Token)
SinkTokenizer Class See Also Send Feedback
Returns the next token out of the list of cached tokens

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Analysis.TokenStream.Next(Lucene.Net.Analysis.Token)")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Analysis.TokenStream.Next(Lucene.Net.Analysis.Token)")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Analysis.TokenStream.Next(Lucene.Net.Analysis.Token)")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.SinkTokenizer.Next(Lucene.Net.Analysis.Token)"]

Return Value

The next {@link Lucene.Net.Analysis.Token} in the Sink.

See Also

SinkTokenizer Class
Next Overload
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
SinkTokenizer..::..Reset Method
SinkTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reset()()()() | Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)} (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer. (Inherited from Tokenizer.)

See Also

SinkTokenizer Class
SinkTokenizer Members
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
SinkTokenizer..::..Reset Method
SinkTokenizer Class See Also Send Feedback
Reset the internal data structures to the start at the front of the list of tokens. Should be called if tokens were added to the list after an invocation of {@link #Next(Token)}

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

SinkTokenizer Class
Reset Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Class

[image]

Lucene.Net Class Libraries
StopAnalyzer Class
Members See Also Send Feedback
Filters {@link LetterTokenizer} with {@link LowerCaseFilter} and {@link StopFilter}.

You must specify the required {@link Version} compatibility when creating StopAnalyzer:

  • As of 2.9, position increments are preserved

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StopAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class StopAnalyzer _
    Inherits Analyzer
Visual C++
public ref class StopAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis..::..StopAnalyzer

See Also

StopAnalyzer Members
Lucene.Net.Analysis Namespace


StopAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
StopAnalyzer Members
StopAnalyzer Class Constructors Methods Fields See Also Send Feedback

The StopAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | StopAnalyzer()()()() | Obsolete. Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Boolean) | Obsolete. Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Hashtable) | Obsolete. Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(FileInfo) | Obsolete. Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(TextReader) | Obsolete. Builds an analyzer with the stop words from the given reader.
Public method | StopAnalyzer(array<String>[]()[][]) | Obsolete. Builds an analyzer which removes words in the provided array.
Public method | StopAnalyzer(Version) | Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Hashtable, Boolean) | Obsolete. Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(FileInfo, Boolean) | Obsolete. Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(TextReader, Boolean) | Obsolete. Builds an analyzer with the stop words from the given reader.
Public method | StopAnalyzer(array<String>[]()[][], Boolean) | Obsolete. Builds an analyzer which removes words in the provided array.
Public method | StopAnalyzer(Version, Hashtable) | Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Filters LowerCaseTokenizer with StopFilter. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | ENGLISH_STOP_WORDS | Obsolete. An array containing some common English words that are not usually useful for searching.
 | ENGLISH_STOP_WORDS_SET | An unmodifiable set containing some common English words that are not usually useful for searching.
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
StopAnalyzer Constructor
StopAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StopAnalyzer()()()() | Obsolete. Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Boolean) | Obsolete. Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Hashtable) | Obsolete. Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(FileInfo) | Obsolete. Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(TextReader) | Obsolete. Builds an analyzer with the stop words from the given reader.
Public method | StopAnalyzer(array<String>[]()[][]) | Obsolete. Builds an analyzer which removes words in the provided array.
Public method | StopAnalyzer(Version) | Builds an analyzer which removes words in ENGLISH_STOP_WORDS.
Public method | StopAnalyzer(Hashtable, Boolean) | Obsolete. Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(FileInfo, Boolean) | Obsolete. Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(TextReader, Boolean) | Obsolete. Builds an analyzer with the stop words from the given reader.
Public method | StopAnalyzer(array<String>[]()[][], Boolean) | Obsolete. Builds an analyzer which removes words in the provided array.
Public method | StopAnalyzer(Version, Hashtable) | Builds an analyzer with the stop words from the given set.
Public method | StopAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StopAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.

See Also

StopAnalyzer Class
StopAnalyzer Members
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor
StopAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version) instead")]
public StopAnalyzer()
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version) instead")> _
Public Sub New
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version) instead")]
public:
StopAnalyzer()

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (Boolean)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Boolean)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version) instead")]
public StopAnalyzer(
    bool enablePositionIncrements
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version) instead")> _
Public Sub New ( _
    enablePositionIncrements As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version) instead")]
public:
StopAnalyzer(
    bool enablePositionIncrements
)

Parameters

enablePositionIncrements
Type: System..::..Boolean
See {@link StopFilter#SetEnablePositionIncrements}

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Hashtable)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, Set) instead")]
public StopAnalyzer(
    Hashtable stopWords
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, Set) instead")> _
Public Sub New ( _
    stopWords As Hashtable _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, Set) instead")]
public:
StopAnalyzer(
    Hashtable^ stopWords
)

Parameters

stopWords
Type: System.Collections..::..Hashtable

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (FileInfo)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, File) instead")]
public StopAnalyzer(
    FileInfo stopwordsFile
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, File) instead")> _
Public Sub New ( _
    stopwordsFile As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, File) instead")]
public:
StopAnalyzer(
    FileInfo^ stopwordsFile
)

Parameters

stopwordsFile
Type: System.IO..::..FileInfo

[Missing <param name="stopwordsFile"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
[!:WordlistLoader.GetWordSet(File)]


StopAnalyzer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (TextReader)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, Reader) instead")]
public StopAnalyzer(
    TextReader stopwords
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, Reader) instead")> _
Public Sub New ( _
    stopwords As TextReader _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, Reader) instead")]
public:
StopAnalyzer(
    TextReader^ stopwords
)

Parameters

stopwords
Type: System.IO..::..TextReader

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(System.IO.TextReader)"]

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
[!:WordlistLoader.GetWordSet(Reader)]


StopAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (array<String>[]()[][])
StopAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in the provided array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Set, boolean) or StopAnalyzer(Version, Set) instead ")]
public StopAnalyzer(
    string[] stopWords
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Set, boolean) or StopAnalyzer(Version, Set) instead ")> _
Public Sub New ( _
    stopWords As String() _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Set, boolean) or StopAnalyzer(Version, Set) instead ")]
public:
StopAnalyzer(
    array<String^>^ stopWords
)

Parameters

stopWords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(System.String[])"]

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (Version)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Version)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in ENGLISH_STOP_WORDS.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StopAnalyzer(
    Version matchVersion
)
Visual Basic
Public Sub New ( _
    matchVersion As Version _
)
Visual C++
public:
StopAnalyzer(
    Version^ matchVersion
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(Lucene.Net.Util.Version)"]

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (Hashtable, Boolean)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Hashtable, Boolean)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, Set) instead")]
public StopAnalyzer(
    Hashtable stopWords,
    bool enablePositionIncrements
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, Set) instead")> _
Public Sub New ( _
    stopWords As Hashtable, _
    enablePositionIncrements As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, Set) instead")]
public:
StopAnalyzer(
    Hashtable^ stopWords,
    bool enablePositionIncrements
)

Parameters

stopWords
Type: System.Collections..::..Hashtable
Set of stop words
enablePositionIncrements
Type: System..::..Boolean
See {@link StopFilter#SetEnablePositionIncrements}

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (FileInfo, Boolean)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (FileInfo, Boolean)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, File) instead")]
public StopAnalyzer(
    FileInfo stopwordsFile,
    bool enablePositionIncrements
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, File) instead")> _
Public Sub New ( _
    stopwordsFile As FileInfo, _
    enablePositionIncrements As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, File) instead")]
public:
StopAnalyzer(
    FileInfo^ stopwordsFile,
    bool enablePositionIncrements
)

Parameters

stopwordsFile
Type: System.IO..::..FileInfo
File to load stop words from
enablePositionIncrements
Type: System..::..Boolean
See {@link StopFilter#SetEnablePositionIncrements}

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
[!:WordlistLoader.GetWordSet(File)]


StopAnalyzer Constructor (TextReader, Boolean)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (TextReader, Boolean)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, Reader) instead")]
public StopAnalyzer(
    TextReader stopwords,
    bool enablePositionIncrements
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, Reader) instead")> _
Public Sub New ( _
    stopwords As TextReader, _
    enablePositionIncrements As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, Reader) instead")]
public:
StopAnalyzer(
    TextReader^ stopwords,
    bool enablePositionIncrements
)

Parameters

stopwords
Type: System.IO..::..TextReader
Reader to load stop words from
enablePositionIncrements
Type: System..::..Boolean
See {@link StopFilter#SetEnablePositionIncrements}

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
[!:WordlistLoader.GetWordSet(Reader)]


StopAnalyzer Constructor (String[], Boolean)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (array<String>[]()[][], Boolean)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in the provided array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopAnalyzer(Version, Set) instead")]
public StopAnalyzer(
    string[] stopWords,
    bool enablePositionIncrements
)
Visual Basic
<ObsoleteAttribute("Use StopAnalyzer(Version, Set) instead")> _
Public Sub New ( _
    stopWords As String(), _
    enablePositionIncrements As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopAnalyzer(Version, Set) instead")]
public:
StopAnalyzer(
    array<String^>^ stopWords,
    bool enablePositionIncrements
)

Parameters

stopWords
Type: array< System..::..String >[]()[][]
Array of stop words
enablePositionIncrements
Type: System..::..Boolean
See {@link StopFilter#SetEnablePositionIncrements}

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (Version, Hashtable)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Version, Hashtable)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StopAnalyzer(
    Version matchVersion,
    Hashtable stopWords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopWords As Hashtable _
)
Visual C++
public:
StopAnalyzer(
    Version^ matchVersion,
    Hashtable^ stopWords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(Lucene.Net.Util.Version,System.Collections.Hashtable)"]

stopWords
Type: System.Collections..::..Hashtable

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.#ctor(Lucene.Net.Util.Version,System.Collections.Hashtable)"]

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace


StopAnalyzer Constructor (Version, FileInfo)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Version, FileInfo)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StopAnalyzer(
    Version matchVersion,
    FileInfo stopwordsFile
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopwordsFile As FileInfo _
)
Visual C++
public:
StopAnalyzer(
    Version^ matchVersion,
    FileInfo^ stopwordsFile
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
See above
stopwordsFile
Type: System.IO..::..FileInfo
File to load stop words from

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
[!:WordlistLoader.getWordSet(File)]


StopAnalyzer Constructor (Version, TextReader)

[image]

Lucene.Net Class Libraries
StopAnalyzer Constructor (Version, TextReader)
StopAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StopAnalyzer(
    Version matchVersion,
    TextReader stopwords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopwords As TextReader _
)
Visual C++
public:
StopAnalyzer(
    Version^ matchVersion,
    TextReader^ stopwords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
See above
stopwords
Type: System.IO..::..TextReader
Reader to load stop words from

See Also

StopAnalyzer Class
StopAnalyzer Overload
Lucene.Net.Analysis Namespace
[!:WordlistLoader.GetWordSet(Reader)]


StopAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
StopAnalyzer Fields
StopAnalyzer Class See Also Send Feedback

The StopAnalyzer type exposes the following members.

Fields

 | Name | Description
 | ENGLISH_STOP_WORDS | Obsolete. An array containing some common English words that are not usually useful for searching.
 | ENGLISH_STOP_WORDS_SET | An unmodifiable set containing some common English words that are not usually useful for searching.
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


ENGLISH_STOP_WORDS Field

[image]

Lucene.Net Class Libraries
StopAnalyzer..::..ENGLISH_STOP_WORDS Field
StopAnalyzer Class See Also Send Feedback
An array containing some common English words that are not usually useful for searching.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use ENGLISH_STOP_WORDS_SET instead ")]
public static readonly string[] ENGLISH_STOP_WORDS
Visual Basic
<ObsoleteAttribute("Use ENGLISH_STOP_WORDS_SET instead ")> _
Public Shared ReadOnly ENGLISH_STOP_WORDS As String()
Visual C++
[ObsoleteAttribute(L"Use ENGLISH_STOP_WORDS_SET instead ")]
public:
static initonly array<String^>^ ENGLISH_STOP_WORDS

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


ENGLISH_STOP_WORDS_SET Field

[image]

Lucene.Net Class Libraries
StopAnalyzer..::..ENGLISH_STOP_WORDS_SET Field
StopAnalyzer Class See Also Send Feedback
An unmodifiable set containing some common English words that are not usually useful for searching.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable ENGLISH_STOP_WORDS_SET
Visual Basic
Public Shared ENGLISH_STOP_WORDS_SET As Hashtable
Visual C++
public:
static Hashtable^ ENGLISH_STOP_WORDS_SET

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


StopAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
StopAnalyzer Methods
StopAnalyzer Class See Also Send Feedback

The StopAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Filters LowerCaseTokenizer with StopFilter. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
StopAnalyzer..::..ReusableTokenStream Method
StopAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
StopAnalyzer..::..TokenStream Method
StopAnalyzer Class See Also Send Feedback
Filters LowerCaseTokenizer with StopFilter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

StopAnalyzer Class
Lucene.Net.Analysis Namespace


StopFilter Class

[image]

Lucene.Net Class Libraries
StopFilter Class
Members See Also Send Feedback
Removes stop words from a token stream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StopFilter : TokenFilter
Visual Basic
Public NotInheritable Class StopFilter _
    Inherits TokenFilter
Visual C++
public ref class StopFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..StopFilter

See Also

StopFilter Members
Lucene.Net.Analysis Namespace


StopFilter Members

[image] [image]

Lucene.Net Class Libraries
StopFilter Members
StopFilter Class Constructors Methods Fields See Also Send Feedback

The StopFilter type exposes the following members.

Constructors

Name Description
Public method StopFilter(TokenStream, Hashtable) Obsolete.
Constructs a filter which removes words from the input TokenStream that are named in the Set.
Public method StopFilter(TokenStream, array<String>[]()[][]) Obsolete.
Construct a token stream filtering the given input.
Public method StopFilter(Boolean, TokenStream, Hashtable)
Constructs a filter which removes words from the input TokenStream that are named in the Set.
Public method StopFilter(Boolean, TokenStream, array<String>[]()[][]) Obsolete.
Construct a token stream filtering the given input.
Public method StopFilter(TokenStream, Hashtable, Boolean) Obsolete.
Construct a token stream filtering the given input. If
CopyC#
stopWords
 is an instance of {@link CharArraySet} (true if
CopyC#
makeStopSet()
 was used to construct the set) it will be directly used and
CopyC#
ignoreCase
 will be ignored since
CopyC#
CharArraySet
 directly controls case sensitivity.

If

CopyC#
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
CopyC#
ignoreCase
 will be used to specify the case sensitivity of that set.
Public method StopFilter(TokenStream, array<String>[]()[][], Boolean) Obsolete.
Constructs a filter which removes words from the input TokenStream that are named in the array of words.
Public method StopFilter(Boolean, TokenStream, Hashtable, Boolean)
Construct a token stream filtering the given input. If
CopyC#
stopWords
 is an instance of {@link CharArraySet} (true if
CopyC#
makeStopSet()
 was used to construct the set) it will be directly used and
CopyC#
ignoreCase
 will be ignored since
CopyC#
CharArraySet
 directly controls case sensitivity.

If

CopyC#
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
CopyC#
ignoreCase
 will be used to specify the case sensitivity of that set.
Public method StopFilter(Boolean, TokenStream, array<String>[]()[][], Boolean) Obsolete.
Constructs a filter which removes words from the input TokenStream that are named in the array of words.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetEnablePositionIncrements
GetEnablePositionIncrementsDefault | Obsolete.
GetEnablePositionIncrementsVersionDefault
Returns version-dependent default for enablePositionIncrements. Analyzers that embed StopFilter use this method when creating the StopFilter. Prior to 2.9, this returns {@link #getEnablePositionIncrementsDefault}. On 2.9 or later, it returns true.
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Returns the next input Token whose term() is not a stop word.
(Overrides TokenStream..::..IncrementToken()()()().)
Public method | Init
MakeStopSet(IList)
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(array<String>[]()[][])
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(IList, Boolean)
MakeStopSet(array<String>[]()[][], Boolean)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetEnablePositionIncrements
If
CopyC#
true
, this StopFilter will preserve positions of the incoming tokens (ie, accumulate and set position increments of the removed stop tokens). Generally,
CopyC#
true
 is best as it does not lose information (positions of the original tokens) during indexing.

When set, when a token is stopped (omitted), the position increment of the following token is incremented.

NOTE: be sure to also set {@link QueryParser#setEnablePositionIncrements} if you use QueryParser to create queries.

SetEnablePositionIncrementsDefault Obsolete.
Set the default position increments behavior of every StopFilter created from now on.

Note: behavior of a single StopFilter instance can be modified with {@link #SetEnablePositionIncrements(boolean)}. This static method allows control over behavior of classes using StopFilters internally, for example {@link Lucene.Net.Analysis.Standard.StandardAnalyzer StandardAnalyzer} if used with the no-arg ctor.

Default : false.

Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


StopFilter Constructor

[image] [image]

Lucene.Net Class Libraries
StopFilter Constructor
StopFilter Class See Also Send Feedback

Overload List

Name Description
Public method StopFilter(TokenStream, Hashtable) Obsolete.
Constructs a filter which removes words from the input TokenStream that are named in the Set.
Public method StopFilter(TokenStream, array<String>[]()[][]) Obsolete.
Construct a token stream filtering the given input.
Public method StopFilter(Boolean, TokenStream, Hashtable)
Constructs a filter which removes words from the input TokenStream that are named in the Set.
Public method StopFilter(Boolean, TokenStream, array<String>[]()[][]) Obsolete.
Construct a token stream filtering the given input.
Public method StopFilter(TokenStream, Hashtable, Boolean) Obsolete.
Construct a token stream filtering the given input. If
CopyC#
stopWords
 is an instance of {@link CharArraySet} (true if
CopyC#
makeStopSet()
 was used to construct the set) it will be directly used and
CopyC#
ignoreCase
 will be ignored since
CopyC#
CharArraySet
 directly controls case sensitivity.

If

CopyC#
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
CopyC#
ignoreCase
 will be used to specify the case sensitivity of that set.
Public method StopFilter(TokenStream, array<String>[]()[][], Boolean) Obsolete.
Constructs a filter which removes words from the input TokenStream that are named in the array of words.
Public method StopFilter(Boolean, TokenStream, Hashtable, Boolean)
Construct a token stream filtering the given input. If
CopyC#
stopWords
 is an instance of {@link CharArraySet} (true if
CopyC#
makeStopSet()
 was used to construct the set) it will be directly used and
CopyC#
ignoreCase
 will be ignored since
CopyC#
CharArraySet
 directly controls case sensitivity.

If

CopyC#
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
CopyC#
ignoreCase
 will be used to specify the case sensitivity of that set.
Public method StopFilter(Boolean, TokenStream, array<String>[]()[][], Boolean) Obsolete.
Constructs a filter which removes words from the input TokenStream that are named in the array of words.

See Also

StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace


StopFilter Constructor (TokenStream, Hashtable)

[image]

Lucene.Net Class Libraries
StopFilter Constructor (TokenStream, Hashtable)
StopFilter Class See Also Send Feedback
Constructs a filter which removes words from the input TokenStream that are named in the Set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopFilter(bool, TokenStream, Hashtable) instead")]
public StopFilter(
    TokenStream in_Renamed,
    Hashtable stopWords
)
Visual Basic
<ObsoleteAttribute("Use StopFilter(bool, TokenStream, Hashtable) instead")> _
Public Sub New ( _
    in_Renamed As TokenStream, _
    stopWords As Hashtable _
)
Visual C++
[ObsoleteAttribute(L"Use StopFilter(bool, TokenStream, Hashtable) instead")]
public:
StopFilter(
    TokenStream^ in_Renamed,
    Hashtable^ stopWords
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

stopWords
Type: System.Collections..::..Hashtable

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace
[!:MakeStopSet(java.lang.String[])]


StopFilter Constructor (TokenStream, String[])

[image]

Lucene.Net Class Libraries
StopFilter Constructor (TokenStream, array<String>[]()[][])
StopFilter Class See Also Send Feedback
Construct a token stream filtering the given input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopFilter(bool, TokenStream, String[]) instead")]
public StopFilter(
    TokenStream input,
    string[] stopWords
)
Visual Basic
<ObsoleteAttribute("Use StopFilter(bool, TokenStream, String[]) instead")> _
Public Sub New ( _
    input As TokenStream, _
    stopWords As String() _
)
Visual C++
[ObsoleteAttribute(L"Use StopFilter(bool, TokenStream, String[]) instead")]
public:
StopFilter(
    TokenStream^ input,
    array<String^>^ stopWords
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String[])"]

stopWords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String[])"]

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace


StopFilter Constructor (Boolean, TokenStream, Hashtable)

[image]

Lucene.Net Class Libraries
StopFilter Constructor (Boolean, TokenStream, Hashtable)
StopFilter Class See Also Send Feedback
Constructs a filter which removes words from the input TokenStream that are named in the Set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StopFilter(
    bool enablePositionIncrements,
    TokenStream in_Renamed,
    Hashtable stopWords
)
Visual Basic
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    in_Renamed As TokenStream, _
    stopWords As Hashtable _
)
Visual C++
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ in_Renamed,
    Hashtable^ stopWords
)

Parameters

enablePositionIncrements
Type: System..::..Boolean
true if token positions should record the removed stop words
in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(System.Boolean,Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

stopWords
Type: System.Collections..::..Hashtable
The set of Stop Words.

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace
[!:MakeStopSet(java.lang.String[])]


StopFilter Constructor (Boolean, TokenStream, String[])

[image]

Lucene.Net Class Libraries
StopFilter Constructor (Boolean, TokenStream, array<String>[]()[][])
StopFilter Class See Also Send Feedback
Construct a token stream filtering the given input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopFilter(bool, TokenStream, Hashtable) instead.")]
public StopFilter(
    bool enablePositionIncrements,
    TokenStream input,
    string[] stopWords
)
Visual Basic
<ObsoleteAttribute("Use StopFilter(bool, TokenStream, Hashtable) instead.")> _
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    input As TokenStream, _
    stopWords As String() _
)
Visual C++
[ObsoleteAttribute(L"Use StopFilter(bool, TokenStream, Hashtable) instead.")]
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ input,
    array<String^>^ stopWords
)

Parameters

enablePositionIncrements
Type: System..::..Boolean
true if token positions should record the removed stop words
input
Type: Lucene.Net.Analysis..::..TokenStream
input TokenStream
stopWords
Type: array< System..::..String >[]()[][]
array of stop words

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace


StopFilter Constructor (TokenStream, Hashtable, Boolean)

[image]

Lucene.Net Class Libraries
StopFilter Constructor (TokenStream, Hashtable, Boolean)
StopFilter Class See Also Send Feedback
Construct a token stream filtering the given input. If
CopyC#
stopWords
 is an instance of {@link CharArraySet} (true if
CopyC#
makeStopSet()
 was used to construct the set) it will be directly used and
CopyC#
ignoreCase
 will be ignored since
CopyC#
CharArraySet
 directly controls case sensitivity.

If

CopyC#
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
CopyC#
ignoreCase
 will be used to specify the case sensitivity of that set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopFilter(bool, TokenStream, Set, bool) instead")]
public StopFilter(
    TokenStream input,
    Hashtable stopWords,
    bool ignoreCase
)
Visual Basic
<ObsoleteAttribute("Use StopFilter(bool, TokenStream, Set, bool) instead")> _
Public Sub New ( _
    input As TokenStream, _
    stopWords As Hashtable, _
    ignoreCase As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopFilter(bool, TokenStream, Set, bool) instead")]
public:
StopFilter(
    TokenStream^ input,
    Hashtable^ stopWords,
    bool ignoreCase
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable,System.Boolean)"]

stopWords
Type: System.Collections..::..Hashtable
The set of Stop Words.
ignoreCase
Type: System..::..Boolean
-Ignore case when stopping.

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace


StopFilter Constructor (TokenStream, String[], Boolean)

[image]

Lucene.Net Class Libraries
StopFilter Constructor (TokenStream, array<String>[]()[][], Boolean)
StopFilter Class See Also Send Feedback
Constructs a filter which removes words from the input TokenStream that are named in the array of words.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use {@link #StopFilter(bool, TokenStream, String[], bool)} instead")]
public StopFilter(
    TokenStream in_Renamed,
    string[] stopWords,
    bool ignoreCase
)
Visual Basic
<ObsoleteAttribute("Use {@link #StopFilter(bool, TokenStream, String[], bool)} instead")> _
Public Sub New ( _
    in_Renamed As TokenStream, _
    stopWords As String(), _
    ignoreCase As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use {@link #StopFilter(bool, TokenStream, String[], bool)} instead")]
public:
StopFilter(
    TokenStream^ in_Renamed,
    array<String^>^ stopWords,
    bool ignoreCase
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String[],System.Boolean)"]

stopWords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String[],System.Boolean)"]

ignoreCase
Type: System..::..Boolean

[Missing <param name="ignoreCase"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String[],System.Boolean)"]

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace


StopFilter Constructor (Boolean, TokenStream, Hashtable, Boolean)

[image]

Lucene.Net Class Libraries
StopFilter Constructor (Boolean, TokenStream, Hashtable, Boolean)
StopFilter Class See Also Send Feedback
Construct a token stream filtering the given input. If
CopyC#
stopWords
 is an instance of {@link CharArraySet} (true if
CopyC#
makeStopSet()
 was used to construct the set) it will be directly used and
CopyC#
ignoreCase
 will be ignored since
CopyC#
CharArraySet
 directly controls case sensitivity.

If

CopyC#
stopWords
is not an instance of {@link CharArraySet}, a new CharArraySet will be constructed and
CopyC#
ignoreCase
 will be used to specify the case sensitivity of that set.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StopFilter(
    bool enablePositionIncrements,
    TokenStream input,
    Hashtable stopWords,
    bool ignoreCase
)
Visual Basic
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    input As TokenStream, _
    stopWords As Hashtable, _
    ignoreCase As Boolean _
)
Visual C++
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ input,
    Hashtable^ stopWords,
    bool ignoreCase
)

Parameters

enablePositionIncrements
Type: System..::..Boolean
true if token positions should record the removed stop words
input
Type: Lucene.Net.Analysis..::..TokenStream
Input TokenStream
stopWords
Type: System.Collections..::..Hashtable
The set of Stop Words.
ignoreCase
Type: System..::..Boolean
-Ignore case when stopping.

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace


StopFilter Constructor (Boolean, TokenStream, String[], Boolean)

[image]

Lucene.Net Class Libraries
StopFilter Constructor (Boolean, TokenStream, array<String>[]()[][], Boolean)
StopFilter Class See Also Send Feedback
Constructs a filter which removes words from the input TokenStream that are named in the array of words.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StopFilter(bool, TokenStream, Hashtable, bool) instead.")]
public StopFilter(
    bool enablePositionIncrements,
    TokenStream in_Renamed,
    string[] stopWords,
    bool ignoreCase
)
Visual Basic
<ObsoleteAttribute("Use StopFilter(bool, TokenStream, Hashtable, bool) instead.")> _
Public Sub New ( _
    enablePositionIncrements As Boolean, _
    in_Renamed As TokenStream, _
    stopWords As String(), _
    ignoreCase As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StopFilter(bool, TokenStream, Hashtable, bool) instead.")]
public:
StopFilter(
    bool enablePositionIncrements,
    TokenStream^ in_Renamed,
    array<String^>^ stopWords,
    bool ignoreCase
)

Parameters

enablePositionIncrements
Type: System..::..Boolean
true if token positions should record the removed stop words
in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.StopFilter.#ctor(System.Boolean,Lucene.Net.Analysis.TokenStream,System.String[],System.Boolean)"]

stopWords
Type: array< System..::..String >[]()[][]
array of stop words
ignoreCase
Type: System..::..Boolean
true if case is ignored

See Also

StopFilter Class
StopFilter Overload
Lucene.Net.Analysis Namespace


StopFilter Fields

[image] [image]

Lucene.Net Class Libraries
StopFilter Fields
StopFilter Class See Also Send Feedback

The StopFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


StopFilter Methods

[image] [image]

Lucene.Net Class Libraries
StopFilter Methods
StopFilter Class See Also Send Feedback

The StopFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetEnablePositionIncrements
GetEnablePositionIncrementsDefault | Obsolete.
GetEnablePositionIncrementsVersionDefault
Returns version-dependent default for enablePositionIncrements. Analyzers that embed StopFilter use this method when creating the StopFilter. Prior to 2.9, this returns {@link #getEnablePositionIncrementsDefault}. On 2.9 or later, it returns true.
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Returns the next input Token whose term() is not a stop word.
(Overrides TokenStream..::..IncrementToken()()()().)
Public method | Init
MakeStopSet(IList)
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(array<String>[]()[][])
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(IList, Boolean)
MakeStopSet(array<String>[]()[][], Boolean)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetEnablePositionIncrements
If
CopyC#
true
, this StopFilter will preserve positions of the incoming tokens (ie, accumulate and set position increments of the removed stop tokens). Generally,
CopyC#
true
 is best as it does not lose information (positions of the original tokens) during indexing.

When set, when a token is stopped (omitted), the position increment of the following token is incremented.

NOTE: be sure to also set {@link QueryParser#setEnablePositionIncrements} if you use QueryParser to create queries.

SetEnablePositionIncrementsDefault Obsolete.
Set the default position increments behavior of every StopFilter created from now on.

Note: behavior of a single StopFilter instance can be modified with {@link #SetEnablePositionIncrements(boolean)}. This static method allows control over behavior of classes using StopFilters internally, for example {@link Lucene.Net.Analysis.Standard.StandardAnalyzer StandardAnalyzer} if used with the no-arg ctor.

Default : false.

Public method | ToString | (Inherited from AttributeSource.)

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


GetEnablePositionIncrements Method

[image]

Lucene.Net Class Libraries
StopFilter..::..GetEnablePositionIncrements Method
StopFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.StopFilter.GetEnablePositionIncrements"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool GetEnablePositionIncrements()
Visual Basic
Public Function GetEnablePositionIncrements As Boolean
Visual C++
public:
bool GetEnablePositionIncrements()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopFilter.GetEnablePositionIncrements"]

See Also

StopFilter Class
Lucene.Net.Analysis Namespace
StopFilter..::..SetEnablePositionIncrements(Boolean)


GetEnablePositionIncrementsDefault Method

[image]

Lucene.Net Class Libraries
StopFilter..::..GetEnablePositionIncrementsDefault Method
StopFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.StopFilter.GetEnablePositionIncrementsDefault"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify this when you create the StopFilter")]
public static bool GetEnablePositionIncrementsDefault()
Visual Basic
<ObsoleteAttribute("Please specify this when you create the StopFilter")> _
Public Shared Function GetEnablePositionIncrementsDefault As Boolean
Visual C++
[ObsoleteAttribute(L"Please specify this when you create the StopFilter")]
public:
static bool GetEnablePositionIncrementsDefault()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopFilter.GetEnablePositionIncrementsDefault"]

See Also

StopFilter Class
Lucene.Net.Analysis Namespace
StopFilter..::..SetEnablePositionIncrementsDefault(Boolean)


GetEnablePositionIncrementsVersionDefault Method

[image]

Lucene.Net Class Libraries
StopFilter..::..GetEnablePositionIncrementsVersionDefault Method
StopFilter Class See Also Send Feedback
Returns version-dependent default for enablePositionIncrements. Analyzers that embed StopFilter use this method when creating the StopFilter. Prior to 2.9, this returns {@link #getEnablePositionIncrementsDefault}. On 2.9 or later, it returns true.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool GetEnablePositionIncrementsVersionDefault(
    Version matchVersion
)
Visual Basic
Public Shared Function GetEnablePositionIncrementsVersionDefault ( _
    matchVersion As Version _
) As Boolean
Visual C++
public:
static bool GetEnablePositionIncrementsVersionDefault(
    Version^ matchVersion
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.StopFilter.GetEnablePositionIncrementsVersionDefault(Lucene.Net.Util.Version)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopFilter.GetEnablePositionIncrementsVersionDefault(Lucene.Net.Util.Version)"]

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
StopFilter..::..IncrementToken Method
StopFilter Class See Also Send Feedback
Returns the next input Token whose term() is not a stop word.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopFilter.IncrementToken"]

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


Init Method

[image]

Lucene.Net Class Libraries
StopFilter..::..Init Method
StopFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.StopFilter.Init"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Init()
Visual Basic
Public Sub Init
Visual C++
public:
void Init()

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


MakeStopSet Method

[image] [image]

Lucene.Net Class Libraries
StopFilter..::..MakeStopSet Method
StopFilter Class See Also Send Feedback

Overload List

Name | Description
MakeStopSet(IList) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(array<String>[]()[][]) | Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.
MakeStopSet(IList, Boolean) |
MakeStopSet(array<String>[]()[][], Boolean) |

See Also

StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace


MakeStopSet Method (IList)

[image]

Lucene.Net Class Libraries
StopFilter..::..MakeStopSet Method (IList)
StopFilter Class See Also Send Feedback
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable MakeStopSet(
    IList stopWords
)
Visual Basic
Public Shared Function MakeStopSet ( _
    stopWords As IList _
) As Hashtable
Visual C++
public:
static Hashtable^ MakeStopSet(
    IList^ stopWords
)

Parameters

stopWords
Type: System.Collections..::..IList

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopFilter.MakeStopSet(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopFilter.MakeStopSet(System.Collections.IList)"]

See Also

StopFilter Class
MakeStopSet Overload
Lucene.Net.Analysis Namespace
passing false to ignoreCase


MakeStopSet Method (String[])

[image]

Lucene.Net Class Libraries
StopFilter..::..MakeStopSet Method (array<String>[]()[][])
StopFilter Class See Also Send Feedback
Builds a Set from an array of stop words, appropriate for passing into the StopFilter constructor. This permits this stopWords construction to be cached once when an Analyzer is constructed.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable MakeStopSet(
    string[] stopWords
)
Visual Basic
Public Shared Function MakeStopSet ( _
    stopWords As String() _
) As Hashtable
Visual C++
public:
static Hashtable^ MakeStopSet(
    array<String^>^ stopWords
)

Parameters

stopWords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.StopFilter.MakeStopSet(System.String[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.StopFilter.MakeStopSet(System.String[])"]

See Also

StopFilter Class
MakeStopSet Overload
Lucene.Net.Analysis Namespace
passing false to ignoreCase


MakeStopSet Method (IList, Boolean)

[image]

Lucene.Net Class Libraries
StopFilter..::..MakeStopSet Method (IList, Boolean)
StopFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.StopFilter.MakeStopSet(System.Collections.IList,System.Boolean)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable MakeStopSet(
    IList stopWords,
    bool ignoreCase
)
Visual Basic
Public Shared Function MakeStopSet ( _
    stopWords As IList, _
    ignoreCase As Boolean _
) As Hashtable
Visual C++
public:
static Hashtable^ MakeStopSet(
    IList^ stopWords,
    bool ignoreCase
)

Parameters

stopWords
Type: System.Collections..::..IList
A List of Strings representing the stopwords
ignoreCase
Type: System..::..Boolean
if true, all words are lower cased first

Return Value

A Set containing the words

See Also

StopFilter Class
MakeStopSet Overload
Lucene.Net.Analysis Namespace


MakeStopSet Method (String[], Boolean)

[image]

Lucene.Net Class Libraries
StopFilter..::..MakeStopSet Method (array<String>[]()[][], Boolean)
StopFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.StopFilter.MakeStopSet(System.String[],System.Boolean)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable MakeStopSet(
    string[] stopWords,
    bool ignoreCase
)
Visual Basic
Public Shared Function MakeStopSet ( _
    stopWords As String(), _
    ignoreCase As Boolean _
) As Hashtable
Visual C++
public:
static Hashtable^ MakeStopSet(
    array<String^>^ stopWords,
    bool ignoreCase
)

Parameters

stopWords
Type: array< System..::..String >[]()[][]
An array of stopwords
ignoreCase
Type: System..::..Boolean
If true, all words are lower cased first.

Return Value

a Set containing the words

See Also

StopFilter Class
MakeStopSet Overload
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
StopFilter..::..Next Method
StopFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

StopFilter Class
StopFilter Members
Lucene.Net.Analysis Namespace


SetEnablePositionIncrements Method

[image]

Lucene.Net Class Libraries
StopFilter..::..SetEnablePositionIncrements Method
StopFilter Class See Also Send Feedback
If
CopyC#
true
, this StopFilter will preserve positions of the incoming tokens (ie, accumulate and set position increments of the removed stop tokens). Generally,
CopyC#
true
 is best as it does not lose information (positions of the original tokens) during indexing.

When set, when a token is stopped (omitted), the position increment of the following token is incremented.

NOTE: be sure to also set {@link QueryParser#setEnablePositionIncrements} if you use QueryParser to create queries.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetEnablePositionIncrements(
    bool enable
)
Visual Basic
Public Sub SetEnablePositionIncrements ( _
    enable As Boolean _
)
Visual C++
public:
void SetEnablePositionIncrements(
    bool enable
)

Parameters

enable
Type: System..::..Boolean

[Missing <param name="enable"/> documentation for "M:Lucene.Net.Analysis.StopFilter.SetEnablePositionIncrements(System.Boolean)"]

See Also

StopFilter Class
Lucene.Net.Analysis Namespace


SetEnablePositionIncrementsDefault Method

[image]

Lucene.Net Class Libraries
StopFilter..::..SetEnablePositionIncrementsDefault Method
StopFilter Class See Also Send Feedback
Set the default position increments behavior of every StopFilter created from now on.

Note: behavior of a single StopFilter instance can be modified with {@link #SetEnablePositionIncrements(boolean)}. This static method allows control over behavior of classes using StopFilters internally, for example {@link Lucene.Net.Analysis.Standard.StandardAnalyzer StandardAnalyzer} if used with the no-arg ctor.

Default : false.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify this when you create the StopFilter")]
public static void SetEnablePositionIncrementsDefault(
    bool defaultValue
)
Visual Basic
<ObsoleteAttribute("Please specify this when you create the StopFilter")> _
Public Shared Sub SetEnablePositionIncrementsDefault ( _
    defaultValue As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Please specify this when you create the StopFilter")]
public:
static void SetEnablePositionIncrementsDefault(
    bool defaultValue
)

Parameters

defaultValue
Type: System..::..Boolean

[Missing <param name="defaultValue"/> documentation for "M:Lucene.Net.Analysis.StopFilter.SetEnablePositionIncrementsDefault(System.Boolean)"]

See Also

StopFilter Class
Lucene.Net.Analysis Namespace
[!:setEnablePositionIncrements(bool)]


TeeSinkTokenFilter Class

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter Class
Members See Also Send Feedback
This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
            TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
            TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
            TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
            source2.addSinkTokenStream(sink1);
            source2.addSinkTokenStream(sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using {@link #consumeAllTokens}. This TokenFilter is exhausted after this. In the above example, change the example above to:
            ...
            TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
            TokenStream final2 = source2.newSinkTokenStream();
            sink1.consumeAllTokens();
            sink2.consumeAllTokens();
            ...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class TeeSinkTokenFilter : TokenFilter
Visual Basic
Public NotInheritable Class TeeSinkTokenFilter _
    Inherits TokenFilter
Visual C++
public ref class TeeSinkTokenFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..TeeSinkTokenFilter

See Also

TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter Members
TeeSinkTokenFilter Class Constructors Methods Fields See Also Send Feedback

The TeeSinkTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | TeeSinkTokenFilter | Instantiates a new TeeSinkTokenFilter.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method AddSinkTokenStream
Adds a {@link SinkTokenStream} created by another
CopyC#
TeeSinkTokenFilter
 to this one. The supplied stream will also receive all consumed tokens. This method can be used to pass tokens from two different tees to one sink.
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method ConsumeAllTokens
CopyC#
TeeSinkTokenFilter
 passes all tokens to the added sinks when itself is consumed. To be sure, that all tokens from the input stream are passed to the sinks, you can call this methods. This instance is exhausted after this, but all sinks are instant available.
Public method | End | (Overrides TokenFilter..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method NewSinkTokenStream()()()()
Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream.
Public method NewSinkTokenStream(TeeSinkTokenFilter..::..SinkFilter)
Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream that pass the supplied filter.
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter Constructor

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter Constructor
TeeSinkTokenFilter Class See Also Send Feedback
Instantiates a new TeeSinkTokenFilter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TeeSinkTokenFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
TeeSinkTokenFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter Fields

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter Fields
TeeSinkTokenFilter Class See Also Send Feedback

The TeeSinkTokenFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter Methods
TeeSinkTokenFilter Class See Also Send Feedback

The TeeSinkTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method AddSinkTokenStream
Adds a {@link SinkTokenStream} created by another
CopyC#
TeeSinkTokenFilter
 to this one. The supplied stream will also receive all consumed tokens. This method can be used to pass tokens from two different tees to one sink.
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method ConsumeAllTokens
CopyC#
TeeSinkTokenFilter
 passes all tokens to the added sinks when itself is consumed. To be sure, that all tokens from the input stream are passed to the sinks, you can call this methods. This instance is exhausted after this, but all sinks are instant available.
Public method | End | (Overrides TokenFilter..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method NewSinkTokenStream()()()()
Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream.
Public method NewSinkTokenStream(TeeSinkTokenFilter..::..SinkFilter)
Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream that pass the supplied filter.
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


AddSinkTokenStream Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..AddSinkTokenStream Method
TeeSinkTokenFilter Class See Also Send Feedback
Adds a {@link SinkTokenStream} created by another
CopyC#
TeeSinkTokenFilter
 to this one. The supplied stream will also receive all consumed tokens. This method can be used to pass tokens from two different tees to one sink.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void AddSinkTokenStream(
    TeeSinkTokenFilter..::..SinkTokenStream sink
)
Visual Basic
Public Sub AddSinkTokenStream ( _
    sink As TeeSinkTokenFilter..::..SinkTokenStream _
)
Visual C++
public:
void AddSinkTokenStream(
    TeeSinkTokenFilter..::..SinkTokenStream^ sink
)

Parameters

sink
Type: Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkTokenStream

[Missing <param name="sink"/> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.AddSinkTokenStream(Lucene.Net.Analysis.TeeSinkTokenFilter.SinkTokenStream)"]

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


ConsumeAllTokens Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..ConsumeAllTokens Method
TeeSinkTokenFilter Class See Also Send Feedback
CopyC#
TeeSinkTokenFilter
 passes all tokens to the added sinks when itself is consumed. To be sure, that all tokens from the input stream are passed to the sinks, you can call this methods. This instance is exhausted after this, but all sinks are instant available.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void ConsumeAllTokens()
Visual Basic
Public Sub ConsumeAllTokens
Visual C++
public:
void ConsumeAllTokens()

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..End Method
TeeSinkTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.End"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..IncrementToken Method
TeeSinkTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.IncrementToken"]

See Also

TeeSinkTokenFilter Class
Lucene.Net.Analysis Namespace


NewSinkTokenStream Method

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..NewSinkTokenStream Method
TeeSinkTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewSinkTokenStream()()()() | Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream.
Public method | NewSinkTokenStream(TeeSinkTokenFilter..::..SinkFilter) | Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream that pass the supplied filter.

See Also

TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace


NewSinkTokenStream Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..NewSinkTokenStream Method
TeeSinkTokenFilter Class See Also Send Feedback
Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TeeSinkTokenFilter..::..SinkTokenStream NewSinkTokenStream()
Visual Basic
Public Function NewSinkTokenStream As TeeSinkTokenFilter..::..SinkTokenStream
Visual C++
public:
TeeSinkTokenFilter..::..SinkTokenStream^ NewSinkTokenStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.NewSinkTokenStream"]

See Also

TeeSinkTokenFilter Class
NewSinkTokenStream Overload
Lucene.Net.Analysis Namespace


NewSinkTokenStream Method (TeeSinkTokenFilter.SinkFilter)

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..NewSinkTokenStream Method (TeeSinkTokenFilter..::..SinkFilter)
TeeSinkTokenFilter Class See Also Send Feedback
Returns a new {@link SinkTokenStream} that receives all tokens consumed by this stream that pass the supplied filter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TeeSinkTokenFilter..::..SinkTokenStream NewSinkTokenStream(
    TeeSinkTokenFilter..::..SinkFilter filter
)
Visual Basic
Public Function NewSinkTokenStream ( _
    filter As TeeSinkTokenFilter..::..SinkFilter _
) As TeeSinkTokenFilter..::..SinkTokenStream
Visual C++
public:
TeeSinkTokenFilter..::..SinkTokenStream^ NewSinkTokenStream(
    TeeSinkTokenFilter..::..SinkFilter^ filter
)

Parameters

filter
Type: Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkFilter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.NewSinkTokenStream(Lucene.Net.Analysis.TeeSinkTokenFilter.SinkFilter)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.NewSinkTokenStream(Lucene.Net.Analysis.TeeSinkTokenFilter.SinkFilter)"]

See Also

TeeSinkTokenFilter Class
NewSinkTokenStream Overload
Lucene.Net.Analysis Namespace
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkFilter


Next Method

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..Next Method
TeeSinkTokenFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

TeeSinkTokenFilter Class
TeeSinkTokenFilter Members
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.AnonymousClassSinkFilter Class

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class
TeeSinkTokenFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.TeeSinkTokenFilter.AnonymousClassSinkFilter"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class AnonymousClassSinkFilter : TeeSinkTokenFilter..::..SinkFilter
Visual Basic
Public Class AnonymousClassSinkFilter _
    Inherits TeeSinkTokenFilter..::..SinkFilter
Visual C++
public ref class AnonymousClassSinkFilter : public TeeSinkTokenFilter..::..SinkFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkFilter
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..AnonymousClassSinkFilter

See Also

TeeSinkTokenFilter..::..AnonymousClassSinkFilter Members
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.AnonymousClassSinkFilter Members

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Members
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class Constructors Methods See Also Send Feedback

This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
            TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
            TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
            TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
            source2.addSinkTokenStream(sink1);
            source2.addSinkTokenStream(sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using {@link #consumeAllTokens}. This TokenFilter is exhausted after this. In the above example, change the example above to:
            ...
            TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
            TokenStream final2 = source2.newSinkTokenStream();
            sink1.consumeAllTokens();
            sink2.consumeAllTokens();
            ...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

The TeeSinkTokenFilter..::..AnonymousClassSinkFilter type exposes the following members.

Constructors

 | Name | Description
Public method | TeeSinkTokenFilter..::..AnonymousClassSinkFilter | Initializes a new instance of the TeeSinkTokenFilter..::..AnonymousClassSinkFilter class

Methods

 | Name | Description
Public method | Accept | (Overrides TeeSinkTokenFilter..::..SinkFilter..::..Accept(AttributeSource).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Called by {@link SinkTokenStream#Reset()}. This method does nothing by default and can optionally be overridden. (Inherited from TeeSinkTokenFilter..::..SinkFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.AnonymousClassSinkFilter Constructor

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Constructor
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class See Also Send Feedback
Initializes a new instance of the TeeSinkTokenFilter..::..AnonymousClassSinkFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AnonymousClassSinkFilter()
Visual Basic
Public Sub New
Visual C++
public:
AnonymousClassSinkFilter()

See Also

TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.AnonymousClassSinkFilter Methods

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Methods
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class See Also Send Feedback

The TeeSinkTokenFilter..::..AnonymousClassSinkFilter type exposes the following members.

Methods

 | Name | Description
Public method | Accept | (Overrides TeeSinkTokenFilter..::..SinkFilter..::..Accept(AttributeSource).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Called by {@link SinkTokenStream#Reset()}. This method does nothing by default and can optionally be overridden. (Inherited from TeeSinkTokenFilter..::..SinkFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class
Lucene.Net.Analysis Namespace


Accept Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..AnonymousClassSinkFilter..::..Accept Method
TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.AnonymousClassSinkFilter.Accept(Lucene.Net.Util.AttributeSource)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Accept(
    AttributeSource source
)
Visual Basic
Public Overrides Function Accept ( _
    source As AttributeSource _
) As Boolean
Visual C++
public:
virtual bool Accept(
    AttributeSource^ source
) override

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.AnonymousClassSinkFilter.Accept(Lucene.Net.Util.AttributeSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.AnonymousClassSinkFilter.Accept(Lucene.Net.Util.AttributeSource)"]

See Also

TeeSinkTokenFilter..::..AnonymousClassSinkFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkFilter Class

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkFilter Class
TeeSinkTokenFilter Class Members See Also Send Feedback
A filter that decides which {@link AttributeSource} states to store in the sink.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class SinkFilter
Visual Basic
Public MustInherit Class SinkFilter
Visual C++
public ref class SinkFilter abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkFilter
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..AnonymousClassSinkFilter

See Also

TeeSinkTokenFilter..::..SinkFilter Members
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkFilter Members

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkFilter Members
TeeSinkTokenFilter..::..SinkFilter Class Constructors Methods See Also Send Feedback

This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
            TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
            TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
            TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
            source2.addSinkTokenStream(sink1);
            source2.addSinkTokenStream(sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using {@link #consumeAllTokens}. This TokenFilter is exhausted after this. In the above example, change the example above to:
            ...
            TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
            TokenStream final2 = source2.newSinkTokenStream();
            sink1.consumeAllTokens();
            sink2.consumeAllTokens();
            ...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

The TeeSinkTokenFilter..::..SinkFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | TeeSinkTokenFilter..::..SinkFilter | Initializes a new instance of the TeeSinkTokenFilter..::..SinkFilter class

Methods

 | Name | Description
Public method | Accept | Returns true, iff the current state of the passed-in {@link AttributeSource} shall be stored in the sink.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Called by {@link SinkTokenStream#Reset()}. This method does nothing by default and can optionally be overridden.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TeeSinkTokenFilter..::..SinkFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkFilter Constructor

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkFilter Constructor
TeeSinkTokenFilter..::..SinkFilter Class See Also Send Feedback
Initializes a new instance of the TeeSinkTokenFilter..::..SinkFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected SinkFilter()
Visual Basic
Protected Sub New
Visual C++
protected:
SinkFilter()

See Also

TeeSinkTokenFilter..::..SinkFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkFilter Methods

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkFilter Methods
TeeSinkTokenFilter..::..SinkFilter Class See Also Send Feedback

The TeeSinkTokenFilter..::..SinkFilter type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Returns true, iff the current state of the passed-in {@link AttributeSource} shall be stored in the sink.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Called by {@link SinkTokenStream#Reset()}. This method does nothing by default and can optionally be overridden.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TeeSinkTokenFilter..::..SinkFilter Class
Lucene.Net.Analysis Namespace


Accept Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkFilter..::..Accept Method
TeeSinkTokenFilter..::..SinkFilter Class See Also Send Feedback
Returns true, iff the current state of the passed-in {@link AttributeSource} shall be stored in the sink.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Accept(
    AttributeSource source
)
Visual Basic
Public MustOverride Function Accept ( _
    source As AttributeSource _
) As Boolean
Visual C++
public:
virtual bool Accept(
    AttributeSource^ source
) abstract

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkFilter.Accept(Lucene.Net.Util.AttributeSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkFilter.Accept(Lucene.Net.Util.AttributeSource)"]

See Also

TeeSinkTokenFilter..::..SinkFilter Class
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkFilter..::..Reset Method
TeeSinkTokenFilter..::..SinkFilter Class See Also Send Feedback
Called by {@link SinkTokenStream#Reset()}. This method does nothing by default and can optionally be overridden.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

TeeSinkTokenFilter..::..SinkFilter Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkTokenStream Class

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkTokenStream Class
TeeSinkTokenFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkTokenStream"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class SinkTokenStream : TokenStream
Visual Basic
Public NotInheritable Class SinkTokenStream _
    Inherits TokenStream
Visual C++
public ref class SinkTokenStream sealed : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkTokenStream

See Also

TeeSinkTokenFilter..::..SinkTokenStream Members
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkTokenStream Members

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkTokenStream Members
TeeSinkTokenFilter..::..SinkTokenStream Class Methods See Also Send Feedback

This TokenFilter provides the ability to set aside attribute states that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            TeeSinkTokenFilter source1 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader1));
            TeeSinkTokenFilter.SinkTokenStream sink1 = source1.newSinkTokenStream();
            TeeSinkTokenFilter.SinkTokenStream sink2 = source1.newSinkTokenStream();
            TeeSinkTokenFilter source2 = new TeeSinkTokenFilter(new WhitespaceTokenizer(reader2));
            source2.addSinkTokenStream(sink1);
            source2.addSinkTokenStream(sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). If you are not sure, which stream is consumed first, you can simply add another sink and then pass all tokens to the sinks at once using {@link #consumeAllTokens}. This TokenFilter is exhausted after this. In the above example, change the example above to:
            ...
            TokenStream final1 = new LowerCaseFilter(source1.newSinkTokenStream());
            TokenStream final2 = source2.newSinkTokenStream();
            sink1.consumeAllTokens();
            sink2.consumeAllTokens();
            ...
In this case, the fields can be added in any order, because the sources are not used anymore and all sinks are ready.

Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene.

The TeeSinkTokenFilter..::..SinkTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TeeSinkTokenFilter..::..SinkTokenStream Class
Lucene.Net.Analysis Namespace


TeeSinkTokenFilter.SinkTokenStream Methods

[image] [image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkTokenStream Methods
TeeSinkTokenFilter..::..SinkTokenStream Class See Also Send Feedback

The TeeSinkTokenFilter..::..SinkTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TeeSinkTokenFilter..::..SinkTokenStream Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkTokenStream..::..End Method
TeeSinkTokenFilter..::..SinkTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkTokenStream.End"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

TeeSinkTokenFilter..::..SinkTokenStream Class
Lucene.Net.Analysis Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkTokenStream..::..IncrementToken Method
TeeSinkTokenFilter..::..SinkTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkTokenStream.IncrementToken"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkTokenStream.IncrementToken"]

See Also

TeeSinkTokenFilter..::..SinkTokenStream Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
SinkTokenStream..::..Next Method
TeeSinkTokenFilter..::..SinkTokenStream Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

TeeSinkTokenFilter..::..SinkTokenStream Class
TeeSinkTokenFilter..::..SinkTokenStream Members
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
TeeSinkTokenFilter..::..SinkTokenStream..::..Reset Method
TeeSinkTokenFilter..::..SinkTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeSinkTokenFilter.SinkTokenStream.Reset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

TeeSinkTokenFilter..::..SinkTokenStream Class
Lucene.Net.Analysis Namespace


TeeTokenFilter Class

[image]

Lucene.Net Class Libraries
TeeTokenFilter Class
Members See Also Send Feedback
Works in conjunction with the SinkTokenizer to provide the ability to set aside tokens that have already been analyzed. This is useful in situations where multiple fields share many common analysis steps and then go their separate ways.

It is also useful for doing things like entity extraction or proper noun analysis as part of the analysis workflow and saving off those tokens for use in another field.

            SinkTokenizer sink1 = new SinkTokenizer();
            SinkTokenizer sink2 = new SinkTokenizer();
            TokenStream source1 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader1), sink1), sink2);
            TokenStream source2 = new TeeTokenFilter(new TeeTokenFilter(new WhitespaceTokenizer(reader2), sink1), sink2);
            TokenStream final1 = new LowerCaseFilter(source1);
            TokenStream final2 = source2;
            TokenStream final3 = new EntityDetect(sink1);
            TokenStream final4 = new URLDetect(sink2);
            d.add(new Field("f1", final1));
            d.add(new Field("f2", final2));
            d.add(new Field("f3", final3));
            d.add(new Field("f4", final4));
In this example,
CopyC#
sink1
 and
CopyC#
sink2
 will both get tokens from both
CopyC#
reader1
 and
CopyC#
reader2
 after whitespace tokenizer and now we can further wrap any of these in extra analysis, and more "sources" can be inserted if desired. It is important, that tees are consumed before sinks (in the above example, the field names must be less the sink's field names). Note, the EntityDetect and URLDetect TokenStreams are for the example and do not currently exist in Lucene

See LUCENE-1058.

WARNING: {@link TeeTokenFilter} and {@link SinkTokenizer} only work with the old TokenStream API. If you switch to the new API, you need to use {@link TeeSinkTokenFilter} instead, which offers the same functionality.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use TeeSinkTokenFilter instead")]
public class TeeTokenFilter : TokenFilter
Visual Basic
<ObsoleteAttribute("Use TeeSinkTokenFilter instead")> _
Public Class TeeTokenFilter _
    Inherits TokenFilter
Visual C++
[ObsoleteAttribute(L"Use TeeSinkTokenFilter instead")]
public ref class TeeTokenFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..TeeTokenFilter

See Also

TeeTokenFilter Members
Lucene.Net.Analysis Namespace
Lucene.Net.Analysis..::..SinkTokenizer


TeeTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
TeeTokenFilter Members
TeeTokenFilter Class Constructors Methods Fields See Also Send Feedback

The TeeTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | TeeTokenFilter | Initializes a new instance of the TeeTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

TeeTokenFilter Class
Lucene.Net.Analysis Namespace


TeeTokenFilter Constructor

[image]

Lucene.Net Class Libraries
TeeTokenFilter Constructor
TeeTokenFilter Class See Also Send Feedback
Initializes a new instance of the TeeTokenFilter class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TeeTokenFilter(
    TokenStream input,
    SinkTokenizer sink
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    sink As SinkTokenizer _
)
Visual C++
public:
TeeTokenFilter(
    TokenStream^ input,
    SinkTokenizer^ sink
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.TeeTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.SinkTokenizer)"]

sink
Type: Lucene.Net.Analysis..::..SinkTokenizer

[Missing <param name="sink"/> documentation for "M:Lucene.Net.Analysis.TeeTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.SinkTokenizer)"]

See Also

TeeTokenFilter Class
Lucene.Net.Analysis Namespace


TeeTokenFilter Fields

[image] [image]

Lucene.Net Class Libraries
TeeTokenFilter Fields
TeeTokenFilter Class See Also Send Feedback

The TeeTokenFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

TeeTokenFilter Class
Lucene.Net.Analysis Namespace


TeeTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
TeeTokenFilter Methods
TeeTokenFilter Class See Also Send Feedback

The TeeTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TeeTokenFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
TeeTokenFilter..::..Next Method
TeeTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. Returns the next {@link Token} in the stream, or null at EOS. (Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

TeeTokenFilter Class
TeeTokenFilter Members
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
TeeTokenFilter..::..Next Method (Token)
TeeTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TeeTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Analysis.TokenStream.Next(Lucene.Net.Analysis.Token)")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Analysis.TokenStream.Next(Lucene.Net.Analysis.Token)")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Analysis.TokenStream.Next(Lucene.Net.Analysis.Token)")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.TeeTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TeeTokenFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

TeeTokenFilter Class
Next Overload
Lucene.Net.Analysis Namespace


Token Class

[image]

Lucene.Net Class Libraries
Token Class
Members See Also Send Feedback
A Token is an occurrence of a term from the text of a field. It consists of a term's text, the start and end offset of the term in the text of the field, and a type string.

The start and end offsets permit applications to re-associate a token with its source text, e.g., to display highlighted query terms in a document browser, or to show matching text fragments in a KWIC display, etc.

The type is a string, assigned by a lexical analyzer (a.k.a. tokenizer), naming the lexical or syntactic class that the token belongs to. For example an end of sentence marker token might be implemented with type "eos". The default token type is "word".

A Token can optionally have metadata (a.k.a. Payload) in the form of a variable length byte array. Use {@link TermPositions#GetPayloadLength()} and {@link TermPositions#GetPayload(byte[], int)} to retrieve the payloads from the index.

NOTE: As of 2.9, Token implements all {@link Attribute} interfaces that are part of core Lucene and can be found in the {@code tokenattributes} subpackage. Even though it is not necessary to use Token anymore, with the new TokenStream API it can be used as convenience class that implements all {@link Attribute}s, which is especially useful to easily switch from the old to the new TokenStream API.

NOTE: As of 2.3, Token stores the term text internally as a malleable char[] termBuffer instead of String termText. The indexing code and core tokenizers have been changed to re-use a single Token instance, changing its buffer and other fields in-place as the Token is processed. This provides substantially better indexing performance as it saves the GC cost of new'ing a Token and String for every term. The APIs that accept String termText are still available but a warning about the associated performance cost has been added (below). The {@link #TermText()} method has been deprecated.

Tokenizers and TokenFilters should try to re-use a Token instance when possible for best performance, by implementing the {@link TokenStream#IncrementToken()} API. Failing that, to create a new Token you should first use one of the constructors that starts with null text. To load the token from a char[] use {@link #SetTermBuffer(char[], int, int)}. To load from a String use {@link #SetTermBuffer(String)} or {@link #SetTermBuffer(String, int, int)}. Alternatively you can get the Token's termBuffer by calling either {@link #TermBuffer()}, if you know that your text is shorter than the capacity of the termBuffer or {@link #ResizeTermBuffer(int)}, if there is any possibility that you may need to grow the buffer. Fill in the characters of your term into this buffer, with {@link String#getChars(int, int, char[], int)} if loading from a string, or with {@link System#arraycopy(Object, int, Object, int, int)}, and finally call {@link #SetTermLength(int)} to set the length of the term text. See LUCENE-969 for details.

Typical Token reuse patterns:

  • Copying text from a string (type is reset to {@link #DEFAULT_TYPE} if not specified):
                return reusableToken.reinit(string, startOffset, endOffset[, type]);
  • Copying some text from a string (type is reset to {@link #DEFAULT_TYPE} if not specified):
                return reusableToken.reinit(string, 0, string.length(), startOffset, endOffset[, type]);
  • Copying text from char[] buffer (type is reset to {@link #DEFAULT_TYPE} if not specified):
                return reusableToken.reinit(buffer, 0, buffer.length, startOffset, endOffset[, type]);
  • Copying some text from a char[] buffer (type is reset to {@link #DEFAULT_TYPE} if not specified):
                return reusableToken.reinit(buffer, start, end - start, startOffset, endOffset[, type]);
  • Copying from one one Token to another (type is reset to {@link #DEFAULT_TYPE} if not specified):
                return reusableToken.reinit(source.termBuffer(), 0, source.termLength(), source.startOffset(), source.endOffset()[, source.type()]);
A few things to note:
  • clear() initializes all of the fields to default values. This was changed in contrast to Lucene 2.4, but should affect no one.
  • Because
    CopyC#
    TokenStreams
     can be chained, one cannot assume that the
    CopyC#
    Token's
     current type is correct.
  • The startOffset and endOffset represent the start and offset in the source text, so be careful in adjusting them.
  • When caching a reusable token, clone it. When injecting a cached token into a stream that can be reset, clone it again.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class Token : AttributeImpl, ICloneable,
    TermAttribute, TypeAttribute, PositionIncrementAttribute, FlagsAttribute, OffsetAttribute,
    PayloadAttribute, Attribute
Visual Basic
<SerializableAttribute> _
Public Class Token _
    Inherits AttributeImpl _
    Implements ICloneable, TermAttribute, TypeAttribute, PositionIncrementAttribute,  _
    FlagsAttribute, OffsetAttribute, PayloadAttribute, Attribute
Visual C++
[SerializableAttribute]
public ref class Token : public AttributeImpl,
    ICloneable, TermAttribute, TypeAttribute, PositionIncrementAttribute, FlagsAttribute,
    OffsetAttribute, PayloadAttribute, Attribute

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis..::..Token

See Also

Token Members
Lucene.Net.Analysis Namespace
Lucene.Net.Index..::..Payload


Token Members

[image] [image]

Lucene.Net Class Libraries
Token Members
Token Class Constructors Methods Fields See Also Send Feedback

The Token type exposes the following members.

Constructors

 | Name | Description
Public method | Token()()()() | Constructs a Token will null text.
Public method | Token(Int32, Int32) | Constructs a Token with null text and start & end offsets.
Public method | Token(Int32, Int32, Int32) | Constructs a Token with null text and start & end offsets plus flags. NOTE: flags is EXPERIMENTAL.
Public method | Token(Int32, Int32, String) | Constructs a Token with null text and start & end offsets plus the Token type.
Public method | Token(String, Int32, Int32) | Constructs a Token with the given term text, and start & end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, Int32) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, String) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(array<Char>[]()[][], Int32, Int32, Int32, Int32) | Constructs a Token with the given term buffer (offset & length), start and end offsets

Methods

Name | Description
Public method Clear
Resets the term text, payload, flags, and positionIncrement, startOffset, endOffset and token type to default.
(Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone()()()() | (Overrides AttributeImpl..::..Clone()()()().)
Public method Clone(array<Char>[]()[][], Int32, Int32, Int32, Int32)
Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method EndOffset
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetFlags
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link #Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetPayload
Returns this Token's payload.
Public method GetPositionIncrement
Returns the position increment of this Token.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Reinit(Token)
Copy the prototype token's fields into this one. Note: Payloads are shared.
Public method Reinit(Token, String)
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method Reinit(String, Int32, Int32)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method Reinit(String, Int32, Int32, String)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}
Public method Reinit(Token, array<Char>[]()[][], Int32, Int32)
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method Reinit(array<Char>[]()[][], Int32, Int32, Int32, Int32)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method Reinit(String, Int32, Int32, Int32, Int32)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method Reinit(array<Char>[]()[][], Int32, Int32, Int32, Int32, String)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset}, {@link #setType}
Public method Reinit(String, Int32, Int32, Int32, Int32, String)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}
Public method ResizeTermBuffer
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.
Public method SetEndOffset
Set the ending offset.
Public method | SetFlags
Public method SetOffset
Set the starting and ending offset. See StartOffset() and EndOffset()
Public method SetPayload
Sets this Token's payload.
Public method SetPositionIncrement
Set the position increment. This determines the position of this token relative to the previous Token in a {@link TokenStream}, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public method SetStartOffset
Set the starting offset.
Public method SetTermBuffer(String)
Copies the contents of buffer into the termBuffer array.
Public method SetTermBuffer(array<Char>[]()[][], Int32, Int32)
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method SetTermBuffer(String, Int32, Int32)
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method SetTermLength
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.
Public method SetTermText Obsolete.
Sets the Token's term text. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method SetType
Set the lexical type.
Public method StartOffset
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Public method Term
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public method TermBuffer
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
Public method TermLength
Return number of valid characters (length of the term) in the termBuffer array.
Public method TermText
Returns the Token's term text.
Public method | ToString | (Overrides AttributeImpl..::..ToString()()()().)
Public method Type
Returns this Token's lexical type. Defaults to "word".

Fields

Name | Description
DEFAULT_TYPE |

See Also

Token Class
Lucene.Net.Analysis Namespace


Token Constructor

[image] [image]

Lucene.Net Class Libraries
Token Constructor
Token Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Token()()()() | Constructs a Token will null text.
Public method | Token(Int32, Int32) | Constructs a Token with null text and start & end offsets.
Public method | Token(Int32, Int32, Int32) | Constructs a Token with null text and start & end offsets plus flags. NOTE: flags is EXPERIMENTAL.
Public method | Token(Int32, Int32, String) | Constructs a Token with null text and start & end offsets plus the Token type.
Public method | Token(String, Int32, Int32) | Constructs a Token with the given term text, and start & end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, Int32) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(String, Int32, Int32, String) | Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method | Token(array<Char>[]()[][], Int32, Int32, Int32, Int32) | Constructs a Token with the given term buffer (offset & length), start and end offsets

See Also

Token Class
Token Members
Lucene.Net.Analysis Namespace


Token Constructor

[image]

Lucene.Net Class Libraries
Token Constructor
Token Class See Also Send Feedback
Constructs a Token will null text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token()
Visual Basic
Public Sub New
Visual C++
public:
Token()

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (Int32, Int32)

[image]

Lucene.Net Class Libraries
Token Constructor (Int32, Int32)
Token Class See Also Send Feedback
Constructs a Token with null text and start & end offsets.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    int start,
    int end
)
Visual Basic
Public Sub New ( _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
Token(
    int start,
    int end
)

Parameters

start
Type: System..::..Int32
start offset in the source text
end
Type: System..::..Int32
end offset in the source text

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token Constructor (Int32, Int32, Int32)
Token Class See Also Send Feedback
Constructs a Token with null text and start & end offsets plus flags. NOTE: flags is EXPERIMENTAL.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    int start,
    int end,
    int flags
)
Visual Basic
Public Sub New ( _
    start As Integer, _
    end As Integer, _
    flags As Integer _
)
Visual C++
public:
Token(
    int start,
    int end,
    int flags
)

Parameters

start
Type: System..::..Int32
start offset in the source text
end
Type: System..::..Int32
end offset in the source text
flags
Type: System..::..Int32
The bits to set for this token

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (Int32, Int32, String)

[image]

Lucene.Net Class Libraries
Token Constructor (Int32, Int32, String)
Token Class See Also Send Feedback
Constructs a Token with null text and start & end offsets plus the Token type.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    int start,
    int end,
    string typ
)
Visual Basic
Public Sub New ( _
    start As Integer, _
    end As Integer, _
    typ As String _
)
Visual C++
public:
Token(
    int start,
    int end,
    String^ typ
)

Parameters

start
Type: System..::..Int32
start offset in the source text
end
Type: System..::..Int32
end offset in the source text
typ
Type: System..::..String
the lexical type of this Token

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token Constructor (String, Int32, Int32)
Token Class See Also Send Feedback
Constructs a Token with the given term text, and start & end offsets. The type defaults to "word." NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    string text,
    int start,
    int end
)
Visual Basic
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
Token(
    String^ text,
    int start,
    int end
)

Parameters

text
Type: System..::..String
term text
start
Type: System..::..Int32
start offset
end
Type: System..::..Int32
end offset

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (String, Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token Constructor (String, Int32, Int32, Int32)
Token Class See Also Send Feedback
Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    string text,
    int start,
    int end,
    int flags
)
Visual Basic
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer, _
    flags As Integer _
)
Visual C++
public:
Token(
    String^ text,
    int start,
    int end,
    int flags
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

flags
Type: System..::..Int32
token type bits

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (String, Int32, Int32, String)

[image]

Lucene.Net Class Libraries
Token Constructor (String, Int32, Int32, String)
Token Class See Also Send Feedback
Constructs a Token with the given text, start and end offsets, & type. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    string text,
    int start,
    int end,
    string typ
)
Visual Basic
Public Sub New ( _
    text As String, _
    start As Integer, _
    end As Integer, _
    typ As String _
)
Visual C++
public:
Token(
    String^ text,
    int start,
    int end,
    String^ typ
)

Parameters

text
Type: System..::..String
term text
start
Type: System..::..Int32
start offset
end
Type: System..::..Int32
end offset
typ
Type: System..::..String
token type

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Constructor (Char[], Int32, Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token Constructor (array<Char>[]()[][], Int32, Int32, Int32, Int32)
Token Class See Also Send Feedback
Constructs a Token with the given term buffer (offset & length), start and end offsets

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    char[] startTermBuffer,
    int termBufferOffset,
    int termBufferLength,
    int start,
    int end
)
Visual Basic
Public Sub New ( _
    startTermBuffer As Char(), _
    termBufferOffset As Integer, _
    termBufferLength As Integer, _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
Token(
    array<wchar_t>^ startTermBuffer,
    int termBufferOffset,
    int termBufferLength,
    int start,
    int end
)

Parameters

startTermBuffer
Type: array< System..::..Char >[]()[][]

[Missing <param name="startTermBuffer"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

termBufferOffset
Type: System..::..Int32

[Missing <param name="termBufferOffset"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

termBufferLength
Type: System..::..Int32

[Missing <param name="termBufferLength"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Analysis.Token.#ctor(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Token Class
Token Overload
Lucene.Net.Analysis Namespace


Token Fields

[image] [image]

Lucene.Net Class Libraries
Token Fields
Token Class See Also Send Feedback

The Token type exposes the following members.

Fields

Name | Description
DEFAULT_TYPE |

See Also

Token Class
Lucene.Net.Analysis Namespace


DEFAULT_TYPE Field

[image]

Lucene.Net Class Libraries
Token..::..DEFAULT_TYPE Field
Token Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Token.DEFAULT_TYPE"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string DEFAULT_TYPE
Visual Basic
Public Const DEFAULT_TYPE As String
Visual C++
public:
literal String^ DEFAULT_TYPE

See Also

Token Class
Lucene.Net.Analysis Namespace


Token Methods

[image] [image]

Lucene.Net Class Libraries
Token Methods
Token Class See Also Send Feedback

The Token type exposes the following members.

Methods

Name | Description
Public method Clear
Resets the term text, payload, flags, and positionIncrement, startOffset, endOffset and token type to default.
(Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone()()()() | (Overrides AttributeImpl..::..Clone()()()().)
Public method Clone(array<Char>[]()[][], Int32, Int32, Int32, Int32)
Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method EndOffset
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetFlags
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link #Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetPayload
Returns this Token's payload.
Public method GetPositionIncrement
Returns the position increment of this Token.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Reinit(Token)
Copy the prototype token's fields into this one. Note: Payloads are shared.
Public method Reinit(Token, String)
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method Reinit(String, Int32, Int32)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method Reinit(String, Int32, Int32, String)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}
Public method Reinit(Token, array<Char>[]()[][], Int32, Int32)
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method Reinit(array<Char>[]()[][], Int32, Int32, Int32, Int32)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method Reinit(String, Int32, Int32, Int32, Int32)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method Reinit(array<Char>[]()[][], Int32, Int32, Int32, Int32, String)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset}, {@link #setType}
Public method Reinit(String, Int32, Int32, Int32, Int32, String)
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}
Public method ResizeTermBuffer
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.
Public method SetEndOffset
Set the ending offset.
Public method | SetFlags
Public method SetOffset
Set the starting and ending offset. See StartOffset() and EndOffset()
Public method SetPayload
Sets this Token's payload.
Public method SetPositionIncrement
Set the position increment. This determines the position of this token relative to the previous Token in a {@link TokenStream}, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public method SetStartOffset
Set the starting offset.
Public method SetTermBuffer(String)
Copies the contents of buffer into the termBuffer array.
Public method SetTermBuffer(array<Char>[]()[][], Int32, Int32)
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method SetTermBuffer(String, Int32, Int32)
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method SetTermLength
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.
Public method SetTermText Obsolete.
Sets the Token's term text. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.
Public method SetType
Set the lexical type.
Public method StartOffset
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Public method Term
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public method TermBuffer
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
Public method TermLength
Return number of valid characters (length of the term) in the termBuffer array.
Public method TermText
Returns the Token's term text.
Public method | ToString | (Overrides AttributeImpl..::..ToString()()()().)
Public method Type
Returns this Token's lexical type. Defaults to "word".

See Also

Token Class
Lucene.Net.Analysis Namespace


Clear Method

[image]

Lucene.Net Class Libraries
Token..::..Clear Method
Token Class See Also Send Feedback
Resets the term text, payload, flags, and positionIncrement, startOffset, endOffset and token type to default.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

Token Class
Lucene.Net.Analysis Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
Token..::..Clone Method
Token Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Overrides AttributeImpl..::..Clone()()()().)
Public method | Clone(array<Char>[]()[][], Int32, Int32, Int32, Int32) | Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.

See Also

Token Class
Token Members
Lucene.Net.Analysis Namespace


Clone Method

[image]

Lucene.Net Class Libraries
Token..::..Clone Method
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Token.Clone"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

Token Class
Clone Overload
Lucene.Net.Analysis Namespace


Clone Method (Char[], Int32, Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..Clone Method (array<Char>[]()[][], Int32, Int32, Int32, Int32)
Token Class See Also Send Feedback
Makes a clone, but replaces the term buffer & start/end offset in the process. This is more efficient than doing a full clone (and then calling setTermBuffer) because it saves a wasted copy of the old termBuffer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Clone(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Visual Basic
Public Overridable Function Clone ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Visual C++
public:
virtual Token^ Clone(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)

Parameters

newTermBuffer
Type: array< System..::..Char >[]()[][]

[Missing <param name="newTermBuffer"/> documentation for "M:Lucene.Net.Analysis.Token.Clone(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newTermOffset
Type: System..::..Int32

[Missing <param name="newTermOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Clone(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newTermLength
Type: System..::..Int32

[Missing <param name="newTermLength"/> documentation for "M:Lucene.Net.Analysis.Token.Clone(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Clone(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Clone(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.Clone(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Token Class
Clone Overload
Lucene.Net.Analysis Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
Token..::..CopyTo Method
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Token.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Token.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

Token Class
Lucene.Net.Analysis Namespace


EndOffset Method

[image]

Lucene.Net Class Libraries
Token..::..EndOffset Method
Token Class See Also Send Feedback
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int EndOffset()
Visual Basic
Public Function EndOffset As Integer
Visual C++
public:
virtual int EndOffset() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.EndOffset"]

Implements

OffsetAttribute..::..EndOffset()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Token..::..Equals Method
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Token.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Analysis.Token.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.Equals(System.Object)"]

See Also

Token Class
Lucene.Net.Analysis Namespace


GetFlags Method

[image]

Lucene.Net Class Libraries
Token..::..GetFlags Method
Token Class See Also Send Feedback
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link #Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetFlags()
Visual Basic
Public Overridable Function GetFlags As Integer
Visual C++
public:
virtual int GetFlags()

Return Value

The bits

Implements

FlagsAttribute..::..GetFlags()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Token..::..GetHashCode Method
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Token.GetHashCode"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.GetHashCode"]

See Also

Token Class
Lucene.Net.Analysis Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
Token..::..GetPayload Method
Token Class See Also Send Feedback
Returns this Token's payload.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Payload GetPayload()
Visual Basic
Public Overridable Function GetPayload As Payload
Visual C++
public:
virtual Payload^ GetPayload()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.GetPayload"]

Implements

PayloadAttribute..::..GetPayload()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


GetPositionIncrement Method

[image]

Lucene.Net Class Libraries
Token..::..GetPositionIncrement Method
Token Class See Also Send Feedback
Returns the position increment of this Token.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPositionIncrement()
Visual Basic
Public Overridable Function GetPositionIncrement As Integer
Visual C++
public:
virtual int GetPositionIncrement()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.GetPositionIncrement"]

Implements

PositionIncrementAttribute..::..GetPositionIncrement()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace
[!:setPositionIncrement]


Reinit Method

[image] [image]

Lucene.Net Class Libraries
Token..::..Reinit Method
Token Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reinit(Token) | Copy the prototype token's fields into this one. Note: Payloads are shared.
Public method | Reinit(Token, String) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit(String, Int32, Int32) | Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, String) | Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}
Public method | Reinit(Token, array<Char>[]()[][], Int32, Int32) | Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.
Public method | Reinit(array<Char>[]()[][], Int32, Int32, Int32, Int32) | Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method | Reinit(String, Int32, Int32, Int32, Int32) | Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE
Public method | Reinit(array<Char>[]()[][], Int32, Int32, Int32, Int32, String) | Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset}, {@link #setType}
Public method | Reinit(String, Int32, Int32, Int32, Int32, String) | Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}

See Also

Token Class
Token Members
Lucene.Net.Analysis Namespace


Reinit Method (Token)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (Token)
Token Class See Also Send Feedback
Copy the prototype token's fields into this one. Note: Payloads are shared.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reinit(
    Token prototype
)
Visual Basic
Public Overridable Sub Reinit ( _
    prototype As Token _
)
Visual C++
public:
virtual void Reinit(
    Token^ prototype
)

Parameters

prototype
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="prototype"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token)"]

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (Token, String)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (Token, String)
Token Class See Also Send Feedback
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reinit(
    Token prototype,
    string newTerm
)
Visual Basic
Public Overridable Sub Reinit ( _
    prototype As Token, _
    newTerm As String _
)
Visual C++
public:
virtual void Reinit(
    Token^ prototype,
    String^ newTerm
)

Parameters

prototype
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="prototype"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token,System.String)"]

newTerm
Type: System..::..String

[Missing <param name="newTerm"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token,System.String)"]

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (String, Int32, Int32)
Token Class See Also Send Feedback
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Reinit(
    string newTerm,
    int newStartOffset,
    int newEndOffset
)
Visual Basic
Public Overridable Function Reinit ( _
    newTerm As String, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Visual C++
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newStartOffset,
    int newEndOffset
)

Parameters

newTerm
Type: System..::..String

[Missing <param name="newTerm"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32)"]

Return Value

this Token instance

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (String, Int32, Int32, String)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (String, Int32, Int32, String)
Token Class See Also Send Feedback
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Reinit(
    string newTerm,
    int newStartOffset,
    int newEndOffset,
    string newType
)
Visual Basic
Public Overridable Function Reinit ( _
    newTerm As String, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
Visual C++
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)

Parameters

newTerm
Type: System..::..String

[Missing <param name="newTerm"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.String)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.String)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.String)"]

newType
Type: System..::..String

[Missing <param name="newType"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.String)"]

Return Value

this Token instance

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (Token, Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (Token, array<Char>[]()[][], Int32, Int32)
Token Class See Also Send Feedback
Copy the prototype token's fields into this one, with a different term. Note: Payloads are shared.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reinit(
    Token prototype,
    char[] newTermBuffer,
    int offset,
    int length
)
Visual Basic
Public Overridable Sub Reinit ( _
    prototype As Token, _
    newTermBuffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void Reinit(
    Token^ prototype,
    array<wchar_t>^ newTermBuffer,
    int offset,
    int length
)

Parameters

prototype
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="prototype"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token,System.Char[],System.Int32,System.Int32)"]

newTermBuffer
Type: array< System..::..Char >[]()[][]

[Missing <param name="newTermBuffer"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token,System.Char[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token,System.Char[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(Lucene.Net.Analysis.Token,System.Char[],System.Int32,System.Int32)"]

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (Char[], Int32, Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (array<Char>[]()[][], Int32, Int32, Int32, Int32)
Token Class See Also Send Feedback
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Reinit(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Visual Basic
Public Overridable Function Reinit ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Visual C++
public:
virtual Token^ Reinit(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)

Parameters

newTermBuffer
Type: array< System..::..Char >[]()[][]

[Missing <param name="newTermBuffer"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newTermOffset
Type: System..::..Int32

[Missing <param name="newTermOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newTermLength
Type: System..::..Int32

[Missing <param name="newTermLength"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

this Token instance

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (String, Int32, Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (String, Int32, Int32, Int32, Int32)
Token Class See Also Send Feedback
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType} on Token.DEFAULT_TYPE

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Reinit(
    string newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)
Visual Basic
Public Overridable Function Reinit ( _
    newTerm As String, _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer _
) As Token
Visual C++
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset
)

Parameters

newTerm
Type: System..::..String

[Missing <param name="newTerm"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

newTermOffset
Type: System..::..Int32

[Missing <param name="newTermOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

newTermLength
Type: System..::..Int32

[Missing <param name="newTermLength"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

this Token instance

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (Char[], Int32, Int32, Int32, Int32, String)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (array<Char>[]()[][], Int32, Int32, Int32, Int32, String)
Token Class See Also Send Feedback
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(char[], int, int)}, {@link #setStartOffset}, {@link #setEndOffset}, {@link #setType}

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Reinit(
    char[] newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    string newType
)
Visual Basic
Public Overridable Function Reinit ( _
    newTermBuffer As Char(), _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
Visual C++
public:
virtual Token^ Reinit(
    array<wchar_t>^ newTermBuffer,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)

Parameters

newTermBuffer
Type: array< System..::..Char >[]()[][]

[Missing <param name="newTermBuffer"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newTermOffset
Type: System..::..Int32

[Missing <param name="newTermOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newTermLength
Type: System..::..Int32

[Missing <param name="newTermLength"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newType
Type: System..::..String

[Missing <param name="newType"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.Char[],System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

Return Value

this Token instance

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


Reinit Method (String, Int32, Int32, Int32, Int32, String)

[image]

Lucene.Net Class Libraries
Token..::..Reinit Method (String, Int32, Int32, Int32, Int32, String)
Token Class See Also Send Feedback
Shorthand for calling {@link #clear}, {@link #SetTermBuffer(String, int, int)}, {@link #setStartOffset}, {@link #setEndOffset} {@link #setType}

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token Reinit(
    string newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    string newType
)
Visual Basic
Public Overridable Function Reinit ( _
    newTerm As String, _
    newTermOffset As Integer, _
    newTermLength As Integer, _
    newStartOffset As Integer, _
    newEndOffset As Integer, _
    newType As String _
) As Token
Visual C++
public:
virtual Token^ Reinit(
    String^ newTerm,
    int newTermOffset,
    int newTermLength,
    int newStartOffset,
    int newEndOffset,
    String^ newType
)

Parameters

newTerm
Type: System..::..String

[Missing <param name="newTerm"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newTermOffset
Type: System..::..Int32

[Missing <param name="newTermOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newTermLength
Type: System..::..Int32

[Missing <param name="newTermLength"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newStartOffset
Type: System..::..Int32

[Missing <param name="newStartOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newEndOffset
Type: System..::..Int32

[Missing <param name="newEndOffset"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

newType
Type: System..::..String

[Missing <param name="newType"/> documentation for "M:Lucene.Net.Analysis.Token.Reinit(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.String)"]

Return Value

this Token instance

See Also

Token Class
Reinit Overload
Lucene.Net.Analysis Namespace


ResizeTermBuffer Method

[image]

Lucene.Net Class Libraries
Token..::..ResizeTermBuffer Method
Token Class See Also Send Feedback
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual char[] ResizeTermBuffer(
    int newSize
)
Visual Basic
Public Overridable Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Visual C++
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
)

Parameters

newSize
Type: System..::..Int32
minimum size of the new termBuffer

Return Value

newly created termBuffer with length >= newSize

Implements

TermAttribute..::..ResizeTermBuffer(Int32)

See Also

Token Class
Lucene.Net.Analysis Namespace


SetEndOffset Method

[image]

Lucene.Net Class Libraries
Token..::..SetEndOffset Method
Token Class See Also Send Feedback
Set the ending offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetEndOffset(
    int offset
)
Visual Basic
Public Overridable Sub SetEndOffset ( _
    offset As Integer _
)
Visual C++
public:
virtual void SetEndOffset(
    int offset
)

Parameters

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analysis.Token.SetEndOffset(System.Int32)"]

See Also

Token Class
Lucene.Net.Analysis Namespace
Token..::..EndOffset()()()()


SetFlags Method

[image]

Lucene.Net Class Libraries
Token..::..SetFlags Method
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Token.SetFlags(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetFlags(
    int flags
)
Visual Basic
Public Overridable Sub SetFlags ( _
    flags As Integer _
)
Visual C++
public:
virtual void SetFlags(
    int flags
)

Parameters

flags
Type: System..::..Int32

[Missing <param name="flags"/> documentation for "M:Lucene.Net.Analysis.Token.SetFlags(System.Int32)"]

Implements

FlagsAttribute..::..SetFlags(Int32)

See Also

Token Class
Lucene.Net.Analysis Namespace
Token..::..GetFlags()()()()


SetOffset Method

[image]

Lucene.Net Class Libraries
Token..::..SetOffset Method
Token Class See Also Send Feedback
Set the starting and ending offset. See StartOffset() and EndOffset()

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetOffset(
    int startOffset,
    int endOffset
)
Visual Basic
Public Overridable Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Visual C++
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Analysis.Token.SetOffset(System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Analysis.Token.SetOffset(System.Int32,System.Int32)"]

Implements

OffsetAttribute..::..SetOffset(Int32, Int32)

See Also

Token Class
Lucene.Net.Analysis Namespace


SetPayload Method

[image]

Lucene.Net Class Libraries
Token..::..SetPayload Method
Token Class See Also Send Feedback
Sets this Token's payload.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetPayload(
    Payload payload
)
Visual Basic
Public Overridable Sub SetPayload ( _
    payload As Payload _
)
Visual C++
public:
virtual void SetPayload(
    Payload^ payload
)

Parameters

payload
Type: Lucene.Net.Index..::..Payload

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analysis.Token.SetPayload(Lucene.Net.Index.Payload)"]

Implements

PayloadAttribute..::..SetPayload(Payload)

See Also

Token Class
Lucene.Net.Analysis Namespace


SetPositionIncrement Method

[image]

Lucene.Net Class Libraries
Token..::..SetPositionIncrement Method
Token Class See Also Send Feedback
Set the position increment. This determines the position of this token relative to the previous Token in a {@link TokenStream}, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetPositionIncrement(
    int positionIncrement
)
Visual Basic
Public Overridable Sub SetPositionIncrement ( _
    positionIncrement As Integer _
)
Visual C++
public:
virtual void SetPositionIncrement(
    int positionIncrement
)

Parameters

positionIncrement
Type: System..::..Int32
the distance from the prior term

Implements

PositionIncrementAttribute..::..SetPositionIncrement(Int32)

See Also

Token Class
Lucene.Net.Analysis Namespace
Lucene.Net.Index..::..TermPositions


SetStartOffset Method

[image]

Lucene.Net Class Libraries
Token..::..SetStartOffset Method
Token Class See Also Send Feedback
Set the starting offset.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetStartOffset(
    int offset
)
Visual Basic
Public Overridable Sub SetStartOffset ( _
    offset As Integer _
)
Visual C++
public:
virtual void SetStartOffset(
    int offset
)

Parameters

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analysis.Token.SetStartOffset(System.Int32)"]

See Also

Token Class
Lucene.Net.Analysis Namespace
Token..::..StartOffset()()()()


SetTermBuffer Method

[image] [image]

Lucene.Net Class Libraries
Token..::..SetTermBuffer Method
Token Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

See Also

Token Class
Token Members
Lucene.Net.Analysis Namespace


SetTermBuffer Method (String)

[image]

Lucene.Net Class Libraries
Token..::..SetTermBuffer Method (String)
Token Class See Also Send Feedback
Copies the contents of buffer into the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermBuffer(
    string buffer
)
Visual Basic
Public Sub SetTermBuffer ( _
    buffer As String _
)
Visual C++
public:
virtual void SetTermBuffer(
    String^ buffer
) sealed

Parameters

buffer
Type: System..::..String
the buffer to copy

Implements

TermAttribute..::..SetTermBuffer(String)

See Also

Token Class
SetTermBuffer Overload
Lucene.Net.Analysis Namespace


SetTermBuffer Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..SetTermBuffer Method (array<Char>[]()[][], Int32, Int32)
Token Class See Also Send Feedback
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Visual Basic
Public Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
) sealed

Parameters

buffer
Type: array< System..::..Char >[]()[][]
the buffer to copy
offset
Type: System..::..Int32
the index in the buffer of the first character to copy
length
Type: System..::..Int32
the number of characters to copy

Implements

TermAttribute..::..SetTermBuffer(array<Char>[]()[][], Int32, Int32)

See Also

Token Class
SetTermBuffer Overload
Lucene.Net.Analysis Namespace


SetTermBuffer Method (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
Token..::..SetTermBuffer Method (String, Int32, Int32)
Token Class See Also Send Feedback
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Visual Basic
Public Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
) sealed

Parameters

buffer
Type: System..::..String
the buffer to copy
offset
Type: System..::..Int32
the index in the buffer of the first character to copy
length
Type: System..::..Int32
the number of characters to copy

Implements

TermAttribute..::..SetTermBuffer(String, Int32, Int32)

See Also

Token Class
SetTermBuffer Overload
Lucene.Net.Analysis Namespace


SetTermLength Method

[image]

Lucene.Net Class Libraries
Token..::..SetTermLength Method
Token Class See Also Send Feedback
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermLength(
    int length
)
Visual Basic
Public Sub SetTermLength ( _
    length As Integer _
)
Visual C++
public:
virtual void SetTermLength(
    int length
) sealed

Parameters

length
Type: System..::..Int32
the truncated length

Implements

TermAttribute..::..SetTermLength(Int32)

See Also

Token Class
Lucene.Net.Analysis Namespace


SetTermText Method

[image]

Lucene.Net Class Libraries
Token..::..SetTermText Method
Token Class See Also Send Feedback
Sets the Token's term text. NOTE: for better indexing speed you should instead use the char[] termBuffer methods to set the term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use SetTermBuffer(char[], int, int) or SetTermBuffer(String) or SetTermBuffer(String, int, int)")]
public virtual void SetTermText(
    string text
)
Visual Basic
<ObsoleteAttribute("Use SetTermBuffer(char[], int, int) or SetTermBuffer(String) or SetTermBuffer(String, int, int)")> _
Public Overridable Sub SetTermText ( _
    text As String _
)
Visual C++
[ObsoleteAttribute(L"Use SetTermBuffer(char[], int, int) or SetTermBuffer(String) or SetTermBuffer(String, int, int)")]
public:
virtual void SetTermText(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Lucene.Net.Analysis.Token.SetTermText(System.String)"]

See Also

Token Class
Lucene.Net.Analysis Namespace


SetType Method

[image]

Lucene.Net Class Libraries
Token..::..SetType Method
Token Class See Also Send Feedback
Set the lexical type.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetType(
    string type
)
Visual Basic
Public Sub SetType ( _
    type As String _
)
Visual C++
public:
virtual void SetType(
    String^ type
) sealed

Parameters

type
Type: System..::..String

[Missing <param name="type"/> documentation for "M:Lucene.Net.Analysis.Token.SetType(System.String)"]

Implements

TypeAttribute..::..SetType(String)

See Also

Token Class
Lucene.Net.Analysis Namespace
Token..::..Type()()()()


StartOffset Method

[image]

Lucene.Net Class Libraries
Token..::..StartOffset Method
Token Class See Also Send Feedback
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int StartOffset()
Visual Basic
Public Function StartOffset As Integer
Visual C++
public:
virtual int StartOffset() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.StartOffset"]

Implements

OffsetAttribute..::..StartOffset()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


Term Method

[image]

Lucene.Net Class Libraries
Token..::..Term Method
Token Class See Also Send Feedback
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Term()
Visual Basic
Public Function Term As String
Visual C++
public:
virtual String^ Term() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.Term"]

Implements

TermAttribute..::..Term()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


TermBuffer Method

[image]

Lucene.Net Class Libraries
Token..::..TermBuffer Method
Token Class See Also Send Feedback
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char[] TermBuffer()
Visual Basic
Public Function TermBuffer As Char()
Visual C++
public:
virtual array<wchar_t>^ TermBuffer() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.TermBuffer"]

Implements

TermAttribute..::..TermBuffer()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


TermLength Method

[image]

Lucene.Net Class Libraries
Token..::..TermLength Method
Token Class See Also Send Feedback
Return number of valid characters (length of the term) in the termBuffer array.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int TermLength()
Visual Basic
Public Function TermLength As Integer
Visual C++
public:
virtual int TermLength() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.TermLength"]

Implements

TermAttribute..::..TermLength()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


TermText Method

[image]

Lucene.Net Class Libraries
Token..::..TermText Method
Token Class See Also Send Feedback
Returns the Token's term text.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string TermText()
Visual Basic
Public Function TermText As String
Visual C++
public:
String^ TermText()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.TermText"]

See Also

Token Class
Lucene.Net.Analysis Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Token..::..ToString Method
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Token.ToString"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.ToString"]

See Also

Token Class
Lucene.Net.Analysis Namespace


Type Method

[image]

Lucene.Net Class Libraries
Token..::..Type Method
Token Class See Also Send Feedback
Returns this Token's lexical type. Defaults to "word".

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Type()
Visual Basic
Public Function Type As String
Visual C++
public:
virtual String^ Type() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Token.Type"]

Implements

TypeAttribute..::..Type()()()()

See Also

Token Class
Lucene.Net.Analysis Namespace


TokenFilter Class

[image]

Lucene.Net Class Libraries
TokenFilter Class
Members See Also Send Feedback
A TokenFilter is a TokenStream whose input is another TokenStream.

This is an abstract class; subclasses must override {@link #IncrementToken()}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TokenFilter : TokenStream
Visual Basic
Public MustInherit Class TokenFilter _
    Inherits TokenStream
Visual C++
public ref class TokenFilter abstract : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.AR..::..ArabicNormalizationFilter
Lucene.Net.Analysis.AR..::..ArabicStemFilter
Lucene.Net.Analysis..::..ASCIIFoldingFilter
Lucene.Net.Analysis.BR..::..BrazilianStemFilter
Lucene.Net.Analysis..::..CachingTokenFilter
Lucene.Net.Analysis.Cn..::..ChineseFilter
Lucene.Net.Analysis.De..::..GermanStemFilter
Lucene.Net.Analysis.Fr..::..FrenchStemFilter
Lucene.Net.Analysis..::..ISOLatin1AccentFilter
Lucene.Net.Analysis..::..LengthFilter
Lucene.Net.Analysis..::..LowerCaseFilter
Lucene.Net.Analysis.NGram..::..EdgeNGramTokenFilter
Lucene.Net.Analysis.NGram..::..NGramTokenFilter
Lucene.Net.Analysis.Nl..::..DutchStemFilter
Lucene.Net.Analysis..::..PorterStemFilter
Lucene.Net.Analysis.Ru..::..RussianLowerCaseFilter
Lucene.Net.Analysis.Ru..::..RussianStemFilter
Lucene.Net.Analysis.Snowball..::..SnowballFilter
Lucene.Net.Analysis.Standard..::..StandardFilter
Lucene.Net.Analysis..::..StopFilter
Lucene.Net.Analysis..::..TeeSinkTokenFilter
Lucene.Net.Analysis..::..TeeTokenFilter
Lucene.Net.Analyzers.Shingle..::..ShingleFilter

See Also

TokenFilter Members
Lucene.Net.Analysis Namespace
Lucene.Net.Analysis..::..TokenStream


TokenFilter Members

[image] [image]

Lucene.Net Class Libraries
TokenFilter Members
TokenFilter Class Constructors Methods Fields See Also Send Feedback

The TokenFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | TokenFilter | Construct a token stream filtering the given input.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Overrides TokenStream..::..Close()()()().)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter.

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


TokenFilter Constructor

[image]

Lucene.Net Class Libraries
TokenFilter Constructor
TokenFilter Class See Also Send Feedback
Construct a token stream filtering the given input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TokenFilter(
    TokenStream input
)
Visual Basic
Protected Friend Sub New ( _
    input As TokenStream _
)
Visual C++
protected public:
TokenFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.TokenFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


TokenFilter Fields

[image] [image]

Lucene.Net Class Libraries
TokenFilter Fields
TokenFilter Class See Also Send Feedback

The TokenFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter.

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


input Field

[image]

Lucene.Net Class Libraries
TokenFilter..::..input Field
TokenFilter Class See Also Send Feedback
The source of tokens for this filter.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TokenStream input
Visual Basic
Protected Friend input As TokenStream
Visual C++
protected public:
TokenStream^ input

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


TokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
TokenFilter Methods
TokenFilter Class See Also Send Feedback

The TokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Overrides TokenStream..::..Close()()()().)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
TokenFilter..::..Close Method
TokenFilter Class See Also Send Feedback
Close the input TokenStream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
TokenFilter..::..End Method
TokenFilter Class See Also Send Feedback
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
TokenFilter..::..Next Method
TokenFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

TokenFilter Class
TokenFilter Members
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
TokenFilter..::..Reset Method
TokenFilter Class See Also Send Feedback
Reset the filter as well as the input TokenStream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

TokenFilter Class
Lucene.Net.Analysis Namespace


Tokenizer Class

[image]

Lucene.Net Class Libraries
Tokenizer Class
Members See Also Send Feedback
A Tokenizer is a TokenStream whose input is a Reader.

This is an abstract class; subclasses must override {@link #IncrementToken()}

NOTE: Subclasses overriding {@link #next(Token)} must call
{@link AttributeSource#ClearAttributes()} before setting attributes.
Subclasses overriding {@link #IncrementToken()} must call
{@link Token#Clear()} before setting Token attributes.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Tokenizer : TokenStream
Visual Basic
Public MustInherit Class Tokenizer _
    Inherits TokenStream
Visual C++
public ref class Tokenizer abstract : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis.CJK..::..CJKTokenizer
Lucene.Net.Analysis.Cn..::..ChineseTokenizer
Lucene.Net.Analysis..::..KeywordTokenizer
Lucene.Net.Analysis.NGram..::..EdgeNGramTokenizer
Lucene.Net.Analysis.NGram..::..NGramTokenizer
Lucene.Net.Analysis..::..SinkTokenizer
Lucene.Net.Analysis.Standard..::..StandardTokenizer

See Also

Tokenizer Members
Lucene.Net.Analysis Namespace


Tokenizer Members

[image] [image]

Lucene.Net Class Libraries
Tokenizer Members
Tokenizer Class Constructors Methods Fields See Also Send Feedback

The Tokenizer type exposes the following members.

Constructors

 | Name | Description
Protected method | Tokenizer()()()() | Construct a tokenizer with null input.
Protected method | Tokenizer(TextReader) | Construct a token stream processing the given input.
Protected method | Tokenizer(AttributeSource) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource..::..AttributeFactory) | Construct a tokenizer with null input using the given AttributeFactory.
Protected method | Tokenizer(AttributeSource, TextReader) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a token stream processing the given input using the given AttributeFactory.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Overrides TokenStream..::..Close()()()().)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer.

See Also

Tokenizer Class
Lucene.Net.Analysis Namespace


Tokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
Tokenizer Constructor
Tokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Tokenizer()()()() | Construct a tokenizer with null input.
Protected method | Tokenizer(TextReader) | Construct a token stream processing the given input.
Protected method | Tokenizer(AttributeSource) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource..::..AttributeFactory) | Construct a tokenizer with null input using the given AttributeFactory.
Protected method | Tokenizer(AttributeSource, TextReader) | Construct a token stream processing the given input using the given AttributeSource.
Protected method | Tokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a token stream processing the given input using the given AttributeFactory.

See Also

Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace


Tokenizer Constructor

[image]

Lucene.Net Class Libraries
Tokenizer Constructor
Tokenizer Class See Also Send Feedback
Construct a tokenizer with null input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Tokenizer()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
Tokenizer()

See Also

Tokenizer Class
Tokenizer Overload
Lucene.Net.Analysis Namespace


Tokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
Tokenizer Constructor (TextReader)
Tokenizer Class See Also Send Feedback
Construct a token stream processing the given input.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Tokenizer(
    TextReader input
)
Visual Basic
Protected Friend Sub New ( _
    input As TextReader _
)
Visual C++
protected public:
Tokenizer(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(System.IO.TextReader)"]

See Also

Tokenizer Class
Tokenizer Overload
Lucene.Net.Analysis Namespace


Tokenizer Constructor (AttributeSource)

[image]

Lucene.Net Class Libraries
Tokenizer Constructor (AttributeSource)
Tokenizer Class See Also Send Feedback
Construct a token stream processing the given input using the given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Tokenizer(
    AttributeSource source
)
Visual Basic
Protected Friend Sub New ( _
    source As AttributeSource _
)
Visual C++
protected public:
Tokenizer(
    AttributeSource^ source
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(Lucene.Net.Util.AttributeSource)"]

See Also

Tokenizer Class
Tokenizer Overload
Lucene.Net.Analysis Namespace


Tokenizer Constructor (AttributeSource.AttributeFactory)

[image]

Lucene.Net Class Libraries
Tokenizer Constructor (AttributeSource..::..AttributeFactory)
Tokenizer Class See Also Send Feedback
Construct a tokenizer with null input using the given AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Tokenizer(
    AttributeSource..::..AttributeFactory factory
)
Visual Basic
Protected Friend Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
Visual C++
protected public:
Tokenizer(
    AttributeSource..::..AttributeFactory^ factory
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory)"]

See Also

Tokenizer Class
Tokenizer Overload
Lucene.Net.Analysis Namespace


Tokenizer Constructor (AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
Tokenizer Constructor (AttributeSource, TextReader)
Tokenizer Class See Also Send Feedback
Construct a token stream processing the given input using the given AttributeSource.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Tokenizer(
    AttributeSource source,
    TextReader input
)
Visual Basic
Protected Friend Sub New ( _
    source As AttributeSource, _
    input As TextReader _
)
Visual C++
protected public:
Tokenizer(
    AttributeSource^ source,
    TextReader^ input
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

Tokenizer Class
Tokenizer Overload
Lucene.Net.Analysis Namespace


Tokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
Tokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader)
Tokenizer Class See Also Send Feedback
Construct a token stream processing the given input using the given AttributeFactory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Tokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
Visual Basic
Protected Friend Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
Visual C++
protected public:
Tokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

Tokenizer Class
Tokenizer Overload
Lucene.Net.Analysis Namespace


Tokenizer Fields

[image] [image]

Lucene.Net Class Libraries
Tokenizer Fields
Tokenizer Class See Also Send Feedback

The Tokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer.

See Also

Tokenizer Class
Lucene.Net.Analysis Namespace


input Field

[image]

Lucene.Net Class Libraries
Tokenizer..::..input Field
Tokenizer Class See Also Send Feedback
The text source for this Tokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TextReader input
Visual Basic
Protected Friend input As TextReader
Visual C++
protected public:
TextReader^ input

See Also

Tokenizer Class
Lucene.Net.Analysis Namespace


Tokenizer Methods

[image] [image]

Lucene.Net Class Libraries
Tokenizer Methods
Tokenizer Class See Also Send Feedback

The Tokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Overrides TokenStream..::..Close()()()().)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

Tokenizer Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
Tokenizer..::..Close Method
Tokenizer Class See Also Send Feedback
By default, closes the input Reader.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

Tokenizer Class
Lucene.Net.Analysis Namespace


CorrectOffset Method

[image]

Lucene.Net Class Libraries
Tokenizer..::..CorrectOffset Method
Tokenizer Class See Also Send Feedback
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int CorrectOffset(
    int currentOff
)
Visual Basic
Protected Friend Function CorrectOffset ( _
    currentOff As Integer _
) As Integer
Visual C++
protected public:
int CorrectOffset(
    int currentOff
)

Parameters

currentOff
Type: System..::..Int32
offset as seen in the output

Return Value

corrected offset based on the input

See Also

Tokenizer Class
Lucene.Net.Analysis Namespace
CharStream..::..CorrectOffset(Int32)


Next Method

[image] [image]

Lucene.Net Class Libraries
Tokenizer..::..Next Method
Tokenizer Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
Tokenizer..::..Reset Method
Tokenizer Class See Also Send Feedback

Overload List

Name Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.

See Also

Tokenizer Class
Tokenizer Members
Lucene.Net.Analysis Namespace


Reset Method (TextReader)

[image]

Lucene.Net Class Libraries
Tokenizer..::..Reset Method (TextReader)
Tokenizer Class See Also Send Feedback
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reset(
    TextReader input
)
Visual Basic
Public Overridable Sub Reset ( _
    input As TextReader _
)
Visual C++
public:
virtual void Reset(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Tokenizer.Reset(System.IO.TextReader)"]

See Also

Tokenizer Class
Reset Overload
Lucene.Net.Analysis Namespace


TokenStream Class

[image]

Lucene.Net Class Libraries
TokenStream Class
Members See Also Send Feedback
A
CopyC#
TokenStream
 enumerates the sequence of tokens, either from {@link Field}s of a {@link Document} or from query text.

This is an abstract class. Concrete subclasses are:

  • {@link Tokenizer}, a
    CopyC#
    TokenStream
     whose input is a Reader; and
  • {@link TokenFilter}, a
    CopyC#
    TokenStream
     whose input is another
    CopyC#
    TokenStream
    .
A new
CopyC#
TokenStream
 API has been introduced with Lucene 2.9. This API has moved from being {@link Token} based to {@link Attribute} based. While {@link Token} still exists in 2.9 as a convenience class, the preferred way to store the information of a {@link Token} is to use {@link AttributeImpl}s.

CopyC#
TokenStream
now extends {@link AttributeSource}, which provides access to all of the token {@link Attribute}s for the
CopyC#
TokenStream
. Note that only one instance per {@link AttributeImpl} is created and reused for every token. This approach reduces object creation and allows local caching of references to the {@link AttributeImpl}s. See {@link #IncrementToken()} for further details.

The workflow of the new

CopyC#
TokenStream
API is as follows:
  1. Instantiation of
    CopyC#
    TokenStream
    /{@link TokenFilter}s which add/get attributes to/from the {@link AttributeSource}.
  2. The consumer calls {@link TokenStream#Reset()}.
  3. The consumer retrieves attributes from the stream and stores local references to all attributes it wants to access
  4. The consumer calls {@link #IncrementToken()} until it returns false and consumes the attributes after each call.
  5. The consumer calls {@link #End()} so that any end-of-stream operations can be performed.
  6. The consumer calls {@link #Close()} to release any resource when finished using the
    CopyC#
    TokenStream
To make sure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.

You can find some example code for the new API in the analysis package level Javadoc.

Sometimes it is desirable to capture a current state of a

CopyC#
TokenStream
, e. g. for buffering purposes (see {@link CachingTokenFilter}, {@link TeeSinkTokenFilter}). For this usecase {@link AttributeSource#CaptureState} and {@link AttributeSource#RestoreState} can be used.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TokenStream : AttributeSource
Visual Basic
Public MustInherit Class TokenStream _
    Inherits AttributeSource
Visual C++
public ref class TokenStream abstract : public AttributeSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..NumericTokenStream
Lucene.Net.Analysis..::..TeeSinkTokenFilter..::..SinkTokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analyzers.Miscellaneous..::..EmptyTokenStream
Lucene.Net.Analyzers.Miscellaneous..::..PrefixAndSuffixAwareTokenFilter
Lucene.Net.Analyzers.Miscellaneous..::..PrefixAwareTokenFilter
Lucene.Net.Analyzers.Miscellaneous..::..SingleTokenTokenStream
Lucene.Net.Analyzers.Shingle..::..ShingleMatrixFilter
Lucene.Net.Highlight..::..TokenSources..::..StoredTokenStream

See Also

TokenStream Members
Lucene.Net.Analysis Namespace


TokenStream Members

[image] [image]

Lucene.Net Class Libraries
TokenStream Members
TokenStream Class Constructors Methods See Also Send Feedback

The TokenStream type exposes the following members.

Constructors

 | Name | Description
Protected method | TokenStream()()()() | A TokenStream using the default attribute factory.
Protected method | TokenStream(AttributeSource) | A TokenStream that uses the same attributes as the supplied one.
Protected method | TokenStream(AttributeSource..::..AttributeFactory) | A TokenStream using the supplied AttributeFactory for creating new {@link Attribute} instances.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
GetOnlyUseNewAPI Obsolete.
Returns if only the new API is used.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
SetOnlyUseNewAPI Obsolete.
For extra performance you can globally enable the new {@link #IncrementToken} API using {@link Attribute}s. There will be a small, but in most cases negligible performance increase by enabling this, but it only works if all
CopyC#
TokenStream
s use the new API and implement {@link #IncrementToken}. This setting can only be enabled globally.

This setting only affects

CopyC#
TokenStream
s instantiated after this call. All
CopyC#
TokenStream
s already created use the other setting.

All core {@link Analyzer}s are compatible with this setting, if you have your own

CopyC#
TokenStream
s that are also compatible, you should enable this.

When enabled, tokenization may throw {@link UnsupportedOperationException} s, if the whole tokenizer chain is not compatible eg one of the

CopyC#
TokenStream
s does not implement the new
CopyC#
TokenStream
 API.

The default is

CopyC#
false
, so there is the fallback to the old API available.
Public method | ToString | (Inherited from AttributeSource.)

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


TokenStream Constructor

[image] [image]

Lucene.Net Class Libraries
TokenStream Constructor
TokenStream Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | TokenStream()()()() | A TokenStream using the default attribute factory.
Protected method | TokenStream(AttributeSource) | A TokenStream that uses the same attributes as the supplied one.
Protected method | TokenStream(AttributeSource..::..AttributeFactory) | A TokenStream using the supplied AttributeFactory for creating new {@link Attribute} instances.

See Also

TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace


TokenStream Constructor

[image]

Lucene.Net Class Libraries
TokenStream Constructor
TokenStream Class See Also Send Feedback
A TokenStream using the default attribute factory.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TokenStream()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
TokenStream()

See Also

TokenStream Class
TokenStream Overload
Lucene.Net.Analysis Namespace


TokenStream Constructor (AttributeSource)

[image]

Lucene.Net Class Libraries
TokenStream Constructor (AttributeSource)
TokenStream Class See Also Send Feedback
A TokenStream that uses the same attributes as the supplied one.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TokenStream(
    AttributeSource input
)
Visual Basic
Protected Friend Sub New ( _
    input As AttributeSource _
)
Visual C++
protected public:
TokenStream(
    AttributeSource^ input
)

Parameters

input
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.TokenStream.#ctor(Lucene.Net.Util.AttributeSource)"]

See Also

TokenStream Class
TokenStream Overload
Lucene.Net.Analysis Namespace


TokenStream Constructor (AttributeSource.AttributeFactory)

[image]

Lucene.Net Class Libraries
TokenStream Constructor (AttributeSource..::..AttributeFactory)
TokenStream Class See Also Send Feedback
A TokenStream using the supplied AttributeFactory for creating new {@link Attribute} instances.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TokenStream(
    AttributeSource..::..AttributeFactory factory
)
Visual Basic
Protected Friend Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
Visual C++
protected public:
TokenStream(
    AttributeSource..::..AttributeFactory^ factory
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.TokenStream.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory)"]

See Also

TokenStream Class
TokenStream Overload
Lucene.Net.Analysis Namespace


TokenStream Methods

[image] [image]

Lucene.Net Class Libraries
TokenStream Methods
TokenStream Class See Also Send Feedback

The TokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
GetOnlyUseNewAPI Obsolete.
Returns if only the new API is used.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
SetOnlyUseNewAPI Obsolete.
For extra performance you can globally enable the new {@link #IncrementToken} API using {@link Attribute}s. There will be a small, but in most cases negligible performance increase by enabling this, but it only works if all
CopyC#
TokenStream
s use the new API and implement {@link #IncrementToken}. This setting can only be enabled globally.

This setting only affects

CopyC#
TokenStream
s instantiated after this call. All
CopyC#
TokenStream
s already created use the other setting.

All core {@link Analyzer}s are compatible with this setting, if you have your own

CopyC#
TokenStream
s that are also compatible, you should enable this.

When enabled, tokenization may throw {@link UnsupportedOperationException} s, if the whole tokenizer chain is not compatible eg one of the

CopyC#
TokenStream
s does not implement the new
CopyC#
TokenStream
 API.

The default is

CopyC#
false
, so there is the fallback to the old API available.
Public method | ToString | (Inherited from AttributeSource.)

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


Close Method

[image]

Lucene.Net Class Libraries
TokenStream..::..Close Method
TokenStream Class See Also Send Feedback
Releases resources associated with this stream.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


End Method

[image]

Lucene.Net Class Libraries
TokenStream..::..End Method
TokenStream Class See Also Send Feedback
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void End()
Visual Basic
Public Overridable Sub End
Visual C++
public:
virtual void End()

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


GetOnlyUseNewAPI Method

[image]

Lucene.Net Class Libraries
TokenStream..::..GetOnlyUseNewAPI Method
TokenStream Class See Also Send Feedback
Returns if only the new API is used.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This setting will no longer be needed in Lucene 3.0 as the old API will be removed.")]
public static bool GetOnlyUseNewAPI()
Visual Basic
<ObsoleteAttribute("This setting will no longer be needed in Lucene 3.0 as the old API will be removed.")> _
Public Shared Function GetOnlyUseNewAPI As Boolean
Visual C++
[ObsoleteAttribute(L"This setting will no longer be needed in Lucene 3.0 as the old API will be removed.")]
public:
static bool GetOnlyUseNewAPI()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenStream.GetOnlyUseNewAPI"]

See Also

TokenStream Class
Lucene.Net.Analysis Namespace
[!:setOnlyUseNewAPI]


IncrementToken Method

[image]

Lucene.Net Class Libraries
TokenStream..::..IncrementToken Method
TokenStream Class See Also Send Feedback
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IncrementToken()
Visual Basic
Public Overridable Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken()

Return Value

false for end of stream; true otherwise Note that this method will be defined abstract in Lucene 3.0.

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
TokenStream..::..Next Method
TokenStream Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.

See Also

TokenStream Class
TokenStream Members
Lucene.Net.Analysis Namespace


Next Method

[image]

Lucene.Net Class Libraries
TokenStream..::..Next Method
TokenStream Class See Also Send Feedback
Returns the next {@link Token} in the stream, or null at EOS.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public virtual Token Next()
Visual Basic
<ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")> _
Public Overridable Function Next As Token
Visual C++
[ObsoleteAttribute(L"The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public:
virtual Token^ Next()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenStream.Next"]

See Also

TokenStream Class
Next Overload
Lucene.Net.Analysis Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
TokenStream..::..Next Method (Token)
TokenStream Class See Also Send Feedback
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public virtual Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overridable Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
)

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token
a {@link Token} that may or may not be used to return; this parameter should never be null (the callee is not required to check for null before using it, but it is a good idea to assert that it is not null.)

Return Value

next {@link Token} in the stream or null if end-of-stream was hit

See Also

TokenStream Class
Next Overload
Lucene.Net.Analysis Namespace


Reset Method

[image]

Lucene.Net Class Libraries
TokenStream..::..Reset Method
TokenStream Class See Also Send Feedback
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


SetOnlyUseNewAPI Method

[image]

Lucene.Net Class Libraries
TokenStream..::..SetOnlyUseNewAPI Method
TokenStream Class See Also Send Feedback
For extra performance you can globally enable the new {@link #IncrementToken} API using {@link Attribute}s. There will be a small, but in most cases negligible performance increase by enabling this, but it only works if all
CopyC#
TokenStream
s use the new API and implement {@link #IncrementToken}. This setting can only be enabled globally.

This setting only affects

CopyC#
TokenStream
s instantiated after this call. All
CopyC#
TokenStream
s already created use the other setting.

All core {@link Analyzer}s are compatible with this setting, if you have your own

CopyC#
TokenStream
s that are also compatible, you should enable this.

When enabled, tokenization may throw {@link UnsupportedOperationException} s, if the whole tokenizer chain is not compatible eg one of the

CopyC#
TokenStream
s does not implement the new
CopyC#
TokenStream
 API.

The default is

CopyC#
false
, so there is the fallback to the old API available.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This setting will no longer be needed in Lucene 3.0 as the old API will be removed.")]
public static void SetOnlyUseNewAPI(
    bool onlyUseNewAPI
)
Visual Basic
<ObsoleteAttribute("This setting will no longer be needed in Lucene 3.0 as the old API will be removed.")> _
Public Shared Sub SetOnlyUseNewAPI ( _
    onlyUseNewAPI As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This setting will no longer be needed in Lucene 3.0 as the old API will be removed.")]
public:
static void SetOnlyUseNewAPI(
    bool onlyUseNewAPI
)

Parameters

onlyUseNewAPI
Type: System..::..Boolean

[Missing <param name="onlyUseNewAPI"/> documentation for "M:Lucene.Net.Analysis.TokenStream.SetOnlyUseNewAPI(System.Boolean)"]

See Also

TokenStream Class
Lucene.Net.Analysis Namespace


TokenWrapper Class

[image]

Lucene.Net Class Libraries
TokenWrapper Class
Members See Also Send Feedback
This class wraps a Token and supplies a single attribute instance where the delegate token can be replaced.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Will be removed, when old TokenStream API is removed.")]
public sealed class TokenWrapper : AttributeImpl,
    ICloneable, TermAttribute, TypeAttribute, PositionIncrementAttribute, FlagsAttribute,
    OffsetAttribute, PayloadAttribute, Attribute
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Will be removed, when old TokenStream API is removed.")> _
Public NotInheritable Class TokenWrapper _
    Inherits AttributeImpl _
    Implements ICloneable, TermAttribute, TypeAttribute, PositionIncrementAttribute,  _
    FlagsAttribute, OffsetAttribute, PayloadAttribute, Attribute
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Will be removed, when old TokenStream API is removed.")]
public ref class TokenWrapper sealed : public AttributeImpl,
    ICloneable, TermAttribute, TypeAttribute, PositionIncrementAttribute, FlagsAttribute,
    OffsetAttribute, PayloadAttribute, Attribute

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis..::..TokenWrapper

See Also

TokenWrapper Members
Lucene.Net.Analysis Namespace


TokenWrapper Members

[image] [image]

Lucene.Net Class Libraries
TokenWrapper Members
TokenWrapper Class Methods See Also Send Feedback

The TokenWrapper type exposes the following members.

Methods

 | Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | EndOffset |
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFlags |
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method | GetPayload |
Public method | GetPositionIncrement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeTermBuffer |
Public method | SetFlags |
Public method | SetOffset |
Public method | SetPayload |
Public method | SetPositionIncrement |
Public method | SetTermBuffer(String) |
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) |
Public method | SetTermBuffer(String, Int32, Int32) |
Public method | SetTermLength |
Public method | SetType |
Public method | StartOffset |
Public method | Term |
Public method | TermBuffer |
Public method | TermLength |
Public method | ToString | (Overrides AttributeImpl..::..ToString()()()().)
Public method | Type |

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


TokenWrapper Methods

[image] [image]

Lucene.Net Class Libraries
TokenWrapper Methods
TokenWrapper Class See Also Send Feedback

The TokenWrapper type exposes the following members.

Methods

 | Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | EndOffset |
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFlags |
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method | GetPayload |
Public method | GetPositionIncrement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeTermBuffer |
Public method | SetFlags |
Public method | SetOffset |
Public method | SetPayload |
Public method | SetPositionIncrement |
Public method | SetTermBuffer(String) |
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) |
Public method | SetTermBuffer(String, Int32, Int32) |
Public method | SetTermLength |
Public method | SetType |
Public method | StartOffset |
Public method | Term |
Public method | TermBuffer |
Public method | TermLength |
Public method | ToString | (Overrides AttributeImpl..::..ToString()()()().)
Public method | Type |

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


Clear Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..Clear Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Clear"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


Clone Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..Clone Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Clone"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..CopyTo Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


EndOffset Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..EndOffset Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.EndOffset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int EndOffset()
Visual Basic
Public Function EndOffset As Integer
Visual C++
public:
virtual int EndOffset() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.EndOffset"]

Implements

OffsetAttribute..::..EndOffset()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..Equals Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Equals(System.Object)"]

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


GetFlags Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..GetFlags Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetFlags"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetFlags()
Visual Basic
Public Function GetFlags As Integer
Visual C++
public:
virtual int GetFlags() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetFlags"]

Implements

FlagsAttribute..::..GetFlags()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..GetHashCode Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetHashCode"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetHashCode"]

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..GetPayload Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetPayload"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Payload GetPayload()
Visual Basic
Public Function GetPayload As Payload
Visual C++
public:
virtual Payload^ GetPayload() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetPayload"]

Implements

PayloadAttribute..::..GetPayload()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


GetPositionIncrement Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..GetPositionIncrement Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetPositionIncrement"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetPositionIncrement()
Visual Basic
Public Function GetPositionIncrement As Integer
Visual C++
public:
virtual int GetPositionIncrement() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.GetPositionIncrement"]

Implements

PositionIncrementAttribute..::..GetPositionIncrement()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


ResizeTermBuffer Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..ResizeTermBuffer Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.ResizeTermBuffer(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char[] ResizeTermBuffer(
    int newSize
)
Visual Basic
Public Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Visual C++
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
) sealed

Parameters

newSize
Type: System..::..Int32

[Missing <param name="newSize"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.ResizeTermBuffer(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.ResizeTermBuffer(System.Int32)"]

Implements

TermAttribute..::..ResizeTermBuffer(Int32)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


SetFlags Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetFlags Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetFlags(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetFlags(
    int flags
)
Visual Basic
Public Sub SetFlags ( _
    flags As Integer _
)
Visual C++
public:
virtual void SetFlags(
    int flags
) sealed

Parameters

flags
Type: System..::..Int32

[Missing <param name="flags"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetFlags(System.Int32)"]

Implements

FlagsAttribute..::..SetFlags(Int32)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


SetOffset Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetOffset Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetOffset(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetOffset(
    int startOffset,
    int endOffset
)
Visual Basic
Public Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Visual C++
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
) sealed

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetOffset(System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetOffset(System.Int32,System.Int32)"]

Implements

OffsetAttribute..::..SetOffset(Int32, Int32)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


SetPayload Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetPayload Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetPayload(Lucene.Net.Index.Payload)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetPayload(
    Payload payload
)
Visual Basic
Public Sub SetPayload ( _
    payload As Payload _
)
Visual C++
public:
virtual void SetPayload(
    Payload^ payload
) sealed

Parameters

payload
Type: Lucene.Net.Index..::..Payload

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetPayload(Lucene.Net.Index.Payload)"]

Implements

PayloadAttribute..::..SetPayload(Payload)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


SetPositionIncrement Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetPositionIncrement Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetPositionIncrement(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetPositionIncrement(
    int positionIncrement
)
Visual Basic
Public Sub SetPositionIncrement ( _
    positionIncrement As Integer _
)
Visual C++
public:
virtual void SetPositionIncrement(
    int positionIncrement
) sealed

Parameters

positionIncrement
Type: System..::..Int32

[Missing <param name="positionIncrement"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetPositionIncrement(System.Int32)"]

Implements

PositionIncrementAttribute..::..SetPositionIncrement(Int32)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


SetTermBuffer Method

[image] [image]

Lucene.Net Class Libraries
TokenWrapper..::..SetTermBuffer Method
TokenWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTermBuffer(String) |
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) |
Public method | SetTermBuffer(String, Int32, Int32) |

See Also

TokenWrapper Class
TokenWrapper Members
Lucene.Net.Analysis Namespace


SetTermBuffer Method (String)

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetTermBuffer Method (String)
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.String)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermBuffer(
    string buffer
)
Visual Basic
Public Sub SetTermBuffer ( _
    buffer As String _
)
Visual C++
public:
virtual void SetTermBuffer(
    String^ buffer
) sealed

Parameters

buffer
Type: System..::..String

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.String)"]

Implements

TermAttribute..::..SetTermBuffer(String)

See Also

TokenWrapper Class
SetTermBuffer Overload
Lucene.Net.Analysis Namespace


SetTermBuffer Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetTermBuffer Method (array<Char>[]()[][], Int32, Int32)
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.Char[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Visual Basic
Public Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
) sealed

Parameters

buffer
Type: array< System..::..Char >[]()[][]

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.Char[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.Char[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.Char[],System.Int32,System.Int32)"]

Implements

TermAttribute..::..SetTermBuffer(array<Char>[]()[][], Int32, Int32)

See Also

TokenWrapper Class
SetTermBuffer Overload
Lucene.Net.Analysis Namespace


SetTermBuffer Method (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetTermBuffer Method (String, Int32, Int32)
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.String,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Visual Basic
Public Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
) sealed

Parameters

buffer
Type: System..::..String

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.String,System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.String,System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermBuffer(System.String,System.Int32,System.Int32)"]

Implements

TermAttribute..::..SetTermBuffer(String, Int32, Int32)

See Also

TokenWrapper Class
SetTermBuffer Overload
Lucene.Net.Analysis Namespace


SetTermLength Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetTermLength Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermLength(System.Int32)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTermLength(
    int length
)
Visual Basic
Public Sub SetTermLength ( _
    length As Integer _
)
Visual C++
public:
virtual void SetTermLength(
    int length
) sealed

Parameters

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetTermLength(System.Int32)"]

Implements

TermAttribute..::..SetTermLength(Int32)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


SetType Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..SetType Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetType(System.String)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetType(
    string type
)
Visual Basic
Public Sub SetType ( _
    type As String _
)
Visual C++
public:
virtual void SetType(
    String^ type
) sealed

Parameters

type
Type: System..::..String

[Missing <param name="type"/> documentation for "M:Lucene.Net.Analysis.TokenWrapper.SetType(System.String)"]

Implements

TypeAttribute..::..SetType(String)

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


StartOffset Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..StartOffset Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.StartOffset"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int StartOffset()
Visual Basic
Public Function StartOffset As Integer
Visual C++
public:
virtual int StartOffset() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.StartOffset"]

Implements

OffsetAttribute..::..StartOffset()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


Term Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..Term Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Term"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Term()
Visual Basic
Public Function Term As String
Visual C++
public:
virtual String^ Term() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Term"]

Implements

TermAttribute..::..Term()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


TermBuffer Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..TermBuffer Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.TermBuffer"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char[] TermBuffer()
Visual Basic
Public Function TermBuffer As Char()
Visual C++
public:
virtual array<wchar_t>^ TermBuffer() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.TermBuffer"]

Implements

TermAttribute..::..TermBuffer()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


TermLength Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..TermLength Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.TermLength"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int TermLength()
Visual Basic
Public Function TermLength As Integer
Visual C++
public:
virtual int TermLength() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.TermLength"]

Implements

TermAttribute..::..TermLength()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..ToString Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.ToString"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.ToString"]

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


Type Method

[image]

Lucene.Net Class Libraries
TokenWrapper..::..Type Method
TokenWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Type"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Type()
Visual Basic
Public Function Type As String
Visual C++
public:
virtual String^ Type() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.TokenWrapper.Type"]

Implements

TypeAttribute..::..Type()()()()

See Also

TokenWrapper Class
Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Class

[image]

Lucene.Net Class Libraries
WhitespaceAnalyzer Class
Members See Also Send Feedback
An Analyzer that uses {@link WhitespaceTokenizer}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class WhitespaceAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class WhitespaceAnalyzer _
    Inherits Analyzer
Visual C++
public ref class WhitespaceAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis..::..WhitespaceAnalyzer

See Also

WhitespaceAnalyzer Members
Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
WhitespaceAnalyzer Members
WhitespaceAnalyzer Class Constructors Methods Fields See Also Send Feedback

The WhitespaceAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | WhitespaceAnalyzer | Initializes a new instance of the WhitespaceAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Constructor

[image]

Lucene.Net Class Libraries
WhitespaceAnalyzer Constructor
WhitespaceAnalyzer Class See Also Send Feedback
Initializes a new instance of the WhitespaceAnalyzer class

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WhitespaceAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
WhitespaceAnalyzer()

See Also

WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
WhitespaceAnalyzer Fields
WhitespaceAnalyzer Class See Also Send Feedback

The WhitespaceAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace


WhitespaceAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
WhitespaceAnalyzer Methods
WhitespaceAnalyzer Class See Also Send Feedback

The WhitespaceAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
WhitespaceAnalyzer..::..ReusableTokenStream Method
WhitespaceAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
WhitespaceAnalyzer..::..TokenStream Method
WhitespaceAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.WhitespaceAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

WhitespaceAnalyzer Class
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Class

[image]

Lucene.Net Class Libraries
WhitespaceTokenizer Class
Members See Also Send Feedback
A WhitespaceTokenizer is a tokenizer that divides text at whitespace. Adjacent sequences of non-Whitespace characters form tokens.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class WhitespaceTokenizer : CharTokenizer
Visual Basic
Public Class WhitespaceTokenizer _
    Inherits CharTokenizer
Visual C++
public ref class WhitespaceTokenizer : public CharTokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis..::..WhitespaceTokenizer

See Also

WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Members

[image] [image]

Lucene.Net Class Libraries
WhitespaceTokenizer Members
WhitespaceTokenizer Class Constructors Methods Fields See Also Send Feedback

The WhitespaceTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | WhitespaceTokenizer(TextReader) | Construct a new WhitespaceTokenizer.
Public method | WhitespaceTokenizer(AttributeSource, TextReader) | Construct a new WhitespaceTokenizer using a given {@link AttributeSource}.
Public method | WhitespaceTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a new WhitespaceTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
WhitespaceTokenizer Constructor
WhitespaceTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WhitespaceTokenizer(TextReader) | Construct a new WhitespaceTokenizer.
Public method | WhitespaceTokenizer(AttributeSource, TextReader) | Construct a new WhitespaceTokenizer using a given {@link AttributeSource}.
Public method | WhitespaceTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Construct a new WhitespaceTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

See Also

WhitespaceTokenizer Class
WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
WhitespaceTokenizer Constructor (TextReader)
WhitespaceTokenizer Class See Also Send Feedback
Construct a new WhitespaceTokenizer.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WhitespaceTokenizer(
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TextReader _
)
Visual C++
public:
WhitespaceTokenizer(
    TextReader^ in_Renamed
)

Parameters

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.#ctor(System.IO.TextReader)"]

See Also

WhitespaceTokenizer Class
WhitespaceTokenizer Overload
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Constructor (AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
WhitespaceTokenizer Constructor (AttributeSource, TextReader)
WhitespaceTokenizer Class See Also Send Feedback
Construct a new WhitespaceTokenizer using a given {@link AttributeSource}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WhitespaceTokenizer(
    AttributeSource source,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    in_Renamed As TextReader _
)
Visual C++
public:
WhitespaceTokenizer(
    AttributeSource^ source,
    TextReader^ in_Renamed
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

WhitespaceTokenizer Class
WhitespaceTokenizer Overload
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
WhitespaceTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader)
WhitespaceTokenizer Class See Also Send Feedback
Construct a new WhitespaceTokenizer using a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WhitespaceTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in_Renamed
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in_Renamed As TextReader _
)
Visual C++
public:
WhitespaceTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in_Renamed
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

in_Renamed
Type: System.IO..::..TextReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

WhitespaceTokenizer Class
WhitespaceTokenizer Overload
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
WhitespaceTokenizer Fields
WhitespaceTokenizer Class See Also Send Feedback

The WhitespaceTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace


WhitespaceTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
WhitespaceTokenizer Methods
WhitespaceTokenizer Class See Also Send Feedback

The WhitespaceTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace


IsTokenChar Method

[image]

Lucene.Net Class Libraries
WhitespaceTokenizer..::..IsTokenChar Method
WhitespaceTokenizer Class See Also Send Feedback
Collects only characters which do not satisfy {@link Character#isWhitespace(char)}.

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override bool IsTokenChar(
    char c
)
Visual Basic
Protected Friend Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Visual C++
protected public:
virtual bool IsTokenChar(
    wchar_t c
) override

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.IsTokenChar(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.WhitespaceTokenizer.IsTokenChar(System.Char)"]

See Also

WhitespaceTokenizer Class
Lucene.Net.Analysis Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
WhitespaceTokenizer..::..Next Method
WhitespaceTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)

See Also

WhitespaceTokenizer Class
WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
WhitespaceTokenizer..::..Reset Method
WhitespaceTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)

See Also

WhitespaceTokenizer Class
WhitespaceTokenizer Members
Lucene.Net.Analysis Namespace


WordlistLoader Class

[image]

Lucene.Net Class Libraries
WordlistLoader Class
Members See Also Send Feedback
Loads a text file and adds every line as an entry to a Hashtable. Every line should contain only one word. If the file is not found or on any error, an empty table is returned.

Namespace: Lucene.Net.Analysis
Assemblies: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)
Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class WordlistLoader
Visual Basic
Public Class WordlistLoader
Visual C++
public ref class WordlistLoader

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..WordlistLoader

See Also

WordlistLoader Members
Lucene.Net.Analysis Namespace


WordlistLoader Members

[image] [image]

Lucene.Net Class Libraries
WordlistLoader Members
WordlistLoader Class Constructors Methods See Also Send Feedback

The WordlistLoader type exposes the following members.

Constructors

 | Name | Description
Public method | WordlistLoader | Initializes a new instance of the WordlistLoader class

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetStemDict
Reads a stem dictionary. Each line contains:
word\tstem
(i.e. two tab seperated words)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetWordSet(FileInfo)
Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader)
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(FileInfo, String)
Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader, String)
Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordtable(FileInfo)
Load words table from the file
GetWordtable(TextReader)
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordtable(String)
Load words table from the file
GetWordtable(String, String)
Load words table from the file
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

WordlistLoader Class
Lucene.Net.Analysis Namespace


WordlistLoader Constructor

[image]

Lucene.Net Class Libraries
WordlistLoader Constructor
WordlistLoader Class See Also Send Feedback
Initializes a new instance of the WordlistLoader class

Namespace: Lucene.Net.Analysis
Assemblies: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)
Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WordlistLoader()
Visual Basic
Public Sub New
Visual C++
public:
WordlistLoader()

See Also

WordlistLoader Class
Lucene.Net.Analysis Namespace


WordlistLoader Methods

[image] [image]

Lucene.Net Class Libraries
WordlistLoader Methods
WordlistLoader Class See Also Send Feedback

The WordlistLoader type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetStemDict
Reads a stem dictionary. Each line contains:
word\tstem
(i.e. two tab seperated words)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetWordSet(FileInfo)
Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader)
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(FileInfo, String)
Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader, String)
Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordtable(FileInfo)
Load words table from the file
GetWordtable(TextReader)
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordtable(String)
Load words table from the file
GetWordtable(String, String)
Load words table from the file
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

WordlistLoader Class
Lucene.Net.Analysis Namespace


GetStemDict Method

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetStemDict Method
WordlistLoader Class See Also Send Feedback
Reads a stem dictionary. Each line contains:
word\tstem
(i.e. two tab seperated words)

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable GetStemDict(
    FileInfo wordstemfile
)
Visual Basic
Public Shared Function GetStemDict ( _
    wordstemfile As FileInfo _
) As Hashtable
Visual C++
public:
static Hashtable^ GetStemDict(
    FileInfo^ wordstemfile
)

Parameters

wordstemfile
Type: System.IO..::..FileInfo

[Missing <param name="wordstemfile"/> documentation for "M:Lucene.Net.Analysis.WordlistLoader.GetStemDict(System.IO.FileInfo)"]

Return Value

stem dictionary that overrules the stemming algorithm

See Also

WordlistLoader Class
Lucene.Net.Analysis Namespace


GetWordSet Method

[image] [image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordSet Method
WordlistLoader Class See Also Send Feedback

Overload List

Name | Description
GetWordSet(FileInfo) | Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader) | Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(FileInfo, String) | Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordSet(TextReader, String) | Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

See Also

WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis Namespace


GetWordSet Method (FileInfo)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordSet Method (FileInfo)
WordlistLoader Class See Also Send Feedback
Loads a text file and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable GetWordSet(
    FileInfo wordfile
)
Visual Basic
Public Shared Function GetWordSet ( _
    wordfile As FileInfo _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordSet(
    FileInfo^ wordfile
)

Parameters

wordfile
Type: System.IO..::..FileInfo
File containing the wordlist

Return Value

A HashSet with the file's words

See Also

WordlistLoader Class
GetWordSet Overload
Lucene.Net.Analysis Namespace


GetWordSet Method (TextReader)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordSet Method (TextReader)
WordlistLoader Class See Also Send Feedback
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable GetWordSet(
    TextReader reader
)
Visual Basic
Public Shared Function GetWordSet ( _
    reader As TextReader _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordSet(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::..TextReader
Reader containing the wordlist

Return Value

A HashSet with the reader's words

See Also

WordlistLoader Class
GetWordSet Overload
Lucene.Net.Analysis Namespace


GetWordSet Method (FileInfo, String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordSet Method (FileInfo, String)
WordlistLoader Class See Also Send Feedback
Loads a text file and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the file should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable GetWordSet(
    FileInfo wordfile,
    string comment
)
Visual Basic
Public Shared Function GetWordSet ( _
    wordfile As FileInfo, _
    comment As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordSet(
    FileInfo^ wordfile,
    String^ comment
)

Parameters

wordfile
Type: System.IO..::..FileInfo
File containing the wordlist
comment
Type: System..::..String
The comment string to ignore

Return Value

A HashSet with the file's words

See Also

WordlistLoader Class
GetWordSet Overload
Lucene.Net.Analysis Namespace


GetWordSet Method (TextReader, String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordSet Method (TextReader, String)
WordlistLoader Class See Also Send Feedback
Reads lines from a Reader and adds every non-comment line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Hashtable GetWordSet(
    TextReader reader,
    string comment
)
Visual Basic
Public Shared Function GetWordSet ( _
    reader As TextReader, _
    comment As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordSet(
    TextReader^ reader,
    String^ comment
)

Parameters

reader
Type: System.IO..::..TextReader
Reader containing the wordlist
comment
Type: System..::..String
The string representing a comment.

Return Value

A HashSet with the reader's words

See Also

WordlistLoader Class
GetWordSet Overload
Lucene.Net.Analysis Namespace


GetWordtable Method

[image] [image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method
WordlistLoader Class See Also Send Feedback

Overload List

Name | Description
GetWordtable(FileInfo) | Load words table from the file
GetWordtable(TextReader) | Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).
GetWordtable(String) | Load words table from the file
GetWordtable(String, String) | Load words table from the file

See Also

WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis Namespace


GetWordtable Method (FileInfo)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (FileInfo)
WordlistLoader Class See Also Send Feedback
Load words table from the file

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    FileInfo wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    wordfile As FileInfo _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    FileInfo^ wordfile
)

Parameters

wordfile
Type: System.IO..::..FileInfo
File containing the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.WordlistLoader.GetWordtable(System.IO.FileInfo)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis Namespace


GetWordtable Method (TextReader)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (TextReader)
WordlistLoader Class See Also Send Feedback
Reads lines from a Reader and adds every line as an entry to a HashSet (omitting leading and trailing whitespace). Every line of the Reader should contain only one word. The words need to be in lowercase if you make use of an Analyzer which uses LowerCaseFilter (like StandardAnalyzer).

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    TextReader reader
)
Visual Basic
Public Shared Function GetWordtable ( _
    reader As TextReader _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::..TextReader
Reader containing the wordlist

Return Value

A Hashtable with the reader's words

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis Namespace


GetWordtable Method (String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (String)
WordlistLoader Class See Also Send Feedback
Load words table from the file

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    string wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    wordfile As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    String^ wordfile
)

Parameters

wordfile
Type: System..::..String
Complete path to the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.WordlistLoader.GetWordtable(System.String)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis Namespace


GetWordtable Method (String, String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (String, String)
WordlistLoader Class See Also Send Feedback
Load words table from the file

Namespace: Lucene.Net.Analysis
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    string path,
    string wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    path As String, _
    wordfile As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    String^ path,
    String^ wordfile
)

Parameters

path
Type: System..::..String
Path to the wordlist
wordfile
Type: System..::..String
Name of the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.WordlistLoader.GetWordtable(System.String,System.String)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis Namespace


Lucene.Net.Analysis.AR Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.AR Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.AR"]

Classes

 | Class | Description
Public class | ArabicAnalyzer |
Public class | ArabicLetterTokenizer |
Public class | ArabicNormalizationFilter |
Public class | ArabicNormalizer |
Public class | ArabicStemFilter |
Public class | ArabicStemmer |


ArabicAnalyzer Class

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.AR.ArabicAnalyzer"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ArabicAnalyzer : Analyzer
Visual Basic
Public Class ArabicAnalyzer _
    Inherits Analyzer
Visual C++
public ref class ArabicAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.AR..::..ArabicAnalyzer

See Also

ArabicAnalyzer Members
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
ArabicAnalyzer Members
ArabicAnalyzer Class Constructors Methods Fields See Also Send Feedback

The ArabicAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | ArabicAnalyzer()()()() | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Hashtable) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(array<String>[]()[][]) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Version) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Version, Hashtable) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Version, array<String>[]()[][]) | Initializes a new instance of the ArabicAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | DEFAULT_STOPWORD_FILE |
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | STOPWORDS_COMMENT |

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor
ArabicAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArabicAnalyzer()()()() | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Hashtable) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(array<String>[]()[][]) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Version) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Version, Hashtable) | Initializes a new instance of the ArabicAnalyzer class
Public method | ArabicAnalyzer(Version, array<String>[]()[][]) | Initializes a new instance of the ArabicAnalyzer class

See Also

ArabicAnalyzer Class
ArabicAnalyzer Members
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor
ArabicAnalyzer Class See Also Send Feedback
Initializes a new instance of the ArabicAnalyzer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
ArabicAnalyzer()

See Also

ArabicAnalyzer Class
ArabicAnalyzer Overload
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor (Hashtable)
ArabicAnalyzer Class See Also Send Feedback
Initializes a new instance of the ArabicAnalyzer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicAnalyzer(
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As Hashtable _
)
Visual C++
public:
ArabicAnalyzer(
    Hashtable^ stopwords
)

Parameters

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

ArabicAnalyzer Class
ArabicAnalyzer Overload
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor (array<String>[]()[][])
ArabicAnalyzer Class See Also Send Feedback
Initializes a new instance of the ArabicAnalyzer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicAnalyzer(
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As String() _
)
Visual C++
public:
ArabicAnalyzer(
    array<String^>^ stopwords
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(System.String[])"]

See Also

ArabicAnalyzer Class
ArabicAnalyzer Overload
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor (Version)

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor (Version)
ArabicAnalyzer Class See Also Send Feedback
Initializes a new instance of the ArabicAnalyzer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicAnalyzer(
    Version matchVersion
)
Visual Basic
Public Sub New ( _
    matchVersion As Version _
)
Visual C++
public:
ArabicAnalyzer(
    Version^ matchVersion
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(Lucene.Net.Util.Version)"]

See Also

ArabicAnalyzer Class
ArabicAnalyzer Overload
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor (Version, Hashtable)

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor (Version, Hashtable)
ArabicAnalyzer Class See Also Send Feedback
Initializes a new instance of the ArabicAnalyzer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicAnalyzer(
    Version matchVersion,
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopwords As Hashtable _
)
Visual C++
public:
ArabicAnalyzer(
    Version^ matchVersion,
    Hashtable^ stopwords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(Lucene.Net.Util.Version,System.Collections.Hashtable)"]

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(Lucene.Net.Util.Version,System.Collections.Hashtable)"]

See Also

ArabicAnalyzer Class
ArabicAnalyzer Overload
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Constructor (Version, String[])

[image]

Lucene.Net Class Libraries
ArabicAnalyzer Constructor (Version, array<String>[]()[][])
ArabicAnalyzer Class See Also Send Feedback
Initializes a new instance of the ArabicAnalyzer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicAnalyzer(
    Version matchVersion,
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopwords As String() _
)
Visual C++
public:
ArabicAnalyzer(
    Version^ matchVersion,
    array<String^>^ stopwords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(Lucene.Net.Util.Version,System.String[])"]

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.#ctor(Lucene.Net.Util.Version,System.String[])"]

See Also

ArabicAnalyzer Class
ArabicAnalyzer Overload
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
ArabicAnalyzer Fields
ArabicAnalyzer Class See Also Send Feedback

The ArabicAnalyzer type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_STOPWORD_FILE |
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | STOPWORDS_COMMENT |

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


DEFAULT_STOPWORD_FILE Field

[image]

Lucene.Net Class Libraries
ArabicAnalyzer..::..DEFAULT_STOPWORD_FILE Field
ArabicAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicAnalyzer.DEFAULT_STOPWORD_FILE"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string DEFAULT_STOPWORD_FILE
Visual Basic
Public Shared DEFAULT_STOPWORD_FILE As String
Visual C++
public:
static String^ DEFAULT_STOPWORD_FILE

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


STOPWORDS_COMMENT Field

[image]

Lucene.Net Class Libraries
ArabicAnalyzer..::..STOPWORDS_COMMENT Field
ArabicAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicAnalyzer.STOPWORDS_COMMENT"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string STOPWORDS_COMMENT
Visual Basic
Public Shared STOPWORDS_COMMENT As String
Visual C++
public:
static String^ STOPWORDS_COMMENT

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


ArabicAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
ArabicAnalyzer Methods
ArabicAnalyzer Class See Also Send Feedback

The ArabicAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
ArabicAnalyzer..::..ReusableTokenStream Method
ArabicAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
ArabicAnalyzer..::..TokenStream Method
ArabicAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

ArabicAnalyzer Class
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Class

[image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.AR.ArabicLetterTokenizer"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ArabicLetterTokenizer : LetterTokenizer
Visual Basic
Public Class ArabicLetterTokenizer _
    Inherits LetterTokenizer
Visual C++
public ref class ArabicLetterTokenizer : public LetterTokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis..::..LetterTokenizer
Lucene.Net.Analysis.AR..::..ArabicLetterTokenizer

See Also

ArabicLetterTokenizer Members
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Members

[image] [image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Members
ArabicLetterTokenizer Class Constructors Methods Fields See Also Send Feedback

The ArabicLetterTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | ArabicLetterTokenizer(TextReader) | Initializes a new instance of the ArabicLetterTokenizer class
Public method | ArabicLetterTokenizer(AttributeSource, TextReader) | Initializes a new instance of the ArabicLetterTokenizer class
Public method | ArabicLetterTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Initializes a new instance of the ArabicLetterTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | (Overrides LetterTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

ArabicLetterTokenizer Class
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Constructor
ArabicLetterTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArabicLetterTokenizer(TextReader) | Initializes a new instance of the ArabicLetterTokenizer class
Public method | ArabicLetterTokenizer(AttributeSource, TextReader) | Initializes a new instance of the ArabicLetterTokenizer class
Public method | ArabicLetterTokenizer(AttributeSource..::..AttributeFactory, TextReader) | Initializes a new instance of the ArabicLetterTokenizer class

See Also

ArabicLetterTokenizer Class
ArabicLetterTokenizer Members
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Constructor (TextReader)
ArabicLetterTokenizer Class See Also Send Feedback
Initializes a new instance of the ArabicLetterTokenizer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicLetterTokenizer(
    TextReader in
)
Visual Basic
Public Sub New ( _
    in As TextReader _
)
Visual C++
public:
ArabicLetterTokenizer(
    TextReader^ in
)

Parameters

in
Type: System.IO..::..TextReader

[Missing <param name="in"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.#ctor(System.IO.TextReader)"]

See Also

ArabicLetterTokenizer Class
ArabicLetterTokenizer Overload
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Constructor (AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Constructor (AttributeSource, TextReader)
ArabicLetterTokenizer Class See Also Send Feedback
Initializes a new instance of the ArabicLetterTokenizer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicLetterTokenizer(
    AttributeSource source,
    TextReader in
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    in As TextReader _
)
Visual C++
public:
ArabicLetterTokenizer(
    AttributeSource^ source,
    TextReader^ in
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

in
Type: System.IO..::..TextReader

[Missing <param name="in"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

ArabicLetterTokenizer Class
ArabicLetterTokenizer Overload
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Constructor (AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader)
ArabicLetterTokenizer Class See Also Send Feedback
Initializes a new instance of the ArabicLetterTokenizer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicLetterTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader in
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    in As TextReader _
)
Visual C++
public:
ArabicLetterTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ in
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

in
Type: System.IO..::..TextReader

[Missing <param name="in"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

ArabicLetterTokenizer Class
ArabicLetterTokenizer Overload
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Fields
ArabicLetterTokenizer Class See Also Send Feedback

The ArabicLetterTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

ArabicLetterTokenizer Class
Lucene.Net.Analysis.AR Namespace


ArabicLetterTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
ArabicLetterTokenizer Methods
ArabicLetterTokenizer Class See Also Send Feedback

The ArabicLetterTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method | IsTokenChar | (Overrides LetterTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ArabicLetterTokenizer Class
Lucene.Net.Analysis.AR Namespace


IsTokenChar Method

[image]

Lucene.Net Class Libraries
ArabicLetterTokenizer..::..IsTokenChar Method
ArabicLetterTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.IsTokenChar(System.Char)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected override bool IsTokenChar(
    char c
)
Visual Basic
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Visual C++
protected:
virtual bool IsTokenChar(
    wchar_t c
) override

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.IsTokenChar(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicLetterTokenizer.IsTokenChar(System.Char)"]

See Also

ArabicLetterTokenizer Class
Lucene.Net.Analysis.AR Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ArabicLetterTokenizer..::..Next Method
ArabicLetterTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)

See Also

ArabicLetterTokenizer Class
ArabicLetterTokenizer Members
Lucene.Net.Analysis.AR Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
ArabicLetterTokenizer..::..Reset Method
ArabicLetterTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)

See Also

ArabicLetterTokenizer Class
ArabicLetterTokenizer Members
Lucene.Net.Analysis.AR Namespace


ArabicNormalizationFilter Class

[image]

Lucene.Net Class Libraries
ArabicNormalizationFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.AR.ArabicNormalizationFilter"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ArabicNormalizationFilter : TokenFilter
Visual Basic
Public Class ArabicNormalizationFilter _
    Inherits TokenFilter
Visual C++
public ref class ArabicNormalizationFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.AR..::..ArabicNormalizationFilter

See Also

ArabicNormalizationFilter Members
Lucene.Net.Analysis.AR Namespace


ArabicNormalizationFilter Members

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizationFilter Members
ArabicNormalizationFilter Class Constructors Methods Fields See Also Send Feedback

The ArabicNormalizationFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ArabicNormalizationFilter | Initializes a new instance of the ArabicNormalizationFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Protected field | normalizer |

See Also

ArabicNormalizationFilter Class
Lucene.Net.Analysis.AR Namespace


ArabicNormalizationFilter Constructor

[image]

Lucene.Net Class Libraries
ArabicNormalizationFilter Constructor
ArabicNormalizationFilter Class See Also Send Feedback
Initializes a new instance of the ArabicNormalizationFilter class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicNormalizationFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
ArabicNormalizationFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizationFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

ArabicNormalizationFilter Class
Lucene.Net.Analysis.AR Namespace


ArabicNormalizationFilter Fields

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizationFilter Fields
ArabicNormalizationFilter Class See Also Send Feedback

The ArabicNormalizationFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Protected field | normalizer |

See Also

ArabicNormalizationFilter Class
Lucene.Net.Analysis.AR Namespace


normalizer Field

[image]

Lucene.Net Class Libraries
ArabicNormalizationFilter..::..normalizer Field
ArabicNormalizationFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizationFilter.normalizer"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected ArabicNormalizer normalizer
Visual Basic
Protected normalizer As ArabicNormalizer
Visual C++
protected:
ArabicNormalizer^ normalizer

See Also

ArabicNormalizationFilter Class
Lucene.Net.Analysis.AR Namespace


ArabicNormalizationFilter Methods

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizationFilter Methods
ArabicNormalizationFilter Class See Also Send Feedback

The ArabicNormalizationFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ArabicNormalizationFilter Class
Lucene.Net.Analysis.AR Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
ArabicNormalizationFilter..::..IncrementToken Method
ArabicNormalizationFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizationFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizationFilter.IncrementToken"]

See Also

ArabicNormalizationFilter Class
Lucene.Net.Analysis.AR Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizationFilter..::..Next Method
ArabicNormalizationFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

ArabicNormalizationFilter Class
ArabicNormalizationFilter Members
Lucene.Net.Analysis.AR Namespace


ArabicNormalizer Class

[image]

Lucene.Net Class Libraries
ArabicNormalizer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.AR.ArabicNormalizer"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ArabicNormalizer
Visual Basic
Public Class ArabicNormalizer
Visual C++
public ref class ArabicNormalizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.AR..::..ArabicNormalizer

See Also

ArabicNormalizer Members
Lucene.Net.Analysis.AR Namespace


ArabicNormalizer Members

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizer Members
ArabicNormalizer Class Constructors Methods Fields See Also Send Feedback

The ArabicNormalizer type exposes the following members.

Constructors

 | Name | Description
Public method | ArabicNormalizer | Initializes a new instance of the ArabicNormalizer class

Methods

 | Name | Description
Protected method | Delete |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ALEF |
ALEF_HAMZA_ABOVE |
ALEF_HAMZA_BELOW |
ALEF_MADDA |
DAMMA |
DAMMATAN |
DOTLESS_YEH |
FATHA |
FATHATAN |
HEH |
KASRA |
KASRATAN |
SHADDA |
SUKUN |
TATWEEL |
TEH_MARBUTA |
YEH |

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ArabicNormalizer Constructor

[image]

Lucene.Net Class Libraries
ArabicNormalizer Constructor
ArabicNormalizer Class See Also Send Feedback
Initializes a new instance of the ArabicNormalizer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicNormalizer()
Visual Basic
Public Sub New
Visual C++
public:
ArabicNormalizer()

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ArabicNormalizer Fields

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizer Fields
ArabicNormalizer Class See Also Send Feedback

The ArabicNormalizer type exposes the following members.

Fields

Name | Description
ALEF |
ALEF_HAMZA_ABOVE |
ALEF_HAMZA_BELOW |
ALEF_MADDA |
DAMMA |
DAMMATAN |
DOTLESS_YEH |
FATHA |
FATHATAN |
HEH |
KASRA |
KASRATAN |
SHADDA |
SUKUN |
TATWEEL |
TEH_MARBUTA |
YEH |

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ALEF Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..ALEF Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.ALEF"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char ALEF
Visual Basic
Public Shared ALEF As Char
Visual C++
public:
static wchar_t ALEF

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ALEF_HAMZA_ABOVE Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..ALEF_HAMZA_ABOVE Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.ALEF_HAMZA_ABOVE"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char ALEF_HAMZA_ABOVE
Visual Basic
Public Shared ALEF_HAMZA_ABOVE As Char
Visual C++
public:
static wchar_t ALEF_HAMZA_ABOVE

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ALEF_HAMZA_BELOW Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..ALEF_HAMZA_BELOW Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.ALEF_HAMZA_BELOW"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char ALEF_HAMZA_BELOW
Visual Basic
Public Shared ALEF_HAMZA_BELOW As Char
Visual C++
public:
static wchar_t ALEF_HAMZA_BELOW

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ALEF_MADDA Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..ALEF_MADDA Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.ALEF_MADDA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char ALEF_MADDA
Visual Basic
Public Shared ALEF_MADDA As Char
Visual C++
public:
static wchar_t ALEF_MADDA

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


DAMMA Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..DAMMA Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.DAMMA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char DAMMA
Visual Basic
Public Shared DAMMA As Char
Visual C++
public:
static wchar_t DAMMA

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


DAMMATAN Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..DAMMATAN Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.DAMMATAN"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char DAMMATAN
Visual Basic
Public Shared DAMMATAN As Char
Visual C++
public:
static wchar_t DAMMATAN

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


DOTLESS_YEH Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..DOTLESS_YEH Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.DOTLESS_YEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char DOTLESS_YEH
Visual Basic
Public Shared DOTLESS_YEH As Char
Visual C++
public:
static wchar_t DOTLESS_YEH

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


FATHA Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..FATHA Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.FATHA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char FATHA
Visual Basic
Public Shared FATHA As Char
Visual C++
public:
static wchar_t FATHA

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


FATHATAN Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..FATHATAN Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.FATHATAN"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char FATHATAN
Visual Basic
Public Shared FATHATAN As Char
Visual C++
public:
static wchar_t FATHATAN

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


HEH Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..HEH Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.HEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char HEH
Visual Basic
Public Shared HEH As Char
Visual C++
public:
static wchar_t HEH

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


KASRA Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..KASRA Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.KASRA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char KASRA
Visual Basic
Public Shared KASRA As Char
Visual C++
public:
static wchar_t KASRA

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


KASRATAN Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..KASRATAN Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.KASRATAN"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char KASRATAN
Visual Basic
Public Shared KASRATAN As Char
Visual C++
public:
static wchar_t KASRATAN

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


SHADDA Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..SHADDA Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.SHADDA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char SHADDA
Visual Basic
Public Shared SHADDA As Char
Visual C++
public:
static wchar_t SHADDA

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


SUKUN Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..SUKUN Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.SUKUN"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char SUKUN
Visual Basic
Public Shared SUKUN As Char
Visual C++
public:
static wchar_t SUKUN

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


TATWEEL Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..TATWEEL Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.TATWEEL"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char TATWEEL
Visual Basic
Public Shared TATWEEL As Char
Visual C++
public:
static wchar_t TATWEEL

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


TEH_MARBUTA Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..TEH_MARBUTA Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.TEH_MARBUTA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char TEH_MARBUTA
Visual Basic
Public Shared TEH_MARBUTA As Char
Visual C++
public:
static wchar_t TEH_MARBUTA

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


YEH Field

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..YEH Field
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicNormalizer.YEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char YEH
Visual Basic
Public Shared YEH As Char
Visual C++
public:
static wchar_t YEH

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ArabicNormalizer Methods

[image] [image]

Lucene.Net Class Libraries
ArabicNormalizer Methods
ArabicNormalizer Class See Also Send Feedback

The ArabicNormalizer type exposes the following members.

Methods

 | Name | Description
Protected method | Delete |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


Delete Method

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..Delete Method
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Delete(System.Char[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected int Delete(
    char[] s,
    int pos,
    int len
)
Visual Basic
Protected Function Delete ( _
    s As Char(), _
    pos As Integer, _
    len As Integer _
) As Integer
Visual C++
protected:
int Delete(
    array<wchar_t>^ s,
    int pos,
    int len
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Delete(System.Char[],System.Int32,System.Int32)"]

pos
Type: System..::..Int32

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Delete(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Delete(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Delete(System.Char[],System.Int32,System.Int32)"]

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
ArabicNormalizer..::..Normalize Method
ArabicNormalizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Normalize(System.Char[],System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int Normalize(
    char[] s,
    int len
)
Visual Basic
Public Function Normalize ( _
    s As Char(), _
    len As Integer _
) As Integer
Visual C++
public:
int Normalize(
    array<wchar_t>^ s,
    int len
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Normalize(System.Char[],System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Normalize(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicNormalizer.Normalize(System.Char[],System.Int32)"]

See Also

ArabicNormalizer Class
Lucene.Net.Analysis.AR Namespace


ArabicStemFilter Class

[image]

Lucene.Net Class Libraries
ArabicStemFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.AR.ArabicStemFilter"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ArabicStemFilter : TokenFilter
Visual Basic
Public Class ArabicStemFilter _
    Inherits TokenFilter
Visual C++
public ref class ArabicStemFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.AR..::..ArabicStemFilter

See Also

ArabicStemFilter Members
Lucene.Net.Analysis.AR Namespace


ArabicStemFilter Members

[image] [image]

Lucene.Net Class Libraries
ArabicStemFilter Members
ArabicStemFilter Class Constructors Methods Fields See Also Send Feedback

The ArabicStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ArabicStemFilter | Initializes a new instance of the ArabicStemFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Protected field | stemmer |

See Also

ArabicStemFilter Class
Lucene.Net.Analysis.AR Namespace


ArabicStemFilter Constructor

[image]

Lucene.Net Class Libraries
ArabicStemFilter Constructor
ArabicStemFilter Class See Also Send Feedback
Initializes a new instance of the ArabicStemFilter class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicStemFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
ArabicStemFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

ArabicStemFilter Class
Lucene.Net.Analysis.AR Namespace


ArabicStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
ArabicStemFilter Fields
ArabicStemFilter Class See Also Send Feedback

The ArabicStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
Protected field | stemmer |

See Also

ArabicStemFilter Class
Lucene.Net.Analysis.AR Namespace


stemmer Field

[image]

Lucene.Net Class Libraries
ArabicStemFilter..::..stemmer Field
ArabicStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemFilter.stemmer"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected ArabicStemmer stemmer
Visual Basic
Protected stemmer As ArabicStemmer
Visual C++
protected:
ArabicStemmer^ stemmer

See Also

ArabicStemFilter Class
Lucene.Net.Analysis.AR Namespace


ArabicStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
ArabicStemFilter Methods
ArabicStemFilter Class See Also Send Feedback

The ArabicStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ArabicStemFilter Class
Lucene.Net.Analysis.AR Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
ArabicStemFilter..::..IncrementToken Method
ArabicStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemFilter.IncrementToken"]

See Also

ArabicStemFilter Class
Lucene.Net.Analysis.AR Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ArabicStemFilter..::..Next Method
ArabicStemFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

ArabicStemFilter Class
ArabicStemFilter Members
Lucene.Net.Analysis.AR Namespace


ArabicStemmer Class

[image]

Lucene.Net Class Libraries
ArabicStemmer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.AR.ArabicStemmer"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ArabicStemmer
Visual Basic
Public Class ArabicStemmer
Visual C++
public ref class ArabicStemmer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.AR..::..ArabicStemmer

See Also

ArabicStemmer Members
Lucene.Net.Analysis.AR Namespace


ArabicStemmer Members

[image] [image]

Lucene.Net Class Libraries
ArabicStemmer Members
ArabicStemmer Class Constructors Methods Fields See Also Send Feedback

The ArabicStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | ArabicStemmer | Initializes a new instance of the ArabicStemmer class

Methods

 | Name | Description
Protected method | Delete |
Protected method | DeleteN |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stem |
Public method | StemPrefix |
Public method | StemSuffix |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ALEF |
BEH |
FEH |
HEH |
KAF |
LAM |
NOON |
prefixes |
suffixes |
TEH |
TEH_MARBUTA |
WAW |
YEH |

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


ArabicStemmer Constructor

[image]

Lucene.Net Class Libraries
ArabicStemmer Constructor
ArabicStemmer Class See Also Send Feedback
Initializes a new instance of the ArabicStemmer class

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ArabicStemmer()
Visual Basic
Public Sub New
Visual C++
public:
ArabicStemmer()

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


ArabicStemmer Fields

[image] [image]

Lucene.Net Class Libraries
ArabicStemmer Fields
ArabicStemmer Class See Also Send Feedback

The ArabicStemmer type exposes the following members.

Fields

Name | Description
ALEF |
BEH |
FEH |
HEH |
KAF |
LAM |
NOON |
prefixes |
suffixes |
TEH |
TEH_MARBUTA |
WAW |
YEH |

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


ALEF Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..ALEF Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.ALEF"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char ALEF
Visual Basic
Public Shared ALEF As Char
Visual C++
public:
static wchar_t ALEF

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


BEH Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..BEH Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.BEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char BEH
Visual Basic
Public Shared BEH As Char
Visual C++
public:
static wchar_t BEH

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


FEH Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..FEH Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.FEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char FEH
Visual Basic
Public Shared FEH As Char
Visual C++
public:
static wchar_t FEH

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


HEH Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..HEH Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.HEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char HEH
Visual Basic
Public Shared HEH As Char
Visual C++
public:
static wchar_t HEH

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


KAF Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..KAF Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.KAF"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char KAF
Visual Basic
Public Shared KAF As Char
Visual C++
public:
static wchar_t KAF

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


LAM Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..LAM Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.LAM"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char LAM
Visual Basic
Public Shared LAM As Char
Visual C++
public:
static wchar_t LAM

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


NOON Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..NOON Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.NOON"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char NOON
Visual Basic
Public Shared NOON As Char
Visual C++
public:
static wchar_t NOON

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


prefixes Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..prefixes Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.prefixes"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char[][] prefixes
Visual Basic
Public Shared prefixes As Char()()
Visual C++
public:
static array<array<wchar_t>^>^ prefixes

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


suffixes Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..suffixes Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.suffixes"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char[][] suffixes
Visual Basic
Public Shared suffixes As Char()()
Visual C++
public:
static array<array<wchar_t>^>^ suffixes

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


TEH Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..TEH Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.TEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char TEH
Visual Basic
Public Shared TEH As Char
Visual C++
public:
static wchar_t TEH

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


TEH_MARBUTA Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..TEH_MARBUTA Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.TEH_MARBUTA"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char TEH_MARBUTA
Visual Basic
Public Shared TEH_MARBUTA As Char
Visual C++
public:
static wchar_t TEH_MARBUTA

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


WAW Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..WAW Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.WAW"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char WAW
Visual Basic
Public Shared WAW As Char
Visual C++
public:
static wchar_t WAW

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


YEH Field

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..YEH Field
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.AR.ArabicStemmer.YEH"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char YEH
Visual Basic
Public Shared YEH As Char
Visual C++
public:
static wchar_t YEH

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


ArabicStemmer Methods

[image] [image]

Lucene.Net Class Libraries
ArabicStemmer Methods
ArabicStemmer Class See Also Send Feedback

The ArabicStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | Delete |
Protected method | DeleteN |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stem |
Public method | StemPrefix |
Public method | StemSuffix |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


Delete Method

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..Delete Method
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Delete(System.Char[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected int Delete(
    char[] s,
    int pos,
    int len
)
Visual Basic
Protected Function Delete ( _
    s As Char(), _
    pos As Integer, _
    len As Integer _
) As Integer
Visual C++
protected:
int Delete(
    array<wchar_t>^ s,
    int pos,
    int len
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Delete(System.Char[],System.Int32,System.Int32)"]

pos
Type: System..::..Int32

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Delete(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Delete(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Delete(System.Char[],System.Int32,System.Int32)"]

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


DeleteN Method

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..DeleteN Method
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.DeleteN(System.Char[],System.Int32,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected int DeleteN(
    char[] s,
    int pos,
    int len,
    int nChars
)
Visual Basic
Protected Function DeleteN ( _
    s As Char(), _
    pos As Integer, _
    len As Integer, _
    nChars As Integer _
) As Integer
Visual C++
protected:
int DeleteN(
    array<wchar_t>^ s,
    int pos,
    int len,
    int nChars
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.DeleteN(System.Char[],System.Int32,System.Int32,System.Int32)"]

pos
Type: System..::..Int32

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.DeleteN(System.Char[],System.Int32,System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.DeleteN(System.Char[],System.Int32,System.Int32,System.Int32)"]

nChars
Type: System..::..Int32

[Missing <param name="nChars"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.DeleteN(System.Char[],System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.DeleteN(System.Char[],System.Int32,System.Int32,System.Int32)"]

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


Stem Method

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..Stem Method
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Stem(System.Char[],System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int Stem(
    char[] s,
    int len
)
Visual Basic
Public Function Stem ( _
    s As Char(), _
    len As Integer _
) As Integer
Visual C++
public:
int Stem(
    array<wchar_t>^ s,
    int len
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Stem(System.Char[],System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Stem(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.Stem(System.Char[],System.Int32)"]

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


StemPrefix Method

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..StemPrefix Method
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemPrefix(System.Char[],System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int StemPrefix(
    char[] s,
    int len
)
Visual Basic
Public Function StemPrefix ( _
    s As Char(), _
    len As Integer _
) As Integer
Visual C++
public:
int StemPrefix(
    array<wchar_t>^ s,
    int len
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemPrefix(System.Char[],System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemPrefix(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemPrefix(System.Char[],System.Int32)"]

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


StemSuffix Method

[image]

Lucene.Net Class Libraries
ArabicStemmer..::..StemSuffix Method
ArabicStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemSuffix(System.Char[],System.Int32)"]

Namespace: Lucene.Net.Analysis.AR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int StemSuffix(
    char[] s,
    int len
)
Visual Basic
Public Function StemSuffix ( _
    s As Char(), _
    len As Integer _
) As Integer
Visual C++
public:
int StemSuffix(
    array<wchar_t>^ s,
    int len
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemSuffix(System.Char[],System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemSuffix(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.AR.ArabicStemmer.StemSuffix(System.Char[],System.Int32)"]

See Also

ArabicStemmer Class
Lucene.Net.Analysis.AR Namespace


Lucene.Net.Analysis.BR Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.BR Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.BR"]

Classes

 | Class | Description
Public class | BrazilianAnalyzer |
Public class | BrazilianStemFilter |
Public class | BrazilianStemmer |


BrazilianAnalyzer Class

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.BR.BrazilianAnalyzer"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class BrazilianAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class BrazilianAnalyzer _
    Inherits Analyzer
Visual C++
public ref class BrazilianAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.BR..::..BrazilianAnalyzer

See Also

BrazilianAnalyzer Members
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
BrazilianAnalyzer Members
BrazilianAnalyzer Class Constructors Methods Fields See Also Send Feedback

The BrazilianAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | BrazilianAnalyzer()()()() | Initializes a new instance of the BrazilianAnalyzer class
Public method | BrazilianAnalyzer(Hashtable) | Initializes a new instance of the BrazilianAnalyzer class
Public method | BrazilianAnalyzer(FileInfo) | Initializes a new instance of the BrazilianAnalyzer class
Public method | BrazilianAnalyzer(array<String>[]()[][]) | Initializes a new instance of the BrazilianAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemExclusionTable(Hashtable) |
Public method | SetStemExclusionTable(FileInfo) |
Public method | SetStemExclusionTable(array<String>[]()[][]) |
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | BRAZILIAN_STOP_WORDS |
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

BrazilianAnalyzer Class
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
BrazilianAnalyzer Constructor
BrazilianAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BrazilianAnalyzer()()()() | Initializes a new instance of the BrazilianAnalyzer class
Public method | BrazilianAnalyzer(Hashtable) | Initializes a new instance of the BrazilianAnalyzer class
Public method | BrazilianAnalyzer(FileInfo) | Initializes a new instance of the BrazilianAnalyzer class
Public method | BrazilianAnalyzer(array<String>[]()[][]) | Initializes a new instance of the BrazilianAnalyzer class

See Also

BrazilianAnalyzer Class
BrazilianAnalyzer Members
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Constructor

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer Constructor
BrazilianAnalyzer Class See Also Send Feedback
Initializes a new instance of the BrazilianAnalyzer class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
BrazilianAnalyzer()

See Also

BrazilianAnalyzer Class
BrazilianAnalyzer Overload
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer Constructor (Hashtable)
BrazilianAnalyzer Class See Also Send Feedback
Initializes a new instance of the BrazilianAnalyzer class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianAnalyzer(
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As Hashtable _
)
Visual C++
public:
BrazilianAnalyzer(
    Hashtable^ stopwords
)

Parameters

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

BrazilianAnalyzer Class
BrazilianAnalyzer Overload
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer Constructor (FileInfo)
BrazilianAnalyzer Class See Also Send Feedback
Initializes a new instance of the BrazilianAnalyzer class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianAnalyzer(
    FileInfo stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As FileInfo _
)
Visual C++
public:
BrazilianAnalyzer(
    FileInfo^ stopwords
)

Parameters

stopwords
Type: System.IO..::..FileInfo

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

BrazilianAnalyzer Class
BrazilianAnalyzer Overload
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer Constructor (array<String>[]()[][])
BrazilianAnalyzer Class See Also Send Feedback
Initializes a new instance of the BrazilianAnalyzer class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianAnalyzer(
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As String() _
)
Visual C++
public:
BrazilianAnalyzer(
    array<String^>^ stopwords
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.#ctor(System.String[])"]

See Also

BrazilianAnalyzer Class
BrazilianAnalyzer Overload
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
BrazilianAnalyzer Fields
BrazilianAnalyzer Class See Also Send Feedback

The BrazilianAnalyzer type exposes the following members.

Fields

 | Name | Description
 | BRAZILIAN_STOP_WORDS |
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

BrazilianAnalyzer Class
Lucene.Net.Analysis.BR Namespace


BRAZILIAN_STOP_WORDS Field

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer..::..BRAZILIAN_STOP_WORDS Field
BrazilianAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.BR.BrazilianAnalyzer.BRAZILIAN_STOP_WORDS"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string[] BRAZILIAN_STOP_WORDS
Visual Basic
Public Shared BRAZILIAN_STOP_WORDS As String()
Visual C++
public:
static array<String^>^ BRAZILIAN_STOP_WORDS

See Also

BrazilianAnalyzer Class
Lucene.Net.Analysis.BR Namespace


BrazilianAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
BrazilianAnalyzer Methods
BrazilianAnalyzer Class See Also Send Feedback

The BrazilianAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemExclusionTable(Hashtable) |
Public method | SetStemExclusionTable(FileInfo) |
Public method | SetStemExclusionTable(array<String>[]()[][]) |
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrazilianAnalyzer Class
Lucene.Net.Analysis.BR Namespace


SetStemExclusionTable Method

[image] [image]

Lucene.Net Class Libraries
BrazilianAnalyzer..::..SetStemExclusionTable Method
BrazilianAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetStemExclusionTable(Hashtable) |
Public method | SetStemExclusionTable(FileInfo) |
Public method | SetStemExclusionTable(array<String>[]()[][]) |

See Also

BrazilianAnalyzer Class
BrazilianAnalyzer Members
Lucene.Net.Analysis.BR Namespace


SetStemExclusionTable Method (Hashtable)

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer..::..SetStemExclusionTable Method (Hashtable)
BrazilianAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.SetStemExclusionTable(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    Hashtable exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As Hashtable _
)
Visual C++
public:
void SetStemExclusionTable(
    Hashtable^ exclusionlist
)

Parameters

exclusionlist
Type: System.Collections..::..Hashtable

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.SetStemExclusionTable(System.Collections.Hashtable)"]

See Also

BrazilianAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.BR Namespace


SetStemExclusionTable Method (FileInfo)

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer..::..SetStemExclusionTable Method (FileInfo)
BrazilianAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.SetStemExclusionTable(System.IO.FileInfo)"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    FileInfo exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As FileInfo _
)
Visual C++
public:
void SetStemExclusionTable(
    FileInfo^ exclusionlist
)

Parameters

exclusionlist
Type: System.IO..::..FileInfo

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.SetStemExclusionTable(System.IO.FileInfo)"]

See Also

BrazilianAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.BR Namespace


SetStemExclusionTable Method (String[])

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer..::..SetStemExclusionTable Method (array<String>[]()[][])
BrazilianAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.SetStemExclusionTable(System.String[])"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    string[] exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As String() _
)
Visual C++
public:
void SetStemExclusionTable(
    array<String^>^ exclusionlist
)

Parameters

exclusionlist
Type: array< System..::..String >[]()[][]

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.SetStemExclusionTable(System.String[])"]

See Also

BrazilianAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.BR Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
BrazilianAnalyzer..::..TokenStream Method
BrazilianAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.BR.BrazilianAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

BrazilianAnalyzer Class
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Class

[image]

Lucene.Net Class Libraries
BrazilianStemFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.BR.BrazilianStemFilter"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class BrazilianStemFilter : TokenFilter
Visual Basic
Public NotInheritable Class BrazilianStemFilter _
    Inherits TokenFilter
Visual C++
public ref class BrazilianStemFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.BR..::..BrazilianStemFilter

See Also

BrazilianStemFilter Members
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Members

[image] [image]

Lucene.Net Class Libraries
BrazilianStemFilter Members
BrazilianStemFilter Class Constructors Methods Fields See Also Send Feedback

The BrazilianStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BrazilianStemFilter(TokenStream) | Initializes a new instance of the BrazilianStemFilter class
Public method | BrazilianStemFilter(TokenStream, Hashtable) | Initializes a new instance of the BrazilianStemFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method | Next(Token) | (Overrides TokenStream..::..Next(Token).)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

BrazilianStemFilter Class
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Constructor

[image] [image]

Lucene.Net Class Libraries
BrazilianStemFilter Constructor
BrazilianStemFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BrazilianStemFilter(TokenStream) | Initializes a new instance of the BrazilianStemFilter class
Public method | BrazilianStemFilter(TokenStream, Hashtable) | Initializes a new instance of the BrazilianStemFilter class

See Also

BrazilianStemFilter Class
BrazilianStemFilter Members
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
BrazilianStemFilter Constructor (TokenStream)
BrazilianStemFilter Class See Also Send Feedback
Initializes a new instance of the BrazilianStemFilter class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianStemFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
BrazilianStemFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

BrazilianStemFilter Class
BrazilianStemFilter Overload
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Constructor (TokenStream, Hashtable)

[image]

Lucene.Net Class Libraries
BrazilianStemFilter Constructor (TokenStream, Hashtable)
BrazilianStemFilter Class See Also Send Feedback
Initializes a new instance of the BrazilianStemFilter class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianStemFilter(
    TokenStream input,
    Hashtable exclusiontable
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    exclusiontable As Hashtable _
)
Visual C++
public:
BrazilianStemFilter(
    TokenStream^ input,
    Hashtable^ exclusiontable
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

See Also

BrazilianStemFilter Class
BrazilianStemFilter Overload
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
BrazilianStemFilter Fields
BrazilianStemFilter Class See Also Send Feedback

The BrazilianStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

BrazilianStemFilter Class
Lucene.Net.Analysis.BR Namespace


BrazilianStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
BrazilianStemFilter Methods
BrazilianStemFilter Class See Also Send Feedback

The BrazilianStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method | Next(Token) | (Overrides TokenStream..::..Next(Token).)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

BrazilianStemFilter Class
Lucene.Net.Analysis.BR Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
BrazilianStemFilter..::..Next Method
BrazilianStemFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. Returns the next {@link Token} in the stream, or null at EOS. (Inherited from TokenStream.)
Public method | Next(Token) | (Overrides TokenStream..::..Next(Token).)

See Also

BrazilianStemFilter Class
BrazilianStemFilter Members
Lucene.Net.Analysis.BR Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
BrazilianStemFilter..::..Next Method (Token)
BrazilianStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemFilter.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next(
    Token reusableToken
)
Visual Basic
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

BrazilianStemFilter Class
Next Overload
Lucene.Net.Analysis.BR Namespace


BrazilianStemmer Class

[image]

Lucene.Net Class Libraries
BrazilianStemmer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.BR.BrazilianStemmer"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class BrazilianStemmer
Visual Basic
Public Class BrazilianStemmer
Visual C++
public ref class BrazilianStemmer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.BR..::..BrazilianStemmer

See Also

BrazilianStemmer Members
Lucene.Net.Analysis.BR Namespace


BrazilianStemmer Members

[image] [image]

Lucene.Net Class Libraries
BrazilianStemmer Members
BrazilianStemmer Class Constructors Methods See Also Send Feedback

The BrazilianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | BrazilianStemmer | Initializes a new instance of the BrazilianStemmer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrazilianStemmer Class
Lucene.Net.Analysis.BR Namespace


BrazilianStemmer Constructor

[image]

Lucene.Net Class Libraries
BrazilianStemmer Constructor
BrazilianStemmer Class See Also Send Feedback
Initializes a new instance of the BrazilianStemmer class

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public BrazilianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
BrazilianStemmer()

See Also

BrazilianStemmer Class
Lucene.Net.Analysis.BR Namespace


BrazilianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
BrazilianStemmer Methods
BrazilianStemmer Class See Also Send Feedback

The BrazilianStemmer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrazilianStemmer Class
Lucene.Net.Analysis.BR Namespace


Log Method

[image]

Lucene.Net Class Libraries
BrazilianStemmer..::..Log Method
BrazilianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemmer.Log"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public string Log()
Visual Basic
Public Function Log As String
Visual C++
public:
String^ Log()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemmer.Log"]

See Also

BrazilianStemmer Class
Lucene.Net.Analysis.BR Namespace


Stem Method

[image]

Lucene.Net Class Libraries
BrazilianStemmer..::..Stem Method
BrazilianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemmer.Stem(System.String)"]

Namespace: Lucene.Net.Analysis.BR
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public string Stem(
    string term
)
Visual Basic
Public Function Stem ( _
    term As String _
) As String
Visual C++
public:
String^ Stem(
    String^ term
)

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemmer.Stem(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.BR.BrazilianStemmer.Stem(System.String)"]

See Also

BrazilianStemmer Class
Lucene.Net.Analysis.BR Namespace


Lucene.Net.Analysis.CJK Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.CJK Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.CJK"]

Classes

 | Class | Description
Public class | CJKAnalyzer | Filters CJKTokenizer with StopFilter. Che, Dong
Public class | CJKTokenizer |


CJKAnalyzer Class

[image]

Lucene.Net Class Libraries
CJKAnalyzer Class
Members See Also Send Feedback
Filters CJKTokenizer with StopFilter. Che, Dong

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class CJKAnalyzer : Analyzer
Visual Basic
Public Class CJKAnalyzer _
    Inherits Analyzer
Visual C++
public ref class CJKAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.CJK..::..CJKAnalyzer

See Also

CJKAnalyzer Members
Lucene.Net.Analysis.CJK Namespace


CJKAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
CJKAnalyzer Members
CJKAnalyzer Class Constructors Methods Fields See Also Send Feedback

The CJKAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | CJKAnalyzer()()()() | Builds an analyzer which removes words in STOP_WORDS.
Public method | CJKAnalyzer(array<String>[]()[][]) | Builds an analyzer which removes words in the provided array.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | get token stream from input (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | stopWords | An array containing some common English words that are not usually useful for searching. and some double-byte interpunctions.....

See Also

CJKAnalyzer Class
Lucene.Net.Analysis.CJK Namespace


CJKAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
CJKAnalyzer Constructor
CJKAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CJKAnalyzer()()()() | Builds an analyzer which removes words in STOP_WORDS.
Public method | CJKAnalyzer(array<String>[]()[][]) | Builds an analyzer which removes words in the provided array.

See Also

CJKAnalyzer Class
CJKAnalyzer Members
Lucene.Net.Analysis.CJK Namespace


CJKAnalyzer Constructor

[image]

Lucene.Net Class Libraries
CJKAnalyzer Constructor
CJKAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in STOP_WORDS.

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CJKAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
CJKAnalyzer()

See Also

CJKAnalyzer Class
CJKAnalyzer Overload
Lucene.Net.Analysis.CJK Namespace


CJKAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
CJKAnalyzer Constructor (array<String>[]()[][])
CJKAnalyzer Class See Also Send Feedback
Builds an analyzer which removes words in the provided array.

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CJKAnalyzer(
    string[] stopWords
)
Visual Basic
Public Sub New ( _
    stopWords As String() _
)
Visual C++
public:
CJKAnalyzer(
    array<String^>^ stopWords
)

Parameters

stopWords
Type: array< System..::..String >[]()[][]
stop word array

See Also

CJKAnalyzer Class
CJKAnalyzer Overload
Lucene.Net.Analysis.CJK Namespace


CJKAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
CJKAnalyzer Fields
CJKAnalyzer Class See Also Send Feedback

The CJKAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | stopWords | An array containing some common English words that are not usually useful for searching. and some double-byte interpunctions.....

See Also

CJKAnalyzer Class
Lucene.Net.Analysis.CJK Namespace


stopWords Field

[image]

Lucene.Net Class Libraries
CJKAnalyzer..::..stopWords Field
CJKAnalyzer Class See Also Send Feedback
An array containing some common English words that are not usually useful for searching. and some double-byte interpunctions.....

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string[] stopWords
Visual Basic
Public Shared stopWords As String()
Visual C++
public:
static array<String^>^ stopWords

See Also

CJKAnalyzer Class
Lucene.Net.Analysis.CJK Namespace


CJKAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
CJKAnalyzer Methods
CJKAnalyzer Class See Also Send Feedback

The CJKAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | get token stream from input (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CJKAnalyzer Class
Lucene.Net.Analysis.CJK Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
CJKAnalyzer..::..TokenStream Method
CJKAnalyzer Class See Also Send Feedback
get token stream from input

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override sealed TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides NotOverridable Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override sealed

Parameters

fieldName
Type: System..::..String
lucene field name
reader
Type: System.IO..::..TextReader
input reader

Return Value

Token Stream

See Also

CJKAnalyzer Class
Lucene.Net.Analysis.CJK Namespace


CJKTokenizer Class

[image]

Lucene.Net Class Libraries
CJKTokenizer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.CJK.CJKTokenizer"]

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class CJKTokenizer : Tokenizer
Visual Basic
Public NotInheritable Class CJKTokenizer _
    Inherits Tokenizer
Visual C++
public ref class CJKTokenizer sealed : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis.CJK..::..CJKTokenizer

See Also

CJKTokenizer Members
Lucene.Net.Analysis.CJK Namespace


CJKTokenizer Members

[image] [image]

Lucene.Net Class Libraries
CJKTokenizer Members
CJKTokenizer Class Constructors Methods Fields See Also Send Feedback

The CJKTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | CJKTokenizer | Construct a token stream processing the given input.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
Returns the next token in the stream, or null at EOS.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

CJKTokenizer Class
Lucene.Net.Analysis.CJK Namespace


CJKTokenizer Constructor

[image]

Lucene.Net Class Libraries
CJKTokenizer Constructor
CJKTokenizer Class See Also Send Feedback
Construct a token stream processing the given input.

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CJKTokenizer(
    TextReader _in
)
Visual Basic
Public Sub New ( _
    _in As TextReader _
)
Visual C++
public:
CJKTokenizer(
    TextReader^ _in
)

Parameters

_in
Type: System.IO..::..TextReader
I/O reader

See Also

CJKTokenizer Class
Lucene.Net.Analysis.CJK Namespace


CJKTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
CJKTokenizer Fields
CJKTokenizer Class See Also Send Feedback

The CJKTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

CJKTokenizer Class
Lucene.Net.Analysis.CJK Namespace


CJKTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
CJKTokenizer Methods
CJKTokenizer Class See Also Send Feedback

The CJKTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
Returns the next token in the stream, or null at EOS.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

CJKTokenizer Class
Lucene.Net.Analysis.CJK Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
CJKTokenizer..::..Next Method
CJKTokenizer Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()()
Returns the next token in the stream, or null at EOS.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

CJKTokenizer Class
CJKTokenizer Members
Lucene.Net.Analysis.CJK Namespace


Next Method

[image]

Lucene.Net Class Libraries
CJKTokenizer..::..Next Method
CJKTokenizer Class See Also Send Feedback
Returns the next token in the stream, or null at EOS.

Namespace: Lucene.Net.Analysis.CJK
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

Token

See Also

CJKTokenizer Class
Next Overload
Lucene.Net.Analysis.CJK Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
CJKTokenizer..::..Reset Method
CJKTokenizer Class See Also Send Feedback

Overload List

Name Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)

See Also

CJKTokenizer Class
CJKTokenizer Members
Lucene.Net.Analysis.CJK Namespace


Lucene.Net.Analysis.Cn Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Cn Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Cn"]

Classes

 | Class | Description
Public class | ChineseAnalyzer | Title: ChineseAnalyzer Description: Subclass of org.apache.lucene.analysis.Analyzer build from a ChineseTokenizer, filtered with ChineseFilter. Copyright: Copyright (c) 2001 Company: Yiyi Sun$Id: ChineseAnalyzer.java, v 1.2 2003/01/22 20:54:47 ehatcher Exp $
Public class | ChineseFilter | Title: ChineseFilter Description: Filter with a stop word table Rule: No digital is allowed. English word/token should larger than 1 character. One Chinese character as one Chinese word. TO DO: 1. Add Chinese stop words, such as \ue400 2. Dictionary based Chinese word extraction 3. Intelligent Chinese word extraction Copyright: Copyright (c) 2001 Company: Yiyi Sun$Id: ChineseFilter.java, v 1.4 2003/01/23 12:49:33 ehatcher Exp $
Public class | ChineseTokenizer | Title: ChineseTokenizer Description: Extract tokens from the Stream using Character.getType() Rule: A Chinese character as a single token Copyright: Copyright (c) 2001 Company: The difference between thr ChineseTokenizer and the CJKTokenizer (id=23545) is that they have different token parsing logic. Let me use an example. If having a Chinese text "C1C2C3C4" to be indexed, the tokens returned from the ChineseTokenizer are C1, C2, C3, C4. And the tokens returned from the CJKTokenizer are C1C2, C2C3, C3C4. Therefore the index the CJKTokenizer created is much larger. The problem is that when searching for C1, C1C2, C1C3, C4C2, C1C2C3 ... the ChineseTokenizer works, but the CJKTokenizer will not work. Yiyi Sun$Id: ChineseTokenizer.java, v 1.4 2003/03/02 13:56:03 otis Exp $


ChineseAnalyzer Class

[image]

Lucene.Net Class Libraries
ChineseAnalyzer Class
Members See Also Send Feedback
Title: ChineseAnalyzer Description: Subclass of org.apache.lucene.analysis.Analyzer build from a ChineseTokenizer, filtered with ChineseFilter. Copyright: Copyright (c) 2001 Company: Yiyi Sun$Id: ChineseAnalyzer.java, v 1.2 2003/01/22 20:54:47 ehatcher Exp $

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ChineseAnalyzer : Analyzer
Visual Basic
Public Class ChineseAnalyzer _
    Inherits Analyzer
Visual C++
public ref class ChineseAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Cn..::..ChineseAnalyzer

See Also

ChineseAnalyzer Members
Lucene.Net.Analysis.Cn Namespace


ChineseAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
ChineseAnalyzer Members
ChineseAnalyzer Class Constructors Methods Fields See Also Send Feedback

The ChineseAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | ChineseAnalyzer | Initializes a new instance of the ChineseAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

ChineseAnalyzer Class
Lucene.Net.Analysis.Cn Namespace


ChineseAnalyzer Constructor

[image]

Lucene.Net Class Libraries
ChineseAnalyzer Constructor
ChineseAnalyzer Class See Also Send Feedback
Initializes a new instance of the ChineseAnalyzer class

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ChineseAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
ChineseAnalyzer()

See Also

ChineseAnalyzer Class
Lucene.Net.Analysis.Cn Namespace


ChineseAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
ChineseAnalyzer Fields
ChineseAnalyzer Class See Also Send Feedback

The ChineseAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

ChineseAnalyzer Class
Lucene.Net.Analysis.Cn Namespace


ChineseAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
ChineseAnalyzer Methods
ChineseAnalyzer Class See Also Send Feedback

The ChineseAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChineseAnalyzer Class
Lucene.Net.Analysis.Cn Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
ChineseAnalyzer..::..TokenStream Method
ChineseAnalyzer Class See Also Send Feedback
Creates a TokenStream which tokenizes all the text in the provided Reader.

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override sealed TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides NotOverridable Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override sealed

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Cn.ChineseAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Cn.ChineseAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

A TokenStream build from a ChineseTokenizer filtered with ChineseFilter.

See Also

ChineseAnalyzer Class
Lucene.Net.Analysis.Cn Namespace


ChineseFilter Class

[image]

Lucene.Net Class Libraries
ChineseFilter Class
Members See Also Send Feedback
Title: ChineseFilter Description: Filter with a stop word table Rule: No digital is allowed. English word/token should larger than 1 character. One Chinese character as one Chinese word. TO DO: 1. Add Chinese stop words, such as \ue400 2. Dictionary based Chinese word extraction 3. Intelligent Chinese word extraction Copyright: Copyright (c) 2001 Company: Yiyi Sun$Id: ChineseFilter.java, v 1.4 2003/01/23 12:49:33 ehatcher Exp $

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class ChineseFilter : TokenFilter
Visual Basic
Public NotInheritable Class ChineseFilter _
    Inherits TokenFilter
Visual C++
public ref class ChineseFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Cn..::..ChineseFilter

See Also

ChineseFilter Members
Lucene.Net.Analysis.Cn Namespace


ChineseFilter Members

[image] [image]

Lucene.Net Class Libraries
ChineseFilter Members
ChineseFilter Class Constructors Methods Fields See Also Send Feedback

The ChineseFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ChineseFilter | Initializes a new instance of the ChineseFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
 | STOP_WORDS |

See Also

ChineseFilter Class
Lucene.Net.Analysis.Cn Namespace


ChineseFilter Constructor

[image]

Lucene.Net Class Libraries
ChineseFilter Constructor
ChineseFilter Class See Also Send Feedback
Initializes a new instance of the ChineseFilter class

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ChineseFilter(
    TokenStream _in
)
Visual Basic
Public Sub New ( _
    _in As TokenStream _
)
Visual C++
public:
ChineseFilter(
    TokenStream^ _in
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Cn.ChineseFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

ChineseFilter Class
Lucene.Net.Analysis.Cn Namespace


ChineseFilter Fields

[image] [image]

Lucene.Net Class Libraries
ChineseFilter Fields
ChineseFilter Class See Also Send Feedback

The ChineseFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
 | STOP_WORDS |

See Also

ChineseFilter Class
Lucene.Net.Analysis.Cn Namespace


STOP_WORDS Field

[image]

Lucene.Net Class Libraries
ChineseFilter..::..STOP_WORDS Field
ChineseFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Cn.ChineseFilter.STOP_WORDS"]

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string[] STOP_WORDS
Visual Basic
Public Shared STOP_WORDS As String()
Visual C++
public:
static array<String^>^ STOP_WORDS

See Also

ChineseFilter Class
Lucene.Net.Analysis.Cn Namespace


ChineseFilter Methods

[image] [image]

Lucene.Net Class Libraries
ChineseFilter Methods
ChineseFilter Class See Also Send Feedback

The ChineseFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ChineseFilter Class
Lucene.Net.Analysis.Cn Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ChineseFilter..::..Next Method
ChineseFilter Class See Also Send Feedback

Overload List

Name | Description
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

ChineseFilter Class
ChineseFilter Members
Lucene.Net.Analysis.Cn Namespace


Next Method

[image]

Lucene.Net Class Libraries
ChineseFilter..::..Next Method
ChineseFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Cn.ChineseFilter.Next"]

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Cn.ChineseFilter.Next"]

See Also

ChineseFilter Class
Next Overload
Lucene.Net.Analysis.Cn Namespace


ChineseTokenizer Class

[image]

Lucene.Net Class Libraries
ChineseTokenizer Class
Members See Also Send Feedback
Title: ChineseTokenizer Description: Extract tokens from the Stream using Character.getType() Rule: A Chinese character as a single token Copyright: Copyright (c) 2001 Company: The difference between thr ChineseTokenizer and the CJKTokenizer (id=23545) is that they have different token parsing logic. Let me use an example. If having a Chinese text "C1C2C3C4" to be indexed, the tokens returned from the ChineseTokenizer are C1, C2, C3, C4. And the tokens returned from the CJKTokenizer are C1C2, C2C3, C3C4. Therefore the index the CJKTokenizer created is much larger. The problem is that when searching for C1, C1C2, C1C3, C4C2, C1C2C3 ... the ChineseTokenizer works, but the CJKTokenizer will not work. Yiyi Sun$Id: ChineseTokenizer.java, v 1.4 2003/03/02 13:56:03 otis Exp $

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class ChineseTokenizer : Tokenizer
Visual Basic
Public NotInheritable Class ChineseTokenizer _
    Inherits Tokenizer
Visual C++
public ref class ChineseTokenizer sealed : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis.Cn..::..ChineseTokenizer

See Also

ChineseTokenizer Members
Lucene.Net.Analysis.Cn Namespace


ChineseTokenizer Members

[image] [image]

Lucene.Net Class Libraries
ChineseTokenizer Members
ChineseTokenizer Class Constructors Methods Fields See Also Send Feedback

The ChineseTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | ChineseTokenizer | Initializes a new instance of the ChineseTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

ChineseTokenizer Class
Lucene.Net.Analysis.Cn Namespace


ChineseTokenizer Constructor

[image]

Lucene.Net Class Libraries
ChineseTokenizer Constructor
ChineseTokenizer Class See Also Send Feedback
Initializes a new instance of the ChineseTokenizer class

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ChineseTokenizer(
    TextReader _in
)
Visual Basic
Public Sub New ( _
    _in As TextReader _
)
Visual C++
public:
ChineseTokenizer(
    TextReader^ _in
)

Parameters

_in
Type: System.IO..::..TextReader

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Cn.ChineseTokenizer.#ctor(System.IO.TextReader)"]

See Also

ChineseTokenizer Class
Lucene.Net.Analysis.Cn Namespace


ChineseTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
ChineseTokenizer Fields
ChineseTokenizer Class See Also Send Feedback

The ChineseTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

ChineseTokenizer Class
Lucene.Net.Analysis.Cn Namespace


ChineseTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
ChineseTokenizer Methods
ChineseTokenizer Class See Also Send Feedback

The ChineseTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

ChineseTokenizer Class
Lucene.Net.Analysis.Cn Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ChineseTokenizer..::..Next Method
ChineseTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

ChineseTokenizer Class
ChineseTokenizer Members
Lucene.Net.Analysis.Cn Namespace


Next Method

[image]

Lucene.Net Class Libraries
ChineseTokenizer..::..Next Method
ChineseTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Cn.ChineseTokenizer.Next"]

Namespace: Lucene.Net.Analysis.Cn
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Cn.ChineseTokenizer.Next"]

See Also

ChineseTokenizer Class
Next Overload
Lucene.Net.Analysis.Cn Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
ChineseTokenizer..::..Reset Method
ChineseTokenizer Class See Also Send Feedback

Overload List

Name Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method Reset(TextReader)
Expert: Reset the tokenizer to a new reader. Typically, an analyzer (in its reusableTokenStream method) will use this to re-use a previously created tokenizer.
(Inherited from Tokenizer.)

See Also

ChineseTokenizer Class
ChineseTokenizer Members
Lucene.Net.Analysis.Cn Namespace


Lucene.Net.Analysis.Cz Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Cz Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Cz"]

Classes

 | Class | Description
Public class | CzechAnalyzer | Analyzer for Czech language. Supports an external list of stopwords (words that will not be indexed at all). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default. Lukas Zapletal [lzap@root.cz]$Id: CzechAnalyzer.java,v 1.2 2003/01/22 20:54:47 ehatcher Exp $


CzechAnalyzer Class

[image]

Lucene.Net Class Libraries
CzechAnalyzer Class
Members See Also Send Feedback
Analyzer for Czech language. Supports an external list of stopwords (words that will not be indexed at all). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default. Lukas Zapletal [lzap@root.cz]$Id: CzechAnalyzer.java,v 1.2 2003/01/22 20:54:47 ehatcher Exp $

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class CzechAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class CzechAnalyzer _
    Inherits Analyzer
Visual C++
public ref class CzechAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Cz..::..CzechAnalyzer

See Also

CzechAnalyzer Members
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
CzechAnalyzer Members
CzechAnalyzer Class Constructors Methods Fields See Also Send Feedback

The CzechAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | CzechAnalyzer()()()() | Builds an analyzer.
Public method | CzechAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | CzechAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | CzechAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadStopWords | Loads stopwords hash from resource stream (file, database...).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | STOP_WORDS | List of typical stopwords.

See Also

CzechAnalyzer Class
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
CzechAnalyzer Constructor
CzechAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CzechAnalyzer()()()() | Builds an analyzer.
Public method | CzechAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | CzechAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | CzechAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

See Also

CzechAnalyzer Class
CzechAnalyzer Members
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Constructor

[image]

Lucene.Net Class Libraries
CzechAnalyzer Constructor
CzechAnalyzer Class See Also Send Feedback
Builds an analyzer.

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CzechAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
CzechAnalyzer()

See Also

CzechAnalyzer Class
CzechAnalyzer Overload
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
CzechAnalyzer Constructor (Hashtable)
CzechAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CzechAnalyzer(
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As Hashtable _
)
Visual C++
public:
CzechAnalyzer(
    Hashtable^ stopwords
)

Parameters

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

CzechAnalyzer Class
CzechAnalyzer Overload
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
CzechAnalyzer Constructor (FileInfo)
CzechAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CzechAnalyzer(
    FileInfo stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As FileInfo _
)
Visual C++
public:
CzechAnalyzer(
    FileInfo^ stopwords
)

Parameters

stopwords
Type: System.IO..::..FileInfo

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

CzechAnalyzer Class
CzechAnalyzer Overload
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
CzechAnalyzer Constructor (array<String>[]()[][])
CzechAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public CzechAnalyzer(
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As String() _
)
Visual C++
public:
CzechAnalyzer(
    array<String^>^ stopwords
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.#ctor(System.String[])"]

See Also

CzechAnalyzer Class
CzechAnalyzer Overload
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
CzechAnalyzer Fields
CzechAnalyzer Class See Also Send Feedback

The CzechAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | STOP_WORDS | List of typical stopwords.

See Also

CzechAnalyzer Class
Lucene.Net.Analysis.Cz Namespace


STOP_WORDS Field

[image]

Lucene.Net Class Libraries
CzechAnalyzer..::..STOP_WORDS Field
CzechAnalyzer Class See Also Send Feedback
List of typical stopwords.

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string[] STOP_WORDS
Visual Basic
Public Shared STOP_WORDS As String()
Visual C++
public:
static array<String^>^ STOP_WORDS

See Also

CzechAnalyzer Class
Lucene.Net.Analysis.Cz Namespace


CzechAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
CzechAnalyzer Methods
CzechAnalyzer Class See Also Send Feedback

The CzechAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadStopWords | Loads stopwords hash from resource stream (file, database...).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CzechAnalyzer Class
Lucene.Net.Analysis.Cz Namespace


LoadStopWords Method

[image]

Lucene.Net Class Libraries
CzechAnalyzer..::..LoadStopWords Method
CzechAnalyzer Class See Also Send Feedback
Loads stopwords hash from resource stream (file, database...).

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void LoadStopWords(
    Stream wordfile,
    string encoding
)
Visual Basic
Public Sub LoadStopWords ( _
    wordfile As Stream, _
    encoding As String _
)
Visual C++
public:
void LoadStopWords(
    Stream^ wordfile,
    String^ encoding
)

Parameters

wordfile
Type: System.IO..::..Stream
File containing the wordlist
encoding
Type: System..::..String
Encoding used (win-1250, iso-8859-2, ...}, null for default system encoding

See Also

CzechAnalyzer Class
Lucene.Net.Analysis.Cz Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
CzechAnalyzer..::..TokenStream Method
CzechAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.Cz
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Cz.CzechAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

CzechAnalyzer Class
Lucene.Net.Analysis.Cz Namespace


Lucene.Net.Analysis.De Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.De Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.De"]

Classes

 | Class | Description
Public class | GermanAnalyzer | Analyzer for German language. Supports an external list of stopwords (words that will not be indexed at all) and an external list of exclusions (word that will not be stemmed, but indexed). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default.
Public class | GermanStemFilter | A filter that stems German words. It supports a table of words that should not be stemmed at all. The stemmer used can be changed at runtime after the filter object is created (as long as it is a GermanStemmer).
Public class | GermanStemmer | A stemmer for German words. The algorithm is based on the report "A Fast and Simple Stemming Algorithm for German Words" by JГ¶rg Caumanns (joerg.caumanns@isst.fhg.de).
Public class | WordlistLoader | Loads a text file and adds every line as an entry to a Hashtable. Every line should contain only one word. If the file is not found or on any error, an empty table is returned.


GermanAnalyzer Class

[image]

Lucene.Net Class Libraries
GermanAnalyzer Class
Members See Also Send Feedback
Analyzer for German language. Supports an external list of stopwords (words that will not be indexed at all) and an external list of exclusions (word that will not be stemmed, but indexed). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class GermanAnalyzer : Analyzer
Visual Basic
Public Class GermanAnalyzer _
    Inherits Analyzer
Visual C++
public ref class GermanAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.De..::..GermanAnalyzer

See Also

GermanAnalyzer Members
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
GermanAnalyzer Members
GermanAnalyzer Class Constructors Methods Fields See Also Send Feedback

The GermanAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | GermanAnalyzer()()()() | Builds an analyzer.
Public method | GermanAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | GermanAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | GermanAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided TextReader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

GermanAnalyzer Class
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
GermanAnalyzer Constructor
GermanAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GermanAnalyzer()()()() | Builds an analyzer.
Public method | GermanAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | GermanAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | GermanAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

See Also

GermanAnalyzer Class
GermanAnalyzer Members
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Constructor

[image]

Lucene.Net Class Libraries
GermanAnalyzer Constructor
GermanAnalyzer Class See Also Send Feedback
Builds an analyzer.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
GermanAnalyzer()

See Also

GermanAnalyzer Class
GermanAnalyzer Overload
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
GermanAnalyzer Constructor (Hashtable)
GermanAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanAnalyzer(
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As Hashtable _
)
Visual C++
public:
GermanAnalyzer(
    Hashtable^ stopwords
)

Parameters

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

GermanAnalyzer Class
GermanAnalyzer Overload
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
GermanAnalyzer Constructor (FileInfo)
GermanAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanAnalyzer(
    FileInfo stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As FileInfo _
)
Visual C++
public:
GermanAnalyzer(
    FileInfo^ stopwords
)

Parameters

stopwords
Type: System.IO..::..FileInfo

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

GermanAnalyzer Class
GermanAnalyzer Overload
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
GermanAnalyzer Constructor (array<String>[]()[][])
GermanAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanAnalyzer(
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As String() _
)
Visual C++
public:
GermanAnalyzer(
    array<String^>^ stopwords
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.#ctor(System.String[])"]

See Also

GermanAnalyzer Class
GermanAnalyzer Overload
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
GermanAnalyzer Fields
GermanAnalyzer Class See Also Send Feedback

The GermanAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

GermanAnalyzer Class
Lucene.Net.Analysis.De Namespace


GermanAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
GermanAnalyzer Methods
GermanAnalyzer Class See Also Send Feedback

The GermanAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided TextReader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GermanAnalyzer Class
Lucene.Net.Analysis.De Namespace


SetStemExclusionTable Method

[image] [image]

Lucene.Net Class Libraries
GermanAnalyzer..::..SetStemExclusionTable Method
GermanAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.

See Also

GermanAnalyzer Class
GermanAnalyzer Members
Lucene.Net.Analysis.De Namespace


SetStemExclusionTable Method (Hashtable)

[image]

Lucene.Net Class Libraries
GermanAnalyzer..::..SetStemExclusionTable Method (Hashtable)
GermanAnalyzer Class See Also Send Feedback
Builds an exclusionlist from a Hashtable.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    Hashtable exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As Hashtable _
)
Visual C++
public:
void SetStemExclusionTable(
    Hashtable^ exclusionlist
)

Parameters

exclusionlist
Type: System.Collections..::..Hashtable

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.SetStemExclusionTable(System.Collections.Hashtable)"]

See Also

GermanAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.De Namespace


SetStemExclusionTable Method (FileInfo)

[image]

Lucene.Net Class Libraries
GermanAnalyzer..::..SetStemExclusionTable Method (FileInfo)
GermanAnalyzer Class See Also Send Feedback
Builds an exclusionlist from the words contained in the given file.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    FileInfo exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As FileInfo _
)
Visual C++
public:
void SetStemExclusionTable(
    FileInfo^ exclusionlist
)

Parameters

exclusionlist
Type: System.IO..::..FileInfo

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.SetStemExclusionTable(System.IO.FileInfo)"]

See Also

GermanAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.De Namespace


SetStemExclusionTable Method (String[])

[image]

Lucene.Net Class Libraries
GermanAnalyzer..::..SetStemExclusionTable Method (array<String>[]()[][])
GermanAnalyzer Class See Also Send Feedback
Builds an exclusionlist from an array of Strings.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    string[] exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As String() _
)
Visual C++
public:
void SetStemExclusionTable(
    array<String^>^ exclusionlist
)

Parameters

exclusionlist
Type: array< System..::..String >[]()[][]

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.SetStemExclusionTable(System.String[])"]

See Also

GermanAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.De Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
GermanAnalyzer..::..TokenStream Method
GermanAnalyzer Class See Also Send Feedback
Creates a TokenStream which tokenizes all the text in the provided TextReader.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.De.GermanAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

A TokenStream build from a StandardTokenizer filtered with StandardFilter, StopFilter, GermanStemFilter

See Also

GermanAnalyzer Class
Lucene.Net.Analysis.De Namespace


GermanStemFilter Class

[image]

Lucene.Net Class Libraries
GermanStemFilter Class
Members See Also Send Feedback
A filter that stems German words. It supports a table of words that should not be stemmed at all. The stemmer used can be changed at runtime after the filter object is created (as long as it is a GermanStemmer).

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class GermanStemFilter : TokenFilter
Visual Basic
Public NotInheritable Class GermanStemFilter _
    Inherits TokenFilter
Visual C++
public ref class GermanStemFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.De..::..GermanStemFilter

See Also

GermanStemFilter Members
Lucene.Net.Analysis.De Namespace


GermanStemFilter Members

[image] [image]

Lucene.Net Class Libraries
GermanStemFilter Members
GermanStemFilter Class Constructors Methods Fields See Also Send Feedback

The GermanStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | GermanStemFilter(TokenStream) | Initializes a new instance of the GermanStemFilter class
Public method | GermanStemFilter(TokenStream, Hashtable) | Builds a GermanStemFilter that uses an exclusiontable.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetExclusionTable
Set an alternative exclusion list for this filter.
Public method SetStemmer
Set a alternative/custom GermanStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

GermanStemFilter Class
Lucene.Net.Analysis.De Namespace


GermanStemFilter Constructor

[image] [image]

Lucene.Net Class Libraries
GermanStemFilter Constructor
GermanStemFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GermanStemFilter(TokenStream) | Initializes a new instance of the GermanStemFilter class
Public method | GermanStemFilter(TokenStream, Hashtable) | Builds a GermanStemFilter that uses an exclusiontable.

See Also

GermanStemFilter Class
GermanStemFilter Members
Lucene.Net.Analysis.De Namespace


GermanStemFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
GermanStemFilter Constructor (TokenStream)
GermanStemFilter Class See Also Send Feedback
Initializes a new instance of the GermanStemFilter class

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanStemFilter(
    TokenStream _in
)
Visual Basic
Public Sub New ( _
    _in As TokenStream _
)
Visual C++
public:
GermanStemFilter(
    TokenStream^ _in
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.De.GermanStemFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

GermanStemFilter Class
GermanStemFilter Overload
Lucene.Net.Analysis.De Namespace


GermanStemFilter Constructor (TokenStream, Hashtable)

[image]

Lucene.Net Class Libraries
GermanStemFilter Constructor (TokenStream, Hashtable)
GermanStemFilter Class See Also Send Feedback
Builds a GermanStemFilter that uses an exclusiontable.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanStemFilter(
    TokenStream _in,
    Hashtable exclusiontable
)
Visual Basic
Public Sub New ( _
    _in As TokenStream, _
    exclusiontable As Hashtable _
)
Visual C++
public:
GermanStemFilter(
    TokenStream^ _in,
    Hashtable^ exclusiontable
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.De.GermanStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.De.GermanStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

See Also

GermanStemFilter Class
GermanStemFilter Overload
Lucene.Net.Analysis.De Namespace


GermanStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
GermanStemFilter Fields
GermanStemFilter Class See Also Send Feedback

The GermanStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

GermanStemFilter Class
Lucene.Net.Analysis.De Namespace


GermanStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
GermanStemFilter Methods
GermanStemFilter Class See Also Send Feedback

The GermanStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetExclusionTable
Set an alternative exclusion list for this filter.
Public method SetStemmer
Set a alternative/custom GermanStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

See Also

GermanStemFilter Class
Lucene.Net.Analysis.De Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
GermanStemFilter..::..Next Method
GermanStemFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

GermanStemFilter Class
GermanStemFilter Members
Lucene.Net.Analysis.De Namespace


Next Method

[image]

Lucene.Net Class Libraries
GermanStemFilter..::..Next Method
GermanStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.De.GermanStemFilter.Next"]

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

Returns the next token in the stream, or null at EOS

See Also

GermanStemFilter Class
Next Overload
Lucene.Net.Analysis.De Namespace


SetExclusionTable Method

[image]

Lucene.Net Class Libraries
GermanStemFilter..::..SetExclusionTable Method
GermanStemFilter Class See Also Send Feedback
Set an alternative exclusion list for this filter.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetExclusionTable(
    Hashtable exclusiontable
)
Visual Basic
Public Sub SetExclusionTable ( _
    exclusiontable As Hashtable _
)
Visual C++
public:
void SetExclusionTable(
    Hashtable^ exclusiontable
)

Parameters

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.De.GermanStemFilter.SetExclusionTable(System.Collections.Hashtable)"]

See Also

GermanStemFilter Class
Lucene.Net.Analysis.De Namespace


SetStemmer Method

[image]

Lucene.Net Class Libraries
GermanStemFilter..::..SetStemmer Method
GermanStemFilter Class See Also Send Feedback
Set a alternative/custom GermanStemmer for this filter.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemmer(
    GermanStemmer stemmer
)
Visual Basic
Public Sub SetStemmer ( _
    stemmer As GermanStemmer _
)
Visual C++
public:
void SetStemmer(
    GermanStemmer^ stemmer
)

Parameters

stemmer
Type: Lucene.Net.Analysis.De..::..GermanStemmer

[Missing <param name="stemmer"/> documentation for "M:Lucene.Net.Analysis.De.GermanStemFilter.SetStemmer(Lucene.Net.Analysis.De.GermanStemmer)"]

See Also

GermanStemFilter Class
Lucene.Net.Analysis.De Namespace


GermanStemmer Class

[image]

Lucene.Net Class Libraries
GermanStemmer Class
Members See Also Send Feedback
A stemmer for German words. The algorithm is based on the report "A Fast and Simple Stemming Algorithm for German Words" by JГ¶rg Caumanns (joerg.caumanns@isst.fhg.de).

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class GermanStemmer
Visual Basic
Public Class GermanStemmer
Visual C++
public ref class GermanStemmer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.De..::..GermanStemmer

See Also

GermanStemmer Members
Lucene.Net.Analysis.De Namespace


GermanStemmer Members

[image] [image]

Lucene.Net Class Libraries
GermanStemmer Members
GermanStemmer Class Constructors Methods See Also Send Feedback

The GermanStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | GermanStemmer | Initializes a new instance of the GermanStemmer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GermanStemmer Class
Lucene.Net.Analysis.De Namespace


GermanStemmer Constructor

[image]

Lucene.Net Class Libraries
GermanStemmer Constructor
GermanStemmer Class See Also Send Feedback
Initializes a new instance of the GermanStemmer class

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public GermanStemmer()
Visual Basic
Public Sub New
Visual C++
public:
GermanStemmer()

See Also

GermanStemmer Class
Lucene.Net.Analysis.De Namespace


GermanStemmer Methods

[image] [image]

Lucene.Net Class Libraries
GermanStemmer Methods
GermanStemmer Class See Also Send Feedback

The GermanStemmer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GermanStemmer Class
Lucene.Net.Analysis.De Namespace


WordlistLoader Class

[image]

Lucene.Net Class Libraries
WordlistLoader Class
Members See Also Send Feedback
Loads a text file and adds every line as an entry to a Hashtable. Every line should contain only one word. If the file is not found or on any error, an empty table is returned.

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class WordlistLoader
Visual Basic
Public Class WordlistLoader
Visual C++
public ref class WordlistLoader

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.De..::..WordlistLoader

See Also

WordlistLoader Members
Lucene.Net.Analysis.De Namespace


WordlistLoader Members

[image] [image]

Lucene.Net Class Libraries
WordlistLoader Members
WordlistLoader Class Constructors Methods See Also Send Feedback

The WordlistLoader type exposes the following members.

Constructors

 | Name | Description
Public method | WordlistLoader | Initializes a new instance of the WordlistLoader class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWordtable(FileInfo) |
 | GetWordtable(String) |
 | GetWordtable(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WordlistLoader Class
Lucene.Net.Analysis.De Namespace


WordlistLoader Constructor

[image]

Lucene.Net Class Libraries
WordlistLoader Constructor
WordlistLoader Class See Also Send Feedback
Initializes a new instance of the WordlistLoader class

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public WordlistLoader()
Visual Basic
Public Sub New
Visual C++
public:
WordlistLoader()

See Also

WordlistLoader Class
Lucene.Net.Analysis.De Namespace


WordlistLoader Methods

[image] [image]

Lucene.Net Class Libraries
WordlistLoader Methods
WordlistLoader Class See Also Send Feedback

The WordlistLoader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWordtable(FileInfo) |
 | GetWordtable(String) |
 | GetWordtable(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WordlistLoader Class
Lucene.Net.Analysis.De Namespace


GetWordtable Method

[image] [image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method
WordlistLoader Class See Also Send Feedback

Overload List

Name | Description
GetWordtable(FileInfo) |
GetWordtable(String) |
GetWordtable(String, String) |

See Also

WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis.De Namespace


GetWordtable Method (FileInfo)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (FileInfo)
WordlistLoader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.De.WordlistLoader.GetWordtable(System.IO.FileInfo)"]

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    FileInfo wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    wordfile As FileInfo _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    FileInfo^ wordfile
)

Parameters

wordfile
Type: System.IO..::..FileInfo
File containing the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.De.WordlistLoader.GetWordtable(System.IO.FileInfo)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis.De Namespace


GetWordtable Method (String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (String)
WordlistLoader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.De.WordlistLoader.GetWordtable(System.String)"]

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    string wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    wordfile As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    String^ wordfile
)

Parameters

wordfile
Type: System..::..String
Complete path to the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.De.WordlistLoader.GetWordtable(System.String)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis.De Namespace


GetWordtable Method (String, String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (String, String)
WordlistLoader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.De.WordlistLoader.GetWordtable(System.String,System.String)"]

Namespace: Lucene.Net.Analysis.De
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    string path,
    string wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    path As String, _
    wordfile As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    String^ path,
    String^ wordfile
)

Parameters

path
Type: System..::..String
Path to the wordlist
wordfile
Type: System..::..String
Name of the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.De.WordlistLoader.GetWordtable(System.String,System.String)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis.De Namespace


Lucene.Net.Analysis.Ext Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Ext Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Ext"]

Classes

 | Class | Description
Public class | LetterOrDigitTokenizer | if a char is not a letter or digit, it is a word separator
Public class | SingleCharTokenAnalyzer | This analyzer targets short fields where *word* like searches are required. [SomeUser@GMAIL.com 1234567890] will be tokenized as [s.o.m.e.u.s.e.r..g.m.a.i.l..com..1.2.3.4.5.6.7.8.9.0] (read .'s as blank) Usage: QueryParser p = new QueryParser(Lucene.Net.Util.Version.LUCENE_29, "fieldName", new SingleCharTokenAnalyzer()); p.SetDefaultOperator(QueryParser.Operator.AND); p.SetEnablePositionIncrements(true); TopDocs td = src.Search(p.Parse("678"), 10); or TopDocs td = src.Search(p.Parse("\"gmail.com 1234\""), 10);
Public class | UnaccentedWordAnalyzer | Another Analyzer. Every char which is not a letter or digit is treated as a word separator. [Name.Surname@gmail.com 123.456 ğüşıöç%ĞÜŞİÖÇ$ΑΒΓΔΕΖ#АБВГДЕ SSß] will be tokenized as [name surname gmail com 123 456 gusioc gusioc αβγδεζ абвгде ssss] No problem with searches like someuser@gmail or 123.456 since they are converted to phrase-query as "someuser gmail" or "123 456".


LetterOrDigitTokenizer Class

[image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer Class
Members See Also Send Feedback
if a char is not a letter or digit, it is a word separator

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class LetterOrDigitTokenizer : CharTokenizer
Visual Basic
Public Class LetterOrDigitTokenizer _
    Inherits CharTokenizer
Visual C++
public ref class LetterOrDigitTokenizer : public CharTokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis.Ext..::..LetterOrDigitTokenizer

See Also

LetterOrDigitTokenizer Members
Lucene.Net.Analysis.Ext Namespace


LetterOrDigitTokenizer Members

[image] [image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer Members
LetterOrDigitTokenizer Class Constructors Methods Fields See Also Send Feedback

The LetterOrDigitTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | LetterOrDigitTokenizer | Initializes a new instance of the LetterOrDigitTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

LetterOrDigitTokenizer Class
Lucene.Net.Analysis.Ext Namespace


LetterOrDigitTokenizer Constructor

[image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer Constructor
LetterOrDigitTokenizer Class See Also Send Feedback
Initializes a new instance of the LetterOrDigitTokenizer class

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public LetterOrDigitTokenizer(
    TextReader reader
)
Visual Basic
Public Sub New ( _
    reader As TextReader _
)
Visual C++
public:
LetterOrDigitTokenizer(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Ext.LetterOrDigitTokenizer.#ctor(System.IO.TextReader)"]

See Also

LetterOrDigitTokenizer Class
Lucene.Net.Analysis.Ext Namespace


LetterOrDigitTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer Fields
LetterOrDigitTokenizer Class See Also Send Feedback

The LetterOrDigitTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

LetterOrDigitTokenizer Class
Lucene.Net.Analysis.Ext Namespace


LetterOrDigitTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer Methods
LetterOrDigitTokenizer Class See Also Send Feedback

The LetterOrDigitTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

LetterOrDigitTokenizer Class
Lucene.Net.Analysis.Ext Namespace


IsTokenChar Method

[image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer..::..IsTokenChar Method
LetterOrDigitTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Ext.LetterOrDigitTokenizer.IsTokenChar(System.Char)"]

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool IsTokenChar(
    char c
)
Visual Basic
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Visual C++
protected:
virtual bool IsTokenChar(
    wchar_t c
) override

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.Ext.LetterOrDigitTokenizer.IsTokenChar(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ext.LetterOrDigitTokenizer.IsTokenChar(System.Char)"]

See Also

LetterOrDigitTokenizer Class
Lucene.Net.Analysis.Ext Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer..::..Next Method
LetterOrDigitTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)

See Also

LetterOrDigitTokenizer Class
LetterOrDigitTokenizer Members
Lucene.Net.Analysis.Ext Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
LetterOrDigitTokenizer..::..Reset Method
LetterOrDigitTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)

See Also

LetterOrDigitTokenizer Class
LetterOrDigitTokenizer Members
Lucene.Net.Analysis.Ext Namespace


SingleCharTokenAnalyzer Class

[image]

Lucene.Net Class Libraries
SingleCharTokenAnalyzer Class
Members See Also Send Feedback
This analyzer targets short fields where *word* like searches are required. [SomeUser@GMAIL.com 1234567890] will be tokenized as [s.o.m.e.u.s.e.r..g.m.a.i.l..com..1.2.3.4.5.6.7.8.9.0] (read .'s as blank) Usage: QueryParser p = new QueryParser(Lucene.Net.Util.Version.LUCENE_29, "fieldName", new SingleCharTokenAnalyzer()); p.SetDefaultOperator(QueryParser.Operator.AND); p.SetEnablePositionIncrements(true); TopDocs td = src.Search(p.Parse("678"), 10); or TopDocs td = src.Search(p.Parse("\"gmail.com 1234\""), 10);

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class SingleCharTokenAnalyzer : Analyzer
Visual Basic
Public Class SingleCharTokenAnalyzer _
    Inherits Analyzer
Visual C++
public ref class SingleCharTokenAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Ext..::..SingleCharTokenAnalyzer

See Also

SingleCharTokenAnalyzer Members
Lucene.Net.Analysis.Ext Namespace


SingleCharTokenAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
SingleCharTokenAnalyzer Members
SingleCharTokenAnalyzer Class Constructors Methods Fields See Also Send Feedback

The SingleCharTokenAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | SingleCharTokenAnalyzer | Initializes a new instance of the SingleCharTokenAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

SingleCharTokenAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


SingleCharTokenAnalyzer Constructor

[image]

Lucene.Net Class Libraries
SingleCharTokenAnalyzer Constructor
SingleCharTokenAnalyzer Class See Also Send Feedback
Initializes a new instance of the SingleCharTokenAnalyzer class

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public SingleCharTokenAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
SingleCharTokenAnalyzer()

See Also

SingleCharTokenAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


SingleCharTokenAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
SingleCharTokenAnalyzer Fields
SingleCharTokenAnalyzer Class See Also Send Feedback

The SingleCharTokenAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

SingleCharTokenAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


SingleCharTokenAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
SingleCharTokenAnalyzer Methods
SingleCharTokenAnalyzer Class See Also Send Feedback

The SingleCharTokenAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleCharTokenAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
SingleCharTokenAnalyzer..::..TokenStream Method
SingleCharTokenAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Ext.SingleCharTokenAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Ext.SingleCharTokenAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Ext.SingleCharTokenAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ext.SingleCharTokenAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

SingleCharTokenAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


UnaccentedWordAnalyzer Class

[image]

Lucene.Net Class Libraries
UnaccentedWordAnalyzer Class
Members See Also Send Feedback
Another Analyzer. Every char which is not a letter or digit is treated as a word separator. [Name.Surname@gmail.com 123.456 ğüşıöç%ĞÜŞİÖÇ$ΑΒΓΔΕΖ#АБВГДЕ SSß] will be tokenized as [name surname gmail com 123 456 gusioc gusioc αβγδεζ абвгде ssss] No problem with searches like someuser@gmail or 123.456 since they are converted to phrase-query as "someuser gmail" or "123 456".

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class UnaccentedWordAnalyzer : Analyzer
Visual Basic
Public Class UnaccentedWordAnalyzer _
    Inherits Analyzer
Visual C++
public ref class UnaccentedWordAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Ext..::..UnaccentedWordAnalyzer

See Also

UnaccentedWordAnalyzer Members
Lucene.Net.Analysis.Ext Namespace


UnaccentedWordAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
UnaccentedWordAnalyzer Members
UnaccentedWordAnalyzer Class Constructors Methods Fields See Also Send Feedback

The UnaccentedWordAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | UnaccentedWordAnalyzer | Initializes a new instance of the UnaccentedWordAnalyzer class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

UnaccentedWordAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


UnaccentedWordAnalyzer Constructor

[image]

Lucene.Net Class Libraries
UnaccentedWordAnalyzer Constructor
UnaccentedWordAnalyzer Class See Also Send Feedback
Initializes a new instance of the UnaccentedWordAnalyzer class

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public UnaccentedWordAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
UnaccentedWordAnalyzer()

See Also

UnaccentedWordAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


UnaccentedWordAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
UnaccentedWordAnalyzer Fields
UnaccentedWordAnalyzer Class See Also Send Feedback

The UnaccentedWordAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

UnaccentedWordAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


UnaccentedWordAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
UnaccentedWordAnalyzer Methods
UnaccentedWordAnalyzer Class See Also Send Feedback

The UnaccentedWordAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnaccentedWordAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
UnaccentedWordAnalyzer..::..TokenStream Method
UnaccentedWordAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Ext.UnaccentedWordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.Ext
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Ext.UnaccentedWordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Ext.UnaccentedWordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ext.UnaccentedWordAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

UnaccentedWordAnalyzer Class
Lucene.Net.Analysis.Ext Namespace


Lucene.Net.Analysis.Fr Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Fr Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Fr"]

Classes

 | Class | Description
Public class | FrenchAnalyzer | Analyzer for french language. Supports an external list of stopwords (words that will not be indexed at all) and an external list of exclusions (word that will not be stemmed, but indexed). A default set of stopwords is used unless an other list is specified, the exclusionlist is empty by default. Patrick Talbot (based on Gerhard Schwarz work for German)$Id: FrenchAnalyzer.java,v 1.9 2004/10/17 11:41:40 dnaber Exp $
Public class | FrenchStemFilter | A filter that stemms french words. It supports a table of words that should not be stemmed at all. The used stemmer can be changed at runtime after the filter object is created (as long as it is a FrenchStemmer). Patrick Talbot (based on Gerhard Schwarz work for German)$Id: FrenchAnalyzer.java,v 1.2 2004/01/23 20:54:47 ehatcher Exp $
Public class | FrenchStemmer | A stemmer for French words. The algorithm is based on the work of Dr Martin Porter on his snowball project refer to http://snowball.sourceforge.net/french/stemmer.html (French stemming algorithm) for details Patrick Talbot (based on Gerhard Schwarz work for German)$Id: FrenchStemmer.java,v 1.2 2004/01/22 20:54:47 ehatcher Exp $


FrenchAnalyzer Class

[image]

Lucene.Net Class Libraries
FrenchAnalyzer Class
Members See Also Send Feedback
Analyzer for french language. Supports an external list of stopwords (words that will not be indexed at all) and an external list of exclusions (word that will not be stemmed, but indexed). A default set of stopwords is used unless an other list is specified, the exclusionlist is empty by default. Patrick Talbot (based on Gerhard Schwarz work for German)$Id: FrenchAnalyzer.java,v 1.9 2004/10/17 11:41:40 dnaber Exp $

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class FrenchAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class FrenchAnalyzer _
    Inherits Analyzer
Visual C++
public ref class FrenchAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Fr..::..FrenchAnalyzer

See Also

FrenchAnalyzer Members
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
FrenchAnalyzer Members
FrenchAnalyzer Class Constructors Methods Fields See Also Send Feedback

The FrenchAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | FrenchAnalyzer()()()() | Builds an analyzer.
Public method | FrenchAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | FrenchAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | FrenchAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | FRENCH_STOP_WORDS | Extended list of typical french stopwords.
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

FrenchAnalyzer Class
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
FrenchAnalyzer Constructor
FrenchAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FrenchAnalyzer()()()() | Builds an analyzer.
Public method | FrenchAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | FrenchAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | FrenchAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

See Also

FrenchAnalyzer Class
FrenchAnalyzer Members
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Constructor

[image]

Lucene.Net Class Libraries
FrenchAnalyzer Constructor
FrenchAnalyzer Class See Also Send Feedback
Builds an analyzer.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
FrenchAnalyzer()

See Also

FrenchAnalyzer Class
FrenchAnalyzer Overload
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
FrenchAnalyzer Constructor (Hashtable)
FrenchAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchAnalyzer(
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As Hashtable _
)
Visual C++
public:
FrenchAnalyzer(
    Hashtable^ stopwords
)

Parameters

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

FrenchAnalyzer Class
FrenchAnalyzer Overload
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
FrenchAnalyzer Constructor (FileInfo)
FrenchAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchAnalyzer(
    FileInfo stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As FileInfo _
)
Visual C++
public:
FrenchAnalyzer(
    FileInfo^ stopwords
)

Parameters

stopwords
Type: System.IO..::..FileInfo

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

FrenchAnalyzer Class
FrenchAnalyzer Overload
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
FrenchAnalyzer Constructor (array<String>[]()[][])
FrenchAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchAnalyzer(
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As String() _
)
Visual C++
public:
FrenchAnalyzer(
    array<String^>^ stopwords
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.#ctor(System.String[])"]

See Also

FrenchAnalyzer Class
FrenchAnalyzer Overload
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
FrenchAnalyzer Fields
FrenchAnalyzer Class See Also Send Feedback

The FrenchAnalyzer type exposes the following members.

Fields

 | Name | Description
 | FRENCH_STOP_WORDS | Extended list of typical french stopwords.
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

FrenchAnalyzer Class
Lucene.Net.Analysis.Fr Namespace


FRENCH_STOP_WORDS Field

[image]

Lucene.Net Class Libraries
FrenchAnalyzer..::..FRENCH_STOP_WORDS Field
FrenchAnalyzer Class See Also Send Feedback
Extended list of typical french stopwords.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string[] FRENCH_STOP_WORDS
Visual Basic
Public Shared FRENCH_STOP_WORDS As String()
Visual C++
public:
static array<String^>^ FRENCH_STOP_WORDS

See Also

FrenchAnalyzer Class
Lucene.Net.Analysis.Fr Namespace


FrenchAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
FrenchAnalyzer Methods
FrenchAnalyzer Class See Also Send Feedback

The FrenchAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided Reader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FrenchAnalyzer Class
Lucene.Net.Analysis.Fr Namespace


SetStemExclusionTable Method

[image] [image]

Lucene.Net Class Libraries
FrenchAnalyzer..::..SetStemExclusionTable Method
FrenchAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.

See Also

FrenchAnalyzer Class
FrenchAnalyzer Members
Lucene.Net.Analysis.Fr Namespace


SetStemExclusionTable Method (Hashtable)

[image]

Lucene.Net Class Libraries
FrenchAnalyzer..::..SetStemExclusionTable Method (Hashtable)
FrenchAnalyzer Class See Also Send Feedback
Builds an exclusionlist from a Hashtable.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    Hashtable exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As Hashtable _
)
Visual C++
public:
void SetStemExclusionTable(
    Hashtable^ exclusionlist
)

Parameters

exclusionlist
Type: System.Collections..::..Hashtable

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.SetStemExclusionTable(System.Collections.Hashtable)"]

See Also

FrenchAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.Fr Namespace


SetStemExclusionTable Method (FileInfo)

[image]

Lucene.Net Class Libraries
FrenchAnalyzer..::..SetStemExclusionTable Method (FileInfo)
FrenchAnalyzer Class See Also Send Feedback
Builds an exclusionlist from the words contained in the given file.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    FileInfo exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As FileInfo _
)
Visual C++
public:
void SetStemExclusionTable(
    FileInfo^ exclusionlist
)

Parameters

exclusionlist
Type: System.IO..::..FileInfo

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.SetStemExclusionTable(System.IO.FileInfo)"]

See Also

FrenchAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.Fr Namespace


SetStemExclusionTable Method (String[])

[image]

Lucene.Net Class Libraries
FrenchAnalyzer..::..SetStemExclusionTable Method (array<String>[]()[][])
FrenchAnalyzer Class See Also Send Feedback
Builds an exclusionlist from an array of Strings.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    string[] exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As String() _
)
Visual C++
public:
void SetStemExclusionTable(
    array<String^>^ exclusionlist
)

Parameters

exclusionlist
Type: array< System..::..String >[]()[][]

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.SetStemExclusionTable(System.String[])"]

See Also

FrenchAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.Fr Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
FrenchAnalyzer..::..TokenStream Method
FrenchAnalyzer Class See Also Send Feedback
Creates a TokenStream which tokenizes all the text in the provided Reader.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

A TokenStream build from a StandardTokenizer filtered with StandardFilter, StopFilter, FrenchStemFilter and LowerCaseFilter

See Also

FrenchAnalyzer Class
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Class

[image]

Lucene.Net Class Libraries
FrenchStemFilter Class
Members See Also Send Feedback
A filter that stemms french words. It supports a table of words that should not be stemmed at all. The used stemmer can be changed at runtime after the filter object is created (as long as it is a FrenchStemmer). Patrick Talbot (based on Gerhard Schwarz work for German)$Id: FrenchAnalyzer.java,v 1.2 2004/01/23 20:54:47 ehatcher Exp $

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class FrenchStemFilter : TokenFilter
Visual Basic
Public NotInheritable Class FrenchStemFilter _
    Inherits TokenFilter
Visual C++
public ref class FrenchStemFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Fr..::..FrenchStemFilter

See Also

FrenchStemFilter Members
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Members

[image] [image]

Lucene.Net Class Libraries
FrenchStemFilter Members
FrenchStemFilter Class Constructors Methods Fields See Also Send Feedback

The FrenchStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FrenchStemFilter(TokenStream) | Initializes a new instance of the FrenchStemFilter class
Public method | FrenchStemFilter(TokenStream, Hashtable) | Builds a FrenchStemFilter that uses an exclusiontable.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
Returns the next token in the stream, or null at EOS
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetExclusionTable
Set an alternative exclusion list for this filter.
Public method SetStemmer
Set a alternative/custom FrenchStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

FrenchStemFilter Class
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Constructor

[image] [image]

Lucene.Net Class Libraries
FrenchStemFilter Constructor
FrenchStemFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FrenchStemFilter(TokenStream) | Initializes a new instance of the FrenchStemFilter class
Public method | FrenchStemFilter(TokenStream, Hashtable) | Builds a FrenchStemFilter that uses an exclusiontable.

See Also

FrenchStemFilter Class
FrenchStemFilter Members
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
FrenchStemFilter Constructor (TokenStream)
FrenchStemFilter Class See Also Send Feedback
Initializes a new instance of the FrenchStemFilter class

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchStemFilter(
    TokenStream _in
)
Visual Basic
Public Sub New ( _
    _in As TokenStream _
)
Visual C++
public:
FrenchStemFilter(
    TokenStream^ _in
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

FrenchStemFilter Class
FrenchStemFilter Overload
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Constructor (TokenStream, Hashtable)

[image]

Lucene.Net Class Libraries
FrenchStemFilter Constructor (TokenStream, Hashtable)
FrenchStemFilter Class See Also Send Feedback
Builds a FrenchStemFilter that uses an exclusiontable.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchStemFilter(
    TokenStream _in,
    Hashtable exclusiontable
)
Visual Basic
Public Sub New ( _
    _in As TokenStream, _
    exclusiontable As Hashtable _
)
Visual C++
public:
FrenchStemFilter(
    TokenStream^ _in,
    Hashtable^ exclusiontable
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

See Also

FrenchStemFilter Class
FrenchStemFilter Overload
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
FrenchStemFilter Fields
FrenchStemFilter Class See Also Send Feedback

The FrenchStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

FrenchStemFilter Class
Lucene.Net.Analysis.Fr Namespace


FrenchStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
FrenchStemFilter Methods
FrenchStemFilter Class See Also Send Feedback

The FrenchStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
Returns the next token in the stream, or null at EOS
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetExclusionTable
Set an alternative exclusion list for this filter.
Public method SetStemmer
Set a alternative/custom FrenchStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

See Also

FrenchStemFilter Class
Lucene.Net.Analysis.Fr Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
FrenchStemFilter..::..Next Method
FrenchStemFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()()
Returns the next token in the stream, or null at EOS
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

FrenchStemFilter Class
FrenchStemFilter Members
Lucene.Net.Analysis.Fr Namespace


Next Method

[image]

Lucene.Net Class Libraries
FrenchStemFilter..::..Next Method
FrenchStemFilter Class See Also Send Feedback
Returns the next token in the stream, or null at EOS

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

Returns the next token in the stream, or null at EOS

See Also

FrenchStemFilter Class
Next Overload
Lucene.Net.Analysis.Fr Namespace


SetExclusionTable Method

[image]

Lucene.Net Class Libraries
FrenchStemFilter..::..SetExclusionTable Method
FrenchStemFilter Class See Also Send Feedback
Set an alternative exclusion list for this filter.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetExclusionTable(
    Hashtable exclusiontable
)
Visual Basic
Public Sub SetExclusionTable ( _
    exclusiontable As Hashtable _
)
Visual C++
public:
void SetExclusionTable(
    Hashtable^ exclusiontable
)

Parameters

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchStemFilter.SetExclusionTable(System.Collections.Hashtable)"]

See Also

FrenchStemFilter Class
Lucene.Net.Analysis.Fr Namespace


SetStemmer Method

[image]

Lucene.Net Class Libraries
FrenchStemFilter..::..SetStemmer Method
FrenchStemFilter Class See Also Send Feedback
Set a alternative/custom FrenchStemmer for this filter.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemmer(
    FrenchStemmer stemmer
)
Visual Basic
Public Sub SetStemmer ( _
    stemmer As FrenchStemmer _
)
Visual C++
public:
void SetStemmer(
    FrenchStemmer^ stemmer
)

Parameters

stemmer
Type: Lucene.Net.Analysis.Fr..::..FrenchStemmer

[Missing <param name="stemmer"/> documentation for "M:Lucene.Net.Analysis.Fr.FrenchStemFilter.SetStemmer(Lucene.Net.Analysis.Fr.FrenchStemmer)"]

See Also

FrenchStemFilter Class
Lucene.Net.Analysis.Fr Namespace


FrenchStemmer Class

[image]

Lucene.Net Class Libraries
FrenchStemmer Class
Members See Also Send Feedback
A stemmer for French words. The algorithm is based on the work of Dr Martin Porter on his snowball project
refer to http://snowball.sourceforge.net/french/stemmer.html
(French stemming algorithm) for details Patrick Talbot (based on Gerhard Schwarz work for German)$Id: FrenchStemmer.java,v 1.2 2004/01/22 20:54:47 ehatcher Exp $

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class FrenchStemmer
Visual Basic
Public Class FrenchStemmer
Visual C++
public ref class FrenchStemmer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.Fr..::..FrenchStemmer

See Also

FrenchStemmer Members
Lucene.Net.Analysis.Fr Namespace


FrenchStemmer Members

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer Members
FrenchStemmer Class Constructors Methods See Also Send Feedback

The FrenchStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | FrenchStemmer | Initializes a new instance of the FrenchStemmer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Stem | Stemms the given term to a unique discriminator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FrenchStemmer Class
Lucene.Net.Analysis.Fr Namespace


FrenchStemmer Constructor

[image]

Lucene.Net Class Libraries
FrenchStemmer Constructor
FrenchStemmer Class See Also Send Feedback
Initializes a new instance of the FrenchStemmer class

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public FrenchStemmer()
Visual Basic
Public Sub New
Visual C++
public:
FrenchStemmer()

See Also

FrenchStemmer Class
Lucene.Net.Analysis.Fr Namespace


FrenchStemmer Methods

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer Methods
FrenchStemmer Class See Also Send Feedback

The FrenchStemmer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Stem | Stemms the given term to a unique discriminator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FrenchStemmer Class
Lucene.Net.Analysis.Fr Namespace


Stem Method

[image]

Lucene.Net Class Libraries
FrenchStemmer..::..Stem Method
FrenchStemmer Class See Also Send Feedback
Stemms the given term to a unique discriminator.

Namespace: Lucene.Net.Analysis.Fr
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected internal string Stem(
    string term
)
Visual Basic
Protected Friend Function Stem ( _
    term As String _
) As String
Visual C++
protected public:
String^ Stem(
    String^ term
)

Parameters

term
Type: System..::..String
java.langString The term that should be stemmed

Return Value

Discriminator for term

See Also

FrenchStemmer Class
Lucene.Net.Analysis.Fr Namespace


Lucene.Net.Analysis.NGram Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.NGram Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.NGram"]

Classes

 | Class | Description
Public class | EdgeNGramTokenFilter |
Public class | EdgeNGramTokenFilter..::..Side |
Public class | EdgeNGramTokenizer |
Public class | EdgeNGramTokenizer..::..Side |
Public class | NGramTokenFilter |
Public class | NGramTokenizer |


EdgeNGramTokenFilter Class

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class EdgeNGramTokenFilter : TokenFilter
Visual Basic
Public Class EdgeNGramTokenFilter _
    Inherits TokenFilter
Visual C++
public ref class EdgeNGramTokenFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.NGram..::..EdgeNGramTokenFilter

See Also

EdgeNGramTokenFilter Members
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Members
EdgeNGramTokenFilter Class Constructors Methods Fields See Also Send Feedback

The EdgeNGramTokenFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | EdgeNGramTokenFilter(TokenStream) | Initializes a new instance of the EdgeNGramTokenFilter class
Public method | EdgeNGramTokenFilter(TokenStream, EdgeNGramTokenFilter..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenFilter class
Public method | EdgeNGramTokenFilter(TokenStream, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
 | DEFAULT_MAX_GRAM_SIZE |
 | DEFAULT_MIN_GRAM_SIZE |
 | DEFAULT_SIDE |
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Constructor

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Constructor
EdgeNGramTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | EdgeNGramTokenFilter(TokenStream) | Initializes a new instance of the EdgeNGramTokenFilter class
Public method | EdgeNGramTokenFilter(TokenStream, EdgeNGramTokenFilter..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenFilter class
Public method | EdgeNGramTokenFilter(TokenStream, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenFilter class

See Also

EdgeNGramTokenFilter Class
EdgeNGramTokenFilter Members
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Constructor (TokenStream)
EdgeNGramTokenFilter Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenFilter class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected EdgeNGramTokenFilter(
    TokenStream input
)
Visual Basic
Protected Sub New ( _
    input As TokenStream _
)
Visual C++
protected:
EdgeNGramTokenFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

EdgeNGramTokenFilter Class
EdgeNGramTokenFilter Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Constructor (TokenStream, EdgeNGramTokenFilter.Side, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Constructor (TokenStream, EdgeNGramTokenFilter..::..Side, Int32, Int32)
EdgeNGramTokenFilter Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenFilter class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenFilter(
    TokenStream input,
    EdgeNGramTokenFilter..::..Side side,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    side As EdgeNGramTokenFilter..::..Side, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenFilter(
    TokenStream^ input,
    EdgeNGramTokenFilter..::..Side^ side,
    int minGram,
    int maxGram
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side,System.Int32,System.Int32)"]

side
Type: Lucene.Net.Analysis.NGram..::..EdgeNGramTokenFilter..::..Side

[Missing <param name="side"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenFilter Class
EdgeNGramTokenFilter Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Constructor (TokenStream, String, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Constructor (TokenStream, String, Int32, Int32)
EdgeNGramTokenFilter Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenFilter class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenFilter(
    TokenStream input,
    string sideLabel,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    sideLabel As String, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenFilter(
    TokenStream^ input,
    String^ sideLabel,
    int minGram,
    int maxGram
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String,System.Int32,System.Int32)"]

sideLabel
Type: System..::..String

[Missing <param name="sideLabel"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenFilter Class
EdgeNGramTokenFilter Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Fields

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Fields
EdgeNGramTokenFilter Class See Also Send Feedback

The EdgeNGramTokenFilter type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_MAX_GRAM_SIZE |
 | DEFAULT_MIN_GRAM_SIZE |
 | DEFAULT_SIDE |
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MAX_GRAM_SIZE Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..DEFAULT_MAX_GRAM_SIZE Field
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.DEFAULT_MAX_GRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MAX_GRAM_SIZE
Visual Basic
Public Shared DEFAULT_MAX_GRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MAX_GRAM_SIZE

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MIN_GRAM_SIZE Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..DEFAULT_MIN_GRAM_SIZE Field
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.DEFAULT_MIN_GRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MIN_GRAM_SIZE
Visual Basic
Public Shared DEFAULT_MIN_GRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MIN_GRAM_SIZE

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_SIDE Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..DEFAULT_SIDE Field
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.DEFAULT_SIDE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenFilter..::..Side DEFAULT_SIDE
Visual Basic
Public Shared DEFAULT_SIDE As EdgeNGramTokenFilter..::..Side
Visual C++
public:
static EdgeNGramTokenFilter..::..Side^ DEFAULT_SIDE

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter Methods
EdgeNGramTokenFilter Class See Also Send Feedback

The EdgeNGramTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..IncrementToken Method
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.IncrementToken"]

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Next Method
EdgeNGramTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

EdgeNGramTokenFilter Class
EdgeNGramTokenFilter Members
Lucene.Net.Analysis.NGram Namespace


Next Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Next Method
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Next"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Next"]

See Also

EdgeNGramTokenFilter Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Next Method (Token)
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

EdgeNGramTokenFilter Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Reset Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Reset Method
EdgeNGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Reset"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

EdgeNGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter.Side Class

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side Class
EdgeNGramTokenFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class Side
Visual Basic
Public Class Side
Visual C++
public ref class Side

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.NGram..::..EdgeNGramTokenFilter..::..Side

See Also

EdgeNGramTokenFilter..::..Side Members
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter.Side Members

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side Members
EdgeNGramTokenFilter..::..Side Class Methods Fields See Also Send Feedback

The EdgeNGramTokenFilter..::..Side type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getLabel |
 | getSide |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BACK |
FRONT |

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter.Side Fields

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side Fields
EdgeNGramTokenFilter..::..Side Class See Also Send Feedback

The EdgeNGramTokenFilter..::..Side type exposes the following members.

Fields

Name | Description
BACK |
FRONT |

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


BACK Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side..::..BACK Field
EdgeNGramTokenFilter..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.BACK"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenFilter..::..Side BACK
Visual Basic
Public Shared BACK As EdgeNGramTokenFilter..::..Side
Visual C++
public:
static EdgeNGramTokenFilter..::..Side^ BACK

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


FRONT Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side..::..FRONT Field
EdgeNGramTokenFilter..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.FRONT"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenFilter..::..Side FRONT
Visual Basic
Public Shared FRONT As EdgeNGramTokenFilter..::..Side
Visual C++
public:
static EdgeNGramTokenFilter..::..Side^ FRONT

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenFilter.Side Methods

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side Methods
EdgeNGramTokenFilter..::..Side Class See Also Send Feedback

The EdgeNGramTokenFilter..::..Side type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getLabel |
 | getSide |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


getLabel Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side..::..getLabel Method
EdgeNGramTokenFilter..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.getLabel"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public string getLabel()
Visual Basic
Public Function getLabel As String
Visual C++
public:
String^ getLabel()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.getLabel"]

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


getSide Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenFilter..::..Side..::..getSide Method
EdgeNGramTokenFilter..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.getSide(System.String)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenFilter..::..Side getSide(
    string sideName
)
Visual Basic
Public Shared Function getSide ( _
    sideName As String _
) As EdgeNGramTokenFilter..::..Side
Visual C++
public:
static EdgeNGramTokenFilter..::..Side^ getSide(
    String^ sideName
)

Parameters

sideName
Type: System..::..String

[Missing <param name="sideName"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.getSide(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenFilter.Side.getSide(System.String)"]

See Also

EdgeNGramTokenFilter..::..Side Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Class

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class EdgeNGramTokenizer : Tokenizer
Visual Basic
Public Class EdgeNGramTokenizer _
    Inherits Tokenizer
Visual C++
public ref class EdgeNGramTokenizer : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis.NGram..::..EdgeNGramTokenizer

See Also

EdgeNGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Members

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Members
EdgeNGramTokenizer Class Constructors Methods Fields See Also Send Feedback

The EdgeNGramTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeNGramTokenizer(TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(TextReader, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource, TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource, TextReader, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource..::..AttributeFactory, TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource..::..AttributeFactory, TextReader, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset()()()() | (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
 | DEFAULT_MAX_GRAM_SIZE |
 | DEFAULT_MIN_GRAM_SIZE |
 | DEFAULT_SIDE |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor
EdgeNGramTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EdgeNGramTokenizer(TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(TextReader, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource, TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource, TextReader, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource..::..AttributeFactory, TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class
Public method | EdgeNGramTokenizer(AttributeSource..::..AttributeFactory, TextReader, String, Int32, Int32) | Initializes a new instance of the EdgeNGramTokenizer class

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor (TextReader, EdgeNGramTokenizer.Side, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor (TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32)
EdgeNGramTokenizer Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenizer(
    TextReader input,
    EdgeNGramTokenizer..::..Side side,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    input As TextReader, _
    side As EdgeNGramTokenizer..::..Side, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenizer(
    TextReader^ input,
    EdgeNGramTokenizer..::..Side^ side,
    int minGram,
    int maxGram
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

side
Type: Lucene.Net.Analysis.NGram..::..EdgeNGramTokenizer..::..Side

[Missing <param name="side"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor (TextReader, String, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor (TextReader, String, Int32, Int32)
EdgeNGramTokenizer Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenizer(
    TextReader input,
    string sideLabel,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    input As TextReader, _
    sideLabel As String, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenizer(
    TextReader^ input,
    String^ sideLabel,
    int minGram,
    int maxGram
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,System.String,System.Int32,System.Int32)"]

sideLabel
Type: System..::..String

[Missing <param name="sideLabel"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,System.String,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,System.String,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(System.IO.TextReader,System.String,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor (AttributeSource, TextReader, EdgeNGramTokenizer.Side, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor (AttributeSource, TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32)
EdgeNGramTokenizer Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenizer(
    AttributeSource source,
    TextReader input,
    EdgeNGramTokenizer..::..Side side,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    side As EdgeNGramTokenizer..::..Side, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    EdgeNGramTokenizer..::..Side^ side,
    int minGram,
    int maxGram
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

side
Type: Lucene.Net.Analysis.NGram..::..EdgeNGramTokenizer..::..Side

[Missing <param name="side"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor (AttributeSource, TextReader, String, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor (AttributeSource, TextReader, String, Int32, Int32)
EdgeNGramTokenizer Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenizer(
    AttributeSource source,
    TextReader input,
    string sideLabel,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    sideLabel As String, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    String^ sideLabel,
    int minGram,
    int maxGram
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

sideLabel
Type: System..::..String

[Missing <param name="sideLabel"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor (AttributeSource.AttributeFactory, TextReader, EdgeNGramTokenizer.Side, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader, EdgeNGramTokenizer..::..Side, Int32, Int32)
EdgeNGramTokenizer Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    EdgeNGramTokenizer..::..Side side,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    side As EdgeNGramTokenizer..::..Side, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    EdgeNGramTokenizer..::..Side^ side,
    int minGram,
    int maxGram
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

side
Type: Lucene.Net.Analysis.NGram..::..EdgeNGramTokenizer..::..Side

[Missing <param name="side"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Constructor (AttributeSource.AttributeFactory, TextReader, String, Int32, Int32)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader, String, Int32, Int32)
EdgeNGramTokenizer Class See Also Send Feedback
Initializes a new instance of the EdgeNGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EdgeNGramTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    string sideLabel,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    sideLabel As String, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
EdgeNGramTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    String^ sideLabel,
    int minGram,
    int maxGram
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

sideLabel
Type: System..::..String

[Missing <param name="sideLabel"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.String,System.Int32,System.Int32)"]

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Fields
EdgeNGramTokenizer Class See Also Send Feedback

The EdgeNGramTokenizer type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_MAX_GRAM_SIZE |
 | DEFAULT_MIN_GRAM_SIZE |
 | DEFAULT_SIDE |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MAX_GRAM_SIZE Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..DEFAULT_MAX_GRAM_SIZE Field
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.DEFAULT_MAX_GRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MAX_GRAM_SIZE
Visual Basic
Public Shared DEFAULT_MAX_GRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MAX_GRAM_SIZE

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MIN_GRAM_SIZE Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..DEFAULT_MIN_GRAM_SIZE Field
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.DEFAULT_MIN_GRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MIN_GRAM_SIZE
Visual Basic
Public Shared DEFAULT_MIN_GRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MIN_GRAM_SIZE

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_SIDE Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..DEFAULT_SIDE Field
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.DEFAULT_SIDE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenizer..::..Side DEFAULT_SIDE
Visual Basic
Public Shared DEFAULT_SIDE As EdgeNGramTokenizer..::..Side
Visual C++
public:
static EdgeNGramTokenizer..::..Side^ DEFAULT_SIDE

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer Methods
EdgeNGramTokenizer Class See Also Send Feedback

The EdgeNGramTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset()()()() | (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


End Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..End Method
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.End"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..IncrementToken Method
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.IncrementToken"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.IncrementToken"]

See Also

EdgeNGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Next Method
EdgeNGramTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


Next Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Next Method
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Next"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Next"]

See Also

EdgeNGramTokenizer Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Next Method (Token)
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Next(Lucene.Net.Analysis.Token)"]

See Also

EdgeNGramTokenizer Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Reset Method
EdgeNGramTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reset()()()() | (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)

See Also

EdgeNGramTokenizer Class
EdgeNGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


Reset Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Reset Method
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Reset"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

EdgeNGramTokenizer Class
Reset Overload
Lucene.Net.Analysis.NGram Namespace


Reset Method (TextReader)

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Reset Method (TextReader)
EdgeNGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Reset(System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset(
    TextReader input
)
Visual Basic
Public Overrides Sub Reset ( _
    input As TextReader _
)
Visual C++
public:
virtual void Reset(
    TextReader^ input
) override

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Reset(System.IO.TextReader)"]

See Also

EdgeNGramTokenizer Class
Reset Overload
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer.Side Class

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side Class
EdgeNGramTokenizer Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class Side
Visual Basic
Public Class Side
Visual C++
public ref class Side

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.NGram..::..EdgeNGramTokenizer..::..Side

See Also

EdgeNGramTokenizer..::..Side Members
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer.Side Members

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side Members
EdgeNGramTokenizer..::..Side Class Methods Fields See Also Send Feedback

The EdgeNGramTokenizer..::..Side type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getLabel |
 | getSide |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BACK |
FRONT |

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer.Side Fields

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side Fields
EdgeNGramTokenizer..::..Side Class See Also Send Feedback

The EdgeNGramTokenizer..::..Side type exposes the following members.

Fields

Name | Description
BACK |
FRONT |

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


BACK Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side..::..BACK Field
EdgeNGramTokenizer..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.BACK"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenizer..::..Side BACK
Visual Basic
Public Shared BACK As EdgeNGramTokenizer..::..Side
Visual C++
public:
static EdgeNGramTokenizer..::..Side^ BACK

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


FRONT Field

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side..::..FRONT Field
EdgeNGramTokenizer..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.FRONT"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenizer..::..Side FRONT
Visual Basic
Public Shared FRONT As EdgeNGramTokenizer..::..Side
Visual C++
public:
static EdgeNGramTokenizer..::..Side^ FRONT

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


EdgeNGramTokenizer.Side Methods

[image] [image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side Methods
EdgeNGramTokenizer..::..Side Class See Also Send Feedback

The EdgeNGramTokenizer..::..Side type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getLabel |
 | getSide |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


getLabel Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side..::..getLabel Method
EdgeNGramTokenizer..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.getLabel"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public string getLabel()
Visual Basic
Public Function getLabel As String
Visual C++
public:
String^ getLabel()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.getLabel"]

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


getSide Method

[image]

Lucene.Net Class Libraries
EdgeNGramTokenizer..::..Side..::..getSide Method
EdgeNGramTokenizer..::..Side Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.getSide(System.String)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static EdgeNGramTokenizer..::..Side getSide(
    string sideName
)
Visual Basic
Public Shared Function getSide ( _
    sideName As String _
) As EdgeNGramTokenizer..::..Side
Visual C++
public:
static EdgeNGramTokenizer..::..Side^ getSide(
    String^ sideName
)

Parameters

sideName
Type: System..::..String

[Missing <param name="sideName"/> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.getSide(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.EdgeNGramTokenizer.Side.getSide(System.String)"]

See Also

EdgeNGramTokenizer..::..Side Class
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Class

[image]

Lucene.Net Class Libraries
NGramTokenFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.NGram.NGramTokenFilter"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class NGramTokenFilter : TokenFilter
Visual Basic
Public Class NGramTokenFilter _
    Inherits TokenFilter
Visual C++
public ref class NGramTokenFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.NGram..::..NGramTokenFilter

See Also

NGramTokenFilter Members
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
NGramTokenFilter Members
NGramTokenFilter Class Constructors Methods Fields See Also Send Feedback

The NGramTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | NGramTokenFilter(TokenStream) | Initializes a new instance of the NGramTokenFilter class
Public method | NGramTokenFilter(TokenStream, Int32, Int32) | Initializes a new instance of the NGramTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
 | DEFAULT_MAX_NGRAM_SIZE |
 | DEFAULT_MIN_NGRAM_SIZE |
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Constructor

[image] [image]

Lucene.Net Class Libraries
NGramTokenFilter Constructor
NGramTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NGramTokenFilter(TokenStream) | Initializes a new instance of the NGramTokenFilter class
Public method | NGramTokenFilter(TokenStream, Int32, Int32) | Initializes a new instance of the NGramTokenFilter class

See Also

NGramTokenFilter Class
NGramTokenFilter Members
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
NGramTokenFilter Constructor (TokenStream)
NGramTokenFilter Class See Also Send Feedback
Initializes a new instance of the NGramTokenFilter class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public NGramTokenFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
NGramTokenFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

NGramTokenFilter Class
NGramTokenFilter Overload
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Constructor (TokenStream, Int32, Int32)

[image]

Lucene.Net Class Libraries
NGramTokenFilter Constructor (TokenStream, Int32, Int32)
NGramTokenFilter Class See Also Send Feedback
Initializes a new instance of the NGramTokenFilter class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public NGramTokenFilter(
    TokenStream input,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
NGramTokenFilter(
    TokenStream^ input,
    int minGram,
    int maxGram
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Int32,System.Int32)"]

See Also

NGramTokenFilter Class
NGramTokenFilter Overload
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Fields

[image] [image]

Lucene.Net Class Libraries
NGramTokenFilter Fields
NGramTokenFilter Class See Also Send Feedback

The NGramTokenFilter type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_MAX_NGRAM_SIZE |
 | DEFAULT_MIN_NGRAM_SIZE |
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MAX_NGRAM_SIZE Field

[image]

Lucene.Net Class Libraries
NGramTokenFilter..::..DEFAULT_MAX_NGRAM_SIZE Field
NGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.NGramTokenFilter.DEFAULT_MAX_NGRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MAX_NGRAM_SIZE
Visual Basic
Public Shared DEFAULT_MAX_NGRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MAX_NGRAM_SIZE

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MIN_NGRAM_SIZE Field

[image]

Lucene.Net Class Libraries
NGramTokenFilter..::..DEFAULT_MIN_NGRAM_SIZE Field
NGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.NGramTokenFilter.DEFAULT_MIN_NGRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MIN_NGRAM_SIZE
Visual Basic
Public Shared DEFAULT_MIN_NGRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MIN_NGRAM_SIZE

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


NGramTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
NGramTokenFilter Methods
NGramTokenFilter Class See Also Send Feedback

The NGramTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
NGramTokenFilter..::..IncrementToken Method
NGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.IncrementToken"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.IncrementToken"]

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
NGramTokenFilter..::..Next Method
NGramTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

NGramTokenFilter Class
NGramTokenFilter Members
Lucene.Net.Analysis.NGram Namespace


Next Method

[image]

Lucene.Net Class Libraries
NGramTokenFilter..::..Next Method
NGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.Next"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.Next"]

See Also

NGramTokenFilter Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
NGramTokenFilter..::..Next Method (Token)
NGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

NGramTokenFilter Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Reset Method

[image]

Lucene.Net Class Libraries
NGramTokenFilter..::..Reset Method
NGramTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenFilter.Reset"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

NGramTokenFilter Class
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Class

[image]

Lucene.Net Class Libraries
NGramTokenizer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analysis.NGram.NGramTokenizer"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class NGramTokenizer : Tokenizer
Visual Basic
Public Class NGramTokenizer _
    Inherits Tokenizer
Visual C++
public ref class NGramTokenizer : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis.NGram..::..NGramTokenizer

See Also

NGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Members

[image] [image]

Lucene.Net Class Libraries
NGramTokenizer Members
NGramTokenizer Class Constructors Methods Fields See Also Send Feedback

The NGramTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | NGramTokenizer(TextReader) | Initializes a new instance of the NGramTokenizer class
Public method | NGramTokenizer(TextReader, Int32, Int32) | Initializes a new instance of the NGramTokenizer class
Public method | NGramTokenizer(AttributeSource, TextReader, Int32, Int32) | Initializes a new instance of the NGramTokenizer class
Public method | NGramTokenizer(AttributeSource..::..AttributeFactory, TextReader, Int32, Int32) | Initializes a new instance of the NGramTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset()()()() | (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
 | DEFAULT_MAX_NGRAM_SIZE |
 | DEFAULT_MIN_NGRAM_SIZE |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
NGramTokenizer Constructor
NGramTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NGramTokenizer(TextReader) | Initializes a new instance of the NGramTokenizer class
Public method | NGramTokenizer(TextReader, Int32, Int32) | Initializes a new instance of the NGramTokenizer class
Public method | NGramTokenizer(AttributeSource, TextReader, Int32, Int32) | Initializes a new instance of the NGramTokenizer class
Public method | NGramTokenizer(AttributeSource..::..AttributeFactory, TextReader, Int32, Int32) | Initializes a new instance of the NGramTokenizer class

See Also

NGramTokenizer Class
NGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
NGramTokenizer Constructor (TextReader)
NGramTokenizer Class See Also Send Feedback
Initializes a new instance of the NGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public NGramTokenizer(
    TextReader input
)
Visual Basic
Public Sub New ( _
    input As TextReader _
)
Visual C++
public:
NGramTokenizer(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(System.IO.TextReader)"]

See Also

NGramTokenizer Class
NGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Constructor (TextReader, Int32, Int32)

[image]

Lucene.Net Class Libraries
NGramTokenizer Constructor (TextReader, Int32, Int32)
NGramTokenizer Class See Also Send Feedback
Initializes a new instance of the NGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public NGramTokenizer(
    TextReader input,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    input As TextReader, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
NGramTokenizer(
    TextReader^ input,
    int minGram,
    int maxGram
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(System.IO.TextReader,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(System.IO.TextReader,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(System.IO.TextReader,System.Int32,System.Int32)"]

See Also

NGramTokenizer Class
NGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Constructor (AttributeSource, TextReader, Int32, Int32)

[image]

Lucene.Net Class Libraries
NGramTokenizer Constructor (AttributeSource, TextReader, Int32, Int32)
NGramTokenizer Class See Also Send Feedback
Initializes a new instance of the NGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public NGramTokenizer(
    AttributeSource source,
    TextReader input,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
NGramTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    int minGram,
    int maxGram
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Int32,System.Int32)"]

See Also

NGramTokenizer Class
NGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Constructor (AttributeSource.AttributeFactory, TextReader, Int32, Int32)

[image]

Lucene.Net Class Libraries
NGramTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader, Int32, Int32)
NGramTokenizer Class See Also Send Feedback
Initializes a new instance of the NGramTokenizer class

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public NGramTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    int minGram,
    int maxGram
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    minGram As Integer, _
    maxGram As Integer _
)
Visual C++
public:
NGramTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    int minGram,
    int maxGram
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32,System.Int32)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32,System.Int32)"]

minGram
Type: System..::..Int32

[Missing <param name="minGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32,System.Int32)"]

maxGram
Type: System..::..Int32

[Missing <param name="maxGram"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Int32,System.Int32)"]

See Also

NGramTokenizer Class
NGramTokenizer Overload
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
NGramTokenizer Fields
NGramTokenizer Class See Also Send Feedback

The NGramTokenizer type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_MAX_NGRAM_SIZE |
 | DEFAULT_MIN_NGRAM_SIZE |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MAX_NGRAM_SIZE Field

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..DEFAULT_MAX_NGRAM_SIZE Field
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.NGramTokenizer.DEFAULT_MAX_NGRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MAX_NGRAM_SIZE
Visual Basic
Public Shared DEFAULT_MAX_NGRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MAX_NGRAM_SIZE

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


DEFAULT_MIN_NGRAM_SIZE Field

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..DEFAULT_MIN_NGRAM_SIZE Field
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.NGram.NGramTokenizer.DEFAULT_MIN_NGRAM_SIZE"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DEFAULT_MIN_NGRAM_SIZE
Visual Basic
Public Shared DEFAULT_MIN_NGRAM_SIZE As Integer
Visual C++
public:
static int DEFAULT_MIN_NGRAM_SIZE

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


NGramTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
NGramTokenizer Methods
NGramTokenizer Class See Also Send Feedback

The NGramTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method | Reset()()()() | (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


End Method

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..End Method
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.End"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..IncrementToken Method
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.IncrementToken"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.IncrementToken"]

See Also

NGramTokenizer Class
Lucene.Net.Analysis.NGram Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
NGramTokenizer..::..Next Method
NGramTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

NGramTokenizer Class
NGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


Next Method

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..Next Method
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Next"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Next"]

See Also

NGramTokenizer Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..Next Method (Token)
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Next(Lucene.Net.Analysis.Token)"]

See Also

NGramTokenizer Class
Next Overload
Lucene.Net.Analysis.NGram Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
NGramTokenizer..::..Reset Method
NGramTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reset()()()() | (Overrides TokenStream..::..Reset()()()().)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)

See Also

NGramTokenizer Class
NGramTokenizer Members
Lucene.Net.Analysis.NGram Namespace


Reset Method

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..Reset Method
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Reset"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

NGramTokenizer Class
Reset Overload
Lucene.Net.Analysis.NGram Namespace


Reset Method (TextReader)

[image]

Lucene.Net Class Libraries
NGramTokenizer..::..Reset Method (TextReader)
NGramTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Reset(System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.NGram
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset(
    TextReader input
)
Visual Basic
Public Overrides Sub Reset ( _
    input As TextReader _
)
Visual C++
public:
virtual void Reset(
    TextReader^ input
) override

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.NGram.NGramTokenizer.Reset(System.IO.TextReader)"]

See Also

NGramTokenizer Class
Reset Overload
Lucene.Net.Analysis.NGram Namespace


Lucene.Net.Analysis.Nl Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Nl Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Nl"]

Classes

 | Class | Description
Public class | DutchAnalyzer | Analyzer for Dutch language. Supports an external list of stopwords (words that will not be indexed at all), an external list of exclusions (word that will not be stemmed, but indexed) and an external list of word-stem pairs that overrule the algorithm (dictionary stemming). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default. As start for the Analyzer the German Analyzer was used. The stemming algorithm implemented can be found at $Id: DutchAnalyzer.java,v 1.1 2004/03/09 14:55:08 otis Exp $
Public class | DutchStemFilter | A filter that stems Dutch words. It supports a table of words that should not be stemmed at all. The stemmer used can be changed at runtime after the filter object is created (as long as it is a DutchStemmer). $Id: DutchStemFilter.java,v 1.1 2004/03/09 14:55:08 otis Exp $
Public class | DutchStemmer | A stemmer for Dutch words. The algorithm is an implementation of the dutch stemming algorithm in snowball. Snowball is a project of Martin Porter (does Porter Stemmer ring a bell?): @version $Id: DutchStemmer.java,v 1.1 2004/03/09 14:55:08 otis Exp $
Public class | WordlistLoader | Loads a text file and adds every line as an entry to a Hashtable. Every line should contain only one word. If the file is not found or on any error, an empty table is returned. $Id: WordListLoader.java,v 1.1 2004/03/09 14:55:08 otis Exp $


DutchAnalyzer Class

[image]

Lucene.Net Class Libraries
DutchAnalyzer Class
Members See Also Send Feedback
Analyzer for Dutch language. Supports an external list of stopwords (words that will not be indexed at all), an external list of exclusions (word that will not be stemmed, but indexed) and an external list of word-stem pairs that overrule the algorithm (dictionary stemming). A default set of stopwords is used unless an alternative list is specified, the exclusion list is empty by default. As start for the Analyzer the German Analyzer was used. The stemming algorithm implemented can be found at $Id: DutchAnalyzer.java,v 1.1 2004/03/09 14:55:08 otis Exp $

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class DutchAnalyzer : Analyzer
Visual Basic
Public Class DutchAnalyzer _
    Inherits Analyzer
Visual C++
public ref class DutchAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Nl..::..DutchAnalyzer

See Also

DutchAnalyzer Members
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
DutchAnalyzer Members
DutchAnalyzer Class Constructors Methods Fields See Also Send Feedback

The DutchAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | DutchAnalyzer()()()() | Builds an analyzer.
Public method | DutchAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | DutchAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | DutchAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemDictionary | Reads a stemdictionary file , that overrules the stemming algorithm This is a textfile that contains per line word\tstem i.e: tabseperated
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided TextReader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | DUTCH_STOP_WORDS | List of typical german stopwords.
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

DutchAnalyzer Class
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
DutchAnalyzer Constructor
DutchAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DutchAnalyzer()()()() | Builds an analyzer.
Public method | DutchAnalyzer(Hashtable) | Builds an analyzer with the given stop words.
Public method | DutchAnalyzer(FileInfo) | Builds an analyzer with the given stop words.
Public method | DutchAnalyzer(array<String>[]()[][]) | Builds an analyzer with the given stop words.

See Also

DutchAnalyzer Class
DutchAnalyzer Members
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Constructor

[image]

Lucene.Net Class Libraries
DutchAnalyzer Constructor
DutchAnalyzer Class See Also Send Feedback
Builds an analyzer.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
DutchAnalyzer()

See Also

DutchAnalyzer Class
DutchAnalyzer Overload
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
DutchAnalyzer Constructor (Hashtable)
DutchAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchAnalyzer(
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As Hashtable _
)
Visual C++
public:
DutchAnalyzer(
    Hashtable^ stopwords
)

Parameters

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

DutchAnalyzer Class
DutchAnalyzer Overload
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
DutchAnalyzer Constructor (FileInfo)
DutchAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchAnalyzer(
    FileInfo stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As FileInfo _
)
Visual C++
public:
DutchAnalyzer(
    FileInfo^ stopwords
)

Parameters

stopwords
Type: System.IO..::..FileInfo

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

DutchAnalyzer Class
DutchAnalyzer Overload
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
DutchAnalyzer Constructor (array<String>[]()[][])
DutchAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchAnalyzer(
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    stopwords As String() _
)
Visual C++
public:
DutchAnalyzer(
    array<String^>^ stopwords
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.#ctor(System.String[])"]

See Also

DutchAnalyzer Class
DutchAnalyzer Overload
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
DutchAnalyzer Fields
DutchAnalyzer Class See Also Send Feedback

The DutchAnalyzer type exposes the following members.

Fields

 | Name | Description
 | DUTCH_STOP_WORDS | List of typical german stopwords.
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

DutchAnalyzer Class
Lucene.Net.Analysis.Nl Namespace


DUTCH_STOP_WORDS Field

[image]

Lucene.Net Class Libraries
DutchAnalyzer..::..DUTCH_STOP_WORDS Field
DutchAnalyzer Class See Also Send Feedback
List of typical german stopwords.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string[] DUTCH_STOP_WORDS
Visual Basic
Public Shared DUTCH_STOP_WORDS As String()
Visual C++
public:
static array<String^>^ DUTCH_STOP_WORDS

See Also

DutchAnalyzer Class
Lucene.Net.Analysis.Nl Namespace


DutchAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
DutchAnalyzer Methods
DutchAnalyzer Class See Also Send Feedback

The DutchAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetStemDictionary | Reads a stemdictionary file , that overrules the stemming algorithm This is a textfile that contains per line word\tstem i.e: tabseperated
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided TextReader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DutchAnalyzer Class
Lucene.Net.Analysis.Nl Namespace


SetStemDictionary Method

[image]

Lucene.Net Class Libraries
DutchAnalyzer..::..SetStemDictionary Method
DutchAnalyzer Class See Also Send Feedback
Reads a stemdictionary file , that overrules the stemming algorithm This is a textfile that contains per line word\tstem i.e: tabseperated

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemDictionary(
    FileInfo stemdict
)
Visual Basic
Public Sub SetStemDictionary ( _
    stemdict As FileInfo _
)
Visual C++
public:
void SetStemDictionary(
    FileInfo^ stemdict
)

Parameters

stemdict
Type: System.IO..::..FileInfo

[Missing <param name="stemdict"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.SetStemDictionary(System.IO.FileInfo)"]

See Also

DutchAnalyzer Class
Lucene.Net.Analysis.Nl Namespace


SetStemExclusionTable Method

[image] [image]

Lucene.Net Class Libraries
DutchAnalyzer..::..SetStemExclusionTable Method
DutchAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetStemExclusionTable(Hashtable) | Builds an exclusionlist from a Hashtable.
Public method | SetStemExclusionTable(FileInfo) | Builds an exclusionlist from the words contained in the given file.
Public method | SetStemExclusionTable(array<String>[]()[][]) | Builds an exclusionlist from an array of Strings.

See Also

DutchAnalyzer Class
DutchAnalyzer Members
Lucene.Net.Analysis.Nl Namespace


SetStemExclusionTable Method (Hashtable)

[image]

Lucene.Net Class Libraries
DutchAnalyzer..::..SetStemExclusionTable Method (Hashtable)
DutchAnalyzer Class See Also Send Feedback
Builds an exclusionlist from a Hashtable.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    Hashtable exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As Hashtable _
)
Visual C++
public:
void SetStemExclusionTable(
    Hashtable^ exclusionlist
)

Parameters

exclusionlist
Type: System.Collections..::..Hashtable

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.SetStemExclusionTable(System.Collections.Hashtable)"]

See Also

DutchAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.Nl Namespace


SetStemExclusionTable Method (FileInfo)

[image]

Lucene.Net Class Libraries
DutchAnalyzer..::..SetStemExclusionTable Method (FileInfo)
DutchAnalyzer Class See Also Send Feedback
Builds an exclusionlist from the words contained in the given file.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    FileInfo exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As FileInfo _
)
Visual C++
public:
void SetStemExclusionTable(
    FileInfo^ exclusionlist
)

Parameters

exclusionlist
Type: System.IO..::..FileInfo

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.SetStemExclusionTable(System.IO.FileInfo)"]

See Also

DutchAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.Nl Namespace


SetStemExclusionTable Method (String[])

[image]

Lucene.Net Class Libraries
DutchAnalyzer..::..SetStemExclusionTable Method (array<String>[]()[][])
DutchAnalyzer Class See Also Send Feedback
Builds an exclusionlist from an array of Strings.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemExclusionTable(
    string[] exclusionlist
)
Visual Basic
Public Sub SetStemExclusionTable ( _
    exclusionlist As String() _
)
Visual C++
public:
void SetStemExclusionTable(
    array<String^>^ exclusionlist
)

Parameters

exclusionlist
Type: array< System..::..String >[]()[][]

[Missing <param name="exclusionlist"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.SetStemExclusionTable(System.String[])"]

See Also

DutchAnalyzer Class
SetStemExclusionTable Overload
Lucene.Net.Analysis.Nl Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
DutchAnalyzer..::..TokenStream Method
DutchAnalyzer Class See Also Send Feedback
Creates a TokenStream which tokenizes all the text in the provided TextReader.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

A TokenStream build from a StandardTokenizer filtered with StandardFilter, StopFilter, GermanStemFilter

See Also

DutchAnalyzer Class
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Class

[image]

Lucene.Net Class Libraries
DutchStemFilter Class
Members See Also Send Feedback
A filter that stems Dutch words. It supports a table of words that should not be stemmed at all. The stemmer used can be changed at runtime after the filter object is created (as long as it is a DutchStemmer). $Id: DutchStemFilter.java,v 1.1 2004/03/09 14:55:08 otis Exp $

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class DutchStemFilter : TokenFilter
Visual Basic
Public NotInheritable Class DutchStemFilter _
    Inherits TokenFilter
Visual C++
public ref class DutchStemFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Nl..::..DutchStemFilter

See Also

DutchStemFilter Members
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Members

[image] [image]

Lucene.Net Class Libraries
DutchStemFilter Members
DutchStemFilter Class Constructors Methods Fields See Also Send Feedback

The DutchStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DutchStemFilter(TokenStream) | Initializes a new instance of the DutchStemFilter class
Public method | DutchStemFilter(TokenStream, Hashtable) | Builds a DutchStemFilter that uses an exclusiontable.
Public method | DutchStemFilter(TokenStream, Hashtable, Hashtable) | Initializes a new instance of the DutchStemFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetExclusionTable
Set an alternative exclusion list for this filter.
Public method SetStemDictionary
Set dictionary for stemming, this dictionary overrules the algorithm, so you can correct for a particular unwanted word-stem pair.
Public method SetStemmer
Set a alternative/custom DutchStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

DutchStemFilter Class
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Constructor

[image] [image]

Lucene.Net Class Libraries
DutchStemFilter Constructor
DutchStemFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DutchStemFilter(TokenStream) | Initializes a new instance of the DutchStemFilter class
Public method | DutchStemFilter(TokenStream, Hashtable) | Builds a DutchStemFilter that uses an exclusiontable.
Public method | DutchStemFilter(TokenStream, Hashtable, Hashtable) | Initializes a new instance of the DutchStemFilter class

See Also

DutchStemFilter Class
DutchStemFilter Members
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
DutchStemFilter Constructor (TokenStream)
DutchStemFilter Class See Also Send Feedback
Initializes a new instance of the DutchStemFilter class

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchStemFilter(
    TokenStream _in
)
Visual Basic
Public Sub New ( _
    _in As TokenStream _
)
Visual C++
public:
DutchStemFilter(
    TokenStream^ _in
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

DutchStemFilter Class
DutchStemFilter Overload
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Constructor (TokenStream, Hashtable)

[image]

Lucene.Net Class Libraries
DutchStemFilter Constructor (TokenStream, Hashtable)
DutchStemFilter Class See Also Send Feedback
Builds a DutchStemFilter that uses an exclusiontable.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchStemFilter(
    TokenStream _in,
    Hashtable exclusiontable
)
Visual Basic
Public Sub New ( _
    _in As TokenStream, _
    exclusiontable As Hashtable _
)
Visual C++
public:
DutchStemFilter(
    TokenStream^ _in,
    Hashtable^ exclusiontable
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable)"]

See Also

DutchStemFilter Class
DutchStemFilter Overload
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Constructor (TokenStream, Hashtable, Hashtable)

[image]

Lucene.Net Class Libraries
DutchStemFilter Constructor (TokenStream, Hashtable, Hashtable)
DutchStemFilter Class See Also Send Feedback
Initializes a new instance of the DutchStemFilter class

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchStemFilter(
    TokenStream _in,
    Hashtable exclusiontable,
    Hashtable stemdictionary
)
Visual Basic
Public Sub New ( _
    _in As TokenStream, _
    exclusiontable As Hashtable, _
    stemdictionary As Hashtable _
)
Visual C++
public:
DutchStemFilter(
    TokenStream^ _in,
    Hashtable^ exclusiontable,
    Hashtable^ stemdictionary
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable,System.Collections.Hashtable)"]

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Collections.Hashtable,System.Collections.Hashtable)"]

stemdictionary
Type: System.Collections..::..Hashtable
Dictionary of word stem pairs, that overrule the algorithm

See Also

DutchStemFilter Class
DutchStemFilter Overload
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
DutchStemFilter Fields
DutchStemFilter Class See Also Send Feedback

The DutchStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

DutchStemFilter Class
Lucene.Net.Analysis.Nl Namespace


DutchStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
DutchStemFilter Methods
DutchStemFilter Class See Also Send Feedback

The DutchStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetExclusionTable
Set an alternative exclusion list for this filter.
Public method SetStemDictionary
Set dictionary for stemming, this dictionary overrules the algorithm, so you can correct for a particular unwanted word-stem pair.
Public method SetStemmer
Set a alternative/custom DutchStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

See Also

DutchStemFilter Class
Lucene.Net.Analysis.Nl Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
DutchStemFilter..::..Next Method
DutchStemFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

DutchStemFilter Class
DutchStemFilter Members
Lucene.Net.Analysis.Nl Namespace


Next Method

[image]

Lucene.Net Class Libraries
DutchStemFilter..::..Next Method
DutchStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.Next"]

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

Returns the next token in the stream, or null at EOS

See Also

DutchStemFilter Class
Next Overload
Lucene.Net.Analysis.Nl Namespace


SetExclusionTable Method

[image]

Lucene.Net Class Libraries
DutchStemFilter..::..SetExclusionTable Method
DutchStemFilter Class See Also Send Feedback
Set an alternative exclusion list for this filter.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetExclusionTable(
    Hashtable exclusiontable
)
Visual Basic
Public Sub SetExclusionTable ( _
    exclusiontable As Hashtable _
)
Visual C++
public:
void SetExclusionTable(
    Hashtable^ exclusiontable
)

Parameters

exclusiontable
Type: System.Collections..::..Hashtable

[Missing <param name="exclusiontable"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.SetExclusionTable(System.Collections.Hashtable)"]

See Also

DutchStemFilter Class
Lucene.Net.Analysis.Nl Namespace


SetStemDictionary Method

[image]

Lucene.Net Class Libraries
DutchStemFilter..::..SetStemDictionary Method
DutchStemFilter Class See Also Send Feedback
Set dictionary for stemming, this dictionary overrules the algorithm, so you can correct for a particular unwanted word-stem pair.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemDictionary(
    Hashtable dict
)
Visual Basic
Public Sub SetStemDictionary ( _
    dict As Hashtable _
)
Visual C++
public:
void SetStemDictionary(
    Hashtable^ dict
)

Parameters

dict
Type: System.Collections..::..Hashtable

[Missing <param name="dict"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.SetStemDictionary(System.Collections.Hashtable)"]

See Also

DutchStemFilter Class
Lucene.Net.Analysis.Nl Namespace


SetStemmer Method

[image]

Lucene.Net Class Libraries
DutchStemFilter..::..SetStemmer Method
DutchStemFilter Class See Also Send Feedback
Set a alternative/custom DutchStemmer for this filter.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemmer(
    DutchStemmer stemmer
)
Visual Basic
Public Sub SetStemmer ( _
    stemmer As DutchStemmer _
)
Visual C++
public:
void SetStemmer(
    DutchStemmer^ stemmer
)

Parameters

stemmer
Type: Lucene.Net.Analysis.Nl..::..DutchStemmer

[Missing <param name="stemmer"/> documentation for "M:Lucene.Net.Analysis.Nl.DutchStemFilter.SetStemmer(Lucene.Net.Analysis.Nl.DutchStemmer)"]

See Also

DutchStemFilter Class
Lucene.Net.Analysis.Nl Namespace


DutchStemmer Class

[image]

Lucene.Net Class Libraries
DutchStemmer Class
Members See Also Send Feedback
A stemmer for Dutch words. The algorithm is an implementation of the dutch stemming algorithm in snowball. Snowball is a project of Martin Porter (does Porter Stemmer ring a bell?): @version $Id: DutchStemmer.java,v 1.1 2004/03/09 14:55:08 otis Exp $

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class DutchStemmer
Visual Basic
Public Class DutchStemmer
Visual C++
public ref class DutchStemmer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.Nl..::..DutchStemmer

See Also

DutchStemmer Members
Lucene.Net.Analysis.Nl Namespace


DutchStemmer Members

[image] [image]

Lucene.Net Class Libraries
DutchStemmer Members
DutchStemmer Class Constructors Methods See Also Send Feedback

The DutchStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | DutchStemmer | Initializes a new instance of the DutchStemmer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stem | Stemms the given term to an unique discriminator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DutchStemmer Class
Lucene.Net.Analysis.Nl Namespace


DutchStemmer Constructor

[image]

Lucene.Net Class Libraries
DutchStemmer Constructor
DutchStemmer Class See Also Send Feedback
Initializes a new instance of the DutchStemmer class

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public DutchStemmer()
Visual Basic
Public Sub New
Visual C++
public:
DutchStemmer()

See Also

DutchStemmer Class
Lucene.Net.Analysis.Nl Namespace


DutchStemmer Methods

[image] [image]

Lucene.Net Class Libraries
DutchStemmer Methods
DutchStemmer Class See Also Send Feedback

The DutchStemmer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stem | Stemms the given term to an unique discriminator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DutchStemmer Class
Lucene.Net.Analysis.Nl Namespace


Stem Method

[image]

Lucene.Net Class Libraries
DutchStemmer..::..Stem Method
DutchStemmer Class See Also Send Feedback
Stemms the given term to an unique discriminator.

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public string Stem(
    string term
)
Visual Basic
Public Function Stem ( _
    term As String _
) As String
Visual C++
public:
String^ Stem(
    String^ term
)

Parameters

term
Type: System..::..String
The term that should be stemmed.

Return Value

Discriminator for term

See Also

DutchStemmer Class
Lucene.Net.Analysis.Nl Namespace


WordlistLoader Class

[image]

Lucene.Net Class Libraries
WordlistLoader Class
Members See Also Send Feedback
Loads a text file and adds every line as an entry to a Hashtable. Every line should contain only one word. If the file is not found or on any error, an empty table is returned. $Id: WordListLoader.java,v 1.1 2004/03/09 14:55:08 otis Exp $

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class WordlistLoader
Visual Basic
Public Class WordlistLoader
Visual C++
public ref class WordlistLoader

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.Nl..::..WordlistLoader

See Also

WordlistLoader Members
Lucene.Net.Analysis.Nl Namespace


WordlistLoader Members

[image] [image]

Lucene.Net Class Libraries
WordlistLoader Members
WordlistLoader Class Constructors Methods See Also Send Feedback

The WordlistLoader type exposes the following members.

Constructors

 | Name | Description
Public method | WordlistLoader | Initializes a new instance of the WordlistLoader class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStemDict | Reads a stemsdictionary. Each line contains: word \t stem (i.e. tab seperated)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWordtable(FileInfo) |
 | GetWordtable(String) |
 | GetWordtable(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WordlistLoader Class
Lucene.Net.Analysis.Nl Namespace


WordlistLoader Constructor

[image]

Lucene.Net Class Libraries
WordlistLoader Constructor
WordlistLoader Class See Also Send Feedback
Initializes a new instance of the WordlistLoader class

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public WordlistLoader()
Visual Basic
Public Sub New
Visual C++
public:
WordlistLoader()

See Also

WordlistLoader Class
Lucene.Net.Analysis.Nl Namespace


WordlistLoader Methods

[image] [image]

Lucene.Net Class Libraries
WordlistLoader Methods
WordlistLoader Class See Also Send Feedback

The WordlistLoader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStemDict | Reads a stemsdictionary. Each line contains: word \t stem (i.e. tab seperated)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWordtable(FileInfo) |
 | GetWordtable(String) |
 | GetWordtable(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WordlistLoader Class
Lucene.Net.Analysis.Nl Namespace


GetStemDict Method

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetStemDict Method
WordlistLoader Class See Also Send Feedback
Reads a stemsdictionary. Each line contains: word \t stem (i.e. tab seperated)

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetStemDict(
    FileInfo wordstemfile
)
Visual Basic
Public Shared Function GetStemDict ( _
    wordstemfile As FileInfo _
) As Hashtable
Visual C++
public:
static Hashtable^ GetStemDict(
    FileInfo^ wordstemfile
)

Parameters

wordstemfile
Type: System.IO..::..FileInfo

[Missing <param name="wordstemfile"/> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetStemDict(System.IO.FileInfo)"]

Return Value

Stem dictionary that overrules, the stemming algorithm

See Also

WordlistLoader Class
Lucene.Net.Analysis.Nl Namespace


GetWordtable Method

[image] [image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method
WordlistLoader Class See Also Send Feedback

Overload List

Name | Description
GetWordtable(FileInfo) |
GetWordtable(String) |
GetWordtable(String, String) |

See Also

WordlistLoader Class
WordlistLoader Members
Lucene.Net.Analysis.Nl Namespace


GetWordtable Method (FileInfo)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (FileInfo)
WordlistLoader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetWordtable(System.IO.FileInfo)"]

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    FileInfo wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    wordfile As FileInfo _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    FileInfo^ wordfile
)

Parameters

wordfile
Type: System.IO..::..FileInfo
File containing the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetWordtable(System.IO.FileInfo)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis.Nl Namespace


GetWordtable Method (String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (String)
WordlistLoader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetWordtable(System.String)"]

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    string wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    wordfile As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    String^ wordfile
)

Parameters

wordfile
Type: System..::..String
Complete path to the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetWordtable(System.String)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis.Nl Namespace


GetWordtable Method (String, String)

[image]

Lucene.Net Class Libraries
WordlistLoader..::..GetWordtable Method (String, String)
WordlistLoader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetWordtable(System.String,System.String)"]

Namespace: Lucene.Net.Analysis.Nl
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static Hashtable GetWordtable(
    string path,
    string wordfile
)
Visual Basic
Public Shared Function GetWordtable ( _
    path As String, _
    wordfile As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetWordtable(
    String^ path,
    String^ wordfile
)

Parameters

path
Type: System..::..String
Path to the wordlist
wordfile
Type: System..::..String
Name of the wordlist

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Nl.WordlistLoader.GetWordtable(System.String,System.String)"]

See Also

WordlistLoader Class
GetWordtable Overload
Lucene.Net.Analysis.Nl Namespace


Lucene.Net.Analysis.Ru Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Ru Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Ru"]

Classes

 | Class | Description
Public class | RussianAnalyzer | Analyzer for Russian language. Supports an external list of stopwords (words that will not be indexed at all). A default set of stopwords is used unless an alternative list is specified.
Public class | RussianCharsets | RussianCharsets class contains encodings schemes (charsets) and ToLowerCase() method implementation for russian characters in Unicode, KOI8 and CP1252. Each encoding scheme contains lowercase (positions 0-31) and uppercase (position 32-63) characters. One should be able to add other encoding schemes (like ISO-8859-5 or customized) by adding a new charset and adding logic to ToLowerCase() method for that charset.
Public class | RussianLetterTokenizer | A RussianLetterTokenizer is a tokenizer that extends LetterTokenizer by additionally looking up letters in a given "russian charset". The problem with LeterTokenizer is that it uses Character.isLetter() method, which doesn't know how to detect letters in encodings like CP1252 and KOI8 (well-known problems with 0xD7 and 0xF7 chars)
Public class | RussianLowerCaseFilter | Normalizes token text to lower case, analyzing given ("russian") charset.
Public class | RussianStemFilter | A filter that stems Russian words. The implementation was inspired by GermanStemFilter. The input should be filtered by RussianLowerCaseFilter before passing it to RussianStemFilter, because RussianStemFilter only works with lowercase part of any "russian" charset.
Public class | RussianStemmer | Russian stemming algorithm implementation (see http://snowball.sourceforge.net for detailed description).


RussianAnalyzer Class

[image]

Lucene.Net Class Libraries
RussianAnalyzer Class
Members See Also Send Feedback
Analyzer for Russian language. Supports an external list of stopwords (words that will not be indexed at all). A default set of stopwords is used unless an alternative list is specified.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class RussianAnalyzer : Analyzer
Visual Basic
Public NotInheritable Class RussianAnalyzer _
    Inherits Analyzer
Visual C++
public ref class RussianAnalyzer sealed : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Ru..::..RussianAnalyzer

See Also

RussianAnalyzer Members
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
RussianAnalyzer Members
RussianAnalyzer Class Constructors Methods Fields See Also Send Feedback

The RussianAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | RussianAnalyzer()()()() | Builds an analyzer.
Public method | RussianAnalyzer(array<Char>[]()[][]) | Builds an analyzer.
Public method | RussianAnalyzer(array<Char>[]()[][], Hashtable) | Builds an analyzer with the given stop words.
Public method | RussianAnalyzer(array<Char>[]()[][], array<String>[]()[][]) | Builds an analyzer with the given stop words.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided TextReader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

RussianAnalyzer Class
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
RussianAnalyzer Constructor
RussianAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RussianAnalyzer()()()() | Builds an analyzer.
Public method | RussianAnalyzer(array<Char>[]()[][]) | Builds an analyzer.
Public method | RussianAnalyzer(array<Char>[]()[][], Hashtable) | Builds an analyzer with the given stop words.
Public method | RussianAnalyzer(array<Char>[]()[][], array<String>[]()[][]) | Builds an analyzer with the given stop words.

See Also

RussianAnalyzer Class
RussianAnalyzer Members
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Constructor

[image]

Lucene.Net Class Libraries
RussianAnalyzer Constructor
RussianAnalyzer Class See Also Send Feedback
Builds an analyzer.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianAnalyzer()
Visual Basic
Public Sub New
Visual C++
public:
RussianAnalyzer()

See Also

RussianAnalyzer Class
RussianAnalyzer Overload
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Constructor (Char[])

[image]

Lucene.Net Class Libraries
RussianAnalyzer Constructor (array<Char>[]()[][])
RussianAnalyzer Class See Also Send Feedback
Builds an analyzer.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianAnalyzer(
    char[] charset
)
Visual Basic
Public Sub New ( _
    charset As Char() _
)
Visual C++
public:
RussianAnalyzer(
    array<wchar_t>^ charset
)

Parameters

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.#ctor(System.Char[])"]

See Also

RussianAnalyzer Class
RussianAnalyzer Overload
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Constructor (Char[], Hashtable)

[image]

Lucene.Net Class Libraries
RussianAnalyzer Constructor (array<Char>[]()[][], Hashtable)
RussianAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianAnalyzer(
    char[] charset,
    Hashtable stopwords
)
Visual Basic
Public Sub New ( _
    charset As Char(), _
    stopwords As Hashtable _
)
Visual C++
public:
RussianAnalyzer(
    array<wchar_t>^ charset,
    Hashtable^ stopwords
)

Parameters

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.#ctor(System.Char[],System.Collections.Hashtable)"]

stopwords
Type: System.Collections..::..Hashtable

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.#ctor(System.Char[],System.Collections.Hashtable)"]

See Also

RussianAnalyzer Class
RussianAnalyzer Overload
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Constructor (Char[], String[])

[image]

Lucene.Net Class Libraries
RussianAnalyzer Constructor (array<Char>[]()[][], array<String>[]()[][])
RussianAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianAnalyzer(
    char[] charset,
    string[] stopwords
)
Visual Basic
Public Sub New ( _
    charset As Char(), _
    stopwords As String() _
)
Visual C++
public:
RussianAnalyzer(
    array<wchar_t>^ charset,
    array<String^>^ stopwords
)

Parameters

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.#ctor(System.Char[],System.String[])"]

stopwords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.#ctor(System.Char[],System.String[])"]

See Also

RussianAnalyzer Class
RussianAnalyzer Overload
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
RussianAnalyzer Fields
RussianAnalyzer Class See Also Send Feedback

The RussianAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

RussianAnalyzer Class
Lucene.Net.Analysis.Ru Namespace


RussianAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
RussianAnalyzer Methods
RussianAnalyzer Class See Also Send Feedback

The RussianAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Creates a TokenStream which tokenizes all the text in the provided TextReader. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RussianAnalyzer Class
Lucene.Net.Analysis.Ru Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
RussianAnalyzer..::..TokenStream Method
RussianAnalyzer Class See Also Send Feedback
Creates a TokenStream which tokenizes all the text in the provided TextReader.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

A TokenStream build from a RussianLetterTokenizer filtered with RussianLowerCaseFilter, StopFilter, and RussianStemFilter

See Also

RussianAnalyzer Class
Lucene.Net.Analysis.Ru Namespace


RussianCharsets Class

[image]

Lucene.Net Class Libraries
RussianCharsets Class
Members See Also Send Feedback
RussianCharsets class contains encodings schemes (charsets) and ToLowerCase() method implementation for russian characters in Unicode, KOI8 and CP1252. Each encoding scheme contains lowercase (positions 0-31) and uppercase (position 32-63) characters. One should be able to add other encoding schemes (like ISO-8859-5 or customized) by adding a new charset and adding logic to ToLowerCase() method for that charset.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class RussianCharsets
Visual Basic
Public Class RussianCharsets
Visual C++
public ref class RussianCharsets

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.Ru..::..RussianCharsets

See Also

RussianCharsets Members
Lucene.Net.Analysis.Ru Namespace


RussianCharsets Members

[image] [image]

Lucene.Net Class Libraries
RussianCharsets Members
RussianCharsets Class Constructors Methods Fields See Also Send Feedback

The RussianCharsets type exposes the following members.

Constructors

 | Name | Description
Public method | RussianCharsets | Initializes a new instance of the RussianCharsets class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToLowerCase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CP1251 | CP1251 Charset
KOI8 | KOI8 charset
UnicodeRussian | Unicode Russian charset (lowercase letters only)

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


RussianCharsets Constructor

[image]

Lucene.Net Class Libraries
RussianCharsets Constructor
RussianCharsets Class See Also Send Feedback
Initializes a new instance of the RussianCharsets class

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianCharsets()
Visual Basic
Public Sub New
Visual C++
public:
RussianCharsets()

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


RussianCharsets Fields

[image] [image]

Lucene.Net Class Libraries
RussianCharsets Fields
RussianCharsets Class See Also Send Feedback

The RussianCharsets type exposes the following members.

Fields

Name | Description
CP1251 | CP1251 Charset
KOI8 | KOI8 charset
UnicodeRussian | Unicode Russian charset (lowercase letters only)

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


CP1251 Field

[image]

Lucene.Net Class Libraries
RussianCharsets..::..CP1251 Field
RussianCharsets Class See Also Send Feedback
CP1251 Charset

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char[] CP1251
Visual Basic
Public Shared CP1251 As Char()
Visual C++
public:
static array<wchar_t>^ CP1251

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


KOI8 Field

[image]

Lucene.Net Class Libraries
RussianCharsets..::..KOI8 Field
RussianCharsets Class See Also Send Feedback
KOI8 charset

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char[] KOI8
Visual Basic
Public Shared KOI8 As Char()
Visual C++
public:
static array<wchar_t>^ KOI8

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


UnicodeRussian Field

[image]

Lucene.Net Class Libraries
RussianCharsets..::..UnicodeRussian Field
RussianCharsets Class See Also Send Feedback
Unicode Russian charset (lowercase letters only)

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char[] UnicodeRussian
Visual Basic
Public Shared UnicodeRussian As Char()
Visual C++
public:
static array<wchar_t>^ UnicodeRussian

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


RussianCharsets Methods

[image] [image]

Lucene.Net Class Libraries
RussianCharsets Methods
RussianCharsets Class See Also Send Feedback

The RussianCharsets type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToLowerCase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


ToLowerCase Method

[image]

Lucene.Net Class Libraries
RussianCharsets..::..ToLowerCase Method
RussianCharsets Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Ru.RussianCharsets.ToLowerCase(System.Char,System.Char[])"]

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char ToLowerCase(
    char letter,
    char[] charset
)
Visual Basic
Public Shared Function ToLowerCase ( _
    letter As Char, _
    charset As Char() _
) As Char
Visual C++
public:
static wchar_t ToLowerCase(
    wchar_t letter,
    array<wchar_t>^ charset
)

Parameters

letter
Type: System..::..Char

[Missing <param name="letter"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianCharsets.ToLowerCase(System.Char,System.Char[])"]

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianCharsets.ToLowerCase(System.Char,System.Char[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ru.RussianCharsets.ToLowerCase(System.Char,System.Char[])"]

See Also

RussianCharsets Class
Lucene.Net.Analysis.Ru Namespace


RussianLetterTokenizer Class

[image]

Lucene.Net Class Libraries
RussianLetterTokenizer Class
Members See Also Send Feedback
A RussianLetterTokenizer is a tokenizer that extends LetterTokenizer by additionally looking up letters in a given "russian charset". The problem with LeterTokenizer is that it uses Character.isLetter() method, which doesn't know how to detect letters in encodings like CP1252 and KOI8 (well-known problems with 0xD7 and 0xF7 chars)

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class RussianLetterTokenizer : CharTokenizer
Visual Basic
Public Class RussianLetterTokenizer _
    Inherits CharTokenizer
Visual C++
public ref class RussianLetterTokenizer : public CharTokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis..::..CharTokenizer
Lucene.Net.Analysis.Ru..::..RussianLetterTokenizer

See Also

RussianLetterTokenizer Members
Lucene.Net.Analysis.Ru Namespace


RussianLetterTokenizer Members

[image] [image]

Lucene.Net Class Libraries
RussianLetterTokenizer Members
RussianLetterTokenizer Class Constructors Methods Fields See Also Send Feedback

The RussianLetterTokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | RussianLetterTokenizer | Initializes a new instance of the RussianLetterTokenizer class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which satisfy Char.IsLetter(char).
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

RussianLetterTokenizer Class
Lucene.Net.Analysis.Ru Namespace


RussianLetterTokenizer Constructor

[image]

Lucene.Net Class Libraries
RussianLetterTokenizer Constructor
RussianLetterTokenizer Class See Also Send Feedback
Initializes a new instance of the RussianLetterTokenizer class

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianLetterTokenizer(
    TextReader _in,
    char[] charset
)
Visual Basic
Public Sub New ( _
    _in As TextReader, _
    charset As Char() _
)
Visual C++
public:
RussianLetterTokenizer(
    TextReader^ _in,
    array<wchar_t>^ charset
)

Parameters

_in
Type: System.IO..::..TextReader

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianLetterTokenizer.#ctor(System.IO.TextReader,System.Char[])"]

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianLetterTokenizer.#ctor(System.IO.TextReader,System.Char[])"]

See Also

RussianLetterTokenizer Class
Lucene.Net.Analysis.Ru Namespace


RussianLetterTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
RussianLetterTokenizer Fields
RussianLetterTokenizer Class See Also Send Feedback

The RussianLetterTokenizer type exposes the following members.

Fields

 | Name | Description
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)

See Also

RussianLetterTokenizer Class
Lucene.Net.Analysis.Ru Namespace


RussianLetterTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
RussianLetterTokenizer Methods
RussianLetterTokenizer Class See Also Send Feedback

The RussianLetterTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Inherited from CharTokenizer.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from CharTokenizer.)
Protected method IsTokenChar
Collects only characters which satisfy Char.IsLetter(char).
(Overrides CharTokenizer..::..IsTokenChar(Char).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)
Protected method Normalize
Called on each token character to normalize it before it is added to the token. The default implementation does nothing. Subclasses may use this to, e.g., lowercase tokens.
(Inherited from CharTokenizer.)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

RussianLetterTokenizer Class
Lucene.Net.Analysis.Ru Namespace


IsTokenChar Method

[image]

Lucene.Net Class Libraries
RussianLetterTokenizer..::..IsTokenChar Method
RussianLetterTokenizer Class See Also Send Feedback
Collects only characters which satisfy Char.IsLetter(char).

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected override bool IsTokenChar(
    char c
)
Visual Basic
Protected Overrides Function IsTokenChar ( _
    c As Char _
) As Boolean
Visual C++
protected:
virtual bool IsTokenChar(
    wchar_t c
) override

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianLetterTokenizer.IsTokenChar(System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ru.RussianLetterTokenizer.IsTokenChar(System.Char)"]

See Also

RussianLetterTokenizer Class
Lucene.Net.Analysis.Ru Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
RussianLetterTokenizer..::..Next Method
RussianLetterTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Inherited from CharTokenizer.)
Public method | Next(Token) | Obsolete. (Inherited from CharTokenizer.)

See Also

RussianLetterTokenizer Class
RussianLetterTokenizer Members
Lucene.Net.Analysis.Ru Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
RussianLetterTokenizer..::..Reset Method
RussianLetterTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Inherited from CharTokenizer.)

See Also

RussianLetterTokenizer Class
RussianLetterTokenizer Members
Lucene.Net.Analysis.Ru Namespace


RussianLowerCaseFilter Class

[image]

Lucene.Net Class Libraries
RussianLowerCaseFilter Class
Members See Also Send Feedback
Normalizes token text to lower case, analyzing given ("russian") charset.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class RussianLowerCaseFilter : TokenFilter
Visual Basic
Public NotInheritable Class RussianLowerCaseFilter _
    Inherits TokenFilter
Visual C++
public ref class RussianLowerCaseFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Ru..::..RussianLowerCaseFilter

See Also

RussianLowerCaseFilter Members
Lucene.Net.Analysis.Ru Namespace


RussianLowerCaseFilter Members

[image] [image]

Lucene.Net Class Libraries
RussianLowerCaseFilter Members
RussianLowerCaseFilter Class Constructors Methods Fields See Also Send Feedback

The RussianLowerCaseFilter type exposes the following members.

Constructors

 | Name | Description
Public method | RussianLowerCaseFilter | Initializes a new instance of the RussianLowerCaseFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

RussianLowerCaseFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianLowerCaseFilter Constructor

[image]

Lucene.Net Class Libraries
RussianLowerCaseFilter Constructor
RussianLowerCaseFilter Class See Also Send Feedback
Initializes a new instance of the RussianLowerCaseFilter class

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianLowerCaseFilter(
    TokenStream _in,
    char[] charset
)
Visual Basic
Public Sub New ( _
    _in As TokenStream, _
    charset As Char() _
)
Visual C++
public:
RussianLowerCaseFilter(
    TokenStream^ _in,
    array<wchar_t>^ charset
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianLowerCaseFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Char[])"]

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianLowerCaseFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Char[])"]

See Also

RussianLowerCaseFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianLowerCaseFilter Fields

[image] [image]

Lucene.Net Class Libraries
RussianLowerCaseFilter Fields
RussianLowerCaseFilter Class See Also Send Feedback

The RussianLowerCaseFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

RussianLowerCaseFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianLowerCaseFilter Methods

[image] [image]

Lucene.Net Class Libraries
RussianLowerCaseFilter Methods
RussianLowerCaseFilter Class See Also Send Feedback

The RussianLowerCaseFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

RussianLowerCaseFilter Class
Lucene.Net.Analysis.Ru Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
RussianLowerCaseFilter..::..Next Method
RussianLowerCaseFilter Class See Also Send Feedback

Overload List

Name | Description
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

RussianLowerCaseFilter Class
RussianLowerCaseFilter Members
Lucene.Net.Analysis.Ru Namespace


Next Method

[image]

Lucene.Net Class Libraries
RussianLowerCaseFilter..::..Next Method
RussianLowerCaseFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Ru.RussianLowerCaseFilter.Next"]

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ru.RussianLowerCaseFilter.Next"]

See Also

RussianLowerCaseFilter Class
Next Overload
Lucene.Net.Analysis.Ru Namespace


RussianStemFilter Class

[image]

Lucene.Net Class Libraries
RussianStemFilter Class
Members See Also Send Feedback
A filter that stems Russian words. The implementation was inspired by GermanStemFilter. The input should be filtered by RussianLowerCaseFilter before passing it to RussianStemFilter, because RussianStemFilter only works with lowercase part of any "russian" charset.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public sealed class RussianStemFilter : TokenFilter
Visual Basic
Public NotInheritable Class RussianStemFilter _
    Inherits TokenFilter
Visual C++
public ref class RussianStemFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Ru..::..RussianStemFilter

See Also

RussianStemFilter Members
Lucene.Net.Analysis.Ru Namespace


RussianStemFilter Members

[image] [image]

Lucene.Net Class Libraries
RussianStemFilter Members
RussianStemFilter Class Constructors Methods Fields See Also Send Feedback

The RussianStemFilter type exposes the following members.

Constructors

 | Name | Description
Public method | RussianStemFilter | Initializes a new instance of the RussianStemFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetStemmer
Set a alternative/custom RussianStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

RussianStemFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianStemFilter Constructor

[image]

Lucene.Net Class Libraries
RussianStemFilter Constructor
RussianStemFilter Class See Also Send Feedback
Initializes a new instance of the RussianStemFilter class

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianStemFilter(
    TokenStream _in,
    char[] charset
)
Visual Basic
Public Sub New ( _
    _in As TokenStream, _
    charset As Char() _
)
Visual C++
public:
RussianStemFilter(
    TokenStream^ _in,
    array<wchar_t>^ charset
)

Parameters

_in
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="_in"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Char[])"]

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.Char[])"]

See Also

RussianStemFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianStemFilter Fields

[image] [image]

Lucene.Net Class Libraries
RussianStemFilter Fields
RussianStemFilter Class See Also Send Feedback

The RussianStemFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

RussianStemFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianStemFilter Methods

[image] [image]

Lucene.Net Class Libraries
RussianStemFilter Methods
RussianStemFilter Class See Also Send Feedback

The RussianStemFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetStemmer
Set a alternative/custom RussianStemmer for this filter.
Public method | ToString | (Inherited from AttributeSource.)

See Also

RussianStemFilter Class
Lucene.Net.Analysis.Ru Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
RussianStemFilter..::..Next Method
RussianStemFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()()
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

RussianStemFilter Class
RussianStemFilter Members
Lucene.Net.Analysis.Ru Namespace


Next Method

[image]

Lucene.Net Class Libraries
RussianStemFilter..::..Next Method
RussianStemFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemFilter.Next"]

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

Returns the next token in the stream, or null at EOS

See Also

RussianStemFilter Class
Next Overload
Lucene.Net.Analysis.Ru Namespace


SetStemmer Method

[image]

Lucene.Net Class Libraries
RussianStemFilter..::..SetStemmer Method
RussianStemFilter Class See Also Send Feedback
Set a alternative/custom RussianStemmer for this filter.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetStemmer(
    RussianStemmer stemmer
)
Visual Basic
Public Sub SetStemmer ( _
    stemmer As RussianStemmer _
)
Visual C++
public:
void SetStemmer(
    RussianStemmer^ stemmer
)

Parameters

stemmer
Type: Lucene.Net.Analysis.Ru..::..RussianStemmer

[Missing <param name="stemmer"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemFilter.SetStemmer(Lucene.Net.Analysis.Ru.RussianStemmer)"]

See Also

RussianStemFilter Class
Lucene.Net.Analysis.Ru Namespace


RussianStemmer Class

[image]

Lucene.Net Class Libraries
RussianStemmer Class
Members See Also Send Feedback
Russian stemming algorithm implementation (see http://snowball.sourceforge.net for detailed description).

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class RussianStemmer
Visual Basic
Public Class RussianStemmer
Visual C++
public ref class RussianStemmer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis.Ru..::..RussianStemmer

See Also

RussianStemmer Members
Lucene.Net.Analysis.Ru Namespace


RussianStemmer Members

[image] [image]

Lucene.Net Class Libraries
RussianStemmer Members
RussianStemmer Class Constructors Methods See Also Send Feedback

The RussianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | RussianStemmer()()()() | RussianStemmer constructor comment.
Public method | RussianStemmer(array<Char>[]()[][]) | RussianStemmer constructor comment.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCharset | Insert the method's description here. Creation date: (16/03/2002 10:58:42 PM)
Public method | Stem(String) | Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)
 | Stem(String, array<Char>[]()[][]) | Static method for stemming with different charsets
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RussianStemmer Class
Lucene.Net.Analysis.Ru Namespace


RussianStemmer Constructor

[image] [image]

Lucene.Net Class Libraries
RussianStemmer Constructor
RussianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RussianStemmer()()()() | RussianStemmer constructor comment.
Public method | RussianStemmer(array<Char>[]()[][]) | RussianStemmer constructor comment.

See Also

RussianStemmer Class
RussianStemmer Members
Lucene.Net.Analysis.Ru Namespace


RussianStemmer Constructor

[image]

Lucene.Net Class Libraries
RussianStemmer Constructor
RussianStemmer Class See Also Send Feedback
RussianStemmer constructor comment.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
RussianStemmer()

See Also

RussianStemmer Class
RussianStemmer Overload
Lucene.Net.Analysis.Ru Namespace


RussianStemmer Constructor (Char[])

[image]

Lucene.Net Class Libraries
RussianStemmer Constructor (array<Char>[]()[][])
RussianStemmer Class See Also Send Feedback
RussianStemmer constructor comment.

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public RussianStemmer(
    char[] charset
)
Visual Basic
Public Sub New ( _
    charset As Char() _
)
Visual C++
public:
RussianStemmer(
    array<wchar_t>^ charset
)

Parameters

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.#ctor(System.Char[])"]

See Also

RussianStemmer Class
RussianStemmer Overload
Lucene.Net.Analysis.Ru Namespace


RussianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
RussianStemmer Methods
RussianStemmer Class See Also Send Feedback

The RussianStemmer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCharset | Insert the method's description here. Creation date: (16/03/2002 10:58:42 PM)
Public method | Stem(String) | Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)
 | Stem(String, array<Char>[]()[][]) | Static method for stemming with different charsets
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RussianStemmer Class
Lucene.Net.Analysis.Ru Namespace


SetCharset Method

[image]

Lucene.Net Class Libraries
RussianStemmer..::..SetCharset Method
RussianStemmer Class See Also Send Feedback
Insert the method's description here. Creation date: (16/03/2002 10:58:42 PM)

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetCharset(
    char[] newCharset
)
Visual Basic
Public Sub SetCharset ( _
    newCharset As Char() _
)
Visual C++
public:
void SetCharset(
    array<wchar_t>^ newCharset
)

Parameters

newCharset
Type: array< System..::..Char >[]()[][]

[Missing <param name="newCharset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.SetCharset(System.Char[])"]

See Also

RussianStemmer Class
Lucene.Net.Analysis.Ru Namespace


Stem Method

[image] [image]

Lucene.Net Class Libraries
RussianStemmer..::..Stem Method
RussianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Stem(String) | Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)
 | Stem(String, array<Char>[]()[][]) | Static method for stemming with different charsets

See Also

RussianStemmer Class
RussianStemmer Members
Lucene.Net.Analysis.Ru Namespace


Stem Method (String)

[image]

Lucene.Net Class Libraries
RussianStemmer..::..Stem Method (String)
RussianStemmer Class See Also Send Feedback
Finds the stem for given Russian word. Creation date: (16/03/2002 3:36:48 PM)

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public string Stem(
    string input
)
Visual Basic
Public Function Stem ( _
    input As String _
) As String
Visual C++
public:
String^ Stem(
    String^ input
)

Parameters

input
Type: System..::..String

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.Stem(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.Stem(System.String)"]

See Also

RussianStemmer Class
Stem Overload
Lucene.Net.Analysis.Ru Namespace


Stem Method (String, Char[])

[image]

Lucene.Net Class Libraries
RussianStemmer..::..Stem Method (String, array<Char>[]()[][])
RussianStemmer Class See Also Send Feedback
Static method for stemming with different charsets

Namespace: Lucene.Net.Analysis.Ru
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static string Stem(
    string theWord,
    char[] charset
)
Visual Basic
Public Shared Function Stem ( _
    theWord As String, _
    charset As Char() _
) As String
Visual C++
public:
static String^ Stem(
    String^ theWord,
    array<wchar_t>^ charset
)

Parameters

theWord
Type: System..::..String

[Missing <param name="theWord"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.Stem(System.String,System.Char[])"]

charset
Type: array< System..::..Char >[]()[][]

[Missing <param name="charset"/> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.Stem(System.String,System.Char[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Ru.RussianStemmer.Stem(System.String,System.Char[])"]

See Also

RussianStemmer Class
Stem Overload
Lucene.Net.Analysis.Ru Namespace


Lucene.Net.Analysis.Snowball Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Snowball Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Snowball"]

Classes

 | Class | Description
Public class | SnowballAnalyzer | Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter}, {@link StopFilter} and {@link SnowballFilter}. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".
Public class | SnowballFilter | A filter that stems words using a Snowball-generated stemmer. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".


SnowballAnalyzer Class

[image]

Lucene.Net Class Libraries
SnowballAnalyzer Class
Members See Also Send Feedback
Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter}, {@link StopFilter} and {@link SnowballFilter}. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class SnowballAnalyzer : Analyzer
Visual Basic
Public Class SnowballAnalyzer _
    Inherits Analyzer
Visual C++
public ref class SnowballAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Snowball..::..SnowballAnalyzer

See Also

SnowballAnalyzer Members
Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
SnowballAnalyzer Members
SnowballAnalyzer Class Constructors Methods Fields See Also Send Feedback

The SnowballAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | SnowballAnalyzer(String) | Builds the named analyzer with no stop words.
Public method | SnowballAnalyzer(String, array<String>[]()[][]) | Builds the named analyzer with the given stop words.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

SnowballAnalyzer Class
Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
SnowballAnalyzer Constructor
SnowballAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SnowballAnalyzer(String) | Builds the named analyzer with no stop words.
Public method | SnowballAnalyzer(String, array<String>[]()[][]) | Builds the named analyzer with the given stop words.

See Also

SnowballAnalyzer Class
SnowballAnalyzer Members
Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Constructor (String)

[image]

Lucene.Net Class Libraries
SnowballAnalyzer Constructor (String)
SnowballAnalyzer Class See Also Send Feedback
Builds the named analyzer with no stop words.

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public SnowballAnalyzer(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
SnowballAnalyzer(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballAnalyzer.#ctor(System.String)"]

See Also

SnowballAnalyzer Class
SnowballAnalyzer Overload
Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Constructor (String, String[])

[image]

Lucene.Net Class Libraries
SnowballAnalyzer Constructor (String, array<String>[]()[][])
SnowballAnalyzer Class See Also Send Feedback
Builds the named analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public SnowballAnalyzer(
    string name,
    string[] stopWords
)
Visual Basic
Public Sub New ( _
    name As String, _
    stopWords As String() _
)
Visual C++
public:
SnowballAnalyzer(
    String^ name,
    array<String^>^ stopWords
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballAnalyzer.#ctor(System.String,System.String[])"]

stopWords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballAnalyzer.#ctor(System.String,System.String[])"]

See Also

SnowballAnalyzer Class
SnowballAnalyzer Overload
Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
SnowballAnalyzer Fields
SnowballAnalyzer Class See Also Send Feedback

The SnowballAnalyzer type exposes the following members.

Fields

 | Name | Description
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

SnowballAnalyzer Class
Lucene.Net.Analysis.Snowball Namespace


SnowballAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
SnowballAnalyzer Methods
SnowballAnalyzer Class See Also Send Feedback

The SnowballAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Creates a TokenStream that is allowed to be re-used from the previous time that the same thread called this method. Callers that do not need to use more than one TokenStream at the same time from this analyzer should use this method for better performance. (Inherited from Analyzer.)
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SnowballAnalyzer Class
Lucene.Net.Analysis.Snowball Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
SnowballAnalyzer..::..TokenStream Method
SnowballAnalyzer Class See Also Send Feedback
Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

SnowballAnalyzer Class
Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Class

[image]

Lucene.Net Class Libraries
SnowballFilter Class
Members See Also Send Feedback
A filter that stems words using a Snowball-generated stemmer. Available stemmers are listed in {@link SF.Snowball.Ext}. The name of a stemmer is the part of the class name before "Stemmer", e.g., the stemmer in {@link EnglishStemmer} is named "English".

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class SnowballFilter : TokenFilter
Visual Basic
Public Class SnowballFilter _
    Inherits TokenFilter
Visual C++
public ref class SnowballFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Snowball..::..SnowballFilter

See Also

SnowballFilter Members
Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Members

[image] [image]

Lucene.Net Class Libraries
SnowballFilter Members
SnowballFilter Class Constructors Methods Fields See Also Send Feedback

The SnowballFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SnowballFilter | Construct the named stemming filter.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
Returns the next input Token, after being stemmed
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

SnowballFilter Class
Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Constructor

[image]

Lucene.Net Class Libraries
SnowballFilter Constructor
SnowballFilter Class See Also Send Feedback
Construct the named stemming filter.

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public SnowballFilter(
    TokenStream in_Renamed,
    string name
)
Visual Basic
Public Sub New ( _
    in_Renamed As TokenStream, _
    name As String _
)
Visual C++
public:
SnowballFilter(
    TokenStream^ in_Renamed,
    String^ name
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballFilter.#ctor(Lucene.Net.Analysis.TokenStream,System.String)"]

name
Type: System..::..String
the name of a stemmer

See Also

SnowballFilter Class
Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Fields

[image] [image]

Lucene.Net Class Libraries
SnowballFilter Fields
SnowballFilter Class See Also Send Feedback

The SnowballFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

SnowballFilter Class
Lucene.Net.Analysis.Snowball Namespace


SnowballFilter Methods

[image] [image]

Lucene.Net Class Libraries
SnowballFilter Methods
SnowballFilter Class See Also Send Feedback

The SnowballFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()()
Returns the next input Token, after being stemmed
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

SnowballFilter Class
Lucene.Net.Analysis.Snowball Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
SnowballFilter..::..Next Method
SnowballFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()()
Returns the next input Token, after being stemmed
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

SnowballFilter Class
SnowballFilter Members
Lucene.Net.Analysis.Snowball Namespace


Next Method

[image]

Lucene.Net Class Libraries
SnowballFilter..::..Next Method
SnowballFilter Class See Also Send Feedback
Returns the next input Token, after being stemmed

Namespace: Lucene.Net.Analysis.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Snowball.SnowballFilter.Next"]

See Also

SnowballFilter Class
Next Overload
Lucene.Net.Analysis.Snowball Namespace


Lucene.Net.Analysis.Standard Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Standard Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Standard"]

Classes

Class Description
Public class StandardAnalyzer
Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter} and {@link StopFilter}, using a list of English stop words.

You must specify the required {@link Version} compatibility when creating StandardAnalyzer:

  • As of 2.9, StopFilter preserves position increments
  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see LUCENE-1608
Public class StandardFilter
Normalizes tokens extracted with {@link StandardTokenizer}.
Public class StandardTokenizer
A grammar-based tokenizer constructed with JFlex

This should be a good tokenizer for most European-language documents:

  • Splits words at punctuation characters, removing punctuation. However, a dot that's not followed by whitespace is considered part of a token.
  • Splits words at hyphens, unless there's a number in the token, in which case the whole token is interpreted as a product number and is not split.
  • Recognizes email addresses and internet hostnames as one token.

Many applications have specific tokenizer needs. If this tokenizer does not suit your application, please consider copying this source code directory to your project and maintaining your own grammar-based tokenizer.

You must specify the required {@link Version} compatibility when creating StandardAnalyzer:


StandardAnalyzer Class

[image]

Lucene.Net Class Libraries
StandardAnalyzer Class
Members See Also Send Feedback
Filters {@link StandardTokenizer} with {@link StandardFilter}, {@link LowerCaseFilter} and {@link StopFilter}, using a list of English stop words.

You must specify the required {@link Version} compatibility when creating StandardAnalyzer:

  • As of 2.9, StopFilter preserves position increments
  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see LUCENE-1608

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class StandardAnalyzer : Analyzer
Visual Basic
Public Class StandardAnalyzer _
    Inherits Analyzer
Visual C++
public ref class StandardAnalyzer : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analysis.Standard..::..StandardAnalyzer

See Also

StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Members

[image] [image]

Lucene.Net Class Libraries
StandardAnalyzer Members
StandardAnalyzer Class Constructors Methods Fields See Also Send Feedback

The StandardAnalyzer type exposes the following members.

Constructors

 | Name | Description
Public method | StandardAnalyzer()()()() | Obsolete. Builds an analyzer with the default stop words ({@link #STOP_WORDS_SET}).
Public method | StandardAnalyzer(Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(Hashtable) | Obsolete. Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(FileInfo) | Obsolete. Builds an analyzer with the stop words from the given file.
Public method | StandardAnalyzer(TextReader) | Obsolete. Builds an analyzer with the stop words from the given reader.
Public method | StandardAnalyzer(array<String>[]()[][]) | Obsolete. Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(Version) | Builds an analyzer with the default stop words ({@link #STOP_WORDS}).
Public method | StandardAnalyzer(Hashtable, Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(FileInfo, Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(TextReader, Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(array<String>[]()[][], Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(Version, Hashtable) | Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StandardAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultReplaceInvalidAcronym | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxTokenLength |
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReplaceInvalidAcronym | Obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Obsolete. (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
 | SetDefaultReplaceInvalidAcronym | Obsolete.
Public method | SetMaxTokenLength | Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetReplaceInvalidAcronym | Obsolete.
Public method | TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | DEFAULT_MAX_TOKEN_LENGTH | Default maximum allowed token length
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | STOP_WORDS | Obsolete. An array containing some common English words that are usually not useful for searching.
 | STOP_WORDS_SET | An unmodifiable set containing some common English words that are usually not useful for searching.

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor

[image] [image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor
StandardAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StandardAnalyzer()()()() | Obsolete. Builds an analyzer with the default stop words ({@link #STOP_WORDS_SET}).
Public method | StandardAnalyzer(Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(Hashtable) | Obsolete. Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(FileInfo) | Obsolete. Builds an analyzer with the stop words from the given file.
Public method | StandardAnalyzer(TextReader) | Obsolete. Builds an analyzer with the stop words from the given reader.
Public method | StandardAnalyzer(array<String>[]()[][]) | Obsolete. Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(Version) | Builds an analyzer with the default stop words ({@link #STOP_WORDS}).
Public method | StandardAnalyzer(Hashtable, Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(FileInfo, Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(TextReader, Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(array<String>[]()[][], Boolean) | Obsolete. Initializes a new instance of the StandardAnalyzer class
Public method | StandardAnalyzer(Version, Hashtable) | Builds an analyzer with the given stop words.
Public method | StandardAnalyzer(Version, FileInfo) | Builds an analyzer with the stop words from the given file.
Public method | StandardAnalyzer(Version, TextReader) | Builds an analyzer with the stop words from the given reader.

See Also

StandardAnalyzer Class
StandardAnalyzer Members
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the default stop words ({@link #STOP_WORDS_SET}).

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardAnalyzer(Version) instead")]
public StandardAnalyzer()
Visual Basic
<ObsoleteAttribute("Use StandardAnalyzer(Version) instead")> _
Public Sub New
Visual C++
[ObsoleteAttribute(L"Use StandardAnalyzer(Version) instead")]
public:
StandardAnalyzer()

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (Boolean)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Boolean)
StandardAnalyzer Class See Also Send Feedback
Initializes a new instance of the StandardAnalyzer class

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value")]
public StandardAnalyzer(
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value")> _
Public Sub New ( _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value")]
public:
StandardAnalyzer(
    bool replaceInvalidAcronym
)

Parameters

replaceInvalidAcronym
Type: System..::..Boolean
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (Hashtable)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Hashtable)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardAnalyzer(Version, Set) instead")]
public StandardAnalyzer(
    Hashtable stopWords
)
Visual Basic
<ObsoleteAttribute("Use StandardAnalyzer(Version, Set) instead")> _
Public Sub New ( _
    stopWords As Hashtable _
)
Visual C++
[ObsoleteAttribute(L"Use StandardAnalyzer(Version, Set) instead")]
public:
StandardAnalyzer(
    Hashtable^ stopWords
)

Parameters

stopWords
Type: System.Collections..::..Hashtable

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.#ctor(System.Collections.Hashtable)"]

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (FileInfo)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardAnalyzer(Version, File) instead")]
public StandardAnalyzer(
    FileInfo stopwords
)
Visual Basic
<ObsoleteAttribute("Use StandardAnalyzer(Version, File) instead")> _
Public Sub New ( _
    stopwords As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use StandardAnalyzer(Version, File) instead")]
public:
StandardAnalyzer(
    FileInfo^ stopwords
)

Parameters

stopwords
Type: System.IO..::..FileInfo

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.#ctor(System.IO.FileInfo)"]

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
[!:WordlistLoader.GetWordSet(File)]


StandardAnalyzer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (TextReader)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardAnalyzer(Version, Reader) instead")]
public StandardAnalyzer(
    TextReader stopwords
)
Visual Basic
<ObsoleteAttribute("Use StandardAnalyzer(Version, Reader) instead")> _
Public Sub New ( _
    stopwords As TextReader _
)
Visual C++
[ObsoleteAttribute(L"Use StandardAnalyzer(Version, Reader) instead")]
public:
StandardAnalyzer(
    TextReader^ stopwords
)

Parameters

stopwords
Type: System.IO..::..TextReader

[Missing <param name="stopwords"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.#ctor(System.IO.TextReader)"]

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
[!:WordlistLoader.GetWordSet(Reader)]


StandardAnalyzer Constructor (String[])

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (array<String>[]()[][])
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardAnalyzer(Version, Set) instead")]
public StandardAnalyzer(
    string[] stopWords
)
Visual Basic
<ObsoleteAttribute("Use StandardAnalyzer(Version, Set) instead")> _
Public Sub New ( _
    stopWords As String() _
)
Visual C++
[ObsoleteAttribute(L"Use StandardAnalyzer(Version, Set) instead")]
public:
StandardAnalyzer(
    array<String^>^ stopWords
)

Parameters

stopWords
Type: array< System..::..String >[]()[][]

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.#ctor(System.String[])"]

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (Version)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Version)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the default stop words ({@link #STOP_WORDS}).

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardAnalyzer(
    Version matchVersion
)
Visual Basic
Public Sub New ( _
    matchVersion As Version _
)
Visual C++
public:
StandardAnalyzer(
    Version^ matchVersion
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match See {@link above}

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (Hashtable, Boolean)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Hashtable, Boolean)
StandardAnalyzer Class See Also Send Feedback
Initializes a new instance of the StandardAnalyzer class

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value")]
public StandardAnalyzer(
    Hashtable stopwords,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value")> _
Public Sub New ( _
    stopwords As Hashtable, _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value")]
public:
StandardAnalyzer(
    Hashtable^ stopwords,
    bool replaceInvalidAcronym
)

Parameters

stopwords
Type: System.Collections..::..Hashtable
The stopwords to use
replaceInvalidAcronym
Type: System..::..Boolean
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (FileInfo, Boolean)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (FileInfo, Boolean)
StandardAnalyzer Class See Also Send Feedback
Initializes a new instance of the StandardAnalyzer class

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value")]
public StandardAnalyzer(
    FileInfo stopwords,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value")> _
Public Sub New ( _
    stopwords As FileInfo, _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value")]
public:
StandardAnalyzer(
    FileInfo^ stopwords,
    bool replaceInvalidAcronym
)

Parameters

stopwords
Type: System.IO..::..FileInfo
The stopwords to use
replaceInvalidAcronym
Type: System..::..Boolean
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (TextReader, Boolean)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (TextReader, Boolean)
StandardAnalyzer Class See Also Send Feedback
Initializes a new instance of the StandardAnalyzer class

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value")]
public StandardAnalyzer(
    TextReader stopwords,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value")> _
Public Sub New ( _
    stopwords As TextReader, _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value")]
public:
StandardAnalyzer(
    TextReader^ stopwords,
    bool replaceInvalidAcronym
)

Parameters

stopwords
Type: System.IO..::..TextReader
The stopwords to use
replaceInvalidAcronym
Type: System..::..Boolean
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (String[], Boolean)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (array<String>[]()[][], Boolean)
StandardAnalyzer Class See Also Send Feedback
Initializes a new instance of the StandardAnalyzer class

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value")]
public StandardAnalyzer(
    string[] stopwords,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value")> _
Public Sub New ( _
    stopwords As String(), _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value")]
public:
StandardAnalyzer(
    array<String^>^ stopwords,
    bool replaceInvalidAcronym
)

Parameters

stopwords
Type: array< System..::..String >[]()[][]
The stopwords to use
replaceInvalidAcronym
Type: System..::..Boolean
Set to true if this analyzer should replace mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (Version, Hashtable)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Version, Hashtable)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the given stop words.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardAnalyzer(
    Version matchVersion,
    Hashtable stopWords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopWords As Hashtable _
)
Visual C++
public:
StandardAnalyzer(
    Version^ matchVersion,
    Hashtable^ stopWords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match See {@link above}
stopWords
Type: System.Collections..::..Hashtable
stop words

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Constructor (Version, FileInfo)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Version, FileInfo)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given file.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardAnalyzer(
    Version matchVersion,
    FileInfo stopwords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopwords As FileInfo _
)
Visual C++
public:
StandardAnalyzer(
    Version^ matchVersion,
    FileInfo^ stopwords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match See {@link above}
stopwords
Type: System.IO..::..FileInfo
File to read stop words from

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
[!:WordlistLoader.GetWordSet(File)]


StandardAnalyzer Constructor (Version, TextReader)

[image]

Lucene.Net Class Libraries
StandardAnalyzer Constructor (Version, TextReader)
StandardAnalyzer Class See Also Send Feedback
Builds an analyzer with the stop words from the given reader.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardAnalyzer(
    Version matchVersion,
    TextReader stopwords
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    stopwords As TextReader _
)
Visual C++
public:
StandardAnalyzer(
    Version^ matchVersion,
    TextReader^ stopwords
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match See {@link above}
stopwords
Type: System.IO..::..TextReader
Reader to read stop words from

See Also

StandardAnalyzer Class
StandardAnalyzer Overload
Lucene.Net.Analysis.Standard Namespace
[!:WordlistLoader.GetWordSet(Reader)]


StandardAnalyzer Fields

[image] [image]

Lucene.Net Class Libraries
StandardAnalyzer Fields
StandardAnalyzer Class See Also Send Feedback

The StandardAnalyzer type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_MAX_TOKEN_LENGTH | Default maximum allowed token length
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)
 | STOP_WORDS | Obsolete. An array containing some common English words that are usually not useful for searching.
 | STOP_WORDS_SET | An unmodifiable set containing some common English words that are usually not useful for searching.

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


DEFAULT_MAX_TOKEN_LENGTH Field

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..DEFAULT_MAX_TOKEN_LENGTH Field
StandardAnalyzer Class See Also Send Feedback
Default maximum allowed token length

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT_MAX_TOKEN_LENGTH
Visual Basic
Public Const DEFAULT_MAX_TOKEN_LENGTH As Integer
Visual C++
public:
literal int DEFAULT_MAX_TOKEN_LENGTH

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


STOP_WORDS Field

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..STOP_WORDS Field
StandardAnalyzer Class See Also Send Feedback
An array containing some common English words that are usually not useful for searching.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use STOP_WORDS_SET instead ")]
public static readonly string[] STOP_WORDS
Visual Basic
<ObsoleteAttribute("Use STOP_WORDS_SET instead ")> _
Public Shared ReadOnly STOP_WORDS As String()
Visual C++
[ObsoleteAttribute(L"Use STOP_WORDS_SET instead ")]
public:
static initonly array<String^>^ STOP_WORDS

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


STOP_WORDS_SET Field

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..STOP_WORDS_SET Field
StandardAnalyzer Class See Also Send Feedback
An unmodifiable set containing some common English words that are usually not useful for searching.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Hashtable STOP_WORDS_SET
Visual Basic
Public Shared ReadOnly STOP_WORDS_SET As Hashtable
Visual C++
public:
static initonly Hashtable^ STOP_WORDS_SET

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


StandardAnalyzer Methods

[image] [image]

Lucene.Net Class Libraries
StandardAnalyzer Methods
StandardAnalyzer Class See Also Send Feedback

The StandardAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultReplaceInvalidAcronym | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxTokenLength |
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReplaceInvalidAcronym | Obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | Obsolete. (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
 | SetDefaultReplaceInvalidAcronym | Obsolete.
Public method | SetMaxTokenLength | Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | SetReplaceInvalidAcronym | Obsolete.
Public method | TokenStream | Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}. (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


GetDefaultReplaceInvalidAcronym Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..GetDefaultReplaceInvalidAcronym Method
StandardAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.GetDefaultReplaceInvalidAcronym"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")]
public static bool GetDefaultReplaceInvalidAcronym()
Visual Basic
<ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")> _
Public Shared Function GetDefaultReplaceInvalidAcronym As Boolean
Visual C++
[ObsoleteAttribute(L"This will be removed (hardwired to true) in 3.0")]
public:
static bool GetDefaultReplaceInvalidAcronym()

Return Value

true if new instances of StandardTokenizer will replace mischaracterized acronyms See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


GetMaxTokenLength Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..GetMaxTokenLength Method
StandardAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.GetMaxTokenLength"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxTokenLength()
Visual Basic
Public Overridable Function GetMaxTokenLength As Integer
Visual C++
public:
virtual int GetMaxTokenLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.GetMaxTokenLength"]

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace
[!:setMaxTokenLength]


IsReplaceInvalidAcronym Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..IsReplaceInvalidAcronym Method
StandardAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.IsReplaceInvalidAcronym"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")]
public virtual bool IsReplaceInvalidAcronym()
Visual Basic
<ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")> _
Public Overridable Function IsReplaceInvalidAcronym As Boolean
Visual C++
[ObsoleteAttribute(L"This will be removed (hardwired to true) in 3.0")]
public:
virtual bool IsReplaceInvalidAcronym()

Return Value

true if this Analyzer is replacing mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..ReusableTokenStream Method
StandardAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use TokenStream instead")]
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
<ObsoleteAttribute("Use TokenStream instead")> _
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
[ObsoleteAttribute(L"Use TokenStream instead")]
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


SetDefaultReplaceInvalidAcronym Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..SetDefaultReplaceInvalidAcronym Method
StandardAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.SetDefaultReplaceInvalidAcronym(System.Boolean)"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")]
public static void SetDefaultReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")> _
Public Shared Sub SetDefaultReplaceInvalidAcronym ( _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This will be removed (hardwired to true) in 3.0")]
public:
static void SetDefaultReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)

Parameters

replaceInvalidAcronym
Type: System..::..Boolean
Set to true to have new instances of StandardTokenizer replace mischaracterized acronyms by default. Set to false to preserve the previous (before 2.4) buggy behavior. Alternatively, set the system property Lucene.Net.Analysis.Standard.StandardAnalyzer.replaceInvalidAcronym to false. See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


SetMaxTokenLength Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..SetMaxTokenLength Method
StandardAnalyzer Class See Also Send Feedback
Set maximum allowed token length. If a token is seen that exceeds this length then it is discarded. This setting only takes effect the next time tokenStream or reusableTokenStream is called.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxTokenLength(
    int length
)
Visual Basic
Public Overridable Sub SetMaxTokenLength ( _
    length As Integer _
)
Visual C++
public:
virtual void SetMaxTokenLength(
    int length
)

Parameters

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.SetMaxTokenLength(System.Int32)"]

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


SetReplaceInvalidAcronym Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..SetReplaceInvalidAcronym Method
StandardAnalyzer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.SetReplaceInvalidAcronym(System.Boolean)"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")]
public virtual void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("This will be removed (hardwired to true) in 3.0")> _
Public Overridable Sub SetReplaceInvalidAcronym ( _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This will be removed (hardwired to true) in 3.0")]
public:
virtual void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)

Parameters

replaceInvalidAcronym
Type: System..::..Boolean
Set to true if this Analyzer is replacing mischaracterized acronyms in the StandardTokenizer See https://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
StandardAnalyzer..::..TokenStream Method
StandardAnalyzer Class See Also Send Feedback
Constructs a {@link StandardTokenizer} filtered by a {@link StandardFilter}, a {@link LowerCaseFilter} and a {@link StopFilter}.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardAnalyzer.TokenStream(System.String,System.IO.TextReader)"]

See Also

StandardAnalyzer Class
Lucene.Net.Analysis.Standard Namespace


StandardFilter Class

[image]

Lucene.Net Class Libraries
StandardFilter Class
Members See Also Send Feedback
Normalizes tokens extracted with {@link StandardTokenizer}.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StandardFilter : TokenFilter
Visual Basic
Public NotInheritable Class StandardFilter _
    Inherits TokenFilter
Visual C++
public ref class StandardFilter sealed : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analysis.Standard..::..StandardFilter

See Also

StandardFilter Members
Lucene.Net.Analysis.Standard Namespace


StandardFilter Members

[image] [image]

Lucene.Net Class Libraries
StandardFilter Members
StandardFilter Class Constructors Methods Fields See Also Send Feedback

The StandardFilter type exposes the following members.

Constructors

 | Name | Description
Public method | StandardFilter | Construct filtering in.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Returns the next token in the stream, or null at EOS.

Removes 's from the end of words.

Removes dots from acronyms.

(Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

StandardFilter Class
Lucene.Net.Analysis.Standard Namespace


StandardFilter Constructor

[image]

Lucene.Net Class Libraries
StandardFilter Constructor
StandardFilter Class See Also Send Feedback
Construct filtering in.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardFilter(
    TokenStream in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TokenStream _
)
Visual C++
public:
StandardFilter(
    TokenStream^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardFilter.#ctor(Lucene.Net.Analysis.TokenStream)"]

See Also

StandardFilter Class
Lucene.Net.Analysis.Standard Namespace


StandardFilter Fields

[image] [image]

Lucene.Net Class Libraries
StandardFilter Fields
StandardFilter Class See Also Send Feedback

The StandardFilter type exposes the following members.

Fields

 | Name | Description
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)

See Also

StandardFilter Class
Lucene.Net.Analysis.Standard Namespace


StandardFilter Methods

[image] [image]

Lucene.Net Class Libraries
StandardFilter Methods
StandardFilter Class See Also Send Feedback

The StandardFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Returns the next token in the stream, or null at EOS.

Removes 's from the end of words.

Removes dots from acronyms.

(Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Reset the filter as well as the input TokenStream.
(Inherited from TokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

StandardFilter Class
Lucene.Net.Analysis.Standard Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
StandardFilter..::..IncrementToken Method
StandardFilter Class See Also Send Feedback
Returns the next token in the stream, or null at EOS.

Removes 's from the end of words.

Removes dots from acronyms.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardFilter.IncrementToken"]

See Also

StandardFilter Class
Lucene.Net.Analysis.Standard Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
StandardFilter..::..Next Method
StandardFilter Class See Also Send Feedback

Overload List

Name Description
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

StandardFilter Class
StandardFilter Members
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Class

[image]

Lucene.Net Class Libraries
StandardTokenizer Class
Members See Also Send Feedback
A grammar-based tokenizer constructed with JFlex

This should be a good tokenizer for most European-language documents:

  • Splits words at punctuation characters, removing punctuation. However, a dot that's not followed by whitespace is considered part of a token.
  • Splits words at hyphens, unless there's a number in the token, in which case the whole token is interpreted as a product number and is not split.
  • Recognizes email addresses and internet hostnames as one token.

Many applications have specific tokenizer needs. If this tokenizer does not suit your application, please consider copying this source code directory to your project and maintaining your own grammar-based tokenizer.

You must specify the required {@link Version} compatibility when creating StandardAnalyzer:

  • As of 2.4, Tokens incorrectly identified as acronyms are corrected (see LUCENE-1608

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class StandardTokenizer : Tokenizer
Visual Basic
Public Class StandardTokenizer _
    Inherits Tokenizer
Visual C++
public ref class StandardTokenizer : public Tokenizer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..Tokenizer
Lucene.Net.Analysis.Standard..::..StandardTokenizer

See Also

StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Members

[image] [image]

Lucene.Net Class Libraries
StandardTokenizer Members
StandardTokenizer Class Constructors Methods Fields See Also Send Feedback

The StandardTokenizer type exposes the following members.

Constructors

Name Description
Public method StandardTokenizer(TextReader) Obsolete.
Creates a new instance of the {@link StandardTokenizer}. Attaches the
CopyC#
input
 to a newly created JFlex scanner.
Public method StandardTokenizer(TextReader, Boolean) Obsolete.
Creates a new instance of the {@link Lucene.Net.Analysis.Standard.StandardTokenizer}. Attaches the
CopyC#
input
 to the newly created JFlex scanner.
Public method StandardTokenizer(Version, TextReader)
Creates a new instance of the {@link org.apache.lucene.analysis.standard.StandardTokenizer}. Attaches the
CopyC#
input
 to the newly created JFlex scanner.
Public method StandardTokenizer(AttributeSource, TextReader, Boolean) Obsolete.
Creates a new StandardTokenizer with a given {@link AttributeSource}.
Public method StandardTokenizer(AttributeSource..::..AttributeFactory, TextReader, Boolean) Obsolete.
Creates a new StandardTokenizer with a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}
Public method StandardTokenizer(Version, AttributeSource, TextReader)
Creates a new StandardTokenizer with a given {@link AttributeSource}.
Public method StandardTokenizer(Version, AttributeSource..::..AttributeFactory, TextReader)
Creates a new StandardTokenizer with a given {@link org.apache.lucene.util.AttributeSource.AttributeFactory}

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | GetMaxTokenLength
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Public method IsReplaceInvalidAcronym Obsolete.
Prior to https://issues.apache.org/jira/browse/LUCENE-1068, StandardTokenizer mischaracterized as acronyms tokens like www.abc.com when they should have been labeled as hosts instead.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetMaxTokenLength
Set the max allowed token length. Any token longer than this is skipped.
Public method SetReplaceInvalidAcronym Obsolete.
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
 | ACRONYM |
 | ACRONYM_DEP | Obsolete.
 | ALPHANUM |
 | APOSTROPHE |
 | CJ |
 | COMPANY |
 | EMAIL |
 | HOST |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
 | NUM |
 | TOKEN_TYPES | String token types that correspond to token type int constants
 | tokenImage | Obsolete.

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor

[image] [image]

Lucene.Net Class Libraries
StandardTokenizer Constructor
StandardTokenizer Class See Also Send Feedback

Overload List

Name Description
Public method StandardTokenizer(TextReader) Obsolete.
Creates a new instance of the {@link StandardTokenizer}. Attaches the
CopyC#
input
 to a newly created JFlex scanner.
Public method StandardTokenizer(TextReader, Boolean) Obsolete.
Creates a new instance of the {@link Lucene.Net.Analysis.Standard.StandardTokenizer}. Attaches the
CopyC#
input
 to the newly created JFlex scanner.
Public method StandardTokenizer(Version, TextReader)
Creates a new instance of the {@link org.apache.lucene.analysis.standard.StandardTokenizer}. Attaches the
CopyC#
input
 to the newly created JFlex scanner.
Public method StandardTokenizer(AttributeSource, TextReader, Boolean) Obsolete.
Creates a new StandardTokenizer with a given {@link AttributeSource}.
Public method StandardTokenizer(AttributeSource..::..AttributeFactory, TextReader, Boolean) Obsolete.
Creates a new StandardTokenizer with a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}
Public method StandardTokenizer(Version, AttributeSource, TextReader)
Creates a new StandardTokenizer with a given {@link AttributeSource}.
Public method StandardTokenizer(Version, AttributeSource..::..AttributeFactory, TextReader)
Creates a new StandardTokenizer with a given {@link org.apache.lucene.util.AttributeSource.AttributeFactory}

See Also

StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (TextReader)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (TextReader)
StandardTokenizer Class See Also Send Feedback
Creates a new instance of the {@link StandardTokenizer}. Attaches the
CopyC#
input
 to a newly created JFlex scanner.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardTokenizer(Version, Reader) instead")]
public StandardTokenizer(
    TextReader input
)
Visual Basic
<ObsoleteAttribute("Use StandardTokenizer(Version, Reader) instead")> _
Public Sub New ( _
    input As TextReader _
)
Visual C++
[ObsoleteAttribute(L"Use StandardTokenizer(Version, Reader) instead")]
public:
StandardTokenizer(
    TextReader^ input
)

Parameters

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(System.IO.TextReader)"]

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (TextReader, Boolean)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (TextReader, Boolean)
StandardTokenizer Class See Also Send Feedback
Creates a new instance of the {@link Lucene.Net.Analysis.Standard.StandardTokenizer}. Attaches the
CopyC#
input
 to the newly created JFlex scanner.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardTokenizer(Version, Reader) instead")]
public StandardTokenizer(
    TextReader input,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Use StandardTokenizer(Version, Reader) instead")> _
Public Sub New ( _
    input As TextReader, _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StandardTokenizer(Version, Reader) instead")]
public:
StandardTokenizer(
    TextReader^ input,
    bool replaceInvalidAcronym
)

Parameters

input
Type: System.IO..::..TextReader
The input reader
replaceInvalidAcronym
Type: System..::..Boolean
Set to true to replace mischaracterized acronyms with HOST. See http://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (Version, TextReader)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (Version, TextReader)
StandardTokenizer Class See Also Send Feedback
Creates a new instance of the {@link org.apache.lucene.analysis.standard.StandardTokenizer}. Attaches the
CopyC#
input
 to the newly created JFlex scanner.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardTokenizer(
    Version matchVersion,
    TextReader input
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    input As TextReader _
)
Visual C++
public:
StandardTokenizer(
    Version^ matchVersion,
    TextReader^ input
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader
The input reader See http://issues.apache.org/jira/browse/LUCENE-1068

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (AttributeSource, TextReader, Boolean)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (AttributeSource, TextReader, Boolean)
StandardTokenizer Class See Also Send Feedback
Creates a new StandardTokenizer with a given {@link AttributeSource}.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardTokenizer(Version, AttributeSource, Reader) instead")]
public StandardTokenizer(
    AttributeSource source,
    TextReader input,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Use StandardTokenizer(Version, AttributeSource, Reader) instead")> _
Public Sub New ( _
    source As AttributeSource, _
    input As TextReader, _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StandardTokenizer(Version, AttributeSource, Reader) instead")]
public:
StandardTokenizer(
    AttributeSource^ source,
    TextReader^ input,
    bool replaceInvalidAcronym
)

Parameters

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Boolean)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Boolean)"]

replaceInvalidAcronym
Type: System..::..Boolean

[Missing <param name="replaceInvalidAcronym"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.AttributeSource,System.IO.TextReader,System.Boolean)"]

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (AttributeSource.AttributeFactory, TextReader, Boolean)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (AttributeSource..::..AttributeFactory, TextReader, Boolean)
StandardTokenizer Class See Also Send Feedback
Creates a new StandardTokenizer with a given {@link Lucene.Net.Util.AttributeSource.AttributeFactory}

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use StandardTokenizer(Version, Lucene.Net.Util.AttributeSource.AttributeFactory, Reader) instead")]
public StandardTokenizer(
    AttributeSource..::..AttributeFactory factory,
    TextReader input,
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Use StandardTokenizer(Version, Lucene.Net.Util.AttributeSource.AttributeFactory, Reader) instead")> _
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader, _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use StandardTokenizer(Version, Lucene.Net.Util.AttributeSource.AttributeFactory, Reader) instead")]
public:
StandardTokenizer(
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input,
    bool replaceInvalidAcronym
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Boolean)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Boolean)"]

replaceInvalidAcronym
Type: System..::..Boolean

[Missing <param name="replaceInvalidAcronym"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader,System.Boolean)"]

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (Version, AttributeSource, TextReader)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (Version, AttributeSource, TextReader)
StandardTokenizer Class See Also Send Feedback
Creates a new StandardTokenizer with a given {@link AttributeSource}.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardTokenizer(
    Version matchVersion,
    AttributeSource source,
    TextReader input
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    source As AttributeSource, _
    input As TextReader _
)
Visual C++
public:
StandardTokenizer(
    Version^ matchVersion,
    AttributeSource^ source,
    TextReader^ input
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

source
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="source"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,Lucene.Net.Util.AttributeSource,System.IO.TextReader)"]

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Constructor (Version, AttributeSource.AttributeFactory, TextReader)

[image]

Lucene.Net Class Libraries
StandardTokenizer Constructor (Version, AttributeSource..::..AttributeFactory, TextReader)
StandardTokenizer Class See Also Send Feedback
Creates a new StandardTokenizer with a given {@link org.apache.lucene.util.AttributeSource.AttributeFactory}

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StandardTokenizer(
    Version matchVersion,
    AttributeSource..::..AttributeFactory factory,
    TextReader input
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    factory As AttributeSource..::..AttributeFactory, _
    input As TextReader _
)
Visual C++
public:
StandardTokenizer(
    Version^ matchVersion,
    AttributeSource..::..AttributeFactory^ factory,
    TextReader^ input
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

input
Type: System.IO..::..TextReader

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.#ctor(Lucene.Net.Util.Version,Lucene.Net.Util.AttributeSource.AttributeFactory,System.IO.TextReader)"]

See Also

StandardTokenizer Class
StandardTokenizer Overload
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Fields

[image] [image]

Lucene.Net Class Libraries
StandardTokenizer Fields
StandardTokenizer Class See Also Send Feedback

The StandardTokenizer type exposes the following members.

Fields

 | Name | Description
 | ACRONYM |
 | ACRONYM_DEP | Obsolete.
 | ALPHANUM |
 | APOSTROPHE |
 | CJ |
 | COMPANY |
 | EMAIL |
 | HOST |
Protected field | input | The text source for this Tokenizer. (Inherited from Tokenizer.)
 | NUM |
 | TOKEN_TYPES | String token types that correspond to token type int constants
 | tokenImage | Obsolete.

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


ACRONYM Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..ACRONYM Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.ACRONYM"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int ACRONYM
Visual Basic
Public Const ACRONYM As Integer
Visual C++
public:
literal int ACRONYM

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


ACRONYM_DEP Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..ACRONYM_DEP Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.ACRONYM_DEP"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("this solves a bug where HOSTs that end with '.' are identified as ACRONYMs. It is deprecated and will be removed in the next release.")]
public const int ACRONYM_DEP
Visual Basic
<ObsoleteAttribute("this solves a bug where HOSTs that end with '.' are identified as ACRONYMs. It is deprecated and will be removed in the next release.")> _
Public Const ACRONYM_DEP As Integer
Visual C++
[ObsoleteAttribute(L"this solves a bug where HOSTs that end with '.' are identified as ACRONYMs. It is deprecated and will be removed in the next release.")]
public:
literal int ACRONYM_DEP

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


ALPHANUM Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..ALPHANUM Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.ALPHANUM"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int ALPHANUM
Visual Basic
Public Const ALPHANUM As Integer
Visual C++
public:
literal int ALPHANUM

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


APOSTROPHE Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..APOSTROPHE Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.APOSTROPHE"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int APOSTROPHE
Visual Basic
Public Const APOSTROPHE As Integer
Visual C++
public:
literal int APOSTROPHE

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


CJ Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..CJ Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.CJ"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int CJ
Visual Basic
Public Const CJ As Integer
Visual C++
public:
literal int CJ

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


COMPANY Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..COMPANY Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.COMPANY"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int COMPANY
Visual Basic
Public Const COMPANY As Integer
Visual C++
public:
literal int COMPANY

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


EMAIL Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..EMAIL Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.EMAIL"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int EMAIL
Visual Basic
Public Const EMAIL As Integer
Visual C++
public:
literal int EMAIL

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


HOST Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..HOST Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.HOST"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int HOST
Visual Basic
Public Const HOST As Integer
Visual C++
public:
literal int HOST

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


NUM Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..NUM Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.NUM"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int NUM
Visual Basic
Public Const NUM As Integer
Visual C++
public:
literal int NUM

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


TOKEN_TYPES Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..TOKEN_TYPES Field
StandardTokenizer Class See Also Send Feedback
String token types that correspond to token type int constants

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] TOKEN_TYPES
Visual Basic
Public Shared ReadOnly TOKEN_TYPES As String()
Visual C++
public:
static initonly array<String^>^ TOKEN_TYPES

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


tokenImage Field

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..tokenImage Field
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Standard.StandardTokenizer.tokenImage"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use TOKEN_TYPES instead")]
public static readonly string[] tokenImage
Visual Basic
<ObsoleteAttribute("Please use TOKEN_TYPES instead")> _
Public Shared ReadOnly tokenImage As String()
Visual C++
[ObsoleteAttribute(L"Please use TOKEN_TYPES instead")]
public:
static initonly array<String^>^ tokenImage

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


StandardTokenizer Methods

[image] [image]

Lucene.Net Class Libraries
StandardTokenizer Methods
StandardTokenizer Class See Also Send Feedback

The StandardTokenizer type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
By default, closes the input Reader.
(Inherited from Tokenizer.)
Protected method CorrectOffset
Return the corrected offset. If {@link #input} is a {@link CharStream} subclass this method calls {@link CharStream#CorrectOffset}, else returns
CopyC#
currentOff
.
(Inherited from Tokenizer.)
Public method | End | (Overrides TokenStream..::..End()()()().)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | GetMaxTokenLength
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Public method IsReplaceInvalidAcronym Obsolete.
Prior to https://issues.apache.org/jira/browse/LUCENE-1068, StandardTokenizer mischaracterized as acronyms tokens like www.abc.com when they should have been labeled as hosts instead.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetMaxTokenLength
Set the max allowed token length. Any token longer than this is skipped.
Public method SetReplaceInvalidAcronym Obsolete.
Public method | ToString | (Inherited from AttributeSource.)

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


End Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..End Method
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.End"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void End()
Visual Basic
Public Overrides Sub End
Visual C++
public:
virtual void End() override

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


GetMaxTokenLength Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..GetMaxTokenLength Method
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.GetMaxTokenLength"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxTokenLength()
Visual Basic
Public Overridable Function GetMaxTokenLength As Integer
Visual C++
public:
virtual int GetMaxTokenLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.GetMaxTokenLength"]

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace
[!:setMaxTokenLength]


IncrementToken Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..IncrementToken Method
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.IncrementToken"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.IncrementToken"]

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


IsReplaceInvalidAcronym Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..IsReplaceInvalidAcronym Method
StandardTokenizer Class See Also Send Feedback
Prior to https://issues.apache.org/jira/browse/LUCENE-1068, StandardTokenizer mischaracterized as acronyms tokens like www.abc.com when they should have been labeled as hosts instead.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value")]
public virtual bool IsReplaceInvalidAcronym()
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value")> _
Public Overridable Function IsReplaceInvalidAcronym As Boolean
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value")]
public:
virtual bool IsReplaceInvalidAcronym()

Return Value

true if StandardTokenizer now returns these tokens as Hosts, otherwise false

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
StandardTokenizer..::..Next Method
StandardTokenizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace


Next Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..Next Method
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Next"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next()
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Next"]

See Also

StandardTokenizer Class
Next Overload
Lucene.Net.Analysis.Standard Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..Next Method (Token)
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. ")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Next(Lucene.Net.Analysis.Token)"]

See Also

StandardTokenizer Class
Next Overload
Lucene.Net.Analysis.Standard Namespace


Reset Method

[image] [image]

Lucene.Net Class Libraries
StandardTokenizer..::..Reset Method
StandardTokenizer Class See Also Send Feedback

Overload List

Name | Description
Public method Reset()()()()
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method | Reset(TextReader) | (Overrides Tokenizer..::..Reset(TextReader).)

See Also

StandardTokenizer Class
StandardTokenizer Members
Lucene.Net.Analysis.Standard Namespace


Reset Method (TextReader)

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..Reset Method (TextReader)
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Reset(System.IO.TextReader)"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Reset(
    TextReader reader
)
Visual Basic
Public Overrides Sub Reset ( _
    reader As TextReader _
)
Visual C++
public:
virtual void Reset(
    TextReader^ reader
) override

Parameters

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.Reset(System.IO.TextReader)"]

See Also

StandardTokenizer Class
Reset Overload
Lucene.Net.Analysis.Standard Namespace


SetMaxTokenLength Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..SetMaxTokenLength Method
StandardTokenizer Class See Also Send Feedback
Set the max allowed token length. Any token longer than this is skipped.

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxTokenLength(
    int length
)
Visual Basic
Public Overridable Sub SetMaxTokenLength ( _
    length As Integer _
)
Visual C++
public:
virtual void SetMaxTokenLength(
    int length
)

Parameters

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.SetMaxTokenLength(System.Int32)"]

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


SetReplaceInvalidAcronym Method

[image]

Lucene.Net Class Libraries
StandardTokenizer..::..SetReplaceInvalidAcronym Method
StandardTokenizer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Standard.StandardTokenizer.SetReplaceInvalidAcronym(System.Boolean)"]

Namespace: Lucene.Net.Analysis.Standard
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")]
public virtual void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)
Visual Basic
<ObsoleteAttribute("Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")> _
Public Overridable Sub SetReplaceInvalidAcronym ( _
    replaceInvalidAcronym As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Remove in 3.X and make true the only valid value. See https://issues.apache.org/jira/browse/LUCENE-1068")]
public:
virtual void SetReplaceInvalidAcronym(
    bool replaceInvalidAcronym
)

Parameters

replaceInvalidAcronym
Type: System..::..Boolean
Set to true to replace mischaracterized acronyms as HOST.

See Also

StandardTokenizer Class
Lucene.Net.Analysis.Standard Namespace


Lucene.Net.Analysis.Tokenattributes Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analysis.Tokenattributes Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analysis.Tokenattributes"]

Classes

Class Description
Public class FlagsAttributeImpl
This attribute can be used to pass different flags down the tokenizer chain, eg from one TokenFilter to another one.
Public class OffsetAttributeImpl
The start and end character offset of a Token.
Public class PayloadAttributeImpl
The payload of a Token. See also {@link Payload}.
Public class PositionIncrementAttributeImpl
The positionIncrement determines the position of this token relative to the previous Token in a {@link TokenStream}, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public class TermAttributeImpl
The term text of a Token.
Public class TypeAttributeImpl
A Token's lexical type. The Default value is "word".

Interfaces

Interface Description
Public interface FlagsAttribute
This attribute can be used to pass different flags down the {@link Tokenizer} chain, eg from one TokenFilter to another one.
Public interface OffsetAttribute
The start and end character offset of a Token.
Public interface PayloadAttribute
The payload of a Token. See also {@link Payload}.
Public interface PositionIncrementAttribute
The positionIncrement determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.
Public interface TermAttribute
The term text of a Token.
Public interface TypeAttribute
A Token's lexical type. The Default value is "word".


FlagsAttribute Interface

[image]

Lucene.Net Class Libraries
FlagsAttribute Interface
Members See Also Send Feedback
This attribute can be used to pass different flags down the {@link Tokenizer} chain, eg from one TokenFilter to another one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface FlagsAttribute : Attribute
Visual Basic
Public Interface FlagsAttribute _
    Inherits Attribute
Visual C++
public interface class FlagsAttribute : Attribute

See Also

FlagsAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace


FlagsAttribute Members

[image] [image]

Lucene.Net Class Libraries
FlagsAttribute Members
FlagsAttribute Interface Methods See Also Send Feedback

The FlagsAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetFlags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from {@link TypeAttribute#Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.
Public method | SetFlags |

See Also

FlagsAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


FlagsAttribute Methods

[image] [image]

Lucene.Net Class Libraries
FlagsAttribute Methods
FlagsAttribute Interface See Also Send Feedback

The FlagsAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetFlags | EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long. Get the bitset for any bits that have been set. This is completely distinct from {@link TypeAttribute#Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.
Public method | SetFlags |

See Also

FlagsAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


GetFlags Method

[image]

Lucene.Net Class Libraries
FlagsAttribute..::..GetFlags Method
FlagsAttribute Interface See Also Send Feedback
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link TypeAttribute#Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetFlags()
Visual Basic
Function GetFlags As Integer
Visual C++
int GetFlags()

Return Value

The bits

See Also

FlagsAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


SetFlags Method

[image]

Lucene.Net Class Libraries
FlagsAttribute..::..SetFlags Method
FlagsAttribute Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttribute.SetFlags(System.Int32)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetFlags(
    int flags
)
Visual Basic
Sub SetFlags ( _
    flags As Integer _
)
Visual C++
void SetFlags(
    int flags
)

Parameters

flags
Type: System..::..Int32

[Missing <param name="flags"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttribute.SetFlags(System.Int32)"]

See Also

FlagsAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace
FlagsAttribute..::..GetFlags()()()()


FlagsAttributeImpl Class

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl Class
Members See Also Send Feedback
This attribute can be used to pass different flags down the tokenizer chain, eg from one TokenFilter to another one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FlagsAttributeImpl : AttributeImpl,
    FlagsAttribute, Attribute, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class FlagsAttributeImpl _
    Inherits AttributeImpl _
    Implements FlagsAttribute, Attribute, ICloneable
Visual C++
[SerializableAttribute]
public ref class FlagsAttributeImpl : public AttributeImpl,
    FlagsAttribute, Attribute, ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..FlagsAttributeImpl

See Also

FlagsAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


FlagsAttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
FlagsAttributeImpl Members
FlagsAttributeImpl Class Constructors Methods See Also Send Feedback

The FlagsAttributeImpl type exposes the following members.

Constructors

 | Name | Description
Public method | FlagsAttributeImpl | Initializes a new instance of the FlagsAttributeImpl class

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetFlags
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link TypeAttribute#Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | SetFlags
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


FlagsAttributeImpl Constructor

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl Constructor
FlagsAttributeImpl Class See Also Send Feedback
Initializes a new instance of the FlagsAttributeImpl class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FlagsAttributeImpl()
Visual Basic
Public Sub New
Visual C++
public:
FlagsAttributeImpl()

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


FlagsAttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
FlagsAttributeImpl Methods
FlagsAttributeImpl Class See Also Send Feedback

The FlagsAttributeImpl type exposes the following members.

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetFlags
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link TypeAttribute#Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | SetFlags
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clear Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..Clear Method
FlagsAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.Clear"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clone Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..Clone Method
FlagsAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.Clone"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..CopyTo Method
FlagsAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..Equals Method
FlagsAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.Equals(System.Object)"]

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetFlags Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..GetFlags Method
FlagsAttributeImpl Class See Also Send Feedback
EXPERIMENTAL: While we think this is here to stay, we may want to change it to be a long.

Get the bitset for any bits that have been set. This is completely distinct from {@link TypeAttribute#Type()}, although they do share similar purposes. The flags can be used to encode information about the token for use by other {@link Lucene.Net.Analysis.TokenFilter}s.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetFlags()
Visual Basic
Public Overridable Function GetFlags As Integer
Visual C++
public:
virtual int GetFlags()

Return Value

The bits

Implements

FlagsAttribute..::..GetFlags()()()()

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..GetHashCode Method
FlagsAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.GetHashCode"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.GetHashCode"]

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


SetFlags Method

[image]

Lucene.Net Class Libraries
FlagsAttributeImpl..::..SetFlags Method
FlagsAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.SetFlags(System.Int32)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetFlags(
    int flags
)
Visual Basic
Public Overridable Sub SetFlags ( _
    flags As Integer _
)
Visual C++
public:
virtual void SetFlags(
    int flags
)

Parameters

flags
Type: System..::..Int32

[Missing <param name="flags"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.FlagsAttributeImpl.SetFlags(System.Int32)"]

Implements

FlagsAttribute..::..SetFlags(Int32)

See Also

FlagsAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace
FlagsAttributeImpl..::..GetFlags()()()()


OffsetAttribute Interface

[image]

Lucene.Net Class Libraries
OffsetAttribute Interface
Members See Also Send Feedback
The start and end character offset of a Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface OffsetAttribute : Attribute
Visual Basic
Public Interface OffsetAttribute _
    Inherits Attribute
Visual C++
public interface class OffsetAttribute : Attribute

See Also

OffsetAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace


OffsetAttribute Members

[image] [image]

Lucene.Net Class Libraries
OffsetAttribute Members
OffsetAttribute Interface Methods See Also Send Feedback

The OffsetAttribute type exposes the following members.

Methods

 | Name | Description
Public method | EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public method | SetOffset | Set the starting and ending offset. See StartOffset() and EndOffset()
Public method | StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

See Also

OffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


OffsetAttribute Methods

[image] [image]

Lucene.Net Class Libraries
OffsetAttribute Methods
OffsetAttribute Interface See Also Send Feedback

The OffsetAttribute type exposes the following members.

Methods

 | Name | Description
Public method | EndOffset | Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public method | SetOffset | Set the starting and ending offset. See StartOffset() and EndOffset()
Public method | StartOffset | Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

See Also

OffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


EndOffset Method

[image]

Lucene.Net Class Libraries
OffsetAttribute..::..EndOffset Method
OffsetAttribute Interface See Also Send Feedback
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int EndOffset()
Visual Basic
Function EndOffset As Integer
Visual C++
int EndOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttribute.EndOffset"]

See Also

OffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


SetOffset Method

[image]

Lucene.Net Class Libraries
OffsetAttribute..::..SetOffset Method
OffsetAttribute Interface See Also Send Feedback
Set the starting and ending offset. See StartOffset() and EndOffset()

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetOffset(
    int startOffset,
    int endOffset
)
Visual Basic
Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Visual C++
void SetOffset(
    int startOffset,
    int endOffset
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttribute.SetOffset(System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttribute.SetOffset(System.Int32,System.Int32)"]

See Also

OffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


StartOffset Method

[image]

Lucene.Net Class Libraries
OffsetAttribute..::..StartOffset Method
OffsetAttribute Interface See Also Send Feedback
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int StartOffset()
Visual Basic
Function StartOffset As Integer
Visual C++
int StartOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttribute.StartOffset"]

See Also

OffsetAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


OffsetAttributeImpl Class

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl Class
Members See Also Send Feedback
The start and end character offset of a Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class OffsetAttributeImpl : AttributeImpl,
    OffsetAttribute, Attribute, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class OffsetAttributeImpl _
    Inherits AttributeImpl _
    Implements OffsetAttribute, Attribute, ICloneable
Visual C++
[SerializableAttribute]
public ref class OffsetAttributeImpl : public AttributeImpl,
    OffsetAttribute, Attribute, ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..OffsetAttributeImpl

See Also

OffsetAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


OffsetAttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
OffsetAttributeImpl Members
OffsetAttributeImpl Class Constructors Methods See Also Send Feedback

The OffsetAttributeImpl type exposes the following members.

Constructors

 | Name | Description
Public method | OffsetAttributeImpl | Initializes a new instance of the OffsetAttributeImpl class

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method EndOffset
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetOffset
Set the starting and ending offset. See StartOffset() and EndOffset()
Public method StartOffset
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


OffsetAttributeImpl Constructor

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl Constructor
OffsetAttributeImpl Class See Also Send Feedback
Initializes a new instance of the OffsetAttributeImpl class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OffsetAttributeImpl()
Visual Basic
Public Sub New
Visual C++
public:
OffsetAttributeImpl()

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


OffsetAttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
OffsetAttributeImpl Methods
OffsetAttributeImpl Class See Also Send Feedback

The OffsetAttributeImpl type exposes the following members.

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method EndOffset
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetOffset
Set the starting and ending offset. See StartOffset() and EndOffset()
Public method StartOffset
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clear Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..Clear Method
OffsetAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.Clear"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clone Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..Clone Method
OffsetAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.Clone"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..CopyTo Method
OffsetAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


EndOffset Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..EndOffset Method
OffsetAttributeImpl Class See Also Send Feedback
Returns this Token's ending offset, one greater than the position of the last character corresponding to this token in the source text. The length of the token in the source text is (endOffset - startOffset).

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int EndOffset()
Visual Basic
Public Overridable Function EndOffset As Integer
Visual C++
public:
virtual int EndOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.EndOffset"]

Implements

OffsetAttribute..::..EndOffset()()()()

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Equals Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..Equals Method
OffsetAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.Equals(System.Object)"]

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..GetHashCode Method
OffsetAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.GetHashCode"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.GetHashCode"]

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


SetOffset Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..SetOffset Method
OffsetAttributeImpl Class See Also Send Feedback
Set the starting and ending offset. See StartOffset() and EndOffset()

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetOffset(
    int startOffset,
    int endOffset
)
Visual Basic
Public Overridable Sub SetOffset ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Visual C++
public:
virtual void SetOffset(
    int startOffset,
    int endOffset
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.SetOffset(System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.SetOffset(System.Int32,System.Int32)"]

Implements

OffsetAttribute..::..SetOffset(Int32, Int32)

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


StartOffset Method

[image]

Lucene.Net Class Libraries
OffsetAttributeImpl..::..StartOffset Method
OffsetAttributeImpl Class See Also Send Feedback
Returns this Token's starting offset, the position of the first character corresponding to this token in the source text. Note that the difference between endOffset() and startOffset() may not be equal to termText.length(), as the term text may have been altered by a stemmer or some other filter.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int StartOffset()
Visual Basic
Public Overridable Function StartOffset As Integer
Visual C++
public:
virtual int StartOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.OffsetAttributeImpl.StartOffset"]

Implements

OffsetAttribute..::..StartOffset()()()()

See Also

OffsetAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttribute Interface

[image]

Lucene.Net Class Libraries
PayloadAttribute Interface
Members See Also Send Feedback
The payload of a Token. See also {@link Payload}.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface PayloadAttribute : Attribute
Visual Basic
Public Interface PayloadAttribute _
    Inherits Attribute
Visual C++
public interface class PayloadAttribute : Attribute

See Also

PayloadAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttribute Members

[image] [image]

Lucene.Net Class Libraries
PayloadAttribute Members
PayloadAttribute Interface Methods See Also Send Feedback

The PayloadAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetPayload | Returns this Token's payload.
Public method | SetPayload | Sets this Token's payload.

See Also

PayloadAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttribute Methods

[image] [image]

Lucene.Net Class Libraries
PayloadAttribute Methods
PayloadAttribute Interface See Also Send Feedback

The PayloadAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetPayload | Returns this Token's payload.
Public method | SetPayload | Sets this Token's payload.

See Also

PayloadAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
PayloadAttribute..::..GetPayload Method
PayloadAttribute Interface See Also Send Feedback
Returns this Token's payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Payload GetPayload()
Visual Basic
Function GetPayload As Payload
Visual C++
Payload^ GetPayload()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttribute.GetPayload"]

See Also

PayloadAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


SetPayload Method

[image]

Lucene.Net Class Libraries
PayloadAttribute..::..SetPayload Method
PayloadAttribute Interface See Also Send Feedback
Sets this Token's payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetPayload(
    Payload payload
)
Visual Basic
Sub SetPayload ( _
    payload As Payload _
)
Visual C++
void SetPayload(
    Payload^ payload
)

Parameters

payload
Type: Lucene.Net.Index..::..Payload

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttribute.SetPayload(Lucene.Net.Index.Payload)"]

See Also

PayloadAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttributeImpl Class

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl Class
Members See Also Send Feedback
The payload of a Token. See also {@link Payload}.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PayloadAttributeImpl : AttributeImpl,
    PayloadAttribute, Attribute, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class PayloadAttributeImpl _
    Inherits AttributeImpl _
    Implements PayloadAttribute, Attribute, ICloneable
Visual C++
[SerializableAttribute]
public ref class PayloadAttributeImpl : public AttributeImpl,
    PayloadAttribute, Attribute, ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..PayloadAttributeImpl

See Also

PayloadAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
PayloadAttributeImpl Members
PayloadAttributeImpl Class Constructors Methods See Also Send Feedback

The PayloadAttributeImpl type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadAttributeImpl()()()() | Initialize this attribute with no payload.
Public method | PayloadAttributeImpl(Payload) | Initialize this attribute with the given payload.

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetPayload
Returns this Token's payload.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetPayload
Sets this Token's payload.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttributeImpl Constructor

[image] [image]

Lucene.Net Class Libraries
PayloadAttributeImpl Constructor
PayloadAttributeImpl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PayloadAttributeImpl()()()() | Initialize this attribute with no payload.
Public method | PayloadAttributeImpl(Payload) | Initialize this attribute with the given payload.

See Also

PayloadAttributeImpl Class
PayloadAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttributeImpl Constructor

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl Constructor
PayloadAttributeImpl Class See Also Send Feedback
Initialize this attribute with no payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadAttributeImpl()
Visual Basic
Public Sub New
Visual C++
public:
PayloadAttributeImpl()

See Also

PayloadAttributeImpl Class
PayloadAttributeImpl Overload
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttributeImpl Constructor (Payload)

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl Constructor (Payload)
PayloadAttributeImpl Class See Also Send Feedback
Initialize this attribute with the given payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadAttributeImpl(
    Payload payload
)
Visual Basic
Public Sub New ( _
    payload As Payload _
)
Visual C++
public:
PayloadAttributeImpl(
    Payload^ payload
)

Parameters

payload
Type: Lucene.Net.Index..::..Payload

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.#ctor(Lucene.Net.Index.Payload)"]

See Also

PayloadAttributeImpl Class
PayloadAttributeImpl Overload
Lucene.Net.Analysis.Tokenattributes Namespace


PayloadAttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
PayloadAttributeImpl Methods
PayloadAttributeImpl Class See Also Send Feedback

The PayloadAttributeImpl type exposes the following members.

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetPayload
Returns this Token's payload.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetPayload
Sets this Token's payload.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clear Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..Clear Method
PayloadAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.Clear"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clone Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..Clone Method
PayloadAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.Clone"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..CopyTo Method
PayloadAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..Equals Method
PayloadAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.Equals(System.Object)"]

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..GetHashCode Method
PayloadAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.GetHashCode"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.GetHashCode"]

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..GetPayload Method
PayloadAttributeImpl Class See Also Send Feedback
Returns this Token's payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Payload GetPayload()
Visual Basic
Public Overridable Function GetPayload As Payload
Visual C++
public:
virtual Payload^ GetPayload()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.GetPayload"]

Implements

PayloadAttribute..::..GetPayload()()()()

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


SetPayload Method

[image]

Lucene.Net Class Libraries
PayloadAttributeImpl..::..SetPayload Method
PayloadAttributeImpl Class See Also Send Feedback
Sets this Token's payload.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetPayload(
    Payload payload
)
Visual Basic
Public Overridable Sub SetPayload ( _
    payload As Payload _
)
Visual C++
public:
virtual void SetPayload(
    Payload^ payload
)

Parameters

payload
Type: Lucene.Net.Index..::..Payload

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PayloadAttributeImpl.SetPayload(Lucene.Net.Index.Payload)"]

Implements

PayloadAttribute..::..SetPayload(Payload)

See Also

PayloadAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


PositionIncrementAttribute Interface

[image]

Lucene.Net Class Libraries
PositionIncrementAttribute Interface
Members See Also Send Feedback
The positionIncrement determines the position of this token relative to the previous Token in a TokenStream, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface PositionIncrementAttribute : Attribute
Visual Basic
Public Interface PositionIncrementAttribute _
    Inherits Attribute
Visual C++
public interface class PositionIncrementAttribute : Attribute

See Also

PositionIncrementAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace
Lucene.Net.Index..::..TermPositions


PositionIncrementAttribute Members

[image] [image]

Lucene.Net Class Libraries
PositionIncrementAttribute Members
PositionIncrementAttribute Interface Methods See Also Send Feedback

The PositionIncrementAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetPositionIncrement | Returns the position increment of this Token.
Public method | SetPositionIncrement | Set the position increment. The default value is one.

See Also

PositionIncrementAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


PositionIncrementAttribute Methods

[image] [image]

Lucene.Net Class Libraries
PositionIncrementAttribute Methods
PositionIncrementAttribute Interface See Also Send Feedback

The PositionIncrementAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetPositionIncrement | Returns the position increment of this Token.
Public method | SetPositionIncrement | Set the position increment. The default value is one.

See Also

PositionIncrementAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


GetPositionIncrement Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttribute..::..GetPositionIncrement Method
PositionIncrementAttribute Interface See Also Send Feedback
Returns the position increment of this Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetPositionIncrement()
Visual Basic
Function GetPositionIncrement As Integer
Visual C++
int GetPositionIncrement()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttribute.GetPositionIncrement"]

See Also

PositionIncrementAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace
[!:setPositionIncrement]


SetPositionIncrement Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttribute..::..SetPositionIncrement Method
PositionIncrementAttribute Interface See Also Send Feedback
Set the position increment. The default value is one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetPositionIncrement(
    int positionIncrement
)
Visual Basic
Sub SetPositionIncrement ( _
    positionIncrement As Integer _
)
Visual C++
void SetPositionIncrement(
    int positionIncrement
)

Parameters

positionIncrement
Type: System..::..Int32
the distance from the prior term

See Also

PositionIncrementAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


PositionIncrementAttributeImpl Class

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl Class
Members See Also Send Feedback
The positionIncrement determines the position of this token relative to the previous Token in a {@link TokenStream}, used in phrase searching.

The default value is one.

Some common uses for this are:

  • Set it to zero to put multiple terms in the same position. This is useful if, e.g., a word has multiple stems. Searches for phrases including either stem will match. In this case, all but the first stem's increment should be set to zero: the increment of the first instance should be one. Repeating a token with an increment of zero can also be used to boost the scores of matches on that token.
  • Set it to values greater than one to inhibit exact phrase matches. If, for example, one does not want phrases to match across removed stop words, then one could build a stop word filter that removes stop words and also sets the increment to the number of stop words removed before each non-stop word. Then exact phrase queries will only match when the terms occur with no intervening stop words.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PositionIncrementAttributeImpl : AttributeImpl,
    PositionIncrementAttribute, Attribute, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class PositionIncrementAttributeImpl _
    Inherits AttributeImpl _
    Implements PositionIncrementAttribute, Attribute, ICloneable
Visual C++
[SerializableAttribute]
public ref class PositionIncrementAttributeImpl : public AttributeImpl,
    PositionIncrementAttribute, Attribute, ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..PositionIncrementAttributeImpl

See Also

PositionIncrementAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


PositionIncrementAttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl Members
PositionIncrementAttributeImpl Class Constructors Methods See Also Send Feedback

The PositionIncrementAttributeImpl type exposes the following members.

Constructors

 | Name | Description
Public method | PositionIncrementAttributeImpl | Initializes a new instance of the PositionIncrementAttributeImpl class

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetPositionIncrement
Returns the position increment of this Token.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetPositionIncrement
Set the position increment. The default value is one.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


PositionIncrementAttributeImpl Constructor

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl Constructor
PositionIncrementAttributeImpl Class See Also Send Feedback
Initializes a new instance of the PositionIncrementAttributeImpl class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PositionIncrementAttributeImpl()
Visual Basic
Public Sub New
Visual C++
public:
PositionIncrementAttributeImpl()

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


PositionIncrementAttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl Methods
PositionIncrementAttributeImpl Class See Also Send Feedback

The PositionIncrementAttributeImpl type exposes the following members.

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetPositionIncrement
Returns the position increment of this Token.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetPositionIncrement
Set the position increment. The default value is one.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clear Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..Clear Method
PositionIncrementAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.Clear"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clone Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..Clone Method
PositionIncrementAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.Clone"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..CopyTo Method
PositionIncrementAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..Equals Method
PositionIncrementAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.Equals(System.Object)"]

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..GetHashCode Method
PositionIncrementAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.GetHashCode"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.GetHashCode"]

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetPositionIncrement Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..GetPositionIncrement Method
PositionIncrementAttributeImpl Class See Also Send Feedback
Returns the position increment of this Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPositionIncrement()
Visual Basic
Public Overridable Function GetPositionIncrement As Integer
Visual C++
public:
virtual int GetPositionIncrement()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.PositionIncrementAttributeImpl.GetPositionIncrement"]

Implements

PositionIncrementAttribute..::..GetPositionIncrement()()()()

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace
[!:setPositionIncrement]


SetPositionIncrement Method

[image]

Lucene.Net Class Libraries
PositionIncrementAttributeImpl..::..SetPositionIncrement Method
PositionIncrementAttributeImpl Class See Also Send Feedback
Set the position increment. The default value is one.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetPositionIncrement(
    int positionIncrement
)
Visual Basic
Public Overridable Sub SetPositionIncrement ( _
    positionIncrement As Integer _
)
Visual C++
public:
virtual void SetPositionIncrement(
    int positionIncrement
)

Parameters

positionIncrement
Type: System..::..Int32
the distance from the prior term

Implements

PositionIncrementAttribute..::..SetPositionIncrement(Int32)

See Also

PositionIncrementAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttribute Interface

[image]

Lucene.Net Class Libraries
TermAttribute Interface
Members See Also Send Feedback
The term text of a Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface TermAttribute : Attribute
Visual Basic
Public Interface TermAttribute _
    Inherits Attribute
Visual C++
public interface class TermAttribute : Attribute

See Also

TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttribute Members

[image] [image]

Lucene.Net Class Libraries
TermAttribute Members
TermAttribute Interface Methods See Also Send Feedback

The TermAttribute type exposes the following members.

Methods

 | Name | Description
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.
Public method | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttribute Methods

[image] [image]

Lucene.Net Class Libraries
TermAttribute Methods
TermAttribute Interface See Also Send Feedback

The TermAttribute type exposes the following members.

Methods

 | Name | Description
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.
Public method | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


ResizeTermBuffer Method

[image]

Lucene.Net Class Libraries
TermAttribute..::..ResizeTermBuffer Method
TermAttribute Interface See Also Send Feedback
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
char[] ResizeTermBuffer(
    int newSize
)
Visual Basic
Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Visual C++
array<wchar_t>^ ResizeTermBuffer(
    int newSize
)

Parameters

newSize
Type: System..::..Int32
minimum size of the new termBuffer

Return Value

newly created termBuffer with length >= newSize

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method

[image] [image]

Lucene.Net Class Libraries
TermAttribute..::..SetTermBuffer Method
TermAttribute Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

See Also

TermAttribute Interface
TermAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method (String)

[image]

Lucene.Net Class Libraries
TermAttribute..::..SetTermBuffer Method (String)
TermAttribute Interface See Also Send Feedback
Copies the contents of buffer into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetTermBuffer(
    string buffer
)
Visual Basic
Sub SetTermBuffer ( _
    buffer As String _
)
Visual C++
void SetTermBuffer(
    String^ buffer
)

Parameters

buffer
Type: System..::..String
the buffer to copy

See Also

TermAttribute Interface
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
TermAttribute..::..SetTermBuffer Method (array<Char>[]()[][], Int32, Int32)
TermAttribute Interface See Also Send Feedback
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Visual Basic
Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: array< System..::..Char >[]()[][]
the buffer to copy
offset
Type: System..::..Int32
the index in the buffer of the first character to copy
length
Type: System..::..Int32
the number of characters to copy

See Also

TermAttribute Interface
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
TermAttribute..::..SetTermBuffer Method (String, Int32, Int32)
TermAttribute Interface See Also Send Feedback
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Visual Basic
Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Visual C++
void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: System..::..String
the buffer to copy
offset
Type: System..::..Int32
the index in the buffer of the first character to copy
length
Type: System..::..Int32
the number of characters to copy

See Also

TermAttribute Interface
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermLength Method

[image]

Lucene.Net Class Libraries
TermAttribute..::..SetTermLength Method
TermAttribute Interface See Also Send Feedback
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetTermLength(
    int length
)
Visual Basic
Sub SetTermLength ( _
    length As Integer _
)
Visual C++
void SetTermLength(
    int length
)

Parameters

length
Type: System..::..Int32
the truncated length

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


Term Method

[image]

Lucene.Net Class Libraries
TermAttribute..::..Term Method
TermAttribute Interface See Also Send Feedback
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string Term()
Visual Basic
Function Term As String
Visual C++
String^ Term()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttribute.Term"]

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


TermBuffer Method

[image]

Lucene.Net Class Libraries
TermAttribute..::..TermBuffer Method
TermAttribute Interface See Also Send Feedback
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
char[] TermBuffer()
Visual Basic
Function TermBuffer As Char()
Visual C++
array<wchar_t>^ TermBuffer()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttribute.TermBuffer"]

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


TermLength Method

[image]

Lucene.Net Class Libraries
TermAttribute..::..TermLength Method
TermAttribute Interface See Also Send Feedback
Return number of valid characters (length of the term) in the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int TermLength()
Visual Basic
Function TermLength As Integer
Visual C++
int TermLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttribute.TermLength"]

See Also

TermAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttributeImpl Class

[image]

Lucene.Net Class Libraries
TermAttributeImpl Class
Members See Also Send Feedback
The term text of a Token.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TermAttributeImpl : AttributeImpl,
    TermAttribute, Attribute, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class TermAttributeImpl _
    Inherits AttributeImpl _
    Implements TermAttribute, Attribute, ICloneable
Visual C++
[SerializableAttribute]
public ref class TermAttributeImpl : public AttributeImpl,
    TermAttribute, Attribute, ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..TermAttributeImpl

See Also

TermAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
TermAttributeImpl Members
TermAttributeImpl Class Constructors Methods See Also Send Feedback

The TermAttributeImpl type exposes the following members.

Constructors

 | Name | Description
Public method | TermAttributeImpl | Initializes a new instance of the TermAttributeImpl class

Methods

 | Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.
Public method | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Public method | ToString | (Overrides AttributeImpl..::..ToString()()()().)

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttributeImpl Constructor

[image]

Lucene.Net Class Libraries
TermAttributeImpl Constructor
TermAttributeImpl Class See Also Send Feedback
Initializes a new instance of the TermAttributeImpl class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermAttributeImpl()
Visual Basic
Public Sub New
Visual C++
public:
TermAttributeImpl()

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TermAttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
TermAttributeImpl Methods
TermAttributeImpl Class See Also Send Feedback

The TermAttributeImpl type exposes the following members.

Methods

 | Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeTermBuffer | Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.
Public method | SetTermLength | Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.
Public method | Term | Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())
Public method | TermBuffer | Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.
Public method | TermLength | Return number of valid characters (length of the term) in the termBuffer array.
Public method | ToString | (Overrides AttributeImpl..::..ToString()()()().)

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clear Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..Clear Method
TermAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Clear"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clone Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..Clone Method
TermAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Clone"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..CopyTo Method
TermAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..Equals Method
TermAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Equals(System.Object)"]

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..GetHashCode Method
TermAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.GetHashCode"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.GetHashCode"]

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


ResizeTermBuffer Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..ResizeTermBuffer Method
TermAttributeImpl Class See Also Send Feedback
Grows the termBuffer to at least size newSize, preserving the existing content. Note: If the next operation is to change the contents of the term buffer use {@link #SetTermBuffer(char[], int, int)}, {@link #SetTermBuffer(String)}, or {@link #SetTermBuffer(String, int, int)} to optimally combine the resize with the setting of the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual char[] ResizeTermBuffer(
    int newSize
)
Visual Basic
Public Overridable Function ResizeTermBuffer ( _
    newSize As Integer _
) As Char()
Visual C++
public:
virtual array<wchar_t>^ ResizeTermBuffer(
    int newSize
)

Parameters

newSize
Type: System..::..Int32
minimum size of the new termBuffer

Return Value

newly created termBuffer with length >= newSize

Implements

TermAttribute..::..ResizeTermBuffer(Int32)

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method

[image] [image]

Lucene.Net Class Libraries
TermAttributeImpl..::..SetTermBuffer Method
TermAttributeImpl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetTermBuffer(String) | Copies the contents of buffer into the termBuffer array.
Public method | SetTermBuffer(array<Char>[]()[][], Int32, Int32) | Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.
Public method | SetTermBuffer(String, Int32, Int32) | Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

See Also

TermAttributeImpl Class
TermAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method (String)

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..SetTermBuffer Method (String)
TermAttributeImpl Class See Also Send Feedback
Copies the contents of buffer into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetTermBuffer(
    string buffer
)
Visual Basic
Public Overridable Sub SetTermBuffer ( _
    buffer As String _
)
Visual C++
public:
virtual void SetTermBuffer(
    String^ buffer
)

Parameters

buffer
Type: System..::..String
the buffer to copy

Implements

TermAttribute..::..SetTermBuffer(String)

See Also

TermAttributeImpl Class
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..SetTermBuffer Method (array<Char>[]()[][], Int32, Int32)
TermAttributeImpl Class See Also Send Feedback
Copies the contents of buffer, starting at offset for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetTermBuffer(
    char[] buffer,
    int offset,
    int length
)
Visual Basic
Public Overridable Sub SetTermBuffer ( _
    buffer As Char(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetTermBuffer(
    array<wchar_t>^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: array< System..::..Char >[]()[][]
the buffer to copy
offset
Type: System..::..Int32
the index in the buffer of the first character to copy
length
Type: System..::..Int32
the number of characters to copy

Implements

TermAttribute..::..SetTermBuffer(array<Char>[]()[][], Int32, Int32)

See Also

TermAttributeImpl Class
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermBuffer Method (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..SetTermBuffer Method (String, Int32, Int32)
TermAttributeImpl Class See Also Send Feedback
Copies the contents of buffer, starting at offset and continuing for length characters, into the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetTermBuffer(
    string buffer,
    int offset,
    int length
)
Visual Basic
Public Overridable Sub SetTermBuffer ( _
    buffer As String, _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetTermBuffer(
    String^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: System..::..String
the buffer to copy
offset
Type: System..::..Int32
the index in the buffer of the first character to copy
length
Type: System..::..Int32
the number of characters to copy

Implements

TermAttribute..::..SetTermBuffer(String, Int32, Int32)

See Also

TermAttributeImpl Class
SetTermBuffer Overload
Lucene.Net.Analysis.Tokenattributes Namespace


SetTermLength Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..SetTermLength Method
TermAttributeImpl Class See Also Send Feedback
Set number of valid characters (length of the term) in the termBuffer array. Use this to truncate the termBuffer or to synchronize with external manipulation of the termBuffer. Note: to grow the size of the array, use {@link #ResizeTermBuffer(int)} first.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetTermLength(
    int length
)
Visual Basic
Public Overridable Sub SetTermLength ( _
    length As Integer _
)
Visual C++
public:
virtual void SetTermLength(
    int length
)

Parameters

length
Type: System..::..Int32
the truncated length

Implements

TermAttribute..::..SetTermLength(Int32)

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Term Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..Term Method
TermAttributeImpl Class See Also Send Feedback
Returns the Token's term text. This method has a performance penalty because the text is stored internally in a char[]. If possible, use {@link #TermBuffer()} and {@link #TermLength()} directly instead. If you really need a String, use this method, which is nothing more than a convenience call to new String(token.termBuffer(), 0, token.termLength())

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Term()
Visual Basic
Public Overridable Function Term As String
Visual C++
public:
virtual String^ Term()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.Term"]

Implements

TermAttribute..::..Term()()()()

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TermBuffer Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..TermBuffer Method
TermAttributeImpl Class See Also Send Feedback
Returns the internal termBuffer character array which you can then directly alter. If the array is too small for your token, use {@link #ResizeTermBuffer(int)} to increase it. After altering the buffer be sure to call {@link #setTermLength} to record the number of valid characters that were placed into the termBuffer.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual char[] TermBuffer()
Visual Basic
Public Overridable Function TermBuffer As Char()
Visual C++
public:
virtual array<wchar_t>^ TermBuffer()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.TermBuffer"]

Implements

TermAttribute..::..TermBuffer()()()()

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TermLength Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..TermLength Method
TermAttributeImpl Class See Also Send Feedback
Return number of valid characters (length of the term) in the termBuffer array.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int TermLength()
Visual Basic
Public Overridable Function TermLength As Integer
Visual C++
public:
virtual int TermLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.TermLength"]

Implements

TermAttribute..::..TermLength()()()()

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TermAttributeImpl..::..ToString Method
TermAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.ToString"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TermAttributeImpl.ToString"]

See Also

TermAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttribute Interface

[image]

Lucene.Net Class Libraries
TypeAttribute Interface
Members See Also Send Feedback
A Token's lexical type. The Default value is "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface TypeAttribute : Attribute
Visual Basic
Public Interface TypeAttribute _
    Inherits Attribute
Visual C++
public interface class TypeAttribute : Attribute

See Also

TypeAttribute Members
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttribute Members

[image] [image]

Lucene.Net Class Libraries
TypeAttribute Members
TypeAttribute Interface Methods See Also Send Feedback

The TypeAttribute type exposes the following members.

Methods

 | Name | Description
Public method | SetType | Set the lexical type.
Public method | Type | Returns this Token's lexical type. Defaults to "word".

See Also

TypeAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttribute Methods

[image] [image]

Lucene.Net Class Libraries
TypeAttribute Methods
TypeAttribute Interface See Also Send Feedback

The TypeAttribute type exposes the following members.

Methods

 | Name | Description
Public method | SetType | Set the lexical type.
Public method | Type | Returns this Token's lexical type. Defaults to "word".

See Also

TypeAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


SetType Method

[image]

Lucene.Net Class Libraries
TypeAttribute..::..SetType Method
TypeAttribute Interface See Also Send Feedback
Set the lexical type.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetType(
    string type
)
Visual Basic
Sub SetType ( _
    type As String _
)
Visual C++
void SetType(
    String^ type
)

Parameters

type
Type: System..::..String

[Missing <param name="type"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttribute.SetType(System.String)"]

See Also

TypeAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace
TypeAttribute..::..Type()()()()


Type Method

[image]

Lucene.Net Class Libraries
TypeAttribute..::..Type Method
TypeAttribute Interface See Also Send Feedback
Returns this Token's lexical type. Defaults to "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string Type()
Visual Basic
Function Type As String
Visual C++
String^ Type()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttribute.Type"]

See Also

TypeAttribute Interface
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Class

[image]

Lucene.Net Class Libraries
TypeAttributeImpl Class
Members See Also Send Feedback
A Token's lexical type. The Default value is "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TypeAttributeImpl : AttributeImpl,
    TypeAttribute, Attribute, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class TypeAttributeImpl _
    Inherits AttributeImpl _
    Implements TypeAttribute, Attribute, ICloneable
Visual C++
[SerializableAttribute]
public ref class TypeAttributeImpl : public AttributeImpl,
    TypeAttribute, Attribute, ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..TypeAttributeImpl

See Also

TypeAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
TypeAttributeImpl Members
TypeAttributeImpl Class Constructors Methods Fields See Also Send Feedback

The TypeAttributeImpl type exposes the following members.

Constructors

 | Name | Description
Public method | TypeAttributeImpl()()()() | Initializes a new instance of the TypeAttributeImpl class
Public method | TypeAttributeImpl(String) | Initializes a new instance of the TypeAttributeImpl class

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetType
Set the lexical type.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)
Public method Type
Returns this Token's lexical type. Defaults to "word".

Fields

Name | Description
DEFAULT_TYPE |

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Constructor

[image] [image]

Lucene.Net Class Libraries
TypeAttributeImpl Constructor
TypeAttributeImpl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeAttributeImpl()()()() | Initializes a new instance of the TypeAttributeImpl class
Public method | TypeAttributeImpl(String) | Initializes a new instance of the TypeAttributeImpl class

See Also

TypeAttributeImpl Class
TypeAttributeImpl Members
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Constructor

[image]

Lucene.Net Class Libraries
TypeAttributeImpl Constructor
TypeAttributeImpl Class See Also Send Feedback
Initializes a new instance of the TypeAttributeImpl class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TypeAttributeImpl()
Visual Basic
Public Sub New
Visual C++
public:
TypeAttributeImpl()

See Also

TypeAttributeImpl Class
TypeAttributeImpl Overload
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Constructor (String)

[image]

Lucene.Net Class Libraries
TypeAttributeImpl Constructor (String)
TypeAttributeImpl Class See Also Send Feedback
Initializes a new instance of the TypeAttributeImpl class

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TypeAttributeImpl(
    string type
)
Visual Basic
Public Sub New ( _
    type As String _
)
Visual C++
public:
TypeAttributeImpl(
    String^ type
)

Parameters

type
Type: System..::..String

[Missing <param name="type"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.#ctor(System.String)"]

See Also

TypeAttributeImpl Class
TypeAttributeImpl Overload
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Fields

[image] [image]

Lucene.Net Class Libraries
TypeAttributeImpl Fields
TypeAttributeImpl Class See Also Send Feedback

The TypeAttributeImpl type exposes the following members.

Fields

Name | Description
DEFAULT_TYPE |

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


DEFAULT_TYPE Field

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..DEFAULT_TYPE Field
TypeAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.DEFAULT_TYPE"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string DEFAULT_TYPE
Visual Basic
Public Const DEFAULT_TYPE As String
Visual C++
public:
literal String^ DEFAULT_TYPE

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


TypeAttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
TypeAttributeImpl Methods
TypeAttributeImpl Class See Also Send Feedback

The TypeAttributeImpl type exposes the following members.

Methods

Name | Description
Public method | Clear | (Overrides AttributeImpl..::..Clear()()()().)
Public method | Clone | (Overrides AttributeImpl..::..Clone()()()().)
Public method | CopyTo | (Overrides AttributeImpl..::..CopyTo(AttributeImpl).)
Public method | Equals | (Overrides AttributeImpl..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetHashCode | (Overrides AttributeImpl..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetType
Set the lexical type.
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Inherited from AttributeImpl.)
Public method Type
Returns this Token's lexical type. Defaults to "word".

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clear Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..Clear Method
TypeAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Clear"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Clone Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..Clone Method
TypeAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Clone"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..CopyTo Method
TypeAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void CopyTo(
    AttributeImpl target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) override

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..Equals Method
TypeAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Equals(System.Object)"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Equals(System.Object)"]

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..GetHashCode Method
TypeAttributeImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.GetHashCode"]

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.GetHashCode"]

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


SetType Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..SetType Method
TypeAttributeImpl Class See Also Send Feedback
Set the lexical type.

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetType(
    string type
)
Visual Basic
Public Overridable Sub SetType ( _
    type As String _
)
Visual C++
public:
virtual void SetType(
    String^ type
)

Parameters

type
Type: System..::..String

[Missing <param name="type"/> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.SetType(System.String)"]

Implements

TypeAttribute..::..SetType(String)

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace
TypeAttributeImpl..::..Type()()()()


Type Method

[image]

Lucene.Net Class Libraries
TypeAttributeImpl..::..Type Method
TypeAttributeImpl Class See Also Send Feedback
Returns this Token's lexical type. Defaults to "word".

Namespace: Lucene.Net.Analysis.Tokenattributes
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Type()
Visual Basic
Public Overridable Function Type As String
Visual C++
public:
virtual String^ Type()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analysis.Tokenattributes.TypeAttributeImpl.Type"]

Implements

TypeAttribute..::..Type()()()()

See Also

TypeAttributeImpl Class
Lucene.Net.Analysis.Tokenattributes Namespace


Lucene.Net.Analyzers.Miscellaneous Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analyzers.Miscellaneous Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analyzers.Miscellaneous"]

Classes

 | Class | Description
Public class | EmptyTokenStream |
Public class | InjectablePrefixAwareTokenFilter |
Public class | PrefixAndSuffixAwareTokenFilter | Links two PrefixAwareTokenFilter. NOTE: This filter might not behave correctly if used with custom Attributes, i.e. Attributes other than the ones located in Lucene.Net.Analysis.Tokenattributes.
Public class | PrefixAwareTokenFilter | Joins two token streams and leaves the last token of the first stream available to be used when updating the token values in the second stream based on that token. The default implementation adds last prefix token end offset to the suffix token start and end offsets. NOTE: This filter might not behave correctly if used with custom Attributes, i.e. Attributes other than the ones located in Lucene.Net.Analysis.TokenAttributes.
Public class | SingleTokenTokenStream | A TokenStream containing a single token.


EmptyTokenStream Class

[image]

Lucene.Net Class Libraries
EmptyTokenStream Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analyzers.Miscellaneous.EmptyTokenStream"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class EmptyTokenStream : TokenStream
Visual Basic
Public Class EmptyTokenStream _
    Inherits TokenStream
Visual C++
public ref class EmptyTokenStream : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analyzers.Miscellaneous..::..EmptyTokenStream

See Also

EmptyTokenStream Members
Lucene.Net.Analyzers.Miscellaneous Namespace


EmptyTokenStream Members

[image] [image]

Lucene.Net Class Libraries
EmptyTokenStream Members
EmptyTokenStream Class Constructors Methods See Also Send Feedback

The EmptyTokenStream type exposes the following members.

Constructors

 | Name | Description
Public method | EmptyTokenStream | Initializes a new instance of the EmptyTokenStream class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

EmptyTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


EmptyTokenStream Constructor

[image]

Lucene.Net Class Libraries
EmptyTokenStream Constructor
EmptyTokenStream Class See Also Send Feedback
Initializes a new instance of the EmptyTokenStream class

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public EmptyTokenStream()
Visual Basic
Public Sub New
Visual C++
public:
EmptyTokenStream()

See Also

EmptyTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


EmptyTokenStream Methods

[image] [image]

Lucene.Net Class Libraries
EmptyTokenStream Methods
EmptyTokenStream Class See Also Send Feedback

The EmptyTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Returns the next {@link Token} in the stream, or null at EOS.
(Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

EmptyTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
EmptyTokenStream..::..Next Method
EmptyTokenStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. Returns the next {@link Token} in the stream, or null at EOS. (Inherited from TokenStream.)
Public method | Next(Token) | Obsolete. (Overrides TokenStream..::..Next(Token).)

See Also

EmptyTokenStream Class
EmptyTokenStream Members
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
EmptyTokenStream..::..Next Method (Token)
EmptyTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.EmptyTokenStream.Next(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public override Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overrides Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.EmptyTokenStream.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.EmptyTokenStream.Next(Lucene.Net.Analysis.Token)"]

See Also

EmptyTokenStream Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


InjectablePrefixAwareTokenFilter Class

[image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class InjectablePrefixAwareTokenFilter : PrefixAwareTokenFilter
Visual Basic
Public Class InjectablePrefixAwareTokenFilter _
    Inherits PrefixAwareTokenFilter
Visual C++
public ref class InjectablePrefixAwareTokenFilter : public PrefixAwareTokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analyzers.Miscellaneous..::..PrefixAwareTokenFilter
Lucene.Net.Analyzers.Miscellaneous..::..InjectablePrefixAwareTokenFilter

See Also

InjectablePrefixAwareTokenFilter Members
Lucene.Net.Analyzers.Miscellaneous Namespace


InjectablePrefixAwareTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter Members
InjectablePrefixAwareTokenFilter Class Constructors Methods Properties See Also Send Feedback

The InjectablePrefixAwareTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | InjectablePrefixAwareTokenFilter | Initializes a new instance of the InjectablePrefixAwareTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Inherited from PrefixAwareTokenFilter.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from PrefixAwareTokenFilter.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Inherited from PrefixAwareTokenFilter.)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Inherited from PrefixAwareTokenFilter.)
Public method | Reset | (Inherited from PrefixAwareTokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method | UpdateSuffixToken | (Overrides PrefixAwareTokenFilter..::..UpdateSuffixToken(Token, Token).)

Properties

 | Name | Description
Public property | Prefix | (Inherited from PrefixAwareTokenFilter.)
Public property | Suffix | (Inherited from PrefixAwareTokenFilter.)
Public property | UpdateAction |

See Also

InjectablePrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


InjectablePrefixAwareTokenFilter Constructor

[image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter Constructor
InjectablePrefixAwareTokenFilter Class See Also Send Feedback
Initializes a new instance of the InjectablePrefixAwareTokenFilter class

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public InjectablePrefixAwareTokenFilter(
    TokenStream prefix,
    TokenStream suffix
)
Visual Basic
Public Sub New ( _
    prefix As TokenStream, _
    suffix As TokenStream _
)
Visual C++
public:
InjectablePrefixAwareTokenFilter(
    TokenStream^ prefix,
    TokenStream^ suffix
)

Parameters

prefix
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="prefix"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

suffix
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="suffix"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

See Also

InjectablePrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


InjectablePrefixAwareTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter Methods
InjectablePrefixAwareTokenFilter Class See Also Send Feedback

The InjectablePrefixAwareTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Inherited from PrefixAwareTokenFilter.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Inherited from PrefixAwareTokenFilter.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Inherited from PrefixAwareTokenFilter.)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Inherited from PrefixAwareTokenFilter.)
Public method | Reset | (Inherited from PrefixAwareTokenFilter.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method | UpdateSuffixToken | (Overrides PrefixAwareTokenFilter..::..UpdateSuffixToken(Token, Token).)

See Also

InjectablePrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter..::..Next Method
InjectablePrefixAwareTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Inherited from PrefixAwareTokenFilter.)
Public method | Next(Token) | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Inherited from PrefixAwareTokenFilter.)

See Also

InjectablePrefixAwareTokenFilter Class
InjectablePrefixAwareTokenFilter Members
Lucene.Net.Analyzers.Miscellaneous Namespace


UpdateSuffixToken Method

[image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter..::..UpdateSuffixToken Method
InjectablePrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override Token UpdateSuffixToken(
    Token suffixToken,
    Token lastPrefixToken
)
Visual Basic
Public Overrides Function UpdateSuffixToken ( _
    suffixToken As Token, _
    lastPrefixToken As Token _
) As Token
Visual C++
public:
virtual Token^ UpdateSuffixToken(
    Token^ suffixToken,
    Token^ lastPrefixToken
) override

Parameters

suffixToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="suffixToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

lastPrefixToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="lastPrefixToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

See Also

InjectablePrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


InjectablePrefixAwareTokenFilter Properties

[image] [image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter Properties
InjectablePrefixAwareTokenFilter Class See Also Send Feedback

The InjectablePrefixAwareTokenFilter type exposes the following members.

Properties

 | Name | Description
Public property | Prefix | (Inherited from PrefixAwareTokenFilter.)
Public property | Suffix | (Inherited from PrefixAwareTokenFilter.)
Public property | UpdateAction |

See Also

InjectablePrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


UpdateAction Property

[image]

Lucene.Net Class Libraries
InjectablePrefixAwareTokenFilter..::..UpdateAction Property
InjectablePrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Miscellaneous.InjectablePrefixAwareTokenFilter.UpdateAction"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Func<Token, Token, Token> UpdateAction { get; set; }
Visual Basic
Public Property UpdateAction As Func(Of Token, Token, Token)
    Get
    Set
Visual C++
public:
property Func<Token^, Token^, Token^>^ UpdateAction {
    Func<Token^, Token^, Token^>^ get ();
    void set (Func<Token^, Token^, Token^>^ value);
}

See Also

InjectablePrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAndSuffixAwareTokenFilter Class

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter Class
Members See Also Send Feedback
Links two PrefixAwareTokenFilter.

NOTE: This filter might not behave correctly if used with custom Attributes, i.e. Attributes other than the ones located in Lucene.Net.Analysis.Tokenattributes.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class PrefixAndSuffixAwareTokenFilter : TokenStream
Visual Basic
Public Class PrefixAndSuffixAwareTokenFilter _
    Inherits TokenStream
Visual C++
public ref class PrefixAndSuffixAwareTokenFilter : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analyzers.Miscellaneous..::..PrefixAndSuffixAwareTokenFilter

See Also

PrefixAndSuffixAwareTokenFilter Members
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAndSuffixAwareTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter Members
PrefixAndSuffixAwareTokenFilter Class Constructors Methods See Also Send Feedback

The PrefixAndSuffixAwareTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PrefixAndSuffixAwareTokenFilter | Initializes a new instance of the PrefixAndSuffixAwareTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Overrides TokenStream..::..Close()()()().)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method | UpdateInputToken
Public method | UpdateSuffixToken

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAndSuffixAwareTokenFilter Constructor

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter Constructor
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback
Initializes a new instance of the PrefixAndSuffixAwareTokenFilter class

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public PrefixAndSuffixAwareTokenFilter(
    TokenStream prefix,
    TokenStream input,
    TokenStream suffix
)
Visual Basic
Public Sub New ( _
    prefix As TokenStream, _
    input As TokenStream, _
    suffix As TokenStream _
)
Visual C++
public:
PrefixAndSuffixAwareTokenFilter(
    TokenStream^ prefix,
    TokenStream^ input,
    TokenStream^ suffix
)

Parameters

prefix
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="prefix"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

input
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="input"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

suffix
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="suffix"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAndSuffixAwareTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter Methods
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

The PrefixAndSuffixAwareTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Overrides TokenStream..::..Close()()()().)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method | UpdateInputToken
Public method | UpdateSuffixToken

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Close Method

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..Close Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.Close"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..IncrementToken Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.IncrementToken"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override sealed bool IncrementToken()
Visual Basic
Public Overrides NotOverridable Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.IncrementToken"]

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..Next Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next(Token).)

See Also

PrefixAndSuffixAwareTokenFilter Class
PrefixAndSuffixAwareTokenFilter Members
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..Next Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public override sealed Token Next()
Visual Basic
<ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")> _
Public Overrides NotOverridable Function Next As Token
Visual C++
[ObsoleteAttribute(L"The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public:
virtual Token^ Next() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.Next"]

See Also

PrefixAndSuffixAwareTokenFilter Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..Next Method (Token)
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public override sealed Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overrides NotOverridable Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override sealed

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

PrefixAndSuffixAwareTokenFilter Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


Reset Method

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..Reset Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.Reset"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


UpdateInputToken Method

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..UpdateInputToken Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateInputToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Token UpdateInputToken(
    Token inputToken,
    Token lastPrefixToken
)
Visual Basic
Public Function UpdateInputToken ( _
    inputToken As Token, _
    lastPrefixToken As Token _
) As Token
Visual C++
public:
Token^ UpdateInputToken(
    Token^ inputToken,
    Token^ lastPrefixToken
)

Parameters

inputToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="inputToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateInputToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

lastPrefixToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="lastPrefixToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateInputToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateInputToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


UpdateSuffixToken Method

[image]

Lucene.Net Class Libraries
PrefixAndSuffixAwareTokenFilter..::..UpdateSuffixToken Method
PrefixAndSuffixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Token UpdateSuffixToken(
    Token suffixToken,
    Token lastInputToken
)
Visual Basic
Public Function UpdateSuffixToken ( _
    suffixToken As Token, _
    lastInputToken As Token _
) As Token
Visual C++
public:
Token^ UpdateSuffixToken(
    Token^ suffixToken,
    Token^ lastInputToken
)

Parameters

suffixToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="suffixToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

lastInputToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="lastInputToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAndSuffixAwareTokenFilter.UpdateSuffixToken(Lucene.Net.Analysis.Token,Lucene.Net.Analysis.Token)"]

See Also

PrefixAndSuffixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAwareTokenFilter Class

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter Class
Members See Also Send Feedback
Joins two token streams and leaves the last token of the first stream available to be used when updating the token values in the second stream based on that token. The default implementation adds last prefix token end offset to the suffix token start and end offsets.

NOTE: This filter might not behave correctly if used with custom Attributes, i.e. Attributes other than the ones located in Lucene.Net.Analysis.TokenAttributes.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class PrefixAwareTokenFilter : TokenStream
Visual Basic
Public Class PrefixAwareTokenFilter _
    Inherits TokenStream
Visual C++
public ref class PrefixAwareTokenFilter : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analyzers.Miscellaneous..::..PrefixAwareTokenFilter
Lucene.Net.Analyzers.Miscellaneous..::..InjectablePrefixAwareTokenFilter

See Also

PrefixAwareTokenFilter Members
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAwareTokenFilter Members

[image] [image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter Members
PrefixAwareTokenFilter Class Constructors Methods Properties See Also Send Feedback

The PrefixAwareTokenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PrefixAwareTokenFilter | Initializes a new instance of the PrefixAwareTokenFilter class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Overrides TokenStream..::..Close()()()().)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method UpdateSuffixToken
The default implementation adds last prefix token end offset to the suffix token start and end offsets.

Properties

 | Name | Description
Public property | Prefix |
Public property | Suffix |

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAwareTokenFilter Constructor

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter Constructor
PrefixAwareTokenFilter Class See Also Send Feedback
Initializes a new instance of the PrefixAwareTokenFilter class

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public PrefixAwareTokenFilter(
    TokenStream prefix,
    TokenStream suffix
)
Visual Basic
Public Sub New ( _
    prefix As TokenStream, _
    suffix As TokenStream _
)
Visual C++
public:
PrefixAwareTokenFilter(
    TokenStream^ prefix,
    TokenStream^ suffix
)

Parameters

prefix
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="prefix"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

suffix
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="suffix"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.#ctor(Lucene.Net.Analysis.TokenStream,Lucene.Net.Analysis.TokenStream)"]

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAwareTokenFilter Methods

[image] [image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter Methods
PrefixAwareTokenFilter Class See Also Send Feedback

The PrefixAwareTokenFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method | Close | (Overrides TokenStream..::..Close()()()().)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method UpdateSuffixToken
The default implementation adds last prefix token end offset to the suffix token start and end offsets.

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Close Method

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Close Method
PrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Close"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..IncrementToken Method
PrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.IncrementToken"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override sealed bool IncrementToken()
Visual Basic
Public Overrides NotOverridable Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.IncrementToken"]

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Next Method
PrefixAwareTokenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next(Token).)

See Also

PrefixAwareTokenFilter Class
PrefixAwareTokenFilter Members
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Next Method
PrefixAwareTokenFilter Class See Also Send Feedback
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public override sealed Token Next()
Visual Basic
<ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")> _
Public Overrides NotOverridable Function Next As Token
Visual C++
[ObsoleteAttribute(L"The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public:
virtual Token^ Next() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Next"]

See Also

PrefixAwareTokenFilter Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Next Method (Token)
PrefixAwareTokenFilter Class See Also Send Feedback
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public override sealed Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overrides NotOverridable Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override sealed

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

PrefixAwareTokenFilter Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


Reset Method

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Reset Method
PrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Reset"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


UpdateSuffixToken Method

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..UpdateSuffixToken Method
PrefixAwareTokenFilter Class See Also Send Feedback
The default implementation adds last prefix token end offset to the suffix token start and end offsets.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public virtual Token UpdateSuffixToken(
    Token suffixToken,
    Token lastPrefixToken
)
Visual Basic
Public Overridable Function UpdateSuffixToken ( _
    suffixToken As Token, _
    lastPrefixToken As Token _
) As Token
Visual C++
public:
virtual Token^ UpdateSuffixToken(
    Token^ suffixToken,
    Token^ lastPrefixToken
)

Parameters

suffixToken
Type: Lucene.Net.Analysis..::..Token
a token from the suffix stream
lastPrefixToken
Type: Lucene.Net.Analysis..::..Token
the last token from the prefix stream

Return Value

consumer token

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


PrefixAwareTokenFilter Properties

[image] [image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter Properties
PrefixAwareTokenFilter Class See Also Send Feedback

The PrefixAwareTokenFilter type exposes the following members.

Properties

 | Name | Description
Public property | Prefix |
Public property | Suffix |

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Prefix Property

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Prefix Property
PrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Prefix"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public TokenStream Prefix { get; set; }
Visual Basic
Public Property Prefix As TokenStream
    Get
    Set
Visual C++
public:
property TokenStream^ Prefix {
    TokenStream^ get ();
    void set (TokenStream^ value);
}

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Suffix Property

[image]

Lucene.Net Class Libraries
PrefixAwareTokenFilter..::..Suffix Property
PrefixAwareTokenFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Miscellaneous.PrefixAwareTokenFilter.Suffix"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public TokenStream Suffix { get; set; }
Visual Basic
Public Property Suffix As TokenStream
    Get
    Set
Visual C++
public:
property TokenStream^ Suffix {
    TokenStream^ get ();
    void set (TokenStream^ value);
}

See Also

PrefixAwareTokenFilter Class
Lucene.Net.Analyzers.Miscellaneous Namespace


SingleTokenTokenStream Class

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream Class
Members See Also Send Feedback
A TokenStream containing a single token.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class SingleTokenTokenStream : TokenStream
Visual Basic
Public Class SingleTokenTokenStream _
    Inherits TokenStream
Visual C++
public ref class SingleTokenTokenStream : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analyzers.Miscellaneous..::..SingleTokenTokenStream

See Also

SingleTokenTokenStream Members
Lucene.Net.Analyzers.Miscellaneous Namespace


SingleTokenTokenStream Members

[image] [image]

Lucene.Net Class Libraries
SingleTokenTokenStream Members
SingleTokenTokenStream Class Constructors Methods See Also Send Feedback

The SingleTokenTokenStream type exposes the following members.

Constructors

 | Name | Description
Public method | SingleTokenTokenStream | Initializes a new instance of the SingleTokenTokenStream class

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | GetToken
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | SetToken
Public method | ToString | (Inherited from AttributeSource.)

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


SingleTokenTokenStream Constructor

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream Constructor
SingleTokenTokenStream Class See Also Send Feedback
Initializes a new instance of the SingleTokenTokenStream class

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public SingleTokenTokenStream(
    Token token
)
Visual Basic
Public Sub New ( _
    token As Token _
)
Visual C++
public:
SingleTokenTokenStream(
    Token^ token
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.#ctor(Lucene.Net.Analysis.Token)"]

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


SingleTokenTokenStream Methods

[image] [image]

Lucene.Net Class Libraries
SingleTokenTokenStream Methods
SingleTokenTokenStream Class See Also Send Feedback

The SingleTokenTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method | GetToken
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | SetToken
Public method | ToString | (Inherited from AttributeSource.)

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


GetToken Method

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..GetToken Method
SingleTokenTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.GetToken"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Token GetToken()
Visual Basic
Public Function GetToken As Token
Visual C++
public:
Token^ GetToken()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.GetToken"]

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..IncrementToken Method
SingleTokenTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.IncrementToken"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override sealed bool IncrementToken()
Visual Basic
Public Overrides NotOverridable Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.IncrementToken"]

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..Next Method
SingleTokenTokenStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. @deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next(Token).)

See Also

SingleTokenTokenStream Class
SingleTokenTokenStream Members
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..Next Method
SingleTokenTokenStream Class See Also Send Feedback
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public override sealed Token Next()
Visual Basic
<ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")> _
Public Overrides NotOverridable Function Next As Token
Visual C++
[ObsoleteAttribute(L"The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public:
virtual Token^ Next() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.Next"]

See Also

SingleTokenTokenStream Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..Next Method (Token)
SingleTokenTokenStream Class See Also Send Feedback
@deprecated Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public override sealed Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overrides NotOverridable Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override sealed

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.Next(Lucene.Net.Analysis.Token)"]

See Also

SingleTokenTokenStream Class
Next Overload
Lucene.Net.Analyzers.Miscellaneous Namespace


Reset Method

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..Reset Method
SingleTokenTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.Reset"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


SetToken Method

[image]

Lucene.Net Class Libraries
SingleTokenTokenStream..::..SetToken Method
SingleTokenTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.SetToken(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Miscellaneous
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetToken(
    Token token
)
Visual Basic
Public Sub SetToken ( _
    token As Token _
)
Visual C++
public:
void SetToken(
    Token^ token
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Miscellaneous.SingleTokenTokenStream.SetToken(Lucene.Net.Analysis.Token)"]

See Also

SingleTokenTokenStream Class
Lucene.Net.Analyzers.Miscellaneous Namespace


Lucene.Net.Analyzers.Payloads Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analyzers.Payloads Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analyzers.Payloads"]

Classes

 | Class | Description
Public class | PayloadHelper | Utility methods for encoding payloads.


PayloadHelper Class

[image]

Lucene.Net Class Libraries
PayloadHelper Class
Members See Also Send Feedback
Utility methods for encoding payloads.

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static class PayloadHelper
Visual Basic
Public NotInheritable Class PayloadHelper
Visual C++
public ref class PayloadHelper abstract sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Payloads..::..PayloadHelper

See Also

PayloadHelper Members
Lucene.Net.Analyzers.Payloads Namespace


PayloadHelper Members

[image] [image]

Lucene.Net Class Libraries
PayloadHelper Members
PayloadHelper Class Methods See Also Send Feedback

The PayloadHelper type exposes the following members.

Methods

Name | Description
DecodeFloat(array<Byte>[]()[][]) | Decode the payload that was encoded using encodeFloat(float) NOTE: the length of the array must be at least offset + 4 long.
DecodeFloat(array<Byte>[]()[][], Int32) | Decode the payload that was encoded using encodeFloat(float) NOTE: the length of the array must be at least offset + 4 long.
DecodeInt |
EncodeFloat(Single) |
EncodeFloat(Single, array<Byte>[]()[][], Int32) |
EncodeInt(Int32) |
EncodeInt(Int32, array<Byte>[]()[][], Int32) |

See Also

PayloadHelper Class
Lucene.Net.Analyzers.Payloads Namespace


PayloadHelper Methods

[image] [image]

Lucene.Net Class Libraries
PayloadHelper Methods
PayloadHelper Class See Also Send Feedback

The PayloadHelper type exposes the following members.

Methods

Name | Description
DecodeFloat(array<Byte>[]()[][]) | Decode the payload that was encoded using encodeFloat(float) NOTE: the length of the array must be at least offset + 4 long.
DecodeFloat(array<Byte>[]()[][], Int32) | Decode the payload that was encoded using encodeFloat(float) NOTE: the length of the array must be at least offset + 4 long.
DecodeInt |
EncodeFloat(Single) |
EncodeFloat(Single, array<Byte>[]()[][], Int32) |
EncodeInt(Int32) |
EncodeInt(Int32, array<Byte>[]()[][], Int32) |

See Also

PayloadHelper Class
Lucene.Net.Analyzers.Payloads Namespace


DecodeFloat Method

[image] [image]

Lucene.Net Class Libraries
PayloadHelper..::..DecodeFloat Method
PayloadHelper Class See Also Send Feedback

Overload List

Name | Description
DecodeFloat(array<Byte>[]()[][]) | Decode the payload that was encoded using encodeFloat(float) NOTE: the length of the array must be at least offset + 4 long.
DecodeFloat(array<Byte>[]()[][], Int32) | Decode the payload that was encoded using encodeFloat(float) NOTE: the length of the array must be at least offset + 4 long.

See Also

PayloadHelper Class
PayloadHelper Members
Lucene.Net.Analyzers.Payloads Namespace


DecodeFloat Method (Byte[])

[image]

Lucene.Net Class Libraries
PayloadHelper..::..DecodeFloat Method (array<Byte>[]()[][])
PayloadHelper Class See Also Send Feedback

Decode the payload that was encoded using encodeFloat(float)

NOTE: the length of the array must be at least offset + 4 long.

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static float DecodeFloat(
    byte[] bytes
)
Visual Basic
Public Shared Function DecodeFloat ( _
    bytes As Byte() _
) As Single
Visual C++
public:
static float DecodeFloat(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]
The bytes to decode

Return Value

the decoded float

See Also

PayloadHelper Class
DecodeFloat Overload
Lucene.Net.Analyzers.Payloads Namespace


DecodeFloat Method (Byte[], Int32)

[image]

Lucene.Net Class Libraries
PayloadHelper..::..DecodeFloat Method (array<Byte>[]()[][], Int32)
PayloadHelper Class See Also Send Feedback

Decode the payload that was encoded using encodeFloat(float)

NOTE: the length of the array must be at least offset + 4 long.

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static float DecodeFloat(
    byte[] bytes,
    int offset
)
Visual Basic
Public Shared Function DecodeFloat ( _
    bytes As Byte(), _
    offset As Integer _
) As Single
Visual C++
public:
static float DecodeFloat(
    array<unsigned char>^ bytes,
    int offset
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]
The bytes to decode
offset
Type: System..::..Int32
The offset into the array.

Return Value

The float that was encoded

See Also

PayloadHelper Class
DecodeFloat Overload
Lucene.Net.Analyzers.Payloads Namespace


DecodeInt Method

[image]

Lucene.Net Class Libraries
PayloadHelper..::..DecodeInt Method
PayloadHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.DecodeInt(System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static int DecodeInt(
    byte[] bytes,
    int offset
)
Visual Basic
Public Shared Function DecodeInt ( _
    bytes As Byte(), _
    offset As Integer _
) As Integer
Visual C++
public:
static int DecodeInt(
    array<unsigned char>^ bytes,
    int offset
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.DecodeInt(System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.DecodeInt(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.DecodeInt(System.Byte[],System.Int32)"]

See Also

PayloadHelper Class
Lucene.Net.Analyzers.Payloads Namespace


EncodeFloat Method

[image] [image]

Lucene.Net Class Libraries
PayloadHelper..::..EncodeFloat Method
PayloadHelper Class See Also Send Feedback

Overload List

Name | Description
EncodeFloat(Single) |
EncodeFloat(Single, array<Byte>[]()[][], Int32) |

See Also

PayloadHelper Class
PayloadHelper Members
Lucene.Net.Analyzers.Payloads Namespace


EncodeFloat Method (Single)

[image]

Lucene.Net Class Libraries
PayloadHelper..::..EncodeFloat Method (Single)
PayloadHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single)"]

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static byte[] EncodeFloat(
    float payload
)
Visual Basic
Public Shared Function EncodeFloat ( _
    payload As Single _
) As Byte()
Visual C++
public:
static array<unsigned char>^ EncodeFloat(
    float payload
)

Parameters

payload
Type: System..::..Single

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single)"]

See Also

PayloadHelper Class
EncodeFloat Overload
Lucene.Net.Analyzers.Payloads Namespace


EncodeFloat Method (Single, Byte[], Int32)

[image]

Lucene.Net Class Libraries
PayloadHelper..::..EncodeFloat Method (Single, array<Byte>[]()[][], Int32)
PayloadHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single,System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static byte[] EncodeFloat(
    float payload,
    byte[] data,
    int offset
)
Visual Basic
Public Shared Function EncodeFloat ( _
    payload As Single, _
    data As Byte(), _
    offset As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ EncodeFloat(
    float payload,
    array<unsigned char>^ data,
    int offset
)

Parameters

payload
Type: System..::..Single

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single,System.Byte[],System.Int32)"]

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single,System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeFloat(System.Single,System.Byte[],System.Int32)"]

See Also

PayloadHelper Class
EncodeFloat Overload
Lucene.Net.Analyzers.Payloads Namespace


EncodeInt Method

[image] [image]

Lucene.Net Class Libraries
PayloadHelper..::..EncodeInt Method
PayloadHelper Class See Also Send Feedback

Overload List

Name | Description
EncodeInt(Int32) |
EncodeInt(Int32, array<Byte>[]()[][], Int32) |

See Also

PayloadHelper Class
PayloadHelper Members
Lucene.Net.Analyzers.Payloads Namespace


EncodeInt Method (Int32)

[image]

Lucene.Net Class Libraries
PayloadHelper..::..EncodeInt Method (Int32)
PayloadHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32)"]

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static byte[] EncodeInt(
    int payload
)
Visual Basic
Public Shared Function EncodeInt ( _
    payload As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ EncodeInt(
    int payload
)

Parameters

payload
Type: System..::..Int32

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32)"]

See Also

PayloadHelper Class
EncodeInt Overload
Lucene.Net.Analyzers.Payloads Namespace


EncodeInt Method (Int32, Byte[], Int32)

[image]

Lucene.Net Class Libraries
PayloadHelper..::..EncodeInt Method (Int32, array<Byte>[]()[][], Int32)
PayloadHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32,System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Analyzers.Payloads
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static byte[] EncodeInt(
    int payload,
    byte[] data,
    int offset
)
Visual Basic
Public Shared Function EncodeInt ( _
    payload As Integer, _
    data As Byte(), _
    offset As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ EncodeInt(
    int payload,
    array<unsigned char>^ data,
    int offset
)

Parameters

payload
Type: System..::..Int32

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32,System.Byte[],System.Int32)"]

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32,System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Payloads.PayloadHelper.EncodeInt(System.Int32,System.Byte[],System.Int32)"]

See Also

PayloadHelper Class
EncodeInt Overload
Lucene.Net.Analyzers.Payloads Namespace


Lucene.Net.Analyzers.Shingle Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analyzers.Shingle Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analyzers.Shingle"]

Classes

Class | Description
Public class ShingleAnalyzerWrapper
A ShingleAnalyzerWrapper wraps a ShingleFilter around another Analyzer.

A shingle is another name for a token based n-gram.

Public class ShingleFilter

A ShingleFilter constructs shingles (token n-grams) from a token stream. In other words, it creates combinations of tokens as a single token.

For example, the sentence "please divide this sentence into shingles" might be tokenized into shingles "please divide", "divide this", "this sentence", "sentence into", and "into shingles".

This filter handles position increments > 1 by inserting filler tokens (tokens with termtext "_"). It does not handle a position increment of 0.

Public class ShingleMatrixFilter

A ShingleMatrixFilter constructs shingles (token n-grams) from a token stream. In other words, it creates combinations of tokens as a single token.

For example, the sentence "please divide this sentence into shingles" might be tokenized into shingles "please divide", "divide this", "this sentence", "sentence into", and "into shingles".

Using a shingle filter at index and query time can in some instances be used to replace phrase queries, especially them with 0 slop.

Without a spacer character it can be used to handle composition and decomposition of words such as searching for "multi dimensional" instead of "multidimensional". It is a rather common human problem at query time in several languages, notably the northern Germanic branch.

Shingles are amongst many things also known to solve problems in spell checking, language detection and document clustering.

This filter is backed by a three dimensional column oriented matrix used to create permutations of the second dimension, the rows, and leaves the third, the z-axis, for for multi token synonyms.

In order to use this filter you need to define a way of positioning the input stream tokens in the matrix. This is done using a ShingleMatrixFilter.TokenSettingsCodec. There are three simple implementations for demonstrational purposes, see ShingleMatrixFilter.OneDimensionalNonWeightedTokenSettingsCodec, ShingleMatrixFilter.TwoDimensionalNonWeightedSynonymTokenSettingsCodec and ShingleMatrixFilter.SimpleThreeDimensionalTokenSettingsCodec.

Consider this token matrix:

              Token[column][row][z-axis]{
                {{hello}, {greetings, and, salutations}},
                {{world}, {earth}, {tellus}}
              };
It would produce the following 2-3 gram sized shingles:
             "hello_world"
             "greetings_and"
             "greetings_and_salutations"
             "and_salutations"
             "and_salutations_world"
             "salutations_world"
             "hello_earth"
             "and_salutations_earth"
             "salutations_earth"
             "hello_tellus"
             "and_salutations_tellus"
             "salutations_tellus"

This implementation can be rather heap demanding if (maximum shingle size - minimum shingle size) is a great number and the stream contains many columns, or if each column contains a great number of rows.

The problem is that in order avoid producing duplicates the filter needs to keep track of any shingle already produced and returned to the consumer.

There is a bit of resource management to handle this but it would of course be much better if the filter was written so it never created the same shingle more than once in the first place.

The filter also has basic support for calculating weights for the shingles based on the weights of the tokens from the input stream, output shingle size, etc. See CalculateShingleWeight.

NOTE: This filter might not behave correctly if used with custom Attributes, i.e. Attributes other than the ones located in org.apache.lucene.analysis.tokenattributes.

Public class | TokenPositioner


ShingleAnalyzerWrapper Class

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Class
Members See Also Send Feedback
A ShingleAnalyzerWrapper wraps a ShingleFilter around another Analyzer.

A shingle is another name for a token based n-gram.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ShingleAnalyzerWrapper : Analyzer
Visual Basic
Public Class ShingleAnalyzerWrapper _
    Inherits Analyzer
Visual C++
public ref class ShingleAnalyzerWrapper : public Analyzer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analysis..::..Analyzer
Lucene.Net.Analyzers.Shingle..::..ShingleAnalyzerWrapper

See Also

ShingleAnalyzerWrapper Members
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Members

[image] [image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Members
ShingleAnalyzerWrapper Class Constructors Methods Fields See Also Send Feedback

The ShingleAnalyzerWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | ShingleAnalyzerWrapper()()()() | Wraps StandardAnalyzer.
Public method | ShingleAnalyzerWrapper(Int32) | Initializes a new instance of the ShingleAnalyzerWrapper class
Public method | ShingleAnalyzerWrapper(Analyzer) | Initializes a new instance of the ShingleAnalyzerWrapper class
Public method | ShingleAnalyzerWrapper(Analyzer, Int32) | Initializes a new instance of the ShingleAnalyzerWrapper class

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxShingleSize | The max shingle (ngram) size
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOutputUnigrams |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Public method | SetMaxShingleSize | Set the maximum size of output shingles
Public method | SetOutputUnigrams | Shall the filter pass the original tokens (the "unigrams") to the output stream?
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | DefaultAnalyzer |
Protected field | MaxShingleSize |
Protected field | OutputUnigrams |
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Constructor

[image] [image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Constructor
ShingleAnalyzerWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShingleAnalyzerWrapper()()()() | Wraps StandardAnalyzer.
Public method | ShingleAnalyzerWrapper(Int32) | Initializes a new instance of the ShingleAnalyzerWrapper class
Public method | ShingleAnalyzerWrapper(Analyzer) | Initializes a new instance of the ShingleAnalyzerWrapper class
Public method | ShingleAnalyzerWrapper(Analyzer, Int32) | Initializes a new instance of the ShingleAnalyzerWrapper class

See Also

ShingleAnalyzerWrapper Class
ShingleAnalyzerWrapper Members
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Constructor

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Constructor
ShingleAnalyzerWrapper Class See Also Send Feedback
Wraps StandardAnalyzer.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleAnalyzerWrapper()
Visual Basic
Public Sub New
Visual C++
public:
ShingleAnalyzerWrapper()

See Also

ShingleAnalyzerWrapper Class
ShingleAnalyzerWrapper Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Constructor (Int32)

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Constructor (Int32)
ShingleAnalyzerWrapper Class See Also Send Feedback
Initializes a new instance of the ShingleAnalyzerWrapper class

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleAnalyzerWrapper(
    int nGramSize
)
Visual Basic
Public Sub New ( _
    nGramSize As Integer _
)
Visual C++
public:
ShingleAnalyzerWrapper(
    int nGramSize
)

Parameters

nGramSize
Type: System..::..Int32

[Missing <param name="nGramSize"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.#ctor(System.Int32)"]

See Also

ShingleAnalyzerWrapper Class
ShingleAnalyzerWrapper Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Constructor (Analyzer)

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Constructor (Analyzer)
ShingleAnalyzerWrapper Class See Also Send Feedback
Initializes a new instance of the ShingleAnalyzerWrapper class

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleAnalyzerWrapper(
    Analyzer defaultAnalyzer
)
Visual Basic
Public Sub New ( _
    defaultAnalyzer As Analyzer _
)
Visual C++
public:
ShingleAnalyzerWrapper(
    Analyzer^ defaultAnalyzer
)

Parameters

defaultAnalyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="defaultAnalyzer"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.#ctor(Lucene.Net.Analysis.Analyzer)"]

See Also

ShingleAnalyzerWrapper Class
ShingleAnalyzerWrapper Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Constructor (Analyzer, Int32)

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Constructor (Analyzer, Int32)
ShingleAnalyzerWrapper Class See Also Send Feedback
Initializes a new instance of the ShingleAnalyzerWrapper class

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleAnalyzerWrapper(
    Analyzer defaultAnalyzer,
    int maxShingleSize
)
Visual Basic
Public Sub New ( _
    defaultAnalyzer As Analyzer, _
    maxShingleSize As Integer _
)
Visual C++
public:
ShingleAnalyzerWrapper(
    Analyzer^ defaultAnalyzer,
    int maxShingleSize
)

Parameters

defaultAnalyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="defaultAnalyzer"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.#ctor(Lucene.Net.Analysis.Analyzer,System.Int32)"]

maxShingleSize
Type: System..::..Int32

[Missing <param name="maxShingleSize"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.#ctor(Lucene.Net.Analysis.Analyzer,System.Int32)"]

See Also

ShingleAnalyzerWrapper Class
ShingleAnalyzerWrapper Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Fields

[image] [image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Fields
ShingleAnalyzerWrapper Class See Also Send Feedback

The ShingleAnalyzerWrapper type exposes the following members.

Fields

 | Name | Description
Protected field | DefaultAnalyzer |
Protected field | MaxShingleSize |
Protected field | OutputUnigrams |
Protected field | overridesTokenStreamMethod | (Inherited from Analyzer.)

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


DefaultAnalyzer Field

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..DefaultAnalyzer Field
ShingleAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.DefaultAnalyzer"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected Analyzer DefaultAnalyzer
Visual Basic
Protected DefaultAnalyzer As Analyzer
Visual C++
protected:
Analyzer^ DefaultAnalyzer

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


MaxShingleSize Field

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..MaxShingleSize Field
ShingleAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.MaxShingleSize"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected int MaxShingleSize
Visual Basic
Protected MaxShingleSize As Integer
Visual C++
protected:
int MaxShingleSize

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


OutputUnigrams Field

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..OutputUnigrams Field
ShingleAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.OutputUnigrams"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected bool OutputUnigrams
Visual Basic
Protected OutputUnigrams As Boolean
Visual C++
protected:
bool OutputUnigrams

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleAnalyzerWrapper Methods

[image] [image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper Methods
ShingleAnalyzerWrapper Class See Also Send Feedback

The ShingleAnalyzerWrapper type exposes the following members.

Methods

 | Name | Description
Public method | Close | Frees persistent resources used by this Analyzer (Inherited from Analyzer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxShingleSize | The max shingle (ngram) size
Public method | GetOffsetGap | Just like {@link #getPositionIncrementGap}, except for Token offsets instead. By default this returns 1 for tokenized fields and, as if the fields were joined with an extra space character, and 0 for un-tokenized fields. This method is only called if the field produced at least one token for indexing. (Inherited from Analyzer.)
Public method | GetPositionIncrementGap | Invoked before indexing a Fieldable instance if terms have already been added to that field. This allows custom analyzers to place an automatic position increment gap between Fieldable instances using the same field name. The default value position increment gap is 0. With a 0 position increment gap and the typical default token position increment of 1, all terms in a field, including across Fieldable instances, are in successive positions, allowing exact PhraseQuery matches, for instance, across Fieldable instance boundaries. (Inherited from Analyzer.)
Protected method | GetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to retrieve previously saved TokenStreams for re-use by the same thread. (Inherited from Analyzer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOutputUnigrams |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReusableTokenStream | (Overrides Analyzer..::..ReusableTokenStream(String, TextReader).)
Public method | SetMaxShingleSize | Set the maximum size of output shingles
Public method | SetOutputUnigrams | Shall the filter pass the original tokens (the "unigrams") to the output stream?
Protected method | SetOverridesTokenStreamMethod | Obsolete. (Inherited from Analyzer.)
Protected method | SetPreviousTokenStream | Used by Analyzers that implement reusableTokenStream to save a TokenStream for later re-use by the same thread. (Inherited from Analyzer.)
Public method | TokenStream | (Overrides Analyzer..::..TokenStream(String, TextReader).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


GetMaxShingleSize Method

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..GetMaxShingleSize Method
ShingleAnalyzerWrapper Class See Also Send Feedback
The max shingle (ngram) size

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int GetMaxShingleSize()
Visual Basic
Public Function GetMaxShingleSize As Integer
Visual C++
public:
int GetMaxShingleSize()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.GetMaxShingleSize"]

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


IsOutputUnigrams Method

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..IsOutputUnigrams Method
ShingleAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.IsOutputUnigrams"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public bool IsOutputUnigrams()
Visual Basic
Public Function IsOutputUnigrams As Boolean
Visual C++
public:
bool IsOutputUnigrams()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.IsOutputUnigrams"]

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


ReusableTokenStream Method

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..ReusableTokenStream Method
ShingleAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream ReusableTokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function ReusableTokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ ReusableTokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.ReusableTokenStream(System.String,System.IO.TextReader)"]

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


SetMaxShingleSize Method

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..SetMaxShingleSize Method
ShingleAnalyzerWrapper Class See Also Send Feedback
Set the maximum size of output shingles

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetMaxShingleSize(
    int maxShingleSize
)
Visual Basic
Public Sub SetMaxShingleSize ( _
    maxShingleSize As Integer _
)
Visual C++
public:
void SetMaxShingleSize(
    int maxShingleSize
)

Parameters

maxShingleSize
Type: System..::..Int32
max shingle size

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


SetOutputUnigrams Method

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..SetOutputUnigrams Method
ShingleAnalyzerWrapper Class See Also Send Feedback
Shall the filter pass the original tokens (the "unigrams") to the output stream?

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetOutputUnigrams(
    bool outputUnigrams
)
Visual Basic
Public Sub SetOutputUnigrams ( _
    outputUnigrams As Boolean _
)
Visual C++
public:
void SetOutputUnigrams(
    bool outputUnigrams
)

Parameters

outputUnigrams
Type: System..::..Boolean
Whether or not the filter shall pass the original tokens to the output stream

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


TokenStream Method

[image]

Lucene.Net Class Libraries
ShingleAnalyzerWrapper..::..TokenStream Method
ShingleAnalyzerWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenStream TokenStream(
    string fieldName,
    TextReader reader
)
Visual Basic
Public Overrides Function TokenStream ( _
    fieldName As String, _
    reader As TextReader _
) As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStream(
    String^ fieldName,
    TextReader^ reader
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

reader
Type: System.IO..::..TextReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleAnalyzerWrapper.TokenStream(System.String,System.IO.TextReader)"]

See Also

ShingleAnalyzerWrapper Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Class

[image]

Lucene.Net Class Libraries
ShingleFilter Class
Members See Also Send Feedback

A ShingleFilter constructs shingles (token n-grams) from a token stream. In other words, it creates combinations of tokens as a single token.

For example, the sentence "please divide this sentence into shingles" might be tokenized into shingles "please divide", "divide this", "this sentence", "sentence into", and "into shingles".

This filter handles position increments > 1 by inserting filler tokens (tokens with termtext "_"). It does not handle a position increment of 0.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ShingleFilter : TokenFilter
Visual Basic
Public Class ShingleFilter _
    Inherits TokenFilter
Visual C++
public ref class ShingleFilter : public TokenFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analysis..::..TokenFilter
Lucene.Net.Analyzers.Shingle..::..ShingleFilter

See Also

ShingleFilter Members
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Members

[image] [image]

Lucene.Net Class Libraries
ShingleFilter Members
ShingleFilter Class Constructors Methods Fields See Also Send Feedback

The ShingleFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ShingleFilter(TokenStream) | Construct a ShingleFilter with default shingle size.
Public method | ShingleFilter(TokenStream, Int32) | Constructs a ShingleFilter with the specified single size from the TokenStream
Public method | ShingleFilter(TokenStream, String) | Construct a ShingleFilter with the specified token type for shingle tokens.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
See Lucene.Net.Analysis.TokenStream.Next()
(Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetMaxShingleSize
Set the max shingle size (default: 2)
Public method SetOutputUnigrams
Shall the output stream contain the input tokens (unigrams) as well as shingles? (default: true.)
Public method SetTokenType
Set the type of the shingle tokens produced by this filter. (default: "shingle")
Public method | ToString | (Inherited from AttributeSource.)

Fields

 | Name | Description
 | DefaultMaxShingleSize | Default maximum shingle size is 2.
 | FillerToken | Filler token for when positionIncrement is more than 1
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
 | TokenSeparator | The string to use when joining adjacent tokens to form a shingle

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Constructor

[image] [image]

Lucene.Net Class Libraries
ShingleFilter Constructor
ShingleFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShingleFilter(TokenStream) | Construct a ShingleFilter with default shingle size.
Public method | ShingleFilter(TokenStream, Int32) | Constructs a ShingleFilter with the specified single size from the TokenStream
Public method | ShingleFilter(TokenStream, String) | Construct a ShingleFilter with the specified token type for shingle tokens.

See Also

ShingleFilter Class
ShingleFilter Members
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Constructor (TokenStream)

[image]

Lucene.Net Class Libraries
ShingleFilter Constructor (TokenStream)
ShingleFilter Class See Also Send Feedback
Construct a ShingleFilter with default shingle size.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleFilter(
    TokenStream input
)
Visual Basic
Public Sub New ( _
    input As TokenStream _
)
Visual C++
public:
ShingleFilter(
    TokenStream^ input
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
input stream

See Also

ShingleFilter Class
ShingleFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Constructor (TokenStream, Int32)

[image]

Lucene.Net Class Libraries
ShingleFilter Constructor (TokenStream, Int32)
ShingleFilter Class See Also Send Feedback
Constructs a ShingleFilter with the specified single size from the TokenStream

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleFilter(
    TokenStream input,
    int maxShingleSize
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    maxShingleSize As Integer _
)
Visual C++
public:
ShingleFilter(
    TokenStream^ input,
    int maxShingleSize
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
input token stream
maxShingleSize
Type: System..::..Int32
maximum shingle size produced by the filter.

See Also

ShingleFilter Class
ShingleFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Constructor (TokenStream, String)

[image]

Lucene.Net Class Libraries
ShingleFilter Constructor (TokenStream, String)
ShingleFilter Class See Also Send Feedback
Construct a ShingleFilter with the specified token type for shingle tokens.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleFilter(
    TokenStream input,
    string tokenType
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    tokenType As String _
)
Visual C++
public:
ShingleFilter(
    TokenStream^ input,
    String^ tokenType
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
input stream
tokenType
Type: System..::..String
token type for shingle tokens

See Also

ShingleFilter Class
ShingleFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Fields

[image] [image]

Lucene.Net Class Libraries
ShingleFilter Fields
ShingleFilter Class See Also Send Feedback

The ShingleFilter type exposes the following members.

Fields

 | Name | Description
 | DefaultMaxShingleSize | Default maximum shingle size is 2.
 | FillerToken | Filler token for when positionIncrement is more than 1
Protected field | input | The source of tokens for this filter. (Inherited from TokenFilter.)
 | TokenSeparator | The string to use when joining adjacent tokens to form a shingle

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


DefaultMaxShingleSize Field

[image]

Lucene.Net Class Libraries
ShingleFilter..::..DefaultMaxShingleSize Field
ShingleFilter Class See Also Send Feedback
Default maximum shingle size is 2.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static readonly int DefaultMaxShingleSize
Visual Basic
Public Shared ReadOnly DefaultMaxShingleSize As Integer
Visual C++
public:
static initonly int DefaultMaxShingleSize

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


FillerToken Field

[image]

Lucene.Net Class Libraries
ShingleFilter..::..FillerToken Field
ShingleFilter Class See Also Send Feedback
Filler token for when positionIncrement is more than 1

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static readonly char[] FillerToken
Visual Basic
Public Shared ReadOnly FillerToken As Char()
Visual C++
public:
static initonly array<wchar_t>^ FillerToken

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


TokenSeparator Field

[image]

Lucene.Net Class Libraries
ShingleFilter..::..TokenSeparator Field
ShingleFilter Class See Also Send Feedback
The string to use when joining adjacent tokens to form a shingle

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static readonly string TokenSeparator
Visual Basic
Public Shared ReadOnly TokenSeparator As String
Visual C++
public:
static initonly String^ TokenSeparator

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleFilter Methods

[image] [image]

Lucene.Net Class Libraries
ShingleFilter Methods
ShingleFilter Class See Also Send Feedback

The ShingleFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Close the input TokenStream.
(Inherited from TokenFilter.)
Public method End
Performs end-of-stream operations, if any, and calls then
CopyC#
end()
 on the input TokenStream.

NOTE: Be sure to call

CopyC#
super.end()
first when overriding this method.
(Inherited from TokenFilter.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
See Lucene.Net.Analysis.TokenStream.Next()
(Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenFilter..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method SetMaxShingleSize
Set the max shingle size (default: 2)
Public method SetOutputUnigrams
Shall the output stream contain the input tokens (unigrams) as well as shingles? (default: true.)
Public method SetTokenType
Set the type of the shingle tokens produced by this filter. (default: "shingle")
Public method | ToString | (Inherited from AttributeSource.)

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
ShingleFilter..::..IncrementToken Method
ShingleFilter Class See Also Send Feedback
See Lucene.Net.Analysis.TokenStream.Next()

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override bool IncrementToken()
Visual Basic
Public Overrides Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleFilter.IncrementToken"]

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ShingleFilter..::..Next Method
ShingleFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next(Token).)

See Also

ShingleFilter Class
ShingleFilter Members
Lucene.Net.Analyzers.Shingle Namespace


Next Method

[image]

Lucene.Net Class Libraries
ShingleFilter..::..Next Method
ShingleFilter Class See Also Send Feedback
Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public override sealed Token Next()
Visual Basic
<ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")> _
Public Overrides NotOverridable Function Next As Token
Visual C++
[ObsoleteAttribute(L"The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public:
virtual Token^ Next() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleFilter.Next"]

See Also

ShingleFilter Class
Next Overload
Lucene.Net.Analyzers.Shingle Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
ShingleFilter..::..Next Method (Token)
ShingleFilter Class See Also Send Feedback
Deprecated: Will be removed in Lucene 3.0. This method is readonly, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public override sealed Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overrides NotOverridable Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override sealed

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

ShingleFilter Class
Next Overload
Lucene.Net.Analyzers.Shingle Namespace


Reset Method

[image]

Lucene.Net Class Libraries
ShingleFilter..::..Reset Method
ShingleFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleFilter.Reset"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


SetMaxShingleSize Method

[image]

Lucene.Net Class Libraries
ShingleFilter..::..SetMaxShingleSize Method
ShingleFilter Class See Also Send Feedback
Set the max shingle size (default: 2)

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetMaxShingleSize(
    int maxShingleSize
)
Visual Basic
Public Sub SetMaxShingleSize ( _
    maxShingleSize As Integer _
)
Visual C++
public:
void SetMaxShingleSize(
    int maxShingleSize
)

Parameters

maxShingleSize
Type: System..::..Int32
max size of output shingles

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


SetOutputUnigrams Method

[image]

Lucene.Net Class Libraries
ShingleFilter..::..SetOutputUnigrams Method
ShingleFilter Class See Also Send Feedback
Shall the output stream contain the input tokens (unigrams) as well as shingles? (default: true.)

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetOutputUnigrams(
    bool outputUnigrams
)
Visual Basic
Public Sub SetOutputUnigrams ( _
    outputUnigrams As Boolean _
)
Visual C++
public:
void SetOutputUnigrams(
    bool outputUnigrams
)

Parameters

outputUnigrams
Type: System..::..Boolean
Whether or not the output stream shall contain the input tokens (unigrams)

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


SetTokenType Method

[image]

Lucene.Net Class Libraries
ShingleFilter..::..SetTokenType Method
ShingleFilter Class See Also Send Feedback
Set the type of the shingle tokens produced by this filter. (default: "shingle")

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void SetTokenType(
    string tokenType
)
Visual Basic
Public Sub SetTokenType ( _
    tokenType As String _
)
Visual C++
public:
void SetTokenType(
    String^ tokenType
)

Parameters

tokenType
Type: System..::..String
token TokenType

See Also

ShingleFilter Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Class

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter Class
Members See Also Send Feedback

A ShingleMatrixFilter constructs shingles (token n-grams) from a token stream. In other words, it creates combinations of tokens as a single token.

For example, the sentence "please divide this sentence into shingles" might be tokenized into shingles "please divide", "divide this", "this sentence", "sentence into", and "into shingles".

Using a shingle filter at index and query time can in some instances be used to replace phrase queries, especially them with 0 slop.

Without a spacer character it can be used to handle composition and decomposition of words such as searching for "multi dimensional" instead of "multidimensional". It is a rather common human problem at query time in several languages, notably the northern Germanic branch.

Shingles are amongst many things also known to solve problems in spell checking, language detection and document clustering.

This filter is backed by a three dimensional column oriented matrix used to create permutations of the second dimension, the rows, and leaves the third, the z-axis, for for multi token synonyms.

In order to use this filter you need to define a way of positioning the input stream tokens in the matrix. This is done using a ShingleMatrixFilter.TokenSettingsCodec. There are three simple implementations for demonstrational purposes, see ShingleMatrixFilter.OneDimensionalNonWeightedTokenSettingsCodec, ShingleMatrixFilter.TwoDimensionalNonWeightedSynonymTokenSettingsCodec and ShingleMatrixFilter.SimpleThreeDimensionalTokenSettingsCodec.

Consider this token matrix:

              Token[column][row][z-axis]{
                {{hello}, {greetings, and, salutations}},
                {{world}, {earth}, {tellus}}
              };
It would produce the following 2-3 gram sized shingles:
             "hello_world"
             "greetings_and"
             "greetings_and_salutations"
             "and_salutations"
             "and_salutations_world"
             "salutations_world"
             "hello_earth"
             "and_salutations_earth"
             "salutations_earth"
             "hello_tellus"
             "and_salutations_tellus"
             "salutations_tellus"

This implementation can be rather heap demanding if (maximum shingle size - minimum shingle size) is a great number and the stream contains many columns, or if each column contains a great number of rows.

The problem is that in order avoid producing duplicates the filter needs to keep track of any shingle already produced and returned to the consumer.

There is a bit of resource management to handle this but it would of course be much better if the filter was written so it never created the same shingle more than once in the first place.

The filter also has basic support for calculating weights for the shingles based on the weights of the tokens from the input stream, output shingle size, etc. See CalculateShingleWeight.

NOTE: This filter might not behave correctly if used with custom Attributes, i.e. Attributes other than the ones located in org.apache.lucene.analysis.tokenattributes.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class ShingleMatrixFilter : TokenStream
Visual Basic
Public Class ShingleMatrixFilter _
    Inherits TokenStream
Visual C++
public ref class ShingleMatrixFilter : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Analyzers.Shingle..::..ShingleMatrixFilter

See Also

ShingleMatrixFilter Members
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Members

[image] [image]

Lucene.Net Class Libraries
ShingleMatrixFilter Members
ShingleMatrixFilter Class Constructors Methods Fields Properties See Also Send Feedback

The ShingleMatrixFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32) | Creates a shingle filter using default settings. See ShingleMatrixFilter.DefaultSpacerCharacter, ShingleMatrixFilter.IgnoringSinglePrefixOrSuffixShingleByDefault, and ShingleMatrixFilter.DefaultSettingsCodec
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32, Nullable<(Of <<'(Char>)>>)) | Creates a shingle filter using default settings. See IgnoringSinglePrefixOrSuffixShingleByDefault, and DefaultSettingsCodec
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32, Nullable<(Of <<'(Char>)>>), Boolean) | Creates a shingle filter using the default {@link TokenSettingsCodec}. See DefaultSettingsCodec
Public method | ShingleMatrixFilter(Matrix, Int32, Int32, Char, Boolean, TokenSettingsCodec) | Creates a shingle filter based on a user defined matrix. The filter /will/ delete columns from the input matrix! You will not be able to reset the filter if you used this constructor. todo: don't touch the matrix! use a bool, set the input stream to null or something, and keep track of where in the matrix we are at.
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32, Nullable<(Of <<'(Char>)>>), Boolean, TokenSettingsCodec) | Creates a shingle filter with ad hoc parameter settings.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CalculateShingleWeight
Evaluates the new shingle token weight. for (shingle part token in shingle) weight += shingle part token weight * (1 / sqrt(all shingle part token weights summed)) This algorithm gives a slightly greater score for longer shingles and is rather penalising to great shingle token part weights.
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method UpdateToken
Final touch of a shingle token before it is passed on to the consumer from method {@link #next(org.apache.lucene.analysis.Token)}. Calculates and sets type, flags, position increment, start/end offsets and weight.

Fields

Name | Description
DefaultSettingsCodec |
DefaultSpacerCharacter |
IgnoringSinglePrefixOrSuffixShingleByDefault |

Properties

 | Name | Description
Public property | IsIgnoringSinglePrefixOrSuffixShingle |
Public property | Matrix |
Public property | MaximumShingleSize |
Public property | MinimumShingleSize |
Public property | SpacerCharacter |

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Constructor

[image] [image]

Lucene.Net Class Libraries
ShingleMatrixFilter Constructor
ShingleMatrixFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32) | Creates a shingle filter using default settings. See ShingleMatrixFilter.DefaultSpacerCharacter, ShingleMatrixFilter.IgnoringSinglePrefixOrSuffixShingleByDefault, and ShingleMatrixFilter.DefaultSettingsCodec
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32, Nullable<(Of <<'(Char>)>>)) | Creates a shingle filter using default settings. See IgnoringSinglePrefixOrSuffixShingleByDefault, and DefaultSettingsCodec
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32, Nullable<(Of <<'(Char>)>>), Boolean) | Creates a shingle filter using the default {@link TokenSettingsCodec}. See DefaultSettingsCodec
Public method | ShingleMatrixFilter(Matrix, Int32, Int32, Char, Boolean, TokenSettingsCodec) | Creates a shingle filter based on a user defined matrix. The filter /will/ delete columns from the input matrix! You will not be able to reset the filter if you used this constructor. todo: don't touch the matrix! use a bool, set the input stream to null or something, and keep track of where in the matrix we are at.
Public method | ShingleMatrixFilter(TokenStream, Int32, Int32, Nullable<(Of <<'(Char>)>>), Boolean, TokenSettingsCodec) | Creates a shingle filter with ad hoc parameter settings.

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Members
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Constructor (TokenStream, Int32, Int32)

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter Constructor (TokenStream, Int32, Int32)
ShingleMatrixFilter Class See Also Send Feedback
Creates a shingle filter using default settings. See ShingleMatrixFilter.DefaultSpacerCharacter, ShingleMatrixFilter.IgnoringSinglePrefixOrSuffixShingleByDefault, and ShingleMatrixFilter.DefaultSettingsCodec

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleMatrixFilter(
    TokenStream input,
    int minimumShingleSize,
    int maximumShingleSize
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    minimumShingleSize As Integer, _
    maximumShingleSize As Integer _
)
Visual C++
public:
ShingleMatrixFilter(
    TokenStream^ input,
    int minimumShingleSize,
    int maximumShingleSize
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
stream from which to construct the matrix
minimumShingleSize
Type: System..::..Int32
minimum number of tokens in any shingle.
maximumShingleSize
Type: System..::..Int32
maximum number of tokens in any shingle.

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Constructor (TokenStream, Int32, Int32, Nullable(Char))

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter Constructor (TokenStream, Int32, Int32, Nullable<(Of <(<'Char>)>)>)
ShingleMatrixFilter Class See Also Send Feedback
Creates a shingle filter using default settings. See IgnoringSinglePrefixOrSuffixShingleByDefault, and DefaultSettingsCodec

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleMatrixFilter(
    TokenStream input,
    int minimumShingleSize,
    int maximumShingleSize,
    Nullable<char> spacerCharacter
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    minimumShingleSize As Integer, _
    maximumShingleSize As Integer, _
    spacerCharacter As Nullable(Of Char) _
)
Visual C++
public:
ShingleMatrixFilter(
    TokenStream^ input,
    int minimumShingleSize,
    int maximumShingleSize,
    Nullable<wchar_t> spacerCharacter
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
stream from which to construct the matrix
minimumShingleSize
Type: System..::..Int32
minimum number of tokens in any shingle.
maximumShingleSize
Type: System..::..Int32
maximum number of tokens in any shingle.
spacerCharacter
Type: System..::..Nullable <(Of <(<' Char >)>)>
character to use between texts of the token parts in a shingle. null for none.

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Constructor (TokenStream, Int32, Int32, Nullable(Char), Boolean)

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter Constructor (TokenStream, Int32, Int32, Nullable<(Of <(<'Char>)>)>, Boolean)
ShingleMatrixFilter Class See Also Send Feedback
Creates a shingle filter using the default {@link TokenSettingsCodec}. See DefaultSettingsCodec

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleMatrixFilter(
    TokenStream input,
    int minimumShingleSize,
    int maximumShingleSize,
    Nullable<char> spacerCharacter,
    bool ignoringSinglePrefixOrSuffixShingle
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    minimumShingleSize As Integer, _
    maximumShingleSize As Integer, _
    spacerCharacter As Nullable(Of Char), _
    ignoringSinglePrefixOrSuffixShingle As Boolean _
)
Visual C++
public:
ShingleMatrixFilter(
    TokenStream^ input,
    int minimumShingleSize,
    int maximumShingleSize,
    Nullable<wchar_t> spacerCharacter,
    bool ignoringSinglePrefixOrSuffixShingle
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
stream from which to construct the matrix
minimumShingleSize
Type: System..::..Int32
minimum number of tokens in any shingle.
maximumShingleSize
Type: System..::..Int32
maximum number of tokens in any shingle.
spacerCharacter
Type: System..::..Nullable <(Of <(<' Char >)>)>
character to use between texts of the token parts in a shingle. null for none.
ignoringSinglePrefixOrSuffixShingle
Type: System..::..Boolean
if true, shingles that only contains permutation of the first of the last column will not be produced as shingles. Useful when adding boundary marker tokens such as '^' and '$'.

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Constructor (Matrix, Int32, Int32, Char, Boolean, TokenSettingsCodec)

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter Constructor (Matrix, Int32, Int32, Char, Boolean, TokenSettingsCodec)
ShingleMatrixFilter Class See Also Send Feedback
Creates a shingle filter based on a user defined matrix. The filter /will/ delete columns from the input matrix! You will not be able to reset the filter if you used this constructor. todo: don't touch the matrix! use a bool, set the input stream to null or something, and keep track of where in the matrix we are at.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleMatrixFilter(
    Matrix matrix,
    int minimumShingleSize,
    int maximumShingleSize,
    char spacerCharacter,
    bool ignoringSinglePrefixOrSuffixShingle,
    TokenSettingsCodec settingsCodec
)
Visual Basic
Public Sub New ( _
    matrix As Matrix, _
    minimumShingleSize As Integer, _
    maximumShingleSize As Integer, _
    spacerCharacter As Char, _
    ignoringSinglePrefixOrSuffixShingle As Boolean, _
    settingsCodec As TokenSettingsCodec _
)
Visual C++
public:
ShingleMatrixFilter(
    Matrix^ matrix,
    int minimumShingleSize,
    int maximumShingleSize,
    wchar_t spacerCharacter,
    bool ignoringSinglePrefixOrSuffixShingle,
    TokenSettingsCodec^ settingsCodec
)

Parameters

matrix
Type: Lucene.Net.Analyzers.Shingle.Matrix..::..Matrix
the input based for creating shingles. Does not need to contain any information until ShingleMatrixFilter.Next(Token) is called the first time.
minimumShingleSize
Type: System..::..Int32
minimum number of tokens in any shingle.
maximumShingleSize
Type: System..::..Int32
maximum number of tokens in any shingle.
spacerCharacter
Type: System..::..Char
character to use between texts of the token parts in a shingle. null for none.
ignoringSinglePrefixOrSuffixShingle
Type: System..::..Boolean
if true, shingles that only contains permutation of the first of the last column will not be produced as shingles. Useful when adding boundary marker tokens such as '^' and '$'.
settingsCodec
Type: Lucene.Net.Analyzers.Shingle.Codec..::..TokenSettingsCodec
codec used to read input token weight and matrix positioning.

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Constructor (TokenStream, Int32, Int32, Nullable(Char), Boolean, TokenSettingsCodec)

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter Constructor (TokenStream, Int32, Int32, Nullable<(Of <(<'Char>)>)>, Boolean, TokenSettingsCodec)
ShingleMatrixFilter Class See Also Send Feedback
Creates a shingle filter with ad hoc parameter settings.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public ShingleMatrixFilter(
    TokenStream input,
    int minimumShingleSize,
    int maximumShingleSize,
    Nullable<char> spacerCharacter,
    bool ignoringSinglePrefixOrSuffixShingle,
    TokenSettingsCodec settingsCodec
)
Visual Basic
Public Sub New ( _
    input As TokenStream, _
    minimumShingleSize As Integer, _
    maximumShingleSize As Integer, _
    spacerCharacter As Nullable(Of Char), _
    ignoringSinglePrefixOrSuffixShingle As Boolean, _
    settingsCodec As TokenSettingsCodec _
)
Visual C++
public:
ShingleMatrixFilter(
    TokenStream^ input,
    int minimumShingleSize,
    int maximumShingleSize,
    Nullable<wchar_t> spacerCharacter,
    bool ignoringSinglePrefixOrSuffixShingle,
    TokenSettingsCodec^ settingsCodec
)

Parameters

input
Type: Lucene.Net.Analysis..::..TokenStream
stream from which to construct the matrix
minimumShingleSize
Type: System..::..Int32
minimum number of tokens in any shingle.
maximumShingleSize
Type: System..::..Int32
maximum number of tokens in any shingle.
spacerCharacter
Type: System..::..Nullable <(Of <(<' Char >)>)>
character to use between texts of the token parts in a shingle. null for none.
ignoringSinglePrefixOrSuffixShingle
Type: System..::..Boolean
if true, shingles that only contains permutation of the first of the last column will not be produced as shingles. Useful when adding boundary marker tokens such as '^' and '$'.
settingsCodec
Type: Lucene.Net.Analyzers.Shingle.Codec..::..TokenSettingsCodec
codec used to read input token weight and matrix positioning.

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Overload
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Fields

[image] [image]

Lucene.Net Class Libraries
ShingleMatrixFilter Fields
ShingleMatrixFilter Class See Also Send Feedback

The ShingleMatrixFilter type exposes the following members.

Fields

Name | Description
DefaultSettingsCodec |
DefaultSpacerCharacter |
IgnoringSinglePrefixOrSuffixShingleByDefault |

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


DefaultSettingsCodec Field

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..DefaultSettingsCodec Field
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.DefaultSettingsCodec"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static TokenSettingsCodec DefaultSettingsCodec
Visual Basic
Public Shared DefaultSettingsCodec As TokenSettingsCodec
Visual C++
public:
static TokenSettingsCodec^ DefaultSettingsCodec

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


DefaultSpacerCharacter Field

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..DefaultSpacerCharacter Field
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.DefaultSpacerCharacter"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static char DefaultSpacerCharacter
Visual Basic
Public Shared DefaultSpacerCharacter As Char
Visual C++
public:
static wchar_t DefaultSpacerCharacter

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


IgnoringSinglePrefixOrSuffixShingleByDefault Field

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..IgnoringSinglePrefixOrSuffixShingleByDefault Field
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.IgnoringSinglePrefixOrSuffixShingleByDefault"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static bool IgnoringSinglePrefixOrSuffixShingleByDefault
Visual Basic
Public Shared IgnoringSinglePrefixOrSuffixShingleByDefault As Boolean
Visual C++
public:
static bool IgnoringSinglePrefixOrSuffixShingleByDefault

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Methods

[image] [image]

Lucene.Net Class Libraries
ShingleMatrixFilter Methods
ShingleMatrixFilter Class See Also Send Feedback

The ShingleMatrixFilter type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CalculateShingleWeight
Evaluates the new shingle token weight. for (shingle part token in shingle) weight += shingle part token weight * (1 / sqrt(all shingle part token weights summed)) This algorithm gives a slightly greater score for longer shingles and is rather penalising to great shingle token part weights.
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method | IncrementToken | (Overrides TokenStream..::..IncrementToken()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next()()()() Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.
(Overrides TokenStream..::..Next(Token).)
Public method | Reset | (Overrides TokenStream..::..Reset()()()().)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)
Public method UpdateToken
Final touch of a shingle token before it is passed on to the consumer from method {@link #next(org.apache.lucene.analysis.Token)}. Calculates and sets type, flags, position increment, start/end offsets and weight.

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


CalculateShingleWeight Method

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..CalculateShingleWeight Method
ShingleMatrixFilter Class See Also Send Feedback
Evaluates the new shingle token weight. for (shingle part token in shingle) weight += shingle part token weight * (1 / sqrt(all shingle part token weights summed)) This algorithm gives a slightly greater score for longer shingles and is rather penalising to great shingle token part weights.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public float CalculateShingleWeight(
    Token shingleToken,
    List<Token> shingle,
    int currentPermutationStartOffset,
    List<Row> currentPermutationRows,
    List<Token> currentPermuationTokens
)
Visual Basic
Public Function CalculateShingleWeight ( _
    shingleToken As Token, _
    shingle As List(Of Token), _
    currentPermutationStartOffset As Integer, _
    currentPermutationRows As List(Of Row), _
    currentPermuationTokens As List(Of Token) _
) As Single
Visual C++
public:
float CalculateShingleWeight(
    Token^ shingleToken,
    List<Token^>^ shingle,
    int currentPermutationStartOffset,
    List<Row^>^ currentPermutationRows,
    List<Token^>^ currentPermuationTokens
)

Parameters

shingleToken
Type: Lucene.Net.Analysis..::..Token
token returned to consumer
shingle
Type: System.Collections.Generic..::..List <(Of <(<' Token >)>)>
tokens the tokens used to produce the shingle token.
currentPermutationStartOffset
Type: System..::..Int32
start offset in parameter currentPermutationRows and currentPermutationTokens.
currentPermutationRows
Type: System.Collections.Generic..::..List <(Of <(<' Row >)>)>
an index to what matrix row a token in parameter currentPermutationTokens exist.
currentPermuationTokens
Type: System.Collections.Generic..::..List <(Of <(<' Token >)>)>
all tokens in the current row permutation of the matrix. A sub list (parameter offset, parameter shingle.size) equals parameter shingle.

Return Value

weight to be set for parameter shingleToken

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


IncrementToken Method

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..IncrementToken Method
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.IncrementToken"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override sealed bool IncrementToken()
Visual Basic
Public Overrides NotOverridable Function IncrementToken As Boolean
Visual C++
public:
virtual bool IncrementToken() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.IncrementToken"]

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..Next Method
ShingleMatrixFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Obsolete. Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next()()()().)
Public method | Next(Token) | Obsolete. Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer. (Overrides TokenStream..::..Next(Token).)

See Also

ShingleMatrixFilter Class
ShingleMatrixFilter Members
Lucene.Net.Analyzers.Shingle Namespace


Next Method

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..Next Method
ShingleMatrixFilter Class See Also Send Feedback
Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public override sealed Token Next()
Visual Basic
<ObsoleteAttribute("The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")> _
Public Overrides NotOverridable Function Next As Token
Visual C++
[ObsoleteAttribute(L"The returned Token is a "full private copy" (not re-used across calls to Next()) but will be slower than calling {@link #Next(Token)} or using the new IncrementToken() method with the new AttributeSource API.")]
public:
virtual Token^ Next() override sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.Next"]

See Also

ShingleMatrixFilter Class
Next Overload
Lucene.Net.Analyzers.Shingle Namespace


Next Method (Token)

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..Next Method (Token)
ShingleMatrixFilter Class See Also Send Feedback
Deprecated: Will be removed in Lucene 3.0. This method is final, as it should not be overridden. Delegates to the backwards compatibility layer.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
[ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")]
public override sealed Token Next(
    Token reusableToken
)
Visual Basic
<ObsoleteAttribute("The new IncrementToken() and AttributeSource APIs should be used instead.")> _
Public Overrides NotOverridable Function Next ( _
    reusableToken As Token _
) As Token
Visual C++
[ObsoleteAttribute(L"The new IncrementToken() and AttributeSource APIs should be used instead.")]
public:
virtual Token^ Next(
    Token^ reusableToken
) override sealed

Parameters

reusableToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="reusableToken"/> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.Next(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.Next(Lucene.Net.Analysis.Token)"]

See Also

ShingleMatrixFilter Class
Next Overload
Lucene.Net.Analyzers.Shingle Namespace


Reset Method

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..Reset Method
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.Reset"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void Reset()
Visual Basic
Public Overrides Sub Reset
Visual C++
public:
virtual void Reset() override

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


UpdateToken Method

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..UpdateToken Method
ShingleMatrixFilter Class See Also Send Feedback
Final touch of a shingle token before it is passed on to the consumer from method {@link #next(org.apache.lucene.analysis.Token)}. Calculates and sets type, flags, position increment, start/end offsets and weight.

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public void UpdateToken(
    Token token,
    List<Token> shingle,
    int currentPermutationStartOffset,
    List<Row> currentPermutationRows,
    List<Token> currentPermuationTokens
)
Visual Basic
Public Sub UpdateToken ( _
    token As Token, _
    shingle As List(Of Token), _
    currentPermutationStartOffset As Integer, _
    currentPermutationRows As List(Of Row), _
    currentPermuationTokens As List(Of Token) _
)
Visual C++
public:
void UpdateToken(
    Token^ token,
    List<Token^>^ shingle,
    int currentPermutationStartOffset,
    List<Row^>^ currentPermutationRows,
    List<Token^>^ currentPermuationTokens
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token
Shingle Token
shingle
Type: System.Collections.Generic..::..List <(Of <(<' Token >)>)>
Tokens used to produce the shingle token.
currentPermutationStartOffset
Type: System..::..Int32
Start offset in parameter currentPermutationTokens
currentPermutationRows
Type: System.Collections.Generic..::..List <(Of <(<' Row >)>)>
index to Matrix.Column.Row from the position of tokens in parameter currentPermutationTokens
currentPermuationTokens
Type: System.Collections.Generic..::..List <(Of <(<' Token >)>)>
tokens of the current permutation of rows in the matrix.

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


ShingleMatrixFilter Properties

[image] [image]

Lucene.Net Class Libraries
ShingleMatrixFilter Properties
ShingleMatrixFilter Class See Also Send Feedback

The ShingleMatrixFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsIgnoringSinglePrefixOrSuffixShingle |
Public property | Matrix |
Public property | MaximumShingleSize |
Public property | MinimumShingleSize |
Public property | SpacerCharacter |

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


IsIgnoringSinglePrefixOrSuffixShingle Property

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..IsIgnoringSinglePrefixOrSuffixShingle Property
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.IsIgnoringSinglePrefixOrSuffixShingle"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public bool IsIgnoringSinglePrefixOrSuffixShingle { get; set; }
Visual Basic
Public Property IsIgnoringSinglePrefixOrSuffixShingle As Boolean
    Get
    Set
Visual C++
public:
property bool IsIgnoringSinglePrefixOrSuffixShingle {
    bool get ();
    void set (bool value);
}

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


Matrix Property

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..Matrix Property
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.Matrix"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Matrix Matrix { get; set; }
Visual Basic
Public Property Matrix As Matrix
    Get
    Set
Visual C++
public:
property Matrix^ Matrix {
    Matrix^ get ();
    void set (Matrix^ value);
}

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


MaximumShingleSize Property

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..MaximumShingleSize Property
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.MaximumShingleSize"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int MaximumShingleSize { get; set; }
Visual Basic
Public Property MaximumShingleSize As Integer
    Get
    Set
Visual C++
public:
property int MaximumShingleSize {
    int get ();
    void set (int value);
}

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


MinimumShingleSize Property

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..MinimumShingleSize Property
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.MinimumShingleSize"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int MinimumShingleSize { get; set; }
Visual Basic
Public Property MinimumShingleSize As Integer
    Get
    Set
Visual C++
public:
property int MinimumShingleSize {
    int get ();
    void set (int value);
}

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


SpacerCharacter Property

[image]

Lucene.Net Class Libraries
ShingleMatrixFilter..::..SpacerCharacter Property
ShingleMatrixFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.ShingleMatrixFilter.SpacerCharacter"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Nullable<char> SpacerCharacter { get; set; }
Visual Basic
Public Property SpacerCharacter As Nullable(Of Char)
    Get
    Set
Visual C++
public:
property Nullable<wchar_t> SpacerCharacter {
    Nullable<wchar_t> get ();
    void set (Nullable<wchar_t> value);
}

See Also

ShingleMatrixFilter Class
Lucene.Net.Analyzers.Shingle Namespace


TokenPositioner Class

[image]

Lucene.Net Class Libraries
TokenPositioner Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analyzers.Shingle.TokenPositioner"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class TokenPositioner
Visual Basic
Public Class TokenPositioner
Visual C++
public ref class TokenPositioner

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle..::..TokenPositioner

See Also

TokenPositioner Members
Lucene.Net.Analyzers.Shingle Namespace


TokenPositioner Members

[image] [image]

Lucene.Net Class Libraries
TokenPositioner Members
TokenPositioner Class Methods Fields Properties See Also Send Feedback

The TokenPositioner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NewColumn |
NewRow |
SameRow |

Properties

 | Name | Description
Public property | Index |

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


TokenPositioner Fields

[image] [image]

Lucene.Net Class Libraries
TokenPositioner Fields
TokenPositioner Class See Also Send Feedback

The TokenPositioner type exposes the following members.

Fields

Name | Description
NewColumn |
NewRow |
SameRow |

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


NewColumn Field

[image]

Lucene.Net Class Libraries
TokenPositioner..::..NewColumn Field
TokenPositioner Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.TokenPositioner.NewColumn"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static readonly TokenPositioner NewColumn
Visual Basic
Public Shared ReadOnly NewColumn As TokenPositioner
Visual C++
public:
static initonly TokenPositioner^ NewColumn

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


NewRow Field

[image]

Lucene.Net Class Libraries
TokenPositioner..::..NewRow Field
TokenPositioner Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.TokenPositioner.NewRow"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static readonly TokenPositioner NewRow
Visual Basic
Public Shared ReadOnly NewRow As TokenPositioner
Visual C++
public:
static initonly TokenPositioner^ NewRow

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


SameRow Field

[image]

Lucene.Net Class Libraries
TokenPositioner..::..SameRow Field
TokenPositioner Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Analyzers.Shingle.TokenPositioner.SameRow"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public static readonly TokenPositioner SameRow
Visual Basic
Public Shared ReadOnly SameRow As TokenPositioner
Visual C++
public:
static initonly TokenPositioner^ SameRow

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


TokenPositioner Methods

[image] [image]

Lucene.Net Class Libraries
TokenPositioner Methods
TokenPositioner Class See Also Send Feedback

The TokenPositioner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


TokenPositioner Properties

[image] [image]

Lucene.Net Class Libraries
TokenPositioner Properties
TokenPositioner Class See Also Send Feedback

The TokenPositioner type exposes the following members.

Properties

 | Name | Description
Public property | Index |

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


Index Property

[image]

Lucene.Net Class Libraries
TokenPositioner..::..Index Property
TokenPositioner Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.TokenPositioner.Index"]

Namespace: Lucene.Net.Analyzers.Shingle
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int Index { get; private set; }
Visual Basic
Public Property Index As Integer
    Get
    Private Set
Visual C++
public:
property int Index {
    int get ();
    private: void set (int value);
}

See Also

TokenPositioner Class
Lucene.Net.Analyzers.Shingle Namespace


Lucene.Net.Analyzers.Shingle.Codec Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analyzers.Shingle.Codec Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analyzers.Shingle.Codec"]

Classes

 | Class | Description
Public class | OneDimensionalNonWeightedTokenSettingsCodec | Using this codec makes a ShingleMatrixFilter act like ShingleFilter. It produces the most simple sort of shingles, ignoring token position increments, etc. It adds each token as a new column.
Public class | SimpleThreeDimensionalTokenSettingsCodec | A full featured codec not to be used for something serious. It takes complete control of payload for weight and the bit flags for positioning in the matrix. Mainly exist for demonstrational purposes.
Public class | TokenSettingsCodec | Strategy used to code and decode meta data of the tokens from the input stream regarding how to position the tokens in the matrix, set and retreive weight, etc.
Public class | TwoDimensionalNonWeightedSynonymTokenSettingsCodec | A codec that creates a two dimensional matrix by treating tokens from the input stream with 0 position increment as new rows to the current column.


OneDimensionalNonWeightedTokenSettingsCodec Class

[image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec Class
Members See Also Send Feedback
Using this codec makes a ShingleMatrixFilter act like ShingleFilter. It produces the most simple sort of shingles, ignoring token position increments, etc. It adds each token as a new column.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class OneDimensionalNonWeightedTokenSettingsCodec : TokenSettingsCodec
Visual Basic
Public Class OneDimensionalNonWeightedTokenSettingsCodec _
    Inherits TokenSettingsCodec
Visual C++
public ref class OneDimensionalNonWeightedTokenSettingsCodec : public TokenSettingsCodec

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Codec..::..TokenSettingsCodec
Lucene.Net.Analyzers.Shingle.Codec..::..OneDimensionalNonWeightedTokenSettingsCodec

See Also

OneDimensionalNonWeightedTokenSettingsCodec Members
Lucene.Net.Analyzers.Shingle.Codec Namespace


OneDimensionalNonWeightedTokenSettingsCodec Members

[image] [image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec Members
OneDimensionalNonWeightedTokenSettingsCodec Class Constructors Methods See Also Send Feedback

The OneDimensionalNonWeightedTokenSettingsCodec type exposes the following members.

Constructors

 | Name | Description
Public method | OneDimensionalNonWeightedTokenSettingsCodec | Initializes a new instance of the OneDimensionalNonWeightedTokenSettingsCodec class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | (Overrides TokenSettingsCodec..::..GetTokenPositioner(Token).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | (Overrides TokenSettingsCodec..::..GetWeight(Token).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | (Overrides TokenSettingsCodec..::..SetTokenPositioner(Token, TokenPositioner).)
Public method | SetWeight | (Overrides TokenSettingsCodec..::..SetWeight(Token, Single).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


OneDimensionalNonWeightedTokenSettingsCodec Constructor

[image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec Constructor
OneDimensionalNonWeightedTokenSettingsCodec Class See Also Send Feedback
Initializes a new instance of the OneDimensionalNonWeightedTokenSettingsCodec class

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public OneDimensionalNonWeightedTokenSettingsCodec()
Visual Basic
Public Sub New
Visual C++
public:
OneDimensionalNonWeightedTokenSettingsCodec()

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


OneDimensionalNonWeightedTokenSettingsCodec Methods

[image] [image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec Methods
OneDimensionalNonWeightedTokenSettingsCodec Class See Also Send Feedback

The OneDimensionalNonWeightedTokenSettingsCodec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | (Overrides TokenSettingsCodec..::..GetTokenPositioner(Token).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | (Overrides TokenSettingsCodec..::..GetWeight(Token).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | (Overrides TokenSettingsCodec..::..SetTokenPositioner(Token, TokenPositioner).)
Public method | SetWeight | (Overrides TokenSettingsCodec..::..SetWeight(Token, Single).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetTokenPositioner Method

[image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec..::..GetTokenPositioner Method
OneDimensionalNonWeightedTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenPositioner GetTokenPositioner(
    Token token
)
Visual Basic
Public Overrides Function GetTokenPositioner ( _
    token As Token _
) As TokenPositioner
Visual C++
public:
virtual TokenPositioner^ GetTokenPositioner(
    Token^ token
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetWeight Method

[image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec..::..GetWeight Method
OneDimensionalNonWeightedTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override float GetWeight(
    Token token
)
Visual Basic
Public Overrides Function GetWeight ( _
    token As Token _
) As Single
Visual C++
public:
virtual float GetWeight(
    Token^ token
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetTokenPositioner Method

[image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec..::..SetTokenPositioner Method
OneDimensionalNonWeightedTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void SetTokenPositioner(
    Token token,
    TokenPositioner tokenPositioner
)
Visual Basic
Public Overrides Sub SetTokenPositioner ( _
    token As Token, _
    tokenPositioner As TokenPositioner _
)
Visual C++
public:
virtual void SetTokenPositioner(
    Token^ token,
    TokenPositioner^ tokenPositioner
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

tokenPositioner
Type: Lucene.Net.Analyzers.Shingle..::..TokenPositioner

[Missing <param name="tokenPositioner"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetWeight Method

[image]

Lucene.Net Class Libraries
OneDimensionalNonWeightedTokenSettingsCodec..::..SetWeight Method
OneDimensionalNonWeightedTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void SetWeight(
    Token token,
    float weight
)
Visual Basic
Public Overrides Sub SetWeight ( _
    token As Token, _
    weight As Single _
)
Visual C++
public:
virtual void SetWeight(
    Token^ token,
    float weight
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

weight
Type: System..::..Single

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.OneDimensionalNonWeightedTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

See Also

OneDimensionalNonWeightedTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SimpleThreeDimensionalTokenSettingsCodec Class

[image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec Class
Members See Also Send Feedback
A full featured codec not to be used for something serious. It takes complete control of payload for weight and the bit flags for positioning in the matrix. Mainly exist for demonstrational purposes.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class SimpleThreeDimensionalTokenSettingsCodec : TokenSettingsCodec
Visual Basic
Public Class SimpleThreeDimensionalTokenSettingsCodec _
    Inherits TokenSettingsCodec
Visual C++
public ref class SimpleThreeDimensionalTokenSettingsCodec : public TokenSettingsCodec

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Codec..::..TokenSettingsCodec
Lucene.Net.Analyzers.Shingle.Codec..::..SimpleThreeDimensionalTokenSettingsCodec

See Also

SimpleThreeDimensionalTokenSettingsCodec Members
Lucene.Net.Analyzers.Shingle.Codec Namespace


SimpleThreeDimensionalTokenSettingsCodec Members

[image] [image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec Members
SimpleThreeDimensionalTokenSettingsCodec Class Constructors Methods See Also Send Feedback

The SimpleThreeDimensionalTokenSettingsCodec type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleThreeDimensionalTokenSettingsCodec | Initializes a new instance of the SimpleThreeDimensionalTokenSettingsCodec class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | (Overrides TokenSettingsCodec..::..GetTokenPositioner(Token).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | Returns a 32 bit float from the payload, or 1f it null. (Overrides TokenSettingsCodec..::..GetWeight(Token).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | Sets the TokenPositioner as token flags int value. (Overrides TokenSettingsCodec..::..SetTokenPositioner(Token, TokenPositioner).)
Public method | SetWeight | Stores a 32 bit float in the payload, or set it to null if 1f; (Overrides TokenSettingsCodec..::..SetWeight(Token, Single).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SimpleThreeDimensionalTokenSettingsCodec Constructor

[image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec Constructor
SimpleThreeDimensionalTokenSettingsCodec Class See Also Send Feedback
Initializes a new instance of the SimpleThreeDimensionalTokenSettingsCodec class

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public SimpleThreeDimensionalTokenSettingsCodec()
Visual Basic
Public Sub New
Visual C++
public:
SimpleThreeDimensionalTokenSettingsCodec()

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SimpleThreeDimensionalTokenSettingsCodec Methods

[image] [image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec Methods
SimpleThreeDimensionalTokenSettingsCodec Class See Also Send Feedback

The SimpleThreeDimensionalTokenSettingsCodec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | (Overrides TokenSettingsCodec..::..GetTokenPositioner(Token).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | Returns a 32 bit float from the payload, or 1f it null. (Overrides TokenSettingsCodec..::..GetWeight(Token).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | Sets the TokenPositioner as token flags int value. (Overrides TokenSettingsCodec..::..SetTokenPositioner(Token, TokenPositioner).)
Public method | SetWeight | Stores a 32 bit float in the payload, or set it to null if 1f; (Overrides TokenSettingsCodec..::..SetWeight(Token, Single).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetTokenPositioner Method

[image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec..::..GetTokenPositioner Method
SimpleThreeDimensionalTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenPositioner GetTokenPositioner(
    Token token
)
Visual Basic
Public Overrides Function GetTokenPositioner ( _
    token As Token _
) As TokenPositioner
Visual C++
public:
virtual TokenPositioner^ GetTokenPositioner(
    Token^ token
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Return Value

the token flags int value as TokenPosition

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetWeight Method

[image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec..::..GetWeight Method
SimpleThreeDimensionalTokenSettingsCodec Class See Also Send Feedback
Returns a 32 bit float from the payload, or 1f it null.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override float GetWeight(
    Token token
)
Visual Basic
Public Overrides Function GetWeight ( _
    token As Token _
) As Single
Visual C++
public:
virtual float GetWeight(
    Token^ token
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetTokenPositioner Method

[image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec..::..SetTokenPositioner Method
SimpleThreeDimensionalTokenSettingsCodec Class See Also Send Feedback
Sets the TokenPositioner as token flags int value.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void SetTokenPositioner(
    Token token,
    TokenPositioner tokenPositioner
)
Visual Basic
Public Overrides Sub SetTokenPositioner ( _
    token As Token, _
    tokenPositioner As TokenPositioner _
)
Visual C++
public:
virtual void SetTokenPositioner(
    Token^ token,
    TokenPositioner^ tokenPositioner
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

tokenPositioner
Type: Lucene.Net.Analyzers.Shingle..::..TokenPositioner

[Missing <param name="tokenPositioner"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetWeight Method

[image]

Lucene.Net Class Libraries
SimpleThreeDimensionalTokenSettingsCodec..::..SetWeight Method
SimpleThreeDimensionalTokenSettingsCodec Class See Also Send Feedback
Stores a 32 bit float in the payload, or set it to null if 1f;

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void SetWeight(
    Token token,
    float weight
)
Visual Basic
Public Overrides Sub SetWeight ( _
    token As Token, _
    weight As Single _
)
Visual C++
public:
virtual void SetWeight(
    Token^ token,
    float weight
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

weight
Type: System..::..Single

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.SimpleThreeDimensionalTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

See Also

SimpleThreeDimensionalTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


TokenSettingsCodec Class

[image]

Lucene.Net Class Libraries
TokenSettingsCodec Class
Members See Also Send Feedback
Strategy used to code and decode meta data of the tokens from the input stream regarding how to position the tokens in the matrix, set and retreive weight, etc.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public abstract class TokenSettingsCodec
Visual Basic
Public MustInherit Class TokenSettingsCodec
Visual C++
public ref class TokenSettingsCodec abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Codec..::..TokenSettingsCodec
Lucene.Net.Analyzers.Shingle.Codec..::..OneDimensionalNonWeightedTokenSettingsCodec
Lucene.Net.Analyzers.Shingle.Codec..::..SimpleThreeDimensionalTokenSettingsCodec
Lucene.Net.Analyzers.Shingle.Codec..::..TwoDimensionalNonWeightedSynonymTokenSettingsCodec

See Also

TokenSettingsCodec Members
Lucene.Net.Analyzers.Shingle.Codec Namespace


TokenSettingsCodec Members

[image] [image]

Lucene.Net Class Libraries
TokenSettingsCodec Members
TokenSettingsCodec Class Constructors Methods See Also Send Feedback

The TokenSettingsCodec type exposes the following members.

Constructors

 | Name | Description
Protected method | TokenSettingsCodec | Initializes a new instance of the TokenSettingsCodec class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | Retrieves information on how a Token is to be inserted to a ShingleMatrixFilter.Matrix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | Have this method return 1f in order to 'disable' weights.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | Sets information on how a Token is to be inserted to a ShingleMatrixFilter.Matrix.
Public method | SetWeight | Have this method do nothing in order to 'disable' weights.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


TokenSettingsCodec Constructor

[image]

Lucene.Net Class Libraries
TokenSettingsCodec Constructor
TokenSettingsCodec Class See Also Send Feedback
Initializes a new instance of the TokenSettingsCodec class

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
protected TokenSettingsCodec()
Visual Basic
Protected Sub New
Visual C++
protected:
TokenSettingsCodec()

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


TokenSettingsCodec Methods

[image] [image]

Lucene.Net Class Libraries
TokenSettingsCodec Methods
TokenSettingsCodec Class See Also Send Feedback

The TokenSettingsCodec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | Retrieves information on how a Token is to be inserted to a ShingleMatrixFilter.Matrix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | Have this method return 1f in order to 'disable' weights.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | Sets information on how a Token is to be inserted to a ShingleMatrixFilter.Matrix.
Public method | SetWeight | Have this method do nothing in order to 'disable' weights.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetTokenPositioner Method

[image]

Lucene.Net Class Libraries
TokenSettingsCodec..::..GetTokenPositioner Method
TokenSettingsCodec Class See Also Send Feedback
Retrieves information on how a Token is to be inserted to a ShingleMatrixFilter.Matrix.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public abstract TokenPositioner GetTokenPositioner(
    Token token
)
Visual Basic
Public MustOverride Function GetTokenPositioner ( _
    token As Token _
) As TokenPositioner
Visual C++
public:
virtual TokenPositioner^ GetTokenPositioner(
    Token^ token
) abstract

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetWeight Method

[image]

Lucene.Net Class Libraries
TokenSettingsCodec..::..GetWeight Method
TokenSettingsCodec Class See Also Send Feedback
Have this method return 1f in order to 'disable' weights.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public abstract float GetWeight(
    Token token
)
Visual Basic
Public MustOverride Function GetWeight ( _
    token As Token _
) As Single
Visual C++
public:
virtual float GetWeight(
    Token^ token
) abstract

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetTokenPositioner Method

[image]

Lucene.Net Class Libraries
TokenSettingsCodec..::..SetTokenPositioner Method
TokenSettingsCodec Class See Also Send Feedback
Sets information on how a Token is to be inserted to a ShingleMatrixFilter.Matrix.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public abstract void SetTokenPositioner(
    Token token,
    TokenPositioner tokenPositioner
)
Visual Basic
Public MustOverride Sub SetTokenPositioner ( _
    token As Token, _
    tokenPositioner As TokenPositioner _
)
Visual C++
public:
virtual void SetTokenPositioner(
    Token^ token,
    TokenPositioner^ tokenPositioner
) abstract

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

tokenPositioner
Type: Lucene.Net.Analyzers.Shingle..::..TokenPositioner

[Missing <param name="tokenPositioner"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetWeight Method

[image]

Lucene.Net Class Libraries
TokenSettingsCodec..::..SetWeight Method
TokenSettingsCodec Class See Also Send Feedback
Have this method do nothing in order to 'disable' weights.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public abstract void SetWeight(
    Token token,
    float weight
)
Visual Basic
Public MustOverride Sub SetWeight ( _
    token As Token, _
    weight As Single _
)
Visual C++
public:
virtual void SetWeight(
    Token^ token,
    float weight
) abstract

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

weight
Type: System..::..Single

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

See Also

TokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class

[image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Members See Also Send Feedback
A codec that creates a two dimensional matrix by treating tokens from the input stream with 0 position increment as new rows to the current column.

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class TwoDimensionalNonWeightedSynonymTokenSettingsCodec : TokenSettingsCodec
Visual Basic
Public Class TwoDimensionalNonWeightedSynonymTokenSettingsCodec _
    Inherits TokenSettingsCodec
Visual C++
public ref class TwoDimensionalNonWeightedSynonymTokenSettingsCodec : public TokenSettingsCodec

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Codec..::..TokenSettingsCodec
Lucene.Net.Analyzers.Shingle.Codec..::..TwoDimensionalNonWeightedSynonymTokenSettingsCodec

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Members
Lucene.Net.Analyzers.Shingle.Codec Namespace


TwoDimensionalNonWeightedSynonymTokenSettingsCodec Members

[image] [image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Members
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class Constructors Methods See Also Send Feedback

The TwoDimensionalNonWeightedSynonymTokenSettingsCodec type exposes the following members.

Constructors

 | Name | Description
Public method | TwoDimensionalNonWeightedSynonymTokenSettingsCodec | Initializes a new instance of the TwoDimensionalNonWeightedSynonymTokenSettingsCodec class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | (Overrides TokenSettingsCodec..::..GetTokenPositioner(Token).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | (Overrides TokenSettingsCodec..::..GetWeight(Token).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | (Overrides TokenSettingsCodec..::..SetTokenPositioner(Token, TokenPositioner).)
Public method | SetWeight | (Overrides TokenSettingsCodec..::..SetWeight(Token, Single).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


TwoDimensionalNonWeightedSynonymTokenSettingsCodec Constructor

[image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Constructor
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class See Also Send Feedback
Initializes a new instance of the TwoDimensionalNonWeightedSynonymTokenSettingsCodec class

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public TwoDimensionalNonWeightedSynonymTokenSettingsCodec()
Visual Basic
Public Sub New
Visual C++
public:
TwoDimensionalNonWeightedSynonymTokenSettingsCodec()

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


TwoDimensionalNonWeightedSynonymTokenSettingsCodec Methods

[image] [image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Methods
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class See Also Send Feedback

The TwoDimensionalNonWeightedSynonymTokenSettingsCodec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTokenPositioner | (Overrides TokenSettingsCodec..::..GetTokenPositioner(Token).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight | (Overrides TokenSettingsCodec..::..GetWeight(Token).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTokenPositioner | (Overrides TokenSettingsCodec..::..SetTokenPositioner(Token, TokenPositioner).)
Public method | SetWeight | (Overrides TokenSettingsCodec..::..SetWeight(Token, Single).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetTokenPositioner Method

[image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec..::..GetTokenPositioner Method
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override TokenPositioner GetTokenPositioner(
    Token token
)
Visual Basic
Public Overrides Function GetTokenPositioner ( _
    token As Token _
) As TokenPositioner
Visual C++
public:
virtual TokenPositioner^ GetTokenPositioner(
    Token^ token
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.GetTokenPositioner(Lucene.Net.Analysis.Token)"]

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


GetWeight Method

[image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec..::..GetWeight Method
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override float GetWeight(
    Token token
)
Visual Basic
Public Overrides Function GetWeight ( _
    token As Token _
) As Single
Visual C++
public:
virtual float GetWeight(
    Token^ token
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.GetWeight(Lucene.Net.Analysis.Token)"]

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetTokenPositioner Method

[image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec..::..SetTokenPositioner Method
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void SetTokenPositioner(
    Token token,
    TokenPositioner tokenPositioner
)
Visual Basic
Public Overrides Sub SetTokenPositioner ( _
    token As Token, _
    tokenPositioner As TokenPositioner _
)
Visual C++
public:
virtual void SetTokenPositioner(
    Token^ token,
    TokenPositioner^ tokenPositioner
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

tokenPositioner
Type: Lucene.Net.Analyzers.Shingle..::..TokenPositioner

[Missing <param name="tokenPositioner"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.SetTokenPositioner(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.TokenPositioner)"]

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


SetWeight Method

[image]

Lucene.Net Class Libraries
TwoDimensionalNonWeightedSynonymTokenSettingsCodec..::..SetWeight Method
TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

Namespace: Lucene.Net.Analyzers.Shingle.Codec
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override void SetWeight(
    Token token,
    float weight
)
Visual Basic
Public Overrides Sub SetWeight ( _
    token As Token, _
    weight As Single _
)
Visual C++
public:
virtual void SetWeight(
    Token^ token,
    float weight
) override

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

weight
Type: System..::..Single

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Codec.TwoDimensionalNonWeightedSynonymTokenSettingsCodec.SetWeight(Lucene.Net.Analysis.Token,System.Single)"]

See Also

TwoDimensionalNonWeightedSynonymTokenSettingsCodec Class
Lucene.Net.Analyzers.Shingle.Codec Namespace


Lucene.Net.Analyzers.Shingle.Matrix Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Analyzers.Shingle.Matrix Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Analyzers.Shingle.Matrix"]

Classes

Class | Description
Public class | Column
Public class Matrix
A column focused matrix in three dimensions:
            Token[column][row][z-axis] {
                {{hello}, {greetings, and, salutations}},
                {{world}, {earth}, {tellus}}
            };
todo consider row groups to indicate that shingles is only to contain permutations with texts in that same row group.
Public class | MatrixPermutationIterator
Public class | Row


Column Class

[image]

Lucene.Net Class Libraries
Column Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analyzers.Shingle.Matrix.Column"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class Column
Visual Basic
Public Class Column
Visual C++
public ref class Column

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Matrix..::..Column

See Also

Column Members
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Members

[image] [image]

Lucene.Net Class Libraries
Column Members
Column Class Constructors Methods Properties See Also Send Feedback

The Column type exposes the following members.

Constructors

 | Name | Description
Public method | Column(Matrix) | Initializes a new instance of the Column class
Public method | Column(Token, Matrix) | Initializes a new instance of the Column class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Index |
Public property | IsFirst |
Public property | IsLast |
Public property | Matrix |
Public property | Rows |

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Constructor

[image] [image]

Lucene.Net Class Libraries
Column Constructor
Column Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Column(Matrix) | Initializes a new instance of the Column class
Public method | Column(Token, Matrix) | Initializes a new instance of the Column class

See Also

Column Class
Column Members
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Constructor (Matrix)

[image]

Lucene.Net Class Libraries
Column Constructor (Matrix)
Column Class See Also Send Feedback
Initializes a new instance of the Column class

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Column(
    Matrix enclosingInstance
)
Visual Basic
Public Sub New ( _
    enclosingInstance As Matrix _
)
Visual C++
public:
Column(
    Matrix^ enclosingInstance
)

Parameters

enclosingInstance
Type: Lucene.Net.Analyzers.Shingle.Matrix..::..Matrix

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Column.#ctor(Lucene.Net.Analyzers.Shingle.Matrix.Matrix)"]

See Also

Column Class
Column Overload
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Constructor (Token, Matrix)

[image]

Lucene.Net Class Libraries
Column Constructor (Token, Matrix)
Column Class See Also Send Feedback
Initializes a new instance of the Column class

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Column(
    Token token,
    Matrix enclosingInstance
)
Visual Basic
Public Sub New ( _
    token As Token, _
    enclosingInstance As Matrix _
)
Visual C++
public:
Column(
    Token^ token,
    Matrix^ enclosingInstance
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Column.#ctor(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.Matrix.Matrix)"]

enclosingInstance
Type: Lucene.Net.Analyzers.Shingle.Matrix..::..Matrix

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Column.#ctor(Lucene.Net.Analysis.Token,Lucene.Net.Analyzers.Shingle.Matrix.Matrix)"]

See Also

Column Class
Column Overload
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Methods

[image] [image]

Lucene.Net Class Libraries
Column Methods
Column Class See Also Send Feedback

The Column type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Column..::..ToString Method
Column Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Column.ToString"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Column.ToString"]

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Properties

[image] [image]

Lucene.Net Class Libraries
Column Properties
Column Class See Also Send Feedback

The Column type exposes the following members.

Properties

 | Name | Description
Public property | Index |
Public property | IsFirst |
Public property | IsLast |
Public property | Matrix |
Public property | Rows |

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Index Property

[image]

Lucene.Net Class Libraries
Column..::..Index Property
Column Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Column.Index"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


IsFirst Property

[image]

Lucene.Net Class Libraries
Column..::..IsFirst Property
Column Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Column.IsFirst"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public bool IsFirst { get; set; }
Visual Basic
Public Property IsFirst As Boolean
    Get
    Set
Visual C++
public:
property bool IsFirst {
    bool get ();
    void set (bool value);
}

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


IsLast Property

[image]

Lucene.Net Class Libraries
Column..::..IsLast Property
Column Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Column.IsLast"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public bool IsLast { get; set; }
Visual Basic
Public Property IsLast As Boolean
    Get
    Set
Visual C++
public:
property bool IsLast {
    bool get ();
    void set (bool value);
}

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Matrix Property

[image]

Lucene.Net Class Libraries
Column..::..Matrix Property
Column Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Column.Matrix"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Matrix Matrix { get; private set; }
Visual Basic
Public Property Matrix As Matrix
    Get
    Private Set
Visual C++
public:
property Matrix^ Matrix {
    Matrix^ get ();
    private: void set (Matrix^ value);
}

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Rows Property

[image]

Lucene.Net Class Libraries
Column..::..Rows Property
Column Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Column.Rows"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public List<Row> Rows { get; private set; }
Visual Basic
Public Property Rows As List(Of Row)
    Get
    Private Set
Visual C++
public:
property List<Row^>^ Rows {
    List<Row^>^ get ();
    private: void set (List<Row^>^ value);
}

See Also

Column Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Matrix Class

[image]

Lucene.Net Class Libraries
Matrix Class
Members See Also Send Feedback
A column focused matrix in three dimensions:
            Token[column][row][z-axis] {
                {{hello}, {greetings, and, salutations}},
                {{world}, {earth}, {tellus}}
            };
todo consider row groups to indicate that shingles is only to contain permutations with texts in that same row group.

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class Matrix
Visual Basic
Public Class Matrix
Visual C++
public ref class Matrix

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Matrix..::..Matrix

See Also

Matrix Members
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Matrix Members

[image] [image]

Lucene.Net Class Libraries
Matrix Members
Matrix Class Constructors Methods Properties See Also Send Feedback

The Matrix type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix | Initializes a new instance of the Matrix class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PermutationIterator |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Columns |

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Matrix Constructor

[image]

Lucene.Net Class Libraries
Matrix Constructor
Matrix Class See Also Send Feedback
Initializes a new instance of the Matrix class

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Matrix()
Visual Basic
Public Sub New
Visual C++
public:
Matrix()

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Matrix Methods

[image] [image]

Lucene.Net Class Libraries
Matrix Methods
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PermutationIterator |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


PermutationIterator Method

[image]

Lucene.Net Class Libraries
Matrix..::..PermutationIterator Method
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Matrix.PermutationIterator"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public MatrixPermutationIterator PermutationIterator()
Visual Basic
Public Function PermutationIterator As MatrixPermutationIterator
Visual C++
public:
MatrixPermutationIterator^ PermutationIterator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Matrix.PermutationIterator"]

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Matrix..::..ToString Method
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Matrix.ToString"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Matrix.ToString"]

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Matrix Properties

[image] [image]

Lucene.Net Class Libraries
Matrix Properties
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Properties

 | Name | Description
Public property | Columns |

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Columns Property

[image]

Lucene.Net Class Libraries
Matrix..::..Columns Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Matrix.Columns"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public List<Column> Columns { get; private set; }
Visual Basic
Public Property Columns As List(Of Column)
    Get
    Private Set
Visual C++
public:
property List<Column^>^ Columns {
    List<Column^>^ get ();
    private: void set (List<Column^>^ value);
}

See Also

Matrix Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


MatrixPermutationIterator Class

[image]

Lucene.Net Class Libraries
MatrixPermutationIterator Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analyzers.Shingle.Matrix.MatrixPermutationIterator"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class MatrixPermutationIterator
Visual Basic
Public Class MatrixPermutationIterator
Visual C++
public ref class MatrixPermutationIterator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Matrix..::..MatrixPermutationIterator

See Also

MatrixPermutationIterator Members
Lucene.Net.Analyzers.Shingle.Matrix Namespace


MatrixPermutationIterator Members

[image] [image]

Lucene.Net Class Libraries
MatrixPermutationIterator Members
MatrixPermutationIterator Class Constructors Methods See Also Send Feedback

The MatrixPermutationIterator type exposes the following members.

Constructors

 | Name | Description
Public method | MatrixPermutationIterator | Initializes a new instance of the MatrixPermutationIterator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNext |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixPermutationIterator Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


MatrixPermutationIterator Constructor

[image]

Lucene.Net Class Libraries
MatrixPermutationIterator Constructor
MatrixPermutationIterator Class See Also Send Feedback
Initializes a new instance of the MatrixPermutationIterator class

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public MatrixPermutationIterator(
    Matrix enclosingInstance
)
Visual Basic
Public Sub New ( _
    enclosingInstance As Matrix _
)
Visual C++
public:
MatrixPermutationIterator(
    Matrix^ enclosingInstance
)

Parameters

enclosingInstance
Type: Lucene.Net.Analyzers.Shingle.Matrix..::..Matrix

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.MatrixPermutationIterator.#ctor(Lucene.Net.Analyzers.Shingle.Matrix.Matrix)"]

See Also

MatrixPermutationIterator Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


MatrixPermutationIterator Methods

[image] [image]

Lucene.Net Class Libraries
MatrixPermutationIterator Methods
MatrixPermutationIterator Class See Also Send Feedback

The MatrixPermutationIterator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNext |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixPermutationIterator Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


HasNext Method

[image]

Lucene.Net Class Libraries
MatrixPermutationIterator..::..HasNext Method
MatrixPermutationIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.MatrixPermutationIterator.HasNext"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public bool HasNext()
Visual Basic
Public Function HasNext As Boolean
Visual C++
public:
bool HasNext()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.MatrixPermutationIterator.HasNext"]

See Also

MatrixPermutationIterator Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Next Method

[image]

Lucene.Net Class Libraries
MatrixPermutationIterator..::..Next Method
MatrixPermutationIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.MatrixPermutationIterator.Next"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Row[] Next()
Visual Basic
Public Function Next As Row()
Visual C++
public:
array<Row^>^ Next()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.MatrixPermutationIterator.Next"]

See Also

MatrixPermutationIterator Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Row Class

[image]

Lucene.Net Class Libraries
Row Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Analyzers.Shingle.Matrix.Row"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public class Row
Visual Basic
Public Class Row
Visual C++
public ref class Row

Inheritance Hierarchy

System..::..Object
Lucene.Net.Analyzers.Shingle.Matrix..::..Row

See Also

Row Members
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Row Members

[image] [image]

Lucene.Net Class Libraries
Row Members
Row Class Constructors Methods Properties See Also Send Feedback

The Row type exposes the following members.

Constructors

 | Name | Description
Public method | Row | Initializes a new instance of the Row class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Column |
Public property | Index |
Public property | Tokens |

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Row Constructor

[image]

Lucene.Net Class Libraries
Row Constructor
Row Class See Also Send Feedback
Initializes a new instance of the Row class

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Row(
    Column enclosingInstance
)
Visual Basic
Public Sub New ( _
    enclosingInstance As Column _
)
Visual C++
public:
Row(
    Column^ enclosingInstance
)

Parameters

enclosingInstance
Type: Lucene.Net.Analyzers.Shingle.Matrix..::..Column

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Row.#ctor(Lucene.Net.Analyzers.Shingle.Matrix.Column)"]

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Row Methods

[image] [image]

Lucene.Net Class Libraries
Row Methods
Row Class See Also Send Feedback

The Row type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Row..::..ToString Method
Row Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Row.ToString"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Analyzers.Shingle.Matrix.Row.ToString"]

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Row Properties

[image] [image]

Lucene.Net Class Libraries
Row Properties
Row Class See Also Send Feedback

The Row type exposes the following members.

Properties

 | Name | Description
Public property | Column |
Public property | Index |
Public property | Tokens |

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Column Property

[image]

Lucene.Net Class Libraries
Row..::..Column Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Row.Column"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public Column Column { get; private set; }
Visual Basic
Public Property Column As Column
    Get
    Private Set
Visual C++
public:
property Column^ Column {
    Column^ get ();
    private: void set (Column^ value);
}

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Index Property

[image]

Lucene.Net Class Libraries
Row..::..Index Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Row.Index"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Tokens Property

[image]

Lucene.Net Class Libraries
Row..::..Tokens Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Analyzers.Shingle.Matrix.Row.Tokens"]

Namespace: Lucene.Net.Analyzers.Shingle.Matrix
Assembly: Lucene.Net.Contrib.Analyzers (in Lucene.Net.Contrib.Analyzers.dll) Version: 2.9.2.1 (2.9.2.1)

Syntax

C#
public LinkedList<Token> Tokens { get; set; }
Visual Basic
Public Property Tokens As LinkedList(Of Token)
    Get
    Set
Visual C++
public:
property LinkedList<Token^>^ Tokens {
    LinkedList<Token^>^ get ();
    void set (LinkedList<Token^>^ value);
}

See Also

Row Class
Lucene.Net.Analyzers.Shingle.Matrix Namespace


Lucene.Net.Documents Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Documents Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Documents"]

Classes

Class Description
Public class AbstractField
Public class CompressionTools
Simple utility class providing static methods to compress and decompress binary data for stored fields. This class uses java.util.zip.Deflater and Inflater classes to compress and decompress, which is the same format previously used by the now deprecated Field.Store.COMPRESS.
Public class DateField Obsolete.
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders by date, which makes them suitable for use as field values and search terms.

Note that this class saves dates with millisecond granularity, which is bad for {@link TermRangeQuery} and {@link PrefixQuery}, as those queries are expanded to a BooleanQuery with a potentially large number of terms when searching. Thus you might want to use {@link DateTools} instead.

Note: dates before 1970 cannot be used, and therefore cannot be indexed when using this class. See {@link DateTools} for an alternative without such a limitation.

Another approach is {@link NumericUtils}, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a {@link Date} or {@link Calendar}, just get the unix timestamp as

CopyC#
long
using {@link Date#getTime} or {@link Calendar#getTimeInMillis} and index this as a numeric value with {@link NumericField} and use {@link NumericRangeQuery} to query it.
Public class DateTools
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders them by date, which makes them suitable for use as field values and search terms.

This class also helps you to limit the resolution of your dates. Do not save dates with a finer resolution than you really need, as then RangeQuery and PrefixQuery will require more memory and become slower.

Compared to {@link DateField} the strings generated by the methods in this class take slightly more space, unless your selected resolution is set to

CopyC#
Resolution.DAY
or lower.

Another approach is {@link NumericUtils}, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a {@link Date} or {@link Calendar}, just get the unix timestamp as

CopyC#
long
using {@link Date#getTime} or {@link Calendar#getTimeInMillis} and index this as a numeric value with {@link NumericField} and use {@link NumericRangeQuery} to query it.
Public class DateTools..::..Resolution
Specifies the time granularity.
Public class Document
Documents are the unit of indexing and search. A Document is a set of fields. Each field has a name and a textual value. A field may be {@link Fieldable#IsStored() stored} with the document, in which case it is returned with search hits on the document. Thus each document should typically contain one or more stored fields which uniquely identify it.

Note that fields which are not {@link Fieldable#IsStored() stored} are not available in documents retrieved from the index, e.g. with {@link ScoreDoc#doc}, {@link Searcher#Doc(int)} or {@link IndexReader#Document(int)}.

Public class Field
A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.
Public class Field..::..Index
Specifies whether and how a field should be indexed.
Public class Field..::..Store
Specifies whether and how a field should be stored.
Public class Field..::..TermVector
Specifies whether and how a field should have term vectors.
Public class FieldSelectorResult
Provides information about what should be done with this Field
Public class LoadFirstFieldSelector
Load the First field and break.

See {@link FieldSelectorResult#LOAD_AND_BREAK}

Public class MapFieldSelector
A {@link FieldSelector} based on a Map of field names to {@link FieldSelectorResult}s
Public class NumberTools Obsolete.
Provides support for converting longs to Strings, and back again. The strings are structured so that lexicographic sorting order is preserved.

That is, if l1 is less than l2 for any two longs l1 and l2, then NumberTools.longToString(l1) is lexicographically less than NumberTools.longToString(l2). (Similarly for "greater than" and "equals".)

This class handles all long values (unlike {@link Lucene.Net.Documents.DateField}).

Public class NumericField

This class provides a {@link Field} that enables indexing of numeric values for efficient range filtering and sorting. Here's an example usage, adding an int value:

            document.add(new NumericField(name).setIntValue(value));
For optimal performance, re-use the
CopyC#
NumericField
 and {@link Document} instance for more than one document:
            NumericField field = new NumericField(name);
            Document document = new Document();
            document.add(field);

            for(all documents) {
            ...
            field.setIntValue(value)
            writer.addDocument(document);
            ...
            }

The java native types

CopyC#
int
,
CopyC#
long
,
CopyC#
float
 and
CopyC#
double
 are directly supported. However, any value that can be converted into these native types can also be indexed. For example, date/time values represented by a {@link java.util.Date} can be translated into a long value using the {@link java.util.Date#getTime} method. If you don't need millisecond precision, you can quantize the value, either by dividing the result of {@link java.util.Date#getTime} or using the separate getters (for year, month, etc.) to construct an
CopyC#
int
 or
CopyC#
long
 value.

To perform range querying or filtering against a

CopyC#
NumericField
, use {@link NumericRangeQuery} or {@link NumericRangeFilter}. To sort according to a
CopyC#
NumericField
, use the normal numeric sort types, eg {@link SortField#INT} (note that {@link SortField#AUTO} will not work with these fields).
CopyC#
NumericField
 values can also be loaded directly from {@link FieldCache}.

By default, a

CopyC#
NumericField
's value is not stored but is indexed for range filtering and sorting. You can use the {@link #NumericField(String,Field.Store,boolean)} constructor if you need to change these defaults.

You may add the same field name as a

CopyC#
NumericField
to the same document more than once. Range querying and filtering will be the logical OR of all values; so a range query will hit all documents that have at least one value in the range. However sort behavior is not defined. If you need to sort, you should separately index a single-valued
CopyC#
NumericField
.

A

CopyC#
NumericField
will consume somewhat more disk space in the index than an ordinary single-valued field. However, for a typical index that includes substantial textual content per document, this increase will likely be in the noise.

Within Lucene, each numeric value is indexed as a trie structure, where each term is logically assigned to larger and larger pre-defined brackets (which are simply lower-precision representations of the value). The step size between each successive bracket is called the

CopyC#
precisionStep
, measured in bits. Smaller
CopyC#
precisionStep
 values result in larger number of brackets, which consumes more disk space in the index but may result in faster range search performance. The default value, 4, was selected for a reasonable tradeoff of disk space consumption versus performance. You can use the expert constructor {@link #NumericField(String,int,Field.Store,boolean)} if you'd like to change the value. Note that you must also specify a congruent value when creating {@link NumericRangeQuery} or {@link NumericRangeFilter}. For low cardinality fields larger precision steps are good. If the cardinality is < 100, it is fair to use {@link Integer#MAX_VALUE}, which produces one term per value.

For more information on the internals of numeric trie indexing, including the

CopyC#
precisionStep
configuration, see {@link NumericRangeQuery}. The format of indexed values is described in {@link NumericUtils}.

If you only need to sort by numeric value, and never run range querying/filtering, you can index using a

CopyC#
precisionStep
of {@link Integer#MAX_VALUE}. This will minimize disk space consumed.

More advanced users can instead use {@link NumericTokenStream} directly, when indexing numbers. This class is a wrapper around this token stream type for easier, more intuitive usage.

NOTE: This class is only used during indexing. When retrieving the stored field value from a {@link Document} instance after search, you will get a conventional {@link Fieldable} instance where the numeric values are returned as {@link String}s (according to

CopyC#
toString(value)
of the used data type).

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class SetBasedFieldSelector
Declare what fields to load normally and what fields to load lazily

Interfaces

 | Interface | Description
Public interface | Fieldable | Synonymous with {@link Field}. WARNING: This interface may change within minor versions, despite Lucene's backward compatibility requirements. This means new methods may be added from version to version. This change only affects the Fieldable API; other backwards compatibility promises remain intact. For example, Lucene can still read and write indices created within the same major version.
Public interface | FieldSelector | Similar to a {@link java.io.FileFilter}, the FieldSelector allows one to make decisions about what Fields get loaded on a {@link Document} by {@link Lucene.Net.Index.IndexReader#Document(int,Lucene.Net.Documents.FieldSelector)}


AbstractField Class

[image]

Lucene.Net Class Libraries
AbstractField Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Documents.AbstractField"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class AbstractField : Fieldable
Visual Basic
<SerializableAttribute> _
Public MustInherit Class AbstractField _
    Implements Fieldable
Visual C++
[SerializableAttribute]
public ref class AbstractField abstract : Fieldable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..AbstractField
Lucene.Net.Documents..::..Field
Lucene.Net.Documents..::..NumericField

See Also

AbstractField Members
Lucene.Net.Documents Namespace


AbstractField Members

[image] [image]

Lucene.Net Class Libraries
AbstractField Members
AbstractField Class Constructors Methods Fields See Also Send Feedback

The AbstractField type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractField()()()() | Initializes a new instance of the AbstractField class
Protected method | AbstractField(String, Field..::..Store, Field..::..Index, Field..::..TermVector) | Initializes a new instance of the AbstractField class

Methods

Name | Description
Public method | BinaryValue
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue(array<Byte>[]()[][])
Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetOmitNorms
True if norms are omitted for this indexed field
Public method | GetOmitTermFreqAndPositions
Public method | GetOmitTf | Obsolete.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsBinary
True iff the value of the filed is stored as binary
Public method IsCompressed
True if the value of the field is stored and compressed within the index
Public method IsIndexed
True iff the value of the field is to be indexed, so that it may be searched on.
Public method | IsLazy
Public method IsStored
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
Public method IsStoreOffsetWithTermVector
True iff terms are stored as term vector together with their offsets (start and end position in source text).
Public method IsStorePositionWithTermVector
True iff terms are stored as term vector together with their token positions.
Public method IsTermVectorStored
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
Public method IsTokenized
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public method | ReaderValue
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
Public method SetOmitTermFreqAndPositions
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

Public method | SetOmitTf | Obsolete.
Protected method | SetStoreTermVector
Public method | StringValue
Public method | TokenStreamValue
Public method ToString
Prints a Field for human consumption.
(Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | binaryLength |
Protected field | binaryOffset |
Protected field | boost |
Protected field | fieldsData |
Protected field | isBinary |
Protected field | isCompressed |
Protected field | isIndexed |
Protected field | isStored |
Protected field | isTokenized |
Protected field | lazy |
Protected field | name |
Protected field | omitNorms |
Protected field | omitTermFreqAndPositions |
Protected field | storeOffsetWithTermVector |
Protected field | storePositionWithTermVector |
Protected field | storeTermVector |
Protected field | tokenStream |

See Also

AbstractField Class
Lucene.Net.Documents Namespace


AbstractField Constructor

[image] [image]

Lucene.Net Class Libraries
AbstractField Constructor
AbstractField Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AbstractField()()()() | Initializes a new instance of the AbstractField class
Protected method | AbstractField(String, Field..::..Store, Field..::..Index, Field..::..TermVector) | Initializes a new instance of the AbstractField class

See Also

AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace


AbstractField Constructor

[image]

Lucene.Net Class Libraries
AbstractField Constructor
AbstractField Class See Also Send Feedback
Initializes a new instance of the AbstractField class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal AbstractField()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
AbstractField()

See Also

AbstractField Class
AbstractField Overload
Lucene.Net.Documents Namespace


AbstractField Constructor (String, Field.Store, Field.Index, Field.TermVector)

[image]

Lucene.Net Class Libraries
AbstractField Constructor (String, Field..::..Store, Field..::..Index, Field..::..TermVector)
AbstractField Class See Also Send Feedback
Initializes a new instance of the AbstractField class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal AbstractField(
    string name,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Visual Basic
Protected Friend Sub New ( _
    name As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
Visual C++
protected public:
AbstractField(
    String^ name,
    Field..::..Store^ store,
    Field..::..Index^ index,
    Field..::..TermVector^ termVector
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Documents.AbstractField.#ctor(System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index,Lucene.Net.Documents.Field.TermVector)"]

store
Type: Lucene.Net.Documents..::..Field..::..Store

[Missing <param name="store"/> documentation for "M:Lucene.Net.Documents.AbstractField.#ctor(System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index,Lucene.Net.Documents.Field.TermVector)"]

index
Type: Lucene.Net.Documents..::..Field..::..Index

[Missing <param name="index"/> documentation for "M:Lucene.Net.Documents.AbstractField.#ctor(System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index,Lucene.Net.Documents.Field.TermVector)"]

termVector
Type: Lucene.Net.Documents..::..Field..::..TermVector

[Missing <param name="termVector"/> documentation for "M:Lucene.Net.Documents.AbstractField.#ctor(System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index,Lucene.Net.Documents.Field.TermVector)"]

See Also

AbstractField Class
AbstractField Overload
Lucene.Net.Documents Namespace


AbstractField Fields

[image] [image]

Lucene.Net Class Libraries
AbstractField Fields
AbstractField Class See Also Send Feedback

The AbstractField type exposes the following members.

Fields

 | Name | Description
Protected field | binaryLength |
Protected field | binaryOffset |
Protected field | boost |
Protected field | fieldsData |
Protected field | isBinary |
Protected field | isCompressed |
Protected field | isIndexed |
Protected field | isStored |
Protected field | isTokenized |
Protected field | lazy |
Protected field | name |
Protected field | omitNorms |
Protected field | omitTermFreqAndPositions |
Protected field | storeOffsetWithTermVector |
Protected field | storePositionWithTermVector |
Protected field | storeTermVector |
Protected field | tokenStream |

See Also

AbstractField Class
Lucene.Net.Documents Namespace


binaryLength Field

[image]

Lucene.Net Class Libraries
AbstractField..::..binaryLength Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.binaryLength"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int binaryLength
Visual Basic
Protected Friend binaryLength As Integer
Visual C++
protected public:
int binaryLength

See Also

AbstractField Class
Lucene.Net.Documents Namespace


binaryOffset Field

[image]

Lucene.Net Class Libraries
AbstractField..::..binaryOffset Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.binaryOffset"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int binaryOffset
Visual Basic
Protected Friend binaryOffset As Integer
Visual C++
protected public:
int binaryOffset

See Also

AbstractField Class
Lucene.Net.Documents Namespace


boost Field

[image]

Lucene.Net Class Libraries
AbstractField..::..boost Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.boost"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float boost
Visual Basic
Protected Friend boost As Single
Visual C++
protected public:
float boost

See Also

AbstractField Class
Lucene.Net.Documents Namespace


fieldsData Field

[image]

Lucene.Net Class Libraries
AbstractField..::..fieldsData Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.fieldsData"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Object fieldsData
Visual Basic
Protected Friend fieldsData As Object
Visual C++
protected public:
Object^ fieldsData

See Also

AbstractField Class
Lucene.Net.Documents Namespace


isBinary Field

[image]

Lucene.Net Class Libraries
AbstractField..::..isBinary Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.isBinary"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isBinary
Visual Basic
Protected Friend isBinary As Boolean
Visual C++
protected public:
bool isBinary

See Also

AbstractField Class
Lucene.Net.Documents Namespace


isCompressed Field

[image]

Lucene.Net Class Libraries
AbstractField..::..isCompressed Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.isCompressed"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isCompressed
Visual Basic
Protected Friend isCompressed As Boolean
Visual C++
protected public:
bool isCompressed

See Also

AbstractField Class
Lucene.Net.Documents Namespace


isIndexed Field

[image]

Lucene.Net Class Libraries
AbstractField..::..isIndexed Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.isIndexed"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isIndexed
Visual Basic
Protected Friend isIndexed As Boolean
Visual C++
protected public:
bool isIndexed

See Also

AbstractField Class
Lucene.Net.Documents Namespace


isStored Field

[image]

Lucene.Net Class Libraries
AbstractField..::..isStored Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.isStored"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isStored
Visual Basic
Protected Friend isStored As Boolean
Visual C++
protected public:
bool isStored

See Also

AbstractField Class
Lucene.Net.Documents Namespace


isTokenized Field

[image]

Lucene.Net Class Libraries
AbstractField..::..isTokenized Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.isTokenized"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isTokenized
Visual Basic
Protected Friend isTokenized As Boolean
Visual C++
protected public:
bool isTokenized

See Also

AbstractField Class
Lucene.Net.Documents Namespace


lazy Field

[image]

Lucene.Net Class Libraries
AbstractField..::..lazy Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.lazy"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool lazy
Visual Basic
Protected Friend lazy As Boolean
Visual C++
protected public:
bool lazy

See Also

AbstractField Class
Lucene.Net.Documents Namespace


name Field

[image]

Lucene.Net Class Libraries
AbstractField..::..name Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.name"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string name
Visual Basic
Protected Friend name As String
Visual C++
protected public:
String^ name

See Also

AbstractField Class
Lucene.Net.Documents Namespace


omitNorms Field

[image]

Lucene.Net Class Libraries
AbstractField..::..omitNorms Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.omitNorms"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool omitNorms
Visual Basic
Protected Friend omitNorms As Boolean
Visual C++
protected public:
bool omitNorms

See Also

AbstractField Class
Lucene.Net.Documents Namespace


omitTermFreqAndPositions Field

[image]

Lucene.Net Class Libraries
AbstractField..::..omitTermFreqAndPositions Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.omitTermFreqAndPositions"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool omitTermFreqAndPositions
Visual Basic
Protected Friend omitTermFreqAndPositions As Boolean
Visual C++
protected public:
bool omitTermFreqAndPositions

See Also

AbstractField Class
Lucene.Net.Documents Namespace


storeOffsetWithTermVector Field

[image]

Lucene.Net Class Libraries
AbstractField..::..storeOffsetWithTermVector Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.storeOffsetWithTermVector"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool storeOffsetWithTermVector
Visual Basic
Protected Friend storeOffsetWithTermVector As Boolean
Visual C++
protected public:
bool storeOffsetWithTermVector

See Also

AbstractField Class
Lucene.Net.Documents Namespace


storePositionWithTermVector Field

[image]

Lucene.Net Class Libraries
AbstractField..::..storePositionWithTermVector Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.storePositionWithTermVector"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool storePositionWithTermVector
Visual Basic
Protected Friend storePositionWithTermVector As Boolean
Visual C++
protected public:
bool storePositionWithTermVector

See Also

AbstractField Class
Lucene.Net.Documents Namespace


storeTermVector Field

[image]

Lucene.Net Class Libraries
AbstractField..::..storeTermVector Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.storeTermVector"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool storeTermVector
Visual Basic
Protected Friend storeTermVector As Boolean
Visual C++
protected public:
bool storeTermVector

See Also

AbstractField Class
Lucene.Net.Documents Namespace


tokenStream Field

[image]

Lucene.Net Class Libraries
AbstractField..::..tokenStream Field
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.AbstractField.tokenStream"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TokenStream tokenStream
Visual Basic
Protected Friend tokenStream As TokenStream
Visual C++
protected public:
TokenStream^ tokenStream

See Also

AbstractField Class
Lucene.Net.Documents Namespace


AbstractField Methods

[image] [image]

Lucene.Net Class Libraries
AbstractField Methods
AbstractField Class See Also Send Feedback

The AbstractField type exposes the following members.

Methods

Name | Description
Public method | BinaryValue
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue(array<Byte>[]()[][])
Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetOmitNorms
True if norms are omitted for this indexed field
Public method | GetOmitTermFreqAndPositions
Public method | GetOmitTf | Obsolete.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsBinary
True iff the value of the filed is stored as binary
Public method IsCompressed
True if the value of the field is stored and compressed within the index
Public method IsIndexed
True iff the value of the field is to be indexed, so that it may be searched on.
Public method | IsLazy
Public method IsStored
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
Public method IsStoreOffsetWithTermVector
True iff terms are stored as term vector together with their offsets (start and end position in source text).
Public method IsStorePositionWithTermVector
True iff terms are stored as term vector together with their token positions.
Public method IsTermVectorStored
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
Public method IsTokenized
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public method | ReaderValue
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
Public method SetOmitTermFreqAndPositions
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

Public method | SetOmitTf | Obsolete.
Protected method | SetStoreTermVector
Public method | StringValue
Public method | TokenStreamValue
Public method ToString
Prints a Field for human consumption.
(Overrides Object..::..ToString()()()().)

See Also

AbstractField Class
Lucene.Net.Documents Namespace


BinaryValue Method

[image]

Lucene.Net Class Libraries
AbstractField..::..BinaryValue Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.BinaryValue"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract byte[] BinaryValue()
Visual Basic
Public MustOverride Function BinaryValue As Byte()
Visual C++
public:
virtual array<unsigned char>^ BinaryValue() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.BinaryValue"]

Implements

Fieldable..::..BinaryValue()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


GetBinaryLength Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetBinaryLength Method
AbstractField Class See Also Send Feedback
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetBinaryLength()
Visual Basic
Public Overridable Function GetBinaryLength As Integer
Visual C++
public:
virtual int GetBinaryLength()

Return Value

length of byte[] segment that represents this Field value

Implements

Fieldable..::..GetBinaryLength()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


GetBinaryOffset Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetBinaryOffset Method
AbstractField Class See Also Send Feedback
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetBinaryOffset()
Visual Basic
Public Overridable Function GetBinaryOffset As Integer
Visual C++
public:
virtual int GetBinaryOffset()

Return Value

index of the first character in byte[] segment that represents this Field value

Implements

Fieldable..::..GetBinaryOffset()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image] [image]

Lucene.Net Class Libraries
AbstractField..::..GetBinaryValue Method
AbstractField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBinaryValue()()()() | Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue(array<Byte>[]()[][]) |

See Also

AbstractField Class
AbstractField Members
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetBinaryValue Method
AbstractField Class See Also Send Feedback
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] GetBinaryValue()
Visual Basic
Public Overridable Function GetBinaryValue As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetBinaryValue()

Return Value

reference to the Field value as byte[].

Implements

Fieldable..::..GetBinaryValue()()()()

See Also

AbstractField Class
GetBinaryValue Overload
Lucene.Net.Documents Namespace


GetBinaryValue Method (Byte[])

[image]

Lucene.Net Class Libraries
AbstractField..::..GetBinaryValue Method (array<Byte>[]()[][])
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.GetBinaryValue(System.Byte[])"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] GetBinaryValue(
    byte[] result
)
Visual Basic
Public Overridable Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
)

Parameters

result
Type: array< System..::..Byte >[]()[][]

[Missing <param name="result"/> documentation for "M:Lucene.Net.Documents.AbstractField.GetBinaryValue(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.GetBinaryValue(System.Byte[])"]

Implements

Fieldable..::..GetBinaryValue(array<Byte>[]()[][])

See Also

AbstractField Class
GetBinaryValue Overload
Lucene.Net.Documents Namespace


GetBoost Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetBoost Method
AbstractField Class See Also Send Feedback
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetBoost()
Visual Basic
Public Overridable Function GetBoost As Single
Visual C++
public:
virtual float GetBoost()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.GetBoost"]

Implements

Fieldable..::..GetBoost()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace
AbstractField..::..SetBoost(Single)


GetOmitNorms Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetOmitNorms Method
AbstractField Class See Also Send Feedback
True if norms are omitted for this indexed field

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetOmitNorms()
Visual Basic
Public Overridable Function GetOmitNorms As Boolean
Visual C++
public:
virtual bool GetOmitNorms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.GetOmitNorms"]

Implements

Fieldable..::..GetOmitNorms()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


GetOmitTermFreqAndPositions Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetOmitTermFreqAndPositions Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.GetOmitTermFreqAndPositions"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetOmitTermFreqAndPositions()
Visual Basic
Public Overridable Function GetOmitTermFreqAndPositions As Boolean
Visual C++
public:
virtual bool GetOmitTermFreqAndPositions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.GetOmitTermFreqAndPositions"]

See Also

AbstractField Class
Lucene.Net.Documents Namespace
[!:setOmitTermFreqAndPositions]


GetOmitTf Method

[image]

Lucene.Net Class Libraries
AbstractField..::..GetOmitTf Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.GetOmitTf"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Renamed to GetOmitTermFreqAndPositions")]
public virtual bool GetOmitTf()
Visual Basic
<ObsoleteAttribute("Renamed to GetOmitTermFreqAndPositions")> _
Public Overridable Function GetOmitTf As Boolean
Visual C++
[ObsoleteAttribute(L"Renamed to GetOmitTermFreqAndPositions")]
public:
virtual bool GetOmitTf()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.GetOmitTf"]

Implements

Fieldable..::..GetOmitTf()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsBinary Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsBinary Method
AbstractField Class See Also Send Feedback
True iff the value of the filed is stored as binary

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsBinary()
Visual Basic
Public Function IsBinary As Boolean
Visual C++
public:
virtual bool IsBinary() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsBinary"]

Implements

Fieldable..::..IsBinary()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsCompressed Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsCompressed Method
AbstractField Class See Also Send Feedback
True if the value of the field is stored and compressed within the index

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsCompressed()
Visual Basic
Public Function IsCompressed As Boolean
Visual C++
public:
virtual bool IsCompressed() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsCompressed"]

Implements

Fieldable..::..IsCompressed()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsIndexed Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsIndexed Method
AbstractField Class See Also Send Feedback
True iff the value of the field is to be indexed, so that it may be searched on.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsIndexed()
Visual Basic
Public Function IsIndexed As Boolean
Visual C++
public:
virtual bool IsIndexed() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsIndexed"]

Implements

Fieldable..::..IsIndexed()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsLazy Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsLazy Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.IsLazy"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsLazy()
Visual Basic
Public Overridable Function IsLazy As Boolean
Visual C++
public:
virtual bool IsLazy()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsLazy"]

Implements

Fieldable..::..IsLazy()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsStored Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsStored Method
AbstractField Class See Also Send Feedback
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsStored()
Visual Basic
Public Function IsStored As Boolean
Visual C++
public:
virtual bool IsStored() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsStored"]

Implements

Fieldable..::..IsStored()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsStoreOffsetWithTermVector Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsStoreOffsetWithTermVector Method
AbstractField Class See Also Send Feedback
True iff terms are stored as term vector together with their offsets (start and end position in source text).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsStoreOffsetWithTermVector()
Visual Basic
Public Overridable Function IsStoreOffsetWithTermVector As Boolean
Visual C++
public:
virtual bool IsStoreOffsetWithTermVector()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsStoreOffsetWithTermVector"]

Implements

Fieldable..::..IsStoreOffsetWithTermVector()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsStorePositionWithTermVector Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsStorePositionWithTermVector Method
AbstractField Class See Also Send Feedback
True iff terms are stored as term vector together with their token positions.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsStorePositionWithTermVector()
Visual Basic
Public Overridable Function IsStorePositionWithTermVector As Boolean
Visual C++
public:
virtual bool IsStorePositionWithTermVector()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsStorePositionWithTermVector"]

Implements

Fieldable..::..IsStorePositionWithTermVector()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


IsTermVectorStored Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsTermVectorStored Method
AbstractField Class See Also Send Feedback
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsTermVectorStored()
Visual Basic
Public Function IsTermVectorStored As Boolean
Visual C++
public:
virtual bool IsTermVectorStored() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsTermVectorStored"]

Implements

Fieldable..::..IsTermVectorStored()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace
IndexReader..::..GetTermFreqVector(Int32, String)


IsTokenized Method

[image]

Lucene.Net Class Libraries
AbstractField..::..IsTokenized Method
AbstractField Class See Also Send Feedback
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsTokenized()
Visual Basic
Public Function IsTokenized As Boolean
Visual C++
public:
virtual bool IsTokenized() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.IsTokenized"]

Implements

Fieldable..::..IsTokenized()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


Name Method

[image]

Lucene.Net Class Libraries
AbstractField..::..Name Method
AbstractField Class See Also Send Feedback
Returns the name of the field as an interned string. For example "date", "title", "body", ...

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Name()
Visual Basic
Public Overridable Function Name As String
Visual C++
public:
virtual String^ Name()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.Name"]

Implements

Fieldable..::..Name()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


ReaderValue Method

[image]

Lucene.Net Class Libraries
AbstractField..::..ReaderValue Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.ReaderValue"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TextReader ReaderValue()
Visual Basic
Public MustOverride Function ReaderValue As TextReader
Visual C++
public:
virtual TextReader^ ReaderValue() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.ReaderValue"]

Implements

Fieldable..::..ReaderValue()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


SetBoost Method

[image]

Lucene.Net Class Libraries
AbstractField..::..SetBoost Method
AbstractField Class See Also Send Feedback
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetBoost(
    float boost
)
Visual Basic
Public Overridable Sub SetBoost ( _
    boost As Single _
)
Visual C++
public:
virtual void SetBoost(
    float boost
)

Parameters

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Documents.AbstractField.SetBoost(System.Single)"]

Implements

Fieldable..::..SetBoost(Single)

See Also

AbstractField Class
Lucene.Net.Documents Namespace
Document..::..SetBoost(Single)
Similarity..::..ComputeNorm(String, FieldInvertState)
Similarity..::..EncodeNorm(Single)


SetOmitNorms Method

[image]

Lucene.Net Class Libraries
AbstractField..::..SetOmitNorms Method
AbstractField Class See Also Send Feedback
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetOmitNorms(
    bool omitNorms
)
Visual Basic
Public Overridable Sub SetOmitNorms ( _
    omitNorms As Boolean _
)
Visual C++
public:
virtual void SetOmitNorms(
    bool omitNorms
)

Parameters

omitNorms
Type: System..::..Boolean

[Missing <param name="omitNorms"/> documentation for "M:Lucene.Net.Documents.AbstractField.SetOmitNorms(System.Boolean)"]

Implements

Fieldable..::..SetOmitNorms(Boolean)

See Also

AbstractField Class
Lucene.Net.Documents Namespace


SetOmitTermFreqAndPositions Method

[image]

Lucene.Net Class Libraries
AbstractField..::..SetOmitTermFreqAndPositions Method
AbstractField Class See Also Send Feedback
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetOmitTermFreqAndPositions(
    bool omitTermFreqAndPositions
)
Visual Basic
Public Overridable Sub SetOmitTermFreqAndPositions ( _
    omitTermFreqAndPositions As Boolean _
)
Visual C++
public:
virtual void SetOmitTermFreqAndPositions(
    bool omitTermFreqAndPositions
)

Parameters

omitTermFreqAndPositions
Type: System..::..Boolean

[Missing <param name="omitTermFreqAndPositions"/> documentation for "M:Lucene.Net.Documents.AbstractField.SetOmitTermFreqAndPositions(System.Boolean)"]

See Also

AbstractField Class
Lucene.Net.Documents Namespace


SetOmitTf Method

[image]

Lucene.Net Class Libraries
AbstractField..::..SetOmitTf Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.SetOmitTf(System.Boolean)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Renamed to SetOmitTermFreqAndPositions")]
public virtual void SetOmitTf(
    bool omitTermFreqAndPositions
)
Visual Basic
<ObsoleteAttribute("Renamed to SetOmitTermFreqAndPositions")> _
Public Overridable Sub SetOmitTf ( _
    omitTermFreqAndPositions As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Renamed to SetOmitTermFreqAndPositions")]
public:
virtual void SetOmitTf(
    bool omitTermFreqAndPositions
)

Parameters

omitTermFreqAndPositions
Type: System..::..Boolean

[Missing <param name="omitTermFreqAndPositions"/> documentation for "M:Lucene.Net.Documents.AbstractField.SetOmitTf(System.Boolean)"]

Implements

Fieldable..::..SetOmitTf(Boolean)

See Also

AbstractField Class
Lucene.Net.Documents Namespace


SetStoreTermVector Method

[image]

Lucene.Net Class Libraries
AbstractField..::..SetStoreTermVector Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.SetStoreTermVector(Lucene.Net.Documents.Field.TermVector)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void SetStoreTermVector(
    Field..::..TermVector termVector
)
Visual Basic
Protected Friend Overridable Sub SetStoreTermVector ( _
    termVector As Field..::..TermVector _
)
Visual C++
protected public:
virtual void SetStoreTermVector(
    Field..::..TermVector^ termVector
)

Parameters

termVector
Type: Lucene.Net.Documents..::..Field..::..TermVector

[Missing <param name="termVector"/> documentation for "M:Lucene.Net.Documents.AbstractField.SetStoreTermVector(Lucene.Net.Documents.Field.TermVector)"]

See Also

AbstractField Class
Lucene.Net.Documents Namespace


StringValue Method

[image]

Lucene.Net Class Libraries
AbstractField..::..StringValue Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.StringValue"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string StringValue()
Visual Basic
Public MustOverride Function StringValue As String
Visual C++
public:
virtual String^ StringValue() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.StringValue"]

Implements

Fieldable..::..StringValue()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


TokenStreamValue Method

[image]

Lucene.Net Class Libraries
AbstractField..::..TokenStreamValue Method
AbstractField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.AbstractField.TokenStreamValue"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TokenStream TokenStreamValue()
Visual Basic
Public MustOverride Function TokenStreamValue As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStreamValue() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.TokenStreamValue"]

Implements

Fieldable..::..TokenStreamValue()()()()

See Also

AbstractField Class
Lucene.Net.Documents Namespace


ToString Method

[image]

Lucene.Net Class Libraries
AbstractField..::..ToString Method
AbstractField Class See Also Send Feedback
Prints a Field for human consumption.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.AbstractField.ToString"]

See Also

AbstractField Class
Lucene.Net.Documents Namespace


CompressionTools Class

[image]

Lucene.Net Class Libraries
CompressionTools Class
Members See Also Send Feedback
Simple utility class providing static methods to compress and decompress binary data for stored fields. This class uses java.util.zip.Deflater and Inflater classes to compress and decompress, which is the same format previously used by the now deprecated Field.Store.COMPRESS.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CompressionTools
Visual Basic
Public Class CompressionTools
Visual C++
public ref class CompressionTools

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..CompressionTools

See Also

CompressionTools Members
Lucene.Net.Documents Namespace


CompressionTools Members

[image] [image]

Lucene.Net Class Libraries
CompressionTools Members
CompressionTools Class Methods See Also Send Feedback

The CompressionTools type exposes the following members.

Methods

 | Name | Description
 | Compress(array<Byte>[]()[][]) | Compresses all bytes in the array, with default BEST_COMPRESSION level
 | Compress(array<Byte>[]()[][], Int32, Int32) | Compresses the specified byte range, with default BEST_COMPRESSION level
 | Compress(array<Byte>[]()[][], Int32, Int32, Int32) | Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | CompressString(String) | Compresses the String value, with default BEST_COMPRESSION level
 | CompressString(String, Int32) | Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | Decompress | Decompress the byte array previously returned by compress
 | DecompressString | Decompress the byte array previously returned by compressString back into a String
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressionTools Class
Lucene.Net.Documents Namespace


CompressionTools Methods

[image] [image]

Lucene.Net Class Libraries
CompressionTools Methods
CompressionTools Class See Also Send Feedback

The CompressionTools type exposes the following members.

Methods

 | Name | Description
 | Compress(array<Byte>[]()[][]) | Compresses all bytes in the array, with default BEST_COMPRESSION level
 | Compress(array<Byte>[]()[][], Int32, Int32) | Compresses the specified byte range, with default BEST_COMPRESSION level
 | Compress(array<Byte>[]()[][], Int32, Int32, Int32) | Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | CompressString(String) | Compresses the String value, with default BEST_COMPRESSION level
 | CompressString(String, Int32) | Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).
 | Decompress | Decompress the byte array previously returned by compress
 | DecompressString | Decompress the byte array previously returned by compressString back into a String
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressionTools Class
Lucene.Net.Documents Namespace


Compress Method

[image] [image]

Lucene.Net Class Libraries
CompressionTools..::..Compress Method
CompressionTools Class See Also Send Feedback

Overload List

Name | Description
Compress(array<Byte>[]()[][]) | Compresses all bytes in the array, with default BEST_COMPRESSION level
Compress(array<Byte>[]()[][], Int32, Int32) | Compresses the specified byte range, with default BEST_COMPRESSION level
Compress(array<Byte>[]()[][], Int32, Int32, Int32) | Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).

See Also

CompressionTools Class
CompressionTools Members
Lucene.Net.Documents Namespace


Compress Method (Byte[])

[image]

Lucene.Net Class Libraries
CompressionTools..::..Compress Method (array<Byte>[]()[][])
CompressionTools Class See Also Send Feedback
Compresses all bytes in the array, with default BEST_COMPRESSION level

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Compress(
    byte[] value_Renamed
)
Visual Basic
Public Shared Function Compress ( _
    value_Renamed As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[])"]

See Also

CompressionTools Class
Compress Overload
Lucene.Net.Documents Namespace


Compress Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
CompressionTools..::..Compress Method (array<Byte>[]()[][], Int32, Int32)
CompressionTools Class See Also Send Feedback
Compresses the specified byte range, with default BEST_COMPRESSION level

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Compress(
    byte[] value_Renamed,
    int offset,
    int length
)
Visual Basic
Public Shared Function Compress ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32)"]

See Also

CompressionTools Class
Compress Overload
Lucene.Net.Documents Namespace


Compress Method (Byte[], Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
CompressionTools..::..Compress Method (array<Byte>[]()[][], Int32, Int32, Int32)
CompressionTools Class See Also Send Feedback
Compresses the specified byte range using the specified compressionLevel (constants are defined in java.util.zip.Deflater).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Compress(
    byte[] value_Renamed,
    int offset,
    int length,
    int compressionLevel
)
Visual Basic
Public Shared Function Compress ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer, _
    compressionLevel As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length,
    int compressionLevel
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32,System.Int32)"]

compressionLevel
Type: System..::..Int32

[Missing <param name="compressionLevel"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.Compress(System.Byte[],System.Int32,System.Int32,System.Int32)"]

See Also

CompressionTools Class
Compress Overload
Lucene.Net.Documents Namespace


CompressString Method

[image] [image]

Lucene.Net Class Libraries
CompressionTools..::..CompressString Method
CompressionTools Class See Also Send Feedback

Overload List

Name | Description
CompressString(String) | Compresses the String value, with default BEST_COMPRESSION level
CompressString(String, Int32) | Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).

See Also

CompressionTools Class
CompressionTools Members
Lucene.Net.Documents Namespace


CompressString Method (String)

[image]

Lucene.Net Class Libraries
CompressionTools..::..CompressString Method (String)
CompressionTools Class See Also Send Feedback
Compresses the String value, with default BEST_COMPRESSION level

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] CompressString(
    string value_Renamed
)
Visual Basic
Public Shared Function CompressString ( _
    value_Renamed As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ CompressString(
    String^ value_Renamed
)

Parameters

value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.CompressString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.CompressString(System.String)"]

See Also

CompressionTools Class
CompressString Overload
Lucene.Net.Documents Namespace


CompressString Method (String, Int32)

[image]

Lucene.Net Class Libraries
CompressionTools..::..CompressString Method (String, Int32)
CompressionTools Class See Also Send Feedback
Compresses the String value using the specified compressionLevel (constants are defined in java.util.zip.Deflater).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] CompressString(
    string value_Renamed,
    int compressionLevel
)
Visual Basic
Public Shared Function CompressString ( _
    value_Renamed As String, _
    compressionLevel As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ CompressString(
    String^ value_Renamed,
    int compressionLevel
)

Parameters

value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.CompressString(System.String,System.Int32)"]

compressionLevel
Type: System..::..Int32

[Missing <param name="compressionLevel"/> documentation for "M:Lucene.Net.Documents.CompressionTools.CompressString(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.CompressString(System.String,System.Int32)"]

See Also

CompressionTools Class
CompressString Overload
Lucene.Net.Documents Namespace


Decompress Method

[image]

Lucene.Net Class Libraries
CompressionTools..::..Decompress Method
CompressionTools Class See Also Send Feedback
Decompress the byte array previously returned by compress

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Decompress(
    byte[] value_Renamed
)
Visual Basic
Public Shared Function Decompress ( _
    value_Renamed As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Decompress(
    array<unsigned char>^ value_Renamed
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.Decompress(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.Decompress(System.Byte[])"]

See Also

CompressionTools Class
Lucene.Net.Documents Namespace


DecompressString Method

[image]

Lucene.Net Class Libraries
CompressionTools..::..DecompressString Method
CompressionTools Class See Also Send Feedback
Decompress the byte array previously returned by compressString back into a String

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string DecompressString(
    byte[] value_Renamed
)
Visual Basic
Public Shared Function DecompressString ( _
    value_Renamed As Byte() _
) As String
Visual C++
public:
static String^ DecompressString(
    array<unsigned char>^ value_Renamed
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.CompressionTools.DecompressString(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.CompressionTools.DecompressString(System.Byte[])"]

See Also

CompressionTools Class
Lucene.Net.Documents Namespace


DateField Class

[image]

Lucene.Net Class Libraries
DateField Class
Members See Also Send Feedback
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders by date, which makes them suitable for use as field values and search terms.

Note that this class saves dates with millisecond granularity, which is bad for {@link TermRangeQuery} and {@link PrefixQuery}, as those queries are expanded to a BooleanQuery with a potentially large number of terms when searching. Thus you might want to use {@link DateTools} instead.

Note: dates before 1970 cannot be used, and therefore cannot be indexed when using this class. See {@link DateTools} for an alternative without such a limitation.

Another approach is {@link NumericUtils}, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a {@link Date} or {@link Calendar}, just get the unix timestamp as

CopyC#
long
using {@link Date#getTime} or {@link Calendar#getTimeInMillis} and index this as a numeric value with {@link NumericField} and use {@link NumericRangeQuery} to query it.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release.")]
public class DateField
Visual Basic
<ObsoleteAttribute("If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release.")> _
Public Class DateField
Visual C++
[ObsoleteAttribute(L"If you build a new index, use DateTools or NumericField instead.This class is included for use with existing indices and will be removed in a future release.")]
public ref class DateField

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..DateField

See Also

DateField Members
Lucene.Net.Documents Namespace


DateField Members

[image] [image]

Lucene.Net Class Libraries
DateField Members
DateField Class Methods See Also Send Feedback

The DateField type exposes the following members.

Methods

 | Name | Description
 | DateToString | Converts a Date to a string suitable for indexing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MAX_DATE_STRING |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MIN_DATE_STRING |
 | StringToDate | Converts a string-encoded date into a Date object.
 | StringToTime | Converts a string-encoded date into a millisecond time.
 | TimeToString | Converts a millisecond time to a string suitable for indexing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateField Class
Lucene.Net.Documents Namespace


DateField Methods

[image] [image]

Lucene.Net Class Libraries
DateField Methods
DateField Class See Also Send Feedback

The DateField type exposes the following members.

Methods

 | Name | Description
 | DateToString | Converts a Date to a string suitable for indexing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MAX_DATE_STRING |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MIN_DATE_STRING |
 | StringToDate | Converts a string-encoded date into a Date object.
 | StringToTime | Converts a string-encoded date into a millisecond time.
 | TimeToString | Converts a millisecond time to a string suitable for indexing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateField Class
Lucene.Net.Documents Namespace


DateToString Method

[image]

Lucene.Net Class Libraries
DateField..::..DateToString Method
DateField Class See Also Send Feedback
Converts a Date to a string suitable for indexing.
method argument is before 1970

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string DateToString(
    DateTime date
)
Visual Basic
Public Shared Function DateToString ( _
    date As DateTime _
) As String
Visual C++
public:
static String^ DateToString(
    DateTime date
)

Parameters

date
Type: System..::..DateTime

[Missing <param name="date"/> documentation for "M:Lucene.Net.Documents.DateField.DateToString(System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateField.DateToString(System.DateTime)"]

See Also

DateField Class
Lucene.Net.Documents Namespace


MAX_DATE_STRING Method

[image]

Lucene.Net Class Libraries
DateField..::..MAX_DATE_STRING Method
DateField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.DateField.MAX_DATE_STRING"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string MAX_DATE_STRING()
Visual Basic
Public Shared Function MAX_DATE_STRING As String
Visual C++
public:
static String^ MAX_DATE_STRING()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateField.MAX_DATE_STRING"]

See Also

DateField Class
Lucene.Net.Documents Namespace


MIN_DATE_STRING Method

[image]

Lucene.Net Class Libraries
DateField..::..MIN_DATE_STRING Method
DateField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.DateField.MIN_DATE_STRING"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string MIN_DATE_STRING()
Visual Basic
Public Shared Function MIN_DATE_STRING As String
Visual C++
public:
static String^ MIN_DATE_STRING()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateField.MIN_DATE_STRING"]

See Also

DateField Class
Lucene.Net.Documents Namespace


StringToDate Method

[image]

Lucene.Net Class Libraries
DateField..::..StringToDate Method
DateField Class See Also Send Feedback
Converts a string-encoded date into a Date object.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static DateTime StringToDate(
    string s
)
Visual Basic
Public Shared Function StringToDate ( _
    s As String _
) As DateTime
Visual C++
public:
static DateTime StringToDate(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Documents.DateField.StringToDate(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateField.StringToDate(System.String)"]

See Also

DateField Class
Lucene.Net.Documents Namespace


StringToTime Method

[image]

Lucene.Net Class Libraries
DateField..::..StringToTime Method
DateField Class See Also Send Feedback
Converts a string-encoded date into a millisecond time.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long StringToTime(
    string s
)
Visual Basic
Public Shared Function StringToTime ( _
    s As String _
) As Long
Visual C++
public:
static long long StringToTime(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Documents.DateField.StringToTime(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateField.StringToTime(System.String)"]

See Also

DateField Class
Lucene.Net.Documents Namespace


TimeToString Method

[image]

Lucene.Net Class Libraries
DateField..::..TimeToString Method
DateField Class See Also Send Feedback
Converts a millisecond time to a string suitable for indexing.
method argument is negative, that is, before 1970

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string TimeToString(
    long time
)
Visual Basic
Public Shared Function TimeToString ( _
    time As Long _
) As String
Visual C++
public:
static String^ TimeToString(
    long long time
)

Parameters

time
Type: System..::..Int64

[Missing <param name="time"/> documentation for "M:Lucene.Net.Documents.DateField.TimeToString(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateField.TimeToString(System.Int64)"]

See Also

DateField Class
Lucene.Net.Documents Namespace


DateTools Class

[image]

Lucene.Net Class Libraries
DateTools Class
Members See Also Send Feedback
Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders them by date, which makes them suitable for use as field values and search terms.

This class also helps you to limit the resolution of your dates. Do not save dates with a finer resolution than you really need, as then RangeQuery and PrefixQuery will require more memory and become slower.

Compared to {@link DateField} the strings generated by the methods in this class take slightly more space, unless your selected resolution is set to

CopyC#
Resolution.DAY
or lower.

Another approach is {@link NumericUtils}, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a {@link Date} or {@link Calendar}, just get the unix timestamp as

CopyC#
long
using {@link Date#getTime} or {@link Calendar#getTimeInMillis} and index this as a numeric value with {@link NumericField} and use {@link NumericRangeQuery} to query it.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class DateTools
Visual Basic
Public Class DateTools
Visual C++
public ref class DateTools

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..DateTools

See Also

DateTools Members
Lucene.Net.Documents Namespace


DateTools Members

[image] [image]

Lucene.Net Class Libraries
DateTools Members
DateTools Class Methods See Also Send Feedback

The DateTools type exposes the following members.

Methods

Name Description
DateToString
Converts a Date to a string suitable for indexing.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Round(DateTime, DateTools..::..Resolution)
Limit a date's resolution. For example, the date
CopyC#
2004-09-21 13:50:11
 will be changed to
CopyC#
2004-09-01 00:00:00
 when using
CopyC#
Resolution.MONTH
.
Round(Int64, DateTools..::..Resolution)
Limit a date's resolution. For example, the date
CopyC#
1095767411000
 (which represents 2004-09-21 13:50:11) will be changed to
CopyC#
1093989600000
 (2004-09-01 00:00:00) when using
CopyC#
Resolution.MONTH
.
StringToDate
Converts a string produced by
CopyC#
timeToString
 or
CopyC#
DateToString
 back to a time, represented as a Date object.
StringToTime
Converts a string produced by
CopyC#
timeToString
 or
CopyC#
DateToString
 back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
TimeToString
Converts a millisecond time to a string suitable for indexing.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

DateTools Class
Lucene.Net.Documents Namespace


DateTools Methods

[image] [image]

Lucene.Net Class Libraries
DateTools Methods
DateTools Class See Also Send Feedback

The DateTools type exposes the following members.

Methods

Name Description
DateToString
Converts a Date to a string suitable for indexing.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Round(DateTime, DateTools..::..Resolution)
Limit a date's resolution. For example, the date
CopyC#
2004-09-21 13:50:11
 will be changed to
CopyC#
2004-09-01 00:00:00
 when using
CopyC#
Resolution.MONTH
.
Round(Int64, DateTools..::..Resolution)
Limit a date's resolution. For example, the date
CopyC#
1095767411000
 (which represents 2004-09-21 13:50:11) will be changed to
CopyC#
1093989600000
 (2004-09-01 00:00:00) when using
CopyC#
Resolution.MONTH
.
StringToDate
Converts a string produced by
CopyC#
timeToString
 or
CopyC#
DateToString
 back to a time, represented as a Date object.
StringToTime
Converts a string produced by
CopyC#
timeToString
 or
CopyC#
DateToString
 back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
TimeToString
Converts a millisecond time to a string suitable for indexing.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

DateTools Class
Lucene.Net.Documents Namespace


DateToString Method

[image]

Lucene.Net Class Libraries
DateTools..::..DateToString Method
DateTools Class See Also Send Feedback
Converts a Date to a string suitable for indexing.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string DateToString(
    DateTime date,
    DateTools..::..Resolution resolution
)
Visual Basic
Public Shared Function DateToString ( _
    date As DateTime, _
    resolution As DateTools..::..Resolution _
) As String
Visual C++
public:
static String^ DateToString(
    DateTime date,
    DateTools..::..Resolution^ resolution
)

Parameters

date
Type: System..::..DateTime
the date to be converted
resolution
Type: Lucene.Net.Documents..::..DateTools..::..Resolution
the desired resolution, see {@link #Round(Date, DateTools.Resolution)}

Return Value

a string in format
CopyC#
yyyyMMddHHmmssSSS
 or shorter, depending on
CopyC#
resolution
; using GMT as timezone

See Also

DateTools Class
Lucene.Net.Documents Namespace


Round Method

[image] [image]

Lucene.Net Class Libraries
DateTools..::..Round Method
DateTools Class See Also Send Feedback

Overload List

Name Description
Round(DateTime, DateTools..::..Resolution)
Limit a date's resolution. For example, the date
CopyC#
2004-09-21 13:50:11
 will be changed to
CopyC#
2004-09-01 00:00:00
 when using
CopyC#
Resolution.MONTH
.
Round(Int64, DateTools..::..Resolution)
Limit a date's resolution. For example, the date
CopyC#
1095767411000
 (which represents 2004-09-21 13:50:11) will be changed to
CopyC#
1093989600000
 (2004-09-01 00:00:00) when using
CopyC#
Resolution.MONTH
.

See Also

DateTools Class
DateTools Members
Lucene.Net.Documents Namespace


Round Method (DateTime, DateTools.Resolution)

[image]

Lucene.Net Class Libraries
DateTools..::..Round Method (DateTime, DateTools..::..Resolution)
DateTools Class See Also Send Feedback
Limit a date's resolution. For example, the date
CopyC#
2004-09-21 13:50:11
 will be changed to
CopyC#
2004-09-01 00:00:00
 when using
CopyC#
Resolution.MONTH
.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static DateTime Round(
    DateTime date,
    DateTools..::..Resolution resolution
)
Visual Basic
Public Shared Function Round ( _
    date As DateTime, _
    resolution As DateTools..::..Resolution _
) As DateTime
Visual C++
public:
static DateTime Round(
    DateTime date,
    DateTools..::..Resolution^ resolution
)

Parameters

date
Type: System..::..DateTime

[Missing <param name="date"/> documentation for "M:Lucene.Net.Documents.DateTools.Round(System.DateTime,Lucene.Net.Documents.DateTools.Resolution)"]

resolution
Type: Lucene.Net.Documents..::..DateTools..::..Resolution
The desired resolution of the date to be returned

Return Value

the date with all values more precise than
CopyC#
resolution
 set to 0 or 1

See Also

DateTools Class
Round Overload
Lucene.Net.Documents Namespace


Round Method (Int64, DateTools.Resolution)

[image]

Lucene.Net Class Libraries
DateTools..::..Round Method (Int64, DateTools..::..Resolution)
DateTools Class See Also Send Feedback
Limit a date's resolution. For example, the date
CopyC#
1095767411000
 (which represents 2004-09-21 13:50:11) will be changed to
CopyC#
1093989600000
 (2004-09-01 00:00:00) when using
CopyC#
Resolution.MONTH
.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long Round(
    long time,
    DateTools..::..Resolution resolution
)
Visual Basic
Public Shared Function Round ( _
    time As Long, _
    resolution As DateTools..::..Resolution _
) As Long
Visual C++
public:
static long long Round(
    long long time,
    DateTools..::..Resolution^ resolution
)

Parameters

time
Type: System..::..Int64
The time in milliseconds (not ticks).
resolution
Type: Lucene.Net.Documents..::..DateTools..::..Resolution
The desired resolution of the date to be returned

Return Value

the date with all values more precise than
CopyC#
resolution
 set to 0 or 1, expressed as milliseconds since January 1, 1970, 00:00:00 GMT

See Also

DateTools Class
Round Overload
Lucene.Net.Documents Namespace


StringToDate Method

[image]

Lucene.Net Class Libraries
DateTools..::..StringToDate Method
DateTools Class See Also Send Feedback
Converts a string produced by
CopyC#
timeToString
 or
CopyC#
DateToString
 back to a time, represented as a Date object.
expected format

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static DateTime StringToDate(
    string dateString
)
Visual Basic
Public Shared Function StringToDate ( _
    dateString As String _
) As DateTime
Visual C++
public:
static DateTime StringToDate(
    String^ dateString
)

Parameters

dateString
Type: System..::..String
the date string to be converted

Return Value

the parsed time as a Date object

See Also

DateTools Class
Lucene.Net.Documents Namespace


StringToTime Method

[image]

Lucene.Net Class Libraries
DateTools..::..StringToTime Method
DateTools Class See Also Send Feedback
Converts a string produced by
CopyC#
timeToString
 or
CopyC#
DateToString
 back to a time, represented as the number of milliseconds since January 1, 1970, 00:00:00 GMT.
expected format

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long StringToTime(
    string dateString
)
Visual Basic
Public Shared Function StringToTime ( _
    dateString As String _
) As Long
Visual C++
public:
static long long StringToTime(
    String^ dateString
)

Parameters

dateString
Type: System..::..String
the date string to be converted

Return Value

the number of milliseconds since January 1, 1970, 00:00:00 GMT

See Also

DateTools Class
Lucene.Net.Documents Namespace


TimeToString Method

[image]

Lucene.Net Class Libraries
DateTools..::..TimeToString Method
DateTools Class See Also Send Feedback
Converts a millisecond time to a string suitable for indexing.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string TimeToString(
    long time,
    DateTools..::..Resolution resolution
)
Visual Basic
Public Shared Function TimeToString ( _
    time As Long, _
    resolution As DateTools..::..Resolution _
) As String
Visual C++
public:
static String^ TimeToString(
    long long time,
    DateTools..::..Resolution^ resolution
)

Parameters

time
Type: System..::..Int64
the date expressed as milliseconds since January 1, 1970, 00:00:00 GMT
resolution
Type: Lucene.Net.Documents..::..DateTools..::..Resolution
the desired resolution, see {@link #Round(long, DateTools.Resolution)}

Return Value

a string in format
CopyC#
yyyyMMddHHmmssSSS
 or shorter, depending on
CopyC#
resolution
; using GMT as timezone

See Also

DateTools Class
Lucene.Net.Documents Namespace


DateTools.Resolution Class

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution Class
DateTools Class Members See Also Send Feedback
Specifies the time granularity.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class Resolution
Visual Basic
Public Class Resolution
Visual C++
public ref class Resolution

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..DateTools..::..Resolution

See Also

DateTools..::..Resolution Members
Lucene.Net.Documents Namespace


DateTools.Resolution Members

[image] [image]

Lucene.Net Class Libraries
DateTools..::..Resolution Members
DateTools..::..Resolution Class Methods Fields See Also Send Feedback

Provides support for converting dates to strings and vice-versa. The strings are structured so that lexicographic sorting orders them by date, which makes them suitable for use as field values and search terms.

This class also helps you to limit the resolution of your dates. Do not save dates with a finer resolution than you really need, as then RangeQuery and PrefixQuery will require more memory and become slower.

Compared to {@link DateField} the strings generated by the methods in this class take slightly more space, unless your selected resolution is set to

CopyC#
Resolution.DAY
or lower.

Another approach is {@link NumericUtils}, which provides a sortable binary representation (prefix encoded) of numeric values, which date/time are. For indexing a {@link Date} or {@link Calendar}, just get the unix timestamp as

CopyC#
long
using {@link Date#getTime} or {@link Calendar#getTimeInMillis} and index this as a numeric value with {@link NumericField} and use {@link NumericRangeQuery} to query it.

The DateTools..::..Resolution type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
DAY |
HOUR |
MILLISECOND |
MINUTE |
MONTH |
SECOND |
YEAR |

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


DateTools.Resolution Fields

[image] [image]

Lucene.Net Class Libraries
DateTools..::..Resolution Fields
DateTools..::..Resolution Class See Also Send Feedback

The DateTools..::..Resolution type exposes the following members.

Fields

Name | Description
DAY |
HOUR |
MILLISECOND |
MINUTE |
MONTH |
SECOND |
YEAR |

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


DAY Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..DAY Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.DAY"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution DAY
Visual Basic
Public Shared ReadOnly DAY As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ DAY

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


HOUR Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..HOUR Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.HOUR"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution HOUR
Visual Basic
Public Shared ReadOnly HOUR As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ HOUR

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


MILLISECOND Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..MILLISECOND Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.MILLISECOND"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution MILLISECOND
Visual Basic
Public Shared ReadOnly MILLISECOND As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ MILLISECOND

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


MINUTE Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..MINUTE Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.MINUTE"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution MINUTE
Visual Basic
Public Shared ReadOnly MINUTE As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ MINUTE

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


MONTH Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..MONTH Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.MONTH"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution MONTH
Visual Basic
Public Shared ReadOnly MONTH As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ MONTH

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


SECOND Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..SECOND Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.SECOND"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution SECOND
Visual Basic
Public Shared ReadOnly SECOND As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ SECOND

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


YEAR Field

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..YEAR Field
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.DateTools.Resolution.YEAR"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DateTools..::..Resolution YEAR
Visual Basic
Public Shared ReadOnly YEAR As DateTools..::..Resolution
Visual C++
public:
static initonly DateTools..::..Resolution^ YEAR

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


DateTools.Resolution Methods

[image] [image]

Lucene.Net Class Libraries
DateTools..::..Resolution Methods
DateTools..::..Resolution Class See Also Send Feedback

The DateTools..::..Resolution type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


ToString Method

[image]

Lucene.Net Class Libraries
DateTools..::..Resolution..::..ToString Method
DateTools..::..Resolution Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.DateTools.Resolution.ToString"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.DateTools.Resolution.ToString"]

See Also

DateTools..::..Resolution Class
Lucene.Net.Documents Namespace


Document Class

[image]

Lucene.Net Class Libraries
Document Class
Members See Also Send Feedback
Documents are the unit of indexing and search. A Document is a set of fields. Each field has a name and a textual value. A field may be {@link Fieldable#IsStored() stored} with the document, in which case it is returned with search hits on the document. Thus each document should typically contain one or more stored fields which uniquely identify it.

Note that fields which are not {@link Fieldable#IsStored() stored} are not available in documents retrieved from the index, e.g. with {@link ScoreDoc#doc}, {@link Searcher#Doc(int)} or {@link IndexReader#Document(int)}.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Document
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Document
Visual C++
[SerializableAttribute]
public ref class Document sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..Document

See Also

Document Members
Lucene.Net.Documents Namespace


Document Members

[image] [image]

Lucene.Net Class Libraries
Document Members
Document Class Constructors Methods Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

 | Name | Description
Public method | Document | Constructs a new document with no fields.

Methods

Name Description
Public method Add

Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search.

Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Fields Obsolete.
Returns an Enumeration of all the fields in a document.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Get
Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
Public method GetBinaryValue
Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return
CopyC#
null
 if no binary fields with the specified name are available. There may be non-binary fields with the same name.
Public method GetBinaryValues
Returns an array of byte arrays for of the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Public method GetBoost
Returns, at indexing time, the boost factor as set by {@link #SetBoost(float)}.

Note that once a document is indexed this value is no longer available from the index. At search time, for retrieved documents, this method always returns 1. This however does not mean that the boost value set at indexing time was ignored - it was just combined with other indexing time factors and stored elsewhere, for better indexing and search performance. (For more information see the "norm(t,d)" part of the scoring formula in {@link Lucene.Net.Search.Similarity Similarity}.)

Public method GetField
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.
Public method GetFieldable
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
Public method GetFieldables
Returns an array of {@link Fieldable}s with the given name. This method returns an empty array when there are no matching fields. It never returns null.
Public method GetFields()()()()
Returns a List of all the fields in a document.

Note that fields which are not {@link Fieldable#IsStored() stored} are not available in documents retrieved from the index, e.g. {@link Searcher#Doc(int)} or {@link IndexReader#Document(int)}.

Public method GetFields(String)
Returns an array of {@link Field}s with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValues
Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method RemoveField

Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Public method RemoveFields

Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Public method SetBoost
Sets a boost factor for hits on any field of this document. This value will be multiplied into the score of all hits on this document.

The default value is 1.0.

Values are multiplied into the value of {@link Fieldable#GetBoost()} of each field in this document. Thus, this method in effect sets a default boost for the fields of this document.

Public method ToString
Prints the fields of a document for human consumption.
(Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | fields_ForNUnit |

See Also

Document Class
Lucene.Net.Documents Namespace


Document Constructor

[image]

Lucene.Net Class Libraries
Document Constructor
Document Class See Also Send Feedback
Constructs a new document with no fields.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Document()
Visual Basic
Public Sub New
Visual C++
public:
Document()

See Also

Document Class
Lucene.Net.Documents Namespace


Document Methods

[image] [image]

Lucene.Net Class Libraries
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name Description
Public method Add

Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search.

Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Fields Obsolete.
Returns an Enumeration of all the fields in a document.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Get
Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
Public method GetBinaryValue
Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return
CopyC#
null
 if no binary fields with the specified name are available. There may be non-binary fields with the same name.
Public method GetBinaryValues
Returns an array of byte arrays for of the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Public method GetBoost
Returns, at indexing time, the boost factor as set by {@link #SetBoost(float)}.

Note that once a document is indexed this value is no longer available from the index. At search time, for retrieved documents, this method always returns 1. This however does not mean that the boost value set at indexing time was ignored - it was just combined with other indexing time factors and stored elsewhere, for better indexing and search performance. (For more information see the "norm(t,d)" part of the scoring formula in {@link Lucene.Net.Search.Similarity Similarity}.)

Public method GetField
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.
Public method GetFieldable
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.
Public method GetFieldables
Returns an array of {@link Fieldable}s with the given name. This method returns an empty array when there are no matching fields. It never returns null.
Public method GetFields()()()()
Returns a List of all the fields in a document.

Note that fields which are not {@link Fieldable#IsStored() stored} are not available in documents retrieved from the index, e.g. {@link Searcher#Doc(int)} or {@link IndexReader#Document(int)}.

Public method GetFields(String)
Returns an array of {@link Field}s with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValues
Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method RemoveField

Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Public method RemoveFields

Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Public method SetBoost
Sets a boost factor for hits on any field of this document. This value will be multiplied into the score of all hits on this document.

The default value is 1.0.

Values are multiplied into the value of {@link Fieldable#GetBoost()} of each field in this document. Thus, this method in effect sets a default boost for the fields of this document.

Public method ToString
Prints the fields of a document for human consumption.
(Overrides Object..::..ToString()()()().)

See Also

Document Class
Lucene.Net.Documents Namespace


Add Method

[image]

Lucene.Net Class Libraries
Document..::..Add Method
Document Class See Also Send Feedback

Adds a field to a document. Several fields may be added with the same name. In this case, if the fields are indexed, their text is treated as though appended for the purposes of search.

Note that add like the removeField(s) methods only makes sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    Fieldable field
)
Visual Basic
Public Sub Add ( _
    field As Fieldable _
)
Visual C++
public:
void Add(
    Fieldable^ field
)

Parameters

field
Type: Lucene.Net.Documents..::..Fieldable

[Missing <param name="field"/> documentation for "M:Lucene.Net.Documents.Document.Add(Lucene.Net.Documents.Fieldable)"]

See Also

Document Class
Lucene.Net.Documents Namespace


Fields Method

[image]

Lucene.Net Class Libraries
Document..::..Fields Method
Document Class See Also Send Feedback
Returns an Enumeration of all the fields in a document.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetFields() instead")]
public IEnumerator Fields()
Visual Basic
<ObsoleteAttribute("Use GetFields() instead")> _
Public Function Fields As IEnumerator
Visual C++
[ObsoleteAttribute(L"Use GetFields() instead")]
public:
IEnumerator^ Fields()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.Fields"]

See Also

Document Class
Lucene.Net.Documents Namespace


Get Method

[image]

Lucene.Net Class Libraries
Document..::..Get Method
Document Class See Also Send Feedback
Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Get(
    string name
)
Visual Basic
Public Function Get ( _
    name As String _
) As String
Visual C++
public:
String^ Get(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Documents.Document.Get(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.Get(System.String)"]

See Also

Document Class
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image]

Lucene.Net Class Libraries
Document..::..GetBinaryValue Method
Document Class See Also Send Feedback
Returns an array of bytes for the first (or only) field that has the name specified as the method parameter. This method will return
CopyC#
null
 if no binary fields with the specified name are available. There may be non-binary fields with the same name.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] GetBinaryValue(
    string name
)
Visual Basic
Public Function GetBinaryValue ( _
    name As String _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetBinaryValue(
    String^ name
)

Parameters

name
Type: System..::..String
the name of the field.

Return Value

a
CopyC#
byte[]
 containing the binary field value or
CopyC#
null

See Also

Document Class
Lucene.Net.Documents Namespace


GetBinaryValues Method

[image]

Lucene.Net Class Libraries
Document..::..GetBinaryValues Method
Document Class See Also Send Feedback
Returns an array of byte arrays for of the fields that have the name specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[][] GetBinaryValues(
    string name
)
Visual Basic
Public Function GetBinaryValues ( _
    name As String _
) As Byte()()
Visual C++
public:
array<array<unsigned char>^>^ GetBinaryValues(
    String^ name
)

Parameters

name
Type: System..::..String
the name of the field

Return Value

a
CopyC#
byte[][]
 of binary field values

See Also

Document Class
Lucene.Net.Documents Namespace


GetBoost Method

[image]

Lucene.Net Class Libraries
Document..::..GetBoost Method
Document Class See Also Send Feedback
Returns, at indexing time, the boost factor as set by {@link #SetBoost(float)}.

Note that once a document is indexed this value is no longer available from the index. At search time, for retrieved documents, this method always returns 1. This however does not mean that the boost value set at indexing time was ignored - it was just combined with other indexing time factors and stored elsewhere, for better indexing and search performance. (For more information see the "norm(t,d)" part of the scoring formula in {@link Lucene.Net.Search.Similarity Similarity}.)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float GetBoost()
Visual Basic
Public Function GetBoost As Single
Visual C++
public:
float GetBoost()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.GetBoost"]

See Also

Document Class
Lucene.Net.Documents Namespace
Document..::..SetBoost(Single)


GetField Method

[image]

Lucene.Net Class Libraries
Document..::..GetField Method
Document Class See Also Send Feedback
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added. Do not use this method with lazy loaded fields.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field GetField(
    string name
)
Visual Basic
Public Function GetField ( _
    name As String _
) As Field
Visual C++
public:
Field^ GetField(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Documents.Document.GetField(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.GetField(System.String)"]

See Also

Document Class
Lucene.Net.Documents Namespace


GetFieldable Method

[image]

Lucene.Net Class Libraries
Document..::..GetFieldable Method
Document Class See Also Send Feedback
Returns a field with the given name if any exist in this document, or null. If multiple fields exists with this name, this method returns the first value added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Fieldable GetFieldable(
    string name
)
Visual Basic
Public Function GetFieldable ( _
    name As String _
) As Fieldable
Visual C++
public:
Fieldable^ GetFieldable(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Documents.Document.GetFieldable(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.GetFieldable(System.String)"]

See Also

Document Class
Lucene.Net.Documents Namespace


GetFieldables Method

[image]

Lucene.Net Class Libraries
Document..::..GetFieldables Method
Document Class See Also Send Feedback
Returns an array of {@link Fieldable}s with the given name. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Fieldable[] GetFieldables(
    string name
)
Visual Basic
Public Function GetFieldables ( _
    name As String _
) As Fieldable()
Visual C++
public:
array<Fieldable^>^ GetFieldables(
    String^ name
)

Parameters

name
Type: System..::..String
the name of the field

Return Value

a
CopyC#
Fieldable[]
 array

See Also

Document Class
Lucene.Net.Documents Namespace


GetFields Method

[image] [image]

Lucene.Net Class Libraries
Document..::..GetFields Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFields()()()() | Returns a List of all the fields in a document. Note that fields which are not {@link Fieldable#IsStored() stored} are not available in documents retrieved from the index, e.g. {@link Searcher#Doc(int)} or {@link IndexReader#Document(int)}.
Public method | GetFields(String) | Returns an array of {@link Field}s with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.

See Also

Document Class
Document Members
Lucene.Net.Documents Namespace


GetFields Method

[image]

Lucene.Net Class Libraries
Document..::..GetFields Method
Document Class See Also Send Feedback
Returns a List of all the fields in a document.

Note that fields which are not {@link Fieldable#IsStored() stored} are not available in documents retrieved from the index, e.g. {@link Searcher#Doc(int)} or {@link IndexReader#Document(int)}.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IList GetFields()
Visual Basic
Public Function GetFields As IList
Visual C++
public:
IList^ GetFields()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.GetFields"]

See Also

Document Class
GetFields Overload
Lucene.Net.Documents Namespace


GetFields Method (String)

[image]

Lucene.Net Class Libraries
Document..::..GetFields Method (String)
Document Class See Also Send Feedback
Returns an array of {@link Field}s with the given name. Do not use with lazy loaded fields. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field[] GetFields(
    string name
)
Visual Basic
Public Function GetFields ( _
    name As String _
) As Field()
Visual C++
public:
array<Field^>^ GetFields(
    String^ name
)

Parameters

name
Type: System..::..String
the name of the field

Return Value

a
CopyC#
Field[]
 array

See Also

Document Class
GetFields Overload
Lucene.Net.Documents Namespace


GetValues Method

[image]

Lucene.Net Class Libraries
Document..::..GetValues Method
Document Class See Also Send Feedback
Returns an array of values of the field specified as the method parameter. This method returns an empty array when there are no matching fields. It never returns null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string[] GetValues(
    string name
)
Visual Basic
Public Function GetValues ( _
    name As String _
) As String()
Visual C++
public:
array<String^>^ GetValues(
    String^ name
)

Parameters

name
Type: System..::..String
the name of the field

Return Value

a
CopyC#
String[]
 of field values

See Also

Document Class
Lucene.Net.Documents Namespace


RemoveField Method

[image]

Lucene.Net Class Libraries
Document..::..RemoveField Method
Document Class See Also Send Feedback

Removes field with the specified name from the document. If multiple fields exist with this name, this method removes the first field that has been added. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void RemoveField(
    string name
)
Visual Basic
Public Sub RemoveField ( _
    name As String _
)
Visual C++
public:
void RemoveField(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Documents.Document.RemoveField(System.String)"]

See Also

Document Class
Lucene.Net.Documents Namespace


RemoveFields Method

[image]

Lucene.Net Class Libraries
Document..::..RemoveFields Method
Document Class See Also Send Feedback

Removes all fields with the given name from the document. If there is no field with the specified name, the document remains unchanged.

Note that the removeField(s) methods like the add method only make sense prior to adding a document to an index. These methods cannot be used to change the content of an existing index! In order to achieve this, a document has to be deleted from an index and a new changed version of that document has to be added.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void RemoveFields(
    string name
)
Visual Basic
Public Sub RemoveFields ( _
    name As String _
)
Visual C++
public:
void RemoveFields(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Documents.Document.RemoveFields(System.String)"]

See Also

Document Class
Lucene.Net.Documents Namespace


SetBoost Method

[image]

Lucene.Net Class Libraries
Document..::..SetBoost Method
Document Class See Also Send Feedback
Sets a boost factor for hits on any field of this document. This value will be multiplied into the score of all hits on this document.

The default value is 1.0.

Values are multiplied into the value of {@link Fieldable#GetBoost()} of each field in this document. Thus, this method in effect sets a default boost for the fields of this document.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetBoost(
    float boost
)
Visual Basic
Public Sub SetBoost ( _
    boost As Single _
)
Visual C++
public:
void SetBoost(
    float boost
)

Parameters

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Documents.Document.SetBoost(System.Single)"]

See Also

Document Class
Lucene.Net.Documents Namespace
Fieldable..::..SetBoost(Single)


ToString Method

[image]

Lucene.Net Class Libraries
Document..::..ToString Method
Document Class See Also Send Feedback
Prints the fields of a document for human consumption.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Document.ToString"]

See Also

Document Class
Lucene.Net.Documents Namespace


Document Properties

[image] [image]

Lucene.Net Class Libraries
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | fields_ForNUnit |

See Also

Document Class
Lucene.Net.Documents Namespace


fields_ForNUnit Property

[image]

Lucene.Net Class Libraries
Document..::..fields_ForNUnit Property
Document Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Documents.Document.fields_ForNUnit"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IList fields_ForNUnit { get; }
Visual Basic
Public ReadOnly Property fields_ForNUnit As IList
    Get
Visual C++
public:
property IList^ fields_ForNUnit {
    IList^ get ();
}

See Also

Document Class
Lucene.Net.Documents Namespace


Field Class

[image]

Lucene.Net Class Libraries
Field Class
Members See Also Send Feedback
A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Field : AbstractField,
    Fieldable
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Field _
    Inherits AbstractField _
    Implements Fieldable
Visual C++
[SerializableAttribute]
public ref class Field sealed : public AbstractField,
    Fieldable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..AbstractField
Lucene.Net.Documents..::..Field

See Also

Field Members
Lucene.Net.Documents Namespace


Field Members

[image] [image]

Lucene.Net Class Libraries
Field Members
Field Class Constructors Methods Fields See Also Send Feedback

The Field type exposes the following members.

Constructors

 | Name | Description
Public method | Field(String, TokenStream) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, TextReader) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, TokenStream, Field..::..TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, array<Byte>[]()[][], Field..::..Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, TextReader, Field..::..TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, String, Field..::..Store, Field..::..Index) | Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.
Public method | Field(String, array<Byte>[]()[][], Int32, Int32, Field..::..Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, String, Field..::..Store, Field..::..Index, Field..::..TermVector) | Create a field by specifying its name, value and how it will be saved in the index.
Public method | Field(String, Boolean, String, Field..::..Store, Field..::..Index, Field..::..TermVector) | Create a field by specifying its name, value and how it will be saved in the index.

Methods

Name | Description
Public method BinaryValue Obsolete.
The value of the field in Binary, or null. If null, the Reader value, or String value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.
(Overrides AbstractField..::..BinaryValue()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
(Inherited from AbstractField.)
Public method | GetBinaryValue(array<Byte>[]()[][]) | (Inherited from AbstractField.)
Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

(Inherited from AbstractField.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetOmitNorms
True if norms are omitted for this indexed field
(Inherited from AbstractField.)
Public method | GetOmitTermFreqAndPositions | (Inherited from AbstractField.)
Public method | GetOmitTf | Obsolete. (Inherited from AbstractField.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsBinary
True iff the value of the filed is stored as binary
(Inherited from AbstractField.)
Public method IsCompressed
True if the value of the field is stored and compressed within the index
(Inherited from AbstractField.)
Public method IsIndexed
True iff the value of the field is to be indexed, so that it may be searched on.
(Inherited from AbstractField.)
Public method | IsLazy | (Inherited from AbstractField.)
Public method IsStored
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
(Inherited from AbstractField.)
Public method IsStoreOffsetWithTermVector
True iff terms are stored as term vector together with their offsets (start and end position in source text).
(Inherited from AbstractField.)
Public method IsStorePositionWithTermVector
True iff terms are stored as term vector together with their token positions.
(Inherited from AbstractField.)
Public method IsTermVectorStored
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
(Inherited from AbstractField.)
Public method IsTokenized
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
(Inherited from AbstractField.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
(Inherited from AbstractField.)
Public method ReaderValue
The value of the field as a Reader, or null. If null, the String value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.
(Overrides AbstractField..::..ReaderValue()()()().)
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

(Inherited from AbstractField.)
Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
(Inherited from AbstractField.)
Public method SetOmitTermFreqAndPositions
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

(Inherited from AbstractField.)
Public method | SetOmitTf | Obsolete. (Inherited from AbstractField.)
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method SetTokenStream
Expert: sets the token stream to be used for indexing and causes isIndexed() and isTokenized() to return true. May be combined with stored values from stringValue() or binaryValue()
Public method SetValue(array<Byte>[]()[][])
Expert: change the value of this field. See setValue(String).
Public method SetValue(TextReader)
Expert: change the value of this field. See setValue(String).
Public method SetValue(String)

Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents.

Each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.

Public method SetValue(TokenStream) Obsolete.
Expert: change the value of this field. See setValue(String).
Public method SetValue(array<Byte>[]()[][], Int32, Int32)
Expert: change the value of this field. See setValue(String).
Public method StringValue
The value of the field as a String, or null. If null, the Reader value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.
(Overrides AbstractField..::..StringValue()()()().)
Public method TokenStreamValue
The TokesStream for this field to be used when indexing, or null. If null, the Reader value or String value is analyzed to produce the indexed tokens.
(Overrides AbstractField..::..TokenStreamValue()()()().)
Public method ToString
Prints a Field for human consumption.
(Inherited from AbstractField.)

Fields

 | Name | Description
Protected field | binaryLength | (Inherited from AbstractField.)
Protected field | binaryOffset | (Inherited from AbstractField.)
Protected field | boost | (Inherited from AbstractField.)
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | isBinary | (Inherited from AbstractField.)
Protected field | isCompressed | (Inherited from AbstractField.)
Protected field | isIndexed | (Inherited from AbstractField.)
Protected field | isStored | (Inherited from AbstractField.)
Protected field | isTokenized | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | name | (Inherited from AbstractField.)
Protected field | omitNorms | (Inherited from AbstractField.)
Protected field | omitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)

See Also

Field Class
Lucene.Net.Documents Namespace


Field Constructor

[image] [image]

Lucene.Net Class Libraries
Field Constructor
Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Field(String, TokenStream) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, TextReader) | Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, TokenStream, Field..::..TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, array<Byte>[]()[][], Field..::..Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, TextReader, Field..::..TermVector) | Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.
Public method | Field(String, String, Field..::..Store, Field..::..Index) | Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.
Public method | Field(String, array<Byte>[]()[][], Int32, Int32, Field..::..Store) | Create a stored field with binary value. Optionally the value may be compressed.
Public method | Field(String, String, Field..::..Store, Field..::..Index, Field..::..TermVector) | Create a field by specifying its name, value and how it will be saved in the index.
Public method | Field(String, Boolean, String, Field..::..Store, Field..::..Index, Field..::..TermVector) | Create a field by specifying its name, value and how it will be saved in the index.

See Also

Field Class
Field Members
Lucene.Net.Documents Namespace


Field Constructor (String, TokenStream)

[image]

Lucene.Net Class Libraries
Field Constructor (String, TokenStream)
Field Class See Also Send Feedback
Create a tokenized and indexed field that is not stored. Term vectors will not be stored. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    TokenStream tokenStream
)
Visual Basic
Public Sub New ( _
    name As String, _
    tokenStream As TokenStream _
)
Visual C++
public:
Field(
    String^ name,
    TokenStream^ tokenStream
)

Parameters

name
Type: System..::..String
The name of the field
tokenStream
Type: Lucene.Net.Analysis..::..TokenStream
The TokenStream with the content

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, TextReader)

[image]

Lucene.Net Class Libraries
Field Constructor (String, TextReader)
Field Class See Also Send Feedback
Create a tokenized and indexed field that is not stored. Term vectors will not be stored. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    TextReader reader
)
Visual Basic
Public Sub New ( _
    name As String, _
    reader As TextReader _
)
Visual C++
public:
Field(
    String^ name,
    TextReader^ reader
)

Parameters

name
Type: System..::..String
The name of the field
reader
Type: System.IO..::..TextReader
The reader with the content

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, TokenStream, Field.TermVector)

[image]

Lucene.Net Class Libraries
Field Constructor (String, TokenStream, Field..::..TermVector)
Field Class See Also Send Feedback
Create a tokenized and indexed field that is not stored, optionally with storing term vectors. This is useful for pre-analyzed fields. The TokenStream is read only when the Document is added to the index, i.e. you may not close the TokenStream until {@link IndexWriter#AddDocument(Document)} has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    TokenStream tokenStream,
    Field..::..TermVector termVector
)
Visual Basic
Public Sub New ( _
    name As String, _
    tokenStream As TokenStream, _
    termVector As Field..::..TermVector _
)
Visual C++
public:
Field(
    String^ name,
    TokenStream^ tokenStream,
    Field..::..TermVector^ termVector
)

Parameters

name
Type: System..::..String
The name of the field
tokenStream
Type: Lucene.Net.Analysis..::..TokenStream
The TokenStream with the content
termVector
Type: Lucene.Net.Documents..::..Field..::..TermVector
Whether term vector should be stored

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, Byte[], Field.Store)

[image]

Lucene.Net Class Libraries
Field Constructor (String, array<Byte>[]()[][], Field..::..Store)
Field Class See Also Send Feedback
Create a stored field with binary value. Optionally the value may be compressed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    byte[] value_Renamed,
    Field..::..Store store
)
Visual Basic
Public Sub New ( _
    name As String, _
    value_Renamed As Byte(), _
    store As Field..::..Store _
)
Visual C++
public:
Field(
    String^ name,
    array<unsigned char>^ value_Renamed,
    Field..::..Store^ store
)

Parameters

name
Type: System..::..String
The name of the field
value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.#ctor(System.String,System.Byte[],Lucene.Net.Documents.Field.Store)"]

store
Type: Lucene.Net.Documents..::..Field..::..Store
How
CopyC#
value
 should be stored (compressed or not)

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, TextReader, Field.TermVector)

[image]

Lucene.Net Class Libraries
Field Constructor (String, TextReader, Field..::..TermVector)
Field Class See Also Send Feedback
Create a tokenized and indexed field that is not stored, optionally with storing term vectors. The Reader is read only when the Document is added to the index, i.e. you may not close the Reader until {@link IndexWriter#AddDocument(Document)} has been called.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    TextReader reader,
    Field..::..TermVector termVector
)
Visual Basic
Public Sub New ( _
    name As String, _
    reader As TextReader, _
    termVector As Field..::..TermVector _
)
Visual C++
public:
Field(
    String^ name,
    TextReader^ reader,
    Field..::..TermVector^ termVector
)

Parameters

name
Type: System..::..String
The name of the field
reader
Type: System.IO..::..TextReader
The reader with the content
termVector
Type: Lucene.Net.Documents..::..Field..::..TermVector
Whether term vector should be stored

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, String, Field.Store, Field.Index)

[image]

Lucene.Net Class Libraries
Field Constructor (String, String, Field..::..Store, Field..::..Index)
Field Class See Also Send Feedback
Create a field by specifying its name, value and how it will be saved in the index. Term vectors will not be stored in the index.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    string value_Renamed,
    Field..::..Store store,
    Field..::..Index index
)
Visual Basic
Public Sub New ( _
    name As String, _
    value_Renamed As String, _
    store As Field..::..Store, _
    index As Field..::..Index _
)
Visual C++
public:
Field(
    String^ name,
    String^ value_Renamed,
    Field..::..Store^ store,
    Field..::..Index^ index
)

Parameters

name
Type: System..::..String
The name of the field
value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.#ctor(System.String,System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index)"]

store
Type: Lucene.Net.Documents..::..Field..::..Store
Whether
CopyC#
value
 should be stored in the index
index
Type: Lucene.Net.Documents..::..Field..::..Index
Whether the field should be indexed, and if so, if it should be tokenized before indexing

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, Byte[], Int32, Int32, Field.Store)

[image]

Lucene.Net Class Libraries
Field Constructor (String, array<Byte>[]()[][], Int32, Int32, Field..::..Store)
Field Class See Also Send Feedback
Create a stored field with binary value. Optionally the value may be compressed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    byte[] value_Renamed,
    int offset,
    int length,
    Field..::..Store store
)
Visual Basic
Public Sub New ( _
    name As String, _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer, _
    store As Field..::..Store _
)
Visual C++
public:
Field(
    String^ name,
    array<unsigned char>^ value_Renamed,
    int offset,
    int length,
    Field..::..Store^ store
)

Parameters

name
Type: System..::..String
The name of the field
value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.#ctor(System.String,System.Byte[],System.Int32,System.Int32,Lucene.Net.Documents.Field.Store)"]

offset
Type: System..::..Int32
Starting offset in value where this Field's bytes are
length
Type: System..::..Int32
Number of bytes to use for this Field, starting at offset
store
Type: Lucene.Net.Documents..::..Field..::..Store
How
CopyC#
value
 should be stored (compressed or not)

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, String, Field.Store, Field.Index, Field.TermVector)

[image]

Lucene.Net Class Libraries
Field Constructor (String, String, Field..::..Store, Field..::..Index, Field..::..TermVector)
Field Class See Also Send Feedback
Create a field by specifying its name, value and how it will be saved in the index.
  • the field is neither stored nor indexed
  • the field is not indexed but termVector is
    CopyC#
    TermVector.YES

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    string value_Renamed,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Visual Basic
Public Sub New ( _
    name As String, _
    value_Renamed As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
Visual C++
public:
Field(
    String^ name,
    String^ value_Renamed,
    Field..::..Store^ store,
    Field..::..Index^ index,
    Field..::..TermVector^ termVector
)

Parameters

name
Type: System..::..String
The name of the field
value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.#ctor(System.String,System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index,Lucene.Net.Documents.Field.TermVector)"]

store
Type: Lucene.Net.Documents..::..Field..::..Store
Whether
CopyC#
value
 should be stored in the index
index
Type: Lucene.Net.Documents..::..Field..::..Index
Whether the field should be indexed, and if so, if it should be tokenized before indexing
termVector
Type: Lucene.Net.Documents..::..Field..::..TermVector
Whether term vector should be stored

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Constructor (String, Boolean, String, Field.Store, Field.Index, Field.TermVector)

[image]

Lucene.Net Class Libraries
Field Constructor (String, Boolean, String, Field..::..Store, Field..::..Index, Field..::..TermVector)
Field Class See Also Send Feedback
Create a field by specifying its name, value and how it will be saved in the index.
  • the field is neither stored nor indexed
  • the field is not indexed but termVector is
    CopyC#
    TermVector.YES

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Field(
    string name,
    bool internName,
    string value_Renamed,
    Field..::..Store store,
    Field..::..Index index,
    Field..::..TermVector termVector
)
Visual Basic
Public Sub New ( _
    name As String, _
    internName As Boolean, _
    value_Renamed As String, _
    store As Field..::..Store, _
    index As Field..::..Index, _
    termVector As Field..::..TermVector _
)
Visual C++
public:
Field(
    String^ name,
    bool internName,
    String^ value_Renamed,
    Field..::..Store^ store,
    Field..::..Index^ index,
    Field..::..TermVector^ termVector
)

Parameters

name
Type: System..::..String
The name of the field
internName
Type: System..::..Boolean
Whether to .intern() name or not
value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.#ctor(System.String,System.Boolean,System.String,Lucene.Net.Documents.Field.Store,Lucene.Net.Documents.Field.Index,Lucene.Net.Documents.Field.TermVector)"]

store
Type: Lucene.Net.Documents..::..Field..::..Store
Whether
CopyC#
value
 should be stored in the index
index
Type: Lucene.Net.Documents..::..Field..::..Index
Whether the field should be indexed, and if so, if it should be tokenized before indexing
termVector
Type: Lucene.Net.Documents..::..Field..::..TermVector
Whether term vector should be stored

See Also

Field Class
Field Overload
Lucene.Net.Documents Namespace


Field Fields

[image] [image]

Lucene.Net Class Libraries
Field Fields
Field Class See Also Send Feedback

The Field type exposes the following members.

Fields

 | Name | Description
Protected field | binaryLength | (Inherited from AbstractField.)
Protected field | binaryOffset | (Inherited from AbstractField.)
Protected field | boost | (Inherited from AbstractField.)
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | isBinary | (Inherited from AbstractField.)
Protected field | isCompressed | (Inherited from AbstractField.)
Protected field | isIndexed | (Inherited from AbstractField.)
Protected field | isStored | (Inherited from AbstractField.)
Protected field | isTokenized | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | name | (Inherited from AbstractField.)
Protected field | omitNorms | (Inherited from AbstractField.)
Protected field | omitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)

See Also

Field Class
Lucene.Net.Documents Namespace


Field Methods

[image] [image]

Lucene.Net Class Libraries
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Public method BinaryValue Obsolete.
The value of the field in Binary, or null. If null, the Reader value, or String value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.
(Overrides AbstractField..::..BinaryValue()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
(Inherited from AbstractField.)
Public method | GetBinaryValue(array<Byte>[]()[][]) | (Inherited from AbstractField.)
Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

(Inherited from AbstractField.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetOmitNorms
True if norms are omitted for this indexed field
(Inherited from AbstractField.)
Public method | GetOmitTermFreqAndPositions | (Inherited from AbstractField.)
Public method | GetOmitTf | Obsolete. (Inherited from AbstractField.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsBinary
True iff the value of the filed is stored as binary
(Inherited from AbstractField.)
Public method IsCompressed
True if the value of the field is stored and compressed within the index
(Inherited from AbstractField.)
Public method IsIndexed
True iff the value of the field is to be indexed, so that it may be searched on.
(Inherited from AbstractField.)
Public method | IsLazy | (Inherited from AbstractField.)
Public method IsStored
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
(Inherited from AbstractField.)
Public method IsStoreOffsetWithTermVector
True iff terms are stored as term vector together with their offsets (start and end position in source text).
(Inherited from AbstractField.)
Public method IsStorePositionWithTermVector
True iff terms are stored as term vector together with their token positions.
(Inherited from AbstractField.)
Public method IsTermVectorStored
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
(Inherited from AbstractField.)
Public method IsTokenized
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
(Inherited from AbstractField.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
(Inherited from AbstractField.)
Public method ReaderValue
The value of the field as a Reader, or null. If null, the String value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.
(Overrides AbstractField..::..ReaderValue()()()().)
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

(Inherited from AbstractField.)
Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
(Inherited from AbstractField.)
Public method SetOmitTermFreqAndPositions
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

(Inherited from AbstractField.)
Public method | SetOmitTf | Obsolete. (Inherited from AbstractField.)
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method SetTokenStream
Expert: sets the token stream to be used for indexing and causes isIndexed() and isTokenized() to return true. May be combined with stored values from stringValue() or binaryValue()
Public method SetValue(array<Byte>[]()[][])
Expert: change the value of this field. See setValue(String).
Public method SetValue(TextReader)
Expert: change the value of this field. See setValue(String).
Public method SetValue(String)

Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents.

Each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.

Public method SetValue(TokenStream) Obsolete.
Expert: change the value of this field. See setValue(String).
Public method SetValue(array<Byte>[]()[][], Int32, Int32)
Expert: change the value of this field. See setValue(String).
Public method StringValue
The value of the field as a String, or null. If null, the Reader value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.
(Overrides AbstractField..::..StringValue()()()().)
Public method TokenStreamValue
The TokesStream for this field to be used when indexing, or null. If null, the Reader value or String value is analyzed to produce the indexed tokens.
(Overrides AbstractField..::..TokenStreamValue()()()().)
Public method ToString
Prints a Field for human consumption.
(Inherited from AbstractField.)

See Also

Field Class
Lucene.Net.Documents Namespace


BinaryValue Method

[image]

Lucene.Net Class Libraries
Field..::..BinaryValue Method
Field Class See Also Send Feedback
The value of the field in Binary, or null. If null, the Reader value, or String value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This method must allocate a new byte[] if the AbstractField.GetBinaryOffset() is non-zero or AbstractField.GetBinaryLength() is not the full length of the byte[]. Please use AbstractField.GetBinaryValue() instead, which simply returns the byte[].")]
public override byte[] BinaryValue()
Visual Basic
<ObsoleteAttribute("This method must allocate a new byte[] if the AbstractField.GetBinaryOffset() is non-zero or AbstractField.GetBinaryLength() is not the full length of the byte[]. Please use AbstractField.GetBinaryValue() instead, which simply returns the byte[].")> _
Public Overrides Function BinaryValue As Byte()
Visual C++
[ObsoleteAttribute(L"This method must allocate a new byte[] if the AbstractField.GetBinaryOffset() is non-zero or AbstractField.GetBinaryLength() is not the full length of the byte[]. Please use AbstractField.GetBinaryValue() instead, which simply returns the byte[].")]
public:
virtual array<unsigned char>^ BinaryValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Field.BinaryValue"]

Implements

Fieldable..::..BinaryValue()()()()
Fieldable..::..BinaryValue()()()()

See Also

Field Class
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image] [image]

Lucene.Net Class Libraries
Field..::..GetBinaryValue Method
Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBinaryValue()()()() | Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field. (Inherited from AbstractField.)
Public method | GetBinaryValue(array<Byte>[]()[][]) | (Inherited from AbstractField.)

See Also

Field Class
Field Members
Lucene.Net.Documents Namespace


ReaderValue Method

[image]

Lucene.Net Class Libraries
Field..::..ReaderValue Method
Field Class See Also Send Feedback
The value of the field as a Reader, or null. If null, the String value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TextReader ReaderValue()
Visual Basic
Public Overrides Function ReaderValue As TextReader
Visual C++
public:
virtual TextReader^ ReaderValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Field.ReaderValue"]

Implements

Fieldable..::..ReaderValue()()()()
Fieldable..::..ReaderValue()()()()

See Also

Field Class
Lucene.Net.Documents Namespace


SetTokenStream Method

[image]

Lucene.Net Class Libraries
Field..::..SetTokenStream Method
Field Class See Also Send Feedback
Expert: sets the token stream to be used for indexing and causes isIndexed() and isTokenized() to return true. May be combined with stored values from stringValue() or binaryValue()

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetTokenStream(
    TokenStream tokenStream
)
Visual Basic
Public Sub SetTokenStream ( _
    tokenStream As TokenStream _
)
Visual C++
public:
void SetTokenStream(
    TokenStream^ tokenStream
)

Parameters

tokenStream
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="tokenStream"/> documentation for "M:Lucene.Net.Documents.Field.SetTokenStream(Lucene.Net.Analysis.TokenStream)"]

See Also

Field Class
Lucene.Net.Documents Namespace


SetValue Method

[image] [image]

Lucene.Net Class Libraries
Field..::..SetValue Method
Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(array<Byte>[]()[][]) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(TextReader) | Expert: change the value of this field. See setValue(String).
Public method | SetValue(String) | Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents. Each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.
Public method | SetValue(TokenStream) | Obsolete. Expert: change the value of this field. See setValue(String).
Public method | SetValue(array<Byte>[]()[][], Int32, Int32) | Expert: change the value of this field. See setValue(String).

See Also

Field Class
Field Members
Lucene.Net.Documents Namespace


SetValue Method (Byte[])

[image]

Lucene.Net Class Libraries
Field..::..SetValue Method (array<Byte>[]()[][])
Field Class See Also Send Feedback
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetValue(
    byte[] value_Renamed
)
Visual Basic
Public Sub SetValue ( _
    value_Renamed As Byte() _
)
Visual C++
public:
void SetValue(
    array<unsigned char>^ value_Renamed
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(System.Byte[])"]

See Also

Field Class
SetValue Overload
Lucene.Net.Documents Namespace


SetValue Method (TextReader)

[image]

Lucene.Net Class Libraries
Field..::..SetValue Method (TextReader)
Field Class See Also Send Feedback
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetValue(
    TextReader value_Renamed
)
Visual Basic
Public Sub SetValue ( _
    value_Renamed As TextReader _
)
Visual C++
public:
void SetValue(
    TextReader^ value_Renamed
)

Parameters

value_Renamed
Type: System.IO..::..TextReader

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(System.IO.TextReader)"]

See Also

Field Class
SetValue Overload
Lucene.Net.Documents Namespace


SetValue Method (String)

[image]

Lucene.Net Class Libraries
Field..::..SetValue Method (String)
Field Class See Also Send Feedback

Expert: change the value of this field. This can be used during indexing to re-use a single Field instance to improve indexing speed by avoiding GC cost of new'ing and reclaiming Field instances. Typically a single {@link Document} instance is re-used as well. This helps most on small documents.

Each Field instance should only be used once within a single {@link Document} instance. See ImproveIndexingSpeed for details.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetValue(
    string value_Renamed
)
Visual Basic
Public Sub SetValue ( _
    value_Renamed As String _
)
Visual C++
public:
void SetValue(
    String^ value_Renamed
)

Parameters

value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(System.String)"]

See Also

Field Class
SetValue Overload
Lucene.Net.Documents Namespace


SetValue Method (TokenStream)

[image]

Lucene.Net Class Libraries
Field..::..SetValue Method (TokenStream)
Field Class See Also Send Feedback
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use SetTokenStream ")]
public void SetValue(
    TokenStream value_Renamed
)
Visual Basic
<ObsoleteAttribute("use SetTokenStream ")> _
Public Sub SetValue ( _
    value_Renamed As TokenStream _
)
Visual C++
[ObsoleteAttribute(L"use SetTokenStream ")]
public:
void SetValue(
    TokenStream^ value_Renamed
)

Parameters

value_Renamed
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(Lucene.Net.Analysis.TokenStream)"]

See Also

Field Class
SetValue Overload
Lucene.Net.Documents Namespace


SetValue Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Field..::..SetValue Method (array<Byte>[]()[][], Int32, Int32)
Field Class See Also Send Feedback
Expert: change the value of this field. See setValue(String).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetValue(
    byte[] value_Renamed,
    int offset,
    int length
)
Visual Basic
Public Sub SetValue ( _
    value_Renamed As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
void SetValue(
    array<unsigned char>^ value_Renamed,
    int offset,
    int length
)

Parameters

value_Renamed
Type: array< System..::..Byte >[]()[][]

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(System.Byte[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Documents.Field.SetValue(System.Byte[],System.Int32,System.Int32)"]

See Also

Field Class
SetValue Overload
Lucene.Net.Documents Namespace


StringValue Method

[image]

Lucene.Net Class Libraries
Field..::..StringValue Method
Field Class See Also Send Feedback
The value of the field as a String, or null. If null, the Reader value or binary value is used. Exactly one of stringValue(), readerValue(), and getBinaryValue() must be set.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string StringValue()
Visual Basic
Public Overrides Function StringValue As String
Visual C++
public:
virtual String^ StringValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Field.StringValue"]

Implements

Fieldable..::..StringValue()()()()
Fieldable..::..StringValue()()()()

See Also

Field Class
Lucene.Net.Documents Namespace


TokenStreamValue Method

[image]

Lucene.Net Class Libraries
Field..::..TokenStreamValue Method
Field Class See Also Send Feedback
The TokesStream for this field to be used when indexing, or null. If null, the Reader value or String value is analyzed to produce the indexed tokens.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStreamValue()
Visual Basic
Public Overrides Function TokenStreamValue As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStreamValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Field.TokenStreamValue"]

Implements

Fieldable..::..TokenStreamValue()()()()
Fieldable..::..TokenStreamValue()()()()

See Also

Field Class
Lucene.Net.Documents Namespace


Field.Index Class

[image]

Lucene.Net Class Libraries
Field..::..Index Class
Field Class Members See Also Send Feedback
Specifies whether and how a field should be indexed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Index : Parameter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Index _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class Index sealed : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Documents..::..Field..::..Index

See Also

Field..::..Index Members
Lucene.Net.Documents Namespace


Field.Index Members

[image] [image]

Lucene.Net Class Libraries
Field..::..Index Members
Field..::..Index Class Methods Fields See Also Send Feedback

A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.

The Field..::..Index type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

Fields

Name | Description
ANALYZED | Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.
ANALYZED_NO_NORMS | Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See {@link #NOT_ANALYZED_NO_NORMS} for what norms are and why you may want to disable them.
NO | Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is {@link Field.Store stored}.
NO_NORMS | Obsolete.
NOT_ANALYZED | Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.
NOT_ANALYZED_NO_NORMS | Expert: Index the field's value without an Analyzer, and also disable the storing of norms. Note that you can also separately enable/disable norms by calling {@link Field#setOmitNorms}. No norms means that index-time field and document boosting and field length normalization are disabled. The benefit is less memory usage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.
TOKENIZED | Obsolete.
UN_TOKENIZED | Obsolete.

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


Field.Index Fields

[image] [image]

Lucene.Net Class Libraries
Field..::..Index Fields
Field..::..Index Class See Also Send Feedback

The Field..::..Index type exposes the following members.

Fields

Name | Description
ANALYZED | Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.
ANALYZED_NO_NORMS | Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See {@link #NOT_ANALYZED_NO_NORMS} for what norms are and why you may want to disable them.
NO | Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is {@link Field.Store stored}.
NO_NORMS | Obsolete.
NOT_ANALYZED | Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.
NOT_ANALYZED_NO_NORMS | Expert: Index the field's value without an Analyzer, and also disable the storing of norms. Note that you can also separately enable/disable norms by calling {@link Field#setOmitNorms}. No norms means that index-time field and document boosting and field length normalization are disabled. The benefit is less memory usage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.
TOKENIZED | Obsolete.
UN_TOKENIZED | Obsolete.

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


ANALYZED Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..ANALYZED Field
Field..::..Index Class See Also Send Feedback
Index the tokens produced by running the field's value through an Analyzer. This is useful for common text.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Index ANALYZED
Visual Basic
Public Shared ReadOnly ANALYZED As Field..::..Index
Visual C++
public:
static initonly Field..::..Index^ ANALYZED

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


ANALYZED_NO_NORMS Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..ANALYZED_NO_NORMS Field
Field..::..Index Class See Also Send Feedback
Expert: Index the tokens produced by running the field's value through an Analyzer, and also separately disable the storing of norms. See {@link #NOT_ANALYZED_NO_NORMS} for what norms are and why you may want to disable them.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Index ANALYZED_NO_NORMS
Visual Basic
Public Shared ReadOnly ANALYZED_NO_NORMS As Field..::..Index
Visual C++
public:
static initonly Field..::..Index^ ANALYZED_NO_NORMS

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


NO Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..NO Field
Field..::..Index Class See Also Send Feedback
Do not index the field value. This field can thus not be searched, but one can still access its contents provided it is {@link Field.Store stored}.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Index NO
Visual Basic
Public Shared ReadOnly NO As Field..::..Index
Visual C++
public:
static initonly Field..::..Index^ NO

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


NO_NORMS Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..NO_NORMS Field
Field..::..Index Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.Field.Index.NO_NORMS"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This has been renamed to NOT_ANALYZED_NO_NORMS")]
public static readonly Field..::..Index NO_NORMS
Visual Basic
<ObsoleteAttribute("This has been renamed to NOT_ANALYZED_NO_NORMS")> _
Public Shared ReadOnly NO_NORMS As Field..::..Index
Visual C++
[ObsoleteAttribute(L"This has been renamed to NOT_ANALYZED_NO_NORMS")]
public:
static initonly Field..::..Index^ NO_NORMS

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


NOT_ANALYZED Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..NOT_ANALYZED Field
Field..::..Index Class See Also Send Feedback
Index the field's value without using an Analyzer, so it can be searched. As no analyzer is used the value will be stored as a single term. This is useful for unique Ids like product numbers.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Index NOT_ANALYZED
Visual Basic
Public Shared ReadOnly NOT_ANALYZED As Field..::..Index
Visual C++
public:
static initonly Field..::..Index^ NOT_ANALYZED

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


NOT_ANALYZED_NO_NORMS Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..NOT_ANALYZED_NO_NORMS Field
Field..::..Index Class See Also Send Feedback
Expert: Index the field's value without an Analyzer, and also disable the storing of norms. Note that you can also separately enable/disable norms by calling {@link Field#setOmitNorms}. No norms means that index-time field and document boosting and field length normalization are disabled. The benefit is less memory usage as norms take up one byte of RAM per indexed field for every document in the index, during searching. Note that once you index a given field with norms enabled, disabling norms will have no effect. In other words, for this to have the above described effect on a field, all instances of that field must be indexed with NOT_ANALYZED_NO_NORMS from the beginning.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Index NOT_ANALYZED_NO_NORMS
Visual Basic
Public Shared ReadOnly NOT_ANALYZED_NO_NORMS As Field..::..Index
Visual C++
public:
static initonly Field..::..Index^ NOT_ANALYZED_NO_NORMS

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


TOKENIZED Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..TOKENIZED Field
Field..::..Index Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.Field.Index.TOKENIZED"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("this has been renamed to ANALYZED")]
public static readonly Field..::..Index TOKENIZED
Visual Basic
<ObsoleteAttribute("this has been renamed to ANALYZED")> _
Public Shared ReadOnly TOKENIZED As Field..::..Index
Visual C++
[ObsoleteAttribute(L"this has been renamed to ANALYZED")]
public:
static initonly Field..::..Index^ TOKENIZED

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


UN_TOKENIZED Field

[image]

Lucene.Net Class Libraries
Field..::..Index..::..UN_TOKENIZED Field
Field..::..Index Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Documents.Field.Index.UN_TOKENIZED"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This has been renamed to NOT_ANALYZED")]
public static readonly Field..::..Index UN_TOKENIZED
Visual Basic
<ObsoleteAttribute("This has been renamed to NOT_ANALYZED")> _
Public Shared ReadOnly UN_TOKENIZED As Field..::..Index
Visual C++
[ObsoleteAttribute(L"This has been renamed to NOT_ANALYZED")]
public:
static initonly Field..::..Index^ UN_TOKENIZED

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


Field.Index Methods

[image] [image]

Lucene.Net Class Libraries
Field..::..Index Methods
Field..::..Index Class See Also Send Feedback

The Field..::..Index type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

See Also

Field..::..Index Class
Lucene.Net.Documents Namespace


Field.Store Class

[image]

Lucene.Net Class Libraries
Field..::..Store Class
Field Class Members See Also Send Feedback
Specifies whether and how a field should be stored.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Store : Parameter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Store _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class Store sealed : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Documents..::..Field..::..Store

See Also

Field..::..Store Members
Lucene.Net.Documents Namespace


Field.Store Members

[image] [image]

Lucene.Net Class Libraries
Field..::..Store Members
Field..::..Store Class Methods Fields See Also Send Feedback

A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.

The Field..::..Store type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

Fields

Name | Description
COMPRESS | Store the original field value in the index in a compressed form. This is useful for long documents and for binary valued fields.
NO | Do not store the field value in the index.
YES | Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.

See Also

Field..::..Store Class
Lucene.Net.Documents Namespace


Field.Store Fields

[image] [image]

Lucene.Net Class Libraries
Field..::..Store Fields
Field..::..Store Class See Also Send Feedback

The Field..::..Store type exposes the following members.

Fields

Name | Description
COMPRESS | Store the original field value in the index in a compressed form. This is useful for long documents and for binary valued fields.
NO | Do not store the field value in the index.
YES | Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.

See Also

Field..::..Store Class
Lucene.Net.Documents Namespace


COMPRESS Field

[image]

Lucene.Net Class Libraries
Field..::..Store..::..COMPRESS Field
Field..::..Store Class See Also Send Feedback
Store the original field value in the index in a compressed form. This is useful for long documents and for binary valued fields.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Store COMPRESS
Visual Basic
Public Shared ReadOnly COMPRESS As Field..::..Store
Visual C++
public:
static initonly Field..::..Store^ COMPRESS

See Also

Field..::..Store Class
Lucene.Net.Documents Namespace


NO Field

[image]

Lucene.Net Class Libraries
Field..::..Store..::..NO Field
Field..::..Store Class See Also Send Feedback
Do not store the field value in the index.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Store NO
Visual Basic
Public Shared ReadOnly NO As Field..::..Store
Visual C++
public:
static initonly Field..::..Store^ NO

See Also

Field..::..Store Class
Lucene.Net.Documents Namespace


YES Field

[image]

Lucene.Net Class Libraries
Field..::..Store..::..YES Field
Field..::..Store Class See Also Send Feedback
Store the original field value in the index. This is useful for short texts like a document's title which should be displayed with the results. The value is stored in its original form, i.e. no analyzer is used before it is stored.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..Store YES
Visual Basic
Public Shared ReadOnly YES As Field..::..Store
Visual C++
public:
static initonly Field..::..Store^ YES

See Also

Field..::..Store Class
Lucene.Net.Documents Namespace


Field.Store Methods

[image] [image]

Lucene.Net Class Libraries
Field..::..Store Methods
Field..::..Store Class See Also Send Feedback

The Field..::..Store type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

See Also

Field..::..Store Class
Lucene.Net.Documents Namespace


Field.TermVector Class

[image]

Lucene.Net Class Libraries
Field..::..TermVector Class
Field Class Members See Also Send Feedback
Specifies whether and how a field should have term vectors.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class TermVector : Parameter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class TermVector _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class TermVector sealed : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Documents..::..Field..::..TermVector

See Also

Field..::..TermVector Members
Lucene.Net.Documents Namespace


Field.TermVector Members

[image] [image]

Lucene.Net Class Libraries
Field..::..TermVector Members
Field..::..TermVector Class Methods Fields See Also Send Feedback

A field is a section of a Document. Each field has two parts, a name and a value. Values may be free text, provided as a String or as a Reader, or they may be atomic keywords, which are not further processed. Such keywords may be used to represent dates, urls, etc. Fields are optionally stored in the index, so that they may be returned with hits on the document.

The Field..::..TermVector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

Fields

Name | Description
NO | Do not store term vectors.
WITH_OFFSETS | Store the term vector + Token offset information
WITH_POSITIONS | Store the term vector + token position information
WITH_POSITIONS_OFFSETS | Store the term vector + Token position and offset information
YES | Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurrences in that document.

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace


Field.TermVector Fields

[image] [image]

Lucene.Net Class Libraries
Field..::..TermVector Fields
Field..::..TermVector Class See Also Send Feedback

The Field..::..TermVector type exposes the following members.

Fields

Name | Description
NO | Do not store term vectors.
WITH_OFFSETS | Store the term vector + Token offset information
WITH_POSITIONS | Store the term vector + token position information
WITH_POSITIONS_OFFSETS | Store the term vector + Token position and offset information
YES | Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurrences in that document.

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace


NO Field

[image]

Lucene.Net Class Libraries
Field..::..TermVector..::..NO Field
Field..::..TermVector Class See Also Send Feedback
Do not store term vectors.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..TermVector NO
Visual Basic
Public Shared ReadOnly NO As Field..::..TermVector
Visual C++
public:
static initonly Field..::..TermVector^ NO

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace


WITH_OFFSETS Field

[image]

Lucene.Net Class Libraries
Field..::..TermVector..::..WITH_OFFSETS Field
Field..::..TermVector Class See Also Send Feedback
Store the term vector + Token offset information

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..TermVector WITH_OFFSETS
Visual Basic
Public Shared ReadOnly WITH_OFFSETS As Field..::..TermVector
Visual C++
public:
static initonly Field..::..TermVector^ WITH_OFFSETS

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace
Field..::..TermVector..::..YES


WITH_POSITIONS Field

[image]

Lucene.Net Class Libraries
Field..::..TermVector..::..WITH_POSITIONS Field
Field..::..TermVector Class See Also Send Feedback
Store the term vector + token position information

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..TermVector WITH_POSITIONS
Visual Basic
Public Shared ReadOnly WITH_POSITIONS As Field..::..TermVector
Visual C++
public:
static initonly Field..::..TermVector^ WITH_POSITIONS

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace
Field..::..TermVector..::..YES


WITH_POSITIONS_OFFSETS Field

[image]

Lucene.Net Class Libraries
Field..::..TermVector..::..WITH_POSITIONS_OFFSETS Field
Field..::..TermVector Class See Also Send Feedback
Store the term vector + Token position and offset information

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..TermVector WITH_POSITIONS_OFFSETS
Visual Basic
Public Shared ReadOnly WITH_POSITIONS_OFFSETS As Field..::..TermVector
Visual C++
public:
static initonly Field..::..TermVector^ WITH_POSITIONS_OFFSETS

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace
Field..::..TermVector..::..YES
Field..::..TermVector..::..WITH_POSITIONS
Field..::..TermVector..::..WITH_OFFSETS


YES Field

[image]

Lucene.Net Class Libraries
Field..::..TermVector..::..YES Field
Field..::..TermVector Class See Also Send Feedback
Store the term vectors of each document. A term vector is a list of the document's terms and their number of occurrences in that document.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Field..::..TermVector YES
Visual Basic
Public Shared ReadOnly YES As Field..::..TermVector
Visual C++
public:
static initonly Field..::..TermVector^ YES

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace


Field.TermVector Methods

[image] [image]

Lucene.Net Class Libraries
Field..::..TermVector Methods
Field..::..TermVector Class See Also Send Feedback

The Field..::..TermVector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

See Also

Field..::..TermVector Class
Lucene.Net.Documents Namespace


Fieldable Interface

[image]

Lucene.Net Class Libraries
Fieldable Interface
Members See Also Send Feedback
Synonymous with {@link Field}.

WARNING: This interface may change within minor versions, despite Lucene's backward compatibility requirements. This means new methods may be added from version to version. This change only affects the Fieldable API; other backwards compatibility promises remain intact. For example, Lucene can still read and write indices created within the same major version.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface Fieldable
Visual Basic
Public Interface Fieldable
Visual C++
public interface class Fieldable

See Also

Fieldable Members
Lucene.Net.Documents Namespace


Fieldable Members

[image] [image]

Lucene.Net Class Libraries
Fieldable Members
Fieldable Interface Methods See Also Send Feedback

The Fieldable type exposes the following members.

Methods

Name | Description
Public method BinaryValue
The value of the field in Binary, or null.
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
Public method GetBinaryValue(array<Byte>[]()[][])
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.

About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to {@link #BinaryValue()} or {@link #GetBinaryValue()}. So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

Public method GetOmitNorms
True if norms are omitted for this indexed field
Public method | GetOmitTf | Obsolete.
Public method IsBinary
True if the value of the field is stored as binary
Public method IsCompressed
True if the value of the field is stored and compressed within the index
Public method IsIndexed
True if the value of the field is to be indexed, so that it may be searched on.
Public method IsLazy
Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via {@link #StringValue()} or {@link #BinaryValue()} is only valid as long as the {@link Lucene.Net.Index.IndexReader} that retrieved the {@link Document} is still open.
Public method IsStored
True if the value of the field is to be stored in the index for return with search hits.
Public method IsStoreOffsetWithTermVector
True if terms are stored as term vector together with their offsets (start and end positon in source text).
Public method IsStorePositionWithTermVector
True if terms are stored as term vector together with their token positions.
Public method IsTermVectorStored
True if the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
Public method IsTokenized
True if the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public method ReaderValue
The value of the field as a Reader, which can be used at index time to generate indexed tokens.
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multiplied by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
Public method | SetOmitTf | Obsolete.
Public method StringValue
The value of the field as a String, or null.

For indexing, if isStored()==true, the stringValue() will be used as the stored field value unless isBinary()==true, in which case binaryValue() will be used. If isIndexed()==true and isTokenized()==false, this String value will be indexed as a single token. If isIndexed()==true and isTokenized()==true, then tokenStreamValue() will be used to generate indexed tokens if not null, else readerValue() will be used to generate indexed tokens if not null, else stringValue() will be used to generate tokens.

Public method TokenStreamValue
The TokenStream for this field to be used when indexing, or null.

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


Fieldable Methods

[image] [image]

Lucene.Net Class Libraries
Fieldable Methods
Fieldable Interface See Also Send Feedback

The Fieldable type exposes the following members.

Methods

Name | Description
Public method BinaryValue
The value of the field in Binary, or null.
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
Public method GetBinaryValue(array<Byte>[]()[][])
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.

About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to {@link #BinaryValue()} or {@link #GetBinaryValue()}. So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

Public method GetOmitNorms
True if norms are omitted for this indexed field
Public method | GetOmitTf | Obsolete.
Public method IsBinary
True if the value of the field is stored as binary
Public method IsCompressed
True if the value of the field is stored and compressed within the index
Public method IsIndexed
True if the value of the field is to be indexed, so that it may be searched on.
Public method IsLazy
Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via {@link #StringValue()} or {@link #BinaryValue()} is only valid as long as the {@link Lucene.Net.Index.IndexReader} that retrieved the {@link Document} is still open.
Public method IsStored
True if the value of the field is to be stored in the index for return with search hits.
Public method IsStoreOffsetWithTermVector
True if terms are stored as term vector together with their offsets (start and end positon in source text).
Public method IsStorePositionWithTermVector
True if terms are stored as term vector together with their token positions.
Public method IsTermVectorStored
True if the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
Public method IsTokenized
True if the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
Public method ReaderValue
The value of the field as a Reader, which can be used at index time to generate indexed tokens.
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multiplied by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
Public method | SetOmitTf | Obsolete.
Public method StringValue
The value of the field as a String, or null.

For indexing, if isStored()==true, the stringValue() will be used as the stored field value unless isBinary()==true, in which case binaryValue() will be used. If isIndexed()==true and isTokenized()==false, this String value will be indexed as a single token. If isIndexed()==true and isTokenized()==true, then tokenStreamValue() will be used to generate indexed tokens if not null, else readerValue() will be used to generate indexed tokens if not null, else stringValue() will be used to generate tokens.

Public method TokenStreamValue
The TokenStream for this field to be used when indexing, or null.

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


BinaryValue Method

[image]

Lucene.Net Class Libraries
Fieldable..::..BinaryValue Method
Fieldable Interface See Also Send Feedback
The value of the field in Binary, or null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
byte[] BinaryValue()
Visual Basic
Function BinaryValue As Byte()
Visual C++
array<unsigned char>^ BinaryValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.BinaryValue"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace
Fieldable..::..StringValue()()()()


GetBinaryLength Method

[image]

Lucene.Net Class Libraries
Fieldable..::..GetBinaryLength Method
Fieldable Interface See Also Send Feedback
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetBinaryLength()
Visual Basic
Function GetBinaryLength As Integer
Visual C++
int GetBinaryLength()

Return Value

length of byte[] segment that represents this Field value

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


GetBinaryOffset Method

[image]

Lucene.Net Class Libraries
Fieldable..::..GetBinaryOffset Method
Fieldable Interface See Also Send Feedback
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetBinaryOffset()
Visual Basic
Function GetBinaryOffset As Integer
Visual C++
int GetBinaryOffset()

Return Value

index of the first character in byte[] segment that represents this Field value

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image] [image]

Lucene.Net Class Libraries
Fieldable..::..GetBinaryValue Method
Fieldable Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBinaryValue()()()() | Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
Public method | GetBinaryValue(array<Byte>[]()[][]) | Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field. About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to {@link #BinaryValue()} or {@link #GetBinaryValue()}. So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

See Also

Fieldable Interface
Fieldable Members
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image]

Lucene.Net Class Libraries
Fieldable..::..GetBinaryValue Method
Fieldable Interface See Also Send Feedback
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
byte[] GetBinaryValue()
Visual Basic
Function GetBinaryValue As Byte()
Visual C++
array<unsigned char>^ GetBinaryValue()

Return Value

reference to the Field value as byte[].

See Also

Fieldable Interface
GetBinaryValue Overload
Lucene.Net.Documents Namespace


GetBinaryValue Method (Byte[])

[image]

Lucene.Net Class Libraries
Fieldable..::..GetBinaryValue Method (array<Byte>[]()[][])
Fieldable Interface See Also Send Feedback
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.

About reuse: if you pass in the result byte[] and it is used, likely the underlying implementation will hold onto this byte[] and return it in future calls to {@link #BinaryValue()} or {@link #GetBinaryValue()}. So if you subsequently re-use the same byte[] elsewhere it will alter this Fieldable's value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
byte[] GetBinaryValue(
    byte[] result
)
Visual Basic
Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
Visual C++
array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
)

Parameters

result
Type: array< System..::..Byte >[]()[][]
User defined buffer that will be used if possible. If this is null or not large enough, a new buffer is allocated

Return Value

reference to the Field value as byte[].

See Also

Fieldable Interface
GetBinaryValue Overload
Lucene.Net.Documents Namespace


GetBoost Method

[image]

Lucene.Net Class Libraries
Fieldable..::..GetBoost Method
Fieldable Interface See Also Send Feedback
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
float GetBoost()
Visual Basic
Function GetBoost As Single
Visual C++
float GetBoost()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.GetBoost"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace
Fieldable..::..SetBoost(Single)


GetOmitNorms Method

[image]

Lucene.Net Class Libraries
Fieldable..::..GetOmitNorms Method
Fieldable Interface See Also Send Feedback
True if norms are omitted for this indexed field

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool GetOmitNorms()
Visual Basic
Function GetOmitNorms As Boolean
Visual C++
bool GetOmitNorms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.GetOmitNorms"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


GetOmitTf Method

[image]

Lucene.Net Class Libraries
Fieldable..::..GetOmitTf Method
Fieldable Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.Fieldable.GetOmitTf"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Renamed to AbstractField.GetOmitTermFreqAndPositions")]
bool GetOmitTf()
Visual Basic
<ObsoleteAttribute("Renamed to AbstractField.GetOmitTermFreqAndPositions")> _
Function GetOmitTf As Boolean
Visual C++
[ObsoleteAttribute(L"Renamed to AbstractField.GetOmitTermFreqAndPositions")]
bool GetOmitTf()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.GetOmitTf"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsBinary Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsBinary Method
Fieldable Interface See Also Send Feedback
True if the value of the field is stored as binary

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsBinary()
Visual Basic
Function IsBinary As Boolean
Visual C++
bool IsBinary()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsBinary"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsCompressed Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsCompressed Method
Fieldable Interface See Also Send Feedback
True if the value of the field is stored and compressed within the index

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsCompressed()
Visual Basic
Function IsCompressed As Boolean
Visual C++
bool IsCompressed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsCompressed"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsIndexed Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsIndexed Method
Fieldable Interface See Also Send Feedback
True if the value of the field is to be indexed, so that it may be searched on.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsIndexed()
Visual Basic
Function IsIndexed As Boolean
Visual C++
bool IsIndexed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsIndexed"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsLazy Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsLazy Method
Fieldable Interface See Also Send Feedback
Indicates whether a Field is Lazy or not. The semantics of Lazy loading are such that if a Field is lazily loaded, retrieving it's values via {@link #StringValue()} or {@link #BinaryValue()} is only valid as long as the {@link Lucene.Net.Index.IndexReader} that retrieved the {@link Document} is still open.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsLazy()
Visual Basic
Function IsLazy As Boolean
Visual C++
bool IsLazy()

Return Value

true if this field can be loaded lazily

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsStored Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsStored Method
Fieldable Interface See Also Send Feedback
True if the value of the field is to be stored in the index for return with search hits.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsStored()
Visual Basic
Function IsStored As Boolean
Visual C++
bool IsStored()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsStored"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsStoreOffsetWithTermVector Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsStoreOffsetWithTermVector Method
Fieldable Interface See Also Send Feedback
True if terms are stored as term vector together with their offsets (start and end positon in source text).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsStoreOffsetWithTermVector()
Visual Basic
Function IsStoreOffsetWithTermVector As Boolean
Visual C++
bool IsStoreOffsetWithTermVector()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsStoreOffsetWithTermVector"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsStorePositionWithTermVector Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsStorePositionWithTermVector Method
Fieldable Interface See Also Send Feedback
True if terms are stored as term vector together with their token positions.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsStorePositionWithTermVector()
Visual Basic
Function IsStorePositionWithTermVector As Boolean
Visual C++
bool IsStorePositionWithTermVector()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsStorePositionWithTermVector"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


IsTermVectorStored Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsTermVectorStored Method
Fieldable Interface See Also Send Feedback
True if the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsTermVectorStored()
Visual Basic
Function IsTermVectorStored As Boolean
Visual C++
bool IsTermVectorStored()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsTermVectorStored"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace
IndexReader..::..GetTermFreqVector(Int32, String)


IsTokenized Method

[image]

Lucene.Net Class Libraries
Fieldable..::..IsTokenized Method
Fieldable Interface See Also Send Feedback
True if the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsTokenized()
Visual Basic
Function IsTokenized As Boolean
Visual C++
bool IsTokenized()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.IsTokenized"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


Name Method

[image]

Lucene.Net Class Libraries
Fieldable..::..Name Method
Fieldable Interface See Also Send Feedback
Returns the name of the field as an interned string. For example "date", "title", "body", ...

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string Name()
Visual Basic
Function Name As String
Visual C++
String^ Name()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.Name"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


ReaderValue Method

[image]

Lucene.Net Class Libraries
Fieldable..::..ReaderValue Method
Fieldable Interface See Also Send Feedback
The value of the field as a Reader, which can be used at index time to generate indexed tokens.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
TextReader ReaderValue()
Visual Basic
Function ReaderValue As TextReader
Visual C++
TextReader^ ReaderValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.ReaderValue"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace
Fieldable..::..StringValue()()()()


SetBoost Method

[image]

Lucene.Net Class Libraries
Fieldable..::..SetBoost Method
Fieldable Interface See Also Send Feedback
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multiplied by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetBoost(
    float boost
)
Visual Basic
Sub SetBoost ( _
    boost As Single _
)
Visual C++
void SetBoost(
    float boost
)

Parameters

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Documents.Fieldable.SetBoost(System.Single)"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace
Document..::..SetBoost(Single)
Similarity..::..ComputeNorm(String, FieldInvertState)
Similarity..::..EncodeNorm(Single)


SetOmitNorms Method

[image]

Lucene.Net Class Libraries
Fieldable..::..SetOmitNorms Method
Fieldable Interface See Also Send Feedback
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetOmitNorms(
    bool omitNorms
)
Visual Basic
Sub SetOmitNorms ( _
    omitNorms As Boolean _
)
Visual C++
void SetOmitNorms(
    bool omitNorms
)

Parameters

omitNorms
Type: System..::..Boolean

[Missing <param name="omitNorms"/> documentation for "M:Lucene.Net.Documents.Fieldable.SetOmitNorms(System.Boolean)"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


SetOmitTf Method

[image]

Lucene.Net Class Libraries
Fieldable..::..SetOmitTf Method
Fieldable Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.Fieldable.SetOmitTf(System.Boolean)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Renamed to AbstractField.SetOmitTermFreqAndPositions")]
void SetOmitTf(
    bool omitTf
)
Visual Basic
<ObsoleteAttribute("Renamed to AbstractField.SetOmitTermFreqAndPositions")> _
Sub SetOmitTf ( _
    omitTf As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Renamed to AbstractField.SetOmitTermFreqAndPositions")]
void SetOmitTf(
    bool omitTf
)

Parameters

omitTf
Type: System..::..Boolean

[Missing <param name="omitTf"/> documentation for "M:Lucene.Net.Documents.Fieldable.SetOmitTf(System.Boolean)"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


StringValue Method

[image]

Lucene.Net Class Libraries
Fieldable..::..StringValue Method
Fieldable Interface See Also Send Feedback
The value of the field as a String, or null.

For indexing, if isStored()==true, the stringValue() will be used as the stored field value unless isBinary()==true, in which case binaryValue() will be used. If isIndexed()==true and isTokenized()==false, this String value will be indexed as a single token. If isIndexed()==true and isTokenized()==true, then tokenStreamValue() will be used to generate indexed tokens if not null, else readerValue() will be used to generate indexed tokens if not null, else stringValue() will be used to generate tokens.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string StringValue()
Visual Basic
Function StringValue As String
Visual C++
String^ StringValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.StringValue"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace


TokenStreamValue Method

[image]

Lucene.Net Class Libraries
Fieldable..::..TokenStreamValue Method
Fieldable Interface See Also Send Feedback
The TokenStream for this field to be used when indexing, or null.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
TokenStream TokenStreamValue()
Visual Basic
Function TokenStreamValue As TokenStream
Visual C++
TokenStream^ TokenStreamValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.Fieldable.TokenStreamValue"]

See Also

Fieldable Interface
Lucene.Net.Documents Namespace
Fieldable..::..StringValue()()()()


FieldSelector Interface

[image]

Lucene.Net Class Libraries
FieldSelector Interface
Members See Also Send Feedback
Similar to a {@link java.io.FileFilter}, the FieldSelector allows one to make decisions about what Fields get loaded on a {@link Document} by {@link Lucene.Net.Index.IndexReader#Document(int,Lucene.Net.Documents.FieldSelector)}

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface FieldSelector
Visual Basic
Public Interface FieldSelector
Visual C++
public interface class FieldSelector

See Also

FieldSelector Members
Lucene.Net.Documents Namespace


FieldSelector Members

[image] [image]

Lucene.Net Class Libraries
FieldSelector Members
FieldSelector Interface Methods See Also Send Feedback

The FieldSelector type exposes the following members.

Methods

 | Name | Description
Public method | Accept |

See Also

FieldSelector Interface
Lucene.Net.Documents Namespace


FieldSelector Methods

[image] [image]

Lucene.Net Class Libraries
FieldSelector Methods
FieldSelector Interface See Also Send Feedback

The FieldSelector type exposes the following members.

Methods

 | Name | Description
Public method | Accept |

See Also

FieldSelector Interface
Lucene.Net.Documents Namespace


Accept Method

[image]

Lucene.Net Class Libraries
FieldSelector..::..Accept Method
FieldSelector Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.FieldSelector.Accept(System.String)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
FieldSelectorResult Accept(
    string fieldName
)
Visual Basic
Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
Visual C++
FieldSelectorResult^ Accept(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
the field to accept or reject

Return Value

an instance of {@link FieldSelectorResult} if the {@link Field} named
CopyC#
fieldName
 should be loaded.

See Also

FieldSelector Interface
Lucene.Net.Documents Namespace


FieldSelectorResult Class

[image]

Lucene.Net Class Libraries
FieldSelectorResult Class
Members See Also Send Feedback
Provides information about what should be done with this Field

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class FieldSelectorResult
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class FieldSelectorResult
Visual C++
[SerializableAttribute]
public ref class FieldSelectorResult sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..FieldSelectorResult

See Also

FieldSelectorResult Members
Lucene.Net.Documents Namespace


FieldSelectorResult Members

[image] [image]

Lucene.Net Class Libraries
FieldSelectorResult Members
FieldSelectorResult Class Methods Fields See Also Send Feedback

The FieldSelectorResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LAZY_LOAD | Lazily load this {@link Field}. This means the {@link Field} is valid, but it may not actually contain its data until invoked. {@link Document#GetField(String)} SHOULD NOT BE USED. {@link Document#GetFieldable(String)} is safe to use and should return a valid instance of a {@link Fieldable}. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD | Load this {@link Field} every time the {@link Document} is loaded, reading in the data as it is encountered. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_AND_BREAK | Load this field as in the {@link #LOAD} case, but immediately return from {@link Field} loading for the {@link Document}. Thus, the Document may not have its complete set of Fields. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should both be valid for this {@link Field} {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_FOR_MERGE | Obsolete. Behaves much like {@link #LOAD} but does not uncompress any compressed data. This is used for internal purposes. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
NO_LOAD | Do not load the {@link Field}. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should return null. {@link Document#Add(Fieldable)} is not called. {@link Document#Add(Fieldable)} should not be called by the Reader.
SIZE | Expert: Load the size of this {@link Field} rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]
SIZE_AND_BREAK | Expert: Like {@link #SIZE} but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


FieldSelectorResult Fields

[image] [image]

Lucene.Net Class Libraries
FieldSelectorResult Fields
FieldSelectorResult Class See Also Send Feedback

The FieldSelectorResult type exposes the following members.

Fields

Name | Description
LAZY_LOAD | Lazily load this {@link Field}. This means the {@link Field} is valid, but it may not actually contain its data until invoked. {@link Document#GetField(String)} SHOULD NOT BE USED. {@link Document#GetFieldable(String)} is safe to use and should return a valid instance of a {@link Fieldable}. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD | Load this {@link Field} every time the {@link Document} is loaded, reading in the data as it is encountered. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_AND_BREAK | Load this field as in the {@link #LOAD} case, but immediately return from {@link Field} loading for the {@link Document}. Thus, the Document may not have its complete set of Fields. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should both be valid for this {@link Field} {@link Document#Add(Fieldable)} should be called by the Reader.
LOAD_FOR_MERGE | Obsolete. Behaves much like {@link #LOAD} but does not uncompress any compressed data. This is used for internal purposes. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null. {@link Document#Add(Fieldable)} should be called by the Reader.
NO_LOAD | Do not load the {@link Field}. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should return null. {@link Document#Add(Fieldable)} is not called. {@link Document#Add(Fieldable)} should not be called by the Reader.
SIZE | Expert: Load the size of this {@link Field} rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]
SIZE_AND_BREAK | Expert: Like {@link #SIZE} but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


LAZY_LOAD Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..LAZY_LOAD Field
FieldSelectorResult Class See Also Send Feedback
Lazily load this {@link Field}. This means the {@link Field} is valid, but it may not actually contain its data until invoked. {@link Document#GetField(String)} SHOULD NOT BE USED. {@link Document#GetFieldable(String)} is safe to use and should return a valid instance of a {@link Fieldable}.

{@link Document#Add(Fieldable)} should be called by the Reader.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly FieldSelectorResult LAZY_LOAD
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly LAZY_LOAD As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
public:
static initonly FieldSelectorResult^ LAZY_LOAD

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


LOAD Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..LOAD Field
FieldSelectorResult Class See Also Send Feedback
Load this {@link Field} every time the {@link Document} is loaded, reading in the data as it is encountered. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null.

{@link Document#Add(Fieldable)} should be called by the Reader.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly FieldSelectorResult LOAD
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly LOAD As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
public:
static initonly FieldSelectorResult^ LOAD

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


LOAD_AND_BREAK Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..LOAD_AND_BREAK Field
FieldSelectorResult Class See Also Send Feedback
Load this field as in the {@link #LOAD} case, but immediately return from {@link Field} loading for the {@link Document}. Thus, the Document may not have its complete set of Fields. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should both be valid for this {@link Field}

{@link Document#Add(Fieldable)} should be called by the Reader.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly FieldSelectorResult LOAD_AND_BREAK
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly LOAD_AND_BREAK As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
public:
static initonly FieldSelectorResult^ LOAD_AND_BREAK

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


LOAD_FOR_MERGE Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..LOAD_FOR_MERGE Field
FieldSelectorResult Class See Also Send Feedback
Behaves much like {@link #LOAD} but does not uncompress any compressed data. This is used for internal purposes. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should not return null.

{@link Document#Add(Fieldable)} should be called by the Reader.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
[ObsoleteAttribute("This is an internal option only, and is no longer needed now that CompressionTools is used for field compression.")]
public static readonly FieldSelectorResult LOAD_FOR_MERGE
Visual Basic
<NonSerializedAttribute> _
<ObsoleteAttribute("This is an internal option only, and is no longer needed now that CompressionTools is used for field compression.")> _
Public Shared ReadOnly LOAD_FOR_MERGE As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
[ObsoleteAttribute(L"This is an internal option only, and is no longer needed now that CompressionTools is used for field compression.")]
public:
static initonly FieldSelectorResult^ LOAD_FOR_MERGE

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


NO_LOAD Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..NO_LOAD Field
FieldSelectorResult Class See Also Send Feedback
Do not load the {@link Field}. {@link Document#GetField(String)} and {@link Document#GetFieldable(String)} should return null. {@link Document#Add(Fieldable)} is not called.

{@link Document#Add(Fieldable)} should not be called by the Reader.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly FieldSelectorResult NO_LOAD
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly NO_LOAD As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
public:
static initonly FieldSelectorResult^ NO_LOAD

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


SIZE Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..SIZE Field
FieldSelectorResult Class See Also Send Feedback
Expert: Load the size of this {@link Field} rather than its value. Size is measured as number of bytes required to store the field == bytes for a binary or any compressed value, and 2*chars for a String value. The size is stored as a binary value, represented as an int in a byte[], with the higher order byte first in [0]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly FieldSelectorResult SIZE
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly SIZE As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
public:
static initonly FieldSelectorResult^ SIZE

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


SIZE_AND_BREAK Field

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..SIZE_AND_BREAK Field
FieldSelectorResult Class See Also Send Feedback
Expert: Like {@link #SIZE} but immediately break from the field loading loop, i.e., stop loading further fields, after the size is loaded

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly FieldSelectorResult SIZE_AND_BREAK
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly SIZE_AND_BREAK As FieldSelectorResult
Visual C++
[NonSerializedAttribute]
public:
static initonly FieldSelectorResult^ SIZE_AND_BREAK

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


FieldSelectorResult Methods

[image] [image]

Lucene.Net Class Libraries
FieldSelectorResult Methods
FieldSelectorResult Class See Also Send Feedback

The FieldSelectorResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..Equals Method
FieldSelectorResult Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.FieldSelectorResult.Equals(System.Object)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Documents.FieldSelectorResult.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.FieldSelectorResult.Equals(System.Object)"]

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FieldSelectorResult..::..GetHashCode Method
FieldSelectorResult Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.FieldSelectorResult.GetHashCode"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.FieldSelectorResult.GetHashCode"]

See Also

FieldSelectorResult Class
Lucene.Net.Documents Namespace


LoadFirstFieldSelector Class

[image]

Lucene.Net Class Libraries
LoadFirstFieldSelector Class
Members See Also Send Feedback
Load the First field and break.

See {@link FieldSelectorResult#LOAD_AND_BREAK}

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class LoadFirstFieldSelector : FieldSelector
Visual Basic
<SerializableAttribute> _
Public Class LoadFirstFieldSelector _
    Implements FieldSelector
Visual C++
[SerializableAttribute]
public ref class LoadFirstFieldSelector : FieldSelector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..LoadFirstFieldSelector

See Also

LoadFirstFieldSelector Members
Lucene.Net.Documents Namespace


LoadFirstFieldSelector Members

[image] [image]

Lucene.Net Class Libraries
LoadFirstFieldSelector Members
LoadFirstFieldSelector Class Constructors Methods See Also Send Feedback

The LoadFirstFieldSelector type exposes the following members.

Constructors

 | Name | Description
Public method | LoadFirstFieldSelector | Initializes a new instance of the LoadFirstFieldSelector class

Methods

 | Name | Description
Public method | Accept |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadFirstFieldSelector Class
Lucene.Net.Documents Namespace


LoadFirstFieldSelector Constructor

[image]

Lucene.Net Class Libraries
LoadFirstFieldSelector Constructor
LoadFirstFieldSelector Class See Also Send Feedback
Initializes a new instance of the LoadFirstFieldSelector class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LoadFirstFieldSelector()
Visual Basic
Public Sub New
Visual C++
public:
LoadFirstFieldSelector()

See Also

LoadFirstFieldSelector Class
Lucene.Net.Documents Namespace


LoadFirstFieldSelector Methods

[image] [image]

Lucene.Net Class Libraries
LoadFirstFieldSelector Methods
LoadFirstFieldSelector Class See Also Send Feedback

The LoadFirstFieldSelector type exposes the following members.

Methods

 | Name | Description
Public method | Accept |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadFirstFieldSelector Class
Lucene.Net.Documents Namespace


Accept Method

[image]

Lucene.Net Class Libraries
LoadFirstFieldSelector..::..Accept Method
LoadFirstFieldSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.LoadFirstFieldSelector.Accept(System.String)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldSelectorResult Accept(
    string fieldName
)
Visual Basic
Public Overridable Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
Visual C++
public:
virtual FieldSelectorResult^ Accept(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Documents.LoadFirstFieldSelector.Accept(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.LoadFirstFieldSelector.Accept(System.String)"]

Implements

FieldSelector..::..Accept(String)

See Also

LoadFirstFieldSelector Class
Lucene.Net.Documents Namespace


MapFieldSelector Class

[image]

Lucene.Net Class Libraries
MapFieldSelector Class
Members See Also Send Feedback
A {@link FieldSelector} based on a Map of field names to {@link FieldSelectorResult}s

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MapFieldSelector : FieldSelector
Visual Basic
<SerializableAttribute> _
Public Class MapFieldSelector _
    Implements FieldSelector
Visual C++
[SerializableAttribute]
public ref class MapFieldSelector : FieldSelector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..MapFieldSelector

See Also

MapFieldSelector Members
Lucene.Net.Documents Namespace


MapFieldSelector Members

[image] [image]

Lucene.Net Class Libraries
MapFieldSelector Members
MapFieldSelector Class Constructors Methods See Also Send Feedback

The MapFieldSelector type exposes the following members.

Constructors

 | Name | Description
Public method | MapFieldSelector(IDictionary) | Create a a MapFieldSelector
Public method | MapFieldSelector(IList) | Create a a MapFieldSelector
Public method | MapFieldSelector(array<String>[]()[][]) | Create a a MapFieldSelector

Methods

 | Name | Description
Public method | Accept | Load field according to its associated value in fieldSelections
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapFieldSelector Class
Lucene.Net.Documents Namespace


MapFieldSelector Constructor

[image] [image]

Lucene.Net Class Libraries
MapFieldSelector Constructor
MapFieldSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MapFieldSelector(IDictionary) | Create a a MapFieldSelector
Public method | MapFieldSelector(IList) | Create a a MapFieldSelector
Public method | MapFieldSelector(array<String>[]()[][]) | Create a a MapFieldSelector

See Also

MapFieldSelector Class
MapFieldSelector Members
Lucene.Net.Documents Namespace


MapFieldSelector Constructor (IDictionary)

[image]

Lucene.Net Class Libraries
MapFieldSelector Constructor (IDictionary)
MapFieldSelector Class See Also Send Feedback
Create a a MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MapFieldSelector(
    IDictionary fieldSelections
)
Visual Basic
Public Sub New ( _
    fieldSelections As IDictionary _
)
Visual C++
public:
MapFieldSelector(
    IDictionary^ fieldSelections
)

Parameters

fieldSelections
Type: System.Collections..::..IDictionary
maps from field names (String) to {@link FieldSelectorResult}s

See Also

MapFieldSelector Class
MapFieldSelector Overload
Lucene.Net.Documents Namespace


MapFieldSelector Constructor (IList)

[image]

Lucene.Net Class Libraries
MapFieldSelector Constructor (IList)
MapFieldSelector Class See Also Send Feedback
Create a a MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MapFieldSelector(
    IList fields
)
Visual Basic
Public Sub New ( _
    fields As IList _
)
Visual C++
public:
MapFieldSelector(
    IList^ fields
)

Parameters

fields
Type: System.Collections..::..IList
fields to LOAD. List of Strings. All other fields are NO_LOAD.

See Also

MapFieldSelector Class
MapFieldSelector Overload
Lucene.Net.Documents Namespace


MapFieldSelector Constructor (String[])

[image]

Lucene.Net Class Libraries
MapFieldSelector Constructor (array<String>[]()[][])
MapFieldSelector Class See Also Send Feedback
Create a a MapFieldSelector

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MapFieldSelector(
    string[] fields
)
Visual Basic
Public Sub New ( _
    fields As String() _
)
Visual C++
public:
MapFieldSelector(
    array<String^>^ fields
)

Parameters

fields
Type: array< System..::..String >[]()[][]
fields to LOAD. All other fields are NO_LOAD.

See Also

MapFieldSelector Class
MapFieldSelector Overload
Lucene.Net.Documents Namespace


MapFieldSelector Methods

[image] [image]

Lucene.Net Class Libraries
MapFieldSelector Methods
MapFieldSelector Class See Also Send Feedback

The MapFieldSelector type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Load field according to its associated value in fieldSelections
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapFieldSelector Class
Lucene.Net.Documents Namespace


Accept Method

[image]

Lucene.Net Class Libraries
MapFieldSelector..::..Accept Method
MapFieldSelector Class See Also Send Feedback
Load field according to its associated value in fieldSelections

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldSelectorResult Accept(
    string field
)
Visual Basic
Public Overridable Function Accept ( _
    field As String _
) As FieldSelectorResult
Visual C++
public:
virtual FieldSelectorResult^ Accept(
    String^ field
)

Parameters

field
Type: System..::..String
a field name

Return Value

the fieldSelections value that field maps to or NO_LOAD if none.

Implements

FieldSelector..::..Accept(String)

See Also

MapFieldSelector Class
Lucene.Net.Documents Namespace


NumberTools Class

[image]

Lucene.Net Class Libraries
NumberTools Class
Members See Also Send Feedback
Provides support for converting longs to Strings, and back again. The strings are structured so that lexicographic sorting order is preserved.

That is, if l1 is less than l2 for any two longs l1 and l2, then NumberTools.longToString(l1) is lexicographically less than NumberTools.longToString(l2). (Similarly for "greater than" and "equals".)

This class handles all long values (unlike {@link Lucene.Net.Documents.DateField}).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release.")]
public class NumberTools
Visual Basic
<ObsoleteAttribute("For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release.")> _
Public Class NumberTools
Visual C++
[ObsoleteAttribute(L"For new indexes use NumericUtils instead, which provides a sortable binary representation (prefix encoded) of numeric values. To index and efficiently query numeric values use NumericField and NumericRangeQuery. This class is included for use with existing indices and will be removed in a future release.")]
public ref class NumberTools

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..NumberTools

See Also

NumberTools Members
Lucene.Net.Documents Namespace


NumberTools Members

[image] [image]

Lucene.Net Class Libraries
NumberTools Members
NumberTools Class Constructors Methods Fields See Also Send Feedback

The NumberTools type exposes the following members.

Constructors

 | Name | Description
Public method | NumberTools | Initializes a new instance of the NumberTools class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LongToString | Converts a long to a String suitable for indexing.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StringToLong | Converts a String that was returned by {@link #longToString} back to a long.
 | ToLong |
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToString(Int64) |

Fields

Name | Description
MAX_STRING_VALUE | Equivalent to longToString(Long.MAX_VALUE)
MIN_STRING_VALUE | Equivalent to longToString(Long.MIN_VALUE)
STR_SIZE | The length of (all) strings returned by {@link #longToString}

See Also

NumberTools Class
Lucene.Net.Documents Namespace


NumberTools Constructor

[image]

Lucene.Net Class Libraries
NumberTools Constructor
NumberTools Class See Also Send Feedback
Initializes a new instance of the NumberTools class

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumberTools()
Visual Basic
Public Sub New
Visual C++
public:
NumberTools()

See Also

NumberTools Class
Lucene.Net.Documents Namespace


NumberTools Fields

[image] [image]

Lucene.Net Class Libraries
NumberTools Fields
NumberTools Class See Also Send Feedback

The NumberTools type exposes the following members.

Fields

Name | Description
MAX_STRING_VALUE | Equivalent to longToString(Long.MAX_VALUE)
MIN_STRING_VALUE | Equivalent to longToString(Long.MIN_VALUE)
STR_SIZE | The length of (all) strings returned by {@link #longToString}

See Also

NumberTools Class
Lucene.Net.Documents Namespace


MAX_STRING_VALUE Field

[image]

Lucene.Net Class Libraries
NumberTools..::..MAX_STRING_VALUE Field
NumberTools Class See Also Send Feedback
Equivalent to longToString(Long.MAX_VALUE)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string MAX_STRING_VALUE
Visual Basic
Public Shared ReadOnly MAX_STRING_VALUE As String
Visual C++
public:
static initonly String^ MAX_STRING_VALUE

See Also

NumberTools Class
Lucene.Net.Documents Namespace


MIN_STRING_VALUE Field

[image]

Lucene.Net Class Libraries
NumberTools..::..MIN_STRING_VALUE Field
NumberTools Class See Also Send Feedback
Equivalent to longToString(Long.MIN_VALUE)

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string MIN_STRING_VALUE
Visual Basic
Public Shared ReadOnly MIN_STRING_VALUE As String
Visual C++
public:
static initonly String^ MIN_STRING_VALUE

See Also

NumberTools Class
Lucene.Net.Documents Namespace


STR_SIZE Field

[image]

Lucene.Net Class Libraries
NumberTools..::..STR_SIZE Field
NumberTools Class See Also Send Feedback
The length of (all) strings returned by {@link #longToString}

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int STR_SIZE
Visual Basic
Public Shared ReadOnly STR_SIZE As Integer
Visual C++
public:
static initonly int STR_SIZE

See Also

NumberTools Class
Lucene.Net.Documents Namespace


NumberTools Methods

[image] [image]

Lucene.Net Class Libraries
NumberTools Methods
NumberTools Class See Also Send Feedback

The NumberTools type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LongToString | Converts a long to a String suitable for indexing.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StringToLong | Converts a String that was returned by {@link #longToString} back to a long.
 | ToLong |
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToString(Int64) |

See Also

NumberTools Class
Lucene.Net.Documents Namespace


LongToString Method

[image]

Lucene.Net Class Libraries
NumberTools..::..LongToString Method
NumberTools Class See Also Send Feedback
Converts a long to a String suitable for indexing.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string LongToString(
    long l
)
Visual Basic
Public Shared Function LongToString ( _
    l As Long _
) As String
Visual C++
public:
static String^ LongToString(
    long long l
)

Parameters

l
Type: System..::..Int64

[Missing <param name="l"/> documentation for "M:Lucene.Net.Documents.NumberTools.LongToString(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumberTools.LongToString(System.Int64)"]

See Also

NumberTools Class
Lucene.Net.Documents Namespace


StringToLong Method

[image]

Lucene.Net Class Libraries
NumberTools..::..StringToLong Method
NumberTools Class See Also Send Feedback
Converts a String that was returned by {@link #longToString} back to a long.
if the input is null
if the input does not parse (it was not a String returned by longToString()).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long StringToLong(
    string str
)
Visual Basic
Public Shared Function StringToLong ( _
    str As String _
) As Long
Visual C++
public:
static long long StringToLong(
    String^ str
)

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Lucene.Net.Documents.NumberTools.StringToLong(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumberTools.StringToLong(System.String)"]

See Also

NumberTools Class
Lucene.Net.Documents Namespace


ToLong Method

[image]

Lucene.Net Class Libraries
NumberTools..::..ToLong Method
NumberTools Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.NumberTools.ToLong(System.String)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long ToLong(
    string t
)
Visual Basic
Public Shared Function ToLong ( _
    t As String _
) As Long
Visual C++
public:
static long long ToLong(
    String^ t
)

Parameters

t
Type: System..::..String

[Missing <param name="t"/> documentation for "M:Lucene.Net.Documents.NumberTools.ToLong(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumberTools.ToLong(System.String)"]

See Also

NumberTools Class
Lucene.Net.Documents Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
NumberTools..::..ToString Method
NumberTools Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToString(Int64) |

See Also

NumberTools Class
NumberTools Members
Lucene.Net.Documents Namespace


ToString Method (Int64)

[image]

Lucene.Net Class Libraries
NumberTools..::..ToString Method (Int64)
NumberTools Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Documents.NumberTools.ToString(System.Int64)"]

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string ToString(
    long lval
)
Visual Basic
Public Shared Function ToString ( _
    lval As Long _
) As String
Visual C++
public:
static String^ ToString(
    long long lval
)

Parameters

lval
Type: System..::..Int64

[Missing <param name="lval"/> documentation for "M:Lucene.Net.Documents.NumberTools.ToString(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumberTools.ToString(System.Int64)"]

See Also

NumberTools Class
ToString Overload
Lucene.Net.Documents Namespace


NumericField Class

[image]

Lucene.Net Class Libraries
NumericField Class
Members See Also Send Feedback

This class provides a {@link Field} that enables indexing of numeric values for efficient range filtering and sorting. Here's an example usage, adding an int value:

            document.add(new NumericField(name).setIntValue(value));
For optimal performance, re-use the
CopyC#
NumericField
 and {@link Document} instance for more than one document:
            NumericField field = new NumericField(name);
            Document document = new Document();
            document.add(field);

            for(all documents) {
            ...
            field.setIntValue(value)
            writer.addDocument(document);
            ...
            }

The java native types

CopyC#
int
,
CopyC#
long
,
CopyC#
float
 and
CopyC#
double
 are directly supported. However, any value that can be converted into these native types can also be indexed. For example, date/time values represented by a {@link java.util.Date} can be translated into a long value using the {@link java.util.Date#getTime} method. If you don't need millisecond precision, you can quantize the value, either by dividing the result of {@link java.util.Date#getTime} or using the separate getters (for year, month, etc.) to construct an
CopyC#
int
 or
CopyC#
long
 value.

To perform range querying or filtering against a

CopyC#
NumericField
, use {@link NumericRangeQuery} or {@link NumericRangeFilter}. To sort according to a
CopyC#
NumericField
, use the normal numeric sort types, eg {@link SortField#INT} (note that {@link SortField#AUTO} will not work with these fields).
CopyC#
NumericField
 values can also be loaded directly from {@link FieldCache}.

By default, a

CopyC#
NumericField
's value is not stored but is indexed for range filtering and sorting. You can use the {@link #NumericField(String,Field.Store,boolean)} constructor if you need to change these defaults.

You may add the same field name as a

CopyC#
NumericField
to the same document more than once. Range querying and filtering will be the logical OR of all values; so a range query will hit all documents that have at least one value in the range. However sort behavior is not defined. If you need to sort, you should separately index a single-valued
CopyC#
NumericField
.

A

CopyC#
NumericField
will consume somewhat more disk space in the index than an ordinary single-valued field. However, for a typical index that includes substantial textual content per document, this increase will likely be in the noise.

Within Lucene, each numeric value is indexed as a trie structure, where each term is logically assigned to larger and larger pre-defined brackets (which are simply lower-precision representations of the value). The step size between each successive bracket is called the

CopyC#
precisionStep
, measured in bits. Smaller
CopyC#
precisionStep
 values result in larger number of brackets, which consumes more disk space in the index but may result in faster range search performance. The default value, 4, was selected for a reasonable tradeoff of disk space consumption versus performance. You can use the expert constructor {@link #NumericField(String,int,Field.Store,boolean)} if you'd like to change the value. Note that you must also specify a congruent value when creating {@link NumericRangeQuery} or {@link NumericRangeFilter}. For low cardinality fields larger precision steps are good. If the cardinality is < 100, it is fair to use {@link Integer#MAX_VALUE}, which produces one term per value.

For more information on the internals of numeric trie indexing, including the

CopyC#
precisionStep
configuration, see {@link NumericRangeQuery}. The format of indexed values is described in {@link NumericUtils}.

If you only need to sort by numeric value, and never run range querying/filtering, you can index using a

CopyC#
precisionStep
of {@link Integer#MAX_VALUE}. This will minimize disk space consumed.

More advanced users can instead use {@link NumericTokenStream} directly, when indexing numbers. This class is a wrapper around this token stream type for easier, more intuitive usage.

NOTE: This class is only used during indexing. When retrieving the stored field value from a {@link Document} instance after search, you will get a conventional {@link Fieldable} instance where the numeric values are returned as {@link String}s (according to

CopyC#
toString(value)
of the used data type).

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class NumericField : AbstractField
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class NumericField _
    Inherits AbstractField
Visual C++
[SerializableAttribute]
public ref class NumericField sealed : public AbstractField

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..AbstractField
Lucene.Net.Documents..::..NumericField

See Also

NumericField Members
Lucene.Net.Documents Namespace


NumericField Members

[image] [image]

Lucene.Net Class Libraries
NumericField Members
NumericField Class Constructors Methods Fields See Also Send Feedback

The NumericField type exposes the following members.

Constructors

Name Description
Public method NumericField(String)
Creates a field for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method NumericField(String, Int32)
Creates a field for numeric values with the specified
CopyC#
precisionStep
. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method NumericField(String, Field..::..Store, Boolean)
Creates a field for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.
Public method NumericField(String, Int32, Field..::..Store, Boolean)
Creates a field for numeric values with the specified
CopyC#
precisionStep
. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.

Methods

Name | Description
Public method BinaryValue
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..BinaryValue()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
(Inherited from AbstractField.)
Public method GetBinaryValue(array<Byte>[]()[][])
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..GetBinaryValue(array<Byte>[]()[][]).)
Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

(Inherited from AbstractField.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetNumericValue
Returns the current numeric value as a subclass of {@link Number},
CopyC#
null
 if not yet initialized.
Public method GetOmitNorms
True if norms are omitted for this indexed field
(Inherited from AbstractField.)
Public method | GetOmitTermFreqAndPositions | (Inherited from AbstractField.)
Public method | GetOmitTf | Obsolete. (Inherited from AbstractField.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsBinary
True iff the value of the filed is stored as binary
(Inherited from AbstractField.)
Public method IsCompressed
True if the value of the field is stored and compressed within the index
(Inherited from AbstractField.)
Public method IsIndexed
True iff the value of the field is to be indexed, so that it may be searched on.
(Inherited from AbstractField.)
Public method | IsLazy | (Inherited from AbstractField.)
Public method IsStored
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
(Inherited from AbstractField.)
Public method IsStoreOffsetWithTermVector
True iff terms are stored as term vector together with their offsets (start and end position in source text).
(Inherited from AbstractField.)
Public method IsStorePositionWithTermVector
True iff terms are stored as term vector together with their token positions.
(Inherited from AbstractField.)
Public method IsTermVectorStored
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
(Inherited from AbstractField.)
Public method IsTokenized
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
(Inherited from AbstractField.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
(Inherited from AbstractField.)
Public method ReaderValue
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..ReaderValue()()()().)
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

(Inherited from AbstractField.)
Public method SetDoubleValue
Initializes the field with the supplied
CopyC#
double
 value.
Public method SetFloatValue
Initializes the field with the supplied
CopyC#
float
 value.
Public method SetIntValue
Initializes the field with the supplied
CopyC#
int
 value.
Public method SetLongValue
Initializes the field with the supplied
CopyC#
long
 value.
Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
(Inherited from AbstractField.)
Public method SetOmitTermFreqAndPositions
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

(Inherited from AbstractField.)
Public method | SetOmitTf | Obsolete. (Inherited from AbstractField.)
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method StringValue
Returns the numeric value as a string (how it is stored, when {@link Field.Store#YES} is chosen).
(Overrides AbstractField..::..StringValue()()()().)
Public method TokenStreamValue
Returns a {@link NumericTokenStream} for indexing the numeric value.
(Overrides AbstractField..::..TokenStreamValue()()()().)
Public method ToString
Prints a Field for human consumption.
(Inherited from AbstractField.)

Fields

 | Name | Description
Protected field | binaryLength | (Inherited from AbstractField.)
Protected field | binaryOffset | (Inherited from AbstractField.)
Protected field | boost | (Inherited from AbstractField.)
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | isBinary | (Inherited from AbstractField.)
Protected field | isCompressed | (Inherited from AbstractField.)
Protected field | isIndexed | (Inherited from AbstractField.)
Protected field | isStored | (Inherited from AbstractField.)
Protected field | isTokenized | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | name | (Inherited from AbstractField.)
Protected field | omitNorms | (Inherited from AbstractField.)
Protected field | omitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)

See Also

NumericField Class
Lucene.Net.Documents Namespace


NumericField Constructor

[image] [image]

Lucene.Net Class Libraries
NumericField Constructor
NumericField Class See Also Send Feedback

Overload List

Name Description
Public method NumericField(String)
Creates a field for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method NumericField(String, Int32)
Creates a field for numeric values with the specified
CopyC#
precisionStep
. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.
Public method NumericField(String, Field..::..Store, Boolean)
Creates a field for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.
Public method NumericField(String, Int32, Field..::..Store, Boolean)
Creates a field for numeric values with the specified
CopyC#
precisionStep
. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.

See Also

NumericField Class
NumericField Members
Lucene.Net.Documents Namespace


NumericField Constructor (String)

[image]

Lucene.Net Class Libraries
NumericField Constructor (String)
NumericField Class See Also Send Feedback
Creates a field for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
NumericField(
    String^ name
)

Parameters

name
Type: System..::..String
the field name

See Also

NumericField Class
NumericField Overload
Lucene.Net.Documents Namespace


NumericField Constructor (String, Int32)

[image]

Lucene.Net Class Libraries
NumericField Constructor (String, Int32)
NumericField Class See Also Send Feedback
Creates a field for numeric values with the specified
CopyC#
precisionStep
. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods. This constructor creates an indexed, but not stored field.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField(
    string name,
    int precisionStep
)
Visual Basic
Public Sub New ( _
    name As String, _
    precisionStep As Integer _
)
Visual C++
public:
NumericField(
    String^ name,
    int precisionStep
)

Parameters

name
Type: System..::..String
the field name
precisionStep
Type: System..::..Int32
the used precision step

See Also

NumericField Class
NumericField Overload
Lucene.Net.Documents Namespace


NumericField Constructor (String, Field.Store, Boolean)

[image]

Lucene.Net Class Libraries
NumericField Constructor (String, Field..::..Store, Boolean)
NumericField Class See Also Send Feedback
Creates a field for numeric values using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField(
    string name,
    Field..::..Store store,
    bool index
)
Visual Basic
Public Sub New ( _
    name As String, _
    store As Field..::..Store, _
    index As Boolean _
)
Visual C++
public:
NumericField(
    String^ name,
    Field..::..Store^ store,
    bool index
)

Parameters

name
Type: System..::..String
the field name
store
Type: Lucene.Net.Documents..::..Field..::..Store
if the field should be stored in plain text form (according to
CopyC#
toString(value)
 of the used data type)
index
Type: System..::..Boolean
if the field should be indexed using {@link NumericTokenStream}

See Also

NumericField Class
NumericField Overload
Lucene.Net.Documents Namespace


NumericField Constructor (String, Int32, Field.Store, Boolean)

[image]

Lucene.Net Class Libraries
NumericField Constructor (String, Int32, Field..::..Store, Boolean)
NumericField Class See Also Send Feedback
Creates a field for numeric values with the specified
CopyC#
precisionStep
. The instance is not yet initialized with a numeric value, before indexing a document containing this field, set a value using the various set???Value() methods.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField(
    string name,
    int precisionStep,
    Field..::..Store store,
    bool index
)
Visual Basic
Public Sub New ( _
    name As String, _
    precisionStep As Integer, _
    store As Field..::..Store, _
    index As Boolean _
)
Visual C++
public:
NumericField(
    String^ name,
    int precisionStep,
    Field..::..Store^ store,
    bool index
)

Parameters

name
Type: System..::..String
the field name
precisionStep
Type: System..::..Int32
the used precision step
store
Type: Lucene.Net.Documents..::..Field..::..Store
if the field should be stored in plain text form (according to
CopyC#
toString(value)
 of the used data type)
index
Type: System..::..Boolean
if the field should be indexed using {@link NumericTokenStream}

See Also

NumericField Class
NumericField Overload
Lucene.Net.Documents Namespace


NumericField Fields

[image] [image]

Lucene.Net Class Libraries
NumericField Fields
NumericField Class See Also Send Feedback

The NumericField type exposes the following members.

Fields

 | Name | Description
Protected field | binaryLength | (Inherited from AbstractField.)
Protected field | binaryOffset | (Inherited from AbstractField.)
Protected field | boost | (Inherited from AbstractField.)
Protected field | fieldsData | (Inherited from AbstractField.)
Protected field | isBinary | (Inherited from AbstractField.)
Protected field | isCompressed | (Inherited from AbstractField.)
Protected field | isIndexed | (Inherited from AbstractField.)
Protected field | isStored | (Inherited from AbstractField.)
Protected field | isTokenized | (Inherited from AbstractField.)
Protected field | lazy | (Inherited from AbstractField.)
Protected field | name | (Inherited from AbstractField.)
Protected field | omitNorms | (Inherited from AbstractField.)
Protected field | omitTermFreqAndPositions | (Inherited from AbstractField.)
Protected field | storeOffsetWithTermVector | (Inherited from AbstractField.)
Protected field | storePositionWithTermVector | (Inherited from AbstractField.)
Protected field | storeTermVector | (Inherited from AbstractField.)
Protected field | tokenStream | (Inherited from AbstractField.)

See Also

NumericField Class
Lucene.Net.Documents Namespace


NumericField Methods

[image] [image]

Lucene.Net Class Libraries
NumericField Methods
NumericField Class See Also Send Feedback

The NumericField type exposes the following members.

Methods

Name | Description
Public method BinaryValue
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..BinaryValue()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBinaryLength
Returns length of byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryOffset
Returns offset into byte[] segment that is used as value, if Field is not binary returned value is undefined
(Inherited from AbstractField.)
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
(Inherited from AbstractField.)
Public method GetBinaryValue(array<Byte>[]()[][])
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..GetBinaryValue(array<Byte>[]()[][]).)
Public method GetBoost
Returns the boost factor for hits for this field.

The default value is 1.0.

Note: this value is not stored directly with the document in the index. Documents returned from {@link Lucene.Net.Index.IndexReader#Document(int)} and {@link Lucene.Net.Search.Hits#Doc(int)} may thus not have the same value present as when this field was indexed.

(Inherited from AbstractField.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetNumericValue
Returns the current numeric value as a subclass of {@link Number},
CopyC#
null
 if not yet initialized.
Public method GetOmitNorms
True if norms are omitted for this indexed field
(Inherited from AbstractField.)
Public method | GetOmitTermFreqAndPositions | (Inherited from AbstractField.)
Public method | GetOmitTf | Obsolete. (Inherited from AbstractField.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsBinary
True iff the value of the filed is stored as binary
(Inherited from AbstractField.)
Public method IsCompressed
True if the value of the field is stored and compressed within the index
(Inherited from AbstractField.)
Public method IsIndexed
True iff the value of the field is to be indexed, so that it may be searched on.
(Inherited from AbstractField.)
Public method | IsLazy | (Inherited from AbstractField.)
Public method IsStored
True iff the value of the field is to be stored in the index for return with search hits. It is an error for this to be true if a field is Reader-valued.
(Inherited from AbstractField.)
Public method IsStoreOffsetWithTermVector
True iff terms are stored as term vector together with their offsets (start and end position in source text).
(Inherited from AbstractField.)
Public method IsStorePositionWithTermVector
True iff terms are stored as term vector together with their token positions.
(Inherited from AbstractField.)
Public method IsTermVectorStored
True iff the term or terms used to index this field are stored as a term vector, available from {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}. These methods do not provide access to the original content of the field, only to terms used to index it. If the original content must be preserved, use the
CopyC#
stored
 attribute instead.
(Inherited from AbstractField.)
Public method IsTokenized
True iff the value of the field should be tokenized as text prior to indexing. Un-tokenized fields are indexed as a single word and may not be Reader-valued.
(Inherited from AbstractField.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
Returns the name of the field as an interned string. For example "date", "title", "body", ...
(Inherited from AbstractField.)
Public method ReaderValue
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..ReaderValue()()()().)
Public method SetBoost
Sets the boost factor hits on this field. This value will be multiplied into the score of all hits on this this field of this document.

The boost is multiplied by {@link Lucene.Net.Documents.Document#GetBoost()} of the document containing this field. If a document has multiple fields with the same name, all such values are multiplied together. This product is then used to compute the norm factor for the field. By default, in the {@link Lucene.Net.Search.Similarity#ComputeNorm(String, FieldInvertState)} method, the boost value is multipled by the {@link Lucene.Net.Search.Similarity#LengthNorm(String, int)} and then rounded by {@link Lucene.Net.Search.Similarity#EncodeNorm(float)} before it is stored in the index. One should attempt to ensure that this product does not overflow the range of that encoding.

(Inherited from AbstractField.)
Public method SetDoubleValue
Initializes the field with the supplied
CopyC#
double
 value.
Public method SetFloatValue
Initializes the field with the supplied
CopyC#
float
 value.
Public method SetIntValue
Initializes the field with the supplied
CopyC#
int
 value.
Public method SetLongValue
Initializes the field with the supplied
CopyC#
long
 value.
Public method SetOmitNorms
Expert: If set, omit normalization factors associated with this indexed field. This effectively disables indexing boosts and length normalization for this field.
(Inherited from AbstractField.)
Public method SetOmitTermFreqAndPositions
Expert: If set, omit term freq, positions and payloads from postings for this field.

NOTE: While this option reduces storage space required in the index, it also means any query requiring positional information, such as {@link PhraseQuery} or {@link SpanQuery} subclasses will silently fail to find results.

(Inherited from AbstractField.)
Public method | SetOmitTf | Obsolete. (Inherited from AbstractField.)
Protected method | SetStoreTermVector | (Inherited from AbstractField.)
Public method StringValue
Returns the numeric value as a string (how it is stored, when {@link Field.Store#YES} is chosen).
(Overrides AbstractField..::..StringValue()()()().)
Public method TokenStreamValue
Returns a {@link NumericTokenStream} for indexing the numeric value.
(Overrides AbstractField..::..TokenStreamValue()()()().)
Public method ToString
Prints a Field for human consumption.
(Inherited from AbstractField.)

See Also

NumericField Class
Lucene.Net.Documents Namespace


BinaryValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..BinaryValue Method
NumericField Class See Also Send Feedback
Returns always
CopyC#
null
 for numeric fields

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] BinaryValue()
Visual Basic
Public Overrides Function BinaryValue As Byte()
Visual C++
public:
virtual array<unsigned char>^ BinaryValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumericField.BinaryValue"]

Implements

Fieldable..::..BinaryValue()()()()

See Also

NumericField Class
Lucene.Net.Documents Namespace


GetBinaryValue Method

[image] [image]

Lucene.Net Class Libraries
NumericField..::..GetBinaryValue Method
NumericField Class See Also Send Feedback

Overload List

Name Description
Public method GetBinaryValue()()()()
Return the raw byte[] for the binary field. Note that you must also call {@link #getBinaryLength} and {@link #getBinaryOffset} to know which range of bytes in this returned array belong to the field.
(Inherited from AbstractField.)
Public method GetBinaryValue(array<Byte>[]()[][])
Returns always
CopyC#
null
 for numeric fields
(Overrides AbstractField..::..GetBinaryValue(array<Byte>[]()[][]).)

See Also

NumericField Class
NumericField Members
Lucene.Net.Documents Namespace


GetBinaryValue Method (Byte[])

[image]

Lucene.Net Class Libraries
NumericField..::..GetBinaryValue Method (array<Byte>[]()[][])
NumericField Class See Also Send Feedback
Returns always
CopyC#
null
 for numeric fields

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] GetBinaryValue(
    byte[] result
)
Visual Basic
Public Overrides Function GetBinaryValue ( _
    result As Byte() _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetBinaryValue(
    array<unsigned char>^ result
) override

Parameters

result
Type: array< System..::..Byte >[]()[][]

[Missing <param name="result"/> documentation for "M:Lucene.Net.Documents.NumericField.GetBinaryValue(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumericField.GetBinaryValue(System.Byte[])"]

Implements

Fieldable..::..GetBinaryValue(array<Byte>[]()[][])

See Also

NumericField Class
GetBinaryValue Overload
Lucene.Net.Documents Namespace


GetNumericValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..GetNumericValue Method
NumericField Class See Also Send Feedback
Returns the current numeric value as a subclass of {@link Number},
CopyC#
null
 if not yet initialized.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueType GetNumericValue()
Visual Basic
Public Function GetNumericValue As ValueType
Visual C++
public:
ValueType^ GetNumericValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumericField.GetNumericValue"]

See Also

NumericField Class
Lucene.Net.Documents Namespace


ReaderValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..ReaderValue Method
NumericField Class See Also Send Feedback
Returns always
CopyC#
null
 for numeric fields

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TextReader ReaderValue()
Visual Basic
Public Overrides Function ReaderValue As TextReader
Visual C++
public:
virtual TextReader^ ReaderValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumericField.ReaderValue"]

Implements

Fieldable..::..ReaderValue()()()()

See Also

NumericField Class
Lucene.Net.Documents Namespace


SetDoubleValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..SetDoubleValue Method
NumericField Class See Also Send Feedback
Initializes the field with the supplied
CopyC#
double
 value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField SetDoubleValue(
    double value_Renamed
)
Visual Basic
Public Function SetDoubleValue ( _
    value_Renamed As Double _
) As NumericField
Visual C++
public:
NumericField^ SetDoubleValue(
    double value_Renamed
)

Parameters

value_Renamed
Type: System..::..Double

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.NumericField.SetDoubleValue(System.Double)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
document.add(new NumericField(name, precisionStep).setDoubleValue(value))

See Also

NumericField Class
Lucene.Net.Documents Namespace


SetFloatValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..SetFloatValue Method
NumericField Class See Also Send Feedback
Initializes the field with the supplied
CopyC#
float
 value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField SetFloatValue(
    float value_Renamed
)
Visual Basic
Public Function SetFloatValue ( _
    value_Renamed As Single _
) As NumericField
Visual C++
public:
NumericField^ SetFloatValue(
    float value_Renamed
)

Parameters

value_Renamed
Type: System..::..Single

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.NumericField.SetFloatValue(System.Single)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
document.add(new NumericField(name, precisionStep).setFloatValue(value))

See Also

NumericField Class
Lucene.Net.Documents Namespace


SetIntValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..SetIntValue Method
NumericField Class See Also Send Feedback
Initializes the field with the supplied
CopyC#
int
 value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField SetIntValue(
    int value_Renamed
)
Visual Basic
Public Function SetIntValue ( _
    value_Renamed As Integer _
) As NumericField
Visual C++
public:
NumericField^ SetIntValue(
    int value_Renamed
)

Parameters

value_Renamed
Type: System..::..Int32

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.NumericField.SetIntValue(System.Int32)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
document.add(new NumericField(name, precisionStep).setIntValue(value))

See Also

NumericField Class
Lucene.Net.Documents Namespace


SetLongValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..SetLongValue Method
NumericField Class See Also Send Feedback
Initializes the field with the supplied
CopyC#
long
 value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NumericField SetLongValue(
    long value_Renamed
)
Visual Basic
Public Function SetLongValue ( _
    value_Renamed As Long _
) As NumericField
Visual C++
public:
NumericField^ SetLongValue(
    long long value_Renamed
)

Parameters

value_Renamed
Type: System..::..Int64

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Documents.NumericField.SetLongValue(System.Int64)"]

Return Value

this instance, because of this you can use it the following way:
CopyC#
document.add(new NumericField(name, precisionStep).SetLongValue(value))

See Also

NumericField Class
Lucene.Net.Documents Namespace


StringValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..StringValue Method
NumericField Class See Also Send Feedback
Returns the numeric value as a string (how it is stored, when {@link Field.Store#YES} is chosen).

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string StringValue()
Visual Basic
Public Overrides Function StringValue As String
Visual C++
public:
virtual String^ StringValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumericField.StringValue"]

Implements

Fieldable..::..StringValue()()()()

See Also

NumericField Class
Lucene.Net.Documents Namespace


TokenStreamValue Method

[image]

Lucene.Net Class Libraries
NumericField..::..TokenStreamValue Method
NumericField Class See Also Send Feedback
Returns a {@link NumericTokenStream} for indexing the numeric value.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TokenStream TokenStreamValue()
Visual Basic
Public Overrides Function TokenStreamValue As TokenStream
Visual C++
public:
virtual TokenStream^ TokenStreamValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Documents.NumericField.TokenStreamValue"]

Implements

Fieldable..::..TokenStreamValue()()()()

See Also

NumericField Class
Lucene.Net.Documents Namespace


SetBasedFieldSelector Class

[image]

Lucene.Net Class Libraries
SetBasedFieldSelector Class
Members See Also Send Feedback
Declare what fields to load normally and what fields to load lazily

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SetBasedFieldSelector : FieldSelector
Visual Basic
<SerializableAttribute> _
Public Class SetBasedFieldSelector _
    Implements FieldSelector
Visual C++
[SerializableAttribute]
public ref class SetBasedFieldSelector : FieldSelector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Documents..::..SetBasedFieldSelector

See Also

SetBasedFieldSelector Members
Lucene.Net.Documents Namespace


SetBasedFieldSelector Members

[image] [image]

Lucene.Net Class Libraries
SetBasedFieldSelector Members
SetBasedFieldSelector Class Constructors Methods See Also Send Feedback

The SetBasedFieldSelector type exposes the following members.

Constructors

 | Name | Description
Public method | SetBasedFieldSelector | Pass in the Set of {@link Field} names to load and the Set of {@link Field} names to load lazily. If both are null, the Document will not have any {@link Field} on it.

Methods

Name Description
Public method Accept
Indicate whether to load the field with the given name or not. If the {@link Field#Name()} is not in either of the initializing Sets, then {@link Lucene.Net.Documents.FieldSelectorResult#NO_LOAD} is returned. If a Field name is in both
CopyC#
fieldsToLoad
 and
CopyC#
lazyFieldsToLoad
, lazy has precedence.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SetBasedFieldSelector Class
Lucene.Net.Documents Namespace


SetBasedFieldSelector Constructor

[image]

Lucene.Net Class Libraries
SetBasedFieldSelector Constructor
SetBasedFieldSelector Class See Also Send Feedback
Pass in the Set of {@link Field} names to load and the Set of {@link Field} names to load lazily. If both are null, the Document will not have any {@link Field} on it.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SetBasedFieldSelector(
    Hashtable fieldsToLoad,
    Hashtable lazyFieldsToLoad
)
Visual Basic
Public Sub New ( _
    fieldsToLoad As Hashtable, _
    lazyFieldsToLoad As Hashtable _
)
Visual C++
public:
SetBasedFieldSelector(
    Hashtable^ fieldsToLoad,
    Hashtable^ lazyFieldsToLoad
)

Parameters

fieldsToLoad
Type: System.Collections..::..Hashtable
A Set of {@link String} field names to load. May be empty, but not null
lazyFieldsToLoad
Type: System.Collections..::..Hashtable
A Set of {@link String} field names to load lazily. May be empty, but not null

See Also

SetBasedFieldSelector Class
Lucene.Net.Documents Namespace


SetBasedFieldSelector Methods

[image] [image]

Lucene.Net Class Libraries
SetBasedFieldSelector Methods
SetBasedFieldSelector Class See Also Send Feedback

The SetBasedFieldSelector type exposes the following members.

Methods

Name Description
Public method Accept
Indicate whether to load the field with the given name or not. If the {@link Field#Name()} is not in either of the initializing Sets, then {@link Lucene.Net.Documents.FieldSelectorResult#NO_LOAD} is returned. If a Field name is in both
CopyC#
fieldsToLoad
 and
CopyC#
lazyFieldsToLoad
, lazy has precedence.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SetBasedFieldSelector Class
Lucene.Net.Documents Namespace


Accept Method

[image]

Lucene.Net Class Libraries
SetBasedFieldSelector..::..Accept Method
SetBasedFieldSelector Class See Also Send Feedback
Indicate whether to load the field with the given name or not. If the {@link Field#Name()} is not in either of the initializing Sets, then {@link Lucene.Net.Documents.FieldSelectorResult#NO_LOAD} is returned. If a Field name is in both
CopyC#
fieldsToLoad
 and
CopyC#
lazyFieldsToLoad
, lazy has precedence.

Namespace: Lucene.Net.Documents
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldSelectorResult Accept(
    string fieldName
)
Visual Basic
Public Overridable Function Accept ( _
    fieldName As String _
) As FieldSelectorResult
Visual C++
public:
virtual FieldSelectorResult^ Accept(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
The {@link Field} name to check

Return Value

The {@link FieldSelectorResult}

Implements

FieldSelector..::..Accept(String)

See Also

SetBasedFieldSelector Class
Lucene.Net.Documents Namespace


Lucene.Net.Highlight Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Highlight Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Highlight"]

Classes

 | Class | Description
Public class | DefaultEncoder | Simple {@link Encoder} implementation that does not modify the output
Public class | GradientFormatter | Formats text with different color intensity depending on the score of the term.
Public class | Highlighter | Class used to markup highlighted terms found in the best sections of a text, using configurable {@link Fragmenter}, {@link Scorer}, {@link Formatter}, {@link Encoder} and tokenizers.
Public class | NullFragmenter | {@link Fragmenter} implementation which does not fragment the text. This is useful for highlighting the entire content of a document or field.
Public class | QueryScorer | {@link Scorer} implementation which scores text fragments by the number of unique query terms found. This class uses the {@link QueryTermExtractor} class to process determine the query terms and their boosts to be used.
Public class | QueryTermExtractor | Utility class used to extract the terms used in a query, plus any weights. This class will not find terms for MultiTermQuery, RangeQuery and PrefixQuery classes so the caller must pass a rewritten query (see Query.rewrite) to obtain a list of expanded terms.
Public class | SimpleFragmenter | {@link Fragmenter} implementation which breaks text up into same-size fragments with no concerns over spotting sentence boundaries.
Public class | SimpleHTMLEncoder | Simple {@link Encoder} implementation to escape text for HTML output
Public class | SimpleHTMLFormatter | Simple {@link Formatter} implementation to highlight terms with a pre and post tag
Public class | SpanGradientFormatter | Formats text with different color intensity depending on the score of the term using the span tag. GradientFormatter uses a bgcolor argument to the font tag which doesn't work in Mozilla, thus this class.
Public class | TextFragment | Low-level class used to record information about a section of a document with a score.
Public class | TokenGroup | One, or several overlapping tokens, along with the score(s) and the scope of the original text
Public class | TokenSources | Hides implementation issues associated with obtaining a TokenStream for use with the higlighter - can obtain from TermFreqVectors with offsets and (optionally) positions or from Analyzer class reparsing the stored content.
Public class | TokenSources..::..StoredTokenStream |
Public class | WeightedTerm | Lightweight class to hold term and a weight value used for scoring this term

Interfaces

 | Interface | Description
Public interface | Encoder | Encodes original text. The Encoder works with the Formatter to generate the output.
Public interface | Formatter | Processes terms found in the original text, typically by applying some form of mark-up to highlight terms in HTML search results pages.
Public interface | Fragmenter | Implements the policy for breaking text into multiple fragments for consideration by the {@link Highlighter} class. A sophisticated implementation may do this on the basis of detecting end of sentences in the text.
Public interface | Scorer | Adds to the score for a fragment based on its tokens


DefaultEncoder Class

[image]

Lucene.Net Class Libraries
DefaultEncoder Class
Members See Also Send Feedback
Simple {@link Encoder} implementation that does not modify the output

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class DefaultEncoder : Encoder
Visual Basic
Public Class DefaultEncoder _
    Implements Encoder
Visual C++
public ref class DefaultEncoder : Encoder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..DefaultEncoder

See Also

DefaultEncoder Members
Lucene.Net.Highlight Namespace


DefaultEncoder Members

[image] [image]

Lucene.Net Class Libraries
DefaultEncoder Members
DefaultEncoder Class Constructors Methods See Also Send Feedback

The DefaultEncoder type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultEncoder | Initializes a new instance of the DefaultEncoder class

Methods

 | Name | Description
Public method | EncodeText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultEncoder Class
Lucene.Net.Highlight Namespace


DefaultEncoder Constructor

[image]

Lucene.Net Class Libraries
DefaultEncoder Constructor
DefaultEncoder Class See Also Send Feedback
Initializes a new instance of the DefaultEncoder class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public DefaultEncoder()
Visual Basic
Public Sub New
Visual C++
public:
DefaultEncoder()

See Also

DefaultEncoder Class
Lucene.Net.Highlight Namespace


DefaultEncoder Methods

[image] [image]

Lucene.Net Class Libraries
DefaultEncoder Methods
DefaultEncoder Class See Also Send Feedback

The DefaultEncoder type exposes the following members.

Methods

 | Name | Description
Public method | EncodeText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultEncoder Class
Lucene.Net.Highlight Namespace


EncodeText Method

[image]

Lucene.Net Class Libraries
DefaultEncoder..::..EncodeText Method
DefaultEncoder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.DefaultEncoder.EncodeText(System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual string EncodeText(
    string originalText
)
Visual Basic
Public Overridable Function EncodeText ( _
    originalText As String _
) As String
Visual C++
public:
virtual String^ EncodeText(
    String^ originalText
)

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.DefaultEncoder.EncodeText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.DefaultEncoder.EncodeText(System.String)"]

Implements

Encoder..::..EncodeText(String)

See Also

DefaultEncoder Class
Lucene.Net.Highlight Namespace


Encoder Interface

[image]

Lucene.Net Class Libraries
Encoder Interface
Members See Also Send Feedback
Encodes original text. The Encoder works with the Formatter to generate the output.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public interface Encoder
Visual Basic
Public Interface Encoder
Visual C++
public interface class Encoder

See Also

Encoder Members
Lucene.Net.Highlight Namespace


Encoder Members

[image] [image]

Lucene.Net Class Libraries
Encoder Members
Encoder Interface Methods See Also Send Feedback

The Encoder type exposes the following members.

Methods

 | Name | Description
Public method | EncodeText |

See Also

Encoder Interface
Lucene.Net.Highlight Namespace


Encoder Methods

[image] [image]

Lucene.Net Class Libraries
Encoder Methods
Encoder Interface See Also Send Feedback

The Encoder type exposes the following members.

Methods

 | Name | Description
Public method | EncodeText |

See Also

Encoder Interface
Lucene.Net.Highlight Namespace


EncodeText Method

[image]

Lucene.Net Class Libraries
Encoder..::..EncodeText Method
Encoder Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Encoder.EncodeText(System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
string EncodeText(
    string originalText
)
Visual Basic
Function EncodeText ( _
    originalText As String _
) As String
Visual C++
String^ EncodeText(
    String^ originalText
)

Parameters

originalText
Type: System..::..String
The section of text being output

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Encoder.EncodeText(System.String)"]

See Also

Encoder Interface
Lucene.Net.Highlight Namespace


Formatter Interface

[image]

Lucene.Net Class Libraries
Formatter Interface
Members See Also Send Feedback
Processes terms found in the original text, typically by applying some form of mark-up to highlight terms in HTML search results pages.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public interface Formatter
Visual Basic
Public Interface Formatter
Visual C++
public interface class Formatter

See Also

Formatter Members
Lucene.Net.Highlight Namespace


Formatter Members

[image] [image]

Lucene.Net Class Libraries
Formatter Members
Formatter Interface Methods See Also Send Feedback

The Formatter type exposes the following members.

Methods

 | Name | Description
Public method | HighlightTerm |

See Also

Formatter Interface
Lucene.Net.Highlight Namespace


Formatter Methods

[image] [image]

Lucene.Net Class Libraries
Formatter Methods
Formatter Interface See Also Send Feedback

The Formatter type exposes the following members.

Methods

 | Name | Description
Public method | HighlightTerm |

See Also

Formatter Interface
Lucene.Net.Highlight Namespace


HighlightTerm Method

[image]

Lucene.Net Class Libraries
Formatter..::..HighlightTerm Method
Formatter Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Formatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
string HighlightTerm(
    string originalText,
    TokenGroup tokenGroup
)
Visual Basic
Function HighlightTerm ( _
    originalText As String, _
    tokenGroup As TokenGroup _
) As String
Visual C++
String^ HighlightTerm(
    String^ originalText,
    TokenGroup^ tokenGroup
)

Parameters

originalText
Type: System..::..String
The section of text being considered for markup
tokenGroup
Type: Lucene.Net.Highlight..::..TokenGroup
contains one or several overlapping Tokens along with their scores and positions.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Formatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

See Also

Formatter Interface
Lucene.Net.Highlight Namespace


Fragmenter Interface

[image]

Lucene.Net Class Libraries
Fragmenter Interface
Members See Also Send Feedback
Implements the policy for breaking text into multiple fragments for consideration by the {@link Highlighter} class. A sophisticated implementation may do this on the basis of detecting end of sentences in the text.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public interface Fragmenter
Visual Basic
Public Interface Fragmenter
Visual C++
public interface class Fragmenter

See Also

Fragmenter Members
Lucene.Net.Highlight Namespace


Fragmenter Members

[image] [image]

Lucene.Net Class Libraries
Fragmenter Members
Fragmenter Interface Methods See Also Send Feedback

The Fragmenter type exposes the following members.

Methods

 | Name | Description
Public method | IsNewFragment | Test to see if this token from the stream should be held in a new TextFragment
Public method | Start | Initializes the Fragmenter

See Also

Fragmenter Interface
Lucene.Net.Highlight Namespace


Fragmenter Methods

[image] [image]

Lucene.Net Class Libraries
Fragmenter Methods
Fragmenter Interface See Also Send Feedback

The Fragmenter type exposes the following members.

Methods

 | Name | Description
Public method | IsNewFragment | Test to see if this token from the stream should be held in a new TextFragment
Public method | Start | Initializes the Fragmenter

See Also

Fragmenter Interface
Lucene.Net.Highlight Namespace


IsNewFragment Method

[image]

Lucene.Net Class Libraries
Fragmenter..::..IsNewFragment Method
Fragmenter Interface See Also Send Feedback
Test to see if this token from the stream should be held in a new TextFragment

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
bool IsNewFragment(
    Token nextToken
)
Visual Basic
Function IsNewFragment ( _
    nextToken As Token _
) As Boolean
Visual C++
bool IsNewFragment(
    Token^ nextToken
)

Parameters

nextToken
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="nextToken"/> documentation for "M:Lucene.Net.Highlight.Fragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Fragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

See Also

Fragmenter Interface
Lucene.Net.Highlight Namespace


Start Method

[image]

Lucene.Net Class Libraries
Fragmenter..::..Start Method
Fragmenter Interface See Also Send Feedback
Initializes the Fragmenter

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
void Start(
    string originalText
)
Visual Basic
Sub Start ( _
    originalText As String _
)
Visual C++
void Start(
    String^ originalText
)

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.Fragmenter.Start(System.String)"]

See Also

Fragmenter Interface
Lucene.Net.Highlight Namespace


GradientFormatter Class

[image]

Lucene.Net Class Libraries
GradientFormatter Class
Members See Also Send Feedback
Formats text with different color intensity depending on the score of the term.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class GradientFormatter : Formatter
Visual Basic
Public Class GradientFormatter _
    Implements Formatter
Visual C++
public ref class GradientFormatter : Formatter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..GradientFormatter
Lucene.Net.Highlight..::..SpanGradientFormatter

See Also

GradientFormatter Members
Lucene.Net.Highlight Namespace


GradientFormatter Members

[image] [image]

Lucene.Net Class Libraries
GradientFormatter Members
GradientFormatter Class Constructors Methods Fields See Also Send Feedback

The GradientFormatter type exposes the following members.

Constructors

 | Name | Description
Public method | GradientFormatter | Sets the color range for the IDF scores

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBackgroundColorString |
Protected method | GetForegroundColorString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HexToInt | Converts a hex string into an int. Integer.parseInt(hex, 16) assumes the input is nonnegative unless there is a preceding minus sign. This method reads the input as twos complement instead, so if the input is 8 bytes long, it will correctly restore a negative int produced by Integer.toHexString() but not neccesarily one produced by Integer.toString(x,16) since that method will produce a string like '-FF' for negative integer values.
Public method | HighlightTerm |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | highlightBackground |
Protected field | highlightForeground |

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


GradientFormatter Constructor

[image]

Lucene.Net Class Libraries
GradientFormatter Constructor
GradientFormatter Class See Also Send Feedback
Sets the color range for the IDF scores

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public GradientFormatter(
    float maxScore,
    string minForegroundColor,
    string maxForegroundColor,
    string minBackgroundColor,
    string maxBackgroundColor
)
Visual Basic
Public Sub New ( _
    maxScore As Single, _
    minForegroundColor As String, _
    maxForegroundColor As String, _
    minBackgroundColor As String, _
    maxBackgroundColor As String _
)
Visual C++
public:
GradientFormatter(
    float maxScore,
    String^ minForegroundColor,
    String^ maxForegroundColor,
    String^ minBackgroundColor,
    String^ maxBackgroundColor
)

Parameters

maxScore
Type: System..::..Single

[Missing <param name="maxScore"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

minForegroundColor
Type: System..::..String

[Missing <param name="minForegroundColor"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

maxForegroundColor
Type: System..::..String

[Missing <param name="maxForegroundColor"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

minBackgroundColor
Type: System..::..String

[Missing <param name="minBackgroundColor"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

maxBackgroundColor
Type: System..::..String

[Missing <param name="maxBackgroundColor"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


GradientFormatter Fields

[image] [image]

Lucene.Net Class Libraries
GradientFormatter Fields
GradientFormatter Class See Also Send Feedback

The GradientFormatter type exposes the following members.

Fields

 | Name | Description
Protected field | highlightBackground |
Protected field | highlightForeground |

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


highlightBackground Field

[image]

Lucene.Net Class Libraries
GradientFormatter..::..highlightBackground Field
GradientFormatter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Highlight.GradientFormatter.highlightBackground"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
protected internal bool highlightBackground
Visual Basic
Protected Friend highlightBackground As Boolean
Visual C++
protected public:
bool highlightBackground

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


highlightForeground Field

[image]

Lucene.Net Class Libraries
GradientFormatter..::..highlightForeground Field
GradientFormatter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Highlight.GradientFormatter.highlightForeground"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
protected internal bool highlightForeground
Visual Basic
Protected Friend highlightForeground As Boolean
Visual C++
protected public:
bool highlightForeground

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


GradientFormatter Methods

[image] [image]

Lucene.Net Class Libraries
GradientFormatter Methods
GradientFormatter Class See Also Send Feedback

The GradientFormatter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBackgroundColorString |
Protected method | GetForegroundColorString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HexToInt | Converts a hex string into an int. Integer.parseInt(hex, 16) assumes the input is nonnegative unless there is a preceding minus sign. This method reads the input as twos complement instead, so if the input is 8 bytes long, it will correctly restore a negative int produced by Integer.toHexString() but not neccesarily one produced by Integer.toString(x,16) since that method will produce a string like '-FF' for negative integer values.
Public method | HighlightTerm |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


GetBackgroundColorString Method

[image]

Lucene.Net Class Libraries
GradientFormatter..::..GetBackgroundColorString Method
GradientFormatter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.GradientFormatter.GetBackgroundColorString(System.Single)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
protected internal virtual string GetBackgroundColorString(
    float score
)
Visual Basic
Protected Friend Overridable Function GetBackgroundColorString ( _
    score As Single _
) As String
Visual C++
protected public:
virtual String^ GetBackgroundColorString(
    float score
)

Parameters

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.GetBackgroundColorString(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.GradientFormatter.GetBackgroundColorString(System.Single)"]

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


GetForegroundColorString Method

[image]

Lucene.Net Class Libraries
GradientFormatter..::..GetForegroundColorString Method
GradientFormatter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.GradientFormatter.GetForegroundColorString(System.Single)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
protected internal virtual string GetForegroundColorString(
    float score
)
Visual Basic
Protected Friend Overridable Function GetForegroundColorString ( _
    score As Single _
) As String
Visual C++
protected public:
virtual String^ GetForegroundColorString(
    float score
)

Parameters

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.GetForegroundColorString(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.GradientFormatter.GetForegroundColorString(System.Single)"]

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


HexToInt Method

[image]

Lucene.Net Class Libraries
GradientFormatter..::..HexToInt Method
GradientFormatter Class See Also Send Feedback
Converts a hex string into an int. Integer.parseInt(hex, 16) assumes the input is nonnegative unless there is a preceding minus sign. This method reads the input as twos complement instead, so if the input is 8 bytes long, it will correctly restore a negative int produced by Integer.toHexString() but not neccesarily one produced by Integer.toString(x,16) since that method will produce a string like '-FF' for negative integer values.
if the string is more than 16 characters long, or if any character is not in the set [0-9a-fA-f]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static int HexToInt(
    string hex
)
Visual Basic
Public Shared Function HexToInt ( _
    hex As String _
) As Integer
Visual C++
public:
static int HexToInt(
    String^ hex
)

Parameters

hex
Type: System..::..String

[Missing <param name="hex"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.HexToInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.GradientFormatter.HexToInt(System.String)"]

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


HighlightTerm Method

[image]

Lucene.Net Class Libraries
GradientFormatter..::..HighlightTerm Method
GradientFormatter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.GradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual string HighlightTerm(
    string originalText,
    TokenGroup tokenGroup
)
Visual Basic
Public Overridable Function HighlightTerm ( _
    originalText As String, _
    tokenGroup As TokenGroup _
) As String
Visual C++
public:
virtual String^ HighlightTerm(
    String^ originalText,
    TokenGroup^ tokenGroup
)

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

tokenGroup
Type: Lucene.Net.Highlight..::..TokenGroup

[Missing <param name="tokenGroup"/> documentation for "M:Lucene.Net.Highlight.GradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.GradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Implements

Formatter..::..HighlightTerm(String, TokenGroup)

See Also

GradientFormatter Class
Lucene.Net.Highlight Namespace


Highlighter Class

[image]

Lucene.Net Class Libraries
Highlighter Class
Members See Also Send Feedback
Class used to markup highlighted terms found in the best sections of a text, using configurable {@link Fragmenter}, {@link Scorer}, {@link Formatter}, {@link Encoder} and tokenizers.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class Highlighter
Visual Basic
Public Class Highlighter
Visual C++
public ref class Highlighter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..Highlighter

See Also

Highlighter Members
Lucene.Net.Highlight Namespace


Highlighter Members

[image] [image]

Lucene.Net Class Libraries
Highlighter Members
Highlighter Class Constructors Methods Fields See Also Send Feedback

The Highlighter type exposes the following members.

Constructors

 | Name | Description
Public method | Highlighter(Scorer) | Initializes a new instance of the Highlighter class
Public method | Highlighter(Formatter, Scorer) | Initializes a new instance of the Highlighter class
Public method | Highlighter(Formatter, Encoder, Scorer) | Initializes a new instance of the Highlighter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestFragment(TokenStream, String) | Highlights chosen terms in a text, extracting the most relevant section. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragment with the highest score is returned
Public method | GetBestFragment(Analyzer, String, String) | Highlights chosen terms in a text, extracting the most relevant section. This is a convenience method that calls {@link #GetBestFragment(TokenStream, String)}
Public method | GetBestFragments(Analyzer, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}
Public method | GetBestFragments(TokenStream, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned as an array of strings in order of score (contiguous fragments are merged into one in their original order to improve readability)
Public method | GetBestFragments(Analyzer, String, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}
Public method | GetBestFragments(TokenStream, String, Int32, String) | Highlights terms in the text , extracting the most relevant sections and concatenating the chosen fragments with a separator (typically "..."). The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned in order as "separator" delimited strings.
Public method | GetBestTextFragments | Low level api to get the most relevant (formatted) sections of the document. This method has been made public to allow visibility of score information held in TextFragment objects. Thanks to Jason Calabrese for help in redefining the interface.
Public method | GetEncoder |
Public method | GetFragmentScorer |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxDocBytesToAnalyze |
Public method | GetTextFragmenter |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEncoder |
Public method | SetFragmentScorer |
Public method | SetMaxDocBytesToAnalyze |
Public method | SetTextFragmenter |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DEFAULT_MAX_DOC_BYTES_TO_ANALYZE |

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


Highlighter Constructor

[image] [image]

Lucene.Net Class Libraries
Highlighter Constructor
Highlighter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlighter(Scorer) | Initializes a new instance of the Highlighter class
Public method | Highlighter(Formatter, Scorer) | Initializes a new instance of the Highlighter class
Public method | Highlighter(Formatter, Encoder, Scorer) | Initializes a new instance of the Highlighter class

See Also

Highlighter Class
Highlighter Members
Lucene.Net.Highlight Namespace


Highlighter Constructor (Scorer)

[image]

Lucene.Net Class Libraries
Highlighter Constructor (Scorer)
Highlighter Class See Also Send Feedback
Initializes a new instance of the Highlighter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public Highlighter(
    Scorer fragmentScorer
)
Visual Basic
Public Sub New ( _
    fragmentScorer As Scorer _
)
Visual C++
public:
Highlighter(
    Scorer^ fragmentScorer
)

Parameters

fragmentScorer
Type: Lucene.Net.Highlight..::..Scorer

[Missing <param name="fragmentScorer"/> documentation for "M:Lucene.Net.Highlight.Highlighter.#ctor(Lucene.Net.Highlight.Scorer)"]

See Also

Highlighter Class
Highlighter Overload
Lucene.Net.Highlight Namespace


Highlighter Constructor (Formatter, Scorer)

[image]

Lucene.Net Class Libraries
Highlighter Constructor (Formatter, Scorer)
Highlighter Class See Also Send Feedback
Initializes a new instance of the Highlighter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public Highlighter(
    Formatter formatter,
    Scorer fragmentScorer
)
Visual Basic
Public Sub New ( _
    formatter As Formatter, _
    fragmentScorer As Scorer _
)
Visual C++
public:
Highlighter(
    Formatter^ formatter,
    Scorer^ fragmentScorer
)

Parameters

formatter
Type: Lucene.Net.Highlight..::..Formatter

[Missing <param name="formatter"/> documentation for "M:Lucene.Net.Highlight.Highlighter.#ctor(Lucene.Net.Highlight.Formatter,Lucene.Net.Highlight.Scorer)"]

fragmentScorer
Type: Lucene.Net.Highlight..::..Scorer

[Missing <param name="fragmentScorer"/> documentation for "M:Lucene.Net.Highlight.Highlighter.#ctor(Lucene.Net.Highlight.Formatter,Lucene.Net.Highlight.Scorer)"]

See Also

Highlighter Class
Highlighter Overload
Lucene.Net.Highlight Namespace


Highlighter Constructor (Formatter, Encoder, Scorer)

[image]

Lucene.Net Class Libraries
Highlighter Constructor (Formatter, Encoder, Scorer)
Highlighter Class See Also Send Feedback
Initializes a new instance of the Highlighter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public Highlighter(
    Formatter formatter,
    Encoder encoder,
    Scorer fragmentScorer
)
Visual Basic
Public Sub New ( _
    formatter As Formatter, _
    encoder As Encoder, _
    fragmentScorer As Scorer _
)
Visual C++
public:
Highlighter(
    Formatter^ formatter,
    Encoder^ encoder,
    Scorer^ fragmentScorer
)

Parameters

formatter
Type: Lucene.Net.Highlight..::..Formatter

[Missing <param name="formatter"/> documentation for "M:Lucene.Net.Highlight.Highlighter.#ctor(Lucene.Net.Highlight.Formatter,Lucene.Net.Highlight.Encoder,Lucene.Net.Highlight.Scorer)"]

encoder
Type: Lucene.Net.Highlight..::..Encoder

[Missing <param name="encoder"/> documentation for "M:Lucene.Net.Highlight.Highlighter.#ctor(Lucene.Net.Highlight.Formatter,Lucene.Net.Highlight.Encoder,Lucene.Net.Highlight.Scorer)"]

fragmentScorer
Type: Lucene.Net.Highlight..::..Scorer

[Missing <param name="fragmentScorer"/> documentation for "M:Lucene.Net.Highlight.Highlighter.#ctor(Lucene.Net.Highlight.Formatter,Lucene.Net.Highlight.Encoder,Lucene.Net.Highlight.Scorer)"]

See Also

Highlighter Class
Highlighter Overload
Lucene.Net.Highlight Namespace


Highlighter Fields

[image] [image]

Lucene.Net Class Libraries
Highlighter Fields
Highlighter Class See Also Send Feedback

The Highlighter type exposes the following members.

Fields

Name | Description
DEFAULT_MAX_DOC_BYTES_TO_ANALYZE |

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


DEFAULT_MAX_DOC_BYTES_TO_ANALYZE Field

[image]

Lucene.Net Class Libraries
Highlighter..::..DEFAULT_MAX_DOC_BYTES_TO_ANALYZE Field
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Highlight.Highlighter.DEFAULT_MAX_DOC_BYTES_TO_ANALYZE"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public const int DEFAULT_MAX_DOC_BYTES_TO_ANALYZE
Visual Basic
Public Const DEFAULT_MAX_DOC_BYTES_TO_ANALYZE As Integer
Visual C++
public:
literal int DEFAULT_MAX_DOC_BYTES_TO_ANALYZE

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


Highlighter Methods

[image] [image]

Lucene.Net Class Libraries
Highlighter Methods
Highlighter Class See Also Send Feedback

The Highlighter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestFragment(TokenStream, String) | Highlights chosen terms in a text, extracting the most relevant section. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragment with the highest score is returned
Public method | GetBestFragment(Analyzer, String, String) | Highlights chosen terms in a text, extracting the most relevant section. This is a convenience method that calls {@link #GetBestFragment(TokenStream, String)}
Public method | GetBestFragments(Analyzer, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}
Public method | GetBestFragments(TokenStream, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned as an array of strings in order of score (contiguous fragments are merged into one in their original order to improve readability)
Public method | GetBestFragments(Analyzer, String, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}
Public method | GetBestFragments(TokenStream, String, Int32, String) | Highlights terms in the text , extracting the most relevant sections and concatenating the chosen fragments with a separator (typically "..."). The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned in order as "separator" delimited strings.
Public method | GetBestTextFragments | Low level api to get the most relevant (formatted) sections of the document. This method has been made public to allow visibility of score information held in TextFragment objects. Thanks to Jason Calabrese for help in redefining the interface.
Public method | GetEncoder |
Public method | GetFragmentScorer |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxDocBytesToAnalyze |
Public method | GetTextFragmenter |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEncoder |
Public method | SetFragmentScorer |
Public method | SetMaxDocBytesToAnalyze |
Public method | SetTextFragmenter |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


GetBestFragment Method

[image] [image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragment Method
Highlighter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBestFragment(TokenStream, String) | Highlights chosen terms in a text, extracting the most relevant section. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragment with the highest score is returned
Public method | GetBestFragment(Analyzer, String, String) | Highlights chosen terms in a text, extracting the most relevant section. This is a convenience method that calls {@link #GetBestFragment(TokenStream, String)}

See Also

Highlighter Class
Highlighter Members
Lucene.Net.Highlight Namespace


GetBestFragment Method (TokenStream, String)

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragment Method (TokenStream, String)
Highlighter Class See Also Send Feedback
Highlights chosen terms in a text, extracting the most relevant section. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragment with the highest score is returned

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public string GetBestFragment(
    TokenStream tokenStream,
    string text
)
Visual Basic
Public Function GetBestFragment ( _
    tokenStream As TokenStream, _
    text As String _
) As String
Visual C++
public:
String^ GetBestFragment(
    TokenStream^ tokenStream,
    String^ text
)

Parameters

tokenStream
Type: Lucene.Net.Analysis..::..TokenStream
a stream of tokens identified in the text parameter, including offset information. This is typically produced by an analyzer re-parsing a document's text. Some work may be done on retrieving TokenStreams more efficently by adding support for storing original text position data in the Lucene index but this support is not currently available (as of Lucene 1.4 rc2).
text
Type: System..::..String
text to highlight terms in

Return Value

highlighted text fragment or null if no terms found

See Also

Highlighter Class
GetBestFragment Overload
Lucene.Net.Highlight Namespace


GetBestFragment Method (Analyzer, String, String)

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragment Method (Analyzer, String, String)
Highlighter Class See Also Send Feedback
Highlights chosen terms in a text, extracting the most relevant section. This is a convenience method that calls {@link #GetBestFragment(TokenStream, String)}

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public string GetBestFragment(
    Analyzer analyzer,
    string fieldName,
    string text
)
Visual Basic
Public Function GetBestFragment ( _
    analyzer As Analyzer, _
    fieldName As String, _
    text As String _
) As String
Visual C++
public:
String^ GetBestFragment(
    Analyzer^ analyzer,
    String^ fieldName,
    String^ text
)

Parameters

analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer that will be used to split
CopyC#
text
 into chunks
fieldName
Type: System..::..String
Name of field used to influence analyzer's tokenization policy
text
Type: System..::..String
text to highlight terms in

Return Value

highlighted text fragment or null if no terms found

See Also

Highlighter Class
GetBestFragment Overload
Lucene.Net.Highlight Namespace


GetBestFragments Method

[image] [image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragments Method
Highlighter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBestFragments(Analyzer, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}
Public method | GetBestFragments(TokenStream, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned as an array of strings in order of score (contiguous fragments are merged into one in their original order to improve readability)
Public method | GetBestFragments(Analyzer, String, String, Int32) | Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}
Public method | GetBestFragments(TokenStream, String, Int32, String) | Highlights terms in the text , extracting the most relevant sections and concatenating the chosen fragments with a separator (typically "..."). The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned in order as "separator" delimited strings.

See Also

Highlighter Class
Highlighter Members
Lucene.Net.Highlight Namespace


GetBestFragments Method (Analyzer, String, Int32)

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragments Method (Analyzer, String, Int32)
Highlighter Class See Also Send Feedback
Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public string[] GetBestFragments(
    Analyzer analyzer,
    string text,
    int maxNumFragments
)
Visual Basic
Public Function GetBestFragments ( _
    analyzer As Analyzer, _
    text As String, _
    maxNumFragments As Integer _
) As String()
Visual C++
public:
array<String^>^ GetBestFragments(
    Analyzer^ analyzer,
    String^ text,
    int maxNumFragments
)

Parameters

analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer that will be used to split
CopyC#
text
 into chunks
text
Type: System..::..String
text to highlight terms in
maxNumFragments
Type: System..::..Int32
the maximum number of fragments.

Return Value

highlighted text fragments (between 0 and maxNumFragments number of fragments)

See Also

Highlighter Class
GetBestFragments Overload
Lucene.Net.Highlight Namespace


GetBestFragments Method (TokenStream, String, Int32)

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragments Method (TokenStream, String, Int32)
Highlighter Class See Also Send Feedback
Highlights chosen terms in a text, extracting the most relevant sections. The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned as an array of strings in order of score (contiguous fragments are merged into one in their original order to improve readability)

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public string[] GetBestFragments(
    TokenStream tokenStream,
    string text,
    int maxNumFragments
)
Visual Basic
Public Function GetBestFragments ( _
    tokenStream As TokenStream, _
    text As String, _
    maxNumFragments As Integer _
) As String()
Visual C++
public:
array<String^>^ GetBestFragments(
    TokenStream^ tokenStream,
    String^ text,
    int maxNumFragments
)

Parameters

tokenStream
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="tokenStream"/> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Int32)"]

text
Type: System..::..String
text to highlight terms in
maxNumFragments
Type: System..::..Int32
the maximum number of fragments.

Return Value

highlighted text fragments (between 0 and maxNumFragments number of fragments)

See Also

Highlighter Class
GetBestFragments Overload
Lucene.Net.Highlight Namespace


GetBestFragments Method (Analyzer, String, String, Int32)

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragments Method (Analyzer, String, String, Int32)
Highlighter Class See Also Send Feedback
Highlights chosen terms in a text, extracting the most relevant sections. This is a convenience method that calls {@link #getBestFragments(TokenStream, String, int)}

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public string[] GetBestFragments(
    Analyzer analyzer,
    string fieldName,
    string text,
    int maxNumFragments
)
Visual Basic
Public Function GetBestFragments ( _
    analyzer As Analyzer, _
    fieldName As String, _
    text As String, _
    maxNumFragments As Integer _
) As String()
Visual C++
public:
array<String^>^ GetBestFragments(
    Analyzer^ analyzer,
    String^ fieldName,
    String^ text,
    int maxNumFragments
)

Parameters

analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer that will be used to split
CopyC#
text
 into chunks
fieldName
Type: System..::..String
the name of the field being highlighted (used by analyzer)
text
Type: System..::..String
text to highlight terms in
maxNumFragments
Type: System..::..Int32
the maximum number of fragments.

Return Value

highlighted text fragments (between 0 and maxNumFragments number of fragments)

See Also

Highlighter Class
GetBestFragments Overload
Lucene.Net.Highlight Namespace


GetBestFragments Method (TokenStream, String, Int32, String)

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestFragments Method (TokenStream, String, Int32, String)
Highlighter Class See Also Send Feedback
Highlights terms in the text , extracting the most relevant sections and concatenating the chosen fragments with a separator (typically "..."). The document text is analysed in chunks to record hit statistics across the document. After accumulating stats, the fragments with the highest scores are returned in order as "separator" delimited strings.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public string GetBestFragments(
    TokenStream tokenStream,
    string text,
    int maxNumFragments,
    string separator
)
Visual Basic
Public Function GetBestFragments ( _
    tokenStream As TokenStream, _
    text As String, _
    maxNumFragments As Integer, _
    separator As String _
) As String
Visual C++
public:
String^ GetBestFragments(
    TokenStream^ tokenStream,
    String^ text,
    int maxNumFragments,
    String^ separator
)

Parameters

tokenStream
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="tokenStream"/> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Int32,System.String)"]

text
Type: System..::..String
text to highlight terms in
maxNumFragments
Type: System..::..Int32
the maximum number of fragments.
separator
Type: System..::..String
the separator used to intersperse the document fragments (typically "...")

Return Value

highlighted text

See Also

Highlighter Class
GetBestFragments Overload
Lucene.Net.Highlight Namespace


GetBestTextFragments Method

[image]

Lucene.Net Class Libraries
Highlighter..::..GetBestTextFragments Method
Highlighter Class See Also Send Feedback
Low level api to get the most relevant (formatted) sections of the document. This method has been made public to allow visibility of score information held in TextFragment objects. Thanks to Jason Calabrese for help in redefining the interface.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public TextFragment[] GetBestTextFragments(
    TokenStream tokenStream,
    string text,
    bool mergeContiguousFragments,
    int maxNumFragments
)
Visual Basic
Public Function GetBestTextFragments ( _
    tokenStream As TokenStream, _
    text As String, _
    mergeContiguousFragments As Boolean, _
    maxNumFragments As Integer _
) As TextFragment()
Visual C++
public:
array<TextFragment^>^ GetBestTextFragments(
    TokenStream^ tokenStream,
    String^ text,
    bool mergeContiguousFragments,
    int maxNumFragments
)

Parameters

tokenStream
Type: Lucene.Net.Analysis..::..TokenStream

[Missing <param name="tokenStream"/> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestTextFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Boolean,System.Int32)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestTextFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Boolean,System.Int32)"]

mergeContiguousFragments
Type: System..::..Boolean

[Missing <param name="mergeContiguousFragments"/> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestTextFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Boolean,System.Int32)"]

maxNumFragments
Type: System..::..Int32

[Missing <param name="maxNumFragments"/> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestTextFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Boolean,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Highlighter.GetBestTextFragments(Lucene.Net.Analysis.TokenStream,System.String,System.Boolean,System.Int32)"]

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


GetEncoder Method

[image]

Lucene.Net Class Libraries
Highlighter..::..GetEncoder Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.GetEncoder"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual Encoder GetEncoder()
Visual Basic
Public Overridable Function GetEncoder As Encoder
Visual C++
public:
virtual Encoder^ GetEncoder()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Highlighter.GetEncoder"]

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


GetFragmentScorer Method

[image]

Lucene.Net Class Libraries
Highlighter..::..GetFragmentScorer Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.GetFragmentScorer"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual Scorer GetFragmentScorer()
Visual Basic
Public Overridable Function GetFragmentScorer As Scorer
Visual C++
public:
virtual Scorer^ GetFragmentScorer()

Return Value

Object used to score each text fragment

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


GetMaxDocBytesToAnalyze Method

[image]

Lucene.Net Class Libraries
Highlighter..::..GetMaxDocBytesToAnalyze Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.GetMaxDocBytesToAnalyze"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual int GetMaxDocBytesToAnalyze()
Visual Basic
Public Overridable Function GetMaxDocBytesToAnalyze As Integer
Visual C++
public:
virtual int GetMaxDocBytesToAnalyze()

Return Value

the maximum number of bytes to be tokenized per doc

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


GetTextFragmenter Method

[image]

Lucene.Net Class Libraries
Highlighter..::..GetTextFragmenter Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.GetTextFragmenter"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual Fragmenter GetTextFragmenter()
Visual Basic
Public Overridable Function GetTextFragmenter As Fragmenter
Visual C++
public:
virtual Fragmenter^ GetTextFragmenter()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Highlighter.GetTextFragmenter"]

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


SetEncoder Method

[image]

Lucene.Net Class Libraries
Highlighter..::..SetEncoder Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.SetEncoder(Lucene.Net.Highlight.Encoder)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetEncoder(
    Encoder encoder
)
Visual Basic
Public Overridable Sub SetEncoder ( _
    encoder As Encoder _
)
Visual C++
public:
virtual void SetEncoder(
    Encoder^ encoder
)

Parameters

encoder
Type: Lucene.Net.Highlight..::..Encoder

[Missing <param name="encoder"/> documentation for "M:Lucene.Net.Highlight.Highlighter.SetEncoder(Lucene.Net.Highlight.Encoder)"]

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


SetFragmentScorer Method

[image]

Lucene.Net Class Libraries
Highlighter..::..SetFragmentScorer Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.SetFragmentScorer(Lucene.Net.Highlight.Scorer)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetFragmentScorer(
    Scorer scorer
)
Visual Basic
Public Overridable Sub SetFragmentScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetFragmentScorer(
    Scorer^ scorer
)

Parameters

scorer
Type: Lucene.Net.Highlight..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Highlight.Highlighter.SetFragmentScorer(Lucene.Net.Highlight.Scorer)"]

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


SetMaxDocBytesToAnalyze Method

[image]

Lucene.Net Class Libraries
Highlighter..::..SetMaxDocBytesToAnalyze Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.SetMaxDocBytesToAnalyze(System.Int32)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetMaxDocBytesToAnalyze(
    int byteCount
)
Visual Basic
Public Overridable Sub SetMaxDocBytesToAnalyze ( _
    byteCount As Integer _
)
Visual C++
public:
virtual void SetMaxDocBytesToAnalyze(
    int byteCount
)

Parameters

byteCount
Type: System..::..Int32
the maximum number of bytes to be tokenized per doc (This can improve performance with large documents)

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


SetTextFragmenter Method

[image]

Lucene.Net Class Libraries
Highlighter..::..SetTextFragmenter Method
Highlighter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.Highlighter.SetTextFragmenter(Lucene.Net.Highlight.Fragmenter)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetTextFragmenter(
    Fragmenter fragmenter
)
Visual Basic
Public Overridable Sub SetTextFragmenter ( _
    fragmenter As Fragmenter _
)
Visual C++
public:
virtual void SetTextFragmenter(
    Fragmenter^ fragmenter
)

Parameters

fragmenter
Type: Lucene.Net.Highlight..::..Fragmenter

[Missing <param name="fragmenter"/> documentation for "M:Lucene.Net.Highlight.Highlighter.SetTextFragmenter(Lucene.Net.Highlight.Fragmenter)"]

See Also

Highlighter Class
Lucene.Net.Highlight Namespace


NullFragmenter Class

[image]

Lucene.Net Class Libraries
NullFragmenter Class
Members See Also Send Feedback
{@link Fragmenter} implementation which does not fragment the text. This is useful for highlighting the entire content of a document or field.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class NullFragmenter : Fragmenter
Visual Basic
Public Class NullFragmenter _
    Implements Fragmenter
Visual C++
public ref class NullFragmenter : Fragmenter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..NullFragmenter

See Also

NullFragmenter Members
Lucene.Net.Highlight Namespace


NullFragmenter Members

[image] [image]

Lucene.Net Class Libraries
NullFragmenter Members
NullFragmenter Class Constructors Methods See Also Send Feedback

The NullFragmenter type exposes the following members.

Constructors

 | Name | Description
Public method | NullFragmenter | Initializes a new instance of the NullFragmenter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNewFragment |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NullFragmenter Class
Lucene.Net.Highlight Namespace


NullFragmenter Constructor

[image]

Lucene.Net Class Libraries
NullFragmenter Constructor
NullFragmenter Class See Also Send Feedback
Initializes a new instance of the NullFragmenter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public NullFragmenter()
Visual Basic
Public Sub New
Visual C++
public:
NullFragmenter()

See Also

NullFragmenter Class
Lucene.Net.Highlight Namespace


NullFragmenter Methods

[image] [image]

Lucene.Net Class Libraries
NullFragmenter Methods
NullFragmenter Class See Also Send Feedback

The NullFragmenter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNewFragment |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NullFragmenter Class
Lucene.Net.Highlight Namespace


IsNewFragment Method

[image]

Lucene.Net Class Libraries
NullFragmenter..::..IsNewFragment Method
NullFragmenter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.NullFragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual bool IsNewFragment(
    Token token
)
Visual Basic
Public Overridable Function IsNewFragment ( _
    token As Token _
) As Boolean
Visual C++
public:
virtual bool IsNewFragment(
    Token^ token
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Highlight.NullFragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.NullFragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Implements

Fragmenter..::..IsNewFragment(Token)

See Also

NullFragmenter Class
Lucene.Net.Highlight Namespace


Start Method

[image]

Lucene.Net Class Libraries
NullFragmenter..::..Start Method
NullFragmenter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.NullFragmenter.Start(System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void Start(
    string s
)
Visual Basic
Public Overridable Sub Start ( _
    s As String _
)
Visual C++
public:
virtual void Start(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Highlight.NullFragmenter.Start(System.String)"]

Implements

Fragmenter..::..Start(String)

See Also

NullFragmenter Class
Lucene.Net.Highlight Namespace


QueryScorer Class

[image]

Lucene.Net Class Libraries
QueryScorer Class
Members See Also Send Feedback
{@link Scorer} implementation which scores text fragments by the number of unique query terms found. This class uses the {@link QueryTermExtractor} class to process determine the query terms and their boosts to be used.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class QueryScorer : Scorer
Visual Basic
Public Class QueryScorer _
    Implements Scorer
Visual C++
public ref class QueryScorer : Scorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..QueryScorer

See Also

QueryScorer Members
Lucene.Net.Highlight Namespace


QueryScorer Members

[image] [image]

Lucene.Net Class Libraries
QueryScorer Members
QueryScorer Class Constructors Methods See Also Send Feedback

The QueryScorer type exposes the following members.

Constructors

 | Name | Description
Public method | QueryScorer(Query) | Initializes a new instance of the QueryScorer class
Public method | QueryScorer(array<WeightedTerm>[]()[][]) | Initializes a new instance of the QueryScorer class
Public method | QueryScorer(Query, String) | Initializes a new instance of the QueryScorer class
Public method | QueryScorer(Query, IndexReader, String) | Initializes a new instance of the QueryScorer class

Methods

 | Name | Description
Public method | AllFragmentsProcessed |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFragmentScore |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxTermWeight |
Public method | GetTokenScore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartFragment |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


QueryScorer Constructor

[image] [image]

Lucene.Net Class Libraries
QueryScorer Constructor
QueryScorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryScorer(Query) | Initializes a new instance of the QueryScorer class
Public method | QueryScorer(array<WeightedTerm>[]()[][]) | Initializes a new instance of the QueryScorer class
Public method | QueryScorer(Query, String) | Initializes a new instance of the QueryScorer class
Public method | QueryScorer(Query, IndexReader, String) | Initializes a new instance of the QueryScorer class

See Also

QueryScorer Class
QueryScorer Members
Lucene.Net.Highlight Namespace


QueryScorer Constructor (Query)

[image]

Lucene.Net Class Libraries
QueryScorer Constructor (Query)
QueryScorer Class See Also Send Feedback
Initializes a new instance of the QueryScorer class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public QueryScorer(
    Query query
)
Visual Basic
Public Sub New ( _
    query As Query _
)
Visual C++
public:
QueryScorer(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query
a Lucene query (ideally rewritten using query.rewrite before being passed to this class and the searcher)

See Also

QueryScorer Class
QueryScorer Overload
Lucene.Net.Highlight Namespace


QueryScorer Constructor (WeightedTerm[])

[image]

Lucene.Net Class Libraries
QueryScorer Constructor (array<WeightedTerm>[]()[][])
QueryScorer Class See Also Send Feedback
Initializes a new instance of the QueryScorer class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public QueryScorer(
    WeightedTerm[] weightedTerms
)
Visual Basic
Public Sub New ( _
    weightedTerms As WeightedTerm() _
)
Visual C++
public:
QueryScorer(
    array<WeightedTerm^>^ weightedTerms
)

Parameters

weightedTerms
Type: array< Lucene.Net.Highlight..::..WeightedTerm >[]()[][]

[Missing <param name="weightedTerms"/> documentation for "M:Lucene.Net.Highlight.QueryScorer.#ctor(Lucene.Net.Highlight.WeightedTerm[])"]

See Also

QueryScorer Class
QueryScorer Overload
Lucene.Net.Highlight Namespace


QueryScorer Constructor (Query, String)

[image]

Lucene.Net Class Libraries
QueryScorer Constructor (Query, String)
QueryScorer Class See Also Send Feedback
Initializes a new instance of the QueryScorer class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public QueryScorer(
    Query query,
    string fieldName
)
Visual Basic
Public Sub New ( _
    query As Query, _
    fieldName As String _
)
Visual C++
public:
QueryScorer(
    Query^ query,
    String^ fieldName
)

Parameters

query
Type: Lucene.Net.Search..::..Query
a Lucene query (ideally rewritten using query.rewrite before being passed to this class and the searcher)
fieldName
Type: System..::..String
the Field name which is used to match Query terms

See Also

QueryScorer Class
QueryScorer Overload
Lucene.Net.Highlight Namespace


QueryScorer Constructor (Query, IndexReader, String)

[image]

Lucene.Net Class Libraries
QueryScorer Constructor (Query, IndexReader, String)
QueryScorer Class See Also Send Feedback
Initializes a new instance of the QueryScorer class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public QueryScorer(
    Query query,
    IndexReader reader,
    string fieldName
)
Visual Basic
Public Sub New ( _
    query As Query, _
    reader As IndexReader, _
    fieldName As String _
)
Visual C++
public:
QueryScorer(
    Query^ query,
    IndexReader^ reader,
    String^ fieldName
)

Parameters

query
Type: Lucene.Net.Search..::..Query
a Lucene query (ideally rewritten using query.rewrite before being passed to this class and the searcher)
reader
Type: Lucene.Net.Index..::..IndexReader
used to compute IDF which can be used to a) score selected fragments better b) use graded highlights eg set font color intensity
fieldName
Type: System..::..String
the field on which Inverse Document Frequency (IDF) calculations are based

See Also

QueryScorer Class
QueryScorer Overload
Lucene.Net.Highlight Namespace


QueryScorer Methods

[image] [image]

Lucene.Net Class Libraries
QueryScorer Methods
QueryScorer Class See Also Send Feedback

The QueryScorer type exposes the following members.

Methods

 | Name | Description
Public method | AllFragmentsProcessed |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFragmentScore |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxTermWeight |
Public method | GetTokenScore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartFragment |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


AllFragmentsProcessed Method

[image]

Lucene.Net Class Libraries
QueryScorer..::..AllFragmentsProcessed Method
QueryScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.QueryScorer.AllFragmentsProcessed"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void AllFragmentsProcessed()
Visual Basic
Public Overridable Sub AllFragmentsProcessed
Visual C++
public:
virtual void AllFragmentsProcessed()

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


GetFragmentScore Method

[image]

Lucene.Net Class Libraries
QueryScorer..::..GetFragmentScore Method
QueryScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.QueryScorer.GetFragmentScore"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetFragmentScore()
Visual Basic
Public Overridable Function GetFragmentScore As Single
Visual C++
public:
virtual float GetFragmentScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.QueryScorer.GetFragmentScore"]

Implements

Scorer..::..GetFragmentScore()()()()

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


GetMaxTermWeight Method

[image]

Lucene.Net Class Libraries
QueryScorer..::..GetMaxTermWeight Method
QueryScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.QueryScorer.GetMaxTermWeight"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetMaxTermWeight()
Visual Basic
Public Overridable Function GetMaxTermWeight As Single
Visual C++
public:
virtual float GetMaxTermWeight()

Return Value

The highest weighted term (useful for passing to GradientFormatter to set top end of coloring scale.

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


GetTokenScore Method

[image]

Lucene.Net Class Libraries
QueryScorer..::..GetTokenScore Method
QueryScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.QueryScorer.GetTokenScore(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetTokenScore(
    Token token
)
Visual Basic
Public Overridable Function GetTokenScore ( _
    token As Token _
) As Single
Visual C++
public:
virtual float GetTokenScore(
    Token^ token
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Highlight.QueryScorer.GetTokenScore(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.QueryScorer.GetTokenScore(Lucene.Net.Analysis.Token)"]

Implements

Scorer..::..GetTokenScore(Token)

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


StartFragment Method

[image]

Lucene.Net Class Libraries
QueryScorer..::..StartFragment Method
QueryScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.QueryScorer.StartFragment(Lucene.Net.Highlight.TextFragment)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void StartFragment(
    TextFragment newFragment
)
Visual Basic
Public Overridable Sub StartFragment ( _
    newFragment As TextFragment _
)
Visual C++
public:
virtual void StartFragment(
    TextFragment^ newFragment
)

Parameters

newFragment
Type: Lucene.Net.Highlight..::..TextFragment

[Missing <param name="newFragment"/> documentation for "M:Lucene.Net.Highlight.QueryScorer.StartFragment(Lucene.Net.Highlight.TextFragment)"]

Implements

Scorer..::..StartFragment(TextFragment)

See Also

QueryScorer Class
Lucene.Net.Highlight Namespace


QueryTermExtractor Class

[image]

Lucene.Net Class Libraries
QueryTermExtractor Class
Members See Also Send Feedback
Utility class used to extract the terms used in a query, plus any weights. This class will not find terms for MultiTermQuery, RangeQuery and PrefixQuery classes so the caller must pass a rewritten query (see Query.rewrite) to obtain a list of expanded terms.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public sealed class QueryTermExtractor
Visual Basic
Public NotInheritable Class QueryTermExtractor
Visual C++
public ref class QueryTermExtractor sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..QueryTermExtractor

See Also

QueryTermExtractor Members
Lucene.Net.Highlight Namespace


QueryTermExtractor Members

[image] [image]

Lucene.Net Class Libraries
QueryTermExtractor Members
QueryTermExtractor Class Constructors Methods See Also Send Feedback

The QueryTermExtractor type exposes the following members.

Constructors

 | Name | Description
Public method | QueryTermExtractor | Initializes a new instance of the QueryTermExtractor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIdfWeightedTerms | Extracts all terms texts of a given Query into an array of WeightedTerms
 | GetTerms(Query) | Extracts all terms texts of a given Query into an array of WeightedTerms
 | GetTerms(Query, Boolean) | Extracts all terms texts of a given Query into an array of WeightedTerms
 | GetTerms(Query, Boolean, String) | Extracts all terms texts of a given Query into an array of WeightedTerms
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryTermExtractor Class
Lucene.Net.Highlight Namespace


QueryTermExtractor Constructor

[image]

Lucene.Net Class Libraries
QueryTermExtractor Constructor
QueryTermExtractor Class See Also Send Feedback
Initializes a new instance of the QueryTermExtractor class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public QueryTermExtractor()
Visual Basic
Public Sub New
Visual C++
public:
QueryTermExtractor()

See Also

QueryTermExtractor Class
Lucene.Net.Highlight Namespace


QueryTermExtractor Methods

[image] [image]

Lucene.Net Class Libraries
QueryTermExtractor Methods
QueryTermExtractor Class See Also Send Feedback

The QueryTermExtractor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIdfWeightedTerms | Extracts all terms texts of a given Query into an array of WeightedTerms
 | GetTerms(Query) | Extracts all terms texts of a given Query into an array of WeightedTerms
 | GetTerms(Query, Boolean) | Extracts all terms texts of a given Query into an array of WeightedTerms
 | GetTerms(Query, Boolean, String) | Extracts all terms texts of a given Query into an array of WeightedTerms
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryTermExtractor Class
Lucene.Net.Highlight Namespace


GetIdfWeightedTerms Method

[image]

Lucene.Net Class Libraries
QueryTermExtractor..::..GetIdfWeightedTerms Method
QueryTermExtractor Class See Also Send Feedback
Extracts all terms texts of a given Query into an array of WeightedTerms

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static WeightedTerm[] GetIdfWeightedTerms(
    Query query,
    IndexReader reader,
    string fieldName
)
Visual Basic
Public Shared Function GetIdfWeightedTerms ( _
    query As Query, _
    reader As IndexReader, _
    fieldName As String _
) As WeightedTerm()
Visual C++
public:
static array<WeightedTerm^>^ GetIdfWeightedTerms(
    Query^ query,
    IndexReader^ reader,
    String^ fieldName
)

Parameters

query
Type: Lucene.Net.Search..::..Query
Query to extract term texts from
reader
Type: Lucene.Net.Index..::..IndexReader
used to compute IDF which can be used to a) score selected fragments better b) use graded highlights eg chaning intensity of font color
fieldName
Type: System..::..String
the field on which Inverse Document Frequency (IDF) calculations are based

Return Value

an array of the terms used in a query, plus their weights.

See Also

QueryTermExtractor Class
Lucene.Net.Highlight Namespace


GetTerms Method

[image] [image]

Lucene.Net Class Libraries
QueryTermExtractor..::..GetTerms Method
QueryTermExtractor Class See Also Send Feedback

Overload List

Name | Description
GetTerms(Query) | Extracts all terms texts of a given Query into an array of WeightedTerms
GetTerms(Query, Boolean) | Extracts all terms texts of a given Query into an array of WeightedTerms
GetTerms(Query, Boolean, String) | Extracts all terms texts of a given Query into an array of WeightedTerms

See Also

QueryTermExtractor Class
QueryTermExtractor Members
Lucene.Net.Highlight Namespace


GetTerms Method (Query)

[image]

Lucene.Net Class Libraries
QueryTermExtractor..::..GetTerms Method (Query)
QueryTermExtractor Class See Also Send Feedback
Extracts all terms texts of a given Query into an array of WeightedTerms

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static WeightedTerm[] GetTerms(
    Query query
)
Visual Basic
Public Shared Function GetTerms ( _
    query As Query _
) As WeightedTerm()
Visual C++
public:
static array<WeightedTerm^>^ GetTerms(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query
Query to extract term texts from

Return Value

an array of the terms used in a query, plus their weights.

See Also

QueryTermExtractor Class
GetTerms Overload
Lucene.Net.Highlight Namespace


GetTerms Method (Query, Boolean)

[image]

Lucene.Net Class Libraries
QueryTermExtractor..::..GetTerms Method (Query, Boolean)
QueryTermExtractor Class See Also Send Feedback
Extracts all terms texts of a given Query into an array of WeightedTerms

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static WeightedTerm[] GetTerms(
    Query query,
    bool prohibited
)
Visual Basic
Public Shared Function GetTerms ( _
    query As Query, _
    prohibited As Boolean _
) As WeightedTerm()
Visual C++
public:
static array<WeightedTerm^>^ GetTerms(
    Query^ query,
    bool prohibited
)

Parameters

query
Type: Lucene.Net.Search..::..Query
Query to extract term texts from
prohibited
Type: System..::..Boolean
CopyC#
true
 to extract "prohibited" terms, too

Return Value

an array of the terms used in a query, plus their weights.

See Also

QueryTermExtractor Class
GetTerms Overload
Lucene.Net.Highlight Namespace


GetTerms Method (Query, Boolean, String)

[image]

Lucene.Net Class Libraries
QueryTermExtractor..::..GetTerms Method (Query, Boolean, String)
QueryTermExtractor Class See Also Send Feedback
Extracts all terms texts of a given Query into an array of WeightedTerms

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static WeightedTerm[] GetTerms(
    Query query,
    bool prohibited,
    string fieldName
)
Visual Basic
Public Shared Function GetTerms ( _
    query As Query, _
    prohibited As Boolean, _
    fieldName As String _
) As WeightedTerm()
Visual C++
public:
static array<WeightedTerm^>^ GetTerms(
    Query^ query,
    bool prohibited,
    String^ fieldName
)

Parameters

query
Type: Lucene.Net.Search..::..Query
Query to extract term texts from
prohibited
Type: System..::..Boolean
CopyC#
true
 to extract "prohibited" terms, too
fieldName
Type: System..::..String
The fieldName used to filter query terms

Return Value

an array of the terms used in a query, plus their weights.

See Also

QueryTermExtractor Class
GetTerms Overload
Lucene.Net.Highlight Namespace


Scorer Interface

[image]

Lucene.Net Class Libraries
Scorer Interface
Members See Also Send Feedback
Adds to the score for a fragment based on its tokens

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public interface Scorer
Visual Basic
Public Interface Scorer
Visual C++
public interface class Scorer

See Also

Scorer Members
Lucene.Net.Highlight Namespace


Scorer Members

[image] [image]

Lucene.Net Class Libraries
Scorer Members
Scorer Interface Methods See Also Send Feedback

The Scorer type exposes the following members.

Methods

 | Name | Description
Public method | GetFragmentScore | Called when the highlighter has no more tokens for the current fragment - the scorer returns the weighting it has derived for the most recent fragment, typically based on the tokens passed to getTokenScore().
Public method | GetTokenScore | Called for each token in the current fragment
Public method | StartFragment | called when a new fragment is started for consideration

See Also

Scorer Interface
Lucene.Net.Highlight Namespace


Scorer Methods

[image] [image]

Lucene.Net Class Libraries
Scorer Methods
Scorer Interface See Also Send Feedback

The Scorer type exposes the following members.

Methods

 | Name | Description
Public method | GetFragmentScore | Called when the highlighter has no more tokens for the current fragment - the scorer returns the weighting it has derived for the most recent fragment, typically based on the tokens passed to getTokenScore().
Public method | GetTokenScore | Called for each token in the current fragment
Public method | StartFragment | called when a new fragment is started for consideration

See Also

Scorer Interface
Lucene.Net.Highlight Namespace


GetFragmentScore Method

[image]

Lucene.Net Class Libraries
Scorer..::..GetFragmentScore Method
Scorer Interface See Also Send Feedback
Called when the highlighter has no more tokens for the current fragment - the scorer returns the weighting it has derived for the most recent fragment, typically based on the tokens passed to getTokenScore().

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
float GetFragmentScore()
Visual Basic
Function GetFragmentScore As Single
Visual C++
float GetFragmentScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.Scorer.GetFragmentScore"]

See Also

Scorer Interface
Lucene.Net.Highlight Namespace


GetTokenScore Method

[image]

Lucene.Net Class Libraries
Scorer..::..GetTokenScore Method
Scorer Interface See Also Send Feedback
Called for each token in the current fragment

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
float GetTokenScore(
    Token token
)
Visual Basic
Function GetTokenScore ( _
    token As Token _
) As Single
Visual C++
float GetTokenScore(
    Token^ token
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token
The token to be scored

Return Value

a score which is passed to the Highlighter class to influence the mark-up of the text (this return value is NOT used to score the fragment)

See Also

Scorer Interface
Lucene.Net.Highlight Namespace


StartFragment Method

[image]

Lucene.Net Class Libraries
Scorer..::..StartFragment Method
Scorer Interface See Also Send Feedback
called when a new fragment is started for consideration

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
void StartFragment(
    TextFragment newFragment
)
Visual Basic
Sub StartFragment ( _
    newFragment As TextFragment _
)
Visual C++
void StartFragment(
    TextFragment^ newFragment
)

Parameters

newFragment
Type: Lucene.Net.Highlight..::..TextFragment

[Missing <param name="newFragment"/> documentation for "M:Lucene.Net.Highlight.Scorer.StartFragment(Lucene.Net.Highlight.TextFragment)"]

See Also

Scorer Interface
Lucene.Net.Highlight Namespace


SimpleFragmenter Class

[image]

Lucene.Net Class Libraries
SimpleFragmenter Class
Members See Also Send Feedback
{@link Fragmenter} implementation which breaks text up into same-size fragments with no concerns over spotting sentence boundaries.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class SimpleFragmenter : Fragmenter
Visual Basic
Public Class SimpleFragmenter _
    Implements Fragmenter
Visual C++
public ref class SimpleFragmenter : Fragmenter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..SimpleFragmenter

See Also

SimpleFragmenter Members
Lucene.Net.Highlight Namespace


SimpleFragmenter Members

[image] [image]

Lucene.Net Class Libraries
SimpleFragmenter Members
SimpleFragmenter Class Constructors Methods See Also Send Feedback

The SimpleFragmenter type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFragmenter()()()() | Initializes a new instance of the SimpleFragmenter class
Public method | SimpleFragmenter(Int32) | Initializes a new instance of the SimpleFragmenter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFragmentSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNewFragment |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFragmentSize |
Public method | Start |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFragmenter Class
Lucene.Net.Highlight Namespace


SimpleFragmenter Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleFragmenter Constructor
SimpleFragmenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleFragmenter()()()() | Initializes a new instance of the SimpleFragmenter class
Public method | SimpleFragmenter(Int32) | Initializes a new instance of the SimpleFragmenter class

See Also

SimpleFragmenter Class
SimpleFragmenter Members
Lucene.Net.Highlight Namespace


SimpleFragmenter Constructor

[image]

Lucene.Net Class Libraries
SimpleFragmenter Constructor
SimpleFragmenter Class See Also Send Feedback
Initializes a new instance of the SimpleFragmenter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public SimpleFragmenter()
Visual Basic
Public Sub New
Visual C++
public:
SimpleFragmenter()

See Also

SimpleFragmenter Class
SimpleFragmenter Overload
Lucene.Net.Highlight Namespace


SimpleFragmenter Constructor (Int32)

[image]

Lucene.Net Class Libraries
SimpleFragmenter Constructor (Int32)
SimpleFragmenter Class See Also Send Feedback
Initializes a new instance of the SimpleFragmenter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public SimpleFragmenter(
    int fragmentSize
)
Visual Basic
Public Sub New ( _
    fragmentSize As Integer _
)
Visual C++
public:
SimpleFragmenter(
    int fragmentSize
)

Parameters

fragmentSize
Type: System..::..Int32
size in bytes of each fragment

See Also

SimpleFragmenter Class
SimpleFragmenter Overload
Lucene.Net.Highlight Namespace


SimpleFragmenter Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFragmenter Methods
SimpleFragmenter Class See Also Send Feedback

The SimpleFragmenter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFragmentSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNewFragment |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFragmentSize |
Public method | Start |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFragmenter Class
Lucene.Net.Highlight Namespace


GetFragmentSize Method

[image]

Lucene.Net Class Libraries
SimpleFragmenter..::..GetFragmentSize Method
SimpleFragmenter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.GetFragmentSize"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual int GetFragmentSize()
Visual Basic
Public Overridable Function GetFragmentSize As Integer
Visual C++
public:
virtual int GetFragmentSize()

Return Value

size in bytes of each fragment

See Also

SimpleFragmenter Class
Lucene.Net.Highlight Namespace


IsNewFragment Method

[image]

Lucene.Net Class Libraries
SimpleFragmenter..::..IsNewFragment Method
SimpleFragmenter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual bool IsNewFragment(
    Token token
)
Visual Basic
Public Overridable Function IsNewFragment ( _
    token As Token _
) As Boolean
Visual C++
public:
virtual bool IsNewFragment(
    Token^ token
)

Parameters

token
Type: Lucene.Net.Analysis..::..Token

[Missing <param name="token"/> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.IsNewFragment(Lucene.Net.Analysis.Token)"]

Implements

Fragmenter..::..IsNewFragment(Token)

See Also

SimpleFragmenter Class
Lucene.Net.Highlight Namespace


SetFragmentSize Method

[image]

Lucene.Net Class Libraries
SimpleFragmenter..::..SetFragmentSize Method
SimpleFragmenter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.SetFragmentSize(System.Int32)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetFragmentSize(
    int size
)
Visual Basic
Public Overridable Sub SetFragmentSize ( _
    size As Integer _
)
Visual C++
public:
virtual void SetFragmentSize(
    int size
)

Parameters

size
Type: System..::..Int32
size in bytes of each fragment

See Also

SimpleFragmenter Class
Lucene.Net.Highlight Namespace


Start Method

[image]

Lucene.Net Class Libraries
SimpleFragmenter..::..Start Method
SimpleFragmenter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.Start(System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void Start(
    string originalText
)
Visual Basic
Public Overridable Sub Start ( _
    originalText As String _
)
Visual C++
public:
virtual void Start(
    String^ originalText
)

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.SimpleFragmenter.Start(System.String)"]

Implements

Fragmenter..::..Start(String)

See Also

SimpleFragmenter Class
Lucene.Net.Highlight Namespace


SimpleHTMLEncoder Class

[image]

Lucene.Net Class Libraries
SimpleHTMLEncoder Class
Members See Also Send Feedback
Simple {@link Encoder} implementation to escape text for HTML output

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class SimpleHTMLEncoder : Encoder
Visual Basic
Public Class SimpleHTMLEncoder _
    Implements Encoder
Visual C++
public ref class SimpleHTMLEncoder : Encoder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..SimpleHTMLEncoder

See Also

SimpleHTMLEncoder Members
Lucene.Net.Highlight Namespace


SimpleHTMLEncoder Members

[image] [image]

Lucene.Net Class Libraries
SimpleHTMLEncoder Members
SimpleHTMLEncoder Class Constructors Methods See Also Send Feedback

The SimpleHTMLEncoder type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleHTMLEncoder | Initializes a new instance of the SimpleHTMLEncoder class

Methods

 | Name | Description
Public method | EncodeText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HtmlEncode | Encode string into HTML
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleHTMLEncoder Class
Lucene.Net.Highlight Namespace


SimpleHTMLEncoder Constructor

[image]

Lucene.Net Class Libraries
SimpleHTMLEncoder Constructor
SimpleHTMLEncoder Class See Also Send Feedback
Initializes a new instance of the SimpleHTMLEncoder class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public SimpleHTMLEncoder()
Visual Basic
Public Sub New
Visual C++
public:
SimpleHTMLEncoder()

See Also

SimpleHTMLEncoder Class
Lucene.Net.Highlight Namespace


SimpleHTMLEncoder Methods

[image] [image]

Lucene.Net Class Libraries
SimpleHTMLEncoder Methods
SimpleHTMLEncoder Class See Also Send Feedback

The SimpleHTMLEncoder type exposes the following members.

Methods

 | Name | Description
Public method | EncodeText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HtmlEncode | Encode string into HTML
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleHTMLEncoder Class
Lucene.Net.Highlight Namespace


EncodeText Method

[image]

Lucene.Net Class Libraries
SimpleHTMLEncoder..::..EncodeText Method
SimpleHTMLEncoder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SimpleHTMLEncoder.EncodeText(System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual string EncodeText(
    string originalText
)
Visual Basic
Public Overridable Function EncodeText ( _
    originalText As String _
) As String
Visual C++
public:
virtual String^ EncodeText(
    String^ originalText
)

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.SimpleHTMLEncoder.EncodeText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.SimpleHTMLEncoder.EncodeText(System.String)"]

Implements

Encoder..::..EncodeText(String)

See Also

SimpleHTMLEncoder Class
Lucene.Net.Highlight Namespace


HtmlEncode Method

[image]

Lucene.Net Class Libraries
SimpleHTMLEncoder..::..HtmlEncode Method
SimpleHTMLEncoder Class See Also Send Feedback
Encode string into HTML

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static string HtmlEncode(
    string plainText
)
Visual Basic
Public Shared Function HtmlEncode ( _
    plainText As String _
) As String
Visual C++
public:
static String^ HtmlEncode(
    String^ plainText
)

Parameters

plainText
Type: System..::..String

[Missing <param name="plainText"/> documentation for "M:Lucene.Net.Highlight.SimpleHTMLEncoder.HtmlEncode(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.SimpleHTMLEncoder.HtmlEncode(System.String)"]

See Also

SimpleHTMLEncoder Class
Lucene.Net.Highlight Namespace


SimpleHTMLFormatter Class

[image]

Lucene.Net Class Libraries
SimpleHTMLFormatter Class
Members See Also Send Feedback
Simple {@link Formatter} implementation to highlight terms with a pre and post tag

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class SimpleHTMLFormatter : Formatter
Visual Basic
Public Class SimpleHTMLFormatter _
    Implements Formatter
Visual C++
public ref class SimpleHTMLFormatter : Formatter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..SimpleHTMLFormatter

See Also

SimpleHTMLFormatter Members
Lucene.Net.Highlight Namespace


SimpleHTMLFormatter Members

[image] [image]

Lucene.Net Class Libraries
SimpleHTMLFormatter Members
SimpleHTMLFormatter Class Constructors Methods See Also Send Feedback

The SimpleHTMLFormatter type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleHTMLFormatter()()()() | Default constructor uses HTML: <B> tags to markup terms
Public method | SimpleHTMLFormatter(String, String) | Initializes a new instance of the SimpleHTMLFormatter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTerm |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleHTMLFormatter Class
Lucene.Net.Highlight Namespace


SimpleHTMLFormatter Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleHTMLFormatter Constructor
SimpleHTMLFormatter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleHTMLFormatter()()()() | Default constructor uses HTML: <B> tags to markup terms
Public method | SimpleHTMLFormatter(String, String) | Initializes a new instance of the SimpleHTMLFormatter class

See Also

SimpleHTMLFormatter Class
SimpleHTMLFormatter Members
Lucene.Net.Highlight Namespace


SimpleHTMLFormatter Constructor

[image]

Lucene.Net Class Libraries
SimpleHTMLFormatter Constructor
SimpleHTMLFormatter Class See Also Send Feedback
Default constructor uses HTML: <B> tags to markup terms

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public SimpleHTMLFormatter()
Visual Basic
Public Sub New
Visual C++
public:
SimpleHTMLFormatter()

See Also

SimpleHTMLFormatter Class
SimpleHTMLFormatter Overload
Lucene.Net.Highlight Namespace


SimpleHTMLFormatter Constructor (String, String)

[image]

Lucene.Net Class Libraries
SimpleHTMLFormatter Constructor (String, String)
SimpleHTMLFormatter Class See Also Send Feedback
Initializes a new instance of the SimpleHTMLFormatter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public SimpleHTMLFormatter(
    string preTag,
    string postTag
)
Visual Basic
Public Sub New ( _
    preTag As String, _
    postTag As String _
)
Visual C++
public:
SimpleHTMLFormatter(
    String^ preTag,
    String^ postTag
)

Parameters

preTag
Type: System..::..String

[Missing <param name="preTag"/> documentation for "M:Lucene.Net.Highlight.SimpleHTMLFormatter.#ctor(System.String,System.String)"]

postTag
Type: System..::..String

[Missing <param name="postTag"/> documentation for "M:Lucene.Net.Highlight.SimpleHTMLFormatter.#ctor(System.String,System.String)"]

See Also

SimpleHTMLFormatter Class
SimpleHTMLFormatter Overload
Lucene.Net.Highlight Namespace


SimpleHTMLFormatter Methods

[image] [image]

Lucene.Net Class Libraries
SimpleHTMLFormatter Methods
SimpleHTMLFormatter Class See Also Send Feedback

The SimpleHTMLFormatter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTerm |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleHTMLFormatter Class
Lucene.Net.Highlight Namespace


HighlightTerm Method

[image]

Lucene.Net Class Libraries
SimpleHTMLFormatter..::..HighlightTerm Method
SimpleHTMLFormatter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SimpleHTMLFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual string HighlightTerm(
    string originalText,
    TokenGroup tokenGroup
)
Visual Basic
Public Overridable Function HighlightTerm ( _
    originalText As String, _
    tokenGroup As TokenGroup _
) As String
Visual C++
public:
virtual String^ HighlightTerm(
    String^ originalText,
    TokenGroup^ tokenGroup
)

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.SimpleHTMLFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

tokenGroup
Type: Lucene.Net.Highlight..::..TokenGroup

[Missing <param name="tokenGroup"/> documentation for "M:Lucene.Net.Highlight.SimpleHTMLFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.SimpleHTMLFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Implements

Formatter..::..HighlightTerm(String, TokenGroup)

See Also

SimpleHTMLFormatter Class
Lucene.Net.Highlight Namespace


SpanGradientFormatter Class

[image]

Lucene.Net Class Libraries
SpanGradientFormatter Class
Members See Also Send Feedback
Formats text with different color intensity depending on the score of the term using the span tag. GradientFormatter uses a bgcolor argument to the font tag which doesn't work in Mozilla, thus this class.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class SpanGradientFormatter : GradientFormatter
Visual Basic
Public Class SpanGradientFormatter _
    Inherits GradientFormatter
Visual C++
public ref class SpanGradientFormatter : public GradientFormatter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..GradientFormatter
Lucene.Net.Highlight..::..SpanGradientFormatter

See Also

SpanGradientFormatter Members
Lucene.Net.Highlight Namespace
Lucene.Net.Highlight..::..GradientFormatter


SpanGradientFormatter Members

[image] [image]

Lucene.Net Class Libraries
SpanGradientFormatter Members
SpanGradientFormatter Class Constructors Methods Fields See Also Send Feedback

The SpanGradientFormatter type exposes the following members.

Constructors

 | Name | Description
Public method | SpanGradientFormatter | Initializes a new instance of the SpanGradientFormatter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBackgroundColorString | (Inherited from GradientFormatter.)
Protected method | GetForegroundColorString | (Inherited from GradientFormatter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTerm | (Overrides GradientFormatter..::..HighlightTerm(String, TokenGroup).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | highlightBackground | (Inherited from GradientFormatter.)
Protected field | highlightForeground | (Inherited from GradientFormatter.)

See Also

SpanGradientFormatter Class
Lucene.Net.Highlight Namespace


SpanGradientFormatter Constructor

[image]

Lucene.Net Class Libraries
SpanGradientFormatter Constructor
SpanGradientFormatter Class See Also Send Feedback
Initializes a new instance of the SpanGradientFormatter class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public SpanGradientFormatter(
    float maxScore,
    string minForegroundColor,
    string maxForegroundColor,
    string minBackgroundColor,
    string maxBackgroundColor
)
Visual Basic
Public Sub New ( _
    maxScore As Single, _
    minForegroundColor As String, _
    maxForegroundColor As String, _
    minBackgroundColor As String, _
    maxBackgroundColor As String _
)
Visual C++
public:
SpanGradientFormatter(
    float maxScore,
    String^ minForegroundColor,
    String^ maxForegroundColor,
    String^ minBackgroundColor,
    String^ maxBackgroundColor
)

Parameters

maxScore
Type: System..::..Single

[Missing <param name="maxScore"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

minForegroundColor
Type: System..::..String

[Missing <param name="minForegroundColor"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

maxForegroundColor
Type: System..::..String

[Missing <param name="maxForegroundColor"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

minBackgroundColor
Type: System..::..String

[Missing <param name="minBackgroundColor"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

maxBackgroundColor
Type: System..::..String

[Missing <param name="maxBackgroundColor"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.#ctor(System.Single,System.String,System.String,System.String,System.String)"]

See Also

SpanGradientFormatter Class
Lucene.Net.Highlight Namespace


SpanGradientFormatter Fields

[image] [image]

Lucene.Net Class Libraries
SpanGradientFormatter Fields
SpanGradientFormatter Class See Also Send Feedback

The SpanGradientFormatter type exposes the following members.

Fields

 | Name | Description
Protected field | highlightBackground | (Inherited from GradientFormatter.)
Protected field | highlightForeground | (Inherited from GradientFormatter.)

See Also

SpanGradientFormatter Class
Lucene.Net.Highlight Namespace


SpanGradientFormatter Methods

[image] [image]

Lucene.Net Class Libraries
SpanGradientFormatter Methods
SpanGradientFormatter Class See Also Send Feedback

The SpanGradientFormatter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBackgroundColorString | (Inherited from GradientFormatter.)
Protected method | GetForegroundColorString | (Inherited from GradientFormatter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTerm | (Overrides GradientFormatter..::..HighlightTerm(String, TokenGroup).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanGradientFormatter Class
Lucene.Net.Highlight Namespace


HighlightTerm Method

[image]

Lucene.Net Class Libraries
SpanGradientFormatter..::..HighlightTerm Method
SpanGradientFormatter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public override string HighlightTerm(
    string originalText,
    TokenGroup tokenGroup
)
Visual Basic
Public Overrides Function HighlightTerm ( _
    originalText As String, _
    tokenGroup As TokenGroup _
) As String
Visual C++
public:
virtual String^ HighlightTerm(
    String^ originalText,
    TokenGroup^ tokenGroup
) override

Parameters

originalText
Type: System..::..String

[Missing <param name="originalText"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

tokenGroup
Type: Lucene.Net.Highlight..::..TokenGroup

[Missing <param name="tokenGroup"/> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.SpanGradientFormatter.HighlightTerm(System.String,Lucene.Net.Highlight.TokenGroup)"]

Implements

Formatter..::..HighlightTerm(String, TokenGroup)

See Also

SpanGradientFormatter Class
Lucene.Net.Highlight Namespace


TextFragment Class

[image]

Lucene.Net Class Libraries
TextFragment Class
Members See Also Send Feedback
Low-level class used to record information about a section of a document with a score.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class TextFragment
Visual Basic
Public Class TextFragment
Visual C++
public ref class TextFragment

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..TextFragment

See Also

TextFragment Members
Lucene.Net.Highlight Namespace


TextFragment Members

[image] [image]

Lucene.Net Class Libraries
TextFragment Members
TextFragment Class Constructors Methods See Also Send Feedback

The TextFragment type exposes the following members.

Constructors

 | Name | Description
Public method | TextFragment | Initializes a new instance of the TextFragment class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Follows |
Public method | GetFragNum |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetScore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


TextFragment Constructor

[image]

Lucene.Net Class Libraries
TextFragment Constructor
TextFragment Class See Also Send Feedback
Initializes a new instance of the TextFragment class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public TextFragment(
    StringBuilder markedUpText,
    int textStartPos,
    int fragNum
)
Visual Basic
Public Sub New ( _
    markedUpText As StringBuilder, _
    textStartPos As Integer, _
    fragNum As Integer _
)
Visual C++
public:
TextFragment(
    StringBuilder^ markedUpText,
    int textStartPos,
    int fragNum
)

Parameters

markedUpText
Type: System.Text..::..StringBuilder

[Missing <param name="markedUpText"/> documentation for "M:Lucene.Net.Highlight.TextFragment.#ctor(System.Text.StringBuilder,System.Int32,System.Int32)"]

textStartPos
Type: System..::..Int32

[Missing <param name="textStartPos"/> documentation for "M:Lucene.Net.Highlight.TextFragment.#ctor(System.Text.StringBuilder,System.Int32,System.Int32)"]

fragNum
Type: System..::..Int32

[Missing <param name="fragNum"/> documentation for "M:Lucene.Net.Highlight.TextFragment.#ctor(System.Text.StringBuilder,System.Int32,System.Int32)"]

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


TextFragment Methods

[image] [image]

Lucene.Net Class Libraries
TextFragment Methods
TextFragment Class See Also Send Feedback

The TextFragment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Follows |
Public method | GetFragNum |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetScore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


Follows Method

[image]

Lucene.Net Class Libraries
TextFragment..::..Follows Method
TextFragment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TextFragment.Follows(Lucene.Net.Highlight.TextFragment)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual bool Follows(
    TextFragment fragment
)
Visual Basic
Public Overridable Function Follows ( _
    fragment As TextFragment _
) As Boolean
Visual C++
public:
virtual bool Follows(
    TextFragment^ fragment
)

Parameters

fragment
Type: Lucene.Net.Highlight..::..TextFragment

[Missing <param name="fragment"/> documentation for "M:Lucene.Net.Highlight.TextFragment.Follows(Lucene.Net.Highlight.TextFragment)"]

Return Value

true if this fragment follows the one passed

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


GetFragNum Method

[image]

Lucene.Net Class Libraries
TextFragment..::..GetFragNum Method
TextFragment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TextFragment.GetFragNum"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual int GetFragNum()
Visual Basic
Public Overridable Function GetFragNum As Integer
Visual C++
public:
virtual int GetFragNum()

Return Value

the fragment sequence number

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


GetScore Method

[image]

Lucene.Net Class Libraries
TextFragment..::..GetScore Method
TextFragment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TextFragment.GetScore"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetScore()
Visual Basic
Public Overridable Function GetScore As Single
Visual C++
public:
virtual float GetScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TextFragment.GetScore"]

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


Merge Method

[image]

Lucene.Net Class Libraries
TextFragment..::..Merge Method
TextFragment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TextFragment.Merge(Lucene.Net.Highlight.TextFragment)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void Merge(
    TextFragment frag2
)
Visual Basic
Public Overridable Sub Merge ( _
    frag2 As TextFragment _
)
Visual C++
public:
virtual void Merge(
    TextFragment^ frag2
)

Parameters

frag2
Type: Lucene.Net.Highlight..::..TextFragment
Fragment to be merged into this one

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TextFragment..::..ToString Method
TextFragment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TextFragment.ToString"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TextFragment.ToString"]

See Also

TextFragment Class
Lucene.Net.Highlight Namespace


TokenGroup Class

[image]

Lucene.Net Class Libraries
TokenGroup Class
Members See Also Send Feedback
One, or several overlapping tokens, along with the score(s) and the scope of the original text

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class TokenGroup
Visual Basic
Public Class TokenGroup
Visual C++
public ref class TokenGroup

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..TokenGroup

See Also

TokenGroup Members
Lucene.Net.Highlight Namespace


TokenGroup Members

[image] [image]

Lucene.Net Class Libraries
TokenGroup Members
TokenGroup Class Constructors Methods See Also Send Feedback

The TokenGroup type exposes the following members.

Constructors

 | Name | Description
Public method | TokenGroup | Initializes a new instance of the TokenGroup class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumTokens |
Public method | GetScore |
Public method | GetStartOffset |
Public method | GetToken |
Public method | GetTotalScore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


TokenGroup Constructor

[image]

Lucene.Net Class Libraries
TokenGroup Constructor
TokenGroup Class See Also Send Feedback
Initializes a new instance of the TokenGroup class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public TokenGroup()
Visual Basic
Public Sub New
Visual C++
public:
TokenGroup()

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


TokenGroup Methods

[image] [image]

Lucene.Net Class Libraries
TokenGroup Methods
TokenGroup Class See Also Send Feedback

The TokenGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumTokens |
Public method | GetScore |
Public method | GetStartOffset |
Public method | GetToken |
Public method | GetTotalScore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


GetEndOffset Method

[image]

Lucene.Net Class Libraries
TokenGroup..::..GetEndOffset Method
TokenGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenGroup.GetEndOffset"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual int GetEndOffset()
Visual Basic
Public Overridable Function GetEndOffset As Integer
Visual C++
public:
virtual int GetEndOffset()

Return Value

the end position in the original text

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


GetNumTokens Method

[image]

Lucene.Net Class Libraries
TokenGroup..::..GetNumTokens Method
TokenGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenGroup.GetNumTokens"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual int GetNumTokens()
Visual Basic
Public Overridable Function GetNumTokens As Integer
Visual C++
public:
virtual int GetNumTokens()

Return Value

the number of tokens in this group

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


GetScore Method

[image]

Lucene.Net Class Libraries
TokenGroup..::..GetScore Method
TokenGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenGroup.GetScore(System.Int32)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetScore(
    int index
)
Visual Basic
Public Overridable Function GetScore ( _
    index As Integer _
) As Single
Visual C++
public:
virtual float GetScore(
    int index
)

Parameters

index
Type: System..::..Int32
a value between 0 and numTokens -1

Return Value

the "n"th score

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


GetStartOffset Method

[image]

Lucene.Net Class Libraries
TokenGroup..::..GetStartOffset Method
TokenGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenGroup.GetStartOffset"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual int GetStartOffset()
Visual Basic
Public Overridable Function GetStartOffset As Integer
Visual C++
public:
virtual int GetStartOffset()

Return Value

the start position in the original text

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


GetToken Method

[image]

Lucene.Net Class Libraries
TokenGroup..::..GetToken Method
TokenGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenGroup.GetToken(System.Int32)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual Token GetToken(
    int index
)
Visual Basic
Public Overridable Function GetToken ( _
    index As Integer _
) As Token
Visual C++
public:
virtual Token^ GetToken(
    int index
)

Parameters

index
Type: System..::..Int32
a value between 0 and numTokens -1

Return Value

the "n"th token

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


GetTotalScore Method

[image]

Lucene.Net Class Libraries
TokenGroup..::..GetTotalScore Method
TokenGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenGroup.GetTotalScore"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetTotalScore()
Visual Basic
Public Overridable Function GetTotalScore As Single
Visual C++
public:
virtual float GetTotalScore()

Return Value

all tokens' scores summed up

See Also

TokenGroup Class
Lucene.Net.Highlight Namespace


TokenSources Class

[image]

Lucene.Net Class Libraries
TokenSources Class
Members See Also Send Feedback
Hides implementation issues associated with obtaining a TokenStream for use with the higlighter - can obtain from TermFreqVectors with offsets and (optionally) positions or from Analyzer class reparsing the stored content.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class TokenSources
Visual Basic
Public Class TokenSources
Visual C++
public ref class TokenSources

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..TokenSources

See Also

TokenSources Members
Lucene.Net.Highlight Namespace


TokenSources Members

[image] [image]

Lucene.Net Class Libraries
TokenSources Members
TokenSources Class Constructors Methods See Also Send Feedback

The TokenSources type exposes the following members.

Constructors

 | Name | Description
Public method | TokenSources | Initializes a new instance of the TokenSources class

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAnyTokenStream
A convenience method that tries a number of approaches to getting a token stream. The cost of finding there are no termVectors in the index is minimal (1000 invocations still registers 0 ms). So this "lazy" (flexible?) approach to coding is probably acceptable
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetTokenStream(TermPositionVector)
GetTokenStream(TermPositionVector, Boolean)
Low level api. Returns a token stream or null if no offset info available in index. This can be used to feed the highlighter with a pre-parsed token stream In my tests the speeds to recreate 1000 token streams using this method are: - with TermVector offset only data stored - 420 milliseconds - with TermVector offset AND position data stored - 271 milliseconds (nb timings for TermVector with position data are based on a tokenizer with contiguous positions - no overlaps or gaps) The cost of not using TermPositionVector to store pre-parsed content and using an analyzer to re-parse the original content: - reanalyzing the original content - 980 milliseconds The re-analyze timings will typically vary depending on - 1) The complexity of the analyzer code (timings above were using a stemmer/lowercaser/stopword combo) 2) The number of other fields (Lucene reads ALL fields off the disk when accessing just one document field - can cost dear!) 3) Use of compression on field storage - could be faster cos of compression (less disk IO) or slower (more CPU burn) depending on the content.
GetTokenStream(IndexReader, Int32, String)
GetTokenStream(IndexReader, Int32, String, Analyzer)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TokenSources Class
Lucene.Net.Highlight Namespace


TokenSources Constructor

[image]

Lucene.Net Class Libraries
TokenSources Constructor
TokenSources Class See Also Send Feedback
Initializes a new instance of the TokenSources class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public TokenSources()
Visual Basic
Public Sub New
Visual C++
public:
TokenSources()

See Also

TokenSources Class
Lucene.Net.Highlight Namespace


TokenSources Methods

[image] [image]

Lucene.Net Class Libraries
TokenSources Methods
TokenSources Class See Also Send Feedback

The TokenSources type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAnyTokenStream
A convenience method that tries a number of approaches to getting a token stream. The cost of finding there are no termVectors in the index is minimal (1000 invocations still registers 0 ms). So this "lazy" (flexible?) approach to coding is probably acceptable
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetTokenStream(TermPositionVector)
GetTokenStream(TermPositionVector, Boolean)
Low level api. Returns a token stream or null if no offset info available in index. This can be used to feed the highlighter with a pre-parsed token stream In my tests the speeds to recreate 1000 token streams using this method are: - with TermVector offset only data stored - 420 milliseconds - with TermVector offset AND position data stored - 271 milliseconds (nb timings for TermVector with position data are based on a tokenizer with contiguous positions - no overlaps or gaps) The cost of not using TermPositionVector to store pre-parsed content and using an analyzer to re-parse the original content: - reanalyzing the original content - 980 milliseconds The re-analyze timings will typically vary depending on - 1) The complexity of the analyzer code (timings above were using a stemmer/lowercaser/stopword combo) 2) The number of other fields (Lucene reads ALL fields off the disk when accessing just one document field - can cost dear!) 3) Use of compression on field storage - could be faster cos of compression (less disk IO) or slower (more CPU burn) depending on the content.
GetTokenStream(IndexReader, Int32, String)
GetTokenStream(IndexReader, Int32, String, Analyzer)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TokenSources Class
Lucene.Net.Highlight Namespace


GetAnyTokenStream Method

[image]

Lucene.Net Class Libraries
TokenSources..::..GetAnyTokenStream Method
TokenSources Class See Also Send Feedback
A convenience method that tries a number of approaches to getting a token stream. The cost of finding there are no termVectors in the index is minimal (1000 invocations still registers 0 ms). So this "lazy" (flexible?) approach to coding is probably acceptable

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static TokenStream GetAnyTokenStream(
    IndexReader reader,
    int docId,
    string field,
    Analyzer analyzer
)
Visual Basic
Public Shared Function GetAnyTokenStream ( _
    reader As IndexReader, _
    docId As Integer, _
    field As String, _
    analyzer As Analyzer _
) As TokenStream
Visual C++
public:
static TokenStream^ GetAnyTokenStream(
    IndexReader^ reader,
    int docId,
    String^ field,
    Analyzer^ analyzer
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetAnyTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetAnyTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetAnyTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetAnyTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

Return Value

null if field not stored correctly

See Also

TokenSources Class
Lucene.Net.Highlight Namespace


GetTokenStream Method

[image] [image]

Lucene.Net Class Libraries
TokenSources..::..GetTokenStream Method
TokenSources Class See Also Send Feedback

Overload List

Name Description
GetTokenStream(TermPositionVector)
GetTokenStream(TermPositionVector, Boolean)
Low level api. Returns a token stream or null if no offset info available in index. This can be used to feed the highlighter with a pre-parsed token stream In my tests the speeds to recreate 1000 token streams using this method are: - with TermVector offset only data stored - 420 milliseconds - with TermVector offset AND position data stored - 271 milliseconds (nb timings for TermVector with position data are based on a tokenizer with contiguous positions - no overlaps or gaps) The cost of not using TermPositionVector to store pre-parsed content and using an analyzer to re-parse the original content: - reanalyzing the original content - 980 milliseconds The re-analyze timings will typically vary depending on - 1) The complexity of the analyzer code (timings above were using a stemmer/lowercaser/stopword combo) 2) The number of other fields (Lucene reads ALL fields off the disk when accessing just one document field - can cost dear!) 3) Use of compression on field storage - could be faster cos of compression (less disk IO) or slower (more CPU burn) depending on the content.
GetTokenStream(IndexReader, Int32, String)
GetTokenStream(IndexReader, Int32, String, Analyzer)

See Also

TokenSources Class
TokenSources Members
Lucene.Net.Highlight Namespace


GetTokenStream Method (TermPositionVector)

[image]

Lucene.Net Class Libraries
TokenSources..::..GetTokenStream Method (TermPositionVector)
TokenSources Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.TermPositionVector)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static TokenStream GetTokenStream(
    TermPositionVector tpv
)
Visual Basic
Public Shared Function GetTokenStream ( _
    tpv As TermPositionVector _
) As TokenStream
Visual C++
public:
static TokenStream^ GetTokenStream(
    TermPositionVector^ tpv
)

Parameters

tpv
Type: Lucene.Net.Index..::..TermPositionVector

[Missing <param name="tpv"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.TermPositionVector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.TermPositionVector)"]

See Also

TokenSources Class
GetTokenStream Overload
Lucene.Net.Highlight Namespace


GetTokenStream Method (TermPositionVector, Boolean)

[image]

Lucene.Net Class Libraries
TokenSources..::..GetTokenStream Method (TermPositionVector, Boolean)
TokenSources Class See Also Send Feedback
Low level api. Returns a token stream or null if no offset info available in index. This can be used to feed the highlighter with a pre-parsed token stream In my tests the speeds to recreate 1000 token streams using this method are: - with TermVector offset only data stored - 420 milliseconds - with TermVector offset AND position data stored - 271 milliseconds (nb timings for TermVector with position data are based on a tokenizer with contiguous positions - no overlaps or gaps) The cost of not using TermPositionVector to store pre-parsed content and using an analyzer to re-parse the original content: - reanalyzing the original content - 980 milliseconds The re-analyze timings will typically vary depending on - 1) The complexity of the analyzer code (timings above were using a stemmer/lowercaser/stopword combo) 2) The number of other fields (Lucene reads ALL fields off the disk when accessing just one document field - can cost dear!) 3) Use of compression on field storage - could be faster cos of compression (less disk IO) or slower (more CPU burn) depending on the content.

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static TokenStream GetTokenStream(
    TermPositionVector tpv,
    bool tokenPositionsGuaranteedContiguous
)
Visual Basic
Public Shared Function GetTokenStream ( _
    tpv As TermPositionVector, _
    tokenPositionsGuaranteedContiguous As Boolean _
) As TokenStream
Visual C++
public:
static TokenStream^ GetTokenStream(
    TermPositionVector^ tpv,
    bool tokenPositionsGuaranteedContiguous
)

Parameters

tpv
Type: Lucene.Net.Index..::..TermPositionVector

[Missing <param name="tpv"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.TermPositionVector,System.Boolean)"]

tokenPositionsGuaranteedContiguous
Type: System..::..Boolean
true if the token position numbers have no overlaps or gaps. If looking to eek out the last drops of performance, set to true. If in doubt, set to false.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.TermPositionVector,System.Boolean)"]

See Also

TokenSources Class
GetTokenStream Overload
Lucene.Net.Highlight Namespace


GetTokenStream Method (IndexReader, Int32, String)

[image]

Lucene.Net Class Libraries
TokenSources..::..GetTokenStream Method (IndexReader, Int32, String)
TokenSources Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static TokenStream GetTokenStream(
    IndexReader reader,
    int docId,
    string field
)
Visual Basic
Public Shared Function GetTokenStream ( _
    reader As IndexReader, _
    docId As Integer, _
    field As String _
) As TokenStream
Visual C++
public:
static TokenStream^ GetTokenStream(
    IndexReader^ reader,
    int docId,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

See Also

TokenSources Class
GetTokenStream Overload
Lucene.Net.Highlight Namespace


GetTokenStream Method (IndexReader, Int32, String, Analyzer)

[image]

Lucene.Net Class Libraries
TokenSources..::..GetTokenStream Method (IndexReader, Int32, String, Analyzer)
TokenSources Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public static TokenStream GetTokenStream(
    IndexReader reader,
    int docId,
    string field,
    Analyzer analyzer
)
Visual Basic
Public Shared Function GetTokenStream ( _
    reader As IndexReader, _
    docId As Integer, _
    field As String, _
    analyzer As Analyzer _
) As TokenStream
Visual C++
public:
static TokenStream^ GetTokenStream(
    IndexReader^ reader,
    int docId,
    String^ field,
    Analyzer^ analyzer
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TokenSources.GetTokenStream(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Analysis.Analyzer)"]

See Also

TokenSources Class
GetTokenStream Overload
Lucene.Net.Highlight Namespace


TokenSources.StoredTokenStream Class

[image]

Lucene.Net Class Libraries
TokenSources..::..StoredTokenStream Class
TokenSources Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Highlight.TokenSources.StoredTokenStream"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class StoredTokenStream : TokenStream
Visual Basic
Public Class StoredTokenStream _
    Inherits TokenStream
Visual C++
public ref class StoredTokenStream : public TokenStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream
Lucene.Net.Highlight..::..TokenSources..::..StoredTokenStream

See Also

TokenSources..::..StoredTokenStream Members
Lucene.Net.Highlight Namespace


TokenSources.StoredTokenStream Members

[image] [image]

Lucene.Net Class Libraries
TokenSources..::..StoredTokenStream Members
TokenSources..::..StoredTokenStream Class Methods See Also Send Feedback

Hides implementation issues associated with obtaining a TokenStream for use with the higlighter - can obtain from TermFreqVectors with offsets and (optionally) positions or from Analyzer class reparsing the stored content.

The TokenSources..::..StoredTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TokenSources..::..StoredTokenStream Class
Lucene.Net.Highlight Namespace


TokenSources.StoredTokenStream Methods

[image] [image]

Lucene.Net Class Libraries
TokenSources..::..StoredTokenStream Methods
TokenSources..::..StoredTokenStream Class See Also Send Feedback

The TokenSources..::..StoredTokenStream type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
(Inherited from AttributeSource.)
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
(Inherited from AttributeSource.)
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
(Inherited from AttributeSource.)
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
(Inherited from AttributeSource.)
Public method Close
Releases resources associated with this stream.
(Inherited from TokenStream.)
Public method End
This method is called by the consumer after the last token has been consumed, after {@link #IncrementToken()} returned
CopyC#
false
 (using the new
CopyC#
TokenStream
 API). Streams implementing the old API should upgrade to use this feature.

This method can be used to perform any end-of-stream operations, such as setting the final offset of a stream. The final offset of a stream might differ from the offset of the last token eg in case one or more whitespaces followed after the last token, but a {@link WhitespaceTokenizer} was used.

(Inherited from TokenStream.)
Public method | Equals | (Inherited from AttributeSource.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
(Inherited from AttributeSource.)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
(Inherited from AttributeSource.)
Public method GetAttributeFactory
returns the used AttributeFactory.
(Inherited from AttributeSource.)
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
(Inherited from AttributeSource.)
Public method | GetHashCode | (Inherited from AttributeSource.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
(Inherited from AttributeSource.)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
(Inherited from AttributeSource.)
Public method IncrementToken
Consumers (i.e., {@link IndexWriter}) use this method to advance the stream to the next token. Implementing classes must implement this method and update the appropriate {@link AttributeImpl}s with the attributes of the next token. The producer must make no assumptions about the attributes after the method has been returned: the caller may arbitrarily change it. If the producer needs to preserve the state for subsequent calls, it can use {@link #captureState} to create a copy of the current attribute state. This method is called for every token of a document, so an efficient implementation is crucial for good performance. To avoid calls to {@link #AddAttribute(Class)} and {@link #GetAttribute(Class)} or downcasts, references to all {@link AttributeImpl}s that this stream uses should be retrieved during instantiation. To ensure that filters and consumers know which attributes are available, the attributes must be added during instantiation. Filters and consumers are not required to check for availability of attributes in {@link #IncrementToken()}.
(Inherited from TokenStream.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)
Public method Reset
Resets this stream to the beginning. This is an optional operation, so subclasses may or may not implement this method. {@link #Reset()} is not needed for the standard indexing process. However, if the tokens of a
CopyC#
TokenStream
 are intended to be consumed more than once, it is necessary to implement {@link #Reset()}. Note that if your TokenStream caches tokens and feeds them back again after a reset, it is imperative that you clone the tokens when you store them away (on the first pass) as well as when you return them (on future passes after {@link #Reset()}).
(Inherited from TokenStream.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
(Inherited from AttributeSource.)
Public method | ToString | (Inherited from AttributeSource.)

See Also

TokenSources..::..StoredTokenStream Class
Lucene.Net.Highlight Namespace


Next Method

[image] [image]

Lucene.Net Class Libraries
TokenSources..::..StoredTokenStream..::..Next Method
TokenSources..::..StoredTokenStream Class See Also Send Feedback

Overload List

Name | Description
Public method | Next()()()() | (Overrides TokenStream..::..Next()()()().)
Public method Next(Token) Obsolete.
Returns the next token in the stream, or null at EOS. When possible, the input Token should be used as the returned Token (this gives fastest tokenization performance), but this is not required and a new Token may be returned. Callers may re-use a single Token instance for successive calls to this method. This implicitly defines a "contract" between consumers (callers of this method) and producers (implementations of this method that are the source for tokens):
  • A consumer must fully consume the previously returned {@link Token} before calling this method again.
  • A producer must call {@link Token#Clear()} before setting the fields in it and returning it
Also, the producer must make no assumptions about a {@link Token} after it has been returned: the caller may arbitrarily change it. If the producer needs to hold onto the {@link Token} for subsequent calls, it must clone() it before storing it. Note that a {@link TokenFilter} is considered a consumer.
(Inherited from TokenStream.)

See Also

TokenSources..::..StoredTokenStream Class
TokenSources..::..StoredTokenStream Members
Lucene.Net.Highlight Namespace


Next Method

[image]

Lucene.Net Class Libraries
TokenSources..::..StoredTokenStream..::..Next Method
TokenSources..::..StoredTokenStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.TokenSources.StoredTokenStream.Next"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public override Token Next()
Visual Basic
Public Overrides Function Next As Token
Visual C++
public:
virtual Token^ Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Highlight.TokenSources.StoredTokenStream.Next"]

See Also

TokenSources..::..StoredTokenStream Class
Next Overload
Lucene.Net.Highlight Namespace


WeightedTerm Class

[image]

Lucene.Net Class Libraries
WeightedTerm Class
Members See Also Send Feedback
Lightweight class to hold term and a weight value used for scoring this term

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public class WeightedTerm
Visual Basic
Public Class WeightedTerm
Visual C++
public ref class WeightedTerm

Inheritance Hierarchy

System..::..Object
Lucene.Net.Highlight..::..WeightedTerm

See Also

WeightedTerm Members
Lucene.Net.Highlight Namespace


WeightedTerm Members

[image] [image]

Lucene.Net Class Libraries
WeightedTerm Members
WeightedTerm Class Constructors Methods See Also Send Feedback

The WeightedTerm type exposes the following members.

Constructors

 | Name | Description
Public method | WeightedTerm | Initializes a new instance of the WeightedTerm class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTerm |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTerm |
Public method | SetWeight |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


WeightedTerm Constructor

[image]

Lucene.Net Class Libraries
WeightedTerm Constructor
WeightedTerm Class See Also Send Feedback
Initializes a new instance of the WeightedTerm class

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public WeightedTerm(
    float weight,
    string term
)
Visual Basic
Public Sub New ( _
    weight As Single, _
    term As String _
)
Visual C++
public:
WeightedTerm(
    float weight,
    String^ term
)

Parameters

weight
Type: System..::..Single

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Highlight.WeightedTerm.#ctor(System.Single,System.String)"]

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Highlight.WeightedTerm.#ctor(System.Single,System.String)"]

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


WeightedTerm Methods

[image] [image]

Lucene.Net Class Libraries
WeightedTerm Methods
WeightedTerm Class See Also Send Feedback

The WeightedTerm type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTerm |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeight |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTerm |
Public method | SetWeight |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
WeightedTerm..::..GetTerm Method
WeightedTerm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.WeightedTerm.GetTerm"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual string GetTerm()
Visual Basic
Public Overridable Function GetTerm As String
Visual C++
public:
virtual String^ GetTerm()

Return Value

the term value (stemmed)

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


GetWeight Method

[image]

Lucene.Net Class Libraries
WeightedTerm..::..GetWeight Method
WeightedTerm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.WeightedTerm.GetWeight"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual float GetWeight()
Visual Basic
Public Overridable Function GetWeight As Single
Visual C++
public:
virtual float GetWeight()

Return Value

the weight associated with this term

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


SetTerm Method

[image]

Lucene.Net Class Libraries
WeightedTerm..::..SetTerm Method
WeightedTerm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.WeightedTerm.SetTerm(System.String)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetTerm(
    string term
)
Visual Basic
Public Overridable Sub SetTerm ( _
    term As String _
)
Visual C++
public:
virtual void SetTerm(
    String^ term
)

Parameters

term
Type: System..::..String
the term value (stemmed)

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


SetWeight Method

[image]

Lucene.Net Class Libraries
WeightedTerm..::..SetWeight Method
WeightedTerm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Highlight.WeightedTerm.SetWeight(System.Single)"]

Namespace: Lucene.Net.Highlight
Assembly: Lucene.Net.Contrib.Highlighter (in Lucene.Net.Contrib.Highlighter.dll) Version: 2.3.2.1

Syntax

C#
public virtual void SetWeight(
    float weight
)
Visual Basic
Public Overridable Sub SetWeight ( _
    weight As Single _
)
Visual C++
public:
virtual void SetWeight(
    float weight
)

Parameters

weight
Type: System..::..Single
the weight associated with this term

See Also

WeightedTerm Class
Lucene.Net.Highlight Namespace


Lucene.Net.Index Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Index Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Index"]

Classes

Class | Description
Public class AbstractAllTermDocs
Base class for enumerating all but deleted docs.

NOTE: this class is meant only to be used internally by Lucene; it's only public so it can be shared across packages. This means the API is freely subject to change, and, the class could be removed entirely, in any Lucene release. Use directly at your own risk! */

Public class | ByteBlockPool
Public class | ByteBlockPool..::..Allocator
Public class | ByteSliceReader
Public class ByteSliceWriter
Class to write byte streams into slices of shared byte[]. This is used by DocumentsWriter to hold the posting list for many terms in RAM.
Public class CheckIndex
Basic tool and API to check the health of an index and write a new segments file that removes reference to problematic segments.

As this tool checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: this tool and API is new and experimental and is subject to suddenly change in the next release. Please make a complete backup of your index before using this to fix your index!

Public class CheckIndex..::..Status
Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

Public class CheckIndex..::..Status..::..FieldNormStatus
Status from testing field norms.
Public class CheckIndex..::..Status..::..SegmentInfoStatus
Holds the status of each segment in the index. See {@link #segmentInfos}.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

Public class CheckIndex..::..Status..::..StoredFieldStatus
Status from testing stored fields.
Public class CheckIndex..::..Status..::..TermIndexStatus
Status from testing term index.
Public class CheckIndex..::..Status..::..TermVectorStatus
Status from testing stored fields.
Public class CompoundFileReader
Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.
Public class CompoundFileReader..::..CSIndexInput
Implementation of an IndexInput that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.
Public class CompoundFileWriter
Combines multiple files into a single compound file. The file format:
  • VInt fileCount
  • {Directory} fileCount entries with the following structure:
    • long dataOffset
    • String fileName
  • {File Data} fileCount entries with the raw data of the corresponding file
The fileCount integer indicates how many files are contained in this compound file. The {directory} that follows has that many entries. Each directory entry contains a long pointer to the start of this file's data section, and a String with that file's name.
Public class ConcurrentMergeScheduler
A {@link MergeScheduler} that runs each merge using a separate thread, up until a maximum number of threads ({@link #setMaxThreadCount}) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.
Public class | ConcurrentMergeScheduler..::..MergeThread
Public class CorruptIndexException
This exception is thrown when Lucene detects an inconsistency in the index.
Public class DirectoryReader
An IndexReader which reads indexes with multiple segments.
Public class DocumentsWriter
This class accepts multiple added documents and directly writes a single segment file. It does this more efficiently than creating a single segment per document (with DocumentWriter) and doing standard merges on those segments. Each added document is passed to the {@link DocConsumer}, which in turn processes the document and interacts with other consumers in the indexing chain. Certain consumers, like {@link StoredFieldsWriter} and {@link TermVectorsTermsWriter}, digest a document and immediately write bytes to the "doc store" files (ie, they do not consume RAM per document, except while they are processing the document). Other consumers, eg {@link FreqProxTermsWriter} and {@link NormsWriter}, buffer bytes in RAM and flush only when a new segment is produced. Once we have used our allowed RAM buffer, or the number of added docs is large enough (in the case we are flushing by doc count instead of RAM usage), we create a real segment and flush it to the Directory. Threads: Multiple threads are allowed into addDocument at once. There is an initial synchronized call to getThreadState which allocates a ThreadState for this thread. The same thread will get the same ThreadState over time (thread affinity) so that if there are consistent patterns (for example each thread is indexing a different content source) then we make better use of RAM. Then processDocument is called on that ThreadState without synchronization (most of the "heavy lifting" is in this call). Finally the synchronized "finishDocument" is called to flush changes to the directory. When flush is called by IndexWriter, or, we flush internally when autoCommit=false, we forcefully idle all threads and flush only once they are all idle. This means you can call flush with a given thread even while other threads are actively adding/deleting documents. Exceptions: Because this class directly updates in-memory posting lists, and flushes stored fields and term vectors directly to files in the directory, there are certain limited times when an exception can corrupt this state. For example, a disk full while flushing stored fields leaves this file in a corrupt state. Or, an OOM exception while appending to the in-memory posting lists can corrupt that posting list. We call such exceptions "aborting exceptions". In these cases we must call abort() to discard all docs added since the last flush. All other exceptions ("non-aborting exceptions") can still partially update the index structures. These updates are consistent, but, they represent only a part of the document seen up until the exception was hit. When this happens, we immediately mark the document as deleted so that the document is always atomically ("all or none") added to the index.
Public class DoubleFieldEnumerator
Implementation for enumerating over all of the terms in a double numeric field.
Public class EmptyVector
A simple TermFreqVector implementation for an empty vector for use with a deleted document or a document that does not have the field that is being enumerated.
Public class | FieldEnumerator<(Of <(<'T>)>)>
Public class FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator
The enumerator over the terms in an index.
Public class | FieldInfo
Public class FieldInfos
Access to the Fieldable Info file that describes document fields and whether or not they are indexed. Each segment has a separate Fieldable Info file. Objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.
Public class FieldInvertState
This class tracks the number and position / offset parameters of terms being added to the index. The information collected in this class is also used to calculate the normalization factor for a field.

WARNING: This API is new and experimental, and may suddenly change.

Public class FieldReaderException
Public class FieldSortedTermVectorMapper
For each Field, store a sorted collection of {@link TermVectorEntry}s

This is not thread-safe.

Public class FieldsReader
Class responsible for access to stored document fields.

It uses <segment>.fdt and <segment>.fdx; files.

Public class FilterIndexReader
A
CopyC#
FilterIndexReader
 contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
CopyC#
FilterIndexReader
 itself simply implements all abstract methods of
CopyC#
IndexReader
 with versions that pass all requests to the contained index reader. Subclasses of
CopyC#
FilterIndexReader
 may further override some of these methods and may also provide additional methods and fields.
Public class FilterIndexReader..::..FilterTermDocs
Base class for filtering {@link TermDocs} implementations.
Public class FilterIndexReader..::..FilterTermEnum
Base class for filtering {@link TermEnum} implementations.
Public class FilterIndexReader..::..FilterTermPositions
Base class for filtering {@link TermPositions} implementations.
Public class FloatFieldEnumerator
Implementation for enumerating over all of the terms in a float numeric field.
Public class IndexCommit

Expert: represents a single commit into an index as seen by the {@link IndexDeletionPolicy} or {@link IndexReader}.

Changes to the content of an index are made visible only after the writer who made that change commits by writing a new segments file (

CopyC#
segments_N
). This point in time, when the action of writing of a new segments file to the directory is completed, is an index commit.

Each index commit point has a unique segments file associated with it. The segments file associated with a later index commit point would have a larger N.

WARNING: This API is a new and experimental and may suddenly change.

Public class | IndexFileDeleter
Public class IndexFileNameFilter
Filename filter that accept filenames and extensions only created by Lucene.
Public class IndexFileNames
Useful constants representing filenames and extensions used by lucene
Public class IndexModifier Obsolete.

[Note that as of 2.1, all but one of the methods in this class are available via {@link IndexWriter}. The one method that is not available is {@link #DeleteDocument(int)}.]

A class to modify an index, i.e. to delete and add documents. This class hides {@link IndexReader} and {@link IndexWriter} so that you do not need to care about implementation details such as that adding documents is done via IndexWriter and deletion is done via IndexReader.

Note that you cannot create more than one

CopyC#
IndexModifier
object on the same directory at the same time.

Example usage:

CopyC#
<font color="#ffffff">    </font><font color="#000000">Analyzer analyzer = </font><font color="#7f0055"><b>new </b></font><font color="#000000">StandardAnalyzer</font><font color="#000000">()</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#3f7f5f">// create an index in /tmp/index, overwriting an existing one:</font><br /><font color="#ffffff">    </font><font color="#000000">IndexModifier indexModifier = </font><font color="#7f0055"><b>new </b></font><font color="#000000">IndexModifier</font><font color="#000000">(</font><font color="#2a00ff">"/tmp/index"</font><font color="#000000">, analyzer, </font><font color="#7f0055"><b>true</b></font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">Document doc = </font><font color="#7f0055"><b>new </b></font><font color="#000000">Document</font><font color="#000000">()</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">doc.add</font><font color="#000000">(</font><font color="#7f0055"><b>new </b></font><font color="#000000">Field</font><font color="#000000">(</font><font color="#2a00ff">"id"</font><font color="#000000">, </font><font color="#2a00ff">"1"</font><font color="#000000">, Field.Store.YES, Field.Index.NOT_ANALYZED</font><font color="#000000">))</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">doc.add</font><font color="#000000">(</font><font color="#7f0055"><b>new </b></font><font color="#000000">Field</font><font color="#000000">(</font><font color="#2a00ff">"body"</font><font color="#000000">, </font><font color="#2a00ff">"a simple test"</font><font color="#000000">, Field.Store.YES, Field.Index.ANALYZED</font><font color="#000000">))</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">indexModifier.addDocument</font><font color="#000000">(</font><font color="#000000">doc</font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#7f0055"><b>int </b></font><font color="#000000">deleted = indexModifier.delete</font><font color="#000000">(</font><font color="#7f0055"><b>new </b></font><font color="#000000">Term</font><font color="#000000">(</font><font color="#2a00ff">"id"</font><font color="#000000">, </font><font color="#2a00ff">"1"</font><font color="#000000">))</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">System.out.println</font><font color="#000000">(</font><font color="#2a00ff">"Deleted " </font><font color="#000000">+ deleted + </font><font color="#2a00ff">" document"</font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">indexModifier.flush</font><font color="#000000">()</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">System.out.println</font><font color="#000000">(</font><font color="#000000">indexModifier.docCount</font><font color="#000000">() </font><font color="#000000">+ </font><font color="#2a00ff">" docs in index"</font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">indexModifier.close</font><font color="#000000">()</font><font color="#000000">;</font>

Not all methods of IndexReader and IndexWriter are offered by this class. If you need access to additional methods, either use those classes directly or implement your own class that extends

CopyC#
IndexModifier
.

Although an instance of this class can be used from more than one thread, you will not get the best performance. You might want to use IndexReader and IndexWriter directly for that (but you will need to care about synchronization yourself then).

While you can freely mix calls to add() and delete() using this class, you should batch you calls for best performance. For example, if you want to update 20 documents, you should first delete all those documents, then add all the new documents.

Public class IndexReader
IndexReader is an abstract class, providing an interface for accessing an index. Search of an index is done entirely through this abstract interface, so that any subclass which implements it is searchable.

Concrete subclasses of IndexReader are usually constructed with a call to one of the static

CopyC#
open()
methods, e.g. {@link #Open(String, boolean)}.

For efficiency, in this API documents are often referred to via document numbers, non-negative integers which each name a unique document in the index. These document numbers are ephemeral--they may change as documents are added to and deleted from an index. Clients should thus not rely on a given document having the same number between sessions.

An IndexReader can be opened on a directory for which an IndexWriter is opened already, but it cannot be used to delete documents from the index then.

NOTE: for backwards API compatibility, several methods are not listed as abstract, but have no useful implementations in this base class and instead always throw UnsupportedOperationException. Subclasses are strongly encouraged to override these methods, but in many cases may not need to.

NOTE: as of 2.4, it's possible to open a read-only IndexReader using one of the static open methods that accepts the boolean readOnly parameter. Such a reader has better concurrency as it's not necessary to synchronize on the isDeleted method. Currently the default for readOnly is false, meaning if not specified you will get a read/write IndexReader. But in 3.0 this default will change to true, meaning you must explicitly specify false if you want to make changes with the resulting IndexReader.

NOTE: {@link

CopyC#
IndexReader
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexReader
 instance; use your own (non-Lucene) objects instead.
Public class IndexReader..::..FieldOption
Constants describing field properties, for example used for {@link IndexReader#GetFieldNames(FieldOption)}.
Public class IndexWriter
An
CopyC#
IndexWriter
 creates and maintains an index.

The

CopyC#
create
argument to the {@link #IndexWriter(Directory, Analyzer, boolean) constructor} determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with
CopyC#
create=true
 even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also {@link #IndexWriter(Directory, Analyzer) constructors} with no
CopyC#
create
 argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with {@link #AddDocument(Document) addDocument} and removed with {@link #DeleteDocuments(Term)} or {@link #DeleteDocuments(Query)}. A document can be updated with {@link #UpdateDocument(Term, Document) updateDocument} (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, {@link #Close() close} should be called.

These changes are buffered in memory and periodically flushed to the {@link Directory} (during the above method calls). A flush is triggered when there are enough buffered deletes (see {@link #setMaxBufferedDeleteTerms}) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see {@link #setRAMBufferSizeMB}) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either {@link #Commit()} or {@link #close} is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the {@link MergeScheduler}).

The optional

CopyC#
autoCommit
argument to the {@link #IndexWriter(Directory, boolean, Analyzer) constructors} controls visibility of the changes to {@link IndexReader} instances reading the same index. When this is
CopyC#
false
, changes are not visible until {@link #Close()} or {@link #Commit()} is called. Note that changes will still be flushed to the {@link Directory} as new files, but are not committed (no new
CopyC#
segments_N
 file is written referencing the new files, nor are the files sync'd to stable storage) until {@link #Close()} or {@link #Commit()} is called. If something goes terribly wrong (for example the JVM crashes), then the index will reflect none of the changes made since the last commit, or the starting state if commit was not called. You can also call {@link #Rollback()}, which closes the writer without committing any changes, and removes any index files that had been flushed but are now unreferenced. This mode is useful for preventing readers from refreshing at a bad time (for example after you've done all your deletes but before you've done your adds). It can also be used to implement simple single-writer transactional semantics ("all or none"). You can do a two-phase commit by calling {@link #PrepareCommit()} followed by {@link #Commit()}. This is necessary when Lucene is working with an external resource (for example, a database) and both must either commit or rollback the transaction.

When

CopyC#
autoCommit
is
CopyC#
true
 then the writer will periodically commit on its own. [Deprecated: Note that in 3.0, IndexWriter will no longer accept autoCommit=true (it will be hardwired to false). You can always call {@link #Commit()} yourself when needed]. There is no guarantee when exactly an auto commit will occur (it used to be after every flush, but it is now after every completed merge, as of 2.4). If you want to force a commit, call {@link #Commit()}, or, close the writer. Once a commit has finished, newly opened {@link IndexReader} instances will see the changes to the index as of that commit. When running in this mode, be careful not to refresh your readers while optimize or segment merges are taking place as this can tie up substantial disk space.

Public class IndexWriter..::..IndexReaderWarmer
If {@link #getReader} has been called (ie, this writer is in near real-time mode), then after a merge completes, this class can be invoked to warm the reader on the newly merged segment, before the merge commits. This is not required for near real-time search, but will reduce search latency on opening a new near real-time reader after a merge completes.

NOTE: This API is experimental and might change in incompatible ways in the next release.

NOTE: warm is called before any deletes have been carried over to the merged segment.

Public class IndexWriter..::..MaxFieldLength
Specifies maximum field length (in number of tokens/terms) in {@link IndexWriter} constructors. {@link #SetMaxFieldLength(int)} overrides the value set by the constructor.
Public class IntFieldEnumerator
Implementation for enumerating over all of the terms in an int numeric field.
Public class KeepOnlyLastCommitDeletionPolicy
This {@link IndexDeletionPolicy} implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.
Public class LogByteSizeMergePolicy
This is a {@link LogMergePolicy} that measures size of a segment as the total byte size of the segment's files.
Public class LogDocMergePolicy
This is a {@link LogMergePolicy} that measures size of a segment as the number of documents (not taking deletions into account).
Public class LogMergePolicy

This class implements a {@link MergePolicy} that tries to merge segments into levels of exponentially increasing size, where each level has fewer segments than the value of the merge factor. Whenever extra segments (beyond the merge factor upper bound) are encountered, all segments within the level are merged. You can get or set the merge factor using {@link #GetMergeFactor()} and {@link #SetMergeFactor(int)} respectively.

This class is abstract and requires a subclass to define the {@link #size} method which specifies how a segment's size is determined. {@link LogDocMergePolicy} is one subclass that measures size by document count in the segment. {@link LogByteSizeMergePolicy} is another subclass that measures size as the total byte size of the file(s) for the segment.

Public class LongFieldEnumerator
Implementation for enumerating over all of the terms in a long numeric field.
Public class MergePolicy

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g.

CopyC#
SegmentInfos
) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.
Public class | MergePolicy..::..MergeAbortedException
Public class MergePolicy..::..MergeException
Exception thrown if there are any problems while executing a merge.
Public class MergePolicy..::..MergeSpecification
A MergeSpecification instance provides the information necessary to perform multiple merges. It simply contains a list of {@link OneMerge} instances.
Public class MergePolicy..::..OneMerge
OneMerge provides the information necessary to perform an individual primitive merge operation, resulting in a single new segment. The merge spec includes the subset of segments to be merged as well as whether the new segment should use the compound file format.
Public class MergeScheduler

Expert: {@link IndexWriter} uses an instance implementing this interface to execute the merges selected by a {@link MergePolicy}. The default MergeScheduler is {@link ConcurrentMergeScheduler}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (eg, SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

Public class MultipleTermPositions
Allows you to iterate over the {@link TermPositions} for multiple {@link Term}s as a single {@link TermPositions}.
Public class MultiReader
An IndexReader which reads multiple indexes, appending their content.
Public class NumericFieldEnum<(Of <(<'T>)>)>
Base for enumerating over numeric fields.
Public class ParallelReader
An IndexReader which reads multiple, parallel indexes. Each index added must have the same number of documents, but typically each contains different fields. Each document contains the union of the fields of all documents with the same document number. When searching, matches for a query term are from the first index added that has the field.

This is useful, e.g., with collections that have large fields which change rarely and small fields that change more frequently. The smaller fields may be re-indexed in a new index and both indexes may be searched together.

Warning: It is up to you to make sure all indexes are created and modified the same way. For example, if you add documents to one index, you need to add the same documents in the same order to the other indexes. Failure to do so will result in undefined behavior.

Public class Payload
A Payload is metadata that can be stored together with each occurrence of a term. This metadata is stored inline in the posting list of the specific term.

To store payloads in the index a {@link TokenStream} has to be used that produces payload data.

Use {@link TermPositions#GetPayloadLength()} and {@link TermPositions#GetPayload(byte[], int)} to retrieve the payloads from the index.

Public class PositionBasedTermVectorMapper
For each Field, store position by position information. It ignores frequency information

This is not thread-safe.

Public class PositionBasedTermVectorMapper..::..TVPositionInfo
Container for a term at a position
Public class | ReadOnlyDirectoryReader
Public class | ReadOnlySegmentReader
Public class SegmentInfo
Information about a segment such as it's name, directory, and files related to the segment. *

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Public class SegmentInfos
A collection of segmentInfo objects with methods for operating on those segments in relation to the file system.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Public class SegmentInfos..::..FindSegmentsFile
Utility class for executing code that needs to do something with the current segments file. This is necessary with lock-less commits because from the time you locate the current segments file name, until you actually open it, read its contents, or check modified time, etc., it could have been deleted due to a writer commit finishing.
Public class SegmentMerger
The SegmentMerger class combines two or more Segments, represented by an IndexReader ({@link #add}, into a single Segment. After adding the appropriate readers, call the merge method to combine the segments.

If the compoundFile flag is set, then the segments will be merged into a compound file.

Public class SegmentReader

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Public class | SegmentReader..::..CoreReaders
Public class SegmentReader..::..Norm
Byte[] referencing is used because a new norm object needs to be created for each clone, and the byte array is all that is needed for sharing between cloned readers. The current norm referencing is for sharing between readers whereas the byte[] referencing is for copy on write which is independent of reader references (i.e. incRef, decRef).
Public class | SegmentReader..::..Ref
Public class SegmentsGenCommit
Class that will force an index writer to open an index based on the generation in the segments.gen file as opposed to the highest generation found in a directory listing. A use case for using this IndexCommit when opening an IndexWriter would be if index snapshots (source) are being copied over an existing index (target) and the source now has a lower generation than the target due to initiating a rebuild of the index.
Public class | SegmentTermDocs
Public class | SegmentTermEnum
Public class | SegmentTermPositions
Public class SerialMergeScheduler
A {@link MergeScheduler} that simply does each merge sequentially, using the current thread.
Public class SnapshotDeletionPolicy
A {@link IndexDeletionPolicy} that wraps around any other {@link IndexDeletionPolicy} and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the {@link IndexWriter} will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary {@link IndexDeletionPolicy}, this gives you the freedom to continue using whatever {@link IndexDeletionPolicy} you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened.

WARNING: This API is a new and experimental and may suddenly change.

Public class SortedTermVectorMapper
Store a sorted collection of {@link Lucene.Net.Index.TermVectorEntry}s. Collects all term information into a single, SortedSet.
NOTE: This Mapper ignores all Field information for the Document. This means that if you are using offset/positions you will not know what Fields they correlate with.
This is not thread-safe
Public class StaleReaderException
This exception is thrown when an {@link IndexReader} tries to make changes to the index (via {@link IndexReader#deleteDocument}, {@link IndexReader#undeleteAll} or {@link IndexReader#setNorm}) but changes have already been committed to the index since this reader was instantiated. When this happens you must open a new reader on the current index to make the changes.
Public class StringFieldEnumerator
Implementation for enumerating over terms with a string value.
Public class Term
A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.
Public class TermDocEnumerator
Class to handle creating a TermDocs and allowing for seeking and enumeration. Used when you have a set of one or moreterms for which you want to enumerate over the documents that contain those terms.
Public class TermDocEnumerator..::..TermDocUsingTermsEnumerator
Class to handle enumeration over the TermDocs that does NOT close them on a call to Dispose!
Public class TermEnum
Abstract class for enumerating terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Public class TermVectorEntry
Convenience class for holding TermVector information.
Public class TermVectorEntryFreqSortedComparator
Compares {@link Lucene.Net.Index.TermVectorEntry}s first by frequency and then by the term (case-sensitive)
Public class TermVectorEnumerator
Class to allow for enumerating over the documents in the index to retrieve the term vector for each one.
Public class TermVectorMapper
The TermVectorMapper can be used to map Term Vectors into your own structure instead of the parallel array structure used by {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}.

It is up to the implementation to make sure it is thread-safe.

Public class TermVectorOffsetInfo
The TermVectorOffsetInfo class holds information pertaining to a Term in a {@link Lucene.Net.Index.TermPositionVector}'s offset information. This offset information is the character offset as set during the Analysis phase (and thus may not be the actual offset in the original content).
Public class | TermVectorsReader

Interfaces

Interface | Description
Public interface | IndexCommitPoint | Obsolete.
Public interface IndexDeletionPolicy

Expert: policy for deletion of stale {@link IndexCommit index commits}.

Implement this interface, and pass it to one of the {@link IndexWriter} or {@link IndexReader} constructors, to customize when older {@link IndexCommit point-in-time commits} are deleted from the index directory. The default deletion policy is {@link KeepOnlyLastCommitDeletionPolicy}, which always removes old commits as soon as a new commit is done (this matches the behavior before 2.2).

One expected use case for this (and the reason why it was first created) is to work around problems with an index directory accessed via filesystems like NFS because NFS does not provide the "delete on last close" semantics that Lucene's "point in time" search normally relies on. By implementing a custom deletion policy, such as "a commit is only removed once it has been stale for more than X minutes", you can give your readers time to refresh to the new commit before {@link IndexWriter} removes the old commits. Note that doing so will increase the storage requirements of the index. See LUCENE-710 for details.

Public interface TermDocs
TermDocs provides an interface for enumerating <document, frequency> pairs for a term.

The document portion names each document containing the term. Documents are indicated by number. The frequency portion gives the number of times the term occurred in each document.

The pairs are ordered by document number.

Public interface TermFreqVector
Provides access to stored term vector of a document field. The vector consists of the name of the field, an array of the terms tha occur in the field of the {@link Lucene.Net.Documents.Document} and a parallel array of frequencies. Thus, getTermFrequencies()[5] corresponds with the frequency of getTerms()[5], assuming there are at least 5 terms in the Document.
Public interface TermPositions
TermPositions provides an interface for enumerating the <document, frequency, <position>* > tuples for a term.

The document and frequency are the same as for a TermDocs. The positions portion lists the ordinal positions of each occurrence of a term in a document.

Public interface TermPositionVector
Extends
CopyC#
TermFreqVector
 to provide additional information about positions in which each of the terms is found. A TermPositionVector not necessarily contains both positions and offsets, but at least one of these arrays exists.

Enumerations

 | Enumeration | Description
Public enumeration | FieldParser | The type of parser for the value of the term.


AbstractAllTermDocs Class

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs Class
Members See Also Send Feedback
Base class for enumerating all but deleted docs.

NOTE: this class is meant only to be used internally by Lucene; it's only public so it can be shared across packages. This means the API is freely subject to change, and, the class could be removed entirely, in any Lucene release. Use directly at your own risk! */

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class AbstractAllTermDocs : TermDocs
Visual Basic
Public MustInherit Class AbstractAllTermDocs _
    Implements TermDocs
Visual C++
public ref class AbstractAllTermDocs abstract : TermDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..AbstractAllTermDocs

See Also

AbstractAllTermDocs Members
Lucene.Net.Index Namespace


AbstractAllTermDocs Members

[image] [image]

Lucene.Net Class Libraries
AbstractAllTermDocs Members
AbstractAllTermDocs Class Constructors Methods Fields See Also Send Feedback

The AbstractAllTermDocs type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractAllTermDocs | Initializes a new instance of the AbstractAllTermDocs class

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDeleted |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | doc |
Protected field | maxDoc |

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


AbstractAllTermDocs Constructor

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs Constructor
AbstractAllTermDocs Class See Also Send Feedback
Initializes a new instance of the AbstractAllTermDocs class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected AbstractAllTermDocs(
    int maxDoc
)
Visual Basic
Protected Sub New ( _
    maxDoc As Integer _
)
Visual C++
protected:
AbstractAllTermDocs(
    int maxDoc
)

Parameters

maxDoc
Type: System..::..Int32

[Missing <param name="maxDoc"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.#ctor(System.Int32)"]

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


AbstractAllTermDocs Fields

[image] [image]

Lucene.Net Class Libraries
AbstractAllTermDocs Fields
AbstractAllTermDocs Class See Also Send Feedback

The AbstractAllTermDocs type exposes the following members.

Fields

 | Name | Description
Protected field | doc |
Protected field | maxDoc |

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


doc Field

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..doc Field
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.AbstractAllTermDocs.doc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected int doc
Visual Basic
Protected doc As Integer
Visual C++
protected:
int doc

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


maxDoc Field

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..maxDoc Field
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.AbstractAllTermDocs.maxDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected int maxDoc
Visual Basic
Protected maxDoc As Integer
Visual C++
protected:
int maxDoc

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


AbstractAllTermDocs Methods

[image] [image]

Lucene.Net Class Libraries
AbstractAllTermDocs Methods
AbstractAllTermDocs Class See Also Send Feedback

The AbstractAllTermDocs type exposes the following members.

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDeleted |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Close Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
virtual void Close() sealed

Implements

TermDocs..::..Close()()()()

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


Doc Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Doc Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Doc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Doc()
Visual Basic
Public Function Doc As Integer
Visual C++
public:
virtual int Doc() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Doc"]

Implements

TermDocs..::..Doc()()()()

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


Freq Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Freq Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Freq"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Freq()
Visual Basic
Public Function Freq As Integer
Visual C++
public:
virtual int Freq() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Freq"]

Implements

TermDocs..::..Freq()()()()

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..IsDeleted Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool IsDeleted(
    int doc
)
Visual Basic
Public MustOverride Function IsDeleted ( _
    doc As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int doc
) abstract

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.IsDeleted(System.Int32)"]

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Next Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Next"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool Next()
Visual Basic
Public Function Next As Boolean
Visual C++
public:
virtual bool Next() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Next"]

Implements

TermDocs..::..Next()()()()

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


Read Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Read Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Read(System.Int32[],System.Int32[])"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Read(
    int[] docs,
    int[] freqs
)
Visual Basic
Public Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Visual C++
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
) sealed

Parameters

docs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="docs"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Read(System.Int32[],System.Int32[])"]

freqs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="freqs"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Read(System.Int32[],System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Read(System.Int32[],System.Int32[])"]

Implements

TermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][])

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Seek Method
AbstractAllTermDocs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) |
Public method | Seek(TermEnum) |

See Also

AbstractAllTermDocs Class
AbstractAllTermDocs Members
Lucene.Net.Index Namespace


Seek Method (Term)

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Seek Method (Term)
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Seek(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Seek(
    Term term
)
Visual Basic
Public Sub Seek ( _
    term As Term _
)
Visual C++
public:
virtual void Seek(
    Term^ term
) sealed

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Seek(Lucene.Net.Index.Term)"]

Implements

TermDocs..::..Seek(Term)

See Also

AbstractAllTermDocs Class
Seek Overload
Lucene.Net.Index Namespace


Seek Method (TermEnum)

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..Seek Method (TermEnum)
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Seek(Lucene.Net.Index.TermEnum)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Seek(
    TermEnum termEnum
)
Visual Basic
Public Sub Seek ( _
    termEnum As TermEnum _
)
Visual C++
public:
virtual void Seek(
    TermEnum^ termEnum
) sealed

Parameters

termEnum
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="termEnum"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.Seek(Lucene.Net.Index.TermEnum)"]

Implements

TermDocs..::..Seek(TermEnum)

See Also

AbstractAllTermDocs Class
Seek Overload
Lucene.Net.Index Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
AbstractAllTermDocs..::..SkipTo Method
AbstractAllTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool SkipTo(
    int target
)
Visual Basic
Public Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
) sealed

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.AbstractAllTermDocs.SkipTo(System.Int32)"]

Implements

TermDocs..::..SkipTo(Int32)

See Also

AbstractAllTermDocs Class
Lucene.Net.Index Namespace


ByteBlockPool Class

[image]

Lucene.Net Class Libraries
ByteBlockPool Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.ByteBlockPool"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ByteBlockPool
Visual Basic
Public NotInheritable Class ByteBlockPool
Visual C++
public ref class ByteBlockPool sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..ByteBlockPool

See Also

ByteBlockPool Members
Lucene.Net.Index Namespace


ByteBlockPool Members

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool Members
ByteBlockPool Class Constructors Methods Fields Properties See Also Send Feedback

The ByteBlockPool type exposes the following members.

Constructors

 | Name | Description
Public method | ByteBlockPool | Initializes a new instance of the ByteBlockPool class

Methods

 | Name | Description
Public method | AllocSlice |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewSlice |
Public method | NextBuffer |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | buffer |
Public field | buffers |
Public field | byteOffset |
Public field | byteUpto |
 | FIRST_LEVEL_SIZE_For_NUnit_Test |

Properties

Name | Description
FIRST_LEVEL_SIZE_ForNUnit |

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


ByteBlockPool Constructor

[image]

Lucene.Net Class Libraries
ByteBlockPool Constructor
ByteBlockPool Class See Also Send Feedback
Initializes a new instance of the ByteBlockPool class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ByteBlockPool(
    ByteBlockPool..::..Allocator allocator,
    bool trackAllocations
)
Visual Basic
Public Sub New ( _
    allocator As ByteBlockPool..::..Allocator, _
    trackAllocations As Boolean _
)
Visual C++
public:
ByteBlockPool(
    ByteBlockPool..::..Allocator^ allocator,
    bool trackAllocations
)

Parameters

allocator
Type: Lucene.Net.Index..::..ByteBlockPool..::..Allocator

[Missing <param name="allocator"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.#ctor(Lucene.Net.Index.ByteBlockPool.Allocator,System.Boolean)"]

trackAllocations
Type: System..::..Boolean

[Missing <param name="trackAllocations"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.#ctor(Lucene.Net.Index.ByteBlockPool.Allocator,System.Boolean)"]

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


ByteBlockPool Fields

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool Fields
ByteBlockPool Class See Also Send Feedback

The ByteBlockPool type exposes the following members.

Fields

 | Name | Description
Public field | buffer |
Public field | buffers |
Public field | byteOffset |
Public field | byteUpto |
 | FIRST_LEVEL_SIZE_For_NUnit_Test |

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


buffer Field

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..buffer Field
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteBlockPool.buffer"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] buffer
Visual Basic
Public buffer As Byte()
Visual C++
public:
array<unsigned char>^ buffer

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


buffers Field

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..buffers Field
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteBlockPool.buffers"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[][] buffers
Visual Basic
Public buffers As Byte()()
Visual C++
public:
array<array<unsigned char>^>^ buffers

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


byteOffset Field

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..byteOffset Field
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteBlockPool.byteOffset"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int byteOffset
Visual Basic
Public byteOffset As Integer
Visual C++
public:
int byteOffset

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


byteUpto Field

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..byteUpto Field
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteBlockPool.byteUpto"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int byteUpto
Visual Basic
Public byteUpto As Integer
Visual C++
public:
int byteUpto

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


FIRST_LEVEL_SIZE_For_NUnit_Test Field

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..FIRST_LEVEL_SIZE_For_NUnit_Test Field
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteBlockPool.FIRST_LEVEL_SIZE_For_NUnit_Test"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int FIRST_LEVEL_SIZE_For_NUnit_Test
Visual Basic
Public Shared ReadOnly FIRST_LEVEL_SIZE_For_NUnit_Test As Integer
Visual C++
public:
static initonly int FIRST_LEVEL_SIZE_For_NUnit_Test

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


ByteBlockPool Methods

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool Methods
ByteBlockPool Class See Also Send Feedback

The ByteBlockPool type exposes the following members.

Methods

 | Name | Description
Public method | AllocSlice |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewSlice |
Public method | NextBuffer |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


AllocSlice Method

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..AllocSlice Method
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.AllocSlice(System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int AllocSlice(
    byte[] slice,
    int upto
)
Visual Basic
Public Function AllocSlice ( _
    slice As Byte(), _
    upto As Integer _
) As Integer
Visual C++
public:
int AllocSlice(
    array<unsigned char>^ slice,
    int upto
)

Parameters

slice
Type: array< System..::..Byte >[]()[][]

[Missing <param name="slice"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.AllocSlice(System.Byte[],System.Int32)"]

upto
Type: System..::..Int32

[Missing <param name="upto"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.AllocSlice(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteBlockPool.AllocSlice(System.Byte[],System.Int32)"]

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


NewSlice Method

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..NewSlice Method
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.NewSlice(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int NewSlice(
    int size
)
Visual Basic
Public Function NewSlice ( _
    size As Integer _
) As Integer
Visual C++
public:
int NewSlice(
    int size
)

Parameters

size
Type: System..::..Int32

[Missing <param name="size"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.NewSlice(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteBlockPool.NewSlice(System.Int32)"]

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


NextBuffer Method

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..NextBuffer Method
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.NextBuffer"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void NextBuffer()
Visual Basic
Public Sub NextBuffer
Visual C++
public:
void NextBuffer()

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


Reset Method

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..Reset Method
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.Reset"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


ByteBlockPool Properties

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool Properties
ByteBlockPool Class See Also Send Feedback

The ByteBlockPool type exposes the following members.

Properties

Name | Description
FIRST_LEVEL_SIZE_ForNUnit |

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


FIRST_LEVEL_SIZE_ForNUnit Property

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..FIRST_LEVEL_SIZE_ForNUnit Property
ByteBlockPool Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.ByteBlockPool.FIRST_LEVEL_SIZE_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int FIRST_LEVEL_SIZE_ForNUnit { get; }
Visual Basic
Public Shared ReadOnly Property FIRST_LEVEL_SIZE_ForNUnit As Integer
    Get
Visual C++
public:
static property int FIRST_LEVEL_SIZE_ForNUnit {
    int get ();
}

See Also

ByteBlockPool Class
Lucene.Net.Index Namespace


ByteBlockPool.Allocator Class

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator Class
ByteBlockPool Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.ByteBlockPool.Allocator"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Allocator
Visual Basic
Public MustInherit Class Allocator
Visual C++
public ref class Allocator abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..ByteBlockPool..::..Allocator

See Also

ByteBlockPool..::..Allocator Members
Lucene.Net.Index Namespace


ByteBlockPool.Allocator Members

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator Members
ByteBlockPool..::..Allocator Class Constructors Methods See Also Send Feedback

The ByteBlockPool..::..Allocator type exposes the following members.

Constructors

 | Name | Description
Protected method | ByteBlockPool..::..Allocator | Initializes a new instance of the ByteBlockPool..::..Allocator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByteBlock |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RecycleByteBlocks(ArrayList) |
Public method | RecycleByteBlocks(array<array<Byte>[]()[][]>[]()[][], Int32, Int32) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ByteBlockPool..::..Allocator Class
Lucene.Net.Index Namespace


ByteBlockPool.Allocator Constructor

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator Constructor
ByteBlockPool..::..Allocator Class See Also Send Feedback
Initializes a new instance of the ByteBlockPool..::..Allocator class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Allocator()
Visual Basic
Protected Sub New
Visual C++
protected:
Allocator()

See Also

ByteBlockPool..::..Allocator Class
Lucene.Net.Index Namespace


ByteBlockPool.Allocator Methods

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator Methods
ByteBlockPool..::..Allocator Class See Also Send Feedback

The ByteBlockPool..::..Allocator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByteBlock |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RecycleByteBlocks(ArrayList) |
Public method | RecycleByteBlocks(array<array<Byte>[]()[][]>[]()[][], Int32, Int32) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ByteBlockPool..::..Allocator Class
Lucene.Net.Index Namespace


GetByteBlock Method

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator..::..GetByteBlock Method
ByteBlockPool..::..Allocator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.GetByteBlock(System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract byte[] GetByteBlock(
    bool trackAllocations
)
Visual Basic
Public MustOverride Function GetByteBlock ( _
    trackAllocations As Boolean _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetByteBlock(
    bool trackAllocations
) abstract

Parameters

trackAllocations
Type: System..::..Boolean

[Missing <param name="trackAllocations"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.GetByteBlock(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.GetByteBlock(System.Boolean)"]

See Also

ByteBlockPool..::..Allocator Class
Lucene.Net.Index Namespace


RecycleByteBlocks Method

[image] [image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator..::..RecycleByteBlocks Method
ByteBlockPool..::..Allocator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecycleByteBlocks(ArrayList) |
Public method | RecycleByteBlocks(array<array<Byte>[]()[][]>[]()[][], Int32, Int32) |

See Also

ByteBlockPool..::..Allocator Class
ByteBlockPool..::..Allocator Members
Lucene.Net.Index Namespace


RecycleByteBlocks Method (ArrayList)

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator..::..RecycleByteBlocks Method (ArrayList)
ByteBlockPool..::..Allocator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.RecycleByteBlocks(System.Collections.ArrayList)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void RecycleByteBlocks(
    ArrayList blocks
)
Visual Basic
Public MustOverride Sub RecycleByteBlocks ( _
    blocks As ArrayList _
)
Visual C++
public:
virtual void RecycleByteBlocks(
    ArrayList^ blocks
) abstract

Parameters

blocks
Type: System.Collections..::..ArrayList

[Missing <param name="blocks"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.RecycleByteBlocks(System.Collections.ArrayList)"]

See Also

ByteBlockPool..::..Allocator Class
RecycleByteBlocks Overload
Lucene.Net.Index Namespace


RecycleByteBlocks Method (Byte[][], Int32, Int32)

[image]

Lucene.Net Class Libraries
ByteBlockPool..::..Allocator..::..RecycleByteBlocks Method (array<array<Byte>[]()[][]>[]()[][], Int32, Int32)
ByteBlockPool..::..Allocator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.RecycleByteBlocks(System.Byte[][],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void RecycleByteBlocks(
    byte[][] blocks,
    int start,
    int end
)
Visual Basic
Public MustOverride Sub RecycleByteBlocks ( _
    blocks As Byte()(), _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
virtual void RecycleByteBlocks(
    array<array<unsigned char>^>^ blocks,
    int start,
    int end
) abstract

Parameters

blocks
Type: array<array< System..::..Byte >[]()[][]>[]()[][]

[Missing <param name="blocks"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.RecycleByteBlocks(System.Byte[][],System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.RecycleByteBlocks(System.Byte[][],System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Index.ByteBlockPool.Allocator.RecycleByteBlocks(System.Byte[][],System.Int32,System.Int32)"]

See Also

ByteBlockPool..::..Allocator Class
RecycleByteBlocks Overload
Lucene.Net.Index Namespace


ByteSliceReader Class

[image]

Lucene.Net Class Libraries
ByteSliceReader Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.ByteSliceReader"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ByteSliceReader : IndexInput
Visual Basic
Public NotInheritable Class ByteSliceReader _
    Inherits IndexInput
Visual C++
public ref class ByteSliceReader sealed : public IndexInput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Index..::..ByteSliceReader

See Also

ByteSliceReader Members
Lucene.Net.Index Namespace


ByteSliceReader Members

[image] [image]

Lucene.Net Class Libraries
ByteSliceReader Members
ByteSliceReader Class Constructors Methods Fields See Also Send Feedback

The ByteSliceReader type exposes the following members.

Constructors

 | Name | Description
Public method | ByteSliceReader | Initializes a new instance of the ByteSliceReader class

Methods

 | Name | Description
Public method | Clone | (Overrides IndexInput..::..Clone()()()().)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Eof |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSlice |
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteTo |

Fields

 | Name | Description
Public field | bufferOffset |
Public field | endIndex |
Public field | upto |

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


ByteSliceReader Constructor

[image]

Lucene.Net Class Libraries
ByteSliceReader Constructor
ByteSliceReader Class See Also Send Feedback
Initializes a new instance of the ByteSliceReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ByteSliceReader()
Visual Basic
Public Sub New
Visual C++
public:
ByteSliceReader()

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


ByteSliceReader Fields

[image] [image]

Lucene.Net Class Libraries
ByteSliceReader Fields
ByteSliceReader Class See Also Send Feedback

The ByteSliceReader type exposes the following members.

Fields

 | Name | Description
Public field | bufferOffset |
Public field | endIndex |
Public field | upto |

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


bufferOffset Field

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..bufferOffset Field
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteSliceReader.bufferOffset"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int bufferOffset
Visual Basic
Public bufferOffset As Integer
Visual C++
public:
int bufferOffset

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


endIndex Field

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..endIndex Field
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteSliceReader.endIndex"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int endIndex
Visual Basic
Public endIndex As Integer
Visual C++
public:
int endIndex

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


upto Field

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..upto Field
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ByteSliceReader.upto"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int upto
Visual Basic
Public upto As Integer
Visual C++
public:
int upto

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


ByteSliceReader Methods

[image] [image]

Lucene.Net Class Libraries
ByteSliceReader Methods
ByteSliceReader Class See Also Send Feedback

The ByteSliceReader type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides IndexInput..::..Clone()()()().)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Eof |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSlice |
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteTo |

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..Clone Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceReader.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..Close Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


Eof Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..Eof Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.Eof"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool Eof()
Visual Basic
Public Function Eof As Boolean
Visual C++
public:
bool Eof()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceReader.Eof"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..GetFilePointer Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.GetFilePointer"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceReader.GetFilePointer"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


Init Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..Init Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.Init(Lucene.Net.Index.ByteBlockPool,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Init(
    ByteBlockPool pool,
    int startIndex,
    int endIndex
)
Visual Basic
Public Sub Init ( _
    pool As ByteBlockPool, _
    startIndex As Integer, _
    endIndex As Integer _
)
Visual C++
public:
void Init(
    ByteBlockPool^ pool,
    int startIndex,
    int endIndex
)

Parameters

pool
Type: Lucene.Net.Index..::..ByteBlockPool

[Missing <param name="pool"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.Init(Lucene.Net.Index.ByteBlockPool,System.Int32,System.Int32)"]

startIndex
Type: System..::..Int32

[Missing <param name="startIndex"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.Init(Lucene.Net.Index.ByteBlockPool,System.Int32,System.Int32)"]

endIndex
Type: System..::..Int32

[Missing <param name="endIndex"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.Init(Lucene.Net.Index.ByteBlockPool,System.Int32,System.Int32)"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


Length Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..Length Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.Length"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceReader.Length"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


NextSlice Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..NextSlice Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.NextSlice"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void NextSlice()
Visual Basic
Public Sub NextSlice
Visual C++
public:
void NextSlice()

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


ReadByte Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..ReadByte Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.ReadByte"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte ReadByte()
Visual Basic
Public Overrides Function ReadByte As Byte
Visual C++
public:
virtual unsigned char ReadByte() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceReader.ReadByte"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
ByteSliceReader..::..ReadBytes Method
ByteSliceReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)

See Also

ByteSliceReader Class
ByteSliceReader Members
Lucene.Net.Index Namespace


ReadBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32)
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

ByteSliceReader Class
ReadBytes Overload
Lucene.Net.Index Namespace


Seek Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..Seek Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.Seek(System.Int64)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.Seek(System.Int64)"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


WriteTo Method

[image]

Lucene.Net Class Libraries
ByteSliceReader..::..WriteTo Method
ByteSliceReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceReader.WriteTo(Lucene.Net.Store.IndexOutput)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long WriteTo(
    IndexOutput out_Renamed
)
Visual Basic
Public Function WriteTo ( _
    out_Renamed As IndexOutput _
) As Long
Visual C++
public:
long long WriteTo(
    IndexOutput^ out_Renamed
)

Parameters

out_Renamed
Type: Lucene.Net.Store..::..IndexOutput

[Missing <param name="out_Renamed"/> documentation for "M:Lucene.Net.Index.ByteSliceReader.WriteTo(Lucene.Net.Store.IndexOutput)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceReader.WriteTo(Lucene.Net.Store.IndexOutput)"]

See Also

ByteSliceReader Class
Lucene.Net.Index Namespace


ByteSliceWriter Class

[image]

Lucene.Net Class Libraries
ByteSliceWriter Class
Members See Also Send Feedback
Class to write byte streams into slices of shared byte[]. This is used by DocumentsWriter to hold the posting list for many terms in RAM.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ByteSliceWriter
Visual Basic
Public NotInheritable Class ByteSliceWriter
Visual C++
public ref class ByteSliceWriter sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..ByteSliceWriter

See Also

ByteSliceWriter Members
Lucene.Net.Index Namespace


ByteSliceWriter Members

[image] [image]

Lucene.Net Class Libraries
ByteSliceWriter Members
ByteSliceWriter Class Constructors Methods See Also Send Feedback

The ByteSliceWriter type exposes the following members.

Constructors

 | Name | Description
Public method | ByteSliceWriter | Initializes a new instance of the ByteSliceWriter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddress |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Set up the writer to write at address.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Write byte into byte slice stream
Public method | WriteBytes |
Public method | WriteVInt |

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


ByteSliceWriter Constructor

[image]

Lucene.Net Class Libraries
ByteSliceWriter Constructor
ByteSliceWriter Class See Also Send Feedback
Initializes a new instance of the ByteSliceWriter class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ByteSliceWriter(
    ByteBlockPool pool
)
Visual Basic
Public Sub New ( _
    pool As ByteBlockPool _
)
Visual C++
public:
ByteSliceWriter(
    ByteBlockPool^ pool
)

Parameters

pool
Type: Lucene.Net.Index..::..ByteBlockPool

[Missing <param name="pool"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.#ctor(Lucene.Net.Index.ByteBlockPool)"]

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


ByteSliceWriter Methods

[image] [image]

Lucene.Net Class Libraries
ByteSliceWriter Methods
ByteSliceWriter Class See Also Send Feedback

The ByteSliceWriter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddress |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Set up the writer to write at address.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Write byte into byte slice stream
Public method | WriteBytes |
Public method | WriteVInt |

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


GetAddress Method

[image]

Lucene.Net Class Libraries
ByteSliceWriter..::..GetAddress Method
ByteSliceWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceWriter.GetAddress"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetAddress()
Visual Basic
Public Function GetAddress As Integer
Visual C++
public:
int GetAddress()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ByteSliceWriter.GetAddress"]

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


Init Method

[image]

Lucene.Net Class Libraries
ByteSliceWriter..::..Init Method
ByteSliceWriter Class See Also Send Feedback
Set up the writer to write at address.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Init(
    int address
)
Visual Basic
Public Sub Init ( _
    address As Integer _
)
Visual C++
public:
void Init(
    int address
)

Parameters

address
Type: System..::..Int32

[Missing <param name="address"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.Init(System.Int32)"]

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


WriteByte Method

[image]

Lucene.Net Class Libraries
ByteSliceWriter..::..WriteByte Method
ByteSliceWriter Class See Also Send Feedback
Write byte into byte slice stream

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void WriteByte(
    byte b
)
Visual Basic
Public Sub WriteByte ( _
    b As Byte _
)
Visual C++
public:
void WriteByte(
    unsigned char b
)

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteByte(System.Byte)"]

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


WriteBytes Method

[image]

Lucene.Net Class Libraries
ByteSliceWriter..::..WriteBytes Method
ByteSliceWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void WriteBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int len
)

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


WriteVInt Method

[image]

Lucene.Net Class Libraries
ByteSliceWriter..::..WriteVInt Method
ByteSliceWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteVInt(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void WriteVInt(
    int i
)
Visual Basic
Public Sub WriteVInt ( _
    i As Integer _
)
Visual C++
public:
void WriteVInt(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Index.ByteSliceWriter.WriteVInt(System.Int32)"]

See Also

ByteSliceWriter Class
Lucene.Net.Index Namespace


CheckIndex Class

[image]

Lucene.Net Class Libraries
CheckIndex Class
Members See Also Send Feedback
Basic tool and API to check the health of an index and write a new segments file that removes reference to problematic segments.

As this tool checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: this tool and API is new and experimental and is subject to suddenly change in the next release. Please make a complete backup of your index before using this to fix your index!

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CheckIndex
Visual Basic
Public Class CheckIndex
Visual C++
public ref class CheckIndex

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex

See Also

CheckIndex Members
Lucene.Net.Index Namespace


CheckIndex Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex Members
CheckIndex Class Constructors Methods Fields See Also Send Feedback

The CheckIndex type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex | Create a new CheckIndex on the directory.

Methods

Name Description
Check(Directory, Boolean) Obsolete.
Returns true if index is clean, else false.
Check(Directory, Boolean, IList) Obsolete.
Returns true if index is clean, else false.
Public method CheckIndex_Renamed_Method()()()()
Returns a {@link Status} instance detailing the state of the index.

As this method checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.

Public method CheckIndex_Renamed_Method(IList)
Returns a {@link Status} instance detailing the state of the index.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FixIndex
Repairs the index using previously returned result from {@link #checkIndex}. Note that this does not remove any of the unreferenced files after it's done; you must separately open an {@link IndexWriter}, which deletes unreferenced files when it's created.

WARNING: this writes a new segments file into the index, effectively removing all documents in broken segments from the index. BE CAREFUL.

WARNING: Make sure you only call this when the index is not opened by any writer.

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Main
Command-line interface to check and fix an index.

Run it like this:

            java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
  • CopyC#
    -fix
    : actually write a new segments_N file, removing any problematic segments
  • CopyC#
    -segment X
    : only check the specified segment(s). This can be specified multiple times, to check more than one segment, eg
    CopyC#
    -segment _2
            -segment _a
    . You can't use this with the -fix option.

WARNING:

CopyC#
-fix
should only be used on an emergency basis as it will cause documents (perhaps many) to be permanently removed from the index. Always make a backup copy of your index before running this! Do not run this tool on an index that is actively being written to. You have been warned!

Run without -fix, this tool will open the index, report version information and report any exceptions it hits and what action it would take if -fix were specified. With -fix, this tool will remove any segments that have issues and write a new segments_N file. This means all documents contained in the affected segments will be removed.

This tool exits with exit code 1 if the index cannot be opened or has any corruption, else 0.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetInfoStream
Set infoStream where messages should go. If null, no messages are printed
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name | Description
out_Renamed | Obsolete. Default PrintStream for all CheckIndex instances.

See Also

CheckIndex Class
Lucene.Net.Index Namespace


CheckIndex Constructor

[image]

Lucene.Net Class Libraries
CheckIndex Constructor
CheckIndex Class See Also Send Feedback
Create a new CheckIndex on the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CheckIndex(
    Directory dir
)
Visual Basic
Public Sub New ( _
    dir As Directory _
)
Visual C++
public:
CheckIndex(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.CheckIndex.#ctor(Lucene.Net.Store.Directory)"]

See Also

CheckIndex Class
Lucene.Net.Index Namespace


CheckIndex Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex Fields
CheckIndex Class See Also Send Feedback

The CheckIndex type exposes the following members.

Fields

Name | Description
out_Renamed | Obsolete. Default PrintStream for all CheckIndex instances.

See Also

CheckIndex Class
Lucene.Net.Index Namespace


out_Renamed Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..out_Renamed Field
CheckIndex Class See Also Send Feedback
Default PrintStream for all CheckIndex instances.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use SetInfoStream per instance,instead.")]
public static StreamWriter out_Renamed
Visual Basic
<ObsoleteAttribute("Use SetInfoStream per instance,instead.")> _
Public Shared out_Renamed As StreamWriter
Visual C++
[ObsoleteAttribute(L"Use SetInfoStream per instance,instead.")]
public:
static StreamWriter^ out_Renamed

See Also

CheckIndex Class
Lucene.Net.Index Namespace


CheckIndex Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex Methods
CheckIndex Class See Also Send Feedback

The CheckIndex type exposes the following members.

Methods

Name Description
Check(Directory, Boolean) Obsolete.
Returns true if index is clean, else false.
Check(Directory, Boolean, IList) Obsolete.
Returns true if index is clean, else false.
Public method CheckIndex_Renamed_Method()()()()
Returns a {@link Status} instance detailing the state of the index.

As this method checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.

Public method CheckIndex_Renamed_Method(IList)
Returns a {@link Status} instance detailing the state of the index.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FixIndex
Repairs the index using previously returned result from {@link #checkIndex}. Note that this does not remove any of the unreferenced files after it's done; you must separately open an {@link IndexWriter}, which deletes unreferenced files when it's created.

WARNING: this writes a new segments file into the index, effectively removing all documents in broken segments from the index. BE CAREFUL.

WARNING: Make sure you only call this when the index is not opened by any writer.

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Main
Command-line interface to check and fix an index.

Run it like this:

            java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
  • CopyC#
    -fix
    : actually write a new segments_N file, removing any problematic segments
  • CopyC#
    -segment X
    : only check the specified segment(s). This can be specified multiple times, to check more than one segment, eg
    CopyC#
    -segment _2
            -segment _a
    . You can't use this with the -fix option.

WARNING:

CopyC#
-fix
should only be used on an emergency basis as it will cause documents (perhaps many) to be permanently removed from the index. Always make a backup copy of your index before running this! Do not run this tool on an index that is actively being written to. You have been warned!

Run without -fix, this tool will open the index, report version information and report any exceptions it hits and what action it would take if -fix were specified. With -fix, this tool will remove any segments that have issues and write a new segments_N file. This means all documents contained in the affected segments will be removed.

This tool exits with exit code 1 if the index cannot be opened or has any corruption, else 0.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetInfoStream
Set infoStream where messages should go. If null, no messages are printed
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

CheckIndex Class
Lucene.Net.Index Namespace


Check Method

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Check Method
CheckIndex Class See Also Send Feedback

Overload List

Name | Description
Check(Directory, Boolean) | Obsolete. Returns true if index is clean, else false.
Check(Directory, Boolean, IList) | Obsolete. Returns true if index is clean, else false.

See Also

CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace


Check Method (Directory, Boolean)

[image]

Lucene.Net Class Libraries
CheckIndex..::..Check Method (Directory, Boolean)
CheckIndex Class See Also Send Feedback
Returns true if index is clean, else false.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please instantiate a CheckIndex and then use CheckIndex() instead")]
public static bool Check(
    Directory dir,
    bool doFix
)
Visual Basic
<ObsoleteAttribute("Please instantiate a CheckIndex and then use CheckIndex() instead")> _
Public Shared Function Check ( _
    dir As Directory, _
    doFix As Boolean _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Please instantiate a CheckIndex and then use CheckIndex() instead")]
public:
static bool Check(
    Directory^ dir,
    bool doFix
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean)"]

doFix
Type: System..::..Boolean

[Missing <param name="doFix"/> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean)"]

See Also

CheckIndex Class
Check Overload
Lucene.Net.Index Namespace


Check Method (Directory, Boolean, IList)

[image]

Lucene.Net Class Libraries
CheckIndex..::..Check Method (Directory, Boolean, IList)
CheckIndex Class See Also Send Feedback
Returns true if index is clean, else false.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please instantiate a CheckIndex and then use CheckIndex(List) instead")]
public static bool Check(
    Directory dir,
    bool doFix,
    IList onlySegments
)
Visual Basic
<ObsoleteAttribute("Please instantiate a CheckIndex and then use CheckIndex(List) instead")> _
Public Shared Function Check ( _
    dir As Directory, _
    doFix As Boolean, _
    onlySegments As IList _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Please instantiate a CheckIndex and then use CheckIndex(List) instead")]
public:
static bool Check(
    Directory^ dir,
    bool doFix,
    IList^ onlySegments
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean,System.Collections.IList)"]

doFix
Type: System..::..Boolean

[Missing <param name="doFix"/> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean,System.Collections.IList)"]

onlySegments
Type: System.Collections..::..IList

[Missing <param name="onlySegments"/> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean,System.Collections.IList)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CheckIndex.Check(Lucene.Net.Store.Directory,System.Boolean,System.Collections.IList)"]

See Also

CheckIndex Class
Check Overload
Lucene.Net.Index Namespace


CheckIndex_Renamed_Method Method

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..CheckIndex_Renamed_Method Method
CheckIndex Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckIndex_Renamed_Method()()()() | Returns a {@link Status} instance detailing the state of the index. As this method checks every byte in the index, on a large index it can take quite a long time to run. WARNING: make sure you only call this when the index is not opened by any writer.
Public method | CheckIndex_Renamed_Method(IList) | Returns a {@link Status} instance detailing the state of the index.

See Also

CheckIndex Class
CheckIndex Members
Lucene.Net.Index Namespace


CheckIndex_Renamed_Method Method

[image]

Lucene.Net Class Libraries
CheckIndex..::..CheckIndex_Renamed_Method Method
CheckIndex Class See Also Send Feedback
Returns a {@link Status} instance detailing the state of the index.

As this method checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CheckIndex..::..Status CheckIndex_Renamed_Method()
Visual Basic
Public Overridable Function CheckIndex_Renamed_Method As CheckIndex..::..Status
Visual C++
public:
virtual CheckIndex..::..Status^ CheckIndex_Renamed_Method()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CheckIndex.CheckIndex_Renamed_Method"]

See Also

CheckIndex Class
CheckIndex_Renamed_Method Overload
Lucene.Net.Index Namespace


CheckIndex_Renamed_Method Method (IList)

[image]

Lucene.Net Class Libraries
CheckIndex..::..CheckIndex_Renamed_Method Method (IList)
CheckIndex Class See Also Send Feedback
Returns a {@link Status} instance detailing the state of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CheckIndex..::..Status CheckIndex_Renamed_Method(
    IList onlySegments
)
Visual Basic
Public Overridable Function CheckIndex_Renamed_Method ( _
    onlySegments As IList _
) As CheckIndex..::..Status
Visual C++
public:
virtual CheckIndex..::..Status^ CheckIndex_Renamed_Method(
    IList^ onlySegments
)

Parameters

onlySegments
Type: System.Collections..::..IList
list of specific segment names to check

As this method checks every byte in the specified segments, on a large index it can take quite a long time to run.

WARNING: make sure you only call this when the index is not opened by any writer.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CheckIndex.CheckIndex_Renamed_Method(System.Collections.IList)"]

See Also

CheckIndex Class
CheckIndex_Renamed_Method Overload
Lucene.Net.Index Namespace


FixIndex Method

[image]

Lucene.Net Class Libraries
CheckIndex..::..FixIndex Method
CheckIndex Class See Also Send Feedback
Repairs the index using previously returned result from {@link #checkIndex}. Note that this does not remove any of the unreferenced files after it's done; you must separately open an {@link IndexWriter}, which deletes unreferenced files when it's created.

WARNING: this writes a new segments file into the index, effectively removing all documents in broken segments from the index. BE CAREFUL.

WARNING: Make sure you only call this when the index is not opened by any writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FixIndex(
    CheckIndex..::..Status result
)
Visual Basic
Public Overridable Sub FixIndex ( _
    result As CheckIndex..::..Status _
)
Visual C++
public:
virtual void FixIndex(
    CheckIndex..::..Status^ result
)

Parameters

result
Type: Lucene.Net.Index..::..CheckIndex..::..Status

[Missing <param name="result"/> documentation for "M:Lucene.Net.Index.CheckIndex.FixIndex(Lucene.Net.Index.CheckIndex.Status)"]

See Also

CheckIndex Class
Lucene.Net.Index Namespace


Main Method

[image]

Lucene.Net Class Libraries
CheckIndex..::..Main Method
CheckIndex Class See Also Send Feedback
Command-line interface to check and fix an index.

Run it like this:

            java -ea:Lucene.Net... Lucene.Net.Index.CheckIndex pathToIndex [-fix] [-segment X] [-segment Y]
  • CopyC#
    -fix
    : actually write a new segments_N file, removing any problematic segments
  • CopyC#
    -segment X
    : only check the specified segment(s). This can be specified multiple times, to check more than one segment, eg
    CopyC#
    -segment _2
            -segment _a
    . You can't use this with the -fix option.

WARNING:

CopyC#
-fix
should only be used on an emergency basis as it will cause documents (perhaps many) to be permanently removed from the index. Always make a backup copy of your index before running this! Do not run this tool on an index that is actively being written to. You have been warned!

Run without -fix, this tool will open the index, report version information and report any exceptions it hits and what action it would take if -fix were specified. With -fix, this tool will remove any segments that have issues and write a new segments_N file. This means all documents contained in the affected segments will be removed.

This tool exits with exit code 1 if the index cannot be opened or has any corruption, else 0.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Index.CheckIndex.Main(System.String[])"]

See Also

CheckIndex Class
Lucene.Net.Index Namespace


SetInfoStream Method

[image]

Lucene.Net Class Libraries
CheckIndex..::..SetInfoStream Method
CheckIndex Class See Also Send Feedback
Set infoStream where messages should go. If null, no messages are printed

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetInfoStream(
    StreamWriter out_Renamed
)
Visual Basic
Public Overridable Sub SetInfoStream ( _
    out_Renamed As StreamWriter _
)
Visual C++
public:
virtual void SetInfoStream(
    StreamWriter^ out_Renamed
)

Parameters

out_Renamed
Type: System.IO..::..StreamWriter

[Missing <param name="out_Renamed"/> documentation for "M:Lucene.Net.Index.CheckIndex.SetInfoStream(System.IO.StreamWriter)"]

See Also

CheckIndex Class
Lucene.Net.Index Namespace


CheckIndex.Status Class

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status Class
CheckIndex Class Members See Also Send Feedback
Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class Status
Visual Basic
Public Class Status
Visual C++
public ref class Status

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex..::..Status

See Also

CheckIndex..::..Status Members
Lucene.Net.Index Namespace


CheckIndex.Status Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status Members
CheckIndex..::..Status Class Constructors Methods Fields See Also Send Feedback

Basic tool and API to check the health of an index and write a new segments file that removes reference to problematic segments.

As this tool checks every byte in the index, on a large index it can take quite a long time to run.

WARNING: this tool and API is new and experimental and is subject to suddenly change in the next release. Please make a complete backup of your index before using this to fix your index!

The CheckIndex..::..Status type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex..::..Status | Initializes a new instance of the CheckIndex..::..Status class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | cantOpenSegments | True if we were unable to open the segments_N file.
Public field | clean | True if no problems were found with the index.
Public field | dir | Directory index is in.
Public field | missingSegments | True if we were unable to locate and load the segments_N file.
Public field | missingSegmentVersion | True if we were unable to read the version number from segments_N file.
Public field | numBadSegments | How many bad segments were found.
Public field | numSegments | Number of segments in the index.
Public field | partial | True if we checked only specific segments ({@link #CheckIndex(List)}) was called with non-null argument).
Public field | segmentFormat | String description of the version of the index.
Public field | segmentInfos | List of {@link SegmentInfoStatus} instances, detailing status of each segment.
Public field | segmentsChecked | Empty unless you passed specific segments list to check as optional 3rd argument.
Public field | segmentsFileName | Name of latest segments_N file in the index.
Public field | toolOutOfDate | True if the index was created with a newer version of Lucene than the CheckIndex tool.
Public field | totLoseDocCount | How many documents will be lost to bad segments.
Public field | userData | Holds the userData of the last commit in the index

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


CheckIndex.Status Constructor

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status Constructor
CheckIndex..::..Status Class See Also Send Feedback
Initializes a new instance of the CheckIndex..::..Status class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Status()
Visual Basic
Public Sub New
Visual C++
public:
Status()

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


CheckIndex.Status Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status Fields
CheckIndex..::..Status Class See Also Send Feedback

The CheckIndex..::..Status type exposes the following members.

Fields

 | Name | Description
Public field | cantOpenSegments | True if we were unable to open the segments_N file.
Public field | clean | True if no problems were found with the index.
Public field | dir | Directory index is in.
Public field | missingSegments | True if we were unable to locate and load the segments_N file.
Public field | missingSegmentVersion | True if we were unable to read the version number from segments_N file.
Public field | numBadSegments | How many bad segments were found.
Public field | numSegments | Number of segments in the index.
Public field | partial | True if we checked only specific segments ({@link #CheckIndex(List)}) was called with non-null argument).
Public field | segmentFormat | String description of the version of the index.
Public field | segmentInfos | List of {@link SegmentInfoStatus} instances, detailing status of each segment.
Public field | segmentsChecked | Empty unless you passed specific segments list to check as optional 3rd argument.
Public field | segmentsFileName | Name of latest segments_N file in the index.
Public field | toolOutOfDate | True if the index was created with a newer version of Lucene than the CheckIndex tool.
Public field | totLoseDocCount | How many documents will be lost to bad segments.
Public field | userData | Holds the userData of the last commit in the index

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


cantOpenSegments Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..cantOpenSegments Field
CheckIndex..::..Status Class See Also Send Feedback
True if we were unable to open the segments_N file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool cantOpenSegments
Visual Basic
Public cantOpenSegments As Boolean
Visual C++
public:
bool cantOpenSegments

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


clean Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..clean Field
CheckIndex..::..Status Class See Also Send Feedback
True if no problems were found with the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool clean
Visual Basic
Public clean As Boolean
Visual C++
public:
bool clean

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


dir Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..dir Field
CheckIndex..::..Status Class See Also Send Feedback
Directory index is in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Directory dir
Visual Basic
Public dir As Directory
Visual C++
public:
Directory^ dir

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


missingSegments Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..missingSegments Field
CheckIndex..::..Status Class See Also Send Feedback
True if we were unable to locate and load the segments_N file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool missingSegments
Visual Basic
Public missingSegments As Boolean
Visual C++
public:
bool missingSegments

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


missingSegmentVersion Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..missingSegmentVersion Field
CheckIndex..::..Status Class See Also Send Feedback
True if we were unable to read the version number from segments_N file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool missingSegmentVersion
Visual Basic
Public missingSegmentVersion As Boolean
Visual C++
public:
bool missingSegmentVersion

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


numBadSegments Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..numBadSegments Field
CheckIndex..::..Status Class See Also Send Feedback
How many bad segments were found.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int numBadSegments
Visual Basic
Public numBadSegments As Integer
Visual C++
public:
int numBadSegments

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


numSegments Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..numSegments Field
CheckIndex..::..Status Class See Also Send Feedback
Number of segments in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int numSegments
Visual Basic
Public numSegments As Integer
Visual C++
public:
int numSegments

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


partial Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..partial Field
CheckIndex..::..Status Class See Also Send Feedback
True if we checked only specific segments ({@link #CheckIndex(List)}) was called with non-null argument).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool partial
Visual Basic
Public partial As Boolean
Visual C++
public:
bool partial

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


segmentFormat Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..segmentFormat Field
CheckIndex..::..Status Class See Also Send Feedback
String description of the version of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string segmentFormat
Visual Basic
Public segmentFormat As String
Visual C++
public:
String^ segmentFormat

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


segmentInfos Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..segmentInfos Field
CheckIndex..::..Status Class See Also Send Feedback
List of {@link SegmentInfoStatus} instances, detailing status of each segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IList segmentInfos
Visual Basic
Public segmentInfos As IList
Visual C++
public:
IList^ segmentInfos

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


segmentsChecked Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..segmentsChecked Field
CheckIndex..::..Status Class See Also Send Feedback
Empty unless you passed specific segments list to check as optional 3rd argument.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IList segmentsChecked
Visual Basic
Public segmentsChecked As IList
Visual C++
public:
IList^ segmentsChecked

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace
[!:CheckIndex.CheckIndex(List)]


segmentsFileName Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..segmentsFileName Field
CheckIndex..::..Status Class See Also Send Feedback
Name of latest segments_N file in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string segmentsFileName
Visual Basic
Public segmentsFileName As String
Visual C++
public:
String^ segmentsFileName

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


toolOutOfDate Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..toolOutOfDate Field
CheckIndex..::..Status Class See Also Send Feedback
True if the index was created with a newer version of Lucene than the CheckIndex tool.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool toolOutOfDate
Visual Basic
Public toolOutOfDate As Boolean
Visual C++
public:
bool toolOutOfDate

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


totLoseDocCount Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..totLoseDocCount Field
CheckIndex..::..Status Class See Also Send Feedback
How many documents will be lost to bad segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int totLoseDocCount
Visual Basic
Public totLoseDocCount As Integer
Visual C++
public:
int totLoseDocCount

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


userData Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..userData Field
CheckIndex..::..Status Class See Also Send Feedback
Holds the userData of the last commit in the index

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IDictionary<string, string> userData
Visual Basic
Public userData As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ userData

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


CheckIndex.Status Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status Methods
CheckIndex..::..Status Class See Also Send Feedback

The CheckIndex..::..Status type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIndex..::..Status Class
Lucene.Net.Index Namespace


CheckIndex.Status.FieldNormStatus Class

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus Class
CheckIndex..::..Status Class Members See Also Send Feedback
Status from testing field norms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldNormStatus
Visual Basic
Public NotInheritable Class FieldNormStatus
Visual C++
public ref class FieldNormStatus sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex..::..Status..::..FieldNormStatus

See Also

CheckIndex..::..Status..::..FieldNormStatus Members
Lucene.Net.Index Namespace


CheckIndex.Status.FieldNormStatus Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus Members
CheckIndex..::..Status..::..FieldNormStatus Class Constructors Methods Fields See Also Send Feedback

Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex..::..Status..::..FieldNormStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex..::..Status..::..FieldNormStatus | Initializes a new instance of the CheckIndex..::..Status..::..FieldNormStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | totFields | Number of fields successfully tested

See Also

CheckIndex..::..Status..::..FieldNormStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.FieldNormStatus Constructor

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus Constructor
CheckIndex..::..Status..::..FieldNormStatus Class See Also Send Feedback
Initializes a new instance of the CheckIndex..::..Status..::..FieldNormStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldNormStatus()
Visual Basic
Public Sub New
Visual C++
public:
FieldNormStatus()

See Also

CheckIndex..::..Status..::..FieldNormStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.FieldNormStatus Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus Fields
CheckIndex..::..Status..::..FieldNormStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..FieldNormStatus type exposes the following members.

Fields

 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | totFields | Number of fields successfully tested

See Also

CheckIndex..::..Status..::..FieldNormStatus Class
Lucene.Net.Index Namespace


error Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus..::..error Field
CheckIndex..::..Status..::..FieldNormStatus Class See Also Send Feedback
Exception thrown during term index test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Exception error
Visual Basic
Public error As Exception
Visual C++
public:
Exception^ error

See Also

CheckIndex..::..Status..::..FieldNormStatus Class
Lucene.Net.Index Namespace


totFields Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus..::..totFields Field
CheckIndex..::..Status..::..FieldNormStatus Class See Also Send Feedback
Number of fields successfully tested

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long totFields
Visual Basic
Public totFields As Long
Visual C++
public:
long long totFields

See Also

CheckIndex..::..Status..::..FieldNormStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.FieldNormStatus Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..FieldNormStatus Methods
CheckIndex..::..Status..::..FieldNormStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..FieldNormStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIndex..::..Status..::..FieldNormStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Class

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus Class
CheckIndex..::..Status Class Members See Also Send Feedback
Holds the status of each segment in the index. See {@link #segmentInfos}.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SegmentInfoStatus
Visual Basic
Public Class SegmentInfoStatus
Visual C++
public ref class SegmentInfoStatus

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex..::..Status..::..SegmentInfoStatus

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Members
Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus Members
CheckIndex..::..Status..::..SegmentInfoStatus Class Constructors Methods Fields See Also Send Feedback

Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex..::..Status..::..SegmentInfoStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex..::..Status..::..SegmentInfoStatus | Initializes a new instance of the CheckIndex..::..Status..::..SegmentInfoStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | compound | True if segment is compound file format.
Public field | deletionsFileName | Name of the current deletions file name.
Public field | diagnostics | Map<String, String> that includes certain debugging details that IndexWriter records into each segment it creates
Public field | docCount | Document count (does not take deletions into account).
Public field | docStoreCompoundFile | True if the shared doc store files are compound file format.
Public field | docStoreOffset | Doc store offset, if this segment shares the doc store files (stored fields and term vectors) with other segments. This is -1 if it does not share.
Public field | docStoreSegment | String of the shared doc store segment, or null if this segment does not share the doc store files.
Public field | fieldNormStatus | Status for testing of field norms (null if field norms could not be tested).
Public field | hasDeletions | True if this segment has pending deletions.
Public field | hasProx | True if at least one of the fields in this segment does not omitTermFreqAndPositions.
Public field | name | Name of the segment.
Public field | numDeleted | Number of deleted documents.
Public field | numFiles | Number of files referenced by this segment.
Public field | openReaderPassed | True if we were able to open a SegmentReader on this segment.
Public field | sizeMB | Net size (MB) of the files referenced by this segment.
Public field | storedFieldStatus | Status for testing of stored fields (null if stored fields could not be tested).
Public field | termIndexStatus | Status for testing of indexed terms (null if indexed terms could not be tested).
Public field | termVectorStatus | Status for testing of term vectors (null if term vectors could not be tested).

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Constructor

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus Constructor
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Initializes a new instance of the CheckIndex..::..Status..::..SegmentInfoStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfoStatus()
Visual Basic
Public Sub New
Visual C++
public:
SegmentInfoStatus()

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus Fields
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..SegmentInfoStatus type exposes the following members.

Fields

 | Name | Description
Public field | compound | True if segment is compound file format.
Public field | deletionsFileName | Name of the current deletions file name.
Public field | diagnostics | Map<String, String> that includes certain debugging details that IndexWriter records into each segment it creates
Public field | docCount | Document count (does not take deletions into account).
Public field | docStoreCompoundFile | True if the shared doc store files are compound file format.
Public field | docStoreOffset | Doc store offset, if this segment shares the doc store files (stored fields and term vectors) with other segments. This is -1 if it does not share.
Public field | docStoreSegment | String of the shared doc store segment, or null if this segment does not share the doc store files.
Public field | fieldNormStatus | Status for testing of field norms (null if field norms could not be tested).
Public field | hasDeletions | True if this segment has pending deletions.
Public field | hasProx | True if at least one of the fields in this segment does not omitTermFreqAndPositions.
Public field | name | Name of the segment.
Public field | numDeleted | Number of deleted documents.
Public field | numFiles | Number of files referenced by this segment.
Public field | openReaderPassed | True if we were able to open a SegmentReader on this segment.
Public field | sizeMB | Net size (MB) of the files referenced by this segment.
Public field | storedFieldStatus | Status for testing of stored fields (null if stored fields could not be tested).
Public field | termIndexStatus | Status for testing of indexed terms (null if indexed terms could not be tested).
Public field | termVectorStatus | Status for testing of term vectors (null if term vectors could not be tested).

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


compound Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..compound Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
True if segment is compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool compound
Visual Basic
Public compound As Boolean
Visual C++
public:
bool compound

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


deletionsFileName Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..deletionsFileName Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Name of the current deletions file name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string deletionsFileName
Visual Basic
Public deletionsFileName As String
Visual C++
public:
String^ deletionsFileName

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


diagnostics Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..diagnostics Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Map<String, String> that includes certain debugging details that IndexWriter records into each segment it creates

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IDictionary<string, string> diagnostics
Visual Basic
Public diagnostics As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ diagnostics

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


docCount Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..docCount Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Document count (does not take deletions into account).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int docCount
Visual Basic
Public docCount As Integer
Visual C++
public:
int docCount

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


docStoreCompoundFile Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..docStoreCompoundFile Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
True if the shared doc store files are compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool docStoreCompoundFile
Visual Basic
Public docStoreCompoundFile As Boolean
Visual C++
public:
bool docStoreCompoundFile

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


docStoreOffset Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..docStoreOffset Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Doc store offset, if this segment shares the doc store files (stored fields and term vectors) with other segments. This is -1 if it does not share.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int docStoreOffset
Visual Basic
Public docStoreOffset As Integer
Visual C++
public:
int docStoreOffset

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


docStoreSegment Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..docStoreSegment Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
String of the shared doc store segment, or null if this segment does not share the doc store files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string docStoreSegment
Visual Basic
Public docStoreSegment As String
Visual C++
public:
String^ docStoreSegment

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


fieldNormStatus Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..fieldNormStatus Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Status for testing of field norms (null if field norms could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CheckIndex..::..Status..::..FieldNormStatus fieldNormStatus
Visual Basic
Public fieldNormStatus As CheckIndex..::..Status..::..FieldNormStatus
Visual C++
public:
CheckIndex..::..Status..::..FieldNormStatus^ fieldNormStatus

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


hasDeletions Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..hasDeletions Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
True if this segment has pending deletions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool hasDeletions
Visual Basic
Public hasDeletions As Boolean
Visual C++
public:
bool hasDeletions

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


hasProx Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..hasProx Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
True if at least one of the fields in this segment does not omitTermFreqAndPositions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool hasProx
Visual Basic
Public hasProx As Boolean
Visual C++
public:
bool hasProx

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace
[!:AbstractField.setOmitTermFreqAndPositions]


name Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..name Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Name of the segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string name
Visual Basic
Public name As String
Visual C++
public:
String^ name

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


numDeleted Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..numDeleted Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Number of deleted documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int numDeleted
Visual Basic
Public numDeleted As Integer
Visual C++
public:
int numDeleted

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


numFiles Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..numFiles Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Number of files referenced by this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int numFiles
Visual Basic
Public numFiles As Integer
Visual C++
public:
int numFiles

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


openReaderPassed Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..openReaderPassed Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
True if we were able to open a SegmentReader on this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool openReaderPassed
Visual Basic
Public openReaderPassed As Boolean
Visual C++
public:
bool openReaderPassed

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


sizeMB Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..sizeMB Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Net size (MB) of the files referenced by this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public double sizeMB
Visual Basic
Public sizeMB As Double
Visual C++
public:
double sizeMB

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


storedFieldStatus Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..storedFieldStatus Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Status for testing of stored fields (null if stored fields could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CheckIndex..::..Status..::..StoredFieldStatus storedFieldStatus
Visual Basic
Public storedFieldStatus As CheckIndex..::..Status..::..StoredFieldStatus
Visual C++
public:
CheckIndex..::..Status..::..StoredFieldStatus^ storedFieldStatus

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


termIndexStatus Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..termIndexStatus Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Status for testing of indexed terms (null if indexed terms could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CheckIndex..::..Status..::..TermIndexStatus termIndexStatus
Visual Basic
Public termIndexStatus As CheckIndex..::..Status..::..TermIndexStatus
Visual C++
public:
CheckIndex..::..Status..::..TermIndexStatus^ termIndexStatus

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


termVectorStatus Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus..::..termVectorStatus Field
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback
Status for testing of term vectors (null if term vectors could not be tested).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CheckIndex..::..Status..::..TermVectorStatus termVectorStatus
Visual Basic
Public termVectorStatus As CheckIndex..::..Status..::..TermVectorStatus
Visual C++
public:
CheckIndex..::..Status..::..TermVectorStatus^ termVectorStatus

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.SegmentInfoStatus Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..SegmentInfoStatus Methods
CheckIndex..::..Status..::..SegmentInfoStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..SegmentInfoStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIndex..::..Status..::..SegmentInfoStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.StoredFieldStatus Class

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus Class
CheckIndex..::..Status Class Members See Also Send Feedback
Status from testing stored fields.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StoredFieldStatus
Visual Basic
Public NotInheritable Class StoredFieldStatus
Visual C++
public ref class StoredFieldStatus sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex..::..Status..::..StoredFieldStatus

See Also

CheckIndex..::..Status..::..StoredFieldStatus Members
Lucene.Net.Index Namespace


CheckIndex.Status.StoredFieldStatus Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus Members
CheckIndex..::..Status..::..StoredFieldStatus Class Constructors Methods Fields See Also Send Feedback

Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex..::..Status..::..StoredFieldStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex..::..Status..::..StoredFieldStatus | Initializes a new instance of the CheckIndex..::..Status..::..StoredFieldStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during stored fields test (null on success)
Public field | totFields | Total number of stored fields tested.

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.StoredFieldStatus Constructor

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus Constructor
CheckIndex..::..Status..::..StoredFieldStatus Class See Also Send Feedback
Initializes a new instance of the CheckIndex..::..Status..::..StoredFieldStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StoredFieldStatus()
Visual Basic
Public Sub New
Visual C++
public:
StoredFieldStatus()

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.StoredFieldStatus Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus Fields
CheckIndex..::..Status..::..StoredFieldStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..StoredFieldStatus type exposes the following members.

Fields

 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during stored fields test (null on success)
Public field | totFields | Total number of stored fields tested.

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


docCount Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus..::..docCount Field
CheckIndex..::..Status..::..StoredFieldStatus Class See Also Send Feedback
Number of documents tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int docCount
Visual Basic
Public docCount As Integer
Visual C++
public:
int docCount

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


error Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus..::..error Field
CheckIndex..::..Status..::..StoredFieldStatus Class See Also Send Feedback
Exception thrown during stored fields test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Exception error
Visual Basic
Public error As Exception
Visual C++
public:
Exception^ error

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


totFields Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus..::..totFields Field
CheckIndex..::..Status..::..StoredFieldStatus Class See Also Send Feedback
Total number of stored fields tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long totFields
Visual Basic
Public totFields As Long
Visual C++
public:
long long totFields

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.StoredFieldStatus Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..StoredFieldStatus Methods
CheckIndex..::..Status..::..StoredFieldStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..StoredFieldStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIndex..::..Status..::..StoredFieldStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermIndexStatus Class

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus Class
CheckIndex..::..Status Class Members See Also Send Feedback
Status from testing term index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class TermIndexStatus
Visual Basic
Public NotInheritable Class TermIndexStatus
Visual C++
public ref class TermIndexStatus sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex..::..Status..::..TermIndexStatus

See Also

CheckIndex..::..Status..::..TermIndexStatus Members
Lucene.Net.Index Namespace


CheckIndex.Status.TermIndexStatus Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus Members
CheckIndex..::..Status..::..TermIndexStatus Class Constructors Methods Fields See Also Send Feedback

Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex..::..Status..::..TermIndexStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex..::..Status..::..TermIndexStatus | Initializes a new instance of the CheckIndex..::..Status..::..TermIndexStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | termCount | Total term count
Public field | totFreq | Total frequency across all terms.
Public field | totPos | Total number of positions.

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermIndexStatus Constructor

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus Constructor
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback
Initializes a new instance of the CheckIndex..::..Status..::..TermIndexStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermIndexStatus()
Visual Basic
Public Sub New
Visual C++
public:
TermIndexStatus()

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermIndexStatus Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus Fields
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..TermIndexStatus type exposes the following members.

Fields

 | Name | Description
Public field | error | Exception thrown during term index test (null on success)
Public field | termCount | Total term count
Public field | totFreq | Total frequency across all terms.
Public field | totPos | Total number of positions.

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


error Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus..::..error Field
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback
Exception thrown during term index test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Exception error
Visual Basic
Public error As Exception
Visual C++
public:
Exception^ error

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


termCount Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus..::..termCount Field
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback
Total term count

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long termCount
Visual Basic
Public termCount As Long
Visual C++
public:
long long termCount

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


totFreq Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus..::..totFreq Field
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback
Total frequency across all terms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long totFreq
Visual Basic
Public totFreq As Long
Visual C++
public:
long long totFreq

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


totPos Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus..::..totPos Field
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback
Total number of positions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long totPos
Visual Basic
Public totPos As Long
Visual C++
public:
long long totPos

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermIndexStatus Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermIndexStatus Methods
CheckIndex..::..Status..::..TermIndexStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..TermIndexStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIndex..::..Status..::..TermIndexStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermVectorStatus Class

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus Class
CheckIndex..::..Status Class Members See Also Send Feedback
Status from testing stored fields.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class TermVectorStatus
Visual Basic
Public NotInheritable Class TermVectorStatus
Visual C++
public ref class TermVectorStatus sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CheckIndex..::..Status..::..TermVectorStatus

See Also

CheckIndex..::..Status..::..TermVectorStatus Members
Lucene.Net.Index Namespace


CheckIndex.Status.TermVectorStatus Members

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus Members
CheckIndex..::..Status..::..TermVectorStatus Class Constructors Methods Fields See Also Send Feedback

Returned from {@link #CheckIndex()} detailing the health and status of the index.

WARNING: this API is new and experimental and is subject to suddenly change in the next release.

The CheckIndex..::..Status..::..TermVectorStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIndex..::..Status..::..TermVectorStatus | Initializes a new instance of the CheckIndex..::..Status..::..TermVectorStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during term vector test (null on success)
Public field | totVectors | Total number of term vectors tested.

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermVectorStatus Constructor

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus Constructor
CheckIndex..::..Status..::..TermVectorStatus Class See Also Send Feedback
Initializes a new instance of the CheckIndex..::..Status..::..TermVectorStatus class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorStatus()
Visual Basic
Public Sub New
Visual C++
public:
TermVectorStatus()

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermVectorStatus Fields

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus Fields
CheckIndex..::..Status..::..TermVectorStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..TermVectorStatus type exposes the following members.

Fields

 | Name | Description
Public field | docCount | Number of documents tested.
Public field | error | Exception thrown during term vector test (null on success)
Public field | totVectors | Total number of term vectors tested.

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


docCount Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus..::..docCount Field
CheckIndex..::..Status..::..TermVectorStatus Class See Also Send Feedback
Number of documents tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int docCount
Visual Basic
Public docCount As Integer
Visual C++
public:
int docCount

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


error Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus..::..error Field
CheckIndex..::..Status..::..TermVectorStatus Class See Also Send Feedback
Exception thrown during term vector test (null on success)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Exception error
Visual Basic
Public error As Exception
Visual C++
public:
Exception^ error

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


totVectors Field

[image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus..::..totVectors Field
CheckIndex..::..Status..::..TermVectorStatus Class See Also Send Feedback
Total number of term vectors tested.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long totVectors
Visual Basic
Public totVectors As Long
Visual C++
public:
long long totVectors

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


CheckIndex.Status.TermVectorStatus Methods

[image] [image]

Lucene.Net Class Libraries
CheckIndex..::..Status..::..TermVectorStatus Methods
CheckIndex..::..Status..::..TermVectorStatus Class See Also Send Feedback

The CheckIndex..::..Status..::..TermVectorStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIndex..::..Status..::..TermVectorStatus Class
Lucene.Net.Index Namespace


CompoundFileReader Class

[image]

Lucene.Net Class Libraries
CompoundFileReader Class
Members See Also Send Feedback
Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CompoundFileReader : Directory
Visual Basic
Public Class CompoundFileReader _
    Inherits Directory
Visual C++
public ref class CompoundFileReader : public Directory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Index..::..CompoundFileReader

See Also

CompoundFileReader Members
Lucene.Net.Index Namespace


CompoundFileReader Members

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader Members
CompoundFileReader Class Constructors Methods Fields Properties See Also Send Feedback

The CompoundFileReader type exposes the following members.

Constructors

 | Name | Description
Public method | CompoundFileReader(Directory, String) | Initializes a new instance of the CompoundFileReader class
Public method | CompoundFileReader(Directory, String, Int32) | Initializes a new instance of the CompoundFileReader class

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | Not implemented (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | Not implemented (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory..::..FileExists(String).)
Public method | FileLength | Returns the length of a file in the directory. (Overrides Directory..::..FileLength(String).)
Public method | FileModified | Returns the time the compound file was last modified. (Overrides Directory..::..FileModified(String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | GetName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete. Returns an array of strings, one for each file in the directory. (Overrides Directory..::..List()()()().)
Public method | ListAll | Returns an array of strings, one for each file in the directory. Unlike {@link #list} this method does no filtering of the contents in a directory, and it will never return null (throws IOException instead). Currently this method simply fallsback to {@link #list} for Directory impls outside of Lucene's core & contrib, but in 3.0 that method will be removed and this method will become abstract. (Inherited from Directory.)
Public method | MakeLock | Not implemented (Overrides Directory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | (Overrides Directory..::..OpenInput(String, Int32).)
Public method | RenameFile | Obsolete. Not implemented (Overrides Directory..::..RenameFile(String, String).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of the compound file to now. (Overrides Directory..::..TouchFile(String).)

Fields

 | Name | Description
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


CompoundFileReader Constructor

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader Constructor
CompoundFileReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompoundFileReader(Directory, String) | Initializes a new instance of the CompoundFileReader class
Public method | CompoundFileReader(Directory, String, Int32) | Initializes a new instance of the CompoundFileReader class

See Also

CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace


CompoundFileReader Constructor (Directory, String)

[image]

Lucene.Net Class Libraries
CompoundFileReader Constructor (Directory, String)
CompoundFileReader Class See Also Send Feedback
Initializes a new instance of the CompoundFileReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CompoundFileReader(
    Directory dir,
    string name
)
Visual Basic
Public Sub New ( _
    dir As Directory, _
    name As String _
)
Visual C++
public:
CompoundFileReader(
    Directory^ dir,
    String^ name
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.#ctor(Lucene.Net.Store.Directory,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.#ctor(Lucene.Net.Store.Directory,System.String)"]

See Also

CompoundFileReader Class
CompoundFileReader Overload
Lucene.Net.Index Namespace


CompoundFileReader Constructor (Directory, String, Int32)

[image]

Lucene.Net Class Libraries
CompoundFileReader Constructor (Directory, String, Int32)
CompoundFileReader Class See Also Send Feedback
Initializes a new instance of the CompoundFileReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CompoundFileReader(
    Directory dir,
    string name,
    int readBufferSize
)
Visual Basic
Public Sub New ( _
    dir As Directory, _
    name As String, _
    readBufferSize As Integer _
)
Visual C++
public:
CompoundFileReader(
    Directory^ dir,
    String^ name,
    int readBufferSize
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.#ctor(Lucene.Net.Store.Directory,System.String,System.Int32)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.#ctor(Lucene.Net.Store.Directory,System.String,System.Int32)"]

readBufferSize
Type: System..::..Int32

[Missing <param name="readBufferSize"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.#ctor(Lucene.Net.Store.Directory,System.String,System.Int32)"]

See Also

CompoundFileReader Class
CompoundFileReader Overload
Lucene.Net.Index Namespace


CompoundFileReader Fields

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader Fields
CompoundFileReader Class See Also Send Feedback

The CompoundFileReader type exposes the following members.

Fields

 | Name | Description
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


CompoundFileReader Methods

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader Methods
CompoundFileReader Class See Also Send Feedback

The CompoundFileReader type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | Not implemented (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | Not implemented (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory..::..FileExists(String).)
Public method | FileLength | Returns the length of a file in the directory. (Overrides Directory..::..FileLength(String).)
Public method | FileModified | Returns the time the compound file was last modified. (Overrides Directory..::..FileModified(String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | GetName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete. Returns an array of strings, one for each file in the directory. (Overrides Directory..::..List()()()().)
Public method | ListAll | Returns an array of strings, one for each file in the directory. Unlike {@link #list} this method does no filtering of the contents in a directory, and it will never return null (throws IOException instead). Currently this method simply fallsback to {@link #list} for Directory impls outside of Lucene's core & contrib, but in 3.0 that method will be removed and this method will become abstract. (Inherited from Directory.)
Public method | MakeLock | Not implemented (Overrides Directory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | (Overrides Directory..::..OpenInput(String, Int32).)
Public method | RenameFile | Obsolete. Not implemented (Overrides Directory..::..RenameFile(String, String).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of the compound file to now. (Overrides Directory..::..TouchFile(String).)

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..Close Method
CompoundFileReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CreateOutput Method
CompoundFileReader Class See Also Send Feedback
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.CreateOutput(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


DeleteFile Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..DeleteFile Method
CompoundFileReader Class See Also Send Feedback
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void DeleteFile(
    string name
)
Visual Basic
Public Overrides Sub DeleteFile ( _
    name As String _
)
Visual C++
public:
virtual void DeleteFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.DeleteFile(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..Dispose Method
CompoundFileReader Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::..Dispose()()()()

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


FileExists Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..FileExists Method
CompoundFileReader Class See Also Send Feedback
Returns true iff a file with the given name exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool FileExists(
    string name
)
Visual Basic
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool FileExists(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.FileExists(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.FileExists(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


FileLength Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..FileLength Method
CompoundFileReader Class See Also Send Feedback
Returns the length of a file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileLength(
    string name
)
Visual Basic
Public Overrides Function FileLength ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileLength(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.FileLength(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.FileLength(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


FileModified Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..FileModified Method
CompoundFileReader Class See Also Send Feedback
Returns the time the compound file was last modified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileModified(
    string name
)
Visual Basic
Public Overrides Function FileModified ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileModified(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.FileModified(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.FileModified(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


GetDirectory Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..GetDirectory Method
CompoundFileReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.GetDirectory"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Directory GetDirectory()
Visual Basic
Public Overridable Function GetDirectory As Directory
Visual C++
public:
virtual Directory^ GetDirectory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.GetDirectory"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


GetName Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..GetName Method
CompoundFileReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.GetName"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetName()
Visual Basic
Public Overridable Function GetName As String
Visual C++
public:
virtual String^ GetName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.GetName"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


List Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..List Method
CompoundFileReader Class See Also Send Feedback
Returns an array of strings, one for each file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public override string[] List()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")> _
Public Overrides Function List As String()
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public:
virtual array<String^>^ List() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.List"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..MakeLock Method
CompoundFileReader Class See Also Send Feedback
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Lock MakeLock(
    string name
)
Visual Basic
Public Overrides Function MakeLock ( _
    name As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.MakeLock(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.MakeLock(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader..::..OpenInput Method
CompoundFileReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | (Overrides Directory..::..OpenInput(String, Int32).)

See Also

CompoundFileReader Class
CompoundFileReader Members
Lucene.Net.Index Namespace


OpenInput Method (String)

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..OpenInput Method (String)
CompoundFileReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string id
)
Visual Basic
Public Overrides Function OpenInput ( _
    id As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ id
) override

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String)"]

See Also

CompoundFileReader Class
OpenInput Overload
Lucene.Net.Index Namespace


OpenInput Method (String, Int32)

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..OpenInput Method (String, Int32)
CompoundFileReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string id,
    int readBufferSize
)
Visual Basic
Public Overrides Function OpenInput ( _
    id As String, _
    readBufferSize As Integer _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ id,
    int readBufferSize
) override

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String,System.Int32)"]

readBufferSize
Type: System..::..Int32

[Missing <param name="readBufferSize"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.OpenInput(System.String,System.Int32)"]

See Also

CompoundFileReader Class
OpenInput Overload
Lucene.Net.Index Namespace


RenameFile Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..RenameFile Method
CompoundFileReader Class See Also Send Feedback
Not implemented

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.RenameFile(string, string)")]
public override void RenameFile(
    string from,
    string to
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.RenameFile(string, string)")> _
Public Overrides Sub RenameFile ( _
    from As String, _
    to As String _
)
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.RenameFile(string, string)")]
public:
virtual void RenameFile(
    String^ from,
    String^ to
) override

Parameters

from
Type: System..::..String

[Missing <param name="from"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.RenameFile(System.String,System.String)"]

to
Type: System..::..String

[Missing <param name="to"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.RenameFile(System.String,System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


TouchFile Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..TouchFile Method
CompoundFileReader Class See Also Send Feedback
Set the modified time of the compound file to now.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void TouchFile(
    string name
)
Visual Basic
Public Overrides Sub TouchFile ( _
    name As String _
)
Visual C++
public:
virtual void TouchFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.TouchFile(System.String)"]

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


CompoundFileReader Properties

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader Properties
CompoundFileReader Class See Also Send Feedback

The CompoundFileReader type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

CompoundFileReader Class
Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Class

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput Class
CompoundFileReader Class Members See Also Send Feedback
Implementation of an IndexInput that reads from a portion of the compound file. The visibility is left as "package" *only* because this helps with testing since JUnit test cases in a different class can then access package fields of this class.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class CSIndexInput : BufferedIndexInput,
    ICloneable
Visual Basic
Public NotInheritable Class CSIndexInput _
    Inherits BufferedIndexInput _
    Implements ICloneable
Visual C++
public ref class CSIndexInput sealed : public BufferedIndexInput,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Store..::..BufferedIndexInput
Lucene.Net.Index..::..CompoundFileReader..::..CSIndexInput

See Also

CompoundFileReader..::..CSIndexInput Members
Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Members

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput Members
CompoundFileReader..::..CSIndexInput Class Methods Fields Properties See Also Send Feedback

Class for accessing a compound stream. This class implements a directory, but is limited to only read operations. Directory methods that would normally modify data throw an exception.

The CompoundFileReader..::..CSIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput..::..Clone()()()().)
Public method | Close | Closes the stream to further operations. (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize | (Inherited from BufferedIndexInput.)
Public method | GetFilePointer | (Inherited from BufferedIndexInput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input. (Overrides BufferedIndexInput..::..ReadInternal(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur. (Overrides BufferedIndexInput..::..SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)

Properties

 | Name | Description
Public property | base_Renamed_ForNUnit |

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Fields

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput Fields
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

The CompoundFileReader..::..CSIndexInput type exposes the following members.

Fields

 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


CompoundFileReader.CSIndexInput Methods

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput Methods
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

The CompoundFileReader..::..CSIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput..::..Clone()()()().)
Public method | Close | Closes the stream to further operations. (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize | (Inherited from BufferedIndexInput.)
Public method | GetFilePointer | (Inherited from BufferedIndexInput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input. (Overrides BufferedIndexInput..::..ReadInternal(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur. (Overrides BufferedIndexInput..::..SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput..::..Clone Method
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.CSIndexInput.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.CSIndexInput.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput..::..Close Method
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback
Closes the stream to further operations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


Length Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput..::..Length Method
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.CompoundFileReader.CSIndexInput.Length"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileReader.CSIndexInput.Length"]

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
CSIndexInput..::..ReadBytes Method
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)

See Also

CompoundFileReader..::..CSIndexInput Class
CompoundFileReader..::..CSIndexInput Members
Lucene.Net.Index Namespace


ReadInternal Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput..::..ReadInternal Method
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback
Expert: implements buffer refill. Reads bytes from the current position in the input.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadInternal(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]
the array to read bytes into
offset
Type: System..::..Int32
the offset in the array to start storing bytes
len
Type: System..::..Int32
the number of bytes to read

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


SeekInternal Method

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput..::..SeekInternal Method
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback
Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SeekInternal(
    long pos
)
Visual Basic
Public Overrides Sub SeekInternal ( _
    pos As Long _
)
Visual C++
public:
virtual void SeekInternal(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Index.CompoundFileReader.CSIndexInput.SeekInternal(System.Int64)"]

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace
CompoundFileReader..::..CSIndexInput..::..ReadInternal(array<Byte>[]()[][], Int32, Int32)


CompoundFileReader.CSIndexInput Properties

[image] [image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput Properties
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

The CompoundFileReader..::..CSIndexInput type exposes the following members.

Properties

 | Name | Description
Public property | base_Renamed_ForNUnit |

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


base_Renamed_ForNUnit Property

[image]

Lucene.Net Class Libraries
CompoundFileReader..::..CSIndexInput..::..base_Renamed_ForNUnit Property
CompoundFileReader..::..CSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.CompoundFileReader.CSIndexInput.base_Renamed_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexInput base_Renamed_ForNUnit { get; }
Visual Basic
Public ReadOnly Property base_Renamed_ForNUnit As IndexInput
    Get
Visual C++
public:
property IndexInput^ base_Renamed_ForNUnit {
    IndexInput^ get ();
}

See Also

CompoundFileReader..::..CSIndexInput Class
Lucene.Net.Index Namespace


CompoundFileWriter Class

[image]

Lucene.Net Class Libraries
CompoundFileWriter Class
Members See Also Send Feedback
Combines multiple files into a single compound file. The file format:
  • VInt fileCount
  • {Directory} fileCount entries with the following structure:
    • long dataOffset
    • String fileName
  • {File Data} fileCount entries with the raw data of the corresponding file
The fileCount integer indicates how many files are contained in this compound file. The {directory} that follows has that many entries. Each directory entry contains a long pointer to the start of this file's data section, and a String with that file's name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class CompoundFileWriter
Visual Basic
Public NotInheritable Class CompoundFileWriter
Visual C++
public ref class CompoundFileWriter sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..CompoundFileWriter

See Also

CompoundFileWriter Members
Lucene.Net.Index Namespace


CompoundFileWriter Members

[image] [image]

Lucene.Net Class Libraries
CompoundFileWriter Members
CompoundFileWriter Class Constructors Methods See Also Send Feedback

The CompoundFileWriter type exposes the following members.

Constructors

 | Name | Description
Public method | CompoundFileWriter | Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

Methods

Name Description
Public method AddFile
Add a source stream.
CopyC#
file
 is the string by which the sub-stream will be known in the compound stream.
Public method Close
Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDirectory
Returns the directory of the compound file.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetName
Returns the name of the compound file.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


CompoundFileWriter Constructor

[image]

Lucene.Net Class Libraries
CompoundFileWriter Constructor
CompoundFileWriter Class See Also Send Feedback
Create the compound stream in the specified file. The file name is the entire name (no extensions are added).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CompoundFileWriter(
    Directory dir,
    string name
)
Visual Basic
Public Sub New ( _
    dir As Directory, _
    name As String _
)
Visual C++
public:
CompoundFileWriter(
    Directory^ dir,
    String^ name
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.CompoundFileWriter.#ctor(Lucene.Net.Store.Directory,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.CompoundFileWriter.#ctor(Lucene.Net.Store.Directory,System.String)"]

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


CompoundFileWriter Methods

[image] [image]

Lucene.Net Class Libraries
CompoundFileWriter Methods
CompoundFileWriter Class See Also Send Feedback

The CompoundFileWriter type exposes the following members.

Methods

Name Description
Public method AddFile
Add a source stream.
CopyC#
file
 is the string by which the sub-stream will be known in the compound stream.
Public method Close
Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDirectory
Returns the directory of the compound file.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetName
Returns the name of the compound file.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


AddFile Method

[image]

Lucene.Net Class Libraries
CompoundFileWriter..::..AddFile Method
CompoundFileWriter Class See Also Send Feedback
Add a source stream.
CopyC#
file
 is the string by which the sub-stream will be known in the compound stream.
has been added already

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void AddFile(
    string file
)
Visual Basic
Public Sub AddFile ( _
    file As String _
)
Visual C++
public:
void AddFile(
    String^ file
)

Parameters

file
Type: System..::..String

[Missing <param name="file"/> documentation for "M:Lucene.Net.Index.CompoundFileWriter.AddFile(System.String)"]

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
CompoundFileWriter..::..Close Method
CompoundFileWriter Class See Also Send Feedback
Merge files with the extensions added up to now. All files with these extensions are combined sequentially into the compound stream. After successful merge, the source files are deleted.
if no file has been added to this object

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


GetDirectory Method

[image]

Lucene.Net Class Libraries
CompoundFileWriter..::..GetDirectory Method
CompoundFileWriter Class See Also Send Feedback
Returns the directory of the compound file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Directory GetDirectory()
Visual Basic
Public Function GetDirectory As Directory
Visual C++
public:
Directory^ GetDirectory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileWriter.GetDirectory"]

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


GetName Method

[image]

Lucene.Net Class Libraries
CompoundFileWriter..::..GetName Method
CompoundFileWriter Class See Also Send Feedback
Returns the name of the compound file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.CompoundFileWriter.GetName"]

See Also

CompoundFileWriter Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler Class

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler Class
Members See Also Send Feedback
A {@link MergeScheduler} that runs each merge using a separate thread, up until a maximum number of threads ({@link #setMaxThreadCount}) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ConcurrentMergeScheduler : MergeScheduler
Visual Basic
Public Class ConcurrentMergeScheduler _
    Inherits MergeScheduler
Visual C++
public ref class ConcurrentMergeScheduler : public MergeScheduler

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergeScheduler
Lucene.Net.Index..::..ConcurrentMergeScheduler

See Also

ConcurrentMergeScheduler Members
Lucene.Net.Index Namespace


ConcurrentMergeScheduler Members

[image] [image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler Members
ConcurrentMergeScheduler Class Constructors Methods Fields See Also Send Feedback

The ConcurrentMergeScheduler type exposes the following members.

Constructors

 | Name | Description
Public method | ConcurrentMergeScheduler | Initializes a new instance of the ConcurrentMergeScheduler class

Methods

 | Name | Description
 | AnyUnhandledExceptions | Used for testing
Public method | ClearSuppressExceptions | Used for testing
 | ClearUnhandledExceptions |
Public method | Close | (Overrides MergeScheduler..::..Close()()()().)
Protected method | DoMerge | Does the actual merge, by calling {@link IndexWriter#merge}
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxThreadCount | Get the max # simultaneous threads that may be
Protected method | GetMergeThread | Create and return a new MergeThread
Public method | GetMergeThreadPriority | Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleMergeException | Called when an exception is hit in a background merge thread
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | (Overrides MergeScheduler..::..Merge(IndexWriter).)
Public method | SetMaxThreadCount | Sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.
Public method | SetMergeThreadPriority | Return the priority that merge threads run at.
Public method | SetSuppressExceptions | Used for testing
 | SetTestMode |
Public method | Sync |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | dir |
Protected field | mergeThreadCount |
Protected field | mergeThreads |
Protected field | writer |

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler Constructor

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler Constructor
ConcurrentMergeScheduler Class See Also Send Feedback
Initializes a new instance of the ConcurrentMergeScheduler class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConcurrentMergeScheduler()
Visual Basic
Public Sub New
Visual C++
public:
ConcurrentMergeScheduler()

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler Fields

[image] [image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler Fields
ConcurrentMergeScheduler Class See Also Send Feedback

The ConcurrentMergeScheduler type exposes the following members.

Fields

 | Name | Description
Protected field | dir |
Protected field | mergeThreadCount |
Protected field | mergeThreads |
Protected field | writer |

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


dir Field

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..dir Field
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ConcurrentMergeScheduler.dir"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Directory dir
Visual Basic
Protected Friend dir As Directory
Visual C++
protected public:
Directory^ dir

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


mergeThreadCount Field

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..mergeThreadCount Field
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ConcurrentMergeScheduler.mergeThreadCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int mergeThreadCount
Visual Basic
Protected Friend mergeThreadCount As Integer
Visual C++
protected public:
int mergeThreadCount

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


mergeThreads Field

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..mergeThreads Field
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ConcurrentMergeScheduler.mergeThreads"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IList mergeThreads
Visual Basic
Protected Friend mergeThreads As IList
Visual C++
protected public:
IList^ mergeThreads

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


writer Field

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..writer Field
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.ConcurrentMergeScheduler.writer"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexWriter writer
Visual Basic
Protected Friend writer As IndexWriter
Visual C++
protected public:
IndexWriter^ writer

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler Methods

[image] [image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler Methods
ConcurrentMergeScheduler Class See Also Send Feedback

The ConcurrentMergeScheduler type exposes the following members.

Methods

 | Name | Description
 | AnyUnhandledExceptions | Used for testing
Public method | ClearSuppressExceptions | Used for testing
 | ClearUnhandledExceptions |
Public method | Close | (Overrides MergeScheduler..::..Close()()()().)
Protected method | DoMerge | Does the actual merge, by calling {@link IndexWriter#merge}
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxThreadCount | Get the max # simultaneous threads that may be
Protected method | GetMergeThread | Create and return a new MergeThread
Public method | GetMergeThreadPriority | Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleMergeException | Called when an exception is hit in a background merge thread
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | (Overrides MergeScheduler..::..Merge(IndexWriter).)
Public method | SetMaxThreadCount | Sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.
Public method | SetMergeThreadPriority | Return the priority that merge threads run at.
Public method | SetSuppressExceptions | Used for testing
 | SetTestMode |
Public method | Sync |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


AnyUnhandledExceptions Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..AnyUnhandledExceptions Method
ConcurrentMergeScheduler Class See Also Send Feedback
Used for testing

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool AnyUnhandledExceptions()
Visual Basic
Public Shared Function AnyUnhandledExceptions As Boolean
Visual C++
public:
static bool AnyUnhandledExceptions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.AnyUnhandledExceptions"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


ClearSuppressExceptions Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..ClearSuppressExceptions Method
ConcurrentMergeScheduler Class See Also Send Feedback
Used for testing

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ClearSuppressExceptions()
Visual Basic
Public Overridable Sub ClearSuppressExceptions
Visual C++
public:
virtual void ClearSuppressExceptions()

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


ClearUnhandledExceptions Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..ClearUnhandledExceptions Method
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.ClearUnhandledExceptions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void ClearUnhandledExceptions()
Visual Basic
Public Shared Sub ClearUnhandledExceptions
Visual C++
public:
static void ClearUnhandledExceptions()

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..Close Method
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


DoMerge Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..DoMerge Method
ConcurrentMergeScheduler Class See Also Send Feedback
Does the actual merge, by calling {@link IndexWriter#merge}

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void DoMerge(
    MergePolicy..::..OneMerge merge
)
Visual Basic
Protected Friend Overridable Sub DoMerge ( _
    merge As MergePolicy..::..OneMerge _
)
Visual C++
protected public:
virtual void DoMerge(
    MergePolicy..::..OneMerge^ merge
)

Parameters

merge
Type: Lucene.Net.Index..::..MergePolicy..::..OneMerge

[Missing <param name="merge"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.DoMerge(Lucene.Net.Index.MergePolicy.OneMerge)"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


GetMaxThreadCount Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..GetMaxThreadCount Method
ConcurrentMergeScheduler Class See Also Send Feedback
Get the max # simultaneous threads that may be

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxThreadCount()
Visual Basic
Public Overridable Function GetMaxThreadCount As Integer
Visual C++
public:
virtual int GetMaxThreadCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.GetMaxThreadCount"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace
[!:setMaxThreadCount]


GetMergeThread Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..GetMergeThread Method
ConcurrentMergeScheduler Class See Also Send Feedback
Create and return a new MergeThread

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual ConcurrentMergeScheduler..::..MergeThread GetMergeThread(
    IndexWriter writer,
    MergePolicy..::..OneMerge merge
)
Visual Basic
Protected Friend Overridable Function GetMergeThread ( _
    writer As IndexWriter, _
    merge As MergePolicy..::..OneMerge _
) As ConcurrentMergeScheduler..::..MergeThread
Visual C++
protected public:
virtual ConcurrentMergeScheduler..::..MergeThread^ GetMergeThread(
    IndexWriter^ writer,
    MergePolicy..::..OneMerge^ merge
)

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.GetMergeThread(Lucene.Net.Index.IndexWriter,Lucene.Net.Index.MergePolicy.OneMerge)"]

merge
Type: Lucene.Net.Index..::..MergePolicy..::..OneMerge

[Missing <param name="merge"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.GetMergeThread(Lucene.Net.Index.IndexWriter,Lucene.Net.Index.MergePolicy.OneMerge)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.GetMergeThread(Lucene.Net.Index.IndexWriter,Lucene.Net.Index.MergePolicy.OneMerge)"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


GetMergeThreadPriority Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..GetMergeThreadPriority Method
ConcurrentMergeScheduler Class See Also Send Feedback
Return the priority that merge threads run at. By default the priority is 1 plus the priority of (ie, slightly higher priority than) the first thread that calls merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMergeThreadPriority()
Visual Basic
Public Overridable Function GetMergeThreadPriority As Integer
Visual C++
public:
virtual int GetMergeThreadPriority()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.GetMergeThreadPriority"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


HandleMergeException Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..HandleMergeException Method
ConcurrentMergeScheduler Class See Also Send Feedback
Called when an exception is hit in a background merge thread

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void HandleMergeException(
    Exception exc
)
Visual Basic
Protected Friend Overridable Sub HandleMergeException ( _
    exc As Exception _
)
Visual C++
protected public:
virtual void HandleMergeException(
    Exception^ exc
)

Parameters

exc
Type: System..::..Exception

[Missing <param name="exc"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.HandleMergeException(System.Exception)"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


Merge Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..Merge Method
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.Merge(Lucene.Net.Index.IndexWriter)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Merge(
    IndexWriter writer
)
Visual Basic
Public Overrides Sub Merge ( _
    writer As IndexWriter _
)
Visual C++
public:
virtual void Merge(
    IndexWriter^ writer
) override

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.Merge(Lucene.Net.Index.IndexWriter)"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


SetMaxThreadCount Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..SetMaxThreadCount Method
ConcurrentMergeScheduler Class See Also Send Feedback
Sets the max # simultaneous threads that may be running. If a merge is necessary yet we already have this many threads running, the incoming thread (that is calling add/updateDocument) will block until a merge thread has completed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxThreadCount(
    int count
)
Visual Basic
Public Overridable Sub SetMaxThreadCount ( _
    count As Integer _
)
Visual C++
public:
virtual void SetMaxThreadCount(
    int count
)

Parameters

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.SetMaxThreadCount(System.Int32)"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


SetMergeThreadPriority Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..SetMergeThreadPriority Method
ConcurrentMergeScheduler Class See Also Send Feedback
Return the priority that merge threads run at.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergeThreadPriority(
    int pri
)
Visual Basic
Public Overridable Sub SetMergeThreadPriority ( _
    pri As Integer _
)
Visual C++
public:
virtual void SetMergeThreadPriority(
    int pri
)

Parameters

pri
Type: System..::..Int32

[Missing <param name="pri"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.SetMergeThreadPriority(System.Int32)"]

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


SetSuppressExceptions Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..SetSuppressExceptions Method
ConcurrentMergeScheduler Class See Also Send Feedback
Used for testing

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSuppressExceptions()
Visual Basic
Public Overridable Sub SetSuppressExceptions
Visual C++
public:
virtual void SetSuppressExceptions()

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


SetTestMode Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..SetTestMode Method
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.SetTestMode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetTestMode()
Visual Basic
Public Shared Sub SetTestMode
Visual C++
public:
static void SetTestMode()

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


Sync Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..Sync Method
ConcurrentMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.Sync"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Sync()
Visual Basic
Public Overridable Sub Sync
Visual C++
public:
virtual void Sync()

See Also

ConcurrentMergeScheduler Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Class

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread Class
ConcurrentMergeScheduler Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MergeThread : ThreadClass
Visual Basic
Public Class MergeThread _
    Inherits ThreadClass
Visual C++
public ref class MergeThread : public ThreadClass

Inheritance Hierarchy

System..::..Object
ThreadClass
Lucene.Net.Index..::..ConcurrentMergeScheduler..::..MergeThread

See Also

ConcurrentMergeScheduler..::..MergeThread Members
Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Members

[image] [image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread Members
ConcurrentMergeScheduler..::..MergeThread Class Constructors Methods Properties See Also Send Feedback

A {@link MergeScheduler} that runs each merge using a separate thread, up until a maximum number of threads ({@link #setMaxThreadCount}) at which when a merge is needed, the thread(s) that are updating the index will pause until one or more merges completes. This is a simple way to use concurrency in the indexing process without having to create and manage application level threads.

The ConcurrentMergeScheduler..::..MergeThread type exposes the following members.

Constructors

 | Name | Description
Public method | ConcurrentMergeScheduler..::..MergeThread | Initializes a new instance of the ConcurrentMergeScheduler..::..MergeThread class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRunningMerge |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | (Overrides ThreadClassRun()()()().)
Public method | SetRunningMerge |
Public method | SetThreadPriority |
Public method | ToString | (Overrides ThreadClassToString()()()().)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Constructor

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread Constructor
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback
Initializes a new instance of the ConcurrentMergeScheduler..::..MergeThread class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergeThread(
    ConcurrentMergeScheduler enclosingInstance,
    IndexWriter writer,
    MergePolicy..::..OneMerge startMerge
)
Visual Basic
Public Sub New ( _
    enclosingInstance As ConcurrentMergeScheduler, _
    writer As IndexWriter, _
    startMerge As MergePolicy..::..OneMerge _
)
Visual C++
public:
MergeThread(
    ConcurrentMergeScheduler^ enclosingInstance,
    IndexWriter^ writer,
    MergePolicy..::..OneMerge^ startMerge
)

Parameters

enclosingInstance
Type: Lucene.Net.Index..::..ConcurrentMergeScheduler

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.#ctor(Lucene.Net.Index.ConcurrentMergeScheduler,Lucene.Net.Index.IndexWriter,Lucene.Net.Index.MergePolicy.OneMerge)"]

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.#ctor(Lucene.Net.Index.ConcurrentMergeScheduler,Lucene.Net.Index.IndexWriter,Lucene.Net.Index.MergePolicy.OneMerge)"]

startMerge
Type: Lucene.Net.Index..::..MergePolicy..::..OneMerge

[Missing <param name="startMerge"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.#ctor(Lucene.Net.Index.ConcurrentMergeScheduler,Lucene.Net.Index.IndexWriter,Lucene.Net.Index.MergePolicy.OneMerge)"]

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Methods

[image] [image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread Methods
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

The ConcurrentMergeScheduler..::..MergeThread type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRunningMerge |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | (Overrides ThreadClassRun()()()().)
Public method | SetRunningMerge |
Public method | SetThreadPriority |
Public method | ToString | (Overrides ThreadClassToString()()()().)

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


GetRunningMerge Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread..::..GetRunningMerge Method
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.GetRunningMerge"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual MergePolicy..::..OneMerge GetRunningMerge()
Visual Basic
Public Overridable Function GetRunningMerge As MergePolicy..::..OneMerge
Visual C++
public:
virtual MergePolicy..::..OneMerge^ GetRunningMerge()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.GetRunningMerge"]

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


Run Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread..::..Run Method
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.Run"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Run()
Visual Basic
Public Overrides Sub Run
Visual C++
public:
virtual void Run() override

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


SetRunningMerge Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread..::..SetRunningMerge Method
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.SetRunningMerge(Lucene.Net.Index.MergePolicy.OneMerge)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetRunningMerge(
    MergePolicy..::..OneMerge merge
)
Visual Basic
Public Overridable Sub SetRunningMerge ( _
    merge As MergePolicy..::..OneMerge _
)
Visual C++
public:
virtual void SetRunningMerge(
    MergePolicy..::..OneMerge^ merge
)

Parameters

merge
Type: Lucene.Net.Index..::..MergePolicy..::..OneMerge

[Missing <param name="merge"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.SetRunningMerge(Lucene.Net.Index.MergePolicy.OneMerge)"]

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


SetThreadPriority Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread..::..SetThreadPriority Method
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.SetThreadPriority(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetThreadPriority(
    int pri
)
Visual Basic
Public Overridable Sub SetThreadPriority ( _
    pri As Integer _
)
Visual C++
public:
virtual void SetThreadPriority(
    int pri
)

Parameters

pri
Type: System..::..Int32

[Missing <param name="pri"/> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.SetThreadPriority(System.Int32)"]

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread..::..ToString Method
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.ToString"]

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


ConcurrentMergeScheduler.MergeThread Properties

[image] [image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread Properties
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

The ConcurrentMergeScheduler..::..MergeThread type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
ConcurrentMergeScheduler..::..MergeThread..::..Enclosing_Instance Property
ConcurrentMergeScheduler..::..MergeThread Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.ConcurrentMergeScheduler.MergeThread.Enclosing_Instance"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConcurrentMergeScheduler Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As ConcurrentMergeScheduler
    Get
Visual C++
public:
property ConcurrentMergeScheduler^ Enclosing_Instance {
    ConcurrentMergeScheduler^ get ();
}

See Also

ConcurrentMergeScheduler..::..MergeThread Class
Lucene.Net.Index Namespace


CorruptIndexException Class

[image]

Lucene.Net Class Libraries
CorruptIndexException Class
Members See Also Send Feedback
This exception is thrown when Lucene detects an inconsistency in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class CorruptIndexException : IOException
Visual Basic
<SerializableAttribute> _
Public Class CorruptIndexException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class CorruptIndexException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Lucene.Net.Index..::..CorruptIndexException

See Also

CorruptIndexException Members
Lucene.Net.Index Namespace


CorruptIndexException Members

[image] [image]

Lucene.Net Class Libraries
CorruptIndexException Members
CorruptIndexException Class Constructors Methods Properties Events See Also Send Feedback

The CorruptIndexException type exposes the following members.

Constructors

 | Name | Description
Public method | CorruptIndexException(String) | Initializes a new instance of the CorruptIndexException class
Public method | CorruptIndexException(String, Exception) | Initializes a new instance of the CorruptIndexException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CorruptIndexException Class
Lucene.Net.Index Namespace


CorruptIndexException Constructor

[image] [image]

Lucene.Net Class Libraries
CorruptIndexException Constructor
CorruptIndexException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CorruptIndexException(String) | Initializes a new instance of the CorruptIndexException class
Public method | CorruptIndexException(String, Exception) | Initializes a new instance of the CorruptIndexException class

See Also

CorruptIndexException Class
CorruptIndexException Members
Lucene.Net.Index Namespace


CorruptIndexException Constructor (String)

[image]

Lucene.Net Class Libraries
CorruptIndexException Constructor (String)
CorruptIndexException Class See Also Send Feedback
Initializes a new instance of the CorruptIndexException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CorruptIndexException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
CorruptIndexException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.CorruptIndexException.#ctor(System.String)"]

See Also

CorruptIndexException Class
CorruptIndexException Overload
Lucene.Net.Index Namespace


CorruptIndexException Constructor (String, Exception)

[image]

Lucene.Net Class Libraries
CorruptIndexException Constructor (String, Exception)
CorruptIndexException Class See Also Send Feedback
Initializes a new instance of the CorruptIndexException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CorruptIndexException(
    string message,
    Exception exp
)
Visual Basic
Public Sub New ( _
    message As String, _
    exp As Exception _
)
Visual C++
public:
CorruptIndexException(
    String^ message,
    Exception^ exp
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.CorruptIndexException.#ctor(System.String,System.Exception)"]

exp
Type: System..::..Exception

[Missing <param name="exp"/> documentation for "M:Lucene.Net.Index.CorruptIndexException.#ctor(System.String,System.Exception)"]

See Also

CorruptIndexException Class
CorruptIndexException Overload
Lucene.Net.Index Namespace


CorruptIndexException Methods

[image] [image]

Lucene.Net Class Libraries
CorruptIndexException Methods
CorruptIndexException Class See Also Send Feedback

The CorruptIndexException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CorruptIndexException Class
Lucene.Net.Index Namespace


CorruptIndexException Properties

[image] [image]

Lucene.Net Class Libraries
CorruptIndexException Properties
CorruptIndexException Class See Also Send Feedback

The CorruptIndexException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CorruptIndexException Class
Lucene.Net.Index Namespace


CorruptIndexException Events

[image] [image]

Lucene.Net Class Libraries
CorruptIndexException Events
CorruptIndexException Class See Also Send Feedback

The CorruptIndexException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CorruptIndexException Class
Lucene.Net.Index Namespace


DirectoryReader Class

[image]

Lucene.Net Class Libraries
DirectoryReader Class
Members See Also Send Feedback
An IndexReader which reads indexes with multiple segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class DirectoryReader : IndexReader,
    ICloneable
Visual Basic
Public Class DirectoryReader _
    Inherits IndexReader _
    Implements ICloneable
Visual C++
public ref class DirectoryReader : public IndexReader,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..DirectoryReader
Lucene.Net.Index..::..ReadOnlyDirectoryReader

See Also

DirectoryReader Members
Lucene.Net.Index Namespace


DirectoryReader Members

[image] [image]

Lucene.Net Class Libraries
DirectoryReader Members
DirectoryReader Class Methods Fields Properties See Also Send Feedback

The DirectoryReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
(Overrides IndexReader..::..AcquireWriteLock()()()().)
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | (Overrides IndexReader..::..Clone(Boolean).)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Overrides IndexReader..::..Directory()()()().)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method DoCommit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations

If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

(Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method | GetCommitUserData | (Overrides IndexReader..::..GetCommitUserData()()()().)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened.

WARNING: this API is new and experimental and may suddenly change.

(Overrides IndexReader..::..GetIndexCommit()()()().)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Overrides IndexReader..::..GetSequentialSubReaders()()()().)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method | GetTermInfosIndexDivisor | (Overrides IndexReader..::..GetTermInfosIndexDivisor()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Version number when this IndexReader was opened.
(Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions)
(Overrides IndexReader..::..IsOptimized()()()().)
ListCommits
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method | Reopen()()()() | (Overrides IndexReader..::..Reopen()()()().)
Public method | Reopen(Boolean) | (Overrides IndexReader..::..Reopen(Boolean).)
Public method | Reopen(IndexCommit) | (Overrides IndexReader..::..Reopen(IndexCommit).)
Public method | SetDisableFakeNorms | Obsolete. (Overrides IndexReader..::..SetDisableFakeNorms(Boolean).)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | directory |
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly |

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DirectoryReader Fields

[image] [image]

Lucene.Net Class Libraries
DirectoryReader Fields
DirectoryReader Class See Also Send Feedback

The DirectoryReader type exposes the following members.

Fields

 | Name | Description
Protected field | directory |
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly |

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


directory Field

[image]

Lucene.Net Class Libraries
DirectoryReader..::..directory Field
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.DirectoryReader.directory"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Directory directory
Visual Basic
Protected Friend directory As Directory
Visual C++
protected public:
Directory^ directory

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


readOnly Field

[image]

Lucene.Net Class Libraries
DirectoryReader..::..readOnly Field
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.DirectoryReader.readOnly"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool readOnly
Visual Basic
Protected Friend readOnly As Boolean
Visual C++
protected public:
bool readOnly

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DirectoryReader Methods

[image] [image]

Lucene.Net Class Libraries
DirectoryReader Methods
DirectoryReader Class See Also Send Feedback

The DirectoryReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
(Overrides IndexReader..::..AcquireWriteLock()()()().)
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | (Overrides IndexReader..::..Clone(Boolean).)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Overrides IndexReader..::..Directory()()()().)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method DoCommit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations

If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

(Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method | GetCommitUserData | (Overrides IndexReader..::..GetCommitUserData()()()().)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened.

WARNING: this API is new and experimental and may suddenly change.

(Overrides IndexReader..::..GetIndexCommit()()()().)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Overrides IndexReader..::..GetSequentialSubReaders()()()().)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method | GetTermInfosIndexDivisor | (Overrides IndexReader..::..GetTermInfosIndexDivisor()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Version number when this IndexReader was opened.
(Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions)
(Overrides IndexReader..::..IsOptimized()()()().)
ListCommits
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method | Reopen()()()() | (Overrides IndexReader..::..Reopen()()()().)
Public method | Reopen(Boolean) | (Overrides IndexReader..::..Reopen(Boolean).)
Public method | Reopen(IndexCommit) | (Overrides IndexReader..::..Reopen(IndexCommit).)
Public method | SetDisableFakeNorms | Obsolete. (Overrides IndexReader..::..SetDisableFakeNorms(Boolean).)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


AcquireWriteLock Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..AcquireWriteLock Method
DirectoryReader Class See Also Send Feedback
Tries to acquire the WriteLock on this directory. this method is only valid if this IndexReader is directory owner.
if another writer has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void AcquireWriteLock()
Visual Basic
Protected Friend Overrides Sub AcquireWriteLock
Visual C++
protected public:
virtual void AcquireWriteLock() override

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Clone Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | (Overrides IndexReader..::..Clone(Boolean).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Clone Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

DirectoryReader Class
Clone Overload
Lucene.Net.Index Namespace


Clone Method (Boolean)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Clone Method (Boolean)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Clone(System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Clone(
    bool openReadOnly
)
Visual Basic
Public Overrides Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Clone(
    bool openReadOnly
) override

Parameters

openReadOnly
Type: System..::..Boolean

[Missing <param name="openReadOnly"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Clone(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Clone(System.Boolean)"]

See Also

DirectoryReader Class
Clone Overload
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Commit Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


Directory Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Directory Method
DirectoryReader Class See Also Send Feedback
Returns the directory this index resides in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Directory Directory()
Visual Basic
Public Overrides Function Directory As Directory
Visual C++
public:
virtual Directory^ Directory() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Directory"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DocFreq Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term t
)
Visual Basic
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ t
) override

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.DirectoryReader.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.DocFreq(Lucene.Net.Index.Term)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DoClose Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DoClose Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.DoClose"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoClose()
Visual Basic
Protected Friend Overrides Sub DoClose
Visual C++
protected public:
virtual void DoClose() override

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..DoCommit Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DoCommit Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.DoCommit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal override void DoCommit()
Visual Basic
<ObsoleteAttribute> _
Protected Friend Overrides Sub DoCommit
Visual C++
[ObsoleteAttribute]
protected public:
virtual void DoCommit() override

See Also

DirectoryReader Class
DoCommit Overload
Lucene.Net.Index Namespace


DoCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DoCommit Method (IDictionary<(Of <(<'String, String>)>)>)
DirectoryReader Class See Also Send Feedback
Commit changes resulting from delete, undeleteAll, or setNorm operations

If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Protected Friend Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
protected public:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.DirectoryReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

DirectoryReader Class
DoCommit Overload
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Document Method
DirectoryReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


Document Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Document Method (Int32, FieldSelector)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

See Also

DirectoryReader Class
Document Overload
Lucene.Net.Index Namespace


DoDelete Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DoDelete Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.DoDelete(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoDelete(
    int n
)
Visual Basic
Protected Friend Overrides Sub DoDelete ( _
    n As Integer _
)
Visual C++
protected public:
virtual void DoDelete(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.DirectoryReader.DoDelete(System.Int32)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DoSetNorm Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DoSetNorm Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
Visual Basic
Protected Friend Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Visual C++
protected public:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.DirectoryReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.DirectoryReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

value_Renamed
Type: System..::..Byte

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.DirectoryReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DoUndeleteAll Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..DoUndeleteAll Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.DoUndeleteAll"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoUndeleteAll()
Visual Basic
Protected Friend Overrides Sub DoUndeleteAll
Visual C++
protected public:
virtual void DoUndeleteAll() override

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Flush Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


GetCommitUserData Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetCommitUserData Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetCommitUserData"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IDictionary<string, string> GetCommitUserData()
Visual Basic
Public Overrides Function GetCommitUserData As IDictionary(Of String, String)
Visual C++
public:
virtual IDictionary<String^, String^>^ GetCommitUserData() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetCommitUserData"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetFieldNames Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Visual Basic
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override

Parameters

fieldNames
Type: Lucene.Net.Index..::..IndexReader..::..FieldOption

[Missing <param name="fieldNames"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


GetIndexCommit Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetIndexCommit Method
DirectoryReader Class See Also Send Feedback
Expert: return the IndexCommit that this reader has opened.

WARNING: this API is new and experimental and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexCommit GetIndexCommit()
Visual Basic
Public Overrides Function GetIndexCommit As IndexCommit
Visual C++
public:
virtual IndexCommit^ GetIndexCommit() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetIndexCommit"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


GetSequentialSubReaders Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetSequentialSubReaders Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetSequentialSubReaders"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader[] GetSequentialSubReaders()
Visual Basic
Public Overrides Function GetSequentialSubReaders As IndexReader()
Visual C++
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetSequentialSubReaders"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..GetTermFreqVector Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetTermFreqVector Method (Int32, TermVectorMapper)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

See Also

DirectoryReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetTermFreqVector Method (Int32, String)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector GetTermFreqVector(
    int n,
    string field
)
Visual Basic
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String)"]

See Also

DirectoryReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetTermFreqVector Method (Int32, String, TermVectorMapper)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

See Also

DirectoryReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVectors Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetTermFreqVectors Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVectors(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector[] GetTermFreqVectors(
    int n
)
Visual Basic
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ GetTermFreqVectors(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVectors(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermFreqVectors(System.Int32)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


GetTermInfosIndexDivisor Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetTermInfosIndexDivisor Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermInfosIndexDivisor"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetTermInfosIndexDivisor()
Visual Basic
Public Overrides Function GetTermInfosIndexDivisor As Integer
Visual C++
public:
virtual int GetTermInfosIndexDivisor() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetTermInfosIndexDivisor"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..GetVersion Method
DirectoryReader Class See Also Send Feedback
Version number when this IndexReader was opened.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetVersion()
Visual Basic
Public Overrides Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.GetVersion"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..HasDeletions Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasDeletions()
Visual Basic
Public Overrides Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.HasDeletions"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


HasNorms Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..HasNorms Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.HasNorms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasNorms(
    string field
)
Visual Basic
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool HasNorms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.DirectoryReader.HasNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.HasNorms(System.String)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


IsCurrent Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..IsCurrent Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.IsCurrent"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCurrent()
Visual Basic
Public Overrides Function IsCurrent As Boolean
Visual C++
public:
virtual bool IsCurrent() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.IsCurrent"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..IsDeleted Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsDeleted(
    int n
)
Visual Basic
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.DirectoryReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.IsDeleted(System.Int32)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..IsOptimized Method
DirectoryReader Class See Also Send Feedback
Checks is the index is optimized (if it has a single segment and no deletions)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsOptimized()
Visual Basic
Public Overrides Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized() override

Return Value

CopyC#
true
 if the index is optimized;
CopyC#
false
 otherwise

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


ListCommits Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..ListCommits Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.ListCommits(Lucene.Net.Store.Directory)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static ICollection ListCommits(
    Directory dir
)
Visual Basic
Public Shared Function ListCommits ( _
    dir As Directory _
) As ICollection
Visual C++
public:
static ICollection^ ListCommits(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.DirectoryReader.ListCommits(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.ListCommits(Lucene.Net.Store.Directory)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace
[!:Lucene.Net.Index.IndexReader.listCommits]


MaxDoc Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..MaxDoc Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.MaxDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.MaxDoc"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Norms Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


Norms Method (String)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Norms Method (String)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] Norms(
    string field
)
Visual Basic
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String)"]

See Also

DirectoryReader Class
Norms Overload
Lucene.Net.Index Namespace


Norms Method (String, Byte[], Int32)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Norms Method (String, array<Byte>[]()[][], Int32)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String,System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Norms(
    string field,
    byte[] result,
    int offset
)
Visual Basic
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
Visual C++
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String,System.Byte[],System.Int32)"]

result
Type: array< System..::..Byte >[]()[][]

[Missing <param name="result"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Norms(System.String,System.Byte[],System.Int32)"]

See Also

DirectoryReader Class
Norms Overload
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..NumDocs Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.NumDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NumDocs()
Visual Basic
Public Overrides Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.NumDocs"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Reopen Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reopen()()()() | (Overrides IndexReader..::..Reopen()()()().)
Public method | Reopen(Boolean) | (Overrides IndexReader..::..Reopen(Boolean).)
Public method | Reopen(IndexCommit) | (Overrides IndexReader..::..Reopen(IndexCommit).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


Reopen Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Reopen Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Reopen()
Visual Basic
Public Overrides Function Reopen As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen"]

See Also

DirectoryReader Class
Reopen Overload
Lucene.Net.Index Namespace


Reopen Method (Boolean)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Reopen Method (Boolean)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen(System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Reopen(
    bool openReadOnly
)
Visual Basic
Public Overrides Function Reopen ( _
    openReadOnly As Boolean _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen(
    bool openReadOnly
) override

Parameters

openReadOnly
Type: System..::..Boolean

[Missing <param name="openReadOnly"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen(System.Boolean)"]

See Also

DirectoryReader Class
Reopen Overload
Lucene.Net.Index Namespace


Reopen Method (IndexCommit)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Reopen Method (IndexCommit)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen(Lucene.Net.Index.IndexCommit)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Reopen(
    IndexCommit commit
)
Visual Basic
Public Overrides Function Reopen ( _
    commit As IndexCommit _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen(
    IndexCommit^ commit
) override

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit

[Missing <param name="commit"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen(Lucene.Net.Index.IndexCommit)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Reopen(Lucene.Net.Index.IndexCommit)"]

See Also

DirectoryReader Class
Reopen Overload
Lucene.Net.Index Namespace


SetDisableFakeNorms Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..SetDisableFakeNorms Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.SetDisableFakeNorms(System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Index.IndexReader.SetDisableFakeNorms(bool)")]
public override void SetDisableFakeNorms(
    bool disableFakeNorms
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Index.IndexReader.SetDisableFakeNorms(bool)")> _
Public Overrides Sub SetDisableFakeNorms ( _
    disableFakeNorms As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Index.IndexReader.SetDisableFakeNorms(bool)")]
public:
virtual void SetDisableFakeNorms(
    bool disableFakeNorms
) override

Parameters

disableFakeNorms
Type: System..::..Boolean

[Missing <param name="disableFakeNorms"/> documentation for "M:Lucene.Net.Index.DirectoryReader.SetDisableFakeNorms(System.Boolean)"]

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..SetNorm Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..TermDocs Method
DirectoryReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..TermDocs Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.TermDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs()
Visual Basic
Public Overrides Function TermDocs As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.TermDocs"]

See Also

DirectoryReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..TermPositions Method
DirectoryReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..TermPositions Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.TermPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermPositions TermPositions()
Visual Basic
Public Overrides Function TermPositions As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.TermPositions"]

See Also

DirectoryReader Class
TermPositions Overload
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
DirectoryReader..::..Terms Method
DirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)

See Also

DirectoryReader Class
DirectoryReader Members
Lucene.Net.Index Namespace


Terms Method

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Terms Method
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Terms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms()
Visual Basic
Public Overrides Function Terms As TermEnum
Visual C++
public:
virtual TermEnum^ Terms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Terms"]

See Also

DirectoryReader Class
Terms Overload
Lucene.Net.Index Namespace


Terms Method (Term)

[image]

Lucene.Net Class Libraries
DirectoryReader..::..Terms Method (Term)
DirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.DirectoryReader.Terms(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms(
    Term term
)
Visual Basic
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
Visual C++
public:
virtual TermEnum^ Terms(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.DirectoryReader.Terms(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.DirectoryReader.Terms(Lucene.Net.Index.Term)"]

See Also

DirectoryReader Class
Terms Overload
Lucene.Net.Index Namespace


DirectoryReader Properties

[image] [image]

Lucene.Net Class Libraries
DirectoryReader Properties
DirectoryReader Class See Also Send Feedback

The DirectoryReader type exposes the following members.

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

DirectoryReader Class
Lucene.Net.Index Namespace


DocumentsWriter Class

[image]

Lucene.Net Class Libraries
DocumentsWriter Class
Members See Also Send Feedback
This class accepts multiple added documents and directly writes a single segment file. It does this more efficiently than creating a single segment per document (with DocumentWriter) and doing standard merges on those segments. Each added document is passed to the {@link DocConsumer}, which in turn processes the document and interacts with other consumers in the indexing chain. Certain consumers, like {@link StoredFieldsWriter} and {@link TermVectorsTermsWriter}, digest a document and immediately write bytes to the "doc store" files (ie, they do not consume RAM per document, except while they are processing the document). Other consumers, eg {@link FreqProxTermsWriter} and {@link NormsWriter}, buffer bytes in RAM and flush only when a new segment is produced. Once we have used our allowed RAM buffer, or the number of added docs is large enough (in the case we are flushing by doc count instead of RAM usage), we create a real segment and flush it to the Directory. Threads: Multiple threads are allowed into addDocument at once. There is an initial synchronized call to getThreadState which allocates a ThreadState for this thread. The same thread will get the same ThreadState over time (thread affinity) so that if there are consistent patterns (for example each thread is indexing a different content source) then we make better use of RAM. Then processDocument is called on that ThreadState without synchronization (most of the "heavy lifting" is in this call). Finally the synchronized "finishDocument" is called to flush changes to the directory. When flush is called by IndexWriter, or, we flush internally when autoCommit=false, we forcefully idle all threads and flush only once they are all idle. This means you can call flush with a given thread even while other threads are actively adding/deleting documents. Exceptions: Because this class directly updates in-memory posting lists, and flushes stored fields and term vectors directly to files in the directory, there are certain limited times when an exception can corrupt this state. For example, a disk full while flushing stored fields leaves this file in a corrupt state. Or, an OOM exception while appending to the in-memory posting lists can corrupt that posting list. We call such exceptions "aborting exceptions". In these cases we must call abort() to discard all docs added since the last flush. All other exceptions ("non-aborting exceptions") can still partially update the index structures. These updates are consistent, but, they represent only a part of the document seen up until the exception was hit. When this happens, we immediately mark the document as deleted so that the document is always atomically ("all or none") added to the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class DocumentsWriter
Visual Basic
Public NotInheritable Class DocumentsWriter
Visual C++
public ref class DocumentsWriter sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..DocumentsWriter

See Also

DocumentsWriter Members
Lucene.Net.Index Namespace


DocumentsWriter Members

[image] [image]

Lucene.Net Class Libraries
DocumentsWriter Members
DocumentsWriter Class Methods Properties See Also Send Feedback

The DocumentsWriter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BYTE_BLOCK_SIZE_ForNUnit |
CHAR_BLOCK_SIZE_ForNUnit |

See Also

DocumentsWriter Class
Lucene.Net.Index Namespace


DocumentsWriter Methods

[image] [image]

Lucene.Net Class Libraries
DocumentsWriter Methods
DocumentsWriter Class See Also Send Feedback

The DocumentsWriter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentsWriter Class
Lucene.Net.Index Namespace


DocumentsWriter Properties

[image] [image]

Lucene.Net Class Libraries
DocumentsWriter Properties
DocumentsWriter Class See Also Send Feedback

The DocumentsWriter type exposes the following members.

Properties

Name | Description
BYTE_BLOCK_SIZE_ForNUnit |
CHAR_BLOCK_SIZE_ForNUnit |

See Also

DocumentsWriter Class
Lucene.Net.Index Namespace


BYTE_BLOCK_SIZE_ForNUnit Property

[image]

Lucene.Net Class Libraries
DocumentsWriter..::..BYTE_BLOCK_SIZE_ForNUnit Property
DocumentsWriter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.DocumentsWriter.BYTE_BLOCK_SIZE_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int BYTE_BLOCK_SIZE_ForNUnit { get; }
Visual Basic
Public Shared ReadOnly Property BYTE_BLOCK_SIZE_ForNUnit As Integer
    Get
Visual C++
public:
static property int BYTE_BLOCK_SIZE_ForNUnit {
    int get ();
}

See Also

DocumentsWriter Class
Lucene.Net.Index Namespace


CHAR_BLOCK_SIZE_ForNUnit Property

[image]

Lucene.Net Class Libraries
DocumentsWriter..::..CHAR_BLOCK_SIZE_ForNUnit Property
DocumentsWriter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.DocumentsWriter.CHAR_BLOCK_SIZE_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int CHAR_BLOCK_SIZE_ForNUnit { get; }
Visual Basic
Public Shared ReadOnly Property CHAR_BLOCK_SIZE_ForNUnit As Integer
    Get
Visual C++
public:
static property int CHAR_BLOCK_SIZE_ForNUnit {
    int get ();
}

See Also

DocumentsWriter Class
Lucene.Net.Index Namespace


DoubleFieldEnumerator Class

[image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Class
Members See Also Send Feedback
Implementation for enumerating over all of the terms in a double numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class DoubleFieldEnumerator : NumericFieldEnum<double>
Visual Basic
Public Class DoubleFieldEnumerator _
    Inherits NumericFieldEnum(Of Double)
Visual C++
public ref class DoubleFieldEnumerator : public NumericFieldEnum<double>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator <(Of <(<' Double >)>)>
Lucene.Net.Index..::..NumericFieldEnum <(Of <(<' Double >)>)>
Lucene.Net.Index..::..DoubleFieldEnumerator

See Also

DoubleFieldEnumerator Members
Lucene.Net.Index Namespace


DoubleFieldEnumerator Members

[image] [image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Members
DoubleFieldEnumerator Class Constructors Methods Fields Properties See Also Send Feedback

The DoubleFieldEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | DoubleFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the double from a numeric field. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the double from a string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

DoubleFieldEnumerator Class
Lucene.Net.Index Namespace


DoubleFieldEnumerator Constructor

[image] [image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Constructor
DoubleFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DoubleFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | DoubleFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

See Also

DoubleFieldEnumerator Class
DoubleFieldEnumerator Members
Lucene.Net.Index Namespace


DoubleFieldEnumerator Constructor (IndexReader, String, FieldParser)

[image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Constructor (IndexReader, String, FieldParser)
DoubleFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public DoubleFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser _
)
Visual C++
public:
DoubleFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.DoubleFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser)"]

See Also

DoubleFieldEnumerator Class
DoubleFieldEnumerator Overload
Lucene.Net.Index Namespace


DoubleFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)

[image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)
DoubleFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public DoubleFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser,
    bool includeDocs
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser, _
    includeDocs As Boolean _
)
Visual C++
public:
DoubleFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser,
    bool includeDocs
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.DoubleFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser,System.Boolean)"]

includeDocs
Type: System..::..Boolean
Whether the TermDocs will also be enumerated.

See Also

DoubleFieldEnumerator Class
DoubleFieldEnumerator Overload
Lucene.Net.Index Namespace


DoubleFieldEnumerator Fields

[image] [image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Fields
DoubleFieldEnumerator Class See Also Send Feedback

The DoubleFieldEnumerator type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

DoubleFieldEnumerator Class
Lucene.Net.Index Namespace


DoubleFieldEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Methods
DoubleFieldEnumerator Class See Also Send Feedback

The DoubleFieldEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the double from a numeric field. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the double from a string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

See Also

DoubleFieldEnumerator Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
DoubleFieldEnumerator..::..Init Method
DoubleFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)

See Also

DoubleFieldEnumerator Class
DoubleFieldEnumerator Members
Lucene.Net.Index Namespace


TryParseNumeric Method

[image]

Lucene.Net Class Libraries
DoubleFieldEnumerator..::..TryParseNumeric Method
DoubleFieldEnumerator Class See Also Send Feedback
Parse the double from a numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseNumeric(
    string s
)
Visual Basic
Protected Overrides Function TryParseNumeric ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseNumeric(
    String^ s
) override

Parameters

s
Type: System..::..String
The string to parse.

Return Value

True if the string was parsed, false to indicate the end of usable numeric terms.

See Also

DoubleFieldEnumerator Class
Lucene.Net.Index Namespace


TryParseString Method

[image]

Lucene.Net Class Libraries
DoubleFieldEnumerator..::..TryParseString Method
DoubleFieldEnumerator Class See Also Send Feedback
Parse the double from a string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseString(
    string s
)
Visual Basic
Protected Overrides Function TryParseString ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseString(
    String^ s
) override

Parameters

s
Type: System..::..String
The string to parse.

Return Value

Always true.

See Also

DoubleFieldEnumerator Class
Lucene.Net.Index Namespace


DoubleFieldEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
DoubleFieldEnumerator Properties
DoubleFieldEnumerator Class See Also Send Feedback

The DoubleFieldEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

DoubleFieldEnumerator Class
Lucene.Net.Index Namespace


EmptyVector Class

[image]

Lucene.Net Class Libraries
EmptyVector Class
Members See Also Send Feedback
A simple TermFreqVector implementation for an empty vector for use with a deleted document or a document that does not have the field that is being enumerated.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class EmptyVector : TermFreqVector
Visual Basic
Public Class EmptyVector _
    Implements TermFreqVector
Visual C++
public ref class EmptyVector : TermFreqVector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..EmptyVector

See Also

EmptyVector Members
Lucene.Net.Index Namespace


EmptyVector Members

[image] [image]

Lucene.Net Class Libraries
EmptyVector Members
EmptyVector Class Constructors Methods See Also Send Feedback

The EmptyVector type exposes the following members.

Constructors

 | Name | Description
Public method | EmptyVector | Initializes a new instance of the EmptyVector class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTermFrequencies |
Public method | GetTerms |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexesOf |
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyVector Class
Lucene.Net.Index Namespace


EmptyVector Constructor

[image]

Lucene.Net Class Libraries
EmptyVector Constructor
EmptyVector Class See Also Send Feedback
Initializes a new instance of the EmptyVector class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public EmptyVector(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
EmptyVector(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.EmptyVector.#ctor(System.String)"]

See Also

EmptyVector Class
Lucene.Net.Index Namespace


EmptyVector Methods

[image] [image]

Lucene.Net Class Libraries
EmptyVector Methods
EmptyVector Class See Also Send Feedback

The EmptyVector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTermFrequencies |
Public method | GetTerms |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexesOf |
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyVector Class
Lucene.Net.Index Namespace


GetField Method

[image]

Lucene.Net Class Libraries
EmptyVector..::..GetField Method
EmptyVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.EmptyVector.GetField"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetField()
Visual Basic
Public Function GetField As String
Visual C++
public:
virtual String^ GetField() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.EmptyVector.GetField"]

Implements

TermFreqVector..::..GetField()()()()

See Also

EmptyVector Class
Lucene.Net.Index Namespace


GetTermFrequencies Method

[image]

Lucene.Net Class Libraries
EmptyVector..::..GetTermFrequencies Method
EmptyVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.EmptyVector.GetTermFrequencies"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int[] GetTermFrequencies()
Visual Basic
Public Function GetTermFrequencies As Integer()
Visual C++
public:
virtual array<int>^ GetTermFrequencies() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.EmptyVector.GetTermFrequencies"]

Implements

TermFreqVector..::..GetTermFrequencies()()()()

See Also

EmptyVector Class
Lucene.Net.Index Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
EmptyVector..::..GetTerms Method
EmptyVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.EmptyVector.GetTerms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] GetTerms()
Visual Basic
Public Function GetTerms As String()
Visual C++
public:
virtual array<String^>^ GetTerms() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.EmptyVector.GetTerms"]

Implements

TermFreqVector..::..GetTerms()()()()

See Also

EmptyVector Class
Lucene.Net.Index Namespace


IndexesOf Method

[image]

Lucene.Net Class Libraries
EmptyVector..::..IndexesOf Method
EmptyVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.EmptyVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
Visual Basic
Public Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
Visual C++
public:
virtual array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
) sealed

Parameters

terms
Type: array< System..::..String >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Index.EmptyVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Index.EmptyVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Index.EmptyVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.EmptyVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

Implements

TermFreqVector..::..IndexesOf(array<String>[]()[][], Int32, Int32)

See Also

EmptyVector Class
Lucene.Net.Index Namespace


IndexOf Method

[image]

Lucene.Net Class Libraries
EmptyVector..::..IndexOf Method
EmptyVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.EmptyVector.IndexOf(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int IndexOf(
    string term
)
Visual Basic
Public Function IndexOf ( _
    term As String _
) As Integer
Visual C++
public:
virtual int IndexOf(
    String^ term
) sealed

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.EmptyVector.IndexOf(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.EmptyVector.IndexOf(System.String)"]

Implements

TermFreqVector..::..IndexOf(String)

See Also

EmptyVector Class
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
EmptyVector..::..Size Method
EmptyVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.EmptyVector.Size"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.EmptyVector.Size"]

Implements

TermFreqVector..::..Size()()()()

See Also

EmptyVector Class
Lucene.Net.Index Namespace


FieldEnumerator(T) Class

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)> Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.FieldEnumerator`1"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract class FieldEnumerator<T> : IDisposable
Visual Basic
Public MustInherit Class FieldEnumerator(Of T) _
    Implements IDisposable
Visual C++
generic<typename T>
public ref class FieldEnumerator abstract : IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Lucene.Net.Index.FieldEnumerator`1"]

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator<(Of <(<'T>)>)>
Lucene.Net.Index..::..NumericFieldEnum<(Of <(<'T>)>)>
Lucene.Net.Index..::..StringFieldEnumerator

See Also

FieldEnumerator<(Of <(<'T>)>)> Members
Lucene.Net.Index Namespace


FieldEnumerator(T) Members

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)> Members
FieldEnumerator<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldEnumerator<(Of <(<'T>)>)> | Initializes a new instance of the FieldEnumerator<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Method to attempt to parse out the value from the encoded string and sets the value of Current.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs.
Protected field | tEnum | The specialized TermEnum enumerator.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs.
Public property | Terms | Access the enumerator for the terms.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


FieldEnumerator(T) Constructor

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)> Constructor
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the FieldEnumerator<(Of <(<'T>)>)> class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected FieldEnumerator()
Visual Basic
Protected Sub New
Visual C++
protected:
FieldEnumerator()

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


FieldEnumerator(T) Fields

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)> Fields
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs.
Protected field | tEnum | The specialized TermEnum enumerator.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


includeDocs Field

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..includeDocs Field
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Whether the enumerator will include TermDocs.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected bool includeDocs
Visual Basic
Protected includeDocs As Boolean
Visual C++
protected:
bool includeDocs

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


tEnum Field

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..tEnum Field
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
The specialized TermEnum enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator tEnum
Visual Basic
Protected tEnum As FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator
Visual C++
protected:
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator^ tEnum

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


FieldEnumerator(T) Methods

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)> Methods
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Method to attempt to parse out the value from the encoded string and sets the value of Current.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..Dispose Method
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Dispose of the instance.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..Init Method
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
FieldEnumerator<(Of <(<'T>)>)> Members
Lucene.Net.Index Namespace


Init Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..Init Method (IndexReader, String)
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected void Init(
    IndexReader reader,
    string field
)
Visual Basic
Protected Sub Init ( _
    reader As IndexReader, _
    field As String _
)
Visual C++
protected:
void Init(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The index reader to read from.
field
Type: System..::..String
The field to enumerate.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Init Overload
Lucene.Net.Index Namespace


Init Method (IndexReader, String, Boolean)

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..Init Method (IndexReader, String, Boolean)
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected void Init(
    IndexReader reader,
    string fieldName,
    bool includeDocs
)
Visual Basic
Protected Sub Init ( _
    reader As IndexReader, _
    fieldName As String, _
    includeDocs As Boolean _
)
Visual C++
protected:
void Init(
    IndexReader^ reader,
    String^ fieldName,
    bool includeDocs
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The index reader to read from.
fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Index.FieldEnumerator`1.Init(Lucene.Net.Index.IndexReader,System.String,System.Boolean)"]

includeDocs
Type: System..::..Boolean
Whether this enumerator will support TermDocs.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Init Overload
Lucene.Net.Index Namespace


TryParse Method

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TryParse Method
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Method to attempt to parse out the value from the encoded string and sets the value of Current.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected abstract bool TryParse(
    string s
)
Visual Basic
Protected MustOverride Function TryParse ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParse(
    String^ s
) abstract

Parameters

s
Type: System..::..String
The encoded string.

Return Value

True if the value was successfully parsed, false if we reached the end of encoded values in the fiele and only the tries remain.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


FieldEnumerator(T) Properties

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)> Properties
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs.
Public property | Terms | Access the enumerator for the terms.

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


Docs Property

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..Docs Property
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Access the enumerator for the TermDocs.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermDocEnumerator..::..TermDocUsingTermsEnumerator Docs { get; }
Visual Basic
Public ReadOnly Property Docs As TermDocEnumerator..::..TermDocUsingTermsEnumerator
    Get
Visual C++
public:
property TermDocEnumerator..::..TermDocUsingTermsEnumerator^ Docs {
    TermDocEnumerator..::..TermDocUsingTermsEnumerator^ get ();
}

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


Terms Property

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..Terms Property
FieldEnumerator<(Of <(<'T>)>)> Class See Also Send Feedback
Access the enumerator for the terms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Terms { get; }
Visual Basic
Public ReadOnly Property Terms As FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator
    Get
Visual C++
public:
property FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator^ Terms {
    FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator^ get ();
}

See Also

FieldEnumerator<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


FieldEnumerator(T).TermEnumerator Class

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
FieldEnumerator<(Of <(<'T>)>)> Class Members See Also Send Feedback
The enumerator over the terms in an index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class TermEnumerator : IEnumerator<T>,
    IDisposable, IEnumerator, IEnumerable<T>, IEnumerable
Visual Basic
Public Class TermEnumerator _
    Implements IEnumerator(Of T), IDisposable, IEnumerator,  _
    IEnumerable(Of T), IEnumerable
Visual C++
public ref class TermEnumerator : IEnumerator<T>,
    IDisposable, IEnumerator, IEnumerable<T>, IEnumerable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Members
Lucene.Net.Index Namespace


FieldEnumerator(T).TermEnumerator Members

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Members
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class Constructors Methods Fields Properties See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator generic type exposes the following members.

Constructors

 | Name | Description
Public method | FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator | Ctor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Accessor to IEnumerator-T-."/>
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advance to the next item.
Public method | Reset | Reset the enumerator to the beginngin.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | fieldName | The field name, if any for the enum.

Properties

 | Name | Description
Public property | Current | The current item in the enumerator.

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


FieldEnumerator(T).TermEnumerator Constructor

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Constructor
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
Ctor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermEnumerator(
    TermEnum termEnum,
    TermDocs termDocs,
    string field,
    FieldEnumerator<T> enclosing
)
Visual Basic
Public Sub New ( _
    termEnum As TermEnum, _
    termDocs As TermDocs, _
    field As String, _
    enclosing As FieldEnumerator(Of T) _
)
Visual C++
public:
TermEnumerator(
    TermEnum^ termEnum,
    TermDocs^ termDocs,
    String^ field,
    FieldEnumerator<T>^ enclosing
)

Parameters

termEnum
Type: Lucene.Net.Index..::..TermEnum
The TermEnum to wrap.
termDocs
Type: Lucene.Net.Index..::..TermDocs
The TermDocs to wrap.
field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.FieldEnumerator`1.TermEnumerator.#ctor(Lucene.Net.Index.TermEnum,Lucene.Net.Index.TermDocs,System.String,Lucene.Net.Index.FieldEnumerator{`0})"]

enclosing
Type: Lucene.Net.Index..::..FieldEnumerator <(Of <(<' T >)>)>

[Missing <param name="enclosing"/> documentation for "M:Lucene.Net.Index.FieldEnumerator`1.TermEnumerator.#ctor(Lucene.Net.Index.TermEnum,Lucene.Net.Index.TermDocs,System.String,Lucene.Net.Index.FieldEnumerator{`0})"]

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


FieldEnumerator(T).TermEnumerator Fields

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Fields
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator generic type exposes the following members.

Fields

 | Name | Description
Protected field | fieldName | The field name, if any for the enum.

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


fieldName Field

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator..::..fieldName Field
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
The field name, if any for the enum.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected string fieldName
Visual Basic
Protected fieldName As String
Visual C++
protected:
String^ fieldName

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


FieldEnumerator(T).TermEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Methods
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator generic type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Accessor to IEnumerator-T-."/>
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advance to the next item.
Public method | Reset | Reset the enumerator to the beginngin.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator..::..Dispose Method
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
Releases all resources used by the FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


GetEnumerator Method

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator..::..GetEnumerator Method
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
Accessor to IEnumerator-T-."/>

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldEnumerator`1.TermEnumerator.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


MoveNext Method

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator..::..MoveNext Method
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
Advance to the next item.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldEnumerator`1.TermEnumerator.MoveNext"]

Implements

IEnumerator..::..MoveNext()()()()

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


Reset Method

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator..::..Reset Method
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
Reset the enumerator to the beginngin.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


FieldEnumerator(T).TermEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Properties
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback

The FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator generic type exposes the following members.

Properties

 | Name | Description
Public property | Current | The current item in the enumerator.

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


Current Property

[image]

Lucene.Net Class Libraries
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator..::..Current Property
FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class See Also Send Feedback
The current item in the enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public T Current { get; internal set; }
Visual Basic
Public Property Current As T
    Get
    Friend Set
Visual C++
public:
virtual property T Current {
    T get () sealed;
    internal: void set (T value) sealed;
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

FieldEnumerator<(Of <(<'T>)>)>..::..TermEnumerator Class
Lucene.Net.Index Namespace


FieldInfo Class

[image]

Lucene.Net Class Libraries
FieldInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.FieldInfo"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldInfo : ICloneable
Visual Basic
Public NotInheritable Class FieldInfo _
    Implements ICloneable
Visual C++
public ref class FieldInfo sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldInfo

See Also

FieldInfo Members
Lucene.Net.Index Namespace


FieldInfo Members

[image] [image]

Lucene.Net Class Libraries
FieldInfo Members
FieldInfo Class Methods Properties See Also Send Feedback

The FieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | isIndexed_ForNUnit |
Public property | name_ForNUnit |
Public property | omitNorms_ForNUnit |
Public property | omitTermFreqAndPositions_ForNUnit |
Public property | storePayloads_ForNUnit |
Public property | storeTermVector_ForNUnit |

See Also

FieldInfo Class
Lucene.Net.Index Namespace


FieldInfo Methods

[image] [image]

Lucene.Net Class Libraries
FieldInfo Methods
FieldInfo Class See Also Send Feedback

The FieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldInfo Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
FieldInfo..::..Clone Method
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfo.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfo.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

FieldInfo Class
Lucene.Net.Index Namespace


FieldInfo Properties

[image] [image]

Lucene.Net Class Libraries
FieldInfo Properties
FieldInfo Class See Also Send Feedback

The FieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | isIndexed_ForNUnit |
Public property | name_ForNUnit |
Public property | omitNorms_ForNUnit |
Public property | omitTermFreqAndPositions_ForNUnit |
Public property | storePayloads_ForNUnit |
Public property | storeTermVector_ForNUnit |

See Also

FieldInfo Class
Lucene.Net.Index Namespace


isIndexed_ForNUnit Property

[image]

Lucene.Net Class Libraries
FieldInfo..::..isIndexed_ForNUnit Property
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.FieldInfo.isIndexed_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool isIndexed_ForNUnit { get; }
Visual Basic
Public ReadOnly Property isIndexed_ForNUnit As Boolean
    Get
Visual C++
public:
property bool isIndexed_ForNUnit {
    bool get ();
}

See Also

FieldInfo Class
Lucene.Net.Index Namespace


name_ForNUnit Property

[image]

Lucene.Net Class Libraries
FieldInfo..::..name_ForNUnit Property
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.FieldInfo.name_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string name_ForNUnit { get; }
Visual Basic
Public ReadOnly Property name_ForNUnit As String
    Get
Visual C++
public:
property String^ name_ForNUnit {
    String^ get ();
}

See Also

FieldInfo Class
Lucene.Net.Index Namespace


omitNorms_ForNUnit Property

[image]

Lucene.Net Class Libraries
FieldInfo..::..omitNorms_ForNUnit Property
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.FieldInfo.omitNorms_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool omitNorms_ForNUnit { get; }
Visual Basic
Public ReadOnly Property omitNorms_ForNUnit As Boolean
    Get
Visual C++
public:
property bool omitNorms_ForNUnit {
    bool get ();
}

See Also

FieldInfo Class
Lucene.Net.Index Namespace


omitTermFreqAndPositions_ForNUnit Property

[image]

Lucene.Net Class Libraries
FieldInfo..::..omitTermFreqAndPositions_ForNUnit Property
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.FieldInfo.omitTermFreqAndPositions_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool omitTermFreqAndPositions_ForNUnit { get; }
Visual Basic
Public ReadOnly Property omitTermFreqAndPositions_ForNUnit As Boolean
    Get
Visual C++
public:
property bool omitTermFreqAndPositions_ForNUnit {
    bool get ();
}

See Also

FieldInfo Class
Lucene.Net.Index Namespace


storePayloads_ForNUnit Property

[image]

Lucene.Net Class Libraries
FieldInfo..::..storePayloads_ForNUnit Property
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.FieldInfo.storePayloads_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool storePayloads_ForNUnit { get; }
Visual Basic
Public ReadOnly Property storePayloads_ForNUnit As Boolean
    Get
Visual C++
public:
property bool storePayloads_ForNUnit {
    bool get ();
}

See Also

FieldInfo Class
Lucene.Net.Index Namespace


storeTermVector_ForNUnit Property

[image]

Lucene.Net Class Libraries
FieldInfo..::..storeTermVector_ForNUnit Property
FieldInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.FieldInfo.storeTermVector_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool storeTermVector_ForNUnit { get; }
Visual Basic
Public ReadOnly Property storeTermVector_ForNUnit As Boolean
    Get
Visual C++
public:
property bool storeTermVector_ForNUnit {
    bool get ();
}

See Also

FieldInfo Class
Lucene.Net.Index Namespace


FieldInfos Class

[image]

Lucene.Net Class Libraries
FieldInfos Class
Members See Also Send Feedback
Access to the Fieldable Info file that describes document fields and whether or not they are indexed. Each segment has a separate Fieldable Info file. Objects of this class are thread-safe for multiple readers, but only one thread can be adding documents at a time, with no other reader or writer threads accessing this object.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldInfos : ICloneable
Visual Basic
Public NotInheritable Class FieldInfos _
    Implements ICloneable
Visual C++
public ref class FieldInfos sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldInfos

See Also

FieldInfos Members
Lucene.Net.Index Namespace


FieldInfos Members

[image] [image]

Lucene.Net Class Libraries
FieldInfos Members
FieldInfos Class Constructors Methods Fields See Also Send Feedback

The FieldInfos type exposes the following members.

Constructors

 | Name | Description
Public method | FieldInfos()()()() | Initializes a new instance of the FieldInfos class
Public method | FieldInfos(Directory, String) | Construct a FieldInfos object using the directory and the name of the file IndexInput

Methods

 | Name | Description
Public method | Add(Document) | Adds field info for a Document.
Public method | Add(ICollection<(Of <<'(String>)>>), Boolean) | Assumes the fields are not storing term vectors.
Public method | Add(String, Boolean) | Calls 5 parameter add with false for all TermVector parameters.
Public method | Add(String, Boolean, Boolean) | Calls 5 parameter add with false for term vector positions and offsets.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | AddIndexed | Add fields that are indexed. Whether they have termvectors has to be specified.
Public method | Clone | Returns a deep clone of this FieldInfos instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FieldInfo(Int32) | Return the fieldinfo object referenced by the fieldNumber.
Public method | FieldInfo(String) |
Public method | FieldName | Return the fieldName identified by its number.
Public method | FieldNumber |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasVectors |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(IndexOutput) |
Public method | Write(Directory, String) |

Fields

Name | Description
FORMAT_PRE |
FORMAT_START |

See Also

FieldInfos Class
Lucene.Net.Index Namespace


FieldInfos Constructor

[image] [image]

Lucene.Net Class Libraries
FieldInfos Constructor
FieldInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldInfos()()()() | Initializes a new instance of the FieldInfos class
Public method | FieldInfos(Directory, String) | Construct a FieldInfos object using the directory and the name of the file IndexInput

See Also

FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace


FieldInfos Constructor

[image]

Lucene.Net Class Libraries
FieldInfos Constructor
FieldInfos Class See Also Send Feedback
Initializes a new instance of the FieldInfos class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInfos()
Visual Basic
Public Sub New
Visual C++
public:
FieldInfos()

See Also

FieldInfos Class
FieldInfos Overload
Lucene.Net.Index Namespace


FieldInfos Constructor (Directory, String)

[image]

Lucene.Net Class Libraries
FieldInfos Constructor (Directory, String)
FieldInfos Class See Also Send Feedback
Construct a FieldInfos object using the directory and the name of the file IndexInput

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInfos(
    Directory d,
    string name
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    name As String _
)
Visual C++
public:
FieldInfos(
    Directory^ d,
    String^ name
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
The directory to open the IndexInput from
name
Type: System..::..String
The name of the file to open the IndexInput from in the Directory

See Also

FieldInfos Class
FieldInfos Overload
Lucene.Net.Index Namespace


FieldInfos Fields

[image] [image]

Lucene.Net Class Libraries
FieldInfos Fields
FieldInfos Class See Also Send Feedback

The FieldInfos type exposes the following members.

Fields

Name | Description
FORMAT_PRE |
FORMAT_START |

See Also

FieldInfos Class
Lucene.Net.Index Namespace


FORMAT_PRE Field

[image]

Lucene.Net Class Libraries
FieldInfos..::..FORMAT_PRE Field
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.FieldInfos.FORMAT_PRE"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_PRE
Visual Basic
Public Const FORMAT_PRE As Integer
Visual C++
public:
literal int FORMAT_PRE

See Also

FieldInfos Class
Lucene.Net.Index Namespace


FORMAT_START Field

[image]

Lucene.Net Class Libraries
FieldInfos..::..FORMAT_START Field
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.FieldInfos.FORMAT_START"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_START
Visual Basic
Public Const FORMAT_START As Integer
Visual C++
public:
literal int FORMAT_START

See Also

FieldInfos Class
Lucene.Net.Index Namespace


FieldInfos Methods

[image] [image]

Lucene.Net Class Libraries
FieldInfos Methods
FieldInfos Class See Also Send Feedback

The FieldInfos type exposes the following members.

Methods

 | Name | Description
Public method | Add(Document) | Adds field info for a Document.
Public method | Add(ICollection<(Of <<'(String>)>>), Boolean) | Assumes the fields are not storing term vectors.
Public method | Add(String, Boolean) | Calls 5 parameter add with false for all TermVector parameters.
Public method | Add(String, Boolean, Boolean) | Calls 5 parameter add with false for term vector positions and offsets.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | AddIndexed | Add fields that are indexed. Whether they have termvectors has to be specified.
Public method | Clone | Returns a deep clone of this FieldInfos instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FieldInfo(Int32) | Return the fieldinfo object referenced by the fieldNumber.
Public method | FieldInfo(String) |
Public method | FieldName | Return the fieldName identified by its number.
Public method | FieldNumber |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasVectors |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(IndexOutput) |
Public method | Write(Directory, String) |

See Also

FieldInfos Class
Lucene.Net.Index Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method
FieldInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Document) | Adds field info for a Document.
Public method | Add(ICollection<(Of <<'(String>)>>), Boolean) | Assumes the fields are not storing term vectors.
Public method | Add(String, Boolean) | Calls 5 parameter add with false for all TermVector parameters.
Public method | Add(String, Boolean, Boolean) | Calls 5 parameter add with false for term vector positions and offsets.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.
Public method | Add(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

See Also

FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace


Add Method (Document)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (Document)
FieldInfos Class See Also Send Feedback
Adds field info for a Document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    Document doc
)
Visual Basic
Public Sub Add ( _
    doc As Document _
)
Visual C++
public:
void Add(
    Document^ doc
)

Parameters

doc
Type: Lucene.Net.Documents..::..Document

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.FieldInfos.Add(Lucene.Net.Documents.Document)"]

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace


Add Method (ICollection(String), Boolean)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (ICollection<(Of <(<'String>)>)>, Boolean)
FieldInfos Class See Also Send Feedback
Assumes the fields are not storing term vectors.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    ICollection<string> names,
    bool isIndexed
)
Visual Basic
Public Sub Add ( _
    names As ICollection(Of String), _
    isIndexed As Boolean _
)
Visual C++
public:
void Add(
    ICollection<String^>^ names,
    bool isIndexed
)

Parameters

names
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
The names of the fields
isIndexed
Type: System..::..Boolean
Whether the fields are indexed or not

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace
[!:Add(String, boolean)]


Add Method (String, Boolean)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (String, Boolean)
FieldInfos Class See Also Send Feedback
Calls 5 parameter add with false for all TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    string name,
    bool isIndexed
)
Visual Basic
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean _
)
Visual C++
public:
void Add(
    String^ name,
    bool isIndexed
)

Parameters

name
Type: System..::..String
The name of the Fieldable
isIndexed
Type: System..::..Boolean
true if the field is indexed

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace
[!:Add(String, boolean, boolean, boolean, boolean)]


Add Method (String, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (String, Boolean, Boolean)
FieldInfos Class See Also Send Feedback
Calls 5 parameter add with false for term vector positions and offsets.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector
)
Visual Basic
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean _
)
Visual C++
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector
)

Parameters

name
Type: System..::..String
The name of the field
isIndexed
Type: System..::..Boolean
true if the field is indexed
storeTermVector
Type: System..::..Boolean
true if the term vector should be stored

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace


Add Method (String, Boolean, Boolean, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (String, Boolean, Boolean, Boolean, Boolean)
FieldInfos Class See Also Send Feedback
If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
Visual Basic
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean _
)
Visual C++
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)

Parameters

name
Type: System..::..String
The name of the field
isIndexed
Type: System..::..Boolean
true if the field is indexed
storeTermVector
Type: System..::..Boolean
true if the term vector should be stored
storePositionWithTermVector
Type: System..::..Boolean
true if the term vector with positions should be stored
storeOffsetWithTermVector
Type: System..::..Boolean
true if the term vector with offsets should be stored

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace


Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean)
FieldInfos Class See Also Send Feedback
If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms
)
Visual Basic
Public Sub Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean, _
    omitNorms As Boolean _
)
Visual C++
public:
void Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms
)

Parameters

name
Type: System..::..String
The name of the field
isIndexed
Type: System..::..Boolean
true if the field is indexed
storeTermVector
Type: System..::..Boolean
true if the term vector should be stored
storePositionWithTermVector
Type: System..::..Boolean
true if the term vector with positions should be stored
storeOffsetWithTermVector
Type: System..::..Boolean
true if the term vector with offsets should be stored
omitNorms
Type: System..::..Boolean
true if the norms for the indexed field should be omitted

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace


Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Add Method (String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
FieldInfos Class See Also Send Feedback
If the field is not yet known, adds it. If it is known, checks to make sure that the isIndexed flag is the same as was given previously for this field. If not - marks it as being indexed. Same goes for the TermVector parameters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInfo Add(
    string name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms,
    bool storePayloads,
    bool omitTermFreqAndPositions
)
Visual Basic
Public Function Add ( _
    name As String, _
    isIndexed As Boolean, _
    storeTermVector As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean, _
    omitNorms As Boolean, _
    storePayloads As Boolean, _
    omitTermFreqAndPositions As Boolean _
) As FieldInfo
Visual C++
public:
FieldInfo^ Add(
    String^ name,
    bool isIndexed,
    bool storeTermVector,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector,
    bool omitNorms,
    bool storePayloads,
    bool omitTermFreqAndPositions
)

Parameters

name
Type: System..::..String
The name of the field
isIndexed
Type: System..::..Boolean
true if the field is indexed
storeTermVector
Type: System..::..Boolean
true if the term vector should be stored
storePositionWithTermVector
Type: System..::..Boolean
true if the term vector with positions should be stored
storeOffsetWithTermVector
Type: System..::..Boolean
true if the term vector with offsets should be stored
omitNorms
Type: System..::..Boolean
true if the norms for the indexed field should be omitted
storePayloads
Type: System..::..Boolean
true if payloads should be stored for this field
omitTermFreqAndPositions
Type: System..::..Boolean
true if term freqs should be omitted for this field

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfos.Add(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean)"]

See Also

FieldInfos Class
Add Overload
Lucene.Net.Index Namespace


AddIndexed Method

[image]

Lucene.Net Class Libraries
FieldInfos..::..AddIndexed Method
FieldInfos Class See Also Send Feedback
Add fields that are indexed. Whether they have termvectors has to be specified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void AddIndexed(
    ICollection names,
    bool storeTermVectors,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)
Visual Basic
Public Sub AddIndexed ( _
    names As ICollection, _
    storeTermVectors As Boolean, _
    storePositionWithTermVector As Boolean, _
    storeOffsetWithTermVector As Boolean _
)
Visual C++
public:
void AddIndexed(
    ICollection^ names,
    bool storeTermVectors,
    bool storePositionWithTermVector,
    bool storeOffsetWithTermVector
)

Parameters

names
Type: System.Collections..::..ICollection
The names of the fields
storeTermVectors
Type: System..::..Boolean
Whether the fields store term vectors or not
storePositionWithTermVector
Type: System..::..Boolean
true if positions should be stored.
storeOffsetWithTermVector
Type: System..::..Boolean
true if offsets should be stored

See Also

FieldInfos Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
FieldInfos..::..Clone Method
FieldInfos Class See Also Send Feedback
Returns a deep clone of this FieldInfos instance.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfos.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

FieldInfos Class
Lucene.Net.Index Namespace


FieldInfo Method

[image] [image]

Lucene.Net Class Libraries
FieldInfos..::..FieldInfo Method
FieldInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldInfo(Int32) | Return the fieldinfo object referenced by the fieldNumber.
Public method | FieldInfo(String) |

See Also

FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace


FieldInfo Method (Int32)

[image]

Lucene.Net Class Libraries
FieldInfos..::..FieldInfo Method (Int32)
FieldInfos Class See Also Send Feedback
Return the fieldinfo object referenced by the fieldNumber.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInfo FieldInfo(
    int fieldNumber
)
Visual Basic
Public Function FieldInfo ( _
    fieldNumber As Integer _
) As FieldInfo
Visual C++
public:
FieldInfo^ FieldInfo(
    int fieldNumber
)

Parameters

fieldNumber
Type: System..::..Int32

[Missing <param name="fieldNumber"/> documentation for "M:Lucene.Net.Index.FieldInfos.FieldInfo(System.Int32)"]

Return Value

the FieldInfo object or null when the given fieldNumber doesn't exist.

See Also

FieldInfos Class
FieldInfo Overload
Lucene.Net.Index Namespace


FieldInfo Method (String)

[image]

Lucene.Net Class Libraries
FieldInfos..::..FieldInfo Method (String)
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfos.FieldInfo(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInfo FieldInfo(
    string fieldName
)
Visual Basic
Public Function FieldInfo ( _
    fieldName As String _
) As FieldInfo
Visual C++
public:
FieldInfo^ FieldInfo(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Index.FieldInfos.FieldInfo(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfos.FieldInfo(System.String)"]

See Also

FieldInfos Class
FieldInfo Overload
Lucene.Net.Index Namespace


FieldName Method

[image]

Lucene.Net Class Libraries
FieldInfos..::..FieldName Method
FieldInfos Class See Also Send Feedback
Return the fieldName identified by its number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string FieldName(
    int fieldNumber
)
Visual Basic
Public Function FieldName ( _
    fieldNumber As Integer _
) As String
Visual C++
public:
String^ FieldName(
    int fieldNumber
)

Parameters

fieldNumber
Type: System..::..Int32

[Missing <param name="fieldNumber"/> documentation for "M:Lucene.Net.Index.FieldInfos.FieldName(System.Int32)"]

Return Value

the fieldName or an empty string when the field with the given number doesn't exist.

See Also

FieldInfos Class
Lucene.Net.Index Namespace


FieldNumber Method

[image]

Lucene.Net Class Libraries
FieldInfos..::..FieldNumber Method
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfos.FieldNumber(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int FieldNumber(
    string fieldName
)
Visual Basic
Public Function FieldNumber ( _
    fieldName As String _
) As Integer
Visual C++
public:
int FieldNumber(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Index.FieldInfos.FieldNumber(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfos.FieldNumber(System.String)"]

See Also

FieldInfos Class
Lucene.Net.Index Namespace


HasVectors Method

[image]

Lucene.Net Class Libraries
FieldInfos..::..HasVectors Method
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfos.HasVectors"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool HasVectors()
Visual Basic
Public Function HasVectors As Boolean
Visual C++
public:
bool HasVectors()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfos.HasVectors"]

See Also

FieldInfos Class
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
FieldInfos..::..Size Method
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfos.Size"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInfos.Size"]

See Also

FieldInfos Class
Lucene.Net.Index Namespace


Write Method

[image] [image]

Lucene.Net Class Libraries
FieldInfos..::..Write Method
FieldInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(IndexOutput) |
Public method | Write(Directory, String) |

See Also

FieldInfos Class
FieldInfos Members
Lucene.Net.Index Namespace


Write Method (IndexOutput)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Write Method (IndexOutput)
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfos.Write(Lucene.Net.Store.IndexOutput)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Write(
    IndexOutput output
)
Visual Basic
Public Sub Write ( _
    output As IndexOutput _
)
Visual C++
public:
void Write(
    IndexOutput^ output
)

Parameters

output
Type: Lucene.Net.Store..::..IndexOutput

[Missing <param name="output"/> documentation for "M:Lucene.Net.Index.FieldInfos.Write(Lucene.Net.Store.IndexOutput)"]

See Also

FieldInfos Class
Write Overload
Lucene.Net.Index Namespace


Write Method (Directory, String)

[image]

Lucene.Net Class Libraries
FieldInfos..::..Write Method (Directory, String)
FieldInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInfos.Write(Lucene.Net.Store.Directory,System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Write(
    Directory d,
    string name
)
Visual Basic
Public Sub Write ( _
    d As Directory, _
    name As String _
)
Visual C++
public:
void Write(
    Directory^ d,
    String^ name
)

Parameters

d
Type: Lucene.Net.Store..::..Directory

[Missing <param name="d"/> documentation for "M:Lucene.Net.Index.FieldInfos.Write(Lucene.Net.Store.Directory,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.FieldInfos.Write(Lucene.Net.Store.Directory,System.String)"]

See Also

FieldInfos Class
Write Overload
Lucene.Net.Index Namespace


FieldInvertState Class

[image]

Lucene.Net Class Libraries
FieldInvertState Class
Members See Also Send Feedback
This class tracks the number and position / offset parameters of terms being added to the index. The information collected in this class is also used to calculate the normalization factor for a field.

WARNING: This API is new and experimental, and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldInvertState
Visual Basic
Public NotInheritable Class FieldInvertState
Visual C++
public ref class FieldInvertState sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldInvertState

See Also

FieldInvertState Members
Lucene.Net.Index Namespace


FieldInvertState Members

[image] [image]

Lucene.Net Class Libraries
FieldInvertState Members
FieldInvertState Class Constructors Methods See Also Send Feedback

The FieldInvertState type exposes the following members.

Constructors

 | Name | Description
Public method | FieldInvertState()()()() | Initializes a new instance of the FieldInvertState class
Public method | FieldInvertState(Int32, Int32, Int32, Int32, Single) | Initializes a new instance of the FieldInvertState class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetAttributeSource
Public method GetBoost
Get boost value. This is the cumulative product of document boost and field boost for all field instances sharing the same field name.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLength
Get total number of terms in this field.
Public method GetNumOverlap
Get the number of terms with
CopyC#
positionIncrement == 0
.
Public method GetOffset
Get end offset of the last processed term.
Public method GetPosition
Get the last processed term position.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


FieldInvertState Constructor

[image] [image]

Lucene.Net Class Libraries
FieldInvertState Constructor
FieldInvertState Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldInvertState()()()() | Initializes a new instance of the FieldInvertState class
Public method | FieldInvertState(Int32, Int32, Int32, Int32, Single) | Initializes a new instance of the FieldInvertState class

See Also

FieldInvertState Class
FieldInvertState Members
Lucene.Net.Index Namespace


FieldInvertState Constructor

[image]

Lucene.Net Class Libraries
FieldInvertState Constructor
FieldInvertState Class See Also Send Feedback
Initializes a new instance of the FieldInvertState class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInvertState()
Visual Basic
Public Sub New
Visual C++
public:
FieldInvertState()

See Also

FieldInvertState Class
FieldInvertState Overload
Lucene.Net.Index Namespace


FieldInvertState Constructor (Int32, Int32, Int32, Int32, Single)

[image]

Lucene.Net Class Libraries
FieldInvertState Constructor (Int32, Int32, Int32, Int32, Single)
FieldInvertState Class See Also Send Feedback
Initializes a new instance of the FieldInvertState class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInvertState(
    int position,
    int length,
    int numOverlap,
    int offset,
    float boost
)
Visual Basic
Public Sub New ( _
    position As Integer, _
    length As Integer, _
    numOverlap As Integer, _
    offset As Integer, _
    boost As Single _
)
Visual C++
public:
FieldInvertState(
    int position,
    int length,
    int numOverlap,
    int offset,
    float boost
)

Parameters

position
Type: System..::..Int32

[Missing <param name="position"/> documentation for "M:Lucene.Net.Index.FieldInvertState.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Single)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Index.FieldInvertState.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Single)"]

numOverlap
Type: System..::..Int32

[Missing <param name="numOverlap"/> documentation for "M:Lucene.Net.Index.FieldInvertState.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Single)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.FieldInvertState.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Single)"]

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Index.FieldInvertState.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Single)"]

See Also

FieldInvertState Class
FieldInvertState Overload
Lucene.Net.Index Namespace


FieldInvertState Methods

[image] [image]

Lucene.Net Class Libraries
FieldInvertState Methods
FieldInvertState Class See Also Send Feedback

The FieldInvertState type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetAttributeSource
Public method GetBoost
Get boost value. This is the cumulative product of document boost and field boost for all field instances sharing the same field name.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLength
Get total number of terms in this field.
Public method GetNumOverlap
Get the number of terms with
CopyC#
positionIncrement == 0
.
Public method GetOffset
Get end offset of the last processed term.
Public method GetPosition
Get the last processed term position.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


GetAttributeSource Method

[image]

Lucene.Net Class Libraries
FieldInvertState..::..GetAttributeSource Method
FieldInvertState Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldInvertState.GetAttributeSource"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AttributeSource GetAttributeSource()
Visual Basic
Public Function GetAttributeSource As AttributeSource
Visual C++
public:
AttributeSource^ GetAttributeSource()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldInvertState.GetAttributeSource"]

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


GetBoost Method

[image]

Lucene.Net Class Libraries
FieldInvertState..::..GetBoost Method
FieldInvertState Class See Also Send Feedback
Get boost value. This is the cumulative product of document boost and field boost for all field instances sharing the same field name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float GetBoost()
Visual Basic
Public Function GetBoost As Single
Visual C++
public:
float GetBoost()

Return Value

the boost

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


GetLength Method

[image]

Lucene.Net Class Libraries
FieldInvertState..::..GetLength Method
FieldInvertState Class See Also Send Feedback
Get total number of terms in this field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetLength()
Visual Basic
Public Function GetLength As Integer
Visual C++
public:
int GetLength()

Return Value

the length

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


GetNumOverlap Method

[image]

Lucene.Net Class Libraries
FieldInvertState..::..GetNumOverlap Method
FieldInvertState Class See Also Send Feedback
Get the number of terms with
CopyC#
positionIncrement == 0
.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetNumOverlap()
Visual Basic
Public Function GetNumOverlap As Integer
Visual C++
public:
int GetNumOverlap()

Return Value

the numOverlap

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


GetOffset Method

[image]

Lucene.Net Class Libraries
FieldInvertState..::..GetOffset Method
FieldInvertState Class See Also Send Feedback
Get end offset of the last processed term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetOffset()
Visual Basic
Public Function GetOffset As Integer
Visual C++
public:
int GetOffset()

Return Value

the offset

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


GetPosition Method

[image]

Lucene.Net Class Libraries
FieldInvertState..::..GetPosition Method
FieldInvertState Class See Also Send Feedback
Get the last processed term position.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetPosition()
Visual Basic
Public Function GetPosition As Integer
Visual C++
public:
int GetPosition()

Return Value

the position

See Also

FieldInvertState Class
Lucene.Net.Index Namespace


FieldParser Enumeration

[image]

Lucene.Net Class Libraries
FieldParser Enumeration
See Also Send Feedback
The type of parser for the value of the term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public enum FieldParser
Visual Basic
Public Enumeration FieldParser
Visual C++
public enum class FieldParser

Members

Member name | Value | Description
String | 0 |
Numeric | 1 |

See Also

Lucene.Net.Index Namespace


FieldReaderException Class

[image]

Lucene.Net Class Libraries
FieldReaderException Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.FieldReaderException"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FieldReaderException : SystemException
Visual Basic
<SerializableAttribute> _
Public Class FieldReaderException _
    Inherits SystemException
Visual C++
[SerializableAttribute]
public ref class FieldReaderException : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Lucene.Net.Index..::..FieldReaderException

See Also

FieldReaderException Members
Lucene.Net.Index Namespace


FieldReaderException Members

[image] [image]

Lucene.Net Class Libraries
FieldReaderException Members
FieldReaderException Class Constructors Methods Properties Events See Also Send Feedback

The FieldReaderException type exposes the following members.

Constructors

Name Description
Public method FieldReaderException()()()()
Constructs a new runtime exception with
CopyC#
null
 as its detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #innerException}.
Public method FieldReaderException(Exception)
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.

Public method FieldReaderException(String)
Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #innerException}.
Public method FieldReaderException(String, Exception)
Constructs a new runtime exception with the specified detail message and cause.

Note that the detail message associated with

CopyC#
cause
is not automatically incorporated in this runtime exception's detail message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FieldReaderException Class
Lucene.Net.Index Namespace


FieldReaderException Constructor

[image] [image]

Lucene.Net Class Libraries
FieldReaderException Constructor
FieldReaderException Class See Also Send Feedback

Overload List

Name Description
Public method FieldReaderException()()()()
Constructs a new runtime exception with
CopyC#
null
 as its detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #innerException}.
Public method FieldReaderException(Exception)
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.

Public method FieldReaderException(String)
Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #innerException}.
Public method FieldReaderException(String, Exception)
Constructs a new runtime exception with the specified detail message and cause.

Note that the detail message associated with

CopyC#
cause
is not automatically incorporated in this runtime exception's detail message.

See Also

FieldReaderException Class
FieldReaderException Members
Lucene.Net.Index Namespace


FieldReaderException Constructor

[image]

Lucene.Net Class Libraries
FieldReaderException Constructor
FieldReaderException Class See Also Send Feedback
Constructs a new runtime exception with
CopyC#
null
 as its detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #innerException}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldReaderException()
Visual Basic
Public Sub New
Visual C++
public:
FieldReaderException()

See Also

FieldReaderException Class
FieldReaderException Overload
Lucene.Net.Index Namespace


FieldReaderException Constructor (Exception)

[image]

Lucene.Net Class Libraries
FieldReaderException Constructor (Exception)
FieldReaderException Class See Also Send Feedback
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldReaderException(
    Exception cause
)
Visual Basic
Public Sub New ( _
    cause As Exception _
)
Visual C++
public:
FieldReaderException(
    Exception^ cause
)

Parameters

cause
Type: System..::..Exception
the cause (which is saved for later retrieval by the {@link #InnerException()} method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

See Also

FieldReaderException Class
FieldReaderException Overload
Lucene.Net.Index Namespace


FieldReaderException Constructor (String)

[image]

Lucene.Net Class Libraries
FieldReaderException Constructor (String)
FieldReaderException Class See Also Send Feedback
Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to {@link #innerException}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldReaderException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
FieldReaderException(
    String^ message
)

Parameters

message
Type: System..::..String
the detail message. The detail message is saved for later retrieval by the {@link #getMessage()} method.

See Also

FieldReaderException Class
FieldReaderException Overload
Lucene.Net.Index Namespace


FieldReaderException Constructor (String, Exception)

[image]

Lucene.Net Class Libraries
FieldReaderException Constructor (String, Exception)
FieldReaderException Class See Also Send Feedback
Constructs a new runtime exception with the specified detail message and cause.

Note that the detail message associated with

CopyC#
cause
is not automatically incorporated in this runtime exception's detail message.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldReaderException(
    string message,
    Exception cause
)
Visual Basic
Public Sub New ( _
    message As String, _
    cause As Exception _
)
Visual C++
public:
FieldReaderException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: System..::..String
the detail message (which is saved for later retrieval by the {@link #getMessage()} method).
cause
Type: System..::..Exception
the cause (which is saved for later retrieval by the {@link #InnerException()} method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

See Also

FieldReaderException Class
FieldReaderException Overload
Lucene.Net.Index Namespace


FieldReaderException Methods

[image] [image]

Lucene.Net Class Libraries
FieldReaderException Methods
FieldReaderException Class See Also Send Feedback

The FieldReaderException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FieldReaderException Class
Lucene.Net.Index Namespace


FieldReaderException Properties

[image] [image]

Lucene.Net Class Libraries
FieldReaderException Properties
FieldReaderException Class See Also Send Feedback

The FieldReaderException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FieldReaderException Class
Lucene.Net.Index Namespace


FieldReaderException Events

[image] [image]

Lucene.Net Class Libraries
FieldReaderException Events
FieldReaderException Class See Also Send Feedback

The FieldReaderException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FieldReaderException Class
Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Class

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper Class
Members See Also Send Feedback
For each Field, store a sorted collection of {@link TermVectorEntry}s

This is not thread-safe.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FieldSortedTermVectorMapper : TermVectorMapper
Visual Basic
Public Class FieldSortedTermVectorMapper _
    Inherits TermVectorMapper
Visual C++
public ref class FieldSortedTermVectorMapper : public TermVectorMapper

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorMapper
Lucene.Net.Index..::..FieldSortedTermVectorMapper

See Also

FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Members

[image] [image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper Members
FieldSortedTermVectorMapper Class Constructors Methods See Also Send Feedback

The FieldSortedTermVectorMapper type exposes the following members.

Constructors

 | Name | Description
Public method | FieldSortedTermVectorMapper(IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the FieldSortedTermVectorMapper class
Public method | FieldSortedTermVectorMapper(Boolean, Boolean, IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the FieldSortedTermVectorMapper class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComparator |
Public method | GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public method | Map | (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Constructor

[image] [image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper Constructor
FieldSortedTermVectorMapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldSortedTermVectorMapper(IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the FieldSortedTermVectorMapper class
Public method | FieldSortedTermVectorMapper(Boolean, Boolean, IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the FieldSortedTermVectorMapper class

See Also

FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Members
Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Constructor (IComparer(Object))

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper Constructor (IComparer<(Of <(<'Object>)>)>)
FieldSortedTermVectorMapper Class See Also Send Feedback
Initializes a new instance of the FieldSortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldSortedTermVectorMapper(
    IComparer<Object> comparator
)
Visual Basic
Public Sub New ( _
    comparator As IComparer(Of Object) _
)
Visual C++
public:
FieldSortedTermVectorMapper(
    IComparer<Object^>^ comparator
)

Parameters

comparator
Type: System.Collections.Generic..::..IComparer <(Of <(<' Object >)>)>
A Comparator for sorting {@link TermVectorEntry}s

See Also

FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Overload
Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Constructor (Boolean, Boolean, IComparer(Object))

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper Constructor (Boolean, Boolean, IComparer<(Of <(<'Object>)>)>)
FieldSortedTermVectorMapper Class See Also Send Feedback
Initializes a new instance of the FieldSortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldSortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<Object> comparator
)
Visual Basic
Public Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean, _
    comparator As IComparer(Of Object) _
)
Visual C++
public:
FieldSortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<Object^>^ comparator
)

Parameters

ignoringPositions
Type: System..::..Boolean

[Missing <param name="ignoringPositions"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.#ctor(System.Boolean,System.Boolean,System.Collections.Generic.IComparer{System.Object})"]

ignoringOffsets
Type: System..::..Boolean

[Missing <param name="ignoringOffsets"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.#ctor(System.Boolean,System.Boolean,System.Collections.Generic.IComparer{System.Object})"]

comparator
Type: System.Collections.Generic..::..IComparer <(Of <(<' Object >)>)>

[Missing <param name="comparator"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.#ctor(System.Boolean,System.Boolean,System.Collections.Generic.IComparer{System.Object})"]

See Also

FieldSortedTermVectorMapper Class
FieldSortedTermVectorMapper Overload
Lucene.Net.Index Namespace


FieldSortedTermVectorMapper Methods

[image] [image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper Methods
FieldSortedTermVectorMapper Class See Also Send Feedback

The FieldSortedTermVectorMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComparator |
Public method | GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public method | Map | (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace


GetComparator Method

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper..::..GetComparator Method
FieldSortedTermVectorMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.GetComparator"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IComparer<Object> GetComparator()
Visual Basic
Public Overridable Function GetComparator As IComparer(Of Object)
Visual C++
public:
virtual IComparer<Object^>^ GetComparator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.GetComparator"]

See Also

FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace


GetFieldToTerms Method

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper..::..GetFieldToTerms Method
FieldSortedTermVectorMapper Class See Also Send Feedback
Get the mapping between fields and terms, sorted by the comparator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IDictionary GetFieldToTerms()
Visual Basic
Public Overridable Function GetFieldToTerms As IDictionary
Visual C++
public:
virtual IDictionary^ GetFieldToTerms()

Return Value

A map between field names and {@link java.util.SortedSet}s per field. SortedSet entries are {@link TermVectorEntry}

See Also

FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace


Map Method

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper..::..Map Method
FieldSortedTermVectorMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Visual Basic
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Visual C++
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo^>^ offsets,
    array<int>^ positions
) override

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

frequency
Type: System..::..Int32

[Missing <param name="frequency"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

offsets
Type: array< Lucene.Net.Index..::..TermVectorOffsetInfo >[]()[][]

[Missing <param name="offsets"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

positions
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="positions"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

See Also

FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace


SetExpectations Method

[image]

Lucene.Net Class Libraries
FieldSortedTermVectorMapper..::..SetExpectations Method
FieldSortedTermVectorMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Visual Basic
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Visual C++
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

numTerms
Type: System..::..Int32

[Missing <param name="numTerms"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

storeOffsets
Type: System..::..Boolean

[Missing <param name="storeOffsets"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

storePositions
Type: System..::..Boolean

[Missing <param name="storePositions"/> documentation for "M:Lucene.Net.Index.FieldSortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

See Also

FieldSortedTermVectorMapper Class
Lucene.Net.Index Namespace


FieldsReader Class

[image]

Lucene.Net Class Libraries
FieldsReader Class
Members See Also Send Feedback
Class responsible for access to stored document fields.

It uses <segment>.fdt and <segment>.fdx; files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldsReader : ICloneable
Visual Basic
Public NotInheritable Class FieldsReader _
    Implements ICloneable
Visual C++
public ref class FieldsReader sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldsReader

See Also

FieldsReader Members
Lucene.Net.Index Namespace


FieldsReader Members

[image] [image]

Lucene.Net Class Libraries
FieldsReader Members
FieldsReader Class Constructors Methods See Also Send Feedback

The FieldsReader type exposes the following members.

Constructors

 | Name | Description
Public method | FieldsReader | Initializes a new instance of the FieldsReader class

Methods

 | Name | Description
Public method | Clone | Returns a cloned FieldsReader that shares open IndexInputs with the original one. It is the caller's job not to close the original FieldsReader until all clones are called (eg, currently SegmentReader manages this logic).
Public method | Close | Closes the underlying {@link Lucene.Net.Store.IndexInput} streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldsReader Class
Lucene.Net.Index Namespace


FieldsReader Constructor

[image]

Lucene.Net Class Libraries
FieldsReader Constructor
FieldsReader Class See Also Send Feedback
Initializes a new instance of the FieldsReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldsReader(
    Directory d,
    string segment,
    FieldInfos fn
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    segment As String, _
    fn As FieldInfos _
)
Visual C++
public:
FieldsReader(
    Directory^ d,
    String^ segment,
    FieldInfos^ fn
)

Parameters

d
Type: Lucene.Net.Store..::..Directory

[Missing <param name="d"/> documentation for "M:Lucene.Net.Index.FieldsReader.#ctor(Lucene.Net.Store.Directory,System.String,Lucene.Net.Index.FieldInfos)"]

segment
Type: System..::..String

[Missing <param name="segment"/> documentation for "M:Lucene.Net.Index.FieldsReader.#ctor(Lucene.Net.Store.Directory,System.String,Lucene.Net.Index.FieldInfos)"]

fn
Type: Lucene.Net.Index..::..FieldInfos

[Missing <param name="fn"/> documentation for "M:Lucene.Net.Index.FieldsReader.#ctor(Lucene.Net.Store.Directory,System.String,Lucene.Net.Index.FieldInfos)"]

See Also

FieldsReader Class
Lucene.Net.Index Namespace


FieldsReader Methods

[image] [image]

Lucene.Net Class Libraries
FieldsReader Methods
FieldsReader Class See Also Send Feedback

The FieldsReader type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a cloned FieldsReader that shares open IndexInputs with the original one. It is the caller's job not to close the original FieldsReader until all clones are called (eg, currently SegmentReader manages this logic).
Public method | Close | Closes the underlying {@link Lucene.Net.Store.IndexInput} streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldsReader Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
FieldsReader..::..Clone Method
FieldsReader Class See Also Send Feedback
Returns a cloned FieldsReader that shares open IndexInputs with the original one. It is the caller's job not to close the original FieldsReader until all clones are called (eg, currently SegmentReader manages this logic).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldsReader.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

FieldsReader Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
FieldsReader..::..Close Method
FieldsReader Class See Also Send Feedback
Closes the underlying {@link Lucene.Net.Store.IndexInput} streams, including any ones associated with a lazy implementation of a Field. This means that the Fields values will not be accessible.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

FieldsReader Class
Lucene.Net.Index Namespace


Doc Method

[image]

Lucene.Net Class Libraries
FieldsReader..::..Doc Method
FieldsReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldsReader.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Document Doc(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.FieldsReader.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Index.FieldsReader.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldsReader.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

See Also

FieldsReader Class
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
FieldsReader..::..Size Method
FieldsReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FieldsReader.Size"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FieldsReader.Size"]

See Also

FieldsReader Class
Lucene.Net.Index Namespace


FilterIndexReader Class

[image]

Lucene.Net Class Libraries
FilterIndexReader Class
Members See Also Send Feedback
A
CopyC#
FilterIndexReader
 contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
CopyC#
FilterIndexReader
 itself simply implements all abstract methods of
CopyC#
IndexReader
 with versions that pass all requests to the contained index reader. Subclasses of
CopyC#
FilterIndexReader
 may further override some of these methods and may also provide additional methods and fields.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FilterIndexReader : IndexReader
Visual Basic
Public Class FilterIndexReader _
    Inherits IndexReader
Visual C++
public ref class FilterIndexReader : public IndexReader

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..FilterIndexReader

See Also

FilterIndexReader Members
Lucene.Net.Index Namespace


FilterIndexReader Members

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader Members
FilterIndexReader Class Constructors Methods Fields Properties See Also Send Feedback

The FilterIndexReader type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIndexReader | Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader. Note that base reader is closed if this FilterIndexReader is closed.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method | Directory | (Overrides IndexReader..::..Directory()()()().)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method GetDeletesCacheKey
If the subclass of FilteredIndexReader modifies the deleted docs, you must override this method to provide a different key */
(Overrides IndexReader..::..GetDeletesCacheKey()()()().)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey
If the subclass of FilteredIndexReader modifies the contents of the FieldCache, you must override this method to provide a different key */
(Overrides IndexReader..::..GetFieldCacheKey()()()().)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Overrides IndexReader..::..GetSequentialSubReaders()()()().)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

(Inherited from IndexReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method | GetVersion | (Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader..::..IsOptimized()()()().)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | in_Renamed |

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


FilterIndexReader Constructor

[image]

Lucene.Net Class Libraries
FilterIndexReader Constructor
FilterIndexReader Class See Also Send Feedback

Construct a FilterIndexReader based on the specified base reader. Directory locking for delete, undeleteAll, and setNorm operations is left to the base reader.

Note that base reader is closed if this FilterIndexReader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterIndexReader(
    IndexReader in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As IndexReader _
)
Visual C++
public:
FilterIndexReader(
    IndexReader^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.#ctor(Lucene.Net.Index.IndexReader)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


FilterIndexReader Fields

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader Fields
FilterIndexReader Class See Also Send Feedback

The FilterIndexReader type exposes the following members.

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | in_Renamed |

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


in_Renamed Field

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..in_Renamed Field
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.FilterIndexReader.in_Renamed"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexReader in_Renamed
Visual Basic
Protected Friend in_Renamed As IndexReader
Visual C++
protected public:
IndexReader^ in_Renamed

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


FilterIndexReader Methods

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader Methods
FilterIndexReader Class See Also Send Feedback

The FilterIndexReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method | Directory | (Overrides IndexReader..::..Directory()()()().)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method GetDeletesCacheKey
If the subclass of FilteredIndexReader modifies the deleted docs, you must override this method to provide a different key */
(Overrides IndexReader..::..GetDeletesCacheKey()()()().)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey
If the subclass of FilteredIndexReader modifies the contents of the FieldCache, you must override this method to provide a different key */
(Overrides IndexReader..::..GetFieldCacheKey()()()().)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Overrides IndexReader..::..GetSequentialSubReaders()()()().)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

(Inherited from IndexReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method | GetVersion | (Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader..::..IsOptimized()()()().)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Clone Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Clone Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

FilterIndexReader Class
Clone Overload
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Commit Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


Directory Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Directory Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Directory"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Directory Directory()
Visual Basic
Public Overrides Function Directory As Directory
Visual C++
public:
virtual Directory^ Directory() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.Directory"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DocFreq Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term t
)
Visual Basic
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ t
) override

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.DocFreq(Lucene.Net.Index.Term)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


DoClose Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoClose Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoClose"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoClose()
Visual Basic
Protected Friend Overrides Sub DoClose
Visual C++
protected public:
virtual void DoClose() override

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoCommit Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoCommit Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoCommit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal override void DoCommit()
Visual Basic
<ObsoleteAttribute> _
Protected Friend Overrides Sub DoCommit
Visual C++
[ObsoleteAttribute]
protected public:
virtual void DoCommit() override

See Also

FilterIndexReader Class
DoCommit Overload
Lucene.Net.Index Namespace


DoCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoCommit Method (IDictionary<(Of <(<'String, String>)>)>)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Protected Friend Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
protected public:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

FilterIndexReader Class
DoCommit Overload
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Document Method
FilterIndexReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


Document Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Document Method (Int32, FieldSelector)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

See Also

FilterIndexReader Class
Document Overload
Lucene.Net.Index Namespace


DoDelete Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoDelete Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoDelete(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoDelete(
    int n
)
Visual Basic
Protected Friend Overrides Sub DoDelete ( _
    n As Integer _
)
Visual C++
protected public:
virtual void DoDelete(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoDelete(System.Int32)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


DoSetNorm Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoSetNorm Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoSetNorm(
    int d,
    string f,
    byte b
)
Visual Basic
Protected Friend Overrides Sub DoSetNorm ( _
    d As Integer, _
    f As String, _
    b As Byte _
)
Visual C++
protected public:
virtual void DoSetNorm(
    int d,
    String^ f,
    unsigned char b
) override

Parameters

d
Type: System..::..Int32

[Missing <param name="d"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

f
Type: System..::..String

[Missing <param name="f"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


DoUndeleteAll Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..DoUndeleteAll Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.DoUndeleteAll"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoUndeleteAll()
Visual Basic
Protected Friend Overrides Sub DoUndeleteAll
Visual C++
protected public:
virtual void DoUndeleteAll() override

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Flush Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


GetDeletesCacheKey Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetDeletesCacheKey Method
FilterIndexReader Class See Also Send Feedback
If the subclass of FilteredIndexReader modifies the deleted docs, you must override this method to provide a different key */

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object GetDeletesCacheKey()
Visual Basic
Public Overrides Function GetDeletesCacheKey As Object
Visual C++
public:
virtual Object^ GetDeletesCacheKey() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetDeletesCacheKey"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


GetFieldCacheKey Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetFieldCacheKey Method
FilterIndexReader Class See Also Send Feedback
If the subclass of FilteredIndexReader modifies the contents of the FieldCache, you must override this method to provide a different key */

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object GetFieldCacheKey()
Visual Basic
Public Overrides Function GetFieldCacheKey As Object
Visual C++
public:
virtual Object^ GetFieldCacheKey() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetFieldCacheKey"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetFieldNames Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Visual Basic
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override

Parameters

fieldNames
Type: Lucene.Net.Index..::..IndexReader..::..FieldOption

[Missing <param name="fieldNames"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


GetSequentialSubReaders Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetSequentialSubReaders Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetSequentialSubReaders"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader[] GetSequentialSubReaders()
Visual Basic
Public Overrides Function GetSequentialSubReaders As IndexReader()
Visual C++
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetSequentialSubReaders"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetTermFreqVector Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetTermFreqVector Method (Int32, TermVectorMapper)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

See Also

FilterIndexReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetTermFreqVector Method (Int32, String)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
Visual Basic
Public Overrides Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String)"]

See Also

FilterIndexReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetTermFreqVector Method (Int32, String, TermVectorMapper)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

See Also

FilterIndexReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVectors Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetTermFreqVectors Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVectors(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector[] GetTermFreqVectors(
    int docNumber
)
Visual Basic
Public Overrides Function GetTermFreqVectors ( _
    docNumber As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVectors(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetTermFreqVectors(System.Int32)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..GetVersion Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetVersion"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetVersion()
Visual Basic
Public Overrides Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.GetVersion"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..HasDeletions Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasDeletions()
Visual Basic
Public Overrides Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.HasDeletions"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


HasNorms Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..HasNorms Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.HasNorms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasNorms(
    string field
)
Visual Basic
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool HasNorms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.HasNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.HasNorms(System.String)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


IsCurrent Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..IsCurrent Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsCurrent"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCurrent()
Visual Basic
Public Overrides Function IsCurrent As Boolean
Visual C++
public:
virtual bool IsCurrent() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsCurrent"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..IsDeleted Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsDeleted(
    int n
)
Visual Basic
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsDeleted(System.Int32)"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..IsOptimized Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsOptimized"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsOptimized()
Visual Basic
Public Overrides Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.IsOptimized"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..MaxDoc Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.MaxDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.MaxDoc"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Norms Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


Norms Method (String)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Norms Method (String)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] Norms(
    string f
)
Visual Basic
Public Overrides Function Norms ( _
    f As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Norms(
    String^ f
) override

Parameters

f
Type: System..::..String

[Missing <param name="f"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String)"]

See Also

FilterIndexReader Class
Norms Overload
Lucene.Net.Index Namespace


Norms Method (String, Byte[], Int32)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Norms Method (String, array<Byte>[]()[][], Int32)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String,System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Norms(
    string f,
    byte[] bytes,
    int offset
)
Visual Basic
Public Overrides Sub Norms ( _
    f As String, _
    bytes As Byte(), _
    offset As Integer _
)
Visual C++
public:
virtual void Norms(
    String^ f,
    array<unsigned char>^ bytes,
    int offset
) override

Parameters

f
Type: System..::..String

[Missing <param name="f"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String,System.Byte[],System.Int32)"]

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Norms(System.String,System.Byte[],System.Int32)"]

See Also

FilterIndexReader Class
Norms Overload
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..NumDocs Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.NumDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NumDocs()
Visual Basic
Public Overrides Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.NumDocs"]

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Reopen Method
FilterIndexReader Class See Also Send Feedback

Overload List

Name Description
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..SetNorm Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..TermDocs Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..TermDocs Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs()
Visual Basic
Public Overrides Function TermDocs As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermDocs"]

See Also

FilterIndexReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermDocs Method (Term)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..TermDocs Method (Term)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermDocs(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs(
    Term term
)
Visual Basic
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermDocs(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermDocs(Lucene.Net.Index.Term)"]

See Also

FilterIndexReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..TermPositions Method
FilterIndexReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..TermPositions Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermPositions TermPositions()
Visual Basic
Public Overrides Function TermPositions As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.TermPositions"]

See Also

FilterIndexReader Class
TermPositions Overload
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..Terms Method
FilterIndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)

See Also

FilterIndexReader Class
FilterIndexReader Members
Lucene.Net.Index Namespace


Terms Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Terms Method
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Terms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms()
Visual Basic
Public Overrides Function Terms As TermEnum
Visual C++
public:
virtual TermEnum^ Terms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.Terms"]

See Also

FilterIndexReader Class
Terms Overload
Lucene.Net.Index Namespace


Terms Method (Term)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..Terms Method (Term)
FilterIndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.Terms(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms(
    Term t
)
Visual Basic
Public Overrides Function Terms ( _
    t As Term _
) As TermEnum
Visual C++
public:
virtual TermEnum^ Terms(
    Term^ t
) override

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.Terms(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.Terms(Lucene.Net.Index.Term)"]

See Also

FilterIndexReader Class
Terms Overload
Lucene.Net.Index Namespace


FilterIndexReader Properties

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader Properties
FilterIndexReader Class See Also Send Feedback

The FilterIndexReader type exposes the following members.

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

FilterIndexReader Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Class

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs Class
FilterIndexReader Class Members See Also Send Feedback
Base class for filtering {@link TermDocs} implementations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FilterTermDocs : TermDocs
Visual Basic
Public Class FilterTermDocs _
    Implements TermDocs
Visual C++
public ref class FilterTermDocs : TermDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FilterIndexReader..::..FilterTermDocs
Lucene.Net.Index..::..FilterIndexReader..::..FilterTermPositions

See Also

FilterIndexReader..::..FilterTermDocs Members
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Members

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs Members
FilterIndexReader..::..FilterTermDocs Class Constructors Methods Fields See Also Send Feedback

A
CopyC#
FilterIndexReader
 contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
CopyC#
FilterIndexReader
 itself simply implements all abstract methods of
CopyC#
IndexReader
 with versions that pass all requests to the contained index reader. Subclasses of
CopyC#
FilterIndexReader
 may further override some of these methods and may also provide additional methods and fields.

The FilterIndexReader..::..FilterTermDocs type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIndexReader..::..FilterTermDocs | Initializes a new instance of the FilterIndexReader..::..FilterTermDocs class

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | in_Renamed |

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Constructor

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs Constructor
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback
Initializes a new instance of the FilterIndexReader..::..FilterTermDocs class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterTermDocs(
    TermDocs in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TermDocs _
)
Visual C++
public:
FilterTermDocs(
    TermDocs^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Index..::..TermDocs

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.#ctor(Lucene.Net.Index.TermDocs)"]

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Fields

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs Fields
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

The FilterIndexReader..::..FilterTermDocs type exposes the following members.

Fields

 | Name | Description
Protected field | in_Renamed |

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


in_Renamed Field

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..in_Renamed Field
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.in_Renamed"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermDocs in_Renamed
Visual Basic
Protected Friend in_Renamed As TermDocs
Visual C++
protected public:
TermDocs^ in_Renamed

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermDocs Methods

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs Methods
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

The FilterIndexReader..::..FilterTermDocs type exposes the following members.

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Read |
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Public method | SkipTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Close Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

Implements

TermDocs..::..Close()()()()

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


Doc Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Doc Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Doc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Doc()
Visual Basic
Public Overridable Function Doc As Integer
Visual C++
public:
virtual int Doc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Doc"]

Implements

TermDocs..::..Doc()()()()

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


Freq Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Freq Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Freq"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Freq()
Visual Basic
Public Overridable Function Freq As Integer
Visual C++
public:
virtual int Freq()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Freq"]

Implements

TermDocs..::..Freq()()()()

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Next Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Next"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Next()
Visual Basic
Public Overridable Function Next As Boolean
Visual C++
public:
virtual bool Next()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Next"]

Implements

TermDocs..::..Next()()()()

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


Read Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Read Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Read(System.Int32[],System.Int32[])"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Read(
    int[] docs,
    int[] freqs
)
Visual Basic
Public Overridable Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Visual C++
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
)

Parameters

docs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="docs"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Read(System.Int32[],System.Int32[])"]

freqs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="freqs"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Read(System.Int32[],System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Read(System.Int32[],System.Int32[])"]

Implements

TermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][])

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Seek Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) |
Public method | Seek(TermEnum) |

See Also

FilterIndexReader..::..FilterTermDocs Class
FilterIndexReader..::..FilterTermDocs Members
Lucene.Net.Index Namespace


Seek Method (Term)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Seek Method (Term)
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Seek(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Seek(
    Term term
)
Visual Basic
Public Overridable Sub Seek ( _
    term As Term _
)
Visual C++
public:
virtual void Seek(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Seek(Lucene.Net.Index.Term)"]

Implements

TermDocs..::..Seek(Term)

See Also

FilterIndexReader..::..FilterTermDocs Class
Seek Overload
Lucene.Net.Index Namespace


Seek Method (TermEnum)

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..Seek Method (TermEnum)
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Seek(Lucene.Net.Index.TermEnum)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Seek(
    TermEnum termEnum
)
Visual Basic
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
Visual C++
public:
virtual void Seek(
    TermEnum^ termEnum
)

Parameters

termEnum
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="termEnum"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.Seek(Lucene.Net.Index.TermEnum)"]

Implements

TermDocs..::..Seek(TermEnum)

See Also

FilterIndexReader..::..FilterTermDocs Class
Seek Overload
Lucene.Net.Index Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermDocs..::..SkipTo Method
FilterIndexReader..::..FilterTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool SkipTo(
    int i
)
Visual Basic
Public Overridable Function SkipTo ( _
    i As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermDocs.SkipTo(System.Int32)"]

Implements

TermDocs..::..SkipTo(Int32)

See Also

FilterIndexReader..::..FilterTermDocs Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Class

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum Class
FilterIndexReader Class Members See Also Send Feedback
Base class for filtering {@link TermEnum} implementations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FilterTermEnum : TermEnum
Visual Basic
Public Class FilterTermEnum _
    Inherits TermEnum
Visual C++
public ref class FilterTermEnum : public TermEnum

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Index..::..FilterIndexReader..::..FilterTermEnum

See Also

FilterIndexReader..::..FilterTermEnum Members
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Members

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum Members
FilterIndexReader..::..FilterTermEnum Class Constructors Methods Fields See Also Send Feedback

A
CopyC#
FilterIndexReader
 contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
CopyC#
FilterIndexReader
 itself simply implements all abstract methods of
CopyC#
IndexReader
 with versions that pass all requests to the contained index reader. Subclasses of
CopyC#
FilterIndexReader
 may further override some of these methods and may also provide additional methods and fields.

The FilterIndexReader..::..FilterTermEnum type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIndexReader..::..FilterTermEnum | Initializes a new instance of the FilterIndexReader..::..FilterTermEnum class

Methods

Name | Description
Public method | Close | (Overrides TermEnum..::..Close()()()().)
Public method | DocFreq | (Overrides TermEnum..::..DocFreq()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | (Overrides TermEnum..::..Next()()()().)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method | Term | (Overrides TermEnum..::..Term()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | in_Renamed |

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Constructor

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum Constructor
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback
Initializes a new instance of the FilterIndexReader..::..FilterTermEnum class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterTermEnum(
    TermEnum in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TermEnum _
)
Visual C++
public:
FilterTermEnum(
    TermEnum^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.#ctor(Lucene.Net.Index.TermEnum)"]

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum Fields
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

The FilterIndexReader..::..FilterTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | in_Renamed |

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


in_Renamed Field

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum..::..in_Renamed Field
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.in_Renamed"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermEnum in_Renamed
Visual Basic
Protected Friend in_Renamed As TermEnum
Visual C++
protected public:
TermEnum^ in_Renamed

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum Methods
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

The FilterIndexReader..::..FilterTermEnum type exposes the following members.

Methods

Name | Description
Public method | Close | (Overrides TermEnum..::..Close()()()().)
Public method | DocFreq | (Overrides TermEnum..::..DocFreq()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | (Overrides TermEnum..::..Next()()()().)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method | Term | (Overrides TermEnum..::..Term()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum..::..Close Method
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum..::..DocFreq Method
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.DocFreq"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq()
Visual Basic
Public Overrides Function DocFreq As Integer
Visual C++
public:
virtual int DocFreq() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.DocFreq"]

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum..::..Next Method
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.Next"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.Next"]

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


Term Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermEnum..::..Term Method
FilterIndexReader..::..FilterTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.Term"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Term Term()
Visual Basic
Public Overrides Function Term As Term
Visual C++
public:
virtual Term^ Term() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermEnum.Term"]

See Also

FilterIndexReader..::..FilterTermEnum Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Class

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions Class
FilterIndexReader Class Members See Also Send Feedback
Base class for filtering {@link TermPositions} implementations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FilterTermPositions : FilterIndexReader..::..FilterTermDocs,
    TermPositions, TermDocs
Visual Basic
Public Class FilterTermPositions _
    Inherits FilterIndexReader..::..FilterTermDocs _
    Implements TermPositions, TermDocs
Visual C++
public ref class FilterTermPositions : public FilterIndexReader..::..FilterTermDocs,
    TermPositions, TermDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FilterIndexReader..::..FilterTermDocs
Lucene.Net.Index..::..FilterIndexReader..::..FilterTermPositions

See Also

FilterIndexReader..::..FilterTermPositions Members
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Members

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions Members
FilterIndexReader..::..FilterTermPositions Class Constructors Methods Fields See Also Send Feedback

A
CopyC#
FilterIndexReader
 contains another IndexReader, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality. The class
CopyC#
FilterIndexReader
 itself simply implements all abstract methods of
CopyC#
IndexReader
 with versions that pass all requests to the contained index reader. Subclasses of
CopyC#
FilterIndexReader
 may further override some of these methods and may also provide additional methods and fields.

The FilterIndexReader..::..FilterTermPositions type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIndexReader..::..FilterTermPositions | Initializes a new instance of the FilterIndexReader..::..FilterTermPositions class

Methods

 | Name | Description
Public method | Close | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Doc | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload |
Public method | GetPayloadLength |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | NextPosition |
Public method | Read | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Seek(Term) | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Seek(TermEnum) | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | SkipTo | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | in_Renamed | (Inherited from FilterIndexReader..::..FilterTermDocs.)

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Constructor

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions Constructor
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback
Initializes a new instance of the FilterIndexReader..::..FilterTermPositions class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterTermPositions(
    TermPositions in_Renamed
)
Visual Basic
Public Sub New ( _
    in_Renamed As TermPositions _
)
Visual C++
public:
FilterTermPositions(
    TermPositions^ in_Renamed
)

Parameters

in_Renamed
Type: Lucene.Net.Index..::..TermPositions

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.#ctor(Lucene.Net.Index.TermPositions)"]

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Fields

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions Fields
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

The FilterIndexReader..::..FilterTermPositions type exposes the following members.

Fields

 | Name | Description
Protected field | in_Renamed | (Inherited from FilterIndexReader..::..FilterTermDocs.)

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


FilterIndexReader.FilterTermPositions Methods

[image] [image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions Methods
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

The FilterIndexReader..::..FilterTermPositions type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Doc | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload |
Public method | GetPayloadLength |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | NextPosition |
Public method | Read | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Seek(Term) | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Seek(TermEnum) | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | SkipTo | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions..::..GetPayload Method
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.GetPayload(System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] GetPayload(
    byte[] data,
    int offset
)
Visual Basic
Public Overridable Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.GetPayload(System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.GetPayload(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.GetPayload(System.Byte[],System.Int32)"]

Implements

TermPositions..::..GetPayload(array<Byte>[]()[][], Int32)

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


GetPayloadLength Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions..::..GetPayloadLength Method
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.GetPayloadLength"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPayloadLength()
Visual Basic
Public Overridable Function GetPayloadLength As Integer
Visual C++
public:
virtual int GetPayloadLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.GetPayloadLength"]

Implements

TermPositions..::..GetPayloadLength()()()()

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions..::..IsPayloadAvailable Method
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.IsPayloadAvailable"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsPayloadAvailable()
Visual Basic
Public Overridable Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.IsPayloadAvailable"]

Implements

TermPositions..::..IsPayloadAvailable()()()()

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


NextPosition Method

[image]

Lucene.Net Class Libraries
FilterIndexReader..::..FilterTermPositions..::..NextPosition Method
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.NextPosition"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int NextPosition()
Visual Basic
Public Overridable Function NextPosition As Integer
Visual C++
public:
virtual int NextPosition()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.FilterIndexReader.FilterTermPositions.NextPosition"]

Implements

TermPositions..::..NextPosition()()()()

See Also

FilterIndexReader..::..FilterTermPositions Class
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
FilterTermPositions..::..Seek Method
FilterIndexReader..::..FilterTermPositions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) | (Inherited from FilterIndexReader..::..FilterTermDocs.)
Public method | Seek(TermEnum) | (Inherited from FilterIndexReader..::..FilterTermDocs.)

See Also

FilterIndexReader..::..FilterTermPositions Class
FilterIndexReader..::..FilterTermPositions Members
Lucene.Net.Index Namespace


FloatFieldEnumerator Class

[image]

Lucene.Net Class Libraries
FloatFieldEnumerator Class
Members See Also Send Feedback
Implementation for enumerating over all of the terms in a float numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FloatFieldEnumerator : NumericFieldEnum<float>
Visual Basic
Public Class FloatFieldEnumerator _
    Inherits NumericFieldEnum(Of Single)
Visual C++
public ref class FloatFieldEnumerator : public NumericFieldEnum<float>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator <(Of <(<' Single >)>)>
Lucene.Net.Index..::..NumericFieldEnum <(Of <(<' Single >)>)>
Lucene.Net.Index..::..FloatFieldEnumerator

See Also

FloatFieldEnumerator Members
Lucene.Net.Index Namespace


FloatFieldEnumerator Members

[image] [image]

Lucene.Net Class Libraries
FloatFieldEnumerator Members
FloatFieldEnumerator Class Constructors Methods Fields Properties See Also Send Feedback

The FloatFieldEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | FloatFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | FloatFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the float from a numeric field. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the float from a string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

FloatFieldEnumerator Class
Lucene.Net.Index Namespace


FloatFieldEnumerator Constructor

[image] [image]

Lucene.Net Class Libraries
FloatFieldEnumerator Constructor
FloatFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FloatFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | FloatFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

See Also

FloatFieldEnumerator Class
FloatFieldEnumerator Members
Lucene.Net.Index Namespace


FloatFieldEnumerator Constructor (IndexReader, String, FieldParser)

[image]

Lucene.Net Class Libraries
FloatFieldEnumerator Constructor (IndexReader, String, FieldParser)
FloatFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FloatFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser _
)
Visual C++
public:
FloatFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.FloatFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser)"]

See Also

FloatFieldEnumerator Class
FloatFieldEnumerator Overload
Lucene.Net.Index Namespace


FloatFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)

[image]

Lucene.Net Class Libraries
FloatFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)
FloatFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FloatFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser,
    bool includeDocs
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser, _
    includeDocs As Boolean _
)
Visual C++
public:
FloatFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser,
    bool includeDocs
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.FloatFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser,System.Boolean)"]

includeDocs
Type: System..::..Boolean
Whether the TermDocs will also be enumerated.

See Also

FloatFieldEnumerator Class
FloatFieldEnumerator Overload
Lucene.Net.Index Namespace


FloatFieldEnumerator Fields

[image] [image]

Lucene.Net Class Libraries
FloatFieldEnumerator Fields
FloatFieldEnumerator Class See Also Send Feedback

The FloatFieldEnumerator type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

FloatFieldEnumerator Class
Lucene.Net.Index Namespace


FloatFieldEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
FloatFieldEnumerator Methods
FloatFieldEnumerator Class See Also Send Feedback

The FloatFieldEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the float from a numeric field. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the float from a string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

See Also

FloatFieldEnumerator Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
FloatFieldEnumerator..::..Init Method
FloatFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)

See Also

FloatFieldEnumerator Class
FloatFieldEnumerator Members
Lucene.Net.Index Namespace


TryParseNumeric Method

[image]

Lucene.Net Class Libraries
FloatFieldEnumerator..::..TryParseNumeric Method
FloatFieldEnumerator Class See Also Send Feedback
Parse the float from a numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseNumeric(
    string s
)
Visual Basic
Protected Overrides Function TryParseNumeric ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseNumeric(
    String^ s
) override

Parameters

s
Type: System..::..String
The string to parse.

Return Value

True if the string was parsed, false to signify the end of usable terms in a numeric field.

See Also

FloatFieldEnumerator Class
Lucene.Net.Index Namespace


TryParseString Method

[image]

Lucene.Net Class Libraries
FloatFieldEnumerator..::..TryParseString Method
FloatFieldEnumerator Class See Also Send Feedback
Parse the float from a string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseString(
    string s
)
Visual Basic
Protected Overrides Function TryParseString ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseString(
    String^ s
) override

Parameters

s
Type: System..::..String
The string to parse.

Return Value

Always true.

See Also

FloatFieldEnumerator Class
Lucene.Net.Index Namespace


FloatFieldEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
FloatFieldEnumerator Properties
FloatFieldEnumerator Class See Also Send Feedback

The FloatFieldEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

FloatFieldEnumerator Class
Lucene.Net.Index Namespace


IndexCommit Class

[image]

Lucene.Net Class Libraries
IndexCommit Class
Members See Also Send Feedback

Expert: represents a single commit into an index as seen by the {@link IndexDeletionPolicy} or {@link IndexReader}.

Changes to the content of an index are made visible only after the writer who made that change commits by writing a new segments file (

CopyC#
segments_N
). This point in time, when the action of writing of a new segments file to the directory is completed, is an index commit.

Each index commit point has a unique segments file associated with it. The segments file associated with a later index commit point would have a larger N.

WARNING: This API is a new and experimental and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class IndexCommit : IndexCommitPoint
Visual Basic
Public MustInherit Class IndexCommit _
    Implements IndexCommitPoint
Visual C++
public ref class IndexCommit abstract : IndexCommitPoint

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexCommit
Lucene.Net.Index..::..SegmentsGenCommit

See Also

IndexCommit Members
Lucene.Net.Index Namespace


IndexCommit Members

[image] [image]

Lucene.Net Class Libraries
IndexCommit Members
IndexCommit Class Constructors Methods See Also Send Feedback

The IndexCommit type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexCommit | Initializes a new instance of the IndexCommit class

Methods

Name | Description
Public method Delete
Delete this commit point. This only applies when using the commit point in the context of IndexWriter's IndexDeletionPolicy.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the {@link IndexDeletionPolicy} in effect and therefore this should only be called by its {@link IndexDeletionPolicy#onInit onInit()} or {@link IndexDeletionPolicy#onCommit onCommit()} methods.

Public method Equals
Two IndexCommits are equal if both their Directory and versions are equal.
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDirectory
Returns the {@link Directory} for the index.
Public method GetFileNames
Returns all index files referenced by this commit point.
Public method GetGeneration
Returns the generation (the _N in segments_N) for this IndexCommit
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetSegmentsFileName
Get the segments file (
CopyC#
segments_N
) associated with this commit point.
Public method GetTimestamp
Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()).
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUserData
Returns userData, previously passed to {@link IndexWriter#Commit(Map)} for this commit. Map is String -> String.
Public method GetVersion
Returns the version for this IndexCommit. This is the same value that {@link IndexReader#getVersion} would return if it were opened on this commit.
Public method | IsDeleted
Public method IsOptimized
Returns true if this commit is an optimized index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

IndexCommit Class
Lucene.Net.Index Namespace


IndexCommit Constructor

[image]

Lucene.Net Class Libraries
IndexCommit Constructor
IndexCommit Class See Also Send Feedback
Initializes a new instance of the IndexCommit class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IndexCommit()
Visual Basic
Protected Sub New
Visual C++
protected:
IndexCommit()

See Also

IndexCommit Class
Lucene.Net.Index Namespace


IndexCommit Methods

[image] [image]

Lucene.Net Class Libraries
IndexCommit Methods
IndexCommit Class See Also Send Feedback

The IndexCommit type exposes the following members.

Methods

Name | Description
Public method Delete
Delete this commit point. This only applies when using the commit point in the context of IndexWriter's IndexDeletionPolicy.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the {@link IndexDeletionPolicy} in effect and therefore this should only be called by its {@link IndexDeletionPolicy#onInit onInit()} or {@link IndexDeletionPolicy#onCommit onCommit()} methods.

Public method Equals
Two IndexCommits are equal if both their Directory and versions are equal.
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDirectory
Returns the {@link Directory} for the index.
Public method GetFileNames
Returns all index files referenced by this commit point.
Public method GetGeneration
Returns the generation (the _N in segments_N) for this IndexCommit
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetSegmentsFileName
Get the segments file (
CopyC#
segments_N
) associated with this commit point.
Public method GetTimestamp
Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()).
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUserData
Returns userData, previously passed to {@link IndexWriter#Commit(Map)} for this commit. Map is String -> String.
Public method GetVersion
Returns the version for this IndexCommit. This is the same value that {@link IndexReader#getVersion} would return if it were opened on this commit.
Public method | IsDeleted
Public method IsOptimized
Returns true if this commit is an optimized index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

IndexCommit Class
Lucene.Net.Index Namespace


Delete Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..Delete Method
IndexCommit Class See Also Send Feedback
Delete this commit point. This only applies when using the commit point in the context of IndexWriter's IndexDeletionPolicy.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the {@link IndexDeletionPolicy} in effect and therefore this should only be called by its {@link IndexDeletionPolicy#onInit onInit()} or {@link IndexDeletionPolicy#onCommit onCommit()} methods.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Delete()
Visual Basic
Public MustOverride Sub Delete
Visual C++
public:
virtual void Delete() abstract

Implements

IndexCommitPoint..::..Delete()()()()

See Also

IndexCommit Class
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..Equals Method
IndexCommit Class See Also Send Feedback
Two IndexCommits are equal if both their Directory and versions are equal.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Index.IndexCommit.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.Equals(System.Object)"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetDirectory Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetDirectory Method
IndexCommit Class See Also Send Feedback
Returns the {@link Directory} for the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Directory GetDirectory()
Visual Basic
Public MustOverride Function GetDirectory As Directory
Visual C++
public:
virtual Directory^ GetDirectory() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetDirectory"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetFileNames Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetFileNames Method
IndexCommit Class See Also Send Feedback
Returns all index files referenced by this commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract ICollection<string> GetFileNames()
Visual Basic
Public MustOverride Function GetFileNames As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFileNames() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetFileNames"]

Implements

IndexCommitPoint..::..GetFileNames()()()()

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetGeneration Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetGeneration Method
IndexCommit Class See Also Send Feedback
Returns the generation (the _N in segments_N) for this IndexCommit

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long GetGeneration()
Visual Basic
Public MustOverride Function GetGeneration As Long
Visual C++
public:
virtual long long GetGeneration() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetGeneration"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetHashCode Method
IndexCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexCommit.GetHashCode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetHashCode"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetSegmentsFileName Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetSegmentsFileName Method
IndexCommit Class See Also Send Feedback
Get the segments file (
CopyC#
segments_N
) associated with this commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string GetSegmentsFileName()
Visual Basic
Public MustOverride Function GetSegmentsFileName As String
Visual C++
public:
virtual String^ GetSegmentsFileName() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetSegmentsFileName"]

Implements

IndexCommitPoint..::..GetSegmentsFileName()()()()

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetTimestamp Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetTimestamp Method
IndexCommit Class See Also Send Feedback
Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetTimestamp()
Visual Basic
Public Overridable Function GetTimestamp As Long
Visual C++
public:
virtual long long GetTimestamp()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetTimestamp"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetUserData Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetUserData Method
IndexCommit Class See Also Send Feedback
Returns userData, previously passed to {@link IndexWriter#Commit(Map)} for this commit. Map is String -> String.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract IDictionary<string, string> GetUserData()
Visual Basic
Public MustOverride Function GetUserData As IDictionary(Of String, String)
Visual C++
public:
virtual IDictionary<String^, String^>^ GetUserData() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetUserData"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..GetVersion Method
IndexCommit Class See Also Send Feedback
Returns the version for this IndexCommit. This is the same value that {@link IndexReader#getVersion} would return if it were opened on this commit.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long GetVersion()
Visual Basic
Public MustOverride Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.GetVersion"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..IsDeleted Method
IndexCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexCommit.IsDeleted"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool IsDeleted()
Visual Basic
Public MustOverride Function IsDeleted As Boolean
Visual C++
public:
virtual bool IsDeleted() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.IsDeleted"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
IndexCommit..::..IsOptimized Method
IndexCommit Class See Also Send Feedback
Returns true if this commit is an optimized index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool IsOptimized()
Visual Basic
Public MustOverride Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommit.IsOptimized"]

See Also

IndexCommit Class
Lucene.Net.Index Namespace


IndexCommitPoint Interface

[image]

Lucene.Net Class Libraries
IndexCommitPoint Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.IndexCommitPoint"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please subclass IndexCommit class instead")]
public interface IndexCommitPoint
Visual Basic
<ObsoleteAttribute("Please subclass IndexCommit class instead")> _
Public Interface IndexCommitPoint
Visual C++
[ObsoleteAttribute(L"Please subclass IndexCommit class instead")]
public interface class IndexCommitPoint

See Also

IndexCommitPoint Members
Lucene.Net.Index Namespace


IndexCommitPoint Members

[image] [image]

Lucene.Net Class Libraries
IndexCommitPoint Members
IndexCommitPoint Interface Methods See Also Send Feedback

The IndexCommitPoint type exposes the following members.

Methods

Name Description
Public method Delete
Delete this commit point.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the {@link IndexDeletionPolicy} in effect and therefore this should only be called by its {@link IndexDeletionPolicy#onInit onInit()} or {@link IndexDeletionPolicy#onCommit onCommit()} methods.

Public method GetFileNames
Returns all index files referenced by this commit point.
Public method GetSegmentsFileName
Get the segments file (
CopyC#
segments_N
) associated with this commit point.

See Also

IndexCommitPoint Interface
Lucene.Net.Index Namespace


IndexCommitPoint Methods

[image] [image]

Lucene.Net Class Libraries
IndexCommitPoint Methods
IndexCommitPoint Interface See Also Send Feedback

The IndexCommitPoint type exposes the following members.

Methods

Name Description
Public method Delete
Delete this commit point.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the {@link IndexDeletionPolicy} in effect and therefore this should only be called by its {@link IndexDeletionPolicy#onInit onInit()} or {@link IndexDeletionPolicy#onCommit onCommit()} methods.

Public method GetFileNames
Returns all index files referenced by this commit point.
Public method GetSegmentsFileName
Get the segments file (
CopyC#
segments_N
) associated with this commit point.

See Also

IndexCommitPoint Interface
Lucene.Net.Index Namespace


Delete Method

[image]

Lucene.Net Class Libraries
IndexCommitPoint..::..Delete Method
IndexCommitPoint Interface See Also Send Feedback
Delete this commit point.

Upon calling this, the writer is notified that this commit point should be deleted.

Decision that a commit-point should be deleted is taken by the {@link IndexDeletionPolicy} in effect and therefore this should only be called by its {@link IndexDeletionPolicy#onInit onInit()} or {@link IndexDeletionPolicy#onCommit onCommit()} methods.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Delete()
Visual Basic
Sub Delete
Visual C++
void Delete()

See Also

IndexCommitPoint Interface
Lucene.Net.Index Namespace


GetFileNames Method

[image]

Lucene.Net Class Libraries
IndexCommitPoint..::..GetFileNames Method
IndexCommitPoint Interface See Also Send Feedback
Returns all index files referenced by this commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
ICollection<string> GetFileNames()
Visual Basic
Function GetFileNames As ICollection(Of String)
Visual C++
ICollection<String^>^ GetFileNames()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommitPoint.GetFileNames"]

See Also

IndexCommitPoint Interface
Lucene.Net.Index Namespace


GetSegmentsFileName Method

[image]

Lucene.Net Class Libraries
IndexCommitPoint..::..GetSegmentsFileName Method
IndexCommitPoint Interface See Also Send Feedback
Get the segments file (
CopyC#
segments_N
) associated with this commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string GetSegmentsFileName()
Visual Basic
Function GetSegmentsFileName As String
Visual C++
String^ GetSegmentsFileName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexCommitPoint.GetSegmentsFileName"]

See Also

IndexCommitPoint Interface
Lucene.Net.Index Namespace


IndexDeletionPolicy Interface

[image]

Lucene.Net Class Libraries
IndexDeletionPolicy Interface
Members See Also Send Feedback

Expert: policy for deletion of stale {@link IndexCommit index commits}.

Implement this interface, and pass it to one of the {@link IndexWriter} or {@link IndexReader} constructors, to customize when older {@link IndexCommit point-in-time commits} are deleted from the index directory. The default deletion policy is {@link KeepOnlyLastCommitDeletionPolicy}, which always removes old commits as soon as a new commit is done (this matches the behavior before 2.2).

One expected use case for this (and the reason why it was first created) is to work around problems with an index directory accessed via filesystems like NFS because NFS does not provide the "delete on last close" semantics that Lucene's "point in time" search normally relies on. By implementing a custom deletion policy, such as "a commit is only removed once it has been stale for more than X minutes", you can give your readers time to refresh to the new commit before {@link IndexWriter} removes the old commits. Note that doing so will increase the storage requirements of the index. See LUCENE-710 for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface IndexDeletionPolicy
Visual Basic
Public Interface IndexDeletionPolicy
Visual C++
public interface class IndexDeletionPolicy

See Also

IndexDeletionPolicy Members
Lucene.Net.Index Namespace


IndexDeletionPolicy Members

[image] [image]

Lucene.Net Class Libraries
IndexDeletionPolicy Members
IndexDeletionPolicy Interface Methods See Also Send Feedback

The IndexDeletionPolicy type exposes the following members.

Methods

Name Description
Public method OnCommit

This is called each time the writer completed a commit. This gives the policy a chance to remove old commit points with each commit.

The policy may now choose to delete old commit points by calling method {@link IndexCommit#delete delete()} of {@link IndexCommit}.

If writer has

CopyC#
autoCommit = true
then this method will in general be called many times during one instance of {@link IndexWriter}. If
CopyC#
autoCommit = false
 then this method is only called once when {@link IndexWriter#close} is called, or not at all if the {@link IndexWriter#abort} is called.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

Public method OnInit

This is called once when a writer is first instantiated to give the policy a chance to remove old commit points.

The writer locates all index commits present in the index directory and calls this method. The policy may choose to delete some of the commit points, doing so by calling method {@link IndexCommit#delete delete()} of {@link IndexCommit}.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

See Also

IndexDeletionPolicy Interface
Lucene.Net.Index Namespace


IndexDeletionPolicy Methods

[image] [image]

Lucene.Net Class Libraries
IndexDeletionPolicy Methods
IndexDeletionPolicy Interface See Also Send Feedback

The IndexDeletionPolicy type exposes the following members.

Methods

Name Description
Public method OnCommit

This is called each time the writer completed a commit. This gives the policy a chance to remove old commit points with each commit.

The policy may now choose to delete old commit points by calling method {@link IndexCommit#delete delete()} of {@link IndexCommit}.

If writer has

CopyC#
autoCommit = true
then this method will in general be called many times during one instance of {@link IndexWriter}. If
CopyC#
autoCommit = false
 then this method is only called once when {@link IndexWriter#close} is called, or not at all if the {@link IndexWriter#abort} is called.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

Public method OnInit

This is called once when a writer is first instantiated to give the policy a chance to remove old commit points.

The writer locates all index commits present in the index directory and calls this method. The policy may choose to delete some of the commit points, doing so by calling method {@link IndexCommit#delete delete()} of {@link IndexCommit}.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

See Also

IndexDeletionPolicy Interface
Lucene.Net.Index Namespace


OnCommit Method

[image]

Lucene.Net Class Libraries
IndexDeletionPolicy..::..OnCommit Method
IndexDeletionPolicy Interface See Also Send Feedback

This is called each time the writer completed a commit. This gives the policy a chance to remove old commit points with each commit.

The policy may now choose to delete old commit points by calling method {@link IndexCommit#delete delete()} of {@link IndexCommit}.

If writer has

CopyC#
autoCommit = true
then this method will in general be called many times during one instance of {@link IndexWriter}. If
CopyC#
autoCommit = false
 then this method is only called once when {@link IndexWriter#close} is called, or not at all if the {@link IndexWriter#abort} is called.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void OnCommit(
    IList commits
)
Visual Basic
Sub OnCommit ( _
    commits As IList _
)
Visual C++
void OnCommit(
    IList^ commits
)

Parameters

commits
Type: System.Collections..::..IList
List of {@link IndexCommit}, sorted by age (the 0th one is the oldest commit).

See Also

IndexDeletionPolicy Interface
Lucene.Net.Index Namespace


OnInit Method

[image]

Lucene.Net Class Libraries
IndexDeletionPolicy..::..OnInit Method
IndexDeletionPolicy Interface See Also Send Feedback

This is called once when a writer is first instantiated to give the policy a chance to remove old commit points.

The writer locates all index commits present in the index directory and calls this method. The policy may choose to delete some of the commit points, doing so by calling method {@link IndexCommit#delete delete()} of {@link IndexCommit}.

Note: the last CommitPoint is the most recent one, i.e. the "front index state". Be careful not to delete it, unless you know for sure what you are doing, and unless you can afford to lose the index content while doing that.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void OnInit(
    IList commits
)
Visual Basic
Sub OnInit ( _
    commits As IList _
)
Visual C++
void OnInit(
    IList^ commits
)

Parameters

commits
Type: System.Collections..::..IList
List of current {@link IndexCommit point-in-time commits}, sorted by age (the 0th one is the oldest commit).

See Also

IndexDeletionPolicy Interface
Lucene.Net.Index Namespace


IndexFileDeleter Class

[image]

Lucene.Net Class Libraries
IndexFileDeleter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.IndexFileDeleter"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class IndexFileDeleter
Visual Basic
Public NotInheritable Class IndexFileDeleter
Visual C++
public ref class IndexFileDeleter sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexFileDeleter

See Also

IndexFileDeleter Members
Lucene.Net.Index Namespace


IndexFileDeleter Members

[image] [image]

Lucene.Net Class Libraries
IndexFileDeleter Members
IndexFileDeleter Class Constructors Methods Fields See Also Send Feedback

The IndexFileDeleter type exposes the following members.

Constructors

 | Name | Description
Public method | IndexFileDeleter | Initialize the deleter: find all previous commits in the Directory, incref the files they reference, call the policy to let it delete commits. This will remove any files not referenced by any of the commits.

Methods

 | Name | Description
Public method | Checkpoint | For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.
Public method | Close |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSegmentInfos |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh()()()() |
Public method | Refresh(String) | Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
VERBOSE_REF_COUNTS | Change to true to see details of reference counts when infoStream != null

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


IndexFileDeleter Constructor

[image]

Lucene.Net Class Libraries
IndexFileDeleter Constructor
IndexFileDeleter Class See Also Send Feedback
Initialize the deleter: find all previous commits in the Directory, incref the files they reference, call the policy to let it delete commits. This will remove any files not referenced by any of the commits.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexFileDeleter(
    Directory directory,
    IndexDeletionPolicy policy,
    SegmentInfos segmentInfos,
    StreamWriter infoStream,
    DocumentsWriter docWriter,
    Dictionary<string, string> synced
)
Visual Basic
Public Sub New ( _
    directory As Directory, _
    policy As IndexDeletionPolicy, _
    segmentInfos As SegmentInfos, _
    infoStream As StreamWriter, _
    docWriter As DocumentsWriter, _
    synced As Dictionary(Of String, String) _
)
Visual C++
public:
IndexFileDeleter(
    Directory^ directory,
    IndexDeletionPolicy^ policy,
    SegmentInfos^ segmentInfos,
    StreamWriter^ infoStream,
    DocumentsWriter^ docWriter,
    Dictionary<String^, String^>^ synced
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.#ctor(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,Lucene.Net.Index.SegmentInfos,System.IO.StreamWriter,Lucene.Net.Index.DocumentsWriter,System.Collections.Generic.Dictionary{System.String,System.String})"]

policy
Type: Lucene.Net.Index..::..IndexDeletionPolicy

[Missing <param name="policy"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.#ctor(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,Lucene.Net.Index.SegmentInfos,System.IO.StreamWriter,Lucene.Net.Index.DocumentsWriter,System.Collections.Generic.Dictionary{System.String,System.String})"]

segmentInfos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="segmentInfos"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.#ctor(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,Lucene.Net.Index.SegmentInfos,System.IO.StreamWriter,Lucene.Net.Index.DocumentsWriter,System.Collections.Generic.Dictionary{System.String,System.String})"]

infoStream
Type: System.IO..::..StreamWriter

[Missing <param name="infoStream"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.#ctor(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,Lucene.Net.Index.SegmentInfos,System.IO.StreamWriter,Lucene.Net.Index.DocumentsWriter,System.Collections.Generic.Dictionary{System.String,System.String})"]

docWriter
Type: Lucene.Net.Index..::..DocumentsWriter

[Missing <param name="docWriter"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.#ctor(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,Lucene.Net.Index.SegmentInfos,System.IO.StreamWriter,Lucene.Net.Index.DocumentsWriter,System.Collections.Generic.Dictionary{System.String,System.String})"]

synced
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

[Missing <param name="synced"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.#ctor(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,Lucene.Net.Index.SegmentInfos,System.IO.StreamWriter,Lucene.Net.Index.DocumentsWriter,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


IndexFileDeleter Fields

[image] [image]

Lucene.Net Class Libraries
IndexFileDeleter Fields
IndexFileDeleter Class See Also Send Feedback

The IndexFileDeleter type exposes the following members.

Fields

Name | Description
VERBOSE_REF_COUNTS | Change to true to see details of reference counts when infoStream != null

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


VERBOSE_REF_COUNTS Field

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..VERBOSE_REF_COUNTS Field
IndexFileDeleter Class See Also Send Feedback
Change to true to see details of reference counts when infoStream != null

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool VERBOSE_REF_COUNTS
Visual Basic
Public Shared VERBOSE_REF_COUNTS As Boolean
Visual C++
public:
static bool VERBOSE_REF_COUNTS

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


IndexFileDeleter Methods

[image] [image]

Lucene.Net Class Libraries
IndexFileDeleter Methods
IndexFileDeleter Class See Also Send Feedback

The IndexFileDeleter type exposes the following members.

Methods

 | Name | Description
Public method | Checkpoint | For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.
Public method | Close |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSegmentInfos |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh()()()() |
Public method | Refresh(String) | Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


Checkpoint Method

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..Checkpoint Method
IndexFileDeleter Class See Also Send Feedback
For definition of "check point" see IndexWriter comments: "Clarification: Check Points (and commits)". Writer calls this when it has made a "consistent change" to the index, meaning new files are written to the index and the in-memory SegmentInfos have been modified to point to those files. This may or may not be a commit (segments_N may or may not have been written). We simply incref the files referenced by the new SegmentInfos and decref the files we had previously seen (if any). If this is a commit, we also call the policy to give it a chance to remove other commits. If any commits are removed, we decref their files as well.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Checkpoint(
    SegmentInfos segmentInfos,
    bool isCommit
)
Visual Basic
Public Sub Checkpoint ( _
    segmentInfos As SegmentInfos, _
    isCommit As Boolean _
)
Visual C++
public:
void Checkpoint(
    SegmentInfos^ segmentInfos,
    bool isCommit
)

Parameters

segmentInfos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="segmentInfos"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Checkpoint(Lucene.Net.Index.SegmentInfos,System.Boolean)"]

isCommit
Type: System..::..Boolean

[Missing <param name="isCommit"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Checkpoint(Lucene.Net.Index.SegmentInfos,System.Boolean)"]

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..Close Method
IndexFileDeleter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


Exists Method

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..Exists Method
IndexFileDeleter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Exists(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool Exists(
    string fileName
)
Visual Basic
Public Function Exists ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool Exists(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Exists(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Exists(System.String)"]

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


GetLastSegmentInfos Method

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..GetLastSegmentInfos Method
IndexFileDeleter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexFileDeleter.GetLastSegmentInfos"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfos GetLastSegmentInfos()
Visual Basic
Public Function GetLastSegmentInfos As SegmentInfos
Visual C++
public:
SegmentInfos^ GetLastSegmentInfos()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexFileDeleter.GetLastSegmentInfos"]

See Also

IndexFileDeleter Class
Lucene.Net.Index Namespace


Refresh Method

[image] [image]

Lucene.Net Class Libraries
IndexFileDeleter..::..Refresh Method
IndexFileDeleter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Refresh()()()() |
Public method | Refresh(String) | Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.

See Also

IndexFileDeleter Class
IndexFileDeleter Members
Lucene.Net.Index Namespace


Refresh Method

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..Refresh Method
IndexFileDeleter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Refresh"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh
Visual C++
public:
void Refresh()

See Also

IndexFileDeleter Class
Refresh Overload
Lucene.Net.Index Namespace


Refresh Method (String)

[image]

Lucene.Net Class Libraries
IndexFileDeleter..::..Refresh Method (String)
IndexFileDeleter Class See Also Send Feedback
Writer calls this when it has hit an error and had to roll back, to tell us that there may now be unreferenced files in the filesystem. So we re-list the filesystem and delete such files. If segmentName is non-null, we will only delete files corresponding to that segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Refresh(
    string segmentName
)
Visual Basic
Public Sub Refresh ( _
    segmentName As String _
)
Visual C++
public:
void Refresh(
    String^ segmentName
)

Parameters

segmentName
Type: System..::..String

[Missing <param name="segmentName"/> documentation for "M:Lucene.Net.Index.IndexFileDeleter.Refresh(System.String)"]

See Also

IndexFileDeleter Class
Refresh Overload
Lucene.Net.Index Namespace


IndexFileNameFilter Class

[image]

Lucene.Net Class Libraries
IndexFileNameFilter Class
Members See Also Send Feedback
Filename filter that accept filenames and extensions only created by Lucene.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class IndexFileNameFilter
Visual Basic
Public Class IndexFileNameFilter
Visual C++
public ref class IndexFileNameFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexFileNameFilter

See Also

IndexFileNameFilter Members
Lucene.Net.Index Namespace


IndexFileNameFilter Members

[image] [image]

Lucene.Net Class Libraries
IndexFileNameFilter Members
IndexFileNameFilter Class Methods See Also Send Feedback

The IndexFileNameFilter type exposes the following members.

Methods

 | Name | Description
Public method | Accept |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCFSFile | Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexFileNameFilter Class
Lucene.Net.Index Namespace


IndexFileNameFilter Methods

[image] [image]

Lucene.Net Class Libraries
IndexFileNameFilter Methods
IndexFileNameFilter Class See Also Send Feedback

The IndexFileNameFilter type exposes the following members.

Methods

 | Name | Description
Public method | Accept |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCFSFile | Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexFileNameFilter Class
Lucene.Net.Index Namespace


Accept Method

[image]

Lucene.Net Class Libraries
IndexFileNameFilter..::..Accept Method
IndexFileNameFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.Accept(System.IO.FileInfo,System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Accept(
    FileInfo dir,
    string name
)
Visual Basic
Public Overridable Function Accept ( _
    dir As FileInfo, _
    name As String _
) As Boolean
Visual C++
public:
virtual bool Accept(
    FileInfo^ dir,
    String^ name
)

Parameters

dir
Type: System.IO..::..FileInfo

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.Accept(System.IO.FileInfo,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.Accept(System.IO.FileInfo,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.Accept(System.IO.FileInfo,System.String)"]

See Also

IndexFileNameFilter Class
Lucene.Net.Index Namespace


GetFilter Method

[image]

Lucene.Net Class Libraries
IndexFileNameFilter..::..GetFilter Method
IndexFileNameFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.GetFilter"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexFileNameFilter GetFilter()
Visual Basic
Public Shared Function GetFilter As IndexFileNameFilter
Visual C++
public:
static IndexFileNameFilter^ GetFilter()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.GetFilter"]

See Also

IndexFileNameFilter Class
Lucene.Net.Index Namespace


IsCFSFile Method

[image]

Lucene.Net Class Libraries
IndexFileNameFilter..::..IsCFSFile Method
IndexFileNameFilter Class See Also Send Feedback
Returns true if this is a file that would be contained in a CFS file. This function should only be called on files that pass the above "accept" (ie, are already known to be a Lucene index file).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsCFSFile(
    string name
)
Visual Basic
Public Overridable Function IsCFSFile ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool IsCFSFile(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.IsCFSFile(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexFileNameFilter.IsCFSFile(System.String)"]

See Also

IndexFileNameFilter Class
Lucene.Net.Index Namespace


IndexFileNames Class

[image]

Lucene.Net Class Libraries
IndexFileNames Class
Members See Also Send Feedback
Useful constants representing filenames and extensions used by lucene

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class IndexFileNames
Visual Basic
Public NotInheritable Class IndexFileNames
Visual C++
public ref class IndexFileNames sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexFileNames

See Also

IndexFileNames Members
Lucene.Net.Index Namespace


IndexFileNames Members

[image] [image]

Lucene.Net Class Libraries
IndexFileNames Members
IndexFileNames Class Constructors Methods Fields See Also Send Feedback

The IndexFileNames type exposes the following members.

Constructors

 | Name | Description
Public method | IndexFileNames | Initializes a new instance of the IndexFileNames class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileNameFromGeneration | Computes the full file name from base, extension and generation. If the generation is -1, the file name is null. If it's 0, the file name is If it's > 0, the file name is
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name Description
COMPOUND_EXTENSIONS
File extensions of old-style index files
COMPOUND_FILE_EXTENSION
Extension of compound file
COMPOUND_FILE_STORE_EXTENSION
Extension of compound file for doc store files
DELETABLE
Name of the index deletable file (only used in pre-lockless indices)
FIELD_INFOS_EXTENSION
Extension of field infos
FIELDS_EXTENSION
Extension of stored fields file
FIELDS_INDEX_EXTENSION
Extension of stored fields index file
FREQ_EXTENSION
Extension of freq postings file
GEN_EXTENSION
Extension of gen file
INDEX_EXTENSIONS
This array contains all filename extensions used by Lucene's index files, with two exceptions, namely the extension made up from
CopyC#
.f
 + a number and from
CopyC#
.s
 + a number. Also note that Lucene's
CopyC#
segments_N
 files do not have any filename extension.
INDEX_EXTENSIONS_IN_COMPOUND_FILE
File extensions that are added to a compound file (same as above, minus "del", "gen", "cfs").
NON_STORE_INDEX_EXTENSIONS
NORMS_EXTENSION
Extension of norms file
PLAIN_NORMS_EXTENSION
Extension of plain norms
PROX_EXTENSION
Extension of prox postings file
SEGMENTS
Name of the index segment file
SEGMENTS_GEN
Name of the generation reference file name
SEPARATE_NORMS_EXTENSION
Extension of separate norms
STORE_INDEX_EXTENSIONS
TERMS_EXTENSION
Extension of terms file
TERMS_INDEX_EXTENSION
Extension of terms index file
VECTOR_EXTENSIONS
File extensions for term vector support
VECTORS_DOCUMENTS_EXTENSION
Extension of vectors documents file
VECTORS_FIELDS_EXTENSION
Extension of vectors fields file
VECTORS_INDEX_EXTENSION
Extension of vectors index file

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


IndexFileNames Constructor

[image]

Lucene.Net Class Libraries
IndexFileNames Constructor
IndexFileNames Class See Also Send Feedback
Initializes a new instance of the IndexFileNames class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexFileNames()
Visual Basic
Public Sub New
Visual C++
public:
IndexFileNames()

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


IndexFileNames Fields

[image] [image]

Lucene.Net Class Libraries
IndexFileNames Fields
IndexFileNames Class See Also Send Feedback

The IndexFileNames type exposes the following members.

Fields

Name Description
COMPOUND_EXTENSIONS
File extensions of old-style index files
COMPOUND_FILE_EXTENSION
Extension of compound file
COMPOUND_FILE_STORE_EXTENSION
Extension of compound file for doc store files
DELETABLE
Name of the index deletable file (only used in pre-lockless indices)
FIELD_INFOS_EXTENSION
Extension of field infos
FIELDS_EXTENSION
Extension of stored fields file
FIELDS_INDEX_EXTENSION
Extension of stored fields index file
FREQ_EXTENSION
Extension of freq postings file
GEN_EXTENSION
Extension of gen file
INDEX_EXTENSIONS
This array contains all filename extensions used by Lucene's index files, with two exceptions, namely the extension made up from
CopyC#
.f
 + a number and from
CopyC#
.s
 + a number. Also note that Lucene's
CopyC#
segments_N
 files do not have any filename extension.
INDEX_EXTENSIONS_IN_COMPOUND_FILE
File extensions that are added to a compound file (same as above, minus "del", "gen", "cfs").
NON_STORE_INDEX_EXTENSIONS
NORMS_EXTENSION
Extension of norms file
PLAIN_NORMS_EXTENSION
Extension of plain norms
PROX_EXTENSION
Extension of prox postings file
SEGMENTS
Name of the index segment file
SEGMENTS_GEN
Name of the generation reference file name
SEPARATE_NORMS_EXTENSION
Extension of separate norms
STORE_INDEX_EXTENSIONS
TERMS_EXTENSION
Extension of terms file
TERMS_INDEX_EXTENSION
Extension of terms index file
VECTOR_EXTENSIONS
File extensions for term vector support
VECTORS_DOCUMENTS_EXTENSION
Extension of vectors documents file
VECTORS_FIELDS_EXTENSION
Extension of vectors fields file
VECTORS_INDEX_EXTENSION
Extension of vectors index file

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


COMPOUND_EXTENSIONS Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..COMPOUND_EXTENSIONS Field
IndexFileNames Class See Also Send Feedback
File extensions of old-style index files

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] COMPOUND_EXTENSIONS
Visual Basic
Public Shared ReadOnly COMPOUND_EXTENSIONS As String()
Visual C++
public:
static initonly array<String^>^ COMPOUND_EXTENSIONS

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


COMPOUND_FILE_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..COMPOUND_FILE_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of compound file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string COMPOUND_FILE_EXTENSION
Visual Basic
Public Const COMPOUND_FILE_EXTENSION As String
Visual C++
public:
literal String^ COMPOUND_FILE_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


COMPOUND_FILE_STORE_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..COMPOUND_FILE_STORE_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of compound file for doc store files

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string COMPOUND_FILE_STORE_EXTENSION
Visual Basic
Public Const COMPOUND_FILE_STORE_EXTENSION As String
Visual C++
public:
literal String^ COMPOUND_FILE_STORE_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


DELETABLE Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..DELETABLE Field
IndexFileNames Class See Also Send Feedback
Name of the index deletable file (only used in pre-lockless indices)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string DELETABLE
Visual Basic
Public Const DELETABLE As String
Visual C++
public:
literal String^ DELETABLE

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


FIELD_INFOS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..FIELD_INFOS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of field infos

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string FIELD_INFOS_EXTENSION
Visual Basic
Public Const FIELD_INFOS_EXTENSION As String
Visual C++
public:
literal String^ FIELD_INFOS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


FIELDS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..FIELDS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of stored fields file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string FIELDS_EXTENSION
Visual Basic
Public Const FIELDS_EXTENSION As String
Visual C++
public:
literal String^ FIELDS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


FIELDS_INDEX_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..FIELDS_INDEX_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of stored fields index file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string FIELDS_INDEX_EXTENSION
Visual Basic
Public Const FIELDS_INDEX_EXTENSION As String
Visual C++
public:
literal String^ FIELDS_INDEX_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


FREQ_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..FREQ_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of freq postings file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string FREQ_EXTENSION
Visual Basic
Public Const FREQ_EXTENSION As String
Visual C++
public:
literal String^ FREQ_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


GEN_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..GEN_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of gen file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string GEN_EXTENSION
Visual Basic
Public Const GEN_EXTENSION As String
Visual C++
public:
literal String^ GEN_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


INDEX_EXTENSIONS Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..INDEX_EXTENSIONS Field
IndexFileNames Class See Also Send Feedback
This array contains all filename extensions used by Lucene's index files, with two exceptions, namely the extension made up from
CopyC#
.f
 + a number and from
CopyC#
.s
 + a number. Also note that Lucene's
CopyC#
segments_N
 files do not have any filename extension.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] INDEX_EXTENSIONS
Visual Basic
Public Shared ReadOnly INDEX_EXTENSIONS As String()
Visual C++
public:
static initonly array<String^>^ INDEX_EXTENSIONS

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


INDEX_EXTENSIONS_IN_COMPOUND_FILE Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..INDEX_EXTENSIONS_IN_COMPOUND_FILE Field
IndexFileNames Class See Also Send Feedback
File extensions that are added to a compound file (same as above, minus "del", "gen", "cfs").

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] INDEX_EXTENSIONS_IN_COMPOUND_FILE
Visual Basic
Public Shared ReadOnly INDEX_EXTENSIONS_IN_COMPOUND_FILE As String()
Visual C++
public:
static initonly array<String^>^ INDEX_EXTENSIONS_IN_COMPOUND_FILE

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


NON_STORE_INDEX_EXTENSIONS Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..NON_STORE_INDEX_EXTENSIONS Field
IndexFileNames Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexFileNames.NON_STORE_INDEX_EXTENSIONS"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] NON_STORE_INDEX_EXTENSIONS
Visual Basic
Public Shared ReadOnly NON_STORE_INDEX_EXTENSIONS As String()
Visual C++
public:
static initonly array<String^>^ NON_STORE_INDEX_EXTENSIONS

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


NORMS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..NORMS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of norms file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string NORMS_EXTENSION
Visual Basic
Public Const NORMS_EXTENSION As String
Visual C++
public:
literal String^ NORMS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


PLAIN_NORMS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..PLAIN_NORMS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of plain norms

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string PLAIN_NORMS_EXTENSION
Visual Basic
Public Const PLAIN_NORMS_EXTENSION As String
Visual C++
public:
literal String^ PLAIN_NORMS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


PROX_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..PROX_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of prox postings file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string PROX_EXTENSION
Visual Basic
Public Const PROX_EXTENSION As String
Visual C++
public:
literal String^ PROX_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


SEGMENTS Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..SEGMENTS Field
IndexFileNames Class See Also Send Feedback
Name of the index segment file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string SEGMENTS
Visual Basic
Public Const SEGMENTS As String
Visual C++
public:
literal String^ SEGMENTS

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


SEGMENTS_GEN Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..SEGMENTS_GEN Field
IndexFileNames Class See Also Send Feedback
Name of the generation reference file name

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string SEGMENTS_GEN
Visual Basic
Public Const SEGMENTS_GEN As String
Visual C++
public:
literal String^ SEGMENTS_GEN

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


SEPARATE_NORMS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..SEPARATE_NORMS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of separate norms

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string SEPARATE_NORMS_EXTENSION
Visual Basic
Public Const SEPARATE_NORMS_EXTENSION As String
Visual C++
public:
literal String^ SEPARATE_NORMS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


STORE_INDEX_EXTENSIONS Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..STORE_INDEX_EXTENSIONS Field
IndexFileNames Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexFileNames.STORE_INDEX_EXTENSIONS"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] STORE_INDEX_EXTENSIONS
Visual Basic
Public Shared ReadOnly STORE_INDEX_EXTENSIONS As String()
Visual C++
public:
static initonly array<String^>^ STORE_INDEX_EXTENSIONS

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


TERMS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..TERMS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of terms file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string TERMS_EXTENSION
Visual Basic
Public Const TERMS_EXTENSION As String
Visual C++
public:
literal String^ TERMS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


TERMS_INDEX_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..TERMS_INDEX_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of terms index file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string TERMS_INDEX_EXTENSION
Visual Basic
Public Const TERMS_INDEX_EXTENSION As String
Visual C++
public:
literal String^ TERMS_INDEX_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


VECTOR_EXTENSIONS Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..VECTOR_EXTENSIONS Field
IndexFileNames Class See Also Send Feedback
File extensions for term vector support

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] VECTOR_EXTENSIONS
Visual Basic
Public Shared ReadOnly VECTOR_EXTENSIONS As String()
Visual C++
public:
static initonly array<String^>^ VECTOR_EXTENSIONS

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


VECTORS_DOCUMENTS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..VECTORS_DOCUMENTS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of vectors documents file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string VECTORS_DOCUMENTS_EXTENSION
Visual Basic
Public Const VECTORS_DOCUMENTS_EXTENSION As String
Visual C++
public:
literal String^ VECTORS_DOCUMENTS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


VECTORS_FIELDS_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..VECTORS_FIELDS_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of vectors fields file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string VECTORS_FIELDS_EXTENSION
Visual Basic
Public Const VECTORS_FIELDS_EXTENSION As String
Visual C++
public:
literal String^ VECTORS_FIELDS_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


VECTORS_INDEX_EXTENSION Field

[image]

Lucene.Net Class Libraries
IndexFileNames..::..VECTORS_INDEX_EXTENSION Field
IndexFileNames Class See Also Send Feedback
Extension of vectors index file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string VECTORS_INDEX_EXTENSION
Visual Basic
Public Const VECTORS_INDEX_EXTENSION As String
Visual C++
public:
literal String^ VECTORS_INDEX_EXTENSION

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


IndexFileNames Methods

[image] [image]

Lucene.Net Class Libraries
IndexFileNames Methods
IndexFileNames Class See Also Send Feedback

The IndexFileNames type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileNameFromGeneration | Computes the full file name from base, extension and generation. If the generation is -1, the file name is null. If it's 0, the file name is If it's > 0, the file name is
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


FileNameFromGeneration Method

[image]

Lucene.Net Class Libraries
IndexFileNames..::..FileNameFromGeneration Method
IndexFileNames Class See Also Send Feedback
Computes the full file name from base, extension and generation. If the generation is -1, the file name is null. If it's 0, the file name is If it's > 0, the file name is

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string FileNameFromGeneration(
    string base_Renamed,
    string extension,
    long gen
)
Visual Basic
Public Shared Function FileNameFromGeneration ( _
    base_Renamed As String, _
    extension As String, _
    gen As Long _
) As String
Visual C++
public:
static String^ FileNameFromGeneration(
    String^ base_Renamed,
    String^ extension,
    long long gen
)

Parameters

base_Renamed
Type: System..::..String

[Missing <param name="base_Renamed"/> documentation for "M:Lucene.Net.Index.IndexFileNames.FileNameFromGeneration(System.String,System.String,System.Int64)"]

extension
Type: System..::..String
-- extension of the filename (including .)
gen
Type: System..::..Int64
-- generation

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexFileNames.FileNameFromGeneration(System.String,System.String,System.Int64)"]

See Also

IndexFileNames Class
Lucene.Net.Index Namespace


IndexModifier Class

[image]

Lucene.Net Class Libraries
IndexModifier Class
Members See Also Send Feedback

[Note that as of 2.1, all but one of the methods in this class are available via {@link IndexWriter}. The one method that is not available is {@link #DeleteDocument(int)}.]

A class to modify an index, i.e. to delete and add documents. This class hides {@link IndexReader} and {@link IndexWriter} so that you do not need to care about implementation details such as that adding documents is done via IndexWriter and deletion is done via IndexReader.

Note that you cannot create more than one

CopyC#
IndexModifier
object on the same directory at the same time.

Example usage:

CopyC#
<font color="#ffffff">    </font><font color="#000000">Analyzer analyzer = </font><font color="#7f0055"><b>new </b></font><font color="#000000">StandardAnalyzer</font><font color="#000000">()</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#3f7f5f">// create an index in /tmp/index, overwriting an existing one:</font><br /><font color="#ffffff">    </font><font color="#000000">IndexModifier indexModifier = </font><font color="#7f0055"><b>new </b></font><font color="#000000">IndexModifier</font><font color="#000000">(</font><font color="#2a00ff">"/tmp/index"</font><font color="#000000">, analyzer, </font><font color="#7f0055"><b>true</b></font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">Document doc = </font><font color="#7f0055"><b>new </b></font><font color="#000000">Document</font><font color="#000000">()</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">doc.add</font><font color="#000000">(</font><font color="#7f0055"><b>new </b></font><font color="#000000">Field</font><font color="#000000">(</font><font color="#2a00ff">"id"</font><font color="#000000">, </font><font color="#2a00ff">"1"</font><font color="#000000">, Field.Store.YES, Field.Index.NOT_ANALYZED</font><font color="#000000">))</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">doc.add</font><font color="#000000">(</font><font color="#7f0055"><b>new </b></font><font color="#000000">Field</font><font color="#000000">(</font><font color="#2a00ff">"body"</font><font color="#000000">, </font><font color="#2a00ff">"a simple test"</font><font color="#000000">, Field.Store.YES, Field.Index.ANALYZED</font><font color="#000000">))</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">indexModifier.addDocument</font><font color="#000000">(</font><font color="#000000">doc</font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#7f0055"><b>int </b></font><font color="#000000">deleted = indexModifier.delete</font><font color="#000000">(</font><font color="#7f0055"><b>new </b></font><font color="#000000">Term</font><font color="#000000">(</font><font color="#2a00ff">"id"</font><font color="#000000">, </font><font color="#2a00ff">"1"</font><font color="#000000">))</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">System.out.println</font><font color="#000000">(</font><font color="#2a00ff">"Deleted " </font><font color="#000000">+ deleted + </font><font color="#2a00ff">" document"</font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">indexModifier.flush</font><font color="#000000">()</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">System.out.println</font><font color="#000000">(</font><font color="#000000">indexModifier.docCount</font><font color="#000000">() </font><font color="#000000">+ </font><font color="#2a00ff">" docs in index"</font><font color="#000000">)</font><font color="#000000">;</font><br /><font color="#ffffff">    </font><font color="#000000">indexModifier.close</font><font color="#000000">()</font><font color="#000000">;</font>

Not all methods of IndexReader and IndexWriter are offered by this class. If you need access to additional methods, either use those classes directly or implement your own class that extends

CopyC#
IndexModifier
.

Although an instance of this class can be used from more than one thread, you will not get the best performance. You might want to use IndexReader and IndexWriter directly for that (but you will need to care about synchronization yourself then).

While you can freely mix calls to add() and delete() using this class, you should batch you calls for best performance. For example, if you want to update 20 documents, you should first delete all those documents, then add all the new documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use IndexWriter instead.")]
public class IndexModifier
Visual Basic
<ObsoleteAttribute("Please use IndexWriter instead.")> _
Public Class IndexModifier
Visual C++
[ObsoleteAttribute(L"Please use IndexWriter instead.")]
public ref class IndexModifier

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexModifier

See Also

IndexModifier Members
Lucene.Net.Index Namespace


IndexModifier Members

[image] [image]

Lucene.Net Class Libraries
IndexModifier Members
IndexModifier Class Constructors Methods Fields See Also Send Feedback

The IndexModifier type exposes the following members.

Constructors

 | Name | Description
Public method | IndexModifier(FileInfo, Analyzer, Boolean) | Open an index with write access.
Public method | IndexModifier(String, Analyzer, Boolean) | Open an index with write access.
Public method | IndexModifier(Directory, Analyzer, Boolean) | Open an index with write access.

Methods

Name | Description
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Protected method AssureOpen
Throw an IllegalStateException if the index is closed.
Public method Close
Close this index, writing all pending changes to disk.
Protected method CreateIndexReader
Close the IndexWriter and open an IndexReader.
Protected method CreateIndexWriter
Close the IndexReader and open an IndexWriter.
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
.
Public method DeleteDocuments
Deletes all documents containing
CopyC#
term
. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.
Public method DocCount
Returns the number of documents currently in this index. If the writer is currently open, this returns {@link IndexWriter#DocCount()}, else {@link IndexReader#NumDocs()}. But, note that {@link IndexWriter#DocCount()} does not take deletions into account, unlike {@link IndexReader#numDocs}.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush
Make sure all changes are written to disk.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetInfoStream
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetMaxBufferedDocs
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetMaxFieldLength
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetMergeFactor
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUseCompoundFile
has this index open (
CopyC#
write.lock
 could not be obtained)
Protected method Init
Initialize an IndexWriter.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Optimize
Merges all segments together into a single segment, optimizing an index for search.
Public method SetInfoStream
If non-null, information about merges and a message when {@link #GetMaxFieldLength()} is reached will be printed to this.

Example: index.setInfoStream(System.err);

Public method SetMaxBufferedDocs
Determines the minimal number of documents required before the buffered in-memory documents are merging and a new Segment is created. Since Documents are merged in a {@link Lucene.Net.Store.RAMDirectory}, large value gives faster indexing. At the same time, mergeFactor limits the number of files open in a FSDirectory.

The default value is 10.

Public method SetMaxFieldLength
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory.

Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accommodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than 10,000 terms will be indexed for a field.

Public method SetMergeFactor
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

This must never be less than 2. The default value is 10.

Public method SetUseCompoundFile
Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | analyzer |
Protected field | closeDir |
Protected field | directory |
Protected field | indexReader |
Protected field | indexWriter |
Protected field | infoStream |
Protected field | maxBufferedDocs |
Protected field | maxFieldLength |
Protected field | mergeFactor |
Protected field | open |
Protected field | useCompoundFile |

See Also

IndexModifier Class
Lucene.Net.Index Namespace


IndexModifier Constructor

[image] [image]

Lucene.Net Class Libraries
IndexModifier Constructor
IndexModifier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexModifier(FileInfo, Analyzer, Boolean) | Open an index with write access.
Public method | IndexModifier(String, Analyzer, Boolean) | Open an index with write access.
Public method | IndexModifier(Directory, Analyzer, Boolean) | Open an index with write access.

See Also

IndexModifier Class
IndexModifier Members
Lucene.Net.Index Namespace


IndexModifier Constructor (FileInfo, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexModifier Constructor (FileInfo, Analyzer, Boolean)
IndexModifier Class See Also Send Feedback
Open an index with write access.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexModifier(
    FileInfo file,
    Analyzer analyzer,
    bool create
)
Visual Basic
Public Sub New ( _
    file As FileInfo, _
    analyzer As Analyzer, _
    create As Boolean _
)
Visual C++
public:
IndexModifier(
    FileInfo^ file,
    Analyzer^ analyzer,
    bool create
)

Parameters

file
Type: System.IO..::..FileInfo
the index directory
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use for adding new documents
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexModifier Class
IndexModifier Overload
Lucene.Net.Index Namespace


IndexModifier Constructor (String, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexModifier Constructor (String, Analyzer, Boolean)
IndexModifier Class See Also Send Feedback
Open an index with write access.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexModifier(
    string dirName,
    Analyzer analyzer,
    bool create
)
Visual Basic
Public Sub New ( _
    dirName As String, _
    analyzer As Analyzer, _
    create As Boolean _
)
Visual C++
public:
IndexModifier(
    String^ dirName,
    Analyzer^ analyzer,
    bool create
)

Parameters

dirName
Type: System..::..String
the index directory
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use for adding new documents
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexModifier Class
IndexModifier Overload
Lucene.Net.Index Namespace


IndexModifier Constructor (Directory, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexModifier Constructor (Directory, Analyzer, Boolean)
IndexModifier Class See Also Send Feedback
Open an index with write access.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexModifier(
    Directory directory,
    Analyzer analyzer,
    bool create
)
Visual Basic
Public Sub New ( _
    directory As Directory, _
    analyzer As Analyzer, _
    create As Boolean _
)
Visual C++
public:
IndexModifier(
    Directory^ directory,
    Analyzer^ analyzer,
    bool create
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the index directory
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use for adding new documents
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexModifier Class
IndexModifier Overload
Lucene.Net.Index Namespace


IndexModifier Fields

[image] [image]

Lucene.Net Class Libraries
IndexModifier Fields
IndexModifier Class See Also Send Feedback

The IndexModifier type exposes the following members.

Fields

 | Name | Description
Protected field | analyzer |
Protected field | closeDir |
Protected field | directory |
Protected field | indexReader |
Protected field | indexWriter |
Protected field | infoStream |
Protected field | maxBufferedDocs |
Protected field | maxFieldLength |
Protected field | mergeFactor |
Protected field | open |
Protected field | useCompoundFile |

See Also

IndexModifier Class
Lucene.Net.Index Namespace


analyzer Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..analyzer Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.analyzer"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Analyzer analyzer
Visual Basic
Protected Friend analyzer As Analyzer
Visual C++
protected public:
Analyzer^ analyzer

See Also

IndexModifier Class
Lucene.Net.Index Namespace


closeDir Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..closeDir Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.closeDir"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool closeDir
Visual Basic
Protected Friend closeDir As Boolean
Visual C++
protected public:
bool closeDir

See Also

IndexModifier Class
Lucene.Net.Index Namespace


directory Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..directory Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.directory"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Directory directory
Visual Basic
Protected Friend directory As Directory
Visual C++
protected public:
Directory^ directory

See Also

IndexModifier Class
Lucene.Net.Index Namespace


indexReader Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..indexReader Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.indexReader"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexReader indexReader
Visual Basic
Protected Friend indexReader As IndexReader
Visual C++
protected public:
IndexReader^ indexReader

See Also

IndexModifier Class
Lucene.Net.Index Namespace


indexWriter Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..indexWriter Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.indexWriter"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexWriter indexWriter
Visual Basic
Protected Friend indexWriter As IndexWriter
Visual C++
protected public:
IndexWriter^ indexWriter

See Also

IndexModifier Class
Lucene.Net.Index Namespace


infoStream Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..infoStream Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.infoStream"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal StreamWriter infoStream
Visual Basic
Protected Friend infoStream As StreamWriter
Visual C++
protected public:
StreamWriter^ infoStream

See Also

IndexModifier Class
Lucene.Net.Index Namespace


maxBufferedDocs Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..maxBufferedDocs Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.maxBufferedDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int maxBufferedDocs
Visual Basic
Protected Friend maxBufferedDocs As Integer
Visual C++
protected public:
int maxBufferedDocs

See Also

IndexModifier Class
Lucene.Net.Index Namespace


maxFieldLength Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..maxFieldLength Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.maxFieldLength"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int maxFieldLength
Visual Basic
Protected Friend maxFieldLength As Integer
Visual C++
protected public:
int maxFieldLength

See Also

IndexModifier Class
Lucene.Net.Index Namespace


mergeFactor Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..mergeFactor Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.mergeFactor"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int mergeFactor
Visual Basic
Protected Friend mergeFactor As Integer
Visual C++
protected public:
int mergeFactor

See Also

IndexModifier Class
Lucene.Net.Index Namespace


open Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..open Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.open"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool open
Visual Basic
Protected Friend open As Boolean
Visual C++
protected public:
bool open

See Also

IndexModifier Class
Lucene.Net.Index Namespace


useCompoundFile Field

[image]

Lucene.Net Class Libraries
IndexModifier..::..useCompoundFile Field
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexModifier.useCompoundFile"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool useCompoundFile
Visual Basic
Protected Friend useCompoundFile As Boolean
Visual C++
protected public:
bool useCompoundFile

See Also

IndexModifier Class
Lucene.Net.Index Namespace


IndexModifier Methods

[image] [image]

Lucene.Net Class Libraries
IndexModifier Methods
IndexModifier Class See Also Send Feedback

The IndexModifier type exposes the following members.

Methods

Name | Description
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Protected method AssureOpen
Throw an IllegalStateException if the index is closed.
Public method Close
Close this index, writing all pending changes to disk.
Protected method CreateIndexReader
Close the IndexWriter and open an IndexReader.
Protected method CreateIndexWriter
Close the IndexReader and open an IndexWriter.
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
.
Public method DeleteDocuments
Deletes all documents containing
CopyC#
term
. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.
Public method DocCount
Returns the number of documents currently in this index. If the writer is currently open, this returns {@link IndexWriter#DocCount()}, else {@link IndexReader#NumDocs()}. But, note that {@link IndexWriter#DocCount()} does not take deletions into account, unlike {@link IndexReader#numDocs}.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush
Make sure all changes are written to disk.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetInfoStream
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetMaxBufferedDocs
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetMaxFieldLength
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetMergeFactor
has this index open (
CopyC#
write.lock
 could not be obtained)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUseCompoundFile
has this index open (
CopyC#
write.lock
 could not be obtained)
Protected method Init
Initialize an IndexWriter.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Optimize
Merges all segments together into a single segment, optimizing an index for search.
Public method SetInfoStream
If non-null, information about merges and a message when {@link #GetMaxFieldLength()} is reached will be printed to this.

Example: index.setInfoStream(System.err);

Public method SetMaxBufferedDocs
Determines the minimal number of documents required before the buffered in-memory documents are merging and a new Segment is created. Since Documents are merged in a {@link Lucene.Net.Store.RAMDirectory}, large value gives faster indexing. At the same time, mergeFactor limits the number of files open in a FSDirectory.

The default value is 10.

Public method SetMaxFieldLength
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory.

Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accommodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than 10,000 terms will be indexed for a field.

Public method SetMergeFactor
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

This must never be less than 2. The default value is 10.

Public method SetUseCompoundFile
Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

IndexModifier Class
Lucene.Net.Index Namespace


AddDocument Method

[image] [image]

Lucene.Net Class Libraries
IndexModifier..::..AddDocument Method
IndexModifier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddDocument(Document) | Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
Public method | AddDocument(Document, Analyzer) | Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

See Also

IndexModifier Class
IndexModifier Members
Lucene.Net.Index Namespace


AddDocument Method (Document)

[image]

Lucene.Net Class Libraries
IndexModifier..::..AddDocument Method (Document)
IndexModifier Class See Also Send Feedback
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddDocument(
    Document doc
)
Visual Basic
Public Overridable Sub AddDocument ( _
    doc As Document _
)
Visual C++
public:
virtual void AddDocument(
    Document^ doc
)

Parameters

doc
Type: Lucene.Net.Documents..::..Document

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexModifier.AddDocument(Lucene.Net.Documents.Document)"]

See Also

IndexModifier Class
AddDocument Overload
Lucene.Net.Index Namespace
IndexWriter..::..AddDocument(Document)


AddDocument Method (Document, Analyzer)

[image]

Lucene.Net Class Libraries
IndexModifier..::..AddDocument Method (Document, Analyzer)
IndexModifier Class See Also Send Feedback
Adds a document to this index, using the provided analyzer instead of the one specific in the constructor. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddDocument(
    Document doc,
    Analyzer docAnalyzer
)
Visual Basic
Public Overridable Sub AddDocument ( _
    doc As Document, _
    docAnalyzer As Analyzer _
)
Visual C++
public:
virtual void AddDocument(
    Document^ doc,
    Analyzer^ docAnalyzer
)

Parameters

doc
Type: Lucene.Net.Documents..::..Document

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexModifier.AddDocument(Lucene.Net.Documents.Document,Lucene.Net.Analysis.Analyzer)"]

docAnalyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="docAnalyzer"/> documentation for "M:Lucene.Net.Index.IndexModifier.AddDocument(Lucene.Net.Documents.Document,Lucene.Net.Analysis.Analyzer)"]

See Also

IndexModifier Class
AddDocument Overload
Lucene.Net.Index Namespace
IndexWriter..::..AddDocument(Document, Analyzer)


AssureOpen Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..AssureOpen Method
IndexModifier Class See Also Send Feedback
Throw an IllegalStateException if the index is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void AssureOpen()
Visual Basic
Protected Friend Overridable Sub AssureOpen
Visual C++
protected public:
virtual void AssureOpen()

See Also

IndexModifier Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..Close Method
IndexModifier Class See Also Send Feedback
Close this index, writing all pending changes to disk.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

See Also

IndexModifier Class
Lucene.Net.Index Namespace


CreateIndexReader Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..CreateIndexReader Method
IndexModifier Class See Also Send Feedback
Close the IndexWriter and open an IndexReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void CreateIndexReader()
Visual Basic
Protected Friend Overridable Sub CreateIndexReader
Visual C++
protected public:
virtual void CreateIndexReader()

See Also

IndexModifier Class
Lucene.Net.Index Namespace


CreateIndexWriter Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..CreateIndexWriter Method
IndexModifier Class See Also Send Feedback
Close the IndexReader and open an IndexWriter.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void CreateIndexWriter()
Visual Basic
Protected Friend Overridable Sub CreateIndexWriter
Visual C++
protected public:
virtual void CreateIndexWriter()

See Also

IndexModifier Class
Lucene.Net.Index Namespace


DeleteDocument Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..DeleteDocument Method
IndexModifier Class See Also Send Feedback
Deletes the document numbered
CopyC#
docNum
.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteDocument(
    int docNum
)
Visual Basic
Public Overridable Sub DeleteDocument ( _
    docNum As Integer _
)
Visual C++
public:
virtual void DeleteDocument(
    int docNum
)

Parameters

docNum
Type: System..::..Int32

[Missing <param name="docNum"/> documentation for "M:Lucene.Net.Index.IndexModifier.DeleteDocument(System.Int32)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexReader..::..DeleteDocument(Int32)


DeleteDocuments Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..DeleteDocuments Method
IndexModifier Class See Also Send Feedback
Deletes all documents containing
CopyC#
term
. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. Returns the number of documents deleted.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int DeleteDocuments(
    Term term
)
Visual Basic
Public Overridable Function DeleteDocuments ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DeleteDocuments(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.IndexModifier.DeleteDocuments(Lucene.Net.Index.Term)"]

Return Value

the number of documents deleted

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexReader..::..DeleteDocuments(Term)


DocCount Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..DocCount Method
IndexModifier Class See Also Send Feedback
Returns the number of documents currently in this index. If the writer is currently open, this returns {@link IndexWriter#DocCount()}, else {@link IndexReader#NumDocs()}. But, note that {@link IndexWriter#DocCount()} does not take deletions into account, unlike {@link IndexReader#numDocs}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int DocCount()
Visual Basic
Public Overridable Function DocCount As Integer
Visual C++
public:
virtual int DocCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.DocCount"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace


Flush Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..Flush Method
IndexModifier Class See Also Send Feedback
Make sure all changes are written to disk.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Flush()
Visual Basic
Public Overridable Sub Flush
Visual C++
public:
virtual void Flush()

See Also

IndexModifier Class
Lucene.Net.Index Namespace


GetInfoStream Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..GetInfoStream Method
IndexModifier Class See Also Send Feedback
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual StreamWriter GetInfoStream()
Visual Basic
Public Overridable Function GetInfoStream As StreamWriter
Visual C++
public:
virtual StreamWriter^ GetInfoStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.GetInfoStream"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
[!:IndexModifier.SetInfoStream(PrintStream)]


GetMaxBufferedDocs Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..GetMaxBufferedDocs Method
IndexModifier Class See Also Send Feedback
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxBufferedDocs()
Visual Basic
Public Overridable Function GetMaxBufferedDocs As Integer
Visual C++
public:
virtual int GetMaxBufferedDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.GetMaxBufferedDocs"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexModifier..::..SetMaxBufferedDocs(Int32)


GetMaxFieldLength Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..GetMaxFieldLength Method
IndexModifier Class See Also Send Feedback
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxFieldLength()
Visual Basic
Public Overridable Function GetMaxFieldLength As Integer
Visual C++
public:
virtual int GetMaxFieldLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.GetMaxFieldLength"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexModifier..::..SetMaxFieldLength(Int32)


GetMergeFactor Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..GetMergeFactor Method
IndexModifier Class See Also Send Feedback
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMergeFactor()
Visual Basic
Public Overridable Function GetMergeFactor As Integer
Visual C++
public:
virtual int GetMergeFactor()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.GetMergeFactor"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexModifier..::..SetMergeFactor(Int32)


GetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..GetUseCompoundFile Method
IndexModifier Class See Also Send Feedback
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetUseCompoundFile()
Visual Basic
Public Overridable Function GetUseCompoundFile As Boolean
Visual C++
public:
virtual bool GetUseCompoundFile()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.GetUseCompoundFile"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
[!:IndexModifier.SetUseCompoundFile(boolean)]


Init Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..Init Method
IndexModifier Class See Also Send Feedback
Initialize an IndexWriter.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void Init(
    Directory directory,
    Analyzer analyzer,
    bool create
)
Visual Basic
Protected Friend Overridable Sub Init ( _
    directory As Directory, _
    analyzer As Analyzer, _
    create As Boolean _
)
Visual C++
protected public:
virtual void Init(
    Directory^ directory,
    Analyzer^ analyzer,
    bool create
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.IndexModifier.Init(Lucene.Net.Store.Directory,Lucene.Net.Analysis.Analyzer,System.Boolean)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Index.IndexModifier.Init(Lucene.Net.Store.Directory,Lucene.Net.Analysis.Analyzer,System.Boolean)"]

create
Type: System..::..Boolean

[Missing <param name="create"/> documentation for "M:Lucene.Net.Index.IndexModifier.Init(Lucene.Net.Store.Directory,Lucene.Net.Analysis.Analyzer,System.Boolean)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace


Optimize Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..Optimize Method
IndexModifier Class See Also Send Feedback
Merges all segments together into a single segment, optimizing an index for search.
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Optimize()
Visual Basic
Public Overridable Sub Optimize
Visual C++
public:
virtual void Optimize()

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexWriter..::..Optimize()()()()


SetInfoStream Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..SetInfoStream Method
IndexModifier Class See Also Send Feedback
If non-null, information about merges and a message when {@link #GetMaxFieldLength()} is reached will be printed to this.

Example: index.setInfoStream(System.err);

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetInfoStream(
    StreamWriter infoStream
)
Visual Basic
Public Overridable Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
Visual C++
public:
virtual void SetInfoStream(
    StreamWriter^ infoStream
)

Parameters

infoStream
Type: System.IO..::..StreamWriter

[Missing <param name="infoStream"/> documentation for "M:Lucene.Net.Index.IndexModifier.SetInfoStream(System.IO.StreamWriter)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
[!:IndexWriter.SetInfoStream(PrintStream)]


SetMaxBufferedDocs Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..SetMaxBufferedDocs Method
IndexModifier Class See Also Send Feedback
Determines the minimal number of documents required before the buffered in-memory documents are merging and a new Segment is created. Since Documents are merged in a {@link Lucene.Net.Store.RAMDirectory}, large value gives faster indexing. At the same time, mergeFactor limits the number of files open in a FSDirectory.

The default value is 10.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)
Visual Basic
Public Overridable Sub SetMaxBufferedDocs ( _
    maxBufferedDocs As Integer _
)
Visual C++
public:
virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)

Parameters

maxBufferedDocs
Type: System..::..Int32

[Missing <param name="maxBufferedDocs"/> documentation for "M:Lucene.Net.Index.IndexModifier.SetMaxBufferedDocs(System.Int32)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexWriter..::..SetMaxBufferedDocs(Int32)


SetMaxFieldLength Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..SetMaxFieldLength Method
IndexModifier Class See Also Send Feedback
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory.

Note that this effectively truncates large documents, excluding from the index terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accommodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than 10,000 terms will be indexed for a field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxFieldLength(
    int maxFieldLength
)
Visual Basic
Public Overridable Sub SetMaxFieldLength ( _
    maxFieldLength As Integer _
)
Visual C++
public:
virtual void SetMaxFieldLength(
    int maxFieldLength
)

Parameters

maxFieldLength
Type: System..::..Int32

[Missing <param name="maxFieldLength"/> documentation for "M:Lucene.Net.Index.IndexModifier.SetMaxFieldLength(System.Int32)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexWriter..::..SetMaxFieldLength(Int32)


SetMergeFactor Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..SetMergeFactor Method
IndexModifier Class See Also Send Feedback
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

This must never be less than 2. The default value is 10.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergeFactor(
    int mergeFactor
)
Visual Basic
Public Overridable Sub SetMergeFactor ( _
    mergeFactor As Integer _
)
Visual C++
public:
virtual void SetMergeFactor(
    int mergeFactor
)

Parameters

mergeFactor
Type: System..::..Int32

[Missing <param name="mergeFactor"/> documentation for "M:Lucene.Net.Index.IndexModifier.SetMergeFactor(System.Int32)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
IndexWriter..::..SetMergeFactor(Int32)


SetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..SetUseCompoundFile Method
IndexModifier Class See Also Send Feedback
Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file once the segment creation is finished. This is done regardless of what directory is in use.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetUseCompoundFile(
    bool useCompoundFile
)
Visual Basic
Public Overridable Sub SetUseCompoundFile ( _
    useCompoundFile As Boolean _
)
Visual C++
public:
virtual void SetUseCompoundFile(
    bool useCompoundFile
)

Parameters

useCompoundFile
Type: System..::..Boolean

[Missing <param name="useCompoundFile"/> documentation for "M:Lucene.Net.Index.IndexModifier.SetUseCompoundFile(System.Boolean)"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace
[!:IndexWriter.SetUseCompoundFile(boolean)]


ToString Method

[image]

Lucene.Net Class Libraries
IndexModifier..::..ToString Method
IndexModifier Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexModifier.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexModifier.ToString"]

See Also

IndexModifier Class
Lucene.Net.Index Namespace


IndexReader Class

[image]

Lucene.Net Class Libraries
IndexReader Class
Members See Also Send Feedback
IndexReader is an abstract class, providing an interface for accessing an index. Search of an index is done entirely through this abstract interface, so that any subclass which implements it is searchable.

Concrete subclasses of IndexReader are usually constructed with a call to one of the static

CopyC#
open()
methods, e.g. {@link #Open(String, boolean)}.

For efficiency, in this API documents are often referred to via document numbers, non-negative integers which each name a unique document in the index. These document numbers are ephemeral--they may change as documents are added to and deleted from an index. Clients should thus not rely on a given document having the same number between sessions.

An IndexReader can be opened on a directory for which an IndexWriter is opened already, but it cannot be used to delete documents from the index then.

NOTE: for backwards API compatibility, several methods are not listed as abstract, but have no useful implementations in this base class and instead always throw UnsupportedOperationException. Subclasses are strongly encouraged to override these methods, but in many cases may not need to.

NOTE: as of 2.4, it's possible to open a read-only IndexReader using one of the static open methods that accepts the boolean readOnly parameter. Such a reader has better concurrency as it's not necessary to synchronize on the isDeleted method. Currently the default for readOnly is false, meaning if not specified you will get a read/write IndexReader. But in 3.0 this default will change to true, meaning you must explicitly specify false if you want to make changes with the resulting IndexReader.

NOTE: {@link

CopyC#
IndexReader
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexReader
 instance; use your own (non-Lucene) objects instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class IndexReader : ICloneable,
    IDisposable
Visual Basic
Public MustInherit Class IndexReader _
    Implements ICloneable, IDisposable
Visual C++
public ref class IndexReader abstract : ICloneable,
    IDisposable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..DirectoryReader
Lucene.Net.Index..::..FilterIndexReader
Lucene.Net.Index..::..MultiReader
Lucene.Net.Index..::..ParallelReader
Lucene.Net.Index..::..SegmentReader

See Also

IndexReader Members
Lucene.Net.Index Namespace


IndexReader Members

[image] [image]

Lucene.Net Class Libraries
IndexReader Members
IndexReader Class Constructors Methods Fields Properties See Also Send Feedback

The IndexReader type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexReader()()()() | Initializes a new instance of the IndexReader class
Protected method | IndexReader(Directory) | Obsolete. Legacy Constructor for backwards compatibility. This Constructor should not be used, it exists for backwards compatibility only to support legacy subclasses that did not "own" a specific directory, but needed to specify something to be returned by the directory() method. Future subclasses should delegate to the no arg constructor and implement the directory() method as appropriate.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
Public method Clone()()()()
Efficiently clones the IndexReader (sharing most internal state).

On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned.

Like {@link #Reopen()}, it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
Public method Dispose
.NET
Public method DocFreq
Returns the number of documents containing the term
CopyC#
t
.
Protected method DoClose
Implements close.
Protected method DoCommit()()()() Obsolete.
Implements commit.
Protected method DoCommit(IDictionary<(Of <<'(String, String>)>>))
Implements commit. NOTE: subclasses should override this. In 3.0 this will become an abstract method.
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Public method Document(Int32, FieldSelector)
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Protected method DoDelete
Implements deletion of the document numbered
CopyC#
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.
Protected method DoSetNorm
Implements setNorm in subclass.
Protected method DoUndeleteAll
Implements actual undeleteAll() in subclass.
Protected method | EnsureOpen
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
Public method | Flush(IDictionary<(Of <<'(String, String>)>>))
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
GetCommitUserData(Directory)
Reads commitUserData, previously passed to {@link IndexWriter#Commit(Map)}, from current index segments file. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
GetCurrentVersion(FileInfo) Obsolete.
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
GetCurrentVersion(String) Obsolete.
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
GetCurrentVersion(Directory)
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
Public method | GetDeletesCacheKey
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
Public method GetFieldCacheKey Obsolete.
Expert
Public method GetFieldNames
Get a list of unique field names that exist in this index and have the specified field option information.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

Public method GetRefCount
Expert: returns the current refCount for this reader
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

Public method GetTermFreqVector(Int32, TermVectorMapper)
Map all the term vectors for all fields in a Document
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a {@link TermPositionVector} is returned.
Public method GetTermFreqVector(Int32, String, TermVectorMapper)
Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the {@link TermFreqVector}.
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned may either be of type {@link TermFreqVector} or of type {@link TermPositionVector} if positions or offsets have been stored.
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
Public method GetVersion
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

Public method HasDeletions
Returns true if any documents have been deleted
Public method HasNorms
Returns true if there are norms stored for this field.
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IndexExists(FileInfo) Obsolete.
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
IndexExists(String) Obsolete.
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
CopyC#
false
 is returned.
IndexExists(Directory)
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

Public method IsDeleted
Returns true if document n has been deleted
IsLocked(String) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
IsLocked(Directory) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
LastModified(FileInfo) Obsolete.
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
LastModified(String) Obsolete.
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
LastModified(Directory)
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
ListCommits
Returns all commit points that exist in the Directory. Normally, because the default is {@link KeepOnlyLastCommitDeletionPolicy}, there would be only one commit point. But if you're using a custom {@link IndexDeletionPolicy} then there could be many commits. Once you have a given commit, you can open a reader on it by calling {@link IndexReader#Open(IndexCommit)} There must be at least one commit in the Directory, else this method throws {@link java.io.IOException}. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.
Main
Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.
Public method MaxDoc
Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Norms(String)
Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method Norms(String, array<Byte>[]()[][], Int32)
Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method NumDeletedDocs
Returns the number of deleted documents.
Public method NumDocs
Returns the number of documents in this index.
Open(FileInfo) Obsolete.
Returns a read/write IndexReader reading the index in an FSDirectory in the named path.
Open(String) Obsolete.
Returns a read/write IndexReader reading the index in an FSDirectory in the named path.
Open(Directory) Obsolete.
Returns a read/write IndexReader reading the index in the given Directory.
Open(IndexCommit) Obsolete.
Expert: returns a read/write IndexReader reading the index in the given {@link IndexCommit}.
Open(FileInfo, Boolean) Obsolete.
Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(String, Boolean) Obsolete.
Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy) Obsolete.
Expert: returns a read/write IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}.
Open(Directory, Boolean)
Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy) Obsolete.
Expert: returns a read/write IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}.
Open(IndexCommit, Boolean)
Expert: returns an IndexReader reading the index in the given {@link IndexCommit}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

Public method TermDocs()()()()
Returns an unpositioned {@link TermDocs} enumerator.
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Public method TermPositions()()()()
Returns an unpositioned {@link TermPositions} enumerator.
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Public method Terms()()()()
Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
Public method Terms(Term)
Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
Unlock Obsolete.
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

Fields

 | Name | Description
Protected field | hasChanges |

Properties

 | Name | Description
Public property | hasChanges_ForNUnit |

See Also

IndexReader Class
Lucene.Net.Index Namespace


IndexReader Constructor

[image] [image]

Lucene.Net Class Libraries
IndexReader Constructor
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IndexReader()()()() | Initializes a new instance of the IndexReader class
Protected method | IndexReader(Directory) | Obsolete. Legacy Constructor for backwards compatibility. This Constructor should not be used, it exists for backwards compatibility only to support legacy subclasses that did not "own" a specific directory, but needed to specify something to be returned by the directory() method. Future subclasses should delegate to the no arg constructor and implement the directory() method as appropriate.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


IndexReader Constructor

[image]

Lucene.Net Class Libraries
IndexReader Constructor
IndexReader Class See Also Send Feedback
Initializes a new instance of the IndexReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexReader()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
IndexReader()

See Also

IndexReader Class
IndexReader Overload
Lucene.Net.Index Namespace


IndexReader Constructor (Directory)

[image]

Lucene.Net Class Libraries
IndexReader Constructor (Directory)
IndexReader Class See Also Send Feedback
Legacy Constructor for backwards compatibility.

This Constructor should not be used, it exists for backwards compatibility only to support legacy subclasses that did not "own" a specific directory, but needed to specify something to be returned by the directory() method. Future subclasses should delegate to the no arg constructor and implement the directory() method as appropriate.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("- use IndexReader()")]
protected internal IndexReader(
    Directory directory
)
Visual Basic
<ObsoleteAttribute("- use IndexReader()")> _
Protected Friend Sub New ( _
    directory As Directory _
)
Visual C++
[ObsoleteAttribute(L"- use IndexReader()")]
protected public:
IndexReader(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
Directory to be returned by the directory() method

See Also

IndexReader Class
IndexReader Overload
Lucene.Net.Index Namespace
IndexReader..::..Directory()()()()


IndexReader Fields

[image] [image]

Lucene.Net Class Libraries
IndexReader Fields
IndexReader Class See Also Send Feedback

The IndexReader type exposes the following members.

Fields

 | Name | Description
Protected field | hasChanges |

See Also

IndexReader Class
Lucene.Net.Index Namespace


hasChanges Field

[image]

Lucene.Net Class Libraries
IndexReader..::..hasChanges Field
IndexReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexReader.hasChanges"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool hasChanges
Visual Basic
Protected Friend hasChanges As Boolean
Visual C++
protected public:
bool hasChanges

See Also

IndexReader Class
Lucene.Net.Index Namespace


IndexReader Methods

[image] [image]

Lucene.Net Class Libraries
IndexReader Methods
IndexReader Class See Also Send Feedback

The IndexReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
Public method Clone()()()()
Efficiently clones the IndexReader (sharing most internal state).

On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned.

Like {@link #Reopen()}, it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
Public method Dispose
.NET
Public method DocFreq
Returns the number of documents containing the term
CopyC#
t
.
Protected method DoClose
Implements close.
Protected method DoCommit()()()() Obsolete.
Implements commit.
Protected method DoCommit(IDictionary<(Of <<'(String, String>)>>))
Implements commit. NOTE: subclasses should override this. In 3.0 this will become an abstract method.
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Public method Document(Int32, FieldSelector)
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Protected method DoDelete
Implements deletion of the document numbered
CopyC#
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.
Protected method DoSetNorm
Implements setNorm in subclass.
Protected method DoUndeleteAll
Implements actual undeleteAll() in subclass.
Protected method | EnsureOpen
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
Public method | Flush(IDictionary<(Of <<'(String, String>)>>))
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
GetCommitUserData(Directory)
Reads commitUserData, previously passed to {@link IndexWriter#Commit(Map)}, from current index segments file. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
GetCurrentVersion(FileInfo) Obsolete.
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
GetCurrentVersion(String) Obsolete.
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
GetCurrentVersion(Directory)
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
Public method | GetDeletesCacheKey
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
Public method GetFieldCacheKey Obsolete.
Expert
Public method GetFieldNames
Get a list of unique field names that exist in this index and have the specified field option information.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

Public method GetRefCount
Expert: returns the current refCount for this reader
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

Public method GetTermFreqVector(Int32, TermVectorMapper)
Map all the term vectors for all fields in a Document
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a {@link TermPositionVector} is returned.
Public method GetTermFreqVector(Int32, String, TermVectorMapper)
Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the {@link TermFreqVector}.
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned may either be of type {@link TermFreqVector} or of type {@link TermPositionVector} if positions or offsets have been stored.
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
Public method GetVersion
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

Public method HasDeletions
Returns true if any documents have been deleted
Public method HasNorms
Returns true if there are norms stored for this field.
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
IndexExists(FileInfo) Obsolete.
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
IndexExists(String) Obsolete.
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
CopyC#
false
 is returned.
IndexExists(Directory)
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

Public method IsDeleted
Returns true if document n has been deleted
IsLocked(String) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
IsLocked(Directory) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
LastModified(FileInfo) Obsolete.
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
LastModified(String) Obsolete.
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
LastModified(Directory)
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
ListCommits
Returns all commit points that exist in the Directory. Normally, because the default is {@link KeepOnlyLastCommitDeletionPolicy}, there would be only one commit point. But if you're using a custom {@link IndexDeletionPolicy} then there could be many commits. Once you have a given commit, you can open a reader on it by calling {@link IndexReader#Open(IndexCommit)} There must be at least one commit in the Directory, else this method throws {@link java.io.IOException}. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.
Main
Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.
Public method MaxDoc
Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Norms(String)
Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method Norms(String, array<Byte>[]()[][], Int32)
Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method NumDeletedDocs
Returns the number of deleted documents.
Public method NumDocs
Returns the number of documents in this index.
Open(FileInfo) Obsolete.
Returns a read/write IndexReader reading the index in an FSDirectory in the named path.
Open(String) Obsolete.
Returns a read/write IndexReader reading the index in an FSDirectory in the named path.
Open(Directory) Obsolete.
Returns a read/write IndexReader reading the index in the given Directory.
Open(IndexCommit) Obsolete.
Expert: returns a read/write IndexReader reading the index in the given {@link IndexCommit}.
Open(FileInfo, Boolean) Obsolete.
Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(String, Boolean) Obsolete.
Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy) Obsolete.
Expert: returns a read/write IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}.
Open(Directory, Boolean)
Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy) Obsolete.
Expert: returns a read/write IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}.
Open(IndexCommit, Boolean)
Expert: returns an IndexReader reading the index in the given {@link IndexCommit}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean, Int32)
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

Public method TermDocs()()()()
Returns an unpositioned {@link TermDocs} enumerator.
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Public method TermPositions()()()()
Returns an unpositioned {@link TermPositions} enumerator.
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Public method Terms()()()()
Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
Public method Terms(Term)
Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
Unlock Obsolete.
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

See Also

IndexReader Class
Lucene.Net.Index Namespace


AcquireWriteLock Method

[image]

Lucene.Net Class Libraries
IndexReader..::..AcquireWriteLock Method
IndexReader Class See Also Send Feedback
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void AcquireWriteLock()
Visual Basic
Protected Friend Overridable Sub AcquireWriteLock
Visual C++
protected public:
virtual void AcquireWriteLock()

See Also

IndexReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Clone Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Efficiently clones the IndexReader (sharing most internal state). On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned. Like {@link #Reopen()}, it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Clone Method
IndexReader Class See Also Send Feedback
Efficiently clones the IndexReader (sharing most internal state).

On cloning a reader with pending changes (deletions, norms), the original reader transfers its write lock to the cloned reader. This means only the cloned reader may make further changes to the index, and commit the changes to the index on close, but the old reader still reflects all changes made up until it was cloned.

Like {@link #Reopen()}, it's safe to make changes to either the original or the cloned reader: all shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

IndexReader Class
Clone Overload
Lucene.Net.Index Namespace


Clone Method (Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Clone Method (Boolean)
IndexReader Class See Also Send Feedback
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader Clone(
    bool openReadOnly
)
Visual Basic
Public Overridable Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Clone(
    bool openReadOnly
)

Parameters

openReadOnly
Type: System..::..Boolean

[Missing <param name="openReadOnly"/> documentation for "M:Lucene.Net.Index.IndexReader.Clone(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Clone(System.Boolean)"]

See Also

IndexReader Class
Clone Overload
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Close Method
IndexReader Class See Also Send Feedback
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

IndexReader Class
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Commit Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Commit Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Commit Method
IndexReader Class See Also Send Feedback
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Commit()
Visual Basic
Public Sub Commit
Visual C++
public:
void Commit()

See Also

IndexReader Class
Commit Overload
Lucene.Net.Index Namespace


Commit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
IndexReader..::..Commit Method (IDictionary<(Of <(<'String, String>)>)>)
IndexReader Class See Also Send Feedback
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Commit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Public Sub Commit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
public:
void Commit(
    IDictionary<String^, String^>^ commitUserData
)

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.IndexReader.Commit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

IndexReader Class
Commit Overload
Lucene.Net.Index Namespace


DecRef Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DecRef Method
IndexReader Class See Also Send Feedback
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DecRef()
Visual Basic
Public Overridable Sub DecRef
Visual C++
public:
virtual void DecRef()

See Also

IndexReader Class
Lucene.Net.Index Namespace
[!:incRef]


DeleteDocument Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DeleteDocument Method
IndexReader Class See Also Send Feedback
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteDocument(
    int docNum
)
Visual Basic
Public Overridable Sub DeleteDocument ( _
    docNum As Integer _
)
Visual C++
public:
virtual void DeleteDocument(
    int docNum
)

Parameters

docNum
Type: System..::..Int32

[Missing <param name="docNum"/> documentation for "M:Lucene.Net.Index.IndexReader.DeleteDocument(System.Int32)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


DeleteDocuments Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DeleteDocuments Method
IndexReader Class See Also Send Feedback
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int DeleteDocuments(
    Term term
)
Visual Basic
Public Overridable Function DeleteDocuments ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DeleteDocuments(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.IndexReader.DeleteDocuments(Lucene.Net.Index.Term)"]

Return Value

the number of documents deleted

See Also

IndexReader Class
Lucene.Net.Index Namespace


Directory Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Directory Method
IndexReader Class See Also Send Feedback
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Directory Directory()
Visual Basic
Public Overridable Function Directory As Directory
Visual C++
public:
virtual Directory^ Directory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Directory"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Dispose Method
IndexReader Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IndexReader Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DocFreq Method
IndexReader Class See Also Send Feedback
Returns the number of documents containing the term
CopyC#
t
.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int DocFreq(
    Term t
)
Visual Basic
Public MustOverride Function DocFreq ( _
    t As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ t
) abstract

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.IndexReader.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.DocFreq(Lucene.Net.Index.Term)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


DoClose Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DoClose Method
IndexReader Class See Also Send Feedback
Implements close.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract void DoClose()
Visual Basic
Protected Friend MustOverride Sub DoClose
Visual C++
protected public:
virtual void DoClose() abstract

See Also

IndexReader Class
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..DoCommit Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. Implements commit.
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | Implements commit. NOTE: subclasses should override this. In 3.0 this will become an abstract method.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DoCommit Method
IndexReader Class See Also Send Feedback
Implements commit.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please implement DoCommit(IDictionary<string, string>) instead")]
protected internal abstract void DoCommit()
Visual Basic
<ObsoleteAttribute("Please implement DoCommit(IDictionary<string, string>) instead")> _
Protected Friend MustOverride Sub DoCommit
Visual C++
[ObsoleteAttribute(L"Please implement DoCommit(IDictionary<string, string>) instead")]
protected public:
virtual void DoCommit() abstract

See Also

IndexReader Class
DoCommit Overload
Lucene.Net.Index Namespace


DoCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
IndexReader..::..DoCommit Method (IDictionary<(Of <(<'String, String>)>)>)
IndexReader Class See Also Send Feedback
Implements commit. NOTE: subclasses should override this. In 3.0 this will become an abstract method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void DoCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Protected Friend Overridable Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
protected public:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
)

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.IndexReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

IndexReader Class
DoCommit Overload
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Document Method
IndexReader Class See Also Send Feedback

Overload List

Name Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Public method Document(Int32, FieldSelector)
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Document Method (Int32)

[image]

Lucene.Net Class Libraries
IndexReader..::..Document Method (Int32)
IndexReader Class See Also Send Feedback
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Document Document(
    int n
)
Visual Basic
Public Overridable Function Document ( _
    n As Integer _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.IndexReader.Document(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Document(System.Int32)"]

See Also

IndexReader Class
Document Overload
Lucene.Net.Index Namespace


Document Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
IndexReader..::..Document Method (Int32, FieldSelector)
IndexReader Class See Also Send Feedback
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If this Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Document Document(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public MustOverride Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) abstract

Parameters

n
Type: System..::..Int32
Get the document at the
CopyC#
n
th position
fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector
The {@link FieldSelector} to use to determine what Fields should be loaded on the Document. May be null, in which case all Fields will be loaded.

Return Value

The stored fields of the {@link Lucene.Net.Documents.Document} at the nth position

See Also

IndexReader Class
Document Overload
Lucene.Net.Index Namespace
Lucene.Net.Documents..::..Fieldable
Lucene.Net.Documents..::..FieldSelector
Lucene.Net.Documents..::..SetBasedFieldSelector
Lucene.Net.Documents..::..LoadFirstFieldSelector


DoDelete Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DoDelete Method
IndexReader Class See Also Send Feedback
Implements deletion of the document numbered
CopyC#
docNum
. Applications should call {@link #DeleteDocument(int)} or {@link #DeleteDocuments(Term)}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract void DoDelete(
    int docNum
)
Visual Basic
Protected Friend MustOverride Sub DoDelete ( _
    docNum As Integer _
)
Visual C++
protected public:
virtual void DoDelete(
    int docNum
) abstract

Parameters

docNum
Type: System..::..Int32

[Missing <param name="docNum"/> documentation for "M:Lucene.Net.Index.IndexReader.DoDelete(System.Int32)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


DoSetNorm Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DoSetNorm Method
IndexReader Class See Also Send Feedback
Implements setNorm in subclass.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract void DoSetNorm(
    int doc,
    string field,
    byte value_Renamed
)
Visual Basic
Protected Friend MustOverride Sub DoSetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Visual C++
protected public:
virtual void DoSetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
) abstract

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.IndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

value_Renamed
Type: System..::..Byte

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.IndexReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


DoUndeleteAll Method

[image]

Lucene.Net Class Libraries
IndexReader..::..DoUndeleteAll Method
IndexReader Class See Also Send Feedback
Implements actual undeleteAll() in subclass.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract void DoUndeleteAll()
Visual Basic
Protected Friend MustOverride Sub DoUndeleteAll
Visual C++
protected public:
virtual void DoUndeleteAll() abstract

See Also

IndexReader Class
Lucene.Net.Index Namespace


EnsureOpen Method

[image]

Lucene.Net Class Libraries
IndexReader..::..EnsureOpen Method
IndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexReader.EnsureOpen"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal void EnsureOpen()
Visual Basic
Protected Friend Sub EnsureOpen
Visual C++
protected public:
void EnsureOpen()

See Also

IndexReader Class
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Flush Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() |
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) |

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Flush Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Flush Method
IndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexReader.Flush"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Flush()
Visual Basic
Public Sub Flush
Visual C++
public:
void Flush()

See Also

IndexReader Class
Flush Overload
Lucene.Net.Index Namespace


Flush Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
IndexReader..::..Flush Method (IDictionary<(Of <(<'String, String>)>)>)
IndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexReader.Flush(System.Collections.Generic.IDictionary{System.String,System.String})"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Flush(
    IDictionary<string, string> commitUserData
)
Visual Basic
Public Sub Flush ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
public:
void Flush(
    IDictionary<String^, String^>^ commitUserData
)

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
Opaque Map (String -> String) that's recorded into the segments file in the index, and retrievable by {@link IndexReader#getCommitUserData}.

See Also

IndexReader Class
Flush Overload
Lucene.Net.Index Namespace


GetCommitUserData Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..GetCommitUserData Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCommitUserData()()()() | Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
 | GetCommitUserData(Directory) | Reads commitUserData, previously passed to {@link IndexWriter#Commit(Map)}, from current index segments file. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


GetCommitUserData Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetCommitUserData Method
IndexReader Class See Also Send Feedback
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IDictionary<string, string> GetCommitUserData()
Visual Basic
Public Overridable Function GetCommitUserData As IDictionary(Of String, String)
Visual C++
public:
virtual IDictionary<String^, String^>^ GetCommitUserData()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetCommitUserData"]

See Also

IndexReader Class
GetCommitUserData Overload
Lucene.Net.Index Namespace
IndexReader..::..GetCommitUserData(Directory)


GetCommitUserData Method (Directory)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetCommitUserData Method (Directory)
IndexReader Class See Also Send Feedback
Reads commitUserData, previously passed to {@link IndexWriter#Commit(Map)}, from current index segments file. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IDictionary<string, string> GetCommitUserData(
    Directory directory
)
Visual Basic
Public Shared Function GetCommitUserData ( _
    directory As Directory _
) As IDictionary(Of String, String)
Visual C++
public:
static IDictionary<String^, String^>^ GetCommitUserData(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
where the index resides.

Return Value

commit userData.

See Also

IndexReader Class
GetCommitUserData Overload
Lucene.Net.Index Namespace
IndexReader..::..GetCommitUserData()()()()


GetCurrentVersion Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..GetCurrentVersion Method
IndexReader Class See Also Send Feedback

Overload List

Name | Description
GetCurrentVersion(FileInfo) | Obsolete. Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
GetCurrentVersion(String) | Obsolete. Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.
GetCurrentVersion(Directory) | Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


GetCurrentVersion Method (FileInfo)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetCurrentVersion Method (FileInfo)
IndexReader Class See Also Send Feedback
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetCurrentVersion(Directory) instead. This method will be removed in the 3.0 release.")]
public static long GetCurrentVersion(
    FileInfo directory
)
Visual Basic
<ObsoleteAttribute("Use GetCurrentVersion(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function GetCurrentVersion ( _
    directory As FileInfo _
) As Long
Visual C++
[ObsoleteAttribute(L"Use GetCurrentVersion(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static long long GetCurrentVersion(
    FileInfo^ directory
)

Parameters

directory
Type: System.IO..::..FileInfo
where the index resides.

Return Value

version number.

See Also

IndexReader Class
GetCurrentVersion Overload
Lucene.Net.Index Namespace


GetCurrentVersion Method (String)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetCurrentVersion Method (String)
IndexReader Class See Also Send Feedback
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetCurrentVersion(Directory) instead. This method will be removed in the 3.0 release.")]
public static long GetCurrentVersion(
    string directory
)
Visual Basic
<ObsoleteAttribute("Use GetCurrentVersion(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function GetCurrentVersion ( _
    directory As String _
) As Long
Visual C++
[ObsoleteAttribute(L"Use GetCurrentVersion(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static long long GetCurrentVersion(
    String^ directory
)

Parameters

directory
Type: System..::..String
where the index resides.

Return Value

version number.

See Also

IndexReader Class
GetCurrentVersion Overload
Lucene.Net.Index Namespace


GetCurrentVersion Method (Directory)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetCurrentVersion Method (Directory)
IndexReader Class See Also Send Feedback
Reads version number from segments files. The version number is initialized with a timestamp and then increased by one for each change of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GetCurrentVersion(
    Directory directory
)
Visual Basic
Public Shared Function GetCurrentVersion ( _
    directory As Directory _
) As Long
Visual C++
public:
static long long GetCurrentVersion(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
where the index resides.

Return Value

version number.

See Also

IndexReader Class
GetCurrentVersion Overload
Lucene.Net.Index Namespace


GetDeletesCacheKey Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetDeletesCacheKey Method
IndexReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexReader.GetDeletesCacheKey"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object GetDeletesCacheKey()
Visual Basic
Public Overridable Function GetDeletesCacheKey As Object
Visual C++
public:
virtual Object^ GetDeletesCacheKey()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetDeletesCacheKey"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetDisableFakeNorms Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetDisableFakeNorms Method
IndexReader Class See Also Send Feedback
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This currently defaults to false (to remain back-compatible), but in 3.0 it will be hardwired to true, meaning the norms() methods will return null for fields that had disabled norms.")]
public virtual bool GetDisableFakeNorms()
Visual Basic
<ObsoleteAttribute("This currently defaults to false (to remain back-compatible), but in 3.0 it will be hardwired to true, meaning the norms() methods will return null for fields that had disabled norms.")> _
Public Overridable Function GetDisableFakeNorms As Boolean
Visual C++
[ObsoleteAttribute(L"This currently defaults to false (to remain back-compatible), but in 3.0 it will be hardwired to true, meaning the norms() methods will return null for fields that had disabled norms.")]
public:
virtual bool GetDisableFakeNorms()

Return Value

true if fake norms are disabled

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetFieldCacheKey Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetFieldCacheKey Method
IndexReader Class See Also Send Feedback
Expert

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public virtual Object GetFieldCacheKey()
Visual Basic
<ObsoleteAttribute> _
Public Overridable Function GetFieldCacheKey As Object
Visual C++
[ObsoleteAttribute]
public:
virtual Object^ GetFieldCacheKey()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetFieldCacheKey"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetFieldNames Method
IndexReader Class See Also Send Feedback
Get a list of unique field names that exist in this index and have the specified field option information.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fldOption
)
Visual Basic
Public MustOverride Function GetFieldNames ( _
    fldOption As IndexReader..::..FieldOption _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fldOption
) abstract

Parameters

fldOption
Type: Lucene.Net.Index..::..IndexReader..::..FieldOption
specifies which field option should be available for the returned fields

Return Value

Collection of Strings indicating the names of the fields.

See Also

IndexReader Class
Lucene.Net.Index Namespace
Lucene.Net.Index..::..IndexReader..::..FieldOption


GetIndexCommit Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetIndexCommit Method
IndexReader Class See Also Send Feedback
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexCommit GetIndexCommit()
Visual Basic
Public Overridable Function GetIndexCommit As IndexCommit
Visual C++
public:
virtual IndexCommit^ GetIndexCommit()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetIndexCommit"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetRefCount Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetRefCount Method
IndexReader Class See Also Send Feedback
Expert: returns the current refCount for this reader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetRefCount()
Visual Basic
Public Overridable Function GetRefCount As Integer
Visual C++
public:
virtual int GetRefCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetRefCount"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetSequentialSubReaders Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetSequentialSubReaders Method
IndexReader Class See Also Send Feedback
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader[] GetSequentialSubReaders()
Visual Basic
Public Overridable Function GetSequentialSubReaders As IndexReader()
Visual C++
public:
virtual array<IndexReader^>^ GetSequentialSubReaders()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetSequentialSubReaders"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..GetTermFreqVector Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | Map all the term vectors for all fields in a Document
Public method | GetTermFreqVector(Int32, String) | Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a {@link TermPositionVector} is returned.
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the {@link TermFreqVector}.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetTermFreqVector Method (Int32, TermVectorMapper)
IndexReader Class See Also Send Feedback
Map all the term vectors for all fields in a Document

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public MustOverride Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) abstract

Parameters

docNumber
Type: System..::..Int32
The number of the document to load the vector for
mapper
Type: Lucene.Net.Index..::..TermVectorMapper
The {@link TermVectorMapper} to process the vector. Must not be null

See Also

IndexReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetTermFreqVector Method (Int32, String)
IndexReader Class See Also Send Feedback
Return a term frequency vector for the specified document and field. The returned vector contains terms and frequencies for the terms in the specified field of this document, if the field had the storeTermVector flag set. If termvectors had been stored with positions or offsets, a {@link TermPositionVector} is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
Visual Basic
Public MustOverride Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) abstract

Parameters

docNumber
Type: System..::..Int32
document for which the term frequency vector is returned
field
Type: System..::..String
field for which the term frequency vector is returned.

Return Value

term frequency vector May be null if field does not exist in the specified document or term vector was not stored.

See Also

IndexReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace
Lucene.Net.Documents..::..Field..::..TermVector


GetTermFreqVector Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
IndexReader..::..GetTermFreqVector Method (Int32, String, TermVectorMapper)
IndexReader Class See Also Send Feedback
Load the Term Vector into a user-defined data structure instead of relying on the parallel arrays of the {@link TermFreqVector}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public MustOverride Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) abstract

Parameters

docNumber
Type: System..::..Int32
The number of the document to load the vector for
field
Type: System..::..String
The name of the field to load
mapper
Type: Lucene.Net.Index..::..TermVectorMapper
The {@link TermVectorMapper} to process the vector. Must not be null

See Also

IndexReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVectors Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetTermFreqVectors Method
IndexReader Class See Also Send Feedback
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector contains terms and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null. The term vectors that are returned may either be of type {@link TermFreqVector} or of type {@link TermPositionVector} if positions or offsets have been stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TermFreqVector[] GetTermFreqVectors(
    int docNumber
)
Visual Basic
Public MustOverride Function GetTermFreqVectors ( _
    docNumber As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) abstract

Parameters

docNumber
Type: System..::..Int32
document for which term frequency vectors are returned

Return Value

array of term frequency vectors. May be null if no term vectors have been stored for the specified document.

See Also

IndexReader Class
Lucene.Net.Index Namespace
Lucene.Net.Documents..::..Field..::..TermVector


GetTermInfosIndexDivisor Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetTermInfosIndexDivisor Method
IndexReader Class See Also Send Feedback

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTermInfosIndexDivisor()
Visual Basic
Public Overridable Function GetTermInfosIndexDivisor As Integer
Visual C++
public:
virtual int GetTermInfosIndexDivisor()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetTermInfosIndexDivisor"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetUniqueTermCount Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetUniqueTermCount Method
IndexReader Class See Also Send Feedback
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
cannot be easily determined (eg Multi*Readers). Instead, you should call {@link #getSequentialSubReaders} and ask each sub reader for its unique term count.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetUniqueTermCount()
Visual Basic
Public Overridable Function GetUniqueTermCount As Long
Visual C++
public:
virtual long long GetUniqueTermCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetUniqueTermCount"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
IndexReader..::..GetVersion Method
IndexReader Class See Also Send Feedback
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

unless overridden in subclass

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetVersion()
Visual Basic
Public Overridable Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.GetVersion"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
IndexReader..::..HasDeletions Method
IndexReader Class See Also Send Feedback
Returns true if any documents have been deleted

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool HasDeletions()
Visual Basic
Public MustOverride Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.HasDeletions"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


HasNorms Method

[image]

Lucene.Net Class Libraries
IndexReader..::..HasNorms Method
IndexReader Class See Also Send Feedback
Returns true if there are norms stored for this field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool HasNorms(
    string field
)
Visual Basic
Public Overridable Function HasNorms ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool HasNorms(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.IndexReader.HasNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.HasNorms(System.String)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


IncRef Method

[image]

Lucene.Net Class Libraries
IndexReader..::..IncRef Method
IndexReader Class See Also Send Feedback
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void IncRef()
Visual Basic
Public Overridable Sub IncRef
Visual C++
public:
virtual void IncRef()

See Also

IndexReader Class
Lucene.Net.Index Namespace
[!:decRef]


IndexExists Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..IndexExists Method
IndexReader Class See Also Send Feedback

Overload List

Name Description
IndexExists(FileInfo) Obsolete.
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
IndexExists(String) Obsolete.
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
CopyC#
false
 is returned.
IndexExists(Directory)
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


IndexExists Method (FileInfo)

[image]

Lucene.Net Class Libraries
IndexReader..::..IndexExists Method (FileInfo)
IndexReader Class See Also Send Feedback
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexExists(Directory) instead. This method will be removed in the 3.0 release.")]
public static bool IndexExists(
    FileInfo directory
)
Visual Basic
<ObsoleteAttribute("Use IndexExists(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function IndexExists ( _
    directory As FileInfo _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IndexExists(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static bool IndexExists(
    FileInfo^ directory
)

Parameters

directory
Type: System.IO..::..FileInfo
the directory to check for an index

Return Value

CopyC#
true
 if an index exists;
CopyC#
false
 otherwise

See Also

IndexReader Class
IndexExists Overload
Lucene.Net.Index Namespace


IndexExists Method (String)

[image]

Lucene.Net Class Libraries
IndexReader..::..IndexExists Method (String)
IndexReader Class See Also Send Feedback
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.
CopyC#
false
 is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexExists(Directory) instead. This method will be removed in the 3.0 release.")]
public static bool IndexExists(
    string directory
)
Visual Basic
<ObsoleteAttribute("Use IndexExists(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function IndexExists ( _
    directory As String _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IndexExists(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static bool IndexExists(
    String^ directory
)

Parameters

directory
Type: System..::..String
the directory to check for an index

Return Value

CopyC#
true
 if an index exists;
CopyC#
false
 otherwise

See Also

IndexReader Class
IndexExists Overload
Lucene.Net.Index Namespace


IndexExists Method (Directory)

[image]

Lucene.Net Class Libraries
IndexReader..::..IndexExists Method (Directory)
IndexReader Class See Also Send Feedback
Returns
CopyC#
true
 if an index exists at the specified directory. If the directory does not exist or if there is no index in it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool IndexExists(
    Directory directory
)
Visual Basic
Public Shared Function IndexExists ( _
    directory As Directory _
) As Boolean
Visual C++
public:
static bool IndexExists(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the directory to check for an index

Return Value

CopyC#
true
 if an index exists;
CopyC#
false
 otherwise

See Also

IndexReader Class
IndexExists Overload
Lucene.Net.Index Namespace


IsCurrent Method

[image]

Lucene.Net Class Libraries
IndexReader..::..IsCurrent Method
IndexReader Class See Also Send Feedback
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsCurrent()
Visual Basic
Public Overridable Function IsCurrent As Boolean
Visual C++
public:
virtual bool IsCurrent()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.IsCurrent"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
IndexReader..::..IsDeleted Method
IndexReader Class See Also Send Feedback
Returns true if document n has been deleted

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool IsDeleted(
    int n
)
Visual Basic
Public MustOverride Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) abstract

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.IndexReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.IsDeleted(System.Int32)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


IsLocked Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..IsLocked Method
IndexReader Class See Also Send Feedback

Overload List

Name Description
IsLocked(String) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
IsLocked(Directory) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


IsLocked Method (String)

[image]

Lucene.Net Class Libraries
IndexReader..::..IsLocked Method (String)
IndexReader Class See Also Send Feedback
Returns
CopyC#
true
 iff the index in the named directory is currently locked.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IsLocked(Directory) instead. This method will be removed in the 3.0 release.")]
public static bool IsLocked(
    string directory
)
Visual Basic
<ObsoleteAttribute("Use IsLocked(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function IsLocked ( _
    directory As String _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IsLocked(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static bool IsLocked(
    String^ directory
)

Parameters

directory
Type: System..::..String
the directory to check for a lock

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.IsLocked(System.String)"]

See Also

IndexReader Class
IsLocked Overload
Lucene.Net.Index Namespace


IsLocked Method (Directory)

[image]

Lucene.Net Class Libraries
IndexReader..::..IsLocked Method (Directory)
IndexReader Class See Also Send Feedback
Returns
CopyC#
true
 iff the index in the named directory is currently locked.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use IndexWriter.IsLocked(Directory) instead. This method will be removed in the 3.0 release.")]
public static bool IsLocked(
    Directory directory
)
Visual Basic
<ObsoleteAttribute("Please use IndexWriter.IsLocked(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function IsLocked ( _
    directory As Directory _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Please use IndexWriter.IsLocked(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static bool IsLocked(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the directory to check for a lock

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.IsLocked(Lucene.Net.Store.Directory)"]

See Also

IndexReader Class
IsLocked Overload
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
IndexReader..::..IsOptimized Method
IndexReader Class See Also Send Feedback
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsOptimized()
Visual Basic
Public Overridable Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized()

Return Value

CopyC#
true
 if the index is optimized;
CopyC#
false
 otherwise

See Also

IndexReader Class
Lucene.Net.Index Namespace


LastModified Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..LastModified Method
IndexReader Class See Also Send Feedback

Overload List

Name | Description
LastModified(FileInfo) | Obsolete. Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
LastModified(String) | Obsolete. Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.
LastModified(Directory) | Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


LastModified Method (FileInfo)

[image]

Lucene.Net Class Libraries
IndexReader..::..LastModified Method (FileInfo)
IndexReader Class See Also Send Feedback
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use LastModified(Directory) instead. This method will be removed in the 3.0 release.")]
public static long LastModified(
    FileInfo fileDirectory
)
Visual Basic
<ObsoleteAttribute("Use LastModified(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function LastModified ( _
    fileDirectory As FileInfo _
) As Long
Visual C++
[ObsoleteAttribute(L"Use LastModified(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static long long LastModified(
    FileInfo^ fileDirectory
)

Parameters

fileDirectory
Type: System.IO..::..FileInfo

[Missing <param name="fileDirectory"/> documentation for "M:Lucene.Net.Index.IndexReader.LastModified(System.IO.FileInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.LastModified(System.IO.FileInfo)"]

See Also

IndexReader Class
LastModified Overload
Lucene.Net.Index Namespace


LastModified Method (String)

[image]

Lucene.Net Class Libraries
IndexReader..::..LastModified Method (String)
IndexReader Class See Also Send Feedback
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use LastModified(Directory) instead. This method will be removed in the 3.0 release.")]
public static long LastModified(
    string directory
)
Visual Basic
<ObsoleteAttribute("Use LastModified(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function LastModified ( _
    directory As String _
) As Long
Visual C++
[ObsoleteAttribute(L"Use LastModified(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static long long LastModified(
    String^ directory
)

Parameters

directory
Type: System..::..String

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.IndexReader.LastModified(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.LastModified(System.String)"]

See Also

IndexReader Class
LastModified Overload
Lucene.Net.Index Namespace


LastModified Method (Directory)

[image]

Lucene.Net Class Libraries
IndexReader..::..LastModified Method (Directory)
IndexReader Class See Also Send Feedback
Returns the time the index in the named directory was last modified. Do not use this to check whether the reader is still up-to-date, use {@link #IsCurrent()} instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long LastModified(
    Directory directory2
)
Visual Basic
Public Shared Function LastModified ( _
    directory2 As Directory _
) As Long
Visual C++
public:
static long long LastModified(
    Directory^ directory2
)

Parameters

directory2
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory2"/> documentation for "M:Lucene.Net.Index.IndexReader.LastModified(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.LastModified(Lucene.Net.Store.Directory)"]

See Also

IndexReader Class
LastModified Overload
Lucene.Net.Index Namespace


ListCommits Method

[image]

Lucene.Net Class Libraries
IndexReader..::..ListCommits Method
IndexReader Class See Also Send Feedback
Returns all commit points that exist in the Directory. Normally, because the default is {@link KeepOnlyLastCommitDeletionPolicy}, there would be only one commit point. But if you're using a custom {@link IndexDeletionPolicy} then there could be many commits. Once you have a given commit, you can open a reader on it by calling {@link IndexReader#Open(IndexCommit)} There must be at least one commit in the Directory, else this method throws {@link java.io.IOException}. Note that if a commit is in progress while this method is running, that commit may or may not be returned array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static ICollection ListCommits(
    Directory dir
)
Visual Basic
Public Shared Function ListCommits ( _
    dir As Directory _
) As ICollection
Visual C++
public:
static ICollection^ ListCommits(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.IndexReader.ListCommits(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.ListCommits(Lucene.Net.Store.Directory)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


Main Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Main Method
IndexReader Class See Also Send Feedback
Prints the filename and size of each file within a given compound file. Add the -extract flag to extract files to the current working directory. In order to make the extracted version of the index work, you have to copy the segments file from the compound index into the directory where the extracted files are stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]
Usage: Lucene.Net.Index.IndexReader [-extract] <cfsfile>

See Also

IndexReader Class
Lucene.Net.Index Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
IndexReader..::..MaxDoc Method
IndexReader Class See Also Send Feedback
Returns one greater than the largest possible document number. This may be used to, e.g., determine how big to allocate an array which will have an element for every document number in an index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int MaxDoc()
Visual Basic
Public MustOverride Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.MaxDoc"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Norms Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.
Public method | Norms(String, array<Byte>[]()[][], Int32) | Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Norms Method (String)

[image]

Lucene.Net Class Libraries
IndexReader..::..Norms Method (String)
IndexReader Class See Also Send Feedback
Returns the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract byte[] Norms(
    string field
)
Visual Basic
Public MustOverride Function Norms ( _
    field As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Norms(
    String^ field
) abstract

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.IndexReader.Norms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Norms(System.String)"]

See Also

IndexReader Class
Norms Overload
Lucene.Net.Index Namespace
[!:Lucene.Net.Documents.Field.SetBoost(float)]


Norms Method (String, Byte[], Int32)

[image]

Lucene.Net Class Libraries
IndexReader..::..Norms Method (String, array<Byte>[]()[][], Int32)
IndexReader Class See Also Send Feedback
Reads the byte-encoded normalization factor for the named field of every document. This is used by the search code to score documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Norms(
    string field,
    byte[] bytes,
    int offset
)
Visual Basic
Public MustOverride Sub Norms ( _
    field As String, _
    bytes As Byte(), _
    offset As Integer _
)
Visual C++
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ bytes,
    int offset
) abstract

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.IndexReader.Norms(System.String,System.Byte[],System.Int32)"]

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:Lucene.Net.Index.IndexReader.Norms(System.String,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.IndexReader.Norms(System.String,System.Byte[],System.Int32)"]

See Also

IndexReader Class
Norms Overload
Lucene.Net.Index Namespace
[!:Lucene.Net.Documents.Field.SetBoost(float)]


NumDeletedDocs Method

[image]

Lucene.Net Class Libraries
IndexReader..::..NumDeletedDocs Method
IndexReader Class See Also Send Feedback
Returns the number of deleted documents.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int NumDeletedDocs()
Visual Basic
Public Overridable Function NumDeletedDocs As Integer
Visual C++
public:
virtual int NumDeletedDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.NumDeletedDocs"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
IndexReader..::..NumDocs Method
IndexReader Class See Also Send Feedback
Returns the number of documents in this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int NumDocs()
Visual Basic
Public MustOverride Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.NumDocs"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


Open Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Open Method
IndexReader Class See Also Send Feedback

Overload List

Name | Description
Open(FileInfo) | Obsolete. Returns a read/write IndexReader reading the index in an FSDirectory in the named path.
Open(String) | Obsolete. Returns a read/write IndexReader reading the index in an FSDirectory in the named path.
Open(Directory) | Obsolete. Returns a read/write IndexReader reading the index in the given Directory.
Open(IndexCommit) | Obsolete. Expert: returns a read/write IndexReader reading the index in the given {@link IndexCommit}.
Open(FileInfo, Boolean) | Obsolete. Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(String, Boolean) | Obsolete. Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy) | Obsolete. Expert: returns a read/write IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}.
Open(Directory, Boolean) | Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy) | Obsolete. Expert: returns a read/write IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}.
Open(IndexCommit, Boolean) | Expert: returns an IndexReader reading the index in the given {@link IndexCommit}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean) | Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean) | Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(Directory, IndexDeletionPolicy, Boolean, Int32) | Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.
Open(IndexCommit, IndexDeletionPolicy, Boolean, Int32) | Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Open Method (FileInfo)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (FileInfo)
IndexReader Class See Also Send Feedback
Returns a read/write IndexReader reading the index in an FSDirectory in the named path.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(Directory, bool) instead.This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute("Use Open(Directory, bool) instead.This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    path As FileInfo _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(Directory, bool) instead.This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo
the path to the index directory

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(System.IO.FileInfo)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (String)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (String)
IndexReader Class See Also Send Feedback
Returns a read/write IndexReader reading the index in an FSDirectory in the named path.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(Directory, boolean) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    string path
)
Visual Basic
<ObsoleteAttribute("Use Open(Directory, boolean) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    path As String _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(Directory, boolean) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    String^ path
)

Parameters

path
Type: System..::..String
the path to the index directory

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(System.String)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (Directory)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (Directory)
IndexReader Class See Also Send Feedback
Returns a read/write IndexReader reading the index in the given Directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    Directory directory
)
Visual Basic
<ObsoleteAttribute("Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    directory As Directory _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the index directory

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Store.Directory)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (IndexCommit)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (IndexCommit)
IndexReader Class See Also Send Feedback
Expert: returns a read/write IndexReader reading the index in the given {@link IndexCommit}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(IndexCommit, bool) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    IndexCommit commit
)
Visual Basic
<ObsoleteAttribute("Use Open(IndexCommit, bool) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    commit As IndexCommit _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(IndexCommit, bool) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    IndexCommit^ commit
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit
the commit point to open

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Index.IndexCommit)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (FileInfo, Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (FileInfo, Boolean)
IndexReader Class See Also Send Feedback
Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    FileInfo path,
    bool readOnly
)
Visual Basic
<ObsoleteAttribute("Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    path As FileInfo, _
    readOnly As Boolean _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    FileInfo^ path,
    bool readOnly
)

Parameters

path
Type: System.IO..::..FileInfo
the path to the index directory
readOnly
Type: System..::..Boolean
true if this should be a readOnly reader

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(System.IO.FileInfo,System.Boolean)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (String, Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (String, Boolean)
IndexReader Class See Also Send Feedback
Returns an IndexReader reading the index in an FSDirectory in the named path. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    string path,
    bool readOnly
)
Visual Basic
<ObsoleteAttribute("Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    path As String, _
    readOnly As Boolean _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(Directory, bool) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    String^ path,
    bool readOnly
)

Parameters

path
Type: System..::..String
the path to the index directory
readOnly
Type: System..::..Boolean
true if this should be a readOnly reader

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(System.String,System.Boolean)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (Directory, IndexDeletionPolicy)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (Directory, IndexDeletionPolicy)
IndexReader Class See Also Send Feedback
Expert: returns a read/write IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(Directory, IndexDeletionPolicy, bool) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy
)
Visual Basic
<ObsoleteAttribute("Use Open(Directory, IndexDeletionPolicy, bool) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(Directory, IndexDeletionPolicy, bool) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the index directory
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
a custom deletion policy (only used if you use this reader to perform deletes or to set norms); see {@link IndexWriter} for details.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (Directory, Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (Directory, Boolean)
IndexReader Class See Also Send Feedback
Returns an IndexReader reading the index in the given Directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader Open(
    Directory directory,
    bool readOnly
)
Visual Basic
Public Shared Function Open ( _
    directory As Directory, _
    readOnly As Boolean _
) As IndexReader
Visual C++
public:
static IndexReader^ Open(
    Directory^ directory,
    bool readOnly
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the index directory
readOnly
Type: System..::..Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Store.Directory,System.Boolean)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (IndexCommit, IndexDeletionPolicy)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (IndexCommit, IndexDeletionPolicy)
IndexReader Class See Also Send Feedback
Expert: returns a read/write IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(IndexCommit, IndexDeletionPolicy, bool) instead. This method will be removed in the 3.0 release.")]
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy
)
Visual Basic
<ObsoleteAttribute("Use Open(IndexCommit, IndexDeletionPolicy, bool) instead. This method will be removed in the 3.0 release.")> _
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy _
) As IndexReader
Visual C++
[ObsoleteAttribute(L"Use Open(IndexCommit, IndexDeletionPolicy, bool) instead. This method will be removed in the 3.0 release.")]
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit
the specific {@link IndexCommit} to open; see {@link IndexReader#listCommits} to list all commits in a directory
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
a custom deletion policy (only used if you use this reader to perform deletes or to set norms); see {@link IndexWriter} for details.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Index.IndexCommit,Lucene.Net.Index.IndexDeletionPolicy)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (IndexCommit, Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (IndexCommit, Boolean)
IndexReader Class See Also Send Feedback
Expert: returns an IndexReader reading the index in the given {@link IndexCommit}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader Open(
    IndexCommit commit,
    bool readOnly
)
Visual Basic
Public Shared Function Open ( _
    commit As IndexCommit, _
    readOnly As Boolean _
) As IndexReader
Visual C++
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    bool readOnly
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit
the commit point to open
readOnly
Type: System..::..Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Index.IndexCommit,System.Boolean)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (Directory, IndexDeletionPolicy, Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (Directory, IndexDeletionPolicy, Boolean)
IndexReader Class See Also Send Feedback
Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly
)
Visual Basic
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean _
) As IndexReader
Visual C++
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the index directory
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
a custom deletion policy (only used if you use this reader to perform deletes or to set norms); see {@link IndexWriter} for details.
readOnly
Type: System..::..Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,System.Boolean)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (IndexCommit, IndexDeletionPolicy, Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (IndexCommit, IndexDeletionPolicy, Boolean)
IndexReader Class See Also Send Feedback
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly
)
Visual Basic
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean _
) As IndexReader
Visual C++
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit
the specific {@link IndexCommit} to open; see {@link IndexReader#listCommits} to list all commits in a directory
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
a custom deletion policy (only used if you use this reader to perform deletes or to set norms); see {@link IndexWriter} for details.
readOnly
Type: System..::..Boolean
true if no changes (deletions, norms) will be made with this IndexReader

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Index.IndexCommit,Lucene.Net.Index.IndexDeletionPolicy,System.Boolean)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (Directory, IndexDeletionPolicy, Boolean, Int32)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (Directory, IndexDeletionPolicy, Boolean, Int32)
IndexReader Class See Also Send Feedback
Expert: returns an IndexReader reading the index in the given Directory, with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader Open(
    Directory directory,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
Visual Basic
Public Shared Function Open ( _
    directory As Directory, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean, _
    termInfosIndexDivisor As Integer _
) As IndexReader
Visual C++
public:
static IndexReader^ Open(
    Directory^ directory,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the index directory
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
a custom deletion policy (only used if you use this reader to perform deletes or to set norms); see {@link IndexWriter} for details.
readOnly
Type: System..::..Boolean
true if no changes (deletions, norms) will be made with this IndexReader
termInfosIndexDivisor
Type: System..::..Int32
Subsamples which indexed terms are loaded into RAM. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. Set this to -1 to skip loading the terms index entirely.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Store.Directory,Lucene.Net.Index.IndexDeletionPolicy,System.Boolean,System.Int32)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Open Method (IndexCommit, IndexDeletionPolicy, Boolean, Int32)

[image]

Lucene.Net Class Libraries
IndexReader..::..Open Method (IndexCommit, IndexDeletionPolicy, Boolean, Int32)
IndexReader Class See Also Send Feedback
Expert: returns an IndexReader reading the index in the given Directory, using a specific commit and with a custom {@link IndexDeletionPolicy}. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the reader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader Open(
    IndexCommit commit,
    IndexDeletionPolicy deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)
Visual Basic
Public Shared Function Open ( _
    commit As IndexCommit, _
    deletionPolicy As IndexDeletionPolicy, _
    readOnly As Boolean, _
    termInfosIndexDivisor As Integer _
) As IndexReader
Visual C++
public:
static IndexReader^ Open(
    IndexCommit^ commit,
    IndexDeletionPolicy^ deletionPolicy,
    bool readOnly,
    int termInfosIndexDivisor
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit
the specific {@link IndexCommit} to open; see {@link IndexReader#listCommits} to list all commits in a directory
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
a custom deletion policy (only used if you use this reader to perform deletes or to set norms); see {@link IndexWriter} for details.
readOnly
Type: System..::..Boolean
true if no changes (deletions, norms) will be made with this IndexReader
termInfosIndexDivisor
Type: System..::..Int32
Subsambles which indexed terms are loaded into RAM. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. Set this to -1 to skip loading the terms index entirely.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Open(Lucene.Net.Index.IndexCommit,Lucene.Net.Index.IndexDeletionPolicy,System.Boolean,System.Int32)"]

See Also

IndexReader Class
Open Overload
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Reopen Method
IndexReader Class See Also Send Feedback

Overload List

Name Description
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Reopen Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Reopen Method
IndexReader Class See Also Send Feedback
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader Reopen()
Visual Basic
Public Overridable Function Reopen As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Reopen"]

See Also

IndexReader Class
Reopen Overload
Lucene.Net.Index Namespace


Reopen Method (Boolean)

[image]

Lucene.Net Class Libraries
IndexReader..::..Reopen Method (Boolean)
IndexReader Class See Also Send Feedback
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader Reopen(
    bool openReadOnly
)
Visual Basic
Public Overridable Function Reopen ( _
    openReadOnly As Boolean _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen(
    bool openReadOnly
)

Parameters

openReadOnly
Type: System..::..Boolean

[Missing <param name="openReadOnly"/> documentation for "M:Lucene.Net.Index.IndexReader.Reopen(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Reopen(System.Boolean)"]

See Also

IndexReader Class
Reopen Overload
Lucene.Net.Index Namespace


Reopen Method (IndexCommit)

[image]

Lucene.Net Class Libraries
IndexReader..::..Reopen Method (IndexCommit)
IndexReader Class See Also Send Feedback
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader Reopen(
    IndexCommit commit
)
Visual Basic
Public Overridable Function Reopen ( _
    commit As IndexCommit _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen(
    IndexCommit^ commit
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit

[Missing <param name="commit"/> documentation for "M:Lucene.Net.Index.IndexReader.Reopen(Lucene.Net.Index.IndexCommit)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Reopen(Lucene.Net.Index.IndexCommit)"]

See Also

IndexReader Class
Reopen Overload
Lucene.Net.Index Namespace


SetDisableFakeNorms Method

[image]

Lucene.Net Class Libraries
IndexReader..::..SetDisableFakeNorms Method
IndexReader Class See Also Send Feedback
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This currently defaults to false (to remain back-compatible), but in 3.0 it will be hardwired to true, meaning the norms() methods will return null for fields that had disabled norms.")]
public virtual void SetDisableFakeNorms(
    bool disableFakeNorms
)
Visual Basic
<ObsoleteAttribute("This currently defaults to false (to remain back-compatible), but in 3.0 it will be hardwired to true, meaning the norms() methods will return null for fields that had disabled norms.")> _
Public Overridable Sub SetDisableFakeNorms ( _
    disableFakeNorms As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This currently defaults to false (to remain back-compatible), but in 3.0 it will be hardwired to true, meaning the norms() methods will return null for fields that had disabled norms.")]
public:
virtual void SetDisableFakeNorms(
    bool disableFakeNorms
)

Parameters

disableFakeNorms
Type: System..::..Boolean
true to disable fake norms, false to preserve the legacy behavior

See Also

IndexReader Class
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..SetNorm Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


SetNorm Method (Int32, String, Byte)

[image]

Lucene.Net Class Libraries
IndexReader..::..SetNorm Method (Int32, String, Byte)
IndexReader Class See Also Send Feedback
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetNorm(
    int doc,
    string field,
    byte value_Renamed
)
Visual Basic
Public Overridable Sub SetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Visual C++
public:
virtual void SetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexReader.SetNorm(System.Int32,System.String,System.Byte)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.IndexReader.SetNorm(System.Int32,System.String,System.Byte)"]

value_Renamed
Type: System..::..Byte

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.IndexReader.SetNorm(System.Int32,System.String,System.Byte)"]

See Also

IndexReader Class
SetNorm Overload
Lucene.Net.Index Namespace
IndexReader..::..Norms(String)
Similarity..::..DecodeNorm(Byte)


SetNorm Method (Int32, String, Single)

[image]

Lucene.Net Class Libraries
IndexReader..::..SetNorm Method (Int32, String, Single)
IndexReader Class See Also Send Feedback
Expert: Resets the normalization factor for the named field of the named document.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetNorm(
    int doc,
    string field,
    float value_Renamed
)
Visual Basic
Public Overridable Sub SetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Single _
)
Visual C++
public:
virtual void SetNorm(
    int doc,
    String^ field,
    float value_Renamed
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexReader.SetNorm(System.Int32,System.String,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.IndexReader.SetNorm(System.Int32,System.String,System.Single)"]

value_Renamed
Type: System..::..Single

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.IndexReader.SetNorm(System.Int32,System.String,System.Single)"]

See Also

IndexReader Class
SetNorm Overload
Lucene.Net.Index Namespace
IndexReader..::..Norms(String)
Similarity..::..DecodeNorm(Byte)


SetTermInfosIndexDivisor Method

[image]

Lucene.Net Class Libraries
IndexReader..::..SetTermInfosIndexDivisor Method
IndexReader Class See Also Send Feedback

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use IndexReader.Open(Directory, IndexDeletionPolicy, bool, int) to specify the required TermInfos index divisor instead.")]
public virtual void SetTermInfosIndexDivisor(
    int indexDivisor
)
Visual Basic
<ObsoleteAttribute("Please use IndexReader.Open(Directory, IndexDeletionPolicy, bool, int) to specify the required TermInfos index divisor instead.")> _
Public Overridable Sub SetTermInfosIndexDivisor ( _
    indexDivisor As Integer _
)
Visual C++
[ObsoleteAttribute(L"Please use IndexReader.Open(Directory, IndexDeletionPolicy, bool, int) to specify the required TermInfos index divisor instead.")]
public:
virtual void SetTermInfosIndexDivisor(
    int indexDivisor
)

Parameters

indexDivisor
Type: System..::..Int32

[Missing <param name="indexDivisor"/> documentation for "M:Lucene.Net.Index.IndexReader.SetTermInfosIndexDivisor(System.Int32)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..TermDocs Method
IndexReader Class See Also Send Feedback

Overload List

Name Description
Public method TermDocs()()()()
Returns an unpositioned {@link TermDocs} enumerator.
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image]

Lucene.Net Class Libraries
IndexReader..::..TermDocs Method
IndexReader Class See Also Send Feedback
Returns an unpositioned {@link TermDocs} enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TermDocs TermDocs()
Visual Basic
Public MustOverride Function TermDocs As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.TermDocs"]

See Also

IndexReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermDocs Method (Term)

[image]

Lucene.Net Class Libraries
IndexReader..::..TermDocs Method (Term)
IndexReader Class See Also Send Feedback
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TermDocs TermDocs(
    Term term
)
Visual Basic
Public Overridable Function TermDocs ( _
    term As Term _
) As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.IndexReader.TermDocs(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.TermDocs(Lucene.Net.Index.Term)"]

See Also

IndexReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..TermPositions Method
IndexReader Class See Also Send Feedback

Overload List

Name Description
Public method TermPositions()()()()
Returns an unpositioned {@link TermPositions} enumerator.
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image]

Lucene.Net Class Libraries
IndexReader..::..TermPositions Method
IndexReader Class See Also Send Feedback
Returns an unpositioned {@link TermPositions} enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TermPositions TermPositions()
Visual Basic
Public MustOverride Function TermPositions As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.TermPositions"]

See Also

IndexReader Class
TermPositions Overload
Lucene.Net.Index Namespace


TermPositions Method (Term)

[image]

Lucene.Net Class Libraries
IndexReader..::..TermPositions Method (Term)
IndexReader Class See Also Send Feedback
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TermPositions TermPositions(
    Term term
)
Visual Basic
Public Overridable Function TermPositions ( _
    term As Term _
) As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.IndexReader.TermPositions(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.TermPositions(Lucene.Net.Index.Term)"]

See Also

IndexReader Class
TermPositions Overload
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..Terms Method
IndexReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.
Public method | Terms(Term) | Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

See Also

IndexReader Class
IndexReader Members
Lucene.Net.Index Namespace


Terms Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Terms Method
IndexReader Class See Also Send Feedback
Returns an enumeration of all the terms in the index. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration. Note that after calling terms(), {@link TermEnum#Next()} must be called on the resulting enumeration before calling other methods such as {@link TermEnum#Term()}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TermEnum Terms()
Visual Basic
Public MustOverride Function Terms As TermEnum
Visual C++
public:
virtual TermEnum^ Terms() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Terms"]

See Also

IndexReader Class
Terms Overload
Lucene.Net.Index Namespace


Terms Method (Term)

[image]

Lucene.Net Class Libraries
IndexReader..::..Terms Method (Term)
IndexReader Class See Also Send Feedback
Returns an enumeration of all terms starting at a given term. If the given term does not exist, the enumeration is positioned at the first term greater than the supplied term. The enumeration is ordered by Term.compareTo(). Each term is greater than all that precede it in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TermEnum Terms(
    Term t
)
Visual Basic
Public MustOverride Function Terms ( _
    t As Term _
) As TermEnum
Visual C++
public:
virtual TermEnum^ Terms(
    Term^ t
) abstract

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.IndexReader.Terms(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.Terms(Lucene.Net.Index.Term)"]

See Also

IndexReader Class
Terms Overload
Lucene.Net.Index Namespace


UndeleteAll Method

[image]

Lucene.Net Class Libraries
IndexReader..::..UndeleteAll Method
IndexReader Class See Also Send Feedback
Undeletes all documents currently marked as deleted in this index.
since this reader was opened
has this index open (
CopyC#
write.lock
 could not be obtained)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void UndeleteAll()
Visual Basic
Public Overridable Sub UndeleteAll
Visual C++
public:
virtual void UndeleteAll()

See Also

IndexReader Class
Lucene.Net.Index Namespace


Unlock Method

[image]

Lucene.Net Class Libraries
IndexReader..::..Unlock Method
IndexReader Class See Also Send Feedback
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use IndexWriter.Unlock(Directory) instead. This method will be removed in the 3.0 release.")]
public static void Unlock(
    Directory directory
)
Visual Basic
<ObsoleteAttribute("Please use IndexWriter.Unlock(Directory) instead. This method will be removed in the 3.0 release.")> _
Public Shared Sub Unlock ( _
    directory As Directory _
)
Visual C++
[ObsoleteAttribute(L"Please use IndexWriter.Unlock(Directory) instead. This method will be removed in the 3.0 release.")]
public:
static void Unlock(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.IndexReader.Unlock(Lucene.Net.Store.Directory)"]

See Also

IndexReader Class
Lucene.Net.Index Namespace


IndexReader Properties

[image] [image]

Lucene.Net Class Libraries
IndexReader Properties
IndexReader Class See Also Send Feedback

The IndexReader type exposes the following members.

Properties

 | Name | Description
Public property | hasChanges_ForNUnit |

See Also

IndexReader Class
Lucene.Net.Index Namespace


hasChanges_ForNUnit Property

[image]

Lucene.Net Class Libraries
IndexReader..::..hasChanges_ForNUnit Property
IndexReader Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.IndexReader.hasChanges_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool hasChanges_ForNUnit { get; }
Visual Basic
Public ReadOnly Property hasChanges_ForNUnit As Boolean
    Get
Visual C++
public:
property bool hasChanges_ForNUnit {
    bool get ();
}

See Also

IndexReader Class
Lucene.Net.Index Namespace


IndexReader.FieldOption Class

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption Class
IndexReader Class Members See Also Send Feedback
Constants describing field properties, for example used for {@link IndexReader#GetFieldNames(FieldOption)}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldOption
Visual Basic
Public NotInheritable Class FieldOption
Visual C++
public ref class FieldOption sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader..::..FieldOption

See Also

IndexReader..::..FieldOption Members
Lucene.Net.Index Namespace


IndexReader.FieldOption Members

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption Members
IndexReader..::..FieldOption Class Methods Fields See Also Send Feedback

IndexReader is an abstract class, providing an interface for accessing an index. Search of an index is done entirely through this abstract interface, so that any subclass which implements it is searchable.

Concrete subclasses of IndexReader are usually constructed with a call to one of the static

CopyC#
open()
methods, e.g. {@link #Open(String, boolean)}.

For efficiency, in this API documents are often referred to via document numbers, non-negative integers which each name a unique document in the index. These document numbers are ephemeral--they may change as documents are added to and deleted from an index. Clients should thus not rely on a given document having the same number between sessions.

An IndexReader can be opened on a directory for which an IndexWriter is opened already, but it cannot be used to delete documents from the index then.

NOTE: for backwards API compatibility, several methods are not listed as abstract, but have no useful implementations in this base class and instead always throw UnsupportedOperationException. Subclasses are strongly encouraged to override these methods, but in many cases may not need to.

NOTE: as of 2.4, it's possible to open a read-only IndexReader using one of the static open methods that accepts the boolean readOnly parameter. Such a reader has better concurrency as it's not necessary to synchronize on the isDeleted method. Currently the default for readOnly is false, meaning if not specified you will get a read/write IndexReader. But in 3.0 this default will change to true, meaning you must explicitly specify false if you want to make changes with the resulting IndexReader.

NOTE: {@link

CopyC#
IndexReader
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexReader
 instance; use your own (non-Lucene) objects instead.

The IndexReader..::..FieldOption type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
ALL | All fields
INDEXED | All indexed fields
INDEXED_NO_TERMVECTOR | All fields which are indexed but don't have termvectors enabled
INDEXED_WITH_TERMVECTOR | All fields which are indexed with termvectors enabled
OMIT_TERM_FREQ_AND_POSITIONS | All fields that omit tf
OMIT_TF | Obsolete.
STORES_PAYLOADS | All fields that store payloads
TERMVECTOR | All fields with termvectors enabled. Please note that only standard termvector fields are returned
TERMVECTOR_WITH_OFFSET | All fields with termvectors with offset values enabled
TERMVECTOR_WITH_POSITION | All fields with termvectors with position values enabled
TERMVECTOR_WITH_POSITION_OFFSET | All fields with termvectors with offset values and position values enabled
UNINDEXED | All fields which are not indexed

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


IndexReader.FieldOption Fields

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption Fields
IndexReader..::..FieldOption Class See Also Send Feedback

The IndexReader..::..FieldOption type exposes the following members.

Fields

Name | Description
ALL | All fields
INDEXED | All indexed fields
INDEXED_NO_TERMVECTOR | All fields which are indexed but don't have termvectors enabled
INDEXED_WITH_TERMVECTOR | All fields which are indexed with termvectors enabled
OMIT_TERM_FREQ_AND_POSITIONS | All fields that omit tf
OMIT_TF | Obsolete.
STORES_PAYLOADS | All fields that store payloads
TERMVECTOR | All fields with termvectors enabled. Please note that only standard termvector fields are returned
TERMVECTOR_WITH_OFFSET | All fields with termvectors with offset values enabled
TERMVECTOR_WITH_POSITION | All fields with termvectors with position values enabled
TERMVECTOR_WITH_POSITION_OFFSET | All fields with termvectors with offset values and position values enabled
UNINDEXED | All fields which are not indexed

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


ALL Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..ALL Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption ALL
Visual Basic
Public Shared ReadOnly ALL As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ ALL

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


INDEXED Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..INDEXED Field
IndexReader..::..FieldOption Class See Also Send Feedback
All indexed fields

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption INDEXED
Visual Basic
Public Shared ReadOnly INDEXED As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ INDEXED

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


INDEXED_NO_TERMVECTOR Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..INDEXED_NO_TERMVECTOR Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields which are indexed but don't have termvectors enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption INDEXED_NO_TERMVECTOR
Visual Basic
Public Shared ReadOnly INDEXED_NO_TERMVECTOR As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ INDEXED_NO_TERMVECTOR

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


INDEXED_WITH_TERMVECTOR Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..INDEXED_WITH_TERMVECTOR Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields which are indexed with termvectors enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption INDEXED_WITH_TERMVECTOR
Visual Basic
Public Shared ReadOnly INDEXED_WITH_TERMVECTOR As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ INDEXED_WITH_TERMVECTOR

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


OMIT_TERM_FREQ_AND_POSITIONS Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..OMIT_TERM_FREQ_AND_POSITIONS Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields that omit tf

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption OMIT_TERM_FREQ_AND_POSITIONS
Visual Basic
Public Shared ReadOnly OMIT_TERM_FREQ_AND_POSITIONS As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ OMIT_TERM_FREQ_AND_POSITIONS

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


OMIT_TF Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..OMIT_TF Field
IndexReader..::..FieldOption Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexReader.FieldOption.OMIT_TF"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Renamed to OMIT_TERM_FREQ_AND_POSITIONS")]
public static readonly IndexReader..::..FieldOption OMIT_TF
Visual Basic
<ObsoleteAttribute("Renamed to OMIT_TERM_FREQ_AND_POSITIONS")> _
Public Shared ReadOnly OMIT_TF As IndexReader..::..FieldOption
Visual C++
[ObsoleteAttribute(L"Renamed to OMIT_TERM_FREQ_AND_POSITIONS")]
public:
static initonly IndexReader..::..FieldOption^ OMIT_TF

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


STORES_PAYLOADS Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..STORES_PAYLOADS Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields that store payloads

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption STORES_PAYLOADS
Visual Basic
Public Shared ReadOnly STORES_PAYLOADS As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ STORES_PAYLOADS

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


TERMVECTOR Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..TERMVECTOR Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields with termvectors enabled. Please note that only standard termvector fields are returned

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption TERMVECTOR
Visual Basic
Public Shared ReadOnly TERMVECTOR As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


TERMVECTOR_WITH_OFFSET Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..TERMVECTOR_WITH_OFFSET Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields with termvectors with offset values enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_OFFSET
Visual Basic
Public Shared ReadOnly TERMVECTOR_WITH_OFFSET As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_OFFSET

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


TERMVECTOR_WITH_POSITION Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..TERMVECTOR_WITH_POSITION Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields with termvectors with position values enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_POSITION
Visual Basic
Public Shared ReadOnly TERMVECTOR_WITH_POSITION As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_POSITION

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


TERMVECTOR_WITH_POSITION_OFFSET Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..TERMVECTOR_WITH_POSITION_OFFSET Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields with termvectors with offset values and position values enabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption TERMVECTOR_WITH_POSITION_OFFSET
Visual Basic
Public Shared ReadOnly TERMVECTOR_WITH_POSITION_OFFSET As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ TERMVECTOR_WITH_POSITION_OFFSET

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


UNINDEXED Field

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..UNINDEXED Field
IndexReader..::..FieldOption Class See Also Send Feedback
All fields which are not indexed

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexReader..::..FieldOption UNINDEXED
Visual Basic
Public Shared ReadOnly UNINDEXED As IndexReader..::..FieldOption
Visual C++
public:
static initonly IndexReader..::..FieldOption^ UNINDEXED

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


IndexReader.FieldOption Methods

[image] [image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption Methods
IndexReader..::..FieldOption Class See Also Send Feedback

The IndexReader..::..FieldOption type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
IndexReader..::..FieldOption..::..ToString Method
IndexReader..::..FieldOption Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexReader.FieldOption.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexReader.FieldOption.ToString"]

See Also

IndexReader..::..FieldOption Class
Lucene.Net.Index Namespace


IndexWriter Class

[image]

Lucene.Net Class Libraries
IndexWriter Class
Members See Also Send Feedback
An
CopyC#
IndexWriter
 creates and maintains an index.

The

CopyC#
create
argument to the {@link #IndexWriter(Directory, Analyzer, boolean) constructor} determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with
CopyC#
create=true
 even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also {@link #IndexWriter(Directory, Analyzer) constructors} with no
CopyC#
create
 argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with {@link #AddDocument(Document) addDocument} and removed with {@link #DeleteDocuments(Term)} or {@link #DeleteDocuments(Query)}. A document can be updated with {@link #UpdateDocument(Term, Document) updateDocument} (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, {@link #Close() close} should be called.

These changes are buffered in memory and periodically flushed to the {@link Directory} (during the above method calls). A flush is triggered when there are enough buffered deletes (see {@link #setMaxBufferedDeleteTerms}) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see {@link #setRAMBufferSizeMB}) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either {@link #Commit()} or {@link #close} is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the {@link MergeScheduler}).

The optional

CopyC#
autoCommit
argument to the {@link #IndexWriter(Directory, boolean, Analyzer) constructors} controls visibility of the changes to {@link IndexReader} instances reading the same index. When this is
CopyC#
false
, changes are not visible until {@link #Close()} or {@link #Commit()} is called. Note that changes will still be flushed to the {@link Directory} as new files, but are not committed (no new
CopyC#
segments_N
 file is written referencing the new files, nor are the files sync'd to stable storage) until {@link #Close()} or {@link #Commit()} is called. If something goes terribly wrong (for example the JVM crashes), then the index will reflect none of the changes made since the last commit, or the starting state if commit was not called. You can also call {@link #Rollback()}, which closes the writer without committing any changes, and removes any index files that had been flushed but are now unreferenced. This mode is useful for preventing readers from refreshing at a bad time (for example after you've done all your deletes but before you've done your adds). It can also be used to implement simple single-writer transactional semantics ("all or none"). You can do a two-phase commit by calling {@link #PrepareCommit()} followed by {@link #Commit()}. This is necessary when Lucene is working with an external resource (for example, a database) and both must either commit or rollback the transaction.

When

CopyC#
autoCommit
is
CopyC#
true
 then the writer will periodically commit on its own. [Deprecated: Note that in 3.0, IndexWriter will no longer accept autoCommit=true (it will be hardwired to false). You can always call {@link #Commit()} yourself when needed]. There is no guarantee when exactly an auto commit will occur (it used to be after every flush, but it is now after every completed merge, as of 2.4). If you want to force a commit, call {@link #Commit()}, or, close the writer. Once a commit has finished, newly opened {@link IndexReader} instances will see the changes to the index as of that commit. When running in this mode, be careful not to refresh your readers while optimize or segment merges are taking place as this can tie up substantial disk space.

Regardless of

CopyC#
autoCommit
, an {@link IndexReader} or {@link Lucene.Net.Search.IndexSearcher} will only see the index as of the "point in time" that it was opened. Any changes committed to the index after the reader was opened are not visible until the reader is re-opened.

If an index will not have more documents added for a while and optimal search performance is desired, then either the full {@link #Optimize() optimize} method or partial {@link #Optimize(int)} method should be called before the index is closed.

Opening an

CopyC#
IndexWriter
creates a lock file for the directory in use. Trying to open another
CopyC#
IndexWriter
 on the same directory will lead to a {@link LockObtainFailedException}. The {@link LockObtainFailedException} is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert:

CopyC#
IndexWriter
allows an optional {@link IndexDeletionPolicy} implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is {@link KeepOnlyLastCommitDeletionPolicy} which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert:

CopyC#
IndexWriter
allows you to separately change the {@link MergePolicy} and the {@link MergeScheduler}. The {@link MergePolicy} is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a {@link MergePolicy.MergeSpecification} describing the merges. It also selects merges to do for optimize(). (The default is {@link LogByteSizeMergePolicy}. Then, the {@link MergeScheduler} is invoked with the requested merges and it decides when and how to run the merges. The default is {@link ConcurrentMergeScheduler}.

NOTE: if you hit an OutOfMemoryError then IndexWriter will quietly record this fact and block all future segment commits. This is a defensive measure in case any internal state (buffered documents and deletions) were corrupted. Any subsequent calls to {@link #Commit()} will throw an IllegalStateException. The only course of action is to call {@link #Close()}, which internally will call {@link #Rollback()}, to undo any changes to the index since the last commit. If you opened the writer with autoCommit false you can also just call {@link #Rollback()} directly.

NOTE: {@link

CopyC#
IndexWriter
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexWriter
 instance as this may cause deadlock; use your own (non-Lucene) objects instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class IndexWriter : IDisposable
Visual Basic
Public Class IndexWriter _
    Implements IDisposable
Visual C++
public ref class IndexWriter : IDisposable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexWriter

See Also

IndexWriter Members
Lucene.Net.Index Namespace


IndexWriter Members

[image] [image]

Lucene.Net Class Libraries
IndexWriter Members
IndexWriter Class Constructors Methods Fields See Also Send Feedback

The IndexWriter type exposes the following members.

Constructors

Name Description
Public method IndexWriter(FileInfo, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(String, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(Directory, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(FileInfo, Analyzer, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(FileInfo, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.
Public method IndexWriter(String, Analyzer, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(String, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.
Public method IndexWriter(Directory, Analyzer, IndexWriter..::..MaxFieldLength)
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
Public method IndexWriter(Directory, Boolean, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(FileInfo, Analyzer, Boolean, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(String, Analyzer, Boolean, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength)
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, Boolean, IndexWriter..::..MaxFieldLength)
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Boolean, Analyzer, IndexDeletionPolicy) Obsolete.
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(Directory, Boolean, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
Public method IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength, IndexCommit)
Expert: constructs an IndexWriter on specific commit point, with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
.

This is only meaningful if you've used a {@link IndexDeletionPolicy} in that past that keeps more than just the last commit.

This operation is similar to {@link #Rollback()}, except that method can only rollback what's been done with the current instance of IndexWriter since its last commit, whereas this method can rollback to an arbitrary commit point from the past, assuming the {@link IndexDeletionPolicy} has preserved past commits.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength)
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Boolean, Analyzer, Boolean, IndexDeletionPolicy) Obsolete.
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

Methods

Name | Description
Public method | Abort | Obsolete.
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the {@link MergePolicy} in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see {@link #Optimize()} for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

See {@link #AddDocument(Document)} for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexes(array<Directory>[]()[][]) Obsolete.
Merges all segments from an array of indexes into this index.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexes(array<IndexReader>[]()[][])
Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

See {@link #AddIndexesNoOptimize(Directory[])} for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexesNoOptimize
Merges all segments from an array of indexes into this index.

This may be used to parallelize batch indexing. A large document collection can be broken into sub-collections. Each sub-collection can be indexed in parallel, on a different thread, process or machine. The complete index can then be created by merging sub-collection indexes with this method.

NOTE: the index in each Directory must not be changed (opened by a writer) while this method is running. This method does not acquire a write lock in each input Directory, so it is up to the caller to enforce this.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

This method is transactional in how Exceptions are handled: it does not commit a new segments_N file until all indexes are added. This means if an Exception occurs (for example disk full), then either no indexes will have been added or they all will have been.

Note that this requires temporary free space in the Directory up to 2X the sum of all input indexes (including the starting index). If readers/searchers are open against the starting index, then temporary free space required will be higher by the size of the starting index (see {@link #Optimize()} for details).

Once this completes, the final size of the index will be less than the sum of all input index sizes (including the starting index). It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

This requires this index not be among those to be added.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Close()()()()
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See {@link #Commit()} for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

            try {
            writer.close();
            } finally {
            if (IndexWriter.isLocked(directory)) {
            IndexWriter.unlock(directory);
            }
            }
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Close(Boolean)
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Public method Commit()()()()

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls {@link #PrepareCommit(Map)} (if you didn't already call it) and then {@link #finishCommit}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteAll
Delete all documents in the index.

This method will drop all buffered documents and will remove all segments from the index. This change will not be visible until a {@link #Commit()} has been called. This method can be rolled back using {@link #Rollback()}.

NOTE: this method is much faster than using deleteDocuments( new MatchAllDocsQuery() ).

NOTE: this method will forcefully abort all merges in progress. If other threads are running {@link #Optimize()} or any of the addIndexes methods, they will receive {@link MergePolicy.MergeAbortedException}s.

Public method DeleteDocuments(Query)
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(array<Query>[]()[][])
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(Term)
Deletes the document(s) containing
CopyC#
term
.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(array<Term>[]()[][])
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Dispose
.NET
Protected method DoAfterFlush
A hook for extending classes to execute operations after pending added and deleted documents have been flushed to the Directory but before the change is committed (new segments_N file written).
Protected method DoBeforeFlush
A hook for extending classes to execute operations before pending added and deleted documents are flushed to the Directory.
Public method DocCount Obsolete.
Returns the number of documents currently in this index, not counting deletions.
Protected method | EnsureOpen()()()()
Protected method EnsureOpen(Boolean)
Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method ExpungeDeletes()()()()
Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #ExpungeDeletes(boolean)}

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method ExpungeDeletes(Boolean)
Just like {@link #ExpungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()() Obsolete.
Flush all in-memory buffered updates (adds and deletes) to the Directory.

Note: while this will force buffered docs to be pushed into the index, it will not make these docs visible to a reader. Use {@link #Commit()} instead

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Flush(Boolean, Boolean, Boolean)
Flush all in-memory buffered udpates (adds and deletes) to the Directory.
Public method GetAnalyzer
Returns the analyzer used by this index.
Public method | GetBufferedDeleteTermsSize
GetDefaultInfoStream
Returns the current default infoStream for newly instantiated IndexWriters.
GetDefaultWriteLockTimeout
Returns default write lock timeout for newly instantiated IndexWriters.
Public method GetDirectory
Returns the Directory used by this index.
Public method | GetDocCount
Public method | GetFlushCount
Public method | GetFlushDeletesCount
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetInfoStream
Returns the current infoStream in use by this writer.
Public method GetMaxBufferedDeleteTerms
Returns the number of buffered deleted terms that will trigger a flush if enabled.
Public method GetMaxBufferedDocs
Returns the number of buffered added documents that will trigger a flush if enabled.
Public method GetMaxFieldLength
Returns the maximum number of terms that will be indexed for a single field in a document.
Public method GetMaxMergeDocs

Returns the largest segment (measured by document count) that may be merged with other segments.

Note that this method is a convenience method: it just calls mergePolicy.getMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method GetMaxSyncPauseSeconds Obsolete.
Expert: returns max delay inserted before syncing a commit point. On Windows, at least, pausing before syncing can increase net indexing throughput. The delay is variable based on size of the segment's files, and is only inserted when using ConcurrentMergeScheduler for merges.
Public method GetMergedSegmentWarmer
Returns the current merged segment warmer. See {@link IndexReaderWarmer}.
Public method GetMergeFactor

Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Note that this method is a convenience method: it just calls mergePolicy.getMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method GetMergePolicy
Expert: returns the current MergePolicy in use by this writer.
Public method GetMergeScheduler
Expert: returns the current MergePolicy in use by this writer.
Public method | GetNextMerge_forNUnit
Public method | GetNumBufferedDeleteTerms
Public method | GetNumBufferedDocuments
Public method GetRAMBufferSizeMB
Returns the value set by {@link #setRAMBufferSizeMB} if enabled.
Public method GetReader()()()()
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling {@link #commit}.

Note that this is functionally equivalent to calling {#commit} and then using {@link IndexReader#open} to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly {@link #commit}.

You must close the {@link IndexReader} returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports {@link IndexReader#reopen}, but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call {@link #setMergedSegmentWarmer} to call {@link #setMergedSegmentWarmer} to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an {@link AlreadyClosedException}.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public method GetReader(Int32)
Expert: like {@link #getReader}, except you can specify which termInfosIndexDivisor should be used for any newly opened readers.
Public method | GetReaderTermsIndexDivisor
Public method | GetSegmentCount
Public method GetSimilarity
Expert: Return the Similarity implementation used by this IndexWriter.

This defaults to the current value of {@link Similarity#GetDefault()}.

Public method GetTermIndexInterval
Expert: Return the interval between indexed terms.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUseCompoundFile

Get the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(boolean), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.getUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method GetWriteLockTimeout
Returns allowed timeout when acquiring the write lock.
Public method | HasDeletions
IsLocked(String) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
IsLocked(Directory)
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
Public method MaxDoc
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), not counting deletions.
Public method MaybeMerge
Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to maybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Merge_ForNUnit
Public method Message
Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.
Public method | NewestSegment
Public method NumDeletedDocs
Obtain the number of deleted docs for a pooled reader. If the reader isn't being pooled, the segmentInfo's delCount is returned.
Public method NumDocs
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), and including deletions. NOTE: buffered deletions are not counted. If you really need these to be counted you should call {@link #Commit()} first.
Public method NumRamDocs
Expert: Return the number of documents currently buffered in RAM.
Public method Optimize()()()()
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Boolean)
Just like {@link #Optimize()}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32)
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as {@link #Optimize()}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32, Boolean)
Just like {@link #Optimize(int)}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method PrepareCommit()()()()
Expert: prepare for commit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method PrepareCommit(IDictionary<(Of <<'(String, String>)>>))

Expert: prepare for commit, specifying commitUserData Map (String -> String). This does the first phase of 2-phase commit. You can only call this when autoCommit is false. This method does all steps necessary to commit changes since this writer was opened: flushes pending added and deleted docs, syncs the index files, writes most of next segments_N file. After calling this you must call either {@link #Commit()} to finish the commit, or {@link #Rollback()} to revert the commit and undo all changes done since the writer was opened.

You can also just call {@link #Commit(Map)} directly without prepareCommit first in which case that method will internally call prepareCommit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method RamSizeInBytes
Expert: Return the total size of all index files currently cached in memory. Useful for size management with flushRamDocs()
Public method Rollback
Close the
CopyC#
IndexWriter
 without committing any changes that have occurred since the last commit (or since it was opened, if commit hasn't been called). This removes any temporary files that had been created, after which the state of the index will be the same as it was when commit() was last called or when this writer was first opened. This can only be called when this IndexWriter was opened with
CopyC#
autoCommit=false
. This also clears a previous call to {@link #prepareCommit}.
Public method | SegString
Public method SetAllowMinus1Position
Deprecated: emulates IndexWriter's buggy behavior when first token(s) have positionIncrement==0 (ie, prior to fixing LUCENE-1542)
SetDefaultInfoStream
If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.
SetDefaultWriteLockTimeout
Sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).
Public method SetInfoStream
If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.
Public method SetMaxBufferedDeleteTerms

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxBufferedDocs
Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxFieldLength
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than {@link #DEFAULT_MAX_FIELD_LENGTH} terms will be indexed for a field.

Public method SetMaxMergeDocs

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is {@link Integer#MAX_VALUE}.

Note that this method is a convenience method: it just calls mergePolicy.setMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.

Public method SetMaxSyncPauseSeconds Obsolete.
Expert: sets the max delay before syncing a commit point.
Public method SetMergedSegmentWarmer
Set the merged segment warmer. See {@link IndexReaderWarmer}.
Public method SetMergeFactor
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Note that this method is a convenience method: it just calls mergePolicy.setMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

This must never be less than 2. The default value is 10.

Public method SetMergePolicy
Expert: set the merge policy used by this writer.
Public method SetMergeScheduler
Expert: set the merge scheduler used by this writer.
Public method SetRAMBufferSizeMB
Determines the amount of RAM that may be used for buffering added documents and deletions before they are flushed to the Directory. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents and deletions use this much RAM. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

NOTE: the account of RAM usage for pending deletions is only approximate. Specifically, if you delete by Query, Lucene currently has no way to measure the RAM usage if individual Queries so the accounting will under-estimate and you should compensate by either calling commit() periodically yourself, or by using {@link #setMaxBufferedDeleteTerms} to flush by count instead of RAM usage (each buffered delete Query counts as one).

NOTE: because IndexWriter uses

CopyC#
int
s when managing its internal storage, the absolute maximum value for this setting is somewhat less than 2048 MB. The precise limit depends on various factors, such as how large your documents are, how many fields have norms, etc., so it's best to set this value comfortably under 2048.

The default value is {@link #DEFAULT_RAM_BUFFER_SIZE_MB}.

Public method | SetReaderTermsIndexDivisor
Public method SetSimilarity
Expert: Set the Similarity implementation used by this IndexWriter.
Public method SetTermIndexInterval
Expert: Set the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular,
CopyC#
numUniqueTerms/interval
 terms are read into memory by an IndexReader, and, on average,
CopyC#
interval/2
 terms must be scanned for each random term access.
Public method SetUseCompoundFile

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file when a new segment is flushed.

Note that this method is a convenience method: it just calls mergePolicy.setUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method | SetWriteLockTimeout
Public method | TestPoint
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Unlock
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

Public method UpdateDocument(Term, Document)
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method UpdateDocument(Term, Document, Analyzer)
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Verbose
Returns true if verbosing is enabled (i.e., infoStream != null).
Public method WaitForMerges
Wait for any currently outstanding merges to finish.

It is guaranteed that any merges started prior to calling this method will have completed once this method completes.

Fields

Name | Description
DEFAULT_MAX_BUFFERED_DELETE_TERMS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDeleteTerms(int)}.
DEFAULT_MAX_BUFFERED_DOCS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDocs(int)}.
DEFAULT_MAX_FIELD_LENGTH | Default value is 10,000. Change using {@link #SetMaxFieldLength(int)}.
DEFAULT_MAX_MERGE_DOCS | Obsolete.
DEFAULT_MAX_SYNC_PAUSE_SECONDS | Default for {@link #getMaxSyncPauseSeconds}. On Windows this defaults to 10.0 seconds; elsewhere it's 0.
DEFAULT_MERGE_FACTOR | Obsolete.
DEFAULT_RAM_BUFFER_SIZE_MB | Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using {@link #setRAMBufferSizeMB}.
DEFAULT_TERM_INDEX_INTERVAL | Default value is 128. Change using {@link #SetTermIndexInterval(int)}.
DISABLE_AUTO_FLUSH | Value to denote a flush trigger is disabled
MAX_TERM_LENGTH | Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see {@link #setInfoStream}).
WRITE_LOCK_NAME | Name of the write lock in the index.
WRITE_LOCK_TIMEOUT | Default value for the write lock timeout (1,000).

See Also

IndexWriter Class
Lucene.Net.Index Namespace


IndexWriter Constructor

[image] [image]

Lucene.Net Class Libraries
IndexWriter Constructor
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method IndexWriter(FileInfo, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(String, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(Directory, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(FileInfo, Analyzer, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(FileInfo, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.
Public method IndexWriter(String, Analyzer, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(String, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.
Public method IndexWriter(Directory, Analyzer, IndexWriter..::..MaxFieldLength)
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
Public method IndexWriter(Directory, Boolean, Analyzer) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(FileInfo, Analyzer, Boolean, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(String, Analyzer, Boolean, IndexWriter..::..MaxFieldLength) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength)
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, Boolean, IndexWriter..::..MaxFieldLength)
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Boolean, Analyzer, IndexDeletionPolicy) Obsolete.
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
Public method IndexWriter(Directory, Boolean, Analyzer, Boolean) Obsolete.
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
Public method IndexWriter(Directory, Analyzer, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength, IndexCommit)
Expert: constructs an IndexWriter on specific commit point, with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
.

This is only meaningful if you've used a {@link IndexDeletionPolicy} in that past that keeps more than just the last commit.

This operation is similar to {@link #Rollback()}, except that method can only rollback what's been done with the current instance of IndexWriter since its last commit, whereas this method can rollback to an arbitrary commit point from the past, assuming the {@link IndexDeletionPolicy} has preserved past commits.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength)
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

Public method IndexWriter(Directory, Boolean, Analyzer, Boolean, IndexDeletionPolicy) Obsolete.
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


IndexWriter Constructor (FileInfo, Analyzer)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (FileInfo, Analyzer)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    FileInfo path,
    Analyzer a
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    path As FileInfo, _
    a As Analyzer _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    FileInfo^ path,
    Analyzer^ a
)

Parameters

path
Type: System.IO..::..FileInfo
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (String, Analyzer)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (String, Analyzer)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release, and call Commit() when needed. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead.")]
public IndexWriter(
    string path,
    Analyzer a
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release, and call Commit() when needed. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead.")> _
Public Sub New ( _
    path As String, _
    a As Analyzer _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release, and call Commit() when needed. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead.")]
public:
IndexWriter(
    String^ path,
    Analyzer^ a
)

Parameters

path
Type: System..::..String
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    Directory d,
    Analyzer a
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    d As Directory, _
    a As Analyzer _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (FileInfo, Analyzer, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (FileInfo, Analyzer, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use {@link #IndexWriter(Directory,Analyzer, MaxFieldLength)")]
public IndexWriter(
    FileInfo path,
    Analyzer a,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
<ObsoleteAttribute("Use {@link #IndexWriter(Directory,Analyzer, MaxFieldLength)")> _
Public Sub New ( _
    path As FileInfo, _
    a As Analyzer, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
[ObsoleteAttribute(L"Use {@link #IndexWriter(Directory,Analyzer, MaxFieldLength)")]
public:
IndexWriter(
    FileInfo^ path,
    Analyzer^ a,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

path
Type: System.IO..::..FileInfo
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified via the MaxFieldLength constructor.

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (FileInfo, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (FileInfo, Analyzer, Boolean)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.
has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    FileInfo path,
    Analyzer a,
    bool create
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    path As FileInfo, _
    a As Analyzer, _
    create As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    FileInfo^ path,
    Analyzer^ a,
    bool create
)

Parameters

path
Type: System.IO..::..FileInfo
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (String, Analyzer, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (String, Analyzer, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexWriter(Directory, Analyzer, MaxFieldLength)")]
public IndexWriter(
    string path,
    Analyzer a,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
<ObsoleteAttribute("Use IndexWriter(Directory, Analyzer, MaxFieldLength)")> _
Public Sub New ( _
    path As String, _
    a As Analyzer, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
[ObsoleteAttribute(L"Use IndexWriter(Directory, Analyzer, MaxFieldLength)")]
public:
IndexWriter(
    String^ path,
    Analyzer^ a,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

path
Type: System..::..String
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified via the MaxFieldLength constructor.

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (String, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (String, Analyzer, Boolean)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.
has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead, and call Commit() when needed")]
public IndexWriter(
    string path,
    Analyzer a,
    bool create
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead, and call Commit() when needed")> _
Public Sub New ( _
    path As String, _
    a As Analyzer, _
    create As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead, and call Commit() when needed")]
public:
IndexWriter(
    String^ path,
    Analyzer^ a,
    bool create
)

Parameters

path
Type: System..::..String
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified via the MaxFieldLength constructor.

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer, Boolean)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release, and call Commit() when needed. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead.")]
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release, and call Commit() when needed. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead.")> _
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release, and call Commit() when needed. Use IndexWriter(Directory,Analyzer,bool,MaxFieldLength) instead.")]
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Boolean, Analyzer)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Boolean, Analyzer)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    Directory d,
    bool autoCommit,
    Analyzer a
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    d As Directory, _
    autoCommit As Boolean, _
    a As Analyzer _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    Directory^ d,
    bool autoCommit,
    Analyzer^ a
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
autoCommit
Type: System..::..Boolean
see above
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (FileInfo, Analyzer, Boolean, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (FileInfo, Analyzer, Boolean, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexWriter(Directory, Analyzer, boolean, MaxFieldLength)")]
public IndexWriter(
    FileInfo path,
    Analyzer a,
    bool create,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
<ObsoleteAttribute("Use IndexWriter(Directory, Analyzer, boolean, MaxFieldLength)")> _
Public Sub New ( _
    path As FileInfo, _
    a As Analyzer, _
    create As Boolean, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
[ObsoleteAttribute(L"Use IndexWriter(Directory, Analyzer, boolean, MaxFieldLength)")]
public:
IndexWriter(
    FileInfo^ path,
    Analyzer^ a,
    bool create,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

path
Type: System.IO..::..FileInfo
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified via the MaxFieldLength constructor.

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (String, Analyzer, Boolean, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (String, Analyzer, Boolean, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
path
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
path
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexWriter(Directory, Analyzer,boolean, MaxFieldLength)")]
public IndexWriter(
    string path,
    Analyzer a,
    bool create,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
<ObsoleteAttribute("Use IndexWriter(Directory, Analyzer,boolean, MaxFieldLength)")> _
Public Sub New ( _
    path As String, _
    a As Analyzer, _
    create As Boolean, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
[ObsoleteAttribute(L"Use IndexWriter(Directory, Analyzer,boolean, MaxFieldLength)")]
public:
IndexWriter(
    String^ path,
    Analyzer^ a,
    bool create,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

path
Type: System..::..String
the path to the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
Maximum field length in number of tokens/terms: LIMITED, UNLIMITED, or user-specified via the MaxFieldLength constructor.

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
see above
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
whether or not to limit field lengths

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer, Boolean, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer, Boolean, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
Maximum field length in number of terms/tokens: LIMITED, UNLIMITED, or user-specified via the MaxFieldLength constructor.

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Boolean, Analyzer, IndexDeletionPolicy)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Boolean, Analyzer, IndexDeletionPolicy)
IndexWriter Class See Also Send Feedback
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
, first creating it if it does not already exist. Text will be analyzed with
CopyC#
a
.
has this index open (
CopyC#
write.lock
 could not be obtained)
read/written to or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,IndexDeletionPolicy,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    Directory d,
    bool autoCommit,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,IndexDeletionPolicy,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    d As Directory, _
    autoCommit As Boolean, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,IndexDeletionPolicy,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    Directory^ d,
    bool autoCommit,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
autoCommit
Type: System..::..Boolean
see above
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
see above

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Boolean, Analyzer, Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Boolean, Analyzer, Boolean)
IndexWriter Class See Also Send Feedback
Constructs an IndexWriter for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,boolean,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    Directory d,
    bool autoCommit,
    Analyzer a,
    bool create
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,boolean,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    d As Directory, _
    autoCommit As Boolean, _
    a As Analyzer, _
    create As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,boolean,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    Directory^ d,
    bool autoCommit,
    Analyzer^ a,
    bool create
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
autoCommit
Type: System..::..Boolean
see above
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter.MaxFieldLength, IndexCommit)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength, IndexCommit)
IndexWriter Class See Also Send Feedback
Expert: constructs an IndexWriter on specific commit point, with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
.

This is only meaningful if you've used a {@link IndexDeletionPolicy} in that past that keeps more than just the last commit.

This operation is similar to {@link #Rollback()}, except that method can only rollback what's been done with the current instance of IndexWriter since its last commit, whereas this method can rollback to an arbitrary commit point from the past, assuming the {@link IndexDeletionPolicy} has preserved past commits.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexWriter(
    Directory d,
    Analyzer a,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl,
    IndexCommit commit
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength, _
    commit As IndexCommit _
)
Visual C++
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl,
    IndexCommit^ commit
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
see above
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
whether or not to limit field lengths, value is in number of terms/tokens. See {@link Lucene.Net.Index.IndexWriter.MaxFieldLength}.
commit
Type: Lucene.Net.Index..::..IndexCommit
which commit to open

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter.MaxFieldLength)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Analyzer, Boolean, IndexDeletionPolicy, IndexWriter..::..MaxFieldLength)
IndexWriter Class See Also Send Feedback
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.

NOTE: autoCommit (see above) is set to false with this constructor.

has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexWriter(
    Directory d,
    Analyzer a,
    bool create,
    IndexDeletionPolicy deletionPolicy,
    IndexWriter..::..MaxFieldLength mfl
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    a As Analyzer, _
    create As Boolean, _
    deletionPolicy As IndexDeletionPolicy, _
    mfl As IndexWriter..::..MaxFieldLength _
)
Visual C++
public:
IndexWriter(
    Directory^ d,
    Analyzer^ a,
    bool create,
    IndexDeletionPolicy^ deletionPolicy,
    IndexWriter..::..MaxFieldLength^ mfl
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
see above
mfl
Type: Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength
{@link Lucene.Net.Index.IndexWriter.MaxFieldLength}, whether or not to limit field lengths. Value is in number of terms/tokens

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Constructor (Directory, Boolean, Analyzer, Boolean, IndexDeletionPolicy)

[image]

Lucene.Net Class Libraries
IndexWriter Constructor (Directory, Boolean, Analyzer, Boolean, IndexDeletionPolicy)
IndexWriter Class See Also Send Feedback
Expert: constructs an IndexWriter with a custom {@link IndexDeletionPolicy}, for the index in
CopyC#
d
. Text will be analyzed with
CopyC#
a
. If
CopyC#
create
 is true, then a new, empty index will be created in
CopyC#
d
, replacing the index already there, if any.
has this index open (
CopyC#
write.lock
 could not be obtained)
if it does not exist and
CopyC#
create
 is
CopyC#
false
 or if there is any other low-level IO error

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,boolean,IndexDeletionPolicy,MaxFieldLength) instead, and call Commit() when needed.")]
public IndexWriter(
    Directory d,
    bool autoCommit,
    Analyzer a,
    bool create,
    IndexDeletionPolicy deletionPolicy
)
Visual Basic
<ObsoleteAttribute("This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,boolean,IndexDeletionPolicy,MaxFieldLength) instead, and call Commit() when needed.")> _
Public Sub New ( _
    d As Directory, _
    autoCommit As Boolean, _
    a As Analyzer, _
    create As Boolean, _
    deletionPolicy As IndexDeletionPolicy _
)
Visual C++
[ObsoleteAttribute(L"This constructor will be removed in the 3.0 release. Use IndexWriter(Directory,Analyzer,boolean,IndexDeletionPolicy,MaxFieldLength) instead, and call Commit() when needed.")]
public:
IndexWriter(
    Directory^ d,
    bool autoCommit,
    Analyzer^ a,
    bool create,
    IndexDeletionPolicy^ deletionPolicy
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
the index directory
autoCommit
Type: System..::..Boolean
see above
a
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use
create
Type: System..::..Boolean
CopyC#
true
 to create the index or overwrite the existing one;
CopyC#
false
 to append to the existing index
deletionPolicy
Type: Lucene.Net.Index..::..IndexDeletionPolicy
see above

See Also

IndexWriter Class
IndexWriter Overload
Lucene.Net.Index Namespace


IndexWriter Fields

[image] [image]

Lucene.Net Class Libraries
IndexWriter Fields
IndexWriter Class See Also Send Feedback

The IndexWriter type exposes the following members.

Fields

Name | Description
DEFAULT_MAX_BUFFERED_DELETE_TERMS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDeleteTerms(int)}.
DEFAULT_MAX_BUFFERED_DOCS | Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDocs(int)}.
DEFAULT_MAX_FIELD_LENGTH | Default value is 10,000. Change using {@link #SetMaxFieldLength(int)}.
DEFAULT_MAX_MERGE_DOCS | Obsolete.
DEFAULT_MAX_SYNC_PAUSE_SECONDS | Default for {@link #getMaxSyncPauseSeconds}. On Windows this defaults to 10.0 seconds; elsewhere it's 0.
DEFAULT_MERGE_FACTOR | Obsolete.
DEFAULT_RAM_BUFFER_SIZE_MB | Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using {@link #setRAMBufferSizeMB}.
DEFAULT_TERM_INDEX_INTERVAL | Default value is 128. Change using {@link #SetTermIndexInterval(int)}.
DISABLE_AUTO_FLUSH | Value to denote a flush trigger is disabled
MAX_TERM_LENGTH | Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see {@link #setInfoStream}).
WRITE_LOCK_NAME | Name of the write lock in the index.
WRITE_LOCK_TIMEOUT | Default value for the write lock timeout (1,000).

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DEFAULT_MAX_BUFFERED_DELETE_TERMS Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_MAX_BUFFERED_DELETE_TERMS Field
IndexWriter Class See Also Send Feedback
Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDeleteTerms(int)}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS
Visual Basic
Public Shared ReadOnly DEFAULT_MAX_BUFFERED_DELETE_TERMS As Integer
Visual C++
public:
static initonly int DEFAULT_MAX_BUFFERED_DELETE_TERMS

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DEFAULT_MAX_BUFFERED_DOCS Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_MAX_BUFFERED_DOCS Field
IndexWriter Class See Also Send Feedback
Disabled by default (because IndexWriter flushes by RAM usage by default). Change using {@link #SetMaxBufferedDocs(int)}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int DEFAULT_MAX_BUFFERED_DOCS
Visual Basic
Public Shared ReadOnly DEFAULT_MAX_BUFFERED_DOCS As Integer
Visual C++
public:
static initonly int DEFAULT_MAX_BUFFERED_DOCS

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DEFAULT_MAX_FIELD_LENGTH Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_MAX_FIELD_LENGTH Field
IndexWriter Class See Also Send Feedback
Default value is 10,000. Change using {@link #SetMaxFieldLength(int)}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT_MAX_FIELD_LENGTH
Visual Basic
Public Const DEFAULT_MAX_FIELD_LENGTH As Integer
Visual C++
public:
literal int DEFAULT_MAX_FIELD_LENGTH

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DEFAULT_MAX_MERGE_DOCS Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_MAX_MERGE_DOCS Field
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexWriter.DEFAULT_MAX_MERGE_DOCS"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("See LogDocMergePolicy.DEFAULT_MAX_MERGE_DOCS")]
public static readonly int DEFAULT_MAX_MERGE_DOCS
Visual Basic
<ObsoleteAttribute("See LogDocMergePolicy.DEFAULT_MAX_MERGE_DOCS")> _
Public Shared ReadOnly DEFAULT_MAX_MERGE_DOCS As Integer
Visual C++
[ObsoleteAttribute(L"See LogDocMergePolicy.DEFAULT_MAX_MERGE_DOCS")]
public:
static initonly int DEFAULT_MAX_MERGE_DOCS

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:LogDocMergePolicy.DEFAULT_MAX_MERGE_DOCS]


DEFAULT_MAX_SYNC_PAUSE_SECONDS Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_MAX_SYNC_PAUSE_SECONDS Field
IndexWriter Class See Also Send Feedback
Default for {@link #getMaxSyncPauseSeconds}. On Windows this defaults to 10.0 seconds; elsewhere it's 0.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static double DEFAULT_MAX_SYNC_PAUSE_SECONDS
Visual Basic
Public Shared DEFAULT_MAX_SYNC_PAUSE_SECONDS As Double
Visual C++
public:
static double DEFAULT_MAX_SYNC_PAUSE_SECONDS

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DEFAULT_MERGE_FACTOR Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_MERGE_FACTOR Field
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.IndexWriter.DEFAULT_MERGE_FACTOR"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("See LogMergePolicy.DEFAULT_MERGE_FACTOR")]
public static readonly int DEFAULT_MERGE_FACTOR
Visual Basic
<ObsoleteAttribute("See LogMergePolicy.DEFAULT_MERGE_FACTOR")> _
Public Shared ReadOnly DEFAULT_MERGE_FACTOR As Integer
Visual C++
[ObsoleteAttribute(L"See LogMergePolicy.DEFAULT_MERGE_FACTOR")]
public:
static initonly int DEFAULT_MERGE_FACTOR

See Also

IndexWriter Class
Lucene.Net.Index Namespace
LogMergePolicy..::..DEFAULT_MERGE_FACTOR


DEFAULT_RAM_BUFFER_SIZE_MB Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_RAM_BUFFER_SIZE_MB Field
IndexWriter Class See Also Send Feedback
Default value is 16 MB (which means flush when buffered docs consume 16 MB RAM). Change using {@link #setRAMBufferSizeMB}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const double DEFAULT_RAM_BUFFER_SIZE_MB
Visual Basic
Public Const DEFAULT_RAM_BUFFER_SIZE_MB As Double
Visual C++
public:
literal double DEFAULT_RAM_BUFFER_SIZE_MB

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DEFAULT_TERM_INDEX_INTERVAL Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DEFAULT_TERM_INDEX_INTERVAL Field
IndexWriter Class See Also Send Feedback
Default value is 128. Change using {@link #SetTermIndexInterval(int)}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT_TERM_INDEX_INTERVAL
Visual Basic
Public Const DEFAULT_TERM_INDEX_INTERVAL As Integer
Visual C++
public:
literal int DEFAULT_TERM_INDEX_INTERVAL

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DISABLE_AUTO_FLUSH Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..DISABLE_AUTO_FLUSH Field
IndexWriter Class See Also Send Feedback
Value to denote a flush trigger is disabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DISABLE_AUTO_FLUSH
Visual Basic
Public Const DISABLE_AUTO_FLUSH As Integer
Visual C++
public:
literal int DISABLE_AUTO_FLUSH

See Also

IndexWriter Class
Lucene.Net.Index Namespace


MAX_TERM_LENGTH Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..MAX_TERM_LENGTH Field
IndexWriter Class See Also Send Feedback
Absolute hard maximum length for a term. If a term arrives from the analyzer longer than this length, it is skipped and a message is printed to infoStream, if set (see {@link #setInfoStream}).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int MAX_TERM_LENGTH
Visual Basic
Public Shared ReadOnly MAX_TERM_LENGTH As Integer
Visual C++
public:
static initonly int MAX_TERM_LENGTH

See Also

IndexWriter Class
Lucene.Net.Index Namespace


WRITE_LOCK_NAME Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..WRITE_LOCK_NAME Field
IndexWriter Class See Also Send Feedback
Name of the write lock in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string WRITE_LOCK_NAME
Visual Basic
Public Const WRITE_LOCK_NAME As String
Visual C++
public:
literal String^ WRITE_LOCK_NAME

See Also

IndexWriter Class
Lucene.Net.Index Namespace


WRITE_LOCK_TIMEOUT Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..WRITE_LOCK_TIMEOUT Field
IndexWriter Class See Also Send Feedback
Default value for the write lock timeout (1,000).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long WRITE_LOCK_TIMEOUT
Visual Basic
Public Shared WRITE_LOCK_TIMEOUT As Long
Visual C++
public:
static long long WRITE_LOCK_TIMEOUT

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setDefaultWriteLockTimeout]


IndexWriter Methods

[image] [image]

Lucene.Net Class Libraries
IndexWriter Methods
IndexWriter Class See Also Send Feedback

The IndexWriter type exposes the following members.

Methods

Name | Description
Public method | Abort | Obsolete.
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the {@link MergePolicy} in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see {@link #Optimize()} for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

See {@link #AddDocument(Document)} for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexes(array<Directory>[]()[][]) Obsolete.
Merges all segments from an array of indexes into this index.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexes(array<IndexReader>[]()[][])
Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

See {@link #AddIndexesNoOptimize(Directory[])} for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddIndexesNoOptimize
Merges all segments from an array of indexes into this index.

This may be used to parallelize batch indexing. A large document collection can be broken into sub-collections. Each sub-collection can be indexed in parallel, on a different thread, process or machine. The complete index can then be created by merging sub-collection indexes with this method.

NOTE: the index in each Directory must not be changed (opened by a writer) while this method is running. This method does not acquire a write lock in each input Directory, so it is up to the caller to enforce this.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

This method is transactional in how Exceptions are handled: it does not commit a new segments_N file until all indexes are added. This means if an Exception occurs (for example disk full), then either no indexes will have been added or they all will have been.

Note that this requires temporary free space in the Directory up to 2X the sum of all input indexes (including the starting index). If readers/searchers are open against the starting index, then temporary free space required will be higher by the size of the starting index (see {@link #Optimize()} for details).

Once this completes, the final size of the index will be less than the sum of all input index sizes (including the starting index). It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

This requires this index not be among those to be added.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Close()()()()
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See {@link #Commit()} for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

            try {
            writer.close();
            } finally {
            if (IndexWriter.isLocked(directory)) {
            IndexWriter.unlock(directory);
            }
            }
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Close(Boolean)
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Public method Commit()()()()

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls {@link #PrepareCommit(Map)} (if you didn't already call it) and then {@link #finishCommit}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteAll
Delete all documents in the index.

This method will drop all buffered documents and will remove all segments from the index. This change will not be visible until a {@link #Commit()} has been called. This method can be rolled back using {@link #Rollback()}.

NOTE: this method is much faster than using deleteDocuments( new MatchAllDocsQuery() ).

NOTE: this method will forcefully abort all merges in progress. If other threads are running {@link #Optimize()} or any of the addIndexes methods, they will receive {@link MergePolicy.MergeAbortedException}s.

Public method DeleteDocuments(Query)
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(array<Query>[]()[][])
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(Term)
Deletes the document(s) containing
CopyC#
term
.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(array<Term>[]()[][])
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Dispose
.NET
Protected method DoAfterFlush
A hook for extending classes to execute operations after pending added and deleted documents have been flushed to the Directory but before the change is committed (new segments_N file written).
Protected method DoBeforeFlush
A hook for extending classes to execute operations before pending added and deleted documents are flushed to the Directory.
Public method DocCount Obsolete.
Returns the number of documents currently in this index, not counting deletions.
Protected method | EnsureOpen()()()()
Protected method EnsureOpen(Boolean)
Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method ExpungeDeletes()()()()
Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #ExpungeDeletes(boolean)}

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method ExpungeDeletes(Boolean)
Just like {@link #ExpungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()() Obsolete.
Flush all in-memory buffered updates (adds and deletes) to the Directory.

Note: while this will force buffered docs to be pushed into the index, it will not make these docs visible to a reader. Use {@link #Commit()} instead

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Flush(Boolean, Boolean, Boolean)
Flush all in-memory buffered udpates (adds and deletes) to the Directory.
Public method GetAnalyzer
Returns the analyzer used by this index.
Public method | GetBufferedDeleteTermsSize
GetDefaultInfoStream
Returns the current default infoStream for newly instantiated IndexWriters.
GetDefaultWriteLockTimeout
Returns default write lock timeout for newly instantiated IndexWriters.
Public method GetDirectory
Returns the Directory used by this index.
Public method | GetDocCount
Public method | GetFlushCount
Public method | GetFlushDeletesCount
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetInfoStream
Returns the current infoStream in use by this writer.
Public method GetMaxBufferedDeleteTerms
Returns the number of buffered deleted terms that will trigger a flush if enabled.
Public method GetMaxBufferedDocs
Returns the number of buffered added documents that will trigger a flush if enabled.
Public method GetMaxFieldLength
Returns the maximum number of terms that will be indexed for a single field in a document.
Public method GetMaxMergeDocs

Returns the largest segment (measured by document count) that may be merged with other segments.

Note that this method is a convenience method: it just calls mergePolicy.getMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method GetMaxSyncPauseSeconds Obsolete.
Expert: returns max delay inserted before syncing a commit point. On Windows, at least, pausing before syncing can increase net indexing throughput. The delay is variable based on size of the segment's files, and is only inserted when using ConcurrentMergeScheduler for merges.
Public method GetMergedSegmentWarmer
Returns the current merged segment warmer. See {@link IndexReaderWarmer}.
Public method GetMergeFactor

Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Note that this method is a convenience method: it just calls mergePolicy.getMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method GetMergePolicy
Expert: returns the current MergePolicy in use by this writer.
Public method GetMergeScheduler
Expert: returns the current MergePolicy in use by this writer.
Public method | GetNextMerge_forNUnit
Public method | GetNumBufferedDeleteTerms
Public method | GetNumBufferedDocuments
Public method GetRAMBufferSizeMB
Returns the value set by {@link #setRAMBufferSizeMB} if enabled.
Public method GetReader()()()()
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling {@link #commit}.

Note that this is functionally equivalent to calling {#commit} and then using {@link IndexReader#open} to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly {@link #commit}.

You must close the {@link IndexReader} returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports {@link IndexReader#reopen}, but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call {@link #setMergedSegmentWarmer} to call {@link #setMergedSegmentWarmer} to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an {@link AlreadyClosedException}.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public method GetReader(Int32)
Expert: like {@link #getReader}, except you can specify which termInfosIndexDivisor should be used for any newly opened readers.
Public method | GetReaderTermsIndexDivisor
Public method | GetSegmentCount
Public method GetSimilarity
Expert: Return the Similarity implementation used by this IndexWriter.

This defaults to the current value of {@link Similarity#GetDefault()}.

Public method GetTermIndexInterval
Expert: Return the interval between indexed terms.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUseCompoundFile

Get the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(boolean), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.getUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method GetWriteLockTimeout
Returns allowed timeout when acquiring the write lock.
Public method | HasDeletions
IsLocked(String) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
IsLocked(Directory)
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
Public method MaxDoc
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), not counting deletions.
Public method MaybeMerge
Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to maybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Merge_ForNUnit
Public method Message
Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.
Public method | NewestSegment
Public method NumDeletedDocs
Obtain the number of deleted docs for a pooled reader. If the reader isn't being pooled, the segmentInfo's delCount is returned.
Public method NumDocs
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), and including deletions. NOTE: buffered deletions are not counted. If you really need these to be counted you should call {@link #Commit()} first.
Public method NumRamDocs
Expert: Return the number of documents currently buffered in RAM.
Public method Optimize()()()()
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Boolean)
Just like {@link #Optimize()}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32)
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as {@link #Optimize()}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32, Boolean)
Just like {@link #Optimize(int)}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method PrepareCommit()()()()
Expert: prepare for commit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method PrepareCommit(IDictionary<(Of <<'(String, String>)>>))

Expert: prepare for commit, specifying commitUserData Map (String -> String). This does the first phase of 2-phase commit. You can only call this when autoCommit is false. This method does all steps necessary to commit changes since this writer was opened: flushes pending added and deleted docs, syncs the index files, writes most of next segments_N file. After calling this you must call either {@link #Commit()} to finish the commit, or {@link #Rollback()} to revert the commit and undo all changes done since the writer was opened.

You can also just call {@link #Commit(Map)} directly without prepareCommit first in which case that method will internally call prepareCommit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method RamSizeInBytes
Expert: Return the total size of all index files currently cached in memory. Useful for size management with flushRamDocs()
Public method Rollback
Close the
CopyC#
IndexWriter
 without committing any changes that have occurred since the last commit (or since it was opened, if commit hasn't been called). This removes any temporary files that had been created, after which the state of the index will be the same as it was when commit() was last called or when this writer was first opened. This can only be called when this IndexWriter was opened with
CopyC#
autoCommit=false
. This also clears a previous call to {@link #prepareCommit}.
Public method | SegString
Public method SetAllowMinus1Position
Deprecated: emulates IndexWriter's buggy behavior when first token(s) have positionIncrement==0 (ie, prior to fixing LUCENE-1542)
SetDefaultInfoStream
If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.
SetDefaultWriteLockTimeout
Sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).
Public method SetInfoStream
If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.
Public method SetMaxBufferedDeleteTerms

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxBufferedDocs
Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

Public method SetMaxFieldLength
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than {@link #DEFAULT_MAX_FIELD_LENGTH} terms will be indexed for a field.

Public method SetMaxMergeDocs

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is {@link Integer#MAX_VALUE}.

Note that this method is a convenience method: it just calls mergePolicy.setMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.

Public method SetMaxSyncPauseSeconds Obsolete.
Expert: sets the max delay before syncing a commit point.
Public method SetMergedSegmentWarmer
Set the merged segment warmer. See {@link IndexReaderWarmer}.
Public method SetMergeFactor
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Note that this method is a convenience method: it just calls mergePolicy.setMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

This must never be less than 2. The default value is 10.

Public method SetMergePolicy
Expert: set the merge policy used by this writer.
Public method SetMergeScheduler
Expert: set the merge scheduler used by this writer.
Public method SetRAMBufferSizeMB
Determines the amount of RAM that may be used for buffering added documents and deletions before they are flushed to the Directory. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents and deletions use this much RAM. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

NOTE: the account of RAM usage for pending deletions is only approximate. Specifically, if you delete by Query, Lucene currently has no way to measure the RAM usage if individual Queries so the accounting will under-estimate and you should compensate by either calling commit() periodically yourself, or by using {@link #setMaxBufferedDeleteTerms} to flush by count instead of RAM usage (each buffered delete Query counts as one).

NOTE: because IndexWriter uses

CopyC#
int
s when managing its internal storage, the absolute maximum value for this setting is somewhat less than 2048 MB. The precise limit depends on various factors, such as how large your documents are, how many fields have norms, etc., so it's best to set this value comfortably under 2048.

The default value is {@link #DEFAULT_RAM_BUFFER_SIZE_MB}.

Public method | SetReaderTermsIndexDivisor
Public method SetSimilarity
Expert: Set the Similarity implementation used by this IndexWriter.
Public method SetTermIndexInterval
Expert: Set the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular,
CopyC#
numUniqueTerms/interval
 terms are read into memory by an IndexReader, and, on average,
CopyC#
interval/2
 terms must be scanned for each random term access.
Public method SetUseCompoundFile

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file when a new segment is flushed.

Note that this method is a convenience method: it just calls mergePolicy.setUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Public method | SetWriteLockTimeout
Public method | TestPoint
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Unlock
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

Public method UpdateDocument(Term, Document)
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method UpdateDocument(Term, Document, Analyzer)
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Verbose
Returns true if verbosing is enabled (i.e., infoStream != null).
Public method WaitForMerges
Wait for any currently outstanding merges to finish.

It is guaranteed that any merges started prior to calling this method will have completed once this method completes.

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Abort Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Abort Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.Abort"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use Rollback instead.")]
public virtual void Abort()
Visual Basic
<ObsoleteAttribute("Please use Rollback instead.")> _
Public Overridable Sub Abort
Visual C++
[ObsoleteAttribute(L"Please use Rollback instead.")]
public:
virtual void Abort()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


AddDocument Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..AddDocument Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method AddDocument(Document)
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the {@link MergePolicy} in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see {@link #Optimize()} for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method AddDocument(Document, Analyzer)
Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

See {@link #AddDocument(Document)} for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


AddDocument Method (Document)

[image]

Lucene.Net Class Libraries
IndexWriter..::..AddDocument Method (Document)
IndexWriter Class See Also Send Feedback
Adds a document to this index. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

Note that if an Exception is hit (for example disk full) then the index will be consistent, but this document may not have been added. Furthermore, it's possible the index will have one segment in non-compound format even when using compound files (when a merge has partially succeeded).

This method periodically flushes pending documents to the Directory (see above), and also periodically triggers segment merges in the index according to the {@link MergePolicy} in use.

Merges temporarily consume space in the directory. The amount of space required is up to 1X the size of all segments being merged, when no readers/searchers are open against the index, and up to 2X the size of all segments being merged when readers/searchers are open against the index (see {@link #Optimize()} for details). The sequence of primitive merge operations performed is governed by the merge policy.

Note that each term in the document can be no longer than 16383 characters, otherwise an IllegalArgumentException will be thrown.

Note that it's possible to create an invalid Unicode string in java if a UTF16 surrogate pair is malformed. In this case, the invalid characters are silently replaced with the Unicode replacement character U+FFFD.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddDocument(
    Document doc
)
Visual Basic
Public Overridable Sub AddDocument ( _
    doc As Document _
)
Visual C++
public:
virtual void AddDocument(
    Document^ doc
)

Parameters

doc
Type: Lucene.Net.Documents..::..Document

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexWriter.AddDocument(Lucene.Net.Documents.Document)"]

See Also

IndexWriter Class
AddDocument Overload
Lucene.Net.Index Namespace


AddDocument Method (Document, Analyzer)

[image]

Lucene.Net Class Libraries
IndexWriter..::..AddDocument Method (Document, Analyzer)
IndexWriter Class See Also Send Feedback
Adds a document to this index, using the provided analyzer instead of the value of {@link #GetAnalyzer()}. If the document contains more than {@link #SetMaxFieldLength(int)} terms for a given field, the remainder are discarded.

See {@link #AddDocument(Document)} for details on index and IndexWriter state after an Exception, and flushing/merging temporary free space requirements.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddDocument(
    Document doc,
    Analyzer analyzer
)
Visual Basic
Public Overridable Sub AddDocument ( _
    doc As Document, _
    analyzer As Analyzer _
)
Visual C++
public:
virtual void AddDocument(
    Document^ doc,
    Analyzer^ analyzer
)

Parameters

doc
Type: Lucene.Net.Documents..::..Document

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.IndexWriter.AddDocument(Lucene.Net.Documents.Document,Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Index.IndexWriter.AddDocument(Lucene.Net.Documents.Document,Lucene.Net.Analysis.Analyzer)"]

See Also

IndexWriter Class
AddDocument Overload
Lucene.Net.Index Namespace


AddIndexes Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..AddIndexes Method
IndexWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddIndexes(array<Directory>[]()[][]) | Obsolete. Merges all segments from an array of indexes into this index. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | AddIndexes(array<IndexReader>[]()[][]) | Merges the provided indexes into this index. After this completes, the index is optimized. The provided IndexReaders are not closed. NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes. See {@link #AddIndexesNoOptimize(Directory[])} for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


AddIndexes Method (Directory[])

[image]

Lucene.Net Class Libraries
IndexWriter..::..AddIndexes Method (array<Directory>[]()[][])
IndexWriter Class See Also Send Feedback
Merges all segments from an array of indexes into this index.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use {@link #addIndexesNoOptimize} instead,then separately call {@link #optimize} afterwards if you need to.")]
public virtual void AddIndexes(
    Directory[] dirs
)
Visual Basic
<ObsoleteAttribute("Use {@link #addIndexesNoOptimize} instead,then separately call {@link #optimize} afterwards if you need to.")> _
Public Overridable Sub AddIndexes ( _
    dirs As Directory() _
)
Visual C++
[ObsoleteAttribute(L"Use {@link #addIndexesNoOptimize} instead,then separately call {@link #optimize} afterwards if you need to.")]
public:
virtual void AddIndexes(
    array<Directory^>^ dirs
)

Parameters

dirs
Type: array< Lucene.Net.Store..::..Directory >[]()[][]

[Missing <param name="dirs"/> documentation for "M:Lucene.Net.Index.IndexWriter.AddIndexes(Lucene.Net.Store.Directory[])"]

See Also

IndexWriter Class
AddIndexes Overload
Lucene.Net.Index Namespace


AddIndexes Method (IndexReader[])

[image]

Lucene.Net Class Libraries
IndexWriter..::..AddIndexes Method (array<IndexReader>[]()[][])
IndexWriter Class See Also Send Feedback
Merges the provided indexes into this index.

After this completes, the index is optimized.

The provided IndexReaders are not closed.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

See {@link #AddIndexesNoOptimize(Directory[])} for details on transactional semantics, temporary free space required in the Directory, and non-CFS segments on an Exception.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddIndexes(
    IndexReader[] readers
)
Visual Basic
Public Overridable Sub AddIndexes ( _
    readers As IndexReader() _
)
Visual C++
public:
virtual void AddIndexes(
    array<IndexReader^>^ readers
)

Parameters

readers
Type: array< Lucene.Net.Index..::..IndexReader >[]()[][]

[Missing <param name="readers"/> documentation for "M:Lucene.Net.Index.IndexWriter.AddIndexes(Lucene.Net.Index.IndexReader[])"]

See Also

IndexWriter Class
AddIndexes Overload
Lucene.Net.Index Namespace


AddIndexesNoOptimize Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..AddIndexesNoOptimize Method
IndexWriter Class See Also Send Feedback
Merges all segments from an array of indexes into this index.

This may be used to parallelize batch indexing. A large document collection can be broken into sub-collections. Each sub-collection can be indexed in parallel, on a different thread, process or machine. The complete index can then be created by merging sub-collection indexes with this method.

NOTE: the index in each Directory must not be changed (opened by a writer) while this method is running. This method does not acquire a write lock in each input Directory, so it is up to the caller to enforce this.

NOTE: while this is running, any attempts to add or delete documents (with another thread) will be paused until this method completes.

This method is transactional in how Exceptions are handled: it does not commit a new segments_N file until all indexes are added. This means if an Exception occurs (for example disk full), then either no indexes will have been added or they all will have been.

Note that this requires temporary free space in the Directory up to 2X the sum of all input indexes (including the starting index). If readers/searchers are open against the starting index, then temporary free space required will be higher by the size of the starting index (see {@link #Optimize()} for details).

Once this completes, the final size of the index will be less than the sum of all input index sizes (including the starting index). It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

This requires this index not be among those to be added.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddIndexesNoOptimize(
    Directory[] dirs
)
Visual Basic
Public Overridable Sub AddIndexesNoOptimize ( _
    dirs As Directory() _
)
Visual C++
public:
virtual void AddIndexesNoOptimize(
    array<Directory^>^ dirs
)

Parameters

dirs
Type: array< Lucene.Net.Store..::..Directory >[]()[][]

[Missing <param name="dirs"/> documentation for "M:Lucene.Net.Index.IndexWriter.AddIndexesNoOptimize(Lucene.Net.Store.Directory[])"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Close Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..Close Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method Close()()()()
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See {@link #Commit()} for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

            try {
            writer.close();
            } finally {
            if (IndexWriter.isLocked(directory)) {
            IndexWriter.unlock(directory);
            }
            }
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Public method Close(Boolean)
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Close Method
IndexWriter Class See Also Send Feedback
Commits all changes to an index and closes all associated files. Note that this may be a costly operation, so, try to re-use a single writer instead of closing and opening a new one. See {@link #Commit()} for caveats about write caching done by some IO devices.

If an Exception is hit during close, eg due to disk full or some other reason, then both the on-disk index and the internal state of the IndexWriter instance will be consistent. However, the close will not be complete even though part of it (flushing buffered documents) may have succeeded, so the write lock will still be held.

If you can correct the underlying cause (eg free up some disk space) then you can call close() again. Failing that, if you want to force the write lock to be released (dangerous, because you may then lose buffered docs in the IndexWriter instance) then you can do something like this:

            try {
            writer.close();
            } finally {
            if (IndexWriter.isLocked(directory)) {
            IndexWriter.unlock(directory);
            }
            }
after which, you must be certain not to use the writer instance anymore.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

See Also

IndexWriter Class
Close Overload
Lucene.Net.Index Namespace


Close Method (Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter..::..Close Method (Boolean)
IndexWriter Class See Also Send Feedback
Closes the index with or without waiting for currently running merges to finish. This is only meaningful when using a MergeScheduler that runs merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer, again. See above for details.

NOTE: it is dangerous to always call close(false), especially when IndexWriter is not open for very long, because this can result in "merge starvation" whereby long merges will never have a chance to finish. This will cause too many segments in your index over time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close(
    bool waitForMerges
)
Visual Basic
Public Overridable Sub Close ( _
    waitForMerges As Boolean _
)
Visual C++
public:
virtual void Close(
    bool waitForMerges
)

Parameters

waitForMerges
Type: System..::..Boolean
if true, this call will block until all merges complete; else, it will ask all running merges to abort, wait until those merges have finished (which should be at most a few seconds), and then return.

See Also

IndexWriter Class
Close Overload
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..Commit Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method Commit()()()()

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls {@link #PrepareCommit(Map)} (if you didn't already call it) and then {@link #finishCommit}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


Commit Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Commit Method
IndexWriter Class See Also Send Feedback

Commits all pending changes (added & deleted documents, optimizations, segment merges, added indexes, etc.) to the index, and syncs all referenced index files, such that a reader will see the changes and the index updates will survive an OS or machine crash or power loss. Note that this does not wait for any running background merges to finish. This may be a costly operation, so you should test the cost in your application and do it only when really necessary.

Note that this operation calls Directory.sync on the index files. That call should not return until the file contents & metadata are on stable storage. For FSDirectory, this calls the OS's fsync. But, beware: some hardware devices may in fact cache writes even during fsync, and return before the bits are actually on stable storage, to give the appearance of faster performance. If you have such a device, and it does not have a battery backup (for example) then on power loss it may still lose data. Lucene cannot guarantee consistency on such devices.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Commit()
Visual Basic
Public Sub Commit
Visual C++
public:
void Commit()

See Also

IndexWriter Class
Commit Overload
Lucene.Net.Index Namespace
[!:prepareCommit]
[!:Commit(Map)]


Commit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
IndexWriter..::..Commit Method (IDictionary<(Of <(<'String, String>)>)>)
IndexWriter Class See Also Send Feedback
Commits all changes to the index, specifying a commitUserData Map (String -> String). This just calls {@link #PrepareCommit(Map)} (if you didn't already call it) and then {@link #finishCommit}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Commit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Public Sub Commit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
public:
void Commit(
    IDictionary<String^, String^>^ commitUserData
)

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.IndexWriter.Commit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

IndexWriter Class
Commit Overload
Lucene.Net.Index Namespace


DeleteAll Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..DeleteAll Method
IndexWriter Class See Also Send Feedback
Delete all documents in the index.

This method will drop all buffered documents and will remove all segments from the index. This change will not be visible until a {@link #Commit()} has been called. This method can be rolled back using {@link #Rollback()}.

NOTE: this method is much faster than using deleteDocuments( new MatchAllDocsQuery() ).

NOTE: this method will forcefully abort all merges in progress. If other threads are running {@link #Optimize()} or any of the addIndexes methods, they will receive {@link MergePolicy.MergeAbortedException}s.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteAll()
Visual Basic
Public Overridable Sub DeleteAll
Visual C++
public:
virtual void DeleteAll()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DeleteDocuments Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..DeleteDocuments Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method DeleteDocuments(Query)
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(array<Query>[]()[][])
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(Term)
Deletes the document(s) containing
CopyC#
term
.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method DeleteDocuments(array<Term>[]()[][])
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


DeleteDocuments Method (Query)

[image]

Lucene.Net Class Libraries
IndexWriter..::..DeleteDocuments Method (Query)
IndexWriter Class See Also Send Feedback
Deletes the document(s) matching the provided query.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteDocuments(
    Query query
)
Visual Basic
Public Overridable Sub DeleteDocuments ( _
    query As Query _
)
Visual C++
public:
virtual void DeleteDocuments(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query
the query to identify the documents to be deleted

See Also

IndexWriter Class
DeleteDocuments Overload
Lucene.Net.Index Namespace


DeleteDocuments Method (Query[])

[image]

Lucene.Net Class Libraries
IndexWriter..::..DeleteDocuments Method (array<Query>[]()[][])
IndexWriter Class See Also Send Feedback
Deletes the document(s) matching any of the provided queries. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteDocuments(
    Query[] queries
)
Visual Basic
Public Overridable Sub DeleteDocuments ( _
    queries As Query() _
)
Visual C++
public:
virtual void DeleteDocuments(
    array<Query^>^ queries
)

Parameters

queries
Type: array< Lucene.Net.Search..::..Query >[]()[][]
array of queries to identify the documents to be deleted

See Also

IndexWriter Class
DeleteDocuments Overload
Lucene.Net.Index Namespace


DeleteDocuments Method (Term)

[image]

Lucene.Net Class Libraries
IndexWriter..::..DeleteDocuments Method (Term)
IndexWriter Class See Also Send Feedback
Deletes the document(s) containing
CopyC#
term
.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteDocuments(
    Term term
)
Visual Basic
Public Overridable Sub DeleteDocuments ( _
    term As Term _
)
Visual C++
public:
virtual void DeleteDocuments(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term
the term to identify the documents to be deleted

See Also

IndexWriter Class
DeleteDocuments Overload
Lucene.Net.Index Namespace


DeleteDocuments Method (Term[])

[image]

Lucene.Net Class Libraries
IndexWriter..::..DeleteDocuments Method (array<Term>[]()[][])
IndexWriter Class See Also Send Feedback
Deletes the document(s) containing any of the terms. All deletes are flushed at the same time.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void DeleteDocuments(
    Term[] terms
)
Visual Basic
Public Overridable Sub DeleteDocuments ( _
    terms As Term() _
)
Visual C++
public:
virtual void DeleteDocuments(
    array<Term^>^ terms
)

Parameters

terms
Type: array< Lucene.Net.Index..::..Term >[]()[][]
array of terms to identify the documents to be deleted

See Also

IndexWriter Class
DeleteDocuments Overload
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Dispose Method
IndexWriter Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DoAfterFlush Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..DoAfterFlush Method
IndexWriter Class See Also Send Feedback
A hook for extending classes to execute operations after pending added and deleted documents have been flushed to the Directory but before the change is committed (new segments_N file written).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected virtual void DoAfterFlush()
Visual Basic
Protected Overridable Sub DoAfterFlush
Visual C++
protected:
virtual void DoAfterFlush()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DoBeforeFlush Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..DoBeforeFlush Method
IndexWriter Class See Also Send Feedback
A hook for extending classes to execute operations before pending added and deleted documents are flushed to the Directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected virtual void DoBeforeFlush()
Visual Basic
Protected Overridable Sub DoBeforeFlush
Visual C++
protected:
virtual void DoBeforeFlush()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


DocCount Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..DocCount Method
IndexWriter Class See Also Send Feedback
Returns the number of documents currently in this index, not counting deletions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use MaxDoc() (same as this method) or NumDocs() (also takes deletions into account), instead. ")]
public virtual int DocCount()
Visual Basic
<ObsoleteAttribute("Please use MaxDoc() (same as this method) or NumDocs() (also takes deletions into account), instead. ")> _
Public Overridable Function DocCount As Integer
Visual C++
[ObsoleteAttribute(L"Please use MaxDoc() (same as this method) or NumDocs() (also takes deletions into account), instead. ")]
public:
virtual int DocCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.DocCount"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


EnsureOpen Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..EnsureOpen Method
IndexWriter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | EnsureOpen()()()() |
Protected method | EnsureOpen(Boolean) | Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


EnsureOpen Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..EnsureOpen Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.EnsureOpen"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal void EnsureOpen()
Visual Basic
Protected Friend Sub EnsureOpen
Visual C++
protected public:
void EnsureOpen()

See Also

IndexWriter Class
EnsureOpen Overload
Lucene.Net.Index Namespace


EnsureOpen Method (Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter..::..EnsureOpen Method (Boolean)
IndexWriter Class See Also Send Feedback
Used internally to throw an {@link AlreadyClosedException} if this IndexWriter has been closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal void EnsureOpen(
    bool includePendingClose
)
Visual Basic
Protected Friend Sub EnsureOpen ( _
    includePendingClose As Boolean _
)
Visual C++
protected public:
void EnsureOpen(
    bool includePendingClose
)

Parameters

includePendingClose
Type: System..::..Boolean

[Missing <param name="includePendingClose"/> documentation for "M:Lucene.Net.Index.IndexWriter.EnsureOpen(System.Boolean)"]

See Also

IndexWriter Class
EnsureOpen Overload
Lucene.Net.Index Namespace


ExpungeDeletes Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..ExpungeDeletes Method
IndexWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExpungeDeletes()()()() | Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #ExpungeDeletes(boolean)} NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | ExpungeDeletes(Boolean) | Just like {@link #ExpungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


ExpungeDeletes Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..ExpungeDeletes Method
IndexWriter Class See Also Send Feedback
Expunges all deletes from the index. When an index has many document deletions (or updates to existing documents), it's best to either call optimize or expungeDeletes to remove all unused data in the index associated with the deleted documents. To see how many deletions you have pending in your index, call {@link IndexReader#numDeletedDocs} This saves disk space and memory usage while searching. expungeDeletes should be somewhat faster than optimize since it does not insist on reducing the index to a single segment (though, this depends on the {@link MergePolicy}; see {@link MergePolicy#findMergesToExpungeDeletes}.). Note that this call does not first commit any buffered documents, so you must do so yourself if necessary. See also {@link #ExpungeDeletes(boolean)}

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ExpungeDeletes()
Visual Basic
Public Overridable Sub ExpungeDeletes
Visual C++
public:
virtual void ExpungeDeletes()

See Also

IndexWriter Class
ExpungeDeletes Overload
Lucene.Net.Index Namespace


ExpungeDeletes Method (Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter..::..ExpungeDeletes Method (Boolean)
IndexWriter Class See Also Send Feedback
Just like {@link #ExpungeDeletes()}, except you can specify whether the call should block until the operation completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ExpungeDeletes(
    bool doWait
)
Visual Basic
Public Overridable Sub ExpungeDeletes ( _
    doWait As Boolean _
)
Visual C++
public:
virtual void ExpungeDeletes(
    bool doWait
)

Parameters

doWait
Type: System..::..Boolean

[Missing <param name="doWait"/> documentation for "M:Lucene.Net.Index.IndexWriter.ExpungeDeletes(System.Boolean)"]

See Also

IndexWriter Class
ExpungeDeletes Overload
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..Flush Method
IndexWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | Obsolete. Flush all in-memory buffered updates (adds and deletes) to the Directory. Note: while this will force buffered docs to be pushed into the index, it will not make these docs visible to a reader. Use {@link #Commit()} instead NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | Flush(Boolean, Boolean, Boolean) | Flush all in-memory buffered udpates (adds and deletes) to the Directory.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


Flush Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Flush Method
IndexWriter Class See Also Send Feedback
Flush all in-memory buffered updates (adds and deletes) to the Directory.

Note: while this will force buffered docs to be pushed into the index, it will not make these docs visible to a reader. Use {@link #Commit()} instead

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("please call Commit() instead")]
public void Flush()
Visual Basic
<ObsoleteAttribute("please call Commit() instead")> _
Public Sub Flush
Visual C++
[ObsoleteAttribute(L"please call Commit() instead")]
public:
void Flush()

See Also

IndexWriter Class
Flush Overload
Lucene.Net.Index Namespace


Flush Method (Boolean, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter..::..Flush Method (Boolean, Boolean, Boolean)
IndexWriter Class See Also Send Feedback
Flush all in-memory buffered udpates (adds and deletes) to the Directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Flush(
    bool triggerMerge,
    bool flushDocStores,
    bool flushDeletes
)
Visual Basic
Public Sub Flush ( _
    triggerMerge As Boolean, _
    flushDocStores As Boolean, _
    flushDeletes As Boolean _
)
Visual C++
public:
void Flush(
    bool triggerMerge,
    bool flushDocStores,
    bool flushDeletes
)

Parameters

triggerMerge
Type: System..::..Boolean
if true, we may merge segments (if deletes or docs were flushed) if necessary
flushDocStores
Type: System..::..Boolean
if false we are allowed to keep doc stores open to share with the next segment
flushDeletes
Type: System..::..Boolean
whether pending deletes should also be flushed

See Also

IndexWriter Class
Flush Overload
Lucene.Net.Index Namespace


GetAnalyzer Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetAnalyzer Method
IndexWriter Class See Also Send Feedback
Returns the analyzer used by this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Analyzer GetAnalyzer()
Visual Basic
Public Overridable Function GetAnalyzer As Analyzer
Visual C++
public:
virtual Analyzer^ GetAnalyzer()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetAnalyzer"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetBufferedDeleteTermsSize Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetBufferedDeleteTermsSize Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetBufferedDeleteTermsSize"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetBufferedDeleteTermsSize()
Visual Basic
Public Function GetBufferedDeleteTermsSize As Integer
Visual C++
public:
int GetBufferedDeleteTermsSize()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetBufferedDeleteTermsSize"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetDefaultInfoStream Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetDefaultInfoStream Method
IndexWriter Class See Also Send Feedback
Returns the current default infoStream for newly instantiated IndexWriters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static StreamWriter GetDefaultInfoStream()
Visual Basic
Public Shared Function GetDefaultInfoStream As StreamWriter
Visual C++
public:
static StreamWriter^ GetDefaultInfoStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetDefaultInfoStream"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setDefaultInfoStream]


GetDefaultWriteLockTimeout Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetDefaultWriteLockTimeout Method
IndexWriter Class See Also Send Feedback
Returns default write lock timeout for newly instantiated IndexWriters.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GetDefaultWriteLockTimeout()
Visual Basic
Public Shared Function GetDefaultWriteLockTimeout As Long
Visual C++
public:
static long long GetDefaultWriteLockTimeout()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetDefaultWriteLockTimeout"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setDefaultWriteLockTimeout]


GetDirectory Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetDirectory Method
IndexWriter Class See Also Send Feedback
Returns the Directory used by this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Directory GetDirectory()
Visual Basic
Public Overridable Function GetDirectory As Directory
Visual C++
public:
virtual Directory^ GetDirectory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetDirectory"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetDocCount Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetDocCount Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetDocCount(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetDocCount(
    int i
)
Visual Basic
Public Function GetDocCount ( _
    i As Integer _
) As Integer
Visual C++
public:
int GetDocCount(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Index.IndexWriter.GetDocCount(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetDocCount(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetFlushCount Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetFlushCount Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetFlushCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetFlushCount()
Visual Basic
Public Function GetFlushCount As Integer
Visual C++
public:
int GetFlushCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetFlushCount"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetFlushDeletesCount Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetFlushDeletesCount Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetFlushDeletesCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetFlushDeletesCount()
Visual Basic
Public Function GetFlushDeletesCount As Integer
Visual C++
public:
int GetFlushDeletesCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetFlushDeletesCount"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetInfoStream Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetInfoStream Method
IndexWriter Class See Also Send Feedback
Returns the current infoStream in use by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual StreamWriter GetInfoStream()
Visual Basic
Public Overridable Function GetInfoStream As StreamWriter
Visual C++
public:
virtual StreamWriter^ GetInfoStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetInfoStream"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setInfoStream]


GetMaxBufferedDeleteTerms Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMaxBufferedDeleteTerms Method
IndexWriter Class See Also Send Feedback
Returns the number of buffered deleted terms that will trigger a flush if enabled.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxBufferedDeleteTerms()
Visual Basic
Public Overridable Function GetMaxBufferedDeleteTerms As Integer
Visual C++
public:
virtual int GetMaxBufferedDeleteTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMaxBufferedDeleteTerms"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMaxBufferedDeleteTerms]


GetMaxBufferedDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMaxBufferedDocs Method
IndexWriter Class See Also Send Feedback
Returns the number of buffered added documents that will trigger a flush if enabled.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxBufferedDocs()
Visual Basic
Public Overridable Function GetMaxBufferedDocs As Integer
Visual C++
public:
virtual int GetMaxBufferedDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMaxBufferedDocs"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMaxBufferedDocs]


GetMaxFieldLength Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMaxFieldLength Method
IndexWriter Class See Also Send Feedback
Returns the maximum number of terms that will be indexed for a single field in a document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxFieldLength()
Visual Basic
Public Overridable Function GetMaxFieldLength As Integer
Visual C++
public:
virtual int GetMaxFieldLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMaxFieldLength"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMaxFieldLength]


GetMaxMergeDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMaxMergeDocs Method
IndexWriter Class See Also Send Feedback

Returns the largest segment (measured by document count) that may be merged with other segments.

Note that this method is a convenience method: it just calls mergePolicy.getMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxMergeDocs()
Visual Basic
Public Overridable Function GetMaxMergeDocs As Integer
Visual C++
public:
virtual int GetMaxMergeDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMaxMergeDocs"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMaxMergeDocs]


GetMaxSyncPauseSeconds Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMaxSyncPauseSeconds Method
IndexWriter Class See Also Send Feedback
Expert: returns max delay inserted before syncing a commit point. On Windows, at least, pausing before syncing can increase net indexing throughput. The delay is variable based on size of the segment's files, and is only inserted when using ConcurrentMergeScheduler for merges.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.")]
public virtual double GetMaxSyncPauseSeconds()
Visual Basic
<ObsoleteAttribute("This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.")> _
Public Overridable Function GetMaxSyncPauseSeconds As Double
Visual C++
[ObsoleteAttribute(L"This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.")]
public:
virtual double GetMaxSyncPauseSeconds()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMaxSyncPauseSeconds"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetMergedSegmentWarmer Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMergedSegmentWarmer Method
IndexWriter Class See Also Send Feedback
Returns the current merged segment warmer. See {@link IndexReaderWarmer}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexWriter..::..IndexReaderWarmer GetMergedSegmentWarmer()
Visual Basic
Public Overridable Function GetMergedSegmentWarmer As IndexWriter..::..IndexReaderWarmer
Visual C++
public:
virtual IndexWriter..::..IndexReaderWarmer^ GetMergedSegmentWarmer()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMergedSegmentWarmer"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetMergeFactor Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMergeFactor Method
IndexWriter Class See Also Send Feedback

Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Note that this method is a convenience method: it just calls mergePolicy.getMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMergeFactor()
Visual Basic
Public Overridable Function GetMergeFactor As Integer
Visual C++
public:
virtual int GetMergeFactor()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMergeFactor"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMergeFactor]


GetMergePolicy Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMergePolicy Method
IndexWriter Class See Also Send Feedback
Expert: returns the current MergePolicy in use by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual MergePolicy GetMergePolicy()
Visual Basic
Public Overridable Function GetMergePolicy As MergePolicy
Visual C++
public:
virtual MergePolicy^ GetMergePolicy()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMergePolicy"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMergePolicy]


GetMergeScheduler Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetMergeScheduler Method
IndexWriter Class See Also Send Feedback
Expert: returns the current MergePolicy in use by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual MergeScheduler GetMergeScheduler()
Visual Basic
Public Overridable Function GetMergeScheduler As MergeScheduler
Visual C++
public:
virtual MergeScheduler^ GetMergeScheduler()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetMergeScheduler"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setMergePolicy]


GetNextMerge_forNUnit Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetNextMerge_forNUnit Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetNextMerge_forNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual MergePolicy..::..OneMerge GetNextMerge_forNUnit()
Visual Basic
Public Overridable Function GetNextMerge_forNUnit As MergePolicy..::..OneMerge
Visual C++
public:
virtual MergePolicy..::..OneMerge^ GetNextMerge_forNUnit()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetNextMerge_forNUnit"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetNumBufferedDeleteTerms Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetNumBufferedDeleteTerms Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetNumBufferedDeleteTerms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetNumBufferedDeleteTerms()
Visual Basic
Public Function GetNumBufferedDeleteTerms As Integer
Visual C++
public:
int GetNumBufferedDeleteTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetNumBufferedDeleteTerms"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetNumBufferedDocuments Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetNumBufferedDocuments Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetNumBufferedDocuments"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetNumBufferedDocuments()
Visual Basic
Public Function GetNumBufferedDocuments As Integer
Visual C++
public:
int GetNumBufferedDocuments()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetNumBufferedDocuments"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetRAMBufferSizeMB Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetRAMBufferSizeMB Method
IndexWriter Class See Also Send Feedback
Returns the value set by {@link #setRAMBufferSizeMB} if enabled.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual double GetRAMBufferSizeMB()
Visual Basic
Public Overridable Function GetRAMBufferSizeMB As Double
Visual C++
public:
virtual double GetRAMBufferSizeMB()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetRAMBufferSizeMB"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetReader Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..GetReader Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method GetReader()()()()
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling {@link #commit}.

Note that this is functionally equivalent to calling {#commit} and then using {@link IndexReader#open} to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly {@link #commit}.

You must close the {@link IndexReader} returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports {@link IndexReader#reopen}, but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call {@link #setMergedSegmentWarmer} to call {@link #setMergedSegmentWarmer} to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an {@link AlreadyClosedException}.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public method GetReader(Int32)
Expert: like {@link #getReader}, except you can specify which termInfosIndexDivisor should be used for any newly opened readers.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


GetReader Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetReader Method
IndexWriter Class See Also Send Feedback
Expert: returns a readonly reader, covering all committed as well as un-committed changes to the index. This provides "near real-time" searching, in that changes made during an IndexWriter session can be quickly made available for searching without closing the writer nor calling {@link #commit}.

Note that this is functionally equivalent to calling {#commit} and then using {@link IndexReader#open} to open a new reader. But the turarnound time of this method should be faster since it avoids the potentially costly {@link #commit}.

You must close the {@link IndexReader} returned by this method once you are done using it.

It's near real-time because there is no hard guarantee on how quickly you can get a new reader after making changes with IndexWriter. You'll have to experiment in your situation to determine if it's faster enough. As this is a new and experimental feature, please report back on your findings so we can learn, improve and iterate.

The resulting reader suppports {@link IndexReader#reopen}, but that call will simply forward back to this method (though this may change in the future).

The very first time this method is called, this writer instance will make every effort to pool the readers that it opens for doing merges, applying deletes, etc. This means additional resources (RAM, file descriptors, CPU time) will be consumed.

For lower latency on reopening a reader, you should call {@link #setMergedSegmentWarmer} to call {@link #setMergedSegmentWarmer} to pre-warm a newly merged segment before it's committed to the index. This is important for minimizing index-to-search delay after a large merge.

If an addIndexes* call is running in another thread, then this reader will only search those segments from the foreign index that have been successfully copied over, so far

.

NOTE: Once the writer is closed, any outstanding readers may continue to be used. However, if you attempt to reopen any of those readers, you'll hit an {@link AlreadyClosedException}.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader GetReader()
Visual Basic
Public Overridable Function GetReader As IndexReader
Visual C++
public:
virtual IndexReader^ GetReader()

Return Value

IndexReader that covers entire index plus all changes made so far by this IndexWriter instance

See Also

IndexWriter Class
GetReader Overload
Lucene.Net.Index Namespace


GetReader Method (Int32)

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetReader Method (Int32)
IndexWriter Class See Also Send Feedback
Expert: like {@link #getReader}, except you can specify which termInfosIndexDivisor should be used for any newly opened readers.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader GetReader(
    int termInfosIndexDivisor
)
Visual Basic
Public Overridable Function GetReader ( _
    termInfosIndexDivisor As Integer _
) As IndexReader
Visual C++
public:
virtual IndexReader^ GetReader(
    int termInfosIndexDivisor
)

Parameters

termInfosIndexDivisor
Type: System..::..Int32
Subsambles which indexed terms are loaded into RAM. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1. Set this to -1 to skip loading the terms index entirely.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetReader(System.Int32)"]

See Also

IndexWriter Class
GetReader Overload
Lucene.Net.Index Namespace


GetReaderTermsIndexDivisor Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetReaderTermsIndexDivisor Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetReaderTermsIndexDivisor"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetReaderTermsIndexDivisor()
Visual Basic
Public Function GetReaderTermsIndexDivisor As Integer
Visual C++
public:
int GetReaderTermsIndexDivisor()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetReaderTermsIndexDivisor"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetSegmentCount Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetSegmentCount Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.GetSegmentCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetSegmentCount()
Visual Basic
Public Function GetSegmentCount As Integer
Visual C++
public:
int GetSegmentCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetSegmentCount"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetSimilarity Method
IndexWriter Class See Also Send Feedback
Expert: Return the Similarity implementation used by this IndexWriter.

This defaults to the current value of {@link Similarity#GetDefault()}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Similarity GetSimilarity()
Visual Basic
Public Overridable Function GetSimilarity As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetSimilarity"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


GetTermIndexInterval Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetTermIndexInterval Method
IndexWriter Class See Also Send Feedback
Expert: Return the interval between indexed terms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTermIndexInterval()
Visual Basic
Public Overridable Function GetTermIndexInterval As Integer
Visual C++
public:
virtual int GetTermIndexInterval()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetTermIndexInterval"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
IndexWriter..::..SetTermIndexInterval(Int32)


GetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetUseCompoundFile Method
IndexWriter Class See Also Send Feedback

Get the current setting of whether newly flushed segments will use the compound file format. Note that this just returns the value previously set with setUseCompoundFile(boolean), or the default value (true). You cannot use this to query the status of previously flushed segments.

Note that this method is a convenience method: it just calls mergePolicy.getUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetUseCompoundFile()
Visual Basic
Public Overridable Function GetUseCompoundFile As Boolean
Visual C++
public:
virtual bool GetUseCompoundFile()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetUseCompoundFile"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:SetUseCompoundFile(boolean)]


GetWriteLockTimeout Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..GetWriteLockTimeout Method
IndexWriter Class See Also Send Feedback
Returns allowed timeout when acquiring the write lock.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetWriteLockTimeout()
Visual Basic
Public Overridable Function GetWriteLockTimeout As Long
Visual C++
public:
virtual long long GetWriteLockTimeout()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.GetWriteLockTimeout"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setWriteLockTimeout]


HasDeletions Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..HasDeletions Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool HasDeletions()
Visual Basic
Public Overridable Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.HasDeletions"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


IsLocked Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..IsLocked Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
IsLocked(String) Obsolete.
Returns
CopyC#
true
 iff the index in the named directory is currently locked.
IsLocked(Directory)
Returns
CopyC#
true
 iff the index in the named directory is currently locked.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


IsLocked Method (String)

[image]

Lucene.Net Class Libraries
IndexWriter..::..IsLocked Method (String)
IndexWriter Class See Also Send Feedback
Returns
CopyC#
true
 iff the index in the named directory is currently locked.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IsLocked(Directory)")]
public static bool IsLocked(
    string directory
)
Visual Basic
<ObsoleteAttribute("Use IsLocked(Directory)")> _
Public Shared Function IsLocked ( _
    directory As String _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IsLocked(Directory)")]
public:
static bool IsLocked(
    String^ directory
)

Parameters

directory
Type: System..::..String
the directory to check for a lock

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.IsLocked(System.String)"]

See Also

IndexWriter Class
IsLocked Overload
Lucene.Net.Index Namespace


IsLocked Method (Directory)

[image]

Lucene.Net Class Libraries
IndexWriter..::..IsLocked Method (Directory)
IndexWriter Class See Also Send Feedback
Returns
CopyC#
true
 iff the index in the named directory is currently locked.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool IsLocked(
    Directory directory
)
Visual Basic
Public Shared Function IsLocked ( _
    directory As Directory _
) As Boolean
Visual C++
public:
static bool IsLocked(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
the directory to check for a lock

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.IsLocked(Lucene.Net.Store.Directory)"]

See Also

IndexWriter Class
IsLocked Overload
Lucene.Net.Index Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxDoc Method
IndexWriter Class See Also Send Feedback
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), not counting deletions.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int MaxDoc()
Visual Basic
Public Overridable Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.MaxDoc"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:numDocs]


MaybeMerge Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaybeMerge Method
IndexWriter Class See Also Send Feedback
Expert: asks the mergePolicy whether any merges are necessary now and if so, runs the requested merges and then iterate (test again if merges are needed) until no more merges are returned by the mergePolicy. Explicit calls to maybeMerge() are usually not necessary. The most common case is when merge policy parameters have changed.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void MaybeMerge()
Visual Basic
Public Sub MaybeMerge
Visual C++
public:
void MaybeMerge()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Merge_ForNUnit Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Merge_ForNUnit Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.Merge_ForNUnit(Lucene.Net.Index.MergePolicy.OneMerge)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Merge_ForNUnit(
    MergePolicy..::..OneMerge merge
)
Visual Basic
Public Sub Merge_ForNUnit ( _
    merge As MergePolicy..::..OneMerge _
)
Visual C++
public:
void Merge_ForNUnit(
    MergePolicy..::..OneMerge^ merge
)

Parameters

merge
Type: Lucene.Net.Index..::..MergePolicy..::..OneMerge

[Missing <param name="merge"/> documentation for "M:Lucene.Net.Index.IndexWriter.Merge_ForNUnit(Lucene.Net.Index.MergePolicy.OneMerge)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Message Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Message Method
IndexWriter Class See Also Send Feedback
Prints a message to the infoStream (if non-null), prefixed with the identifying information for this writer and the thread that's calling it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Message(
    string message
)
Visual Basic
Public Overridable Sub Message ( _
    message As String _
)
Visual C++
public:
virtual void Message(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.IndexWriter.Message(System.String)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


NewestSegment Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..NewestSegment Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.NewestSegment"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SegmentInfo NewestSegment()
Visual Basic
Public Overridable Function NewestSegment As SegmentInfo
Visual C++
public:
virtual SegmentInfo^ NewestSegment()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.NewestSegment"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


NumDeletedDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..NumDeletedDocs Method
IndexWriter Class See Also Send Feedback
Obtain the number of deleted docs for a pooled reader. If the reader isn't being pooled, the segmentInfo's delCount is returned.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int NumDeletedDocs(
    SegmentInfo info
)
Visual Basic
Public Overridable Function NumDeletedDocs ( _
    info As SegmentInfo _
) As Integer
Visual C++
public:
virtual int NumDeletedDocs(
    SegmentInfo^ info
)

Parameters

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.IndexWriter.NumDeletedDocs(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.NumDeletedDocs(Lucene.Net.Index.SegmentInfo)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..NumDocs Method
IndexWriter Class See Also Send Feedback
Returns total number of docs in this index, including docs not yet flushed (still in the RAM buffer), and including deletions. NOTE: buffered deletions are not counted. If you really need these to be counted you should call {@link #Commit()} first.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int NumDocs()
Visual Basic
Public Overridable Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.NumDocs"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:numDocs]


NumRamDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..NumRamDocs Method
IndexWriter Class See Also Send Feedback
Expert: Return the number of documents currently buffered in RAM.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int NumRamDocs()
Visual Basic
Public Function NumRamDocs As Integer
Visual C++
public:
int NumRamDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.NumRamDocs"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Optimize Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..Optimize Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method Optimize()()()()
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Boolean)
Just like {@link #Optimize()}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32)
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as {@link #Optimize()}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method Optimize(Int32, Boolean)
Just like {@link #Optimize(int)}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


Optimize Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Optimize Method
IndexWriter Class See Also Send Feedback
Requests an "optimize" operation on an index, priming the index for the fastest available search. Traditionally this has meant merging all segments into a single segment as is done in the default merge policy, but individaul merge policies may implement optimize in different ways.

It is recommended that this method be called upon completion of indexing. In environments with frequent updates, optimize is best done during low volume times, if at all.

See http://www.gossamer-threads.com/lists/lucene/java-dev/47895 for more discussion.

Note that optimize requires 2X the index size free space in your Directory (3X if you're using compound file format). For example, if your index size is 10 MB then you need 20 MB free for optimize to complete (30 MB if you're using compound fiel format).

If some but not all readers re-open while an optimize is underway, this will cause > 2X temporary space to be consumed as those new readers will then hold open the partially optimized segments at that time. It is best not to re-open readers while optimize is running.

The actual temporary usage could be much less than these figures (it depends on many factors).

In general, once the optimize completes, the total size of the index will be less than the size of the starting index. It could be quite a bit smaller (if there were many pending deletes) or just slightly smaller.

If an Exception is hit during optimize(), for example due to disk full, the index will not be corrupt and no documents will have been lost. However, it may have been partially optimized (some segments were merged but not all), and it's possible that one of the segments in the index will be in non-compound format even when using compound file format. This will occur when the Exception is hit during conversion of the segment into compound format.

This call will optimize those segments present in the index when the call started. If other threads are still adding documents and flushing segments, those newly created segments will not be optimized unless you call optimize again.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Optimize()
Visual Basic
Public Overridable Sub Optimize
Visual C++
public:
virtual void Optimize()

See Also

IndexWriter Class
Optimize Overload
Lucene.Net.Index Namespace
[!:LogMergePolicy.findMergesForOptimize]


Optimize Method (Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter..::..Optimize Method (Boolean)
IndexWriter Class See Also Send Feedback
Just like {@link #Optimize()}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Optimize(
    bool doWait
)
Visual Basic
Public Overridable Sub Optimize ( _
    doWait As Boolean _
)
Visual C++
public:
virtual void Optimize(
    bool doWait
)

Parameters

doWait
Type: System..::..Boolean

[Missing <param name="doWait"/> documentation for "M:Lucene.Net.Index.IndexWriter.Optimize(System.Boolean)"]

See Also

IndexWriter Class
Optimize Overload
Lucene.Net.Index Namespace


Optimize Method (Int32)

[image]

Lucene.Net Class Libraries
IndexWriter..::..Optimize Method (Int32)
IndexWriter Class See Also Send Feedback
Optimize the index down to <= maxNumSegments. If maxNumSegments==1 then this is the same as {@link #Optimize()}.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Optimize(
    int maxNumSegments
)
Visual Basic
Public Overridable Sub Optimize ( _
    maxNumSegments As Integer _
)
Visual C++
public:
virtual void Optimize(
    int maxNumSegments
)

Parameters

maxNumSegments
Type: System..::..Int32
maximum number of segments left in the index after optimization finishes

See Also

IndexWriter Class
Optimize Overload
Lucene.Net.Index Namespace


Optimize Method (Int32, Boolean)

[image]

Lucene.Net Class Libraries
IndexWriter..::..Optimize Method (Int32, Boolean)
IndexWriter Class See Also Send Feedback
Just like {@link #Optimize(int)}, except you can specify whether the call should block until the optimize completes. This is only meaningful with a {@link MergeScheduler} that is able to run merges in background threads.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Optimize(
    int maxNumSegments,
    bool doWait
)
Visual Basic
Public Overridable Sub Optimize ( _
    maxNumSegments As Integer, _
    doWait As Boolean _
)
Visual C++
public:
virtual void Optimize(
    int maxNumSegments,
    bool doWait
)

Parameters

maxNumSegments
Type: System..::..Int32

[Missing <param name="maxNumSegments"/> documentation for "M:Lucene.Net.Index.IndexWriter.Optimize(System.Int32,System.Boolean)"]

doWait
Type: System..::..Boolean

[Missing <param name="doWait"/> documentation for "M:Lucene.Net.Index.IndexWriter.Optimize(System.Int32,System.Boolean)"]

See Also

IndexWriter Class
Optimize Overload
Lucene.Net.Index Namespace


PrepareCommit Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..PrepareCommit Method
IndexWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrepareCommit()()()() | Expert: prepare for commit. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.
Public method | PrepareCommit(IDictionary<(Of <<'(String, String>)>>)) | Expert: prepare for commit, specifying commitUserData Map (String -> String). This does the first phase of 2-phase commit. You can only call this when autoCommit is false. This method does all steps necessary to commit changes since this writer was opened: flushes pending added and deleted docs, syncs the index files, writes most of next segments_N file. After calling this you must call either {@link #Commit()} to finish the commit, or {@link #Rollback()} to revert the commit and undo all changes done since the writer was opened. You can also just call {@link #Commit(Map)} directly without prepareCommit first in which case that method will internally call prepareCommit. NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


PrepareCommit Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..PrepareCommit Method
IndexWriter Class See Also Send Feedback
Expert: prepare for commit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void PrepareCommit()
Visual Basic
Public Sub PrepareCommit
Visual C++
public:
void PrepareCommit()

See Also

IndexWriter Class
PrepareCommit Overload
Lucene.Net.Index Namespace
[!:PrepareCommit(Map)]


PrepareCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
IndexWriter..::..PrepareCommit Method (IDictionary<(Of <(<'String, String>)>)>)
IndexWriter Class See Also Send Feedback

Expert: prepare for commit, specifying commitUserData Map (String -> String). This does the first phase of 2-phase commit. You can only call this when autoCommit is false. This method does all steps necessary to commit changes since this writer was opened: flushes pending added and deleted docs, syncs the index files, writes most of next segments_N file. After calling this you must call either {@link #Commit()} to finish the commit, or {@link #Rollback()} to revert the commit and undo all changes done since the writer was opened.

You can also just call {@link #Commit(Map)} directly without prepareCommit first in which case that method will internally call prepareCommit.

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void PrepareCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Public Sub PrepareCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
public:
void PrepareCommit(
    IDictionary<String^, String^>^ commitUserData
)

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
Opaque Map (String->String) that's recorded into the segments file in the index, and retrievable by {@link IndexReader#getCommitUserData}. Note that when IndexWriter commits itself, for example if open with autoCommit=true, or, during {@link #close}, the commitUserData is unchanged (just carried over from the prior commit). If this is null then the previous commitUserData is kept. Also, the commitUserData will only "stick" if there are actually changes in the index to commit. Therefore it's best to use this feature only when autoCommit is false.

See Also

IndexWriter Class
PrepareCommit Overload
Lucene.Net.Index Namespace


RamSizeInBytes Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..RamSizeInBytes Method
IndexWriter Class See Also Send Feedback
Expert: Return the total size of all index files currently cached in memory. Useful for size management with flushRamDocs()

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long RamSizeInBytes()
Visual Basic
Public Function RamSizeInBytes As Long
Visual C++
public:
long long RamSizeInBytes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.RamSizeInBytes"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Rollback Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Rollback Method
IndexWriter Class See Also Send Feedback
Close the
CopyC#
IndexWriter
 without committing any changes that have occurred since the last commit (or since it was opened, if commit hasn't been called). This removes any temporary files that had been created, after which the state of the index will be the same as it was when commit() was last called or when this writer was first opened. This can only be called when this IndexWriter was opened with
CopyC#
autoCommit=false
. This also clears a previous call to {@link #prepareCommit}.
the writer was opened with
CopyC#
autoCommit=true
.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Rollback()
Visual Basic
Public Overridable Sub Rollback
Visual C++
public:
virtual void Rollback()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SegString Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SegString Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.SegString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string SegString()
Visual Basic
Public Overridable Function SegString As String
Visual C++
public:
virtual String^ SegString()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.SegString"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetAllowMinus1Position Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetAllowMinus1Position Method
IndexWriter Class See Also Send Feedback
Deprecated: emulates IndexWriter's buggy behavior when first token(s) have positionIncrement==0 (ie, prior to fixing LUCENE-1542)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetAllowMinus1Position()
Visual Basic
Public Overridable Sub SetAllowMinus1Position
Visual C++
public:
virtual void SetAllowMinus1Position()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetDefaultInfoStream Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetDefaultInfoStream Method
IndexWriter Class See Also Send Feedback
If non-null, this will be the default infoStream used by a newly instantiated IndexWriter.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetDefaultInfoStream(
    StreamWriter infoStream
)
Visual Basic
Public Shared Sub SetDefaultInfoStream ( _
    infoStream As StreamWriter _
)
Visual C++
public:
static void SetDefaultInfoStream(
    StreamWriter^ infoStream
)

Parameters

infoStream
Type: System.IO..::..StreamWriter

[Missing <param name="infoStream"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetDefaultInfoStream(System.IO.StreamWriter)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setInfoStream]


SetDefaultWriteLockTimeout Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetDefaultWriteLockTimeout Method
IndexWriter Class See Also Send Feedback
Sets the default (for any instance of IndexWriter) maximum time to wait for a write lock (in milliseconds).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetDefaultWriteLockTimeout(
    long writeLockTimeout
)
Visual Basic
Public Shared Sub SetDefaultWriteLockTimeout ( _
    writeLockTimeout As Long _
)
Visual C++
public:
static void SetDefaultWriteLockTimeout(
    long long writeLockTimeout
)

Parameters

writeLockTimeout
Type: System..::..Int64

[Missing <param name="writeLockTimeout"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetDefaultWriteLockTimeout(System.Int64)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetInfoStream Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetInfoStream Method
IndexWriter Class See Also Send Feedback
If non-null, information about merges, deletes and a message when maxFieldLength is reached will be printed to this.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetInfoStream(
    StreamWriter infoStream
)
Visual Basic
Public Overridable Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
Visual C++
public:
virtual void SetInfoStream(
    StreamWriter^ infoStream
)

Parameters

infoStream
Type: System.IO..::..StreamWriter

[Missing <param name="infoStream"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetInfoStream(System.IO.StreamWriter)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetMaxBufferedDeleteTerms Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMaxBufferedDeleteTerms Method
IndexWriter Class See Also Send Feedback

Determines the minimal number of delete terms required before the buffered in-memory delete terms are applied and flushed. If there are documents buffered in memory at the time, they are merged and a new segment is created.

Disabled by default (writer flushes by RAM usage).

is enabled but smaller than 1

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxBufferedDeleteTerms(
    int maxBufferedDeleteTerms
)
Visual Basic
Public Overridable Sub SetMaxBufferedDeleteTerms ( _
    maxBufferedDeleteTerms As Integer _
)
Visual C++
public:
virtual void SetMaxBufferedDeleteTerms(
    int maxBufferedDeleteTerms
)

Parameters

maxBufferedDeleteTerms
Type: System..::..Int32

[Missing <param name="maxBufferedDeleteTerms"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMaxBufferedDeleteTerms(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setRAMBufferSizeMB]


SetMaxBufferedDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMaxBufferedDocs Method
IndexWriter Class See Also Send Feedback
Determines the minimal number of documents required before the buffered in-memory documents are flushed as a new Segment. Large values generally gives faster indexing.

When this is set, the writer will flush every maxBufferedDocs added documents. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to number of buffered documents. Note that if flushing by RAM usage is also enabled, then the flush will be triggered by whichever comes first.

Disabled by default (writer flushes by RAM usage).

enabled but smaller than 2, or it disables maxBufferedDocs when ramBufferSize is already disabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)
Visual Basic
Public Overridable Sub SetMaxBufferedDocs ( _
    maxBufferedDocs As Integer _
)
Visual C++
public:
virtual void SetMaxBufferedDocs(
    int maxBufferedDocs
)

Parameters

maxBufferedDocs
Type: System..::..Int32

[Missing <param name="maxBufferedDocs"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMaxBufferedDocs(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:setRAMBufferSizeMB]


SetMaxFieldLength Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMaxFieldLength Method
IndexWriter Class See Also Send Feedback
The maximum number of terms that will be indexed for a single field in a document. This limits the amount of memory required for indexing, so that collections with very large files will not crash the indexing process by running out of memory. This setting refers to the number of running terms, not to the number of different terms.

Note: this silently truncates large documents, excluding from the index all terms that occur further in the document. If you know your source documents are large, be sure to set this value high enough to accomodate the expected size. If you set it to Integer.MAX_VALUE, then the only limit is your memory, but you should anticipate an OutOfMemoryError.

By default, no more than {@link #DEFAULT_MAX_FIELD_LENGTH} terms will be indexed for a field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxFieldLength(
    int maxFieldLength
)
Visual Basic
Public Overridable Sub SetMaxFieldLength ( _
    maxFieldLength As Integer _
)
Visual C++
public:
virtual void SetMaxFieldLength(
    int maxFieldLength
)

Parameters

maxFieldLength
Type: System..::..Int32

[Missing <param name="maxFieldLength"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMaxFieldLength(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetMaxMergeDocs Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMaxMergeDocs Method
IndexWriter Class See Also Send Feedback

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is {@link Integer#MAX_VALUE}.

Note that this method is a convenience method: it just calls mergePolicy.setMaxMergeDocs as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxMergeDocs(
    int maxMergeDocs
)
Visual Basic
Public Overridable Sub SetMaxMergeDocs ( _
    maxMergeDocs As Integer _
)
Visual C++
public:
virtual void SetMaxMergeDocs(
    int maxMergeDocs
)

Parameters

maxMergeDocs
Type: System..::..Int32

[Missing <param name="maxMergeDocs"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMaxMergeDocs(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetMaxSyncPauseSeconds Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMaxSyncPauseSeconds Method
IndexWriter Class See Also Send Feedback
Expert: sets the max delay before syncing a commit point.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.")]
public virtual void SetMaxSyncPauseSeconds(
    double seconds
)
Visual Basic
<ObsoleteAttribute("This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.")> _
Public Overridable Sub SetMaxSyncPauseSeconds ( _
    seconds As Double _
)
Visual C++
[ObsoleteAttribute(L"This will be removed in 3.0, when autoCommit=true is removed from IndexWriter.")]
public:
virtual void SetMaxSyncPauseSeconds(
    double seconds
)

Parameters

seconds
Type: System..::..Double

[Missing <param name="seconds"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMaxSyncPauseSeconds(System.Double)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
[!:getMaxSyncPauseSeconds]


SetMergedSegmentWarmer Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMergedSegmentWarmer Method
IndexWriter Class See Also Send Feedback
Set the merged segment warmer. See {@link IndexReaderWarmer}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergedSegmentWarmer(
    IndexWriter..::..IndexReaderWarmer warmer
)
Visual Basic
Public Overridable Sub SetMergedSegmentWarmer ( _
    warmer As IndexWriter..::..IndexReaderWarmer _
)
Visual C++
public:
virtual void SetMergedSegmentWarmer(
    IndexWriter..::..IndexReaderWarmer^ warmer
)

Parameters

warmer
Type: Lucene.Net.Index..::..IndexWriter..::..IndexReaderWarmer

[Missing <param name="warmer"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMergedSegmentWarmer(Lucene.Net.Index.IndexWriter.IndexReaderWarmer)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetMergeFactor Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMergeFactor Method
IndexWriter Class See Also Send Feedback
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Note that this method is a convenience method: it just calls mergePolicy.setMergeFactor as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

This must never be less than 2. The default value is 10.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergeFactor(
    int mergeFactor
)
Visual Basic
Public Overridable Sub SetMergeFactor ( _
    mergeFactor As Integer _
)
Visual C++
public:
virtual void SetMergeFactor(
    int mergeFactor
)

Parameters

mergeFactor
Type: System..::..Int32

[Missing <param name="mergeFactor"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMergeFactor(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetMergePolicy Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMergePolicy Method
IndexWriter Class See Also Send Feedback
Expert: set the merge policy used by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergePolicy(
    MergePolicy mp
)
Visual Basic
Public Overridable Sub SetMergePolicy ( _
    mp As MergePolicy _
)
Visual C++
public:
virtual void SetMergePolicy(
    MergePolicy^ mp
)

Parameters

mp
Type: Lucene.Net.Index..::..MergePolicy

[Missing <param name="mp"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMergePolicy(Lucene.Net.Index.MergePolicy)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetMergeScheduler Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetMergeScheduler Method
IndexWriter Class See Also Send Feedback
Expert: set the merge scheduler used by this writer.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergeScheduler(
    MergeScheduler mergeScheduler
)
Visual Basic
Public Overridable Sub SetMergeScheduler ( _
    mergeScheduler As MergeScheduler _
)
Visual C++
public:
virtual void SetMergeScheduler(
    MergeScheduler^ mergeScheduler
)

Parameters

mergeScheduler
Type: Lucene.Net.Index..::..MergeScheduler

[Missing <param name="mergeScheduler"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetMergeScheduler(Lucene.Net.Index.MergeScheduler)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetRAMBufferSizeMB Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetRAMBufferSizeMB Method
IndexWriter Class See Also Send Feedback
Determines the amount of RAM that may be used for buffering added documents and deletions before they are flushed to the Directory. Generally for faster indexing performance it's best to flush by RAM usage instead of document count and use as large a RAM buffer as you can.

When this is set, the writer will flush whenever buffered documents and deletions use this much RAM. Pass in {@link #DISABLE_AUTO_FLUSH} to prevent triggering a flush due to RAM usage. Note that if flushing by document count is also enabled, then the flush will be triggered by whichever comes first.

NOTE: the account of RAM usage for pending deletions is only approximate. Specifically, if you delete by Query, Lucene currently has no way to measure the RAM usage if individual Queries so the accounting will under-estimate and you should compensate by either calling commit() periodically yourself, or by using {@link #setMaxBufferedDeleteTerms} to flush by count instead of RAM usage (each buffered delete Query counts as one).

NOTE: because IndexWriter uses

CopyC#
int
s when managing its internal storage, the absolute maximum value for this setting is somewhat less than 2048 MB. The precise limit depends on various factors, such as how large your documents are, how many fields have norms, etc., so it's best to set this value comfortably under 2048.

The default value is {@link #DEFAULT_RAM_BUFFER_SIZE_MB}.

enabled but non-positive, or it disables ramBufferSize when maxBufferedDocs is already disabled

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetRAMBufferSizeMB(
    double mb
)
Visual Basic
Public Overridable Sub SetRAMBufferSizeMB ( _
    mb As Double _
)
Visual C++
public:
virtual void SetRAMBufferSizeMB(
    double mb
)

Parameters

mb
Type: System..::..Double

[Missing <param name="mb"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetRAMBufferSizeMB(System.Double)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetReaderTermsIndexDivisor Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetReaderTermsIndexDivisor Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.SetReaderTermsIndexDivisor(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetReaderTermsIndexDivisor(
    int divisor
)
Visual Basic
Public Sub SetReaderTermsIndexDivisor ( _
    divisor As Integer _
)
Visual C++
public:
void SetReaderTermsIndexDivisor(
    int divisor
)

Parameters

divisor
Type: System..::..Int32

[Missing <param name="divisor"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetReaderTermsIndexDivisor(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetSimilarity Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetSimilarity Method
IndexWriter Class See Also Send Feedback
Expert: Set the Similarity implementation used by this IndexWriter.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSimilarity(
    Similarity similarity
)
Visual Basic
Public Overridable Sub SetSimilarity ( _
    similarity As Similarity _
)
Visual C++
public:
virtual void SetSimilarity(
    Similarity^ similarity
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetSimilarity(Lucene.Net.Search.Similarity)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
Similarity..::..SetDefault(Similarity)


SetTermIndexInterval Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetTermIndexInterval Method
IndexWriter Class See Also Send Feedback
Expert: Set the interval between indexed terms. Large values cause less memory to be used by IndexReader, but slow random-access to terms. Small values cause more memory to be used by an IndexReader, and speed random-access to terms. This parameter determines the amount of computation required per query term, regardless of the number of documents that contain that term. In particular, it is the maximum number of other terms that must be scanned before a term is located and its frequency and position information may be processed. In a large index with user-entered query terms, query processing time is likely to be dominated not by term lookup but rather by the processing of frequency and positional data. In a small index or when many uncommon query terms are generated (e.g., by wildcard queries) term lookup may become a dominant cost. In particular,
CopyC#
numUniqueTerms/interval
 terms are read into memory by an IndexReader, and, on average,
CopyC#
interval/2
 terms must be scanned for each random term access.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetTermIndexInterval(
    int interval
)
Visual Basic
Public Overridable Sub SetTermIndexInterval ( _
    interval As Integer _
)
Visual C++
public:
virtual void SetTermIndexInterval(
    int interval
)

Parameters

interval
Type: System..::..Int32

[Missing <param name="interval"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetTermIndexInterval(System.Int32)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
IndexWriter..::..DEFAULT_TERM_INDEX_INTERVAL


SetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetUseCompoundFile Method
IndexWriter Class See Also Send Feedback

Setting to turn on usage of a compound file. When on, multiple files for each segment are merged into a single file when a new segment is flushed.

Note that this method is a convenience method: it just calls mergePolicy.setUseCompoundFile as long as mergePolicy is an instance of {@link LogMergePolicy}. Otherwise an IllegalArgumentException is thrown.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetUseCompoundFile(
    bool value_Renamed
)
Visual Basic
Public Overridable Sub SetUseCompoundFile ( _
    value_Renamed As Boolean _
)
Visual C++
public:
virtual void SetUseCompoundFile(
    bool value_Renamed
)

Parameters

value_Renamed
Type: System..::..Boolean

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetUseCompoundFile(System.Boolean)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


SetWriteLockTimeout Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..SetWriteLockTimeout Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.SetWriteLockTimeout(System.Int64)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetWriteLockTimeout(
    long writeLockTimeout
)
Visual Basic
Public Overridable Sub SetWriteLockTimeout ( _
    writeLockTimeout As Long _
)
Visual C++
public:
virtual void SetWriteLockTimeout(
    long long writeLockTimeout
)

Parameters

writeLockTimeout
Type: System..::..Int64

[Missing <param name="writeLockTimeout"/> documentation for "M:Lucene.Net.Index.IndexWriter.SetWriteLockTimeout(System.Int64)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace
to change the default value for all instances of IndexWriter.


TestPoint Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..TestPoint Method
IndexWriter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.TestPoint(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool TestPoint(
    string name
)
Visual Basic
Public Overridable Function TestPoint ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool TestPoint(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.IndexWriter.TestPoint(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.TestPoint(System.String)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


Unlock Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Unlock Method
IndexWriter Class See Also Send Feedback
Forcibly unlocks the index in the named directory.

Caution: this should only be used by failure recovery code, when it is known that no other process nor thread is in fact currently accessing this index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Unlock(
    Directory directory
)
Visual Basic
Public Shared Sub Unlock ( _
    directory As Directory _
)
Visual C++
public:
static void Unlock(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.IndexWriter.Unlock(Lucene.Net.Store.Directory)"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


UpdateDocument Method

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..UpdateDocument Method
IndexWriter Class See Also Send Feedback

Overload List

Name Description
Public method UpdateDocument(Term, Document)
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Public method UpdateDocument(Term, Document, Analyzer)
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

See Also

IndexWriter Class
IndexWriter Members
Lucene.Net.Index Namespace


UpdateDocument Method (Term, Document)

[image]

Lucene.Net Class Libraries
IndexWriter..::..UpdateDocument Method (Term, Document)
IndexWriter Class See Also Send Feedback
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void UpdateDocument(
    Term term,
    Document doc
)
Visual Basic
Public Overridable Sub UpdateDocument ( _
    term As Term, _
    doc As Document _
)
Visual C++
public:
virtual void UpdateDocument(
    Term^ term,
    Document^ doc
)

Parameters

term
Type: Lucene.Net.Index..::..Term
the term to identify the document(s) to be deleted
doc
Type: Lucene.Net.Documents..::..Document
the document to be added

See Also

IndexWriter Class
UpdateDocument Overload
Lucene.Net.Index Namespace


UpdateDocument Method (Term, Document, Analyzer)

[image]

Lucene.Net Class Libraries
IndexWriter..::..UpdateDocument Method (Term, Document, Analyzer)
IndexWriter Class See Also Send Feedback
Updates a document by first deleting the document(s) containing
CopyC#
term
 and then adding the new document. The delete and then add are atomic as seen by a reader on the same index (flush may happen only after the add).

NOTE: if this method hits an OutOfMemoryError you should immediately close the writer. See above for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void UpdateDocument(
    Term term,
    Document doc,
    Analyzer analyzer
)
Visual Basic
Public Overridable Sub UpdateDocument ( _
    term As Term, _
    doc As Document, _
    analyzer As Analyzer _
)
Visual C++
public:
virtual void UpdateDocument(
    Term^ term,
    Document^ doc,
    Analyzer^ analyzer
)

Parameters

term
Type: Lucene.Net.Index..::..Term
the term to identify the document(s) to be deleted
doc
Type: Lucene.Net.Documents..::..Document
the document to be added
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use when analyzing the document

See Also

IndexWriter Class
UpdateDocument Overload
Lucene.Net.Index Namespace


Verbose Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..Verbose Method
IndexWriter Class See Also Send Feedback
Returns true if verbosing is enabled (i.e., infoStream != null).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Verbose()
Visual Basic
Public Overridable Function Verbose As Boolean
Visual C++
public:
virtual bool Verbose()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.Verbose"]

See Also

IndexWriter Class
Lucene.Net.Index Namespace


WaitForMerges Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..WaitForMerges Method
IndexWriter Class See Also Send Feedback
Wait for any currently outstanding merges to finish.

It is guaranteed that any merges started prior to calling this method will have completed once this method completes.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WaitForMerges()
Visual Basic
Public Overridable Sub WaitForMerges
Visual C++
public:
virtual void WaitForMerges()

See Also

IndexWriter Class
Lucene.Net.Index Namespace


IndexWriter.IndexReaderWarmer Class

[image]

Lucene.Net Class Libraries
IndexWriter..::..IndexReaderWarmer Class
IndexWriter Class Members See Also Send Feedback
If {@link #getReader} has been called (ie, this writer is in near real-time mode), then after a merge completes, this class can be invoked to warm the reader on the newly merged segment, before the merge commits. This is not required for near real-time search, but will reduce search latency on opening a new near real-time reader after a merge completes.

NOTE: This API is experimental and might change in incompatible ways in the next release.

NOTE: warm is called before any deletes have been carried over to the merged segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class IndexReaderWarmer
Visual Basic
Public MustInherit Class IndexReaderWarmer
Visual C++
public ref class IndexReaderWarmer abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexWriter..::..IndexReaderWarmer

See Also

IndexWriter..::..IndexReaderWarmer Members
Lucene.Net.Index Namespace


IndexWriter.IndexReaderWarmer Members

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..IndexReaderWarmer Members
IndexWriter..::..IndexReaderWarmer Class Constructors Methods See Also Send Feedback

An
CopyC#
IndexWriter
 creates and maintains an index.

The

CopyC#
create
argument to the {@link #IndexWriter(Directory, Analyzer, boolean) constructor} determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with
CopyC#
create=true
 even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also {@link #IndexWriter(Directory, Analyzer) constructors} with no
CopyC#
create
 argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with {@link #AddDocument(Document) addDocument} and removed with {@link #DeleteDocuments(Term)} or {@link #DeleteDocuments(Query)}. A document can be updated with {@link #UpdateDocument(Term, Document) updateDocument} (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, {@link #Close() close} should be called.

These changes are buffered in memory and periodically flushed to the {@link Directory} (during the above method calls). A flush is triggered when there are enough buffered deletes (see {@link #setMaxBufferedDeleteTerms}) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see {@link #setRAMBufferSizeMB}) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either {@link #Commit()} or {@link #close} is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the {@link MergeScheduler}).

The optional

CopyC#
autoCommit
argument to the {@link #IndexWriter(Directory, boolean, Analyzer) constructors} controls visibility of the changes to {@link IndexReader} instances reading the same index. When this is
CopyC#
false
, changes are not visible until {@link #Close()} or {@link #Commit()} is called. Note that changes will still be flushed to the {@link Directory} as new files, but are not committed (no new
CopyC#
segments_N
 file is written referencing the new files, nor are the files sync'd to stable storage) until {@link #Close()} or {@link #Commit()} is called. If something goes terribly wrong (for example the JVM crashes), then the index will reflect none of the changes made since the last commit, or the starting state if commit was not called. You can also call {@link #Rollback()}, which closes the writer without committing any changes, and removes any index files that had been flushed but are now unreferenced. This mode is useful for preventing readers from refreshing at a bad time (for example after you've done all your deletes but before you've done your adds). It can also be used to implement simple single-writer transactional semantics ("all or none"). You can do a two-phase commit by calling {@link #PrepareCommit()} followed by {@link #Commit()}. This is necessary when Lucene is working with an external resource (for example, a database) and both must either commit or rollback the transaction.

When

CopyC#
autoCommit
is
CopyC#
true
 then the writer will periodically commit on its own. [Deprecated: Note that in 3.0, IndexWriter will no longer accept autoCommit=true (it will be hardwired to false). You can always call {@link #Commit()} yourself when needed]. There is no guarantee when exactly an auto commit will occur (it used to be after every flush, but it is now after every completed merge, as of 2.4). If you want to force a commit, call {@link #Commit()}, or, close the writer. Once a commit has finished, newly opened {@link IndexReader} instances will see the changes to the index as of that commit. When running in this mode, be careful not to refresh your readers while optimize or segment merges are taking place as this can tie up substantial disk space.

Regardless of

CopyC#
autoCommit
, an {@link IndexReader} or {@link Lucene.Net.Search.IndexSearcher} will only see the index as of the "point in time" that it was opened. Any changes committed to the index after the reader was opened are not visible until the reader is re-opened.

If an index will not have more documents added for a while and optimal search performance is desired, then either the full {@link #Optimize() optimize} method or partial {@link #Optimize(int)} method should be called before the index is closed.

Opening an

CopyC#
IndexWriter
creates a lock file for the directory in use. Trying to open another
CopyC#
IndexWriter
 on the same directory will lead to a {@link LockObtainFailedException}. The {@link LockObtainFailedException} is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert:

CopyC#
IndexWriter
allows an optional {@link IndexDeletionPolicy} implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is {@link KeepOnlyLastCommitDeletionPolicy} which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert:

CopyC#
IndexWriter
allows you to separately change the {@link MergePolicy} and the {@link MergeScheduler}. The {@link MergePolicy} is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a {@link MergePolicy.MergeSpecification} describing the merges. It also selects merges to do for optimize(). (The default is {@link LogByteSizeMergePolicy}. Then, the {@link MergeScheduler} is invoked with the requested merges and it decides when and how to run the merges. The default is {@link ConcurrentMergeScheduler}.

NOTE: if you hit an OutOfMemoryError then IndexWriter will quietly record this fact and block all future segment commits. This is a defensive measure in case any internal state (buffered documents and deletions) were corrupted. Any subsequent calls to {@link #Commit()} will throw an IllegalStateException. The only course of action is to call {@link #Close()}, which internally will call {@link #Rollback()}, to undo any changes to the index since the last commit. If you opened the writer with autoCommit false you can also just call {@link #Rollback()} directly.

NOTE: {@link

CopyC#
IndexWriter
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexWriter
 instance as this may cause deadlock; use your own (non-Lucene) objects instead.

The IndexWriter..::..IndexReaderWarmer type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexWriter..::..IndexReaderWarmer | Initializes a new instance of the IndexWriter..::..IndexReaderWarmer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Warm |

See Also

IndexWriter..::..IndexReaderWarmer Class
Lucene.Net.Index Namespace


IndexWriter.IndexReaderWarmer Constructor

[image]

Lucene.Net Class Libraries
IndexWriter..::..IndexReaderWarmer Constructor
IndexWriter..::..IndexReaderWarmer Class See Also Send Feedback
Initializes a new instance of the IndexWriter..::..IndexReaderWarmer class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IndexReaderWarmer()
Visual Basic
Protected Sub New
Visual C++
protected:
IndexReaderWarmer()

See Also

IndexWriter..::..IndexReaderWarmer Class
Lucene.Net.Index Namespace


IndexWriter.IndexReaderWarmer Methods

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..IndexReaderWarmer Methods
IndexWriter..::..IndexReaderWarmer Class See Also Send Feedback

The IndexWriter..::..IndexReaderWarmer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Warm |

See Also

IndexWriter..::..IndexReaderWarmer Class
Lucene.Net.Index Namespace


Warm Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..IndexReaderWarmer..::..Warm Method
IndexWriter..::..IndexReaderWarmer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.IndexReaderWarmer.Warm(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Warm(
    IndexReader reader
)
Visual Basic
Public MustOverride Sub Warm ( _
    reader As IndexReader _
)
Visual C++
public:
virtual void Warm(
    IndexReader^ reader
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Index.IndexWriter.IndexReaderWarmer.Warm(Lucene.Net.Index.IndexReader)"]

See Also

IndexWriter..::..IndexReaderWarmer Class
Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Class

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength Class
IndexWriter Class Members See Also Send Feedback
Specifies maximum field length (in number of tokens/terms) in {@link IndexWriter} constructors. {@link #SetMaxFieldLength(int)} overrides the value set by the constructor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class MaxFieldLength
Visual Basic
Public NotInheritable Class MaxFieldLength
Visual C++
public ref class MaxFieldLength sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexWriter..::..MaxFieldLength

See Also

IndexWriter..::..MaxFieldLength Members
Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Members

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength Members
IndexWriter..::..MaxFieldLength Class Constructors Methods Fields See Also Send Feedback

An
CopyC#
IndexWriter
 creates and maintains an index.

The

CopyC#
create
argument to the {@link #IndexWriter(Directory, Analyzer, boolean) constructor} determines whether a new index is created, or whether an existing index is opened. Note that you can open an index with
CopyC#
create=true
 even while readers are using the index. The old readers will continue to search the "point in time" snapshot they had opened, and won't see the newly created index until they re-open. There are also {@link #IndexWriter(Directory, Analyzer) constructors} with no
CopyC#
create
 argument which will create a new index if there is not already an index at the provided path and otherwise open the existing index.

In either case, documents are added with {@link #AddDocument(Document) addDocument} and removed with {@link #DeleteDocuments(Term)} or {@link #DeleteDocuments(Query)}. A document can be updated with {@link #UpdateDocument(Term, Document) updateDocument} (which just deletes and then adds the entire document). When finished adding, deleting and updating documents, {@link #Close() close} should be called.

These changes are buffered in memory and periodically flushed to the {@link Directory} (during the above method calls). A flush is triggered when there are enough buffered deletes (see {@link #setMaxBufferedDeleteTerms}) or enough added documents since the last flush, whichever is sooner. For the added documents, flushing is triggered either by RAM usage of the documents (see {@link #setRAMBufferSizeMB}) or the number of added documents. The default is to flush when RAM usage hits 16 MB. For best indexing speed you should flush by RAM usage with a large RAM buffer. Note that flushing just moves the internal buffered state in IndexWriter into the index, but these changes are not visible to IndexReader until either {@link #Commit()} or {@link #close} is called. A flush may also trigger one or more segment merges which by default run with a background thread so as not to block the addDocument calls (see below for changing the {@link MergeScheduler}).

The optional

CopyC#
autoCommit
argument to the {@link #IndexWriter(Directory, boolean, Analyzer) constructors} controls visibility of the changes to {@link IndexReader} instances reading the same index. When this is
CopyC#
false
, changes are not visible until {@link #Close()} or {@link #Commit()} is called. Note that changes will still be flushed to the {@link Directory} as new files, but are not committed (no new
CopyC#
segments_N
 file is written referencing the new files, nor are the files sync'd to stable storage) until {@link #Close()} or {@link #Commit()} is called. If something goes terribly wrong (for example the JVM crashes), then the index will reflect none of the changes made since the last commit, or the starting state if commit was not called. You can also call {@link #Rollback()}, which closes the writer without committing any changes, and removes any index files that had been flushed but are now unreferenced. This mode is useful for preventing readers from refreshing at a bad time (for example after you've done all your deletes but before you've done your adds). It can also be used to implement simple single-writer transactional semantics ("all or none"). You can do a two-phase commit by calling {@link #PrepareCommit()} followed by {@link #Commit()}. This is necessary when Lucene is working with an external resource (for example, a database) and both must either commit or rollback the transaction.

When

CopyC#
autoCommit
is
CopyC#
true
 then the writer will periodically commit on its own. [Deprecated: Note that in 3.0, IndexWriter will no longer accept autoCommit=true (it will be hardwired to false). You can always call {@link #Commit()} yourself when needed]. There is no guarantee when exactly an auto commit will occur (it used to be after every flush, but it is now after every completed merge, as of 2.4). If you want to force a commit, call {@link #Commit()}, or, close the writer. Once a commit has finished, newly opened {@link IndexReader} instances will see the changes to the index as of that commit. When running in this mode, be careful not to refresh your readers while optimize or segment merges are taking place as this can tie up substantial disk space.

Regardless of

CopyC#
autoCommit
, an {@link IndexReader} or {@link Lucene.Net.Search.IndexSearcher} will only see the index as of the "point in time" that it was opened. Any changes committed to the index after the reader was opened are not visible until the reader is re-opened.

If an index will not have more documents added for a while and optimal search performance is desired, then either the full {@link #Optimize() optimize} method or partial {@link #Optimize(int)} method should be called before the index is closed.

Opening an

CopyC#
IndexWriter
creates a lock file for the directory in use. Trying to open another
CopyC#
IndexWriter
 on the same directory will lead to a {@link LockObtainFailedException}. The {@link LockObtainFailedException} is also thrown if an IndexReader on the same directory is used to delete documents from the index.

Expert:

CopyC#
IndexWriter
allows an optional {@link IndexDeletionPolicy} implementation to be specified. You can use this to control when prior commits are deleted from the index. The default policy is {@link KeepOnlyLastCommitDeletionPolicy} which removes all prior commits as soon as a new commit is done (this matches behavior before 2.2). Creating your own policy can allow you to explicitly keep previous "point in time" commits alive in the index for some time, to allow readers to refresh to the new commit without having the old commit deleted out from under them. This is necessary on filesystems like NFS that do not support "delete on last close" semantics, which Lucene's "point in time" search normally relies on.

Expert:

CopyC#
IndexWriter
allows you to separately change the {@link MergePolicy} and the {@link MergeScheduler}. The {@link MergePolicy} is invoked whenever there are changes to the segments in the index. Its role is to select which merges to do, if any, and return a {@link MergePolicy.MergeSpecification} describing the merges. It also selects merges to do for optimize(). (The default is {@link LogByteSizeMergePolicy}. Then, the {@link MergeScheduler} is invoked with the requested merges and it decides when and how to run the merges. The default is {@link ConcurrentMergeScheduler}.

NOTE: if you hit an OutOfMemoryError then IndexWriter will quietly record this fact and block all future segment commits. This is a defensive measure in case any internal state (buffered documents and deletions) were corrupted. Any subsequent calls to {@link #Commit()} will throw an IllegalStateException. The only course of action is to call {@link #Close()}, which internally will call {@link #Rollback()}, to undo any changes to the index since the last commit. If you opened the writer with autoCommit false you can also just call {@link #Rollback()} directly.

NOTE: {@link

CopyC#
IndexWriter
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexWriter
 instance as this may cause deadlock; use your own (non-Lucene) objects instead.

The IndexWriter..::..MaxFieldLength type exposes the following members.

Constructors

 | Name | Description
Public method | IndexWriter..::..MaxFieldLength | Public constructor to allow users to specify the maximum field size limit.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLimit |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
LIMITED | Sets the maximum field length to {@link #DEFAULT_MAX_FIELD_LENGTH}
UNLIMITED | Sets the maximum field length to {@link Integer#MAX_VALUE}.

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Constructor

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength Constructor
IndexWriter..::..MaxFieldLength Class See Also Send Feedback
Public constructor to allow users to specify the maximum field size limit.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MaxFieldLength(
    int limit
)
Visual Basic
Public Sub New ( _
    limit As Integer _
)
Visual C++
public:
MaxFieldLength(
    int limit
)

Parameters

limit
Type: System..::..Int32
The maximum field length

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Fields

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength Fields
IndexWriter..::..MaxFieldLength Class See Also Send Feedback

The IndexWriter..::..MaxFieldLength type exposes the following members.

Fields

Name | Description
LIMITED | Sets the maximum field length to {@link #DEFAULT_MAX_FIELD_LENGTH}
UNLIMITED | Sets the maximum field length to {@link Integer#MAX_VALUE}.

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


LIMITED Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength..::..LIMITED Field
IndexWriter..::..MaxFieldLength Class See Also Send Feedback
Sets the maximum field length to {@link #DEFAULT_MAX_FIELD_LENGTH}

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexWriter..::..MaxFieldLength LIMITED
Visual Basic
Public Shared ReadOnly LIMITED As IndexWriter..::..MaxFieldLength
Visual C++
public:
static initonly IndexWriter..::..MaxFieldLength^ LIMITED

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


UNLIMITED Field

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength..::..UNLIMITED Field
IndexWriter..::..MaxFieldLength Class See Also Send Feedback
Sets the maximum field length to {@link Integer#MAX_VALUE}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IndexWriter..::..MaxFieldLength UNLIMITED
Visual Basic
Public Shared ReadOnly UNLIMITED As IndexWriter..::..MaxFieldLength
Visual C++
public:
static initonly IndexWriter..::..MaxFieldLength^ UNLIMITED

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


IndexWriter.MaxFieldLength Methods

[image] [image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength Methods
IndexWriter..::..MaxFieldLength Class See Also Send Feedback

The IndexWriter..::..MaxFieldLength type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLimit |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


GetLimit Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength..::..GetLimit Method
IndexWriter..::..MaxFieldLength Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.MaxFieldLength.GetLimit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetLimit()
Visual Basic
Public Function GetLimit As Integer
Visual C++
public:
int GetLimit()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.MaxFieldLength.GetLimit"]

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
IndexWriter..::..MaxFieldLength..::..ToString Method
IndexWriter..::..MaxFieldLength Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.IndexWriter.MaxFieldLength.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.IndexWriter.MaxFieldLength.ToString"]

See Also

IndexWriter..::..MaxFieldLength Class
Lucene.Net.Index Namespace


IntFieldEnumerator Class

[image]

Lucene.Net Class Libraries
IntFieldEnumerator Class
Members See Also Send Feedback
Implementation for enumerating over all of the terms in an int numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class IntFieldEnumerator : NumericFieldEnum<int>
Visual Basic
Public Class IntFieldEnumerator _
    Inherits NumericFieldEnum(Of Integer)
Visual C++
public ref class IntFieldEnumerator : public NumericFieldEnum<int>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator <(Of <(<' Int32 >)>)>
Lucene.Net.Index..::..NumericFieldEnum <(Of <(<' Int32 >)>)>
Lucene.Net.Index..::..IntFieldEnumerator

See Also

IntFieldEnumerator Members
Lucene.Net.Index Namespace


IntFieldEnumerator Members

[image] [image]

Lucene.Net Class Libraries
IntFieldEnumerator Members
IntFieldEnumerator Class Constructors Methods Fields Properties See Also Send Feedback

The IntFieldEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | IntFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | IntFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the int from an encoded string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the int from the string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

IntFieldEnumerator Class
Lucene.Net.Index Namespace


IntFieldEnumerator Constructor

[image] [image]

Lucene.Net Class Libraries
IntFieldEnumerator Constructor
IntFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | IntFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

See Also

IntFieldEnumerator Class
IntFieldEnumerator Members
Lucene.Net.Index Namespace


IntFieldEnumerator Constructor (IndexReader, String, FieldParser)

[image]

Lucene.Net Class Libraries
IntFieldEnumerator Constructor (IndexReader, String, FieldParser)
IntFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public IntFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser _
)
Visual C++
public:
IntFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.IntFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser)"]

See Also

IntFieldEnumerator Class
IntFieldEnumerator Overload
Lucene.Net.Index Namespace


IntFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)

[image]

Lucene.Net Class Libraries
IntFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)
IntFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public IntFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser,
    bool includeDocs
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser, _
    includeDocs As Boolean _
)
Visual C++
public:
IntFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser,
    bool includeDocs
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.IntFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser,System.Boolean)"]

includeDocs
Type: System..::..Boolean
Whether the TermDocs will also be enumerated.

See Also

IntFieldEnumerator Class
IntFieldEnumerator Overload
Lucene.Net.Index Namespace


IntFieldEnumerator Fields

[image] [image]

Lucene.Net Class Libraries
IntFieldEnumerator Fields
IntFieldEnumerator Class See Also Send Feedback

The IntFieldEnumerator type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

IntFieldEnumerator Class
Lucene.Net.Index Namespace


IntFieldEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
IntFieldEnumerator Methods
IntFieldEnumerator Class See Also Send Feedback

The IntFieldEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the int from an encoded string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the int from the string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

See Also

IntFieldEnumerator Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
IntFieldEnumerator..::..Init Method
IntFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)

See Also

IntFieldEnumerator Class
IntFieldEnumerator Members
Lucene.Net.Index Namespace


TryParseNumeric Method

[image]

Lucene.Net Class Libraries
IntFieldEnumerator..::..TryParseNumeric Method
IntFieldEnumerator Class See Also Send Feedback
Parse the int from an encoded string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseNumeric(
    string s
)
Visual Basic
Protected Overrides Function TryParseNumeric ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseNumeric(
    String^ s
) override

Parameters

s
Type: System..::..String
String to parse.

Return Value

True if the parse was successful, false indicating failure and the end of useful terms in the numeric field.

See Also

IntFieldEnumerator Class
Lucene.Net.Index Namespace


TryParseString Method

[image]

Lucene.Net Class Libraries
IntFieldEnumerator..::..TryParseString Method
IntFieldEnumerator Class See Also Send Feedback
Parse the int from the string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseString(
    string s
)
Visual Basic
Protected Overrides Function TryParseString ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseString(
    String^ s
) override

Parameters

s
Type: System..::..String
String to parse.

Return Value

Always true.

See Also

IntFieldEnumerator Class
Lucene.Net.Index Namespace


IntFieldEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
IntFieldEnumerator Properties
IntFieldEnumerator Class See Also Send Feedback

The IntFieldEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

IntFieldEnumerator Class
Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Class

[image]

Lucene.Net Class Libraries
KeepOnlyLastCommitDeletionPolicy Class
Members See Also Send Feedback
This {@link IndexDeletionPolicy} implementation that keeps only the most recent commit and immediately removes all prior commits after a new commit is done. This is the default deletion policy.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class KeepOnlyLastCommitDeletionPolicy : IndexDeletionPolicy
Visual Basic
Public NotInheritable Class KeepOnlyLastCommitDeletionPolicy _
    Implements IndexDeletionPolicy
Visual C++
public ref class KeepOnlyLastCommitDeletionPolicy sealed : IndexDeletionPolicy

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..KeepOnlyLastCommitDeletionPolicy

See Also

KeepOnlyLastCommitDeletionPolicy Members
Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Members

[image] [image]

Lucene.Net Class Libraries
KeepOnlyLastCommitDeletionPolicy Members
KeepOnlyLastCommitDeletionPolicy Class Constructors Methods See Also Send Feedback

The KeepOnlyLastCommitDeletionPolicy type exposes the following members.

Constructors

 | Name | Description
Public method | KeepOnlyLastCommitDeletionPolicy | Initializes a new instance of the KeepOnlyLastCommitDeletionPolicy class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCommit | Deletes all commits except the most recent one.
Public method | OnInit | Deletes all commits except the most recent one.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Constructor

[image]

Lucene.Net Class Libraries
KeepOnlyLastCommitDeletionPolicy Constructor
KeepOnlyLastCommitDeletionPolicy Class See Also Send Feedback
Initializes a new instance of the KeepOnlyLastCommitDeletionPolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public KeepOnlyLastCommitDeletionPolicy()
Visual Basic
Public Sub New
Visual C++
public:
KeepOnlyLastCommitDeletionPolicy()

See Also

KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace


KeepOnlyLastCommitDeletionPolicy Methods

[image] [image]

Lucene.Net Class Libraries
KeepOnlyLastCommitDeletionPolicy Methods
KeepOnlyLastCommitDeletionPolicy Class See Also Send Feedback

The KeepOnlyLastCommitDeletionPolicy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCommit | Deletes all commits except the most recent one.
Public method | OnInit | Deletes all commits except the most recent one.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace


OnCommit Method

[image]

Lucene.Net Class Libraries
KeepOnlyLastCommitDeletionPolicy..::..OnCommit Method
KeepOnlyLastCommitDeletionPolicy Class See Also Send Feedback
Deletes all commits except the most recent one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void OnCommit(
    IList commits
)
Visual Basic
Public Sub OnCommit ( _
    commits As IList _
)
Visual C++
public:
virtual void OnCommit(
    IList^ commits
) sealed

Parameters

commits
Type: System.Collections..::..IList

[Missing <param name="commits"/> documentation for "M:Lucene.Net.Index.KeepOnlyLastCommitDeletionPolicy.OnCommit(System.Collections.IList)"]

Implements

IndexDeletionPolicy..::..OnCommit(IList)

See Also

KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace


OnInit Method

[image]

Lucene.Net Class Libraries
KeepOnlyLastCommitDeletionPolicy..::..OnInit Method
KeepOnlyLastCommitDeletionPolicy Class See Also Send Feedback
Deletes all commits except the most recent one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void OnInit(
    IList commits
)
Visual Basic
Public Sub OnInit ( _
    commits As IList _
)
Visual C++
public:
virtual void OnInit(
    IList^ commits
) sealed

Parameters

commits
Type: System.Collections..::..IList

[Missing <param name="commits"/> documentation for "M:Lucene.Net.Index.KeepOnlyLastCommitDeletionPolicy.OnInit(System.Collections.IList)"]

Implements

IndexDeletionPolicy..::..OnInit(IList)

See Also

KeepOnlyLastCommitDeletionPolicy Class
Lucene.Net.Index Namespace


LogByteSizeMergePolicy Class

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy Class
Members See Also Send Feedback
This is a {@link LogMergePolicy} that measures size of a segment as the total byte size of the segment's files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class LogByteSizeMergePolicy : LogMergePolicy
Visual Basic
Public Class LogByteSizeMergePolicy _
    Inherits LogMergePolicy
Visual C++
public ref class LogByteSizeMergePolicy : public LogMergePolicy

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergePolicy
Lucene.Net.Index..::..LogMergePolicy
Lucene.Net.Index..::..LogByteSizeMergePolicy

See Also

LogByteSizeMergePolicy Members
Lucene.Net.Index Namespace


LogByteSizeMergePolicy Members

[image] [image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy Members
LogByteSizeMergePolicy Class Constructors Methods Fields See Also Send Feedback

The LogByteSizeMergePolicy type exposes the following members.

Constructors

 | Name | Description
Public method | LogByteSizeMergePolicy | Initializes a new instance of the LogByteSizeMergePolicy class

Methods

 | Name | Description
Public method | Close | (Inherited from LogMergePolicy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | GetCalibrateSizeByDeletes | Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments. (Inherited from LogMergePolicy.)
Public method | GetMaxMergeMB | Returns the largest segment (meaured by total byte size of the segment's files, in MB) that may be merged with other segments.
Public method | GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index. (Inherited from LogMergePolicy.)
Public method | GetMinMergeMB | Get the minimum size for a segment to remain un-merged.
Public method | GetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | Returns true if newly flushed and newly merge segments (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCalibrateSizeByDeletes | Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}. (Inherited from LogMergePolicy.)
Public method | SetMaxMergeMB | Determines the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. Note that {@link #setMaxMergeDocs} is also used to check whether a segment is too large for merging (it's either or).
Public method | SetMergeFactor | Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public method | SetMinMergeMB | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public method | SetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy..::..Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)

Fields

 | Name | Description
Protected field | calibrateSizeByDeletes | (Inherited from LogMergePolicy.)
 | DEFAULT_MAX_MERGE_MB | Default maximum segment size. A segment of this size
 | DEFAULT_MIN_MERGE_MB |
Protected field | noCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


LogByteSizeMergePolicy Constructor

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy Constructor
LogByteSizeMergePolicy Class See Also Send Feedback
Initializes a new instance of the LogByteSizeMergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LogByteSizeMergePolicy(
    IndexWriter writer
)
Visual Basic
Public Sub New ( _
    writer As IndexWriter _
)
Visual C++
public:
LogByteSizeMergePolicy(
    IndexWriter^ writer
)

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.#ctor(Lucene.Net.Index.IndexWriter)"]

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


LogByteSizeMergePolicy Fields

[image] [image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy Fields
LogByteSizeMergePolicy Class See Also Send Feedback

The LogByteSizeMergePolicy type exposes the following members.

Fields

 | Name | Description
Protected field | calibrateSizeByDeletes | (Inherited from LogMergePolicy.)
 | DEFAULT_MAX_MERGE_MB | Default maximum segment size. A segment of this size
 | DEFAULT_MIN_MERGE_MB |
Protected field | noCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


DEFAULT_MAX_MERGE_MB Field

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..DEFAULT_MAX_MERGE_MB Field
LogByteSizeMergePolicy Class See Also Send Feedback
Default maximum segment size. A segment of this size

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly long DEFAULT_MAX_MERGE_MB
Visual Basic
Public Shared ReadOnly DEFAULT_MAX_MERGE_MB As Long
Visual C++
public:
static initonly long long DEFAULT_MAX_MERGE_MB

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace
[!:setMaxMergeMB]


DEFAULT_MIN_MERGE_MB Field

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..DEFAULT_MIN_MERGE_MB Field
LogByteSizeMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.LogByteSizeMergePolicy.DEFAULT_MIN_MERGE_MB"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const double DEFAULT_MIN_MERGE_MB
Visual Basic
Public Const DEFAULT_MIN_MERGE_MB As Double
Visual C++
public:
literal double DEFAULT_MIN_MERGE_MB

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace
[!:setMinMergeMB]


LogByteSizeMergePolicy Methods

[image] [image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy Methods
LogByteSizeMergePolicy Class See Also Send Feedback

The LogByteSizeMergePolicy type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from LogMergePolicy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | GetCalibrateSizeByDeletes | Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments. (Inherited from LogMergePolicy.)
Public method | GetMaxMergeMB | Returns the largest segment (meaured by total byte size of the segment's files, in MB) that may be merged with other segments.
Public method | GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index. (Inherited from LogMergePolicy.)
Public method | GetMinMergeMB | Get the minimum size for a segment to remain un-merged.
Public method | GetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | Returns true if newly flushed and newly merge segments (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCalibrateSizeByDeletes | Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}. (Inherited from LogMergePolicy.)
Public method | SetMaxMergeMB | Determines the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. Note that {@link #setMaxMergeDocs} is also used to check whether a segment is too large for merging (it's either or).
Public method | SetMergeFactor | Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public method | SetMinMergeMB | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public method | SetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy..::..Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


GetMaxMergeMB Method

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..GetMaxMergeMB Method
LogByteSizeMergePolicy Class See Also Send Feedback
Returns the largest segment (meaured by total byte size of the segment's files, in MB) that may be merged with other segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual double GetMaxMergeMB()
Visual Basic
Public Overridable Function GetMaxMergeMB As Double
Visual C++
public:
virtual double GetMaxMergeMB()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.GetMaxMergeMB"]

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace
[!:setMaxMergeMB]


GetMinMergeMB Method

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..GetMinMergeMB Method
LogByteSizeMergePolicy Class See Also Send Feedback
Get the minimum size for a segment to remain un-merged.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual double GetMinMergeMB()
Visual Basic
Public Overridable Function GetMinMergeMB As Double
Visual C++
public:
virtual double GetMinMergeMB()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.GetMinMergeMB"]

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace
[!:setMinMergeMB]


SetMaxMergeMB Method

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..SetMaxMergeMB Method
LogByteSizeMergePolicy Class See Also Send Feedback

Determines the largest segment (measured by total byte size of the segment's files, in MB) that may be merged with other segments. Small values (e.g., less than 50 MB) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

Note that {@link #setMaxMergeDocs} is also used to check whether a segment is too large for merging (it's either or).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxMergeMB(
    double mb
)
Visual Basic
Public Overridable Sub SetMaxMergeMB ( _
    mb As Double _
)
Visual C++
public:
virtual void SetMaxMergeMB(
    double mb
)

Parameters

mb
Type: System..::..Double

[Missing <param name="mb"/> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.SetMaxMergeMB(System.Double)"]

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


SetMinMergeMB Method

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..SetMinMergeMB Method
LogByteSizeMergePolicy Class See Also Send Feedback
Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMinMergeMB(
    double mb
)
Visual Basic
Public Overridable Sub SetMinMergeMB ( _
    mb As Double _
)
Visual C++
public:
virtual void SetMinMergeMB(
    double mb
)

Parameters

mb
Type: System..::..Double

[Missing <param name="mb"/> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.SetMinMergeMB(System.Double)"]

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
LogByteSizeMergePolicy..::..Size Method
LogByteSizeMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override long Size(
    SegmentInfo info
)
Visual Basic
Protected Friend Overrides Function Size ( _
    info As SegmentInfo _
) As Long
Visual C++
protected public:
virtual long long Size(
    SegmentInfo^ info
) override

Parameters

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogByteSizeMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

See Also

LogByteSizeMergePolicy Class
Lucene.Net.Index Namespace


LogDocMergePolicy Class

[image]

Lucene.Net Class Libraries
LogDocMergePolicy Class
Members See Also Send Feedback
This is a {@link LogMergePolicy} that measures size of a segment as the number of documents (not taking deletions into account).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class LogDocMergePolicy : LogMergePolicy
Visual Basic
Public Class LogDocMergePolicy _
    Inherits LogMergePolicy
Visual C++
public ref class LogDocMergePolicy : public LogMergePolicy

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergePolicy
Lucene.Net.Index..::..LogMergePolicy
Lucene.Net.Index..::..LogDocMergePolicy

See Also

LogDocMergePolicy Members
Lucene.Net.Index Namespace


LogDocMergePolicy Members

[image] [image]

Lucene.Net Class Libraries
LogDocMergePolicy Members
LogDocMergePolicy Class Constructors Methods Fields See Also Send Feedback

The LogDocMergePolicy type exposes the following members.

Constructors

 | Name | Description
Public method | LogDocMergePolicy | Initializes a new instance of the LogDocMergePolicy class

Methods

 | Name | Description
Public method | Close | (Inherited from LogMergePolicy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | GetCalibrateSizeByDeletes | Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments. (Inherited from LogMergePolicy.)
Public method | GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index. (Inherited from LogMergePolicy.)
Public method | GetMinMergeDocs | Get the minimum size for a segment to remain un-merged.
Public method | GetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | Returns true if newly flushed and newly merge segments (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCalibrateSizeByDeletes | Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}. (Inherited from LogMergePolicy.)
Public method | SetMergeFactor | Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public method | SetMinMergeDocs | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public method | SetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy..::..Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)

Fields

 | Name | Description
Protected field | calibrateSizeByDeletes | (Inherited from LogMergePolicy.)
 | DEFAULT_MIN_MERGE_DOCS |
Protected field | noCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace


LogDocMergePolicy Constructor

[image]

Lucene.Net Class Libraries
LogDocMergePolicy Constructor
LogDocMergePolicy Class See Also Send Feedback
Initializes a new instance of the LogDocMergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LogDocMergePolicy(
    IndexWriter writer
)
Visual Basic
Public Sub New ( _
    writer As IndexWriter _
)
Visual C++
public:
LogDocMergePolicy(
    IndexWriter^ writer
)

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.LogDocMergePolicy.#ctor(Lucene.Net.Index.IndexWriter)"]

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace


LogDocMergePolicy Fields

[image] [image]

Lucene.Net Class Libraries
LogDocMergePolicy Fields
LogDocMergePolicy Class See Also Send Feedback

The LogDocMergePolicy type exposes the following members.

Fields

 | Name | Description
Protected field | calibrateSizeByDeletes | (Inherited from LogMergePolicy.)
 | DEFAULT_MIN_MERGE_DOCS |
Protected field | noCFSRatio | (Inherited from LogMergePolicy.)
Protected field | writer | (Inherited from MergePolicy.)

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace


DEFAULT_MIN_MERGE_DOCS Field

[image]

Lucene.Net Class Libraries
LogDocMergePolicy..::..DEFAULT_MIN_MERGE_DOCS Field
LogDocMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.LogDocMergePolicy.DEFAULT_MIN_MERGE_DOCS"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT_MIN_MERGE_DOCS
Visual Basic
Public Const DEFAULT_MIN_MERGE_DOCS As Integer
Visual C++
public:
literal int DEFAULT_MIN_MERGE_DOCS

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace
[!:setMinMergeDocs]


LogDocMergePolicy Methods

[image] [image]

Lucene.Net Class Libraries
LogDocMergePolicy Methods
LogDocMergePolicy Class See Also Send Feedback

The LogDocMergePolicy type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from LogMergePolicy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency. (Inherited from LogMergePolicy.)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Inherited from LogMergePolicy.)
Public method | GetCalibrateSizeByDeletes | Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments. (Inherited from LogMergePolicy.)
Public method | GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index. (Inherited from LogMergePolicy.)
Public method | GetMinMergeDocs | Get the minimum size for a segment to remain un-merged.
Public method | GetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields) (Inherited from LogMergePolicy.)
Public method | GetUseCompoundFile | Returns true if newly flushed and newly merge segments (Inherited from LogMergePolicy.)
Protected method | MakeOneMerge | (Inherited from LogMergePolicy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCalibrateSizeByDeletes | Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge. (Inherited from LogMergePolicy.)
Public method | SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}. (Inherited from LogMergePolicy.)
Public method | SetMergeFactor | Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained. (Inherited from LogMergePolicy.)
Public method | SetMinMergeDocs | Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).
Public method | SetNoCFSRatio | (Inherited from LogMergePolicy.)
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields). (Inherited from LogMergePolicy.)
Public method | SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments. (Inherited from LogMergePolicy.)
Protected method | Size | (Overrides LogMergePolicy..::..Size(SegmentInfo).)
Protected method | SizeBytes | (Inherited from LogMergePolicy.)
Protected method | SizeDocs | (Inherited from LogMergePolicy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | (Inherited from LogMergePolicy.)
Public method | UseCompoundFile | (Inherited from LogMergePolicy.)
Protected method | Verbose | (Inherited from LogMergePolicy.)

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace


GetMinMergeDocs Method

[image]

Lucene.Net Class Libraries
LogDocMergePolicy..::..GetMinMergeDocs Method
LogDocMergePolicy Class See Also Send Feedback
Get the minimum size for a segment to remain un-merged.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMinMergeDocs()
Visual Basic
Public Overridable Function GetMinMergeDocs As Integer
Visual C++
public:
virtual int GetMinMergeDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogDocMergePolicy.GetMinMergeDocs"]

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace
[!:setMinMergeDocs]


SetMinMergeDocs Method

[image]

Lucene.Net Class Libraries
LogDocMergePolicy..::..SetMinMergeDocs Method
LogDocMergePolicy Class See Also Send Feedback
Sets the minimum size for the lowest level segments. Any segments below this size are considered to be on the same level (even if they vary drastically in size) and will be merged whenever there are mergeFactor of them. This effectively truncates the "long tail" of small segments that would otherwise be created into a single level. If you set this too large, it could greatly increase the merging cost during indexing (if you flush many small segments).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMinMergeDocs(
    int minMergeDocs
)
Visual Basic
Public Overridable Sub SetMinMergeDocs ( _
    minMergeDocs As Integer _
)
Visual C++
public:
virtual void SetMinMergeDocs(
    int minMergeDocs
)

Parameters

minMergeDocs
Type: System..::..Int32

[Missing <param name="minMergeDocs"/> documentation for "M:Lucene.Net.Index.LogDocMergePolicy.SetMinMergeDocs(System.Int32)"]

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
LogDocMergePolicy..::..Size Method
LogDocMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogDocMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override long Size(
    SegmentInfo info
)
Visual Basic
Protected Friend Overrides Function Size ( _
    info As SegmentInfo _
) As Long
Visual C++
protected public:
virtual long long Size(
    SegmentInfo^ info
) override

Parameters

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.LogDocMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogDocMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

See Also

LogDocMergePolicy Class
Lucene.Net.Index Namespace


LogMergePolicy Class

[image]

Lucene.Net Class Libraries
LogMergePolicy Class
Members See Also Send Feedback

This class implements a {@link MergePolicy} that tries to merge segments into levels of exponentially increasing size, where each level has fewer segments than the value of the merge factor. Whenever extra segments (beyond the merge factor upper bound) are encountered, all segments within the level are merged. You can get or set the merge factor using {@link #GetMergeFactor()} and {@link #SetMergeFactor(int)} respectively.

This class is abstract and requires a subclass to define the {@link #size} method which specifies how a segment's size is determined. {@link LogDocMergePolicy} is one subclass that measures size by document count in the segment. {@link LogByteSizeMergePolicy} is another subclass that measures size as the total byte size of the file(s) for the segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class LogMergePolicy : MergePolicy
Visual Basic
Public MustInherit Class LogMergePolicy _
    Inherits MergePolicy
Visual C++
public ref class LogMergePolicy abstract : public MergePolicy

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergePolicy
Lucene.Net.Index..::..LogMergePolicy
Lucene.Net.Index..::..LogByteSizeMergePolicy
Lucene.Net.Index..::..LogDocMergePolicy

See Also

LogMergePolicy Members
Lucene.Net.Index Namespace


LogMergePolicy Members

[image] [image]

Lucene.Net Class Libraries
LogMergePolicy Members
LogMergePolicy Class Constructors Methods Fields See Also Send Feedback

The LogMergePolicy type exposes the following members.

Constructors

 | Name | Description
Public method | LogMergePolicy | Initializes a new instance of the LogMergePolicy class

Methods

 | Name | Description
Public method | Close | (Overrides MergePolicy..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency. (Overrides MergePolicy..::..FindMerges(SegmentInfos).)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency. (Overrides MergePolicy..::..FindMergesForOptimize(SegmentInfos, Int32, Hashtable).)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Overrides MergePolicy..::..FindMergesToExpungeDeletes(SegmentInfos).)
Public method | GetCalibrateSizeByDeletes | Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments.
Public method | GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
Public method | GetNoCFSRatio |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
Public method | GetUseCompoundFile | Returns true if newly flushed and newly merge segments
Protected method | MakeOneMerge |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCalibrateSizeByDeletes | Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge.
Public method | SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
Public method | SetMergeFactor | Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.
Public method | SetNoCFSRatio |
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
Public method | SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments.
Protected method | Size |
Protected method | SizeBytes |
Protected method | SizeDocs |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | (Overrides MergePolicy..::..UseCompoundDocStore(SegmentInfos).)
Public method | UseCompoundFile | (Overrides MergePolicy..::..UseCompoundFile(SegmentInfos, SegmentInfo).)
Protected method | Verbose |

Fields

 | Name | Description
Protected field | calibrateSizeByDeletes |
 | DEFAULT_MAX_MERGE_DOCS | Default maximum segment size. A segment of this size
 | DEFAULT_MERGE_FACTOR | Default merge factor, which is how many segments are merged at a time
 | DEFAULT_NO_CFS_RATIO | Default noCFSRatio. If a merge's size is >= 10% of the index, then we disable compound file for it. @see #setNoCFSRatio
 | LEVEL_LOG_SPAN | Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minus LEVEL_LOG_SPAN, and finding all segments falling within that range.
Protected field | noCFSRatio |
Protected field | writer | (Inherited from MergePolicy.)

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


LogMergePolicy Constructor

[image]

Lucene.Net Class Libraries
LogMergePolicy Constructor
LogMergePolicy Class See Also Send Feedback
Initializes a new instance of the LogMergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LogMergePolicy(
    IndexWriter writer
)
Visual Basic
Public Sub New ( _
    writer As IndexWriter _
)
Visual C++
public:
LogMergePolicy(
    IndexWriter^ writer
)

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.#ctor(Lucene.Net.Index.IndexWriter)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


LogMergePolicy Fields

[image] [image]

Lucene.Net Class Libraries
LogMergePolicy Fields
LogMergePolicy Class See Also Send Feedback

The LogMergePolicy type exposes the following members.

Fields

 | Name | Description
Protected field | calibrateSizeByDeletes |
 | DEFAULT_MAX_MERGE_DOCS | Default maximum segment size. A segment of this size
 | DEFAULT_MERGE_FACTOR | Default merge factor, which is how many segments are merged at a time
 | DEFAULT_NO_CFS_RATIO | Default noCFSRatio. If a merge's size is >= 10% of the index, then we disable compound file for it. @see #setNoCFSRatio
 | LEVEL_LOG_SPAN | Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minus LEVEL_LOG_SPAN, and finding all segments falling within that range.
Protected field | noCFSRatio |
Protected field | writer | (Inherited from MergePolicy.)

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


calibrateSizeByDeletes Field

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..calibrateSizeByDeletes Field
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.LogMergePolicy.calibrateSizeByDeletes"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool calibrateSizeByDeletes
Visual Basic
Protected Friend calibrateSizeByDeletes As Boolean
Visual C++
protected public:
bool calibrateSizeByDeletes

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


DEFAULT_MAX_MERGE_DOCS Field

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..DEFAULT_MAX_MERGE_DOCS Field
LogMergePolicy Class See Also Send Feedback
Default maximum segment size. A segment of this size

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int DEFAULT_MAX_MERGE_DOCS
Visual Basic
Public Shared ReadOnly DEFAULT_MAX_MERGE_DOCS As Integer
Visual C++
public:
static initonly int DEFAULT_MAX_MERGE_DOCS

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace
[!:setMaxMergeDocs]


DEFAULT_MERGE_FACTOR Field

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..DEFAULT_MERGE_FACTOR Field
LogMergePolicy Class See Also Send Feedback
Default merge factor, which is how many segments are merged at a time

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT_MERGE_FACTOR
Visual Basic
Public Const DEFAULT_MERGE_FACTOR As Integer
Visual C++
public:
literal int DEFAULT_MERGE_FACTOR

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


DEFAULT_NO_CFS_RATIO Field

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..DEFAULT_NO_CFS_RATIO Field
LogMergePolicy Class See Also Send Feedback
Default noCFSRatio. If a merge's size is >= 10% of the index, then we disable compound file for it. @see #setNoCFSRatio

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static double DEFAULT_NO_CFS_RATIO
Visual Basic
Public Shared DEFAULT_NO_CFS_RATIO As Double
Visual C++
public:
static double DEFAULT_NO_CFS_RATIO

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


LEVEL_LOG_SPAN Field

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..LEVEL_LOG_SPAN Field
LogMergePolicy Class See Also Send Feedback
Defines the allowed range of log(size) for each level. A level is computed by taking the max segment log size, minus LEVEL_LOG_SPAN, and finding all segments falling within that range.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const double LEVEL_LOG_SPAN
Visual Basic
Public Const LEVEL_LOG_SPAN As Double
Visual C++
public:
literal double LEVEL_LOG_SPAN

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


noCFSRatio Field

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..noCFSRatio Field
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.LogMergePolicy.noCFSRatio"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected double noCFSRatio
Visual Basic
Protected noCFSRatio As Double
Visual C++
protected:
double noCFSRatio

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


LogMergePolicy Methods

[image] [image]

Lucene.Net Class Libraries
LogMergePolicy Methods
LogMergePolicy Class See Also Send Feedback

The LogMergePolicy type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides MergePolicy..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency. (Overrides MergePolicy..::..FindMerges(SegmentInfos).)
Public method | FindMergesForOptimize | Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency. (Overrides MergePolicy..::..FindMergesForOptimize(SegmentInfos, Int32, Hashtable).)
Public method | FindMergesToExpungeDeletes | Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time. (Overrides MergePolicy..::..FindMergesToExpungeDeletes(SegmentInfos).)
Public method | GetCalibrateSizeByDeletes | Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxMergeDocs | Returns the largest segment (measured by document count) that may be merged with other segments.
Public method | GetMergeFactor | Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.
Public method | GetNoCFSRatio |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundDocStore | Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)
Public method | GetUseCompoundFile | Returns true if newly flushed and newly merge segments
Protected method | MakeOneMerge |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCalibrateSizeByDeletes | Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge.
Public method | SetMaxMergeDocs | Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches. The default value is {@link Integer#MAX_VALUE}. The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.
Public method | SetMergeFactor | Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.
Public method | SetNoCFSRatio |
Public method | SetUseCompoundDocStore | Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).
Public method | SetUseCompoundFile | Sets whether compound file format should be used for newly flushed and newly merged segments.
Protected method | Size |
Protected method | SizeBytes |
Protected method | SizeDocs |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | (Overrides MergePolicy..::..UseCompoundDocStore(SegmentInfos).)
Public method | UseCompoundFile | (Overrides MergePolicy..::..UseCompoundFile(SegmentInfos, SegmentInfo).)
Protected method | Verbose |

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..Close Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


FindMerges Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..FindMerges Method
LogMergePolicy Class See Also Send Feedback
Checks if any merges are now necessary and returns a {@link MergePolicy.MergeSpecification} if so. A merge is necessary when there are more than {@link #setMergeFactor} segments at a given level. When multiple levels have too many segments, this method will return multiple merges, allowing the {@link MergeScheduler} to use concurrency.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override MergePolicy..::..MergeSpecification FindMerges(
    SegmentInfos infos
)
Visual Basic
Public Overrides Function FindMerges ( _
    infos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Visual C++
public:
virtual MergePolicy..::..MergeSpecification^ FindMerges(
    SegmentInfos^ infos
) override

Parameters

infos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="infos"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMerges(Lucene.Net.Index.SegmentInfos)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMerges(Lucene.Net.Index.SegmentInfos)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


FindMergesForOptimize Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..FindMergesForOptimize Method
LogMergePolicy Class See Also Send Feedback
Returns the merges necessary to optimize the index. This merge policy defines "optimized" to mean only one segment in the index, where that segment has no deletions pending nor separate norms, and it is in compound file format if the current useCompoundFile setting is true. This method returns multiple merges (mergeFactor at a time) so the {@link MergeScheduler} in use may make use of concurrency.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override MergePolicy..::..MergeSpecification FindMergesForOptimize(
    SegmentInfos infos,
    int maxNumSegments,
    Hashtable segmentsToOptimize
)
Visual Basic
Public Overrides Function FindMergesForOptimize ( _
    infos As SegmentInfos, _
    maxNumSegments As Integer, _
    segmentsToOptimize As Hashtable _
) As MergePolicy..::..MergeSpecification
Visual C++
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesForOptimize(
    SegmentInfos^ infos,
    int maxNumSegments,
    Hashtable^ segmentsToOptimize
) override

Parameters

infos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="infos"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMergesForOptimize(Lucene.Net.Index.SegmentInfos,System.Int32,System.Collections.Hashtable)"]

maxNumSegments
Type: System..::..Int32

[Missing <param name="maxNumSegments"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMergesForOptimize(Lucene.Net.Index.SegmentInfos,System.Int32,System.Collections.Hashtable)"]

segmentsToOptimize
Type: System.Collections..::..Hashtable

[Missing <param name="segmentsToOptimize"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMergesForOptimize(Lucene.Net.Index.SegmentInfos,System.Int32,System.Collections.Hashtable)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMergesForOptimize(Lucene.Net.Index.SegmentInfos,System.Int32,System.Collections.Hashtable)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


FindMergesToExpungeDeletes Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..FindMergesToExpungeDeletes Method
LogMergePolicy Class See Also Send Feedback
Finds merges necessary to expunge all deletes from the index. We simply merge adjacent segments that have deletes, up to mergeFactor at a time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override MergePolicy..::..MergeSpecification FindMergesToExpungeDeletes(
    SegmentInfos segmentInfos
)
Visual Basic
Public Overrides Function FindMergesToExpungeDeletes ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Visual C++
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesToExpungeDeletes(
    SegmentInfos^ segmentInfos
) override

Parameters

segmentInfos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="segmentInfos"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMergesToExpungeDeletes(Lucene.Net.Index.SegmentInfos)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.FindMergesToExpungeDeletes(Lucene.Net.Index.SegmentInfos)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


GetCalibrateSizeByDeletes Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..GetCalibrateSizeByDeletes Method
LogMergePolicy Class See Also Send Feedback
Returns true if the segment size should be calibrated by the number of deletes when choosing segments for merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetCalibrateSizeByDeletes()
Visual Basic
Public Overridable Function GetCalibrateSizeByDeletes As Boolean
Visual C++
public:
virtual bool GetCalibrateSizeByDeletes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetCalibrateSizeByDeletes"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


GetMaxMergeDocs Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..GetMaxMergeDocs Method
LogMergePolicy Class See Also Send Feedback
Returns the largest segment (measured by document count) that may be merged with other segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxMergeDocs()
Visual Basic
Public Overridable Function GetMaxMergeDocs As Integer
Visual C++
public:
virtual int GetMaxMergeDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetMaxMergeDocs"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace
[!:setMaxMergeDocs]


GetMergeFactor Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..GetMergeFactor Method
LogMergePolicy Class See Also Send Feedback

Returns the number of segments that are merged at once and also controls the total number of segments allowed to accumulate in the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMergeFactor()
Visual Basic
Public Overridable Function GetMergeFactor As Integer
Visual C++
public:
virtual int GetMergeFactor()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetMergeFactor"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


GetNoCFSRatio Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..GetNoCFSRatio Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetNoCFSRatio"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public double GetNoCFSRatio()
Visual Basic
Public Function GetNoCFSRatio As Double
Visual C++
public:
double GetNoCFSRatio()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetNoCFSRatio"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


GetUseCompoundDocStore Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..GetUseCompoundDocStore Method
LogMergePolicy Class See Also Send Feedback
Returns true if newly flushed and newly merge doc store segment files (term vectors and stored fields)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetUseCompoundDocStore()
Visual Basic
Public Overridable Function GetUseCompoundDocStore As Boolean
Visual C++
public:
virtual bool GetUseCompoundDocStore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetUseCompoundDocStore"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace
LogMergePolicy..::..SetUseCompoundDocStore(Boolean)


GetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..GetUseCompoundFile Method
LogMergePolicy Class See Also Send Feedback
Returns true if newly flushed and newly merge segments

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetUseCompoundFile()
Visual Basic
Public Overridable Function GetUseCompoundFile As Boolean
Visual C++
public:
virtual bool GetUseCompoundFile()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.GetUseCompoundFile"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace
LogMergePolicy..::..SetUseCompoundFile(Boolean)


MakeOneMerge Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..MakeOneMerge Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.MakeOneMerge(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfos)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected MergePolicy..::..OneMerge MakeOneMerge(
    SegmentInfos infos,
    SegmentInfos infosToMerge
)
Visual Basic
Protected Function MakeOneMerge ( _
    infos As SegmentInfos, _
    infosToMerge As SegmentInfos _
) As MergePolicy..::..OneMerge
Visual C++
protected:
MergePolicy..::..OneMerge^ MakeOneMerge(
    SegmentInfos^ infos,
    SegmentInfos^ infosToMerge
)

Parameters

infos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="infos"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.MakeOneMerge(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfos)"]

infosToMerge
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="infosToMerge"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.MakeOneMerge(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfos)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.MakeOneMerge(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfos)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SetCalibrateSizeByDeletes Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SetCalibrateSizeByDeletes Method
LogMergePolicy Class See Also Send Feedback
Sets whether the segment size should be calibrated by the number of deletes when choosing segments for merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetCalibrateSizeByDeletes(
    bool calibrateSizeByDeletes
)
Visual Basic
Public Overridable Sub SetCalibrateSizeByDeletes ( _
    calibrateSizeByDeletes As Boolean _
)
Visual C++
public:
virtual void SetCalibrateSizeByDeletes(
    bool calibrateSizeByDeletes
)

Parameters

calibrateSizeByDeletes
Type: System..::..Boolean

[Missing <param name="calibrateSizeByDeletes"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetCalibrateSizeByDeletes(System.Boolean)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SetMaxMergeDocs Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SetMaxMergeDocs Method
LogMergePolicy Class See Also Send Feedback

Determines the largest segment (measured by document count) that may be merged with other segments. Small values (e.g., less than 10,000) are best for interactive indexing, as this limits the length of pauses while indexing to a few seconds. Larger values are best for batched indexing and speedier searches.

The default value is {@link Integer#MAX_VALUE}.

The default merge policy ({@link LogByteSizeMergePolicy}) also allows you to set this limit by net size (in MB) of the segment, using {@link LogByteSizeMergePolicy#setMaxMergeMB}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxMergeDocs(
    int maxMergeDocs
)
Visual Basic
Public Overridable Sub SetMaxMergeDocs ( _
    maxMergeDocs As Integer _
)
Visual C++
public:
virtual void SetMaxMergeDocs(
    int maxMergeDocs
)

Parameters

maxMergeDocs
Type: System..::..Int32

[Missing <param name="maxMergeDocs"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetMaxMergeDocs(System.Int32)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SetMergeFactor Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SetMergeFactor Method
LogMergePolicy Class See Also Send Feedback
Determines how often segment indices are merged by addDocument(). With smaller values, less RAM is used while indexing, and searches on unoptimized indices are faster, but indexing speed is slower. With larger values, more RAM is used during indexing, and while searches on unoptimized indices are slower, indexing is faster. Thus larger values (> 10) are best for batch index creation, and smaller values (< 10) for indices that are interactively maintained.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMergeFactor(
    int mergeFactor
)
Visual Basic
Public Overridable Sub SetMergeFactor ( _
    mergeFactor As Integer _
)
Visual C++
public:
virtual void SetMergeFactor(
    int mergeFactor
)

Parameters

mergeFactor
Type: System..::..Int32

[Missing <param name="mergeFactor"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetMergeFactor(System.Int32)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SetNoCFSRatio Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SetNoCFSRatio Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetNoCFSRatio(System.Double)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetNoCFSRatio(
    double noCFSRatio
)
Visual Basic
Public Sub SetNoCFSRatio ( _
    noCFSRatio As Double _
)
Visual C++
public:
void SetNoCFSRatio(
    double noCFSRatio
)

Parameters

noCFSRatio
Type: System..::..Double

[Missing <param name="noCFSRatio"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetNoCFSRatio(System.Double)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SetUseCompoundDocStore Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SetUseCompoundDocStore Method
LogMergePolicy Class See Also Send Feedback
Sets whether compound file format should be used for newly flushed and newly merged doc store segment files (term vectors and stored fields).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetUseCompoundDocStore(
    bool useCompoundDocStore
)
Visual Basic
Public Overridable Sub SetUseCompoundDocStore ( _
    useCompoundDocStore As Boolean _
)
Visual C++
public:
virtual void SetUseCompoundDocStore(
    bool useCompoundDocStore
)

Parameters

useCompoundDocStore
Type: System..::..Boolean

[Missing <param name="useCompoundDocStore"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetUseCompoundDocStore(System.Boolean)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SetUseCompoundFile Method
LogMergePolicy Class See Also Send Feedback
Sets whether compound file format should be used for newly flushed and newly merged segments.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetUseCompoundFile(
    bool useCompoundFile
)
Visual Basic
Public Overridable Sub SetUseCompoundFile ( _
    useCompoundFile As Boolean _
)
Visual C++
public:
virtual void SetUseCompoundFile(
    bool useCompoundFile
)

Parameters

useCompoundFile
Type: System..::..Boolean

[Missing <param name="useCompoundFile"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SetUseCompoundFile(System.Boolean)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..Size Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract long Size(
    SegmentInfo info
)
Visual Basic
Protected Friend MustOverride Function Size ( _
    info As SegmentInfo _
) As Long
Visual C++
protected public:
virtual long long Size(
    SegmentInfo^ info
) abstract

Parameters

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.Size(Lucene.Net.Index.SegmentInfo)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SizeBytes Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SizeBytes Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.SizeBytes(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual long SizeBytes(
    SegmentInfo info
)
Visual Basic
Protected Friend Overridable Function SizeBytes ( _
    info As SegmentInfo _
) As Long
Visual C++
protected public:
virtual long long SizeBytes(
    SegmentInfo^ info
)

Parameters

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SizeBytes(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.SizeBytes(Lucene.Net.Index.SegmentInfo)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


SizeDocs Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..SizeDocs Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.SizeDocs(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual long SizeDocs(
    SegmentInfo info
)
Visual Basic
Protected Friend Overridable Function SizeDocs ( _
    info As SegmentInfo _
) As Long
Visual C++
protected public:
virtual long long SizeDocs(
    SegmentInfo^ info
)

Parameters

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.SizeDocs(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.SizeDocs(Lucene.Net.Index.SegmentInfo)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


UseCompoundDocStore Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..UseCompoundDocStore Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundDocStore(Lucene.Net.Index.SegmentInfos)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool UseCompoundDocStore(
    SegmentInfos infos
)
Visual Basic
Public Overrides Function UseCompoundDocStore ( _
    infos As SegmentInfos _
) As Boolean
Visual C++
public:
virtual bool UseCompoundDocStore(
    SegmentInfos^ infos
) override

Parameters

infos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="infos"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundDocStore(Lucene.Net.Index.SegmentInfos)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundDocStore(Lucene.Net.Index.SegmentInfos)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


UseCompoundFile Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..UseCompoundFile Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool UseCompoundFile(
    SegmentInfos infos,
    SegmentInfo info
)
Visual Basic
Public Overrides Function UseCompoundFile ( _
    infos As SegmentInfos, _
    info As SegmentInfo _
) As Boolean
Visual C++
public:
virtual bool UseCompoundFile(
    SegmentInfos^ infos,
    SegmentInfo^ info
) override

Parameters

infos
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="infos"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

info
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


Verbose Method

[image]

Lucene.Net Class Libraries
LogMergePolicy..::..Verbose Method
LogMergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.LogMergePolicy.Verbose"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual bool Verbose()
Visual Basic
Protected Friend Overridable Function Verbose As Boolean
Visual C++
protected public:
virtual bool Verbose()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.LogMergePolicy.Verbose"]

See Also

LogMergePolicy Class
Lucene.Net.Index Namespace


LongFieldEnumerator Class

[image]

Lucene.Net Class Libraries
LongFieldEnumerator Class
Members See Also Send Feedback
Implementation for enumerating over all of the terms in a long numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class LongFieldEnumerator : NumericFieldEnum<long>
Visual Basic
Public Class LongFieldEnumerator _
    Inherits NumericFieldEnum(Of Long)
Visual C++
public ref class LongFieldEnumerator : public NumericFieldEnum<long long>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator <(Of <(<' Int64 >)>)>
Lucene.Net.Index..::..NumericFieldEnum <(Of <(<' Int64 >)>)>
Lucene.Net.Index..::..LongFieldEnumerator

See Also

LongFieldEnumerator Members
Lucene.Net.Index Namespace


LongFieldEnumerator Members

[image] [image]

Lucene.Net Class Libraries
LongFieldEnumerator Members
LongFieldEnumerator Class Constructors Methods Fields Properties See Also Send Feedback

The LongFieldEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | LongFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | LongFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the long from a numeric field. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the long from a string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

LongFieldEnumerator Class
Lucene.Net.Index Namespace


LongFieldEnumerator Constructor

[image] [image]

Lucene.Net Class Libraries
LongFieldEnumerator Constructor
LongFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LongFieldEnumerator(IndexReader, String, FieldParser) | Construct an enumerator over one field.
Public method | LongFieldEnumerator(IndexReader, String, FieldParser, Boolean) | Construct an enumerator over one field.

See Also

LongFieldEnumerator Class
LongFieldEnumerator Members
Lucene.Net.Index Namespace


LongFieldEnumerator Constructor (IndexReader, String, FieldParser)

[image]

Lucene.Net Class Libraries
LongFieldEnumerator Constructor (IndexReader, String, FieldParser)
LongFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public LongFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser _
)
Visual C++
public:
LongFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.LongFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser)"]

See Also

LongFieldEnumerator Class
LongFieldEnumerator Overload
Lucene.Net.Index Namespace


LongFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)

[image]

Lucene.Net Class Libraries
LongFieldEnumerator Constructor (IndexReader, String, FieldParser, Boolean)
LongFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public LongFieldEnumerator(
    IndexReader reader,
    string fieldName,
    FieldParser parser,
    bool includeDocs
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    parser As FieldParser, _
    includeDocs As Boolean _
)
Visual C++
public:
LongFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    FieldParser parser,
    bool includeDocs
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
parser
Type: Lucene.Net.Index..::..FieldParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Index.LongFieldEnumerator.#ctor(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Index.FieldParser,System.Boolean)"]

includeDocs
Type: System..::..Boolean
Whether the TermDocs will also be enumerated.

See Also

LongFieldEnumerator Class
LongFieldEnumerator Overload
Lucene.Net.Index Namespace


LongFieldEnumerator Fields

[image] [image]

Lucene.Net Class Libraries
LongFieldEnumerator Fields
LongFieldEnumerator Class See Also Send Feedback

The LongFieldEnumerator type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

LongFieldEnumerator Class
Lucene.Net.Index Namespace


LongFieldEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
LongFieldEnumerator Methods
LongFieldEnumerator Class See Also Send Feedback

The LongFieldEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)
Protected method | TryParseNumeric | Parse the long from a numeric field. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric(String).)
Protected method | TryParseString | Parse the long from a string. (Overrides NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString(String).)

See Also

LongFieldEnumerator Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
LongFieldEnumerator..::..Init Method
LongFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance. (Inherited from NumericFieldEnum<(Of <(<'T>)>)>.)

See Also

LongFieldEnumerator Class
LongFieldEnumerator Members
Lucene.Net.Index Namespace


TryParseNumeric Method

[image]

Lucene.Net Class Libraries
LongFieldEnumerator..::..TryParseNumeric Method
LongFieldEnumerator Class See Also Send Feedback
Parse the long from a numeric field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseNumeric(
    string s
)
Visual Basic
Protected Overrides Function TryParseNumeric ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseNumeric(
    String^ s
) override

Parameters

s
Type: System..::..String
The string to parse.

Return Value

True if the string was parsed, false to inidicate the end of usable terms in a numeric field.

See Also

LongFieldEnumerator Class
Lucene.Net.Index Namespace


TryParseString Method

[image]

Lucene.Net Class Libraries
LongFieldEnumerator..::..TryParseString Method
LongFieldEnumerator Class See Also Send Feedback
Parse the long from a string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParseString(
    string s
)
Visual Basic
Protected Overrides Function TryParseString ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseString(
    String^ s
) override

Parameters

s
Type: System..::..String
The string to parse.

Return Value

Always true.

See Also

LongFieldEnumerator Class
Lucene.Net.Index Namespace


LongFieldEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
LongFieldEnumerator Properties
LongFieldEnumerator Class See Also Send Feedback

The LongFieldEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

LongFieldEnumerator Class
Lucene.Net.Index Namespace


MergePolicy Class

[image]

Lucene.Net Class Libraries
MergePolicy Class
Members See Also Send Feedback

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g.

CopyC#
SegmentInfos
) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class MergePolicy
Visual Basic
Public MustInherit Class MergePolicy
Visual C++
public ref class MergePolicy abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergePolicy
Lucene.Net.Index..::..LogMergePolicy

See Also

MergePolicy Members
Lucene.Net.Index Namespace


MergePolicy Members

[image] [image]

Lucene.Net Class Libraries
MergePolicy Members
MergePolicy Class Constructors Methods Fields See Also Send Feedback

The MergePolicy type exposes the following members.

Constructors

 | Name | Description
Public method | MergePolicy | Initializes a new instance of the MergePolicy class

Methods

 | Name | Description
Public method | Close | Release all resources for the policy.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Determine what set of merge operations are now necessary on the index. {@link IndexWriter} calls this whenever there is a change to the segments. This call is always synchronized on the {@link IndexWriter} instance so only one thread at a time will call this method.
Public method | FindMergesForOptimize | Determine what set of merge operations is necessary in order to optimize the index. {@link IndexWriter} calls this when its {@link IndexWriter#Optimize()} method is called. This call is always synchronized on the {@link IndexWriter} instance so only one thread at a time will call this method.
Public method | FindMergesToExpungeDeletes | Determine what set of merge operations is necessary in order to expunge all deletes from the index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | Returns true if the doc store files should use the compound file format.
Public method | UseCompoundFile | Returns true if a newly flushed (not from merge) segment should use the compound file format.

Fields

 | Name | Description
Protected field | writer |

See Also

MergePolicy Class
Lucene.Net.Index Namespace


MergePolicy Constructor

[image]

Lucene.Net Class Libraries
MergePolicy Constructor
MergePolicy Class See Also Send Feedback
Initializes a new instance of the MergePolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergePolicy(
    IndexWriter writer
)
Visual Basic
Public Sub New ( _
    writer As IndexWriter _
)
Visual C++
public:
MergePolicy(
    IndexWriter^ writer
)

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.MergePolicy.#ctor(Lucene.Net.Index.IndexWriter)"]

See Also

MergePolicy Class
Lucene.Net.Index Namespace


MergePolicy Fields

[image] [image]

Lucene.Net Class Libraries
MergePolicy Fields
MergePolicy Class See Also Send Feedback

The MergePolicy type exposes the following members.

Fields

 | Name | Description
Protected field | writer |

See Also

MergePolicy Class
Lucene.Net.Index Namespace


writer Field

[image]

Lucene.Net Class Libraries
MergePolicy..::..writer Field
MergePolicy Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.MergePolicy.writer"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexWriter writer
Visual Basic
Protected Friend writer As IndexWriter
Visual C++
protected public:
IndexWriter^ writer

See Also

MergePolicy Class
Lucene.Net.Index Namespace


MergePolicy Methods

[image] [image]

Lucene.Net Class Libraries
MergePolicy Methods
MergePolicy Class See Also Send Feedback

The MergePolicy type exposes the following members.

Methods

 | Name | Description
Public method | Close | Release all resources for the policy.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMerges | Determine what set of merge operations are now necessary on the index. {@link IndexWriter} calls this whenever there is a change to the segments. This call is always synchronized on the {@link IndexWriter} instance so only one thread at a time will call this method.
Public method | FindMergesForOptimize | Determine what set of merge operations is necessary in order to optimize the index. {@link IndexWriter} calls this when its {@link IndexWriter#Optimize()} method is called. This call is always synchronized on the {@link IndexWriter} instance so only one thread at a time will call this method.
Public method | FindMergesToExpungeDeletes | Determine what set of merge operations is necessary in order to expunge all deletes from the index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseCompoundDocStore | Returns true if the doc store files should use the compound file format.
Public method | UseCompoundFile | Returns true if a newly flushed (not from merge) segment should use the compound file format.

See Also

MergePolicy Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..Close Method
MergePolicy Class See Also Send Feedback
Release all resources for the policy.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

MergePolicy Class
Lucene.Net.Index Namespace


FindMerges Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..FindMerges Method
MergePolicy Class See Also Send Feedback
Determine what set of merge operations are now necessary on the index. {@link IndexWriter} calls this whenever there is a change to the segments. This call is always synchronized on the {@link IndexWriter} instance so only one thread at a time will call this method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract MergePolicy..::..MergeSpecification FindMerges(
    SegmentInfos segmentInfos
)
Visual Basic
Public MustOverride Function FindMerges ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Visual C++
public:
virtual MergePolicy..::..MergeSpecification^ FindMerges(
    SegmentInfos^ segmentInfos
) abstract

Parameters

segmentInfos
Type: Lucene.Net.Index..::..SegmentInfos
the total set of segments in the index

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.FindMerges(Lucene.Net.Index.SegmentInfos)"]

See Also

MergePolicy Class
Lucene.Net.Index Namespace


FindMergesForOptimize Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..FindMergesForOptimize Method
MergePolicy Class See Also Send Feedback
Determine what set of merge operations is necessary in order to optimize the index. {@link IndexWriter} calls this when its {@link IndexWriter#Optimize()} method is called. This call is always synchronized on the {@link IndexWriter} instance so only one thread at a time will call this method.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract MergePolicy..::..MergeSpecification FindMergesForOptimize(
    SegmentInfos segmentInfos,
    int maxSegmentCount,
    Hashtable segmentsToOptimize
)
Visual Basic
Public MustOverride Function FindMergesForOptimize ( _
    segmentInfos As SegmentInfos, _
    maxSegmentCount As Integer, _
    segmentsToOptimize As Hashtable _
) As MergePolicy..::..MergeSpecification
Visual C++
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesForOptimize(
    SegmentInfos^ segmentInfos,
    int maxSegmentCount,
    Hashtable^ segmentsToOptimize
) abstract

Parameters

segmentInfos
Type: Lucene.Net.Index..::..SegmentInfos
the total set of segments in the index
maxSegmentCount
Type: System..::..Int32
requested maximum number of segments in the index (currently this is always 1)
segmentsToOptimize
Type: System.Collections..::..Hashtable
contains the specific SegmentInfo instances that must be merged away. This may be a subset of all SegmentInfos.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.FindMergesForOptimize(Lucene.Net.Index.SegmentInfos,System.Int32,System.Collections.Hashtable)"]

See Also

MergePolicy Class
Lucene.Net.Index Namespace


FindMergesToExpungeDeletes Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..FindMergesToExpungeDeletes Method
MergePolicy Class See Also Send Feedback
Determine what set of merge operations is necessary in order to expunge all deletes from the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract MergePolicy..::..MergeSpecification FindMergesToExpungeDeletes(
    SegmentInfos segmentInfos
)
Visual Basic
Public MustOverride Function FindMergesToExpungeDeletes ( _
    segmentInfos As SegmentInfos _
) As MergePolicy..::..MergeSpecification
Visual C++
public:
virtual MergePolicy..::..MergeSpecification^ FindMergesToExpungeDeletes(
    SegmentInfos^ segmentInfos
) abstract

Parameters

segmentInfos
Type: Lucene.Net.Index..::..SegmentInfos
the total set of segments in the index

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.FindMergesToExpungeDeletes(Lucene.Net.Index.SegmentInfos)"]

See Also

MergePolicy Class
Lucene.Net.Index Namespace


UseCompoundDocStore Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..UseCompoundDocStore Method
MergePolicy Class See Also Send Feedback
Returns true if the doc store files should use the compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool UseCompoundDocStore(
    SegmentInfos segments
)
Visual Basic
Public MustOverride Function UseCompoundDocStore ( _
    segments As SegmentInfos _
) As Boolean
Visual C++
public:
virtual bool UseCompoundDocStore(
    SegmentInfos^ segments
) abstract

Parameters

segments
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="segments"/> documentation for "M:Lucene.Net.Index.MergePolicy.UseCompoundDocStore(Lucene.Net.Index.SegmentInfos)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.UseCompoundDocStore(Lucene.Net.Index.SegmentInfos)"]

See Also

MergePolicy Class
Lucene.Net.Index Namespace


UseCompoundFile Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..UseCompoundFile Method
MergePolicy Class See Also Send Feedback
Returns true if a newly flushed (not from merge) segment should use the compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool UseCompoundFile(
    SegmentInfos segments,
    SegmentInfo newSegment
)
Visual Basic
Public MustOverride Function UseCompoundFile ( _
    segments As SegmentInfos, _
    newSegment As SegmentInfo _
) As Boolean
Visual C++
public:
virtual bool UseCompoundFile(
    SegmentInfos^ segments,
    SegmentInfo^ newSegment
) abstract

Parameters

segments
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="segments"/> documentation for "M:Lucene.Net.Index.MergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

newSegment
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="newSegment"/> documentation for "M:Lucene.Net.Index.MergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.UseCompoundFile(Lucene.Net.Index.SegmentInfos,Lucene.Net.Index.SegmentInfo)"]

See Also

MergePolicy Class
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Class

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Class
MergePolicy Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.MergePolicy.MergeAbortedException"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MergeAbortedException : IOException
Visual Basic
<SerializableAttribute> _
Public Class MergeAbortedException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class MergeAbortedException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Lucene.Net.Index..::..MergePolicy..::..MergeAbortedException

See Also

MergePolicy..::..MergeAbortedException Members
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Members

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Members
MergePolicy..::..MergeAbortedException Class Constructors Methods Properties Events See Also Send Feedback

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g.

CopyC#
SegmentInfos
) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy..::..MergeAbortedException type exposes the following members.

Constructors

 | Name | Description
Public method | MergePolicy..::..MergeAbortedException()()()() | Initializes a new instance of the MergePolicy..::..MergeAbortedException class
Public method | MergePolicy..::..MergeAbortedException(String) | Initializes a new instance of the MergePolicy..::..MergeAbortedException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeAbortedException Class
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Constructor

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Constructor
MergePolicy..::..MergeAbortedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MergePolicy..::..MergeAbortedException()()()() | Initializes a new instance of the MergePolicy..::..MergeAbortedException class
Public method | MergePolicy..::..MergeAbortedException(String) | Initializes a new instance of the MergePolicy..::..MergeAbortedException class

See Also

MergePolicy..::..MergeAbortedException Class
MergePolicy..::..MergeAbortedException Members
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Constructor

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Constructor
MergePolicy..::..MergeAbortedException Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeAbortedException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergeAbortedException()
Visual Basic
Public Sub New
Visual C++
public:
MergeAbortedException()

See Also

MergePolicy..::..MergeAbortedException Class
MergePolicy..::..MergeAbortedException Overload
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Constructor (String)

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Constructor (String)
MergePolicy..::..MergeAbortedException Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeAbortedException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergeAbortedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MergeAbortedException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeAbortedException.#ctor(System.String)"]

See Also

MergePolicy..::..MergeAbortedException Class
MergePolicy..::..MergeAbortedException Overload
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Methods

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Methods
MergePolicy..::..MergeAbortedException Class See Also Send Feedback

The MergePolicy..::..MergeAbortedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeAbortedException Class
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Properties

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Properties
MergePolicy..::..MergeAbortedException Class See Also Send Feedback

The MergePolicy..::..MergeAbortedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeAbortedException Class
Lucene.Net.Index Namespace


MergePolicy.MergeAbortedException Events

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeAbortedException Events
MergePolicy..::..MergeAbortedException Class See Also Send Feedback

The MergePolicy..::..MergeAbortedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeAbortedException Class
Lucene.Net.Index Namespace


MergePolicy.MergeException Class

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Class
MergePolicy Class Members See Also Send Feedback
Exception thrown if there are any problems while executing a merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MergeException : SystemException
Visual Basic
<SerializableAttribute> _
Public Class MergeException _
    Inherits SystemException
Visual C++
[SerializableAttribute]
public ref class MergeException : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Lucene.Net.Index..::..MergePolicy..::..MergeException

See Also

MergePolicy..::..MergeException Members
Lucene.Net.Index Namespace


MergePolicy.MergeException Members

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Members
MergePolicy..::..MergeException Class Constructors Methods Properties Events See Also Send Feedback

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g.

CopyC#
SegmentInfos
) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy..::..MergeException type exposes the following members.

Constructors

 | Name | Description
Public method | MergePolicy..::..MergeException(Exception) | Obsolete. Initializes a new instance of the MergePolicy..::..MergeException class
Public method | MergePolicy..::..MergeException(String) | Obsolete. Initializes a new instance of the MergePolicy..::..MergeException class
Public method | MergePolicy..::..MergeException(Exception, Directory) | Initializes a new instance of the MergePolicy..::..MergeException class
Public method | MergePolicy..::..MergeException(String, Directory) | Initializes a new instance of the MergePolicy..::..MergeException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetDirectory | Returns the {@link Directory} of the index that hit the exception.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeException Class
Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Constructor
MergePolicy..::..MergeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MergePolicy..::..MergeException(Exception) | Obsolete. Initializes a new instance of the MergePolicy..::..MergeException class
Public method | MergePolicy..::..MergeException(String) | Obsolete. Initializes a new instance of the MergePolicy..::..MergeException class
Public method | MergePolicy..::..MergeException(Exception, Directory) | Initializes a new instance of the MergePolicy..::..MergeException class
Public method | MergePolicy..::..MergeException(String, Directory) | Initializes a new instance of the MergePolicy..::..MergeException class

See Also

MergePolicy..::..MergeException Class
MergePolicy..::..MergeException Members
Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor (Exception)

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Constructor (Exception)
MergePolicy..::..MergeException Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use MergePolicy.MergeException(Throwable,Directory) instead ")]
public MergeException(
    Exception exc
)
Visual Basic
<ObsoleteAttribute("Use MergePolicy.MergeException(Throwable,Directory) instead ")> _
Public Sub New ( _
    exc As Exception _
)
Visual C++
[ObsoleteAttribute(L"Use MergePolicy.MergeException(Throwable,Directory) instead ")]
public:
MergeException(
    Exception^ exc
)

Parameters

exc
Type: System..::..Exception

[Missing <param name="exc"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.#ctor(System.Exception)"]

See Also

MergePolicy..::..MergeException Class
MergePolicy..::..MergeException Overload
Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor (String)

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Constructor (String)
MergePolicy..::..MergeException Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use MergePolicy.MergeException(String,Directory) instead ")]
public MergeException(
    string message
)
Visual Basic
<ObsoleteAttribute("Use MergePolicy.MergeException(String,Directory) instead ")> _
Public Sub New ( _
    message As String _
)
Visual C++
[ObsoleteAttribute(L"Use MergePolicy.MergeException(String,Directory) instead ")]
public:
MergeException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.#ctor(System.String)"]

See Also

MergePolicy..::..MergeException Class
MergePolicy..::..MergeException Overload
Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor (Exception, Directory)

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Constructor (Exception, Directory)
MergePolicy..::..MergeException Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergeException(
    Exception exc,
    Directory dir
)
Visual Basic
Public Sub New ( _
    exc As Exception, _
    dir As Directory _
)
Visual C++
public:
MergeException(
    Exception^ exc,
    Directory^ dir
)

Parameters

exc
Type: System..::..Exception

[Missing <param name="exc"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.#ctor(System.Exception,Lucene.Net.Store.Directory)"]

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.#ctor(System.Exception,Lucene.Net.Store.Directory)"]

See Also

MergePolicy..::..MergeException Class
MergePolicy..::..MergeException Overload
Lucene.Net.Index Namespace


MergePolicy.MergeException Constructor (String, Directory)

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Constructor (String, Directory)
MergePolicy..::..MergeException Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergeException(
    string message,
    Directory dir
)
Visual Basic
Public Sub New ( _
    message As String, _
    dir As Directory _
)
Visual C++
public:
MergeException(
    String^ message,
    Directory^ dir
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.#ctor(System.String,Lucene.Net.Store.Directory)"]

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.#ctor(System.String,Lucene.Net.Store.Directory)"]

See Also

MergePolicy..::..MergeException Class
MergePolicy..::..MergeException Overload
Lucene.Net.Index Namespace


MergePolicy.MergeException Methods

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Methods
MergePolicy..::..MergeException Class See Also Send Feedback

The MergePolicy..::..MergeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetDirectory | Returns the {@link Directory} of the index that hit the exception.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeException Class
Lucene.Net.Index Namespace


GetDirectory Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException..::..GetDirectory Method
MergePolicy..::..MergeException Class See Also Send Feedback
Returns the {@link Directory} of the index that hit the exception.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Directory GetDirectory()
Visual Basic
Public Overridable Function GetDirectory As Directory
Visual C++
public:
virtual Directory^ GetDirectory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.MergeException.GetDirectory"]

See Also

MergePolicy..::..MergeException Class
Lucene.Net.Index Namespace


MergePolicy.MergeException Properties

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Properties
MergePolicy..::..MergeException Class See Also Send Feedback

The MergePolicy..::..MergeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeException Class
Lucene.Net.Index Namespace


MergePolicy.MergeException Events

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeException Events
MergePolicy..::..MergeException Class See Also Send Feedback

The MergePolicy..::..MergeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MergePolicy..::..MergeException Class
Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Class

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification Class
MergePolicy Class Members See Also Send Feedback
A MergeSpecification instance provides the information necessary to perform multiple merges. It simply contains a list of {@link OneMerge} instances.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MergeSpecification
Visual Basic
Public Class MergeSpecification
Visual C++
public ref class MergeSpecification

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergePolicy..::..MergeSpecification

See Also

MergePolicy..::..MergeSpecification Members
Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Members

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification Members
MergePolicy..::..MergeSpecification Class Constructors Methods Fields See Also Send Feedback

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g.

CopyC#
SegmentInfos
) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy..::..MergeSpecification type exposes the following members.

Constructors

 | Name | Description
Public method | MergePolicy..::..MergeSpecification | Initializes a new instance of the MergePolicy..::..MergeSpecification class

Methods

 | Name | Description
Public method | Add |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SegString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | merges | The subset of segments to be included in the primitive merge.

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Constructor

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification Constructor
MergePolicy..::..MergeSpecification Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..MergeSpecification class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MergeSpecification()
Visual Basic
Public Sub New
Visual C++
public:
MergeSpecification()

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Fields

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification Fields
MergePolicy..::..MergeSpecification Class See Also Send Feedback

The MergePolicy..::..MergeSpecification type exposes the following members.

Fields

 | Name | Description
Public field | merges | The subset of segments to be included in the primitive merge.

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


merges Field

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification..::..merges Field
MergePolicy..::..MergeSpecification Class See Also Send Feedback
The subset of segments to be included in the primitive merge.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IList merges
Visual Basic
Public merges As IList
Visual C++
public:
IList^ merges

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


MergePolicy.MergeSpecification Methods

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification Methods
MergePolicy..::..MergeSpecification Class See Also Send Feedback

The MergePolicy..::..MergeSpecification type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SegString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


Add Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification..::..Add Method
MergePolicy..::..MergeSpecification Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MergePolicy.MergeSpecification.Add(Lucene.Net.Index.MergePolicy.OneMerge)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    MergePolicy..::..OneMerge merge
)
Visual Basic
Public Overridable Sub Add ( _
    merge As MergePolicy..::..OneMerge _
)
Visual C++
public:
virtual void Add(
    MergePolicy..::..OneMerge^ merge
)

Parameters

merge
Type: Lucene.Net.Index..::..MergePolicy..::..OneMerge

[Missing <param name="merge"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeSpecification.Add(Lucene.Net.Index.MergePolicy.OneMerge)"]

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


SegString Method

[image]

Lucene.Net Class Libraries
MergePolicy..::..MergeSpecification..::..SegString Method
MergePolicy..::..MergeSpecification Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MergePolicy.MergeSpecification.SegString(Lucene.Net.Store.Directory)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string SegString(
    Directory dir
)
Visual Basic
Public Overridable Function SegString ( _
    dir As Directory _
) As String
Visual C++
public:
virtual String^ SegString(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.MergePolicy.MergeSpecification.SegString(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MergePolicy.MergeSpecification.SegString(Lucene.Net.Store.Directory)"]

See Also

MergePolicy..::..MergeSpecification Class
Lucene.Net.Index Namespace


MergePolicy.OneMerge Class

[image]

Lucene.Net Class Libraries
MergePolicy..::..OneMerge Class
MergePolicy Class Members See Also Send Feedback
OneMerge provides the information necessary to perform an individual primitive merge operation, resulting in a single new segment. The merge spec includes the subset of segments to be merged as well as whether the new segment should use the compound file format.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class OneMerge
Visual Basic
Public Class OneMerge
Visual C++
public ref class OneMerge

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergePolicy..::..OneMerge

See Also

MergePolicy..::..OneMerge Members
Lucene.Net.Index Namespace


MergePolicy.OneMerge Members

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..OneMerge Members
MergePolicy..::..OneMerge Class Constructors Methods Properties See Also Send Feedback

Expert: a MergePolicy determines the sequence of primitive merge operations to be used for overall merge and optimize operations.

Whenever the segments in an index have been altered by {@link IndexWriter}, either the addition of a newly flushed segment, addition of many segments from addIndexes* calls, or a previous merge that may now need to cascade, {@link IndexWriter} invokes {@link #findMerges} to give the MergePolicy a chance to pick merges that are now required. This method returns a {@link MergeSpecification} instance describing the set of merges that should be done, or null if no merges are necessary. When IndexWriter.optimize is called, it calls {@link #findMergesForOptimize} and the MergePolicy should then return the necessary merges.

Note that the policy can return more than one merge at a time. In this case, if the writer is using {@link SerialMergeScheduler}, the merges will be run sequentially but if it is using {@link ConcurrentMergeScheduler} they will be run concurrently.

The default MergePolicy is {@link LogByteSizeMergePolicy}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (e.g.

CopyC#
SegmentInfos
) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

The MergePolicy..::..OneMerge type exposes the following members.

Constructors

 | Name | Description
Public method | MergePolicy..::..OneMerge | Initializes a new instance of the MergePolicy..::..OneMerge class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | segments_ForNUnit |

See Also

MergePolicy..::..OneMerge Class
Lucene.Net.Index Namespace


MergePolicy.OneMerge Constructor

[image]

Lucene.Net Class Libraries
MergePolicy..::..OneMerge Constructor
MergePolicy..::..OneMerge Class See Also Send Feedback
Initializes a new instance of the MergePolicy..::..OneMerge class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OneMerge(
    SegmentInfos segments,
    bool useCompoundFile
)
Visual Basic
Public Sub New ( _
    segments As SegmentInfos, _
    useCompoundFile As Boolean _
)
Visual C++
public:
OneMerge(
    SegmentInfos^ segments,
    bool useCompoundFile
)

Parameters

segments
Type: Lucene.Net.Index..::..SegmentInfos

[Missing <param name="segments"/> documentation for "M:Lucene.Net.Index.MergePolicy.OneMerge.#ctor(Lucene.Net.Index.SegmentInfos,System.Boolean)"]

useCompoundFile
Type: System..::..Boolean

[Missing <param name="useCompoundFile"/> documentation for "M:Lucene.Net.Index.MergePolicy.OneMerge.#ctor(Lucene.Net.Index.SegmentInfos,System.Boolean)"]

See Also

MergePolicy..::..OneMerge Class
Lucene.Net.Index Namespace


MergePolicy.OneMerge Methods

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..OneMerge Methods
MergePolicy..::..OneMerge Class See Also Send Feedback

The MergePolicy..::..OneMerge type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MergePolicy..::..OneMerge Class
Lucene.Net.Index Namespace


MergePolicy.OneMerge Properties

[image] [image]

Lucene.Net Class Libraries
MergePolicy..::..OneMerge Properties
MergePolicy..::..OneMerge Class See Also Send Feedback

The MergePolicy..::..OneMerge type exposes the following members.

Properties

 | Name | Description
Public property | segments_ForNUnit |

See Also

MergePolicy..::..OneMerge Class
Lucene.Net.Index Namespace


segments_ForNUnit Property

[image]

Lucene.Net Class Libraries
MergePolicy..::..OneMerge..::..segments_ForNUnit Property
MergePolicy..::..OneMerge Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.MergePolicy.OneMerge.segments_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfos segments_ForNUnit { get; }
Visual Basic
Public ReadOnly Property segments_ForNUnit As SegmentInfos
    Get
Visual C++
public:
property SegmentInfos^ segments_ForNUnit {
    SegmentInfos^ get ();
}

See Also

MergePolicy..::..OneMerge Class
Lucene.Net.Index Namespace


MergeScheduler Class

[image]

Lucene.Net Class Libraries
MergeScheduler Class
Members See Also Send Feedback

Expert: {@link IndexWriter} uses an instance implementing this interface to execute the merges selected by a {@link MergePolicy}. The default MergeScheduler is {@link ConcurrentMergeScheduler}.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

NOTE: This class typically requires access to package-private APIs (eg, SegmentInfos) to do its job; if you implement your own MergePolicy, you'll need to put it in package Lucene.Net.Index in order to use these APIs.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class MergeScheduler
Visual Basic
Public MustInherit Class MergeScheduler
Visual C++
public ref class MergeScheduler abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergeScheduler
Lucene.Net.Index..::..ConcurrentMergeScheduler
Lucene.Net.Index..::..SerialMergeScheduler

See Also

MergeScheduler Members
Lucene.Net.Index Namespace


MergeScheduler Members

[image] [image]

Lucene.Net Class Libraries
MergeScheduler Members
MergeScheduler Class Constructors Methods See Also Send Feedback

The MergeScheduler type exposes the following members.

Constructors

 | Name | Description
Protected method | MergeScheduler | Initializes a new instance of the MergeScheduler class

Methods

 | Name | Description
Public method | Close | Close this MergeScheduler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Run the merges provided by {@link IndexWriter#GetNextMerge()}.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MergeScheduler Class
Lucene.Net.Index Namespace


MergeScheduler Constructor

[image]

Lucene.Net Class Libraries
MergeScheduler Constructor
MergeScheduler Class See Also Send Feedback
Initializes a new instance of the MergeScheduler class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected MergeScheduler()
Visual Basic
Protected Sub New
Visual C++
protected:
MergeScheduler()

See Also

MergeScheduler Class
Lucene.Net.Index Namespace


MergeScheduler Methods

[image] [image]

Lucene.Net Class Libraries
MergeScheduler Methods
MergeScheduler Class See Also Send Feedback

The MergeScheduler type exposes the following members.

Methods

 | Name | Description
Public method | Close | Close this MergeScheduler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Run the merges provided by {@link IndexWriter#GetNextMerge()}.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MergeScheduler Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
MergeScheduler..::..Close Method
MergeScheduler Class See Also Send Feedback
Close this MergeScheduler.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

MergeScheduler Class
Lucene.Net.Index Namespace


Merge Method

[image]

Lucene.Net Class Libraries
MergeScheduler..::..Merge Method
MergeScheduler Class See Also Send Feedback
Run the merges provided by {@link IndexWriter#GetNextMerge()}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Merge(
    IndexWriter writer
)
Visual Basic
Public MustOverride Sub Merge ( _
    writer As IndexWriter _
)
Visual C++
public:
virtual void Merge(
    IndexWriter^ writer
) abstract

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.MergeScheduler.Merge(Lucene.Net.Index.IndexWriter)"]

See Also

MergeScheduler Class
Lucene.Net.Index Namespace


MultipleTermPositions Class

[image]

Lucene.Net Class Libraries
MultipleTermPositions Class
Members See Also Send Feedback
Allows you to iterate over the {@link TermPositions} for multiple {@link Term}s as a single {@link TermPositions}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MultipleTermPositions : TermPositions,
    TermDocs
Visual Basic
Public Class MultipleTermPositions _
    Implements TermPositions, TermDocs
Visual C++
public ref class MultipleTermPositions : TermPositions,
    TermDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MultipleTermPositions

See Also

MultipleTermPositions Members
Lucene.Net.Index Namespace


MultipleTermPositions Members

[image] [image]

Lucene.Net Class Libraries
MultipleTermPositions Members
MultipleTermPositions Class Constructors Methods See Also Send Feedback

The MultipleTermPositions type exposes the following members.

Constructors

Name Description
Public method MultipleTermPositions
Creates a new
CopyC#
MultipleTermPositions
 instance.

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | Not implemented.
Public method | GetPayloadLength | Not implemented.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | NextPosition |
Public method | Read | Not implemented.
Public method | Seek(Term) | Not implemented.
Public method | Seek(TermEnum) | Not implemented.
Public method | SkipTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


MultipleTermPositions Constructor

[image]

Lucene.Net Class Libraries
MultipleTermPositions Constructor
MultipleTermPositions Class See Also Send Feedback
Creates a new
CopyC#
MultipleTermPositions
 instance.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultipleTermPositions(
    IndexReader indexReader,
    Term[] terms
)
Visual Basic
Public Sub New ( _
    indexReader As IndexReader, _
    terms As Term() _
)
Visual C++
public:
MultipleTermPositions(
    IndexReader^ indexReader,
    array<Term^>^ terms
)

Parameters

indexReader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="indexReader"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term[])"]

terms
Type: array< Lucene.Net.Index..::..Term >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term[])"]

Exceptions

Exception | Condition
[!:IOException] |

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


MultipleTermPositions Methods

[image] [image]

Lucene.Net Class Libraries
MultipleTermPositions Methods
MultipleTermPositions Class See Also Send Feedback

The MultipleTermPositions type exposes the following members.

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | Not implemented.
Public method | GetPayloadLength | Not implemented.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | NextPosition |
Public method | Read | Not implemented.
Public method | Seek(Term) | Not implemented.
Public method | Seek(TermEnum) | Not implemented.
Public method | SkipTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Close Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
virtual void Close() sealed

Implements

TermDocs..::..Close()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


Doc Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Doc Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Doc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Doc()
Visual Basic
Public Function Doc As Integer
Visual C++
public:
virtual int Doc() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Doc"]

Implements

TermDocs..::..Doc()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


Freq Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Freq Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Freq"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Freq()
Visual Basic
Public Function Freq As Integer
Visual C++
public:
virtual int Freq() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Freq"]

Implements

TermDocs..::..Freq()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..GetPayload Method
MultipleTermPositions Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] GetPayload(
    byte[] data,
    int offset
)
Visual Basic
Public Overridable Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.GetPayload(System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.GetPayload(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.GetPayload(System.Byte[],System.Int32)"]

Implements

TermPositions..::..GetPayload(array<Byte>[]()[][], Int32)

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


GetPayloadLength Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..GetPayloadLength Method
MultipleTermPositions Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPayloadLength()
Visual Basic
Public Overridable Function GetPayloadLength As Integer
Visual C++
public:
virtual int GetPayloadLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.GetPayloadLength"]

Implements

TermPositions..::..GetPayloadLength()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..IsPayloadAvailable Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.IsPayloadAvailable"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsPayloadAvailable()
Visual Basic
Public Overridable Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable()

Return Value

false

Implements

TermPositions..::..IsPayloadAvailable()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Next Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Next"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool Next()
Visual Basic
Public Function Next As Boolean
Visual C++
public:
virtual bool Next() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Next"]

Implements

TermDocs..::..Next()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


NextPosition Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..NextPosition Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.NextPosition"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int NextPosition()
Visual Basic
Public Function NextPosition As Integer
Visual C++
public:
virtual int NextPosition() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.NextPosition"]

Implements

TermPositions..::..NextPosition()()()()

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


Read Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Read Method
MultipleTermPositions Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Read(
    int[] arg0,
    int[] arg1
)
Visual Basic
Public Overridable Function Read ( _
    arg0 As Integer(), _
    arg1 As Integer() _
) As Integer
Visual C++
public:
virtual int Read(
    array<int>^ arg0,
    array<int>^ arg1
)

Parameters

arg0
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="arg0"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Read(System.Int32[],System.Int32[])"]

arg1
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="arg1"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Read(System.Int32[],System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Read(System.Int32[],System.Int32[])"]

Implements

TermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][])

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Seek Method
MultipleTermPositions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) | Not implemented.
Public method | Seek(TermEnum) | Not implemented.

See Also

MultipleTermPositions Class
MultipleTermPositions Members
Lucene.Net.Index Namespace


Seek Method (Term)

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Seek Method (Term)
MultipleTermPositions Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Seek(
    Term arg0
)
Visual Basic
Public Overridable Sub Seek ( _
    arg0 As Term _
)
Visual C++
public:
virtual void Seek(
    Term^ arg0
)

Parameters

arg0
Type: Lucene.Net.Index..::..Term

[Missing <param name="arg0"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Seek(Lucene.Net.Index.Term)"]

Implements

TermDocs..::..Seek(Term)

See Also

MultipleTermPositions Class
Seek Overload
Lucene.Net.Index Namespace


Seek Method (TermEnum)

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..Seek Method (TermEnum)
MultipleTermPositions Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Seek(
    TermEnum termEnum
)
Visual Basic
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
Visual C++
public:
virtual void Seek(
    TermEnum^ termEnum
)

Parameters

termEnum
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="termEnum"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.Seek(Lucene.Net.Index.TermEnum)"]

Implements

TermDocs..::..Seek(TermEnum)

See Also

MultipleTermPositions Class
Seek Overload
Lucene.Net.Index Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
MultipleTermPositions..::..SkipTo Method
MultipleTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultipleTermPositions.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool SkipTo(
    int target
)
Visual Basic
Public Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
) sealed

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Index.MultipleTermPositions.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultipleTermPositions.SkipTo(System.Int32)"]

Implements

TermDocs..::..SkipTo(Int32)

See Also

MultipleTermPositions Class
Lucene.Net.Index Namespace


MultiReader Class

[image]

Lucene.Net Class Libraries
MultiReader Class
Members See Also Send Feedback
An IndexReader which reads multiple indexes, appending their content.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MultiReader : IndexReader,
    ICloneable
Visual Basic
Public Class MultiReader _
    Inherits IndexReader _
    Implements ICloneable
Visual C++
public ref class MultiReader : public IndexReader,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..MultiReader

See Also

MultiReader Members
Lucene.Net.Index Namespace


MultiReader Members

[image] [image]

Lucene.Net Class Libraries
MultiReader Members
MultiReader Class Constructors Methods Fields Properties See Also Send Feedback

The MultiReader type exposes the following members.

Constructors

 | Name | Description
Public method | MultiReader(array<IndexReader>[]()[][]) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders. Note that all subreaders are closed if this Multireader is closed.
Public method | MultiReader(array<IndexReader>[]()[][], Boolean) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method Clone()()()()
Clones the subreaders. (see {@link IndexReader#clone()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
(Inherited from IndexReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method DoReopen
If clone is true then we clone each of the subreaders
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Overrides IndexReader..::..GetSequentialSubReaders()()()().)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

(Inherited from IndexReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Not implemented.
(Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Checks recursively if all subreaders are up to date.
(Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader..::..IsOptimized()()()().)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Reopen()()()().)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | subReaders |

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

MultiReader Class
Lucene.Net.Index Namespace


MultiReader Constructor

[image] [image]

Lucene.Net Class Libraries
MultiReader Constructor
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MultiReader(array<IndexReader>[]()[][]) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders. Note that all subreaders are closed if this Multireader is closed.
Public method | MultiReader(array<IndexReader>[]()[][], Boolean) | Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


MultiReader Constructor (IndexReader[])

[image]

Lucene.Net Class Libraries
MultiReader Constructor (array<IndexReader>[]()[][])
MultiReader Class See Also Send Feedback

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Note that all subreaders are closed if this Multireader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiReader(
    IndexReader[] subReaders
)
Visual Basic
Public Sub New ( _
    subReaders As IndexReader() _
)
Visual C++
public:
MultiReader(
    array<IndexReader^>^ subReaders
)

Parameters

subReaders
Type: array< Lucene.Net.Index..::..IndexReader >[]()[][]
set of (sub)readers

See Also

MultiReader Class
MultiReader Overload
Lucene.Net.Index Namespace


MultiReader Constructor (IndexReader[], Boolean)

[image]

Lucene.Net Class Libraries
MultiReader Constructor (array<IndexReader>[]()[][], Boolean)
MultiReader Class See Also Send Feedback

Construct a MultiReader aggregating the named set of (sub)readers. Directory locking for delete, undeleteAll, and setNorm operations is left to the subreaders.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiReader(
    IndexReader[] subReaders,
    bool closeSubReaders
)
Visual Basic
Public Sub New ( _
    subReaders As IndexReader(), _
    closeSubReaders As Boolean _
)
Visual C++
public:
MultiReader(
    array<IndexReader^>^ subReaders,
    bool closeSubReaders
)

Parameters

subReaders
Type: array< Lucene.Net.Index..::..IndexReader >[]()[][]
set of (sub)readers
closeSubReaders
Type: System..::..Boolean
indicates whether the subreaders should be closed when this MultiReader is closed

See Also

MultiReader Class
MultiReader Overload
Lucene.Net.Index Namespace


MultiReader Fields

[image] [image]

Lucene.Net Class Libraries
MultiReader Fields
MultiReader Class See Also Send Feedback

The MultiReader type exposes the following members.

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | subReaders |

See Also

MultiReader Class
Lucene.Net.Index Namespace


subReaders Field

[image]

Lucene.Net Class Libraries
MultiReader..::..subReaders Field
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.MultiReader.subReaders"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexReader[] subReaders
Visual Basic
Protected Friend subReaders As IndexReader()
Visual C++
protected public:
array<IndexReader^>^ subReaders

See Also

MultiReader Class
Lucene.Net.Index Namespace


MultiReader Methods

[image] [image]

Lucene.Net Class Libraries
MultiReader Methods
MultiReader Class See Also Send Feedback

The MultiReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method Clone()()()()
Clones the subreaders. (see {@link IndexReader#clone()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
(Inherited from IndexReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method DoReopen
If clone is true then we clone each of the subreaders
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Overrides IndexReader..::..GetSequentialSubReaders()()()().)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

(Inherited from IndexReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Not implemented.
(Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Checks recursively if all subreaders are up to date.
(Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method | IsOptimized | (Overrides IndexReader..::..IsOptimized()()()().)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Reopen()()()().)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

MultiReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Clone Method
MultiReader Class See Also Send Feedback

Overload List

Name Description
Public method Clone()()()()
Clones the subreaders. (see {@link IndexReader#clone()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
MultiReader..::..Clone Method
MultiReader Class See Also Send Feedback
Clones the subreaders. (see {@link IndexReader#clone()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

MultiReader Class
Clone Overload
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Commit Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DocFreq Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term t
)
Visual Basic
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ t
) override

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.MultiReader.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.DocFreq(Lucene.Net.Index.Term)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


DoClose Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DoClose Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DoClose"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoClose()
Visual Basic
Protected Friend Overrides Sub DoClose
Visual C++
protected public:
virtual void DoClose() override

See Also

MultiReader Class
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..DoCommit Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DoCommit Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DoCommit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal override void DoCommit()
Visual Basic
<ObsoleteAttribute> _
Protected Friend Overrides Sub DoCommit
Visual C++
[ObsoleteAttribute]
protected public:
virtual void DoCommit() override

See Also

MultiReader Class
DoCommit Overload
Lucene.Net.Index Namespace


DoCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
MultiReader..::..DoCommit Method (IDictionary<(Of <(<'String, String>)>)>)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Protected Friend Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
protected public:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.MultiReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

MultiReader Class
DoCommit Overload
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Document Method
MultiReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


Document Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
MultiReader..::..Document Method (Int32, FieldSelector)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.MultiReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Index.MultiReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

See Also

MultiReader Class
Document Overload
Lucene.Net.Index Namespace


DoDelete Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DoDelete Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DoDelete(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoDelete(
    int n
)
Visual Basic
Protected Friend Overrides Sub DoDelete ( _
    n As Integer _
)
Visual C++
protected public:
virtual void DoDelete(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.MultiReader.DoDelete(System.Int32)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


DoReopen Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DoReopen Method
MultiReader Class See Also Send Feedback
If clone is true then we clone each of the subreaders

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual IndexReader DoReopen(
    bool doClone
)
Visual Basic
Protected Friend Overridable Function DoReopen ( _
    doClone As Boolean _
) As IndexReader
Visual C++
protected public:
virtual IndexReader^ DoReopen(
    bool doClone
)

Parameters

doClone
Type: System..::..Boolean

[Missing <param name="doClone"/> documentation for "M:Lucene.Net.Index.MultiReader.DoReopen(System.Boolean)"]

Return Value

New IndexReader, or same one (this) if reopen/clone is not necessary

See Also

MultiReader Class
Lucene.Net.Index Namespace


DoSetNorm Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DoSetNorm Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
Visual Basic
Protected Friend Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Visual C++
protected public:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.MultiReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.MultiReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

value_Renamed
Type: System..::..Byte

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.MultiReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


DoUndeleteAll Method

[image]

Lucene.Net Class Libraries
MultiReader..::..DoUndeleteAll Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.DoUndeleteAll"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoUndeleteAll()
Visual Basic
Protected Friend Overrides Sub DoUndeleteAll
Visual C++
protected public:
virtual void DoUndeleteAll() override

See Also

MultiReader Class
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Flush Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
MultiReader..::..GetFieldNames Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Visual Basic
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override

Parameters

fieldNames
Type: Lucene.Net.Index..::..IndexReader..::..FieldOption

[Missing <param name="fieldNames"/> documentation for "M:Lucene.Net.Index.MultiReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


GetSequentialSubReaders Method

[image]

Lucene.Net Class Libraries
MultiReader..::..GetSequentialSubReaders Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.GetSequentialSubReaders"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader[] GetSequentialSubReaders()
Visual Basic
Public Overrides Function GetSequentialSubReaders As IndexReader()
Visual C++
public:
virtual array<IndexReader^>^ GetSequentialSubReaders() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.GetSequentialSubReaders"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..GetTermFreqVector Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
MultiReader..::..GetTermFreqVector Method (Int32, TermVectorMapper)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

See Also

MultiReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String)

[image]

Lucene.Net Class Libraries
MultiReader..::..GetTermFreqVector Method (Int32, String)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector GetTermFreqVector(
    int n,
    string field
)
Visual Basic
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String)"]

See Also

MultiReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
MultiReader..::..GetTermFreqVector Method (Int32, String, TermVectorMapper)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

See Also

MultiReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVectors Method

[image]

Lucene.Net Class Libraries
MultiReader..::..GetTermFreqVectors Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVectors(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector[] GetTermFreqVectors(
    int n
)
Visual Basic
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ GetTermFreqVectors(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVectors(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.GetTermFreqVectors(System.Int32)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
MultiReader..::..GetVersion Method
MultiReader Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetVersion()
Visual Basic
Public Overrides Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.GetVersion"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
MultiReader..::..HasDeletions Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasDeletions()
Visual Basic
Public Overrides Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.HasDeletions"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


HasNorms Method

[image]

Lucene.Net Class Libraries
MultiReader..::..HasNorms Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.HasNorms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasNorms(
    string field
)
Visual Basic
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool HasNorms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.MultiReader.HasNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.HasNorms(System.String)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


IsCurrent Method

[image]

Lucene.Net Class Libraries
MultiReader..::..IsCurrent Method
MultiReader Class See Also Send Feedback
Checks recursively if all subreaders are up to date.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCurrent()
Visual Basic
Public Overrides Function IsCurrent As Boolean
Visual C++
public:
virtual bool IsCurrent() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.IsCurrent"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
MultiReader..::..IsDeleted Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsDeleted(
    int n
)
Visual Basic
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.MultiReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.IsDeleted(System.Int32)"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
MultiReader..::..IsOptimized Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.IsOptimized"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsOptimized()
Visual Basic
Public Overrides Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.IsOptimized"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
MultiReader..::..MaxDoc Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.MaxDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.MaxDoc"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Norms Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


Norms Method (String)

[image]

Lucene.Net Class Libraries
MultiReader..::..Norms Method (String)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] Norms(
    string field
)
Visual Basic
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String)"]

See Also

MultiReader Class
Norms Overload
Lucene.Net.Index Namespace


Norms Method (String, Byte[], Int32)

[image]

Lucene.Net Class Libraries
MultiReader..::..Norms Method (String, array<Byte>[]()[][], Int32)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String,System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Norms(
    string field,
    byte[] result,
    int offset
)
Visual Basic
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
Visual C++
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String,System.Byte[],System.Int32)"]

result
Type: array< System..::..Byte >[]()[][]

[Missing <param name="result"/> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.MultiReader.Norms(System.String,System.Byte[],System.Int32)"]

See Also

MultiReader Class
Norms Overload
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
MultiReader..::..NumDocs Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.NumDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NumDocs()
Visual Basic
Public Overrides Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.NumDocs"]

See Also

MultiReader Class
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Reopen Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reopen()()()() | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader..::..Reopen()()()().)
Public method | Reopen(Boolean) | Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


Reopen Method

[image]

Lucene.Net Class Libraries
MultiReader..::..Reopen Method
MultiReader Class See Also Send Feedback
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new MultiReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Reopen()
Visual Basic
Public Overrides Function Reopen As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.Reopen"]

See Also

MultiReader Class
Reopen Overload
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..SetNorm Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..TermDocs Method
MultiReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image]

Lucene.Net Class Libraries
MultiReader..::..TermDocs Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.TermDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs()
Visual Basic
Public Overrides Function TermDocs As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.TermDocs"]

See Also

MultiReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..TermPositions Method
MultiReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image]

Lucene.Net Class Libraries
MultiReader..::..TermPositions Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.TermPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermPositions TermPositions()
Visual Basic
Public Overrides Function TermPositions As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.TermPositions"]

See Also

MultiReader Class
TermPositions Overload
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
MultiReader..::..Terms Method
MultiReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)

See Also

MultiReader Class
MultiReader Members
Lucene.Net.Index Namespace


Terms Method

[image]

Lucene.Net Class Libraries
MultiReader..::..Terms Method
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.Terms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms()
Visual Basic
Public Overrides Function Terms As TermEnum
Visual C++
public:
virtual TermEnum^ Terms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.Terms"]

See Also

MultiReader Class
Terms Overload
Lucene.Net.Index Namespace


Terms Method (Term)

[image]

Lucene.Net Class Libraries
MultiReader..::..Terms Method (Term)
MultiReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.MultiReader.Terms(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms(
    Term term
)
Visual Basic
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
Visual C++
public:
virtual TermEnum^ Terms(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.MultiReader.Terms(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.MultiReader.Terms(Lucene.Net.Index.Term)"]

See Also

MultiReader Class
Terms Overload
Lucene.Net.Index Namespace


MultiReader Properties

[image] [image]

Lucene.Net Class Libraries
MultiReader Properties
MultiReader Class See Also Send Feedback

The MultiReader type exposes the following members.

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

MultiReader Class
Lucene.Net.Index Namespace


NumericFieldEnum(T) Class

[image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Base for enumerating over numeric fields.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract class NumericFieldEnum<T> : FieldEnumerator<T>
Visual Basic
Public MustInherit Class NumericFieldEnum(Of T) _
    Inherits FieldEnumerator(Of T)
Visual C++
generic<typename T>
public ref class NumericFieldEnum abstract : public FieldEnumerator<T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Lucene.Net.Index.NumericFieldEnum`1"]

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator <(Of <(<'T>)>)>
Lucene.Net.Index..::..NumericFieldEnum<(Of <(<'T>)>)>
Lucene.Net.Index..::..DoubleFieldEnumerator
Lucene.Net.Index..::..FloatFieldEnumerator
Lucene.Net.Index..::..IntFieldEnumerator
Lucene.Net.Index..::..LongFieldEnumerator

See Also

NumericFieldEnum<(Of <(<'T>)>)> Members
Lucene.Net.Index Namespace


NumericFieldEnum(T) Members

[image] [image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)> Members
NumericFieldEnum<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The NumericFieldEnum<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | NumericFieldEnum<(Of <(<'T>)>)> | Initializes a new instance of the NumericFieldEnum<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Overrides FieldEnumerator<(Of <(<'T>)>)>..::..TryParse(String).)
Protected method | TryParseNumeric | Parse out an encoded numeric string and set the value of current.
Protected method | TryParseString | Parse out a standard string and set the value of current.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


NumericFieldEnum(T) Constructor

[image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)> Constructor
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the NumericFieldEnum<(Of <(<'T>)>)> class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected NumericFieldEnum()
Visual Basic
Protected Sub New
Visual C++
protected:
NumericFieldEnum()

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


NumericFieldEnum(T) Fields

[image] [image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)> Fields
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback

The NumericFieldEnum<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


NumericFieldEnum(T) Methods

[image] [image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)> Methods
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback

The NumericFieldEnum<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Overridden from base. (Overrides FieldEnumerator<(Of <(<'T>)>)>..::..TryParse(String).)
Protected method | TryParseNumeric | Parse out an encoded numeric string and set the value of current.
Protected method | TryParseString | Parse out a standard string and set the value of current.

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)>..::..Init Method
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean, FieldParser) | Initialize the instance.

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
NumericFieldEnum<(Of <(<'T>)>)> Members
Lucene.Net.Index Namespace


Init Method (IndexReader, String, Boolean, FieldParser)

[image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)>..::..Init Method (IndexReader, String, Boolean, FieldParser)
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback
Initialize the instance.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected void Init(
    IndexReader reader,
    string field,
    bool includeDocs,
    FieldParser parser
)
Visual Basic
Protected Sub Init ( _
    reader As IndexReader, _
    field As String, _
    includeDocs As Boolean, _
    parser As FieldParser _
)
Visual C++
protected:
void Init(
    IndexReader^ reader,
    String^ field,
    bool includeDocs,
    FieldParser parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The reader.
field
Type: System..::..String
The field name.
includeDocs
Type: System..::..Boolean
Whether to include a TermDoc enum.
parser
Type: Lucene.Net.Index..::..FieldParser
The parser to use on the field.

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Init Overload
Lucene.Net.Index Namespace


TryParse Method

[image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)>..::..TryParse Method
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback
Overridden from base.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParse(
    string s
)
Visual Basic
Protected Overrides Function TryParse ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParse(
    String^ s
) override

Parameters

s
Type: System..::..String
String to parse.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.NumericFieldEnum`1.TryParse(System.String)"]

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


TryParseNumeric Method

[image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseNumeric Method
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback
Parse out an encoded numeric string and set the value of current.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected abstract bool TryParseNumeric(
    string s
)
Visual Basic
Protected MustOverride Function TryParseNumeric ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseNumeric(
    String^ s
) abstract

Parameters

s
Type: System..::..String
String to parse.

Return Value

True on success.

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


TryParseString Method

[image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)>..::..TryParseString Method
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback
Parse out a standard string and set the value of current.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected abstract bool TryParseString(
    string s
)
Visual Basic
Protected MustOverride Function TryParseString ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParseString(
    String^ s
) abstract

Parameters

s
Type: System..::..String
String to parse.

Return Value

True on success.

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


NumericFieldEnum(T) Properties

[image] [image]

Lucene.Net Class Libraries
NumericFieldEnum<(Of <(<'T>)>)> Properties
NumericFieldEnum<(Of <(<'T>)>)> Class See Also Send Feedback

The NumericFieldEnum<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

NumericFieldEnum<(Of <(<'T>)>)> Class
Lucene.Net.Index Namespace


ParallelReader Class

[image]

Lucene.Net Class Libraries
ParallelReader Class
Members See Also Send Feedback
An IndexReader which reads multiple, parallel indexes. Each index added must have the same number of documents, but typically each contains different fields. Each document contains the union of the fields of all documents with the same document number. When searching, matches for a query term are from the first index added that has the field.

This is useful, e.g., with collections that have large fields which change rarely and small fields that change more frequently. The smaller fields may be re-indexed in a new index and both indexes may be searched together.

Warning: It is up to you to make sure all indexes are created and modified the same way. For example, if you add documents to one index, you need to add the same documents in the same order to the other indexes. Failure to do so will result in undefined behavior.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ParallelReader : IndexReader,
    ICloneable
Visual Basic
Public Class ParallelReader _
    Inherits IndexReader _
    Implements ICloneable
Visual C++
public ref class ParallelReader : public IndexReader,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..ParallelReader

See Also

ParallelReader Members
Lucene.Net.Index Namespace


ParallelReader Members

[image] [image]

Lucene.Net Class Libraries
ParallelReader Members
ParallelReader Class Constructors Methods Fields Properties See Also Send Feedback

The ParallelReader type exposes the following members.

Constructors

 | Name | Description
Public method | ParallelReader()()()() | Construct a ParallelReader. Note that all subreaders are closed if this ParallelReader is closed.
Public method | ParallelReader(Boolean) | Construct a ParallelReader.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method Add(IndexReader)
Add an IndexReader.
Public method Add(IndexReader, Boolean)
Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
(Inherited from IndexReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoReopen
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

(Inherited from IndexReader.)
Public method | GetSubReaders
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

(Inherited from IndexReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Not implemented.
(Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Checks recursively if all subreaders are up to date.
(Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks recursively if all subindexes are optimized
(Overrides IndexReader..::..IsOptimized()()()().)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Reopen()()()().)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method | TermPositions(Term) | (Overrides IndexReader..::..TermPositions(Term).)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

ParallelReader Class
Lucene.Net.Index Namespace


ParallelReader Constructor

[image] [image]

Lucene.Net Class Libraries
ParallelReader Constructor
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParallelReader()()()() | Construct a ParallelReader. Note that all subreaders are closed if this ParallelReader is closed.
Public method | ParallelReader(Boolean) | Construct a ParallelReader.

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


ParallelReader Constructor

[image]

Lucene.Net Class Libraries
ParallelReader Constructor
ParallelReader Class See Also Send Feedback
Construct a ParallelReader.

Note that all subreaders are closed if this ParallelReader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParallelReader()
Visual Basic
Public Sub New
Visual C++
public:
ParallelReader()

See Also

ParallelReader Class
ParallelReader Overload
Lucene.Net.Index Namespace


ParallelReader Constructor (Boolean)

[image]

Lucene.Net Class Libraries
ParallelReader Constructor (Boolean)
ParallelReader Class See Also Send Feedback
Construct a ParallelReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParallelReader(
    bool closeSubReaders
)
Visual Basic
Public Sub New ( _
    closeSubReaders As Boolean _
)
Visual C++
public:
ParallelReader(
    bool closeSubReaders
)

Parameters

closeSubReaders
Type: System..::..Boolean
indicates whether the subreaders should be closed when this ParallelReader is closed

See Also

ParallelReader Class
ParallelReader Overload
Lucene.Net.Index Namespace


ParallelReader Fields

[image] [image]

Lucene.Net Class Libraries
ParallelReader Fields
ParallelReader Class See Also Send Feedback

The ParallelReader type exposes the following members.

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)

See Also

ParallelReader Class
Lucene.Net.Index Namespace


ParallelReader Methods

[image] [image]

Lucene.Net Class Libraries
ParallelReader Methods
ParallelReader Class See Also Send Feedback

The ParallelReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method Add(IndexReader)
Add an IndexReader.
Public method Add(IndexReader, Boolean)
Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method Clone(Boolean)
Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader.
(Inherited from IndexReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory associated with this index. The Default implementation returns the directory specified by subclasses when delegating to the IndexReader(Directory) constructor, or throws an UnsupportedOperationException if one was not specified.
(Inherited from IndexReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoReopen
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

(Inherited from IndexReader.)
Public method | GetSubReaders
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method | GetTermFreqVectors | (Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method GetTermInfosIndexDivisor

For IndexReader implementations that use TermInfosReader to read terms, this returns the current indexDivisor as specified when the reader was opened.

(Inherited from IndexReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Not implemented.
(Overrides IndexReader..::..GetVersion()()()().)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Checks recursively if all subreaders are up to date.
(Overrides IndexReader..::..IsCurrent()()()().)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks recursively if all subindexes are optimized
(Overrides IndexReader..::..IsOptimized()()()().)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

(Overrides IndexReader..::..Reopen()()()().)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method | TermPositions(Term) | (Overrides IndexReader..::..TermPositions(Term).)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

ParallelReader Class
Lucene.Net.Index Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Add Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(IndexReader) | Add an IndexReader.
Public method | Add(IndexReader, Boolean) | Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


Add Method (IndexReader)

[image]

Lucene.Net Class Libraries
ParallelReader..::..Add Method (IndexReader)
ParallelReader Class See Also Send Feedback
Add an IndexReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    IndexReader reader
)
Visual Basic
Public Overridable Sub Add ( _
    reader As IndexReader _
)
Visual C++
public:
virtual void Add(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Index.ParallelReader.Add(Lucene.Net.Index.IndexReader)"]

See Also

ParallelReader Class
Add Overload
Lucene.Net.Index Namespace


Add Method (IndexReader, Boolean)

[image]

Lucene.Net Class Libraries
ParallelReader..::..Add Method (IndexReader, Boolean)
ParallelReader Class See Also Send Feedback
Add an IndexReader whose stored fields will not be returned. This can accellerate search when stored fields are only needed from a subset of the IndexReaders.
of documents
of {@link IndexReader#MaxDoc()}

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    IndexReader reader,
    bool ignoreStoredFields
)
Visual Basic
Public Overridable Sub Add ( _
    reader As IndexReader, _
    ignoreStoredFields As Boolean _
)
Visual C++
public:
virtual void Add(
    IndexReader^ reader,
    bool ignoreStoredFields
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Index.ParallelReader.Add(Lucene.Net.Index.IndexReader,System.Boolean)"]

ignoreStoredFields
Type: System..::..Boolean

[Missing <param name="ignoreStoredFields"/> documentation for "M:Lucene.Net.Index.ParallelReader.Add(Lucene.Net.Index.IndexReader,System.Boolean)"]

See Also

ParallelReader Class
Add Overload
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Clone Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | Clones the IndexReader and optionally changes readOnly. A readOnly reader cannot open a writeable reader. (Inherited from IndexReader.)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..Clone Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

ParallelReader Class
Clone Overload
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Commit Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DocFreq Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term term
)
Visual Basic
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.ParallelReader.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.DocFreq(Lucene.Net.Index.Term)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


DoClose Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoClose Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoClose"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoClose()
Visual Basic
Protected Friend Overrides Sub DoClose
Visual C++
protected public:
virtual void DoClose() override

See Also

ParallelReader Class
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..DoCommit Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoCommit Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoCommit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal override void DoCommit()
Visual Basic
<ObsoleteAttribute> _
Protected Friend Overrides Sub DoCommit
Visual C++
[ObsoleteAttribute]
protected public:
virtual void DoCommit() override

See Also

ParallelReader Class
DoCommit Overload
Lucene.Net.Index Namespace


DoCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoCommit Method (IDictionary<(Of <(<'String, String>)>)>)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Protected Friend Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
protected public:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.ParallelReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

ParallelReader Class
DoCommit Overload
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Document Method
ParallelReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


Document Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
ParallelReader..::..Document Method (Int32, FieldSelector)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ParallelReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Index.ParallelReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

See Also

ParallelReader Class
Document Overload
Lucene.Net.Index Namespace


DoDelete Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoDelete Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoDelete(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoDelete(
    int n
)
Visual Basic
Protected Friend Overrides Sub DoDelete ( _
    n As Integer _
)
Visual C++
protected public:
virtual void DoDelete(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ParallelReader.DoDelete(System.Int32)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


DoReopen Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoReopen Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoReopen(System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual IndexReader DoReopen(
    bool doClone
)
Visual Basic
Protected Friend Overridable Function DoReopen ( _
    doClone As Boolean _
) As IndexReader
Visual C++
protected public:
virtual IndexReader^ DoReopen(
    bool doClone
)

Parameters

doClone
Type: System..::..Boolean

[Missing <param name="doClone"/> documentation for "M:Lucene.Net.Index.ParallelReader.DoReopen(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.DoReopen(System.Boolean)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


DoSetNorm Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoSetNorm Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoSetNorm(
    int n,
    string field,
    byte value_Renamed
)
Visual Basic
Protected Friend Overrides Sub DoSetNorm ( _
    n As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Visual C++
protected public:
virtual void DoSetNorm(
    int n,
    String^ field,
    unsigned char value_Renamed
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ParallelReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.ParallelReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

value_Renamed
Type: System..::..Byte

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.ParallelReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


DoUndeleteAll Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..DoUndeleteAll Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.DoUndeleteAll"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoUndeleteAll()
Visual Basic
Protected Friend Overrides Sub DoUndeleteAll
Visual C++
protected public:
virtual void DoUndeleteAll() override

See Also

ParallelReader Class
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Flush Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetFieldNames Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldNames
)
Visual Basic
Public Overrides Function GetFieldNames ( _
    fieldNames As IndexReader..::..FieldOption _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldNames
) override

Parameters

fieldNames
Type: Lucene.Net.Index..::..IndexReader..::..FieldOption

[Missing <param name="fieldNames"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


GetSubReaders Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetSubReaders Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.GetSubReaders"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader[] GetSubReaders()
Visual Basic
Public Overridable Function GetSubReaders As IndexReader()
Visual C++
public:
virtual array<IndexReader^>^ GetSubReaders()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.GetSubReaders"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..GetTermFreqVector Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetTermFreqVector Method (Int32, TermVectorMapper)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

See Also

ParallelReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String)

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetTermFreqVector Method (Int32, String)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector GetTermFreqVector(
    int n,
    string field
)
Visual Basic
Public Overrides Function GetTermFreqVector ( _
    n As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ GetTermFreqVector(
    int n,
    String^ field
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String)"]

See Also

ParallelReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetTermFreqVector Method (Int32, String, TermVectorMapper)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

See Also

ParallelReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVectors Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetTermFreqVectors Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVectors(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector[] GetTermFreqVectors(
    int n
)
Visual Basic
Public Overrides Function GetTermFreqVectors ( _
    n As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ GetTermFreqVectors(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVectors(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.GetTermFreqVectors(System.Int32)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..GetVersion Method
ParallelReader Class See Also Send Feedback
Not implemented.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetVersion()
Visual Basic
Public Overrides Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.GetVersion"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..HasDeletions Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasDeletions()
Visual Basic
Public Overrides Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.HasDeletions"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


HasNorms Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..HasNorms Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.HasNorms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasNorms(
    string field
)
Visual Basic
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool HasNorms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.ParallelReader.HasNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.HasNorms(System.String)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


IsCurrent Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..IsCurrent Method
ParallelReader Class See Also Send Feedback
Checks recursively if all subreaders are up to date.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCurrent()
Visual Basic
Public Overrides Function IsCurrent As Boolean
Visual C++
public:
virtual bool IsCurrent() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.IsCurrent"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..IsDeleted Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsDeleted(
    int n
)
Visual Basic
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ParallelReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.IsDeleted(System.Int32)"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..IsOptimized Method
ParallelReader Class See Also Send Feedback
Checks recursively if all subindexes are optimized

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsOptimized()
Visual Basic
Public Overrides Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.IsOptimized"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..MaxDoc Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.MaxDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.MaxDoc"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Norms Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


Norms Method (String)

[image]

Lucene.Net Class Libraries
ParallelReader..::..Norms Method (String)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] Norms(
    string field
)
Visual Basic
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String)"]

See Also

ParallelReader Class
Norms Overload
Lucene.Net.Index Namespace


Norms Method (String, Byte[], Int32)

[image]

Lucene.Net Class Libraries
ParallelReader..::..Norms Method (String, array<Byte>[]()[][], Int32)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String,System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Norms(
    string field,
    byte[] result,
    int offset
)
Visual Basic
Public Overrides Sub Norms ( _
    field As String, _
    result As Byte(), _
    offset As Integer _
)
Visual C++
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ result,
    int offset
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String,System.Byte[],System.Int32)"]

result
Type: array< System..::..Byte >[]()[][]

[Missing <param name="result"/> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.ParallelReader.Norms(System.String,System.Byte[],System.Int32)"]

See Also

ParallelReader Class
Norms Overload
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..NumDocs Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.NumDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NumDocs()
Visual Basic
Public Overrides Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.NumDocs"]

See Also

ParallelReader Class
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Reopen Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reopen()()()() | Tries to reopen the subreaders. If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned. A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}). If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed. (Overrides IndexReader..::..Reopen()()()().)
Public method | Reopen(Boolean) | Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned. (Inherited from IndexReader.)
Public method | Reopen(IndexCommit) | Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned. (Inherited from IndexReader.)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


Reopen Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..Reopen Method
ParallelReader Class See Also Send Feedback
Tries to reopen the subreaders.
If one or more subreaders could be re-opened (i. e. subReader.reopen() returned a new instance != subReader), then a new ParallelReader instance is returned, otherwise this instance is returned.

A re-opened instance might share one or more subreaders with the old instance. Index modification operations result in undefined behavior when performed before the old instance is closed. (see {@link IndexReader#Reopen()}).

If subreaders are shared, then the reference count of those readers is increased to ensure that the subreaders remain open until the last referring reader is closed.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Reopen()
Visual Basic
Public Overrides Function Reopen As IndexReader
Visual C++
public:
virtual IndexReader^ Reopen() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.Reopen"]

See Also

ParallelReader Class
Reopen Overload
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..SetNorm Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..TermDocs Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..TermDocs Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.TermDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs()
Visual Basic
Public Overrides Function TermDocs As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.TermDocs"]

See Also

ParallelReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermDocs Method (Term)

[image]

Lucene.Net Class Libraries
ParallelReader..::..TermDocs Method (Term)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.TermDocs(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs(
    Term term
)
Visual Basic
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.ParallelReader.TermDocs(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.TermDocs(Lucene.Net.Index.Term)"]

See Also

ParallelReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..TermPositions Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method | TermPositions(Term) | (Overrides IndexReader..::..TermPositions(Term).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..TermPositions Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.TermPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermPositions TermPositions()
Visual Basic
Public Overrides Function TermPositions As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.TermPositions"]

See Also

ParallelReader Class
TermPositions Overload
Lucene.Net.Index Namespace


TermPositions Method (Term)

[image]

Lucene.Net Class Libraries
ParallelReader..::..TermPositions Method (Term)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.TermPositions(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermPositions TermPositions(
    Term term
)
Visual Basic
Public Overrides Function TermPositions ( _
    term As Term _
) As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.ParallelReader.TermPositions(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.TermPositions(Lucene.Net.Index.Term)"]

See Also

ParallelReader Class
TermPositions Overload
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
ParallelReader..::..Terms Method
ParallelReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)

See Also

ParallelReader Class
ParallelReader Members
Lucene.Net.Index Namespace


Terms Method

[image]

Lucene.Net Class Libraries
ParallelReader..::..Terms Method
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.Terms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms()
Visual Basic
Public Overrides Function Terms As TermEnum
Visual C++
public:
virtual TermEnum^ Terms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.Terms"]

See Also

ParallelReader Class
Terms Overload
Lucene.Net.Index Namespace


Terms Method (Term)

[image]

Lucene.Net Class Libraries
ParallelReader..::..Terms Method (Term)
ParallelReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ParallelReader.Terms(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms(
    Term term
)
Visual Basic
Public Overrides Function Terms ( _
    term As Term _
) As TermEnum
Visual C++
public:
virtual TermEnum^ Terms(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.ParallelReader.Terms(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ParallelReader.Terms(Lucene.Net.Index.Term)"]

See Also

ParallelReader Class
Terms Overload
Lucene.Net.Index Namespace


ParallelReader Properties

[image] [image]

Lucene.Net Class Libraries
ParallelReader Properties
ParallelReader Class See Also Send Feedback

The ParallelReader type exposes the following members.

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

ParallelReader Class
Lucene.Net.Index Namespace


Payload Class

[image]

Lucene.Net Class Libraries
Payload Class
Members See Also Send Feedback
A Payload is metadata that can be stored together with each occurrence of a term. This metadata is stored inline in the posting list of the specific term.

To store payloads in the index a {@link TokenStream} has to be used that produces payload data.

Use {@link TermPositions#GetPayloadLength()} and {@link TermPositions#GetPayload(byte[], int)} to retrieve the payloads from the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class Payload : ICloneable
Visual Basic
<SerializableAttribute> _
Public Class Payload _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class Payload : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..Payload

See Also

Payload Members
Lucene.Net.Index Namespace


Payload Members

[image] [image]

Lucene.Net Class Libraries
Payload Members
Payload Class Constructors Methods Fields See Also Send Feedback

The Payload type exposes the following members.

Constructors

 | Name | Description
Public method | Payload()()()() | Creates an empty payload and does not allocate a byte array.
Public method | Payload(array<Byte>[]()[][]) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | Payload(array<Byte>[]()[][], Int32, Int32) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

Methods

 | Name | Description
Public method | ByteAt | Returns the byte at the given index.
Public method | Clone | Clones this payload by creating a copy of the underlying byte array.
Public method | CopyTo | Copies the payload data to a byte array.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Returns a reference to the underlying byte array that holds this payloads data.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetOffset | Returns the offset in the underlying byte array
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Returns the length of the payload data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetData(array<Byte>[]()[][]) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | SetData(array<Byte>[]()[][], Int32, Int32) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | ToByteArray | Allocates a new byte array, copies the payload data into it and returns it.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | data | the byte array containing the payload data
Protected field | length | the length of the payload data
Protected field | offset | the offset within the byte array

See Also

Payload Class
Lucene.Net.Index Namespace


Payload Constructor

[image] [image]

Lucene.Net Class Libraries
Payload Constructor
Payload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Payload()()()() | Creates an empty payload and does not allocate a byte array.
Public method | Payload(array<Byte>[]()[][]) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | Payload(array<Byte>[]()[][], Int32, Int32) | Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

See Also

Payload Class
Payload Members
Lucene.Net.Index Namespace


Payload Constructor

[image]

Lucene.Net Class Libraries
Payload Constructor
Payload Class See Also Send Feedback
Creates an empty payload and does not allocate a byte array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Payload()
Visual Basic
Public Sub New
Visual C++
public:
Payload()

See Also

Payload Class
Payload Overload
Lucene.Net.Index Namespace


Payload Constructor (Byte[])

[image]

Lucene.Net Class Libraries
Payload Constructor (array<Byte>[]()[][])
Payload Class See Also Send Feedback
Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Payload(
    byte[] data
)
Visual Basic
Public Sub New ( _
    data As Byte() _
)
Visual C++
public:
Payload(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]
the data of this payload

See Also

Payload Class
Payload Overload
Lucene.Net.Index Namespace


Payload Constructor (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Payload Constructor (array<Byte>[]()[][], Int32, Int32)
Payload Class See Also Send Feedback
Creates a new payload with the the given array as data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Payload(
    byte[] data,
    int offset,
    int length
)
Visual Basic
Public Sub New ( _
    data As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
Payload(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: array< System..::..Byte >[]()[][]
the data of this payload
offset
Type: System..::..Int32
the offset in the data byte array
length
Type: System..::..Int32
the length of the data

See Also

Payload Class
Payload Overload
Lucene.Net.Index Namespace


Payload Fields

[image] [image]

Lucene.Net Class Libraries
Payload Fields
Payload Class See Also Send Feedback

The Payload type exposes the following members.

Fields

 | Name | Description
Protected field | data | the byte array containing the payload data
Protected field | length | the length of the payload data
Protected field | offset | the offset within the byte array

See Also

Payload Class
Lucene.Net.Index Namespace


data Field

[image]

Lucene.Net Class Libraries
Payload..::..data Field
Payload Class See Also Send Feedback
the byte array containing the payload data

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal byte[] data
Visual Basic
Protected Friend data As Byte()
Visual C++
protected public:
array<unsigned char>^ data

See Also

Payload Class
Lucene.Net.Index Namespace


length Field

[image]

Lucene.Net Class Libraries
Payload..::..length Field
Payload Class See Also Send Feedback
the length of the payload data

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int length
Visual Basic
Protected Friend length As Integer
Visual C++
protected public:
int length

See Also

Payload Class
Lucene.Net.Index Namespace


offset Field

[image]

Lucene.Net Class Libraries
Payload..::..offset Field
Payload Class See Also Send Feedback
the offset within the byte array

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int offset
Visual Basic
Protected Friend offset As Integer
Visual C++
protected public:
int offset

See Also

Payload Class
Lucene.Net.Index Namespace


Payload Methods

[image] [image]

Lucene.Net Class Libraries
Payload Methods
Payload Class See Also Send Feedback

The Payload type exposes the following members.

Methods

 | Name | Description
Public method | ByteAt | Returns the byte at the given index.
Public method | Clone | Clones this payload by creating a copy of the underlying byte array.
Public method | CopyTo | Copies the payload data to a byte array.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Returns a reference to the underlying byte array that holds this payloads data.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetOffset | Returns the offset in the underlying byte array
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Returns the length of the payload data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetData(array<Byte>[]()[][]) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | SetData(array<Byte>[]()[][], Int32, Int32) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | ToByteArray | Allocates a new byte array, copies the payload data into it and returns it.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Payload Class
Lucene.Net.Index Namespace


ByteAt Method

[image]

Lucene.Net Class Libraries
Payload..::..ByteAt Method
Payload Class See Also Send Feedback
Returns the byte at the given index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte ByteAt(
    int index
)
Visual Basic
Public Overridable Function ByteAt ( _
    index As Integer _
) As Byte
Visual C++
public:
virtual unsigned char ByteAt(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Index.Payload.ByteAt(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.ByteAt(System.Int32)"]

See Also

Payload Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
Payload..::..Clone Method
Payload Class See Also Send Feedback
Clones this payload by creating a copy of the underlying byte array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

Payload Class
Lucene.Net.Index Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
Payload..::..CopyTo Method
Payload Class See Also Send Feedback
Copies the payload data to a byte array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void CopyTo(
    byte[] target,
    int targetOffset
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As Byte(), _
    targetOffset As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<unsigned char>^ target,
    int targetOffset
)

Parameters

target
Type: array< System..::..Byte >[]()[][]
the target byte array
targetOffset
Type: System..::..Int32
the offset in the target byte array

See Also

Payload Class
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Payload..::..Equals Method
Payload Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.Payload.Equals(System.Object)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Index.Payload.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.Equals(System.Object)"]

See Also

Payload Class
Lucene.Net.Index Namespace


GetData Method

[image]

Lucene.Net Class Libraries
Payload..::..GetData Method
Payload Class See Also Send Feedback
Returns a reference to the underlying byte array that holds this payloads data.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] GetData()
Visual Basic
Public Overridable Function GetData As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetData()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.GetData"]

See Also

Payload Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Payload..::..GetHashCode Method
Payload Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.Payload.GetHashCode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.GetHashCode"]

See Also

Payload Class
Lucene.Net.Index Namespace


GetOffset Method

[image]

Lucene.Net Class Libraries
Payload..::..GetOffset Method
Payload Class See Also Send Feedback
Returns the offset in the underlying byte array

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetOffset()
Visual Basic
Public Overridable Function GetOffset As Integer
Visual C++
public:
virtual int GetOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.GetOffset"]

See Also

Payload Class
Lucene.Net.Index Namespace


Length Method

[image]

Lucene.Net Class Libraries
Payload..::..Length Method
Payload Class See Also Send Feedback
Returns the length of the payload data.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Length()
Visual Basic
Public Overridable Function Length As Integer
Visual C++
public:
virtual int Length()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.Length"]

See Also

Payload Class
Lucene.Net.Index Namespace


SetData Method

[image] [image]

Lucene.Net Class Libraries
Payload..::..SetData Method
Payload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetData(array<Byte>[]()[][]) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.
Public method | SetData(array<Byte>[]()[][], Int32, Int32) | Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

See Also

Payload Class
Payload Members
Lucene.Net.Index Namespace


SetData Method (Byte[])

[image]

Lucene.Net Class Libraries
Payload..::..SetData Method (array<Byte>[]()[][])
Payload Class See Also Send Feedback
Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetData(
    byte[] data
)
Visual Basic
Public Overridable Sub SetData ( _
    data As Byte() _
)
Visual C++
public:
virtual void SetData(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Index.Payload.SetData(System.Byte[])"]

See Also

Payload Class
SetData Overload
Lucene.Net.Index Namespace


SetData Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Payload..::..SetData Method (array<Byte>[]()[][], Int32, Int32)
Payload Class See Also Send Feedback
Sets this payloads data. A reference to the passed-in array is held, i. e. no copy is made.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetData(
    byte[] data,
    int offset,
    int length
)
Visual Basic
Public Overridable Sub SetData ( _
    data As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void SetData(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Index.Payload.SetData(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.Payload.SetData(System.Byte[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Index.Payload.SetData(System.Byte[],System.Int32,System.Int32)"]

See Also

Payload Class
SetData Overload
Lucene.Net.Index Namespace


ToByteArray Method

[image]

Lucene.Net Class Libraries
Payload..::..ToByteArray Method
Payload Class See Also Send Feedback
Allocates a new byte array, copies the payload data into it and returns it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] ToByteArray()
Visual Basic
Public Overridable Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Payload.ToByteArray"]

See Also

Payload Class
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Class

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper Class
Members See Also Send Feedback
For each Field, store position by position information. It ignores frequency information

This is not thread-safe.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PositionBasedTermVectorMapper : TermVectorMapper
Visual Basic
Public Class PositionBasedTermVectorMapper _
    Inherits TermVectorMapper
Visual C++
public ref class PositionBasedTermVectorMapper : public TermVectorMapper

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorMapper
Lucene.Net.Index..::..PositionBasedTermVectorMapper

See Also

PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Members

[image] [image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper Members
PositionBasedTermVectorMapper Class Constructors Methods See Also Send Feedback

The PositionBasedTermVectorMapper type exposes the following members.

Constructors

 | Name | Description
Public method | PositionBasedTermVectorMapper()()()() | Initializes a new instance of the PositionBasedTermVectorMapper class
Public method | PositionBasedTermVectorMapper(Boolean) | Initializes a new instance of the PositionBasedTermVectorMapper class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Never ignores positions. This mapper doesn't make much sense unless there are positions (Overrides TermVectorMapper..::..IsIgnoringPositions()()()().)
Public method | Map | Callback for the TermVectorReader. (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | Callback mechanism used by the TermVectorReader (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Constructor

[image] [image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper Constructor
PositionBasedTermVectorMapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PositionBasedTermVectorMapper()()()() | Initializes a new instance of the PositionBasedTermVectorMapper class
Public method | PositionBasedTermVectorMapper(Boolean) | Initializes a new instance of the PositionBasedTermVectorMapper class

See Also

PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Members
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Constructor

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper Constructor
PositionBasedTermVectorMapper Class See Also Send Feedback
Initializes a new instance of the PositionBasedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PositionBasedTermVectorMapper()
Visual Basic
Public Sub New
Visual C++
public:
PositionBasedTermVectorMapper()

See Also

PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Overload
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Constructor (Boolean)

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper Constructor (Boolean)
PositionBasedTermVectorMapper Class See Also Send Feedback
Initializes a new instance of the PositionBasedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PositionBasedTermVectorMapper(
    bool ignoringOffsets
)
Visual Basic
Public Sub New ( _
    ignoringOffsets As Boolean _
)
Visual C++
public:
PositionBasedTermVectorMapper(
    bool ignoringOffsets
)

Parameters

ignoringOffsets
Type: System..::..Boolean

[Missing <param name="ignoringOffsets"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.#ctor(System.Boolean)"]

See Also

PositionBasedTermVectorMapper Class
PositionBasedTermVectorMapper Overload
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper Methods

[image] [image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper Methods
PositionBasedTermVectorMapper Class See Also Send Feedback

The PositionBasedTermVectorMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldToTerms | Get the mapping between fields and terms, sorted by the comparator
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Never ignores positions. This mapper doesn't make much sense unless there are positions (Overrides TermVectorMapper..::..IsIgnoringPositions()()()().)
Public method | Map | Callback for the TermVectorReader. (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | Callback mechanism used by the TermVectorReader (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace


GetFieldToTerms Method

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..GetFieldToTerms Method
PositionBasedTermVectorMapper Class See Also Send Feedback
Get the mapping between fields and terms, sorted by the comparator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IDictionary GetFieldToTerms()
Visual Basic
Public Overridable Function GetFieldToTerms As IDictionary
Visual C++
public:
virtual IDictionary^ GetFieldToTerms()

Return Value

A map between field names and a Map. The sub-Map key is the position as the integer, the value is {@link Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo}.

See Also

PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace


IsIgnoringPositions Method

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..IsIgnoringPositions Method
PositionBasedTermVectorMapper Class See Also Send Feedback
Never ignores positions. This mapper doesn't make much sense unless there are positions

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsIgnoringPositions()
Visual Basic
Public Overrides Function IsIgnoringPositions As Boolean
Visual C++
public:
virtual bool IsIgnoringPositions() override

Return Value

false

See Also

PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace


Map Method

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..Map Method
PositionBasedTermVectorMapper Class See Also Send Feedback
Callback for the TermVectorReader.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Visual Basic
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Visual C++
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo^>^ offsets,
    array<int>^ positions
) override

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

frequency
Type: System..::..Int32

[Missing <param name="frequency"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

offsets
Type: array< Lucene.Net.Index..::..TermVectorOffsetInfo >[]()[][]

[Missing <param name="offsets"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

positions
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="positions"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

See Also

PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace


SetExpectations Method

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..SetExpectations Method
PositionBasedTermVectorMapper Class See Also Send Feedback
Callback mechanism used by the TermVectorReader

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Visual Basic
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Visual C++
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override

Parameters

field
Type: System..::..String
The field being read
numTerms
Type: System..::..Int32
The number of terms in the vector
storeOffsets
Type: System..::..Boolean
Whether offsets are available
storePositions
Type: System..::..Boolean
Whether positions are available

See Also

PositionBasedTermVectorMapper Class
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Class

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo Class
PositionBasedTermVectorMapper Class Members See Also Send Feedback
Container for a term at a position

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TVPositionInfo
Visual Basic
Public Class TVPositionInfo
Visual C++
public ref class TVPositionInfo

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..PositionBasedTermVectorMapper..::..TVPositionInfo

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Members
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Members

[image] [image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo Members
PositionBasedTermVectorMapper..::..TVPositionInfo Class Constructors Methods Properties See Also Send Feedback

For each Field, store position by position information. It ignores frequency information

This is not thread-safe.

The PositionBasedTermVectorMapper..::..TVPositionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PositionBasedTermVectorMapper..::..TVPositionInfo | Initializes a new instance of the PositionBasedTermVectorMapper..::..TVPositionInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Offsets | Parallel list (to {@link #getTerms()}) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position
Public property | Position |
Public property | Terms | Note, there may be multiple terms at the same position

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Constructor

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo Constructor
PositionBasedTermVectorMapper..::..TVPositionInfo Class See Also Send Feedback
Initializes a new instance of the PositionBasedTermVectorMapper..::..TVPositionInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TVPositionInfo(
    int position,
    bool storeOffsets
)
Visual Basic
Public Sub New ( _
    position As Integer, _
    storeOffsets As Boolean _
)
Visual C++
public:
TVPositionInfo(
    int position,
    bool storeOffsets
)

Parameters

position
Type: System..::..Int32

[Missing <param name="position"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo.#ctor(System.Int32,System.Boolean)"]

storeOffsets
Type: System..::..Boolean

[Missing <param name="storeOffsets"/> documentation for "M:Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo.#ctor(System.Int32,System.Boolean)"]

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Methods

[image] [image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo Methods
PositionBasedTermVectorMapper..::..TVPositionInfo Class See Also Send Feedback

The PositionBasedTermVectorMapper..::..TVPositionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


PositionBasedTermVectorMapper.TVPositionInfo Properties

[image] [image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo Properties
PositionBasedTermVectorMapper..::..TVPositionInfo Class See Also Send Feedback

The PositionBasedTermVectorMapper..::..TVPositionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Offsets | Parallel list (to {@link #getTerms()}) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position
Public property | Position |
Public property | Terms | Note, there may be multiple terms at the same position

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


Offsets Property

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo..::..Offsets Property
PositionBasedTermVectorMapper..::..TVPositionInfo Class See Also Send Feedback
Parallel list (to {@link #getTerms()}) of TermVectorOffsetInfo objects. There may be multiple entries since there may be multiple terms at a position

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList Offsets { get; }
Visual Basic
Public Overridable ReadOnly Property Offsets As IList
    Get
Visual C++
public:
virtual property IList^ Offsets {
    IList^ get ();
}

Return Value

A List of TermVectorOffsetInfo objects, if offsets are store.

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


Position Property

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo..::..Position Property
PositionBasedTermVectorMapper..::..TVPositionInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.PositionBasedTermVectorMapper.TVPositionInfo.Position"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Position { get; }
Visual Basic
Public Overridable ReadOnly Property Position As Integer
    Get
Visual C++
public:
virtual property int Position {
    int get ();
}

Return Value

The position of the term

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


Terms Property

[image]

Lucene.Net Class Libraries
PositionBasedTermVectorMapper..::..TVPositionInfo..::..Terms Property
PositionBasedTermVectorMapper..::..TVPositionInfo Class See Also Send Feedback
Note, there may be multiple terms at the same position

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList Terms { get; }
Visual Basic
Public Overridable ReadOnly Property Terms As IList
    Get
Visual C++
public:
virtual property IList^ Terms {
    IList^ get ();
}

Return Value

A List of Strings

See Also

PositionBasedTermVectorMapper..::..TVPositionInfo Class
Lucene.Net.Index Namespace


ReadOnlyDirectoryReader Class

[image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.ReadOnlyDirectoryReader"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ReadOnlyDirectoryReader : DirectoryReader
Visual Basic
Public Class ReadOnlyDirectoryReader _
    Inherits DirectoryReader
Visual C++
public ref class ReadOnlyDirectoryReader : public DirectoryReader

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..DirectoryReader
Lucene.Net.Index..::..ReadOnlyDirectoryReader

See Also

ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


ReadOnlyDirectoryReader Members

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader Members
ReadOnlyDirectoryReader Class Methods Fields Properties See Also Send Feedback

The ReadOnlyDirectoryReader type exposes the following members.

Methods

Name | Description
Protected method | AcquireWriteLock | (Overrides DirectoryReader..::..AcquireWriteLock()()()().)
Public method | Clone()()()() | (Inherited from DirectoryReader.)
Public method | Clone(Boolean) | (Inherited from DirectoryReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Inherited from DirectoryReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Inherited from DirectoryReader.)
Protected method | DoClose | (Inherited from DirectoryReader.)
Protected method | DoCommit()()()() | Obsolete. (Inherited from DirectoryReader.)
Protected method DoCommit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations

If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

(Inherited from DirectoryReader.)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from DirectoryReader.)
Protected method | DoDelete | (Inherited from DirectoryReader.)
Protected method | DoSetNorm | (Inherited from DirectoryReader.)
Protected method | DoUndeleteAll | (Inherited from DirectoryReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method | GetCommitUserData | (Inherited from DirectoryReader.)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Inherited from DirectoryReader.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from DirectoryReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVectors | (Inherited from DirectoryReader.)
Public method | GetTermInfosIndexDivisor | (Inherited from DirectoryReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Version number when this IndexReader was opened.
(Inherited from DirectoryReader.)
Public method | HasDeletions | (Inherited from DirectoryReader.)
Public method | HasNorms | (Inherited from DirectoryReader.)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Inherited from DirectoryReader.)
Public method | IsDeleted | (Inherited from DirectoryReader.)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions)
(Inherited from DirectoryReader.)
Public method | MaxDoc | (Inherited from DirectoryReader.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Inherited from DirectoryReader.)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Inherited from DirectoryReader.)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Inherited from DirectoryReader.)
Public method | Reopen()()()() | (Inherited from DirectoryReader.)
Public method | Reopen(Boolean) | (Inherited from DirectoryReader.)
Public method | Reopen(IndexCommit) | (Inherited from DirectoryReader.)
Public method | SetDisableFakeNorms | Obsolete. (Inherited from DirectoryReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Inherited from DirectoryReader.)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | TermPositions()()()() | (Inherited from DirectoryReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Inherited from DirectoryReader.)
Public method | Terms(Term) | (Inherited from DirectoryReader.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | directory | (Inherited from DirectoryReader.)
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly | (Inherited from DirectoryReader.)

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace


ReadOnlyDirectoryReader Fields

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader Fields
ReadOnlyDirectoryReader Class See Also Send Feedback

The ReadOnlyDirectoryReader type exposes the following members.

Fields

 | Name | Description
Protected field | directory | (Inherited from DirectoryReader.)
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace


ReadOnlyDirectoryReader Methods

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader Methods
ReadOnlyDirectoryReader Class See Also Send Feedback

The ReadOnlyDirectoryReader type exposes the following members.

Methods

Name | Description
Protected method | AcquireWriteLock | (Overrides DirectoryReader..::..AcquireWriteLock()()()().)
Public method | Clone()()()() | (Inherited from DirectoryReader.)
Public method | Clone(Boolean) | (Inherited from DirectoryReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Inherited from DirectoryReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Inherited from DirectoryReader.)
Protected method | DoClose | (Inherited from DirectoryReader.)
Protected method | DoCommit()()()() | Obsolete. (Inherited from DirectoryReader.)
Protected method DoCommit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations

If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).

(Inherited from DirectoryReader.)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from DirectoryReader.)
Protected method | DoDelete | (Inherited from DirectoryReader.)
Protected method | DoSetNorm | (Inherited from DirectoryReader.)
Protected method | DoUndeleteAll | (Inherited from DirectoryReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method | GetCommitUserData | (Inherited from DirectoryReader.)
Public method | GetDeletesCacheKey | (Inherited from IndexReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method GetFieldCacheKey Obsolete.
Expert
(Inherited from IndexReader.)
Public method | GetFieldNames | (Inherited from DirectoryReader.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from DirectoryReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method | GetSequentialSubReaders | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVectors | (Inherited from DirectoryReader.)
Public method | GetTermInfosIndexDivisor | (Inherited from DirectoryReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUniqueTermCount
Returns the number of unique terms (across all fields) in this reader. This method returns long, even though internally Lucene cannot handle more than 2^31 unique terms, for a possible future when this limitation is removed.
(Inherited from IndexReader.)
Public method GetVersion
Version number when this IndexReader was opened.
(Inherited from DirectoryReader.)
Public method | HasDeletions | (Inherited from DirectoryReader.)
Public method | HasNorms | (Inherited from DirectoryReader.)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method | IsCurrent | (Inherited from DirectoryReader.)
Public method | IsDeleted | (Inherited from DirectoryReader.)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions)
(Inherited from DirectoryReader.)
Public method | MaxDoc | (Inherited from DirectoryReader.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Inherited from DirectoryReader.)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Inherited from DirectoryReader.)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Inherited from DirectoryReader.)
Public method | Reopen()()()() | (Inherited from DirectoryReader.)
Public method | Reopen(Boolean) | (Inherited from DirectoryReader.)
Public method | Reopen(IndexCommit) | (Inherited from DirectoryReader.)
Public method | SetDisableFakeNorms | Obsolete. (Inherited from DirectoryReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Inherited from DirectoryReader.)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | TermPositions()()()() | (Inherited from DirectoryReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Inherited from DirectoryReader.)
Public method | Terms(Term) | (Inherited from DirectoryReader.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace


AcquireWriteLock Method

[image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..AcquireWriteLock Method
ReadOnlyDirectoryReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ReadOnlyDirectoryReader.AcquireWriteLock"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void AcquireWriteLock()
Visual Basic
Protected Friend Overrides Sub AcquireWriteLock
Visual C++
protected public:
virtual void AcquireWriteLock() override

See Also

ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Clone Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Inherited from DirectoryReader.)
Public method | Clone(Boolean) | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Commit Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..DoCommit Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Inherited from DirectoryReader.)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Document Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Flush Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..GetTermFreqVector Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String) | (Inherited from DirectoryReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Norms Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Inherited from DirectoryReader.)
Public method | Norms(String, array<Byte>[]()[][], Int32) | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Reopen Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reopen()()()() | (Inherited from DirectoryReader.)
Public method | Reopen(Boolean) | (Inherited from DirectoryReader.)
Public method | Reopen(IndexCommit) | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..SetNorm Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..TermDocs Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermDocs()()()() | (Inherited from DirectoryReader.)
Public method TermDocs(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, the document number, the frequency of the term in that document is also provided, for use in search scoring. If term is null, then all non-deleted docs are returned with freq=1. Thus, this method implements the mapping:

    Term => <docNum, freq>*

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..TermPositions Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermPositions()()()() | (Inherited from DirectoryReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader..::..Terms Method
ReadOnlyDirectoryReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Inherited from DirectoryReader.)
Public method | Terms(Term) | (Inherited from DirectoryReader.)

See Also

ReadOnlyDirectoryReader Class
ReadOnlyDirectoryReader Members
Lucene.Net.Index Namespace


ReadOnlyDirectoryReader Properties

[image] [image]

Lucene.Net Class Libraries
ReadOnlyDirectoryReader Properties
ReadOnlyDirectoryReader Class See Also Send Feedback

The ReadOnlyDirectoryReader type exposes the following members.

Properties

 | Name | Description
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)

See Also

ReadOnlyDirectoryReader Class
Lucene.Net.Index Namespace


ReadOnlySegmentReader Class

[image]

Lucene.Net Class Libraries
ReadOnlySegmentReader Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.ReadOnlySegmentReader"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ReadOnlySegmentReader : SegmentReader
Visual Basic
Public Class ReadOnlySegmentReader _
    Inherits SegmentReader
Visual C++
public ref class ReadOnlySegmentReader : public SegmentReader

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..SegmentReader
Lucene.Net.Index..::..ReadOnlySegmentReader

See Also

ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


ReadOnlySegmentReader Members

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader Members
ReadOnlySegmentReader Class Constructors Methods Fields Properties See Also Send Feedback

The ReadOnlySegmentReader type exposes the following members.

Constructors

 | Name | Description
Public method | ReadOnlySegmentReader | Initializes a new instance of the ReadOnlySegmentReader class

Methods

Name | Description
Protected method | AcquireWriteLock | (Overrides IndexReader..::..AcquireWriteLock()()()().)
Public method | Clone()()()() | (Inherited from SegmentReader.)
Public method | Clone(Boolean) | (Inherited from SegmentReader.)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Inherited from SegmentReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Inherited from SegmentReader.)
Protected method | DoClose | (Inherited from SegmentReader.)
Protected method | DoCommit()()()() | Obsolete. (Inherited from SegmentReader.)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from SegmentReader.)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from SegmentReader.)
Protected method | DoDelete | (Inherited from SegmentReader.)
Protected method | DoSetNorm | (Inherited from SegmentReader.)
Protected method | DoUndeleteAll | (Inherited from SegmentReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | FieldInfos | (Inherited from SegmentReader.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Inherited from SegmentReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method | GetFieldCacheKey | Obsolete. (Inherited from SegmentReader.)
Public method | GetFieldNames | (Inherited from SegmentReader.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Protected method | GetNorms | (Inherited from SegmentReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method GetSegmentName
Return the name of the segment this reader is reading.
(Inherited from SegmentReader.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Inherited from SegmentReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Inherited from SegmentReader.)
Public method | GetTermInfosIndexDivisor | (Inherited from SegmentReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUniqueTermCount | (Inherited from SegmentReader.)
Public method GetVersion
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

(Inherited from IndexReader.)
Public method | HasDeletions | (Inherited from SegmentReader.)
Public method | HasNorms | (Inherited from SegmentReader.)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides SegmentReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Public method | MaxDoc | (Inherited from SegmentReader.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Inherited from SegmentReader.)
Public method Norms(String, array<Byte>[]()[][], Int32)
Read norms into a pre-allocated array.
(Inherited from SegmentReader.)
Public method | NormsClosed()()()() | (Inherited from SegmentReader.)
Public method | NormsClosed(String) | (Inherited from SegmentReader.)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Inherited from SegmentReader.)
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Inherited from SegmentReader.)
Public method | TermDocs(Term) | (Inherited from SegmentReader.)
Public method | TermPositions()()()() | (Inherited from SegmentReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Inherited from SegmentReader.)
Public method | Terms(Term) | (Inherited from SegmentReader.)
Public method | TermsIndexLoaded | (Inherited from SegmentReader.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly | (Inherited from SegmentReader.)

Properties

 | Name | Description
Public property | core_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocs_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocsRef_ForNUnit | (Inherited from SegmentReader.)
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)
Public property | norms_ForNUnit | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


ReadOnlySegmentReader Constructor

[image]

Lucene.Net Class Libraries
ReadOnlySegmentReader Constructor
ReadOnlySegmentReader Class See Also Send Feedback
Initializes a new instance of the ReadOnlySegmentReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ReadOnlySegmentReader()
Visual Basic
Public Sub New
Visual C++
public:
ReadOnlySegmentReader()

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


ReadOnlySegmentReader Fields

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader Fields
ReadOnlySegmentReader Class See Also Send Feedback

The ReadOnlySegmentReader type exposes the following members.

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


ReadOnlySegmentReader Methods

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader Methods
ReadOnlySegmentReader Class See Also Send Feedback

The ReadOnlySegmentReader type exposes the following members.

Methods

Name | Description
Protected method | AcquireWriteLock | (Overrides IndexReader..::..AcquireWriteLock()()()().)
Public method | Clone()()()() | (Inherited from SegmentReader.)
Public method | Clone(Boolean) | (Inherited from SegmentReader.)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
(Inherited from SegmentReader.)
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Inherited from SegmentReader.)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Inherited from SegmentReader.)
Protected method | DoClose | (Inherited from SegmentReader.)
Protected method | DoCommit()()()() | Obsolete. (Inherited from SegmentReader.)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from SegmentReader.)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from SegmentReader.)
Protected method | DoDelete | (Inherited from SegmentReader.)
Protected method | DoSetNorm | (Inherited from SegmentReader.)
Protected method | DoUndeleteAll | (Inherited from SegmentReader.)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | FieldInfos | (Inherited from SegmentReader.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Inherited from SegmentReader.)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method | GetFieldCacheKey | Obsolete. (Inherited from SegmentReader.)
Public method | GetFieldNames | (Inherited from SegmentReader.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Protected method | GetNorms | (Inherited from SegmentReader.)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method GetSegmentName
Return the name of the segment this reader is reading.
(Inherited from SegmentReader.)
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Inherited from SegmentReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from SegmentReader.)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Inherited from SegmentReader.)
Public method | GetTermInfosIndexDivisor | (Inherited from SegmentReader.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUniqueTermCount | (Inherited from SegmentReader.)
Public method GetVersion
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

(Inherited from IndexReader.)
Public method | HasDeletions | (Inherited from SegmentReader.)
Public method | HasNorms | (Inherited from SegmentReader.)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides SegmentReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Public method | MaxDoc | (Inherited from SegmentReader.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Inherited from SegmentReader.)
Public method Norms(String, array<Byte>[]()[][], Int32)
Read norms into a pre-allocated array.
(Inherited from SegmentReader.)
Public method | NormsClosed()()()() | (Inherited from SegmentReader.)
Public method | NormsClosed(String) | (Inherited from SegmentReader.)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Inherited from SegmentReader.)
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Inherited from SegmentReader.)
Public method | TermDocs(Term) | (Inherited from SegmentReader.)
Public method | TermPositions()()()() | (Inherited from SegmentReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Inherited from SegmentReader.)
Public method | Terms(Term) | (Inherited from SegmentReader.)
Public method | TermsIndexLoaded | (Inherited from SegmentReader.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


AcquireWriteLock Method

[image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..AcquireWriteLock Method
ReadOnlySegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ReadOnlySegmentReader.AcquireWriteLock"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void AcquireWriteLock()
Visual Basic
Protected Friend Overrides Sub AcquireWriteLock
Visual C++
protected public:
virtual void AcquireWriteLock() override

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Clone Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Inherited from SegmentReader.)
Public method | Clone(Boolean) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Commit Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..DoCommit Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Inherited from SegmentReader.)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Document Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Flush Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..GetTermFreqVector Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Inherited from SegmentReader.)
Public method | GetTermFreqVector(Int32, String) | Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null. (Inherited from SegmentReader.)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..IsDeleted Method
ReadOnlySegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.ReadOnlySegmentReader.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsDeleted(
    int n
)
Visual Basic
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.ReadOnlySegmentReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.ReadOnlySegmentReader.IsDeleted(System.Int32)"]

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Norms Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Inherited from SegmentReader.)
Public method | Norms(String, array<Byte>[]()[][], Int32) | Read norms into a pre-allocated array. (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


NormsClosed Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..NormsClosed Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NormsClosed()()()() | (Inherited from SegmentReader.)
Public method | NormsClosed(String) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Reopen Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

Name Description
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..SetNorm Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..TermDocs Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermDocs()()()() | (Inherited from SegmentReader.)
Public method | TermDocs(Term) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..TermPositions Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermPositions()()()() | (Inherited from SegmentReader.)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader..::..Terms Method
ReadOnlySegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Inherited from SegmentReader.)
Public method | Terms(Term) | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
ReadOnlySegmentReader Members
Lucene.Net.Index Namespace


ReadOnlySegmentReader Properties

[image] [image]

Lucene.Net Class Libraries
ReadOnlySegmentReader Properties
ReadOnlySegmentReader Class See Also Send Feedback

The ReadOnlySegmentReader type exposes the following members.

Properties

 | Name | Description
Public property | core_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocs_ForNUnit | (Inherited from SegmentReader.)
Public property | deletedDocsRef_ForNUnit | (Inherited from SegmentReader.)
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)
Public property | norms_ForNUnit | (Inherited from SegmentReader.)

See Also

ReadOnlySegmentReader Class
Lucene.Net.Index Namespace


SegmentInfo Class

[image]

Lucene.Net Class Libraries
SegmentInfo Class
Members See Also Send Feedback
Information about a segment such as it's name, directory, and files related to the segment. *

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class SegmentInfo : ICloneable
Visual Basic
Public NotInheritable Class SegmentInfo _
    Implements ICloneable
Visual C++
public ref class SegmentInfo sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentInfo

See Also

SegmentInfo Members
Lucene.Net.Index Namespace


SegmentInfo Members

[image] [image]

Lucene.Net Class Libraries
SegmentInfo Members
SegmentInfo Class Constructors Methods Fields See Also Send Feedback

The SegmentInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentInfo(String, Int32, Directory) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | We consider another SegmentInfo instance equal if it has the same dir and same name. (Overrides Object..::..Equals(Object).)
Public method | Files |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDelCount |
Public method | GetDelFileName |
Public method | GetDiagnostics |
Public method | GetDocStoreIsCompoundFile |
Public method | GetDocStoreOffset |
Public method | GetDocStoreSegment |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetHasProx |
Public method | GetNormFileName | Get the file name for the norms file for this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundFile | Returns true if this segment is stored as a compound file; else, false.
Public method | HasDeletions |
Public method | HasSeparateNorms()()()() | Returns true if any fields in this segment have separate norms.
Public method | HasSeparateNorms(Int32) | Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SegString | Used for debugging
Public method | SizeInBytes | Returns total size in bytes of all of files used by this segment.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | dir |
Public field | docCount |
Public field | name |

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


SegmentInfo Constructor

[image] [image]

Lucene.Net Class Libraries
SegmentInfo Constructor
SegmentInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SegmentInfo(String, Int32, Directory) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class
Public method | SegmentInfo(String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean) | Initializes a new instance of the SegmentInfo class

See Also

SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace


SegmentInfo Constructor (String, Int32, Directory)

[image]

Lucene.Net Class Libraries
SegmentInfo Constructor (String, Int32, Directory)
SegmentInfo Class See Also Send Feedback
Initializes a new instance of the SegmentInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfo(
    string name,
    int docCount,
    Directory dir
)
Visual Basic
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory _
)
Visual C++
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory)"]

docCount
Type: System..::..Int32

[Missing <param name="docCount"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory)"]

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory)"]

See Also

SegmentInfo Class
SegmentInfo Overload
Lucene.Net.Index Namespace


SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean)
SegmentInfo Class See Also Send Feedback
Initializes a new instance of the SegmentInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfo(
    string name,
    int docCount,
    Directory dir,
    bool isCompoundFile,
    bool hasSingleNormFile
)
Visual Basic
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory, _
    isCompoundFile As Boolean, _
    hasSingleNormFile As Boolean _
)
Visual C++
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir,
    bool isCompoundFile,
    bool hasSingleNormFile
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean)"]

docCount
Type: System..::..Int32

[Missing <param name="docCount"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean)"]

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean)"]

isCompoundFile
Type: System..::..Boolean

[Missing <param name="isCompoundFile"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean)"]

hasSingleNormFile
Type: System..::..Boolean

[Missing <param name="hasSingleNormFile"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean)"]

See Also

SegmentInfo Class
SegmentInfo Overload
Lucene.Net.Index Namespace


SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
SegmentInfo Constructor (String, Int32, Directory, Boolean, Boolean, Int32, String, Boolean, Boolean)
SegmentInfo Class See Also Send Feedback
Initializes a new instance of the SegmentInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfo(
    string name,
    int docCount,
    Directory dir,
    bool isCompoundFile,
    bool hasSingleNormFile,
    int docStoreOffset,
    string docStoreSegment,
    bool docStoreIsCompoundFile,
    bool hasProx
)
Visual Basic
Public Sub New ( _
    name As String, _
    docCount As Integer, _
    dir As Directory, _
    isCompoundFile As Boolean, _
    hasSingleNormFile As Boolean, _
    docStoreOffset As Integer, _
    docStoreSegment As String, _
    docStoreIsCompoundFile As Boolean, _
    hasProx As Boolean _
)
Visual C++
public:
SegmentInfo(
    String^ name,
    int docCount,
    Directory^ dir,
    bool isCompoundFile,
    bool hasSingleNormFile,
    int docStoreOffset,
    String^ docStoreSegment,
    bool docStoreIsCompoundFile,
    bool hasProx
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

docCount
Type: System..::..Int32

[Missing <param name="docCount"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

isCompoundFile
Type: System..::..Boolean

[Missing <param name="isCompoundFile"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

hasSingleNormFile
Type: System..::..Boolean

[Missing <param name="hasSingleNormFile"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

docStoreOffset
Type: System..::..Int32

[Missing <param name="docStoreOffset"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

docStoreSegment
Type: System..::..String

[Missing <param name="docStoreSegment"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

docStoreIsCompoundFile
Type: System..::..Boolean

[Missing <param name="docStoreIsCompoundFile"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

hasProx
Type: System..::..Boolean

[Missing <param name="hasProx"/> documentation for "M:Lucene.Net.Index.SegmentInfo.#ctor(System.String,System.Int32,Lucene.Net.Store.Directory,System.Boolean,System.Boolean,System.Int32,System.String,System.Boolean,System.Boolean)"]

See Also

SegmentInfo Class
SegmentInfo Overload
Lucene.Net.Index Namespace


SegmentInfo Fields

[image] [image]

Lucene.Net Class Libraries
SegmentInfo Fields
SegmentInfo Class See Also Send Feedback

The SegmentInfo type exposes the following members.

Fields

 | Name | Description
Public field | dir |
Public field | docCount |
Public field | name |

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


dir Field

[image]

Lucene.Net Class Libraries
SegmentInfo..::..dir Field
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentInfo.dir"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Directory dir
Visual Basic
Public dir As Directory
Visual C++
public:
Directory^ dir

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


docCount Field

[image]

Lucene.Net Class Libraries
SegmentInfo..::..docCount Field
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentInfo.docCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int docCount
Visual Basic
Public docCount As Integer
Visual C++
public:
int docCount

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


name Field

[image]

Lucene.Net Class Libraries
SegmentInfo..::..name Field
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentInfo.name"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string name
Visual Basic
Public name As String
Visual C++
public:
String^ name

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


SegmentInfo Methods

[image] [image]

Lucene.Net Class Libraries
SegmentInfo Methods
SegmentInfo Class See Also Send Feedback

The SegmentInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | We consider another SegmentInfo instance equal if it has the same dir and same name. (Overrides Object..::..Equals(Object).)
Public method | Files |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDelCount |
Public method | GetDelFileName |
Public method | GetDiagnostics |
Public method | GetDocStoreIsCompoundFile |
Public method | GetDocStoreOffset |
Public method | GetDocStoreSegment |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetHasProx |
Public method | GetNormFileName | Get the file name for the norms file for this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUseCompoundFile | Returns true if this segment is stored as a compound file; else, false.
Public method | HasDeletions |
Public method | HasSeparateNorms()()()() | Returns true if any fields in this segment have separate norms.
Public method | HasSeparateNorms(Int32) | Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SegString | Used for debugging
Public method | SizeInBytes | Returns total size in bytes of all of files used by this segment.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..Clone Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..Equals Method
SegmentInfo Class See Also Send Feedback
We consider another SegmentInfo instance equal if it has the same dir and same name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Index.SegmentInfo.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.Equals(System.Object)"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


Files Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..Files Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.Files"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IList<string> Files()
Visual Basic
Public Function Files As IList(Of String)
Visual C++
public:
IList<String^>^ Files()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.Files"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetDelCount Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetDelCount Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDelCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetDelCount()
Visual Basic
Public Function GetDelCount As Integer
Visual C++
public:
int GetDelCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDelCount"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetDelFileName Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetDelFileName Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDelFileName"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetDelFileName()
Visual Basic
Public Function GetDelFileName As String
Visual C++
public:
String^ GetDelFileName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDelFileName"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetDiagnostics Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetDiagnostics Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDiagnostics"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IDictionary<string, string> GetDiagnostics()
Visual Basic
Public Function GetDiagnostics As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetDiagnostics()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDiagnostics"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetDocStoreIsCompoundFile Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetDocStoreIsCompoundFile Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDocStoreIsCompoundFile"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool GetDocStoreIsCompoundFile()
Visual Basic
Public Function GetDocStoreIsCompoundFile As Boolean
Visual C++
public:
bool GetDocStoreIsCompoundFile()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDocStoreIsCompoundFile"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetDocStoreOffset Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetDocStoreOffset Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDocStoreOffset"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetDocStoreOffset()
Visual Basic
Public Function GetDocStoreOffset As Integer
Visual C++
public:
int GetDocStoreOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDocStoreOffset"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetDocStoreSegment Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetDocStoreSegment Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDocStoreSegment"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetDocStoreSegment()
Visual Basic
Public Function GetDocStoreSegment As String
Visual C++
public:
String^ GetDocStoreSegment()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetDocStoreSegment"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetHashCode Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetHashCode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetHashCode"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetHasProx Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetHasProx Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.GetHasProx"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool GetHasProx()
Visual Basic
Public Function GetHasProx As Boolean
Visual C++
public:
bool GetHasProx()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetHasProx"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetNormFileName Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetNormFileName Method
SegmentInfo Class See Also Send Feedback
Get the file name for the norms file for this field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetNormFileName(
    int number
)
Visual Basic
Public Function GetNormFileName ( _
    number As Integer _
) As String
Visual C++
public:
String^ GetNormFileName(
    int number
)

Parameters

number
Type: System..::..Int32
field index

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetNormFileName(System.Int32)"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


GetUseCompoundFile Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..GetUseCompoundFile Method
SegmentInfo Class See Also Send Feedback
Returns true if this segment is stored as a compound file; else, false.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool GetUseCompoundFile()
Visual Basic
Public Function GetUseCompoundFile As Boolean
Visual C++
public:
bool GetUseCompoundFile()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.GetUseCompoundFile"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..HasDeletions Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool HasDeletions()
Visual Basic
Public Function HasDeletions As Boolean
Visual C++
public:
bool HasDeletions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.HasDeletions"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


HasSeparateNorms Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfo..::..HasSeparateNorms Method
SegmentInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HasSeparateNorms()()()() | Returns true if any fields in this segment have separate norms.
Public method | HasSeparateNorms(Int32) | Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).

See Also

SegmentInfo Class
SegmentInfo Members
Lucene.Net.Index Namespace


HasSeparateNorms Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..HasSeparateNorms Method
SegmentInfo Class See Also Send Feedback
Returns true if any fields in this segment have separate norms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool HasSeparateNorms()
Visual Basic
Public Function HasSeparateNorms As Boolean
Visual C++
public:
bool HasSeparateNorms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.HasSeparateNorms"]

See Also

SegmentInfo Class
HasSeparateNorms Overload
Lucene.Net.Index Namespace


HasSeparateNorms Method (Int32)

[image]

Lucene.Net Class Libraries
SegmentInfo..::..HasSeparateNorms Method (Int32)
SegmentInfo Class See Also Send Feedback
Returns true if this field for this segment has saved a separate norms file (_<segment>_N.sX).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool HasSeparateNorms(
    int fieldNumber
)
Visual Basic
Public Function HasSeparateNorms ( _
    fieldNumber As Integer _
) As Boolean
Visual C++
public:
bool HasSeparateNorms(
    int fieldNumber
)

Parameters

fieldNumber
Type: System..::..Int32
the field index to check

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.HasSeparateNorms(System.Int32)"]

See Also

SegmentInfo Class
HasSeparateNorms Overload
Lucene.Net.Index Namespace


SegString Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..SegString Method
SegmentInfo Class See Also Send Feedback
Used for debugging

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string SegString(
    Directory dir
)
Visual Basic
Public Function SegString ( _
    dir As Directory _
) As String
Visual C++
public:
String^ SegString(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfo.SegString(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.SegString(Lucene.Net.Store.Directory)"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


SizeInBytes Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..SizeInBytes Method
SegmentInfo Class See Also Send Feedback
Returns total size in bytes of all of files used by this segment.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long SizeInBytes()
Visual Basic
Public Function SizeInBytes As Long
Visual C++
public:
long long SizeInBytes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.SizeInBytes"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
SegmentInfo..::..ToString Method
SegmentInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfo.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfo.ToString"]

See Also

SegmentInfo Class
Lucene.Net.Index Namespace


SegmentInfos Class

[image]

Lucene.Net Class Libraries
SegmentInfos Class
Members See Also Send Feedback
A collection of segmentInfo objects with methods for operating on those segments in relation to the file system.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class SegmentInfos : ArrayList
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class SegmentInfos _
    Inherits ArrayList
Visual C++
[SerializableAttribute]
public ref class SegmentInfos sealed : public ArrayList

Inheritance Hierarchy

System..::..Object
System.Collections..::..ArrayList
Lucene.Net.Index..::..SegmentInfos

See Also

SegmentInfos Members
Lucene.Net.Index Namespace


SegmentInfos Members

[image] [image]

Lucene.Net Class Libraries
SegmentInfos Members
SegmentInfos Class Constructors Methods Fields Properties See Also Send Feedback

The SegmentInfos type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentInfos | Initializes a new instance of the SegmentInfos class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the ArrayList. (Inherited from ArrayList.)
Public method | AddRange | Adds the elements of an ICollection to the end of the ArrayList. (Inherited from ArrayList.)
Public method | BinarySearch(Object) | Searches the entire sorted ArrayList for an element using the default comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Object, IComparer) | Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Int32, Int32, Object, IComparer) | Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | Clear | Removes all elements from the ArrayList. (Inherited from ArrayList.)
Public method | Clone | Returns a copy of this instance, also copying each SegmentInfo. (Overrides ArrayList..::..Clone()()()().)
Public method | Commit | Writes & syncs to the Directory dir, taking care to remove the segments file on exception
Public method | Contains | Determines whether an element is in the ArrayList. (Inherited from ArrayList.)
Public method | CopyTo(Array) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Array, Int32) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Int32, Array, Int32, Int32) | Copies a range of elements from the ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | Equals | Simple brute force implementation. If size is equal, compare items one by one. (Overrides Object..::..Equals(Object).)
Public method | Files | Returns all file names referenced by SegmentInfo instances matching the provided Directory (ie files associated with any "external" segments are skipped). The returned collection is recomputed on each invocation.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerationFromSegmentsFileName | Parse the generation off the segments file name and return it.
Public method | GetCurrentSegmentFileName()()()() | Get the segments_N filename in use by this segment infos.
 | GetCurrentSegmentFileName(array<String>[]()[][]) | Get the filename of the current segments_N file from a list of files.
 | GetCurrentSegmentFileName(Directory) | Get the filename of the current segments_N file in the directory.
 | GetCurrentSegmentGeneration(array<String>[]()[][]) | Get the generation (N) of the current segments_N file from a list of files.
 | GetCurrentSegmentGeneration(Directory) | Get the generation (N) of the current segments_N file in the directory.
 | GetDefaultGenFileRetryCount |
 | GetDefaultGenFileRetryPauseMsec |
 | GetDefaultGenLookahedCount |
Public method | GetEnumerator()()()() | Returns an enumerator for the entire ArrayList. (Inherited from ArrayList.)
Public method | GetEnumerator(Int32, Int32) | Returns an enumerator for a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | GetGeneration |
Public method | GetHashCode | Calculate hash code of SegmentInfos (Overrides Object..::..GetHashCode()()()().)
 | GetInfoStream |
Public method | GetLastGeneration |
Public method | GetNextSegmentFileName | Get the next segments_N filename that will be written.
Public method | GetRange | Returns an ArrayList which represents a subset of the elements in the source ArrayList. (Inherited from ArrayList.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserData |
Public method | GetVersion | version number when this SegmentInfos was generated.
Public method | HasExternalSegments |
Public method | IndexOf(Object) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that extends from the specified index to the last element. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that starts at the specified index and contains the specified number of elements. (Inherited from ArrayList.)
Public method | Info |
Public method | Insert | Inserts an element into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | InsertRange | Inserts the elements of a collection into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object) | Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that extends from the first element to the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that contains the specified number of elements and ends at the specified index. (Inherited from ArrayList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Range | Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.
Public method | Read(Directory) | This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.
Public method | Read(Directory, String) | Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
 | ReadCurrentUserData | Returns userData from latest segments file
 | ReadCurrentVersion | Current version number from segments file.
Public method | Remove | Removes the first occurrence of a specific object from the ArrayList. (Inherited from ArrayList.)
Public method | RemoveAt | Removes the element at the specified index of the ArrayList. (Inherited from ArrayList.)
Public method | RemoveRange | Removes a range of elements from the ArrayList. (Inherited from ArrayList.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire ArrayList. (Inherited from ArrayList.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ArrayList.)
Public method | SegString |
 | SetDefaultGenFileRetryCount | Advanced: set how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.
 | SetDefaultGenFileRetryPauseMsec | Advanced: set how many milliseconds to pause in between attempts to load the segments.gen file.
 | SetDefaultGenLookaheadCount | Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.
 | SetInfoStream | If non-null, information about retries when loading the segments file will be printed to this.
Public method | SetRange | Copies the elements of a collection over a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | Sort()()()() | Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from ArrayList.)
Public method | Sort(IComparer) | Sorts the elements in the entire ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | Sort(Int32, Int32, IComparer) | Sorts the elements in a range of elements in ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | ToArray()()()() | Copies the elements of the ArrayList to a new Object array. (Inherited from ArrayList.)
Public method | ToArray(Type) | Copies the elements of the ArrayList to a new array of the specified element type. (Inherited from ArrayList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the ArrayList. (Inherited from ArrayList.)

Fields

 | Name | Description
Public field | counter |
 | FORMAT | The file format version, a negative number.
 | FORMAT_CHECKSUM | This format adds a checksum at the end of the file to ensure all bytes were successfully written.
 | FORMAT_DEL_COUNT | This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().
 | FORMAT_DIAGNOSTICS | This format adds optional per-segment String dianostics storage, and switches userData to Map
 | FORMAT_HAS_PROX | This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTermFreqAndPositions==false)
 | FORMAT_LOCKLESS | This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See file formats for details.
 | FORMAT_SHARED_DOC_STORE | This format allows multiple segments to share a single vectors and stored fields file.
 | FORMAT_SINGLE_NORM_FILE | This format adds a "hasSingleNormFile" flag into each segment info. See LUCENE-756 for details.
 | FORMAT_USER_DATA | This format adds optional commit userData (String) storage.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the ArrayList can contain. (Inherited from ArrayList.)
Public property | Count | Gets the number of elements actually contained in the ArrayList. (Inherited from ArrayList.)
Public property | IsFixedSize | Gets a value indicating whether the ArrayList has a fixed size. (Inherited from ArrayList.)
Public property | IsReadOnly | Gets a value indicating whether the ArrayList is read-only. (Inherited from ArrayList.)
Public property | IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread safe). (Inherited from ArrayList.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ArrayList.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ArrayList. (Inherited from ArrayList.)

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SegmentInfos Constructor

[image]

Lucene.Net Class Libraries
SegmentInfos Constructor
SegmentInfos Class See Also Send Feedback
Initializes a new instance of the SegmentInfos class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfos()
Visual Basic
Public Sub New
Visual C++
public:
SegmentInfos()

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SegmentInfos Fields

[image] [image]

Lucene.Net Class Libraries
SegmentInfos Fields
SegmentInfos Class See Also Send Feedback

The SegmentInfos type exposes the following members.

Fields

 | Name | Description
Public field | counter |
 | FORMAT | The file format version, a negative number.
 | FORMAT_CHECKSUM | This format adds a checksum at the end of the file to ensure all bytes were successfully written.
 | FORMAT_DEL_COUNT | This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().
 | FORMAT_DIAGNOSTICS | This format adds optional per-segment String dianostics storage, and switches userData to Map
 | FORMAT_HAS_PROX | This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTermFreqAndPositions==false)
 | FORMAT_LOCKLESS | This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See file formats for details.
 | FORMAT_SHARED_DOC_STORE | This format allows multiple segments to share a single vectors and stored fields file.
 | FORMAT_SINGLE_NORM_FILE | This format adds a "hasSingleNormFile" flag into each segment info. See LUCENE-756 for details.
 | FORMAT_USER_DATA | This format adds optional commit userData (String) storage.

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


counter Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..counter Field
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentInfos.counter"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int counter
Visual Basic
Public counter As Integer
Visual C++
public:
int counter

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT Field
SegmentInfos Class See Also Send Feedback
The file format version, a negative number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT
Visual Basic
Public Const FORMAT As Integer
Visual C++
public:
literal int FORMAT

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_CHECKSUM Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_CHECKSUM Field
SegmentInfos Class See Also Send Feedback
This format adds a checksum at the end of the file to ensure all bytes were successfully written.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_CHECKSUM
Visual Basic
Public Const FORMAT_CHECKSUM As Integer
Visual C++
public:
literal int FORMAT_CHECKSUM

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_DEL_COUNT Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_DEL_COUNT Field
SegmentInfos Class See Also Send Feedback
This format adds the deletion count for each segment. This way IndexWriter can efficiently report numDocs().

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_DEL_COUNT
Visual Basic
Public Const FORMAT_DEL_COUNT As Integer
Visual C++
public:
literal int FORMAT_DEL_COUNT

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_DIAGNOSTICS Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_DIAGNOSTICS Field
SegmentInfos Class See Also Send Feedback
This format adds optional per-segment String dianostics storage, and switches userData to Map

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_DIAGNOSTICS
Visual Basic
Public Const FORMAT_DIAGNOSTICS As Integer
Visual C++
public:
literal int FORMAT_DIAGNOSTICS

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_HAS_PROX Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_HAS_PROX Field
SegmentInfos Class See Also Send Feedback
This format adds the boolean hasProx to record if any fields in the segment store prox information (ie, have omitTermFreqAndPositions==false)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_HAS_PROX
Visual Basic
Public Const FORMAT_HAS_PROX As Integer
Visual C++
public:
literal int FORMAT_HAS_PROX

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_LOCKLESS Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_LOCKLESS Field
SegmentInfos Class See Also Send Feedback
This format adds details used for lockless commits. It differs slightly from the previous format in that file names are never re-used (write once). Instead, each file is written to the next generation. For example, segments_1, segments_2, etc. This allows us to not use a commit lock. See file formats for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_LOCKLESS
Visual Basic
Public Const FORMAT_LOCKLESS As Integer
Visual C++
public:
literal int FORMAT_LOCKLESS

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_SHARED_DOC_STORE Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_SHARED_DOC_STORE Field
SegmentInfos Class See Also Send Feedback
This format allows multiple segments to share a single vectors and stored fields file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_SHARED_DOC_STORE
Visual Basic
Public Const FORMAT_SHARED_DOC_STORE As Integer
Visual C++
public:
literal int FORMAT_SHARED_DOC_STORE

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_SINGLE_NORM_FILE Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_SINGLE_NORM_FILE Field
SegmentInfos Class See Also Send Feedback
This format adds a "hasSingleNormFile" flag into each segment info. See LUCENE-756 for details.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_SINGLE_NORM_FILE
Visual Basic
Public Const FORMAT_SINGLE_NORM_FILE As Integer
Visual C++
public:
literal int FORMAT_SINGLE_NORM_FILE

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


FORMAT_USER_DATA Field

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FORMAT_USER_DATA Field
SegmentInfos Class See Also Send Feedback
This format adds optional commit userData (String) storage.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FORMAT_USER_DATA
Visual Basic
Public Const FORMAT_USER_DATA As Integer
Visual C++
public:
literal int FORMAT_USER_DATA

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SegmentInfos Methods

[image] [image]

Lucene.Net Class Libraries
SegmentInfos Methods
SegmentInfos Class See Also Send Feedback

The SegmentInfos type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the ArrayList. (Inherited from ArrayList.)
Public method | AddRange | Adds the elements of an ICollection to the end of the ArrayList. (Inherited from ArrayList.)
Public method | BinarySearch(Object) | Searches the entire sorted ArrayList for an element using the default comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Object, IComparer) | Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Int32, Int32, Object, IComparer) | Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | Clear | Removes all elements from the ArrayList. (Inherited from ArrayList.)
Public method | Clone | Returns a copy of this instance, also copying each SegmentInfo. (Overrides ArrayList..::..Clone()()()().)
Public method | Commit | Writes & syncs to the Directory dir, taking care to remove the segments file on exception
Public method | Contains | Determines whether an element is in the ArrayList. (Inherited from ArrayList.)
Public method | CopyTo(Array) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Array, Int32) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Int32, Array, Int32, Int32) | Copies a range of elements from the ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | Equals | Simple brute force implementation. If size is equal, compare items one by one. (Overrides Object..::..Equals(Object).)
Public method | Files | Returns all file names referenced by SegmentInfo instances matching the provided Directory (ie files associated with any "external" segments are skipped). The returned collection is recomputed on each invocation.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerationFromSegmentsFileName | Parse the generation off the segments file name and return it.
Public method | GetCurrentSegmentFileName()()()() | Get the segments_N filename in use by this segment infos.
 | GetCurrentSegmentFileName(array<String>[]()[][]) | Get the filename of the current segments_N file from a list of files.
 | GetCurrentSegmentFileName(Directory) | Get the filename of the current segments_N file in the directory.
 | GetCurrentSegmentGeneration(array<String>[]()[][]) | Get the generation (N) of the current segments_N file from a list of files.
 | GetCurrentSegmentGeneration(Directory) | Get the generation (N) of the current segments_N file in the directory.
 | GetDefaultGenFileRetryCount |
 | GetDefaultGenFileRetryPauseMsec |
 | GetDefaultGenLookahedCount |
Public method | GetEnumerator()()()() | Returns an enumerator for the entire ArrayList. (Inherited from ArrayList.)
Public method | GetEnumerator(Int32, Int32) | Returns an enumerator for a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | GetGeneration |
Public method | GetHashCode | Calculate hash code of SegmentInfos (Overrides Object..::..GetHashCode()()()().)
 | GetInfoStream |
Public method | GetLastGeneration |
Public method | GetNextSegmentFileName | Get the next segments_N filename that will be written.
Public method | GetRange | Returns an ArrayList which represents a subset of the elements in the source ArrayList. (Inherited from ArrayList.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserData |
Public method | GetVersion | version number when this SegmentInfos was generated.
Public method | HasExternalSegments |
Public method | IndexOf(Object) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that extends from the specified index to the last element. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that starts at the specified index and contains the specified number of elements. (Inherited from ArrayList.)
Public method | Info |
Public method | Insert | Inserts an element into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | InsertRange | Inserts the elements of a collection into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object) | Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that extends from the first element to the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that contains the specified number of elements and ends at the specified index. (Inherited from ArrayList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Range | Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.
Public method | Read(Directory) | This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.
Public method | Read(Directory, String) | Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.
 | ReadCurrentUserData | Returns userData from latest segments file
 | ReadCurrentVersion | Current version number from segments file.
Public method | Remove | Removes the first occurrence of a specific object from the ArrayList. (Inherited from ArrayList.)
Public method | RemoveAt | Removes the element at the specified index of the ArrayList. (Inherited from ArrayList.)
Public method | RemoveRange | Removes a range of elements from the ArrayList. (Inherited from ArrayList.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire ArrayList. (Inherited from ArrayList.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ArrayList.)
Public method | SegString |
 | SetDefaultGenFileRetryCount | Advanced: set how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.
 | SetDefaultGenFileRetryPauseMsec | Advanced: set how many milliseconds to pause in between attempts to load the segments.gen file.
 | SetDefaultGenLookaheadCount | Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.
 | SetInfoStream | If non-null, information about retries when loading the segments file will be printed to this.
Public method | SetRange | Copies the elements of a collection over a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | Sort()()()() | Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from ArrayList.)
Public method | Sort(IComparer) | Sorts the elements in the entire ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | Sort(Int32, Int32, IComparer) | Sorts the elements in a range of elements in ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | ToArray()()()() | Copies the elements of the ArrayList to a new Object array. (Inherited from ArrayList.)
Public method | ToArray(Type) | Copies the elements of the ArrayList to a new array of the specified element type. (Inherited from ArrayList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the ArrayList. (Inherited from ArrayList.)

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


BinarySearch Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..BinarySearch Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(Object) | Searches the entire sorted ArrayList for an element using the default comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Object, IComparer) | Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Int32, Int32, Object, IComparer) | Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Clone Method
SegmentInfos Class See Also Send Feedback
Returns a copy of this instance, also copying each SegmentInfo.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


Commit Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Commit Method
SegmentInfos Class See Also Send Feedback
Writes & syncs to the Directory dir, taking care to remove the segments file on exception

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Commit(
    Directory dir
)
Visual Basic
Public Sub Commit ( _
    dir As Directory _
)
Visual C++
public:
void Commit(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Commit(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


CopyTo Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..CopyTo Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(Array) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Array, Int32) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Int32, Array, Int32, Int32) | Copies a range of elements from the ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Equals Method
SegmentInfos Class See Also Send Feedback
Simple brute force implementation. If size is equal, compare items one by one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
SegmentInfos object to check equality for

Return Value

true if lists are equal, false otherwise

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


Files Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Files Method
SegmentInfos Class See Also Send Feedback
Returns all file names referenced by SegmentInfo instances matching the provided Directory (ie files associated with any "external" segments are skipped). The returned collection is recomputed on each invocation.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ICollection<string> Files(
    Directory dir,
    bool includeSegmentsFile
)
Visual Basic
Public Function Files ( _
    dir As Directory, _
    includeSegmentsFile As Boolean _
) As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ Files(
    Directory^ dir,
    bool includeSegmentsFile
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Files(Lucene.Net.Store.Directory,System.Boolean)"]

includeSegmentsFile
Type: System..::..Boolean

[Missing <param name="includeSegmentsFile"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Files(Lucene.Net.Store.Directory,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.Files(Lucene.Net.Store.Directory,System.Boolean)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GenerationFromSegmentsFileName Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GenerationFromSegmentsFileName Method
SegmentInfos Class See Also Send Feedback
Parse the generation off the segments file name and return it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GenerationFromSegmentsFileName(
    string fileName
)
Visual Basic
Public Shared Function GenerationFromSegmentsFileName ( _
    fileName As String _
) As Long
Visual C++
public:
static long long GenerationFromSegmentsFileName(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:Lucene.Net.Index.SegmentInfos.GenerationFromSegmentsFileName(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GenerationFromSegmentsFileName(System.String)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GetCurrentSegmentFileName Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentFileName Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCurrentSegmentFileName()()()() | Get the segments_N filename in use by this segment infos.
 | GetCurrentSegmentFileName(array<String>[]()[][]) | Get the filename of the current segments_N file from a list of files.
 | GetCurrentSegmentFileName(Directory) | Get the filename of the current segments_N file in the directory.

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


GetCurrentSegmentFileName Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentFileName Method
SegmentInfos Class See Also Send Feedback
Get the segments_N filename in use by this segment infos.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetCurrentSegmentFileName()
Visual Basic
Public Function GetCurrentSegmentFileName As String
Visual C++
public:
String^ GetCurrentSegmentFileName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetCurrentSegmentFileName"]

See Also

SegmentInfos Class
GetCurrentSegmentFileName Overload
Lucene.Net.Index Namespace


GetCurrentSegmentFileName Method (String[])

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentFileName Method (array<String>[]()[][])
SegmentInfos Class See Also Send Feedback
Get the filename of the current segments_N file from a list of files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetCurrentSegmentFileName(
    string[] files
)
Visual Basic
Public Shared Function GetCurrentSegmentFileName ( _
    files As String() _
) As String
Visual C++
public:
static String^ GetCurrentSegmentFileName(
    array<String^>^ files
)

Parameters

files
Type: array< System..::..String >[]()[][]
-- array of file names to check

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetCurrentSegmentFileName(System.String[])"]

See Also

SegmentInfos Class
GetCurrentSegmentFileName Overload
Lucene.Net.Index Namespace


GetCurrentSegmentFileName Method (Directory)

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentFileName Method (Directory)
SegmentInfos Class See Also Send Feedback
Get the filename of the current segments_N file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetCurrentSegmentFileName(
    Directory directory
)
Visual Basic
Public Shared Function GetCurrentSegmentFileName ( _
    directory As Directory _
) As String
Visual C++
public:
static String^ GetCurrentSegmentFileName(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
-- directory to search for the latest segments_N file

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetCurrentSegmentFileName(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
GetCurrentSegmentFileName Overload
Lucene.Net.Index Namespace


GetCurrentSegmentGeneration Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentGeneration Method
SegmentInfos Class See Also Send Feedback

Overload List

Name | Description
GetCurrentSegmentGeneration(array<String>[]()[][]) | Get the generation (N) of the current segments_N file from a list of files.
GetCurrentSegmentGeneration(Directory) | Get the generation (N) of the current segments_N file in the directory.

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


GetCurrentSegmentGeneration Method (String[])

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentGeneration Method (array<String>[]()[][])
SegmentInfos Class See Also Send Feedback
Get the generation (N) of the current segments_N file from a list of files.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GetCurrentSegmentGeneration(
    string[] files
)
Visual Basic
Public Shared Function GetCurrentSegmentGeneration ( _
    files As String() _
) As Long
Visual C++
public:
static long long GetCurrentSegmentGeneration(
    array<String^>^ files
)

Parameters

files
Type: array< System..::..String >[]()[][]
-- array of file names to check

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetCurrentSegmentGeneration(System.String[])"]

See Also

SegmentInfos Class
GetCurrentSegmentGeneration Overload
Lucene.Net.Index Namespace


GetCurrentSegmentGeneration Method (Directory)

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetCurrentSegmentGeneration Method (Directory)
SegmentInfos Class See Also Send Feedback
Get the generation (N) of the current segments_N file in the directory.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GetCurrentSegmentGeneration(
    Directory directory
)
Visual Basic
Public Shared Function GetCurrentSegmentGeneration ( _
    directory As Directory _
) As Long
Visual C++
public:
static long long GetCurrentSegmentGeneration(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
-- directory to search for the latest segments_N file

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetCurrentSegmentGeneration(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
GetCurrentSegmentGeneration Overload
Lucene.Net.Index Namespace


GetDefaultGenFileRetryCount Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetDefaultGenFileRetryCount Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetDefaultGenFileRetryCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetDefaultGenFileRetryCount()
Visual Basic
Public Shared Function GetDefaultGenFileRetryCount As Integer
Visual C++
public:
static int GetDefaultGenFileRetryCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetDefaultGenFileRetryCount"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace
[!:setDefaultGenFileRetryCount]


GetDefaultGenFileRetryPauseMsec Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetDefaultGenFileRetryPauseMsec Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetDefaultGenFileRetryPauseMsec"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetDefaultGenFileRetryPauseMsec()
Visual Basic
Public Shared Function GetDefaultGenFileRetryPauseMsec As Integer
Visual C++
public:
static int GetDefaultGenFileRetryPauseMsec()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetDefaultGenFileRetryPauseMsec"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace
[!:setDefaultGenFileRetryPauseMsec]


GetDefaultGenLookahedCount Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetDefaultGenLookahedCount Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetDefaultGenLookahedCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetDefaultGenLookahedCount()
Visual Basic
Public Shared Function GetDefaultGenLookahedCount As Integer
Visual C++
public:
static int GetDefaultGenLookahedCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetDefaultGenLookahedCount"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace
[!:setDefaultGenLookaheadCount]


GetEnumerator Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..GetEnumerator Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEnumerator()()()() | Returns an enumerator for the entire ArrayList. (Inherited from ArrayList.)
Public method | GetEnumerator(Int32, Int32) | Returns an enumerator for a range of elements in the ArrayList. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


GetGeneration Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetGeneration Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetGeneration"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long GetGeneration()
Visual Basic
Public Function GetGeneration As Long
Visual C++
public:
long long GetGeneration()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetGeneration"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetHashCode Method
SegmentInfos Class See Also Send Feedback
Calculate hash code of SegmentInfos

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

hash code as in java version of ArrayList

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GetInfoStream Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetInfoStream Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetInfoStream"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static StreamWriter GetInfoStream()
Visual Basic
Public Shared Function GetInfoStream As StreamWriter
Visual C++
public:
static StreamWriter^ GetInfoStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetInfoStream"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace
[!:setInfoStream]


GetLastGeneration Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetLastGeneration Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetLastGeneration"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long GetLastGeneration()
Visual Basic
Public Function GetLastGeneration As Long
Visual C++
public:
long long GetLastGeneration()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetLastGeneration"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GetNextSegmentFileName Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetNextSegmentFileName Method
SegmentInfos Class See Also Send Feedback
Get the next segments_N filename that will be written.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetNextSegmentFileName()
Visual Basic
Public Function GetNextSegmentFileName As String
Visual C++
public:
String^ GetNextSegmentFileName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetNextSegmentFileName"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GetUserData Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetUserData Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.GetUserData"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IDictionary<string, string> GetUserData()
Visual Basic
Public Function GetUserData As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetUserData()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetUserData"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..GetVersion Method
SegmentInfos Class See Also Send Feedback
version number when this SegmentInfos was generated.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long GetVersion()
Visual Basic
Public Function GetVersion As Long
Visual C++
public:
long long GetVersion()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.GetVersion"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


HasExternalSegments Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..HasExternalSegments Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.HasExternalSegments(Lucene.Net.Store.Directory)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool HasExternalSegments(
    Directory dir
)
Visual Basic
Public Function HasExternalSegments ( _
    dir As Directory _
) As Boolean
Visual C++
public:
bool HasExternalSegments(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentInfos.HasExternalSegments(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.HasExternalSegments(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


IndexOf Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..IndexOf Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(Object) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that extends from the specified index to the last element. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that starts at the specified index and contains the specified number of elements. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


Info Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Info Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.Info(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfo Info(
    int i
)
Visual Basic
Public Function Info ( _
    i As Integer _
) As SegmentInfo
Visual C++
public:
SegmentInfo^ Info(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Info(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.Info(System.Int32)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


LastIndexOf Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..LastIndexOf Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(Object) | Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that extends from the first element to the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that contains the specified number of elements and ends at the specified index. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


Range Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Range Method
SegmentInfos Class See Also Send Feedback
Returns a new SegmentInfos containg the SegmentInfo instances in the specified range first (inclusive) to last (exclusive), so total number of segments returned is last-first.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentInfos Range(
    int first,
    int last
)
Visual Basic
Public Function Range ( _
    first As Integer, _
    last As Integer _
) As SegmentInfos
Visual C++
public:
SegmentInfos^ Range(
    int first,
    int last
)

Parameters

first
Type: System..::..Int32

[Missing <param name="first"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Range(System.Int32,System.Int32)"]

last
Type: System..::..Int32

[Missing <param name="last"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Range(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.Range(System.Int32,System.Int32)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..Read Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(Directory) | This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.
Public method | Read(Directory, String) | Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


Read Method (Directory)

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Read Method (Directory)
SegmentInfos Class See Also Send Feedback
This version of read uses the retry logic (for lock-less commits) to find the right segments file to load.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Read(
    Directory directory
)
Visual Basic
Public Sub Read ( _
    directory As Directory _
)
Visual C++
public:
void Read(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.SegmentInfos.Read(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
Read Overload
Lucene.Net.Index Namespace


Read Method (Directory, String)

[image]

Lucene.Net Class Libraries
SegmentInfos..::..Read Method (Directory, String)
SegmentInfos Class See Also Send Feedback
Read a particular segmentFileName. Note that this may throw an IOException if a commit is in process.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Read(
    Directory directory,
    string segmentFileName
)
Visual Basic
Public Sub Read ( _
    directory As Directory, _
    segmentFileName As String _
)
Visual C++
public:
void Read(
    Directory^ directory,
    String^ segmentFileName
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory
-- directory containing the segments file
segmentFileName
Type: System..::..String
-- segment file to load

See Also

SegmentInfos Class
Read Overload
Lucene.Net.Index Namespace


ReadCurrentUserData Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..ReadCurrentUserData Method
SegmentInfos Class See Also Send Feedback
Returns userData from latest segments file

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IDictionary<string, string> ReadCurrentUserData(
    Directory directory
)
Visual Basic
Public Shared Function ReadCurrentUserData ( _
    directory As Directory _
) As IDictionary(Of String, String)
Visual C++
public:
static IDictionary<String^, String^>^ ReadCurrentUserData(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.SegmentInfos.ReadCurrentUserData(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.ReadCurrentUserData(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


ReadCurrentVersion Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..ReadCurrentVersion Method
SegmentInfos Class See Also Send Feedback
Current version number from segments file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long ReadCurrentVersion(
    Directory directory
)
Visual Basic
Public Shared Function ReadCurrentVersion ( _
    directory As Directory _
) As Long
Visual C++
public:
static long long ReadCurrentVersion(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.SegmentInfos.ReadCurrentVersion(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.ReadCurrentVersion(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


Reverse Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..Reverse Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire ArrayList. (Inherited from ArrayList.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


SegString Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..SegString Method
SegmentInfos Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.SegString(Lucene.Net.Store.Directory)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string SegString(
    Directory directory
)
Visual Basic
Public Function SegString ( _
    directory As Directory _
) As String
Visual C++
public:
String^ SegString(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.SegmentInfos.SegString(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.SegString(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SetDefaultGenFileRetryCount Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..SetDefaultGenFileRetryCount Method
SegmentInfos Class See Also Send Feedback
Advanced: set how many times to try loading the segments.gen file contents to determine current segment generation. This file is only referenced when the primary method (listing the directory) fails.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetDefaultGenFileRetryCount(
    int count
)
Visual Basic
Public Shared Sub SetDefaultGenFileRetryCount ( _
    count As Integer _
)
Visual C++
public:
static void SetDefaultGenFileRetryCount(
    int count
)

Parameters

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Lucene.Net.Index.SegmentInfos.SetDefaultGenFileRetryCount(System.Int32)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SetDefaultGenFileRetryPauseMsec Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..SetDefaultGenFileRetryPauseMsec Method
SegmentInfos Class See Also Send Feedback
Advanced: set how many milliseconds to pause in between attempts to load the segments.gen file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetDefaultGenFileRetryPauseMsec(
    int msec
)
Visual Basic
Public Shared Sub SetDefaultGenFileRetryPauseMsec ( _
    msec As Integer _
)
Visual C++
public:
static void SetDefaultGenFileRetryPauseMsec(
    int msec
)

Parameters

msec
Type: System..::..Int32

[Missing <param name="msec"/> documentation for "M:Lucene.Net.Index.SegmentInfos.SetDefaultGenFileRetryPauseMsec(System.Int32)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SetDefaultGenLookaheadCount Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..SetDefaultGenLookaheadCount Method
SegmentInfos Class See Also Send Feedback
Advanced: set how many times to try incrementing the gen when loading the segments file. This only runs if the primary (listing directory) and secondary (opening segments.gen file) methods fail to find the segments file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetDefaultGenLookaheadCount(
    int count
)
Visual Basic
Public Shared Sub SetDefaultGenLookaheadCount ( _
    count As Integer _
)
Visual C++
public:
static void SetDefaultGenLookaheadCount(
    int count
)

Parameters

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Lucene.Net.Index.SegmentInfos.SetDefaultGenLookaheadCount(System.Int32)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SetInfoStream Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..SetInfoStream Method
SegmentInfos Class See Also Send Feedback
If non-null, information about retries when loading the segments file will be printed to this.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetInfoStream(
    StreamWriter infoStream
)
Visual Basic
Public Shared Sub SetInfoStream ( _
    infoStream As StreamWriter _
)
Visual C++
public:
static void SetInfoStream(
    StreamWriter^ infoStream
)

Parameters

infoStream
Type: System.IO..::..StreamWriter

[Missing <param name="infoStream"/> documentation for "M:Lucene.Net.Index.SegmentInfos.SetInfoStream(System.IO.StreamWriter)"]

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


Sort Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..Sort Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from ArrayList.)
Public method | Sort(IComparer) | Sorts the elements in the entire ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | Sort(Int32, Int32, IComparer) | Sorts the elements in a range of elements in ArrayList using the specified comparer. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


ToArray Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..ToArray Method
SegmentInfos Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToArray()()()() | Copies the elements of the ArrayList to a new Object array. (Inherited from ArrayList.)
Public method | ToArray(Type) | Copies the elements of the ArrayList to a new array of the specified element type. (Inherited from ArrayList.)

See Also

SegmentInfos Class
SegmentInfos Members
Lucene.Net.Index Namespace


SegmentInfos Properties

[image] [image]

Lucene.Net Class Libraries
SegmentInfos Properties
SegmentInfos Class See Also Send Feedback

The SegmentInfos type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the ArrayList can contain. (Inherited from ArrayList.)
Public property | Count | Gets the number of elements actually contained in the ArrayList. (Inherited from ArrayList.)
Public property | IsFixedSize | Gets a value indicating whether the ArrayList has a fixed size. (Inherited from ArrayList.)
Public property | IsReadOnly | Gets a value indicating whether the ArrayList is read-only. (Inherited from ArrayList.)
Public property | IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread safe). (Inherited from ArrayList.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ArrayList.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ArrayList. (Inherited from ArrayList.)

See Also

SegmentInfos Class
Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Class

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile Class
SegmentInfos Class Members See Also Send Feedback
Utility class for executing code that needs to do something with the current segments file. This is necessary with lock-less commits because from the time you locate the current segments file name, until you actually open it, read its contents, or check modified time, etc., it could have been deleted due to a writer commit finishing.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FindSegmentsFile
Visual Basic
Public MustInherit Class FindSegmentsFile
Visual C++
public ref class FindSegmentsFile abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentInfos..::..FindSegmentsFile

See Also

SegmentInfos..::..FindSegmentsFile Members
Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Members

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile Members
SegmentInfos..::..FindSegmentsFile Class Constructors Methods See Also Send Feedback

A collection of segmentInfo objects with methods for operating on those segments in relation to the file system.

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentInfos..::..FindSegmentsFile type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentInfos..::..FindSegmentsFile | Initializes a new instance of the SegmentInfos..::..FindSegmentsFile class

Methods

 | Name | Description
Public method | DoBody | Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run()()()() |
Public method | Run(IndexCommit) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentInfos..::..FindSegmentsFile Class
Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Constructor

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile Constructor
SegmentInfos..::..FindSegmentsFile Class See Also Send Feedback
Initializes a new instance of the SegmentInfos..::..FindSegmentsFile class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FindSegmentsFile(
    Directory directory
)
Visual Basic
Public Sub New ( _
    directory As Directory _
)
Visual C++
public:
FindSegmentsFile(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.#ctor(Lucene.Net.Store.Directory)"]

See Also

SegmentInfos..::..FindSegmentsFile Class
Lucene.Net.Index Namespace


SegmentInfos.FindSegmentsFile Methods

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile Methods
SegmentInfos..::..FindSegmentsFile Class See Also Send Feedback

The SegmentInfos..::..FindSegmentsFile type exposes the following members.

Methods

 | Name | Description
Public method | DoBody | Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run()()()() |
Public method | Run(IndexCommit) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentInfos..::..FindSegmentsFile Class
Lucene.Net.Index Namespace


DoBody Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile..::..DoBody Method
SegmentInfos..::..FindSegmentsFile Class See Also Send Feedback
Subclass must implement this. The assumption is an IOException will be thrown if something goes wrong during the processing that could have been caused by a writer committing.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Object DoBody(
    string segmentFileName
)
Visual Basic
Public MustOverride Function DoBody ( _
    segmentFileName As String _
) As Object
Visual C++
public:
virtual Object^ DoBody(
    String^ segmentFileName
) abstract

Parameters

segmentFileName
Type: System..::..String

[Missing <param name="segmentFileName"/> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.DoBody(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.DoBody(System.String)"]

See Also

SegmentInfos..::..FindSegmentsFile Class
Lucene.Net.Index Namespace


Run Method

[image] [image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile..::..Run Method
SegmentInfos..::..FindSegmentsFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Run()()()() |
Public method | Run(IndexCommit) |

See Also

SegmentInfos..::..FindSegmentsFile Class
SegmentInfos..::..FindSegmentsFile Members
Lucene.Net.Index Namespace


Run Method

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile..::..Run Method
SegmentInfos..::..FindSegmentsFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Run()
Visual Basic
Public Function Run As Object
Visual C++
public:
Object^ Run()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run"]

See Also

SegmentInfos..::..FindSegmentsFile Class
Run Overload
Lucene.Net.Index Namespace


Run Method (IndexCommit)

[image]

Lucene.Net Class Libraries
SegmentInfos..::..FindSegmentsFile..::..Run Method (IndexCommit)
SegmentInfos..::..FindSegmentsFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run(Lucene.Net.Index.IndexCommit)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Run(
    IndexCommit commit
)
Visual Basic
Public Function Run ( _
    commit As IndexCommit _
) As Object
Visual C++
public:
Object^ Run(
    IndexCommit^ commit
)

Parameters

commit
Type: Lucene.Net.Index..::..IndexCommit

[Missing <param name="commit"/> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run(Lucene.Net.Index.IndexCommit)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run(Lucene.Net.Index.IndexCommit)"]

See Also

SegmentInfos..::..FindSegmentsFile Class
Run Overload
Lucene.Net.Index Namespace


SegmentMerger Class

[image]

Lucene.Net Class Libraries
SegmentMerger Class
Members See Also Send Feedback
The SegmentMerger class combines two or more Segments, represented by an IndexReader ({@link #add}, into a single Segment. After adding the appropriate readers, call the merge method to combine the segments.

If the compoundFile flag is set, then the segments will be merged into a compound file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class SegmentMerger
Visual Basic
Public NotInheritable Class SegmentMerger
Visual C++
public ref class SegmentMerger sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentMerger

See Also

SegmentMerger Members
Lucene.Net.Index Namespace
[!:merge]
[!:add]


SegmentMerger Members

[image] [image]

Lucene.Net Class Libraries
SegmentMerger Members
SegmentMerger Class Constructors Methods See Also Send Feedback

The SegmentMerger type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentMerger | This ctor used only by test code.

Methods

 | Name | Description
Public method | Add | Add an IndexReader to the collection of readers that are to be merged
Public method | CloseReaders | close all IndexReaders that have been added. Should not be called before merge().
Public method | CreateCompoundFile |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMergedFiles |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merges the readers specified by the {@link #add} method into the directory passed to the constructor
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


SegmentMerger Constructor

[image]

Lucene.Net Class Libraries
SegmentMerger Constructor
SegmentMerger Class See Also Send Feedback
This ctor used only by test code.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentMerger(
    Directory dir,
    string name
)
Visual Basic
Public Sub New ( _
    dir As Directory, _
    name As String _
)
Visual C++
public:
SegmentMerger(
    Directory^ dir,
    String^ name
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory
The Directory to merge the other segments into
name
Type: System..::..String
The name of the new segment

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


SegmentMerger Methods

[image] [image]

Lucene.Net Class Libraries
SegmentMerger Methods
SegmentMerger Class See Also Send Feedback

The SegmentMerger type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an IndexReader to the collection of readers that are to be merged
Public method | CloseReaders | close all IndexReaders that have been added. Should not be called before merge().
Public method | CreateCompoundFile |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMergedFiles |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merges the readers specified by the {@link #add} method into the directory passed to the constructor
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


Add Method

[image]

Lucene.Net Class Libraries
SegmentMerger..::..Add Method
SegmentMerger Class See Also Send Feedback
Add an IndexReader to the collection of readers that are to be merged

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Add(
    IndexReader reader
)
Visual Basic
Public Sub Add ( _
    reader As IndexReader _
)
Visual C++
public:
void Add(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Index.SegmentMerger.Add(Lucene.Net.Index.IndexReader)"]

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


CloseReaders Method

[image]

Lucene.Net Class Libraries
SegmentMerger..::..CloseReaders Method
SegmentMerger Class See Also Send Feedback
close all IndexReaders that have been added. Should not be called before merge().

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void CloseReaders()
Visual Basic
Public Sub CloseReaders
Visual C++
public:
void CloseReaders()

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


CreateCompoundFile Method

[image]

Lucene.Net Class Libraries
SegmentMerger..::..CreateCompoundFile Method
SegmentMerger Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentMerger.CreateCompoundFile(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ICollection<string> CreateCompoundFile(
    string fileName
)
Visual Basic
Public Function CreateCompoundFile ( _
    fileName As String _
) As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ CreateCompoundFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:Lucene.Net.Index.SegmentMerger.CreateCompoundFile(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentMerger.CreateCompoundFile(System.String)"]

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


GetMergedFiles Method

[image]

Lucene.Net Class Libraries
SegmentMerger..::..GetMergedFiles Method
SegmentMerger Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentMerger.GetMergedFiles"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ICollection<string> GetMergedFiles()
Visual Basic
Public Function GetMergedFiles As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ GetMergedFiles()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentMerger.GetMergedFiles"]

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


Merge Method

[image]

Lucene.Net Class Libraries
SegmentMerger..::..Merge Method
SegmentMerger Class See Also Send Feedback
Merges the readers specified by the {@link #add} method into the directory passed to the constructor

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Merge()
Visual Basic
Public Function Merge As Integer
Visual C++
public:
int Merge()

Return Value

The number of documents that were merged

See Also

SegmentMerger Class
Lucene.Net.Index Namespace


SegmentReader Class

[image]

Lucene.Net Class Libraries
SegmentReader Class
Members See Also Send Feedback

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SegmentReader : IndexReader,
    ICloneable
Visual Basic
Public Class SegmentReader _
    Inherits IndexReader _
    Implements ICloneable
Visual C++
public ref class SegmentReader : public IndexReader,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexReader
Lucene.Net.Index..::..SegmentReader
Lucene.Net.Index..::..ReadOnlySegmentReader

See Also

SegmentReader Members
Lucene.Net.Index Namespace


SegmentReader Members

[image] [image]

Lucene.Net Class Libraries
SegmentReader Members
SegmentReader Class Constructors Methods Fields Properties See Also Send Feedback

The SegmentReader type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentReader | Initializes a new instance of the SegmentReader class

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | (Overrides IndexReader..::..Clone(Boolean).)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Overrides IndexReader..::..Directory()()()().)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | FieldInfos
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Get(SegmentInfo) | Obsolete.
Get(Boolean, SegmentInfo, Int32)
Get(Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Overrides IndexReader..::..GetDeletesCacheKey()()()().)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method | GetFieldCacheKey | Obsolete. (Overrides IndexReader..::..GetFieldCacheKey()()()().)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Protected method | GetNorms
GetOnlySegmentReader(Directory)
Lotsa tests did hacks like:
SegmentReader reader = (SegmentReader) IndexReader.open(dir);
They broke. This method serves as a hack to keep hacks working
GetOnlySegmentReader(IndexReader)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method GetSegmentName
Return the name of the segment this reader is reading.
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method | GetTermInfosIndexDivisor | (Overrides IndexReader..::..GetTermInfosIndexDivisor()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUniqueTermCount | (Overrides IndexReader..::..GetUniqueTermCount()()()().)
Public method GetVersion
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

(Inherited from IndexReader.)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method Norms(String, array<Byte>[]()[][], Int32)
Read norms into a pre-allocated array.
(Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method | NormsClosed()()()()
Public method | NormsClosed(String)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method | TermsIndexLoaded
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly |

Properties

 | Name | Description
Public property | core_ForNUnit |
Public property | deletedDocs_ForNUnit |
Public property | deletedDocsRef_ForNUnit |
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)
Public property | norms_ForNUnit |

See Also

SegmentReader Class
Lucene.Net.Index Namespace


SegmentReader Constructor

[image]

Lucene.Net Class Libraries
SegmentReader Constructor
SegmentReader Class See Also Send Feedback
Initializes a new instance of the SegmentReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentReader()
Visual Basic
Public Sub New
Visual C++
public:
SegmentReader()

See Also

SegmentReader Class
Lucene.Net.Index Namespace


SegmentReader Fields

[image] [image]

Lucene.Net Class Libraries
SegmentReader Fields
SegmentReader Class See Also Send Feedback

The SegmentReader type exposes the following members.

Fields

 | Name | Description
Protected field | hasChanges | (Inherited from IndexReader.)
Protected field | readOnly |

See Also

SegmentReader Class
Lucene.Net.Index Namespace


readOnly Field

[image]

Lucene.Net Class Libraries
SegmentReader..::..readOnly Field
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentReader.readOnly"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool readOnly
Visual Basic
Protected Friend readOnly As Boolean
Visual C++
protected public:
bool readOnly

See Also

SegmentReader Class
Lucene.Net.Index Namespace


SegmentReader Methods

[image] [image]

Lucene.Net Class Libraries
SegmentReader Methods
SegmentReader Class See Also Send Feedback

The SegmentReader type exposes the following members.

Methods

Name | Description
Protected method AcquireWriteLock
Does nothing by default. Subclasses that require a write lock for index modifications must implement this method.
(Inherited from IndexReader.)
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | (Overrides IndexReader..::..Clone(Boolean).)
Protected method CloneDeletedDocs
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.
Protected method CloneNormBytes
Clones the norm bytes. May be overridden by subclasses. New and experimental.
Public method Close
Closes files associated with this index. Also saves any new deletions to disk. No other methods should be called after this has been called.
(Inherited from IndexReader.)
Public method Commit()()()()
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method Commit(IDictionary<(Of <<'(String, String>)>>))
Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics).
(Inherited from IndexReader.)
Public method DecRef
Expert: decreases the refCount of this IndexReader instance. If the refCount drops to 0, then pending changes (if any) are committed to the index and this reader is closed.
(Inherited from IndexReader.)
Public method DeleteDocument
Deletes the document numbered
CopyC#
docNum
. Once a document is deleted it will not appear in TermDocs or TermPostitions enumerations. Attempts to read its field with the {@link #document} method will result in an error. The presence of this document may still be reflected in the {@link #docFreq} statistic, though this will be corrected eventually as the index is further modified.
(Inherited from IndexReader.)
Public method DeleteDocuments
Deletes all documents that have a given
CopyC#
term
 indexed. This is useful if one uses a document field to hold a unique ID string for the document. Then to delete such a document, one merely constructs a term with the appropriate field and the unique ID string as its text and passes it to this method. See {@link #DeleteDocument(int)} for information about when this deletion will become effective.
(Inherited from IndexReader.)
Public method Directory
Returns the directory this index resides in.
(Overrides IndexReader..::..Directory()()()().)
Public method Dispose
.NET
(Inherited from IndexReader.)
Public method | DocFreq | (Overrides IndexReader..::..DocFreq(Term).)
Protected method | DoClose | (Overrides IndexReader..::..DoClose()()()().)
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)
Protected method | DoDelete | (Overrides IndexReader..::..DoDelete(Int32).)
Protected method | DoSetNorm | (Overrides IndexReader..::..DoSetNorm(Int32, String, Byte).)
Protected method | DoUndeleteAll | (Overrides IndexReader..::..DoUndeleteAll()()()().)
Protected method | EnsureOpen | (Inherited from IndexReader.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | FieldInfos
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Flush()()()()
(Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)
Get(SegmentInfo) | Obsolete.
Get(Boolean, SegmentInfo, Int32)
Get(Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)
Public method GetCommitUserData()()()()
Retrieve the String userData optionally passed to IndexWriter#commit. This will return null if {@link IndexWriter#Commit(Map)} has never been called for this index.
(Inherited from IndexReader.)
Public method | GetDeletesCacheKey | (Overrides IndexReader..::..GetDeletesCacheKey()()()().)
Public method GetDisableFakeNorms Obsolete.
Expert: Return the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method | GetFieldCacheKey | Obsolete. (Overrides IndexReader..::..GetFieldCacheKey()()()().)
Public method | GetFieldNames | (Overrides IndexReader..::..GetFieldNames(IndexReader..::..FieldOption).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexCommit
Expert: return the IndexCommit that this reader has opened. This method is only implemented by those readers that correspond to a Directory with its own segments_N file.

WARNING: this API is new and experimental and may suddenly change.

(Inherited from IndexReader.)
Protected method | GetNorms
GetOnlySegmentReader(Directory)
Lotsa tests did hacks like:
SegmentReader reader = (SegmentReader) IndexReader.open(dir);
They broke. This method serves as a hack to keep hacks working
GetOnlySegmentReader(IndexReader)
Public method GetRefCount
Expert: returns the current refCount for this reader
(Inherited from IndexReader.)
Public method GetSegmentName
Return the name of the segment this reader is reading.
Public method GetSequentialSubReaders
Expert: returns the sequential sub readers that this reader is logically composed of. For example, IndexSearcher uses this API to drive searching by one sub reader at a time. If this reader is not composed of sequential child readers, it should return null. If this method returns an empty array, that means this reader is a null reader (for example a MultiReader that has no sub readers).

NOTE: You should not try using sub-readers returned by this method to make any changes (setNorm, deleteDocument, etc.). While this might succeed for one composite reader (like MultiReader), it will most likely lead to index corruption for other readers (like DirectoryReader obtained through {@link #open}. Use the parent reader directly.

(Inherited from IndexReader.)
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method GetTermFreqVector(Int32, String)
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.
(Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)
Public method GetTermFreqVectors
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.
(Overrides IndexReader..::..GetTermFreqVectors(Int32).)
Public method | GetTermInfosIndexDivisor | (Overrides IndexReader..::..GetTermInfosIndexDivisor()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUniqueTermCount | (Overrides IndexReader..::..GetUniqueTermCount()()()().)
Public method GetVersion
Version number when this IndexReader was opened. Not implemented in the IndexReader base class.

If this reader is based on a Directory (ie, was created by calling {@link #Open}, or {@link #Reopen} on a reader based on a Directory), then this method returns the version recorded in the commit that the reader opened. This version is advanced every time {@link IndexWriter#Commit} is called.

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#GetReader}, or by calling {@link #Reopen} on a near real-time reader), then this method returns the version of the last commit done by the writer. Note that even as further changes are made with the writer, the version will not changed until a commit is completed. Thus, you should not rely on this method to determine when a near real-time reader should be opened. Use {@link #IsCurrent} instead.

(Inherited from IndexReader.)
Public method | HasDeletions | (Overrides IndexReader..::..HasDeletions()()()().)
Public method | HasNorms | (Overrides IndexReader..::..HasNorms(String).)
Public method IncRef
Expert: increments the refCount of this IndexReader instance. RefCounts are used to determine when a reader can be closed safely, i.e. as soon as there are no more references. Be sure to always call a corresponding {@link #decRef}, in a finally clause; otherwise the reader may never be closed. Note that {@link #close} simply calls decRef(), which means that the IndexReader will not really be closed until {@link #decRef} has been called for all outstanding references.
(Inherited from IndexReader.)
Public method IsCurrent
Check whether any new changes have occurred to the index since this reader was opened.

If this reader is based on a Directory (ie, was created by calling {@link #open}, or {@link #reopen} on a reader based on a Directory), then this method checks if any further commits (see {@link IndexWriter#commit} have occurred in that directory).

If instead this reader is a near real-time reader (ie, obtained by a call to {@link IndexWriter#getReader}, or by calling {@link #reopen} on a near real-time reader), then this method checks if either a new commmit has occurred, or any new uncommitted changes have taken place via the writer. Note that even if the writer has only performed merging, this method will still return false.

In any event, if this returns false, you should call {@link #reopen} to get a new reader that sees the changes.

(Inherited from IndexReader.)
Public method | IsDeleted | (Overrides IndexReader..::..IsDeleted(Int32).)
Public method IsOptimized
Checks is the index is optimized (if it has a single segment and no deletions). Not implemented in the IndexReader base class.
(Inherited from IndexReader.)
Public method | MaxDoc | (Overrides IndexReader..::..MaxDoc()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method Norms(String, array<Byte>[]()[][], Int32)
Read norms into a pre-allocated array.
(Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)
Public method | NormsClosed()()()()
Public method | NormsClosed(String)
Public method NumDeletedDocs
Returns the number of deleted documents.
(Inherited from IndexReader.)
Public method | NumDocs | (Overrides IndexReader..::..NumDocs()()()().)
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)
Public method SetDisableFakeNorms Obsolete.
Expert: Set the state of the flag that disables fakes norms in favor of representing the absence of field norms with null.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Byte)
Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing.
(Inherited from IndexReader.)
Public method SetNorm(Int32, String, Single)
Expert: Resets the normalization factor for the named field of the named document.
(Inherited from IndexReader.)
Public method SetTermInfosIndexDivisor Obsolete.

For IndexReader implementations that use TermInfosReader to read terms, this sets the indexDivisor to subsample the number of indexed terms loaded into memory. This has the same effect as {@link IndexWriter#setTermIndexInterval} except that setting must be done at indexing time while this setting can be set per reader. When set to N, then one in every N*termIndexInterval terms in the index is loaded into memory. By setting this to a value > 1 you can reduce memory usage, at the expense of higher latency when loading a TermInfo. The default value is 1.

NOTE: you must call this before the term index is loaded. If the index is already loaded, an IllegalStateException is thrown.

(Inherited from IndexReader.)
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)
Public method | TermsIndexLoaded
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UndeleteAll
Undeletes all documents currently marked as deleted in this index.
(Inherited from IndexReader.)

See Also

SegmentReader Class
Lucene.Net.Index Namespace


Clone Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Clone Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | (Overrides IndexReader..::..Clone()()()().)
Public method | Clone(Boolean) | (Overrides IndexReader..::..Clone(Boolean).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Clone Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SegmentReader Class
Clone Overload
Lucene.Net.Index Namespace


Clone Method (Boolean)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Clone Method (Boolean)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Clone(System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexReader Clone(
    bool openReadOnly
)
Visual Basic
Public Overrides Function Clone ( _
    openReadOnly As Boolean _
) As IndexReader
Visual C++
public:
virtual IndexReader^ Clone(
    bool openReadOnly
) override

Parameters

openReadOnly
Type: System..::..Boolean

[Missing <param name="openReadOnly"/> documentation for "M:Lucene.Net.Index.SegmentReader.Clone(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Clone(System.Boolean)"]

See Also

SegmentReader Class
Clone Overload
Lucene.Net.Index Namespace


CloneDeletedDocs Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..CloneDeletedDocs Method
SegmentReader Class See Also Send Feedback
Clones the deleteDocs BitVector. May be overridden by subclasses. New and experimental.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual BitVector CloneDeletedDocs(
    BitVector bv
)
Visual Basic
Protected Friend Overridable Function CloneDeletedDocs ( _
    bv As BitVector _
) As BitVector
Visual C++
protected public:
virtual BitVector^ CloneDeletedDocs(
    BitVector^ bv
)

Parameters

bv
Type: Lucene.Net.Util..::..BitVector
BitVector to clone

Return Value

New BitVector

See Also

SegmentReader Class
Lucene.Net.Index Namespace


CloneNormBytes Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..CloneNormBytes Method
SegmentReader Class See Also Send Feedback
Clones the norm bytes. May be overridden by subclasses. New and experimental.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual byte[] CloneNormBytes(
    byte[] bytes
)
Visual Basic
Protected Friend Overridable Function CloneNormBytes ( _
    bytes As Byte() _
) As Byte()
Visual C++
protected public:
virtual array<unsigned char>^ CloneNormBytes(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]
Byte array to clone

Return Value

New BitVector

See Also

SegmentReader Class
Lucene.Net.Index Namespace


Commit Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Commit Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)
Public method | Commit(IDictionary<(Of <<'(String, String>)>>)) | Commit changes resulting from delete, undeleteAll, or setNorm operations If an exception is hit, then either no changes or all changes will have been committed to the index (transactional semantics). (Inherited from IndexReader.)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Directory Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Directory Method
SegmentReader Class See Also Send Feedback
Returns the directory this index resides in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Directory Directory()
Visual Basic
Public Overrides Function Directory As Directory
Visual C++
public:
virtual Directory^ Directory() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Directory"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..DocFreq Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term t
)
Visual Basic
Public Overrides Function DocFreq ( _
    t As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ t
) override

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.SegmentReader.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.DocFreq(Lucene.Net.Index.Term)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


DoClose Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..DoClose Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DoClose"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoClose()
Visual Basic
Protected Friend Overrides Sub DoClose
Visual C++
protected public:
virtual void DoClose() override

See Also

SegmentReader Class
Lucene.Net.Index Namespace


DoCommit Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..DoCommit Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoCommit()()()() | Obsolete. (Overrides IndexReader..::..DoCommit()()()().)
Protected method | DoCommit(IDictionary<(Of <<'(String, String>)>>)) | (Overrides IndexReader..::..DoCommit(IDictionary<(Of <<'(String, String>)>>)).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


DoCommit Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..DoCommit Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DoCommit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal override void DoCommit()
Visual Basic
<ObsoleteAttribute> _
Protected Friend Overrides Sub DoCommit
Visual C++
[ObsoleteAttribute]
protected public:
virtual void DoCommit() override

See Also

SegmentReader Class
DoCommit Overload
Lucene.Net.Index Namespace


DoCommit Method (IDictionary(String, String))

[image]

Lucene.Net Class Libraries
SegmentReader..::..DoCommit Method (IDictionary<(Of <(<'String, String>)>)>)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoCommit(
    IDictionary<string, string> commitUserData
)
Visual Basic
Protected Friend Overrides Sub DoCommit ( _
    commitUserData As IDictionary(Of String, String) _
)
Visual C++
protected public:
virtual void DoCommit(
    IDictionary<String^, String^>^ commitUserData
) override

Parameters

commitUserData
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="commitUserData"/> documentation for "M:Lucene.Net.Index.SegmentReader.DoCommit(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

SegmentReader Class
DoCommit Overload
Lucene.Net.Index Namespace


Document Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Document Method
SegmentReader Class See Also Send Feedback

Overload List

Name | Description
Public method Document(Int32)
Returns the stored fields of the
CopyC#
n
th
CopyC#
Document
 in this index.

NOTE: for performance reasons, this method does not check if the requested document is deleted, and therefore asking for a deleted document may yield unspecified results. Usually this is not required, however you can call {@link #IsDeleted(int)} with the requested document ID to verify the document is not deleted.

(Inherited from IndexReader.)
Public method | Document(Int32, FieldSelector) | (Overrides IndexReader..::..Document(Int32, FieldSelector).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Document Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Document Method (Int32, FieldSelector)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Document(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Document ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Document(
    int n,
    FieldSelector^ fieldSelector
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.SegmentReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Index.SegmentReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Document(System.Int32,Lucene.Net.Documents.FieldSelector)"]

See Also

SegmentReader Class
Document Overload
Lucene.Net.Index Namespace


DoDelete Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..DoDelete Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DoDelete(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoDelete(
    int docNum
)
Visual Basic
Protected Friend Overrides Sub DoDelete ( _
    docNum As Integer _
)
Visual C++
protected public:
virtual void DoDelete(
    int docNum
) override

Parameters

docNum
Type: System..::..Int32

[Missing <param name="docNum"/> documentation for "M:Lucene.Net.Index.SegmentReader.DoDelete(System.Int32)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


DoSetNorm Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..DoSetNorm Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoSetNorm(
    int doc,
    string field,
    byte value_Renamed
)
Visual Basic
Protected Friend Overrides Sub DoSetNorm ( _
    doc As Integer, _
    field As String, _
    value_Renamed As Byte _
)
Visual C++
protected public:
virtual void DoSetNorm(
    int doc,
    String^ field,
    unsigned char value_Renamed
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Index.SegmentReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

value_Renamed
Type: System..::..Byte

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Index.SegmentReader.DoSetNorm(System.Int32,System.String,System.Byte)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


DoUndeleteAll Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..DoUndeleteAll Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.DoUndeleteAll"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void DoUndeleteAll()
Visual Basic
Protected Friend Overrides Sub DoUndeleteAll
Visual C++
protected public:
virtual void DoUndeleteAll() override

See Also

SegmentReader Class
Lucene.Net.Index Namespace


FieldInfos Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..FieldInfos Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.FieldInfos"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldInfos FieldInfos()
Visual Basic
Public Overridable Function FieldInfos As FieldInfos
Visual C++
public:
virtual FieldInfos^ FieldInfos()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.FieldInfos"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


Flush Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Flush Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flush()()()() | (Inherited from IndexReader.)
Public method | Flush(IDictionary<(Of <<'(String, String>)>>)) | (Inherited from IndexReader.)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Get Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Get Method
SegmentReader Class See Also Send Feedback

Overload List

Name | Description
Get(SegmentInfo) | Obsolete.
Get(Boolean, SegmentInfo, Int32) |
Get(Boolean, Directory, SegmentInfo, Int32, Boolean, Int32) |

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Get Method (SegmentInfo)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Get Method (SegmentInfo)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Get(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public static SegmentReader Get(
    SegmentInfo si
)
Visual Basic
<ObsoleteAttribute> _
Public Shared Function Get ( _
    si As SegmentInfo _
) As SegmentReader
Visual C++
[ObsoleteAttribute]
public:
static SegmentReader^ Get(
    SegmentInfo^ si
)

Parameters

si
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="si"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(Lucene.Net.Index.SegmentInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Get(Lucene.Net.Index.SegmentInfo)"]

See Also

SegmentReader Class
Get Overload
Lucene.Net.Index Namespace


Get Method (Boolean, SegmentInfo, Int32)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Get Method (Boolean, SegmentInfo, Int32)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Index.SegmentInfo,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static SegmentReader Get(
    bool readOnly,
    SegmentInfo si,
    int termInfosIndexDivisor
)
Visual Basic
Public Shared Function Get ( _
    readOnly As Boolean, _
    si As SegmentInfo, _
    termInfosIndexDivisor As Integer _
) As SegmentReader
Visual C++
public:
static SegmentReader^ Get(
    bool readOnly,
    SegmentInfo^ si,
    int termInfosIndexDivisor
)

Parameters

readOnly
Type: System..::..Boolean

[Missing <param name="readOnly"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Index.SegmentInfo,System.Int32)"]

si
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="si"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Index.SegmentInfo,System.Int32)"]

termInfosIndexDivisor
Type: System..::..Int32

[Missing <param name="termInfosIndexDivisor"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Index.SegmentInfo,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Index.SegmentInfo,System.Int32)"]

See Also

SegmentReader Class
Get Overload
Lucene.Net.Index Namespace


Get Method (Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Get Method (Boolean, Directory, SegmentInfo, Int32, Boolean, Int32)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static SegmentReader Get(
    bool readOnly,
    Directory dir,
    SegmentInfo si,
    int readBufferSize,
    bool doOpenStores,
    int termInfosIndexDivisor
)
Visual Basic
Public Shared Function Get ( _
    readOnly As Boolean, _
    dir As Directory, _
    si As SegmentInfo, _
    readBufferSize As Integer, _
    doOpenStores As Boolean, _
    termInfosIndexDivisor As Integer _
) As SegmentReader
Visual C++
public:
static SegmentReader^ Get(
    bool readOnly,
    Directory^ dir,
    SegmentInfo^ si,
    int readBufferSize,
    bool doOpenStores,
    int termInfosIndexDivisor
)

Parameters

readOnly
Type: System..::..Boolean

[Missing <param name="readOnly"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

si
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="si"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

readBufferSize
Type: System..::..Int32

[Missing <param name="readBufferSize"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

doOpenStores
Type: System..::..Boolean

[Missing <param name="doOpenStores"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

termInfosIndexDivisor
Type: System..::..Int32

[Missing <param name="termInfosIndexDivisor"/> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Get(System.Boolean,Lucene.Net.Store.Directory,Lucene.Net.Index.SegmentInfo,System.Int32,System.Boolean,System.Int32)"]

See Also

SegmentReader Class
Get Overload
Lucene.Net.Index Namespace


GetDeletesCacheKey Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetDeletesCacheKey Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetDeletesCacheKey"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object GetDeletesCacheKey()
Visual Basic
Public Overrides Function GetDeletesCacheKey As Object
Visual C++
public:
virtual Object^ GetDeletesCacheKey() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetDeletesCacheKey"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


GetFieldCacheKey Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetFieldCacheKey Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetFieldCacheKey"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Index.IndexReader.GetFieldCacheKey()")]
public override Object GetFieldCacheKey()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Index.IndexReader.GetFieldCacheKey()")> _
Public Overrides Function GetFieldCacheKey As Object
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Index.IndexReader.GetFieldCacheKey()")]
public:
virtual Object^ GetFieldCacheKey() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetFieldCacheKey"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetFieldNames Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<string> GetFieldNames(
    IndexReader..::..FieldOption fieldOption
)
Visual Basic
Public Overrides Function GetFieldNames ( _
    fieldOption As IndexReader..::..FieldOption _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFieldNames(
    IndexReader..::..FieldOption^ fieldOption
) override

Parameters

fieldOption
Type: Lucene.Net.Index..::..IndexReader..::..FieldOption

[Missing <param name="fieldOption"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetFieldNames(Lucene.Net.Index.IndexReader.FieldOption)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace
IndexReader..::..GetFieldNames(IndexReader..::..FieldOption)


GetNorms Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetNorms Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetNorms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual byte[] GetNorms(
    string field
)
Visual Basic
Protected Friend Overridable Function GetNorms ( _
    field As String _
) As Byte()
Visual C++
protected public:
virtual array<unsigned char>^ GetNorms(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetNorms(System.String)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


GetOnlySegmentReader Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..GetOnlySegmentReader Method
SegmentReader Class See Also Send Feedback

Overload List

Name | Description
GetOnlySegmentReader(Directory) | Lotsa tests did hacks like: SegmentReader reader = (SegmentReader) IndexReader.open(dir); They broke. This method serves as a hack to keep hacks working
GetOnlySegmentReader(IndexReader) |

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


GetOnlySegmentReader Method (Directory)

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetOnlySegmentReader Method (Directory)
SegmentReader Class See Also Send Feedback
Lotsa tests did hacks like:
SegmentReader reader = (SegmentReader) IndexReader.open(dir);
They broke. This method serves as a hack to keep hacks working

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static SegmentReader GetOnlySegmentReader(
    Directory dir
)
Visual Basic
Public Shared Function GetOnlySegmentReader ( _
    dir As Directory _
) As SegmentReader
Visual C++
public:
static SegmentReader^ GetOnlySegmentReader(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetOnlySegmentReader(Lucene.Net.Store.Directory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetOnlySegmentReader(Lucene.Net.Store.Directory)"]

See Also

SegmentReader Class
GetOnlySegmentReader Overload
Lucene.Net.Index Namespace


GetOnlySegmentReader Method (IndexReader)

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetOnlySegmentReader Method (IndexReader)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetOnlySegmentReader(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static SegmentReader GetOnlySegmentReader(
    IndexReader reader
)
Visual Basic
Public Shared Function GetOnlySegmentReader ( _
    reader As IndexReader _
) As SegmentReader
Visual C++
public:
static SegmentReader^ GetOnlySegmentReader(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetOnlySegmentReader(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetOnlySegmentReader(Lucene.Net.Index.IndexReader)"]

See Also

SegmentReader Class
GetOnlySegmentReader Overload
Lucene.Net.Index Namespace


GetSegmentName Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetSegmentName Method
SegmentReader Class See Also Send Feedback
Return the name of the segment this reader is reading.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetSegmentName()
Visual Basic
Public Overridable Function GetSegmentName As String
Visual C++
public:
virtual String^ GetSegmentName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetSegmentName"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


GetTermFreqVector Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..GetTermFreqVector Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTermFreqVector(Int32, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, TermVectorMapper).)
Public method | GetTermFreqVector(Int32, String) | Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null. (Overrides IndexReader..::..GetTermFreqVector(Int32, String).)
Public method | GetTermFreqVector(Int32, String, TermVectorMapper) | (Overrides IndexReader..::..GetTermFreqVector(Int32, String, TermVectorMapper).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetTermFreqVector Method (Int32, TermVectorMapper)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

See Also

SegmentReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String)

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetTermFreqVector Method (Int32, String)
SegmentReader Class See Also Send Feedback
Return a term frequency vector for the specified document and field. The vector returned contains term numbers and frequencies for all terms in the specified field of this document, if the field had storeTermVector flag set. If the flag was not set, the method returns null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector GetTermFreqVector(
    int docNumber,
    string field
)
Visual Basic
Public Overrides Function GetTermFreqVector ( _
    docNumber As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ GetTermFreqVector(
    int docNumber,
    String^ field
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String)"]

See Also

SegmentReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVector Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetTermFreqVector Method (Int32, String, TermVectorMapper)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void GetTermFreqVector(
    int docNumber,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public Overrides Sub GetTermFreqVector ( _
    docNumber As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void GetTermFreqVector(
    int docNumber,
    String^ field,
    TermVectorMapper^ mapper
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVector(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

See Also

SegmentReader Class
GetTermFreqVector Overload
Lucene.Net.Index Namespace


GetTermFreqVectors Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetTermFreqVectors Method
SegmentReader Class See Also Send Feedback
Return an array of term frequency vectors for the specified document. The array contains a vector for each vectorized field in the document. Each vector vector contains term numbers and frequencies for all terms in a given vectorized field. If no such fields existed, the method returns null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermFreqVector[] GetTermFreqVectors(
    int docNumber
)
Visual Basic
Public Overrides Function GetTermFreqVectors ( _
    docNumber As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ GetTermFreqVectors(
    int docNumber
) override

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVectors(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermFreqVectors(System.Int32)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


GetTermInfosIndexDivisor Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetTermInfosIndexDivisor Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermInfosIndexDivisor"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetTermInfosIndexDivisor()
Visual Basic
Public Overrides Function GetTermInfosIndexDivisor As Integer
Visual C++
public:
virtual int GetTermInfosIndexDivisor() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetTermInfosIndexDivisor"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


GetUniqueTermCount Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..GetUniqueTermCount Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.GetUniqueTermCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetUniqueTermCount()
Visual Basic
Public Overrides Function GetUniqueTermCount As Long
Visual C++
public:
virtual long long GetUniqueTermCount() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.GetUniqueTermCount"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


HasDeletions Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..HasDeletions Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.HasDeletions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasDeletions()
Visual Basic
Public Overrides Function HasDeletions As Boolean
Visual C++
public:
virtual bool HasDeletions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.HasDeletions"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


HasNorms Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..HasNorms Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.HasNorms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool HasNorms(
    string field
)
Visual Basic
Public Overrides Function HasNorms ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool HasNorms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.HasNorms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.HasNorms(System.String)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..IsDeleted Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.IsDeleted(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsDeleted(
    int n
)
Visual Basic
Public Overrides Function IsDeleted ( _
    n As Integer _
) As Boolean
Visual C++
public:
virtual bool IsDeleted(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Index.SegmentReader.IsDeleted(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.IsDeleted(System.Int32)"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..MaxDoc Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.MaxDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.MaxDoc"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


Norms Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Norms Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Norms(String) | (Overrides IndexReader..::..Norms(String).)
Public method | Norms(String, array<Byte>[]()[][], Int32) | Read norms into a pre-allocated array. (Overrides IndexReader..::..Norms(String, array<Byte>[]()[][], Int32).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Norms Method (String)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norms Method (String)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norms(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte[] Norms(
    string field
)
Visual Basic
Public Overrides Function Norms ( _
    field As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Norms(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norms(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Norms(System.String)"]

See Also

SegmentReader Class
Norms Overload
Lucene.Net.Index Namespace


Norms Method (String, Byte[], Int32)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norms Method (String, array<Byte>[]()[][], Int32)
SegmentReader Class See Also Send Feedback
Read norms into a pre-allocated array.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Norms(
    string field,
    byte[] bytes,
    int offset
)
Visual Basic
Public Overrides Sub Norms ( _
    field As String, _
    bytes As Byte(), _
    offset As Integer _
)
Visual C++
public:
virtual void Norms(
    String^ field,
    array<unsigned char>^ bytes,
    int offset
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norms(System.String,System.Byte[],System.Int32)"]

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norms(System.String,System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norms(System.String,System.Byte[],System.Int32)"]

See Also

SegmentReader Class
Norms Overload
Lucene.Net.Index Namespace


NormsClosed Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..NormsClosed Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NormsClosed()()()() |
Public method | NormsClosed(String) |

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


NormsClosed Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..NormsClosed Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.NormsClosed"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool NormsClosed()
Visual Basic
Public Overridable Function NormsClosed As Boolean
Visual C++
public:
virtual bool NormsClosed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.NormsClosed"]

See Also

SegmentReader Class
NormsClosed Overload
Lucene.Net.Index Namespace


NormsClosed Method (String)

[image]

Lucene.Net Class Libraries
SegmentReader..::..NormsClosed Method (String)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.NormsClosed(System.String)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool NormsClosed(
    string field
)
Visual Basic
Public Overridable Function NormsClosed ( _
    field As String _
) As Boolean
Visual C++
public:
virtual bool NormsClosed(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SegmentReader.NormsClosed(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.NormsClosed(System.String)"]

See Also

SegmentReader Class
NormsClosed Overload
Lucene.Net.Index Namespace


NumDocs Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..NumDocs Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.NumDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NumDocs()
Visual Basic
Public Overrides Function NumDocs As Integer
Visual C++
public:
virtual int NumDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.NumDocs"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


Reopen Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Reopen Method
SegmentReader Class See Also Send Feedback

Overload List

Name Description
Public method Reopen()()()()
Refreshes an IndexReader if the index has changed since this instance was (re)opened.

Opening an IndexReader is an expensive operation. This method can be used to refresh an existing IndexReader to reduce these costs. This method tries to only load segments that have changed or were created after the IndexReader was (re)opened.

If the index has not changed since this instance was (re)opened, then this call is a NOOP and returns this instance. Otherwise, a new instance is returned. The old instance is not closed and remains usable.

If the reader is reopened, even though they share resources internally, it's safe to make changes (deletions, norms) with the new reader. All shared mutable state obeys "copy on write" semantics to ensure the changes are not seen by other readers.

You can determine whether a reader was actually reopened by comparing the old instance with the instance returned by this method:

            IndexReader reader = ...
            ...
            IndexReader newReader = r.reopen();
            if (newReader != reader) {
            ...     // reader was reopened
            reader.close();
            }
            reader = newReader;
            ...
Be sure to synchronize that code so that other threads, if present, can never use reader after it has been closed and before it's switched to newReader.

NOTE: If this reader is a near real-time reader (obtained from {@link IndexWriter#GetReader()}, reopen() will simply call writer.getReader() again for you, though this may change in the future.

(Inherited from IndexReader.)
Public method Reopen(Boolean)
Just like {@link #Reopen()}, except you can change the readOnly of the original reader. If the index is unchanged but readOnly is different then a new reader will be returned.
(Inherited from IndexReader.)
Public method Reopen(IndexCommit)
Expert: reopen this reader on a specific commit point. This always returns a readOnly reader. If the specified commit point matches what this reader is already on, and this reader is already readOnly, then this same instance is returned; if it is not already readOnly, a readOnly clone is returned.
(Inherited from IndexReader.)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


SetNorm Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..SetNorm Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetNorm(Int32, String, Byte) | Expert: Resets the normalization factor for the named field of the named document. The norm represents the product of the field's {@link Lucene.Net.Documents.Fieldable#SetBoost(float) boost} and its {@link Similarity#LengthNorm(String, int) length normalization}. Thus, to preserve the length normalization values when resetting this, one should base the new value upon the old. NOTE: If this field does not store norms, then this method call will silently do nothing. (Inherited from IndexReader.)
Public method | SetNorm(Int32, String, Single) | Expert: Resets the normalization factor for the named field of the named document. (Inherited from IndexReader.)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..TermDocs Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermDocs()()()() | (Overrides IndexReader..::..TermDocs()()()().)
Public method | TermDocs(Term) | (Overrides IndexReader..::..TermDocs(Term).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


TermDocs Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..TermDocs Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.TermDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs()
Visual Basic
Public Overrides Function TermDocs As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.TermDocs"]

See Also

SegmentReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermDocs Method (Term)

[image]

Lucene.Net Class Libraries
SegmentReader..::..TermDocs Method (Term)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.TermDocs(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermDocs TermDocs(
    Term term
)
Visual Basic
Public Overrides Function TermDocs ( _
    term As Term _
) As TermDocs
Visual C++
public:
virtual TermDocs^ TermDocs(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.SegmentReader.TermDocs(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.TermDocs(Lucene.Net.Index.Term)"]

See Also

SegmentReader Class
TermDocs Overload
Lucene.Net.Index Namespace


TermPositions Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..TermPositions Method
SegmentReader Class See Also Send Feedback

Overload List

Name | Description
Public method | TermPositions()()()() | (Overrides IndexReader..::..TermPositions()()()().)
Public method TermPositions(Term)
Returns an enumeration of all the documents which contain
CopyC#
term
. For each document, in addition to the document number and frequency of the term in that document, a list of all of the ordinal positions of the term in the document is available. Thus, this method implements the mapping:

    Term => <docNum, freq, <pos1, pos2, ... posfreq-1> >*

This positional information facilitates phrase and proximity searching.

The enumeration is ordered by document number. Each document number is greater than all that precede it in the enumeration.

(Inherited from IndexReader.)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


TermPositions Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..TermPositions Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.TermPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermPositions TermPositions()
Visual Basic
Public Overrides Function TermPositions As TermPositions
Visual C++
public:
virtual TermPositions^ TermPositions() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.TermPositions"]

See Also

SegmentReader Class
TermPositions Overload
Lucene.Net.Index Namespace


Terms Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Terms Method
SegmentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Terms()()()() | (Overrides IndexReader..::..Terms()()()().)
Public method | Terms(Term) | (Overrides IndexReader..::..Terms(Term).)

See Also

SegmentReader Class
SegmentReader Members
Lucene.Net.Index Namespace


Terms Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Terms Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Terms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms()
Visual Basic
Public Overrides Function Terms As TermEnum
Visual C++
public:
virtual TermEnum^ Terms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Terms"]

See Also

SegmentReader Class
Terms Overload
Lucene.Net.Index Namespace


Terms Method (Term)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Terms Method (Term)
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Terms(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TermEnum Terms(
    Term t
)
Visual Basic
Public Overrides Function Terms ( _
    t As Term _
) As TermEnum
Visual C++
public:
virtual TermEnum^ Terms(
    Term^ t
) override

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.SegmentReader.Terms(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Terms(Lucene.Net.Index.Term)"]

See Also

SegmentReader Class
Terms Overload
Lucene.Net.Index Namespace


TermsIndexLoaded Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..TermsIndexLoaded Method
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.TermsIndexLoaded"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool TermsIndexLoaded()
Visual Basic
Public Overridable Function TermsIndexLoaded As Boolean
Visual C++
public:
virtual bool TermsIndexLoaded()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.TermsIndexLoaded"]

See Also

SegmentReader Class
Lucene.Net.Index Namespace


SegmentReader Properties

[image] [image]

Lucene.Net Class Libraries
SegmentReader Properties
SegmentReader Class See Also Send Feedback

The SegmentReader type exposes the following members.

Properties

 | Name | Description
Public property | core_ForNUnit |
Public property | deletedDocs_ForNUnit |
Public property | deletedDocsRef_ForNUnit |
Public property | hasChanges_ForNUnit | (Inherited from IndexReader.)
Public property | norms_ForNUnit |

See Also

SegmentReader Class
Lucene.Net.Index Namespace


core_ForNUnit Property

[image]

Lucene.Net Class Libraries
SegmentReader..::..core_ForNUnit Property
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentReader.core_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentReader..::..CoreReaders core_ForNUnit { get; }
Visual Basic
Public ReadOnly Property core_ForNUnit As SegmentReader..::..CoreReaders
    Get
Visual C++
public:
property SegmentReader..::..CoreReaders^ core_ForNUnit {
    SegmentReader..::..CoreReaders^ get ();
}

See Also

SegmentReader Class
Lucene.Net.Index Namespace


deletedDocs_ForNUnit Property

[image]

Lucene.Net Class Libraries
SegmentReader..::..deletedDocs_ForNUnit Property
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentReader.deletedDocs_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BitVector deletedDocs_ForNUnit { get; }
Visual Basic
Public ReadOnly Property deletedDocs_ForNUnit As BitVector
    Get
Visual C++
public:
property BitVector^ deletedDocs_ForNUnit {
    BitVector^ get ();
}

See Also

SegmentReader Class
Lucene.Net.Index Namespace


deletedDocsRef_ForNUnit Property

[image]

Lucene.Net Class Libraries
SegmentReader..::..deletedDocsRef_ForNUnit Property
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentReader.deletedDocsRef_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentReader..::..Ref deletedDocsRef_ForNUnit { get; }
Visual Basic
Public ReadOnly Property deletedDocsRef_ForNUnit As SegmentReader..::..Ref
    Get
Visual C++
public:
property SegmentReader..::..Ref^ deletedDocsRef_ForNUnit {
    SegmentReader..::..Ref^ get ();
}

See Also

SegmentReader Class
Lucene.Net.Index Namespace


norms_ForNUnit Property

[image]

Lucene.Net Class Libraries
SegmentReader..::..norms_ForNUnit Property
SegmentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentReader.norms_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IDictionary norms_ForNUnit { get; }
Visual Basic
Public ReadOnly Property norms_ForNUnit As IDictionary
    Get
Visual C++
public:
property IDictionary^ norms_ForNUnit {
    IDictionary^ get ();
}

See Also

SegmentReader Class
Lucene.Net.Index Namespace


SegmentReader.CoreReaders Class

[image]

Lucene.Net Class Libraries
SegmentReader..::..CoreReaders Class
SegmentReader Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.SegmentReader.CoreReaders"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class CoreReaders
Visual Basic
Public NotInheritable Class CoreReaders
Visual C++
public ref class CoreReaders sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentReader..::..CoreReaders

See Also

SegmentReader..::..CoreReaders Members
Lucene.Net.Index Namespace


SegmentReader.CoreReaders Members

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..CoreReaders Members
SegmentReader..::..CoreReaders Class Methods Properties See Also Send Feedback

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentReader..::..CoreReaders type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | fieldInfos_ForNUnit |

See Also

SegmentReader..::..CoreReaders Class
Lucene.Net.Index Namespace


SegmentReader.CoreReaders Methods

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..CoreReaders Methods
SegmentReader..::..CoreReaders Class See Also Send Feedback

The SegmentReader..::..CoreReaders type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentReader..::..CoreReaders Class
Lucene.Net.Index Namespace


SegmentReader.CoreReaders Properties

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..CoreReaders Properties
SegmentReader..::..CoreReaders Class See Also Send Feedback

The SegmentReader..::..CoreReaders type exposes the following members.

Properties

 | Name | Description
Public property | fieldInfos_ForNUnit |

See Also

SegmentReader..::..CoreReaders Class
Lucene.Net.Index Namespace


fieldInfos_ForNUnit Property

[image]

Lucene.Net Class Libraries
SegmentReader..::..CoreReaders..::..fieldInfos_ForNUnit Property
SegmentReader..::..CoreReaders Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentReader.CoreReaders.fieldInfos_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldInfos fieldInfos_ForNUnit { get; }
Visual Basic
Public ReadOnly Property fieldInfos_ForNUnit As FieldInfos
    Get
Visual C++
public:
property FieldInfos^ fieldInfos_ForNUnit {
    FieldInfos^ get ();
}

See Also

SegmentReader..::..CoreReaders Class
Lucene.Net.Index Namespace


SegmentReader.Norm Class

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm Class
SegmentReader Class Members See Also Send Feedback
Byte[] referencing is used because a new norm object needs to be created for each clone, and the byte array is all that is needed for sharing between cloned readers. The current norm referencing is for sharing between readers whereas the byte[] referencing is for copy on write which is independent of reader references (i.e. incRef, decRef).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class Norm : ICloneable
Visual Basic
Public NotInheritable Class Norm _
    Implements ICloneable
Visual C++
public ref class Norm sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentReader..::..Norm

See Also

SegmentReader..::..Norm Members
Lucene.Net.Index Namespace


SegmentReader.Norm Members

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Norm Members
SegmentReader..::..Norm Class Constructors Methods Properties See Also Send Feedback

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentReader..::..Norm type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentReader..::..Norm | Initializes a new instance of the SegmentReader..::..Norm class

Methods

 | Name | Description
Public method | Bytes()()()() |
Public method | Bytes(array<Byte>[]()[][], Int32, Int32) |
Public method | BytesRef |
Public method | Clone |
Public method | CopyOnWrite |
Public method | DecRef |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncRef |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReWrite |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


SegmentReader.Norm Constructor

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm Constructor
SegmentReader..::..Norm Class See Also Send Feedback
Initializes a new instance of the SegmentReader..::..Norm class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Norm(
    SegmentReader enclosingInstance,
    IndexInput in_Renamed,
    int number,
    long normSeek
)
Visual Basic
Public Sub New ( _
    enclosingInstance As SegmentReader, _
    in_Renamed As IndexInput, _
    number As Integer, _
    normSeek As Long _
)
Visual C++
public:
Norm(
    SegmentReader^ enclosingInstance,
    IndexInput^ in_Renamed,
    int number,
    long long normSeek
)

Parameters

enclosingInstance
Type: Lucene.Net.Index..::..SegmentReader

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.#ctor(Lucene.Net.Index.SegmentReader,Lucene.Net.Store.IndexInput,System.Int32,System.Int64)"]

in_Renamed
Type: Lucene.Net.Store..::..IndexInput

[Missing <param name="in_Renamed"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.#ctor(Lucene.Net.Index.SegmentReader,Lucene.Net.Store.IndexInput,System.Int32,System.Int64)"]

number
Type: System..::..Int32

[Missing <param name="number"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.#ctor(Lucene.Net.Index.SegmentReader,Lucene.Net.Store.IndexInput,System.Int32,System.Int64)"]

normSeek
Type: System..::..Int64

[Missing <param name="normSeek"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.#ctor(Lucene.Net.Index.SegmentReader,Lucene.Net.Store.IndexInput,System.Int32,System.Int64)"]

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


SegmentReader.Norm Methods

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Norm Methods
SegmentReader..::..Norm Class See Also Send Feedback

The SegmentReader..::..Norm type exposes the following members.

Methods

 | Name | Description
Public method | Bytes()()()() |
Public method | Bytes(array<Byte>[]()[][], Int32, Int32) |
Public method | BytesRef |
Public method | Clone |
Public method | CopyOnWrite |
Public method | DecRef |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncRef |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReWrite |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


Bytes Method

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..Bytes Method
SegmentReader..::..Norm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bytes()()()() |
Public method | Bytes(array<Byte>[]()[][], Int32, Int32) |

See Also

SegmentReader..::..Norm Class
SegmentReader..::..Norm Members
Lucene.Net.Index Namespace


Bytes Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..Bytes Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Bytes"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] Bytes()
Visual Basic
Public Function Bytes As Byte()
Visual C++
public:
array<unsigned char>^ Bytes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Bytes"]

See Also

SegmentReader..::..Norm Class
Bytes Overload
Lucene.Net.Index Namespace


Bytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..Bytes Method (array<Byte>[]()[][], Int32, Int32)
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Bytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Bytes(
    byte[] bytesOut,
    int offset,
    int len
)
Visual Basic
Public Sub Bytes ( _
    bytesOut As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
void Bytes(
    array<unsigned char>^ bytesOut,
    int offset,
    int len
)

Parameters

bytesOut
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytesOut"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Bytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Bytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Bytes(System.Byte[],System.Int32,System.Int32)"]

See Also

SegmentReader..::..Norm Class
Bytes Overload
Lucene.Net.Index Namespace


BytesRef Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..BytesRef Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.BytesRef"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentReader..::..Ref BytesRef()
Visual Basic
Public Function BytesRef As SegmentReader..::..Ref
Visual C++
public:
SegmentReader..::..Ref^ BytesRef()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.BytesRef"]

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..Clone Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


CopyOnWrite Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..CopyOnWrite Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.CopyOnWrite"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] CopyOnWrite()
Visual Basic
Public Function CopyOnWrite As Byte()
Visual C++
public:
array<unsigned char>^ CopyOnWrite()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.CopyOnWrite"]

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


DecRef Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..DecRef Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.DecRef"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void DecRef()
Visual Basic
Public Sub DecRef
Visual C++
public:
void DecRef()

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


IncRef Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..IncRef Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.IncRef"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void IncRef()
Visual Basic
Public Sub IncRef
Visual C++
public:
void IncRef()

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


ReWrite Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..ReWrite Method
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.ReWrite(Lucene.Net.Index.SegmentInfo)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void ReWrite(
    SegmentInfo si
)
Visual Basic
Public Sub ReWrite ( _
    si As SegmentInfo _
)
Visual C++
public:
void ReWrite(
    SegmentInfo^ si
)

Parameters

si
Type: Lucene.Net.Index..::..SegmentInfo

[Missing <param name="si"/> documentation for "M:Lucene.Net.Index.SegmentReader.Norm.ReWrite(Lucene.Net.Index.SegmentInfo)"]

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


SegmentReader.Norm Properties

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Norm Properties
SegmentReader..::..Norm Class See Also Send Feedback

The SegmentReader..::..Norm type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
SegmentReader..::..Norm..::..Enclosing_Instance Property
SegmentReader..::..Norm Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentReader.Norm.Enclosing_Instance"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentReader Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As SegmentReader
    Get
Visual C++
public:
property SegmentReader^ Enclosing_Instance {
    SegmentReader^ get ();
}

See Also

SegmentReader..::..Norm Class
Lucene.Net.Index Namespace


SegmentReader.Ref Class

[image]

Lucene.Net Class Libraries
SegmentReader..::..Ref Class
SegmentReader Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.SegmentReader.Ref"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class Ref
Visual Basic
Public Class Ref
Visual C++
public ref class Ref

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentReader..::..Ref

See Also

SegmentReader..::..Ref Members
Lucene.Net.Index Namespace


SegmentReader.Ref Members

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Ref Members
SegmentReader..::..Ref Class Constructors Methods See Also Send Feedback

NOTE: This API is new and still experimental (subject to change suddenly in the next release)

The SegmentReader..::..Ref type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentReader..::..Ref | Initializes a new instance of the SegmentReader..::..Ref class

Methods

 | Name | Description
Public method | DecRef |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncRef |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefCount |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


SegmentReader.Ref Constructor

[image]

Lucene.Net Class Libraries
SegmentReader..::..Ref Constructor
SegmentReader..::..Ref Class See Also Send Feedback
Initializes a new instance of the SegmentReader..::..Ref class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Ref()
Visual Basic
Public Sub New
Visual C++
public:
Ref()

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


SegmentReader.Ref Methods

[image] [image]

Lucene.Net Class Libraries
SegmentReader..::..Ref Methods
SegmentReader..::..Ref Class See Also Send Feedback

The SegmentReader..::..Ref type exposes the following members.

Methods

 | Name | Description
Public method | DecRef |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncRef |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefCount |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


DecRef Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Ref..::..DecRef Method
SegmentReader..::..Ref Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.DecRef"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int DecRef()
Visual Basic
Public Overridable Function DecRef As Integer
Visual C++
public:
virtual int DecRef()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.DecRef"]

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


IncRef Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Ref..::..IncRef Method
SegmentReader..::..Ref Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.IncRef"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int IncRef()
Visual Basic
Public Overridable Function IncRef As Integer
Visual C++
public:
virtual int IncRef()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.IncRef"]

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


RefCount Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Ref..::..RefCount Method
SegmentReader..::..Ref Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.RefCount"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int RefCount()
Visual Basic
Public Overridable Function RefCount As Integer
Visual C++
public:
virtual int RefCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.RefCount"]

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
SegmentReader..::..Ref..::..ToString Method
SegmentReader..::..Ref Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentReader.Ref.ToString"]

See Also

SegmentReader..::..Ref Class
Lucene.Net.Index Namespace


SegmentsGenCommit Class

[image]

Lucene.Net Class Libraries
SegmentsGenCommit Class
Members See Also Send Feedback
Class that will force an index writer to open an index based on the generation in the segments.gen file as opposed to the highest generation found in a directory listing. A use case for using this IndexCommit when opening an IndexWriter would be if index snapshots (source) are being copied over an existing index (target) and the source now has a lower generation than the target due to initiating a rebuild of the index.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class SegmentsGenCommit : IndexCommit
Visual Basic
Public Class SegmentsGenCommit _
    Inherits IndexCommit
Visual C++
public ref class SegmentsGenCommit : public IndexCommit

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..IndexCommit
Lucene.Net.Index..::..SegmentsGenCommit

See Also

SegmentsGenCommit Members
Lucene.Net.Index Namespace


SegmentsGenCommit Members

[image] [image]

Lucene.Net Class Libraries
SegmentsGenCommit Members
SegmentsGenCommit Class Constructors Methods See Also Send Feedback

The SegmentsGenCommit type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentsGenCommit | Ctor.

Methods

 | Name | Description
Public method | Delete | (Overrides IndexCommit..::..Delete()()()().)
Public method | Equals | Two IndexCommits are equal if both their Directory and versions are equal. (Inherited from IndexCommit.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory | (Overrides IndexCommit..::..GetDirectory()()()().)
Public method | GetFileNames | (Overrides IndexCommit..::..GetFileNames()()()().)
Public method | GetGeneration | (Overrides IndexCommit..::..GetGeneration()()()().)
Public method | GetHashCode | (Inherited from IndexCommit.)
Public method | GetSegmentsFileName | Get the segments_n file for the generation found in the segments.gen file. (Overrides IndexCommit..::..GetSegmentsFileName()()()().)
Public method | GetTimestamp | Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()). (Inherited from IndexCommit.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserData | (Overrides IndexCommit..::..GetUserData()()()().)
Public method | GetVersion | (Overrides IndexCommit..::..GetVersion()()()().)
Public method | IsDeleted | (Overrides IndexCommit..::..IsDeleted()()()().)
Public method | IsOptimized | (Overrides IndexCommit..::..IsOptimized()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


SegmentsGenCommit Constructor

[image]

Lucene.Net Class Libraries
SegmentsGenCommit Constructor
SegmentsGenCommit Class See Also Send Feedback
Ctor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public SegmentsGenCommit(
    Directory d
)
Visual Basic
Public Sub New ( _
    d As Directory _
)
Visual C++
public:
SegmentsGenCommit(
    Directory^ d
)

Parameters

d
Type: Lucene.Net.Store..::..Directory
The index directory.

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


SegmentsGenCommit Methods

[image] [image]

Lucene.Net Class Libraries
SegmentsGenCommit Methods
SegmentsGenCommit Class See Also Send Feedback

The SegmentsGenCommit type exposes the following members.

Methods

 | Name | Description
Public method | Delete | (Overrides IndexCommit..::..Delete()()()().)
Public method | Equals | Two IndexCommits are equal if both their Directory and versions are equal. (Inherited from IndexCommit.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory | (Overrides IndexCommit..::..GetDirectory()()()().)
Public method | GetFileNames | (Overrides IndexCommit..::..GetFileNames()()()().)
Public method | GetGeneration | (Overrides IndexCommit..::..GetGeneration()()()().)
Public method | GetHashCode | (Inherited from IndexCommit.)
Public method | GetSegmentsFileName | Get the segments_n file for the generation found in the segments.gen file. (Overrides IndexCommit..::..GetSegmentsFileName()()()().)
Public method | GetTimestamp | Convenience method that returns the last modified time of the segments_N file corresponding to this index commit, equivalent to getDirectory().fileModified(getSegmentsFileName()). (Inherited from IndexCommit.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserData | (Overrides IndexCommit..::..GetUserData()()()().)
Public method | GetVersion | (Overrides IndexCommit..::..GetVersion()()()().)
Public method | IsDeleted | (Overrides IndexCommit..::..IsDeleted()()()().)
Public method | IsOptimized | (Overrides IndexCommit..::..IsOptimized()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


Delete Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..Delete Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.Delete"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Implements

IndexCommitPoint..::..Delete()()()()

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


GetDirectory Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..GetDirectory Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetDirectory"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override Directory GetDirectory()
Visual Basic
Public Overrides Function GetDirectory As Directory
Visual C++
public:
virtual Directory^ GetDirectory() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetDirectory"]

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


GetFileNames Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..GetFileNames Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetFileNames"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override ICollection<string> GetFileNames()
Visual Basic
Public Overrides Function GetFileNames As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ GetFileNames() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetFileNames"]

Implements

IndexCommitPoint..::..GetFileNames()()()()

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


GetGeneration Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..GetGeneration Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetGeneration"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override long GetGeneration()
Visual Basic
Public Overrides Function GetGeneration As Long
Visual C++
public:
virtual long long GetGeneration() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetGeneration"]

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


GetSegmentsFileName Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..GetSegmentsFileName Method
SegmentsGenCommit Class See Also Send Feedback
Get the segments_n file for the generation found in the segments.gen file.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string GetSegmentsFileName()
Visual Basic
Public Overrides Function GetSegmentsFileName As String
Visual C++
public:
virtual String^ GetSegmentsFileName() override

Return Value

The segments_n file to use.

Implements

IndexCommitPoint..::..GetSegmentsFileName()()()()

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


GetUserData Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..GetUserData Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetUserData"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override IDictionary<string, string> GetUserData()
Visual Basic
Public Overrides Function GetUserData As IDictionary(Of String, String)
Visual C++
public:
virtual IDictionary<String^, String^>^ GetUserData() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetUserData"]

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


GetVersion Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..GetVersion Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetVersion"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override long GetVersion()
Visual Basic
Public Overrides Function GetVersion As Long
Visual C++
public:
virtual long long GetVersion() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.GetVersion"]

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


IsDeleted Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..IsDeleted Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.IsDeleted"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool IsDeleted()
Visual Basic
Public Overrides Function IsDeleted As Boolean
Visual C++
public:
virtual bool IsDeleted() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.IsDeleted"]

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


IsOptimized Method

[image]

Lucene.Net Class Libraries
SegmentsGenCommit..::..IsOptimized Method
SegmentsGenCommit Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.IsOptimized"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool IsOptimized()
Visual Basic
Public Overrides Function IsOptimized As Boolean
Visual C++
public:
virtual bool IsOptimized() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentsGenCommit.IsOptimized"]

See Also

SegmentsGenCommit Class
Lucene.Net.Index Namespace


SegmentTermDocs Class

[image]

Lucene.Net Class Libraries
SegmentTermDocs Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.SegmentTermDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SegmentTermDocs : TermDocs
Visual Basic
Public Class SegmentTermDocs _
    Implements TermDocs
Visual C++
public ref class SegmentTermDocs : TermDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentTermDocs
Lucene.Net.Index..::..SegmentTermPositions

See Also

SegmentTermDocs Members
Lucene.Net.Index Namespace


SegmentTermDocs Members

[image] [image]

Lucene.Net Class Libraries
SegmentTermDocs Members
SegmentTermDocs Class Constructors Methods Fields Properties See Also Send Feedback

The SegmentTermDocs type exposes the following members.

Constructors

 | Name | Description
Public method | SegmentTermDocs | Initializes a new instance of the SegmentTermDocs class

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Read | Optimized implementation.
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Protected method | SkippingDoc |
Protected method | SkipProx | Overridden by SegmentTermPositions to skip in prox stream.
Public method | SkipTo | Optimized implementation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | count |
Protected field | currentFieldOmitTermFreqAndPositions |
Protected field | currentFieldStoresPayloads |
Protected field | deletedDocs |
Protected field | df |
Protected field | freqStream |
Protected field | parent |

Properties

 | Name | Description
Public property | freqStream_ForNUnit |

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SegmentTermDocs Constructor

[image]

Lucene.Net Class Libraries
SegmentTermDocs Constructor
SegmentTermDocs Class See Also Send Feedback
Initializes a new instance of the SegmentTermDocs class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SegmentTermDocs(
    SegmentReader parent
)
Visual Basic
Public Sub New ( _
    parent As SegmentReader _
)
Visual C++
public:
SegmentTermDocs(
    SegmentReader^ parent
)

Parameters

parent
Type: Lucene.Net.Index..::..SegmentReader

[Missing <param name="parent"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.#ctor(Lucene.Net.Index.SegmentReader)"]

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SegmentTermDocs Fields

[image] [image]

Lucene.Net Class Libraries
SegmentTermDocs Fields
SegmentTermDocs Class See Also Send Feedback

The SegmentTermDocs type exposes the following members.

Fields

 | Name | Description
Protected field | count |
Protected field | currentFieldOmitTermFreqAndPositions |
Protected field | currentFieldStoresPayloads |
Protected field | deletedDocs |
Protected field | df |
Protected field | freqStream |
Protected field | parent |

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


count Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..count Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.count"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int count
Visual Basic
Protected Friend count As Integer
Visual C++
protected public:
int count

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


currentFieldOmitTermFreqAndPositions Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..currentFieldOmitTermFreqAndPositions Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.currentFieldOmitTermFreqAndPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool currentFieldOmitTermFreqAndPositions
Visual Basic
Protected Friend currentFieldOmitTermFreqAndPositions As Boolean
Visual C++
protected public:
bool currentFieldOmitTermFreqAndPositions

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


currentFieldStoresPayloads Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..currentFieldStoresPayloads Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.currentFieldStoresPayloads"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool currentFieldStoresPayloads
Visual Basic
Protected Friend currentFieldStoresPayloads As Boolean
Visual C++
protected public:
bool currentFieldStoresPayloads

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


deletedDocs Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..deletedDocs Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.deletedDocs"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal BitVector deletedDocs
Visual Basic
Protected Friend deletedDocs As BitVector
Visual C++
protected public:
BitVector^ deletedDocs

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


df Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..df Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.df"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int df
Visual Basic
Protected Friend df As Integer
Visual C++
protected public:
int df

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


freqStream Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..freqStream Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.freqStream"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IndexInput freqStream
Visual Basic
Protected Friend freqStream As IndexInput
Visual C++
protected public:
IndexInput^ freqStream

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


parent Field

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..parent Field
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Index.SegmentTermDocs.parent"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SegmentReader parent
Visual Basic
Protected Friend parent As SegmentReader
Visual C++
protected public:
SegmentReader^ parent

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SegmentTermDocs Methods

[image] [image]

Lucene.Net Class Libraries
SegmentTermDocs Methods
SegmentTermDocs Class See Also Send Feedback

The SegmentTermDocs type exposes the following members.

Methods

 | Name | Description
Public method | Close |
Public method | Doc |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Read | Optimized implementation.
Public method | Seek(Term) |
Public method | Seek(TermEnum) |
Protected method | SkippingDoc |
Protected method | SkipProx | Overridden by SegmentTermPositions to skip in prox stream.
Public method | SkipTo | Optimized implementation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Close Method
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

Implements

TermDocs..::..Close()()()()

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


Doc Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Doc Method
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Doc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Doc()
Visual Basic
Public Function Doc As Integer
Visual C++
public:
virtual int Doc() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Doc"]

Implements

TermDocs..::..Doc()()()()

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


Freq Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Freq Method
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Freq"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Freq()
Visual Basic
Public Function Freq As Integer
Visual C++
public:
virtual int Freq() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Freq"]

Implements

TermDocs..::..Freq()()()()

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Next Method
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Next"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Next()
Visual Basic
Public Overridable Function Next As Boolean
Visual C++
public:
virtual bool Next()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Next"]

Implements

TermDocs..::..Next()()()()

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


Read Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Read Method
SegmentTermDocs Class See Also Send Feedback
Optimized implementation.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Read(
    int[] docs,
    int[] freqs
)
Visual Basic
Public Overridable Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Visual C++
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
)

Parameters

docs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="docs"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Read(System.Int32[],System.Int32[])"]

freqs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="freqs"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Read(System.Int32[],System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Read(System.Int32[],System.Int32[])"]

Implements

TermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][])

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Seek Method
SegmentTermDocs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) |
Public method | Seek(TermEnum) |

See Also

SegmentTermDocs Class
SegmentTermDocs Members
Lucene.Net.Index Namespace


Seek Method (Term)

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Seek Method (Term)
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Seek(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Seek(
    Term term
)
Visual Basic
Public Overridable Sub Seek ( _
    term As Term _
)
Visual C++
public:
virtual void Seek(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Seek(Lucene.Net.Index.Term)"]

Implements

TermDocs..::..Seek(Term)

See Also

SegmentTermDocs Class
Seek Overload
Lucene.Net.Index Namespace


Seek Method (TermEnum)

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..Seek Method (TermEnum)
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Seek(Lucene.Net.Index.TermEnum)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Seek(
    TermEnum termEnum
)
Visual Basic
Public Overridable Sub Seek ( _
    termEnum As TermEnum _
)
Visual C++
public:
virtual void Seek(
    TermEnum^ termEnum
)

Parameters

termEnum
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="termEnum"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.Seek(Lucene.Net.Index.TermEnum)"]

Implements

TermDocs..::..Seek(TermEnum)

See Also

SegmentTermDocs Class
Seek Overload
Lucene.Net.Index Namespace


SkippingDoc Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..SkippingDoc Method
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermDocs.SkippingDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void SkippingDoc()
Visual Basic
Protected Friend Overridable Sub SkippingDoc
Visual C++
protected public:
virtual void SkippingDoc()

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SkipProx Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..SkipProx Method
SegmentTermDocs Class See Also Send Feedback
Overridden by SegmentTermPositions to skip in prox stream.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void SkipProx(
    long proxPointer,
    int payloadLength
)
Visual Basic
Protected Friend Overridable Sub SkipProx ( _
    proxPointer As Long, _
    payloadLength As Integer _
)
Visual C++
protected public:
virtual void SkipProx(
    long long proxPointer,
    int payloadLength
)

Parameters

proxPointer
Type: System..::..Int64

[Missing <param name="proxPointer"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.SkipProx(System.Int64,System.Int32)"]

payloadLength
Type: System..::..Int32

[Missing <param name="payloadLength"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.SkipProx(System.Int64,System.Int32)"]

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..SkipTo Method
SegmentTermDocs Class See Also Send Feedback
Optimized implementation.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool SkipTo(
    int target
)
Visual Basic
Public Overridable Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
)

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Index.SegmentTermDocs.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermDocs.SkipTo(System.Int32)"]

Implements

TermDocs..::..SkipTo(Int32)

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SegmentTermDocs Properties

[image] [image]

Lucene.Net Class Libraries
SegmentTermDocs Properties
SegmentTermDocs Class See Also Send Feedback

The SegmentTermDocs type exposes the following members.

Properties

 | Name | Description
Public property | freqStream_ForNUnit |

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


freqStream_ForNUnit Property

[image]

Lucene.Net Class Libraries
SegmentTermDocs..::..freqStream_ForNUnit Property
SegmentTermDocs Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.SegmentTermDocs.freqStream_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexInput freqStream_ForNUnit { get; set; }
Visual Basic
Public Property freqStream_ForNUnit As IndexInput
    Get
    Set
Visual C++
public:
property IndexInput^ freqStream_ForNUnit {
    IndexInput^ get ();
    void set (IndexInput^ value);
}

See Also

SegmentTermDocs Class
Lucene.Net.Index Namespace


SegmentTermEnum Class

[image]

Lucene.Net Class Libraries
SegmentTermEnum Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.SegmentTermEnum"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class SegmentTermEnum : TermEnum,
    ICloneable
Visual Basic
Public NotInheritable Class SegmentTermEnum _
    Inherits TermEnum _
    Implements ICloneable
Visual C++
public ref class SegmentTermEnum sealed : public TermEnum,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Index..::..SegmentTermEnum

See Also

SegmentTermEnum Members
Lucene.Net.Index Namespace


SegmentTermEnum Members

[image] [image]

Lucene.Net Class Libraries
SegmentTermEnum Members
SegmentTermEnum Class Methods See Also Send Feedback

The SegmentTermEnum type exposes the following members.

Methods

Name | Description
Public method | Clone
Public method Close
Closes the enumeration to further activity, freeing resources.
(Overrides TermEnum..::..Close()()()().)
Public method DocFreq
Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
(Overrides TermEnum..::..DocFreq()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Overrides TermEnum..::..Next()()()().)
Public method Prev
Returns the previous Term enumerated. Initially null.
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
(Overrides TermEnum..::..Term()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


SegmentTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
SegmentTermEnum Methods
SegmentTermEnum Class See Also Send Feedback

The SegmentTermEnum type exposes the following members.

Methods

Name | Description
Public method | Clone
Public method Close
Closes the enumeration to further activity, freeing resources.
(Overrides TermEnum..::..Close()()()().)
Public method DocFreq
Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.
(Overrides TermEnum..::..DocFreq()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Overrides TermEnum..::..Next()()()().)
Public method Prev
Returns the previous Term enumerated. Initially null.
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.
(Overrides TermEnum..::..Term()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SegmentTermEnum..::..Clone Method
SegmentTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermEnum.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermEnum.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
SegmentTermEnum..::..Close Method
SegmentTermEnum Class See Also Send Feedback
Closes the enumeration to further activity, freeing resources.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
SegmentTermEnum..::..DocFreq Method
SegmentTermEnum Class See Also Send Feedback
Returns the docFreq from the current TermInfo in the enumeration. Initially invalid, valid after next() called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq()
Visual Basic
Public Overrides Function DocFreq As Integer
Visual C++
public:
virtual int DocFreq() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermEnum.DocFreq"]

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
SegmentTermEnum..::..Next Method
SegmentTermEnum Class See Also Send Feedback
Increments the enumeration to the next element. True if one exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermEnum.Next"]

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


Prev Method

[image]

Lucene.Net Class Libraries
SegmentTermEnum..::..Prev Method
SegmentTermEnum Class See Also Send Feedback
Returns the previous Term enumerated. Initially null.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Term Prev()
Visual Basic
Public Function Prev As Term
Visual C++
public:
Term^ Prev()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermEnum.Prev"]

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


Term Method

[image]

Lucene.Net Class Libraries
SegmentTermEnum..::..Term Method
SegmentTermEnum Class See Also Send Feedback
Returns the current Term in the enumeration. Initially invalid, valid after next() called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Term Term()
Visual Basic
Public Overrides Function Term As Term
Visual C++
public:
virtual Term^ Term() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermEnum.Term"]

See Also

SegmentTermEnum Class
Lucene.Net.Index Namespace


SegmentTermPositions Class

[image]

Lucene.Net Class Libraries
SegmentTermPositions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.SegmentTermPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class SegmentTermPositions : SegmentTermDocs,
    TermPositions, TermDocs
Visual Basic
Public NotInheritable Class SegmentTermPositions _
    Inherits SegmentTermDocs _
    Implements TermPositions, TermDocs
Visual C++
public ref class SegmentTermPositions sealed : public SegmentTermDocs,
    TermPositions, TermDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SegmentTermDocs
Lucene.Net.Index..::..SegmentTermPositions

See Also

SegmentTermPositions Members
Lucene.Net.Index Namespace


SegmentTermPositions Members

[image] [image]

Lucene.Net Class Libraries
SegmentTermPositions Members
SegmentTermPositions Class Methods Fields Properties See Also Send Feedback

The SegmentTermPositions type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides SegmentTermDocs..::..Close()()()().)
Public method | Doc | (Inherited from SegmentTermDocs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq | (Inherited from SegmentTermDocs.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload |
Public method | GetPayloadLength |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides SegmentTermDocs..::..Next()()()().)
Public method | NextPosition |
Public method | Read | (Overrides SegmentTermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][]).)
Public method | Seek(Term) | (Inherited from SegmentTermDocs.)
Public method | Seek(TermEnum) | (Inherited from SegmentTermDocs.)
Protected method | SkippingDoc | (Overrides SegmentTermDocs..::..SkippingDoc()()()().)
Protected method | SkipProx | Called by super.skipTo(). (Overrides SegmentTermDocs..::..SkipProx(Int64, Int32).)
Public method | SkipTo | Optimized implementation. (Inherited from SegmentTermDocs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | count | (Inherited from SegmentTermDocs.)
Protected field | currentFieldOmitTermFreqAndPositions | (Inherited from SegmentTermDocs.)
Protected field | currentFieldStoresPayloads | (Inherited from SegmentTermDocs.)
Protected field | deletedDocs | (Inherited from SegmentTermDocs.)
Protected field | df | (Inherited from SegmentTermDocs.)
Protected field | freqStream | (Inherited from SegmentTermDocs.)
Protected field | parent | (Inherited from SegmentTermDocs.)

Properties

 | Name | Description
Public property | freqStream_ForNUnit | (Inherited from SegmentTermDocs.)

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


SegmentTermPositions Fields

[image] [image]

Lucene.Net Class Libraries
SegmentTermPositions Fields
SegmentTermPositions Class See Also Send Feedback

The SegmentTermPositions type exposes the following members.

Fields

 | Name | Description
Protected field | count | (Inherited from SegmentTermDocs.)
Protected field | currentFieldOmitTermFreqAndPositions | (Inherited from SegmentTermDocs.)
Protected field | currentFieldStoresPayloads | (Inherited from SegmentTermDocs.)
Protected field | deletedDocs | (Inherited from SegmentTermDocs.)
Protected field | df | (Inherited from SegmentTermDocs.)
Protected field | freqStream | (Inherited from SegmentTermDocs.)
Protected field | parent | (Inherited from SegmentTermDocs.)

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


SegmentTermPositions Methods

[image] [image]

Lucene.Net Class Libraries
SegmentTermPositions Methods
SegmentTermPositions Class See Also Send Feedback

The SegmentTermPositions type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides SegmentTermDocs..::..Close()()()().)
Public method | Doc | (Inherited from SegmentTermDocs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freq | (Inherited from SegmentTermDocs.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload |
Public method | GetPayloadLength |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides SegmentTermDocs..::..Next()()()().)
Public method | NextPosition |
Public method | Read | (Overrides SegmentTermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][]).)
Public method | Seek(Term) | (Inherited from SegmentTermDocs.)
Public method | Seek(TermEnum) | (Inherited from SegmentTermDocs.)
Protected method | SkippingDoc | (Overrides SegmentTermDocs..::..SkippingDoc()()()().)
Protected method | SkipProx | Called by super.skipTo(). (Overrides SegmentTermDocs..::..SkipProx(Int64, Int32).)
Public method | SkipTo | Optimized implementation. (Inherited from SegmentTermDocs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..Close Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

Implements

TermDocs..::..Close()()()()
TermDocs..::..Close()()()()

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..GetPayload Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.GetPayload(System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] GetPayload(
    byte[] data,
    int offset
)
Visual Basic
Public Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
) sealed

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lucene.Net.Index.SegmentTermPositions.GetPayload(System.Byte[],System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Index.SegmentTermPositions.GetPayload(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermPositions.GetPayload(System.Byte[],System.Int32)"]

Implements

TermPositions..::..GetPayload(array<Byte>[]()[][], Int32)

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


GetPayloadLength Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..GetPayloadLength Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.GetPayloadLength"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetPayloadLength()
Visual Basic
Public Function GetPayloadLength As Integer
Visual C++
public:
virtual int GetPayloadLength() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermPositions.GetPayloadLength"]

Implements

TermPositions..::..GetPayloadLength()()()()

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..IsPayloadAvailable Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.IsPayloadAvailable"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IsPayloadAvailable()
Visual Basic
Public Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermPositions.IsPayloadAvailable"]

Implements

TermPositions..::..IsPayloadAvailable()()()()

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..Next Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Next"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Next"]

Implements

TermDocs..::..Next()()()()
TermDocs..::..Next()()()()

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


NextPosition Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..NextPosition Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.NextPosition"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int NextPosition()
Visual Basic
Public Function NextPosition As Integer
Visual C++
public:
virtual int NextPosition() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermPositions.NextPosition"]

Implements

TermPositions..::..NextPosition()()()()

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


Read Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..Read Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Read(System.Int32[],System.Int32[])"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Read(
    int[] docs,
    int[] freqs
)
Visual Basic
Public Overrides Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Visual C++
public:
virtual int Read(
    array<int>^ docs,
    array<int>^ freqs
) override

Parameters

docs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="docs"/> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Read(System.Int32[],System.Int32[])"]

freqs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="freqs"/> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Read(System.Int32[],System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SegmentTermPositions.Read(System.Int32[],System.Int32[])"]

Implements

TermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][])
TermDocs..::..Read(array<Int32>[]()[][], array<Int32>[]()[][])

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
SegmentTermPositions..::..Seek Method
SegmentTermPositions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) | (Inherited from SegmentTermDocs.)
Public method | Seek(TermEnum) | (Inherited from SegmentTermDocs.)

See Also

SegmentTermPositions Class
SegmentTermPositions Members
Lucene.Net.Index Namespace


SkippingDoc Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..SkippingDoc Method
SegmentTermPositions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SegmentTermPositions.SkippingDoc"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void SkippingDoc()
Visual Basic
Protected Friend Overrides Sub SkippingDoc
Visual C++
protected public:
virtual void SkippingDoc() override

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


SkipProx Method

[image]

Lucene.Net Class Libraries
SegmentTermPositions..::..SkipProx Method
SegmentTermPositions Class See Also Send Feedback
Called by super.skipTo().

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void SkipProx(
    long proxPointer,
    int payloadLength
)
Visual Basic
Protected Friend Overrides Sub SkipProx ( _
    proxPointer As Long, _
    payloadLength As Integer _
)
Visual C++
protected public:
virtual void SkipProx(
    long long proxPointer,
    int payloadLength
) override

Parameters

proxPointer
Type: System..::..Int64

[Missing <param name="proxPointer"/> documentation for "M:Lucene.Net.Index.SegmentTermPositions.SkipProx(System.Int64,System.Int32)"]

payloadLength
Type: System..::..Int32

[Missing <param name="payloadLength"/> documentation for "M:Lucene.Net.Index.SegmentTermPositions.SkipProx(System.Int64,System.Int32)"]

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


SegmentTermPositions Properties

[image] [image]

Lucene.Net Class Libraries
SegmentTermPositions Properties
SegmentTermPositions Class See Also Send Feedback

The SegmentTermPositions type exposes the following members.

Properties

 | Name | Description
Public property | freqStream_ForNUnit | (Inherited from SegmentTermDocs.)

See Also

SegmentTermPositions Class
Lucene.Net.Index Namespace


SerialMergeScheduler Class

[image]

Lucene.Net Class Libraries
SerialMergeScheduler Class
Members See Also Send Feedback
A {@link MergeScheduler} that simply does each merge sequentially, using the current thread.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SerialMergeScheduler : MergeScheduler
Visual Basic
Public Class SerialMergeScheduler _
    Inherits MergeScheduler
Visual C++
public ref class SerialMergeScheduler : public MergeScheduler

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..MergeScheduler
Lucene.Net.Index..::..SerialMergeScheduler

See Also

SerialMergeScheduler Members
Lucene.Net.Index Namespace


SerialMergeScheduler Members

[image] [image]

Lucene.Net Class Libraries
SerialMergeScheduler Members
SerialMergeScheduler Class Constructors Methods See Also Send Feedback

The SerialMergeScheduler type exposes the following members.

Constructors

 | Name | Description
Public method | SerialMergeScheduler | Initializes a new instance of the SerialMergeScheduler class

Methods

 | Name | Description
Public method | Close | (Overrides MergeScheduler..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time. (Overrides MergeScheduler..::..Merge(IndexWriter).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerialMergeScheduler Class
Lucene.Net.Index Namespace


SerialMergeScheduler Constructor

[image]

Lucene.Net Class Libraries
SerialMergeScheduler Constructor
SerialMergeScheduler Class See Also Send Feedback
Initializes a new instance of the SerialMergeScheduler class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SerialMergeScheduler()
Visual Basic
Public Sub New
Visual C++
public:
SerialMergeScheduler()

See Also

SerialMergeScheduler Class
Lucene.Net.Index Namespace


SerialMergeScheduler Methods

[image] [image]

Lucene.Net Class Libraries
SerialMergeScheduler Methods
SerialMergeScheduler Class See Also Send Feedback

The SerialMergeScheduler type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides MergeScheduler..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time. (Overrides MergeScheduler..::..Merge(IndexWriter).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerialMergeScheduler Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
SerialMergeScheduler..::..Close Method
SerialMergeScheduler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SerialMergeScheduler.Close"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SerialMergeScheduler Class
Lucene.Net.Index Namespace


Merge Method

[image]

Lucene.Net Class Libraries
SerialMergeScheduler..::..Merge Method
SerialMergeScheduler Class See Also Send Feedback
Just do the merges in sequence. We do this "synchronized" so that even if the application is using multiple threads, only one merge may run at a time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Merge(
    IndexWriter writer
)
Visual Basic
Public Overrides Sub Merge ( _
    writer As IndexWriter _
)
Visual C++
public:
virtual void Merge(
    IndexWriter^ writer
) override

Parameters

writer
Type: Lucene.Net.Index..::..IndexWriter

[Missing <param name="writer"/> documentation for "M:Lucene.Net.Index.SerialMergeScheduler.Merge(Lucene.Net.Index.IndexWriter)"]

See Also

SerialMergeScheduler Class
Lucene.Net.Index Namespace


SnapshotDeletionPolicy Class

[image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy Class
Members See Also Send Feedback
A {@link IndexDeletionPolicy} that wraps around any other {@link IndexDeletionPolicy} and adds the ability to hold and later release a single "snapshot" of an index. While the snapshot is held, the {@link IndexWriter} will not remove any files associated with it even if the index is otherwise being actively, arbitrarily changed. Because we wrap another arbitrary {@link IndexDeletionPolicy}, this gives you the freedom to continue using whatever {@link IndexDeletionPolicy} you would normally want to use with your index. Note that you can re-use a single instance of SnapshotDeletionPolicy across multiple writers as long as they are against the same index Directory. Any snapshot held when a writer is closed will "survive" when the next writer is opened.

WARNING: This API is a new and experimental and may suddenly change.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SnapshotDeletionPolicy : IndexDeletionPolicy
Visual Basic
Public Class SnapshotDeletionPolicy _
    Implements IndexDeletionPolicy
Visual C++
public ref class SnapshotDeletionPolicy : IndexDeletionPolicy

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..SnapshotDeletionPolicy

See Also

SnapshotDeletionPolicy Members
Lucene.Net.Index Namespace


SnapshotDeletionPolicy Members

[image] [image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy Members
SnapshotDeletionPolicy Class Constructors Methods See Also Send Feedback

The SnapshotDeletionPolicy type exposes the following members.

Constructors

 | Name | Description
Public method | SnapshotDeletionPolicy | Initializes a new instance of the SnapshotDeletionPolicy class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCommit |
Public method | OnInit |
Public method | Release | Release the currently held snapshot.
Public method | Snapshot | Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


SnapshotDeletionPolicy Constructor

[image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy Constructor
SnapshotDeletionPolicy Class See Also Send Feedback
Initializes a new instance of the SnapshotDeletionPolicy class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SnapshotDeletionPolicy(
    IndexDeletionPolicy primary
)
Visual Basic
Public Sub New ( _
    primary As IndexDeletionPolicy _
)
Visual C++
public:
SnapshotDeletionPolicy(
    IndexDeletionPolicy^ primary
)

Parameters

primary
Type: Lucene.Net.Index..::..IndexDeletionPolicy

[Missing <param name="primary"/> documentation for "M:Lucene.Net.Index.SnapshotDeletionPolicy.#ctor(Lucene.Net.Index.IndexDeletionPolicy)"]

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


SnapshotDeletionPolicy Methods

[image] [image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy Methods
SnapshotDeletionPolicy Class See Also Send Feedback

The SnapshotDeletionPolicy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCommit |
Public method | OnInit |
Public method | Release | Release the currently held snapshot.
Public method | Snapshot | Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


OnCommit Method

[image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy..::..OnCommit Method
SnapshotDeletionPolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SnapshotDeletionPolicy.OnCommit(System.Collections.IList)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void OnCommit(
    IList commits
)
Visual Basic
Public Overridable Sub OnCommit ( _
    commits As IList _
)
Visual C++
public:
virtual void OnCommit(
    IList^ commits
)

Parameters

commits
Type: System.Collections..::..IList

[Missing <param name="commits"/> documentation for "M:Lucene.Net.Index.SnapshotDeletionPolicy.OnCommit(System.Collections.IList)"]

Implements

IndexDeletionPolicy..::..OnCommit(IList)

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


OnInit Method

[image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy..::..OnInit Method
SnapshotDeletionPolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SnapshotDeletionPolicy.OnInit(System.Collections.IList)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void OnInit(
    IList commits
)
Visual Basic
Public Overridable Sub OnInit ( _
    commits As IList _
)
Visual C++
public:
virtual void OnInit(
    IList^ commits
)

Parameters

commits
Type: System.Collections..::..IList

[Missing <param name="commits"/> documentation for "M:Lucene.Net.Index.SnapshotDeletionPolicy.OnInit(System.Collections.IList)"]

Implements

IndexDeletionPolicy..::..OnInit(IList)

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


Release Method

[image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy..::..Release Method
SnapshotDeletionPolicy Class See Also Send Feedback
Release the currently held snapshot.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Release()
Visual Basic
Public Overridable Sub Release
Visual C++
public:
virtual void Release()

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


Snapshot Method

[image]

Lucene.Net Class Libraries
SnapshotDeletionPolicy..::..Snapshot Method
SnapshotDeletionPolicy Class See Also Send Feedback
Take a snapshot of the most recent commit to the index. You must call release() to free this snapshot. Note that while the snapshot is held, the files it references will not be deleted, which will consume additional disk space in your index. If you take a snapshot at a particularly bad time (say just before you call optimize()) then in the worst case this could consume an extra 1X of your total index size, until you release the snapshot.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexCommitPoint Snapshot()
Visual Basic
Public Overridable Function Snapshot As IndexCommitPoint
Visual C++
public:
virtual IndexCommitPoint^ Snapshot()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.SnapshotDeletionPolicy.Snapshot"]

See Also

SnapshotDeletionPolicy Class
Lucene.Net.Index Namespace


SortedTermVectorMapper Class

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper Class
Members See Also Send Feedback
Store a sorted collection of {@link Lucene.Net.Index.TermVectorEntry}s. Collects all term information into a single, SortedSet.
NOTE: This Mapper ignores all Field information for the Document. This means that if you are using offset/positions you will not know what Fields they correlate with.
This is not thread-safe

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SortedTermVectorMapper : TermVectorMapper
Visual Basic
Public Class SortedTermVectorMapper _
    Inherits TermVectorMapper
Visual C++
public ref class SortedTermVectorMapper : public TermVectorMapper

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorMapper
Lucene.Net.Index..::..SortedTermVectorMapper

See Also

SortedTermVectorMapper Members
Lucene.Net.Index Namespace


SortedTermVectorMapper Members

[image] [image]

Lucene.Net Class Libraries
SortedTermVectorMapper Members
SortedTermVectorMapper Class Constructors Methods Fields See Also Send Feedback

The SortedTermVectorMapper type exposes the following members.

Constructors

 | Name | Description
Public method | SortedTermVectorMapper(IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the SortedTermVectorMapper class
Public method | SortedTermVectorMapper(Boolean, Boolean, IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the SortedTermVectorMapper class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTermVectorEntrySet | The TermVectorEntrySet. A SortedSet of {@link TermVectorEntry} objects. Sort is by the comparator passed into the constructor. This set will be empty until after the mapping process takes place.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public method | Map | (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ALL | Stand-in name for the field in {@link TermVectorEntry}.

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


SortedTermVectorMapper Constructor

[image] [image]

Lucene.Net Class Libraries
SortedTermVectorMapper Constructor
SortedTermVectorMapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortedTermVectorMapper(IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the SortedTermVectorMapper class
Public method | SortedTermVectorMapper(Boolean, Boolean, IComparer<(Of <<'(Object>)>>)) | Initializes a new instance of the SortedTermVectorMapper class

See Also

SortedTermVectorMapper Class
SortedTermVectorMapper Members
Lucene.Net.Index Namespace


SortedTermVectorMapper Constructor (IComparer(Object))

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper Constructor (IComparer<(Of <(<'Object>)>)>)
SortedTermVectorMapper Class See Also Send Feedback
Initializes a new instance of the SortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedTermVectorMapper(
    IComparer<Object> comparator
)
Visual Basic
Public Sub New ( _
    comparator As IComparer(Of Object) _
)
Visual C++
public:
SortedTermVectorMapper(
    IComparer<Object^>^ comparator
)

Parameters

comparator
Type: System.Collections.Generic..::..IComparer <(Of <(<' Object >)>)>
A Comparator for sorting {@link TermVectorEntry}s

See Also

SortedTermVectorMapper Class
SortedTermVectorMapper Overload
Lucene.Net.Index Namespace


SortedTermVectorMapper Constructor (Boolean, Boolean, IComparer(Object))

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper Constructor (Boolean, Boolean, IComparer<(Of <(<'Object>)>)>)
SortedTermVectorMapper Class See Also Send Feedback
Initializes a new instance of the SortedTermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<Object> comparator
)
Visual Basic
Public Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean, _
    comparator As IComparer(Of Object) _
)
Visual C++
public:
SortedTermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets,
    IComparer<Object^>^ comparator
)

Parameters

ignoringPositions
Type: System..::..Boolean

[Missing <param name="ignoringPositions"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.#ctor(System.Boolean,System.Boolean,System.Collections.Generic.IComparer{System.Object})"]

ignoringOffsets
Type: System..::..Boolean

[Missing <param name="ignoringOffsets"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.#ctor(System.Boolean,System.Boolean,System.Collections.Generic.IComparer{System.Object})"]

comparator
Type: System.Collections.Generic..::..IComparer <(Of <(<' Object >)>)>

[Missing <param name="comparator"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.#ctor(System.Boolean,System.Boolean,System.Collections.Generic.IComparer{System.Object})"]

See Also

SortedTermVectorMapper Class
SortedTermVectorMapper Overload
Lucene.Net.Index Namespace


SortedTermVectorMapper Fields

[image] [image]

Lucene.Net Class Libraries
SortedTermVectorMapper Fields
SortedTermVectorMapper Class See Also Send Feedback

The SortedTermVectorMapper type exposes the following members.

Fields

Name | Description
ALL | Stand-in name for the field in {@link TermVectorEntry}.

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


ALL Field

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper..::..ALL Field
SortedTermVectorMapper Class See Also Send Feedback
Stand-in name for the field in {@link TermVectorEntry}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const string ALL
Visual Basic
Public Const ALL As String
Visual C++
public:
literal String^ ALL

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


SortedTermVectorMapper Methods

[image] [image]

Lucene.Net Class Libraries
SortedTermVectorMapper Methods
SortedTermVectorMapper Class See Also Send Feedback

The SortedTermVectorMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTermVectorEntrySet | The TermVectorEntrySet. A SortedSet of {@link TermVectorEntry} objects. Sort is by the comparator passed into the constructor. This set will be empty until after the mapping process takes place.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public method | Map | (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


GetTermVectorEntrySet Method

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper..::..GetTermVectorEntrySet Method
SortedTermVectorMapper Class See Also Send Feedback
The TermVectorEntrySet. A SortedSet of {@link TermVectorEntry} objects. Sort is by the comparator passed into the constructor.
This set will be empty until after the mapping process takes place.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SortedDictionary<Object, Object> GetTermVectorEntrySet()
Visual Basic
Public Overridable Function GetTermVectorEntrySet As SortedDictionary(Of Object, Object)
Visual C++
public:
virtual SortedDictionary<Object^, Object^>^ GetTermVectorEntrySet()

Return Value

The SortedSet of {@link TermVectorEntry}.

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


Map Method

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper..::..Map Method
SortedTermVectorMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Visual Basic
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Visual C++
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo^>^ offsets,
    array<int>^ positions
) override

Parameters

term
Type: System..::..String
The term to map
frequency
Type: System..::..Int32
The frequency of the term
offsets
Type: array< Lucene.Net.Index..::..TermVectorOffsetInfo >[]()[][]
Offset information, may be null
positions
Type: array< System..::..Int32 >[]()[][]
Position information, may be null

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


SetExpectations Method

[image]

Lucene.Net Class Libraries
SortedTermVectorMapper..::..SetExpectations Method
SortedTermVectorMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Visual Basic
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Visual C++
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

numTerms
Type: System..::..Int32

[Missing <param name="numTerms"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

storeOffsets
Type: System..::..Boolean

[Missing <param name="storeOffsets"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

storePositions
Type: System..::..Boolean

[Missing <param name="storePositions"/> documentation for "M:Lucene.Net.Index.SortedTermVectorMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

See Also

SortedTermVectorMapper Class
Lucene.Net.Index Namespace


StaleReaderException Class

[image]

Lucene.Net Class Libraries
StaleReaderException Class
Members See Also Send Feedback
This exception is thrown when an {@link IndexReader} tries to make changes to the index (via {@link IndexReader#deleteDocument}, {@link IndexReader#undeleteAll} or {@link IndexReader#setNorm}) but changes have already been committed to the index since this reader was instantiated. When this happens you must open a new reader on the current index to make the changes.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class StaleReaderException : IOException
Visual Basic
<SerializableAttribute> _
Public Class StaleReaderException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class StaleReaderException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Lucene.Net.Index..::..StaleReaderException

See Also

StaleReaderException Members
Lucene.Net.Index Namespace


StaleReaderException Members

[image] [image]

Lucene.Net Class Libraries
StaleReaderException Members
StaleReaderException Class Constructors Methods Properties Events See Also Send Feedback

The StaleReaderException type exposes the following members.

Constructors

 | Name | Description
Public method | StaleReaderException | Initializes a new instance of the StaleReaderException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

StaleReaderException Class
Lucene.Net.Index Namespace


StaleReaderException Constructor

[image]

Lucene.Net Class Libraries
StaleReaderException Constructor
StaleReaderException Class See Also Send Feedback
Initializes a new instance of the StaleReaderException class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StaleReaderException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
StaleReaderException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Index.StaleReaderException.#ctor(System.String)"]

See Also

StaleReaderException Class
Lucene.Net.Index Namespace


StaleReaderException Methods

[image] [image]

Lucene.Net Class Libraries
StaleReaderException Methods
StaleReaderException Class See Also Send Feedback

The StaleReaderException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

StaleReaderException Class
Lucene.Net.Index Namespace


StaleReaderException Properties

[image] [image]

Lucene.Net Class Libraries
StaleReaderException Properties
StaleReaderException Class See Also Send Feedback

The StaleReaderException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

StaleReaderException Class
Lucene.Net.Index Namespace


StaleReaderException Events

[image] [image]

Lucene.Net Class Libraries
StaleReaderException Events
StaleReaderException Class See Also Send Feedback

The StaleReaderException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

StaleReaderException Class
Lucene.Net.Index Namespace


StringFieldEnumerator Class

[image]

Lucene.Net Class Libraries
StringFieldEnumerator Class
Members See Also Send Feedback
Implementation for enumerating over terms with a string value.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class StringFieldEnumerator : FieldEnumerator<string>
Visual Basic
Public Class StringFieldEnumerator _
    Inherits FieldEnumerator(Of String)
Visual C++
public ref class StringFieldEnumerator : public FieldEnumerator<String^>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..FieldEnumerator <(Of <(<' String >)>)>
Lucene.Net.Index..::..StringFieldEnumerator

See Also

StringFieldEnumerator Members
Lucene.Net.Index Namespace


StringFieldEnumerator Members

[image] [image]

Lucene.Net Class Libraries
StringFieldEnumerator Members
StringFieldEnumerator Class Constructors Methods Fields Properties See Also Send Feedback

The StringFieldEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | StringFieldEnumerator(IndexReader, String) | Construct an enumerator over one field.
Public method | StringFieldEnumerator(IndexReader, String, Boolean) | Construct an enumerator over one field.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Sets the value of current. (Overrides FieldEnumerator<(Of <(<'T>)>)>..::..TryParse(String).)

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

StringFieldEnumerator Class
Lucene.Net.Index Namespace


StringFieldEnumerator Constructor

[image] [image]

Lucene.Net Class Libraries
StringFieldEnumerator Constructor
StringFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringFieldEnumerator(IndexReader, String) | Construct an enumerator over one field.
Public method | StringFieldEnumerator(IndexReader, String, Boolean) | Construct an enumerator over one field.

See Also

StringFieldEnumerator Class
StringFieldEnumerator Members
Lucene.Net.Index Namespace


StringFieldEnumerator Constructor (IndexReader, String)

[image]

Lucene.Net Class Libraries
StringFieldEnumerator Constructor (IndexReader, String)
StringFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public StringFieldEnumerator(
    IndexReader reader,
    string fieldName
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String _
)
Visual C++
public:
StringFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.

See Also

StringFieldEnumerator Class
StringFieldEnumerator Overload
Lucene.Net.Index Namespace


StringFieldEnumerator Constructor (IndexReader, String, Boolean)

[image]

Lucene.Net Class Libraries
StringFieldEnumerator Constructor (IndexReader, String, Boolean)
StringFieldEnumerator Class See Also Send Feedback
Construct an enumerator over one field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public StringFieldEnumerator(
    IndexReader reader,
    string fieldName,
    bool includeDocs
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fieldName As String, _
    includeDocs As Boolean _
)
Visual C++
public:
StringFieldEnumerator(
    IndexReader^ reader,
    String^ fieldName,
    bool includeDocs
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index reader.
fieldName
Type: System..::..String
The field to read.
includeDocs
Type: System..::..Boolean
Whether the TermDocs will also be enumerated.

See Also

StringFieldEnumerator Class
StringFieldEnumerator Overload
Lucene.Net.Index Namespace


StringFieldEnumerator Fields

[image] [image]

Lucene.Net Class Libraries
StringFieldEnumerator Fields
StringFieldEnumerator Class See Also Send Feedback

The StringFieldEnumerator type exposes the following members.

Fields

 | Name | Description
Protected field | includeDocs | Whether the enumerator will include TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected field | tEnum | The specialized TermEnum enumerator. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

StringFieldEnumerator Class
Lucene.Net.Index Namespace


StringFieldEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
StringFieldEnumerator Methods
StringFieldEnumerator Class See Also Send Feedback

The StringFieldEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TryParse | Sets the value of current. (Overrides FieldEnumerator<(Of <(<'T>)>)>..::..TryParse(String).)

See Also

StringFieldEnumerator Class
Lucene.Net.Index Namespace


Init Method

[image] [image]

Lucene.Net Class Libraries
StringFieldEnumerator..::..Init Method
StringFieldEnumerator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Init(IndexReader, String) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Protected method | Init(IndexReader, String, Boolean) | Initialization method called by subclasses to simulate a shared base constructor as generic classes cannot have a parameterized ctor. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

StringFieldEnumerator Class
StringFieldEnumerator Members
Lucene.Net.Index Namespace


TryParse Method

[image]

Lucene.Net Class Libraries
StringFieldEnumerator..::..TryParse Method
StringFieldEnumerator Class See Also Send Feedback
Sets the value of current.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected override bool TryParse(
    string s
)
Visual Basic
Protected Overrides Function TryParse ( _
    s As String _
) As Boolean
Visual C++
protected:
virtual bool TryParse(
    String^ s
) override

Parameters

s
Type: System..::..String
The string.

Return Value

Always true.

See Also

StringFieldEnumerator Class
Lucene.Net.Index Namespace


StringFieldEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
StringFieldEnumerator Properties
StringFieldEnumerator Class See Also Send Feedback

The StringFieldEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Docs | Access the enumerator for the TermDocs. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)
Public property | Terms | Access the enumerator for the terms. (Inherited from FieldEnumerator<(Of <(<'T>)>)>.)

See Also

StringFieldEnumerator Class
Lucene.Net.Index Namespace


Term Class

[image]

Lucene.Net Class Libraries
Term Class
Members See Also Send Feedback
A Term represents a word from text. This is the unit of search. It is composed of two elements, the text of the word, as a string, and the name of the field that the text occured in, an interned string. Note that terms may represent more than words from text fields, but also things like dates, email addresses, urls, etc.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Term : IComparable
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Term _
    Implements IComparable
Visual C++
[SerializableAttribute]
public ref class Term sealed : IComparable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..Term

See Also

Term Members
Lucene.Net.Index Namespace


Term Members

[image] [image]

Lucene.Net Class Libraries
Term Members
Term Class Constructors Methods Properties See Also Send Feedback

The Term type exposes the following members.

Constructors

 | Name | Description
Public method | Term(String) | Constructs a Term with the given field and empty text. This serves two purposes: 1) reuse of a Term with the same field. 2) pattern for a query.
Public method | Term(String, String) | Constructs a Term with the given field and text. Note that a null field or null text value results in undefined behavior for most Lucene APIs that accept a Term parameter.

Methods

 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(Term) | Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.
Public method | CreateTerm | Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Field | Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | text_ForNUnit |

See Also

Term Class
Lucene.Net.Index Namespace


Term Constructor

[image] [image]

Lucene.Net Class Libraries
Term Constructor
Term Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Term(String) | Constructs a Term with the given field and empty text. This serves two purposes: 1) reuse of a Term with the same field. 2) pattern for a query.
Public method | Term(String, String) | Constructs a Term with the given field and text. Note that a null field or null text value results in undefined behavior for most Lucene APIs that accept a Term parameter.

See Also

Term Class
Term Members
Lucene.Net.Index Namespace


Term Constructor (String)

[image]

Lucene.Net Class Libraries
Term Constructor (String)
Term Class See Also Send Feedback
Constructs a Term with the given field and empty text. This serves two purposes: 1) reuse of a Term with the same field. 2) pattern for a query.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Term(
    string fld
)
Visual Basic
Public Sub New ( _
    fld As String _
)
Visual C++
public:
Term(
    String^ fld
)

Parameters

fld
Type: System..::..String

[Missing <param name="fld"/> documentation for "M:Lucene.Net.Index.Term.#ctor(System.String)"]

See Also

Term Class
Term Overload
Lucene.Net.Index Namespace


Term Constructor (String, String)

[image]

Lucene.Net Class Libraries
Term Constructor (String, String)
Term Class See Also Send Feedback
Constructs a Term with the given field and text.

Note that a null field or null text value results in undefined behavior for most Lucene APIs that accept a Term parameter.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Term(
    string fld,
    string txt
)
Visual Basic
Public Sub New ( _
    fld As String, _
    txt As String _
)
Visual C++
public:
Term(
    String^ fld,
    String^ txt
)

Parameters

fld
Type: System..::..String

[Missing <param name="fld"/> documentation for "M:Lucene.Net.Index.Term.#ctor(System.String,System.String)"]

txt
Type: System..::..String

[Missing <param name="txt"/> documentation for "M:Lucene.Net.Index.Term.#ctor(System.String,System.String)"]

See Also

Term Class
Term Overload
Lucene.Net.Index Namespace


Term Methods

[image] [image]

Lucene.Net Class Libraries
Term Methods
Term Class See Also Send Feedback

The Term type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(Term) | Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.
Public method | CreateTerm | Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Field | Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Text | Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Term Class
Lucene.Net.Index Namespace


CompareTo Method

[image] [image]

Lucene.Net Class Libraries
Term..::..CompareTo Method
Term Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(Term) | Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.

See Also

Term Class
Term Members
Lucene.Net.Index Namespace


CompareTo Method (Object)

[image]

Lucene.Net Class Libraries
Term..::..CompareTo Method (Object)
Term Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.Term.CompareTo(System.Object)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int CompareTo(
    Object other
)
Visual Basic
Public Function CompareTo ( _
    other As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ other
) sealed

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Index.Term.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.CompareTo(System.Object)"]

Implements

IComparable..::..CompareTo(Object)

See Also

Term Class
CompareTo Overload
Lucene.Net.Index Namespace


CompareTo Method (Term)

[image]

Lucene.Net Class Libraries
Term..::..CompareTo Method (Term)
Term Class See Also Send Feedback
Compares two terms, returning a negative integer if this term belongs before the argument, zero if this term is equal to the argument, and a positive integer if this term belongs after the argument. The ordering of terms is first by field, then by text.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int CompareTo(
    Term other
)
Visual Basic
Public Function CompareTo ( _
    other As Term _
) As Integer
Visual C++
public:
int CompareTo(
    Term^ other
)

Parameters

other
Type: Lucene.Net.Index..::..Term

[Missing <param name="other"/> documentation for "M:Lucene.Net.Index.Term.CompareTo(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.CompareTo(Lucene.Net.Index.Term)"]

See Also

Term Class
CompareTo Overload
Lucene.Net.Index Namespace


CreateTerm Method

[image]

Lucene.Net Class Libraries
Term..::..CreateTerm Method
Term Class See Also Send Feedback
Optimized construction of new Terms by reusing same field as this Term - avoids field.intern() overhead

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Term CreateTerm(
    string text
)
Visual Basic
Public Function CreateTerm ( _
    text As String _
) As Term
Visual C++
public:
Term^ CreateTerm(
    String^ text
)

Parameters

text
Type: System..::..String
The text of the new term (field is implicitly same as this Term instance)

Return Value

A new Term

See Also

Term Class
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Term..::..Equals Method
Term Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.Term.Equals(System.Object)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Index.Term.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.Equals(System.Object)"]

See Also

Term Class
Lucene.Net.Index Namespace


Field Method

[image]

Lucene.Net Class Libraries
Term..::..Field Method
Term Class See Also Send Feedback
Returns the field of this term, an interned string. The field indicates the part of a document which this term came from.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Field()
Visual Basic
Public Function Field As String
Visual C++
public:
String^ Field()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.Field"]

See Also

Term Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Term..::..GetHashCode Method
Term Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.Term.GetHashCode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.GetHashCode"]

See Also

Term Class
Lucene.Net.Index Namespace


Text Method

[image]

Lucene.Net Class Libraries
Term..::..Text Method
Term Class See Also Send Feedback
Returns the text of this term. In the case of words, this is simply the text of the word. In the case of dates and other types, this is an encoding of the object as a string.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string Text()
Visual Basic
Public Function Text As String
Visual C++
public:
String^ Text()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.Text"]

See Also

Term Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Term..::..ToString Method
Term Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.Term.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.Term.ToString"]

See Also

Term Class
Lucene.Net.Index Namespace


Term Properties

[image] [image]

Lucene.Net Class Libraries
Term Properties
Term Class See Also Send Feedback

The Term type exposes the following members.

Properties

 | Name | Description
Public property | text_ForNUnit |

See Also

Term Class
Lucene.Net.Index Namespace


text_ForNUnit Property

[image]

Lucene.Net Class Libraries
Term..::..text_ForNUnit Property
Term Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.Term.text_ForNUnit"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string text_ForNUnit { get; }
Visual Basic
Public ReadOnly Property text_ForNUnit As String
    Get
Visual C++
public:
property String^ text_ForNUnit {
    String^ get ();
}

See Also

Term Class
Lucene.Net.Index Namespace


TermDocEnumerator Class

[image]

Lucene.Net Class Libraries
TermDocEnumerator Class
Members See Also Send Feedback
Class to handle creating a TermDocs and allowing for seeking and enumeration. Used when you have a set of one or moreterms for which you want to enumerate over the documents that contain those terms.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class TermDocEnumerator : IEnumerable<int>,
    IEnumerable, IDisposable
Visual Basic
Public Class TermDocEnumerator _
    Implements IEnumerable(Of Integer), IEnumerable, IDisposable
Visual C++
public ref class TermDocEnumerator : IEnumerable<int>,
    IEnumerable, IDisposable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermDocEnumerator

See Also

TermDocEnumerator Members
Lucene.Net.Index Namespace


TermDocEnumerator Members

[image] [image]

Lucene.Net Class Libraries
TermDocEnumerator Members
TermDocEnumerator Class Constructors Methods See Also Send Feedback

The TermDocEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | TermDocEnumerator | Ctor.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance, closing the termdocs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Seek to a specific term.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermDocEnumerator Class
Lucene.Net.Index Namespace


TermDocEnumerator Constructor

[image]

Lucene.Net Class Libraries
TermDocEnumerator Constructor
TermDocEnumerator Class See Also Send Feedback
Ctor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermDocEnumerator(
    TermDocs termDocs
)
Visual Basic
Public Sub New ( _
    termDocs As TermDocs _
)
Visual C++
public:
TermDocEnumerator(
    TermDocs^ termDocs
)

Parameters

termDocs
Type: Lucene.Net.Index..::..TermDocs
The TermDocs to wrap.

See Also

TermDocEnumerator Class
Lucene.Net.Index Namespace


TermDocEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
TermDocEnumerator Methods
TermDocEnumerator Class See Also Send Feedback

The TermDocEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of the instance, closing the termdocs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Seek to a specific term.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermDocEnumerator Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..Dispose Method
TermDocEnumerator Class See Also Send Feedback
Dispose of the instance, closing the termdocs.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TermDocEnumerator Class
Lucene.Net.Index Namespace


GetEnumerator Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..GetEnumerator Method
TermDocEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermDocEnumerator.GetEnumerator"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public IEnumerator<int> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of Integer)
Visual C++
public:
virtual IEnumerator<int>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocEnumerator.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

TermDocEnumerator Class
Lucene.Net.Index Namespace


Seek Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..Seek Method
TermDocEnumerator Class See Also Send Feedback
Seek to a specific term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Seek(
    Term t
)
Visual Basic
Public Sub Seek ( _
    t As Term _
)
Visual C++
public:
void Seek(
    Term^ t
)

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Index.TermDocEnumerator.Seek(Lucene.Net.Index.Term)"]

See Also

TermDocEnumerator Class
Lucene.Net.Index Namespace


TermDocEnumerator.TermDocUsingTermsEnumerator Class

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
TermDocEnumerator Class Members See Also Send Feedback
Class to handle enumeration over the TermDocs that does NOT close them on a call to Dispose!

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class TermDocUsingTermsEnumerator : IEnumerable<int>,
    IEnumerable, IEnumerator<int>, IDisposable, IEnumerator
Visual Basic
Public Class TermDocUsingTermsEnumerator _
    Implements IEnumerable(Of Integer), IEnumerable, IEnumerator(Of Integer),  _
    IDisposable, IEnumerator
Visual C++
public ref class TermDocUsingTermsEnumerator : IEnumerable<int>,
    IEnumerable, IEnumerator<int>, IDisposable, IEnumerator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermDocEnumerator..::..TermDocUsingTermsEnumerator

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Members
Lucene.Net.Index Namespace


TermDocEnumerator.TermDocUsingTermsEnumerator Members

[image] [image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator Members
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class Methods Properties See Also Send Feedback

Class to handle creating a TermDocs and allowing for seeking and enumeration. Used when you have a set of one or moreterms for which you want to enumerate over the documents that contain those terms.

The TermDocEnumerator..::..TermDocUsingTermsEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose impl.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get the enumerator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Move to the next item.
Public method | Reset | Not implemented. Use Seek instead.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | The current document id.

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


TermDocEnumerator.TermDocUsingTermsEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator Methods
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback

The TermDocEnumerator..::..TermDocUsingTermsEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose impl.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get the enumerator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Move to the next item.
Public method | Reset | Not implemented. Use Seek instead.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator..::..Dispose Method
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback
Dispose impl.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


GetEnumerator Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator..::..GetEnumerator Method
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback
Get the enumerator.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public IEnumerator<int> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of Integer)
Visual C++
public:
virtual IEnumerator<int>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocEnumerator.TermDocUsingTermsEnumerator.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


MoveNext Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator..::..MoveNext Method
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback
Move to the next item.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

True if more, false if not.

Implements

IEnumerator..::..MoveNext()()()()

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


Reset Method

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator..::..Reset Method
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback
Not implemented. Use Seek instead.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


TermDocEnumerator.TermDocUsingTermsEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator Properties
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback

The TermDocEnumerator..::..TermDocUsingTermsEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current | The current document id.

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


Current Property

[image]

Lucene.Net Class Libraries
TermDocEnumerator..::..TermDocUsingTermsEnumerator..::..Current Property
TermDocEnumerator..::..TermDocUsingTermsEnumerator Class See Also Send Feedback
The current document id.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int Current { get; }
Visual Basic
Public ReadOnly Property Current As Integer
    Get
Visual C++
public:
virtual property int Current {
    int get () sealed;
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

TermDocEnumerator..::..TermDocUsingTermsEnumerator Class
Lucene.Net.Index Namespace


TermDocs Interface

[image]

Lucene.Net Class Libraries
TermDocs Interface
Members See Also Send Feedback
TermDocs provides an interface for enumerating <document, frequency> pairs for a term.

The document portion names each document containing the term. Documents are indicated by number. The frequency portion gives the number of times the term occurred in each document.

The pairs are ordered by document number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface TermDocs
Visual Basic
Public Interface TermDocs
Visual C++
public interface class TermDocs

See Also

TermDocs Members
Lucene.Net.Index Namespace
IndexReader..::..TermDocs()()()()


TermDocs Members

[image] [image]

Lucene.Net Class Libraries
TermDocs Members
TermDocs Interface Methods See Also Send Feedback

The TermDocs type exposes the following members.

Methods

Name Description
Public method Close
Frees associated resources.
Public method Doc
Returns the current document number.

This is invalid until {@link #Next()} is called for the first time.

Public method Freq
Returns the frequency of the term within the current document.

This is invalid until {@link #Next()} is called for the first time.

Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.

Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.

Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
Public method Seek(TermEnum)
Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Some implementations are considerably more efficient than that.

See Also

TermDocs Interface
Lucene.Net.Index Namespace


TermDocs Methods

[image] [image]

Lucene.Net Class Libraries
TermDocs Methods
TermDocs Interface See Also Send Feedback

The TermDocs type exposes the following members.

Methods

Name Description
Public method Close
Frees associated resources.
Public method Doc
Returns the current document number.

This is invalid until {@link #Next()} is called for the first time.

Public method Freq
Returns the frequency of the term within the current document.

This is invalid until {@link #Next()} is called for the first time.

Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.

Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.

Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
Public method Seek(TermEnum)
Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Some implementations are considerably more efficient than that.

See Also

TermDocs Interface
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
TermDocs..::..Close Method
TermDocs Interface See Also Send Feedback
Frees associated resources.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Close()
Visual Basic
Sub Close
Visual C++
void Close()

See Also

TermDocs Interface
Lucene.Net.Index Namespace


Doc Method

[image]

Lucene.Net Class Libraries
TermDocs..::..Doc Method
TermDocs Interface See Also Send Feedback
Returns the current document number.

This is invalid until {@link #Next()} is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int Doc()
Visual Basic
Function Doc As Integer
Visual C++
int Doc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocs.Doc"]

See Also

TermDocs Interface
Lucene.Net.Index Namespace


Freq Method

[image]

Lucene.Net Class Libraries
TermDocs..::..Freq Method
TermDocs Interface See Also Send Feedback
Returns the frequency of the term within the current document.

This is invalid until {@link #Next()} is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int Freq()
Visual Basic
Function Freq As Integer
Visual C++
int Freq()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocs.Freq"]

See Also

TermDocs Interface
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
TermDocs..::..Next Method
TermDocs Interface See Also Send Feedback
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool Next()
Visual Basic
Function Next As Boolean
Visual C++
bool Next()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocs.Next"]

See Also

TermDocs Interface
Lucene.Net.Index Namespace


Read Method

[image]

Lucene.Net Class Libraries
TermDocs..::..Read Method
TermDocs Interface See Also Send Feedback
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int Read(
    int[] docs,
    int[] freqs
)
Visual Basic
Function Read ( _
    docs As Integer(), _
    freqs As Integer() _
) As Integer
Visual C++
int Read(
    array<int>^ docs,
    array<int>^ freqs
)

Parameters

docs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="docs"/> documentation for "M:Lucene.Net.Index.TermDocs.Read(System.Int32[],System.Int32[])"]

freqs
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="freqs"/> documentation for "M:Lucene.Net.Index.TermDocs.Read(System.Int32[],System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocs.Read(System.Int32[],System.Int32[])"]

See Also

TermDocs Interface
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
TermDocs..::..Seek Method
TermDocs Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) | Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
Public method | Seek(TermEnum) | Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.

See Also

TermDocs Interface
TermDocs Members
Lucene.Net.Index Namespace


Seek Method (Term)

[image]

Lucene.Net Class Libraries
TermDocs..::..Seek Method (Term)
TermDocs Interface See Also Send Feedback
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Seek(
    Term term
)
Visual Basic
Sub Seek ( _
    term As Term _
)
Visual C++
void Seek(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.TermDocs.Seek(Lucene.Net.Index.Term)"]

See Also

TermDocs Interface
Seek Overload
Lucene.Net.Index Namespace


Seek Method (TermEnum)

[image]

Lucene.Net Class Libraries
TermDocs..::..Seek Method (TermEnum)
TermDocs Interface See Also Send Feedback
Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Seek(
    TermEnum termEnum
)
Visual Basic
Sub Seek ( _
    termEnum As TermEnum _
)
Visual C++
void Seek(
    TermEnum^ termEnum
)

Parameters

termEnum
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="termEnum"/> documentation for "M:Lucene.Net.Index.TermDocs.Seek(Lucene.Net.Index.TermEnum)"]

See Also

TermDocs Interface
Seek Overload
Lucene.Net.Index Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
TermDocs..::..SkipTo Method
TermDocs Interface See Also Send Feedback
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Some implementations are considerably more efficient than that.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool SkipTo(
    int target
)
Visual Basic
Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
bool SkipTo(
    int target
)

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Index.TermDocs.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermDocs.SkipTo(System.Int32)"]

See Also

TermDocs Interface
Lucene.Net.Index Namespace


TermEnum Class

[image]

Lucene.Net Class Libraries
TermEnum Class
Members See Also Send Feedback
Abstract class for enumerating terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TermEnum
Visual Basic
Public MustInherit Class TermEnum
Visual C++
public ref class TermEnum abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Index..::..FilterIndexReader..::..FilterTermEnum
Lucene.Net.Index..::..SegmentTermEnum
Lucene.Net.Search..::..FilteredTermEnum

See Also

TermEnum Members
Lucene.Net.Index Namespace


TermEnum Members

[image] [image]

Lucene.Net Class Libraries
TermEnum Members
TermEnum Class Constructors Methods See Also Send Feedback

The TermEnum type exposes the following members.

Constructors

 | Name | Description
Protected method | TermEnum | Initializes a new instance of the TermEnum class

Methods

Name Description
Public method Close
Closes the enumeration to further activity, freeing resources.
Public method DocFreq
Returns the docFreq of the current Term in the enumeration.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
Public method Term
Returns the current Term in the enumeration.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TermEnum Class
Lucene.Net.Index Namespace


TermEnum Constructor

[image]

Lucene.Net Class Libraries
TermEnum Constructor
TermEnum Class See Also Send Feedback
Initializes a new instance of the TermEnum class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected TermEnum()
Visual Basic
Protected Sub New
Visual C++
protected:
TermEnum()

See Also

TermEnum Class
Lucene.Net.Index Namespace


TermEnum Methods

[image] [image]

Lucene.Net Class Libraries
TermEnum Methods
TermEnum Class See Also Send Feedback

The TermEnum type exposes the following members.

Methods

Name Description
Public method Close
Closes the enumeration to further activity, freeing resources.
Public method DocFreq
Returns the docFreq of the current Term in the enumeration.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
Public method Term
Returns the current Term in the enumeration.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TermEnum Class
Lucene.Net.Index Namespace


Close Method

[image]

Lucene.Net Class Libraries
TermEnum..::..Close Method
TermEnum Class See Also Send Feedback
Closes the enumeration to further activity, freeing resources.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

TermEnum Class
Lucene.Net.Index Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
TermEnum..::..DocFreq Method
TermEnum Class See Also Send Feedback
Returns the docFreq of the current Term in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int DocFreq()
Visual Basic
Public MustOverride Function DocFreq As Integer
Visual C++
public:
virtual int DocFreq() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermEnum.DocFreq"]

See Also

TermEnum Class
Lucene.Net.Index Namespace


Next Method

[image]

Lucene.Net Class Libraries
TermEnum..::..Next Method
TermEnum Class See Also Send Feedback
Increments the enumeration to the next element. True if one exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Next()
Visual Basic
Public MustOverride Function Next As Boolean
Visual C++
public:
virtual bool Next() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermEnum.Next"]

See Also

TermEnum Class
Lucene.Net.Index Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
TermEnum..::..SkipTo Method
TermEnum Class See Also Send Feedback
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("This method is not performant and will be removed in Lucene 3.0.Use IndexReader.Terms(Term) to create a new TermEnum positioned at a given term.")]
public virtual bool SkipTo(
    Term target
)
Visual Basic
<ObsoleteAttribute("This method is not performant and will be removed in Lucene 3.0.Use IndexReader.Terms(Term) to create a new TermEnum positioned at a given term.")> _
Public Overridable Function SkipTo ( _
    target As Term _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is not performant and will be removed in Lucene 3.0.Use IndexReader.Terms(Term) to create a new TermEnum positioned at a given term.")]
public:
virtual bool SkipTo(
    Term^ target
)

Parameters

target
Type: Lucene.Net.Index..::..Term

[Missing <param name="target"/> documentation for "M:Lucene.Net.Index.TermEnum.SkipTo(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermEnum.SkipTo(Lucene.Net.Index.Term)"]

See Also

TermEnum Class
Lucene.Net.Index Namespace


Term Method

[image]

Lucene.Net Class Libraries
TermEnum..::..Term Method
TermEnum Class See Also Send Feedback
Returns the current Term in the enumeration.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Term Term()
Visual Basic
Public MustOverride Function Term As Term
Visual C++
public:
virtual Term^ Term() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermEnum.Term"]

See Also

TermEnum Class
Lucene.Net.Index Namespace


TermFreqVector Interface

[image]

Lucene.Net Class Libraries
TermFreqVector Interface
Members See Also Send Feedback
Provides access to stored term vector of a document field. The vector consists of the name of the field, an array of the terms tha occur in the field of the {@link Lucene.Net.Documents.Document} and a parallel array of frequencies. Thus, getTermFrequencies()[5] corresponds with the frequency of getTerms()[5], assuming there are at least 5 terms in the Document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface TermFreqVector
Visual Basic
Public Interface TermFreqVector
Visual C++
public interface class TermFreqVector

See Also

TermFreqVector Members
Lucene.Net.Index Namespace


TermFreqVector Members

[image] [image]

Lucene.Net Class Libraries
TermFreqVector Members
TermFreqVector Interface Methods See Also Send Feedback

The TermFreqVector type exposes the following members.

Methods

Name | Description
Public method GetField
The {@link Lucene.Net.Documents.Fieldable} name.
Public method GetTermFrequencies
Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
CopyC#
getTerms
 method. Each location in the array contains the number of times this term occurs in the document or the document field.
Public method | GetTerms
Public method IndexesOf
Just like
CopyC#
indexOf(int)
 but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
Public method IndexOf
Return an index in the term numbers array returned from
CopyC#
getTerms
 at which the term with the specified
CopyC#
term
 appears. If this term does not appear in the array, return -1.
Public method | Size

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


TermFreqVector Methods

[image] [image]

Lucene.Net Class Libraries
TermFreqVector Methods
TermFreqVector Interface See Also Send Feedback

The TermFreqVector type exposes the following members.

Methods

Name | Description
Public method GetField
The {@link Lucene.Net.Documents.Fieldable} name.
Public method GetTermFrequencies
Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
CopyC#
getTerms
 method. Each location in the array contains the number of times this term occurs in the document or the document field.
Public method | GetTerms
Public method IndexesOf
Just like
CopyC#
indexOf(int)
 but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
Public method IndexOf
Return an index in the term numbers array returned from
CopyC#
getTerms
 at which the term with the specified
CopyC#
term
 appears. If this term does not appear in the array, return -1.
Public method | Size

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


GetField Method

[image]

Lucene.Net Class Libraries
TermFreqVector..::..GetField Method
TermFreqVector Interface See Also Send Feedback
The {@link Lucene.Net.Documents.Fieldable} name.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string GetField()
Visual Basic
Function GetField As String
Visual C++
String^ GetField()

Return Value

The name of the field this vector is associated with.

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


GetTermFrequencies Method

[image]

Lucene.Net Class Libraries
TermFreqVector..::..GetTermFrequencies Method
TermFreqVector Interface See Also Send Feedback
Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
CopyC#
getTerms
 method. Each location in the array contains the number of times this term occurs in the document or the document field.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int[] GetTermFrequencies()
Visual Basic
Function GetTermFrequencies As Integer()
Visual C++
array<int>^ GetTermFrequencies()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermFreqVector.GetTermFrequencies"]

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
TermFreqVector..::..GetTerms Method
TermFreqVector Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermFreqVector.GetTerms"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string[] GetTerms()
Visual Basic
Function GetTerms As String()
Visual C++
array<String^>^ GetTerms()

Return Value

An Array of term texts in ascending order.

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


IndexesOf Method

[image]

Lucene.Net Class Libraries
TermFreqVector..::..IndexesOf Method
TermFreqVector Interface See Also Send Feedback
Just like
CopyC#
indexOf(int)
 but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
Visual Basic
Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
Visual C++
array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
)

Parameters

terms
Type: array< System..::..String >[]()[][]
array containing terms to look for
start
Type: System..::..Int32
index in the array where the list of terms starts
len
Type: System..::..Int32
the number of terms in the list

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermFreqVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


IndexOf Method

[image]

Lucene.Net Class Libraries
TermFreqVector..::..IndexOf Method
TermFreqVector Interface See Also Send Feedback
Return an index in the term numbers array returned from
CopyC#
getTerms
 at which the term with the specified
CopyC#
term
 appears. If this term does not appear in the array, return -1.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int IndexOf(
    string term
)
Visual Basic
Function IndexOf ( _
    term As String _
) As Integer
Visual C++
int IndexOf(
    String^ term
)

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.TermFreqVector.IndexOf(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermFreqVector.IndexOf(System.String)"]

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


Size Method

[image]

Lucene.Net Class Libraries
TermFreqVector..::..Size Method
TermFreqVector Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermFreqVector.Size"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int Size()
Visual Basic
Function Size As Integer
Visual C++
int Size()

Return Value

The number of terms in the term vector.

See Also

TermFreqVector Interface
Lucene.Net.Index Namespace


TermPositions Interface

[image]

Lucene.Net Class Libraries
TermPositions Interface
Members See Also Send Feedback
TermPositions provides an interface for enumerating the <document, frequency, <position>* > tuples for a term.

The document and frequency are the same as for a TermDocs. The positions portion lists the ordinal positions of each occurrence of a term in a document.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface TermPositions : TermDocs
Visual Basic
Public Interface TermPositions _
    Inherits TermDocs
Visual C++
public interface class TermPositions : TermDocs

See Also

TermPositions Members
Lucene.Net.Index Namespace
IndexReader..::..TermPositions()()()()


TermPositions Members

[image] [image]

Lucene.Net Class Libraries
TermPositions Members
TermPositions Interface Methods See Also Send Feedback

The TermPositions type exposes the following members.

Methods

Name Description
Public method Close
Frees associated resources.
(Inherited from TermDocs.)
Public method Doc
Returns the current document number.

This is invalid until {@link #Next()} is called for the first time.

(Inherited from TermDocs.)
Public method Freq
Returns the frequency of the term within the current document.

This is invalid until {@link #Next()} is called for the first time.

(Inherited from TermDocs.)
Public method GetPayload
Returns the payload data at the current term position. This is invalid until {@link #NextPosition()} is called for the first time. This method must not be called more than once after each call of {@link #NextPosition()}. However, payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons.
Public method GetPayloadLength
Returns the length of the payload at the current term position. This is invalid until {@link #NextPosition()} is called for the first time.
Public method IsPayloadAvailable
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to {@link #NextPosition()}.

Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.

(Inherited from TermDocs.)
Public method NextPosition
Returns next position in the current document. It is an error to call this more than {@link #Freq()} times without calling {@link #Next()}

This is invalid until {@link #Next()} is called for the first time.

Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.

(Inherited from TermDocs.)
Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
(Inherited from TermDocs.)
Public method Seek(TermEnum)
Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.
(Inherited from TermDocs.)
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Some implementations are considerably more efficient than that.
(Inherited from TermDocs.)

See Also

TermPositions Interface
Lucene.Net.Index Namespace


TermPositions Methods

[image] [image]

Lucene.Net Class Libraries
TermPositions Methods
TermPositions Interface See Also Send Feedback

The TermPositions type exposes the following members.

Methods

Name Description
Public method Close
Frees associated resources.
(Inherited from TermDocs.)
Public method Doc
Returns the current document number.

This is invalid until {@link #Next()} is called for the first time.

(Inherited from TermDocs.)
Public method Freq
Returns the frequency of the term within the current document.

This is invalid until {@link #Next()} is called for the first time.

(Inherited from TermDocs.)
Public method GetPayload
Returns the payload data at the current term position. This is invalid until {@link #NextPosition()} is called for the first time. This method must not be called more than once after each call of {@link #NextPosition()}. However, payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons.
Public method GetPayloadLength
Returns the length of the payload at the current term position. This is invalid until {@link #NextPosition()} is called for the first time.
Public method IsPayloadAvailable
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to {@link #NextPosition()}.

Public method Next
Moves to the next pair in the enumeration.

Returns true iff there is such a next pair in the enumeration.

(Inherited from TermDocs.)
Public method NextPosition
Returns next position in the current document. It is an error to call this more than {@link #Freq()} times without calling {@link #Next()}

This is invalid until {@link #Next()} is called for the first time.

Public method Read
Attempts to read multiple entries from the enumeration, up to length of docs. Document numbers are stored in docs, and term frequencies are stored in freqs. The freqs array must be as long as the docs array.

Returns the number of entries read. Zero is only returned when the stream has been exhausted.

(Inherited from TermDocs.)
Public method Seek(Term)
Sets this to the data for a term. The enumeration is reset to the start of the data for this term.
(Inherited from TermDocs.)
Public method Seek(TermEnum)
Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations.
(Inherited from TermDocs.)
Public method SkipTo
Skips entries to the first beyond the current whose document number is greater than or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Some implementations are considerably more efficient than that.
(Inherited from TermDocs.)

See Also

TermPositions Interface
Lucene.Net.Index Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
TermPositions..::..GetPayload Method
TermPositions Interface See Also Send Feedback
Returns the payload data at the current term position. This is invalid until {@link #NextPosition()} is called for the first time. This method must not be called more than once after each call of {@link #NextPosition()}. However, payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
byte[] GetPayload(
    byte[] data,
    int offset
)
Visual Basic
Function GetPayload ( _
    data As Byte(), _
    offset As Integer _
) As Byte()
Visual C++
array<unsigned char>^ GetPayload(
    array<unsigned char>^ data,
    int offset
)

Parameters

data
Type: array< System..::..Byte >[]()[][]
the array into which the data of this payload is to be stored, if it is big enough; otherwise, a new byte[] array is allocated for this purpose.
offset
Type: System..::..Int32
the offset in the array into which the data of this payload is to be stored.

Return Value

a byte[] array containing the data of this payload

See Also

TermPositions Interface
Lucene.Net.Index Namespace


GetPayloadLength Method

[image]

Lucene.Net Class Libraries
TermPositions..::..GetPayloadLength Method
TermPositions Interface See Also Send Feedback
Returns the length of the payload at the current term position. This is invalid until {@link #NextPosition()} is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetPayloadLength()
Visual Basic
Function GetPayloadLength As Integer
Visual C++
int GetPayloadLength()

Return Value

length of the current payload in number of bytes

See Also

TermPositions Interface
Lucene.Net.Index Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
TermPositions..::..IsPayloadAvailable Method
TermPositions Interface See Also Send Feedback
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to {@link #NextPosition()}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
bool IsPayloadAvailable()
Visual Basic
Function IsPayloadAvailable As Boolean
Visual C++
bool IsPayloadAvailable()

Return Value

true if there is a payload available at this position that can be loaded

See Also

TermPositions Interface
Lucene.Net.Index Namespace


NextPosition Method

[image]

Lucene.Net Class Libraries
TermPositions..::..NextPosition Method
TermPositions Interface See Also Send Feedback
Returns next position in the current document. It is an error to call this more than {@link #Freq()} times without calling {@link #Next()}

This is invalid until {@link #Next()} is called for the first time.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int NextPosition()
Visual Basic
Function NextPosition As Integer
Visual C++
int NextPosition()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermPositions.NextPosition"]

See Also

TermPositions Interface
Lucene.Net.Index Namespace


Seek Method

[image] [image]

Lucene.Net Class Libraries
TermPositions..::..Seek Method
TermPositions Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(Term) | Sets this to the data for a term. The enumeration is reset to the start of the data for this term. (Inherited from TermDocs.)
Public method | Seek(TermEnum) | Sets this to the data for the current term in a {@link TermEnum}. This may be optimized in some implementations. (Inherited from TermDocs.)

See Also

TermPositions Interface
TermPositions Members
Lucene.Net.Index Namespace


TermPositionVector Interface

[image]

Lucene.Net Class Libraries
TermPositionVector Interface
Members See Also Send Feedback
Extends
CopyC#
TermFreqVector
 to provide additional information about positions in which each of the terms is found. A TermPositionVector not necessarily contains both positions and offsets, but at least one of these arrays exists.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface TermPositionVector : TermFreqVector
Visual Basic
Public Interface TermPositionVector _
    Inherits TermFreqVector
Visual C++
public interface class TermPositionVector : TermFreqVector

See Also

TermPositionVector Members
Lucene.Net.Index Namespace


TermPositionVector Members

[image] [image]

Lucene.Net Class Libraries
TermPositionVector Members
TermPositionVector Interface Methods See Also Send Feedback

The TermPositionVector type exposes the following members.

Methods

Name | Description
Public method GetField
The {@link Lucene.Net.Documents.Fieldable} name.
(Inherited from TermFreqVector.)
Public method GetOffsets
Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.
Public method GetTermFrequencies
Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
CopyC#
getTerms
 method. Each location in the array contains the number of times this term occurs in the document or the document field.
(Inherited from TermFreqVector.)
Public method GetTermPositions
Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the
CopyC#
indexOf
 method. May return null if positions have not been stored.
Public method | GetTerms | (Inherited from TermFreqVector.)
Public method IndexesOf
Just like
CopyC#
indexOf(int)
 but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
(Inherited from TermFreqVector.)
Public method IndexOf
Return an index in the term numbers array returned from
CopyC#
getTerms
 at which the term with the specified
CopyC#
term
 appears. If this term does not appear in the array, return -1.
(Inherited from TermFreqVector.)
Public method | Size | (Inherited from TermFreqVector.)

See Also

TermPositionVector Interface
Lucene.Net.Index Namespace


TermPositionVector Methods

[image] [image]

Lucene.Net Class Libraries
TermPositionVector Methods
TermPositionVector Interface See Also Send Feedback

The TermPositionVector type exposes the following members.

Methods

Name | Description
Public method GetField
The {@link Lucene.Net.Documents.Fieldable} name.
(Inherited from TermFreqVector.)
Public method GetOffsets
Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.
Public method GetTermFrequencies
Array of term frequencies. Locations of the array correspond one to one to the terms in the array obtained from
CopyC#
getTerms
 method. Each location in the array contains the number of times this term occurs in the document or the document field.
(Inherited from TermFreqVector.)
Public method GetTermPositions
Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the
CopyC#
indexOf
 method. May return null if positions have not been stored.
Public method | GetTerms | (Inherited from TermFreqVector.)
Public method IndexesOf
Just like
CopyC#
indexOf(int)
 but searches for a number of terms at the same time. Returns an array that has the same size as the number of terms searched for, each slot containing the result of searching for that term number.
(Inherited from TermFreqVector.)
Public method IndexOf
Return an index in the term numbers array returned from
CopyC#
getTerms
 at which the term with the specified
CopyC#
term
 appears. If this term does not appear in the array, return -1.
(Inherited from TermFreqVector.)
Public method | Size | (Inherited from TermFreqVector.)

See Also

TermPositionVector Interface
Lucene.Net.Index Namespace


GetOffsets Method

[image]

Lucene.Net Class Libraries
TermPositionVector..::..GetOffsets Method
TermPositionVector Interface See Also Send Feedback
Returns an array of TermVectorOffsetInfo in which the term is found. May return null if offsets have not been stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
TermVectorOffsetInfo[] GetOffsets(
    int index
)
Visual Basic
Function GetOffsets ( _
    index As Integer _
) As TermVectorOffsetInfo()
Visual C++
array<TermVectorOffsetInfo^>^ GetOffsets(
    int index
)

Parameters

index
Type: System..::..Int32
The position in the array to get the offsets from

Return Value

An array of TermVectorOffsetInfo objects or the empty list

See Also

TermPositionVector Interface
Lucene.Net.Index Namespace
Lucene.Net.Analysis..::..Token


GetTermPositions Method

[image]

Lucene.Net Class Libraries
TermPositionVector..::..GetTermPositions Method
TermPositionVector Interface See Also Send Feedback
Returns an array of positions in which the term is found. Terms are identified by the index at which its number appears in the term String array obtained from the
CopyC#
indexOf
 method. May return null if positions have not been stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int[] GetTermPositions(
    int index
)
Visual Basic
Function GetTermPositions ( _
    index As Integer _
) As Integer()
Visual C++
array<int>^ GetTermPositions(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Index.TermPositionVector.GetTermPositions(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermPositionVector.GetTermPositions(System.Int32)"]

See Also

TermPositionVector Interface
Lucene.Net.Index Namespace


TermVectorEntry Class

[image]

Lucene.Net Class Libraries
TermVectorEntry Class
Members See Also Send Feedback
Convenience class for holding TermVector information.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TermVectorEntry
Visual Basic
Public Class TermVectorEntry
Visual C++
public ref class TermVectorEntry

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorEntry

See Also

TermVectorEntry Members
Lucene.Net.Index Namespace


TermVectorEntry Members

[image] [image]

Lucene.Net Class Libraries
TermVectorEntry Members
TermVectorEntry Class Constructors Methods See Also Send Feedback

The TermVectorEntry type exposes the following members.

Constructors

 | Name | Description
Public method | TermVectorEntry()()()() | Initializes a new instance of the TermVectorEntry class
Public method | TermVectorEntry(String, String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]) | Initializes a new instance of the TermVectorEntry class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetFrequency |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetOffsets |
Public method | GetPositions |
Public method | GetTerm |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


TermVectorEntry Constructor

[image] [image]

Lucene.Net Class Libraries
TermVectorEntry Constructor
TermVectorEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermVectorEntry()()()() | Initializes a new instance of the TermVectorEntry class
Public method | TermVectorEntry(String, String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]) | Initializes a new instance of the TermVectorEntry class

See Also

TermVectorEntry Class
TermVectorEntry Members
Lucene.Net.Index Namespace


TermVectorEntry Constructor

[image]

Lucene.Net Class Libraries
TermVectorEntry Constructor
TermVectorEntry Class See Also Send Feedback
Initializes a new instance of the TermVectorEntry class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorEntry()
Visual Basic
Public Sub New
Visual C++
public:
TermVectorEntry()

See Also

TermVectorEntry Class
TermVectorEntry Overload
Lucene.Net.Index Namespace


TermVectorEntry Constructor (String, String, Int32, TermVectorOffsetInfo[], Int32[])

[image]

Lucene.Net Class Libraries
TermVectorEntry Constructor (String, String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][])
TermVectorEntry Class See Also Send Feedback
Initializes a new instance of the TermVectorEntry class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorEntry(
    string field,
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Visual Basic
Public Sub New ( _
    field As String, _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Visual C++
public:
TermVectorEntry(
    String^ field,
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo^>^ offsets,
    array<int>^ positions
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.TermVectorEntry.#ctor(System.String,System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Index.TermVectorEntry.#ctor(System.String,System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

frequency
Type: System..::..Int32

[Missing <param name="frequency"/> documentation for "M:Lucene.Net.Index.TermVectorEntry.#ctor(System.String,System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

offsets
Type: array< Lucene.Net.Index..::..TermVectorOffsetInfo >[]()[][]

[Missing <param name="offsets"/> documentation for "M:Lucene.Net.Index.TermVectorEntry.#ctor(System.String,System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

positions
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="positions"/> documentation for "M:Lucene.Net.Index.TermVectorEntry.#ctor(System.String,System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

See Also

TermVectorEntry Class
TermVectorEntry Overload
Lucene.Net.Index Namespace


TermVectorEntry Methods

[image] [image]

Lucene.Net Class Libraries
TermVectorEntry Methods
TermVectorEntry Class See Also Send Feedback

The TermVectorEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetFrequency |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetOffsets |
Public method | GetPositions |
Public method | GetTerm |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..Equals Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.Equals(System.Object)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Index.TermVectorEntry.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.Equals(System.Object)"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


GetField Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..GetField Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetField"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetField"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


GetFrequency Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..GetFrequency Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetFrequency"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetFrequency()
Visual Basic
Public Overridable Function GetFrequency As Integer
Visual C++
public:
virtual int GetFrequency()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetFrequency"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..GetHashCode Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetHashCode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetHashCode"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


GetOffsets Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..GetOffsets Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetOffsets"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TermVectorOffsetInfo[] GetOffsets()
Visual Basic
Public Overridable Function GetOffsets As TermVectorOffsetInfo()
Visual C++
public:
virtual array<TermVectorOffsetInfo^>^ GetOffsets()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetOffsets"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


GetPositions Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..GetPositions Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetPositions"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int[] GetPositions()
Visual Basic
Public Overridable Function GetPositions As Integer()
Visual C++
public:
virtual array<int>^ GetPositions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetPositions"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..GetTerm Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetTerm"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetTerm()
Visual Basic
Public Overridable Function GetTerm As String
Visual C++
public:
virtual String^ GetTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.GetTerm"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TermVectorEntry..::..ToString Method
TermVectorEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntry.ToString"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntry.ToString"]

See Also

TermVectorEntry Class
Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Class

[image]

Lucene.Net Class Libraries
TermVectorEntryFreqSortedComparator Class
Members See Also Send Feedback
Compares {@link Lucene.Net.Index.TermVectorEntry}s first by frequency and then by the term (case-sensitive)

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TermVectorEntryFreqSortedComparator : IComparer<Object>
Visual Basic
Public Class TermVectorEntryFreqSortedComparator _
    Implements IComparer(Of Object)
Visual C++
public ref class TermVectorEntryFreqSortedComparator : IComparer<Object^>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorEntryFreqSortedComparator

See Also

TermVectorEntryFreqSortedComparator Members
Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Members

[image] [image]

Lucene.Net Class Libraries
TermVectorEntryFreqSortedComparator Members
TermVectorEntryFreqSortedComparator Class Constructors Methods See Also Send Feedback

The TermVectorEntryFreqSortedComparator type exposes the following members.

Constructors

 | Name | Description
Public method | TermVectorEntryFreqSortedComparator | Initializes a new instance of the TermVectorEntryFreqSortedComparator class

Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorEntryFreqSortedComparator Class
Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Constructor

[image]

Lucene.Net Class Libraries
TermVectorEntryFreqSortedComparator Constructor
TermVectorEntryFreqSortedComparator Class See Also Send Feedback
Initializes a new instance of the TermVectorEntryFreqSortedComparator class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorEntryFreqSortedComparator()
Visual Basic
Public Sub New
Visual C++
public:
TermVectorEntryFreqSortedComparator()

See Also

TermVectorEntryFreqSortedComparator Class
Lucene.Net.Index Namespace


TermVectorEntryFreqSortedComparator Methods

[image] [image]

Lucene.Net Class Libraries
TermVectorEntryFreqSortedComparator Methods
TermVectorEntryFreqSortedComparator Class See Also Send Feedback

The TermVectorEntryFreqSortedComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorEntryFreqSortedComparator Class
Lucene.Net.Index Namespace


Compare Method

[image]

Lucene.Net Class Libraries
TermVectorEntryFreqSortedComparator..::..Compare Method
TermVectorEntryFreqSortedComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEntryFreqSortedComparator.Compare(System.Object,System.Object)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Compare(
    Object object_Renamed,
    Object object1
)
Visual Basic
Public Overridable Function Compare ( _
    object_Renamed As Object, _
    object1 As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ object_Renamed,
    Object^ object1
)

Parameters

object_Renamed
Type: System..::..Object

[Missing <param name="object_Renamed"/> documentation for "M:Lucene.Net.Index.TermVectorEntryFreqSortedComparator.Compare(System.Object,System.Object)"]

object1
Type: System..::..Object

[Missing <param name="object1"/> documentation for "M:Lucene.Net.Index.TermVectorEntryFreqSortedComparator.Compare(System.Object,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEntryFreqSortedComparator.Compare(System.Object,System.Object)"]

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

TermVectorEntryFreqSortedComparator Class
Lucene.Net.Index Namespace


TermVectorEnumerator Class

[image]

Lucene.Net Class Libraries
TermVectorEnumerator Class
Members See Also Send Feedback
Class to allow for enumerating over the documents in the index to retrieve the term vector for each one.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class TermVectorEnumerator : IEnumerator<TermFreqVector>,
    IDisposable, IEnumerator, IEnumerable<TermFreqVector>, IEnumerable
Visual Basic
Public Class TermVectorEnumerator _
    Implements IEnumerator(Of TermFreqVector), IDisposable,  _
    IEnumerator, IEnumerable(Of TermFreqVector), IEnumerable
Visual C++
public ref class TermVectorEnumerator : IEnumerator<TermFreqVector^>,
    IDisposable, IEnumerator, IEnumerable<TermFreqVector^>, IEnumerable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorEnumerator

See Also

TermVectorEnumerator Members
Lucene.Net.Index Namespace


TermVectorEnumerator Members

[image] [image]

Lucene.Net Class Libraries
TermVectorEnumerator Members
TermVectorEnumerator Class Constructors Methods Properties See Also Send Feedback

The TermVectorEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | TermVectorEnumerator | Ctor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TermVectorEnumerator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


TermVectorEnumerator Constructor

[image]

Lucene.Net Class Libraries
TermVectorEnumerator Constructor
TermVectorEnumerator Class See Also Send Feedback
Ctor.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermVectorEnumerator(
    IndexReader reader,
    string field
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    field As String _
)
Visual C++
public:
TermVectorEnumerator(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The index reader used to read the vectors.
field
Type: System..::..String
The name of the field the vectors are read from.

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


TermVectorEnumerator Methods

[image] [image]

Lucene.Net Class Libraries
TermVectorEnumerator Methods
TermVectorEnumerator Class See Also Send Feedback

The TermVectorEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
TermVectorEnumerator..::..Dispose Method
TermVectorEnumerator Class See Also Send Feedback
Releases all resources used by the TermVectorEnumerator

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


GetEnumerator Method

[image]

Lucene.Net Class Libraries
TermVectorEnumerator..::..GetEnumerator Method
TermVectorEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEnumerator.GetEnumerator"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public IEnumerator<TermFreqVector> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of TermFreqVector)
Visual C++
public:
virtual IEnumerator<TermFreqVector^>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEnumerator.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


MoveNext Method

[image]

Lucene.Net Class Libraries
TermVectorEnumerator..::..MoveNext Method
TermVectorEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEnumerator.MoveNext"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorEnumerator.MoveNext"]

Implements

IEnumerator..::..MoveNext()()()()

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


Reset Method

[image]

Lucene.Net Class Libraries
TermVectorEnumerator..::..Reset Method
TermVectorEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorEnumerator.Reset"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


TermVectorEnumerator Properties

[image] [image]

Lucene.Net Class Libraries
TermVectorEnumerator Properties
TermVectorEnumerator Class See Also Send Feedback

The TermVectorEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current |

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


Current Property

[image]

Lucene.Net Class Libraries
TermVectorEnumerator..::..Current Property
TermVectorEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Index.TermVectorEnumerator.Current"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermFreqVector Current { get; }
Visual Basic
Public ReadOnly Property Current As TermFreqVector
    Get
Visual C++
public:
virtual property TermFreqVector^ Current {
    TermFreqVector^ get () sealed;
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

TermVectorEnumerator Class
Lucene.Net.Index Namespace


TermVectorMapper Class

[image]

Lucene.Net Class Libraries
TermVectorMapper Class
Members See Also Send Feedback
The TermVectorMapper can be used to map Term Vectors into your own structure instead of the parallel array structure used by {@link Lucene.Net.Index.IndexReader#GetTermFreqVector(int,String)}.

It is up to the implementation to make sure it is thread-safe.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TermVectorMapper
Visual Basic
Public MustInherit Class TermVectorMapper
Visual C++
public ref class TermVectorMapper abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorMapper
Lucene.Net.Index..::..FieldSortedTermVectorMapper
Lucene.Net.Index..::..PositionBasedTermVectorMapper
Lucene.Net.Index..::..SortedTermVectorMapper
Lucene.Net.Search.Vectorhighlight..::..VectorHighlightMapper

See Also

TermVectorMapper Members
Lucene.Net.Index Namespace


TermVectorMapper Members

[image] [image]

Lucene.Net Class Libraries
TermVectorMapper Members
TermVectorMapper Class Constructors Methods See Also Send Feedback

The TermVectorMapper type exposes the following members.

Constructors

 | Name | Description
Protected method | TermVectorMapper()()()() | Initializes a new instance of the TermVectorMapper class
Protected method | TermVectorMapper(Boolean, Boolean) | Initializes a new instance of the TermVectorMapper class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets |
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Public method | Map | Map the Term Vector information into your own structure
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
Public method | SetExpectations | Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before {@link #Map(String,int,TermVectorOffsetInfo[],int[])}.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace


TermVectorMapper Constructor

[image] [image]

Lucene.Net Class Libraries
TermVectorMapper Constructor
TermVectorMapper Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | TermVectorMapper()()()() | Initializes a new instance of the TermVectorMapper class
Protected method | TermVectorMapper(Boolean, Boolean) | Initializes a new instance of the TermVectorMapper class

See Also

TermVectorMapper Class
TermVectorMapper Members
Lucene.Net.Index Namespace


TermVectorMapper Constructor

[image]

Lucene.Net Class Libraries
TermVectorMapper Constructor
TermVectorMapper Class See Also Send Feedback
Initializes a new instance of the TermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermVectorMapper()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
TermVectorMapper()

See Also

TermVectorMapper Class
TermVectorMapper Overload
Lucene.Net.Index Namespace


TermVectorMapper Constructor (Boolean, Boolean)

[image]

Lucene.Net Class Libraries
TermVectorMapper Constructor (Boolean, Boolean)
TermVectorMapper Class See Also Send Feedback
Initializes a new instance of the TermVectorMapper class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets
)
Visual Basic
Protected Friend Sub New ( _
    ignoringPositions As Boolean, _
    ignoringOffsets As Boolean _
)
Visual C++
protected public:
TermVectorMapper(
    bool ignoringPositions,
    bool ignoringOffsets
)

Parameters

ignoringPositions
Type: System..::..Boolean
true if this mapper should tell Lucene to ignore positions even if they are stored
ignoringOffsets
Type: System..::..Boolean
similar to ignoringPositions

See Also

TermVectorMapper Class
TermVectorMapper Overload
Lucene.Net.Index Namespace


TermVectorMapper Methods

[image] [image]

Lucene.Net Class Libraries
TermVectorMapper Methods
TermVectorMapper Class See Also Send Feedback

The TermVectorMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIgnoringOffsets |
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.
Public method | Map | Map the Term Vector information into your own structure
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.
Public method | SetExpectations | Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before {@link #Map(String,int,TermVectorOffsetInfo[],int[])}.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace


IsIgnoringOffsets Method

[image]

Lucene.Net Class Libraries
TermVectorMapper..::..IsIgnoringOffsets Method
TermVectorMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorMapper.IsIgnoringOffsets"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsIgnoringOffsets()
Visual Basic
Public Overridable Function IsIgnoringOffsets As Boolean
Visual C++
public:
virtual bool IsIgnoringOffsets()

Return Value

false

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace
Same principal as {@link #IsIgnoringPositions()}, but applied to offsets. false by default.


IsIgnoringPositions Method

[image]

Lucene.Net Class Libraries
TermVectorMapper..::..IsIgnoringPositions Method
TermVectorMapper Class See Also Send Feedback
Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsIgnoringPositions()
Visual Basic
Public Overridable Function IsIgnoringPositions As Boolean
Visual C++
public:
virtual bool IsIgnoringPositions()

Return Value

false

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace


Map Method

[image]

Lucene.Net Class Libraries
TermVectorMapper..::..Map Method
TermVectorMapper Class See Also Send Feedback
Map the Term Vector information into your own structure

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Visual Basic
Public MustOverride Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Visual C++
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo^>^ offsets,
    array<int>^ positions
) abstract

Parameters

term
Type: System..::..String
The term to add to the vector
frequency
Type: System..::..Int32
The frequency of the term in the document
offsets
Type: array< Lucene.Net.Index..::..TermVectorOffsetInfo >[]()[][]
null if the offset is not specified, otherwise the offset into the field of the term
positions
Type: array< System..::..Int32 >[]()[][]
null if the position is not specified, otherwise the position in the field of the term

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace


SetDocumentNumber Method

[image]

Lucene.Net Class Libraries
TermVectorMapper..::..SetDocumentNumber Method
TermVectorMapper Class See Also Send Feedback
Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader.

Default implementation IGNORES the document number. Override if your implementation needs the document number.

NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDocumentNumber(
    int documentNumber
)
Visual Basic
Public Overridable Sub SetDocumentNumber ( _
    documentNumber As Integer _
)
Visual C++
public:
virtual void SetDocumentNumber(
    int documentNumber
)

Parameters

documentNumber
Type: System..::..Int32
index of document currently being mapped

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace


SetExpectations Method

[image]

Lucene.Net Class Libraries
TermVectorMapper..::..SetExpectations Method
TermVectorMapper Class See Also Send Feedback
Tell the mapper what to expect in regards to field, number of terms, offset and position storage. This method will be called once before retrieving the vector for a field. This method will be called before {@link #Map(String,int,TermVectorOffsetInfo[],int[])}.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Visual Basic
Public MustOverride Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Visual C++
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) abstract

Parameters

field
Type: System..::..String
The field the vector is for
numTerms
Type: System..::..Int32
The number of terms that need to be mapped
storeOffsets
Type: System..::..Boolean
true if the mapper should expect offset information
storePositions
Type: System..::..Boolean
true if the mapper should expect positions info

See Also

TermVectorMapper Class
Lucene.Net.Index Namespace


TermVectorOffsetInfo Class

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Class
Members See Also Send Feedback
The TermVectorOffsetInfo class holds information pertaining to a Term in a {@link Lucene.Net.Index.TermPositionVector}'s offset information. This offset information is the character offset as set during the Analysis phase (and thus may not be the actual offset in the original content).

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TermVectorOffsetInfo
Visual Basic
<SerializableAttribute> _
Public Class TermVectorOffsetInfo
Visual C++
[SerializableAttribute]
public ref class TermVectorOffsetInfo

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorOffsetInfo

See Also

TermVectorOffsetInfo Members
Lucene.Net.Index Namespace


TermVectorOffsetInfo Members

[image] [image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Members
TermVectorOffsetInfo Class Constructors Methods Fields See Also Send Feedback

The TermVectorOffsetInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TermVectorOffsetInfo()()()() | Initializes a new instance of the TermVectorOffsetInfo class
Public method | TermVectorOffsetInfo(Int32, Int32) | Initializes a new instance of the TermVectorOffsetInfo class

Methods

 | Name | Description
Public method | Equals | Two TermVectorOffsetInfos are equals if both the start and end offsets are the same (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset | The accessor for the ending offset for the term
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetStartOffset | The accessor for the starting offset of the term.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEndOffset |
Public method | SetStartOffset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
EMPTY_OFFSET_INFO | Convenience declaration when creating a {@link Lucene.Net.Index.TermPositionVector} that stores only position information.

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


TermVectorOffsetInfo Constructor

[image] [image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Constructor
TermVectorOffsetInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermVectorOffsetInfo()()()() | Initializes a new instance of the TermVectorOffsetInfo class
Public method | TermVectorOffsetInfo(Int32, Int32) | Initializes a new instance of the TermVectorOffsetInfo class

See Also

TermVectorOffsetInfo Class
TermVectorOffsetInfo Members
Lucene.Net.Index Namespace


TermVectorOffsetInfo Constructor

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Constructor
TermVectorOffsetInfo Class See Also Send Feedback
Initializes a new instance of the TermVectorOffsetInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorOffsetInfo()
Visual Basic
Public Sub New
Visual C++
public:
TermVectorOffsetInfo()

See Also

TermVectorOffsetInfo Class
TermVectorOffsetInfo Overload
Lucene.Net.Index Namespace


TermVectorOffsetInfo Constructor (Int32, Int32)

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Constructor (Int32, Int32)
TermVectorOffsetInfo Class See Also Send Feedback
Initializes a new instance of the TermVectorOffsetInfo class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorOffsetInfo(
    int startOffset,
    int endOffset
)
Visual Basic
Public Sub New ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Visual C++
public:
TermVectorOffsetInfo(
    int startOffset,
    int endOffset
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.#ctor(System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.#ctor(System.Int32,System.Int32)"]

See Also

TermVectorOffsetInfo Class
TermVectorOffsetInfo Overload
Lucene.Net.Index Namespace


TermVectorOffsetInfo Fields

[image] [image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Fields
TermVectorOffsetInfo Class See Also Send Feedback

The TermVectorOffsetInfo type exposes the following members.

Fields

Name | Description
EMPTY_OFFSET_INFO | Convenience declaration when creating a {@link Lucene.Net.Index.TermPositionVector} that stores only position information.

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


EMPTY_OFFSET_INFO Field

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..EMPTY_OFFSET_INFO Field
TermVectorOffsetInfo Class See Also Send Feedback
Convenience declaration when creating a {@link Lucene.Net.Index.TermPositionVector} that stores only position information.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly TermVectorOffsetInfo[] EMPTY_OFFSET_INFO
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly EMPTY_OFFSET_INFO As TermVectorOffsetInfo()
Visual C++
[NonSerializedAttribute]
public:
static initonly array<TermVectorOffsetInfo^>^ EMPTY_OFFSET_INFO

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


TermVectorOffsetInfo Methods

[image] [image]

Lucene.Net Class Libraries
TermVectorOffsetInfo Methods
TermVectorOffsetInfo Class See Also Send Feedback

The TermVectorOffsetInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Two TermVectorOffsetInfos are equals if both the start and end offsets are the same (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset | The accessor for the ending offset for the term
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetStartOffset | The accessor for the starting offset of the term.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetEndOffset |
Public method | SetStartOffset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..Equals Method
TermVectorOffsetInfo Class See Also Send Feedback
Two TermVectorOffsetInfos are equals if both the start and end offsets are the same

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object
The comparison Object

Return Value

true if both {@link #GetStartOffset()} and {@link #GetEndOffset()} are the same for both objects.

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


GetEndOffset Method

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..GetEndOffset Method
TermVectorOffsetInfo Class See Also Send Feedback
The accessor for the ending offset for the term

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetEndOffset()
Visual Basic
Public Overridable Function GetEndOffset As Integer
Visual C++
public:
virtual int GetEndOffset()

Return Value

The offset

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..GetHashCode Method
TermVectorOffsetInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.GetHashCode"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.GetHashCode"]

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


GetStartOffset Method

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..GetStartOffset Method
TermVectorOffsetInfo Class See Also Send Feedback
The accessor for the starting offset of the term.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetStartOffset()
Visual Basic
Public Overridable Function GetStartOffset As Integer
Visual C++
public:
virtual int GetStartOffset()

Return Value

The offset

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


SetEndOffset Method

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..SetEndOffset Method
TermVectorOffsetInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.SetEndOffset(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetEndOffset(
    int endOffset
)
Visual Basic
Public Overridable Sub SetEndOffset ( _
    endOffset As Integer _
)
Visual C++
public:
virtual void SetEndOffset(
    int endOffset
)

Parameters

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.SetEndOffset(System.Int32)"]

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


SetStartOffset Method

[image]

Lucene.Net Class Libraries
TermVectorOffsetInfo..::..SetStartOffset Method
TermVectorOffsetInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.SetStartOffset(System.Int32)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetStartOffset(
    int startOffset
)
Visual Basic
Public Overridable Sub SetStartOffset ( _
    startOffset As Integer _
)
Visual C++
public:
virtual void SetStartOffset(
    int startOffset
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Index.TermVectorOffsetInfo.SetStartOffset(System.Int32)"]

See Also

TermVectorOffsetInfo Class
Lucene.Net.Index Namespace


TermVectorsReader Class

[image]

Lucene.Net Class Libraries
TermVectorsReader Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Index.TermVectorsReader"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TermVectorsReader : ICloneable
Visual Basic
Public Class TermVectorsReader _
    Implements ICloneable
Visual C++
public ref class TermVectorsReader : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorsReader

See Also

TermVectorsReader Members
Lucene.Net.Index Namespace


TermVectorsReader Members

[image] [image]

Lucene.Net Class Libraries
TermVectorsReader Members
TermVectorsReader Class Constructors Methods See Also Send Feedback

The TermVectorsReader type exposes the following members.

Constructors

 | Name | Description
Public method | TermVectorsReader | Initializes a new instance of the TermVectorsReader class

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Int32) | Return all term vectors stored for this document or null if the could not be read in.
Public method | Get(Int32, TermVectorMapper) |
Public method | Get(Int32, String) | Retrieve the term vector for the given document and field
Public method | Get(Int32, String, TermVectorMapper) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorsReader Class
Lucene.Net.Index Namespace


TermVectorsReader Constructor

[image]

Lucene.Net Class Libraries
TermVectorsReader Constructor
TermVectorsReader Class See Also Send Feedback
Initializes a new instance of the TermVectorsReader class

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermVectorsReader(
    Directory d,
    string segment,
    FieldInfos fieldInfos
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    segment As String, _
    fieldInfos As FieldInfos _
)
Visual C++
public:
TermVectorsReader(
    Directory^ d,
    String^ segment,
    FieldInfos^ fieldInfos
)

Parameters

d
Type: Lucene.Net.Store..::..Directory

[Missing <param name="d"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.#ctor(Lucene.Net.Store.Directory,System.String,Lucene.Net.Index.FieldInfos)"]

segment
Type: System..::..String

[Missing <param name="segment"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.#ctor(Lucene.Net.Store.Directory,System.String,Lucene.Net.Index.FieldInfos)"]

fieldInfos
Type: Lucene.Net.Index..::..FieldInfos

[Missing <param name="fieldInfos"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.#ctor(Lucene.Net.Store.Directory,System.String,Lucene.Net.Index.FieldInfos)"]

See Also

TermVectorsReader Class
Lucene.Net.Index Namespace


TermVectorsReader Methods

[image] [image]

Lucene.Net Class Libraries
TermVectorsReader Methods
TermVectorsReader Class See Also Send Feedback

The TermVectorsReader type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Int32) | Return all term vectors stored for this document or null if the could not be read in.
Public method | Get(Int32, TermVectorMapper) |
Public method | Get(Int32, String) | Retrieve the term vector for the given document and field
Public method | Get(Int32, String, TermVectorMapper) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TermVectorsReader Class
Lucene.Net.Index Namespace


Clone Method

[image]

Lucene.Net Class Libraries
TermVectorsReader..::..Clone Method
TermVectorsReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorsReader.Clone"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Index.TermVectorsReader.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

TermVectorsReader Class
Lucene.Net.Index Namespace


Get Method

[image] [image]

Lucene.Net Class Libraries
TermVectorsReader..::..Get Method
TermVectorsReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(Int32) | Return all term vectors stored for this document or null if the could not be read in.
Public method | Get(Int32, TermVectorMapper) |
Public method | Get(Int32, String) | Retrieve the term vector for the given document and field
Public method | Get(Int32, String, TermVectorMapper) |

See Also

TermVectorsReader Class
TermVectorsReader Members
Lucene.Net.Index Namespace


Get Method (Int32)

[image]

Lucene.Net Class Libraries
TermVectorsReader..::..Get Method (Int32)
TermVectorsReader Class See Also Send Feedback
Return all term vectors stored for this document or null if the could not be read in.

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TermFreqVector[] Get(
    int docNum
)
Visual Basic
Public Overridable Function Get ( _
    docNum As Integer _
) As TermFreqVector()
Visual C++
public:
virtual array<TermFreqVector^>^ Get(
    int docNum
)

Parameters

docNum
Type: System..::..Int32
The document number to retrieve the vector for

Return Value

All term frequency vectors

See Also

TermVectorsReader Class
Get Overload
Lucene.Net.Index Namespace


Get Method (Int32, TermVectorMapper)

[image]

Lucene.Net Class Libraries
TermVectorsReader..::..Get Method (Int32, TermVectorMapper)
TermVectorsReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Get(
    int docNumber,
    TermVectorMapper mapper
)
Visual Basic
Public Overridable Sub Get ( _
    docNumber As Integer, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void Get(
    int docNumber,
    TermVectorMapper^ mapper
)

Parameters

docNumber
Type: System..::..Int32

[Missing <param name="docNumber"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,Lucene.Net.Index.TermVectorMapper)"]

See Also

TermVectorsReader Class
Get Overload
Lucene.Net.Index Namespace


Get Method (Int32, String)

[image]

Lucene.Net Class Libraries
TermVectorsReader..::..Get Method (Int32, String)
TermVectorsReader Class See Also Send Feedback
Retrieve the term vector for the given document and field

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TermFreqVector Get(
    int docNum,
    string field
)
Visual Basic
Public Overridable Function Get ( _
    docNum As Integer, _
    field As String _
) As TermFreqVector
Visual C++
public:
virtual TermFreqVector^ Get(
    int docNum,
    String^ field
)

Parameters

docNum
Type: System..::..Int32
The document number to retrieve the vector for
field
Type: System..::..String
The field within the document to retrieve

Return Value

The TermFreqVector for the document and field or null if there is no termVector for this field.

See Also

TermVectorsReader Class
Get Overload
Lucene.Net.Index Namespace


Get Method (Int32, String, TermVectorMapper)

[image]

Lucene.Net Class Libraries
TermVectorsReader..::..Get Method (Int32, String, TermVectorMapper)
TermVectorsReader Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

Namespace: Lucene.Net.Index
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Get(
    int docNum,
    string field,
    TermVectorMapper mapper
)
Visual Basic
Public Overridable Sub Get ( _
    docNum As Integer, _
    field As String, _
    mapper As TermVectorMapper _
)
Visual C++
public:
virtual void Get(
    int docNum,
    String^ field,
    TermVectorMapper^ mapper
)

Parameters

docNum
Type: System..::..Int32

[Missing <param name="docNum"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

mapper
Type: Lucene.Net.Index..::..TermVectorMapper

[Missing <param name="mapper"/> documentation for "M:Lucene.Net.Index.TermVectorsReader.Get(System.Int32,System.String,Lucene.Net.Index.TermVectorMapper)"]

See Also

TermVectorsReader Class
Get Overload
Lucene.Net.Index Namespace


Lucene.Net.Messages Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Messages Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Messages"]

Classes

 | Class | Description
Public class | MessageImpl | Default implementation of Message interface. For Native Language Support (NLS), system of software internationalization.
Public class | NLS | MessageBundles classes extend this class, to implement a bundle. For Native Language Support (NLS), system of software internationalization. This interface is similar to the NLS class in eclipse.osgi.util.NLS class - initializeMessages() method resets the values of all static strings, should only be called by classes that extend from NLS (see TestMessages.java for reference) - performs validation of all message in a bundle, at class load time - performs per message validation at runtime - see NLSTest.java for usage reference MessageBundle classes may subclass this type.

Interfaces

 | Interface | Description
Public interface | Message | Message Interface for a lazy loading. For Native Language Support (NLS), system of software internationalization.
Public interface | NLS..::..IPriviligedAction |
Public interface | NLSException | Interface that exceptions should implement to support lazy loading of messages. For Native Language Support (NLS), system of software internationalization. This Interface should be implemented by all exceptions that require translation


Message Interface

[image]

Lucene.Net Class Libraries
Message Interface
Members See Also Send Feedback
Message Interface for a lazy loading. For Native Language Support (NLS), system of software internationalization.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface Message
Visual Basic
Public Interface Message
Visual C++
public interface class Message

See Also

Message Members
Lucene.Net.Messages Namespace


Message Members

[image] [image]

Lucene.Net Class Libraries
Message Members
Message Interface Methods See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | GetArguments |
Public method | GetKey |
Public method | GetLocalizedMessage()()()() |
Public method | GetLocalizedMessage(CultureInfo) |

See Also

Message Interface
Lucene.Net.Messages Namespace


Message Methods

[image] [image]

Lucene.Net Class Libraries
Message Methods
Message Interface See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | GetArguments |
Public method | GetKey |
Public method | GetLocalizedMessage()()()() |
Public method | GetLocalizedMessage(CultureInfo) |

See Also

Message Interface
Lucene.Net.Messages Namespace


GetArguments Method

[image]

Lucene.Net Class Libraries
Message..::..GetArguments Method
Message Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.Message.GetArguments"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Object[] GetArguments()
Visual Basic
Function GetArguments As Object()
Visual C++
array<Object^>^ GetArguments()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.Message.GetArguments"]

See Also

Message Interface
Lucene.Net.Messages Namespace


GetKey Method

[image]

Lucene.Net Class Libraries
Message..::..GetKey Method
Message Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.Message.GetKey"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string GetKey()
Visual Basic
Function GetKey As String
Visual C++
String^ GetKey()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.Message.GetKey"]

See Also

Message Interface
Lucene.Net.Messages Namespace


GetLocalizedMessage Method

[image] [image]

Lucene.Net Class Libraries
Message..::..GetLocalizedMessage Method
Message Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLocalizedMessage()()()() |
Public method | GetLocalizedMessage(CultureInfo) |

See Also

Message Interface
Message Members
Lucene.Net.Messages Namespace


GetLocalizedMessage Method

[image]

Lucene.Net Class Libraries
Message..::..GetLocalizedMessage Method
Message Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.Message.GetLocalizedMessage"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string GetLocalizedMessage()
Visual Basic
Function GetLocalizedMessage As String
Visual C++
String^ GetLocalizedMessage()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.Message.GetLocalizedMessage"]

See Also

Message Interface
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


GetLocalizedMessage Method (CultureInfo)

[image]

Lucene.Net Class Libraries
Message..::..GetLocalizedMessage Method (CultureInfo)
Message Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.Message.GetLocalizedMessage(System.Globalization.CultureInfo)"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string GetLocalizedMessage(
    CultureInfo locale
)
Visual Basic
Function GetLocalizedMessage ( _
    locale As CultureInfo _
) As String
Visual C++
String^ GetLocalizedMessage(
    CultureInfo^ locale
)

Parameters

locale
Type: System.Globalization..::..CultureInfo

[Missing <param name="locale"/> documentation for "M:Lucene.Net.Messages.Message.GetLocalizedMessage(System.Globalization.CultureInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.Message.GetLocalizedMessage(System.Globalization.CultureInfo)"]

See Also

Message Interface
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


MessageImpl Class

[image]

Lucene.Net Class Libraries
MessageImpl Class
Members See Also Send Feedback
Default implementation of Message interface. For Native Language Support (NLS), system of software internationalization.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MessageImpl : Message
Visual Basic
<SerializableAttribute> _
Public Class MessageImpl _
    Implements Message
Visual C++
[SerializableAttribute]
public ref class MessageImpl : Message

Inheritance Hierarchy

System..::..Object
Lucene.Net.Messages..::..MessageImpl

See Also

MessageImpl Members
Lucene.Net.Messages Namespace


MessageImpl Members

[image] [image]

Lucene.Net Class Libraries
MessageImpl Members
MessageImpl Class Constructors Methods See Also Send Feedback

The MessageImpl type exposes the following members.

Constructors

 | Name | Description
Public method | MessageImpl(String) | Initializes a new instance of the MessageImpl class
Public method | MessageImpl(String, array<Object>[]()[][]) | Initializes a new instance of the MessageImpl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArguments |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey |
Public method | GetLocalizedMessage()()()() |
Public method | GetLocalizedMessage(CultureInfo) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

MessageImpl Class
Lucene.Net.Messages Namespace


MessageImpl Constructor

[image] [image]

Lucene.Net Class Libraries
MessageImpl Constructor
MessageImpl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageImpl(String) | Initializes a new instance of the MessageImpl class
Public method | MessageImpl(String, array<Object>[]()[][]) | Initializes a new instance of the MessageImpl class

See Also

MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace


MessageImpl Constructor (String)

[image]

Lucene.Net Class Libraries
MessageImpl Constructor (String)
MessageImpl Class See Also Send Feedback
Initializes a new instance of the MessageImpl class

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MessageImpl(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
MessageImpl(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Messages.MessageImpl.#ctor(System.String)"]

See Also

MessageImpl Class
MessageImpl Overload
Lucene.Net.Messages Namespace


MessageImpl Constructor (String, Object[])

[image]

Lucene.Net Class Libraries
MessageImpl Constructor (String, array<Object>[]()[][])
MessageImpl Class See Also Send Feedback
Initializes a new instance of the MessageImpl class

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MessageImpl(
    string key,
    Object[] args
)
Visual Basic
Public Sub New ( _
    key As String, _
    args As Object() _
)
Visual C++
public:
MessageImpl(
    String^ key,
    array<Object^>^ args
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Messages.MessageImpl.#ctor(System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Messages.MessageImpl.#ctor(System.String,System.Object[])"]

See Also

MessageImpl Class
MessageImpl Overload
Lucene.Net.Messages Namespace


MessageImpl Methods

[image] [image]

Lucene.Net Class Libraries
MessageImpl Methods
MessageImpl Class See Also Send Feedback

The MessageImpl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArguments |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey |
Public method | GetLocalizedMessage()()()() |
Public method | GetLocalizedMessage(CultureInfo) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

MessageImpl Class
Lucene.Net.Messages Namespace


GetArguments Method

[image]

Lucene.Net Class Libraries
MessageImpl..::..GetArguments Method
MessageImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.MessageImpl.GetArguments"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object[] GetArguments()
Visual Basic
Public Overridable Function GetArguments As Object()
Visual C++
public:
virtual array<Object^>^ GetArguments()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.MessageImpl.GetArguments"]

Implements

Message..::..GetArguments()()()()

See Also

MessageImpl Class
Lucene.Net.Messages Namespace


GetKey Method

[image]

Lucene.Net Class Libraries
MessageImpl..::..GetKey Method
MessageImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.MessageImpl.GetKey"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetKey()
Visual Basic
Public Overridable Function GetKey As String
Visual C++
public:
virtual String^ GetKey()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.MessageImpl.GetKey"]

Implements

Message..::..GetKey()()()()

See Also

MessageImpl Class
Lucene.Net.Messages Namespace


GetLocalizedMessage Method

[image] [image]

Lucene.Net Class Libraries
MessageImpl..::..GetLocalizedMessage Method
MessageImpl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLocalizedMessage()()()() |
Public method | GetLocalizedMessage(CultureInfo) |

See Also

MessageImpl Class
MessageImpl Members
Lucene.Net.Messages Namespace


GetLocalizedMessage Method

[image]

Lucene.Net Class Libraries
MessageImpl..::..GetLocalizedMessage Method
MessageImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.MessageImpl.GetLocalizedMessage"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLocalizedMessage()
Visual Basic
Public Overridable Function GetLocalizedMessage As String
Visual C++
public:
virtual String^ GetLocalizedMessage()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.MessageImpl.GetLocalizedMessage"]

Implements

Message..::..GetLocalizedMessage()()()()

See Also

MessageImpl Class
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


GetLocalizedMessage Method (CultureInfo)

[image]

Lucene.Net Class Libraries
MessageImpl..::..GetLocalizedMessage Method (CultureInfo)
MessageImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.MessageImpl.GetLocalizedMessage(System.Globalization.CultureInfo)"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLocalizedMessage(
    CultureInfo locale
)
Visual Basic
Public Overridable Function GetLocalizedMessage ( _
    locale As CultureInfo _
) As String
Visual C++
public:
virtual String^ GetLocalizedMessage(
    CultureInfo^ locale
)

Parameters

locale
Type: System.Globalization..::..CultureInfo

[Missing <param name="locale"/> documentation for "M:Lucene.Net.Messages.MessageImpl.GetLocalizedMessage(System.Globalization.CultureInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.MessageImpl.GetLocalizedMessage(System.Globalization.CultureInfo)"]

Implements

Message..::..GetLocalizedMessage(CultureInfo)

See Also

MessageImpl Class
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


ToString Method

[image]

Lucene.Net Class Libraries
MessageImpl..::..ToString Method
MessageImpl Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.MessageImpl.ToString"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.MessageImpl.ToString"]

See Also

MessageImpl Class
Lucene.Net.Messages Namespace


NLS Class

[image]

Lucene.Net Class Libraries
NLS Class
Members See Also Send Feedback
MessageBundles classes extend this class, to implement a bundle. For Native Language Support (NLS), system of software internationalization. This interface is similar to the NLS class in eclipse.osgi.util.NLS class - initializeMessages() method resets the values of all static strings, should only be called by classes that extend from NLS (see TestMessages.java for reference) - performs validation of all message in a bundle, at class load time - performs per message validation at runtime - see NLSTest.java for usage reference MessageBundle classes may subclass this type.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NLS
Visual Basic
Public Class NLS
Visual C++
public ref class NLS

Inheritance Hierarchy

System..::..Object
Lucene.Net.Messages..::..NLS

See Also

NLS Members
Lucene.Net.Messages Namespace


NLS Members

[image] [image]

Lucene.Net Class Libraries
NLS Members
NLS Class Constructors Methods See Also Send Feedback

The NLS type exposes the following members.

Constructors

 | Name | Description
Protected method | NLS | Initializes a new instance of the NLS class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalizedMessage(String) |
 | GetLocalizedMessage(String, CultureInfo) |
 | GetLocalizedMessage(String, array<Object>[]()[][]) |
 | GetLocalizedMessage(String, CultureInfo, array<Object>[]()[][]) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeMessages | Initialize a given class with the message bundle Keys Should be called from a class that extends NLS in a static block at class load time.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NLS Class
Lucene.Net.Messages Namespace


NLS Constructor

[image]

Lucene.Net Class Libraries
NLS Constructor
NLS Class See Also Send Feedback
Initializes a new instance of the NLS class

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal NLS()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
NLS()

See Also

NLS Class
Lucene.Net.Messages Namespace


NLS Methods

[image] [image]

Lucene.Net Class Libraries
NLS Methods
NLS Class See Also Send Feedback

The NLS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalizedMessage(String) |
 | GetLocalizedMessage(String, CultureInfo) |
 | GetLocalizedMessage(String, array<Object>[]()[][]) |
 | GetLocalizedMessage(String, CultureInfo, array<Object>[]()[][]) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeMessages | Initialize a given class with the message bundle Keys Should be called from a class that extends NLS in a static block at class load time.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NLS Class
Lucene.Net.Messages Namespace


GetLocalizedMessage Method

[image] [image]

Lucene.Net Class Libraries
NLS..::..GetLocalizedMessage Method
NLS Class See Also Send Feedback

Overload List

Name | Description
GetLocalizedMessage(String) |
GetLocalizedMessage(String, CultureInfo) |
GetLocalizedMessage(String, array<Object>[]()[][]) |
GetLocalizedMessage(String, CultureInfo, array<Object>[]()[][]) |

See Also

NLS Class
NLS Members
Lucene.Net.Messages Namespace


GetLocalizedMessage Method (String)

[image]

Lucene.Net Class Libraries
NLS..::..GetLocalizedMessage Method (String)
NLS Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String)"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetLocalizedMessage(
    string key
)
Visual Basic
Public Shared Function GetLocalizedMessage ( _
    key As String _
) As String
Visual C++
public:
static String^ GetLocalizedMessage(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String)"]

See Also

NLS Class
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


GetLocalizedMessage Method (String, CultureInfo)

[image]

Lucene.Net Class Libraries
NLS..::..GetLocalizedMessage Method (String, CultureInfo)
NLS Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo)"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetLocalizedMessage(
    string key,
    CultureInfo locale
)
Visual Basic
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    locale As CultureInfo _
) As String
Visual C++
public:
static String^ GetLocalizedMessage(
    String^ key,
    CultureInfo^ locale
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo)"]

locale
Type: System.Globalization..::..CultureInfo

[Missing <param name="locale"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo)"]

See Also

NLS Class
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


GetLocalizedMessage Method (String, Object[])

[image]

Lucene.Net Class Libraries
NLS..::..GetLocalizedMessage Method (String, array<Object>[]()[][])
NLS Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Object[])"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetLocalizedMessage(
    string key,
    Object[] args
)
Visual Basic
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    args As Object() _
) As String
Visual C++
public:
static String^ GetLocalizedMessage(
    String^ key,
    array<Object^>^ args
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Object[])"]

See Also

NLS Class
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


GetLocalizedMessage Method (String, CultureInfo, Object[])

[image]

Lucene.Net Class Libraries
NLS..::..GetLocalizedMessage Method (String, CultureInfo, array<Object>[]()[][])
NLS Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo,System.Object[])"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetLocalizedMessage(
    string key,
    CultureInfo locale,
    Object[] args
)
Visual Basic
Public Shared Function GetLocalizedMessage ( _
    key As String, _
    locale As CultureInfo, _
    args As Object() _
) As String
Visual C++
public:
static String^ GetLocalizedMessage(
    String^ key,
    CultureInfo^ locale,
    array<Object^>^ args
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo,System.Object[])"]

locale
Type: System.Globalization..::..CultureInfo

[Missing <param name="locale"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Messages.NLS.GetLocalizedMessage(System.String,System.Globalization.CultureInfo,System.Object[])"]

See Also

NLS Class
GetLocalizedMessage Overload
Lucene.Net.Messages Namespace


InitializeMessages Method

[image]

Lucene.Net Class Libraries
NLS..::..InitializeMessages Method
NLS Class See Also Send Feedback
Initialize a given class with the message bundle Keys Should be called from a class that extends NLS in a static block at class load time.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static void InitializeMessages(
    string bundleName,
    Type clazz
)
Visual Basic
Protected Friend Shared Sub InitializeMessages ( _
    bundleName As String, _
    clazz As Type _
)
Visual C++
protected public:
static void InitializeMessages(
    String^ bundleName,
    Type^ clazz
)

Parameters

bundleName
Type: System..::..String
Property file with that contains the message bundle
clazz
Type: System..::..Type
where constants will reside

See Also

NLS Class
Lucene.Net.Messages Namespace


NLS.IPriviligedAction Interface

[image]

Lucene.Net Class Libraries
NLS..::..IPriviligedAction Interface
NLS Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Messages.NLS.IPriviligedAction"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface IPriviligedAction
Visual Basic
Public Interface IPriviligedAction
Visual C++
public interface class IPriviligedAction

See Also

NLS..::..IPriviligedAction Members
Lucene.Net.Messages Namespace


NLS.IPriviligedAction Members

[image] [image]

Lucene.Net Class Libraries
NLS..::..IPriviligedAction Members
NLS..::..IPriviligedAction Interface Methods See Also Send Feedback

MessageBundles classes extend this class, to implement a bundle. For Native Language Support (NLS), system of software internationalization. This interface is similar to the NLS class in eclipse.osgi.util.NLS class - initializeMessages() method resets the values of all static strings, should only be called by classes that extend from NLS (see TestMessages.java for reference) - performs validation of all message in a bundle, at class load time - performs per message validation at runtime - see NLSTest.java for usage reference MessageBundle classes may subclass this type.

The NLS..::..IPriviligedAction type exposes the following members.

Methods

 | Name | Description
Public method | Run | Performs the priviliged action.

See Also

NLS..::..IPriviligedAction Interface
Lucene.Net.Messages Namespace


NLS.IPriviligedAction Methods

[image] [image]

Lucene.Net Class Libraries
NLS..::..IPriviligedAction Methods
NLS..::..IPriviligedAction Interface See Also Send Feedback

The NLS..::..IPriviligedAction type exposes the following members.

Methods

 | Name | Description
Public method | Run | Performs the priviliged action.

See Also

NLS..::..IPriviligedAction Interface
Lucene.Net.Messages Namespace


Run Method

[image]

Lucene.Net Class Libraries
NLS..::..IPriviligedAction..::..Run Method
NLS..::..IPriviligedAction Interface See Also Send Feedback
Performs the priviliged action.

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Object Run()
Visual Basic
Function Run As Object
Visual C++
Object^ Run()

Return Value

A value that may represent the result of the action.

See Also

NLS..::..IPriviligedAction Interface
Lucene.Net.Messages Namespace


NLSException Interface

[image]

Lucene.Net Class Libraries
NLSException Interface
Members See Also Send Feedback
Interface that exceptions should implement to support lazy loading of messages. For Native Language Support (NLS), system of software internationalization. This Interface should be implemented by all exceptions that require translation

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface NLSException
Visual Basic
Public Interface NLSException
Visual C++
public interface class NLSException

See Also

NLSException Members
Lucene.Net.Messages Namespace


NLSException Members

[image] [image]

Lucene.Net Class Libraries
NLSException Members
NLSException Interface Methods See Also Send Feedback

The NLSException type exposes the following members.

Methods

 | Name | Description
Public method | GetMessageObject |

See Also

NLSException Interface
Lucene.Net.Messages Namespace


NLSException Methods

[image] [image]

Lucene.Net Class Libraries
NLSException Methods
NLSException Interface See Also Send Feedback

The NLSException type exposes the following members.

Methods

 | Name | Description
Public method | GetMessageObject |

See Also

NLSException Interface
Lucene.Net.Messages Namespace


GetMessageObject Method

[image]

Lucene.Net Class Libraries
NLSException..::..GetMessageObject Method
NLSException Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Messages.NLSException.GetMessageObject"]

Namespace: Lucene.Net.Messages
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Message GetMessageObject()
Visual Basic
Function GetMessageObject As Message
Visual C++
Message^ GetMessageObject()

Return Value

a instance of a class that implements the Message interface

See Also

NLSException Interface
Lucene.Net.Messages Namespace


Lucene.Net.QueryParsers Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.QueryParsers Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.QueryParsers"]

Classes

Class Description
Public class FastCharStream
An efficient implementation of JavaCC's CharStream interface.

Note that this does not do line-number counting, but instead keeps track of the character position of the token in the input, as required by Lucene's {@link Lucene.Net.Analysis.Token} API.

Public class MultiFieldQueryParser
A QueryParser which constructs queries to search multiple fields.
Public class ParseException
This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.
Public class QueryParser
This class is generated by JavaCC. The most important method is {@link #Parse(String)}. The syntax for query strings is as follows: A Query is a series of clauses. A clause may be prefixed by:
  • a plus (
    CopyC#
    +
    ) or a minus (
    CopyC#
    -
    ) sign, indicating that the clause is required or prohibited respectively; or
  • a term followed by a colon, indicating the field to be searched. This enables one to construct queries which search multiple fields.
A clause may be either:
  • a term, indicating all the documents that contain this term; or
  • a nested query, enclosed in parentheses. Note that this may be used with a
    CopyC#
    +
    /
    CopyC#
    -
     prefix to require any of a set of terms.
Thus, in BNF, the query grammar is:
            Query  ::= ( Clause )*
            Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )

Examples of appropriately formatted queries can be found in the query syntax documentation.

In {@link TermRangeQuery}s, QueryParser tries to detect date values, e.g. date:[6/1/2005 TO 6/4/2005] produces a range query that searches for "date" fields between 2005-06-01 and 2005-06-04. Note that the format of the accepted input depends on {@link #SetLocale(Locale) the locale}. By default a date is converted into a search term using the deprecated {@link DateField} for compatibility reasons. To use the new {@link DateTools} to convert dates, a {@link Lucene.Net.Documents.DateTools.Resolution} has to be set.

The date resolution that shall be used for RangeQueries can be set using {@link #SetDateResolution(DateTools.Resolution)} or {@link #SetDateResolution(String, DateTools.Resolution)}. The former sets the default date resolution for all fields, whereas the latter can be used to set field specific date resolutions. Field specific date resolutions take, if set, precedence over the default date resolution.

If you use neither {@link DateField} nor {@link DateTools} in your index, you can create your own query parser that inherits QueryParser and overwrites {@link #GetRangeQuery(String, String, String, boolean)} to use a different method for date conversion.

Note that QueryParser is not thread-safe.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created. NOTE: You must specify the required {@link Version} compatibility when creating QueryParser:

  • As of 2.9, {@link #SetEnablePositionIncrements} is true by default.
Public class QueryParser..::..Operator
The default operator for parsing queries. Use {@link QueryParser#setDefaultOperator} to change it.
Public class QueryParserConstants
Token literal values and constants. Generated by org.javacc.parser.OtherFilesGen#start()
Public class QueryParserTokenManager
Token Manager.
Public class Token
Describes the input token stream.
Public class TokenMgrError
Token Manager Error.

Interfaces

 | Interface | Description
Public interface | CharStream | This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.


CharStream Interface

[image]

Lucene.Net Class Libraries
CharStream Interface
Members See Also Send Feedback
This interface describes a character stream that maintains line and column number positions of the characters. It also has the capability to backup the stream to some extent. An implementation of this interface is used in the TokenManager implementation generated by JavaCCParser. All the methods except backup can be implemented in any fashion. backup needs to be implemented correctly for the correct operation of the lexer. Rest of the methods are all used to get information like line number, column number and the String that constitutes a token and are not used by the lexer. Hence their implementation won't affect the generated lexer's operation.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface CharStream
Visual Basic
Public Interface CharStream
Visual C++
public interface class CharStream

See Also

CharStream Members
Lucene.Net.QueryParsers Namespace


CharStream Members

[image] [image]

Lucene.Net Class Libraries
CharStream Members
CharStream Interface Methods See Also Send Feedback

The CharStream type exposes the following members.

Methods

 | Name | Description
Public method | Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
Public method | BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Public method | Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
Public method | GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
Public method | GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
Public method | GetColumn | Obsolete. Returns the column position of the character last read.
Public method | GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
Public method | GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
Public method | GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
Public method | GetLine | Obsolete. Returns the line number of the character last read.
Public method | GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
Public method | ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


CharStream Methods

[image] [image]

Lucene.Net Class Libraries
CharStream Methods
CharStream Interface See Also Send Feedback

The CharStream type exposes the following members.

Methods

 | Name | Description
Public method | Backup | Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.
Public method | BeginToken | Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.
Public method | Done | The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.
Public method | GetBeginColumn | Returns the column number of the first character for current token (being matched after the last call to BeginTOken).
Public method | GetBeginLine | Returns the line number of the first character for current token (being matched after the last call to BeginTOken).
Public method | GetColumn | Obsolete. Returns the column position of the character last read.
Public method | GetEndColumn | Returns the column number of the last character for current token (being matched after the last call to BeginTOken).
Public method | GetEndLine | Returns the line number of the last character for current token (being matched after the last call to BeginTOken).
Public method | GetImage | Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.
Public method | GetLine | Obsolete. Returns the line number of the character last read.
Public method | GetSuffix | Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }
Public method | ReadChar | Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


Backup Method

[image]

Lucene.Net Class Libraries
CharStream..::..Backup Method
CharStream Interface See Also Send Feedback
Backs up the input stream by amount steps. Lexer calls this method if it had already read some characters, but could not use them to match a (longer) token. So, they will be used again as the prefix of the next token and it is the implemetation's responsibility to do this right.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Backup(
    int amount
)
Visual Basic
Sub Backup ( _
    amount As Integer _
)
Visual C++
void Backup(
    int amount
)

Parameters

amount
Type: System..::..Int32

[Missing <param name="amount"/> documentation for "M:Lucene.Net.QueryParsers.CharStream.Backup(System.Int32)"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


BeginToken Method

[image]

Lucene.Net Class Libraries
CharStream..::..BeginToken Method
CharStream Interface See Also Send Feedback
Returns the next character that marks the beginning of the next token. All characters must remain in the buffer between two successive calls to this method to implement backup correctly.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
char BeginToken()
Visual Basic
Function BeginToken As Char
Visual C++
wchar_t BeginToken()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.BeginToken"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


Done Method

[image]

Lucene.Net Class Libraries
CharStream..::..Done Method
CharStream Interface See Also Send Feedback
The lexer calls this function to indicate that it is done with the stream and hence implementations can free any resources held by this class. Again, the body of this function can be just empty and it will not affect the lexer's operation.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Done()
Visual Basic
Sub Done
Visual C++
void Done()

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


GetBeginColumn Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetBeginColumn Method
CharStream Interface See Also Send Feedback
Returns the column number of the first character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetBeginColumn()
Visual Basic
Function GetBeginColumn As Integer
Visual C++
int GetBeginColumn()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetBeginColumn"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


GetBeginLine Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetBeginLine Method
CharStream Interface See Also Send Feedback
Returns the line number of the first character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetBeginLine()
Visual Basic
Function GetBeginLine As Integer
Visual C++
int GetBeginLine()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetBeginLine"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


GetColumn Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetColumn Method
CharStream Interface See Also Send Feedback
Returns the column position of the character last read.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
int GetColumn()
Visual Basic
<ObsoleteAttribute> _
Function GetColumn As Integer
Visual C++
[ObsoleteAttribute]
int GetColumn()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetColumn"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace
[!:getEndColumn]


GetEndColumn Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetEndColumn Method
CharStream Interface See Also Send Feedback
Returns the column number of the last character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetEndColumn()
Visual Basic
Function GetEndColumn As Integer
Visual C++
int GetEndColumn()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetEndColumn"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


GetEndLine Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetEndLine Method
CharStream Interface See Also Send Feedback
Returns the line number of the last character for current token (being matched after the last call to BeginTOken).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int GetEndLine()
Visual Basic
Function GetEndLine As Integer
Visual C++
int GetEndLine()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetEndLine"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


GetImage Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetImage Method
CharStream Interface See Also Send Feedback
Returns a string made up of characters from the marked token beginning to the current buffer position. Implementations have the choice of returning anything that they want to. For example, for efficiency, one might decide to just return null, which is a valid implementation.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string GetImage()
Visual Basic
Function GetImage As String
Visual C++
String^ GetImage()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetImage"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


GetLine Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetLine Method
CharStream Interface See Also Send Feedback
Returns the line number of the character last read.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
int GetLine()
Visual Basic
<ObsoleteAttribute> _
Function GetLine As Integer
Visual C++
[ObsoleteAttribute]
int GetLine()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetLine"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace
[!:getEndLine]


GetSuffix Method

[image]

Lucene.Net Class Libraries
CharStream..::..GetSuffix Method
CharStream Interface See Also Send Feedback
Returns an array of characters that make up the suffix of length 'len' for the currently matched token. This is used to build up the matched string for use in actions in the case of MORE. A simple and inefficient implementation of this is as follows : { String t = GetImage(); return t.substring(t.length() - len, t.length()).toCharArray(); }

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
char[] GetSuffix(
    int len
)
Visual Basic
Function GetSuffix ( _
    len As Integer _
) As Char()
Visual C++
array<wchar_t>^ GetSuffix(
    int len
)

Parameters

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetSuffix(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.GetSuffix(System.Int32)"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


ReadChar Method

[image]

Lucene.Net Class Libraries
CharStream..::..ReadChar Method
CharStream Interface See Also Send Feedback
Returns the next character from the selected input. The method of selecting the input is the responsibility of the class implementing this interface. Can throw any java.io.IOException.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
char ReadChar()
Visual Basic
Function ReadChar As Char
Visual C++
wchar_t ReadChar()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.CharStream.ReadChar"]

See Also

CharStream Interface
Lucene.Net.QueryParsers Namespace


FastCharStream Class

[image]

Lucene.Net Class Libraries
FastCharStream Class
Members See Also Send Feedback
An efficient implementation of JavaCC's CharStream interface.

Note that this does not do line-number counting, but instead keeps track of the character position of the token in the input, as required by Lucene's {@link Lucene.Net.Analysis.Token} API.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FastCharStream : CharStream
Visual Basic
Public NotInheritable Class FastCharStream _
    Implements CharStream
Visual C++
public ref class FastCharStream sealed : CharStream

Inheritance Hierarchy

System..::..Object
Lucene.Net.QueryParsers..::..FastCharStream

See Also

FastCharStream Members
Lucene.Net.QueryParsers Namespace


FastCharStream Members

[image] [image]

Lucene.Net Class Libraries
FastCharStream Members
FastCharStream Class Constructors Methods See Also Send Feedback

The FastCharStream type exposes the following members.

Constructors

 | Name | Description
Public method | FastCharStream | Constructs from a Reader.

Methods

 | Name | Description
Public method | Backup |
Public method | BeginToken |
Public method | Done |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBeginColumn |
Public method | GetBeginLine |
Public method | GetColumn |
Public method | GetEndColumn |
Public method | GetEndLine |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage |
Public method | GetLine |
Public method | GetSuffix |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadChar |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


FastCharStream Constructor

[image]

Lucene.Net Class Libraries
FastCharStream Constructor
FastCharStream Class See Also Send Feedback
Constructs from a Reader.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FastCharStream(
    TextReader r
)
Visual Basic
Public Sub New ( _
    r As TextReader _
)
Visual C++
public:
FastCharStream(
    TextReader^ r
)

Parameters

r
Type: System.IO..::..TextReader

[Missing <param name="r"/> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.#ctor(System.IO.TextReader)"]

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


FastCharStream Methods

[image] [image]

Lucene.Net Class Libraries
FastCharStream Methods
FastCharStream Class See Also Send Feedback

The FastCharStream type exposes the following members.

Methods

 | Name | Description
Public method | Backup |
Public method | BeginToken |
Public method | Done |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBeginColumn |
Public method | GetBeginLine |
Public method | GetColumn |
Public method | GetEndColumn |
Public method | GetEndLine |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage |
Public method | GetLine |
Public method | GetSuffix |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadChar |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


Backup Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..Backup Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.Backup(System.Int32)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Backup(
    int amount
)
Visual Basic
Public Sub Backup ( _
    amount As Integer _
)
Visual C++
public:
virtual void Backup(
    int amount
) sealed

Parameters

amount
Type: System..::..Int32

[Missing <param name="amount"/> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.Backup(System.Int32)"]

Implements

CharStream..::..Backup(Int32)

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


BeginToken Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..BeginToken Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.BeginToken"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char BeginToken()
Visual Basic
Public Function BeginToken As Char
Visual C++
public:
virtual wchar_t BeginToken() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.BeginToken"]

Implements

CharStream..::..BeginToken()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


Done Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..Done Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.Done"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Done()
Visual Basic
Public Sub Done
Visual C++
public:
virtual void Done() sealed

Implements

CharStream..::..Done()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetBeginColumn Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetBeginColumn Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetBeginColumn"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetBeginColumn()
Visual Basic
Public Function GetBeginColumn As Integer
Visual C++
public:
virtual int GetBeginColumn() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetBeginColumn"]

Implements

CharStream..::..GetBeginColumn()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetBeginLine Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetBeginLine Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetBeginLine"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetBeginLine()
Visual Basic
Public Function GetBeginLine As Integer
Visual C++
public:
virtual int GetBeginLine() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetBeginLine"]

Implements

CharStream..::..GetBeginLine()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetColumn Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetColumn Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetColumn"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetColumn()
Visual Basic
Public Function GetColumn As Integer
Visual C++
public:
virtual int GetColumn() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetColumn"]

Implements

CharStream..::..GetColumn()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetEndColumn Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetEndColumn Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetEndColumn"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetEndColumn()
Visual Basic
Public Function GetEndColumn As Integer
Visual C++
public:
virtual int GetEndColumn() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetEndColumn"]

Implements

CharStream..::..GetEndColumn()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetEndLine Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetEndLine Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetEndLine"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetEndLine()
Visual Basic
Public Function GetEndLine As Integer
Visual C++
public:
virtual int GetEndLine() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetEndLine"]

Implements

CharStream..::..GetEndLine()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetImage Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetImage Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetImage"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetImage()
Visual Basic
Public Function GetImage As String
Visual C++
public:
virtual String^ GetImage() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetImage"]

Implements

CharStream..::..GetImage()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetLine Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetLine Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetLine"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetLine()
Visual Basic
Public Function GetLine As Integer
Visual C++
public:
virtual int GetLine() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetLine"]

Implements

CharStream..::..GetLine()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


GetSuffix Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..GetSuffix Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetSuffix(System.Int32)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char[] GetSuffix(
    int len
)
Visual Basic
Public Function GetSuffix ( _
    len As Integer _
) As Char()
Visual C++
public:
virtual array<wchar_t>^ GetSuffix(
    int len
) sealed

Parameters

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetSuffix(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.GetSuffix(System.Int32)"]

Implements

CharStream..::..GetSuffix(Int32)

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


ReadChar Method

[image]

Lucene.Net Class Libraries
FastCharStream..::..ReadChar Method
FastCharStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.ReadChar"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char ReadChar()
Visual Basic
Public Function ReadChar As Char
Visual C++
public:
virtual wchar_t ReadChar() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.FastCharStream.ReadChar"]

Implements

CharStream..::..ReadChar()()()()

See Also

FastCharStream Class
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Class

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser Class
Members See Also Send Feedback
A QueryParser which constructs queries to search multiple fields.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MultiFieldQueryParser : QueryParser
Visual Basic
Public Class MultiFieldQueryParser _
    Inherits QueryParser
Visual C++
public ref class MultiFieldQueryParser : public QueryParser

Inheritance Hierarchy

System..::..Object
Lucene.Net.QueryParsers..::..QueryParserConstants
Lucene.Net.QueryParsers..::..QueryParser
Lucene.Net.QueryParsers..::..MultiFieldQueryParser

See Also

MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Members

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser Members
MultiFieldQueryParser Class Constructors Methods Fields See Also Send Feedback

The MultiFieldQueryParser type exposes the following members.

Constructors

Name Description
Public method MultiFieldQueryParser(array<String>[]()[][], Analyzer) Obsolete.
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(array<String>[]()[][], Analyzer, IDictionary) Obsolete.
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

CopyC#
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(Version, array<String>[]()[][], Analyzer)
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(Version, array<String>[]()[][], Analyzer, IDictionary)
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

CopyC#
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Methods

Name | Description
Protected method | AddClause(ArrayList, Int32, Int32, Query) | Obsolete. (Inherited from QueryParser.)
Protected method | AddClause(IList, Int32, Int32, Query) | (Inherited from QueryParser.)
Public method | Clause | (Inherited from QueryParser.)
Public method | Conjunction | (Inherited from QueryParser.)
Public method Disable_tracing
Disable tracing.
(Inherited from QueryParser.)
Public method Enable_tracing
Enable tracing.
(Inherited from QueryParser.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GenerateParseException
Generate ParseException.
(Inherited from QueryParser.)
Public method | GetAllowLeadingWildcard | (Inherited from QueryParser.)
Public method | GetAnalyzer | (Inherited from QueryParser.)
Protected method GetBooleanQuery(ArrayList) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(ArrayList, Boolean) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList, Boolean)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Public method GetDateResolution
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
(Inherited from QueryParser.)
Public method GetDefaultOperator
Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
(Inherited from QueryParser.)
Public method | GetEnablePositionIncrements | (Inherited from QueryParser.)
Public method | GetField | (Inherited from QueryParser.)
Public method | GetFieldQuery(String, String) | (Overrides QueryParser..::..GetFieldQuery(String, String).)
Protected method | GetFieldQuery(String, String, Int32) | (Overrides QueryParser..::..GetFieldQuery(String, String, Int32).)
Public method GetFuzzyMinSim
Get the minimal similarity for fuzzy queries.
(Inherited from QueryParser.)
Public method GetFuzzyPrefixLength
Get the prefix length for fuzzy queries.
(Inherited from QueryParser.)
Public method | GetFuzzyQuery | (Overrides QueryParser..::..GetFuzzyQuery(String, String, Single).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLocale
Returns current locale, allowing access by subclasses.
(Inherited from QueryParser.)
Public method | GetLowercaseExpandedTerms | (Inherited from QueryParser.)
Public method | GetMultiTermRewriteMethod | (Inherited from QueryParser.)
Public method GetNextToken
Get the next Token.
(Inherited from QueryParser.)
Public method GetPhraseSlop
Gets the default slop for phrases.
(Inherited from QueryParser.)
Public method | GetPrefixQuery | (Overrides QueryParser..::..GetPrefixQuery(String, String).)
Public method | GetRangeCollator | (Inherited from QueryParser.)
Protected method | GetRangeQuery | (Overrides QueryParser..::..GetRangeQuery(String, String, String, Boolean).)
Public method GetToken
Get the specific Token.
(Inherited from QueryParser.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUseOldRangeQuery | Obsolete. (Inherited from QueryParser.)
Public method | GetWildcardQuery | (Overrides QueryParser..::..GetWildcardQuery(String, String).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Modifiers | (Inherited from QueryParser.)
Protected method NewBooleanClause
Builds a new BooleanClause instance
(Inherited from QueryParser.)
Protected method NewBooleanQuery
Builds a new BooleanQuery instance
(Inherited from QueryParser.)
Protected method NewFuzzyQuery
Builds a new FuzzyQuery instance
(Inherited from QueryParser.)
Protected method NewMatchAllDocsQuery
Builds a new MatchAllDocsQuery instance
(Inherited from QueryParser.)
Protected method NewMultiPhraseQuery
Builds a new MultiPhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPhraseQuery
Builds a new PhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPrefixQuery
Builds a new PrefixQuery instance
(Inherited from QueryParser.)
Protected method NewRangeQuery
Builds a new TermRangeQuery instance
(Inherited from QueryParser.)
Protected method NewTermQuery
Builds a new TermQuery instance
(Inherited from QueryParser.)
Protected method NewWildcardQuery
Builds a new WildcardQuery instance
(Inherited from QueryParser.)
Public method Parse(String)
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
(Inherited from QueryParser.)
Parse(array<String>[]()[][], array<String>[]()[][], Analyzer) Obsolete.
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
Parse(String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer) Obsolete.
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query) +(contents:query) -(description:query)
Parse(array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer) Obsolete.
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query1) +(contents:query2) -(description:query3)
Parse(Version, array<String>[]()[][], array<String>[]()[][], Analyzer)
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
Parse(Version, String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse("query", fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query) +(contents:query) -(description:query)
            </code>
Parse(Version, array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] query = {"query1", "query2", "query3"};
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse(query, fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query1) +(contents:query2) -(description:query3)
            </code>
Public method | Query | (Inherited from QueryParser.)
Public method ReInit(CharStream)
Reinitialise.
(Inherited from QueryParser.)
Public method ReInit(QueryParserTokenManager)
Reinitialise.
(Inherited from QueryParser.)
Public method SetAllowLeadingWildcard
Set to
CopyC#
true
 to allow leading wildcard characters.

When set,

CopyC#
*
or
CopyC#
?
 are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes.

Default: false.

(Inherited from QueryParser.)
Public method SetDateResolution(DateTools..::..Resolution)
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
(Inherited from QueryParser.)
Public method SetDateResolution(String, DateTools..::..Resolution)
Sets the date resolution used by RangeQueries for a specific field.
(Inherited from QueryParser.)
Public method SetDefaultOperator
Sets the boolean operator of the QueryParser. In default mode (
CopyC#
OR_OPERATOR
) terms without any modifiers are considered optional: for example
CopyC#
capital of Hungary
 is equal to
CopyC#
capital OR of OR Hungary
.
In
CopyC#
AND_OPERATOR
 mode terms are considered to be in conjunction: the above mentioned query is parsed as
CopyC#
capital AND of AND Hungary
(Inherited from QueryParser.)
Public method SetEnablePositionIncrements
Set to
CopyC#
true
 to enable position increments in result query.

When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token.

Default: false.

(Inherited from QueryParser.)
Public method SetFuzzyMinSim
Set the minimum similarity for fuzzy queries. Default is 0.5f.
(Inherited from QueryParser.)
Public method SetFuzzyPrefixLength
Set the prefix length for fuzzy queries. Default is 0.
(Inherited from QueryParser.)
Public method SetLocale
Set locale used by date range parsing.
(Inherited from QueryParser.)
Public method SetLowercaseExpandedTerms
Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
CopyC#
true
.
(Inherited from QueryParser.)
Public method SetMultiTermRewriteMethod
By default QueryParser uses {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.
(Inherited from QueryParser.)
Public method SetPhraseSlop
Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
(Inherited from QueryParser.)
Public method SetRangeCollator
Sets the collator used to determine index term inclusion in ranges for RangeQuerys.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

(Inherited from QueryParser.)
Public method | SetUseOldRangeQuery | Obsolete. (Inherited from QueryParser.)
Public method | Term | (Inherited from QueryParser.)
Public method | TopLevelQuery | (Inherited from QueryParser.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | boosts |
Protected field | fields |
Public field | token | Current token. (Inherited from QueryParser.)
Public field | token_source | Generated Token Manager. (Inherited from QueryParser.)

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser Constructor
MultiFieldQueryParser Class See Also Send Feedback

Overload List

Name Description
Public method MultiFieldQueryParser(array<String>[]()[][], Analyzer) Obsolete.
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(array<String>[]()[][], Analyzer, IDictionary) Obsolete.
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

CopyC#
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(Version, array<String>[]()[][], Analyzer)
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Public method MultiFieldQueryParser(Version, array<String>[]()[][], Analyzer, IDictionary)
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

CopyC#
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor (String[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser Constructor (array<String>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use MultiFieldQueryParser(Version, String[], Analyzer) instead")]
public MultiFieldQueryParser(
    string[] fields,
    Analyzer analyzer
)
Visual Basic
<ObsoleteAttribute("Please use MultiFieldQueryParser(Version, String[], Analyzer) instead")> _
Public Sub New ( _
    fields As String(), _
    analyzer As Analyzer _
)
Visual C++
[ObsoleteAttribute(L"Please use MultiFieldQueryParser(Version, String[], Analyzer) instead")]
public:
MultiFieldQueryParser(
    array<String^>^ fields,
    Analyzer^ analyzer
)

Parameters

fields
Type: array< System..::..String >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(System.String[],Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(System.String[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Overload
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor (String[], Analyzer, IDictionary)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser Constructor (array<String>[]()[][], Analyzer, IDictionary)
MultiFieldQueryParser Class See Also Send Feedback
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

CopyC#
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use MultiFieldQueryParser(Version, String[], Analyzer, IDictionary) instead")]
public MultiFieldQueryParser(
    string[] fields,
    Analyzer analyzer,
    IDictionary boosts
)
Visual Basic
<ObsoleteAttribute("Please use MultiFieldQueryParser(Version, String[], Analyzer, IDictionary) instead")> _
Public Sub New ( _
    fields As String(), _
    analyzer As Analyzer, _
    boosts As IDictionary _
)
Visual C++
[ObsoleteAttribute(L"Please use MultiFieldQueryParser(Version, String[], Analyzer, IDictionary) instead")]
public:
MultiFieldQueryParser(
    array<String^>^ fields,
    Analyzer^ analyzer,
    IDictionary^ boosts
)

Parameters

fields
Type: array< System..::..String >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

boosts
Type: System.Collections..::..IDictionary

[Missing <param name="boosts"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Overload
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor (Version, String[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser Constructor (Version, array<String>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Creates a MultiFieldQueryParser.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiFieldQueryParser(
    Version matchVersion,
    string[] fields,
    Analyzer analyzer
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    fields As String(), _
    analyzer As Analyzer _
)
Visual C++
public:
MultiFieldQueryParser(
    Version^ matchVersion,
    array<String^>^ fields,
    Analyzer^ analyzer
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer)"]

fields
Type: array< System..::..String >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Overload
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Constructor (Version, String[], Analyzer, IDictionary)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser Constructor (Version, array<String>[]()[][], Analyzer, IDictionary)
MultiFieldQueryParser Class See Also Send Feedback
Creates a MultiFieldQueryParser. Allows passing of a map with term to Boost, and the boost to apply to each term.

It will, when parse(String query) is called, construct a query like this (assuming the query consists of two terms and you specify the two fields

CopyC#
title
and
CopyC#
body
):

CopyC#
(title:term1 body:term1) (title:term2 body:term2)

When setDefaultOperator(AND_OPERATOR) is set, the result will be:

CopyC#
+(title:term1 body:term1) +(title:term2 body:term2)

When you pass a boost (title=>5 body=>10) you can get

CopyC#
+(title:term1^5.0 body:term1^10.0) +(title:term2^5.0 body:term2^10.0)

In other words, all the query's terms must appear, but it doesn't matter in what fields they appear.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiFieldQueryParser(
    Version matchVersion,
    string[] fields,
    Analyzer analyzer,
    IDictionary boosts
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    fields As String(), _
    analyzer As Analyzer, _
    boosts As IDictionary _
)
Visual C++
public:
MultiFieldQueryParser(
    Version^ matchVersion,
    array<String^>^ fields,
    Analyzer^ analyzer,
    IDictionary^ boosts
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version

[Missing <param name="matchVersion"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

fields
Type: array< System..::..String >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

boosts
Type: System.Collections..::..IDictionary

[Missing <param name="boosts"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.#ctor(Lucene.Net.Util.Version,System.String[],Lucene.Net.Analysis.Analyzer,System.Collections.IDictionary)"]

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Overload
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Fields

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser Fields
MultiFieldQueryParser Class See Also Send Feedback

The MultiFieldQueryParser type exposes the following members.

Fields

 | Name | Description
Protected field | boosts |
Protected field | fields |
Public field | token | Current token. (Inherited from QueryParser.)
Public field | token_source | Generated Token Manager. (Inherited from QueryParser.)

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


boosts Field

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..boosts Field
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.QueryParsers.MultiFieldQueryParser.boosts"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IDictionary boosts
Visual Basic
Protected Friend boosts As IDictionary
Visual C++
protected public:
IDictionary^ boosts

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


fields Field

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..fields Field
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.QueryParsers.MultiFieldQueryParser.fields"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string[] fields
Visual Basic
Protected Friend fields As String()
Visual C++
protected public:
array<String^>^ fields

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


MultiFieldQueryParser Methods

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser Methods
MultiFieldQueryParser Class See Also Send Feedback

The MultiFieldQueryParser type exposes the following members.

Methods

Name | Description
Protected method | AddClause(ArrayList, Int32, Int32, Query) | Obsolete. (Inherited from QueryParser.)
Protected method | AddClause(IList, Int32, Int32, Query) | (Inherited from QueryParser.)
Public method | Clause | (Inherited from QueryParser.)
Public method | Conjunction | (Inherited from QueryParser.)
Public method Disable_tracing
Disable tracing.
(Inherited from QueryParser.)
Public method Enable_tracing
Enable tracing.
(Inherited from QueryParser.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GenerateParseException
Generate ParseException.
(Inherited from QueryParser.)
Public method | GetAllowLeadingWildcard | (Inherited from QueryParser.)
Public method | GetAnalyzer | (Inherited from QueryParser.)
Protected method GetBooleanQuery(ArrayList) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(ArrayList, Boolean) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Protected method GetBooleanQuery(IList, Boolean)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
(Inherited from QueryParser.)
Public method GetDateResolution
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
(Inherited from QueryParser.)
Public method GetDefaultOperator
Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
(Inherited from QueryParser.)
Public method | GetEnablePositionIncrements | (Inherited from QueryParser.)
Public method | GetField | (Inherited from QueryParser.)
Public method | GetFieldQuery(String, String) | (Overrides QueryParser..::..GetFieldQuery(String, String).)
Protected method | GetFieldQuery(String, String, Int32) | (Overrides QueryParser..::..GetFieldQuery(String, String, Int32).)
Public method GetFuzzyMinSim
Get the minimal similarity for fuzzy queries.
(Inherited from QueryParser.)
Public method GetFuzzyPrefixLength
Get the prefix length for fuzzy queries.
(Inherited from QueryParser.)
Public method | GetFuzzyQuery | (Overrides QueryParser..::..GetFuzzyQuery(String, String, Single).)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLocale
Returns current locale, allowing access by subclasses.
(Inherited from QueryParser.)
Public method | GetLowercaseExpandedTerms | (Inherited from QueryParser.)
Public method | GetMultiTermRewriteMethod | (Inherited from QueryParser.)
Public method GetNextToken
Get the next Token.
(Inherited from QueryParser.)
Public method GetPhraseSlop
Gets the default slop for phrases.
(Inherited from QueryParser.)
Public method | GetPrefixQuery | (Overrides QueryParser..::..GetPrefixQuery(String, String).)
Public method | GetRangeCollator | (Inherited from QueryParser.)
Protected method | GetRangeQuery | (Overrides QueryParser..::..GetRangeQuery(String, String, String, Boolean).)
Public method GetToken
Get the specific Token.
(Inherited from QueryParser.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUseOldRangeQuery | Obsolete. (Inherited from QueryParser.)
Public method | GetWildcardQuery | (Overrides QueryParser..::..GetWildcardQuery(String, String).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Modifiers | (Inherited from QueryParser.)
Protected method NewBooleanClause
Builds a new BooleanClause instance
(Inherited from QueryParser.)
Protected method NewBooleanQuery
Builds a new BooleanQuery instance
(Inherited from QueryParser.)
Protected method NewFuzzyQuery
Builds a new FuzzyQuery instance
(Inherited from QueryParser.)
Protected method NewMatchAllDocsQuery
Builds a new MatchAllDocsQuery instance
(Inherited from QueryParser.)
Protected method NewMultiPhraseQuery
Builds a new MultiPhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPhraseQuery
Builds a new PhraseQuery instance
(Inherited from QueryParser.)
Protected method NewPrefixQuery
Builds a new PrefixQuery instance
(Inherited from QueryParser.)
Protected method NewRangeQuery
Builds a new TermRangeQuery instance
(Inherited from QueryParser.)
Protected method NewTermQuery
Builds a new TermQuery instance
(Inherited from QueryParser.)
Protected method NewWildcardQuery
Builds a new WildcardQuery instance
(Inherited from QueryParser.)
Public method Parse(String)
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
(Inherited from QueryParser.)
Parse(array<String>[]()[][], array<String>[]()[][], Analyzer) Obsolete.
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
Parse(String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer) Obsolete.
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query) +(contents:query) -(description:query)
Parse(array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer) Obsolete.
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query1) +(contents:query2) -(description:query3)
Parse(Version, array<String>[]()[][], array<String>[]()[][], Analyzer)
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
Parse(Version, String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse("query", fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query) +(contents:query) -(description:query)
            </code>
Parse(Version, array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] query = {"query1", "query2", "query3"};
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse(query, fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query1) +(contents:query2) -(description:query3)
            </code>
Public method | Query | (Inherited from QueryParser.)
Public method ReInit(CharStream)
Reinitialise.
(Inherited from QueryParser.)
Public method ReInit(QueryParserTokenManager)
Reinitialise.
(Inherited from QueryParser.)
Public method SetAllowLeadingWildcard
Set to
CopyC#
true
 to allow leading wildcard characters.

When set,

CopyC#
*
or
CopyC#
?
 are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes.

Default: false.

(Inherited from QueryParser.)
Public method SetDateResolution(DateTools..::..Resolution)
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
(Inherited from QueryParser.)
Public method SetDateResolution(String, DateTools..::..Resolution)
Sets the date resolution used by RangeQueries for a specific field.
(Inherited from QueryParser.)
Public method SetDefaultOperator
Sets the boolean operator of the QueryParser. In default mode (
CopyC#
OR_OPERATOR
) terms without any modifiers are considered optional: for example
CopyC#
capital of Hungary
 is equal to
CopyC#
capital OR of OR Hungary
.
In
CopyC#
AND_OPERATOR
 mode terms are considered to be in conjunction: the above mentioned query is parsed as
CopyC#
capital AND of AND Hungary
(Inherited from QueryParser.)
Public method SetEnablePositionIncrements
Set to
CopyC#
true
 to enable position increments in result query.

When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token.

Default: false.

(Inherited from QueryParser.)
Public method SetFuzzyMinSim
Set the minimum similarity for fuzzy queries. Default is 0.5f.
(Inherited from QueryParser.)
Public method SetFuzzyPrefixLength
Set the prefix length for fuzzy queries. Default is 0.
(Inherited from QueryParser.)
Public method SetLocale
Set locale used by date range parsing.
(Inherited from QueryParser.)
Public method SetLowercaseExpandedTerms
Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
CopyC#
true
.
(Inherited from QueryParser.)
Public method SetMultiTermRewriteMethod
By default QueryParser uses {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.
(Inherited from QueryParser.)
Public method SetPhraseSlop
Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
(Inherited from QueryParser.)
Public method SetRangeCollator
Sets the collator used to determine index term inclusion in ranges for RangeQuerys.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

(Inherited from QueryParser.)
Public method | SetUseOldRangeQuery | Obsolete. (Inherited from QueryParser.)
Public method | Term | (Inherited from QueryParser.)
Public method | TopLevelQuery | (Inherited from QueryParser.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


AddClause Method

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..AddClause Method
MultiFieldQueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddClause(ArrayList, Int32, Int32, Query) | Obsolete. (Inherited from QueryParser.)
Protected method | AddClause(IList, Int32, Int32, Query) | (Inherited from QueryParser.)

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetBooleanQuery Method
MultiFieldQueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetBooleanQuery(ArrayList) | Obsolete. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned. (Inherited from QueryParser.)
Protected method | GetBooleanQuery(IList) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned. (Inherited from QueryParser.)
Protected method | GetBooleanQuery(ArrayList, Boolean) | Obsolete. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned. (Inherited from QueryParser.)
Protected method | GetBooleanQuery(IList, Boolean) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned. (Inherited from QueryParser.)

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


GetFieldQuery Method

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetFieldQuery Method
MultiFieldQueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldQuery(String, String) | (Overrides QueryParser..::..GetFieldQuery(String, String).)
Protected method | GetFieldQuery(String, String, Int32) | (Overrides QueryParser..::..GetFieldQuery(String, String, Int32).)

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


GetFieldQuery Method (String, String)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetFieldQuery Method (String, String)
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetFieldQuery(
    string field,
    string queryText
)
Visual Basic
Public Overrides Function GetFieldQuery ( _
    field As String, _
    queryText As String _
) As Query
Visual C++
public:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String)"]

queryText
Type: System..::..String

[Missing <param name="queryText"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String)"]

See Also

MultiFieldQueryParser Class
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace


GetFieldQuery Method (String, String, Int32)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetFieldQuery Method (String, String, Int32)
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override Query GetFieldQuery(
    string field,
    string queryText,
    int slop
)
Visual Basic
Protected Friend Overrides Function GetFieldQuery ( _
    field As String, _
    queryText As String, _
    slop As Integer _
) As Query
Visual C++
protected public:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText,
    int slop
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

queryText
Type: System..::..String

[Missing <param name="queryText"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

slop
Type: System..::..Int32

[Missing <param name="slop"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

See Also

MultiFieldQueryParser Class
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace


GetFuzzyQuery Method

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetFuzzyQuery Method
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFuzzyQuery(System.String,System.String,System.Single)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetFuzzyQuery(
    string field,
    string termStr,
    float minSimilarity
)
Visual Basic
Public Overrides Function GetFuzzyQuery ( _
    field As String, _
    termStr As String, _
    minSimilarity As Single _
) As Query
Visual C++
public:
virtual Query^ GetFuzzyQuery(
    String^ field,
    String^ termStr,
    float minSimilarity
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFuzzyQuery(System.String,System.String,System.Single)"]

termStr
Type: System..::..String

[Missing <param name="termStr"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFuzzyQuery(System.String,System.String,System.Single)"]

minSimilarity
Type: System..::..Single

[Missing <param name="minSimilarity"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFuzzyQuery(System.String,System.String,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetFuzzyQuery(System.String,System.String,System.Single)"]

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


GetPrefixQuery Method

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetPrefixQuery Method
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetPrefixQuery(System.String,System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetPrefixQuery(
    string field,
    string termStr
)
Visual Basic
Public Overrides Function GetPrefixQuery ( _
    field As String, _
    termStr As String _
) As Query
Visual C++
public:
virtual Query^ GetPrefixQuery(
    String^ field,
    String^ termStr
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetPrefixQuery(System.String,System.String)"]

termStr
Type: System..::..String

[Missing <param name="termStr"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetPrefixQuery(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetPrefixQuery(System.String,System.String)"]

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


GetRangeQuery Method

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetRangeQuery Method
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override Query GetRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
Visual Basic
Protected Friend Overrides Function GetRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
Visual C++
protected public:
virtual Query^ GetRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

part1
Type: System..::..String

[Missing <param name="part1"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

part2
Type: System..::..String

[Missing <param name="part2"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

inclusive
Type: System..::..Boolean

[Missing <param name="inclusive"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


GetWildcardQuery Method

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..GetWildcardQuery Method
MultiFieldQueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetWildcardQuery(System.String,System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetWildcardQuery(
    string field,
    string termStr
)
Visual Basic
Public Overrides Function GetWildcardQuery ( _
    field As String, _
    termStr As String _
) As Query
Visual C++
public:
virtual Query^ GetWildcardQuery(
    String^ field,
    String^ termStr
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetWildcardQuery(System.String,System.String)"]

termStr
Type: System..::..String

[Missing <param name="termStr"/> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetWildcardQuery(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.GetWildcardQuery(System.String,System.String)"]

See Also

MultiFieldQueryParser Class
Lucene.Net.QueryParsers Namespace


Parse Method

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method
MultiFieldQueryParser Class See Also Send Feedback

Overload List

Name Description
Public method Parse(String)
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
(Inherited from QueryParser.)
Parse(array<String>[]()[][], array<String>[]()[][], Analyzer) Obsolete.
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
Parse(String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer) Obsolete.
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query) +(contents:query) -(description:query)
Parse(array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer) Obsolete.
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query1) +(contents:query2) -(description:query3)
Parse(Version, array<String>[]()[][], array<String>[]()[][], Analyzer)
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
Parse(Version, String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse("query", fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query) +(contents:query) -(description:query)
            </code>
Parse(Version, array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] query = {"query1", "query2", "query3"};
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse(query, fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query1) +(contents:query2) -(description:query3)
            </code>

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


Parse Method (String[], String[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method (array<String>[]()[][], array<String>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
if query parsing fails
if the length of the queries array differs from the length of the fields array

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Parse(Version,String[],String[],Analyzer) instead")]
public static Query Parse(
    string[] queries,
    string[] fields,
    Analyzer analyzer
)
Visual Basic
<ObsoleteAttribute("Use Parse(Version,String[],String[],Analyzer) instead")> _
Public Shared Function Parse ( _
    queries As String(), _
    fields As String(), _
    analyzer As Analyzer _
) As Query
Visual C++
[ObsoleteAttribute(L"Use Parse(Version,String[],String[],Analyzer) instead")]
public:
static Query^ Parse(
    array<String^>^ queries,
    array<String^>^ fields,
    Analyzer^ analyzer
)

Parameters

queries
Type: array< System..::..String >[]()[][]
Queries strings to parse
fields
Type: array< System..::..String >[]()[][]
Fields to search on
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
Analyzer to use

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.Parse(System.String[],System.String[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
Parse Overload
Lucene.Net.QueryParsers Namespace


Parse Method (String, String[], BooleanClause.Occur[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method (String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse("query", fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query) +(contents:query) -(description:query)
from the length of the flags array

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Parse(Version, String, String[], BooleanClause.Occur[], Analyzer) instead")]
public static Query Parse(
    string query,
    string[] fields,
    BooleanClause..::..Occur[] flags,
    Analyzer analyzer
)
Visual Basic
<ObsoleteAttribute("Use Parse(Version, String, String[], BooleanClause.Occur[], Analyzer) instead")> _
Public Shared Function Parse ( _
    query As String, _
    fields As String(), _
    flags As BooleanClause..::..Occur(), _
    analyzer As Analyzer _
) As Query
Visual C++
[ObsoleteAttribute(L"Use Parse(Version, String, String[], BooleanClause.Occur[], Analyzer) instead")]
public:
static Query^ Parse(
    String^ query,
    array<String^>^ fields,
    array<BooleanClause..::..Occur^>^ flags,
    Analyzer^ analyzer
)

Parameters

query
Type: System..::..String
Query string to parse
fields
Type: array< System..::..String >[]()[][]
Fields to search on
flags
Type: array< Lucene.Net.Search..::..BooleanClause..::..Occur >[]()[][]
Flags describing the fields
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
Analyzer to use

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.Parse(System.String,System.String[],Lucene.Net.Search.BooleanClause.Occur[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
Parse Overload
Lucene.Net.QueryParsers Namespace


Parse Method (String[], String[], BooleanClause.Occur[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method (array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:

  CopyC#
String[] query = {"query1", "query2", "query3"};
String[] fields = {"filename", "contents", "description"};
BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
BooleanClause.Occur.MUST,
BooleanClause.Occur.MUST_NOT};
MultiFieldQueryParser.parse(query, fields, flags, analyzer);

The code above would construct a query:

  CopyC#
(filename:query1) +(contents:query2) -(description:query3)
and flags array differ

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Parse(Version, String[], String[], BooleanClause.Occur[], Analyzer) instead")]
public static Query Parse(
    string[] queries,
    string[] fields,
    BooleanClause..::..Occur[] flags,
    Analyzer analyzer
)
Visual Basic
<ObsoleteAttribute("Use Parse(Version, String[], String[], BooleanClause.Occur[], Analyzer) instead")> _
Public Shared Function Parse ( _
    queries As String(), _
    fields As String(), _
    flags As BooleanClause..::..Occur(), _
    analyzer As Analyzer _
) As Query
Visual C++
[ObsoleteAttribute(L"Use Parse(Version, String[], String[], BooleanClause.Occur[], Analyzer) instead")]
public:
static Query^ Parse(
    array<String^>^ queries,
    array<String^>^ fields,
    array<BooleanClause..::..Occur^>^ flags,
    Analyzer^ analyzer
)

Parameters

queries
Type: array< System..::..String >[]()[][]
Queries string to parse
fields
Type: array< System..::..String >[]()[][]
Fields to search on
flags
Type: array< Lucene.Net.Search..::..BooleanClause..::..Occur >[]()[][]
Flags describing the fields
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
Analyzer to use

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.Parse(System.String[],System.String[],Lucene.Net.Search.BooleanClause.Occur[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
Parse Overload
Lucene.Net.QueryParsers Namespace


Parse Method (Version, String[], String[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method (Version, array<String>[]()[][], array<String>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Parses a query which searches on the fields specified.

If x fields are specified, this effectively constructs:

            <code>
            (field1:query1) (field2:query2) (field3:query3)...(fieldx:queryx)
            </code>
if query parsing fails
if the length of the queries array differs from the length of the fields array

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Query Parse(
    Version matchVersion,
    string[] queries,
    string[] fields,
    Analyzer analyzer
)
Visual Basic
Public Shared Function Parse ( _
    matchVersion As Version, _
    queries As String(), _
    fields As String(), _
    analyzer As Analyzer _
) As Query
Visual C++
public:
static Query^ Parse(
    Version^ matchVersion,
    array<String^>^ queries,
    array<String^>^ fields,
    Analyzer^ analyzer
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match; this is passed through to QueryParser.
queries
Type: array< System..::..String >[]()[][]
Queries strings to parse
fields
Type: array< System..::..String >[]()[][]
Fields to search on
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
Analyzer to use

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.Parse(Lucene.Net.Util.Version,System.String[],System.String[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
Parse Overload
Lucene.Net.QueryParsers Namespace


Parse Method (Version, String, String[], BooleanClause.Occur[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method (Version, String, array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse("query", fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query) +(contents:query) -(description:query)
            </code>
if query parsing fails
if the length of the fields array differs from the length of the flags array

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Query Parse(
    Version matchVersion,
    string query,
    string[] fields,
    BooleanClause..::..Occur[] flags,
    Analyzer analyzer
)
Visual Basic
Public Shared Function Parse ( _
    matchVersion As Version, _
    query As String, _
    fields As String(), _
    flags As BooleanClause..::..Occur(), _
    analyzer As Analyzer _
) As Query
Visual C++
public:
static Query^ Parse(
    Version^ matchVersion,
    String^ query,
    array<String^>^ fields,
    array<BooleanClause..::..Occur^>^ flags,
    Analyzer^ analyzer
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match; this is passed through to QueryParser.
query
Type: System..::..String
Query string to parse
fields
Type: array< System..::..String >[]()[][]
Fields to search on
flags
Type: array< Lucene.Net.Search..::..BooleanClause..::..Occur >[]()[][]
Flags describing the fields
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
Analyzer to use

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.Parse(Lucene.Net.Util.Version,System.String,System.String[],Lucene.Net.Search.BooleanClause.Occur[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
Parse Overload
Lucene.Net.QueryParsers Namespace


Parse Method (Version, String[], String[], BooleanClause.Occur[], Analyzer)

[image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..Parse Method (Version, array<String>[]()[][], array<String>[]()[][], array<BooleanClause..::..Occur>[]()[][], Analyzer)
MultiFieldQueryParser Class See Also Send Feedback
Parses a query, searching on the fields specified. Use this if you need to specify certain fields as required, and others as prohibited.

            Usage:
            <code>
            String[] query = {"query1", "query2", "query3"};
            String[] fields = {"filename", "contents", "description"};
            BooleanClause.Occur[] flags = {BooleanClause.Occur.SHOULD,
            BooleanClause.Occur.MUST,
            BooleanClause.Occur.MUST_NOT};
            MultiFieldQueryParser.parse(query, fields, flags, analyzer);
            </code>

The code above would construct a query:

            <code>
            (filename:query1) +(contents:query2) -(description:query3)
            </code>
if query parsing fails
if the length of the queries, fields, and flags array differ

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Query Parse(
    Version matchVersion,
    string[] queries,
    string[] fields,
    BooleanClause..::..Occur[] flags,
    Analyzer analyzer
)
Visual Basic
Public Shared Function Parse ( _
    matchVersion As Version, _
    queries As String(), _
    fields As String(), _
    flags As BooleanClause..::..Occur(), _
    analyzer As Analyzer _
) As Query
Visual C++
public:
static Query^ Parse(
    Version^ matchVersion,
    array<String^>^ queries,
    array<String^>^ fields,
    array<BooleanClause..::..Occur^>^ flags,
    Analyzer^ analyzer
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match; this is passed through to QueryParser.
queries
Type: array< System..::..String >[]()[][]
Queries string to parse
fields
Type: array< System..::..String >[]()[][]
Fields to search on
flags
Type: array< Lucene.Net.Search..::..BooleanClause..::..Occur >[]()[][]
Flags describing the fields
analyzer
Type: Lucene.Net.Analysis..::..Analyzer
Analyzer to use

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.MultiFieldQueryParser.Parse(Lucene.Net.Util.Version,System.String[],System.String[],Lucene.Net.Search.BooleanClause.Occur[],Lucene.Net.Analysis.Analyzer)"]

See Also

MultiFieldQueryParser Class
Parse Overload
Lucene.Net.QueryParsers Namespace


ReInit Method

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..ReInit Method
MultiFieldQueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReInit(CharStream) | Reinitialise. (Inherited from QueryParser.)
Public method | ReInit(QueryParserTokenManager) | Reinitialise. (Inherited from QueryParser.)

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


SetDateResolution Method

[image] [image]

Lucene.Net Class Libraries
MultiFieldQueryParser..::..SetDateResolution Method
MultiFieldQueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDateResolution(DateTools..::..Resolution) | Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}. (Inherited from QueryParser.)
Public method | SetDateResolution(String, DateTools..::..Resolution) | Sets the date resolution used by RangeQueries for a specific field. (Inherited from QueryParser.)

See Also

MultiFieldQueryParser Class
MultiFieldQueryParser Members
Lucene.Net.QueryParsers Namespace


ParseException Class

[image]

Lucene.Net Class Libraries
ParseException Class
Members See Also Send Feedback
This exception is thrown when parse errors are encountered. You can explicitly create objects of this exception type by calling the method generateParseException in the generated parser. You can modify this class to customize your error reporting mechanisms so long as you retain the public fields.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ParseException : Exception
Visual Basic
<SerializableAttribute> _
Public Class ParseException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ParseException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Lucene.Net.QueryParsers..::..ParseException

See Also

ParseException Members
Lucene.Net.QueryParsers Namespace


ParseException Members

[image] [image]

Lucene.Net Class Libraries
ParseException Members
ParseException Class Constructors Methods Fields Properties Events See Also Send Feedback

The ParseException type exposes the following members.

Constructors

 | Name | Description
Public method | ParseException()()()() | The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.
Public method | ParseException(String) | Constructor with message.
Public method | ParseException(String, Exception) | Constructor with message.
Public method | ParseException(Token, array<array<Int32>[]()[][]>[]()[][], array<String>[]()[][]) | This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

Methods

 | Name | Description
Protected method | Add_escapes | Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
Protected field | eol | The end of line string for this machine.
Public field | expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
Protected field | specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).
Public field | tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


ParseException Constructor

[image] [image]

Lucene.Net Class Libraries
ParseException Constructor
ParseException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseException()()()() | The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.
Public method | ParseException(String) | Constructor with message.
Public method | ParseException(String, Exception) | Constructor with message.
Public method | ParseException(Token, array<array<Int32>[]()[][]>[]()[][], array<String>[]()[][]) | This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

See Also

ParseException Class
ParseException Members
Lucene.Net.QueryParsers Namespace


ParseException Constructor

[image]

Lucene.Net Class Libraries
ParseException Constructor
ParseException Class See Also Send Feedback
The following constructors are for use by you for whatever purpose you can think of. Constructing the exception in this manner makes the exception behave in the normal way - i.e., as documented in the class "Throwable". The fields "errorToken", "expectedTokenSequences", and "tokenImage" do not contain relevant information. The JavaCC generated code does not use these constructors.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParseException()
Visual Basic
Public Sub New
Visual C++
public:
ParseException()

See Also

ParseException Class
ParseException Overload
Lucene.Net.QueryParsers Namespace


ParseException Constructor (String)

[image]

Lucene.Net Class Libraries
ParseException Constructor (String)
ParseException Class See Also Send Feedback
Constructor with message.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParseException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ParseException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.#ctor(System.String)"]

See Also

ParseException Class
ParseException Overload
Lucene.Net.QueryParsers Namespace


ParseException Constructor (String, Exception)

[image]

Lucene.Net Class Libraries
ParseException Constructor (String, Exception)
ParseException Class See Also Send Feedback
Constructor with message.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParseException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New ( _
    message As String, _
    ex As Exception _
)
Visual C++
public:
ParseException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.#ctor(System.String,System.Exception)"]

ex
Type: System..::..Exception

[Missing <param name="ex"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.#ctor(System.String,System.Exception)"]

See Also

ParseException Class
ParseException Overload
Lucene.Net.QueryParsers Namespace


ParseException Constructor (Token, Int32[][], String[])

[image]

Lucene.Net Class Libraries
ParseException Constructor (Token, array<array<Int32>[]()[][]>[]()[][], array<String>[]()[][])
ParseException Class See Also Send Feedback
This constructor is used by the method "generateParseException" in the generated parser. Calling this constructor generates a new object of this type with the fields "currentToken", "expectedTokenSequences", and "tokenImage" set. The boolean flag "specialConstructor" is also set to true to indicate that this constructor was used to create this object. This constructor calls its super class with the empty string to force the "toString" method of parent class "Throwable" to print the error message in the form: ParseException: <result of getMessage>

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParseException(
    Token currentTokenVal,
    int[][] expectedTokenSequencesVal,
    string[] tokenImageVal
)
Visual Basic
Public Sub New ( _
    currentTokenVal As Token, _
    expectedTokenSequencesVal As Integer()(), _
    tokenImageVal As String() _
)
Visual C++
public:
ParseException(
    Token^ currentTokenVal,
    array<array<int>^>^ expectedTokenSequencesVal,
    array<String^>^ tokenImageVal
)

Parameters

currentTokenVal
Type: Lucene.Net.QueryParsers..::..Token

[Missing <param name="currentTokenVal"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.#ctor(Lucene.Net.QueryParsers.Token,System.Int32[][],System.String[])"]

expectedTokenSequencesVal
Type: array<array< System..::..Int32 >[]()[][]>[]()[][]

[Missing <param name="expectedTokenSequencesVal"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.#ctor(Lucene.Net.QueryParsers.Token,System.Int32[][],System.String[])"]

tokenImageVal
Type: array< System..::..String >[]()[][]

[Missing <param name="tokenImageVal"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.#ctor(Lucene.Net.QueryParsers.Token,System.Int32[][],System.String[])"]

See Also

ParseException Class
ParseException Overload
Lucene.Net.QueryParsers Namespace


ParseException Fields

[image] [image]

Lucene.Net Class Libraries
ParseException Fields
ParseException Class See Also Send Feedback

The ParseException type exposes the following members.

Fields

 | Name | Description
Public field | currentToken | This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.
Protected field | eol | The end of line string for this machine.
Public field | expectedTokenSequences | Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.
Protected field | specialConstructor | This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).
Public field | tokenImage | This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


currentToken Field

[image]

Lucene.Net Class Libraries
ParseException..::..currentToken Field
ParseException Class See Also Send Feedback
This is the last token that has been consumed successfully. If this object has been created due to a parse error, the token followng this token will (therefore) be the first error token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token currentToken
Visual Basic
Public currentToken As Token
Visual C++
public:
Token^ currentToken

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


eol Field

[image]

Lucene.Net Class Libraries
ParseException..::..eol Field
ParseException Class See Also Send Feedback
The end of line string for this machine.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string eol
Visual Basic
Protected Friend eol As String
Visual C++
protected public:
String^ eol

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


expectedTokenSequences Field

[image]

Lucene.Net Class Libraries
ParseException..::..expectedTokenSequences Field
ParseException Class See Also Send Feedback
Each entry in this array is an array of integers. Each array of integers represents a sequence of tokens (by their ordinal values) that is expected at this point of the parse.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int[][] expectedTokenSequences
Visual Basic
Public expectedTokenSequences As Integer()()
Visual C++
public:
array<array<int>^>^ expectedTokenSequences

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


specialConstructor Field

[image]

Lucene.Net Class Libraries
ParseException..::..specialConstructor Field
ParseException Class See Also Send Feedback
This variable determines which constructor was used to create this object and thereby affects the semantics of the "getMessage" method (see below).

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool specialConstructor
Visual Basic
Protected Friend specialConstructor As Boolean
Visual C++
protected public:
bool specialConstructor

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


tokenImage Field

[image]

Lucene.Net Class Libraries
ParseException..::..tokenImage Field
ParseException Class See Also Send Feedback
This is a reference to the "tokenImage" array of the generated parser within which the parse error occurred. This array is defined in the generated ...Constants interface.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string[] tokenImage
Visual Basic
Public tokenImage As String()
Visual C++
public:
array<String^>^ tokenImage

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


ParseException Methods

[image] [image]

Lucene.Net Class Libraries
ParseException Methods
ParseException Class See Also Send Feedback

The ParseException type exposes the following members.

Methods

 | Name | Description
Protected method | Add_escapes | Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


Add_escapes Method

[image]

Lucene.Net Class Libraries
ParseException..::..Add_escapes Method
ParseException Class See Also Send Feedback
Used to convert raw characters to their escaped version when these raw version cannot be used as part of an ASCII string literal.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual string Add_escapes(
    string str
)
Visual Basic
Protected Friend Overridable Function Add_escapes ( _
    str As String _
) As String
Visual C++
protected public:
virtual String^ Add_escapes(
    String^ str
)

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Lucene.Net.QueryParsers.ParseException.Add_escapes(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.ParseException.Add_escapes(System.String)"]

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


ParseException Properties

[image] [image]

Lucene.Net Class Libraries
ParseException Properties
ParseException Class See Also Send Feedback

The ParseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


Message Property

[image]

Lucene.Net Class Libraries
ParseException..::..Message Property
ParseException Class See Also Send Feedback
This method has the standard behavior when this object has been created using the standard constructors. Otherwise, it uses "currentToken" and "expectedTokenSequences" to generate a parse error message and returns it. If this object has been created due to a parse error, and you do not catch it (it gets thrown from the parser), then this method is called during the printing of the final stack trace, and hence the correct error message gets displayed.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


ParseException Events

[image] [image]

Lucene.Net Class Libraries
ParseException Events
ParseException Class See Also Send Feedback

The ParseException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ParseException Class
Lucene.Net.QueryParsers Namespace


QueryParser Class

[image]

Lucene.Net Class Libraries
QueryParser Class
Members See Also Send Feedback
This class is generated by JavaCC. The most important method is {@link #Parse(String)}. The syntax for query strings is as follows: A Query is a series of clauses. A clause may be prefixed by:
  • a plus (
    CopyC#
    +
    ) or a minus (
    CopyC#
    -
    ) sign, indicating that the clause is required or prohibited respectively; or
  • a term followed by a colon, indicating the field to be searched. This enables one to construct queries which search multiple fields.
A clause may be either:
  • a term, indicating all the documents that contain this term; or
  • a nested query, enclosed in parentheses. Note that this may be used with a
    CopyC#
    +
    /
    CopyC#
    -
     prefix to require any of a set of terms.
Thus, in BNF, the query grammar is:
            Query  ::= ( Clause )*
            Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )

Examples of appropriately formatted queries can be found in the query syntax documentation.

In {@link TermRangeQuery}s, QueryParser tries to detect date values, e.g. date:[6/1/2005 TO 6/4/2005] produces a range query that searches for "date" fields between 2005-06-01 and 2005-06-04. Note that the format of the accepted input depends on {@link #SetLocale(Locale) the locale}. By default a date is converted into a search term using the deprecated {@link DateField} for compatibility reasons. To use the new {@link DateTools} to convert dates, a {@link Lucene.Net.Documents.DateTools.Resolution} has to be set.

The date resolution that shall be used for RangeQueries can be set using {@link #SetDateResolution(DateTools.Resolution)} or {@link #SetDateResolution(String, DateTools.Resolution)}. The former sets the default date resolution for all fields, whereas the latter can be used to set field specific date resolutions. Field specific date resolutions take, if set, precedence over the default date resolution.

If you use neither {@link DateField} nor {@link DateTools} in your index, you can create your own query parser that inherits QueryParser and overwrites {@link #GetRangeQuery(String, String, String, boolean)} to use a different method for date conversion.

Note that QueryParser is not thread-safe.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created. NOTE: You must specify the required {@link Version} compatibility when creating QueryParser:

  • As of 2.9, {@link #SetEnablePositionIncrements} is true by default.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class QueryParser : QueryParserConstants
Visual Basic
Public Class QueryParser _
    Inherits QueryParserConstants
Visual C++
public ref class QueryParser : public QueryParserConstants

Inheritance Hierarchy

System..::..Object
Lucene.Net.QueryParsers..::..QueryParserConstants
Lucene.Net.QueryParsers..::..QueryParser
Lucene.Net.QueryParsers..::..MultiFieldQueryParser

See Also

QueryParser Members
Lucene.Net.QueryParsers Namespace


QueryParser Members

[image] [image]

Lucene.Net Class Libraries
QueryParser Members
QueryParser Class Constructors Methods Fields See Also Send Feedback

The QueryParser type exposes the following members.

Constructors

 | Name | Description
Protected method | QueryParser(CharStream) | Constructor with user supplied CharStream.
Protected method | QueryParser(QueryParserTokenManager) | Constructor with generated Token Manager.
Public method | QueryParser(String, Analyzer) | Obsolete. Constructs a query parser.
Public method | QueryParser(Version, String, Analyzer) | Constructs a query parser.

Methods

Name | Description
Protected method | AddClause(ArrayList, Int32, Int32, Query) | Obsolete.
Protected method | AddClause(IList, Int32, Int32, Query)
Public method | Clause
Public method | Conjunction
Public method Disable_tracing
Disable tracing.
Public method Enable_tracing
Enable tracing.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Escape
Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding
CopyC#
\
.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GenerateParseException
Generate ParseException.
Public method | GetAllowLeadingWildcard
Public method | GetAnalyzer
Protected method GetBooleanQuery(ArrayList) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method GetBooleanQuery(IList)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method GetBooleanQuery(ArrayList, Boolean) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method GetBooleanQuery(IList, Boolean)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Public method GetDateResolution
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
Public method GetDefaultOperator
Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
Public method | GetEnablePositionIncrements
Public method | GetField
Public method | GetFieldQuery(String, String)
Protected method GetFieldQuery(String, String, Int32)
Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
Public method GetFuzzyMinSim
Get the minimal similarity for fuzzy queries.
Public method GetFuzzyPrefixLength
Get the prefix length for fuzzy queries.
Public method GetFuzzyQuery
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLocale
Returns current locale, allowing access by subclasses.
Public method | GetLowercaseExpandedTerms
Public method | GetMultiTermRewriteMethod
Public method GetNextToken
Get the next Token.
Public method GetPhraseSlop
Gets the default slop for phrases.
Public method GetPrefixQuery
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that uses prefix notation; that is, contains a single '*' wildcard character as its last character. Since this is a special case of generic wildcard term, and such a query can be optimized easily, this usually results in a different query object.

Depending on settings, a prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wild card queries, which may be necessary due to missing analyzer calls.

Public method | GetRangeCollator
Protected method | GetRangeQuery
Public method GetToken
Get the specific Token.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUseOldRangeQuery | Obsolete.
Public method GetWildcardQuery
Factory method for generating a query. Called when parser parses an input term token that contains one or more wildcard characters (? and *), but is not a prefix term token (one that has just a single * character at the end)

Depending on settings, prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wildcard queries, which may be necessary due to missing analyzer calls.

Main
Command line tool to test QueryParser, using {@link Lucene.Net.Analysis.SimpleAnalyzer}. Usage:
CopyC#
java Lucene.Net.QueryParsers.QueryParser <input>
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Modifiers
Protected method NewBooleanClause
Builds a new BooleanClause instance
Protected method NewBooleanQuery
Builds a new BooleanQuery instance
Protected method NewFuzzyQuery
Builds a new FuzzyQuery instance
Protected method NewMatchAllDocsQuery
Builds a new MatchAllDocsQuery instance
Protected method NewMultiPhraseQuery
Builds a new MultiPhraseQuery instance
Protected method NewPhraseQuery
Builds a new PhraseQuery instance
Protected method NewPrefixQuery
Builds a new PrefixQuery instance
Protected method NewRangeQuery
Builds a new TermRangeQuery instance
Protected method NewTermQuery
Builds a new TermQuery instance
Protected method NewWildcardQuery
Builds a new WildcardQuery instance
Public method Parse
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Public method | Query
Public method ReInit(CharStream)
Reinitialise.
Public method ReInit(QueryParserTokenManager)
Reinitialise.
Public method SetAllowLeadingWildcard
Set to
CopyC#
true
 to allow leading wildcard characters.

When set,

CopyC#
*
or
CopyC#
?
 are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes.

Default: false.

Public method SetDateResolution(DateTools..::..Resolution)
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
Public method SetDateResolution(String, DateTools..::..Resolution)
Sets the date resolution used by RangeQueries for a specific field.
Public method SetDefaultOperator
Sets the boolean operator of the QueryParser. In default mode (
CopyC#
OR_OPERATOR
) terms without any modifiers are considered optional: for example
CopyC#
capital of Hungary
 is equal to
CopyC#
capital OR of OR Hungary
.
In
CopyC#
AND_OPERATOR
 mode terms are considered to be in conjunction: the above mentioned query is parsed as
CopyC#
capital AND of AND Hungary
Public method SetEnablePositionIncrements
Set to
CopyC#
true
 to enable position increments in result query.

When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token.

Default: false.

Public method SetFuzzyMinSim
Set the minimum similarity for fuzzy queries. Default is 0.5f.
Public method SetFuzzyPrefixLength
Set the prefix length for fuzzy queries. Default is 0.
Public method SetLocale
Set locale used by date range parsing.
Public method SetLowercaseExpandedTerms
Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
CopyC#
true
.
Public method SetMultiTermRewriteMethod
By default QueryParser uses {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.
Public method SetPhraseSlop
Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Public method SetRangeCollator
Sets the collator used to determine index term inclusion in ranges for RangeQuerys.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Public method | SetUseOldRangeQuery | Obsolete.
Public method | Term
Public method | TopLevelQuery
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
 | AND_OPERATOR | Alternative form of QueryParser.Operator.AND
 | OR_OPERATOR | Alternative form of QueryParser.Operator.OR
Public field | token | Current token.
Public field | token_source | Generated Token Manager.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


QueryParser Constructor

[image] [image]

Lucene.Net Class Libraries
QueryParser Constructor
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryParser(CharStream) | Constructor with user supplied CharStream.
Protected method | QueryParser(QueryParserTokenManager) | Constructor with generated Token Manager.
Public method | QueryParser(String, Analyzer) | Obsolete. Constructs a query parser.
Public method | QueryParser(Version, String, Analyzer) | Constructs a query parser.

See Also

QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace


QueryParser Constructor (CharStream)

[image]

Lucene.Net Class Libraries
QueryParser Constructor (CharStream)
QueryParser Class See Also Send Feedback
Constructor with user supplied CharStream.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal QueryParser(
    CharStream stream
)
Visual Basic
Protected Friend Sub New ( _
    stream As CharStream _
)
Visual C++
protected public:
QueryParser(
    CharStream^ stream
)

Parameters

stream
Type: Lucene.Net.QueryParsers..::..CharStream

[Missing <param name="stream"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.#ctor(Lucene.Net.QueryParsers.CharStream)"]

See Also

QueryParser Class
QueryParser Overload
Lucene.Net.QueryParsers Namespace


QueryParser Constructor (QueryParserTokenManager)

[image]

Lucene.Net Class Libraries
QueryParser Constructor (QueryParserTokenManager)
QueryParser Class See Also Send Feedback
Constructor with generated Token Manager.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal QueryParser(
    QueryParserTokenManager tm
)
Visual Basic
Protected Friend Sub New ( _
    tm As QueryParserTokenManager _
)
Visual C++
protected public:
QueryParser(
    QueryParserTokenManager^ tm
)

Parameters

tm
Type: Lucene.Net.QueryParsers..::..QueryParserTokenManager

[Missing <param name="tm"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.#ctor(Lucene.Net.QueryParsers.QueryParserTokenManager)"]

See Also

QueryParser Class
QueryParser Overload
Lucene.Net.QueryParsers Namespace


QueryParser Constructor (String, Analyzer)

[image]

Lucene.Net Class Libraries
QueryParser Constructor (String, Analyzer)
QueryParser Class See Also Send Feedback
Constructs a query parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use QueryParser(Version, String, Analyzer) instead")]
public QueryParser(
    string f,
    Analyzer a
)
Visual Basic
<ObsoleteAttribute("Use QueryParser(Version, String, Analyzer) instead")> _
Public Sub New ( _
    f As String, _
    a As Analyzer _
)
Visual C++
[ObsoleteAttribute(L"Use QueryParser(Version, String, Analyzer) instead")]
public:
QueryParser(
    String^ f,
    Analyzer^ a
)

Parameters

f
Type: System..::..String
the default field for query terms.
a
Type: Lucene.Net.Analysis..::..Analyzer
used to find terms in the query text.

See Also

QueryParser Class
QueryParser Overload
Lucene.Net.QueryParsers Namespace


QueryParser Constructor (Version, String, Analyzer)

[image]

Lucene.Net Class Libraries
QueryParser Constructor (Version, String, Analyzer)
QueryParser Class See Also Send Feedback
Constructs a query parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryParser(
    Version matchVersion,
    string f,
    Analyzer a
)
Visual Basic
Public Sub New ( _
    matchVersion As Version, _
    f As String, _
    a As Analyzer _
)
Visual C++
public:
QueryParser(
    Version^ matchVersion,
    String^ f,
    Analyzer^ a
)

Parameters

matchVersion
Type: Lucene.Net.Util..::..Version
Lucene version to match. See above)
f
Type: System..::..String
the default field for query terms.
a
Type: Lucene.Net.Analysis..::..Analyzer
used to find terms in the query text.

See Also

QueryParser Class
QueryParser Overload
Lucene.Net.QueryParsers Namespace


QueryParser Fields

[image] [image]

Lucene.Net Class Libraries
QueryParser Fields
QueryParser Class See Also Send Feedback

The QueryParser type exposes the following members.

Fields

 | Name | Description
 | AND_OPERATOR | Alternative form of QueryParser.Operator.AND
 | OR_OPERATOR | Alternative form of QueryParser.Operator.OR
Public field | token | Current token.
Public field | token_source | Generated Token Manager.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


AND_OPERATOR Field

[image]

Lucene.Net Class Libraries
QueryParser..::..AND_OPERATOR Field
QueryParser Class See Also Send Feedback
Alternative form of QueryParser.Operator.AND

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly QueryParser..::..Operator AND_OPERATOR
Visual Basic
Public Shared ReadOnly AND_OPERATOR As QueryParser..::..Operator
Visual C++
public:
static initonly QueryParser..::..Operator^ AND_OPERATOR

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


OR_OPERATOR Field

[image]

Lucene.Net Class Libraries
QueryParser..::..OR_OPERATOR Field
QueryParser Class See Also Send Feedback
Alternative form of QueryParser.Operator.OR

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly QueryParser..::..Operator OR_OPERATOR
Visual Basic
Public Shared ReadOnly OR_OPERATOR As QueryParser..::..Operator
Visual C++
public:
static initonly QueryParser..::..Operator^ OR_OPERATOR

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


token Field

[image]

Lucene.Net Class Libraries
QueryParser..::..token Field
QueryParser Class See Also Send Feedback
Current token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token token
Visual Basic
Public token As Token
Visual C++
public:
Token^ token

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


token_source Field

[image]

Lucene.Net Class Libraries
QueryParser..::..token_source Field
QueryParser Class See Also Send Feedback
Generated Token Manager.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryParserTokenManager token_source
Visual Basic
Public token_source As QueryParserTokenManager
Visual C++
public:
QueryParserTokenManager^ token_source

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


QueryParser Methods

[image] [image]

Lucene.Net Class Libraries
QueryParser Methods
QueryParser Class See Also Send Feedback

The QueryParser type exposes the following members.

Methods

Name | Description
Protected method | AddClause(ArrayList, Int32, Int32, Query) | Obsolete.
Protected method | AddClause(IList, Int32, Int32, Query)
Public method | Clause
Public method | Conjunction
Public method Disable_tracing
Disable tracing.
Public method Enable_tracing
Enable tracing.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Escape
Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding
CopyC#
\
.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GenerateParseException
Generate ParseException.
Public method | GetAllowLeadingWildcard
Public method | GetAnalyzer
Protected method GetBooleanQuery(ArrayList) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method GetBooleanQuery(IList)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method GetBooleanQuery(ArrayList, Boolean) Obsolete.
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method GetBooleanQuery(IList, Boolean)
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Public method GetDateResolution
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.
Public method GetDefaultOperator
Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.
Public method | GetEnablePositionIncrements
Public method | GetField
Public method | GetFieldQuery(String, String)
Protected method GetFieldQuery(String, String, Int32)
Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.
Public method GetFuzzyMinSim
Get the minimal similarity for fuzzy queries.
Public method GetFuzzyPrefixLength
Get the prefix length for fuzzy queries.
Public method GetFuzzyQuery
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLocale
Returns current locale, allowing access by subclasses.
Public method | GetLowercaseExpandedTerms
Public method | GetMultiTermRewriteMethod
Public method GetNextToken
Get the next Token.
Public method GetPhraseSlop
Gets the default slop for phrases.
Public method GetPrefixQuery
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that uses prefix notation; that is, contains a single '*' wildcard character as its last character. Since this is a special case of generic wildcard term, and such a query can be optimized easily, this usually results in a different query object.

Depending on settings, a prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wild card queries, which may be necessary due to missing analyzer calls.

Public method | GetRangeCollator
Protected method | GetRangeQuery
Public method GetToken
Get the specific Token.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetUseOldRangeQuery | Obsolete.
Public method GetWildcardQuery
Factory method for generating a query. Called when parser parses an input term token that contains one or more wildcard characters (? and *), but is not a prefix term token (one that has just a single * character at the end)

Depending on settings, prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wildcard queries, which may be necessary due to missing analyzer calls.

Main
Command line tool to test QueryParser, using {@link Lucene.Net.Analysis.SimpleAnalyzer}. Usage:
CopyC#
java Lucene.Net.QueryParsers.QueryParser <input>
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Modifiers
Protected method NewBooleanClause
Builds a new BooleanClause instance
Protected method NewBooleanQuery
Builds a new BooleanQuery instance
Protected method NewFuzzyQuery
Builds a new FuzzyQuery instance
Protected method NewMatchAllDocsQuery
Builds a new MatchAllDocsQuery instance
Protected method NewMultiPhraseQuery
Builds a new MultiPhraseQuery instance
Protected method NewPhraseQuery
Builds a new PhraseQuery instance
Protected method NewPrefixQuery
Builds a new PrefixQuery instance
Protected method NewRangeQuery
Builds a new TermRangeQuery instance
Protected method NewTermQuery
Builds a new TermQuery instance
Protected method NewWildcardQuery
Builds a new WildcardQuery instance
Public method Parse
Parses a query string, returning a {@link Lucene.Net.Search.Query}.
Public method | Query
Public method ReInit(CharStream)
Reinitialise.
Public method ReInit(QueryParserTokenManager)
Reinitialise.
Public method SetAllowLeadingWildcard
Set to
CopyC#
true
 to allow leading wildcard characters.

When set,

CopyC#
*
or
CopyC#
?
 are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes.

Default: false.

Public method SetDateResolution(DateTools..::..Resolution)
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
Public method SetDateResolution(String, DateTools..::..Resolution)
Sets the date resolution used by RangeQueries for a specific field.
Public method SetDefaultOperator
Sets the boolean operator of the QueryParser. In default mode (
CopyC#
OR_OPERATOR
) terms without any modifiers are considered optional: for example
CopyC#
capital of Hungary
 is equal to
CopyC#
capital OR of OR Hungary
.
In
CopyC#
AND_OPERATOR
 mode terms are considered to be in conjunction: the above mentioned query is parsed as
CopyC#
capital AND of AND Hungary
Public method SetEnablePositionIncrements
Set to
CopyC#
true
 to enable position increments in result query.

When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token.

Default: false.

Public method SetFuzzyMinSim
Set the minimum similarity for fuzzy queries. Default is 0.5f.
Public method SetFuzzyPrefixLength
Set the prefix length for fuzzy queries. Default is 0.
Public method SetLocale
Set locale used by date range parsing.
Public method SetLowercaseExpandedTerms
Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
CopyC#
true
.
Public method SetMultiTermRewriteMethod
By default QueryParser uses {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.
Public method SetPhraseSlop
Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.
Public method SetRangeCollator
Sets the collator used to determine index term inclusion in ranges for RangeQuerys.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Public method | SetUseOldRangeQuery | Obsolete.
Public method | Term
Public method | TopLevelQuery
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


AddClause Method

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..AddClause Method
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddClause(ArrayList, Int32, Int32, Query) | Obsolete.
Protected method | AddClause(IList, Int32, Int32, Query) |

See Also

QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace


AddClause Method (ArrayList, Int32, Int32, Query)

[image]

Lucene.Net Class Libraries
QueryParser..::..AddClause Method (ArrayList, Int32, Int32, Query)
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.ArrayList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use AddClause(List, int, int, Query) instead.")]
protected internal virtual void AddClause(
    ArrayList clauses,
    int conj,
    int mods,
    Query q
)
Visual Basic
<ObsoleteAttribute("use AddClause(List, int, int, Query) instead.")> _
Protected Friend Overridable Sub AddClause ( _
    clauses As ArrayList, _
    conj As Integer, _
    mods As Integer, _
    q As Query _
)
Visual C++
[ObsoleteAttribute(L"use AddClause(List, int, int, Query) instead.")]
protected public:
virtual void AddClause(
    ArrayList^ clauses,
    int conj,
    int mods,
    Query^ q
)

Parameters

clauses
Type: System.Collections..::..ArrayList

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.ArrayList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

conj
Type: System..::..Int32

[Missing <param name="conj"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.ArrayList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

mods
Type: System..::..Int32

[Missing <param name="mods"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.ArrayList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

q
Type: Lucene.Net.Search..::..Query

[Missing <param name="q"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.ArrayList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

See Also

QueryParser Class
AddClause Overload
Lucene.Net.QueryParsers Namespace


AddClause Method (IList, Int32, Int32, Query)

[image]

Lucene.Net Class Libraries
QueryParser..::..AddClause Method (IList, Int32, Int32, Query)
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.IList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void AddClause(
    IList clauses,
    int conj,
    int mods,
    Query q
)
Visual Basic
Protected Friend Overridable Sub AddClause ( _
    clauses As IList, _
    conj As Integer, _
    mods As Integer, _
    q As Query _
)
Visual C++
protected public:
virtual void AddClause(
    IList^ clauses,
    int conj,
    int mods,
    Query^ q
)

Parameters

clauses
Type: System.Collections..::..IList

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.IList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

conj
Type: System..::..Int32

[Missing <param name="conj"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.IList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

mods
Type: System..::..Int32

[Missing <param name="mods"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.IList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

q
Type: Lucene.Net.Search..::..Query

[Missing <param name="q"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.AddClause(System.Collections.IList,System.Int32,System.Int32,Lucene.Net.Search.Query)"]

See Also

QueryParser Class
AddClause Overload
Lucene.Net.QueryParsers Namespace


Clause Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Clause Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Clause(System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Query Clause(
    string field
)
Visual Basic
Public Function Clause ( _
    field As String _
) As Query
Visual C++
public:
Query^ Clause(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Clause(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Clause(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Conjunction Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Conjunction Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Conjunction"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Conjunction()
Visual Basic
Public Function Conjunction As Integer
Visual C++
public:
int Conjunction()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Conjunction"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Disable_tracing Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Disable_tracing Method
QueryParser Class See Also Send Feedback
Disable tracing.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Disable_tracing()
Visual Basic
Public Sub Disable_tracing
Visual C++
public:
void Disable_tracing()

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Enable_tracing Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Enable_tracing Method
QueryParser Class See Also Send Feedback
Enable tracing.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Enable_tracing()
Visual Basic
Public Sub Enable_tracing
Visual C++
public:
void Enable_tracing()

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Escape Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Escape Method
QueryParser Class See Also Send Feedback
Returns a String where those characters that QueryParser expects to be escaped are escaped by a preceding
CopyC#
\
.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string Escape(
    string s
)
Visual Basic
Public Shared Function Escape ( _
    s As String _
) As String
Visual C++
public:
static String^ Escape(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Escape(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Escape(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GenerateParseException Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GenerateParseException Method
QueryParser Class See Also Send Feedback
Generate ParseException.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual ParseException GenerateParseException()
Visual Basic
Public Overridable Function GenerateParseException As ParseException
Visual C++
public:
virtual ParseException^ GenerateParseException()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GenerateParseException"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetAllowLeadingWildcard Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetAllowLeadingWildcard Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetAllowLeadingWildcard"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetAllowLeadingWildcard()
Visual Basic
Public Overridable Function GetAllowLeadingWildcard As Boolean
Visual C++
public:
virtual bool GetAllowLeadingWildcard()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetAllowLeadingWildcard"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace
[!:SetAllowLeadingWildcard(boolean)]


GetAnalyzer Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetAnalyzer Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetAnalyzer"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Analyzer GetAnalyzer()
Visual Basic
Public Overridable Function GetAnalyzer As Analyzer
Visual C++
public:
virtual Analyzer^ GetAnalyzer()

Return Value

Returns the analyzer.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..GetBooleanQuery Method
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetBooleanQuery(ArrayList) | Obsolete. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method | GetBooleanQuery(IList) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method | GetBooleanQuery(ArrayList, Boolean) | Obsolete. Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.
Protected method | GetBooleanQuery(IList, Boolean) | Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

See Also

QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method (ArrayList)

[image]

Lucene.Net Class Libraries
QueryParser..::..GetBooleanQuery Method (ArrayList)
QueryParser Class See Also Send Feedback
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use GetBooleanQuery(List) instead")]
protected internal virtual Query GetBooleanQuery(
    ArrayList clauses
)
Visual Basic
<ObsoleteAttribute("use GetBooleanQuery(List) instead")> _
Protected Friend Overridable Function GetBooleanQuery ( _
    clauses As ArrayList _
) As Query
Visual C++
[ObsoleteAttribute(L"use GetBooleanQuery(List) instead")]
protected public:
virtual Query^ GetBooleanQuery(
    ArrayList^ clauses
)

Parameters

clauses
Type: System.Collections..::..ArrayList
List that contains {@link BooleanClause} instances to join.

Return Value

Resulting {@link Query} object.

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
GetBooleanQuery Overload
Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method (IList)

[image]

Lucene.Net Class Libraries
QueryParser..::..GetBooleanQuery Method (IList)
QueryParser Class See Also Send Feedback
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query GetBooleanQuery(
    IList clauses
)
Visual Basic
Protected Friend Overridable Function GetBooleanQuery ( _
    clauses As IList _
) As Query
Visual C++
protected public:
virtual Query^ GetBooleanQuery(
    IList^ clauses
)

Parameters

clauses
Type: System.Collections..::..IList
List that contains {@link BooleanClause} instances to join.

Return Value

Resulting {@link Query} object.

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
GetBooleanQuery Overload
Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method (ArrayList, Boolean)

[image]

Lucene.Net Class Libraries
QueryParser..::..GetBooleanQuery Method (ArrayList, Boolean)
QueryParser Class See Also Send Feedback
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use GetBooleanQuery(List, bool) instead")]
protected internal virtual Query GetBooleanQuery(
    ArrayList clauses,
    bool disableCoord
)
Visual Basic
<ObsoleteAttribute("use GetBooleanQuery(List, bool) instead")> _
Protected Friend Overridable Function GetBooleanQuery ( _
    clauses As ArrayList, _
    disableCoord As Boolean _
) As Query
Visual C++
[ObsoleteAttribute(L"use GetBooleanQuery(List, bool) instead")]
protected public:
virtual Query^ GetBooleanQuery(
    ArrayList^ clauses,
    bool disableCoord
)

Parameters

clauses
Type: System.Collections..::..ArrayList
List that contains {@link BooleanClause} instances to join.
disableCoord
Type: System..::..Boolean
true if coord scoring should be disabled.

Return Value

Resulting {@link Query} object.

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
GetBooleanQuery Overload
Lucene.Net.QueryParsers Namespace


GetBooleanQuery Method (IList, Boolean)

[image]

Lucene.Net Class Libraries
QueryParser..::..GetBooleanQuery Method (IList, Boolean)
QueryParser Class See Also Send Feedback
Factory method for generating query, given a set of clauses. By default creates a boolean query composed of clauses passed in. Can be overridden by extending classes, to modify query being returned.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query GetBooleanQuery(
    IList clauses,
    bool disableCoord
)
Visual Basic
Protected Friend Overridable Function GetBooleanQuery ( _
    clauses As IList, _
    disableCoord As Boolean _
) As Query
Visual C++
protected public:
virtual Query^ GetBooleanQuery(
    IList^ clauses,
    bool disableCoord
)

Parameters

clauses
Type: System.Collections..::..IList
List that contains {@link BooleanClause} instances to join.
disableCoord
Type: System..::..Boolean
true if coord scoring should be disabled.

Return Value

Resulting {@link Query} object.

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
GetBooleanQuery Overload
Lucene.Net.QueryParsers Namespace


GetDateResolution Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetDateResolution Method
QueryParser Class See Also Send Feedback
Returns the date resolution that is used by RangeQueries for the given field. Returns null, if no default or field specific date resolution has been set for the given field.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual DateTools..::..Resolution GetDateResolution(
    string fieldName
)
Visual Basic
Public Overridable Function GetDateResolution ( _
    fieldName As String _
) As DateTools..::..Resolution
Visual C++
public:
virtual DateTools..::..Resolution^ GetDateResolution(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetDateResolution(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetDateResolution(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetDefaultOperator Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetDefaultOperator Method
QueryParser Class See Also Send Feedback
Gets implicit operator setting, which will be either AND_OPERATOR or OR_OPERATOR.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual QueryParser..::..Operator GetDefaultOperator()
Visual Basic
Public Overridable Function GetDefaultOperator As QueryParser..::..Operator
Visual C++
public:
virtual QueryParser..::..Operator^ GetDefaultOperator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetDefaultOperator"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetEnablePositionIncrements Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetEnablePositionIncrements Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetEnablePositionIncrements"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetEnablePositionIncrements()
Visual Basic
Public Overridable Function GetEnablePositionIncrements As Boolean
Visual C++
public:
virtual bool GetEnablePositionIncrements()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetEnablePositionIncrements"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace
[!:SetEnablePositionIncrements(boolean)]


GetField Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetField Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetField"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

Returns the field.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetFieldQuery Method

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..GetFieldQuery Method
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldQuery(String, String) |
Protected method | GetFieldQuery(String, String, Int32) | Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

See Also

QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace


GetFieldQuery Method (String, String)

[image]

Lucene.Net Class Libraries
QueryParser..::..GetFieldQuery Method (String, String)
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query GetFieldQuery(
    string field,
    string queryText
)
Visual Basic
Public Overridable Function GetFieldQuery ( _
    field As String, _
    queryText As String _
) As Query
Visual C++
public:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String)"]

queryText
Type: System..::..String

[Missing <param name="queryText"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String)"]

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace


GetFieldQuery Method (String, String, Int32)

[image]

Lucene.Net Class Libraries
QueryParser..::..GetFieldQuery Method (String, String, Int32)
QueryParser Class See Also Send Feedback
Base implementation delegates to {@link #GetFieldQuery(String,String)}. This method may be overridden, for example, to return a SpanNearQuery instead of a PhraseQuery.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query GetFieldQuery(
    string field,
    string queryText,
    int slop
)
Visual Basic
Protected Friend Overridable Function GetFieldQuery ( _
    field As String, _
    queryText As String, _
    slop As Integer _
) As Query
Visual C++
protected public:
virtual Query^ GetFieldQuery(
    String^ field,
    String^ queryText,
    int slop
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

queryText
Type: System..::..String

[Missing <param name="queryText"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

slop
Type: System..::..Int32

[Missing <param name="slop"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFieldQuery(System.String,System.String,System.Int32)"]

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
GetFieldQuery Overload
Lucene.Net.QueryParsers Namespace


GetFuzzyMinSim Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetFuzzyMinSim Method
QueryParser Class See Also Send Feedback
Get the minimal similarity for fuzzy queries.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetFuzzyMinSim()
Visual Basic
Public Overridable Function GetFuzzyMinSim As Single
Visual C++
public:
virtual float GetFuzzyMinSim()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFuzzyMinSim"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetFuzzyPrefixLength Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetFuzzyPrefixLength Method
QueryParser Class See Also Send Feedback
Get the prefix length for fuzzy queries.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetFuzzyPrefixLength()
Visual Basic
Public Overridable Function GetFuzzyPrefixLength As Integer
Visual C++
public:
virtual int GetFuzzyPrefixLength()

Return Value

Returns the fuzzyPrefixLength.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetFuzzyQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetFuzzyQuery Method
QueryParser Class See Also Send Feedback
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that has the fuzzy suffix (~) appended.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query GetFuzzyQuery(
    string field,
    string termStr,
    float minSimilarity
)
Visual Basic
Public Overridable Function GetFuzzyQuery ( _
    field As String, _
    termStr As String, _
    minSimilarity As Single _
) As Query
Visual C++
public:
virtual Query^ GetFuzzyQuery(
    String^ field,
    String^ termStr,
    float minSimilarity
)

Parameters

field
Type: System..::..String
Name of the field query will use.
termStr
Type: System..::..String
Term token to use for building term for the query
minSimilarity
Type: System..::..Single

[Missing <param name="minSimilarity"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetFuzzyQuery(System.String,System.String,System.Single)"]

Return Value

Resulting {@link Query} built for the term

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetLocale Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetLocale Method
QueryParser Class See Also Send Feedback
Returns current locale, allowing access by subclasses.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CultureInfo GetLocale()
Visual Basic
Public Overridable Function GetLocale As CultureInfo
Visual C++
public:
virtual CultureInfo^ GetLocale()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetLocale"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetLowercaseExpandedTerms Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetLowercaseExpandedTerms Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetLowercaseExpandedTerms"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetLowercaseExpandedTerms()
Visual Basic
Public Overridable Function GetLowercaseExpandedTerms As Boolean
Visual C++
public:
virtual bool GetLowercaseExpandedTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetLowercaseExpandedTerms"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace
[!:SetLowercaseExpandedTerms(boolean)]


GetMultiTermRewriteMethod Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetMultiTermRewriteMethod Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetMultiTermRewriteMethod"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual MultiTermQuery..::..RewriteMethod GetMultiTermRewriteMethod()
Visual Basic
Public Overridable Function GetMultiTermRewriteMethod As MultiTermQuery..::..RewriteMethod
Visual C++
public:
virtual MultiTermQuery..::..RewriteMethod^ GetMultiTermRewriteMethod()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetMultiTermRewriteMethod"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace
[!:setMultiTermRewriteMethod]


GetNextToken Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetNextToken Method
QueryParser Class See Also Send Feedback
Get the next Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token GetNextToken()
Visual Basic
Public Function GetNextToken As Token
Visual C++
public:
Token^ GetNextToken()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetNextToken"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetPhraseSlop Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetPhraseSlop Method
QueryParser Class See Also Send Feedback
Gets the default slop for phrases.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPhraseSlop()
Visual Basic
Public Overridable Function GetPhraseSlop As Integer
Visual C++
public:
virtual int GetPhraseSlop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetPhraseSlop"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetPrefixQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetPrefixQuery Method
QueryParser Class See Also Send Feedback
Factory method for generating a query (similar to {@link #getWildcardQuery}). Called when parser parses an input term token that uses prefix notation; that is, contains a single '*' wildcard character as its last character. Since this is a special case of generic wildcard term, and such a query can be optimized easily, this usually results in a different query object.

Depending on settings, a prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wild card queries, which may be necessary due to missing analyzer calls.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query GetPrefixQuery(
    string field,
    string termStr
)
Visual Basic
Public Overridable Function GetPrefixQuery ( _
    field As String, _
    termStr As String _
) As Query
Visual C++
public:
virtual Query^ GetPrefixQuery(
    String^ field,
    String^ termStr
)

Parameters

field
Type: System..::..String
Name of the field query will use.
termStr
Type: System..::..String
Term token to use for building term for the query (without trailing '*' character!)

Return Value

Resulting {@link Query} built for the term

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetRangeCollator Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetRangeCollator Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeCollator"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CompareInfo GetRangeCollator()
Visual Basic
Public Overridable Function GetRangeCollator As CompareInfo
Visual C++
public:
virtual CompareInfo^ GetRangeCollator()

Return Value

the collator used to determine index term inclusion in ranges for RangeQuerys.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetRangeQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetRangeQuery Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query GetRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
Visual Basic
Protected Friend Overridable Function GetRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
Visual C++
protected public:
virtual Query^ GetRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

part1
Type: System..::..String

[Missing <param name="part1"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

part2
Type: System..::..String

[Missing <param name="part2"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

inclusive
Type: System..::..Boolean

[Missing <param name="inclusive"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetRangeQuery(System.String,System.String,System.String,System.Boolean)"]

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetToken Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetToken Method
QueryParser Class See Also Send Feedback
Get the specific Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token GetToken(
    int index
)
Visual Basic
Public Function GetToken ( _
    index As Integer _
) As Token
Visual C++
public:
Token^ GetToken(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetToken(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetToken(System.Int32)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetUseOldRangeQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetUseOldRangeQuery Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetUseOldRangeQuery"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use GetMultiTermRewriteMethod} instead.")]
public virtual bool GetUseOldRangeQuery()
Visual Basic
<ObsoleteAttribute("Please use GetMultiTermRewriteMethod} instead.")> _
Public Overridable Function GetUseOldRangeQuery As Boolean
Visual C++
[ObsoleteAttribute(L"Please use GetMultiTermRewriteMethod} instead.")]
public:
virtual bool GetUseOldRangeQuery()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.GetUseOldRangeQuery"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


GetWildcardQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..GetWildcardQuery Method
QueryParser Class See Also Send Feedback
Factory method for generating a query. Called when parser parses an input term token that contains one or more wildcard characters (? and *), but is not a prefix term token (one that has just a single * character at the end)

Depending on settings, prefix term may be lower-cased automatically. It will not go through the default Analyzer, however, since normal Analyzers are unlikely to work properly with wildcard templates.

Can be overridden by extending classes, to provide custom handling for wildcard queries, which may be necessary due to missing analyzer calls.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query GetWildcardQuery(
    string field,
    string termStr
)
Visual Basic
Public Overridable Function GetWildcardQuery ( _
    field As String, _
    termStr As String _
) As Query
Visual C++
public:
virtual Query^ GetWildcardQuery(
    String^ field,
    String^ termStr
)

Parameters

field
Type: System..::..String
Name of the field query will use.
termStr
Type: System..::..String
Term token that contains one or more wild card characters (? or *), but is not simple prefix term

Return Value

Resulting {@link Query} built for the term

Exceptions

Exception | Condition
Lucene.Net.QueryParsers..::..ParseException | throw in overridden method to disallow

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Main Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Main Method
QueryParser Class See Also Send Feedback
Command line tool to test QueryParser, using {@link Lucene.Net.Analysis.SimpleAnalyzer}. Usage:
CopyC#
java Lucene.Net.QueryParsers.QueryParser <input>

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Main(System.String[])"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Modifiers Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Modifiers Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Modifiers"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Modifiers()
Visual Basic
Public Function Modifiers As Integer
Visual C++
public:
int Modifiers()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Modifiers"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewBooleanClause Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewBooleanClause Method
QueryParser Class See Also Send Feedback
Builds a new BooleanClause instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual BooleanClause NewBooleanClause(
    Query q,
    BooleanClause..::..Occur occur
)
Visual Basic
Protected Friend Overridable Function NewBooleanClause ( _
    q As Query, _
    occur As BooleanClause..::..Occur _
) As BooleanClause
Visual C++
protected public:
virtual BooleanClause^ NewBooleanClause(
    Query^ q,
    BooleanClause..::..Occur^ occur
)

Parameters

q
Type: Lucene.Net.Search..::..Query
sub query
occur
Type: Lucene.Net.Search..::..BooleanClause..::..Occur
how this clause should occur when matching documents

Return Value

new BooleanClause instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewBooleanQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewBooleanQuery Method
QueryParser Class See Also Send Feedback
Builds a new BooleanQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual BooleanQuery NewBooleanQuery(
    bool disableCoord
)
Visual Basic
Protected Friend Overridable Function NewBooleanQuery ( _
    disableCoord As Boolean _
) As BooleanQuery
Visual C++
protected public:
virtual BooleanQuery^ NewBooleanQuery(
    bool disableCoord
)

Parameters

disableCoord
Type: System..::..Boolean
disable coord

Return Value

new BooleanQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewFuzzyQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewFuzzyQuery Method
QueryParser Class See Also Send Feedback
Builds a new FuzzyQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query NewFuzzyQuery(
    Term term,
    float minimumSimilarity,
    int prefixLength
)
Visual Basic
Protected Friend Overridable Function NewFuzzyQuery ( _
    term As Term, _
    minimumSimilarity As Single, _
    prefixLength As Integer _
) As Query
Visual C++
protected public:
virtual Query^ NewFuzzyQuery(
    Term^ term,
    float minimumSimilarity,
    int prefixLength
)

Parameters

term
Type: Lucene.Net.Index..::..Term
Term
minimumSimilarity
Type: System..::..Single
minimum similarity
prefixLength
Type: System..::..Int32
prefix length

Return Value

new FuzzyQuery Instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewMatchAllDocsQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewMatchAllDocsQuery Method
QueryParser Class See Also Send Feedback
Builds a new MatchAllDocsQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query NewMatchAllDocsQuery()
Visual Basic
Protected Friend Overridable Function NewMatchAllDocsQuery As Query
Visual C++
protected public:
virtual Query^ NewMatchAllDocsQuery()

Return Value

new MatchAllDocsQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewMultiPhraseQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewMultiPhraseQuery Method
QueryParser Class See Also Send Feedback
Builds a new MultiPhraseQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual MultiPhraseQuery NewMultiPhraseQuery()
Visual Basic
Protected Friend Overridable Function NewMultiPhraseQuery As MultiPhraseQuery
Visual C++
protected public:
virtual MultiPhraseQuery^ NewMultiPhraseQuery()

Return Value

new MultiPhraseQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewPhraseQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewPhraseQuery Method
QueryParser Class See Also Send Feedback
Builds a new PhraseQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual PhraseQuery NewPhraseQuery()
Visual Basic
Protected Friend Overridable Function NewPhraseQuery As PhraseQuery
Visual C++
protected public:
virtual PhraseQuery^ NewPhraseQuery()

Return Value

new PhraseQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewPrefixQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewPrefixQuery Method
QueryParser Class See Also Send Feedback
Builds a new PrefixQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query NewPrefixQuery(
    Term prefix
)
Visual Basic
Protected Friend Overridable Function NewPrefixQuery ( _
    prefix As Term _
) As Query
Visual C++
protected public:
virtual Query^ NewPrefixQuery(
    Term^ prefix
)

Parameters

prefix
Type: Lucene.Net.Index..::..Term
Prefix term

Return Value

new PrefixQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewRangeQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewRangeQuery Method
QueryParser Class See Also Send Feedback
Builds a new TermRangeQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query NewRangeQuery(
    string field,
    string part1,
    string part2,
    bool inclusive
)
Visual Basic
Protected Friend Overridable Function NewRangeQuery ( _
    field As String, _
    part1 As String, _
    part2 As String, _
    inclusive As Boolean _
) As Query
Visual C++
protected public:
virtual Query^ NewRangeQuery(
    String^ field,
    String^ part1,
    String^ part2,
    bool inclusive
)

Parameters

field
Type: System..::..String
Field
part1
Type: System..::..String
min
part2
Type: System..::..String
max
inclusive
Type: System..::..Boolean
true if range is inclusive

Return Value

new TermRangeQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewTermQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewTermQuery Method
QueryParser Class See Also Send Feedback
Builds a new TermQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query NewTermQuery(
    Term term
)
Visual Basic
Protected Friend Overridable Function NewTermQuery ( _
    term As Term _
) As Query
Visual C++
protected public:
virtual Query^ NewTermQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term
term

Return Value

new TermQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


NewWildcardQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..NewWildcardQuery Method
QueryParser Class See Also Send Feedback
Builds a new WildcardQuery instance

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Query NewWildcardQuery(
    Term t
)
Visual Basic
Protected Friend Overridable Function NewWildcardQuery ( _
    t As Term _
) As Query
Visual C++
protected public:
virtual Query^ NewWildcardQuery(
    Term^ t
)

Parameters

t
Type: Lucene.Net.Index..::..Term
wildcard term

Return Value

new WildcardQuery instance

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Parse Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Parse Method
QueryParser Class See Also Send Feedback
Parses a query string, returning a {@link Lucene.Net.Search.Query}.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query Parse(
    string query
)
Visual Basic
Public Overridable Function Parse ( _
    query As String _
) As Query
Visual C++
public:
virtual Query^ Parse(
    String^ query
)

Parameters

query
Type: System..::..String
the query string to be parsed.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Parse(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Query Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Query Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Query(System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Query Query(
    string field
)
Visual Basic
Public Function Query ( _
    field As String _
) As Query
Visual C++
public:
Query^ Query(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Query(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Query(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


ReInit Method

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..ReInit Method
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReInit(CharStream) | Reinitialise.
Public method | ReInit(QueryParserTokenManager) | Reinitialise.

See Also

QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace


ReInit Method (CharStream)

[image]

Lucene.Net Class Libraries
QueryParser..::..ReInit Method (CharStream)
QueryParser Class See Also Send Feedback
Reinitialise.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ReInit(
    CharStream stream
)
Visual Basic
Public Overridable Sub ReInit ( _
    stream As CharStream _
)
Visual C++
public:
virtual void ReInit(
    CharStream^ stream
)

Parameters

stream
Type: Lucene.Net.QueryParsers..::..CharStream

[Missing <param name="stream"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.ReInit(Lucene.Net.QueryParsers.CharStream)"]

See Also

QueryParser Class
ReInit Overload
Lucene.Net.QueryParsers Namespace


ReInit Method (QueryParserTokenManager)

[image]

Lucene.Net Class Libraries
QueryParser..::..ReInit Method (QueryParserTokenManager)
QueryParser Class See Also Send Feedback
Reinitialise.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ReInit(
    QueryParserTokenManager tm
)
Visual Basic
Public Overridable Sub ReInit ( _
    tm As QueryParserTokenManager _
)
Visual C++
public:
virtual void ReInit(
    QueryParserTokenManager^ tm
)

Parameters

tm
Type: Lucene.Net.QueryParsers..::..QueryParserTokenManager

[Missing <param name="tm"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.ReInit(Lucene.Net.QueryParsers.QueryParserTokenManager)"]

See Also

QueryParser Class
ReInit Overload
Lucene.Net.QueryParsers Namespace


SetAllowLeadingWildcard Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetAllowLeadingWildcard Method
QueryParser Class See Also Send Feedback
Set to
CopyC#
true
 to allow leading wildcard characters.

When set,

CopyC#
*
or
CopyC#
?
 are allowed as the first character of a PrefixQuery and WildcardQuery. Note that this can produce very slow queries on big indexes.

Default: false.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetAllowLeadingWildcard(
    bool allowLeadingWildcard
)
Visual Basic
Public Overridable Sub SetAllowLeadingWildcard ( _
    allowLeadingWildcard As Boolean _
)
Visual C++
public:
virtual void SetAllowLeadingWildcard(
    bool allowLeadingWildcard
)

Parameters

allowLeadingWildcard
Type: System..::..Boolean

[Missing <param name="allowLeadingWildcard"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetAllowLeadingWildcard(System.Boolean)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetDateResolution Method

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..SetDateResolution Method
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDateResolution(DateTools..::..Resolution) | Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.
Public method | SetDateResolution(String, DateTools..::..Resolution) | Sets the date resolution used by RangeQueries for a specific field.

See Also

QueryParser Class
QueryParser Members
Lucene.Net.QueryParsers Namespace


SetDateResolution Method (DateTools.Resolution)

[image]

Lucene.Net Class Libraries
QueryParser..::..SetDateResolution Method (DateTools..::..Resolution)
QueryParser Class See Also Send Feedback
Sets the default date resolution used by RangeQueries for fields for which no specific date resolutions has been set. Field specific resolutions can be set with {@link #SetDateResolution(String, DateTools.Resolution)}.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDateResolution(
    DateTools..::..Resolution dateResolution
)
Visual Basic
Public Overridable Sub SetDateResolution ( _
    dateResolution As DateTools..::..Resolution _
)
Visual C++
public:
virtual void SetDateResolution(
    DateTools..::..Resolution^ dateResolution
)

Parameters

dateResolution
Type: Lucene.Net.Documents..::..DateTools..::..Resolution
the default date resolution to set

See Also

QueryParser Class
SetDateResolution Overload
Lucene.Net.QueryParsers Namespace


SetDateResolution Method (String, DateTools.Resolution)

[image]

Lucene.Net Class Libraries
QueryParser..::..SetDateResolution Method (String, DateTools..::..Resolution)
QueryParser Class See Also Send Feedback
Sets the date resolution used by RangeQueries for a specific field.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDateResolution(
    string fieldName,
    DateTools..::..Resolution dateResolution
)
Visual Basic
Public Overridable Sub SetDateResolution ( _
    fieldName As String, _
    dateResolution As DateTools..::..Resolution _
)
Visual C++
public:
virtual void SetDateResolution(
    String^ fieldName,
    DateTools..::..Resolution^ dateResolution
)

Parameters

fieldName
Type: System..::..String
field for which the date resolution is to be set
dateResolution
Type: Lucene.Net.Documents..::..DateTools..::..Resolution
date resolution to set

See Also

QueryParser Class
SetDateResolution Overload
Lucene.Net.QueryParsers Namespace


SetDefaultOperator Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetDefaultOperator Method
QueryParser Class See Also Send Feedback
Sets the boolean operator of the QueryParser. In default mode (
CopyC#
OR_OPERATOR
) terms without any modifiers are considered optional: for example
CopyC#
capital of Hungary
 is equal to
CopyC#
capital OR of OR Hungary
.
In
CopyC#
AND_OPERATOR
 mode terms are considered to be in conjunction: the above mentioned query is parsed as
CopyC#
capital AND of AND Hungary

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDefaultOperator(
    QueryParser..::..Operator op
)
Visual Basic
Public Overridable Sub SetDefaultOperator ( _
    op As QueryParser..::..Operator _
)
Visual C++
public:
virtual void SetDefaultOperator(
    QueryParser..::..Operator^ op
)

Parameters

op
Type: Lucene.Net.QueryParsers..::..QueryParser..::..Operator

[Missing <param name="op"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetDefaultOperator(Lucene.Net.QueryParsers.QueryParser.Operator)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetEnablePositionIncrements Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetEnablePositionIncrements Method
QueryParser Class See Also Send Feedback
Set to
CopyC#
true
 to enable position increments in result query.

When set, result phrase and multi-phrase queries will be aware of position increments. Useful when e.g. a StopFilter increases the position increment of the token that follows an omitted token.

Default: false.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetEnablePositionIncrements(
    bool enable
)
Visual Basic
Public Overridable Sub SetEnablePositionIncrements ( _
    enable As Boolean _
)
Visual C++
public:
virtual void SetEnablePositionIncrements(
    bool enable
)

Parameters

enable
Type: System..::..Boolean

[Missing <param name="enable"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetEnablePositionIncrements(System.Boolean)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetFuzzyMinSim Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetFuzzyMinSim Method
QueryParser Class See Also Send Feedback
Set the minimum similarity for fuzzy queries. Default is 0.5f.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetFuzzyMinSim(
    float fuzzyMinSim
)
Visual Basic
Public Overridable Sub SetFuzzyMinSim ( _
    fuzzyMinSim As Single _
)
Visual C++
public:
virtual void SetFuzzyMinSim(
    float fuzzyMinSim
)

Parameters

fuzzyMinSim
Type: System..::..Single

[Missing <param name="fuzzyMinSim"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetFuzzyMinSim(System.Single)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetFuzzyPrefixLength Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetFuzzyPrefixLength Method
QueryParser Class See Also Send Feedback
Set the prefix length for fuzzy queries. Default is 0.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetFuzzyPrefixLength(
    int fuzzyPrefixLength
)
Visual Basic
Public Overridable Sub SetFuzzyPrefixLength ( _
    fuzzyPrefixLength As Integer _
)
Visual C++
public:
virtual void SetFuzzyPrefixLength(
    int fuzzyPrefixLength
)

Parameters

fuzzyPrefixLength
Type: System..::..Int32
The fuzzyPrefixLength to set.

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetLocale Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetLocale Method
QueryParser Class See Also Send Feedback
Set locale used by date range parsing.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetLocale(
    CultureInfo locale
)
Visual Basic
Public Overridable Sub SetLocale ( _
    locale As CultureInfo _
)
Visual C++
public:
virtual void SetLocale(
    CultureInfo^ locale
)

Parameters

locale
Type: System.Globalization..::..CultureInfo

[Missing <param name="locale"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetLocale(System.Globalization.CultureInfo)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetLowercaseExpandedTerms Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetLowercaseExpandedTerms Method
QueryParser Class See Also Send Feedback
Whether terms of wildcard, prefix, fuzzy and range queries are to be automatically lower-cased or not. Default is
CopyC#
true
.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetLowercaseExpandedTerms(
    bool lowercaseExpandedTerms
)
Visual Basic
Public Overridable Sub SetLowercaseExpandedTerms ( _
    lowercaseExpandedTerms As Boolean _
)
Visual C++
public:
virtual void SetLowercaseExpandedTerms(
    bool lowercaseExpandedTerms
)

Parameters

lowercaseExpandedTerms
Type: System..::..Boolean

[Missing <param name="lowercaseExpandedTerms"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetLowercaseExpandedTerms(System.Boolean)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetMultiTermRewriteMethod Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetMultiTermRewriteMethod Method
QueryParser Class See Also Send Feedback
By default QueryParser uses {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} when creating a PrefixQuery, WildcardQuery or RangeQuery. This implementation is generally preferable because it a) Runs faster b) Does not have the scarcity of terms unduly influence score c) avoids any "TooManyBooleanClauses" exception. However, if your application really needs to use the old-fashioned BooleanQuery expansion rewriting and the above points are not relevant then use this to change the rewrite method.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMultiTermRewriteMethod(
    MultiTermQuery..::..RewriteMethod method
)
Visual Basic
Public Overridable Sub SetMultiTermRewriteMethod ( _
    method As MultiTermQuery..::..RewriteMethod _
)
Visual C++
public:
virtual void SetMultiTermRewriteMethod(
    MultiTermQuery..::..RewriteMethod^ method
)

Parameters

method
Type: Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod

[Missing <param name="method"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetMultiTermRewriteMethod(Lucene.Net.Search.MultiTermQuery.RewriteMethod)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetPhraseSlop Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetPhraseSlop Method
QueryParser Class See Also Send Feedback
Sets the default slop for phrases. If zero, then exact phrase matches are required. Default value is zero.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetPhraseSlop(
    int phraseSlop
)
Visual Basic
Public Overridable Sub SetPhraseSlop ( _
    phraseSlop As Integer _
)
Visual C++
public:
virtual void SetPhraseSlop(
    int phraseSlop
)

Parameters

phraseSlop
Type: System..::..Int32

[Missing <param name="phraseSlop"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetPhraseSlop(System.Int32)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetRangeCollator Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetRangeCollator Method
QueryParser Class See Also Send Feedback
Sets the collator used to determine index term inclusion in ranges for RangeQuerys.

WARNING: Setting the rangeCollator to a non-null collator using this method will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetRangeCollator(
    CompareInfo rc
)
Visual Basic
Public Overridable Sub SetRangeCollator ( _
    rc As CompareInfo _
)
Visual C++
public:
virtual void SetRangeCollator(
    CompareInfo^ rc
)

Parameters

rc
Type: System.Globalization..::..CompareInfo
the collator to use when constructing RangeQuerys

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


SetUseOldRangeQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..SetUseOldRangeQuery Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetUseOldRangeQuery(System.Boolean)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use SetMultiTermRewriteMethod instead.")]
public virtual void SetUseOldRangeQuery(
    bool useOldRangeQuery
)
Visual Basic
<ObsoleteAttribute("Please use SetMultiTermRewriteMethod instead.")> _
Public Overridable Sub SetUseOldRangeQuery ( _
    useOldRangeQuery As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Please use SetMultiTermRewriteMethod instead.")]
public:
virtual void SetUseOldRangeQuery(
    bool useOldRangeQuery
)

Parameters

useOldRangeQuery
Type: System..::..Boolean

[Missing <param name="useOldRangeQuery"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.SetUseOldRangeQuery(System.Boolean)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


Term Method

[image]

Lucene.Net Class Libraries
QueryParser..::..Term Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Term(System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Query Term(
    string field
)
Visual Basic
Public Function Term ( _
    field As String _
) As Query
Visual C++
public:
Query^ Term(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Term(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.Term(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


TopLevelQuery Method

[image]

Lucene.Net Class Libraries
QueryParser..::..TopLevelQuery Method
QueryParser Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParser.TopLevelQuery(System.String)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Query TopLevelQuery(
    string field
)
Visual Basic
Public Function TopLevelQuery ( _
    field As String _
) As Query
Visual C++
public:
Query^ TopLevelQuery(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.QueryParsers.QueryParser.TopLevelQuery(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParser.TopLevelQuery(System.String)"]

See Also

QueryParser Class
Lucene.Net.QueryParsers Namespace


QueryParser.Operator Class

[image]

Lucene.Net Class Libraries
QueryParser..::..Operator Class
QueryParser Class Members See Also Send Feedback
The default operator for parsing queries. Use {@link QueryParser#setDefaultOperator} to change it.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Operator : Parameter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Operator _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class Operator sealed : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.QueryParsers..::..QueryParser..::..Operator

See Also

QueryParser..::..Operator Members
Lucene.Net.QueryParsers Namespace


QueryParser.Operator Members

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..Operator Members
QueryParser..::..Operator Class Methods Fields See Also Send Feedback

This class is generated by JavaCC. The most important method is {@link #Parse(String)}. The syntax for query strings is as follows: A Query is a series of clauses. A clause may be prefixed by:
  • a plus (
    CopyC#
    +
    ) or a minus (
    CopyC#
    -
    ) sign, indicating that the clause is required or prohibited respectively; or
  • a term followed by a colon, indicating the field to be searched. This enables one to construct queries which search multiple fields.
A clause may be either:
  • a term, indicating all the documents that contain this term; or
  • a nested query, enclosed in parentheses. Note that this may be used with a
    CopyC#
    +
    /
    CopyC#
    -
     prefix to require any of a set of terms.
Thus, in BNF, the query grammar is:
            Query  ::= ( Clause )*
            Clause ::= ["+", "-"] [<TERM> ":"] ( <TERM> | "(" Query ")" )

Examples of appropriately formatted queries can be found in the query syntax documentation.

In {@link TermRangeQuery}s, QueryParser tries to detect date values, e.g. date:[6/1/2005 TO 6/4/2005] produces a range query that searches for "date" fields between 2005-06-01 and 2005-06-04. Note that the format of the accepted input depends on {@link #SetLocale(Locale) the locale}. By default a date is converted into a search term using the deprecated {@link DateField} for compatibility reasons. To use the new {@link DateTools} to convert dates, a {@link Lucene.Net.Documents.DateTools.Resolution} has to be set.

The date resolution that shall be used for RangeQueries can be set using {@link #SetDateResolution(DateTools.Resolution)} or {@link #SetDateResolution(String, DateTools.Resolution)}. The former sets the default date resolution for all fields, whereas the latter can be used to set field specific date resolutions. Field specific date resolutions take, if set, precedence over the default date resolution.

If you use neither {@link DateField} nor {@link DateTools} in your index, you can create your own query parser that inherits QueryParser and overwrites {@link #GetRangeQuery(String, String, String, boolean)} to use a different method for date conversion.

Note that QueryParser is not thread-safe.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created.

NOTE: there is a new QueryParser in contrib, which matches the same syntax as this class, but is more modular, enabling substantial customization to how a query is created. NOTE: You must specify the required {@link Version} compatibility when creating QueryParser:

  • As of 2.9, {@link #SetEnablePositionIncrements} is true by default.

The QueryParser..::..Operator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

Fields

Name | Description
AND |
OR |

See Also

QueryParser..::..Operator Class
Lucene.Net.QueryParsers Namespace


QueryParser.Operator Fields

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..Operator Fields
QueryParser..::..Operator Class See Also Send Feedback

The QueryParser..::..Operator type exposes the following members.

Fields

Name | Description
AND |
OR |

See Also

QueryParser..::..Operator Class
Lucene.Net.QueryParsers Namespace


AND Field

[image]

Lucene.Net Class Libraries
QueryParser..::..Operator..::..AND Field
QueryParser..::..Operator Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.QueryParsers.QueryParser.Operator.AND"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly QueryParser..::..Operator AND
Visual Basic
Public Shared ReadOnly AND As QueryParser..::..Operator
Visual C++
public:
static initonly QueryParser..::..Operator^ AND

See Also

QueryParser..::..Operator Class
Lucene.Net.QueryParsers Namespace


OR Field

[image]

Lucene.Net Class Libraries
QueryParser..::..Operator..::..OR Field
QueryParser..::..Operator Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.QueryParsers.QueryParser.Operator.OR"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly QueryParser..::..Operator OR
Visual Basic
Public Shared ReadOnly OR As QueryParser..::..Operator
Visual C++
public:
static initonly QueryParser..::..Operator^ OR

See Also

QueryParser..::..Operator Class
Lucene.Net.QueryParsers Namespace


QueryParser.Operator Methods

[image] [image]

Lucene.Net Class Libraries
QueryParser..::..Operator Methods
QueryParser..::..Operator Class See Also Send Feedback

The QueryParser..::..Operator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

See Also

QueryParser..::..Operator Class
Lucene.Net.QueryParsers Namespace


QueryParserConstants Class

[image]

Lucene.Net Class Libraries
QueryParserConstants Class
Members See Also Send Feedback
Token literal values and constants. Generated by org.javacc.parser.OtherFilesGen#start()

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class QueryParserConstants
Visual Basic
Public Class QueryParserConstants
Visual C++
public ref class QueryParserConstants

Inheritance Hierarchy

System..::..Object
Lucene.Net.QueryParsers..::..QueryParserConstants
Lucene.Net.QueryParsers..::..QueryParser
Lucene.Net.QueryParsers..::..QueryParserTokenManager

See Also

QueryParserConstants Members
Lucene.Net.QueryParsers Namespace


QueryParserConstants Members

[image] [image]

Lucene.Net Class Libraries
QueryParserConstants Members
QueryParserConstants Class Constructors Methods Fields See Also Send Feedback

The QueryParserConstants type exposes the following members.

Constructors

 | Name | Description
Public method | QueryParserConstants | Initializes a new instance of the QueryParserConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_ESCAPED_CHAR | RegularExpression Id.
_NUM_CHAR | RegularExpression Id.
_QUOTED_CHAR | RegularExpression Id.
_TERM_CHAR | RegularExpression Id.
_TERM_START_CHAR | RegularExpression Id.
_WHITESPACE | RegularExpression Id.
AND | RegularExpression Id.
Boost | Lexical state.
CARAT | RegularExpression Id.
COLON | RegularExpression Id.
DEFAULT | Lexical state.
EOF | End of File.
FUZZY_SLOP | RegularExpression Id.
LPAREN | RegularExpression Id.
MINUS | RegularExpression Id.
NOT | RegularExpression Id.
NUMBER | RegularExpression Id.
OR | RegularExpression Id.
PLUS | RegularExpression Id.
PREFIXTERM | RegularExpression Id.
QUOTED | RegularExpression Id.
RangeEx | Lexical state.
RANGEEX_END | RegularExpression Id.
RANGEEX_GOOP | RegularExpression Id.
RANGEEX_QUOTED | RegularExpression Id.
RANGEEX_START | RegularExpression Id.
RANGEEX_TO | RegularExpression Id.
RangeIn | Lexical state.
RANGEIN_END | RegularExpression Id.
RANGEIN_GOOP | RegularExpression Id.
RANGEIN_QUOTED | RegularExpression Id.
RANGEIN_START | RegularExpression Id.
RANGEIN_TO | RegularExpression Id.
RPAREN | RegularExpression Id.
STAR | RegularExpression Id.
TERM | RegularExpression Id.
tokenImage | Literal token values.
WILDTERM | RegularExpression Id.

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


QueryParserConstants Constructor

[image]

Lucene.Net Class Libraries
QueryParserConstants Constructor
QueryParserConstants Class See Also Send Feedback
Initializes a new instance of the QueryParserConstants class

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryParserConstants()
Visual Basic
Public Sub New
Visual C++
public:
QueryParserConstants()

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


QueryParserConstants Fields

[image] [image]

Lucene.Net Class Libraries
QueryParserConstants Fields
QueryParserConstants Class See Also Send Feedback

The QueryParserConstants type exposes the following members.

Fields

Name | Description
_ESCAPED_CHAR | RegularExpression Id.
_NUM_CHAR | RegularExpression Id.
_QUOTED_CHAR | RegularExpression Id.
_TERM_CHAR | RegularExpression Id.
_TERM_START_CHAR | RegularExpression Id.
_WHITESPACE | RegularExpression Id.
AND | RegularExpression Id.
Boost | Lexical state.
CARAT | RegularExpression Id.
COLON | RegularExpression Id.
DEFAULT | Lexical state.
EOF | End of File.
FUZZY_SLOP | RegularExpression Id.
LPAREN | RegularExpression Id.
MINUS | RegularExpression Id.
NOT | RegularExpression Id.
NUMBER | RegularExpression Id.
OR | RegularExpression Id.
PLUS | RegularExpression Id.
PREFIXTERM | RegularExpression Id.
QUOTED | RegularExpression Id.
RangeEx | Lexical state.
RANGEEX_END | RegularExpression Id.
RANGEEX_GOOP | RegularExpression Id.
RANGEEX_QUOTED | RegularExpression Id.
RANGEEX_START | RegularExpression Id.
RANGEEX_TO | RegularExpression Id.
RangeIn | Lexical state.
RANGEIN_END | RegularExpression Id.
RANGEIN_GOOP | RegularExpression Id.
RANGEIN_QUOTED | RegularExpression Id.
RANGEIN_START | RegularExpression Id.
RANGEIN_TO | RegularExpression Id.
RPAREN | RegularExpression Id.
STAR | RegularExpression Id.
TERM | RegularExpression Id.
tokenImage | Literal token values.
WILDTERM | RegularExpression Id.

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


_ESCAPED_CHAR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::.._ESCAPED_CHAR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int _ESCAPED_CHAR
Visual Basic
Public Const _ESCAPED_CHAR As Integer
Visual C++
public:
literal int _ESCAPED_CHAR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


_NUM_CHAR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::.._NUM_CHAR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int _NUM_CHAR
Visual Basic
Public Const _NUM_CHAR As Integer
Visual C++
public:
literal int _NUM_CHAR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


_QUOTED_CHAR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::.._QUOTED_CHAR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int _QUOTED_CHAR
Visual Basic
Public Const _QUOTED_CHAR As Integer
Visual C++
public:
literal int _QUOTED_CHAR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


_TERM_CHAR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::.._TERM_CHAR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int _TERM_CHAR
Visual Basic
Public Const _TERM_CHAR As Integer
Visual C++
public:
literal int _TERM_CHAR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


_TERM_START_CHAR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::.._TERM_START_CHAR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int _TERM_START_CHAR
Visual Basic
Public Const _TERM_START_CHAR As Integer
Visual C++
public:
literal int _TERM_START_CHAR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


_WHITESPACE Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::.._WHITESPACE Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int _WHITESPACE
Visual Basic
Public Const _WHITESPACE As Integer
Visual C++
public:
literal int _WHITESPACE

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


AND Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..AND Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int AND
Visual Basic
Public Const AND As Integer
Visual C++
public:
literal int AND

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


Boost Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..Boost Field
QueryParserConstants Class See Also Send Feedback
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int Boost
Visual Basic
Public Const Boost As Integer
Visual C++
public:
literal int Boost

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


CARAT Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..CARAT Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int CARAT
Visual Basic
Public Const CARAT As Integer
Visual C++
public:
literal int CARAT

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


COLON Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..COLON Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int COLON
Visual Basic
Public Const COLON As Integer
Visual C++
public:
literal int COLON

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


DEFAULT Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..DEFAULT Field
QueryParserConstants Class See Also Send Feedback
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT
Visual Basic
Public Const DEFAULT As Integer
Visual C++
public:
literal int DEFAULT

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


EOF Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..EOF Field
QueryParserConstants Class See Also Send Feedback
End of File.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int EOF
Visual Basic
Public Const EOF As Integer
Visual C++
public:
literal int EOF

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


FUZZY_SLOP Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..FUZZY_SLOP Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FUZZY_SLOP
Visual Basic
Public Const FUZZY_SLOP As Integer
Visual C++
public:
literal int FUZZY_SLOP

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


LPAREN Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..LPAREN Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int LPAREN
Visual Basic
Public Const LPAREN As Integer
Visual C++
public:
literal int LPAREN

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


MINUS Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..MINUS Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int MINUS
Visual Basic
Public Const MINUS As Integer
Visual C++
public:
literal int MINUS

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


NOT Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..NOT Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int NOT
Visual Basic
Public Const NOT As Integer
Visual C++
public:
literal int NOT

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


NUMBER Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..NUMBER Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int NUMBER
Visual Basic
Public Const NUMBER As Integer
Visual C++
public:
literal int NUMBER

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


OR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..OR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int OR
Visual Basic
Public Const OR As Integer
Visual C++
public:
literal int OR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


PLUS Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..PLUS Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int PLUS
Visual Basic
Public Const PLUS As Integer
Visual C++
public:
literal int PLUS

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


PREFIXTERM Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..PREFIXTERM Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int PREFIXTERM
Visual Basic
Public Const PREFIXTERM As Integer
Visual C++
public:
literal int PREFIXTERM

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


QUOTED Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..QUOTED Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int QUOTED
Visual Basic
Public Const QUOTED As Integer
Visual C++
public:
literal int QUOTED

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RangeEx Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RangeEx Field
QueryParserConstants Class See Also Send Feedback
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RangeEx
Visual Basic
Public Const RangeEx As Integer
Visual C++
public:
literal int RangeEx

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEEX_END Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEEX_END Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEEX_END
Visual Basic
Public Const RANGEEX_END As Integer
Visual C++
public:
literal int RANGEEX_END

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEEX_GOOP Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEEX_GOOP Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEEX_GOOP
Visual Basic
Public Const RANGEEX_GOOP As Integer
Visual C++
public:
literal int RANGEEX_GOOP

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEEX_QUOTED Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEEX_QUOTED Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEEX_QUOTED
Visual Basic
Public Const RANGEEX_QUOTED As Integer
Visual C++
public:
literal int RANGEEX_QUOTED

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEEX_START Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEEX_START Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEEX_START
Visual Basic
Public Const RANGEEX_START As Integer
Visual C++
public:
literal int RANGEEX_START

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEEX_TO Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEEX_TO Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEEX_TO
Visual Basic
Public Const RANGEEX_TO As Integer
Visual C++
public:
literal int RANGEEX_TO

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RangeIn Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RangeIn Field
QueryParserConstants Class See Also Send Feedback
Lexical state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RangeIn
Visual Basic
Public Const RangeIn As Integer
Visual C++
public:
literal int RangeIn

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEIN_END Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEIN_END Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEIN_END
Visual Basic
Public Const RANGEIN_END As Integer
Visual C++
public:
literal int RANGEIN_END

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEIN_GOOP Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEIN_GOOP Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEIN_GOOP
Visual Basic
Public Const RANGEIN_GOOP As Integer
Visual C++
public:
literal int RANGEIN_GOOP

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEIN_QUOTED Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEIN_QUOTED Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEIN_QUOTED
Visual Basic
Public Const RANGEIN_QUOTED As Integer
Visual C++
public:
literal int RANGEIN_QUOTED

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEIN_START Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEIN_START Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEIN_START
Visual Basic
Public Const RANGEIN_START As Integer
Visual C++
public:
literal int RANGEIN_START

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RANGEIN_TO Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RANGEIN_TO Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RANGEIN_TO
Visual Basic
Public Const RANGEIN_TO As Integer
Visual C++
public:
literal int RANGEIN_TO

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


RPAREN Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..RPAREN Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int RPAREN
Visual Basic
Public Const RPAREN As Integer
Visual C++
public:
literal int RPAREN

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


STAR Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..STAR Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int STAR
Visual Basic
Public Const STAR As Integer
Visual C++
public:
literal int STAR

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


TERM Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..TERM Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int TERM
Visual Basic
Public Const TERM As Integer
Visual C++
public:
literal int TERM

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


tokenImage Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..tokenImage Field
QueryParserConstants Class See Also Send Feedback
Literal token values.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string[] tokenImage
Visual Basic
Public Shared tokenImage As String()
Visual C++
public:
static array<String^>^ tokenImage

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


WILDTERM Field

[image]

Lucene.Net Class Libraries
QueryParserConstants..::..WILDTERM Field
QueryParserConstants Class See Also Send Feedback
RegularExpression Id.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int WILDTERM
Visual Basic
Public Const WILDTERM As Integer
Visual C++
public:
literal int WILDTERM

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


QueryParserConstants Methods

[image] [image]

Lucene.Net Class Libraries
QueryParserConstants Methods
QueryParserConstants Class See Also Send Feedback

The QueryParserConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryParserConstants Class
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Class

[image]

Lucene.Net Class Libraries
QueryParserTokenManager Class
Members See Also Send Feedback
Token Manager.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class QueryParserTokenManager : QueryParserConstants
Visual Basic
Public Class QueryParserTokenManager _
    Inherits QueryParserConstants
Visual C++
public ref class QueryParserTokenManager : public QueryParserConstants

Inheritance Hierarchy

System..::..Object
Lucene.Net.QueryParsers..::..QueryParserConstants
Lucene.Net.QueryParsers..::..QueryParserTokenManager

See Also

QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Members

[image] [image]

Lucene.Net Class Libraries
QueryParserTokenManager Members
QueryParserTokenManager Class Constructors Methods Fields See Also Send Feedback

The QueryParserTokenManager type exposes the following members.

Constructors

 | Name | Description
Public method | QueryParserTokenManager(CharStream) | Constructor.
Public method | QueryParserTokenManager(CharStream, Int32) | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextToken | Get the next Token.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | JjFillToken |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReInit(CharStream) | Reinitialise parser.
Public method | ReInit(CharStream, Int32) | Reinitialise parser.
Public method | SetDebugStream | Set debug output.
Public method | SwitchTo | Switch to specified lex state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | curChar |
Public field | debugStream | Debug output.
Protected field | input_stream |
 | jjnewLexState | Lex State array.
 | jjstrLiteralImages | Token literal values.
 | lexStateNames | Lexer state names.

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor

[image] [image]

Lucene.Net Class Libraries
QueryParserTokenManager Constructor
QueryParserTokenManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryParserTokenManager(CharStream) | Constructor.
Public method | QueryParserTokenManager(CharStream, Int32) | Constructor.

See Also

QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor (CharStream)

[image]

Lucene.Net Class Libraries
QueryParserTokenManager Constructor (CharStream)
QueryParserTokenManager Class See Also Send Feedback
Constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryParserTokenManager(
    CharStream stream
)
Visual Basic
Public Sub New ( _
    stream As CharStream _
)
Visual C++
public:
QueryParserTokenManager(
    CharStream^ stream
)

Parameters

stream
Type: Lucene.Net.QueryParsers..::..CharStream

[Missing <param name="stream"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.#ctor(Lucene.Net.QueryParsers.CharStream)"]

See Also

QueryParserTokenManager Class
QueryParserTokenManager Overload
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Constructor (CharStream, Int32)

[image]

Lucene.Net Class Libraries
QueryParserTokenManager Constructor (CharStream, Int32)
QueryParserTokenManager Class See Also Send Feedback
Constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryParserTokenManager(
    CharStream stream,
    int lexState
)
Visual Basic
Public Sub New ( _
    stream As CharStream, _
    lexState As Integer _
)
Visual C++
public:
QueryParserTokenManager(
    CharStream^ stream,
    int lexState
)

Parameters

stream
Type: Lucene.Net.QueryParsers..::..CharStream

[Missing <param name="stream"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.#ctor(Lucene.Net.QueryParsers.CharStream,System.Int32)"]

lexState
Type: System..::..Int32

[Missing <param name="lexState"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.#ctor(Lucene.Net.QueryParsers.CharStream,System.Int32)"]

See Also

QueryParserTokenManager Class
QueryParserTokenManager Overload
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Fields

[image] [image]

Lucene.Net Class Libraries
QueryParserTokenManager Fields
QueryParserTokenManager Class See Also Send Feedback

The QueryParserTokenManager type exposes the following members.

Fields

 | Name | Description
Protected field | curChar |
Public field | debugStream | Debug output.
Protected field | input_stream |
 | jjnewLexState | Lex State array.
 | jjstrLiteralImages | Token literal values.
 | lexStateNames | Lexer state names.

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


curChar Field

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..curChar Field
QueryParserTokenManager Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.QueryParsers.QueryParserTokenManager.curChar"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal char curChar
Visual Basic
Protected Friend curChar As Char
Visual C++
protected public:
wchar_t curChar

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


debugStream Field

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..debugStream Field
QueryParserTokenManager Class See Also Send Feedback
Debug output.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StreamWriter debugStream
Visual Basic
Public debugStream As StreamWriter
Visual C++
public:
StreamWriter^ debugStream

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


input_stream Field

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..input_stream Field
QueryParserTokenManager Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.QueryParsers.QueryParserTokenManager.input_stream"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal CharStream input_stream
Visual Basic
Protected Friend input_stream As CharStream
Visual C++
protected public:
CharStream^ input_stream

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


jjnewLexState Field

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..jjnewLexState Field
QueryParserTokenManager Class See Also Send Feedback
Lex State array.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int[] jjnewLexState
Visual Basic
Public Shared ReadOnly jjnewLexState As Integer()
Visual C++
public:
static initonly array<int>^ jjnewLexState

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


jjstrLiteralImages Field

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..jjstrLiteralImages Field
QueryParserTokenManager Class See Also Send Feedback
Token literal values.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] jjstrLiteralImages
Visual Basic
Public Shared ReadOnly jjstrLiteralImages As String()
Visual C++
public:
static initonly array<String^>^ jjstrLiteralImages

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


lexStateNames Field

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..lexStateNames Field
QueryParserTokenManager Class See Also Send Feedback
Lexer state names.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string[] lexStateNames
Visual Basic
Public Shared ReadOnly lexStateNames As String()
Visual C++
public:
static initonly array<String^>^ lexStateNames

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


QueryParserTokenManager Methods

[image] [image]

Lucene.Net Class Libraries
QueryParserTokenManager Methods
QueryParserTokenManager Class See Also Send Feedback

The QueryParserTokenManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextToken | Get the next Token.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | JjFillToken |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReInit(CharStream) | Reinitialise parser.
Public method | ReInit(CharStream, Int32) | Reinitialise parser.
Public method | SetDebugStream | Set debug output.
Public method | SwitchTo | Switch to specified lex state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


GetNextToken Method

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..GetNextToken Method
QueryParserTokenManager Class See Also Send Feedback
Get the next Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Token GetNextToken()
Visual Basic
Public Overridable Function GetNextToken As Token
Visual C++
public:
virtual Token^ GetNextToken()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.GetNextToken"]

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


JjFillToken Method

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..JjFillToken Method
QueryParserTokenManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.JjFillToken"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Token JjFillToken()
Visual Basic
Protected Friend Overridable Function JjFillToken As Token
Visual C++
protected public:
virtual Token^ JjFillToken()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.JjFillToken"]

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


ReInit Method

[image] [image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..ReInit Method
QueryParserTokenManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReInit(CharStream) | Reinitialise parser.
Public method | ReInit(CharStream, Int32) | Reinitialise parser.

See Also

QueryParserTokenManager Class
QueryParserTokenManager Members
Lucene.Net.QueryParsers Namespace


ReInit Method (CharStream)

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..ReInit Method (CharStream)
QueryParserTokenManager Class See Also Send Feedback
Reinitialise parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ReInit(
    CharStream stream
)
Visual Basic
Public Overridable Sub ReInit ( _
    stream As CharStream _
)
Visual C++
public:
virtual void ReInit(
    CharStream^ stream
)

Parameters

stream
Type: Lucene.Net.QueryParsers..::..CharStream

[Missing <param name="stream"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.ReInit(Lucene.Net.QueryParsers.CharStream)"]

See Also

QueryParserTokenManager Class
ReInit Overload
Lucene.Net.QueryParsers Namespace


ReInit Method (CharStream, Int32)

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..ReInit Method (CharStream, Int32)
QueryParserTokenManager Class See Also Send Feedback
Reinitialise parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ReInit(
    CharStream stream,
    int lexState
)
Visual Basic
Public Overridable Sub ReInit ( _
    stream As CharStream, _
    lexState As Integer _
)
Visual C++
public:
virtual void ReInit(
    CharStream^ stream,
    int lexState
)

Parameters

stream
Type: Lucene.Net.QueryParsers..::..CharStream

[Missing <param name="stream"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.ReInit(Lucene.Net.QueryParsers.CharStream,System.Int32)"]

lexState
Type: System..::..Int32

[Missing <param name="lexState"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.ReInit(Lucene.Net.QueryParsers.CharStream,System.Int32)"]

See Also

QueryParserTokenManager Class
ReInit Overload
Lucene.Net.QueryParsers Namespace


SetDebugStream Method

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..SetDebugStream Method
QueryParserTokenManager Class See Also Send Feedback
Set debug output.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDebugStream(
    StreamWriter ds
)
Visual Basic
Public Overridable Sub SetDebugStream ( _
    ds As StreamWriter _
)
Visual C++
public:
virtual void SetDebugStream(
    StreamWriter^ ds
)

Parameters

ds
Type: System.IO..::..StreamWriter

[Missing <param name="ds"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.SetDebugStream(System.IO.StreamWriter)"]

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


SwitchTo Method

[image]

Lucene.Net Class Libraries
QueryParserTokenManager..::..SwitchTo Method
QueryParserTokenManager Class See Also Send Feedback
Switch to specified lex state.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SwitchTo(
    int lexState
)
Visual Basic
Public Overridable Sub SwitchTo ( _
    lexState As Integer _
)
Visual C++
public:
virtual void SwitchTo(
    int lexState
)

Parameters

lexState
Type: System..::..Int32

[Missing <param name="lexState"/> documentation for "M:Lucene.Net.QueryParsers.QueryParserTokenManager.SwitchTo(System.Int32)"]

See Also

QueryParserTokenManager Class
Lucene.Net.QueryParsers Namespace


Token Class

[image]

Lucene.Net Class Libraries
Token Class
Members See Also Send Feedback
Describes the input token stream.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class Token
Visual Basic
Public Class Token
Visual C++
public ref class Token

Inheritance Hierarchy

System..::..Object
Lucene.Net.QueryParsers..::..Token

See Also

Token Members
Lucene.Net.QueryParsers Namespace


Token Members

[image] [image]

Lucene.Net Class Libraries
Token Members
Token Class Constructors Methods Fields See Also Send Feedback

The Token type exposes the following members.

Constructors

 | Name | Description
Public method | Token()()()() | No-argument constructor
Public method | Token(Int32) | Constructs a new token for the specified Image.
Public method | Token(Int32, String) | Constructs a new token for the specified Image and Kind.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewToken(Int32) |
 | NewToken(Int32, String) | Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.
Public method | ToString | Returns the image. (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | beginColumn | The column number of the first character of this Token.
Public field | beginLine | The line number of the first character of this Token.
Public field | endColumn | The column number of the last character of this Token.
Public field | endLine | The line number of the last character of this Token.
Public field | image | The string image of the token.
Public field | kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
Public field | next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.
Public field | specialToken | This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

See Also

Token Class
Lucene.Net.QueryParsers Namespace


Token Constructor

[image] [image]

Lucene.Net Class Libraries
Token Constructor
Token Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Token()()()() | No-argument constructor
Public method | Token(Int32) | Constructs a new token for the specified Image.
Public method | Token(Int32, String) | Constructs a new token for the specified Image and Kind.

See Also

Token Class
Token Members
Lucene.Net.QueryParsers Namespace


Token Constructor

[image]

Lucene.Net Class Libraries
Token Constructor
Token Class See Also Send Feedback
No-argument constructor

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token()
Visual Basic
Public Sub New
Visual C++
public:
Token()

See Also

Token Class
Token Overload
Lucene.Net.QueryParsers Namespace


Token Constructor (Int32)

[image]

Lucene.Net Class Libraries
Token Constructor (Int32)
Token Class See Also Send Feedback
Constructs a new token for the specified Image.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    int kind
)
Visual Basic
Public Sub New ( _
    kind As Integer _
)
Visual C++
public:
Token(
    int kind
)

Parameters

kind
Type: System..::..Int32

[Missing <param name="kind"/> documentation for "M:Lucene.Net.QueryParsers.Token.#ctor(System.Int32)"]

See Also

Token Class
Token Overload
Lucene.Net.QueryParsers Namespace


Token Constructor (Int32, String)

[image]

Lucene.Net Class Libraries
Token Constructor (Int32, String)
Token Class See Also Send Feedback
Constructs a new token for the specified Image and Kind.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token(
    int kind,
    string image
)
Visual Basic
Public Sub New ( _
    kind As Integer, _
    image As String _
)
Visual C++
public:
Token(
    int kind,
    String^ image
)

Parameters

kind
Type: System..::..Int32

[Missing <param name="kind"/> documentation for "M:Lucene.Net.QueryParsers.Token.#ctor(System.Int32,System.String)"]

image
Type: System..::..String

[Missing <param name="image"/> documentation for "M:Lucene.Net.QueryParsers.Token.#ctor(System.Int32,System.String)"]

See Also

Token Class
Token Overload
Lucene.Net.QueryParsers Namespace


Token Fields

[image] [image]

Lucene.Net Class Libraries
Token Fields
Token Class See Also Send Feedback

The Token type exposes the following members.

Fields

 | Name | Description
Public field | beginColumn | The column number of the first character of this Token.
Public field | beginLine | The line number of the first character of this Token.
Public field | endColumn | The column number of the last character of this Token.
Public field | endLine | The line number of the last character of this Token.
Public field | image | The string image of the token.
Public field | kind | An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.
Public field | next | A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.
Public field | specialToken | This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

See Also

Token Class
Lucene.Net.QueryParsers Namespace


beginColumn Field

[image]

Lucene.Net Class Libraries
Token..::..beginColumn Field
Token Class See Also Send Feedback
The column number of the first character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int beginColumn
Visual Basic
Public beginColumn As Integer
Visual C++
public:
int beginColumn

See Also

Token Class
Lucene.Net.QueryParsers Namespace


beginLine Field

[image]

Lucene.Net Class Libraries
Token..::..beginLine Field
Token Class See Also Send Feedback
The line number of the first character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int beginLine
Visual Basic
Public beginLine As Integer
Visual C++
public:
int beginLine

See Also

Token Class
Lucene.Net.QueryParsers Namespace


endColumn Field

[image]

Lucene.Net Class Libraries
Token..::..endColumn Field
Token Class See Also Send Feedback
The column number of the last character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int endColumn
Visual Basic
Public endColumn As Integer
Visual C++
public:
int endColumn

See Also

Token Class
Lucene.Net.QueryParsers Namespace


endLine Field

[image]

Lucene.Net Class Libraries
Token..::..endLine Field
Token Class See Also Send Feedback
The line number of the last character of this Token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int endLine
Visual Basic
Public endLine As Integer
Visual C++
public:
int endLine

See Also

Token Class
Lucene.Net.QueryParsers Namespace


image Field

[image]

Lucene.Net Class Libraries
Token..::..image Field
Token Class See Also Send Feedback
The string image of the token.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string image
Visual Basic
Public image As String
Visual C++
public:
String^ image

See Also

Token Class
Lucene.Net.QueryParsers Namespace


kind Field

[image]

Lucene.Net Class Libraries
Token..::..kind Field
Token Class See Also Send Feedback
An integer that describes the kind of this token. This numbering system is determined by JavaCCParser, and a table of these numbers is stored in the file ...Constants.java.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int kind
Visual Basic
Public kind As Integer
Visual C++
public:
int kind

See Also

Token Class
Lucene.Net.QueryParsers Namespace


next Field

[image]

Lucene.Net Class Libraries
Token..::..next Field
Token Class See Also Send Feedback
A reference to the next regular (non-special) token from the input stream. If this is the last token from the input stream, or if the token manager has not read tokens beyond this one, this field is set to null. This is true only if this token is also a regular token. Otherwise, see below for a description of the contents of this field.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token next
Visual Basic
Public next As Token
Visual C++
public:
Token^ next

See Also

Token Class
Lucene.Net.QueryParsers Namespace


specialToken Field

[image]

Lucene.Net Class Libraries
Token..::..specialToken Field
Token Class See Also Send Feedback
This field is used to access special tokens that occur prior to this token, but after the immediately preceding regular (non-special) token. If there are no such special tokens, this field is set to null. When there are more than one such special token, this field refers to the last of these special tokens, which in turn refers to the next previous special token through its specialToken field, and so on until the first special token (whose specialToken field is null). The next fields of special tokens refer to other special tokens that immediately follow it (without an intervening regular token). If there is no such token, this field is null.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Token specialToken
Visual Basic
Public specialToken As Token
Visual C++
public:
Token^ specialToken

See Also

Token Class
Lucene.Net.QueryParsers Namespace


Token Methods

[image] [image]

Lucene.Net Class Libraries
Token Methods
Token Class See Also Send Feedback

The Token type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewToken(Int32) |
 | NewToken(Int32, String) | Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.
Public method | ToString | Returns the image. (Overrides Object..::..ToString()()()().)

See Also

Token Class
Lucene.Net.QueryParsers Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
Token..::..GetValue Method
Token Class See Also Send Feedback
An optional attribute value of the Token. Tokens which are not used as syntactic sugar will often contain meaningful values that will be used later on by the compiler or interpreter. This attribute value is often different from the image. Any subclass of Token that actually wants to return a non-null value can override this method as appropriate.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object GetValue()
Visual Basic
Public Overridable Function GetValue As Object
Visual C++
public:
virtual Object^ GetValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.Token.GetValue"]

See Also

Token Class
Lucene.Net.QueryParsers Namespace


NewToken Method

[image] [image]

Lucene.Net Class Libraries
Token..::..NewToken Method
Token Class See Also Send Feedback

Overload List

Name | Description
NewToken(Int32) |
NewToken(Int32, String) | Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.

See Also

Token Class
Token Members
Lucene.Net.QueryParsers Namespace


NewToken Method (Int32)

[image]

Lucene.Net Class Libraries
Token..::..NewToken Method (Int32)
Token Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.QueryParsers.Token.NewToken(System.Int32)"]

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Token NewToken(
    int ofKind
)
Visual Basic
Public Shared Function NewToken ( _
    ofKind As Integer _
) As Token
Visual C++
public:
static Token^ NewToken(
    int ofKind
)

Parameters

ofKind
Type: System..::..Int32

[Missing <param name="ofKind"/> documentation for "M:Lucene.Net.QueryParsers.Token.NewToken(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.Token.NewToken(System.Int32)"]

See Also

Token Class
NewToken Overload
Lucene.Net.QueryParsers Namespace


NewToken Method (Int32, String)

[image]

Lucene.Net Class Libraries
Token..::..NewToken Method (Int32, String)
Token Class See Also Send Feedback
Returns a new Token object, by default. However, if you want, you can create and return subclass objects based on the value of ofKind. Simply add the cases to the switch for all those special cases. For example, if you have a subclass of Token called IDToken that you want to create if ofKind is ID, simply add something like : case MyParserConstants.ID : return new IDToken(ofKind, image); to the following switch statement. Then you can cast matchedToken variable to the appropriate type and use sit in your lexical actions.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Token NewToken(
    int ofKind,
    string image
)
Visual Basic
Public Shared Function NewToken ( _
    ofKind As Integer, _
    image As String _
) As Token
Visual C++
public:
static Token^ NewToken(
    int ofKind,
    String^ image
)

Parameters

ofKind
Type: System..::..Int32

[Missing <param name="ofKind"/> documentation for "M:Lucene.Net.QueryParsers.Token.NewToken(System.Int32,System.String)"]

image
Type: System..::..String

[Missing <param name="image"/> documentation for "M:Lucene.Net.QueryParsers.Token.NewToken(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.Token.NewToken(System.Int32,System.String)"]

See Also

Token Class
NewToken Overload
Lucene.Net.QueryParsers Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Token..::..ToString Method
Token Class See Also Send Feedback
Returns the image.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.Token.ToString"]

See Also

Token Class
Lucene.Net.QueryParsers Namespace


TokenMgrError Class

[image]

Lucene.Net Class Libraries
TokenMgrError Class
Members See Also Send Feedback
Token Manager Error.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TokenMgrError : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class TokenMgrError _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class TokenMgrError : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Lucene.Net.QueryParsers..::..TokenMgrError

See Also

TokenMgrError Members
Lucene.Net.QueryParsers Namespace


TokenMgrError Members

[image] [image]

Lucene.Net Class Libraries
TokenMgrError Members
TokenMgrError Class Constructors Methods Properties Events See Also Send Feedback

The TokenMgrError type exposes the following members.

Constructors

 | Name | Description
Public method | TokenMgrError()()()() | No arg constructor.
Public method | TokenMgrError(String, Int32) | Constructor with message and reason.
Public method | TokenMgrError(Boolean, Int32, Int32, Int32, String, Char, Int32) | Full Constructor.

Methods

 | Name | Description
 | addEscapes | Replaces unprintable characters by their escaped (or unicode escaped) equivalents in the given string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
 | LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexical error curLexState : lexical state in which this error occurred errorLine : line number when the error occurred errorColumn : column number when the error occurred errorAfter : prefix that was seen before this error occurred curchar : the offending character Note: You can customize the lexical error message by modifying this method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor

[image] [image]

Lucene.Net Class Libraries
TokenMgrError Constructor
TokenMgrError Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TokenMgrError()()()() | No arg constructor.
Public method | TokenMgrError(String, Int32) | Constructor with message and reason.
Public method | TokenMgrError(Boolean, Int32, Int32, Int32, String, Char, Int32) | Full Constructor.

See Also

TokenMgrError Class
TokenMgrError Members
Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor

[image]

Lucene.Net Class Libraries
TokenMgrError Constructor
TokenMgrError Class See Also Send Feedback
No arg constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TokenMgrError()
Visual Basic
Public Sub New
Visual C++
public:
TokenMgrError()

See Also

TokenMgrError Class
TokenMgrError Overload
Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor (String, Int32)

[image]

Lucene.Net Class Libraries
TokenMgrError Constructor (String, Int32)
TokenMgrError Class See Also Send Feedback
Constructor with message and reason.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TokenMgrError(
    string message,
    int reason
)
Visual Basic
Public Sub New ( _
    message As String, _
    reason As Integer _
)
Visual C++
public:
TokenMgrError(
    String^ message,
    int reason
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.String,System.Int32)"]

reason
Type: System..::..Int32

[Missing <param name="reason"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.String,System.Int32)"]

See Also

TokenMgrError Class
TokenMgrError Overload
Lucene.Net.QueryParsers Namespace


TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32)

[image]

Lucene.Net Class Libraries
TokenMgrError Constructor (Boolean, Int32, Int32, Int32, String, Char, Int32)
TokenMgrError Class See Also Send Feedback
Full Constructor.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TokenMgrError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    string errorAfter,
    char curChar,
    int reason
)
Visual Basic
Public Sub New ( _
    EOFSeen As Boolean, _
    lexState As Integer, _
    errorLine As Integer, _
    errorColumn As Integer, _
    errorAfter As String, _
    curChar As Char, _
    reason As Integer _
)
Visual C++
public:
TokenMgrError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    String^ errorAfter,
    wchar_t curChar,
    int reason
)

Parameters

EOFSeen
Type: System..::..Boolean

[Missing <param name="EOFSeen"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

lexState
Type: System..::..Int32

[Missing <param name="lexState"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

errorLine
Type: System..::..Int32

[Missing <param name="errorLine"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

errorColumn
Type: System..::..Int32

[Missing <param name="errorColumn"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

errorAfter
Type: System..::..String

[Missing <param name="errorAfter"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

curChar
Type: System..::..Char

[Missing <param name="curChar"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

reason
Type: System..::..Int32

[Missing <param name="reason"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.#ctor(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char,System.Int32)"]

See Also

TokenMgrError Class
TokenMgrError Overload
Lucene.Net.QueryParsers Namespace


TokenMgrError Methods

[image] [image]

Lucene.Net Class Libraries
TokenMgrError Methods
TokenMgrError Class See Also Send Feedback

The TokenMgrError type exposes the following members.

Methods

 | Name | Description
 | addEscapes | Replaces unprintable characters by their escaped (or unicode escaped) equivalents in the given string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
 | LexicalError | Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexical error curLexState : lexical state in which this error occurred errorLine : line number when the error occurred errorColumn : column number when the error occurred errorAfter : prefix that was seen before this error occurred curchar : the offending character Note: You can customize the lexical error message by modifying this method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


addEscapes Method

[image]

Lucene.Net Class Libraries
TokenMgrError..::..addEscapes Method
TokenMgrError Class See Also Send Feedback
Replaces unprintable characters by their escaped (or unicode escaped) equivalents in the given string

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static string addEscapes(
    string str
)
Visual Basic
Protected Friend Shared Function addEscapes ( _
    str As String _
) As String
Visual C++
protected public:
static String^ addEscapes(
    String^ str
)

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.addEscapes(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.addEscapes(System.String)"]

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


LexicalError Method

[image]

Lucene.Net Class Libraries
TokenMgrError..::..LexicalError Method
TokenMgrError Class See Also Send Feedback
Returns a detailed message for the Error when it is thrown by the token manager to indicate a lexical error. Parameters : EOFSeen : indicates if EOF caused the lexical error curLexState : lexical state in which this error occurred errorLine : line number when the error occurred errorColumn : column number when the error occurred errorAfter : prefix that was seen before this error occurred curchar : the offending character Note: You can customize the lexical error message by modifying this method.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static string LexicalError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    string errorAfter,
    char curChar
)
Visual Basic
Protected Friend Shared Function LexicalError ( _
    EOFSeen As Boolean, _
    lexState As Integer, _
    errorLine As Integer, _
    errorColumn As Integer, _
    errorAfter As String, _
    curChar As Char _
) As String
Visual C++
protected public:
static String^ LexicalError(
    bool EOFSeen,
    int lexState,
    int errorLine,
    int errorColumn,
    String^ errorAfter,
    wchar_t curChar
)

Parameters

EOFSeen
Type: System..::..Boolean

[Missing <param name="EOFSeen"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

lexState
Type: System..::..Int32

[Missing <param name="lexState"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

errorLine
Type: System..::..Int32

[Missing <param name="errorLine"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

errorColumn
Type: System..::..Int32

[Missing <param name="errorColumn"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

errorAfter
Type: System..::..String

[Missing <param name="errorAfter"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

curChar
Type: System..::..Char

[Missing <param name="curChar"/> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.QueryParsers.TokenMgrError.LexicalError(System.Boolean,System.Int32,System.Int32,System.Int32,System.String,System.Char)"]

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


TokenMgrError Properties

[image] [image]

Lucene.Net Class Libraries
TokenMgrError Properties
TokenMgrError Class See Also Send Feedback

The TokenMgrError type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


Message Property

[image]

Lucene.Net Class Libraries
TokenMgrError..::..Message Property
TokenMgrError Class See Also Send Feedback
You can also modify the body of this method to customize your error messages. For example, cases like LOOP_DETECTED and INVALID_LEXICAL_STATE are not of end-users concern, so you can return something like : "Internal Error : Please file a bug report .... " from this method for such cases in the release version of your parser.

Namespace: Lucene.Net.QueryParsers
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


TokenMgrError Events

[image] [image]

Lucene.Net Class Libraries
TokenMgrError Events
TokenMgrError Class See Also Send Feedback

The TokenMgrError type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TokenMgrError Class
Lucene.Net.QueryParsers Namespace


Lucene.Net.Search Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search"]

Classes

Class | Description
Public class BooleanClause
A clause in a BooleanQuery.
Public class BooleanClause..::..Occur
Specifies how clauses are to occur in matching documents.
Public class | BooleanFilter
Public class BooleanFilterClause
A spefic clause that makes up a part of the BooleanFilter
Public class BooleanQuery
A Query that matches documents matching boolean combinations of other queries, e.g. {@link TermQuery}s, {@link PhraseQuery}s or other BooleanQuerys.
Protected class BooleanQuery..::..BooleanWeight
Expert: the Weight for BooleanQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Public class BooleanQuery..::..TooManyClauses
Thrown when an attempt is made to add more than {@link #GetMaxClauseCount()} clauses. This typically happens if a PrefixQuery, FuzzyQuery, WildcardQuery, or TermRangeQuery is expanded to many terms during search.
Public class | BooleanScorer
Public class | BoostingQuery
Public class CacheEntry
EXPERT: A unique Identifier/Description for each item in the FieldCache. Can be useful for logging/debugging.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public class CachingSpanFilter
Wraps another SpanFilter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
Public class CachingWrapperFilter
Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.
Public class | CachingWrapperFilter..::..DeletesMode
Public class Collector

Expert: Collectors are primarily meant to be used to gather raw results from a search, and implement sorting or custom result filtering, collation, etc.

As of 2.9, this class replaces the deprecated HitCollector, and offers an API for efficient collection of hits across sequential {@link IndexReader}s. {@link IndexSearcher} advances the collector through each of the sub readers, in an arbitrary order. This results in a higher performance means of collection.

Lucene's core collectors are derived from Collector. Likely your application can use one of these classes, or subclass {@link TopDocsCollector}, instead of implementing Collector directly:

  • {@link TopDocsCollector} is an abstract base class that assumes you will retrieve the top N docs, according to some criteria, after collection is done.
  • {@link TopScoreDocCollector} is a concrete subclass {@link TopDocsCollector} and sorts according to score + docID. This is used internally by the {@link IndexSearcher} search methods that do not take an explicit {@link Sort}. It is likely the most frequently used collector.
  • {@link TopFieldCollector} subclasses {@link TopDocsCollector} and sorts according to a specified {@link Sort} object (sort by field). This is used internally by the {@link IndexSearcher} search methods that take an explicit {@link Sort}.
  • {@link TimeLimitingCollector}, which wraps any other Collector and aborts the search if it's taken too much time, will subclass Collector in 3.0 (presently it subclasses the deprecated HitCollector).
  • {@link PositiveScoresOnlyCollector} wraps any other Collector and prevents collection of hits whose score is <= 0.0

Collector decouples the score from the collected doc: the score computation is skipped entirely if it's not needed. Collectors that do need the score should implement the {@link #setScorer} method, to hold onto the passed {@link Scorer} instance, and call {@link Scorer#Score()} within the collect method to compute the current hit's score. If your collector may request the score for a single hit multiple times, you should use {@link ScoreCachingWrappingScorer}.

NOTE: The doc that is passed to the collect method is relative to the current reader. If your collector needs to resolve this to the docID space of the Multi*Reader, you must re-base it by recording the docBase from the most recent setNextReader call. Here's a simple example showing how to collect docIDs into a BitSet:

            Searcher searcher = new IndexSearcher(indexReader);
            final BitSet bits = new BitSet(indexReader.maxDoc());
            searcher.search(query, new Collector() {
            private int docBase;

            // ignore scorer
            public void setScorer(Scorer scorer) {
            }

            // accept docs out of order (for a BitSet it doesn't matter)
            public boolean acceptsDocsOutOfOrder() {
            return true;
            }

            public void collect(int doc) {
            bits.set(doc + docBase);
            }

            public void setNextReader(IndexReader reader, int docBase) {
            this.docBase = docBase;
            }
            });

Not all collectors will need to rebase the docID. For example, a collector that simply counts the total number of hits would skip it.

NOTE: Prior to 2.9, Lucene silently filtered out hits with score <= 0. As of 2.9, the core Collectors no longer do that. It's very unusual to have such hits (a negative query boost, or function query returning negative custom scores, could cause it to happen). If you need that behavior, use {@link PositiveScoresOnlyCollector}.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class ComplexExplanation
Expert: Describes the score computation for document and query, and can distinguish a match independent of a positive value.
Public class ConstantScoreQuery
A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.
Protected class | ConstantScoreQuery..::..ConstantScorer
Protected class | ConstantScoreQuery..::..ConstantWeight
Public class ConstantScoreRangeQuery Obsolete.
A range query that returns a constant score equal to its boost for all documents in the exclusive range of terms.

It does not have an upper bound on the number of clauses covered in the range.

This query matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeQuery} instead.

This query is hardwired to {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}. If you want to change this, use {@link TermRangeQuery} instead.

Public class CreationPlaceholder
Expert: Maintains caches of term values.

Created: May 19, 2004 11:13:14 AM

Public class DefaultSimilarity
Expert: Default scoring implementation.
Public class DisjunctionMaxQuery
A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.
Protected class DisjunctionMaxQuery..::..DisjunctionMaxWeight
Expert: the Weight for DisjunctionMaxQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Public class DocIdSet
A DocIdSet contains a set of doc ids. Implementing classes must only implement {@link #iterator} to provide access to the set.
Public class | DocIdSet..::..AnonymousClassDocIdSet
Public class | DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator
Public class DocIdSetIterator
This abstract class defines methods to iterate over a set of non-decreasing doc ids. Note that this class assumes it iterates on doc Ids, and therefore {@link #NO_MORE_DOCS} is set to {@value #NO_MORE_DOCS} in order to be used as a sentinel object. Implementations of this class are expected to consider {@link Integer#MAX_VALUE} as an invalid value.
Public class | DuplicateFilter
Public class Explanation
Expert: Describes the score computation for document and query.
Public class Explanation..::..IDFExplanation
Small Util class used to pass both an idf factor as well as an explanation for that factor. This class will likely be held on a {@link Weight}, so be aware before storing any large or un-serializable fields.
Public class | Extensions
Public class FieldCacheRangeFilter
A range filter built on top of a cached single term field (in {@link FieldCache}).

FieldCacheRangeFilter builds a single cache for the field the first time it is used. Each subsequent FieldCacheRangeFilter on the same field then reuses this cache, even if the range itself changes.

This means that FieldCacheRangeFilter is much faster (sometimes more than 100x as fast) as building a {@link TermRangeFilter} (or {@link ConstantScoreRangeQuery} on a {@link TermRangeFilter}) for each query, if using a {@link #newStringRange}. However, if the range never changes it is slower (around 2x as slow) than building a CachingWrapperFilter on top of a single TermRangeFilter. For numeric data types, this filter may be significantly faster than {@link NumericRangeFilter}. Furthermore, it does not need the numeric values encoded by {@link NumericField}. But it has the problem that it only works with exact one value/document (see below).

As with all {@link FieldCache} based functionality, FieldCacheRangeFilter is only valid for fields which exact one term for each document (except for {@link #newStringRange} where 0 terms are also allowed). Due to a restriction of {@link FieldCache}, for numeric ranges all terms that do not have a numeric value, 0 is assumed.

Thus it works on dates, prices and other single value fields but will not work on regular text fields. It is preferable to use a

CopyC#
NOT_ANALYZED
field to ensure that there is only a single term.

This class does not have an constructor, use one of the static factory methods available, that create a correct instance for different data types supported by {@link FieldCache}.

Public class FieldCacheTermsFilter
A {@link Filter} that only accepts documents whose single term value in the specified field is contained in the provided set of allowed terms.

This is the same functionality as TermsFilter (from contrib/queries), except this filter requires that the field contains only a single term for all documents. Because of drastically different implementations, they also have different performance characteristics, as described below.

The first invocation of this filter on a given field will be slower, since a {@link FieldCache.StringIndex} must be created. Subsequent invocations using the same field will re-use this cache. However, as with all functionality based on {@link FieldCache}, persistent RAM is consumed to hold the cache, and is not freed until the {@link IndexReader} is closed. In contrast, TermsFilter has no persistent RAM consumption.

With each search, this filter translates the specified set of Terms into a private {@link OpenBitSet} keyed by term number per unique {@link IndexReader} (normally one reader per segment). Then, during matching, the term number for each docID is retrieved from the cache and then checked for inclusion using the {@link OpenBitSet}. Since all testing is done using RAM resident data structures, performance should be very fast, most likely fast enough to not require further caching of the DocIdSet for each possible combination of terms. However, because docIDs are simply scanned linearly, an index with a great many small documents may find this linear scan too costly.

In contrast, TermsFilter builds up an {@link OpenBitSet}, keyed by docID, every time it's created, by enumerating through all matching docs using {@link TermDocs} to seek and scan through each term's docID list. While there is no linear scan of all docIDs, besides the allocation of the underlying array in the {@link OpenBitSet}, this approach requires a number of "disk seeks" in proportion to the number of terms, which can be exceptionally costly when there are cache misses in the OS's IO cache.

Generally, this filter will be slower on the first invocation for a given field, but subsequent invocations, even if you change the allowed set of Terms, should be faster than TermsFilter, especially as the number of Terms being matched increases. If you are matching only a very small number of terms, and those terms in turn match a very small number of documents, TermsFilter may perform faster.

Which filter is best is very application dependent.

Protected class | FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet
Protected class | FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator
Public class FieldComparator
Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class FieldComparator..::..ByteComparator
Parses field's values as byte (using {@link FieldCache#getBytes} and sorts by ascending value
Public class FieldComparator..::..DocComparator
Sorts by ascending docID
Public class FieldComparator..::..DoubleComparator
Parses field's values as double (using {@link FieldCache#getDoubles} and sorts by ascending value
Public class FieldComparator..::..FloatComparator
Parses field's values as float (using {@link FieldCache#getFloats} and sorts by ascending value
Public class FieldComparator..::..IntComparator
Parses field's values as int (using {@link FieldCache#getInts} and sorts by ascending value
Public class FieldComparator..::..LongComparator
Parses field's values as long (using {@link FieldCache#getLongs} and sorts by ascending value
Public class FieldComparator..::..RelevanceComparator
Sorts by descending relevance. NOTE: if you are sorting only by descending relevance and then secondarily by ascending docID, peformance is faster using {@link TopScoreDocCollector} directly (which {@link IndexSearcher#search} uses when no {@link Sort} is specified).
Public class FieldComparator..::..ShortComparator
Parses field's values as short (using {@link FieldCache#getShorts} and sorts by ascending value
Public class FieldComparator..::..StringComparatorLocale
Sorts by a field's value using the Collator for a given Locale.
Public class FieldComparator..::..StringOrdValComparator
Sorts by field's natural String sort order, using ordinals. This is functionally equivalent to {@link StringValComparator}, but it first resolves the string to their relative ordinal positions (using the index returned by {@link FieldCache#getStringIndex}), and does most comparisons using the ordinals. For medium to large results, this comparator will be much faster than {@link StringValComparator}. For very small result sets it may be slower.
Public class FieldComparator..::..StringValComparator
Sorts by field's natural String sort order. All comparisons are done using String.compareTo, which is slow for medium to large result sets but possibly very fast for very small results sets.
Public class FieldComparatorSource
Provides a {@link FieldComparator} for custom field sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class FieldDoc
Expert: A ScoreDoc which also contains information about how to sort the referenced document. In addition to the document number and score, this object contains an array of values for the document from the field(s) used to sort. For example, if the sort criteria was to sort by fields "a", "b" then "c", the
CopyC#
fields
 object array will have three elements, corresponding respectively to the term values for the document in fields "a", "b" and "c". The class of each element in the array will be either Integer, Float or String depending on the type of values in the terms of each field.

Created: Feb 11, 2004 1:23:38 PM

Public class FieldSortedHitQueue Obsolete.
Expert: A hit queue for sorting by hits by terms in more than one field. Uses
CopyC#
FieldCache.DEFAULT
 for maintaining internal term lookup tables.

Created: Dec 8, 2003 12:56:03 PM

Public class FieldValueHitQueue
Expert: A hit queue for sorting by hits by terms in more than one field. Uses
CopyC#
FieldCache.DEFAULT
 for maintaining internal term lookup tables. This class will not resolve SortField.AUTO types, and expects the type of all SortFields used for construction to already have been resolved. {@link SortField#DetectFieldType(IndexReader, String)} is a utility method which may be used for field type detection. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public class Filter
Abstract base class for restricting which documents may be returned during searching.

Note: In Lucene 3.0 {@link #Bits(IndexReader)} will be removed and {@link #GetDocIdSet(IndexReader)} will be defined as abstract. All implementing classes must therefore implement {@link #GetDocIdSet(IndexReader)} in order to work with Lucene 3.0.

Public class FilteredDocIdSet
Abstract decorator class for a DocIdSet implementation that provides on-demand filtering/validation mechanism on a given DocIdSet.

Technically, this same functionality could be achieved with ChainedFilter (under contrib/misc), however the benefit of this class is it never materializes the full bitset for the filter. Instead, the {@link #match} method is invoked on-demand, per docID visited during searching. If you know few docIDs will be visited, and the logic behind {@link #match} is relatively costly, this may be a better way to filter than ChainedFilter.

Public class FilteredDocIdSetIterator
Abstract decorator class of a DocIdSetIterator implementation that provides on-demand filter/validation mechanism on an underlying DocIdSetIterator. See {@link FilteredDocIdSet}.
Public class FilteredQuery
A query that applies a filter to the results of another query.

Note: the bits are retrieved from the filter each time this query is used in a search - use a CachingWrapperFilter to avoid regenerating the bits every time.

Created: Apr 20, 2004 8:58:29 AM

Public class FilteredTermEnum
Abstract class for enumerating a subset of all terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Public class FilterManager
Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.
Protected class FilterManager..::..FilterCleaner
Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.
Protected class FilterManager..::..FilterItem
Holds the filter and the last time the filter was used, to make LRU-based cache cleaning possible. TODO: Clean this up when we switch to Java 1.5
Public class FuzzyLikeThisQuery
Fuzzifies ALL terms provided as strings and then picks the best n differentiating terms. In effect this mixes the behaviour of FuzzyQuery and MoreLikeThis but with special consideration of fuzzy scoring factors. This generally produces good results for queries where users may provide details in a number of fields and have no knowledge of boolean query syntax and also want a degree of fuzzy matching and a fast query. For each source term the fuzzy variants are held in a BooleanQuery with no coord factor (because we are not looking for matches on multiple variants in any one doc). Additionally, a specialized TermQuery is used for variants and does not use that variant term's IDF because this would favour rarer terms eg misspellings. Instead, all variants use the same IDF ranking (the one for the source query term) and this is factored into the variant's boost. If the source query term does not exist in the index the average IDF of the variants is used.
Public class FuzzyQuery
Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.
Protected class | FuzzyQuery..::..ScoreTerm
Protected class | FuzzyQuery..::..ScoreTermQueue
Public class FuzzyTermEnum
Subclass of FilteredTermEnum for enumerating all terms that are similiar to the specified filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Public class Hit Obsolete.
Wrapper used by {@link HitIterator} to provide a lazily loaded hit from {@link Hits}.
Public class HitCollector Obsolete.
Lower-level search API.
HitCollectors are primarily meant to be used to implement queries, sorting and filtering. See {@link Collector} for a lower level and higher performance (on a multi-segment index) API.
Public class HitCollectorWrapper Obsolete.
Wrapper for ({@link HitCollector}) implementations, which simply re-bases the incoming docID before calling {@link HitCollector#collect}.
Public class HitIterator Obsolete.
An iterator over {@link Hits} that provides lazy fetching of each document. {@link Hits#Iterator()} returns an instance of this class. Calls to {@link #next()} return a {@link Hit} instance.
Public class | HitQueue
Public class Hits Obsolete.
A ranked list of documents, used to hold search results.

Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using the search method that takes a {@link HitCollector}.

Note: Deleting matching documents concurrently with traversing the hits, might, when deleting hits that were not yet retrieved, decrease {@link #Length()}. In such case, {@link java.util.ConcurrentModificationException ConcurrentModificationException} is thrown when accessing hit

CopyC#
n
> current_{@link #Length()} (but
CopyC#
n
 < {@link #Length()} _at_start).
Public class IndexSearcher
Implements search over a single IndexReader.

Applications usually need only call the inherited {@link #Search(Query)} or {@link #Search(Query,Filter)} methods. For performance reasons it is recommended to open only one IndexSearcher and use it for all of your searches.

Note that you can only access Hits from an IndexSearcher as long as it is not yet closed, otherwise an IOException will be thrown.

NOTE: {@link

CopyC#
IndexSearcher
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexSearcher
 instance; use your own (non-Lucene) objects instead.

Public class MatchAllDocsQuery
A query that matches all documents.
Public class MultiPhraseQuery
MultiPhraseQuery is a generalized version of PhraseQuery, with an added method {@link #Add(Term[])}. To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that have "app" as prefix using IndexReader.terms(Term), and use MultiPhraseQuery.add(Term[] terms) to add them to the query.
Public class MultiSearcher
Implements search over a set of
CopyC#
Searchables
.

Applications usually need only call the inherited {@link #Search(Query)} or {@link #Search(Query,Filter)} methods.

Public class MultiTermQuery
An abstract {@link Query} that matches documents containing a subset of terms provided by a {@link FilteredTermEnum} enumeration.

This query cannot be used directly; you must subclass it and define {@link #getEnum} to provide a {@link FilteredTermEnum} that iterates through the terms to be matched.

NOTE: if {@link #setRewriteMethod} is either {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} or {@link #SCORING_BOOLEAN_QUERY_REWRITE}, you may encounter a {@link BooleanQuery.TooManyClauses} exception during searching, which happens when the number of terms to be searched exceeds {@link BooleanQuery#GetMaxClauseCount()}. Setting {@link #setRewriteMethod} to {@link #CONSTANT_SCORE_FILTER_REWRITE} prevents this.

The recommended rewrite method is {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}: it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that {@link QueryParser} produces MultiTermQueries using {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} by default.

Public class | MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite
Public class MultiTermQuery..::..ConstantScoreAutoRewrite
A rewrite method that tries to pick the best constant-score rewrite method based on term and document counts from the query. If both the number of terms and documents is small enough, then {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} is used. Otherwise, {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.
Public class MultiTermQuery..::..RewriteMethod
Abstract class that defines how the query is rewritten.
Public class MultiTermQueryWrapperFilter
A wrapper for {@link MultiTermQuery}, that exposes its functionality as a {@link Filter}.

CopyC#
MultiTermQueryWrapperFilter
is not designed to be used by itself. Normally you subclass it to provide a Filter counterpart for a {@link MultiTermQuery} subclass.

For example, {@link TermRangeFilter} and {@link PrefixFilter} extend

CopyC#
MultiTermQueryWrapperFilter
. This class also provides the functionality behind {@link MultiTermQuery#CONSTANT_SCORE_FILTER_REWRITE}; this is why it is not abstract.
Public class NumericRangeFilter
A {@link Filter} that only accepts numeric values within a specified range. To use this, you must first index the numeric values using {@link NumericField} (expert: {@link NumericTokenStream}).

You create a new NumericRangeFilter with the static factory methods, eg:

            Filter f = NumericRangeFilter.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
accepts all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive. See {@link NumericRangeQuery} for details on how Lucene indexes and searches numeric valued fields.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class NumericRangeQuery

A {@link Query} that matches numeric values within a specified range. To use this, you must first index the numeric values using {@link NumericField} (expert: {@link NumericTokenStream}). If your terms are instead textual, you should use {@link TermRangeQuery}. {@link NumericRangeFilter} is the filter equivalent of this query.

You create a new NumericRangeQuery with the static factory methods, eg:

            Query q = NumericRangeQuery.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
matches all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive.

The performance of NumericRangeQuery is much better than the corresponding {@link TermRangeQuery} because the number of terms that must be searched is usually far fewer, thanks to trie indexing, described below.

You can optionally specify a

CopyC#
precisionStep
when creating this query. This is necessary if you've changed this configuration from its default (4) during indexing. Lower values consume more disk space but speed up searching. Suitable values are between 1 and 8. A good starting point to test is 4, which is the default value for all
CopyC#
Numeric*
 classes. See below for details.

This query defaults to {@linkplain MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} for 32 bit (int/float) ranges with precisionStep <8 and 64 bit (long/double) ranges with precisionStep <6. Otherwise it uses {@linkplain MultiTermQuery#CONSTANT_SCORE_FILTER_REWRITE} as the number of terms is likely to be high. With precision steps of <4, this query can be run with one of the BooleanQuery rewrite methods without changing BooleanQuery's default max clause count.

NOTE: This API is experimental and might change in incompatible ways in the next release.

How it works

See the publication about panFMP, where this algorithm was described (referred to as

CopyC#
TrieRangeQuery
):
Schindler, U, Diepenbroek, M, 2008. Generic XML-based Framework for Metadata Portals. Computers & Geosciences 34 (12), 1947-1955. doi:10.1016/j.cageo.2008.02.023

A quote from this paper: Because Apache Lucene is a full-text search engine and not a conventional database, it cannot handle numerical ranges (e.g., field value is inside user defined bounds, even dates are numerical values). We have developed an extension to Apache Lucene that stores the numerical values in a special string-encoded format with variable precision (all numerical values like doubles, longs, floats, and ints are converted to lexicographic sortable string representations and stored with different precisions (for a more detailed description of how the values are stored, see {@link NumericUtils}). A range is then divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

For the variant that stores long values in 8 different precisions (each reduced by 8 bits) that uses a lowest precision of 1 byte, the index contains only a maximum of 256 distinct values in the lowest precision. Overall, a range could consist of a theoretical maximum of

CopyC#
7*255*2 + 255 = 3825
distinct terms (when there is a term for every distinct value of an 8-byte-number in the index and the range covers almost all of them; a maximum of 255 distinct values is used because it would always be possible to reduce the full 256 values to one term with degraded precision). In practice, we have seen up to 300 terms in most cases (index with 500,000 metadata records and a uniform value distribution).

Precision Step

You can choose any

CopyC#
precisionStep
when encoding values. Lower step values mean more precisions and so more terms in index (and index gets larger). On the other hand, the maximum number of terms to match reduces, which optimized query speed. The formula to calculate the maximum term count is:
            n = [ (bitsPerValue/precisionStep - 1) * (2^precisionStep - 1 ) * 2 ] + (2^precisionStep - 1 )

(this formula is only correct, when

CopyC#
bitsPerValue/precisionStep
is an integer; in other cases, the value must be rounded up and the last summand must contain the modulo of the division as precision step). For longs stored using a precision step of 4,
CopyC#
n = 15*15*2 + 15 = 465
, and for a precision step of 2,
CopyC#
n = 31*3*2 + 3 = 189
. But the faster search speed is reduced by more seeking in the term enum of the index. Because of this, the ideal
CopyC#
precisionStep
 value can only be found out by testing. Important: You can index with a lower precision step value and test search speed using a multiple of the original step value.

Good values for

CopyC#
precisionStep
are depending on usage and data type:
  • The default for all data types is 4, which is used, when no
    CopyC#
    precisionStep
     is given.
  • Ideal value in most cases for 64 bit data types (long, double) is 6 or 8.
  • Ideal value in most cases for 32 bit data types (int, float) is 4.
  • Steps >64 for long/double and >32 for int/float produces one token per value in the index and querying is as slow as a conventional {@link TermRangeQuery}. But it can be used to produce fields, that are solely used for sorting (in this case simply use {@link Integer#MAX_VALUE} as
    CopyC#
    precisionStep
    ). Using {@link NumericField NumericFields} for sorting is ideal, because building the field cache is much faster than with text-only numbers. Sorting is also possible with range query optimized fields using one of the above
    CopyC#
    precisionSteps
    .

Comparisons of the different types of RangeQueries on an index with about 500,000 docs showed that {@link TermRangeQuery} in boolean rewrite mode (with raised {@link BooleanQuery} clause count) took about 30-40 secs to complete, {@link TermRangeQuery} in constant score filter rewrite mode took 5 secs and executing this class took <100ms to complete (on an Opteron64 machine, Java 1.5, 8 bit precision step). This query type was developed for a geographic portal, where the performance for e.g. bounding boxes or exact date/time stamps is important.

Public class ParallelMultiSearcher
Implements parallel search over a set of
CopyC#
Searchables
.

Applications usually need only call the inherited {@link #Search(Query)} or {@link #Search(Query,Filter)} methods.

Public class PhraseQuery
A Query that matches documents containing a particular sequence of terms. A PhraseQuery is built by QueryParser for input like
CopyC#
"new york"
.

This query may be combined with other terms or queries with a {@link BooleanQuery}.

Public class PositiveScoresOnlyCollector
A {@link Collector} implementation which wraps another {@link Collector} and makes sure only documents with scores > 0 are collected.
Public class PrefixFilter
A Filter that restricts search results to values that have a matching prefix in a given field.
Public class PrefixQuery
A Query that matches documents containing terms with a specified prefix. A PrefixQuery is built by QueryParser for input like
CopyC#
app*
.

This query uses the {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} rewrite method.

Public class PrefixTermEnum
Subclass of FilteredTermEnum for enumerating all terms that match the specified prefix filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Public class Query
The abstract base class for queries.

Instantiable subclasses are:

  • {@link TermQuery}
  • {@link MultiTermQuery}
  • {@link BooleanQuery}
  • {@link WildcardQuery}
  • {@link PhraseQuery}
  • {@link PrefixQuery}
  • {@link MultiPhraseQuery}
  • {@link FuzzyQuery}
  • {@link TermRangeQuery}
  • {@link NumericRangeQuery}
  • {@link Lucene.Net.Search.Spans.SpanQuery}

A parser for queries is contained in:

  • {@link Lucene.Net.QueryParsers.QueryParser QueryParser}
Public class QueryFilter Obsolete.
Constrains search results to only match those which also match a provided query. Results are cached, so that searches after the first on the same index using this filter are much faster.
Public class QueryTermVector
Public class QueryWrapperFilter
Constrains search results to only match those which also match a provided query.

This could be used, for example, with a {@link TermRangeQuery} on a suitably formatted date field to implement date filtering. One could re-use a single QueryFilter that matches, e.g., only documents modified within the last week. The QueryFilter and TermRangeQuery would only need to be reconstructed once per day.

Public class RangeFilter Obsolete.
A Filter that restricts search results to a range of values in a given field.

This filter matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeFilter} instead.

If you construct a large number of range filters with different ranges but on the same field, {@link FieldCacheRangeFilter} may have significantly better performance.

Public class RangeQuery Obsolete.
A Query that matches documents within an exclusive range of terms.

This query matches the documents looking for terms that fall into the supplied range according to {@link Term#CompareTo(Term)}. It is not intended for numerical ranges, use {@link NumericRangeQuery} instead.

This query uses {@linkplain MultiTermQuery#SCORING_BOOLEAN_QUERY_REWRITE}. If you want to change this, use the new {@link TermRangeQuery} instead.

Public class ScoreCachingWrappingScorer
A {@link Scorer} which wraps another scorer and caches the score of the current document. Successive calls to {@link #Score()} will return the same result and will not invoke the wrapped Scorer's score() method, unless the current document has changed.
This class might be useful due to the changes done to the {@link Collector} interface, in which the score is not computed for a document by default, only if the collector requests it. Some collectors may need to use the score in several places, however all they have in hand is a {@link Scorer} object, and might end up computing the score of a document more than once.
Public class ScoreDoc
Expert: Returned by low-level search implementations.
Public class Scorer
Expert: Common scoring functionality for different types of queries.

A

CopyC#
Scorer
iterates over documents matching a query in increasing order of doc Id.

Document scores are computed using a given

CopyC#
Similarity
implementation.

NOTE: The values Float.Nan, Float.NEGATIVE_INFINITY and Float.POSITIVE_INFINITY are not valid scores. Certain collectors (eg {@link TopScoreDocCollector}) will not properly collect hits with these scores.

Public class Searcher
An abstract base class for search implementations. Implements the main search methods.

Note that you can only access hits from a Searcher as long as it is not yet closed, otherwise an IOException will be thrown.

Public class Similarity
Expert: Scoring API.

Subclasses implement search scoring.

The score of query

CopyC#
q
for document
CopyC#
d
 correlates to the cosine-distance or dot-product between document and query vectors in a Vector Space Model (VSM) of Information Retrieval. A document whose vector is closer to the query vector in that model is scored higher. The score is computed as follows:

score(q,d) = coord(q,d) · queryNorm(q) · | ∑ | (tf(t in d) · idf(t)2 · t.getBoost() · norm(t,d))
 | t in q |

where

  1. tf(t in d) correlates to the term's frequency, defined as the number of times term t appears in the currently scored document d. Documents that have more occurrences of a given term receive a higher score. The default computation for tf(t in d) in {@link Lucene.Net.Search.DefaultSimilarity#Tf(float) DefaultSimilarity} is:

    {@link Lucene.Net.Search.DefaultSimilarity#Tf(float) tf(t in d)} = frequency½

  2. idf(t) stands for Inverse Document Frequency. This value correlates to the inverse of docFreq (the number of documents in which the term t appears). This means rarer terms give higher contribution to the total score. The default computation for idf(t) in {@link Lucene.Net.Search.DefaultSimilarity#Idf(int, int) DefaultSimilarity} is:

    {@link Lucene.Net.Search.DefaultSimilarity#Idf(int, int) idf(t)} = 1 + log (
    numDocs
    –––––––––
    docFreq+1
            )

  3. coord(q,d) is a score factor based on how many of the query terms are found in the specified document. Typically, a document that contains more of the query's terms will receive a higher score than another document with fewer query terms. This is a search time factor computed in {@link #Coord(int, int) coord(q,d)} by the Similarity in effect at search time.

  4. queryNorm(q) is a normalizing factor used to make scores between queries comparable. This factor does not affect document ranking (since all ranked documents are multiplied by the same factor), but rather just attempts to make scores from different queries (or even different indexes) comparable. This is a search time factor computed by the Similarity in effect at search time. The default computation in {@link Lucene.Net.Search.DefaultSimilarity#QueryNorm(float) DefaultSimilarity} is:

    queryNorm(q) = {@link Lucene.Net.Search.DefaultSimilarity#QueryNorm(float) queryNorm(sumOfSquaredWeights)} =
    1
    ––––––––––––––
    sumOfSquaredWeights½

    The sum of squared weights (of the query terms) is computed by the query {@link Lucene.Net.Search.Weight} object. For example, a {@link Lucene.Net.Search.BooleanQuery boolean query} computes this value as:

    {@link Lucene.Net.Search.Weight#SumOfSquaredWeights() sumOfSquaredWeights} = {@link Lucene.Net.Search.Query#GetBoost() q.getBoost()} 2 · ∑ (idf(t) · t.getBoost()) 2
    t in q

  5. t.getBoost() is a search time boost of term t in the query q as specified in the query text (see query syntax), or as set by application calls to {@link Lucene.Net.Search.Query#SetBoost(float) setBoost()}. Notice that there is really no direct API for accessing a boost of one term in a multi term query, but rather multi terms are represented in a query as multi {@link Lucene.Net.Search.TermQuery TermQuery} objects, and so the boost of a term in the query is accessible by calling the sub-query {@link Lucene.Net.Search.Query#GetBoost() getBoost()}.

  6. norm(t,d) encapsulates a few (indexing time) boost and length factors:
    • Document boost - set by calling {@link Lucene.Net.Documents.Document#SetBoost(float) doc.setBoost()} before adding the document to the index.
    • Field boost - set by calling {@link Lucene.Net.Documents.Fieldable#SetBoost(float) field.setBoost()} before adding the field to a document.
    • {@link #LengthNorm(String, int) lengthNorm(field)} - computed when the document is added to the index in accordance with the number of tokens of this field in the document, so that shorter fields contribute more to the score. LengthNorm is computed by the Similarity class in effect at indexing.

    When a document is added to the index, all the above factors are multiplied. If the document has multiple fields with the same name, all their boosts are multiplied together:

    norm(t,d) = {@link Lucene.Net.Documents.Document#GetBoost() doc.getBoost()} · {@link #LengthNorm(String, int) lengthNorm(field)} · ∏ {@link Lucene.Net.Documents.Fieldable#GetBoost() f.getBoost}()
    field f in d named as t

    However the resulted norm value is {@link #EncodeNorm(float) encoded} as a single byte before being stored. At search time, the norm byte value is read from the index {@link Lucene.Net.Store.Directory directory} and {@link #DecodeNorm(byte) decoded} back to a float norm value. This encoding/decoding, while reducing index size, comes with the price of precision loss - it is not guaranteed that decode(encode(x)) = x. For instance, decode(encode(0.89)) = 0.75. Also notice that search time is too late to modify this norm part of scoring, e.g. by using a different {@link Similarity} for search.

Public class SimilarityDelegator
Expert: Delegating scoring implementation. Useful in {@link Query#GetSimilarity(Searcher)} implementations, to override only certain methods of a Searcher's Similiarty implementation..
Public class | SimpleFacetedSearch
Public class | SimpleFacetedSearch..::..FacetName
Public class | SimpleFacetedSearch..::..Hits
Public class | SimpleFacetedSearch..::..HitsPerFacet
Public class Sort
Encapsulates sort criteria for returned hits.

The fields used to determine sort order must be carefully chosen. Documents must contain a single term in such a field, and the value of the term should indicate the document's relative position in a given sort order. The field must be indexed, but should not be tokenized, and does not need to be stored (unless you happen to want it back with the rest of your document data). In other words:

CopyC#
document.add (new Field ("byNumber", Integer.toString(x), Field.Store.NO, Field.Index.NOT_ANALYZED));

Valid Types of Values

There are four possible kinds of term values which may be put into sorting fields: Integers, Longs, Floats, or Strings. Unless {@link SortField SortField} objects are specified, the type of value in the field is determined by parsing the first term in the field.

Integer term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range

CopyC#
Integer.MIN_VALUE
and
CopyC#
Integer.MAX_VALUE
 inclusive. Documents which should appear first in the sort should have low value integers, later documents high values (i.e. the documents should be numbered
CopyC#
1..n
 where
CopyC#
1
 is the first and
CopyC#
n
 the last).

Long term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range

CopyC#
Long.MIN_VALUE
and
CopyC#
Long.MAX_VALUE
 inclusive. Documents which should appear first in the sort should have low value integers, later documents high values.

Float term values should conform to values accepted by {@link Float Float.valueOf(String)} (except that

CopyC#
NaN
and
CopyC#
Infinity
 are not supported). Documents which should appear first in the sort should have low values, later documents high values.

String term values can contain any valid String, but should not be tokenized. The values are sorted according to their {@link Comparable natural order}. Note that using this type of term value has higher memory requirements than the other two types.

Object Reuse

One of these objects can be used multiple times and the sort order changed between usages.

This class is thread safe.

Memory Usage

Sorting uses of caches of term values maintained by the internal HitQueue(s). The cache is static and contains an integer or float array of length

CopyC#
IndexReader.maxDoc()
for each field name for which a sort is performed. In other words, the size of the cache in bytes is:

CopyC#
4 * IndexReader.maxDoc() * (# of different fields actually used to sort)

For String fields, the cache is larger: in addition to the above array, the value of every term in the field is kept in memory. If there are many unique terms in the field, this could be quite large.

Note that the size of the cache is not affected by how many fields are in the index and might be used to sort - only by the ones actually used to sort a result set.

Created: Feb 12, 2004 10:53:57 AM

Public class SortComparator Obsolete.
Abstract base class for sorting hits returned by a Query.

This class should only be used if the other SortField types (SCORE, DOC, STRING, INT, FLOAT) do not provide an adequate sorting. It maintains an internal cache of values which could be quite large. The cache is an array of Comparable, one for each document in the index. There is a distinct Comparable for each unique term in the field - if some documents have the same term in the field, the cache array will have entries which reference the same Comparable. This class will be used as part of a key to a FieldCache value. You must implement hashCode and equals to avoid an explosion in RAM usage if you use instances that are not the same instance. If you are searching using the Remote contrib, the same instance of this class on the client will be a new instance on every call to the server, so hashCode/equals is very important in that situation.

Created: Apr 21, 2004 5:08:38 PM

Public class SortField
Stores information about how to sort documents by terms in an individual field. Fields must be indexed in order to sort by them.

Created: Feb 11, 2004 1:25:29 PM

Public class SpanFilter
Abstract base class providing a mechanism to restrict searches to a subset of an index and also maintains and returns position information. This is useful if you want to compare the positions from a SpanQuery with the positions of items in a filter. For instance, if you had a SpanFilter that marked all the occurrences of the word "foo" in documents, and then you entered a new SpanQuery containing bar, you could not only filter by the word foo, but you could then compare position information for post processing.
Public class SpanFilterResult
The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.

Public class | SpanFilterResult..::..PositionInfo
Public class | SpanFilterResult..::..StartEnd
Public class SpanQueryFilter
Constrains search results to only match those which also match a provided query. Also provides position information about where each document matches at the cost of extra space compared with the QueryWrapperFilter. There is an added cost to this above what is stored in a {@link QueryWrapperFilter}. Namely, the position information for each matching document is stored.

This filter does not cache. See the {@link Lucene.Net.Search.CachingSpanFilter} for a wrapper that caches.

Public class StringIndex
Expert: Stores term text values and document ordering data.
Public class TermQuery
A Query that matches documents containing a term. This may be combined with other terms with a {@link BooleanQuery}.
Public class TermRangeFilter
A Filter that restricts search results to a range of values in a given field.

This filter matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeFilter} instead.

If you construct a large number of range filters with different ranges but on the same field, {@link FieldCacheRangeFilter} may have significantly better performance.

Public class TermRangeQuery
A Query that matches documents within an exclusive range of terms.

This query matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeQuery} instead.

This query uses the {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} rewrite method.

Public class TermRangeTermEnum
Subclass of FilteredTermEnum for enumerating all terms that match the specified range parameters.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Public class TermScorer
Expert: A
CopyC#
Scorer
 for documents matching a
CopyC#
Term
.
Public class TermsFilter
A filter that contains multiple terms.
Public class TimeLimitedCollector Obsolete.

The TimeLimitedCollector is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a TimeExceeded Exception.

Public class TimeLimitedCollector..::..TimeExceededException
Thrown when elapsed search time exceeds allowed search time.
Public class TimeLimitingCollector
The {@link TimeLimitingCollector} is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a {@link TimeExceededException}.
Public class TimeLimitingCollector..::..TimeExceededException
Thrown when elapsed search time exceeds allowed search time.
Public class TopDocCollector Obsolete.
A {@link HitCollector} implementation that collects the top-scoring documents, returning them as a {@link TopDocs}. This is used by {@link IndexSearcher} to implement {@link TopDocs}-based search.

This may be extended, overriding the collect method to, e.g., conditionally invoke

CopyC#
super()
in order to filter which documents are collected.
Public class TopDocs
Represents hits returned by {@link * Searcher#search(Query,Filter,int)} and {@link * Searcher#search(Query,int)
Public class TopDocsCollector
A base class for all collectors that return a {@link TopDocs} output. This collector allows easy extension by providing a single constructor which accepts a {@link PriorityQueue} as well as protected members for that priority queue and a counter of the number of total hits.
Extending classes can override {@link #TopDocs(int, int)} and {@link #GetTotalHits()} in order to provide their own implementation.
Public class TopFieldCollector
A {@link Collector} that sorts by {@link SortField} using {@link FieldComparator}s.

See the {@link #create(Lucene.Net.Search.Sort, int, boolean, boolean, boolean, boolean)} method for instantiating a TopFieldCollector.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class TopFieldDocCollector Obsolete.
A {@link HitCollector} implementation that collects the top-sorting documents, returning them as a {@link TopFieldDocs}. This is used by {@link IndexSearcher} to implement {@link TopFieldDocs}-based search.

This may be extended, overriding the collect method to, e.g., conditionally invoke

CopyC#
super()
in order to filter which documents are collected.
Public class TopFieldDocs
Represents hits returned by {@link Searcher#search(Query,Filter,int,Sort)}.
Public class TopScoreDocCollector
A {@link Collector} implementation that collects the top-scoring hits, returning them as a {@link TopDocs}. This is used by {@link IndexSearcher} to implement {@link TopDocs}-based search. Hits are sorted by score descending and then (when the scores are tied) docID ascending. When you create an instance of this collector you should know in advance whether documents are going to be collected in doc Id order or not.

NOTE: The values {@link Float#NaN} and {Float#NEGATIVE_INFINITY} are not valid scores. This collector will not properly collect hits with such scores.

Public class Weight
Expert: Calculate query weights and build query scorers.

The purpose of {@link Weight} is to ensure searching does not modify a {@link Query}, so that a {@link Query} instance can be reused.
{@link Searcher} dependent state of the query should reside in the {@link Weight}.
{@link IndexReader} dependent state should reside in the {@link Scorer}.

A

CopyC#
Weight
is used in the following way:
  1. A
    CopyC#
    Weight
     is constructed by a top-level query, given a
    CopyC#
    Searcher
     ({@link Query#CreateWeight(Searcher)}).
  2. The {@link #SumOfSquaredWeights()} method is called on the
    CopyC#
    Weight
     to compute the query normalization factor {@link Similarity#QueryNorm(float)} of the query clauses contained in the query.
  3. The query normalization factor is passed to {@link #Normalize(float)}. At this point the weighting is complete.
  4. A
    CopyC#
    Scorer
     is constructed by {@link #Scorer(IndexReader,boolean,boolean)}.
Public class WildcardQuery
Implements the wildcard search query. Supported wildcards are
CopyC#
*
, which matches any character sequence (including the empty one), and
CopyC#
?
, which matches any single character. Note this query can be slow, as it needs to iterate over many terms. In order to prevent extremely slow WildcardQueries, a Wildcard term should not start with one of the wildcards
CopyC#
*
 or
CopyC#
?
.

This query uses the {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} rewrite method.

Public class WildcardTermEnum
Subclass of FilteredTermEnum for enumerating all terms that match the specified wildcard filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Structures

 | Structure | Description
Public structure | FieldCache_Fields |
Public structure | ScoreDocComparator_Fields | Obsolete. Expert: Compares two ScoreDoc objects for sorting. Created: Feb 3, 2004 9:00:16 AM

Interfaces

 | Interface | Description
Public interface | ByteParser | Interface to parse bytes from document fields.
Public interface | DoubleParser | Obsolete. Interface to parse doubles from document fields.
Public interface | FieldCache |
Public interface | FloatParser | Interface to parse floats from document fields.
Public interface | IntParser | Interface to parse ints from document fields.
Public interface | LongParser | Obsolete. Interface to parse long from document fields.
Public interface | Parser | Marker interface as super-interface to all parsers. It is used to specify a custom parser to {@link SortField#SortField(String, FieldCache.Parser)}.
Public interface | ScoreDocComparator |
Public interface | Searchable | The interface for search implementations. Searchable is the abstract network protocol for searching. Implementations provide search over a single index, over multiple indices, and over indices on remote servers. Queries, filters and sort criteria are designed to be compact so that they may be efficiently passed to a remote index, with only the top-scoring hits being returned, rather than every matching hit. NOTE: this interface is kept public for convenience. Since it is not expected to be implemented directly, it may be changed unexpectedly between releases.
Public interface | ShortParser | Interface to parse shorts from document fields.
Public interface | SortComparatorSource | Obsolete. Expert: returns a comparator for sorting ScoreDocs. Created: Apr 21, 2004 3:49:28 PM This class will be used as part of a key to a FieldCache value. You must implement hashCode and equals to avoid an explosion in RAM usage if you use instances that are not the same instance. If you are searching using the Remote contrib, the same instance of this class on the client will be a new instance on every call to the server, so hashCode/equals is very important in that situation.


BooleanClause Class

[image]

Lucene.Net Class Libraries
BooleanClause Class
Members See Also Send Feedback
A clause in a BooleanQuery.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class BooleanClause
Visual Basic
<SerializableAttribute> _
Public Class BooleanClause
Visual C++
[SerializableAttribute]
public ref class BooleanClause

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..BooleanClause

See Also

BooleanClause Members
Lucene.Net.Search Namespace


BooleanClause Members

[image] [image]

Lucene.Net Class Libraries
BooleanClause Members
BooleanClause Class Constructors Methods See Also Send Feedback

The BooleanClause type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanClause | Constructs a BooleanClause.

Methods

Name | Description
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Object..::..GetHashCode()()()().)
Public method | GetOccur
Public method | GetQuery
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | IsProhibited
Public method | IsRequired
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | SetOccur
Public method | SetQuery
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

BooleanClause Class
Lucene.Net.Search Namespace


BooleanClause Constructor

[image]

Lucene.Net Class Libraries
BooleanClause Constructor
BooleanClause Class See Also Send Feedback
Constructs a BooleanClause.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BooleanClause(
    Query query,
    BooleanClause..::..Occur occur
)
Visual Basic
Public Sub New ( _
    query As Query, _
    occur As BooleanClause..::..Occur _
)
Visual C++
public:
BooleanClause(
    Query^ query,
    BooleanClause..::..Occur^ occur
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.BooleanClause.#ctor(Lucene.Net.Search.Query,Lucene.Net.Search.BooleanClause.Occur)"]

occur
Type: Lucene.Net.Search..::..BooleanClause..::..Occur

[Missing <param name="occur"/> documentation for "M:Lucene.Net.Search.BooleanClause.#ctor(Lucene.Net.Search.Query,Lucene.Net.Search.BooleanClause.Occur)"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


BooleanClause Methods

[image] [image]

Lucene.Net Class Libraries
BooleanClause Methods
BooleanClause Class See Also Send Feedback

The BooleanClause type exposes the following members.

Methods

Name | Description
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Object..::..GetHashCode()()()().)
Public method | GetOccur
Public method | GetQuery
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | IsProhibited
Public method | IsRequired
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | SetOccur
Public method | SetQuery
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

BooleanClause Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..Equals Method
BooleanClause Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.BooleanClause.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.Equals(System.Object)"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..GetHashCode Method
BooleanClause Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.GetHashCode"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


GetOccur Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..GetOccur Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.GetOccur"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual BooleanClause..::..Occur GetOccur()
Visual Basic
Public Overridable Function GetOccur As BooleanClause..::..Occur
Visual C++
public:
virtual BooleanClause..::..Occur^ GetOccur()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.GetOccur"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..GetQuery Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.GetQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query GetQuery()
Visual Basic
Public Overridable Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.GetQuery"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


IsProhibited Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..IsProhibited Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.IsProhibited"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsProhibited()
Visual Basic
Public Overridable Function IsProhibited As Boolean
Visual C++
public:
virtual bool IsProhibited()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.IsProhibited"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


IsRequired Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..IsRequired Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.IsRequired"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsRequired()
Visual Basic
Public Overridable Function IsRequired As Boolean
Visual C++
public:
virtual bool IsRequired()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.IsRequired"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


SetOccur Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..SetOccur Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.SetOccur(Lucene.Net.Search.BooleanClause.Occur)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetOccur(
    BooleanClause..::..Occur occur
)
Visual Basic
Public Overridable Sub SetOccur ( _
    occur As BooleanClause..::..Occur _
)
Visual C++
public:
virtual void SetOccur(
    BooleanClause..::..Occur^ occur
)

Parameters

occur
Type: Lucene.Net.Search..::..BooleanClause..::..Occur

[Missing <param name="occur"/> documentation for "M:Lucene.Net.Search.BooleanClause.SetOccur(Lucene.Net.Search.BooleanClause.Occur)"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


SetQuery Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..SetQuery Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.SetQuery(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetQuery(
    Query query
)
Visual Basic
Public Overridable Sub SetQuery ( _
    query As Query _
)
Visual C++
public:
virtual void SetQuery(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.BooleanClause.SetQuery(Lucene.Net.Search.Query)"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..ToString Method
BooleanClause Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.ToString"]

See Also

BooleanClause Class
Lucene.Net.Search Namespace


BooleanClause.Occur Class

[image]

Lucene.Net Class Libraries
BooleanClause..::..Occur Class
BooleanClause Class Members See Also Send Feedback
Specifies how clauses are to occur in matching documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Occur : Parameter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Occur _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class Occur sealed : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Search..::..BooleanClause..::..Occur

See Also

BooleanClause..::..Occur Members
Lucene.Net.Search Namespace


BooleanClause.Occur Members

[image] [image]

Lucene.Net Class Libraries
BooleanClause..::..Occur Members
BooleanClause..::..Occur Class Methods Fields See Also Send Feedback

A clause in a BooleanQuery.

The BooleanClause..::..Occur type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Parameter..::..ToString()()()().)

Fields

Name Description
MUST
Use this operator for clauses that must appear in the matching documents.
MUST_NOT
Use this operator for clauses that must not appear in the matching documents. Note that it is not possible to search for queries that only consist of a
CopyC#
MUST_NOT
 clause.
SHOULD
Use this operator for clauses that should appear in the matching documents. For a BooleanQuery with no
CopyC#
MUST
 clauses one or more
CopyC#
SHOULD
 clauses must match a document for the BooleanQuery to match.

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace


BooleanClause.Occur Fields

[image] [image]

Lucene.Net Class Libraries
BooleanClause..::..Occur Fields
BooleanClause..::..Occur Class See Also Send Feedback

The BooleanClause..::..Occur type exposes the following members.

Fields

Name Description
MUST
Use this operator for clauses that must appear in the matching documents.
MUST_NOT
Use this operator for clauses that must not appear in the matching documents. Note that it is not possible to search for queries that only consist of a
CopyC#
MUST_NOT
 clause.
SHOULD
Use this operator for clauses that should appear in the matching documents. For a BooleanQuery with no
CopyC#
MUST
 clauses one or more
CopyC#
SHOULD
 clauses must match a document for the BooleanQuery to match.

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace


MUST Field

[image]

Lucene.Net Class Libraries
BooleanClause..::..Occur..::..MUST Field
BooleanClause..::..Occur Class See Also Send Feedback
Use this operator for clauses that must appear in the matching documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly BooleanClause..::..Occur MUST
Visual Basic
Public Shared ReadOnly MUST As BooleanClause..::..Occur
Visual C++
public:
static initonly BooleanClause..::..Occur^ MUST

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace


MUST_NOT Field

[image]

Lucene.Net Class Libraries
BooleanClause..::..Occur..::..MUST_NOT Field
BooleanClause..::..Occur Class See Also Send Feedback
Use this operator for clauses that must not appear in the matching documents. Note that it is not possible to search for queries that only consist of a
CopyC#
MUST_NOT
 clause.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly BooleanClause..::..Occur MUST_NOT
Visual Basic
Public Shared ReadOnly MUST_NOT As BooleanClause..::..Occur
Visual C++
public:
static initonly BooleanClause..::..Occur^ MUST_NOT

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace


SHOULD Field

[image]

Lucene.Net Class Libraries
BooleanClause..::..Occur..::..SHOULD Field
BooleanClause..::..Occur Class See Also Send Feedback
Use this operator for clauses that should appear in the matching documents. For a BooleanQuery with no
CopyC#
MUST
 clauses one or more
CopyC#
SHOULD
 clauses must match a document for the BooleanQuery to match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly BooleanClause..::..Occur SHOULD
Visual Basic
Public Shared ReadOnly SHOULD As BooleanClause..::..Occur
Visual C++
public:
static initonly BooleanClause..::..Occur^ SHOULD

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace
[!:BooleanQuery.setMinimumNumberShouldMatch]


BooleanClause.Occur Methods

[image] [image]

Lucene.Net Class Libraries
BooleanClause..::..Occur Methods
BooleanClause..::..Occur Class See Also Send Feedback

The BooleanClause..::..Occur type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Parameter..::..ToString()()()().)

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
BooleanClause..::..Occur..::..ToString Method
BooleanClause..::..Occur Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanClause.Occur.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanClause.Occur.ToString"]

See Also

BooleanClause..::..Occur Class
Lucene.Net.Search Namespace


BooleanFilter Class

[image]

Lucene.Net Class Libraries
BooleanFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.BooleanFilter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class BooleanFilter : Filter
Visual Basic
Public Class BooleanFilter _
    Inherits Filter
Visual C++
public ref class BooleanFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..BooleanFilter

See Also

BooleanFilter Members
Lucene.Net.Search Namespace


BooleanFilter Members

[image] [image]

Lucene.Net Class Libraries
BooleanFilter Members
BooleanFilter Class Constructors Methods See Also Send Feedback

The BooleanFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanFilter | Initializes a new instance of the BooleanFilter class

Methods

 | Name | Description
Public method | Add | Add a filter clause.
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | Equality (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalResult |
Public method | GetDocIdSet | Get the id set for the filter. (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | Hash code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation. (Overrides Object..::..ToString()()()().)

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


BooleanFilter Constructor

[image]

Lucene.Net Class Libraries
BooleanFilter Constructor
BooleanFilter Class See Also Send Feedback
Initializes a new instance of the BooleanFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public BooleanFilter()
Visual Basic
Public Sub New
Visual C++
public:
BooleanFilter()

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


BooleanFilter Methods

[image] [image]

Lucene.Net Class Libraries
BooleanFilter Methods
BooleanFilter Class See Also Send Feedback

The BooleanFilter type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add a filter clause.
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | Equality (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalResult |
Public method | GetDocIdSet | Get the id set for the filter. (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | Hash code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation. (Overrides Object..::..ToString()()()().)

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


Add Method

[image]

Lucene.Net Class Libraries
BooleanFilter..::..Add Method
BooleanFilter Class See Also Send Feedback
Add a filter clause.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Add(
    BooleanFilterClause filterClause
)
Visual Basic
Public Sub Add ( _
    filterClause As BooleanFilterClause _
)
Visual C++
public:
void Add(
    BooleanFilterClause^ filterClause
)

Parameters

filterClause
Type: Lucene.Net.Search..::..BooleanFilterClause
The clause to add.

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
BooleanFilter..::..Equals Method
BooleanFilter Class See Also Send Feedback
Equality

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.BooleanFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanFilter.Equals(System.Object)"]

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


FinalResult Method

[image]

Lucene.Net Class Libraries
BooleanFilter..::..FinalResult Method
BooleanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanFilter.FinalResult(Lucene.Net.Util.OpenBitSetDISI,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected DocIdSet FinalResult(
    OpenBitSetDISI result,
    int maxDocs
)
Visual Basic
Protected Function FinalResult ( _
    result As OpenBitSetDISI, _
    maxDocs As Integer _
) As DocIdSet
Visual C++
protected:
DocIdSet^ FinalResult(
    OpenBitSetDISI^ result,
    int maxDocs
)

Parameters

result
Type: Lucene.Net.Util..::..OpenBitSetDISI

[Missing <param name="result"/> documentation for "M:Lucene.Net.Search.BooleanFilter.FinalResult(Lucene.Net.Util.OpenBitSetDISI,System.Int32)"]

maxDocs
Type: System..::..Int32

[Missing <param name="maxDocs"/> documentation for "M:Lucene.Net.Search.BooleanFilter.FinalResult(Lucene.Net.Util.OpenBitSetDISI,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanFilter.FinalResult(Lucene.Net.Util.OpenBitSetDISI,System.Int32)"]

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
BooleanFilter..::..GetDocIdSet Method
BooleanFilter Class See Also Send Feedback
Get the id set for the filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The reader.

Return Value

The filter set to use.

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
BooleanFilter..::..GetHashCode Method
BooleanFilter Class See Also Send Feedback
Hash code.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanFilter.GetHashCode"]

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
BooleanFilter..::..ToString Method
BooleanFilter Class See Also Send Feedback
String representation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanFilter.ToString"]

See Also

BooleanFilter Class
Lucene.Net.Search Namespace


BooleanFilterClause Class

[image]

Lucene.Net Class Libraries
BooleanFilterClause Class
Members See Also Send Feedback
A spefic clause that makes up a part of the BooleanFilter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class BooleanFilterClause
Visual Basic
Public Class BooleanFilterClause
Visual C++
public ref class BooleanFilterClause

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..BooleanFilterClause

See Also

BooleanFilterClause Members
Lucene.Net.Search Namespace


BooleanFilterClause Members

[image] [image]

Lucene.Net Class Libraries
BooleanFilterClause Members
BooleanFilterClause Class Constructors Methods Properties See Also Send Feedback

The BooleanFilterClause type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanFilterClause | Create a new BooleanFilterClause

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Filter | The underlying filter for the clause.
Public property | Occur | The occurrence of this clause.

See Also

BooleanFilterClause Class
Lucene.Net.Search Namespace


BooleanFilterClause Constructor

[image]

Lucene.Net Class Libraries
BooleanFilterClause Constructor
BooleanFilterClause Class See Also Send Feedback
Create a new BooleanFilterClause

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public BooleanFilterClause(
    Filter filter,
    BooleanClause..::..Occur occur
)
Visual Basic
Public Sub New ( _
    filter As Filter, _
    occur As BooleanClause..::..Occur _
)
Visual C++
public:
BooleanFilterClause(
    Filter^ filter,
    BooleanClause..::..Occur^ occur
)

Parameters

filter
Type: Lucene.Net.Search..::..Filter
A Filter object
occur
Type: Lucene.Net.Search..::..BooleanClause..::..Occur
A parameter implementation indicating SHOULD, MUST or MUST NOT

See Also

BooleanFilterClause Class
Lucene.Net.Search Namespace


BooleanFilterClause Methods

[image] [image]

Lucene.Net Class Libraries
BooleanFilterClause Methods
BooleanFilterClause Class See Also Send Feedback

The BooleanFilterClause type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanFilterClause Class
Lucene.Net.Search Namespace


BooleanFilterClause Properties

[image] [image]

Lucene.Net Class Libraries
BooleanFilterClause Properties
BooleanFilterClause Class See Also Send Feedback

The BooleanFilterClause type exposes the following members.

Properties

 | Name | Description
Public property | Filter | The underlying filter for the clause.
Public property | Occur | The occurrence of this clause.

See Also

BooleanFilterClause Class
Lucene.Net.Search Namespace


Filter Property

[image]

Lucene.Net Class Libraries
BooleanFilterClause..::..Filter Property
BooleanFilterClause Class See Also Send Feedback
The underlying filter for the clause.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Filter Filter { get; private set; }
Visual Basic
Public Property Filter As Filter
    Get
    Private Set
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
    private: void set (Filter^ value);
}

See Also

BooleanFilterClause Class
Lucene.Net.Search Namespace


Occur Property

[image]

Lucene.Net Class Libraries
BooleanFilterClause..::..Occur Property
BooleanFilterClause Class See Also Send Feedback
The occurrence of this clause.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public BooleanClause..::..Occur Occur { get; private set; }
Visual Basic
Public Property Occur As BooleanClause..::..Occur
    Get
    Private Set
Visual C++
public:
property BooleanClause..::..Occur^ Occur {
    BooleanClause..::..Occur^ get ();
    private: void set (BooleanClause..::..Occur^ value);
}

See Also

BooleanFilterClause Class
Lucene.Net.Search Namespace


BooleanQuery Class

[image]

Lucene.Net Class Libraries
BooleanQuery Class
Members See Also Send Feedback
A Query that matches documents matching boolean combinations of other queries, e.g. {@link TermQuery}s, {@link PhraseQuery}s or other BooleanQuerys.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class BooleanQuery : Query,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class BooleanQuery _
    Inherits Query _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class BooleanQuery : public Query,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..BooleanQuery

See Also

BooleanQuery Members
Lucene.Net.Search Namespace


BooleanQuery Members

[image] [image]

Lucene.Net Class Libraries
BooleanQuery Members
BooleanQuery Class Constructors Methods Fields See Also Send Feedback

The BooleanQuery type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanQuery()()()() | Constructs an empty boolean query.
Public method | BooleanQuery(Boolean) | Constructs an empty boolean query. {@link Similarity#Coord(int,int)} may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like {@link WildcardQuery} and {@link FuzzyQuery}.

Methods

Name | Description
Public method Add(BooleanClause)
Adds a clause to a boolean query.
Public method Add(Query, BooleanClause..::..Occur)
Adds a clause to a boolean query.
Public method Clauses
Returns the list of clauses in this query.
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAllowDocsOutOfOrder Obsolete.
Whether hit docs may be collected out of docid order.
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Returns the set of clauses in this query.
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
GetMaxClauseCount
Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.
Public method GetMinimumNumberShouldMatch
Gets the minimum number of the optional BooleanClauses which must be satisifed.
Public method | GetSimilarity | (Overrides Query..::..GetSimilarity(Searcher).)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetUseScorer14 | Obsolete.
Public method IsCoordDisabled
Returns true iff {@link Similarity#Coord(int,int)} is disabled in scoring for this query instance.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
SetAllowDocsOutOfOrder Obsolete.
Expert: Indicates whether hit docs may be collected out of docid order.

Background: although the contract of the Scorer class requires that documents be iterated in order of doc id, this was not true in early versions of Lucene. Many pieces of functionality in the current Lucene code base have undefined behavior if this contract is not upheld, but in some specific simple cases may be faster. (For example: disjunction queries with less than 32 prohibited clauses; This setting has no effect for other queries.)

Specifics: By setting this option to true, docid N might be scored for a single segment before docid N-1. Across multiple segments, docs may be scored out of order regardless of this setting - it only applies to scoring a single segment. Being static, this setting is system wide.

Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
SetMaxClauseCount
Set the maximum number of clauses permitted per BooleanQuery. Default value is 1024.
Public method SetMinimumNumberShouldMatch
Specifies a minimum number of the optional BooleanClauses which must be satisfied.

By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required.

Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.

EXPERT NOTE: Using this method may force collecting docs in order, regardless of whether setAllowDocsOutOfOrder(true) has been called.

SetUseScorer14 | Obsolete.
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | minNrShouldMatch |

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


BooleanQuery Constructor

[image] [image]

Lucene.Net Class Libraries
BooleanQuery Constructor
BooleanQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BooleanQuery()()()() | Constructs an empty boolean query.
Public method | BooleanQuery(Boolean) | Constructs an empty boolean query. {@link Similarity#Coord(int,int)} may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like {@link WildcardQuery} and {@link FuzzyQuery}.

See Also

BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace


BooleanQuery Constructor

[image]

Lucene.Net Class Libraries
BooleanQuery Constructor
BooleanQuery Class See Also Send Feedback
Constructs an empty boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BooleanQuery()
Visual Basic
Public Sub New
Visual C++
public:
BooleanQuery()

See Also

BooleanQuery Class
BooleanQuery Overload
Lucene.Net.Search Namespace


BooleanQuery Constructor (Boolean)

[image]

Lucene.Net Class Libraries
BooleanQuery Constructor (Boolean)
BooleanQuery Class See Also Send Feedback
Constructs an empty boolean query. {@link Similarity#Coord(int,int)} may be disabled in scoring, as appropriate. For example, this score factor does not make sense for most automatically generated queries, like {@link WildcardQuery} and {@link FuzzyQuery}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BooleanQuery(
    bool disableCoord
)
Visual Basic
Public Sub New ( _
    disableCoord As Boolean _
)
Visual C++
public:
BooleanQuery(
    bool disableCoord
)

Parameters

disableCoord
Type: System..::..Boolean
disables {@link Similarity#Coord(int,int)} in scoring.

See Also

BooleanQuery Class
BooleanQuery Overload
Lucene.Net.Search Namespace


BooleanQuery Fields

[image] [image]

Lucene.Net Class Libraries
BooleanQuery Fields
BooleanQuery Class See Also Send Feedback

The BooleanQuery type exposes the following members.

Fields

 | Name | Description
Protected field | minNrShouldMatch |

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


minNrShouldMatch Field

[image]

Lucene.Net Class Libraries
BooleanQuery..::..minNrShouldMatch Field
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.BooleanQuery.minNrShouldMatch"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int minNrShouldMatch
Visual Basic
Protected Friend minNrShouldMatch As Integer
Visual C++
protected public:
int minNrShouldMatch

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


BooleanQuery Methods

[image] [image]

Lucene.Net Class Libraries
BooleanQuery Methods
BooleanQuery Class See Also Send Feedback

The BooleanQuery type exposes the following members.

Methods

Name | Description
Public method Add(BooleanClause)
Adds a clause to a boolean query.
Public method Add(Query, BooleanClause..::..Occur)
Adds a clause to a boolean query.
Public method Clauses
Returns the list of clauses in this query.
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAllowDocsOutOfOrder Obsolete.
Whether hit docs may be collected out of docid order.
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Returns the set of clauses in this query.
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
GetMaxClauseCount
Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.
Public method GetMinimumNumberShouldMatch
Gets the minimum number of the optional BooleanClauses which must be satisifed.
Public method | GetSimilarity | (Overrides Query..::..GetSimilarity(Searcher).)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetUseScorer14 | Obsolete.
Public method IsCoordDisabled
Returns true iff {@link Similarity#Coord(int,int)} is disabled in scoring for this query instance.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
SetAllowDocsOutOfOrder Obsolete.
Expert: Indicates whether hit docs may be collected out of docid order.

Background: although the contract of the Scorer class requires that documents be iterated in order of doc id, this was not true in early versions of Lucene. Many pieces of functionality in the current Lucene code base have undefined behavior if this contract is not upheld, but in some specific simple cases may be faster. (For example: disjunction queries with less than 32 prohibited clauses; This setting has no effect for other queries.)

Specifics: By setting this option to true, docid N might be scored for a single segment before docid N-1. Across multiple segments, docs may be scored out of order regardless of this setting - it only applies to scoring a single segment. Being static, this setting is system wide.

Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
SetMaxClauseCount
Set the maximum number of clauses permitted per BooleanQuery. Default value is 1024.
Public method SetMinimumNumberShouldMatch
Specifies a minimum number of the optional BooleanClauses which must be satisfied.

By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required.

Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.

EXPERT NOTE: Using this method may force collecting docs in order, regardless of whether setAllowDocsOutOfOrder(true) has been called.

SetUseScorer14 | Obsolete.
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..Add Method
BooleanQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(BooleanClause) | Adds a clause to a boolean query.
Public method | Add(Query, BooleanClause..::..Occur) | Adds a clause to a boolean query.

See Also

BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace


Add Method (BooleanClause)

[image]

Lucene.Net Class Libraries
BooleanQuery..::..Add Method (BooleanClause)
BooleanQuery Class See Also Send Feedback
Adds a clause to a boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    BooleanClause clause
)
Visual Basic
Public Overridable Sub Add ( _
    clause As BooleanClause _
)
Visual C++
public:
virtual void Add(
    BooleanClause^ clause
)

Parameters

clause
Type: Lucene.Net.Search..::..BooleanClause

[Missing <param name="clause"/> documentation for "M:Lucene.Net.Search.BooleanQuery.Add(Lucene.Net.Search.BooleanClause)"]

See Also

BooleanQuery Class
Add Overload
Lucene.Net.Search Namespace
BooleanQuery..::..GetMaxClauseCount()()()()


Add Method (Query, BooleanClause.Occur)

[image]

Lucene.Net Class Libraries
BooleanQuery..::..Add Method (Query, BooleanClause..::..Occur)
BooleanQuery Class See Also Send Feedback
Adds a clause to a boolean query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Query query,
    BooleanClause..::..Occur occur
)
Visual Basic
Public Overridable Sub Add ( _
    query As Query, _
    occur As BooleanClause..::..Occur _
)
Visual C++
public:
virtual void Add(
    Query^ query,
    BooleanClause..::..Occur^ occur
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.BooleanQuery.Add(Lucene.Net.Search.Query,Lucene.Net.Search.BooleanClause.Occur)"]

occur
Type: Lucene.Net.Search..::..BooleanClause..::..Occur

[Missing <param name="occur"/> documentation for "M:Lucene.Net.Search.BooleanQuery.Add(Lucene.Net.Search.Query,Lucene.Net.Search.BooleanClause.Occur)"]

See Also

BooleanQuery Class
Add Overload
Lucene.Net.Search Namespace
BooleanQuery..::..GetMaxClauseCount()()()()


Clauses Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..Clauses Method
BooleanQuery Class See Also Send Feedback
Returns the list of clauses in this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList Clauses()
Visual Basic
Public Overridable Function Clauses As IList
Visual C++
public:
virtual IList^ Clauses()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.Clauses"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


Clone Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..Clone Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.Clone"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..CreateWeight Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.BooleanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..Equals Method
BooleanQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.BooleanQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.Equals(System.Object)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..ExtractTerms Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.BooleanQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


GetAllowDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetAllowDocsOutOfOrder Method
BooleanQuery Class See Also Send Feedback
Whether hit docs may be collected out of docid order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("this is not needed anymore, as Weight.ScoresDocsOutOfOrder() is used.")]
public static bool GetAllowDocsOutOfOrder()
Visual Basic
<ObsoleteAttribute("this is not needed anymore, as Weight.ScoresDocsOutOfOrder() is used.")> _
Public Shared Function GetAllowDocsOutOfOrder As Boolean
Visual C++
[ObsoleteAttribute(L"this is not needed anymore, as Weight.ScoresDocsOutOfOrder() is used.")]
public:
static bool GetAllowDocsOutOfOrder()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetAllowDocsOutOfOrder"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace
[!:SetAllowDocsOutOfOrder(boolean)]


GetClauses Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetClauses Method
BooleanQuery Class See Also Send Feedback
Returns the set of clauses in this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual BooleanClause[] GetClauses()
Visual Basic
Public Overridable Function GetClauses As BooleanClause()
Visual C++
public:
virtual array<BooleanClause^>^ GetClauses()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetClauses"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetHashCode Method
BooleanQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetHashCode"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


GetMaxClauseCount Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetMaxClauseCount Method
BooleanQuery Class See Also Send Feedback
Return the maximum number of clauses permitted, 1024 by default. Attempts to add more than the permitted number of clauses cause {@link TooManyClauses} to be thrown.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetMaxClauseCount()
Visual Basic
Public Shared Function GetMaxClauseCount As Integer
Visual C++
public:
static int GetMaxClauseCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetMaxClauseCount"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace
BooleanQuery..::..SetMaxClauseCount(Int32)


GetMinimumNumberShouldMatch Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetMinimumNumberShouldMatch Method
BooleanQuery Class See Also Send Feedback
Gets the minimum number of the optional BooleanClauses which must be satisifed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMinimumNumberShouldMatch()
Visual Basic
Public Overridable Function GetMinimumNumberShouldMatch As Integer
Visual C++
public:
virtual int GetMinimumNumberShouldMatch()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetMinimumNumberShouldMatch"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetSimilarity Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.GetSimilarity(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Similarity GetSimilarity(
    Searcher searcher
)
Visual Basic
Public Overrides Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.BooleanQuery.GetSimilarity(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetSimilarity(Lucene.Net.Search.Searcher)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


GetUseScorer14 Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..GetUseScorer14 Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.GetUseScorer14"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetAllowDocsOutOfOrder() instead.")]
public static bool GetUseScorer14()
Visual Basic
<ObsoleteAttribute("Use GetAllowDocsOutOfOrder() instead.")> _
Public Shared Function GetUseScorer14 As Boolean
Visual C++
[ObsoleteAttribute(L"Use GetAllowDocsOutOfOrder() instead.")]
public:
static bool GetUseScorer14()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.GetUseScorer14"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


IsCoordDisabled Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..IsCoordDisabled Method
BooleanQuery Class See Also Send Feedback
Returns true iff {@link Similarity#Coord(int,int)} is disabled in scoring for this query instance.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsCoordDisabled()
Visual Basic
Public Overridable Function IsCoordDisabled As Boolean
Visual C++
public:
virtual bool IsCoordDisabled()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.IsCoordDisabled"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace
[!:BooleanQuery(boolean)]


Rewrite Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..Rewrite Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.BooleanQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


SetAllowDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..SetAllowDocsOutOfOrder Method
BooleanQuery Class See Also Send Feedback
Expert: Indicates whether hit docs may be collected out of docid order.

Background: although the contract of the Scorer class requires that documents be iterated in order of doc id, this was not true in early versions of Lucene. Many pieces of functionality in the current Lucene code base have undefined behavior if this contract is not upheld, but in some specific simple cases may be faster. (For example: disjunction queries with less than 32 prohibited clauses; This setting has no effect for other queries.)

Specifics: By setting this option to true, docid N might be scored for a single segment before docid N-1. Across multiple segments, docs may be scored out of order regardless of this setting - it only applies to scoring a single segment. Being static, this setting is system wide.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("this is not needed anymore, as Weight.ScoresDocsOutOfOrder() is used.")]
public static void SetAllowDocsOutOfOrder(
    bool allow
)
Visual Basic
<ObsoleteAttribute("this is not needed anymore, as Weight.ScoresDocsOutOfOrder() is used.")> _
Public Shared Sub SetAllowDocsOutOfOrder ( _
    allow As Boolean _
)
Visual C++
[ObsoleteAttribute(L"this is not needed anymore, as Weight.ScoresDocsOutOfOrder() is used.")]
public:
static void SetAllowDocsOutOfOrder(
    bool allow
)

Parameters

allow
Type: System..::..Boolean

[Missing <param name="allow"/> documentation for "M:Lucene.Net.Search.BooleanQuery.SetAllowDocsOutOfOrder(System.Boolean)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


SetMaxClauseCount Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..SetMaxClauseCount Method
BooleanQuery Class See Also Send Feedback
Set the maximum number of clauses permitted per BooleanQuery. Default value is 1024.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetMaxClauseCount(
    int maxClauseCount
)
Visual Basic
Public Shared Sub SetMaxClauseCount ( _
    maxClauseCount As Integer _
)
Visual C++
public:
static void SetMaxClauseCount(
    int maxClauseCount
)

Parameters

maxClauseCount
Type: System..::..Int32

[Missing <param name="maxClauseCount"/> documentation for "M:Lucene.Net.Search.BooleanQuery.SetMaxClauseCount(System.Int32)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


SetMinimumNumberShouldMatch Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..SetMinimumNumberShouldMatch Method
BooleanQuery Class See Also Send Feedback
Specifies a minimum number of the optional BooleanClauses which must be satisfied.

By default no optional clauses are necessary for a match (unless there are no required clauses). If this method is used, then the specified number of clauses is required.

Use of this method is totally independent of specifying that any specific clauses are required (or prohibited). This number will only be compared against the number of matching optional clauses.

EXPERT NOTE: Using this method may force collecting docs in order, regardless of whether setAllowDocsOutOfOrder(true) has been called.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMinimumNumberShouldMatch(
    int min
)
Visual Basic
Public Overridable Sub SetMinimumNumberShouldMatch ( _
    min As Integer _
)
Visual C++
public:
virtual void SetMinimumNumberShouldMatch(
    int min
)

Parameters

min
Type: System..::..Int32
the number of optional clauses that must match

See Also

BooleanQuery Class
Lucene.Net.Search Namespace
[!:setAllowDocsOutOfOrder]


SetUseScorer14 Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..SetUseScorer14 Method
BooleanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.SetUseScorer14(System.Boolean)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use SetAllowDocsOutOfOrder(bool) instead.")]
public static void SetUseScorer14(
    bool use14
)
Visual Basic
<ObsoleteAttribute("Use SetAllowDocsOutOfOrder(bool) instead.")> _
Public Shared Sub SetUseScorer14 ( _
    use14 As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use SetAllowDocsOutOfOrder(bool) instead.")]
public:
static void SetUseScorer14(
    bool use14
)

Parameters

use14
Type: System..::..Boolean

[Missing <param name="use14"/> documentation for "M:Lucene.Net.Search.BooleanQuery.SetUseScorer14(System.Boolean)"]

See Also

BooleanQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..ToString Method
BooleanQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

BooleanQuery Class
BooleanQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
BooleanQuery..::..ToString Method (String)
BooleanQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.BooleanQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.ToString(System.String)"]

See Also

BooleanQuery Class
ToString Overload
Lucene.Net.Search Namespace


BooleanQuery.BooleanWeight Class

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight Class
BooleanQuery Class Members See Also Send Feedback
Expert: the Weight for BooleanQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
protected internal class BooleanWeight : Weight
Visual Basic
<SerializableAttribute> _
Protected Friend Class BooleanWeight _
    Inherits Weight
Visual C++
[SerializableAttribute]
protected public ref class BooleanWeight : public Weight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search..::..BooleanQuery..::..BooleanWeight

See Also

BooleanQuery..::..BooleanWeight Members
Lucene.Net.Search Namespace


BooleanQuery.BooleanWeight Members

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight Members
BooleanQuery..::..BooleanWeight Class Constructors Methods Fields Properties See Also Send Feedback

A Query that matches documents matching boolean combinations of other queries, e.g. {@link TermQuery}s, {@link PhraseQuery}s or other BooleanQuerys.

The BooleanQuery..::..BooleanWeight type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanQuery..::..BooleanWeight | Initializes a new instance of the BooleanQuery..::..BooleanWeight class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method | ScoresDocsOutOfOrder | (Overrides Weight..::..ScoresDocsOutOfOrder()()()().)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights |

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


BooleanQuery.BooleanWeight Constructor

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight Constructor
BooleanQuery..::..BooleanWeight Class See Also Send Feedback
Initializes a new instance of the BooleanQuery..::..BooleanWeight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BooleanWeight(
    BooleanQuery enclosingInstance,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    enclosingInstance As BooleanQuery, _
    searcher As Searcher _
)
Visual C++
public:
BooleanWeight(
    BooleanQuery^ enclosingInstance,
    Searcher^ searcher
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..BooleanQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.#ctor(Lucene.Net.Search.BooleanQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.#ctor(Lucene.Net.Search.BooleanQuery,Lucene.Net.Search.Searcher)"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


BooleanQuery.BooleanWeight Fields

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight Fields
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

The BooleanQuery..::..BooleanWeight type exposes the following members.

Fields

 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights |

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


similarity Field

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..similarity Field
BooleanQuery..::..BooleanWeight Class See Also Send Feedback
The Similarity implementation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Similarity similarity
Visual Basic
Protected Friend similarity As Similarity
Visual C++
protected public:
Similarity^ similarity

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


weights Field

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..weights Field
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.BooleanQuery.BooleanWeight.weights"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal ArrayList weights
Visual Basic
Protected Friend weights As ArrayList
Visual C++
protected public:
ArrayList^ weights

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


BooleanQuery.BooleanWeight Methods

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight Methods
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

The BooleanQuery..::..BooleanWeight type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method | ScoresDocsOutOfOrder | (Overrides Weight..::..ScoresDocsOutOfOrder()()()().)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..Explain Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..GetQuery Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.GetQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetQuery()
Visual Basic
Public Overrides Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.GetQuery"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..GetValue Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.GetValue"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float GetValue()
Visual Basic
Public Overrides Function GetValue As Single
Visual C++
public:
virtual float GetValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.GetValue"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..Normalize Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Normalize(System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Normalize(
    float norm
)
Visual Basic
Public Overrides Sub Normalize ( _
    norm As Single _
)
Visual C++
public:
virtual void Normalize(
    float norm
) override

Parameters

norm
Type: System..::..Single

[Missing <param name="norm"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Normalize(System.Single)"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..Scorer Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


ScoresDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..ScoresDocsOutOfOrder Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.ScoresDocsOutOfOrder"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool ScoresDocsOutOfOrder()
Visual Basic
Public Overrides Function ScoresDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool ScoresDocsOutOfOrder() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.ScoresDocsOutOfOrder"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


SumOfSquaredWeights Method

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..SumOfSquaredWeights Method
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.SumOfSquaredWeights"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float SumOfSquaredWeights()
Visual Basic
Public Overrides Function SumOfSquaredWeights As Single
Visual C++
public:
virtual float SumOfSquaredWeights() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanQuery.BooleanWeight.SumOfSquaredWeights"]

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


BooleanQuery.BooleanWeight Properties

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight Properties
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

The BooleanQuery..::..BooleanWeight type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
BooleanQuery..::..BooleanWeight..::..Enclosing_Instance Property
BooleanQuery..::..BooleanWeight Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.BooleanQuery.BooleanWeight.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BooleanQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As BooleanQuery
    Get
Visual C++
public:
property BooleanQuery^ Enclosing_Instance {
    BooleanQuery^ get ();
}

See Also

BooleanQuery..::..BooleanWeight Class
Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Class

[image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses Class
BooleanQuery Class Members See Also Send Feedback
Thrown when an attempt is made to add more than {@link #GetMaxClauseCount()} clauses. This typically happens if a PrefixQuery, FuzzyQuery, WildcardQuery, or TermRangeQuery is expanded to many terms during search.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TooManyClauses : SystemException
Visual Basic
<SerializableAttribute> _
Public Class TooManyClauses _
    Inherits SystemException
Visual C++
[SerializableAttribute]
public ref class TooManyClauses : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Lucene.Net.Search..::..BooleanQuery..::..TooManyClauses

See Also

BooleanQuery..::..TooManyClauses Members
Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Members

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses Members
BooleanQuery..::..TooManyClauses Class Constructors Methods Properties Events See Also Send Feedback

A Query that matches documents matching boolean combinations of other queries, e.g. {@link TermQuery}s, {@link PhraseQuery}s or other BooleanQuerys.

The BooleanQuery..::..TooManyClauses type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanQuery..::..TooManyClauses | Initializes a new instance of the BooleanQuery..::..TooManyClauses class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BooleanQuery..::..TooManyClauses Class
Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Constructor

[image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses Constructor
BooleanQuery..::..TooManyClauses Class See Also Send Feedback
Initializes a new instance of the BooleanQuery..::..TooManyClauses class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TooManyClauses()
Visual Basic
Public Sub New
Visual C++
public:
TooManyClauses()

See Also

BooleanQuery..::..TooManyClauses Class
Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Methods

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses Methods
BooleanQuery..::..TooManyClauses Class See Also Send Feedback

The BooleanQuery..::..TooManyClauses type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BooleanQuery..::..TooManyClauses Class
Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Properties

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses Properties
BooleanQuery..::..TooManyClauses Class See Also Send Feedback

The BooleanQuery..::..TooManyClauses type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BooleanQuery..::..TooManyClauses Class
Lucene.Net.Search Namespace


Message Property

[image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses..::..Message Property
BooleanQuery..::..TooManyClauses Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.BooleanQuery.TooManyClauses.Message"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

BooleanQuery..::..TooManyClauses Class
Lucene.Net.Search Namespace


BooleanQuery.TooManyClauses Events

[image] [image]

Lucene.Net Class Libraries
BooleanQuery..::..TooManyClauses Events
BooleanQuery..::..TooManyClauses Class See Also Send Feedback

The BooleanQuery..::..TooManyClauses type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BooleanQuery..::..TooManyClauses Class
Lucene.Net.Search Namespace


BooleanScorer Class

[image]

Lucene.Net Class Libraries
BooleanScorer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.BooleanScorer"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class BooleanScorer : Scorer
Visual Basic
Public NotInheritable Class BooleanScorer _
    Inherits Scorer
Visual C++
public ref class BooleanScorer sealed : public Scorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search..::..BooleanScorer

See Also

BooleanScorer Members
Lucene.Net.Search Namespace


BooleanScorer Members

[image] [image]

Lucene.Net Class Libraries
BooleanScorer Members
BooleanScorer Class Constructors Methods See Also Send Feedback

The BooleanScorer type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanScorer | Initializes a new instance of the BooleanScorer class

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSimilarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. (Overrides Scorer..::..Score(HitCollector).)
Protected method | Score(HitCollector, Int32) | Obsolete. (Overrides Scorer..::..Score(HitCollector, Int32).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


BooleanScorer Constructor

[image]

Lucene.Net Class Libraries
BooleanScorer Constructor
BooleanScorer Class See Also Send Feedback
Initializes a new instance of the BooleanScorer class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BooleanScorer(
    Similarity similarity,
    int minNrShouldMatch,
    IList optionalScorers,
    IList prohibitedScorers
)
Visual Basic
Public Sub New ( _
    similarity As Similarity, _
    minNrShouldMatch As Integer, _
    optionalScorers As IList, _
    prohibitedScorers As IList _
)
Visual C++
public:
BooleanScorer(
    Similarity^ similarity,
    int minNrShouldMatch,
    IList^ optionalScorers,
    IList^ prohibitedScorers
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.BooleanScorer.#ctor(Lucene.Net.Search.Similarity,System.Int32,System.Collections.IList,System.Collections.IList)"]

minNrShouldMatch
Type: System..::..Int32

[Missing <param name="minNrShouldMatch"/> documentation for "M:Lucene.Net.Search.BooleanScorer.#ctor(Lucene.Net.Search.Similarity,System.Int32,System.Collections.IList,System.Collections.IList)"]

optionalScorers
Type: System.Collections..::..IList

[Missing <param name="optionalScorers"/> documentation for "M:Lucene.Net.Search.BooleanScorer.#ctor(Lucene.Net.Search.Similarity,System.Int32,System.Collections.IList,System.Collections.IList)"]

prohibitedScorers
Type: System.Collections..::..IList

[Missing <param name="prohibitedScorers"/> documentation for "M:Lucene.Net.Search.BooleanScorer.#ctor(Lucene.Net.Search.Similarity,System.Int32,System.Collections.IList,System.Collections.IList)"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


BooleanScorer Methods

[image] [image]

Lucene.Net Class Libraries
BooleanScorer Methods
BooleanScorer Class See Also Send Feedback

The BooleanScorer type exposes the following members.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSimilarity | Returns the Similarity implementation used by this scorer. (Inherited from Scorer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. (Overrides Scorer..::..Score(HitCollector).)
Protected method | Score(HitCollector, Int32) | Obsolete. (Overrides Scorer..::..Score(HitCollector, Int32).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Advance Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Advance(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Advance(System.Int32)"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Doc Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Doc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead. ")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead. ")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead. ")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Doc"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..DocID Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.DocID"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Explain Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Explain(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Explain(System.Int32)"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Next Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Next"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead. ")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead. ")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead. ")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Next"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..NextDoc Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.NextDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.NextDoc"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
BooleanScorer..::..Score Method
BooleanScorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. (Overrides Scorer..::..Score(HitCollector).)
Protected method | Score(HitCollector, Int32) | Obsolete. (Overrides Scorer..::..Score(HitCollector, Int32).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)

See Also

BooleanScorer Class
BooleanScorer Members
Lucene.Net.Search Namespace


Score Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Score Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Score"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Score"]

See Also

BooleanScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector)

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Score Method (Collector)
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Score(
    Collector collector
)
Visual Basic
Public Overrides Sub Score ( _
    collector As Collector _
)
Visual C++
public:
virtual void Score(
    Collector^ collector
) override

Parameters

collector
Type: Lucene.Net.Search..::..Collector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector)"]

See Also

BooleanScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (HitCollector)

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Score Method (HitCollector)
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.HitCollector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Score(Collector) instead. ")]
public override void Score(
    HitCollector hc
)
Visual Basic
<ObsoleteAttribute("use Score(Collector) instead. ")> _
Public Overrides Sub Score ( _
    hc As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Score(Collector) instead. ")]
public:
virtual void Score(
    HitCollector^ hc
) override

Parameters

hc
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="hc"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.HitCollector)"]

See Also

BooleanScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (HitCollector, Int32)

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Score Method (HitCollector, Int32)
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Score(Collector, int, int) instead.")]
protected internal override bool Score(
    HitCollector hc,
    int max
)
Visual Basic
<ObsoleteAttribute("use Score(Collector, int, int) instead.")> _
Protected Friend Overrides Function Score ( _
    hc As HitCollector, _
    max As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Score(Collector, int, int) instead.")]
protected public:
virtual bool Score(
    HitCollector^ hc,
    int max
) override

Parameters

hc
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="hc"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

See Also

BooleanScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector, Int32, Int32)

[image]

Lucene.Net Class Libraries
BooleanScorer..::..Score Method (Collector, Int32, Int32)
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Score(
    Collector collector,
    int max,
    int firstDocID
)
Visual Basic
Public Overrides Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
Visual C++
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
) override

Parameters

collector
Type: Lucene.Net.Search..::..Collector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

firstDocID
Type: System..::..Int32

[Missing <param name="firstDocID"/> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

See Also

BooleanScorer Class
Score Overload
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..SkipTo Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead. ")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead. ")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead. ")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.BooleanScorer.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.SkipTo(System.Int32)"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
BooleanScorer..::..ToString Method
BooleanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BooleanScorer.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BooleanScorer.ToString"]

See Also

BooleanScorer Class
Lucene.Net.Search Namespace


BoostingQuery Class

[image]

Lucene.Net Class Libraries
BoostingQuery Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.BoostingQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class BoostingQuery : Query
Visual Basic
Public Class BoostingQuery _
    Inherits Query
Visual C++
public ref class BoostingQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..BoostingQuery

See Also

BoostingQuery Members
Lucene.Net.Search Namespace


BoostingQuery Members

[image] [image]

Lucene.Net Class Libraries
BoostingQuery Members
BoostingQuery Class Constructors Methods See Also Send Feedback

The BoostingQuery type exposes the following members.

Constructors

 | Name | Description
Public method | BoostingQuery | Initializes a new instance of the BoostingQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

BoostingQuery Class
Lucene.Net.Search Namespace


BoostingQuery Constructor

[image]

Lucene.Net Class Libraries
BoostingQuery Constructor
BoostingQuery Class See Also Send Feedback
Initializes a new instance of the BoostingQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public BoostingQuery(
    Query match,
    Query context,
    float boost
)
Visual Basic
Public Sub New ( _
    match As Query, _
    context As Query, _
    boost As Single _
)
Visual C++
public:
BoostingQuery(
    Query^ match,
    Query^ context,
    float boost
)

Parameters

match
Type: Lucene.Net.Search..::..Query

[Missing <param name="match"/> documentation for "M:Lucene.Net.Search.BoostingQuery.#ctor(Lucene.Net.Search.Query,Lucene.Net.Search.Query,System.Single)"]

context
Type: Lucene.Net.Search..::..Query

[Missing <param name="context"/> documentation for "M:Lucene.Net.Search.BoostingQuery.#ctor(Lucene.Net.Search.Query,Lucene.Net.Search.Query,System.Single)"]

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Search.BoostingQuery.#ctor(Lucene.Net.Search.Query,Lucene.Net.Search.Query,System.Single)"]

See Also

BoostingQuery Class
Lucene.Net.Search Namespace


BoostingQuery Methods

[image] [image]

Lucene.Net Class Libraries
BoostingQuery Methods
BoostingQuery Class See Also Send Feedback

The BoostingQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

BoostingQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
BoostingQuery..::..Equals Method
BoostingQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BoostingQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.BoostingQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BoostingQuery.Equals(System.Object)"]

See Also

BoostingQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
BoostingQuery..::..GetHashCode Method
BoostingQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BoostingQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BoostingQuery.GetHashCode"]

See Also

BoostingQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
BoostingQuery..::..Rewrite Method
BoostingQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BoostingQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.BoostingQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BoostingQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

BoostingQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
BoostingQuery..::..ToString Method
BoostingQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

BoostingQuery Class
BoostingQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
BoostingQuery..::..ToString Method (String)
BoostingQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.BoostingQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.BoostingQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.BoostingQuery.ToString(System.String)"]

See Also

BoostingQuery Class
ToString Overload
Lucene.Net.Search Namespace


ByteParser Interface

[image]

Lucene.Net Class Libraries
ByteParser Interface
Members See Also Send Feedback
Interface to parse bytes from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface ByteParser : Parser
Visual Basic
Public Interface ByteParser _
    Inherits Parser
Visual C++
public interface class ByteParser : Parser

See Also

ByteParser Members
Lucene.Net.Search Namespace
[!:FieldCache.GetBytes(IndexReader, String, FieldCache.ByteParser)]


ByteParser Members

[image] [image]

Lucene.Net Class Libraries
ByteParser Members
ByteParser Interface Methods See Also Send Feedback

The ByteParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseByte | Return a single Byte representation of this field's value.

See Also

ByteParser Interface
Lucene.Net.Search Namespace


ByteParser Methods

[image] [image]

Lucene.Net Class Libraries
ByteParser Methods
ByteParser Interface See Also Send Feedback

The ByteParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseByte | Return a single Byte representation of this field's value.

See Also

ByteParser Interface
Lucene.Net.Search Namespace


ParseByte Method

[image]

Lucene.Net Class Libraries
ByteParser..::..ParseByte Method
ByteParser Interface See Also Send Feedback
Return a single Byte representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
sbyte ParseByte(
    string string_Renamed
)
Visual Basic
Function ParseByte ( _
    string_Renamed As String _
) As SByte
Visual C++
signed char ParseByte(
    String^ string_Renamed
)

Parameters

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.ByteParser.ParseByte(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ByteParser.ParseByte(System.String)"]

See Also

ByteParser Interface
Lucene.Net.Search Namespace


CacheEntry Class

[image]

Lucene.Net Class Libraries
CacheEntry Class
Members See Also Send Feedback
EXPERT: A unique Identifier/Description for each item in the FieldCache. Can be useful for logging/debugging.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class CacheEntry
Visual Basic
Public MustInherit Class CacheEntry
Visual C++
public ref class CacheEntry abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..CacheEntry

See Also

CacheEntry Members
Lucene.Net.Search Namespace


CacheEntry Members

[image] [image]

Lucene.Net Class Libraries
CacheEntry Members
CacheEntry Class Constructors Methods See Also Send Feedback

The CacheEntry type exposes the following members.

Constructors

 | Name | Description
Protected method | CacheEntry | Initializes a new instance of the CacheEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EstimateSize()()()() |
Public method | EstimateSize(RamUsageEstimator) | Computes (and stores) the estimated size of the cache Value
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheType |
Public method | GetCustom |
Public method | GetEstimatedSize | The most recently estimated size of the value, null unless estimateSize has been called.
Public method | GetFieldName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReaderKey |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEstimatedSize |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CacheEntry Class
Lucene.Net.Search Namespace


CacheEntry Constructor

[image]

Lucene.Net Class Libraries
CacheEntry Constructor
CacheEntry Class See Also Send Feedback
Initializes a new instance of the CacheEntry class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected CacheEntry()
Visual Basic
Protected Sub New
Visual C++
protected:
CacheEntry()

See Also

CacheEntry Class
Lucene.Net.Search Namespace


CacheEntry Methods

[image] [image]

Lucene.Net Class Libraries
CacheEntry Methods
CacheEntry Class See Also Send Feedback

The CacheEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EstimateSize()()()() |
Public method | EstimateSize(RamUsageEstimator) | Computes (and stores) the estimated size of the cache Value
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheType |
Public method | GetCustom |
Public method | GetEstimatedSize | The most recently estimated size of the value, null unless estimateSize has been called.
Public method | GetFieldName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReaderKey |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEstimatedSize |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CacheEntry Class
Lucene.Net.Search Namespace


EstimateSize Method

[image] [image]

Lucene.Net Class Libraries
CacheEntry..::..EstimateSize Method
CacheEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EstimateSize()()()() |
Public method | EstimateSize(RamUsageEstimator) | Computes (and stores) the estimated size of the cache Value

See Also

CacheEntry Class
CacheEntry Members
Lucene.Net.Search Namespace


EstimateSize Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..EstimateSize Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.EstimateSize"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void EstimateSize()
Visual Basic
Public Overridable Sub EstimateSize
Visual C++
public:
virtual void EstimateSize()

See Also

CacheEntry Class
EstimateSize Overload
Lucene.Net.Search Namespace
CacheEntry..::..EstimateSize(RamUsageEstimator)


EstimateSize Method (RamUsageEstimator)

[image]

Lucene.Net Class Libraries
CacheEntry..::..EstimateSize Method (RamUsageEstimator)
CacheEntry Class See Also Send Feedback
Computes (and stores) the estimated size of the cache Value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void EstimateSize(
    RamUsageEstimator ramCalc
)
Visual Basic
Public Overridable Sub EstimateSize ( _
    ramCalc As RamUsageEstimator _
)
Visual C++
public:
virtual void EstimateSize(
    RamUsageEstimator^ ramCalc
)

Parameters

ramCalc
Type: Lucene.Net.Util..::..RamUsageEstimator

[Missing <param name="ramCalc"/> documentation for "M:Lucene.Net.Search.CacheEntry.EstimateSize(Lucene.Net.Util.RamUsageEstimator)"]

See Also

CacheEntry Class
EstimateSize Overload
Lucene.Net.Search Namespace
[!:getEstimatedSize]


GetCacheType Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..GetCacheType Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.GetCacheType"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Type GetCacheType()
Visual Basic
Public MustOverride Function GetCacheType As Type
Visual C++
public:
virtual Type^ GetCacheType() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.GetCacheType"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


GetCustom Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..GetCustom Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.GetCustom"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Object GetCustom()
Visual Basic
Public MustOverride Function GetCustom As Object
Visual C++
public:
virtual Object^ GetCustom() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.GetCustom"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


GetEstimatedSize Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..GetEstimatedSize Method
CacheEntry Class See Also Send Feedback
The most recently estimated size of the value, null unless estimateSize has been called.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetEstimatedSize()
Visual Basic
Public Function GetEstimatedSize As String
Visual C++
public:
String^ GetEstimatedSize()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.GetEstimatedSize"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


GetFieldName Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..GetFieldName Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.GetFieldName"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string GetFieldName()
Visual Basic
Public MustOverride Function GetFieldName As String
Visual C++
public:
virtual String^ GetFieldName() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.GetFieldName"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


GetReaderKey Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..GetReaderKey Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.GetReaderKey"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Object GetReaderKey()
Visual Basic
Public MustOverride Function GetReaderKey As Object
Visual C++
public:
virtual Object^ GetReaderKey() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.GetReaderKey"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..GetValue Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.GetValue"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Object GetValue()
Visual Basic
Public MustOverride Function GetValue As Object
Visual C++
public:
virtual Object^ GetValue() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.GetValue"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


SetEstimatedSize Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..SetEstimatedSize Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.SetEstimatedSize(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal void SetEstimatedSize(
    string size
)
Visual Basic
Protected Friend Sub SetEstimatedSize ( _
    size As String _
)
Visual C++
protected public:
void SetEstimatedSize(
    String^ size
)

Parameters

size
Type: System..::..String

[Missing <param name="size"/> documentation for "M:Lucene.Net.Search.CacheEntry.SetEstimatedSize(System.String)"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
CacheEntry..::..ToString Method
CacheEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CacheEntry.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CacheEntry.ToString"]

See Also

CacheEntry Class
Lucene.Net.Search Namespace


CachingSpanFilter Class

[image]

Lucene.Net Class Libraries
CachingSpanFilter Class
Members See Also Send Feedback
Wraps another SpanFilter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class CachingSpanFilter : SpanFilter
Visual Basic
<SerializableAttribute> _
Public Class CachingSpanFilter _
    Inherits SpanFilter
Visual C++
[SerializableAttribute]
public ref class CachingSpanFilter : public SpanFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..SpanFilter
Lucene.Net.Search..::..CachingSpanFilter

See Also

CachingSpanFilter Members
Lucene.Net.Search Namespace


CachingSpanFilter Members

[image] [image]

Lucene.Net Class Libraries
CachingSpanFilter Members
CachingSpanFilter Class Constructors Methods Fields See Also Send Feedback

The CachingSpanFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CachingSpanFilter(SpanFilter) | New deletions always result in a cache miss, by default ({@link CachingWrapperFilter.DeletesMode#RECACHE}. Filter to cache results of
Public method | CachingSpanFilter(SpanFilter, CachingWrapperFilter..::..DeletesMode) | Initializes a new instance of the CachingSpanFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Overrides Filter..::..Bits(IndexReader).)
Public method | BitSpans | (Overrides SpanFilter..::..BitSpans(IndexReader).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | filter |
Public field | hitCount |
Public field | missCount |

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


CachingSpanFilter Constructor

[image] [image]

Lucene.Net Class Libraries
CachingSpanFilter Constructor
CachingSpanFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CachingSpanFilter(SpanFilter) | New deletions always result in a cache miss, by default ({@link CachingWrapperFilter.DeletesMode#RECACHE}. Filter to cache results of
Public method | CachingSpanFilter(SpanFilter, CachingWrapperFilter..::..DeletesMode) | Initializes a new instance of the CachingSpanFilter class

See Also

CachingSpanFilter Class
CachingSpanFilter Members
Lucene.Net.Search Namespace


CachingSpanFilter Constructor (SpanFilter)

[image]

Lucene.Net Class Libraries
CachingSpanFilter Constructor (SpanFilter)
CachingSpanFilter Class See Also Send Feedback
New deletions always result in a cache miss, by default ({@link CachingWrapperFilter.DeletesMode#RECACHE}. Filter to cache results of

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CachingSpanFilter(
    SpanFilter filter
)
Visual Basic
Public Sub New ( _
    filter As SpanFilter _
)
Visual C++
public:
CachingSpanFilter(
    SpanFilter^ filter
)

Parameters

filter
Type: Lucene.Net.Search..::..SpanFilter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.#ctor(Lucene.Net.Search.SpanFilter)"]

See Also

CachingSpanFilter Class
CachingSpanFilter Overload
Lucene.Net.Search Namespace


CachingSpanFilter Constructor (SpanFilter, CachingWrapperFilter.DeletesMode)

[image]

Lucene.Net Class Libraries
CachingSpanFilter Constructor (SpanFilter, CachingWrapperFilter..::..DeletesMode)
CachingSpanFilter Class See Also Send Feedback
Initializes a new instance of the CachingSpanFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CachingSpanFilter(
    SpanFilter filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
Visual Basic
Public Sub New ( _
    filter As SpanFilter, _
    deletesMode As CachingWrapperFilter..::..DeletesMode _
)
Visual C++
public:
CachingSpanFilter(
    SpanFilter^ filter,
    CachingWrapperFilter..::..DeletesMode^ deletesMode
)

Parameters

filter
Type: Lucene.Net.Search..::..SpanFilter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.#ctor(Lucene.Net.Search.SpanFilter,Lucene.Net.Search.CachingWrapperFilter.DeletesMode)"]

deletesMode
Type: Lucene.Net.Search..::..CachingWrapperFilter..::..DeletesMode

[Missing <param name="deletesMode"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.#ctor(Lucene.Net.Search.SpanFilter,Lucene.Net.Search.CachingWrapperFilter.DeletesMode)"]

See Also

CachingSpanFilter Class
CachingSpanFilter Overload
Lucene.Net.Search Namespace


CachingSpanFilter Fields

[image] [image]

Lucene.Net Class Libraries
CachingSpanFilter Fields
CachingSpanFilter Class See Also Send Feedback

The CachingSpanFilter type exposes the following members.

Fields

 | Name | Description
Protected field | filter |
Public field | hitCount |
Public field | missCount |

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


filter Field

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..filter Field
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingSpanFilter.filter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SpanFilter filter
Visual Basic
Protected Friend filter As SpanFilter
Visual C++
protected public:
SpanFilter^ filter

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


hitCount Field

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..hitCount Field
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingSpanFilter.hitCount"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int hitCount
Visual Basic
Public hitCount As Integer
Visual C++
public:
int hitCount

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


missCount Field

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..missCount Field
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingSpanFilter.missCount"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int missCount
Visual Basic
Public missCount As Integer
Visual C++
public:
int missCount

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


CachingSpanFilter Methods

[image] [image]

Lucene.Net Class Libraries
CachingSpanFilter Methods
CachingSpanFilter Class See Also Send Feedback

The CachingSpanFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Overrides Filter..::..Bits(IndexReader).)
Public method | BitSpans | (Overrides SpanFilter..::..BitSpans(IndexReader).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


Bits Method

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..Bits Method
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingSpanFilter.Bits(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")]
public override BitArray Bits(
    IndexReader reader
)
Visual Basic
<ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")> _
Public Overrides Function Bits ( _
    reader As IndexReader _
) As BitArray
Visual C++
[ObsoleteAttribute(L"Use GetDocIdSet(IndexReader) instead.")]
public:
virtual BitArray^ Bits(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.Bits(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingSpanFilter.Bits(Lucene.Net.Index.IndexReader)"]

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


BitSpans Method

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..BitSpans Method
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingSpanFilter.BitSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override SpanFilterResult BitSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
Visual C++
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.BitSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingSpanFilter.BitSpans(Lucene.Net.Index.IndexReader)"]

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..Equals Method
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingSpanFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingSpanFilter.Equals(System.Object)"]

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..GetDocIdSet Method
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingSpanFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.CachingSpanFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingSpanFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..GetHashCode Method
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingSpanFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingSpanFilter.GetHashCode"]

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
CachingSpanFilter..::..ToString Method
CachingSpanFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingSpanFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingSpanFilter.ToString"]

See Also

CachingSpanFilter Class
Lucene.Net.Search Namespace


CachingWrapperFilter Class

[image]

Lucene.Net Class Libraries
CachingWrapperFilter Class
Members See Also Send Feedback
Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class CachingWrapperFilter : Filter
Visual Basic
<SerializableAttribute> _
Public Class CachingWrapperFilter _
    Inherits Filter
Visual C++
[SerializableAttribute]
public ref class CachingWrapperFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..CachingWrapperFilter
Lucene.Net.Search..::..QueryFilter

See Also

CachingWrapperFilter Members
Lucene.Net.Search Namespace


CachingWrapperFilter Members

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter Members
CachingWrapperFilter Class Constructors Methods Fields See Also Send Feedback

The CachingWrapperFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CachingWrapperFilter(Filter) | Initializes a new instance of the CachingWrapperFilter class
Public method | CachingWrapperFilter(Filter, CachingWrapperFilter..::..DeletesMode) | Initializes a new instance of the CachingWrapperFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Overrides Filter..::..Bits(IndexReader).)
Protected method | DocIdSetToCache | Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | filter |
Public field | hitCount |
Public field | missCount |

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


CachingWrapperFilter Constructor

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter Constructor
CachingWrapperFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CachingWrapperFilter(Filter) | Initializes a new instance of the CachingWrapperFilter class
Public method | CachingWrapperFilter(Filter, CachingWrapperFilter..::..DeletesMode) | Initializes a new instance of the CachingWrapperFilter class

See Also

CachingWrapperFilter Class
CachingWrapperFilter Members
Lucene.Net.Search Namespace


CachingWrapperFilter Constructor (Filter)

[image]

Lucene.Net Class Libraries
CachingWrapperFilter Constructor (Filter)
CachingWrapperFilter Class See Also Send Feedback
Initializes a new instance of the CachingWrapperFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CachingWrapperFilter(
    Filter filter
)
Visual Basic
Public Sub New ( _
    filter As Filter _
)
Visual C++
public:
CachingWrapperFilter(
    Filter^ filter
)

Parameters

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.#ctor(Lucene.Net.Search.Filter)"]

See Also

CachingWrapperFilter Class
CachingWrapperFilter Overload
Lucene.Net.Search Namespace


CachingWrapperFilter Constructor (Filter, CachingWrapperFilter.DeletesMode)

[image]

Lucene.Net Class Libraries
CachingWrapperFilter Constructor (Filter, CachingWrapperFilter..::..DeletesMode)
CachingWrapperFilter Class See Also Send Feedback
Initializes a new instance of the CachingWrapperFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CachingWrapperFilter(
    Filter filter,
    CachingWrapperFilter..::..DeletesMode deletesMode
)
Visual Basic
Public Sub New ( _
    filter As Filter, _
    deletesMode As CachingWrapperFilter..::..DeletesMode _
)
Visual C++
public:
CachingWrapperFilter(
    Filter^ filter,
    CachingWrapperFilter..::..DeletesMode^ deletesMode
)

Parameters

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.#ctor(Lucene.Net.Search.Filter,Lucene.Net.Search.CachingWrapperFilter.DeletesMode)"]

deletesMode
Type: Lucene.Net.Search..::..CachingWrapperFilter..::..DeletesMode

[Missing <param name="deletesMode"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.#ctor(Lucene.Net.Search.Filter,Lucene.Net.Search.CachingWrapperFilter.DeletesMode)"]

See Also

CachingWrapperFilter Class
CachingWrapperFilter Overload
Lucene.Net.Search Namespace


CachingWrapperFilter Fields

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter Fields
CachingWrapperFilter Class See Also Send Feedback

The CachingWrapperFilter type exposes the following members.

Fields

 | Name | Description
Protected field | filter |
Public field | hitCount |
Public field | missCount |

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


filter Field

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..filter Field
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingWrapperFilter.filter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Filter filter
Visual Basic
Protected Friend filter As Filter
Visual C++
protected public:
Filter^ filter

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


hitCount Field

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..hitCount Field
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingWrapperFilter.hitCount"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int hitCount
Visual Basic
Public hitCount As Integer
Visual C++
public:
int hitCount

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


missCount Field

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..missCount Field
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingWrapperFilter.missCount"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int missCount
Visual Basic
Public missCount As Integer
Visual C++
public:
int missCount

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


CachingWrapperFilter Methods

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter Methods
CachingWrapperFilter Class See Also Send Feedback

The CachingWrapperFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Overrides Filter..::..Bits(IndexReader).)
Protected method | DocIdSetToCache | Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


Bits Method

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..Bits Method
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")]
public override BitArray Bits(
    IndexReader reader
)
Visual Basic
<ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")> _
Public Overrides Function Bits ( _
    reader As IndexReader _
) As BitArray
Visual C++
[ObsoleteAttribute(L"Use GetDocIdSet(IndexReader) instead.")]
public:
virtual BitArray^ Bits(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


DocIdSetToCache Method

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DocIdSetToCache Method
CachingWrapperFilter Class See Also Send Feedback
Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual DocIdSet DocIdSetToCache(
    DocIdSet docIdSet,
    IndexReader reader
)
Visual Basic
Protected Friend Overridable Function DocIdSetToCache ( _
    docIdSet As DocIdSet, _
    reader As IndexReader _
) As DocIdSet
Visual C++
protected public:
virtual DocIdSet^ DocIdSetToCache(
    DocIdSet^ docIdSet,
    IndexReader^ reader
)

Parameters

docIdSet
Type: Lucene.Net.Search..::..DocIdSet

[Missing <param name="docIdSet"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.DocIdSetToCache(Lucene.Net.Search.DocIdSet,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.DocIdSetToCache(Lucene.Net.Search.DocIdSet,Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.DocIdSetToCache(Lucene.Net.Search.DocIdSet,Lucene.Net.Index.IndexReader)"]

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..Equals Method
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.Equals(System.Object)"]

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..GetDocIdSet Method
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..GetHashCode Method
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.GetHashCode"]

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..ToString Method
CachingWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.CachingWrapperFilter.ToString"]

See Also

CachingWrapperFilter Class
Lucene.Net.Search Namespace


CachingWrapperFilter.DeletesMode Class

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode Class
CachingWrapperFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.CachingWrapperFilter.DeletesMode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class DeletesMode : Parameter
Visual Basic
<SerializableAttribute> _
Public Class DeletesMode _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class DeletesMode : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Search..::..CachingWrapperFilter..::..DeletesMode

See Also

CachingWrapperFilter..::..DeletesMode Members
Lucene.Net.Search Namespace


CachingWrapperFilter.DeletesMode Members

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode Members
CachingWrapperFilter..::..DeletesMode Class Methods Fields See Also Send Feedback

Wraps another filter's result and caches it. The purpose is to allow filters to simply filter, and then wrap with this class to add caching.

The CachingWrapperFilter..::..DeletesMode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

Fields

Name | Description
DYNAMIC |
IGNORE |
RECACHE |

See Also

CachingWrapperFilter..::..DeletesMode Class
Lucene.Net.Search Namespace


CachingWrapperFilter.DeletesMode Fields

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode Fields
CachingWrapperFilter..::..DeletesMode Class See Also Send Feedback

The CachingWrapperFilter..::..DeletesMode type exposes the following members.

Fields

Name | Description
DYNAMIC |
IGNORE |
RECACHE |

See Also

CachingWrapperFilter..::..DeletesMode Class
Lucene.Net.Search Namespace


DYNAMIC Field

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode..::..DYNAMIC Field
CachingWrapperFilter..::..DeletesMode Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingWrapperFilter.DeletesMode.DYNAMIC"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static CachingWrapperFilter..::..DeletesMode DYNAMIC
Visual Basic
Public Shared DYNAMIC As CachingWrapperFilter..::..DeletesMode
Visual C++
public:
static CachingWrapperFilter..::..DeletesMode^ DYNAMIC

See Also

CachingWrapperFilter..::..DeletesMode Class
Lucene.Net.Search Namespace


IGNORE Field

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode..::..IGNORE Field
CachingWrapperFilter..::..DeletesMode Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingWrapperFilter.DeletesMode.IGNORE"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static CachingWrapperFilter..::..DeletesMode IGNORE
Visual Basic
Public Shared IGNORE As CachingWrapperFilter..::..DeletesMode
Visual C++
public:
static CachingWrapperFilter..::..DeletesMode^ IGNORE

See Also

CachingWrapperFilter..::..DeletesMode Class
Lucene.Net.Search Namespace


RECACHE Field

[image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode..::..RECACHE Field
CachingWrapperFilter..::..DeletesMode Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.CachingWrapperFilter.DeletesMode.RECACHE"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static CachingWrapperFilter..::..DeletesMode RECACHE
Visual Basic
Public Shared RECACHE As CachingWrapperFilter..::..DeletesMode
Visual C++
public:
static CachingWrapperFilter..::..DeletesMode^ RECACHE

See Also

CachingWrapperFilter..::..DeletesMode Class
Lucene.Net.Search Namespace


CachingWrapperFilter.DeletesMode Methods

[image] [image]

Lucene.Net Class Libraries
CachingWrapperFilter..::..DeletesMode Methods
CachingWrapperFilter..::..DeletesMode Class See Also Send Feedback

The CachingWrapperFilter..::..DeletesMode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from Parameter.)

See Also

CachingWrapperFilter..::..DeletesMode Class
Lucene.Net.Search Namespace


Collector Class

[image]

Lucene.Net Class Libraries
Collector Class
Members See Also Send Feedback

Expert: Collectors are primarily meant to be used to gather raw results from a search, and implement sorting or custom result filtering, collation, etc.

As of 2.9, this class replaces the deprecated HitCollector, and offers an API for efficient collection of hits across sequential {@link IndexReader}s. {@link IndexSearcher} advances the collector through each of the sub readers, in an arbitrary order. This results in a higher performance means of collection.

Lucene's core collectors are derived from Collector. Likely your application can use one of these classes, or subclass {@link TopDocsCollector}, instead of implementing Collector directly:

  • {@link TopDocsCollector} is an abstract base class that assumes you will retrieve the top N docs, according to some criteria, after collection is done.
  • {@link TopScoreDocCollector} is a concrete subclass {@link TopDocsCollector} and sorts according to score + docID. This is used internally by the {@link IndexSearcher} search methods that do not take an explicit {@link Sort}. It is likely the most frequently used collector.
  • {@link TopFieldCollector} subclasses {@link TopDocsCollector} and sorts according to a specified {@link Sort} object (sort by field). This is used internally by the {@link IndexSearcher} search methods that take an explicit {@link Sort}.
  • {@link TimeLimitingCollector}, which wraps any other Collector and aborts the search if it's taken too much time, will subclass Collector in 3.0 (presently it subclasses the deprecated HitCollector).
  • {@link PositiveScoresOnlyCollector} wraps any other Collector and prevents collection of hits whose score is <= 0.0

Collector decouples the score from the collected doc: the score computation is skipped entirely if it's not needed. Collectors that do need the score should implement the {@link #setScorer} method, to hold onto the passed {@link Scorer} instance, and call {@link Scorer#Score()} within the collect method to compute the current hit's score. If your collector may request the score for a single hit multiple times, you should use {@link ScoreCachingWrappingScorer}.

NOTE: The doc that is passed to the collect method is relative to the current reader. If your collector needs to resolve this to the docID space of the Multi*Reader, you must re-base it by recording the docBase from the most recent setNextReader call. Here's a simple example showing how to collect docIDs into a BitSet:

            Searcher searcher = new IndexSearcher(indexReader);
            final BitSet bits = new BitSet(indexReader.maxDoc());
            searcher.search(query, new Collector() {
            private int docBase;

            // ignore scorer
            public void setScorer(Scorer scorer) {
            }

            // accept docs out of order (for a BitSet it doesn't matter)
            public boolean acceptsDocsOutOfOrder() {
            return true;
            }

            public void collect(int doc) {
            bits.set(doc + docBase);
            }

            public void setNextReader(IndexReader reader, int docBase) {
            this.docBase = docBase;
            }
            });

Not all collectors will need to rebase the docID. For example, a collector that simply counts the total number of hits would skip it.

NOTE: Prior to 2.9, Lucene silently filtered out hits with score <= 0. As of 2.9, the core Collectors no longer do that. It's very unusual to have such hits (a negative query boost, or function query returning negative custom scores, could cause it to happen). If you need that behavior, use {@link PositiveScoresOnlyCollector}.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Collector
Visual Basic
Public MustInherit Class Collector
Visual C++
public ref class Collector abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..HitCollectorWrapper
Lucene.Net.Search..::..PositiveScoresOnlyCollector
Lucene.Net.Search..::..TimeLimitingCollector
Lucene.Net.Search..::..TopDocsCollector

See Also

Collector Members
Lucene.Net.Search Namespace


Collector Members

[image] [image]

Lucene.Net Class Libraries
Collector Members
Collector Class Constructors Methods See Also Send Feedback

The Collector type exposes the following members.

Constructors

 | Name | Description
Protected method | Collector | Initializes a new instance of the Collector class

Methods

Name Description
Public method AcceptsDocsOutOfOrder
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetNextReader
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.
Public method SetScorer
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Collector Class
Lucene.Net.Search Namespace


Collector Constructor

[image]

Lucene.Net Class Libraries
Collector Constructor
Collector Class See Also Send Feedback
Initializes a new instance of the Collector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Collector()
Visual Basic
Protected Sub New
Visual C++
protected:
Collector()

See Also

Collector Class
Lucene.Net.Search Namespace


Collector Methods

[image] [image]

Lucene.Net Class Libraries
Collector Methods
Collector Class See Also Send Feedback

The Collector type exposes the following members.

Methods

Name Description
Public method AcceptsDocsOutOfOrder
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetNextReader
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.
Public method SetScorer
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Collector Class
Lucene.Net.Search Namespace


AcceptsDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
Collector..::..AcceptsDocsOutOfOrder Method
Collector Class See Also Send Feedback
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool AcceptsDocsOutOfOrder()
Visual Basic
Public MustOverride Function AcceptsDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool AcceptsDocsOutOfOrder() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Collector.AcceptsDocsOutOfOrder"]

See Also

Collector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
Collector..::..Collect Method
Collector Class See Also Send Feedback
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Collect(
    int doc
)
Visual Basic
Public MustOverride Sub Collect ( _
    doc As Integer _
)
Visual C++
public:
virtual void Collect(
    int doc
) abstract

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Collector.Collect(System.Int32)"]

See Also

Collector Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
Collector..::..SetNextReader Method
Collector Class See Also Send Feedback
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public MustOverride Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
next IndexReader
docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.Collector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

Collector Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
Collector..::..SetScorer Method
Collector Class See Also Send Feedback
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void SetScorer(
    Scorer scorer
)
Visual Basic
Public MustOverride Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
) abstract

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.Collector.SetScorer(Lucene.Net.Search.Scorer)"]

See Also

Collector Class
Lucene.Net.Search Namespace


ComplexExplanation Class

[image]

Lucene.Net Class Libraries
ComplexExplanation Class
Members See Also Send Feedback
Expert: Describes the score computation for document and query, and can distinguish a match independent of a positive value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ComplexExplanation : Explanation
Visual Basic
<SerializableAttribute> _
Public Class ComplexExplanation _
    Inherits Explanation
Visual C++
[SerializableAttribute]
public ref class ComplexExplanation : public Explanation

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Explanation
Lucene.Net.Search..::..ComplexExplanation

See Also

ComplexExplanation Members
Lucene.Net.Search Namespace


ComplexExplanation Members

[image] [image]

Lucene.Net Class Libraries
ComplexExplanation Members
ComplexExplanation Class Constructors Methods See Also Send Feedback

The ComplexExplanation type exposes the following members.

Constructors

 | Name | Description
Public method | ComplexExplanation()()()() | Initializes a new instance of the ComplexExplanation class
Public method | ComplexExplanation(Boolean, Single, String) | Initializes a new instance of the ComplexExplanation class

Methods

 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node. (Inherited from Explanation.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription | A description of this explanation node. (Inherited from Explanation.)
Public method | GetDetails | The sub-nodes of this explanation node. (Inherited from Explanation.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatch | The match status of this explanation node.
Protected method | GetSummary | (Overrides Explanation..::..GetSummary()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | The value assigned to this explanation node. (Inherited from Explanation.)
Public method | IsMatch | Indicates whether or not this Explanation models a good match. If the match status is explicitly set (i.e.: not null) this method uses it; otherwise it defers to the superclass. (Overrides Explanation..::..IsMatch()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDescription | Sets the description of this explanation node. (Inherited from Explanation.)
Public method | SetMatch | Sets the match status assigned to this explanation node.
Public method | SetValue | Sets the value assigned to this explanation node. (Inherited from Explanation.)
Public method | ToHtml | Render an explanation as HTML. (Inherited from Explanation.)
Public method | ToString()()()() | Render an explanation as text. (Inherited from Explanation.)
Public method | ToString(Int32) | (Inherited from Explanation.)

See Also

ComplexExplanation Class
Lucene.Net.Search Namespace


ComplexExplanation Constructor

[image] [image]

Lucene.Net Class Libraries
ComplexExplanation Constructor
ComplexExplanation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComplexExplanation()()()() | Initializes a new instance of the ComplexExplanation class
Public method | ComplexExplanation(Boolean, Single, String) | Initializes a new instance of the ComplexExplanation class

See Also

ComplexExplanation Class
ComplexExplanation Members
Lucene.Net.Search Namespace


ComplexExplanation Constructor

[image]

Lucene.Net Class Libraries
ComplexExplanation Constructor
ComplexExplanation Class See Also Send Feedback
Initializes a new instance of the ComplexExplanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ComplexExplanation()
Visual Basic
Public Sub New
Visual C++
public:
ComplexExplanation()

See Also

ComplexExplanation Class
ComplexExplanation Overload
Lucene.Net.Search Namespace


ComplexExplanation Constructor (Boolean, Single, String)

[image]

Lucene.Net Class Libraries
ComplexExplanation Constructor (Boolean, Single, String)
ComplexExplanation Class See Also Send Feedback
Initializes a new instance of the ComplexExplanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ComplexExplanation(
    bool match,
    float value_Renamed,
    string description
)
Visual Basic
Public Sub New ( _
    match As Boolean, _
    value_Renamed As Single, _
    description As String _
)
Visual C++
public:
ComplexExplanation(
    bool match,
    float value_Renamed,
    String^ description
)

Parameters

match
Type: System..::..Boolean

[Missing <param name="match"/> documentation for "M:Lucene.Net.Search.ComplexExplanation.#ctor(System.Boolean,System.Single,System.String)"]

value_Renamed
Type: System..::..Single

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Search.ComplexExplanation.#ctor(System.Boolean,System.Single,System.String)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:Lucene.Net.Search.ComplexExplanation.#ctor(System.Boolean,System.Single,System.String)"]

See Also

ComplexExplanation Class
ComplexExplanation Overload
Lucene.Net.Search Namespace


ComplexExplanation Methods

[image] [image]

Lucene.Net Class Libraries
ComplexExplanation Methods
ComplexExplanation Class See Also Send Feedback

The ComplexExplanation type exposes the following members.

Methods

 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node. (Inherited from Explanation.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription | A description of this explanation node. (Inherited from Explanation.)
Public method | GetDetails | The sub-nodes of this explanation node. (Inherited from Explanation.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatch | The match status of this explanation node.
Protected method | GetSummary | (Overrides Explanation..::..GetSummary()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | The value assigned to this explanation node. (Inherited from Explanation.)
Public method | IsMatch | Indicates whether or not this Explanation models a good match. If the match status is explicitly set (i.e.: not null) this method uses it; otherwise it defers to the superclass. (Overrides Explanation..::..IsMatch()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDescription | Sets the description of this explanation node. (Inherited from Explanation.)
Public method | SetMatch | Sets the match status assigned to this explanation node.
Public method | SetValue | Sets the value assigned to this explanation node. (Inherited from Explanation.)
Public method | ToHtml | Render an explanation as HTML. (Inherited from Explanation.)
Public method | ToString()()()() | Render an explanation as text. (Inherited from Explanation.)
Public method | ToString(Int32) | (Inherited from Explanation.)

See Also

ComplexExplanation Class
Lucene.Net.Search Namespace


GetMatch Method

[image]

Lucene.Net Class Libraries
ComplexExplanation..::..GetMatch Method
ComplexExplanation Class See Also Send Feedback
The match status of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Nullable<bool> GetMatch()
Visual Basic
Public Overridable Function GetMatch As Nullable(Of Boolean)
Visual C++
public:
virtual Nullable<bool> GetMatch()

Return Value

May be null if match status is unknown

See Also

ComplexExplanation Class
Lucene.Net.Search Namespace


GetSummary Method

[image]

Lucene.Net Class Libraries
ComplexExplanation..::..GetSummary Method
ComplexExplanation Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ComplexExplanation.GetSummary"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override string GetSummary()
Visual Basic
Protected Friend Overrides Function GetSummary As String
Visual C++
protected public:
virtual String^ GetSummary() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ComplexExplanation.GetSummary"]

See Also

ComplexExplanation Class
Lucene.Net.Search Namespace


IsMatch Method

[image]

Lucene.Net Class Libraries
ComplexExplanation..::..IsMatch Method
ComplexExplanation Class See Also Send Feedback
Indicates whether or not this Explanation models a good match.

If the match status is explicitly set (i.e.: not null) this method uses it; otherwise it defers to the superclass.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsMatch()
Visual Basic
Public Overrides Function IsMatch As Boolean
Visual C++
public:
virtual bool IsMatch() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ComplexExplanation.IsMatch"]

See Also

ComplexExplanation Class
Lucene.Net.Search Namespace
[!:getMatch]


SetMatch Method

[image]

Lucene.Net Class Libraries
ComplexExplanation..::..SetMatch Method
ComplexExplanation Class See Also Send Feedback
Sets the match status assigned to this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMatch(
    Nullable<bool> match
)
Visual Basic
Public Overridable Sub SetMatch ( _
    match As Nullable(Of Boolean) _
)
Visual C++
public:
virtual void SetMatch(
    Nullable<bool> match
)

Parameters

match
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
May be null if match status is unknown

See Also

ComplexExplanation Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
ComplexExplanation..::..ToString Method
ComplexExplanation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Render an explanation as text. (Inherited from Explanation.)
Public method | ToString(Int32) | (Inherited from Explanation.)

See Also

ComplexExplanation Class
ComplexExplanation Members
Lucene.Net.Search Namespace


ConstantScoreQuery Class

[image]

Lucene.Net Class Libraries
ConstantScoreQuery Class
Members See Also Send Feedback
A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ConstantScoreQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class ConstantScoreQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class ConstantScoreQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..ConstantScoreQuery

See Also

ConstantScoreQuery Members
Lucene.Net.Search Namespace


ConstantScoreQuery Members

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery Members
ConstantScoreQuery Class Constructors Methods Fields See Also Send Feedback

The ConstantScoreQuery type exposes the following members.

Constructors

 | Name | Description
Public method | ConstantScoreQuery | Initializes a new instance of the ConstantScoreQuery class

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetFilter
Returns the encapsulated filter
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | filter |

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


ConstantScoreQuery Constructor

[image]

Lucene.Net Class Libraries
ConstantScoreQuery Constructor
ConstantScoreQuery Class See Also Send Feedback
Initializes a new instance of the ConstantScoreQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScoreQuery(
    Filter filter
)
Visual Basic
Public Sub New ( _
    filter As Filter _
)
Visual C++
public:
ConstantScoreQuery(
    Filter^ filter
)

Parameters

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.#ctor(Lucene.Net.Search.Filter)"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


ConstantScoreQuery Fields

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery Fields
ConstantScoreQuery Class See Also Send Feedback

The ConstantScoreQuery type exposes the following members.

Fields

 | Name | Description
Protected field | filter |

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


filter Field

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..filter Field
ConstantScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.ConstantScoreQuery.filter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Filter filter
Visual Basic
Protected Friend filter As Filter
Visual C++
protected public:
Filter^ filter

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


ConstantScoreQuery Methods

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery Methods
ConstantScoreQuery Class See Also Send Feedback

The ConstantScoreQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetFilter
Returns the encapsulated filter
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


Clone Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..Clone Method
ConstantScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Clone"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..CreateWeight Method
ConstantScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..Equals Method
ConstantScoreQuery Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Equals(System.Object)"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ExtractTerms Method
ConstantScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


GetFilter Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..GetFilter Method
ConstantScoreQuery Class See Also Send Feedback
Returns the encapsulated filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Filter GetFilter()
Visual Basic
Public Overridable Function GetFilter As Filter
Visual C++
public:
virtual Filter^ GetFilter()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.GetFilter"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..GetHashCode Method
ConstantScoreQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.GetHashCode"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..Rewrite Method
ConstantScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

ConstantScoreQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ToString Method
ConstantScoreQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

ConstantScoreQuery Class
ConstantScoreQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ToString Method (String)
ConstantScoreQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ToString(System.String)"]

See Also

ConstantScoreQuery Class
ToString Overload
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Class

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer Class
ConstantScoreQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class ConstantScorer : Scorer
Visual Basic
Protected Friend Class ConstantScorer _
    Inherits Scorer
Visual C++
protected public ref class ConstantScorer : public Scorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search..::..ConstantScoreQuery..::..ConstantScorer

See Also

ConstantScoreQuery..::..ConstantScorer Members
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Members

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer Members
ConstantScoreQuery..::..ConstantScorer Class Constructors Methods Properties See Also Send Feedback

A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.

The ConstantScoreQuery..::..ConstantScorer type exposes the following members.

Constructors

 | Name | Description
Public method | ConstantScoreQuery..::..ConstantScorer | Initializes a new instance of the ConstantScoreQuery..::..ConstantScorer class

Methods

Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Constructor

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer Constructor
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback
Initializes a new instance of the ConstantScoreQuery..::..ConstantScorer class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScorer(
    ConstantScoreQuery enclosingInstance,
    Similarity similarity,
    IndexReader reader,
    Weight w
)
Visual Basic
Public Sub New ( _
    enclosingInstance As ConstantScoreQuery, _
    similarity As Similarity, _
    reader As IndexReader, _
    w As Weight _
)
Visual C++
public:
ConstantScorer(
    ConstantScoreQuery^ enclosingInstance,
    Similarity^ similarity,
    IndexReader^ reader,
    Weight^ w
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..ConstantScoreQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.#ctor(Lucene.Net.Search.ConstantScoreQuery,Lucene.Net.Search.Similarity,Lucene.Net.Index.IndexReader,Lucene.Net.Search.Weight)"]

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.#ctor(Lucene.Net.Search.ConstantScoreQuery,Lucene.Net.Search.Similarity,Lucene.Net.Index.IndexReader,Lucene.Net.Search.Weight)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.#ctor(Lucene.Net.Search.ConstantScoreQuery,Lucene.Net.Search.Similarity,Lucene.Net.Index.IndexReader,Lucene.Net.Search.Weight)"]

w
Type: Lucene.Net.Search..::..Weight

[Missing <param name="w"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.#ctor(Lucene.Net.Search.ConstantScoreQuery,Lucene.Net.Search.Similarity,Lucene.Net.Index.IndexReader,Lucene.Net.Search.Weight)"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Methods

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer Methods
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

The ConstantScoreQuery..::..ConstantScorer type exposes the following members.

Methods

Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Advance Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Advance(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Advance(System.Int32)"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Doc Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Doc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead. ")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead. ")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead. ")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Doc"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..DocID Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.DocID"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Explain Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Explain(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Explain(System.Int32)"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Next Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Next"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Next"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..NextDoc Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.NextDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.NextDoc"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Score Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

Overload List

Name | Description
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)

See Also

ConstantScoreQuery..::..ConstantScorer Class
ConstantScoreQuery..::..ConstantScorer Members
Lucene.Net.Search Namespace


Score Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Score Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Score"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Score"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Score Overload
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..SkipTo Method
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead. ")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead. ")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead. ")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.SkipTo(System.Int32)"]

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantScorer Properties

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer Properties
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

The ConstantScoreQuery..::..ConstantScorer type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantScorer..::..Enclosing_Instance Property
ConstantScoreQuery..::..ConstantScorer Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.ConstantScoreQuery.ConstantScorer.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScoreQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As ConstantScoreQuery
    Get
Visual C++
public:
property ConstantScoreQuery^ Enclosing_Instance {
    ConstantScoreQuery^ get ();
}

See Also

ConstantScoreQuery..::..ConstantScorer Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Class

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight Class
ConstantScoreQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
protected internal class ConstantWeight : Weight
Visual Basic
<SerializableAttribute> _
Protected Friend Class ConstantWeight _
    Inherits Weight
Visual C++
[SerializableAttribute]
protected public ref class ConstantWeight : public Weight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search..::..ConstantScoreQuery..::..ConstantWeight

See Also

ConstantScoreQuery..::..ConstantWeight Members
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Members

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight Members
ConstantScoreQuery..::..ConstantWeight Class Constructors Methods Properties See Also Send Feedback

A query that wraps a filter and simply returns a constant score equal to the query boost for every document in the filter.

The ConstantScoreQuery..::..ConstantWeight type exposes the following members.

Constructors

 | Name | Description
Public method | ConstantScoreQuery..::..ConstantWeight | Initializes a new instance of the ConstantScoreQuery..::..ConstantWeight class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Constructor

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight Constructor
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback
Initializes a new instance of the ConstantScoreQuery..::..ConstantWeight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantWeight(
    ConstantScoreQuery enclosingInstance,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    enclosingInstance As ConstantScoreQuery, _
    searcher As Searcher _
)
Visual C++
public:
ConstantWeight(
    ConstantScoreQuery^ enclosingInstance,
    Searcher^ searcher
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..ConstantScoreQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.#ctor(Lucene.Net.Search.ConstantScoreQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.#ctor(Lucene.Net.Search.ConstantScoreQuery,Lucene.Net.Search.Searcher)"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Methods

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight Methods
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

The ConstantScoreQuery..::..ConstantWeight type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..Explain Method
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..GetQuery Method
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.GetQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetQuery()
Visual Basic
Public Overrides Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.GetQuery"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..GetValue Method
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.GetValue"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float GetValue()
Visual Basic
Public Overrides Function GetValue As Single
Visual C++
public:
virtual float GetValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.GetValue"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..Normalize Method
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Normalize(System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Normalize(
    float norm
)
Visual Basic
Public Overrides Sub Normalize ( _
    norm As Single _
)
Visual C++
public:
virtual void Normalize(
    float norm
) override

Parameters

norm
Type: System..::..Single

[Missing <param name="norm"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Normalize(System.Single)"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..Scorer Method
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


SumOfSquaredWeights Method

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..SumOfSquaredWeights Method
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.SumOfSquaredWeights"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float SumOfSquaredWeights()
Visual Basic
Public Overrides Function SumOfSquaredWeights As Single
Visual C++
public:
virtual float SumOfSquaredWeights() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.SumOfSquaredWeights"]

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


ConstantScoreQuery.ConstantWeight Properties

[image] [image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight Properties
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

The ConstantScoreQuery..::..ConstantWeight type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
ConstantScoreQuery..::..ConstantWeight..::..Enclosing_Instance Property
ConstantScoreQuery..::..ConstantWeight Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.ConstantScoreQuery.ConstantWeight.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScoreQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As ConstantScoreQuery
    Get
Visual C++
public:
property ConstantScoreQuery^ Enclosing_Instance {
    ConstantScoreQuery^ get ();
}

See Also

ConstantScoreQuery..::..ConstantWeight Class
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Class

[image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Class
Members See Also Send Feedback
A range query that returns a constant score equal to its boost for all documents in the exclusive range of terms.

It does not have an upper bound on the number of clauses covered in the range.

This query matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeQuery} instead.

This query is hardwired to {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}. If you want to change this, use {@link TermRangeQuery} instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Use TermRangeQuery for term ranges or NumericRangeQuery for numeric ranges instead. This class will be removed in Lucene 3.0.")]
public class ConstantScoreRangeQuery : TermRangeQuery
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Use TermRangeQuery for term ranges or NumericRangeQuery for numeric ranges instead. This class will be removed in Lucene 3.0.")> _
Public Class ConstantScoreRangeQuery _
    Inherits TermRangeQuery
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Use TermRangeQuery for term ranges or NumericRangeQuery for numeric ranges instead. This class will be removed in Lucene 3.0.")]
public ref class ConstantScoreRangeQuery : public TermRangeQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..TermRangeQuery
Lucene.Net.Search..::..ConstantScoreRangeQuery

See Also

ConstantScoreRangeQuery Members
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Members

[image] [image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Members
ConstantScoreRangeQuery Class Constructors Methods Fields See Also Send Feedback

The ConstantScoreRangeQuery type exposes the following members.

Constructors

 | Name | Description
Public method | ConstantScoreRangeQuery(String, String, String, Boolean, Boolean) | Initializes a new instance of the ConstantScoreRangeQuery class
Public method | ConstantScoreRangeQuery(String, String, String, Boolean, Boolean, CompareInfo) | Initializes a new instance of the ConstantScoreRangeQuery class

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Inherited from TermRangeQuery.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
(Inherited from TermRangeQuery.)
Public method | GetEnum | (Inherited from TermRangeQuery.)
Public method GetField
Returns the field name for this query
(Inherited from TermRangeQuery.)
Public method | GetHashCode | (Inherited from TermRangeQuery.)
Public method GetLowerTerm
Returns the lower value of this range query
(Inherited from TermRangeQuery.)
Public method | GetLowerVal
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper value of this range query
(Inherited from TermRangeQuery.)
Public method | GetUpperVal
Public method IncludesLower
Returns
CopyC#
true
 if the lower endpoint is inclusive
(Inherited from TermRangeQuery.)
Public method IncludesUpper
Returns
CopyC#
true
 if the upper endpoint is inclusive
(Inherited from TermRangeQuery.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Changes of mode are not supported by this class (fixed to constant score rewrite mode)
(Overrides MultiTermQuery..::..SetRewriteMethod(MultiTermQuery..::..RewriteMethod).)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Inherited from TermRangeQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

ConstantScoreRangeQuery Class
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Constructor

[image] [image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Constructor
ConstantScoreRangeQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConstantScoreRangeQuery(String, String, String, Boolean, Boolean) | Initializes a new instance of the ConstantScoreRangeQuery class
Public method | ConstantScoreRangeQuery(String, String, String, Boolean, Boolean, CompareInfo) | Initializes a new instance of the ConstantScoreRangeQuery class

See Also

ConstantScoreRangeQuery Class
ConstantScoreRangeQuery Members
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Constructor (String, String, String, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Constructor (String, String, String, Boolean, Boolean)
ConstantScoreRangeQuery Class See Also Send Feedback
Initializes a new instance of the ConstantScoreRangeQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScoreRangeQuery(
    string fieldName,
    string lowerVal,
    string upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    lowerVal As String, _
    upperVal As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Visual C++
public:
ConstantScoreRangeQuery(
    String^ fieldName,
    String^ lowerVal,
    String^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..String

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..String

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

See Also

ConstantScoreRangeQuery Class
ConstantScoreRangeQuery Overload
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo)

[image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo)
ConstantScoreRangeQuery Class See Also Send Feedback
Initializes a new instance of the ConstantScoreRangeQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScoreRangeQuery(
    string fieldName,
    string lowerVal,
    string upperVal,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    lowerVal As String, _
    upperVal As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Visual C++
public:
ConstantScoreRangeQuery(
    String^ fieldName,
    String^ lowerVal,
    String^ upperVal,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

lowerVal
Type: System..::..String

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

upperVal
Type: System..::..String

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

collator
Type: System.Globalization..::..CompareInfo

[Missing <param name="collator"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

See Also

ConstantScoreRangeQuery Class
ConstantScoreRangeQuery Overload
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Fields

[image] [image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Fields
ConstantScoreRangeQuery Class See Also Send Feedback

The ConstantScoreRangeQuery type exposes the following members.

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

ConstantScoreRangeQuery Class
Lucene.Net.Search Namespace


ConstantScoreRangeQuery Methods

[image] [image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery Methods
ConstantScoreRangeQuery Class See Also Send Feedback

The ConstantScoreRangeQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Inherited from TermRangeQuery.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
(Inherited from TermRangeQuery.)
Public method | GetEnum | (Inherited from TermRangeQuery.)
Public method GetField
Returns the field name for this query
(Inherited from TermRangeQuery.)
Public method | GetHashCode | (Inherited from TermRangeQuery.)
Public method GetLowerTerm
Returns the lower value of this range query
(Inherited from TermRangeQuery.)
Public method | GetLowerVal
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper value of this range query
(Inherited from TermRangeQuery.)
Public method | GetUpperVal
Public method IncludesLower
Returns
CopyC#
true
 if the lower endpoint is inclusive
(Inherited from TermRangeQuery.)
Public method IncludesUpper
Returns
CopyC#
true
 if the upper endpoint is inclusive
(Inherited from TermRangeQuery.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Changes of mode are not supported by this class (fixed to constant score rewrite mode)
(Overrides MultiTermQuery..::..SetRewriteMethod(MultiTermQuery..::..RewriteMethod).)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Inherited from TermRangeQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

ConstantScoreRangeQuery Class
Lucene.Net.Search Namespace


GetLowerVal Method

[image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery..::..GetLowerVal Method
ConstantScoreRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.GetLowerVal"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLowerVal()
Visual Basic
Public Overridable Function GetLowerVal As String
Visual C++
public:
virtual String^ GetLowerVal()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.GetLowerVal"]

See Also

ConstantScoreRangeQuery Class
Lucene.Net.Search Namespace


GetUpperVal Method

[image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery..::..GetUpperVal Method
ConstantScoreRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.GetUpperVal"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetUpperVal()
Visual Basic
Public Overridable Function GetUpperVal As String
Visual C++
public:
virtual String^ GetUpperVal()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.GetUpperVal"]

See Also

ConstantScoreRangeQuery Class
Lucene.Net.Search Namespace


SetRewriteMethod Method

[image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery..::..SetRewriteMethod Method
ConstantScoreRangeQuery Class See Also Send Feedback
Changes of mode are not supported by this class (fixed to constant score rewrite mode)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetRewriteMethod(
    MultiTermQuery..::..RewriteMethod method
)
Visual Basic
Public Overrides Sub SetRewriteMethod ( _
    method As MultiTermQuery..::..RewriteMethod _
)
Visual C++
public:
virtual void SetRewriteMethod(
    MultiTermQuery..::..RewriteMethod^ method
) override

Parameters

method
Type: Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod

[Missing <param name="method"/> documentation for "M:Lucene.Net.Search.ConstantScoreRangeQuery.SetRewriteMethod(Lucene.Net.Search.MultiTermQuery.RewriteMethod)"]

See Also

ConstantScoreRangeQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
ConstantScoreRangeQuery..::..ToString Method
ConstantScoreRangeQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Inherited from TermRangeQuery.)

See Also

ConstantScoreRangeQuery Class
ConstantScoreRangeQuery Members
Lucene.Net.Search Namespace


CreationPlaceholder Class

[image]

Lucene.Net Class Libraries
CreationPlaceholder Class
Members See Also Send Feedback
Expert: Maintains caches of term values.

Created: May 19, 2004 11:13:14 AM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class CreationPlaceholder
Visual Basic
Public NotInheritable Class CreationPlaceholder
Visual C++
public ref class CreationPlaceholder sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..CreationPlaceholder

See Also

CreationPlaceholder Members
Lucene.Net.Search Namespace
Lucene.Net.Util..::..FieldCacheSanityChecker


CreationPlaceholder Members

[image] [image]

Lucene.Net Class Libraries
CreationPlaceholder Members
CreationPlaceholder Class Constructors Methods See Also Send Feedback

The CreationPlaceholder type exposes the following members.

Constructors

 | Name | Description
Public method | CreationPlaceholder | Initializes a new instance of the CreationPlaceholder class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreationPlaceholder Class
Lucene.Net.Search Namespace


CreationPlaceholder Constructor

[image]

Lucene.Net Class Libraries
CreationPlaceholder Constructor
CreationPlaceholder Class See Also Send Feedback
Initializes a new instance of the CreationPlaceholder class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CreationPlaceholder()
Visual Basic
Public Sub New
Visual C++
public:
CreationPlaceholder()

See Also

CreationPlaceholder Class
Lucene.Net.Search Namespace


CreationPlaceholder Methods

[image] [image]

Lucene.Net Class Libraries
CreationPlaceholder Methods
CreationPlaceholder Class See Also Send Feedback

The CreationPlaceholder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreationPlaceholder Class
Lucene.Net.Search Namespace


DefaultSimilarity Class

[image]

Lucene.Net Class Libraries
DefaultSimilarity Class
Members See Also Send Feedback
Expert: Default scoring implementation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class DefaultSimilarity : Similarity
Visual Basic
<SerializableAttribute> _
Public Class DefaultSimilarity _
    Inherits Similarity
Visual C++
[SerializableAttribute]
public ref class DefaultSimilarity : public Similarity

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Similarity
Lucene.Net.Search..::..DefaultSimilarity

See Also

DefaultSimilarity Members
Lucene.Net.Search Namespace


DefaultSimilarity Members

[image] [image]

Lucene.Net Class Libraries
DefaultSimilarity Members
DefaultSimilarity Class Constructors Methods Fields See Also Send Feedback

The DefaultSimilarity type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultSimilarity | Initializes a new instance of the DefaultSimilarity class

Methods

Name | Description
Public method ComputeNorm
Implemented as
CopyC#
state.getBoost()*lengthNorm(numTerms)
, where
CopyC#
numTerms
 is {@link FieldInvertState#GetLength()} if {@link #setDiscountOverlaps} is false, else it's {@link FieldInvertState#GetLength()} - {@link FieldInvertState#GetNumOverlap()}.

WARNING: This API is new and experimental, and may suddenly change.

(Overrides Similarity..::..ComputeNorm(String, FieldInvertState).)
Public method Coord
Implemented as
CopyC#
overlap / maxOverlap
.
(Overrides Similarity..::..Coord(Int32, Int32).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetDiscountOverlaps
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Idf(Int32, Int32)
Implemented as
CopyC#
log(numDocs/(docFreq+1)) + 1
.
(Overrides Similarity..::..Idf(Int32, Int32).)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

(Inherited from Similarity.)
Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method idfExplain
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

(Inherited from Similarity.)
Public method IdfExplain
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method LengthNorm
Implemented as
CopyC#
1/sqrt(numTerms)
.
(Overrides Similarity..::..LengthNorm(String, Int32).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method QueryNorm
Implemented as
CopyC#
1/sqrt(sumOfSquaredWeights)
.
(Overrides Similarity..::..QueryNorm(Single).)
Public method ScorePayload(String, array<Byte>[]()[][], Int32, Int32) Obsolete.
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

(Inherited from Similarity.)
Public method ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

(Inherited from Similarity.)
Public method SetDiscountOverlaps
Determines whether overlap tokens (Tokens with 0 position increment) are ignored when computing norm. By default this is false, meaning overlap tokens are counted just like non-overlap tokens.

WARNING: This API is new and experimental, and may suddenly change.

Public method SloppyFreq
Implemented as
CopyC#
1 / (distance + 1)
.
(Overrides Similarity..::..SloppyFreq(Int32).)
Public method Tf(Single)
Implemented as
CopyC#
sqrt(freq)
.
(Overrides Similarity..::..Tf(Single).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

(Inherited from Similarity.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | discountOverlaps |

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


DefaultSimilarity Constructor

[image]

Lucene.Net Class Libraries
DefaultSimilarity Constructor
DefaultSimilarity Class See Also Send Feedback
Initializes a new instance of the DefaultSimilarity class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DefaultSimilarity()
Visual Basic
Public Sub New
Visual C++
public:
DefaultSimilarity()

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


DefaultSimilarity Fields

[image] [image]

Lucene.Net Class Libraries
DefaultSimilarity Fields
DefaultSimilarity Class See Also Send Feedback

The DefaultSimilarity type exposes the following members.

Fields

 | Name | Description
Protected field | discountOverlaps |

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


discountOverlaps Field

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..discountOverlaps Field
DefaultSimilarity Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.DefaultSimilarity.discountOverlaps"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool discountOverlaps
Visual Basic
Protected Friend discountOverlaps As Boolean
Visual C++
protected public:
bool discountOverlaps

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


DefaultSimilarity Methods

[image] [image]

Lucene.Net Class Libraries
DefaultSimilarity Methods
DefaultSimilarity Class See Also Send Feedback

The DefaultSimilarity type exposes the following members.

Methods

Name | Description
Public method ComputeNorm
Implemented as
CopyC#
state.getBoost()*lengthNorm(numTerms)
, where
CopyC#
numTerms
 is {@link FieldInvertState#GetLength()} if {@link #setDiscountOverlaps} is false, else it's {@link FieldInvertState#GetLength()} - {@link FieldInvertState#GetNumOverlap()}.

WARNING: This API is new and experimental, and may suddenly change.

(Overrides Similarity..::..ComputeNorm(String, FieldInvertState).)
Public method Coord
Implemented as
CopyC#
overlap / maxOverlap
.
(Overrides Similarity..::..Coord(Int32, Int32).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetDiscountOverlaps
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Idf(Int32, Int32)
Implemented as
CopyC#
log(numDocs/(docFreq+1)) + 1
.
(Overrides Similarity..::..Idf(Int32, Int32).)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

(Inherited from Similarity.)
Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method idfExplain
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

(Inherited from Similarity.)
Public method IdfExplain
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method LengthNorm
Implemented as
CopyC#
1/sqrt(numTerms)
.
(Overrides Similarity..::..LengthNorm(String, Int32).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method QueryNorm
Implemented as
CopyC#
1/sqrt(sumOfSquaredWeights)
.
(Overrides Similarity..::..QueryNorm(Single).)
Public method ScorePayload(String, array<Byte>[]()[][], Int32, Int32) Obsolete.
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

(Inherited from Similarity.)
Public method ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

(Inherited from Similarity.)
Public method SetDiscountOverlaps
Determines whether overlap tokens (Tokens with 0 position increment) are ignored when computing norm. By default this is false, meaning overlap tokens are counted just like non-overlap tokens.

WARNING: This API is new and experimental, and may suddenly change.

Public method SloppyFreq
Implemented as
CopyC#
1 / (distance + 1)
.
(Overrides Similarity..::..SloppyFreq(Int32).)
Public method Tf(Single)
Implemented as
CopyC#
sqrt(freq)
.
(Overrides Similarity..::..Tf(Single).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

(Inherited from Similarity.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


ComputeNorm Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..ComputeNorm Method
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
state.getBoost()*lengthNorm(numTerms)
, where
CopyC#
numTerms
 is {@link FieldInvertState#GetLength()} if {@link #setDiscountOverlaps} is false, else it's {@link FieldInvertState#GetLength()} - {@link FieldInvertState#GetNumOverlap()}.

WARNING: This API is new and experimental, and may suddenly change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float ComputeNorm(
    string field,
    FieldInvertState state
)
Visual Basic
Public Overrides Function ComputeNorm ( _
    field As String, _
    state As FieldInvertState _
) As Single
Visual C++
public:
virtual float ComputeNorm(
    String^ field,
    FieldInvertState^ state
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

state
Type: Lucene.Net.Index..::..FieldInvertState

[Missing <param name="state"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


Coord Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..Coord Method
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
overlap / maxOverlap
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Coord(
    int overlap,
    int maxOverlap
)
Visual Basic
Public Overrides Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
Visual C++
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) override

Parameters

overlap
Type: System..::..Int32

[Missing <param name="overlap"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Coord(System.Int32,System.Int32)"]

maxOverlap
Type: System..::..Int32

[Missing <param name="maxOverlap"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Coord(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Coord(System.Int32,System.Int32)"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


GetDiscountOverlaps Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..GetDiscountOverlaps Method
DefaultSimilarity Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DefaultSimilarity.GetDiscountOverlaps"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetDiscountOverlaps()
Visual Basic
Public Overridable Function GetDiscountOverlaps As Boolean
Visual C++
public:
virtual bool GetDiscountOverlaps()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.GetDiscountOverlaps"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace
[!:setDiscountOverlaps]


Idf Method

[image] [image]

Lucene.Net Class Libraries
DefaultSimilarity..::..Idf Method
DefaultSimilarity Class See Also Send Feedback

Overload List

Name Description
Public method Idf(Int32, Int32)
Implemented as
CopyC#
log(numDocs/(docFreq+1)) + 1
.
(Overrides Similarity..::..Idf(Int32, Int32).)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

(Inherited from Similarity.)
Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)

See Also

DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace


Idf Method (Int32, Int32)

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..Idf Method (Int32, Int32)
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
log(numDocs/(docFreq+1)) + 1
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Idf(
    int docFreq,
    int numDocs
)
Visual Basic
Public Overrides Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
Visual C++
public:
virtual float Idf(
    int docFreq,
    int numDocs
) override

Parameters

docFreq
Type: System..::..Int32

[Missing <param name="docFreq"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Idf(System.Int32,System.Int32)"]

numDocs
Type: System..::..Int32

[Missing <param name="numDocs"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Idf(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Idf(System.Int32,System.Int32)"]

See Also

DefaultSimilarity Class
Idf Overload
Lucene.Net.Search Namespace


LengthNorm Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..LengthNorm Method
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
1/sqrt(numTerms)
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float LengthNorm(
    string fieldName,
    int numTerms
)
Visual Basic
Public Overrides Function LengthNorm ( _
    fieldName As String, _
    numTerms As Integer _
) As Single
Visual C++
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTerms
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.LengthNorm(System.String,System.Int32)"]

numTerms
Type: System..::..Int32

[Missing <param name="numTerms"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.LengthNorm(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.LengthNorm(System.String,System.Int32)"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


QueryNorm Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..QueryNorm Method
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
1/sqrt(sumOfSquaredWeights)
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float QueryNorm(
    float sumOfSquaredWeights
)
Visual Basic
Public Overrides Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
Visual C++
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) override

Parameters

sumOfSquaredWeights
Type: System..::..Single

[Missing <param name="sumOfSquaredWeights"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.QueryNorm(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.QueryNorm(System.Single)"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


ScorePayload Method

[image] [image]

Lucene.Net Class Libraries
DefaultSimilarity..::..ScorePayload Method
DefaultSimilarity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScorePayload(String, array<Byte>[]()[][], Int32, Int32) | Obsolete. Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array. The default implementation returns 1. (Inherited from Similarity.)
Public method | ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32) | Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array. The default implementation returns 1. (Inherited from Similarity.)

See Also

DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace


SetDiscountOverlaps Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..SetDiscountOverlaps Method
DefaultSimilarity Class See Also Send Feedback
Determines whether overlap tokens (Tokens with 0 position increment) are ignored when computing norm. By default this is false, meaning overlap tokens are counted just like non-overlap tokens.

WARNING: This API is new and experimental, and may suddenly change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDiscountOverlaps(
    bool v
)
Visual Basic
Public Overridable Sub SetDiscountOverlaps ( _
    v As Boolean _
)
Visual C++
public:
virtual void SetDiscountOverlaps(
    bool v
)

Parameters

v
Type: System..::..Boolean

[Missing <param name="v"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.SetDiscountOverlaps(System.Boolean)"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace
[!:computeNorm]


SloppyFreq Method

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..SloppyFreq Method
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
1 / (distance + 1)
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float SloppyFreq(
    int distance
)
Visual Basic
Public Overrides Function SloppyFreq ( _
    distance As Integer _
) As Single
Visual C++
public:
virtual float SloppyFreq(
    int distance
) override

Parameters

distance
Type: System..::..Int32

[Missing <param name="distance"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.SloppyFreq(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.SloppyFreq(System.Int32)"]

See Also

DefaultSimilarity Class
Lucene.Net.Search Namespace


Tf Method

[image] [image]

Lucene.Net Class Libraries
DefaultSimilarity..::..Tf Method
DefaultSimilarity Class See Also Send Feedback

Overload List

Name Description
Public method Tf(Single)
Implemented as
CopyC#
sqrt(freq)
.
(Overrides Similarity..::..Tf(Single).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

(Inherited from Similarity.)

See Also

DefaultSimilarity Class
DefaultSimilarity Members
Lucene.Net.Search Namespace


Tf Method (Single)

[image]

Lucene.Net Class Libraries
DefaultSimilarity..::..Tf Method (Single)
DefaultSimilarity Class See Also Send Feedback
Implemented as
CopyC#
sqrt(freq)
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Tf(
    float freq
)
Visual Basic
Public Overrides Function Tf ( _
    freq As Single _
) As Single
Visual C++
public:
virtual float Tf(
    float freq
) override

Parameters

freq
Type: System..::..Single

[Missing <param name="freq"/> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Tf(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DefaultSimilarity.Tf(System.Single)"]

See Also

DefaultSimilarity Class
Tf Overload
Lucene.Net.Search Namespace


DisjunctionMaxQuery Class

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery Class
Members See Also Send Feedback
A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class DisjunctionMaxQuery : Query,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class DisjunctionMaxQuery _
    Inherits Query _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class DisjunctionMaxQuery : public Query,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..DisjunctionMaxQuery

See Also

DisjunctionMaxQuery Members
Lucene.Net.Search Namespace


DisjunctionMaxQuery Members

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery Members
DisjunctionMaxQuery Class Constructors Methods See Also Send Feedback

The DisjunctionMaxQuery type exposes the following members.

Constructors

 | Name | Description
Public method | DisjunctionMaxQuery(Single) | Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.
Public method | DisjunctionMaxQuery(ICollection, Single) | Creates a new DisjunctionMaxQuery

Methods

Name | Description
Public method Add(ICollection)
Add a collection of disjuncts to this disjunction via Iterable
Public method Add(Query)
Add a subquery to this disjunction
Public method Clone
Create a shallow copy of us -- used in rewriting if necessary
(Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Return true iff we represent the same query as o
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Compute a hash code for hashing us
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Iterator
An Iterator<Query> over the disjuncts
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Optimize our representation and our subqueries representations
(Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prettyprint us.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


DisjunctionMaxQuery Constructor

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery Constructor
DisjunctionMaxQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DisjunctionMaxQuery(Single) | Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.
Public method | DisjunctionMaxQuery(ICollection, Single) | Creates a new DisjunctionMaxQuery

See Also

DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace


DisjunctionMaxQuery Constructor (Single)

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery Constructor (Single)
DisjunctionMaxQuery Class See Also Send Feedback
Creates a new empty DisjunctionMaxQuery. Use add() to add the subqueries.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DisjunctionMaxQuery(
    float tieBreakerMultiplier
)
Visual Basic
Public Sub New ( _
    tieBreakerMultiplier As Single _
)
Visual C++
public:
DisjunctionMaxQuery(
    float tieBreakerMultiplier
)

Parameters

tieBreakerMultiplier
Type: System..::..Single
the score of each non-maximum disjunct for a document is multiplied by this weight and added into the final score. If non-zero, the value should be small, on the order of 0.1, which says that 10 occurrences of word in a lower-scored field that is also in a higher scored field is just as good as a unique word in the lower scored field (i.e., one that is not in any higher scored field.

See Also

DisjunctionMaxQuery Class
DisjunctionMaxQuery Overload
Lucene.Net.Search Namespace


DisjunctionMaxQuery Constructor (ICollection, Single)

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery Constructor (ICollection, Single)
DisjunctionMaxQuery Class See Also Send Feedback
Creates a new DisjunctionMaxQuery

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DisjunctionMaxQuery(
    ICollection disjuncts,
    float tieBreakerMultiplier
)
Visual Basic
Public Sub New ( _
    disjuncts As ICollection, _
    tieBreakerMultiplier As Single _
)
Visual C++
public:
DisjunctionMaxQuery(
    ICollection^ disjuncts,
    float tieBreakerMultiplier
)

Parameters

disjuncts
Type: System.Collections..::..ICollection
a Collection<Query> of all the disjuncts to add
tieBreakerMultiplier
Type: System..::..Single
the weight to give to each matching non-maximum disjunct

See Also

DisjunctionMaxQuery Class
DisjunctionMaxQuery Overload
Lucene.Net.Search Namespace


DisjunctionMaxQuery Methods

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery Methods
DisjunctionMaxQuery Class See Also Send Feedback

The DisjunctionMaxQuery type exposes the following members.

Methods

Name | Description
Public method Add(ICollection)
Add a collection of disjuncts to this disjunction via Iterable
Public method Add(Query)
Add a subquery to this disjunction
Public method Clone
Create a shallow copy of us -- used in rewriting if necessary
(Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Return true iff we represent the same query as o
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Compute a hash code for hashing us
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Iterator
An Iterator<Query> over the disjuncts
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Optimize our representation and our subqueries representations
(Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prettyprint us.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Add Method
DisjunctionMaxQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(ICollection) | Add a collection of disjuncts to this disjunction via Iterable
Public method | Add(Query) | Add a subquery to this disjunction

See Also

DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace


Add Method (ICollection)

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Add Method (ICollection)
DisjunctionMaxQuery Class See Also Send Feedback
Add a collection of disjuncts to this disjunction via Iterable

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    ICollection disjuncts
)
Visual Basic
Public Overridable Sub Add ( _
    disjuncts As ICollection _
)
Visual C++
public:
virtual void Add(
    ICollection^ disjuncts
)

Parameters

disjuncts
Type: System.Collections..::..ICollection

[Missing <param name="disjuncts"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.Add(System.Collections.ICollection)"]

See Also

DisjunctionMaxQuery Class
Add Overload
Lucene.Net.Search Namespace


Add Method (Query)

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Add Method (Query)
DisjunctionMaxQuery Class See Also Send Feedback
Add a subquery to this disjunction

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Query query
)
Visual Basic
Public Overridable Sub Add ( _
    query As Query _
)
Visual C++
public:
virtual void Add(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query
the disjunct added

See Also

DisjunctionMaxQuery Class
Add Overload
Lucene.Net.Search Namespace


Clone Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Clone Method
DisjunctionMaxQuery Class See Also Send Feedback
Create a shallow copy of us -- used in rewriting if necessary

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

a copy of us (but reuse, don't copy, our subqueries)

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..CreateWeight Method
DisjunctionMaxQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Equals Method
DisjunctionMaxQuery Class See Also Send Feedback
Return true iff we represent the same query as o

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object
another object

Return Value

true iff o is a DisjunctionMaxQuery with the same boost and the same subqueries, in the same order, as us

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..ExtractTerms Method
DisjunctionMaxQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..GetHashCode Method
DisjunctionMaxQuery Class See Also Send Feedback
Compute a hash code for hashing us

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

the hash code

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Iterator Method
DisjunctionMaxQuery Class See Also Send Feedback
An Iterator<Query> over the disjuncts

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IEnumerator Iterator()
Visual Basic
Public Overridable Function Iterator As IEnumerator
Visual C++
public:
virtual IEnumerator^ Iterator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.Iterator"]

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..Rewrite Method
DisjunctionMaxQuery Class See Also Send Feedback
Optimize our representation and our subqueries representations

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
the IndexReader we query

Return Value

an optimized copy of us (which may not be a copy if there is nothing to optimize)

See Also

DisjunctionMaxQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..ToString Method
DisjunctionMaxQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prettyprint us. (Overrides Query..::..ToString(String).)

See Also

DisjunctionMaxQuery Class
DisjunctionMaxQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..ToString Method (String)
DisjunctionMaxQuery Class See Also Send Feedback
Prettyprint us.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String
the field to which we are applied

Return Value

a string that shows what we do, of the form "(disjunct1 | disjunct2 | ... | disjunctn)^boost"

See Also

DisjunctionMaxQuery Class
ToString Overload
Lucene.Net.Search Namespace


DisjunctionMaxQuery.DisjunctionMaxWeight Class

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
DisjunctionMaxQuery Class Members See Also Send Feedback
Expert: the Weight for DisjunctionMaxQuery, used to normalize, score and explain these queries.

NOTE: this API and implementation is subject to change suddenly in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
protected internal class DisjunctionMaxWeight : Weight
Visual Basic
<SerializableAttribute> _
Protected Friend Class DisjunctionMaxWeight _
    Inherits Weight
Visual C++
[SerializableAttribute]
protected public ref class DisjunctionMaxWeight : public Weight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search..::..DisjunctionMaxQuery..::..DisjunctionMaxWeight

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Members
Lucene.Net.Search Namespace


DisjunctionMaxQuery.DisjunctionMaxWeight Members

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight Members
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class Constructors Methods Fields Properties See Also Send Feedback

A query that generates the union of documents produced by its subqueries, and that scores each document with the maximum score for that document as produced by any subquery, plus a tie breaking increment for any additional matching subqueries. This is useful when searching for a word in multiple fields with different boost factors (so that the fields cannot be combined equivalently into a single search field). We want the primary score to be the one associated with the highest boost, not the sum of the field scores (as BooleanQuery would give). If the query is "albino elephant" this ensures that "albino" matching one field and "elephant" matching another gets a higher score than "albino" matching both fields. To get this result, use both BooleanQuery and DisjunctionMaxQuery: for each term a DisjunctionMaxQuery searches for it in each field, while the set of these DisjunctionMaxQuery's is combined into a BooleanQuery. The tie breaker capability allows results that include the same term in multiple fields to be judged better than results that include this term in only the best of those multiple fields, without confusing this with the better case of two different terms in the multiple fields.

The DisjunctionMaxQuery..::..DisjunctionMaxWeight type exposes the following members.

Constructors

 | Name | Description
Public method | DisjunctionMaxQuery..::..DisjunctionMaxWeight | Initializes a new instance of the DisjunctionMaxQuery..::..DisjunctionMaxWeight class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights | The Weights for our subqueries, in 1-1 correspondence with disjuncts

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


DisjunctionMaxQuery.DisjunctionMaxWeight Constructor

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight Constructor
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback
Initializes a new instance of the DisjunctionMaxQuery..::..DisjunctionMaxWeight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DisjunctionMaxWeight(
    DisjunctionMaxQuery enclosingInstance,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    enclosingInstance As DisjunctionMaxQuery, _
    searcher As Searcher _
)
Visual C++
public:
DisjunctionMaxWeight(
    DisjunctionMaxQuery^ enclosingInstance,
    Searcher^ searcher
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..DisjunctionMaxQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.#ctor(Lucene.Net.Search.DisjunctionMaxQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.#ctor(Lucene.Net.Search.DisjunctionMaxQuery,Lucene.Net.Search.Searcher)"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


DisjunctionMaxQuery.DisjunctionMaxWeight Fields

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight Fields
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

The DisjunctionMaxQuery..::..DisjunctionMaxWeight type exposes the following members.

Fields

 | Name | Description
Protected field | similarity | The Similarity implementation.
Protected field | weights | The Weights for our subqueries, in 1-1 correspondence with disjuncts

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


similarity Field

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..similarity Field
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback
The Similarity implementation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Similarity similarity
Visual Basic
Protected Friend similarity As Similarity
Visual C++
protected public:
Similarity^ similarity

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


weights Field

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..weights Field
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback
The Weights for our subqueries, in 1-1 correspondence with disjuncts

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal ArrayList weights
Visual Basic
Protected Friend weights As ArrayList
Visual C++
protected public:
ArrayList^ weights

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


DisjunctionMaxQuery.DisjunctionMaxWeight Methods

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight Methods
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

The DisjunctionMaxQuery..::..DisjunctionMaxWeight type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..Explain Method
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..GetQuery Method
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.GetQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetQuery()
Visual Basic
Public Overrides Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.GetQuery"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..GetValue Method
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.GetValue"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float GetValue()
Visual Basic
Public Overrides Function GetValue As Single
Visual C++
public:
virtual float GetValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.GetValue"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..Normalize Method
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Normalize(System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Normalize(
    float norm
)
Visual Basic
Public Overrides Sub Normalize ( _
    norm As Single _
)
Visual C++
public:
virtual void Normalize(
    float norm
) override

Parameters

norm
Type: System..::..Single

[Missing <param name="norm"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Normalize(System.Single)"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..Scorer Method
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


SumOfSquaredWeights Method

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..SumOfSquaredWeights Method
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.SumOfSquaredWeights"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float SumOfSquaredWeights()
Visual Basic
Public Overrides Function SumOfSquaredWeights As Single
Visual C++
public:
virtual float SumOfSquaredWeights() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.SumOfSquaredWeights"]

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


DisjunctionMaxQuery.DisjunctionMaxWeight Properties

[image] [image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight Properties
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

The DisjunctionMaxQuery..::..DisjunctionMaxWeight type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
DisjunctionMaxQuery..::..DisjunctionMaxWeight..::..Enclosing_Instance Property
DisjunctionMaxQuery..::..DisjunctionMaxWeight Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.DisjunctionMaxQuery.DisjunctionMaxWeight.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DisjunctionMaxQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As DisjunctionMaxQuery
    Get
Visual C++
public:
property DisjunctionMaxQuery^ Enclosing_Instance {
    DisjunctionMaxQuery^ get ();
}

See Also

DisjunctionMaxQuery..::..DisjunctionMaxWeight Class
Lucene.Net.Search Namespace


DocIdSet Class

[image]

Lucene.Net Class Libraries
DocIdSet Class
Members See Also Send Feedback
A DocIdSet contains a set of doc ids. Implementing classes must only implement {@link #iterator} to provide access to the set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class DocIdSet
Visual Basic
<SerializableAttribute> _
Public MustInherit Class DocIdSet
Visual C++
[SerializableAttribute]
public ref class DocIdSet abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Search..::..DocIdSet..::..AnonymousClassDocIdSet
Lucene.Net.Search..::..FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet
Lucene.Net.Search..::..FilteredDocIdSet
Lucene.Net.Util..::..DocIdBitSet
Lucene.Net.Util..::..OpenBitSet
Lucene.Net.Util..::..SortedVIntList

See Also

DocIdSet Members
Lucene.Net.Search Namespace


DocIdSet Members

[image] [image]

Lucene.Net Class Libraries
DocIdSet Members
DocIdSet Class Constructors Methods Fields See Also Send Feedback

The DocIdSet type exposes the following members.

Constructors

 | Name | Description
Protected method | DocIdSet | Initializes a new instance of the DocIdSet class

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsCacheable
This method is a hint for {@link CachingWrapperFilter}, if this
CopyC#
DocIdSet
 should be cached without copying it into a BitSet. The default is to return
CopyC#
false
. If you have an own
CopyC#
DocIdSet
 implementation that does its iteration very effective and fast without doing disk I/O, override this method and return true.
Public method Iterator
Provides a {@link DocIdSetIterator} to access the set. This implementation can return
CopyC#
null
 or
CopyC#
{@linkplain #EMPTY_DOCIDSET}.iterator()
 if there are no docs that match.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name | Description
EMPTY_DOCIDSET | An empty {@code DocIdSet} instance for easy use, e.g. in Filters that hit no documents.

See Also

DocIdSet Class
Lucene.Net.Search Namespace


DocIdSet Constructor

[image]

Lucene.Net Class Libraries
DocIdSet Constructor
DocIdSet Class See Also Send Feedback
Initializes a new instance of the DocIdSet class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected DocIdSet()
Visual Basic
Protected Sub New
Visual C++
protected:
DocIdSet()

See Also

DocIdSet Class
Lucene.Net.Search Namespace


DocIdSet Fields

[image] [image]

Lucene.Net Class Libraries
DocIdSet Fields
DocIdSet Class See Also Send Feedback

The DocIdSet type exposes the following members.

Fields

Name | Description
EMPTY_DOCIDSET | An empty {@code DocIdSet} instance for easy use, e.g. in Filters that hit no documents.

See Also

DocIdSet Class
Lucene.Net.Search Namespace


EMPTY_DOCIDSET Field

[image]

Lucene.Net Class Libraries
DocIdSet..::..EMPTY_DOCIDSET Field
DocIdSet Class See Also Send Feedback
An empty {@code DocIdSet} instance for easy use, e.g. in Filters that hit no documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public static readonly DocIdSet EMPTY_DOCIDSET
Visual Basic
<NonSerializedAttribute> _
Public Shared ReadOnly EMPTY_DOCIDSET As DocIdSet
Visual C++
[NonSerializedAttribute]
public:
static initonly DocIdSet^ EMPTY_DOCIDSET

See Also

DocIdSet Class
Lucene.Net.Search Namespace


DocIdSet Methods

[image] [image]

Lucene.Net Class Libraries
DocIdSet Methods
DocIdSet Class See Also Send Feedback

The DocIdSet type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsCacheable
This method is a hint for {@link CachingWrapperFilter}, if this
CopyC#
DocIdSet
 should be cached without copying it into a BitSet. The default is to return
CopyC#
false
. If you have an own
CopyC#
DocIdSet
 implementation that does its iteration very effective and fast without doing disk I/O, override this method and return true.
Public method Iterator
Provides a {@link DocIdSetIterator} to access the set. This implementation can return
CopyC#
null
 or
CopyC#
{@linkplain #EMPTY_DOCIDSET}.iterator()
 if there are no docs that match.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

DocIdSet Class
Lucene.Net.Search Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..IsCacheable Method
DocIdSet Class See Also Send Feedback
This method is a hint for {@link CachingWrapperFilter}, if this
CopyC#
DocIdSet
 should be cached without copying it into a BitSet. The default is to return
CopyC#
false
. If you have an own
CopyC#
DocIdSet
 implementation that does its iteration very effective and fast without doing disk I/O, override this method and return true.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsCacheable()
Visual Basic
Public Overridable Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.IsCacheable"]

See Also

DocIdSet Class
Lucene.Net.Search Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..Iterator Method
DocIdSet Class See Also Send Feedback
Provides a {@link DocIdSetIterator} to access the set. This implementation can return
CopyC#
null
 or
CopyC#
{@linkplain #EMPTY_DOCIDSET}.iterator()
 if there are no docs that match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract DocIdSetIterator Iterator()
Visual Basic
Public MustOverride Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.Iterator"]

See Also

DocIdSet Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet Class

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet Class
DocIdSet Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class AnonymousClassDocIdSet : DocIdSet
Visual Basic
Public Class AnonymousClassDocIdSet _
    Inherits DocIdSet
Visual C++
public ref class AnonymousClassDocIdSet : public DocIdSet

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Search..::..DocIdSet..::..AnonymousClassDocIdSet

See Also

DocIdSet..::..AnonymousClassDocIdSet Members
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet Members

[image] [image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet Members
DocIdSet..::..AnonymousClassDocIdSet Class Constructors Methods See Also Send Feedback

A DocIdSet contains a set of doc ids. Implementing classes must only implement {@link #iterator} to provide access to the set.

The DocIdSet..::..AnonymousClassDocIdSet type exposes the following members.

Constructors

 | Name | Description
Public method | DocIdSet..::..AnonymousClassDocIdSet | Initializes a new instance of the DocIdSet..::..AnonymousClassDocIdSet class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocIdSet..::..AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet Constructor

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet Constructor
DocIdSet..::..AnonymousClassDocIdSet Class See Also Send Feedback
Initializes a new instance of the DocIdSet..::..AnonymousClassDocIdSet class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AnonymousClassDocIdSet()
Visual Basic
Public Sub New
Visual C++
public:
AnonymousClassDocIdSet()

See Also

DocIdSet..::..AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet Methods

[image] [image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet Methods
DocIdSet..::..AnonymousClassDocIdSet Class See Also Send Feedback

The DocIdSet..::..AnonymousClassDocIdSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocIdSet..::..AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..IsCacheable Method
DocIdSet..::..AnonymousClassDocIdSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.IsCacheable"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCacheable()
Visual Basic
Public Overrides Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.IsCacheable"]

See Also

DocIdSet..::..AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..Iterator Method
DocIdSet..::..AnonymousClassDocIdSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.Iterator"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSetIterator Iterator()
Visual Basic
Public Overrides Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.Iterator"]

See Also

DocIdSet..::..AnonymousClassDocIdSet Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Class

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
DocIdSet..::..AnonymousClassDocIdSet Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class AnonymousClassDocIdSetIterator : DocIdSetIterator
Visual Basic
Public Class AnonymousClassDocIdSetIterator _
    Inherits DocIdSetIterator
Visual C++
public ref class AnonymousClassDocIdSetIterator : public DocIdSetIterator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Members
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Members

[image] [image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Members
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class Constructors Methods Properties See Also Send Feedback

The DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator | Initializes a new instance of the DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator class

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called. (Inherited from DocIdSetIterator.)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called. (Inherited from DocIdSetIterator.)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called. (Inherited from DocIdSetIterator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Constructor

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Constructor
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback
Initializes a new instance of the DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AnonymousClassDocIdSetIterator(
    DocIdSet..::..AnonymousClassDocIdSet enclosingInstance
)
Visual Basic
Public Sub New ( _
    enclosingInstance As DocIdSet..::..AnonymousClassDocIdSet _
)
Visual C++
public:
AnonymousClassDocIdSetIterator(
    DocIdSet..::..AnonymousClassDocIdSet^ enclosingInstance
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..DocIdSet..::..AnonymousClassDocIdSet

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.#ctor(Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet)"]

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Methods

[image] [image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Methods
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback

The DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called. (Inherited from DocIdSetIterator.)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called. (Inherited from DocIdSetIterator.)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called. (Inherited from DocIdSetIterator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator..::..Advance Method
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.Advance(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.Advance(System.Int32)"]

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator..::..DocID Method
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.DocID"]

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator..::..NextDoc Method
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.NextDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.NextDoc"]

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator Properties

[image] [image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Properties
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback

The DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator..::..Enclosing_Instance Property
DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.DocIdSet.AnonymousClassDocIdSet.AnonymousClassDocIdSetIterator.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DocIdSet..::..AnonymousClassDocIdSet Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As DocIdSet..::..AnonymousClassDocIdSet
    Get
Visual C++
public:
property DocIdSet..::..AnonymousClassDocIdSet^ Enclosing_Instance {
    DocIdSet..::..AnonymousClassDocIdSet^ get ();
}

See Also

DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSetIterator Class

[image]

Lucene.Net Class Libraries
DocIdSetIterator Class
Members See Also Send Feedback
This abstract class defines methods to iterate over a set of non-decreasing doc ids. Note that this class assumes it iterates on doc Ids, and therefore {@link #NO_MORE_DOCS} is set to {@value #NO_MORE_DOCS} in order to be used as a sentinel object. Implementations of this class are expected to consider {@link Integer#MAX_VALUE} as an invalid value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class DocIdSetIterator
Visual Basic
Public MustInherit Class DocIdSetIterator
Visual C++
public ref class DocIdSetIterator abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..DocIdSet..::..AnonymousClassDocIdSet..::..AnonymousClassDocIdSetIterator
Lucene.Net.Search..::..FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator
Lucene.Net.Search..::..FilteredDocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Util..::..OpenBitSetIterator

See Also

DocIdSetIterator Members
Lucene.Net.Search Namespace


DocIdSetIterator Members

[image] [image]

Lucene.Net Class Libraries
DocIdSetIterator Members
DocIdSetIterator Class Constructors Methods Fields See Also Send Feedback

The DocIdSetIterator type exposes the following members.

Constructors

 | Name | Description
Protected method | DocIdSetIterator | Initializes a new instance of the DocIdSetIterator class

Methods

Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or {@link #NO_MORE_DOCS} if there are no more docs in the set.

Behaves as if written:

            int advance(int target) {
            int doc;
            while ((doc = nextDoc()) < target) {
            }
            return doc;
            }
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with {@value #NO_MORE_DOCS} for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

NOTE: in 3.0 this method will become abstract, following the removal of {@link #SkipTo(int)}.

Public method Doc Obsolete.
Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called.
Public method DocID
Returns the following:
  • -1 or {@link #NO_MORE_DOCS} if {@link #NextDoc()} or {@link #Advance(int)} were not called yet.
  • {@link #NO_MORE_DOCS} if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

NOTE: in 3.0, this method will become abstract.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next Obsolete.
Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called.
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or {@link #NO_MORE_DOCS} if there are no more docs in the set.
NOTE: in 3.0 this method will become abstract, following the removal of {@link #Next()}. For backward compatibility it is implemented as:
            public int nextDoc() throws IOException {
            return next() ? doc() : NO_MORE_DOCS;
            }
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
Public method SkipTo Obsolete.
Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name | Description
NO_MORE_DOCS | When returned by {@link #NextDoc()}, {@link #Advance(int)} and {@link #Doc()} it means there are no more docs in the iterator.

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSetIterator Constructor

[image]

Lucene.Net Class Libraries
DocIdSetIterator Constructor
DocIdSetIterator Class See Also Send Feedback
Initializes a new instance of the DocIdSetIterator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected DocIdSetIterator()
Visual Basic
Protected Sub New
Visual C++
protected:
DocIdSetIterator()

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSetIterator Fields

[image] [image]

Lucene.Net Class Libraries
DocIdSetIterator Fields
DocIdSetIterator Class See Also Send Feedback

The DocIdSetIterator type exposes the following members.

Fields

Name | Description
NO_MORE_DOCS | When returned by {@link #NextDoc()}, {@link #Advance(int)} and {@link #Doc()} it means there are no more docs in the iterator.

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


NO_MORE_DOCS Field

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..NO_MORE_DOCS Field
DocIdSetIterator Class See Also Send Feedback
When returned by {@link #NextDoc()}, {@link #Advance(int)} and {@link #Doc()} it means there are no more docs in the iterator.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int NO_MORE_DOCS
Visual Basic
Public Shared ReadOnly NO_MORE_DOCS As Integer
Visual C++
public:
static initonly int NO_MORE_DOCS

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


DocIdSetIterator Methods

[image] [image]

Lucene.Net Class Libraries
DocIdSetIterator Methods
DocIdSetIterator Class See Also Send Feedback

The DocIdSetIterator type exposes the following members.

Methods

Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or {@link #NO_MORE_DOCS} if there are no more docs in the set.

Behaves as if written:

            int advance(int target) {
            int doc;
            while ((doc = nextDoc()) < target) {
            }
            return doc;
            }
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with {@value #NO_MORE_DOCS} for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

NOTE: in 3.0 this method will become abstract, following the removal of {@link #SkipTo(int)}.

Public method Doc Obsolete.
Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called.
Public method DocID
Returns the following:
  • -1 or {@link #NO_MORE_DOCS} if {@link #NextDoc()} or {@link #Advance(int)} were not called yet.
  • {@link #NO_MORE_DOCS} if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

NOTE: in 3.0, this method will become abstract.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next Obsolete.
Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called.
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or {@link #NO_MORE_DOCS} if there are no more docs in the set.
NOTE: in 3.0 this method will become abstract, following the removal of {@link #Next()}. For backward compatibility it is implemented as:
            public int nextDoc() throws IOException {
            return next() ? doc() : NO_MORE_DOCS;
            }
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
Public method SkipTo Obsolete.
Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..Advance Method
DocIdSetIterator Class See Also Send Feedback
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or {@link #NO_MORE_DOCS} if there are no more docs in the set.

Behaves as if written:

            int advance(int target) {
            int doc;
            while ((doc = nextDoc()) < target) {
            }
            return doc;
            }
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with {@value #NO_MORE_DOCS} for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

NOTE: in 3.0 this method will become abstract, following the removal of {@link #SkipTo(int)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Advance(
    int target
)
Visual Basic
Public Overridable Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
)

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.DocIdSetIterator.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSetIterator.Advance(System.Int32)"]

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..Doc Method
DocIdSetIterator Class See Also Send Feedback
Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead.")]
public virtual int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead.")> _
Public Overridable Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead.")]
public:
virtual int Doc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSetIterator.Doc"]

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..DocID Method
DocIdSetIterator Class See Also Send Feedback
Returns the following:
  • -1 or {@link #NO_MORE_DOCS} if {@link #NextDoc()} or {@link #Advance(int)} were not called yet.
  • {@link #NO_MORE_DOCS} if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

NOTE: in 3.0, this method will become abstract.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int DocID()
Visual Basic
Public Overridable Function DocID As Integer
Visual C++
public:
virtual int DocID()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSetIterator.DocID"]

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..Next Method
DocIdSetIterator Class See Also Send Feedback
Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead. This will be removed in 3.0")]
public virtual bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead. This will be removed in 3.0")> _
Public Overridable Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead. This will be removed in 3.0")]
public:
virtual bool Next()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSetIterator.Next"]

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..NextDoc Method
DocIdSetIterator Class See Also Send Feedback
Advances to the next document in the set and returns the doc it is currently on, or {@link #NO_MORE_DOCS} if there are no more docs in the set.
NOTE: in 3.0 this method will become abstract, following the removal of {@link #Next()}. For backward compatibility it is implemented as:
            public int nextDoc() throws IOException {
            return next() ? doc() : NO_MORE_DOCS;
            }
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int NextDoc()
Visual Basic
Public Overridable Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSetIterator.NextDoc"]

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
DocIdSetIterator..::..SkipTo Method
DocIdSetIterator Class See Also Send Feedback
Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead. This will be removed in 3.0")]
public virtual bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead. This will be removed in 3.0")> _
Public Overridable Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead. This will be removed in 3.0")]
public:
virtual bool SkipTo(
    int target
)

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.DocIdSetIterator.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DocIdSetIterator.SkipTo(System.Int32)"]

See Also

DocIdSetIterator Class
Lucene.Net.Search Namespace


DoubleParser Interface

[image]

Lucene.Net Class Libraries
DoubleParser Interface
Members See Also Send Feedback
Interface to parse doubles from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use FieldCache.DoubleParser, this will be removed in Lucene 3.0 ")]
public interface DoubleParser : Parser
Visual Basic
<ObsoleteAttribute("Use FieldCache.DoubleParser, this will be removed in Lucene 3.0 ")> _
Public Interface DoubleParser _
    Inherits Parser
Visual C++
[ObsoleteAttribute(L"Use FieldCache.DoubleParser, this will be removed in Lucene 3.0 ")]
public interface class DoubleParser : Parser

See Also

DoubleParser Members
Lucene.Net.Search Namespace
[!:FieldCache.GetDoubles(IndexReader, String, FieldCache.DoubleParser)]


DoubleParser Members

[image] [image]

Lucene.Net Class Libraries
DoubleParser Members
DoubleParser Interface Methods See Also Send Feedback

The DoubleParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseDouble | Return an long representation of this field's value.

See Also

DoubleParser Interface
Lucene.Net.Search Namespace


DoubleParser Methods

[image] [image]

Lucene.Net Class Libraries
DoubleParser Methods
DoubleParser Interface See Also Send Feedback

The DoubleParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseDouble | Return an long representation of this field's value.

See Also

DoubleParser Interface
Lucene.Net.Search Namespace


ParseDouble Method

[image]

Lucene.Net Class Libraries
DoubleParser..::..ParseDouble Method
DoubleParser Interface See Also Send Feedback
Return an long representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
double ParseDouble(
    string string_Renamed
)
Visual Basic
Function ParseDouble ( _
    string_Renamed As String _
) As Double
Visual C++
double ParseDouble(
    String^ string_Renamed
)

Parameters

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.DoubleParser.ParseDouble(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DoubleParser.ParseDouble(System.String)"]

See Also

DoubleParser Interface
Lucene.Net.Search Namespace


DuplicateFilter Class

[image]

Lucene.Net Class Libraries
DuplicateFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.DuplicateFilter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class DuplicateFilter : Filter
Visual Basic
Public Class DuplicateFilter _
    Inherits Filter
Visual C++
public ref class DuplicateFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..DuplicateFilter

See Also

DuplicateFilter Members
Lucene.Net.Search Namespace


DuplicateFilter Members

[image] [image]

Lucene.Net Class Libraries
DuplicateFilter Members
DuplicateFilter Class Constructors Methods Fields See Also Send Feedback

The DuplicateFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateFilter(String) | Initializes a new instance of the DuplicateFilter class
Public method | DuplicateFilter(String, Int32, Int32) | Initializes a new instance of the DuplicateFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetFieldName |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetKeepMode |
Public method | GetProcessingMode |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFieldName |
Public method | SetKeepMode |
Public method | SetProcessingMode |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
KM_USE_FIRST_OCCURRENCE |
KM_USE_LAST_OCCURRENCE |
PM_FAST_INVALIDATION |
PM_FULL_VALIDATION |

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


DuplicateFilter Constructor

[image] [image]

Lucene.Net Class Libraries
DuplicateFilter Constructor
DuplicateFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateFilter(String) | Initializes a new instance of the DuplicateFilter class
Public method | DuplicateFilter(String, Int32, Int32) | Initializes a new instance of the DuplicateFilter class

See Also

DuplicateFilter Class
DuplicateFilter Members
Lucene.Net.Search Namespace


DuplicateFilter Constructor (String)

[image]

Lucene.Net Class Libraries
DuplicateFilter Constructor (String)
DuplicateFilter Class See Also Send Feedback
Initializes a new instance of the DuplicateFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public DuplicateFilter(
    string fieldName
)
Visual Basic
Public Sub New ( _
    fieldName As String _
)
Visual C++
public:
DuplicateFilter(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.#ctor(System.String)"]

See Also

DuplicateFilter Class
DuplicateFilter Overload
Lucene.Net.Search Namespace


DuplicateFilter Constructor (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
DuplicateFilter Constructor (String, Int32, Int32)
DuplicateFilter Class See Also Send Feedback
Initializes a new instance of the DuplicateFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public DuplicateFilter(
    string fieldName,
    int keepMode,
    int processingMode
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    keepMode As Integer, _
    processingMode As Integer _
)
Visual C++
public:
DuplicateFilter(
    String^ fieldName,
    int keepMode,
    int processingMode
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.#ctor(System.String,System.Int32,System.Int32)"]

keepMode
Type: System..::..Int32

[Missing <param name="keepMode"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.#ctor(System.String,System.Int32,System.Int32)"]

processingMode
Type: System..::..Int32

[Missing <param name="processingMode"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.#ctor(System.String,System.Int32,System.Int32)"]

See Also

DuplicateFilter Class
DuplicateFilter Overload
Lucene.Net.Search Namespace


DuplicateFilter Fields

[image] [image]

Lucene.Net Class Libraries
DuplicateFilter Fields
DuplicateFilter Class See Also Send Feedback

The DuplicateFilter type exposes the following members.

Fields

Name | Description
KM_USE_FIRST_OCCURRENCE |
KM_USE_LAST_OCCURRENCE |
PM_FAST_INVALIDATION |
PM_FULL_VALIDATION |

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


KM_USE_FIRST_OCCURRENCE Field

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..KM_USE_FIRST_OCCURRENCE Field
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.DuplicateFilter.KM_USE_FIRST_OCCURRENCE"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static int KM_USE_FIRST_OCCURRENCE
Visual Basic
Public Shared KM_USE_FIRST_OCCURRENCE As Integer
Visual C++
public:
static int KM_USE_FIRST_OCCURRENCE

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


KM_USE_LAST_OCCURRENCE Field

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..KM_USE_LAST_OCCURRENCE Field
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.DuplicateFilter.KM_USE_LAST_OCCURRENCE"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static int KM_USE_LAST_OCCURRENCE
Visual Basic
Public Shared KM_USE_LAST_OCCURRENCE As Integer
Visual C++
public:
static int KM_USE_LAST_OCCURRENCE

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


PM_FAST_INVALIDATION Field

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..PM_FAST_INVALIDATION Field
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.DuplicateFilter.PM_FAST_INVALIDATION"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static int PM_FAST_INVALIDATION
Visual Basic
Public Shared PM_FAST_INVALIDATION As Integer
Visual C++
public:
static int PM_FAST_INVALIDATION

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


PM_FULL_VALIDATION Field

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..PM_FULL_VALIDATION Field
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.DuplicateFilter.PM_FULL_VALIDATION"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static int PM_FULL_VALIDATION
Visual Basic
Public Shared PM_FULL_VALIDATION As Integer
Visual C++
public:
static int PM_FULL_VALIDATION

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


DuplicateFilter Methods

[image] [image]

Lucene.Net Class Libraries
DuplicateFilter Methods
DuplicateFilter Class See Also Send Feedback

The DuplicateFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetFieldName |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetKeepMode |
Public method | GetProcessingMode |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFieldName |
Public method | SetKeepMode |
Public method | SetProcessingMode |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..Equals Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DuplicateFilter.Equals(System.Object)"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..GetDocIdSet Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


GetFieldName Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..GetFieldName Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetFieldName"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetFieldName()
Visual Basic
Public Function GetFieldName As String
Visual C++
public:
String^ GetFieldName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetFieldName"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..GetHashCode Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetHashCode"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


GetKeepMode Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..GetKeepMode Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetKeepMode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetKeepMode()
Visual Basic
Public Function GetKeepMode As Integer
Visual C++
public:
int GetKeepMode()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetKeepMode"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


GetProcessingMode Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..GetProcessingMode Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetProcessingMode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetProcessingMode()
Visual Basic
Public Function GetProcessingMode As Integer
Visual C++
public:
int GetProcessingMode()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.DuplicateFilter.GetProcessingMode"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


SetFieldName Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..SetFieldName Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.SetFieldName(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetFieldName(
    string fieldName
)
Visual Basic
Public Sub SetFieldName ( _
    fieldName As String _
)
Visual C++
public:
void SetFieldName(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.SetFieldName(System.String)"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


SetKeepMode Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..SetKeepMode Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.SetKeepMode(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetKeepMode(
    int keepMode
)
Visual Basic
Public Sub SetKeepMode ( _
    keepMode As Integer _
)
Visual C++
public:
void SetKeepMode(
    int keepMode
)

Parameters

keepMode
Type: System..::..Int32

[Missing <param name="keepMode"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.SetKeepMode(System.Int32)"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


SetProcessingMode Method

[image]

Lucene.Net Class Libraries
DuplicateFilter..::..SetProcessingMode Method
DuplicateFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.DuplicateFilter.SetProcessingMode(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetProcessingMode(
    int processingMode
)
Visual Basic
Public Sub SetProcessingMode ( _
    processingMode As Integer _
)
Visual C++
public:
void SetProcessingMode(
    int processingMode
)

Parameters

processingMode
Type: System..::..Int32

[Missing <param name="processingMode"/> documentation for "M:Lucene.Net.Search.DuplicateFilter.SetProcessingMode(System.Int32)"]

See Also

DuplicateFilter Class
Lucene.Net.Search Namespace


Explanation Class

[image]

Lucene.Net Class Libraries
Explanation Class
Members See Also Send Feedback
Expert: Describes the score computation for document and query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class Explanation
Visual Basic
<SerializableAttribute> _
Public Class Explanation
Visual C++
[SerializableAttribute]
public ref class Explanation

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Explanation
Lucene.Net.Search..::..ComplexExplanation

See Also

Explanation Members
Lucene.Net.Search Namespace


Explanation Members

[image] [image]

Lucene.Net Class Libraries
Explanation Members
Explanation Class Constructors Methods See Also Send Feedback

The Explanation type exposes the following members.

Constructors

 | Name | Description
Public method | Explanation()()()() | Initializes a new instance of the Explanation class
Public method | Explanation(Single, String) | Initializes a new instance of the Explanation class

Methods

 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription | A description of this explanation node.
Public method | GetDetails | The sub-nodes of this explanation node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSummary | A short one line summary which should contain all high level information about this Explanation, without the "Details"
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | The value assigned to this explanation node.
Public method | IsMatch | Indicates whether or not this Explanation models a good match. By default, an Explanation represents a "match" if the value is positive.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDescription | Sets the description of this explanation node.
Public method | SetValue | Sets the value assigned to this explanation node.
Public method | ToHtml | Render an explanation as HTML.
Public method | ToString()()()() | Render an explanation as text. (Overrides Object..::..ToString()()()().)
Public method | ToString(Int32) |

See Also

Explanation Class
Lucene.Net.Search Namespace


Explanation Constructor

[image] [image]

Lucene.Net Class Libraries
Explanation Constructor
Explanation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Explanation()()()() | Initializes a new instance of the Explanation class
Public method | Explanation(Single, String) | Initializes a new instance of the Explanation class

See Also

Explanation Class
Explanation Members
Lucene.Net.Search Namespace


Explanation Constructor

[image]

Lucene.Net Class Libraries
Explanation Constructor
Explanation Class See Also Send Feedback
Initializes a new instance of the Explanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Explanation()
Visual Basic
Public Sub New
Visual C++
public:
Explanation()

See Also

Explanation Class
Explanation Overload
Lucene.Net.Search Namespace


Explanation Constructor (Single, String)

[image]

Lucene.Net Class Libraries
Explanation Constructor (Single, String)
Explanation Class See Also Send Feedback
Initializes a new instance of the Explanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Explanation(
    float value_Renamed,
    string description
)
Visual Basic
Public Sub New ( _
    value_Renamed As Single, _
    description As String _
)
Visual C++
public:
Explanation(
    float value_Renamed,
    String^ description
)

Parameters

value_Renamed
Type: System..::..Single

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Search.Explanation.#ctor(System.Single,System.String)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:Lucene.Net.Search.Explanation.#ctor(System.Single,System.String)"]

See Also

Explanation Class
Explanation Overload
Lucene.Net.Search Namespace


Explanation Methods

[image] [image]

Lucene.Net Class Libraries
Explanation Methods
Explanation Class See Also Send Feedback

The Explanation type exposes the following members.

Methods

 | Name | Description
Public method | AddDetail | Adds a sub-node to this explanation node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription | A description of this explanation node.
Public method | GetDetails | The sub-nodes of this explanation node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSummary | A short one line summary which should contain all high level information about this Explanation, without the "Details"
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | The value assigned to this explanation node.
Public method | IsMatch | Indicates whether or not this Explanation models a good match. By default, an Explanation represents a "match" if the value is positive.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDescription | Sets the description of this explanation node.
Public method | SetValue | Sets the value assigned to this explanation node.
Public method | ToHtml | Render an explanation as HTML.
Public method | ToString()()()() | Render an explanation as text. (Overrides Object..::..ToString()()()().)
Public method | ToString(Int32) |

See Also

Explanation Class
Lucene.Net.Search Namespace


AddDetail Method

[image]

Lucene.Net Class Libraries
Explanation..::..AddDetail Method
Explanation Class See Also Send Feedback
Adds a sub-node to this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddDetail(
    Explanation detail
)
Visual Basic
Public Overridable Sub AddDetail ( _
    detail As Explanation _
)
Visual C++
public:
virtual void AddDetail(
    Explanation^ detail
)

Parameters

detail
Type: Lucene.Net.Search..::..Explanation

[Missing <param name="detail"/> documentation for "M:Lucene.Net.Search.Explanation.AddDetail(Lucene.Net.Search.Explanation)"]

See Also

Explanation Class
Lucene.Net.Search Namespace


GetDescription Method

[image]

Lucene.Net Class Libraries
Explanation..::..GetDescription Method
Explanation Class See Also Send Feedback
A description of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetDescription()
Visual Basic
Public Overridable Function GetDescription As String
Visual C++
public:
virtual String^ GetDescription()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.GetDescription"]

See Also

Explanation Class
Lucene.Net.Search Namespace


GetDetails Method

[image]

Lucene.Net Class Libraries
Explanation..::..GetDetails Method
Explanation Class See Also Send Feedback
The sub-nodes of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation[] GetDetails()
Visual Basic
Public Overridable Function GetDetails As Explanation()
Visual C++
public:
virtual array<Explanation^>^ GetDetails()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.GetDetails"]

See Also

Explanation Class
Lucene.Net.Search Namespace


GetSummary Method

[image]

Lucene.Net Class Libraries
Explanation..::..GetSummary Method
Explanation Class See Also Send Feedback
A short one line summary which should contain all high level information about this Explanation, without the "Details"

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual string GetSummary()
Visual Basic
Protected Friend Overridable Function GetSummary As String
Visual C++
protected public:
virtual String^ GetSummary()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.GetSummary"]

See Also

Explanation Class
Lucene.Net.Search Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
Explanation..::..GetValue Method
Explanation Class See Also Send Feedback
The value assigned to this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetValue()
Visual Basic
Public Overridable Function GetValue As Single
Visual C++
public:
virtual float GetValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.GetValue"]

See Also

Explanation Class
Lucene.Net.Search Namespace


IsMatch Method

[image]

Lucene.Net Class Libraries
Explanation..::..IsMatch Method
Explanation Class See Also Send Feedback
Indicates whether or not this Explanation models a good match.

By default, an Explanation represents a "match" if the value is positive.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsMatch()
Visual Basic
Public Overridable Function IsMatch As Boolean
Visual C++
public:
virtual bool IsMatch()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.IsMatch"]

See Also

Explanation Class
Lucene.Net.Search Namespace
[!:getValue]


SetDescription Method

[image]

Lucene.Net Class Libraries
Explanation..::..SetDescription Method
Explanation Class See Also Send Feedback
Sets the description of this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDescription(
    string description
)
Visual Basic
Public Overridable Sub SetDescription ( _
    description As String _
)
Visual C++
public:
virtual void SetDescription(
    String^ description
)

Parameters

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:Lucene.Net.Search.Explanation.SetDescription(System.String)"]

See Also

Explanation Class
Lucene.Net.Search Namespace


SetValue Method

[image]

Lucene.Net Class Libraries
Explanation..::..SetValue Method
Explanation Class See Also Send Feedback
Sets the value assigned to this explanation node.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetValue(
    float value_Renamed
)
Visual Basic
Public Overridable Sub SetValue ( _
    value_Renamed As Single _
)
Visual C++
public:
virtual void SetValue(
    float value_Renamed
)

Parameters

value_Renamed
Type: System..::..Single

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Search.Explanation.SetValue(System.Single)"]

See Also

Explanation Class
Lucene.Net.Search Namespace


ToHtml Method

[image]

Lucene.Net Class Libraries
Explanation..::..ToHtml Method
Explanation Class See Also Send Feedback
Render an explanation as HTML.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string ToHtml()
Visual Basic
Public Overridable Function ToHtml As String
Visual C++
public:
virtual String^ ToHtml()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.ToHtml"]

See Also

Explanation Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
Explanation..::..ToString Method
Explanation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Render an explanation as text. (Overrides Object..::..ToString()()()().)
Public method | ToString(Int32) |

See Also

Explanation Class
Explanation Members
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Explanation..::..ToString Method
Explanation Class See Also Send Feedback
Render an explanation as text.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.ToString"]

See Also

Explanation Class
ToString Overload
Lucene.Net.Search Namespace


ToString Method (Int32)

[image]

Lucene.Net Class Libraries
Explanation..::..ToString Method (Int32)
Explanation Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Explanation.ToString(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string ToString(
    int depth
)
Visual Basic
Public Overridable Function ToString ( _
    depth As Integer _
) As String
Visual C++
public:
virtual String^ ToString(
    int depth
)

Parameters

depth
Type: System..::..Int32

[Missing <param name="depth"/> documentation for "M:Lucene.Net.Search.Explanation.ToString(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Explanation.ToString(System.Int32)"]

See Also

Explanation Class
ToString Overload
Lucene.Net.Search Namespace


Explanation.IDFExplanation Class

[image]

Lucene.Net Class Libraries
Explanation..::..IDFExplanation Class
Explanation Class Members See Also Send Feedback
Small Util class used to pass both an idf factor as well as an explanation for that factor. This class will likely be held on a {@link Weight}, so be aware before storing any large or un-serializable fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class IDFExplanation
Visual Basic
<SerializableAttribute> _
Public MustInherit Class IDFExplanation
Visual C++
[SerializableAttribute]
public ref class IDFExplanation abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Explanation..::..IDFExplanation

See Also

Explanation..::..IDFExplanation Members
Lucene.Net.Search Namespace


Explanation.IDFExplanation Members

[image] [image]

Lucene.Net Class Libraries
Explanation..::..IDFExplanation Members
Explanation..::..IDFExplanation Class Constructors Methods See Also Send Feedback

Expert: Describes the score computation for document and query.

The Explanation..::..IDFExplanation type exposes the following members.

Constructors

 | Name | Description
Protected method | Explanation..::..IDFExplanation | Initializes a new instance of the Explanation..::..IDFExplanation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | This should be calculated lazily if possible.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdf |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Explanation..::..IDFExplanation Class
Lucene.Net.Search Namespace


Explanation.IDFExplanation Constructor

[image]

Lucene.Net Class Libraries
Explanation..::..IDFExplanation Constructor
Explanation..::..IDFExplanation Class See Also Send Feedback
Initializes a new instance of the Explanation..::..IDFExplanation class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IDFExplanation()
Visual Basic
Protected Sub New
Visual C++
protected:
IDFExplanation()

See Also

Explanation..::..IDFExplanation Class
Lucene.Net.Search Namespace


Explanation.IDFExplanation Methods

[image] [image]

Lucene.Net Class Libraries
Explanation..::..IDFExplanation Methods
Explanation..::..IDFExplanation Class See Also Send Feedback

The Explanation..::..IDFExplanation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | This should be calculated lazily if possible.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdf |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Explanation..::..IDFExplanation Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
Explanation..::..IDFExplanation..::..Explain Method
Explanation..::..IDFExplanation Class See Also Send Feedback
This should be calculated lazily if possible.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string Explain()
Visual Basic
Public MustOverride Function Explain As String
Visual C++
public:
virtual String^ Explain() abstract

Return Value

the explanation for the idf factor.

See Also

Explanation..::..IDFExplanation Class
Lucene.Net.Search Namespace


GetIdf Method

[image]

Lucene.Net Class Libraries
Explanation..::..IDFExplanation..::..GetIdf Method
Explanation..::..IDFExplanation Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Explanation.IDFExplanation.GetIdf"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float GetIdf()
Visual Basic
Public MustOverride Function GetIdf As Single
Visual C++
public:
virtual float GetIdf() abstract

Return Value

the idf factor

See Also

Explanation..::..IDFExplanation Class
Lucene.Net.Search Namespace


Extensions Class

[image]

Lucene.Net Class Libraries
Extensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Extensions"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public static class Extensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Extensions
Visual C++
[ExtensionAttribute]
public ref class Extensions abstract sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Extensions

See Also

Extensions Members
Lucene.Net.Search Namespace


Extensions Members

[image] [image]

Lucene.Net Class Libraries
Extensions Members
Extensions Class Methods See Also Send Feedback

The Extensions type exposes the following members.

Methods

Name | Description
CartesianProduct<(Of <<'(T>)>>) |

See Also

Extensions Class
Lucene.Net.Search Namespace


Extensions Methods

[image] [image]

Lucene.Net Class Libraries
Extensions Methods
Extensions Class See Also Send Feedback

The Extensions type exposes the following members.

Methods

Name | Description
CartesianProduct<(Of <<'(T>)>>) |

See Also

Extensions Class
Lucene.Net.Search Namespace


CartesianProduct(T) Method

[image]

Lucene.Net Class Libraries
Extensions..::..CartesianProduct<(Of <(<'T>)>)> Method
Extensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Extensions.CartesianProduct``1(System.Collections.Generic.IEnumerable{System.Collections.Generic.IEnumerable{``0}})"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public static IEnumerable<IEnumerable<T>> CartesianProduct<T>(
    this IEnumerable<IEnumerable<T>> sequences
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CartesianProduct(Of T) ( _
    sequences As IEnumerable(Of IEnumerable(Of T)) _
) As IEnumerable(Of IEnumerable(Of T))
Visual C++
[ExtensionAttribute]
public:
generic<typename T>
static IEnumerable<IEnumerable<T>^>^ CartesianProduct(
    IEnumerable<IEnumerable<T>^>^ sequences
)

Parameters

sequences
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IEnumerable <(Of <(<'T>)>)>>)>)>

[Missing <param name="sequences"/> documentation for "M:Lucene.Net.Search.Extensions.CartesianProduct``1(System.Collections.Generic.IEnumerable{System.Collections.Generic.IEnumerable{``0}})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Lucene.Net.Search.Extensions.CartesianProduct``1(System.Collections.Generic.IEnumerable{System.Collections.Generic.IEnumerable{``0}})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Extensions.CartesianProduct``1(System.Collections.Generic.IEnumerable{System.Collections.Generic.IEnumerable{``0}})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' IEnumerable <(Of <(<'T>)>)>>)>)>. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Extensions Class
Lucene.Net.Search Namespace


FieldCache Interface

[image]

Lucene.Net Class Libraries
FieldCache Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.FieldCache"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface FieldCache
Visual Basic
Public Interface FieldCache
Visual C++
public interface class FieldCache

See Also

FieldCache Members
Lucene.Net.Search Namespace


FieldCache Members

[image] [image]

Lucene.Net Class Libraries
FieldCache Members
FieldCache Interface Methods See Also Send Feedback

The FieldCache type exposes the following members.

Methods

Name Description
Public method GetAuto Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads
CopyC#
field
 to see if it contains integers, longs, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
CopyC#
AUTO
 and the actual found type.
Public method GetBytes(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetBytes(IndexReader, String, ByteParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetCacheEntries
EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache.

NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public method GetCustom Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
CopyC#
field
 and calls the given SortComparator to get the sort values. A hit in the cache will happen if
CopyC#
reader
,
CopyC#
field
, and
CopyC#
comparator
 are the same (using
CopyC#
equals()
) as a previous call to this method.
Public method GetDoubles(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetDoubles(IndexReader, String, DoubleParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetFloats(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetFloats(IndexReader, String, FloatParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetInfoStream
counterpart of {@link #SetInfoStream(PrintStream)}
Public method GetInts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetInts(IndexReader, String, IntParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetLongs(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetLongs(IndexReader, String, LongParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetShorts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetShorts(IndexReader, String, ShortParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetStringIndex
Checks the internal cache for an appropriate entry, and if none is found reads the term values in
CopyC#
field
 and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
Public method GetStrings
Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
CopyC#
field
 and returns an array of size
CopyC#
reader.maxDoc()
 containing the value each document has in the given field.
Public method Purge
Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.
Public method PurgeAllCaches

EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public method SetInfoStream
If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to {@link Lucene.Net.Util.FieldCacheSanityChecker}.

See Also

FieldCache Interface
Lucene.Net.Search Namespace


FieldCache Methods

[image] [image]

Lucene.Net Class Libraries
FieldCache Methods
FieldCache Interface See Also Send Feedback

The FieldCache type exposes the following members.

Methods

Name Description
Public method GetAuto Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads
CopyC#
field
 to see if it contains integers, longs, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
CopyC#
AUTO
 and the actual found type.
Public method GetBytes(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetBytes(IndexReader, String, ByteParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetCacheEntries
EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache.

NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public method GetCustom Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
CopyC#
field
 and calls the given SortComparator to get the sort values. A hit in the cache will happen if
CopyC#
reader
,
CopyC#
field
, and
CopyC#
comparator
 are the same (using
CopyC#
equals()
) as a previous call to this method.
Public method GetDoubles(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetDoubles(IndexReader, String, DoubleParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetFloats(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetFloats(IndexReader, String, FloatParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetInfoStream
counterpart of {@link #SetInfoStream(PrintStream)}
Public method GetInts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetInts(IndexReader, String, IntParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetLongs(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetLongs(IndexReader, String, LongParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetShorts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetShorts(IndexReader, String, ShortParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetStringIndex
Checks the internal cache for an appropriate entry, and if none is found reads the term values in
CopyC#
field
 and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
Public method GetStrings
Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
CopyC#
field
 and returns an array of size
CopyC#
reader.maxDoc()
 containing the value each document has in the given field.
Public method Purge
Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.
Public method PurgeAllCaches

EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public method SetInfoStream
If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to {@link Lucene.Net.Util.FieldCacheSanityChecker}.

See Also

FieldCache Interface
Lucene.Net.Search Namespace


GetAuto Method

[image]

Lucene.Net Class Libraries
FieldCache..::..GetAuto Method
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found reads
CopyC#
field
 to see if it contains integers, longs, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
CopyC#
AUTO
 and the actual found type.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the exact type, instead. Especially, guessing does not work with the new NumericField type.")]
Object GetAuto(
    IndexReader reader,
    string field
)
Visual Basic
<ObsoleteAttribute("Please specify the exact type, instead. Especially, guessing does not work with the new NumericField type.")> _
Function GetAuto ( _
    reader As IndexReader, _
    field As String _
) As Object
Visual C++
[ObsoleteAttribute(L"Please specify the exact type, instead. Especially, guessing does not work with the new NumericField type.")]
Object^ GetAuto(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the values.

Return Value

int[], long[], float[] or StringIndex.

See Also

FieldCache Interface
Lucene.Net.Search Namespace


GetBytes Method

[image] [image]

Lucene.Net Class Libraries
FieldCache..::..GetBytes Method
FieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetBytes(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetBytes(IndexReader, String, ByteParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

See Also

FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace


GetBytes Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetBytes Method (IndexReader, String)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
sbyte[] GetBytes(
    IndexReader reader,
    string field
)
Visual Basic
Function GetBytes ( _
    reader As IndexReader, _
    field As String _
) As SByte()
Visual C++
array<signed char>^ GetBytes(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the single byte values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetBytes Overload
Lucene.Net.Search Namespace


GetBytes Method (IndexReader, String, ByteParser)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetBytes Method (IndexReader, String, ByteParser)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
sbyte[] GetBytes(
    IndexReader reader,
    string field,
    ByteParser parser
)
Visual Basic
Function GetBytes ( _
    reader As IndexReader, _
    field As String, _
    parser As ByteParser _
) As SByte()
Visual C++
array<signed char>^ GetBytes(
    IndexReader^ reader,
    String^ field,
    ByteParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the bytes.
parser
Type: Lucene.Net.Search..::..ByteParser
Computes byte for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetBytes Overload
Lucene.Net.Search Namespace


GetCacheEntries Method

[image]

Lucene.Net Class Libraries
FieldCache..::..GetCacheEntries Method
FieldCache Interface See Also Send Feedback
EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache.

NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
CacheEntry[] GetCacheEntries()
Visual Basic
Function GetCacheEntries As CacheEntry()
Visual C++
array<CacheEntry^>^ GetCacheEntries()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCache.GetCacheEntries"]

See Also

FieldCache Interface
Lucene.Net.Search Namespace


GetCustom Method

[image]

Lucene.Net Class Libraries
FieldCache..::..GetCustom Method
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
CopyC#
field
 and calls the given SortComparator to get the sort values. A hit in the cache will happen if
CopyC#
reader
,
CopyC#
field
, and
CopyC#
comparator
 are the same (using
CopyC#
equals()
) as a previous call to this method.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please implement FieldComparatorSource directly, instead.")]
IComparable[] GetCustom(
    IndexReader reader,
    string field,
    SortComparator comparator
)
Visual Basic
<ObsoleteAttribute("Please implement FieldComparatorSource directly, instead.")> _
Function GetCustom ( _
    reader As IndexReader, _
    field As String, _
    comparator As SortComparator _
) As IComparable()
Visual C++
[ObsoleteAttribute(L"Please implement FieldComparatorSource directly, instead.")]
array<IComparable^>^ GetCustom(
    IndexReader^ reader,
    String^ field,
    SortComparator^ comparator
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the values.
comparator
Type: Lucene.Net.Search..::..SortComparator
Used to convert terms into something to sort by.

Return Value

Array of sort objects, one for each document.

See Also

FieldCache Interface
Lucene.Net.Search Namespace


GetDoubles Method

[image] [image]

Lucene.Net Class Libraries
FieldCache..::..GetDoubles Method
FieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetDoubles(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetDoubles(IndexReader, String, DoubleParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

See Also

FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace


GetDoubles Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetDoubles Method (IndexReader, String)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
double[] GetDoubles(
    IndexReader reader,
    string field
)
Visual Basic
Function GetDoubles ( _
    reader As IndexReader, _
    field As String _
) As Double()
Visual C++
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the doubles.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetDoubles Overload
Lucene.Net.Search Namespace


GetDoubles Method (IndexReader, String, DoubleParser)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetDoubles Method (IndexReader, String, DoubleParser)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
double[] GetDoubles(
    IndexReader reader,
    string field,
    DoubleParser parser
)
Visual Basic
Function GetDoubles ( _
    reader As IndexReader, _
    field As String, _
    parser As DoubleParser _
) As Double()
Visual C++
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field,
    DoubleParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the doubles.
parser
Type: Lucene.Net.Search..::..DoubleParser
Computes integer for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetDoubles Overload
Lucene.Net.Search Namespace


GetFloats Method

[image] [image]

Lucene.Net Class Libraries
FieldCache..::..GetFloats Method
FieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetFloats(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetFloats(IndexReader, String, FloatParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

See Also

FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace


GetFloats Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetFloats Method (IndexReader, String)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
float[] GetFloats(
    IndexReader reader,
    string field
)
Visual Basic
Function GetFloats ( _
    reader As IndexReader, _
    field As String _
) As Single()
Visual C++
array<float>^ GetFloats(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the floats.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetFloats Overload
Lucene.Net.Search Namespace


GetFloats Method (IndexReader, String, FloatParser)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetFloats Method (IndexReader, String, FloatParser)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
float[] GetFloats(
    IndexReader reader,
    string field,
    FloatParser parser
)
Visual Basic
Function GetFloats ( _
    reader As IndexReader, _
    field As String, _
    parser As FloatParser _
) As Single()
Visual C++
array<float>^ GetFloats(
    IndexReader^ reader,
    String^ field,
    FloatParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the floats.
parser
Type: Lucene.Net.Search..::..FloatParser
Computes float for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetFloats Overload
Lucene.Net.Search Namespace


GetInfoStream Method

[image]

Lucene.Net Class Libraries
FieldCache..::..GetInfoStream Method
FieldCache Interface See Also Send Feedback
counterpart of {@link #SetInfoStream(PrintStream)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
StreamWriter GetInfoStream()
Visual Basic
Function GetInfoStream As StreamWriter
Visual C++
StreamWriter^ GetInfoStream()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCache.GetInfoStream"]

See Also

FieldCache Interface
Lucene.Net.Search Namespace


GetInts Method

[image] [image]

Lucene.Net Class Libraries
FieldCache..::..GetInts Method
FieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetInts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetInts(IndexReader, String, IntParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

See Also

FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace


GetInts Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetInts Method (IndexReader, String)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int[] GetInts(
    IndexReader reader,
    string field
)
Visual Basic
Function GetInts ( _
    reader As IndexReader, _
    field As String _
) As Integer()
Visual C++
array<int>^ GetInts(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the integers.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetInts Overload
Lucene.Net.Search Namespace


GetInts Method (IndexReader, String, IntParser)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetInts Method (IndexReader, String, IntParser)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int[] GetInts(
    IndexReader reader,
    string field,
    IntParser parser
)
Visual Basic
Function GetInts ( _
    reader As IndexReader, _
    field As String, _
    parser As IntParser _
) As Integer()
Visual C++
array<int>^ GetInts(
    IndexReader^ reader,
    String^ field,
    IntParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the integers.
parser
Type: Lucene.Net.Search..::..IntParser
Computes integer for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetInts Overload
Lucene.Net.Search Namespace


GetLongs Method

[image] [image]

Lucene.Net Class Libraries
FieldCache..::..GetLongs Method
FieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetLongs(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetLongs(IndexReader, String, LongParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

See Also

FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace


GetLongs Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetLongs Method (IndexReader, String)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
long[] GetLongs(
    IndexReader reader,
    string field
)
Visual Basic
Function GetLongs ( _
    reader As IndexReader, _
    field As String _
) As Long()
Visual C++
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the longs.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetLongs Overload
Lucene.Net.Search Namespace


GetLongs Method (IndexReader, String, LongParser)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetLongs Method (IndexReader, String, LongParser)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
long[] GetLongs(
    IndexReader reader,
    string field,
    LongParser parser
)
Visual Basic
Function GetLongs ( _
    reader As IndexReader, _
    field As String, _
    parser As LongParser _
) As Long()
Visual C++
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field,
    LongParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the longs.
parser
Type: Lucene.Net.Search..::..LongParser
Computes integer for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetLongs Overload
Lucene.Net.Search Namespace


GetShorts Method

[image] [image]

Lucene.Net Class Libraries
FieldCache..::..GetShorts Method
FieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetShorts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
Public method GetShorts(IndexReader, String, ShortParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

See Also

FieldCache Interface
FieldCache Members
Lucene.Net.Search Namespace


GetShorts Method (IndexReader, String)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetShorts Method (IndexReader, String)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
short[] GetShorts(
    IndexReader reader,
    string field
)
Visual Basic
Function GetShorts ( _
    reader As IndexReader, _
    field As String _
) As Short()
Visual C++
array<short>^ GetShorts(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the shorts.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetShorts Overload
Lucene.Net.Search Namespace


GetShorts Method (IndexReader, String, ShortParser)

[image]

Lucene.Net Class Libraries
FieldCache..::..GetShorts Method (IndexReader, String, ShortParser)
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
short[] GetShorts(
    IndexReader reader,
    string field,
    ShortParser parser
)
Visual Basic
Function GetShorts ( _
    reader As IndexReader, _
    field As String, _
    parser As ShortParser _
) As Short()
Visual C++
array<short>^ GetShorts(
    IndexReader^ reader,
    String^ field,
    ShortParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the shorts.
parser
Type: Lucene.Net.Search..::..ShortParser
Computes short for string values.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
GetShorts Overload
Lucene.Net.Search Namespace


GetStringIndex Method

[image]

Lucene.Net Class Libraries
FieldCache..::..GetStringIndex Method
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found reads the term values in
CopyC#
field
 and returns an array of them in natural order, along with an array telling which element in the term array each document uses.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
StringIndex GetStringIndex(
    IndexReader reader,
    string field
)
Visual Basic
Function GetStringIndex ( _
    reader As IndexReader, _
    field As String _
) As StringIndex
Visual C++
StringIndex^ GetStringIndex(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the strings.

Return Value

Array of terms and index into the array for each document.

See Also

FieldCache Interface
Lucene.Net.Search Namespace


GetStrings Method

[image]

Lucene.Net Class Libraries
FieldCache..::..GetStrings Method
FieldCache Interface See Also Send Feedback
Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
CopyC#
field
 and returns an array of size
CopyC#
reader.maxDoc()
 containing the value each document has in the given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
string[] GetStrings(
    IndexReader reader,
    string field
)
Visual Basic
Function GetStrings ( _
    reader As IndexReader, _
    field As String _
) As String()
Visual C++
array<String^>^ GetStrings(
    IndexReader^ reader,
    String^ field
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Used to get field values.
field
Type: System..::..String
Which field contains the strings.

Return Value

The values in the given field for each document.

See Also

FieldCache Interface
Lucene.Net.Search Namespace


Purge Method

[image]

Lucene.Net Class Libraries
FieldCache..::..Purge Method
FieldCache Interface See Also Send Feedback
Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Purge(
    IndexReader r
)
Visual Basic
Sub Purge ( _
    r As IndexReader _
)
Visual C++
void Purge(
    IndexReader^ r
)

Parameters

r
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="r"/> documentation for "M:Lucene.Net.Search.FieldCache.Purge(Lucene.Net.Index.IndexReader)"]

See Also

FieldCache Interface
Lucene.Net.Search Namespace


PurgeAllCaches Method

[image]

Lucene.Net Class Libraries
FieldCache..::..PurgeAllCaches Method
FieldCache Interface See Also Send Feedback

EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void PurgeAllCaches()
Visual Basic
Sub PurgeAllCaches
Visual C++
void PurgeAllCaches()

See Also

FieldCache Interface
Lucene.Net.Search Namespace


SetInfoStream Method

[image]

Lucene.Net Class Libraries
FieldCache..::..SetInfoStream Method
FieldCache Interface See Also Send Feedback
If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to {@link Lucene.Net.Util.FieldCacheSanityChecker}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void SetInfoStream(
    StreamWriter stream
)
Visual Basic
Sub SetInfoStream ( _
    stream As StreamWriter _
)
Visual C++
void SetInfoStream(
    StreamWriter^ stream
)

Parameters

stream
Type: System.IO..::..StreamWriter

[Missing <param name="stream"/> documentation for "M:Lucene.Net.Search.FieldCache.SetInfoStream(System.IO.StreamWriter)"]

See Also

FieldCache Interface
Lucene.Net.Search Namespace


FieldCache_Fields Structure

[image]

Lucene.Net Class Libraries
FieldCache_Fields Structure
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.FieldCache_Fields"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public struct FieldCache_Fields
Visual Basic
Public Structure FieldCache_Fields
Visual C++
public value class FieldCache_Fields

See Also

FieldCache_Fields Members
Lucene.Net.Search Namespace


FieldCache_Fields Members

[image] [image]

Lucene.Net Class Libraries
FieldCache_Fields Members
FieldCache_Fields Structure Methods Fields See Also Send Feedback

The FieldCache_Fields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
DEFAULT | Expert: The cache used internally by sorting and range query classes.
DEFAULT_BYTE_PARSER | The default parser for byte values, which are encoded by {@link Byte#toString(byte)}
DEFAULT_DOUBLE_PARSER | The default parser for double values, which are encoded by {@link Double#toString(double)}
DEFAULT_FLOAT_PARSER | The default parser for float values, which are encoded by {@link Float#toString(float)}
DEFAULT_INT_PARSER | The default parser for int values, which are encoded by {@link Integer#toString(int)}
DEFAULT_LONG_PARSER | The default parser for long values, which are encoded by {@link Long#toString(long)}
DEFAULT_SHORT_PARSER | The default parser for short values, which are encoded by {@link Short#toString(short)}
NUMERIC_UTILS_DOUBLE_PARSER | A parser instance for double values encoded with {@link NumericUtils}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
NUMERIC_UTILS_FLOAT_PARSER | A parser instance for float values encoded with {@link NumericUtils}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
NUMERIC_UTILS_INT_PARSER | A parser instance for int values encoded by {@link NumericUtils#IntToPrefixCoded(int)}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
NUMERIC_UTILS_LONG_PARSER | A parser instance for long values encoded by {@link NumericUtils#LongToPrefixCoded(long)}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
STRING_INDEX | Indicator for StringIndex values in the cache.

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


FieldCache_Fields Fields

[image] [image]

Lucene.Net Class Libraries
FieldCache_Fields Fields
FieldCache_Fields Structure See Also Send Feedback

The FieldCache_Fields type exposes the following members.

Fields

Name | Description
DEFAULT | Expert: The cache used internally by sorting and range query classes.
DEFAULT_BYTE_PARSER | The default parser for byte values, which are encoded by {@link Byte#toString(byte)}
DEFAULT_DOUBLE_PARSER | The default parser for double values, which are encoded by {@link Double#toString(double)}
DEFAULT_FLOAT_PARSER | The default parser for float values, which are encoded by {@link Float#toString(float)}
DEFAULT_INT_PARSER | The default parser for int values, which are encoded by {@link Integer#toString(int)}
DEFAULT_LONG_PARSER | The default parser for long values, which are encoded by {@link Long#toString(long)}
DEFAULT_SHORT_PARSER | The default parser for short values, which are encoded by {@link Short#toString(short)}
NUMERIC_UTILS_DOUBLE_PARSER | A parser instance for double values encoded with {@link NumericUtils}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
NUMERIC_UTILS_FLOAT_PARSER | A parser instance for float values encoded with {@link NumericUtils}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
NUMERIC_UTILS_INT_PARSER | A parser instance for int values encoded by {@link NumericUtils#IntToPrefixCoded(int)}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
NUMERIC_UTILS_LONG_PARSER | A parser instance for long values encoded by {@link NumericUtils#LongToPrefixCoded(long)}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.
STRING_INDEX | Indicator for StringIndex values in the cache.

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT Field
FieldCache_Fields Structure See Also Send Feedback
Expert: The cache used internally by sorting and range query classes.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldCache DEFAULT
Visual Basic
Public Shared ReadOnly DEFAULT As FieldCache
Visual C++
public:
static initonly FieldCache^ DEFAULT

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT_BYTE_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT_BYTE_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
The default parser for byte values, which are encoded by {@link Byte#toString(byte)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly ByteParser DEFAULT_BYTE_PARSER
Visual Basic
Public Shared ReadOnly DEFAULT_BYTE_PARSER As ByteParser
Visual C++
public:
static initonly ByteParser^ DEFAULT_BYTE_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT_DOUBLE_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT_DOUBLE_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
The default parser for double values, which are encoded by {@link Double#toString(double)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DoubleParser DEFAULT_DOUBLE_PARSER
Visual Basic
Public Shared ReadOnly DEFAULT_DOUBLE_PARSER As DoubleParser
Visual C++
public:
static initonly DoubleParser^ DEFAULT_DOUBLE_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT_FLOAT_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT_FLOAT_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
The default parser for float values, which are encoded by {@link Float#toString(float)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FloatParser DEFAULT_FLOAT_PARSER
Visual Basic
Public Shared ReadOnly DEFAULT_FLOAT_PARSER As FloatParser
Visual C++
public:
static initonly FloatParser^ DEFAULT_FLOAT_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT_INT_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT_INT_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
The default parser for int values, which are encoded by {@link Integer#toString(int)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IntParser DEFAULT_INT_PARSER
Visual Basic
Public Shared ReadOnly DEFAULT_INT_PARSER As IntParser
Visual C++
public:
static initonly IntParser^ DEFAULT_INT_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT_LONG_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT_LONG_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
The default parser for long values, which are encoded by {@link Long#toString(long)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly LongParser DEFAULT_LONG_PARSER
Visual Basic
Public Shared ReadOnly DEFAULT_LONG_PARSER As LongParser
Visual C++
public:
static initonly LongParser^ DEFAULT_LONG_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


DEFAULT_SHORT_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..DEFAULT_SHORT_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
The default parser for short values, which are encoded by {@link Short#toString(short)}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly ShortParser DEFAULT_SHORT_PARSER
Visual Basic
Public Shared ReadOnly DEFAULT_SHORT_PARSER As ShortParser
Visual C++
public:
static initonly ShortParser^ DEFAULT_SHORT_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


NUMERIC_UTILS_DOUBLE_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..NUMERIC_UTILS_DOUBLE_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
A parser instance for double values encoded with {@link NumericUtils}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly DoubleParser NUMERIC_UTILS_DOUBLE_PARSER
Visual Basic
Public Shared ReadOnly NUMERIC_UTILS_DOUBLE_PARSER As DoubleParser
Visual C++
public:
static initonly DoubleParser^ NUMERIC_UTILS_DOUBLE_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


NUMERIC_UTILS_FLOAT_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..NUMERIC_UTILS_FLOAT_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
A parser instance for float values encoded with {@link NumericUtils}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FloatParser NUMERIC_UTILS_FLOAT_PARSER
Visual Basic
Public Shared ReadOnly NUMERIC_UTILS_FLOAT_PARSER As FloatParser
Visual C++
public:
static initonly FloatParser^ NUMERIC_UTILS_FLOAT_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


NUMERIC_UTILS_INT_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..NUMERIC_UTILS_INT_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
A parser instance for int values encoded by {@link NumericUtils#IntToPrefixCoded(int)}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly IntParser NUMERIC_UTILS_INT_PARSER
Visual Basic
Public Shared ReadOnly NUMERIC_UTILS_INT_PARSER As IntParser
Visual C++
public:
static initonly IntParser^ NUMERIC_UTILS_INT_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


NUMERIC_UTILS_LONG_PARSER Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..NUMERIC_UTILS_LONG_PARSER Field
FieldCache_Fields Structure See Also Send Feedback
A parser instance for long values encoded by {@link NumericUtils#LongToPrefixCoded(long)}, e.g. when indexed via {@link NumericField}/{@link NumericTokenStream}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly LongParser NUMERIC_UTILS_LONG_PARSER
Visual Basic
Public Shared ReadOnly NUMERIC_UTILS_LONG_PARSER As LongParser
Visual C++
public:
static initonly LongParser^ NUMERIC_UTILS_LONG_PARSER

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


STRING_INDEX Field

[image]

Lucene.Net Class Libraries
FieldCache_Fields..::..STRING_INDEX Field
FieldCache_Fields Structure See Also Send Feedback
Indicator for StringIndex values in the cache.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int STRING_INDEX
Visual Basic
Public Shared ReadOnly STRING_INDEX As Integer
Visual C++
public:
static initonly int STRING_INDEX

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


FieldCache_Fields Methods

[image] [image]

Lucene.Net Class Libraries
FieldCache_Fields Methods
FieldCache_Fields Structure See Also Send Feedback

The FieldCache_Fields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

FieldCache_Fields Structure
Lucene.Net.Search Namespace


FieldCacheRangeFilter Class

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter Class
Members See Also Send Feedback
A range filter built on top of a cached single term field (in {@link FieldCache}).

FieldCacheRangeFilter builds a single cache for the field the first time it is used. Each subsequent FieldCacheRangeFilter on the same field then reuses this cache, even if the range itself changes.

This means that FieldCacheRangeFilter is much faster (sometimes more than 100x as fast) as building a {@link TermRangeFilter} (or {@link ConstantScoreRangeQuery} on a {@link TermRangeFilter}) for each query, if using a {@link #newStringRange}. However, if the range never changes it is slower (around 2x as slow) than building a CachingWrapperFilter on top of a single TermRangeFilter. For numeric data types, this filter may be significantly faster than {@link NumericRangeFilter}. Furthermore, it does not need the numeric values encoded by {@link NumericField}. But it has the problem that it only works with exact one value/document (see below).

As with all {@link FieldCache} based functionality, FieldCacheRangeFilter is only valid for fields which exact one term for each document (except for {@link #newStringRange} where 0 terms are also allowed). Due to a restriction of {@link FieldCache}, for numeric ranges all terms that do not have a numeric value, 0 is assumed.

Thus it works on dates, prices and other single value fields but will not work on regular text fields. It is preferable to use a

CopyC#
NOT_ANALYZED
field to ensure that there is only a single term.

This class does not have an constructor, use one of the static factory methods available, that create a correct instance for different data types supported by {@link FieldCache}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class FieldCacheRangeFilter : Filter
Visual Basic
<SerializableAttribute> _
Public MustInherit Class FieldCacheRangeFilter _
    Inherits Filter
Visual C++
[SerializableAttribute]
public ref class FieldCacheRangeFilter abstract : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..FieldCacheRangeFilter

See Also

FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


FieldCacheRangeFilter Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter Members
FieldCacheRangeFilter Class Methods See Also Send Feedback

The FieldCacheRangeFilter type exposes the following members.

Methods

Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDocIdSet
This method is implemented for each data type
(Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
NewByteRange(String, Byte, Byte, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewByteRange(String, ByteParser, Byte, Byte, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String,FieldCache.ByteParser)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewDoubleRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewDoubleRange(String, DoubleParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String,FieldCache.DoubleParser)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewFloatRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewFloatRange(String, FloatParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String,FieldCache.FloatParser)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewIntRange(String, IntParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String,FieldCache.IntParser)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewLongRange(String, LongParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String,FieldCache.LongParser)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewShortRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewShortRange(String, ShortParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String,FieldCache.ShortParser)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewStringRange
Creates a string range query using {@link FieldCache#getStringIndex}. This works with all fields containing zero or one term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


FieldCacheRangeFilter Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter Methods
FieldCacheRangeFilter Class See Also Send Feedback

The FieldCacheRangeFilter type exposes the following members.

Methods

Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDocIdSet
This method is implemented for each data type
(Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
NewByteRange(String, Byte, Byte, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewByteRange(String, ByteParser, Byte, Byte, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String,FieldCache.ByteParser)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewDoubleRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewDoubleRange(String, DoubleParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String,FieldCache.DoubleParser)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewFloatRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewFloatRange(String, FloatParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String,FieldCache.FloatParser)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewIntRange(String, IntParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String,FieldCache.IntParser)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewLongRange(String, LongParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String,FieldCache.LongParser)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewShortRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewShortRange(String, ShortParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String,FieldCache.ShortParser)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewStringRange
Creates a string range query using {@link FieldCache#getStringIndex}. This works with all fields containing zero or one term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..Equals Method
FieldCacheRangeFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.Equals(System.Object)"]

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..GetDocIdSet Method
FieldCacheRangeFilter Class See Also Send Feedback
This method is implemented for each data type

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public MustOverride Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) abstract override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..GetHashCode Method
FieldCacheRangeFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.GetHashCode"]

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


NewByteRange Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewByteRange Method
FieldCacheRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewByteRange(String, Byte, Byte, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewByteRange(String, ByteParser, Byte, Byte, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String,FieldCache.ByteParser)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

See Also

FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


NewByteRange Method (String, Byte, Byte, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewByteRange Method (String, Byte, Byte, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewByteRange(
    string field,
    byte lowerVal,
    byte upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewByteRange ( _
    field As String, _
    lowerVal As Byte, _
    upperVal As Byte, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewByteRange(
    String^ field,
    unsigned char lowerVal,
    unsigned char upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..Byte

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..Byte

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewByteRange Overload
Lucene.Net.Search Namespace


NewByteRange Method (String, ByteParser, Byte, Byte, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewByteRange Method (String, ByteParser, Byte, Byte, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetBytes(IndexReader,String,FieldCache.ByteParser)}. This works with all byte fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewByteRange(
    string field,
    ByteParser parser,
    byte lowerVal,
    byte upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewByteRange ( _
    field As String, _
    parser As ByteParser, _
    lowerVal As Byte, _
    upperVal As Byte, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewByteRange(
    String^ field,
    ByteParser^ parser,
    unsigned char lowerVal,
    unsigned char upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

parser
Type: Lucene.Net.Search..::..ByteParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..Byte

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..Byte

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewByteRange(System.String,Lucene.Net.Search.ByteParser,System.Byte,System.Byte,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewByteRange Overload
Lucene.Net.Search Namespace


NewDoubleRange Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewDoubleRange Method
FieldCacheRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewDoubleRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewDoubleRange(String, DoubleParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String,FieldCache.DoubleParser)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

See Also

FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


NewDoubleRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewDoubleRange Method (String, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewDoubleRange(
    string field,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewDoubleRange ( _
    field As String, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewDoubleRange(
    String^ field,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewDoubleRange Overload
Lucene.Net.Search Namespace


NewDoubleRange Method (String, DoubleParser, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewDoubleRange Method (String, DoubleParser, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetDoubles(IndexReader,String,FieldCache.DoubleParser)}. This works with all double fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewDoubleRange(
    string field,
    DoubleParser parser,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewDoubleRange ( _
    field As String, _
    parser As DoubleParser, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewDoubleRange(
    String^ field,
    DoubleParser^ parser,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

parser
Type: Lucene.Net.Search..::..DoubleParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewDoubleRange(System.String,Lucene.Net.Search.DoubleParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewDoubleRange Overload
Lucene.Net.Search Namespace


NewFloatRange Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewFloatRange Method
FieldCacheRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewFloatRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewFloatRange(String, FloatParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String,FieldCache.FloatParser)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

See Also

FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


NewFloatRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewFloatRange Method (String, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewFloatRange(
    string field,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewFloatRange ( _
    field As String, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewFloatRange(
    String^ field,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewFloatRange Overload
Lucene.Net.Search Namespace


NewFloatRange Method (String, FloatParser, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewFloatRange Method (String, FloatParser, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetFloats(IndexReader,String,FieldCache.FloatParser)}. This works with all float fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewFloatRange(
    string field,
    FloatParser parser,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewFloatRange ( _
    field As String, _
    parser As FloatParser, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewFloatRange(
    String^ field,
    FloatParser^ parser,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

parser
Type: Lucene.Net.Search..::..FloatParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewFloatRange(System.String,Lucene.Net.Search.FloatParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewFloatRange Overload
Lucene.Net.Search Namespace


NewIntRange Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewIntRange Method
FieldCacheRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewIntRange(String, IntParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String,FieldCache.IntParser)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

See Also

FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


NewIntRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewIntRange Method (String, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewIntRange(
    string field,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewIntRange ( _
    field As String, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewIntRange(
    String^ field,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewIntRange Overload
Lucene.Net.Search Namespace


NewIntRange Method (String, IntParser, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewIntRange Method (String, IntParser, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetInts(IndexReader,String,FieldCache.IntParser)}. This works with all int fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewIntRange(
    string field,
    IntParser parser,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewIntRange ( _
    field As String, _
    parser As IntParser, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewIntRange(
    String^ field,
    IntParser^ parser,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

parser
Type: Lucene.Net.Search..::..IntParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewIntRange(System.String,Lucene.Net.Search.IntParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewIntRange Overload
Lucene.Net.Search Namespace


NewLongRange Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewLongRange Method
FieldCacheRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewLongRange(String, LongParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String,FieldCache.LongParser)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

See Also

FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


NewLongRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewLongRange Method (String, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewLongRange(
    string field,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewLongRange ( _
    field As String, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewLongRange(
    String^ field,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewLongRange Overload
Lucene.Net.Search Namespace


NewLongRange Method (String, LongParser, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewLongRange Method (String, LongParser, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetLongs(IndexReader,String,FieldCache.LongParser)}. This works with all long fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewLongRange(
    string field,
    LongParser parser,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewLongRange ( _
    field As String, _
    parser As LongParser, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewLongRange(
    String^ field,
    LongParser^ parser,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

parser
Type: Lucene.Net.Search..::..LongParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewLongRange(System.String,Lucene.Net.Search.LongParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewLongRange Overload
Lucene.Net.Search Namespace


NewShortRange Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewShortRange Method
FieldCacheRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewShortRange(String, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.
NewShortRange(String, ShortParser, ValueType, ValueType, Boolean, Boolean)
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String,FieldCache.ShortParser)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

See Also

FieldCacheRangeFilter Class
FieldCacheRangeFilter Members
Lucene.Net.Search Namespace


NewShortRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewShortRange Method (String, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewShortRange(
    string field,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewShortRange ( _
    field As String, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewShortRange(
    String^ field,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewShortRange Overload
Lucene.Net.Search Namespace


NewShortRange Method (String, ShortParser, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewShortRange Method (String, ShortParser, ValueType, ValueType, Boolean, Boolean)
FieldCacheRangeFilter Class See Also Send Feedback
Creates a numeric range query using {@link FieldCache#GetShorts(IndexReader,String,FieldCache.ShortParser)}. This works with all short fields containing exactly one numeric term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewShortRange(
    string field,
    ShortParser parser,
    ValueType lowerVal,
    ValueType upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewShortRange ( _
    field As String, _
    parser As ShortParser, _
    lowerVal As ValueType, _
    upperVal As ValueType, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewShortRange(
    String^ field,
    ShortParser^ parser,
    ValueType^ lowerVal,
    ValueType^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

parser
Type: Lucene.Net.Search..::..ShortParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..ValueType

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..ValueType

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewShortRange(System.String,Lucene.Net.Search.ShortParser,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
NewShortRange Overload
Lucene.Net.Search Namespace


NewStringRange Method

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..NewStringRange Method
FieldCacheRangeFilter Class See Also Send Feedback
Creates a string range query using {@link FieldCache#getStringIndex}. This works with all fields containing zero or one term in the field. The range can be half-open by setting one of the values to
CopyC#
null
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheRangeFilter NewStringRange(
    string field,
    string lowerVal,
    string upperVal,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Shared Function NewStringRange ( _
    field As String, _
    lowerVal As String, _
    upperVal As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
) As FieldCacheRangeFilter
Visual C++
public:
static FieldCacheRangeFilter^ NewStringRange(
    String^ field,
    String^ lowerVal,
    String^ upperVal,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewStringRange(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

lowerVal
Type: System..::..String

[Missing <param name="lowerVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewStringRange(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

upperVal
Type: System..::..String

[Missing <param name="upperVal"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewStringRange(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

includeLower
Type: System..::..Boolean

[Missing <param name="includeLower"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewStringRange(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

includeUpper
Type: System..::..Boolean

[Missing <param name="includeUpper"/> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewStringRange(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.NewStringRange(System.String,System.String,System.String,System.Boolean,System.Boolean)"]

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldCacheRangeFilter..::..ToString Method
FieldCacheRangeFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheRangeFilter.ToString"]

See Also

FieldCacheRangeFilter Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter Class

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter Class
Members See Also Send Feedback
A {@link Filter} that only accepts documents whose single term value in the specified field is contained in the provided set of allowed terms.

This is the same functionality as TermsFilter (from contrib/queries), except this filter requires that the field contains only a single term for all documents. Because of drastically different implementations, they also have different performance characteristics, as described below.

The first invocation of this filter on a given field will be slower, since a {@link FieldCache.StringIndex} must be created. Subsequent invocations using the same field will re-use this cache. However, as with all functionality based on {@link FieldCache}, persistent RAM is consumed to hold the cache, and is not freed until the {@link IndexReader} is closed. In contrast, TermsFilter has no persistent RAM consumption.

With each search, this filter translates the specified set of Terms into a private {@link OpenBitSet} keyed by term number per unique {@link IndexReader} (normally one reader per segment). Then, during matching, the term number for each docID is retrieved from the cache and then checked for inclusion using the {@link OpenBitSet}. Since all testing is done using RAM resident data structures, performance should be very fast, most likely fast enough to not require further caching of the DocIdSet for each possible combination of terms. However, because docIDs are simply scanned linearly, an index with a great many small documents may find this linear scan too costly.

In contrast, TermsFilter builds up an {@link OpenBitSet}, keyed by docID, every time it's created, by enumerating through all matching docs using {@link TermDocs} to seek and scan through each term's docID list. While there is no linear scan of all docIDs, besides the allocation of the underlying array in the {@link OpenBitSet}, this approach requires a number of "disk seeks" in proportion to the number of terms, which can be exceptionally costly when there are cache misses in the OS's IO cache.

Generally, this filter will be slower on the first invocation for a given field, but subsequent invocations, even if you change the allowed set of Terms, should be faster than TermsFilter, especially as the number of Terms being matched increases. If you are matching only a very small number of terms, and those terms in turn match a very small number of documents, TermsFilter may perform faster.

Which filter is best is very application dependent.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FieldCacheTermsFilter : Filter
Visual Basic
<SerializableAttribute> _
Public Class FieldCacheTermsFilter _
    Inherits Filter
Visual C++
[SerializableAttribute]
public ref class FieldCacheTermsFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..FieldCacheTermsFilter

See Also

FieldCacheTermsFilter Members
Lucene.Net.Search Namespace


FieldCacheTermsFilter Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter Members
FieldCacheTermsFilter Class Constructors Methods See Also Send Feedback

The FieldCacheTermsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCacheTermsFilter | Initializes a new instance of the FieldCacheTermsFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetFieldCache |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCacheTermsFilter Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter Constructor

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter Constructor
FieldCacheTermsFilter Class See Also Send Feedback
Initializes a new instance of the FieldCacheTermsFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheTermsFilter(
    string field,
    string[] terms
)
Visual Basic
Public Sub New ( _
    field As String, _
    terms As String() _
)
Visual C++
public:
FieldCacheTermsFilter(
    String^ field,
    array<String^>^ terms
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.#ctor(System.String,System.String[])"]

terms
Type: array< System..::..String >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.#ctor(System.String,System.String[])"]

See Also

FieldCacheTermsFilter Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter Methods
FieldCacheTermsFilter Class See Also Send Feedback

The FieldCacheTermsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetFieldCache |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCacheTermsFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..GetDocIdSet Method
FieldCacheTermsFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

FieldCacheTermsFilter Class
Lucene.Net.Search Namespace


GetFieldCache Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..GetFieldCache Method
FieldCacheTermsFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.GetFieldCache"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldCache GetFieldCache()
Visual Basic
Public Overridable Function GetFieldCache As FieldCache
Visual C++
public:
virtual FieldCache^ GetFieldCache()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.GetFieldCache"]

See Also

FieldCacheTermsFilter Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Class

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
FieldCacheTermsFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class FieldCacheTermsFilterDocIdSet : DocIdSet
Visual Basic
Protected Friend Class FieldCacheTermsFilterDocIdSet _
    Inherits DocIdSet
Visual C++
protected public ref class FieldCacheTermsFilterDocIdSet : public DocIdSet

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Search..::..FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Members
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Members
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class Constructors Methods Properties See Also Send Feedback

A {@link Filter} that only accepts documents whose single term value in the specified field is contained in the provided set of allowed terms.

This is the same functionality as TermsFilter (from contrib/queries), except this filter requires that the field contains only a single term for all documents. Because of drastically different implementations, they also have different performance characteristics, as described below.

The first invocation of this filter on a given field will be slower, since a {@link FieldCache.StringIndex} must be created. Subsequent invocations using the same field will re-use this cache. However, as with all functionality based on {@link FieldCache}, persistent RAM is consumed to hold the cache, and is not freed until the {@link IndexReader} is closed. In contrast, TermsFilter has no persistent RAM consumption.

With each search, this filter translates the specified set of Terms into a private {@link OpenBitSet} keyed by term number per unique {@link IndexReader} (normally one reader per segment). Then, during matching, the term number for each docID is retrieved from the cache and then checked for inclusion using the {@link OpenBitSet}. Since all testing is done using RAM resident data structures, performance should be very fast, most likely fast enough to not require further caching of the DocIdSet for each possible combination of terms. However, because docIDs are simply scanned linearly, an index with a great many small documents may find this linear scan too costly.

In contrast, TermsFilter builds up an {@link OpenBitSet}, keyed by docID, every time it's created, by enumerating through all matching docs using {@link TermDocs} to seek and scan through each term's docID list. While there is no linear scan of all docIDs, besides the allocation of the underlying array in the {@link OpenBitSet}, this approach requires a number of "disk seeks" in proportion to the number of terms, which can be exceptionally costly when there are cache misses in the OS's IO cache.

Generally, this filter will be slower on the first invocation for a given field, but subsequent invocations, even if you change the allowed set of Terms, should be faster than TermsFilter, especially as the number of Terms being matched increases. If you are matching only a very small number of terms, and those terms in turn match a very small number of documents, TermsFilter may perform faster.

Which filter is best is very application dependent.

The FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet | Initializes a new instance of the FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Constructor

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Constructor
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class See Also Send Feedback
Initializes a new instance of the FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheTermsFilterDocIdSet(
    FieldCacheTermsFilter enclosingInstance,
    StringIndex fcsi
)
Visual Basic
Public Sub New ( _
    enclosingInstance As FieldCacheTermsFilter, _
    fcsi As StringIndex _
)
Visual C++
public:
FieldCacheTermsFilterDocIdSet(
    FieldCacheTermsFilter^ enclosingInstance,
    StringIndex^ fcsi
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..FieldCacheTermsFilter

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.#ctor(Lucene.Net.Search.FieldCacheTermsFilter,Lucene.Net.Search.StringIndex)"]

fcsi
Type: Lucene.Net.Search..::..StringIndex

[Missing <param name="fcsi"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.#ctor(Lucene.Net.Search.FieldCacheTermsFilter,Lucene.Net.Search.StringIndex)"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Methods
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class See Also Send Feedback

The FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..IsCacheable Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class See Also Send Feedback
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCacheable()
Visual Basic
Public Overrides Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.IsCacheable"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..Iterator Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.Iterator"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSetIterator Iterator()
Visual Basic
Public Overrides Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.Iterator"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet Properties

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Properties
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class See Also Send Feedback

The FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..Enclosing_Instance Property
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheTermsFilter Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As FieldCacheTermsFilter
    Get
Visual C++
public:
property FieldCacheTermsFilter^ Enclosing_Instance {
    FieldCacheTermsFilter^ get ();
}

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Class

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class FieldCacheTermsFilterDocIdSetIterator : DocIdSetIterator
Visual Basic
Protected Friend Class FieldCacheTermsFilterDocIdSetIterator _
    Inherits DocIdSetIterator
Visual C++
protected public ref class FieldCacheTermsFilterDocIdSetIterator : public DocIdSetIterator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Members
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Members
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class Constructors Methods Properties See Also Send Feedback

The FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator | Initializes a new instance of the FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator class

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Constructor

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Constructor
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback
Initializes a new instance of the FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheTermsFilterDocIdSetIterator(
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet enclosingInstance
)
Visual Basic
Public Sub New ( _
    enclosingInstance As FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet _
)
Visual C++
public:
FieldCacheTermsFilterDocIdSetIterator(
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ enclosingInstance
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.#ctor(Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet)"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Methods
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

The FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..Advance Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Advance(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Advance(System.Int32)"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..Doc Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Doc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead.")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead.")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead.")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Doc"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..DocID Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.DocID"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..Next Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Next"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Next"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..NextDoc Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.NextDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.NextDoc"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..SkipTo Method
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead.")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead.")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead.")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.SkipTo(System.Int32)"]

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator Properties

[image] [image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Properties
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

The FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator..::..Enclosing_Instance Property
FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.FieldCacheTermsFilter.FieldCacheTermsFilterDocIdSet.FieldCacheTermsFilterDocIdSetIterator.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet
    Get
Visual C++
public:
property FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ Enclosing_Instance {
    FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet^ get ();
}

See Also

FieldCacheTermsFilter..::..FieldCacheTermsFilterDocIdSet..::..FieldCacheTermsFilterDocIdSetIterator Class
Lucene.Net.Search Namespace


FieldComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator Class
Members See Also Send Feedback
Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FieldComparator
Visual Basic
Public MustInherit Class FieldComparator
Visual C++
public ref class FieldComparator abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..ByteComparator
Lucene.Net.Search..::..FieldComparator..::..DocComparator
Lucene.Net.Search..::..FieldComparator..::..DoubleComparator
Lucene.Net.Search..::..FieldComparator..::..FloatComparator
Lucene.Net.Search..::..FieldComparator..::..IntComparator
Lucene.Net.Search..::..FieldComparator..::..LongComparator
Lucene.Net.Search..::..FieldComparator..::..RelevanceComparator
Lucene.Net.Search..::..FieldComparator..::..ShortComparator
Lucene.Net.Search..::..FieldComparator..::..StringComparatorLocale
Lucene.Net.Search..::..FieldComparator..::..StringOrdValComparator
Lucene.Net.Search..::..FieldComparator..::..StringValComparator

See Also

FieldComparator Members
Lucene.Net.Search Namespace


FieldComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator Members
FieldComparator Class Constructors Methods See Also Send Feedback

The FieldComparator type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldComparator | Initializes a new instance of the FieldComparator class

Methods

 | Name | Description
 | BinarySearch(array<String>[]()[][], String) |
 | BinarySearch(array<String>[]()[][], String, Int32, Int32) |
Public method | Compare | Compare hit at slot1 with hit at slot2.
Public method | CompareBottom | Compare the bottom of the queue with doc. This will only invoked after setBottom has been called. This should return the same result as {@link #Compare(int,int)}} as if bottom were slot1 and the new document were slot 2. For a search that hits many results, this method will be the hotspot (invoked by far the most frequently).
Public method | Copy | This method is called when a new hit is competitive. You should copy any state associated with this document that will be required for future comparisons, into the specified slot.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | Set the bottom slot, ie the "weakest" (sorted last) entry in the queue. When {@link #compareBottom} is called, you should compare against this slot. This will always be called before {@link #compareBottom}.
Public method | SetNextReader | Set a new Reader. All doc correspond to the current Reader.
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | Return the actual value in the slot.

See Also

FieldComparator Class
Lucene.Net.Search Namespace


FieldComparator Constructor

[image]

Lucene.Net Class Libraries
FieldComparator Constructor
FieldComparator Class See Also Send Feedback
Initializes a new instance of the FieldComparator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected FieldComparator()
Visual Basic
Protected Sub New
Visual C++
protected:
FieldComparator()

See Also

FieldComparator Class
Lucene.Net.Search Namespace


FieldComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator Methods
FieldComparator Class See Also Send Feedback

The FieldComparator type exposes the following members.

Methods

 | Name | Description
 | BinarySearch(array<String>[]()[][], String) |
 | BinarySearch(array<String>[]()[][], String, Int32, Int32) |
Public method | Compare | Compare hit at slot1 with hit at slot2.
Public method | CompareBottom | Compare the bottom of the queue with doc. This will only invoked after setBottom has been called. This should return the same result as {@link #Compare(int,int)}} as if bottom were slot1 and the new document were slot 2. For a search that hits many results, this method will be the hotspot (invoked by far the most frequently).
Public method | Copy | This method is called when a new hit is competitive. You should copy any state associated with this document that will be required for future comparisons, into the specified slot.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | Set the bottom slot, ie the "weakest" (sorted last) entry in the queue. When {@link #compareBottom} is called, you should compare against this slot. This will always be called before {@link #compareBottom}.
Public method | SetNextReader | Set a new Reader. All doc correspond to the current Reader.
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | Return the actual value in the slot.

See Also

FieldComparator Class
Lucene.Net.Search Namespace


BinarySearch Method

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..BinarySearch Method
FieldComparator Class See Also Send Feedback

Overload List

Name | Description
BinarySearch(array<String>[]()[][], String) |
BinarySearch(array<String>[]()[][], String, Int32, Int32) |

See Also

FieldComparator Class
FieldComparator Members
Lucene.Net.Search Namespace


BinarySearch Method (String[], String)

[image]

Lucene.Net Class Libraries
FieldComparator..::..BinarySearch Method (array<String>[]()[][], String)
FieldComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static int BinarySearch(
    string[] a,
    string key
)
Visual Basic
Protected Friend Shared Function BinarySearch ( _
    a As String(), _
    key As String _
) As Integer
Visual C++
protected public:
static int BinarySearch(
    array<String^>^ a,
    String^ key
)

Parameters

a
Type: array< System..::..String >[]()[][]

[Missing <param name="a"/> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String)"]

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String)"]

See Also

FieldComparator Class
BinarySearch Overload
Lucene.Net.Search Namespace


BinarySearch Method (String[], String, Int32, Int32)

[image]

Lucene.Net Class Libraries
FieldComparator..::..BinarySearch Method (array<String>[]()[][], String, Int32, Int32)
FieldComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static int BinarySearch(
    string[] a,
    string key,
    int low,
    int high
)
Visual Basic
Protected Friend Shared Function BinarySearch ( _
    a As String(), _
    key As String, _
    low As Integer, _
    high As Integer _
) As Integer
Visual C++
protected public:
static int BinarySearch(
    array<String^>^ a,
    String^ key,
    int low,
    int high
)

Parameters

a
Type: array< System..::..String >[]()[][]

[Missing <param name="a"/> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String,System.Int32,System.Int32)"]

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String,System.Int32,System.Int32)"]

low
Type: System..::..Int32

[Missing <param name="low"/> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String,System.Int32,System.Int32)"]

high
Type: System..::..Int32

[Missing <param name="high"/> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.BinarySearch(System.String[],System.String,System.Int32,System.Int32)"]

See Also

FieldComparator Class
BinarySearch Overload
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..Compare Method
FieldComparator Class See Also Send Feedback
Compare hit at slot1 with hit at slot2.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public MustOverride Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) abstract

Parameters

slot1
Type: System..::..Int32
first slot to compare
slot2
Type: System..::..Int32
second slot to compare

Return Value

any N < 0 if slot2's value is sorted after slot1, any N > 0 if the slot2's value is sorted before slot1 and 0 if they are equal

See Also

FieldComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..CompareBottom Method
FieldComparator Class See Also Send Feedback
Compare the bottom of the queue with doc. This will only invoked after setBottom has been called. This should return the same result as {@link #Compare(int,int)}} as if bottom were slot1 and the new document were slot 2.

For a search that hits many results, this method will be the hotspot (invoked by far the most frequently).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int CompareBottom(
    int doc
)
Visual Basic
Public MustOverride Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) abstract

Parameters

doc
Type: System..::..Int32
that was hit

Return Value

any N < 0 if the doc's value is sorted after the bottom entry (not competitive), any N > 0 if the doc's value is sorted before the bottom entry and 0 if they are equal.

See Also

FieldComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..Copy Method
FieldComparator Class See Also Send Feedback
This method is called when a new hit is competitive. You should copy any state associated with this document that will be required for future comparisons, into the specified slot.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Copy(
    int slot,
    int doc
)
Visual Basic
Public MustOverride Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) abstract

Parameters

slot
Type: System..::..Int32
which slot to copy the hit to
doc
Type: System..::..Int32
docID relative to current reader

See Also

FieldComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..SetBottom Method
FieldComparator Class See Also Send Feedback
Set the bottom slot, ie the "weakest" (sorted last) entry in the queue. When {@link #compareBottom} is called, you should compare against this slot. This will always be called before {@link #compareBottom}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void SetBottom(
    int slot
)
Visual Basic
Public MustOverride Sub SetBottom ( _
    slot As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int slot
) abstract

Parameters

slot
Type: System..::..Int32
the currently weakest (sorted last) slot in the queue

See Also

FieldComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..SetNextReader Method
FieldComparator Class See Also Send Feedback
Set a new Reader. All doc correspond to the current Reader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public MustOverride Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
current reader
docBase
Type: System..::..Int32
docBase of this reader

See Also

FieldComparator Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..SetScorer Method
FieldComparator Class See Also Send Feedback
Sets the Scorer to use in case a document's score is needed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetScorer(
    Scorer scorer
)
Visual Basic
Public Overridable Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
)

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer
Scorer instance that you should use to obtain the current hit's score, if necessary.

See Also

FieldComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..Value Method
FieldComparator Class See Also Send Feedback
Return the actual value in the slot.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract IComparable Value(
    int slot
)
Visual Basic
Public MustOverride Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) abstract

Parameters

slot
Type: System..::..Int32
the value

Return Value

value in this slot upgraded to Comparable

See Also

FieldComparator Class
Lucene.Net.Search Namespace


FieldComparator.ByteComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator Class
FieldComparator Class Members See Also Send Feedback
Parses field's values as byte (using {@link FieldCache#getBytes} and sorts by ascending value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ByteComparator : FieldComparator
Visual Basic
Public NotInheritable Class ByteComparator _
    Inherits FieldComparator
Visual C++
public ref class ByteComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..ByteComparator

See Also

FieldComparator..::..ByteComparator Members
Lucene.Net.Search Namespace


FieldComparator.ByteComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator Members
FieldComparator..::..ByteComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..ByteComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


FieldComparator.ByteComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator Methods
FieldComparator..::..ByteComparator Class See Also Send Feedback

The FieldComparator..::..ByteComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator..::..Compare Method
FieldComparator..::..ByteComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator..::..CompareBottom Method
FieldComparator..::..ByteComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator..::..Copy Method
FieldComparator..::..ByteComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator..::..SetBottom Method
FieldComparator..::..ByteComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator..::..SetNextReader Method
FieldComparator..::..ByteComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ByteComparator..::..Value Method
FieldComparator..::..ByteComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.ByteComparator.Value(System.Int32)"]

See Also

FieldComparator..::..ByteComparator Class
Lucene.Net.Search Namespace


FieldComparator.DocComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator Class
FieldComparator Class Members See Also Send Feedback
Sorts by ascending docID

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class DocComparator : FieldComparator
Visual Basic
Public NotInheritable Class DocComparator _
    Inherits FieldComparator
Visual C++
public ref class DocComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..DocComparator

See Also

FieldComparator..::..DocComparator Members
Lucene.Net.Search Namespace


FieldComparator.DocComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator Members
FieldComparator..::..DocComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..DocComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


FieldComparator.DocComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator Methods
FieldComparator..::..DocComparator Class See Also Send Feedback

The FieldComparator..::..DocComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator..::..Compare Method
FieldComparator..::..DocComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator..::..CompareBottom Method
FieldComparator..::..DocComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator..::..Copy Method
FieldComparator..::..DocComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator..::..SetBottom Method
FieldComparator..::..DocComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator..::..SetNextReader Method
FieldComparator..::..DocComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DocComparator..::..Value Method
FieldComparator..::..DocComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.DocComparator.Value(System.Int32)"]

See Also

FieldComparator..::..DocComparator Class
Lucene.Net.Search Namespace


FieldComparator.DoubleComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator Class
FieldComparator Class Members See Also Send Feedback
Parses field's values as double (using {@link FieldCache#getDoubles} and sorts by ascending value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class DoubleComparator : FieldComparator
Visual Basic
Public NotInheritable Class DoubleComparator _
    Inherits FieldComparator
Visual C++
public ref class DoubleComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..DoubleComparator

See Also

FieldComparator..::..DoubleComparator Members
Lucene.Net.Search Namespace


FieldComparator.DoubleComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator Members
FieldComparator..::..DoubleComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..DoubleComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


FieldComparator.DoubleComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator Methods
FieldComparator..::..DoubleComparator Class See Also Send Feedback

The FieldComparator..::..DoubleComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator..::..Compare Method
FieldComparator..::..DoubleComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator..::..CompareBottom Method
FieldComparator..::..DoubleComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator..::..Copy Method
FieldComparator..::..DoubleComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator..::..SetBottom Method
FieldComparator..::..DoubleComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator..::..SetNextReader Method
FieldComparator..::..DoubleComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..DoubleComparator..::..Value Method
FieldComparator..::..DoubleComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.DoubleComparator.Value(System.Int32)"]

See Also

FieldComparator..::..DoubleComparator Class
Lucene.Net.Search Namespace


FieldComparator.FloatComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator Class
FieldComparator Class Members See Also Send Feedback
Parses field's values as float (using {@link FieldCache#getFloats} and sorts by ascending value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FloatComparator : FieldComparator
Visual Basic
Public NotInheritable Class FloatComparator _
    Inherits FieldComparator
Visual C++
public ref class FloatComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..FloatComparator

See Also

FieldComparator..::..FloatComparator Members
Lucene.Net.Search Namespace


FieldComparator.FloatComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator Members
FieldComparator..::..FloatComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..FloatComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


FieldComparator.FloatComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator Methods
FieldComparator..::..FloatComparator Class See Also Send Feedback

The FieldComparator..::..FloatComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator..::..Compare Method
FieldComparator..::..FloatComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator..::..CompareBottom Method
FieldComparator..::..FloatComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator..::..Copy Method
FieldComparator..::..FloatComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator..::..SetBottom Method
FieldComparator..::..FloatComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator..::..SetNextReader Method
FieldComparator..::..FloatComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..FloatComparator..::..Value Method
FieldComparator..::..FloatComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.FloatComparator.Value(System.Int32)"]

See Also

FieldComparator..::..FloatComparator Class
Lucene.Net.Search Namespace


FieldComparator.IntComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator Class
FieldComparator Class Members See Also Send Feedback
Parses field's values as int (using {@link FieldCache#getInts} and sorts by ascending value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class IntComparator : FieldComparator
Visual Basic
Public NotInheritable Class IntComparator _
    Inherits FieldComparator
Visual C++
public ref class IntComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..IntComparator

See Also

FieldComparator..::..IntComparator Members
Lucene.Net.Search Namespace


FieldComparator.IntComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator Members
FieldComparator..::..IntComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..IntComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


FieldComparator.IntComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator Methods
FieldComparator..::..IntComparator Class See Also Send Feedback

The FieldComparator..::..IntComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator..::..Compare Method
FieldComparator..::..IntComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator..::..CompareBottom Method
FieldComparator..::..IntComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator..::..Copy Method
FieldComparator..::..IntComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator..::..SetBottom Method
FieldComparator..::..IntComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator..::..SetNextReader Method
FieldComparator..::..IntComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..IntComparator..::..Value Method
FieldComparator..::..IntComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.IntComparator.Value(System.Int32)"]

See Also

FieldComparator..::..IntComparator Class
Lucene.Net.Search Namespace


FieldComparator.LongComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator Class
FieldComparator Class Members See Also Send Feedback
Parses field's values as long (using {@link FieldCache#getLongs} and sorts by ascending value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class LongComparator : FieldComparator
Visual Basic
Public NotInheritable Class LongComparator _
    Inherits FieldComparator
Visual C++
public ref class LongComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..LongComparator

See Also

FieldComparator..::..LongComparator Members
Lucene.Net.Search Namespace


FieldComparator.LongComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator Members
FieldComparator..::..LongComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..LongComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


FieldComparator.LongComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator Methods
FieldComparator..::..LongComparator Class See Also Send Feedback

The FieldComparator..::..LongComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator..::..Compare Method
FieldComparator..::..LongComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator..::..CompareBottom Method
FieldComparator..::..LongComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator..::..Copy Method
FieldComparator..::..LongComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator..::..SetBottom Method
FieldComparator..::..LongComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator..::..SetNextReader Method
FieldComparator..::..LongComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..LongComparator..::..Value Method
FieldComparator..::..LongComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.LongComparator.Value(System.Int32)"]

See Also

FieldComparator..::..LongComparator Class
Lucene.Net.Search Namespace


FieldComparator.RelevanceComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator Class
FieldComparator Class Members See Also Send Feedback
Sorts by descending relevance. NOTE: if you are sorting only by descending relevance and then secondarily by ascending docID, peformance is faster using {@link TopScoreDocCollector} directly (which {@link IndexSearcher#search} uses when no {@link Sort} is specified).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class RelevanceComparator : FieldComparator
Visual Basic
Public NotInheritable Class RelevanceComparator _
    Inherits FieldComparator
Visual C++
public ref class RelevanceComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..RelevanceComparator

See Also

FieldComparator..::..RelevanceComparator Members
Lucene.Net.Search Namespace


FieldComparator.RelevanceComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator Members
FieldComparator..::..RelevanceComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..RelevanceComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides FieldComparator..::..SetScorer(Scorer).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


FieldComparator.RelevanceComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator Methods
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

The FieldComparator..::..RelevanceComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides FieldComparator..::..SetScorer(Scorer).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..Compare Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..CompareBottom Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..Copy Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..SetBottom Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..SetNextReader Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..SetScorer Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetScorer(Lucene.Net.Search.Scorer)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetScorer(
    Scorer scorer
)
Visual Basic
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
) override

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.SetScorer(Lucene.Net.Search.Scorer)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..RelevanceComparator..::..Value Method
FieldComparator..::..RelevanceComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.RelevanceComparator.Value(System.Int32)"]

See Also

FieldComparator..::..RelevanceComparator Class
Lucene.Net.Search Namespace


FieldComparator.ShortComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator Class
FieldComparator Class Members See Also Send Feedback
Parses field's values as short (using {@link FieldCache#getShorts} and sorts by ascending value

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ShortComparator : FieldComparator
Visual Basic
Public NotInheritable Class ShortComparator _
    Inherits FieldComparator
Visual C++
public ref class ShortComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..ShortComparator

See Also

FieldComparator..::..ShortComparator Members
Lucene.Net.Search Namespace


FieldComparator.ShortComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator Members
FieldComparator..::..ShortComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..ShortComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


FieldComparator.ShortComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator Methods
FieldComparator..::..ShortComparator Class See Also Send Feedback

The FieldComparator..::..ShortComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator..::..Compare Method
FieldComparator..::..ShortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator..::..CompareBottom Method
FieldComparator..::..ShortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator..::..Copy Method
FieldComparator..::..ShortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator..::..SetBottom Method
FieldComparator..::..ShortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator..::..SetNextReader Method
FieldComparator..::..ShortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..ShortComparator..::..Value Method
FieldComparator..::..ShortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.ShortComparator.Value(System.Int32)"]

See Also

FieldComparator..::..ShortComparator Class
Lucene.Net.Search Namespace


FieldComparator.StringComparatorLocale Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale Class
FieldComparator Class Members See Also Send Feedback
Sorts by a field's value using the Collator for a given Locale.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StringComparatorLocale : FieldComparator
Visual Basic
Public NotInheritable Class StringComparatorLocale _
    Inherits FieldComparator
Visual C++
public ref class StringComparatorLocale sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..StringComparatorLocale

See Also

FieldComparator..::..StringComparatorLocale Members
Lucene.Net.Search Namespace


FieldComparator.StringComparatorLocale Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale Members
FieldComparator..::..StringComparatorLocale Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..StringComparatorLocale type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


FieldComparator.StringComparatorLocale Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale Methods
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

The FieldComparator..::..StringComparatorLocale type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale..::..Compare Method
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale..::..CompareBottom Method
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale..::..Copy Method
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale..::..SetBottom Method
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.SetBottom(System.Int32)"]

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale..::..SetNextReader Method
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringComparatorLocale..::..Value Method
FieldComparator..::..StringComparatorLocale Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringComparatorLocale.Value(System.Int32)"]

See Also

FieldComparator..::..StringComparatorLocale Class
Lucene.Net.Search Namespace


FieldComparator.StringOrdValComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator Class
FieldComparator Class Members See Also Send Feedback
Sorts by field's natural String sort order, using ordinals. This is functionally equivalent to {@link StringValComparator}, but it first resolves the string to their relative ordinal positions (using the index returned by {@link FieldCache#getStringIndex}), and does most comparisons using the ordinals. For medium to large results, this comparator will be much faster than {@link StringValComparator}. For very small result sets it may be slower.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StringOrdValComparator : FieldComparator
Visual Basic
Public NotInheritable Class StringOrdValComparator _
    Inherits FieldComparator
Visual C++
public ref class StringOrdValComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..StringOrdValComparator

See Also

FieldComparator..::..StringOrdValComparator Members
Lucene.Net.Search Namespace


FieldComparator.StringOrdValComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator Members
FieldComparator..::..StringOrdValComparator Class Constructors Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..StringOrdValComparator type exposes the following members.

Constructors

 | Name | Description
Public method | FieldComparator..::..StringOrdValComparator | Initializes a new instance of the FieldComparator..::..StringOrdValComparator class

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBottomSlot |
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


FieldComparator.StringOrdValComparator Constructor

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator Constructor
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback
Initializes a new instance of the FieldComparator..::..StringOrdValComparator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StringOrdValComparator(
    int numHits,
    string field,
    int sortPos,
    bool reversed
)
Visual Basic
Public Sub New ( _
    numHits As Integer, _
    field As String, _
    sortPos As Integer, _
    reversed As Boolean _
)
Visual C++
public:
StringOrdValComparator(
    int numHits,
    String^ field,
    int sortPos,
    bool reversed
)

Parameters

numHits
Type: System..::..Int32

[Missing <param name="numHits"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.#ctor(System.Int32,System.String,System.Int32,System.Boolean)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.#ctor(System.Int32,System.String,System.Int32,System.Boolean)"]

sortPos
Type: System..::..Int32

[Missing <param name="sortPos"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.#ctor(System.Int32,System.String,System.Int32,System.Boolean)"]

reversed
Type: System..::..Boolean

[Missing <param name="reversed"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.#ctor(System.Int32,System.String,System.Int32,System.Boolean)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


FieldComparator.StringOrdValComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator Methods
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

The FieldComparator..::..StringOrdValComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBottomSlot |
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..Compare Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..CompareBottom Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..Copy Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


GetBottomSlot Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..GetBottomSlot Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.GetBottomSlot"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetBottomSlot()
Visual Basic
Public Function GetBottomSlot As Integer
Visual C++
public:
int GetBottomSlot()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.GetBottomSlot"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..GetField Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.GetField"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetField()
Visual Basic
Public Function GetField As String
Visual C++
public:
String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.GetField"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


GetValues Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..GetValues Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.GetValues"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string[] GetValues()
Visual Basic
Public Function GetValues As String()
Visual C++
public:
array<String^>^ GetValues()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.GetValues"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..SetBottom Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..SetNextReader Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringOrdValComparator..::..Value Method
FieldComparator..::..StringOrdValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringOrdValComparator.Value(System.Int32)"]

See Also

FieldComparator..::..StringOrdValComparator Class
Lucene.Net.Search Namespace


FieldComparator.StringValComparator Class

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator Class
FieldComparator Class Members See Also Send Feedback
Sorts by field's natural String sort order. All comparisons are done using String.compareTo, which is slow for medium to large result sets but possibly very fast for very small results sets.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class StringValComparator : FieldComparator
Visual Basic
Public NotInheritable Class StringValComparator _
    Inherits FieldComparator
Visual C++
public ref class StringValComparator sealed : public FieldComparator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparator
Lucene.Net.Search..::..FieldComparator..::..StringValComparator

See Also

FieldComparator..::..StringValComparator Members
Lucene.Net.Search Namespace


FieldComparator.StringValComparator Members

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator Members
FieldComparator..::..StringValComparator Class Methods See Also Send Feedback

Expert: a FieldComparator compares hits so as to determine their sort order when collecting the top results with {@link TopFieldCollector}. The concrete public FieldComparator classes here correspond to the SortField types.

This API is designed to achieve high performance sorting, by exposing a tight interaction with {@link FieldValueHitQueue} as it visits hits. Whenever a hit is competitive, it's enrolled into a virtual slot, which is an int ranging from 0 to numHits-1. The {@link FieldComparator} is made aware of segment transitions during searching in case any internal state it's tracking needs to be recomputed during these transitions.

A comparator must define these functions:

  • {@link #compare} Compare a hit at 'slot a' with hit 'slot b'.
  • {@link #setBottom} This method is called by {@link FieldValueHitQueue} to notify the FieldComparator of the current weakest ("bottom") slot. Note that this slot may not hold the weakest value according to your comparator, in cases where your comparator is not the primary one (ie, is only used to break ties from the comparators before it).
  • {@link #compareBottom} Compare a new hit (docID) against the "weakest" (bottom) entry in the queue.
  • {@link #copy} Installs a new hit into the priority queue. The {@link FieldValueHitQueue} calls this method when a new hit is competitive.
  • {@link #setNextReader} Invoked when the search is switching to the next segment. You may need to update internal state of the comparator, for example retrieving new values from the {@link FieldCache}.
  • {@link #value} Return the sort value stored in the specified slot. This is only called at the end of the search, in order to populate {@link FieldDoc#fields} when returning the top results.
NOTE: This API is experimental and might change in incompatible ways in the next release.

The FieldComparator..::..StringValComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


FieldComparator.StringValComparator Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator Methods
FieldComparator..::..StringValComparator Class See Also Send Feedback

The FieldComparator..::..StringValComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare | (Overrides FieldComparator..::..Compare(Int32, Int32).)
Public method | CompareBottom | (Overrides FieldComparator..::..CompareBottom(Int32).)
Public method | Copy | (Overrides FieldComparator..::..Copy(Int32, Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBottom | (Overrides FieldComparator..::..SetBottom(Int32).)
Public method | SetNextReader | (Overrides FieldComparator..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | Sets the Scorer to use in case a document's score is needed. (Inherited from FieldComparator.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | (Overrides FieldComparator..::..Value(Int32).)

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator..::..Compare Method
FieldComparator..::..StringValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Compare(
    int slot1,
    int slot2
)
Visual Basic
Public Overrides Function Compare ( _
    slot1 As Integer, _
    slot2 As Integer _
) As Integer
Visual C++
public:
virtual int Compare(
    int slot1,
    int slot2
) override

Parameters

slot1
Type: System..::..Int32

[Missing <param name="slot1"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Compare(System.Int32,System.Int32)"]

slot2
Type: System..::..Int32

[Missing <param name="slot2"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Compare(System.Int32,System.Int32)"]

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


CompareBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator..::..CompareBottom Method
FieldComparator..::..StringValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.CompareBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CompareBottom(
    int doc
)
Visual Basic
Public Overrides Function CompareBottom ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int CompareBottom(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.CompareBottom(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.CompareBottom(System.Int32)"]

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator..::..Copy Method
FieldComparator..::..StringValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Copy(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Copy(
    int slot,
    int doc
)
Visual Basic
Public Overrides Sub Copy ( _
    slot As Integer, _
    doc As Integer _
)
Visual C++
public:
virtual void Copy(
    int slot,
    int doc
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Copy(System.Int32,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Copy(System.Int32,System.Int32)"]

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


SetBottom Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator..::..SetBottom Method
FieldComparator..::..StringValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.SetBottom(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBottom(
    int bottom
)
Visual Basic
Public Overrides Sub SetBottom ( _
    bottom As Integer _
)
Visual C++
public:
virtual void SetBottom(
    int bottom
) override

Parameters

bottom
Type: System..::..Int32

[Missing <param name="bottom"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.SetBottom(System.Int32)"]

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator..::..SetNextReader Method
FieldComparator..::..StringValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


Value Method

[image]

Lucene.Net Class Libraries
FieldComparator..::..StringValComparator..::..Value Method
FieldComparator..::..StringValComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Value(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IComparable Value(
    int slot
)
Visual Basic
Public Overrides Function Value ( _
    slot As Integer _
) As IComparable
Visual C++
public:
virtual IComparable^ Value(
    int slot
) override

Parameters

slot
Type: System..::..Int32

[Missing <param name="slot"/> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Value(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldComparator.StringValComparator.Value(System.Int32)"]

See Also

FieldComparator..::..StringValComparator Class
Lucene.Net.Search Namespace


FieldComparatorSource Class

[image]

Lucene.Net Class Libraries
FieldComparatorSource Class
Members See Also Send Feedback
Provides a {@link FieldComparator} for custom field sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class FieldComparatorSource
Visual Basic
<SerializableAttribute> _
Public MustInherit Class FieldComparatorSource
Visual C++
[SerializableAttribute]
public ref class FieldComparatorSource abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparatorSource
Lucene.Net.Spatial.Tier..::..DistanceFieldComparatorSource

See Also

FieldComparatorSource Members
Lucene.Net.Search Namespace


FieldComparatorSource Members

[image] [image]

Lucene.Net Class Libraries
FieldComparatorSource Members
FieldComparatorSource Class Constructors Methods See Also Send Feedback

The FieldComparatorSource type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldComparatorSource | Initializes a new instance of the FieldComparatorSource class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewComparator | Creates a comparator for the field in the given index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldComparatorSource Class
Lucene.Net.Search Namespace


FieldComparatorSource Constructor

[image]

Lucene.Net Class Libraries
FieldComparatorSource Constructor
FieldComparatorSource Class See Also Send Feedback
Initializes a new instance of the FieldComparatorSource class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected FieldComparatorSource()
Visual Basic
Protected Sub New
Visual C++
protected:
FieldComparatorSource()

See Also

FieldComparatorSource Class
Lucene.Net.Search Namespace


FieldComparatorSource Methods

[image] [image]

Lucene.Net Class Libraries
FieldComparatorSource Methods
FieldComparatorSource Class See Also Send Feedback

The FieldComparatorSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewComparator | Creates a comparator for the field in the given index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldComparatorSource Class
Lucene.Net.Search Namespace


NewComparator Method

[image]

Lucene.Net Class Libraries
FieldComparatorSource..::..NewComparator Method
FieldComparatorSource Class See Also Send Feedback
Creates a comparator for the field in the given index.
If an error occurs reading the index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract FieldComparator NewComparator(
    string fieldname,
    int numHits,
    int sortPos,
    bool reversed
)
Visual Basic
Public MustOverride Function NewComparator ( _
    fieldname As String, _
    numHits As Integer, _
    sortPos As Integer, _
    reversed As Boolean _
) As FieldComparator
Visual C++
public:
virtual FieldComparator^ NewComparator(
    String^ fieldname,
    int numHits,
    int sortPos,
    bool reversed
) abstract

Parameters

fieldname
Type: System..::..String
Name of the field to create comparator for.
numHits
Type: System..::..Int32

[Missing <param name="numHits"/> documentation for "M:Lucene.Net.Search.FieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

sortPos
Type: System..::..Int32

[Missing <param name="sortPos"/> documentation for "M:Lucene.Net.Search.FieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

reversed
Type: System..::..Boolean

[Missing <param name="reversed"/> documentation for "M:Lucene.Net.Search.FieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

Return Value

FieldComparator.

See Also

FieldComparatorSource Class
Lucene.Net.Search Namespace


FieldDoc Class

[image]

Lucene.Net Class Libraries
FieldDoc Class
Members See Also Send Feedback
Expert: A ScoreDoc which also contains information about how to sort the referenced document. In addition to the document number and score, this object contains an array of values for the document from the field(s) used to sort. For example, if the sort criteria was to sort by fields "a", "b" then "c", the
CopyC#
fields
 object array will have three elements, corresponding respectively to the term values for the document in fields "a", "b" and "c". The class of each element in the array will be either Integer, Float or String depending on the type of values in the terms of each field.

Created: Feb 11, 2004 1:23:38 PM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FieldDoc : ScoreDoc
Visual Basic
<SerializableAttribute> _
Public Class FieldDoc _
    Inherits ScoreDoc
Visual C++
[SerializableAttribute]
public ref class FieldDoc : public ScoreDoc

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..ScoreDoc
Lucene.Net.Search..::..FieldDoc

See Also

FieldDoc Members
Lucene.Net.Search Namespace
Lucene.Net.Search..::..ScoreDoc
Lucene.Net.Search..::..TopFieldDocs


FieldDoc Members

[image] [image]

Lucene.Net Class Libraries
FieldDoc Members
FieldDoc Class Constructors Methods Fields See Also Send Feedback

The FieldDoc type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDoc(Int32, Single) | Expert: Creates one of these objects with empty sort information.
Public method | FieldDoc(Int32, Single, array<IComparable>[]()[][]) | Expert: Creates one of these objects with the given sort information.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ScoreDoc..::..ToString()()()().)

Fields

 | Name | Description
Public field | doc | Expert: A hit document's number. (Inherited from ScoreDoc.)
Public field | fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.
Public field | score | Expert: The score of this document for the query. (Inherited from ScoreDoc.)

See Also

FieldDoc Class
Lucene.Net.Search Namespace


FieldDoc Constructor

[image] [image]

Lucene.Net Class Libraries
FieldDoc Constructor
FieldDoc Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldDoc(Int32, Single) | Expert: Creates one of these objects with empty sort information.
Public method | FieldDoc(Int32, Single, array<IComparable>[]()[][]) | Expert: Creates one of these objects with the given sort information.

See Also

FieldDoc Class
FieldDoc Members
Lucene.Net.Search Namespace


FieldDoc Constructor (Int32, Single)

[image]

Lucene.Net Class Libraries
FieldDoc Constructor (Int32, Single)
FieldDoc Class See Also Send Feedback
Expert: Creates one of these objects with empty sort information.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldDoc(
    int doc,
    float score
)
Visual Basic
Public Sub New ( _
    doc As Integer, _
    score As Single _
)
Visual C++
public:
FieldDoc(
    int doc,
    float score
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldDoc.#ctor(System.Int32,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.FieldDoc.#ctor(System.Int32,System.Single)"]

See Also

FieldDoc Class
FieldDoc Overload
Lucene.Net.Search Namespace


FieldDoc Constructor (Int32, Single, IComparable[])

[image]

Lucene.Net Class Libraries
FieldDoc Constructor (Int32, Single, array<IComparable>[]()[][])
FieldDoc Class See Also Send Feedback
Expert: Creates one of these objects with the given sort information.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldDoc(
    int doc,
    float score,
    IComparable[] fields
)
Visual Basic
Public Sub New ( _
    doc As Integer, _
    score As Single, _
    fields As IComparable() _
)
Visual C++
public:
FieldDoc(
    int doc,
    float score,
    array<IComparable^>^ fields
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.FieldDoc.#ctor(System.Int32,System.Single,System.IComparable[])"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.FieldDoc.#ctor(System.Int32,System.Single,System.IComparable[])"]

fields
Type: array< System..::..IComparable >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.Search.FieldDoc.#ctor(System.Int32,System.Single,System.IComparable[])"]

See Also

FieldDoc Class
FieldDoc Overload
Lucene.Net.Search Namespace


FieldDoc Fields

[image] [image]

Lucene.Net Class Libraries
FieldDoc Fields
FieldDoc Class See Also Send Feedback

The FieldDoc type exposes the following members.

Fields

 | Name | Description
Public field | doc | Expert: A hit document's number. (Inherited from ScoreDoc.)
Public field | fields | Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.
Public field | score | Expert: The score of this document for the query. (Inherited from ScoreDoc.)

See Also

FieldDoc Class
Lucene.Net.Search Namespace


fields Field

[image]

Lucene.Net Class Libraries
FieldDoc..::..fields Field
FieldDoc Class See Also Send Feedback
Expert: The values which are used to sort the referenced document. The order of these will match the original sort criteria given by a Sort object. Each Object will be either an Integer, Float or String, depending on the type of values in the terms of the original field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
public IComparable[] fields
Visual Basic
<NonSerializedAttribute> _
Public fields As IComparable()
Visual C++
[NonSerializedAttribute]
public:
array<IComparable^>^ fields

See Also

FieldDoc Class
Lucene.Net.Search Namespace
Lucene.Net.Search..::..Sort
Searcher..::..Search(Query, Filter, Int32, Sort)


FieldDoc Methods

[image] [image]

Lucene.Net Class Libraries
FieldDoc Methods
FieldDoc Class See Also Send Feedback

The FieldDoc type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ScoreDoc..::..ToString()()()().)

See Also

FieldDoc Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldDoc..::..ToString Method
FieldDoc Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldDoc.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldDoc.ToString"]

See Also

FieldDoc Class
Lucene.Net.Search Namespace


FieldSortedHitQueue Class

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue Class
Members See Also Send Feedback
Expert: A hit queue for sorting by hits by terms in more than one field. Uses
CopyC#
FieldCache.DEFAULT
 for maintaining internal term lookup tables.

Created: Dec 8, 2003 12:56:03 PM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("see FieldValueHitQueue")]
public class FieldSortedHitQueue : PriorityQueue
Visual Basic
<ObsoleteAttribute("see FieldValueHitQueue")> _
Public Class FieldSortedHitQueue _
    Inherits PriorityQueue
Visual C++
[ObsoleteAttribute(L"see FieldValueHitQueue")]
public ref class FieldSortedHitQueue : public PriorityQueue

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..PriorityQueue
Lucene.Net.Search..::..FieldSortedHitQueue

See Also

FieldSortedHitQueue Members
Lucene.Net.Search Namespace
Searcher..::..Search(Query, Filter, Int32, Sort)
Lucene.Net.Search..::..FieldCache


FieldSortedHitQueue Members

[image] [image]

Lucene.Net Class Libraries
FieldSortedHitQueue Members
FieldSortedHitQueue Class Constructors Methods Fields See Also Send Feedback

The FieldSortedHitQueue type exposes the following members.

Constructors

 | Name | Description
Public method | FieldSortedHitQueue | Creates a hit queue sorted by the given list of fields.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetMaxScore
returns the maximum score encountered by elements inserted via insert()
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method | Insert(Object) | Obsolete. (Overrides PriorityQueue..::..Insert(Object).)
Public method | Insert(FieldDoc)
Public method | InsertWithOverflow | (Overrides PriorityQueue..::..InsertWithOverflow(Object).)
Public method LessThan
Returns whether
CopyC#
a
 is less relevant than
CopyC#
b
.
(Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

Fields

 | Name | Description
Protected field | comparators | Stores a comparator corresponding to each field being sorted by
Protected field | fields | Stores the sort criteria being used.
Protected field | heap | (Inherited from PriorityQueue.)
Protected field | maxscore | Stores the maximum score value encountered, needed for normalizing.

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


FieldSortedHitQueue Constructor

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue Constructor
FieldSortedHitQueue Class See Also Send Feedback
Creates a hit queue sorted by the given list of fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldSortedHitQueue(
    IndexReader reader,
    SortField[] fields,
    int size
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    fields As SortField(), _
    size As Integer _
)
Visual C++
public:
FieldSortedHitQueue(
    IndexReader^ reader,
    array<SortField^>^ fields,
    int size
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index to use.
fields
Type: array< Lucene.Net.Search..::..SortField >[]()[][]
Fieldable names, in priority order (highest priority first). Cannot be
CopyC#
null
 or empty.
size
Type: System..::..Int32
The number of hits to retain. Must be greater than zero.

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


FieldSortedHitQueue Fields

[image] [image]

Lucene.Net Class Libraries
FieldSortedHitQueue Fields
FieldSortedHitQueue Class See Also Send Feedback

The FieldSortedHitQueue type exposes the following members.

Fields

 | Name | Description
Protected field | comparators | Stores a comparator corresponding to each field being sorted by
Protected field | fields | Stores the sort criteria being used.
Protected field | heap | (Inherited from PriorityQueue.)
Protected field | maxscore | Stores the maximum score value encountered, needed for normalizing.

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


comparators Field

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..comparators Field
FieldSortedHitQueue Class See Also Send Feedback
Stores a comparator corresponding to each field being sorted by

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal ScoreDocComparator[] comparators
Visual Basic
Protected Friend comparators As ScoreDocComparator()
Visual C++
protected public:
array<ScoreDocComparator^>^ comparators

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


fields Field

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..fields Field
FieldSortedHitQueue Class See Also Send Feedback
Stores the sort criteria being used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SortField[] fields
Visual Basic
Protected Friend fields As SortField()
Visual C++
protected public:
array<SortField^>^ fields

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


maxscore Field

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..maxscore Field
FieldSortedHitQueue Class See Also Send Feedback
Stores the maximum score value encountered, needed for normalizing.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float maxscore
Visual Basic
Protected Friend maxscore As Single
Visual C++
protected public:
float maxscore

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


FieldSortedHitQueue Methods

[image] [image]

Lucene.Net Class Libraries
FieldSortedHitQueue Methods
FieldSortedHitQueue Class See Also Send Feedback

The FieldSortedHitQueue type exposes the following members.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetMaxScore
returns the maximum score encountered by elements inserted via insert()
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method | Insert(Object) | Obsolete. (Overrides PriorityQueue..::..Insert(Object).)
Public method | Insert(FieldDoc)
Public method | InsertWithOverflow | (Overrides PriorityQueue..::..InsertWithOverflow(Object).)
Public method LessThan
Returns whether
CopyC#
a
 is less relevant than
CopyC#
b
.
(Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


GetMaxScore Method

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..GetMaxScore Method
FieldSortedHitQueue Class See Also Send Feedback
returns the maximum score encountered by elements inserted via insert()

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetMaxScore()
Visual Basic
Public Overridable Function GetMaxScore As Single
Visual C++
public:
virtual float GetMaxScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.GetMaxScore"]

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


Insert Method

[image] [image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..Insert Method
FieldSortedHitQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(Object) | Obsolete. (Overrides PriorityQueue..::..Insert(Object).)
Public method | Insert(FieldDoc) |

See Also

FieldSortedHitQueue Class
FieldSortedHitQueue Members
Lucene.Net.Search Namespace


Insert Method (Object)

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..Insert Method (Object)
FieldSortedHitQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.Insert(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Util.PriorityQueue.Insert(object)")]
public override bool Insert(
    Object fdoc
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Util.PriorityQueue.Insert(object)")> _
Public Overrides Function Insert ( _
    fdoc As Object _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Util.PriorityQueue.Insert(object)")]
public:
virtual bool Insert(
    Object^ fdoc
) override

Parameters

fdoc
Type: System..::..Object

[Missing <param name="fdoc"/> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.Insert(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.Insert(System.Object)"]

See Also

FieldSortedHitQueue Class
Insert Overload
Lucene.Net.Search Namespace


Insert Method (FieldDoc)

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..Insert Method (FieldDoc)
FieldSortedHitQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.Insert(Lucene.Net.Search.FieldDoc)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Insert(
    FieldDoc fdoc
)
Visual Basic
Public Overridable Function Insert ( _
    fdoc As FieldDoc _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FieldDoc^ fdoc
)

Parameters

fdoc
Type: Lucene.Net.Search..::..FieldDoc

[Missing <param name="fdoc"/> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.Insert(Lucene.Net.Search.FieldDoc)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.Insert(Lucene.Net.Search.FieldDoc)"]

See Also

FieldSortedHitQueue Class
Insert Overload
Lucene.Net.Search Namespace


InsertWithOverflow Method

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..InsertWithOverflow Method
FieldSortedHitQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.InsertWithOverflow(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object InsertWithOverflow(
    Object element
)
Visual Basic
Public Overrides Function InsertWithOverflow ( _
    element As Object _
) As Object
Visual C++
public:
virtual Object^ InsertWithOverflow(
    Object^ element
) override

Parameters

element
Type: System..::..Object

[Missing <param name="element"/> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.InsertWithOverflow(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldSortedHitQueue.InsertWithOverflow(System.Object)"]

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


LessThan Method

[image]

Lucene.Net Class Libraries
FieldSortedHitQueue..::..LessThan Method
FieldSortedHitQueue Class See Also Send Feedback
Returns whether
CopyC#
a
 is less relevant than
CopyC#
b
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool LessThan(
    Object a,
    Object b
)
Visual Basic
Public Overrides Function LessThan ( _
    a As Object, _
    b As Object _
) As Boolean
Visual C++
public:
virtual bool LessThan(
    Object^ a,
    Object^ b
) override

Parameters

a
Type: System..::..Object
ScoreDoc
b
Type: System..::..Object
ScoreDoc

Return Value

CopyC#
true
 if document
CopyC#
a
 should be sorted after document
CopyC#
b
.

See Also

FieldSortedHitQueue Class
Lucene.Net.Search Namespace


FieldValueHitQueue Class

[image]

Lucene.Net Class Libraries
FieldValueHitQueue Class
Members See Also Send Feedback
Expert: A hit queue for sorting by hits by terms in more than one field. Uses
CopyC#
FieldCache.DEFAULT
 for maintaining internal term lookup tables. This class will not resolve SortField.AUTO types, and expects the type of all SortFields used for construction to already have been resolved. {@link SortField#DetectFieldType(IndexReader, String)} is a utility method which may be used for field type detection. NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FieldValueHitQueue : PriorityQueue
Visual Basic
Public MustInherit Class FieldValueHitQueue _
    Inherits PriorityQueue
Visual C++
public ref class FieldValueHitQueue abstract : public PriorityQueue

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..PriorityQueue
Lucene.Net.Search..::..FieldValueHitQueue

See Also

FieldValueHitQueue Members
Lucene.Net.Search Namespace
Searcher..::..Search(Query, Filter, Int32, Sort)
Lucene.Net.Search..::..FieldCache


FieldValueHitQueue Members

[image] [image]

Lucene.Net Class Libraries
FieldValueHitQueue Members
FieldValueHitQueue Class Methods Fields See Also Send Feedback

The FieldValueHitQueue type exposes the following members.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Create
Creates a hit queue sorted by the given list of fields.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
(Inherited from PriorityQueue.)
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue.)
Public method | LessThan | (Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

Fields

 | Name | Description
Protected field | comparators |
Protected field | fields | Stores the sort criteria being used.
Protected field | heap | (Inherited from PriorityQueue.)
Protected field | reverseMul |

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


FieldValueHitQueue Fields

[image] [image]

Lucene.Net Class Libraries
FieldValueHitQueue Fields
FieldValueHitQueue Class See Also Send Feedback

The FieldValueHitQueue type exposes the following members.

Fields

 | Name | Description
Protected field | comparators |
Protected field | fields | Stores the sort criteria being used.
Protected field | heap | (Inherited from PriorityQueue.)
Protected field | reverseMul |

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


comparators Field

[image]

Lucene.Net Class Libraries
FieldValueHitQueue..::..comparators Field
FieldValueHitQueue Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FieldValueHitQueue.comparators"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal FieldComparator[] comparators
Visual Basic
Protected Friend comparators As FieldComparator()
Visual C++
protected public:
array<FieldComparator^>^ comparators

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


fields Field

[image]

Lucene.Net Class Libraries
FieldValueHitQueue..::..fields Field
FieldValueHitQueue Class See Also Send Feedback
Stores the sort criteria being used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SortField[] fields
Visual Basic
Protected Friend fields As SortField()
Visual C++
protected public:
array<SortField^>^ fields

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


reverseMul Field

[image]

Lucene.Net Class Libraries
FieldValueHitQueue..::..reverseMul Field
FieldValueHitQueue Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FieldValueHitQueue.reverseMul"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int[] reverseMul
Visual Basic
Protected Friend reverseMul As Integer()
Visual C++
protected public:
array<int>^ reverseMul

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


FieldValueHitQueue Methods

[image] [image]

Lucene.Net Class Libraries
FieldValueHitQueue Methods
FieldValueHitQueue Class See Also Send Feedback

The FieldValueHitQueue type exposes the following members.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Create
Creates a hit queue sorted by the given list of fields.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
(Inherited from PriorityQueue.)
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue.)
Public method | LessThan | (Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


Create Method

[image]

Lucene.Net Class Libraries
FieldValueHitQueue..::..Create Method
FieldValueHitQueue Class See Also Send Feedback
Creates a hit queue sorted by the given list of fields.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldValueHitQueue Create(
    SortField[] fields,
    int size
)
Visual Basic
Public Shared Function Create ( _
    fields As SortField(), _
    size As Integer _
) As FieldValueHitQueue
Visual C++
public:
static FieldValueHitQueue^ Create(
    array<SortField^>^ fields,
    int size
)

Parameters

fields
Type: array< Lucene.Net.Search..::..SortField >[]()[][]
SortField array we are sorting by in priority order (highest priority first); cannot be
CopyC#
null
 or empty
size
Type: System..::..Int32
The number of hits to retain. Must be greater than zero.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldValueHitQueue.Create(Lucene.Net.Search.SortField[],System.Int32)"]

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


LessThan Method

[image]

Lucene.Net Class Libraries
FieldValueHitQueue..::..LessThan Method
FieldValueHitQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FieldValueHitQueue.LessThan(System.Object,System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool LessThan(
    Object a,
    Object b
)
Visual Basic
Public MustOverride Function LessThan ( _
    a As Object, _
    b As Object _
) As Boolean
Visual C++
public:
virtual bool LessThan(
    Object^ a,
    Object^ b
) abstract override

Parameters

a
Type: System..::..Object

[Missing <param name="a"/> documentation for "M:Lucene.Net.Search.FieldValueHitQueue.LessThan(System.Object,System.Object)"]

b
Type: System..::..Object

[Missing <param name="b"/> documentation for "M:Lucene.Net.Search.FieldValueHitQueue.LessThan(System.Object,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FieldValueHitQueue.LessThan(System.Object,System.Object)"]

See Also

FieldValueHitQueue Class
Lucene.Net.Search Namespace


Filter Class

[image]

Lucene.Net Class Libraries
Filter Class
Members See Also Send Feedback
Abstract base class for restricting which documents may be returned during searching.

Note: In Lucene 3.0 {@link #Bits(IndexReader)} will be removed and {@link #GetDocIdSet(IndexReader)} will be defined as abstract. All implementing classes must therefore implement {@link #GetDocIdSet(IndexReader)} in order to work with Lucene 3.0.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class Filter
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Filter
Visual C++
[SerializableAttribute]
public ref class Filter abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..BooleanFilter
Lucene.Net.Search..::..CachingWrapperFilter
Lucene.Net.Search..::..DuplicateFilter
Lucene.Net.Search..::..FieldCacheRangeFilter
Lucene.Net.Search..::..FieldCacheTermsFilter
Lucene.Net.Search..::..MultiTermQueryWrapperFilter
Lucene.Net.Search..::..QueryWrapperFilter
Lucene.Net.Search..::..SpanFilter
Lucene.Net.Search..::..TermsFilter
Lucene.Net.Spatial.Tier..::..CartesianShapeFilter
Lucene.Net.Spatial.Tier..::..DistanceFilter

See Also

Filter Members
Lucene.Net.Search Namespace


Filter Members

[image] [image]

Lucene.Net Class Libraries
Filter Members
Filter Class Constructors Methods See Also Send Feedback

The Filter type exposes the following members.

Constructors

 | Name | Description
Protected method | Filter | Initializes a new instance of the Filter class

Methods

 | Name | Description
Public method | Bits | Obsolete.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter Class
Lucene.Net.Search Namespace


Filter Constructor

[image]

Lucene.Net Class Libraries
Filter Constructor
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Filter()
Visual Basic
Protected Sub New
Visual C++
protected:
Filter()

See Also

Filter Class
Lucene.Net.Search Namespace


Filter Methods

[image] [image]

Lucene.Net Class Libraries
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter Class
Lucene.Net.Search Namespace


Bits Method

[image]

Lucene.Net Class Libraries
Filter..::..Bits Method
Filter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Filter.Bits(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")]
public virtual BitArray Bits(
    IndexReader reader
)
Visual Basic
<ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")> _
Public Overridable Function Bits ( _
    reader As IndexReader _
) As BitArray
Visual C++
[ObsoleteAttribute(L"Use GetDocIdSet(IndexReader) instead.")]
public:
virtual BitArray^ Bits(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Filter.Bits(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Filter.Bits(Lucene.Net.Index.IndexReader)"]

See Also

Filter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
Filter..::..GetDocIdSet Method
Filter Class See Also Send Feedback
Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter.

Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overridable Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Filter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

a DocIdSet that provides the documents which should be permitted or prohibited in search results. NOTE: null can be returned if no documents will be accepted by this Filter.

See Also

Filter Class
Lucene.Net.Search Namespace
Lucene.Net.Util..::..DocIdBitSet


FilteredDocIdSet Class

[image]

Lucene.Net Class Libraries
FilteredDocIdSet Class
Members See Also Send Feedback
Abstract decorator class for a DocIdSet implementation that provides on-demand filtering/validation mechanism on a given DocIdSet.

Technically, this same functionality could be achieved with ChainedFilter (under contrib/misc), however the benefit of this class is it never materializes the full bitset for the filter. Instead, the {@link #match} method is invoked on-demand, per docID visited during searching. If you know few docIDs will be visited, and the logic behind {@link #match} is relatively costly, this may be a better way to filter than ChainedFilter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FilteredDocIdSet : DocIdSet
Visual Basic
Public MustInherit Class FilteredDocIdSet _
    Inherits DocIdSet
Visual C++
public ref class FilteredDocIdSet abstract : public DocIdSet

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Search..::..FilteredDocIdSet

See Also

FilteredDocIdSet Members
Lucene.Net.Search Namespace
Lucene.Net.Search..::..DocIdSet


FilteredDocIdSet Members

[image] [image]

Lucene.Net Class Libraries
FilteredDocIdSet Members
FilteredDocIdSet Class Constructors Methods See Also Send Feedback

The FilteredDocIdSet type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredDocIdSet | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable if the inner set is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | Implementation of the contract to build a DocIdSetIterator. (Overrides DocIdSet..::..Iterator()()()().)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredDocIdSet Class
Lucene.Net.Search Namespace


FilteredDocIdSet Constructor

[image]

Lucene.Net Class Libraries
FilteredDocIdSet Constructor
FilteredDocIdSet Class See Also Send Feedback
Constructor.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilteredDocIdSet(
    DocIdSet innerSet
)
Visual Basic
Public Sub New ( _
    innerSet As DocIdSet _
)
Visual C++
public:
FilteredDocIdSet(
    DocIdSet^ innerSet
)

Parameters

innerSet
Type: Lucene.Net.Search..::..DocIdSet
Underlying DocIdSet

See Also

FilteredDocIdSet Class
Lucene.Net.Search Namespace


FilteredDocIdSet Methods

[image] [image]

Lucene.Net Class Libraries
FilteredDocIdSet Methods
FilteredDocIdSet Class See Also Send Feedback

The FilteredDocIdSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable if the inner set is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | Implementation of the contract to build a DocIdSetIterator. (Overrides DocIdSet..::..Iterator()()()().)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredDocIdSet Class
Lucene.Net.Search Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSet..::..IsCacheable Method
FilteredDocIdSet Class See Also Send Feedback
This DocIdSet implementation is cacheable if the inner set is cacheable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCacheable()
Visual Basic
Public Overrides Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSet.IsCacheable"]

See Also

FilteredDocIdSet Class
Lucene.Net.Search Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSet..::..Iterator Method
FilteredDocIdSet Class See Also Send Feedback
Implementation of the contract to build a DocIdSetIterator.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSetIterator Iterator()
Visual Basic
Public Overrides Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSet.Iterator"]

See Also

FilteredDocIdSet Class
Lucene.Net.Search Namespace
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..FilteredDocIdSetIterator


Match Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSet..::..Match Method
FilteredDocIdSet Class See Also Send Feedback
Validation method to determine whether a docid should be in the result set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Match(
    int docid
)
Visual Basic
Public MustOverride Function Match ( _
    docid As Integer _
) As Boolean
Visual C++
public:
virtual bool Match(
    int docid
) abstract

Parameters

docid
Type: System..::..Int32
docid to be tested

Return Value

true if input docid should be in the result set, false otherwise.

See Also

FilteredDocIdSet Class
Lucene.Net.Search Namespace


FilteredDocIdSetIterator Class

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator Class
Members See Also Send Feedback
Abstract decorator class of a DocIdSetIterator implementation that provides on-demand filter/validation mechanism on an underlying DocIdSetIterator. See {@link FilteredDocIdSet}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FilteredDocIdSetIterator : DocIdSetIterator
Visual Basic
Public MustInherit Class FilteredDocIdSetIterator _
    Inherits DocIdSetIterator
Visual C++
public ref class FilteredDocIdSetIterator abstract : public DocIdSetIterator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..FilteredDocIdSetIterator

See Also

FilteredDocIdSetIterator Members
Lucene.Net.Search Namespace


FilteredDocIdSetIterator Members

[image] [image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator Members
FilteredDocIdSetIterator Class Constructors Methods Fields See Also Send Feedback

The FilteredDocIdSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredDocIdSetIterator | Constructor.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _innerIter |

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


FilteredDocIdSetIterator Constructor

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator Constructor
FilteredDocIdSetIterator Class See Also Send Feedback
Constructor.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilteredDocIdSetIterator(
    DocIdSetIterator innerIter
)
Visual Basic
Public Sub New ( _
    innerIter As DocIdSetIterator _
)
Visual C++
public:
FilteredDocIdSetIterator(
    DocIdSetIterator^ innerIter
)

Parameters

innerIter
Type: Lucene.Net.Search..::..DocIdSetIterator
Underlying DocIdSetIterator.

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


FilteredDocIdSetIterator Fields

[image] [image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator Fields
FilteredDocIdSetIterator Class See Also Send Feedback

The FilteredDocIdSetIterator type exposes the following members.

Fields

 | Name | Description
Protected field | _innerIter |

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


_innerIter Field

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::.._innerIter Field
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FilteredDocIdSetIterator._innerIter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal DocIdSetIterator _innerIter
Visual Basic
Protected Friend _innerIter As DocIdSetIterator
Visual C++
protected public:
DocIdSetIterator^ _innerIter

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


FilteredDocIdSetIterator Methods

[image] [image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator Methods
FilteredDocIdSetIterator Class See Also Send Feedback

The FilteredDocIdSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match | Validation method to determine whether a docid should be in the result set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..Advance Method
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Advance(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Advance(System.Int32)"]

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..Doc Method
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Doc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead.")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead.")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead.")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Doc"]

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..DocID Method
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.DocID"]

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


Match Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..Match Method
FilteredDocIdSetIterator Class See Also Send Feedback
Validation method to determine whether a docid should be in the result set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Match(
    int doc
)
Visual Basic
Public MustOverride Function Match ( _
    doc As Integer _
) As Boolean
Visual C++
public:
virtual bool Match(
    int doc
) abstract

Parameters

doc
Type: System..::..Int32
docid to be tested

Return Value

true if input docid should be in the result set, false otherwise.

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace
FilteredDocIdSetIterator..::..FilteredDocIdSetIterator(DocIdSetIterator)


Next Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..Next Method
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Next"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.Next"]

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..NextDoc Method
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.NextDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.NextDoc"]

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
FilteredDocIdSetIterator..::..SkipTo Method
FilteredDocIdSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead. ")]
public override bool SkipTo(
    int n
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead. ")> _
Public Overrides Function SkipTo ( _
    n As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead. ")]
public:
virtual bool SkipTo(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredDocIdSetIterator.SkipTo(System.Int32)"]

See Also

FilteredDocIdSetIterator Class
Lucene.Net.Search Namespace


FilteredQuery Class

[image]

Lucene.Net Class Libraries
FilteredQuery Class
Members See Also Send Feedback
A query that applies a filter to the results of another query.

Note: the bits are retrieved from the filter each time this query is used in a search - use a CachingWrapperFilter to avoid regenerating the bits every time.

Created: Apr 20, 2004 8:58:29 AM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FilteredQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class FilteredQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class FilteredQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..FilteredQuery

See Also

FilteredQuery Members
Lucene.Net.Search Namespace
Lucene.Net.Search..::..CachingWrapperFilter


FilteredQuery Members

[image] [image]

Lucene.Net Class Libraries
FilteredQuery Members
FilteredQuery Class Constructors Methods See Also Send Feedback

The FilteredQuery type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredQuery | Constructs a new query which applies a filter to the results of the original query. Filter.getDocIdSet() will be called every time this query is used in a search.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.
(Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetFilter
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method | GetQuery
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Rewrites the wrapped query.
(Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


FilteredQuery Constructor

[image]

Lucene.Net Class Libraries
FilteredQuery Constructor
FilteredQuery Class See Also Send Feedback
Constructs a new query which applies a filter to the results of the original query. Filter.getDocIdSet() will be called every time this query is used in a search.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilteredQuery(
    Query query,
    Filter filter
)
Visual Basic
Public Sub New ( _
    query As Query, _
    filter As Filter _
)
Visual C++
public:
FilteredQuery(
    Query^ query,
    Filter^ filter
)

Parameters

query
Type: Lucene.Net.Search..::..Query
Query to be filtered, cannot be
CopyC#
null
.
filter
Type: Lucene.Net.Search..::..Filter
Filter to apply to query results, cannot be
CopyC#
null
.

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


FilteredQuery Methods

[image] [image]

Lucene.Net Class Libraries
FilteredQuery Methods
FilteredQuery Class See Also Send Feedback

The FilteredQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.
(Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetFilter
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method | GetQuery
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Rewrites the wrapped query.
(Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..CreateWeight Method
FilteredQuery Class See Also Send Feedback
Returns a Weight that applies the filter to the enclosed query's Weight. This is accomplished by overriding the Scorer returned by the Weight.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.FilteredQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..Equals Method
FilteredQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.FilteredQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.Equals(System.Object)"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..ExtractTerms Method
FilteredQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.FilteredQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


GetFilter Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..GetFilter Method
FilteredQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredQuery.GetFilter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Filter GetFilter()
Visual Basic
Public Overridable Function GetFilter As Filter
Visual C++
public:
virtual Filter^ GetFilter()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.GetFilter"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..GetHashCode Method
FilteredQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.GetHashCode"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..GetQuery Method
FilteredQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilteredQuery.GetQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query GetQuery()
Visual Basic
Public Overridable Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.GetQuery"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
FilteredQuery..::..Rewrite Method
FilteredQuery Class See Also Send Feedback
Rewrites the wrapped query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FilteredQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

FilteredQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
FilteredQuery..::..ToString Method
FilteredQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

FilteredQuery Class
FilteredQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
FilteredQuery..::..ToString Method (String)
FilteredQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string s
)
Visual Basic
Public Overrides Function ToString ( _
    s As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ s
) override

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Search.FilteredQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredQuery.ToString(System.String)"]

See Also

FilteredQuery Class
ToString Overload
Lucene.Net.Search Namespace


FilteredTermEnum Class

[image]

Lucene.Net Class Libraries
FilteredTermEnum Class
Members See Also Send Feedback
Abstract class for enumerating a subset of all terms.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FilteredTermEnum : TermEnum
Visual Basic
Public MustInherit Class FilteredTermEnum _
    Inherits TermEnum
Visual C++
public ref class FilteredTermEnum abstract : public TermEnum

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Search..::..FilteredTermEnum
Lucene.Net.Search..::..FuzzyTermEnum
Lucene.Net.Search..::..PrefixTermEnum
Lucene.Net.Search.Regex..::..RegexTermEnum
Lucene.Net.Search..::..TermRangeTermEnum
Lucene.Net.Search..::..WildcardTermEnum

See Also

FilteredTermEnum Members
Lucene.Net.Search Namespace


FilteredTermEnum Members

[image] [image]

Lucene.Net Class Libraries
FilteredTermEnum Members
FilteredTermEnum Class Constructors Methods Fields See Also Send Feedback

The FilteredTermEnum type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredTermEnum | Initializes a new instance of the FilteredTermEnum class

Methods

Name Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Overrides TermEnum..::..Close()()()().)
Public method Difference
Equality measure on the term
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Overrides TermEnum..::..DocFreq()()()().)
Public method EndEnum
Indicates the end of the enumeration has been reached
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Overrides TermEnum..::..Next()()()().)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Overrides TermEnum..::..Term()()()().)
Public method TermCompare
Equality compare on the term
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum}
Protected field | currentTerm | the current term

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


FilteredTermEnum Constructor

[image]

Lucene.Net Class Libraries
FilteredTermEnum Constructor
FilteredTermEnum Class See Also Send Feedback
Initializes a new instance of the FilteredTermEnum class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilteredTermEnum()
Visual Basic
Public Sub New
Visual C++
public:
FilteredTermEnum()

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


FilteredTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
FilteredTermEnum Fields
FilteredTermEnum Class See Also Send Feedback

The FilteredTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum}
Protected field | currentTerm | the current term

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


actualEnum Field

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..actualEnum Field
FilteredTermEnum Class See Also Send Feedback
the delegate enum - to set this member use {@link #setEnum}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermEnum actualEnum
Visual Basic
Protected Friend actualEnum As TermEnum
Visual C++
protected public:
TermEnum^ actualEnum

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


currentTerm Field

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..currentTerm Field
FilteredTermEnum Class See Also Send Feedback
the current term

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Term currentTerm
Visual Basic
Protected Friend currentTerm As Term
Visual C++
protected public:
Term^ currentTerm

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


FilteredTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
FilteredTermEnum Methods
FilteredTermEnum Class See Also Send Feedback

The FilteredTermEnum type exposes the following members.

Methods

Name Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Overrides TermEnum..::..Close()()()().)
Public method Difference
Equality measure on the term
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Overrides TermEnum..::..DocFreq()()()().)
Public method EndEnum
Indicates the end of the enumeration has been reached
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Overrides TermEnum..::..Next()()()().)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Overrides TermEnum..::..Term()()()().)
Public method TermCompare
Equality compare on the term
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


Close Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..Close Method
FilteredTermEnum Class See Also Send Feedback
Closes the enumeration to further activity, freeing resources.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


Difference Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..Difference Method
FilteredTermEnum Class See Also Send Feedback
Equality measure on the term

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float Difference()
Visual Basic
Public MustOverride Function Difference As Single
Visual C++
public:
virtual float Difference() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredTermEnum.Difference"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..DocFreq Method
FilteredTermEnum Class See Also Send Feedback
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq()
Visual Basic
Public Overrides Function DocFreq As Integer
Visual C++
public:
virtual int DocFreq() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredTermEnum.DocFreq"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


EndEnum Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..EndEnum Method
FilteredTermEnum Class See Also Send Feedback
Indicates the end of the enumeration has been reached

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool EndEnum()
Visual Basic
Public MustOverride Function EndEnum As Boolean
Visual C++
public:
virtual bool EndEnum() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredTermEnum.EndEnum"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..Next Method
FilteredTermEnum Class See Also Send Feedback
Increments the enumeration to the next element. True if one exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredTermEnum.Next"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


SetEnum Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..SetEnum Method
FilteredTermEnum Class See Also Send Feedback
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void SetEnum(
    TermEnum actualEnum
)
Visual Basic
Protected Friend Overridable Sub SetEnum ( _
    actualEnum As TermEnum _
)
Visual C++
protected public:
virtual void SetEnum(
    TermEnum^ actualEnum
)

Parameters

actualEnum
Type: Lucene.Net.Index..::..TermEnum

[Missing <param name="actualEnum"/> documentation for "M:Lucene.Net.Search.FilteredTermEnum.SetEnum(Lucene.Net.Index.TermEnum)"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


Term Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..Term Method
FilteredTermEnum Class See Also Send Feedback
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Term Term()
Visual Basic
Public Overrides Function Term As Term
Visual C++
public:
virtual Term^ Term() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredTermEnum.Term"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


TermCompare Method

[image]

Lucene.Net Class Libraries
FilteredTermEnum..::..TermCompare Method
FilteredTermEnum Class See Also Send Feedback
Equality compare on the term

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool TermCompare(
    Term term
)
Visual Basic
Public MustOverride Function TermCompare ( _
    term As Term _
) As Boolean
Visual C++
public:
virtual bool TermCompare(
    Term^ term
) abstract

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FilteredTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilteredTermEnum.TermCompare(Lucene.Net.Index.Term)"]

See Also

FilteredTermEnum Class
Lucene.Net.Search Namespace


FilterManager Class

[image]

Lucene.Net Class Libraries
FilterManager Class
Members See Also Send Feedback
Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FilterManager
Visual Basic
Public Class FilterManager
Visual C++
public ref class FilterManager

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FilterManager

See Also

FilterManager Members
Lucene.Net.Search Namespace


FilterManager Members

[image] [image]

Lucene.Net Class Libraries
FilterManager Members
FilterManager Class Constructors Methods Fields See Also Send Feedback

The FilterManager type exposes the following members.

Constructors

 | Name | Description
Protected method | FilterManager | Sets up the FilterManager singleton.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilter | Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCacheSize | Sets the max size that cache should reach before it is cleaned up
Public method | SetCleanThreadSleepTime | Sets the cache cleaning frequency in milliseconds.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | cache | The cache itself
Protected field | cacheCleanSize | Maximum allowed cache size
Protected field | cleanSleepTime | Cache cleaning frequency
 | DEFAULT_CACHE_CLEAN_SIZE | The default maximum number of Filters in the cache
 | DEFAULT_CACHE_SLEEP_TIME | The default frequency of cache clenup
Protected field | filterCleaner | Cache cleaner that runs in a separate thread
 | manager |

See Also

FilterManager Class
Lucene.Net.Search Namespace


FilterManager Constructor

[image]

Lucene.Net Class Libraries
FilterManager Constructor
FilterManager Class See Also Send Feedback
Sets up the FilterManager singleton.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal FilterManager()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
FilterManager()

See Also

FilterManager Class
Lucene.Net.Search Namespace


FilterManager Fields

[image] [image]

Lucene.Net Class Libraries
FilterManager Fields
FilterManager Class See Also Send Feedback

The FilterManager type exposes the following members.

Fields

 | Name | Description
Protected field | cache | The cache itself
Protected field | cacheCleanSize | Maximum allowed cache size
Protected field | cleanSleepTime | Cache cleaning frequency
 | DEFAULT_CACHE_CLEAN_SIZE | The default maximum number of Filters in the cache
 | DEFAULT_CACHE_SLEEP_TIME | The default frequency of cache clenup
Protected field | filterCleaner | Cache cleaner that runs in a separate thread
 | manager |

See Also

FilterManager Class
Lucene.Net.Search Namespace


cache Field

[image]

Lucene.Net Class Libraries
FilterManager..::..cache Field
FilterManager Class See Also Send Feedback
The cache itself

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal IDictionary cache
Visual Basic
Protected Friend cache As IDictionary
Visual C++
protected public:
IDictionary^ cache

See Also

FilterManager Class
Lucene.Net.Search Namespace


cacheCleanSize Field

[image]

Lucene.Net Class Libraries
FilterManager..::..cacheCleanSize Field
FilterManager Class See Also Send Feedback
Maximum allowed cache size

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int cacheCleanSize
Visual Basic
Protected Friend cacheCleanSize As Integer
Visual C++
protected public:
int cacheCleanSize

See Also

FilterManager Class
Lucene.Net.Search Namespace


cleanSleepTime Field

[image]

Lucene.Net Class Libraries
FilterManager..::..cleanSleepTime Field
FilterManager Class See Also Send Feedback
Cache cleaning frequency

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal long cleanSleepTime
Visual Basic
Protected Friend cleanSleepTime As Long
Visual C++
protected public:
long long cleanSleepTime

See Also

FilterManager Class
Lucene.Net.Search Namespace


DEFAULT_CACHE_CLEAN_SIZE Field

[image]

Lucene.Net Class Libraries
FilterManager..::..DEFAULT_CACHE_CLEAN_SIZE Field
FilterManager Class See Also Send Feedback
The default maximum number of Filters in the cache

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal const int DEFAULT_CACHE_CLEAN_SIZE
Visual Basic
Protected Friend Const DEFAULT_CACHE_CLEAN_SIZE As Integer
Visual C++
protected public:
literal int DEFAULT_CACHE_CLEAN_SIZE

See Also

FilterManager Class
Lucene.Net.Search Namespace


DEFAULT_CACHE_SLEEP_TIME Field

[image]

Lucene.Net Class Libraries
FilterManager..::..DEFAULT_CACHE_SLEEP_TIME Field
FilterManager Class See Also Send Feedback
The default frequency of cache clenup

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal const long DEFAULT_CACHE_SLEEP_TIME
Visual Basic
Protected Friend Const DEFAULT_CACHE_SLEEP_TIME As Long
Visual C++
protected public:
literal long long DEFAULT_CACHE_SLEEP_TIME

See Also

FilterManager Class
Lucene.Net.Search Namespace


filterCleaner Field

[image]

Lucene.Net Class Libraries
FilterManager..::..filterCleaner Field
FilterManager Class See Also Send Feedback
Cache cleaner that runs in a separate thread

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal FilterManager..::..FilterCleaner filterCleaner
Visual Basic
Protected Friend filterCleaner As FilterManager..::..FilterCleaner
Visual C++
protected public:
FilterManager..::..FilterCleaner^ filterCleaner

See Also

FilterManager Class
Lucene.Net.Search Namespace


manager Field

[image]

Lucene.Net Class Libraries
FilterManager..::..manager Field
FilterManager Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FilterManager.manager"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static FilterManager manager
Visual Basic
Protected Friend Shared manager As FilterManager
Visual C++
protected public:
static FilterManager^ manager

See Also

FilterManager Class
Lucene.Net.Search Namespace


FilterManager Methods

[image] [image]

Lucene.Net Class Libraries
FilterManager Methods
FilterManager Class See Also Send Feedback

The FilterManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilter | Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCacheSize | Sets the max size that cache should reach before it is cleaned up
Public method | SetCleanThreadSleepTime | Sets the cache cleaning frequency in milliseconds.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterManager Class
Lucene.Net.Search Namespace


GetFilter Method

[image]

Lucene.Net Class Libraries
FilterManager..::..GetFilter Method
FilterManager Class See Also Send Feedback
Returns the cached version of the filter. Allows the caller to pass up a small filter but this will keep a persistent version around and allow the caching filter to do its job.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Filter GetFilter(
    Filter filter
)
Visual Basic
Public Overridable Function GetFilter ( _
    filter As Filter _
) As Filter
Visual C++
public:
virtual Filter^ GetFilter(
    Filter^ filter
)

Parameters

filter
Type: Lucene.Net.Search..::..Filter
The input filter

Return Value

The cached version of the filter

See Also

FilterManager Class
Lucene.Net.Search Namespace


GetInstance Method

[image]

Lucene.Net Class Libraries
FilterManager..::..GetInstance Method
FilterManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilterManager.GetInstance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FilterManager GetInstance()
Visual Basic
Public Shared Function GetInstance As FilterManager
Visual C++
public:
static FilterManager^ GetInstance()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FilterManager.GetInstance"]

See Also

FilterManager Class
Lucene.Net.Search Namespace


SetCacheSize Method

[image]

Lucene.Net Class Libraries
FilterManager..::..SetCacheSize Method
FilterManager Class See Also Send Feedback
Sets the max size that cache should reach before it is cleaned up

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetCacheSize(
    int cacheCleanSize
)
Visual Basic
Public Overridable Sub SetCacheSize ( _
    cacheCleanSize As Integer _
)
Visual C++
public:
virtual void SetCacheSize(
    int cacheCleanSize
)

Parameters

cacheCleanSize
Type: System..::..Int32
maximum allowed cache size

See Also

FilterManager Class
Lucene.Net.Search Namespace


SetCleanThreadSleepTime Method

[image]

Lucene.Net Class Libraries
FilterManager..::..SetCleanThreadSleepTime Method
FilterManager Class See Also Send Feedback
Sets the cache cleaning frequency in milliseconds.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetCleanThreadSleepTime(
    long cleanSleepTime
)
Visual Basic
Public Overridable Sub SetCleanThreadSleepTime ( _
    cleanSleepTime As Long _
)
Visual C++
public:
virtual void SetCleanThreadSleepTime(
    long long cleanSleepTime
)

Parameters

cleanSleepTime
Type: System..::..Int64
cleaning frequency in millioseconds

See Also

FilterManager Class
Lucene.Net.Search Namespace


FilterManager.FilterCleaner Class

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterCleaner Class
FilterManager Class Members See Also Send Feedback
Keeps the cache from getting too big. If we were using Java 1.5, we could use LinkedHashMap and we would not need this thread to clean out the cache. The SortedSet sortedFilterItems is used only to sort the items from the cache, so when it's time to clean up we have the TreeSet sort the FilterItems by timestamp. Removes 1.5 * the numbers of items to make the cache smaller. For example: If cache clean size is 10, and the cache is at 15, we would remove (15 - 10) * 1.5 = 7.5 round up to 8. This way we clean the cache a bit more, and avoid having the cache cleaner having to do it frequently.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class FilterCleaner : IThreadRunnable
Visual Basic
Protected Friend Class FilterCleaner _
    Implements IThreadRunnable
Visual C++
protected public ref class FilterCleaner : IThreadRunnable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FilterManager..::..FilterCleaner

See Also

FilterManager..::..FilterCleaner Members
Lucene.Net.Search Namespace


FilterManager.FilterCleaner Members

[image] [image]

Lucene.Net Class Libraries
FilterManager..::..FilterCleaner Members
FilterManager..::..FilterCleaner Class Constructors Methods See Also Send Feedback

Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.

The FilterManager..::..FilterCleaner type exposes the following members.

Constructors

 | Name | Description
Public method | FilterManager..::..FilterCleaner | Initializes a new instance of the FilterManager..::..FilterCleaner class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterManager..::..FilterCleaner Class
Lucene.Net.Search Namespace


FilterManager.FilterCleaner Constructor

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterCleaner Constructor
FilterManager..::..FilterCleaner Class See Also Send Feedback
Initializes a new instance of the FilterManager..::..FilterCleaner class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterCleaner(
    FilterManager enclosingInstance
)
Visual Basic
Public Sub New ( _
    enclosingInstance As FilterManager _
)
Visual C++
public:
FilterCleaner(
    FilterManager^ enclosingInstance
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..FilterManager

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.FilterManager.FilterCleaner.#ctor(Lucene.Net.Search.FilterManager)"]

See Also

FilterManager..::..FilterCleaner Class
Lucene.Net.Search Namespace


FilterManager.FilterCleaner Methods

[image] [image]

Lucene.Net Class Libraries
FilterManager..::..FilterCleaner Methods
FilterManager..::..FilterCleaner Class See Also Send Feedback

The FilterManager..::..FilterCleaner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterManager..::..FilterCleaner Class
Lucene.Net.Search Namespace


Run Method

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterCleaner..::..Run Method
FilterManager..::..FilterCleaner Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FilterManager.FilterCleaner.Run"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Run()
Visual Basic
Public Overridable Sub Run
Visual C++
public:
virtual void Run()

See Also

FilterManager..::..FilterCleaner Class
Lucene.Net.Search Namespace


FilterManager.FilterItem Class

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem Class
FilterManager Class Members See Also Send Feedback
Holds the filter and the last time the filter was used, to make LRU-based cache cleaning possible. TODO: Clean this up when we switch to Java 1.5

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class FilterItem
Visual Basic
Protected Friend Class FilterItem
Visual C++
protected public ref class FilterItem

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FilterManager..::..FilterItem

See Also

FilterManager..::..FilterItem Members
Lucene.Net.Search Namespace


FilterManager.FilterItem Members

[image] [image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem Members
FilterManager..::..FilterItem Class Constructors Methods Fields Properties See Also Send Feedback

Filter caching singleton. It can be used to save filters locally for reuse. This class makes it possble to cache Filters even when using RMI, as it keeps the cache on the seaercher side of the RMI connection. Also could be used as a persistent storage for any filter as long as the filter provides a proper hashCode(), as that is used as the key in the cache. The cache is periodically cleaned up from a separate thread to ensure the cache doesn't exceed the maximum size.

The FilterManager..::..FilterItem type exposes the following members.

Constructors

 | Name | Description
Public method | FilterManager..::..FilterItem | Initializes a new instance of the FilterManager..::..FilterItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | filter |
Public field | timestamp |

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


FilterManager.FilterItem Constructor

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem Constructor
FilterManager..::..FilterItem Class See Also Send Feedback
Initializes a new instance of the FilterManager..::..FilterItem class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterItem(
    FilterManager enclosingInstance,
    Filter filter
)
Visual Basic
Public Sub New ( _
    enclosingInstance As FilterManager, _
    filter As Filter _
)
Visual C++
public:
FilterItem(
    FilterManager^ enclosingInstance,
    Filter^ filter
)

Parameters

enclosingInstance
Type: Lucene.Net.Search..::..FilterManager

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.FilterManager.FilterItem.#ctor(Lucene.Net.Search.FilterManager,Lucene.Net.Search.Filter)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.FilterManager.FilterItem.#ctor(Lucene.Net.Search.FilterManager,Lucene.Net.Search.Filter)"]

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


FilterManager.FilterItem Fields

[image] [image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem Fields
FilterManager..::..FilterItem Class See Also Send Feedback

The FilterManager..::..FilterItem type exposes the following members.

Fields

 | Name | Description
Public field | filter |
Public field | timestamp |

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


filter Field

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem..::..filter Field
FilterManager..::..FilterItem Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FilterManager.FilterItem.filter"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Filter filter
Visual Basic
Public filter As Filter
Visual C++
public:
Filter^ filter

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


timestamp Field

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem..::..timestamp Field
FilterManager..::..FilterItem Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FilterManager.FilterItem.timestamp"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long timestamp
Visual Basic
Public timestamp As Long
Visual C++
public:
long long timestamp

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


FilterManager.FilterItem Methods

[image] [image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem Methods
FilterManager..::..FilterItem Class See Also Send Feedback

The FilterManager..::..FilterItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


FilterManager.FilterItem Properties

[image] [image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem Properties
FilterManager..::..FilterItem Class See Also Send Feedback

The FilterManager..::..FilterItem type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
FilterManager..::..FilterItem..::..Enclosing_Instance Property
FilterManager..::..FilterItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.FilterManager.FilterItem.Enclosing_Instance"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FilterManager Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As FilterManager
    Get
Visual C++
public:
property FilterManager^ Enclosing_Instance {
    FilterManager^ get ();
}

See Also

FilterManager..::..FilterItem Class
Lucene.Net.Search Namespace


FloatParser Interface

[image]

Lucene.Net Class Libraries
FloatParser Interface
Members See Also Send Feedback
Interface to parse floats from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface FloatParser : Parser
Visual Basic
Public Interface FloatParser _
    Inherits Parser
Visual C++
public interface class FloatParser : Parser

See Also

FloatParser Members
Lucene.Net.Search Namespace
[!:FieldCache.GetFloats(IndexReader, String, FieldCache.FloatParser)]


FloatParser Members

[image] [image]

Lucene.Net Class Libraries
FloatParser Members
FloatParser Interface Methods See Also Send Feedback

The FloatParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseFloat | Return an float representation of this field's value.

See Also

FloatParser Interface
Lucene.Net.Search Namespace


FloatParser Methods

[image] [image]

Lucene.Net Class Libraries
FloatParser Methods
FloatParser Interface See Also Send Feedback

The FloatParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseFloat | Return an float representation of this field's value.

See Also

FloatParser Interface
Lucene.Net.Search Namespace


ParseFloat Method

[image]

Lucene.Net Class Libraries
FloatParser..::..ParseFloat Method
FloatParser Interface See Also Send Feedback
Return an float representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
float ParseFloat(
    string string_Renamed
)
Visual Basic
Function ParseFloat ( _
    string_Renamed As String _
) As Single
Visual C++
float ParseFloat(
    String^ string_Renamed
)

Parameters

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.FloatParser.ParseFloat(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FloatParser.ParseFloat(System.String)"]

See Also

FloatParser Interface
Lucene.Net.Search Namespace


FuzzyLikeThisQuery Class

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery Class
Members See Also Send Feedback
Fuzzifies ALL terms provided as strings and then picks the best n differentiating terms. In effect this mixes the behaviour of FuzzyQuery and MoreLikeThis but with special consideration of fuzzy scoring factors. This generally produces good results for queries where users may provide details in a number of fields and have no knowledge of boolean query syntax and also want a degree of fuzzy matching and a fast query. For each source term the fuzzy variants are held in a BooleanQuery with no coord factor (because we are not looking for matches on multiple variants in any one doc). Additionally, a specialized TermQuery is used for variants and does not use that variant term's IDF because this would favour rarer terms eg misspellings. Instead, all variants use the same IDF ranking (the one for the source query term) and this is factored into the variant's boost. If the source query term does not exist in the index the average IDF of the variants is used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FuzzyLikeThisQuery : Query
Visual Basic
Public Class FuzzyLikeThisQuery _
    Inherits Query
Visual C++
public ref class FuzzyLikeThisQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..FuzzyLikeThisQuery

See Also

FuzzyLikeThisQuery Members
Lucene.Net.Search Namespace


FuzzyLikeThisQuery Members

[image] [image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery Members
FuzzyLikeThisQuery Class Constructors Methods See Also Send Feedback

The FuzzyLikeThisQuery type exposes the following members.

Constructors

 | Name | Description
Public method | FuzzyLikeThisQuery | Initializes a new instance of the FuzzyLikeThisQuery class

Methods

Name | Description
Public method | AddTerms
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | IsIgnoreTF
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetIgnoreTF
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


FuzzyLikeThisQuery Constructor

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery Constructor
FuzzyLikeThisQuery Class See Also Send Feedback
Initializes a new instance of the FuzzyLikeThisQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FuzzyLikeThisQuery(
    int maxNumTerms,
    Analyzer analyzer
)
Visual Basic
Public Sub New ( _
    maxNumTerms As Integer, _
    analyzer As Analyzer _
)
Visual C++
public:
FuzzyLikeThisQuery(
    int maxNumTerms,
    Analyzer^ analyzer
)

Parameters

maxNumTerms
Type: System..::..Int32

[Missing <param name="maxNumTerms"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.#ctor(System.Int32,Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.#ctor(System.Int32,Lucene.Net.Analysis.Analyzer)"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


FuzzyLikeThisQuery Methods

[image] [image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery Methods
FuzzyLikeThisQuery Class See Also Send Feedback

The FuzzyLikeThisQuery type exposes the following members.

Methods

Name | Description
Public method | AddTerms
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | IsIgnoreTF
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetIgnoreTF
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


AddTerms Method

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..AddTerms Method
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.AddTerms(System.String,System.String,System.Single,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void AddTerms(
    string queryString,
    string fieldName,
    float minSimilarity,
    int prefixLength
)
Visual Basic
Public Sub AddTerms ( _
    queryString As String, _
    fieldName As String, _
    minSimilarity As Single, _
    prefixLength As Integer _
)
Visual C++
public:
void AddTerms(
    String^ queryString,
    String^ fieldName,
    float minSimilarity,
    int prefixLength
)

Parameters

queryString
Type: System..::..String

[Missing <param name="queryString"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.AddTerms(System.String,System.String,System.Single,System.Int32)"]

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.AddTerms(System.String,System.String,System.Single,System.Int32)"]

minSimilarity
Type: System..::..Single

[Missing <param name="minSimilarity"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.AddTerms(System.String,System.String,System.Single,System.Int32)"]

prefixLength
Type: System..::..Int32

[Missing <param name="prefixLength"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.AddTerms(System.String,System.String,System.Single,System.Int32)"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..Equals Method
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.Equals(System.Object)"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..GetHashCode Method
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.GetHashCode"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


IsIgnoreTF Method

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..IsIgnoreTF Method
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.IsIgnoreTF"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsIgnoreTF()
Visual Basic
Public Function IsIgnoreTF As Boolean
Visual C++
public:
bool IsIgnoreTF()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.IsIgnoreTF"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..Rewrite Method
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


SetIgnoreTF Method

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..SetIgnoreTF Method
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.SetIgnoreTF(System.Boolean)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetIgnoreTF(
    bool ignoreTF
)
Visual Basic
Public Sub SetIgnoreTF ( _
    ignoreTF As Boolean _
)
Visual C++
public:
void SetIgnoreTF(
    bool ignoreTF
)

Parameters

ignoreTF
Type: System..::..Boolean

[Missing <param name="ignoreTF"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.SetIgnoreTF(System.Boolean)"]

See Also

FuzzyLikeThisQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..ToString Method
FuzzyLikeThisQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

FuzzyLikeThisQuery Class
FuzzyLikeThisQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
FuzzyLikeThisQuery..::..ToString Method (String)
FuzzyLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyLikeThisQuery.ToString(System.String)"]

See Also

FuzzyLikeThisQuery Class
ToString Overload
Lucene.Net.Search Namespace


FuzzyQuery Class

[image]

Lucene.Net Class Libraries
FuzzyQuery Class
Members See Also Send Feedback
Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FuzzyQuery : MultiTermQuery
Visual Basic
<SerializableAttribute> _
Public Class FuzzyQuery _
    Inherits MultiTermQuery
Visual C++
[SerializableAttribute]
public ref class FuzzyQuery : public MultiTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..FuzzyQuery

See Also

FuzzyQuery Members
Lucene.Net.Search Namespace


FuzzyQuery Members

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery Members
FuzzyQuery Class Constructors Methods Fields See Also Send Feedback

The FuzzyQuery type exposes the following members.

Constructors

Name Description
Public method FuzzyQuery(Term)
Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.
Public method FuzzyQuery(Term, Single)
Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.
Public method FuzzyQuery(Term, Single, Int32)
Create a new FuzzyQuery that will match terms with a similarity of at least
CopyC#
minimumSimilarity
 to
CopyC#
term
. If a
CopyC#
prefixLength
 > 0 is specified, a common prefix of that length is also required.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetMinSimilarity
Returns the minimum similarity that is required for this query to match.
Public method GetPrefixLength
Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Overrides MultiTermQuery..::..GetTerm()()()().)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides MultiTermQuery..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetRewriteMethod | (Overrides MultiTermQuery..::..SetRewriteMethod(MultiTermQuery..::..RewriteMethod).)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
 | defaultMinSimilarity |
 | defaultPrefixLength |
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term |

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


FuzzyQuery Constructor

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery Constructor
FuzzyQuery Class See Also Send Feedback

Overload List

Name Description
Public method FuzzyQuery(Term)
Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.
Public method FuzzyQuery(Term, Single)
Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.
Public method FuzzyQuery(Term, Single, Int32)
Create a new FuzzyQuery that will match terms with a similarity of at least
CopyC#
minimumSimilarity
 to
CopyC#
term
. If a
CopyC#
prefixLength
 > 0 is specified, a common prefix of that length is also required.

See Also

FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace


FuzzyQuery Constructor (Term)

[image]

Lucene.Net Class Libraries
FuzzyQuery Constructor (Term)
FuzzyQuery Class See Also Send Feedback
Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, 0.5f, 0)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FuzzyQuery(
    Term term
)
Visual Basic
Public Sub New ( _
    term As Term _
)
Visual C++
public:
FuzzyQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

FuzzyQuery Class
FuzzyQuery Overload
Lucene.Net.Search Namespace


FuzzyQuery Constructor (Term, Single)

[image]

Lucene.Net Class Libraries
FuzzyQuery Constructor (Term, Single)
FuzzyQuery Class See Also Send Feedback
Calls {@link #FuzzyQuery(Term, float) FuzzyQuery(term, minimumSimilarity, 0)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FuzzyQuery(
    Term term,
    float minimumSimilarity
)
Visual Basic
Public Sub New ( _
    term As Term, _
    minimumSimilarity As Single _
)
Visual C++
public:
FuzzyQuery(
    Term^ term,
    float minimumSimilarity
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.#ctor(Lucene.Net.Index.Term,System.Single)"]

minimumSimilarity
Type: System..::..Single

[Missing <param name="minimumSimilarity"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.#ctor(Lucene.Net.Index.Term,System.Single)"]

See Also

FuzzyQuery Class
FuzzyQuery Overload
Lucene.Net.Search Namespace


FuzzyQuery Constructor (Term, Single, Int32)

[image]

Lucene.Net Class Libraries
FuzzyQuery Constructor (Term, Single, Int32)
FuzzyQuery Class See Also Send Feedback
Create a new FuzzyQuery that will match terms with a similarity of at least
CopyC#
minimumSimilarity
 to
CopyC#
term
. If a
CopyC#
prefixLength
 > 0 is specified, a common prefix of that length is also required.
or if prefixLength < 0

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FuzzyQuery(
    Term term,
    float minimumSimilarity,
    int prefixLength
)
Visual Basic
Public Sub New ( _
    term As Term, _
    minimumSimilarity As Single, _
    prefixLength As Integer _
)
Visual C++
public:
FuzzyQuery(
    Term^ term,
    float minimumSimilarity,
    int prefixLength
)

Parameters

term
Type: Lucene.Net.Index..::..Term
the term to search for
minimumSimilarity
Type: System..::..Single
a value between 0 and 1 to set the required similarity between the query term and the matching terms. For example, for a
CopyC#
minimumSimilarity
 of
CopyC#
0.5
 a term of the same length as the query term is considered similar to the query term if the edit distance between both terms is less than
CopyC#
length(term)*0.5
prefixLength
Type: System..::..Int32
length of common (non-fuzzy) prefix

See Also

FuzzyQuery Class
FuzzyQuery Overload
Lucene.Net.Search Namespace


FuzzyQuery Fields

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery Fields
FuzzyQuery Class See Also Send Feedback

The FuzzyQuery type exposes the following members.

Fields

 | Name | Description
 | defaultMinSimilarity |
 | defaultPrefixLength |
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term |

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


defaultMinSimilarity Field

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..defaultMinSimilarity Field
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FuzzyQuery.defaultMinSimilarity"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const float defaultMinSimilarity
Visual Basic
Public Const defaultMinSimilarity As Single
Visual C++
public:
literal float defaultMinSimilarity

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


defaultPrefixLength Field

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..defaultPrefixLength Field
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FuzzyQuery.defaultPrefixLength"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int defaultPrefixLength
Visual Basic
Public Const defaultPrefixLength As Integer
Visual C++
public:
literal int defaultPrefixLength

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


term Field

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..term Field
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FuzzyQuery.term"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Term term
Visual Basic
Protected Friend term As Term
Visual C++
protected public:
Term^ term

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


FuzzyQuery Methods

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery Methods
FuzzyQuery Class See Also Send Feedback

The FuzzyQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetMinSimilarity
Returns the minimum similarity that is required for this query to match.
Public method GetPrefixLength
Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Overrides MultiTermQuery..::..GetTerm()()()().)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides MultiTermQuery..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetRewriteMethod | (Overrides MultiTermQuery..::..SetRewriteMethod(MultiTermQuery..::..RewriteMethod).)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..Equals Method
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.Equals(System.Object)"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..GetEnum Method
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..GetHashCode Method
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetHashCode"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


GetMinSimilarity Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..GetMinSimilarity Method
FuzzyQuery Class See Also Send Feedback
Returns the minimum similarity that is required for this query to match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetMinSimilarity()
Visual Basic
Public Overridable Function GetMinSimilarity As Single
Visual C++
public:
virtual float GetMinSimilarity()

Return Value

float value between 0.0 and 1.0

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


GetPrefixLength Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..GetPrefixLength Method
FuzzyQuery Class See Also Send Feedback
Returns the non-fuzzy prefix length. This is the number of characters at the start of a term that must be identical (not fuzzy) to the query term if the query is to match that term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetPrefixLength()
Visual Basic
Public Overridable Function GetPrefixLength As Integer
Visual C++
public:
virtual int GetPrefixLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetPrefixLength"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..GetTerm Method
FuzzyQuery Class See Also Send Feedback
Returns the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.MultiTermQuery.GetTerm()")]
public override Term GetTerm()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.MultiTermQuery.GetTerm()")> _
Public Overrides Function GetTerm As Term
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.MultiTermQuery.GetTerm()")]
public:
virtual Term^ GetTerm() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.GetTerm"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..Rewrite Method
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


SetRewriteMethod Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..SetRewriteMethod Method
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.SetRewriteMethod(Lucene.Net.Search.MultiTermQuery.RewriteMethod)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetRewriteMethod(
    MultiTermQuery..::..RewriteMethod method
)
Visual Basic
Public Overrides Sub SetRewriteMethod ( _
    method As MultiTermQuery..::..RewriteMethod _
)
Visual C++
public:
virtual void SetRewriteMethod(
    MultiTermQuery..::..RewriteMethod^ method
) override

Parameters

method
Type: Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod

[Missing <param name="method"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.SetRewriteMethod(Lucene.Net.Search.MultiTermQuery.RewriteMethod)"]

See Also

FuzzyQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ToString Method
FuzzyQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides MultiTermQuery..::..ToString(String).)

See Also

FuzzyQuery Class
FuzzyQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ToString Method (String)
FuzzyQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.ToString(System.String)"]

See Also

FuzzyQuery Class
ToString Overload
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Class

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm Class
FuzzyQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.FuzzyQuery.ScoreTerm"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class ScoreTerm
Visual Basic
Protected Friend Class ScoreTerm
Visual C++
protected public ref class ScoreTerm

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FuzzyQuery..::..ScoreTerm

See Also

FuzzyQuery..::..ScoreTerm Members
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Members

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm Members
FuzzyQuery..::..ScoreTerm Class Constructors Methods Fields See Also Send Feedback

Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.

The FuzzyQuery..::..ScoreTerm type exposes the following members.

Constructors

 | Name | Description
Public method | FuzzyQuery..::..ScoreTerm | Initializes a new instance of the FuzzyQuery..::..ScoreTerm class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | score |
Public field | term |

See Also

FuzzyQuery..::..ScoreTerm Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Constructor

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm Constructor
FuzzyQuery..::..ScoreTerm Class See Also Send Feedback
Initializes a new instance of the FuzzyQuery..::..ScoreTerm class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ScoreTerm(
    Term term,
    float score
)
Visual Basic
Public Sub New ( _
    term As Term, _
    score As Single _
)
Visual C++
public:
ScoreTerm(
    Term^ term,
    float score
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTerm.#ctor(Lucene.Net.Index.Term,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTerm.#ctor(Lucene.Net.Index.Term,System.Single)"]

See Also

FuzzyQuery..::..ScoreTerm Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Fields

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm Fields
FuzzyQuery..::..ScoreTerm Class See Also Send Feedback

The FuzzyQuery..::..ScoreTerm type exposes the following members.

Fields

 | Name | Description
Public field | score |
Public field | term |

See Also

FuzzyQuery..::..ScoreTerm Class
Lucene.Net.Search Namespace


score Field

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm..::..score Field
FuzzyQuery..::..ScoreTerm Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FuzzyQuery.ScoreTerm.score"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float score
Visual Basic
Public score As Single
Visual C++
public:
float score

See Also

FuzzyQuery..::..ScoreTerm Class
Lucene.Net.Search Namespace


term Field

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm..::..term Field
FuzzyQuery..::..ScoreTerm Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.FuzzyQuery.ScoreTerm.term"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Term term
Visual Basic
Public term As Term
Visual C++
public:
Term^ term

See Also

FuzzyQuery..::..ScoreTerm Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTerm Methods

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTerm Methods
FuzzyQuery..::..ScoreTerm Class See Also Send Feedback

The FuzzyQuery..::..ScoreTerm type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FuzzyQuery..::..ScoreTerm Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Class

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTermQueue Class
FuzzyQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.FuzzyQuery.ScoreTermQueue"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class ScoreTermQueue : PriorityQueue
Visual Basic
Protected Friend Class ScoreTermQueue _
    Inherits PriorityQueue
Visual C++
protected public ref class ScoreTermQueue : public PriorityQueue

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..PriorityQueue
Lucene.Net.Search..::..FuzzyQuery..::..ScoreTermQueue

See Also

FuzzyQuery..::..ScoreTermQueue Members
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Members

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTermQueue Members
FuzzyQuery..::..ScoreTermQueue Class Constructors Methods Fields See Also Send Feedback

Implements the fuzzy search query. The similarity measurement is based on the Levenshtein (edit distance) algorithm. Warning: this query is not very scalable with its default prefix length of 0 - in this case, *every* term will be enumerated and cause an edit score calculation.

The FuzzyQuery..::..ScoreTermQueue type exposes the following members.

Constructors

 | Name | Description
Public method | FuzzyQuery..::..ScoreTermQueue | Initializes a new instance of the FuzzyQuery..::..ScoreTermQueue class

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
(Inherited from PriorityQueue.)
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue.)
Public method | LessThan | (Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

Fields

 | Name | Description
Protected field | heap | (Inherited from PriorityQueue.)

See Also

FuzzyQuery..::..ScoreTermQueue Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Constructor

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTermQueue Constructor
FuzzyQuery..::..ScoreTermQueue Class See Also Send Feedback
Initializes a new instance of the FuzzyQuery..::..ScoreTermQueue class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ScoreTermQueue(
    int size
)
Visual Basic
Public Sub New ( _
    size As Integer _
)
Visual C++
public:
ScoreTermQueue(
    int size
)

Parameters

size
Type: System..::..Int32

[Missing <param name="size"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTermQueue.#ctor(System.Int32)"]

See Also

FuzzyQuery..::..ScoreTermQueue Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Fields

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTermQueue Fields
FuzzyQuery..::..ScoreTermQueue Class See Also Send Feedback

The FuzzyQuery..::..ScoreTermQueue type exposes the following members.

Fields

 | Name | Description
Protected field | heap | (Inherited from PriorityQueue.)

See Also

FuzzyQuery..::..ScoreTermQueue Class
Lucene.Net.Search Namespace


FuzzyQuery.ScoreTermQueue Methods

[image] [image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTermQueue Methods
FuzzyQuery..::..ScoreTermQueue Class See Also Send Feedback

The FuzzyQuery..::..ScoreTermQueue type exposes the following members.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
(Inherited from PriorityQueue.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
(Inherited from PriorityQueue.)
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue.)
Public method | LessThan | (Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

See Also

FuzzyQuery..::..ScoreTermQueue Class
Lucene.Net.Search Namespace


LessThan Method

[image]

Lucene.Net Class Libraries
FuzzyQuery..::..ScoreTermQueue..::..LessThan Method
FuzzyQuery..::..ScoreTermQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTermQueue.LessThan(System.Object,System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool LessThan(
    Object a,
    Object b
)
Visual Basic
Public Overrides Function LessThan ( _
    a As Object, _
    b As Object _
) As Boolean
Visual C++
public:
virtual bool LessThan(
    Object^ a,
    Object^ b
) override

Parameters

a
Type: System..::..Object

[Missing <param name="a"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTermQueue.LessThan(System.Object,System.Object)"]

b
Type: System..::..Object

[Missing <param name="b"/> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTermQueue.LessThan(System.Object,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyQuery.ScoreTermQueue.LessThan(System.Object,System.Object)"]

See Also

FuzzyQuery..::..ScoreTermQueue Class
Lucene.Net.Search Namespace


FuzzyTermEnum Class

[image]

Lucene.Net Class Libraries
FuzzyTermEnum Class
Members See Also Send Feedback
Subclass of FilteredTermEnum for enumerating all terms that are similiar to the specified filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FuzzyTermEnum : FilteredTermEnum
Visual Basic
Public NotInheritable Class FuzzyTermEnum _
    Inherits FilteredTermEnum
Visual C++
public ref class FuzzyTermEnum sealed : public FilteredTermEnum

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Search..::..FilteredTermEnum
Lucene.Net.Search..::..FuzzyTermEnum

See Also

FuzzyTermEnum Members
Lucene.Net.Search Namespace


FuzzyTermEnum Members

[image] [image]

Lucene.Net Class Libraries
FuzzyTermEnum Members
FuzzyTermEnum Class Constructors Methods Fields See Also Send Feedback

The FuzzyTermEnum type exposes the following members.

Constructors

Name Description
Public method FuzzyTermEnum(IndexReader, Term)
Creates a FuzzyTermEnum with an empty prefix and a minSimilarity of 0.5f.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Public method FuzzyTermEnum(IndexReader, Term, Single)
Creates a FuzzyTermEnum with an empty prefix.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Public method FuzzyTermEnum(IndexReader, Term, Single, Int32)
Constructor for enumeration of all terms from specified
CopyC#
reader
 which share a prefix of length
CopyC#
prefixLength
 with
CopyC#
term
 and which have a fuzzy similarity >
CopyC#
minSimilarity
.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Methods

Name | Description
Public method | Close | (Overrides FilteredTermEnum..::..Close()()()().)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method TermCompare
The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.
(Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


FuzzyTermEnum Constructor

[image] [image]

Lucene.Net Class Libraries
FuzzyTermEnum Constructor
FuzzyTermEnum Class See Also Send Feedback

Overload List

Name Description
Public method FuzzyTermEnum(IndexReader, Term)
Creates a FuzzyTermEnum with an empty prefix and a minSimilarity of 0.5f.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Public method FuzzyTermEnum(IndexReader, Term, Single)
Creates a FuzzyTermEnum with an empty prefix.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Public method FuzzyTermEnum(IndexReader, Term, Single, Int32)
Constructor for enumeration of all terms from specified
CopyC#
reader
 which share a prefix of length
CopyC#
prefixLength
 with
CopyC#
term
 and which have a fuzzy similarity >
CopyC#
minSimilarity
.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

See Also

FuzzyTermEnum Class
FuzzyTermEnum Members
Lucene.Net.Search Namespace


FuzzyTermEnum Constructor (IndexReader, Term)

[image]

Lucene.Net Class Libraries
FuzzyTermEnum Constructor (IndexReader, Term)
FuzzyTermEnum Class See Also Send Feedback
Creates a FuzzyTermEnum with an empty prefix and a minSimilarity of 0.5f.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FuzzyTermEnum(
    IndexReader reader,
    Term term
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    term As Term _
)
Visual C++
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term)"]

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term)"]

See Also

FuzzyTermEnum Class
FuzzyTermEnum Overload
Lucene.Net.Search Namespace
FuzzyTermEnum..::..FuzzyTermEnum(IndexReader, Term, Single, Int32)


FuzzyTermEnum Constructor (IndexReader, Term, Single)

[image]

Lucene.Net Class Libraries
FuzzyTermEnum Constructor (IndexReader, Term, Single)
FuzzyTermEnum Class See Also Send Feedback
Creates a FuzzyTermEnum with an empty prefix.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FuzzyTermEnum(
    IndexReader reader,
    Term term,
    float minSimilarity
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    minSimilarity As Single _
)
Visual C++
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term,
    float minSimilarity
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term,System.Single)"]

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term,System.Single)"]

minSimilarity
Type: System..::..Single

[Missing <param name="minSimilarity"/> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term,System.Single)"]

See Also

FuzzyTermEnum Class
FuzzyTermEnum Overload
Lucene.Net.Search Namespace
FuzzyTermEnum..::..FuzzyTermEnum(IndexReader, Term, Single, Int32)


FuzzyTermEnum Constructor (IndexReader, Term, Single, Int32)

[image]

Lucene.Net Class Libraries
FuzzyTermEnum Constructor (IndexReader, Term, Single, Int32)
FuzzyTermEnum Class See Also Send Feedback
Constructor for enumeration of all terms from specified
CopyC#
reader
 which share a prefix of length
CopyC#
prefixLength
 with
CopyC#
term
 and which have a fuzzy similarity >
CopyC#
minSimilarity
.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FuzzyTermEnum(
    IndexReader reader,
    Term term,
    float minSimilarity,
    int prefixLength
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    minSimilarity As Single, _
    prefixLength As Integer _
)
Visual C++
public:
FuzzyTermEnum(
    IndexReader^ reader,
    Term^ term,
    float minSimilarity,
    int prefixLength
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Delivers terms.
term
Type: Lucene.Net.Index..::..Term
Pattern term.
minSimilarity
Type: System..::..Single
Minimum required similarity for terms from the reader. Default value is 0.5f.
prefixLength
Type: System..::..Int32
Length of required common prefix. Default value is 0.

See Also

FuzzyTermEnum Class
FuzzyTermEnum Overload
Lucene.Net.Search Namespace


FuzzyTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
FuzzyTermEnum Fields
FuzzyTermEnum Class See Also Send Feedback

The FuzzyTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


FuzzyTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
FuzzyTermEnum Methods
FuzzyTermEnum Class See Also Send Feedback

The FuzzyTermEnum type exposes the following members.

Methods

Name | Description
Public method | Close | (Overrides FilteredTermEnum..::..Close()()()().)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method TermCompare
The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.
(Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


Close Method

[image]

Lucene.Net Class Libraries
FuzzyTermEnum..::..Close Method
FuzzyTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.Close"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


Difference Method

[image]

Lucene.Net Class Libraries
FuzzyTermEnum..::..Difference Method
FuzzyTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.Difference"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Difference()
Visual Basic
Public Overrides Function Difference As Single
Visual C++
public:
virtual float Difference() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.Difference"]

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


EndEnum Method

[image]

Lucene.Net Class Libraries
FuzzyTermEnum..::..EndEnum Method
FuzzyTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.EndEnum"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool EndEnum()
Visual Basic
Public Overrides Function EndEnum As Boolean
Visual C++
public:
virtual bool EndEnum() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.EndEnum"]

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


TermCompare Method

[image]

Lucene.Net Class Libraries
FuzzyTermEnum..::..TermCompare Method
FuzzyTermEnum Class See Also Send Feedback
The termCompare method in FuzzyTermEnum uses Levenshtein distance to calculate the distance between the given term and the comparing term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool TermCompare(
    Term term
)
Visual Basic
Public Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Visual C++
public:
virtual bool TermCompare(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.FuzzyTermEnum.TermCompare(Lucene.Net.Index.Term)"]

See Also

FuzzyTermEnum Class
Lucene.Net.Search Namespace


Hit Class

[image]

Lucene.Net Class Libraries
Hit Class
Members See Also Send Feedback
Wrapper used by {@link HitIterator} to provide a lazily loaded hit from {@link Hits}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Use TopScoreDocCollector and TopDocs instead. Hits will be removed in Lucene 3.0.")]
public class Hit
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Use TopScoreDocCollector and TopDocs instead. Hits will be removed in Lucene 3.0.")> _
Public Class Hit
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Use TopScoreDocCollector and TopDocs instead. Hits will be removed in Lucene 3.0.")]
public ref class Hit

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Hit

See Also

Hit Members
Lucene.Net.Search Namespace


Hit Members

[image] [image]

Lucene.Net Class Libraries
Hit Members
Hit Class Methods See Also Send Feedback

The Hit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
Public method | GetBoost | Returns the boost factor for this hit on any field of the underlying document.
Public method | GetDocument | Returns document for this hit.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Returns id for this hit.
Public method | GetScore | Returns score for this hit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Prints the parameters to be used to discover the promised result. (Overrides Object..::..ToString()()()().)

See Also

Hit Class
Lucene.Net.Search Namespace


Hit Methods

[image] [image]

Lucene.Net Class Libraries
Hit Methods
Hit Class See Also Send Feedback

The Hit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.
Public method | GetBoost | Returns the boost factor for this hit on any field of the underlying document.
Public method | GetDocument | Returns document for this hit.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Returns id for this hit.
Public method | GetScore | Returns score for this hit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Prints the parameters to be used to discover the promised result. (Overrides Object..::..ToString()()()().)

See Also

Hit Class
Lucene.Net.Search Namespace


Get Method

[image]

Lucene.Net Class Libraries
Hit..::..Get Method
Hit Class See Also Send Feedback
Returns the string value of the field with the given name if any exist in this document, or null. If multiple fields exist with this name, this method returns the first value added. If only binary fields with this name exist, returns null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Get(
    string name
)
Visual Basic
Public Overridable Function Get ( _
    name As String _
) As String
Visual C++
public:
virtual String^ Get(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Search.Hit.Get(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hit.Get(System.String)"]

See Also

Hit Class
Lucene.Net.Search Namespace
Document..::..Get(String)


GetBoost Method

[image]

Lucene.Net Class Libraries
Hit..::..GetBoost Method
Hit Class See Also Send Feedback
Returns the boost factor for this hit on any field of the underlying document.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetBoost()
Visual Basic
Public Overridable Function GetBoost As Single
Visual C++
public:
virtual float GetBoost()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hit.GetBoost"]

See Also

Hit Class
Lucene.Net.Search Namespace
Document..::..GetBoost()()()()


GetDocument Method

[image]

Lucene.Net Class Libraries
Hit..::..GetDocument Method
Hit Class See Also Send Feedback
Returns document for this hit.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Document GetDocument()
Visual Basic
Public Overridable Function GetDocument As Document
Visual C++
public:
virtual Document^ GetDocument()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hit.GetDocument"]

See Also

Hit Class
Lucene.Net.Search Namespace
Hits..::..Doc(Int32)


GetId Method

[image]

Lucene.Net Class Libraries
Hit..::..GetId Method
Hit Class See Also Send Feedback
Returns id for this hit.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetId()
Visual Basic
Public Overridable Function GetId As Integer
Visual C++
public:
virtual int GetId()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hit.GetId"]

See Also

Hit Class
Lucene.Net.Search Namespace
Hits..::..Id(Int32)


GetScore Method

[image]

Lucene.Net Class Libraries
Hit..::..GetScore Method
Hit Class See Also Send Feedback
Returns score for this hit.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetScore()
Visual Basic
Public Overridable Function GetScore As Single
Visual C++
public:
virtual float GetScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hit.GetScore"]

See Also

Hit Class
Lucene.Net.Search Namespace
Hits..::..Score(Int32)


ToString Method

[image]

Lucene.Net Class Libraries
Hit..::..ToString Method
Hit Class See Also Send Feedback
Prints the parameters to be used to discover the promised result.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hit.ToString"]

See Also

Hit Class
Lucene.Net.Search Namespace


HitCollector Class

[image]

Lucene.Net Class Libraries
HitCollector Class
Members See Also Send Feedback
Lower-level search API.
HitCollectors are primarily meant to be used to implement queries, sorting and filtering. See {@link Collector} for a lower level and higher performance (on a multi-segment index) API.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use Collector instead.")]
public abstract class HitCollector
Visual Basic
<ObsoleteAttribute("Please use Collector instead.")> _
Public MustInherit Class HitCollector
Visual C++
[ObsoleteAttribute(L"Please use Collector instead.")]
public ref class HitCollector abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..HitCollector
Lucene.Net.Search..::..TimeLimitedCollector
Lucene.Net.Search..::..TopDocCollector

See Also

HitCollector Members
Lucene.Net.Search Namespace
Searcher..::..Search(Query, HitCollector)


HitCollector Members

[image] [image]

Lucene.Net Class Libraries
HitCollector Members
HitCollector Class Constructors Methods See Also Send Feedback

The HitCollector type exposes the following members.

Constructors

 | Name | Description
Protected method | HitCollector | Initializes a new instance of the HitCollector class

Methods

Name Description
Public method Collect
Called once for every document matching a query, with the document number and its raw score.

If, for example, an application wished to collect all of the hits for a query in a BitSet, then it might:

            Searcher searcher = new IndexSearcher(indexReader);
            final BitSet bits = new BitSet(indexReader.maxDoc());
            searcher.search(query, new HitCollector() {
            public void collect(int doc, float score) {
            bits.set(doc);
            }
            });

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every document number encountered. Doing so can slow searches by an order of magnitude or more.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

HitCollector Class
Lucene.Net.Search Namespace


HitCollector Constructor

[image]

Lucene.Net Class Libraries
HitCollector Constructor
HitCollector Class See Also Send Feedback
Initializes a new instance of the HitCollector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected HitCollector()
Visual Basic
Protected Sub New
Visual C++
protected:
HitCollector()

See Also

HitCollector Class
Lucene.Net.Search Namespace


HitCollector Methods

[image] [image]

Lucene.Net Class Libraries
HitCollector Methods
HitCollector Class See Also Send Feedback

The HitCollector type exposes the following members.

Methods

Name Description
Public method Collect
Called once for every document matching a query, with the document number and its raw score.

If, for example, an application wished to collect all of the hits for a query in a BitSet, then it might:

            Searcher searcher = new IndexSearcher(indexReader);
            final BitSet bits = new BitSet(indexReader.maxDoc());
            searcher.search(query, new HitCollector() {
            public void collect(int doc, float score) {
            bits.set(doc);
            }
            });

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every document number encountered. Doing so can slow searches by an order of magnitude or more.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

HitCollector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
HitCollector..::..Collect Method
HitCollector Class See Also Send Feedback
Called once for every document matching a query, with the document number and its raw score.

If, for example, an application wished to collect all of the hits for a query in a BitSet, then it might:

            Searcher searcher = new IndexSearcher(indexReader);
            final BitSet bits = new BitSet(indexReader.maxDoc());
            searcher.search(query, new HitCollector() {
            public void collect(int doc, float score) {
            bits.set(doc);
            }
            });

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every document number encountered. Doing so can slow searches by an order of magnitude or more.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Collect(
    int doc,
    float score
)
Visual Basic
Public MustOverride Sub Collect ( _
    doc As Integer, _
    score As Single _
)
Visual C++
public:
virtual void Collect(
    int doc,
    float score
) abstract

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.HitCollector.Collect(System.Int32,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.HitCollector.Collect(System.Int32,System.Single)"]

See Also

HitCollector Class
Lucene.Net.Search Namespace


HitCollectorWrapper Class

[image]

Lucene.Net Class Libraries
HitCollectorWrapper Class
Members See Also Send Feedback
Wrapper for ({@link HitCollector}) implementations, which simply re-bases the incoming docID before calling {@link HitCollector#collect}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please migrate custom HitCollectors to the new Collector class. This class will be removed when HitCollector is removed.")]
public class HitCollectorWrapper : Collector
Visual Basic
<ObsoleteAttribute("Please migrate custom HitCollectors to the new Collector class. This class will be removed when HitCollector is removed.")> _
Public Class HitCollectorWrapper _
    Inherits Collector
Visual C++
[ObsoleteAttribute(L"Please migrate custom HitCollectors to the new Collector class. This class will be removed when HitCollector is removed.")]
public ref class HitCollectorWrapper : public Collector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..HitCollectorWrapper

See Also

HitCollectorWrapper Members
Lucene.Net.Search Namespace


HitCollectorWrapper Members

[image] [image]

Lucene.Net Class Libraries
HitCollectorWrapper Members
HitCollectorWrapper Class Constructors Methods See Also Send Feedback

The HitCollectorWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | HitCollectorWrapper | Initializes a new instance of the HitCollectorWrapper class

Methods

 | Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method | Collect | (Overrides Collector..::..Collect(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


HitCollectorWrapper Constructor

[image]

Lucene.Net Class Libraries
HitCollectorWrapper Constructor
HitCollectorWrapper Class See Also Send Feedback
Initializes a new instance of the HitCollectorWrapper class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public HitCollectorWrapper(
    HitCollector collector
)
Visual Basic
Public Sub New ( _
    collector As HitCollector _
)
Visual C++
public:
HitCollectorWrapper(
    HitCollector^ collector
)

Parameters

collector
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.#ctor(Lucene.Net.Search.HitCollector)"]

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


HitCollectorWrapper Methods

[image] [image]

Lucene.Net Class Libraries
HitCollectorWrapper Methods
HitCollectorWrapper Class See Also Send Feedback

The HitCollectorWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method | Collect | (Overrides Collector..::..Collect(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


AcceptsDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
HitCollectorWrapper..::..AcceptsDocsOutOfOrder Method
HitCollectorWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.AcceptsDocsOutOfOrder"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool AcceptsDocsOutOfOrder()
Visual Basic
Public Overrides Function AcceptsDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool AcceptsDocsOutOfOrder() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.AcceptsDocsOutOfOrder"]

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
HitCollectorWrapper..::..Collect Method
HitCollectorWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.Collect(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Collect(
    int doc
)
Visual Basic
Public Overrides Sub Collect ( _
    doc As Integer _
)
Visual C++
public:
virtual void Collect(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.Collect(System.Int32)"]

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
HitCollectorWrapper..::..SetNextReader Method
HitCollectorWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
HitCollectorWrapper..::..SetScorer Method
HitCollectorWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.SetScorer(Lucene.Net.Search.Scorer)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetScorer(
    Scorer scorer
)
Visual Basic
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
) override

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.HitCollectorWrapper.SetScorer(Lucene.Net.Search.Scorer)"]

See Also

HitCollectorWrapper Class
Lucene.Net.Search Namespace


HitIterator Class

[image]

Lucene.Net Class Libraries
HitIterator Class
Members See Also Send Feedback
An iterator over {@link Hits} that provides lazy fetching of each document. {@link Hits#Iterator()} returns an instance of this class. Calls to {@link #next()} return a {@link Hit} instance.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use TopScoreDocCollector and TopDocs instead. Hits will be removed in Lucene 3.0.")]
public class HitIterator : IEnumerator
Visual Basic
<ObsoleteAttribute("Use TopScoreDocCollector and TopDocs instead. Hits will be removed in Lucene 3.0.")> _
Public Class HitIterator _
    Implements IEnumerator
Visual C++
[ObsoleteAttribute(L"Use TopScoreDocCollector and TopDocs instead. Hits will be removed in Lucene 3.0.")]
public ref class HitIterator : IEnumerator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..HitIterator

See Also

HitIterator Members
Lucene.Net.Search Namespace


HitIterator Members

[image] [image]

Lucene.Net Class Libraries
HitIterator Members
HitIterator Class Methods Properties See Also Send Feedback

The HitIterator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Returns the total number of hits.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Remove | Unsupported operation.
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Returns a {@link Hit} instance representing the next hit in {@link Hits}.

See Also

HitIterator Class
Lucene.Net.Search Namespace


HitIterator Methods

[image] [image]

Lucene.Net Class Libraries
HitIterator Methods
HitIterator Class See Also Send Feedback

The HitIterator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Returns the total number of hits.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Remove | Unsupported operation.
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HitIterator Class
Lucene.Net.Search Namespace


Length Method

[image]

Lucene.Net Class Libraries
HitIterator..::..Length Method
HitIterator Class See Also Send Feedback
Returns the total number of hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Length()
Visual Basic
Public Overridable Function Length As Integer
Visual C++
public:
virtual int Length()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.HitIterator.Length"]

See Also

HitIterator Class
Lucene.Net.Search Namespace


MoveNext Method

[image]

Lucene.Net Class Libraries
HitIterator..::..MoveNext Method
HitIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitIterator.MoveNext"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

true if current hit is less than the total number of {@link Hits}.

Implements

IEnumerator..::..MoveNext()()()()

See Also

HitIterator Class
Lucene.Net.Search Namespace


Remove Method

[image]

Lucene.Net Class Libraries
HitIterator..::..Remove Method
HitIterator Class See Also Send Feedback
Unsupported operation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Remove()
Visual Basic
Public Overridable Sub Remove
Visual C++
public:
virtual void Remove()

See Also

HitIterator Class
Lucene.Net.Search Namespace


Reset Method

[image]

Lucene.Net Class Libraries
HitIterator..::..Reset Method
HitIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitIterator.Reset"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

HitIterator Class
Lucene.Net.Search Namespace


HitIterator Properties

[image] [image]

Lucene.Net Class Libraries
HitIterator Properties
HitIterator Class See Also Send Feedback

The HitIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Returns a {@link Hit} instance representing the next hit in {@link Hits}.

See Also

HitIterator Class
Lucene.Net.Search Namespace


Current Property

[image]

Lucene.Net Class Libraries
HitIterator..::..Current Property
HitIterator Class See Also Send Feedback
Returns a {@link Hit} instance representing the next hit in {@link Hits}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Return Value

Next {@link Hit}.

Implements

IEnumerator..::..Current

See Also

HitIterator Class
Lucene.Net.Search Namespace


HitQueue Class

[image]

Lucene.Net Class Libraries
HitQueue Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.HitQueue"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class HitQueue : PriorityQueue
Visual Basic
Public NotInheritable Class HitQueue _
    Inherits PriorityQueue
Visual C++
public ref class HitQueue sealed : public PriorityQueue

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..PriorityQueue
Lucene.Net.Search..::..HitQueue

See Also

HitQueue Members
Lucene.Net.Search Namespace


HitQueue Members

[image] [image]

Lucene.Net Class Libraries
HitQueue Members
HitQueue Class Constructors Methods Fields See Also Send Feedback

The HitQueue type exposes the following members.

Constructors

Name Description
Public method HitQueue
Creates a new instance with
CopyC#
size
 elements. If
CopyC#
prePopulate
 is set to true, the queue will pre-populate itself with sentinel objects and set its {@link #Size()} to
CopyC#
size
. In that case, you should not rely on {@link #Size()} to get the number of actual elements that were added to the queue, but keep track yourself.
NOTE: in case
CopyC#
prePopulate
 is true, you should pop elements from the queue using the following code example:
            PriorityQueue pq = new HitQueue(10, true); // pre-populate.
            ScoreDoc top = pq.top();

            // Add/Update one element.
            top.score = 1.0f;
            top.doc = 0;
            top = (ScoreDoc) pq.updateTop();
            int totalHits = 1;

            // Now pop only the elements that were *truly* inserted.
            // First, pop all the sentinel elements (there are pq.size() - totalHits).
            for (int i = pq.size() - totalHits; i > 0; i--) pq.pop();

            // Now pop the truly added elements.
            ScoreDoc[] results = new ScoreDoc[totalHits];
            for (int i = totalHits - 1; i >= 0; i--) {
            results[i] = (ScoreDoc) pq.pop();
            }

NOTE: This class pre-allocate a full array of length

CopyC#
size
.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method | GetSentinelObject | (Overrides PriorityQueue..::..GetSentinelObject()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
(Inherited from PriorityQueue.)
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue.)
Public method | LessThan | (Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

Fields

 | Name | Description
Protected field | heap | (Inherited from PriorityQueue.)

See Also

HitQueue Class
Lucene.Net.Search Namespace


HitQueue Constructor

[image]

Lucene.Net Class Libraries
HitQueue Constructor
HitQueue Class See Also Send Feedback
Creates a new instance with
CopyC#
size
 elements. If
CopyC#
prePopulate
 is set to true, the queue will pre-populate itself with sentinel objects and set its {@link #Size()} to
CopyC#
size
. In that case, you should not rely on {@link #Size()} to get the number of actual elements that were added to the queue, but keep track yourself.
NOTE: in case
CopyC#
prePopulate
 is true, you should pop elements from the queue using the following code example:
            PriorityQueue pq = new HitQueue(10, true); // pre-populate.
            ScoreDoc top = pq.top();

            // Add/Update one element.
            top.score = 1.0f;
            top.doc = 0;
            top = (ScoreDoc) pq.updateTop();
            int totalHits = 1;

            // Now pop only the elements that were *truly* inserted.
            // First, pop all the sentinel elements (there are pq.size() - totalHits).
            for (int i = pq.size() - totalHits; i > 0; i--) pq.pop();

            // Now pop the truly added elements.
            ScoreDoc[] results = new ScoreDoc[totalHits];
            for (int i = totalHits - 1; i >= 0; i--) {
            results[i] = (ScoreDoc) pq.pop();
            }

NOTE: This class pre-allocate a full array of length

CopyC#
size
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public HitQueue(
    int size,
    bool prePopulate
)
Visual Basic
Public Sub New ( _
    size As Integer, _
    prePopulate As Boolean _
)
Visual C++
public:
HitQueue(
    int size,
    bool prePopulate
)

Parameters

size
Type: System..::..Int32
the requested size of this queue.
prePopulate
Type: System..::..Boolean
specifies whether to pre-populate the queue with sentinel values.

See Also

HitQueue Class
Lucene.Net.Search Namespace
HitQueue..::..GetSentinelObject()()()()


HitQueue Fields

[image] [image]

Lucene.Net Class Libraries
HitQueue Fields
HitQueue Class See Also Send Feedback

The HitQueue type exposes the following members.

Fields

 | Name | Description
Protected field | heap | (Inherited from PriorityQueue.)

See Also

HitQueue Class
Lucene.Net.Search Namespace


HitQueue Methods

[image] [image]

Lucene.Net Class Libraries
HitQueue Methods
HitQueue Class See Also Send Feedback

The HitQueue type exposes the following members.

Methods

Name | Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
(Inherited from PriorityQueue.)
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)
Public method Clear
Removes all entries from the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method | GetSentinelObject | (Overrides PriorityQueue..::..GetSentinelObject()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
(Inherited from PriorityQueue.)
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
(Inherited from PriorityQueue.)
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
(Inherited from PriorityQueue.)
Public method | LessThan | (Overrides PriorityQueue..::..LessThan(Object, Object).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
(Inherited from PriorityQueue.)
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
(Inherited from PriorityQueue.)
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
(Inherited from PriorityQueue.)
Public method Top
Returns the least element of the PriorityQueue in constant time.
(Inherited from PriorityQueue.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
(Inherited from PriorityQueue.)

See Also

HitQueue Class
Lucene.Net.Search Namespace


GetSentinelObject Method

[image]

Lucene.Net Class Libraries
HitQueue..::..GetSentinelObject Method
HitQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitQueue.GetSentinelObject"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override Object GetSentinelObject()
Visual Basic
Protected Friend Overrides Function GetSentinelObject As Object
Visual C++
protected public:
virtual Object^ GetSentinelObject() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.HitQueue.GetSentinelObject"]

See Also

HitQueue Class
Lucene.Net.Search Namespace


LessThan Method

[image]

Lucene.Net Class Libraries
HitQueue..::..LessThan Method
HitQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.HitQueue.LessThan(System.Object,System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool LessThan(
    Object a,
    Object b
)
Visual Basic
Public Overrides Function LessThan ( _
    a As Object, _
    b As Object _
) As Boolean
Visual C++
public:
virtual bool LessThan(
    Object^ a,
    Object^ b
) override

Parameters

a
Type: System..::..Object

[Missing <param name="a"/> documentation for "M:Lucene.Net.Search.HitQueue.LessThan(System.Object,System.Object)"]

b
Type: System..::..Object

[Missing <param name="b"/> documentation for "M:Lucene.Net.Search.HitQueue.LessThan(System.Object,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.HitQueue.LessThan(System.Object,System.Object)"]

See Also

HitQueue Class
Lucene.Net.Search Namespace


Hits Class

[image]

Lucene.Net Class Libraries
Hits Class
Members See Also Send Feedback
A ranked list of documents, used to hold search results.

Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using the search method that takes a {@link HitCollector}.

Note: Deleting matching documents concurrently with traversing the hits, might, when deleting hits that were not yet retrieved, decrease {@link #Length()}. In such case, {@link java.util.ConcurrentModificationException ConcurrentModificationException} is thrown when accessing hit

CopyC#
n
> current_{@link #Length()} (but
CopyC#
n
 < {@link #Length()} _at_start).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("see Searcher.Search(Query, int), Searcher.Search(Query, Filter, int) and Searcher.Search(Query, Filter, int, Sort)")]
public sealed class Hits
Visual Basic
<ObsoleteAttribute("see Searcher.Search(Query, int), Searcher.Search(Query, Filter, int) and Searcher.Search(Query, Filter, int, Sort)")> _
Public NotInheritable Class Hits
Visual C++
[ObsoleteAttribute(L"see Searcher.Search(Query, int), Searcher.Search(Query, Filter, int) and Searcher.Search(Query, Filter, int, Sort)")]
public ref class Hits sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Hits

See Also

Hits Members
Lucene.Net.Search Namespace


Hits Members

[image] [image]

Lucene.Net Class Libraries
Hits Members
Hits Class Methods Fields See Also Send Feedback

The Hits type exposes the following members.

Methods

 | Name | Description
Public method | Doc | Returns the stored fields of the nth document in this set. Documents are cached, so that repeated requests for the same element may return the same Document object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Id | Returns the id for the nth document in this set. Note that ids may change when the index changes, so you cannot rely on the id to be stable.
Public method | Iterator | Returns a {@link HitIterator} to navigate the Hits. Each item returned from {@link Iterator#next()} is a {@link Hit}. Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using a search method that takes a {@link HitCollector}.
Public method | Length | Returns the total number of hits available in this set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Score | Returns the score for the nth document in this set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | debugCheckedForDeletions |

See Also

Hits Class
Lucene.Net.Search Namespace


Hits Fields

[image] [image]

Lucene.Net Class Libraries
Hits Fields
Hits Class See Also Send Feedback

The Hits type exposes the following members.

Fields

 | Name | Description
Public field | debugCheckedForDeletions |

See Also

Hits Class
Lucene.Net.Search Namespace


debugCheckedForDeletions Field

[image]

Lucene.Net Class Libraries
Hits..::..debugCheckedForDeletions Field
Hits Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Hits.debugCheckedForDeletions"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool debugCheckedForDeletions
Visual Basic
Public debugCheckedForDeletions As Boolean
Visual C++
public:
bool debugCheckedForDeletions

See Also

Hits Class
Lucene.Net.Search Namespace


Hits Methods

[image] [image]

Lucene.Net Class Libraries
Hits Methods
Hits Class See Also Send Feedback

The Hits type exposes the following members.

Methods

 | Name | Description
Public method | Doc | Returns the stored fields of the nth document in this set. Documents are cached, so that repeated requests for the same element may return the same Document object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Id | Returns the id for the nth document in this set. Note that ids may change when the index changes, so you cannot rely on the id to be stable.
Public method | Iterator | Returns a {@link HitIterator} to navigate the Hits. Each item returned from {@link Iterator#next()} is a {@link Hit}. Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using a search method that takes a {@link HitCollector}.
Public method | Length | Returns the total number of hits available in this set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Score | Returns the score for the nth document in this set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Hits Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
Hits..::..Doc Method
Hits Class See Also Send Feedback
Returns the stored fields of the nth document in this set.

Documents are cached, so that repeated requests for the same element may return the same Document object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Document Doc(
    int n
)
Visual Basic
Public Function Doc ( _
    n As Integer _
) As Document
Visual C++
public:
Document^ Doc(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Hits.Doc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hits.Doc(System.Int32)"]

See Also

Hits Class
Lucene.Net.Search Namespace


Id Method

[image]

Lucene.Net Class Libraries
Hits..::..Id Method
Hits Class See Also Send Feedback
Returns the id for the nth document in this set. Note that ids may change when the index changes, so you cannot rely on the id to be stable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Id(
    int n
)
Visual Basic
Public Function Id ( _
    n As Integer _
) As Integer
Visual C++
public:
int Id(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Hits.Id(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hits.Id(System.Int32)"]

See Also

Hits Class
Lucene.Net.Search Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
Hits..::..Iterator Method
Hits Class See Also Send Feedback
Returns a {@link HitIterator} to navigate the Hits. Each item returned from {@link Iterator#next()} is a {@link Hit}.

Caution: Iterate only over the hits needed. Iterating over all hits is generally not desirable and may be the source of performance issues. If you need to iterate over many or all hits, consider using a search method that takes a {@link HitCollector}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IEnumerator Iterator()
Visual Basic
Public Function Iterator As IEnumerator
Visual C++
public:
IEnumerator^ Iterator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hits.Iterator"]

See Also

Hits Class
Lucene.Net.Search Namespace


Length Method

[image]

Lucene.Net Class Libraries
Hits..::..Length Method
Hits Class See Also Send Feedback
Returns the total number of hits available in this set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Length()
Visual Basic
Public Function Length As Integer
Visual C++
public:
int Length()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hits.Length"]

See Also

Hits Class
Lucene.Net.Search Namespace


Score Method

[image]

Lucene.Net Class Libraries
Hits..::..Score Method
Hits Class See Also Send Feedback
Returns the score for the nth document in this set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float Score(
    int n
)
Visual Basic
Public Function Score ( _
    n As Integer _
) As Single
Visual C++
public:
float Score(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Hits.Score(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Hits.Score(System.Int32)"]

See Also

Hits Class
Lucene.Net.Search Namespace


IndexSearcher Class

[image]

Lucene.Net Class Libraries
IndexSearcher Class
Members See Also Send Feedback
Implements search over a single IndexReader.

Applications usually need only call the inherited {@link #Search(Query)} or {@link #Search(Query,Filter)} methods. For performance reasons it is recommended to open only one IndexSearcher and use it for all of your searches.

Note that you can only access Hits from an IndexSearcher as long as it is not yet closed, otherwise an IOException will be thrown.

NOTE: {@link

CopyC#
IndexSearcher
} instances are completely thread safe, meaning multiple threads can call any of its methods, concurrently. If your application requires external synchronization, you should not synchronize on the
CopyC#
IndexSearcher
 instance; use your own (non-Lucene) objects instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class IndexSearcher : Searcher
Visual Basic
<SerializableAttribute> _
Public Class IndexSearcher _
    Inherits Searcher
Visual C++
[SerializableAttribute]
public ref class IndexSearcher : public Searcher

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Lucene.Net.Search..::..Searcher
Lucene.Net.Search..::..IndexSearcher

See Also

IndexSearcher Members
Lucene.Net.Search Namespace


IndexSearcher Members

[image] [image]

Lucene.Net Class Libraries
IndexSearcher Members
IndexSearcher Class Constructors Methods Properties See Also Send Feedback

The IndexSearcher type exposes the following members.

Constructors

 | Name | Description
Public method | IndexSearcher(String) | Obsolete. Creates a searcher searching the index in the named directory.
Public method | IndexSearcher(Directory) | Obsolete. Creates a searcher searching the index in the provided directory.
Public method | IndexSearcher(IndexReader) | Creates a searcher searching the provided index.
Public method | IndexSearcher(String, Boolean) | Obsolete. Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.
Public method | IndexSearcher(Directory, Boolean) | Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.

Methods

Name | Description
Public method Close
Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
(Overrides Searcher..::..Close()()()().)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
creates a weight for
CopyC#
query
(Inherited from Searcher.)
Public method Dispose
.NET
(Overrides Searcher..::..Dispose()()()().)
Public method | Doc(Int32) | (Overrides Searcher..::..Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher..::..Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher..::..DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher..::..Explain(Weight, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Protected method | GatherSubReaders
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexReader
Return the {@link IndexReader} this searches.
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

(Inherited from Searcher.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc | (Overrides Searcher..::..MaxDoc()()()().)
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher..::..Rewrite(Query).)
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher..::..Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher..::..Search(Weight, Filter, Int32, Sort).)
Public method Search(Weight, Filter, Int32, Sort, Boolean)
Just like {@link #Search(Weight, Filter, int, Sort)}, but you choose whether or not the fields in the returned {@link FieldDoc} instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a {@link TopFieldCollector} instance by calling {@link TopFieldCollector#create} and then pass that to {@link #Search(Weight, Filter, Collector)}.

Public method SetDefaultFieldSortScoring
By default, no scores are computed when sorting by field (using {@link #Search(Query,Filter,int,Sort)}). You can change that, per IndexSearcher instance, by calling this method. Note that this will incur a CPU cost.
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
(Inherited from Searcher.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | reader_ForNUnit |

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


IndexSearcher Constructor

[image] [image]

Lucene.Net Class Libraries
IndexSearcher Constructor
IndexSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexSearcher(String) | Obsolete. Creates a searcher searching the index in the named directory.
Public method | IndexSearcher(Directory) | Obsolete. Creates a searcher searching the index in the provided directory.
Public method | IndexSearcher(IndexReader) | Creates a searcher searching the provided index.
Public method | IndexSearcher(String, Boolean) | Obsolete. Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.
Public method | IndexSearcher(Directory, Boolean) | Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.

See Also

IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace


IndexSearcher Constructor (String)

[image]

Lucene.Net Class Libraries
IndexSearcher Constructor (String)
IndexSearcher Class See Also Send Feedback
Creates a searcher searching the index in the named directory.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexSearcher(Directory, bool) instead")]
public IndexSearcher(
    string path
)
Visual Basic
<ObsoleteAttribute("Use IndexSearcher(Directory, bool) instead")> _
Public Sub New ( _
    path As String _
)
Visual C++
[ObsoleteAttribute(L"Use IndexSearcher(Directory, bool) instead")]
public:
IndexSearcher(
    String^ path
)

Parameters

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Lucene.Net.Search.IndexSearcher.#ctor(System.String)"]

See Also

IndexSearcher Class
IndexSearcher Overload
Lucene.Net.Search Namespace


IndexSearcher Constructor (Directory)

[image]

Lucene.Net Class Libraries
IndexSearcher Constructor (Directory)
IndexSearcher Class See Also Send Feedback
Creates a searcher searching the index in the provided directory.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexSearcher(Directory, bool) instead")]
public IndexSearcher(
    Directory directory
)
Visual Basic
<ObsoleteAttribute("Use IndexSearcher(Directory, bool) instead")> _
Public Sub New ( _
    directory As Directory _
)
Visual C++
[ObsoleteAttribute(L"Use IndexSearcher(Directory, bool) instead")]
public:
IndexSearcher(
    Directory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..Directory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Search.IndexSearcher.#ctor(Lucene.Net.Store.Directory)"]

See Also

IndexSearcher Class
IndexSearcher Overload
Lucene.Net.Search Namespace


IndexSearcher Constructor (IndexReader)

[image]

Lucene.Net Class Libraries
IndexSearcher Constructor (IndexReader)
IndexSearcher Class See Also Send Feedback
Creates a searcher searching the provided index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexSearcher(
    IndexReader r
)
Visual Basic
Public Sub New ( _
    r As IndexReader _
)
Visual C++
public:
IndexSearcher(
    IndexReader^ r
)

Parameters

r
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="r"/> documentation for "M:Lucene.Net.Search.IndexSearcher.#ctor(Lucene.Net.Index.IndexReader)"]

See Also

IndexSearcher Class
IndexSearcher Overload
Lucene.Net.Search Namespace


IndexSearcher Constructor (String, Boolean)

[image]

Lucene.Net Class Libraries
IndexSearcher Constructor (String, Boolean)
IndexSearcher Class See Also Send Feedback
Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexSearcher(Directory, bool) instead")]
public IndexSearcher(
    string path,
    bool readOnly
)
Visual Basic
<ObsoleteAttribute("Use IndexSearcher(Directory, bool) instead")> _
Public Sub New ( _
    path As String, _
    readOnly As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use IndexSearcher(Directory, bool) instead")]
public:
IndexSearcher(
    String^ path,
    bool readOnly
)

Parameters

path
Type: System..::..String
directory where IndexReader will be opened
readOnly
Type: System..::..Boolean
if true, the underlying IndexReader will be opened readOnly

See Also

IndexSearcher Class
IndexSearcher Overload
Lucene.Net.Search Namespace


IndexSearcher Constructor (Directory, Boolean)

[image]

Lucene.Net Class Libraries
IndexSearcher Constructor (Directory, Boolean)
IndexSearcher Class See Also Send Feedback
Creates a searcher searching the index in the named directory. You should pass readOnly=true, since it gives much better concurrent performance, unless you intend to do write operations (delete documents or change norms) with the underlying IndexReader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexSearcher(
    Directory path,
    bool readOnly
)
Visual Basic
Public Sub New ( _
    path As Directory, _
    readOnly As Boolean _
)
Visual C++
public:
IndexSearcher(
    Directory^ path,
    bool readOnly
)

Parameters

path
Type: Lucene.Net.Store..::..Directory
directory where IndexReader will be opened
readOnly
Type: System..::..Boolean
if true, the underlying IndexReader will be opened readOnly

See Also

IndexSearcher Class
IndexSearcher Overload
Lucene.Net.Search Namespace


IndexSearcher Methods

[image] [image]

Lucene.Net Class Libraries
IndexSearcher Methods
IndexSearcher Class See Also Send Feedback

The IndexSearcher type exposes the following members.

Methods

Name | Description
Public method Close
Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.
(Overrides Searcher..::..Close()()()().)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
creates a weight for
CopyC#
query
(Inherited from Searcher.)
Public method Dispose
.NET
(Overrides Searcher..::..Dispose()()()().)
Public method | Doc(Int32) | (Overrides Searcher..::..Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher..::..Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher..::..DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher..::..Explain(Weight, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Protected method | GatherSubReaders
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetIndexReader
Return the {@link IndexReader} this searches.
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

(Inherited from Searcher.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc | (Overrides Searcher..::..MaxDoc()()()().)
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher..::..Rewrite(Query).)
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher..::..Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher..::..Search(Weight, Filter, Int32, Sort).)
Public method Search(Weight, Filter, Int32, Sort, Boolean)
Just like {@link #Search(Weight, Filter, int, Sort)}, but you choose whether or not the fields in the returned {@link FieldDoc} instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a {@link TopFieldCollector} instance by calling {@link TopFieldCollector#create} and then pass that to {@link #Search(Weight, Filter, Collector)}.

Public method SetDefaultFieldSortScoring
By default, no scores are computed when sorting by field (using {@link #Search(Query,Filter,int,Sort)}). You can change that, per IndexSearcher instance, by calling this method. Note that this will incur a CPU cost.
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
(Inherited from Searcher.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Close Method
IndexSearcher Class See Also Send Feedback
Note that the underlying IndexReader is not closed, if IndexSearcher was constructed with IndexSearcher(IndexReader r). If the IndexReader was supplied implicitly by specifying a directory, then the IndexReader gets closed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

Implements

Searchable..::..Close()()()()

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Dispose Method
IndexSearcher Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::..Dispose()()()()

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


Doc Method

[image] [image]

Lucene.Net Class Libraries
IndexSearcher..::..Doc Method
IndexSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Doc(Int32) | (Overrides Searcher..::..Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher..::..Doc(Int32, FieldSelector).)

See Also

IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace


Doc Method (Int32)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Doc Method (Int32)
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Doc(
    int i
)
Visual Basic
Public Overrides Function Doc ( _
    i As Integer _
) As Document
Visual C++
public:
virtual Document^ Doc(
    int i
) override

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32)"]

Implements

Searchable..::..Doc(Int32)

See Also

IndexSearcher Class
Doc Overload
Lucene.Net.Search Namespace


Doc Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Doc Method (Int32, FieldSelector)
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Doc(
    int i,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Doc ( _
    i As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Doc(
    int i,
    FieldSelector^ fieldSelector
) override

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Implements

Searchable..::..Doc(Int32, FieldSelector)

See Also

IndexSearcher Class
Doc Overload
Lucene.Net.Search Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..DocFreq Method
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term term
)
Visual Basic
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.IndexSearcher.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.DocFreq(Lucene.Net.Index.Term)"]

Implements

Searchable..::..DocFreq(Term)

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


Explain Method

[image] [image]

Lucene.Net Class Libraries
IndexSearcher..::..Explain Method
IndexSearcher Class See Also Send Feedback

Overload List

Name | Description
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher..::..Explain(Weight, Int32).)

See Also

IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace


Explain Method (Weight, Int32)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Explain Method (Weight, Int32)
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    Weight weight,
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Implements

Searchable..::..Explain(Weight, Int32)

See Also

IndexSearcher Class
Explain Overload
Lucene.Net.Search Namespace


GatherSubReaders Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..GatherSubReaders Method
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.GatherSubReaders(System.Collections.IList,Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void GatherSubReaders(
    IList allSubReaders,
    IndexReader r
)
Visual Basic
Protected Friend Overridable Sub GatherSubReaders ( _
    allSubReaders As IList, _
    r As IndexReader _
)
Visual C++
protected public:
virtual void GatherSubReaders(
    IList^ allSubReaders,
    IndexReader^ r
)

Parameters

allSubReaders
Type: System.Collections..::..IList

[Missing <param name="allSubReaders"/> documentation for "M:Lucene.Net.Search.IndexSearcher.GatherSubReaders(System.Collections.IList,Lucene.Net.Index.IndexReader)"]

r
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="r"/> documentation for "M:Lucene.Net.Search.IndexSearcher.GatherSubReaders(System.Collections.IList,Lucene.Net.Index.IndexReader)"]

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


GetIndexReader Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..GetIndexReader Method
IndexSearcher Class See Also Send Feedback
Return the {@link IndexReader} this searches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexReader GetIndexReader()
Visual Basic
Public Overridable Function GetIndexReader As IndexReader
Visual C++
public:
virtual IndexReader^ GetIndexReader()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.GetIndexReader"]

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..MaxDoc Method
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.MaxDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.MaxDoc"]

Implements

Searchable..::..MaxDoc()()()()

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
IndexSearcher..::..MemberwiseClone Method
IndexSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Rewrite Method
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Rewrite(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    Query original
)
Visual Basic
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    Query^ original
) override

Parameters

original
Type: Lucene.Net.Search..::..Query

[Missing <param name="original"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Rewrite(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Rewrite(Lucene.Net.Search.Query)"]

Implements

Searchable..::..Rewrite(Query)

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


Search Method

[image] [image]

Lucene.Net Class Libraries
IndexSearcher..::..Search Method
IndexSearcher Class See Also Send Feedback

Overload List

Name | Description
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher..::..Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher..::..Search(Weight, Filter, Int32, Sort).)
Public method Search(Weight, Filter, Int32, Sort, Boolean)
Just like {@link #Search(Weight, Filter, int, Sort)}, but you choose whether or not the fields in the returned {@link FieldDoc} instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a {@link TopFieldCollector} instance by calling {@link TopFieldCollector#create} and then pass that to {@link #Search(Weight, Filter, Collector)}.

See Also

IndexSearcher Class
IndexSearcher Members
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Collector)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Search Method (Weight, Filter, Collector)
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Visual Basic
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Visual C++
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

collector
Type: Lucene.Net.Search..::..Collector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

Implements

Searchable..::..Search(Weight, Filter, Collector)

See Also

IndexSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Search Method (Weight, Filter, Int32)
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
Visual Basic
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

nDocs
Type: System..::..Int32

[Missing <param name="nDocs"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Implements

Searchable..::..Search(Weight, Filter, Int32)

See Also

IndexSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32, Sort)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Search Method (Weight, Filter, Int32, Sort)
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort
)
Visual Basic
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort _
) As TopFieldDocs
Visual C++
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

nDocs
Type: System..::..Int32

[Missing <param name="nDocs"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Implements

Searchable..::..Search(Weight, Filter, Int32, Sort)

See Also

IndexSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32, Sort, Boolean)

[image]

Lucene.Net Class Libraries
IndexSearcher..::..Search Method (Weight, Filter, Int32, Sort, Boolean)
IndexSearcher Class See Also Send Feedback
Just like {@link #Search(Weight, Filter, int, Sort)}, but you choose whether or not the fields in the returned {@link FieldDoc} instances should be set by specifying fillFields.

NOTE: this does not compute scores by default. If you need scores, create a {@link TopFieldCollector} instance by calling {@link TopFieldCollector#create} and then pass that to {@link #Search(Weight, Filter, Collector)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort,
    bool fillFields
)
Visual Basic
Public Overridable Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort, _
    fillFields As Boolean _
) As TopFieldDocs
Visual C++
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort,
    bool fillFields
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort,System.Boolean)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort,System.Boolean)"]

nDocs
Type: System..::..Int32

[Missing <param name="nDocs"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort,System.Boolean)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort,System.Boolean)"]

fillFields
Type: System..::..Boolean

[Missing <param name="fillFields"/> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IndexSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort,System.Boolean)"]

See Also

IndexSearcher Class
Search Overload
Lucene.Net.Search Namespace


SetDefaultFieldSortScoring Method

[image]

Lucene.Net Class Libraries
IndexSearcher..::..SetDefaultFieldSortScoring Method
IndexSearcher Class See Also Send Feedback
By default, no scores are computed when sorting by field (using {@link #Search(Query,Filter,int,Sort)}). You can change that, per IndexSearcher instance, by calling this method. Note that this will incur a CPU cost.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDefaultFieldSortScoring(
    bool doTrackScores,
    bool doMaxScore
)
Visual Basic
Public Overridable Sub SetDefaultFieldSortScoring ( _
    doTrackScores As Boolean, _
    doMaxScore As Boolean _
)
Visual C++
public:
virtual void SetDefaultFieldSortScoring(
    bool doTrackScores,
    bool doMaxScore
)

Parameters

doTrackScores
Type: System..::..Boolean
If true, then scores are returned for every matching document in {@link TopFieldDocs}.
doMaxScore
Type: System..::..Boolean
If true, then the max score for all matching docs is computed.

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


IndexSearcher Properties

[image] [image]

Lucene.Net Class Libraries
IndexSearcher Properties
IndexSearcher Class See Also Send Feedback

The IndexSearcher type exposes the following members.

Properties

 | Name | Description
Public property | reader_ForNUnit |

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


reader_ForNUnit Property

[image]

Lucene.Net Class Libraries
IndexSearcher..::..reader_ForNUnit Property
IndexSearcher Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.IndexSearcher.reader_ForNUnit"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IndexReader reader_ForNUnit { get; }
Visual Basic
Public ReadOnly Property reader_ForNUnit As IndexReader
    Get
Visual C++
public:
property IndexReader^ reader_ForNUnit {
    IndexReader^ get ();
}

See Also

IndexSearcher Class
Lucene.Net.Search Namespace


IntParser Interface

[image]

Lucene.Net Class Libraries
IntParser Interface
Members See Also Send Feedback
Interface to parse ints from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface IntParser : Parser
Visual Basic
Public Interface IntParser _
    Inherits Parser
Visual C++
public interface class IntParser : Parser

See Also

IntParser Members
Lucene.Net.Search Namespace
[!:FieldCache.GetInts(IndexReader, String, FieldCache.IntParser)]


IntParser Members

[image] [image]

Lucene.Net Class Libraries
IntParser Members
IntParser Interface Methods See Also Send Feedback

The IntParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseInt | Return an integer representation of this field's value.

See Also

IntParser Interface
Lucene.Net.Search Namespace


IntParser Methods

[image] [image]

Lucene.Net Class Libraries
IntParser Methods
IntParser Interface See Also Send Feedback

The IntParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseInt | Return an integer representation of this field's value.

See Also

IntParser Interface
Lucene.Net.Search Namespace


ParseInt Method

[image]

Lucene.Net Class Libraries
IntParser..::..ParseInt Method
IntParser Interface See Also Send Feedback
Return an integer representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int ParseInt(
    string string_Renamed
)
Visual Basic
Function ParseInt ( _
    string_Renamed As String _
) As Integer
Visual C++
int ParseInt(
    String^ string_Renamed
)

Parameters

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.IntParser.ParseInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.IntParser.ParseInt(System.String)"]

See Also

IntParser Interface
Lucene.Net.Search Namespace


LongParser Interface

[image]

Lucene.Net Class Libraries
LongParser Interface
Members See Also Send Feedback
Interface to parse long from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use FieldCache.LongParser, this will be removed in Lucene 3.0")]
public interface LongParser : Parser
Visual Basic
<ObsoleteAttribute("Use FieldCache.LongParser, this will be removed in Lucene 3.0")> _
Public Interface LongParser _
    Inherits Parser
Visual C++
[ObsoleteAttribute(L"Use FieldCache.LongParser, this will be removed in Lucene 3.0")]
public interface class LongParser : Parser

See Also

LongParser Members
Lucene.Net.Search Namespace
[!:FieldCache.GetLongs(IndexReader, String, FieldCache.LongParser)]


LongParser Members

[image] [image]

Lucene.Net Class Libraries
LongParser Members
LongParser Interface Methods See Also Send Feedback

The LongParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseLong | Return an long representation of this field's value.

See Also

LongParser Interface
Lucene.Net.Search Namespace


LongParser Methods

[image] [image]

Lucene.Net Class Libraries
LongParser Methods
LongParser Interface See Also Send Feedback

The LongParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseLong | Return an long representation of this field's value.

See Also

LongParser Interface
Lucene.Net.Search Namespace


ParseLong Method

[image]

Lucene.Net Class Libraries
LongParser..::..ParseLong Method
LongParser Interface See Also Send Feedback
Return an long representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
long ParseLong(
    string string_Renamed
)
Visual Basic
Function ParseLong ( _
    string_Renamed As String _
) As Long
Visual C++
long long ParseLong(
    String^ string_Renamed
)

Parameters

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.LongParser.ParseLong(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.LongParser.ParseLong(System.String)"]

See Also

LongParser Interface
Lucene.Net.Search Namespace


MatchAllDocsQuery Class

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery Class
Members See Also Send Feedback
A query that matches all documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MatchAllDocsQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class MatchAllDocsQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class MatchAllDocsQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MatchAllDocsQuery

See Also

MatchAllDocsQuery Members
Lucene.Net.Search Namespace


MatchAllDocsQuery Members

[image] [image]

Lucene.Net Class Libraries
MatchAllDocsQuery Members
MatchAllDocsQuery Class Constructors Methods See Also Send Feedback

The MatchAllDocsQuery type exposes the following members.

Constructors

 | Name | Description
Public method | MatchAllDocsQuery()()()() | Initializes a new instance of the MatchAllDocsQuery class
Public method | MatchAllDocsQuery(String) | Initializes a new instance of the MatchAllDocsQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MatchAllDocsQuery Class
Lucene.Net.Search Namespace


MatchAllDocsQuery Constructor

[image] [image]

Lucene.Net Class Libraries
MatchAllDocsQuery Constructor
MatchAllDocsQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MatchAllDocsQuery()()()() | Initializes a new instance of the MatchAllDocsQuery class
Public method | MatchAllDocsQuery(String) | Initializes a new instance of the MatchAllDocsQuery class

See Also

MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace


MatchAllDocsQuery Constructor

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery Constructor
MatchAllDocsQuery Class See Also Send Feedback
Initializes a new instance of the MatchAllDocsQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MatchAllDocsQuery()
Visual Basic
Public Sub New
Visual C++
public:
MatchAllDocsQuery()

See Also

MatchAllDocsQuery Class
MatchAllDocsQuery Overload
Lucene.Net.Search Namespace


MatchAllDocsQuery Constructor (String)

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery Constructor (String)
MatchAllDocsQuery Class See Also Send Feedback
Initializes a new instance of the MatchAllDocsQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MatchAllDocsQuery(
    string normsField
)
Visual Basic
Public Sub New ( _
    normsField As String _
)
Visual C++
public:
MatchAllDocsQuery(
    String^ normsField
)

Parameters

normsField
Type: System..::..String
Field used for normalization factor (document boost). Null if nothing.

See Also

MatchAllDocsQuery Class
MatchAllDocsQuery Overload
Lucene.Net.Search Namespace


MatchAllDocsQuery Methods

[image] [image]

Lucene.Net Class Libraries
MatchAllDocsQuery Methods
MatchAllDocsQuery Class See Also Send Feedback

The MatchAllDocsQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MatchAllDocsQuery Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery..::..CreateWeight Method
MatchAllDocsQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

MatchAllDocsQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery..::..Equals Method
MatchAllDocsQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.Equals(System.Object)"]

See Also

MatchAllDocsQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery..::..ExtractTerms Method
MatchAllDocsQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

MatchAllDocsQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery..::..GetHashCode Method
MatchAllDocsQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.GetHashCode"]

See Also

MatchAllDocsQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
MatchAllDocsQuery..::..ToString Method
MatchAllDocsQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

MatchAllDocsQuery Class
MatchAllDocsQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
MatchAllDocsQuery..::..ToString Method (String)
MatchAllDocsQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MatchAllDocsQuery.ToString(System.String)"]

See Also

MatchAllDocsQuery Class
ToString Overload
Lucene.Net.Search Namespace


MultiPhraseQuery Class

[image]

Lucene.Net Class Libraries
MultiPhraseQuery Class
Members See Also Send Feedback
MultiPhraseQuery is a generalized version of PhraseQuery, with an added method {@link #Add(Term[])}. To use this class, to search for the phrase "Microsoft app*" first use add(Term) on the term "Microsoft", then find all terms that have "app" as prefix using IndexReader.terms(Term), and use MultiPhraseQuery.add(Term[] terms) to add them to the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MultiPhraseQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class MultiPhraseQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class MultiPhraseQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiPhraseQuery

See Also

MultiPhraseQuery Members
Lucene.Net.Search Namespace


MultiPhraseQuery Members

[image] [image]

Lucene.Net Class Libraries
MultiPhraseQuery Members
MultiPhraseQuery Class Constructors Methods See Also Send Feedback

The MultiPhraseQuery type exposes the following members.

Constructors

 | Name | Description
Public method | MultiPhraseQuery | Initializes a new instance of the MultiPhraseQuery class

Methods

Name | Description
Public method Add(Term)
Add a single term at the next position in the phrase.
Public method Add(array<Term>[]()[][])
Add multiple terms at the next position in the phrase. Any of the terms may match.
Public method Add(array<Term>[]()[][], Int32)
Allows to specify the relative position of terms within the phrase.
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetPositions
Returns the relative positions of terms in this phrase.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Sets the phrase slop for this query.
Public method GetTermArrays
Returns a List<Term[]> of the terms in the multiphrase. Do not modify the List or its contents.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetSlop
Sets the phrase slop for this query.
TermEquals
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


MultiPhraseQuery Constructor

[image]

Lucene.Net Class Libraries
MultiPhraseQuery Constructor
MultiPhraseQuery Class See Also Send Feedback
Initializes a new instance of the MultiPhraseQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiPhraseQuery()
Visual Basic
Public Sub New
Visual C++
public:
MultiPhraseQuery()

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


MultiPhraseQuery Methods

[image] [image]

Lucene.Net Class Libraries
MultiPhraseQuery Methods
MultiPhraseQuery Class See Also Send Feedback

The MultiPhraseQuery type exposes the following members.

Methods

Name | Description
Public method Add(Term)
Add a single term at the next position in the phrase.
Public method Add(array<Term>[]()[][])
Add multiple terms at the next position in the phrase. Any of the terms may match.
Public method Add(array<Term>[]()[][], Int32)
Allows to specify the relative position of terms within the phrase.
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetPositions
Returns the relative positions of terms in this phrase.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Sets the phrase slop for this query.
Public method GetTermArrays
Returns a List<Term[]> of the terms in the multiphrase. Do not modify the List or its contents.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetSlop
Sets the phrase slop for this query.
TermEquals
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..Add Method
MultiPhraseQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Term) | Add a single term at the next position in the phrase.
Public method | Add(array<Term>[]()[][]) | Add multiple terms at the next position in the phrase. Any of the terms may match.
Public method | Add(array<Term>[]()[][], Int32) | Allows to specify the relative position of terms within the phrase.

See Also

MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace


Add Method (Term)

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..Add Method (Term)
MultiPhraseQuery Class See Also Send Feedback
Add a single term at the next position in the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Term term
)
Visual Basic
Public Overridable Sub Add ( _
    term As Term _
)
Visual C++
public:
virtual void Add(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Add(Lucene.Net.Index.Term)"]

See Also

MultiPhraseQuery Class
Add Overload
Lucene.Net.Search Namespace
[!:PhraseQuery.add(Term)]


Add Method (Term[])

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..Add Method (array<Term>[]()[][])
MultiPhraseQuery Class See Also Send Feedback
Add multiple terms at the next position in the phrase. Any of the terms may match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Term[] terms
)
Visual Basic
Public Overridable Sub Add ( _
    terms As Term() _
)
Visual C++
public:
virtual void Add(
    array<Term^>^ terms
)

Parameters

terms
Type: array< Lucene.Net.Index..::..Term >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Add(Lucene.Net.Index.Term[])"]

See Also

MultiPhraseQuery Class
Add Overload
Lucene.Net.Search Namespace
[!:PhraseQuery.add(Term)]


Add Method (Term[], Int32)

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..Add Method (array<Term>[]()[][], Int32)
MultiPhraseQuery Class See Also Send Feedback
Allows to specify the relative position of terms within the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Term[] terms,
    int position
)
Visual Basic
Public Overridable Sub Add ( _
    terms As Term(), _
    position As Integer _
)
Visual C++
public:
virtual void Add(
    array<Term^>^ terms,
    int position
)

Parameters

terms
Type: array< Lucene.Net.Index..::..Term >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Add(Lucene.Net.Index.Term[],System.Int32)"]

position
Type: System..::..Int32

[Missing <param name="position"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Add(Lucene.Net.Index.Term[],System.Int32)"]

See Also

MultiPhraseQuery Class
Add Overload
Lucene.Net.Search Namespace
PhraseQuery..::..Add(Term, Int32)


CreateWeight Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..CreateWeight Method
MultiPhraseQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..Equals Method
MultiPhraseQuery Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Equals(System.Object)"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..ExtractTerms Method
MultiPhraseQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..GetHashCode Method
MultiPhraseQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.GetHashCode"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


GetPositions Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..GetPositions Method
MultiPhraseQuery Class See Also Send Feedback
Returns the relative positions of terms in this phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int[] GetPositions()
Visual Basic
Public Overridable Function GetPositions As Integer()
Visual C++
public:
virtual array<int>^ GetPositions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.GetPositions"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


GetSlop Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..GetSlop Method
MultiPhraseQuery Class See Also Send Feedback
Sets the phrase slop for this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetSlop()
Visual Basic
Public Overridable Function GetSlop As Integer
Visual C++
public:
virtual int GetSlop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.GetSlop"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace
PhraseQuery..::..GetSlop()()()()


GetTermArrays Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..GetTermArrays Method
MultiPhraseQuery Class See Also Send Feedback
Returns a List<Term[]> of the terms in the multiphrase. Do not modify the List or its contents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList GetTermArrays()
Visual Basic
Public Overridable Function GetTermArrays As IList
Visual C++
public:
virtual IList^ GetTermArrays()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.GetTermArrays"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..Rewrite Method
MultiPhraseQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


SetSlop Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..SetSlop Method
MultiPhraseQuery Class See Also Send Feedback
Sets the phrase slop for this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSlop(
    int s
)
Visual Basic
Public Overridable Sub SetSlop ( _
    s As Integer _
)
Visual C++
public:
virtual void SetSlop(
    int s
)

Parameters

s
Type: System..::..Int32

[Missing <param name="s"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.SetSlop(System.Int32)"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace
PhraseQuery..::..SetSlop(Int32)


TermEquals Method

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..TermEquals Method
MultiPhraseQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.TermEquals(System.Array,System.Array)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool TermEquals(
    Array array1,
    Array array2
)
Visual Basic
Public Shared Function TermEquals ( _
    array1 As Array, _
    array2 As Array _
) As Boolean
Visual C++
public:
static bool TermEquals(
    Array^ array1,
    Array^ array2
)

Parameters

array1
Type: System..::..Array

[Missing <param name="array1"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.TermEquals(System.Array,System.Array)"]

array2
Type: System..::..Array

[Missing <param name="array2"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.TermEquals(System.Array,System.Array)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.TermEquals(System.Array,System.Array)"]

See Also

MultiPhraseQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..ToString Method
MultiPhraseQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

MultiPhraseQuery Class
MultiPhraseQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
MultiPhraseQuery..::..ToString Method (String)
MultiPhraseQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string f
)
Visual Basic
Public Overrides Function ToString ( _
    f As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ f
) override

Parameters

f
Type: System..::..String

[Missing <param name="f"/> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiPhraseQuery.ToString(System.String)"]

See Also

MultiPhraseQuery Class
ToString Overload
Lucene.Net.Search Namespace


MultiSearcher Class

[image]

Lucene.Net Class Libraries
MultiSearcher Class
Members See Also Send Feedback
Implements search over a set of
CopyC#
Searchables
.

Applications usually need only call the inherited {@link #Search(Query)} or {@link #Search(Query,Filter)} methods.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MultiSearcher : Searcher
Visual Basic
Public Class MultiSearcher _
    Inherits Searcher
Visual C++
public ref class MultiSearcher : public Searcher

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Lucene.Net.Search..::..Searcher
Lucene.Net.Search..::..MultiSearcher
Lucene.Net.Search..::..ParallelMultiSearcher

See Also

MultiSearcher Members
Lucene.Net.Search Namespace


MultiSearcher Members

[image] [image]

Lucene.Net Class Libraries
MultiSearcher Members
MultiSearcher Class Constructors Methods See Also Send Feedback

The MultiSearcher type exposes the following members.

Constructors

 | Name | Description
Public method | MultiSearcher | Creates a searcher which searches searchers.

Methods

Name | Description
Public method | Close | (Overrides Searcher..::..Close()()()().)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Overrides Searcher..::..CreateWeight(Query).)
Public method Dispose
.NET
(Overrides Searcher..::..Dispose()()()().)
Public method | Doc(Int32) | (Overrides Searcher..::..Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher..::..Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher..::..DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher..::..Explain(Weight, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSearchables
Return the array of {@link Searchable}s this searches.
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

(Inherited from Searcher.)
Protected method | GetStarts
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc | (Overrides Searcher..::..MaxDoc()()()().)
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher..::..Rewrite(Query).)
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher..::..Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher..::..Search(Weight, Filter, Int32, Sort).)
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
(Inherited from Searcher.)
Public method SubDoc
Returns the document number of document
CopyC#
n
 within its sub-index.
Public method SubSearcher
Returns index of the searcher for document
CopyC#
n
 in the array used to construct this searcher.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


MultiSearcher Constructor

[image]

Lucene.Net Class Libraries
MultiSearcher Constructor
MultiSearcher Class See Also Send Feedback
Creates a searcher which searches searchers.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiSearcher(
    Searchable[] searchables
)
Visual Basic
Public Sub New ( _
    searchables As Searchable() _
)
Visual C++
public:
MultiSearcher(
    array<Searchable^>^ searchables
)

Parameters

searchables
Type: array< Lucene.Net.Search..::..Searchable >[]()[][]

[Missing <param name="searchables"/> documentation for "M:Lucene.Net.Search.MultiSearcher.#ctor(Lucene.Net.Search.Searchable[])"]

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


MultiSearcher Methods

[image] [image]

Lucene.Net Class Libraries
MultiSearcher Methods
MultiSearcher Class See Also Send Feedback

The MultiSearcher type exposes the following members.

Methods

Name | Description
Public method | Close | (Overrides Searcher..::..Close()()()().)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Overrides Searcher..::..CreateWeight(Query).)
Public method Dispose
.NET
(Overrides Searcher..::..Dispose()()()().)
Public method | Doc(Int32) | (Overrides Searcher..::..Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher..::..Doc(Int32, FieldSelector).)
Public method | DocFreq | (Overrides Searcher..::..DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher..::..Explain(Weight, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSearchables
Return the array of {@link Searchable}s this searches.
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

(Inherited from Searcher.)
Protected method | GetStarts
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc | (Overrides Searcher..::..MaxDoc()()()().)
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite | (Overrides Searcher..::..Rewrite(Query).)
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher..::..Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher..::..Search(Weight, Filter, Int32, Sort).)
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
(Inherited from Searcher.)
Public method SubDoc
Returns the document number of document
CopyC#
n
 within its sub-index.
Public method SubSearcher
Returns index of the searcher for document
CopyC#
n
 in the array used to construct this searcher.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


Close Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Close Method
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Close"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

Implements

Searchable..::..Close()()()()

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..CreateWeight Method
MultiSearcher Class See Also Send Feedback
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Query original
)
Visual Basic
Public Overrides Function CreateWeight ( _
    original As Query _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Query^ original
) override

Parameters

original
Type: Lucene.Net.Search..::..Query

[Missing <param name="original"/> documentation for "M:Lucene.Net.Search.MultiSearcher.CreateWeight(Lucene.Net.Search.Query)"]

Return Value

rewritten queries

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Dispose Method
MultiSearcher Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::..Dispose()()()()

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


Doc Method

[image] [image]

Lucene.Net Class Libraries
MultiSearcher..::..Doc Method
MultiSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Doc(Int32) | (Overrides Searcher..::..Doc(Int32).)
Public method | Doc(Int32, FieldSelector) | (Overrides Searcher..::..Doc(Int32, FieldSelector).)

See Also

MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace


Doc Method (Int32)

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Doc Method (Int32)
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Doc(
    int n
)
Visual Basic
Public Overrides Function Doc ( _
    n As Integer _
) As Document
Visual C++
public:
virtual Document^ Doc(
    int n
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32)"]

Implements

Searchable..::..Doc(Int32)

See Also

MultiSearcher Class
Doc Overload
Lucene.Net.Search Namespace


Doc Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Doc Method (Int32, FieldSelector)
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Document Doc(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Public Overrides Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
) override

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="fieldSelector"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Implements

Searchable..::..Doc(Int32, FieldSelector)

See Also

MultiSearcher Class
Doc Overload
Lucene.Net.Search Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..DocFreq Method
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term term
)
Visual Basic
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.MultiSearcher.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.DocFreq(Lucene.Net.Index.Term)"]

Implements

Searchable..::..DocFreq(Term)

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


Explain Method

[image] [image]

Lucene.Net Class Libraries
MultiSearcher..::..Explain Method
MultiSearcher Class See Also Send Feedback

Overload List

Name | Description
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Overrides Searcher..::..Explain(Weight, Int32).)

See Also

MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace


Explain Method (Weight, Int32)

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Explain Method (Weight, Int32)
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    Weight weight,
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Implements

Searchable..::..Explain(Weight, Int32)

See Also

MultiSearcher Class
Explain Overload
Lucene.Net.Search Namespace


GetSearchables Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..GetSearchables Method
MultiSearcher Class See Also Send Feedback
Return the array of {@link Searchable}s this searches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Searchable[] GetSearchables()
Visual Basic
Public Overridable Function GetSearchables As Searchable()
Visual C++
public:
virtual array<Searchable^>^ GetSearchables()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.GetSearchables"]

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


GetStarts Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..GetStarts Method
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.GetStarts"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual int[] GetStarts()
Visual Basic
Protected Friend Overridable Function GetStarts As Integer()
Visual C++
protected public:
virtual array<int>^ GetStarts()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.GetStarts"]

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..MaxDoc Method
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.MaxDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int MaxDoc()
Visual Basic
Public Overrides Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.MaxDoc"]

Implements

Searchable..::..MaxDoc()()()()

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
MultiSearcher..::..MemberwiseClone Method
MultiSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Rewrite Method
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Rewrite(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    Query original
)
Visual Basic
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    Query^ original
) override

Parameters

original
Type: Lucene.Net.Search..::..Query

[Missing <param name="original"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Rewrite(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.Rewrite(Lucene.Net.Search.Query)"]

Implements

Searchable..::..Rewrite(Query)

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


Search Method

[image] [image]

Lucene.Net Class Libraries
MultiSearcher..::..Search Method
MultiSearcher Class See Also Send Feedback

Overload List

Name | Description
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method | Search(Weight, Filter, Collector) | (Overrides Searcher..::..Search(Weight, Filter, Collector).)
Public method | Search(Weight, Filter, Int32) | (Overrides Searcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method | Search(Weight, Filter, Int32, Sort) | (Overrides Searcher..::..Search(Weight, Filter, Int32, Sort).)

See Also

MultiSearcher Class
MultiSearcher Members
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Collector)

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Search Method (Weight, Filter, Collector)
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Visual Basic
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Visual C++
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

collector
Type: Lucene.Net.Search..::..Collector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

Implements

Searchable..::..Search(Weight, Filter, Collector)

See Also

MultiSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32)

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Search Method (Weight, Filter, Int32)
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
Visual Basic
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

nDocs
Type: System..::..Int32

[Missing <param name="nDocs"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Implements

Searchable..::..Search(Weight, Filter, Int32)

See Also

MultiSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32, Sort)

[image]

Lucene.Net Class Libraries
MultiSearcher..::..Search Method (Weight, Filter, Int32, Sort)
MultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
Visual Basic
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Visual C++
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Implements

Searchable..::..Search(Weight, Filter, Int32, Sort)

See Also

MultiSearcher Class
Search Overload
Lucene.Net.Search Namespace


SubDoc Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..SubDoc Method
MultiSearcher Class See Also Send Feedback
Returns the document number of document
CopyC#
n
 within its sub-index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int SubDoc(
    int n
)
Visual Basic
Public Overridable Function SubDoc ( _
    n As Integer _
) As Integer
Visual C++
public:
virtual int SubDoc(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.MultiSearcher.SubDoc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.SubDoc(System.Int32)"]

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


SubSearcher Method

[image]

Lucene.Net Class Libraries
MultiSearcher..::..SubSearcher Method
MultiSearcher Class See Also Send Feedback
Returns index of the searcher for document
CopyC#
n
 in the array used to construct this searcher.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int SubSearcher(
    int n
)
Visual Basic
Public Overridable Function SubSearcher ( _
    n As Integer _
) As Integer
Visual C++
public:
virtual int SubSearcher(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.MultiSearcher.SubSearcher(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiSearcher.SubSearcher(System.Int32)"]

See Also

MultiSearcher Class
Lucene.Net.Search Namespace


MultiTermQuery Class

[image]

Lucene.Net Class Libraries
MultiTermQuery Class
Members See Also Send Feedback
An abstract {@link Query} that matches documents containing a subset of terms provided by a {@link FilteredTermEnum} enumeration.

This query cannot be used directly; you must subclass it and define {@link #getEnum} to provide a {@link FilteredTermEnum} that iterates through the terms to be matched.

NOTE: if {@link #setRewriteMethod} is either {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} or {@link #SCORING_BOOLEAN_QUERY_REWRITE}, you may encounter a {@link BooleanQuery.TooManyClauses} exception during searching, which happens when the number of terms to be searched exceeds {@link BooleanQuery#GetMaxClauseCount()}. Setting {@link #setRewriteMethod} to {@link #CONSTANT_SCORE_FILTER_REWRITE} prevents this.

The recommended rewrite method is {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}: it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that {@link QueryParser} produces MultiTermQueries using {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} by default.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class MultiTermQuery : Query
Visual Basic
<SerializableAttribute> _
Public MustInherit Class MultiTermQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class MultiTermQuery abstract : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..FuzzyQuery
Lucene.Net.Search..::..NumericRangeQuery
Lucene.Net.Search..::..PrefixQuery
Lucene.Net.Search.Regex..::..RegexQuery
Lucene.Net.Search..::..TermRangeQuery
Lucene.Net.Search..::..WildcardQuery

See Also

MultiTermQuery Members
Lucene.Net.Search Namespace


MultiTermQuery Members

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery Members
MultiTermQuery Class Constructors Methods Fields See Also Send Feedback

The MultiTermQuery type exposes the following members.

Constructors

Name Description
Public method MultiTermQuery()()()()
Constructs a query matching terms that cannot be represented with a single Term.
Public method MultiTermQuery(Term) Obsolete.
Constructs a query for terms matching
CopyC#
term
.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetEnum
Construct the enumeration to be used, expanding the pattern term.
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method | GetRewriteMethod
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
 | CONSTANT_SCORE_AUTO_REWRITE_DEFAULT | Read-only default instance of {@link ConstantScoreAutoRewrite}, with {@link ConstantScoreAutoRewrite#setTermCountCutoff} set to {@link ConstantScoreAutoRewrite#DEFAULT_TERM_COUNT_CUTOFF} and {@link ConstantScoreAutoRewrite#setDocCountPercent} set to {@link ConstantScoreAutoRewrite#DEFAULT_DOC_COUNT_PERCENT}. Note that you cannot alter the configuration of this instance; you'll need to create a private instance instead.
 | CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE | Like {@link #SCORING_BOOLEAN_QUERY_REWRITE} except scores are not computed. Instead, each matching document receives a constant score equal to the query's boost. NOTE: This rewrite method will hit {@link BooleanQuery.TooManyClauses} if the number of terms exceeds {@link BooleanQuery#getMaxClauseCount}.
 | CONSTANT_SCORE_FILTER_REWRITE | A rewrite method that first creates a private Filter, by visiting each term in sequence and marking all docs for that term. Matching documents are assigned a constant score equal to the query's boost. This method is faster than the BooleanQuery rewrite methods when the number of matched terms or matched documents is non-trivial. Also, it will never hit an errant {@link BooleanQuery.TooManyClauses} exception.
Protected field | rewriteMethod |
 | SCORING_BOOLEAN_QUERY_REWRITE | A rewrite method that first translates each term into {@link BooleanClause.Occur#SHOULD} clause in a BooleanQuery, and keeps the scores as computed by the query. Note that typically such scores are meaningless to the user, and require non-trivial CPU to compute, so it's almost always better to use {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} instead. NOTE: This rewrite method will hit {@link BooleanQuery.TooManyClauses} if the number of terms exceeds {@link BooleanQuery#getMaxClauseCount}.
Protected field | term |

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


MultiTermQuery Constructor

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery Constructor
MultiTermQuery Class See Also Send Feedback

Overload List

Name Description
Public method MultiTermQuery()()()()
Constructs a query matching terms that cannot be represented with a single Term.
Public method MultiTermQuery(Term) Obsolete.
Constructs a query for terms matching
CopyC#
term
.

See Also

MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace


MultiTermQuery Constructor

[image]

Lucene.Net Class Libraries
MultiTermQuery Constructor
MultiTermQuery Class See Also Send Feedback
Constructs a query matching terms that cannot be represented with a single Term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiTermQuery()
Visual Basic
Public Sub New
Visual C++
public:
MultiTermQuery()

See Also

MultiTermQuery Class
MultiTermQuery Overload
Lucene.Net.Search Namespace


MultiTermQuery Constructor (Term)

[image]

Lucene.Net Class Libraries
MultiTermQuery Constructor (Term)
MultiTermQuery Class See Also Send Feedback
Constructs a query for terms matching
CopyC#
term
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("check sub class for possible term access - the Term does not make sense for all MultiTermQuerys and will be removed.")]
public MultiTermQuery(
    Term term
)
Visual Basic
<ObsoleteAttribute("check sub class for possible term access - the Term does not make sense for all MultiTermQuerys and will be removed.")> _
Public Sub New ( _
    term As Term _
)
Visual C++
[ObsoleteAttribute(L"check sub class for possible term access - the Term does not make sense for all MultiTermQuerys and will be removed.")]
public:
MultiTermQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

MultiTermQuery Class
MultiTermQuery Overload
Lucene.Net.Search Namespace


MultiTermQuery Fields

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery Fields
MultiTermQuery Class See Also Send Feedback

The MultiTermQuery type exposes the following members.

Fields

 | Name | Description
 | CONSTANT_SCORE_AUTO_REWRITE_DEFAULT | Read-only default instance of {@link ConstantScoreAutoRewrite}, with {@link ConstantScoreAutoRewrite#setTermCountCutoff} set to {@link ConstantScoreAutoRewrite#DEFAULT_TERM_COUNT_CUTOFF} and {@link ConstantScoreAutoRewrite#setDocCountPercent} set to {@link ConstantScoreAutoRewrite#DEFAULT_DOC_COUNT_PERCENT}. Note that you cannot alter the configuration of this instance; you'll need to create a private instance instead.
 | CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE | Like {@link #SCORING_BOOLEAN_QUERY_REWRITE} except scores are not computed. Instead, each matching document receives a constant score equal to the query's boost. NOTE: This rewrite method will hit {@link BooleanQuery.TooManyClauses} if the number of terms exceeds {@link BooleanQuery#getMaxClauseCount}.
 | CONSTANT_SCORE_FILTER_REWRITE | A rewrite method that first creates a private Filter, by visiting each term in sequence and marking all docs for that term. Matching documents are assigned a constant score equal to the query's boost. This method is faster than the BooleanQuery rewrite methods when the number of matched terms or matched documents is non-trivial. Also, it will never hit an errant {@link BooleanQuery.TooManyClauses} exception.
Protected field | rewriteMethod |
 | SCORING_BOOLEAN_QUERY_REWRITE | A rewrite method that first translates each term into {@link BooleanClause.Occur#SHOULD} clause in a BooleanQuery, and keeps the scores as computed by the query. Note that typically such scores are meaningless to the user, and require non-trivial CPU to compute, so it's almost always better to use {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} instead. NOTE: This rewrite method will hit {@link BooleanQuery.TooManyClauses} if the number of terms exceeds {@link BooleanQuery#getMaxClauseCount}.
Protected field | term |

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


CONSTANT_SCORE_AUTO_REWRITE_DEFAULT Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..CONSTANT_SCORE_AUTO_REWRITE_DEFAULT Field
MultiTermQuery Class See Also Send Feedback
Read-only default instance of {@link ConstantScoreAutoRewrite}, with {@link ConstantScoreAutoRewrite#setTermCountCutoff} set to {@link ConstantScoreAutoRewrite#DEFAULT_TERM_COUNT_CUTOFF} and {@link ConstantScoreAutoRewrite#setDocCountPercent} set to {@link ConstantScoreAutoRewrite#DEFAULT_DOC_COUNT_PERCENT}. Note that you cannot alter the configuration of this instance; you'll need to create a private instance instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly MultiTermQuery..::..RewriteMethod CONSTANT_SCORE_AUTO_REWRITE_DEFAULT
Visual Basic
Public Shared ReadOnly CONSTANT_SCORE_AUTO_REWRITE_DEFAULT As MultiTermQuery..::..RewriteMethod
Visual C++
public:
static initonly MultiTermQuery..::..RewriteMethod^ CONSTANT_SCORE_AUTO_REWRITE_DEFAULT

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE Field
MultiTermQuery Class See Also Send Feedback
Like {@link #SCORING_BOOLEAN_QUERY_REWRITE} except scores are not computed. Instead, each matching document receives a constant score equal to the query's boost.

NOTE: This rewrite method will hit {@link BooleanQuery.TooManyClauses} if the number of terms exceeds {@link BooleanQuery#getMaxClauseCount}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly MultiTermQuery..::..RewriteMethod CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE
Visual Basic
Public Shared ReadOnly CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE As MultiTermQuery..::..RewriteMethod
Visual C++
public:
static initonly MultiTermQuery..::..RewriteMethod^ CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace
[!:setRewriteMethod]


CONSTANT_SCORE_FILTER_REWRITE Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..CONSTANT_SCORE_FILTER_REWRITE Field
MultiTermQuery Class See Also Send Feedback
A rewrite method that first creates a private Filter, by visiting each term in sequence and marking all docs for that term. Matching documents are assigned a constant score equal to the query's boost.

This method is faster than the BooleanQuery rewrite methods when the number of matched terms or matched documents is non-trivial. Also, it will never hit an errant {@link BooleanQuery.TooManyClauses} exception.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly MultiTermQuery..::..RewriteMethod CONSTANT_SCORE_FILTER_REWRITE
Visual Basic
Public Shared ReadOnly CONSTANT_SCORE_FILTER_REWRITE As MultiTermQuery..::..RewriteMethod
Visual C++
public:
static initonly MultiTermQuery..::..RewriteMethod^ CONSTANT_SCORE_FILTER_REWRITE

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace
[!:setRewriteMethod]


rewriteMethod Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..rewriteMethod Field
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.MultiTermQuery.rewriteMethod"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal MultiTermQuery..::..RewriteMethod rewriteMethod
Visual Basic
Protected Friend rewriteMethod As MultiTermQuery..::..RewriteMethod
Visual C++
protected public:
MultiTermQuery..::..RewriteMethod^ rewriteMethod

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


SCORING_BOOLEAN_QUERY_REWRITE Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..SCORING_BOOLEAN_QUERY_REWRITE Field
MultiTermQuery Class See Also Send Feedback
A rewrite method that first translates each term into {@link BooleanClause.Occur#SHOULD} clause in a BooleanQuery, and keeps the scores as computed by the query. Note that typically such scores are meaningless to the user, and require non-trivial CPU to compute, so it's almost always better to use {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} instead.

NOTE: This rewrite method will hit {@link BooleanQuery.TooManyClauses} if the number of terms exceeds {@link BooleanQuery#getMaxClauseCount}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly MultiTermQuery..::..RewriteMethod SCORING_BOOLEAN_QUERY_REWRITE
Visual Basic
Public Shared ReadOnly SCORING_BOOLEAN_QUERY_REWRITE As MultiTermQuery..::..RewriteMethod
Visual C++
public:
static initonly MultiTermQuery..::..RewriteMethod^ SCORING_BOOLEAN_QUERY_REWRITE

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace
[!:setRewriteMethod]


term Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..term Field
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.MultiTermQuery.term"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Term term
Visual Basic
Protected Friend term As Term
Visual C++
protected public:
Term^ term

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


MultiTermQuery Methods

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery Methods
MultiTermQuery Class See Also Send Feedback

The MultiTermQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetEnum
Construct the enumeration to be used, expanding the pattern term.
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method | GetRewriteMethod
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


ClearTotalNumberOfTerms Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ClearTotalNumberOfTerms Method
MultiTermQuery Class See Also Send Feedback
Expert: Resets the counting of unique terms. Do this before executing the query/filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ClearTotalNumberOfTerms()
Visual Basic
Public Overridable Sub ClearTotalNumberOfTerms
Visual C++
public:
virtual void ClearTotalNumberOfTerms()

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace
[!:getTotalNumberOfTerms]


Equals Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..Equals Method
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.Equals(System.Object)"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..GetEnum Method
MultiTermQuery Class See Also Send Feedback
Construct the enumeration to be used, expanding the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public MustOverride Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..GetHashCode Method
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetHashCode"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


GetRewriteMethod Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..GetRewriteMethod Method
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetRewriteMethod"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual MultiTermQuery..::..RewriteMethod GetRewriteMethod()
Visual Basic
Public Overridable Function GetRewriteMethod As MultiTermQuery..::..RewriteMethod
Visual C++
public:
virtual MultiTermQuery..::..RewriteMethod^ GetRewriteMethod()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetRewriteMethod"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace
[!:setRewriteMethod]


GetTerm Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..GetTerm Method
MultiTermQuery Class See Also Send Feedback
Returns the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("check sub class for possible term access - getTerm does not make sense for all MultiTermQuerys and will be removed.")]
public virtual Term GetTerm()
Visual Basic
<ObsoleteAttribute("check sub class for possible term access - getTerm does not make sense for all MultiTermQuerys and will be removed.")> _
Public Overridable Function GetTerm As Term
Visual C++
[ObsoleteAttribute(L"check sub class for possible term access - getTerm does not make sense for all MultiTermQuerys and will be removed.")]
public:
virtual Term^ GetTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetTerm"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


GetTotalNumberOfTerms Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..GetTotalNumberOfTerms Method
MultiTermQuery Class See Also Send Feedback
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTotalNumberOfTerms()
Visual Basic
Public Overridable Function GetTotalNumberOfTerms As Integer
Visual C++
public:
virtual int GetTotalNumberOfTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.GetTotalNumberOfTerms"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace
[!:clearTotalNumberOfTerms]


IncTotalNumberOfTerms Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..IncTotalNumberOfTerms Method
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.IncTotalNumberOfTerms(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void IncTotalNumberOfTerms(
    int inc
)
Visual Basic
Protected Friend Overridable Sub IncTotalNumberOfTerms ( _
    inc As Integer _
)
Visual C++
protected public:
virtual void IncTotalNumberOfTerms(
    int inc
)

Parameters

inc
Type: System..::..Int32

[Missing <param name="inc"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.IncTotalNumberOfTerms(System.Int32)"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..Rewrite Method
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


SetRewriteMethod Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..SetRewriteMethod Method
MultiTermQuery Class See Also Send Feedback
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetRewriteMethod(
    MultiTermQuery..::..RewriteMethod method
)
Visual Basic
Public Overridable Sub SetRewriteMethod ( _
    method As MultiTermQuery..::..RewriteMethod _
)
Visual C++
public:
virtual void SetRewriteMethod(
    MultiTermQuery..::..RewriteMethod^ method
)

Parameters

method
Type: Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod

[Missing <param name="method"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.SetRewriteMethod(Lucene.Net.Search.MultiTermQuery.RewriteMethod)"]

See Also

MultiTermQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..ToString Method
MultiTermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

MultiTermQuery Class
MultiTermQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ToString Method (String)
MultiTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.ToString(System.String)"]

See Also

MultiTermQuery Class
ToString Overload
Lucene.Net.Search Namespace


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Class

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
MultiTermQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class AnonymousClassConstantScoreAutoRewrite : MultiTermQuery..::..ConstantScoreAutoRewrite
Visual Basic
<SerializableAttribute> _
Public Class AnonymousClassConstantScoreAutoRewrite _
    Inherits MultiTermQuery..::..ConstantScoreAutoRewrite
Visual C++
[SerializableAttribute]
public ref class AnonymousClassConstantScoreAutoRewrite : public MultiTermQuery..::..ConstantScoreAutoRewrite

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod
Lucene.Net.Search..::..MultiTermQuery..::..ConstantScoreAutoRewrite
Lucene.Net.Search..::..MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Members

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Members
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class Constructors Methods See Also Send Feedback

An abstract {@link Query} that matches documents containing a subset of terms provided by a {@link FilteredTermEnum} enumeration.

This query cannot be used directly; you must subclass it and define {@link #getEnum} to provide a {@link FilteredTermEnum} that iterates through the terms to be matched.

NOTE: if {@link #setRewriteMethod} is either {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} or {@link #SCORING_BOOLEAN_QUERY_REWRITE}, you may encounter a {@link BooleanQuery.TooManyClauses} exception during searching, which happens when the number of terms to be searched exceeds {@link BooleanQuery#GetMaxClauseCount()}. Setting {@link #setRewriteMethod} to {@link #CONSTANT_SCORE_FILTER_REWRITE} prevents this.

The recommended rewrite method is {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}: it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that {@link QueryParser} produces MultiTermQueries using {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} by default.

The MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite type exposes the following members.

Constructors

 | Name | Description
Public method | MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite | Initializes a new instance of the MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite class

Methods

 | Name | Description
Public method | Equals | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocCountPercent | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | GetHashCode | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | GetTermCountCutoff | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReadResolve |
Public method | Rewrite | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | SetDocCountPercent | (Overrides MultiTermQuery..::..ConstantScoreAutoRewrite..::..SetDocCountPercent(Double).)
Public method | SetTermCountCutoff | (Overrides MultiTermQuery..::..ConstantScoreAutoRewrite..::..SetTermCountCutoff(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Constructor

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Constructor
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class See Also Send Feedback
Initializes a new instance of the MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AnonymousClassConstantScoreAutoRewrite()
Visual Basic
Public Sub New
Visual C++
public:
AnonymousClassConstantScoreAutoRewrite()

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.AnonymousClassConstantScoreAutoRewrite Methods

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Methods
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class See Also Send Feedback

The MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocCountPercent | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | GetHashCode | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | GetTermCountCutoff | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReadResolve |
Public method | Rewrite | (Inherited from MultiTermQuery..::..ConstantScoreAutoRewrite.)
Public method | SetDocCountPercent | (Overrides MultiTermQuery..::..ConstantScoreAutoRewrite..::..SetDocCountPercent(Double).)
Public method | SetTermCountCutoff | (Overrides MultiTermQuery..::..ConstantScoreAutoRewrite..::..SetTermCountCutoff(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


ReadResolve Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite..::..ReadResolve Method
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite.ReadResolve"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Object ReadResolve()
Visual Basic
Protected Friend Overridable Function ReadResolve As Object
Visual C++
protected public:
virtual Object^ ReadResolve()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite.ReadResolve"]

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


SetDocCountPercent Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite..::..SetDocCountPercent Method
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite.SetDocCountPercent(System.Double)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetDocCountPercent(
    double percent
)
Visual Basic
Public Overrides Sub SetDocCountPercent ( _
    percent As Double _
)
Visual C++
public:
virtual void SetDocCountPercent(
    double percent
) override

Parameters

percent
Type: System..::..Double

[Missing <param name="percent"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite.SetDocCountPercent(System.Double)"]

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


SetTermCountCutoff Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite..::..SetTermCountCutoff Method
MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite.SetTermCountCutoff(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetTermCountCutoff(
    int count
)
Visual Basic
Public Overrides Sub SetTermCountCutoff ( _
    count As Integer _
)
Visual C++
public:
virtual void SetTermCountCutoff(
    int count
) override

Parameters

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.AnonymousClassConstantScoreAutoRewrite.SetTermCountCutoff(System.Int32)"]

See Also

MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.ConstantScoreAutoRewrite Class

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite Class
MultiTermQuery Class Members See Also Send Feedback
A rewrite method that tries to pick the best constant-score rewrite method based on term and document counts from the query. If both the number of terms and documents is small enough, then {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} is used. Otherwise, {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ConstantScoreAutoRewrite : MultiTermQuery..::..RewriteMethod
Visual Basic
<SerializableAttribute> _
Public Class ConstantScoreAutoRewrite _
    Inherits MultiTermQuery..::..RewriteMethod
Visual C++
[SerializableAttribute]
public ref class ConstantScoreAutoRewrite : public MultiTermQuery..::..RewriteMethod

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod
Lucene.Net.Search..::..MultiTermQuery..::..ConstantScoreAutoRewrite
Lucene.Net.Search..::..MultiTermQuery..::..AnonymousClassConstantScoreAutoRewrite

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Members
Lucene.Net.Search Namespace


MultiTermQuery.ConstantScoreAutoRewrite Members

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite Members
MultiTermQuery..::..ConstantScoreAutoRewrite Class Constructors Methods Fields See Also Send Feedback

An abstract {@link Query} that matches documents containing a subset of terms provided by a {@link FilteredTermEnum} enumeration.

This query cannot be used directly; you must subclass it and define {@link #getEnum} to provide a {@link FilteredTermEnum} that iterates through the terms to be matched.

NOTE: if {@link #setRewriteMethod} is either {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} or {@link #SCORING_BOOLEAN_QUERY_REWRITE}, you may encounter a {@link BooleanQuery.TooManyClauses} exception during searching, which happens when the number of terms to be searched exceeds {@link BooleanQuery#GetMaxClauseCount()}. Setting {@link #setRewriteMethod} to {@link #CONSTANT_SCORE_FILTER_REWRITE} prevents this.

The recommended rewrite method is {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}: it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that {@link QueryParser} produces MultiTermQueries using {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} by default.

The MultiTermQuery..::..ConstantScoreAutoRewrite type exposes the following members.

Constructors

 | Name | Description
Public method | MultiTermQuery..::..ConstantScoreAutoRewrite | Initializes a new instance of the MultiTermQuery..::..ConstantScoreAutoRewrite class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocCountPercent |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetTermCountCutoff |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rewrite | (Overrides MultiTermQuery..::..RewriteMethod..::..Rewrite(IndexReader, MultiTermQuery).)
Public method | SetDocCountPercent | If the number of documents to be visited in the postings exceeds this specified percentage of the maxDoc() for the index, then {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.
Public method | SetTermCountCutoff | If the number of terms in this query is equal to or larger than this setting then {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DEFAULT_DOC_COUNT_PERCENT |
DEFAULT_TERM_COUNT_CUTOFF |

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.ConstantScoreAutoRewrite Constructor

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite Constructor
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback
Initializes a new instance of the MultiTermQuery..::..ConstantScoreAutoRewrite class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ConstantScoreAutoRewrite()
Visual Basic
Public Sub New
Visual C++
public:
ConstantScoreAutoRewrite()

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.ConstantScoreAutoRewrite Fields

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite Fields
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

The MultiTermQuery..::..ConstantScoreAutoRewrite type exposes the following members.

Fields

Name | Description
DEFAULT_DOC_COUNT_PERCENT |
DEFAULT_TERM_COUNT_CUTOFF |

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


DEFAULT_DOC_COUNT_PERCENT Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..DEFAULT_DOC_COUNT_PERCENT Field
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.DEFAULT_DOC_COUNT_PERCENT"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static double DEFAULT_DOC_COUNT_PERCENT
Visual Basic
Public Shared DEFAULT_DOC_COUNT_PERCENT As Double
Visual C++
public:
static double DEFAULT_DOC_COUNT_PERCENT

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


DEFAULT_TERM_COUNT_CUTOFF Field

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..DEFAULT_TERM_COUNT_CUTOFF Field
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.DEFAULT_TERM_COUNT_CUTOFF"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int DEFAULT_TERM_COUNT_CUTOFF
Visual Basic
Public Shared DEFAULT_TERM_COUNT_CUTOFF As Integer
Visual C++
public:
static int DEFAULT_TERM_COUNT_CUTOFF

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.ConstantScoreAutoRewrite Methods

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite Methods
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

The MultiTermQuery..::..ConstantScoreAutoRewrite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocCountPercent |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetTermCountCutoff |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rewrite | (Overrides MultiTermQuery..::..RewriteMethod..::..Rewrite(IndexReader, MultiTermQuery).)
Public method | SetDocCountPercent | If the number of documents to be visited in the postings exceeds this specified percentage of the maxDoc() for the index, then {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.
Public method | SetTermCountCutoff | If the number of terms in this query is equal to or larger than this setting then {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..Equals Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Equals(System.Object)"]

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


GetDocCountPercent Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..GetDocCountPercent Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.GetDocCountPercent"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual double GetDocCountPercent()
Visual Basic
Public Overridable Function GetDocCountPercent As Double
Visual C++
public:
virtual double GetDocCountPercent()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.GetDocCountPercent"]

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace
[!:setDocCountPercent]


GetHashCode Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..GetHashCode Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.GetHashCode"]

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


GetTermCountCutoff Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..GetTermCountCutoff Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.GetTermCountCutoff"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTermCountCutoff()
Visual Basic
Public Overridable Function GetTermCountCutoff As Integer
Visual C++
public:
virtual int GetTermCountCutoff()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.GetTermCountCutoff"]

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace
[!:setTermCountCutoff]


Rewrite Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..Rewrite Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader,
    MultiTermQuery query
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader, _
    query As MultiTermQuery _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader,
    MultiTermQuery^ query
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

query
Type: Lucene.Net.Search..::..MultiTermQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


SetDocCountPercent Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..SetDocCountPercent Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback
If the number of documents to be visited in the postings exceeds this specified percentage of the maxDoc() for the index, then {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetDocCountPercent(
    double percent
)
Visual Basic
Public Overridable Sub SetDocCountPercent ( _
    percent As Double _
)
Visual C++
public:
virtual void SetDocCountPercent(
    double percent
)

Parameters

percent
Type: System..::..Double
0.0 to 100.0

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


SetTermCountCutoff Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..ConstantScoreAutoRewrite..::..SetTermCountCutoff Method
MultiTermQuery..::..ConstantScoreAutoRewrite Class See Also Send Feedback
If the number of terms in this query is equal to or larger than this setting then {@link #CONSTANT_SCORE_FILTER_REWRITE} is used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetTermCountCutoff(
    int count
)
Visual Basic
Public Overridable Sub SetTermCountCutoff ( _
    count As Integer _
)
Visual C++
public:
virtual void SetTermCountCutoff(
    int count
)

Parameters

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.ConstantScoreAutoRewrite.SetTermCountCutoff(System.Int32)"]

See Also

MultiTermQuery..::..ConstantScoreAutoRewrite Class
Lucene.Net.Search Namespace


MultiTermQuery.RewriteMethod Class

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..RewriteMethod Class
MultiTermQuery Class Members See Also Send Feedback
Abstract class that defines how the query is rewritten.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class RewriteMethod
Visual Basic
<SerializableAttribute> _
Public MustInherit Class RewriteMethod
Visual C++
[SerializableAttribute]
public ref class RewriteMethod abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..MultiTermQuery..::..RewriteMethod
Lucene.Net.Search..::..MultiTermQuery..::..ConstantScoreAutoRewrite

See Also

MultiTermQuery..::..RewriteMethod Members
Lucene.Net.Search Namespace


MultiTermQuery.RewriteMethod Members

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..RewriteMethod Members
MultiTermQuery..::..RewriteMethod Class Constructors Methods See Also Send Feedback

An abstract {@link Query} that matches documents containing a subset of terms provided by a {@link FilteredTermEnum} enumeration.

This query cannot be used directly; you must subclass it and define {@link #getEnum} to provide a {@link FilteredTermEnum} that iterates through the terms to be matched.

NOTE: if {@link #setRewriteMethod} is either {@link #CONSTANT_SCORE_BOOLEAN_QUERY_REWRITE} or {@link #SCORING_BOOLEAN_QUERY_REWRITE}, you may encounter a {@link BooleanQuery.TooManyClauses} exception during searching, which happens when the number of terms to be searched exceeds {@link BooleanQuery#GetMaxClauseCount()}. Setting {@link #setRewriteMethod} to {@link #CONSTANT_SCORE_FILTER_REWRITE} prevents this.

The recommended rewrite method is {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT}: it doesn't spend CPU computing unhelpful scores, and it tries to pick the most performant rewrite method given the query. Note that {@link QueryParser} produces MultiTermQueries using {@link #CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} by default.

The MultiTermQuery..::..RewriteMethod type exposes the following members.

Constructors

 | Name | Description
Protected method | MultiTermQuery..::..RewriteMethod | Initializes a new instance of the MultiTermQuery..::..RewriteMethod class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rewrite |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiTermQuery..::..RewriteMethod Class
Lucene.Net.Search Namespace


MultiTermQuery.RewriteMethod Constructor

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..RewriteMethod Constructor
MultiTermQuery..::..RewriteMethod Class See Also Send Feedback
Initializes a new instance of the MultiTermQuery..::..RewriteMethod class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected RewriteMethod()
Visual Basic
Protected Sub New
Visual C++
protected:
RewriteMethod()

See Also

MultiTermQuery..::..RewriteMethod Class
Lucene.Net.Search Namespace


MultiTermQuery.RewriteMethod Methods

[image] [image]

Lucene.Net Class Libraries
MultiTermQuery..::..RewriteMethod Methods
MultiTermQuery..::..RewriteMethod Class See Also Send Feedback

The MultiTermQuery..::..RewriteMethod type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rewrite |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiTermQuery..::..RewriteMethod Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
MultiTermQuery..::..RewriteMethod..::..Rewrite Method
MultiTermQuery..::..RewriteMethod Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQuery.RewriteMethod.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Query Rewrite(
    IndexReader reader,
    MultiTermQuery query
)
Visual Basic
Public MustOverride Function Rewrite ( _
    reader As IndexReader, _
    query As MultiTermQuery _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader,
    MultiTermQuery^ query
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.RewriteMethod.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

query
Type: Lucene.Net.Search..::..MultiTermQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.MultiTermQuery.RewriteMethod.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQuery.RewriteMethod.Rewrite(Lucene.Net.Index.IndexReader,Lucene.Net.Search.MultiTermQuery)"]

See Also

MultiTermQuery..::..RewriteMethod Class
Lucene.Net.Search Namespace


MultiTermQueryWrapperFilter Class

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter Class
Members See Also Send Feedback
A wrapper for {@link MultiTermQuery}, that exposes its functionality as a {@link Filter}.

CopyC#
MultiTermQueryWrapperFilter
is not designed to be used by itself. Normally you subclass it to provide a Filter counterpart for a {@link MultiTermQuery} subclass.

For example, {@link TermRangeFilter} and {@link PrefixFilter} extend

CopyC#
MultiTermQueryWrapperFilter
. This class also provides the functionality behind {@link MultiTermQuery#CONSTANT_SCORE_FILTER_REWRITE}; this is why it is not abstract.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MultiTermQueryWrapperFilter : Filter
Visual Basic
<SerializableAttribute> _
Public Class MultiTermQueryWrapperFilter _
    Inherits Filter
Visual C++
[SerializableAttribute]
public ref class MultiTermQueryWrapperFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..MultiTermQueryWrapperFilter
Lucene.Net.Search..::..NumericRangeFilter
Lucene.Net.Search..::..PrefixFilter
Lucene.Net.Search..::..RangeFilter
Lucene.Net.Search..::..TermRangeFilter

See Also

MultiTermQueryWrapperFilter Members
Lucene.Net.Search Namespace


MultiTermQueryWrapperFilter Members

[image] [image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter Members
MultiTermQueryWrapperFilter Class Constructors Methods Fields See Also Send Feedback

The MultiTermQueryWrapperFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | MultiTermQueryWrapperFilter | Wrap a {@link MultiTermQuery} as a Filter.

Methods

 | Name | Description
Public method | Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not. (Overrides Filter..::..Bits(IndexReader).)
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Returns a DocIdSet with documents that should be permitted in search results. (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetTotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | query |

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


MultiTermQueryWrapperFilter Constructor

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter Constructor
MultiTermQueryWrapperFilter Class See Also Send Feedback
Wrap a {@link MultiTermQuery} as a Filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal MultiTermQueryWrapperFilter(
    MultiTermQuery query
)
Visual Basic
Protected Friend Sub New ( _
    query As MultiTermQuery _
)
Visual C++
protected public:
MultiTermQueryWrapperFilter(
    MultiTermQuery^ query
)

Parameters

query
Type: Lucene.Net.Search..::..MultiTermQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.#ctor(Lucene.Net.Search.MultiTermQuery)"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


MultiTermQueryWrapperFilter Fields

[image] [image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter Fields
MultiTermQueryWrapperFilter Class See Also Send Feedback

The MultiTermQueryWrapperFilter type exposes the following members.

Fields

 | Name | Description
Protected field | query |

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


query Field

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..query Field
MultiTermQueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.MultiTermQueryWrapperFilter.query"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal MultiTermQuery query
Visual Basic
Protected Friend query As MultiTermQuery
Visual C++
protected public:
MultiTermQuery^ query

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


MultiTermQueryWrapperFilter Methods

[image] [image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter Methods
MultiTermQueryWrapperFilter Class See Also Send Feedback

The MultiTermQueryWrapperFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not. (Overrides Filter..::..Bits(IndexReader).)
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Returns a DocIdSet with documents that should be permitted in search results. (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetTotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


Bits Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..Bits Method
MultiTermQueryWrapperFilter Class See Also Send Feedback
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")]
public override BitArray Bits(
    IndexReader reader
)
Visual Basic
<ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")> _
Public Overrides Function Bits ( _
    reader As IndexReader _
) As BitArray
Visual C++
[ObsoleteAttribute(L"Use GetDocIdSet(IndexReader) instead.")]
public:
virtual BitArray^ Bits(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


ClearTotalNumberOfTerms Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..ClearTotalNumberOfTerms Method
MultiTermQueryWrapperFilter Class See Also Send Feedback
Expert: Resets the counting of unique terms. Do this before executing the filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ClearTotalNumberOfTerms()
Visual Basic
Public Overridable Sub ClearTotalNumberOfTerms
Visual C++
public:
virtual void ClearTotalNumberOfTerms()

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace
[!:getTotalNumberOfTerms]


Equals Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..Equals Method
MultiTermQueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.Equals(System.Object)"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..GetDocIdSet Method
MultiTermQueryWrapperFilter Class See Also Send Feedback
Returns a DocIdSet with documents that should be permitted in search results.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..GetHashCode Method
MultiTermQueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.GetHashCode"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


GetTotalNumberOfTerms Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..GetTotalNumberOfTerms Method
MultiTermQueryWrapperFilter Class See Also Send Feedback
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTotalNumberOfTerms()
Visual Basic
Public Overridable Function GetTotalNumberOfTerms As Integer
Visual C++
public:
virtual int GetTotalNumberOfTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.GetTotalNumberOfTerms"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace
[!:clearTotalNumberOfTerms]


ToString Method

[image]

Lucene.Net Class Libraries
MultiTermQueryWrapperFilter..::..ToString Method
MultiTermQueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.MultiTermQueryWrapperFilter.ToString"]

See Also

MultiTermQueryWrapperFilter Class
Lucene.Net.Search Namespace


NumericRangeFilter Class

[image]

Lucene.Net Class Libraries
NumericRangeFilter Class
Members See Also Send Feedback
A {@link Filter} that only accepts numeric values within a specified range. To use this, you must first index the numeric values using {@link NumericField} (expert: {@link NumericTokenStream}).

You create a new NumericRangeFilter with the static factory methods, eg:

            Filter f = NumericRangeFilter.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
accepts all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive. See {@link NumericRangeQuery} for details on how Lucene indexes and searches numeric valued fields.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class NumericRangeFilter : MultiTermQueryWrapperFilter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class NumericRangeFilter _
    Inherits MultiTermQueryWrapperFilter
Visual C++
[SerializableAttribute]
public ref class NumericRangeFilter sealed : public MultiTermQueryWrapperFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..MultiTermQueryWrapperFilter
Lucene.Net.Search..::..NumericRangeFilter

See Also

NumericRangeFilter Members
Lucene.Net.Search Namespace


NumericRangeFilter Members

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter Members
NumericRangeFilter Class Methods Fields See Also Send Feedback

The NumericRangeFilter type exposes the following members.

Methods

Name | Description
Public method Bits Obsolete.
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
(Inherited from MultiTermQueryWrapperFilter.)
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the filter.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDocIdSet
Returns a DocIdSet with documents that should be permitted in search results.
(Inherited from MultiTermQueryWrapperFilter.)
Public method GetField
Returns the field name for this filter
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method GetMax
Returns the upper value of this range filter
Public method GetMin
Returns the lower value of this range filter
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

(Inherited from MultiTermQueryWrapperFilter.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IncludesMax
Returns
CopyC#
true
 if the upper endpoint is inclusive
Public method IncludesMin
Returns
CopyC#
true
 if the lower endpoint is inclusive
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
NewDoubleRange(String, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter.)

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


NumericRangeFilter Fields

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter Fields
NumericRangeFilter Class See Also Send Feedback

The NumericRangeFilter type exposes the following members.

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


NumericRangeFilter Methods

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter Methods
NumericRangeFilter Class See Also Send Feedback

The NumericRangeFilter type exposes the following members.

Methods

Name | Description
Public method Bits Obsolete.
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
(Inherited from MultiTermQueryWrapperFilter.)
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the filter.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDocIdSet
Returns a DocIdSet with documents that should be permitted in search results.
(Inherited from MultiTermQueryWrapperFilter.)
Public method GetField
Returns the field name for this filter
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method GetMax
Returns the upper value of this range filter
Public method GetMin
Returns the lower value of this range filter
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

(Inherited from MultiTermQueryWrapperFilter.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IncludesMax
Returns
CopyC#
true
 if the upper endpoint is inclusive
Public method IncludesMin
Returns
CopyC#
true
 if the lower endpoint is inclusive
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
NewDoubleRange(String, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter.)

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..GetField Method
NumericRangeFilter Class See Also Send Feedback
Returns the field name for this filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetField()
Visual Basic
Public Function GetField As String
Visual C++
public:
String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.GetField"]

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


GetMax Method

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..GetMax Method
NumericRangeFilter Class See Also Send Feedback
Returns the upper value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueType GetMax()
Visual Basic
Public Function GetMax As ValueType
Visual C++
public:
ValueType^ GetMax()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.GetMax"]

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


GetMin Method

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..GetMin Method
NumericRangeFilter Class See Also Send Feedback
Returns the lower value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueType GetMin()
Visual Basic
Public Function GetMin As ValueType
Visual C++
public:
ValueType^ GetMin()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.GetMin"]

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


IncludesMax Method

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..IncludesMax Method
NumericRangeFilter Class See Also Send Feedback
Returns
CopyC#
true
 if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IncludesMax()
Visual Basic
Public Function IncludesMax As Boolean
Visual C++
public:
bool IncludesMax()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.IncludesMax"]

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


IncludesMin Method

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..IncludesMin Method
NumericRangeFilter Class See Also Send Feedback
Returns
CopyC#
true
 if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IncludesMin()
Visual Basic
Public Function IncludesMin As Boolean
Visual C++
public:
bool IncludesMin()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.IncludesMin"]

See Also

NumericRangeFilter Class
Lucene.Net.Search Namespace


NewDoubleRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewDoubleRange Method
NumericRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewDoubleRange(String, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace


NewDoubleRange Method (String, Double, Double, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewDoubleRange Method (String, Double, Double, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewDoubleRange(
    string field,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewDoubleRange ( _
    field As String, _
    min As Double, _
    max As Double, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewDoubleRange(
    String^ field,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

min
Type: System..::..Double

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

max
Type: System..::..Double

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewDoubleRange Overload
Lucene.Net.Search Namespace


NewDoubleRange Method (String, Int32, Double, Double, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewDoubleRange Method (String, Int32, Double, Double, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewDoubleRange(
    string field,
    int precisionStep,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewDoubleRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Double, _
    max As Double, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewDoubleRange(
    String^ field,
    int precisionStep,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

min
Type: System..::..Double

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

max
Type: System..::..Double

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewDoubleRange Overload
Lucene.Net.Search Namespace


NewFloatRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewFloatRange Method
NumericRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewFloatRange(String, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace


NewFloatRange Method (String, Single, Single, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewFloatRange Method (String, Single, Single, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewFloatRange(
    string field,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewFloatRange ( _
    field As String, _
    min As Single, _
    max As Single, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewFloatRange(
    String^ field,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

min
Type: System..::..Single

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

max
Type: System..::..Single

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewFloatRange Overload
Lucene.Net.Search Namespace


NewFloatRange Method (String, Int32, Single, Single, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewFloatRange Method (String, Int32, Single, Single, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewFloatRange(
    string field,
    int precisionStep,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewFloatRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Single, _
    max As Single, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewFloatRange(
    String^ field,
    int precisionStep,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

min
Type: System..::..Single

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

max
Type: System..::..Single

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewFloatRange Overload
Lucene.Net.Search Namespace


NewIntRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewIntRange Method
NumericRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace


NewIntRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewIntRange Method (String, ValueType, ValueType, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewIntRange(
    string field,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewIntRange ( _
    field As String, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewIntRange(
    String^ field,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewIntRange Overload
Lucene.Net.Search Namespace


NewIntRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewIntRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewIntRange(
    string field,
    int precisionStep,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewIntRange ( _
    field As String, _
    precisionStep As Integer, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewIntRange(
    String^ field,
    int precisionStep,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewIntRange Overload
Lucene.Net.Search Namespace


NewLongRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewLongRange Method
NumericRangeFilter Class See Also Send Feedback

Overload List

Name Description
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeFilter Class
NumericRangeFilter Members
Lucene.Net.Search Namespace


NewLongRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewLongRange Method (String, ValueType, ValueType, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewLongRange(
    string field,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewLongRange ( _
    field As String, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewLongRange(
    String^ field,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewLongRange Overload
Lucene.Net.Search Namespace


NewLongRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeFilter..::..NewLongRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)
NumericRangeFilter Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeFilter
, that filters a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeFilter NewLongRange(
    string field,
    int precisionStep,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewLongRange ( _
    field As String, _
    precisionStep As Integer, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeFilter
Visual C++
public:
static NumericRangeFilter^ NewLongRange(
    String^ field,
    int precisionStep,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeFilter.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeFilter Class
NewLongRange Overload
Lucene.Net.Search Namespace


NumericRangeQuery Class

[image]

Lucene.Net Class Libraries
NumericRangeQuery Class
Members See Also Send Feedback

A {@link Query} that matches numeric values within a specified range. To use this, you must first index the numeric values using {@link NumericField} (expert: {@link NumericTokenStream}). If your terms are instead textual, you should use {@link TermRangeQuery}. {@link NumericRangeFilter} is the filter equivalent of this query.

You create a new NumericRangeQuery with the static factory methods, eg:

            Query q = NumericRangeQuery.newFloatRange("weight",
            new Float(0.3f), new Float(0.10f),
            true, true);
matches all documents whose float valued "weight" field ranges from 0.3 to 0.10, inclusive.

The performance of NumericRangeQuery is much better than the corresponding {@link TermRangeQuery} because the number of terms that must be searched is usually far fewer, thanks to trie indexing, described below.

You can optionally specify a

CopyC#
precisionStep
when creating this query. This is necessary if you've changed this configuration from its default (4) during indexing. Lower values consume more disk space but speed up searching. Suitable values are between 1 and 8. A good starting point to test is 4, which is the default value for all
CopyC#
Numeric*
 classes. See below for details.

This query defaults to {@linkplain MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} for 32 bit (int/float) ranges with precisionStep <8 and 64 bit (long/double) ranges with precisionStep <6. Otherwise it uses {@linkplain MultiTermQuery#CONSTANT_SCORE_FILTER_REWRITE} as the number of terms is likely to be high. With precision steps of <4, this query can be run with one of the BooleanQuery rewrite methods without changing BooleanQuery's default max clause count.

NOTE: This API is experimental and might change in incompatible ways in the next release.

How it works

See the publication about panFMP, where this algorithm was described (referred to as

CopyC#
TrieRangeQuery
):
Schindler, U, Diepenbroek, M, 2008. Generic XML-based Framework for Metadata Portals. Computers & Geosciences 34 (12), 1947-1955. doi:10.1016/j.cageo.2008.02.023

A quote from this paper: Because Apache Lucene is a full-text search engine and not a conventional database, it cannot handle numerical ranges (e.g., field value is inside user defined bounds, even dates are numerical values). We have developed an extension to Apache Lucene that stores the numerical values in a special string-encoded format with variable precision (all numerical values like doubles, longs, floats, and ints are converted to lexicographic sortable string representations and stored with different precisions (for a more detailed description of how the values are stored, see {@link NumericUtils}). A range is then divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

For the variant that stores long values in 8 different precisions (each reduced by 8 bits) that uses a lowest precision of 1 byte, the index contains only a maximum of 256 distinct values in the lowest precision. Overall, a range could consist of a theoretical maximum of

CopyC#
7*255*2 + 255 = 3825
distinct terms (when there is a term for every distinct value of an 8-byte-number in the index and the range covers almost all of them; a maximum of 255 distinct values is used because it would always be possible to reduce the full 256 values to one term with degraded precision). In practice, we have seen up to 300 terms in most cases (index with 500,000 metadata records and a uniform value distribution).

Precision Step

You can choose any

CopyC#
precisionStep
when encoding values. Lower step values mean more precisions and so more terms in index (and index gets larger). On the other hand, the maximum number of terms to match reduces, which optimized query speed. The formula to calculate the maximum term count is:
            n = [ (bitsPerValue/precisionStep - 1) * (2^precisionStep - 1 ) * 2 ] + (2^precisionStep - 1 )

(this formula is only correct, when

CopyC#
bitsPerValue/precisionStep
is an integer; in other cases, the value must be rounded up and the last summand must contain the modulo of the division as precision step). For longs stored using a precision step of 4,
CopyC#
n = 15*15*2 + 15 = 465
, and for a precision step of 2,
CopyC#
n = 31*3*2 + 3 = 189
. But the faster search speed is reduced by more seeking in the term enum of the index. Because of this, the ideal
CopyC#
precisionStep
 value can only be found out by testing. Important: You can index with a lower precision step value and test search speed using a multiple of the original step value.

Good values for

CopyC#
precisionStep
are depending on usage and data type:
  • The default for all data types is 4, which is used, when no
    CopyC#
    precisionStep
     is given.
  • Ideal value in most cases for 64 bit data types (long, double) is 6 or 8.
  • Ideal value in most cases for 32 bit data types (int, float) is 4.
  • Steps >64 for long/double and >32 for int/float produces one token per value in the index and querying is as slow as a conventional {@link TermRangeQuery}. But it can be used to produce fields, that are solely used for sorting (in this case simply use {@link Integer#MAX_VALUE} as
    CopyC#
    precisionStep
    ). Using {@link NumericField NumericFields} for sorting is ideal, because building the field cache is much faster than with text-only numbers. Sorting is also possible with range query optimized fields using one of the above
    CopyC#
    precisionSteps
    .

Comparisons of the different types of RangeQueries on an index with about 500,000 docs showed that {@link TermRangeQuery} in boolean rewrite mode (with raised {@link BooleanQuery} clause count) took about 30-40 secs to complete, {@link TermRangeQuery} in constant score filter rewrite mode took 5 secs and executing this class took <100ms to complete (on an Opteron64 machine, Java 1.5, 8 bit precision step). This query type was developed for a geographic portal, where the performance for e.g. bounding boxes or exact date/time stamps is important.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class NumericRangeQuery : MultiTermQuery
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class NumericRangeQuery _
    Inherits MultiTermQuery
Visual C++
[SerializableAttribute]
public ref class NumericRangeQuery sealed : public MultiTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..NumericRangeQuery

See Also

NumericRangeQuery Members
Lucene.Net.Search Namespace


NumericRangeQuery Members

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery Members
NumericRangeQuery Class Methods Fields See Also Send Feedback

The NumericRangeQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method GetField
Returns the field name for this query
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetMax
Returns the upper value of this range query
Public method GetMin
Returns the lower value of this range query
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IncludesMax
Returns
CopyC#
true
 if the upper endpoint is inclusive
Public method IncludesMin
Returns
CopyC#
true
 if the lower endpoint is inclusive
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
NewDoubleRange(String, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


NumericRangeQuery Fields

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery Fields
NumericRangeQuery Class See Also Send Feedback

The NumericRangeQuery type exposes the following members.

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


NumericRangeQuery Methods

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery Methods
NumericRangeQuery Class See Also Send Feedback

The NumericRangeQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method GetField
Returns the field name for this query
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetMax
Returns the upper value of this range query
Public method GetMin
Returns the lower value of this range query
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IncludesMax
Returns
CopyC#
true
 if the upper endpoint is inclusive
Public method IncludesMin
Returns
CopyC#
true
 if the lower endpoint is inclusive
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
NewDoubleRange(String, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..Equals Method
NumericRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.NumericRangeQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.Equals(System.Object)"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..GetEnum Method
NumericRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..GetField Method
NumericRangeQuery Class See Also Send Feedback
Returns the field name for this query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetField()
Visual Basic
Public Function GetField As String
Visual C++
public:
String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetField"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..GetHashCode Method
NumericRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetHashCode"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


GetMax Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..GetMax Method
NumericRangeQuery Class See Also Send Feedback
Returns the upper value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueType GetMax()
Visual Basic
Public Function GetMax As ValueType
Visual C++
public:
ValueType^ GetMax()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetMax"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


GetMin Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..GetMin Method
NumericRangeQuery Class See Also Send Feedback
Returns the lower value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueType GetMin()
Visual Basic
Public Function GetMin As ValueType
Visual C++
public:
ValueType^ GetMin()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.GetMin"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


IncludesMax Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..IncludesMax Method
NumericRangeQuery Class See Also Send Feedback
Returns
CopyC#
true
 if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IncludesMax()
Visual Basic
Public Function IncludesMax As Boolean
Visual C++
public:
bool IncludesMax()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.IncludesMax"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


IncludesMin Method

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..IncludesMin Method
NumericRangeQuery Class See Also Send Feedback
Returns
CopyC#
true
 if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool IncludesMin()
Visual Basic
Public Function IncludesMin As Boolean
Visual C++
public:
bool IncludesMin()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.IncludesMin"]

See Also

NumericRangeQuery Class
Lucene.Net.Search Namespace


NewDoubleRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewDoubleRange Method
NumericRangeQuery Class See Also Send Feedback

Overload List

Name Description
NewDoubleRange(String, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewDoubleRange(String, Int32, Double, Double, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace


NewDoubleRange Method (String, Double, Double, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewDoubleRange Method (String, Double, Double, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewDoubleRange(
    string field,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewDoubleRange ( _
    field As String, _
    min As Double, _
    max As Double, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewDoubleRange(
    String^ field,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

min
Type: System..::..Double

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

max
Type: System..::..Double

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Double,System.Double,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewDoubleRange Overload
Lucene.Net.Search Namespace


NewDoubleRange Method (String, Int32, Double, Double, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewDoubleRange Method (String, Int32, Double, Double, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
double
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewDoubleRange(
    string field,
    int precisionStep,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewDoubleRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Double, _
    max As Double, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewDoubleRange(
    String^ field,
    int precisionStep,
    double min,
    double max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

min
Type: System..::..Double

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

max
Type: System..::..Double

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewDoubleRange(System.String,System.Int32,System.Double,System.Double,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewDoubleRange Overload
Lucene.Net.Search Namespace


NewFloatRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewFloatRange Method
NumericRangeQuery Class See Also Send Feedback

Overload List

Name Description
NewFloatRange(String, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewFloatRange(String, Int32, Single, Single, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace


NewFloatRange Method (String, Single, Single, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewFloatRange Method (String, Single, Single, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewFloatRange(
    string field,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewFloatRange ( _
    field As String, _
    min As Single, _
    max As Single, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewFloatRange(
    String^ field,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

min
Type: System..::..Single

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

max
Type: System..::..Single

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Single,System.Single,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewFloatRange Overload
Lucene.Net.Search Namespace


NewFloatRange Method (String, Int32, Single, Single, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewFloatRange Method (String, Int32, Single, Single, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
float
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewFloatRange(
    string field,
    int precisionStep,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewFloatRange ( _
    field As String, _
    precisionStep As Integer, _
    min As Single, _
    max As Single, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewFloatRange(
    String^ field,
    int precisionStep,
    float min,
    float max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

min
Type: System..::..Single

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

max
Type: System..::..Single

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewFloatRange(System.String,System.Int32,System.Single,System.Single,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewFloatRange Overload
Lucene.Net.Search Namespace


NewIntRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewIntRange Method
NumericRangeQuery Class See Also Send Feedback

Overload List

Name Description
NewIntRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewIntRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace


NewIntRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewIntRange Method (String, ValueType, ValueType, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewIntRange(
    string field,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewIntRange ( _
    field As String, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewIntRange(
    String^ field,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewIntRange Overload
Lucene.Net.Search Namespace


NewIntRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewIntRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
int
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewIntRange(
    string field,
    int precisionStep,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewIntRange ( _
    field As String, _
    precisionStep As Integer, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewIntRange(
    String^ field,
    int precisionStep,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewIntRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewIntRange Overload
Lucene.Net.Search Namespace


NewLongRange Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewLongRange Method
NumericRangeQuery Class See Also Send Feedback

Overload List

Name Description
NewLongRange(String, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.
NewLongRange(String, Int32, ValueType, ValueType, Boolean, Boolean)
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

See Also

NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace


NewLongRange Method (String, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewLongRange Method (String, ValueType, ValueType, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the default
CopyC#
precisionStep
 {@link NumericUtils#PRECISION_STEP_DEFAULT} (4). You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewLongRange(
    string field,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewLongRange ( _
    field As String, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewLongRange(
    String^ field,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewLongRange Overload
Lucene.Net.Search Namespace


NewLongRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..NewLongRange Method (String, Int32, ValueType, ValueType, Boolean, Boolean)
NumericRangeQuery Class See Also Send Feedback
Factory that creates a
CopyC#
NumericRangeQuery
, that queries a
CopyC#
long
 range using the given
CopyC#
precisionStep
. You can have half-open ranges (which are in fact </≤ or >/≥ queries) by setting the min or max value to
CopyC#
null
. By setting inclusive to false, it will match all documents excluding the bounds, with inclusive on, the boundaries are hits, too.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NumericRangeQuery NewLongRange(
    string field,
    int precisionStep,
    ValueType min,
    ValueType max,
    bool minInclusive,
    bool maxInclusive
)
Visual Basic
Public Shared Function NewLongRange ( _
    field As String, _
    precisionStep As Integer, _
    min As ValueType, _
    max As ValueType, _
    minInclusive As Boolean, _
    maxInclusive As Boolean _
) As NumericRangeQuery
Visual C++
public:
static NumericRangeQuery^ NewLongRange(
    String^ field,
    int precisionStep,
    ValueType^ min,
    ValueType^ max,
    bool minInclusive,
    bool maxInclusive
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

min
Type: System..::..ValueType

[Missing <param name="min"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

max
Type: System..::..ValueType

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

minInclusive
Type: System..::..Boolean

[Missing <param name="minInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

maxInclusive
Type: System..::..Boolean

[Missing <param name="maxInclusive"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.NewLongRange(System.String,System.Int32,System.ValueType,System.ValueType,System.Boolean,System.Boolean)"]

See Also

NumericRangeQuery Class
NewLongRange Overload
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
NumericRangeQuery..::..ToString Method
NumericRangeQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides MultiTermQuery..::..ToString(String).)

See Also

NumericRangeQuery Class
NumericRangeQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
NumericRangeQuery..::..ToString Method (String)
NumericRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.NumericRangeQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.NumericRangeQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.NumericRangeQuery.ToString(System.String)"]

See Also

NumericRangeQuery Class
ToString Overload
Lucene.Net.Search Namespace


ParallelMultiSearcher Class

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher Class
Members See Also Send Feedback
Implements parallel search over a set of
CopyC#
Searchables
.

Applications usually need only call the inherited {@link #Search(Query)} or {@link #Search(Query,Filter)} methods.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ParallelMultiSearcher : MultiSearcher
Visual Basic
Public Class ParallelMultiSearcher _
    Inherits MultiSearcher
Visual C++
public ref class ParallelMultiSearcher : public MultiSearcher

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Lucene.Net.Search..::..Searcher
Lucene.Net.Search..::..MultiSearcher
Lucene.Net.Search..::..ParallelMultiSearcher

See Also

ParallelMultiSearcher Members
Lucene.Net.Search Namespace


ParallelMultiSearcher Members

[image] [image]

Lucene.Net Class Libraries
ParallelMultiSearcher Members
ParallelMultiSearcher Class Constructors Methods See Also Send Feedback

The ParallelMultiSearcher type exposes the following members.

Constructors

 | Name | Description
Public method | ParallelMultiSearcher | Creates a searchable which searches searchables.

Methods

Name | Description
Public method | Close | (Inherited from MultiSearcher.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Inherited from MultiSearcher.)
Public method Dispose
.NET
(Inherited from MultiSearcher.)
Public method | Doc(Int32) | (Inherited from MultiSearcher.)
Public method | Doc(Int32, FieldSelector) | (Inherited from MultiSearcher.)
Public method DocFreq
TODO: parallelize this one too
(Overrides MultiSearcher..::..DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Inherited from MultiSearcher.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSearchables
Return the array of {@link Searchable}s this searches.
(Inherited from MultiSearcher.)
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

(Inherited from Searcher.)
Protected method | GetStarts | (Inherited from MultiSearcher.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc | (Inherited from MultiSearcher.)
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite | (Overrides MultiSearcher..::..Rewrite(Query).)
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

(Overrides MultiSearcher..::..Search(Weight, Filter, Collector).)
Public method Search(Weight, Filter, Int32)
A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.
(Overrides MultiSearcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method Search(Weight, Filter, Int32, Sort)
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
(Overrides MultiSearcher..::..Search(Weight, Filter, Int32, Sort).)
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
(Inherited from Searcher.)
Public method SubDoc
Returns the document number of document
CopyC#
n
 within its sub-index.
(Inherited from MultiSearcher.)
Public method SubSearcher
Returns index of the searcher for document
CopyC#
n
 in the array used to construct this searcher.
(Inherited from MultiSearcher.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ParallelMultiSearcher Class
Lucene.Net.Search Namespace


ParallelMultiSearcher Constructor

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher Constructor
ParallelMultiSearcher Class See Also Send Feedback
Creates a searchable which searches searchables.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ParallelMultiSearcher(
    params Searchable[] searchables
)
Visual Basic
Public Sub New ( _
    ParamArray searchables As Searchable() _
)
Visual C++
public:
ParallelMultiSearcher(
    ... array<Searchable^>^ searchables
)

Parameters

searchables
Type: array< Lucene.Net.Search..::..Searchable >[]()[][]

[Missing <param name="searchables"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.#ctor(Lucene.Net.Search.Searchable[])"]

See Also

ParallelMultiSearcher Class
Lucene.Net.Search Namespace


ParallelMultiSearcher Methods

[image] [image]

Lucene.Net Class Libraries
ParallelMultiSearcher Methods
ParallelMultiSearcher Class See Also Send Feedback

The ParallelMultiSearcher type exposes the following members.

Methods

Name | Description
Public method | Close | (Inherited from MultiSearcher.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
Create weight in multiple index scenario. Distributed query processing is done in the following steps: 1. rewrite query 2. extract necessary terms 3. collect dfs for these terms from the Searchables 4. create query weight using aggregate dfs. 5. distribute that weight to Searchables 6. merge results Steps 1-4 are done here, 5+6 in the search() methods
(Inherited from MultiSearcher.)
Public method Dispose
.NET
(Inherited from MultiSearcher.)
Public method | Doc(Int32) | (Inherited from MultiSearcher.)
Public method | Doc(Int32, FieldSelector) | (Inherited from MultiSearcher.)
Public method DocFreq
TODO: parallelize this one too
(Overrides MultiSearcher..::..DocFreq(Term).)
Public method | DocFreqs | (Inherited from Searcher.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Inherited from MultiSearcher.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSearchables
Return the array of {@link Searchable}s this searches.
(Inherited from MultiSearcher.)
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

(Inherited from Searcher.)
Protected method | GetStarts | (Inherited from MultiSearcher.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc | (Inherited from MultiSearcher.)
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite | (Overrides MultiSearcher..::..Rewrite(Query).)
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

(Overrides MultiSearcher..::..Search(Weight, Filter, Collector).)
Public method Search(Weight, Filter, Int32)
A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.
(Overrides MultiSearcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method Search(Weight, Filter, Int32, Sort)
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
(Overrides MultiSearcher..::..Search(Weight, Filter, Int32, Sort).)
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
(Inherited from Searcher.)
Public method SubDoc
Returns the document number of document
CopyC#
n
 within its sub-index.
(Inherited from MultiSearcher.)
Public method SubSearcher
Returns index of the searcher for document
CopyC#
n
 in the array used to construct this searcher.
(Inherited from MultiSearcher.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ParallelMultiSearcher Class
Lucene.Net.Search Namespace


Doc Method

[image] [image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Doc Method
ParallelMultiSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Doc(Int32) | (Inherited from MultiSearcher.)
Public method | Doc(Int32, FieldSelector) | (Inherited from MultiSearcher.)

See Also

ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..DocFreq Method
ParallelMultiSearcher Class See Also Send Feedback
TODO: parallelize this one too

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocFreq(
    Term term
)
Visual Basic
Public Overrides Function DocFreq ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.DocFreq(Lucene.Net.Index.Term)"]

Implements

Searchable..::..DocFreq(Term)

See Also

ParallelMultiSearcher Class
Lucene.Net.Search Namespace


Explain Method

[image] [image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Explain Method
ParallelMultiSearcher Class See Also Send Feedback

Overload List

Name | Description
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

(Inherited from Searcher.)
Public method | Explain(Weight, Int32) | (Inherited from MultiSearcher.)

See Also

ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..MemberwiseClone Method
ParallelMultiSearcher Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Rewrite Method
ParallelMultiSearcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Rewrite(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    Query original
)
Visual Basic
Public Overrides Function Rewrite ( _
    original As Query _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    Query^ original
) override

Parameters

original
Type: Lucene.Net.Search..::..Query

[Missing <param name="original"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Rewrite(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Rewrite(Lucene.Net.Search.Query)"]

Implements

Searchable..::..Rewrite(Query)

See Also

ParallelMultiSearcher Class
Lucene.Net.Search Namespace


Search Method

[image] [image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Search Method
ParallelMultiSearcher Class See Also Send Feedback

Overload List

Name | Description
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
(Inherited from Searcher.)
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
(Inherited from Searcher.)
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

(Inherited from Searcher.)
Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
(Inherited from Searcher.)
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
(Inherited from Searcher.)
Public method Search(Weight, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

(Overrides MultiSearcher..::..Search(Weight, Filter, Collector).)
Public method Search(Weight, Filter, Int32)
A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.
(Overrides MultiSearcher..::..Search(Weight, Filter, Int32).)
Public method | Search(Weight, Filter, HitCollector) | Obsolete. (Inherited from Searcher.)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

(Inherited from Searcher.)
Public method Search(Weight, Filter, Int32, Sort)
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.
(Overrides MultiSearcher..::..Search(Weight, Filter, Int32, Sort).)

See Also

ParallelMultiSearcher Class
ParallelMultiSearcher Members
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Collector)

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Search Method (Weight, Filter, Collector)
ParallelMultiSearcher Class See Also Send Feedback
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Visual Basic
Public Overrides Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Visual C++
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight
to match documents
filter
Type: Lucene.Net.Search..::..Filter
if non-null, a bitset used to eliminate some documents
collector
Type: Lucene.Net.Search..::..Collector
to receive hits TODO: parallelize this one too

Implements

Searchable..::..Search(Weight, Filter, Collector)

See Also

ParallelMultiSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32)

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Search Method (Weight, Filter, Int32)
ParallelMultiSearcher Class See Also Send Feedback
A search implementation which spans a new thread for each Searchable, waits for each search to complete and merge the results back together.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopDocs Search(
    Weight weight,
    Filter filter,
    int nDocs
)
Visual Basic
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

nDocs
Type: System..::..Int32

[Missing <param name="nDocs"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Implements

Searchable..::..Search(Weight, Filter, Int32)

See Also

ParallelMultiSearcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32, Sort)

[image]

Lucene.Net Class Libraries
ParallelMultiSearcher..::..Search Method (Weight, Filter, Int32, Sort)
ParallelMultiSearcher Class See Also Send Feedback
A search implementation allowing sorting which spans a new thread for each Searchable, waits for each search to complete and merges the results back together.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int nDocs,
    Sort sort
)
Visual Basic
Public Overrides Function Search ( _
    weight As Weight, _
    filter As Filter, _
    nDocs As Integer, _
    sort As Sort _
) As TopFieldDocs
Visual C++
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int nDocs,
    Sort^ sort
) override

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

nDocs
Type: System..::..Int32

[Missing <param name="nDocs"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ParallelMultiSearcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Implements

Searchable..::..Search(Weight, Filter, Int32, Sort)

See Also

ParallelMultiSearcher Class
Search Overload
Lucene.Net.Search Namespace


Parser Interface

[image]

Lucene.Net Class Libraries
Parser Interface
See Also Send Feedback
Marker interface as super-interface to all parsers. It is used to specify a custom parser to {@link SortField#SortField(String, FieldCache.Parser)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface Parser
Visual Basic
Public Interface Parser
Visual C++
public interface class Parser

See Also

Lucene.Net.Search Namespace


PhraseQuery Class

[image]

Lucene.Net Class Libraries
PhraseQuery Class
Members See Also Send Feedback
A Query that matches documents containing a particular sequence of terms. A PhraseQuery is built by QueryParser for input like
CopyC#
"new york"
.

This query may be combined with other terms or queries with a {@link BooleanQuery}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PhraseQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class PhraseQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class PhraseQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..PhraseQuery

See Also

PhraseQuery Members
Lucene.Net.Search Namespace


PhraseQuery Members

[image] [image]

Lucene.Net Class Libraries
PhraseQuery Members
PhraseQuery Class Constructors Methods See Also Send Feedback

The PhraseQuery type exposes the following members.

Constructors

 | Name | Description
Public method | PhraseQuery | Constructs an empty phrase query.

Methods

Name | Description
Public method Add(Term)
Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Public method Add(Term, Int32)
Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetPositions
Returns the relative positions of terms in this phrase.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Returns the slop. See setSlop().
Public method GetTerms
Returns the set of terms in this phrase.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetSlop
Sets the number of other words permitted between words in query phrase. If zero, then this is an exact phrase search. For larger values this works like a
CopyC#
WITHIN
 or
CopyC#
NEAR
 operator.

The slop is in fact an edit-distance, where the units correspond to moves of terms in the query phrase out of position. For example, to switch the order of two words requires two moves (the first move places the words atop one another), so to permit re-orderings of phrases, the slop must be at least two.

More exact matches are scored higher than sloppier matches, thus search results are sorted by exactness.

The slop is zero by default, requiring exact matches.

Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


PhraseQuery Constructor

[image]

Lucene.Net Class Libraries
PhraseQuery Constructor
PhraseQuery Class See Also Send Feedback
Constructs an empty phrase query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PhraseQuery()
Visual Basic
Public Sub New
Visual C++
public:
PhraseQuery()

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


PhraseQuery Methods

[image] [image]

Lucene.Net Class Libraries
PhraseQuery Methods
PhraseQuery Class See Also Send Feedback

The PhraseQuery type exposes the following members.

Methods

Name | Description
Public method Add(Term)
Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Public method Add(Term, Int32)
Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetPositions
Returns the relative positions of terms in this phrase.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Returns the slop. See setSlop().
Public method GetTerms
Returns the set of terms in this phrase.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetSlop
Sets the number of other words permitted between words in query phrase. If zero, then this is an exact phrase search. For larger values this works like a
CopyC#
WITHIN
 or
CopyC#
NEAR
 operator.

The slop is in fact an edit-distance, where the units correspond to moves of terms in the query phrase out of position. For example, to switch the order of two words requires two moves (the first move places the words atop one another), so to permit re-orderings of phrases, the slop must be at least two.

More exact matches are scored higher than sloppier matches, thus search results are sorted by exactness.

The slop is zero by default, requiring exact matches.

Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
PhraseQuery..::..Add Method
PhraseQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Term) | Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.
Public method | Add(Term, Int32) | Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

See Also

PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace


Add Method (Term)

[image]

Lucene.Net Class Libraries
PhraseQuery..::..Add Method (Term)
PhraseQuery Class See Also Send Feedback
Adds a term to the end of the query phrase. The relative position of the term is the one immediately after the last term added.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Term term
)
Visual Basic
Public Overridable Sub Add ( _
    term As Term _
)
Visual C++
public:
virtual void Add(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.PhraseQuery.Add(Lucene.Net.Index.Term)"]

See Also

PhraseQuery Class
Add Overload
Lucene.Net.Search Namespace


Add Method (Term, Int32)

[image]

Lucene.Net Class Libraries
PhraseQuery..::..Add Method (Term, Int32)
PhraseQuery Class See Also Send Feedback
Adds a term to the end of the query phrase. The relative position of the term within the phrase is specified explicitly. This allows e.g. phrases with more than one term at the same position or phrases with gaps (e.g. in connection with stopwords).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Add(
    Term term,
    int position
)
Visual Basic
Public Overridable Sub Add ( _
    term As Term, _
    position As Integer _
)
Visual C++
public:
virtual void Add(
    Term^ term,
    int position
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.PhraseQuery.Add(Lucene.Net.Index.Term,System.Int32)"]

position
Type: System..::..Int32

[Missing <param name="position"/> documentation for "M:Lucene.Net.Search.PhraseQuery.Add(Lucene.Net.Index.Term,System.Int32)"]

See Also

PhraseQuery Class
Add Overload
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..CreateWeight Method
PhraseQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PhraseQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.PhraseQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..Equals Method
PhraseQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.PhraseQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.Equals(System.Object)"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..ExtractTerms Method
PhraseQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PhraseQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable queryTerms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    queryTerms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ queryTerms
) override

Parameters

queryTerms
Type: System.Collections..::..Hashtable

[Missing <param name="queryTerms"/> documentation for "M:Lucene.Net.Search.PhraseQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace
[!:Lucene.Net.Search.Query.ExtractTerms(java.util.Set)]


GetHashCode Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..GetHashCode Method
PhraseQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.GetHashCode"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


GetPositions Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..GetPositions Method
PhraseQuery Class See Also Send Feedback
Returns the relative positions of terms in this phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int[] GetPositions()
Visual Basic
Public Overridable Function GetPositions As Integer()
Visual C++
public:
virtual array<int>^ GetPositions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.GetPositions"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


GetSlop Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..GetSlop Method
PhraseQuery Class See Also Send Feedback
Returns the slop. See setSlop().

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetSlop()
Visual Basic
Public Overridable Function GetSlop As Integer
Visual C++
public:
virtual int GetSlop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.GetSlop"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..GetTerms Method
PhraseQuery Class See Also Send Feedback
Returns the set of terms in this phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term[] GetTerms()
Visual Basic
Public Overridable Function GetTerms As Term()
Visual C++
public:
virtual array<Term^>^ GetTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.GetTerms"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


SetSlop Method

[image]

Lucene.Net Class Libraries
PhraseQuery..::..SetSlop Method
PhraseQuery Class See Also Send Feedback
Sets the number of other words permitted between words in query phrase. If zero, then this is an exact phrase search. For larger values this works like a
CopyC#
WITHIN
 or
CopyC#
NEAR
 operator.

The slop is in fact an edit-distance, where the units correspond to moves of terms in the query phrase out of position. For example, to switch the order of two words requires two moves (the first move places the words atop one another), so to permit re-orderings of phrases, the slop must be at least two.

More exact matches are scored higher than sloppier matches, thus search results are sorted by exactness.

The slop is zero by default, requiring exact matches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSlop(
    int s
)
Visual Basic
Public Overridable Sub SetSlop ( _
    s As Integer _
)
Visual C++
public:
virtual void SetSlop(
    int s
)

Parameters

s
Type: System..::..Int32

[Missing <param name="s"/> documentation for "M:Lucene.Net.Search.PhraseQuery.SetSlop(System.Int32)"]

See Also

PhraseQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
PhraseQuery..::..ToString Method
PhraseQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

PhraseQuery Class
PhraseQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
PhraseQuery..::..ToString Method (String)
PhraseQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string f
)
Visual Basic
Public Overrides Function ToString ( _
    f As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ f
) override

Parameters

f
Type: System..::..String

[Missing <param name="f"/> documentation for "M:Lucene.Net.Search.PhraseQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PhraseQuery.ToString(System.String)"]

See Also

PhraseQuery Class
ToString Overload
Lucene.Net.Search Namespace


PositiveScoresOnlyCollector Class

[image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector Class
Members See Also Send Feedback
A {@link Collector} implementation which wraps another {@link Collector} and makes sure only documents with scores > 0 are collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PositiveScoresOnlyCollector : Collector
Visual Basic
Public Class PositiveScoresOnlyCollector _
    Inherits Collector
Visual C++
public ref class PositiveScoresOnlyCollector : public Collector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..PositiveScoresOnlyCollector

See Also

PositiveScoresOnlyCollector Members
Lucene.Net.Search Namespace


PositiveScoresOnlyCollector Members

[image] [image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector Members
PositiveScoresOnlyCollector Class Constructors Methods See Also Send Feedback

The PositiveScoresOnlyCollector type exposes the following members.

Constructors

 | Name | Description
Public method | PositiveScoresOnlyCollector | Initializes a new instance of the PositiveScoresOnlyCollector class

Methods

 | Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method | Collect | (Overrides Collector..::..Collect(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


PositiveScoresOnlyCollector Constructor

[image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector Constructor
PositiveScoresOnlyCollector Class See Also Send Feedback
Initializes a new instance of the PositiveScoresOnlyCollector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PositiveScoresOnlyCollector(
    Collector c
)
Visual Basic
Public Sub New ( _
    c As Collector _
)
Visual C++
public:
PositiveScoresOnlyCollector(
    Collector^ c
)

Parameters

c
Type: Lucene.Net.Search..::..Collector

[Missing <param name="c"/> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.#ctor(Lucene.Net.Search.Collector)"]

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


PositiveScoresOnlyCollector Methods

[image] [image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector Methods
PositiveScoresOnlyCollector Class See Also Send Feedback

The PositiveScoresOnlyCollector type exposes the following members.

Methods

 | Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method | Collect | (Overrides Collector..::..Collect(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


AcceptsDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector..::..AcceptsDocsOutOfOrder Method
PositiveScoresOnlyCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.AcceptsDocsOutOfOrder"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool AcceptsDocsOutOfOrder()
Visual Basic
Public Overrides Function AcceptsDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool AcceptsDocsOutOfOrder() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.AcceptsDocsOutOfOrder"]

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector..::..Collect Method
PositiveScoresOnlyCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.Collect(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Collect(
    int doc
)
Visual Basic
Public Overrides Sub Collect ( _
    doc As Integer _
)
Visual C++
public:
virtual void Collect(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.Collect(System.Int32)"]

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector..::..SetNextReader Method
PositiveScoresOnlyCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int docBase
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    docBase As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int docBase
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

docBase
Type: System..::..Int32

[Missing <param name="docBase"/> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
PositiveScoresOnlyCollector..::..SetScorer Method
PositiveScoresOnlyCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.SetScorer(Lucene.Net.Search.Scorer)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetScorer(
    Scorer scorer
)
Visual Basic
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
) override

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.PositiveScoresOnlyCollector.SetScorer(Lucene.Net.Search.Scorer)"]

See Also

PositiveScoresOnlyCollector Class
Lucene.Net.Search Namespace


PrefixFilter Class

[image]

Lucene.Net Class Libraries
PrefixFilter Class
Members See Also Send Feedback
A Filter that restricts search results to values that have a matching prefix in a given field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PrefixFilter : MultiTermQueryWrapperFilter
Visual Basic
<SerializableAttribute> _
Public Class PrefixFilter _
    Inherits MultiTermQueryWrapperFilter
Visual C++
[SerializableAttribute]
public ref class PrefixFilter : public MultiTermQueryWrapperFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..MultiTermQueryWrapperFilter
Lucene.Net.Search..::..PrefixFilter

See Also

PrefixFilter Members
Lucene.Net.Search Namespace


PrefixFilter Members

[image] [image]

Lucene.Net Class Libraries
PrefixFilter Members
PrefixFilter Class Constructors Methods Fields See Also Send Feedback

The PrefixFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PrefixFilter | Initializes a new instance of the PrefixFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not. (Inherited from MultiTermQueryWrapperFilter.)
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Returns a DocIdSet with documents that should be permitted in search results. (Inherited from MultiTermQueryWrapperFilter.)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method | GetPrefix |
Public method | GetTotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}. (Inherited from MultiTermQueryWrapperFilter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Prints a user-readable version of this query. (Overrides MultiTermQueryWrapperFilter..::..ToString()()()().)

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

PrefixFilter Class
Lucene.Net.Search Namespace


PrefixFilter Constructor

[image]

Lucene.Net Class Libraries
PrefixFilter Constructor
PrefixFilter Class See Also Send Feedback
Initializes a new instance of the PrefixFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PrefixFilter(
    Term prefix
)
Visual Basic
Public Sub New ( _
    prefix As Term _
)
Visual C++
public:
PrefixFilter(
    Term^ prefix
)

Parameters

prefix
Type: Lucene.Net.Index..::..Term

[Missing <param name="prefix"/> documentation for "M:Lucene.Net.Search.PrefixFilter.#ctor(Lucene.Net.Index.Term)"]

See Also

PrefixFilter Class
Lucene.Net.Search Namespace


PrefixFilter Fields

[image] [image]

Lucene.Net Class Libraries
PrefixFilter Fields
PrefixFilter Class See Also Send Feedback

The PrefixFilter type exposes the following members.

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

PrefixFilter Class
Lucene.Net.Search Namespace


PrefixFilter Methods

[image] [image]

Lucene.Net Class Libraries
PrefixFilter Methods
PrefixFilter Class See Also Send Feedback

The PrefixFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not. (Inherited from MultiTermQueryWrapperFilter.)
Public method | ClearTotalNumberOfTerms | Expert: Resets the counting of unique terms. Do this before executing the filter. (Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Returns a DocIdSet with documents that should be permitted in search results. (Inherited from MultiTermQueryWrapperFilter.)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method | GetPrefix |
Public method | GetTotalNumberOfTerms | Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index. This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}. (Inherited from MultiTermQueryWrapperFilter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Prints a user-readable version of this query. (Overrides MultiTermQueryWrapperFilter..::..ToString()()()().)

See Also

PrefixFilter Class
Lucene.Net.Search Namespace


GetPrefix Method

[image]

Lucene.Net Class Libraries
PrefixFilter..::..GetPrefix Method
PrefixFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixFilter.GetPrefix"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term GetPrefix()
Visual Basic
Public Overridable Function GetPrefix As Term
Visual C++
public:
virtual Term^ GetPrefix()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixFilter.GetPrefix"]

See Also

PrefixFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
PrefixFilter..::..ToString Method
PrefixFilter Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixFilter.ToString"]

See Also

PrefixFilter Class
Lucene.Net.Search Namespace


PrefixQuery Class

[image]

Lucene.Net Class Libraries
PrefixQuery Class
Members See Also Send Feedback
A Query that matches documents containing terms with a specified prefix. A PrefixQuery is built by QueryParser for input like
CopyC#
app*
.

This query uses the {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} rewrite method.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PrefixQuery : MultiTermQuery
Visual Basic
<SerializableAttribute> _
Public Class PrefixQuery _
    Inherits MultiTermQuery
Visual C++
[SerializableAttribute]
public ref class PrefixQuery : public MultiTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..PrefixQuery

See Also

PrefixQuery Members
Lucene.Net.Search Namespace


PrefixQuery Members

[image] [image]

Lucene.Net Class Libraries
PrefixQuery Members
PrefixQuery Class Constructors Methods Fields See Also Send Feedback

The PrefixQuery type exposes the following members.

Constructors

Name Description
Public method PrefixQuery
Constructs a query for terms starting with
CopyC#
prefix
.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetPrefix
Returns the prefix of this query.
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


PrefixQuery Constructor

[image]

Lucene.Net Class Libraries
PrefixQuery Constructor
PrefixQuery Class See Also Send Feedback
Constructs a query for terms starting with
CopyC#
prefix
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PrefixQuery(
    Term prefix
)
Visual Basic
Public Sub New ( _
    prefix As Term _
)
Visual C++
public:
PrefixQuery(
    Term^ prefix
)

Parameters

prefix
Type: Lucene.Net.Index..::..Term

[Missing <param name="prefix"/> documentation for "M:Lucene.Net.Search.PrefixQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


PrefixQuery Fields

[image] [image]

Lucene.Net Class Libraries
PrefixQuery Fields
PrefixQuery Class See Also Send Feedback

The PrefixQuery type exposes the following members.

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


PrefixQuery Methods

[image] [image]

Lucene.Net Class Libraries
PrefixQuery Methods
PrefixQuery Class See Also Send Feedback

The PrefixQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetPrefix
Returns the prefix of this query.
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PrefixQuery..::..Equals Method
PrefixQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.PrefixQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixQuery.Equals(System.Object)"]

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
PrefixQuery..::..GetEnum Method
PrefixQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.PrefixQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
PrefixQuery..::..GetHashCode Method
PrefixQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixQuery.GetHashCode"]

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


GetPrefix Method

[image]

Lucene.Net Class Libraries
PrefixQuery..::..GetPrefix Method
PrefixQuery Class See Also Send Feedback
Returns the prefix of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term GetPrefix()
Visual Basic
Public Overridable Function GetPrefix As Term
Visual C++
public:
virtual Term^ GetPrefix()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixQuery.GetPrefix"]

See Also

PrefixQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
PrefixQuery..::..ToString Method
PrefixQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides MultiTermQuery..::..ToString(String).)

See Also

PrefixQuery Class
PrefixQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
PrefixQuery..::..ToString Method (String)
PrefixQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.PrefixQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixQuery.ToString(System.String)"]

See Also

PrefixQuery Class
ToString Overload
Lucene.Net.Search Namespace


PrefixTermEnum Class

[image]

Lucene.Net Class Libraries
PrefixTermEnum Class
Members See Also Send Feedback
Subclass of FilteredTermEnum for enumerating all terms that match the specified prefix filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PrefixTermEnum : FilteredTermEnum
Visual Basic
Public Class PrefixTermEnum _
    Inherits FilteredTermEnum
Visual C++
public ref class PrefixTermEnum : public FilteredTermEnum

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Search..::..FilteredTermEnum
Lucene.Net.Search..::..PrefixTermEnum

See Also

PrefixTermEnum Members
Lucene.Net.Search Namespace


PrefixTermEnum Members

[image] [image]

Lucene.Net Class Libraries
PrefixTermEnum Members
PrefixTermEnum Class Constructors Methods Fields See Also Send Feedback

The PrefixTermEnum type exposes the following members.

Constructors

 | Name | Description
Public method | PrefixTermEnum | Initializes a new instance of the PrefixTermEnum class

Methods

Name | Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method | GetPrefixTerm
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | TermCompare | (Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


PrefixTermEnum Constructor

[image]

Lucene.Net Class Libraries
PrefixTermEnum Constructor
PrefixTermEnum Class See Also Send Feedback
Initializes a new instance of the PrefixTermEnum class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PrefixTermEnum(
    IndexReader reader,
    Term prefix
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    prefix As Term _
)
Visual C++
public:
PrefixTermEnum(
    IndexReader^ reader,
    Term^ prefix
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.PrefixTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term)"]

prefix
Type: Lucene.Net.Index..::..Term

[Missing <param name="prefix"/> documentation for "M:Lucene.Net.Search.PrefixTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term)"]

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


PrefixTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
PrefixTermEnum Fields
PrefixTermEnum Class See Also Send Feedback

The PrefixTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


PrefixTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
PrefixTermEnum Methods
PrefixTermEnum Class See Also Send Feedback

The PrefixTermEnum type exposes the following members.

Methods

Name | Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method | GetPrefixTerm
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | TermCompare | (Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


Difference Method

[image]

Lucene.Net Class Libraries
PrefixTermEnum..::..Difference Method
PrefixTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixTermEnum.Difference"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Difference()
Visual Basic
Public Overrides Function Difference As Single
Visual C++
public:
virtual float Difference() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixTermEnum.Difference"]

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


EndEnum Method

[image]

Lucene.Net Class Libraries
PrefixTermEnum..::..EndEnum Method
PrefixTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixTermEnum.EndEnum"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool EndEnum()
Visual Basic
Public Overrides Function EndEnum As Boolean
Visual C++
public:
virtual bool EndEnum() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixTermEnum.EndEnum"]

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


GetPrefixTerm Method

[image]

Lucene.Net Class Libraries
PrefixTermEnum..::..GetPrefixTerm Method
PrefixTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixTermEnum.GetPrefixTerm"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Term GetPrefixTerm()
Visual Basic
Protected Friend Overridable Function GetPrefixTerm As Term
Visual C++
protected public:
virtual Term^ GetPrefixTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixTermEnum.GetPrefixTerm"]

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


TermCompare Method

[image]

Lucene.Net Class Libraries
PrefixTermEnum..::..TermCompare Method
PrefixTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.PrefixTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool TermCompare(
    Term term
)
Visual Basic
Public Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Visual C++
public:
virtual bool TermCompare(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.PrefixTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.PrefixTermEnum.TermCompare(Lucene.Net.Index.Term)"]

See Also

PrefixTermEnum Class
Lucene.Net.Search Namespace


Query Class

[image]

Lucene.Net Class Libraries
Query Class
Members See Also Send Feedback
The abstract base class for queries.

Instantiable subclasses are:

  • {@link TermQuery}
  • {@link MultiTermQuery}
  • {@link BooleanQuery}
  • {@link WildcardQuery}
  • {@link PhraseQuery}
  • {@link PrefixQuery}
  • {@link MultiPhraseQuery}
  • {@link FuzzyQuery}
  • {@link TermRangeQuery}
  • {@link NumericRangeQuery}
  • {@link Lucene.Net.Search.Spans.SpanQuery}

A parser for queries is contained in:

  • {@link Lucene.Net.QueryParsers.QueryParser QueryParser}

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class Query : ICloneable
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Query _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class Query abstract : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..BooleanQuery
Lucene.Net.Search..::..BoostingQuery
Lucene.Net.Search..::..ConstantScoreQuery
Lucene.Net.Search..::..DisjunctionMaxQuery
Lucene.Net.Search..::..FilteredQuery
Lucene.Net.Search.Function..::..CustomScoreQuery
Lucene.Net.Search.Function..::..ValueSourceQuery
Lucene.Net.Search..::..FuzzyLikeThisQuery
Lucene.Net.Search..::..MatchAllDocsQuery
Lucene.Net.Search..::..MultiPhraseQuery
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..PhraseQuery
Lucene.Net.Search..::..RangeQuery
Lucene.Net.Search.Similar..::..MoreLikeThisQuery
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search..::..TermQuery

See Also

Query Members
Lucene.Net.Search Namespace


Query Members

[image] [image]

Lucene.Net Class Libraries
Query Members
Query Class Constructors Methods See Also Send Feedback

The Query type exposes the following members.

Constructors

 | Name | Description
Protected method | Query | Initializes a new instance of the Query class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
MergeBooleanQueries
Expert: merges the clauses of a set of BooleanQuery's into a single BooleanQuery.

A utility for use by {@link #Combine(Query[])} implementations.

Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
Public method ToString()()()()
Prints a query to a string.
(Overrides Object..::..ToString()()()().)
Public method ToString(String)
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.

See Also

Query Class
Lucene.Net.Search Namespace


Query Constructor

[image]

Lucene.Net Class Libraries
Query Constructor
Query Class See Also Send Feedback
Initializes a new instance of the Query class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Query()
Visual Basic
Protected Sub New
Visual C++
protected:
Query()

See Also

Query Class
Lucene.Net.Search Namespace


Query Methods

[image] [image]

Lucene.Net Class Libraries
Query Methods
Query Class See Also Send Feedback

The Query type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
MergeBooleanQueries
Expert: merges the clauses of a set of BooleanQuery's into a single BooleanQuery.

A utility for use by {@link #Combine(Query[])} implementations.

Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
Public method ToString()()()()
Prints a query to a string.
(Overrides Object..::..ToString()()()().)
Public method ToString(String)
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.

See Also

Query Class
Lucene.Net.Search Namespace


Clone Method

[image]

Lucene.Net Class Libraries
Query..::..Clone Method
Query Class See Also Send Feedback
Returns a clone of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

Query Class
Lucene.Net.Search Namespace


Combine Method

[image]

Lucene.Net Class Libraries
Query..::..Combine Method
Query Class See Also Send Feedback
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query Combine(
    Query[] queries
)
Visual Basic
Public Overridable Function Combine ( _
    queries As Query() _
) As Query
Visual C++
public:
virtual Query^ Combine(
    array<Query^>^ queries
)

Parameters

queries
Type: array< Lucene.Net.Search..::..Query >[]()[][]

[Missing <param name="queries"/> documentation for "M:Lucene.Net.Search.Query.Combine(Lucene.Net.Search.Query[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.Combine(Lucene.Net.Search.Query[])"]

See Also

Query Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
Query..::..CreateWeight Method
Query Class See Also Send Feedback
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overridable Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
)

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Query.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

Query Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Query..::..Equals Method
Query Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Query.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Query.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.Equals(System.Object)"]

See Also

Query Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
Query..::..ExtractTerms Method
Query Class See Also Send Feedback
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overridable Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
)

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Query.ExtractTerms(System.Collections.Hashtable)"]

See Also

Query Class
Lucene.Net.Search Namespace


GetBoost Method

[image]

Lucene.Net Class Libraries
Query..::..GetBoost Method
Query Class See Also Send Feedback
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetBoost()
Visual Basic
Public Overridable Function GetBoost As Single
Visual C++
public:
virtual float GetBoost()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.GetBoost"]

See Also

Query Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Query..::..GetHashCode Method
Query Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Query.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.GetHashCode"]

See Also

Query Class
Lucene.Net.Search Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
Query..::..GetSimilarity Method
Query Class See Also Send Feedback
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Similarity GetSimilarity(
    Searcher searcher
)
Visual Basic
Public Overridable Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
)

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Query.GetSimilarity(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.GetSimilarity(Lucene.Net.Search.Searcher)"]

See Also

Query Class
Lucene.Net.Search Namespace


MergeBooleanQueries Method

[image]

Lucene.Net Class Libraries
Query..::..MergeBooleanQueries Method
Query Class See Also Send Feedback
Expert: merges the clauses of a set of BooleanQuery's into a single BooleanQuery.

A utility for use by {@link #Combine(Query[])} implementations.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Query MergeBooleanQueries(
    BooleanQuery[] queries
)
Visual Basic
Public Shared Function MergeBooleanQueries ( _
    queries As BooleanQuery() _
) As Query
Visual C++
public:
static Query^ MergeBooleanQueries(
    array<BooleanQuery^>^ queries
)

Parameters

queries
Type: array< Lucene.Net.Search..::..BooleanQuery >[]()[][]

[Missing <param name="queries"/> documentation for "M:Lucene.Net.Search.Query.MergeBooleanQueries(Lucene.Net.Search.BooleanQuery[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.MergeBooleanQueries(Lucene.Net.Search.BooleanQuery[])"]

See Also

Query Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
Query..::..Rewrite Method
Query Class See Also Send Feedback
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overridable Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Query.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

Query Class
Lucene.Net.Search Namespace


SetBoost Method

[image]

Lucene.Net Class Libraries
Query..::..SetBoost Method
Query Class See Also Send Feedback
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetBoost(
    float b
)
Visual Basic
Public Overridable Sub SetBoost ( _
    b As Single _
)
Visual C++
public:
virtual void SetBoost(
    float b
)

Parameters

b
Type: System..::..Single

[Missing <param name="b"/> documentation for "M:Lucene.Net.Search.Query.SetBoost(System.Single)"]

See Also

Query Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
Query..::..ToString Method
Query Class See Also Send Feedback

Overload List

Name Description
Public method ToString()()()()
Prints a query to a string.
(Overrides Object..::..ToString()()()().)
Public method ToString(String)
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.

See Also

Query Class
Query Members
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Query..::..ToString Method
Query Class See Also Send Feedback
Prints a query to a string.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.ToString"]

See Also

Query Class
ToString Overload
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
Query..::..ToString Method (String)
Query Class See Also Send Feedback
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string ToString(
    string field
)
Visual Basic
Public MustOverride Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) abstract

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Query.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.ToString(System.String)"]

See Also

Query Class
ToString Overload
Lucene.Net.Search Namespace


Weight Method

[image]

Lucene.Net Class Libraries
Query..::..Weight Method
Query Class See Also Send Feedback
Expert: Constructs and initializes a Weight for a top-level query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Weight Weight(
    Searcher searcher
)
Visual Basic
Public Overridable Function Weight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ Weight(
    Searcher^ searcher
)

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Query.Weight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Query.Weight(Lucene.Net.Search.Searcher)"]

See Also

Query Class
Lucene.Net.Search Namespace


QueryFilter Class

[image]

Lucene.Net Class Libraries
QueryFilter Class
Members See Also Send Feedback
Constrains search results to only match those which also match a provided query. Results are cached, so that searches after the first on the same index using this filter are much faster.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("use a CachingWrapperFilter with QueryWrapperFilter")]
public class QueryFilter : CachingWrapperFilter
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("use a CachingWrapperFilter with QueryWrapperFilter")> _
Public Class QueryFilter _
    Inherits CachingWrapperFilter
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"use a CachingWrapperFilter with QueryWrapperFilter")]
public ref class QueryFilter : public CachingWrapperFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..CachingWrapperFilter
Lucene.Net.Search..::..QueryFilter

See Also

QueryFilter Members
Lucene.Net.Search Namespace


QueryFilter Members

[image] [image]

Lucene.Net Class Libraries
QueryFilter Members
QueryFilter Class Constructors Methods Fields See Also Send Feedback

The QueryFilter type exposes the following members.

Constructors

Name Description
Public method QueryFilter
Constructs a filter which only matches documents matching
CopyC#
query
.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from CachingWrapperFilter.)
Protected method | DocIdSetToCache | Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet. (Inherited from CachingWrapperFilter.)
Public method | Equals | (Overrides CachingWrapperFilter..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Inherited from CachingWrapperFilter.)
Public method | GetHashCode | (Overrides CachingWrapperFilter..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from CachingWrapperFilter.)

Fields

 | Name | Description
Protected field | filter | (Inherited from CachingWrapperFilter.)
Public field | hitCount | (Inherited from CachingWrapperFilter.)
Public field | missCount | (Inherited from CachingWrapperFilter.)

See Also

QueryFilter Class
Lucene.Net.Search Namespace


QueryFilter Constructor

[image]

Lucene.Net Class Libraries
QueryFilter Constructor
QueryFilter Class See Also Send Feedback
Constructs a filter which only matches documents matching
CopyC#
query
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryFilter(
    Query query
)
Visual Basic
Public Sub New ( _
    query As Query _
)
Visual C++
public:
QueryFilter(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.QueryFilter.#ctor(Lucene.Net.Search.Query)"]

See Also

QueryFilter Class
Lucene.Net.Search Namespace


QueryFilter Fields

[image] [image]

Lucene.Net Class Libraries
QueryFilter Fields
QueryFilter Class See Also Send Feedback

The QueryFilter type exposes the following members.

Fields

 | Name | Description
Protected field | filter | (Inherited from CachingWrapperFilter.)
Public field | hitCount | (Inherited from CachingWrapperFilter.)
Public field | missCount | (Inherited from CachingWrapperFilter.)

See Also

QueryFilter Class
Lucene.Net.Search Namespace


QueryFilter Methods

[image] [image]

Lucene.Net Class Libraries
QueryFilter Methods
QueryFilter Class See Also Send Feedback

The QueryFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from CachingWrapperFilter.)
Protected method | DocIdSetToCache | Provide the DocIdSet to be cached, using the DocIdSet provided by the wrapped Filter. This implementation returns the given DocIdSet. (Inherited from CachingWrapperFilter.)
Public method | Equals | (Overrides CachingWrapperFilter..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Inherited from CachingWrapperFilter.)
Public method | GetHashCode | (Overrides CachingWrapperFilter..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from CachingWrapperFilter.)

See Also

QueryFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
QueryFilter..::..Equals Method
QueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.QueryFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryFilter.Equals(System.Object)"]

See Also

QueryFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
QueryFilter..::..GetHashCode Method
QueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryFilter.GetHashCode"]

See Also

QueryFilter Class
Lucene.Net.Search Namespace


QueryTermVector Class

[image]

Lucene.Net Class Libraries
QueryTermVector Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.QueryTermVector"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class QueryTermVector : TermFreqVector
Visual Basic
Public Class QueryTermVector _
    Implements TermFreqVector
Visual C++
public ref class QueryTermVector : TermFreqVector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..QueryTermVector

See Also

QueryTermVector Members
Lucene.Net.Search Namespace


QueryTermVector Members

[image] [image]

Lucene.Net Class Libraries
QueryTermVector Members
QueryTermVector Class Constructors Methods See Also Send Feedback

The QueryTermVector type exposes the following members.

Constructors

 | Name | Description
Public method | QueryTermVector(array<String>[]()[][]) | Initializes a new instance of the QueryTermVector class
Public method | QueryTermVector(String, Analyzer) | Initializes a new instance of the QueryTermVector class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTermFrequencies |
Public method | GetTerms |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexesOf |
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


QueryTermVector Constructor

[image] [image]

Lucene.Net Class Libraries
QueryTermVector Constructor
QueryTermVector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryTermVector(array<String>[]()[][]) | Initializes a new instance of the QueryTermVector class
Public method | QueryTermVector(String, Analyzer) | Initializes a new instance of the QueryTermVector class

See Also

QueryTermVector Class
QueryTermVector Members
Lucene.Net.Search Namespace


QueryTermVector Constructor (String[])

[image]

Lucene.Net Class Libraries
QueryTermVector Constructor (array<String>[]()[][])
QueryTermVector Class See Also Send Feedback
Initializes a new instance of the QueryTermVector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryTermVector(
    string[] queryTerms
)
Visual Basic
Public Sub New ( _
    queryTerms As String() _
)
Visual C++
public:
QueryTermVector(
    array<String^>^ queryTerms
)

Parameters

queryTerms
Type: array< System..::..String >[]()[][]
The original list of terms from the query, can contain duplicates

See Also

QueryTermVector Class
QueryTermVector Overload
Lucene.Net.Search Namespace


QueryTermVector Constructor (String, Analyzer)

[image]

Lucene.Net Class Libraries
QueryTermVector Constructor (String, Analyzer)
QueryTermVector Class See Also Send Feedback
Initializes a new instance of the QueryTermVector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryTermVector(
    string queryString,
    Analyzer analyzer
)
Visual Basic
Public Sub New ( _
    queryString As String, _
    analyzer As Analyzer _
)
Visual C++
public:
QueryTermVector(
    String^ queryString,
    Analyzer^ analyzer
)

Parameters

queryString
Type: System..::..String

[Missing <param name="queryString"/> documentation for "M:Lucene.Net.Search.QueryTermVector.#ctor(System.String,Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Search.QueryTermVector.#ctor(System.String,Lucene.Net.Analysis.Analyzer)"]

See Also

QueryTermVector Class
QueryTermVector Overload
Lucene.Net.Search Namespace


QueryTermVector Methods

[image] [image]

Lucene.Net Class Libraries
QueryTermVector Methods
QueryTermVector Class See Also Send Feedback

The QueryTermVector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTermFrequencies |
Public method | GetTerms |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexesOf |
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..GetField Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.GetField"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.GetField"]

Implements

TermFreqVector..::..GetField()()()()

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


GetTermFrequencies Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..GetTermFrequencies Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.GetTermFrequencies"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int[] GetTermFrequencies()
Visual Basic
Public Overridable Function GetTermFrequencies As Integer()
Visual C++
public:
virtual array<int>^ GetTermFrequencies()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.GetTermFrequencies"]

Implements

TermFreqVector..::..GetTermFrequencies()()()()

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..GetTerms Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.GetTerms"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string[] GetTerms()
Visual Basic
Public Overridable Function GetTerms As String()
Visual C++
public:
virtual array<String^>^ GetTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.GetTerms"]

Implements

TermFreqVector..::..GetTerms()()()()

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


IndexesOf Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..IndexesOf Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
Visual Basic
Public Overridable Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
Visual C++
public:
virtual array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
)

Parameters

terms
Type: array< System..::..String >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexesOf(System.String[],System.Int32,System.Int32)"]

Implements

TermFreqVector..::..IndexesOf(array<String>[]()[][], Int32, Int32)

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


IndexOf Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..IndexOf Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexOf(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int IndexOf(
    string term
)
Visual Basic
Public Overridable Function IndexOf ( _
    term As String _
) As Integer
Visual C++
public:
virtual int IndexOf(
    String^ term
)

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexOf(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.IndexOf(System.String)"]

Implements

TermFreqVector..::..IndexOf(String)

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


Size Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..Size Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.Size"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Size()
Visual Basic
Public Overridable Function Size As Integer
Visual C++
public:
virtual int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.Size"]

Implements

TermFreqVector..::..Size()()()()

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
QueryTermVector..::..ToString Method
QueryTermVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryTermVector.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryTermVector.ToString"]

See Also

QueryTermVector Class
Lucene.Net.Search Namespace


QueryWrapperFilter Class

[image]

Lucene.Net Class Libraries
QueryWrapperFilter Class
Members See Also Send Feedback
Constrains search results to only match those which also match a provided query.

This could be used, for example, with a {@link TermRangeQuery} on a suitably formatted date field to implement date filtering. One could re-use a single QueryFilter that matches, e.g., only documents modified within the last week. The QueryFilter and TermRangeQuery would only need to be reconstructed once per day.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class QueryWrapperFilter : Filter
Visual Basic
<SerializableAttribute> _
Public Class QueryWrapperFilter _
    Inherits Filter
Visual C++
[SerializableAttribute]
public ref class QueryWrapperFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..QueryWrapperFilter

See Also

QueryWrapperFilter Members
Lucene.Net.Search Namespace


QueryWrapperFilter Members

[image] [image]

Lucene.Net Class Libraries
QueryWrapperFilter Members
QueryWrapperFilter Class Constructors Methods See Also Send Feedback

The QueryWrapperFilter type exposes the following members.

Constructors

Name Description
Public method QueryWrapperFilter
Constructs a filter which only matches documents matching
CopyC#
query
.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Overrides Filter..::..Bits(IndexReader).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


QueryWrapperFilter Constructor

[image]

Lucene.Net Class Libraries
QueryWrapperFilter Constructor
QueryWrapperFilter Class See Also Send Feedback
Constructs a filter which only matches documents matching
CopyC#
query
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public QueryWrapperFilter(
    Query query
)
Visual Basic
Public Sub New ( _
    query As Query _
)
Visual C++
public:
QueryWrapperFilter(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.#ctor(Lucene.Net.Search.Query)"]

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


QueryWrapperFilter Methods

[image] [image]

Lucene.Net Class Libraries
QueryWrapperFilter Methods
QueryWrapperFilter Class See Also Send Feedback

The QueryWrapperFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Overrides Filter..::..Bits(IndexReader).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


Bits Method

[image]

Lucene.Net Class Libraries
QueryWrapperFilter..::..Bits Method
QueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")]
public override BitArray Bits(
    IndexReader reader
)
Visual Basic
<ObsoleteAttribute("Use GetDocIdSet(IndexReader) instead.")> _
Public Overrides Function Bits ( _
    reader As IndexReader _
) As BitArray
Visual C++
[ObsoleteAttribute(L"Use GetDocIdSet(IndexReader) instead.")]
public:
virtual BitArray^ Bits(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.Bits(Lucene.Net.Index.IndexReader)"]

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
QueryWrapperFilter..::..Equals Method
QueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.Equals(System.Object)"]

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
QueryWrapperFilter..::..GetDocIdSet Method
QueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
QueryWrapperFilter..::..GetHashCode Method
QueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.GetHashCode"]

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
QueryWrapperFilter..::..ToString Method
QueryWrapperFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.QueryWrapperFilter.ToString"]

See Also

QueryWrapperFilter Class
Lucene.Net.Search Namespace


RangeFilter Class

[image]

Lucene.Net Class Libraries
RangeFilter Class
Members See Also Send Feedback
A Filter that restricts search results to a range of values in a given field.

This filter matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeFilter} instead.

If you construct a large number of range filters with different ranges but on the same field, {@link FieldCacheRangeFilter} may have significantly better performance.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Use TermRangeFilter for term ranges or NumericRangeFilter for numeric ranges instead. This class will be removed in Lucene 3.0")]
public class RangeFilter : MultiTermQueryWrapperFilter
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Use TermRangeFilter for term ranges or NumericRangeFilter for numeric ranges instead. This class will be removed in Lucene 3.0")> _
Public Class RangeFilter _
    Inherits MultiTermQueryWrapperFilter
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Use TermRangeFilter for term ranges or NumericRangeFilter for numeric ranges instead. This class will be removed in Lucene 3.0")]
public ref class RangeFilter : public MultiTermQueryWrapperFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..MultiTermQueryWrapperFilter
Lucene.Net.Search..::..RangeFilter

See Also

RangeFilter Members
Lucene.Net.Search Namespace


RangeFilter Members

[image] [image]

Lucene.Net Class Libraries
RangeFilter Members
RangeFilter Class Constructors Methods Fields See Also Send Feedback

The RangeFilter type exposes the following members.

Constructors

Name Description
Public method RangeFilter(String, String, String, Boolean, Boolean)
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)
Public method RangeFilter(String, String, String, Boolean, Boolean, CompareInfo)
WARNING: Using this constructor and supplying a non-null value in the
CopyC#
collator
 parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Methods

Name | Description
Public method Bits Obsolete.
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
(Inherited from MultiTermQueryWrapperFilter.)
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the filter.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDocIdSet
Returns a DocIdSet with documents that should be permitted in search results.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

(Inherited from MultiTermQueryWrapperFilter.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Less
Constructs a filter for field
CopyC#
fieldName
 matching less than or equal to
CopyC#
upperTerm
.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
More
Constructs a filter for field
CopyC#
fieldName
 matching greater than or equal to
CopyC#
lowerTerm
.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter.)

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

RangeFilter Class
Lucene.Net.Search Namespace


RangeFilter Constructor

[image] [image]

Lucene.Net Class Libraries
RangeFilter Constructor
RangeFilter Class See Also Send Feedback

Overload List

Name Description
Public method RangeFilter(String, String, String, Boolean, Boolean)
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)
Public method RangeFilter(String, String, String, Boolean, Boolean, CompareInfo)
WARNING: Using this constructor and supplying a non-null value in the
CopyC#
collator
 parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

See Also

RangeFilter Class
RangeFilter Members
Lucene.Net.Search Namespace


RangeFilter Constructor (String, String, String, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
RangeFilter Constructor (String, String, String, Boolean, Boolean)
RangeFilter Class See Also Send Feedback
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Visual C++
public:
RangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)

Parameters

fieldName
Type: System..::..String
The field this range applies to
lowerTerm
Type: System..::..String
The lower bound on this range
upperTerm
Type: System..::..String
The upper bound on this range
includeLower
Type: System..::..Boolean
Does this range include the lower bound?
includeUpper
Type: System..::..Boolean
Does this range include the upper bound?

See Also

RangeFilter Class
RangeFilter Overload
Lucene.Net.Search Namespace


RangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo)

[image]

Lucene.Net Class Libraries
RangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo)
RangeFilter Class See Also Send Feedback
WARNING: Using this constructor and supplying a non-null value in the
CopyC#
collator
 parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Visual C++
public:
RangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.RangeFilter.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

lowerTerm
Type: System..::..String
The lower bound on this range
upperTerm
Type: System..::..String
The upper bound on this range
includeLower
Type: System..::..Boolean
Does this range include the lower bound?
includeUpper
Type: System..::..Boolean
Does this range include the upper bound?
collator
Type: System.Globalization..::..CompareInfo
The collator to use when determining range inclusion; set to null to use Unicode code point ordering instead of collation.

See Also

RangeFilter Class
RangeFilter Overload
Lucene.Net.Search Namespace


RangeFilter Fields

[image] [image]

Lucene.Net Class Libraries
RangeFilter Fields
RangeFilter Class See Also Send Feedback

The RangeFilter type exposes the following members.

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

RangeFilter Class
Lucene.Net.Search Namespace


RangeFilter Methods

[image] [image]

Lucene.Net Class Libraries
RangeFilter Methods
RangeFilter Class See Also Send Feedback

The RangeFilter type exposes the following members.

Methods

Name | Description
Public method Bits Obsolete.
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
(Inherited from MultiTermQueryWrapperFilter.)
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the filter.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDocIdSet
Returns a DocIdSet with documents that should be permitted in search results.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

(Inherited from MultiTermQueryWrapperFilter.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Less
Constructs a filter for field
CopyC#
fieldName
 matching less than or equal to
CopyC#
upperTerm
.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
More
Constructs a filter for field
CopyC#
fieldName
 matching greater than or equal to
CopyC#
lowerTerm
.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter.)

See Also

RangeFilter Class
Lucene.Net.Search Namespace


Less Method

[image]

Lucene.Net Class Libraries
RangeFilter..::..Less Method
RangeFilter Class See Also Send Feedback
Constructs a filter for field
CopyC#
fieldName
 matching less than or equal to
CopyC#
upperTerm
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static RangeFilter Less(
    string fieldName,
    string upperTerm
)
Visual Basic
Public Shared Function Less ( _
    fieldName As String, _
    upperTerm As String _
) As RangeFilter
Visual C++
public:
static RangeFilter^ Less(
    String^ fieldName,
    String^ upperTerm
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.RangeFilter.Less(System.String,System.String)"]

upperTerm
Type: System..::..String

[Missing <param name="upperTerm"/> documentation for "M:Lucene.Net.Search.RangeFilter.Less(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeFilter.Less(System.String,System.String)"]

See Also

RangeFilter Class
Lucene.Net.Search Namespace


More Method

[image]

Lucene.Net Class Libraries
RangeFilter..::..More Method
RangeFilter Class See Also Send Feedback
Constructs a filter for field
CopyC#
fieldName
 matching greater than or equal to
CopyC#
lowerTerm
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static RangeFilter More(
    string fieldName,
    string lowerTerm
)
Visual Basic
Public Shared Function More ( _
    fieldName As String, _
    lowerTerm As String _
) As RangeFilter
Visual C++
public:
static RangeFilter^ More(
    String^ fieldName,
    String^ lowerTerm
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.RangeFilter.More(System.String,System.String)"]

lowerTerm
Type: System..::..String

[Missing <param name="lowerTerm"/> documentation for "M:Lucene.Net.Search.RangeFilter.More(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeFilter.More(System.String,System.String)"]

See Also

RangeFilter Class
Lucene.Net.Search Namespace


RangeQuery Class

[image]

Lucene.Net Class Libraries
RangeQuery Class
Members See Also Send Feedback
A Query that matches documents within an exclusive range of terms.

This query matches the documents looking for terms that fall into the supplied range according to {@link Term#CompareTo(Term)}. It is not intended for numerical ranges, use {@link NumericRangeQuery} instead.

This query uses {@linkplain MultiTermQuery#SCORING_BOOLEAN_QUERY_REWRITE}. If you want to change this, use the new {@link TermRangeQuery} instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Use TermRangeQuery for term ranges or NumericRangeQuery for numeric ranges instead. This class will be removed in Lucene 3.0")]
public class RangeQuery : Query
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Use TermRangeQuery for term ranges or NumericRangeQuery for numeric ranges instead. This class will be removed in Lucene 3.0")> _
Public Class RangeQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Use TermRangeQuery for term ranges or NumericRangeQuery for numeric ranges instead. This class will be removed in Lucene 3.0")]
public ref class RangeQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..RangeQuery

See Also

RangeQuery Members
Lucene.Net.Search Namespace


RangeQuery Members

[image] [image]

Lucene.Net Class Libraries
RangeQuery Members
RangeQuery Class Constructors Methods See Also Send Feedback

The RangeQuery type exposes the following members.

Constructors

Name Description
Public method RangeQuery(Term, Term, Boolean)
Constructs a query selecting all terms greater than
CopyC#
lowerTerm
 but less than
CopyC#
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.
Public method RangeQuery(Term, Term, Boolean, CompareInfo)
Constructs a query selecting all terms greater than
CopyC#
lowerTerm
 but less than
CopyC#
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

If

CopyC#
collator
is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the

CopyC#
collator
parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
Public method GetField
Returns the field name for this query
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetLowerTerm
Returns the lower term of this range query.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper term of this range query.
Public method IsInclusive
Returns
CopyC#
true
 if the range query is inclusive
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method | SetBoost | (Overrides Query..::..SetBoost(Single).)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

RangeQuery Class
Lucene.Net.Search Namespace


RangeQuery Constructor

[image] [image]

Lucene.Net Class Libraries
RangeQuery Constructor
RangeQuery Class See Also Send Feedback

Overload List

Name Description
Public method RangeQuery(Term, Term, Boolean)
Constructs a query selecting all terms greater than
CopyC#
lowerTerm
 but less than
CopyC#
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.
Public method RangeQuery(Term, Term, Boolean, CompareInfo)
Constructs a query selecting all terms greater than
CopyC#
lowerTerm
 but less than
CopyC#
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

If

CopyC#
collator
is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the

CopyC#
collator
parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

See Also

RangeQuery Class
RangeQuery Members
Lucene.Net.Search Namespace


RangeQuery Constructor (Term, Term, Boolean)

[image]

Lucene.Net Class Libraries
RangeQuery Constructor (Term, Term, Boolean)
RangeQuery Class See Also Send Feedback
Constructs a query selecting all terms greater than
CopyC#
lowerTerm
 but less than
CopyC#
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RangeQuery(
    Term lowerTerm,
    Term upperTerm,
    bool inclusive
)
Visual Basic
Public Sub New ( _
    lowerTerm As Term, _
    upperTerm As Term, _
    inclusive As Boolean _
)
Visual C++
public:
RangeQuery(
    Term^ lowerTerm,
    Term^ upperTerm,
    bool inclusive
)

Parameters

lowerTerm
Type: Lucene.Net.Index..::..Term
The Term at the lower end of the range
upperTerm
Type: Lucene.Net.Index..::..Term
The Term at the upper end of the range
inclusive
Type: System..::..Boolean
If true, both
CopyC#
lowerTerm
 and
CopyC#
upperTerm
 will themselves be included in the range.

See Also

RangeQuery Class
RangeQuery Overload
Lucene.Net.Search Namespace


RangeQuery Constructor (Term, Term, Boolean, CompareInfo)

[image]

Lucene.Net Class Libraries
RangeQuery Constructor (Term, Term, Boolean, CompareInfo)
RangeQuery Class See Also Send Feedback
Constructs a query selecting all terms greater than
CopyC#
lowerTerm
 but less than
CopyC#
upperTerm
. There must be at least one term and either term may be null, in which case there is no bound on that side, but if there are two terms, both terms must be for the same field.

If

CopyC#
collator
is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the

CopyC#
collator
parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RangeQuery(
    Term lowerTerm,
    Term upperTerm,
    bool inclusive,
    CompareInfo collator
)
Visual Basic
Public Sub New ( _
    lowerTerm As Term, _
    upperTerm As Term, _
    inclusive As Boolean, _
    collator As CompareInfo _
)
Visual C++
public:
RangeQuery(
    Term^ lowerTerm,
    Term^ upperTerm,
    bool inclusive,
    CompareInfo^ collator
)

Parameters

lowerTerm
Type: Lucene.Net.Index..::..Term
The Term at the lower end of the range
upperTerm
Type: Lucene.Net.Index..::..Term
The Term at the upper end of the range
inclusive
Type: System..::..Boolean
If true, both
CopyC#
lowerTerm
 and
CopyC#
upperTerm
 will themselves be included in the range.
collator
Type: System.Globalization..::..CompareInfo
The collator to use to collate index Terms, to determine their membership in the range bounded by
CopyC#
lowerTerm
 and
CopyC#
upperTerm
.

See Also

RangeQuery Class
RangeQuery Overload
Lucene.Net.Search Namespace


RangeQuery Methods

[image] [image]

Lucene.Net Class Libraries
RangeQuery Methods
RangeQuery Class See Also Send Feedback

The RangeQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
Public method GetField
Returns the field name for this query
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetLowerTerm
Returns the lower term of this range query.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper term of this range query.
Public method IsInclusive
Returns
CopyC#
true
 if the range query is inclusive
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method | SetBoost | (Overrides Query..::..SetBoost(Single).)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

RangeQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..Equals Method
RangeQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.RangeQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.Equals(System.Object)"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


GetCollator Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..GetCollator Method
RangeQuery Class See Also Send Feedback
Returns the collator used to determine range inclusion, if any.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CompareInfo GetCollator()
Visual Basic
Public Overridable Function GetCollator As CompareInfo
Visual C++
public:
virtual CompareInfo^ GetCollator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.GetCollator"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..GetField Method
RangeQuery Class See Also Send Feedback
Returns the field name for this query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.GetField"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..GetHashCode Method
RangeQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.GetHashCode"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


GetLowerTerm Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..GetLowerTerm Method
RangeQuery Class See Also Send Feedback
Returns the lower term of this range query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term GetLowerTerm()
Visual Basic
Public Overridable Function GetLowerTerm As Term
Visual C++
public:
virtual Term^ GetLowerTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.GetLowerTerm"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


GetUpperTerm Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..GetUpperTerm Method
RangeQuery Class See Also Send Feedback
Returns the upper term of this range query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term GetUpperTerm()
Visual Basic
Public Overridable Function GetUpperTerm As Term
Visual C++
public:
virtual Term^ GetUpperTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.GetUpperTerm"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


IsInclusive Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..IsInclusive Method
RangeQuery Class See Also Send Feedback
Returns
CopyC#
true
 if the range query is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsInclusive()
Visual Basic
Public Overridable Function IsInclusive As Boolean
Visual C++
public:
virtual bool IsInclusive()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.IsInclusive"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..Rewrite Method
RangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.RangeQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.RangeQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


SetBoost Method

[image]

Lucene.Net Class Libraries
RangeQuery..::..SetBoost Method
RangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.RangeQuery.SetBoost(System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetBoost(
    float b
)
Visual Basic
Public Overrides Sub SetBoost ( _
    b As Single _
)
Visual C++
public:
virtual void SetBoost(
    float b
) override

Parameters

b
Type: System..::..Single

[Missing <param name="b"/> documentation for "M:Lucene.Net.Search.RangeQuery.SetBoost(System.Single)"]

See Also

RangeQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
RangeQuery..::..ToString Method
RangeQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

RangeQuery Class
RangeQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
RangeQuery..::..ToString Method (String)
RangeQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.RangeQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.RangeQuery.ToString(System.String)"]

See Also

RangeQuery Class
ToString Overload
Lucene.Net.Search Namespace


ScoreCachingWrappingScorer Class

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer Class
Members See Also Send Feedback
A {@link Scorer} which wraps another scorer and caches the score of the current document. Successive calls to {@link #Score()} will return the same result and will not invoke the wrapped Scorer's score() method, unless the current document has changed.
This class might be useful due to the changes done to the {@link Collector} interface, in which the score is not computed for a document by default, only if the collector requests it. Some collectors may need to use the score in several places, however all they have in hand is a {@link Scorer} object, and might end up computing the score of a document more than once.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ScoreCachingWrappingScorer : Scorer
Visual Basic
Public Class ScoreCachingWrappingScorer _
    Inherits Scorer
Visual C++
public ref class ScoreCachingWrappingScorer : public Scorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search..::..ScoreCachingWrappingScorer

See Also

ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace


ScoreCachingWrappingScorer Members

[image] [image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer Members
ScoreCachingWrappingScorer Class Constructors Methods See Also Send Feedback

The ScoreCachingWrappingScorer type exposes the following members.

Constructors

 | Name | Description
Public method | ScoreCachingWrappingScorer | Creates a new instance by wrapping the given scorer.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSimilarity | (Overrides Scorer..::..GetSimilarity()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. Scores and collects all matching documents. (Inherited from Scorer.)
Protected method | Score(HitCollector, Int32) | Obsolete. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


ScoreCachingWrappingScorer Constructor

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer Constructor
ScoreCachingWrappingScorer Class See Also Send Feedback
Creates a new instance by wrapping the given scorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ScoreCachingWrappingScorer(
    Scorer scorer
)
Visual Basic
Public Sub New ( _
    scorer As Scorer _
)
Visual C++
public:
ScoreCachingWrappingScorer(
    Scorer^ scorer
)

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.#ctor(Lucene.Net.Search.Scorer)"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


ScoreCachingWrappingScorer Methods

[image] [image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer Methods
ScoreCachingWrappingScorer Class See Also Send Feedback

The ScoreCachingWrappingScorer type exposes the following members.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSimilarity | (Overrides Scorer..::..GetSimilarity()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. Scores and collects all matching documents. (Inherited from Scorer.)
Protected method | Score(HitCollector, Int32) | Obsolete. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Advance Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Advance(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Advance(System.Int32)"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Doc Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Doc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead.")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead.")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead.")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Doc"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..DocID Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.DocID"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Explain Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Explain(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Explain(System.Int32)"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..GetSimilarity Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.GetSimilarity"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Similarity GetSimilarity()
Visual Basic
Public Overrides Function GetSimilarity As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.GetSimilarity"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Next Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Next"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Next"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..NextDoc Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.NextDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.NextDoc"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Score Method
ScoreCachingWrappingScorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. Scores and collects all matching documents. (Inherited from Scorer.)
Protected method | Score(HitCollector, Int32) | Obsolete. Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time. (Inherited from Scorer.)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)

See Also

ScoreCachingWrappingScorer Class
ScoreCachingWrappingScorer Members
Lucene.Net.Search Namespace


Score Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Score Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score"]

See Also

ScoreCachingWrappingScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector)

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Score Method (Collector)
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Score(
    Collector collector
)
Visual Basic
Public Overrides Sub Score ( _
    collector As Collector _
)
Visual C++
public:
virtual void Score(
    Collector^ collector
) override

Parameters

collector
Type: Lucene.Net.Search..::..Collector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector)"]

See Also

ScoreCachingWrappingScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector, Int32, Int32)

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..Score Method (Collector, Int32, Int32)
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Score(
    Collector collector,
    int max,
    int firstDocID
)
Visual Basic
Public Overrides Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
Visual C++
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
) override

Parameters

collector
Type: Lucene.Net.Search..::..Collector

[Missing <param name="collector"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

firstDocID
Type: System..::..Int32

[Missing <param name="firstDocID"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

See Also

ScoreCachingWrappingScorer Class
Score Overload
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
ScoreCachingWrappingScorer..::..SkipTo Method
ScoreCachingWrappingScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead.")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead.")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead.")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreCachingWrappingScorer.SkipTo(System.Int32)"]

See Also

ScoreCachingWrappingScorer Class
Lucene.Net.Search Namespace


ScoreDoc Class

[image]

Lucene.Net Class Libraries
ScoreDoc Class
Members See Also Send Feedback
Expert: Returned by low-level search implementations.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ScoreDoc
Visual Basic
<SerializableAttribute> _
Public Class ScoreDoc
Visual C++
[SerializableAttribute]
public ref class ScoreDoc

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..ScoreDoc
Lucene.Net.Search..::..FieldDoc

See Also

ScoreDoc Members
Lucene.Net.Search Namespace
Lucene.Net.Search..::..TopDocs


ScoreDoc Members

[image] [image]

Lucene.Net Class Libraries
ScoreDoc Members
ScoreDoc Class Constructors Methods Fields See Also Send Feedback

The ScoreDoc type exposes the following members.

Constructors

 | Name | Description
Public method | ScoreDoc | Expert: Constructs a ScoreDoc.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | doc | Expert: A hit document's number.
Public field | score | Expert: The score of this document for the query.

See Also

ScoreDoc Class
Lucene.Net.Search Namespace


ScoreDoc Constructor

[image]

Lucene.Net Class Libraries
ScoreDoc Constructor
ScoreDoc Class See Also Send Feedback
Expert: Constructs a ScoreDoc.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ScoreDoc(
    int doc,
    float score
)
Visual Basic
Public Sub New ( _
    doc As Integer, _
    score As Single _
)
Visual C++
public:
ScoreDoc(
    int doc,
    float score
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.ScoreDoc.#ctor(System.Int32,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.ScoreDoc.#ctor(System.Int32,System.Single)"]

See Also

ScoreDoc Class
Lucene.Net.Search Namespace


ScoreDoc Fields

[image] [image]

Lucene.Net Class Libraries
ScoreDoc Fields
ScoreDoc Class See Also Send Feedback

The ScoreDoc type exposes the following members.

Fields

 | Name | Description
Public field | doc | Expert: A hit document's number.
Public field | score | Expert: The score of this document for the query.

See Also

ScoreDoc Class
Lucene.Net.Search Namespace


doc Field

[image]

Lucene.Net Class Libraries
ScoreDoc..::..doc Field
ScoreDoc Class See Also Send Feedback
Expert: A hit document's number.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int doc
Visual Basic
Public doc As Integer
Visual C++
public:
int doc

See Also

ScoreDoc Class
Lucene.Net.Search Namespace
Searcher..::..Doc(Int32)


score Field

[image]

Lucene.Net Class Libraries
ScoreDoc..::..score Field
ScoreDoc Class See Also Send Feedback
Expert: The score of this document for the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float score
Visual Basic
Public score As Single
Visual C++
public:
float score

See Also

ScoreDoc Class
Lucene.Net.Search Namespace


ScoreDoc Methods

[image] [image]

Lucene.Net Class Libraries
ScoreDoc Methods
ScoreDoc Class See Also Send Feedback

The ScoreDoc type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

ScoreDoc Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
ScoreDoc..::..ToString Method
ScoreDoc Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ScoreDoc.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ScoreDoc.ToString"]

See Also

ScoreDoc Class
Lucene.Net.Search Namespace


ScoreDocComparator Interface

[image]

Lucene.Net Class Libraries
ScoreDocComparator Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.ScoreDocComparator"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface ScoreDocComparator
Visual Basic
Public Interface ScoreDocComparator
Visual C++
public interface class ScoreDocComparator

See Also

ScoreDocComparator Members
Lucene.Net.Search Namespace


ScoreDocComparator Members

[image] [image]

Lucene.Net Class Libraries
ScoreDocComparator Members
ScoreDocComparator Interface Methods See Also Send Feedback

The ScoreDocComparator type exposes the following members.

Methods

Name Description
Public method Compare
Compares two ScoreDoc objects and returns a result indicating their sort order.
Public method SortType
Returns the type of sort. Should return
CopyC#
SortField.SCORE
,
CopyC#
SortField.DOC
,
CopyC#
SortField.STRING
,
CopyC#
SortField.INTEGER
,
CopyC#
SortField.FLOAT
 or
CopyC#
SortField.CUSTOM
. It is not valid to return
CopyC#
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.
Public method SortValue
Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

See Also

ScoreDocComparator Interface
Lucene.Net.Search Namespace


ScoreDocComparator Methods

[image] [image]

Lucene.Net Class Libraries
ScoreDocComparator Methods
ScoreDocComparator Interface See Also Send Feedback

The ScoreDocComparator type exposes the following members.

Methods

Name Description
Public method Compare
Compares two ScoreDoc objects and returns a result indicating their sort order.
Public method SortType
Returns the type of sort. Should return
CopyC#
SortField.SCORE
,
CopyC#
SortField.DOC
,
CopyC#
SortField.STRING
,
CopyC#
SortField.INTEGER
,
CopyC#
SortField.FLOAT
 or
CopyC#
SortField.CUSTOM
. It is not valid to return
CopyC#
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.
Public method SortValue
Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

See Also

ScoreDocComparator Interface
Lucene.Net.Search Namespace


Compare Method

[image]

Lucene.Net Class Libraries
ScoreDocComparator..::..Compare Method
ScoreDocComparator Interface See Also Send Feedback
Compares two ScoreDoc objects and returns a result indicating their sort order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int Compare(
    ScoreDoc i,
    ScoreDoc j
)
Visual Basic
Function Compare ( _
    i As ScoreDoc, _
    j As ScoreDoc _
) As Integer
Visual C++
int Compare(
    ScoreDoc^ i,
    ScoreDoc^ j
)

Parameters

i
Type: Lucene.Net.Search..::..ScoreDoc
First ScoreDoc
j
Type: Lucene.Net.Search..::..ScoreDoc
Second ScoreDoc

Return Value

a negative integer if
CopyC#
i
 should come before
CopyC#
j

a positive integer if
CopyC#
i
 should come after
CopyC#
j

CopyC#
0
 if they are equal

See Also

ScoreDocComparator Interface
Lucene.Net.Search Namespace
[!:java.util.Comparator]


SortType Method

[image]

Lucene.Net Class Libraries
ScoreDocComparator..::..SortType Method
ScoreDocComparator Interface See Also Send Feedback
Returns the type of sort. Should return
CopyC#
SortField.SCORE
,
CopyC#
SortField.DOC
,
CopyC#
SortField.STRING
,
CopyC#
SortField.INTEGER
,
CopyC#
SortField.FLOAT
 or
CopyC#
SortField.CUSTOM
. It is not valid to return
CopyC#
SortField.AUTO
. This is used by multisearchers to determine how to collate results from their searchers.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int SortType()
Visual Basic
Function SortType As Integer
Visual C++
int SortType()

Return Value

One of the constants in SortField.

See Also

ScoreDocComparator Interface
Lucene.Net.Search Namespace
Lucene.Net.Search..::..SortField


SortValue Method

[image]

Lucene.Net Class Libraries
ScoreDocComparator..::..SortValue Method
ScoreDocComparator Interface See Also Send Feedback
Returns the value used to sort the given document. The object returned must implement the java.io.Serializable interface. This is used by multisearchers to determine how to collate results from their searchers.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
IComparable SortValue(
    ScoreDoc i
)
Visual Basic
Function SortValue ( _
    i As ScoreDoc _
) As IComparable
Visual C++
IComparable^ SortValue(
    ScoreDoc^ i
)

Parameters

i
Type: Lucene.Net.Search..::..ScoreDoc
Document

Return Value

Serializable object

See Also

ScoreDocComparator Interface
Lucene.Net.Search Namespace
Lucene.Net.Search..::..FieldDoc


ScoreDocComparator_Fields Structure

[image]

Lucene.Net Class Libraries
ScoreDocComparator_Fields Structure
Members See Also Send Feedback
Expert: Compares two ScoreDoc objects for sorting.

Created: Feb 3, 2004 9:00:16 AM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use FieldComparator")]
public struct ScoreDocComparator_Fields
Visual Basic
<ObsoleteAttribute("use FieldComparator")> _
Public Structure ScoreDocComparator_Fields
Visual C++
[ObsoleteAttribute(L"use FieldComparator")]
public value class ScoreDocComparator_Fields

See Also

ScoreDocComparator_Fields Members
Lucene.Net.Search Namespace


ScoreDocComparator_Fields Members

[image] [image]

Lucene.Net Class Libraries
ScoreDocComparator_Fields Members
ScoreDocComparator_Fields Structure Methods Fields See Also Send Feedback

The ScoreDocComparator_Fields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
INDEXORDER | Special comparator for sorting hits according to index order (document number).
RELEVANCE | Special comparator for sorting hits according to computed relevance (document score).

See Also

ScoreDocComparator_Fields Structure
Lucene.Net.Search Namespace


ScoreDocComparator_Fields Fields

[image] [image]

Lucene.Net Class Libraries
ScoreDocComparator_Fields Fields
ScoreDocComparator_Fields Structure See Also Send Feedback

The ScoreDocComparator_Fields type exposes the following members.

Fields

Name | Description
INDEXORDER | Special comparator for sorting hits according to index order (document number).
RELEVANCE | Special comparator for sorting hits according to computed relevance (document score).

See Also

ScoreDocComparator_Fields Structure
Lucene.Net.Search Namespace


INDEXORDER Field

[image]

Lucene.Net Class Libraries
ScoreDocComparator_Fields..::..INDEXORDER Field
ScoreDocComparator_Fields Structure See Also Send Feedback
Special comparator for sorting hits according to index order (document number).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly ScoreDocComparator INDEXORDER
Visual Basic
Public Shared ReadOnly INDEXORDER As ScoreDocComparator
Visual C++
public:
static initonly ScoreDocComparator^ INDEXORDER

See Also

ScoreDocComparator_Fields Structure
Lucene.Net.Search Namespace


RELEVANCE Field

[image]

Lucene.Net Class Libraries
ScoreDocComparator_Fields..::..RELEVANCE Field
ScoreDocComparator_Fields Structure See Also Send Feedback
Special comparator for sorting hits according to computed relevance (document score).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly ScoreDocComparator RELEVANCE
Visual Basic
Public Shared ReadOnly RELEVANCE As ScoreDocComparator
Visual C++
public:
static initonly ScoreDocComparator^ RELEVANCE

See Also

ScoreDocComparator_Fields Structure
Lucene.Net.Search Namespace


ScoreDocComparator_Fields Methods

[image] [image]

Lucene.Net Class Libraries
ScoreDocComparator_Fields Methods
ScoreDocComparator_Fields Structure See Also Send Feedback

The ScoreDocComparator_Fields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ScoreDocComparator_Fields Structure
Lucene.Net.Search Namespace


Scorer Class

[image]

Lucene.Net Class Libraries
Scorer Class
Members See Also Send Feedback
Expert: Common scoring functionality for different types of queries.

A

CopyC#
Scorer
iterates over documents matching a query in increasing order of doc Id.

Document scores are computed using a given

CopyC#
Similarity
implementation.

NOTE: The values Float.Nan, Float.NEGATIVE_INFINITY and Float.POSITIVE_INFINITY are not valid scores. Certain collectors (eg {@link TopScoreDocCollector}) will not properly collect hits with these scores.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Scorer : DocIdSetIterator
Visual Basic
Public MustInherit Class Scorer _
    Inherits DocIdSetIterator
Visual C++
public ref class Scorer abstract : public DocIdSetIterator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search..::..BooleanScorer
Lucene.Net.Search..::..ConstantScoreQuery..::..ConstantScorer
Lucene.Net.Search..::..ScoreCachingWrappingScorer
Lucene.Net.Search.Spans..::..SpanScorer
Lucene.Net.Search..::..TermScorer

See Also

Scorer Members
Lucene.Net.Search Namespace
[!:BooleanQuery.setAllowDocsOutOfOrder]


Scorer Members

[image] [image]

Lucene.Net Class Libraries
Scorer Members
Scorer Class Constructors Methods See Also Send Feedback

The Scorer type exposes the following members.

Constructors

 | Name | Description
Protected method | Scorer | Constructs a Scorer.

Methods

Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or {@link #NO_MORE_DOCS} if there are no more docs in the set.

Behaves as if written:

            int advance(int target) {
            int doc;
            while ((doc = nextDoc()) < target) {
            }
            return doc;
            }
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with {@value #NO_MORE_DOCS} for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

NOTE: in 3.0 this method will become abstract, following the removal of {@link #SkipTo(int)}.

(Inherited from DocIdSetIterator.)
Public method Doc Obsolete.
Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called.
(Inherited from DocIdSetIterator.)
Public method DocID
Returns the following:
  • -1 or {@link #NO_MORE_DOCS} if {@link #NextDoc()} or {@link #Advance(int)} were not called yet.
  • {@link #NO_MORE_DOCS} if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

NOTE: in 3.0, this method will become abstract.

(Inherited from DocIdSetIterator.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
Returns an explanation of the score for a document.
When this method is used, the {@link #Next()}, {@link #SkipTo(int)} and {@link #Score(HitCollector)} methods should not be used.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next Obsolete.
Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called.
(Inherited from DocIdSetIterator.)
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or {@link #NO_MORE_DOCS} if there are no more docs in the set.
NOTE: in 3.0 this method will become abstract, following the removal of {@link #Next()}. For backward compatibility it is implemented as:
            public int nextDoc() throws IOException {
            return next() ? doc() : NO_MORE_DOCS;
            }
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
(Inherited from DocIdSetIterator.)
Public method Score()()()()
Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time, or when called from within {@link Collector#collect}.
Public method Score(Collector)
Scores and collects all matching documents.
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
Public method SkipTo Obsolete.
Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called.
(Inherited from DocIdSetIterator.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Scorer Class
Lucene.Net.Search Namespace


Scorer Constructor

[image]

Lucene.Net Class Libraries
Scorer Constructor
Scorer Class See Also Send Feedback
Constructs a Scorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Scorer(
    Similarity similarity
)
Visual Basic
Protected Friend Sub New ( _
    similarity As Similarity _
)
Visual C++
protected public:
Scorer(
    Similarity^ similarity
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity
The
CopyC#
Similarity
 implementation used by this scorer.

See Also

Scorer Class
Lucene.Net.Search Namespace


Scorer Methods

[image] [image]

Lucene.Net Class Libraries
Scorer Methods
Scorer Class See Also Send Feedback

The Scorer type exposes the following members.

Methods

Name Description
Public method Advance
Advances to the first beyond the current whose document number is greater than or equal to target. Returns the current document number or {@link #NO_MORE_DOCS} if there are no more docs in the set.

Behaves as if written:

            int advance(int target) {
            int doc;
            while ((doc = nextDoc()) < target) {
            }
            return doc;
            }
Some implementations are considerably more efficient than that.

NOTE: certain implemenations may return a different value (each time) if called several times in a row with the same target.

NOTE: this method may be called with {@value #NO_MORE_DOCS} for efficiency by some Scorers. If your implementation cannot efficiently determine that it should exhaust, it is recommended that you check for that value in each call to this method.

NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.

NOTE: in 3.0 this method will become abstract, following the removal of {@link #SkipTo(int)}.

(Inherited from DocIdSetIterator.)
Public method Doc Obsolete.
Unsupported anymore. Call {@link #DocID()} instead. This method throws {@link UnsupportedOperationException} if called.
(Inherited from DocIdSetIterator.)
Public method DocID
Returns the following:
  • -1 or {@link #NO_MORE_DOCS} if {@link #NextDoc()} or {@link #Advance(int)} were not called yet.
  • {@link #NO_MORE_DOCS} if the iterator has exhausted.
  • Otherwise it should return the doc ID it is currently on.

NOTE: in 3.0, this method will become abstract.

(Inherited from DocIdSetIterator.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
Returns an explanation of the score for a document.
When this method is used, the {@link #Next()}, {@link #SkipTo(int)} and {@link #Score(HitCollector)} methods should not be used.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next Obsolete.
Unsupported anymore. Call {@link #NextDoc()} instead. This method throws {@link UnsupportedOperationException} if called.
(Inherited from DocIdSetIterator.)
Public method NextDoc
Advances to the next document in the set and returns the doc it is currently on, or {@link #NO_MORE_DOCS} if there are no more docs in the set.
NOTE: in 3.0 this method will become abstract, following the removal of {@link #Next()}. For backward compatibility it is implemented as:
            public int nextDoc() throws IOException {
            return next() ? doc() : NO_MORE_DOCS;
            }
NOTE: after the iterator has exhausted you should not call this method, as it may result in unpredicted behavior.
(Inherited from DocIdSetIterator.)
Public method Score()()()()
Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time, or when called from within {@link Collector#collect}.
Public method Score(Collector)
Scores and collects all matching documents.
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
Public method SkipTo Obsolete.
Unsupported anymore. Call {@link #Advance(int)} instead. This method throws {@link UnsupportedOperationException} if called.
(Inherited from DocIdSetIterator.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Scorer Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
Scorer..::..Explain Method
Scorer Class See Also Send Feedback
Returns an explanation of the score for a document.
When this method is used, the {@link #Next()}, {@link #SkipTo(int)} and {@link #Score(HitCollector)} methods should not be used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation Explain(
    int doc
)
Visual Basic
Public Overridable Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
)

Parameters

doc
Type: System..::..Int32
The document number for the explanation.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Scorer.Explain(System.Int32)"]

See Also

Scorer Class
Lucene.Net.Search Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
Scorer..::..GetSimilarity Method
Scorer Class See Also Send Feedback
Returns the Similarity implementation used by this scorer.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Similarity GetSimilarity()
Visual Basic
Public Overridable Function GetSimilarity As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Scorer.GetSimilarity"]

See Also

Scorer Class
Lucene.Net.Search Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
Scorer..::..Score Method
Scorer Class See Also Send Feedback

Overload List

Name Description
Public method Score()()()()
Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time, or when called from within {@link Collector#collect}.
Public method Score(Collector)
Scores and collects all matching documents.
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.

See Also

Scorer Class
Scorer Members
Lucene.Net.Search Namespace


Score Method

[image]

Lucene.Net Class Libraries
Scorer..::..Score Method
Scorer Class See Also Send Feedback
Returns the score of the current document matching the query. Initially invalid, until {@link #Next()} or {@link #SkipTo(int)} is called the first time, or when called from within {@link Collector#collect}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float Score()
Visual Basic
Public MustOverride Function Score As Single
Visual C++
public:
virtual float Score() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Scorer.Score"]

See Also

Scorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector)

[image]

Lucene.Net Class Libraries
Scorer..::..Score Method (Collector)
Scorer Class See Also Send Feedback
Scores and collects all matching documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Score(
    Collector collector
)
Visual Basic
Public Overridable Sub Score ( _
    collector As Collector _
)
Visual C++
public:
virtual void Score(
    Collector^ collector
)

Parameters

collector
Type: Lucene.Net.Search..::..Collector
The collector to which all matching documents are passed.
When this method is used the {@link #Explain(int)} method should not be used.

See Also

Scorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (HitCollector)

[image]

Lucene.Net Class Libraries
Scorer..::..Score Method (HitCollector)
Scorer Class See Also Send Feedback
Scores and collects all matching documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Score(Collector) instead.")]
public virtual void Score(
    HitCollector hc
)
Visual Basic
<ObsoleteAttribute("use Score(Collector) instead.")> _
Public Overridable Sub Score ( _
    hc As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Score(Collector) instead.")]
public:
virtual void Score(
    HitCollector^ hc
)

Parameters

hc
Type: Lucene.Net.Search..::..HitCollector
The collector to which all matching documents are passed through {@link HitCollector#Collect(int, float)}.
When this method is used the {@link #Explain(int)} method should not be used.

See Also

Scorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (HitCollector, Int32)

[image]

Lucene.Net Class Libraries
Scorer..::..Score Method (HitCollector, Int32)
Scorer Class See Also Send Feedback
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Score(Collector, int, int) instead")]
protected internal virtual bool Score(
    HitCollector hc,
    int max
)
Visual Basic
<ObsoleteAttribute("use Score(Collector, int, int) instead")> _
Protected Friend Overridable Function Score ( _
    hc As HitCollector, _
    max As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Score(Collector, int, int) instead")]
protected public:
virtual bool Score(
    HitCollector^ hc,
    int max
)

Parameters

hc
Type: Lucene.Net.Search..::..HitCollector
The collector to which all matching documents are passed through {@link HitCollector#Collect(int, float)}.
max
Type: System..::..Int32
Do not score documents past this.

Return Value

true if more matching documents may remain.

See Also

Scorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector, Int32, Int32)

[image]

Lucene.Net Class Libraries
Scorer..::..Score Method (Collector, Int32, Int32)
Scorer Class See Also Send Feedback
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Score(
    Collector collector,
    int max,
    int firstDocID
)
Visual Basic
Public Overridable Function Score ( _
    collector As Collector, _
    max As Integer, _
    firstDocID As Integer _
) As Boolean
Visual C++
public:
virtual bool Score(
    Collector^ collector,
    int max,
    int firstDocID
)

Parameters

collector
Type: Lucene.Net.Search..::..Collector
The collector to which all matching documents are passed.
max
Type: System..::..Int32
Do not score documents past this.
firstDocID
Type: System..::..Int32
The first document ID (ensures {@link #NextDoc()} is called before this method.

Return Value

true if more matching documents may remain.

See Also

Scorer Class
Score Overload
Lucene.Net.Search Namespace


Searchable Interface

[image]

Lucene.Net Class Libraries
Searchable Interface
Members See Also Send Feedback
The interface for search implementations.

Searchable is the abstract network protocol for searching. Implementations provide search over a single index, over multiple indices, and over indices on remote servers.

Queries, filters and sort criteria are designed to be compact so that they may be efficiently passed to a remote index, with only the top-scoring hits being returned, rather than every matching hit. NOTE: this interface is kept public for convenience. Since it is not expected to be implemented directly, it may be changed unexpectedly between releases.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface Searchable
Visual Basic
Public Interface Searchable
Visual C++
public interface class Searchable

See Also

Searchable Members
Lucene.Net.Search Namespace


Searchable Members

[image] [image]

Lucene.Net Class Libraries
Searchable Members
Searchable Interface Methods See Also Send Feedback

The Searchable type exposes the following members.

Methods

Name Description
Public method Close
Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.
Public method Doc(Int32)
Expert: Returns the stored fields of document
CopyC#
i
. Called by {@link HitCollector} implementations.
Public method Doc(Int32, FieldSelector)
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.
Public method DocFreq
Expert: Returns the number of documents containing
CopyC#
term
. Called by search code to compute term weights.
Public method DocFreqs
Expert: For each term in the terms array, calculates the number of documents containing
CopyC#
term
. Returns an array with these document frequencies. Used to minimize number of remote calls.
Public method Explain
Expert: low-level implementation method Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
weight
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Applications should call {@link Searcher#Explain(Query, int)}.

Public method MaxDoc
Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Public method Rewrite
Expert: called to re-write queries into primitive queries.
Public method Search(Weight, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Weight, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every non-zero scoring document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Weight, Filter, Int32)
Expert: Low-level search implementation. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.

Called by {@link Hits}.

Applications should usually call {@link Searcher#Search(Query)} or {@link Searcher#Search(Query,Filter)} instead.

Public method Search(Weight, Filter, Int32, Sort)
Expert: Low-level search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

Applications should usually call {@link Searcher#Search(Query,Filter,int,Sort)} instead.

See Also

Searchable Interface
Lucene.Net.Search Namespace


Searchable Methods

[image] [image]

Lucene.Net Class Libraries
Searchable Methods
Searchable Interface See Also Send Feedback

The Searchable type exposes the following members.

Methods

Name Description
Public method Close
Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.
Public method Doc(Int32)
Expert: Returns the stored fields of document
CopyC#
i
. Called by {@link HitCollector} implementations.
Public method Doc(Int32, FieldSelector)
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.
Public method DocFreq
Expert: Returns the number of documents containing
CopyC#
term
. Called by search code to compute term weights.
Public method DocFreqs
Expert: For each term in the terms array, calculates the number of documents containing
CopyC#
term
. Returns an array with these document frequencies. Used to minimize number of remote calls.
Public method Explain
Expert: low-level implementation method Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
weight
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Applications should call {@link Searcher#Explain(Query, int)}.

Public method MaxDoc
Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.
Public method Rewrite
Expert: called to re-write queries into primitive queries.
Public method Search(Weight, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Weight, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every non-zero scoring document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Weight, Filter, Int32)
Expert: Low-level search implementation. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.

Called by {@link Hits}.

Applications should usually call {@link Searcher#Search(Query)} or {@link Searcher#Search(Query,Filter)} instead.

Public method Search(Weight, Filter, Int32, Sort)
Expert: Low-level search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

Applications should usually call {@link Searcher#Search(Query,Filter,int,Sort)} instead.

See Also

Searchable Interface
Lucene.Net.Search Namespace


Close Method

[image]

Lucene.Net Class Libraries
Searchable..::..Close Method
Searchable Interface See Also Send Feedback
Frees resources associated with this Searcher. Be careful not to call this method while you are still using objects like {@link Hits}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Close()
Visual Basic
Sub Close
Visual C++
void Close()

See Also

Searchable Interface
Lucene.Net.Search Namespace


Doc Method

[image] [image]

Lucene.Net Class Libraries
Searchable..::..Doc Method
Searchable Interface See Also Send Feedback

Overload List

Name Description
Public method Doc(Int32)
Expert: Returns the stored fields of document
CopyC#
i
. Called by {@link HitCollector} implementations.
Public method Doc(Int32, FieldSelector)
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

See Also

Searchable Interface
Searchable Members
Lucene.Net.Search Namespace


Doc Method (Int32)

[image]

Lucene.Net Class Libraries
Searchable..::..Doc Method (Int32)
Searchable Interface See Also Send Feedback
Expert: Returns the stored fields of document
CopyC#
i
. Called by {@link HitCollector} implementations.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Document Doc(
    int i
)
Visual Basic
Function Doc ( _
    i As Integer _
) As Document
Visual C++
Document^ Doc(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Search.Searchable.Doc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.Doc(System.Int32)"]

See Also

Searchable Interface
Doc Overload
Lucene.Net.Search Namespace
IndexReader..::..Document(Int32)


Doc Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
Searchable..::..Doc Method (Int32, FieldSelector)
Searchable Interface See Also Send Feedback
Get the {@link Lucene.Net.Documents.Document} at the
CopyC#
n
th position. The {@link Lucene.Net.Documents.FieldSelector} may be used to determine what {@link Lucene.Net.Documents.Field}s to load and how they should be loaded. NOTE: If the underlying Reader (more specifically, the underlying
CopyC#
FieldsReader
) is closed before the lazy {@link Lucene.Net.Documents.Field} is loaded an exception may be thrown. If you want the value of a lazy {@link Lucene.Net.Documents.Field} to be available after closing you must explicitly load it or fetch the Document again with a new loader.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Document Doc(
    int n,
    FieldSelector fieldSelector
)
Visual Basic
Function Doc ( _
    n As Integer, _
    fieldSelector As FieldSelector _
) As Document
Visual C++
Document^ Doc(
    int n,
    FieldSelector^ fieldSelector
)

Parameters

n
Type: System..::..Int32
Get the document at the
CopyC#
n
th position
fieldSelector
Type: Lucene.Net.Documents..::..FieldSelector
The {@link Lucene.Net.Documents.FieldSelector} to use to determine what Fields should be loaded on the Document. May be null, in which case all Fields will be loaded.

Return Value

The stored fields of the {@link Lucene.Net.Documents.Document} at the nth position

See Also

Searchable Interface
Doc Overload
Lucene.Net.Search Namespace
IndexReader..::..Document(Int32, FieldSelector)
Lucene.Net.Documents..::..Fieldable
Lucene.Net.Documents..::..FieldSelector
Lucene.Net.Documents..::..SetBasedFieldSelector
Lucene.Net.Documents..::..LoadFirstFieldSelector


DocFreq Method

[image]

Lucene.Net Class Libraries
Searchable..::..DocFreq Method
Searchable Interface See Also Send Feedback
Expert: Returns the number of documents containing
CopyC#
term
. Called by search code to compute term weights.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int DocFreq(
    Term term
)
Visual Basic
Function DocFreq ( _
    term As Term _
) As Integer
Visual C++
int DocFreq(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Searchable.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.DocFreq(Lucene.Net.Index.Term)"]

See Also

Searchable Interface
Lucene.Net.Search Namespace
IndexReader..::..DocFreq(Term)


DocFreqs Method

[image]

Lucene.Net Class Libraries
Searchable..::..DocFreqs Method
Searchable Interface See Also Send Feedback
Expert: For each term in the terms array, calculates the number of documents containing
CopyC#
term
. Returns an array with these document frequencies. Used to minimize number of remote calls.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int[] DocFreqs(
    Term[] terms
)
Visual Basic
Function DocFreqs ( _
    terms As Term() _
) As Integer()
Visual C++
array<int>^ DocFreqs(
    array<Term^>^ terms
)

Parameters

terms
Type: array< Lucene.Net.Index..::..Term >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Searchable.DocFreqs(Lucene.Net.Index.Term[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.DocFreqs(Lucene.Net.Index.Term[])"]

See Also

Searchable Interface
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
Searchable..::..Explain Method
Searchable Interface See Also Send Feedback
Expert: low-level implementation method Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
weight
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Applications should call {@link Searcher#Explain(Query, int)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Explanation Explain(
    Weight weight,
    int doc
)
Visual Basic
Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Visual C++
Explanation^ Explain(
    Weight^ weight,
    int doc
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searchable.Explain(Lucene.Net.Search.Weight,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Searchable.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.Explain(Lucene.Net.Search.Weight,System.Int32)"]

See Also

Searchable Interface
Lucene.Net.Search Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
Searchable..::..MaxDoc Method
Searchable Interface See Also Send Feedback
Expert: Returns one greater than the largest possible document number. Called by search code to compute term weights.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
int MaxDoc()
Visual Basic
Function MaxDoc As Integer
Visual C++
int MaxDoc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.MaxDoc"]

See Also

Searchable Interface
Lucene.Net.Search Namespace
IndexReader..::..MaxDoc()()()()


Rewrite Method

[image]

Lucene.Net Class Libraries
Searchable..::..Rewrite Method
Searchable Interface See Also Send Feedback
Expert: called to re-write queries into primitive queries.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
Query Rewrite(
    Query query
)
Visual Basic
Function Rewrite ( _
    query As Query _
) As Query
Visual C++
Query^ Rewrite(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searchable.Rewrite(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.Rewrite(Lucene.Net.Search.Query)"]

See Also

Searchable Interface
Lucene.Net.Search Namespace


Search Method

[image] [image]

Lucene.Net Class Libraries
Searchable..::..Search Method
Searchable Interface See Also Send Feedback

Overload List

Name Description
Public method Search(Weight, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Weight, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every non-zero scoring document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Weight, Filter, Int32)
Expert: Low-level search implementation. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.

Called by {@link Hits}.

Applications should usually call {@link Searcher#Search(Query)} or {@link Searcher#Search(Query,Filter)} instead.

Public method Search(Weight, Filter, Int32, Sort)
Expert: Low-level search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

Applications should usually call {@link Searcher#Search(Query,Filter,int,Sort)} instead.

See Also

Searchable Interface
Searchable Members
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Collector)

[image]

Lucene.Net Class Libraries
Searchable..::..Search Method (Weight, Filter, Collector)
Searchable Interface See Also Send Feedback
Lower-level search API.

{@link Collector#Collect(int)} is called for every document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
void Search(
    Weight weight,
    Filter filter,
    Collector collector
)
Visual Basic
Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    collector As Collector _
)
Visual C++
void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ collector
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight
to match documents
filter
Type: Lucene.Net.Search..::..Filter
if non-null, used to permit documents to be collected.
collector
Type: Lucene.Net.Search..::..Collector
to receive hits

See Also

Searchable Interface
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, HitCollector)

[image]

Lucene.Net Class Libraries
Searchable..::..Search Method (Weight, Filter, HitCollector)
Searchable Interface See Also Send Feedback
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every non-zero scoring document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Search(Weight, Filter, Collector) instead.")]
void Search(
    Weight weight,
    Filter filter,
    HitCollector results
)
Visual Basic
<ObsoleteAttribute("use Search(Weight, Filter, Collector) instead.")> _
Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    results As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Search(Weight, Filter, Collector) instead.")]
void Search(
    Weight^ weight,
    Filter^ filter,
    HitCollector^ results
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight
to match documents
filter
Type: Lucene.Net.Search..::..Filter
if non-null, used to permit documents to be collected.
results
Type: Lucene.Net.Search..::..HitCollector
to receive hits

See Also

Searchable Interface
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32)

[image]

Lucene.Net Class Libraries
Searchable..::..Search Method (Weight, Filter, Int32)
Searchable Interface See Also Send Feedback
Expert: Low-level search implementation. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.

Called by {@link Hits}.

Applications should usually call {@link Searcher#Search(Query)} or {@link Searcher#Search(Query,Filter)} instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
TopDocs Search(
    Weight weight,
    Filter filter,
    int n
)
Visual Basic
Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer _
) As TopDocs
Visual C++
TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

See Also

Searchable Interface
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32, Sort)

[image]

Lucene.Net Class Libraries
Searchable..::..Search Method (Weight, Filter, Int32, Sort)
Searchable Interface See Also Send Feedback
Expert: Low-level search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

Applications should usually call {@link Searcher#Search(Query,Filter,int,Sort)} instead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
Visual Basic
Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Visual C++
TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searchable.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

See Also

Searchable Interface
Search Overload
Lucene.Net.Search Namespace


Searcher Class

[image]

Lucene.Net Class Libraries
Searcher Class
Members See Also Send Feedback
An abstract base class for search implementations. Implements the main search methods.

Note that you can only access hits from a Searcher as long as it is not yet closed, otherwise an IOException will be thrown.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Searcher : MarshalByRefObject,
    Searchable, IDisposable
Visual Basic
Public MustInherit Class Searcher _
    Inherits MarshalByRefObject _
    Implements Searchable, IDisposable
Visual C++
public ref class Searcher abstract : public MarshalByRefObject,
    Searchable, IDisposable

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Lucene.Net.Search..::..Searcher
Lucene.Net.Search..::..IndexSearcher
Lucene.Net.Search..::..MultiSearcher

See Also

Searcher Members
Lucene.Net.Search Namespace


Searcher Members

[image] [image]

Lucene.Net Class Libraries
Searcher Members
Searcher Class Constructors Methods See Also Send Feedback

The Searcher type exposes the following members.

Constructors

 | Name | Description
Public method | Searcher | Initializes a new instance of the Searcher class

Methods

Name | Description
Public method | Close
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
creates a weight for
CopyC#
query
Public method Dispose
Releases all resources used by the Searcher
Public method | Doc(Int32)
Public method | Doc(Int32, FieldSelector)
Public method | DocFreq
Public method | DocFreqs
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Public method | Explain(Weight, Int32)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
Public method | Search(Weight, Filter, Collector)
Public method | Search(Weight, Filter, HitCollector) | Obsolete.
Public method | Search(Weight, Filter, Int32)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

Public method | Search(Weight, Filter, Int32, Sort)
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Searcher Class
Lucene.Net.Search Namespace


Searcher Constructor

[image]

Lucene.Net Class Libraries
Searcher Constructor
Searcher Class See Also Send Feedback
Initializes a new instance of the Searcher class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Searcher()
Visual Basic
Public Sub New
Visual C++
public:
Searcher()

See Also

Searcher Class
Lucene.Net.Search Namespace


Searcher Methods

[image] [image]

Lucene.Net Class Libraries
Searcher Methods
Searcher Class See Also Send Feedback

The Searcher type exposes the following members.

Methods

Name | Description
Public method | Close
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CreateWeight
creates a weight for
CopyC#
query
Public method | Dispose
Public method | Doc(Int32)
Public method | Doc(Int32, FieldSelector)
Public method | DocFreq
Public method | DocFreqs
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Public method | Explain(Weight, Int32)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetSimilarity
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | MaxDoc
Protected method MemberwiseClone()()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MemberwiseClone(Boolean)
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.)
Public method | Rewrite
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
Public method | Search(Weight, Filter, Collector)
Public method | Search(Weight, Filter, HitCollector) | Obsolete.
Public method | Search(Weight, Filter, Int32)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

Public method | Search(Weight, Filter, Int32, Sort)
Public method SetSimilarity
Expert: Set the Similarity implementation used by this Searcher.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Searcher Class
Lucene.Net.Search Namespace


Close Method

[image]

Lucene.Net Class Libraries
Searcher..::..Close Method
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Close"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

Implements

Searchable..::..Close()()()()

See Also

Searcher Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
Searcher..::..CreateWeight Method
Searcher Class See Also Send Feedback
creates a weight for
CopyC#
query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Weight CreateWeight(
    Query query
)
Visual Basic
Public Overridable Function CreateWeight ( _
    query As Query _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.CreateWeight(Lucene.Net.Search.Query)"]

Return Value

new weight

See Also

Searcher Class
Lucene.Net.Search Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
Searcher..::..Dispose Method
Searcher Class See Also Send Feedback
Releases all resources used by the Searcher

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Dispose()
Visual Basic
Public MustOverride Sub Dispose
Visual C++
public:
virtual void Dispose() abstract

Implements

IDisposable..::..Dispose()()()()

See Also

Searcher Class
Lucene.Net.Search Namespace


Doc Method

[image] [image]

Lucene.Net Class Libraries
Searcher..::..Doc Method
Searcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Doc(Int32) |
Public method | Doc(Int32, FieldSelector) |

See Also

Searcher Class
Searcher Members
Lucene.Net.Search Namespace


Doc Method (Int32)

[image]

Lucene.Net Class Libraries
Searcher..::..Doc Method (Int32)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Document Doc(
    int i
)
Visual Basic
Public MustOverride Function Doc ( _
    i As Integer _
) As Document
Visual C++
public:
virtual Document^ Doc(
    int i
) abstract

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32)"]

Implements

Searchable..::..Doc(Int32)

See Also

Searcher Class
Doc Overload
Lucene.Net.Search Namespace


Doc Method (Int32, FieldSelector)

[image]

Lucene.Net Class Libraries
Searcher..::..Doc Method (Int32, FieldSelector)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Document Doc(
    int param1,
    FieldSelector param2
)
Visual Basic
Public MustOverride Function Doc ( _
    param1 As Integer, _
    param2 As FieldSelector _
) As Document
Visual C++
public:
virtual Document^ Doc(
    int param1,
    FieldSelector^ param2
) abstract

Parameters

param1
Type: System..::..Int32

[Missing <param name="param1"/> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

param2
Type: Lucene.Net.Documents..::..FieldSelector

[Missing <param name="param2"/> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Doc(System.Int32,Lucene.Net.Documents.FieldSelector)"]

Implements

Searchable..::..Doc(Int32, FieldSelector)

See Also

Searcher Class
Doc Overload
Lucene.Net.Search Namespace


DocFreq Method

[image]

Lucene.Net Class Libraries
Searcher..::..DocFreq Method
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.DocFreq(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int DocFreq(
    Term term
)
Visual Basic
Public MustOverride Function DocFreq ( _
    term As Term _
) As Integer
Visual C++
public:
virtual int DocFreq(
    Term^ term
) abstract

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Searcher.DocFreq(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.DocFreq(Lucene.Net.Index.Term)"]

Implements

Searchable..::..DocFreq(Term)

See Also

Searcher Class
Lucene.Net.Search Namespace


DocFreqs Method

[image]

Lucene.Net Class Libraries
Searcher..::..DocFreqs Method
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.DocFreqs(Lucene.Net.Index.Term[])"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int[] DocFreqs(
    Term[] terms
)
Visual Basic
Public Overridable Function DocFreqs ( _
    terms As Term() _
) As Integer()
Visual C++
public:
virtual array<int>^ DocFreqs(
    array<Term^>^ terms
)

Parameters

terms
Type: array< Lucene.Net.Index..::..Term >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Searcher.DocFreqs(Lucene.Net.Index.Term[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.DocFreqs(Lucene.Net.Index.Term[])"]

Implements

Searchable..::..DocFreqs(array<Term>[]()[][])

See Also

Searcher Class
Lucene.Net.Search Namespace


Explain Method

[image] [image]

Lucene.Net Class Libraries
Searcher..::..Explain Method
Searcher Class See Also Send Feedback

Overload List

Name | Description
Public method Explain(Query, Int32)
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Public method | Explain(Weight, Int32)

See Also

Searcher Class
Searcher Members
Lucene.Net.Search Namespace


Explain Method (Query, Int32)

[image]

Lucene.Net Class Libraries
Searcher..::..Explain Method (Query, Int32)
Searcher Class See Also Send Feedback
Returns an Explanation that describes how
CopyC#
doc
 scored against
CopyC#
query
.

This is intended to be used in developing Similarity implementations, and, for good performance, should not be displayed with every hit. Computing an explanation is as expensive as executing the query over the entire index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation Explain(
    Query query,
    int doc
)
Visual Basic
Public Overridable Function Explain ( _
    query As Query, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    Query^ query,
    int doc
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Query,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Query,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Query,System.Int32)"]

See Also

Searcher Class
Explain Overload
Lucene.Net.Search Namespace


Explain Method (Weight, Int32)

[image]

Lucene.Net Class Libraries
Searcher..::..Explain Method (Weight, Int32)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Explanation Explain(
    Weight weight,
    int doc
)
Visual Basic
Public MustOverride Function Explain ( _
    weight As Weight, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    Weight^ weight,
    int doc
) abstract

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Explain(Lucene.Net.Search.Weight,System.Int32)"]

Implements

Searchable..::..Explain(Weight, Int32)

See Also

Searcher Class
Explain Overload
Lucene.Net.Search Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
Searcher..::..GetSimilarity Method
Searcher Class See Also Send Feedback
Expert: Return the Similarity implementation used by this Searcher.

This defaults to the current value of {@link Similarity#GetDefault()}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Similarity GetSimilarity()
Visual Basic
Public Overridable Function GetSimilarity As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.GetSimilarity"]

See Also

Searcher Class
Lucene.Net.Search Namespace


MaxDoc Method

[image]

Lucene.Net Class Libraries
Searcher..::..MaxDoc Method
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.MaxDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int MaxDoc()
Visual Basic
Public MustOverride Function MaxDoc As Integer
Visual C++
public:
virtual int MaxDoc() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.MaxDoc"]

Implements

Searchable..::..MaxDoc()()()()

See Also

Searcher Class
Lucene.Net.Search Namespace


MemberwiseClone Method

[image] [image]

Lucene.Net Class Libraries
Searcher..::..MemberwiseClone Method
Searcher Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Searcher Class
Searcher Members
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
Searcher..::..Rewrite Method
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Rewrite(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Query Rewrite(
    Query query
)
Visual Basic
Public MustOverride Function Rewrite ( _
    query As Query _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    Query^ query
) abstract

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Rewrite(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Rewrite(Lucene.Net.Search.Query)"]

Implements

Searchable..::..Rewrite(Query)

See Also

Searcher Class
Lucene.Net.Search Namespace


Search Method

[image] [image]

Lucene.Net Class Libraries
Searcher..::..Search Method
Searcher Class See Also Send Feedback

Overload List

Name | Description
Public method Search(Query) Obsolete.
Returns the documents matching
CopyC#
query
.
Public method Search(Query, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Filter) Obsolete.
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.
Public method Search(Query, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.
Public method Search(Query, Sort) Obsolete.
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.
Public method Search(Query, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
.
Public method Search(Query, Filter, Collector)
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Query, Filter, HitCollector) Obsolete.
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Public method Search(Query, Filter, Sort) Obsolete.
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.
Public method Search(Query, Filter, Int32)
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.
Public method | Search(Weight, Filter, Collector)
Public method | Search(Weight, Filter, HitCollector) | Obsolete.
Public method | Search(Weight, Filter, Int32)
Public method Search(Query, Filter, Int32, Sort)
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

Public method | Search(Weight, Filter, Int32, Sort)

See Also

Searcher Class
Searcher Members
Lucene.Net.Search Namespace


Search Method (Query)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query)
Searcher Class See Also Send Feedback
Returns the documents matching
CopyC#
query
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead")]
public Hits Search(
    Query query
)
Visual Basic
<ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead")> _
Public Function Search ( _
    query As Query _
) As Hits
Visual C++
[ObsoleteAttribute(L"Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead")]
public:
Hits^ Search(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Collector)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Collector)
Searcher Class See Also Send Feedback
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, int)} ) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Search(
    Query query,
    Collector results
)
Visual Basic
Public Overridable Sub Search ( _
    query As Query, _
    results As Collector _
)
Visual C++
public:
virtual void Search(
    Query^ query,
    Collector^ results
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Collector)"]

results
Type: Lucene.Net.Search..::..Collector

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Collector)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Filter)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Filter)
Searcher Class See Also Send Feedback
Returns the documents matching
CopyC#
query
 and
CopyC#
filter
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead")]
public virtual Hits Search(
    Query query,
    Filter filter
)
Visual Basic
<ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead")> _
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter _
) As Hits
Visual C++
[ObsoleteAttribute(L"Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int) instead")]
public:
virtual Hits^ Search(
    Query^ query,
    Filter^ filter
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, HitCollector)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, HitCollector)
Searcher Class See Also Send Feedback
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query)}) is usually more efficient, as it skips non-high-scoring hits.

Note: The

CopyC#
score
passed to this method is a raw score. In other words, the score will not necessarily be a float whose value is between 0 and 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Search(Query, Collector) instead.")]
public virtual void Search(
    Query query,
    HitCollector results
)
Visual Basic
<ObsoleteAttribute("use Search(Query, Collector) instead.")> _
Public Overridable Sub Search ( _
    query As Query, _
    results As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Search(Query, Collector) instead.")]
public:
virtual void Search(
    Query^ query,
    HitCollector^ results
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.HitCollector)"]

results
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.HitCollector)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Sort)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Sort)
Searcher Class See Also Send Feedback
Returns documents matching
CopyC#
query
 sorted by
CopyC#
sort
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead")]
public virtual Hits Search(
    Query query,
    Sort sort
)
Visual Basic
<ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead")> _
Public Overridable Function Search ( _
    query As Query, _
    sort As Sort _
) As Hits
Visual C++
[ObsoleteAttribute(L"Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead")]
public:
virtual Hits^ Search(
    Query^ query,
    Sort^ sort
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Sort)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Int32)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Int32)
Searcher Class See Also Send Feedback
Finds the top
CopyC#
n
 hits for
CopyC#
query
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TopDocs Search(
    Query query,
    int n
)
Visual Basic
Public Overridable Function Search ( _
    query As Query, _
    n As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ Search(
    Query^ query,
    int n
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,System.Int32)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,System.Int32)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Filter, Collector)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Filter, Collector)
Searcher Class See Also Send Feedback
Lower-level search API.

{@link Collector#Collect(int)} is called for every matching document.
Collector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Search(
    Query query,
    Filter filter,
    Collector results
)
Visual Basic
Public Overridable Sub Search ( _
    query As Query, _
    filter As Filter, _
    results As Collector _
)
Visual C++
public:
virtual void Search(
    Query^ query,
    Filter^ filter,
    Collector^ results
)

Parameters

query
Type: Lucene.Net.Search..::..Query
to match documents
filter
Type: Lucene.Net.Search..::..Filter
if non-null, used to permit documents to be collected.
results
Type: Lucene.Net.Search..::..Collector
to receive hits

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Filter, HitCollector)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Filter, HitCollector)
Searcher Class See Also Send Feedback
Lower-level search API.

{@link HitCollector#Collect(int,float)} is called for every matching document.
HitCollector-based access to remote indexes is discouraged.

Applications should only use this if they need all of the matching documents. The high-level search API ({@link Searcher#Search(Query, Filter, int)}) is usually more efficient, as it skips non-high-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Search(Query, Filter, Collector) instead.")]
public virtual void Search(
    Query query,
    Filter filter,
    HitCollector results
)
Visual Basic
<ObsoleteAttribute("use Search(Query, Filter, Collector) instead.")> _
Public Overridable Sub Search ( _
    query As Query, _
    filter As Filter, _
    results As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Search(Query, Filter, Collector) instead.")]
public:
virtual void Search(
    Query^ query,
    Filter^ filter,
    HitCollector^ results
)

Parameters

query
Type: Lucene.Net.Search..::..Query
to match documents
filter
Type: Lucene.Net.Search..::..Filter
if non-null, used to permit documents to be collected.
results
Type: Lucene.Net.Search..::..HitCollector
to receive hits

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Filter, Sort)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Filter, Sort)
Searcher Class See Also Send Feedback
Returns documents matching
CopyC#
query
 and
CopyC#
filter
, sorted by
CopyC#
sort
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead")]
public virtual Hits Search(
    Query query,
    Filter filter,
    Sort sort
)
Visual Basic
<ObsoleteAttribute("Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead")> _
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    sort As Sort _
) As Hits
Visual C++
[ObsoleteAttribute(L"Hits will be removed in Lucene 3.0. Use Search(Query, Filter, int, Sort) instead")]
public:
virtual Hits^ Search(
    Query^ query,
    Filter^ filter,
    Sort^ sort
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,Lucene.Net.Search.Sort)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Filter, Int32)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Filter, Int32)
Searcher Class See Also Send Feedback
Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TopDocs Search(
    Query query,
    Filter filter,
    int n
)
Visual Basic
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    n As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ Search(
    Query^ query,
    Filter^ filter,
    int n
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Collector)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Weight, Filter, Collector)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Search(
    Weight weight,
    Filter filter,
    Collector results
)
Visual Basic
Public MustOverride Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    results As Collector _
)
Visual C++
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    Collector^ results
) abstract

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

results
Type: Lucene.Net.Search..::..Collector

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.Collector)"]

Implements

Searchable..::..Search(Weight, Filter, Collector)

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, HitCollector)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Weight, Filter, HitCollector)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.HitCollector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Search(Weight, Filter, Collector) instead.")]
public virtual void Search(
    Weight weight,
    Filter filter,
    HitCollector results
)
Visual Basic
<ObsoleteAttribute("use Search(Weight, Filter, Collector) instead.")> _
Public Overridable Sub Search ( _
    weight As Weight, _
    filter As Filter, _
    results As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Search(Weight, Filter, Collector) instead.")]
public:
virtual void Search(
    Weight^ weight,
    Filter^ filter,
    HitCollector^ results
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.HitCollector)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.HitCollector)"]

results
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,Lucene.Net.Search.HitCollector)"]

Implements

Searchable..::..Search(Weight, Filter, HitCollector)

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Weight, Filter, Int32)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TopDocs Search(
    Weight weight,
    Filter filter,
    int n
)
Visual Basic
Public MustOverride Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n
) abstract

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32)"]

Implements

Searchable..::..Search(Weight, Filter, Int32)

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Query, Filter, Int32, Sort)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Query, Filter, Int32, Sort)
Searcher Class See Also Send Feedback
Search implementation with arbitrary sorting. Finds the top
CopyC#
n
 hits for
CopyC#
query
, applying
CopyC#
filter
 if non-null, and sorting the hits by the criteria in
CopyC#
sort
.

NOTE: this does not compute scores by default; use {@link IndexSearcher#setDefaultFieldSortScoring} to enable scoring.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TopFieldDocs Search(
    Query query,
    Filter filter,
    int n,
    Sort sort
)
Visual Basic
Public Overridable Function Search ( _
    query As Query, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Visual C++
public:
virtual TopFieldDocs^ Search(
    Query^ query,
    Filter^ filter,
    int n,
    Sort^ sort
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Query,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


Search Method (Weight, Filter, Int32, Sort)

[image]

Lucene.Net Class Libraries
Searcher..::..Search Method (Weight, Filter, Int32, Sort)
Searcher Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract TopFieldDocs Search(
    Weight weight,
    Filter filter,
    int n,
    Sort sort
)
Visual Basic
Public MustOverride Function Search ( _
    weight As Weight, _
    filter As Filter, _
    n As Integer, _
    sort As Sort _
) As TopFieldDocs
Visual C++
public:
virtual TopFieldDocs^ Search(
    Weight^ weight,
    Filter^ filter,
    int n,
    Sort^ sort
) abstract

Parameters

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

filter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="filter"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

sort
Type: Lucene.Net.Search..::..Sort

[Missing <param name="sort"/> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Searcher.Search(Lucene.Net.Search.Weight,Lucene.Net.Search.Filter,System.Int32,Lucene.Net.Search.Sort)"]

Implements

Searchable..::..Search(Weight, Filter, Int32, Sort)

See Also

Searcher Class
Search Overload
Lucene.Net.Search Namespace


SetSimilarity Method

[image]

Lucene.Net Class Libraries
Searcher..::..SetSimilarity Method
Searcher Class See Also Send Feedback
Expert: Set the Similarity implementation used by this Searcher.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSimilarity(
    Similarity similarity
)
Visual Basic
Public Overridable Sub SetSimilarity ( _
    similarity As Similarity _
)
Visual C++
public:
virtual void SetSimilarity(
    Similarity^ similarity
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Searcher.SetSimilarity(Lucene.Net.Search.Similarity)"]

See Also

Searcher Class
Lucene.Net.Search Namespace
Similarity..::..SetDefault(Similarity)


ShortParser Interface

[image]

Lucene.Net Class Libraries
ShortParser Interface
Members See Also Send Feedback
Interface to parse shorts from document fields.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface ShortParser : Parser
Visual Basic
Public Interface ShortParser _
    Inherits Parser
Visual C++
public interface class ShortParser : Parser

See Also

ShortParser Members
Lucene.Net.Search Namespace
[!:FieldCache.GetShorts(IndexReader, String, FieldCache.ShortParser)]


ShortParser Members

[image] [image]

Lucene.Net Class Libraries
ShortParser Members
ShortParser Interface Methods See Also Send Feedback

The ShortParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseShort | Return a short representation of this field's value.

See Also

ShortParser Interface
Lucene.Net.Search Namespace


ShortParser Methods

[image] [image]

Lucene.Net Class Libraries
ShortParser Methods
ShortParser Interface See Also Send Feedback

The ShortParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseShort | Return a short representation of this field's value.

See Also

ShortParser Interface
Lucene.Net.Search Namespace


ParseShort Method

[image]

Lucene.Net Class Libraries
ShortParser..::..ParseShort Method
ShortParser Interface See Also Send Feedback
Return a short representation of this field's value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
short ParseShort(
    string string_Renamed
)
Visual Basic
Function ParseShort ( _
    string_Renamed As String _
) As Short
Visual C++
short ParseShort(
    String^ string_Renamed
)

Parameters

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.ShortParser.ParseShort(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ShortParser.ParseShort(System.String)"]

See Also

ShortParser Interface
Lucene.Net.Search Namespace


Similarity Class

[image]

Lucene.Net Class Libraries
Similarity Class
Members See Also Send Feedback
Expert: Scoring API.

Subclasses implement search scoring.

The score of query

CopyC#
q
for document
CopyC#
d
 correlates to the cosine-distance or dot-product between document and query vectors in a Vector Space Model (VSM) of Information Retrieval. A document whose vector is closer to the query vector in that model is scored higher. The score is computed as follows:

score(q,d) = coord(q,d) · queryNorm(q) · | ∑ | (tf(t in d) · idf(t)2 · t.getBoost() · norm(t,d))
 | t in q |

where

  1. tf(t in d) correlates to the term's frequency, defined as the number of times term t appears in the currently scored document d. Documents that have more occurrences of a given term receive a higher score. The default computation for tf(t in d) in {@link Lucene.Net.Search.DefaultSimilarity#Tf(float) DefaultSimilarity} is:

    {@link Lucene.Net.Search.DefaultSimilarity#Tf(float) tf(t in d)} = frequency½

  2. idf(t) stands for Inverse Document Frequency. This value correlates to the inverse of docFreq (the number of documents in which the term t appears). This means rarer terms give higher contribution to the total score. The default computation for idf(t) in {@link Lucene.Net.Search.DefaultSimilarity#Idf(int, int) DefaultSimilarity} is:

    {@link Lucene.Net.Search.DefaultSimilarity#Idf(int, int) idf(t)} = 1 + log (
    numDocs
    –––––––––
    docFreq+1
            )

  3. coord(q,d) is a score factor based on how many of the query terms are found in the specified document. Typically, a document that contains more of the query's terms will receive a higher score than another document with fewer query terms. This is a search time factor computed in {@link #Coord(int, int) coord(q,d)} by the Similarity in effect at search time.

  4. queryNorm(q) is a normalizing factor used to make scores between queries comparable. This factor does not affect document ranking (since all ranked documents are multiplied by the same factor), but rather just attempts to make scores from different queries (or even different indexes) comparable. This is a search time factor computed by the Similarity in effect at search time. The default computation in {@link Lucene.Net.Search.DefaultSimilarity#QueryNorm(float) DefaultSimilarity} is:

    queryNorm(q) = {@link Lucene.Net.Search.DefaultSimilarity#QueryNorm(float) queryNorm(sumOfSquaredWeights)} =
    1
    ––––––––––––––
    sumOfSquaredWeights½

    The sum of squared weights (of the query terms) is computed by the query {@link Lucene.Net.Search.Weight} object. For example, a {@link Lucene.Net.Search.BooleanQuery boolean query} computes this value as:

    {@link Lucene.Net.Search.Weight#SumOfSquaredWeights() sumOfSquaredWeights} = {@link Lucene.Net.Search.Query#GetBoost() q.getBoost()} 2 · ∑ (idf(t) · t.getBoost()) 2
    t in q

  5. t.getBoost() is a search time boost of term t in the query q as specified in the query text (see query syntax), or as set by application calls to {@link Lucene.Net.Search.Query#SetBoost(float) setBoost()}. Notice that there is really no direct API for accessing a boost of one term in a multi term query, but rather multi terms are represented in a query as multi {@link Lucene.Net.Search.TermQuery TermQuery} objects, and so the boost of a term in the query is accessible by calling the sub-query {@link Lucene.Net.Search.Query#GetBoost() getBoost()}.

  6. norm(t,d) encapsulates a few (indexing time) boost and length factors:
    • Document boost - set by calling {@link Lucene.Net.Documents.Document#SetBoost(float) doc.setBoost()} before adding the document to the index.
    • Field boost - set by calling {@link Lucene.Net.Documents.Fieldable#SetBoost(float) field.setBoost()} before adding the field to a document.
    • {@link #LengthNorm(String, int) lengthNorm(field)} - computed when the document is added to the index in accordance with the number of tokens of this field in the document, so that shorter fields contribute more to the score. LengthNorm is computed by the Similarity class in effect at indexing.

    When a document is added to the index, all the above factors are multiplied. If the document has multiple fields with the same name, all their boosts are multiplied together:

    norm(t,d) = {@link Lucene.Net.Documents.Document#GetBoost() doc.getBoost()} · {@link #LengthNorm(String, int) lengthNorm(field)} · ∏ {@link Lucene.Net.Documents.Fieldable#GetBoost() f.getBoost}()
    field f in d named as t

    However the resulted norm value is {@link #EncodeNorm(float) encoded} as a single byte before being stored. At search time, the norm byte value is read from the index {@link Lucene.Net.Store.Directory directory} and {@link #DecodeNorm(byte) decoded} back to a float norm value. This encoding/decoding, while reducing index size, comes with the price of precision loss - it is not guaranteed that decode(encode(x)) = x. For instance, decode(encode(0.89)) = 0.75. Also notice that search time is too late to modify this norm part of scoring, e.g. by using a different {@link Similarity} for search.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class Similarity
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Similarity
Visual C++
[SerializableAttribute]
public ref class Similarity abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Similarity
Lucene.Net.Search..::..DefaultSimilarity
Lucene.Net.Search..::..SimilarityDelegator

See Also

Similarity Members
Lucene.Net.Search Namespace
Similarity..::..SetDefault(Similarity)
IndexWriter..::..SetSimilarity(Similarity)
Searcher..::..SetSimilarity(Similarity)


Similarity Members

[image] [image]

Lucene.Net Class Libraries
Similarity Members
Similarity Class Constructors Methods Fields See Also Send Feedback

The Similarity type exposes the following members.

Constructors

 | Name | Description
Public method | Similarity | Initializes a new instance of the Similarity class

Methods

Name Description
Public method ComputeNorm
Compute the normalization value for a field, given the accumulated state of term processing for this field (see {@link FieldInvertState}).

Implementations should calculate a float value based on the field state and then return that value.

For backward compatibility this method by default calls {@link #LengthNorm(String, int)} passing {@link FieldInvertState#GetLength()} as the second argument, and then multiplies this value by {@link FieldInvertState#GetBoost()}.

WARNING: This API is new and experimental and may suddenly change.

Public method Coord
Computes a score factor based on the fraction of all query terms that a document contains. This value is multiplied into scores.

The presence of a large portion of the query terms indicates a better match with the query, so implementations of this method usually return larger values when the ratio between these parameters is large and smaller values when the ratio between them is small.

DecodeNorm
Decodes a normalization factor stored in an index.
EncodeNorm
Encodes a normalization factor for storage in an index.

The encoding uses a three-bit mantissa, a five-bit exponent, and the zero-exponent point at 15, thus representing values from around 7x10^9 to 2x10^-9 with about one significant decimal digit of accuracy. Zero is also represented. Negative numbers are rounded up to zero. Values too large to represent are rounded down to the largest representable value. Positive values too small to represent are rounded up to the smallest positive representable value.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetDefault
Return the default Similarity implementation used by indexing and search code.

This is initially an instance of {@link DefaultSimilarity}.

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetNormDecoder
Returns a table for decoding normalization bytes.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

Public method Idf(Int32, Int32)
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the {@link #Tf(int)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.

Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method idfExplain
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

Public method IdfExplain
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method LengthNorm
Computes the normalization value for a field given the total number of terms contained in a field. These values, together with field boosts, are stored in an index and multipled into scores for hits on each field by the search code.

Matches in longer fields are less precise, so implementations of this method usually return smaller values when

CopyC#
numTokens
is large, and larger values when
CopyC#
numTokens
 is small.

Note that the return values are computed under {@link Lucene.Net.Index.IndexWriter#AddDocument(Lucene.Net.Documents.Document)} and then stored using {@link #EncodeNorm(float)}. Thus they have limited precision, and documents must be re-indexed if this method is altered.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method QueryNorm
Computes the normalization value for a query given the sum of the squared weights of each of the query terms. This value is then multipled into the weight of each query term.

This does not affect ranking, but rather just attempts to make scores from different queries comparable.

Public method ScorePayload(String, array<Byte>[]()[][], Int32, Int32) Obsolete.
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

Public method ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

SetDefault
Set the default Similarity implementation used by indexing and search code.
Public method SloppyFreq
Computes the amount of a sloppy phrase match, based on an edit distance. This value is summed for each sloppy phrase match in a document to form the frequency that is passed to {@link #Tf(float)}.

A phrase match with a small edit distance to a document passage more closely matches the document, so implementations of this method usually return larger values when the edit distance is small and smaller values when it is large.

Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

Public method Tf(Single)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name | Description
NO_DOC_ID_PROVIDED |

See Also

Similarity Class
Lucene.Net.Search Namespace


Similarity Constructor

[image]

Lucene.Net Class Libraries
Similarity Constructor
Similarity Class See Also Send Feedback
Initializes a new instance of the Similarity class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Similarity()
Visual Basic
Public Sub New
Visual C++
public:
Similarity()

See Also

Similarity Class
Lucene.Net.Search Namespace


Similarity Fields

[image] [image]

Lucene.Net Class Libraries
Similarity Fields
Similarity Class See Also Send Feedback

The Similarity type exposes the following members.

Fields

Name | Description
NO_DOC_ID_PROVIDED |

See Also

Similarity Class
Lucene.Net.Search Namespace


NO_DOC_ID_PROVIDED Field

[image]

Lucene.Net Class Libraries
Similarity..::..NO_DOC_ID_PROVIDED Field
Similarity Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Similarity.NO_DOC_ID_PROVIDED"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int NO_DOC_ID_PROVIDED
Visual Basic
Public Const NO_DOC_ID_PROVIDED As Integer
Visual C++
public:
literal int NO_DOC_ID_PROVIDED

See Also

Similarity Class
Lucene.Net.Search Namespace


Similarity Methods

[image] [image]

Lucene.Net Class Libraries
Similarity Methods
Similarity Class See Also Send Feedback

The Similarity type exposes the following members.

Methods

Name Description
Public method ComputeNorm
Compute the normalization value for a field, given the accumulated state of term processing for this field (see {@link FieldInvertState}).

Implementations should calculate a float value based on the field state and then return that value.

For backward compatibility this method by default calls {@link #LengthNorm(String, int)} passing {@link FieldInvertState#GetLength()} as the second argument, and then multiplies this value by {@link FieldInvertState#GetBoost()}.

WARNING: This API is new and experimental and may suddenly change.

Public method Coord
Computes a score factor based on the fraction of all query terms that a document contains. This value is multiplied into scores.

The presence of a large portion of the query terms indicates a better match with the query, so implementations of this method usually return larger values when the ratio between these parameters is large and smaller values when the ratio between them is small.

DecodeNorm
Decodes a normalization factor stored in an index.
EncodeNorm
Encodes a normalization factor for storage in an index.

The encoding uses a three-bit mantissa, a five-bit exponent, and the zero-exponent point at 15, thus representing values from around 7x10^9 to 2x10^-9 with about one significant decimal digit of accuracy. Zero is also represented. Negative numbers are rounded up to zero. Values too large to represent are rounded down to the largest representable value. Positive values too small to represent are rounded up to the smallest positive representable value.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetDefault
Return the default Similarity implementation used by indexing and search code.

This is initially an instance of {@link DefaultSimilarity}.

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetNormDecoder
Returns a table for decoding normalization bytes.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

Public method Idf(Int32, Int32)
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the {@link #Tf(int)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.

Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method idfExplain
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

Public method IdfExplain
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
Public method LengthNorm
Computes the normalization value for a field given the total number of terms contained in a field. These values, together with field boosts, are stored in an index and multipled into scores for hits on each field by the search code.

Matches in longer fields are less precise, so implementations of this method usually return smaller values when

CopyC#
numTokens
is large, and larger values when
CopyC#
numTokens
 is small.

Note that the return values are computed under {@link Lucene.Net.Index.IndexWriter#AddDocument(Lucene.Net.Documents.Document)} and then stored using {@link #EncodeNorm(float)}. Thus they have limited precision, and documents must be re-indexed if this method is altered.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method QueryNorm
Computes the normalization value for a query given the sum of the squared weights of each of the query terms. This value is then multipled into the weight of each query term.

This does not affect ranking, but rather just attempts to make scores from different queries comparable.

Public method ScorePayload(String, array<Byte>[]()[][], Int32, Int32) Obsolete.
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

Public method ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

SetDefault
Set the default Similarity implementation used by indexing and search code.
Public method SloppyFreq
Computes the amount of a sloppy phrase match, based on an edit distance. This value is summed for each sloppy phrase match in a document to form the frequency that is passed to {@link #Tf(float)}.

A phrase match with a small edit distance to a document passage more closely matches the document, so implementations of this method usually return larger values when the edit distance is small and smaller values when it is large.

Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

Public method Tf(Single)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Similarity Class
Lucene.Net.Search Namespace


ComputeNorm Method

[image]

Lucene.Net Class Libraries
Similarity..::..ComputeNorm Method
Similarity Class See Also Send Feedback
Compute the normalization value for a field, given the accumulated state of term processing for this field (see {@link FieldInvertState}).

Implementations should calculate a float value based on the field state and then return that value.

For backward compatibility this method by default calls {@link #LengthNorm(String, int)} passing {@link FieldInvertState#GetLength()} as the second argument, and then multiplies this value by {@link FieldInvertState#GetBoost()}.

WARNING: This API is new and experimental and may suddenly change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float ComputeNorm(
    string field,
    FieldInvertState state
)
Visual Basic
Public Overridable Function ComputeNorm ( _
    field As String, _
    state As FieldInvertState _
) As Single
Visual C++
public:
virtual float ComputeNorm(
    String^ field,
    FieldInvertState^ state
)

Parameters

field
Type: System..::..String
field name
state
Type: Lucene.Net.Index..::..FieldInvertState
current processing state for this field

Return Value

the calculated float norm

See Also

Similarity Class
Lucene.Net.Search Namespace


Coord Method

[image]

Lucene.Net Class Libraries
Similarity..::..Coord Method
Similarity Class See Also Send Feedback
Computes a score factor based on the fraction of all query terms that a document contains. This value is multiplied into scores.

The presence of a large portion of the query terms indicates a better match with the query, so implementations of this method usually return larger values when the ratio between these parameters is large and smaller values when the ratio between them is small.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float Coord(
    int overlap,
    int maxOverlap
)
Visual Basic
Public MustOverride Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
Visual C++
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) abstract

Parameters

overlap
Type: System..::..Int32
the number of query terms matched in the document
maxOverlap
Type: System..::..Int32
the total number of terms in the query

Return Value

a score factor based on term overlap with the query

See Also

Similarity Class
Lucene.Net.Search Namespace


DecodeNorm Method

[image]

Lucene.Net Class Libraries
Similarity..::..DecodeNorm Method
Similarity Class See Also Send Feedback
Decodes a normalization factor stored in an index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float DecodeNorm(
    byte b
)
Visual Basic
Public Shared Function DecodeNorm ( _
    b As Byte _
) As Single
Visual C++
public:
static float DecodeNorm(
    unsigned char b
)

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Search.Similarity.DecodeNorm(System.Byte)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similarity.DecodeNorm(System.Byte)"]

See Also

Similarity Class
Lucene.Net.Search Namespace
Similarity..::..EncodeNorm(Single)


EncodeNorm Method

[image]

Lucene.Net Class Libraries
Similarity..::..EncodeNorm Method
Similarity Class See Also Send Feedback
Encodes a normalization factor for storage in an index.

The encoding uses a three-bit mantissa, a five-bit exponent, and the zero-exponent point at 15, thus representing values from around 7x10^9 to 2x10^-9 with about one significant decimal digit of accuracy. Zero is also represented. Negative numbers are rounded up to zero. Values too large to represent are rounded down to the largest representable value. Positive values too small to represent are rounded up to the smallest positive representable value.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte EncodeNorm(
    float f
)
Visual Basic
Public Shared Function EncodeNorm ( _
    f As Single _
) As Byte
Visual C++
public:
static unsigned char EncodeNorm(
    float f
)

Parameters

f
Type: System..::..Single

[Missing <param name="f"/> documentation for "M:Lucene.Net.Search.Similarity.EncodeNorm(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similarity.EncodeNorm(System.Single)"]

See Also

Similarity Class
Lucene.Net.Search Namespace
[!:Lucene.Net.Documents.Field.SetBoost(float)]
Lucene.Net.Util..::..SmallFloat


GetDefault Method

[image]

Lucene.Net Class Libraries
Similarity..::..GetDefault Method
Similarity Class See Also Send Feedback
Return the default Similarity implementation used by indexing and search code.

This is initially an instance of {@link DefaultSimilarity}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Similarity GetDefault()
Visual Basic
Public Shared Function GetDefault As Similarity
Visual C++
public:
static Similarity^ GetDefault()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similarity.GetDefault"]

See Also

Similarity Class
Lucene.Net.Search Namespace
Searcher..::..SetSimilarity(Similarity)
IndexWriter..::..SetSimilarity(Similarity)


GetNormDecoder Method

[image]

Lucene.Net Class Libraries
Similarity..::..GetNormDecoder Method
Similarity Class See Also Send Feedback
Returns a table for decoding normalization bytes.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float[] GetNormDecoder()
Visual Basic
Public Shared Function GetNormDecoder As Single()
Visual C++
public:
static array<float>^ GetNormDecoder()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similarity.GetNormDecoder"]

See Also

Similarity Class
Lucene.Net.Search Namespace
Similarity..::..EncodeNorm(Single)


Idf Method

[image] [image]

Lucene.Net Class Libraries
Similarity..::..Idf Method
Similarity Class See Also Send Feedback

Overload List

Name Description
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

Public method Idf(Int32, Int32)
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the {@link #Tf(int)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.

Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.

See Also

Similarity Class
Similarity Members
Lucene.Net.Search Namespace


Idf Method (ICollection, Searcher)

[image]

Lucene.Net Class Libraries
Similarity..::..Idf Method (ICollection, Searcher)
Similarity Class See Also Send Feedback
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("see IdfExplain(Collection, Searcher)")]
public virtual float Idf(
    ICollection terms,
    Searcher searcher
)
Visual Basic
<ObsoleteAttribute("see IdfExplain(Collection, Searcher)")> _
Public Overridable Function Idf ( _
    terms As ICollection, _
    searcher As Searcher _
) As Single
Visual C++
[ObsoleteAttribute(L"see IdfExplain(Collection, Searcher)")]
public:
virtual float Idf(
    ICollection^ terms,
    Searcher^ searcher
)

Parameters

terms
Type: System.Collections..::..ICollection
the terms in the phrase
searcher
Type: Lucene.Net.Search..::..Searcher
the document collection being searched

Return Value

idf score factor

See Also

Similarity Class
Idf Overload
Lucene.Net.Search Namespace


Idf Method (Int32, Int32)

[image]

Lucene.Net Class Libraries
Similarity..::..Idf Method (Int32, Int32)
Similarity Class See Also Send Feedback
Computes a score factor based on a term's document frequency (the number of documents which contain the term). This value is multiplied by the {@link #Tf(int)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms that occur in fewer documents are better indicators of topic, so implementations of this method usually return larger values for rare terms, and smaller values for common terms.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float Idf(
    int docFreq,
    int numDocs
)
Visual Basic
Public MustOverride Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
Visual C++
public:
virtual float Idf(
    int docFreq,
    int numDocs
) abstract

Parameters

docFreq
Type: System..::..Int32
the number of documents which contain the term
numDocs
Type: System..::..Int32
the total number of documents in the collection

Return Value

a score factor based on the term's document frequency

See Also

Similarity Class
Idf Overload
Lucene.Net.Search Namespace


Idf Method (Term, Searcher)

[image]

Lucene.Net Class Libraries
Similarity..::..Idf Method (Term, Searcher)
Similarity Class See Also Send Feedback
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("see IdfExplain(Term, Searcher)")]
public virtual float Idf(
    Term term,
    Searcher searcher
)
Visual Basic
<ObsoleteAttribute("see IdfExplain(Term, Searcher)")> _
Public Overridable Function Idf ( _
    term As Term, _
    searcher As Searcher _
) As Single
Visual C++
[ObsoleteAttribute(L"see IdfExplain(Term, Searcher)")]
public:
virtual float Idf(
    Term^ term,
    Searcher^ searcher
)

Parameters

term
Type: Lucene.Net.Index..::..Term
the term in question
searcher
Type: Lucene.Net.Search..::..Searcher
the document collection being searched

Return Value

a score factor for the term

See Also

Similarity Class
Idf Overload
Lucene.Net.Search Namespace


idfExplain Method

[image]

Lucene.Net Class Libraries
Similarity..::..idfExplain Method
Similarity Class See Also Send Feedback
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation..::..IDFExplanation idfExplain(
    ICollection terms,
    Searcher searcher
)
Visual Basic
Public Overridable Function idfExplain ( _
    terms As ICollection, _
    searcher As Searcher _
) As Explanation..::..IDFExplanation
Visual C++
public:
virtual Explanation..::..IDFExplanation^ idfExplain(
    ICollection^ terms,
    Searcher^ searcher
)

Parameters

terms
Type: System.Collections..::..ICollection
the terms in the phrase
searcher
Type: Lucene.Net.Search..::..Searcher
the document collection being searched

Return Value

an IDFExplain object that includes both an idf score factor for the phrase and an explanation for each term.

See Also

Similarity Class
Lucene.Net.Search Namespace


IdfExplain Method

[image]

Lucene.Net Class Libraries
Similarity..::..IdfExplain Method
Similarity Class See Also Send Feedback
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation..::..IDFExplanation IdfExplain(
    Term term,
    Searcher searcher
)
Visual Basic
Public Overridable Function IdfExplain ( _
    term As Term, _
    searcher As Searcher _
) As Explanation..::..IDFExplanation
Visual C++
public:
virtual Explanation..::..IDFExplanation^ IdfExplain(
    Term^ term,
    Searcher^ searcher
)

Parameters

term
Type: Lucene.Net.Index..::..Term
the term in question
searcher
Type: Lucene.Net.Search..::..Searcher
the document collection being searched

Return Value

an IDFExplain object that includes both an idf score factor and an explanation for the term.

See Also

Similarity Class
Lucene.Net.Search Namespace


LengthNorm Method

[image]

Lucene.Net Class Libraries
Similarity..::..LengthNorm Method
Similarity Class See Also Send Feedback
Computes the normalization value for a field given the total number of terms contained in a field. These values, together with field boosts, are stored in an index and multipled into scores for hits on each field by the search code.

Matches in longer fields are less precise, so implementations of this method usually return smaller values when

CopyC#
numTokens
is large, and larger values when
CopyC#
numTokens
 is small.

Note that the return values are computed under {@link Lucene.Net.Index.IndexWriter#AddDocument(Lucene.Net.Documents.Document)} and then stored using {@link #EncodeNorm(float)}. Thus they have limited precision, and documents must be re-indexed if this method is altered.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float LengthNorm(
    string fieldName,
    int numTokens
)
Visual Basic
Public MustOverride Function LengthNorm ( _
    fieldName As String, _
    numTokens As Integer _
) As Single
Visual C++
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTokens
) abstract

Parameters

fieldName
Type: System..::..String
the name of the field
numTokens
Type: System..::..Int32
the total number of tokens contained in fields named fieldName of doc.

Return Value

a normalization factor for hits on this field of this document

See Also

Similarity Class
Lucene.Net.Search Namespace
[!:Lucene.Net.Documents.Field.SetBoost(float)]


QueryNorm Method

[image]

Lucene.Net Class Libraries
Similarity..::..QueryNorm Method
Similarity Class See Also Send Feedback
Computes the normalization value for a query given the sum of the squared weights of each of the query terms. This value is then multipled into the weight of each query term.

This does not affect ranking, but rather just attempts to make scores from different queries comparable.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float QueryNorm(
    float sumOfSquaredWeights
)
Visual Basic
Public MustOverride Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
Visual C++
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) abstract

Parameters

sumOfSquaredWeights
Type: System..::..Single
the sum of the squares of query term weights

Return Value

a normalization factor for query weights

See Also

Similarity Class
Lucene.Net.Search Namespace


ScorePayload Method

[image] [image]

Lucene.Net Class Libraries
Similarity..::..ScorePayload Method
Similarity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScorePayload(String, array<Byte>[]()[][], Int32, Int32) | Obsolete. Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array. The default implementation returns 1.
Public method | ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32) | Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array. The default implementation returns 1.

See Also

Similarity Class
Similarity Members
Lucene.Net.Search Namespace


ScorePayload Method (String, Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Similarity..::..ScorePayload Method (String, array<Byte>[]()[][], Int32, Int32)
Similarity Class See Also Send Feedback
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("See ScorePayload(int, String, int, int, byte[], int, int)")]
public virtual float ScorePayload(
    string fieldName,
    byte[] payload,
    int offset,
    int length
)
Visual Basic
<ObsoleteAttribute("See ScorePayload(int, String, int, int, byte[], int, int)")> _
Public Overridable Function ScorePayload ( _
    fieldName As String, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
Visual C++
[ObsoleteAttribute(L"See ScorePayload(int, String, int, int, byte[], int, int)")]
public:
virtual float ScorePayload(
    String^ fieldName,
    array<unsigned char>^ payload,
    int offset,
    int length
)

Parameters

fieldName
Type: System..::..String
The fieldName of the term this payload belongs to
payload
Type: array< System..::..Byte >[]()[][]
The payload byte array to be scored
offset
Type: System..::..Int32
The offset into the payload array
length
Type: System..::..Int32
The length in the array

Return Value

An implementation dependent float to be used as a scoring factor

See Also

Similarity Class
ScorePayload Overload
Lucene.Net.Search Namespace


ScorePayload Method (Int32, String, Int32, Int32, Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
Similarity..::..ScorePayload Method (Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Similarity Class See Also Send Feedback
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float ScorePayload(
    int docId,
    string fieldName,
    int start,
    int end,
    byte[] payload,
    int offset,
    int length
)
Visual Basic
Public Overridable Function ScorePayload ( _
    docId As Integer, _
    fieldName As String, _
    start As Integer, _
    end As Integer, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
Visual C++
public:
virtual float ScorePayload(
    int docId,
    String^ fieldName,
    int start,
    int end,
    array<unsigned char>^ payload,
    int offset,
    int length
)

Parameters

docId
Type: System..::..Int32
The docId currently being scored. If this value is {@link #NO_DOC_ID_PROVIDED}, then it should be assumed that the PayloadQuery implementation does not provide document information
fieldName
Type: System..::..String
The fieldName of the term this payload belongs to
start
Type: System..::..Int32
The start position of the payload
end
Type: System..::..Int32
The end position of the payload
payload
Type: array< System..::..Byte >[]()[][]
The payload byte array to be scored
offset
Type: System..::..Int32
The offset into the payload array
length
Type: System..::..Int32
The length in the array

Return Value

An implementation dependent float to be used as a scoring factor

See Also

Similarity Class
ScorePayload Overload
Lucene.Net.Search Namespace


SetDefault Method

[image]

Lucene.Net Class Libraries
Similarity..::..SetDefault Method
Similarity Class See Also Send Feedback
Set the default Similarity implementation used by indexing and search code.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetDefault(
    Similarity similarity
)
Visual Basic
Public Shared Sub SetDefault ( _
    similarity As Similarity _
)
Visual C++
public:
static void SetDefault(
    Similarity^ similarity
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Similarity.SetDefault(Lucene.Net.Search.Similarity)"]

See Also

Similarity Class
Lucene.Net.Search Namespace
Searcher..::..SetSimilarity(Similarity)
IndexWriter..::..SetSimilarity(Similarity)


SloppyFreq Method

[image]

Lucene.Net Class Libraries
Similarity..::..SloppyFreq Method
Similarity Class See Also Send Feedback
Computes the amount of a sloppy phrase match, based on an edit distance. This value is summed for each sloppy phrase match in a document to form the frequency that is passed to {@link #Tf(float)}.

A phrase match with a small edit distance to a document passage more closely matches the document, so implementations of this method usually return larger values when the edit distance is small and smaller values when it is large.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float SloppyFreq(
    int distance
)
Visual Basic
Public MustOverride Function SloppyFreq ( _
    distance As Integer _
) As Single
Visual C++
public:
virtual float SloppyFreq(
    int distance
) abstract

Parameters

distance
Type: System..::..Int32
the edit distance of this sloppy phrase match

Return Value

the frequency increment for this match

See Also

Similarity Class
Lucene.Net.Search Namespace
PhraseQuery..::..SetSlop(Int32)


Tf Method

[image] [image]

Lucene.Net Class Libraries
Similarity..::..Tf Method
Similarity Class See Also Send Feedback

Overload List

Name Description
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

Public method Tf(Single)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

See Also

Similarity Class
Similarity Members
Lucene.Net.Search Namespace


Tf Method (Int32)

[image]

Lucene.Net Class Libraries
Similarity..::..Tf Method (Int32)
Similarity Class See Also Send Feedback
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float Tf(
    int freq
)
Visual Basic
Public Overridable Function Tf ( _
    freq As Integer _
) As Single
Visual C++
public:
virtual float Tf(
    int freq
)

Parameters

freq
Type: System..::..Int32
the frequency of a term within a document

Return Value

a score factor based on a term's within-document frequency

See Also

Similarity Class
Tf Overload
Lucene.Net.Search Namespace


Tf Method (Single)

[image]

Lucene.Net Class Libraries
Similarity..::..Tf Method (Single)
Similarity Class See Also Send Feedback
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float Tf(
    float freq
)
Visual Basic
Public MustOverride Function Tf ( _
    freq As Single _
) As Single
Visual C++
public:
virtual float Tf(
    float freq
) abstract

Parameters

freq
Type: System..::..Single
the frequency of a term within a document

Return Value

a score factor based on a term's within-document frequency

See Also

Similarity Class
Tf Overload
Lucene.Net.Search Namespace


SimilarityDelegator Class

[image]

Lucene.Net Class Libraries
SimilarityDelegator Class
Members See Also Send Feedback
Expert: Delegating scoring implementation. Useful in {@link Query#GetSimilarity(Searcher)} implementations, to override only certain methods of a Searcher's Similiarty implementation..

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SimilarityDelegator : Similarity
Visual Basic
<SerializableAttribute> _
Public Class SimilarityDelegator _
    Inherits Similarity
Visual C++
[SerializableAttribute]
public ref class SimilarityDelegator : public Similarity

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Similarity
Lucene.Net.Search..::..SimilarityDelegator

See Also

SimilarityDelegator Members
Lucene.Net.Search Namespace


SimilarityDelegator Members

[image] [image]

Lucene.Net Class Libraries
SimilarityDelegator Members
SimilarityDelegator Class Constructors Methods See Also Send Feedback

The SimilarityDelegator type exposes the following members.

Constructors

 | Name | Description
Public method | SimilarityDelegator | Construct a {@link Similarity} that delegates all methods to another.

Methods

Name | Description
Public method | ComputeNorm | (Overrides Similarity..::..ComputeNorm(String, FieldInvertState).)
Public method | Coord | (Overrides Similarity..::..Coord(Int32, Int32).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

(Inherited from Similarity.)
Public method | Idf(Int32, Int32) | (Overrides Similarity..::..Idf(Int32, Int32).)
Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method idfExplain
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

(Inherited from Similarity.)
Public method IdfExplain
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method | LengthNorm | (Overrides Similarity..::..LengthNorm(String, Int32).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | QueryNorm | (Overrides Similarity..::..QueryNorm(Single).)
Public method | ScorePayload(String, array<Byte>[]()[][], Int32, Int32) | Obsolete. (Overrides Similarity..::..ScorePayload(String, array<Byte>[]()[][], Int32, Int32).)
Public method ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

(Inherited from Similarity.)
Public method | SloppyFreq | (Overrides Similarity..::..SloppyFreq(Int32).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

(Inherited from Similarity.)
Public method | Tf(Single) | (Overrides Similarity..::..Tf(Single).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


SimilarityDelegator Constructor

[image]

Lucene.Net Class Libraries
SimilarityDelegator Constructor
SimilarityDelegator Class See Also Send Feedback
Construct a {@link Similarity} that delegates all methods to another.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimilarityDelegator(
    Similarity delegee
)
Visual Basic
Public Sub New ( _
    delegee As Similarity _
)
Visual C++
public:
SimilarityDelegator(
    Similarity^ delegee
)

Parameters

delegee
Type: Lucene.Net.Search..::..Similarity
the Similarity implementation to delegate to

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


SimilarityDelegator Methods

[image] [image]

Lucene.Net Class Libraries
SimilarityDelegator Methods
SimilarityDelegator Class See Also Send Feedback

The SimilarityDelegator type exposes the following members.

Methods

Name | Description
Public method | ComputeNorm | (Overrides Similarity..::..ComputeNorm(String, FieldInvertState).)
Public method | Coord | (Overrides Similarity..::..Coord(Int32, Int32).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

(Inherited from Similarity.)
Public method | Idf(Int32, Int32) | (Overrides Similarity..::..Idf(Int32, Int32).)
Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method idfExplain
Computes a score factor for a phrase.

The default implementation sums the idf factor for each term in the phrase.

(Inherited from Similarity.)
Public method IdfExplain
Computes a score factor for a simple term and returns an explanation for that score factor.

The default implementation uses:

            idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)
Public method | LengthNorm | (Overrides Similarity..::..LengthNorm(String, Int32).)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | QueryNorm | (Overrides Similarity..::..QueryNorm(Single).)
Public method | ScorePayload(String, array<Byte>[]()[][], Int32, Int32) | Obsolete. (Overrides Similarity..::..ScorePayload(String, array<Byte>[]()[][], Int32, Int32).)
Public method ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32)
Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array.

The default implementation returns 1.

(Inherited from Similarity.)
Public method | SloppyFreq | (Overrides Similarity..::..SloppyFreq(Int32).)
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

(Inherited from Similarity.)
Public method | Tf(Single) | (Overrides Similarity..::..Tf(Single).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


ComputeNorm Method

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..ComputeNorm Method
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float ComputeNorm(
    string fieldName,
    FieldInvertState state
)
Visual Basic
Public Overrides Function ComputeNorm ( _
    fieldName As String, _
    state As FieldInvertState _
) As Single
Visual C++
public:
virtual float ComputeNorm(
    String^ fieldName,
    FieldInvertState^ state
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

state
Type: Lucene.Net.Index..::..FieldInvertState

[Missing <param name="state"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ComputeNorm(System.String,Lucene.Net.Index.FieldInvertState)"]

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


Coord Method

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..Coord Method
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Coord(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Coord(
    int overlap,
    int maxOverlap
)
Visual Basic
Public Overrides Function Coord ( _
    overlap As Integer, _
    maxOverlap As Integer _
) As Single
Visual C++
public:
virtual float Coord(
    int overlap,
    int maxOverlap
) override

Parameters

overlap
Type: System..::..Int32

[Missing <param name="overlap"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Coord(System.Int32,System.Int32)"]

maxOverlap
Type: System..::..Int32

[Missing <param name="maxOverlap"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Coord(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Coord(System.Int32,System.Int32)"]

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


Idf Method

[image] [image]

Lucene.Net Class Libraries
SimilarityDelegator..::..Idf Method
SimilarityDelegator Class See Also Send Feedback

Overload List

Name | Description
Public method Idf(ICollection, Searcher) Obsolete.
Computes a score factor for a phrase.

The default implementation sums the {@link #Idf(Term,Searcher)} factor for each term in the phrase.

(Inherited from Similarity.)
Public method | Idf(Int32, Int32) | (Overrides Similarity..::..Idf(Int32, Int32).)
Public method Idf(Term, Searcher) Obsolete.
Computes a score factor for a simple term.

The default implementation is:

            return idf(searcher.docFreq(term), searcher.maxDoc());
Note that {@link Searcher#MaxDoc()} is used instead of {@link Lucene.Net.Index.IndexReader#NumDocs()} because it is proportional to {@link Searcher#DocFreq(Term)} , i.e., when one is inaccurate, so is the other, and in the same direction.
(Inherited from Similarity.)

See Also

SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace


Idf Method (Int32, Int32)

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..Idf Method (Int32, Int32)
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Idf(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Idf(
    int docFreq,
    int numDocs
)
Visual Basic
Public Overrides Function Idf ( _
    docFreq As Integer, _
    numDocs As Integer _
) As Single
Visual C++
public:
virtual float Idf(
    int docFreq,
    int numDocs
) override

Parameters

docFreq
Type: System..::..Int32

[Missing <param name="docFreq"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Idf(System.Int32,System.Int32)"]

numDocs
Type: System..::..Int32

[Missing <param name="numDocs"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Idf(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Idf(System.Int32,System.Int32)"]

See Also

SimilarityDelegator Class
Idf Overload
Lucene.Net.Search Namespace


LengthNorm Method

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..LengthNorm Method
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.LengthNorm(System.String,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float LengthNorm(
    string fieldName,
    int numTerms
)
Visual Basic
Public Overrides Function LengthNorm ( _
    fieldName As String, _
    numTerms As Integer _
) As Single
Visual C++
public:
virtual float LengthNorm(
    String^ fieldName,
    int numTerms
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.LengthNorm(System.String,System.Int32)"]

numTerms
Type: System..::..Int32

[Missing <param name="numTerms"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.LengthNorm(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.LengthNorm(System.String,System.Int32)"]

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


QueryNorm Method

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..QueryNorm Method
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.QueryNorm(System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float QueryNorm(
    float sumOfSquaredWeights
)
Visual Basic
Public Overrides Function QueryNorm ( _
    sumOfSquaredWeights As Single _
) As Single
Visual C++
public:
virtual float QueryNorm(
    float sumOfSquaredWeights
) override

Parameters

sumOfSquaredWeights
Type: System..::..Single

[Missing <param name="sumOfSquaredWeights"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.QueryNorm(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.QueryNorm(System.Single)"]

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


ScorePayload Method

[image] [image]

Lucene.Net Class Libraries
SimilarityDelegator..::..ScorePayload Method
SimilarityDelegator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScorePayload(String, array<Byte>[]()[][], Int32, Int32) | Obsolete. (Overrides Similarity..::..ScorePayload(String, array<Byte>[]()[][], Int32, Int32).)
Public method | ScorePayload(Int32, String, Int32, Int32, array<Byte>[]()[][], Int32, Int32) | Calculate a scoring factor based on the data in the payload. Overriding implementations are responsible for interpreting what is in the payload. Lucene makes no assumptions about what is in the byte array. The default implementation returns 1. (Inherited from Similarity.)

See Also

SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace


ScorePayload Method (String, Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..ScorePayload Method (String, array<Byte>[]()[][], Int32, Int32)
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ScorePayload(System.String,System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.Similarity.ScorePayload(string, byte[], int, int)")]
public override float ScorePayload(
    string fieldName,
    byte[] payload,
    int offset,
    int length
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.Similarity.ScorePayload(string, byte[], int, int)")> _
Public Overrides Function ScorePayload ( _
    fieldName As String, _
    payload As Byte(), _
    offset As Integer, _
    length As Integer _
) As Single
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.Similarity.ScorePayload(string, byte[], int, int)")]
public:
virtual float ScorePayload(
    String^ fieldName,
    array<unsigned char>^ payload,
    int offset,
    int length
) override

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ScorePayload(System.String,System.Byte[],System.Int32,System.Int32)"]

payload
Type: array< System..::..Byte >[]()[][]

[Missing <param name="payload"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ScorePayload(System.String,System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ScorePayload(System.String,System.Byte[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ScorePayload(System.String,System.Byte[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.ScorePayload(System.String,System.Byte[],System.Int32,System.Int32)"]

See Also

SimilarityDelegator Class
ScorePayload Overload
Lucene.Net.Search Namespace


SloppyFreq Method

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..SloppyFreq Method
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.SloppyFreq(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float SloppyFreq(
    int distance
)
Visual Basic
Public Overrides Function SloppyFreq ( _
    distance As Integer _
) As Single
Visual C++
public:
virtual float SloppyFreq(
    int distance
) override

Parameters

distance
Type: System..::..Int32

[Missing <param name="distance"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.SloppyFreq(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.SloppyFreq(System.Int32)"]

See Also

SimilarityDelegator Class
Lucene.Net.Search Namespace


Tf Method

[image] [image]

Lucene.Net Class Libraries
SimilarityDelegator..::..Tf Method
SimilarityDelegator Class See Also Send Feedback

Overload List

Name | Description
Public method Tf(Int32)
Computes a score factor based on a term or phrase's frequency in a document. This value is multiplied by the {@link #Idf(Term, Searcher)} factor for each term in the query and these products are then summed to form the initial score for a document.

Terms and phrases repeated in a document indicate the topic of the document, so implementations of this method usually return larger values when

CopyC#
freq
is large, and smaller values when
CopyC#
freq
 is small.

The default implementation calls {@link #Tf(float)}.

(Inherited from Similarity.)
Public method | Tf(Single) | (Overrides Similarity..::..Tf(Single).)

See Also

SimilarityDelegator Class
SimilarityDelegator Members
Lucene.Net.Search Namespace


Tf Method (Single)

[image]

Lucene.Net Class Libraries
SimilarityDelegator..::..Tf Method (Single)
SimilarityDelegator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Tf(System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Tf(
    float freq
)
Visual Basic
Public Overrides Function Tf ( _
    freq As Single _
) As Single
Visual C++
public:
virtual float Tf(
    float freq
) override

Parameters

freq
Type: System..::..Single

[Missing <param name="freq"/> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Tf(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimilarityDelegator.Tf(System.Single)"]

See Also

SimilarityDelegator Class
Tf Overload
Lucene.Net.Search Namespace


SimpleFacetedSearch Class

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.SimpleFacetedSearch"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class SimpleFacetedSearch : IDisposable
Visual Basic
Public Class SimpleFacetedSearch _
    Implements IDisposable
Visual C++
public ref class SimpleFacetedSearch : IDisposable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SimpleFacetedSearch

See Also

SimpleFacetedSearch Members
Lucene.Net.Search Namespace


SimpleFacetedSearch Members

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch Members
SimpleFacetedSearch Class Constructors Methods Fields See Also Send Feedback

The SimpleFacetedSearch type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFacetedSearch(IndexReader, String) | Initializes a new instance of the SimpleFacetedSearch class
Public method | SimpleFacetedSearch(IndexReader, array<String>[]()[][]) | Initializes a new instance of the SimpleFacetedSearch class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SimpleFacetedSearch
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Search |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DefaultMaxDocPerGroup |
MAX_FACETS |

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


SimpleFacetedSearch Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch Constructor
SimpleFacetedSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleFacetedSearch(IndexReader, String) | Initializes a new instance of the SimpleFacetedSearch class
Public method | SimpleFacetedSearch(IndexReader, array<String>[]()[][]) | Initializes a new instance of the SimpleFacetedSearch class

See Also

SimpleFacetedSearch Class
SimpleFacetedSearch Members
Lucene.Net.Search Namespace


SimpleFacetedSearch Constructor (IndexReader, String)

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch Constructor (IndexReader, String)
SimpleFacetedSearch Class See Also Send Feedback
Initializes a new instance of the SimpleFacetedSearch class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch(
    IndexReader reader,
    string groupByField
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    groupByField As String _
)
Visual C++
public:
SimpleFacetedSearch(
    IndexReader^ reader,
    String^ groupByField
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.#ctor(Lucene.Net.Index.IndexReader,System.String)"]

groupByField
Type: System..::..String

[Missing <param name="groupByField"/> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.#ctor(Lucene.Net.Index.IndexReader,System.String)"]

See Also

SimpleFacetedSearch Class
SimpleFacetedSearch Overload
Lucene.Net.Search Namespace


SimpleFacetedSearch Constructor (IndexReader, String[])

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch Constructor (IndexReader, array<String>[]()[][])
SimpleFacetedSearch Class See Also Send Feedback
Initializes a new instance of the SimpleFacetedSearch class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch(
    IndexReader reader,
    string[] groupByFields
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    groupByFields As String() _
)
Visual C++
public:
SimpleFacetedSearch(
    IndexReader^ reader,
    array<String^>^ groupByFields
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.#ctor(Lucene.Net.Index.IndexReader,System.String[])"]

groupByFields
Type: array< System..::..String >[]()[][]

[Missing <param name="groupByFields"/> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.#ctor(Lucene.Net.Index.IndexReader,System.String[])"]

See Also

SimpleFacetedSearch Class
SimpleFacetedSearch Overload
Lucene.Net.Search Namespace


SimpleFacetedSearch Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch Fields
SimpleFacetedSearch Class See Also Send Feedback

The SimpleFacetedSearch type exposes the following members.

Fields

Name | Description
DefaultMaxDocPerGroup |
MAX_FACETS |

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


DefaultMaxDocPerGroup Field

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..DefaultMaxDocPerGroup Field
SimpleFacetedSearch Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.SimpleFacetedSearch.DefaultMaxDocPerGroup"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public const int DefaultMaxDocPerGroup
Visual Basic
Public Const DefaultMaxDocPerGroup As Integer
Visual C++
public:
literal int DefaultMaxDocPerGroup

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


MAX_FACETS Field

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..MAX_FACETS Field
SimpleFacetedSearch Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.SimpleFacetedSearch.MAX_FACETS"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public static int MAX_FACETS
Visual Basic
Public Shared MAX_FACETS As Integer
Visual C++
public:
static int MAX_FACETS

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


SimpleFacetedSearch Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch Methods
SimpleFacetedSearch Class See Also Send Feedback

The SimpleFacetedSearch type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Search |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Dispose Method
SimpleFacetedSearch Class See Also Send Feedback
Releases all resources used by the SimpleFacetedSearch

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


Search Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Search Method
SimpleFacetedSearch Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.Search(Lucene.Net.Search.Query,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch..::..Hits Search(
    Query query,
    int maxDocPerGroup
)
Visual Basic
Public Function Search ( _
    query As Query, _
    maxDocPerGroup As Integer _
) As SimpleFacetedSearch..::..Hits
Visual C++
public:
SimpleFacetedSearch..::..Hits^ Search(
    Query^ query,
    int maxDocPerGroup
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.Search(Lucene.Net.Search.Query,System.Int32)"]

maxDocPerGroup
Type: System..::..Int32

[Missing <param name="maxDocPerGroup"/> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.Search(Lucene.Net.Search.Query,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.Search(Lucene.Net.Search.Query,System.Int32)"]

See Also

SimpleFacetedSearch Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.FacetName Class

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName Class
SimpleFacetedSearch Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.SimpleFacetedSearch.FacetName"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class FacetName
Visual Basic
Public Class FacetName
Visual C++
public ref class FacetName

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SimpleFacetedSearch..::..FacetName

See Also

SimpleFacetedSearch..::..FacetName Members
Lucene.Net.Search Namespace


SimpleFacetedSearch.FacetName Members

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName Members
SimpleFacetedSearch..::..FacetName Class Methods Properties See Also Send Feedback

The SimpleFacetedSearch..::..FacetName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Item |
Public property | Length |

See Also

SimpleFacetedSearch..::..FacetName Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.FacetName Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName Methods
SimpleFacetedSearch..::..FacetName Class See Also Send Feedback

The SimpleFacetedSearch..::..FacetName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SimpleFacetedSearch..::..FacetName Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName..::..ToString Method
SimpleFacetedSearch..::..FacetName Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.FacetName.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.FacetName.ToString"]

See Also

SimpleFacetedSearch..::..FacetName Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.FacetName Properties

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName Properties
SimpleFacetedSearch..::..FacetName Class See Also Send Feedback

The SimpleFacetedSearch..::..FacetName type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | Length |

See Also

SimpleFacetedSearch..::..FacetName Class
Lucene.Net.Search Namespace


Item Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName..::..Item Property
SimpleFacetedSearch..::..FacetName Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.FacetName.Item(System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public string this[
    int i
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    i As Integer _
) As String
    Get
Visual C++
public:
property String^ default[int i] {
    String^ get (int i);
}

Parameters

i
Type: System..::..Int32

See Also

SimpleFacetedSearch..::..FacetName Class
Lucene.Net.Search Namespace


Length Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..FacetName..::..Length Property
SimpleFacetedSearch..::..FacetName Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.FacetName.Length"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
Visual C++
public:
property int Length {
    int get ();
}

See Also

SimpleFacetedSearch..::..FacetName Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.Hits Class

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits Class
SimpleFacetedSearch Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.SimpleFacetedSearch.Hits"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class Hits
Visual Basic
Public Class Hits
Visual C++
public ref class Hits

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SimpleFacetedSearch..::..Hits

See Also

SimpleFacetedSearch..::..Hits Members
Lucene.Net.Search Namespace


SimpleFacetedSearch.Hits Members

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits Members
SimpleFacetedSearch..::..Hits Class Constructors Methods Properties See Also Send Feedback

The SimpleFacetedSearch..::..Hits type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFacetedSearch..::..Hits | Initializes a new instance of the SimpleFacetedSearch..::..Hits class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HitsPerFacet |
Public property | Item[([( String])]) |
Public property | Item[([( SimpleFacetedSearch..::..FacetName])]) |
Public property | TotalHitCount |

See Also

SimpleFacetedSearch..::..Hits Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.Hits Constructor

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits Constructor
SimpleFacetedSearch..::..Hits Class See Also Send Feedback
Initializes a new instance of the SimpleFacetedSearch..::..Hits class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public Hits()
Visual Basic
Public Sub New
Visual C++
public:
Hits()

See Also

SimpleFacetedSearch..::..Hits Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.Hits Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits Methods
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

The SimpleFacetedSearch..::..Hits type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFacetedSearch..::..Hits Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.Hits Properties

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits Properties
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

The SimpleFacetedSearch..::..Hits type exposes the following members.

Properties

 | Name | Description
Public property | HitsPerFacet |
Public property | Item[([( String])]) |
Public property | Item[([( SimpleFacetedSearch..::..FacetName])]) |
Public property | TotalHitCount |

See Also

SimpleFacetedSearch..::..Hits Class
Lucene.Net.Search Namespace


HitsPerFacet Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits..::..HitsPerFacet Property
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.Hits.HitsPerFacet"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch..::..HitsPerFacet[] HitsPerFacet { get; internal set; }
Visual Basic
Public Property HitsPerFacet As SimpleFacetedSearch..::..HitsPerFacet()
    Get
    Friend Set
Visual C++
public:
property array<SimpleFacetedSearch..::..HitsPerFacet^>^ HitsPerFacet {
    array<SimpleFacetedSearch..::..HitsPerFacet^>^ get ();
    internal: void set (array<SimpleFacetedSearch..::..HitsPerFacet^>^ value);
}

See Also

SimpleFacetedSearch..::..Hits Class
Lucene.Net.Search Namespace


Item Property

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits..::..Item Property
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) |
Public property | Item[([( SimpleFacetedSearch..::..FacetName])]) |

See Also

SimpleFacetedSearch..::..Hits Class
SimpleFacetedSearch..::..Hits Members
Lucene.Net.Search Namespace


Item Property (String)

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits..::..Item Property (String)
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.Hits.Item(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch..::..HitsPerFacet this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As SimpleFacetedSearch..::..HitsPerFacet
    Get
Visual C++
public:
property SimpleFacetedSearch..::..HitsPerFacet^ default[String^ name] {
    SimpleFacetedSearch..::..HitsPerFacet^ get (String^ name);
}

Parameters

name
Type: System..::..String

See Also

SimpleFacetedSearch..::..Hits Class
Item Overload
Lucene.Net.Search Namespace


Item Property (SimpleFacetedSearch.FacetName)

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits..::..Item Property (SimpleFacetedSearch..::..FacetName)
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.Hits.Item(Lucene.Net.Search.SimpleFacetedSearch.FacetName)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch..::..HitsPerFacet this[
    SimpleFacetedSearch..::..FacetName name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As SimpleFacetedSearch..::..FacetName _
) As SimpleFacetedSearch..::..HitsPerFacet
    Get
Visual C++
public:
property SimpleFacetedSearch..::..HitsPerFacet^ default[SimpleFacetedSearch..::..FacetName^ name] {
    SimpleFacetedSearch..::..HitsPerFacet^ get (SimpleFacetedSearch..::..FacetName^ name);
}

Parameters

name
Type: Lucene.Net.Search..::..SimpleFacetedSearch..::..FacetName

See Also

SimpleFacetedSearch..::..Hits Class
Item Overload
Lucene.Net.Search Namespace


TotalHitCount Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..Hits..::..TotalHitCount Property
SimpleFacetedSearch..::..Hits Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.Hits.TotalHitCount"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public long TotalHitCount { get; }
Visual Basic
Public ReadOnly Property TotalHitCount As Long
    Get
Visual C++
public:
property long long TotalHitCount {
    long long get ();
}

See Also

SimpleFacetedSearch..::..Hits Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.HitsPerFacet Class

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet Class
SimpleFacetedSearch Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class HitsPerFacet : IEnumerable<Document>,
    IEnumerable, IEnumerator<Document>, IDisposable, IEnumerator
Visual Basic
Public Class HitsPerFacet _
    Implements IEnumerable(Of Document), IEnumerable,  _
    IEnumerator(Of Document), IDisposable, IEnumerator
Visual C++
public ref class HitsPerFacet : IEnumerable<Document^>,
    IEnumerable, IEnumerator<Document^>, IDisposable, IEnumerator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SimpleFacetedSearch..::..HitsPerFacet

See Also

SimpleFacetedSearch..::..HitsPerFacet Members
Lucene.Net.Search Namespace


SimpleFacetedSearch.HitsPerFacet Members

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet Members
SimpleFacetedSearch..::..HitsPerFacet Class Methods Properties See Also Send Feedback

The SimpleFacetedSearch..::..HitsPerFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SimpleFacetedSearch..::..HitsPerFacet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | Documents |
Public property | HitCount |
Public property | Name |

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.HitsPerFacet Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet Methods
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

The SimpleFacetedSearch..::..HitsPerFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..Dispose Method
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback
Releases all resources used by the SimpleFacetedSearch..::..HitsPerFacet

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


GetEnumerator Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..GetEnumerator Method
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.GetEnumerator"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public IEnumerator<Document> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of Document)
Visual C++
public:
virtual IEnumerator<Document^>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


MoveNext Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..MoveNext Method
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.MoveNext"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.MoveNext"]

Implements

IEnumerator..::..MoveNext()()()()

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


Reset Method

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..Reset Method
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.Reset"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


SimpleFacetedSearch.HitsPerFacet Properties

[image] [image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet Properties
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

The SimpleFacetedSearch..::..HitsPerFacet type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | Documents |
Public property | HitCount |
Public property | Name |

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


Current Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..Current Property
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.Current"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public Document Current { get; }
Visual Basic
Public ReadOnly Property Current As Document
    Get
Visual C++
public:
virtual property Document^ Current {
    Document^ get () sealed;
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


Documents Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..Documents Property
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.Documents"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch..::..HitsPerFacet Documents { get; }
Visual Basic
Public ReadOnly Property Documents As SimpleFacetedSearch..::..HitsPerFacet
    Get
Visual C++
public:
property SimpleFacetedSearch..::..HitsPerFacet^ Documents {
    SimpleFacetedSearch..::..HitsPerFacet^ get ();
}

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


HitCount Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..HitCount Property
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.HitCount"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public long HitCount { get; }
Visual Basic
Public ReadOnly Property HitCount As Long
    Get
Visual C++
public:
property long long HitCount {
    long long get ();
}

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


Name Property

[image]

Lucene.Net Class Libraries
SimpleFacetedSearch..::..HitsPerFacet..::..Name Property
SimpleFacetedSearch..::..HitsPerFacet Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.SimpleFacetedSearch.HitsPerFacet.Name"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Search.SimpleFacetedSearch (in Lucene.Net.Search.SimpleFacetedSearch.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SimpleFacetedSearch..::..FacetName Name { get; }
Visual Basic
Public ReadOnly Property Name As SimpleFacetedSearch..::..FacetName
    Get
Visual C++
public:
property SimpleFacetedSearch..::..FacetName^ Name {
    SimpleFacetedSearch..::..FacetName^ get ();
}

See Also

SimpleFacetedSearch..::..HitsPerFacet Class
Lucene.Net.Search Namespace


Sort Class

[image]

Lucene.Net Class Libraries
Sort Class
Members See Also Send Feedback
Encapsulates sort criteria for returned hits.

The fields used to determine sort order must be carefully chosen. Documents must contain a single term in such a field, and the value of the term should indicate the document's relative position in a given sort order. The field must be indexed, but should not be tokenized, and does not need to be stored (unless you happen to want it back with the rest of your document data). In other words:

CopyC#
document.add (new Field ("byNumber", Integer.toString(x), Field.Store.NO, Field.Index.NOT_ANALYZED));

Valid Types of Values

There are four possible kinds of term values which may be put into sorting fields: Integers, Longs, Floats, or Strings. Unless {@link SortField SortField} objects are specified, the type of value in the field is determined by parsing the first term in the field.

Integer term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range

CopyC#
Integer.MIN_VALUE
and
CopyC#
Integer.MAX_VALUE
 inclusive. Documents which should appear first in the sort should have low value integers, later documents high values (i.e. the documents should be numbered
CopyC#
1..n
 where
CopyC#
1
 is the first and
CopyC#
n
 the last).

Long term values should contain only digits and an optional preceding negative sign. Values must be base 10 and in the range

CopyC#
Long.MIN_VALUE
and
CopyC#
Long.MAX_VALUE
 inclusive. Documents which should appear first in the sort should have low value integers, later documents high values.

Float term values should conform to values accepted by {@link Float Float.valueOf(String)} (except that

CopyC#
NaN
and
CopyC#
Infinity
 are not supported). Documents which should appear first in the sort should have low values, later documents high values.

String term values can contain any valid String, but should not be tokenized. The values are sorted according to their {@link Comparable natural order}. Note that using this type of term value has higher memory requirements than the other two types.

Object Reuse

One of these objects can be used multiple times and the sort order changed between usages.

This class is thread safe.

Memory Usage

Sorting uses of caches of term values maintained by the internal HitQueue(s). The cache is static and contains an integer or float array of length

CopyC#
IndexReader.maxDoc()
for each field name for which a sort is performed. In other words, the size of the cache in bytes is:

CopyC#
4 * IndexReader.maxDoc() * (# of different fields actually used to sort)

For String fields, the cache is larger: in addition to the above array, the value of every term in the field is kept in memory. If there are many unique terms in the field, this could be quite large.

Note that the size of the cache is not affected by how many fields are in the index and might be used to sort - only by the ones actually used to sort a result set.

Created: Feb 12, 2004 10:53:57 AM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class Sort
Visual Basic
<SerializableAttribute> _
Public Class Sort
Visual C++
[SerializableAttribute]
public ref class Sort

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Sort

See Also

Sort Members
Lucene.Net.Search Namespace


Sort Members

[image] [image]

Lucene.Net Class Libraries
Sort Members
Sort Class Constructors Methods Fields See Also Send Feedback

The Sort type exposes the following members.

Constructors

Name Description
Public method Sort()()()()
Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.
Public method Sort(String) Obsolete.
Sorts by the terms in
CopyC#
field
 then by index order (document number). The type of value in
CopyC#
field
 is determined automatically.
Public method Sort(array<String>[]()[][]) Obsolete.
Sorts in succession by the terms in each field. The type of value in
CopyC#
field
 is determined automatically.
Public method Sort(SortField)
Sorts by the criteria in the given SortField.
Public method Sort(array<SortField>[]()[][])
Sorts in succession by the criteria in each SortField.
Public method Sort(String, Boolean) Obsolete.
Sorts possibly in reverse by the terms in
CopyC#
field
 then by index order (document number). The type of value in
CopyC#
field
 is determined automatically.

Methods

Name | Description
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Object..::..GetHashCode()()()().)
Public method GetSort
Representation of the sort criteria.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetSort(String) Obsolete.
Sets the sort to the terms in
CopyC#
field
 then by index order (document number).
Public method SetSort(array<String>[]()[][]) Obsolete.
Sets the sort to the terms in each field in succession.
Public method SetSort(SortField)
Sets the sort to the given criteria.
Public method SetSort(array<SortField>[]()[][])
Sets the sort to the given criteria in succession.
Public method SetSort(String, Boolean) Obsolete.
Sets the sort to the terms in
CopyC#
field
 possibly in reverse, then by index order (document number).
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

See Also

Sort Class
Lucene.Net.Search Namespace


Sort Constructor

[image] [image]

Lucene.Net Class Libraries
Sort Constructor
Sort Class See Also Send Feedback

Overload List

Name Description
Public method Sort()()()()
Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.
Public method Sort(String) Obsolete.
Sorts by the terms in
CopyC#
field
 then by index order (document number). The type of value in
CopyC#
field
 is determined automatically.
Public method Sort(array<String>[]()[][]) Obsolete.
Sorts in succession by the terms in each field. The type of value in
CopyC#
field
 is determined automatically.
Public method Sort(SortField)
Sorts by the criteria in the given SortField.
Public method Sort(array<SortField>[]()[][])
Sorts in succession by the criteria in each SortField.
Public method Sort(String, Boolean) Obsolete.
Sorts possibly in reverse by the terms in
CopyC#
field
 then by index order (document number). The type of value in
CopyC#
field
 is determined automatically.

See Also

Sort Class
Sort Members
Lucene.Net.Search Namespace


Sort Constructor

[image]

Lucene.Net Class Libraries
Sort Constructor
Sort Class See Also Send Feedback
Sorts by computed relevance. This is the same sort criteria as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Sort()
Visual Basic
Public Sub New
Visual C++
public:
Sort()

See Also

Sort Class
Sort Overload
Lucene.Net.Search Namespace


Sort Constructor (String)

[image]

Lucene.Net Class Libraries
Sort Constructor (String)
Sort Class See Also Send Feedback
Sorts by the terms in
CopyC#
field
 then by index order (document number). The type of value in
CopyC#
field
 is determined automatically.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use Sort(SortField)")]
public Sort(
    string field
)
Visual Basic
<ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use Sort(SortField)")> _
Public Sub New ( _
    field As String _
)
Visual C++
[ObsoleteAttribute(L"Please specify the type explicitly by first creating a SortField and then use Sort(SortField)")]
public:
Sort(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Sort.#ctor(System.String)"]

See Also

Sort Class
Sort Overload
Lucene.Net.Search Namespace
SortField..::..AUTO


Sort Constructor (String[])

[image]

Lucene.Net Class Libraries
Sort Constructor (array<String>[]()[][])
Sort Class See Also Send Feedback
Sorts in succession by the terms in each field. The type of value in
CopyC#
field
 is determined automatically.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the type explicitly by first creating SortFields and then use Sort(SortField[])")]
public Sort(
    string[] fields
)
Visual Basic
<ObsoleteAttribute("Please specify the type explicitly by first creating SortFields and then use Sort(SortField[])")> _
Public Sub New ( _
    fields As String() _
)
Visual C++
[ObsoleteAttribute(L"Please specify the type explicitly by first creating SortFields and then use Sort(SortField[])")]
public:
Sort(
    array<String^>^ fields
)

Parameters

fields
Type: array< System..::..String >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.Search.Sort.#ctor(System.String[])"]

See Also

Sort Class
Sort Overload
Lucene.Net.Search Namespace
SortField..::..AUTO


Sort Constructor (SortField)

[image]

Lucene.Net Class Libraries
Sort Constructor (SortField)
Sort Class See Also Send Feedback
Sorts by the criteria in the given SortField.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Sort(
    SortField field
)
Visual Basic
Public Sub New ( _
    field As SortField _
)
Visual C++
public:
Sort(
    SortField^ field
)

Parameters

field
Type: Lucene.Net.Search..::..SortField

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Sort.#ctor(Lucene.Net.Search.SortField)"]

See Also

Sort Class
Sort Overload
Lucene.Net.Search Namespace


Sort Constructor (SortField[])

[image]

Lucene.Net Class Libraries
Sort Constructor (array<SortField>[]()[][])
Sort Class See Also Send Feedback
Sorts in succession by the criteria in each SortField.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Sort(
    SortField[] fields
)
Visual Basic
Public Sub New ( _
    fields As SortField() _
)
Visual C++
public:
Sort(
    array<SortField^>^ fields
)

Parameters

fields
Type: array< Lucene.Net.Search..::..SortField >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.Search.Sort.#ctor(Lucene.Net.Search.SortField[])"]

See Also

Sort Class
Sort Overload
Lucene.Net.Search Namespace


Sort Constructor (String, Boolean)

[image]

Lucene.Net Class Libraries
Sort Constructor (String, Boolean)
Sort Class See Also Send Feedback
Sorts possibly in reverse by the terms in
CopyC#
field
 then by index order (document number). The type of value in
CopyC#
field
 is determined automatically.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use Sort(SortField)")]
public Sort(
    string field,
    bool reverse
)
Visual Basic
<ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use Sort(SortField)")> _
Public Sub New ( _
    field As String, _
    reverse As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Please specify the type explicitly by first creating a SortField and then use Sort(SortField)")]
public:
Sort(
    String^ field,
    bool reverse
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Sort.#ctor(System.String,System.Boolean)"]

reverse
Type: System..::..Boolean

[Missing <param name="reverse"/> documentation for "M:Lucene.Net.Search.Sort.#ctor(System.String,System.Boolean)"]

See Also

Sort Class
Sort Overload
Lucene.Net.Search Namespace
SortField..::..AUTO


Sort Fields

[image] [image]

Lucene.Net Class Libraries
Sort Fields
Sort Class See Also Send Feedback

The Sort type exposes the following members.

Fields

Name | Description
INDEXORDER | Represents sorting by index order.
RELEVANCE | Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

See Also

Sort Class
Lucene.Net.Search Namespace


INDEXORDER Field

[image]

Lucene.Net Class Libraries
Sort..::..INDEXORDER Field
Sort Class See Also Send Feedback
Represents sorting by index order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Sort INDEXORDER
Visual Basic
Public Shared ReadOnly INDEXORDER As Sort
Visual C++
public:
static initonly Sort^ INDEXORDER

See Also

Sort Class
Lucene.Net.Search Namespace


RELEVANCE Field

[image]

Lucene.Net Class Libraries
Sort..::..RELEVANCE Field
Sort Class See Also Send Feedback
Represents sorting by computed relevance. Using this sort criteria returns the same results as calling {@link Searcher#Search(Query) Searcher#search()}without a sort criteria, only with slightly more overhead.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Sort RELEVANCE
Visual Basic
Public Shared ReadOnly RELEVANCE As Sort
Visual C++
public:
static initonly Sort^ RELEVANCE

See Also

Sort Class
Lucene.Net.Search Namespace


Sort Methods

[image] [image]

Lucene.Net Class Libraries
Sort Methods
Sort Class See Also Send Feedback

The Sort type exposes the following members.

Methods

Name | Description
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Object..::..GetHashCode()()()().)
Public method GetSort
Representation of the sort criteria.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetSort(String) Obsolete.
Sets the sort to the terms in
CopyC#
field
 then by index order (document number).
Public method SetSort(array<String>[]()[][]) Obsolete.
Sets the sort to the terms in each field in succession.
Public method SetSort(SortField)
Sets the sort to the given criteria.
Public method SetSort(array<SortField>[]()[][])
Sets the sort to the given criteria in succession.
Public method SetSort(String, Boolean) Obsolete.
Sets the sort to the terms in
CopyC#
field
 possibly in reverse, then by index order (document number).
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Sort Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Sort..::..Equals Method
Sort Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Sort.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Sort.Equals(System.Object)"]

See Also

Sort Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Sort..::..GetHashCode Method
Sort Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Sort.GetHashCode"]

See Also

Sort Class
Lucene.Net.Search Namespace


GetSort Method

[image]

Lucene.Net Class Libraries
Sort..::..GetSort Method
Sort Class See Also Send Feedback
Representation of the sort criteria.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SortField[] GetSort()
Visual Basic
Public Overridable Function GetSort As SortField()
Visual C++
public:
virtual array<SortField^>^ GetSort()

Return Value

Array of SortField objects used in this sort criteria

See Also

Sort Class
Lucene.Net.Search Namespace


SetSort Method

[image] [image]

Lucene.Net Class Libraries
Sort..::..SetSort Method
Sort Class See Also Send Feedback

Overload List

Name Description
Public method SetSort(String) Obsolete.
Sets the sort to the terms in
CopyC#
field
 then by index order (document number).
Public method SetSort(array<String>[]()[][]) Obsolete.
Sets the sort to the terms in each field in succession.
Public method SetSort(SortField)
Sets the sort to the given criteria.
Public method SetSort(array<SortField>[]()[][])
Sets the sort to the given criteria in succession.
Public method SetSort(String, Boolean) Obsolete.
Sets the sort to the terms in
CopyC#
field
 possibly in reverse, then by index order (document number).

See Also

Sort Class
Sort Members
Lucene.Net.Search Namespace


SetSort Method (String)

[image]

Lucene.Net Class Libraries
Sort..::..SetSort Method (String)
Sort Class See Also Send Feedback
Sets the sort to the terms in
CopyC#
field
 then by index order (document number).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use SetSort(SortField)")]
public void SetSort(
    string field
)
Visual Basic
<ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use SetSort(SortField)")> _
Public Sub SetSort ( _
    field As String _
)
Visual C++
[ObsoleteAttribute(L"Please specify the type explicitly by first creating a SortField and then use SetSort(SortField)")]
public:
void SetSort(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Sort.SetSort(System.String)"]

See Also

Sort Class
SetSort Overload
Lucene.Net.Search Namespace


SetSort Method (String[])

[image]

Lucene.Net Class Libraries
Sort..::..SetSort Method (array<String>[]()[][])
Sort Class See Also Send Feedback
Sets the sort to the terms in each field in succession.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the type explicitly by first creating a SortFields and then use SetSort(SortField[])")]
public virtual void SetSort(
    string[] fieldnames
)
Visual Basic
<ObsoleteAttribute("Please specify the type explicitly by first creating a SortFields and then use SetSort(SortField[])")> _
Public Overridable Sub SetSort ( _
    fieldnames As String() _
)
Visual C++
[ObsoleteAttribute(L"Please specify the type explicitly by first creating a SortFields and then use SetSort(SortField[])")]
public:
virtual void SetSort(
    array<String^>^ fieldnames
)

Parameters

fieldnames
Type: array< System..::..String >[]()[][]

[Missing <param name="fieldnames"/> documentation for "M:Lucene.Net.Search.Sort.SetSort(System.String[])"]

See Also

Sort Class
SetSort Overload
Lucene.Net.Search Namespace


SetSort Method (SortField)

[image]

Lucene.Net Class Libraries
Sort..::..SetSort Method (SortField)
Sort Class See Also Send Feedback
Sets the sort to the given criteria.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSort(
    SortField field
)
Visual Basic
Public Overridable Sub SetSort ( _
    field As SortField _
)
Visual C++
public:
virtual void SetSort(
    SortField^ field
)

Parameters

field
Type: Lucene.Net.Search..::..SortField

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Sort.SetSort(Lucene.Net.Search.SortField)"]

See Also

Sort Class
SetSort Overload
Lucene.Net.Search Namespace


SetSort Method (SortField[])

[image]

Lucene.Net Class Libraries
Sort..::..SetSort Method (array<SortField>[]()[][])
Sort Class See Also Send Feedback
Sets the sort to the given criteria in succession.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetSort(
    SortField[] fields
)
Visual Basic
Public Overridable Sub SetSort ( _
    fields As SortField() _
)
Visual C++
public:
virtual void SetSort(
    array<SortField^>^ fields
)

Parameters

fields
Type: array< Lucene.Net.Search..::..SortField >[]()[][]

[Missing <param name="fields"/> documentation for "M:Lucene.Net.Search.Sort.SetSort(Lucene.Net.Search.SortField[])"]

See Also

Sort Class
SetSort Overload
Lucene.Net.Search Namespace


SetSort Method (String, Boolean)

[image]

Lucene.Net Class Libraries
Sort..::..SetSort Method (String, Boolean)
Sort Class See Also Send Feedback
Sets the sort to the terms in
CopyC#
field
 possibly in reverse, then by index order (document number).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use SetSort(SortField)")]
public virtual void SetSort(
    string field,
    bool reverse
)
Visual Basic
<ObsoleteAttribute("Please specify the type explicitly by first creating a SortField and then use SetSort(SortField)")> _
Public Overridable Sub SetSort ( _
    field As String, _
    reverse As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Please specify the type explicitly by first creating a SortField and then use SetSort(SortField)")]
public:
virtual void SetSort(
    String^ field,
    bool reverse
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Sort.SetSort(System.String,System.Boolean)"]

reverse
Type: System..::..Boolean

[Missing <param name="reverse"/> documentation for "M:Lucene.Net.Search.Sort.SetSort(System.String,System.Boolean)"]

See Also

Sort Class
SetSort Overload
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Sort..::..ToString Method
Sort Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Sort.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Sort.ToString"]

See Also

Sort Class
Lucene.Net.Search Namespace


SortComparator Class

[image]

Lucene.Net Class Libraries
SortComparator Class
Members See Also Send Feedback
Abstract base class for sorting hits returned by a Query.

This class should only be used if the other SortField types (SCORE, DOC, STRING, INT, FLOAT) do not provide an adequate sorting. It maintains an internal cache of values which could be quite large. The cache is an array of Comparable, one for each document in the index. There is a distinct Comparable for each unique term in the field - if some documents have the same term in the field, the cache array will have entries which reference the same Comparable. This class will be used as part of a key to a FieldCache value. You must implement hashCode and equals to avoid an explosion in RAM usage if you use instances that are not the same instance. If you are searching using the Remote contrib, the same instance of this class on the client will be a new instance on every call to the server, so hashCode/equals is very important in that situation.

Created: Apr 21, 2004 5:08:38 PM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Please use FieldComparatorSource instead.")]
public abstract class SortComparator : SortComparatorSource
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Please use FieldComparatorSource instead.")> _
Public MustInherit Class SortComparator _
    Implements SortComparatorSource
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Please use FieldComparatorSource instead.")]
public ref class SortComparator abstract : SortComparatorSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SortComparator

See Also

SortComparator Members
Lucene.Net.Search Namespace


SortComparator Members

[image] [image]

Lucene.Net Class Libraries
SortComparator Members
SortComparator Class Constructors Methods See Also Send Feedback

The SortComparator type exposes the following members.

Constructors

 | Name | Description
Protected method | SortComparator | Initializes a new instance of the SortComparator class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetComparable
Returns an object which, when sorted according to natural order, will order the Term values in the correct order.

For example, if the Terms contained integer values, this method would return

CopyC#
new Integer(termtext)
. Note that this might not always be the most efficient implementation - for this particular example, a better implementation might be to make a ScoreDocLookupComparator that uses an internal lookup table of int.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | NewComparator
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SortComparator Class
Lucene.Net.Search Namespace


SortComparator Constructor

[image]

Lucene.Net Class Libraries
SortComparator Constructor
SortComparator Class See Also Send Feedback
Initializes a new instance of the SortComparator class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected SortComparator()
Visual Basic
Protected Sub New
Visual C++
protected:
SortComparator()

See Also

SortComparator Class
Lucene.Net.Search Namespace


SortComparator Methods

[image] [image]

Lucene.Net Class Libraries
SortComparator Methods
SortComparator Class See Also Send Feedback

The SortComparator type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetComparable
Returns an object which, when sorted according to natural order, will order the Term values in the correct order.

For example, if the Terms contained integer values, this method would return

CopyC#
new Integer(termtext)
. Note that this might not always be the most efficient implementation - for this particular example, a better implementation might be to make a ScoreDocLookupComparator that uses an internal lookup table of int.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | NewComparator
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SortComparator Class
Lucene.Net.Search Namespace


GetComparable Method

[image]

Lucene.Net Class Libraries
SortComparator..::..GetComparable Method
SortComparator Class See Also Send Feedback
Returns an object which, when sorted according to natural order, will order the Term values in the correct order.

For example, if the Terms contained integer values, this method would return

CopyC#
new Integer(termtext)
. Note that this might not always be the most efficient implementation - for this particular example, a better implementation might be to make a ScoreDocLookupComparator that uses an internal lookup table of int.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract IComparable GetComparable(
    string termtext
)
Visual Basic
Public MustOverride Function GetComparable ( _
    termtext As String _
) As IComparable
Visual C++
public:
virtual IComparable^ GetComparable(
    String^ termtext
) abstract

Parameters

termtext
Type: System..::..String
The textual value of the term.

Return Value

An object representing
CopyC#
termtext
 that sorts according to the natural order of
CopyC#
termtext
.

See Also

SortComparator Class
Lucene.Net.Search Namespace
[!:Comparable]
Lucene.Net.Search..::..ScoreDocComparator


NewComparator Method

[image]

Lucene.Net Class Libraries
SortComparator..::..NewComparator Method
SortComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SortComparator.NewComparator(Lucene.Net.Index.IndexReader,System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual ScoreDocComparator NewComparator(
    IndexReader reader,
    string fieldname
)
Visual Basic
Public Overridable Function NewComparator ( _
    reader As IndexReader, _
    fieldname As String _
) As ScoreDocComparator
Visual C++
public:
virtual ScoreDocComparator^ NewComparator(
    IndexReader^ reader,
    String^ fieldname
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.SortComparator.NewComparator(Lucene.Net.Index.IndexReader,System.String)"]

fieldname
Type: System..::..String

[Missing <param name="fieldname"/> documentation for "M:Lucene.Net.Search.SortComparator.NewComparator(Lucene.Net.Index.IndexReader,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SortComparator.NewComparator(Lucene.Net.Index.IndexReader,System.String)"]

Implements

SortComparatorSource..::..NewComparator(IndexReader, String)

See Also

SortComparator Class
Lucene.Net.Search Namespace


SortComparatorSource Interface

[image]

Lucene.Net Class Libraries
SortComparatorSource Interface
Members See Also Send Feedback
Expert: returns a comparator for sorting ScoreDocs.

Created: Apr 21, 2004 3:49:28 PM This class will be used as part of a key to a FieldCache value. You must implement hashCode and equals to avoid an explosion in RAM usage if you use instances that are not the same instance. If you are searching using the Remote contrib, the same instance of this class on the client will be a new instance on every call to the server, so hashCode/equals is very important in that situation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use FieldComparatorSource instead.")]
public interface SortComparatorSource
Visual Basic
<ObsoleteAttribute("Please use FieldComparatorSource instead.")> _
Public Interface SortComparatorSource
Visual C++
[ObsoleteAttribute(L"Please use FieldComparatorSource instead.")]
public interface class SortComparatorSource

See Also

SortComparatorSource Members
Lucene.Net.Search Namespace


SortComparatorSource Members

[image] [image]

Lucene.Net Class Libraries
SortComparatorSource Members
SortComparatorSource Interface Methods See Also Send Feedback

The SortComparatorSource type exposes the following members.

Methods

 | Name | Description
Public method | NewComparator | Creates a comparator for the field in the given index.

See Also

SortComparatorSource Interface
Lucene.Net.Search Namespace


SortComparatorSource Methods

[image] [image]

Lucene.Net Class Libraries
SortComparatorSource Methods
SortComparatorSource Interface See Also Send Feedback

The SortComparatorSource type exposes the following members.

Methods

 | Name | Description
Public method | NewComparator | Creates a comparator for the field in the given index.

See Also

SortComparatorSource Interface
Lucene.Net.Search Namespace


NewComparator Method

[image]

Lucene.Net Class Libraries
SortComparatorSource..::..NewComparator Method
SortComparatorSource Interface See Also Send Feedback
Creates a comparator for the field in the given index.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
ScoreDocComparator NewComparator(
    IndexReader reader,
    string fieldname
)
Visual Basic
Function NewComparator ( _
    reader As IndexReader, _
    fieldname As String _
) As ScoreDocComparator
Visual C++
ScoreDocComparator^ NewComparator(
    IndexReader^ reader,
    String^ fieldname
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Index to create comparator for.
fieldname
Type: System..::..String
Name of the field to create comparator for.

Return Value

Comparator of ScoreDoc objects.

See Also

SortComparatorSource Interface
Lucene.Net.Search Namespace


SortField Class

[image]

Lucene.Net Class Libraries
SortField Class
Members See Also Send Feedback
Stores information about how to sort documents by terms in an individual field. Fields must be indexed in order to sort by them.

Created: Feb 11, 2004 1:25:29 PM

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SortField
Visual Basic
<SerializableAttribute> _
Public Class SortField
Visual C++
[SerializableAttribute]
public ref class SortField

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SortField

See Also

SortField Members
Lucene.Net.Search Namespace
Lucene.Net.Search..::..Sort


SortField Members

[image] [image]

Lucene.Net Class Libraries
SortField Members
SortField Class Constructors Methods Fields See Also Send Feedback

The SortField type exposes the following members.

Constructors

 | Name | Description
Public method | SortField(String) | Obsolete. Creates a sort by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).
Public method | SortField(String, FieldComparatorSource) | Creates a sort with a custom comparison function.
Public method | SortField(String, Parser) | Creates a sort by terms in the given field, parsed to numeric values using a custom {@link FieldCache.Parser}.
Public method | SortField(String, SortComparatorSource) | Obsolete. Creates a sort with a custom comparison function.
Public method | SortField(String, Boolean) | Obsolete. Creates a sort, possibly in reverse, by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).
Public method | SortField(String, CultureInfo) | Creates a sort by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32) | Creates a sort by terms in the given field with the type of term values explicitly given.
Public method | SortField(String, FieldComparatorSource, Boolean) | Creates a sort, possibly in reverse, with a custom comparison function.
Public method | SortField(String, Parser, Boolean) | Creates a sort, possibly in reverse, by terms in the given field, parsed to numeric values using a custom {@link FieldCache.Parser}.
Public method | SortField(String, SortComparatorSource, Boolean) | Obsolete. Creates a sort, possibly in reverse, with a custom comparison function.
Public method | SortField(String, CultureInfo, Boolean) | Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32, Boolean) | Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.

Methods

Name | Description
Public method Equals
Returns true if
CopyC#
o
 is equal to this. If a {@link SortComparatorSource} (deprecated) or {@link FieldCache.Parser} was provided, it must properly implement equals (unless a singleton is always used).
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetComparator
Returns the {@link FieldComparator} to use for sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public method | GetComparatorSource
Public method | GetFactory | Obsolete.
Public method GetField
Returns the name of the field. Could return
CopyC#
null
 if the sort is by SCORE or DOC.
Public method GetHashCode
Returns true if
CopyC#
o
 is equal to this. If a {@link SortComparatorSource} (deprecated) or {@link FieldCache.Parser} was provided, it must properly implement hashCode (unless a singleton is always used).
(Overrides Object..::..GetHashCode()()()().)
Public method GetLocale
Returns the Locale by which term values are interpreted. May return
CopyC#
null
 if no Locale was specified.
Public method GetParser
Returns the instance of a {@link FieldCache} parser that fits to the given sort type. May return
CopyC#
null
 if no parser was specified. Sorting is using the default parser then.
Public method GetReverse
Returns whether the sort should be reversed.
Public method GetType
Returns the type of contents in the field.
Public method | GetUseLegacySearch | Obsolete.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetUseLegacySearch Obsolete.
Use legacy IndexSearch implementation: search with a DirectoryReader rather than passing a single hit collector to multiple SegmentReaders.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
AUTO | Obsolete. Guess type of sort based on field contents. A regular expression is used to look at the first term indexed for the field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.
BYTE | Sort using term values as encoded Bytes. Sort values are Byte and lower values are at the front.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
DOUBLE | Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
LONG | Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
SHORT | Sort using term values as encoded Shorts. Sort values are Short and lower values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.
STRING_VAL | Sort using term values as Strings, but comparing by value (using String.compareTo) for all comparisons. This is typically slower than {@link #STRING}, which uses ordinals to do the sorting.

See Also

SortField Class
Lucene.Net.Search Namespace


SortField Constructor

[image] [image]

Lucene.Net Class Libraries
SortField Constructor
SortField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortField(String) | Obsolete. Creates a sort by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).
Public method | SortField(String, FieldComparatorSource) | Creates a sort with a custom comparison function.
Public method | SortField(String, Parser) | Creates a sort by terms in the given field, parsed to numeric values using a custom {@link FieldCache.Parser}.
Public method | SortField(String, SortComparatorSource) | Obsolete. Creates a sort with a custom comparison function.
Public method | SortField(String, Boolean) | Obsolete. Creates a sort, possibly in reverse, by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).
Public method | SortField(String, CultureInfo) | Creates a sort by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32) | Creates a sort by terms in the given field with the type of term values explicitly given.
Public method | SortField(String, FieldComparatorSource, Boolean) | Creates a sort, possibly in reverse, with a custom comparison function.
Public method | SortField(String, Parser, Boolean) | Creates a sort, possibly in reverse, by terms in the given field, parsed to numeric values using a custom {@link FieldCache.Parser}.
Public method | SortField(String, SortComparatorSource, Boolean) | Obsolete. Creates a sort, possibly in reverse, with a custom comparison function.
Public method | SortField(String, CultureInfo, Boolean) | Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.
Public method | SortField(String, Int32, Boolean) | Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.

See Also

SortField Class
SortField Members
Lucene.Net.Search Namespace


SortField Constructor (String)

[image]

Lucene.Net Class Libraries
SortField Constructor (String)
SortField Class See Also Send Feedback
Creates a sort by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the exact type instead.")]
public SortField(
    string field
)
Visual Basic
<ObsoleteAttribute("Please specify the exact type instead.")> _
Public Sub New ( _
    field As String _
)
Visual C++
[ObsoleteAttribute(L"Please specify the exact type instead.")]
public:
SortField(
    String^ field
)

Parameters

field
Type: System..::..String
Name of field to sort by, cannot be
CopyC#
null
.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, FieldComparatorSource)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, FieldComparatorSource)
SortField Class See Also Send Feedback
Creates a sort with a custom comparison function.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    FieldComparatorSource comparator
)
Visual Basic
Public Sub New ( _
    field As String, _
    comparator As FieldComparatorSource _
)
Visual C++
public:
SortField(
    String^ field,
    FieldComparatorSource^ comparator
)

Parameters

field
Type: System..::..String
Name of field to sort by; cannot be
CopyC#
null
.
comparator
Type: Lucene.Net.Search..::..FieldComparatorSource
Returns a comparator for sorting hits.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, Parser)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, Parser)
SortField Class See Also Send Feedback
Creates a sort by terms in the given field, parsed to numeric values using a custom {@link FieldCache.Parser}.
subclass an existing numeric parser, or field is null

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    Parser parser
)
Visual Basic
Public Sub New ( _
    field As String, _
    parser As Parser _
)
Visual C++
public:
SortField(
    String^ field,
    Parser^ parser
)

Parameters

field
Type: System..::..String
Name of field to sort by. Must not be null.
parser
Type: Lucene.Net.Search..::..Parser
Instance of a {@link FieldCache.Parser}, which must subclass one of the existing numeric parsers from {@link FieldCache}. Sort type is inferred by testing which numeric parser the parser subclasses.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, SortComparatorSource)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, SortComparatorSource)
SortField Class See Also Send Feedback
Creates a sort with a custom comparison function.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use SortField (String field, FieldComparatorSource comparator)")]
public SortField(
    string field,
    SortComparatorSource comparator
)
Visual Basic
<ObsoleteAttribute("use SortField (String field, FieldComparatorSource comparator)")> _
Public Sub New ( _
    field As String, _
    comparator As SortComparatorSource _
)
Visual C++
[ObsoleteAttribute(L"use SortField (String field, FieldComparatorSource comparator)")]
public:
SortField(
    String^ field,
    SortComparatorSource^ comparator
)

Parameters

field
Type: System..::..String
Name of field to sort by; cannot be
CopyC#
null
.
comparator
Type: Lucene.Net.Search..::..SortComparatorSource
Returns a comparator for sorting hits.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, Boolean)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, Boolean)
SortField Class See Also Send Feedback
Creates a sort, possibly in reverse, by terms in the given field where the type of term value is determined dynamically ({@link #AUTO AUTO}).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the exact type instead.")]
public SortField(
    string field,
    bool reverse
)
Visual Basic
<ObsoleteAttribute("Please specify the exact type instead.")> _
Public Sub New ( _
    field As String, _
    reverse As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Please specify the exact type instead.")]
public:
SortField(
    String^ field,
    bool reverse
)

Parameters

field
Type: System..::..String
Name of field to sort by, cannot be
CopyC#
null
.
reverse
Type: System..::..Boolean
True if natural order should be reversed.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, CultureInfo)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, CultureInfo)
SortField Class See Also Send Feedback
Creates a sort by terms in the given field sorted according to the given locale.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    CultureInfo locale
)
Visual Basic
Public Sub New ( _
    field As String, _
    locale As CultureInfo _
)
Visual C++
public:
SortField(
    String^ field,
    CultureInfo^ locale
)

Parameters

field
Type: System..::..String
Name of field to sort by, cannot be
CopyC#
null
.
locale
Type: System.Globalization..::..CultureInfo
Locale of values in the field.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, Int32)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, Int32)
SortField Class See Also Send Feedback
Creates a sort by terms in the given field with the type of term values explicitly given.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    int type
)
Visual Basic
Public Sub New ( _
    field As String, _
    type As Integer _
)
Visual C++
public:
SortField(
    String^ field,
    int type
)

Parameters

field
Type: System..::..String
Name of field to sort by. Can be
CopyC#
null
 if
CopyC#
type
 is SCORE or DOC.
type
Type: System..::..Int32
Type of values in the terms.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, FieldComparatorSource, Boolean)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, FieldComparatorSource, Boolean)
SortField Class See Also Send Feedback
Creates a sort, possibly in reverse, with a custom comparison function.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    FieldComparatorSource comparator,
    bool reverse
)
Visual Basic
Public Sub New ( _
    field As String, _
    comparator As FieldComparatorSource, _
    reverse As Boolean _
)
Visual C++
public:
SortField(
    String^ field,
    FieldComparatorSource^ comparator,
    bool reverse
)

Parameters

field
Type: System..::..String
Name of field to sort by; cannot be
CopyC#
null
.
comparator
Type: Lucene.Net.Search..::..FieldComparatorSource
Returns a comparator for sorting hits.
reverse
Type: System..::..Boolean
True if natural order should be reversed.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, Parser, Boolean)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, Parser, Boolean)
SortField Class See Also Send Feedback
Creates a sort, possibly in reverse, by terms in the given field, parsed to numeric values using a custom {@link FieldCache.Parser}.
subclass an existing numeric parser, or field is null

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    Parser parser,
    bool reverse
)
Visual Basic
Public Sub New ( _
    field As String, _
    parser As Parser, _
    reverse As Boolean _
)
Visual C++
public:
SortField(
    String^ field,
    Parser^ parser,
    bool reverse
)

Parameters

field
Type: System..::..String
Name of field to sort by. Must not be null.
parser
Type: Lucene.Net.Search..::..Parser
Instance of a {@link FieldCache.Parser}, which must subclass one of the existing numeric parsers from {@link FieldCache}. Sort type is inferred by testing which numeric parser the parser subclasses.
reverse
Type: System..::..Boolean
True if natural order should be reversed.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, SortComparatorSource, Boolean)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, SortComparatorSource, Boolean)
SortField Class See Also Send Feedback
Creates a sort, possibly in reverse, with a custom comparison function.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use SortField(String field, FieldComparatorSource comparator, boolean reverse)")]
public SortField(
    string field,
    SortComparatorSource comparator,
    bool reverse
)
Visual Basic
<ObsoleteAttribute("use SortField(String field, FieldComparatorSource comparator, boolean reverse)")> _
Public Sub New ( _
    field As String, _
    comparator As SortComparatorSource, _
    reverse As Boolean _
)
Visual C++
[ObsoleteAttribute(L"use SortField(String field, FieldComparatorSource comparator, boolean reverse)")]
public:
SortField(
    String^ field,
    SortComparatorSource^ comparator,
    bool reverse
)

Parameters

field
Type: System..::..String
Name of field to sort by; cannot be
CopyC#
null
.
comparator
Type: Lucene.Net.Search..::..SortComparatorSource
Returns a comparator for sorting hits.
reverse
Type: System..::..Boolean
True if natural order should be reversed.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, CultureInfo, Boolean)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, CultureInfo, Boolean)
SortField Class See Also Send Feedback
Creates a sort, possibly in reverse, by terms in the given field sorted according to the given locale.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    CultureInfo locale,
    bool reverse
)
Visual Basic
Public Sub New ( _
    field As String, _
    locale As CultureInfo, _
    reverse As Boolean _
)
Visual C++
public:
SortField(
    String^ field,
    CultureInfo^ locale,
    bool reverse
)

Parameters

field
Type: System..::..String
Name of field to sort by, cannot be
CopyC#
null
.
locale
Type: System.Globalization..::..CultureInfo
Locale of values in the field.
reverse
Type: System..::..Boolean

[Missing <param name="reverse"/> documentation for "M:Lucene.Net.Search.SortField.#ctor(System.String,System.Globalization.CultureInfo,System.Boolean)"]

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Constructor (String, Int32, Boolean)

[image]

Lucene.Net Class Libraries
SortField Constructor (String, Int32, Boolean)
SortField Class See Also Send Feedback
Creates a sort, possibly in reverse, by terms in the given field with the type of term values explicitly given.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField(
    string field,
    int type,
    bool reverse
)
Visual Basic
Public Sub New ( _
    field As String, _
    type As Integer, _
    reverse As Boolean _
)
Visual C++
public:
SortField(
    String^ field,
    int type,
    bool reverse
)

Parameters

field
Type: System..::..String
Name of field to sort by. Can be
CopyC#
null
 if
CopyC#
type
 is SCORE or DOC.
type
Type: System..::..Int32
Type of values in the terms.
reverse
Type: System..::..Boolean
True if natural order should be reversed.

See Also

SortField Class
SortField Overload
Lucene.Net.Search Namespace


SortField Fields

[image] [image]

Lucene.Net Class Libraries
SortField Fields
SortField Class See Also Send Feedback

The SortField type exposes the following members.

Fields

Name | Description
AUTO | Obsolete. Guess type of sort based on field contents. A regular expression is used to look at the first term indexed for the field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.
BYTE | Sort using term values as encoded Bytes. Sort values are Byte and lower values are at the front.
CUSTOM | Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.
DOC | Sort by document number (index order). Sort values are Integer and lower values are at the front.
DOUBLE | Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.
FIELD_DOC | Represents sorting by document number (index order).
FIELD_SCORE | Represents sorting by document score (relevancy).
FLOAT | Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.
INT | Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.
LONG | Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.
SCORE | Sort by document score (relevancy). Sort values are Float and higher values are at the front.
SHORT | Sort using term values as encoded Shorts. Sort values are Short and lower values are at the front.
STRING | Sort using term values as Strings. Sort values are String and lower values are at the front.
STRING_VAL | Sort using term values as Strings, but comparing by value (using String.compareTo) for all comparisons. This is typically slower than {@link #STRING}, which uses ordinals to do the sorting.

See Also

SortField Class
Lucene.Net.Search Namespace


AUTO Field

[image]

Lucene.Net Class Libraries
SortField..::..AUTO Field
SortField Class See Also Send Feedback
Guess type of sort based on field contents. A regular expression is used to look at the first term indexed for the field and determine if it represents an integer number, a floating point number, or just arbitrary string characters.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please specify the exact type, instead. Especially, guessing does not work with the new NumericField type.")]
public const int AUTO
Visual Basic
<ObsoleteAttribute("Please specify the exact type, instead. Especially, guessing does not work with the new NumericField type.")> _
Public Const AUTO As Integer
Visual C++
[ObsoleteAttribute(L"Please specify the exact type, instead. Especially, guessing does not work with the new NumericField type.")]
public:
literal int AUTO

See Also

SortField Class
Lucene.Net.Search Namespace


BYTE Field

[image]

Lucene.Net Class Libraries
SortField..::..BYTE Field
SortField Class See Also Send Feedback
Sort using term values as encoded Bytes. Sort values are Byte and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int BYTE
Visual Basic
Public Const BYTE As Integer
Visual C++
public:
literal int BYTE

See Also

SortField Class
Lucene.Net.Search Namespace


CUSTOM Field

[image]

Lucene.Net Class Libraries
SortField..::..CUSTOM Field
SortField Class See Also Send Feedback
Sort using a custom Comparator. Sort values are any Comparable and sorting is done according to natural order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int CUSTOM
Visual Basic
Public Const CUSTOM As Integer
Visual C++
public:
literal int CUSTOM

See Also

SortField Class
Lucene.Net.Search Namespace


DOC Field

[image]

Lucene.Net Class Libraries
SortField..::..DOC Field
SortField Class See Also Send Feedback
Sort by document number (index order). Sort values are Integer and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DOC
Visual Basic
Public Const DOC As Integer
Visual C++
public:
literal int DOC

See Also

SortField Class
Lucene.Net.Search Namespace


DOUBLE Field

[image]

Lucene.Net Class Libraries
SortField..::..DOUBLE Field
SortField Class See Also Send Feedback
Sort using term values as encoded Doubles. Sort values are Double and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DOUBLE
Visual Basic
Public Const DOUBLE As Integer
Visual C++
public:
literal int DOUBLE

See Also

SortField Class
Lucene.Net.Search Namespace


FIELD_DOC Field

[image]

Lucene.Net Class Libraries
SortField..::..FIELD_DOC Field
SortField Class See Also Send Feedback
Represents sorting by document number (index order).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly SortField FIELD_DOC
Visual Basic
Public Shared ReadOnly FIELD_DOC As SortField
Visual C++
public:
static initonly SortField^ FIELD_DOC

See Also

SortField Class
Lucene.Net.Search Namespace


FIELD_SCORE Field

[image]

Lucene.Net Class Libraries
SortField..::..FIELD_SCORE Field
SortField Class See Also Send Feedback
Represents sorting by document score (relevancy).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly SortField FIELD_SCORE
Visual Basic
Public Shared ReadOnly FIELD_SCORE As SortField
Visual C++
public:
static initonly SortField^ FIELD_SCORE

See Also

SortField Class
Lucene.Net.Search Namespace


FLOAT Field

[image]

Lucene.Net Class Libraries
SortField..::..FLOAT Field
SortField Class See Also Send Feedback
Sort using term values as encoded Floats. Sort values are Float and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int FLOAT
Visual Basic
Public Const FLOAT As Integer
Visual C++
public:
literal int FLOAT

See Also

SortField Class
Lucene.Net.Search Namespace


INT Field

[image]

Lucene.Net Class Libraries
SortField..::..INT Field
SortField Class See Also Send Feedback
Sort using term values as encoded Integers. Sort values are Integer and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int INT
Visual Basic
Public Const INT As Integer
Visual C++
public:
literal int INT

See Also

SortField Class
Lucene.Net.Search Namespace


LONG Field

[image]

Lucene.Net Class Libraries
SortField..::..LONG Field
SortField Class See Also Send Feedback
Sort using term values as encoded Longs. Sort values are Long and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int LONG
Visual Basic
Public Const LONG As Integer
Visual C++
public:
literal int LONG

See Also

SortField Class
Lucene.Net.Search Namespace


SCORE Field

[image]

Lucene.Net Class Libraries
SortField..::..SCORE Field
SortField Class See Also Send Feedback
Sort by document score (relevancy). Sort values are Float and higher values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int SCORE
Visual Basic
Public Const SCORE As Integer
Visual C++
public:
literal int SCORE

See Also

SortField Class
Lucene.Net.Search Namespace


SHORT Field

[image]

Lucene.Net Class Libraries
SortField..::..SHORT Field
SortField Class See Also Send Feedback
Sort using term values as encoded Shorts. Sort values are Short and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int SHORT
Visual Basic
Public Const SHORT As Integer
Visual C++
public:
literal int SHORT

See Also

SortField Class
Lucene.Net.Search Namespace


STRING Field

[image]

Lucene.Net Class Libraries
SortField..::..STRING Field
SortField Class See Also Send Feedback
Sort using term values as Strings. Sort values are String and lower values are at the front.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int STRING
Visual Basic
Public Const STRING As Integer
Visual C++
public:
literal int STRING

See Also

SortField Class
Lucene.Net.Search Namespace


STRING_VAL Field

[image]

Lucene.Net Class Libraries
SortField..::..STRING_VAL Field
SortField Class See Also Send Feedback
Sort using term values as Strings, but comparing by value (using String.compareTo) for all comparisons. This is typically slower than {@link #STRING}, which uses ordinals to do the sorting.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int STRING_VAL
Visual Basic
Public Const STRING_VAL As Integer
Visual C++
public:
literal int STRING_VAL

See Also

SortField Class
Lucene.Net.Search Namespace


SortField Methods

[image] [image]

Lucene.Net Class Libraries
SortField Methods
SortField Class See Also Send Feedback

The SortField type exposes the following members.

Methods

Name | Description
Public method Equals
Returns true if
CopyC#
o
 is equal to this. If a {@link SortComparatorSource} (deprecated) or {@link FieldCache.Parser} was provided, it must properly implement equals (unless a singleton is always used).
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetComparator
Returns the {@link FieldComparator} to use for sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.
Public method | GetComparatorSource
Public method | GetFactory | Obsolete.
Public method GetField
Returns the name of the field. Could return
CopyC#
null
 if the sort is by SCORE or DOC.
Public method GetHashCode
Returns true if
CopyC#
o
 is equal to this. If a {@link SortComparatorSource} (deprecated) or {@link FieldCache.Parser} was provided, it must properly implement hashCode (unless a singleton is always used).
(Overrides Object..::..GetHashCode()()()().)
Public method GetLocale
Returns the Locale by which term values are interpreted. May return
CopyC#
null
 if no Locale was specified.
Public method GetParser
Returns the instance of a {@link FieldCache} parser that fits to the given sort type. May return
CopyC#
null
 if no parser was specified. Sorting is using the default parser then.
Public method GetReverse
Returns whether the sort should be reversed.
Public method GetType
Returns the type of contents in the field.
Public method | GetUseLegacySearch | Obsolete.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetUseLegacySearch Obsolete.
Use legacy IndexSearch implementation: search with a DirectoryReader rather than passing a single hit collector to multiple SegmentReaders.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SortField Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SortField..::..Equals Method
SortField Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this. If a {@link SortComparatorSource} (deprecated) or {@link FieldCache.Parser} was provided, it must properly implement equals (unless a singleton is always used).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.SortField.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SortField.Equals(System.Object)"]

See Also

SortField Class
Lucene.Net.Search Namespace


GetComparator Method

[image]

Lucene.Net Class Libraries
SortField..::..GetComparator Method
SortField Class See Also Send Feedback
Returns the {@link FieldComparator} to use for sorting. NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldComparator GetComparator(
    int numHits,
    int sortPos
)
Visual Basic
Public Overridable Function GetComparator ( _
    numHits As Integer, _
    sortPos As Integer _
) As FieldComparator
Visual C++
public:
virtual FieldComparator^ GetComparator(
    int numHits,
    int sortPos
)

Parameters

numHits
Type: System..::..Int32
number of top hits the queue will store
sortPos
Type: System..::..Int32
position of this SortField within {@link Sort}. The comparator is primary if sortPos==0, secondary if sortPos==1, etc. Some comparators can optimize themselves when they are the primary sort.

Return Value

{@link FieldComparator} to use when sorting

See Also

SortField Class
Lucene.Net.Search Namespace


GetComparatorSource Method

[image]

Lucene.Net Class Libraries
SortField..::..GetComparatorSource Method
SortField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SortField.GetComparatorSource"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual FieldComparatorSource GetComparatorSource()
Visual Basic
Public Overridable Function GetComparatorSource As FieldComparatorSource
Visual C++
public:
virtual FieldComparatorSource^ GetComparatorSource()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SortField.GetComparatorSource"]

See Also

SortField Class
Lucene.Net.Search Namespace


GetFactory Method

[image]

Lucene.Net Class Libraries
SortField..::..GetFactory Method
SortField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SortField.GetFactory"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use GetComparatorSource()")]
public virtual SortComparatorSource GetFactory()
Visual Basic
<ObsoleteAttribute("use GetComparatorSource()")> _
Public Overridable Function GetFactory As SortComparatorSource
Visual C++
[ObsoleteAttribute(L"use GetComparatorSource()")]
public:
virtual SortComparatorSource^ GetFactory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SortField.GetFactory"]

See Also

SortField Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SortField..::..GetField Method
SortField Class See Also Send Feedback
Returns the name of the field. Could return
CopyC#
null
 if the sort is by SCORE or DOC.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

Name of field, possibly
CopyC#
null
.

See Also

SortField Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SortField..::..GetHashCode Method
SortField Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this. If a {@link SortComparatorSource} (deprecated) or {@link FieldCache.Parser} was provided, it must properly implement hashCode (unless a singleton is always used).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SortField.GetHashCode"]

See Also

SortField Class
Lucene.Net.Search Namespace


GetLocale Method

[image]

Lucene.Net Class Libraries
SortField..::..GetLocale Method
SortField Class See Also Send Feedback
Returns the Locale by which term values are interpreted. May return
CopyC#
null
 if no Locale was specified.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CultureInfo GetLocale()
Visual Basic
Public Overridable Function GetLocale As CultureInfo
Visual C++
public:
virtual CultureInfo^ GetLocale()

Return Value

Locale, or
CopyC#
null
.

See Also

SortField Class
Lucene.Net.Search Namespace


GetParser Method

[image]

Lucene.Net Class Libraries
SortField..::..GetParser Method
SortField Class See Also Send Feedback
Returns the instance of a {@link FieldCache} parser that fits to the given sort type. May return
CopyC#
null
 if no parser was specified. Sorting is using the default parser then.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Parser GetParser()
Visual Basic
Public Overridable Function GetParser As Parser
Visual C++
public:
virtual Parser^ GetParser()

Return Value

An instance of a {@link FieldCache} parser, or
CopyC#
null
.

See Also

SortField Class
Lucene.Net.Search Namespace


GetReverse Method

[image]

Lucene.Net Class Libraries
SortField..::..GetReverse Method
SortField Class See Also Send Feedback
Returns whether the sort should be reversed.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetReverse()
Visual Basic
Public Overridable Function GetReverse As Boolean
Visual C++
public:
virtual bool GetReverse()

Return Value

True if natural order should be reversed.

See Also

SortField Class
Lucene.Net.Search Namespace


GetType Method

[image]

Lucene.Net Class Libraries
SortField..::..GetType Method
SortField Class See Also Send Feedback
Returns the type of contents in the field.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetType()
Visual Basic
Public Overridable Function GetType As Integer
Visual C++
public:
virtual int GetType()

Return Value

One of the constants SCORE, DOC, AUTO, STRING, INT or FLOAT.

See Also

SortField Class
Lucene.Net.Search Namespace


GetUseLegacySearch Method

[image]

Lucene.Net Class Libraries
SortField..::..GetUseLegacySearch Method
SortField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SortField.GetUseLegacySearch"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("will be removed in Lucene 3.0.")]
public virtual bool GetUseLegacySearch()
Visual Basic
<ObsoleteAttribute("will be removed in Lucene 3.0.")> _
Public Overridable Function GetUseLegacySearch As Boolean
Visual C++
[ObsoleteAttribute(L"will be removed in Lucene 3.0.")]
public:
virtual bool GetUseLegacySearch()

Return Value

if true, IndexSearch will use legacy sorting search implementation. eg. multiple Priority Queues.

See Also

SortField Class
Lucene.Net.Search Namespace


SetUseLegacySearch Method

[image]

Lucene.Net Class Libraries
SortField..::..SetUseLegacySearch Method
SortField Class See Also Send Feedback
Use legacy IndexSearch implementation: search with a DirectoryReader rather than passing a single hit collector to multiple SegmentReaders.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("will be removed in Lucene 3.0.")]
public virtual void SetUseLegacySearch(
    bool legacy
)
Visual Basic
<ObsoleteAttribute("will be removed in Lucene 3.0.")> _
Public Overridable Sub SetUseLegacySearch ( _
    legacy As Boolean _
)
Visual C++
[ObsoleteAttribute(L"will be removed in Lucene 3.0.")]
public:
virtual void SetUseLegacySearch(
    bool legacy
)

Parameters

legacy
Type: System..::..Boolean
true for legacy behavior

See Also

SortField Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
SortField..::..ToString Method
SortField Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SortField.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SortField.ToString"]

See Also

SortField Class
Lucene.Net.Search Namespace


SpanFilter Class

[image]

Lucene.Net Class Libraries
SpanFilter Class
Members See Also Send Feedback
Abstract base class providing a mechanism to restrict searches to a subset of an index and also maintains and returns position information. This is useful if you want to compare the positions from a SpanQuery with the positions of items in a filter. For instance, if you had a SpanFilter that marked all the occurrences of the word "foo" in documents, and then you entered a new SpanQuery containing bar, you could not only filter by the word foo, but you could then compare position information for post processing.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class SpanFilter : Filter
Visual Basic
<SerializableAttribute> _
Public MustInherit Class SpanFilter _
    Inherits Filter
Visual C++
[SerializableAttribute]
public ref class SpanFilter abstract : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..SpanFilter
Lucene.Net.Search..::..CachingSpanFilter
Lucene.Net.Search..::..SpanQueryFilter

See Also

SpanFilter Members
Lucene.Net.Search Namespace


SpanFilter Members

[image] [image]

Lucene.Net Class Libraries
SpanFilter Members
SpanFilter Class Constructors Methods See Also Send Feedback

The SpanFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | SpanFilter | Initializes a new instance of the SpanFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | BitSpans | Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment. (Inherited from Filter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilter Class
Lucene.Net.Search Namespace


SpanFilter Constructor

[image]

Lucene.Net Class Libraries
SpanFilter Constructor
SpanFilter Class See Also Send Feedback
Initializes a new instance of the SpanFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected SpanFilter()
Visual Basic
Protected Sub New
Visual C++
protected:
SpanFilter()

See Also

SpanFilter Class
Lucene.Net.Search Namespace


SpanFilter Methods

[image] [image]

Lucene.Net Class Libraries
SpanFilter Methods
SpanFilter Class See Also Send Feedback

The SpanFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | BitSpans | Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment. (Inherited from Filter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilter Class
Lucene.Net.Search Namespace


BitSpans Method

[image]

Lucene.Net Class Libraries
SpanFilter..::..BitSpans Method
SpanFilter Class See Also Send Feedback
Returns a SpanFilterResult with true for documents which should be permitted in search results, and false for those that should not and Spans for where the true docs match.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract SpanFilterResult BitSpans(
    IndexReader reader
)
Visual Basic
Public MustOverride Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
Visual C++
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The {@link Lucene.Net.Index.IndexReader} to load position and DocIdSet information from

Return Value

A {@link SpanFilterResult}

See Also

SpanFilter Class
Lucene.Net.Search Namespace


SpanFilterResult Class

[image]

Lucene.Net Class Libraries
SpanFilterResult Class
Members See Also Send Feedback
The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SpanFilterResult
Visual Basic
Public Class SpanFilterResult
Visual C++
public ref class SpanFilterResult

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SpanFilterResult

See Also

SpanFilterResult Members
Lucene.Net.Search Namespace


SpanFilterResult Members

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult Members
SpanFilterResult Class Constructors Methods See Also Send Feedback

The SpanFilterResult type exposes the following members.

Constructors

 | Name | Description
Public method | SpanFilterResult(BitArray, IList) | Obsolete. Initializes a new instance of the SpanFilterResult class
Public method | SpanFilterResult(DocIdSet, IList) | Initializes a new instance of the SpanFilterResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBits | Obsolete.
Public method | GetDocIdSet | Returns the docIdSet
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositions | The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilterResult Class
Lucene.Net.Search Namespace


SpanFilterResult Constructor

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult Constructor
SpanFilterResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpanFilterResult(BitArray, IList) | Obsolete. Initializes a new instance of the SpanFilterResult class
Public method | SpanFilterResult(DocIdSet, IList) | Initializes a new instance of the SpanFilterResult class

See Also

SpanFilterResult Class
SpanFilterResult Members
Lucene.Net.Search Namespace


SpanFilterResult Constructor (BitArray, IList)

[image]

Lucene.Net Class Libraries
SpanFilterResult Constructor (BitArray, IList)
SpanFilterResult Class See Also Send Feedback
Initializes a new instance of the SpanFilterResult class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use SpanFilterResult(DocIdSet, List) instead")]
public SpanFilterResult(
    BitArray bits,
    IList positions
)
Visual Basic
<ObsoleteAttribute("Use SpanFilterResult(DocIdSet, List) instead")> _
Public Sub New ( _
    bits As BitArray, _
    positions As IList _
)
Visual C++
[ObsoleteAttribute(L"Use SpanFilterResult(DocIdSet, List) instead")]
public:
SpanFilterResult(
    BitArray^ bits,
    IList^ positions
)

Parameters

bits
Type: System.Collections..::..BitArray
The bits for the Filter
positions
Type: System.Collections..::..IList
A List of {@link Lucene.Net.Search.SpanFilterResult.PositionInfo} objects

See Also

SpanFilterResult Class
SpanFilterResult Overload
Lucene.Net.Search Namespace


SpanFilterResult Constructor (DocIdSet, IList)

[image]

Lucene.Net Class Libraries
SpanFilterResult Constructor (DocIdSet, IList)
SpanFilterResult Class See Also Send Feedback
Initializes a new instance of the SpanFilterResult class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanFilterResult(
    DocIdSet docIdSet,
    IList positions
)
Visual Basic
Public Sub New ( _
    docIdSet As DocIdSet, _
    positions As IList _
)
Visual C++
public:
SpanFilterResult(
    DocIdSet^ docIdSet,
    IList^ positions
)

Parameters

docIdSet
Type: Lucene.Net.Search..::..DocIdSet
The DocIdSet for the Filter
positions
Type: System.Collections..::..IList
A List of {@link Lucene.Net.Search.SpanFilterResult.PositionInfo} objects

See Also

SpanFilterResult Class
SpanFilterResult Overload
Lucene.Net.Search Namespace


SpanFilterResult Methods

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult Methods
SpanFilterResult Class See Also Send Feedback

The SpanFilterResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBits | Obsolete.
Public method | GetDocIdSet | Returns the docIdSet
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositions | The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilterResult Class
Lucene.Net.Search Namespace


GetBits Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..GetBits Method
SpanFilterResult Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanFilterResult.GetBits"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use GetDocIdSet()")]
public virtual BitArray GetBits()
Visual Basic
<ObsoleteAttribute("Use GetDocIdSet()")> _
Public Overridable Function GetBits As BitArray
Visual C++
[ObsoleteAttribute(L"Use GetDocIdSet()")]
public:
virtual BitArray^ GetBits()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanFilterResult.GetBits"]

See Also

SpanFilterResult Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..GetDocIdSet Method
SpanFilterResult Class See Also Send Feedback
Returns the docIdSet

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual DocIdSet GetDocIdSet()
Visual Basic
Public Overridable Function GetDocIdSet As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanFilterResult.GetDocIdSet"]

See Also

SpanFilterResult Class
Lucene.Net.Search Namespace


GetPositions Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..GetPositions Method
SpanFilterResult Class See Also Send Feedback
The first entry in the array corresponds to the first "on" bit. Entries are increasing by document order

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList GetPositions()
Visual Basic
Public Overridable Function GetPositions As IList
Visual C++
public:
virtual IList^ GetPositions()

Return Value

A List of PositionInfo objects

See Also

SpanFilterResult Class
Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Class

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo Class
SpanFilterResult Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.SpanFilterResult.PositionInfo"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PositionInfo
Visual Basic
Public Class PositionInfo
Visual C++
public ref class PositionInfo

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SpanFilterResult..::..PositionInfo

See Also

SpanFilterResult..::..PositionInfo Members
Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Members

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo Members
SpanFilterResult..::..PositionInfo Class Constructors Methods See Also Send Feedback

The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.

The SpanFilterResult..::..PositionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SpanFilterResult..::..PositionInfo | Initializes a new instance of the SpanFilterResult..::..PositionInfo class

Methods

 | Name | Description
Public method | AddPosition |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDoc |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilterResult..::..PositionInfo Class
Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Constructor

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo Constructor
SpanFilterResult..::..PositionInfo Class See Also Send Feedback
Initializes a new instance of the SpanFilterResult..::..PositionInfo class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PositionInfo(
    int doc
)
Visual Basic
Public Sub New ( _
    doc As Integer _
)
Visual C++
public:
PositionInfo(
    int doc
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.#ctor(System.Int32)"]

See Also

SpanFilterResult..::..PositionInfo Class
Lucene.Net.Search Namespace


SpanFilterResult.PositionInfo Methods

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo Methods
SpanFilterResult..::..PositionInfo Class See Also Send Feedback

The SpanFilterResult..::..PositionInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddPosition |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDoc |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilterResult..::..PositionInfo Class
Lucene.Net.Search Namespace


AddPosition Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo..::..AddPosition Method
SpanFilterResult..::..PositionInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.AddPosition(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddPosition(
    int start,
    int end
)
Visual Basic
Public Overridable Sub AddPosition ( _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
virtual void AddPosition(
    int start,
    int end
)

Parameters

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.AddPosition(System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.AddPosition(System.Int32,System.Int32)"]

See Also

SpanFilterResult..::..PositionInfo Class
Lucene.Net.Search Namespace


GetDoc Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo..::..GetDoc Method
SpanFilterResult..::..PositionInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.GetDoc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetDoc()
Visual Basic
Public Overridable Function GetDoc As Integer
Visual C++
public:
virtual int GetDoc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.GetDoc"]

See Also

SpanFilterResult..::..PositionInfo Class
Lucene.Net.Search Namespace


GetPositions Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..PositionInfo..::..GetPositions Method
SpanFilterResult..::..PositionInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanFilterResult.PositionInfo.GetPositions"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IList GetPositions()
Visual Basic
Public Overridable Function GetPositions As IList
Visual C++
public:
virtual IList^ GetPositions()

Return Value

A List of {@link Lucene.Net.Search.SpanFilterResult.StartEnd} objects

See Also

SpanFilterResult..::..PositionInfo Class
Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Class

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..StartEnd Class
SpanFilterResult Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.SpanFilterResult.StartEnd"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class StartEnd
Visual Basic
Public Class StartEnd
Visual C++
public ref class StartEnd

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..SpanFilterResult..::..StartEnd

See Also

SpanFilterResult..::..StartEnd Members
Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Members

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult..::..StartEnd Members
SpanFilterResult..::..StartEnd Class Constructors Methods See Also Send Feedback

The results of a SpanQueryFilter. Wraps the BitSet and the position information from the SpanQuery

NOTE: This API is still experimental and subject to change.

The SpanFilterResult..::..StartEnd type exposes the following members.

Constructors

 | Name | Description
Public method | SpanFilterResult..::..StartEnd | Initializes a new instance of the SpanFilterResult..::..StartEnd class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnd |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStart | The Start position
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilterResult..::..StartEnd Class
Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Constructor

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..StartEnd Constructor
SpanFilterResult..::..StartEnd Class See Also Send Feedback
Initializes a new instance of the SpanFilterResult..::..StartEnd class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StartEnd(
    int start,
    int end
)
Visual Basic
Public Sub New ( _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
StartEnd(
    int start,
    int end
)

Parameters

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.SpanFilterResult.StartEnd.#ctor(System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.SpanFilterResult.StartEnd.#ctor(System.Int32,System.Int32)"]

See Also

SpanFilterResult..::..StartEnd Class
Lucene.Net.Search Namespace


SpanFilterResult.StartEnd Methods

[image] [image]

Lucene.Net Class Libraries
SpanFilterResult..::..StartEnd Methods
SpanFilterResult..::..StartEnd Class See Also Send Feedback

The SpanFilterResult..::..StartEnd type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnd |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStart | The Start position
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanFilterResult..::..StartEnd Class
Lucene.Net.Search Namespace


GetEnd Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..StartEnd..::..GetEnd Method
SpanFilterResult..::..StartEnd Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanFilterResult.StartEnd.GetEnd"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetEnd()
Visual Basic
Public Overridable Function GetEnd As Integer
Visual C++
public:
virtual int GetEnd()

Return Value

The end position of this match

See Also

SpanFilterResult..::..StartEnd Class
Lucene.Net.Search Namespace


GetStart Method

[image]

Lucene.Net Class Libraries
SpanFilterResult..::..StartEnd..::..GetStart Method
SpanFilterResult..::..StartEnd Class See Also Send Feedback
The Start position

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetStart()
Visual Basic
Public Overridable Function GetStart As Integer
Visual C++
public:
virtual int GetStart()

Return Value

The start position of this match

See Also

SpanFilterResult..::..StartEnd Class
Lucene.Net.Search Namespace


SpanQueryFilter Class

[image]

Lucene.Net Class Libraries
SpanQueryFilter Class
Members See Also Send Feedback
Constrains search results to only match those which also match a provided query. Also provides position information about where each document matches at the cost of extra space compared with the QueryWrapperFilter. There is an added cost to this above what is stored in a {@link QueryWrapperFilter}. Namely, the position information for each matching document is stored.

This filter does not cache. See the {@link Lucene.Net.Search.CachingSpanFilter} for a wrapper that caches.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanQueryFilter : SpanFilter
Visual Basic
<SerializableAttribute> _
Public Class SpanQueryFilter _
    Inherits SpanFilter
Visual C++
[SerializableAttribute]
public ref class SpanQueryFilter : public SpanFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..SpanFilter
Lucene.Net.Search..::..SpanQueryFilter

See Also

SpanQueryFilter Members
Lucene.Net.Search Namespace


SpanQueryFilter Members

[image] [image]

Lucene.Net Class Libraries
SpanQueryFilter Members
SpanQueryFilter Class Constructors Methods Fields See Also Send Feedback

The SpanQueryFilter type exposes the following members.

Constructors

Name Description
Protected method SpanQueryFilter()()()()
Initializes a new instance of the SpanQueryFilter class
Public method SpanQueryFilter(SpanQuery)
Constructs a filter which only matches documents matching
CopyC#
query
.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | BitSpans | (Overrides SpanFilter..::..BitSpans(IndexReader).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetQuery |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | query |

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


SpanQueryFilter Constructor

[image] [image]

Lucene.Net Class Libraries
SpanQueryFilter Constructor
SpanQueryFilter Class See Also Send Feedback

Overload List

Name Description
Protected method SpanQueryFilter()()()()
Initializes a new instance of the SpanQueryFilter class
Public method SpanQueryFilter(SpanQuery)
Constructs a filter which only matches documents matching
CopyC#
query
.

See Also

SpanQueryFilter Class
SpanQueryFilter Members
Lucene.Net.Search Namespace


SpanQueryFilter Constructor

[image]

Lucene.Net Class Libraries
SpanQueryFilter Constructor
SpanQueryFilter Class See Also Send Feedback
Initializes a new instance of the SpanQueryFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SpanQueryFilter()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
SpanQueryFilter()

See Also

SpanQueryFilter Class
SpanQueryFilter Overload
Lucene.Net.Search Namespace


SpanQueryFilter Constructor (SpanQuery)

[image]

Lucene.Net Class Libraries
SpanQueryFilter Constructor (SpanQuery)
SpanQueryFilter Class See Also Send Feedback
Constructs a filter which only matches documents matching
CopyC#
query
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanQueryFilter(
    SpanQuery query
)
Visual Basic
Public Sub New ( _
    query As SpanQuery _
)
Visual C++
public:
SpanQueryFilter(
    SpanQuery^ query
)

Parameters

query
Type: Lucene.Net.Search.Spans..::..SpanQuery
The {@link Lucene.Net.Search.Spans.SpanQuery} to use as the basis for the Filter.

See Also

SpanQueryFilter Class
SpanQueryFilter Overload
Lucene.Net.Search Namespace


SpanQueryFilter Fields

[image] [image]

Lucene.Net Class Libraries
SpanQueryFilter Fields
SpanQueryFilter Class See Also Send Feedback

The SpanQueryFilter type exposes the following members.

Fields

 | Name | Description
Protected field | query |

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


query Field

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..query Field
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.SpanQueryFilter.query"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SpanQuery query
Visual Basic
Protected Friend query As SpanQuery
Visual C++
protected public:
SpanQuery^ query

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


SpanQueryFilter Methods

[image] [image]

Lucene.Net Class Libraries
SpanQueryFilter Methods
SpanQueryFilter Class See Also Send Feedback

The SpanQueryFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | BitSpans | (Overrides SpanFilter..::..BitSpans(IndexReader).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetQuery |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


BitSpans Method

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..BitSpans Method
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanQueryFilter.BitSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override SpanFilterResult BitSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function BitSpans ( _
    reader As IndexReader _
) As SpanFilterResult
Visual C++
public:
virtual SpanFilterResult^ BitSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.SpanQueryFilter.BitSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanQueryFilter.BitSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..Equals Method
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanQueryFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.SpanQueryFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanQueryFilter.Equals(System.Object)"]

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..GetDocIdSet Method
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..GetHashCode Method
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetHashCode"]

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..GetQuery Method
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetQuery"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery GetQuery()
Visual Basic
Public Overridable Function GetQuery As SpanQuery
Visual C++
public:
virtual SpanQuery^ GetQuery()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanQueryFilter.GetQuery"]

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
SpanQueryFilter..::..ToString Method
SpanQueryFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.SpanQueryFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.SpanQueryFilter.ToString"]

See Also

SpanQueryFilter Class
Lucene.Net.Search Namespace


StringIndex Class

[image]

Lucene.Net Class Libraries
StringIndex Class
Members See Also Send Feedback
Expert: Stores term text values and document ordering data.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class StringIndex
Visual Basic
Public Class StringIndex
Visual C++
public ref class StringIndex

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..StringIndex

See Also

StringIndex Members
Lucene.Net.Search Namespace


StringIndex Members

[image] [image]

Lucene.Net Class Libraries
StringIndex Members
StringIndex Class Constructors Methods Fields See Also Send Feedback

The StringIndex type exposes the following members.

Constructors

 | Name | Description
Public method | StringIndex | Creates one of these objects

Methods

 | Name | Description
Public method | BinarySearchLookup |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | lookup | All the term values, in natural order.
Public field | order | For each document, an index into the lookup array.

See Also

StringIndex Class
Lucene.Net.Search Namespace


StringIndex Constructor

[image]

Lucene.Net Class Libraries
StringIndex Constructor
StringIndex Class See Also Send Feedback
Creates one of these objects

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StringIndex(
    int[] values,
    string[] lookup
)
Visual Basic
Public Sub New ( _
    values As Integer(), _
    lookup As String() _
)
Visual C++
public:
StringIndex(
    array<int>^ values,
    array<String^>^ lookup
)

Parameters

values
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="values"/> documentation for "M:Lucene.Net.Search.StringIndex.#ctor(System.Int32[],System.String[])"]

lookup
Type: array< System..::..String >[]()[][]

[Missing <param name="lookup"/> documentation for "M:Lucene.Net.Search.StringIndex.#ctor(System.Int32[],System.String[])"]

See Also

StringIndex Class
Lucene.Net.Search Namespace


StringIndex Fields

[image] [image]

Lucene.Net Class Libraries
StringIndex Fields
StringIndex Class See Also Send Feedback

The StringIndex type exposes the following members.

Fields

 | Name | Description
Public field | lookup | All the term values, in natural order.
Public field | order | For each document, an index into the lookup array.

See Also

StringIndex Class
Lucene.Net.Search Namespace


lookup Field

[image]

Lucene.Net Class Libraries
StringIndex..::..lookup Field
StringIndex Class See Also Send Feedback
All the term values, in natural order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string[] lookup
Visual Basic
Public lookup As String()
Visual C++
public:
array<String^>^ lookup

See Also

StringIndex Class
Lucene.Net.Search Namespace


order Field

[image]

Lucene.Net Class Libraries
StringIndex..::..order Field
StringIndex Class See Also Send Feedback
For each document, an index into the lookup array.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int[] order
Visual Basic
Public order As Integer()
Visual C++
public:
array<int>^ order

See Also

StringIndex Class
Lucene.Net.Search Namespace


StringIndex Methods

[image] [image]

Lucene.Net Class Libraries
StringIndex Methods
StringIndex Class See Also Send Feedback

The StringIndex type exposes the following members.

Methods

 | Name | Description
Public method | BinarySearchLookup |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringIndex Class
Lucene.Net.Search Namespace


BinarySearchLookup Method

[image]

Lucene.Net Class Libraries
StringIndex..::..BinarySearchLookup Method
StringIndex Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.StringIndex.BinarySearchLookup(System.String)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int BinarySearchLookup(
    string key
)
Visual Basic
Public Overridable Function BinarySearchLookup ( _
    key As String _
) As Integer
Visual C++
public:
virtual int BinarySearchLookup(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Search.StringIndex.BinarySearchLookup(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.StringIndex.BinarySearchLookup(System.String)"]

See Also

StringIndex Class
Lucene.Net.Search Namespace


TermQuery Class

[image]

Lucene.Net Class Libraries
TermQuery Class
Members See Also Send Feedback
A Query that matches documents containing a term. This may be combined with other terms with a {@link BooleanQuery}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TermQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class TermQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class TermQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..TermQuery

See Also

TermQuery Members
Lucene.Net.Search Namespace


TermQuery Members

[image] [image]

Lucene.Net Class Libraries
TermQuery Members
TermQuery Class Constructors Methods See Also Send Feedback

The TermQuery type exposes the following members.

Constructors

Name Description
Public method TermQuery
Constructs a query for the term
CopyC#
t
.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm
Returns the term of this query.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

TermQuery Class
Lucene.Net.Search Namespace


TermQuery Constructor

[image]

Lucene.Net Class Libraries
TermQuery Constructor
TermQuery Class See Also Send Feedback
Constructs a query for the term
CopyC#
t
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermQuery(
    Term t
)
Visual Basic
Public Sub New ( _
    t As Term _
)
Visual C++
public:
TermQuery(
    Term^ t
)

Parameters

t
Type: Lucene.Net.Index..::..Term

[Missing <param name="t"/> documentation for "M:Lucene.Net.Search.TermQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

TermQuery Class
Lucene.Net.Search Namespace


TermQuery Methods

[image] [image]

Lucene.Net Class Libraries
TermQuery Methods
TermQuery Class See Also Send Feedback

The TermQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm
Returns the term of this query.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

TermQuery Class
Lucene.Net.Search Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
TermQuery..::..CreateWeight Method
TermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.TermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

TermQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TermQuery..::..Equals Method
TermQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.TermQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermQuery.Equals(System.Object)"]

See Also

TermQuery Class
Lucene.Net.Search Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
TermQuery..::..ExtractTerms Method
TermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.TermQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

TermQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TermQuery..::..GetHashCode Method
TermQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermQuery.GetHashCode"]

See Also

TermQuery Class
Lucene.Net.Search Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
TermQuery..::..GetTerm Method
TermQuery Class See Also Send Feedback
Returns the term of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term GetTerm()
Visual Basic
Public Overridable Function GetTerm As Term
Visual C++
public:
virtual Term^ GetTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermQuery.GetTerm"]

See Also

TermQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
TermQuery..::..ToString Method
TermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides Query..::..ToString(String).)

See Also

TermQuery Class
TermQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
TermQuery..::..ToString Method (String)
TermQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.TermQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermQuery.ToString(System.String)"]

See Also

TermQuery Class
ToString Overload
Lucene.Net.Search Namespace


TermRangeFilter Class

[image]

Lucene.Net Class Libraries
TermRangeFilter Class
Members See Also Send Feedback
A Filter that restricts search results to a range of values in a given field.

This filter matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeFilter} instead.

If you construct a large number of range filters with different ranges but on the same field, {@link FieldCacheRangeFilter} may have significantly better performance.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TermRangeFilter : MultiTermQueryWrapperFilter
Visual Basic
<SerializableAttribute> _
Public Class TermRangeFilter _
    Inherits MultiTermQueryWrapperFilter
Visual C++
[SerializableAttribute]
public ref class TermRangeFilter : public MultiTermQueryWrapperFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..MultiTermQueryWrapperFilter
Lucene.Net.Search..::..TermRangeFilter

See Also

TermRangeFilter Members
Lucene.Net.Search Namespace


TermRangeFilter Members

[image] [image]

Lucene.Net Class Libraries
TermRangeFilter Members
TermRangeFilter Class Constructors Methods Fields See Also Send Feedback

The TermRangeFilter type exposes the following members.

Constructors

Name Description
Public method TermRangeFilter(String, String, String, Boolean, Boolean)
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)
Public method TermRangeFilter(String, String, String, Boolean, Boolean, CompareInfo)
WARNING: Using this constructor and supplying a non-null value in the
CopyC#
collator
 parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Methods

Name | Description
Public method Bits Obsolete.
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
(Inherited from MultiTermQueryWrapperFilter.)
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the filter.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
Public method GetDocIdSet
Returns a DocIdSet with documents that should be permitted in search results.
(Inherited from MultiTermQueryWrapperFilter.)
Public method GetField
Returns the field name for this filter
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method GetLowerTerm
Returns the lower value of this range filter
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

(Inherited from MultiTermQueryWrapperFilter.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper value of this range filter
Public method IncludesLower
Returns
CopyC#
true
 if the lower endpoint is inclusive
Public method IncludesUpper
Returns
CopyC#
true
 if the upper endpoint is inclusive
Less
Constructs a filter for field
CopyC#
fieldName
 matching less than or equal to
CopyC#
upperTerm
.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
More
Constructs a filter for field
CopyC#
fieldName
 matching greater than or equal to
CopyC#
lowerTerm
.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter.)

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


TermRangeFilter Constructor

[image] [image]

Lucene.Net Class Libraries
TermRangeFilter Constructor
TermRangeFilter Class See Also Send Feedback

Overload List

Name Description
Public method TermRangeFilter(String, String, String, Boolean, Boolean)
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)
Public method TermRangeFilter(String, String, String, Boolean, Boolean, CompareInfo)
WARNING: Using this constructor and supplying a non-null value in the
CopyC#
collator
 parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

See Also

TermRangeFilter Class
TermRangeFilter Members
Lucene.Net.Search Namespace


TermRangeFilter Constructor (String, String, String, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
TermRangeFilter Constructor (String, String, String, Boolean, Boolean)
TermRangeFilter Class See Also Send Feedback
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermRangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Visual C++
public:
TermRangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)

Parameters

fieldName
Type: System..::..String
The field this range applies to
lowerTerm
Type: System..::..String
The lower bound on this range
upperTerm
Type: System..::..String
The upper bound on this range
includeLower
Type: System..::..Boolean
Does this range include the lower bound?
includeUpper
Type: System..::..Boolean
Does this range include the upper bound?

See Also

TermRangeFilter Class
TermRangeFilter Overload
Lucene.Net.Search Namespace


TermRangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo)

[image]

Lucene.Net Class Libraries
TermRangeFilter Constructor (String, String, String, Boolean, Boolean, CompareInfo)
TermRangeFilter Class See Also Send Feedback
WARNING: Using this constructor and supplying a non-null value in the
CopyC#
collator
 parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.
lowerTerm is null and includeLower is true (similar for upperTerm and includeUpper)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermRangeFilter(
    string fieldName,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Visual C++
public:
TermRangeFilter(
    String^ fieldName,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.TermRangeFilter.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

lowerTerm
Type: System..::..String
The lower bound on this range
upperTerm
Type: System..::..String
The upper bound on this range
includeLower
Type: System..::..Boolean
Does this range include the lower bound?
includeUpper
Type: System..::..Boolean
Does this range include the upper bound?
collator
Type: System.Globalization..::..CompareInfo
The collator to use when determining range inclusion; set to null to use Unicode code point ordering instead of collation.

See Also

TermRangeFilter Class
TermRangeFilter Overload
Lucene.Net.Search Namespace


TermRangeFilter Fields

[image] [image]

Lucene.Net Class Libraries
TermRangeFilter Fields
TermRangeFilter Class See Also Send Feedback

The TermRangeFilter type exposes the following members.

Fields

 | Name | Description
Protected field | query | (Inherited from MultiTermQueryWrapperFilter.)

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


TermRangeFilter Methods

[image] [image]

Lucene.Net Class Libraries
TermRangeFilter Methods
TermRangeFilter Class See Also Send Feedback

The TermRangeFilter type exposes the following members.

Methods

Name | Description
Public method Bits Obsolete.
Returns a BitSet with true for documents which should be permitted in search results, and false for those that should not.
(Inherited from MultiTermQueryWrapperFilter.)
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the filter.
(Inherited from MultiTermQueryWrapperFilter.)
Public method | Equals | (Inherited from MultiTermQueryWrapperFilter.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
Public method GetDocIdSet
Returns a DocIdSet with documents that should be permitted in search results.
(Inherited from MultiTermQueryWrapperFilter.)
Public method GetField
Returns the field name for this filter
Public method | GetHashCode | (Inherited from MultiTermQueryWrapperFilter.)
Public method GetLowerTerm
Returns the lower value of this range filter
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the filter. If there are many of them, you may consider using another filter type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no filter is running! If you re-use the same filter instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

(Inherited from MultiTermQueryWrapperFilter.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper value of this range filter
Public method IncludesLower
Returns
CopyC#
true
 if the lower endpoint is inclusive
Public method IncludesUpper
Returns
CopyC#
true
 if the upper endpoint is inclusive
Less
Constructs a filter for field
CopyC#
fieldName
 matching less than or equal to
CopyC#
upperTerm
.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
More
Constructs a filter for field
CopyC#
fieldName
 matching greater than or equal to
CopyC#
lowerTerm
.
Public method | ToString | (Inherited from MultiTermQueryWrapperFilter.)

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


GetCollator Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..GetCollator Method
TermRangeFilter Class See Also Send Feedback
Returns the collator used to determine range inclusion, if any.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CompareInfo GetCollator()
Visual Basic
Public Overridable Function GetCollator As CompareInfo
Visual C++
public:
virtual CompareInfo^ GetCollator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.GetCollator"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..GetField Method
TermRangeFilter Class See Also Send Feedback
Returns the field name for this filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.GetField"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


GetLowerTerm Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..GetLowerTerm Method
TermRangeFilter Class See Also Send Feedback
Returns the lower value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLowerTerm()
Visual Basic
Public Overridable Function GetLowerTerm As String
Visual C++
public:
virtual String^ GetLowerTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.GetLowerTerm"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


GetUpperTerm Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..GetUpperTerm Method
TermRangeFilter Class See Also Send Feedback
Returns the upper value of this range filter

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetUpperTerm()
Visual Basic
Public Overridable Function GetUpperTerm As String
Visual C++
public:
virtual String^ GetUpperTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.GetUpperTerm"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


IncludesLower Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..IncludesLower Method
TermRangeFilter Class See Also Send Feedback
Returns
CopyC#
true
 if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IncludesLower()
Visual Basic
Public Overridable Function IncludesLower As Boolean
Visual C++
public:
virtual bool IncludesLower()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.IncludesLower"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


IncludesUpper Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..IncludesUpper Method
TermRangeFilter Class See Also Send Feedback
Returns
CopyC#
true
 if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IncludesUpper()
Visual Basic
Public Overridable Function IncludesUpper As Boolean
Visual C++
public:
virtual bool IncludesUpper()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.IncludesUpper"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


Less Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..Less Method
TermRangeFilter Class See Also Send Feedback
Constructs a filter for field
CopyC#
fieldName
 matching less than or equal to
CopyC#
upperTerm
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static TermRangeFilter Less(
    string fieldName,
    string upperTerm
)
Visual Basic
Public Shared Function Less ( _
    fieldName As String, _
    upperTerm As String _
) As TermRangeFilter
Visual C++
public:
static TermRangeFilter^ Less(
    String^ fieldName,
    String^ upperTerm
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.TermRangeFilter.Less(System.String,System.String)"]

upperTerm
Type: System..::..String

[Missing <param name="upperTerm"/> documentation for "M:Lucene.Net.Search.TermRangeFilter.Less(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.Less(System.String,System.String)"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


More Method

[image]

Lucene.Net Class Libraries
TermRangeFilter..::..More Method
TermRangeFilter Class See Also Send Feedback
Constructs a filter for field
CopyC#
fieldName
 matching greater than or equal to
CopyC#
lowerTerm
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static TermRangeFilter More(
    string fieldName,
    string lowerTerm
)
Visual Basic
Public Shared Function More ( _
    fieldName As String, _
    lowerTerm As String _
) As TermRangeFilter
Visual C++
public:
static TermRangeFilter^ More(
    String^ fieldName,
    String^ lowerTerm
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.TermRangeFilter.More(System.String,System.String)"]

lowerTerm
Type: System..::..String

[Missing <param name="lowerTerm"/> documentation for "M:Lucene.Net.Search.TermRangeFilter.More(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeFilter.More(System.String,System.String)"]

See Also

TermRangeFilter Class
Lucene.Net.Search Namespace


TermRangeQuery Class

[image]

Lucene.Net Class Libraries
TermRangeQuery Class
Members See Also Send Feedback
A Query that matches documents within an exclusive range of terms.

This query matches the documents looking for terms that fall into the supplied range according to {@link String#compareTo(String)}. It is not intended for numerical ranges, use {@link NumericRangeQuery} instead.

This query uses the {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} rewrite method.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TermRangeQuery : MultiTermQuery
Visual Basic
<SerializableAttribute> _
Public Class TermRangeQuery _
    Inherits MultiTermQuery
Visual C++
[SerializableAttribute]
public ref class TermRangeQuery : public MultiTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..TermRangeQuery
Lucene.Net.Search..::..ConstantScoreRangeQuery

See Also

TermRangeQuery Members
Lucene.Net.Search Namespace


TermRangeQuery Members

[image] [image]

Lucene.Net Class Libraries
TermRangeQuery Members
TermRangeQuery Class Constructors Methods Fields See Also Send Feedback

The TermRangeQuery type exposes the following members.

Constructors

Name Description
Public method TermRangeQuery(String, String, String, Boolean, Boolean)
Constructs a query selecting all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Public method TermRangeQuery(String, String, String, Boolean, Boolean, CompareInfo)
Constructs a query selecting all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

If

CopyC#
collator
is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the

CopyC#
collator
parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method GetField
Returns the field name for this query
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetLowerTerm
Returns the lower value of this range query
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper value of this range query
Public method IncludesLower
Returns
CopyC#
true
 if the lower endpoint is inclusive
Public method IncludesUpper
Returns
CopyC#
true
 if the upper endpoint is inclusive
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


TermRangeQuery Constructor

[image] [image]

Lucene.Net Class Libraries
TermRangeQuery Constructor
TermRangeQuery Class See Also Send Feedback

Overload List

Name Description
Public method TermRangeQuery(String, String, String, Boolean, Boolean)
Constructs a query selecting all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Public method TermRangeQuery(String, String, String, Boolean, Boolean, CompareInfo)
Constructs a query selecting all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

If

CopyC#
collator
is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the

CopyC#
collator
parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

See Also

TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace


TermRangeQuery Constructor (String, String, String, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
TermRangeQuery Constructor (String, String, String, Boolean, Boolean)
TermRangeQuery Class See Also Send Feedback
Constructs a query selecting all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermRangeQuery(
    string field,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper
)
Visual Basic
Public Sub New ( _
    field As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean _
)
Visual C++
public:
TermRangeQuery(
    String^ field,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper
)

Parameters

field
Type: System..::..String
The field that holds both lower and upper terms.
lowerTerm
Type: System..::..String
The term text at the lower end of the range
upperTerm
Type: System..::..String
The term text at the upper end of the range
includeLower
Type: System..::..Boolean
If true, the
CopyC#
lowerTerm
 is included in the range.
includeUpper
Type: System..::..Boolean
If true, the
CopyC#
upperTerm
 is included in the range.

See Also

TermRangeQuery Class
TermRangeQuery Overload
Lucene.Net.Search Namespace


TermRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo)

[image]

Lucene.Net Class Libraries
TermRangeQuery Constructor (String, String, String, Boolean, Boolean, CompareInfo)
TermRangeQuery Class See Also Send Feedback
Constructs a query selecting all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
.

If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

If

CopyC#
collator
is not null, it will be used to decide whether index terms are within the given range, rather than using the Unicode code point order in which index terms are stored.

WARNING: Using this constructor and supplying a non-null value in the

CopyC#
collator
parameter will cause every single index Term in the Field referenced by lowerTerm and/or upperTerm to be examined. Depending on the number of index Terms in this Field, the operation could be very slow.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermRangeQuery(
    string field,
    string lowerTerm,
    string upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Visual Basic
Public Sub New ( _
    field As String, _
    lowerTerm As String, _
    upperTerm As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Visual C++
public:
TermRangeQuery(
    String^ field,
    String^ lowerTerm,
    String^ upperTerm,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.TermRangeQuery.#ctor(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

lowerTerm
Type: System..::..String
The Term text at the lower end of the range
upperTerm
Type: System..::..String
The Term text at the upper end of the range
includeLower
Type: System..::..Boolean
If true, the
CopyC#
lowerTerm
 is included in the range.
includeUpper
Type: System..::..Boolean
If true, the
CopyC#
upperTerm
 is included in the range.
collator
Type: System.Globalization..::..CompareInfo
The collator to use to collate index Terms, to determine their membership in the range bounded by
CopyC#
lowerTerm
 and
CopyC#
upperTerm
.

See Also

TermRangeQuery Class
TermRangeQuery Overload
Lucene.Net.Search Namespace


TermRangeQuery Fields

[image] [image]

Lucene.Net Class Libraries
TermRangeQuery Fields
TermRangeQuery Class See Also Send Feedback

The TermRangeQuery type exposes the following members.

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


TermRangeQuery Methods

[image] [image]

Lucene.Net Class Libraries
TermRangeQuery Methods
TermRangeQuery Class See Also Send Feedback

The TermRangeQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetCollator
Returns the collator used to determine range inclusion, if any.
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method GetField
Returns the field name for this query
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method GetLowerTerm
Returns the lower value of this range query
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUpperTerm
Returns the upper value of this range query
Public method IncludesLower
Returns
CopyC#
true
 if the lower endpoint is inclusive
Public method IncludesUpper
Returns
CopyC#
true
 if the upper endpoint is inclusive
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..Equals Method
TermRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermRangeQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.TermRangeQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.Equals(System.Object)"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


GetCollator Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..GetCollator Method
TermRangeQuery Class See Also Send Feedback
Returns the collator used to determine range inclusion, if any.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual CompareInfo GetCollator()
Visual Basic
Public Overridable Function GetCollator As CompareInfo
Visual C++
public:
virtual CompareInfo^ GetCollator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetCollator"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..GetEnum Method
TermRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


GetField Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..GetField Method
TermRangeQuery Class See Also Send Feedback
Returns the field name for this query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetField()
Visual Basic
Public Overridable Function GetField As String
Visual C++
public:
virtual String^ GetField()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetField"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..GetHashCode Method
TermRangeQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetHashCode"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


GetLowerTerm Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..GetLowerTerm Method
TermRangeQuery Class See Also Send Feedback
Returns the lower value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLowerTerm()
Visual Basic
Public Overridable Function GetLowerTerm As String
Visual C++
public:
virtual String^ GetLowerTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetLowerTerm"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


GetUpperTerm Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..GetUpperTerm Method
TermRangeQuery Class See Also Send Feedback
Returns the upper value of this range query

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetUpperTerm()
Visual Basic
Public Overridable Function GetUpperTerm As String
Visual C++
public:
virtual String^ GetUpperTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.GetUpperTerm"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


IncludesLower Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..IncludesLower Method
TermRangeQuery Class See Also Send Feedback
Returns
CopyC#
true
 if the lower endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IncludesLower()
Visual Basic
Public Overridable Function IncludesLower As Boolean
Visual C++
public:
virtual bool IncludesLower()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.IncludesLower"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


IncludesUpper Method

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..IncludesUpper Method
TermRangeQuery Class See Also Send Feedback
Returns
CopyC#
true
 if the upper endpoint is inclusive

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IncludesUpper()
Visual Basic
Public Overridable Function IncludesUpper As Boolean
Visual C++
public:
virtual bool IncludesUpper()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.IncludesUpper"]

See Also

TermRangeQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
TermRangeQuery..::..ToString Method
TermRangeQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides MultiTermQuery..::..ToString(String).)

See Also

TermRangeQuery Class
TermRangeQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
TermRangeQuery..::..ToString Method (String)
TermRangeQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.TermRangeQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeQuery.ToString(System.String)"]

See Also

TermRangeQuery Class
ToString Overload
Lucene.Net.Search Namespace


TermRangeTermEnum Class

[image]

Lucene.Net Class Libraries
TermRangeTermEnum Class
Members See Also Send Feedback
Subclass of FilteredTermEnum for enumerating all terms that match the specified range parameters.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TermRangeTermEnum : FilteredTermEnum
Visual Basic
Public Class TermRangeTermEnum _
    Inherits FilteredTermEnum
Visual C++
public ref class TermRangeTermEnum : public FilteredTermEnum

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Search..::..FilteredTermEnum
Lucene.Net.Search..::..TermRangeTermEnum

See Also

TermRangeTermEnum Members
Lucene.Net.Search Namespace


TermRangeTermEnum Members

[image] [image]

Lucene.Net Class Libraries
TermRangeTermEnum Members
TermRangeTermEnum Class Constructors Methods Fields See Also Send Feedback

The TermRangeTermEnum type exposes the following members.

Constructors

Name Description
Public method TermRangeTermEnum
Enumerates all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Methods

Name | Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | TermCompare | (Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


TermRangeTermEnum Constructor

[image]

Lucene.Net Class Libraries
TermRangeTermEnum Constructor
TermRangeTermEnum Class See Also Send Feedback
Enumerates all terms greater/equal than
CopyC#
lowerTerm
 but less/equal than
CopyC#
upperTerm
. If an endpoint is null, it is said to be "open". Either or both endpoints may be open. Open endpoints may not be exclusive (you can't select all but the first or last term without explicitly specifying the term to exclude.)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermRangeTermEnum(
    IndexReader reader,
    string field,
    string lowerTermText,
    string upperTermText,
    bool includeLower,
    bool includeUpper,
    CompareInfo collator
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    field As String, _
    lowerTermText As String, _
    upperTermText As String, _
    includeLower As Boolean, _
    includeUpper As Boolean, _
    collator As CompareInfo _
)
Visual C++
public:
TermRangeTermEnum(
    IndexReader^ reader,
    String^ field,
    String^ lowerTermText,
    String^ upperTermText,
    bool includeLower,
    bool includeUpper,
    CompareInfo^ collator
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.#ctor(Lucene.Net.Index.IndexReader,System.String,System.String,System.String,System.Boolean,System.Boolean,System.Globalization.CompareInfo)"]

field
Type: System..::..String
An interned field that holds both lower and upper terms.
lowerTermText
Type: System..::..String
The term text at the lower end of the range
upperTermText
Type: System..::..String
The term text at the upper end of the range
includeLower
Type: System..::..Boolean
If true, the
CopyC#
lowerTerm
 is included in the range.
includeUpper
Type: System..::..Boolean
If true, the
CopyC#
upperTerm
 is included in the range.
collator
Type: System.Globalization..::..CompareInfo
The collator to use to collate index Terms, to determine their membership in the range bounded by
CopyC#
lowerTerm
 and
CopyC#
upperTerm
.

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


TermRangeTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
TermRangeTermEnum Fields
TermRangeTermEnum Class See Also Send Feedback

The TermRangeTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


TermRangeTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
TermRangeTermEnum Methods
TermRangeTermEnum Class See Also Send Feedback

The TermRangeTermEnum type exposes the following members.

Methods

Name | Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | TermCompare | (Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


Difference Method

[image]

Lucene.Net Class Libraries
TermRangeTermEnum..::..Difference Method
TermRangeTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.Difference"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Difference()
Visual Basic
Public Overrides Function Difference As Single
Visual C++
public:
virtual float Difference() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.Difference"]

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


EndEnum Method

[image]

Lucene.Net Class Libraries
TermRangeTermEnum..::..EndEnum Method
TermRangeTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.EndEnum"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool EndEnum()
Visual Basic
Public Overrides Function EndEnum As Boolean
Visual C++
public:
virtual bool EndEnum() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.EndEnum"]

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


TermCompare Method

[image]

Lucene.Net Class Libraries
TermRangeTermEnum..::..TermCompare Method
TermRangeTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool TermCompare(
    Term term
)
Visual Basic
Public Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Visual C++
public:
virtual bool TermCompare(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermRangeTermEnum.TermCompare(Lucene.Net.Index.Term)"]

See Also

TermRangeTermEnum Class
Lucene.Net.Search Namespace


TermScorer Class

[image]

Lucene.Net Class Libraries
TermScorer Class
Members See Also Send Feedback
Expert: A
CopyC#
Scorer
 for documents matching a
CopyC#
Term
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class TermScorer : Scorer
Visual Basic
Public NotInheritable Class TermScorer _
    Inherits Scorer
Visual C++
public ref class TermScorer sealed : public Scorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search..::..TermScorer

See Also

TermScorer Members
Lucene.Net.Search Namespace


TermScorer Members

[image] [image]

Lucene.Net Class Libraries
TermScorer Members
TermScorer Class Constructors Methods See Also Send Feedback

The TermScorer type exposes the following members.

Constructors

Name Description
Public method TermScorer
Construct a
CopyC#
TermScorer
.

Methods

Name | Description
Public method Advance
Advances to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses {@link TermDocs#SkipTo(int)}.
(Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
Returns an explanation of the score for a document.
When this method is used, the {@link #Next()} method and the {@link #Score(HitCollector)} method should not be used.
(Overrides Scorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next Obsolete.
Advances to the next document matching the query.
The iterator over the matching documents is buffered using {@link TermDocs#Read(int[],int[])}.
(Overrides DocIdSetIterator..::..Next()()()().)
Public method NextDoc
Advances to the next document matching the query.
The iterator over the matching documents is buffered using {@link TermDocs#Read(int[],int[])}.
(Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. (Overrides Scorer..::..Score(HitCollector).)
Protected method | Score(HitCollector, Int32) | Obsolete. (Overrides Scorer..::..Score(HitCollector, Int32).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)
Public method SkipTo Obsolete.
Skips to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses {@link TermDocs#SkipTo(int)}.
(Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method ToString
Returns a string representation of this
CopyC#
TermScorer
.
(Overrides Object..::..ToString()()()().)

See Also

TermScorer Class
Lucene.Net.Search Namespace


TermScorer Constructor

[image]

Lucene.Net Class Libraries
TermScorer Constructor
TermScorer Class See Also Send Feedback
Construct a
CopyC#
TermScorer
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermScorer(
    Weight weight,
    TermDocs td,
    Similarity similarity,
    byte[] norms
)
Visual Basic
Public Sub New ( _
    weight As Weight, _
    td As TermDocs, _
    similarity As Similarity, _
    norms As Byte() _
)
Visual C++
public:
TermScorer(
    Weight^ weight,
    TermDocs^ td,
    Similarity^ similarity,
    array<unsigned char>^ norms
)

Parameters

weight
Type: Lucene.Net.Search..::..Weight
The weight of the
CopyC#
Term
 in the query.
td
Type: Lucene.Net.Index..::..TermDocs
An iterator over the documents matching the
CopyC#
Term
.
similarity
Type: Lucene.Net.Search..::..Similarity
The
CopyC#
Similarity
 implementation to be used for score computations.
norms
Type: array< System..::..Byte >[]()[][]
The field norms of the document fields for the
CopyC#
Term
.

See Also

TermScorer Class
Lucene.Net.Search Namespace


TermScorer Methods

[image] [image]

Lucene.Net Class Libraries
TermScorer Methods
TermScorer Class See Also Send Feedback

The TermScorer type exposes the following members.

Methods

Name | Description
Public method Advance
Advances to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses {@link TermDocs#SkipTo(int)}.
(Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
Returns an explanation of the score for a document.
When this method is used, the {@link #Next()} method and the {@link #Score(HitCollector)} method should not be used.
(Overrides Scorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next Obsolete.
Advances to the next document matching the query.
The iterator over the matching documents is buffered using {@link TermDocs#Read(int[],int[])}.
(Overrides DocIdSetIterator..::..Next()()()().)
Public method NextDoc
Advances to the next document matching the query.
The iterator over the matching documents is buffered using {@link TermDocs#Read(int[],int[])}.
(Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. (Overrides Scorer..::..Score(HitCollector).)
Protected method | Score(HitCollector, Int32) | Obsolete. (Overrides Scorer..::..Score(HitCollector, Int32).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)
Public method SkipTo Obsolete.
Skips to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses {@link TermDocs#SkipTo(int)}.
(Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method ToString
Returns a string representation of this
CopyC#
TermScorer
.
(Overrides Object..::..ToString()()()().)

See Also

TermScorer Class
Lucene.Net.Search Namespace


Advance Method

[image]

Lucene.Net Class Libraries
TermScorer..::..Advance Method
TermScorer Class See Also Send Feedback
Advances to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses {@link TermDocs#SkipTo(int)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32
The target document number.

Return Value

the matching document or -1 if none exist.

See Also

TermScorer Class
Lucene.Net.Search Namespace


Doc Method

[image]

Lucene.Net Class Libraries
TermScorer..::..Doc Method
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.Doc"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead. ")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead. ")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead. ")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.Doc"]

See Also

TermScorer Class
Lucene.Net.Search Namespace


DocID Method

[image]

Lucene.Net Class Libraries
TermScorer..::..DocID Method
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.DocID"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.DocID"]

See Also

TermScorer Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
TermScorer..::..Explain Method
TermScorer Class See Also Send Feedback
Returns an explanation of the score for a document.
When this method is used, the {@link #Next()} method and the {@link #Score(HitCollector)} method should not be used.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32
The document number for the explanation.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.Explain(System.Int32)"]

See Also

TermScorer Class
Lucene.Net.Search Namespace


Next Method

[image]

Lucene.Net Class Libraries
TermScorer..::..Next Method
TermScorer Class See Also Send Feedback
Advances to the next document matching the query.
The iterator over the matching documents is buffered using {@link TermDocs#Read(int[],int[])}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

true iff there is another document matching the query.

See Also

TermScorer Class
Lucene.Net.Search Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
TermScorer..::..NextDoc Method
TermScorer Class See Also Send Feedback
Advances to the next document matching the query.
The iterator over the matching documents is buffered using {@link TermDocs#Read(int[],int[])}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

the document matching the query or -1 if there are no more documents.

See Also

TermScorer Class
Lucene.Net.Search Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
TermScorer..::..Score Method
TermScorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method | Score(Collector) | (Overrides Scorer..::..Score(Collector).)
Public method | Score(HitCollector) | Obsolete. (Overrides Scorer..::..Score(HitCollector).)
Protected method | Score(HitCollector, Int32) | Obsolete. (Overrides Scorer..::..Score(HitCollector, Int32).)
Public method | Score(Collector, Int32, Int32) | (Overrides Scorer..::..Score(Collector, Int32, Int32).)

See Also

TermScorer Class
TermScorer Members
Lucene.Net.Search Namespace


Score Method

[image]

Lucene.Net Class Libraries
TermScorer..::..Score Method
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.Score"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.Score"]

See Also

TermScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector)

[image]

Lucene.Net Class Libraries
TermScorer..::..Score Method (Collector)
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Score(
    Collector c
)
Visual Basic
Public Overrides Sub Score ( _
    c As Collector _
)
Visual C++
public:
virtual void Score(
    Collector^ c
) override

Parameters

c
Type: Lucene.Net.Search..::..Collector

[Missing <param name="c"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector)"]

See Also

TermScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (HitCollector)

[image]

Lucene.Net Class Libraries
TermScorer..::..Score Method (HitCollector)
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.HitCollector)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Score(Collector) instead. ")]
public override void Score(
    HitCollector hc
)
Visual Basic
<ObsoleteAttribute("use Score(Collector) instead. ")> _
Public Overrides Sub Score ( _
    hc As HitCollector _
)
Visual C++
[ObsoleteAttribute(L"use Score(Collector) instead. ")]
public:
virtual void Score(
    HitCollector^ hc
) override

Parameters

hc
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="hc"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.HitCollector)"]

See Also

TermScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (HitCollector, Int32)

[image]

Lucene.Net Class Libraries
TermScorer..::..Score Method (HitCollector, Int32)
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Score(Collector, int, int) instead.")]
protected internal override bool Score(
    HitCollector c,
    int end
)
Visual Basic
<ObsoleteAttribute("use Score(Collector, int, int) instead.")> _
Protected Friend Overrides Function Score ( _
    c As HitCollector, _
    end As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Score(Collector, int, int) instead.")]
protected public:
virtual bool Score(
    HitCollector^ c,
    int end
) override

Parameters

c
Type: Lucene.Net.Search..::..HitCollector

[Missing <param name="c"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.HitCollector,System.Int32)"]

See Also

TermScorer Class
Score Overload
Lucene.Net.Search Namespace


Score Method (Collector, Int32, Int32)

[image]

Lucene.Net Class Libraries
TermScorer..::..Score Method (Collector, Int32, Int32)
TermScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Score(
    Collector c,
    int end,
    int firstDocID
)
Visual Basic
Public Overrides Function Score ( _
    c As Collector, _
    end As Integer, _
    firstDocID As Integer _
) As Boolean
Visual C++
public:
virtual bool Score(
    Collector^ c,
    int end,
    int firstDocID
) override

Parameters

c
Type: Lucene.Net.Search..::..Collector

[Missing <param name="c"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

firstDocID
Type: System..::..Int32

[Missing <param name="firstDocID"/> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.Score(Lucene.Net.Search.Collector,System.Int32,System.Int32)"]

See Also

TermScorer Class
Score Overload
Lucene.Net.Search Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
TermScorer..::..SkipTo Method
TermScorer Class See Also Send Feedback
Skips to the first match beyond the current whose document number is greater than or equal to a given target.
The implementation uses {@link TermDocs#SkipTo(int)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead.")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead.")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead.")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32
The target document number.

Return Value

true iff there is such a match.

See Also

TermScorer Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TermScorer..::..ToString Method
TermScorer Class See Also Send Feedback
Returns a string representation of this
CopyC#
TermScorer
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermScorer.ToString"]

See Also

TermScorer Class
Lucene.Net.Search Namespace


TermsFilter Class

[image]

Lucene.Net Class Libraries
TermsFilter Class
Members See Also Send Feedback
A filter that contains multiple terms.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class TermsFilter : Filter
Visual Basic
Public Class TermsFilter _
    Inherits Filter
Visual C++
public ref class TermsFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Search..::..TermsFilter

See Also

TermsFilter Members
Lucene.Net.Search Namespace


TermsFilter Members

[image] [image]

Lucene.Net Class Libraries
TermsFilter Members
TermsFilter Class Constructors Methods Fields See Also Send Feedback

The TermsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | TermsFilter | Initializes a new instance of the TermsFilter class

Methods

 | Name | Description
Public method | AddTerm | Add a term to the set.
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Get the DocIdSet. (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | terms | The set of terms for this filter.

See Also

TermsFilter Class
Lucene.Net.Search Namespace


TermsFilter Constructor

[image]

Lucene.Net Class Libraries
TermsFilter Constructor
TermsFilter Class See Also Send Feedback
Initializes a new instance of the TermsFilter class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermsFilter()
Visual Basic
Public Sub New
Visual C++
public:
TermsFilter()

See Also

TermsFilter Class
Lucene.Net.Search Namespace


TermsFilter Fields

[image] [image]

Lucene.Net Class Libraries
TermsFilter Fields
TermsFilter Class See Also Send Feedback

The TermsFilter type exposes the following members.

Fields

 | Name | Description
Protected field | terms | The set of terms for this filter.

See Also

TermsFilter Class
Lucene.Net.Search Namespace


terms Field

[image]

Lucene.Net Class Libraries
TermsFilter..::..terms Field
TermsFilter Class See Also Send Feedback
The set of terms for this filter.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected HashSet<Term> terms
Visual Basic
Protected terms As HashSet(Of Term)
Visual C++
protected:
HashSet<Term^>^ terms

See Also

TermsFilter Class
Lucene.Net.Search Namespace


TermsFilter Methods

[image] [image]

Lucene.Net Class Libraries
TermsFilter Methods
TermsFilter Class See Also Send Feedback

The TermsFilter type exposes the following members.

Methods

 | Name | Description
Public method | AddTerm | Add a term to the set.
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | Get the DocIdSet. (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TermsFilter Class
Lucene.Net.Search Namespace


AddTerm Method

[image]

Lucene.Net Class Libraries
TermsFilter..::..AddTerm Method
TermsFilter Class See Also Send Feedback
Add a term to the set.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void AddTerm(
    Term term
)
Visual Basic
Public Sub AddTerm ( _
    term As Term _
)
Visual C++
public:
void AddTerm(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term
The term to add.

See Also

TermsFilter Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
TermsFilter..::..Equals Method
TermsFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermsFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.TermsFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermsFilter.Equals(System.Object)"]

See Also

TermsFilter Class
Lucene.Net.Search Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
TermsFilter..::..GetDocIdSet Method
TermsFilter Class See Also Send Feedback
Get the DocIdSet.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
Applcible reader.

Return Value

The set.

See Also

TermsFilter Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
TermsFilter..::..GetHashCode Method
TermsFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermsFilter.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermsFilter.GetHashCode"]

See Also

TermsFilter Class
Lucene.Net.Search Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TermsFilter..::..ToString Method
TermsFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TermsFilter.ToString"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TermsFilter.ToString"]

See Also

TermsFilter Class
Lucene.Net.Search Namespace


TimeLimitedCollector Class

[image]

Lucene.Net Class Libraries
TimeLimitedCollector Class
Members See Also Send Feedback

The TimeLimitedCollector is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a TimeExceeded Exception.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use TimeLimitingCollector instead, which extends the new Collector. This class will be removed in 3.0.")]
public class TimeLimitedCollector : HitCollector
Visual Basic
<ObsoleteAttribute("Use TimeLimitingCollector instead, which extends the new Collector. This class will be removed in 3.0.")> _
Public Class TimeLimitedCollector _
    Inherits HitCollector
Visual C++
[ObsoleteAttribute(L"Use TimeLimitingCollector instead, which extends the new Collector. This class will be removed in 3.0.")]
public ref class TimeLimitedCollector : public HitCollector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..HitCollector
Lucene.Net.Search..::..TimeLimitedCollector

See Also

TimeLimitedCollector Members
Lucene.Net.Search Namespace


TimeLimitedCollector Members

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector Members
TimeLimitedCollector Class Constructors Methods Fields See Also Send Feedback

The TimeLimitedCollector type exposes the following members.

Constructors

 | Name | Description
Public method | TimeLimitedCollector | Create a TimeLimitedCollector wrapper over another HitCollector with a specified timeout.

Methods

Name Description
Public method Collect
Calls collect() on the decorated HitCollector.
(Overrides HitCollector..::..Collect(Int32, Single).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetResolution
Return the timer resolution.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsGreedy
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a {@link TimeExceededException} without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a {@link TimeExceededException}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetGreedy
Sets whether this time limited collector is greedy.
SetResolution
Set the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Public field | DEFAULT_GREEDY | Default for {@link #IsGreedy()}.
 | DEFAULT_RESOLUTION | Default timer resolution.

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace


TimeLimitedCollector Constructor

[image]

Lucene.Net Class Libraries
TimeLimitedCollector Constructor
TimeLimitedCollector Class See Also Send Feedback
Create a TimeLimitedCollector wrapper over another HitCollector with a specified timeout.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TimeLimitedCollector(
    HitCollector hc,
    long timeAllowed
)
Visual Basic
Public Sub New ( _
    hc As HitCollector, _
    timeAllowed As Long _
)
Visual C++
public:
TimeLimitedCollector(
    HitCollector^ hc,
    long long timeAllowed
)

Parameters

hc
Type: Lucene.Net.Search..::..HitCollector
the wrapped HitCollector
timeAllowed
Type: System..::..Int64
max time allowed for collecting hits after which {@link TimeExceededException} is thrown

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace


TimeLimitedCollector Fields

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector Fields
TimeLimitedCollector Class See Also Send Feedback

The TimeLimitedCollector type exposes the following members.

Fields

 | Name | Description
Public field | DEFAULT_GREEDY | Default for {@link #IsGreedy()}.
 | DEFAULT_RESOLUTION | Default timer resolution.

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace


DEFAULT_GREEDY Field

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..DEFAULT_GREEDY Field
TimeLimitedCollector Class See Also Send Feedback
Default for {@link #IsGreedy()}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool DEFAULT_GREEDY
Visual Basic
Public DEFAULT_GREEDY As Boolean
Visual C++
public:
bool DEFAULT_GREEDY

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace
TimeLimitedCollector..::..IsGreedy()()()()


DEFAULT_RESOLUTION Field

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..DEFAULT_RESOLUTION Field
TimeLimitedCollector Class See Also Send Feedback
Default timer resolution.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int DEFAULT_RESOLUTION
Visual Basic
Public Const DEFAULT_RESOLUTION As Integer
Visual C++
public:
literal int DEFAULT_RESOLUTION

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace
[!:SetResolution(long)]


TimeLimitedCollector Methods

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector Methods
TimeLimitedCollector Class See Also Send Feedback

The TimeLimitedCollector type exposes the following members.

Methods

Name Description
Public method Collect
Calls collect() on the decorated HitCollector.
(Overrides HitCollector..::..Collect(Int32, Single).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetResolution
Return the timer resolution.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsGreedy
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a {@link TimeExceededException} without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a {@link TimeExceededException}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetGreedy
Sets whether this time limited collector is greedy.
SetResolution
Set the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..Collect Method
TimeLimitedCollector Class See Also Send Feedback
Calls collect() on the decorated HitCollector.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Collect(
    int doc,
    float score
)
Visual Basic
Public Overrides Sub Collect ( _
    doc As Integer, _
    score As Single _
)
Visual C++
public:
virtual void Collect(
    int doc,
    float score
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.Collect(System.Int32,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.Collect(System.Int32,System.Single)"]

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace


GetResolution Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..GetResolution Method
TimeLimitedCollector Class See Also Send Feedback
Return the timer resolution.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GetResolution()
Visual Basic
Public Shared Function GetResolution As Long
Visual C++
public:
static long long GetResolution()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.GetResolution"]

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace
[!:SetResolution(long)]


IsGreedy Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..IsGreedy Method
TimeLimitedCollector Class See Also Send Feedback
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a {@link TimeExceededException} without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a {@link TimeExceededException}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsGreedy()
Visual Basic
Public Overridable Function IsGreedy As Boolean
Visual C++
public:
virtual bool IsGreedy()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.IsGreedy"]

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace
[!:SetGreedy(boolean)]


SetGreedy Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..SetGreedy Method
TimeLimitedCollector Class See Also Send Feedback
Sets whether this time limited collector is greedy.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetGreedy(
    bool greedy
)
Visual Basic
Public Overridable Sub SetGreedy ( _
    greedy As Boolean _
)
Visual C++
public:
virtual void SetGreedy(
    bool greedy
)

Parameters

greedy
Type: System..::..Boolean
true to make this time limited greedy

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace
TimeLimitedCollector..::..IsGreedy()()()()


SetResolution Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..SetResolution Method
TimeLimitedCollector Class See Also Send Feedback
Set the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetResolution(
    uint newResolution
)
Visual Basic
Public Shared Sub SetResolution ( _
    newResolution As UInteger _
)
Visual C++
public:
static void SetResolution(
    unsigned int newResolution
)

Parameters

newResolution
Type: System..::..UInt32

[Missing <param name="newResolution"/> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.SetResolution(System.UInt32)"]

See Also

TimeLimitedCollector Class
Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Class

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException Class
TimeLimitedCollector Class Members See Also Send Feedback
Thrown when elapsed search time exceeds allowed search time.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TimeExceededException : SystemException
Visual Basic
<SerializableAttribute> _
Public Class TimeExceededException _
    Inherits SystemException
Visual C++
[SerializableAttribute]
public ref class TimeExceededException : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Lucene.Net.Search..::..TimeLimitedCollector..::..TimeExceededException

See Also

TimeLimitedCollector..::..TimeExceededException Members
Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Members

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException Members
TimeLimitedCollector..::..TimeExceededException Class Methods Properties Events See Also Send Feedback

The TimeLimitedCollector is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a TimeExceeded Exception.

The TimeLimitedCollector..::..TimeExceededException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastDocCollected | Returns last doc that was collected when the search time exceeded.
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetTimeAllowed | Returns allowed time (milliseconds).
Public method | GetTimeElapsed | Returns elapsed time (milliseconds).
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Methods

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException Methods
TimeLimitedCollector..::..TimeExceededException Class See Also Send Feedback

The TimeLimitedCollector..::..TimeExceededException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastDocCollected | Returns last doc that was collected when the search time exceeded.
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetTimeAllowed | Returns allowed time (milliseconds).
Public method | GetTimeElapsed | Returns elapsed time (milliseconds).
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


GetLastDocCollected Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException..::..GetLastDocCollected Method
TimeLimitedCollector..::..TimeExceededException Class See Also Send Feedback
Returns last doc that was collected when the search time exceeded.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetLastDocCollected()
Visual Basic
Public Overridable Function GetLastDocCollected As Integer
Visual C++
public:
virtual int GetLastDocCollected()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.TimeExceededException.GetLastDocCollected"]

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


GetTimeAllowed Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException..::..GetTimeAllowed Method
TimeLimitedCollector..::..TimeExceededException Class See Also Send Feedback
Returns allowed time (milliseconds).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetTimeAllowed()
Visual Basic
Public Overridable Function GetTimeAllowed As Long
Visual C++
public:
virtual long long GetTimeAllowed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.TimeExceededException.GetTimeAllowed"]

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


GetTimeElapsed Method

[image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException..::..GetTimeElapsed Method
TimeLimitedCollector..::..TimeExceededException Class See Also Send Feedback
Returns elapsed time (milliseconds).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetTimeElapsed()
Visual Basic
Public Overridable Function GetTimeElapsed As Long
Visual C++
public:
virtual long long GetTimeElapsed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitedCollector.TimeExceededException.GetTimeElapsed"]

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Properties

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException Properties
TimeLimitedCollector..::..TimeExceededException Class See Also Send Feedback

The TimeLimitedCollector..::..TimeExceededException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitedCollector.TimeExceededException Events

[image] [image]

Lucene.Net Class Libraries
TimeLimitedCollector..::..TimeExceededException Events
TimeLimitedCollector..::..TimeExceededException Class See Also Send Feedback

The TimeLimitedCollector..::..TimeExceededException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TimeLimitedCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitingCollector Class

[image]

Lucene.Net Class Libraries
TimeLimitingCollector Class
Members See Also Send Feedback
The {@link TimeLimitingCollector} is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a {@link TimeExceededException}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TimeLimitingCollector : Collector
Visual Basic
Public Class TimeLimitingCollector _
    Inherits Collector
Visual C++
public ref class TimeLimitingCollector : public Collector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..TimeLimitingCollector

See Also

TimeLimitingCollector Members
Lucene.Net.Search Namespace


TimeLimitingCollector Members

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector Members
TimeLimitingCollector Class Constructors Methods Fields See Also Send Feedback

The TimeLimitingCollector type exposes the following members.

Constructors

 | Name | Description
Public method | TimeLimitingCollector | Create a TimeLimitedCollector wrapper over another {@link Collector} with a specified timeout.

Methods

Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method Collect
Calls {@link Collector#Collect(int)} on the decorated {@link Collector} unless the allowed time has passed, in which case it throws an exception.
(Overrides Collector..::..Collect(Int32).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetResolution
Return the timer resolution.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsGreedy
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a {@link TimeExceededException} without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a {@link TimeExceededException}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetGreedy
Sets whether this time limited collector is greedy.
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
SetResolution
Set the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Public field | DEFAULT_GREEDY | Default for {@link #IsGreedy()}.
 | DEFAULT_RESOLUTION | Default timer resolution.

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


TimeLimitingCollector Constructor

[image]

Lucene.Net Class Libraries
TimeLimitingCollector Constructor
TimeLimitingCollector Class See Also Send Feedback
Create a TimeLimitedCollector wrapper over another {@link Collector} with a specified timeout.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TimeLimitingCollector(
    Collector collector,
    long timeAllowed
)
Visual Basic
Public Sub New ( _
    collector As Collector, _
    timeAllowed As Long _
)
Visual C++
public:
TimeLimitingCollector(
    Collector^ collector,
    long long timeAllowed
)

Parameters

collector
Type: Lucene.Net.Search..::..Collector
the wrapped {@link Collector}
timeAllowed
Type: System..::..Int64
max time allowed for collecting hits after which {@link TimeExceededException} is thrown

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


TimeLimitingCollector Fields

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector Fields
TimeLimitingCollector Class See Also Send Feedback

The TimeLimitingCollector type exposes the following members.

Fields

 | Name | Description
Public field | DEFAULT_GREEDY | Default for {@link #IsGreedy()}.
 | DEFAULT_RESOLUTION | Default timer resolution.

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


DEFAULT_GREEDY Field

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..DEFAULT_GREEDY Field
TimeLimitingCollector Class See Also Send Feedback
Default for {@link #IsGreedy()}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool DEFAULT_GREEDY
Visual Basic
Public DEFAULT_GREEDY As Boolean
Visual C++
public:
bool DEFAULT_GREEDY

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace
TimeLimitingCollector..::..IsGreedy()()()()


DEFAULT_RESOLUTION Field

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..DEFAULT_RESOLUTION Field
TimeLimitingCollector Class See Also Send Feedback
Default timer resolution.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const uint DEFAULT_RESOLUTION
Visual Basic
Public Const DEFAULT_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int DEFAULT_RESOLUTION

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace
[!:SetResolution(long)]


TimeLimitingCollector Methods

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector Methods
TimeLimitingCollector Class See Also Send Feedback

The TimeLimitingCollector type exposes the following members.

Methods

Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method Collect
Calls {@link Collector#Collect(int)} on the decorated {@link Collector} unless the allowed time has passed, in which case it throws an exception.
(Overrides Collector..::..Collect(Int32).)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetResolution
Return the timer resolution.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsGreedy
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a {@link TimeExceededException} without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a {@link TimeExceededException}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetGreedy
Sets whether this time limited collector is greedy.
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
SetResolution
Set the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


AcceptsDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..AcceptsDocsOutOfOrder Method
TimeLimitingCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.AcceptsDocsOutOfOrder"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool AcceptsDocsOutOfOrder()
Visual Basic
Public Overrides Function AcceptsDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool AcceptsDocsOutOfOrder() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.AcceptsDocsOutOfOrder"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..Collect Method
TimeLimitingCollector Class See Also Send Feedback
Calls {@link Collector#Collect(int)} on the decorated {@link Collector} unless the allowed time has passed, in which case it throws an exception.
if the time allowed has exceeded.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Collect(
    int doc
)
Visual Basic
Public Overrides Sub Collect ( _
    doc As Integer _
)
Visual C++
public:
virtual void Collect(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.Collect(System.Int32)"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


GetResolution Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..GetResolution Method
TimeLimitingCollector Class See Also Send Feedback
Return the timer resolution.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long GetResolution()
Visual Basic
Public Shared Function GetResolution As Long
Visual C++
public:
static long long GetResolution()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.GetResolution"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace
[!:SetResolution(long)]


IsGreedy Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..IsGreedy Method
TimeLimitingCollector Class See Also Send Feedback
Checks if this time limited collector is greedy in collecting the last hit. A non greedy collector, upon a timeout, would throw a {@link TimeExceededException} without allowing the wrapped collector to collect current doc. A greedy one would first allow the wrapped hit collector to collect current doc and only then throw a {@link TimeExceededException}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsGreedy()
Visual Basic
Public Overridable Function IsGreedy As Boolean
Visual C++
public:
virtual bool IsGreedy()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.IsGreedy"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace
[!:SetGreedy(boolean)]


SetGreedy Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..SetGreedy Method
TimeLimitingCollector Class See Also Send Feedback
Sets whether this time limited collector is greedy.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetGreedy(
    bool greedy
)
Visual Basic
Public Overridable Sub SetGreedy ( _
    greedy As Boolean _
)
Visual C++
public:
virtual void SetGreedy(
    bool greedy
)

Parameters

greedy
Type: System..::..Boolean
true to make this time limited greedy

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace
TimeLimitingCollector..::..IsGreedy()()()()


SetNextReader Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..SetNextReader Method
TimeLimitingCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int base_Renamed
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    base_Renamed As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int base_Renamed
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

base_Renamed
Type: System..::..Int32

[Missing <param name="base_Renamed"/> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


SetResolution Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..SetResolution Method
TimeLimitingCollector Class See Also Send Feedback
Set the timer resolution. The default timer resolution is 20 milliseconds. This means that a search required to take no longer than 800 milliseconds may be stopped after 780 to 820 milliseconds.
Note that:
  • Finer (smaller) resolution is more accurate but less efficient.
  • Setting resolution to less than 5 milliseconds will be silently modified to 5 milliseconds.
  • Setting resolution smaller than current resolution might take effect only after current resolution. (Assume current resolution of 20 milliseconds is modified to 5 milliseconds, then it can take up to 20 milliseconds for the change to have effect.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SetResolution(
    uint newResolution
)
Visual Basic
Public Shared Sub SetResolution ( _
    newResolution As UInteger _
)
Visual C++
public:
static void SetResolution(
    unsigned int newResolution
)

Parameters

newResolution
Type: System..::..UInt32

[Missing <param name="newResolution"/> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.SetResolution(System.UInt32)"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..SetScorer Method
TimeLimitingCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.SetScorer(Lucene.Net.Search.Scorer)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetScorer(
    Scorer scorer
)
Visual Basic
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
) override

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.SetScorer(Lucene.Net.Search.Scorer)"]

See Also

TimeLimitingCollector Class
Lucene.Net.Search Namespace


TimeLimitingCollector.TimeExceededException Class

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException Class
TimeLimitingCollector Class Members See Also Send Feedback
Thrown when elapsed search time exceeds allowed search time.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TimeExceededException : SystemException
Visual Basic
<SerializableAttribute> _
Public Class TimeExceededException _
    Inherits SystemException
Visual C++
[SerializableAttribute]
public ref class TimeExceededException : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Lucene.Net.Search..::..TimeLimitingCollector..::..TimeExceededException

See Also

TimeLimitingCollector..::..TimeExceededException Members
Lucene.Net.Search Namespace


TimeLimitingCollector.TimeExceededException Members

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException Members
TimeLimitingCollector..::..TimeExceededException Class Methods Properties Events See Also Send Feedback

The {@link TimeLimitingCollector} is used to timeout search requests that take longer than the maximum allowed search time limit. After this time is exceeded, the search thread is stopped by throwing a {@link TimeExceededException}.

The TimeLimitingCollector..::..TimeExceededException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastDocCollected | Returns last doc(absolute doc id) that was collected when the search time exceeded.
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetTimeAllowed | Returns allowed time (milliseconds).
Public method | GetTimeElapsed | Returns elapsed time (milliseconds).
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitingCollector.TimeExceededException Methods

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException Methods
TimeLimitingCollector..::..TimeExceededException Class See Also Send Feedback

The TimeLimitingCollector..::..TimeExceededException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastDocCollected | Returns last doc(absolute doc id) that was collected when the search time exceeded.
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetTimeAllowed | Returns allowed time (milliseconds).
Public method | GetTimeElapsed | Returns elapsed time (milliseconds).
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


GetLastDocCollected Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException..::..GetLastDocCollected Method
TimeLimitingCollector..::..TimeExceededException Class See Also Send Feedback
Returns last doc(absolute doc id) that was collected when the search time exceeded.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetLastDocCollected()
Visual Basic
Public Overridable Function GetLastDocCollected As Integer
Visual C++
public:
virtual int GetLastDocCollected()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.TimeExceededException.GetLastDocCollected"]

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


GetTimeAllowed Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException..::..GetTimeAllowed Method
TimeLimitingCollector..::..TimeExceededException Class See Also Send Feedback
Returns allowed time (milliseconds).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetTimeAllowed()
Visual Basic
Public Overridable Function GetTimeAllowed As Long
Visual C++
public:
virtual long long GetTimeAllowed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.TimeExceededException.GetTimeAllowed"]

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


GetTimeElapsed Method

[image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException..::..GetTimeElapsed Method
TimeLimitingCollector..::..TimeExceededException Class See Also Send Feedback
Returns elapsed time (milliseconds).

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetTimeElapsed()
Visual Basic
Public Overridable Function GetTimeElapsed As Long
Visual C++
public:
virtual long long GetTimeElapsed()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TimeLimitingCollector.TimeExceededException.GetTimeElapsed"]

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitingCollector.TimeExceededException Properties

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException Properties
TimeLimitingCollector..::..TimeExceededException Class See Also Send Feedback

The TimeLimitingCollector..::..TimeExceededException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TimeLimitingCollector.TimeExceededException Events

[image] [image]

Lucene.Net Class Libraries
TimeLimitingCollector..::..TimeExceededException Events
TimeLimitingCollector..::..TimeExceededException Class See Also Send Feedback

The TimeLimitingCollector..::..TimeExceededException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TimeLimitingCollector..::..TimeExceededException Class
Lucene.Net.Search Namespace


TopDocCollector Class

[image]

Lucene.Net Class Libraries
TopDocCollector Class
Members See Also Send Feedback
A {@link HitCollector} implementation that collects the top-scoring documents, returning them as a {@link TopDocs}. This is used by {@link IndexSearcher} to implement {@link TopDocs}-based search.

This may be extended, overriding the collect method to, e.g., conditionally invoke

CopyC#
super()
in order to filter which documents are collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use TopScoreDocCollector instead, which has better performance.")]
public class TopDocCollector : HitCollector
Visual Basic
<ObsoleteAttribute("Please use TopScoreDocCollector instead, which has better performance.")> _
Public Class TopDocCollector _
    Inherits HitCollector
Visual C++
[ObsoleteAttribute(L"Please use TopScoreDocCollector instead, which has better performance.")]
public ref class TopDocCollector : public HitCollector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..HitCollector
Lucene.Net.Search..::..TopDocCollector
Lucene.Net.Search..::..TopFieldDocCollector

See Also

TopDocCollector Members
Lucene.Net.Search Namespace


TopDocCollector Members

[image] [image]

Lucene.Net Class Libraries
TopDocCollector Members
TopDocCollector Class Constructors Methods Fields See Also Send Feedback

The TopDocCollector type exposes the following members.

Constructors

 | Name | Description
Public method | TopDocCollector(Int32) | Construct to collect a given number of hits.
Protected method | TopDocCollector(PriorityQueue) | Constructor to collect the top-scoring documents by using the given PQ.

Methods

 | Name | Description
Public method | Collect | (Overrides HitCollector..::..Collect(Int32, Single).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTotalHits | The total number of documents that matched this query.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TopDocs | The top-scoring hits.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | hq | The priority queue which holds the top-scoring documents.
Protected field | totalHits | The total number of hits the collector encountered.

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


TopDocCollector Constructor

[image] [image]

Lucene.Net Class Libraries
TopDocCollector Constructor
TopDocCollector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TopDocCollector(Int32) | Construct to collect a given number of hits.
Protected method | TopDocCollector(PriorityQueue) | Constructor to collect the top-scoring documents by using the given PQ.

See Also

TopDocCollector Class
TopDocCollector Members
Lucene.Net.Search Namespace


TopDocCollector Constructor (Int32)

[image]

Lucene.Net Class Libraries
TopDocCollector Constructor (Int32)
TopDocCollector Class See Also Send Feedback
Construct to collect a given number of hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopDocCollector(
    int numHits
)
Visual Basic
Public Sub New ( _
    numHits As Integer _
)
Visual C++
public:
TopDocCollector(
    int numHits
)

Parameters

numHits
Type: System..::..Int32
the maximum number of hits to collect

See Also

TopDocCollector Class
TopDocCollector Overload
Lucene.Net.Search Namespace


TopDocCollector Constructor (PriorityQueue)

[image]

Lucene.Net Class Libraries
TopDocCollector Constructor (PriorityQueue)
TopDocCollector Class See Also Send Feedback
Constructor to collect the top-scoring documents by using the given PQ.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TopDocCollector(
    PriorityQueue hq
)
Visual Basic
Protected Friend Sub New ( _
    hq As PriorityQueue _
)
Visual C++
protected public:
TopDocCollector(
    PriorityQueue^ hq
)

Parameters

hq
Type: Lucene.Net.Util..::..PriorityQueue
the PQ to use by this instance.

See Also

TopDocCollector Class
TopDocCollector Overload
Lucene.Net.Search Namespace


TopDocCollector Fields

[image] [image]

Lucene.Net Class Libraries
TopDocCollector Fields
TopDocCollector Class See Also Send Feedback

The TopDocCollector type exposes the following members.

Fields

 | Name | Description
Protected field | hq | The priority queue which holds the top-scoring documents.
Protected field | totalHits | The total number of hits the collector encountered.

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


hq Field

[image]

Lucene.Net Class Libraries
TopDocCollector..::..hq Field
TopDocCollector Class See Also Send Feedback
The priority queue which holds the top-scoring documents.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal PriorityQueue hq
Visual Basic
Protected Friend hq As PriorityQueue
Visual C++
protected public:
PriorityQueue^ hq

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


totalHits Field

[image]

Lucene.Net Class Libraries
TopDocCollector..::..totalHits Field
TopDocCollector Class See Also Send Feedback
The total number of hits the collector encountered.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int totalHits
Visual Basic
Protected Friend totalHits As Integer
Visual C++
protected public:
int totalHits

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


TopDocCollector Methods

[image] [image]

Lucene.Net Class Libraries
TopDocCollector Methods
TopDocCollector Class See Also Send Feedback

The TopDocCollector type exposes the following members.

Methods

 | Name | Description
Public method | Collect | (Overrides HitCollector..::..Collect(Int32, Single).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTotalHits | The total number of documents that matched this query.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TopDocs | The top-scoring hits.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
TopDocCollector..::..Collect Method
TopDocCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopDocCollector.Collect(System.Int32,System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Collect(
    int doc,
    float score
)
Visual Basic
Public Overrides Sub Collect ( _
    doc As Integer, _
    score As Single _
)
Visual C++
public:
virtual void Collect(
    int doc,
    float score
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.TopDocCollector.Collect(System.Int32,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.TopDocCollector.Collect(System.Int32,System.Single)"]

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


GetTotalHits Method

[image]

Lucene.Net Class Libraries
TopDocCollector..::..GetTotalHits Method
TopDocCollector Class See Also Send Feedback
The total number of documents that matched this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTotalHits()
Visual Basic
Public Overridable Function GetTotalHits As Integer
Visual C++
public:
virtual int GetTotalHits()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocCollector.GetTotalHits"]

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


TopDocs Method

[image]

Lucene.Net Class Libraries
TopDocCollector..::..TopDocs Method
TopDocCollector Class See Also Send Feedback
The top-scoring hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TopDocs TopDocs()
Visual Basic
Public Overridable Function TopDocs As TopDocs
Visual C++
public:
virtual TopDocs^ TopDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocCollector.TopDocs"]

See Also

TopDocCollector Class
Lucene.Net.Search Namespace


TopDocs Class

[image]

Lucene.Net Class Libraries
TopDocs Class
Members See Also Send Feedback
Represents hits returned by {@link * Searcher#search(Query,Filter,int)} and {@link * Searcher#search(Query,int)

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TopDocs
Visual Basic
<SerializableAttribute> _
Public Class TopDocs
Visual C++
[SerializableAttribute]
public ref class TopDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..TopDocs
Lucene.Net.Search..::..TopFieldDocs

See Also

TopDocs Members
Lucene.Net.Search Namespace


TopDocs Members

[image] [image]

Lucene.Net Class Libraries
TopDocs Members
TopDocs Class Constructors Methods Fields Properties See Also Send Feedback

The TopDocs type exposes the following members.

Constructors

 | Name | Description
Public method | TopDocs | Initializes a new instance of the TopDocs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxScore | Returns the maximum score value encountered. Note that in case scores are not tracked, this returns {@link Float#NaN}.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMaxScore | Sets the maximum score value encountered.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | scoreDocs | Obsolete. The top hits for the query.
Public field | totalHits | Obsolete. The total number of hits for the query.

Properties

 | Name | Description
Public property | MaxScore |
Public property | ScoreDocs |
Public property | TotalHits |

See Also

TopDocs Class
Lucene.Net.Search Namespace


TopDocs Constructor

[image]

Lucene.Net Class Libraries
TopDocs Constructor
TopDocs Class See Also Send Feedback
Initializes a new instance of the TopDocs class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopDocs(
    int totalHits,
    ScoreDoc[] scoreDocs,
    float maxScore
)
Visual Basic
Public Sub New ( _
    totalHits As Integer, _
    scoreDocs As ScoreDoc(), _
    maxScore As Single _
)
Visual C++
public:
TopDocs(
    int totalHits,
    array<ScoreDoc^>^ scoreDocs,
    float maxScore
)

Parameters

totalHits
Type: System..::..Int32

[Missing <param name="totalHits"/> documentation for "M:Lucene.Net.Search.TopDocs.#ctor(System.Int32,Lucene.Net.Search.ScoreDoc[],System.Single)"]

scoreDocs
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]

[Missing <param name="scoreDocs"/> documentation for "M:Lucene.Net.Search.TopDocs.#ctor(System.Int32,Lucene.Net.Search.ScoreDoc[],System.Single)"]

maxScore
Type: System..::..Single

[Missing <param name="maxScore"/> documentation for "M:Lucene.Net.Search.TopDocs.#ctor(System.Int32,Lucene.Net.Search.ScoreDoc[],System.Single)"]

See Also

TopDocs Class
Lucene.Net.Search Namespace


TopDocs Fields

[image] [image]

Lucene.Net Class Libraries
TopDocs Fields
TopDocs Class See Also Send Feedback

The TopDocs type exposes the following members.

Fields

 | Name | Description
Public field | scoreDocs | Obsolete. The top hits for the query.
Public field | totalHits | Obsolete. The total number of hits for the query.

See Also

TopDocs Class
Lucene.Net.Search Namespace


scoreDocs Field

[image]

Lucene.Net Class Libraries
TopDocs..::..scoreDocs Field
TopDocs Class See Also Send Feedback
The top hits for the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("For backward compatibility. Use ScoreDocs instead")]
public ScoreDoc[] scoreDocs
Visual Basic
<ObsoleteAttribute("For backward compatibility. Use ScoreDocs instead")> _
Public scoreDocs As ScoreDoc()
Visual C++
[ObsoleteAttribute(L"For backward compatibility. Use ScoreDocs instead")]
public:
array<ScoreDoc^>^ scoreDocs

See Also

TopDocs Class
Lucene.Net.Search Namespace


totalHits Field

[image]

Lucene.Net Class Libraries
TopDocs..::..totalHits Field
TopDocs Class See Also Send Feedback
The total number of hits for the query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("For backward compatibility. Use TotalHits instead")]
public int totalHits
Visual Basic
<ObsoleteAttribute("For backward compatibility. Use TotalHits instead")> _
Public totalHits As Integer
Visual C++
[ObsoleteAttribute(L"For backward compatibility. Use TotalHits instead")]
public:
int totalHits

See Also

TopDocs Class
Lucene.Net.Search Namespace
Hits..::..Length()()()()


TopDocs Methods

[image] [image]

Lucene.Net Class Libraries
TopDocs Methods
TopDocs Class See Also Send Feedback

The TopDocs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxScore | Returns the maximum score value encountered. Note that in case scores are not tracked, this returns {@link Float#NaN}.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMaxScore | Sets the maximum score value encountered.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopDocs Class
Lucene.Net.Search Namespace


GetMaxScore Method

[image]

Lucene.Net Class Libraries
TopDocs..::..GetMaxScore Method
TopDocs Class See Also Send Feedback
Returns the maximum score value encountered. Note that in case scores are not tracked, this returns {@link Float#NaN}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetMaxScore()
Visual Basic
Public Overridable Function GetMaxScore As Single
Visual C++
public:
virtual float GetMaxScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocs.GetMaxScore"]

See Also

TopDocs Class
Lucene.Net.Search Namespace


SetMaxScore Method

[image]

Lucene.Net Class Libraries
TopDocs..::..SetMaxScore Method
TopDocs Class See Also Send Feedback
Sets the maximum score value encountered.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxScore(
    float maxScore
)
Visual Basic
Public Overridable Sub SetMaxScore ( _
    maxScore As Single _
)
Visual C++
public:
virtual void SetMaxScore(
    float maxScore
)

Parameters

maxScore
Type: System..::..Single

[Missing <param name="maxScore"/> documentation for "M:Lucene.Net.Search.TopDocs.SetMaxScore(System.Single)"]

See Also

TopDocs Class
Lucene.Net.Search Namespace


TopDocs Properties

[image] [image]

Lucene.Net Class Libraries
TopDocs Properties
TopDocs Class See Also Send Feedback

The TopDocs type exposes the following members.

Properties

 | Name | Description
Public property | MaxScore |
Public property | ScoreDocs |
Public property | TotalHits |

See Also

TopDocs Class
Lucene.Net.Search Namespace


MaxScore Property

[image]

Lucene.Net Class Libraries
TopDocs..::..MaxScore Property
TopDocs Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.TopDocs.MaxScore"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float MaxScore { get; set; }
Visual Basic
Public Property MaxScore As Single
    Get
    Set
Visual C++
public:
property float MaxScore {
    float get ();
    void set (float value);
}

See Also

TopDocs Class
Lucene.Net.Search Namespace


ScoreDocs Property

[image]

Lucene.Net Class Libraries
TopDocs..::..ScoreDocs Property
TopDocs Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.TopDocs.ScoreDocs"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ScoreDoc[] ScoreDocs { get; set; }
Visual Basic
Public Property ScoreDocs As ScoreDoc()
    Get
    Set
Visual C++
public:
property array<ScoreDoc^>^ ScoreDocs {
    array<ScoreDoc^>^ get ();
    void set (array<ScoreDoc^>^ value);
}

See Also

TopDocs Class
Lucene.Net.Search Namespace


TotalHits Property

[image]

Lucene.Net Class Libraries
TopDocs..::..TotalHits Property
TopDocs Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.TopDocs.TotalHits"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int TotalHits { get; set; }
Visual Basic
Public Property TotalHits As Integer
    Get
    Set
Visual C++
public:
property int TotalHits {
    int get ();
    void set (int value);
}

See Also

TopDocs Class
Lucene.Net.Search Namespace


TopDocsCollector Class

[image]

Lucene.Net Class Libraries
TopDocsCollector Class
Members See Also Send Feedback
A base class for all collectors that return a {@link TopDocs} output. This collector allows easy extension by providing a single constructor which accepts a {@link PriorityQueue} as well as protected members for that priority queue and a counter of the number of total hits.
Extending classes can override {@link #TopDocs(int, int)} and {@link #GetTotalHits()} in order to provide their own implementation.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TopDocsCollector : Collector
Visual Basic
Public MustInherit Class TopDocsCollector _
    Inherits Collector
Visual C++
public ref class TopDocsCollector abstract : public Collector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..TopDocsCollector
Lucene.Net.Search..::..TopFieldCollector
Lucene.Net.Search..::..TopScoreDocCollector

See Also

TopDocsCollector Members
Lucene.Net.Search Namespace


TopDocsCollector Members

[image] [image]

Lucene.Net Class Libraries
TopDocsCollector Members
TopDocsCollector Class Constructors Methods Fields See Also Send Feedback

The TopDocsCollector type exposes the following members.

Constructors

 | Name | Description
Protected method | TopDocsCollector | Initializes a new instance of the TopDocsCollector class

Methods

Name Description
Public method AcceptsDocsOutOfOrder
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *
(Inherited from Collector.)
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

(Inherited from Collector.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTotalHits
The total number of documents that matched this query.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method NewTopDocs
Returns a {@link TopDocs} instance containing the given results. If
CopyC#
results
 is null it means there are no results to return, either because there were 0 calls to collect() or because the arguments to topDocs were invalid.
Protected method PopulateResults
Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.
Public method SetNextReader
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.
(Inherited from Collector.)
Public method SetScorer
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.
(Inherited from Collector.)
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
 | EMPTY_TOPDOCS |
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria.
Protected field | totalHits | The total number of documents that the collector encountered.

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


TopDocsCollector Constructor

[image]

Lucene.Net Class Libraries
TopDocsCollector Constructor
TopDocsCollector Class See Also Send Feedback
Initializes a new instance of the TopDocsCollector class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TopDocsCollector(
    PriorityQueue pq
)
Visual Basic
Protected Friend Sub New ( _
    pq As PriorityQueue _
)
Visual C++
protected public:
TopDocsCollector(
    PriorityQueue^ pq
)

Parameters

pq
Type: Lucene.Net.Util..::..PriorityQueue

[Missing <param name="pq"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.#ctor(Lucene.Net.Util.PriorityQueue)"]

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


TopDocsCollector Fields

[image] [image]

Lucene.Net Class Libraries
TopDocsCollector Fields
TopDocsCollector Class See Also Send Feedback

The TopDocsCollector type exposes the following members.

Fields

 | Name | Description
 | EMPTY_TOPDOCS |
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria.
Protected field | totalHits | The total number of documents that the collector encountered.

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


EMPTY_TOPDOCS Field

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..EMPTY_TOPDOCS Field
TopDocsCollector Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.TopDocsCollector.EMPTY_TOPDOCS"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static readonly TopDocs EMPTY_TOPDOCS
Visual Basic
Protected Friend Shared ReadOnly EMPTY_TOPDOCS As TopDocs
Visual C++
protected public:
static initonly TopDocs^ EMPTY_TOPDOCS

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


pq Field

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..pq Field
TopDocsCollector Class See Also Send Feedback
The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal PriorityQueue pq
Visual Basic
Protected Friend pq As PriorityQueue
Visual C++
protected public:
PriorityQueue^ pq

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


totalHits Field

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..totalHits Field
TopDocsCollector Class See Also Send Feedback
The total number of documents that the collector encountered.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int totalHits
Visual Basic
Protected Friend totalHits As Integer
Visual C++
protected public:
int totalHits

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


TopDocsCollector Methods

[image] [image]

Lucene.Net Class Libraries
TopDocsCollector Methods
TopDocsCollector Class See Also Send Feedback

The TopDocsCollector type exposes the following members.

Methods

Name Description
Public method AcceptsDocsOutOfOrder
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *
(Inherited from Collector.)
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

(Inherited from Collector.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTotalHits
The total number of documents that matched this query.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method NewTopDocs
Returns a {@link TopDocs} instance containing the given results. If
CopyC#
results
 is null it means there are no results to return, either because there were 0 calls to collect() or because the arguments to topDocs were invalid.
Protected method PopulateResults
Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.
Public method SetNextReader
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.
(Inherited from Collector.)
Public method SetScorer
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.
(Inherited from Collector.)
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


GetTotalHits Method

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..GetTotalHits Method
TopDocsCollector Class See Also Send Feedback
The total number of documents that matched this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetTotalHits()
Visual Basic
Public Overridable Function GetTotalHits As Integer
Visual C++
public:
virtual int GetTotalHits()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocsCollector.GetTotalHits"]

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


NewTopDocs Method

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..NewTopDocs Method
TopDocsCollector Class See Also Send Feedback
Returns a {@link TopDocs} instance containing the given results. If
CopyC#
results
 is null it means there are no results to return, either because there were 0 calls to collect() or because the arguments to topDocs were invalid.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
Visual Basic
Public Overridable Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
)

Parameters

results
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocsCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


PopulateResults Method

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..PopulateResults Method
TopDocsCollector Class See Also Send Feedback
Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void PopulateResults(
    ScoreDoc[] results,
    int howMany
)
Visual Basic
Protected Friend Overridable Sub PopulateResults ( _
    results As ScoreDoc(), _
    howMany As Integer _
)
Visual C++
protected public:
virtual void PopulateResults(
    array<ScoreDoc^>^ results,
    int howMany
)

Parameters

results
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.PopulateResults(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

howMany
Type: System..::..Int32

[Missing <param name="howMany"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.PopulateResults(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

See Also

TopDocsCollector Class
Lucene.Net.Search Namespace


TopDocs Method

[image] [image]

Lucene.Net Class Libraries
TopDocsCollector..::..TopDocs Method
TopDocsCollector Class See Also Send Feedback

Overload List

Name Description
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.

See Also

TopDocsCollector Class
TopDocsCollector Members
Lucene.Net.Search Namespace


TopDocs Method

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..TopDocs Method
TopDocsCollector Class See Also Send Feedback
Returns the top docs that were collected by this collector.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopDocs TopDocs()
Visual Basic
Public Function TopDocs As TopDocs
Visual C++
public:
TopDocs^ TopDocs()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocsCollector.TopDocs"]

See Also

TopDocsCollector Class
TopDocs Overload
Lucene.Net.Search Namespace


TopDocs Method (Int32)

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..TopDocs Method (Int32)
TopDocsCollector Class See Also Send Feedback
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopDocs TopDocs(
    int start
)
Visual Basic
Public Function TopDocs ( _
    start As Integer _
) As TopDocs
Visual C++
public:
TopDocs^ TopDocs(
    int start
)

Parameters

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.TopDocs(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocsCollector.TopDocs(System.Int32)"]

See Also

TopDocsCollector Class
TopDocs Overload
Lucene.Net.Search Namespace


TopDocs Method (Int32, Int32)

[image]

Lucene.Net Class Libraries
TopDocsCollector..::..TopDocs Method (Int32, Int32)
TopDocsCollector Class See Also Send Feedback
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopDocs TopDocs(
    int start,
    int howMany
)
Visual Basic
Public Function TopDocs ( _
    start As Integer, _
    howMany As Integer _
) As TopDocs
Visual C++
public:
TopDocs^ TopDocs(
    int start,
    int howMany
)

Parameters

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.TopDocs(System.Int32,System.Int32)"]

howMany
Type: System..::..Int32

[Missing <param name="howMany"/> documentation for "M:Lucene.Net.Search.TopDocsCollector.TopDocs(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopDocsCollector.TopDocs(System.Int32,System.Int32)"]

See Also

TopDocsCollector Class
TopDocs Overload
Lucene.Net.Search Namespace


TopFieldCollector Class

[image]

Lucene.Net Class Libraries
TopFieldCollector Class
Members See Also Send Feedback
A {@link Collector} that sorts by {@link SortField} using {@link FieldComparator}s.

See the {@link #create(Lucene.Net.Search.Sort, int, boolean, boolean, boolean, boolean)} method for instantiating a TopFieldCollector.

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TopFieldCollector : TopDocsCollector
Visual Basic
Public MustInherit Class TopFieldCollector _
    Inherits TopDocsCollector
Visual C++
public ref class TopFieldCollector abstract : public TopDocsCollector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..TopDocsCollector
Lucene.Net.Search..::..TopFieldCollector

See Also

TopFieldCollector Members
Lucene.Net.Search Namespace


TopFieldCollector Members

[image] [image]

Lucene.Net Class Libraries
TopFieldCollector Members
TopFieldCollector Class Methods Fields See Also Send Feedback

The TopFieldCollector type exposes the following members.

Methods

Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

(Inherited from Collector.)
create
Creates a new {@link TopFieldCollector} from the given arguments.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTotalHits
The total number of documents that matched this query.
(Inherited from TopDocsCollector.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector..::..NewTopDocs(array<ScoreDoc>[]()[][], Int32).)
Protected method | PopulateResults | (Overrides TopDocsCollector..::..PopulateResults(array<ScoreDoc>[]()[][], Int32).)
Public method SetNextReader
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.
(Inherited from Collector.)
Public method SetScorer
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.
(Inherited from Collector.)
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector.)
Protected field | totalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector.)

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


TopFieldCollector Fields

[image] [image]

Lucene.Net Class Libraries
TopFieldCollector Fields
TopFieldCollector Class See Also Send Feedback

The TopFieldCollector type exposes the following members.

Fields

 | Name | Description
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector.)
Protected field | totalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector.)

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


TopFieldCollector Methods

[image] [image]

Lucene.Net Class Libraries
TopFieldCollector Methods
TopFieldCollector Class See Also Send Feedback

The TopFieldCollector type exposes the following members.

Methods

Name | Description
Public method | AcceptsDocsOutOfOrder | (Overrides Collector..::..AcceptsDocsOutOfOrder()()()().)
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

(Inherited from Collector.)
create
Creates a new {@link TopFieldCollector} from the given arguments.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTotalHits
The total number of documents that matched this query.
(Inherited from TopDocsCollector.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector..::..NewTopDocs(array<ScoreDoc>[]()[][], Int32).)
Protected method | PopulateResults | (Overrides TopDocsCollector..::..PopulateResults(array<ScoreDoc>[]()[][], Int32).)
Public method SetNextReader
Called before collecting from each IndexReader. All doc ids in {@link #Collect(int)} will correspond to reader. Add docBase to the current IndexReaders internal document id to re-base ids in {@link #Collect(int)}.
(Inherited from Collector.)
Public method SetScorer
Called before successive calls to {@link #Collect(int)}. Implementations that need the score of the current document (passed-in to {@link #Collect(int)}), should save the passed-in Scorer and call scorer.score() when needed.
(Inherited from Collector.)
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


AcceptsDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
TopFieldCollector..::..AcceptsDocsOutOfOrder Method
TopFieldCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopFieldCollector.AcceptsDocsOutOfOrder"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool AcceptsDocsOutOfOrder()
Visual Basic
Public Overrides Function AcceptsDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool AcceptsDocsOutOfOrder() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopFieldCollector.AcceptsDocsOutOfOrder"]

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


create Method

[image]

Lucene.Net Class Libraries
TopFieldCollector..::..create Method
TopFieldCollector Class See Also Send Feedback
Creates a new {@link TopFieldCollector} from the given arguments.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static TopFieldCollector create(
    Sort sort,
    int numHits,
    bool fillFields,
    bool trackDocScores,
    bool trackMaxScore,
    bool docsScoredInOrder
)
Visual Basic
Public Shared Function create ( _
    sort As Sort, _
    numHits As Integer, _
    fillFields As Boolean, _
    trackDocScores As Boolean, _
    trackMaxScore As Boolean, _
    docsScoredInOrder As Boolean _
) As TopFieldCollector
Visual C++
public:
static TopFieldCollector^ create(
    Sort^ sort,
    int numHits,
    bool fillFields,
    bool trackDocScores,
    bool trackMaxScore,
    bool docsScoredInOrder
)

Parameters

sort
Type: Lucene.Net.Search..::..Sort
the sort criteria (SortFields).
numHits
Type: System..::..Int32
the number of results to collect.
fillFields
Type: System..::..Boolean
specifies whether the actual field values should be returned on the results (FieldDoc).
trackDocScores
Type: System..::..Boolean
specifies whether document scores should be tracked and set on the results. Note that if set to false, then the results' scores will be set to Float.NaN. Setting this to true affects performance, as it incurs the score computation on each competitive result. Therefore if document scores are not required by the application, it is recommended to set it to false.
trackMaxScore
Type: System..::..Boolean
specifies whether the query's maxScore should be tracked and set on the resulting {@link TopDocs}. Note that if set to false, {@link TopDocs#GetMaxScore()} returns Float.NaN. Setting this to true affects performance as it incurs the score computation on each result. Also, setting this true automatically sets
CopyC#
trackDocScores
 to true as well.
docsScoredInOrder
Type: System..::..Boolean
specifies whether documents are scored in doc Id order or not by the given {@link Scorer} in {@link #SetScorer(Scorer)}.

Return Value

a {@link TopFieldCollector} instance which will sort the results by the sort criteria.

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


NewTopDocs Method

[image]

Lucene.Net Class Libraries
TopFieldCollector..::..NewTopDocs Method
TopFieldCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopFieldCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
Visual Basic
Public Overrides Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
) override

Parameters

results
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.TopFieldCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.TopFieldCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopFieldCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


PopulateResults Method

[image]

Lucene.Net Class Libraries
TopFieldCollector..::..PopulateResults Method
TopFieldCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopFieldCollector.PopulateResults(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal override void PopulateResults(
    ScoreDoc[] results,
    int howMany
)
Visual Basic
Protected Friend Overrides Sub PopulateResults ( _
    results As ScoreDoc(), _
    howMany As Integer _
)
Visual C++
protected public:
virtual void PopulateResults(
    array<ScoreDoc^>^ results,
    int howMany
) override

Parameters

results
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.TopFieldCollector.PopulateResults(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

howMany
Type: System..::..Int32

[Missing <param name="howMany"/> documentation for "M:Lucene.Net.Search.TopFieldCollector.PopulateResults(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

See Also

TopFieldCollector Class
Lucene.Net.Search Namespace


TopDocs Method

[image] [image]

Lucene.Net Class Libraries
TopFieldCollector..::..TopDocs Method
TopFieldCollector Class See Also Send Feedback

Overload List

Name Description
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)

See Also

TopFieldCollector Class
TopFieldCollector Members
Lucene.Net.Search Namespace


TopFieldDocCollector Class

[image]

Lucene.Net Class Libraries
TopFieldDocCollector Class
Members See Also Send Feedback
A {@link HitCollector} implementation that collects the top-sorting documents, returning them as a {@link TopFieldDocs}. This is used by {@link IndexSearcher} to implement {@link TopFieldDocs}-based search.

This may be extended, overriding the collect method to, e.g., conditionally invoke

CopyC#
super()
in order to filter which documents are collected.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use TopFieldCollector instead.")]
public class TopFieldDocCollector : TopDocCollector
Visual Basic
<ObsoleteAttribute("Please use TopFieldCollector instead.")> _
Public Class TopFieldDocCollector _
    Inherits TopDocCollector
Visual C++
[ObsoleteAttribute(L"Please use TopFieldCollector instead.")]
public ref class TopFieldDocCollector : public TopDocCollector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..HitCollector
Lucene.Net.Search..::..TopDocCollector
Lucene.Net.Search..::..TopFieldDocCollector

See Also

TopFieldDocCollector Members
Lucene.Net.Search Namespace


TopFieldDocCollector Members

[image] [image]

Lucene.Net Class Libraries
TopFieldDocCollector Members
TopFieldDocCollector Class Constructors Methods Fields See Also Send Feedback

The TopFieldDocCollector type exposes the following members.

Constructors

 | Name | Description
Public method | TopFieldDocCollector | Construct to collect a given number of hits.

Methods

 | Name | Description
Public method | Collect | (Overrides TopDocCollector..::..Collect(Int32, Single).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTotalHits | The total number of documents that matched this query. (Inherited from TopDocCollector.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TopDocs | (Overrides TopDocCollector..::..TopDocs()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | hq | The priority queue which holds the top-scoring documents. (Inherited from TopDocCollector.)
Protected field | totalHits | The total number of hits the collector encountered. (Inherited from TopDocCollector.)

See Also

TopFieldDocCollector Class
Lucene.Net.Search Namespace


TopFieldDocCollector Constructor

[image]

Lucene.Net Class Libraries
TopFieldDocCollector Constructor
TopFieldDocCollector Class See Also Send Feedback
Construct to collect a given number of hits.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopFieldDocCollector(
    IndexReader reader,
    Sort sort,
    int numHits
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    sort As Sort, _
    numHits As Integer _
)
Visual C++
public:
TopFieldDocCollector(
    IndexReader^ reader,
    Sort^ sort,
    int numHits
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
the index to be searched
sort
Type: Lucene.Net.Search..::..Sort
the sort criteria
numHits
Type: System..::..Int32
the maximum number of hits to collect

See Also

TopFieldDocCollector Class
Lucene.Net.Search Namespace


TopFieldDocCollector Fields

[image] [image]

Lucene.Net Class Libraries
TopFieldDocCollector Fields
TopFieldDocCollector Class See Also Send Feedback

The TopFieldDocCollector type exposes the following members.

Fields

 | Name | Description
Protected field | hq | The priority queue which holds the top-scoring documents. (Inherited from TopDocCollector.)
Protected field | totalHits | The total number of hits the collector encountered. (Inherited from TopDocCollector.)

See Also

TopFieldDocCollector Class
Lucene.Net.Search Namespace


TopFieldDocCollector Methods

[image] [image]

Lucene.Net Class Libraries
TopFieldDocCollector Methods
TopFieldDocCollector Class See Also Send Feedback

The TopFieldDocCollector type exposes the following members.

Methods

 | Name | Description
Public method | Collect | (Overrides TopDocCollector..::..Collect(Int32, Single).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTotalHits | The total number of documents that matched this query. (Inherited from TopDocCollector.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TopDocs | (Overrides TopDocCollector..::..TopDocs()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopFieldDocCollector Class
Lucene.Net.Search Namespace


Collect Method

[image]

Lucene.Net Class Libraries
TopFieldDocCollector..::..Collect Method
TopFieldDocCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopFieldDocCollector.Collect(System.Int32,System.Single)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Collect(
    int doc,
    float score
)
Visual Basic
Public Overrides Sub Collect ( _
    doc As Integer, _
    score As Single _
)
Visual C++
public:
virtual void Collect(
    int doc,
    float score
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.TopFieldDocCollector.Collect(System.Int32,System.Single)"]

score
Type: System..::..Single

[Missing <param name="score"/> documentation for "M:Lucene.Net.Search.TopFieldDocCollector.Collect(System.Int32,System.Single)"]

See Also

TopFieldDocCollector Class
Lucene.Net.Search Namespace


TopDocs Method

[image]

Lucene.Net Class Libraries
TopFieldDocCollector..::..TopDocs Method
TopFieldDocCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopFieldDocCollector.TopDocs"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopDocs TopDocs()
Visual Basic
Public Overrides Function TopDocs As TopDocs
Visual C++
public:
virtual TopDocs^ TopDocs() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopFieldDocCollector.TopDocs"]

See Also

TopFieldDocCollector Class
Lucene.Net.Search Namespace


TopFieldDocs Class

[image]

Lucene.Net Class Libraries
TopFieldDocs Class
Members See Also Send Feedback
Represents hits returned by {@link Searcher#search(Query,Filter,int,Sort)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class TopFieldDocs : TopDocs
Visual Basic
<SerializableAttribute> _
Public Class TopFieldDocs _
    Inherits TopDocs
Visual C++
[SerializableAttribute]
public ref class TopFieldDocs : public TopDocs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..TopDocs
Lucene.Net.Search..::..TopFieldDocs

See Also

TopFieldDocs Members
Lucene.Net.Search Namespace


TopFieldDocs Members

[image] [image]

Lucene.Net Class Libraries
TopFieldDocs Members
TopFieldDocs Class Constructors Methods Fields Properties See Also Send Feedback

The TopFieldDocs type exposes the following members.

Constructors

 | Name | Description
Public method | TopFieldDocs | Creates one of these objects.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxScore | Returns the maximum score value encountered. Note that in case scores are not tracked, this returns {@link Float#NaN}. (Inherited from TopDocs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMaxScore | Sets the maximum score value encountered. (Inherited from TopDocs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | fields | The fields which were used to sort results by.
Public field | scoreDocs | Obsolete. The top hits for the query. (Inherited from TopDocs.)
Public field | totalHits | Obsolete. The total number of hits for the query. (Inherited from TopDocs.)

Properties

 | Name | Description
Public property | MaxScore | (Inherited from TopDocs.)
Public property | ScoreDocs | (Inherited from TopDocs.)
Public property | TotalHits | (Inherited from TopDocs.)

See Also

TopFieldDocs Class
Lucene.Net.Search Namespace


TopFieldDocs Constructor

[image]

Lucene.Net Class Libraries
TopFieldDocs Constructor
TopFieldDocs Class See Also Send Feedback
Creates one of these objects.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TopFieldDocs(
    int totalHits,
    ScoreDoc[] scoreDocs,
    SortField[] fields,
    float maxScore
)
Visual Basic
Public Sub New ( _
    totalHits As Integer, _
    scoreDocs As ScoreDoc(), _
    fields As SortField(), _
    maxScore As Single _
)
Visual C++
public:
TopFieldDocs(
    int totalHits,
    array<ScoreDoc^>^ scoreDocs,
    array<SortField^>^ fields,
    float maxScore
)

Parameters

totalHits
Type: System..::..Int32
Total number of hits for the query.
scoreDocs
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]
The top hits for the query.
fields
Type: array< Lucene.Net.Search..::..SortField >[]()[][]
The sort criteria used to find the top hits.
maxScore
Type: System..::..Single
The maximum score encountered.

See Also

TopFieldDocs Class
Lucene.Net.Search Namespace


TopFieldDocs Fields

[image] [image]

Lucene.Net Class Libraries
TopFieldDocs Fields
TopFieldDocs Class See Also Send Feedback

The TopFieldDocs type exposes the following members.

Fields

 | Name | Description
Public field | fields | The fields which were used to sort results by.
Public field | scoreDocs | Obsolete. The top hits for the query. (Inherited from TopDocs.)
Public field | totalHits | Obsolete. The total number of hits for the query. (Inherited from TopDocs.)

See Also

TopFieldDocs Class
Lucene.Net.Search Namespace


fields Field

[image]

Lucene.Net Class Libraries
TopFieldDocs..::..fields Field
TopFieldDocs Class See Also Send Feedback
The fields which were used to sort results by.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortField[] fields
Visual Basic
Public fields As SortField()
Visual C++
public:
array<SortField^>^ fields

See Also

TopFieldDocs Class
Lucene.Net.Search Namespace


TopFieldDocs Methods

[image] [image]

Lucene.Net Class Libraries
TopFieldDocs Methods
TopFieldDocs Class See Also Send Feedback

The TopFieldDocs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxScore | Returns the maximum score value encountered. Note that in case scores are not tracked, this returns {@link Float#NaN}. (Inherited from TopDocs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMaxScore | Sets the maximum score value encountered. (Inherited from TopDocs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopFieldDocs Class
Lucene.Net.Search Namespace


TopFieldDocs Properties

[image] [image]

Lucene.Net Class Libraries
TopFieldDocs Properties
TopFieldDocs Class See Also Send Feedback

The TopFieldDocs type exposes the following members.

Properties

 | Name | Description
Public property | MaxScore | (Inherited from TopDocs.)
Public property | ScoreDocs | (Inherited from TopDocs.)
Public property | TotalHits | (Inherited from TopDocs.)

See Also

TopFieldDocs Class
Lucene.Net.Search Namespace


TopScoreDocCollector Class

[image]

Lucene.Net Class Libraries
TopScoreDocCollector Class
Members See Also Send Feedback
A {@link Collector} implementation that collects the top-scoring hits, returning them as a {@link TopDocs}. This is used by {@link IndexSearcher} to implement {@link TopDocs}-based search. Hits are sorted by score descending and then (when the scores are tied) docID ascending. When you create an instance of this collector you should know in advance whether documents are going to be collected in doc Id order or not.

NOTE: The values {@link Float#NaN} and {Float#NEGATIVE_INFINITY} are not valid scores. This collector will not properly collect hits with such scores.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class TopScoreDocCollector : TopDocsCollector
Visual Basic
Public MustInherit Class TopScoreDocCollector _
    Inherits TopDocsCollector
Visual C++
public ref class TopScoreDocCollector abstract : public TopDocsCollector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Collector
Lucene.Net.Search..::..TopDocsCollector
Lucene.Net.Search..::..TopScoreDocCollector

See Also

TopScoreDocCollector Members
Lucene.Net.Search Namespace


TopScoreDocCollector Members

[image] [image]

Lucene.Net Class Libraries
TopScoreDocCollector Members
TopScoreDocCollector Class Methods Fields See Also Send Feedback

The TopScoreDocCollector type exposes the following members.

Methods

Name | Description
Public method AcceptsDocsOutOfOrder
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *
(Inherited from Collector.)
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

(Inherited from Collector.)
create
Creates a new {@link TopScoreDocCollector} given the number of hits to collect and whether documents are scored in order by the input {@link Scorer} to {@link #SetScorer(Scorer)}.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
, and fill the array with sentinel objects.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTotalHits
The total number of documents that matched this query.
(Inherited from TopDocsCollector.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector..::..NewTopDocs(array<ScoreDoc>[]()[][], Int32).)
Protected method PopulateResults
Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.
(Inherited from TopDocsCollector.)
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector.)
Protected field | totalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector.)

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


TopScoreDocCollector Fields

[image] [image]

Lucene.Net Class Libraries
TopScoreDocCollector Fields
TopScoreDocCollector Class See Also Send Feedback

The TopScoreDocCollector type exposes the following members.

Fields

 | Name | Description
Protected field | pq | The priority queue which holds the top documents. Note that different implementations of PriorityQueue give different meaning to 'top documents'. HitQueue for example aggregates the top scoring documents, while other PQ implementations may hold documents sorted by other criteria. (Inherited from TopDocsCollector.)
Protected field | totalHits | The total number of documents that the collector encountered. (Inherited from TopDocsCollector.)

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


TopScoreDocCollector Methods

[image] [image]

Lucene.Net Class Libraries
TopScoreDocCollector Methods
TopScoreDocCollector Class See Also Send Feedback

The TopScoreDocCollector type exposes the following members.

Methods

Name | Description
Public method AcceptsDocsOutOfOrder
* Return
CopyC#
true
 if this collector does not * require the matching docIDs to be delivered in int sort * order (smallest to largest) to {@link #collect}. * *

Most Lucene Query implementations will visit * matching docIDs in order. However, some queries * (currently limited to certain cases of {@link * BooleanQuery}) can achieve faster searching if the *

CopyC#
Collector
allows them to deliver the * docIDs out of order. * *

Many collectors don't mind getting docIDs out of * order, so it's important to return

CopyC#
true
* here. *
(Inherited from Collector.)
Public method Collect
Called once for every document matching a query, with the unbased document number.

Note: This is called in an inner search loop. For good search performance, implementations of this method should not call {@link Searcher#Doc(int)} or {@link Lucene.Net.Index.IndexReader#Document(int)} on every hit. Doing so can slow searches by an order of magnitude or more.

(Inherited from Collector.)
create
Creates a new {@link TopScoreDocCollector} given the number of hits to collect and whether documents are scored in order by the input {@link Scorer} to {@link #SetScorer(Scorer)}.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
, and fill the array with sentinel objects.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTotalHits
The total number of documents that matched this query.
(Inherited from TopDocsCollector.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | NewTopDocs | (Overrides TopDocsCollector..::..NewTopDocs(array<ScoreDoc>[]()[][], Int32).)
Protected method PopulateResults
Populates the results array with the ScoreDoc instaces. This can be overridden in case a different ScoreDoc type should be returned.
(Inherited from TopDocsCollector.)
Public method | SetNextReader | (Overrides Collector..::..SetNextReader(IndexReader, Int32).)
Public method | SetScorer | (Overrides Collector..::..SetScorer(Scorer).)
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


create Method

[image]

Lucene.Net Class Libraries
TopScoreDocCollector..::..create Method
TopScoreDocCollector Class See Also Send Feedback
Creates a new {@link TopScoreDocCollector} given the number of hits to collect and whether documents are scored in order by the input {@link Scorer} to {@link #SetScorer(Scorer)}.

NOTE: The instances returned by this method pre-allocate a full array of length

CopyC#
numHits
, and fill the array with sentinel objects.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static TopScoreDocCollector create(
    int numHits,
    bool docsScoredInOrder
)
Visual Basic
Public Shared Function create ( _
    numHits As Integer, _
    docsScoredInOrder As Boolean _
) As TopScoreDocCollector
Visual C++
public:
static TopScoreDocCollector^ create(
    int numHits,
    bool docsScoredInOrder
)

Parameters

numHits
Type: System..::..Int32

[Missing <param name="numHits"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.create(System.Int32,System.Boolean)"]

docsScoredInOrder
Type: System..::..Boolean

[Missing <param name="docsScoredInOrder"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.create(System.Int32,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.create(System.Int32,System.Boolean)"]

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


NewTopDocs Method

[image]

Lucene.Net Class Libraries
TopScoreDocCollector..::..NewTopDocs Method
TopScoreDocCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override TopDocs NewTopDocs(
    ScoreDoc[] results,
    int start
)
Visual Basic
Public Overrides Function NewTopDocs ( _
    results As ScoreDoc(), _
    start As Integer _
) As TopDocs
Visual C++
public:
virtual TopDocs^ NewTopDocs(
    array<ScoreDoc^>^ results,
    int start
) override

Parameters

results
Type: array< Lucene.Net.Search..::..ScoreDoc >[]()[][]

[Missing <param name="results"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.NewTopDocs(Lucene.Net.Search.ScoreDoc[],System.Int32)"]

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


SetNextReader Method

[image]

Lucene.Net Class Libraries
TopScoreDocCollector..::..SetNextReader Method
TopScoreDocCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetNextReader(
    IndexReader reader,
    int base_Renamed
)
Visual Basic
Public Overrides Sub SetNextReader ( _
    reader As IndexReader, _
    base_Renamed As Integer _
)
Visual C++
public:
virtual void SetNextReader(
    IndexReader^ reader,
    int base_Renamed
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

base_Renamed
Type: System..::..Int32

[Missing <param name="base_Renamed"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.SetNextReader(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


SetScorer Method

[image]

Lucene.Net Class Libraries
TopScoreDocCollector..::..SetScorer Method
TopScoreDocCollector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.SetScorer(Lucene.Net.Search.Scorer)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetScorer(
    Scorer scorer
)
Visual Basic
Public Overrides Sub SetScorer ( _
    scorer As Scorer _
)
Visual C++
public:
virtual void SetScorer(
    Scorer^ scorer
) override

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Search.TopScoreDocCollector.SetScorer(Lucene.Net.Search.Scorer)"]

See Also

TopScoreDocCollector Class
Lucene.Net.Search Namespace


TopDocs Method

[image] [image]

Lucene.Net Class Libraries
TopScoreDocCollector..::..TopDocs Method
TopScoreDocCollector Class See Also Send Feedback

Overload List

Name Description
Public method TopDocs()()()()
Returns the top docs that were collected by this collector.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32)
Returns the documents in the rage [start .. pq.size()) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned.
This method is convenient to call if the application allways asks for the last results, starting from the last 'page'.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different
CopyC#
start
, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)
Public method TopDocs(Int32, Int32)
Returns the documents in the rage [start .. start+howMany) that were collected by this collector. Note that if start >= pq.size(), an empty TopDocs is returned, and if pq.size() - start < howMany, then only the available documents in [start .. pq.size()) are returned.
This method is useful to call in case pagination of search results is allowed by the search application, as well as it attempts to optimize the memory used by allocating only as much as requested by howMany.
NOTE: you cannot call this method more than once for each search execution. If you need to call it more than once, passing each time a different range, you should call {@link #TopDocs()} and work with the returned {@link TopDocs} object, which will contain all the results this search execution collected.
(Inherited from TopDocsCollector.)

See Also

TopScoreDocCollector Class
TopScoreDocCollector Members
Lucene.Net.Search Namespace


Weight Class

[image]

Lucene.Net Class Libraries
Weight Class
Members See Also Send Feedback
Expert: Calculate query weights and build query scorers.

The purpose of {@link Weight} is to ensure searching does not modify a {@link Query}, so that a {@link Query} instance can be reused.
{@link Searcher} dependent state of the query should reside in the {@link Weight}.
{@link IndexReader} dependent state should reside in the {@link Scorer}.

A

CopyC#
Weight
is used in the following way:
  1. A
    CopyC#
    Weight
     is constructed by a top-level query, given a
    CopyC#
    Searcher
     ({@link Query#CreateWeight(Searcher)}).
  2. The {@link #SumOfSquaredWeights()} method is called on the
    CopyC#
    Weight
     to compute the query normalization factor {@link Similarity#QueryNorm(float)} of the query clauses contained in the query.
  3. The query normalization factor is passed to {@link #Normalize(float)}. At this point the weighting is complete.
  4. A
    CopyC#
    Scorer
     is constructed by {@link #Scorer(IndexReader,boolean,boolean)}.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class Weight
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Weight
Visual C++
[SerializableAttribute]
public ref class Weight abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search..::..BooleanQuery..::..BooleanWeight
Lucene.Net.Search..::..ConstantScoreQuery..::..ConstantWeight
Lucene.Net.Search..::..DisjunctionMaxQuery..::..DisjunctionMaxWeight
Lucene.Net.Search.Spans..::..SpanWeight

See Also

Weight Members
Lucene.Net.Search Namespace


Weight Members

[image] [image]

Lucene.Net Class Libraries
Weight Members
Weight Class Constructors Methods See Also Send Feedback

The Weight type exposes the following members.

Constructors

 | Name | Description
Protected method | Weight | Initializes a new instance of the Weight class

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
An explanation of the score computation for the named document.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetQuery
The query that this concerns.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValue
The weight for this query.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Normalize
Assigns the query normalization factor to this.
Public method Scorer
Returns a {@link Scorer} which scores documents in/out-of order according to
CopyC#
scoreDocsInOrder
.

NOTE: even if

CopyC#
scoreDocsInOrder
is false, it is recommended to check whether the returned
CopyC#
Scorer
 indeed scores documents out of order (i.e., call {@link #ScoresDocsOutOfOrder()}), as some
CopyC#
Scorer
 implementations will always return documents in-order.
NOTE: null can be returned if no documents will be scored by this query.
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
Public method SumOfSquaredWeights
The sum of squared weights of contained query clauses.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Weight Class
Lucene.Net.Search Namespace


Weight Constructor

[image]

Lucene.Net Class Libraries
Weight Constructor
Weight Class See Also Send Feedback
Initializes a new instance of the Weight class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Weight()
Visual Basic
Protected Sub New
Visual C++
protected:
Weight()

See Also

Weight Class
Lucene.Net.Search Namespace


Weight Methods

[image] [image]

Lucene.Net Class Libraries
Weight Methods
Weight Class See Also Send Feedback

The Weight type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
An explanation of the score computation for the named document.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetQuery
The query that this concerns.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValue
The weight for this query.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Normalize
Assigns the query normalization factor to this.
Public method Scorer
Returns a {@link Scorer} which scores documents in/out-of order according to
CopyC#
scoreDocsInOrder
.

NOTE: even if

CopyC#
scoreDocsInOrder
is false, it is recommended to check whether the returned
CopyC#
Scorer
 indeed scores documents out of order (i.e., call {@link #ScoresDocsOutOfOrder()}), as some
CopyC#
Scorer
 implementations will always return documents in-order.
NOTE: null can be returned if no documents will be scored by this query.
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
Public method SumOfSquaredWeights
The sum of squared weights of contained query clauses.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Weight Class
Lucene.Net.Search Namespace


Explain Method

[image]

Lucene.Net Class Libraries
Weight..::..Explain Method
Weight Class See Also Send Feedback
An explanation of the score computation for the named document.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Explanation Explain(
    IndexReader reader,
    int doc
)
Visual Basic
Public MustOverride Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
sub-reader containing the give doc
doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Weight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Return Value

an Explanation for the score

See Also

Weight Class
Lucene.Net.Search Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
Weight..::..GetQuery Method
Weight Class See Also Send Feedback
The query that this concerns.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Query GetQuery()
Visual Basic
Public MustOverride Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Weight.GetQuery"]

See Also

Weight Class
Lucene.Net.Search Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
Weight..::..GetValue Method
Weight Class See Also Send Feedback
The weight for this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float GetValue()
Visual Basic
Public MustOverride Function GetValue As Single
Visual C++
public:
virtual float GetValue() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Weight.GetValue"]

See Also

Weight Class
Lucene.Net.Search Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
Weight..::..Normalize Method
Weight Class See Also Send Feedback
Assigns the query normalization factor to this.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Normalize(
    float norm
)
Visual Basic
Public MustOverride Sub Normalize ( _
    norm As Single _
)
Visual C++
public:
virtual void Normalize(
    float norm
) abstract

Parameters

norm
Type: System..::..Single

[Missing <param name="norm"/> documentation for "M:Lucene.Net.Search.Weight.Normalize(System.Single)"]

See Also

Weight Class
Lucene.Net.Search Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
Weight..::..Scorer Method
Weight Class See Also Send Feedback
Returns a {@link Scorer} which scores documents in/out-of order according to
CopyC#
scoreDocsInOrder
.

NOTE: even if

CopyC#
scoreDocsInOrder
is false, it is recommended to check whether the returned
CopyC#
Scorer
 indeed scores documents out of order (i.e., call {@link #ScoresDocsOutOfOrder()}), as some
CopyC#
Scorer
 implementations will always return documents in-order.
NOTE: null can be returned if no documents will be scored by this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public MustOverride Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
the {@link IndexReader} for which to return the {@link Scorer}.
scoreDocsInOrder
Type: System..::..Boolean
specifies whether in-order scoring of documents is required. Note that if set to false (i.e., out-of-order scoring is required), this method can return whatever scoring mode it supports, as every in-order scorer is also an out-of-order one. However, an out-of-order scorer may not support {@link Scorer#NextDoc()} and/or {@link Scorer#Advance(int)}, therefore it is recommended to request an in-order scorer if use of these methods is required.
topScorer
Type: System..::..Boolean
if true, {@link Scorer#Score(Collector)} will be called; if false, {@link Scorer#NextDoc()} and/or {@link Scorer#Advance(int)} will be called.

Return Value

a {@link Scorer} which scores documents in/out-of order.

See Also

Weight Class
Lucene.Net.Search Namespace


ScoresDocsOutOfOrder Method

[image]

Lucene.Net Class Libraries
Weight..::..ScoresDocsOutOfOrder Method
Weight Class See Also Send Feedback
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool ScoresDocsOutOfOrder()
Visual Basic
Public Overridable Function ScoresDocsOutOfOrder As Boolean
Visual C++
public:
virtual bool ScoresDocsOutOfOrder()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Weight.ScoresDocsOutOfOrder"]

See Also

Weight Class
Lucene.Net.Search Namespace


SumOfSquaredWeights Method

[image]

Lucene.Net Class Libraries
Weight..::..SumOfSquaredWeights Method
Weight Class See Also Send Feedback
The sum of squared weights of contained query clauses.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float SumOfSquaredWeights()
Visual Basic
Public MustOverride Function SumOfSquaredWeights As Single
Visual C++
public:
virtual float SumOfSquaredWeights() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Weight.SumOfSquaredWeights"]

See Also

Weight Class
Lucene.Net.Search Namespace


WildcardQuery Class

[image]

Lucene.Net Class Libraries
WildcardQuery Class
Members See Also Send Feedback
Implements the wildcard search query. Supported wildcards are
CopyC#
*
, which matches any character sequence (including the empty one), and
CopyC#
?
, which matches any single character. Note this query can be slow, as it needs to iterate over many terms. In order to prevent extremely slow WildcardQueries, a Wildcard term should not start with one of the wildcards
CopyC#
*
 or
CopyC#
?
.

This query uses the {@link MultiTermQuery#CONSTANT_SCORE_AUTO_REWRITE_DEFAULT} rewrite method.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class WildcardQuery : MultiTermQuery
Visual Basic
<SerializableAttribute> _
Public Class WildcardQuery _
    Inherits MultiTermQuery
Visual C++
[SerializableAttribute]
public ref class WildcardQuery : public MultiTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search..::..WildcardQuery

See Also

WildcardQuery Members
Lucene.Net.Search Namespace
Lucene.Net.Search..::..WildcardTermEnum


WildcardQuery Members

[image] [image]

Lucene.Net Class Libraries
WildcardQuery Members
WildcardQuery Class Constructors Methods Fields See Also Send Feedback

The WildcardQuery type exposes the following members.

Constructors

 | Name | Description
Public method | WildcardQuery | Initializes a new instance of the WildcardQuery class

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Overrides MultiTermQuery..::..GetTerm()()()().)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides MultiTermQuery..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term |

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


WildcardQuery Constructor

[image]

Lucene.Net Class Libraries
WildcardQuery Constructor
WildcardQuery Class See Also Send Feedback
Initializes a new instance of the WildcardQuery class

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WildcardQuery(
    Term term
)
Visual Basic
Public Sub New ( _
    term As Term _
)
Visual C++
public:
WildcardQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.WildcardQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


WildcardQuery Fields

[image] [image]

Lucene.Net Class Libraries
WildcardQuery Fields
WildcardQuery Class See Also Send Feedback

The WildcardQuery type exposes the following members.

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term |

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


term Field

[image]

Lucene.Net Class Libraries
WildcardQuery..::..term Field
WildcardQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.WildcardQuery.term"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Term term
Visual Basic
Protected Friend term As Term
Visual C++
protected public:
Term^ term

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


WildcardQuery Methods

[image] [image]

Lucene.Net Class Libraries
WildcardQuery Methods
WildcardQuery Class See Also Send Feedback

The WildcardQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Overrides MultiTermQuery..::..Equals(Object).)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetEnum | (Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Overrides MultiTermQuery..::..GetTerm()()()().)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides MultiTermQuery..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a user-readable version of this query.
(Overrides MultiTermQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


Equals Method

[image]

Lucene.Net Class Libraries
WildcardQuery..::..Equals Method
WildcardQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.WildcardQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardQuery.Equals(System.Object)"]

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
WildcardQuery..::..GetEnum Method
WildcardQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.WildcardQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
WildcardQuery..::..GetHashCode Method
WildcardQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardQuery.GetHashCode"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardQuery.GetHashCode"]

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
WildcardQuery..::..GetTerm Method
WildcardQuery Class See Also Send Feedback
Returns the pattern term.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.MultiTermQuery.GetTerm()")]
public override Term GetTerm()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.MultiTermQuery.GetTerm()")> _
Public Overrides Function GetTerm As Term
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Search.MultiTermQuery.GetTerm()")]
public:
virtual Term^ GetTerm() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardQuery.GetTerm"]

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
WildcardQuery..::..Rewrite Method
WildcardQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.WildcardQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

WildcardQuery Class
Lucene.Net.Search Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
WildcardQuery..::..ToString Method
WildcardQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | Prints a user-readable version of this query. (Overrides MultiTermQuery..::..ToString(String).)

See Also

WildcardQuery Class
WildcardQuery Members
Lucene.Net.Search Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
WildcardQuery..::..ToString Method (String)
WildcardQuery Class See Also Send Feedback
Prints a user-readable version of this query.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.WildcardQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardQuery.ToString(System.String)"]

See Also

WildcardQuery Class
ToString Overload
Lucene.Net.Search Namespace


WildcardTermEnum Class

[image]

Lucene.Net Class Libraries
WildcardTermEnum Class
Members See Also Send Feedback
Subclass of FilteredTermEnum for enumerating all terms that match the specified wildcard filter term.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class WildcardTermEnum : FilteredTermEnum
Visual Basic
Public Class WildcardTermEnum _
    Inherits FilteredTermEnum
Visual C++
public ref class WildcardTermEnum : public FilteredTermEnum

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Search..::..FilteredTermEnum
Lucene.Net.Search..::..WildcardTermEnum

See Also

WildcardTermEnum Members
Lucene.Net.Search Namespace


WildcardTermEnum Members

[image] [image]

Lucene.Net Class Libraries
WildcardTermEnum Members
WildcardTermEnum Class Constructors Methods Fields See Also Send Feedback

The WildcardTermEnum type exposes the following members.

Constructors

Name Description
Public method WildcardTermEnum
Creates a new
CopyC#
WildcardTermEnum
.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Methods

Name | Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | TermCompare | (Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
WildcardEquals
Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
 | WILDCARD_CHAR |
 | WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


WildcardTermEnum Constructor

[image]

Lucene.Net Class Libraries
WildcardTermEnum Constructor
WildcardTermEnum Class See Also Send Feedback
Creates a new
CopyC#
WildcardTermEnum
.

After calling the constructor the enumeration is already pointing to the first valid term if such a term exists.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public WildcardTermEnum(
    IndexReader reader,
    Term term
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    term As Term _
)
Visual C++
public:
WildcardTermEnum(
    IndexReader^ reader,
    Term^ term
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term)"]

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term)"]

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


WildcardTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
WildcardTermEnum Fields
WildcardTermEnum Class See Also Send Feedback

The WildcardTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)
 | WILDCARD_CHAR |
 | WILDCARD_STRING | ***************************************** String equality with support for wildcards ******************************************

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


WILDCARD_CHAR Field

[image]

Lucene.Net Class Libraries
WildcardTermEnum..::..WILDCARD_CHAR Field
WildcardTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.WildcardTermEnum.WILDCARD_CHAR"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const char WILDCARD_CHAR
Visual Basic
Public Const WILDCARD_CHAR As Char
Visual C++
public:
literal wchar_t WILDCARD_CHAR

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


WILDCARD_STRING Field

[image]

Lucene.Net Class Libraries
WildcardTermEnum..::..WILDCARD_STRING Field
WildcardTermEnum Class See Also Send Feedback
***************************************** String equality with support for wildcards ******************************************

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const char WILDCARD_STRING
Visual Basic
Public Const WILDCARD_STRING As Char
Visual C++
public:
literal wchar_t WILDCARD_STRING

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


WildcardTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
WildcardTermEnum Methods
WildcardTermEnum Class See Also Send Feedback

The WildcardTermEnum type exposes the following members.

Methods

Name | Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method | Difference | (Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | EndEnum | (Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method | TermCompare | (Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
WildcardEquals
Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


Difference Method

[image]

Lucene.Net Class Libraries
WildcardTermEnum..::..Difference Method
WildcardTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardTermEnum.Difference"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Difference()
Visual Basic
Public Overrides Function Difference As Single
Visual C++
public:
virtual float Difference() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardTermEnum.Difference"]

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


EndEnum Method

[image]

Lucene.Net Class Libraries
WildcardTermEnum..::..EndEnum Method
WildcardTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardTermEnum.EndEnum"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool EndEnum()
Visual Basic
Public Overrides Function EndEnum As Boolean
Visual C++
public:
virtual bool EndEnum() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardTermEnum.EndEnum"]

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


TermCompare Method

[image]

Lucene.Net Class Libraries
WildcardTermEnum..::..TermCompare Method
WildcardTermEnum Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.WildcardTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool TermCompare(
    Term term
)
Visual Basic
Public Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Visual C++
public:
virtual bool TermCompare(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardTermEnum.TermCompare(Lucene.Net.Index.Term)"]

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


WildcardEquals Method

[image]

Lucene.Net Class Libraries
WildcardTermEnum..::..WildcardEquals Method
WildcardTermEnum Class See Also Send Feedback
Determines if a word matches a wildcard pattern. Work released by Granta Design Ltd after originally being done on company time.

Namespace: Lucene.Net.Search
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool WildcardEquals(
    string pattern,
    int patternIdx,
    string string_Renamed,
    int stringIdx
)
Visual Basic
Public Shared Function WildcardEquals ( _
    pattern As String, _
    patternIdx As Integer, _
    string_Renamed As String, _
    stringIdx As Integer _
) As Boolean
Visual C++
public:
static bool WildcardEquals(
    String^ pattern,
    int patternIdx,
    String^ string_Renamed,
    int stringIdx
)

Parameters

pattern
Type: System..::..String

[Missing <param name="pattern"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.WildcardEquals(System.String,System.Int32,System.String,System.Int32)"]

patternIdx
Type: System..::..Int32

[Missing <param name="patternIdx"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.WildcardEquals(System.String,System.Int32,System.String,System.Int32)"]

string_Renamed
Type: System..::..String

[Missing <param name="string_Renamed"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.WildcardEquals(System.String,System.Int32,System.String,System.Int32)"]

stringIdx
Type: System..::..Int32

[Missing <param name="stringIdx"/> documentation for "M:Lucene.Net.Search.WildcardTermEnum.WildcardEquals(System.String,System.Int32,System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.WildcardTermEnum.WildcardEquals(System.String,System.Int32,System.String,System.Int32)"]

See Also

WildcardTermEnum Class
Lucene.Net.Search Namespace


Lucene.Net.Search.ExtendedFieldCache_old Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.ExtendedFieldCache_old Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.ExtendedFieldCache_old"]

Structures

 | Structure | Description
Public structure | ExtendedFieldCache_Fields | Obsolete. This interface is obsolete, use {@link FieldCache} instead.

Interfaces

 | Interface | Description
Public interface | DoubleParser | Obsolete.
Public interface | ExtendedFieldCache |
Public interface | LongParser | Obsolete.


DoubleParser Interface

[image]

Lucene.Net Class Libraries
DoubleParser Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.ExtendedFieldCache_old.DoubleParser"]

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use FieldCache.DoubleParser, this will be removed in Lucene 3.0 ")]
public interface DoubleParser : DoubleParser,
    Parser
Visual Basic
<ObsoleteAttribute("Use FieldCache.DoubleParser, this will be removed in Lucene 3.0 ")> _
Public Interface DoubleParser _
    Inherits DoubleParser, Parser
Visual C++
[ObsoleteAttribute(L"Use FieldCache.DoubleParser, this will be removed in Lucene 3.0 ")]
public interface class DoubleParser : DoubleParser,
    Parser

See Also

DoubleParser Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


DoubleParser Members

[image] [image]

Lucene.Net Class Libraries
DoubleParser Members
DoubleParser Interface Methods See Also Send Feedback

The DoubleParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseDouble | Return an long representation of this field's value. (Inherited from DoubleParser.)

See Also

DoubleParser Interface
Lucene.Net.Search.ExtendedFieldCache_old Namespace


DoubleParser Methods

[image] [image]

Lucene.Net Class Libraries
DoubleParser Methods
DoubleParser Interface See Also Send Feedback

The DoubleParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseDouble | Return an long representation of this field's value. (Inherited from DoubleParser.)

See Also

DoubleParser Interface
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache Interface

[image]

Lucene.Net Class Libraries
ExtendedFieldCache Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache"]

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface ExtendedFieldCache : FieldCache
Visual Basic
Public Interface ExtendedFieldCache _
    Inherits FieldCache
Visual C++
public interface class ExtendedFieldCache : FieldCache

See Also

ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache Members

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache Members
ExtendedFieldCache Interface Methods See Also Send Feedback

The ExtendedFieldCache type exposes the following members.

Methods

Name | Description
Public method GetAuto Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads
CopyC#
field
 to see if it contains integers, longs, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
CopyC#
AUTO
 and the actual found type.
(Inherited from FieldCache.)
Public method GetBytes(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetBytes(IndexReader, String, ByteParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetCacheEntries
EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache.

NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

(Inherited from FieldCache.)
Public method GetCustom Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
CopyC#
field
 and calls the given SortComparator to get the sort values. A hit in the cache will happen if
CopyC#
reader
,
CopyC#
field
, and
CopyC#
comparator
 are the same (using
CopyC#
equals()
) as a previous call to this method.
(Inherited from FieldCache.)
Public method GetDoubles(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetDoubles(IndexReader, String, DoubleParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method | GetDoubles(IndexReader, String, DoubleParser) | Obsolete.
Public method GetFloats(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetFloats(IndexReader, String, FloatParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetInfoStream
counterpart of {@link #SetInfoStream(PrintStream)}
(Inherited from FieldCache.)
Public method GetInts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetInts(IndexReader, String, IntParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetLongs(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetLongs(IndexReader, String, LongParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method | GetLongs(IndexReader, String, LongParser) | Obsolete.
Public method GetShorts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetShorts(IndexReader, String, ShortParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetStringIndex
Checks the internal cache for an appropriate entry, and if none is found reads the term values in
CopyC#
field
 and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
(Inherited from FieldCache.)
Public method GetStrings
Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
CopyC#
field
 and returns an array of size
CopyC#
reader.maxDoc()
 containing the value each document has in the given field.
(Inherited from FieldCache.)
Public method Purge
Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.
(Inherited from FieldCache.)
Public method PurgeAllCaches

EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

(Inherited from FieldCache.)
Public method SetInfoStream
If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to {@link Lucene.Net.Util.FieldCacheSanityChecker}.
(Inherited from FieldCache.)

See Also

ExtendedFieldCache Interface
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache Methods

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache Methods
ExtendedFieldCache Interface See Also Send Feedback

The ExtendedFieldCache type exposes the following members.

Methods

Name | Description
Public method GetAuto Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads
CopyC#
field
 to see if it contains integers, longs, floats or strings, and then calls one of the other methods in this class to get the values. For string values, a StringIndex is returned. After calling this method, there is an entry in the cache for both type
CopyC#
AUTO
 and the actual found type.
(Inherited from FieldCache.)
Public method GetBytes(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetBytes(IndexReader, String, ByteParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetCacheEntries
EXPERT: Generates an array of CacheEntry objects representing all items currently in the FieldCache.

NOTE: These CacheEntry objects maintain a strong refrence to the Cached Values. Maintaining refrences to a CacheEntry the IndexReader associated with it has garbage collected will prevent the Value itself from being garbage collected when the Cache drops the WeakRefrence.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

(Inherited from FieldCache.)
Public method GetCustom Obsolete.
Checks the internal cache for an appropriate entry, and if none is found reads the terms out of
CopyC#
field
 and calls the given SortComparator to get the sort values. A hit in the cache will happen if
CopyC#
reader
,
CopyC#
field
, and
CopyC#
comparator
 are the same (using
CopyC#
equals()
) as a previous call to this method.
(Inherited from FieldCache.)
Public method GetDoubles(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetDoubles(IndexReader, String, DoubleParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method | GetDoubles(IndexReader, String, DoubleParser) | Obsolete.
Public method GetFloats(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetFloats(IndexReader, String, FloatParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetInfoStream
counterpart of {@link #SetInfoStream(PrintStream)}
(Inherited from FieldCache.)
Public method GetInts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetInts(IndexReader, String, IntParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetLongs(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetLongs(IndexReader, String, LongParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method | GetLongs(IndexReader, String, LongParser) | Obsolete.
Public method GetShorts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetShorts(IndexReader, String, ShortParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetStringIndex
Checks the internal cache for an appropriate entry, and if none is found reads the term values in
CopyC#
field
 and returns an array of them in natural order, along with an array telling which element in the term array each document uses.
(Inherited from FieldCache.)
Public method GetStrings
Checks the internal cache for an appropriate entry, and if none is found, reads the term values in
CopyC#
field
 and returns an array of size
CopyC#
reader.maxDoc()
 containing the value each document has in the given field.
(Inherited from FieldCache.)
Public method Purge
Expert: drops all cache entries associated with this reader. NOTE: this reader must precisely match the reader that the cache entry is keyed on. If you pass a top-level reader, it usually will have no effect as Lucene now caches at the segment reader level.
(Inherited from FieldCache.)
Public method PurgeAllCaches

EXPERT: Instructs the FieldCache to forcibly expunge all entries from the underlying caches. This is intended only to be used for test methods as a way to ensure a known base state of the Cache (with out needing to rely on GC to free WeakReferences). It should not be relied on for "Cache maintenance" in general application code.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

(Inherited from FieldCache.)
Public method SetInfoStream
If non-null, FieldCacheImpl will warn whenever entries are created that are not sane according to {@link Lucene.Net.Util.FieldCacheSanityChecker}.
(Inherited from FieldCache.)

See Also

ExtendedFieldCache Interface
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetBytes Method

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetBytes Method
ExtendedFieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetBytes(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as a single byte and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetBytes(IndexReader, String, ByteParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as bytes and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)

See Also

ExtendedFieldCache Interface
ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetDoubles Method

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetDoubles Method
ExtendedFieldCache Interface See Also Send Feedback

Overload List

Name | Description
Public method GetDoubles(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetDoubles(IndexReader, String, DoubleParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as doubles and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method | GetDoubles(IndexReader, String, DoubleParser) | Obsolete.

See Also

ExtendedFieldCache Interface
ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetDoubles Method (IndexReader, String, DoubleParser)

[image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetDoubles Method (IndexReader, String, DoubleParser)
ExtendedFieldCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetDoubles(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.DoubleParser)"]

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in 3.0, this is for binary compatibility only ")]
double[] GetDoubles(
    IndexReader reader,
    string field,
    DoubleParser parser
)
Visual Basic
<ObsoleteAttribute("Will be removed in 3.0, this is for binary compatibility only ")> _
Function GetDoubles ( _
    reader As IndexReader, _
    field As String, _
    parser As DoubleParser _
) As Double()
Visual C++
[ObsoleteAttribute(L"Will be removed in 3.0, this is for binary compatibility only ")]
array<double>^ GetDoubles(
    IndexReader^ reader,
    String^ field,
    DoubleParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetDoubles(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.DoubleParser)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetDoubles(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.DoubleParser)"]

parser
Type: Lucene.Net.Search..::..DoubleParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetDoubles(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.DoubleParser)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetDoubles(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.DoubleParser)"]

Implements

FieldCache..::..GetDoubles(IndexReader, String, DoubleParser)

See Also

ExtendedFieldCache Interface
GetDoubles Overload
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetFloats Method

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetFloats Method
ExtendedFieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetFloats(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetFloats(IndexReader, String, FloatParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as floats and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)

See Also

ExtendedFieldCache Interface
ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetInts Method

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetInts Method
ExtendedFieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetInts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetInts(IndexReader, String, IntParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as integers and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)

See Also

ExtendedFieldCache Interface
ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetLongs Method

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetLongs Method
ExtendedFieldCache Interface See Also Send Feedback

Overload List

Name | Description
Public method GetLongs(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetLongs(IndexReader, String, LongParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as longs and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method | GetLongs(IndexReader, String, LongParser) | Obsolete.

See Also

ExtendedFieldCache Interface
ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetLongs Method (IndexReader, String, LongParser)

[image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetLongs Method (IndexReader, String, LongParser)
ExtendedFieldCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetLongs(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.LongParser)"]

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in 3.0, this is for binary compatibility only ")]
long[] GetLongs(
    IndexReader reader,
    string field,
    LongParser parser
)
Visual Basic
<ObsoleteAttribute("Will be removed in 3.0, this is for binary compatibility only ")> _
Function GetLongs ( _
    reader As IndexReader, _
    field As String, _
    parser As LongParser _
) As Long()
Visual C++
[ObsoleteAttribute(L"Will be removed in 3.0, this is for binary compatibility only ")]
array<long long>^ GetLongs(
    IndexReader^ reader,
    String^ field,
    LongParser^ parser
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetLongs(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.LongParser)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetLongs(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.LongParser)"]

parser
Type: Lucene.Net.Search..::..LongParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetLongs(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.LongParser)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache.GetLongs(Lucene.Net.Index.IndexReader,System.String,Lucene.Net.Search.LongParser)"]

Implements

FieldCache..::..GetLongs(IndexReader, String, LongParser)

See Also

ExtendedFieldCache Interface
GetLongs Overload
Lucene.Net.Search.ExtendedFieldCache_old Namespace


GetShorts Method

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache..::..GetShorts Method
ExtendedFieldCache Interface See Also Send Feedback

Overload List

Name Description
Public method GetShorts(IndexReader, String)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)
Public method GetShorts(IndexReader, String, ShortParser)
Checks the internal cache for an appropriate entry, and if none is found, reads the terms in
CopyC#
field
 as shorts and returns an array of size
CopyC#
reader.maxDoc()
 of the value each document has in the given field.
(Inherited from FieldCache.)

See Also

ExtendedFieldCache Interface
ExtendedFieldCache Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache_Fields Structure

[image]

Lucene.Net Class Libraries
ExtendedFieldCache_Fields Structure
Members See Also Send Feedback
This interface is obsolete, use {@link FieldCache} instead.

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use FieldCache, this will be removed in Lucene 3.0")]
public struct ExtendedFieldCache_Fields
Visual Basic
<ObsoleteAttribute("Use FieldCache, this will be removed in Lucene 3.0")> _
Public Structure ExtendedFieldCache_Fields
Visual C++
[ObsoleteAttribute(L"Use FieldCache, this will be removed in Lucene 3.0")]
public value class ExtendedFieldCache_Fields

See Also

ExtendedFieldCache_Fields Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache_Fields Members

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache_Fields Members
ExtendedFieldCache_Fields Structure Methods Fields See Also Send Feedback

The ExtendedFieldCache_Fields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
EXT_DEFAULT | Obsolete.

See Also

ExtendedFieldCache_Fields Structure
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache_Fields Fields

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache_Fields Fields
ExtendedFieldCache_Fields Structure See Also Send Feedback

The ExtendedFieldCache_Fields type exposes the following members.

Fields

Name | Description
EXT_DEFAULT | Obsolete.

See Also

ExtendedFieldCache_Fields Structure
Lucene.Net.Search.ExtendedFieldCache_old Namespace


EXT_DEFAULT Field

[image]

Lucene.Net Class Libraries
ExtendedFieldCache_Fields..::..EXT_DEFAULT Field
ExtendedFieldCache_Fields Structure See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.ExtendedFieldCache_old.ExtendedFieldCache_Fields.EXT_DEFAULT"]

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use FieldCache.DEFAULT; this will be removed in Lucene 3.0 ")]
public static readonly ExtendedFieldCache EXT_DEFAULT
Visual Basic
<ObsoleteAttribute("Use FieldCache.DEFAULT; this will be removed in Lucene 3.0 ")> _
Public Shared ReadOnly EXT_DEFAULT As ExtendedFieldCache
Visual C++
[ObsoleteAttribute(L"Use FieldCache.DEFAULT; this will be removed in Lucene 3.0 ")]
public:
static initonly ExtendedFieldCache^ EXT_DEFAULT

See Also

ExtendedFieldCache_Fields Structure
Lucene.Net.Search.ExtendedFieldCache_old Namespace


ExtendedFieldCache_Fields Methods

[image] [image]

Lucene.Net Class Libraries
ExtendedFieldCache_Fields Methods
ExtendedFieldCache_Fields Structure See Also Send Feedback

The ExtendedFieldCache_Fields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ExtendedFieldCache_Fields Structure
Lucene.Net.Search.ExtendedFieldCache_old Namespace


LongParser Interface

[image]

Lucene.Net Class Libraries
LongParser Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.ExtendedFieldCache_old.LongParser"]

Namespace: Lucene.Net.Search.ExtendedFieldCache_old
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use FieldCache.LongParser, this will be removed in Lucene 3.0 ")]
public interface LongParser : LongParser,
    Parser
Visual Basic
<ObsoleteAttribute("Use FieldCache.LongParser, this will be removed in Lucene 3.0 ")> _
Public Interface LongParser _
    Inherits LongParser, Parser
Visual C++
[ObsoleteAttribute(L"Use FieldCache.LongParser, this will be removed in Lucene 3.0 ")]
public interface class LongParser : LongParser,
    Parser

See Also

LongParser Members
Lucene.Net.Search.ExtendedFieldCache_old Namespace


LongParser Members

[image] [image]

Lucene.Net Class Libraries
LongParser Members
LongParser Interface Methods See Also Send Feedback

The LongParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseLong | Return an long representation of this field's value. (Inherited from LongParser.)

See Also

LongParser Interface
Lucene.Net.Search.ExtendedFieldCache_old Namespace


LongParser Methods

[image] [image]

Lucene.Net Class Libraries
LongParser Methods
LongParser Interface See Also Send Feedback

The LongParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseLong | Return an long representation of this field's value. (Inherited from LongParser.)

See Also

LongParser Interface
Lucene.Net.Search.ExtendedFieldCache_old Namespace


Lucene.Net.Search.Function Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.Function Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.Function"]

Classes

Class | Description
Public class ByteFieldSource
Expert: obtains single byte field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getBytes()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class | CustomScoreProvider
Public class CustomScoreQuery
Query that sets document score as a programmatic function of several (sub) scores:
  1. the score of its subQuery (any query)
  2. (optional) the score of its ValueSourceQuery (or queries). For most simple/convenient use cases this query is likely to be a {@link Lucene.Net.Search.Function.FieldScoreQuery FieldScoreQuery}
Subclasses can modify the computation by overriding {@link #getCustomScoreProvider}.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class DocValues
Expert: represents field values as different types. Normally created via a {@link Lucene.Net.Search.Function.ValueSource ValueSuorce} for a particular field and reader.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class FieldCacheSource
Expert: A base class for ValueSource implementations that retrieve values for a single field from the {@link Lucene.Net.Search.FieldCache FieldCache}.

Fields used herein nust be indexed (doesn't matter if these fields are stored or not).

It is assumed that each such indexed field is untokenized, or at least has a single token in a document. For documents with multiple tokens of the same field, behavior is undefined (It is likely that current code would use the value of one of these tokens, but this is not guaranteed).

Document with no tokens in this field are assigned the

CopyC#
Zero
value.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.

Public class FieldScoreQuery
A query that scores each document as the value of the numeric input field.

The query matches all documents, and scores each document according to the numeric value of that field.

It is assumed, and expected, that:

  • The field used here is indexed, and has exactly one token in every scored document.
  • Best if this field is un_tokenized.
  • That token is parsable to the selected type.

Combining this query in a FunctionQuery allows much freedom in affecting document scores. Note, that with this freedom comes responsibility: it is more than likely that the default Lucene scoring is superior in quality to scoring modified as explained here. However, in some cases, and certainly for research experiments, this capability may turn useful.

When contructing this query, select the appropriate type. That type should match the data stored in the field. So in fact the "right" type should be selected before indexing. Type selection has effect on the RAM usage:

  • {@link Type#BYTE} consumes 1 * maxDocs bytes.
  • {@link Type#SHORT} consumes 2 * maxDocs bytes.
  • {@link Type#INT} consumes 4 * maxDocs bytes.
  • {@link Type#FLOAT} consumes 8 * maxDocs bytes.

Caching: Values for the numeric field are loaded once and cached in memory for further use with the same IndexReader. To take advantage of this, it is extremely important to reuse index-readers or index-searchers, otherwise, for instance if for each query a new index reader is opened, large penalties would be paid for loading the field values into memory over and over again!

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class FieldScoreQuery..::..Type
Type of score field, indicating how field values are interpreted/parsed.

The type selected at search search time should match the data stored in the field. Different types have different RAM requirements:

  • {@link #BYTE} consumes 1 * maxDocs bytes.
  • {@link #SHORT} consumes 2 * maxDocs bytes.
  • {@link #INT} consumes 4 * maxDocs bytes.
  • {@link #FLOAT} consumes 8 * maxDocs bytes.
Public class FloatFieldSource
Expert: obtains float field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getFloats()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class IntFieldSource
Expert: obtains int field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getInts()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class MultiValueSource Obsolete.
This class wraps another ValueSource, but protects against accidental double RAM usage in FieldCache when a composite reader is passed to {@link #getValues}.

NOTE: this class adds a CPU penalty to every lookup, as it must resolve the incoming document to the right sub-reader using a binary search.

Public class OrdFieldSource
Expert: obtains the ordinal of the field value from the default Lucene {@link Lucene.Net.Search.FieldCache Fieldcache} using getStringIndex().

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.

Example:
If there were only three field values: "apple","banana","pear"
then ord("apple")=1, ord("banana")=2, ord("pear")=3

WARNING: ord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.

Public class ReverseOrdFieldSource
Expert: obtains the ordinal of the field value from the default Lucene {@link Lucene.Net.Search.FieldCache FieldCache} using getStringIndex() and reverses the order.

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.
Example of reverse ordinal (rord):
If there were only three field values: "apple","banana","pear"
then rord("apple")=3, rord("banana")=2, ord("pear")=1

WARNING: rord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.

Public class ShortFieldSource
Expert: obtains short field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getShorts()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class ValueSource
Expert: source of values for basic function queries.

At its default/simplest form, values - one per doc - are used as the score of that doc.

Values are instantiated as {@link Lucene.Net.Search.Function.DocValues DocValues} for a particular reader.

ValueSource implementations differ in RAM requirements: it would always be a factor of the number of documents, but for each document the number of bytes can be 1, 2, 4, or 8.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public class ValueSourceQuery
Expert: A Query that sets the scores of document to the values obtained from a {@link Lucene.Net.Search.Function.ValueSource ValueSource}.

This query provides a score for each and every undeleted document in the index.

The value source can be based on a (cached) value of an indexed field, but it can also be based on an external source, e.g. values read from an external database.

Score is set as: Score(doc,query) = query.getBoost()2 * valueSource(doc).

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.


ByteFieldSource Class

[image]

Lucene.Net Class Libraries
ByteFieldSource Class
Members See Also Send Feedback
Expert: obtains single byte field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getBytes()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ByteFieldSource : FieldCacheSource
Visual Basic
<SerializableAttribute> _
Public Class ByteFieldSource _
    Inherits FieldCacheSource
Visual C++
[SerializableAttribute]
public ref class ByteFieldSource : public FieldCacheSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..FieldCacheSource
Lucene.Net.Search.Function..::..ByteFieldSource

See Also

ByteFieldSource Members
Lucene.Net.Search.Function Namespace
for requirements" on the field. NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.


ByteFieldSource Members

[image] [image]

Lucene.Net Class Libraries
ByteFieldSource Members
ByteFieldSource Class Constructors Methods See Also Send Feedback

The ByteFieldSource type exposes the following members.

Constructors

 | Name | Description
Public method | ByteFieldSource(String) | Create a cached byte field source with default string-to-byte parser.
Public method | ByteFieldSource(String, ByteParser) | Create a cached byte field source with a specific string-to-byte parser.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

ByteFieldSource Class
Lucene.Net.Search.Function Namespace


ByteFieldSource Constructor

[image] [image]

Lucene.Net Class Libraries
ByteFieldSource Constructor
ByteFieldSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByteFieldSource(String) | Create a cached byte field source with default string-to-byte parser.
Public method | ByteFieldSource(String, ByteParser) | Create a cached byte field source with a specific string-to-byte parser.

See Also

ByteFieldSource Class
ByteFieldSource Members
Lucene.Net.Search.Function Namespace


ByteFieldSource Constructor (String)

[image]

Lucene.Net Class Libraries
ByteFieldSource Constructor (String)
ByteFieldSource Class See Also Send Feedback
Create a cached byte field source with default string-to-byte parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ByteFieldSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
ByteFieldSource(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.#ctor(System.String)"]

See Also

ByteFieldSource Class
ByteFieldSource Overload
Lucene.Net.Search.Function Namespace


ByteFieldSource Constructor (String, ByteParser)

[image]

Lucene.Net Class Libraries
ByteFieldSource Constructor (String, ByteParser)
ByteFieldSource Class See Also Send Feedback
Create a cached byte field source with a specific string-to-byte parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ByteFieldSource(
    string field,
    ByteParser parser
)
Visual Basic
Public Sub New ( _
    field As String, _
    parser As ByteParser _
)
Visual C++
public:
ByteFieldSource(
    String^ field,
    ByteParser^ parser
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.#ctor(System.String,Lucene.Net.Search.ByteParser)"]

parser
Type: Lucene.Net.Search..::..ByteParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.#ctor(System.String,Lucene.Net.Search.ByteParser)"]

See Also

ByteFieldSource Class
ByteFieldSource Overload
Lucene.Net.Search.Function Namespace


ByteFieldSource Methods

[image] [image]

Lucene.Net Class Libraries
ByteFieldSource Methods
ByteFieldSource Class See Also Send Feedback

The ByteFieldSource type exposes the following members.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

ByteFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceEquals Method

[image]

Lucene.Net Class Libraries
ByteFieldSource..::..CachedFieldSourceEquals Method
ByteFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Visual Basic
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Visual C++
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override

Parameters

o
Type: Lucene.Net.Search.Function..::..FieldCacheSource

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

See Also

ByteFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceHashCode Method

[image]

Lucene.Net Class Libraries
ByteFieldSource..::..CachedFieldSourceHashCode Method
ByteFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.CachedFieldSourceHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CachedFieldSourceHashCode()
Visual Basic
Public Overrides Function CachedFieldSourceHashCode As Integer
Visual C++
public:
virtual int CachedFieldSourceHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.CachedFieldSourceHashCode"]

See Also

ByteFieldSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
ByteFieldSource..::..Description Method
ByteFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.Description"]

See Also

ByteFieldSource Class
Lucene.Net.Search.Function Namespace


GetCachedFieldValues Method

[image]

Lucene.Net Class Libraries
ByteFieldSource..::..GetCachedFieldValues Method
ByteFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Visual Basic
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override

Parameters

cache
Type: Lucene.Net.Search..::..FieldCache

[Missing <param name="cache"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ByteFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

See Also

ByteFieldSource Class
Lucene.Net.Search.Function Namespace


CustomScoreProvider Class

[image]

Lucene.Net Class Libraries
CustomScoreProvider Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Function.CustomScoreProvider"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CustomScoreProvider
Visual Basic
Public Class CustomScoreProvider
Visual C++
public ref class CustomScoreProvider

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..CustomScoreProvider

See Also

CustomScoreProvider Members
Lucene.Net.Search.Function Namespace


CustomScoreProvider Members

[image] [image]

Lucene.Net Class Libraries
CustomScoreProvider Members
CustomScoreProvider Class Constructors Methods Fields See Also Send Feedback

The CustomScoreProvider type exposes the following members.

Constructors

 | Name | Description
Public method | CustomScoreProvider | Creates a new instance of the provider class for the given IndexReader.

Methods

Name | Description
Public method CustomExplain(Int32, Explanation, Explanation)
Explain the custom score. Whenever overriding {@link #customScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method CustomExplain(Int32, Explanation, array<Explanation>[]()[][])
Explain the custom score. Whenever overriding {@link #customScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method | CustomScore(Int32, Single, Single)
Public method CustomScore(Int32, Single, array<Single>[]()[][])
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other {@link #customScore(int, float, float) customScore()} method, which is simpler.

The default computation herein is a multiplication of given scores:

                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | reader |

See Also

CustomScoreProvider Class
Lucene.Net.Search.Function Namespace


CustomScoreProvider Constructor

[image]

Lucene.Net Class Libraries
CustomScoreProvider Constructor
CustomScoreProvider Class See Also Send Feedback
Creates a new instance of the provider class for the given IndexReader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CustomScoreProvider(
    IndexReader reader
)
Visual Basic
Public Sub New ( _
    reader As IndexReader _
)
Visual C++
public:
CustomScoreProvider(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreProvider.#ctor(Lucene.Net.Index.IndexReader)"]

See Also

CustomScoreProvider Class
Lucene.Net.Search.Function Namespace


CustomScoreProvider Fields

[image] [image]

Lucene.Net Class Libraries
CustomScoreProvider Fields
CustomScoreProvider Class See Also Send Feedback

The CustomScoreProvider type exposes the following members.

Fields

 | Name | Description
Protected field | reader |

See Also

CustomScoreProvider Class
Lucene.Net.Search.Function Namespace


reader Field

[image]

Lucene.Net Class Libraries
CustomScoreProvider..::..reader Field
CustomScoreProvider Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Function.CustomScoreProvider.reader"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IndexReader reader
Visual Basic
Protected reader As IndexReader
Visual C++
protected:
IndexReader^ reader

See Also

CustomScoreProvider Class
Lucene.Net.Search.Function Namespace


CustomScoreProvider Methods

[image] [image]

Lucene.Net Class Libraries
CustomScoreProvider Methods
CustomScoreProvider Class See Also Send Feedback

The CustomScoreProvider type exposes the following members.

Methods

Name | Description
Public method CustomExplain(Int32, Explanation, Explanation)
Explain the custom score. Whenever overriding {@link #customScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method CustomExplain(Int32, Explanation, array<Explanation>[]()[][])
Explain the custom score. Whenever overriding {@link #customScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method | CustomScore(Int32, Single, Single)
Public method CustomScore(Int32, Single, array<Single>[]()[][])
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other {@link #customScore(int, float, float) customScore()} method, which is simpler.

The default computation herein is a multiplication of given scores:

                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

CustomScoreProvider Class
Lucene.Net.Search.Function Namespace


CustomExplain Method

[image] [image]

Lucene.Net Class Libraries
CustomScoreProvider..::..CustomExplain Method
CustomScoreProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomExplain(Int32, Explanation, Explanation) | Explain the custom score. Whenever overriding {@link #customScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.
Public method | CustomExplain(Int32, Explanation, array<Explanation>[]()[][]) | Explain the custom score. Whenever overriding {@link #customScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

See Also

CustomScoreProvider Class
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace


CustomExplain Method (Int32, Explanation, Explanation)

[image]

Lucene.Net Class Libraries
CustomScoreProvider..::..CustomExplain Method (Int32, Explanation, Explanation)
CustomScoreProvider Class See Also Send Feedback
Explain the custom score. Whenever overriding {@link #customScore(int, float, float)}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation valSrcExpl
)
Visual Basic
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpl As Explanation _
) As Explanation
Visual C++
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    Explanation^ valSrcExpl
)

Parameters

doc
Type: System..::..Int32
doc being explained
subQueryExpl
Type: Lucene.Net.Search..::..Explanation
explanation for the sub-query part
valSrcExpl
Type: Lucene.Net.Search..::..Explanation
explanation for the value source part

Return Value

an explanation for the custom score

See Also

CustomScoreProvider Class
CustomExplain Overload
Lucene.Net.Search.Function Namespace


CustomExplain Method (Int32, Explanation, Explanation[])

[image]

Lucene.Net Class Libraries
CustomScoreProvider..::..CustomExplain Method (Int32, Explanation, array<Explanation>[]()[][])
CustomScoreProvider Class See Also Send Feedback
Explain the custom score. Whenever overriding {@link #customScore(int, float, float[])}, this method should also be overridden to provide the correct explanation for the part of the custom scoring.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation[] valSrcExpls
)
Visual Basic
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpls As Explanation() _
) As Explanation
Visual C++
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    array<Explanation^>^ valSrcExpls
)

Parameters

doc
Type: System..::..Int32
doc being explained
subQueryExpl
Type: Lucene.Net.Search..::..Explanation
explanation for the sub-query part
valSrcExpls
Type: array< Lucene.Net.Search..::..Explanation >[]()[][]
explanation for the value source part

Return Value

an explanation for the custom score

See Also

CustomScoreProvider Class
CustomExplain Overload
Lucene.Net.Search.Function Namespace


CustomScore Method

[image] [image]

Lucene.Net Class Libraries
CustomScoreProvider..::..CustomScore Method
CustomScoreProvider Class See Also Send Feedback

Overload List

Name | Description
Public method | CustomScore(Int32, Single, Single)
Public method CustomScore(Int32, Single, array<Single>[]()[][])
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other {@link #customScore(int, float, float) customScore()} method, which is simpler.

The default computation herein is a multiplication of given scores:

                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...

See Also

CustomScoreProvider Class
CustomScoreProvider Members
Lucene.Net.Search.Function Namespace


CustomScore Method (Int32, Single, Single)

[image]

Lucene.Net Class Libraries
CustomScoreProvider..::..CustomScore Method (Int32, Single, Single)
CustomScoreProvider Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreProvider.CustomScore(System.Int32,System.Single,System.Single)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
Visual Basic
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScore As Single _
) As Single
Visual C++
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreProvider.CustomScore(System.Int32,System.Single,System.Single)"]

subQueryScore
Type: System..::..Single

[Missing <param name="subQueryScore"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreProvider.CustomScore(System.Int32,System.Single,System.Single)"]

valSrcScore
Type: System..::..Single

[Missing <param name="valSrcScore"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreProvider.CustomScore(System.Int32,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreProvider.CustomScore(System.Int32,System.Single,System.Single)"]

See Also

CustomScoreProvider Class
CustomScore Overload
Lucene.Net.Search.Function Namespace


CustomScore Method (Int32, Single, Single[])

[image]

Lucene.Net Class Libraries
CustomScoreProvider..::..CustomScore Method (Int32, Single, array<Single>[]()[][])
CustomScoreProvider Class See Also Send Feedback
* Compute a custom score by the subQuery score and a number of ValueSourceQuery scores.

Subclasses can override this method to modify the custom score.

If your custom scoring is different than the default herein you should override at least one of the two customScore() methods. If the number of ValueSourceQueries is always < 2 it is sufficient to override the other {@link #customScore(int, float, float) customScore()} method, which is simpler.

The default computation herein is a multiplication of given scores:

                ModifiedScore = valSrcScore * valSrcScores[0] * valSrcScores[1] * ...

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float[] valSrcScores
)
Visual Basic
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScores As Single() _
) As Single
Visual C++
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    array<float>^ valSrcScores
)

Parameters

doc
Type: System..::..Int32
id of scored doc
subQueryScore
Type: System..::..Single
score of that doc by the subQuery
valSrcScores
Type: array< System..::..Single >[]()[][]
scores of that doc by the ValueSourceQuery

Return Value

custom score

See Also

CustomScoreProvider Class
CustomScore Overload
Lucene.Net.Search.Function Namespace


CustomScoreQuery Class

[image]

Lucene.Net Class Libraries
CustomScoreQuery Class
Members See Also Send Feedback
Query that sets document score as a programmatic function of several (sub) scores:
  1. the score of its subQuery (any query)
  2. (optional) the score of its ValueSourceQuery (or queries). For most simple/convenient use cases this query is likely to be a {@link Lucene.Net.Search.Function.FieldScoreQuery FieldScoreQuery}
Subclasses can modify the computation by overriding {@link #getCustomScoreProvider}.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class CustomScoreQuery : Query,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class CustomScoreQuery _
    Inherits Query _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class CustomScoreQuery : public Query,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Function..::..CustomScoreQuery

See Also

CustomScoreQuery Members
Lucene.Net.Search.Function Namespace


CustomScoreQuery Members

[image] [image]

Lucene.Net Class Libraries
CustomScoreQuery Members
CustomScoreQuery Class Constructors Methods See Also Send Feedback

The CustomScoreQuery type exposes the following members.

Constructors

 | Name | Description
Public method | CustomScoreQuery(Query) | Create a CustomScoreQuery over input subQuery.
Public method | CustomScoreQuery(Query, ValueSourceQuery) | Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.
Public method | CustomScoreQuery(Query, array<ValueSourceQuery>[]()[][]) | Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method CustomExplain(Int32, Explanation, Explanation) Obsolete.
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.
Public method CustomExplain(Int32, Explanation, array<Explanation>[]()[][]) Obsolete.
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.
Public method CustomScore(Int32, Single, Single) Obsolete.
Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. @see CustomScoreProvider#customScore(int,float,float)
Public method CustomScore(Int32, Single, array<Single>[]()[][]) Obsolete.
Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. see CustomScoreProvider#customScore(int,float,float[])
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Protected method | GetCustomScoreProvider
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsStrict
Checks if this is strict custom scoring. In strict custom scoring, the ValueSource part does not participate in weight normalization. This may be useful when one wants full control over how scores are modified, and does not care about normalizing by the ValueSource part. One particular case where this is useful if for testing this query.

Note: only has effect when the ValueSource part is not null.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
A short name of this query, used in {@link #ToString(String)}.
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetStrict
Set the strict mode of this query.
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


CustomScoreQuery Constructor

[image] [image]

Lucene.Net Class Libraries
CustomScoreQuery Constructor
CustomScoreQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomScoreQuery(Query) | Create a CustomScoreQuery over input subQuery.
Public method | CustomScoreQuery(Query, ValueSourceQuery) | Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.
Public method | CustomScoreQuery(Query, array<ValueSourceQuery>[]()[][]) | Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

See Also

CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace


CustomScoreQuery Constructor (Query)

[image]

Lucene.Net Class Libraries
CustomScoreQuery Constructor (Query)
CustomScoreQuery Class See Also Send Feedback
Create a CustomScoreQuery over input subQuery.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CustomScoreQuery(
    Query subQuery
)
Visual Basic
Public Sub New ( _
    subQuery As Query _
)
Visual C++
public:
CustomScoreQuery(
    Query^ subQuery
)

Parameters

subQuery
Type: Lucene.Net.Search..::..Query
the sub query whose scored is being customed. Must not be null.

See Also

CustomScoreQuery Class
CustomScoreQuery Overload
Lucene.Net.Search.Function Namespace


CustomScoreQuery Constructor (Query, ValueSourceQuery)

[image]

Lucene.Net Class Libraries
CustomScoreQuery Constructor (Query, ValueSourceQuery)
CustomScoreQuery Class See Also Send Feedback
Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CustomScoreQuery(
    Query subQuery,
    ValueSourceQuery valSrcQuery
)
Visual Basic
Public Sub New ( _
    subQuery As Query, _
    valSrcQuery As ValueSourceQuery _
)
Visual C++
public:
CustomScoreQuery(
    Query^ subQuery,
    ValueSourceQuery^ valSrcQuery
)

Parameters

subQuery
Type: Lucene.Net.Search..::..Query
the sub query whose score is being customed. Must not be null.
valSrcQuery
Type: Lucene.Net.Search.Function..::..ValueSourceQuery
a value source query whose scores are used in the custom score computation. For most simple/convineient use case this would be a {@link Lucene.Net.Search.Function.FieldScoreQuery FieldScoreQuery}. This parameter is optional - it can be null or even an empty array.

See Also

CustomScoreQuery Class
CustomScoreQuery Overload
Lucene.Net.Search.Function Namespace


CustomScoreQuery Constructor (Query, ValueSourceQuery[])

[image]

Lucene.Net Class Libraries
CustomScoreQuery Constructor (Query, array<ValueSourceQuery>[]()[][])
CustomScoreQuery Class See Also Send Feedback
Create a CustomScoreQuery over input subQuery and a {@link ValueSourceQuery}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CustomScoreQuery(
    Query subQuery,
    ValueSourceQuery[] valSrcQueries
)
Visual Basic
Public Sub New ( _
    subQuery As Query, _
    valSrcQueries As ValueSourceQuery() _
)
Visual C++
public:
CustomScoreQuery(
    Query^ subQuery,
    array<ValueSourceQuery^>^ valSrcQueries
)

Parameters

subQuery
Type: Lucene.Net.Search..::..Query
the sub query whose score is being customized. Must not be null.
valSrcQueries
Type: array< Lucene.Net.Search.Function..::..ValueSourceQuery >[]()[][]
value source queries whose scores are used in the custom score computation. For most simple/convenient use case these would be {@link Lucene.Net.Search.Function.FieldScoreQuery FieldScoreQueries}. This parameter is optional - it can be null or even an empty array.

See Also

CustomScoreQuery Class
CustomScoreQuery Overload
Lucene.Net.Search.Function Namespace


CustomScoreQuery Methods

[image] [image]

Lucene.Net Class Libraries
CustomScoreQuery Methods
CustomScoreQuery Class See Also Send Feedback

The CustomScoreQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method CustomExplain(Int32, Explanation, Explanation) Obsolete.
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.
Public method CustomExplain(Int32, Explanation, array<Explanation>[]()[][]) Obsolete.
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.
Public method CustomScore(Int32, Single, Single) Obsolete.
Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. @see CustomScoreProvider#customScore(int,float,float)
Public method CustomScore(Int32, Single, array<Single>[]()[][]) Obsolete.
Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. see CustomScoreProvider#customScore(int,float,float[])
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Protected method | GetCustomScoreProvider
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsStrict
Checks if this is strict custom scoring. In strict custom scoring, the ValueSource part does not participate in weight normalization. This may be useful when one wants full control over how scores are modified, and does not care about normalizing by the ValueSource part. One particular case where this is useful if for testing this query.

Note: only has effect when the ValueSource part is not null.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Name
A short name of this query, used in {@link #ToString(String)}.
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method SetStrict
Set the strict mode of this query.
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


Clone Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..Clone Method
CustomScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Clone"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CreateWeight Method
CustomScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


CustomExplain Method

[image] [image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CustomExplain Method
CustomScoreQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomExplain(Int32, Explanation, Explanation) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.
Public method | CustomExplain(Int32, Explanation, array<Explanation>[]()[][]) | Obsolete. Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.

See Also

CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace


CustomExplain Method (Int32, Explanation, Explanation)

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CustomExplain Method (Int32, Explanation, Explanation)
CustomScoreQuery Class See Also Send Feedback
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation valSrcExpl
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpl As Explanation _
) As Explanation
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    Explanation^ valSrcExpl
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation)"]

subQueryExpl
Type: Lucene.Net.Search..::..Explanation

[Missing <param name="subQueryExpl"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation)"]

valSrcExpl
Type: Lucene.Net.Search..::..Explanation

[Missing <param name="valSrcExpl"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation)"]

See Also

CustomScoreQuery Class
CustomExplain Overload
Lucene.Net.Search.Function Namespace


CustomExplain Method (Int32, Explanation, Explanation[])

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CustomExplain Method (Int32, Explanation, array<Explanation>[]()[][])
CustomScoreQuery Class See Also Send Feedback
Explain the custom score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.1.")]
public virtual Explanation CustomExplain(
    int doc,
    Explanation subQueryExpl,
    Explanation[] valSrcExpls
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.1.")> _
Public Overridable Function CustomExplain ( _
    doc As Integer, _
    subQueryExpl As Explanation, _
    valSrcExpls As Explanation() _
) As Explanation
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.1.")]
public:
virtual Explanation^ CustomExplain(
    int doc,
    Explanation^ subQueryExpl,
    array<Explanation^>^ valSrcExpls
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation[])"]

subQueryExpl
Type: Lucene.Net.Search..::..Explanation

[Missing <param name="subQueryExpl"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation[])"]

valSrcExpls
Type: array< Lucene.Net.Search..::..Explanation >[]()[][]

[Missing <param name="valSrcExpls"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomExplain(System.Int32,Lucene.Net.Search.Explanation,Lucene.Net.Search.Explanation[])"]

See Also

CustomScoreQuery Class
CustomExplain Overload
Lucene.Net.Search.Function Namespace


CustomScore Method

[image] [image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CustomScore Method
CustomScoreQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomScore(Int32, Single, Single) | Obsolete. Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. @see CustomScoreProvider#customScore(int,float,float)
Public method | CustomScore(Int32, Single, array<Single>[]()[][]) | Obsolete. Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. see CustomScoreProvider#customScore(int,float,float[])

See Also

CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace


CustomScore Method (Int32, Single, Single)

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CustomScore Method (Int32, Single, Single)
CustomScoreQuery Class See Also Send Feedback
Compute a custom score by the subQuery score and the ValueSourceQuery score. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. @see CustomScoreProvider#customScore(int,float,float)

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScore As Single _
) As Single
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    float valSrcScore
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single)"]

subQueryScore
Type: System..::..Single

[Missing <param name="subQueryScore"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single)"]

valSrcScore
Type: System..::..Single

[Missing <param name="valSrcScore"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single)"]

See Also

CustomScoreQuery Class
CustomScore Overload
Lucene.Net.Search.Function Namespace


CustomScore Method (Int32, Single, Single[])

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..CustomScore Method (Int32, Single, array<Single>[]()[][])
CustomScoreQuery Class See Also Send Feedback
Compute a custom score by the subQuery score and a number of ValueSourceQuery scores. The doc is relative to the current reader, which is unknown to CustomScoreQuery when using per-segment search (since Lucene 2.9). Please override {@link #getCustomScoreProvider} and return a subclass of {@link CustomScoreProvider} for the given {@link IndexReader}. see CustomScoreProvider#customScore(int,float,float[])

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Will be removed in Lucene 3.1")]
public virtual float CustomScore(
    int doc,
    float subQueryScore,
    float[] valSrcScores
)
Visual Basic
<ObsoleteAttribute("Will be removed in Lucene 3.1")> _
Public Overridable Function CustomScore ( _
    doc As Integer, _
    subQueryScore As Single, _
    valSrcScores As Single() _
) As Single
Visual C++
[ObsoleteAttribute(L"Will be removed in Lucene 3.1")]
public:
virtual float CustomScore(
    int doc,
    float subQueryScore,
    array<float>^ valSrcScores
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single[])"]

subQueryScore
Type: System..::..Single

[Missing <param name="subQueryScore"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single[])"]

valSrcScores
Type: array< System..::..Single >[]()[][]

[Missing <param name="valSrcScores"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.CustomScore(System.Int32,System.Single,System.Single[])"]

See Also

CustomScoreQuery Class
CustomScore Overload
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..Equals Method
CustomScoreQuery Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Equals(System.Object)"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..ExtractTerms Method
CustomScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


GetCustomScoreProvider Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..GetCustomScoreProvider Method
CustomScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.GetCustomScoreProvider(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected virtual CustomScoreProvider GetCustomScoreProvider(
    IndexReader reader
)
Visual Basic
Protected Overridable Function GetCustomScoreProvider ( _
    reader As IndexReader _
) As CustomScoreProvider
Visual C++
protected:
virtual CustomScoreProvider^ GetCustomScoreProvider(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.GetCustomScoreProvider(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.GetCustomScoreProvider(Lucene.Net.Index.IndexReader)"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..GetHashCode Method
CustomScoreQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.GetHashCode"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


IsStrict Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..IsStrict Method
CustomScoreQuery Class See Also Send Feedback
Checks if this is strict custom scoring. In strict custom scoring, the ValueSource part does not participate in weight normalization. This may be useful when one wants full control over how scores are modified, and does not care about normalizing by the ValueSource part. One particular case where this is useful if for testing this query.

Note: only has effect when the ValueSource part is not null.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsStrict()
Visual Basic
Public Overridable Function IsStrict As Boolean
Visual C++
public:
virtual bool IsStrict()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.IsStrict"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


Name Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..Name Method
CustomScoreQuery Class See Also Send Feedback
A short name of this query, used in {@link #ToString(String)}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Name()
Visual Basic
Public Overridable Function Name As String
Visual C++
public:
virtual String^ Name()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Name"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..Rewrite Method
CustomScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace


SetStrict Method

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..SetStrict Method
CustomScoreQuery Class See Also Send Feedback
Set the strict mode of this query.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetStrict(
    bool strict
)
Visual Basic
Public Overridable Sub SetStrict ( _
    strict As Boolean _
)
Visual C++
public:
virtual void SetStrict(
    bool strict
)

Parameters

strict
Type: System..::..Boolean
The strict mode to set.

See Also

CustomScoreQuery Class
Lucene.Net.Search.Function Namespace
CustomScoreQuery..::..IsStrict()()()()


ToString Method

[image] [image]

Lucene.Net Class Libraries
CustomScoreQuery..::..ToString Method
CustomScoreQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

CustomScoreQuery Class
CustomScoreQuery Members
Lucene.Net.Search.Function Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
CustomScoreQuery..::..ToString Method (String)
CustomScoreQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.CustomScoreQuery.ToString(System.String)"]

See Also

CustomScoreQuery Class
ToString Overload
Lucene.Net.Search.Function Namespace


DocValues Class

[image]

Lucene.Net Class Libraries
DocValues Class
Members See Also Send Feedback
Expert: represents field values as different types. Normally created via a {@link Lucene.Net.Search.Function.ValueSource ValueSuorce} for a particular field and reader.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class DocValues
Visual Basic
Public MustInherit Class DocValues
Visual C++
public ref class DocValues abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..DocValues

See Also

DocValues Members
Lucene.Net.Search.Function Namespace


DocValues Members

[image] [image]

Lucene.Net Class Libraries
DocValues Members
DocValues Class Constructors Methods See Also Send Feedback

The DocValues type exposes the following members.

Constructors

 | Name | Description
Protected method | DocValues | Initializes a new instance of the DocValues class

Methods

Name Description
Public method DoubleVal
Return doc value as a double.

Optional: DocValues implementation can (but don't have to) override this method.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
Explain the scoring value for the input doc.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FloatVal
Return doc value as a float.

Mandatory: every DocValues implementation must implement at least this method.

Public method GetAverageValue
Returns the average of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value. *

This operation is optional

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetInnerArray
Expert: for test purposes only, return the inner array of values, or null if not applicable.

Allows tests to verify that loaded values are:

  1. indeed cached/reused.
  2. stored in the expected size/type (byte/short/int/float).
Note: implementations of DocValues must override this method for these test elements to be tested, Otherwise the test would not fail, just print a warning.
Public method GetMaxValue
Returns the maximum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

This operation is optional

Public method GetMinValue
Returns the minimum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

This operation is optional

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IntVal
Return doc value as an int.

Optional: DocValues implementation can (but don't have to) override this method.

Public method LongVal
Return doc value as a long.

Optional: DocValues implementation can (but don't have to) override this method.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method StrVal
Return doc value as a string.

Optional: DocValues implementation can (but don't have to) override this method.

Public method ToString()()()()
Returns a String that represents the current Object.
(Inherited from Object.)
Public method ToString(Int32)
Return a string representation of a doc value, as reuired for Explanations.

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


DocValues Constructor

[image]

Lucene.Net Class Libraries
DocValues Constructor
DocValues Class See Also Send Feedback
Initializes a new instance of the DocValues class

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected DocValues()
Visual Basic
Protected Sub New
Visual C++
protected:
DocValues()

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


DocValues Methods

[image] [image]

Lucene.Net Class Libraries
DocValues Methods
DocValues Class See Also Send Feedback

The DocValues type exposes the following members.

Methods

Name Description
Public method DoubleVal
Return doc value as a double.

Optional: DocValues implementation can (but don't have to) override this method.

Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Explain
Explain the scoring value for the input doc.
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FloatVal
Return doc value as a float.

Mandatory: every DocValues implementation must implement at least this method.

Public method GetAverageValue
Returns the average of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value. *

This operation is optional

Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetInnerArray
Expert: for test purposes only, return the inner array of values, or null if not applicable.

Allows tests to verify that loaded values are:

  1. indeed cached/reused.
  2. stored in the expected size/type (byte/short/int/float).
Note: implementations of DocValues must override this method for these test elements to be tested, Otherwise the test would not fail, just print a warning.
Public method GetMaxValue
Returns the maximum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

This operation is optional

Public method GetMinValue
Returns the minimum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

This operation is optional

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IntVal
Return doc value as an int.

Optional: DocValues implementation can (but don't have to) override this method.

Public method LongVal
Return doc value as a long.

Optional: DocValues implementation can (but don't have to) override this method.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method StrVal
Return doc value as a string.

Optional: DocValues implementation can (but don't have to) override this method.

Public method ToString()()()()
Returns a String that represents the current Object.
(Inherited from Object.)
Public method ToString(Int32)
Return a string representation of a doc value, as reuired for Explanations.

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


DoubleVal Method

[image]

Lucene.Net Class Libraries
DocValues..::..DoubleVal Method
DocValues Class See Also Send Feedback
Return doc value as a double.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual double DoubleVal(
    int doc
)
Visual Basic
Public Overridable Function DoubleVal ( _
    doc As Integer _
) As Double
Visual C++
public:
virtual double DoubleVal(
    int doc
)

Parameters

doc
Type: System..::..Int32
document whose double value is requested.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.DoubleVal(System.Int32)"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


Explain Method

[image]

Lucene.Net Class Libraries
DocValues..::..Explain Method
DocValues Class See Also Send Feedback
Explain the scoring value for the input doc.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Explanation Explain(
    int doc
)
Visual Basic
Public Overridable Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
)

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.DocValues.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.Explain(System.Int32)"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


FloatVal Method

[image]

Lucene.Net Class Libraries
DocValues..::..FloatVal Method
DocValues Class See Also Send Feedback
Return doc value as a float.

Mandatory: every DocValues implementation must implement at least this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float FloatVal(
    int doc
)
Visual Basic
Public MustOverride Function FloatVal ( _
    doc As Integer _
) As Single
Visual C++
public:
virtual float FloatVal(
    int doc
) abstract

Parameters

doc
Type: System..::..Int32
document whose float value is requested.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.FloatVal(System.Int32)"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


GetAverageValue Method

[image]

Lucene.Net Class Libraries
DocValues..::..GetAverageValue Method
DocValues Class See Also Send Feedback
Returns the average of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value. *

This operation is optional

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetAverageValue()
Visual Basic
Public Overridable Function GetAverageValue As Single
Visual C++
public:
virtual float GetAverageValue()

Return Value

the average of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


GetInnerArray Method

[image]

Lucene.Net Class Libraries
DocValues..::..GetInnerArray Method
DocValues Class See Also Send Feedback
Expert: for test purposes only, return the inner array of values, or null if not applicable.

Allows tests to verify that loaded values are:

  1. indeed cached/reused.
  2. stored in the expected size/type (byte/short/int/float).
Note: implementations of DocValues must override this method for these test elements to be tested, Otherwise the test would not fail, just print a warning.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object GetInnerArray()
Visual Basic
Public Overridable Function GetInnerArray As Object
Visual C++
public:
virtual Object^ GetInnerArray()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.GetInnerArray"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


GetMaxValue Method

[image]

Lucene.Net Class Libraries
DocValues..::..GetMaxValue Method
DocValues Class See Also Send Feedback
Returns the maximum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

This operation is optional

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetMaxValue()
Visual Basic
Public Overridable Function GetMaxValue As Single
Visual C++
public:
virtual float GetMaxValue()

Return Value

the maximum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


GetMinValue Method

[image]

Lucene.Net Class Libraries
DocValues..::..GetMinValue Method
DocValues Class See Also Send Feedback
Returns the minimum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

This operation is optional

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual float GetMinValue()
Visual Basic
Public Overridable Function GetMinValue As Single
Visual C++
public:
virtual float GetMinValue()

Return Value

the minimum of all values or
CopyC#
Float.NaN
 if this DocValues instance does not contain any value.

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


IntVal Method

[image]

Lucene.Net Class Libraries
DocValues..::..IntVal Method
DocValues Class See Also Send Feedback
Return doc value as an int.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int IntVal(
    int doc
)
Visual Basic
Public Overridable Function IntVal ( _
    doc As Integer _
) As Integer
Visual C++
public:
virtual int IntVal(
    int doc
)

Parameters

doc
Type: System..::..Int32
document whose int value is requested.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.IntVal(System.Int32)"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


LongVal Method

[image]

Lucene.Net Class Libraries
DocValues..::..LongVal Method
DocValues Class See Also Send Feedback
Return doc value as a long.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long LongVal(
    int doc
)
Visual Basic
Public Overridable Function LongVal ( _
    doc As Integer _
) As Long
Visual C++
public:
virtual long long LongVal(
    int doc
)

Parameters

doc
Type: System..::..Int32
document whose long value is requested.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.LongVal(System.Int32)"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


StrVal Method

[image]

Lucene.Net Class Libraries
DocValues..::..StrVal Method
DocValues Class See Also Send Feedback
Return doc value as a string.

Optional: DocValues implementation can (but don't have to) override this method.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string StrVal(
    int doc
)
Visual Basic
Public Overridable Function StrVal ( _
    doc As Integer _
) As String
Visual C++
public:
virtual String^ StrVal(
    int doc
)

Parameters

doc
Type: System..::..Int32
document whose string value is requested.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.StrVal(System.Int32)"]

See Also

DocValues Class
Lucene.Net.Search.Function Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
DocValues..::..ToString Method
DocValues Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(Int32) | Return a string representation of a doc value, as reuired for Explanations.

See Also

DocValues Class
DocValues Members
Lucene.Net.Search.Function Namespace


ToString Method (Int32)

[image]

Lucene.Net Class Libraries
DocValues..::..ToString Method (Int32)
DocValues Class See Also Send Feedback
Return a string representation of a doc value, as reuired for Explanations.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string ToString(
    int doc
)
Visual Basic
Public MustOverride Function ToString ( _
    doc As Integer _
) As String
Visual C++
public:
virtual String^ ToString(
    int doc
) abstract

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Function.DocValues.ToString(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.DocValues.ToString(System.Int32)"]

See Also

DocValues Class
ToString Overload
Lucene.Net.Search.Function Namespace


FieldCacheSource Class

[image]

Lucene.Net Class Libraries
FieldCacheSource Class
Members See Also Send Feedback
Expert: A base class for ValueSource implementations that retrieve values for a single field from the {@link Lucene.Net.Search.FieldCache FieldCache}.

Fields used herein nust be indexed (doesn't matter if these fields are stored or not).

It is assumed that each such indexed field is untokenized, or at least has a single token in a document. For documents with multiple tokens of the same field, behavior is undefined (It is likely that current code would use the value of one of these tokens, but this is not guaranteed).

Document with no tokens in this field are assigned the

CopyC#
Zero
value.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class FieldCacheSource : ValueSource
Visual Basic
<SerializableAttribute> _
Public MustInherit Class FieldCacheSource _
    Inherits ValueSource
Visual C++
[SerializableAttribute]
public ref class FieldCacheSource abstract : public ValueSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..FieldCacheSource
Lucene.Net.Search.Function..::..ByteFieldSource
Lucene.Net.Search.Function..::..FloatFieldSource
Lucene.Net.Search.Function..::..IntFieldSource
Lucene.Net.Search.Function..::..ShortFieldSource

See Also

FieldCacheSource Members
Lucene.Net.Search.Function Namespace


FieldCacheSource Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheSource Members
FieldCacheSource Class Constructors Methods See Also Send Feedback

The FieldCacheSource type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCacheSource | Create a cached field source for the input field.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | Check if equals to another {@link FieldCacheSource}, already knowing that cache and field are equal.
Public method | CachedFieldSourceHashCode | Return a hash code of a {@link FieldCacheSource}, without the hash-codes of the field and the cache (those are taken care of elsewhere).
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | Return cached DocValues for input field and reader.
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


FieldCacheSource Constructor

[image]

Lucene.Net Class Libraries
FieldCacheSource Constructor
FieldCacheSource Class See Also Send Feedback
Create a cached field source for the input field.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
FieldCacheSource(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.#ctor(System.String)"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


FieldCacheSource Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheSource Methods
FieldCacheSource Class See Also Send Feedback

The FieldCacheSource type exposes the following members.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | Check if equals to another {@link FieldCacheSource}, already knowing that cache and field are equal.
Public method | CachedFieldSourceHashCode | Return a hash code of a {@link FieldCacheSource}, without the hash-codes of the field and the cache (those are taken care of elsewhere).
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | Return cached DocValues for input field and reader.
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceEquals Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..CachedFieldSourceEquals Method
FieldCacheSource Class See Also Send Feedback
Check if equals to another {@link FieldCacheSource}, already knowing that cache and field are equal.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool CachedFieldSourceEquals(
    FieldCacheSource other
)
Visual Basic
Public MustOverride Function CachedFieldSourceEquals ( _
    other As FieldCacheSource _
) As Boolean
Visual C++
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ other
) abstract

Parameters

other
Type: Lucene.Net.Search.Function..::..FieldCacheSource

[Missing <param name="other"/> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace
[!:Object.equals(java.lang.Object)]


CachedFieldSourceHashCode Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..CachedFieldSourceHashCode Method
FieldCacheSource Class See Also Send Feedback
Return a hash code of a {@link FieldCacheSource}, without the hash-codes of the field and the cache (those are taken care of elsewhere).

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int CachedFieldSourceHashCode()
Visual Basic
Public MustOverride Function CachedFieldSourceHashCode As Integer
Visual C++
public:
virtual int CachedFieldSourceHashCode() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.CachedFieldSourceHashCode"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace
[!:Object.hashCode()]


Description Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..Description Method
FieldCacheSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.Description"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..Equals Method
FieldCacheSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.Equals(System.Object)"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


GetCachedFieldValues Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..GetCachedFieldValues Method
FieldCacheSource Class See Also Send Feedback
Return cached DocValues for input field and reader.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Visual Basic
Public MustOverride Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) abstract

Parameters

cache
Type: Lucene.Net.Search..::..FieldCache
FieldCache so that values of a field are loaded once per reader (RAM allowing)
field
Type: System..::..String
Field for which values are required.
reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace
Lucene.Net.Search.Function..::..ValueSource


GetHashCode Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..GetHashCode Method
FieldCacheSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetHashCode"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


GetValues Method

[image]

Lucene.Net Class Libraries
FieldCacheSource..::..GetValues Method
FieldCacheSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetValues(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetValues(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetValues(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldCacheSource.GetValues(Lucene.Net.Index.IndexReader)"]

See Also

FieldCacheSource Class
Lucene.Net.Search.Function Namespace


FieldScoreQuery Class

[image]

Lucene.Net Class Libraries
FieldScoreQuery Class
Members See Also Send Feedback
A query that scores each document as the value of the numeric input field.

The query matches all documents, and scores each document according to the numeric value of that field.

It is assumed, and expected, that:

  • The field used here is indexed, and has exactly one token in every scored document.
  • Best if this field is un_tokenized.
  • That token is parsable to the selected type.

Combining this query in a FunctionQuery allows much freedom in affecting document scores. Note, that with this freedom comes responsibility: it is more than likely that the default Lucene scoring is superior in quality to scoring modified as explained here. However, in some cases, and certainly for research experiments, this capability may turn useful.

When contructing this query, select the appropriate type. That type should match the data stored in the field. So in fact the "right" type should be selected before indexing. Type selection has effect on the RAM usage:

  • {@link Type#BYTE} consumes 1 * maxDocs bytes.
  • {@link Type#SHORT} consumes 2 * maxDocs bytes.
  • {@link Type#INT} consumes 4 * maxDocs bytes.
  • {@link Type#FLOAT} consumes 8 * maxDocs bytes.

Caching: Values for the numeric field are loaded once and cached in memory for further use with the same IndexReader. To take advantage of this, it is extremely important to reuse index-readers or index-searchers, otherwise, for instance if for each query a new index reader is opened, large penalties would be paid for loading the field values into memory over and over again!

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FieldScoreQuery : ValueSourceQuery
Visual Basic
<SerializableAttribute> _
Public Class FieldScoreQuery _
    Inherits ValueSourceQuery
Visual C++
[SerializableAttribute]
public ref class FieldScoreQuery : public ValueSourceQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Function..::..ValueSourceQuery
Lucene.Net.Search.Function..::..FieldScoreQuery

See Also

FieldScoreQuery Members
Lucene.Net.Search.Function Namespace


FieldScoreQuery Members

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery Members
FieldScoreQuery Class Constructors Methods Properties See Also Send Feedback

The FieldScoreQuery type exposes the following members.

Constructors

Name Description
Public method FieldScoreQuery
Create a FieldScoreQuery - a query that scores each document as the value of the numeric input field.

The

CopyC#
type
param tells how to parse the field string values into a numeric score value.

Methods

Name | Description
Public method | Clone | (Inherited from ValueSourceQuery.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from ValueSourceQuery.)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Inherited from ValueSourceQuery.)
Public method | ExtractTerms | (Inherited from ValueSourceQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Inherited from ValueSourceQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from ValueSourceQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from ValueSourceQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Properties

 | Name | Description
Public property | valSrc_ForNUnit | (Inherited from ValueSourceQuery.)

See Also

FieldScoreQuery Class
Lucene.Net.Search.Function Namespace


FieldScoreQuery Constructor

[image]

Lucene.Net Class Libraries
FieldScoreQuery Constructor
FieldScoreQuery Class See Also Send Feedback
Create a FieldScoreQuery - a query that scores each document as the value of the numeric input field.

The

CopyC#
type
param tells how to parse the field string values into a numeric score value.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldScoreQuery(
    string field,
    FieldScoreQuery..::..Type type
)
Visual Basic
Public Sub New ( _
    field As String, _
    type As FieldScoreQuery..::..Type _
)
Visual C++
public:
FieldScoreQuery(
    String^ field,
    FieldScoreQuery..::..Type^ type
)

Parameters

field
Type: System..::..String
the numeric field to be used.
type
Type: Lucene.Net.Search.Function..::..FieldScoreQuery..::..Type
the type of the field: either {@link Type#BYTE}, {@link Type#SHORT}, {@link Type#INT}, or {@link Type#FLOAT}.

See Also

FieldScoreQuery Class
Lucene.Net.Search.Function Namespace


FieldScoreQuery Methods

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery Methods
FieldScoreQuery Class See Also Send Feedback

The FieldScoreQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Inherited from ValueSourceQuery.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from ValueSourceQuery.)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Inherited from ValueSourceQuery.)
Public method | ExtractTerms | (Inherited from ValueSourceQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Inherited from ValueSourceQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from ValueSourceQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from ValueSourceQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FieldScoreQuery Class
Lucene.Net.Search.Function Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery..::..ToString Method
FieldScoreQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from ValueSourceQuery.)

See Also

FieldScoreQuery Class
FieldScoreQuery Members
Lucene.Net.Search.Function Namespace


FieldScoreQuery Properties

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery Properties
FieldScoreQuery Class See Also Send Feedback

The FieldScoreQuery type exposes the following members.

Properties

 | Name | Description
Public property | valSrc_ForNUnit | (Inherited from ValueSourceQuery.)

See Also

FieldScoreQuery Class
Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Class

[image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type Class
FieldScoreQuery Class Members See Also Send Feedback
Type of score field, indicating how field values are interpreted/parsed.

The type selected at search search time should match the data stored in the field. Different types have different RAM requirements:

  • {@link #BYTE} consumes 1 * maxDocs bytes.
  • {@link #SHORT} consumes 2 * maxDocs bytes.
  • {@link #INT} consumes 4 * maxDocs bytes.
  • {@link #FLOAT} consumes 8 * maxDocs bytes.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class Type
Visual Basic
Public Class Type
Visual C++
public ref class Type

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..FieldScoreQuery..::..Type

See Also

FieldScoreQuery..::..Type Members
Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Members

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type Members
FieldScoreQuery..::..Type Class Methods Fields See Also Send Feedback

A query that scores each document as the value of the numeric input field.

The query matches all documents, and scores each document according to the numeric value of that field.

It is assumed, and expected, that:

  • The field used here is indexed, and has exactly one token in every scored document.
  • Best if this field is un_tokenized.
  • That token is parsable to the selected type.

Combining this query in a FunctionQuery allows much freedom in affecting document scores. Note, that with this freedom comes responsibility: it is more than likely that the default Lucene scoring is superior in quality to scoring modified as explained here. However, in some cases, and certainly for research experiments, this capability may turn useful.

When contructing this query, select the appropriate type. That type should match the data stored in the field. So in fact the "right" type should be selected before indexing. Type selection has effect on the RAM usage:

  • {@link Type#BYTE} consumes 1 * maxDocs bytes.
  • {@link Type#SHORT} consumes 2 * maxDocs bytes.
  • {@link Type#INT} consumes 4 * maxDocs bytes.
  • {@link Type#FLOAT} consumes 8 * maxDocs bytes.

Caching: Values for the numeric field are loaded once and cached in memory for further use with the same IndexReader. To take advantage of this, it is extremely important to reuse index-readers or index-searchers, otherwise, for instance if for each query a new index reader is opened, large penalties would be paid for loading the field values into memory over and over again!

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

The FieldScoreQuery..::..Type type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
BYTE | field values are interpreted as numeric byte values.
FLOAT | field values are interpreted as numeric float values.
INT | field values are interpreted as numeric int values.
SHORT | field values are interpreted as numeric short values.

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Fields

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type Fields
FieldScoreQuery..::..Type Class See Also Send Feedback

The FieldScoreQuery..::..Type type exposes the following members.

Fields

Name | Description
BYTE | field values are interpreted as numeric byte values.
FLOAT | field values are interpreted as numeric float values.
INT | field values are interpreted as numeric int values.
SHORT | field values are interpreted as numeric short values.

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


BYTE Field

[image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type..::..BYTE Field
FieldScoreQuery..::..Type Class See Also Send Feedback
field values are interpreted as numeric byte values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldScoreQuery..::..Type BYTE
Visual Basic
Public Shared ReadOnly BYTE As FieldScoreQuery..::..Type
Visual C++
public:
static initonly FieldScoreQuery..::..Type^ BYTE

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


FLOAT Field

[image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type..::..FLOAT Field
FieldScoreQuery..::..Type Class See Also Send Feedback
field values are interpreted as numeric float values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldScoreQuery..::..Type FLOAT
Visual Basic
Public Shared ReadOnly FLOAT As FieldScoreQuery..::..Type
Visual C++
public:
static initonly FieldScoreQuery..::..Type^ FLOAT

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


INT Field

[image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type..::..INT Field
FieldScoreQuery..::..Type Class See Also Send Feedback
field values are interpreted as numeric int values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldScoreQuery..::..Type INT
Visual Basic
Public Shared ReadOnly INT As FieldScoreQuery..::..Type
Visual C++
public:
static initonly FieldScoreQuery..::..Type^ INT

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


SHORT Field

[image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type..::..SHORT Field
FieldScoreQuery..::..Type Class See Also Send Feedback
field values are interpreted as numeric short values.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldScoreQuery..::..Type SHORT
Visual Basic
Public Shared ReadOnly SHORT As FieldScoreQuery..::..Type
Visual C++
public:
static initonly FieldScoreQuery..::..Type^ SHORT

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


FieldScoreQuery.Type Methods

[image] [image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type Methods
FieldScoreQuery..::..Type Class See Also Send Feedback

The FieldScoreQuery..::..Type type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldScoreQuery..::..Type..::..ToString Method
FieldScoreQuery..::..Type Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FieldScoreQuery.Type.ToString"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FieldScoreQuery.Type.ToString"]

See Also

FieldScoreQuery..::..Type Class
Lucene.Net.Search.Function Namespace


FloatFieldSource Class

[image]

Lucene.Net Class Libraries
FloatFieldSource Class
Members See Also Send Feedback
Expert: obtains float field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getFloats()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FloatFieldSource : FieldCacheSource
Visual Basic
<SerializableAttribute> _
Public Class FloatFieldSource _
    Inherits FieldCacheSource
Visual C++
[SerializableAttribute]
public ref class FloatFieldSource : public FieldCacheSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..FieldCacheSource
Lucene.Net.Search.Function..::..FloatFieldSource

See Also

FloatFieldSource Members
Lucene.Net.Search.Function Namespace
for requirements" on the field. NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.


FloatFieldSource Members

[image] [image]

Lucene.Net Class Libraries
FloatFieldSource Members
FloatFieldSource Class Constructors Methods See Also Send Feedback

The FloatFieldSource type exposes the following members.

Constructors

 | Name | Description
Public method | FloatFieldSource(String) | Create a cached float field source with default string-to-float parser.
Public method | FloatFieldSource(String, FloatParser) | Create a cached float field source with a specific string-to-float parser.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

FloatFieldSource Class
Lucene.Net.Search.Function Namespace


FloatFieldSource Constructor

[image] [image]

Lucene.Net Class Libraries
FloatFieldSource Constructor
FloatFieldSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FloatFieldSource(String) | Create a cached float field source with default string-to-float parser.
Public method | FloatFieldSource(String, FloatParser) | Create a cached float field source with a specific string-to-float parser.

See Also

FloatFieldSource Class
FloatFieldSource Members
Lucene.Net.Search.Function Namespace


FloatFieldSource Constructor (String)

[image]

Lucene.Net Class Libraries
FloatFieldSource Constructor (String)
FloatFieldSource Class See Also Send Feedback
Create a cached float field source with default string-to-float parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FloatFieldSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
FloatFieldSource(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.#ctor(System.String)"]

See Also

FloatFieldSource Class
FloatFieldSource Overload
Lucene.Net.Search.Function Namespace


FloatFieldSource Constructor (String, FloatParser)

[image]

Lucene.Net Class Libraries
FloatFieldSource Constructor (String, FloatParser)
FloatFieldSource Class See Also Send Feedback
Create a cached float field source with a specific string-to-float parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FloatFieldSource(
    string field,
    FloatParser parser
)
Visual Basic
Public Sub New ( _
    field As String, _
    parser As FloatParser _
)
Visual C++
public:
FloatFieldSource(
    String^ field,
    FloatParser^ parser
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.#ctor(System.String,Lucene.Net.Search.FloatParser)"]

parser
Type: Lucene.Net.Search..::..FloatParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.#ctor(System.String,Lucene.Net.Search.FloatParser)"]

See Also

FloatFieldSource Class
FloatFieldSource Overload
Lucene.Net.Search.Function Namespace


FloatFieldSource Methods

[image] [image]

Lucene.Net Class Libraries
FloatFieldSource Methods
FloatFieldSource Class See Also Send Feedback

The FloatFieldSource type exposes the following members.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

FloatFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceEquals Method

[image]

Lucene.Net Class Libraries
FloatFieldSource..::..CachedFieldSourceEquals Method
FloatFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Visual Basic
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Visual C++
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override

Parameters

o
Type: Lucene.Net.Search.Function..::..FieldCacheSource

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

See Also

FloatFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceHashCode Method

[image]

Lucene.Net Class Libraries
FloatFieldSource..::..CachedFieldSourceHashCode Method
FloatFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.CachedFieldSourceHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CachedFieldSourceHashCode()
Visual Basic
Public Overrides Function CachedFieldSourceHashCode As Integer
Visual C++
public:
virtual int CachedFieldSourceHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.CachedFieldSourceHashCode"]

See Also

FloatFieldSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
FloatFieldSource..::..Description Method
FloatFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.Description"]

See Also

FloatFieldSource Class
Lucene.Net.Search.Function Namespace


GetCachedFieldValues Method

[image]

Lucene.Net Class Libraries
FloatFieldSource..::..GetCachedFieldValues Method
FloatFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Visual Basic
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override

Parameters

cache
Type: Lucene.Net.Search..::..FieldCache

[Missing <param name="cache"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.FloatFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

See Also

FloatFieldSource Class
Lucene.Net.Search.Function Namespace


IntFieldSource Class

[image]

Lucene.Net Class Libraries
IntFieldSource Class
Members See Also Send Feedback
Expert: obtains int field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getInts()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class IntFieldSource : FieldCacheSource
Visual Basic
<SerializableAttribute> _
Public Class IntFieldSource _
    Inherits FieldCacheSource
Visual C++
[SerializableAttribute]
public ref class IntFieldSource : public FieldCacheSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..FieldCacheSource
Lucene.Net.Search.Function..::..IntFieldSource

See Also

IntFieldSource Members
Lucene.Net.Search.Function Namespace
for requirements on the field. NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.


IntFieldSource Members

[image] [image]

Lucene.Net Class Libraries
IntFieldSource Members
IntFieldSource Class Constructors Methods See Also Send Feedback

The IntFieldSource type exposes the following members.

Constructors

 | Name | Description
Public method | IntFieldSource(String) | Create a cached int field source with default string-to-int parser.
Public method | IntFieldSource(String, IntParser) | Create a cached int field source with a specific string-to-int parser.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

IntFieldSource Class
Lucene.Net.Search.Function Namespace


IntFieldSource Constructor

[image] [image]

Lucene.Net Class Libraries
IntFieldSource Constructor
IntFieldSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntFieldSource(String) | Create a cached int field source with default string-to-int parser.
Public method | IntFieldSource(String, IntParser) | Create a cached int field source with a specific string-to-int parser.

See Also

IntFieldSource Class
IntFieldSource Members
Lucene.Net.Search.Function Namespace


IntFieldSource Constructor (String)

[image]

Lucene.Net Class Libraries
IntFieldSource Constructor (String)
IntFieldSource Class See Also Send Feedback
Create a cached int field source with default string-to-int parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IntFieldSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
IntFieldSource(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.#ctor(System.String)"]

See Also

IntFieldSource Class
IntFieldSource Overload
Lucene.Net.Search.Function Namespace


IntFieldSource Constructor (String, IntParser)

[image]

Lucene.Net Class Libraries
IntFieldSource Constructor (String, IntParser)
IntFieldSource Class See Also Send Feedback
Create a cached int field source with a specific string-to-int parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public IntFieldSource(
    string field,
    IntParser parser
)
Visual Basic
Public Sub New ( _
    field As String, _
    parser As IntParser _
)
Visual C++
public:
IntFieldSource(
    String^ field,
    IntParser^ parser
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.#ctor(System.String,Lucene.Net.Search.IntParser)"]

parser
Type: Lucene.Net.Search..::..IntParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.#ctor(System.String,Lucene.Net.Search.IntParser)"]

See Also

IntFieldSource Class
IntFieldSource Overload
Lucene.Net.Search.Function Namespace


IntFieldSource Methods

[image] [image]

Lucene.Net Class Libraries
IntFieldSource Methods
IntFieldSource Class See Also Send Feedback

The IntFieldSource type exposes the following members.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

IntFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceEquals Method

[image]

Lucene.Net Class Libraries
IntFieldSource..::..CachedFieldSourceEquals Method
IntFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Visual Basic
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Visual C++
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override

Parameters

o
Type: Lucene.Net.Search.Function..::..FieldCacheSource

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

See Also

IntFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceHashCode Method

[image]

Lucene.Net Class Libraries
IntFieldSource..::..CachedFieldSourceHashCode Method
IntFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.CachedFieldSourceHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CachedFieldSourceHashCode()
Visual Basic
Public Overrides Function CachedFieldSourceHashCode As Integer
Visual C++
public:
virtual int CachedFieldSourceHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.CachedFieldSourceHashCode"]

See Also

IntFieldSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
IntFieldSource..::..Description Method
IntFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.Description"]

See Also

IntFieldSource Class
Lucene.Net.Search.Function Namespace


GetCachedFieldValues Method

[image]

Lucene.Net Class Libraries
IntFieldSource..::..GetCachedFieldValues Method
IntFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Visual Basic
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override

Parameters

cache
Type: Lucene.Net.Search..::..FieldCache

[Missing <param name="cache"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.IntFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

See Also

IntFieldSource Class
Lucene.Net.Search.Function Namespace


MultiValueSource Class

[image]

Lucene.Net Class Libraries
MultiValueSource Class
Members See Also Send Feedback
This class wraps another ValueSource, but protects against accidental double RAM usage in FieldCache when a composite reader is passed to {@link #getValues}.

NOTE: this class adds a CPU penalty to every lookup, as it must resolve the incoming document to the right sub-reader using a binary search.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("This class is temporary, to ease the migration to segment-based searching. Please change your code to not pass composite readers to these APIs. ")]
public sealed class MultiValueSource : ValueSource
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("This class is temporary, to ease the migration to segment-based searching. Please change your code to not pass composite readers to these APIs. ")> _
Public NotInheritable Class MultiValueSource _
    Inherits ValueSource
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"This class is temporary, to ease the migration to segment-based searching. Please change your code to not pass composite readers to these APIs. ")]
public ref class MultiValueSource sealed : public ValueSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..MultiValueSource

See Also

MultiValueSource Members
Lucene.Net.Search.Function Namespace


MultiValueSource Members

[image] [image]

Lucene.Net Class Libraries
MultiValueSource Members
MultiValueSource Class Constructors Methods See Also Send Feedback

The MultiValueSource type exposes the following members.

Constructors

 | Name | Description
Public method | MultiValueSource | Initializes a new instance of the MultiValueSource class

Methods

 | Name | Description
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


MultiValueSource Constructor

[image]

Lucene.Net Class Libraries
MultiValueSource Constructor
MultiValueSource Class See Also Send Feedback
Initializes a new instance of the MultiValueSource class

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MultiValueSource(
    ValueSource other
)
Visual Basic
Public Sub New ( _
    other As ValueSource _
)
Visual C++
public:
MultiValueSource(
    ValueSource^ other
)

Parameters

other
Type: Lucene.Net.Search.Function..::..ValueSource

[Missing <param name="other"/> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.#ctor(Lucene.Net.Search.Function.ValueSource)"]

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


MultiValueSource Methods

[image] [image]

Lucene.Net Class Libraries
MultiValueSource Methods
MultiValueSource Class See Also Send Feedback

The MultiValueSource type exposes the following members.

Methods

 | Name | Description
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
MultiValueSource..::..Description Method
MultiValueSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.Description"]

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
MultiValueSource..::..Equals Method
MultiValueSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.Equals(System.Object)"]

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MultiValueSource..::..GetHashCode Method
MultiValueSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.GetHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.GetHashCode"]

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


GetValues Method

[image]

Lucene.Net Class Libraries
MultiValueSource..::..GetValues Method
MultiValueSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.GetValues(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetValues(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.GetValues(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.MultiValueSource.GetValues(Lucene.Net.Index.IndexReader)"]

See Also

MultiValueSource Class
Lucene.Net.Search.Function Namespace


OrdFieldSource Class

[image]

Lucene.Net Class Libraries
OrdFieldSource Class
Members See Also Send Feedback
Expert: obtains the ordinal of the field value from the default Lucene {@link Lucene.Net.Search.FieldCache Fieldcache} using getStringIndex().

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.

Example:
If there were only three field values: "apple","banana","pear"
then ord("apple")=1, ord("banana")=2, ord("pear")=3

WARNING: ord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class OrdFieldSource : ValueSource
Visual Basic
<SerializableAttribute> _
Public Class OrdFieldSource _
    Inherits ValueSource
Visual C++
[SerializableAttribute]
public ref class OrdFieldSource : public ValueSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..OrdFieldSource

See Also

OrdFieldSource Members
Lucene.Net.Search.Function Namespace


OrdFieldSource Members

[image] [image]

Lucene.Net Class Libraries
OrdFieldSource Members
OrdFieldSource Class Constructors Methods Fields See Also Send Feedback

The OrdFieldSource type exposes the following members.

Constructors

 | Name | Description
Public method | OrdFieldSource | Constructor for a certain field.

Methods

 | Name | Description
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

Fields

 | Name | Description
Protected field | field |

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


OrdFieldSource Constructor

[image]

Lucene.Net Class Libraries
OrdFieldSource Constructor
OrdFieldSource Class See Also Send Feedback
Constructor for a certain field.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OrdFieldSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
OrdFieldSource(
    String^ field
)

Parameters

field
Type: System..::..String
field whose values order is used.

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


OrdFieldSource Fields

[image] [image]

Lucene.Net Class Libraries
OrdFieldSource Fields
OrdFieldSource Class See Also Send Feedback

The OrdFieldSource type exposes the following members.

Fields

 | Name | Description
Protected field | field |

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


field Field

[image]

Lucene.Net Class Libraries
OrdFieldSource..::..field Field
OrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Function.OrdFieldSource.field"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string field
Visual Basic
Protected Friend field As String
Visual C++
protected public:
String^ field

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


OrdFieldSource Methods

[image] [image]

Lucene.Net Class Libraries
OrdFieldSource Methods
OrdFieldSource Class See Also Send Feedback

The OrdFieldSource type exposes the following members.

Methods

 | Name | Description
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
OrdFieldSource..::..Description Method
OrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.Description"]

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
OrdFieldSource..::..Equals Method
OrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.Equals(System.Object)"]

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
OrdFieldSource..::..GetHashCode Method
OrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.GetHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.GetHashCode"]

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


GetValues Method

[image]

Lucene.Net Class Libraries
OrdFieldSource..::..GetValues Method
OrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.GetValues(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetValues(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.GetValues(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.OrdFieldSource.GetValues(Lucene.Net.Index.IndexReader)"]

See Also

OrdFieldSource Class
Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Class

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource Class
Members See Also Send Feedback
Expert: obtains the ordinal of the field value from the default Lucene {@link Lucene.Net.Search.FieldCache FieldCache} using getStringIndex() and reverses the order.

The native lucene index order is used to assign an ordinal value for each field value.

Field values (terms) are lexicographically ordered by unicode value, and numbered starting at 1.
Example of reverse ordinal (rord):
If there were only three field values: "apple","banana","pear"
then rord("apple")=3, rord("banana")=2, ord("pear")=1

WARNING: rord() depends on the position in an index and can thus change when other documents are inserted or deleted, or if a MultiSearcher is used.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ReverseOrdFieldSource : ValueSource
Visual Basic
<SerializableAttribute> _
Public Class ReverseOrdFieldSource _
    Inherits ValueSource
Visual C++
[SerializableAttribute]
public ref class ReverseOrdFieldSource : public ValueSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..ReverseOrdFieldSource

See Also

ReverseOrdFieldSource Members
Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Members

[image] [image]

Lucene.Net Class Libraries
ReverseOrdFieldSource Members
ReverseOrdFieldSource Class Constructors Methods Fields See Also Send Feedback

The ReverseOrdFieldSource type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseOrdFieldSource | Contructor for a certain field.

Methods

 | Name | Description
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

Fields

 | Name | Description
Public field | field |

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Constructor

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource Constructor
ReverseOrdFieldSource Class See Also Send Feedback
Contructor for a certain field.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ReverseOrdFieldSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
ReverseOrdFieldSource(
    String^ field
)

Parameters

field
Type: System..::..String
field whose values reverse order is used.

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Fields

[image] [image]

Lucene.Net Class Libraries
ReverseOrdFieldSource Fields
ReverseOrdFieldSource Class See Also Send Feedback

The ReverseOrdFieldSource type exposes the following members.

Fields

 | Name | Description
Public field | field |

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


field Field

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource..::..field Field
ReverseOrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Function.ReverseOrdFieldSource.field"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string field
Visual Basic
Public field As String
Visual C++
public:
String^ field

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


ReverseOrdFieldSource Methods

[image] [image]

Lucene.Net Class Libraries
ReverseOrdFieldSource Methods
ReverseOrdFieldSource Class See Also Send Feedback

The ReverseOrdFieldSource type exposes the following members.

Methods

 | Name | Description
Public method | Description | (Overrides ValueSource..::..Description()()()().)
Public method | Equals | (Overrides ValueSource..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueSource..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Overrides ValueSource..::..GetValues(IndexReader).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource..::..Description Method
ReverseOrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.Description"]

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource..::..Equals Method
ReverseOrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.Equals(System.Object)"]

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource..::..GetHashCode Method
ReverseOrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.GetHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.GetHashCode"]

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


GetValues Method

[image]

Lucene.Net Class Libraries
ReverseOrdFieldSource..::..GetValues Method
ReverseOrdFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.GetValues(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetValues(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetValues ( _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.GetValues(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ReverseOrdFieldSource.GetValues(Lucene.Net.Index.IndexReader)"]

See Also

ReverseOrdFieldSource Class
Lucene.Net.Search.Function Namespace


ShortFieldSource Class

[image]

Lucene.Net Class Libraries
ShortFieldSource Class
Members See Also Send Feedback
Expert: obtains short field values from the {@link Lucene.Net.Search.FieldCache FieldCache} using
CopyC#
getShorts()
 and makes those values available as other numeric types, casting as needed.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ShortFieldSource : FieldCacheSource
Visual Basic
<SerializableAttribute> _
Public Class ShortFieldSource _
    Inherits FieldCacheSource
Visual C++
[SerializableAttribute]
public ref class ShortFieldSource : public FieldCacheSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..FieldCacheSource
Lucene.Net.Search.Function..::..ShortFieldSource

See Also

ShortFieldSource Members
Lucene.Net.Search.Function Namespace
for requirements on the field. NOTE: with the switch in 2.9 to segment-based searching, if {@link #getValues} is invoked with a composite (multi-segment) reader, this can easily cause double RAM usage for the values in the FieldCache. It's best to switch your application to pass only atomic (single segment) readers to this API. Alternatively, for a short-term fix, you could wrap your ValueSource using {@link MultiValueSource}, which costs more CPU per lookup but will not consume double the FieldCache RAM.


ShortFieldSource Members

[image] [image]

Lucene.Net Class Libraries
ShortFieldSource Members
ShortFieldSource Class Constructors Methods See Also Send Feedback

The ShortFieldSource type exposes the following members.

Constructors

 | Name | Description
Public method | ShortFieldSource(String) | Create a cached short field source with default string-to-short parser.
Public method | ShortFieldSource(String, ShortParser) | Create a cached short field source with a specific string-to-short parser.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

ShortFieldSource Class
Lucene.Net.Search.Function Namespace


ShortFieldSource Constructor

[image] [image]

Lucene.Net Class Libraries
ShortFieldSource Constructor
ShortFieldSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShortFieldSource(String) | Create a cached short field source with default string-to-short parser.
Public method | ShortFieldSource(String, ShortParser) | Create a cached short field source with a specific string-to-short parser.

See Also

ShortFieldSource Class
ShortFieldSource Members
Lucene.Net.Search.Function Namespace


ShortFieldSource Constructor (String)

[image]

Lucene.Net Class Libraries
ShortFieldSource Constructor (String)
ShortFieldSource Class See Also Send Feedback
Create a cached short field source with default string-to-short parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ShortFieldSource(
    string field
)
Visual Basic
Public Sub New ( _
    field As String _
)
Visual C++
public:
ShortFieldSource(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.#ctor(System.String)"]

See Also

ShortFieldSource Class
ShortFieldSource Overload
Lucene.Net.Search.Function Namespace


ShortFieldSource Constructor (String, ShortParser)

[image]

Lucene.Net Class Libraries
ShortFieldSource Constructor (String, ShortParser)
ShortFieldSource Class See Also Send Feedback
Create a cached short field source with a specific string-to-short parser.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ShortFieldSource(
    string field,
    ShortParser parser
)
Visual Basic
Public Sub New ( _
    field As String, _
    parser As ShortParser _
)
Visual C++
public:
ShortFieldSource(
    String^ field,
    ShortParser^ parser
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.#ctor(System.String,Lucene.Net.Search.ShortParser)"]

parser
Type: Lucene.Net.Search..::..ShortParser

[Missing <param name="parser"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.#ctor(System.String,Lucene.Net.Search.ShortParser)"]

See Also

ShortFieldSource Class
ShortFieldSource Overload
Lucene.Net.Search.Function Namespace


ShortFieldSource Methods

[image] [image]

Lucene.Net Class Libraries
ShortFieldSource Methods
ShortFieldSource Class See Also Send Feedback

The ShortFieldSource type exposes the following members.

Methods

 | Name | Description
Public method | CachedFieldSourceEquals | (Overrides FieldCacheSource..::..CachedFieldSourceEquals(FieldCacheSource).)
Public method | CachedFieldSourceHashCode | (Overrides FieldCacheSource..::..CachedFieldSourceHashCode()()()().)
Public method | Description | (Overrides FieldCacheSource..::..Description()()()().)
Public method | Equals | (Inherited from FieldCacheSource.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedFieldValues | (Overrides FieldCacheSource..::..GetCachedFieldValues(FieldCache, String, IndexReader).)
Public method | GetHashCode | (Inherited from FieldCacheSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | (Inherited from FieldCacheSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from ValueSource.)

See Also

ShortFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceEquals Method

[image]

Lucene.Net Class Libraries
ShortFieldSource..::..CachedFieldSourceEquals Method
ShortFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool CachedFieldSourceEquals(
    FieldCacheSource o
)
Visual Basic
Public Overrides Function CachedFieldSourceEquals ( _
    o As FieldCacheSource _
) As Boolean
Visual C++
public:
virtual bool CachedFieldSourceEquals(
    FieldCacheSource^ o
) override

Parameters

o
Type: Lucene.Net.Search.Function..::..FieldCacheSource

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.CachedFieldSourceEquals(Lucene.Net.Search.Function.FieldCacheSource)"]

See Also

ShortFieldSource Class
Lucene.Net.Search.Function Namespace


CachedFieldSourceHashCode Method

[image]

Lucene.Net Class Libraries
ShortFieldSource..::..CachedFieldSourceHashCode Method
ShortFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.CachedFieldSourceHashCode"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int CachedFieldSourceHashCode()
Visual Basic
Public Overrides Function CachedFieldSourceHashCode As Integer
Visual C++
public:
virtual int CachedFieldSourceHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.CachedFieldSourceHashCode"]

See Also

ShortFieldSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
ShortFieldSource..::..Description Method
ShortFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.Description"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Description()
Visual Basic
Public Overrides Function Description As String
Visual C++
public:
virtual String^ Description() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.Description"]

See Also

ShortFieldSource Class
Lucene.Net.Search.Function Namespace


GetCachedFieldValues Method

[image]

Lucene.Net Class Libraries
ShortFieldSource..::..GetCachedFieldValues Method
ShortFieldSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocValues GetCachedFieldValues(
    FieldCache cache,
    string field,
    IndexReader reader
)
Visual Basic
Public Overrides Function GetCachedFieldValues ( _
    cache As FieldCache, _
    field As String, _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetCachedFieldValues(
    FieldCache^ cache,
    String^ field,
    IndexReader^ reader
) override

Parameters

cache
Type: Lucene.Net.Search..::..FieldCache

[Missing <param name="cache"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ShortFieldSource.GetCachedFieldValues(Lucene.Net.Search.FieldCache,System.String,Lucene.Net.Index.IndexReader)"]

See Also

ShortFieldSource Class
Lucene.Net.Search.Function Namespace


ValueSource Class

[image]

Lucene.Net Class Libraries
ValueSource Class
Members See Also Send Feedback
Expert: source of values for basic function queries.

At its default/simplest form, values - one per doc - are used as the score of that doc.

Values are instantiated as {@link Lucene.Net.Search.Function.DocValues DocValues} for a particular reader.

ValueSource implementations differ in RAM requirements: it would always be a factor of the number of documents, but for each document the number of bytes can be 1, 2, 4, or 8.

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class ValueSource
Visual Basic
<SerializableAttribute> _
Public MustInherit Class ValueSource
Visual C++
[SerializableAttribute]
public ref class ValueSource abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Function..::..ValueSource
Lucene.Net.Search.Function..::..FieldCacheSource
Lucene.Net.Search.Function..::..MultiValueSource
Lucene.Net.Search.Function..::..OrdFieldSource
Lucene.Net.Search.Function..::..ReverseOrdFieldSource

See Also

ValueSource Members
Lucene.Net.Search.Function Namespace


ValueSource Members

[image] [image]

Lucene.Net Class Libraries
ValueSource Members
ValueSource Class Constructors Methods See Also Send Feedback

The ValueSource type exposes the following members.

Constructors

 | Name | Description
Protected method | ValueSource | Initializes a new instance of the ValueSource class

Methods

 | Name | Description
Public method | Description | description of field, used in explain()
Public method | Equals | Needed for possible caching of query results - used by {@link ValueSourceQuery#equals(Object)}. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Needed for possible caching of query results - used by {@link ValueSourceQuery#hashCode()}. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Return the DocValues used by the function query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace


ValueSource Constructor

[image]

Lucene.Net Class Libraries
ValueSource Constructor
ValueSource Class See Also Send Feedback
Initializes a new instance of the ValueSource class

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected ValueSource()
Visual Basic
Protected Sub New
Visual C++
protected:
ValueSource()

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace


ValueSource Methods

[image] [image]

Lucene.Net Class Libraries
ValueSource Methods
ValueSource Class See Also Send Feedback

The ValueSource type exposes the following members.

Methods

 | Name | Description
Public method | Description | description of field, used in explain()
Public method | Equals | Needed for possible caching of query results - used by {@link ValueSourceQuery#equals(Object)}. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Needed for possible caching of query results - used by {@link ValueSourceQuery#hashCode()}. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Return the DocValues used by the function query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace


Description Method

[image]

Lucene.Net Class Libraries
ValueSource..::..Description Method
ValueSource Class See Also Send Feedback
description of field, used in explain()

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string Description()
Visual Basic
Public MustOverride Function Description As String
Visual C++
public:
virtual String^ Description() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSource.Description"]

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
ValueSource..::..Equals Method
ValueSource Class See Also Send Feedback
Needed for possible caching of query results - used by {@link ValueSourceQuery#equals(Object)}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Equals(
    Object o
)
Visual Basic
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) abstract override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.ValueSource.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSource.Equals(System.Object)"]

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace
[!:Object.equals(Object)]


GetHashCode Method

[image]

Lucene.Net Class Libraries
ValueSource..::..GetHashCode Method
ValueSource Class See Also Send Feedback
Needed for possible caching of query results - used by {@link ValueSourceQuery#hashCode()}.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetHashCode()
Visual Basic
Public MustOverride Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() abstract override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSource.GetHashCode"]

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace
[!:Object.hashCode()]


GetValues Method

[image]

Lucene.Net Class Libraries
ValueSource..::..GetValues Method
ValueSource Class See Also Send Feedback
Return the DocValues used by the function query.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract DocValues GetValues(
    IndexReader reader
)
Visual Basic
Public MustOverride Function GetValues ( _
    reader As IndexReader _
) As DocValues
Visual C++
public:
virtual DocValues^ GetValues(
    IndexReader^ reader
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
the IndexReader used to read these values. If any caching is involved, that caching would also be IndexReader based.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSource.GetValues(Lucene.Net.Index.IndexReader)"]

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace


ToString Method

[image]

Lucene.Net Class Libraries
ValueSource..::..ToString Method
ValueSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ValueSource.ToString"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSource.ToString"]

See Also

ValueSource Class
Lucene.Net.Search.Function Namespace


ValueSourceQuery Class

[image]

Lucene.Net Class Libraries
ValueSourceQuery Class
Members See Also Send Feedback
Expert: A Query that sets the scores of document to the values obtained from a {@link Lucene.Net.Search.Function.ValueSource ValueSource}.

This query provides a score for each and every undeleted document in the index.

The value source can be based on a (cached) value of an indexed field, but it can also be based on an external source, e.g. values read from an external database.

Score is set as: Score(doc,query) = query.getBoost()2 * valueSource(doc).

WARNING: The status of the Search.Function package is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class ValueSourceQuery : Query
Visual Basic
<SerializableAttribute> _
Public Class ValueSourceQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class ValueSourceQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Function..::..ValueSourceQuery
Lucene.Net.Search.Function..::..FieldScoreQuery

See Also

ValueSourceQuery Members
Lucene.Net.Search.Function Namespace


ValueSourceQuery Members

[image] [image]

Lucene.Net Class Libraries
ValueSourceQuery Members
ValueSourceQuery Class Constructors Methods Properties See Also Send Feedback

The ValueSourceQuery type exposes the following members.

Constructors

 | Name | Description
Public method | ValueSourceQuery | Create a value source query

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Properties

 | Name | Description
Public property | valSrc_ForNUnit |

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


ValueSourceQuery Constructor

[image]

Lucene.Net Class Libraries
ValueSourceQuery Constructor
ValueSourceQuery Class See Also Send Feedback
Create a value source query

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueSourceQuery(
    ValueSource valSrc
)
Visual Basic
Public Sub New ( _
    valSrc As ValueSource _
)
Visual C++
public:
ValueSourceQuery(
    ValueSource^ valSrc
)

Parameters

valSrc
Type: Lucene.Net.Search.Function..::..ValueSource
provides the values defines the function to be used for scoring

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


ValueSourceQuery Methods

[image] [image]

Lucene.Net Class Libraries
ValueSourceQuery Methods
ValueSourceQuery Class See Also Send Feedback

The ValueSourceQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method Equals
Returns true if
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetHashCode
Returns a hash code value for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


Clone Method

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..Clone Method
ValueSourceQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Clone"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..CreateWeight Method
ValueSourceQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


Equals Method

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..Equals Method
ValueSourceQuery Class See Also Send Feedback
Returns true if
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Equals(System.Object)"]

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..ExtractTerms Method
ValueSourceQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..GetHashCode Method
ValueSourceQuery Class See Also Send Feedback
Returns a hash code value for this object.

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.GetHashCode"]

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..Rewrite Method
ValueSourceQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
ValueSourceQuery..::..ToString Method
ValueSourceQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

ValueSourceQuery Class
ValueSourceQuery Members
Lucene.Net.Search.Function Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..ToString Method (String)
ValueSourceQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Function.ValueSourceQuery.ToString(System.String)"]

See Also

ValueSourceQuery Class
ToString Overload
Lucene.Net.Search.Function Namespace


ValueSourceQuery Properties

[image] [image]

Lucene.Net Class Libraries
ValueSourceQuery Properties
ValueSourceQuery Class See Also Send Feedback

The ValueSourceQuery type exposes the following members.

Properties

 | Name | Description
Public property | valSrc_ForNUnit |

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


valSrc_ForNUnit Property

[image]

Lucene.Net Class Libraries
ValueSourceQuery..::..valSrc_ForNUnit Property
ValueSourceQuery Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Function.ValueSourceQuery.valSrc_ForNUnit"]

Namespace: Lucene.Net.Search.Function
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ValueSource valSrc_ForNUnit { get; }
Visual Basic
Public ReadOnly Property valSrc_ForNUnit As ValueSource
    Get
Visual C++
public:
property ValueSource^ valSrc_ForNUnit {
    ValueSource^ get ();
}

See Also

ValueSourceQuery Class
Lucene.Net.Search.Function Namespace


Lucene.Net.Search.Payloads Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.Payloads Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.Payloads"]

Classes

 | Class | Description
Public class | AveragePayloadFunction | Calculate the final score as the average score of all payloads seen. Is thread safe and completely reusable.
Public class | BoostingTermQuery | Obsolete. The BoostingTermQuery is very similar to the {@link Lucene.Net.Search.Spans.SpanTermQuery} except that it factors in the value of the payload located at each of the positions where the {@link Lucene.Net.Index.Term} occurs. In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default. Payload scores are averaged across term occurrences in the document.
Protected class | BoostingTermQuery..::..BoostingTermWeight |
Public class | MaxPayloadFunction | Returns the maximum payload score seen, else 1 if there are no payloads on the doc. Is thread safe and completely reusable.
Public class | MinPayloadFunction | Calculates the minimum payload seen
Public class | PayloadFunction | An abstract class that defines a way for Payload*Query instances to transform the cumulative effects of payload scores for a document.
Public class | PayloadNearQuery | This class is very similar to {@link Lucene.Net.Search.Spans.SpanNearQuery} except that it factors in the value of the payloads located at each of the positions where the {@link Lucene.Net.Search.Spans.TermSpans} occurs. In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default. Payload scores are aggregated using a pluggable {@link PayloadFunction}.
Public class | PayloadNearQuery..::..PayloadNearSpanScorer |
Public class | PayloadNearQuery..::..PayloadNearSpanWeight |
Public class | PayloadSpanUtil | Experimental class to get set of payloads for most standard Lucene queries. Operates like Highlighter - IndexReader should only contain doc of interest, best to use MemoryIndex. WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.
Public class | PayloadTermQuery | This class is very similar to {@link Lucene.Net.Search.Spans.SpanTermQuery} except that it factors in the value of the payload located at each of the positions where the {@link Lucene.Net.Index.Term} occurs. In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default. Payload scores are aggregated using a pluggable {@link PayloadFunction}.
Protected class | PayloadTermQuery..::..PayloadTermWeight |
Protected class | PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer |


AveragePayloadFunction Class

[image]

Lucene.Net Class Libraries
AveragePayloadFunction Class
Members See Also Send Feedback
Calculate the final score as the average score of all payloads seen.

Is thread safe and completely reusable.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class AveragePayloadFunction : PayloadFunction
Visual Basic
<SerializableAttribute> _
Public Class AveragePayloadFunction _
    Inherits PayloadFunction
Visual C++
[SerializableAttribute]
public ref class AveragePayloadFunction : public PayloadFunction

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Payloads..::..PayloadFunction
Lucene.Net.Search.Payloads..::..AveragePayloadFunction

See Also

AveragePayloadFunction Members
Lucene.Net.Search.Payloads Namespace


AveragePayloadFunction Members

[image] [image]

Lucene.Net Class Libraries
AveragePayloadFunction Members
AveragePayloadFunction Class Constructors Methods See Also Send Feedback

The AveragePayloadFunction type exposes the following members.

Constructors

 | Name | Description
Public method | AveragePayloadFunction | Initializes a new instance of the AveragePayloadFunction class

Methods

 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction..::..CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction..::..DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PayloadFunction..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


AveragePayloadFunction Constructor

[image]

Lucene.Net Class Libraries
AveragePayloadFunction Constructor
AveragePayloadFunction Class See Also Send Feedback
Initializes a new instance of the AveragePayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AveragePayloadFunction()
Visual Basic
Public Sub New
Visual C++
public:
AveragePayloadFunction()

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


AveragePayloadFunction Methods

[image] [image]

Lucene.Net Class Libraries
AveragePayloadFunction Methods
AveragePayloadFunction Class See Also Send Feedback

The AveragePayloadFunction type exposes the following members.

Methods

 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction..::..CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction..::..DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PayloadFunction..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


CurrentScore Method

[image]

Lucene.Net Class Libraries
AveragePayloadFunction..::..CurrentScore Method
AveragePayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Visual Basic
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Visual C++
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override

Parameters

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

numPayloadsSeen
Type: System..::..Int32

[Missing <param name="numPayloadsSeen"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

currentScore
Type: System..::..Single

[Missing <param name="currentScore"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

currentPayloadScore
Type: System..::..Single

[Missing <param name="currentPayloadScore"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


DocScore Method

[image]

Lucene.Net Class Libraries
AveragePayloadFunction..::..DocScore Method
AveragePayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Visual Basic
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Visual C++
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override

Parameters

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

numPayloadsSeen
Type: System..::..Int32

[Missing <param name="numPayloadsSeen"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

payloadScore
Type: System..::..Single

[Missing <param name="payloadScore"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
AveragePayloadFunction..::..Equals Method
AveragePayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.Equals(System.Object)"]

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
AveragePayloadFunction..::..GetHashCode Method
AveragePayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.AveragePayloadFunction.GetHashCode"]

See Also

AveragePayloadFunction Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Class

[image]

Lucene.Net Class Libraries
BoostingTermQuery Class
Members See Also Send Feedback
The BoostingTermQuery is very similar to the {@link Lucene.Net.Search.Spans.SpanTermQuery} except that it factors in the value of the payload located at each of the positions where the {@link Lucene.Net.Index.Term} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are averaged across term occurrences in the document.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("See Lucene.Net.Search.Payloads.PayloadTermQuery")]
public class BoostingTermQuery : PayloadTermQuery
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("See Lucene.Net.Search.Payloads.PayloadTermQuery")> _
Public Class BoostingTermQuery _
    Inherits PayloadTermQuery
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"See Lucene.Net.Search.Payloads.PayloadTermQuery")]
public ref class BoostingTermQuery : public PayloadTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanTermQuery
Lucene.Net.Search.Payloads..::..PayloadTermQuery
Lucene.Net.Search.Payloads..::..BoostingTermQuery

See Also

BoostingTermQuery Members
Lucene.Net.Search.Payloads Namespace
Similarity..::..ScorePayload(String, array<Byte>[]()[][], Int32, Int32)


BoostingTermQuery Members

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery Members
BoostingTermQuery Class Constructors Methods Fields See Also Send Feedback

The BoostingTermQuery type exposes the following members.

Constructors

 | Name | Description
Public method | BoostingTermQuery(Term) | Initializes a new instance of the BoostingTermQuery class
Public method | BoostingTermQuery(Term, Boolean) | Initializes a new instance of the BoostingTermQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides PayloadTermQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides PayloadTermQuery..::..Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanTermQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Inherited from SpanTermQuery.)
Public method | GetHashCode | (Overrides PayloadTermQuery..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Inherited from SpanTermQuery.)
Public method GetTerm
Return the term whose spans are matched.
(Inherited from SpanTermQuery.)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Inherited from SpanTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | function | (Inherited from PayloadTermQuery.)
Protected field | term | (Inherited from SpanTermQuery.)

See Also

BoostingTermQuery Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Constructor

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery Constructor
BoostingTermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoostingTermQuery(Term) | Initializes a new instance of the BoostingTermQuery class
Public method | BoostingTermQuery(Term, Boolean) | Initializes a new instance of the BoostingTermQuery class

See Also

BoostingTermQuery Class
BoostingTermQuery Members
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Constructor (Term)

[image]

Lucene.Net Class Libraries
BoostingTermQuery Constructor (Term)
BoostingTermQuery Class See Also Send Feedback
Initializes a new instance of the BoostingTermQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BoostingTermQuery(
    Term term
)
Visual Basic
Public Sub New ( _
    term As Term _
)
Visual C++
public:
BoostingTermQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

BoostingTermQuery Class
BoostingTermQuery Overload
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Constructor (Term, Boolean)

[image]

Lucene.Net Class Libraries
BoostingTermQuery Constructor (Term, Boolean)
BoostingTermQuery Class See Also Send Feedback
Initializes a new instance of the BoostingTermQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BoostingTermQuery(
    Term term,
    bool includeSpanScore
)
Visual Basic
Public Sub New ( _
    term As Term, _
    includeSpanScore As Boolean _
)
Visual C++
public:
BoostingTermQuery(
    Term^ term,
    bool includeSpanScore
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.#ctor(Lucene.Net.Index.Term,System.Boolean)"]

includeSpanScore
Type: System..::..Boolean

[Missing <param name="includeSpanScore"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.#ctor(Lucene.Net.Index.Term,System.Boolean)"]

See Also

BoostingTermQuery Class
BoostingTermQuery Overload
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Fields

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery Fields
BoostingTermQuery Class See Also Send Feedback

The BoostingTermQuery type exposes the following members.

Fields

 | Name | Description
Protected field | function | (Inherited from PayloadTermQuery.)
Protected field | term | (Inherited from SpanTermQuery.)

See Also

BoostingTermQuery Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery Methods

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery Methods
BoostingTermQuery Class See Also Send Feedback

The BoostingTermQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides PayloadTermQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides PayloadTermQuery..::..Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanTermQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Inherited from SpanTermQuery.)
Public method | GetHashCode | (Overrides PayloadTermQuery..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Inherited from SpanTermQuery.)
Public method GetTerm
Return the term whose spans are matched.
(Inherited from SpanTermQuery.)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Inherited from SpanTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

BoostingTermQuery Class
Lucene.Net.Search.Payloads Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..CreateWeight Method
BoostingTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

BoostingTermQuery Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..Equals Method
BoostingTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.Equals(System.Object)"]

See Also

BoostingTermQuery Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..GetHashCode Method
BoostingTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.GetHashCode"]

See Also

BoostingTermQuery Class
Lucene.Net.Search.Payloads Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery..::..ToString Method
BoostingTermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)

See Also

BoostingTermQuery Class
BoostingTermQuery Members
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Class

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight Class
BoostingTermQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
protected internal class BoostingTermWeight : PayloadTermQuery..::..PayloadTermWeight
Visual Basic
<SerializableAttribute> _
Protected Friend Class BoostingTermWeight _
    Inherits PayloadTermQuery..::..PayloadTermWeight
Visual C++
[SerializableAttribute]
protected public ref class BoostingTermWeight : public PayloadTermQuery..::..PayloadTermWeight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search.Spans..::..SpanWeight
Lucene.Net.Search.Payloads..::..PayloadTermQuery..::..PayloadTermWeight
Lucene.Net.Search.Payloads..::..BoostingTermQuery..::..BoostingTermWeight

See Also

BoostingTermQuery..::..BoostingTermWeight Members
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Members

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight Members
BoostingTermQuery..::..BoostingTermWeight Class Constructors Methods Fields Properties See Also Send Feedback

The BoostingTermQuery is very similar to the {@link Lucene.Net.Search.Spans.SpanTermQuery} except that it factors in the value of the payload located at each of the positions where the {@link Lucene.Net.Index.Term} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are averaged across term occurrences in the document.

The BoostingTermQuery..::..BoostingTermWeight type exposes the following members.

Constructors

 | Name | Description
Public method | BoostingTermQuery..::..BoostingTermWeight | Initializes a new instance of the BoostingTermQuery..::..BoostingTermWeight class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Inherited from SpanWeight.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from SpanWeight.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides PayloadTermQuery..::..PayloadTermWeight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Inherited from SpanWeight.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | query | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Constructor

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight Constructor
BoostingTermQuery..::..BoostingTermWeight Class See Also Send Feedback
Initializes a new instance of the BoostingTermQuery..::..BoostingTermWeight class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BoostingTermWeight(
    BoostingTermQuery enclosingInstance,
    BoostingTermQuery query,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    enclosingInstance As BoostingTermQuery, _
    query As BoostingTermQuery, _
    searcher As Searcher _
)
Visual C++
public:
BoostingTermWeight(
    BoostingTermQuery^ enclosingInstance,
    BoostingTermQuery^ query,
    Searcher^ searcher
)

Parameters

enclosingInstance
Type: Lucene.Net.Search.Payloads..::..BoostingTermQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.#ctor(Lucene.Net.Search.Payloads.BoostingTermQuery,Lucene.Net.Search.Payloads.BoostingTermQuery,Lucene.Net.Search.Searcher)"]

query
Type: Lucene.Net.Search.Payloads..::..BoostingTermQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.#ctor(Lucene.Net.Search.Payloads.BoostingTermQuery,Lucene.Net.Search.Payloads.BoostingTermQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.#ctor(Lucene.Net.Search.Payloads.BoostingTermQuery,Lucene.Net.Search.Payloads.BoostingTermQuery,Lucene.Net.Search.Searcher)"]

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Fields

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight Fields
BoostingTermQuery..::..BoostingTermWeight Class See Also Send Feedback

The BoostingTermQuery..::..BoostingTermWeight type exposes the following members.

Fields

 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | query | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Methods

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight Methods
BoostingTermQuery..::..BoostingTermWeight Class See Also Send Feedback

The BoostingTermQuery..::..BoostingTermWeight type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Inherited from SpanWeight.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from SpanWeight.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides PayloadTermQuery..::..PayloadTermWeight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Inherited from SpanWeight.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight..::..Scorer Method
BoostingTermQuery..::..BoostingTermWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


BoostingTermQuery.BoostingTermWeight Properties

[image] [image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight Properties
BoostingTermQuery..::..BoostingTermWeight Class See Also Send Feedback

The BoostingTermQuery..::..BoostingTermWeight type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
BoostingTermQuery..::..BoostingTermWeight..::..Enclosing_Instance Property
BoostingTermQuery..::..BoostingTermWeight Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Payloads.BoostingTermQuery.BoostingTermWeight.Enclosing_Instance"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BoostingTermQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As BoostingTermQuery
    Get
Visual C++
public:
property BoostingTermQuery^ Enclosing_Instance {
    BoostingTermQuery^ get ();
}

See Also

BoostingTermQuery..::..BoostingTermWeight Class
Lucene.Net.Search.Payloads Namespace


MaxPayloadFunction Class

[image]

Lucene.Net Class Libraries
MaxPayloadFunction Class
Members See Also Send Feedback
Returns the maximum payload score seen, else 1 if there are no payloads on the doc.

Is thread safe and completely reusable.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MaxPayloadFunction : PayloadFunction
Visual Basic
<SerializableAttribute> _
Public Class MaxPayloadFunction _
    Inherits PayloadFunction
Visual C++
[SerializableAttribute]
public ref class MaxPayloadFunction : public PayloadFunction

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Payloads..::..PayloadFunction
Lucene.Net.Search.Payloads..::..MaxPayloadFunction

See Also

MaxPayloadFunction Members
Lucene.Net.Search.Payloads Namespace


MaxPayloadFunction Members

[image] [image]

Lucene.Net Class Libraries
MaxPayloadFunction Members
MaxPayloadFunction Class Constructors Methods See Also Send Feedback

The MaxPayloadFunction type exposes the following members.

Constructors

 | Name | Description
Public method | MaxPayloadFunction | Initializes a new instance of the MaxPayloadFunction class

Methods

 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction..::..CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction..::..DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PayloadFunction..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


MaxPayloadFunction Constructor

[image]

Lucene.Net Class Libraries
MaxPayloadFunction Constructor
MaxPayloadFunction Class See Also Send Feedback
Initializes a new instance of the MaxPayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MaxPayloadFunction()
Visual Basic
Public Sub New
Visual C++
public:
MaxPayloadFunction()

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


MaxPayloadFunction Methods

[image] [image]

Lucene.Net Class Libraries
MaxPayloadFunction Methods
MaxPayloadFunction Class See Also Send Feedback

The MaxPayloadFunction type exposes the following members.

Methods

 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction..::..CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction..::..DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PayloadFunction..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


CurrentScore Method

[image]

Lucene.Net Class Libraries
MaxPayloadFunction..::..CurrentScore Method
MaxPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Visual Basic
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Visual C++
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override

Parameters

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

numPayloadsSeen
Type: System..::..Int32

[Missing <param name="numPayloadsSeen"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

currentScore
Type: System..::..Single

[Missing <param name="currentScore"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

currentPayloadScore
Type: System..::..Single

[Missing <param name="currentPayloadScore"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


DocScore Method

[image]

Lucene.Net Class Libraries
MaxPayloadFunction..::..DocScore Method
MaxPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Visual Basic
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Visual C++
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override

Parameters

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

numPayloadsSeen
Type: System..::..Int32

[Missing <param name="numPayloadsSeen"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

payloadScore
Type: System..::..Single

[Missing <param name="payloadScore"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
MaxPayloadFunction..::..Equals Method
MaxPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.Equals(System.Object)"]

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MaxPayloadFunction..::..GetHashCode Method
MaxPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MaxPayloadFunction.GetHashCode"]

See Also

MaxPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


MinPayloadFunction Class

[image]

Lucene.Net Class Libraries
MinPayloadFunction Class
Members See Also Send Feedback
Calculates the minimum payload seen

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class MinPayloadFunction : PayloadFunction
Visual Basic
<SerializableAttribute> _
Public Class MinPayloadFunction _
    Inherits PayloadFunction
Visual C++
[SerializableAttribute]
public ref class MinPayloadFunction : public PayloadFunction

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Payloads..::..PayloadFunction
Lucene.Net.Search.Payloads..::..MinPayloadFunction

See Also

MinPayloadFunction Members
Lucene.Net.Search.Payloads Namespace


MinPayloadFunction Members

[image] [image]

Lucene.Net Class Libraries
MinPayloadFunction Members
MinPayloadFunction Class Constructors Methods See Also Send Feedback

The MinPayloadFunction type exposes the following members.

Constructors

 | Name | Description
Public method | MinPayloadFunction | Initializes a new instance of the MinPayloadFunction class

Methods

 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction..::..CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction..::..DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PayloadFunction..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


MinPayloadFunction Constructor

[image]

Lucene.Net Class Libraries
MinPayloadFunction Constructor
MinPayloadFunction Class See Also Send Feedback
Initializes a new instance of the MinPayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MinPayloadFunction()
Visual Basic
Public Sub New
Visual C++
public:
MinPayloadFunction()

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


MinPayloadFunction Methods

[image] [image]

Lucene.Net Class Libraries
MinPayloadFunction Methods
MinPayloadFunction Class See Also Send Feedback

The MinPayloadFunction type exposes the following members.

Methods

 | Name | Description
Public method | CurrentScore | (Overrides PayloadFunction..::..CurrentScore(Int32, String, Int32, Int32, Int32, Single, Single).)
Public method | DocScore | (Overrides PayloadFunction..::..DocScore(Int32, String, Int32, Single).)
Public method | Equals | (Overrides PayloadFunction..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PayloadFunction..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


CurrentScore Method

[image]

Lucene.Net Class Libraries
MinPayloadFunction..::..CurrentScore Method
MinPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Visual Basic
Public Overrides Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Visual C++
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) override

Parameters

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

numPayloadsSeen
Type: System..::..Int32

[Missing <param name="numPayloadsSeen"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

currentScore
Type: System..::..Single

[Missing <param name="currentScore"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

currentPayloadScore
Type: System..::..Single

[Missing <param name="currentPayloadScore"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.CurrentScore(System.Int32,System.String,System.Int32,System.Int32,System.Int32,System.Single,System.Single)"]

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


DocScore Method

[image]

Lucene.Net Class Libraries
MinPayloadFunction..::..DocScore Method
MinPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Visual Basic
Public Overrides Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Visual C++
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) override

Parameters

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

numPayloadsSeen
Type: System..::..Int32

[Missing <param name="numPayloadsSeen"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

payloadScore
Type: System..::..Single

[Missing <param name="payloadScore"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.DocScore(System.Int32,System.String,System.Int32,System.Single)"]

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
MinPayloadFunction..::..Equals Method
MinPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.Equals(System.Object)"]

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
MinPayloadFunction..::..GetHashCode Method
MinPayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.MinPayloadFunction.GetHashCode"]

See Also

MinPayloadFunction Class
Lucene.Net.Search.Payloads Namespace


PayloadFunction Class

[image]

Lucene.Net Class Libraries
PayloadFunction Class
Members See Also Send Feedback
An abstract class that defines a way for Payload*Query instances to transform the cumulative effects of payload scores for a document.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class PayloadFunction
Visual Basic
<SerializableAttribute> _
Public MustInherit Class PayloadFunction
Visual C++
[SerializableAttribute]
public ref class PayloadFunction abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Payloads..::..PayloadFunction
Lucene.Net.Search.Payloads..::..AveragePayloadFunction
Lucene.Net.Search.Payloads..::..MaxPayloadFunction
Lucene.Net.Search.Payloads..::..MinPayloadFunction

See Also

PayloadFunction Members
Lucene.Net.Search.Payloads Namespace
for more information This class and its derivations are experimental and subject to change


PayloadFunction Members

[image] [image]

Lucene.Net Class Libraries
PayloadFunction Members
PayloadFunction Class Constructors Methods See Also Send Feedback

The PayloadFunction type exposes the following members.

Constructors

 | Name | Description
Protected method | PayloadFunction | Initializes a new instance of the PayloadFunction class

Methods

 | Name | Description
Public method | CurrentScore | Calculate the score up to this point for this doc and field
Public method | DocScore | Calculate the final score for all the payloads seen so far for this doc/field
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace


PayloadFunction Constructor

[image]

Lucene.Net Class Libraries
PayloadFunction Constructor
PayloadFunction Class See Also Send Feedback
Initializes a new instance of the PayloadFunction class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected PayloadFunction()
Visual Basic
Protected Sub New
Visual C++
protected:
PayloadFunction()

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace


PayloadFunction Methods

[image] [image]

Lucene.Net Class Libraries
PayloadFunction Methods
PayloadFunction Class See Also Send Feedback

The PayloadFunction type exposes the following members.

Methods

 | Name | Description
Public method | CurrentScore | Calculate the score up to this point for this doc and field
Public method | DocScore | Calculate the final score for all the payloads seen so far for this doc/field
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace


CurrentScore Method

[image]

Lucene.Net Class Libraries
PayloadFunction..::..CurrentScore Method
PayloadFunction Class See Also Send Feedback
Calculate the score up to this point for this doc and field

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float CurrentScore(
    int docId,
    string field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
)
Visual Basic
Public MustOverride Function CurrentScore ( _
    docId As Integer, _
    field As String, _
    start As Integer, _
    end As Integer, _
    numPayloadsSeen As Integer, _
    currentScore As Single, _
    currentPayloadScore As Single _
) As Single
Visual C++
public:
virtual float CurrentScore(
    int docId,
    String^ field,
    int start,
    int end,
    int numPayloadsSeen,
    float currentScore,
    float currentPayloadScore
) abstract

Parameters

docId
Type: System..::..Int32
The current doc
field
Type: System..::..String
The field
start
Type: System..::..Int32
The start position of the matching Span
end
Type: System..::..Int32
The end position of the matching Span
numPayloadsSeen
Type: System..::..Int32
The number of payloads seen so far
currentScore
Type: System..::..Single
The current score so far
currentPayloadScore
Type: System..::..Single
The score for the current payload

Return Value

The new current Score

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace
Lucene.Net.Search.Spans..::..Spans


DocScore Method

[image]

Lucene.Net Class Libraries
PayloadFunction..::..DocScore Method
PayloadFunction Class See Also Send Feedback
Calculate the final score for all the payloads seen so far for this doc/field

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract float DocScore(
    int docId,
    string field,
    int numPayloadsSeen,
    float payloadScore
)
Visual Basic
Public MustOverride Function DocScore ( _
    docId As Integer, _
    field As String, _
    numPayloadsSeen As Integer, _
    payloadScore As Single _
) As Single
Visual C++
public:
virtual float DocScore(
    int docId,
    String^ field,
    int numPayloadsSeen,
    float payloadScore
) abstract

Parameters

docId
Type: System..::..Int32
The current doc
field
Type: System..::..String
The current field
numPayloadsSeen
Type: System..::..Int32
The total number of payloads seen on this document
payloadScore
Type: System..::..Single
The raw score for those payloads

Return Value

The final score for the payloads

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PayloadFunction..::..Equals Method
PayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadFunction.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Equals(
    Object o
)
Visual Basic
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) abstract override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadFunction.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadFunction.Equals(System.Object)"]

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
PayloadFunction..::..GetHashCode Method
PayloadFunction Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadFunction.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetHashCode()
Visual Basic
Public MustOverride Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() abstract override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadFunction.GetHashCode"]

See Also

PayloadFunction Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery Class

[image]

Lucene.Net Class Libraries
PayloadNearQuery Class
Members See Also Send Feedback
This class is very similar to {@link Lucene.Net.Search.Spans.SpanNearQuery} except that it factors in the value of the payloads located at each of the positions where the {@link Lucene.Net.Search.Spans.TermSpans} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are aggregated using a pluggable {@link PayloadFunction}.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PayloadNearQuery : SpanNearQuery,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class PayloadNearQuery _
    Inherits SpanNearQuery _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class PayloadNearQuery : public SpanNearQuery,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanNearQuery
Lucene.Net.Search.Payloads..::..PayloadNearQuery

See Also

PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace
Similarity..::..ScorePayload(String, array<Byte>[]()[][], Int32, Int32)


PayloadNearQuery Members

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery Members
PayloadNearQuery Class Constructors Methods Fields See Also Send Feedback

The PayloadNearQuery type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadNearQuery(array<SpanQuery>[]()[][], Int32, Boolean) | Initializes a new instance of the PayloadNearQuery class
Public method | PayloadNearQuery(array<SpanQuery>[]()[][], Int32, Boolean, PayloadFunction) | Initializes a new instance of the PayloadNearQuery class

Methods

Name | Description
Public method | Clone | (Overrides SpanNearQuery..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanNearQuery..::..Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanNearQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Return the clauses whose spans are matched.
(Inherited from SpanNearQuery.)
Public method | GetField | (Inherited from SpanNearQuery.)
Public method | GetHashCode | (Overrides SpanNearQuery..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Return the maximum number of intervening unmatched positions permitted.
(Inherited from SpanNearQuery.)
Public method | GetSpans | (Inherited from SpanNearQuery.)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Inherited from SpanNearQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsInOrder
Return true if matches are required to be in-order.
(Inherited from SpanNearQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from SpanNearQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides SpanNearQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | clauses | (Inherited from SpanNearQuery.)
Protected field | field | (Inherited from SpanNearQuery.)
Protected field | fieldName |
Protected field | function |
Protected field | inOrder | (Inherited from SpanNearQuery.)
Protected field | slop | (Inherited from SpanNearQuery.)

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery Constructor

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery Constructor
PayloadNearQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PayloadNearQuery(array<SpanQuery>[]()[][], Int32, Boolean) | Initializes a new instance of the PayloadNearQuery class
Public method | PayloadNearQuery(array<SpanQuery>[]()[][], Int32, Boolean, PayloadFunction) | Initializes a new instance of the PayloadNearQuery class

See Also

PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery Constructor (SpanQuery[], Int32, Boolean)

[image]

Lucene.Net Class Libraries
PayloadNearQuery Constructor (array<SpanQuery>[]()[][], Int32, Boolean)
PayloadNearQuery Class See Also Send Feedback
Initializes a new instance of the PayloadNearQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder
)
Visual Basic
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean _
)
Visual C++
public:
PayloadNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder
)

Parameters

clauses
Type: array< Lucene.Net.Search.Spans..::..SpanQuery >[]()[][]

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean)"]

slop
Type: System..::..Int32

[Missing <param name="slop"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean)"]

inOrder
Type: System..::..Boolean

[Missing <param name="inOrder"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean)"]

See Also

PayloadNearQuery Class
PayloadNearQuery Overload
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery Constructor (SpanQuery[], Int32, Boolean, PayloadFunction)

[image]

Lucene.Net Class Libraries
PayloadNearQuery Constructor (array<SpanQuery>[]()[][], Int32, Boolean, PayloadFunction)
PayloadNearQuery Class See Also Send Feedback
Initializes a new instance of the PayloadNearQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder,
    PayloadFunction function
)
Visual Basic
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean, _
    function As PayloadFunction _
)
Visual C++
public:
PayloadNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder,
    PayloadFunction^ function
)

Parameters

clauses
Type: array< Lucene.Net.Search.Spans..::..SpanQuery >[]()[][]

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,Lucene.Net.Search.Payloads.PayloadFunction)"]

slop
Type: System..::..Int32

[Missing <param name="slop"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,Lucene.Net.Search.Payloads.PayloadFunction)"]

inOrder
Type: System..::..Boolean

[Missing <param name="inOrder"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,Lucene.Net.Search.Payloads.PayloadFunction)"]

function
Type: Lucene.Net.Search.Payloads..::..PayloadFunction

[Missing <param name="function"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,Lucene.Net.Search.Payloads.PayloadFunction)"]

See Also

PayloadNearQuery Class
PayloadNearQuery Overload
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery Fields

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery Fields
PayloadNearQuery Class See Also Send Feedback

The PayloadNearQuery type exposes the following members.

Fields

 | Name | Description
Protected field | clauses | (Inherited from SpanNearQuery.)
Protected field | field | (Inherited from SpanNearQuery.)
Protected field | fieldName |
Protected field | function |
Protected field | inOrder | (Inherited from SpanNearQuery.)
Protected field | slop | (Inherited from SpanNearQuery.)

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


fieldName Field

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..fieldName Field
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadNearQuery.fieldName"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string fieldName
Visual Basic
Protected Friend fieldName As String
Visual C++
protected public:
String^ fieldName

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


function Field

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..function Field
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadNearQuery.function"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal PayloadFunction function
Visual Basic
Protected Friend function As PayloadFunction
Visual C++
protected public:
PayloadFunction^ function

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery Methods

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery Methods
PayloadNearQuery Class See Also Send Feedback

The PayloadNearQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides SpanNearQuery..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanNearQuery..::..Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanNearQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Return the clauses whose spans are matched.
(Inherited from SpanNearQuery.)
Public method | GetField | (Inherited from SpanNearQuery.)
Public method | GetHashCode | (Overrides SpanNearQuery..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Return the maximum number of intervening unmatched positions permitted.
(Inherited from SpanNearQuery.)
Public method | GetSpans | (Inherited from SpanNearQuery.)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Inherited from SpanNearQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsInOrder
Return true if matches are required to be in-order.
(Inherited from SpanNearQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from SpanNearQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides SpanNearQuery..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


Clone Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..Clone Method
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.Clone"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..CreateWeight Method
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..Equals Method
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.Equals(System.Object)"]

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..GetHashCode Method
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.GetHashCode"]

See Also

PayloadNearQuery Class
Lucene.Net.Search.Payloads Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..ToString Method
PayloadNearQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides SpanNearQuery..::..ToString(String).)

See Also

PayloadNearQuery Class
PayloadNearQuery Members
Lucene.Net.Search.Payloads Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..ToString Method (String)
PayloadNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.ToString(System.String)"]

See Also

PayloadNearQuery Class
ToString Overload
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanScorer Class

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer Class
PayloadNearQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PayloadNearSpanScorer : SpanScorer
Visual Basic
Public Class PayloadNearSpanScorer _
    Inherits SpanScorer
Visual C++
public ref class PayloadNearSpanScorer : public SpanScorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search.Spans..::..SpanScorer
Lucene.Net.Search.Payloads..::..PayloadNearQuery..::..PayloadNearSpanScorer

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanScorer Members

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer Members
PayloadNearQuery..::..PayloadNearSpanScorer Class Constructors Methods Fields Properties See Also Send Feedback

This class is very similar to {@link Lucene.Net.Search.Spans.SpanNearQuery} except that it factors in the value of the payloads located at each of the positions where the {@link Lucene.Net.Search.Spans.TermSpans} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are aggregated using a pluggable {@link PayloadFunction}.

The PayloadNearQuery..::..PayloadNearSpanScorer type exposes the following members.

Constructors

 | Name | Description
Protected method | PayloadNearQuery..::..PayloadNearSpanScorer | Initializes a new instance of the PayloadNearQuery..::..PayloadNearSpanScorer class

Methods

Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | Doc | Obsolete. (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides SpanScorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetPayloads
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Inherited from SpanScorer.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method ProcessPayloads
By default, uses the {@link PayloadFunction} to score the payloads, but can be overridden to do other things.
Public method | Score()()()() | (Overrides SpanScorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer..::..SetFreqCurrentDoc()()()().)
Public method | SkipTo | Obsolete. (Inherited from SpanScorer.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | firstTime | Obsolete. (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payloadScore |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanScorer Constructor

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer Constructor
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback
Initializes a new instance of the PayloadNearQuery..::..PayloadNearSpanScorer class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal PayloadNearSpanScorer(
    PayloadNearQuery enclosingInstance,
    Spans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
Visual Basic
Protected Friend Sub New ( _
    enclosingInstance As PayloadNearQuery, _
    spans As Spans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
Visual C++
protected public:
PayloadNearSpanScorer(
    PayloadNearQuery^ enclosingInstance,
    Spans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)

Parameters

enclosingInstance
Type: Lucene.Net.Search.Payloads..::..PayloadNearQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

spans
Type: Lucene.Net.Search.Spans..::..Spans

[Missing <param name="spans"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

norms
Type: array< System..::..Byte >[]()[][]

[Missing <param name="norms"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanScorer Fields

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer Fields
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

The PayloadNearQuery..::..PayloadNearSpanScorer type exposes the following members.

Fields

 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | firstTime | Obsolete. (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payloadScore |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


payloadScore Field

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..payloadScore Field
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.payloadScore"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float payloadScore
Visual Basic
Protected Friend payloadScore As Single
Visual C++
protected public:
float payloadScore

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanScorer Methods

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer Methods
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

The PayloadNearQuery..::..PayloadNearSpanScorer type exposes the following members.

Methods

Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | Doc | Obsolete. (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides SpanScorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetPayloads
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Inherited from SpanScorer.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method ProcessPayloads
By default, uses the {@link PayloadFunction} to score the payloads, but can be overridden to do other things.
Public method | Score()()()() | (Overrides SpanScorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer..::..SetFreqCurrentDoc()()()().)
Public method | SkipTo | Obsolete. (Inherited from SpanScorer.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


Explain Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..Explain Method
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.Explain(System.Int32)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.Explain(System.Int32)"]

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


GetPayloads Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..GetPayloads Method
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.GetPayloads(Lucene.Net.Search.Spans.Spans[])"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void GetPayloads(
    Spans[] subSpans
)
Visual Basic
Public Overridable Sub GetPayloads ( _
    subSpans As Spans() _
)
Visual C++
public:
virtual void GetPayloads(
    array<Spans^>^ subSpans
)

Parameters

subSpans
Type: array< Lucene.Net.Search.Spans..::..Spans >[]()[][]

[Missing <param name="subSpans"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.GetPayloads(Lucene.Net.Search.Spans.Spans[])"]

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


ProcessPayloads Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..ProcessPayloads Method
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback
By default, uses the {@link PayloadFunction} to score the payloads, but can be overridden to do other things.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void ProcessPayloads(
    ICollection<byte[]> payLoads,
    int start,
    int end
)
Visual Basic
Protected Friend Overridable Sub ProcessPayloads ( _
    payLoads As ICollection(Of Byte()), _
    start As Integer, _
    end As Integer _
)
Visual C++
protected public:
virtual void ProcessPayloads(
    ICollection<array<unsigned char>^>^ payLoads,
    int start,
    int end
)

Parameters

payLoads
Type: System.Collections.Generic..::..ICollection <(Of <(<'array< Byte >[]()[][]>)>)>
The payloads
start
Type: System..::..Int32
The start position of the span being scored
end
Type: System..::..Int32
The end position of the span being scored

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace
Lucene.Net.Search.Spans


Score Method

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..Score Method
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

Overload List

Name | Description
Public method | Score()()()() | (Overrides SpanScorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
PayloadNearQuery..::..PayloadNearSpanScorer Members
Lucene.Net.Search.Payloads Namespace


Score Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..Score Method
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.Score"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.Score"]

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Score Overload
Lucene.Net.Search.Payloads Namespace


SetFreqCurrentDoc Method

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..SetFreqCurrentDoc Method
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.SetFreqCurrentDoc"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool SetFreqCurrentDoc()
Visual Basic
Public Overrides Function SetFreqCurrentDoc As Boolean
Visual C++
public:
virtual bool SetFreqCurrentDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.SetFreqCurrentDoc"]

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanScorer Properties

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer Properties
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

The PayloadNearQuery..::..PayloadNearSpanScorer type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanScorer..::..Enclosing_Instance Property
PayloadNearQuery..::..PayloadNearSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanScorer.Enclosing_Instance"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadNearQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As PayloadNearQuery
    Get
Visual C++
public:
property PayloadNearQuery^ Enclosing_Instance {
    PayloadNearQuery^ get ();
}

See Also

PayloadNearQuery..::..PayloadNearSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanWeight Class

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight Class
PayloadNearQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PayloadNearSpanWeight : SpanWeight
Visual Basic
<SerializableAttribute> _
Public Class PayloadNearSpanWeight _
    Inherits SpanWeight
Visual C++
[SerializableAttribute]
public ref class PayloadNearSpanWeight : public SpanWeight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search.Spans..::..SpanWeight
Lucene.Net.Search.Payloads..::..PayloadNearQuery..::..PayloadNearSpanWeight

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Members
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanWeight Members

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight Members
PayloadNearQuery..::..PayloadNearSpanWeight Class Constructors Methods Fields Properties See Also Send Feedback

This class is very similar to {@link Lucene.Net.Search.Spans.SpanNearQuery} except that it factors in the value of the payloads located at each of the positions where the {@link Lucene.Net.Search.Spans.TermSpans} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are aggregated using a pluggable {@link PayloadFunction}.

The PayloadNearQuery..::..PayloadNearSpanWeight type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadNearQuery..::..PayloadNearSpanWeight | Initializes a new instance of the PayloadNearQuery..::..PayloadNearSpanWeight class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Inherited from SpanWeight.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from SpanWeight.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer(IndexReader)
Public method | Scorer(IndexReader, Boolean, Boolean) | (Overrides SpanWeight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Inherited from SpanWeight.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | query | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanWeight Constructor

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight Constructor
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback
Initializes a new instance of the PayloadNearQuery..::..PayloadNearSpanWeight class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadNearSpanWeight(
    PayloadNearQuery enclosingInstance,
    SpanQuery query,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    enclosingInstance As PayloadNearQuery, _
    query As SpanQuery, _
    searcher As Searcher _
)
Visual C++
public:
PayloadNearSpanWeight(
    PayloadNearQuery^ enclosingInstance,
    SpanQuery^ query,
    Searcher^ searcher
)

Parameters

enclosingInstance
Type: Lucene.Net.Search.Payloads..::..PayloadNearQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Searcher)"]

query
Type: Lucene.Net.Search.Spans..::..SpanQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.#ctor(Lucene.Net.Search.Payloads.PayloadNearQuery,Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Searcher)"]

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanWeight Fields

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight Fields
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

The PayloadNearQuery..::..PayloadNearSpanWeight type exposes the following members.

Fields

 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | query | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanWeight Methods

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight Methods
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

The PayloadNearQuery..::..PayloadNearSpanWeight type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Inherited from SpanWeight.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from SpanWeight.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer(IndexReader)
Public method | Scorer(IndexReader, Boolean, Boolean) | (Overrides SpanWeight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Inherited from SpanWeight.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace


Scorer Method

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight..::..Scorer Method
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scorer(IndexReader) |
Public method | Scorer(IndexReader, Boolean, Boolean) | (Overrides SpanWeight..::..Scorer(IndexReader, Boolean, Boolean).)

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
PayloadNearQuery..::..PayloadNearSpanWeight Members
Lucene.Net.Search.Payloads Namespace


Scorer Method (IndexReader)

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight..::..Scorer Method (IndexReader)
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Scorer Scorer(
    IndexReader reader
)
Visual Basic
Public Overridable Function Scorer ( _
    reader As IndexReader _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader)"]

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Scorer Overload
Lucene.Net.Search.Payloads Namespace


Scorer Method (IndexReader, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight..::..Scorer Method (IndexReader, Boolean, Boolean)
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Scorer Overload
Lucene.Net.Search.Payloads Namespace


PayloadNearQuery.PayloadNearSpanWeight Properties

[image] [image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight Properties
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

The PayloadNearQuery..::..PayloadNearSpanWeight type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
PayloadNearQuery..::..PayloadNearSpanWeight..::..Enclosing_Instance Property
PayloadNearQuery..::..PayloadNearSpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Payloads.PayloadNearQuery.PayloadNearSpanWeight.Enclosing_Instance"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadNearQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As PayloadNearQuery
    Get
Visual C++
public:
property PayloadNearQuery^ Enclosing_Instance {
    PayloadNearQuery^ get ();
}

See Also

PayloadNearQuery..::..PayloadNearSpanWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Class

[image]

Lucene.Net Class Libraries
PayloadSpanUtil Class
Members See Also Send Feedback
Experimental class to get set of payloads for most standard Lucene queries. Operates like Highlighter - IndexReader should only contain doc of interest, best to use MemoryIndex.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class PayloadSpanUtil
Visual Basic
Public Class PayloadSpanUtil
Visual C++
public ref class PayloadSpanUtil

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Payloads..::..PayloadSpanUtil

See Also

PayloadSpanUtil Members
Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Members

[image] [image]

Lucene.Net Class Libraries
PayloadSpanUtil Members
PayloadSpanUtil Class Constructors Methods See Also Send Feedback

The PayloadSpanUtil type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadSpanUtil | Initializes a new instance of the PayloadSpanUtil class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayloadsForQuery | Query should be rewritten for wild/fuzzy support.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayloadSpanUtil Class
Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Constructor

[image]

Lucene.Net Class Libraries
PayloadSpanUtil Constructor
PayloadSpanUtil Class See Also Send Feedback
Initializes a new instance of the PayloadSpanUtil class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadSpanUtil(
    IndexReader reader
)
Visual Basic
Public Sub New ( _
    reader As IndexReader _
)
Visual C++
public:
PayloadSpanUtil(
    IndexReader^ reader
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
that contains doc with payloads to extract

See Also

PayloadSpanUtil Class
Lucene.Net.Search.Payloads Namespace


PayloadSpanUtil Methods

[image] [image]

Lucene.Net Class Libraries
PayloadSpanUtil Methods
PayloadSpanUtil Class See Also Send Feedback

The PayloadSpanUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayloadsForQuery | Query should be rewritten for wild/fuzzy support.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayloadSpanUtil Class
Lucene.Net.Search.Payloads Namespace


GetPayloadsForQuery Method

[image]

Lucene.Net Class Libraries
PayloadSpanUtil..::..GetPayloadsForQuery Method
PayloadSpanUtil Class See Also Send Feedback
Query should be rewritten for wild/fuzzy support.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual ICollection<byte[]> GetPayloadsForQuery(
    Query query
)
Visual Basic
Public Overridable Function GetPayloadsForQuery ( _
    query As Query _
) As ICollection(Of Byte())
Visual C++
public:
virtual ICollection<array<unsigned char>^>^ GetPayloadsForQuery(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadSpanUtil.GetPayloadsForQuery(Lucene.Net.Search.Query)"]

Return Value

payloads Collection

See Also

PayloadSpanUtil Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Class

[image]

Lucene.Net Class Libraries
PayloadTermQuery Class
Members See Also Send Feedback
This class is very similar to {@link Lucene.Net.Search.Spans.SpanTermQuery} except that it factors in the value of the payload located at each of the positions where the {@link Lucene.Net.Index.Term} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are aggregated using a pluggable {@link PayloadFunction}.

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class PayloadTermQuery : SpanTermQuery
Visual Basic
<SerializableAttribute> _
Public Class PayloadTermQuery _
    Inherits SpanTermQuery
Visual C++
[SerializableAttribute]
public ref class PayloadTermQuery : public SpanTermQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanTermQuery
Lucene.Net.Search.Payloads..::..PayloadTermQuery
Lucene.Net.Search.Payloads..::..BoostingTermQuery

See Also

PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Members

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery Members
PayloadTermQuery Class Constructors Methods Fields See Also Send Feedback

The PayloadTermQuery type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadTermQuery(Term, PayloadFunction) | Initializes a new instance of the PayloadTermQuery class
Public method | PayloadTermQuery(Term, PayloadFunction, Boolean) | Initializes a new instance of the PayloadTermQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanTermQuery..::..Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanTermQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Inherited from SpanTermQuery.)
Public method | GetHashCode | (Overrides SpanTermQuery..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Inherited from SpanTermQuery.)
Public method GetTerm
Return the term whose spans are matched.
(Inherited from SpanTermQuery.)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Inherited from SpanTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | function |
Protected field | term | (Inherited from SpanTermQuery.)

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Constructor

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery Constructor
PayloadTermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PayloadTermQuery(Term, PayloadFunction) | Initializes a new instance of the PayloadTermQuery class
Public method | PayloadTermQuery(Term, PayloadFunction, Boolean) | Initializes a new instance of the PayloadTermQuery class

See Also

PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Constructor (Term, PayloadFunction)

[image]

Lucene.Net Class Libraries
PayloadTermQuery Constructor (Term, PayloadFunction)
PayloadTermQuery Class See Also Send Feedback
Initializes a new instance of the PayloadTermQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadTermQuery(
    Term term,
    PayloadFunction function
)
Visual Basic
Public Sub New ( _
    term As Term, _
    function As PayloadFunction _
)
Visual C++
public:
PayloadTermQuery(
    Term^ term,
    PayloadFunction^ function
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.#ctor(Lucene.Net.Index.Term,Lucene.Net.Search.Payloads.PayloadFunction)"]

function
Type: Lucene.Net.Search.Payloads..::..PayloadFunction

[Missing <param name="function"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.#ctor(Lucene.Net.Index.Term,Lucene.Net.Search.Payloads.PayloadFunction)"]

See Also

PayloadTermQuery Class
PayloadTermQuery Overload
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Constructor (Term, PayloadFunction, Boolean)

[image]

Lucene.Net Class Libraries
PayloadTermQuery Constructor (Term, PayloadFunction, Boolean)
PayloadTermQuery Class See Also Send Feedback
Initializes a new instance of the PayloadTermQuery class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadTermQuery(
    Term term,
    PayloadFunction function,
    bool includeSpanScore
)
Visual Basic
Public Sub New ( _
    term As Term, _
    function As PayloadFunction, _
    includeSpanScore As Boolean _
)
Visual C++
public:
PayloadTermQuery(
    Term^ term,
    PayloadFunction^ function,
    bool includeSpanScore
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.#ctor(Lucene.Net.Index.Term,Lucene.Net.Search.Payloads.PayloadFunction,System.Boolean)"]

function
Type: Lucene.Net.Search.Payloads..::..PayloadFunction

[Missing <param name="function"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.#ctor(Lucene.Net.Index.Term,Lucene.Net.Search.Payloads.PayloadFunction,System.Boolean)"]

includeSpanScore
Type: System..::..Boolean

[Missing <param name="includeSpanScore"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.#ctor(Lucene.Net.Index.Term,Lucene.Net.Search.Payloads.PayloadFunction,System.Boolean)"]

See Also

PayloadTermQuery Class
PayloadTermQuery Overload
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Fields

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery Fields
PayloadTermQuery Class See Also Send Feedback

The PayloadTermQuery type exposes the following members.

Fields

 | Name | Description
Protected field | function |
Protected field | term | (Inherited from SpanTermQuery.)

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


function Field

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..function Field
PayloadTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadTermQuery.function"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal PayloadFunction function
Visual Basic
Protected Friend function As PayloadFunction
Visual C++
protected public:
PayloadFunction^ function

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery Methods

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery Methods
PayloadTermQuery Class See Also Send Feedback

The PayloadTermQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides SpanTermQuery..::..Equals(Object).)
Public method | ExtractTerms | (Inherited from SpanTermQuery.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Inherited from SpanTermQuery.)
Public method | GetHashCode | (Overrides SpanTermQuery..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Inherited from SpanTermQuery.)
Public method GetTerm
Return the term whose spans are matched.
(Inherited from SpanTermQuery.)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Inherited from SpanTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..CreateWeight Method
PayloadTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


Equals Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..Equals Method
PayloadTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.Equals(System.Object)"]

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..GetHashCode Method
PayloadTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.GetHashCode"]

See Also

PayloadTermQuery Class
Lucene.Net.Search.Payloads Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..ToString Method
PayloadTermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from SpanTermQuery.)

See Also

PayloadTermQuery Class
PayloadTermQuery Members
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight Class

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight Class
PayloadTermQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
protected internal class PayloadTermWeight : SpanWeight
Visual Basic
<SerializableAttribute> _
Protected Friend Class PayloadTermWeight _
    Inherits SpanWeight
Visual C++
[SerializableAttribute]
protected public ref class PayloadTermWeight : public SpanWeight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search.Spans..::..SpanWeight
Lucene.Net.Search.Payloads..::..PayloadTermQuery..::..PayloadTermWeight
Lucene.Net.Search.Payloads..::..BoostingTermQuery..::..BoostingTermWeight

See Also

PayloadTermQuery..::..PayloadTermWeight Members
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight Members

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight Members
PayloadTermQuery..::..PayloadTermWeight Class Constructors Methods Fields Properties See Also Send Feedback

This class is very similar to {@link Lucene.Net.Search.Spans.SpanTermQuery} except that it factors in the value of the payload located at each of the positions where the {@link Lucene.Net.Index.Term} occurs.

In order to take advantage of this, you must override {@link Lucene.Net.Search.Similarity#ScorePayload(String, byte[],int,int)} which returns 1 by default.

Payload scores are aggregated using a pluggable {@link PayloadFunction}.

The PayloadTermQuery..::..PayloadTermWeight type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadTermQuery..::..PayloadTermWeight | Initializes a new instance of the PayloadTermQuery..::..PayloadTermWeight class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Inherited from SpanWeight.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from SpanWeight.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides SpanWeight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Inherited from SpanWeight.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | query | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight Constructor

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight Constructor
PayloadTermQuery..::..PayloadTermWeight Class See Also Send Feedback
Initializes a new instance of the PayloadTermQuery..::..PayloadTermWeight class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadTermWeight(
    PayloadTermQuery enclosingInstance,
    PayloadTermQuery query,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    enclosingInstance As PayloadTermQuery, _
    query As PayloadTermQuery, _
    searcher As Searcher _
)
Visual C++
public:
PayloadTermWeight(
    PayloadTermQuery^ enclosingInstance,
    PayloadTermQuery^ query,
    Searcher^ searcher
)

Parameters

enclosingInstance
Type: Lucene.Net.Search.Payloads..::..PayloadTermQuery

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery,Lucene.Net.Search.Payloads.PayloadTermQuery,Lucene.Net.Search.Searcher)"]

query
Type: Lucene.Net.Search.Payloads..::..PayloadTermQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery,Lucene.Net.Search.Payloads.PayloadTermQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery,Lucene.Net.Search.Payloads.PayloadTermQuery,Lucene.Net.Search.Searcher)"]

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight Fields

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight Fields
PayloadTermQuery..::..PayloadTermWeight Class See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight type exposes the following members.

Fields

 | Name | Description
Protected field | idf | (Inherited from SpanWeight.)
Protected field | query | (Inherited from SpanWeight.)
Protected field | queryNorm | (Inherited from SpanWeight.)
Protected field | queryWeight | (Inherited from SpanWeight.)
Protected field | similarity | (Inherited from SpanWeight.)
Protected field | terms | (Inherited from SpanWeight.)
Protected field | value_Renamed | (Inherited from SpanWeight.)

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight Methods

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight Methods
PayloadTermQuery..::..PayloadTermWeight Class See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Inherited from SpanWeight.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Inherited from SpanWeight.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from SpanWeight.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Inherited from SpanWeight.)
Public method | Scorer | (Overrides SpanWeight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Inherited from SpanWeight.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..Scorer Method
PayloadTermQuery..::..PayloadTermWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight Properties

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight Properties
PayloadTermQuery..::..PayloadTermWeight Class See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..Enclosing_Instance Property
PayloadTermQuery..::..PayloadTermWeight Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.Enclosing_Instance"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadTermQuery Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As PayloadTermQuery
    Get
Visual C++
public:
property PayloadTermQuery^ Enclosing_Instance {
    PayloadTermQuery^ get ();
}

See Also

PayloadTermQuery..::..PayloadTermWeight Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Class

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
PayloadTermQuery..::..PayloadTermWeight Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class PayloadTermSpanScorer : SpanScorer
Visual Basic
Protected Friend Class PayloadTermSpanScorer _
    Inherits SpanScorer
Visual C++
protected public ref class PayloadTermSpanScorer : public SpanScorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search.Spans..::..SpanScorer
Lucene.Net.Search.Payloads..::..PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Members

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Members
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class Constructors Methods Fields Properties See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer type exposes the following members.

Constructors

 | Name | Description
Public method | PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer | Initializes a new instance of the PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer class

Methods

Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | Doc | Obsolete. (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides SpanScorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetPayloadScore
The score for the payload
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Protected method GetSpanScore
Returns the SpanScorer score only.

Should not be overriden without good cause!

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Inherited from SpanScorer.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method | ProcessPayload
Public method Score()()()()
(Overrides SpanScorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer..::..SetFreqCurrentDoc()()()().)
Public method | SkipTo | Obsolete. (Inherited from SpanScorer.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | firstTime | Obsolete. (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payload |
Protected field | payloadScore |
Protected field | payloadsSeen |
Protected field | positions |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Constructor

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Constructor
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback
Initializes a new instance of the PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer class

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadTermSpanScorer(
    PayloadTermQuery..::..PayloadTermWeight enclosingInstance,
    TermSpans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
Visual Basic
Public Sub New ( _
    enclosingInstance As PayloadTermQuery..::..PayloadTermWeight, _
    spans As TermSpans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
Visual C++
public:
PayloadTermSpanScorer(
    PayloadTermQuery..::..PayloadTermWeight^ enclosingInstance,
    TermSpans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)

Parameters

enclosingInstance
Type: Lucene.Net.Search.Payloads..::..PayloadTermQuery..::..PayloadTermWeight

[Missing <param name="enclosingInstance"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight,Lucene.Net.Search.Spans.TermSpans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

spans
Type: Lucene.Net.Search.Spans..::..TermSpans

[Missing <param name="spans"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight,Lucene.Net.Search.Spans.TermSpans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight,Lucene.Net.Search.Spans.TermSpans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight,Lucene.Net.Search.Spans.TermSpans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

norms
Type: array< System..::..Byte >[]()[][]

[Missing <param name="norms"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.#ctor(Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight,Lucene.Net.Search.Spans.TermSpans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Fields

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Fields
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer type exposes the following members.

Fields

 | Name | Description
Protected field | doc | (Inherited from SpanScorer.)
Protected field | firstTime | Obsolete. (Inherited from SpanScorer.)
Protected field | freq | (Inherited from SpanScorer.)
Protected field | more | (Inherited from SpanScorer.)
Protected field | norms | (Inherited from SpanScorer.)
Protected field | payload |
Protected field | payloadScore |
Protected field | payloadsSeen |
Protected field | positions |
Protected field | spans | (Inherited from SpanScorer.)
Protected field | value_Renamed | (Inherited from SpanScorer.)
Protected field | weight | (Inherited from SpanScorer.)

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


payload Field

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..payload Field
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.payload"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal byte[] payload
Visual Basic
Protected Friend payload As Byte()
Visual C++
protected public:
array<unsigned char>^ payload

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


payloadScore Field

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..payloadScore Field
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.payloadScore"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float payloadScore
Visual Basic
Protected Friend payloadScore As Single
Visual C++
protected public:
float payloadScore

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


payloadsSeen Field

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..payloadsSeen Field
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.payloadsSeen"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int payloadsSeen
Visual Basic
Protected Friend payloadsSeen As Integer
Visual C++
protected public:
int payloadsSeen

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


positions Field

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..positions Field
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.positions"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermPositions positions
Visual Basic
Protected Friend positions As TermPositions
Visual C++
protected public:
TermPositions^ positions

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Methods

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Methods
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer type exposes the following members.

Methods

Name | Description
Public method | Advance | (Inherited from SpanScorer.)
Public method | Doc | Obsolete. (Inherited from SpanScorer.)
Public method | DocID | (Inherited from SpanScorer.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides SpanScorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetPayloadScore
The score for the payload
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Protected method GetSpanScore
Returns the SpanScorer score only.

Should not be overriden without good cause!

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Inherited from SpanScorer.)
Public method | NextDoc | (Inherited from SpanScorer.)
Protected method | ProcessPayload
Public method Score()()()()
(Overrides SpanScorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SetFreqCurrentDoc | (Overrides SpanScorer..::..SetFreqCurrentDoc()()()().)
Public method | SkipTo | Obsolete. (Inherited from SpanScorer.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


Explain Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..Explain Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.Explain(System.Int32)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.Explain(System.Int32)"]

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


GetPayloadScore Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..GetPayloadScore Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback
The score for the payload

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual float GetPayloadScore()
Visual Basic
Protected Friend Overridable Function GetPayloadScore As Single
Visual C++
protected public:
virtual float GetPayloadScore()

Return Value

The score, as calculated by {@link PayloadFunction#DocScore(int, String, int, float)}

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


GetSpanScore Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..GetSpanScore Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback
Returns the SpanScorer score only.

Should not be overriden without good cause!

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual float GetSpanScore()
Visual Basic
Protected Friend Overridable Function GetSpanScore As Single
Visual C++
protected public:
virtual float GetSpanScore()

Return Value

the score for just the Span part w/o the payload

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..Score()()()()


ProcessPayload Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..ProcessPayload Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.ProcessPayload(Lucene.Net.Search.Similarity)"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void ProcessPayload(
    Similarity similarity
)
Visual Basic
Protected Friend Overridable Sub ProcessPayload ( _
    similarity As Similarity _
)
Visual C++
protected public:
virtual void ProcessPayload(
    Similarity^ similarity
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.ProcessPayload(Lucene.Net.Search.Similarity)"]

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..Score Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

Overload List

Name Description
Public method Score()()()()
(Overrides SpanScorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Members
Lucene.Net.Search.Payloads Namespace


Score Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..Score Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.Score"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

{@link #GetSpanScore()} * {@link #GetPayloadScore()}

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Score Overload
Lucene.Net.Search.Payloads Namespace


SetFreqCurrentDoc Method

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..SetFreqCurrentDoc Method
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.SetFreqCurrentDoc"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool SetFreqCurrentDoc()
Visual Basic
Public Overrides Function SetFreqCurrentDoc As Boolean
Visual C++
public:
virtual bool SetFreqCurrentDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.SetFreqCurrentDoc"]

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer Properties

[image] [image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Properties
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

The PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer type exposes the following members.

Properties

 | Name | Description
Public property | Enclosing_Instance |

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


Enclosing_Instance Property

[image]

Lucene.Net Class Libraries
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer..::..Enclosing_Instance Property
PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Payloads.PayloadTermQuery.PayloadTermWeight.PayloadTermSpanScorer.Enclosing_Instance"]

Namespace: Lucene.Net.Search.Payloads
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public PayloadTermQuery..::..PayloadTermWeight Enclosing_Instance { get; }
Visual Basic
Public ReadOnly Property Enclosing_Instance As PayloadTermQuery..::..PayloadTermWeight
    Get
Visual C++
public:
property PayloadTermQuery..::..PayloadTermWeight^ Enclosing_Instance {
    PayloadTermQuery..::..PayloadTermWeight^ get ();
}

See Also

PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer Class
Lucene.Net.Search.Payloads Namespace


Lucene.Net.Search.Regex Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.Regex Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.Regex"]

Classes

 | Class | Description
Public class | CSharpRegexCapabilities | C# Regex based implementation of IRegexCapabilities.
Public class | RegexQuery | Regular expression based query.
Public class | RegexTermEnum | Subclass of FilteredTermEnum for enumerating all terms that match the specified regular expression term using the specified regular expression implementation. Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.
Public class | SpanRegexQuery | A SpanQuery version of RegexQuery allowing regular expression queries to be nested within other SpanQuery subclasses.

Interfaces

 | Interface | Description
Public interface | IRegexCapabilities | Defines basic operations needed by {@link RegexQuery} for a regular expression implementation.
Public interface | IRegexQueryCapable | Defines methods for regular expression supporting queries to use.


CSharpRegexCapabilities Class

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities Class
Members See Also Send Feedback
C# Regex based implementation of IRegexCapabilities.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class CSharpRegexCapabilities : IRegexCapabilities,
    IEquatable<CSharpRegexCapabilities>
Visual Basic
Public Class CSharpRegexCapabilities _
    Implements IRegexCapabilities, IEquatable(Of CSharpRegexCapabilities)
Visual C++
public ref class CSharpRegexCapabilities : IRegexCapabilities,
    IEquatable<CSharpRegexCapabilities^>

Remarks

http://www.java2s.com/Open-Source/Java-Document/Net/lucene-connector/org/apache/lucene/search/regex/JavaUtilRegexCapabilities.java.htm

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Regex..::..CSharpRegexCapabilities

See Also

CSharpRegexCapabilities Members
Lucene.Net.Search.Regex Namespace


CSharpRegexCapabilities Members

[image] [image]

Lucene.Net Class Libraries
CSharpRegexCapabilities Members
CSharpRegexCapabilities Class Constructors Methods See Also Send Feedback

The CSharpRegexCapabilities type exposes the following members.

Constructors

 | Name | Description
Public method | CSharpRegexCapabilities | Initializes a new instance of the CSharpRegexCapabilities class

Methods

 | Name | Description
Public method | Compile | Called by the constructor of RegexTermEnum allowing implementations to cache a compiled version of the regular expression pattern.
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(CSharpRegexCapabilities) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match | True on match.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Prefix | A wise prefix implementation can reduce the term enumeration (and thus performance) of RegexQuery dramatically.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


CSharpRegexCapabilities Constructor

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities Constructor
CSharpRegexCapabilities Class See Also Send Feedback
Initializes a new instance of the CSharpRegexCapabilities class

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public CSharpRegexCapabilities()
Visual Basic
Public Sub New
Visual C++
public:
CSharpRegexCapabilities()

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


CSharpRegexCapabilities Methods

[image] [image]

Lucene.Net Class Libraries
CSharpRegexCapabilities Methods
CSharpRegexCapabilities Class See Also Send Feedback

The CSharpRegexCapabilities type exposes the following members.

Methods

 | Name | Description
Public method | Compile | Called by the constructor of RegexTermEnum allowing implementations to cache a compiled version of the regular expression pattern.
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(CSharpRegexCapabilities) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match | True on match.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Prefix | A wise prefix implementation can reduce the term enumeration (and thus performance) of RegexQuery dramatically.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


Compile Method

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..Compile Method
CSharpRegexCapabilities Class See Also Send Feedback
Called by the constructor of RegexTermEnum allowing implementations to cache a compiled version of the regular expression pattern.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public void Compile(
    string pattern
)
Visual Basic
Public Sub Compile ( _
    pattern As String _
)
Visual C++
public:
virtual void Compile(
    String^ pattern
) sealed

Parameters

pattern
Type: System..::..String
regular expression pattern

Implements

IRegexCapabilities..::..Compile(String)

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


Equals Method

[image] [image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..Equals Method
CSharpRegexCapabilities Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(CSharpRegexCapabilities) | Indicates whether the current object is equal to another object of the same type.

See Also

CSharpRegexCapabilities Class
CSharpRegexCapabilities Members
Lucene.Net.Search.Regex Namespace


Equals Method (Object)

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..Equals Method (Object)
CSharpRegexCapabilities Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.CSharpRegexCapabilities.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Regex.CSharpRegexCapabilities.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.CSharpRegexCapabilities.Equals(System.Object)"]

See Also

CSharpRegexCapabilities Class
Equals Overload
Lucene.Net.Search.Regex Namespace


Equals Method (CSharpRegexCapabilities)

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..Equals Method (CSharpRegexCapabilities)
CSharpRegexCapabilities Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public bool Equals(
    CSharpRegexCapabilities other
)
Visual Basic
Public Function Equals ( _
    other As CSharpRegexCapabilities _
) As Boolean
Visual C++
public:
virtual bool Equals(
    CSharpRegexCapabilities^ other
) sealed

Parameters

other
Type: Lucene.Net.Search.Regex..::..CSharpRegexCapabilities
An object to compare with this object

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

CSharpRegexCapabilities Class
Equals Overload
Lucene.Net.Search.Regex Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..GetHashCode Method
CSharpRegexCapabilities Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.CSharpRegexCapabilities.GetHashCode"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.CSharpRegexCapabilities.GetHashCode"]

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


Match Method

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..Match Method
CSharpRegexCapabilities Class See Also Send Feedback
True on match.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public bool Match(
    string s
)
Visual Basic
Public Function Match ( _
    s As String _
) As Boolean
Visual C++
public:
virtual bool Match(
    String^ s
) sealed

Parameters

s
Type: System..::..String
text to match

Return Value

true on match

Implements

IRegexCapabilities..::..Match(String)

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


Prefix Method

[image]

Lucene.Net Class Libraries
CSharpRegexCapabilities..::..Prefix Method
CSharpRegexCapabilities Class See Also Send Feedback
A wise prefix implementation can reduce the term enumeration (and thus performance) of RegexQuery dramatically.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public string Prefix()
Visual Basic
Public Function Prefix As String
Visual C++
public:
virtual String^ Prefix() sealed

Return Value

static non-regex prefix of the pattern last passed to Compile(String). May return null

Implements

IRegexCapabilities..::..Prefix()()()()

See Also

CSharpRegexCapabilities Class
Lucene.Net.Search.Regex Namespace


IRegexCapabilities Interface

[image]

Lucene.Net Class Libraries
IRegexCapabilities Interface
Members See Also Send Feedback
Defines basic operations needed by {@link RegexQuery} for a regular expression implementation.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public interface IRegexCapabilities
Visual Basic
Public Interface IRegexCapabilities
Visual C++
public interface class IRegexCapabilities

Remarks

http://www.java2s.com/Open-Source/Java-Document/Net/lucene-connector/org/apache/lucene/search/regex/RegexCapabilities.java.htm

See Also

IRegexCapabilities Members
Lucene.Net.Search.Regex Namespace


IRegexCapabilities Members

[image] [image]

Lucene.Net Class Libraries
IRegexCapabilities Members
IRegexCapabilities Interface Methods See Also Send Feedback

The IRegexCapabilities type exposes the following members.

Methods

 | Name | Description
Public method | Compile | Called by the constructor of RegexTermEnum allowing implementations to cache a compiled version of the regular expression pattern.
Public method | Match | True on match.
Public method | Prefix | A wise prefix implementation can reduce the term enumeration (and thus performance) of RegexQuery dramatically.

See Also

IRegexCapabilities Interface
Lucene.Net.Search.Regex Namespace


IRegexCapabilities Methods

[image] [image]

Lucene.Net Class Libraries
IRegexCapabilities Methods
IRegexCapabilities Interface See Also Send Feedback

The IRegexCapabilities type exposes the following members.

Methods

 | Name | Description
Public method | Compile | Called by the constructor of RegexTermEnum allowing implementations to cache a compiled version of the regular expression pattern.
Public method | Match | True on match.
Public method | Prefix | A wise prefix implementation can reduce the term enumeration (and thus performance) of RegexQuery dramatically.

See Also

IRegexCapabilities Interface
Lucene.Net.Search.Regex Namespace


Compile Method

[image]

Lucene.Net Class Libraries
IRegexCapabilities..::..Compile Method
IRegexCapabilities Interface See Also Send Feedback
Called by the constructor of RegexTermEnum allowing implementations to cache a compiled version of the regular expression pattern.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
void Compile(
    string pattern
)
Visual Basic
Sub Compile ( _
    pattern As String _
)
Visual C++
void Compile(
    String^ pattern
)

Parameters

pattern
Type: System..::..String
regular expression pattern

See Also

IRegexCapabilities Interface
Lucene.Net.Search.Regex Namespace


Match Method

[image]

Lucene.Net Class Libraries
IRegexCapabilities..::..Match Method
IRegexCapabilities Interface See Also Send Feedback
True on match.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
bool Match(
    string s
)
Visual Basic
Function Match ( _
    s As String _
) As Boolean
Visual C++
bool Match(
    String^ s
)

Parameters

s
Type: System..::..String
text to match

Return Value

true on match

See Also

IRegexCapabilities Interface
Lucene.Net.Search.Regex Namespace


Prefix Method

[image]

Lucene.Net Class Libraries
IRegexCapabilities..::..Prefix Method
IRegexCapabilities Interface See Also Send Feedback
A wise prefix implementation can reduce the term enumeration (and thus performance) of RegexQuery dramatically.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
string Prefix()
Visual Basic
Function Prefix As String
Visual C++
String^ Prefix()

Return Value

static non-regex prefix of the pattern last passed to Compile(String). May return null

See Also

IRegexCapabilities Interface
Lucene.Net.Search.Regex Namespace


IRegexQueryCapable Interface

[image]

Lucene.Net Class Libraries
IRegexQueryCapable Interface
Members See Also Send Feedback
Defines methods for regular expression supporting queries to use.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public interface IRegexQueryCapable
Visual Basic
Public Interface IRegexQueryCapable
Visual C++
public interface class IRegexQueryCapable

Remarks

http://www.java2s.com/Open-Source/Java-Document/Net/lucene-connector/org/apache/lucene/search/regex/RegexQueryCapable.java.htm

See Also

IRegexQueryCapable Members
Lucene.Net.Search.Regex Namespace


IRegexQueryCapable Members

[image] [image]

Lucene.Net Class Libraries
IRegexQueryCapable Members
IRegexQueryCapable Interface Methods See Also Send Feedback

The IRegexQueryCapable type exposes the following members.

Methods

 | Name | Description
Public method | GetRegexImplementation |
Public method | SetRegexImplementation |

See Also

IRegexQueryCapable Interface
Lucene.Net.Search.Regex Namespace


IRegexQueryCapable Methods

[image] [image]

Lucene.Net Class Libraries
IRegexQueryCapable Methods
IRegexQueryCapable Interface See Also Send Feedback

The IRegexQueryCapable type exposes the following members.

Methods

 | Name | Description
Public method | GetRegexImplementation |
Public method | SetRegexImplementation |

See Also

IRegexQueryCapable Interface
Lucene.Net.Search.Regex Namespace


GetRegexImplementation Method

[image]

Lucene.Net Class Libraries
IRegexQueryCapable..::..GetRegexImplementation Method
IRegexQueryCapable Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.IRegexQueryCapable.GetRegexImplementation"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
IRegexCapabilities GetRegexImplementation()
Visual Basic
Function GetRegexImplementation As IRegexCapabilities
Visual C++
IRegexCapabilities^ GetRegexImplementation()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.IRegexQueryCapable.GetRegexImplementation"]

See Also

IRegexQueryCapable Interface
Lucene.Net.Search.Regex Namespace


SetRegexImplementation Method

[image]

Lucene.Net Class Libraries
IRegexQueryCapable..::..SetRegexImplementation Method
IRegexQueryCapable Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.IRegexQueryCapable.SetRegexImplementation(Lucene.Net.Search.Regex.IRegexCapabilities)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
void SetRegexImplementation(
    IRegexCapabilities impl
)
Visual Basic
Sub SetRegexImplementation ( _
    impl As IRegexCapabilities _
)
Visual C++
void SetRegexImplementation(
    IRegexCapabilities^ impl
)

Parameters

impl
Type: Lucene.Net.Search.Regex..::..IRegexCapabilities

[Missing <param name="impl"/> documentation for "M:Lucene.Net.Search.Regex.IRegexQueryCapable.SetRegexImplementation(Lucene.Net.Search.Regex.IRegexCapabilities)"]

See Also

IRegexQueryCapable Interface
Lucene.Net.Search.Regex Namespace


RegexQuery Class

[image]

Lucene.Net Class Libraries
RegexQuery Class
Members See Also Send Feedback
Regular expression based query.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class RegexQuery : MultiTermQuery, IRegexQueryCapable,
    IEquatable<RegexQuery>
Visual Basic
Public Class RegexQuery _
    Inherits MultiTermQuery _
    Implements IRegexQueryCapable, IEquatable(Of RegexQuery)
Visual C++
public ref class RegexQuery : public MultiTermQuery,
    IRegexQueryCapable, IEquatable<RegexQuery^>

Remarks

http://www.java2s.com/Open-Source/Java-Document/Net/lucene-connector/org/apache/lucene/search/regex/RegexQuery.java.htm

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search..::..MultiTermQuery
Lucene.Net.Search.Regex..::..RegexQuery

See Also

RegexQuery Members
Lucene.Net.Search.Regex Namespace


RegexQuery Members

[image] [image]

Lucene.Net Class Libraries
RegexQuery Members
RegexQuery Class Constructors Methods Fields See Also Send Feedback

The RegexQuery type exposes the following members.

Constructors

 | Name | Description
Public method | RegexQuery | Initializes a new instance of the RegexQuery class

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals(Object) | (Overrides MultiTermQuery..::..Equals(Object).)
Public method Equals(RegexQuery)
Indicates whether the current object is equal to another object of the same type.
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetEnum
Construct the enumeration to be used, expanding the pattern term.
(Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method | GetRegexImplementation
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetRegexImplementation
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from MultiTermQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


RegexQuery Constructor

[image]

Lucene.Net Class Libraries
RegexQuery Constructor
RegexQuery Class See Also Send Feedback
Initializes a new instance of the RegexQuery class

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public RegexQuery(
    Term term
)
Visual Basic
Public Sub New ( _
    term As Term _
)
Visual C++
public:
RegexQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


RegexQuery Fields

[image] [image]

Lucene.Net Class Libraries
RegexQuery Fields
RegexQuery Class See Also Send Feedback

The RegexQuery type exposes the following members.

Fields

 | Name | Description
Protected field | rewriteMethod | (Inherited from MultiTermQuery.)
Protected field | term | (Inherited from MultiTermQuery.)

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


RegexQuery Methods

[image] [image]

Lucene.Net Class Libraries
RegexQuery Methods
RegexQuery Class See Also Send Feedback

The RegexQuery type exposes the following members.

Methods

Name | Description
Public method ClearTotalNumberOfTerms
Expert: Resets the counting of unique terms. Do this before executing the query/filter.
(Inherited from MultiTermQuery.)
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals(Object) | (Overrides MultiTermQuery..::..Equals(Object).)
Public method Equals(RegexQuery)
Indicates whether the current object is equal to another object of the same type.
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetEnum
Construct the enumeration to be used, expanding the pattern term.
(Overrides MultiTermQuery..::..GetEnum(IndexReader).)
Public method | GetHashCode | (Overrides MultiTermQuery..::..GetHashCode()()()().)
Public method | GetRegexImplementation
Public method | GetRewriteMethod | (Inherited from MultiTermQuery.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetTerm Obsolete.
Returns the pattern term.
(Inherited from MultiTermQuery.)
Public method GetTotalNumberOfTerms
Expert: Return the number of unique terms visited during execution of the query. If there are many of them, you may consider using another query type or optimize your total term count in index.

This method is not thread safe, be sure to only call it when no query is running! If you re-use the same query instance for another search, be sure to first reset the term counter with {@link #clearTotalNumberOfTerms}.

On optimized indexes / no MultiReaders, you get the correct number of unique terms for the whole index. Use this number to compare different queries. For non-optimized indexes this number can also be achived in non-constant-score mode. In constant-score mode you get the total number of terms seeked for all segments / sub-readers.

(Inherited from MultiTermQuery.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method | IncTotalNumberOfTerms | (Inherited from MultiTermQuery.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Inherited from MultiTermQuery.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetRegexImplementation
Public method SetRewriteMethod
Sets the rewrite method to be used when executing the query. You can use one of the four core methods, or implement your own subclass of {@link RewriteMethod}.
(Inherited from MultiTermQuery.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Inherited from MultiTermQuery.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


Equals Method

[image] [image]

Lucene.Net Class Libraries
RegexQuery..::..Equals Method
RegexQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | (Overrides MultiTermQuery..::..Equals(Object).)
Public method | Equals(RegexQuery) | Indicates whether the current object is equal to another object of the same type.

See Also

RegexQuery Class
RegexQuery Members
Lucene.Net.Search.Regex Namespace


Equals Method (Object)

[image]

Lucene.Net Class Libraries
RegexQuery..::..Equals Method (Object)
RegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.Equals(System.Object)"]

See Also

RegexQuery Class
Equals Overload
Lucene.Net.Search.Regex Namespace


Equals Method (RegexQuery)

[image]

Lucene.Net Class Libraries
RegexQuery..::..Equals Method (RegexQuery)
RegexQuery Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public bool Equals(
    RegexQuery other
)
Visual Basic
Public Function Equals ( _
    other As RegexQuery _
) As Boolean
Visual C++
public:
virtual bool Equals(
    RegexQuery^ other
) sealed

Parameters

other
Type: Lucene.Net.Search.Regex..::..RegexQuery
An object to compare with this object

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

RegexQuery Class
Equals Overload
Lucene.Net.Search.Regex Namespace


GetEnum Method

[image]

Lucene.Net Class Libraries
RegexQuery..::..GetEnum Method
RegexQuery Class See Also Send Feedback
Construct the enumeration to be used, expanding the pattern term.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override FilteredTermEnum GetEnum(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetEnum ( _
    reader As IndexReader _
) As FilteredTermEnum
Visual C++
public:
virtual FilteredTermEnum^ GetEnum(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.GetEnum(Lucene.Net.Index.IndexReader)"]

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
RegexQuery..::..GetHashCode Method
RegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.GetHashCode"]

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


GetRegexImplementation Method

[image]

Lucene.Net Class Libraries
RegexQuery..::..GetRegexImplementation Method
RegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.GetRegexImplementation"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public IRegexCapabilities GetRegexImplementation()
Visual Basic
Public Function GetRegexImplementation As IRegexCapabilities
Visual C++
public:
virtual IRegexCapabilities^ GetRegexImplementation() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.GetRegexImplementation"]

Implements

IRegexQueryCapable..::..GetRegexImplementation()()()()

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


SetRegexImplementation Method

[image]

Lucene.Net Class Libraries
RegexQuery..::..SetRegexImplementation Method
RegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.SetRegexImplementation(Lucene.Net.Search.Regex.IRegexCapabilities)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public void SetRegexImplementation(
    IRegexCapabilities impl
)
Visual Basic
Public Sub SetRegexImplementation ( _
    impl As IRegexCapabilities _
)
Visual C++
public:
virtual void SetRegexImplementation(
    IRegexCapabilities^ impl
) sealed

Parameters

impl
Type: Lucene.Net.Search.Regex..::..IRegexCapabilities

[Missing <param name="impl"/> documentation for "M:Lucene.Net.Search.Regex.RegexQuery.SetRegexImplementation(Lucene.Net.Search.Regex.IRegexCapabilities)"]

Implements

IRegexQueryCapable..::..SetRegexImplementation(IRegexCapabilities)

See Also

RegexQuery Class
Lucene.Net.Search.Regex Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
RegexQuery..::..ToString Method
RegexQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Inherited from MultiTermQuery.)

See Also

RegexQuery Class
RegexQuery Members
Lucene.Net.Search.Regex Namespace


RegexTermEnum Class

[image]

Lucene.Net Class Libraries
RegexTermEnum Class
Members See Also Send Feedback
Subclass of FilteredTermEnum for enumerating all terms that match the specified regular expression term using the specified regular expression implementation.

Term enumerations are always ordered by Term.compareTo(). Each term in the enumeration is greater than all that precede it.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class RegexTermEnum : FilteredTermEnum
Visual Basic
Public Class RegexTermEnum _
    Inherits FilteredTermEnum
Visual C++
public ref class RegexTermEnum : public FilteredTermEnum

Remarks

http://www.java2s.com/Open-Source/Java-Document/Net/lucene-connector/org/apache/lucene/search/regex/RegexTermEnum.java.htm

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermEnum
Lucene.Net.Search..::..FilteredTermEnum
Lucene.Net.Search.Regex..::..RegexTermEnum

See Also

RegexTermEnum Members
Lucene.Net.Search.Regex Namespace


RegexTermEnum Members

[image] [image]

Lucene.Net Class Libraries
RegexTermEnum Members
RegexTermEnum Class Constructors Methods Fields See Also Send Feedback

The RegexTermEnum type exposes the following members.

Constructors

 | Name | Description
Public method | RegexTermEnum | Initializes a new instance of the RegexTermEnum class

Methods

Name Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method Difference
Equality measure on the term
(Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method EndEnum
Indicates the end of the enumeration has been reached
(Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method TermCompare
Equality compare on the term
(Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


RegexTermEnum Constructor

[image]

Lucene.Net Class Libraries
RegexTermEnum Constructor
RegexTermEnum Class See Also Send Feedback
Initializes a new instance of the RegexTermEnum class

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public RegexTermEnum(
    IndexReader reader,
    Term term,
    IRegexCapabilities regexImpl
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    term As Term, _
    regexImpl As IRegexCapabilities _
)
Visual C++
public:
RegexTermEnum(
    IndexReader^ reader,
    Term^ term,
    IRegexCapabilities^ regexImpl
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term,Lucene.Net.Search.Regex.IRegexCapabilities)"]

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term,Lucene.Net.Search.Regex.IRegexCapabilities)"]

regexImpl
Type: Lucene.Net.Search.Regex..::..IRegexCapabilities

[Missing <param name="regexImpl"/> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Index.Term,Lucene.Net.Search.Regex.IRegexCapabilities)"]

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


RegexTermEnum Fields

[image] [image]

Lucene.Net Class Libraries
RegexTermEnum Fields
RegexTermEnum Class See Also Send Feedback

The RegexTermEnum type exposes the following members.

Fields

 | Name | Description
Protected field | actualEnum | the delegate enum - to set this member use {@link #setEnum} (Inherited from FilteredTermEnum.)
Protected field | currentTerm | the current term (Inherited from FilteredTermEnum.)

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


RegexTermEnum Methods

[image] [image]

Lucene.Net Class Libraries
RegexTermEnum Methods
RegexTermEnum Class See Also Send Feedback

The RegexTermEnum type exposes the following members.

Methods

Name Description
Public method Close
Closes the enumeration to further activity, freeing resources.
(Inherited from FilteredTermEnum.)
Public method Difference
Equality measure on the term
(Overrides FilteredTermEnum..::..Difference()()()().)
Public method DocFreq
Returns the docFreq of the current Term in the enumeration. Returns -1 if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method EndEnum
Indicates the end of the enumeration has been reached
(Overrides FilteredTermEnum..::..EndEnum()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Increments the enumeration to the next element. True if one exists.
(Inherited from FilteredTermEnum.)
Protected method SetEnum
use this method to set the actual TermEnum (e.g. in ctor), it will be automatically positioned on the first matching term.
(Inherited from FilteredTermEnum.)
Public method SkipTo Obsolete.
Skips terms to the first beyond the current whose value is greater or equal to target.

Returns true iff there is such an entry.

Behaves as if written:

            public boolean skipTo(Term target) {
            do {
            if (!next())
            return false;
            } while (target > term());
            return true;
            }
Some implementations *could* be considerably more efficient than a linear scan. Check the implementation to be sure.
(Inherited from TermEnum.)
Public method Term
Returns the current Term in the enumeration. Returns null if no Term matches or all terms have been enumerated.
(Inherited from FilteredTermEnum.)
Public method TermCompare
Equality compare on the term
(Overrides FilteredTermEnum..::..TermCompare(Term).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


Difference Method

[image]

Lucene.Net Class Libraries
RegexTermEnum..::..Difference Method
RegexTermEnum Class See Also Send Feedback
Equality measure on the term

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override float Difference()
Visual Basic
Public Overrides Function Difference As Single
Visual C++
public:
virtual float Difference() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.Difference"]

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


EndEnum Method

[image]

Lucene.Net Class Libraries
RegexTermEnum..::..EndEnum Method
RegexTermEnum Class See Also Send Feedback
Indicates the end of the enumeration has been reached

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override bool EndEnum()
Visual Basic
Public Overrides Function EndEnum As Boolean
Visual C++
public:
virtual bool EndEnum() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.EndEnum"]

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


TermCompare Method

[image]

Lucene.Net Class Libraries
RegexTermEnum..::..TermCompare Method
RegexTermEnum Class See Also Send Feedback
Equality compare on the term

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override bool TermCompare(
    Term term
)
Visual Basic
Public Overrides Function TermCompare ( _
    term As Term _
) As Boolean
Visual C++
public:
virtual bool TermCompare(
    Term^ term
) override

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.TermCompare(Lucene.Net.Index.Term)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.RegexTermEnum.TermCompare(Lucene.Net.Index.Term)"]

See Also

RegexTermEnum Class
Lucene.Net.Search.Regex Namespace


SpanRegexQuery Class

[image]

Lucene.Net Class Libraries
SpanRegexQuery Class
Members See Also Send Feedback
A SpanQuery version of RegexQuery allowing regular expression queries to be nested within other SpanQuery subclasses.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public class SpanRegexQuery : SpanQuery,
    IRegexQueryCapable, IEquatable<SpanRegexQuery>
Visual Basic
Public Class SpanRegexQuery _
    Inherits SpanQuery _
    Implements IRegexQueryCapable, IEquatable(Of SpanRegexQuery)
Visual C++
public ref class SpanRegexQuery : public SpanQuery,
    IRegexQueryCapable, IEquatable<SpanRegexQuery^>

Remarks

http://www.java2s.com/Open-Source/Java-Document/Net/lucene-connector/org/apache/lucene/search/regex/SpanRegexQuery.java.htm

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Regex..::..SpanRegexQuery

See Also

SpanRegexQuery Members
Lucene.Net.Search.Regex Namespace


SpanRegexQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanRegexQuery Members
SpanRegexQuery Class Constructors Methods See Also Send Feedback

The SpanRegexQuery type exposes the following members.

Constructors

 | Name | Description
Public method | SpanRegexQuery | Initializes a new instance of the SpanRegexQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method Equals(Object)
True if this object equals the specified object.
(Overrides Query..::..Equals(Object).)
Public method Equals(SpanRegexQuery)
Indicates whether the current object is equal to another object of the same type.
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetField
Returns the name of the field matched by this query.
(Overrides SpanQuery..::..GetField()()()().)
Public method GetHashCode
Get hash code for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method | GetRegexImplementation
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSpans
Expert: Returns the matches for this query in an index. Used internally to search for spans.
(Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method | GetTerm
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetRegexImplementation
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


SpanRegexQuery Constructor

[image]

Lucene.Net Class Libraries
SpanRegexQuery Constructor
SpanRegexQuery Class See Also Send Feedback
Initializes a new instance of the SpanRegexQuery class

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public SpanRegexQuery(
    Term term
)
Visual Basic
Public Sub New ( _
    term As Term _
)
Visual C++
public:
SpanRegexQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


SpanRegexQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanRegexQuery Methods
SpanRegexQuery Class See Also Send Feedback

The SpanRegexQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method Equals(Object)
True if this object equals the specified object.
(Overrides Query..::..Equals(Object).)
Public method Equals(SpanRegexQuery)
Indicates whether the current object is equal to another object of the same type.
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetField
Returns the name of the field matched by this query.
(Overrides SpanQuery..::..GetField()()()().)
Public method GetHashCode
Get hash code for this object.
(Overrides Query..::..GetHashCode()()()().)
Public method | GetRegexImplementation
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSpans
Expert: Returns the matches for this query in an index. Used internally to search for spans.
(Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method | GetTerm
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetRegexImplementation
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


Equals Method

[image] [image]

Lucene.Net Class Libraries
SpanRegexQuery..::..Equals Method
SpanRegexQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | True if this object equals the specified object. (Overrides Query..::..Equals(Object).)
Public method | Equals(SpanRegexQuery) | Indicates whether the current object is equal to another object of the same type.

See Also

SpanRegexQuery Class
SpanRegexQuery Members
Lucene.Net.Search.Regex Namespace


Equals Method (Object)

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..Equals Method (Object)
SpanRegexQuery Class See Also Send Feedback
True if this object equals the specified object.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object

Return Value

true on equality

See Also

SpanRegexQuery Class
Equals Overload
Lucene.Net.Search.Regex Namespace


Equals Method (SpanRegexQuery)

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..Equals Method (SpanRegexQuery)
SpanRegexQuery Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public bool Equals(
    SpanRegexQuery other
)
Visual Basic
Public Function Equals ( _
    other As SpanRegexQuery _
) As Boolean
Visual C++
public:
virtual bool Equals(
    SpanRegexQuery^ other
) sealed

Parameters

other
Type: Lucene.Net.Search.Regex..::..SpanRegexQuery
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

SpanRegexQuery Class
Equals Overload
Lucene.Net.Search.Regex Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..GetField Method
SpanRegexQuery Class See Also Send Feedback
Returns the name of the field matched by this query.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetField"]

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..GetHashCode Method
SpanRegexQuery Class See Also Send Feedback
Get hash code for this object.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

hash code

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


GetRegexImplementation Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..GetRegexImplementation Method
SpanRegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetRegexImplementation"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public IRegexCapabilities GetRegexImplementation()
Visual Basic
Public Function GetRegexImplementation As IRegexCapabilities
Visual C++
public:
virtual IRegexCapabilities^ GetRegexImplementation() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetRegexImplementation"]

Implements

IRegexQueryCapable..::..GetRegexImplementation()()()()

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..GetSpans Method
SpanRegexQuery Class See Also Send Feedback
Expert: Returns the matches for this query in an index. Used internally to search for spans.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..GetTerm Method
SpanRegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetTerm"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public Term GetTerm()
Visual Basic
Public Function GetTerm As Term
Visual C++
public:
Term^ GetTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetTerm"]

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..GetTerms Method
SpanRegexQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
[ObsoleteAttribute("use ExtractTerms instead")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms instead")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms instead")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.GetTerms"]

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace
Query..::..ExtractTerms(Hashtable)


Rewrite Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..Rewrite Method
SpanRegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


SetRegexImplementation Method

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..SetRegexImplementation Method
SpanRegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.SetRegexImplementation(Lucene.Net.Search.Regex.IRegexCapabilities)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public void SetRegexImplementation(
    IRegexCapabilities impl
)
Visual Basic
Public Sub SetRegexImplementation ( _
    impl As IRegexCapabilities _
)
Visual C++
public:
virtual void SetRegexImplementation(
    IRegexCapabilities^ impl
) sealed

Parameters

impl
Type: Lucene.Net.Search.Regex..::..IRegexCapabilities

[Missing <param name="impl"/> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.SetRegexImplementation(Lucene.Net.Search.Regex.IRegexCapabilities)"]

Implements

IRegexQueryCapable..::..SetRegexImplementation(IRegexCapabilities)

See Also

SpanRegexQuery Class
Lucene.Net.Search.Regex Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanRegexQuery..::..ToString Method
SpanRegexQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

SpanRegexQuery Class
SpanRegexQuery Members
Lucene.Net.Search.Regex Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
SpanRegexQuery..::..ToString Method (String)
SpanRegexQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Regex
Assembly: Contrib.Regex (in Contrib.Regex.dll) Version: 2.9.4.0 (2.9.4)

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Regex.SpanRegexQuery.ToString(System.String)"]

See Also

SpanRegexQuery Class
ToString Overload
Lucene.Net.Search.Regex Namespace


Lucene.Net.Search.Similar Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.Similar Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.Similar"]

Classes

 | Class | Description
Public class | MoreLikeThis |
Public class | MoreLikeThisQuery |


MoreLikeThis Class

[image]

Lucene.Net Class Libraries
MoreLikeThis Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Similar.MoreLikeThis"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public sealed class MoreLikeThis
Visual Basic
Public NotInheritable Class MoreLikeThis
Visual C++
public ref class MoreLikeThis sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Similar..::..MoreLikeThis

See Also

MoreLikeThis Members
Lucene.Net.Search.Similar Namespace


MoreLikeThis Members

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Members
MoreLikeThis Class Constructors Methods Fields See Also Send Feedback

The MoreLikeThis type exposes the following members.

Constructors

 | Name | Description
Public method | MoreLikeThis(IndexReader) | Constructor requiring an IndexReader.
Public method | MoreLikeThis(IndexReader, Similarity) | Initializes a new instance of the MoreLikeThis class

Methods

 | Name | Description
Public method | DescribeParams | Describe the parameters that control how the "more like this" query is formed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnalyzer | Returns an analyzer that will be used to parse source doc with. The default analyzer is the {@link #DEFAULT_ANALYZER}.
Public method | GetBoostFactor | Returns the boost factor used when boosting terms
Public method | GetFieldNames | Returns the field names that will be used when generating the 'More Like This' query. The default field names that will be used is {@link #DEFAULT_FIELD_NAMES}.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxNumTokensParsed |
Public method | GetMaxQueryTerms | Returns the maximum number of query terms that will be included in any generated query. The default is {@link #DEFAULT_MAX_QUERY_TERMS}.
Public method | GetMaxWordLen | Returns the maximum word length above which words will be ignored. Set this to 0 for no maximum word length. The default is {@link #DEFAULT_MAX_WORD_LENGTH}.
Public method | GetMinDocFreq | Returns the frequency at which words will be ignored which do not occur in at least this many docs. The default frequency is {@link #DEFALT_MIN_DOC_FREQ}.
Public method | GetMinTermFreq | Returns the frequency below which terms will be ignored in the source doc. The default frequency is the {@link #DEFAULT_MIN_TERM_FREQ}.
Public method | GetMinWordLen | Returns the minimum word length below which words will be ignored. Set this to 0 for no minimum word length. The default is {@link #DEFAULT_MIN_WORD_LENGTH}.
Public method | GetSimilarity |
Public method | GetStopWords | Get the current stop words being used.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBoost | Returns whether to boost terms in query based on "score" or not. The default is {@link #DEFAULT_BOOST}.
Public method | Like(Int32) | Return a query that will return docs like the passed lucene document ID.
Public method | Like(FileInfo) | Return a query that will return docs like the passed file.
Public method | Like(Stream) | Return a query that will return docs like the passed stream.
Public method | Like(TextReader) | Return a query that will return docs like the passed Reader.
Public method | Like(Uri) | Return a query that will return docs like the passed URL.
 | Main | Test driver. Pass in "-i INDEX" and then either "-fn FILE" or "-url URL".
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrieveInterestingTerms(Int32) |
Public method | RetrieveInterestingTerms(TextReader) | Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.
Public method | RetrieveTerms |
Public method | SetAnalyzer | Sets the analyzer to use. An analyzer is not required for generating a query with the {@link #Like(int)} method, all other 'like' methods require an analyzer.
Public method | SetBoost | Sets whether to boost terms in query based on "score" or not.
Public method | SetBoostFactor | Sets the boost factor to use when boosting terms
Public method | SetFieldNames | Sets the field names that will be used when generating the 'More Like This' query. Set this to null for the field names to be determined at runtime from the IndexReader provided in the constructor.
Public method | SetMaxNumTokensParsed |
Public method | SetMaxQueryTerms | Sets the maximum number of query terms that will be included in any generated query.
Public method | SetMaxWordLen | Sets the maximum word length above which words will be ignored.
Public method | SetMinDocFreq | Sets the frequency at which words will be ignored which do not occur in at least this many docs.
Public method | SetMinTermFreq | Sets the frequency below which terms will be ignored in the source doc.
Public method | SetMinWordLen | Sets the minimum word length below which words will be ignored.
Public method | SetSimilarity |
Public method | SetStopWords | Set the set of stopwords. Any word in this set is considered "uninteresting" and ignored. Even if your Analyzer allows stopwords, you might want to tell the MoreLikeThis code to ignore them, as for the purposes of document similarity it seems reasonable to assume that "a stop word is never interesting".
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DEFALT_MIN_DOC_FREQ | Ignore words which do not occur in at least this many docs.
DEFAULT_ANALYZER | Default analyzer to parse source doc with.
DEFAULT_BOOST | Boost terms in query based on score.
DEFAULT_FIELD_NAMES | Default field names. Null is used to specify that the field names should be looked up at runtime from the provided reader.
DEFAULT_MAX_NUM_TOKENS_PARSED | Default maximum number of tokens to parse in each example doc field that is not stored with TermVector support.
DEFAULT_MAX_QUERY_TERMS | Return a Query with no more than this many terms.
DEFAULT_MAX_WORD_LENGTH | Ignore words greater than this length or if 0 then this has no effect.
DEFAULT_MIN_TERM_FREQ | Ignore terms with less than this frequency in the source doc.
DEFAULT_MIN_WORD_LENGTH | Ignore words less than this length or if 0 then this has no effect.
DEFAULT_STOP_WORDS | Default set of stopwords. If null means to allow stop words.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


MoreLikeThis Constructor

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Constructor
MoreLikeThis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MoreLikeThis(IndexReader) | Constructor requiring an IndexReader.
Public method | MoreLikeThis(IndexReader, Similarity) | Initializes a new instance of the MoreLikeThis class

See Also

MoreLikeThis Class
MoreLikeThis Members
Lucene.Net.Search.Similar Namespace


MoreLikeThis Constructor (IndexReader)

[image]

Lucene.Net Class Libraries
MoreLikeThis Constructor (IndexReader)
MoreLikeThis Class See Also Send Feedback
Constructor requiring an IndexReader.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public MoreLikeThis(
    IndexReader ir
)
Visual Basic
Public Sub New ( _
    ir As IndexReader _
)
Visual C++
public:
MoreLikeThis(
    IndexReader^ ir
)

Parameters

ir
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="ir"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.#ctor(Lucene.Net.Index.IndexReader)"]

See Also

MoreLikeThis Class
MoreLikeThis Overload
Lucene.Net.Search.Similar Namespace


MoreLikeThis Constructor (IndexReader, Similarity)

[image]

Lucene.Net Class Libraries
MoreLikeThis Constructor (IndexReader, Similarity)
MoreLikeThis Class See Also Send Feedback
Initializes a new instance of the MoreLikeThis class

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public MoreLikeThis(
    IndexReader ir,
    Similarity sim
)
Visual Basic
Public Sub New ( _
    ir As IndexReader, _
    sim As Similarity _
)
Visual C++
public:
MoreLikeThis(
    IndexReader^ ir,
    Similarity^ sim
)

Parameters

ir
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="ir"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Search.Similarity)"]

sim
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="sim"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.#ctor(Lucene.Net.Index.IndexReader,Lucene.Net.Search.Similarity)"]

See Also

MoreLikeThis Class
MoreLikeThis Overload
Lucene.Net.Search.Similar Namespace


MoreLikeThis Fields

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Fields
MoreLikeThis Class See Also Send Feedback

The MoreLikeThis type exposes the following members.

Fields

Name | Description
DEFALT_MIN_DOC_FREQ | Ignore words which do not occur in at least this many docs.
DEFAULT_ANALYZER | Default analyzer to parse source doc with.
DEFAULT_BOOST | Boost terms in query based on score.
DEFAULT_FIELD_NAMES | Default field names. Null is used to specify that the field names should be looked up at runtime from the provided reader.
DEFAULT_MAX_NUM_TOKENS_PARSED | Default maximum number of tokens to parse in each example doc field that is not stored with TermVector support.
DEFAULT_MAX_QUERY_TERMS | Return a Query with no more than this many terms.
DEFAULT_MAX_WORD_LENGTH | Ignore words greater than this length or if 0 then this has no effect.
DEFAULT_MIN_TERM_FREQ | Ignore terms with less than this frequency in the source doc.
DEFAULT_MIN_WORD_LENGTH | Ignore words less than this length or if 0 then this has no effect.
DEFAULT_STOP_WORDS | Default set of stopwords. If null means to allow stop words.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


DEFALT_MIN_DOC_FREQ Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFALT_MIN_DOC_FREQ Field
MoreLikeThis Class See Also Send Feedback
Ignore words which do not occur in at least this many docs.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const int DEFALT_MIN_DOC_FREQ
Visual Basic
Public Const DEFALT_MIN_DOC_FREQ As Integer
Visual C++
public:
literal int DEFALT_MIN_DOC_FREQ

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#getMinDocFreq]
[!:#setMinDocFreq]


DEFAULT_ANALYZER Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_ANALYZER Field
MoreLikeThis Class See Also Send Feedback
Default analyzer to parse source doc with.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static readonly Analyzer DEFAULT_ANALYZER
Visual Basic
Public Shared ReadOnly DEFAULT_ANALYZER As Analyzer
Visual C++
public:
static initonly Analyzer^ DEFAULT_ANALYZER

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#getAnalyzer]


DEFAULT_BOOST Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_BOOST Field
MoreLikeThis Class See Also Send Feedback
Boost terms in query based on score.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const bool DEFAULT_BOOST
Visual Basic
Public Const DEFAULT_BOOST As Boolean
Visual C++
public:
literal bool DEFAULT_BOOST

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#isBoost]
[!:#SetBoost]


DEFAULT_FIELD_NAMES Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_FIELD_NAMES Field
MoreLikeThis Class See Also Send Feedback
Default field names. Null is used to specify that the field names should be looked up at runtime from the provided reader.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static readonly string[] DEFAULT_FIELD_NAMES
Visual Basic
Public Shared ReadOnly DEFAULT_FIELD_NAMES As String()
Visual C++
public:
static initonly array<String^>^ DEFAULT_FIELD_NAMES

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


DEFAULT_MAX_NUM_TOKENS_PARSED Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MAX_NUM_TOKENS_PARSED Field
MoreLikeThis Class See Also Send Feedback
Default maximum number of tokens to parse in each example doc field that is not stored with TermVector support.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const int DEFAULT_MAX_NUM_TOKENS_PARSED
Visual Basic
Public Const DEFAULT_MAX_NUM_TOKENS_PARSED As Integer
Visual C++
public:
literal int DEFAULT_MAX_NUM_TOKENS_PARSED

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#getMaxNumTokensParsed]


DEFAULT_MAX_QUERY_TERMS Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MAX_QUERY_TERMS Field
MoreLikeThis Class See Also Send Feedback
Return a Query with no more than this many terms.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const int DEFAULT_MAX_QUERY_TERMS
Visual Basic
Public Const DEFAULT_MAX_QUERY_TERMS As Integer
Visual C++
public:
literal int DEFAULT_MAX_QUERY_TERMS

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:BooleanQuery#getMaxClauseCount]
[!:#getMaxQueryTerms]
[!:#setMaxQueryTerms]


DEFAULT_MAX_WORD_LENGTH Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MAX_WORD_LENGTH Field
MoreLikeThis Class See Also Send Feedback
Ignore words greater than this length or if 0 then this has no effect.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const int DEFAULT_MAX_WORD_LENGTH
Visual Basic
Public Const DEFAULT_MAX_WORD_LENGTH As Integer
Visual C++
public:
literal int DEFAULT_MAX_WORD_LENGTH

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#getMaxWordLen]
[!:#setMaxWordLen]


DEFAULT_MIN_TERM_FREQ Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MIN_TERM_FREQ Field
MoreLikeThis Class See Also Send Feedback
Ignore terms with less than this frequency in the source doc.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const int DEFAULT_MIN_TERM_FREQ
Visual Basic
Public Const DEFAULT_MIN_TERM_FREQ As Integer
Visual C++
public:
literal int DEFAULT_MIN_TERM_FREQ

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#getMinTermFreq]
[!:#setMinTermFreq]


DEFAULT_MIN_WORD_LENGTH Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MIN_WORD_LENGTH Field
MoreLikeThis Class See Also Send Feedback
Ignore words less than this length or if 0 then this has no effect.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public const int DEFAULT_MIN_WORD_LENGTH
Visual Basic
Public Const DEFAULT_MIN_WORD_LENGTH As Integer
Visual C++
public:
literal int DEFAULT_MIN_WORD_LENGTH

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#getMinWordLen]
[!:#setMinWordLen]


DEFAULT_STOP_WORDS Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_STOP_WORDS Field
MoreLikeThis Class See Also Send Feedback
Default set of stopwords. If null means to allow stop words.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static readonly Hashtable DEFAULT_STOP_WORDS
Visual Basic
Public Shared ReadOnly DEFAULT_STOP_WORDS As Hashtable
Visual C++
public:
static initonly Hashtable^ DEFAULT_STOP_WORDS

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#setStopWords]
[!:#getStopWords]


MoreLikeThis Methods

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Methods
MoreLikeThis Class See Also Send Feedback

The MoreLikeThis type exposes the following members.

Methods

 | Name | Description
Public method | DescribeParams | Describe the parameters that control how the "more like this" query is formed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnalyzer | Returns an analyzer that will be used to parse source doc with. The default analyzer is the {@link #DEFAULT_ANALYZER}.
Public method | GetBoostFactor | Returns the boost factor used when boosting terms
Public method | GetFieldNames | Returns the field names that will be used when generating the 'More Like This' query. The default field names that will be used is {@link #DEFAULT_FIELD_NAMES}.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxNumTokensParsed |
Public method | GetMaxQueryTerms | Returns the maximum number of query terms that will be included in any generated query. The default is {@link #DEFAULT_MAX_QUERY_TERMS}.
Public method | GetMaxWordLen | Returns the maximum word length above which words will be ignored. Set this to 0 for no maximum word length. The default is {@link #DEFAULT_MAX_WORD_LENGTH}.
Public method | GetMinDocFreq | Returns the frequency at which words will be ignored which do not occur in at least this many docs. The default frequency is {@link #DEFALT_MIN_DOC_FREQ}.
Public method | GetMinTermFreq | Returns the frequency below which terms will be ignored in the source doc. The default frequency is the {@link #DEFAULT_MIN_TERM_FREQ}.
Public method | GetMinWordLen | Returns the minimum word length below which words will be ignored. Set this to 0 for no minimum word length. The default is {@link #DEFAULT_MIN_WORD_LENGTH}.
Public method | GetSimilarity |
Public method | GetStopWords | Get the current stop words being used.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBoost | Returns whether to boost terms in query based on "score" or not. The default is {@link #DEFAULT_BOOST}.
Public method | Like(Int32) | Return a query that will return docs like the passed lucene document ID.
Public method | Like(FileInfo) | Return a query that will return docs like the passed file.
Public method | Like(Stream) | Return a query that will return docs like the passed stream.
Public method | Like(TextReader) | Return a query that will return docs like the passed Reader.
Public method | Like(Uri) | Return a query that will return docs like the passed URL.
 | Main | Test driver. Pass in "-i INDEX" and then either "-fn FILE" or "-url URL".
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrieveInterestingTerms(Int32) |
Public method | RetrieveInterestingTerms(TextReader) | Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.
Public method | RetrieveTerms |
Public method | SetAnalyzer | Sets the analyzer to use. An analyzer is not required for generating a query with the {@link #Like(int)} method, all other 'like' methods require an analyzer.
Public method | SetBoost | Sets whether to boost terms in query based on "score" or not.
Public method | SetBoostFactor | Sets the boost factor to use when boosting terms
Public method | SetFieldNames | Sets the field names that will be used when generating the 'More Like This' query. Set this to null for the field names to be determined at runtime from the IndexReader provided in the constructor.
Public method | SetMaxNumTokensParsed |
Public method | SetMaxQueryTerms | Sets the maximum number of query terms that will be included in any generated query.
Public method | SetMaxWordLen | Sets the maximum word length above which words will be ignored.
Public method | SetMinDocFreq | Sets the frequency at which words will be ignored which do not occur in at least this many docs.
Public method | SetMinTermFreq | Sets the frequency below which terms will be ignored in the source doc.
Public method | SetMinWordLen | Sets the minimum word length below which words will be ignored.
Public method | SetSimilarity |
Public method | SetStopWords | Set the set of stopwords. Any word in this set is considered "uninteresting" and ignored. Even if your Analyzer allows stopwords, you might want to tell the MoreLikeThis code to ignore them, as for the purposes of document similarity it seems reasonable to assume that "a stop word is never interesting".
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


DescribeParams Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DescribeParams Method
MoreLikeThis Class See Also Send Feedback
Describe the parameters that control how the "more like this" query is formed.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string DescribeParams()
Visual Basic
Public Function DescribeParams As String
Visual C++
public:
String^ DescribeParams()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.DescribeParams"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetAnalyzer Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetAnalyzer Method
MoreLikeThis Class See Also Send Feedback
Returns an analyzer that will be used to parse source doc with. The default analyzer is the {@link #DEFAULT_ANALYZER}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Analyzer GetAnalyzer()
Visual Basic
Public Function GetAnalyzer As Analyzer
Visual C++
public:
Analyzer^ GetAnalyzer()

Return Value

the analyzer that will be used to parse source doc with.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#DEFAULT_ANALYZER]


GetBoostFactor Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetBoostFactor Method
MoreLikeThis Class See Also Send Feedback
Returns the boost factor used when boosting terms

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public float GetBoostFactor()
Visual Basic
Public Function GetBoostFactor As Single
Visual C++
public:
float GetBoostFactor()

Return Value

Returns the boost factor used when boosting terms

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetFieldNames Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetFieldNames Method
MoreLikeThis Class See Also Send Feedback
Returns the field names that will be used when generating the 'More Like This' query. The default field names that will be used is {@link #DEFAULT_FIELD_NAMES}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] GetFieldNames()
Visual Basic
Public Function GetFieldNames As String()
Visual C++
public:
array<String^>^ GetFieldNames()

Return Value

the field names that will be used when generating the 'More Like This' query.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetMaxNumTokensParsed Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMaxNumTokensParsed Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.GetMaxNumTokensParsed"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMaxNumTokensParsed()
Visual Basic
Public Function GetMaxNumTokensParsed As Integer
Visual C++
public:
int GetMaxNumTokensParsed()

Return Value

The maximum number of tokens to parse in each example doc field that is not stored with TermVector support

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#DEFAULT_MAX_NUM_TOKENS_PARSED]


GetMaxQueryTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMaxQueryTerms Method
MoreLikeThis Class See Also Send Feedback
Returns the maximum number of query terms that will be included in any generated query. The default is {@link #DEFAULT_MAX_QUERY_TERMS}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMaxQueryTerms()
Visual Basic
Public Function GetMaxQueryTerms As Integer
Visual C++
public:
int GetMaxQueryTerms()

Return Value

the maximum number of query terms that will be included in any generated query.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetMaxWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMaxWordLen Method
MoreLikeThis Class See Also Send Feedback
Returns the maximum word length above which words will be ignored. Set this to 0 for no maximum word length. The default is {@link #DEFAULT_MAX_WORD_LENGTH}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMaxWordLen()
Visual Basic
Public Function GetMaxWordLen As Integer
Visual C++
public:
int GetMaxWordLen()

Return Value

the maximum word length above which words will be ignored.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetMinDocFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMinDocFreq Method
MoreLikeThis Class See Also Send Feedback
Returns the frequency at which words will be ignored which do not occur in at least this many docs. The default frequency is {@link #DEFALT_MIN_DOC_FREQ}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMinDocFreq()
Visual Basic
Public Function GetMinDocFreq As Integer
Visual C++
public:
int GetMinDocFreq()

Return Value

the frequency at which words will be ignored which do not occur in at least this many docs.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetMinTermFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMinTermFreq Method
MoreLikeThis Class See Also Send Feedback
Returns the frequency below which terms will be ignored in the source doc. The default frequency is the {@link #DEFAULT_MIN_TERM_FREQ}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMinTermFreq()
Visual Basic
Public Function GetMinTermFreq As Integer
Visual C++
public:
int GetMinTermFreq()

Return Value

the frequency below which terms will be ignored in the source doc.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetMinWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMinWordLen Method
MoreLikeThis Class See Also Send Feedback
Returns the minimum word length below which words will be ignored. Set this to 0 for no minimum word length. The default is {@link #DEFAULT_MIN_WORD_LENGTH}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMinWordLen()
Visual Basic
Public Function GetMinWordLen As Integer
Visual C++
public:
int GetMinWordLen()

Return Value

the minimum word length below which words will be ignored.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetSimilarity Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.GetSimilarity"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Similarity GetSimilarity()
Visual Basic
Public Function GetSimilarity As Similarity
Visual C++
public:
Similarity^ GetSimilarity()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.GetSimilarity"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


GetStopWords Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetStopWords Method
MoreLikeThis Class See Also Send Feedback
Get the current stop words being used.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Hashtable GetStopWords()
Visual Basic
Public Function GetStopWords As Hashtable
Visual C++
public:
Hashtable^ GetStopWords()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.GetStopWords"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#setStopWords]


IsBoost Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..IsBoost Method
MoreLikeThis Class See Also Send Feedback
Returns whether to boost terms in query based on "score" or not. The default is {@link #DEFAULT_BOOST}.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsBoost()
Visual Basic
Public Function IsBoost As Boolean
Visual C++
public:
bool IsBoost()

Return Value

whether to boost terms in query based on "score" or not.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#SetBoost]


Like Method

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method
MoreLikeThis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Like(Int32) | Return a query that will return docs like the passed lucene document ID.
Public method | Like(FileInfo) | Return a query that will return docs like the passed file.
Public method | Like(Stream) | Return a query that will return docs like the passed stream.
Public method | Like(TextReader) | Return a query that will return docs like the passed Reader.
Public method | Like(Uri) | Return a query that will return docs like the passed URL.

See Also

MoreLikeThis Class
MoreLikeThis Members
Lucene.Net.Search.Similar Namespace


Like Method (Int32)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (Int32)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed lucene document ID.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Query Like(
    int docNum
)
Visual Basic
Public Function Like ( _
    docNum As Integer _
) As Query
Visual C++
public:
Query^ Like(
    int docNum
)

Parameters

docNum
Type: System..::..Int32
the documentID of the lucene doc to generate the 'More Like This" query for.

Return Value

a query that will return docs like the passed lucene document ID.

See Also

MoreLikeThis Class
Like Overload
Lucene.Net.Search.Similar Namespace


Like Method (FileInfo)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (FileInfo)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed file.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Query Like(
    FileInfo f
)
Visual Basic
Public Function Like ( _
    f As FileInfo _
) As Query
Visual C++
public:
Query^ Like(
    FileInfo^ f
)

Parameters

f
Type: System.IO..::..FileInfo

[Missing <param name="f"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.Like(System.IO.FileInfo)"]

Return Value

a query that will return docs like the passed file.

See Also

MoreLikeThis Class
Like Overload
Lucene.Net.Search.Similar Namespace


Like Method (Stream)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (Stream)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed stream.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Query Like(
    Stream is_Renamed
)
Visual Basic
Public Function Like ( _
    is_Renamed As Stream _
) As Query
Visual C++
public:
Query^ Like(
    Stream^ is_Renamed
)

Parameters

is_Renamed
Type: System.IO..::..Stream

[Missing <param name="is_Renamed"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.Like(System.IO.Stream)"]

Return Value

a query that will return docs like the passed stream.

See Also

MoreLikeThis Class
Like Overload
Lucene.Net.Search.Similar Namespace


Like Method (TextReader)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (TextReader)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed Reader.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Query Like(
    TextReader r
)
Visual Basic
Public Function Like ( _
    r As TextReader _
) As Query
Visual C++
public:
Query^ Like(
    TextReader^ r
)

Parameters

r
Type: System.IO..::..TextReader

[Missing <param name="r"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.Like(System.IO.TextReader)"]

Return Value

a query that will return docs like the passed Reader.

See Also

MoreLikeThis Class
Like Overload
Lucene.Net.Search.Similar Namespace


Like Method (Uri)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (Uri)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed URL.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Query Like(
    Uri u
)
Visual Basic
Public Function Like ( _
    u As Uri _
) As Query
Visual C++
public:
Query^ Like(
    Uri^ u
)

Parameters

u
Type: System..::..Uri

[Missing <param name="u"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.Like(System.Uri)"]

Return Value

a query that will return docs like the passed URL.

See Also

MoreLikeThis Class
Like Overload
Lucene.Net.Search.Similar Namespace


Main Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Main Method
MoreLikeThis Class See Also Send Feedback
Test driver. Pass in "-i INDEX" and then either "-fn FILE" or "-url URL".

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static void Main(
    string[] a
)
Visual Basic
Public Shared Sub Main ( _
    a As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ a
)

Parameters

a
Type: array< System..::..String >[]()[][]

[Missing <param name="a"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.Main(System.String[])"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


RetrieveInterestingTerms Method

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis..::..RetrieveInterestingTerms Method
MoreLikeThis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RetrieveInterestingTerms(Int32) |
Public method | RetrieveInterestingTerms(TextReader) | Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.

See Also

MoreLikeThis Class
MoreLikeThis Members
Lucene.Net.Search.Similar Namespace


RetrieveInterestingTerms Method (Int32)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..RetrieveInterestingTerms Method (Int32)
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.RetrieveInterestingTerms(System.Int32)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] RetrieveInterestingTerms(
    int docNum
)
Visual Basic
Public Function RetrieveInterestingTerms ( _
    docNum As Integer _
) As String()
Visual C++
public:
array<String^>^ RetrieveInterestingTerms(
    int docNum
)

Parameters

docNum
Type: System..::..Int32

[Missing <param name="docNum"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.RetrieveInterestingTerms(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.RetrieveInterestingTerms(System.Int32)"]

See Also

MoreLikeThis Class
RetrieveInterestingTerms Overload
Lucene.Net.Search.Similar Namespace


RetrieveInterestingTerms Method (TextReader)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..RetrieveInterestingTerms Method (TextReader)
MoreLikeThis Class See Also Send Feedback
Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] RetrieveInterestingTerms(
    TextReader r
)
Visual Basic
Public Function RetrieveInterestingTerms ( _
    r As TextReader _
) As String()
Visual C++
public:
array<String^>^ RetrieveInterestingTerms(
    TextReader^ r
)

Parameters

r
Type: System.IO..::..TextReader
the source document

Return Value

the most interesting words in the document

See Also

MoreLikeThis Class
RetrieveInterestingTerms Overload
Lucene.Net.Search.Similar Namespace
[!:#RetrieveTerms(java.io.Reader)]
[!:#setMaxQueryTerms]


RetrieveTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..RetrieveTerms Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.RetrieveTerms(System.IO.TextReader)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public PriorityQueue RetrieveTerms(
    TextReader r
)
Visual Basic
Public Function RetrieveTerms ( _
    r As TextReader _
) As PriorityQueue
Visual C++
public:
PriorityQueue^ RetrieveTerms(
    TextReader^ r
)

Parameters

r
Type: System.IO..::..TextReader

[Missing <param name="r"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.RetrieveTerms(System.IO.TextReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.RetrieveTerms(System.IO.TextReader)"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetAnalyzer Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetAnalyzer Method
MoreLikeThis Class See Also Send Feedback
Sets the analyzer to use. An analyzer is not required for generating a query with the {@link #Like(int)} method, all other 'like' methods require an analyzer.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetAnalyzer(
    Analyzer analyzer
)
Visual Basic
Public Sub SetAnalyzer ( _
    analyzer As Analyzer _
)
Visual C++
public:
void SetAnalyzer(
    Analyzer^ analyzer
)

Parameters

analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use to tokenize text.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetBoost Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetBoost Method
MoreLikeThis Class See Also Send Feedback
Sets whether to boost terms in query based on "score" or not.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetBoost(
    bool boost
)
Visual Basic
Public Sub SetBoost ( _
    boost As Boolean _
)
Visual C++
public:
void SetBoost(
    bool boost
)

Parameters

boost
Type: System..::..Boolean
true to boost terms in query based on "score", false otherwise.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:#isBoost]


SetBoostFactor Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetBoostFactor Method
MoreLikeThis Class See Also Send Feedback
Sets the boost factor to use when boosting terms

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetBoostFactor(
    float boostFactor
)
Visual Basic
Public Sub SetBoostFactor ( _
    boostFactor As Single _
)
Visual C++
public:
void SetBoostFactor(
    float boostFactor
)

Parameters

boostFactor
Type: System..::..Single

[Missing <param name="boostFactor"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.SetBoostFactor(System.Single)"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetFieldNames Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetFieldNames Method
MoreLikeThis Class See Also Send Feedback
Sets the field names that will be used when generating the 'More Like This' query. Set this to null for the field names to be determined at runtime from the IndexReader provided in the constructor.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetFieldNames(
    string[] fieldNames
)
Visual Basic
Public Sub SetFieldNames ( _
    fieldNames As String() _
)
Visual C++
public:
void SetFieldNames(
    array<String^>^ fieldNames
)

Parameters

fieldNames
Type: array< System..::..String >[]()[][]
the field names that will be used when generating the 'More Like This' query.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetMaxNumTokensParsed Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMaxNumTokensParsed Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.SetMaxNumTokensParsed(System.Int32)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMaxNumTokensParsed(
    int i
)
Visual Basic
Public Sub SetMaxNumTokensParsed ( _
    i As Integer _
)
Visual C++
public:
void SetMaxNumTokensParsed(
    int i
)

Parameters

i
Type: System..::..Int32
The maximum number of tokens to parse in each example doc field that is not stored with TermVector support

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetMaxQueryTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMaxQueryTerms Method
MoreLikeThis Class See Also Send Feedback
Sets the maximum number of query terms that will be included in any generated query.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMaxQueryTerms(
    int maxQueryTerms
)
Visual Basic
Public Sub SetMaxQueryTerms ( _
    maxQueryTerms As Integer _
)
Visual C++
public:
void SetMaxQueryTerms(
    int maxQueryTerms
)

Parameters

maxQueryTerms
Type: System..::..Int32
the maximum number of query terms that will be included in any generated query.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetMaxWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMaxWordLen Method
MoreLikeThis Class See Also Send Feedback
Sets the maximum word length above which words will be ignored.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMaxWordLen(
    int maxWordLen
)
Visual Basic
Public Sub SetMaxWordLen ( _
    maxWordLen As Integer _
)
Visual C++
public:
void SetMaxWordLen(
    int maxWordLen
)

Parameters

maxWordLen
Type: System..::..Int32
the maximum word length above which words will be ignored.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetMinDocFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMinDocFreq Method
MoreLikeThis Class See Also Send Feedback
Sets the frequency at which words will be ignored which do not occur in at least this many docs.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMinDocFreq(
    int minDocFreq
)
Visual Basic
Public Sub SetMinDocFreq ( _
    minDocFreq As Integer _
)
Visual C++
public:
void SetMinDocFreq(
    int minDocFreq
)

Parameters

minDocFreq
Type: System..::..Int32
the frequency at which words will be ignored which do not occur in at least this many docs.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetMinTermFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMinTermFreq Method
MoreLikeThis Class See Also Send Feedback
Sets the frequency below which terms will be ignored in the source doc.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMinTermFreq(
    int minTermFreq
)
Visual Basic
Public Sub SetMinTermFreq ( _
    minTermFreq As Integer _
)
Visual C++
public:
void SetMinTermFreq(
    int minTermFreq
)

Parameters

minTermFreq
Type: System..::..Int32
the frequency below which terms will be ignored in the source doc.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetMinWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMinWordLen Method
MoreLikeThis Class See Also Send Feedback
Sets the minimum word length below which words will be ignored.

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMinWordLen(
    int minWordLen
)
Visual Basic
Public Sub SetMinWordLen ( _
    minWordLen As Integer _
)
Visual C++
public:
void SetMinWordLen(
    int minWordLen
)

Parameters

minWordLen
Type: System..::..Int32
the minimum word length below which words will be ignored.

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetSimilarity Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetSimilarity Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.SetSimilarity(Lucene.Net.Search.Similarity)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetSimilarity(
    Similarity similarity
)
Visual Basic
Public Sub SetSimilarity ( _
    similarity As Similarity _
)
Visual C++
public:
void SetSimilarity(
    Similarity^ similarity
)

Parameters

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThis.SetSimilarity(Lucene.Net.Search.Similarity)"]

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace


SetStopWords Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetStopWords Method
MoreLikeThis Class See Also Send Feedback
Set the set of stopwords. Any word in this set is considered "uninteresting" and ignored. Even if your Analyzer allows stopwords, you might want to tell the MoreLikeThis code to ignore them, as for the purposes of document similarity it seems reasonable to assume that "a stop word is never interesting".

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetStopWords(
    Hashtable stopWords
)
Visual Basic
Public Sub SetStopWords ( _
    stopWords As Hashtable _
)
Visual C++
public:
void SetStopWords(
    Hashtable^ stopWords
)

Parameters

stopWords
Type: System.Collections..::..Hashtable
set of stopwords, if null it means to allow stop words

See Also

MoreLikeThis Class
Lucene.Net.Search.Similar Namespace
[!:StopFilter.makeStopSet()]
[!:#getStopWords]


MoreLikeThisQuery Class

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Similar.MoreLikeThisQuery"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class MoreLikeThisQuery : Query
Visual Basic
Public Class MoreLikeThisQuery _
    Inherits Query
Visual C++
public ref class MoreLikeThisQuery : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Similar..::..MoreLikeThisQuery

See Also

MoreLikeThisQuery Members
Lucene.Net.Search.Similar Namespace


MoreLikeThisQuery Members

[image] [image]

Lucene.Net Class Libraries
MoreLikeThisQuery Members
MoreLikeThisQuery Class Constructors Methods See Also Send Feedback

The MoreLikeThisQuery type exposes the following members.

Constructors

 | Name | Description
Public method | MoreLikeThisQuery | Initializes a new instance of the MoreLikeThisQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Inherited from Query.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetAnalyzer
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Inherited from Query.)
Public method | GetLikeText
Public method | GetMaxQueryTerms
Public method | GetMinDocFreq
Public method | GetMinTermFrequency
Public method | GetMoreLikeFields
Public method | GetPercentTermsToMatch
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetStopWords
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method | SetAnalyzer
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetLikeText
Public method | SetMaxQueryTerms
Public method | SetMinDocFreq
Public method | SetMinTermFrequency
Public method | SetMoreLikeFields
Public method | SetPercentTermsToMatch
Public method | SetStopWords
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


MoreLikeThisQuery Constructor

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery Constructor
MoreLikeThisQuery Class See Also Send Feedback
Initializes a new instance of the MoreLikeThisQuery class

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public MoreLikeThisQuery(
    string likeText,
    string[] moreLikeFields,
    Analyzer analyzer
)
Visual Basic
Public Sub New ( _
    likeText As String, _
    moreLikeFields As String(), _
    analyzer As Analyzer _
)
Visual C++
public:
MoreLikeThisQuery(
    String^ likeText,
    array<String^>^ moreLikeFields,
    Analyzer^ analyzer
)

Parameters

likeText
Type: System..::..String

[Missing <param name="likeText"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.#ctor(System.String,System.String[],Lucene.Net.Analysis.Analyzer)"]

moreLikeFields
Type: array< System..::..String >[]()[][]

[Missing <param name="moreLikeFields"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.#ctor(System.String,System.String[],Lucene.Net.Analysis.Analyzer)"]

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.#ctor(System.String,System.String[],Lucene.Net.Analysis.Analyzer)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


MoreLikeThisQuery Methods

[image] [image]

Lucene.Net Class Libraries
MoreLikeThisQuery Methods
MoreLikeThisQuery Class See Also Send Feedback

The MoreLikeThisQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method CreateWeight
Expert: Constructs an appropriate Weight implementation for this query.

Only implemented by primitive queries, which re-write to themselves.

(Inherited from Query.)
Public method | Equals | (Inherited from Query.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetAnalyzer
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetHashCode | (Inherited from Query.)
Public method | GetLikeText
Public method | GetMaxQueryTerms
Public method | GetMinDocFreq
Public method | GetMinTermFrequency
Public method | GetMoreLikeFields
Public method | GetPercentTermsToMatch
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetStopWords
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method | SetAnalyzer
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method | SetLikeText
Public method | SetMaxQueryTerms
Public method | SetMinDocFreq
Public method | SetMinTermFrequency
Public method | SetMoreLikeFields
Public method | SetPercentTermsToMatch
Public method | SetStopWords
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetAnalyzer Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetAnalyzer Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetAnalyzer"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Analyzer GetAnalyzer()
Visual Basic
Public Function GetAnalyzer As Analyzer
Visual C++
public:
Analyzer^ GetAnalyzer()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetAnalyzer"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetLikeText Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetLikeText Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetLikeText"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetLikeText()
Visual Basic
Public Function GetLikeText As String
Visual C++
public:
String^ GetLikeText()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetLikeText"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetMaxQueryTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetMaxQueryTerms Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMaxQueryTerms"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMaxQueryTerms()
Visual Basic
Public Function GetMaxQueryTerms As Integer
Visual C++
public:
int GetMaxQueryTerms()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMaxQueryTerms"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetMinDocFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetMinDocFreq Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMinDocFreq"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMinDocFreq()
Visual Basic
Public Function GetMinDocFreq As Integer
Visual C++
public:
int GetMinDocFreq()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMinDocFreq"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetMinTermFrequency Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetMinTermFrequency Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMinTermFrequency"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetMinTermFrequency()
Visual Basic
Public Function GetMinTermFrequency As Integer
Visual C++
public:
int GetMinTermFrequency()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMinTermFrequency"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetMoreLikeFields Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetMoreLikeFields Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMoreLikeFields"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] GetMoreLikeFields()
Visual Basic
Public Function GetMoreLikeFields As String()
Visual C++
public:
array<String^>^ GetMoreLikeFields()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetMoreLikeFields"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetPercentTermsToMatch Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetPercentTermsToMatch Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetPercentTermsToMatch"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public float GetPercentTermsToMatch()
Visual Basic
Public Function GetPercentTermsToMatch As Single
Visual C++
public:
float GetPercentTermsToMatch()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetPercentTermsToMatch"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


GetStopWords Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..GetStopWords Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetStopWords"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Hashtable GetStopWords()
Visual Basic
Public Function GetStopWords As Hashtable
Visual C++
public:
Hashtable^ GetStopWords()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.GetStopWords"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..Rewrite Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetAnalyzer Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetAnalyzer Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetAnalyzer(Lucene.Net.Analysis.Analyzer)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetAnalyzer(
    Analyzer analyzer
)
Visual Basic
Public Sub SetAnalyzer ( _
    analyzer As Analyzer _
)
Visual C++
public:
void SetAnalyzer(
    Analyzer^ analyzer
)

Parameters

analyzer
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="analyzer"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetAnalyzer(Lucene.Net.Analysis.Analyzer)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetLikeText Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetLikeText Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetLikeText(System.String)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetLikeText(
    string likeText
)
Visual Basic
Public Sub SetLikeText ( _
    likeText As String _
)
Visual C++
public:
void SetLikeText(
    String^ likeText
)

Parameters

likeText
Type: System..::..String

[Missing <param name="likeText"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetLikeText(System.String)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetMaxQueryTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetMaxQueryTerms Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMaxQueryTerms(System.Int32)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMaxQueryTerms(
    int maxQueryTerms
)
Visual Basic
Public Sub SetMaxQueryTerms ( _
    maxQueryTerms As Integer _
)
Visual C++
public:
void SetMaxQueryTerms(
    int maxQueryTerms
)

Parameters

maxQueryTerms
Type: System..::..Int32

[Missing <param name="maxQueryTerms"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMaxQueryTerms(System.Int32)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetMinDocFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetMinDocFreq Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMinDocFreq(System.Int32)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMinDocFreq(
    int minDocFreq
)
Visual Basic
Public Sub SetMinDocFreq ( _
    minDocFreq As Integer _
)
Visual C++
public:
void SetMinDocFreq(
    int minDocFreq
)

Parameters

minDocFreq
Type: System..::..Int32

[Missing <param name="minDocFreq"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMinDocFreq(System.Int32)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetMinTermFrequency Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetMinTermFrequency Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMinTermFrequency(System.Int32)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMinTermFrequency(
    int minTermFrequency
)
Visual Basic
Public Sub SetMinTermFrequency ( _
    minTermFrequency As Integer _
)
Visual C++
public:
void SetMinTermFrequency(
    int minTermFrequency
)

Parameters

minTermFrequency
Type: System..::..Int32

[Missing <param name="minTermFrequency"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMinTermFrequency(System.Int32)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetMoreLikeFields Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetMoreLikeFields Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMoreLikeFields(System.String[])"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetMoreLikeFields(
    string[] moreLikeFields
)
Visual Basic
Public Sub SetMoreLikeFields ( _
    moreLikeFields As String() _
)
Visual C++
public:
void SetMoreLikeFields(
    array<String^>^ moreLikeFields
)

Parameters

moreLikeFields
Type: array< System..::..String >[]()[][]

[Missing <param name="moreLikeFields"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetMoreLikeFields(System.String[])"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetPercentTermsToMatch Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetPercentTermsToMatch Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetPercentTermsToMatch(System.Single)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetPercentTermsToMatch(
    float percentTermsToMatch
)
Visual Basic
Public Sub SetPercentTermsToMatch ( _
    percentTermsToMatch As Single _
)
Visual C++
public:
void SetPercentTermsToMatch(
    float percentTermsToMatch
)

Parameters

percentTermsToMatch
Type: System..::..Single

[Missing <param name="percentTermsToMatch"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetPercentTermsToMatch(System.Single)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


SetStopWords Method

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..SetStopWords Method
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetStopWords(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void SetStopWords(
    Hashtable stopWords
)
Visual Basic
Public Sub SetStopWords ( _
    stopWords As Hashtable _
)
Visual C++
public:
void SetStopWords(
    Hashtable^ stopWords
)

Parameters

stopWords
Type: System.Collections..::..Hashtable

[Missing <param name="stopWords"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.SetStopWords(System.Collections.Hashtable)"]

See Also

MoreLikeThisQuery Class
Lucene.Net.Search.Similar Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..ToString Method
MoreLikeThisQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

MoreLikeThisQuery Class
MoreLikeThisQuery Members
Lucene.Net.Search.Similar Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
MoreLikeThisQuery..::..ToString Method (String)
MoreLikeThisQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Similar
Assembly: Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Similar.MoreLikeThisQuery.ToString(System.String)"]

See Also

MoreLikeThisQuery Class
ToString Overload
Lucene.Net.Search.Similar Namespace


Lucene.Net.Search.Spans Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.Spans Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.Spans"]

Classes

Class Description
Public class FieldMaskingSpanQuery

Wrapper to allow {@link SpanQuery} objects participate in composite single-field SpanQueries by 'lying' about their search field. That is, the masked SpanQuery will function as normal, but {@link SpanQuery#GetField()} simply hands back the value supplied in this class's constructor.

This can be used to support Queries like {@link SpanNearQuery} or {@link SpanOrQuery} across different fields, which is not ordinarily permitted.

This can be useful for denormalized relational data: for example, when indexing a document with conceptually many 'children':

            teacherid: 1
            studentfirstname: james
            studentsurname: jones

            teacherid: 2
            studenfirstname: james
            studentsurname: smith
            studentfirstname: sally
            studentsurname: jones

a SpanNearQuery with a slop of 0 can be applied across two {@link SpanTermQuery} objects as follows:

            SpanQuery q1  = new SpanTermQuery(new Term("studentfirstname", "james"));
            SpanQuery q2  = new SpanTermQuery(new Term("studentsurname", "jones"));
            SpanQuery q2m new FieldMaskingSpanQuery(q2, "studentfirstname");
            Query q = new SpanNearQuery(new SpanQuery[]{q1, q2m}, -1, false);
to search for 'studentfirstname:james studentsurname:jones' and find teacherid 1 without matching teacherid 2 (which has a 'james' in position 0 and 'jones' in position 1).

Note: as {@link #GetField()} returns the masked field, scoring will be done using the norms of the field name supplied. This may lead to unexpected scoring behaviour.

Public class NearSpansOrdered
A Spans that is formed from the ordered subspans of a SpanNearQuery where the subspans do not overlap and have a maximum slop between them.

The formed spans only contains minimum slop matches.
The matching slop is computed from the distance(s) between the non overlapping matching Spans.
Successive matches are always formed from the successive Spans of the SpanNearQuery.

The formed spans may contain overlaps when the slop is at least 1. For example, when querying using

t1 t2 t3
with slop at least 1, the fragment:
t1 t2 t1 t3 t2 t3
matches twice:
t1 t2 .. t3
      t1 .. t2 t3
Expert: Only public for subclassing. Most implementations should not need this class
Public class NearSpansUnordered
Similar to {@link NearSpansOrdered}, but for the unordered case. Expert: Only public for subclassing. Most implementations should not need this class
Public class SpanFirstQuery
Matches spans near the beginning of a field.
Public class SpanNearQuery
Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.
Public class SpanNotQuery
Removes matches which overlap with another SpanQuery.
Public class SpanOrQuery
Matches the union of its clauses.
Public class SpanQuery
Base class for span-based queries.
Public class Spans
Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.
Public class SpanScorer
Public for extension only.
Public class SpanTermQuery
Matches spans containing a term.
Public class SpanWeight
Expert-only. Public for use by other weight implementations
Public class TermSpans
Expert: Public for extension only


FieldMaskingSpanQuery Class

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery Class
Members See Also Send Feedback

Wrapper to allow {@link SpanQuery} objects participate in composite single-field SpanQueries by 'lying' about their search field. That is, the masked SpanQuery will function as normal, but {@link SpanQuery#GetField()} simply hands back the value supplied in this class's constructor.

This can be used to support Queries like {@link SpanNearQuery} or {@link SpanOrQuery} across different fields, which is not ordinarily permitted.

This can be useful for denormalized relational data: for example, when indexing a document with conceptually many 'children':

            teacherid: 1
            studentfirstname: james
            studentsurname: jones

            teacherid: 2
            studenfirstname: james
            studentsurname: smith
            studentfirstname: sally
            studentsurname: jones

a SpanNearQuery with a slop of 0 can be applied across two {@link SpanTermQuery} objects as follows:

            SpanQuery q1  = new SpanTermQuery(new Term("studentfirstname", "james"));
            SpanQuery q2  = new SpanTermQuery(new Term("studentsurname", "jones"));
            SpanQuery q2m new FieldMaskingSpanQuery(q2, "studentfirstname");
            Query q = new SpanNearQuery(new SpanQuery[]{q1, q2m}, -1, false);
to search for 'studentfirstname:james studentsurname:jones' and find teacherid 1 without matching teacherid 2 (which has a 'james' in position 0 and 'jones' in position 1).

Note: as {@link #GetField()} returns the masked field, scoring will be done using the norms of the field name supplied. This may lead to unexpected scoring behaviour.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class FieldMaskingSpanQuery : SpanQuery
Visual Basic
<SerializableAttribute> _
Public Class FieldMaskingSpanQuery _
    Inherits SpanQuery
Visual C++
[SerializableAttribute]
public ref class FieldMaskingSpanQuery : public SpanQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..FieldMaskingSpanQuery

See Also

FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace


FieldMaskingSpanQuery Members

[image] [image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery Members
FieldMaskingSpanQuery Class Constructors Methods See Also Send Feedback

The FieldMaskingSpanQuery type exposes the following members.

Constructors

 | Name | Description
Public method | FieldMaskingSpanQuery | Initializes a new instance of the FieldMaskingSpanQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method | GetMaskedQuery
Public method | GetSimilarity | (Overrides Query..::..GetSimilarity(Searcher).)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method | GetTerms | Obsolete. (Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


FieldMaskingSpanQuery Constructor

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery Constructor
FieldMaskingSpanQuery Class See Also Send Feedback
Initializes a new instance of the FieldMaskingSpanQuery class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldMaskingSpanQuery(
    SpanQuery maskedQuery,
    string maskedField
)
Visual Basic
Public Sub New ( _
    maskedQuery As SpanQuery, _
    maskedField As String _
)
Visual C++
public:
FieldMaskingSpanQuery(
    SpanQuery^ maskedQuery,
    String^ maskedField
)

Parameters

maskedQuery
Type: Lucene.Net.Search.Spans..::..SpanQuery

[Missing <param name="maskedQuery"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery,System.String)"]

maskedField
Type: System..::..String

[Missing <param name="maskedField"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery,System.String)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


FieldMaskingSpanQuery Methods

[image] [image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery Methods
FieldMaskingSpanQuery Class See Also Send Feedback

The FieldMaskingSpanQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides SpanQuery..::..CreateWeight(Searcher).)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method | GetMaskedQuery
Public method | GetSimilarity | (Overrides Query..::..GetSimilarity(Searcher).)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method | GetTerms | Obsolete. (Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..CreateWeight Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..Equals Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.Equals(System.Object)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..ExtractTerms Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..GetField Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetField"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetField"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..GetHashCode Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetHashCode"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


GetMaskedQuery Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..GetMaskedQuery Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetMaskedQuery"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery GetMaskedQuery()
Visual Basic
Public Overridable Function GetMaskedQuery As SpanQuery
Visual C++
public:
virtual SpanQuery^ GetMaskedQuery()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetMaskedQuery"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


GetSimilarity Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..GetSimilarity Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetSimilarity(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Similarity GetSimilarity(
    Searcher searcher
)
Visual Basic
Public Overrides Function GetSimilarity ( _
    searcher As Searcher _
) As Similarity
Visual C++
public:
virtual Similarity^ GetSimilarity(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetSimilarity(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetSimilarity(Lucene.Net.Search.Searcher)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..GetSpans Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..GetTerms Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetTerms"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use ExtractTerms(Hashtable) instead.")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms(Hashtable) instead.")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms(Hashtable) instead.")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.GetTerms"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..Rewrite Method
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

FieldMaskingSpanQuery Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..ToString Method
FieldMaskingSpanQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

FieldMaskingSpanQuery Class
FieldMaskingSpanQuery Members
Lucene.Net.Search.Spans Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
FieldMaskingSpanQuery..::..ToString Method (String)
FieldMaskingSpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.FieldMaskingSpanQuery.ToString(System.String)"]

See Also

FieldMaskingSpanQuery Class
ToString Overload
Lucene.Net.Search.Spans Namespace


NearSpansOrdered Class

[image]

Lucene.Net Class Libraries
NearSpansOrdered Class
Members See Also Send Feedback
A Spans that is formed from the ordered subspans of a SpanNearQuery where the subspans do not overlap and have a maximum slop between them.

The formed spans only contains minimum slop matches.
The matching slop is computed from the distance(s) between the non overlapping matching Spans.
Successive matches are always formed from the successive Spans of the SpanNearQuery.

The formed spans may contain overlaps when the slop is at least 1. For example, when querying using

t1 t2 t3
with slop at least 1, the fragment:
t1 t2 t1 t3 t2 t3
matches twice:
t1 t2 .. t3
      t1 .. t2 t3
Expert: Only public for subclassing. Most implementations should not need this class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NearSpansOrdered : Spans
Visual Basic
Public Class NearSpansOrdered _
    Inherits Spans
Visual C++
public ref class NearSpansOrdered : public Spans

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Spans..::..Spans
Lucene.Net.Search.Spans..::..NearSpansOrdered

See Also

NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace


NearSpansOrdered Members

[image] [image]

Lucene.Net Class Libraries
NearSpansOrdered Members
NearSpansOrdered Class Constructors Methods See Also Send Feedback

The NearSpansOrdered type exposes the following members.

Constructors

 | Name | Description
Public method | NearSpansOrdered(SpanNearQuery, IndexReader) | Initializes a new instance of the NearSpansOrdered class
Public method | NearSpansOrdered(SpanNearQuery, IndexReader, Boolean) | Initializes a new instance of the NearSpansOrdered class

Methods

 | Name | Description
Public method | Doc | (Overrides Spans..::..Doc()()()().)
Public method | End | (Overrides Spans..::..End()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | (Overrides Spans..::..GetPayload()()()().)
Public method | GetSubSpans |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable | (Overrides Spans..::..IsPayloadAvailable()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides Spans..::..Next()()()().)
Public method | SkipTo | (Overrides Spans..::..SkipTo(Int32).)
Public method | Start | (Overrides Spans..::..Start()()()().)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


NearSpansOrdered Constructor

[image] [image]

Lucene.Net Class Libraries
NearSpansOrdered Constructor
NearSpansOrdered Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NearSpansOrdered(SpanNearQuery, IndexReader) | Initializes a new instance of the NearSpansOrdered class
Public method | NearSpansOrdered(SpanNearQuery, IndexReader, Boolean) | Initializes a new instance of the NearSpansOrdered class

See Also

NearSpansOrdered Class
NearSpansOrdered Members
Lucene.Net.Search.Spans Namespace


NearSpansOrdered Constructor (SpanNearQuery, IndexReader)

[image]

Lucene.Net Class Libraries
NearSpansOrdered Constructor (SpanNearQuery, IndexReader)
NearSpansOrdered Class See Also Send Feedback
Initializes a new instance of the NearSpansOrdered class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NearSpansOrdered(
    SpanNearQuery spanNearQuery,
    IndexReader reader
)
Visual Basic
Public Sub New ( _
    spanNearQuery As SpanNearQuery, _
    reader As IndexReader _
)
Visual C++
public:
NearSpansOrdered(
    SpanNearQuery^ spanNearQuery,
    IndexReader^ reader
)

Parameters

spanNearQuery
Type: Lucene.Net.Search.Spans..::..SpanNearQuery

[Missing <param name="spanNearQuery"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader)"]

See Also

NearSpansOrdered Class
NearSpansOrdered Overload
Lucene.Net.Search.Spans Namespace


NearSpansOrdered Constructor (SpanNearQuery, IndexReader, Boolean)

[image]

Lucene.Net Class Libraries
NearSpansOrdered Constructor (SpanNearQuery, IndexReader, Boolean)
NearSpansOrdered Class See Also Send Feedback
Initializes a new instance of the NearSpansOrdered class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NearSpansOrdered(
    SpanNearQuery spanNearQuery,
    IndexReader reader,
    bool collectPayloads
)
Visual Basic
Public Sub New ( _
    spanNearQuery As SpanNearQuery, _
    reader As IndexReader, _
    collectPayloads As Boolean _
)
Visual C++
public:
NearSpansOrdered(
    SpanNearQuery^ spanNearQuery,
    IndexReader^ reader,
    bool collectPayloads
)

Parameters

spanNearQuery
Type: Lucene.Net.Search.Spans..::..SpanNearQuery

[Missing <param name="spanNearQuery"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader,System.Boolean)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader,System.Boolean)"]

collectPayloads
Type: System..::..Boolean

[Missing <param name="collectPayloads"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader,System.Boolean)"]

See Also

NearSpansOrdered Class
NearSpansOrdered Overload
Lucene.Net.Search.Spans Namespace


NearSpansOrdered Methods

[image] [image]

Lucene.Net Class Libraries
NearSpansOrdered Methods
NearSpansOrdered Class See Also Send Feedback

The NearSpansOrdered type exposes the following members.

Methods

 | Name | Description
Public method | Doc | (Overrides Spans..::..Doc()()()().)
Public method | End | (Overrides Spans..::..End()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | (Overrides Spans..::..GetPayload()()()().)
Public method | GetSubSpans |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable | (Overrides Spans..::..IsPayloadAvailable()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides Spans..::..Next()()()().)
Public method | SkipTo | (Overrides Spans..::..SkipTo(Int32).)
Public method | Start | (Overrides Spans..::..Start()()()().)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


Doc Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..Doc Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.Doc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Doc()
Visual Basic
Public Overrides Function Doc As Integer
Visual C++
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.Doc"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


End Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..End Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.End"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int End()
Visual Basic
Public Overrides Function End As Integer
Visual C++
public:
virtual int End() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.End"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..GetPayload Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.GetPayload"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<byte[]> GetPayload()
Visual Basic
Public Overrides Function GetPayload As ICollection(Of Byte())
Visual C++
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.GetPayload"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


GetSubSpans Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..GetSubSpans Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.GetSubSpans"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Spans[] GetSubSpans()
Visual Basic
Public Overridable Function GetSubSpans As Spans()
Visual C++
public:
virtual array<Spans^>^ GetSubSpans()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.GetSubSpans"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..IsPayloadAvailable Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.IsPayloadAvailable"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsPayloadAvailable()
Visual Basic
Public Overrides Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.IsPayloadAvailable"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


Next Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..Next Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.Next"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.Next"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..SkipTo Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool SkipTo(
    int target
)
Visual Basic
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.SkipTo(System.Int32)"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


Start Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..Start Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.Start"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Start()
Visual Basic
Public Overrides Function Start As Integer
Visual C++
public:
virtual int Start() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.Start"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image]

Lucene.Net Class Libraries
NearSpansOrdered..::..ToString Method
NearSpansOrdered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.ToString"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansOrdered.ToString"]

See Also

NearSpansOrdered Class
Lucene.Net.Search.Spans Namespace


NearSpansUnordered Class

[image]

Lucene.Net Class Libraries
NearSpansUnordered Class
Members See Also Send Feedback
Similar to {@link NearSpansOrdered}, but for the unordered case. Expert: Only public for subclassing. Most implementations should not need this class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NearSpansUnordered : Spans
Visual Basic
Public Class NearSpansUnordered _
    Inherits Spans
Visual C++
public ref class NearSpansUnordered : public Spans

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Spans..::..Spans
Lucene.Net.Search.Spans..::..NearSpansUnordered

See Also

NearSpansUnordered Members
Lucene.Net.Search.Spans Namespace


NearSpansUnordered Members

[image] [image]

Lucene.Net Class Libraries
NearSpansUnordered Members
NearSpansUnordered Class Constructors Methods See Also Send Feedback

The NearSpansUnordered type exposes the following members.

Constructors

 | Name | Description
Public method | NearSpansUnordered | Initializes a new instance of the NearSpansUnordered class

Methods

 | Name | Description
Public method | Doc | (Overrides Spans..::..Doc()()()().)
Public method | End | (Overrides Spans..::..End()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | WARNING: The List is not necessarily in order of the the positions (Overrides Spans..::..GetPayload()()()().)
Public method | GetSubSpans |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable | (Overrides Spans..::..IsPayloadAvailable()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides Spans..::..Next()()()().)
Public method | SkipTo | (Overrides Spans..::..SkipTo(Int32).)
Public method | Start | (Overrides Spans..::..Start()()()().)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


NearSpansUnordered Constructor

[image]

Lucene.Net Class Libraries
NearSpansUnordered Constructor
NearSpansUnordered Class See Also Send Feedback
Initializes a new instance of the NearSpansUnordered class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NearSpansUnordered(
    SpanNearQuery query,
    IndexReader reader
)
Visual Basic
Public Sub New ( _
    query As SpanNearQuery, _
    reader As IndexReader _
)
Visual C++
public:
NearSpansUnordered(
    SpanNearQuery^ query,
    IndexReader^ reader
)

Parameters

query
Type: Lucene.Net.Search.Spans..::..SpanNearQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.#ctor(Lucene.Net.Search.Spans.SpanNearQuery,Lucene.Net.Index.IndexReader)"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


NearSpansUnordered Methods

[image] [image]

Lucene.Net Class Libraries
NearSpansUnordered Methods
NearSpansUnordered Class See Also Send Feedback

The NearSpansUnordered type exposes the following members.

Methods

 | Name | Description
Public method | Doc | (Overrides Spans..::..Doc()()()().)
Public method | End | (Overrides Spans..::..End()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | WARNING: The List is not necessarily in order of the the positions (Overrides Spans..::..GetPayload()()()().)
Public method | GetSubSpans |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable | (Overrides Spans..::..IsPayloadAvailable()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides Spans..::..Next()()()().)
Public method | SkipTo | (Overrides Spans..::..SkipTo(Int32).)
Public method | Start | (Overrides Spans..::..Start()()()().)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


Doc Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..Doc Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.Doc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Doc()
Visual Basic
Public Overrides Function Doc As Integer
Visual C++
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.Doc"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


End Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..End Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.End"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int End()
Visual Basic
Public Overrides Function End As Integer
Visual C++
public:
virtual int End() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.End"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..GetPayload Method
NearSpansUnordered Class See Also Send Feedback
WARNING: The List is not necessarily in order of the the positions

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<byte[]> GetPayload()
Visual Basic
Public Overrides Function GetPayload As ICollection(Of Byte())
Visual C++
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override

Return Value

Collection of
CopyC#
byte[]
 payloads

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


GetSubSpans Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..GetSubSpans Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.GetSubSpans"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Spans[] GetSubSpans()
Visual Basic
Public Overridable Function GetSubSpans As Spans()
Visual C++
public:
virtual array<Spans^>^ GetSubSpans()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.GetSubSpans"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..IsPayloadAvailable Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.IsPayloadAvailable"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsPayloadAvailable()
Visual Basic
Public Overrides Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.IsPayloadAvailable"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


Next Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..Next Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.Next"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.Next"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..SkipTo Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool SkipTo(
    int target
)
Visual Basic
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.SkipTo(System.Int32)"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


Start Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..Start Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.Start"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Start()
Visual Basic
Public Overrides Function Start As Integer
Visual C++
public:
virtual int Start() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.Start"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image]

Lucene.Net Class Libraries
NearSpansUnordered..::..ToString Method
NearSpansUnordered Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.ToString"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.NearSpansUnordered.ToString"]

See Also

NearSpansUnordered Class
Lucene.Net.Search.Spans Namespace


SpanFirstQuery Class

[image]

Lucene.Net Class Libraries
SpanFirstQuery Class
Members See Also Send Feedback
Matches spans near the beginning of a field.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanFirstQuery : SpanQuery,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class SpanFirstQuery _
    Inherits SpanQuery _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class SpanFirstQuery : public SpanQuery,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanFirstQuery

See Also

SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace


SpanFirstQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanFirstQuery Members
SpanFirstQuery Class Constructors Methods See Also Send Feedback

The SpanFirstQuery type exposes the following members.

Constructors

Name Description
Public method SpanFirstQuery
Construct a SpanFirstQuery matching spans in
CopyC#
match
 whose end position is less than or equal to
CopyC#
end
.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetEnd
Return the maximum end position permitted in a match.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetMatch
Return the SpanQuery whose matches are filtered.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


SpanFirstQuery Constructor

[image]

Lucene.Net Class Libraries
SpanFirstQuery Constructor
SpanFirstQuery Class See Also Send Feedback
Construct a SpanFirstQuery matching spans in
CopyC#
match
 whose end position is less than or equal to
CopyC#
end
.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanFirstQuery(
    SpanQuery match,
    int end
)
Visual Basic
Public Sub New ( _
    match As SpanQuery, _
    end As Integer _
)
Visual C++
public:
SpanFirstQuery(
    SpanQuery^ match,
    int end
)

Parameters

match
Type: Lucene.Net.Search.Spans..::..SpanQuery

[Missing <param name="match"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery,System.Int32)"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


SpanFirstQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanFirstQuery Methods
SpanFirstQuery Class See Also Send Feedback

The SpanFirstQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetEnd
Return the maximum end position permitted in a match.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetMatch
Return the SpanQuery whose matches are filtered.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..Clone Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Clone"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..Equals Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Equals(System.Object)"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..ExtractTerms Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


GetEnd Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..GetEnd Method
SpanFirstQuery Class See Also Send Feedback
Return the maximum end position permitted in a match.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetEnd()
Visual Basic
Public Overridable Function GetEnd As Integer
Visual C++
public:
virtual int GetEnd()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetEnd"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..GetField Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetField"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetField"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..GetHashCode Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetHashCode"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


GetMatch Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..GetMatch Method
SpanFirstQuery Class See Also Send Feedback
Return the SpanQuery whose matches are filtered.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery GetMatch()
Visual Basic
Public Overridable Function GetMatch As SpanQuery
Visual C++
public:
virtual SpanQuery^ GetMatch()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetMatch"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..GetSpans Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..GetTerms Method
SpanFirstQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use ExtractTerms instead")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms instead")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms instead")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.GetTerms"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace
[!:ExtractTerms(Set)]


Rewrite Method

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..Rewrite Method
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

SpanFirstQuery Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanFirstQuery..::..ToString Method
SpanFirstQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

SpanFirstQuery Class
SpanFirstQuery Members
Lucene.Net.Search.Spans Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
SpanFirstQuery..::..ToString Method (String)
SpanFirstQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanFirstQuery.ToString(System.String)"]

See Also

SpanFirstQuery Class
ToString Overload
Lucene.Net.Search.Spans Namespace


SpanNearQuery Class

[image]

Lucene.Net Class Libraries
SpanNearQuery Class
Members See Also Send Feedback
Matches spans which are near one another. One can specify slop, the maximum number of intervening unmatched positions, as well as whether matches are required to be in-order.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanNearQuery : SpanQuery,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class SpanNearQuery _
    Inherits SpanQuery _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class SpanNearQuery : public SpanQuery,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanNearQuery
Lucene.Net.Search.Payloads..::..PayloadNearQuery

See Also

SpanNearQuery Members
Lucene.Net.Search.Spans Namespace


SpanNearQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanNearQuery Members
SpanNearQuery Class Constructors Methods Fields See Also Send Feedback

The SpanNearQuery type exposes the following members.

Constructors

Name Description
Public method SpanNearQuery(array<SpanQuery>[]()[][], Int32, Boolean)
Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to
CopyC#
slop
 total unmatched positions between them. * When
CopyC#
inOrder
 is true, the spans from each clause must be * ordered as in
CopyC#
clauses
.
Public method SpanNearQuery(array<SpanQuery>[]()[][], Int32, Boolean, Boolean)
Initializes a new instance of the SpanNearQuery class

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Return the clauses whose spans are matched.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Return the maximum number of intervening unmatched positions permitted.
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsInOrder
Return true if matches are required to be in-order.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | clauses |
Protected field | field |
Protected field | inOrder |
Protected field | slop |

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


SpanNearQuery Constructor

[image] [image]

Lucene.Net Class Libraries
SpanNearQuery Constructor
SpanNearQuery Class See Also Send Feedback

Overload List

Name Description
Public method SpanNearQuery(array<SpanQuery>[]()[][], Int32, Boolean)
Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to
CopyC#
slop
 total unmatched positions between them. * When
CopyC#
inOrder
 is true, the spans from each clause must be * ordered as in
CopyC#
clauses
.
Public method SpanNearQuery(array<SpanQuery>[]()[][], Int32, Boolean, Boolean)
Initializes a new instance of the SpanNearQuery class

See Also

SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace


SpanNearQuery Constructor (SpanQuery[], Int32, Boolean)

[image]

Lucene.Net Class Libraries
SpanNearQuery Constructor (array<SpanQuery>[]()[][], Int32, Boolean)
SpanNearQuery Class See Also Send Feedback
Construct a SpanNearQuery. Matches spans matching a span from each clause, with up to
CopyC#
slop
 total unmatched positions between them. * When
CopyC#
inOrder
 is true, the spans from each clause must be * ordered as in
CopyC#
clauses
.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder
)
Visual Basic
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean _
)
Visual C++
public:
SpanNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder
)

Parameters

clauses
Type: array< Lucene.Net.Search.Spans..::..SpanQuery >[]()[][]

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean)"]

slop
Type: System..::..Int32

[Missing <param name="slop"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean)"]

inOrder
Type: System..::..Boolean

[Missing <param name="inOrder"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean)"]

See Also

SpanNearQuery Class
SpanNearQuery Overload
Lucene.Net.Search.Spans Namespace


SpanNearQuery Constructor (SpanQuery[], Int32, Boolean, Boolean)

[image]

Lucene.Net Class Libraries
SpanNearQuery Constructor (array<SpanQuery>[]()[][], Int32, Boolean, Boolean)
SpanNearQuery Class See Also Send Feedback
Initializes a new instance of the SpanNearQuery class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanNearQuery(
    SpanQuery[] clauses,
    int slop,
    bool inOrder,
    bool collectPayloads
)
Visual Basic
Public Sub New ( _
    clauses As SpanQuery(), _
    slop As Integer, _
    inOrder As Boolean, _
    collectPayloads As Boolean _
)
Visual C++
public:
SpanNearQuery(
    array<SpanQuery^>^ clauses,
    int slop,
    bool inOrder,
    bool collectPayloads
)

Parameters

clauses
Type: array< Lucene.Net.Search.Spans..::..SpanQuery >[]()[][]

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,System.Boolean)"]

slop
Type: System..::..Int32

[Missing <param name="slop"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,System.Boolean)"]

inOrder
Type: System..::..Boolean

[Missing <param name="inOrder"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,System.Boolean)"]

collectPayloads
Type: System..::..Boolean

[Missing <param name="collectPayloads"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[],System.Int32,System.Boolean,System.Boolean)"]

See Also

SpanNearQuery Class
SpanNearQuery Overload
Lucene.Net.Search.Spans Namespace


SpanNearQuery Fields

[image] [image]

Lucene.Net Class Libraries
SpanNearQuery Fields
SpanNearQuery Class See Also Send Feedback

The SpanNearQuery type exposes the following members.

Fields

 | Name | Description
Protected field | clauses |
Protected field | field |
Protected field | inOrder |
Protected field | slop |

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


clauses Field

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..clauses Field
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanNearQuery.clauses"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal ArrayList clauses
Visual Basic
Protected Friend clauses As ArrayList
Visual C++
protected public:
ArrayList^ clauses

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


field Field

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..field Field
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanNearQuery.field"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string field
Visual Basic
Protected Friend field As String
Visual C++
protected public:
String^ field

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


inOrder Field

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..inOrder Field
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanNearQuery.inOrder"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool inOrder
Visual Basic
Protected Friend inOrder As Boolean
Visual C++
protected public:
bool inOrder

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


slop Field

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..slop Field
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanNearQuery.slop"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int slop
Visual Basic
Protected Friend slop As Integer
Visual C++
protected public:
int slop

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


SpanNearQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanNearQuery Methods
SpanNearQuery Class See Also Send Feedback

The SpanNearQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Return the clauses whose spans are matched.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSlop
Return the maximum number of intervening unmatched positions permitted.
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsInOrder
Return true if matches are required to be in-order.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..Clone Method
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Clone"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..Equals Method
SpanNearQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Equals(System.Object)"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..ExtractTerms Method
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


GetClauses Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..GetClauses Method
SpanNearQuery Class See Also Send Feedback
Return the clauses whose spans are matched.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery[] GetClauses()
Visual Basic
Public Overridable Function GetClauses As SpanQuery()
Visual C++
public:
virtual array<SpanQuery^>^ GetClauses()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetClauses"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..GetField Method
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetField"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetField"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..GetHashCode Method
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetHashCode"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


GetSlop Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..GetSlop Method
SpanNearQuery Class See Also Send Feedback
Return the maximum number of intervening unmatched positions permitted.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetSlop()
Visual Basic
Public Overridable Function GetSlop As Integer
Visual C++
public:
virtual int GetSlop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetSlop"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..GetSpans Method
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..GetTerms Method
SpanNearQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use ExtractTerms instead")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms instead")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms instead")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.GetTerms"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace
[!:ExtractTerms(Set)]


IsInOrder Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..IsInOrder Method
SpanNearQuery Class See Also Send Feedback
Return true if matches are required to be in-order.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsInOrder()
Visual Basic
Public Overridable Function IsInOrder As Boolean
Visual C++
public:
virtual bool IsInOrder()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.IsInOrder"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


Rewrite Method

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..Rewrite Method
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

SpanNearQuery Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanNearQuery..::..ToString Method
SpanNearQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

SpanNearQuery Class
SpanNearQuery Members
Lucene.Net.Search.Spans Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
SpanNearQuery..::..ToString Method (String)
SpanNearQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNearQuery.ToString(System.String)"]

See Also

SpanNearQuery Class
ToString Overload
Lucene.Net.Search.Spans Namespace


SpanNotQuery Class

[image]

Lucene.Net Class Libraries
SpanNotQuery Class
Members See Also Send Feedback
Removes matches which overlap with another SpanQuery.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanNotQuery : SpanQuery,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class SpanNotQuery _
    Inherits SpanQuery _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class SpanNotQuery : public SpanQuery,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanNotQuery

See Also

SpanNotQuery Members
Lucene.Net.Search.Spans Namespace


SpanNotQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanNotQuery Members
SpanNotQuery Class Constructors Methods See Also Send Feedback

The SpanNotQuery type exposes the following members.

Constructors

Name Description
Public method SpanNotQuery
Construct a SpanNotQuery matching spans from
CopyC#
include
 which have no overlap with spans from
CopyC#
exclude
.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetExclude
Return the SpanQuery whose matches must not overlap those returned.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetInclude
Return the SpanQuery whose matches are filtered.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


SpanNotQuery Constructor

[image]

Lucene.Net Class Libraries
SpanNotQuery Constructor
SpanNotQuery Class See Also Send Feedback
Construct a SpanNotQuery matching spans from
CopyC#
include
 which have no overlap with spans from
CopyC#
exclude
.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanNotQuery(
    SpanQuery include,
    SpanQuery exclude
)
Visual Basic
Public Sub New ( _
    include As SpanQuery, _
    exclude As SpanQuery _
)
Visual C++
public:
SpanNotQuery(
    SpanQuery^ include,
    SpanQuery^ exclude
)

Parameters

include
Type: Lucene.Net.Search.Spans..::..SpanQuery

[Missing <param name="include"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Spans.SpanQuery)"]

exclude
Type: Lucene.Net.Search.Spans..::..SpanQuery

[Missing <param name="exclude"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Spans.SpanQuery)"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


SpanNotQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanNotQuery Methods
SpanNotQuery Class See Also Send Feedback

The SpanNotQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method Equals
Returns true iff
CopyC#
o
 is equal to this.
(Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetExclude
Return the SpanQuery whose matches must not overlap those returned.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetInclude
Return the SpanQuery whose matches are filtered.
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..Clone Method
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Clone"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..Equals Method
SpanNotQuery Class See Also Send Feedback
Returns true iff
CopyC#
o
 is equal to this.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Equals(System.Object)"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..ExtractTerms Method
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


GetExclude Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..GetExclude Method
SpanNotQuery Class See Also Send Feedback
Return the SpanQuery whose matches must not overlap those returned.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery GetExclude()
Visual Basic
Public Overridable Function GetExclude As SpanQuery
Visual C++
public:
virtual SpanQuery^ GetExclude()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetExclude"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..GetField Method
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetField"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetField"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..GetHashCode Method
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetHashCode"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


GetInclude Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..GetInclude Method
SpanNotQuery Class See Also Send Feedback
Return the SpanQuery whose matches are filtered.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery GetInclude()
Visual Basic
Public Overridable Function GetInclude As SpanQuery
Visual C++
public:
virtual SpanQuery^ GetInclude()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetInclude"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..GetSpans Method
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..GetTerms Method
SpanNotQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use ExtractTerms instead")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms instead")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms instead")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.GetTerms"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace
[!:ExtractTerms(Set)]


Rewrite Method

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..Rewrite Method
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

SpanNotQuery Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanNotQuery..::..ToString Method
SpanNotQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

SpanNotQuery Class
SpanNotQuery Members
Lucene.Net.Search.Spans Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
SpanNotQuery..::..ToString Method (String)
SpanNotQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanNotQuery.ToString(System.String)"]

See Also

SpanNotQuery Class
ToString Overload
Lucene.Net.Search.Spans Namespace


SpanOrQuery Class

[image]

Lucene.Net Class Libraries
SpanOrQuery Class
Members See Also Send Feedback
Matches the union of its clauses.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanOrQuery : SpanQuery,
    ICloneable
Visual Basic
<SerializableAttribute> _
Public Class SpanOrQuery _
    Inherits SpanQuery _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class SpanOrQuery : public SpanQuery,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanOrQuery

See Also

SpanOrQuery Members
Lucene.Net.Search.Spans Namespace


SpanOrQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanOrQuery Members
SpanOrQuery Class Constructors Methods See Also Send Feedback

The SpanOrQuery type exposes the following members.

Constructors

 | Name | Description
Public method | SpanOrQuery | Construct a SpanOrQuery merging the provided clauses.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Return the clauses whose spans are matched.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


SpanOrQuery Constructor

[image]

Lucene.Net Class Libraries
SpanOrQuery Constructor
SpanOrQuery Class See Also Send Feedback
Construct a SpanOrQuery merging the provided clauses.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanOrQuery(
    SpanQuery[] clauses
)
Visual Basic
Public Sub New ( _
    clauses As SpanQuery() _
)
Visual C++
public:
SpanOrQuery(
    array<SpanQuery^>^ clauses
)

Parameters

clauses
Type: array< Lucene.Net.Search.Spans..::..SpanQuery >[]()[][]

[Missing <param name="clauses"/> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.#ctor(Lucene.Net.Search.Spans.SpanQuery[])"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


SpanOrQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanOrQuery Methods
SpanOrQuery Class See Also Send Feedback

The SpanOrQuery type exposes the following members.

Methods

Name | Description
Public method | Clone | (Overrides Query..::..Clone()()()().)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetClauses
Return the clauses whose spans are matched.
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Rewrite | (Overrides Query..::..Rewrite(IndexReader).)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..Clone Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Clone"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..Equals Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Equals(System.Object)"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..ExtractTerms Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


GetClauses Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..GetClauses Method
SpanOrQuery Class See Also Send Feedback
Return the clauses whose spans are matched.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual SpanQuery[] GetClauses()
Visual Basic
Public Overridable Function GetClauses As SpanQuery()
Visual C++
public:
virtual array<SpanQuery^>^ GetClauses()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetClauses"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..GetField Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetField"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetField"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..GetHashCode Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetHashCode"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..GetSpans Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..GetTerms Method
SpanOrQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use ExtractTerms instead")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms instead")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms instead")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.GetTerms"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace
[!:ExtractTerms(Set)]


Rewrite Method

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..Rewrite Method
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query Rewrite(
    IndexReader reader
)
Visual Basic
Public Overrides Function Rewrite ( _
    reader As IndexReader _
) As Query
Visual C++
public:
virtual Query^ Rewrite(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.Rewrite(Lucene.Net.Index.IndexReader)"]

See Also

SpanOrQuery Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanOrQuery..::..ToString Method
SpanOrQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

SpanOrQuery Class
SpanOrQuery Members
Lucene.Net.Search.Spans Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
SpanOrQuery..::..ToString Method (String)
SpanOrQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanOrQuery.ToString(System.String)"]

See Also

SpanOrQuery Class
ToString Overload
Lucene.Net.Search.Spans Namespace


SpanQuery Class

[image]

Lucene.Net Class Libraries
SpanQuery Class
Members See Also Send Feedback
Base class for span-based queries.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class SpanQuery : Query
Visual Basic
<SerializableAttribute> _
Public MustInherit Class SpanQuery _
    Inherits Query
Visual C++
[SerializableAttribute]
public ref class SpanQuery abstract : public Query

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Regex..::..SpanRegexQuery
Lucene.Net.Search.Spans..::..FieldMaskingSpanQuery
Lucene.Net.Search.Spans..::..SpanFirstQuery
Lucene.Net.Search.Spans..::..SpanNearQuery
Lucene.Net.Search.Spans..::..SpanNotQuery
Lucene.Net.Search.Spans..::..SpanOrQuery
Lucene.Net.Search.Spans..::..SpanTermQuery

See Also

SpanQuery Members
Lucene.Net.Search.Spans Namespace


SpanQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanQuery Members
SpanQuery Class Constructors Methods See Also Send Feedback

The SpanQuery type exposes the following members.

Constructors

 | Name | Description
Protected method | SpanQuery | Initializes a new instance of the SpanQuery class

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method | Equals | (Inherited from Query.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetField
Returns the name of the field matched by this query.
Public method | GetHashCode | (Inherited from Query.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSpans
Expert: Returns the matches for this query in an index. Used internally to search for spans.
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace


SpanQuery Constructor

[image]

Lucene.Net Class Libraries
SpanQuery Constructor
SpanQuery Class See Also Send Feedback
Initializes a new instance of the SpanQuery class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected SpanQuery()
Visual Basic
Protected Sub New
Visual C++
protected:
SpanQuery()

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace


SpanQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanQuery Methods
SpanQuery Class See Also Send Feedback

The SpanQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Overrides Query..::..CreateWeight(Searcher).)
Public method | Equals | (Inherited from Query.)
Public method ExtractTerms
Expert: adds all terms occuring in this query to the terms set. Only works if this query is in its {@link #rewrite rewritten} form.
(Inherited from Query.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method GetField
Returns the name of the field matched by this query.
Public method | GetHashCode | (Inherited from Query.)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method GetSpans
Expert: Returns the matches for this query in an index. Used internally to search for spans.
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace


CreateWeight Method

[image]

Lucene.Net Class Libraries
SpanQuery..::..CreateWeight Method
SpanQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Weight CreateWeight(
    Searcher searcher
)
Visual Basic
Public Overrides Function CreateWeight ( _
    searcher As Searcher _
) As Weight
Visual C++
public:
virtual Weight^ CreateWeight(
    Searcher^ searcher
) override

Parameters

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.CreateWeight(Lucene.Net.Search.Searcher)"]

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanQuery..::..GetField Method
SpanQuery Class See Also Send Feedback
Returns the name of the field matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract string GetField()
Visual Basic
Public MustOverride Function GetField As String
Visual C++
public:
virtual String^ GetField() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.GetField"]

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanQuery..::..GetSpans Method
SpanQuery Class See Also Send Feedback
Expert: Returns the matches for this query in an index. Used internally to search for spans.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public MustOverride Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanQuery..::..GetTerms Method
SpanQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use ExtractTerms instead")]
public abstract ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use ExtractTerms instead")> _
Public MustOverride Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use ExtractTerms instead")]
public:
virtual ICollection^ GetTerms() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanQuery.GetTerms"]

See Also

SpanQuery Class
Lucene.Net.Search.Spans Namespace
[!:Query.ExtractTerms(Set)]


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanQuery..::..ToString Method
SpanQuery Class See Also Send Feedback

Overload List

Name Description
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method ToString(String)
Prints a query to a string, with
CopyC#
field
 assumed to be the default field and omitted.

The representation used is one that is supposed to be readable by {@link Lucene.Net.QueryParsers.QueryParser QueryParser}. However, there are the following limitations:

  • If the query was created by the parser, the printed representation may not be exactly what was parsed. For example, characters that need to be escaped will be represented without the required backslash.
  • Some of the more complicated queries (e.g. span queries) don't have a representation that can be parsed by QueryParser.
(Inherited from Query.)

See Also

SpanQuery Class
SpanQuery Members
Lucene.Net.Search.Spans Namespace


Spans Class

[image]

Lucene.Net Class Libraries
Spans Class
Members See Also Send Feedback
Expert: an enumeration of span matches. Used to implement span searching. Each span represents a range of term positions within a document. Matches are enumerated in order, by increasing document number, within that by increasing start position and finally by increasing end position.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Spans
Visual Basic
Public MustInherit Class Spans
Visual C++
public ref class Spans abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Spans..::..Spans
Lucene.Net.Search.Spans..::..NearSpansOrdered
Lucene.Net.Search.Spans..::..NearSpansUnordered
Lucene.Net.Search.Spans..::..TermSpans

See Also

Spans Members
Lucene.Net.Search.Spans Namespace


Spans Members

[image] [image]

Lucene.Net Class Libraries
Spans Members
Spans Class Constructors Methods See Also Send Feedback

The Spans type exposes the following members.

Constructors

 | Name | Description
Protected method | Spans | Initializes a new instance of the Spans class

Methods

Name Description
Public method Doc
Returns the document number of the current match. Initially invalid.
Public method End
Returns the end position of the current match. Initially invalid.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetPayload
Returns the payload data for the current span. This is invalid until {@link #Next()} is called for the first time. This method must not be called more than once after each call of {@link #Next()}. However, most payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons. An ordered SpanQuery does not lazy load, so if you have payloads in your index and you do not want ordered SpanNearQuerys to collect payloads, you can disable collection with a constructor option.
Note that the return type is a collection, thus the ordering should not be relied upon.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsPayloadAvailable
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to {@link #Next()}.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Move to the next match, returning true iff any such exists.
Public method SkipTo
Skips to the first match beyond the current, whose document number is greater than or equal to target.

Returns true iff there is such a match.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Most implementations are considerably more efficient than that.
Public method Start
Returns the start position of the current match. Initially invalid.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


Spans Constructor

[image]

Lucene.Net Class Libraries
Spans Constructor
Spans Class See Also Send Feedback
Initializes a new instance of the Spans class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Spans()
Visual Basic
Protected Sub New
Visual C++
protected:
Spans()

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


Spans Methods

[image] [image]

Lucene.Net Class Libraries
Spans Methods
Spans Class See Also Send Feedback

The Spans type exposes the following members.

Methods

Name Description
Public method Doc
Returns the document number of the current match. Initially invalid.
Public method End
Returns the end position of the current match. Initially invalid.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetPayload
Returns the payload data for the current span. This is invalid until {@link #Next()} is called for the first time. This method must not be called more than once after each call of {@link #Next()}. However, most payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons. An ordered SpanQuery does not lazy load, so if you have payloads in your index and you do not want ordered SpanNearQuerys to collect payloads, you can disable collection with a constructor option.
Note that the return type is a collection, thus the ordering should not be relied upon.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsPayloadAvailable
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to {@link #Next()}.

Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Next
Move to the next match, returning true iff any such exists.
Public method SkipTo
Skips to the first match beyond the current, whose document number is greater than or equal to target.

Returns true iff there is such a match.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Most implementations are considerably more efficient than that.
Public method Start
Returns the start position of the current match. Initially invalid.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


Doc Method

[image]

Lucene.Net Class Libraries
Spans..::..Doc Method
Spans Class See Also Send Feedback
Returns the document number of the current match. Initially invalid.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int Doc()
Visual Basic
Public MustOverride Function Doc As Integer
Visual C++
public:
virtual int Doc() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.Spans.Doc"]

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


End Method

[image]

Lucene.Net Class Libraries
Spans..::..End Method
Spans Class See Also Send Feedback
Returns the end position of the current match. Initially invalid.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int End()
Visual Basic
Public MustOverride Function End As Integer
Visual C++
public:
virtual int End() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.Spans.End"]

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
Spans..::..GetPayload Method
Spans Class See Also Send Feedback
Returns the payload data for the current span. This is invalid until {@link #Next()} is called for the first time. This method must not be called more than once after each call of {@link #Next()}. However, most payloads are loaded lazily, so if the payload data for the current position is not needed, this method may not be called at all for performance reasons. An ordered SpanQuery does not lazy load, so if you have payloads in your index and you do not want ordered SpanNearQuerys to collect payloads, you can disable collection with a constructor option.
Note that the return type is a collection, thus the ordering should not be relied upon.

WARNING: The status of the Payloads feature is experimental. The APIs introduced here might change in the future and will not be supported anymore in such a case.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract ICollection<byte[]> GetPayload()
Visual Basic
Public MustOverride Function GetPayload As ICollection(Of Byte())
Visual C++
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() abstract

Return Value

a List of byte arrays containing the data of this payload, otherwise null if isPayloadAvailable is false

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
Spans..::..IsPayloadAvailable Method
Spans Class See Also Send Feedback
Checks if a payload can be loaded at this position.

Payloads can only be loaded once per call to {@link #Next()}.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool IsPayloadAvailable()
Visual Basic
Public MustOverride Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable() abstract

Return Value

true if there is a payload available at this position that can be loaded

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


Next Method

[image]

Lucene.Net Class Libraries
Spans..::..Next Method
Spans Class See Also Send Feedback
Move to the next match, returning true iff any such exists.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Next()
Visual Basic
Public MustOverride Function Next As Boolean
Visual C++
public:
virtual bool Next() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.Spans.Next"]

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
Spans..::..SkipTo Method
Spans Class See Also Send Feedback
Skips to the first match beyond the current, whose document number is greater than or equal to target.

Returns true iff there is such a match.

Behaves as if written:

            boolean skipTo(int target) {
            do {
            if (!next())
            return false;
            } while (target > doc());
            return true;
            }
Most implementations are considerably more efficient than that.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool SkipTo(
    int target
)
Visual Basic
Public MustOverride Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
) abstract

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.Spans.Spans.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.Spans.SkipTo(System.Int32)"]

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


Start Method

[image]

Lucene.Net Class Libraries
Spans..::..Start Method
Spans Class See Also Send Feedback
Returns the start position of the current match. Initially invalid.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int Start()
Visual Basic
Public MustOverride Function Start As Integer
Visual C++
public:
virtual int Start() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.Spans.Start"]

See Also

Spans Class
Lucene.Net.Search.Spans Namespace


SpanScorer Class

[image]

Lucene.Net Class Libraries
SpanScorer Class
Members See Also Send Feedback
Public for extension only.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SpanScorer : Scorer
Visual Basic
Public Class SpanScorer _
    Inherits Scorer
Visual C++
public ref class SpanScorer : public Scorer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Search..::..Scorer
Lucene.Net.Search.Spans..::..SpanScorer
Lucene.Net.Search.Payloads..::..PayloadNearQuery..::..PayloadNearSpanScorer
Lucene.Net.Search.Payloads..::..PayloadTermQuery..::..PayloadTermWeight..::..PayloadTermSpanScorer

See Also

SpanScorer Members
Lucene.Net.Search.Spans Namespace


SpanScorer Members

[image] [image]

Lucene.Net Class Libraries
SpanScorer Members
SpanScorer Class Constructors Methods Fields See Also Send Feedback

The SpanScorer type exposes the following members.

Constructors

 | Name | Description
Protected method | SpanScorer | Initializes a new instance of the SpanScorer class

Methods

Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SetFreqCurrentDoc
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | doc |
Protected field | firstTime | Obsolete.
Protected field | freq |
Protected field | more |
Protected field | norms |
Protected field | spans |
Protected field | value_Renamed |
Protected field | weight |

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


SpanScorer Constructor

[image]

Lucene.Net Class Libraries
SpanScorer Constructor
SpanScorer Class See Also Send Feedback
Initializes a new instance of the SpanScorer class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SpanScorer(
    Spans spans,
    Weight weight,
    Similarity similarity,
    byte[] norms
)
Visual Basic
Protected Friend Sub New ( _
    spans As Spans, _
    weight As Weight, _
    similarity As Similarity, _
    norms As Byte() _
)
Visual C++
protected public:
SpanScorer(
    Spans^ spans,
    Weight^ weight,
    Similarity^ similarity,
    array<unsigned char>^ norms
)

Parameters

spans
Type: Lucene.Net.Search.Spans..::..Spans

[Missing <param name="spans"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.#ctor(Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

weight
Type: Lucene.Net.Search..::..Weight

[Missing <param name="weight"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.#ctor(Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

similarity
Type: Lucene.Net.Search..::..Similarity

[Missing <param name="similarity"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.#ctor(Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

norms
Type: array< System..::..Byte >[]()[][]

[Missing <param name="norms"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.#ctor(Lucene.Net.Search.Spans.Spans,Lucene.Net.Search.Weight,Lucene.Net.Search.Similarity,System.Byte[])"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


SpanScorer Fields

[image] [image]

Lucene.Net Class Libraries
SpanScorer Fields
SpanScorer Class See Also Send Feedback

The SpanScorer type exposes the following members.

Fields

 | Name | Description
Protected field | doc |
Protected field | firstTime | Obsolete.
Protected field | freq |
Protected field | more |
Protected field | norms |
Protected field | spans |
Protected field | value_Renamed |
Protected field | weight |

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


doc Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..doc Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.doc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int doc
Visual Basic
Protected Friend doc As Integer
Visual C++
protected public:
int doc

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


firstTime Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..firstTime Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.firstTime"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("not needed anymore ")]
protected internal bool firstTime
Visual Basic
<ObsoleteAttribute("not needed anymore ")> _
Protected Friend firstTime As Boolean
Visual C++
[ObsoleteAttribute(L"not needed anymore ")]
protected public:
bool firstTime

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


freq Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..freq Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.freq"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float freq
Visual Basic
Protected Friend freq As Single
Visual C++
protected public:
float freq

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


more Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..more Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.more"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool more
Visual Basic
Protected Friend more As Boolean
Visual C++
protected public:
bool more

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


norms Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..norms Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.norms"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal byte[] norms
Visual Basic
Protected Friend norms As Byte()
Visual C++
protected public:
array<unsigned char>^ norms

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


spans Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..spans Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.spans"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Spans spans
Visual Basic
Protected Friend spans As Spans
Visual C++
protected public:
Spans^ spans

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


value_Renamed Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..value_Renamed Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.value_Renamed"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float value_Renamed
Visual Basic
Protected Friend value_Renamed As Single
Visual C++
protected public:
float value_Renamed

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


weight Field

[image]

Lucene.Net Class Libraries
SpanScorer..::..weight Field
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanScorer.weight"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Weight weight
Visual Basic
Protected Friend weight As Weight
Visual C++
protected public:
Weight^ weight

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


SpanScorer Methods

[image] [image]

Lucene.Net Class Libraries
SpanScorer Methods
SpanScorer Class See Also Send Feedback

The SpanScorer type exposes the following members.

Methods

Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Scorer..::..Explain(Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetSimilarity
Returns the Similarity implementation used by this scorer.
(Inherited from Scorer.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)
Public method | SetFreqCurrentDoc
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


Advance Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..Advance Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Advance(System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Advance(System.Int32)"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


Doc Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..Doc Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Doc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead. ")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead. ")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead. ")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Doc"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


DocID Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..DocID Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.DocID"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.DocID"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


Explain Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..Explain Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Explain(System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    int doc
) override

Parameters

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Explain(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Explain(System.Int32)"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


Next Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..Next Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Next"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Next"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..NextDoc Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.NextDoc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.NextDoc"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


Score Method

[image] [image]

Lucene.Net Class Libraries
SpanScorer..::..Score Method
SpanScorer Class See Also Send Feedback

Overload List

Name | Description
Public method | Score()()()() | (Overrides Scorer..::..Score()()()().)
Public method Score(Collector)
Scores and collects all matching documents.
(Inherited from Scorer.)
Public method Score(HitCollector) Obsolete.
Scores and collects all matching documents.
(Inherited from Scorer.)
Protected method Score(HitCollector, Int32) Obsolete.
Expert: Collects matching documents in a range. Hook for optimization. Note that {@link #Next()} must be called once before this method is called for the first time.
(Inherited from Scorer.)
Public method Score(Collector, Int32, Int32)
Expert: Collects matching documents in a range. Hook for optimization. Note,
CopyC#
firstDocID
 is added to ensure that {@link #NextDoc()} was called before this method.
(Inherited from Scorer.)

See Also

SpanScorer Class
SpanScorer Members
Lucene.Net.Search.Spans Namespace


Score Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..Score Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Score"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float Score()
Visual Basic
Public Overrides Function Score As Single
Visual C++
public:
virtual float Score() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.Score"]

See Also

SpanScorer Class
Score Overload
Lucene.Net.Search.Spans Namespace


SetFreqCurrentDoc Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..SetFreqCurrentDoc Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.SetFreqCurrentDoc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool SetFreqCurrentDoc()
Visual Basic
Public Overridable Function SetFreqCurrentDoc As Boolean
Visual C++
public:
virtual bool SetFreqCurrentDoc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.SetFreqCurrentDoc"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
SpanScorer..::..SkipTo Method
SpanScorer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead. ")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead. ")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead. ")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanScorer.SkipTo(System.Int32)"]

See Also

SpanScorer Class
Lucene.Net.Search.Spans Namespace


SpanTermQuery Class

[image]

Lucene.Net Class Libraries
SpanTermQuery Class
Members See Also Send Feedback
Matches spans containing a term.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanTermQuery : SpanQuery
Visual Basic
<SerializableAttribute> _
Public Class SpanTermQuery _
    Inherits SpanQuery
Visual C++
[SerializableAttribute]
public ref class SpanTermQuery : public SpanQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Query
Lucene.Net.Search.Spans..::..SpanQuery
Lucene.Net.Search.Spans..::..SpanTermQuery
Lucene.Net.Search.Payloads..::..PayloadTermQuery

See Also

SpanTermQuery Members
Lucene.Net.Search.Spans Namespace


SpanTermQuery Members

[image] [image]

Lucene.Net Class Libraries
SpanTermQuery Members
SpanTermQuery Class Constructors Methods Fields See Also Send Feedback

The SpanTermQuery type exposes the following members.

Constructors

 | Name | Description
Public method | SpanTermQuery | Construct a SpanTermQuery matching the named term's spans.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerm
Return the term whose spans are matched.
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

Fields

 | Name | Description
Protected field | term |

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


SpanTermQuery Constructor

[image]

Lucene.Net Class Libraries
SpanTermQuery Constructor
SpanTermQuery Class See Also Send Feedback
Construct a SpanTermQuery matching the named term's spans.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanTermQuery(
    Term term
)
Visual Basic
Public Sub New ( _
    term As Term _
)
Visual C++
public:
SpanTermQuery(
    Term^ term
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.#ctor(Lucene.Net.Index.Term)"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


SpanTermQuery Fields

[image] [image]

Lucene.Net Class Libraries
SpanTermQuery Fields
SpanTermQuery Class See Also Send Feedback

The SpanTermQuery type exposes the following members.

Fields

 | Name | Description
Protected field | term |

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


term Field

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..term Field
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanTermQuery.term"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Term term
Visual Basic
Protected Friend term As Term
Visual C++
protected public:
Term^ term

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


SpanTermQuery Methods

[image] [image]

Lucene.Net Class Libraries
SpanTermQuery Methods
SpanTermQuery Class See Also Send Feedback

The SpanTermQuery type exposes the following members.

Methods

Name | Description
Public method Clone
Returns a clone of this query.
(Inherited from Query.)
Public method Combine
Expert: called when re-writing queries under MultiSearcher. Create a single query suitable for use by all subsearchers (in 1-1 correspondence with queries). This is an optimization of the OR of all queries. We handle the common optimization cases of equal queries and overlapping clauses of boolean OR queries (as generated by MultiTermQuery.rewrite()). Be careful overriding this method as queries[0] determines which method will be called and is not necessarily of the same type as the other queries.
(Inherited from Query.)
Public method | CreateWeight | (Inherited from SpanQuery.)
Public method | Equals | (Overrides Query..::..Equals(Object).)
Public method | ExtractTerms | (Overrides Query..::..ExtractTerms(Hashtable).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetBoost
Gets the boost for this clause. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
. The boost is 1.0 by default.
(Inherited from Query.)
Public method | GetField | (Overrides SpanQuery..::..GetField()()()().)
Public method | GetHashCode | (Overrides Query..::..GetHashCode()()()().)
Public method GetSimilarity
Expert: Returns the Similarity implementation to be used for this query. Subclasses may override this method to specify their own Similarity implementation, perhaps one that delegates through that of the Searcher. By default the Searcher's Similarity implementation is returned.
(Inherited from Query.)
Public method | GetSpans | (Overrides SpanQuery..::..GetSpans(IndexReader).)
Public method GetTerm
Return the term whose spans are matched.
Public method GetTerms Obsolete.
Returns a collection of all terms matched by this query.
(Overrides SpanQuery..::..GetTerms()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Rewrite
Expert: called to re-write queries into primitive queries. For example, a PrefixQuery will be rewritten into a BooleanQuery that consists of TermQuerys.
(Inherited from Query.)
Public method SetBoost
Sets the boost for this query clause to
CopyC#
b
. Documents matching this clause will (in addition to the normal weightings) have their score multiplied by
CopyC#
b
.
(Inherited from Query.)
Public method ToString()()()()
Prints a query to a string.
(Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)
Public method Weight
Expert: Constructs and initializes a Weight for a top-level query.
(Inherited from Query.)

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


Equals Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..Equals Method
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.Equals(System.Object)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.Equals(System.Object)"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


ExtractTerms Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..ExtractTerms Method
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.ExtractTerms(System.Collections.Hashtable)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ExtractTerms(
    Hashtable terms
)
Visual Basic
Public Overrides Sub ExtractTerms ( _
    terms As Hashtable _
)
Visual C++
public:
virtual void ExtractTerms(
    Hashtable^ terms
) override

Parameters

terms
Type: System.Collections..::..Hashtable

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.ExtractTerms(System.Collections.Hashtable)"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


GetField Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..GetField Method
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetField"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetField()
Visual Basic
Public Overrides Function GetField As String
Visual C++
public:
virtual String^ GetField() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetField"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..GetHashCode Method
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetHashCode"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetHashCode"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


GetSpans Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..GetSpans Method
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Spans GetSpans(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetSpans ( _
    reader As IndexReader _
) As Spans
Visual C++
public:
virtual Spans^ GetSpans(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetSpans(Lucene.Net.Index.IndexReader)"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


GetTerm Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..GetTerm Method
SpanTermQuery Class See Also Send Feedback
Return the term whose spans are matched.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Term GetTerm()
Visual Basic
Public Overridable Function GetTerm As Term
Visual C++
public:
virtual Term^ GetTerm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetTerm"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..GetTerms Method
SpanTermQuery Class See Also Send Feedback
Returns a collection of all terms matched by this query.

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use extractTerms instead")]
public override ICollection GetTerms()
Visual Basic
<ObsoleteAttribute("use extractTerms instead")> _
Public Overrides Function GetTerms As ICollection
Visual C++
[ObsoleteAttribute(L"use extractTerms instead")]
public:
virtual ICollection^ GetTerms() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.GetTerms"]

See Also

SpanTermQuery Class
Lucene.Net.Search.Spans Namespace
[!:ExtractTerms(Set)]


ToString Method

[image] [image]

Lucene.Net Class Libraries
SpanTermQuery..::..ToString Method
SpanTermQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Prints a query to a string. (Inherited from Query.)
Public method | ToString(String) | (Overrides Query..::..ToString(String).)

See Also

SpanTermQuery Class
SpanTermQuery Members
Lucene.Net.Search.Spans Namespace


ToString Method (String)

[image]

Lucene.Net Class Libraries
SpanTermQuery..::..ToString Method (String)
SpanTermQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.ToString(System.String)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString(
    string field
)
Visual Basic
Public Overrides Function ToString ( _
    field As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ field
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanTermQuery.ToString(System.String)"]

See Also

SpanTermQuery Class
ToString Overload
Lucene.Net.Search.Spans Namespace


SpanWeight Class

[image]

Lucene.Net Class Libraries
SpanWeight Class
Members See Also Send Feedback
Expert-only. Public for use by other weight implementations

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class SpanWeight : Weight
Visual Basic
<SerializableAttribute> _
Public Class SpanWeight _
    Inherits Weight
Visual C++
[SerializableAttribute]
public ref class SpanWeight : public Weight

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Weight
Lucene.Net.Search.Spans..::..SpanWeight
Lucene.Net.Search.Payloads..::..PayloadNearQuery..::..PayloadNearSpanWeight
Lucene.Net.Search.Payloads..::..PayloadTermQuery..::..PayloadTermWeight

See Also

SpanWeight Members
Lucene.Net.Search.Spans Namespace


SpanWeight Members

[image] [image]

Lucene.Net Class Libraries
SpanWeight Members
SpanWeight Class Constructors Methods Fields See Also Send Feedback

The SpanWeight type exposes the following members.

Constructors

 | Name | Description
Public method | SpanWeight | Initializes a new instance of the SpanWeight class

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

 | Name | Description
Protected field | idf |
Protected field | query |
Protected field | queryNorm |
Protected field | queryWeight |
Protected field | similarity |
Protected field | terms |
Protected field | value_Renamed |

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


SpanWeight Constructor

[image]

Lucene.Net Class Libraries
SpanWeight Constructor
SpanWeight Class See Also Send Feedback
Initializes a new instance of the SpanWeight class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SpanWeight(
    SpanQuery query,
    Searcher searcher
)
Visual Basic
Public Sub New ( _
    query As SpanQuery, _
    searcher As Searcher _
)
Visual C++
public:
SpanWeight(
    SpanQuery^ query,
    Searcher^ searcher
)

Parameters

query
Type: Lucene.Net.Search.Spans..::..SpanQuery

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.#ctor(Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Searcher)"]

searcher
Type: Lucene.Net.Search..::..Searcher

[Missing <param name="searcher"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.#ctor(Lucene.Net.Search.Spans.SpanQuery,Lucene.Net.Search.Searcher)"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


SpanWeight Fields

[image] [image]

Lucene.Net Class Libraries
SpanWeight Fields
SpanWeight Class See Also Send Feedback

The SpanWeight type exposes the following members.

Fields

 | Name | Description
Protected field | idf |
Protected field | query |
Protected field | queryNorm |
Protected field | queryWeight |
Protected field | similarity |
Protected field | terms |
Protected field | value_Renamed |

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


idf Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..idf Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.idf"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float idf
Visual Basic
Protected Friend idf As Single
Visual C++
protected public:
float idf

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


query Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..query Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.query"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SpanQuery query
Visual Basic
Protected Friend query As SpanQuery
Visual C++
protected public:
SpanQuery^ query

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


queryNorm Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..queryNorm Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.queryNorm"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float queryNorm
Visual Basic
Protected Friend queryNorm As Single
Visual C++
protected public:
float queryNorm

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


queryWeight Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..queryWeight Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.queryWeight"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float queryWeight
Visual Basic
Protected Friend queryWeight As Single
Visual C++
protected public:
float queryWeight

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


similarity Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..similarity Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.similarity"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Similarity similarity
Visual Basic
Protected Friend similarity As Similarity
Visual C++
protected public:
Similarity^ similarity

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


terms Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..terms Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.terms"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Hashtable terms
Visual Basic
Protected Friend terms As Hashtable
Visual C++
protected public:
Hashtable^ terms

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


value_Renamed Field

[image]

Lucene.Net Class Libraries
SpanWeight..::..value_Renamed Field
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.SpanWeight.value_Renamed"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal float value_Renamed
Visual Basic
Protected Friend value_Renamed As Single
Visual C++
protected public:
float value_Renamed

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


SpanWeight Methods

[image] [image]

Lucene.Net Class Libraries
SpanWeight Methods
SpanWeight Class See Also Send Feedback

The SpanWeight type exposes the following members.

Methods

Name | Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method | Explain | (Overrides Weight..::..Explain(IndexReader, Int32).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetQuery | (Overrides Weight..::..GetQuery()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Overrides Weight..::..GetValue()()()().)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | Normalize | (Overrides Weight..::..Normalize(Single).)
Public method | Scorer | (Overrides Weight..::..Scorer(IndexReader, Boolean, Boolean).)
Public method ScoresDocsOutOfOrder
Returns true iff this implementation scores docs only out of order. This method is used in conjunction with {@link Collector}'s {@link Collector#AcceptsDocsOutOfOrder() acceptsDocsOutOfOrder} and {@link #Scorer(Lucene.Net.Index.IndexReader, boolean, boolean)} to create a matching {@link Scorer} instance for a given {@link Collector}, or vice versa.

NOTE: the default implementation returns

CopyC#
false
, i.e. the
CopyC#
Scorer
 scores documents in-order.
(Inherited from Weight.)
Public method | SumOfSquaredWeights | (Overrides Weight..::..SumOfSquaredWeights()()()().)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


Explain Method

[image]

Lucene.Net Class Libraries
SpanWeight..::..Explain Method
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Explanation Explain(
    IndexReader reader,
    int doc
)
Visual Basic
Public Overrides Function Explain ( _
    reader As IndexReader, _
    doc As Integer _
) As Explanation
Visual C++
public:
virtual Explanation^ Explain(
    IndexReader^ reader,
    int doc
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

doc
Type: System..::..Int32

[Missing <param name="doc"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Explain(Lucene.Net.Index.IndexReader,System.Int32)"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
SpanWeight..::..GetQuery Method
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.GetQuery"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Query GetQuery()
Visual Basic
Public Overrides Function GetQuery As Query
Visual C++
public:
virtual Query^ GetQuery() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.GetQuery"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


GetValue Method

[image]

Lucene.Net Class Libraries
SpanWeight..::..GetValue Method
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.GetValue"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float GetValue()
Visual Basic
Public Overrides Function GetValue As Single
Visual C++
public:
virtual float GetValue() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.GetValue"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
SpanWeight..::..Normalize Method
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Normalize(System.Single)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Normalize(
    float queryNorm
)
Visual Basic
Public Overrides Sub Normalize ( _
    queryNorm As Single _
)
Visual C++
public:
virtual void Normalize(
    float queryNorm
) override

Parameters

queryNorm
Type: System..::..Single

[Missing <param name="queryNorm"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Normalize(System.Single)"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


Scorer Method

[image]

Lucene.Net Class Libraries
SpanWeight..::..Scorer Method
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Scorer Scorer(
    IndexReader reader,
    bool scoreDocsInOrder,
    bool topScorer
)
Visual Basic
Public Overrides Function Scorer ( _
    reader As IndexReader, _
    scoreDocsInOrder As Boolean, _
    topScorer As Boolean _
) As Scorer
Visual C++
public:
virtual Scorer^ Scorer(
    IndexReader^ reader,
    bool scoreDocsInOrder,
    bool topScorer
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

scoreDocsInOrder
Type: System..::..Boolean

[Missing <param name="scoreDocsInOrder"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

topScorer
Type: System..::..Boolean

[Missing <param name="topScorer"/> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.Scorer(Lucene.Net.Index.IndexReader,System.Boolean,System.Boolean)"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


SumOfSquaredWeights Method

[image]

Lucene.Net Class Libraries
SpanWeight..::..SumOfSquaredWeights Method
SpanWeight Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.SumOfSquaredWeights"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override float SumOfSquaredWeights()
Visual Basic
Public Overrides Function SumOfSquaredWeights As Single
Visual C++
public:
virtual float SumOfSquaredWeights() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.SpanWeight.SumOfSquaredWeights"]

See Also

SpanWeight Class
Lucene.Net.Search.Spans Namespace


TermSpans Class

[image]

Lucene.Net Class Libraries
TermSpans Class
Members See Also Send Feedback
Expert: Public for extension only

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class TermSpans : Spans
Visual Basic
Public Class TermSpans _
    Inherits Spans
Visual C++
public ref class TermSpans : public Spans

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Spans..::..Spans
Lucene.Net.Search.Spans..::..TermSpans

See Also

TermSpans Members
Lucene.Net.Search.Spans Namespace


TermSpans Members

[image] [image]

Lucene.Net Class Libraries
TermSpans Members
TermSpans Class Constructors Methods Fields See Also Send Feedback

The TermSpans type exposes the following members.

Constructors

 | Name | Description
Public method | TermSpans | Initializes a new instance of the TermSpans class

Methods

 | Name | Description
Public method | Doc | (Overrides Spans..::..Doc()()()().)
Public method | End | (Overrides Spans..::..End()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | (Overrides Spans..::..GetPayload()()()().)
Public method | GetPositions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable | (Overrides Spans..::..IsPayloadAvailable()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides Spans..::..Next()()()().)
Public method | SkipTo | (Overrides Spans..::..SkipTo(Int32).)
Public method | Start | (Overrides Spans..::..Start()()()().)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | count |
Protected field | doc |
Protected field | freq |
Protected field | position |
Protected field | positions |
Protected field | term |

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


TermSpans Constructor

[image]

Lucene.Net Class Libraries
TermSpans Constructor
TermSpans Class See Also Send Feedback
Initializes a new instance of the TermSpans class

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public TermSpans(
    TermPositions positions,
    Term term
)
Visual Basic
Public Sub New ( _
    positions As TermPositions, _
    term As Term _
)
Visual C++
public:
TermSpans(
    TermPositions^ positions,
    Term^ term
)

Parameters

positions
Type: Lucene.Net.Index..::..TermPositions

[Missing <param name="positions"/> documentation for "M:Lucene.Net.Search.Spans.TermSpans.#ctor(Lucene.Net.Index.TermPositions,Lucene.Net.Index.Term)"]

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Spans.TermSpans.#ctor(Lucene.Net.Index.TermPositions,Lucene.Net.Index.Term)"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


TermSpans Fields

[image] [image]

Lucene.Net Class Libraries
TermSpans Fields
TermSpans Class See Also Send Feedback

The TermSpans type exposes the following members.

Fields

 | Name | Description
Protected field | count |
Protected field | doc |
Protected field | freq |
Protected field | position |
Protected field | positions |
Protected field | term |

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


count Field

[image]

Lucene.Net Class Libraries
TermSpans..::..count Field
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.TermSpans.count"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int count
Visual Basic
Protected Friend count As Integer
Visual C++
protected public:
int count

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


doc Field

[image]

Lucene.Net Class Libraries
TermSpans..::..doc Field
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.TermSpans.doc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int doc
Visual Basic
Protected Friend doc As Integer
Visual C++
protected public:
int doc

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


freq Field

[image]

Lucene.Net Class Libraries
TermSpans..::..freq Field
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.TermSpans.freq"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int freq
Visual Basic
Protected Friend freq As Integer
Visual C++
protected public:
int freq

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


position Field

[image]

Lucene.Net Class Libraries
TermSpans..::..position Field
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.TermSpans.position"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int position
Visual Basic
Protected Friend position As Integer
Visual C++
protected public:
int position

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


positions Field

[image]

Lucene.Net Class Libraries
TermSpans..::..positions Field
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.TermSpans.positions"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal TermPositions positions
Visual Basic
Protected Friend positions As TermPositions
Visual C++
protected public:
TermPositions^ positions

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


term Field

[image]

Lucene.Net Class Libraries
TermSpans..::..term Field
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Spans.TermSpans.term"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Term term
Visual Basic
Protected Friend term As Term
Visual C++
protected public:
Term^ term

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


TermSpans Methods

[image] [image]

Lucene.Net Class Libraries
TermSpans Methods
TermSpans Class See Also Send Feedback

The TermSpans type exposes the following members.

Methods

 | Name | Description
Public method | Doc | (Overrides Spans..::..Doc()()()().)
Public method | End | (Overrides Spans..::..End()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPayload | (Overrides Spans..::..GetPayload()()()().)
Public method | GetPositions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPayloadAvailable | (Overrides Spans..::..IsPayloadAvailable()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | (Overrides Spans..::..Next()()()().)
Public method | SkipTo | (Overrides Spans..::..SkipTo(Int32).)
Public method | Start | (Overrides Spans..::..Start()()()().)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


Doc Method

[image]

Lucene.Net Class Libraries
TermSpans..::..Doc Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.Doc"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Doc()
Visual Basic
Public Overrides Function Doc As Integer
Visual C++
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.Doc"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


End Method

[image]

Lucene.Net Class Libraries
TermSpans..::..End Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.End"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int End()
Visual Basic
Public Overrides Function End As Integer
Visual C++
public:
virtual int End() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.End"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


GetPayload Method

[image]

Lucene.Net Class Libraries
TermSpans..::..GetPayload Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.GetPayload"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override ICollection<byte[]> GetPayload()
Visual Basic
Public Overrides Function GetPayload As ICollection(Of Byte())
Visual C++
public:
virtual ICollection<array<unsigned char>^>^ GetPayload() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.GetPayload"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


GetPositions Method

[image]

Lucene.Net Class Libraries
TermSpans..::..GetPositions Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.GetPositions"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual TermPositions GetPositions()
Visual Basic
Public Overridable Function GetPositions As TermPositions
Visual C++
public:
virtual TermPositions^ GetPositions()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.GetPositions"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


IsPayloadAvailable Method

[image]

Lucene.Net Class Libraries
TermSpans..::..IsPayloadAvailable Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.IsPayloadAvailable"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsPayloadAvailable()
Visual Basic
Public Overrides Function IsPayloadAvailable As Boolean
Visual C++
public:
virtual bool IsPayloadAvailable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.IsPayloadAvailable"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


Next Method

[image]

Lucene.Net Class Libraries
TermSpans..::..Next Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.Next"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Next()
Visual Basic
Public Overrides Function Next As Boolean
Visual C++
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.Next"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
TermSpans..::..SkipTo Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool SkipTo(
    int target
)
Visual Basic
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Search.Spans.TermSpans.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.SkipTo(System.Int32)"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


Start Method

[image]

Lucene.Net Class Libraries
TermSpans..::..Start Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.Start"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Start()
Visual Basic
Public Overrides Function Start As Integer
Visual C++
public:
virtual int Start() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.Start"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


ToString Method

[image]

Lucene.Net Class Libraries
TermSpans..::..ToString Method
TermSpans Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Spans.TermSpans.ToString"]

Namespace: Lucene.Net.Search.Spans
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Spans.TermSpans.ToString"]

See Also

TermSpans Class
Lucene.Net.Search.Spans Namespace


Lucene.Net.Search.Vectorhighlight Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Search.Vectorhighlight Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Search.Vectorhighlight"]

Classes

Class | Description
Public class | BaseFragmentsBuilder
Public class | FastVectorHighlighter
Public class FieldFragList
FieldFragList has a list of "frag info" that is used by FragmentsBuilder class to create fragments (snippets).
Public class | FieldFragList..::..WeightedFragInfo
Public class FieldPhraseList
FieldPhraseList has a list of WeightedPhraseInfo that is used by FragListBuilder to create a FieldFragList object.
Public class | FieldPhraseList..::..WeightedPhraseInfo
Public class | FieldPhraseList..::..WeightedPhraseInfo..::..Toffs
Public class | FieldQuery
Public class | FieldQuery..::..QueryPhraseMap
Public class FieldTermStack
CopyC#
FieldTermStack
 is a stack that keeps query terms in the specified field of the document to be highlighted.
Public class | FieldTermStack..::..TermInfo
Public class | HashMap<(Of <(<'K, V>)>)>
Public class | ScoreOrderFragmentsBuilder
Public class | ScoreOrderFragmentsBuilder..::..ScoreComparator
Public class SimpleFragListBuilder
A simple implementation of FragListBuilder.
Public class SimpleFragmentsBuilder
A simple implementation of FragmentsBuilder.
Public class | VectorHighlightMapper

Interfaces

 | Interface | Description
Public interface | FragListBuilder | FragListBuilder is an interface for FieldFragList builder classes. A FragListBuilder class can be plugged in to Highlighter.
Public interface | FragmentsBuilder | FragmentsBuilder is an interface for fragments (snippets) builder classes. A FragmentsBuilder class can be plugged in to Highlighter.


BaseFragmentsBuilder Class

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract class BaseFragmentsBuilder : FragmentsBuilder
Visual Basic
Public MustInherit Class BaseFragmentsBuilder _
    Implements FragmentsBuilder
Visual C++
public ref class BaseFragmentsBuilder abstract : FragmentsBuilder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..BaseFragmentsBuilder
Lucene.Net.Search.Vectorhighlight..::..ScoreOrderFragmentsBuilder
Lucene.Net.Search.Vectorhighlight..::..SimpleFragmentsBuilder

See Also

BaseFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


BaseFragmentsBuilder Members

[image] [image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Members
BaseFragmentsBuilder Class Constructors Methods Fields See Also Send Feedback

The BaseFragmentsBuilder type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseFragmentsBuilder()()()() | Initializes a new instance of the BaseFragmentsBuilder class
Protected method | BaseFragmentsBuilder(array<String>[]()[][], array<String>[]()[][]) | Initializes a new instance of the BaseFragmentsBuilder class

Methods

 | Name | Description
Public method | CreateFragment |
Public method | CreateFragments |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFields |
Protected method | GetFieldValues | Obsolete.
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) |
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPostTag |
Protected method | GetPreTag |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeightedFragInfoList |
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) |
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | COLORED_POST_TAGS |
 | COLORED_PRE_TAGS |
Protected field | postTags |
Protected field | preTags |

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


BaseFragmentsBuilder Constructor

[image] [image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Constructor
BaseFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | BaseFragmentsBuilder()()()() | Initializes a new instance of the BaseFragmentsBuilder class
Protected method | BaseFragmentsBuilder(array<String>[]()[][], array<String>[]()[][]) | Initializes a new instance of the BaseFragmentsBuilder class

See Also

BaseFragmentsBuilder Class
BaseFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


BaseFragmentsBuilder Constructor

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Constructor
BaseFragmentsBuilder Class See Also Send Feedback
Initializes a new instance of the BaseFragmentsBuilder class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected BaseFragmentsBuilder()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseFragmentsBuilder()

See Also

BaseFragmentsBuilder Class
BaseFragmentsBuilder Overload
Lucene.Net.Search.Vectorhighlight Namespace


BaseFragmentsBuilder Constructor (String[], String[])

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Constructor (array<String>[]()[][], array<String>[]()[][])
BaseFragmentsBuilder Class See Also Send Feedback
Initializes a new instance of the BaseFragmentsBuilder class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected BaseFragmentsBuilder(
    string[] preTags,
    string[] postTags
)
Visual Basic
Protected Sub New ( _
    preTags As String(), _
    postTags As String() _
)
Visual C++
protected:
BaseFragmentsBuilder(
    array<String^>^ preTags,
    array<String^>^ postTags
)

Parameters

preTags
Type: array< System..::..String >[]()[][]

[Missing <param name="preTags"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.#ctor(System.String[],System.String[])"]

postTags
Type: array< System..::..String >[]()[][]

[Missing <param name="postTags"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.#ctor(System.String[],System.String[])"]

See Also

BaseFragmentsBuilder Class
BaseFragmentsBuilder Overload
Lucene.Net.Search.Vectorhighlight Namespace


BaseFragmentsBuilder Fields

[image] [image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Fields
BaseFragmentsBuilder Class See Also Send Feedback

The BaseFragmentsBuilder type exposes the following members.

Fields

 | Name | Description
 | COLORED_POST_TAGS |
 | COLORED_PRE_TAGS |
Protected field | postTags |
Protected field | preTags |

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


COLORED_POST_TAGS Field

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..COLORED_POST_TAGS Field
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.COLORED_POST_TAGS"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static string[] COLORED_POST_TAGS
Visual Basic
Public Shared COLORED_POST_TAGS As String()
Visual C++
public:
static array<String^>^ COLORED_POST_TAGS

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


COLORED_PRE_TAGS Field

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..COLORED_PRE_TAGS Field
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.COLORED_PRE_TAGS"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static string[] COLORED_PRE_TAGS
Visual Basic
Public Shared COLORED_PRE_TAGS As String()
Visual C++
public:
static array<String^>^ COLORED_PRE_TAGS

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


postTags Field

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..postTags Field
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.postTags"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected string[] postTags
Visual Basic
Protected postTags As String()
Visual C++
protected:
array<String^>^ postTags

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


preTags Field

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..preTags Field
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.preTags"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected string[] preTags
Visual Basic
Protected preTags As String()
Visual C++
protected:
array<String^>^ preTags

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


BaseFragmentsBuilder Methods

[image] [image]

Lucene.Net Class Libraries
BaseFragmentsBuilder Methods
BaseFragmentsBuilder Class See Also Send Feedback

The BaseFragmentsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFragment |
Public method | CreateFragments |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFields |
Protected method | GetFieldValues | Obsolete.
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) |
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPostTag |
Protected method | GetPreTag |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeightedFragInfoList |
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) |
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


CreateFragment Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..CreateFragment Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragment(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public virtual string CreateFragment(
    IndexReader reader,
    int docId,
    string fieldName,
    FieldFragList fieldFragList
)
Visual Basic
Public Overridable Function CreateFragment ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fieldFragList As FieldFragList _
) As String
Visual C++
public:
virtual String^ CreateFragment(
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    FieldFragList^ fieldFragList
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragment(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragment(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList)"]

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragment(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList)"]

fieldFragList
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList

[Missing <param name="fieldFragList"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragment(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragment(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList)"]

Implements

FragmentsBuilder..::..CreateFragment(IndexReader, Int32, String, FieldFragList)

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


CreateFragments Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..CreateFragments Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public virtual string[] CreateFragments(
    IndexReader reader,
    int docId,
    string fieldName,
    FieldFragList fieldFragList,
    int maxNumFragments
)
Visual Basic
Public Overridable Function CreateFragments ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fieldFragList As FieldFragList, _
    maxNumFragments As Integer _
) As String()
Visual C++
public:
virtual array<String^>^ CreateFragments(
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    FieldFragList^ fieldFragList,
    int maxNumFragments
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

fieldFragList
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList

[Missing <param name="fieldFragList"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

maxNumFragments
Type: System..::..Int32

[Missing <param name="maxNumFragments"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.CreateFragments(Lucene.Net.Index.IndexReader,System.Int32,System.String,Lucene.Net.Search.Vectorhighlight.FieldFragList,System.Int32)"]

Implements

FragmentsBuilder..::..CreateFragments(IndexReader, Int32, String, FieldFragList, Int32)

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFields Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetFields Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFields(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected virtual Field[] GetFields(
    IndexReader reader,
    int docId,
    string fieldName
)
Visual Basic
Protected Overridable Function GetFields ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String _
) As Field()
Visual C++
protected:
virtual array<Field^>^ GetFields(
    IndexReader^ reader,
    int docId,
    String^ fieldName
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFields(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFields(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFields(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFields(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFieldValues Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetFieldValues Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFieldValues(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
[ObsoleteAttribute]
protected virtual string[] GetFieldValues(
    IndexReader reader,
    int docId,
    string fieldName
)
Visual Basic
<ObsoleteAttribute> _
Protected Overridable Function GetFieldValues ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String _
) As String()
Visual C++
[ObsoleteAttribute]
protected:
virtual array<String^>^ GetFieldValues(
    IndexReader^ reader,
    int docId,
    String^ fieldName
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFieldValues(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

docId
Type: System..::..Int32

[Missing <param name="docId"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFieldValues(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFieldValues(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFieldValues(Lucene.Net.Index.IndexReader,System.Int32,System.String)"]

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFragmentSource Method

[image] [image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetFragmentSource Method
BaseFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) |
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete.

See Also

BaseFragmentsBuilder Class
BaseFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


GetFragmentSource Method (StringBuilder, Int32[], Field[], Int32, Int32)

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetFragmentSource Method (StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32)
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected virtual string GetFragmentSource(
    StringBuilder buffer,
    int[] index,
    Field[] values,
    int startOffset,
    int endOffset
)
Visual Basic
Protected Overridable Function GetFragmentSource ( _
    buffer As StringBuilder, _
    index As Integer(), _
    values As Field(), _
    startOffset As Integer, _
    endOffset As Integer _
) As String
Visual C++
protected:
virtual String^ GetFragmentSource(
    StringBuilder^ buffer,
    array<int>^ index,
    array<Field^>^ values,
    int startOffset,
    int endOffset
)

Parameters

buffer
Type: System.Text..::..StringBuilder

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

index
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="index"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

values
Type: array< Lucene.Net.Documents..::..Field >[]()[][]

[Missing <param name="values"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],System.Int32,System.Int32)"]

See Also

BaseFragmentsBuilder Class
GetFragmentSource Overload
Lucene.Net.Search.Vectorhighlight Namespace


GetFragmentSource Method (StringBuilder, Int32[], String[], Int32, Int32)

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetFragmentSource Method (StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32)
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
[ObsoleteAttribute]
protected virtual string GetFragmentSource(
    StringBuilder buffer,
    int[] index,
    string[] values,
    int startOffset,
    int endOffset
)
Visual Basic
<ObsoleteAttribute> _
Protected Overridable Function GetFragmentSource ( _
    buffer As StringBuilder, _
    index As Integer(), _
    values As String(), _
    startOffset As Integer, _
    endOffset As Integer _
) As String
Visual C++
[ObsoleteAttribute]
protected:
virtual String^ GetFragmentSource(
    StringBuilder^ buffer,
    array<int>^ index,
    array<String^>^ values,
    int startOffset,
    int endOffset
)

Parameters

buffer
Type: System.Text..::..StringBuilder

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

index
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="index"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

values
Type: array< System..::..String >[]()[][]

[Missing <param name="values"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetFragmentSource(System.Text.StringBuilder,System.Int32[],System.String[],System.Int32,System.Int32)"]

See Also

BaseFragmentsBuilder Class
GetFragmentSource Overload
Lucene.Net.Search.Vectorhighlight Namespace


GetPostTag Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetPostTag Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetPostTag(System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected virtual string GetPostTag(
    int num
)
Visual Basic
Protected Overridable Function GetPostTag ( _
    num As Integer _
) As String
Visual C++
protected:
virtual String^ GetPostTag(
    int num
)

Parameters

num
Type: System..::..Int32

[Missing <param name="num"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetPostTag(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetPostTag(System.Int32)"]

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetPreTag Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetPreTag Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetPreTag(System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected virtual string GetPreTag(
    int num
)
Visual Basic
Protected Overridable Function GetPreTag ( _
    num As Integer _
) As String
Visual C++
protected:
virtual String^ GetPreTag(
    int num
)

Parameters

num
Type: System..::..Int32

[Missing <param name="num"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetPreTag(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetPreTag(System.Int32)"]

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetWeightedFragInfoList Method

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..GetWeightedFragInfoList Method
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract List<FieldFragList..::..WeightedFragInfo> GetWeightedFragInfoList(
    List<FieldFragList..::..WeightedFragInfo> src
)
Visual Basic
Public MustOverride Function GetWeightedFragInfoList ( _
    src As List(Of FieldFragList..::..WeightedFragInfo) _
) As List(Of FieldFragList..::..WeightedFragInfo)
Visual C++
public:
virtual List<FieldFragList..::..WeightedFragInfo^>^ GetWeightedFragInfoList(
    List<FieldFragList..::..WeightedFragInfo^>^ src
) abstract

Parameters

src
Type: System.Collections.Generic..::..List <(Of <(<' FieldFragList..::..WeightedFragInfo >)>)>

[Missing <param name="src"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

See Also

BaseFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


MakeFragment Method

[image] [image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..MakeFragment Method
BaseFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) |
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete.

See Also

BaseFragmentsBuilder Class
BaseFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


MakeFragment Method (StringBuilder, Int32[], Field[], FieldFragList.WeightedFragInfo)

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..MakeFragment Method (StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo)
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected virtual string MakeFragment(
    StringBuilder buffer,
    int[] index,
    Field[] values,
    FieldFragList..::..WeightedFragInfo fragInfo
)
Visual Basic
Protected Overridable Function MakeFragment ( _
    buffer As StringBuilder, _
    index As Integer(), _
    values As Field(), _
    fragInfo As FieldFragList..::..WeightedFragInfo _
) As String
Visual C++
protected:
virtual String^ MakeFragment(
    StringBuilder^ buffer,
    array<int>^ index,
    array<Field^>^ values,
    FieldFragList..::..WeightedFragInfo^ fragInfo
)

Parameters

buffer
Type: System.Text..::..StringBuilder

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

index
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="index"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

values
Type: array< Lucene.Net.Documents..::..Field >[]()[][]

[Missing <param name="values"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

fragInfo
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList..::..WeightedFragInfo

[Missing <param name="fragInfo"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],Lucene.Net.Documents.Field[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

See Also

BaseFragmentsBuilder Class
MakeFragment Overload
Lucene.Net.Search.Vectorhighlight Namespace


MakeFragment Method (StringBuilder, Int32[], String[], FieldFragList.WeightedFragInfo)

[image]

Lucene.Net Class Libraries
BaseFragmentsBuilder..::..MakeFragment Method (StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo)
BaseFragmentsBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],System.String[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
[ObsoleteAttribute]
protected virtual string MakeFragment(
    StringBuilder buffer,
    int[] index,
    string[] values,
    FieldFragList..::..WeightedFragInfo fragInfo
)
Visual Basic
<ObsoleteAttribute> _
Protected Overridable Function MakeFragment ( _
    buffer As StringBuilder, _
    index As Integer(), _
    values As String(), _
    fragInfo As FieldFragList..::..WeightedFragInfo _
) As String
Visual C++
[ObsoleteAttribute]
protected:
virtual String^ MakeFragment(
    StringBuilder^ buffer,
    array<int>^ index,
    array<String^>^ values,
    FieldFragList..::..WeightedFragInfo^ fragInfo
)

Parameters

buffer
Type: System.Text..::..StringBuilder

[Missing <param name="buffer"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],System.String[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

index
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="index"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],System.String[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

values
Type: array< System..::..String >[]()[][]

[Missing <param name="values"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],System.String[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

fragInfo
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList..::..WeightedFragInfo

[Missing <param name="fragInfo"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],System.String[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.BaseFragmentsBuilder.MakeFragment(System.Text.StringBuilder,System.Int32[],System.String[],Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

See Also

BaseFragmentsBuilder Class
MakeFragment Overload
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Class

[image]

Lucene.Net Class Libraries
FastVectorHighlighter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FastVectorHighlighter"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FastVectorHighlighter
Visual Basic
Public Class FastVectorHighlighter
Visual C++
public ref class FastVectorHighlighter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FastVectorHighlighter

See Also

FastVectorHighlighter Members
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Members

[image] [image]

Lucene.Net Class Libraries
FastVectorHighlighter Members
FastVectorHighlighter Class Constructors Methods Fields Properties See Also Send Feedback

The FastVectorHighlighter type exposes the following members.

Constructors

 | Name | Description
Public method | FastVectorHighlighter()()()() | the default constructor.
Public method | FastVectorHighlighter(Boolean, Boolean) | a constructor. Using SimpleFragListBuilder and ScoreOrderFragmentsBuilder.
Public method | FastVectorHighlighter(Boolean, Boolean, FragListBuilder, FragmentsBuilder) | a constructor. A FragListBuilder and a FragmentsBuilder can be specified (plugins).

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestFragment | return the best fragment.
Public method | GetBestFragments | return the best fragments.
Public method | GetFieldQuery | create a FieldQuery object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFieldMatch | return whether fieldMatch or not.
Public method | IsPhraseHighlight | return whether phraseHighlight or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DEFAULT_FIELD_MATCH |
DEFAULT_PHRASE_HIGHLIGHT |

Properties

 | Name | Description
Public property | PhraseLimit | The maximum number of phrases to analyze when searching for the highest-scoring phrase. The default is 5000. To ensure that all phrases are analyzed, use a negative number or Integer.MAX_VALUE.

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Constructor

[image] [image]

Lucene.Net Class Libraries
FastVectorHighlighter Constructor
FastVectorHighlighter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastVectorHighlighter()()()() | the default constructor.
Public method | FastVectorHighlighter(Boolean, Boolean) | a constructor. Using SimpleFragListBuilder and ScoreOrderFragmentsBuilder.
Public method | FastVectorHighlighter(Boolean, Boolean, FragListBuilder, FragmentsBuilder) | a constructor. A FragListBuilder and a FragmentsBuilder can be specified (plugins).

See Also

FastVectorHighlighter Class
FastVectorHighlighter Members
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Constructor

[image]

Lucene.Net Class Libraries
FastVectorHighlighter Constructor
FastVectorHighlighter Class See Also Send Feedback
the default constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FastVectorHighlighter()
Visual Basic
Public Sub New
Visual C++
public:
FastVectorHighlighter()

See Also

FastVectorHighlighter Class
FastVectorHighlighter Overload
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Constructor (Boolean, Boolean)

[image]

Lucene.Net Class Libraries
FastVectorHighlighter Constructor (Boolean, Boolean)
FastVectorHighlighter Class See Also Send Feedback
a constructor. Using SimpleFragListBuilder and ScoreOrderFragmentsBuilder.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FastVectorHighlighter(
    bool phraseHighlight,
    bool fieldMatch
)
Visual Basic
Public Sub New ( _
    phraseHighlight As Boolean, _
    fieldMatch As Boolean _
)
Visual C++
public:
FastVectorHighlighter(
    bool phraseHighlight,
    bool fieldMatch
)

Parameters

phraseHighlight
Type: System..::..Boolean
true or false for phrase highlighting
fieldMatch
Type: System..::..Boolean
true of false for field matching

See Also

FastVectorHighlighter Class
FastVectorHighlighter Overload
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Constructor (Boolean, Boolean, FragListBuilder, FragmentsBuilder)

[image]

Lucene.Net Class Libraries
FastVectorHighlighter Constructor (Boolean, Boolean, FragListBuilder, FragmentsBuilder)
FastVectorHighlighter Class See Also Send Feedback
a constructor. A FragListBuilder and a FragmentsBuilder can be specified (plugins).

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FastVectorHighlighter(
    bool phraseHighlight,
    bool fieldMatch,
    FragListBuilder fragListBuilder,
    FragmentsBuilder fragmentsBuilder
)
Visual Basic
Public Sub New ( _
    phraseHighlight As Boolean, _
    fieldMatch As Boolean, _
    fragListBuilder As FragListBuilder, _
    fragmentsBuilder As FragmentsBuilder _
)
Visual C++
public:
FastVectorHighlighter(
    bool phraseHighlight,
    bool fieldMatch,
    FragListBuilder^ fragListBuilder,
    FragmentsBuilder^ fragmentsBuilder
)

Parameters

phraseHighlight
Type: System..::..Boolean
true of false for phrase highlighting
fieldMatch
Type: System..::..Boolean
true of false for field matching
fragListBuilder
Type: Lucene.Net.Search.Vectorhighlight..::..FragListBuilder
an instance of FragListBuilder
fragmentsBuilder
Type: Lucene.Net.Search.Vectorhighlight..::..FragmentsBuilder
an instance of FragmentsBuilder

See Also

FastVectorHighlighter Class
FastVectorHighlighter Overload
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Fields

[image] [image]

Lucene.Net Class Libraries
FastVectorHighlighter Fields
FastVectorHighlighter Class See Also Send Feedback

The FastVectorHighlighter type exposes the following members.

Fields

Name | Description
DEFAULT_FIELD_MATCH |
DEFAULT_PHRASE_HIGHLIGHT |

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


DEFAULT_FIELD_MATCH Field

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..DEFAULT_FIELD_MATCH Field
FastVectorHighlighter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FastVectorHighlighter.DEFAULT_FIELD_MATCH"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static bool DEFAULT_FIELD_MATCH
Visual Basic
Public Shared DEFAULT_FIELD_MATCH As Boolean
Visual C++
public:
static bool DEFAULT_FIELD_MATCH

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


DEFAULT_PHRASE_HIGHLIGHT Field

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..DEFAULT_PHRASE_HIGHLIGHT Field
FastVectorHighlighter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FastVectorHighlighter.DEFAULT_PHRASE_HIGHLIGHT"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static bool DEFAULT_PHRASE_HIGHLIGHT
Visual Basic
Public Shared DEFAULT_PHRASE_HIGHLIGHT As Boolean
Visual C++
public:
static bool DEFAULT_PHRASE_HIGHLIGHT

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Methods

[image] [image]

Lucene.Net Class Libraries
FastVectorHighlighter Methods
FastVectorHighlighter Class See Also Send Feedback

The FastVectorHighlighter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestFragment | return the best fragment.
Public method | GetBestFragments | return the best fragments.
Public method | GetFieldQuery | create a FieldQuery object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFieldMatch | return whether fieldMatch or not.
Public method | IsPhraseHighlight | return whether phraseHighlight or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


GetBestFragment Method

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..GetBestFragment Method
FastVectorHighlighter Class See Also Send Feedback
return the best fragment.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetBestFragment(
    FieldQuery fieldQuery,
    IndexReader reader,
    int docId,
    string fieldName,
    int fragCharSize
)
Visual Basic
Public Function GetBestFragment ( _
    fieldQuery As FieldQuery, _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fragCharSize As Integer _
) As String
Visual C++
public:
String^ GetBestFragment(
    FieldQuery^ fieldQuery,
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    int fragCharSize
)

Parameters

fieldQuery
Type: Lucene.Net.Search.Vectorhighlight..::..FieldQuery
FieldQuery object
reader
Type: Lucene.Net.Index..::..IndexReader
IndexReader of the index
docId
Type: System..::..Int32
document id to be highlighted
fieldName
Type: System..::..String
field of the document to be highlighted
fragCharSize
Type: System..::..Int32
the length (number of chars) of a fragment

Return Value

the best fragment (snippet) string

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


GetBestFragments Method

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..GetBestFragments Method
FastVectorHighlighter Class See Also Send Feedback
return the best fragments.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] GetBestFragments(
    FieldQuery fieldQuery,
    IndexReader reader,
    int docId,
    string fieldName,
    int fragCharSize,
    int maxNumFragments
)
Visual Basic
Public Function GetBestFragments ( _
    fieldQuery As FieldQuery, _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fragCharSize As Integer, _
    maxNumFragments As Integer _
) As String()
Visual C++
public:
array<String^>^ GetBestFragments(
    FieldQuery^ fieldQuery,
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    int fragCharSize,
    int maxNumFragments
)

Parameters

fieldQuery
Type: Lucene.Net.Search.Vectorhighlight..::..FieldQuery
FieldQuery object
reader
Type: Lucene.Net.Index..::..IndexReader
IndexReader of the index
docId
Type: System..::..Int32
document id to be highlighted
fieldName
Type: System..::..String
field of the document to be highlighted
fragCharSize
Type: System..::..Int32
the length (number of chars) of a fragment
maxNumFragments
Type: System..::..Int32
maximum number of fragments

Return Value

created fragments or null when no fragments created. Size of the array can be less than maxNumFragments

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFieldQuery Method

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..GetFieldQuery Method
FastVectorHighlighter Class See Also Send Feedback
create a FieldQuery object.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery GetFieldQuery(
    Query query
)
Visual Basic
Public Function GetFieldQuery ( _
    query As Query _
) As FieldQuery
Visual C++
public:
FieldQuery^ GetFieldQuery(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query
a query

Return Value

the created FieldQuery object

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


IsFieldMatch Method

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..IsFieldMatch Method
FastVectorHighlighter Class See Also Send Feedback
return whether fieldMatch or not.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsFieldMatch()
Visual Basic
Public Function IsFieldMatch As Boolean
Visual C++
public:
bool IsFieldMatch()

Return Value

return whether fieldMatch or not.

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


IsPhraseHighlight Method

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..IsPhraseHighlight Method
FastVectorHighlighter Class See Also Send Feedback
return whether phraseHighlight or not.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsPhraseHighlight()
Visual Basic
Public Function IsPhraseHighlight As Boolean
Visual C++
public:
bool IsPhraseHighlight()

Return Value

return whether phraseHighlight or not.

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


FastVectorHighlighter Properties

[image] [image]

Lucene.Net Class Libraries
FastVectorHighlighter Properties
FastVectorHighlighter Class See Also Send Feedback

The FastVectorHighlighter type exposes the following members.

Properties

 | Name | Description
Public property | PhraseLimit | The maximum number of phrases to analyze when searching for the highest-scoring phrase. The default is 5000. To ensure that all phrases are analyzed, use a negative number or Integer.MAX_VALUE.

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


PhraseLimit Property

[image]

Lucene.Net Class Libraries
FastVectorHighlighter..::..PhraseLimit Property
FastVectorHighlighter Class See Also Send Feedback
The maximum number of phrases to analyze when searching for the highest-scoring phrase. The default is 5000. To ensure that all phrases are analyzed, use a negative number or Integer.MAX_VALUE.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int PhraseLimit { get; set; }
Visual Basic
Public Property PhraseLimit As Integer
    Get
    Set
Visual C++
public:
property int PhraseLimit {
    int get ();
    void set (int value);
}

See Also

FastVectorHighlighter Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList Class

[image]

Lucene.Net Class Libraries
FieldFragList Class
Members See Also Send Feedback
FieldFragList has a list of "frag info" that is used by FragmentsBuilder class to create fragments (snippets).

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FieldFragList
Visual Basic
Public Class FieldFragList
Visual C++
public ref class FieldFragList

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldFragList

See Also

FieldFragList Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList Members

[image] [image]

Lucene.Net Class Libraries
FieldFragList Members
FieldFragList Class Constructors Methods Fields See Also Send Feedback

The FieldFragList type exposes the following members.

Constructors

 | Name | Description
Public method | FieldFragList | a constructor.

Methods

 | Name | Description
Public method | Add | convert the list of WeightedPhraseInfo to WeightedFragInfo, then add it to the fragInfos
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | fragInfos |

See Also

FieldFragList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList Constructor

[image]

Lucene.Net Class Libraries
FieldFragList Constructor
FieldFragList Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldFragList(
    int fragCharSize
)
Visual Basic
Public Sub New ( _
    fragCharSize As Integer _
)
Visual C++
public:
FieldFragList(
    int fragCharSize
)

Parameters

fragCharSize
Type: System..::..Int32
the length (number of chars) of a fragment

See Also

FieldFragList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList Fields

[image] [image]

Lucene.Net Class Libraries
FieldFragList Fields
FieldFragList Class See Also Send Feedback

The FieldFragList type exposes the following members.

Fields

 | Name | Description
Public field | fragInfos |

See Also

FieldFragList Class
Lucene.Net.Search.Vectorhighlight Namespace


fragInfos Field

[image]

Lucene.Net Class Libraries
FieldFragList..::..fragInfos Field
FieldFragList Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldFragList.fragInfos"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public List<FieldFragList..::..WeightedFragInfo> fragInfos
Visual Basic
Public fragInfos As List(Of FieldFragList..::..WeightedFragInfo)
Visual C++
public:
List<FieldFragList..::..WeightedFragInfo^>^ fragInfos

See Also

FieldFragList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList Methods

[image] [image]

Lucene.Net Class Libraries
FieldFragList Methods
FieldFragList Class See Also Send Feedback

The FieldFragList type exposes the following members.

Methods

 | Name | Description
Public method | Add | convert the list of WeightedPhraseInfo to WeightedFragInfo, then add it to the fragInfos
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldFragList Class
Lucene.Net.Search.Vectorhighlight Namespace


Add Method

[image]

Lucene.Net Class Libraries
FieldFragList..::..Add Method
FieldFragList Class See Also Send Feedback
convert the list of WeightedPhraseInfo to WeightedFragInfo, then add it to the fragInfos

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Add(
    int startOffset,
    int endOffset,
    List<FieldPhraseList..::..WeightedPhraseInfo> phraseInfoList
)
Visual Basic
Public Sub Add ( _
    startOffset As Integer, _
    endOffset As Integer, _
    phraseInfoList As List(Of FieldPhraseList..::..WeightedPhraseInfo) _
)
Visual C++
public:
void Add(
    int startOffset,
    int endOffset,
    List<FieldPhraseList..::..WeightedPhraseInfo^>^ phraseInfoList
)

Parameters

startOffset
Type: System..::..Int32
start offset of the fragment
endOffset
Type: System..::..Int32
end offset of the fragment
phraseInfoList
Type: System.Collections.Generic..::..List <(Of <(<' FieldPhraseList..::..WeightedPhraseInfo >)>)>
list of WeightedPhraseInfo objects

See Also

FieldFragList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList.WeightedFragInfo Class

[image]

Lucene.Net Class Libraries
FieldFragList..::..WeightedFragInfo Class
FieldFragList Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class WeightedFragInfo
Visual Basic
Public Class WeightedFragInfo
Visual C++
public ref class WeightedFragInfo

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldFragList..::..WeightedFragInfo

See Also

FieldFragList..::..WeightedFragInfo Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList.WeightedFragInfo Members

[image] [image]

Lucene.Net Class Libraries
FieldFragList..::..WeightedFragInfo Members
FieldFragList..::..WeightedFragInfo Class Constructors Methods See Also Send Feedback

FieldFragList has a list of "frag info" that is used by FragmentsBuilder class to create fragments (snippets).

The FieldFragList..::..WeightedFragInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FieldFragList..::..WeightedFragInfo | Initializes a new instance of the FieldFragList..::..WeightedFragInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldFragList..::..WeightedFragInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList.WeightedFragInfo Constructor

[image]

Lucene.Net Class Libraries
FieldFragList..::..WeightedFragInfo Constructor
FieldFragList..::..WeightedFragInfo Class See Also Send Feedback
Initializes a new instance of the FieldFragList..::..WeightedFragInfo class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public WeightedFragInfo(
    int startOffset,
    int endOffset,
    List<FieldPhraseList..::..WeightedPhraseInfo> phraseInfoList
)
Visual Basic
Public Sub New ( _
    startOffset As Integer, _
    endOffset As Integer, _
    phraseInfoList As List(Of FieldPhraseList..::..WeightedPhraseInfo) _
)
Visual C++
public:
WeightedFragInfo(
    int startOffset,
    int endOffset,
    List<FieldPhraseList..::..WeightedPhraseInfo^>^ phraseInfoList
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo.#ctor(System.Int32,System.Int32,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo})"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo.#ctor(System.Int32,System.Int32,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo})"]

phraseInfoList
Type: System.Collections.Generic..::..List <(Of <(<' FieldPhraseList..::..WeightedPhraseInfo >)>)>

[Missing <param name="phraseInfoList"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo.#ctor(System.Int32,System.Int32,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo})"]

See Also

FieldFragList..::..WeightedFragInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldFragList.WeightedFragInfo Methods

[image] [image]

Lucene.Net Class Libraries
FieldFragList..::..WeightedFragInfo Methods
FieldFragList..::..WeightedFragInfo Class See Also Send Feedback

The FieldFragList..::..WeightedFragInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldFragList..::..WeightedFragInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldFragList..::..WeightedFragInfo..::..ToString Method
FieldFragList..::..WeightedFragInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo.ToString"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo.ToString"]

See Also

FieldFragList..::..WeightedFragInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Class

[image]

Lucene.Net Class Libraries
FieldPhraseList Class
Members See Also Send Feedback
FieldPhraseList has a list of WeightedPhraseInfo that is used by FragListBuilder to create a FieldFragList object.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FieldPhraseList
Visual Basic
Public Class FieldPhraseList
Visual C++
public ref class FieldPhraseList

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldPhraseList

See Also

FieldPhraseList Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Members

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList Members
FieldPhraseList Class Constructors Methods Fields See Also Send Feedback

The FieldPhraseList type exposes the following members.

Constructors

 | Name | Description
Public method | FieldPhraseList(FieldTermStack, FieldQuery) | create a FieldPhraseList that has no limit on the number of phrases to analyze FieldTermStack objectFieldQuery object
Public method | FieldPhraseList(FieldTermStack, FieldQuery, Int32) | a constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | phraseList |

See Also

FieldPhraseList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Constructor

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList Constructor
FieldPhraseList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldPhraseList(FieldTermStack, FieldQuery) | create a FieldPhraseList that has no limit on the number of phrases to analyze FieldTermStack objectFieldQuery object
Public method | FieldPhraseList(FieldTermStack, FieldQuery, Int32) | a constructor.

See Also

FieldPhraseList Class
FieldPhraseList Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Constructor (FieldTermStack, FieldQuery)

[image]

Lucene.Net Class Libraries
FieldPhraseList Constructor (FieldTermStack, FieldQuery)
FieldPhraseList Class See Also Send Feedback
create a FieldPhraseList that has no limit on the number of phrases to analyze FieldTermStack objectFieldQuery object

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldPhraseList(
    FieldTermStack fieldTermStack,
    FieldQuery fieldQuery
)
Visual Basic
Public Sub New ( _
    fieldTermStack As FieldTermStack, _
    fieldQuery As FieldQuery _
)
Visual C++
public:
FieldPhraseList(
    FieldTermStack^ fieldTermStack,
    FieldQuery^ fieldQuery
)

Parameters

fieldTermStack
Type: Lucene.Net.Search.Vectorhighlight..::..FieldTermStack

[Missing <param name="fieldTermStack"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.#ctor(Lucene.Net.Search.Vectorhighlight.FieldTermStack,Lucene.Net.Search.Vectorhighlight.FieldQuery)"]

fieldQuery
Type: Lucene.Net.Search.Vectorhighlight..::..FieldQuery

[Missing <param name="fieldQuery"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.#ctor(Lucene.Net.Search.Vectorhighlight.FieldTermStack,Lucene.Net.Search.Vectorhighlight.FieldQuery)"]

See Also

FieldPhraseList Class
FieldPhraseList Overload
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Constructor (FieldTermStack, FieldQuery, Int32)

[image]

Lucene.Net Class Libraries
FieldPhraseList Constructor (FieldTermStack, FieldQuery, Int32)
FieldPhraseList Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldPhraseList(
    FieldTermStack fieldTermStack,
    FieldQuery fieldQuery,
    int phraseLimit
)
Visual Basic
Public Sub New ( _
    fieldTermStack As FieldTermStack, _
    fieldQuery As FieldQuery, _
    phraseLimit As Integer _
)
Visual C++
public:
FieldPhraseList(
    FieldTermStack^ fieldTermStack,
    FieldQuery^ fieldQuery,
    int phraseLimit
)

Parameters

fieldTermStack
Type: Lucene.Net.Search.Vectorhighlight..::..FieldTermStack
FieldTermStack object
fieldQuery
Type: Lucene.Net.Search.Vectorhighlight..::..FieldQuery
FieldQuery object
phraseLimit
Type: System..::..Int32
maximum size of phraseList

See Also

FieldPhraseList Class
FieldPhraseList Overload
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Fields

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList Fields
FieldPhraseList Class See Also Send Feedback

The FieldPhraseList type exposes the following members.

Fields

 | Name | Description
Public field | phraseList |

See Also

FieldPhraseList Class
Lucene.Net.Search.Vectorhighlight Namespace


phraseList Field

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..phraseList Field
FieldPhraseList Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.phraseList"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public LinkedList<FieldPhraseList..::..WeightedPhraseInfo> phraseList
Visual Basic
Public phraseList As LinkedList(Of FieldPhraseList..::..WeightedPhraseInfo)
Visual C++
public:
LinkedList<FieldPhraseList..::..WeightedPhraseInfo^>^ phraseList

See Also

FieldPhraseList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList Methods

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList Methods
FieldPhraseList Class See Also Send Feedback

The FieldPhraseList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldPhraseList Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo Class

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo Class
FieldPhraseList Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class WeightedPhraseInfo
Visual Basic
Public Class WeightedPhraseInfo
Visual C++
public ref class WeightedPhraseInfo

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldPhraseList..::..WeightedPhraseInfo

See Also

FieldPhraseList..::..WeightedPhraseInfo Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo Members

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo Members
FieldPhraseList..::..WeightedPhraseInfo Class Constructors Methods See Also Send Feedback

FieldPhraseList has a list of WeightedPhraseInfo that is used by FragListBuilder to create a FieldFragList object.

The FieldPhraseList..::..WeightedPhraseInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FieldPhraseList..::..WeightedPhraseInfo(LinkedList<(Of <<'(FieldTermStack..::..TermInfo>)>>), Single) | Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo class
Public method | FieldPhraseList..::..WeightedPhraseInfo(LinkedList<(Of <<'(FieldTermStack..::..TermInfo>)>>), Single, Int32) | Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStartOffset |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOffsetOverlap |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo Constructor

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo Constructor
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldPhraseList..::..WeightedPhraseInfo(LinkedList<(Of <<'(FieldTermStack..::..TermInfo>)>>), Single) | Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo class
Public method | FieldPhraseList..::..WeightedPhraseInfo(LinkedList<(Of <<'(FieldTermStack..::..TermInfo>)>>), Single, Int32) | Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo class

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
FieldPhraseList..::..WeightedPhraseInfo Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo Constructor (LinkedList(FieldTermStack.TermInfo), Single)

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo Constructor (LinkedList<(Of <(<'FieldTermStack..::..TermInfo>)>)>, Single)
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback
Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public WeightedPhraseInfo(
    LinkedList<FieldTermStack..::..TermInfo> terms,
    float boost
)
Visual Basic
Public Sub New ( _
    terms As LinkedList(Of FieldTermStack..::..TermInfo), _
    boost As Single _
)
Visual C++
public:
WeightedPhraseInfo(
    LinkedList<FieldTermStack..::..TermInfo^>^ terms,
    float boost
)

Parameters

terms
Type: System.Collections.Generic..::..LinkedList <(Of <(<' FieldTermStack..::..TermInfo >)>)>

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.#ctor(System.Collections.Generic.LinkedList{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo},System.Single)"]

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.#ctor(System.Collections.Generic.LinkedList{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo},System.Single)"]

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
FieldPhraseList..::..WeightedPhraseInfo Overload
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo Constructor (LinkedList(FieldTermStack.TermInfo), Single, Int32)

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo Constructor (LinkedList<(Of <(<'FieldTermStack..::..TermInfo>)>)>, Single, Int32)
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback
Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public WeightedPhraseInfo(
    LinkedList<FieldTermStack..::..TermInfo> terms,
    float boost,
    int number
)
Visual Basic
Public Sub New ( _
    terms As LinkedList(Of FieldTermStack..::..TermInfo), _
    boost As Single, _
    number As Integer _
)
Visual C++
public:
WeightedPhraseInfo(
    LinkedList<FieldTermStack..::..TermInfo^>^ terms,
    float boost,
    int number
)

Parameters

terms
Type: System.Collections.Generic..::..LinkedList <(Of <(<' FieldTermStack..::..TermInfo >)>)>

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.#ctor(System.Collections.Generic.LinkedList{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo},System.Single,System.Int32)"]

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.#ctor(System.Collections.Generic.LinkedList{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo},System.Single,System.Int32)"]

number
Type: System..::..Int32

[Missing <param name="number"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.#ctor(System.Collections.Generic.LinkedList{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo},System.Single,System.Int32)"]

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
FieldPhraseList..::..WeightedPhraseInfo Overload
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo Methods

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo Methods
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback

The FieldPhraseList..::..WeightedPhraseInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStartOffset |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOffsetOverlap |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


GetEndOffset Method

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..GetEndOffset Method
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.GetEndOffset"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetEndOffset()
Visual Basic
Public Function GetEndOffset As Integer
Visual C++
public:
int GetEndOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.GetEndOffset"]

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


GetStartOffset Method

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..GetStartOffset Method
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.GetStartOffset"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetStartOffset()
Visual Basic
Public Function GetStartOffset As Integer
Visual C++
public:
int GetStartOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.GetStartOffset"]

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


IsOffsetOverlap Method

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..IsOffsetOverlap Method
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.IsOffsetOverlap(Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsOffsetOverlap(
    FieldPhraseList..::..WeightedPhraseInfo other
)
Visual Basic
Public Function IsOffsetOverlap ( _
    other As FieldPhraseList..::..WeightedPhraseInfo _
) As Boolean
Visual C++
public:
bool IsOffsetOverlap(
    FieldPhraseList..::..WeightedPhraseInfo^ other
)

Parameters

other
Type: Lucene.Net.Search.Vectorhighlight..::..FieldPhraseList..::..WeightedPhraseInfo

[Missing <param name="other"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.IsOffsetOverlap(Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.IsOffsetOverlap(Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo)"]

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..ToString Method
FieldPhraseList..::..WeightedPhraseInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.ToString"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.ToString"]

See Also

FieldPhraseList..::..WeightedPhraseInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo.Toffs Class

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class
FieldPhraseList..::..WeightedPhraseInfo Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.Toffs"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class Toffs
Visual Basic
Public Class Toffs
Visual C++
public ref class Toffs

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldPhraseList..::..WeightedPhraseInfo..::..Toffs

See Also

FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo.Toffs Members

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Members
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class Constructors Methods See Also Send Feedback

The FieldPhraseList..::..WeightedPhraseInfo..::..Toffs type exposes the following members.

Constructors

 | Name | Description
Public method | FieldPhraseList..::..WeightedPhraseInfo..::..Toffs | Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo..::..Toffs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo.Toffs Constructor

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Constructor
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class See Also Send Feedback
Initializes a new instance of the FieldPhraseList..::..WeightedPhraseInfo..::..Toffs class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Toffs(
    int startOffset,
    int endOffset
)
Visual Basic
Public Sub New ( _
    startOffset As Integer, _
    endOffset As Integer _
)
Visual C++
public:
Toffs(
    int startOffset,
    int endOffset
)

Parameters

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.Toffs.#ctor(System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.Toffs.#ctor(System.Int32,System.Int32)"]

See Also

FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldPhraseList.WeightedPhraseInfo.Toffs Methods

[image] [image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Methods
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class See Also Send Feedback

The FieldPhraseList..::..WeightedPhraseInfo..::..Toffs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class
Lucene.Net.Search.Vectorhighlight Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs..::..ToString Method
FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.Toffs.ToString"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldPhraseList.WeightedPhraseInfo.Toffs.ToString"]

See Also

FieldPhraseList..::..WeightedPhraseInfo..::..Toffs Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery Class

[image]

Lucene.Net Class Libraries
FieldQuery Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FieldQuery"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FieldQuery
Visual Basic
Public Class FieldQuery
Visual C++
public ref class FieldQuery

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldQuery

See Also

FieldQuery Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery Members

[image] [image]

Lucene.Net Class Libraries
FieldQuery Members
FieldQuery Class Constructors Methods Fields See Also Send Feedback

The FieldQuery type exposes the following members.

Constructors

 | Name | Description
Public method | FieldQuery | Initializes a new instance of the FieldQuery class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | expand |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | flatten |
Public method | GetFieldTermMap |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getRootMap |
Public method | getTermSet |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SearchPhrase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | rootMaps |
Public field | termSetMap |

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery Constructor

[image]

Lucene.Net Class Libraries
FieldQuery Constructor
FieldQuery Class See Also Send Feedback
Initializes a new instance of the FieldQuery class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery(
    Query query,
    bool phraseHighlight,
    bool fieldMatch
)
Visual Basic
Public Sub New ( _
    query As Query, _
    phraseHighlight As Boolean, _
    fieldMatch As Boolean _
)
Visual C++
public:
FieldQuery(
    Query^ query,
    bool phraseHighlight,
    bool fieldMatch
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.#ctor(Lucene.Net.Search.Query,System.Boolean,System.Boolean)"]

phraseHighlight
Type: System..::..Boolean

[Missing <param name="phraseHighlight"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.#ctor(Lucene.Net.Search.Query,System.Boolean,System.Boolean)"]

fieldMatch
Type: System..::..Boolean

[Missing <param name="fieldMatch"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.#ctor(Lucene.Net.Search.Query,System.Boolean,System.Boolean)"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery Fields

[image] [image]

Lucene.Net Class Libraries
FieldQuery Fields
FieldQuery Class See Also Send Feedback

The FieldQuery type exposes the following members.

Fields

 | Name | Description
Public field | rootMaps |
Public field | termSetMap |

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


rootMaps Field

[image]

Lucene.Net Class Libraries
FieldQuery..::..rootMaps Field
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldQuery.rootMaps"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public HashMap<string, FieldQuery..::..QueryPhraseMap> rootMaps
Visual Basic
Public rootMaps As HashMap(Of String, FieldQuery..::..QueryPhraseMap)
Visual C++
public:
HashMap<String^, FieldQuery..::..QueryPhraseMap^>^ rootMaps

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


termSetMap Field

[image]

Lucene.Net Class Libraries
FieldQuery..::..termSetMap Field
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldQuery.termSetMap"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public HashMap<string, List<string>> termSetMap
Visual Basic
Public termSetMap As HashMap(Of String, List(Of String))
Visual C++
public:
HashMap<String^, List<String^>^>^ termSetMap

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery Methods

[image] [image]

Lucene.Net Class Libraries
FieldQuery Methods
FieldQuery Class See Also Send Feedback

The FieldQuery type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | expand |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | flatten |
Public method | GetFieldTermMap |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getRootMap |
Public method | getTermSet |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SearchPhrase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


expand Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..expand Method
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.expand(System.Collections.Generic.Dictionary{Lucene.Net.Search.Query,Lucene.Net.Search.Query})"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public Dictionary<Query, Query> expand(
    Dictionary<Query, Query> flatQueries
)
Visual Basic
Public Function expand ( _
    flatQueries As Dictionary(Of Query, Query) _
) As Dictionary(Of Query, Query)
Visual C++
public:
Dictionary<Query^, Query^>^ expand(
    Dictionary<Query^, Query^>^ flatQueries
)

Parameters

flatQueries
Type: System.Collections.Generic..::..Dictionary <(Of <(<' Query, Query >)>)>

[Missing <param name="flatQueries"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.expand(System.Collections.Generic.Dictionary{Lucene.Net.Search.Query,Lucene.Net.Search.Query})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.expand(System.Collections.Generic.Dictionary{Lucene.Net.Search.Query,Lucene.Net.Search.Query})"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


flatten Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..flatten Method
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.flatten(Lucene.Net.Search.Query,System.Collections.Generic.Dictionary{Lucene.Net.Search.Query,Lucene.Net.Search.Query})"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void flatten(
    Query sourceQuery,
    Dictionary<Query, Query> flatQueries
)
Visual Basic
Public Sub flatten ( _
    sourceQuery As Query, _
    flatQueries As Dictionary(Of Query, Query) _
)
Visual C++
public:
void flatten(
    Query^ sourceQuery,
    Dictionary<Query^, Query^>^ flatQueries
)

Parameters

sourceQuery
Type: Lucene.Net.Search..::..Query

[Missing <param name="sourceQuery"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.flatten(Lucene.Net.Search.Query,System.Collections.Generic.Dictionary{Lucene.Net.Search.Query,Lucene.Net.Search.Query})"]

flatQueries
Type: System.Collections.Generic..::..Dictionary <(Of <(<' Query, Query >)>)>

[Missing <param name="flatQueries"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.flatten(Lucene.Net.Search.Query,System.Collections.Generic.Dictionary{Lucene.Net.Search.Query,Lucene.Net.Search.Query})"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFieldTermMap Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..GetFieldTermMap Method
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.GetFieldTermMap(System.String,System.String)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery..::..QueryPhraseMap GetFieldTermMap(
    string fieldName,
    string term
)
Visual Basic
Public Function GetFieldTermMap ( _
    fieldName As String, _
    term As String _
) As FieldQuery..::..QueryPhraseMap
Visual C++
public:
FieldQuery..::..QueryPhraseMap^ GetFieldTermMap(
    String^ fieldName,
    String^ term
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.GetFieldTermMap(System.String,System.String)"]

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.GetFieldTermMap(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.GetFieldTermMap(System.String,System.String)"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


getRootMap Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..getRootMap Method
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.getRootMap(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery..::..QueryPhraseMap getRootMap(
    Query query
)
Visual Basic
Public Function getRootMap ( _
    query As Query _
) As FieldQuery..::..QueryPhraseMap
Visual C++
public:
FieldQuery..::..QueryPhraseMap^ getRootMap(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.getRootMap(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.getRootMap(Lucene.Net.Search.Query)"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


getTermSet Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..getTermSet Method
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.getTermSet(System.String)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public List<string> getTermSet(
    string field
)
Visual Basic
Public Function getTermSet ( _
    field As String _
) As List(Of String)
Visual C++
public:
List<String^>^ getTermSet(
    String^ field
)

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.getTermSet(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.getTermSet(System.String)"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


SearchPhrase Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..SearchPhrase Method
FieldQuery Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.SearchPhrase(System.String,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery..::..QueryPhraseMap SearchPhrase(
    string fieldName,
    List<FieldTermStack..::..TermInfo> phraseCandidate
)
Visual Basic
Public Function SearchPhrase ( _
    fieldName As String, _
    phraseCandidate As List(Of FieldTermStack..::..TermInfo) _
) As FieldQuery..::..QueryPhraseMap
Visual C++
public:
FieldQuery..::..QueryPhraseMap^ SearchPhrase(
    String^ fieldName,
    List<FieldTermStack..::..TermInfo^>^ phraseCandidate
)

Parameters

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.SearchPhrase(System.String,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

phraseCandidate
Type: System.Collections.Generic..::..List <(Of <(<' FieldTermStack..::..TermInfo >)>)>

[Missing <param name="phraseCandidate"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.SearchPhrase(System.String,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.SearchPhrase(System.String,System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

See Also

FieldQuery Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery.QueryPhraseMap Class

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap Class
FieldQuery Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class QueryPhraseMap
Visual Basic
Public Class QueryPhraseMap
Visual C++
public ref class QueryPhraseMap

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldQuery..::..QueryPhraseMap

See Also

FieldQuery..::..QueryPhraseMap Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery.QueryPhraseMap Members

[image] [image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap Members
FieldQuery..::..QueryPhraseMap Class Constructors Methods Fields See Also Send Feedback

The FieldQuery..::..QueryPhraseMap type exposes the following members.

Constructors

 | Name | Description
Public method | FieldQuery..::..QueryPhraseMap | Initializes a new instance of the FieldQuery..::..QueryPhraseMap class

Methods

 | Name | Description
Public method | Add |
Public method | AddTerm |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoost |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSlop |
Public method | GetTermMap |
Public method | GetTermOrPhraseNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsTerminal |
Public method | IsValidTermOrPhrase |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SearchPhrase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | boost |
Public field | subMap |
Public field | terminal |

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery.QueryPhraseMap Constructor

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap Constructor
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback
Initializes a new instance of the FieldQuery..::..QueryPhraseMap class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public QueryPhraseMap(
    FieldQuery fieldQuery
)
Visual Basic
Public Sub New ( _
    fieldQuery As FieldQuery _
)
Visual C++
public:
QueryPhraseMap(
    FieldQuery^ fieldQuery
)

Parameters

fieldQuery
Type: Lucene.Net.Search.Vectorhighlight..::..FieldQuery

[Missing <param name="fieldQuery"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.#ctor(Lucene.Net.Search.Vectorhighlight.FieldQuery)"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery.QueryPhraseMap Fields

[image] [image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap Fields
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

The FieldQuery..::..QueryPhraseMap type exposes the following members.

Fields

 | Name | Description
Public field | boost |
Public field | subMap |
Public field | terminal |

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


boost Field

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..boost Field
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.boost"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public float boost
Visual Basic
Public boost As Single
Visual C++
public:
float boost

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


subMap Field

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..subMap Field
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.subMap"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public HashMap<string, FieldQuery..::..QueryPhraseMap> subMap
Visual Basic
Public subMap As HashMap(Of String, FieldQuery..::..QueryPhraseMap)
Visual C++
public:
HashMap<String^, FieldQuery..::..QueryPhraseMap^>^ subMap

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


terminal Field

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..terminal Field
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.terminal"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool terminal
Visual Basic
Public terminal As Boolean
Visual C++
public:
bool terminal

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldQuery.QueryPhraseMap Methods

[image] [image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap Methods
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

The FieldQuery..::..QueryPhraseMap type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | AddTerm |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoost |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSlop |
Public method | GetTermMap |
Public method | GetTermOrPhraseNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsTerminal |
Public method | IsValidTermOrPhrase |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SearchPhrase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


Add Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..Add Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.Add(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Add(
    Query query
)
Visual Basic
Public Sub Add ( _
    query As Query _
)
Visual C++
public:
void Add(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.Add(Lucene.Net.Search.Query)"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


AddTerm Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..AddTerm Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.AddTerm(Lucene.Net.Index.Term,System.Single)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void AddTerm(
    Term term,
    float boost
)
Visual Basic
Public Sub AddTerm ( _
    term As Term, _
    boost As Single _
)
Visual C++
public:
void AddTerm(
    Term^ term,
    float boost
)

Parameters

term
Type: Lucene.Net.Index..::..Term

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.AddTerm(Lucene.Net.Index.Term,System.Single)"]

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.AddTerm(Lucene.Net.Index.Term,System.Single)"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


GetBoost Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..GetBoost Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetBoost"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public float GetBoost()
Visual Basic
Public Function GetBoost As Single
Visual C++
public:
float GetBoost()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetBoost"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


GetSlop Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..GetSlop Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetSlop"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetSlop()
Visual Basic
Public Function GetSlop As Integer
Visual C++
public:
int GetSlop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetSlop"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


GetTermMap Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..GetTermMap Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetTermMap(System.String)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery..::..QueryPhraseMap GetTermMap(
    string term
)
Visual Basic
Public Function GetTermMap ( _
    term As String _
) As FieldQuery..::..QueryPhraseMap
Visual C++
public:
FieldQuery..::..QueryPhraseMap^ GetTermMap(
    String^ term
)

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetTermMap(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetTermMap(System.String)"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


GetTermOrPhraseNumber Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..GetTermOrPhraseNumber Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetTermOrPhraseNumber"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetTermOrPhraseNumber()
Visual Basic
Public Function GetTermOrPhraseNumber As Integer
Visual C++
public:
int GetTermOrPhraseNumber()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.GetTermOrPhraseNumber"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


IsTerminal Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..IsTerminal Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.IsTerminal"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsTerminal()
Visual Basic
Public Function IsTerminal As Boolean
Visual C++
public:
bool IsTerminal()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.IsTerminal"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


IsValidTermOrPhrase Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..IsValidTermOrPhrase Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.IsValidTermOrPhrase(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsValidTermOrPhrase(
    List<FieldTermStack..::..TermInfo> phraseCandidate
)
Visual Basic
Public Function IsValidTermOrPhrase ( _
    phraseCandidate As List(Of FieldTermStack..::..TermInfo) _
) As Boolean
Visual C++
public:
bool IsValidTermOrPhrase(
    List<FieldTermStack..::..TermInfo^>^ phraseCandidate
)

Parameters

phraseCandidate
Type: System.Collections.Generic..::..List <(Of <(<' FieldTermStack..::..TermInfo >)>)>

[Missing <param name="phraseCandidate"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.IsValidTermOrPhrase(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.IsValidTermOrPhrase(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


SearchPhrase Method

[image]

Lucene.Net Class Libraries
FieldQuery..::..QueryPhraseMap..::..SearchPhrase Method
FieldQuery..::..QueryPhraseMap Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.SearchPhrase(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldQuery..::..QueryPhraseMap SearchPhrase(
    List<FieldTermStack..::..TermInfo> phraseCandidate
)
Visual Basic
Public Function SearchPhrase ( _
    phraseCandidate As List(Of FieldTermStack..::..TermInfo) _
) As FieldQuery..::..QueryPhraseMap
Visual C++
public:
FieldQuery..::..QueryPhraseMap^ SearchPhrase(
    List<FieldTermStack..::..TermInfo^>^ phraseCandidate
)

Parameters

phraseCandidate
Type: System.Collections.Generic..::..List <(Of <(<' FieldTermStack..::..TermInfo >)>)>

[Missing <param name="phraseCandidate"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.SearchPhrase(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldQuery.QueryPhraseMap.SearchPhrase(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo})"]

See Also

FieldQuery..::..QueryPhraseMap Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack Class

[image]

Lucene.Net Class Libraries
FieldTermStack Class
Members See Also Send Feedback
CopyC#
FieldTermStack
 is a stack that keeps query terms in the specified field of the document to be highlighted.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class FieldTermStack
Visual Basic
Public Class FieldTermStack
Visual C++
public ref class FieldTermStack

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldTermStack

See Also

FieldTermStack Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack Members

[image] [image]

Lucene.Net Class Libraries
FieldTermStack Members
FieldTermStack Class Constructors Methods Fields See Also Send Feedback

The FieldTermStack type exposes the following members.

Constructors

 | Name | Description
Public method | FieldTermStack | a constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | to know whether the stack is empty
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop |
Public method | Push |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | termList |

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack Constructor

[image]

Lucene.Net Class Libraries
FieldTermStack Constructor
FieldTermStack Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldTermStack(
    IndexReader reader,
    int docId,
    string fieldName,
    FieldQuery fieldQuery
)
Visual Basic
Public Sub New ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fieldQuery As FieldQuery _
)
Visual C++
public:
FieldTermStack(
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    FieldQuery^ fieldQuery
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
IndexReader of the index
docId
Type: System..::..Int32
document id to be highlighted
fieldName
Type: System..::..String
field of the document to be highlighted
fieldQuery
Type: Lucene.Net.Search.Vectorhighlight..::..FieldQuery
FieldQuery object

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack Fields

[image] [image]

Lucene.Net Class Libraries
FieldTermStack Fields
FieldTermStack Class See Also Send Feedback

The FieldTermStack type exposes the following members.

Fields

 | Name | Description
Public field | termList |

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


termList Field

[image]

Lucene.Net Class Libraries
FieldTermStack..::..termList Field
FieldTermStack Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.FieldTermStack.termList"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public LinkedList<FieldTermStack..::..TermInfo> termList
Visual Basic
Public termList As LinkedList(Of FieldTermStack..::..TermInfo)
Visual C++
public:
LinkedList<FieldTermStack..::..TermInfo^>^ termList

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack Methods

[image] [image]

Lucene.Net Class Libraries
FieldTermStack Methods
FieldTermStack Class See Also Send Feedback

The FieldTermStack type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | to know whether the stack is empty
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop |
Public method | Push |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFieldName Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..GetFieldName Method
FieldTermStack Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.GetFieldName"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetFieldName()
Visual Basic
Public Function GetFieldName As String
Visual C++
public:
String^ GetFieldName()

Return Value

field name

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


IsEmpty Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..IsEmpty Method
FieldTermStack Class See Also Send Feedback
to know whether the stack is empty

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

true if the stack is empty, false if not

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


Main Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..Main Method
FieldTermStack Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.Main(System.String[])"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.Main(System.String[])"]

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


Pop Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..Pop Method
FieldTermStack Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.Pop"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldTermStack..::..TermInfo Pop()
Visual Basic
Public Function Pop As FieldTermStack..::..TermInfo
Visual C++
public:
FieldTermStack..::..TermInfo^ Pop()

Return Value

the top TermInfo object of the stack

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


Push Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..Push Method
FieldTermStack Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.Push(Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Push(
    FieldTermStack..::..TermInfo termInfo
)
Visual Basic
Public Sub Push ( _
    termInfo As FieldTermStack..::..TermInfo _
)
Visual C++
public:
void Push(
    FieldTermStack..::..TermInfo^ termInfo
)

Parameters

termInfo
Type: Lucene.Net.Search.Vectorhighlight..::..FieldTermStack..::..TermInfo
the TermInfo object to be put on the top of the stack

See Also

FieldTermStack Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack.TermInfo Class

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo Class
FieldTermStack Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class TermInfo : IComparable<FieldTermStack..::..TermInfo>
Visual Basic
Public Class TermInfo _
    Implements IComparable(Of FieldTermStack..::..TermInfo)
Visual C++
public ref class TermInfo : IComparable<FieldTermStack..::..TermInfo^>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..FieldTermStack..::..TermInfo

See Also

FieldTermStack..::..TermInfo Members
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack.TermInfo Members

[image] [image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo Members
FieldTermStack..::..TermInfo Class Constructors Methods See Also Send Feedback

CopyC#
FieldTermStack
 is a stack that keeps query terms in the specified field of the document to be highlighted.

The FieldTermStack..::..TermInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FieldTermStack..::..TermInfo | Initializes a new instance of the FieldTermStack..::..TermInfo class

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition |
Public method | GetStartOffset |
Public method | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack.TermInfo Constructor

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo Constructor
FieldTermStack..::..TermInfo Class See Also Send Feedback
Initializes a new instance of the FieldTermStack..::..TermInfo class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermInfo(
    string text,
    int startOffset,
    int endOffset,
    int position
)
Visual Basic
Public Sub New ( _
    text As String, _
    startOffset As Integer, _
    endOffset As Integer, _
    position As Integer _
)
Visual C++
public:
TermInfo(
    String^ text,
    int startOffset,
    int endOffset,
    int position
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

startOffset
Type: System..::..Int32

[Missing <param name="startOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

endOffset
Type: System..::..Int32

[Missing <param name="endOffset"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

position
Type: System..::..Int32

[Missing <param name="position"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.#ctor(System.String,System.Int32,System.Int32,System.Int32)"]

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FieldTermStack.TermInfo Methods

[image] [image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo Methods
FieldTermStack..::..TermInfo Class See Also Send Feedback

The FieldTermStack..::..TermInfo type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEndOffset |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition |
Public method | GetStartOffset |
Public method | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


CompareTo Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo..::..CompareTo Method
FieldTermStack..::..TermInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.CompareTo(Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int CompareTo(
    FieldTermStack..::..TermInfo o
)
Visual Basic
Public Function CompareTo ( _
    o As FieldTermStack..::..TermInfo _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FieldTermStack..::..TermInfo^ o
) sealed

Parameters

o
Type: Lucene.Net.Search.Vectorhighlight..::..FieldTermStack..::..TermInfo

[Missing <param name="o"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.CompareTo(Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.CompareTo(Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo)"]

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


GetEndOffset Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo..::..GetEndOffset Method
FieldTermStack..::..TermInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetEndOffset"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetEndOffset()
Visual Basic
Public Function GetEndOffset As Integer
Visual C++
public:
int GetEndOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetEndOffset"]

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


GetPosition Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo..::..GetPosition Method
FieldTermStack..::..TermInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetPosition"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetPosition()
Visual Basic
Public Function GetPosition As Integer
Visual C++
public:
int GetPosition()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetPosition"]

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


GetStartOffset Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo..::..GetStartOffset Method
FieldTermStack..::..TermInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetStartOffset"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int GetStartOffset()
Visual Basic
Public Function GetStartOffset As Integer
Visual C++
public:
int GetStartOffset()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetStartOffset"]

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


GetText Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo..::..GetText Method
FieldTermStack..::..TermInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetText"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetText()
Visual Basic
Public Function GetText As String
Visual C++
public:
String^ GetText()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.GetText"]

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldTermStack..::..TermInfo..::..ToString Method
FieldTermStack..::..TermInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.ToString"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.FieldTermStack.TermInfo.ToString"]

See Also

FieldTermStack..::..TermInfo Class
Lucene.Net.Search.Vectorhighlight Namespace


FragListBuilder Interface

[image]

Lucene.Net Class Libraries
FragListBuilder Interface
Members See Also Send Feedback
FragListBuilder is an interface for FieldFragList builder classes. A FragListBuilder class can be plugged in to Highlighter.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public interface FragListBuilder
Visual Basic
Public Interface FragListBuilder
Visual C++
public interface class FragListBuilder

See Also

FragListBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


FragListBuilder Members

[image] [image]

Lucene.Net Class Libraries
FragListBuilder Members
FragListBuilder Interface Methods See Also Send Feedback

The FragListBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFieldFragList | create a FieldFragList.

See Also

FragListBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


FragListBuilder Methods

[image] [image]

Lucene.Net Class Libraries
FragListBuilder Methods
FragListBuilder Interface See Also Send Feedback

The FragListBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFieldFragList | create a FieldFragList.

See Also

FragListBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


CreateFieldFragList Method

[image]

Lucene.Net Class Libraries
FragListBuilder..::..CreateFieldFragList Method
FragListBuilder Interface See Also Send Feedback
create a FieldFragList.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
FieldFragList CreateFieldFragList(
    FieldPhraseList fieldPhraseList,
    int fragCharSize
)
Visual Basic
Function CreateFieldFragList ( _
    fieldPhraseList As FieldPhraseList, _
    fragCharSize As Integer _
) As FieldFragList
Visual C++
FieldFragList^ CreateFieldFragList(
    FieldPhraseList^ fieldPhraseList,
    int fragCharSize
)

Parameters

fieldPhraseList
Type: Lucene.Net.Search.Vectorhighlight..::..FieldPhraseList
FieldPhraseList object
fragCharSize
Type: System..::..Int32
the length (number of chars) of a fragment

Return Value

the created FieldFragList object

See Also

FragListBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


FragmentsBuilder Interface

[image]

Lucene.Net Class Libraries
FragmentsBuilder Interface
Members See Also Send Feedback
FragmentsBuilder is an interface for fragments (snippets) builder classes. A FragmentsBuilder class can be plugged in to Highlighter.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public interface FragmentsBuilder
Visual Basic
Public Interface FragmentsBuilder
Visual C++
public interface class FragmentsBuilder

See Also

FragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


FragmentsBuilder Members

[image] [image]

Lucene.Net Class Libraries
FragmentsBuilder Members
FragmentsBuilder Interface Methods See Also Send Feedback

The FragmentsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFragment | create a fragment.
Public method | CreateFragments | create multiple fragments.

See Also

FragmentsBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


FragmentsBuilder Methods

[image] [image]

Lucene.Net Class Libraries
FragmentsBuilder Methods
FragmentsBuilder Interface See Also Send Feedback

The FragmentsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFragment | create a fragment.
Public method | CreateFragments | create multiple fragments.

See Also

FragmentsBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


CreateFragment Method

[image]

Lucene.Net Class Libraries
FragmentsBuilder..::..CreateFragment Method
FragmentsBuilder Interface See Also Send Feedback
create a fragment.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
string CreateFragment(
    IndexReader reader,
    int docId,
    string fieldName,
    FieldFragList fieldFragList
)
Visual Basic
Function CreateFragment ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fieldFragList As FieldFragList _
) As String
Visual C++
String^ CreateFragment(
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    FieldFragList^ fieldFragList
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
IndexReader of the index
docId
Type: System..::..Int32
document id to be highlighted
fieldName
Type: System..::..String
field of the document to be highlighted
fieldFragList
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList
FieldFragList object

Return Value

a created fragment or null when no fragment created

See Also

FragmentsBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


CreateFragments Method

[image]

Lucene.Net Class Libraries
FragmentsBuilder..::..CreateFragments Method
FragmentsBuilder Interface See Also Send Feedback
create multiple fragments.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
string[] CreateFragments(
    IndexReader reader,
    int docId,
    string fieldName,
    FieldFragList fieldFragList,
    int maxNumFragments
)
Visual Basic
Function CreateFragments ( _
    reader As IndexReader, _
    docId As Integer, _
    fieldName As String, _
    fieldFragList As FieldFragList, _
    maxNumFragments As Integer _
) As String()
Visual C++
array<String^>^ CreateFragments(
    IndexReader^ reader,
    int docId,
    String^ fieldName,
    FieldFragList^ fieldFragList,
    int maxNumFragments
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
IndexReader of the index
docId
Type: System..::..Int32
document id to be highlighted
fieldName
Type: System..::..String
field of the document to be highlighted
fieldFragList
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList
ieldFragList object
maxNumFragments
Type: System..::..Int32
maximum number of fragments

Return Value

created fragments or null when no fragments created. Size of the array can be less than maxNumFragments

See Also

FragmentsBuilder Interface
Lucene.Net.Search.Vectorhighlight Namespace


HashMap(K, V) Class

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)> Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.HashMap`2"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class HashMap<K, V> : Dictionary<K, V>
Visual Basic
Public Class HashMap(Of K, V) _
    Inherits Dictionary(Of K, V)
Visual C++
generic<typename K, typename V>
public ref class HashMap : public Dictionary<K, V>

Type Parameters

K

[Missing <typeparam name="K"/> documentation for "T:Lucene.Net.Search.Vectorhighlight.HashMap`2"]

V

[Missing <typeparam name="V"/> documentation for "T:Lucene.Net.Search.Vectorhighlight.HashMap`2"]

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<'K, V>)>)>
Lucene.Net.Search.Vectorhighlight..::..HashMap<(Of <(<'K, V>)>)>

See Also

HashMap<(Of <(<'K, V>)>)> Members
Lucene.Net.Search.Vectorhighlight Namespace


HashMap(K, V) Members

[image] [image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)> Members
HashMap<(Of <(<'K, V>)>)> Class Constructors Methods Properties See Also Send Feedback

The HashMap<(Of <(<'K, V>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | HashMap<(Of <(<'K, V>)>)> | Initializes a new instance of the HashMap<(Of <(<'K, V>)>)> class

Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | Put |
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public property | Count |
Public property | Item |
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


HashMap(K, V) Constructor

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)> Constructor
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback
Initializes a new instance of the HashMap<(Of <(<'K, V>)>)> class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public HashMap()
Visual Basic
Public Sub New
Visual C++
public:
HashMap()

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


HashMap(K, V) Methods

[image] [image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)> Methods
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

The HashMap<(Of <(<'K, V>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | Put |
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


Add Method

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)>..::..Add Method
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Add(`0,`1)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Add(
    K key,
    V value
)
Visual Basic
Public Sub Add ( _
    key As K, _
    value As V _
)
Visual C++
public:
void Add(
    K key,
    V value
)

Parameters

key
Type: K

[Missing <param name="key"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Add(`0,`1)"]

value
Type: V

[Missing <param name="value"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Add(`0,`1)"]

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


Get Method

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)>..::..Get Method
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Get(`0)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public V Get(
    K key
)
Visual Basic
Public Function Get ( _
    key As K _
) As V
Visual C++
public:
V Get(
    K key
)

Parameters

key
Type: K

[Missing <param name="key"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Get(`0)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Get(`0)"]

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


Put Method

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)>..::..Put Method
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Put(`0,`1)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public void Put(
    K key,
    V val
)
Visual Basic
Public Sub Put ( _
    key As K, _
    val As V _
)
Visual C++
public:
void Put(
    K key,
    V val
)

Parameters

key
Type: K

[Missing <param name="key"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Put(`0,`1)"]

val
Type: V

[Missing <param name="val"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.HashMap`2.Put(`0,`1)"]

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


HashMap(K, V) Properties

[image] [image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)> Properties
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

The HashMap<(Of <(<'K, V>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public property | Count |
Public property | Item |
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' K, V >)>)>.)

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


Count Property

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)>..::..Count Property
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Vectorhighlight.HashMap`2.Count"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


Item Property

[image]

Lucene.Net Class Libraries
HashMap<(Of <(<'K, V>)>)>..::..Item Property
HashMap<(Of <(<'K, V>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Search.Vectorhighlight.HashMap`2.Item(`0)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public V this[
    K key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As K _
) As V
    Get
    Set
Visual C++
public:
property V default[K key] {
    V get (K key);
    void set (K key, V value);
}

Parameters

key
Type: K

See Also

HashMap<(Of <(<'K, V>)>)> Class
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Class

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class ScoreOrderFragmentsBuilder : BaseFragmentsBuilder
Visual Basic
Public Class ScoreOrderFragmentsBuilder _
    Inherits BaseFragmentsBuilder
Visual C++
public ref class ScoreOrderFragmentsBuilder : public BaseFragmentsBuilder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..BaseFragmentsBuilder
Lucene.Net.Search.Vectorhighlight..::..ScoreOrderFragmentsBuilder

See Also

ScoreOrderFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Members

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Members
ScoreOrderFragmentsBuilder Class Constructors Methods Fields See Also Send Feedback

The ScoreOrderFragmentsBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | ScoreOrderFragmentsBuilder()()()() | a constructor.
Public method | ScoreOrderFragmentsBuilder(array<String>[]()[][], array<String>[]()[][]) | a constructor.

Methods

 | Name | Description
Public method | CreateFragment | (Inherited from BaseFragmentsBuilder.)
Public method | CreateFragments | (Inherited from BaseFragmentsBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFields | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFieldValues | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPostTag | (Inherited from BaseFragmentsBuilder.)
Protected method | GetPreTag | (Inherited from BaseFragmentsBuilder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeightedFragInfoList | Sort by score the list of WeightedFragInfo (Overrides BaseFragmentsBuilder..::..GetWeightedFragInfoList(List<(Of <<'(FieldFragList..::..WeightedFragInfo>)>>)).)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) | (Inherited from BaseFragmentsBuilder.)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | postTags | (Inherited from BaseFragmentsBuilder.)
Protected field | preTags | (Inherited from BaseFragmentsBuilder.)

See Also

ScoreOrderFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Constructor

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Constructor
ScoreOrderFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScoreOrderFragmentsBuilder()()()() | a constructor.
Public method | ScoreOrderFragmentsBuilder(array<String>[]()[][], array<String>[]()[][]) | a constructor.

See Also

ScoreOrderFragmentsBuilder Class
ScoreOrderFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Constructor

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Constructor
ScoreOrderFragmentsBuilder Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public ScoreOrderFragmentsBuilder()
Visual Basic
Public Sub New
Visual C++
public:
ScoreOrderFragmentsBuilder()

See Also

ScoreOrderFragmentsBuilder Class
ScoreOrderFragmentsBuilder Overload
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Constructor (String[], String[])

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Constructor (array<String>[]()[][], array<String>[]()[][])
ScoreOrderFragmentsBuilder Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public ScoreOrderFragmentsBuilder(
    string[] preTags,
    string[] postTags
)
Visual Basic
Public Sub New ( _
    preTags As String(), _
    postTags As String() _
)
Visual C++
public:
ScoreOrderFragmentsBuilder(
    array<String^>^ preTags,
    array<String^>^ postTags
)

Parameters

preTags
Type: array< System..::..String >[]()[][]
array of pre-tags for markup terms
postTags
Type: array< System..::..String >[]()[][]
array of post-tags for markup terms

See Also

ScoreOrderFragmentsBuilder Class
ScoreOrderFragmentsBuilder Overload
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Fields

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Fields
ScoreOrderFragmentsBuilder Class See Also Send Feedback

The ScoreOrderFragmentsBuilder type exposes the following members.

Fields

 | Name | Description
Protected field | postTags | (Inherited from BaseFragmentsBuilder.)
Protected field | preTags | (Inherited from BaseFragmentsBuilder.)

See Also

ScoreOrderFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder Methods

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder Methods
ScoreOrderFragmentsBuilder Class See Also Send Feedback

The ScoreOrderFragmentsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFragment | (Inherited from BaseFragmentsBuilder.)
Public method | CreateFragments | (Inherited from BaseFragmentsBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFields | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFieldValues | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPostTag | (Inherited from BaseFragmentsBuilder.)
Protected method | GetPreTag | (Inherited from BaseFragmentsBuilder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeightedFragInfoList | Sort by score the list of WeightedFragInfo (Overrides BaseFragmentsBuilder..::..GetWeightedFragInfoList(List<(Of <<'(FieldFragList..::..WeightedFragInfo>)>>)).)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) | (Inherited from BaseFragmentsBuilder.)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScoreOrderFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFragmentSource Method

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..GetFragmentSource Method
ScoreOrderFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete. (Inherited from BaseFragmentsBuilder.)

See Also

ScoreOrderFragmentsBuilder Class
ScoreOrderFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


GetWeightedFragInfoList Method

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..GetWeightedFragInfoList Method
ScoreOrderFragmentsBuilder Class See Also Send Feedback
Sort by score the list of WeightedFragInfo

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override List<FieldFragList..::..WeightedFragInfo> GetWeightedFragInfoList(
    List<FieldFragList..::..WeightedFragInfo> src
)
Visual Basic
Public Overrides Function GetWeightedFragInfoList ( _
    src As List(Of FieldFragList..::..WeightedFragInfo) _
) As List(Of FieldFragList..::..WeightedFragInfo)
Visual C++
public:
virtual List<FieldFragList..::..WeightedFragInfo^>^ GetWeightedFragInfoList(
    List<FieldFragList..::..WeightedFragInfo^>^ src
) override

Parameters

src
Type: System.Collections.Generic..::..List <(Of <(<' FieldFragList..::..WeightedFragInfo >)>)>

[Missing <param name="src"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

See Also

ScoreOrderFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


MakeFragment Method

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..MakeFragment Method
ScoreOrderFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) | (Inherited from BaseFragmentsBuilder.)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete. (Inherited from BaseFragmentsBuilder.)

See Also

ScoreOrderFragmentsBuilder Class
ScoreOrderFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder.ScoreComparator Class

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..ScoreComparator Class
ScoreOrderFragmentsBuilder Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.ScoreComparator"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class ScoreComparator : IComparer<FieldFragList..::..WeightedFragInfo>
Visual Basic
Public Class ScoreComparator _
    Implements IComparer(Of FieldFragList..::..WeightedFragInfo)
Visual C++
public ref class ScoreComparator : IComparer<FieldFragList..::..WeightedFragInfo^>

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..ScoreOrderFragmentsBuilder..::..ScoreComparator

See Also

ScoreOrderFragmentsBuilder..::..ScoreComparator Members
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder.ScoreComparator Members

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..ScoreComparator Members
ScoreOrderFragmentsBuilder..::..ScoreComparator Class Constructors Methods See Also Send Feedback

The ScoreOrderFragmentsBuilder..::..ScoreComparator type exposes the following members.

Constructors

 | Name | Description
Public method | ScoreOrderFragmentsBuilder..::..ScoreComparator | Initializes a new instance of the ScoreOrderFragmentsBuilder..::..ScoreComparator class

Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScoreOrderFragmentsBuilder..::..ScoreComparator Class
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder.ScoreComparator Constructor

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..ScoreComparator Constructor
ScoreOrderFragmentsBuilder..::..ScoreComparator Class See Also Send Feedback
Initializes a new instance of the ScoreOrderFragmentsBuilder..::..ScoreComparator class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public ScoreComparator()
Visual Basic
Public Sub New
Visual C++
public:
ScoreComparator()

See Also

ScoreOrderFragmentsBuilder..::..ScoreComparator Class
Lucene.Net.Search.Vectorhighlight Namespace


ScoreOrderFragmentsBuilder.ScoreComparator Methods

[image] [image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..ScoreComparator Methods
ScoreOrderFragmentsBuilder..::..ScoreComparator Class See Also Send Feedback

The ScoreOrderFragmentsBuilder..::..ScoreComparator type exposes the following members.

Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScoreOrderFragmentsBuilder..::..ScoreComparator Class
Lucene.Net.Search.Vectorhighlight Namespace


Compare Method

[image]

Lucene.Net Class Libraries
ScoreOrderFragmentsBuilder..::..ScoreComparator..::..Compare Method
ScoreOrderFragmentsBuilder..::..ScoreComparator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.ScoreComparator.Compare(Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo,Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int Compare(
    FieldFragList..::..WeightedFragInfo o1,
    FieldFragList..::..WeightedFragInfo o2
)
Visual Basic
Public Function Compare ( _
    o1 As FieldFragList..::..WeightedFragInfo, _
    o2 As FieldFragList..::..WeightedFragInfo _
) As Integer
Visual C++
public:
virtual int Compare(
    FieldFragList..::..WeightedFragInfo^ o1,
    FieldFragList..::..WeightedFragInfo^ o2
) sealed

Parameters

o1
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList..::..WeightedFragInfo

[Missing <param name="o1"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.ScoreComparator.Compare(Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo,Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

o2
Type: Lucene.Net.Search.Vectorhighlight..::..FieldFragList..::..WeightedFragInfo

[Missing <param name="o2"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.ScoreComparator.Compare(Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo,Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.ScoreOrderFragmentsBuilder.ScoreComparator.Compare(Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo,Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo)"]

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

ScoreOrderFragmentsBuilder..::..ScoreComparator Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragListBuilder Class

[image]

Lucene.Net Class Libraries
SimpleFragListBuilder Class
Members See Also Send Feedback
A simple implementation of FragListBuilder.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class SimpleFragListBuilder : FragListBuilder
Visual Basic
Public Class SimpleFragListBuilder _
    Implements FragListBuilder
Visual C++
public ref class SimpleFragListBuilder : FragListBuilder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..SimpleFragListBuilder

See Also

SimpleFragListBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragListBuilder Members

[image] [image]

Lucene.Net Class Libraries
SimpleFragListBuilder Members
SimpleFragListBuilder Class Constructors Methods Fields See Also Send Feedback

The SimpleFragListBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFragListBuilder | Initializes a new instance of the SimpleFragListBuilder class

Methods

 | Name | Description
Public method | CreateFieldFragList |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MARGIN |
MIN_FRAG_CHAR_SIZE |

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragListBuilder Constructor

[image]

Lucene.Net Class Libraries
SimpleFragListBuilder Constructor
SimpleFragListBuilder Class See Also Send Feedback
Initializes a new instance of the SimpleFragListBuilder class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public SimpleFragListBuilder()
Visual Basic
Public Sub New
Visual C++
public:
SimpleFragListBuilder()

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragListBuilder Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFragListBuilder Fields
SimpleFragListBuilder Class See Also Send Feedback

The SimpleFragListBuilder type exposes the following members.

Fields

Name | Description
MARGIN |
MIN_FRAG_CHAR_SIZE |

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


MARGIN Field

[image]

Lucene.Net Class Libraries
SimpleFragListBuilder..::..MARGIN Field
SimpleFragListBuilder Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.SimpleFragListBuilder.MARGIN"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static int MARGIN
Visual Basic
Public Shared MARGIN As Integer
Visual C++
public:
static int MARGIN

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


MIN_FRAG_CHAR_SIZE Field

[image]

Lucene.Net Class Libraries
SimpleFragListBuilder..::..MIN_FRAG_CHAR_SIZE Field
SimpleFragListBuilder Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Search.Vectorhighlight.SimpleFragListBuilder.MIN_FRAG_CHAR_SIZE"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static int MIN_FRAG_CHAR_SIZE
Visual Basic
Public Shared MIN_FRAG_CHAR_SIZE As Integer
Visual C++
public:
static int MIN_FRAG_CHAR_SIZE

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragListBuilder Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFragListBuilder Methods
SimpleFragListBuilder Class See Also Send Feedback

The SimpleFragListBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFieldFragList |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


CreateFieldFragList Method

[image]

Lucene.Net Class Libraries
SimpleFragListBuilder..::..CreateFieldFragList Method
SimpleFragListBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.SimpleFragListBuilder.CreateFieldFragList(Lucene.Net.Search.Vectorhighlight.FieldPhraseList,System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public FieldFragList CreateFieldFragList(
    FieldPhraseList fieldPhraseList,
    int fragCharSize
)
Visual Basic
Public Function CreateFieldFragList ( _
    fieldPhraseList As FieldPhraseList, _
    fragCharSize As Integer _
) As FieldFragList
Visual C++
public:
virtual FieldFragList^ CreateFieldFragList(
    FieldPhraseList^ fieldPhraseList,
    int fragCharSize
) sealed

Parameters

fieldPhraseList
Type: Lucene.Net.Search.Vectorhighlight..::..FieldPhraseList

[Missing <param name="fieldPhraseList"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.SimpleFragListBuilder.CreateFieldFragList(Lucene.Net.Search.Vectorhighlight.FieldPhraseList,System.Int32)"]

fragCharSize
Type: System..::..Int32

[Missing <param name="fragCharSize"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.SimpleFragListBuilder.CreateFieldFragList(Lucene.Net.Search.Vectorhighlight.FieldPhraseList,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.SimpleFragListBuilder.CreateFieldFragList(Lucene.Net.Search.Vectorhighlight.FieldPhraseList,System.Int32)"]

Implements

FragListBuilder..::..CreateFieldFragList(FieldPhraseList, Int32)

See Also

SimpleFragListBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Class

[image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Class
Members See Also Send Feedback
A simple implementation of FragmentsBuilder.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class SimpleFragmentsBuilder : BaseFragmentsBuilder
Visual Basic
Public Class SimpleFragmentsBuilder _
    Inherits BaseFragmentsBuilder
Visual C++
public ref class SimpleFragmentsBuilder : public BaseFragmentsBuilder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search.Vectorhighlight..::..BaseFragmentsBuilder
Lucene.Net.Search.Vectorhighlight..::..SimpleFragmentsBuilder

See Also

SimpleFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Members

[image] [image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Members
SimpleFragmentsBuilder Class Constructors Methods Fields See Also Send Feedback

The SimpleFragmentsBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFragmentsBuilder()()()() | a constructor.
Public method | SimpleFragmentsBuilder(array<String>[]()[][], array<String>[]()[][]) | a constructor.

Methods

 | Name | Description
Public method | CreateFragment | (Inherited from BaseFragmentsBuilder.)
Public method | CreateFragments | (Inherited from BaseFragmentsBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFields | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFieldValues | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPostTag | (Inherited from BaseFragmentsBuilder.)
Protected method | GetPreTag | (Inherited from BaseFragmentsBuilder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeightedFragInfoList | do nothing. return the source list. (Overrides BaseFragmentsBuilder..::..GetWeightedFragInfoList(List<(Of <<'(FieldFragList..::..WeightedFragInfo>)>>)).)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) | (Inherited from BaseFragmentsBuilder.)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | postTags | (Inherited from BaseFragmentsBuilder.)
Protected field | preTags | (Inherited from BaseFragmentsBuilder.)

See Also

SimpleFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Constructor
SimpleFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleFragmentsBuilder()()()() | a constructor.
Public method | SimpleFragmentsBuilder(array<String>[]()[][], array<String>[]()[][]) | a constructor.

See Also

SimpleFragmentsBuilder Class
SimpleFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Constructor

[image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Constructor
SimpleFragmentsBuilder Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public SimpleFragmentsBuilder()
Visual Basic
Public Sub New
Visual C++
public:
SimpleFragmentsBuilder()

See Also

SimpleFragmentsBuilder Class
SimpleFragmentsBuilder Overload
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Constructor (String[], String[])

[image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Constructor (array<String>[]()[][], array<String>[]()[][])
SimpleFragmentsBuilder Class See Also Send Feedback
a constructor.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public SimpleFragmentsBuilder(
    string[] preTags,
    string[] postTags
)
Visual Basic
Public Sub New ( _
    preTags As String(), _
    postTags As String() _
)
Visual C++
public:
SimpleFragmentsBuilder(
    array<String^>^ preTags,
    array<String^>^ postTags
)

Parameters

preTags
Type: array< System..::..String >[]()[][]
array of pre-tags for markup terms
postTags
Type: array< System..::..String >[]()[][]
array of post-tags for markup terms

See Also

SimpleFragmentsBuilder Class
SimpleFragmentsBuilder Overload
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Fields
SimpleFragmentsBuilder Class See Also Send Feedback

The SimpleFragmentsBuilder type exposes the following members.

Fields

 | Name | Description
Protected field | postTags | (Inherited from BaseFragmentsBuilder.)
Protected field | preTags | (Inherited from BaseFragmentsBuilder.)

See Also

SimpleFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


SimpleFragmentsBuilder Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder Methods
SimpleFragmentsBuilder Class See Also Send Feedback

The SimpleFragmentsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | CreateFragment | (Inherited from BaseFragmentsBuilder.)
Public method | CreateFragments | (Inherited from BaseFragmentsBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFields | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFieldValues | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPostTag | (Inherited from BaseFragmentsBuilder.)
Protected method | GetPreTag | (Inherited from BaseFragmentsBuilder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeightedFragInfoList | do nothing. return the source list. (Overrides BaseFragmentsBuilder..::..GetWeightedFragInfoList(List<(Of <<'(FieldFragList..::..WeightedFragInfo>)>>)).)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) | (Inherited from BaseFragmentsBuilder.)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete. (Inherited from BaseFragmentsBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


GetFragmentSource Method

[image] [image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder..::..GetFragmentSource Method
SimpleFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], Int32, Int32) | (Inherited from BaseFragmentsBuilder.)
Protected method | GetFragmentSource(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], Int32, Int32) | Obsolete. (Inherited from BaseFragmentsBuilder.)

See Also

SimpleFragmentsBuilder Class
SimpleFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


GetWeightedFragInfoList Method

[image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder..::..GetWeightedFragInfoList Method
SimpleFragmentsBuilder Class See Also Send Feedback
do nothing. return the source list.

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override List<FieldFragList..::..WeightedFragInfo> GetWeightedFragInfoList(
    List<FieldFragList..::..WeightedFragInfo> src
)
Visual Basic
Public Overrides Function GetWeightedFragInfoList ( _
    src As List(Of FieldFragList..::..WeightedFragInfo) _
) As List(Of FieldFragList..::..WeightedFragInfo)
Visual C++
public:
virtual List<FieldFragList..::..WeightedFragInfo^>^ GetWeightedFragInfoList(
    List<FieldFragList..::..WeightedFragInfo^>^ src
) override

Parameters

src
Type: System.Collections.Generic..::..List <(Of <(<' FieldFragList..::..WeightedFragInfo >)>)>

[Missing <param name="src"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.SimpleFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.SimpleFragmentsBuilder.GetWeightedFragInfoList(System.Collections.Generic.List{Lucene.Net.Search.Vectorhighlight.FieldFragList.WeightedFragInfo})"]

See Also

SimpleFragmentsBuilder Class
Lucene.Net.Search.Vectorhighlight Namespace


MakeFragment Method

[image] [image]

Lucene.Net Class Libraries
SimpleFragmentsBuilder..::..MakeFragment Method
SimpleFragmentsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<Field>[]()[][], FieldFragList..::..WeightedFragInfo) | (Inherited from BaseFragmentsBuilder.)
Protected method | MakeFragment(StringBuilder, array<Int32>[]()[][], array<String>[]()[][], FieldFragList..::..WeightedFragInfo) | Obsolete. (Inherited from BaseFragmentsBuilder.)

See Also

SimpleFragmentsBuilder Class
SimpleFragmentsBuilder Members
Lucene.Net.Search.Vectorhighlight Namespace


VectorHighlightMapper Class

[image]

Lucene.Net Class Libraries
VectorHighlightMapper Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public class VectorHighlightMapper : TermVectorMapper,
    TermPositionVector, TermFreqVector
Visual Basic
Public Class VectorHighlightMapper _
    Inherits TermVectorMapper _
    Implements TermPositionVector, TermFreqVector
Visual C++
public ref class VectorHighlightMapper : public TermVectorMapper,
    TermPositionVector, TermFreqVector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Index..::..TermVectorMapper
Lucene.Net.Search.Vectorhighlight..::..VectorHighlightMapper

See Also

VectorHighlightMapper Members
Lucene.Net.Search.Vectorhighlight Namespace


VectorHighlightMapper Members

[image] [image]

Lucene.Net Class Libraries
VectorHighlightMapper Members
VectorHighlightMapper Class Constructors Methods See Also Send Feedback

The VectorHighlightMapper type exposes the following members.

Constructors

 | Name | Description
Public method | VectorHighlightMapper | Initializes a new instance of the VectorHighlightMapper class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsets |
Public method | GetTermFrequencies |
Public method | GetTermPositions |
Public method | GetTerms |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexesOf |
Public method | IndexOf |
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public method | Map | (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


VectorHighlightMapper Constructor

[image]

Lucene.Net Class Libraries
VectorHighlightMapper Constructor
VectorHighlightMapper Class See Also Send Feedback
Initializes a new instance of the VectorHighlightMapper class

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public VectorHighlightMapper(
    List<string> terms
)
Visual Basic
Public Sub New ( _
    terms As List(Of String) _
)
Visual C++
public:
VectorHighlightMapper(
    List<String^>^ terms
)

Parameters

terms
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.#ctor(System.Collections.Generic.List{System.String})"]

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


VectorHighlightMapper Methods

[image] [image]

Lucene.Net Class Libraries
VectorHighlightMapper Methods
VectorHighlightMapper Class See Also Send Feedback

The VectorHighlightMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsets |
Public method | GetTermFrequencies |
Public method | GetTermPositions |
Public method | GetTerms |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexesOf |
Public method | IndexOf |
Public method | IsIgnoringOffsets | (Inherited from TermVectorMapper.)
Public method | IsIgnoringPositions | Indicate to Lucene that even if there are positions stored, this mapper is not interested in them and they can be skipped over. Derived classes should set this to true if they want to ignore positions. The default is false, meaning positions will be loaded if they are stored. (Inherited from TermVectorMapper.)
Public method | Map | (Overrides TermVectorMapper..::..Map(String, Int32, array<TermVectorOffsetInfo>[]()[][], array<Int32>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDocumentNumber | Passes down the index of the document whose term vector is currently being mapped, once for each top level call to a term vector reader. Default implementation IGNORES the document number. Override if your implementation needs the document number. NOTE: Document numbers are internal to Lucene and subject to change depending on indexing operations. (Inherited from TermVectorMapper.)
Public method | SetExpectations | (Overrides TermVectorMapper..::..SetExpectations(String, Int32, Boolean, Boolean).)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


GetField Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..GetField Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetField"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string GetField()
Visual Basic
Public Function GetField As String
Visual C++
public:
virtual String^ GetField() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetField"]

Implements

TermFreqVector..::..GetField()()()()

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


GetOffsets Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..GetOffsets Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetOffsets(System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public TermVectorOffsetInfo[] GetOffsets(
    int index
)
Visual Basic
Public Function GetOffsets ( _
    index As Integer _
) As TermVectorOffsetInfo()
Visual C++
public:
virtual array<TermVectorOffsetInfo^>^ GetOffsets(
    int index
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetOffsets(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetOffsets(System.Int32)"]

Implements

TermPositionVector..::..GetOffsets(Int32)

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


GetTermFrequencies Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..GetTermFrequencies Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTermFrequencies"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int[] GetTermFrequencies()
Visual Basic
Public Function GetTermFrequencies As Integer()
Visual C++
public:
virtual array<int>^ GetTermFrequencies() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTermFrequencies"]

Implements

TermFreqVector..::..GetTermFrequencies()()()()

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


GetTermPositions Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..GetTermPositions Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTermPositions(System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int[] GetTermPositions(
    int index
)
Visual Basic
Public Function GetTermPositions ( _
    index As Integer _
) As Integer()
Visual C++
public:
virtual array<int>^ GetTermPositions(
    int index
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTermPositions(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTermPositions(System.Int32)"]

Implements

TermPositionVector..::..GetTermPositions(Int32)

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


GetTerms Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..GetTerms Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTerms"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public string[] GetTerms()
Visual Basic
Public Function GetTerms As String()
Visual C++
public:
virtual array<String^>^ GetTerms() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.GetTerms"]

Implements

TermFreqVector..::..GetTerms()()()()

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


IndexesOf Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..IndexesOf Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexesOf(System.String[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int[] IndexesOf(
    string[] terms,
    int start,
    int len
)
Visual Basic
Public Function IndexesOf ( _
    terms As String(), _
    start As Integer, _
    len As Integer _
) As Integer()
Visual C++
public:
virtual array<int>^ IndexesOf(
    array<String^>^ terms,
    int start,
    int len
) sealed

Parameters

terms
Type: array< System..::..String >[]()[][]

[Missing <param name="terms"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexesOf(System.String[],System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexesOf(System.String[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexesOf(System.String[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexesOf(System.String[],System.Int32,System.Int32)"]

Implements

TermFreqVector..::..IndexesOf(array<String>[]()[][], Int32, Int32)

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


IndexOf Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..IndexOf Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexOf(System.String)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int IndexOf(
    string term
)
Visual Basic
Public Function IndexOf ( _
    term As String _
) As Integer
Visual C++
public:
virtual int IndexOf(
    String^ term
) sealed

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexOf(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.IndexOf(System.String)"]

Implements

TermFreqVector..::..IndexOf(String)

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


Map Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..Map Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override void Map(
    string term,
    int frequency,
    TermVectorOffsetInfo[] offsets,
    int[] positions
)
Visual Basic
Public Overrides Sub Map ( _
    term As String, _
    frequency As Integer, _
    offsets As TermVectorOffsetInfo(), _
    positions As Integer() _
)
Visual C++
public:
virtual void Map(
    String^ term,
    int frequency,
    array<TermVectorOffsetInfo^>^ offsets,
    array<int>^ positions
) override

Parameters

term
Type: System..::..String

[Missing <param name="term"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

frequency
Type: System..::..Int32

[Missing <param name="frequency"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

offsets
Type: array< Lucene.Net.Index..::..TermVectorOffsetInfo >[]()[][]

[Missing <param name="offsets"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

positions
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="positions"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Map(System.String,System.Int32,Lucene.Net.Index.TermVectorOffsetInfo[],System.Int32[])"]

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


SetExpectations Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..SetExpectations Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override void SetExpectations(
    string field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
)
Visual Basic
Public Overrides Sub SetExpectations ( _
    field As String, _
    numTerms As Integer, _
    storeOffsets As Boolean, _
    storePositions As Boolean _
)
Visual C++
public:
virtual void SetExpectations(
    String^ field,
    int numTerms,
    bool storeOffsets,
    bool storePositions
) override

Parameters

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

numTerms
Type: System..::..Int32

[Missing <param name="numTerms"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

storeOffsets
Type: System..::..Boolean

[Missing <param name="storeOffsets"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

storePositions
Type: System..::..Boolean

[Missing <param name="storePositions"/> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.SetExpectations(System.String,System.Int32,System.Boolean,System.Boolean)"]

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


Size Method

[image]

Lucene.Net Class Libraries
VectorHighlightMapper..::..Size Method
VectorHighlightMapper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Size"]

Namespace: Lucene.Net.Search.Vectorhighlight
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Search.Vectorhighlight.VectorHighlightMapper.Size"]

Implements

TermFreqVector..::..Size()()()()

See Also

VectorHighlightMapper Class
Lucene.Net.Search.Vectorhighlight Namespace


Lucene.Net.Spatial.GeoHash Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Spatial.GeoHash Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Spatial.GeoHash"]

Classes

 | Class | Description
Public class | GeoHashDistanceFilter |
Public class | GeoHashUtils |


GeoHashDistanceFilter Class

[image]

Lucene.Net Class Libraries
GeoHashDistanceFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class GeoHashDistanceFilter : DistanceFilter
Visual Basic
Public Class GeoHashDistanceFilter _
    Inherits DistanceFilter
Visual C++
public ref class GeoHashDistanceFilter : public DistanceFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Spatial.Tier..::..DistanceFilter
Lucene.Net.Spatial.GeoHash..::..GeoHashDistanceFilter

See Also

GeoHashDistanceFilter Members
Lucene.Net.Spatial.GeoHash Namespace


GeoHashDistanceFilter Members

[image] [image]

Lucene.Net Class Libraries
GeoHashDistanceFilter Members
GeoHashDistanceFilter Class Constructors Methods Fields Properties See Also Send Feedback

The GeoHashDistanceFilter type exposes the following members.

Constructors

 | Name | Description
Public method | GeoHashDistanceFilter | Provide a distance filter based from a center point with a radius in miles

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides DistanceFilter..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | (Inherited from DistanceFilter.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides DistanceFilter..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | You must call this before re-using this DistanceFilter across searches (Inherited from DistanceFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | Distance | (Inherited from DistanceFilter.)
Protected field | DistanceLookupCache | (Inherited from DistanceFilter.)
Protected field | NextDocBase | (Inherited from DistanceFilter.)
Protected field | Precision | (Inherited from DistanceFilter.)
Protected field | StartingFilter | (Inherited from DistanceFilter.)

Properties

 | Name | Description
Public property | Distances | (Inherited from DistanceFilter.)

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashDistanceFilter Constructor

[image]

Lucene.Net Class Libraries
GeoHashDistanceFilter Constructor
GeoHashDistanceFilter Class See Also Send Feedback
Provide a distance filter based from a center point with a radius in miles

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public GeoHashDistanceFilter(
    Filter startingFilter,
    double lat,
    double lng,
    double miles,
    string geoHashField
)
Visual Basic
Public Sub New ( _
    startingFilter As Filter, _
    lat As Double, _
    lng As Double, _
    miles As Double, _
    geoHashField As String _
)
Visual C++
public:
GeoHashDistanceFilter(
    Filter^ startingFilter,
    double lat,
    double lng,
    double miles,
    String^ geoHashField
)

Parameters

startingFilter
Type: Lucene.Net.Search..::..Filter
The starting filter.
lat
Type: System..::..Double
The lat.
lng
Type: System..::..Double
The LNG.
miles
Type: System..::..Double
The miles.
geoHashField
Type: System..::..String
The geo hash field.

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashDistanceFilter Fields

[image] [image]

Lucene.Net Class Libraries
GeoHashDistanceFilter Fields
GeoHashDistanceFilter Class See Also Send Feedback

The GeoHashDistanceFilter type exposes the following members.

Fields

 | Name | Description
Protected field | Distance | (Inherited from DistanceFilter.)
Protected field | DistanceLookupCache | (Inherited from DistanceFilter.)
Protected field | NextDocBase | (Inherited from DistanceFilter.)
Protected field | Precision | (Inherited from DistanceFilter.)
Protected field | StartingFilter | (Inherited from DistanceFilter.)

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashDistanceFilter Methods

[image] [image]

Lucene.Net Class Libraries
GeoHashDistanceFilter Methods
GeoHashDistanceFilter Class See Also Send Feedback

The GeoHashDistanceFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides DistanceFilter..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | (Inherited from DistanceFilter.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides DistanceFilter..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | You must call this before re-using this DistanceFilter across searches (Inherited from DistanceFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


Equals Method

[image]

Lucene.Net Class Libraries
GeoHashDistanceFilter..::..Equals Method
GeoHashDistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.Equals(System.Object)"]

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
GeoHashDistanceFilter..::..GetDocIdSet Method
GeoHashDistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
GeoHashDistanceFilter..::..GetHashCode Method
GeoHashDistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.GetHashCode"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashDistanceFilter.GetHashCode"]

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashDistanceFilter Properties

[image] [image]

Lucene.Net Class Libraries
GeoHashDistanceFilter Properties
GeoHashDistanceFilter Class See Also Send Feedback

The GeoHashDistanceFilter type exposes the following members.

Properties

 | Name | Description
Public property | Distances | (Inherited from DistanceFilter.)

See Also

GeoHashDistanceFilter Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashUtils Class

[image]

Lucene.Net Class Libraries
GeoHashUtils Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.GeoHash.GeoHashUtils"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class GeoHashUtils
Visual Basic
Public Class GeoHashUtils
Visual C++
public ref class GeoHashUtils

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.GeoHash..::..GeoHashUtils

See Also

GeoHashUtils Members
Lucene.Net.Spatial.GeoHash Namespace


GeoHashUtils Members

[image] [image]

Lucene.Net Class Libraries
GeoHashUtils Members
GeoHashUtils Class Constructors Methods See Also Send Feedback

The GeoHashUtils type exposes the following members.

Constructors

 | Name | Description
Public method | GeoHashUtils | Initializes a new instance of the GeoHashUtils class

Methods

 | Name | Description
 | Decode |
 | DecodeExactly |
 | Encode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrecision |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashUtils Constructor

[image]

Lucene.Net Class Libraries
GeoHashUtils Constructor
GeoHashUtils Class See Also Send Feedback
Initializes a new instance of the GeoHashUtils class

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public GeoHashUtils()
Visual Basic
Public Sub New
Visual C++
public:
GeoHashUtils()

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


GeoHashUtils Methods

[image] [image]

Lucene.Net Class Libraries
GeoHashUtils Methods
GeoHashUtils Class See Also Send Feedback

The GeoHashUtils type exposes the following members.

Methods

 | Name | Description
 | Decode |
 | DecodeExactly |
 | Encode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrecision |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


Decode Method

[image]

Lucene.Net Class Libraries
GeoHashUtils..::..Decode Method
GeoHashUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Decode(System.String)"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double[] Decode(
    string geohash
)
Visual Basic
Public Shared Function Decode ( _
    geohash As String _
) As Double()
Visual C++
public:
static array<double>^ Decode(
    String^ geohash
)

Parameters

geohash
Type: System..::..String

[Missing <param name="geohash"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Decode(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Decode(System.String)"]

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


DecodeExactly Method

[image]

Lucene.Net Class Libraries
GeoHashUtils..::..DecodeExactly Method
GeoHashUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.DecodeExactly(System.String)"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double[] DecodeExactly(
    string geohash
)
Visual Basic
Public Shared Function DecodeExactly ( _
    geohash As String _
) As Double()
Visual C++
public:
static array<double>^ DecodeExactly(
    String^ geohash
)

Parameters

geohash
Type: System..::..String

[Missing <param name="geohash"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.DecodeExactly(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.DecodeExactly(System.String)"]

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


Encode Method

[image]

Lucene.Net Class Libraries
GeoHashUtils..::..Encode Method
GeoHashUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Encode(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static string Encode(
    double latitude,
    double longitude
)
Visual Basic
Public Shared Function Encode ( _
    latitude As Double, _
    longitude As Double _
) As String
Visual C++
public:
static String^ Encode(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Encode(System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Encode(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.Encode(System.Double,System.Double)"]

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


GetPrecision Method

[image]

Lucene.Net Class Libraries
GeoHashUtils..::..GetPrecision Method
GeoHashUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.GetPrecision(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.GeoHash
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double GetPrecision(
    double x,
    double precision
)
Visual Basic
Public Shared Function GetPrecision ( _
    x As Double, _
    precision As Double _
) As Double
Visual C++
public:
static double GetPrecision(
    double x,
    double precision
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.GetPrecision(System.Double,System.Double)"]

precision
Type: System..::..Double

[Missing <param name="precision"/> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.GetPrecision(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.GeoHash.GeoHashUtils.GetPrecision(System.Double,System.Double)"]

See Also

GeoHashUtils Class
Lucene.Net.Spatial.GeoHash Namespace


Lucene.Net.Spatial.Geometry Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Spatial.Geometry Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Spatial.Geometry"]

Classes

 | Class | Description
Public class | CartesianPoint | Represents lat/lngs as fixed point numbers translated so that all world coordinates are in the first quadrant. The same fixed point scale as is used for FixedLatLng is employed.
Public class | FixedLatLng |
Public class | FloatLatLng |
Public class | LatLng |

Enumerations

 | Enumeration | Description
Public enumeration | DistanceUnits |


CartesianPoint Class

[image]

Lucene.Net Class Libraries
CartesianPoint Class
Members See Also Send Feedback
Represents lat/lngs as fixed point numbers translated so that all world coordinates are in the first quadrant. The same fixed point scale as is used for FixedLatLng is employed.

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class CartesianPoint
Visual Basic
Public Class CartesianPoint
Visual C++
public ref class CartesianPoint

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry..::..CartesianPoint

See Also

CartesianPoint Members
Lucene.Net.Spatial.Geometry Namespace


CartesianPoint Members

[image] [image]

Lucene.Net Class Libraries
CartesianPoint Members
CartesianPoint Class Constructors Methods Properties See Also Send Feedback

The CartesianPoint type exposes the following members.

Constructors

 | Name | Description
Public method | CartesianPoint | Initializes a new instance of the CartesianPoint class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Translate |

Properties

 | Name | Description
Public property | X |
Public property | Y |

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


CartesianPoint Constructor

[image]

Lucene.Net Class Libraries
CartesianPoint Constructor
CartesianPoint Class See Also Send Feedback
Initializes a new instance of the CartesianPoint class

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public CartesianPoint(
    int x,
    int y
)
Visual Basic
Public Sub New ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
CartesianPoint(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.#ctor(System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.#ctor(System.Int32,System.Int32)"]

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


CartesianPoint Methods

[image] [image]

Lucene.Net Class Libraries
CartesianPoint Methods
CartesianPoint Class See Also Send Feedback

The CartesianPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Translate |

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


Equals Method

[image]

Lucene.Net Class Libraries
CartesianPoint..::..Equals Method
CartesianPoint Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Equals(System.Object)"]

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
CartesianPoint..::..GetHashCode Method
CartesianPoint Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.GetHashCode"]

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


ToString Method

[image]

Lucene.Net Class Libraries
CartesianPoint..::..ToString Method
CartesianPoint Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.ToString"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.ToString"]

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


Translate Method

[image]

Lucene.Net Class Libraries
CartesianPoint..::..Translate Method
CartesianPoint Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Translate(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public CartesianPoint Translate(
    int deltaX,
    int deltaY
)
Visual Basic
Public Function Translate ( _
    deltaX As Integer, _
    deltaY As Integer _
) As CartesianPoint
Visual C++
public:
CartesianPoint^ Translate(
    int deltaX,
    int deltaY
)

Parameters

deltaX
Type: System..::..Int32

[Missing <param name="deltaX"/> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Translate(System.Int32,System.Int32)"]

deltaY
Type: System..::..Int32

[Missing <param name="deltaY"/> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Translate(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.CartesianPoint.Translate(System.Int32,System.Int32)"]

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


CartesianPoint Properties

[image] [image]

Lucene.Net Class Libraries
CartesianPoint Properties
CartesianPoint Class See Also Send Feedback

The CartesianPoint type exposes the following members.

Properties

 | Name | Description
Public property | X |
Public property | Y |

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


X Property

[image]

Lucene.Net Class Libraries
CartesianPoint..::..X Property
CartesianPoint Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.CartesianPoint.X"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public int X { get; set; }
Visual Basic
Public Property X As Integer
    Get
    Set
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


Y Property

[image]

Lucene.Net Class Libraries
CartesianPoint..::..Y Property
CartesianPoint Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.CartesianPoint.Y"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public int Y { get; set; }
Visual Basic
Public Property Y As Integer
    Get
    Set
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

CartesianPoint Class
Lucene.Net.Spatial.Geometry Namespace


DistanceUnits Enumeration

[image]

Lucene.Net Class Libraries
DistanceUnits Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.DistanceUnits"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public enum DistanceUnits
Visual Basic
Public Enumeration DistanceUnits
Visual C++
public enum class DistanceUnits

Members

Member name | Value | Description
MILES | 0 |
KILOMETERS | 1 |

See Also

Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Class

[image]

Lucene.Net Class Libraries
FixedLatLng Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.FixedLatLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class FixedLatLng : LatLng
Visual Basic
Public Class FixedLatLng _
    Inherits LatLng
Visual C++
public ref class FixedLatLng : public LatLng

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry..::..LatLng
Lucene.Net.Spatial.Geometry..::..FixedLatLng

See Also

FixedLatLng Members
Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Members

[image] [image]

Lucene.Net Class Libraries
FixedLatLng Members
FixedLatLng Class Constructors Methods Fields See Also Send Feedback

The FixedLatLng type exposes the following members.

Constructors

 | Name | Description
Public method | FixedLatLng(LatLng) | Initializes a new instance of the FixedLatLng class
Public method | FixedLatLng(Int32, Int32) | Initializes a new instance of the FixedLatLng class

Methods

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles. (Inherited from LatLng.)
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters. (Inherited from LatLng.)
Public method | CalculateMidpoint | (Overrides LatLng..::..CalculateMidpoint(LatLng).)
Public method | Copy | (Overrides LatLng..::..Copy()()()().)
 | DoubleToFixed |
Public method | Equals | (Overrides LatLng..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedToDouble |
Public method | GetFixedLat | (Overrides LatLng..::..GetFixedLat()()()().)
Public method | GetFixedLng | (Overrides LatLng..::..GetFixedLng()()()().)
Public method | GetHashCode | (Overrides LatLng..::..GetHashCode()()()().)
Public method | GetLat | (Overrides LatLng..::..GetLat()()()().)
Public method | GetLng | (Overrides LatLng..::..GetLng()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFixedPoint | (Overrides LatLng..::..IsFixedPoint()()()().)
Public method | IsNormalized | (Overrides LatLng..::..IsNormalized()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | (Overrides LatLng..::..Normalize()()()().)
Protected method | SetLng |
Public method | ToCartesian | Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling). (Inherited from LatLng.)
Public method | ToFixed | (Overrides LatLng..::..ToFixed()()()().)
Public method | ToFloat | (Overrides LatLng..::..ToFloat()()()().)
Public method | ToString | (Inherited from LatLng.)

Fields

Name | Description
ScaleFactor |
ScaleFactorInt |

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Constructor

[image] [image]

Lucene.Net Class Libraries
FixedLatLng Constructor
FixedLatLng Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FixedLatLng(LatLng) | Initializes a new instance of the FixedLatLng class
Public method | FixedLatLng(Int32, Int32) | Initializes a new instance of the FixedLatLng class

See Also

FixedLatLng Class
FixedLatLng Members
Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Constructor (LatLng)

[image]

Lucene.Net Class Libraries
FixedLatLng Constructor (LatLng)
FixedLatLng Class See Also Send Feedback
Initializes a new instance of the FixedLatLng class

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public FixedLatLng(
    LatLng ll
)
Visual Basic
Public Sub New ( _
    ll As LatLng _
)
Visual C++
public:
FixedLatLng(
    LatLng^ ll
)

Parameters

ll
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="ll"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.#ctor(Lucene.Net.Spatial.Geometry.LatLng)"]

See Also

FixedLatLng Class
FixedLatLng Overload
Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Constructor (Int32, Int32)

[image]

Lucene.Net Class Libraries
FixedLatLng Constructor (Int32, Int32)
FixedLatLng Class See Also Send Feedback
Initializes a new instance of the FixedLatLng class

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public FixedLatLng(
    int lat,
    int lng
)
Visual Basic
Public Sub New ( _
    lat As Integer, _
    lng As Integer _
)
Visual C++
public:
FixedLatLng(
    int lat,
    int lng
)

Parameters

lat
Type: System..::..Int32

[Missing <param name="lat"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.#ctor(System.Int32,System.Int32)"]

lng
Type: System..::..Int32

[Missing <param name="lng"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.#ctor(System.Int32,System.Int32)"]

See Also

FixedLatLng Class
FixedLatLng Overload
Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Fields

[image] [image]

Lucene.Net Class Libraries
FixedLatLng Fields
FixedLatLng Class See Also Send Feedback

The FixedLatLng type exposes the following members.

Fields

Name | Description
ScaleFactor |
ScaleFactorInt |

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ScaleFactor Field

[image]

Lucene.Net Class Libraries
FixedLatLng..::..ScaleFactor Field
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Geometry.FixedLatLng.ScaleFactor"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public const double ScaleFactor
Visual Basic
Public Const ScaleFactor As Double
Visual C++
public:
literal double ScaleFactor

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ScaleFactorInt Field

[image]

Lucene.Net Class Libraries
FixedLatLng..::..ScaleFactorInt Field
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Geometry.FixedLatLng.ScaleFactorInt"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public const int ScaleFactorInt
Visual Basic
Public Const ScaleFactorInt As Integer
Visual C++
public:
literal int ScaleFactorInt

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


FixedLatLng Methods

[image] [image]

Lucene.Net Class Libraries
FixedLatLng Methods
FixedLatLng Class See Also Send Feedback

The FixedLatLng type exposes the following members.

Methods

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles. (Inherited from LatLng.)
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters. (Inherited from LatLng.)
Public method | CalculateMidpoint | (Overrides LatLng..::..CalculateMidpoint(LatLng).)
Public method | Copy | (Overrides LatLng..::..Copy()()()().)
 | DoubleToFixed |
Public method | Equals | (Overrides LatLng..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixedToDouble |
Public method | GetFixedLat | (Overrides LatLng..::..GetFixedLat()()()().)
Public method | GetFixedLng | (Overrides LatLng..::..GetFixedLng()()()().)
Public method | GetHashCode | (Overrides LatLng..::..GetHashCode()()()().)
Public method | GetLat | (Overrides LatLng..::..GetLat()()()().)
Public method | GetLng | (Overrides LatLng..::..GetLng()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFixedPoint | (Overrides LatLng..::..IsFixedPoint()()()().)
Public method | IsNormalized | (Overrides LatLng..::..IsNormalized()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | (Overrides LatLng..::..Normalize()()()().)
Protected method | SetLng |
Public method | ToCartesian | Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling). (Inherited from LatLng.)
Public method | ToFixed | (Overrides LatLng..::..ToFixed()()()().)
Public method | ToFloat | (Overrides LatLng..::..ToFloat()()()().)
Public method | ToString | (Inherited from LatLng.)

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ArcDistance Method

[image] [image]

Lucene.Net Class Libraries
FixedLatLng..::..ArcDistance Method
FixedLatLng Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles. (Inherited from LatLng.)
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters. (Inherited from LatLng.)

See Also

FixedLatLng Class
FixedLatLng Members
Lucene.Net.Spatial.Geometry Namespace


CalculateMidpoint Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..CalculateMidpoint Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override LatLng CalculateMidpoint(
    LatLng other
)
Visual Basic
Public Overrides Function CalculateMidpoint ( _
    other As LatLng _
) As LatLng
Visual C++
public:
virtual LatLng^ CalculateMidpoint(
    LatLng^ other
) override

Parameters

other
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="other"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..Copy Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Copy"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override LatLng Copy()
Visual Basic
Public Overrides Function Copy As LatLng
Visual C++
public:
virtual LatLng^ Copy() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Copy"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


DoubleToFixed Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..DoubleToFixed Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.DoubleToFixed(System.Double)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static int DoubleToFixed(
    double d
)
Visual Basic
Public Shared Function DoubleToFixed ( _
    d As Double _
) As Integer
Visual C++
public:
static int DoubleToFixed(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.DoubleToFixed(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.DoubleToFixed(System.Double)"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..Equals Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Equals(System.Object)"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


FixedToDouble Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..FixedToDouble Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.FixedToDouble(System.Int32)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double FixedToDouble(
    int fixedInt
)
Visual Basic
Public Shared Function FixedToDouble ( _
    fixedInt As Integer _
) As Double
Visual C++
public:
static double FixedToDouble(
    int fixedInt
)

Parameters

fixedInt
Type: System..::..Int32

[Missing <param name="fixedInt"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.FixedToDouble(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.FixedToDouble(System.Int32)"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetFixedLat Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..GetFixedLat Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetFixedLat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetFixedLat()
Visual Basic
Public Overrides Function GetFixedLat As Integer
Visual C++
public:
virtual int GetFixedLat() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetFixedLat"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetFixedLng Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..GetFixedLng Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetFixedLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetFixedLng()
Visual Basic
Public Overrides Function GetFixedLng As Integer
Visual C++
public:
virtual int GetFixedLng() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetFixedLng"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..GetHashCode Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetHashCode"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetLat Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..GetLat Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetLat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override double GetLat()
Visual Basic
Public Overrides Function GetLat As Double
Visual C++
public:
virtual double GetLat() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetLat"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetLng Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..GetLng Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override double GetLng()
Visual Basic
Public Overrides Function GetLng As Double
Visual C++
public:
virtual double GetLng() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.GetLng"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


IsFixedPoint Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..IsFixedPoint Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.IsFixedPoint"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool IsFixedPoint()
Visual Basic
Public Overrides Function IsFixedPoint As Boolean
Visual C++
public:
virtual bool IsFixedPoint() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.IsFixedPoint"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


IsNormalized Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..IsNormalized Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.IsNormalized"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool IsNormalized()
Visual Basic
Public Overrides Function IsNormalized As Boolean
Visual C++
public:
virtual bool IsNormalized() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.IsNormalized"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..Normalize Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Normalize"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override LatLng Normalize()
Visual Basic
Public Overrides Function Normalize As LatLng
Visual C++
public:
virtual LatLng^ Normalize() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.Normalize"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


SetLng Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..SetLng Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.SetLng(System.Int32)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected void SetLng(
    int lng
)
Visual Basic
Protected Sub SetLng ( _
    lng As Integer _
)
Visual C++
protected:
void SetLng(
    int lng
)

Parameters

lng
Type: System..::..Int32

[Missing <param name="lng"/> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.SetLng(System.Int32)"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToFixed Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..ToFixed Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.ToFixed"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override FixedLatLng ToFixed()
Visual Basic
Public Overrides Function ToFixed As FixedLatLng
Visual C++
public:
virtual FixedLatLng^ ToFixed() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.ToFixed"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToFloat Method

[image]

Lucene.Net Class Libraries
FixedLatLng..::..ToFloat Method
FixedLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.ToFloat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override FloatLatLng ToFloat()
Visual Basic
Public Overrides Function ToFloat As FloatLatLng
Visual C++
public:
virtual FloatLatLng^ ToFloat() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FixedLatLng.ToFloat"]

See Also

FixedLatLng Class
Lucene.Net.Spatial.Geometry Namespace


FloatLatLng Class

[image]

Lucene.Net Class Libraries
FloatLatLng Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.FloatLatLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class FloatLatLng : LatLng
Visual Basic
Public Class FloatLatLng _
    Inherits LatLng
Visual C++
public ref class FloatLatLng : public LatLng

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry..::..LatLng
Lucene.Net.Spatial.Geometry..::..FloatLatLng

See Also

FloatLatLng Members
Lucene.Net.Spatial.Geometry Namespace


FloatLatLng Members

[image] [image]

Lucene.Net Class Libraries
FloatLatLng Members
FloatLatLng Class Constructors Methods See Also Send Feedback

The FloatLatLng type exposes the following members.

Constructors

 | Name | Description
Public method | FloatLatLng(LatLng) | Initializes a new instance of the FloatLatLng class
Public method | FloatLatLng(Double, Double) | Initializes a new instance of the FloatLatLng class

Methods

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles. (Inherited from LatLng.)
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters. (Inherited from LatLng.)
Public method | CalculateMidpoint | (Overrides LatLng..::..CalculateMidpoint(LatLng).)
Public method | Copy | (Overrides LatLng..::..Copy()()()().)
Public method | Equals | (Overrides LatLng..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFixedLat | (Overrides LatLng..::..GetFixedLat()()()().)
Public method | GetFixedLng | (Overrides LatLng..::..GetFixedLng()()()().)
Public method | GetHashCode | (Overrides LatLng..::..GetHashCode()()()().)
Public method | GetLat | (Overrides LatLng..::..GetLat()()()().)
Public method | GetLng | (Overrides LatLng..::..GetLng()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFixedPoint | (Overrides LatLng..::..IsFixedPoint()()()().)
Public method | IsNormalized | (Overrides LatLng..::..IsNormalized()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | (Overrides LatLng..::..Normalize()()()().)
Public method | ToCartesian | Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling). (Inherited from LatLng.)
Public method | ToFixed | (Overrides LatLng..::..ToFixed()()()().)
Public method | ToFloat | (Overrides LatLng..::..ToFloat()()()().)
Public method | ToString | (Inherited from LatLng.)

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


FloatLatLng Constructor

[image] [image]

Lucene.Net Class Libraries
FloatLatLng Constructor
FloatLatLng Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FloatLatLng(LatLng) | Initializes a new instance of the FloatLatLng class
Public method | FloatLatLng(Double, Double) | Initializes a new instance of the FloatLatLng class

See Also

FloatLatLng Class
FloatLatLng Members
Lucene.Net.Spatial.Geometry Namespace


FloatLatLng Constructor (LatLng)

[image]

Lucene.Net Class Libraries
FloatLatLng Constructor (LatLng)
FloatLatLng Class See Also Send Feedback
Initializes a new instance of the FloatLatLng class

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public FloatLatLng(
    LatLng ll
)
Visual Basic
Public Sub New ( _
    ll As LatLng _
)
Visual C++
public:
FloatLatLng(
    LatLng^ ll
)

Parameters

ll
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="ll"/> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.#ctor(Lucene.Net.Spatial.Geometry.LatLng)"]

See Also

FloatLatLng Class
FloatLatLng Overload
Lucene.Net.Spatial.Geometry Namespace


FloatLatLng Constructor (Double, Double)

[image]

Lucene.Net Class Libraries
FloatLatLng Constructor (Double, Double)
FloatLatLng Class See Also Send Feedback
Initializes a new instance of the FloatLatLng class

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public FloatLatLng(
    double lat,
    double lng
)
Visual Basic
Public Sub New ( _
    lat As Double, _
    lng As Double _
)
Visual C++
public:
FloatLatLng(
    double lat,
    double lng
)

Parameters

lat
Type: System..::..Double

[Missing <param name="lat"/> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.#ctor(System.Double,System.Double)"]

lng
Type: System..::..Double

[Missing <param name="lng"/> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.#ctor(System.Double,System.Double)"]

See Also

FloatLatLng Class
FloatLatLng Overload
Lucene.Net.Spatial.Geometry Namespace


FloatLatLng Methods

[image] [image]

Lucene.Net Class Libraries
FloatLatLng Methods
FloatLatLng Class See Also Send Feedback

The FloatLatLng type exposes the following members.

Methods

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles. (Inherited from LatLng.)
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters. (Inherited from LatLng.)
Public method | CalculateMidpoint | (Overrides LatLng..::..CalculateMidpoint(LatLng).)
Public method | Copy | (Overrides LatLng..::..Copy()()()().)
Public method | Equals | (Overrides LatLng..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFixedLat | (Overrides LatLng..::..GetFixedLat()()()().)
Public method | GetFixedLng | (Overrides LatLng..::..GetFixedLng()()()().)
Public method | GetHashCode | (Overrides LatLng..::..GetHashCode()()()().)
Public method | GetLat | (Overrides LatLng..::..GetLat()()()().)
Public method | GetLng | (Overrides LatLng..::..GetLng()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFixedPoint | (Overrides LatLng..::..IsFixedPoint()()()().)
Public method | IsNormalized | (Overrides LatLng..::..IsNormalized()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | (Overrides LatLng..::..Normalize()()()().)
Public method | ToCartesian | Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling). (Inherited from LatLng.)
Public method | ToFixed | (Overrides LatLng..::..ToFixed()()()().)
Public method | ToFloat | (Overrides LatLng..::..ToFloat()()()().)
Public method | ToString | (Inherited from LatLng.)

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ArcDistance Method

[image] [image]

Lucene.Net Class Libraries
FloatLatLng..::..ArcDistance Method
FloatLatLng Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles. (Inherited from LatLng.)
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters. (Inherited from LatLng.)

See Also

FloatLatLng Class
FloatLatLng Members
Lucene.Net.Spatial.Geometry Namespace


CalculateMidpoint Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..CalculateMidpoint Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override LatLng CalculateMidpoint(
    LatLng other
)
Visual Basic
Public Overrides Function CalculateMidpoint ( _
    other As LatLng _
) As LatLng
Visual C++
public:
virtual LatLng^ CalculateMidpoint(
    LatLng^ other
) override

Parameters

other
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="other"/> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


Copy Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..Copy Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Copy"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override LatLng Copy()
Visual Basic
Public Overrides Function Copy As LatLng
Visual C++
public:
virtual LatLng^ Copy() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Copy"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


Equals Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..Equals Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Equals(System.Object)"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetFixedLat Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..GetFixedLat Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetFixedLat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetFixedLat()
Visual Basic
Public Overrides Function GetFixedLat As Integer
Visual C++
public:
virtual int GetFixedLat() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetFixedLat"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetFixedLng Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..GetFixedLng Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetFixedLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetFixedLng()
Visual Basic
Public Overrides Function GetFixedLng As Integer
Visual C++
public:
virtual int GetFixedLng() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetFixedLng"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..GetHashCode Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetHashCode"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetLat Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..GetLat Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetLat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override double GetLat()
Visual Basic
Public Overrides Function GetLat As Double
Visual C++
public:
virtual double GetLat() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetLat"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetLng Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..GetLng Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override double GetLng()
Visual Basic
Public Overrides Function GetLng As Double
Visual C++
public:
virtual double GetLng() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.GetLng"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


IsFixedPoint Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..IsFixedPoint Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.IsFixedPoint"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool IsFixedPoint()
Visual Basic
Public Overrides Function IsFixedPoint As Boolean
Visual C++
public:
virtual bool IsFixedPoint() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.IsFixedPoint"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


IsNormalized Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..IsNormalized Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.IsNormalized"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool IsNormalized()
Visual Basic
Public Overrides Function IsNormalized As Boolean
Visual C++
public:
virtual bool IsNormalized() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.IsNormalized"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..Normalize Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Normalize"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override LatLng Normalize()
Visual Basic
Public Overrides Function Normalize As LatLng
Visual C++
public:
virtual LatLng^ Normalize() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.Normalize"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToFixed Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..ToFixed Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.ToFixed"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override FixedLatLng ToFixed()
Visual Basic
Public Overrides Function ToFixed As FixedLatLng
Visual C++
public:
virtual FixedLatLng^ ToFixed() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.ToFixed"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToFloat Method

[image]

Lucene.Net Class Libraries
FloatLatLng..::..ToFloat Method
FloatLatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.ToFloat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override FloatLatLng ToFloat()
Visual Basic
Public Overrides Function ToFloat As FloatLatLng
Visual C++
public:
virtual FloatLatLng^ ToFloat() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.FloatLatLng.ToFloat"]

See Also

FloatLatLng Class
Lucene.Net.Spatial.Geometry Namespace


LatLng Class

[image]

Lucene.Net Class Libraries
LatLng Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.LatLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract class LatLng
Visual Basic
Public MustInherit Class LatLng
Visual C++
public ref class LatLng abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry..::..LatLng
Lucene.Net.Spatial.Geometry..::..FixedLatLng
Lucene.Net.Spatial.Geometry..::..FloatLatLng

See Also

LatLng Members
Lucene.Net.Spatial.Geometry Namespace


LatLng Members

[image] [image]

Lucene.Net Class Libraries
LatLng Members
LatLng Class Constructors Methods See Also Send Feedback

The LatLng type exposes the following members.

Constructors

 | Name | Description
Protected method | LatLng | Initializes a new instance of the LatLng class

Methods

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles.
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters.
Public method | CalculateMidpoint | Calculate the midpoint between this point an another. Respects fixed vs floating point
Public method | Copy |
Public method | Equals |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromCartesian | The inverse of ToCartesian(). Always returns a FixedLatLng.
Public method | GetFixedLat |
Public method | GetFixedLng |
Public method | GetHashCode |
Public method | GetLat |
Public method | GetLng |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFixedPoint |
Public method | IsNormalized |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize |
Public method | ToCartesian | Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling).
Public method | ToFixed |
Public method | ToFloat |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


LatLng Constructor

[image]

Lucene.Net Class Libraries
LatLng Constructor
LatLng Class See Also Send Feedback
Initializes a new instance of the LatLng class

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected LatLng()
Visual Basic
Protected Sub New
Visual C++
protected:
LatLng()

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


LatLng Methods

[image] [image]

Lucene.Net Class Libraries
LatLng Methods
LatLng Class See Also Send Feedback

The LatLng type exposes the following members.

Methods

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles.
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters.
Public method | CalculateMidpoint | Calculate the midpoint between this point an another. Respects fixed vs floating point
Public method | Copy |
Public method | Equals |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromCartesian | The inverse of ToCartesian(). Always returns a FixedLatLng.
Public method | GetFixedLat |
Public method | GetFixedLng |
Public method | GetHashCode |
Public method | GetLat |
Public method | GetLng |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFixedPoint |
Public method | IsNormalized |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize |
Public method | ToCartesian | Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling).
Public method | ToFixed |
Public method | ToFloat |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


ArcDistance Method

[image] [image]

Lucene.Net Class Libraries
LatLng..::..ArcDistance Method
LatLng Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArcDistance(LatLng) | Calculates the distance between two lat/lng's in miles.
Public method | ArcDistance(LatLng, DistanceUnits) | Calculates the distance between two lat/lng's in miles or meters.

See Also

LatLng Class
LatLng Members
Lucene.Net.Spatial.Geometry Namespace


ArcDistance Method (LatLng)

[image]

Lucene.Net Class Libraries
LatLng..::..ArcDistance Method (LatLng)
LatLng Class See Also Send Feedback
Calculates the distance between two lat/lng's in miles.

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double ArcDistance(
    LatLng ll2
)
Visual Basic
Public Function ArcDistance ( _
    ll2 As LatLng _
) As Double
Visual C++
public:
double ArcDistance(
    LatLng^ ll2
)

Parameters

ll2
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="ll2"/> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ArcDistance(Lucene.Net.Spatial.Geometry.LatLng)"]

Return Value

Returns the distance in miles

See Also

LatLng Class
ArcDistance Overload
Lucene.Net.Spatial.Geometry Namespace


ArcDistance Method (LatLng, DistanceUnits)

[image]

Lucene.Net Class Libraries
LatLng..::..ArcDistance Method (LatLng, DistanceUnits)
LatLng Class See Also Send Feedback
Calculates the distance between two lat/lng's in miles or meters.

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double ArcDistance(
    LatLng ll2,
    DistanceUnits lUnits
)
Visual Basic
Public Function ArcDistance ( _
    ll2 As LatLng, _
    lUnits As DistanceUnits _
) As Double
Visual C++
public:
double ArcDistance(
    LatLng^ ll2,
    DistanceUnits lUnits
)

Parameters

ll2
Type: Lucene.Net.Spatial.Geometry..::..LatLng
Second lat,lng position to calculate distance to.
lUnits
Type: Lucene.Net.Spatial.Geometry..::..DistanceUnits
Units to calculate distance, defaults to miles

Return Value

Returns the distance in meters or miles

See Also

LatLng Class
ArcDistance Overload
Lucene.Net.Spatial.Geometry Namespace


CalculateMidpoint Method

[image]

Lucene.Net Class Libraries
LatLng..::..CalculateMidpoint Method
LatLng Class See Also Send Feedback
Calculate the midpoint between this point an another. Respects fixed vs floating point

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract LatLng CalculateMidpoint(
    LatLng other
)
Visual Basic
Public MustOverride Function CalculateMidpoint ( _
    other As LatLng _
) As LatLng
Visual C++
public:
virtual LatLng^ CalculateMidpoint(
    LatLng^ other
) abstract

Parameters

other
Type: Lucene.Net.Spatial.Geometry..::..LatLng
The other.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.CalculateMidpoint(Lucene.Net.Spatial.Geometry.LatLng)"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


Copy Method

[image]

Lucene.Net Class Libraries
LatLng..::..Copy Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Copy"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract LatLng Copy()
Visual Basic
Public MustOverride Function Copy As LatLng
Visual C++
public:
virtual LatLng^ Copy() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Copy"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


Equals Method

[image]

Lucene.Net Class Libraries
LatLng..::..Equals Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract bool Equals(
    Object obj
)
Visual Basic
Public MustOverride Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) abstract

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Equals(System.Object)"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


FromCartesian Method

[image]

Lucene.Net Class Libraries
LatLng..::..FromCartesian Method
LatLng Class See Also Send Feedback
The inverse of ToCartesian(). Always returns a FixedLatLng.

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static LatLng FromCartesian(
    CartesianPoint pt
)
Visual Basic
Public Shared Function FromCartesian ( _
    pt As CartesianPoint _
) As LatLng
Visual C++
public:
static LatLng^ FromCartesian(
    CartesianPoint^ pt
)

Parameters

pt
Type: Lucene.Net.Spatial.Geometry..::..CartesianPoint

[Missing <param name="pt"/> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.FromCartesian(Lucene.Net.Spatial.Geometry.CartesianPoint)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.FromCartesian(Lucene.Net.Spatial.Geometry.CartesianPoint)"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetFixedLat Method

[image]

Lucene.Net Class Libraries
LatLng..::..GetFixedLat Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetFixedLat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract int GetFixedLat()
Visual Basic
Public MustOverride Function GetFixedLat As Integer
Visual C++
public:
virtual int GetFixedLat() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetFixedLat"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetFixedLng Method

[image]

Lucene.Net Class Libraries
LatLng..::..GetFixedLng Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetFixedLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract int GetFixedLng()
Visual Basic
Public MustOverride Function GetFixedLng As Integer
Visual C++
public:
virtual int GetFixedLng() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetFixedLng"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
LatLng..::..GetHashCode Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract int GetHashCode()
Visual Basic
Public MustOverride Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetHashCode"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetLat Method

[image]

Lucene.Net Class Libraries
LatLng..::..GetLat Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetLat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract double GetLat()
Visual Basic
Public MustOverride Function GetLat As Double
Visual C++
public:
virtual double GetLat() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetLat"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


GetLng Method

[image]

Lucene.Net Class Libraries
LatLng..::..GetLng Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetLng"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract double GetLng()
Visual Basic
Public MustOverride Function GetLng As Double
Visual C++
public:
virtual double GetLng() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.GetLng"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


IsFixedPoint Method

[image]

Lucene.Net Class Libraries
LatLng..::..IsFixedPoint Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.IsFixedPoint"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract bool IsFixedPoint()
Visual Basic
Public MustOverride Function IsFixedPoint As Boolean
Visual C++
public:
virtual bool IsFixedPoint() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.IsFixedPoint"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


IsNormalized Method

[image]

Lucene.Net Class Libraries
LatLng..::..IsNormalized Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.IsNormalized"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract bool IsNormalized()
Visual Basic
Public MustOverride Function IsNormalized As Boolean
Visual C++
public:
virtual bool IsNormalized() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.IsNormalized"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


Normalize Method

[image]

Lucene.Net Class Libraries
LatLng..::..Normalize Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Normalize"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract LatLng Normalize()
Visual Basic
Public MustOverride Function Normalize As LatLng
Visual C++
public:
virtual LatLng^ Normalize() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.Normalize"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToCartesian Method

[image]

Lucene.Net Class Libraries
LatLng..::..ToCartesian Method
LatLng Class See Also Send Feedback
Convert the lat/lng into the cartesian coordinate plane such that all world coordinates are represented in the first quadrant. The x dimension corresponds to latitude and y corresponds to longitude. The translation starts with the normalized latlng and adds 180 to the latitude and 90 to the longitude (subject to fixed point scaling).

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public CartesianPoint ToCartesian()
Visual Basic
Public Function ToCartesian As CartesianPoint
Visual C++
public:
CartesianPoint^ ToCartesian()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToCartesian"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToFixed Method

[image]

Lucene.Net Class Libraries
LatLng..::..ToFixed Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToFixed"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract FixedLatLng ToFixed()
Visual Basic
Public MustOverride Function ToFixed As FixedLatLng
Visual C++
public:
virtual FixedLatLng^ ToFixed() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToFixed"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToFloat Method

[image]

Lucene.Net Class Libraries
LatLng..::..ToFloat Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToFloat"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract FloatLatLng ToFloat()
Visual Basic
Public MustOverride Function ToFloat As FloatLatLng
Visual C++
public:
virtual FloatLatLng^ ToFloat() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToFloat"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


ToString Method

[image]

Lucene.Net Class Libraries
LatLng..::..ToString Method
LatLng Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToString"]

Namespace: Lucene.Net.Spatial.Geometry
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.LatLng.ToString"]

See Also

LatLng Class
Lucene.Net.Spatial.Geometry Namespace


Lucene.Net.Spatial.Geometry.Shape Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Spatial.Geometry.Shape Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Spatial.Geometry.Shape"]

Classes

 | Class | Description
Public class | Ellipse |
Public class | LineSegment | 2D line segment
Public class | LLRect | Lat-long rect. Instances are mutable.
Public class | Point2D | Point class. This type is mutable.
Public class | Rectangle |
Public class | Vector2D | 2D Vector

Enumerations

 | Enumeration | Description
Public enumeration | IntersectCase |


Ellipse Class

[image]

Lucene.Net Class Libraries
Ellipse Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.Shape.Ellipse"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class Ellipse : IGeometry2D
Visual Basic
Public Class Ellipse _
    Implements IGeometry2D
Visual C++
public ref class Ellipse : IGeometry2D

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry.Shape..::..Ellipse

See Also

Ellipse Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Ellipse Members

[image] [image]

Lucene.Net Class Libraries
Ellipse Members
Ellipse Class Constructors Methods See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

 | Name | Description
Public method | Ellipse()()()() | Initializes a new instance of the Ellipse class
Public method | Ellipse(Point2D, Point2D, Double) | Constructor given bounding rectangle and a rotation.

Methods

 | Name | Description
Public method | Area |
Public method | Centroid |
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Rectangle) |
Public method | Intersect(LineSegment, Point2D, Point2D) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate |

See Also

Ellipse Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Ellipse Constructor

[image] [image]

Lucene.Net Class Libraries
Ellipse Constructor
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Ellipse()()()() | Initializes a new instance of the Ellipse class
Public method | Ellipse(Point2D, Point2D, Double) | Constructor given bounding rectangle and a rotation.

See Also

Ellipse Class
Ellipse Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Ellipse Constructor

[image]

Lucene.Net Class Libraries
Ellipse Constructor
Ellipse Class See Also Send Feedback
Initializes a new instance of the Ellipse class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Ellipse()
Visual Basic
Public Sub New
Visual C++
public:
Ellipse()

See Also

Ellipse Class
Ellipse Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Ellipse Constructor (Point2D, Point2D, Double)

[image]

Lucene.Net Class Libraries
Ellipse Constructor (Point2D, Point2D, Double)
Ellipse Class See Also Send Feedback
Constructor given bounding rectangle and a rotation.

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Ellipse(
    Point2D p1,
    Point2D p2,
    double angle
)
Visual Basic
Public Sub New ( _
    p1 As Point2D, _
    p2 As Point2D, _
    angle As Double _
)
Visual C++
public:
Ellipse(
    Point2D^ p1,
    Point2D^ p2,
    double angle
)

Parameters

p1
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D
The point 1.
p2
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D
The point 2.
angle
Type: System..::..Double
The angle.

See Also

Ellipse Class
Ellipse Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Ellipse Methods

[image] [image]

Lucene.Net Class Libraries
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | Area |
Public method | Centroid |
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Rectangle) |
Public method | Intersect(LineSegment, Point2D, Point2D) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate |

See Also

Ellipse Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Area Method

[image]

Lucene.Net Class Libraries
Ellipse..::..Area Method
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Area"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Area()
Visual Basic
Public Function Area As Double
Visual C++
public:
virtual double Area() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Area"]

See Also

Ellipse Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Centroid Method

[image]

Lucene.Net Class Libraries
Ellipse..::..Centroid Method
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Centroid"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D Centroid()
Visual Basic
Public Function Centroid As Point2D
Visual C++
public:
virtual Point2D^ Centroid() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Centroid"]

See Also

Ellipse Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Contains Method

[image]

Lucene.Net Class Libraries
Ellipse..::..Contains Method
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Contains(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public bool Contains(
    Point2D point
)
Visual Basic
Public Function Contains ( _
    point As Point2D _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Point2D^ point
) sealed

Parameters

point
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="point"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Contains(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Contains(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Ellipse Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Intersect Method

[image] [image]

Lucene.Net Class Libraries
Ellipse..::..Intersect Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Intersect(Rectangle) |
Public method | Intersect(LineSegment, Point2D, Point2D) |

See Also

Ellipse Class
Ellipse Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Intersect Method (Rectangle)

[image]

Lucene.Net Class Libraries
Ellipse..::..Intersect Method (Rectangle)
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.Rectangle)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public IntersectCase Intersect(
    Rectangle rectangle
)
Visual Basic
Public Function Intersect ( _
    rectangle As Rectangle _
) As IntersectCase
Visual C++
public:
virtual IntersectCase Intersect(
    Rectangle^ rectangle
) sealed

Parameters

rectangle
Type: Lucene.Net.Spatial.Geometry.Shape..::..Rectangle

[Missing <param name="rectangle"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.Rectangle)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.Rectangle)"]

See Also

Ellipse Class
Intersect Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Intersect Method (LineSegment, Point2D, Point2D)

[image]

Lucene.Net Class Libraries
Ellipse..::..Intersect Method (LineSegment, Point2D, Point2D)
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.LineSegment,Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public int Intersect(
    LineSegment seg,
    Point2D pt0,
    Point2D pt1
)
Visual Basic
Public Function Intersect ( _
    seg As LineSegment, _
    pt0 As Point2D, _
    pt1 As Point2D _
) As Integer
Visual C++
public:
int Intersect(
    LineSegment^ seg,
    Point2D^ pt0,
    Point2D^ pt1
)

Parameters

seg
Type: Lucene.Net.Spatial.Geometry.Shape..::..LineSegment

[Missing <param name="seg"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.LineSegment,Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

pt0
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="pt0"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.LineSegment,Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

pt1
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="pt1"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.LineSegment,Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Intersect(Lucene.Net.Spatial.Geometry.Shape.LineSegment,Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Ellipse Class
Intersect Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Translate Method

[image]

Lucene.Net Class Libraries
Ellipse..::..Translate Method
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Translate(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Translate(
    Vector2D vector
)
Visual Basic
Public Sub Translate ( _
    vector As Vector2D _
)
Visual C++
public:
virtual void Translate(
    Vector2D^ vector
) sealed

Parameters

vector
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="vector"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Ellipse.Translate(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Ellipse Class
Lucene.Net.Spatial.Geometry.Shape Namespace


IntersectCase Enumeration

[image]

Lucene.Net Class Libraries
IntersectCase Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.Shape.IntersectCase"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public enum IntersectCase
Visual Basic
Public Enumeration IntersectCase
Visual C++
public enum class IntersectCase

Members

Member name | Value | Description
WITHIN | 0 |
CONTAINS | 1 |
OUTSIDE | 2 |
INTERSECTS | 3 |

See Also

Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Class

[image]

Lucene.Net Class Libraries
LineSegment Class
Members See Also Send Feedback
2D line segment

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class LineSegment
Visual Basic
Public Class LineSegment
Visual C++
public ref class LineSegment

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry.Shape..::..LineSegment

See Also

LineSegment Members
Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Members

[image] [image]

Lucene.Net Class Libraries
LineSegment Members
LineSegment Class Constructors Methods Fields See Also Send Feedback

The LineSegment type exposes the following members.

Constructors

 | Name | Description
Public method | LineSegment()()()() | Initializes a new instance of the LineSegment class
Public method | LineSegment(Point2D, Point2D) | Initializes a new instance of the LineSegment class

Methods

 | Name | Description
Public method | Distance | Finds the distance of a specified point from the line segment and the closest point on the segment to the specified point.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | A |
Public field | B |

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Constructor

[image] [image]

Lucene.Net Class Libraries
LineSegment Constructor
LineSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LineSegment()()()() | Initializes a new instance of the LineSegment class
Public method | LineSegment(Point2D, Point2D) | Initializes a new instance of the LineSegment class

See Also

LineSegment Class
LineSegment Members
Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Constructor

[image]

Lucene.Net Class Libraries
LineSegment Constructor
LineSegment Class See Also Send Feedback
Initializes a new instance of the LineSegment class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LineSegment()
Visual Basic
Public Sub New
Visual C++
public:
LineSegment()

See Also

LineSegment Class
LineSegment Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Constructor (Point2D, Point2D)

[image]

Lucene.Net Class Libraries
LineSegment Constructor (Point2D, Point2D)
LineSegment Class See Also Send Feedback
Initializes a new instance of the LineSegment class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LineSegment(
    Point2D p1,
    Point2D p2
)
Visual Basic
Public Sub New ( _
    p1 As Point2D, _
    p2 As Point2D _
)
Visual C++
public:
LineSegment(
    Point2D^ p1,
    Point2D^ p2
)

Parameters

p1
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="p1"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

p2
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="p2"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

LineSegment Class
LineSegment Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Fields

[image] [image]

Lucene.Net Class Libraries
LineSegment Fields
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Fields

 | Name | Description
Public field | A |
Public field | B |

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


A Field

[image]

Lucene.Net Class Libraries
LineSegment..::..A Field
LineSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Geometry.Shape.LineSegment.A"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public readonly Point2D A
Visual Basic
Public ReadOnly A As Point2D
Visual C++
public:
initonly Point2D^ A

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


B Field

[image]

Lucene.Net Class Libraries
LineSegment..::..B Field
LineSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Geometry.Shape.LineSegment.B"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public readonly Point2D B
Visual Basic
Public ReadOnly B As Point2D
Visual C++
public:
initonly Point2D^ B

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


LineSegment Methods

[image] [image]

Lucene.Net Class Libraries
LineSegment Methods
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Methods

 | Name | Description
Public method | Distance | Finds the distance of a specified point from the line segment and the closest point on the segment to the specified point.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Distance Method

[image]

Lucene.Net Class Libraries
LineSegment..::..Distance Method
LineSegment Class See Also Send Feedback
Finds the distance of a specified point from the line segment and the closest point on the segment to the specified point.

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Distance(
    Point2D p,
    Point2D closestPt
)
Visual Basic
Public Function Distance ( _
    p As Point2D, _
    closestPt As Point2D _
) As Double
Visual C++
public:
double Distance(
    Point2D^ p,
    Point2D^ closestPt
)

Parameters

p
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D
The test point.
closestPt
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D
Closest point on the segment to c.

Return Value

Returns the distance from p to the closest point on the segment.

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Equals Method

[image]

Lucene.Net Class Libraries
LineSegment..::..Equals Method
LineSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.Equals(System.Object)"]

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
LineSegment..::..GetHashCode Method
LineSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LineSegment.GetHashCode"]

See Also

LineSegment Class
Lucene.Net.Spatial.Geometry.Shape Namespace


LLRect Class

[image]

Lucene.Net Class Libraries
LLRect Class
Members See Also Send Feedback
Lat-long rect. Instances are mutable.

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class LLRect
Visual Basic
Public Class LLRect
Visual C++
public ref class LLRect

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry.Shape..::..LLRect

See Also

LLRect Members
Lucene.Net.Spatial.Geometry.Shape Namespace


LLRect Members

[image] [image]

Lucene.Net Class Libraries
LLRect Members
LLRect Class Constructors Methods See Also Send Feedback

The LLRect type exposes the following members.

Constructors

 | Name | Description
Public method | LLRect(LLRect) | Initializes a new instance of the LLRect class
Public method | LLRect(LatLng, LatLng) | Initializes a new instance of the LLRect class

Methods

 | Name | Description
Public method | Area | Return the area in units of lat-lng squared. This is a contrived unit that only has value when comparing to something else.
 | CreateBox | Approximates a box centered at the given point with the given width and height in miles.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLowerLeft |
Public method | GetMidpoint |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpperRight |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToRectangle |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


LLRect Constructor

[image] [image]

Lucene.Net Class Libraries
LLRect Constructor
LLRect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LLRect(LLRect) | Initializes a new instance of the LLRect class
Public method | LLRect(LatLng, LatLng) | Initializes a new instance of the LLRect class

See Also

LLRect Class
LLRect Members
Lucene.Net.Spatial.Geometry.Shape Namespace


LLRect Constructor (LLRect)

[image]

Lucene.Net Class Libraries
LLRect Constructor (LLRect)
LLRect Class See Also Send Feedback
Initializes a new instance of the LLRect class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LLRect(
    LLRect other
)
Visual Basic
Public Sub New ( _
    other As LLRect _
)
Visual C++
public:
LLRect(
    LLRect^ other
)

Parameters

other
Type: Lucene.Net.Spatial.Geometry.Shape..::..LLRect

[Missing <param name="other"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.#ctor(Lucene.Net.Spatial.Geometry.Shape.LLRect)"]

See Also

LLRect Class
LLRect Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


LLRect Constructor (LatLng, LatLng)

[image]

Lucene.Net Class Libraries
LLRect Constructor (LatLng, LatLng)
LLRect Class See Also Send Feedback
Initializes a new instance of the LLRect class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LLRect(
    LatLng ll,
    LatLng ur
)
Visual Basic
Public Sub New ( _
    ll As LatLng, _
    ur As LatLng _
)
Visual C++
public:
LLRect(
    LatLng^ ll,
    LatLng^ ur
)

Parameters

ll
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="ll"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.#ctor(Lucene.Net.Spatial.Geometry.LatLng,Lucene.Net.Spatial.Geometry.LatLng)"]

ur
Type: Lucene.Net.Spatial.Geometry..::..LatLng

[Missing <param name="ur"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.#ctor(Lucene.Net.Spatial.Geometry.LatLng,Lucene.Net.Spatial.Geometry.LatLng)"]

See Also

LLRect Class
LLRect Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


LLRect Methods

[image] [image]

Lucene.Net Class Libraries
LLRect Methods
LLRect Class See Also Send Feedback

The LLRect type exposes the following members.

Methods

 | Name | Description
Public method | Area | Return the area in units of lat-lng squared. This is a contrived unit that only has value when comparing to something else.
 | CreateBox | Approximates a box centered at the given point with the given width and height in miles.
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLowerLeft |
Public method | GetMidpoint |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpperRight |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToRectangle |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Area Method

[image]

Lucene.Net Class Libraries
LLRect..::..Area Method
LLRect Class See Also Send Feedback
Return the area in units of lat-lng squared. This is a contrived unit that only has value when comparing to something else.

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Area()
Visual Basic
Public Function Area As Double
Visual C++
public:
double Area()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.Area"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


CreateBox Method

[image]

Lucene.Net Class Libraries
LLRect..::..CreateBox Method
LLRect Class See Also Send Feedback
Approximates a box centered at the given point with the given width and height in miles.

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static LLRect CreateBox(
    LatLng center,
    double widthMi,
    double heightMi
)
Visual Basic
Public Shared Function CreateBox ( _
    center As LatLng, _
    widthMi As Double, _
    heightMi As Double _
) As LLRect
Visual C++
public:
static LLRect^ CreateBox(
    LatLng^ center,
    double widthMi,
    double heightMi
)

Parameters

center
Type: Lucene.Net.Spatial.Geometry..::..LatLng
The center.
widthMi
Type: System..::..Double
The width mi.
heightMi
Type: System..::..Double
The height mi.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.CreateBox(Lucene.Net.Spatial.Geometry.LatLng,System.Double,System.Double)"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Equals Method

[image]

Lucene.Net Class Libraries
LLRect..::..Equals Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.Equals(System.Object)"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
LLRect..::..GetHashCode Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetHashCode"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetLowerLeft Method

[image]

Lucene.Net Class Libraries
LLRect..::..GetLowerLeft Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetLowerLeft"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LatLng GetLowerLeft()
Visual Basic
Public Function GetLowerLeft As LatLng
Visual C++
public:
LatLng^ GetLowerLeft()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetLowerLeft"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetMidpoint Method

[image]

Lucene.Net Class Libraries
LLRect..::..GetMidpoint Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetMidpoint"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LatLng GetMidpoint()
Visual Basic
Public Function GetMidpoint As LatLng
Visual C++
public:
LatLng^ GetMidpoint()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetMidpoint"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetUpperRight Method

[image]

Lucene.Net Class Libraries
LLRect..::..GetUpperRight Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetUpperRight"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LatLng GetUpperRight()
Visual Basic
Public Function GetUpperRight As LatLng
Visual C++
public:
LatLng^ GetUpperRight()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.GetUpperRight"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


ToRectangle Method

[image]

Lucene.Net Class Libraries
LLRect..::..ToRectangle Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.ToRectangle"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Rectangle ToRectangle()
Visual Basic
Public Function ToRectangle As Rectangle
Visual C++
public:
Rectangle^ ToRectangle()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.ToRectangle"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


ToString Method

[image]

Lucene.Net Class Libraries
LLRect..::..ToString Method
LLRect Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.ToString"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.LLRect.ToString"]

See Also

LLRect Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Class

[image]

Lucene.Net Class Libraries
Point2D Class
Members See Also Send Feedback
Point class. This type is mutable.

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class Point2D
Visual Basic
Public Class Point2D
Visual C++
public ref class Point2D

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry.Shape..::..Point2D

See Also

Point2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Members

[image] [image]

Lucene.Net Class Libraries
Point2D Members
Point2D Class Constructors Methods Properties See Also Send Feedback

The Point2D type exposes the following members.

Constructors

 | Name | Description
Public method | Point2D()()()() | Initializes a new instance of the Point2D class
Public method | Point2D(Point2D) | Initializes a new instance of the Point2D class
Public method | Point2D(Double, Double) | Initializes a new instance of the Point2D class

Methods

 | Name | Description
Public method | Add(Point2D) |
Public method | Add(Vector2D) |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(Point2D) |
Public method | Set(Vector2D) |
Public method | Set(Double, Double) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | X |
Public property | Y |

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Constructor

[image] [image]

Lucene.Net Class Libraries
Point2D Constructor
Point2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Point2D()()()() | Initializes a new instance of the Point2D class
Public method | Point2D(Point2D) | Initializes a new instance of the Point2D class
Public method | Point2D(Double, Double) | Initializes a new instance of the Point2D class

See Also

Point2D Class
Point2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Constructor

[image]

Lucene.Net Class Libraries
Point2D Constructor
Point2D Class See Also Send Feedback
Initializes a new instance of the Point2D class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D()
Visual Basic
Public Sub New
Visual C++
public:
Point2D()

See Also

Point2D Class
Point2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Constructor (Point2D)

[image]

Lucene.Net Class Libraries
Point2D Constructor (Point2D)
Point2D Class See Also Send Feedback
Initializes a new instance of the Point2D class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D(
    Point2D other
)
Visual Basic
Public Sub New ( _
    other As Point2D _
)
Visual C++
public:
Point2D(
    Point2D^ other
)

Parameters

other
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="other"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Point2D Class
Point2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Constructor (Double, Double)

[image]

Lucene.Net Class Libraries
Point2D Constructor (Double, Double)
Point2D Class See Also Send Feedback
Initializes a new instance of the Point2D class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D(
    double x,
    double y
)
Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
Point2D(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.#ctor(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.#ctor(System.Double,System.Double)"]

See Also

Point2D Class
Point2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Methods

[image] [image]

Lucene.Net Class Libraries
Point2D Methods
Point2D Class See Also Send Feedback

The Point2D type exposes the following members.

Methods

 | Name | Description
Public method | Add(Point2D) |
Public method | Add(Vector2D) |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(Point2D) |
Public method | Set(Vector2D) |
Public method | Set(Double, Double) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Add Method

[image] [image]

Lucene.Net Class Libraries
Point2D..::..Add Method
Point2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Point2D) |
Public method | Add(Vector2D) |

See Also

Point2D Class
Point2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Add Method (Point2D)

[image]

Lucene.Net Class Libraries
Point2D..::..Add Method (Point2D)
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Add(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Add(
    Point2D a
)
Visual Basic
Public Sub Add ( _
    a As Point2D _
)
Visual C++
public:
void Add(
    Point2D^ a
)

Parameters

a
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="a"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Add(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Point2D Class
Add Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Add Method (Vector2D)

[image]

Lucene.Net Class Libraries
Point2D..::..Add Method (Vector2D)
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Add(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Add(
    Vector2D v
)
Visual Basic
Public Sub Add ( _
    v As Vector2D _
)
Visual C++
public:
void Add(
    Vector2D^ v
)

Parameters

v
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="v"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Add(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Point2D Class
Add Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Point2D..::..Equals Method
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Equals(System.Object)"]

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Point2D..::..GetHashCode Method
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.GetHashCode"]

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Set Method

[image] [image]

Lucene.Net Class Libraries
Point2D..::..Set Method
Point2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Point2D) |
Public method | Set(Vector2D) |
Public method | Set(Double, Double) |

See Also

Point2D Class
Point2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Set Method (Point2D)

[image]

Lucene.Net Class Libraries
Point2D..::..Set Method (Point2D)
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Set(
    Point2D p1
)
Visual Basic
Public Sub Set ( _
    p1 As Point2D _
)
Visual C++
public:
void Set(
    Point2D^ p1
)

Parameters

p1
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="p1"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Point2D Class
Set Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Set Method (Vector2D)

[image]

Lucene.Net Class Libraries
Point2D..::..Set Method (Vector2D)
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Set(
    Vector2D v
)
Visual Basic
Public Sub Set ( _
    v As Vector2D _
)
Visual C++
public:
void Set(
    Vector2D^ v
)

Parameters

v
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="v"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Point2D Class
Set Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Set Method (Double, Double)

[image]

Lucene.Net Class Libraries
Point2D..::..Set Method (Double, Double)
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Set(
    double x,
    double y
)
Visual Basic
Public Sub Set ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Set(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.Set(System.Double,System.Double)"]

See Also

Point2D Class
Set Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Point2D..::..ToString Method
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.ToString"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Point2D.ToString"]

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Point2D Properties

[image] [image]

Lucene.Net Class Libraries
Point2D Properties
Point2D Class See Also Send Feedback

The Point2D type exposes the following members.

Properties

 | Name | Description
Public property | X |
Public property | Y |

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


X Property

[image]

Lucene.Net Class Libraries
Point2D..::..X Property
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.Shape.Point2D.X"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double X { get; set; }
Visual Basic
Public Property X As Double
    Get
    Set
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Y Property

[image]

Lucene.Net Class Libraries
Point2D..::..Y Property
Point2D Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.Shape.Point2D.Y"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Y { get; set; }
Visual Basic
Public Property Y As Double
    Get
    Set
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

Point2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Class

[image]

Lucene.Net Class Libraries
Rectangle Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Geometry.Shape.Rectangle"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class Rectangle : IGeometry2D
Visual Basic
Public Class Rectangle _
    Implements IGeometry2D
Visual C++
public ref class Rectangle : IGeometry2D

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry.Shape..::..Rectangle

See Also

Rectangle Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Members

[image] [image]

Lucene.Net Class Libraries
Rectangle Members
Rectangle Class Constructors Methods Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle()()()() | Initializes a new instance of the Rectangle class
Public method | Rectangle(Point2D, Point2D) | Initializes a new instance of the Rectangle class
Public method | Rectangle(Double, Double, Double, Double) | Initializes a new instance of the Rectangle class

Methods

 | Name | Description
Public method | Area |
Public method | Centroid |
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Translate |

Properties

 | Name | Description
Public property | MaxPt |
Public property | MinPt |

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Constructor

[image] [image]

Lucene.Net Class Libraries
Rectangle Constructor
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rectangle()()()() | Initializes a new instance of the Rectangle class
Public method | Rectangle(Point2D, Point2D) | Initializes a new instance of the Rectangle class
Public method | Rectangle(Double, Double, Double, Double) | Initializes a new instance of the Rectangle class

See Also

Rectangle Class
Rectangle Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Constructor

[image]

Lucene.Net Class Libraries
Rectangle Constructor
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Rectangle()
Visual Basic
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
Rectangle Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Constructor (Point2D, Point2D)

[image]

Lucene.Net Class Libraries
Rectangle Constructor (Point2D, Point2D)
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Rectangle(
    Point2D minPt,
    Point2D maxPt
)
Visual Basic
Public Sub New ( _
    minPt As Point2D, _
    maxPt As Point2D _
)
Visual C++
public:
Rectangle(
    Point2D^ minPt,
    Point2D^ maxPt
)

Parameters

minPt
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="minPt"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

maxPt
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="maxPt"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Rectangle Class
Rectangle Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Constructor (Double, Double, Double, Double)

[image]

Lucene.Net Class Libraries
Rectangle Constructor (Double, Double, Double, Double)
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Rectangle(
    double x1,
    double y1,
    double x2,
    double y2
)
Visual Basic
Public Sub New ( _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
)
Visual C++
public:
Rectangle(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::..Double

[Missing <param name="x1"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

y1
Type: System..::..Double

[Missing <param name="y1"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

x2
Type: System..::..Double

[Missing <param name="x2"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

y2
Type: System..::..Double

[Missing <param name="y2"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

See Also

Rectangle Class
Rectangle Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Methods

[image] [image]

Lucene.Net Class Libraries
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | Area |
Public method | Centroid |
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Translate |

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Area Method

[image]

Lucene.Net Class Libraries
Rectangle..::..Area Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Area"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Area()
Visual Basic
Public Function Area As Double
Visual C++
public:
virtual double Area() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Area"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Centroid Method

[image]

Lucene.Net Class Libraries
Rectangle..::..Centroid Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Centroid"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D Centroid()
Visual Basic
Public Function Centroid As Point2D
Visual C++
public:
virtual Point2D^ Centroid() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Centroid"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Contains Method

[image]

Lucene.Net Class Libraries
Rectangle..::..Contains Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Contains(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public bool Contains(
    Point2D point
)
Visual Basic
Public Function Contains ( _
    point As Point2D _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Point2D^ point
) sealed

Parameters

point
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="point"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Contains(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Contains(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Rectangle..::..GetHashCode Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.GetHashCode"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Intersect Method

[image]

Lucene.Net Class Libraries
Rectangle..::..Intersect Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Intersect(Lucene.Net.Spatial.Geometry.Shape.Rectangle)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public IntersectCase Intersect(
    Rectangle rectangle
)
Visual Basic
Public Function Intersect ( _
    rectangle As Rectangle _
) As IntersectCase
Visual C++
public:
virtual IntersectCase Intersect(
    Rectangle^ rectangle
) sealed

Parameters

rectangle
Type: Lucene.Net.Spatial.Geometry.Shape..::..Rectangle

[Missing <param name="rectangle"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Intersect(Lucene.Net.Spatial.Geometry.Shape.Rectangle)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Intersect(Lucene.Net.Spatial.Geometry.Shape.Rectangle)"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Rectangle..::..ToString Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.ToString"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.ToString"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Translate Method

[image]

Lucene.Net Class Libraries
Rectangle..::..Translate Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Translate(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Translate(
    Vector2D vector
)
Visual Basic
Public Sub Translate ( _
    vector As Vector2D _
)
Visual C++
public:
virtual void Translate(
    Vector2D^ vector
) sealed

Parameters

vector
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="vector"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Rectangle.Translate(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Rectangle Properties

[image] [image]

Lucene.Net Class Libraries
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | MaxPt |
Public property | MinPt |

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


MaxPt Property

[image]

Lucene.Net Class Libraries
Rectangle..::..MaxPt Property
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.Shape.Rectangle.MaxPt"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D MaxPt { get; set; }
Visual Basic
Public Property MaxPt As Point2D
    Get
    Set
Visual C++
public:
property Point2D^ MaxPt {
    Point2D^ get ();
    void set (Point2D^ value);
}

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


MinPt Property

[image]

Lucene.Net Class Libraries
Rectangle..::..MinPt Property
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.Shape.Rectangle.MinPt"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Point2D MinPt { get; set; }
Visual Basic
Public Property MinPt As Point2D
    Get
    Set
Visual C++
public:
property Point2D^ MinPt {
    Point2D^ get ();
    void set (Point2D^ value);
}

See Also

Rectangle Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Class

[image]

Lucene.Net Class Libraries
Vector2D Class
Members See Also Send Feedback
2D Vector

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class Vector2D
Visual Basic
Public Class Vector2D
Visual C++
public ref class Vector2D

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

See Also

Vector2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Members

[image] [image]

Lucene.Net Class Libraries
Vector2D Members
Vector2D Class Constructors Methods Properties See Also Send Feedback

The Vector2D type exposes the following members.

Constructors

 | Name | Description
Public method | Vector2D()()()() | Initializes a new instance of the Vector2D class
Public method | Vector2D(Point2D) | Create a vector from the origin of the coordinate system to the given point
Public method | Vector2D(Vector2D) | Initializes a new instance of the Vector2D class
Public method | Vector2D(Double, Double) | Create a vector from the origin of the coordinate system to the given point
Public method | Vector2D(Point2D, Point2D) | Create a vector from one point to another

Methods

 | Name | Description
Public method | Dot |
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(Vector2D) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mult |
Public method | Norm |
Public method | NormSqr | Vector length (magnitude) squared
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | X |
Public property | Y |

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Constructor

[image] [image]

Lucene.Net Class Libraries
Vector2D Constructor
Vector2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector2D()()()() | Initializes a new instance of the Vector2D class
Public method | Vector2D(Point2D) | Create a vector from the origin of the coordinate system to the given point
Public method | Vector2D(Vector2D) | Initializes a new instance of the Vector2D class
Public method | Vector2D(Double, Double) | Create a vector from the origin of the coordinate system to the given point
Public method | Vector2D(Point2D, Point2D) | Create a vector from one point to another

See Also

Vector2D Class
Vector2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Constructor

[image]

Lucene.Net Class Libraries
Vector2D Constructor
Vector2D Class See Also Send Feedback
Initializes a new instance of the Vector2D class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Vector2D()
Visual Basic
Public Sub New
Visual C++
public:
Vector2D()

See Also

Vector2D Class
Vector2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Constructor (Point2D)

[image]

Lucene.Net Class Libraries
Vector2D Constructor (Point2D)
Vector2D Class See Also Send Feedback
Create a vector from the origin of the coordinate system to the given point

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Vector2D(
    Point2D p
)
Visual Basic
Public Sub New ( _
    p As Point2D _
)
Visual C++
public:
Vector2D(
    Point2D^ p
)

Parameters

p
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="p"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Vector2D Class
Vector2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Constructor (Vector2D)

[image]

Lucene.Net Class Libraries
Vector2D Constructor (Vector2D)
Vector2D Class See Also Send Feedback
Initializes a new instance of the Vector2D class

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Vector2D(
    Vector2D other
)
Visual Basic
Public Sub New ( _
    other As Vector2D _
)
Visual C++
public:
Vector2D(
    Vector2D^ other
)

Parameters

other
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="other"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.#ctor(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Vector2D Class
Vector2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Constructor (Double, Double)

[image]

Lucene.Net Class Libraries
Vector2D Constructor (Double, Double)
Vector2D Class See Also Send Feedback
Create a vector from the origin of the coordinate system to the given point

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Vector2D(
    double x,
    double y
)
Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
Vector2D(
    double x,
    double y
)

Parameters

x
Type: System..::..Double
The x.
y
Type: System..::..Double
The y.

See Also

Vector2D Class
Vector2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Constructor (Point2D, Point2D)

[image]

Lucene.Net Class Libraries
Vector2D Constructor (Point2D, Point2D)
Vector2D Class See Also Send Feedback
Create a vector from one point to another

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Vector2D(
    Point2D from,
    Point2D to
)
Visual Basic
Public Sub New ( _
    from As Point2D, _
    to As Point2D _
)
Visual C++
public:
Vector2D(
    Point2D^ from,
    Point2D^ to
)

Parameters

from
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="from"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

to
Type: Lucene.Net.Spatial.Geometry.Shape..::..Point2D

[Missing <param name="to"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.#ctor(Lucene.Net.Spatial.Geometry.Shape.Point2D,Lucene.Net.Spatial.Geometry.Shape.Point2D)"]

See Also

Vector2D Class
Vector2D Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Methods

[image] [image]

Lucene.Net Class Libraries
Vector2D Methods
Vector2D Class See Also Send Feedback

The Vector2D type exposes the following members.

Methods

 | Name | Description
Public method | Dot |
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(Vector2D) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mult |
Public method | Norm |
Public method | NormSqr | Vector length (magnitude) squared
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Dot Method

[image]

Lucene.Net Class Libraries
Vector2D..::..Dot Method
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Dot(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Dot(
    Vector2D v
)
Visual Basic
Public Function Dot ( _
    v As Vector2D _
) As Double
Visual C++
public:
double Dot(
    Vector2D^ v
)

Parameters

v
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="v"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Dot(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Dot(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Equals Method

[image] [image]

Lucene.Net Class Libraries
Vector2D..::..Equals Method
Vector2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(Vector2D) |

See Also

Vector2D Class
Vector2D Members
Lucene.Net.Spatial.Geometry.Shape Namespace


Equals Method (Object)

[image]

Lucene.Net Class Libraries
Vector2D..::..Equals Method (Object)
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Equals(System.Object)"]

See Also

Vector2D Class
Equals Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


Equals Method (Vector2D)

[image]

Lucene.Net Class Libraries
Vector2D..::..Equals Method (Vector2D)
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Equals(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public bool Equals(
    Vector2D other
)
Visual Basic
Public Function Equals ( _
    other As Vector2D _
) As Boolean
Visual C++
public:
bool Equals(
    Vector2D^ other
)

Parameters

other
Type: Lucene.Net.Spatial.Geometry.Shape..::..Vector2D

[Missing <param name="other"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Equals(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Equals(Lucene.Net.Spatial.Geometry.Shape.Vector2D)"]

See Also

Vector2D Class
Equals Overload
Lucene.Net.Spatial.Geometry.Shape Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
Vector2D..::..GetHashCode Method
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.GetHashCode"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.GetHashCode"]

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Mult Method

[image]

Lucene.Net Class Libraries
Vector2D..::..Mult Method
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Mult(System.Double)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Vector2D Mult(
    double d
)
Visual Basic
Public Function Mult ( _
    d As Double _
) As Vector2D
Visual C++
public:
Vector2D^ Mult(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Mult(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Mult(System.Double)"]

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Norm Method

[image]

Lucene.Net Class Libraries
Vector2D..::..Norm Method
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Norm"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Norm()
Visual Basic
Public Function Norm As Double
Visual C++
public:
double Norm()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Norm"]

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


NormSqr Method

[image]

Lucene.Net Class Libraries
Vector2D..::..NormSqr Method
Vector2D Class See Also Send Feedback
Vector length (magnitude) squared

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double NormSqr()
Visual Basic
Public Function NormSqr As Double
Visual C++
public:
double NormSqr()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.NormSqr"]

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Set Method

[image]

Lucene.Net Class Libraries
Vector2D..::..Set Method
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Set(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Set(
    double x,
    double y
)
Visual Basic
Public Sub Set ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Set(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Set(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Set(System.Double,System.Double)"]

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Vector2D Properties

[image] [image]

Lucene.Net Class Libraries
Vector2D Properties
Vector2D Class See Also Send Feedback

The Vector2D type exposes the following members.

Properties

 | Name | Description
Public property | X |
Public property | Y |

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


X Property

[image]

Lucene.Net Class Libraries
Vector2D..::..X Property
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.Shape.Vector2D.X"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double X { get; set; }
Visual Basic
Public Property X As Double
    Get
    Set
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Y Property

[image]

Lucene.Net Class Libraries
Vector2D..::..Y Property
Vector2D Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Geometry.Shape.Vector2D.Y"]

Namespace: Lucene.Net.Spatial.Geometry.Shape
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Y { get; set; }
Visual Basic
Public Property Y As Double
    Get
    Set
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

Vector2D Class
Lucene.Net.Spatial.Geometry.Shape Namespace


Lucene.Net.Spatial.Tier Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Spatial.Tier Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Spatial.Tier"]

Classes

 | Class | Description
Public class | CartesianPolyFilterBuilder |
Public class | CartesianShapeFilter |
Public class | DistanceFieldComparatorSource |
Public class | DistanceFilter |
Public class | DistanceHandler | Provide a high level access point to distances Used by DistanceSortSource and DistanceQuery
Public class | DistanceQueryBuilder |
Public class | DistanceUtils |
Public class | LatLongDistanceFilter |
Public class | Shape |

Enumerations

 | Enumeration | Description
Public enumeration | Precision |


CartesianPolyFilterBuilder Class

[image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class CartesianPolyFilterBuilder
Visual Basic
Public Class CartesianPolyFilterBuilder
Visual C++
public ref class CartesianPolyFilterBuilder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier..::..CartesianPolyFilterBuilder

See Also

CartesianPolyFilterBuilder Members
Lucene.Net.Spatial.Tier Namespace


CartesianPolyFilterBuilder Members

[image] [image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder Members
CartesianPolyFilterBuilder Class Constructors Methods Fields See Also Send Feedback

The CartesianPolyFilterBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | CartesianPolyFilterBuilder | Initializes a new instance of the CartesianPolyFilterBuilder class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoundingArea |
Public method | GetBoxShape |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeLoop |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MilesFloor | Finer granularity than 1 mile isn't accurate with standard C# math. Also, there's already a 2nd precise filter, if needed, in DistanceQueryBuilder, that will make the filtering exact.

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


CartesianPolyFilterBuilder Constructor

[image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder Constructor
CartesianPolyFilterBuilder Class See Also Send Feedback
Initializes a new instance of the CartesianPolyFilterBuilder class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public CartesianPolyFilterBuilder(
    string tierPrefix
)
Visual Basic
Public Sub New ( _
    tierPrefix As String _
)
Visual C++
public:
CartesianPolyFilterBuilder(
    String^ tierPrefix
)

Parameters

tierPrefix
Type: System..::..String

[Missing <param name="tierPrefix"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.#ctor(System.String)"]

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


CartesianPolyFilterBuilder Fields

[image] [image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder Fields
CartesianPolyFilterBuilder Class See Also Send Feedback

The CartesianPolyFilterBuilder type exposes the following members.

Fields

Name | Description
MilesFloor | Finer granularity than 1 mile isn't accurate with standard C# math. Also, there's already a 2nd precise filter, if needed, in DistanceQueryBuilder, that will make the filtering exact.

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


MilesFloor Field

[image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder..::..MilesFloor Field
CartesianPolyFilterBuilder Class See Also Send Feedback
Finer granularity than 1 mile isn't accurate with standard C# math. Also, there's already a 2nd precise filter, if needed, in DistanceQueryBuilder, that will make the filtering exact.

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double MilesFloor
Visual Basic
Public Shared MilesFloor As Double
Visual C++
public:
static double MilesFloor

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


CartesianPolyFilterBuilder Methods

[image] [image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder Methods
CartesianPolyFilterBuilder Class See Also Send Feedback

The CartesianPolyFilterBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoundingArea |
Public method | GetBoxShape |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeLoop |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


GetBoundingArea Method

[image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder..::..GetBoundingArea Method
CartesianPolyFilterBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoundingArea(System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Filter GetBoundingArea(
    double latitude,
    double longitude,
    double miles
)
Visual Basic
Public Function GetBoundingArea ( _
    latitude As Double, _
    longitude As Double, _
    miles As Double _
) As Filter
Visual C++
public:
Filter^ GetBoundingArea(
    double latitude,
    double longitude,
    double miles
)

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoundingArea(System.Double,System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoundingArea(System.Double,System.Double,System.Double)"]

miles
Type: System..::..Double

[Missing <param name="miles"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoundingArea(System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoundingArea(System.Double,System.Double,System.Double)"]

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


GetBoxShape Method

[image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder..::..GetBoxShape Method
CartesianPolyFilterBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoxShape(System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Shape GetBoxShape(
    double latitude,
    double longitude,
    double miles
)
Visual Basic
Public Function GetBoxShape ( _
    latitude As Double, _
    longitude As Double, _
    miles As Double _
) As Shape
Visual C++
public:
Shape^ GetBoxShape(
    double latitude,
    double longitude,
    double miles
)

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoxShape(System.Double,System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoxShape(System.Double,System.Double,System.Double)"]

miles
Type: System..::..Double

[Missing <param name="miles"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoxShape(System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetBoxShape(System.Double,System.Double,System.Double)"]

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


GetShapeLoop Method

[image]

Lucene.Net Class Libraries
CartesianPolyFilterBuilder..::..GetShapeLoop Method
CartesianPolyFilterBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Shape GetShapeLoop(
    Shape shape,
    CartesianTierPlotter ctp,
    double latX,
    double longX,
    double latY,
    double longY
)
Visual Basic
Public Function GetShapeLoop ( _
    shape As Shape, _
    ctp As CartesianTierPlotter, _
    latX As Double, _
    longX As Double, _
    latY As Double, _
    longY As Double _
) As Shape
Visual C++
public:
Shape^ GetShapeLoop(
    Shape^ shape,
    CartesianTierPlotter^ ctp,
    double latX,
    double longX,
    double latY,
    double longY
)

Parameters

shape
Type: Lucene.Net.Spatial.Tier..::..Shape

[Missing <param name="shape"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

ctp
Type: Lucene.Net.Spatial.Tier.Projectors..::..CartesianTierPlotter

[Missing <param name="ctp"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

latX
Type: System..::..Double

[Missing <param name="latX"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

longX
Type: System..::..Double

[Missing <param name="longX"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

latY
Type: System..::..Double

[Missing <param name="latY"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

longY
Type: System..::..Double

[Missing <param name="longY"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.CartesianPolyFilterBuilder.GetShapeLoop(Lucene.Net.Spatial.Tier.Shape,Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter,System.Double,System.Double,System.Double,System.Double)"]

See Also

CartesianPolyFilterBuilder Class
Lucene.Net.Spatial.Tier Namespace


CartesianShapeFilter Class

[image]

Lucene.Net Class Libraries
CartesianShapeFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.CartesianShapeFilter"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class CartesianShapeFilter : Filter
Visual Basic
Public Class CartesianShapeFilter _
    Inherits Filter
Visual C++
public ref class CartesianShapeFilter : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Spatial.Tier..::..CartesianShapeFilter

See Also

CartesianShapeFilter Members
Lucene.Net.Spatial.Tier Namespace


CartesianShapeFilter Members

[image] [image]

Lucene.Net Class Libraries
CartesianShapeFilter Members
CartesianShapeFilter Class Constructors Methods See Also Send Feedback

The CartesianShapeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CartesianShapeFilter | Initializes a new instance of the CartesianShapeFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CartesianShapeFilter Class
Lucene.Net.Spatial.Tier Namespace


CartesianShapeFilter Constructor

[image]

Lucene.Net Class Libraries
CartesianShapeFilter Constructor
CartesianShapeFilter Class See Also Send Feedback
Initializes a new instance of the CartesianShapeFilter class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public CartesianShapeFilter(
    Shape shape,
    string fieldName
)
Visual Basic
Public Sub New ( _
    shape As Shape, _
    fieldName As String _
)
Visual C++
public:
CartesianShapeFilter(
    Shape^ shape,
    String^ fieldName
)

Parameters

shape
Type: Lucene.Net.Spatial.Tier..::..Shape

[Missing <param name="shape"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianShapeFilter.#ctor(Lucene.Net.Spatial.Tier.Shape,System.String)"]

fieldName
Type: System..::..String

[Missing <param name="fieldName"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianShapeFilter.#ctor(Lucene.Net.Spatial.Tier.Shape,System.String)"]

See Also

CartesianShapeFilter Class
Lucene.Net.Spatial.Tier Namespace


CartesianShapeFilter Methods

[image] [image]

Lucene.Net Class Libraries
CartesianShapeFilter Methods
CartesianShapeFilter Class See Also Send Feedback

The CartesianShapeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CartesianShapeFilter Class
Lucene.Net.Spatial.Tier Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
CartesianShapeFilter..::..GetDocIdSet Method
CartesianShapeFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.CartesianShapeFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Spatial.Tier.CartesianShapeFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.CartesianShapeFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

CartesianShapeFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceFieldComparatorSource Class

[image]

Lucene.Net Class Libraries
DistanceFieldComparatorSource Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class DistanceFieldComparatorSource : FieldComparatorSource
Visual Basic
Public Class DistanceFieldComparatorSource _
    Inherits FieldComparatorSource
Visual C++
public ref class DistanceFieldComparatorSource : public FieldComparatorSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..FieldComparatorSource
Lucene.Net.Spatial.Tier..::..DistanceFieldComparatorSource

See Also

DistanceFieldComparatorSource Members
Lucene.Net.Spatial.Tier Namespace


DistanceFieldComparatorSource Members

[image] [image]

Lucene.Net Class Libraries
DistanceFieldComparatorSource Members
DistanceFieldComparatorSource Class Constructors Methods See Also Send Feedback

The DistanceFieldComparatorSource type exposes the following members.

Constructors

 | Name | Description
Public method | DistanceFieldComparatorSource | Initializes a new instance of the DistanceFieldComparatorSource class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewComparator | (Overrides FieldComparatorSource..::..NewComparator(String, Int32, Int32, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceFieldComparatorSource Class
Lucene.Net.Spatial.Tier Namespace


DistanceFieldComparatorSource Constructor

[image]

Lucene.Net Class Libraries
DistanceFieldComparatorSource Constructor
DistanceFieldComparatorSource Class See Also Send Feedback
Initializes a new instance of the DistanceFieldComparatorSource class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public DistanceFieldComparatorSource(
    DistanceFilter distanceFilter
)
Visual Basic
Public Sub New ( _
    distanceFilter As DistanceFilter _
)
Visual C++
public:
DistanceFieldComparatorSource(
    DistanceFilter^ distanceFilter
)

Parameters

distanceFilter
Type: Lucene.Net.Spatial.Tier..::..DistanceFilter

[Missing <param name="distanceFilter"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.#ctor(Lucene.Net.Spatial.Tier.DistanceFilter)"]

See Also

DistanceFieldComparatorSource Class
Lucene.Net.Spatial.Tier Namespace


DistanceFieldComparatorSource Methods

[image] [image]

Lucene.Net Class Libraries
DistanceFieldComparatorSource Methods
DistanceFieldComparatorSource Class See Also Send Feedback

The DistanceFieldComparatorSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewComparator | (Overrides FieldComparatorSource..::..NewComparator(String, Int32, Int32, Boolean).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceFieldComparatorSource Class
Lucene.Net.Spatial.Tier Namespace


NewComparator Method

[image]

Lucene.Net Class Libraries
DistanceFieldComparatorSource..::..NewComparator Method
DistanceFieldComparatorSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override FieldComparator NewComparator(
    string fieldname,
    int numHits,
    int sortPos,
    bool reversed
)
Visual Basic
Public Overrides Function NewComparator ( _
    fieldname As String, _
    numHits As Integer, _
    sortPos As Integer, _
    reversed As Boolean _
) As FieldComparator
Visual C++
public:
virtual FieldComparator^ NewComparator(
    String^ fieldname,
    int numHits,
    int sortPos,
    bool reversed
) override

Parameters

fieldname
Type: System..::..String

[Missing <param name="fieldname"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

numHits
Type: System..::..Int32

[Missing <param name="numHits"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

sortPos
Type: System..::..Int32

[Missing <param name="sortPos"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

reversed
Type: System..::..Boolean

[Missing <param name="reversed"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFieldComparatorSource.NewComparator(System.String,System.Int32,System.Int32,System.Boolean)"]

See Also

DistanceFieldComparatorSource Class
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Class

[image]

Lucene.Net Class Libraries
DistanceFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.DistanceFilter"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract class DistanceFilter : Filter
Visual Basic
Public MustInherit Class DistanceFilter _
    Inherits Filter
Visual C++
public ref class DistanceFilter abstract : public Filter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Spatial.Tier..::..DistanceFilter
Lucene.Net.Spatial.GeoHash..::..GeoHashDistanceFilter
Lucene.Net.Spatial.Tier..::..LatLongDistanceFilter

See Also

DistanceFilter Members
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Members

[image] [image]

Lucene.Net Class Libraries
DistanceFilter Members
DistanceFilter Class Constructors Methods Fields Properties See Also Send Feedback

The DistanceFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | DistanceFilter | Initializes a new instance of the DistanceFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance |
Public method | GetDocIdSet | Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment. (Inherited from Filter.)
Public method | GetHashCode |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | You must call this before re-using this DistanceFilter across searches
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | Distance |
Protected field | DistanceLookupCache |
Protected field | NextDocBase |
Protected field | Precision |
Protected field | StartingFilter |

Properties

 | Name | Description
Public property | Distances |

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Constructor

[image]

Lucene.Net Class Libraries
DistanceFilter Constructor
DistanceFilter Class See Also Send Feedback
Initializes a new instance of the DistanceFilter class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected DistanceFilter(
    Filter startingFilter,
    double distance
)
Visual Basic
Protected Sub New ( _
    startingFilter As Filter, _
    distance As Double _
)
Visual C++
protected:
DistanceFilter(
    Filter^ startingFilter,
    double distance
)

Parameters

startingFilter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="startingFilter"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double)"]

distance
Type: System..::..Double

[Missing <param name="distance"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double)"]

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Fields

[image] [image]

Lucene.Net Class Libraries
DistanceFilter Fields
DistanceFilter Class See Also Send Feedback

The DistanceFilter type exposes the following members.

Fields

 | Name | Description
Protected field | Distance |
Protected field | DistanceLookupCache |
Protected field | NextDocBase |
Protected field | Precision |
Protected field | StartingFilter |

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Distance Field

[image]

Lucene.Net Class Libraries
DistanceFilter..::..Distance Field
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Tier.DistanceFilter.Distance"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected double Distance
Visual Basic
Protected Distance As Double
Visual C++
protected:
double Distance

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceLookupCache Field

[image]

Lucene.Net Class Libraries
DistanceFilter..::..DistanceLookupCache Field
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Tier.DistanceFilter.DistanceLookupCache"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected Dictionary<string, double> DistanceLookupCache
Visual Basic
Protected DistanceLookupCache As Dictionary(Of String, Double)
Visual C++
protected:
Dictionary<String^, double>^ DistanceLookupCache

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


NextDocBase Field

[image]

Lucene.Net Class Libraries
DistanceFilter..::..NextDocBase Field
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Tier.DistanceFilter.NextDocBase"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected int NextDocBase
Visual Basic
Protected NextDocBase As Integer
Visual C++
protected:
int NextDocBase

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Precision Field

[image]

Lucene.Net Class Libraries
DistanceFilter..::..Precision Field
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Tier.DistanceFilter.Precision"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected Precision Precision
Visual Basic
Protected Precision As Precision
Visual C++
protected:
Precision Precision

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


StartingFilter Field

[image]

Lucene.Net Class Libraries
DistanceFilter..::..StartingFilter Field
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Tier.DistanceFilter.StartingFilter"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
protected Filter StartingFilter
Visual Basic
Protected StartingFilter As Filter
Visual C++
protected:
Filter^ StartingFilter

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Methods

[image] [image]

Lucene.Net Class Libraries
DistanceFilter Methods
DistanceFilter Class See Also Send Feedback

The DistanceFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance |
Public method | GetDocIdSet | Creates a {@link DocIdSet} enumerating the documents that should be permitted in search results. NOTE: null can be returned if no documents are accepted by this Filter. Note: This method will be called once per segment in the index during searching. The returned {@link DocIdSet} must refer to document IDs for that segment, not for the top-level reader. @param reader a {@link IndexReader} instance opened on the index currently searched on. Note, it is likely that the provided reader does not represent the whole underlying index i.e. if the index has more than one segment the given reader only represents a single segment. (Inherited from Filter.)
Public method | GetHashCode |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | You must call this before re-using this DistanceFilter across searches
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Equals Method

[image]

Lucene.Net Class Libraries
DistanceFilter..::..Equals Method
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract bool Equals(
    Object o
)
Visual Basic
Public MustOverride Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) abstract

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.Equals(System.Object)"]

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


GetDistance Method

[image]

Lucene.Net Class Libraries
DistanceFilter..::..GetDistance Method
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.GetDistance(System.Int32)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double GetDistance(
    int docid
)
Visual Basic
Public Function GetDistance ( _
    docid As Integer _
) As Double
Visual C++
public:
double GetDistance(
    int docid
)

Parameters

docid
Type: System..::..Int32

[Missing <param name="docid"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.GetDistance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.GetDistance(System.Int32)"]

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
DistanceFilter..::..GetHashCode Method
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.GetHashCode"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public abstract int GetHashCode()
Visual Basic
Public MustOverride Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceFilter.GetHashCode"]

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Reset Method

[image]

Lucene.Net Class Libraries
DistanceFilter..::..Reset Method
DistanceFilter Class See Also Send Feedback
You must call this before re-using this DistanceFilter across searches

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Properties

[image] [image]

Lucene.Net Class Libraries
DistanceFilter Properties
DistanceFilter Class See Also Send Feedback

The DistanceFilter type exposes the following members.

Properties

 | Name | Description
Public property | Distances |

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Distances Property

[image]

Lucene.Net Class Libraries
DistanceFilter..::..Distances Property
DistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.DistanceFilter.Distances"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Dictionary<int, double> Distances { get; set; }
Visual Basic
Public Property Distances As Dictionary(Of Integer, Double)
    Get
    Set
Visual C++
public:
property Dictionary<int, double>^ Distances {
    Dictionary<int, double>^ get ();
    void set (Dictionary<int, double>^ value);
}

See Also

DistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


DistanceHandler Class

[image]

Lucene.Net Class Libraries
DistanceHandler Class
Members See Also Send Feedback
Provide a high level access point to distances Used by DistanceSortSource and DistanceQuery

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class DistanceHandler
Visual Basic
Public Class DistanceHandler
Visual C++
public ref class DistanceHandler

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier..::..DistanceHandler

See Also

DistanceHandler Members
Lucene.Net.Spatial.Tier Namespace


DistanceHandler Members

[image] [image]

Lucene.Net Class Libraries
DistanceHandler Members
DistanceHandler Class Constructors Methods See Also Send Feedback

The DistanceHandler type exposes the following members.

Constructors

 | Name | Description
Public method | DistanceHandler | Initializes a new instance of the DistanceHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrecision()()()() |
 | GetPrecision(Double, Nullable<(Of <<'(Precision>)>>)) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceHandler Class
Lucene.Net.Spatial.Tier Namespace


DistanceHandler Constructor

[image]

Lucene.Net Class Libraries
DistanceHandler Constructor
DistanceHandler Class See Also Send Feedback
Initializes a new instance of the DistanceHandler class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public DistanceHandler(
    Dictionary<int, double> distances,
    Dictionary<string, double> distanceLookupCache,
    Precision precision
)
Visual Basic
Public Sub New ( _
    distances As Dictionary(Of Integer, Double), _
    distanceLookupCache As Dictionary(Of String, Double), _
    precision As Precision _
)
Visual C++
public:
DistanceHandler(
    Dictionary<int, double>^ distances,
    Dictionary<String^, double>^ distanceLookupCache,
    Precision precision
)

Parameters

distances
Type: System.Collections.Generic..::..Dictionary <(Of <(<' Int32, Double >)>)>

[Missing <param name="distances"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.#ctor(System.Collections.Generic.Dictionary{System.Int32,System.Double},System.Collections.Generic.Dictionary{System.String,System.Double},Lucene.Net.Spatial.Tier.Precision)"]

distanceLookupCache
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Double >)>)>

[Missing <param name="distanceLookupCache"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.#ctor(System.Collections.Generic.Dictionary{System.Int32,System.Double},System.Collections.Generic.Dictionary{System.String,System.Double},Lucene.Net.Spatial.Tier.Precision)"]

precision
Type: Lucene.Net.Spatial.Tier..::..Precision

[Missing <param name="precision"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.#ctor(System.Collections.Generic.Dictionary{System.Int32,System.Double},System.Collections.Generic.Dictionary{System.String,System.Double},Lucene.Net.Spatial.Tier.Precision)"]

See Also

DistanceHandler Class
Lucene.Net.Spatial.Tier Namespace


DistanceHandler Methods

[image] [image]

Lucene.Net Class Libraries
DistanceHandler Methods
DistanceHandler Class See Also Send Feedback

The DistanceHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrecision()()()() |
 | GetPrecision(Double, Nullable<(Of <<'(Precision>)>>)) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceHandler Class
Lucene.Net.Spatial.Tier Namespace


GetDistance Method

[image]

Lucene.Net Class Libraries
DistanceHandler..::..GetDistance Method
DistanceHandler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double GetDistance(
    int docid,
    double centerLat,
    double centerLng,
    double lat,
    double lng
)
Visual Basic
Public Function GetDistance ( _
    docid As Integer, _
    centerLat As Double, _
    centerLng As Double, _
    lat As Double, _
    lng As Double _
) As Double
Visual C++
public:
double GetDistance(
    int docid,
    double centerLat,
    double centerLng,
    double lat,
    double lng
)

Parameters

docid
Type: System..::..Int32

[Missing <param name="docid"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

centerLat
Type: System..::..Double

[Missing <param name="centerLat"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

centerLng
Type: System..::..Double

[Missing <param name="centerLng"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

lat
Type: System..::..Double

[Missing <param name="lat"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

lng
Type: System..::..Double

[Missing <param name="lng"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetDistance(System.Int32,System.Double,System.Double,System.Double,System.Double)"]

See Also

DistanceHandler Class
Lucene.Net.Spatial.Tier Namespace


GetPrecision Method

[image] [image]

Lucene.Net Class Libraries
DistanceHandler..::..GetPrecision Method
DistanceHandler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPrecision()()()() |
 | GetPrecision(Double, Nullable<(Of <<'(Precision>)>>)) |

See Also

DistanceHandler Class
DistanceHandler Members
Lucene.Net.Spatial.Tier Namespace


GetPrecision Method

[image]

Lucene.Net Class Libraries
DistanceHandler..::..GetPrecision Method
DistanceHandler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetPrecision"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Precision GetPrecision()
Visual Basic
Public Function GetPrecision As Precision
Visual C++
public:
Precision GetPrecision()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetPrecision"]

See Also

DistanceHandler Class
GetPrecision Overload
Lucene.Net.Spatial.Tier Namespace


GetPrecision Method (Double, Nullable(Precision))

[image]

Lucene.Net Class Libraries
DistanceHandler..::..GetPrecision Method (Double, Nullable<(Of <(<'Precision>)>)>)
DistanceHandler Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetPrecision(System.Double,System.Nullable{Lucene.Net.Spatial.Tier.Precision})"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double GetPrecision(
    double x,
    Nullable<Precision> thisPrecision
)
Visual Basic
Public Shared Function GetPrecision ( _
    x As Double, _
    thisPrecision As Nullable(Of Precision) _
) As Double
Visual C++
public:
static double GetPrecision(
    double x,
    Nullable<Precision> thisPrecision
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetPrecision(System.Double,System.Nullable{Lucene.Net.Spatial.Tier.Precision})"]

thisPrecision
Type: System..::..Nullable <(Of <(<' Precision >)>)>

[Missing <param name="thisPrecision"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetPrecision(System.Double,System.Nullable{Lucene.Net.Spatial.Tier.Precision})"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceHandler.GetPrecision(System.Double,System.Nullable{Lucene.Net.Spatial.Tier.Precision})"]

See Also

DistanceHandler Class
GetPrecision Overload
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Class

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.DistanceQueryBuilder"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class DistanceQueryBuilder
Visual Basic
Public Class DistanceQueryBuilder
Visual C++
public ref class DistanceQueryBuilder

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier..::..DistanceQueryBuilder

See Also

DistanceQueryBuilder Members
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Members

[image] [image]

Lucene.Net Class Libraries
DistanceQueryBuilder Members
DistanceQueryBuilder Class Constructors Methods Properties See Also Send Feedback

The DistanceQueryBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | DistanceQueryBuilder(Double, Double, Double, String, String, Boolean) | Create a distance query using a boundary box wrapper around a more precise DistanceFilter.
Public method | DistanceQueryBuilder(Double, Double, Double, String, String, String, Boolean) | Create a distance query using a boundary box wrapper around a more precise DistanceFilter.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQuery |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DistanceFilter |
Public property | Filter |
Public property | Lat |
Public property | Lng |
Public property | Miles |

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Constructor

[image] [image]

Lucene.Net Class Libraries
DistanceQueryBuilder Constructor
DistanceQueryBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DistanceQueryBuilder(Double, Double, Double, String, String, Boolean) | Create a distance query using a boundary box wrapper around a more precise DistanceFilter.
Public method | DistanceQueryBuilder(Double, Double, Double, String, String, String, Boolean) | Create a distance query using a boundary box wrapper around a more precise DistanceFilter.

See Also

DistanceQueryBuilder Class
DistanceQueryBuilder Members
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Constructor (Double, Double, Double, String, String, Boolean)

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder Constructor (Double, Double, Double, String, String, Boolean)
DistanceQueryBuilder Class See Also Send Feedback
Create a distance query using a boundary box wrapper around a more precise DistanceFilter.

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public DistanceQueryBuilder(
    double lat,
    double lng,
    double miles,
    string geoHashFieldPrefix,
    string tierFieldPrefix,
    bool needPrecise
)
Visual Basic
Public Sub New ( _
    lat As Double, _
    lng As Double, _
    miles As Double, _
    geoHashFieldPrefix As String, _
    tierFieldPrefix As String, _
    needPrecise As Boolean _
)
Visual C++
public:
DistanceQueryBuilder(
    double lat,
    double lng,
    double miles,
    String^ geoHashFieldPrefix,
    String^ tierFieldPrefix,
    bool needPrecise
)

Parameters

lat
Type: System..::..Double
The lat.
lng
Type: System..::..Double
The Lng.
miles
Type: System..::..Double
The miles.
geoHashFieldPrefix
Type: System..::..String
The geo hash field prefix.
tierFieldPrefix
Type: System..::..String
The tier field prefix.
needPrecise
Type: System..::..Boolean
if set to true [need precise].

See Also

DistanceQueryBuilder Class
DistanceQueryBuilder Overload
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Constructor (Double, Double, Double, String, String, String, Boolean)

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder Constructor (Double, Double, Double, String, String, String, Boolean)
DistanceQueryBuilder Class See Also Send Feedback
Create a distance query using a boundary box wrapper around a more precise DistanceFilter.

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public DistanceQueryBuilder(
    double lat,
    double lng,
    double miles,
    string latField,
    string lngField,
    string tierFieldPrefix,
    bool needPrecise
)
Visual Basic
Public Sub New ( _
    lat As Double, _
    lng As Double, _
    miles As Double, _
    latField As String, _
    lngField As String, _
    tierFieldPrefix As String, _
    needPrecise As Boolean _
)
Visual C++
public:
DistanceQueryBuilder(
    double lat,
    double lng,
    double miles,
    String^ latField,
    String^ lngField,
    String^ tierFieldPrefix,
    bool needPrecise
)

Parameters

lat
Type: System..::..Double
The lat.
lng
Type: System..::..Double
The Lng.
miles
Type: System..::..Double
The miles.
latField
Type: System..::..String
The lat field.
lngField
Type: System..::..String
The Lng field.
tierFieldPrefix
Type: System..::..String
The tier field prefix.
needPrecise
Type: System..::..Boolean
if set to true [need precise].

See Also

DistanceQueryBuilder Class
DistanceQueryBuilder Overload
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Methods

[image] [image]

Lucene.Net Class Libraries
DistanceQueryBuilder Methods
DistanceQueryBuilder Class See Also Send Feedback

The DistanceQueryBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQuery |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


GetFilter Method

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..GetFilter Method
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.GetFilter(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Filter GetFilter(
    Query query
)
Visual Basic
Public Function GetFilter ( _
    query As Query _
) As Filter
Visual C++
public:
Filter^ GetFilter(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.GetFilter(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.GetFilter(Lucene.Net.Search.Query)"]

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


GetQuery Method

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..GetQuery Method
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.GetQuery(Lucene.Net.Search.Query)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Query GetQuery(
    Query query
)
Visual Basic
Public Function GetQuery ( _
    query As Query _
) As Query
Visual C++
public:
Query^ GetQuery(
    Query^ query
)

Parameters

query
Type: Lucene.Net.Search..::..Query

[Missing <param name="query"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.GetQuery(Lucene.Net.Search.Query)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.GetQuery(Lucene.Net.Search.Query)"]

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


ToString Method

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..ToString Method
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.ToString"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.ToString"]

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


DistanceQueryBuilder Properties

[image] [image]

Lucene.Net Class Libraries
DistanceQueryBuilder Properties
DistanceQueryBuilder Class See Also Send Feedback

The DistanceQueryBuilder type exposes the following members.

Properties

 | Name | Description
Public property | DistanceFilter |
Public property | Filter |
Public property | Lat |
Public property | Lng |
Public property | Miles |

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


DistanceFilter Property

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..DistanceFilter Property
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.DistanceFilter"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public DistanceFilter DistanceFilter { get; private set; }
Visual Basic
Public Property DistanceFilter As DistanceFilter
    Get
    Private Set
Visual C++
public:
property DistanceFilter^ DistanceFilter {
    DistanceFilter^ get ();
    private: void set (DistanceFilter^ value);
}

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


Filter Property

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..Filter Property
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.Filter"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Filter Filter { get; }
Visual Basic
Public ReadOnly Property Filter As Filter
    Get
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
}

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


Lat Property

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..Lat Property
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.Lat"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Lat { get; private set; }
Visual Basic
Public Property Lat As Double
    Get
    Private Set
Visual C++
public:
property double Lat {
    double get ();
    private: void set (double value);
}

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


Lng Property

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..Lng Property
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.Lng"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Lng { get; private set; }
Visual Basic
Public Property Lng As Double
    Get
    Private Set
Visual C++
public:
property double Lng {
    double get ();
    private: void set (double value);
}

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


Miles Property

[image]

Lucene.Net Class Libraries
DistanceQueryBuilder..::..Miles Property
DistanceQueryBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.DistanceQueryBuilder.Miles"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Miles { get; private set; }
Visual Basic
Public Property Miles As Double
    Get
    Private Set
Visual C++
public:
property double Miles {
    double get ();
    private: void set (double value);
}

See Also

DistanceQueryBuilder Class
Lucene.Net.Spatial.Tier Namespace


DistanceUtils Class

[image]

Lucene.Net Class Libraries
DistanceUtils Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.DistanceUtils"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class DistanceUtils
Visual Basic
Public Class DistanceUtils
Visual C++
public ref class DistanceUtils

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier..::..DistanceUtils

See Also

DistanceUtils Members
Lucene.Net.Spatial.Tier Namespace


DistanceUtils Members

[image] [image]

Lucene.Net Class Libraries
DistanceUtils Members
DistanceUtils Class Constructors Methods See Also Send Feedback

The DistanceUtils type exposes the following members.

Constructors

 | Name | Description
Public method | DistanceUtils | Initializes a new instance of the DistanceUtils class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoundary |
Public method | GetDistanceMi |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance |
Public method | GetLLMDistance |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


DistanceUtils Constructor

[image]

Lucene.Net Class Libraries
DistanceUtils Constructor
DistanceUtils Class See Also Send Feedback
Initializes a new instance of the DistanceUtils class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public DistanceUtils()
Visual Basic
Public Sub New
Visual C++
public:
DistanceUtils()

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


DistanceUtils Methods

[image] [image]

Lucene.Net Class Libraries
DistanceUtils Methods
DistanceUtils Class See Also Send Feedback

The DistanceUtils type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoundary |
Public method | GetDistanceMi |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance |
Public method | GetLLMDistance |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


GetBoundary Method

[image]

Lucene.Net Class Libraries
DistanceUtils..::..GetBoundary Method
DistanceUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetBoundary(System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Rectangle GetBoundary(
    double x1,
    double y1,
    double miles
)
Visual Basic
Public Function GetBoundary ( _
    x1 As Double, _
    y1 As Double, _
    miles As Double _
) As Rectangle
Visual C++
public:
Rectangle^ GetBoundary(
    double x1,
    double y1,
    double miles
)

Parameters

x1
Type: System..::..Double

[Missing <param name="x1"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetBoundary(System.Double,System.Double,System.Double)"]

y1
Type: System..::..Double

[Missing <param name="y1"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetBoundary(System.Double,System.Double,System.Double)"]

miles
Type: System..::..Double

[Missing <param name="miles"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetBoundary(System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetBoundary(System.Double,System.Double,System.Double)"]

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


GetDistanceMi Method

[image]

Lucene.Net Class Libraries
DistanceUtils..::..GetDistanceMi Method
DistanceUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetDistanceMi(System.Double,System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double GetDistanceMi(
    double x1,
    double y1,
    double x2,
    double y2
)
Visual Basic
Public Function GetDistanceMi ( _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
) As Double
Visual C++
public:
double GetDistanceMi(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::..Double

[Missing <param name="x1"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetDistanceMi(System.Double,System.Double,System.Double,System.Double)"]

y1
Type: System..::..Double

[Missing <param name="y1"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetDistanceMi(System.Double,System.Double,System.Double,System.Double)"]

x2
Type: System..::..Double

[Missing <param name="x2"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetDistanceMi(System.Double,System.Double,System.Double,System.Double)"]

y2
Type: System..::..Double

[Missing <param name="y2"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetDistanceMi(System.Double,System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetDistanceMi(System.Double,System.Double,System.Double,System.Double)"]

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


GetInstance Method

[image]

Lucene.Net Class Libraries
DistanceUtils..::..GetInstance Method
DistanceUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetInstance"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static DistanceUtils GetInstance()
Visual Basic
Public Shared Function GetInstance As DistanceUtils
Visual C++
public:
static DistanceUtils^ GetInstance()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetInstance"]

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


GetLLMDistance Method

[image]

Lucene.Net Class Libraries
DistanceUtils..::..GetLLMDistance Method
DistanceUtils Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetLLMDistance(System.Double,System.Double,System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double GetLLMDistance(
    double x1,
    double y1,
    double x2,
    double y2
)
Visual Basic
Public Function GetLLMDistance ( _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
) As Double
Visual C++
public:
double GetLLMDistance(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::..Double

[Missing <param name="x1"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetLLMDistance(System.Double,System.Double,System.Double,System.Double)"]

y1
Type: System..::..Double

[Missing <param name="y1"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetLLMDistance(System.Double,System.Double,System.Double,System.Double)"]

x2
Type: System..::..Double

[Missing <param name="x2"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetLLMDistance(System.Double,System.Double,System.Double,System.Double)"]

y2
Type: System..::..Double

[Missing <param name="y2"/> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetLLMDistance(System.Double,System.Double,System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.DistanceUtils.GetLLMDistance(System.Double,System.Double,System.Double,System.Double)"]

See Also

DistanceUtils Class
Lucene.Net.Spatial.Tier Namespace


LatLongDistanceFilter Class

[image]

Lucene.Net Class Libraries
LatLongDistanceFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.LatLongDistanceFilter"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class LatLongDistanceFilter : DistanceFilter
Visual Basic
Public Class LatLongDistanceFilter _
    Inherits DistanceFilter
Visual C++
public ref class LatLongDistanceFilter : public DistanceFilter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..Filter
Lucene.Net.Spatial.Tier..::..DistanceFilter
Lucene.Net.Spatial.Tier..::..LatLongDistanceFilter

See Also

LatLongDistanceFilter Members
Lucene.Net.Spatial.Tier Namespace


LatLongDistanceFilter Members

[image] [image]

Lucene.Net Class Libraries
LatLongDistanceFilter Members
LatLongDistanceFilter Class Constructors Methods Fields Properties See Also Send Feedback

The LatLongDistanceFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LatLongDistanceFilter | Initializes a new instance of the LatLongDistanceFilter class

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides DistanceFilter..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | (Inherited from DistanceFilter.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides DistanceFilter..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | You must call this before re-using this DistanceFilter across searches (Inherited from DistanceFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | Distance | (Inherited from DistanceFilter.)
Protected field | DistanceLookupCache | (Inherited from DistanceFilter.)
Protected field | NextDocBase | (Inherited from DistanceFilter.)
Protected field | Precision | (Inherited from DistanceFilter.)
Protected field | StartingFilter | (Inherited from DistanceFilter.)

Properties

 | Name | Description
Public property | Distances | (Inherited from DistanceFilter.)

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


LatLongDistanceFilter Constructor

[image]

Lucene.Net Class Libraries
LatLongDistanceFilter Constructor
LatLongDistanceFilter Class See Also Send Feedback
Initializes a new instance of the LatLongDistanceFilter class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public LatLongDistanceFilter(
    Filter startingFilter,
    double distance,
    double lat,
    double lng,
    string latField,
    string lngField
)
Visual Basic
Public Sub New ( _
    startingFilter As Filter, _
    distance As Double, _
    lat As Double, _
    lng As Double, _
    latField As String, _
    lngField As String _
)
Visual C++
public:
LatLongDistanceFilter(
    Filter^ startingFilter,
    double distance,
    double lat,
    double lng,
    String^ latField,
    String^ lngField
)

Parameters

startingFilter
Type: Lucene.Net.Search..::..Filter

[Missing <param name="startingFilter"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double,System.Double,System.Double,System.String,System.String)"]

distance
Type: System..::..Double

[Missing <param name="distance"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double,System.Double,System.Double,System.String,System.String)"]

lat
Type: System..::..Double

[Missing <param name="lat"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double,System.Double,System.Double,System.String,System.String)"]

lng
Type: System..::..Double

[Missing <param name="lng"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double,System.Double,System.Double,System.String,System.String)"]

latField
Type: System..::..String

[Missing <param name="latField"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double,System.Double,System.Double,System.String,System.String)"]

lngField
Type: System..::..String

[Missing <param name="lngField"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.#ctor(Lucene.Net.Search.Filter,System.Double,System.Double,System.Double,System.String,System.String)"]

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


LatLongDistanceFilter Fields

[image] [image]

Lucene.Net Class Libraries
LatLongDistanceFilter Fields
LatLongDistanceFilter Class See Also Send Feedback

The LatLongDistanceFilter type exposes the following members.

Fields

 | Name | Description
Protected field | Distance | (Inherited from DistanceFilter.)
Protected field | DistanceLookupCache | (Inherited from DistanceFilter.)
Protected field | NextDocBase | (Inherited from DistanceFilter.)
Protected field | Precision | (Inherited from DistanceFilter.)
Protected field | StartingFilter | (Inherited from DistanceFilter.)

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


LatLongDistanceFilter Methods

[image] [image]

Lucene.Net Class Libraries
LatLongDistanceFilter Methods
LatLongDistanceFilter Class See Also Send Feedback

The LatLongDistanceFilter type exposes the following members.

Methods

 | Name | Description
Public method | Bits | Obsolete. (Inherited from Filter.)
Public method | Equals | (Overrides DistanceFilter..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | (Inherited from DistanceFilter.)
Public method | GetDocIdSet | (Overrides Filter..::..GetDocIdSet(IndexReader).)
Public method | GetHashCode | (Overrides DistanceFilter..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | You must call this before re-using this DistanceFilter across searches (Inherited from DistanceFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Equals Method

[image]

Lucene.Net Class Libraries
LatLongDistanceFilter..::..Equals Method
LatLongDistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.Equals(System.Object)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.Equals(System.Object)"]

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


GetDocIdSet Method

[image]

Lucene.Net Class Libraries
LatLongDistanceFilter..::..GetDocIdSet Method
LatLongDistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override DocIdSet GetDocIdSet(
    IndexReader reader
)
Visual Basic
Public Overrides Function GetDocIdSet ( _
    reader As IndexReader _
) As DocIdSet
Visual C++
public:
virtual DocIdSet^ GetDocIdSet(
    IndexReader^ reader
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.GetDocIdSet(Lucene.Net.Index.IndexReader)"]

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
LatLongDistanceFilter..::..GetHashCode Method
LatLongDistanceFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.GetHashCode"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.LatLongDistanceFilter.GetHashCode"]

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


LatLongDistanceFilter Properties

[image] [image]

Lucene.Net Class Libraries
LatLongDistanceFilter Properties
LatLongDistanceFilter Class See Also Send Feedback

The LatLongDistanceFilter type exposes the following members.

Properties

 | Name | Description
Public property | Distances | (Inherited from DistanceFilter.)

See Also

LatLongDistanceFilter Class
Lucene.Net.Spatial.Tier Namespace


Precision Enumeration

[image]

Lucene.Net Class Libraries
Precision Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.Precision"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public enum Precision
Visual Basic
Public Enumeration Precision
Visual C++
public enum class Precision

Members

Member name | Value | Description
EXACT | 0 |
TWOFEET | 1 |
TWENTYFEET | 2 |
TWOHUNDREDFEET | 3 |

See Also

Lucene.Net.Spatial.Tier Namespace


Shape Class

[image]

Lucene.Net Class Libraries
Shape Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.Shape"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class Shape
Visual Basic
Public Class Shape
Visual C++
public ref class Shape

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier..::..Shape

See Also

Shape Members
Lucene.Net.Spatial.Tier Namespace


Shape Members

[image] [image]

Lucene.Net Class Libraries
Shape Members
Shape Class Constructors Methods Properties See Also Send Feedback

The Shape type exposes the following members.

Constructors

 | Name | Description
Public method | Shape | Initializes a new instance of the Shape class

Methods

 | Name | Description
Public method | AddBox |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInside |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area |
Public property | TierId |

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


Shape Constructor

[image]

Lucene.Net Class Libraries
Shape Constructor
Shape Class See Also Send Feedback
Initializes a new instance of the Shape class

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public Shape(
    string tierId
)
Visual Basic
Public Sub New ( _
    tierId As String _
)
Visual C++
public:
Shape(
    String^ tierId
)

Parameters

tierId
Type: System..::..String

[Missing <param name="tierId"/> documentation for "M:Lucene.Net.Spatial.Tier.Shape.#ctor(System.String)"]

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


Shape Methods

[image] [image]

Lucene.Net Class Libraries
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

 | Name | Description
Public method | AddBox |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInside |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


AddBox Method

[image]

Lucene.Net Class Libraries
Shape..::..AddBox Method
Shape Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.Shape.AddBox(System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public void AddBox(
    double boxId
)
Visual Basic
Public Sub AddBox ( _
    boxId As Double _
)
Visual C++
public:
void AddBox(
    double boxId
)

Parameters

boxId
Type: System..::..Double

[Missing <param name="boxId"/> documentation for "M:Lucene.Net.Spatial.Tier.Shape.AddBox(System.Double)"]

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


IsInside Method

[image]

Lucene.Net Class Libraries
Shape..::..IsInside Method
Shape Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.Shape.IsInside(System.Double)"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public bool IsInside(
    double boxId
)
Visual Basic
Public Function IsInside ( _
    boxId As Double _
) As Boolean
Visual C++
public:
bool IsInside(
    double boxId
)

Parameters

boxId
Type: System..::..Double

[Missing <param name="boxId"/> documentation for "M:Lucene.Net.Spatial.Tier.Shape.IsInside(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Shape.IsInside(System.Double)"]

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


Shape Properties

[image] [image]

Lucene.Net Class Libraries
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | TierId |

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


Area Property

[image]

Lucene.Net Class Libraries
Shape..::..Area Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.Shape.Area"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public List<double> Area { get; private set; }
Visual Basic
Public Property Area As List(Of Double)
    Get
    Private Set
Visual C++
public:
property List<double>^ Area {
    List<double>^ get ();
    private: void set (List<double>^ value);
}

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


TierId Property

[image]

Lucene.Net Class Libraries
Shape..::..TierId Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.Shape.TierId"]

Namespace: Lucene.Net.Spatial.Tier
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public string TierId { get; private set; }
Visual Basic
Public Property TierId As String
    Get
    Private Set
Visual C++
public:
property String^ TierId {
    String^ get ();
    private: void set (String^ value);
}

See Also

Shape Class
Lucene.Net.Spatial.Tier Namespace


Lucene.Net.Spatial.Tier.Projectors Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Spatial.Tier.Projectors Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Spatial.Tier.Projectors"]

Classes

 | Class | Description
Public class | CartesianTierPlotter |
Public class | SinusoidalProjector | Based on Sinusoidal Projections Project a latitude / longitude on a 2D cartesian map

Interfaces

 | Interface | Description
Public interface | IProjector |


CartesianTierPlotter Class

[image]

Lucene.Net Class Libraries
CartesianTierPlotter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class CartesianTierPlotter
Visual Basic
Public Class CartesianTierPlotter
Visual C++
public ref class CartesianTierPlotter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier.Projectors..::..CartesianTierPlotter

See Also

CartesianTierPlotter Members
Lucene.Net.Spatial.Tier.Projectors Namespace


CartesianTierPlotter Members

[image] [image]

Lucene.Net Class Libraries
CartesianTierPlotter Members
CartesianTierPlotter Class Constructors Methods Fields Properties See Also Send Feedback

The CartesianTierPlotter type exposes the following members.

Constructors

 | Name | Description
Public method | CartesianTierPlotter | Initializes a new instance of the CartesianTierPlotter class

Methods

Name Description
Public method BestFit
Find the tier with the best fit for a bounding box Best fit is defined as the ceiling of log2 (circumference of earth / distance) distance is defined as the smallest box fitting the corner between a radius and a bounding box. Distances less than a mile return 15, finer granularity is in accurate
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTierBoxId
TierBoxId is latitude box id + longitude box id where latitude box id, and longitude box id are transposed in to position coordinates.
Public method GetTierFieldName()()()()
Get the string name representing current tier _localTier<tiedId>
Public method GetTierFieldName(Int32)
Get the string name representing tierId _localTier<tierId>
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Log2
A log to the base 2 formula.
CopyC#
Math.Log(value) / Math.Log(2)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name | Description
DefaltFieldPrefix |

Properties

 | Name | Description
Public property | TierVerticalPosDivider |

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


CartesianTierPlotter Constructor

[image]

Lucene.Net Class Libraries
CartesianTierPlotter Constructor
CartesianTierPlotter Class See Also Send Feedback
Initializes a new instance of the CartesianTierPlotter class

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public CartesianTierPlotter(
    int tierLevel,
    IProjector projector,
    string fieldPrefix
)
Visual Basic
Public Sub New ( _
    tierLevel As Integer, _
    projector As IProjector, _
    fieldPrefix As String _
)
Visual C++
public:
CartesianTierPlotter(
    int tierLevel,
    IProjector^ projector,
    String^ fieldPrefix
)

Parameters

tierLevel
Type: System..::..Int32

[Missing <param name="tierLevel"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.#ctor(System.Int32,Lucene.Net.Spatial.Tier.Projectors.IProjector,System.String)"]

projector
Type: Lucene.Net.Spatial.Tier.Projectors..::..IProjector

[Missing <param name="projector"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.#ctor(System.Int32,Lucene.Net.Spatial.Tier.Projectors.IProjector,System.String)"]

fieldPrefix
Type: System..::..String

[Missing <param name="fieldPrefix"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.#ctor(System.Int32,Lucene.Net.Spatial.Tier.Projectors.IProjector,System.String)"]

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


CartesianTierPlotter Fields

[image] [image]

Lucene.Net Class Libraries
CartesianTierPlotter Fields
CartesianTierPlotter Class See Also Send Feedback

The CartesianTierPlotter type exposes the following members.

Fields

Name | Description
DefaltFieldPrefix |

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


DefaltFieldPrefix Field

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..DefaltFieldPrefix Field
CartesianTierPlotter Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.DefaltFieldPrefix"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public const string DefaltFieldPrefix
Visual Basic
Public Const DefaltFieldPrefix As String
Visual C++
public:
literal String^ DefaltFieldPrefix

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


CartesianTierPlotter Methods

[image] [image]

Lucene.Net Class Libraries
CartesianTierPlotter Methods
CartesianTierPlotter Class See Also Send Feedback

The CartesianTierPlotter type exposes the following members.

Methods

Name Description
Public method BestFit
Find the tier with the best fit for a bounding box Best fit is defined as the ceiling of log2 (circumference of earth / distance) distance is defined as the smallest box fitting the corner between a radius and a bounding box. Distances less than a mile return 15, finer granularity is in accurate
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetTierBoxId
TierBoxId is latitude box id + longitude box id where latitude box id, and longitude box id are transposed in to position coordinates.
Public method GetTierFieldName()()()()
Get the string name representing current tier _localTier<tiedId>
Public method GetTierFieldName(Int32)
Get the string name representing tierId _localTier<tierId>
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Log2
A log to the base 2 formula.
CopyC#
Math.Log(value) / Math.Log(2)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


BestFit Method

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..BestFit Method
CartesianTierPlotter Class See Also Send Feedback
Find the tier with the best fit for a bounding box Best fit is defined as the ceiling of log2 (circumference of earth / distance) distance is defined as the smallest box fitting the corner between a radius and a bounding box. Distances less than a mile return 15, finer granularity is in accurate

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public int BestFit(
    double miles
)
Visual Basic
Public Function BestFit ( _
    miles As Double _
) As Integer
Visual C++
public:
int BestFit(
    double miles
)

Parameters

miles
Type: System..::..Double
The miles.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.BestFit(System.Double)"]

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


GetTierBoxId Method

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..GetTierBoxId Method
CartesianTierPlotter Class See Also Send Feedback
TierBoxId is latitude box id + longitude box id where latitude box id, and longitude box id are transposed in to position coordinates.

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double GetTierBoxId(
    double latitude,
    double longitude
)
Visual Basic
Public Function GetTierBoxId ( _
    latitude As Double, _
    longitude As Double _
) As Double
Visual C++
public:
double GetTierBoxId(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::..Double
The latitude.
longitude
Type: System..::..Double
The longitude.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.GetTierBoxId(System.Double,System.Double)"]

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


GetTierFieldName Method

[image] [image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..GetTierFieldName Method
CartesianTierPlotter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTierFieldName()()()() | Get the string name representing current tier _localTier<tiedId>
Public method | GetTierFieldName(Int32) | Get the string name representing tierId _localTier<tierId>

See Also

CartesianTierPlotter Class
CartesianTierPlotter Members
Lucene.Net.Spatial.Tier.Projectors Namespace


GetTierFieldName Method

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..GetTierFieldName Method
CartesianTierPlotter Class See Also Send Feedback
Get the string name representing current tier _localTier<tiedId>

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public string GetTierFieldName()
Visual Basic
Public Function GetTierFieldName As String
Visual C++
public:
String^ GetTierFieldName()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.GetTierFieldName"]

See Also

CartesianTierPlotter Class
GetTierFieldName Overload
Lucene.Net.Spatial.Tier.Projectors Namespace


GetTierFieldName Method (Int32)

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..GetTierFieldName Method (Int32)
CartesianTierPlotter Class See Also Send Feedback
Get the string name representing tierId _localTier<tierId>

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public string GetTierFieldName(
    int tierId
)
Visual Basic
Public Function GetTierFieldName ( _
    tierId As Integer _
) As String
Visual C++
public:
String^ GetTierFieldName(
    int tierId
)

Parameters

tierId
Type: System..::..Int32
The tier id.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.GetTierFieldName(System.Int32)"]

See Also

CartesianTierPlotter Class
GetTierFieldName Overload
Lucene.Net.Spatial.Tier.Projectors Namespace


Log2 Method

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..Log2 Method
CartesianTierPlotter Class See Also Send Feedback
A log to the base 2 formula.
CopyC#
Math.Log(value) / Math.Log(2)

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double Log2(
    double value
)
Visual Basic
Public Function Log2 ( _
    value As Double _
) As Double
Visual C++
public:
double Log2(
    double value
)

Parameters

value
Type: System..::..Double
The value.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.Log2(System.Double)"]

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


CartesianTierPlotter Properties

[image] [image]

Lucene.Net Class Libraries
CartesianTierPlotter Properties
CartesianTierPlotter Class See Also Send Feedback

The CartesianTierPlotter type exposes the following members.

Properties

 | Name | Description
Public property | TierVerticalPosDivider |

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


TierVerticalPosDivider Property

[image]

Lucene.Net Class Libraries
CartesianTierPlotter..::..TierVerticalPosDivider Property
CartesianTierPlotter Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Tier.Projectors.CartesianTierPlotter.TierVerticalPosDivider"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public int TierVerticalPosDivider { get; private set; }
Visual Basic
Public Property TierVerticalPosDivider As Integer
    Get
    Private Set
Visual C++
public:
property int TierVerticalPosDivider {
    int get ();
    private: void set (int value);
}

See Also

CartesianTierPlotter Class
Lucene.Net.Spatial.Tier.Projectors Namespace


IProjector Interface

[image]

Lucene.Net Class Libraries
IProjector Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Tier.Projectors.IProjector"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public interface IProjector
Visual Basic
Public Interface IProjector
Visual C++
public interface class IProjector

See Also

IProjector Members
Lucene.Net.Spatial.Tier.Projectors Namespace


IProjector Members

[image] [image]

Lucene.Net Class Libraries
IProjector Members
IProjector Interface Methods See Also Send Feedback

The IProjector type exposes the following members.

Methods

 | Name | Description
Public method | Coords |
Public method | CoordsAsString |

See Also

IProjector Interface
Lucene.Net.Spatial.Tier.Projectors Namespace


IProjector Methods

[image] [image]

Lucene.Net Class Libraries
IProjector Methods
IProjector Interface See Also Send Feedback

The IProjector type exposes the following members.

Methods

 | Name | Description
Public method | Coords |
Public method | CoordsAsString |

See Also

IProjector Interface
Lucene.Net.Spatial.Tier.Projectors Namespace


Coords Method

[image]

Lucene.Net Class Libraries
IProjector..::..Coords Method
IProjector Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.Coords(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
double[] Coords(
    double latitude,
    double longitude
)
Visual Basic
Function Coords ( _
    latitude As Double, _
    longitude As Double _
) As Double()
Visual C++
array<double>^ Coords(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.Coords(System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.Coords(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.Coords(System.Double,System.Double)"]

See Also

IProjector Interface
Lucene.Net.Spatial.Tier.Projectors Namespace


CoordsAsString Method

[image]

Lucene.Net Class Libraries
IProjector..::..CoordsAsString Method
IProjector Interface See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.CoordsAsString(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
string CoordsAsString(
    double latitude,
    double longitude
)
Visual Basic
Function CoordsAsString ( _
    latitude As Double, _
    longitude As Double _
) As String
Visual C++
String^ CoordsAsString(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.CoordsAsString(System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.CoordsAsString(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.IProjector.CoordsAsString(System.Double,System.Double)"]

See Also

IProjector Interface
Lucene.Net.Spatial.Tier.Projectors Namespace


SinusoidalProjector Class

[image]

Lucene.Net Class Libraries
SinusoidalProjector Class
Members See Also Send Feedback
Based on Sinusoidal Projections Project a latitude / longitude on a 2D cartesian map

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class SinusoidalProjector : IProjector
Visual Basic
Public Class SinusoidalProjector _
    Implements IProjector
Visual C++
public ref class SinusoidalProjector : IProjector

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Tier.Projectors..::..SinusoidalProjector

See Also

SinusoidalProjector Members
Lucene.Net.Spatial.Tier.Projectors Namespace


SinusoidalProjector Members

[image] [image]

Lucene.Net Class Libraries
SinusoidalProjector Members
SinusoidalProjector Class Constructors Methods See Also Send Feedback

The SinusoidalProjector type exposes the following members.

Constructors

 | Name | Description
Public method | SinusoidalProjector | Initializes a new instance of the SinusoidalProjector class

Methods

 | Name | Description
Public method | Coords |
Public method | CoordsAsString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SinusoidalProjector Class
Lucene.Net.Spatial.Tier.Projectors Namespace


SinusoidalProjector Constructor

[image]

Lucene.Net Class Libraries
SinusoidalProjector Constructor
SinusoidalProjector Class See Also Send Feedback
Initializes a new instance of the SinusoidalProjector class

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public SinusoidalProjector()
Visual Basic
Public Sub New
Visual C++
public:
SinusoidalProjector()

See Also

SinusoidalProjector Class
Lucene.Net.Spatial.Tier.Projectors Namespace


SinusoidalProjector Methods

[image] [image]

Lucene.Net Class Libraries
SinusoidalProjector Methods
SinusoidalProjector Class See Also Send Feedback

The SinusoidalProjector type exposes the following members.

Methods

 | Name | Description
Public method | Coords |
Public method | CoordsAsString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SinusoidalProjector Class
Lucene.Net.Spatial.Tier.Projectors Namespace


Coords Method

[image]

Lucene.Net Class Libraries
SinusoidalProjector..::..Coords Method
SinusoidalProjector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.Coords(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public double[] Coords(
    double latitude,
    double longitude
)
Visual Basic
Public Function Coords ( _
    latitude As Double, _
    longitude As Double _
) As Double()
Visual C++
public:
virtual array<double>^ Coords(
    double latitude,
    double longitude
) sealed

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.Coords(System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.Coords(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.Coords(System.Double,System.Double)"]

Implements

IProjector..::..Coords(Double, Double)

See Also

SinusoidalProjector Class
Lucene.Net.Spatial.Tier.Projectors Namespace


CoordsAsString Method

[image]

Lucene.Net Class Libraries
SinusoidalProjector..::..CoordsAsString Method
SinusoidalProjector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.CoordsAsString(System.Double,System.Double)"]

Namespace: Lucene.Net.Spatial.Tier.Projectors
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public string CoordsAsString(
    double latitude,
    double longitude
)
Visual Basic
Public Function CoordsAsString ( _
    latitude As Double, _
    longitude As Double _
) As String
Visual C++
public:
virtual String^ CoordsAsString(
    double latitude,
    double longitude
) sealed

Parameters

latitude
Type: System..::..Double

[Missing <param name="latitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.CoordsAsString(System.Double,System.Double)"]

longitude
Type: System..::..Double

[Missing <param name="longitude"/> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.CoordsAsString(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Tier.Projectors.SinusoidalProjector.CoordsAsString(System.Double,System.Double)"]

Implements

IProjector..::..CoordsAsString(Double, Double)

See Also

SinusoidalProjector Class
Lucene.Net.Spatial.Tier.Projectors Namespace


Lucene.Net.Spatial.Utils Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Spatial.Utils Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Spatial.Utils"]

Classes

 | Class | Description
Public class | BitwiseHelper |
Public class | MathHelper |


BitwiseHelper Class

[image]

Lucene.Net Class Libraries
BitwiseHelper Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Utils.BitwiseHelper"]

Namespace: Lucene.Net.Spatial.Utils
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public class BitwiseHelper
Visual Basic
Public Class BitwiseHelper
Visual C++
public ref class BitwiseHelper

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Utils..::..BitwiseHelper

See Also

BitwiseHelper Members
Lucene.Net.Spatial.Utils Namespace


BitwiseHelper Members

[image] [image]

Lucene.Net Class Libraries
BitwiseHelper Members
BitwiseHelper Class Constructors Methods See Also Send Feedback

The BitwiseHelper type exposes the following members.

Constructors

 | Name | Description
Public method | BitwiseHelper | Initializes a new instance of the BitwiseHelper class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ZeroFillRightShift |

See Also

BitwiseHelper Class
Lucene.Net.Spatial.Utils Namespace


BitwiseHelper Constructor

[image]

Lucene.Net Class Libraries
BitwiseHelper Constructor
BitwiseHelper Class See Also Send Feedback
Initializes a new instance of the BitwiseHelper class

Namespace: Lucene.Net.Spatial.Utils
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public BitwiseHelper()
Visual Basic
Public Sub New
Visual C++
public:
BitwiseHelper()

See Also

BitwiseHelper Class
Lucene.Net.Spatial.Utils Namespace


BitwiseHelper Methods

[image] [image]

Lucene.Net Class Libraries
BitwiseHelper Methods
BitwiseHelper Class See Also Send Feedback

The BitwiseHelper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ZeroFillRightShift |

See Also

BitwiseHelper Class
Lucene.Net.Spatial.Utils Namespace


ZeroFillRightShift Method

[image]

Lucene.Net Class Libraries
BitwiseHelper..::..ZeroFillRightShift Method
BitwiseHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Utils.BitwiseHelper.ZeroFillRightShift(System.Int64,System.Int32)"]

Namespace: Lucene.Net.Spatial.Utils
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static long ZeroFillRightShift(
    long i,
    int amountToShift
)
Visual Basic
Public Shared Function ZeroFillRightShift ( _
    i As Long, _
    amountToShift As Integer _
) As Long
Visual C++
public:
static long long ZeroFillRightShift(
    long long i,
    int amountToShift
)

Parameters

i
Type: System..::..Int64

[Missing <param name="i"/> documentation for "M:Lucene.Net.Spatial.Utils.BitwiseHelper.ZeroFillRightShift(System.Int64,System.Int32)"]

amountToShift
Type: System..::..Int32

[Missing <param name="amountToShift"/> documentation for "M:Lucene.Net.Spatial.Utils.BitwiseHelper.ZeroFillRightShift(System.Int64,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Utils.BitwiseHelper.ZeroFillRightShift(System.Int64,System.Int32)"]

See Also

BitwiseHelper Class
Lucene.Net.Spatial.Utils Namespace


MathHelper Class

[image]

Lucene.Net Class Libraries
MathHelper Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Spatial.Utils.MathHelper"]

Namespace: Lucene.Net.Spatial.Utils
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static class MathHelper
Visual Basic
Public NotInheritable Class MathHelper
Visual C++
public ref class MathHelper abstract sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Spatial.Utils..::..MathHelper

See Also

MathHelper Members
Lucene.Net.Spatial.Utils Namespace


MathHelper Members

[image] [image]

Lucene.Net Class Libraries
MathHelper Members
MathHelper Class Methods Properties See Also Send Feedback

The MathHelper type exposes the following members.

Methods

Name | Description
ToRadians |

Properties

Name | Description
PI |

See Also

MathHelper Class
Lucene.Net.Spatial.Utils Namespace


MathHelper Methods

[image] [image]

Lucene.Net Class Libraries
MathHelper Methods
MathHelper Class See Also Send Feedback

The MathHelper type exposes the following members.

Methods

Name | Description
ToRadians |

See Also

MathHelper Class
Lucene.Net.Spatial.Utils Namespace


ToRadians Method

[image]

Lucene.Net Class Libraries
MathHelper..::..ToRadians Method
MathHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Spatial.Utils.MathHelper.ToRadians(System.Double)"]

Namespace: Lucene.Net.Spatial.Utils
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double ToRadians(
    double degrees
)
Visual Basic
Public Shared Function ToRadians ( _
    degrees As Double _
) As Double
Visual C++
public:
static double ToRadians(
    double degrees
)

Parameters

degrees
Type: System..::..Double

[Missing <param name="degrees"/> documentation for "M:Lucene.Net.Spatial.Utils.MathHelper.ToRadians(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Spatial.Utils.MathHelper.ToRadians(System.Double)"]

See Also

MathHelper Class
Lucene.Net.Spatial.Utils Namespace


MathHelper Properties

[image] [image]

Lucene.Net Class Libraries
MathHelper Properties
MathHelper Class See Also Send Feedback

The MathHelper type exposes the following members.

Properties

Name | Description
PI |

See Also

MathHelper Class
Lucene.Net.Spatial.Utils Namespace


PI Property

[image]

Lucene.Net Class Libraries
MathHelper..::..PI Property
MathHelper Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Spatial.Utils.MathHelper.PI"]

Namespace: Lucene.Net.Spatial.Utils
Assembly: Lucene.Net.Contrib.Spatial (in Lucene.Net.Contrib.Spatial.dll) Version: 2.9.1.2 (2.9.1.002)

Syntax

C#
public static double PI { get; }
Visual Basic
Public Shared ReadOnly Property PI As Double
    Get
Visual C++
public:
static property double PI {
    double get ();
}

See Also

MathHelper Class
Lucene.Net.Spatial.Utils Namespace


Lucene.Net.Store Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Store Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Store"]

Classes

Class | Description
Public class AlreadyClosedException
This exception is thrown when there is an attempt to access something that has already been closed.
Public class BufferedIndexInput
Base implementation class for buffered {@link IndexInput}.
Public class BufferedIndexOutput
Base implementation class for buffered {@link IndexOutput}.
Public class ChecksumIndexInput
Writes bytes through to a primary IndexOutput, computing checksum as it goes. Note that you cannot use seek().
Public class ChecksumIndexOutput
Writes bytes through to a primary IndexOutput, computing checksum. Note that you cannot use seek().
Public class Directory
A Directory is a flat list of files. Files may be written once, when they are created. Once a file is created it may only be opened for read, or deleted. Random access is permitted both when reading and writing.

Java's i/o APIs not used directly, but rather all i/o is through this API. This permits things such as:

  • implementation of RAM-based indices;
  • implementation indices stored in a database, via JDBC;
  • implementation of an index as a single file;
Directory locking is implemented by an instance of {@link LockFactory}, and can be changed for each Directory instance using {@link #setLockFactory}.
Public class FileSwitchDirectory
Expert: A Directory instance that switches files between two other Directory instances.

Files with the specified extensions are placed in the primary directory; others are placed in the secondary directory. The provided Set must not change once passed to this class, and must allow multiple threads to call contains at once.

NOTE: this API is new and experimental and is subject to suddenly change in the next release.

Public class | FSDirectory
Public class | FSDirectory..::..FSIndexInput | Obsolete.
Protected class | FSDirectory..::..FSIndexInput..::..Descriptor | Obsolete.
Protected class | FSDirectory..::..FSIndexOutput | Obsolete.
Public class FSLockFactory
Base class for file system based locking implementation.
Public class IndexInput
Abstract base class for input from a file in a {@link Directory}. A random-access input stream. Used for all Lucene index input operations.
Public class IndexOutput
Abstract base class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.
Public class Lock
An interprocess mutex lock.

Typical use might look like:

            new Lock.With(directory.makeLock("my.lock")) {
            public Object doBody() {
            ... code to execute while locked ...
            }
            }.run();
Public class Lock..::..With
Utility class for executing code with exclusive access.
Public class LockFactory

Base class for Locking implementation. {@link Directory} uses instances of this class to implement locking.

Note that there are some useful tools to verify that your LockFactory is working correctly: {@link VerifyingLockFactory}, {@link LockStressTest}, {@link LockVerifyServer}.

Public class LockObtainFailedException
This exception is thrown when the
CopyC#
write.lock
 could not be acquired. This happens when a writer tries to open an index that another writer already has open.
Public class LockReleaseFailedException
This exception is thrown when the
CopyC#
write.lock
 could not be released.
Public class LockStressTest
Simple standalone tool that forever acquires & releases a lock using a specific LockFactory. Run without any args to see usage.
Public class LockVerifyServer
Simple standalone server that must be running when you use {@link VerifyingLockFactory}. This server simply verifies at most one process holds the lock at a time. Run without any args to see usage.
Public class MMapDirectory
File-based {@link Directory} implementation that uses mmap for reading, and {@link SimpleFSDirectory.SimpleFSIndexOutput} for writing.

NOTE: memory mapping uses up a portion of the virtual memory address space in your process equal to the size of the file being mapped. Before using this class, be sure your have plenty of virtual address space, e.g. by using a 64 bit JRE, or a 32 bit JRE with indexes that are guaranteed to fit within the address space. On 32 bit platforms also consult {@link #setMaxChunkSize} if you have problems with mmap failing because of fragmented address space. If you get an OutOfMemoryException, it is recommened to reduce the chunk size, until it works.

Due to this bug in Sun's JRE, MMapDirectory's {@link IndexInput#close} is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed.

This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of.

This class supplies the workaround mentioned in the bug report (disabled by default, see {@link #setUseUnmap}), which may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. {@link #UNMAP_SUPPORTED} is

CopyC#
true
, if the workaround can be enabled (with no guarantees).
Public class NativeFSLockFactory

Implements {@link LockFactory} using native OS file locks. Note that because this LockFactory relies on java.nio.* APIs for locking, any problems with those APIs will cause locking to fail. Specifically, on certain NFS environments the java.nio.* locks will fail (the lock can incorrectly be double acquired) whereas {@link SimpleFSLockFactory} worked perfectly in those same environments. For NFS based access to an index, it's recommended that you try {@link SimpleFSLockFactory} first and work around the one limitation that a lock file could be left when the JVM exits abnormally.

The primary benefit of {@link NativeFSLockFactory} is that lock files will be properly removed (by the OS) if the JVM has an abnormal exit.

Note that, unlike {@link SimpleFSLockFactory}, the existence of leftover lock files in the filesystem on exiting the JVM is fine because the OS will free the locks held against these files even though the files still remain.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.

Public class NIOFSDirectory
Not implemented. Waiting for volunteers.
Public class NIOFSDirectory..::..NIOFSIndexInput
Not implemented. Waiting for volunteers.
Public class NoLockFactory
Use this {@link LockFactory} to disable locking entirely. This LockFactory is used when you call {@link FSDirectory#setDisableLocks}. Only one instance of this lock is created. You should call {@link #GetNoLockFactory()} to get the instance.
Public class NoSuchDirectoryException
This exception is thrown when you try to list a non-existent directory.
Public class RAMDirectory
A memory-resident {@link Directory} implementation. Locking implementation is by default the {@link SingleInstanceLockFactory} but can be changed with {@link #setLockFactory}.
Public class | RAMFile
Public class RAMInputStream
A memory-resident {@link IndexInput} implementation.
Public class RAMOutputStream
A memory-resident {@link IndexOutput} implementation.
Public class SimpleFSDirectory
A straightforward implementation of {@link FSDirectory} using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use {@link NIOFSDirectory} or {@link MMapDirectory} instead.
Public class | SimpleFSDirectory..::..SimpleFSIndexInput
Protected class | SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Public class | SimpleFSDirectory..::..SimpleFSIndexOutput
Public class SimpleFSLockFactory

Implements {@link LockFactory} using {@link File#createNewFile()}.

NOTE: the javadocs for

CopyC#
File.createNewFile
contain a vague yet spooky warning about not using the API for file locking. This warning was added due to this bug, and in fact the only known problem with using this API for locking is that the Lucene write lock may not be released when the JVM exits abnormally.

When this happens, a {@link LockObtainFailedException} is hit when trying to create a writer, in which case you need to explicitly clear the lock file first. You can either manually remove the file, or use the {@link org.apache.lucene.index.IndexReader#unlock(Directory)} API. But, first be certain that no writer is in fact writing to the index otherwise you can easily corrupt your index.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.

Public class SingleInstanceLockFactory
Implements {@link LockFactory} for a single in-process instance, meaning all locking will take place through this one instance. Only use this {@link LockFactory} when you are certain all IndexReaders and IndexWriters for a given index are running against a single shared in-process Directory instance. This is currently the default locking for RAMDirectory.
Public class VerifyingLockFactory
A {@link LockFactory} that wraps another {@link LockFactory} and verifies that each lock obtain/release is "correct" (never results in two processes holding the lock at the same time). It does this by contacting an external server ({@link LockVerifyServer}) to assert that at most one process holds the lock at a time. To use this, you should also run {@link LockVerifyServer} on the host & port matching what you pass to the constructor.


AlreadyClosedException Class

[image]

Lucene.Net Class Libraries
AlreadyClosedException Class
Members See Also Send Feedback
This exception is thrown when there is an attempt to access something that has already been closed.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class AlreadyClosedException : SystemException
Visual Basic
<SerializableAttribute> _
Public Class AlreadyClosedException _
    Inherits SystemException
Visual C++
[SerializableAttribute]
public ref class AlreadyClosedException : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Lucene.Net.Store..::..AlreadyClosedException

See Also

AlreadyClosedException Members
Lucene.Net.Store Namespace


AlreadyClosedException Members

[image] [image]

Lucene.Net Class Libraries
AlreadyClosedException Members
AlreadyClosedException Class Constructors Methods Properties Events See Also Send Feedback

The AlreadyClosedException type exposes the following members.

Constructors

 | Name | Description
Public method | AlreadyClosedException(String) | Initializes a new instance of the AlreadyClosedException class
Protected method | AlreadyClosedException(SerializationInfo, StreamingContext) | Initializes a new instance of the AlreadyClosedException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AlreadyClosedException Class
Lucene.Net.Store Namespace


AlreadyClosedException Constructor

[image] [image]

Lucene.Net Class Libraries
AlreadyClosedException Constructor
AlreadyClosedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlreadyClosedException(String) | Initializes a new instance of the AlreadyClosedException class
Protected method | AlreadyClosedException(SerializationInfo, StreamingContext) | Initializes a new instance of the AlreadyClosedException class

See Also

AlreadyClosedException Class
AlreadyClosedException Members
Lucene.Net.Store Namespace


AlreadyClosedException Constructor (String)

[image]

Lucene.Net Class Libraries
AlreadyClosedException Constructor (String)
AlreadyClosedException Class See Also Send Feedback
Initializes a new instance of the AlreadyClosedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AlreadyClosedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
AlreadyClosedException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Store.AlreadyClosedException.#ctor(System.String)"]

See Also

AlreadyClosedException Class
AlreadyClosedException Overload
Lucene.Net.Store Namespace


AlreadyClosedException Constructor (SerializationInfo, StreamingContext)

[image]

Lucene.Net Class Libraries
AlreadyClosedException Constructor (SerializationInfo, StreamingContext)
AlreadyClosedException Class See Also Send Feedback
Initializes a new instance of the AlreadyClosedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected AlreadyClosedException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
AlreadyClosedException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo

[Missing <param name="info"/> documentation for "M:Lucene.Net.Store.AlreadyClosedException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:Lucene.Net.Store.AlreadyClosedException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

AlreadyClosedException Class
AlreadyClosedException Overload
Lucene.Net.Store Namespace


AlreadyClosedException Methods

[image] [image]

Lucene.Net Class Libraries
AlreadyClosedException Methods
AlreadyClosedException Class See Also Send Feedback

The AlreadyClosedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AlreadyClosedException Class
Lucene.Net.Store Namespace


AlreadyClosedException Properties

[image] [image]

Lucene.Net Class Libraries
AlreadyClosedException Properties
AlreadyClosedException Class See Also Send Feedback

The AlreadyClosedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AlreadyClosedException Class
Lucene.Net.Store Namespace


AlreadyClosedException Events

[image] [image]

Lucene.Net Class Libraries
AlreadyClosedException Events
AlreadyClosedException Class See Also Send Feedback

The AlreadyClosedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AlreadyClosedException Class
Lucene.Net.Store Namespace


BufferedIndexInput Class

[image]

Lucene.Net Class Libraries
BufferedIndexInput Class
Members See Also Send Feedback
Base implementation class for buffered {@link IndexInput}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class BufferedIndexInput : IndexInput,
    ICloneable
Visual Basic
Public MustInherit Class BufferedIndexInput _
    Inherits IndexInput _
    Implements ICloneable
Visual C++
public ref class BufferedIndexInput abstract : public IndexInput,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Store..::..BufferedIndexInput
Lucene.Net.Index..::..CompoundFileReader..::..CSIndexInput
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexInput

See Also

BufferedIndexInput Members
Lucene.Net.Store Namespace


BufferedIndexInput Members

[image] [image]

Lucene.Net Class Libraries
BufferedIndexInput Members
BufferedIndexInput Class Constructors Methods Fields See Also Send Feedback

The BufferedIndexInput type exposes the following members.

Constructors

 | Name | Description
Public method | BufferedIndexInput()()()() | Initializes a new instance of the BufferedIndexInput class
Public method | BufferedIndexInput(Int32) | Inits BufferedIndexInput with a specific bufferSize

Methods

 | Name | Description
Public method | Clone | (Overrides IndexInput..::..Clone()()()().)
Public method | Close | Closes the stream to futher operations. (Inherited from IndexInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize |
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file. (Inherited from IndexInput.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer |
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean).)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.
Public method | SetBufferSize | Change the buffer size used by this IndexInput
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer |
 | BUFFER_SIZE | Default buffer size

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


BufferedIndexInput Constructor

[image] [image]

Lucene.Net Class Libraries
BufferedIndexInput Constructor
BufferedIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BufferedIndexInput()()()() | Initializes a new instance of the BufferedIndexInput class
Public method | BufferedIndexInput(Int32) | Inits BufferedIndexInput with a specific bufferSize

See Also

BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace


BufferedIndexInput Constructor

[image]

Lucene.Net Class Libraries
BufferedIndexInput Constructor
BufferedIndexInput Class See Also Send Feedback
Initializes a new instance of the BufferedIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BufferedIndexInput()
Visual Basic
Public Sub New
Visual C++
public:
BufferedIndexInput()

See Also

BufferedIndexInput Class
BufferedIndexInput Overload
Lucene.Net.Store Namespace


BufferedIndexInput Constructor (Int32)

[image]

Lucene.Net Class Libraries
BufferedIndexInput Constructor (Int32)
BufferedIndexInput Class See Also Send Feedback
Inits BufferedIndexInput with a specific bufferSize

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BufferedIndexInput(
    int bufferSize
)
Visual Basic
Public Sub New ( _
    bufferSize As Integer _
)
Visual C++
public:
BufferedIndexInput(
    int bufferSize
)

Parameters

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.#ctor(System.Int32)"]

See Also

BufferedIndexInput Class
BufferedIndexInput Overload
Lucene.Net.Store Namespace


BufferedIndexInput Fields

[image] [image]

Lucene.Net Class Libraries
BufferedIndexInput Fields
BufferedIndexInput Class See Also Send Feedback

The BufferedIndexInput type exposes the following members.

Fields

 | Name | Description
Protected field | buffer |
 | BUFFER_SIZE | Default buffer size

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


buffer Field

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..buffer Field
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.BufferedIndexInput.buffer"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal byte[] buffer
Visual Basic
Protected Friend buffer As Byte()
Visual C++
protected public:
array<unsigned char>^ buffer

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


BUFFER_SIZE Field

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..BUFFER_SIZE Field
BufferedIndexInput Class See Also Send Feedback
Default buffer size

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int BUFFER_SIZE
Visual Basic
Public Const BUFFER_SIZE As Integer
Visual C++
public:
literal int BUFFER_SIZE

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


BufferedIndexInput Methods

[image] [image]

Lucene.Net Class Libraries
BufferedIndexInput Methods
BufferedIndexInput Class See Also Send Feedback

The BufferedIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides IndexInput..::..Clone()()()().)
Public method | Close | Closes the stream to futher operations. (Inherited from IndexInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize |
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file. (Inherited from IndexInput.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer |
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean).)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | Expert: implements buffer refill. Reads bytes from the current position in the input.
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SeekInternal | Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.
Public method | SetBufferSize | Change the buffer size used by this IndexInput
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


Clone Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..Clone Method
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.Clone"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.BufferedIndexInput.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


GetBufferSize Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..GetBufferSize Method
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.GetBufferSize"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetBufferSize()
Visual Basic
Public Overridable Function GetBufferSize As Integer
Visual C++
public:
virtual int GetBufferSize()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.BufferedIndexInput.GetBufferSize"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace
[!:setBufferSize]


GetFilePointer Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..GetFilePointer Method
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.GetFilePointer"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.BufferedIndexInput.GetFilePointer"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


NewBuffer Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..NewBuffer Method
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.NewBuffer(System.Byte[])"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void NewBuffer(
    byte[] newBuffer
)
Visual Basic
Protected Friend Overridable Sub NewBuffer ( _
    newBuffer As Byte() _
)
Visual C++
protected public:
virtual void NewBuffer(
    array<unsigned char>^ newBuffer
)

Parameters

newBuffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="newBuffer"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.NewBuffer(System.Byte[])"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


ReadByte Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..ReadByte Method
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadByte"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte ReadByte()
Visual Basic
Public Overrides Function ReadByte As Byte
Visual C++
public:
virtual unsigned char ReadByte() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadByte"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
BufferedIndexInput..::..ReadBytes Method
BufferedIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean).)

See Also

BufferedIndexInput Class
BufferedIndexInput Members
Lucene.Net.Store Namespace


ReadBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32)
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

BufferedIndexInput Class
ReadBytes Overload
Lucene.Net.Store Namespace


ReadBytes Method (Byte[], Int32, Int32, Boolean)

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32, Boolean)
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Boolean)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadBytes(
    byte[] b,
    int offset,
    int len,
    bool useBuffer
)
Visual Basic
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer, _
    useBuffer As Boolean _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len,
    bool useBuffer
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Boolean)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Boolean)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Boolean)"]

useBuffer
Type: System..::..Boolean

[Missing <param name="useBuffer"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Boolean)"]

See Also

BufferedIndexInput Class
ReadBytes Overload
Lucene.Net.Store Namespace


ReadInternal Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..ReadInternal Method
BufferedIndexInput Class See Also Send Feedback
Expert: implements buffer refill. Reads bytes from the current position in the input.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void ReadInternal(
    byte[] b,
    int offset,
    int length
)
Visual Basic
Public MustOverride Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int length
) abstract

Parameters

b
Type: array< System..::..Byte >[]()[][]
the array to read bytes into
offset
Type: System..::..Int32
the offset in the array to start storing bytes
length
Type: System..::..Int32
the number of bytes to read

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..Seek Method
BufferedIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.BufferedIndexInput.Seek(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.Seek(System.Int64)"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


SeekInternal Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..SeekInternal Method
BufferedIndexInput Class See Also Send Feedback
Expert: implements seek. Sets current position in this file, where the next {@link #ReadInternal(byte[],int,int)} will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void SeekInternal(
    long pos
)
Visual Basic
Public MustOverride Sub SeekInternal ( _
    pos As Long _
)
Visual C++
public:
virtual void SeekInternal(
    long long pos
) abstract

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.SeekInternal(System.Int64)"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace
BufferedIndexInput..::..ReadInternal(array<Byte>[]()[][], Int32, Int32)


SetBufferSize Method

[image]

Lucene.Net Class Libraries
BufferedIndexInput..::..SetBufferSize Method
BufferedIndexInput Class See Also Send Feedback
Change the buffer size used by this IndexInput

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetBufferSize(
    int newSize
)
Visual Basic
Public Overridable Sub SetBufferSize ( _
    newSize As Integer _
)
Visual C++
public:
virtual void SetBufferSize(
    int newSize
)

Parameters

newSize
Type: System..::..Int32

[Missing <param name="newSize"/> documentation for "M:Lucene.Net.Store.BufferedIndexInput.SetBufferSize(System.Int32)"]

See Also

BufferedIndexInput Class
Lucene.Net.Store Namespace


BufferedIndexOutput Class

[image]

Lucene.Net Class Libraries
BufferedIndexOutput Class
Members See Also Send Feedback
Base implementation class for buffered {@link IndexOutput}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class BufferedIndexOutput : IndexOutput
Visual Basic
Public MustInherit Class BufferedIndexOutput _
    Inherits IndexOutput
Visual C++
public ref class BufferedIndexOutput abstract : public IndexOutput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexOutput
Lucene.Net.Store..::..BufferedIndexOutput
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexOutput

See Also

BufferedIndexOutput Members
Lucene.Net.Store Namespace


BufferedIndexOutput Members

[image] [image]

Lucene.Net Class Libraries
BufferedIndexOutput Members
BufferedIndexOutput Class Constructors Methods See Also Send Feedback

The BufferedIndexOutput type exposes the following members.

Constructors

 | Name | Description
Protected method | BufferedIndexOutput | Initializes a new instance of the BufferedIndexOutput class

Methods

 | Name | Description
Public method | Close | Closes this stream to further operations. (Overrides IndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written. (Overrides IndexOutput..::..Flush()()()().)
Public method | FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur. (Overrides IndexOutput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file. (Overrides IndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Sets current position in this file, where the next write will occur. (Overrides IndexOutput..::..Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte. (Overrides IndexOutput..::..WriteByte(Byte).)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


BufferedIndexOutput Constructor

[image]

Lucene.Net Class Libraries
BufferedIndexOutput Constructor
BufferedIndexOutput Class See Also Send Feedback
Initializes a new instance of the BufferedIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected BufferedIndexOutput()
Visual Basic
Protected Sub New
Visual C++
protected:
BufferedIndexOutput()

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


BufferedIndexOutput Methods

[image] [image]

Lucene.Net Class Libraries
BufferedIndexOutput Methods
BufferedIndexOutput Class See Also Send Feedback

The BufferedIndexOutput type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes this stream to further operations. (Overrides IndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written. (Overrides IndexOutput..::..Flush()()()().)
Public method | FlushBuffer | Expert: implements buffer write. Writes bytes at the current position in the output.
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur. (Overrides IndexOutput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file. (Overrides IndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Sets current position in this file, where the next write will occur. (Overrides IndexOutput..::..Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte. (Overrides IndexOutput..::..WriteByte(Byte).)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..Close Method
BufferedIndexOutput Class See Also Send Feedback
Closes this stream to further operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


Flush Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..Flush Method
BufferedIndexOutput Class See Also Send Feedback
Forces any buffered output to be written.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


FlushBuffer Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..FlushBuffer Method
BufferedIndexOutput Class See Also Send Feedback
Expert: implements buffer write. Writes bytes at the current position in the output.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void FlushBuffer(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public MustOverride Sub FlushBuffer ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void FlushBuffer(
    array<unsigned char>^ b,
    int offset,
    int len
) abstract

Parameters

b
Type: array< System..::..Byte >[]()[][]
the bytes to write
offset
Type: System..::..Int32
the offset in the byte array
len
Type: System..::..Int32
the number of bytes to write

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..GetFilePointer Method
BufferedIndexOutput Class See Also Send Feedback
Returns the current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.BufferedIndexOutput.GetFilePointer"]

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace
BufferedIndexOutput..::..Seek(Int64)


Length Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..Length Method
BufferedIndexOutput Class See Also Send Feedback
The number of bytes in the file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long Length()
Visual Basic
Public MustOverride Function Length As Long
Visual C++
public:
virtual long long Length() abstract override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.BufferedIndexOutput.Length"]

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..Seek Method
BufferedIndexOutput Class See Also Send Feedback
Sets current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.BufferedIndexOutput.Seek(System.Int64)"]

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace
BufferedIndexOutput..::..GetFilePointer()()()()


WriteByte Method

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..WriteByte Method
BufferedIndexOutput Class See Also Send Feedback
Writes a single byte.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void WriteByte(
    byte b
)
Visual Basic
Public Overrides Sub WriteByte ( _
    b As Byte _
)
Visual C++
public:
virtual void WriteByte(
    unsigned char b
) override

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.BufferedIndexOutput.WriteByte(System.Byte)"]

See Also

BufferedIndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadByte()()()()


WriteBytes Method

[image] [image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..WriteBytes Method
BufferedIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)

See Also

BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace


WriteBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..WriteBytes Method (array<Byte>[]()[][], Int32, Int32)
BufferedIndexOutput Class See Also Send Feedback
Writes an array of bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void WriteBytes(
    byte[] b,
    int offset,
    int length
)
Visual Basic
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]
the bytes to write
offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.BufferedIndexOutput.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

length
Type: System..::..Int32
the number of bytes to write

See Also

BufferedIndexOutput Class
WriteBytes Overload
Lucene.Net.Store Namespace
IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32)


WriteChars Method

[image] [image]

Lucene.Net Class Libraries
BufferedIndexOutput..::..WriteChars Method
BufferedIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)

See Also

BufferedIndexOutput Class
BufferedIndexOutput Members
Lucene.Net.Store Namespace


ChecksumIndexInput Class

[image]

Lucene.Net Class Libraries
ChecksumIndexInput Class
Members See Also Send Feedback
Writes bytes through to a primary IndexOutput, computing checksum as it goes. Note that you cannot use seek().

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ChecksumIndexInput : IndexInput
Visual Basic
Public Class ChecksumIndexInput _
    Inherits IndexInput
Visual C++
public ref class ChecksumIndexInput : public IndexInput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Store..::..ChecksumIndexInput

See Also

ChecksumIndexInput Members
Lucene.Net.Store Namespace


ChecksumIndexInput Members

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexInput Members
ChecksumIndexInput Class Constructors Methods See Also Send Feedback

The ChecksumIndexInput type exposes the following members.

Constructors

 | Name | Description
Public method | ChecksumIndexInput | Initializes a new instance of the ChecksumIndexInput class

Methods

 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChecksum |
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


ChecksumIndexInput Constructor

[image]

Lucene.Net Class Libraries
ChecksumIndexInput Constructor
ChecksumIndexInput Class See Also Send Feedback
Initializes a new instance of the ChecksumIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ChecksumIndexInput(
    IndexInput main
)
Visual Basic
Public Sub New ( _
    main As IndexInput _
)
Visual C++
public:
ChecksumIndexInput(
    IndexInput^ main
)

Parameters

main
Type: Lucene.Net.Store..::..IndexInput

[Missing <param name="main"/> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.#ctor(Lucene.Net.Store.IndexInput)"]

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


ChecksumIndexInput Methods

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexInput Methods
ChecksumIndexInput Class See Also Send Feedback

The ChecksumIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChecksum |
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..Close Method
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


GetChecksum Method

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..GetChecksum Method
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.GetChecksum"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetChecksum()
Visual Basic
Public Overridable Function GetChecksum As Long
Visual C++
public:
virtual long long GetChecksum()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.GetChecksum"]

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..GetFilePointer Method
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.GetFilePointer"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.GetFilePointer"]

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


Length Method

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..Length Method
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.Length"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.Length"]

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


ReadByte Method

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..ReadByte Method
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.ReadByte"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte ReadByte()
Visual Basic
Public Overrides Function ReadByte As Byte
Visual C++
public:
virtual unsigned char ReadByte() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.ReadByte"]

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..ReadBytes Method
ChecksumIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)

See Also

ChecksumIndexInput Class
ChecksumIndexInput Members
Lucene.Net.Store Namespace


ReadBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32)
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

ChecksumIndexInput Class
ReadBytes Overload
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
ChecksumIndexInput..::..Seek Method
ChecksumIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.Seek(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.ChecksumIndexInput.Seek(System.Int64)"]

See Also

ChecksumIndexInput Class
Lucene.Net.Store Namespace


ChecksumIndexOutput Class

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput Class
Members See Also Send Feedback
Writes bytes through to a primary IndexOutput, computing checksum. Note that you cannot use seek().

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ChecksumIndexOutput : IndexOutput
Visual Basic
Public Class ChecksumIndexOutput _
    Inherits IndexOutput
Visual C++
public ref class ChecksumIndexOutput : public IndexOutput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexOutput
Lucene.Net.Store..::..ChecksumIndexOutput

See Also

ChecksumIndexOutput Members
Lucene.Net.Store Namespace


ChecksumIndexOutput Members

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexOutput Members
ChecksumIndexOutput Class Constructors Methods See Also Send Feedback

The ChecksumIndexOutput type exposes the following members.

Constructors

 | Name | Description
Public method | ChecksumIndexOutput | Initializes a new instance of the ChecksumIndexOutput class

Methods

 | Name | Description
Public method | Close | (Overrides IndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishCommit | See {@link #prepareCommit}
Public method | Flush | (Overrides IndexOutput..::..Flush()()()().)
Public method | GetChecksum |
Public method | GetFilePointer | (Overrides IndexOutput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareCommit | Starts but does not complete the commit of this file (= writing of the final checksum at the end). After this is called must call {@link #finishCommit} and the {@link #close} to complete the commit.
Public method | Seek | (Overrides IndexOutput..::..Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | (Overrides IndexOutput..::..WriteByte(Byte).)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


ChecksumIndexOutput Constructor

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput Constructor
ChecksumIndexOutput Class See Also Send Feedback
Initializes a new instance of the ChecksumIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ChecksumIndexOutput(
    IndexOutput main
)
Visual Basic
Public Sub New ( _
    main As IndexOutput _
)
Visual C++
public:
ChecksumIndexOutput(
    IndexOutput^ main
)

Parameters

main
Type: Lucene.Net.Store..::..IndexOutput

[Missing <param name="main"/> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.#ctor(Lucene.Net.Store.IndexOutput)"]

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


ChecksumIndexOutput Methods

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexOutput Methods
ChecksumIndexOutput Class See Also Send Feedback

The ChecksumIndexOutput type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides IndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishCommit | See {@link #prepareCommit}
Public method | Flush | (Overrides IndexOutput..::..Flush()()()().)
Public method | GetChecksum |
Public method | GetFilePointer | (Overrides IndexOutput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareCommit | Starts but does not complete the commit of this file (= writing of the final checksum at the end). After this is called must call {@link #finishCommit} and the {@link #close} to complete the commit.
Public method | Seek | (Overrides IndexOutput..::..Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | (Overrides IndexOutput..::..WriteByte(Byte).)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..Close Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


FinishCommit Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..FinishCommit Method
ChecksumIndexOutput Class See Also Send Feedback
See {@link #prepareCommit}

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FinishCommit()
Visual Basic
Public Overridable Sub FinishCommit
Visual C++
public:
virtual void FinishCommit()

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


Flush Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..Flush Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.Flush"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


GetChecksum Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..GetChecksum Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.GetChecksum"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetChecksum()
Visual Basic
Public Overridable Function GetChecksum As Long
Visual C++
public:
virtual long long GetChecksum()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.GetChecksum"]

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..GetFilePointer Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.GetFilePointer"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.GetFilePointer"]

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


Length Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..Length Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.Length"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.Length"]

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


PrepareCommit Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..PrepareCommit Method
ChecksumIndexOutput Class See Also Send Feedback
Starts but does not complete the commit of this file (= writing of the final checksum at the end). After this is called must call {@link #finishCommit} and the {@link #close} to complete the commit.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void PrepareCommit()
Visual Basic
Public Overridable Sub PrepareCommit
Visual C++
public:
virtual void PrepareCommit()

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..Seek Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.Seek(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.Seek(System.Int64)"]

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


WriteByte Method

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..WriteByte Method
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.WriteByte(System.Byte)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void WriteByte(
    byte b
)
Visual Basic
Public Overrides Sub WriteByte ( _
    b As Byte _
)
Visual C++
public:
virtual void WriteByte(
    unsigned char b
) override

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.WriteByte(System.Byte)"]

See Also

ChecksumIndexOutput Class
Lucene.Net.Store Namespace


WriteBytes Method

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..WriteBytes Method
ChecksumIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)

See Also

ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace


WriteBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..WriteBytes Method (array<Byte>[]()[][], Int32, Int32)
ChecksumIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void WriteBytes(
    byte[] b,
    int offset,
    int length
)
Visual Basic
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Store.ChecksumIndexOutput.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

ChecksumIndexOutput Class
WriteBytes Overload
Lucene.Net.Store Namespace


WriteChars Method

[image] [image]

Lucene.Net Class Libraries
ChecksumIndexOutput..::..WriteChars Method
ChecksumIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)

See Also

ChecksumIndexOutput Class
ChecksumIndexOutput Members
Lucene.Net.Store Namespace


Directory Class

[image]

Lucene.Net Class Libraries
Directory Class
Members See Also Send Feedback
A Directory is a flat list of files. Files may be written once, when they are created. Once a file is created it may only be opened for read, or deleted. Random access is permitted both when reading and writing.

Java's i/o APIs not used directly, but rather all i/o is through this API. This permits things such as:

  • implementation of RAM-based indices;
  • implementation indices stored in a database, via JDBC;
  • implementation of an index as a single file;
Directory locking is implemented by an instance of {@link LockFactory}, and can be changed for each Directory instance using {@link #setLockFactory}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class Directory : IDisposable
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Directory _
    Implements IDisposable
Visual C++
[SerializableAttribute]
public ref class Directory abstract : IDisposable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Index..::..CompoundFileReader
Lucene.Net.Store..::..FileSwitchDirectory
Lucene.Net.Store..::..FSDirectory
Lucene.Net.Store..::..RAMDirectory

See Also

Directory Members
Lucene.Net.Store Namespace


Directory Members

[image] [image]

Lucene.Net Class Libraries
Directory Members
Directory Class Constructors Methods Fields Properties See Also Send Feedback

The Directory type exposes the following members.

Constructors

 | Name | Description
Protected method | Directory | Initializes a new instance of the Directory class

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Close | Closes the store.
 | Copy | Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten. NOTE: the source directory cannot change while this method is running. Otherwise the results are undefined and you could easily hit a FileNotFoundException. NOTE: this method only copies files that look like index files (ie, have extensions matching the known extensions of index files).
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
Public method | DeleteFile | Removes an existing file in the directory.
Public method | Dispose | Releases all resources used by the Directory
Public method | EnsureOpen |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists.
Public method | FileLength | Returns the length of a file in the directory.
Public method | FileModified | Returns the time the named file was last modified.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete.
Public method | ListAll | Returns an array of strings, one for each file in the directory. Unlike {@link #list} this method does no filtering of the contents in a directory, and it will never return null (throws IOException instead). Currently this method simply fallsback to {@link #list} for Directory impls outside of Lucene's core & contrib, but in 3.0 that method will be removed and this method will become abstract.
Public method | MakeLock | Construct a {@link Lock}.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file.
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}.
Public method | RenameFile | Obsolete. Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement is not guaranteed to be atomic.
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | TouchFile | Set the modified time of an existing file to now.

Fields

 | Name | Description
Protected field | isOpen |
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance).

Properties

 | Name | Description
Public property | isOpen_ForNUnit |

See Also

Directory Class
Lucene.Net.Store Namespace


Directory Constructor

[image]

Lucene.Net Class Libraries
Directory Constructor
Directory Class See Also Send Feedback
Initializes a new instance of the Directory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Directory()
Visual Basic
Protected Sub New
Visual C++
protected:
Directory()

See Also

Directory Class
Lucene.Net.Store Namespace


Directory Fields

[image] [image]

Lucene.Net Class Libraries
Directory Fields
Directory Class See Also Send Feedback

The Directory type exposes the following members.

Fields

 | Name | Description
Protected field | isOpen |
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance).

See Also

Directory Class
Lucene.Net.Store Namespace


isOpen Field

[image]

Lucene.Net Class Libraries
Directory..::..isOpen Field
Directory Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.Directory.isOpen"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isOpen
Visual Basic
Protected Friend isOpen As Boolean
Visual C++
protected public:
bool isOpen

See Also

Directory Class
Lucene.Net.Store Namespace


lockFactory Field

[image]

Lucene.Net Class Libraries
Directory..::..lockFactory Field
Directory Class See Also Send Feedback
Holds the LockFactory instance (implements locking for this Directory instance).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[NonSerializedAttribute]
protected internal LockFactory lockFactory
Visual Basic
<NonSerializedAttribute> _
Protected Friend lockFactory As LockFactory
Visual C++
[NonSerializedAttribute]
protected public:
LockFactory^ lockFactory

See Also

Directory Class
Lucene.Net.Store Namespace


Directory Methods

[image] [image]

Lucene.Net Class Libraries
Directory Methods
Directory Class See Also Send Feedback

The Directory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Close | Closes the store.
 | Copy | Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten. NOTE: the source directory cannot change while this method is running. Otherwise the results are undefined and you could easily hit a FileNotFoundException. NOTE: this method only copies files that look like index files (ie, have extensions matching the known extensions of index files).
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file.
Public method | DeleteFile | Removes an existing file in the directory.
Public method | Dispose |
Public method | EnsureOpen |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists.
Public method | FileLength | Returns the length of a file in the directory.
Public method | FileModified | Returns the time the named file was last modified.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete.
Public method | ListAll | Returns an array of strings, one for each file in the directory. Unlike {@link #list} this method does no filtering of the contents in a directory, and it will never return null (throws IOException instead). Currently this method simply fallsback to {@link #list} for Directory impls outside of Lucene's core & contrib, but in 3.0 that method will be removed and this method will become abstract.
Public method | MakeLock | Construct a {@link Lock}.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file.
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}.
Public method | RenameFile | Obsolete. Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement is not guaranteed to be atomic.
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | TouchFile | Set the modified time of an existing file to now.

See Also

Directory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
Directory..::..ClearLock Method
Directory Class See Also Send Feedback
Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ClearLock(
    string name
)
Visual Basic
Public Overridable Sub ClearLock ( _
    name As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ name
)

Parameters

name
Type: System..::..String
name of the lock to be cleared.

See Also

Directory Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
Directory..::..Close Method
Directory Class See Also Send Feedback
Closes the store.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

Directory Class
Lucene.Net.Store Namespace


Copy Method

[image]

Lucene.Net Class Libraries
Directory..::..Copy Method
Directory Class See Also Send Feedback
Copy contents of a directory src to a directory dest. If a file in src already exists in dest then the one in dest will be blindly overwritten.

NOTE: the source directory cannot change while this method is running. Otherwise the results are undefined and you could easily hit a FileNotFoundException.

NOTE: this method only copies files that look like index files (ie, have extensions matching the known extensions of index files).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Copy(
    Directory src,
    Directory dest,
    bool closeDirSrc
)
Visual Basic
Public Shared Sub Copy ( _
    src As Directory, _
    dest As Directory, _
    closeDirSrc As Boolean _
)
Visual C++
public:
static void Copy(
    Directory^ src,
    Directory^ dest,
    bool closeDirSrc
)

Parameters

src
Type: Lucene.Net.Store..::..Directory
source directory
dest
Type: Lucene.Net.Store..::..Directory
destination directory
closeDirSrc
Type: System..::..Boolean
if
CopyC#
true
, call {@link #Close()} method on source directory

See Also

Directory Class
Lucene.Net.Store Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
Directory..::..CreateOutput Method
Directory Class See Also Send Feedback
Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract IndexOutput CreateOutput(
    string name
)
Visual Basic
Public MustOverride Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.CreateOutput(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


DeleteFile Method

[image]

Lucene.Net Class Libraries
Directory..::..DeleteFile Method
Directory Class See Also Send Feedback
Removes an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void DeleteFile(
    string name
)
Visual Basic
Public MustOverride Sub DeleteFile ( _
    name As String _
)
Visual C++
public:
virtual void DeleteFile(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.DeleteFile(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
Directory..::..Dispose Method
Directory Class See Also Send Feedback
Releases all resources used by the Directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Dispose()
Visual Basic
Public MustOverride Sub Dispose
Visual C++
public:
virtual void Dispose() abstract

Implements

IDisposable..::..Dispose()()()()

See Also

Directory Class
Lucene.Net.Store Namespace


EnsureOpen Method

[image]

Lucene.Net Class Libraries
Directory..::..EnsureOpen Method
Directory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.Directory.EnsureOpen"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void EnsureOpen()
Visual Basic
Public Sub EnsureOpen
Visual C++
public:
void EnsureOpen()

See Also

Directory Class
Lucene.Net.Store Namespace


FileExists Method

[image]

Lucene.Net Class Libraries
Directory..::..FileExists Method
Directory Class See Also Send Feedback
Returns true iff a file with the given name exists.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool FileExists(
    string name
)
Visual Basic
Public MustOverride Function FileExists ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool FileExists(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.FileExists(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.FileExists(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


FileLength Method

[image]

Lucene.Net Class Libraries
Directory..::..FileLength Method
Directory Class See Also Send Feedback
Returns the length of a file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long FileLength(
    string name
)
Visual Basic
Public MustOverride Function FileLength ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileLength(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.FileLength(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.FileLength(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


FileModified Method

[image]

Lucene.Net Class Libraries
Directory..::..FileModified Method
Directory Class See Also Send Feedback
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long FileModified(
    string name
)
Visual Basic
Public MustOverride Function FileModified ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileModified(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.FileModified(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.FileModified(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


GetLockFactory Method

[image]

Lucene.Net Class Libraries
Directory..::..GetLockFactory Method
Directory Class See Also Send Feedback
Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual LockFactory GetLockFactory()
Visual Basic
Public Overridable Function GetLockFactory As LockFactory
Visual C++
public:
virtual LockFactory^ GetLockFactory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.GetLockFactory"]

See Also

Directory Class
Lucene.Net.Store Namespace


GetLockID Method

[image]

Lucene.Net Class Libraries
Directory..::..GetLockID Method
Directory Class See Also Send Feedback
Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLockID()
Visual Basic
Public Overridable Function GetLockID As String
Visual C++
public:
virtual String^ GetLockID()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.GetLockID"]

See Also

Directory Class
Lucene.Net.Store Namespace


List Method

[image]

Lucene.Net Class Libraries
Directory..::..List Method
Directory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.Directory.List"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("For some Directory implementations (FSDirectory}, and its subclasses), this method silently filters its results to include only index files.  Please use ListAll instead, which does no filtering. ")]
public abstract string[] List()
Visual Basic
<ObsoleteAttribute("For some Directory implementations (FSDirectory}, and its subclasses), this method silently filters its results to include only index files.  Please use ListAll instead, which does no filtering. ")> _
Public MustOverride Function List As String()
Visual C++
[ObsoleteAttribute(L"For some Directory implementations (FSDirectory}, and its subclasses), this method silently filters its results to include only index files.  Please use ListAll instead, which does no filtering. ")]
public:
virtual array<String^>^ List() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.List"]

See Also

Directory Class
Lucene.Net.Store Namespace


ListAll Method

[image]

Lucene.Net Class Libraries
Directory..::..ListAll Method
Directory Class See Also Send Feedback
Returns an array of strings, one for each file in the directory. Unlike {@link #list} this method does no filtering of the contents in a directory, and it will never return null (throws IOException instead). Currently this method simply fallsback to {@link #list} for Directory impls outside of Lucene's core & contrib, but in 3.0 that method will be removed and this method will become abstract.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string[] ListAll()
Visual Basic
Public Overridable Function ListAll As String()
Visual C++
public:
virtual array<String^>^ ListAll()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.ListAll"]

See Also

Directory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
Directory..::..MakeLock Method
Directory Class See Also Send Feedback
Construct a {@link Lock}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Lock MakeLock(
    string name
)
Visual Basic
Public Overridable Function MakeLock ( _
    name As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ name
)

Parameters

name
Type: System..::..String
the name of the lock file

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.MakeLock(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
Directory..::..OpenInput Method
Directory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | Returns a stream reading an existing file.
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}.

See Also

Directory Class
Directory Members
Lucene.Net.Store Namespace


OpenInput Method (String)

[image]

Lucene.Net Class Libraries
Directory..::..OpenInput Method (String)
Directory Class See Also Send Feedback
Returns a stream reading an existing file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract IndexInput OpenInput(
    string name
)
Visual Basic
Public MustOverride Function OpenInput ( _
    name As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.OpenInput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.OpenInput(System.String)"]

See Also

Directory Class
OpenInput Overload
Lucene.Net.Store Namespace


OpenInput Method (String, Int32)

[image]

Lucene.Net Class Libraries
Directory..::..OpenInput Method (String, Int32)
Directory Class See Also Send Feedback
Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IndexInput OpenInput(
    string name,
    int bufferSize
)
Visual Basic
Public Overridable Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.OpenInput(System.String,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.Directory.OpenInput(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.OpenInput(System.String,System.Int32)"]

See Also

Directory Class
OpenInput Overload
Lucene.Net.Store Namespace


RenameFile Method

[image]

Lucene.Net Class Libraries
Directory..::..RenameFile Method
Directory Class See Also Send Feedback
Renames an existing file in the directory. If a file already exists with the new name, then it is replaced. This replacement is not guaranteed to be atomic.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public abstract void RenameFile(
    string from,
    string to
)
Visual Basic
<ObsoleteAttribute> _
Public MustOverride Sub RenameFile ( _
    from As String, _
    to As String _
)
Visual C++
[ObsoleteAttribute]
public:
virtual void RenameFile(
    String^ from,
    String^ to
) abstract

Parameters

from
Type: System..::..String

[Missing <param name="from"/> documentation for "M:Lucene.Net.Store.Directory.RenameFile(System.String,System.String)"]

to
Type: System..::..String

[Missing <param name="to"/> documentation for "M:Lucene.Net.Store.Directory.RenameFile(System.String,System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


SetLockFactory Method

[image]

Lucene.Net Class Libraries
Directory..::..SetLockFactory Method
Directory Class See Also Send Feedback
Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetLockFactory(
    LockFactory lockFactory
)
Visual Basic
Public Overridable Sub SetLockFactory ( _
    lockFactory As LockFactory _
)
Visual C++
public:
virtual void SetLockFactory(
    LockFactory^ lockFactory
)

Parameters

lockFactory
Type: Lucene.Net.Store..::..LockFactory
instance of {@link LockFactory}.

See Also

Directory Class
Lucene.Net.Store Namespace


Sync Method

[image]

Lucene.Net Class Libraries
Directory..::..Sync Method
Directory Class See Also Send Feedback
Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Sync(
    string name
)
Visual Basic
Public Overridable Sub Sync ( _
    name As String _
)
Visual C++
public:
virtual void Sync(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.Sync(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Directory..::..ToString Method
Directory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.Directory.ToString"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Directory.ToString"]

See Also

Directory Class
Lucene.Net.Store Namespace


TouchFile Method

[image]

Lucene.Net Class Libraries
Directory..::..TouchFile Method
Directory Class See Also Send Feedback
Set the modified time of an existing file to now.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void TouchFile(
    string name
)
Visual Basic
Public MustOverride Sub TouchFile ( _
    name As String _
)
Visual C++
public:
virtual void TouchFile(
    String^ name
) abstract

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.Directory.TouchFile(System.String)"]

See Also

Directory Class
Lucene.Net.Store Namespace


Directory Properties

[image] [image]

Lucene.Net Class Libraries
Directory Properties
Directory Class See Also Send Feedback

The Directory type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit |

See Also

Directory Class
Lucene.Net.Store Namespace


isOpen_ForNUnit Property

[image]

Lucene.Net Class Libraries
Directory..::..isOpen_ForNUnit Property
Directory Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.Directory.isOpen_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool isOpen_ForNUnit { get; }
Visual Basic
Public ReadOnly Property isOpen_ForNUnit As Boolean
    Get
Visual C++
public:
property bool isOpen_ForNUnit {
    bool get ();
}

See Also

Directory Class
Lucene.Net.Store Namespace


FileSwitchDirectory Class

[image]

Lucene.Net Class Libraries
FileSwitchDirectory Class
Members See Also Send Feedback
Expert: A Directory instance that switches files between two other Directory instances.

Files with the specified extensions are placed in the primary directory; others are placed in the secondary directory. The provided Set must not change once passed to this class, and must allow multiple threads to call contains at once.

NOTE: this API is new and experimental and is subject to suddenly change in the next release.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FileSwitchDirectory : Directory
Visual Basic
Public Class FileSwitchDirectory _
    Inherits Directory
Visual C++
public ref class FileSwitchDirectory : public Directory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..FileSwitchDirectory

See Also

FileSwitchDirectory Members
Lucene.Net.Store Namespace


FileSwitchDirectory Members

[image] [image]

Lucene.Net Class Libraries
FileSwitchDirectory Members
FileSwitchDirectory Class Constructors Methods Fields Properties See Also Send Feedback

The FileSwitchDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | FileSwitchDirectory | Initializes a new instance of the FileSwitchDirectory class

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Overrides Directory..::..FileExists(String).)
Public method | FileLength | (Overrides Directory..::..FileLength(String).)
Public method | FileModified | (Overrides Directory..::..FileModified(String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtension | Utility method to return a file's extension.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | GetPrimaryDir | Return the primary directory
Public method | GetSecondaryDir | Return the secondary directory
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete. (Overrides Directory..::..List()()()().)
Public method | ListAll | (Overrides Directory..::..ListAll()()()().)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}. (Inherited from Directory.)
Public method | RenameFile | Obsolete. (Overrides Directory..::..RenameFile(String, String).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Overrides Directory..::..Sync(String).)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | (Overrides Directory..::..TouchFile(String).)

Fields

 | Name | Description
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileSwitchDirectory Constructor

[image]

Lucene.Net Class Libraries
FileSwitchDirectory Constructor
FileSwitchDirectory Class See Also Send Feedback
Initializes a new instance of the FileSwitchDirectory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FileSwitchDirectory(
    Hashtable primaryExtensions,
    Directory primaryDir,
    Directory secondaryDir,
    bool doClose
)
Visual Basic
Public Sub New ( _
    primaryExtensions As Hashtable, _
    primaryDir As Directory, _
    secondaryDir As Directory, _
    doClose As Boolean _
)
Visual C++
public:
FileSwitchDirectory(
    Hashtable^ primaryExtensions,
    Directory^ primaryDir,
    Directory^ secondaryDir,
    bool doClose
)

Parameters

primaryExtensions
Type: System.Collections..::..Hashtable

[Missing <param name="primaryExtensions"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.#ctor(System.Collections.Hashtable,Lucene.Net.Store.Directory,Lucene.Net.Store.Directory,System.Boolean)"]

primaryDir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="primaryDir"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.#ctor(System.Collections.Hashtable,Lucene.Net.Store.Directory,Lucene.Net.Store.Directory,System.Boolean)"]

secondaryDir
Type: Lucene.Net.Store..::..Directory

[Missing <param name="secondaryDir"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.#ctor(System.Collections.Hashtable,Lucene.Net.Store.Directory,Lucene.Net.Store.Directory,System.Boolean)"]

doClose
Type: System..::..Boolean

[Missing <param name="doClose"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.#ctor(System.Collections.Hashtable,Lucene.Net.Store.Directory,Lucene.Net.Store.Directory,System.Boolean)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileSwitchDirectory Fields

[image] [image]

Lucene.Net Class Libraries
FileSwitchDirectory Fields
FileSwitchDirectory Class See Also Send Feedback

The FileSwitchDirectory type exposes the following members.

Fields

 | Name | Description
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileSwitchDirectory Methods

[image] [image]

Lucene.Net Class Libraries
FileSwitchDirectory Methods
FileSwitchDirectory Class See Also Send Feedback

The FileSwitchDirectory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Overrides Directory..::..FileExists(String).)
Public method | FileLength | (Overrides Directory..::..FileLength(String).)
Public method | FileModified | (Overrides Directory..::..FileModified(String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtension | Utility method to return a file's extension.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | GetPrimaryDir | Return the primary directory
Public method | GetSecondaryDir | Return the secondary directory
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete. (Overrides Directory..::..List()()()().)
Public method | ListAll | (Overrides Directory..::..ListAll()()()().)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}. (Inherited from Directory.)
Public method | RenameFile | Obsolete. (Overrides Directory..::..RenameFile(String, String).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | Sync | (Overrides Directory..::..Sync(String).)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | (Overrides Directory..::..TouchFile(String).)

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..Close Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..CreateOutput Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.CreateOutput(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.CreateOutput(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


DeleteFile Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..DeleteFile Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.DeleteFile(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void DeleteFile(
    string name
)
Visual Basic
Public Overrides Sub DeleteFile ( _
    name As String _
)
Visual C++
public:
virtual void DeleteFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.DeleteFile(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..Dispose Method
FileSwitchDirectory Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::..Dispose()()()()

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileExists Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..FileExists Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileExists(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool FileExists(
    string name
)
Visual Basic
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool FileExists(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileExists(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileExists(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileLength Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..FileLength Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileLength(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileLength(
    string name
)
Visual Basic
Public Overrides Function FileLength ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileLength(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileLength(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileLength(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileModified Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..FileModified Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileModified(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileModified(
    string name
)
Visual Basic
Public Overrides Function FileModified ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileModified(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileModified(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.FileModified(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


GetExtension Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..GetExtension Method
FileSwitchDirectory Class See Also Send Feedback
Utility method to return a file's extension.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string GetExtension(
    string name
)
Visual Basic
Public Shared Function GetExtension ( _
    name As String _
) As String
Visual C++
public:
static String^ GetExtension(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.GetExtension(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.GetExtension(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


GetPrimaryDir Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..GetPrimaryDir Method
FileSwitchDirectory Class See Also Send Feedback
Return the primary directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Directory GetPrimaryDir()
Visual Basic
Public Overridable Function GetPrimaryDir As Directory
Visual C++
public:
virtual Directory^ GetPrimaryDir()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.GetPrimaryDir"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


GetSecondaryDir Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..GetSecondaryDir Method
FileSwitchDirectory Class See Also Send Feedback
Return the secondary directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Directory GetSecondaryDir()
Visual Basic
Public Overridable Function GetSecondaryDir As Directory
Visual C++
public:
virtual Directory^ GetSecondaryDir()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.GetSecondaryDir"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


List Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..List Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.List"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public override string[] List()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")> _
Public Overrides Function List As String()
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public:
virtual array<String^>^ List() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.List"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


ListAll Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..ListAll Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.ListAll"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string[] ListAll()
Visual Basic
Public Overrides Function ListAll As String()
Visual C++
public:
virtual array<String^>^ ListAll() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.ListAll"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..OpenInput Method
FileSwitchDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}. (Inherited from Directory.)

See Also

FileSwitchDirectory Class
FileSwitchDirectory Members
Lucene.Net.Store Namespace


OpenInput Method (String)

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..OpenInput Method (String)
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.OpenInput(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string name
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.OpenInput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.OpenInput(System.String)"]

See Also

FileSwitchDirectory Class
OpenInput Overload
Lucene.Net.Store Namespace


RenameFile Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..RenameFile Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.RenameFile(System.String,System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.RenameFile(string, string)")]
public override void RenameFile(
    string from,
    string to
)
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.RenameFile(string, string)")> _
Public Overrides Sub RenameFile ( _
    from As String, _
    to As String _
)
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.RenameFile(string, string)")]
public:
virtual void RenameFile(
    String^ from,
    String^ to
) override

Parameters

from
Type: System..::..String

[Missing <param name="from"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.RenameFile(System.String,System.String)"]

to
Type: System..::..String

[Missing <param name="to"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.RenameFile(System.String,System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


Sync Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..Sync Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.Sync(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Sync(
    string name
)
Visual Basic
Public Overrides Sub Sync ( _
    name As String _
)
Visual C++
public:
virtual void Sync(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.Sync(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


TouchFile Method

[image]

Lucene.Net Class Libraries
FileSwitchDirectory..::..TouchFile Method
FileSwitchDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.TouchFile(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void TouchFile(
    string name
)
Visual Basic
Public Overrides Sub TouchFile ( _
    name As String _
)
Visual C++
public:
virtual void TouchFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FileSwitchDirectory.TouchFile(System.String)"]

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FileSwitchDirectory Properties

[image] [image]

Lucene.Net Class Libraries
FileSwitchDirectory Properties
FileSwitchDirectory Class See Also Send Feedback

The FileSwitchDirectory type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

FileSwitchDirectory Class
Lucene.Net.Store Namespace


FSDirectory Class

[image]

Lucene.Net Class Libraries
FSDirectory Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.FSDirectory"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class FSDirectory : Directory
Visual Basic
Public Class FSDirectory _
    Inherits Directory
Visual C++
public ref class FSDirectory : public Directory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..FSDirectory
Lucene.Net.Store..::..MMapDirectory
Lucene.Net.Store..::..NIOFSDirectory
Lucene.Net.Store..::..SimpleFSDirectory

See Also

FSDirectory Members
Lucene.Net.Store Namespace


FSDirectory Members

[image] [image]

Lucene.Net Class Libraries
FSDirectory Members
FSDirectory Class Constructors Methods Fields Properties See Also Send Feedback

The FSDirectory type exposes the following members.

Constructors

 | Name | Description
Protected method | FSDirectory()()()() | Obsolete. Initializes a new instance of the FSDirectory class
Protected method | FSDirectory(DirectoryInfo, LockFactory) | Create a new FSDirectory for the named location (ctor for subclasses).

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations. (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. In 3.0 this method will become abstract. (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory..::..FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory..::..FileLength(String).)
Public method | FileModified(String) | Returns the time the named file was last modified. (Overrides Directory..::..FileModified(String).)
 | FileModified(FileInfo, String) | Returns the time the named file was last modified.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory()()()() |
 | GetDirectory(DirectoryInfo) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(DirectoryInfo, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(DirectoryInfo, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDisableLocks | Obsolete. Returns whether Lucene's use of lock files is disabled.
Public method | GetFile | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | (Overrides Directory..::..GetLockID()()()().)
Public method | GetReadChunkSize | The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}.
Public method | List | Obsolete. (Overrides Directory..::..List()()()().)
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Overrides Directory..::..ListAll()()()().)
 | ListAll(DirectoryInfo) | Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
 | ListAll(FileInfo) | Obsolete. Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open(DirectoryInfo) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(FileInfo) | Obsolete. Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(DirectoryInfo, LockFactory) | Just like {@link #Open(File)}, but allows you to also specify a custom {@link LockFactory}.
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract. (Overrides Directory..::..OpenInput(String, Int32).)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. Warning: This is not atomic. (Overrides Directory..::..RenameFile(String, String).)
 | SetDisableLocks | Obsolete. Set whether Lucene's use of lock files is disabled. By default, lock files are enabled. They should only be disabled if the index is on a read-only medium like a CD-ROM.
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SetReadChunkSize | Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE}; This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size. Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory. NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size.
Public method | Sync | (Overrides Directory..::..Sync(String).)
Public method | ToString | For debug output. (Overrides Directory..::..ToString()()()().)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory..::..TouchFile(String).)

Fields

Name | Description
DEFAULT_READ_CHUNK_SIZE
Default read chunk size. This is a conditional default: on 32bit JVMs, it defaults to 100 MB. On 64bit JVMs, it's
CopyC#
Integer.MAX_VALUE
.
Protected field directory
The underlying filesystem directory
Protected field | isOpen | (Inherited from Directory.)
Protected field lockFactory
Holds the LockFactory instance (implements locking for this Directory instance).
(Inherited from Directory.)

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FSDirectory Constructor

[image] [image]

Lucene.Net Class Libraries
FSDirectory Constructor
FSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | FSDirectory()()()() | Obsolete. Initializes a new instance of the FSDirectory class
Protected method | FSDirectory(DirectoryInfo, LockFactory) | Create a new FSDirectory for the named location (ctor for subclasses).

See Also

FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace


FSDirectory Constructor

[image]

Lucene.Net Class Libraries
FSDirectory Constructor
FSDirectory Class See Also Send Feedback
Initializes a new instance of the FSDirectory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal FSDirectory()
Visual Basic
<ObsoleteAttribute> _
Protected Friend Sub New
Visual C++
[ObsoleteAttribute]
protected public:
FSDirectory()

See Also

FSDirectory Class
FSDirectory Overload
Lucene.Net.Store Namespace


FSDirectory Constructor (DirectoryInfo, LockFactory)

[image]

Lucene.Net Class Libraries
FSDirectory Constructor (DirectoryInfo, LockFactory)
FSDirectory Class See Also Send Feedback
Create a new FSDirectory for the named location (ctor for subclasses).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal FSDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
Visual Basic
Protected Friend Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
Visual C++
protected public:
FSDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System.IO..::..DirectoryInfo
the path of the directory
lockFactory
Type: Lucene.Net.Store..::..LockFactory
the lock factory to use, or null for the default ({@link NativeFSLockFactory});

See Also

FSDirectory Class
FSDirectory Overload
Lucene.Net.Store Namespace


FSDirectory Fields

[image] [image]

Lucene.Net Class Libraries
FSDirectory Fields
FSDirectory Class See Also Send Feedback

The FSDirectory type exposes the following members.

Fields

Name | Description
DEFAULT_READ_CHUNK_SIZE
Default read chunk size. This is a conditional default: on 32bit JVMs, it defaults to 100 MB. On 64bit JVMs, it's
CopyC#
Integer.MAX_VALUE
.
Protected field directory
The underlying filesystem directory
Protected field | isOpen | (Inherited from Directory.)
Protected field lockFactory
Holds the LockFactory instance (implements locking for this Directory instance).
(Inherited from Directory.)

See Also

FSDirectory Class
Lucene.Net.Store Namespace


DEFAULT_READ_CHUNK_SIZE Field

[image]

Lucene.Net Class Libraries
FSDirectory..::..DEFAULT_READ_CHUNK_SIZE Field
FSDirectory Class See Also Send Feedback
Default read chunk size. This is a conditional default: on 32bit JVMs, it defaults to 100 MB. On 64bit JVMs, it's
CopyC#
Integer.MAX_VALUE
.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly int DEFAULT_READ_CHUNK_SIZE
Visual Basic
Public Shared ReadOnly DEFAULT_READ_CHUNK_SIZE As Integer
Visual C++
public:
static initonly int DEFAULT_READ_CHUNK_SIZE

See Also

FSDirectory Class
Lucene.Net.Store Namespace
[!:setReadChunkSize]


directory Field

[image]

Lucene.Net Class Libraries
FSDirectory..::..directory Field
FSDirectory Class See Also Send Feedback
The underlying filesystem directory

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal DirectoryInfo directory
Visual Basic
Protected Friend directory As DirectoryInfo
Visual C++
protected public:
DirectoryInfo^ directory

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FSDirectory Methods

[image] [image]

Lucene.Net Class Libraries
FSDirectory Methods
FSDirectory Class See Also Send Feedback

The FSDirectory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations. (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. In 3.0 this method will become abstract. (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Overrides Directory..::..FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory..::..FileLength(String).)
Public method | FileModified(String) | Returns the time the named file was last modified. (Overrides Directory..::..FileModified(String).)
 | FileModified(FileInfo, String) | Returns the time the named file was last modified.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory()()()() |
 | GetDirectory(DirectoryInfo) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(DirectoryInfo, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(DirectoryInfo, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDisableLocks | Obsolete. Returns whether Lucene's use of lock files is disabled.
Public method | GetFile | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | (Overrides Directory..::..GetLockID()()()().)
Public method | GetReadChunkSize | The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}.
Public method | List | Obsolete. (Overrides Directory..::..List()()()().)
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Overrides Directory..::..ListAll()()()().)
 | ListAll(DirectoryInfo) | Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
 | ListAll(FileInfo) | Obsolete. Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open(DirectoryInfo) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(FileInfo) | Obsolete. Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
 | Open(DirectoryInfo, LockFactory) | Just like {@link #Open(File)}, but allows you to also specify a custom {@link LockFactory}.
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract. (Overrides Directory..::..OpenInput(String, Int32).)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. Warning: This is not atomic. (Overrides Directory..::..RenameFile(String, String).)
 | SetDisableLocks | Obsolete. Set whether Lucene's use of lock files is disabled. By default, lock files are enabled. They should only be disabled if the index is on a read-only medium like a CD-ROM.
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SetReadChunkSize | Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE}; This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size. Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory. NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size.
Public method | Sync | (Overrides Directory..::..Sync(String).)
Public method | ToString | For debug output. (Overrides Directory..::..ToString()()()().)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory..::..TouchFile(String).)

See Also

FSDirectory Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..Close Method
FSDirectory Class See Also Send Feedback
Closes the store to future operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

FSDirectory Class
Lucene.Net.Store Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..CreateOutput Method
FSDirectory Class See Also Send Feedback
Creates an IndexOutput for the file with the given name. In 3.0 this method will become abstract.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.CreateOutput(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


DeleteFile Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..DeleteFile Method
FSDirectory Class See Also Send Feedback
Removes an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void DeleteFile(
    string name
)
Visual Basic
Public Overrides Sub DeleteFile ( _
    name As String _
)
Visual C++
public:
virtual void DeleteFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.DeleteFile(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..Dispose Method
FSDirectory Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::..Dispose()()()()

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FileExists Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..FileExists Method
FSDirectory Class See Also Send Feedback
Returns true iff a file with the given name exists.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool FileExists(
    string name
)
Visual Basic
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool FileExists(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.FileExists(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.FileExists(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FileLength Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..FileLength Method
FSDirectory Class See Also Send Feedback
Returns the length in bytes of a file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileLength(
    string name
)
Visual Basic
Public Overrides Function FileLength ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileLength(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.FileLength(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.FileLength(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FileModified Method

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FileModified Method
FSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileModified(String) | Returns the time the named file was last modified. (Overrides Directory..::..FileModified(String).)
 | FileModified(FileInfo, String) | Returns the time the named file was last modified.

See Also

FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace


FileModified Method (String)

[image]

Lucene.Net Class Libraries
FSDirectory..::..FileModified Method (String)
FSDirectory Class See Also Send Feedback
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileModified(
    string name
)
Visual Basic
Public Overrides Function FileModified ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileModified(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.FileModified(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.FileModified(System.String)"]

See Also

FSDirectory Class
FileModified Overload
Lucene.Net.Store Namespace


FileModified Method (FileInfo, String)

[image]

Lucene.Net Class Libraries
FSDirectory..::..FileModified Method (FileInfo, String)
FSDirectory Class See Also Send Feedback
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long FileModified(
    FileInfo directory,
    string name
)
Visual Basic
Public Shared Function FileModified ( _
    directory As FileInfo, _
    name As String _
) As Long
Visual C++
public:
static long long FileModified(
    FileInfo^ directory,
    String^ name
)

Parameters

directory
Type: System.IO..::..FileInfo

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Store.FSDirectory.FileModified(System.IO.FileInfo,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.FileModified(System.IO.FileInfo,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.FileModified(System.IO.FileInfo,System.String)"]

See Also

FSDirectory Class
FileModified Overload
Lucene.Net.Store Namespace


GetDirectory Method

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method
FSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDirectory()()()() |
 | GetDirectory(DirectoryInfo) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(DirectoryInfo, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(DirectoryInfo, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(FileInfo, Boolean) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String, LockFactory) | Obsolete. Returns the directory instance for the named location.
 | GetDirectory(String, Boolean) | Obsolete. Returns the directory instance for the named location.

See Also

FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace


GetDirectory Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method
FSDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FSDirectory.GetDirectory"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual DirectoryInfo GetDirectory()
Visual Basic
Public Overridable Function GetDirectory As DirectoryInfo
Visual C++
public:
virtual DirectoryInfo^ GetDirectory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.GetDirectory"]

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (DirectoryInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (DirectoryInfo)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(File)")]
public static FSDirectory GetDirectory(
    DirectoryInfo file
)
Visual Basic
<ObsoleteAttribute("Use Open(File)")> _
Public Shared Function GetDirectory ( _
    file As DirectoryInfo _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use Open(File)")]
public:
static FSDirectory^ GetDirectory(
    DirectoryInfo^ file
)

Parameters

file
Type: System.IO..::..DirectoryInfo
the path to the directory.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (FileInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (FileInfo)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public static FSDirectory GetDirectory(
    FileInfo file
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Shared Function GetDirectory ( _
    file As FileInfo _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
static FSDirectory^ GetDirectory(
    FileInfo^ file
)

Parameters

file
Type: System.IO..::..FileInfo
the path to the directory.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (String)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (String)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(File)")]
public static FSDirectory GetDirectory(
    string path
)
Visual Basic
<ObsoleteAttribute("Use Open(File)")> _
Public Shared Function GetDirectory ( _
    path As String _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use Open(File)")]
public:
static FSDirectory^ GetDirectory(
    String^ path
)

Parameters

path
Type: System..::..String
the path to the directory.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (DirectoryInfo, LockFactory)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (DirectoryInfo, LockFactory)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(File, LockFactory)")]
public static FSDirectory GetDirectory(
    DirectoryInfo file,
    LockFactory lockFactory
)
Visual Basic
<ObsoleteAttribute("Use Open(File, LockFactory)")> _
Public Shared Function GetDirectory ( _
    file As DirectoryInfo, _
    lockFactory As LockFactory _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use Open(File, LockFactory)")]
public:
static FSDirectory^ GetDirectory(
    DirectoryInfo^ file,
    LockFactory^ lockFactory
)

Parameters

file
Type: System.IO..::..DirectoryInfo
the path to the directory.
lockFactory
Type: Lucene.Net.Store..::..LockFactory
instance of {@link LockFactory} providing the locking implementation.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (DirectoryInfo, Boolean)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (DirectoryInfo, Boolean)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexWriter's create flag, instead, to create a new index.")]
public static FSDirectory GetDirectory(
    DirectoryInfo file,
    bool create
)
Visual Basic
<ObsoleteAttribute("Use IndexWriter's create flag, instead, to create a new index.")> _
Public Shared Function GetDirectory ( _
    file As DirectoryInfo, _
    create As Boolean _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use IndexWriter's create flag, instead, to create a new index.")]
public:
static FSDirectory^ GetDirectory(
    DirectoryInfo^ file,
    bool create
)

Parameters

file
Type: System.IO..::..DirectoryInfo
the path to the directory.
create
Type: System..::..Boolean
if true, create, or erase any existing contents.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (FileInfo, LockFactory)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (FileInfo, LockFactory)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public static FSDirectory GetDirectory(
    FileInfo file,
    LockFactory lockFactory
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Shared Function GetDirectory ( _
    file As FileInfo, _
    lockFactory As LockFactory _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
static FSDirectory^ GetDirectory(
    FileInfo^ file,
    LockFactory^ lockFactory
)

Parameters

file
Type: System.IO..::..FileInfo
the path to the directory.
lockFactory
Type: Lucene.Net.Store..::..LockFactory
instance of {@link LockFactory} providing the locking implementation.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (FileInfo, Boolean)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (FileInfo, Boolean)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public static FSDirectory GetDirectory(
    FileInfo file,
    bool create
)
Visual Basic
<ObsoleteAttribute("Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Shared Function GetDirectory ( _
    file As FileInfo, _
    create As Boolean _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
static FSDirectory^ GetDirectory(
    FileInfo^ file,
    bool create
)

Parameters

file
Type: System.IO..::..FileInfo
the path to the directory.
create
Type: System..::..Boolean
if true, create, or erase any existing contents.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (String, LockFactory)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (String, LockFactory)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use Open(File, LockFactory)")]
public static FSDirectory GetDirectory(
    string path,
    LockFactory lockFactory
)
Visual Basic
<ObsoleteAttribute("Use Open(File, LockFactory)")> _
Public Shared Function GetDirectory ( _
    path As String, _
    lockFactory As LockFactory _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use Open(File, LockFactory)")]
public:
static FSDirectory^ GetDirectory(
    String^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System..::..String
the path to the directory.
lockFactory
Type: Lucene.Net.Store..::..LockFactory
instance of {@link LockFactory} providing the locking implementation.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDirectory Method (String, Boolean)

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDirectory Method (String, Boolean)
FSDirectory Class See Also Send Feedback
Returns the directory instance for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use IndexWriter's create flag, instead, to create a new index.")]
public static FSDirectory GetDirectory(
    string path,
    bool create
)
Visual Basic
<ObsoleteAttribute("Use IndexWriter's create flag, instead, to create a new index.")> _
Public Shared Function GetDirectory ( _
    path As String, _
    create As Boolean _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use IndexWriter's create flag, instead, to create a new index.")]
public:
static FSDirectory^ GetDirectory(
    String^ path,
    bool create
)

Parameters

path
Type: System..::..String
the path to the directory.
create
Type: System..::..Boolean
if true, create, or erase any existing contents.

Return Value

the FSDirectory for the named file.

See Also

FSDirectory Class
GetDirectory Overload
Lucene.Net.Store Namespace


GetDisableLocks Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetDisableLocks Method
FSDirectory Class See Also Send Feedback
Returns whether Lucene's use of lock files is disabled.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use a constructor that takes a LockFactory and supply NoLockFactory.GetNoLockFactory.")]
public static bool GetDisableLocks()
Visual Basic
<ObsoleteAttribute("Use a constructor that takes a LockFactory and supply NoLockFactory.GetNoLockFactory.")> _
Public Shared Function GetDisableLocks As Boolean
Visual C++
[ObsoleteAttribute(L"Use a constructor that takes a LockFactory and supply NoLockFactory.GetNoLockFactory.")]
public:
static bool GetDisableLocks()

Return Value

true if locks are disabled, false if locks are enabled.

See Also

FSDirectory Class
Lucene.Net.Store Namespace
[!:setDisableLocks]


GetFile Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetFile Method
FSDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FSDirectory.GetFile"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("A DirectoryInfo is more appropriate, however this is here for backwards compatibility. This will be removed in the 3.0 release")]
public virtual FileInfo GetFile()
Visual Basic
<ObsoleteAttribute("A DirectoryInfo is more appropriate, however this is here for backwards compatibility. This will be removed in the 3.0 release")> _
Public Overridable Function GetFile As FileInfo
Visual C++
[ObsoleteAttribute(L"A DirectoryInfo is more appropriate, however this is here for backwards compatibility. This will be removed in the 3.0 release")]
public:
virtual FileInfo^ GetFile()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.GetFile"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


GetLockID Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetLockID Method
FSDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FSDirectory.GetLockID"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string GetLockID()
Visual Basic
Public Overrides Function GetLockID As String
Visual C++
public:
virtual String^ GetLockID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.GetLockID"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


GetReadChunkSize Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..GetReadChunkSize Method
FSDirectory Class See Also Send Feedback
The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetReadChunkSize()
Visual Basic
Public Function GetReadChunkSize As Integer
Visual C++
public:
int GetReadChunkSize()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.GetReadChunkSize"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace
[!:setReadChunkSize]


InitOutput Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..InitOutput Method
FSDirectory Class See Also Send Feedback
Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal void InitOutput(
    string name
)
Visual Basic
Protected Friend Sub InitOutput ( _
    name As String _
)
Visual C++
protected public:
void InitOutput(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.InitOutput(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


List Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..List Method
FSDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FSDirectory.List"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public override string[] List()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")> _
Public Overrides Function List As String()
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public:
virtual array<String^>^ List() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.List"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


ListAll Method

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..ListAll Method
FSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Overrides Directory..::..ListAll()()()().)
 | ListAll(DirectoryInfo) | Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
 | ListAll(FileInfo) | Obsolete. Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).

See Also

FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace


ListAll Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..ListAll Method
FSDirectory Class See Also Send Feedback
Lists all files (not subdirectories) in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string[] ListAll()
Visual Basic
Public Overrides Function ListAll As String()
Visual C++
public:
virtual array<String^>^ ListAll() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.ListAll"]

See Also

FSDirectory Class
ListAll Overload
Lucene.Net.Store Namespace
[!:ListAll(File)]


ListAll Method (DirectoryInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..ListAll Method (DirectoryInfo)
FSDirectory Class See Also Send Feedback
Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
does not exist, or does exist but is not a directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string[] ListAll(
    DirectoryInfo dir
)
Visual Basic
Public Shared Function ListAll ( _
    dir As DirectoryInfo _
) As String()
Visual C++
public:
static array<String^>^ ListAll(
    DirectoryInfo^ dir
)

Parameters

dir
Type: System.IO..::..DirectoryInfo

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Store.FSDirectory.ListAll(System.IO.DirectoryInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.ListAll(System.IO.DirectoryInfo)"]

See Also

FSDirectory Class
ListAll Overload
Lucene.Net.Store Namespace


ListAll Method (FileInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..ListAll Method (FileInfo)
FSDirectory Class See Also Send Feedback
Lists all files (not subdirectories) in the directory. This method never returns null (throws {@link IOException} instead).
does not exist, or does exist but is not a directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public static string[] ListAll(
    FileInfo dir
)
Visual Basic
<ObsoleteAttribute("Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Shared Function ListAll ( _
    dir As FileInfo _
) As String()
Visual C++
[ObsoleteAttribute(L"Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
static array<String^>^ ListAll(
    FileInfo^ dir
)

Parameters

dir
Type: System.IO..::..FileInfo

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Store.FSDirectory.ListAll(System.IO.FileInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.ListAll(System.IO.FileInfo)"]

See Also

FSDirectory Class
ListAll Overload
Lucene.Net.Store Namespace


Open Method

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..Open Method
FSDirectory Class See Also Send Feedback

Overload List

Name | Description
Open(DirectoryInfo) | Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
Open(FileInfo) | Obsolete. Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported. NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs. See above
Open(DirectoryInfo, LockFactory) | Just like {@link #Open(File)}, but allows you to also specify a custom {@link LockFactory}.

See Also

FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace


Open Method (DirectoryInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..Open Method (DirectoryInfo)
FSDirectory Class See Also Send Feedback
Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}.

Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported.

NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs.

See above

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FSDirectory Open(
    DirectoryInfo path
)
Visual Basic
Public Shared Function Open ( _
    path As DirectoryInfo _
) As FSDirectory
Visual C++
public:
static FSDirectory^ Open(
    DirectoryInfo^ path
)

Parameters

path
Type: System.IO..::..DirectoryInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.DirectoryInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.DirectoryInfo)"]

See Also

FSDirectory Class
Open Overload
Lucene.Net.Store Namespace


Open Method (FileInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..Open Method (FileInfo)
FSDirectory Class See Also Send Feedback
Creates an FSDirectory instance, trying to pick the best implementation given the current environment. The directory returned uses the {@link NativeFSLockFactory}.

Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported.

Currently this returns {@link SimpleFSDirectory} as NIOFSDirectory is currently not supported.

NOTE: this method may suddenly change which implementation is returned from release to release, in the event that higher performance defaults become possible; if the precise implementation is important to your application, please instantiate it directly, instead. On 64 bit systems, it may also good to return {@link MMapDirectory}, but this is disabled because of officially missing unmap support in Java. For optimal performance you should consider using this implementation on 64 bit JVMs.

See above

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public static FSDirectory Open(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute("Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Shared Function Open ( _
    path As FileInfo _
) As FSDirectory
Visual C++
[ObsoleteAttribute(L"Use the method that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
static FSDirectory^ Open(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.FileInfo)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.FileInfo)"]

See Also

FSDirectory Class
Open Overload
Lucene.Net.Store Namespace


Open Method (DirectoryInfo, LockFactory)

[image]

Lucene.Net Class Libraries
FSDirectory..::..Open Method (DirectoryInfo, LockFactory)
FSDirectory Class See Also Send Feedback
Just like {@link #Open(File)}, but allows you to also specify a custom {@link LockFactory}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FSDirectory Open(
    DirectoryInfo path,
    LockFactory lockFactory
)
Visual Basic
Public Shared Function Open ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
) As FSDirectory
Visual C++
public:
static FSDirectory^ Open(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System.IO..::..DirectoryInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.DirectoryInfo,Lucene.Net.Store.LockFactory)"]

lockFactory
Type: Lucene.Net.Store..::..LockFactory

[Missing <param name="lockFactory"/> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.DirectoryInfo,Lucene.Net.Store.LockFactory)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.Open(System.IO.DirectoryInfo,Lucene.Net.Store.LockFactory)"]

See Also

FSDirectory Class
Open Overload
Lucene.Net.Store Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..OpenInput Method
FSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract. (Overrides Directory..::..OpenInput(String, Int32).)

See Also

FSDirectory Class
FSDirectory Members
Lucene.Net.Store Namespace


OpenInput Method (String)

[image]

Lucene.Net Class Libraries
FSDirectory..::..OpenInput Method (String)
FSDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FSDirectory.OpenInput(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string name
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.OpenInput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.OpenInput(System.String)"]

See Also

FSDirectory Class
OpenInput Overload
Lucene.Net.Store Namespace


OpenInput Method (String, Int32)

[image]

Lucene.Net Class Libraries
FSDirectory..::..OpenInput Method (String, Int32)
FSDirectory Class See Also Send Feedback
Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.OpenInput(System.String,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.FSDirectory.OpenInput(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.OpenInput(System.String,System.Int32)"]

See Also

FSDirectory Class
OpenInput Overload
Lucene.Net.Store Namespace


RenameFile Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..RenameFile Method
FSDirectory Class See Also Send Feedback
Renames an existing file in the directory. Warning: This is not atomic.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public override void RenameFile(
    string from,
    string to
)
Visual Basic
<ObsoleteAttribute> _
Public Overrides Sub RenameFile ( _
    from As String, _
    to As String _
)
Visual C++
[ObsoleteAttribute]
public:
virtual void RenameFile(
    String^ from,
    String^ to
) override

Parameters

from
Type: System..::..String

[Missing <param name="from"/> documentation for "M:Lucene.Net.Store.FSDirectory.RenameFile(System.String,System.String)"]

to
Type: System..::..String

[Missing <param name="to"/> documentation for "M:Lucene.Net.Store.FSDirectory.RenameFile(System.String,System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


SetDisableLocks Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..SetDisableLocks Method
FSDirectory Class See Also Send Feedback
Set whether Lucene's use of lock files is disabled. By default, lock files are enabled. They should only be disabled if the index is on a read-only medium like a CD-ROM.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use a Open(File, LockFactory) or a constructor that takes a LockFactory and supply NoLockFactory.GetNoLockFactory. This setting does not work with Open(File) only the deprecated GetDirectory respect this setting.")]
public static void SetDisableLocks(
    bool doDisableLocks
)
Visual Basic
<ObsoleteAttribute("Use a Open(File, LockFactory) or a constructor that takes a LockFactory and supply NoLockFactory.GetNoLockFactory. This setting does not work with Open(File) only the deprecated GetDirectory respect this setting.")> _
Public Shared Sub SetDisableLocks ( _
    doDisableLocks As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use a Open(File, LockFactory) or a constructor that takes a LockFactory and supply NoLockFactory.GetNoLockFactory. This setting does not work with Open(File) only the deprecated GetDirectory respect this setting.")]
public:
static void SetDisableLocks(
    bool doDisableLocks
)

Parameters

doDisableLocks
Type: System..::..Boolean

[Missing <param name="doDisableLocks"/> documentation for "M:Lucene.Net.Store.FSDirectory.SetDisableLocks(System.Boolean)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


SetReadChunkSize Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..SetReadChunkSize Method
FSDirectory Class See Also Send Feedback
Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE};

This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size.

Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory.

NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetReadChunkSize(
    int chunkSize
)
Visual Basic
Public Sub SetReadChunkSize ( _
    chunkSize As Integer _
)
Visual C++
public:
void SetReadChunkSize(
    int chunkSize
)

Parameters

chunkSize
Type: System..::..Int32

[Missing <param name="chunkSize"/> documentation for "M:Lucene.Net.Store.FSDirectory.SetReadChunkSize(System.Int32)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


Sync Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..Sync Method
FSDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.FSDirectory.Sync(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Sync(
    string name
)
Visual Basic
Public Overrides Sub Sync ( _
    name As String _
)
Visual C++
public:
virtual void Sync(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.Sync(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..ToString Method
FSDirectory Class See Also Send Feedback
For debug output.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSDirectory.ToString"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


TouchFile Method

[image]

Lucene.Net Class Libraries
FSDirectory..::..TouchFile Method
FSDirectory Class See Also Send Feedback
Set the modified time of an existing file to now.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void TouchFile(
    string name
)
Visual Basic
Public Overrides Sub TouchFile ( _
    name As String _
)
Visual C++
public:
virtual void TouchFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.FSDirectory.TouchFile(System.String)"]

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FSDirectory Properties

[image] [image]

Lucene.Net Class Libraries
FSDirectory Properties
FSDirectory Class See Also Send Feedback

The FSDirectory type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

FSDirectory Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Class

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Class
FSDirectory Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.FSDirectory.FSIndexInput"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use SimpleFSDirectory.SimpleFSIndexInput instead ")]
public class FSIndexInput : SimpleFSDirectory..::..SimpleFSIndexInput
Visual Basic
<ObsoleteAttribute("Use SimpleFSDirectory.SimpleFSIndexInput instead ")> _
Public Class FSIndexInput _
    Inherits SimpleFSDirectory..::..SimpleFSIndexInput
Visual C++
[ObsoleteAttribute(L"Use SimpleFSDirectory.SimpleFSIndexInput instead ")]
public ref class FSIndexInput : public SimpleFSDirectory..::..SimpleFSIndexInput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Store..::..BufferedIndexInput
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexInput
Lucene.Net.Store..::..FSDirectory..::..FSIndexInput

See Also

FSDirectory..::..FSIndexInput Members
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Members

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Members
FSDirectory..::..FSIndexInput Class Constructors Methods Fields Properties See Also Send Feedback

The FSDirectory..::..FSIndexInput type exposes the following members.

Constructors

 | Name | Description
Public method | FSDirectory..::..FSIndexInput(FileInfo) | Obsolete. Initializes a new instance of the FSDirectory..::..FSIndexInput class
Public method | FSDirectory..::..FSIndexInput(FileInfo, Int32) | Obsolete. Initializes a new instance of the FSDirectory..::..FSIndexInput class

Methods

 | Name | Description
Public method | Clone | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | Close | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize | (Inherited from BufferedIndexInput.)
Public method | GetFilePointer | (Inherited from BufferedIndexInput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid. (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | Length | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | IndexInput methods (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Protected field | chunkSize | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Protected field | file | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)

Properties

 | Name | Description
Public property | isClone_ForNUnit | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)

See Also

FSDirectory..::..FSIndexInput Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Constructor

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Constructor
FSDirectory..::..FSIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FSDirectory..::..FSIndexInput(FileInfo) | Obsolete. Initializes a new instance of the FSDirectory..::..FSIndexInput class
Public method | FSDirectory..::..FSIndexInput(FileInfo, Int32) | Obsolete. Initializes a new instance of the FSDirectory..::..FSIndexInput class

See Also

FSDirectory..::..FSIndexInput Class
FSDirectory..::..FSIndexInput Members
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Constructor (FileInfo)
FSDirectory..::..FSIndexInput Class See Also Send Feedback
Initializes a new instance of the FSDirectory..::..FSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public FSIndexInput(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute> _
Public Sub New ( _
    path As FileInfo _
)
Visual C++
[ObsoleteAttribute]
public:
FSIndexInput(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.FSDirectory.FSIndexInput.#ctor(System.IO.FileInfo)"]

See Also

FSDirectory..::..FSIndexInput Class
FSDirectory..::..FSIndexInput Overload
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Constructor (FileInfo, Int32)

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Constructor (FileInfo, Int32)
FSDirectory..::..FSIndexInput Class See Also Send Feedback
Initializes a new instance of the FSDirectory..::..FSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public FSIndexInput(
    FileInfo path,
    int bufferSize
)
Visual Basic
<ObsoleteAttribute> _
Public Sub New ( _
    path As FileInfo, _
    bufferSize As Integer _
)
Visual C++
[ObsoleteAttribute]
public:
FSIndexInput(
    FileInfo^ path,
    int bufferSize
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.FSDirectory.FSIndexInput.#ctor(System.IO.FileInfo,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.FSDirectory.FSIndexInput.#ctor(System.IO.FileInfo,System.Int32)"]

See Also

FSDirectory..::..FSIndexInput Class
FSDirectory..::..FSIndexInput Overload
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Fields

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Fields
FSDirectory..::..FSIndexInput Class See Also Send Feedback

The FSDirectory..::..FSIndexInput type exposes the following members.

Fields

 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Protected field | chunkSize | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Protected field | file | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)

See Also

FSDirectory..::..FSIndexInput Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Methods

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Methods
FSDirectory..::..FSIndexInput Class See Also Send Feedback

The FSDirectory..::..FSIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | Close | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize | (Inherited from BufferedIndexInput.)
Public method | GetFilePointer | (Inherited from BufferedIndexInput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid. (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | Length | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | IndexInput methods (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FSDirectory..::..FSIndexInput Class
Lucene.Net.Store Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
FSIndexInput..::..ReadBytes Method
FSDirectory..::..FSIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)

See Also

FSDirectory..::..FSIndexInput Class
FSDirectory..::..FSIndexInput Members
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput Properties

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput Properties
FSDirectory..::..FSIndexInput Class See Also Send Feedback

The FSDirectory..::..FSIndexInput type exposes the following members.

Properties

 | Name | Description
Public property | isClone_ForNUnit | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput.)

See Also

FSDirectory..::..FSIndexInput Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Class

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput..::..Descriptor Class
FSDirectory..::..FSIndexInput Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.FSDirectory.FSIndexInput.Descriptor"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
protected internal class Descriptor : SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Visual Basic
<ObsoleteAttribute> _
Protected Friend Class Descriptor _
    Inherits SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Visual C++
[ObsoleteAttribute]
protected public ref class Descriptor : public SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor

Inheritance Hierarchy

System..::..Object
System.IO..::..BinaryReader
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Lucene.Net.Store..::..FSDirectory..::..FSIndexInput..::..Descriptor

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Members
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Members

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput..::..Descriptor Members
FSDirectory..::..FSIndexInput..::..Descriptor Class Constructors Methods Fields Properties See Also Send Feedback

The FSDirectory..::..FSIndexInput..::..Descriptor type exposes the following members.

Constructors

 | Name | Description
Public method | FSDirectory..::..FSIndexInput..::..Descriptor | Obsolete. Initializes a new instance of the FSDirectory..::..FSIndexInput..::..Descriptor class

Methods

 | Name | Description
Public method | Close | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor.)
Public method | Dispose()()()() | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from BinaryReader.)
Protected method | Finalize | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from BinaryReader.)
Public method | Read()()()() | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Public method | Read(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)
Protected method | Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from BinaryReader.)
Public method | ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from BinaryReader.)
Public method | ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from BinaryReader.)
Public method | ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from BinaryReader.)
Public method | ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | isOpen | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor.)

Properties

 | Name | Description
Public property | BaseStream | Exposes access to the underlying stream of the BinaryReader. (Inherited from BinaryReader.)

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Constructor

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput..::..Descriptor Constructor
FSDirectory..::..FSIndexInput..::..Descriptor Class See Also Send Feedback
Initializes a new instance of the FSDirectory..::..FSIndexInput..::..Descriptor class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public Descriptor(
    FileInfo file,
    FileAccess mode
)
Visual Basic
<ObsoleteAttribute> _
Public Sub New ( _
    file As FileInfo, _
    mode As FileAccess _
)
Visual C++
[ObsoleteAttribute]
public:
Descriptor(
    FileInfo^ file,
    FileAccess mode
)

Parameters

file
Type: System.IO..::..FileInfo

[Missing <param name="file"/> documentation for "M:Lucene.Net.Store.FSDirectory.FSIndexInput.Descriptor.#ctor(System.IO.FileInfo,System.IO.FileAccess)"]

mode
Type: System.IO..::..FileAccess

[Missing <param name="mode"/> documentation for "M:Lucene.Net.Store.FSDirectory.FSIndexInput.Descriptor.#ctor(System.IO.FileInfo,System.IO.FileAccess)"]

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Fields

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput..::..Descriptor Fields
FSDirectory..::..FSIndexInput..::..Descriptor Class See Also Send Feedback

The FSDirectory..::..FSIndexInput..::..Descriptor type exposes the following members.

Fields

 | Name | Description
Protected field | isOpen | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor.)

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Methods

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput..::..Descriptor Methods
FSDirectory..::..FSIndexInput..::..Descriptor Class See Also Send Feedback

The FSDirectory..::..FSIndexInput..::..Descriptor type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor.)
Public method | Dispose()()()() | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from BinaryReader.)
Protected method | Finalize | (Inherited from SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from BinaryReader.)
Public method | Read()()()() | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Public method | Read(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)
Protected method | Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from BinaryReader.)
Public method | ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from BinaryReader.)
Public method | ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from BinaryReader.)
Public method | ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from BinaryReader.)
Public method | ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
Descriptor..::..Dispose Method
FSDirectory..::..FSIndexInput..::..Descriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
FSDirectory..::..FSIndexInput..::..Descriptor Members
Lucene.Net.Store Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
Descriptor..::..Read Method
FSDirectory..::..FSIndexInput..::..Descriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Public method | Read(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
FSDirectory..::..FSIndexInput..::..Descriptor Members
Lucene.Net.Store Namespace


FSDirectory.FSIndexInput.Descriptor Properties

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexInput..::..Descriptor Properties
FSDirectory..::..FSIndexInput..::..Descriptor Class See Also Send Feedback

The FSDirectory..::..FSIndexInput..::..Descriptor type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Exposes access to the underlying stream of the BinaryReader. (Inherited from BinaryReader.)

See Also

FSDirectory..::..FSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Class

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexOutput Class
FSDirectory Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.FSDirectory.FSIndexOutput"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use SimpleFSDirectory.SimpleFSIndexOutput instead ")]
protected internal class FSIndexOutput : SimpleFSDirectory..::..SimpleFSIndexOutput
Visual Basic
<ObsoleteAttribute("Use SimpleFSDirectory.SimpleFSIndexOutput instead ")> _
Protected Friend Class FSIndexOutput _
    Inherits SimpleFSDirectory..::..SimpleFSIndexOutput
Visual C++
[ObsoleteAttribute(L"Use SimpleFSDirectory.SimpleFSIndexOutput instead ")]
protected public ref class FSIndexOutput : public SimpleFSDirectory..::..SimpleFSIndexOutput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexOutput
Lucene.Net.Store..::..BufferedIndexOutput
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexOutput
Lucene.Net.Store..::..FSDirectory..::..FSIndexOutput

See Also

FSDirectory..::..FSIndexOutput Members
Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Members

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexOutput Members
FSDirectory..::..FSIndexOutput Class Constructors Methods See Also Send Feedback

The FSDirectory..::..FSIndexOutput type exposes the following members.

Constructors

 | Name | Description
Public method | FSDirectory..::..FSIndexOutput | Obsolete. Initializes a new instance of the FSDirectory..::..FSIndexOutput class

Methods

 | Name | Description
Public method | Close | (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written. (Inherited from BufferedIndexOutput.)
Public method | FlushBuffer | output methods: (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur. (Inherited from BufferedIndexOutput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Random-access methods (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | SetLength | (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte. (Inherited from BufferedIndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

FSDirectory..::..FSIndexOutput Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Constructor

[image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexOutput Constructor
FSDirectory..::..FSIndexOutput Class See Also Send Feedback
Initializes a new instance of the FSDirectory..::..FSIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public FSIndexOutput(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute> _
Public Sub New ( _
    path As FileInfo _
)
Visual C++
[ObsoleteAttribute]
public:
FSIndexOutput(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.FSDirectory.FSIndexOutput.#ctor(System.IO.FileInfo)"]

See Also

FSDirectory..::..FSIndexOutput Class
Lucene.Net.Store Namespace


FSDirectory.FSIndexOutput Methods

[image] [image]

Lucene.Net Class Libraries
FSDirectory..::..FSIndexOutput Methods
FSDirectory..::..FSIndexOutput Class See Also Send Feedback

The FSDirectory..::..FSIndexOutput type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written. (Inherited from BufferedIndexOutput.)
Public method | FlushBuffer | output methods: (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur. (Inherited from BufferedIndexOutput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Random-access methods (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | SetLength | (Inherited from SimpleFSDirectory..::..SimpleFSIndexOutput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte. (Inherited from BufferedIndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

FSDirectory..::..FSIndexOutput Class
Lucene.Net.Store Namespace


WriteBytes Method

[image] [image]

Lucene.Net Class Libraries
FSIndexOutput..::..WriteBytes Method
FSDirectory..::..FSIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)

See Also

FSDirectory..::..FSIndexOutput Class
FSDirectory..::..FSIndexOutput Members
Lucene.Net.Store Namespace


WriteChars Method

[image] [image]

Lucene.Net Class Libraries
FSIndexOutput..::..WriteChars Method
FSDirectory..::..FSIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)

See Also

FSDirectory..::..FSIndexOutput Class
FSDirectory..::..FSIndexOutput Members
Lucene.Net.Store Namespace


FSLockFactory Class

[image]

Lucene.Net Class Libraries
FSLockFactory Class
Members See Also Send Feedback
Base class for file system based locking implementation.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class FSLockFactory : LockFactory
Visual Basic
Public MustInherit Class FSLockFactory _
    Inherits LockFactory
Visual C++
public ref class FSLockFactory abstract : public LockFactory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..FSLockFactory
Lucene.Net.Store..::..NativeFSLockFactory
Lucene.Net.Store..::..SimpleFSLockFactory

See Also

FSLockFactory Members
Lucene.Net.Store Namespace


FSLockFactory Members

[image] [image]

Lucene.Net Class Libraries
FSLockFactory Members
FSLockFactory Class Constructors Methods Fields See Also Send Feedback

The FSLockFactory type exposes the following members.

Constructors

 | Name | Description
Protected method | FSLockFactory | Initializes a new instance of the FSLockFactory class

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from LockFactory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockDir | Retrieve the lock directory.
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName. (Inherited from LockFactory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetLockDir | Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor.
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockDir | Directory for the lock files.
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


FSLockFactory Constructor

[image]

Lucene.Net Class Libraries
FSLockFactory Constructor
FSLockFactory Class See Also Send Feedback
Initializes a new instance of the FSLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected FSLockFactory()
Visual Basic
Protected Sub New
Visual C++
protected:
FSLockFactory()

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


FSLockFactory Fields

[image] [image]

Lucene.Net Class Libraries
FSLockFactory Fields
FSLockFactory Class See Also Send Feedback

The FSLockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockDir | Directory for the lock files.
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


lockDir Field

[image]

Lucene.Net Class Libraries
FSLockFactory..::..lockDir Field
FSLockFactory Class See Also Send Feedback
Directory for the lock files.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal DirectoryInfo lockDir
Visual Basic
Protected Friend lockDir As DirectoryInfo
Visual C++
protected public:
DirectoryInfo^ lockDir

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


FSLockFactory Methods

[image] [image]

Lucene.Net Class Libraries
FSLockFactory Methods
FSLockFactory Class See Also Send Feedback

The FSLockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from LockFactory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockDir | Retrieve the lock directory.
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName. (Inherited from LockFactory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetLockDir | Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor.
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


GetLockDir Method

[image]

Lucene.Net Class Libraries
FSLockFactory..::..GetLockDir Method
FSLockFactory Class See Also Send Feedback
Retrieve the lock directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual DirectoryInfo GetLockDir()
Visual Basic
Public Overridable Function GetLockDir As DirectoryInfo
Visual C++
public:
virtual DirectoryInfo^ GetLockDir()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.FSLockFactory.GetLockDir"]

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


SetLockDir Method

[image]

Lucene.Net Class Libraries
FSLockFactory..::..SetLockDir Method
FSLockFactory Class See Also Send Feedback
Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void SetLockDir(
    DirectoryInfo lockDir
)
Visual Basic
Protected Friend Overridable Sub SetLockDir ( _
    lockDir As DirectoryInfo _
)
Visual C++
protected public:
virtual void SetLockDir(
    DirectoryInfo^ lockDir
)

Parameters

lockDir
Type: System.IO..::..DirectoryInfo

[Missing <param name="lockDir"/> documentation for "M:Lucene.Net.Store.FSLockFactory.SetLockDir(System.IO.DirectoryInfo)"]

See Also

FSLockFactory Class
Lucene.Net.Store Namespace


IndexInput Class

[image]

Lucene.Net Class Libraries
IndexInput Class
Members See Also Send Feedback
Abstract base class for input from a file in a {@link Directory}. A random-access input stream. Used for all Lucene index input operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class IndexInput : ICloneable
Visual Basic
Public MustInherit Class IndexInput _
    Implements ICloneable
Visual C++
public ref class IndexInput abstract : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Index..::..ByteSliceReader
Lucene.Net.Store..::..BufferedIndexInput
Lucene.Net.Store..::..ChecksumIndexInput
Lucene.Net.Store..::..RAMInputStream

See Also

IndexInput Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..Directory


IndexInput Members

[image] [image]

Lucene.Net Class Libraries
IndexInput Members
IndexInput Class Constructors Methods See Also Send Feedback

The IndexInput type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexInput | Initializes a new instance of the IndexInput class

Methods

 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from.
Public method | Close | Closes the stream to futher operations.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilePointer | Returns the current position in this file, where the next read will occur.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | Reads and returns a single byte.
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | Reads a specified number of bytes into an array at the specified offset.
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter.
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
Public method | ReadInt | Reads four bytes and returns an int.
Public method | ReadLong | Reads eight bytes and returns a long.
Public method | ReadString | Reads a string.
Public method | ReadStringStringMap |
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | Seek | Sets current position in this file, where the next read will occur.
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details.
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexInput Class
Lucene.Net.Store Namespace


IndexInput Constructor

[image]

Lucene.Net Class Libraries
IndexInput Constructor
IndexInput Class See Also Send Feedback
Initializes a new instance of the IndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IndexInput()
Visual Basic
Protected Sub New
Visual C++
protected:
IndexInput()

See Also

IndexInput Class
Lucene.Net.Store Namespace


IndexInput Methods

[image] [image]

Lucene.Net Class Libraries
IndexInput Methods
IndexInput Class See Also Send Feedback

The IndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from.
Public method | Close | Closes the stream to futher operations.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilePointer | Returns the current position in this file, where the next read will occur.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | Reads and returns a single byte.
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | Reads a specified number of bytes into an array at the specified offset.
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter.
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array.
Public method | ReadInt | Reads four bytes and returns an int.
Public method | ReadLong | Reads eight bytes and returns a long.
Public method | ReadString | Reads a string.
Public method | ReadStringStringMap |
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | Seek | Sets current position in this file, where the next read will occur.
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details.
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexInput Class
Lucene.Net.Store Namespace


Clone Method

[image]

Lucene.Net Class Libraries
IndexInput..::..Clone Method
IndexInput Class See Also Send Feedback
Returns a clone of this stream.

Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from.

Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

IndexInput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexInput..::..Close Method
IndexInput Class See Also Send Feedback
Closes the stream to futher operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

IndexInput Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
IndexInput..::..GetFilePointer Method
IndexInput Class See Also Send Feedback
Returns the current position in this file, where the next read will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long GetFilePointer()
Visual Basic
Public MustOverride Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.GetFilePointer"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexInput..::..Seek(Int64)


Length Method

[image]

Lucene.Net Class Libraries
IndexInput..::..Length Method
IndexInput Class See Also Send Feedback
The number of bytes in the file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long Length()
Visual Basic
Public MustOverride Function Length As Long
Visual C++
public:
virtual long long Length() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.Length"]

See Also

IndexInput Class
Lucene.Net.Store Namespace


ReadByte Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadByte Method
IndexInput Class See Also Send Feedback
Reads and returns a single byte.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract byte ReadByte()
Visual Basic
Public MustOverride Function ReadByte As Byte
Visual C++
public:
virtual unsigned char ReadByte() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadByte"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexOutput..::..WriteByte(Byte)


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
IndexInput..::..ReadBytes Method
IndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | Reads a specified number of bytes into an array at the specified offset.
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter.

See Also

IndexInput Class
IndexInput Members
Lucene.Net.Store Namespace


ReadBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32)
IndexInput Class See Also Send Feedback
Reads a specified number of bytes into an array at the specified offset.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public MustOverride Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) abstract

Parameters

b
Type: array< System..::..Byte >[]()[][]
the array to read bytes into
offset
Type: System..::..Int32
the offset in the array to start storing bytes
len
Type: System..::..Int32
the number of bytes to read

See Also

IndexInput Class
ReadBytes Overload
Lucene.Net.Store Namespace
IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32)


ReadBytes Method (Byte[], Int32, Int32, Boolean)

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32, Boolean)
IndexInput Class See Also Send Feedback
Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ReadBytes(
    byte[] b,
    int offset,
    int len,
    bool useBuffer
)
Visual Basic
Public Overridable Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer, _
    useBuffer As Boolean _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len,
    bool useBuffer
)

Parameters

b
Type: array< System..::..Byte >[]()[][]
the array to read bytes into
offset
Type: System..::..Int32
the offset in the array to start storing bytes
len
Type: System..::..Int32
the number of bytes to read
useBuffer
Type: System..::..Boolean
set to false if the caller will handle buffering.

See Also

IndexInput Class
ReadBytes Overload
Lucene.Net.Store Namespace
IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32)


ReadChars Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadChars Method
IndexInput Class See Also Send Feedback
Reads Lucene's old "modified UTF-8" encoded characters into an array.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")]
public virtual void ReadChars(
    char[] buffer,
    int start,
    int length
)
Visual Basic
<ObsoleteAttribute("-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")> _
Public Overridable Sub ReadChars ( _
    buffer As Char(), _
    start As Integer, _
    length As Integer _
)
Visual C++
[ObsoleteAttribute(L"-- please use ReadString or ReadBytes instead, and construct the string from those utf8 bytes")]
public:
virtual void ReadChars(
    array<wchar_t>^ buffer,
    int start,
    int length
)

Parameters

buffer
Type: array< System..::..Char >[]()[][]
the array to read characters into
start
Type: System..::..Int32
the offset in the array to start storing characters
length
Type: System..::..Int32
the number of characters to read

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexOutput..::..WriteChars(String, Int32, Int32)


ReadInt Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadInt Method
IndexInput Class See Also Send Feedback
Reads four bytes and returns an int.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int ReadInt()
Visual Basic
Public Overridable Function ReadInt As Integer
Visual C++
public:
virtual int ReadInt()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadInt"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexOutput..::..WriteInt(Int32)


ReadLong Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadLong Method
IndexInput Class See Also Send Feedback
Reads eight bytes and returns a long.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long ReadLong()
Visual Basic
Public Overridable Function ReadLong As Long
Visual C++
public:
virtual long long ReadLong()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadLong"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexOutput..::..WriteLong(Int64)


ReadString Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadString Method
IndexInput Class See Also Send Feedback
Reads a string.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string ReadString()
Visual Basic
Public Overridable Function ReadString As String
Visual C++
public:
virtual String^ ReadString()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadString"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexOutput..::..WriteString(String)


ReadStringStringMap Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadStringStringMap Method
IndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.IndexInput.ReadStringStringMap"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IDictionary<string, string> ReadStringStringMap()
Visual Basic
Public Overridable Function ReadStringStringMap As IDictionary(Of String, String)
Visual C++
public:
virtual IDictionary<String^, String^>^ ReadStringStringMap()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadStringStringMap"]

See Also

IndexInput Class
Lucene.Net.Store Namespace


ReadVInt Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadVInt Method
IndexInput Class See Also Send Feedback
Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int ReadVInt()
Visual Basic
Public Overridable Function ReadVInt As Integer
Visual C++
public:
virtual int ReadVInt()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadVInt"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexOutput..::..WriteVInt(Int32)


ReadVLong Method

[image]

Lucene.Net Class Libraries
IndexInput..::..ReadVLong Method
IndexInput Class See Also Send Feedback
Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long ReadVLong()
Visual Basic
Public Overridable Function ReadVLong As Long
Visual C++
public:
virtual long long ReadVLong()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexInput.ReadVLong"]

See Also

IndexInput Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
IndexInput..::..Seek Method
IndexInput Class See Also Send Feedback
Sets current position in this file, where the next read will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Seek(
    long pos
)
Visual Basic
Public MustOverride Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) abstract

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.IndexInput.Seek(System.Int64)"]

See Also

IndexInput Class
Lucene.Net.Store Namespace
IndexInput..::..GetFilePointer()()()()


SetModifiedUTF8StringsMode Method

[image]

Lucene.Net Class Libraries
IndexInput..::..SetModifiedUTF8StringsMode Method
IndexInput Class See Also Send Feedback
Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetModifiedUTF8StringsMode()
Visual Basic
Public Overridable Sub SetModifiedUTF8StringsMode
Visual C++
public:
virtual void SetModifiedUTF8StringsMode()

See Also

IndexInput Class
Lucene.Net.Store Namespace


SkipChars Method

[image]

Lucene.Net Class Libraries
IndexInput..::..SkipChars Method
IndexInput Class See Also Send Feedback
Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("this method operates on old "modified utf8" encoded strings")]
public virtual void SkipChars(
    int length
)
Visual Basic
<ObsoleteAttribute("this method operates on old "modified utf8" encoded strings")> _
Public Overridable Sub SkipChars ( _
    length As Integer _
)
Visual C++
[ObsoleteAttribute(L"this method operates on old "modified utf8" encoded strings")]
public:
virtual void SkipChars(
    int length
)

Parameters

length
Type: System..::..Int32
The number of chars to read

See Also

IndexInput Class
Lucene.Net.Store Namespace


IndexOutput Class

[image]

Lucene.Net Class Libraries
IndexOutput Class
Members See Also Send Feedback
Abstract base class for output to a file in a Directory. A random-access output stream. Used for all Lucene index output operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class IndexOutput
Visual Basic
Public MustInherit Class IndexOutput
Visual C++
public ref class IndexOutput abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexOutput
Lucene.Net.Store..::..BufferedIndexOutput
Lucene.Net.Store..::..ChecksumIndexOutput
Lucene.Net.Store..::..RAMOutputStream

See Also

IndexOutput Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..IndexInput


IndexOutput Members

[image] [image]

Lucene.Net Class Libraries
IndexOutput Members
IndexOutput Class Constructors Methods See Also Send Feedback

The IndexOutput type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexOutput | Initializes a new instance of the IndexOutput class

Methods

 | Name | Description
Public method | Close | Closes this stream to further operations.
Public method | CopyBytes | Copy numBytes bytes from input to ourself.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written.
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Sets current position in this file, where the next write will occur.
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte.
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes.
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes.
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).
Public method | WriteInt | Writes an int as four bytes.
Public method | WriteLong | Writes a long as eight bytes.
Public method | WriteString | Writes a string.
Public method | WriteStringStringMap |
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

See Also

IndexOutput Class
Lucene.Net.Store Namespace


IndexOutput Constructor

[image]

Lucene.Net Class Libraries
IndexOutput Constructor
IndexOutput Class See Also Send Feedback
Initializes a new instance of the IndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IndexOutput()
Visual Basic
Protected Sub New
Visual C++
protected:
IndexOutput()

See Also

IndexOutput Class
Lucene.Net.Store Namespace


IndexOutput Methods

[image] [image]

Lucene.Net Class Libraries
IndexOutput Methods
IndexOutput Class See Also Send Feedback

The IndexOutput type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes this stream to further operations.
Public method | CopyBytes | Copy numBytes bytes from input to ourself.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written.
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | The number of bytes in the file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Sets current position in this file, where the next write will occur.
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte.
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes.
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes.
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).
Public method | WriteInt | Writes an int as four bytes.
Public method | WriteLong | Writes a long as eight bytes.
Public method | WriteString | Writes a string.
Public method | WriteStringStringMap |
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

See Also

IndexOutput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..Close Method
IndexOutput Class See Also Send Feedback
Closes this stream to further operations.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

IndexOutput Class
Lucene.Net.Store Namespace


CopyBytes Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..CopyBytes Method
IndexOutput Class See Also Send Feedback
Copy numBytes bytes from input to ourself.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void CopyBytes(
    IndexInput input,
    long numBytes
)
Visual Basic
Public Overridable Sub CopyBytes ( _
    input As IndexInput, _
    numBytes As Long _
)
Visual C++
public:
virtual void CopyBytes(
    IndexInput^ input,
    long long numBytes
)

Parameters

input
Type: Lucene.Net.Store..::..IndexInput

[Missing <param name="input"/> documentation for "M:Lucene.Net.Store.IndexOutput.CopyBytes(Lucene.Net.Store.IndexInput,System.Int64)"]

numBytes
Type: System..::..Int64

[Missing <param name="numBytes"/> documentation for "M:Lucene.Net.Store.IndexOutput.CopyBytes(Lucene.Net.Store.IndexInput,System.Int64)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace


Flush Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..Flush Method
IndexOutput Class See Also Send Feedback
Forces any buffered output to be written.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Flush()
Visual Basic
Public MustOverride Sub Flush
Visual C++
public:
virtual void Flush() abstract

See Also

IndexOutput Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..GetFilePointer Method
IndexOutput Class See Also Send Feedback
Returns the current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long GetFilePointer()
Visual Basic
Public MustOverride Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexOutput.GetFilePointer"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexOutput..::..Seek(Int64)


Length Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..Length Method
IndexOutput Class See Also Send Feedback
The number of bytes in the file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract long Length()
Visual Basic
Public MustOverride Function Length As Long
Visual C++
public:
virtual long long Length() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.IndexOutput.Length"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..Seek Method
IndexOutput Class See Also Send Feedback
Sets current position in this file, where the next write will occur.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Seek(
    long pos
)
Visual Basic
Public MustOverride Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) abstract

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.IndexOutput.Seek(System.Int64)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexOutput..::..GetFilePointer()()()()


SetLength Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..SetLength Method
IndexOutput Class See Also Send Feedback
Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetLength(
    long length
)
Visual Basic
Public Overridable Sub SetLength ( _
    length As Long _
)
Visual C++
public:
virtual void SetLength(
    long long length
)

Parameters

length
Type: System..::..Int64
file length

See Also

IndexOutput Class
Lucene.Net.Store Namespace
can use this to inform the underlying IO system to pre-allocate the file to the specified size. If the length is longer than the current file length, the bytes added to the file are undefined. Otherwise the file is truncated.


WriteByte Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteByte Method
IndexOutput Class See Also Send Feedback
Writes a single byte.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void WriteByte(
    byte b
)
Visual Basic
Public MustOverride Sub WriteByte ( _
    b As Byte _
)
Visual C++
public:
virtual void WriteByte(
    unsigned char b
) abstract

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteByte(System.Byte)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadByte()()()()


WriteBytes Method

[image] [image]

Lucene.Net Class Libraries
IndexOutput..::..WriteBytes Method
IndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes.
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes.

See Also

IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace


WriteBytes Method (Byte[], Int32)

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteBytes Method (array<Byte>[]()[][], Int32)
IndexOutput Class See Also Send Feedback
Writes an array of bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteBytes(
    byte[] b,
    int length
)
Visual Basic
Public Overridable Sub WriteBytes ( _
    b As Byte(), _
    length As Integer _
)
Visual C++
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int length
)

Parameters

b
Type: array< System..::..Byte >[]()[][]
the bytes to write
length
Type: System..::..Int32
the number of bytes to write

See Also

IndexOutput Class
WriteBytes Overload
Lucene.Net.Store Namespace
IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32)


WriteBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteBytes Method (array<Byte>[]()[][], Int32, Int32)
IndexOutput Class See Also Send Feedback
Writes an array of bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void WriteBytes(
    byte[] b,
    int offset,
    int length
)
Visual Basic
Public MustOverride Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    length As Integer _
)
Visual C++
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int length
) abstract

Parameters

b
Type: array< System..::..Byte >[]()[][]
the bytes to write
offset
Type: System..::..Int32
the offset in the byte array
length
Type: System..::..Int32
the number of bytes to write

See Also

IndexOutput Class
WriteBytes Overload
Lucene.Net.Store Namespace
IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32)


WriteChars Method

[image] [image]

Lucene.Net Class Libraries
IndexOutput..::..WriteChars Method
IndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).

See Also

IndexOutput Class
IndexOutput Members
Lucene.Net.Store Namespace


WriteChars Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteChars Method (array<Char>[]()[][], Int32, Int32)
IndexOutput Class See Also Send Feedback
Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")]
public virtual void WriteChars(
    char[] s,
    int start,
    int length
)
Visual Basic
<ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")> _
Public Overridable Sub WriteChars ( _
    s As Char(), _
    start As Integer, _
    length As Integer _
)
Visual C++
[ObsoleteAttribute(L"-- please pre-convert to utf8 bytes instead or use WriteString")]
public:
virtual void WriteChars(
    array<wchar_t>^ s,
    int start,
    int length
)

Parameters

s
Type: array< System..::..Char >[]()[][]
the source of the characters
start
Type: System..::..Int32
the first character in the sequence
length
Type: System..::..Int32
the number of characters in the sequence

See Also

IndexOutput Class
WriteChars Overload
Lucene.Net.Store Namespace


WriteChars Method (String, Int32, Int32)

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteChars Method (String, Int32, Int32)
IndexOutput Class See Also Send Feedback
Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")]
public virtual void WriteChars(
    string s,
    int start,
    int length
)
Visual Basic
<ObsoleteAttribute("-- please pre-convert to utf8 bytes instead or use WriteString")> _
Public Overridable Sub WriteChars ( _
    s As String, _
    start As Integer, _
    length As Integer _
)
Visual C++
[ObsoleteAttribute(L"-- please pre-convert to utf8 bytes instead or use WriteString")]
public:
virtual void WriteChars(
    String^ s,
    int start,
    int length
)

Parameters

s
Type: System..::..String
the source of the characters
start
Type: System..::..Int32
the first character in the sequence
length
Type: System..::..Int32
the number of characters in the sequence

See Also

IndexOutput Class
WriteChars Overload
Lucene.Net.Store Namespace


WriteInt Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteInt Method
IndexOutput Class See Also Send Feedback
Writes an int as four bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteInt(
    int i
)
Visual Basic
Public Overridable Sub WriteInt ( _
    i As Integer _
)
Visual C++
public:
virtual void WriteInt(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteInt(System.Int32)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadInt()()()()


WriteLong Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteLong Method
IndexOutput Class See Also Send Feedback
Writes a long as eight bytes.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteLong(
    long i
)
Visual Basic
Public Overridable Sub WriteLong ( _
    i As Long _
)
Visual C++
public:
virtual void WriteLong(
    long long i
)

Parameters

i
Type: System..::..Int64

[Missing <param name="i"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteLong(System.Int64)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadLong()()()()


WriteString Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteString Method
IndexOutput Class See Also Send Feedback
Writes a string.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteString(
    string s
)
Visual Basic
Public Overridable Sub WriteString ( _
    s As String _
)
Visual C++
public:
virtual void WriteString(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteString(System.String)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadString()()()()


WriteStringStringMap Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteStringStringMap Method
IndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.IndexOutput.WriteStringStringMap(System.Collections.Generic.IDictionary{System.String,System.String})"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteStringStringMap(
    IDictionary<string, string> map
)
Visual Basic
Public Overridable Sub WriteStringStringMap ( _
    map As IDictionary(Of String, String) _
)
Visual C++
public:
virtual void WriteStringStringMap(
    IDictionary<String^, String^>^ map
)

Parameters

map
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>

[Missing <param name="map"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteStringStringMap(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace


WriteVInt Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteVInt Method
IndexOutput Class See Also Send Feedback
Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteVInt(
    int i
)
Visual Basic
Public Overridable Sub WriteVInt ( _
    i As Integer _
)
Visual C++
public:
virtual void WriteVInt(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteVInt(System.Int32)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadVInt()()()()


WriteVLong Method

[image]

Lucene.Net Class Libraries
IndexOutput..::..WriteVLong Method
IndexOutput Class See Also Send Feedback
Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteVLong(
    long i
)
Visual Basic
Public Overridable Sub WriteVLong ( _
    i As Long _
)
Visual C++
public:
virtual void WriteVLong(
    long long i
)

Parameters

i
Type: System..::..Int64

[Missing <param name="i"/> documentation for "M:Lucene.Net.Store.IndexOutput.WriteVLong(System.Int64)"]

See Also

IndexOutput Class
Lucene.Net.Store Namespace
IndexInput..::..ReadVLong()()()()


Lock Class

[image]

Lucene.Net Class Libraries
Lock Class
Members See Also Send Feedback
An interprocess mutex lock.

Typical use might look like:

            new Lock.With(directory.makeLock("my.lock")) {
            public Object doBody() {
            ... code to execute while locked ...
            }
            }.run();

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Lock
Visual Basic
Public MustInherit Class Lock
Visual C++
public ref class Lock abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Lock

See Also

Lock Members
Lucene.Net.Store Namespace
Directory..::..MakeLock(String)


Lock Members

[image] [image]

Lucene.Net Class Libraries
Lock Members
Lock Class Constructors Methods Fields See Also Send Feedback

The Lock type exposes the following members.

Constructors

 | Name | Description
Protected method | Lock | Initializes a new instance of the Lock class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLocked | Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Obtain()()()() | Attempts to obtain exclusive access and immediately return upon success or failure.
Public method | Obtain(Int64) | Attempts to obtain an exclusive lock within amount of time given. Polls once per {@link #LOCK_POLL_INTERVAL} (currently 1000) milliseconds until lockWaitTimeout is passed.
Public method | Release | Releases exclusive access.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | failureReason | If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.
 | LOCK_OBTAIN_WAIT_FOREVER | Pass this value to {@link #Obtain(long)} to try forever to obtain the lock.
 | LOCK_POLL_INTERVAL | How long {@link #Obtain(long)} waits, in milliseconds, in between attempts to acquire the lock.

See Also

Lock Class
Lucene.Net.Store Namespace


Lock Constructor

[image]

Lucene.Net Class Libraries
Lock Constructor
Lock Class See Also Send Feedback
Initializes a new instance of the Lock class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Lock()
Visual Basic
Protected Sub New
Visual C++
protected:
Lock()

See Also

Lock Class
Lucene.Net.Store Namespace


Lock Fields

[image] [image]

Lucene.Net Class Libraries
Lock Fields
Lock Class See Also Send Feedback

The Lock type exposes the following members.

Fields

 | Name | Description
Protected field | failureReason | If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.
 | LOCK_OBTAIN_WAIT_FOREVER | Pass this value to {@link #Obtain(long)} to try forever to obtain the lock.
 | LOCK_POLL_INTERVAL | How long {@link #Obtain(long)} waits, in milliseconds, in between attempts to acquire the lock.

See Also

Lock Class
Lucene.Net.Store Namespace


failureReason Field

[image]

Lucene.Net Class Libraries
Lock..::..failureReason Field
Lock Class See Also Send Feedback
If a lock obtain called, this failureReason may be set with the "root cause" Exception as to why the lock was not obtained.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Exception failureReason
Visual Basic
Protected Friend failureReason As Exception
Visual C++
protected public:
Exception^ failureReason

See Also

Lock Class
Lucene.Net.Store Namespace


LOCK_OBTAIN_WAIT_FOREVER Field

[image]

Lucene.Net Class Libraries
Lock..::..LOCK_OBTAIN_WAIT_FOREVER Field
Lock Class See Also Send Feedback
Pass this value to {@link #Obtain(long)} to try forever to obtain the lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const long LOCK_OBTAIN_WAIT_FOREVER
Visual Basic
Public Const LOCK_OBTAIN_WAIT_FOREVER As Long
Visual C++
public:
literal long long LOCK_OBTAIN_WAIT_FOREVER

See Also

Lock Class
Lucene.Net.Store Namespace


LOCK_POLL_INTERVAL Field

[image]

Lucene.Net Class Libraries
Lock..::..LOCK_POLL_INTERVAL Field
Lock Class See Also Send Feedback
How long {@link #Obtain(long)} waits, in milliseconds, in between attempts to acquire the lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long LOCK_POLL_INTERVAL
Visual Basic
Public Shared LOCK_POLL_INTERVAL As Long
Visual C++
public:
static long long LOCK_POLL_INTERVAL

See Also

Lock Class
Lucene.Net.Store Namespace


Lock Methods

[image] [image]

Lucene.Net Class Libraries
Lock Methods
Lock Class See Also Send Feedback

The Lock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLocked | Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Obtain()()()() | Attempts to obtain exclusive access and immediately return upon success or failure.
Public method | Obtain(Int64) | Attempts to obtain an exclusive lock within amount of time given. Polls once per {@link #LOCK_POLL_INTERVAL} (currently 1000) milliseconds until lockWaitTimeout is passed.
Public method | Release | Releases exclusive access.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lock Class
Lucene.Net.Store Namespace


IsLocked Method

[image]

Lucene.Net Class Libraries
Lock..::..IsLocked Method
Lock Class See Also Send Feedback
Returns true if the resource is currently locked. Note that one must still call {@link #Obtain()} before using the resource.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool IsLocked()
Visual Basic
Public MustOverride Function IsLocked As Boolean
Visual C++
public:
virtual bool IsLocked() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Lock.IsLocked"]

See Also

Lock Class
Lucene.Net.Store Namespace


Obtain Method

[image] [image]

Lucene.Net Class Libraries
Lock..::..Obtain Method
Lock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Obtain()()()() | Attempts to obtain exclusive access and immediately return upon success or failure.
Public method | Obtain(Int64) | Attempts to obtain an exclusive lock within amount of time given. Polls once per {@link #LOCK_POLL_INTERVAL} (currently 1000) milliseconds until lockWaitTimeout is passed.

See Also

Lock Class
Lock Members
Lucene.Net.Store Namespace


Obtain Method

[image]

Lucene.Net Class Libraries
Lock..::..Obtain Method
Lock Class See Also Send Feedback
Attempts to obtain exclusive access and immediately return upon success or failure.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Obtain()
Visual Basic
Public MustOverride Function Obtain As Boolean
Visual C++
public:
virtual bool Obtain() abstract

Return Value

true iff exclusive access is obtained

See Also

Lock Class
Obtain Overload
Lucene.Net.Store Namespace


Obtain Method (Int64)

[image]

Lucene.Net Class Libraries
Lock..::..Obtain Method (Int64)
Lock Class See Also Send Feedback
Attempts to obtain an exclusive lock within amount of time given. Polls once per {@link #LOCK_POLL_INTERVAL} (currently 1000) milliseconds until lockWaitTimeout is passed.
out of bounds

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Obtain(
    long lockWaitTimeout
)
Visual Basic
Public Overridable Function Obtain ( _
    lockWaitTimeout As Long _
) As Boolean
Visual C++
public:
virtual bool Obtain(
    long long lockWaitTimeout
)

Parameters

lockWaitTimeout
Type: System..::..Int64
length of time to wait in milliseconds or {@link #LOCK_OBTAIN_WAIT_FOREVER} to retry forever

Return Value

true if lock was obtained

See Also

Lock Class
Obtain Overload
Lucene.Net.Store Namespace


Release Method

[image]

Lucene.Net Class Libraries
Lock..::..Release Method
Lock Class See Also Send Feedback
Releases exclusive access.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Release()
Visual Basic
Public MustOverride Sub Release
Visual C++
public:
virtual void Release() abstract

See Also

Lock Class
Lucene.Net.Store Namespace


Lock.With Class

[image]

Lucene.Net Class Libraries
Lock..::..With Class
Lock Class Members See Also Send Feedback
Utility class for executing code with exclusive access.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class With
Visual Basic
Public MustInherit Class With
Visual C++
public ref class With abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Lock..::..With

See Also

Lock..::..With Members
Lucene.Net.Store Namespace


Lock.With Members

[image] [image]

Lucene.Net Class Libraries
Lock..::..With Members
Lock..::..With Class Constructors Methods See Also Send Feedback

An interprocess mutex lock.

Typical use might look like:

            new Lock.With(directory.makeLock("my.lock")) {
            public Object doBody() {
            ... code to execute while locked ...
            }
            }.run();

The Lock..::..With type exposes the following members.

Constructors

 | Name | Description
Public method | Lock..::..With | Constructs an executor that will grab the named lock.

Methods

 | Name | Description
Protected method | DoBody | Code to execute with exclusive access.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | run | Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lock..::..With Class
Lucene.Net.Store Namespace


Lock.With Constructor

[image]

Lucene.Net Class Libraries
Lock..::..With Constructor
Lock..::..With Class See Also Send Feedback
Constructs an executor that will grab the named lock.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public With(
    Lock lock_Renamed,
    long lockWaitTimeout
)
Visual Basic
Public Sub New ( _
    lock_Renamed As Lock, _
    lockWaitTimeout As Long _
)
Visual C++
public:
With(
    Lock^ lock_Renamed,
    long long lockWaitTimeout
)

Parameters

lock_Renamed
Type: Lucene.Net.Store..::..Lock

[Missing <param name="lock_Renamed"/> documentation for "M:Lucene.Net.Store.Lock.With.#ctor(Lucene.Net.Store.Lock,System.Int64)"]

lockWaitTimeout
Type: System..::..Int64

[Missing <param name="lockWaitTimeout"/> documentation for "M:Lucene.Net.Store.Lock.With.#ctor(Lucene.Net.Store.Lock,System.Int64)"]

See Also

Lock..::..With Class
Lucene.Net.Store Namespace


Lock.With Methods

[image] [image]

Lucene.Net Class Libraries
Lock..::..With Methods
Lock..::..With Class See Also Send Feedback

The Lock..::..With type exposes the following members.

Methods

 | Name | Description
Protected method | DoBody | Code to execute with exclusive access.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | run | Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lock..::..With Class
Lucene.Net.Store Namespace


DoBody Method

[image]

Lucene.Net Class Libraries
Lock..::..With..::..DoBody Method
Lock..::..With Class See Also Send Feedback
Code to execute with exclusive access.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract Object DoBody()
Visual Basic
Protected Friend MustOverride Function DoBody As Object
Visual C++
protected public:
virtual Object^ DoBody() abstract

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Lock.With.DoBody"]

See Also

Lock..::..With Class
Lucene.Net.Store Namespace


run Method

[image]

Lucene.Net Class Libraries
Lock..::..With..::..run Method
Lock..::..With Class See Also Send Feedback
Calls {@link #doBody} while lock is obtained. Blocks if lock cannot be obtained immediately. Retries to obtain lock once per second until it is obtained, or until it has tried ten times. Lock is released when {@link #doBody} exits.
be obtained

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object run()
Visual Basic
Public Overridable Function run As Object
Visual C++
public:
virtual Object^ run()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.Lock.With.run"]

See Also

Lock..::..With Class
Lucene.Net.Store Namespace


LockFactory Class

[image]

Lucene.Net Class Libraries
LockFactory Class
Members See Also Send Feedback

Base class for Locking implementation. {@link Directory} uses instances of this class to implement locking.

Note that there are some useful tools to verify that your LockFactory is working correctly: {@link VerifyingLockFactory}, {@link LockStressTest}, {@link LockVerifyServer}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class LockFactory
Visual Basic
Public MustInherit Class LockFactory
Visual C++
public ref class LockFactory abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..FSLockFactory
Lucene.Net.Store..::..NoLockFactory
Lucene.Net.Store..::..SingleInstanceLockFactory
Lucene.Net.Store..::..VerifyingLockFactory

See Also

LockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..LockVerifyServer
Lucene.Net.Store..::..LockStressTest
Lucene.Net.Store..::..VerifyingLockFactory


LockFactory Members

[image] [image]

Lucene.Net Class Libraries
LockFactory Members
LockFactory Class Constructors Methods Fields See Also Send Feedback

The LockFactory type exposes the following members.

Constructors

 | Name | Description
Protected method | LockFactory | Initializes a new instance of the LockFactory class

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockPrefix |

See Also

LockFactory Class
Lucene.Net.Store Namespace


LockFactory Constructor

[image]

Lucene.Net Class Libraries
LockFactory Constructor
LockFactory Class See Also Send Feedback
Initializes a new instance of the LockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected LockFactory()
Visual Basic
Protected Sub New
Visual C++
protected:
LockFactory()

See Also

LockFactory Class
Lucene.Net.Store Namespace


LockFactory Fields

[image] [image]

Lucene.Net Class Libraries
LockFactory Fields
LockFactory Class See Also Send Feedback

The LockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockPrefix |

See Also

LockFactory Class
Lucene.Net.Store Namespace


lockPrefix Field

[image]

Lucene.Net Class Libraries
LockFactory..::..lockPrefix Field
LockFactory Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.LockFactory.lockPrefix"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal string lockPrefix
Visual Basic
Protected Friend lockPrefix As String
Visual C++
protected public:
String^ lockPrefix

See Also

LockFactory Class
Lucene.Net.Store Namespace


LockFactory Methods

[image] [image]

Lucene.Net Class Libraries
LockFactory Methods
LockFactory Class See Also Send Feedback

The LockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | Return a new Lock instance identified by lockName.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockFactory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
LockFactory..::..ClearLock Method
LockFactory Class See Also Send Feedback
Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void ClearLock(
    string lockName
)
Visual Basic
Public MustOverride Sub ClearLock ( _
    lockName As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ lockName
) abstract

Parameters

lockName
Type: System..::..String
name of the lock to be cleared.

See Also

LockFactory Class
Lucene.Net.Store Namespace


GetLockPrefix Method

[image]

Lucene.Net Class Libraries
LockFactory..::..GetLockPrefix Method
LockFactory Class See Also Send Feedback
Get the prefix in use for all locks created in this LockFactory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string GetLockPrefix()
Visual Basic
Public Overridable Function GetLockPrefix As String
Visual C++
public:
virtual String^ GetLockPrefix()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.LockFactory.GetLockPrefix"]

See Also

LockFactory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
LockFactory..::..MakeLock Method
LockFactory Class See Also Send Feedback
Return a new Lock instance identified by lockName.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Lock MakeLock(
    string lockName
)
Visual Basic
Public MustOverride Function MakeLock ( _
    lockName As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ lockName
) abstract

Parameters

lockName
Type: System..::..String
name of the lock to be created.

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.LockFactory.MakeLock(System.String)"]

See Also

LockFactory Class
Lucene.Net.Store Namespace


SetLockPrefix Method

[image]

Lucene.Net Class Libraries
LockFactory..::..SetLockPrefix Method
LockFactory Class See Also Send Feedback
Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetLockPrefix(
    string lockPrefix
)
Visual Basic
Public Overridable Sub SetLockPrefix ( _
    lockPrefix As String _
)
Visual C++
public:
virtual void SetLockPrefix(
    String^ lockPrefix
)

Parameters

lockPrefix
Type: System..::..String

[Missing <param name="lockPrefix"/> documentation for "M:Lucene.Net.Store.LockFactory.SetLockPrefix(System.String)"]

See Also

LockFactory Class
Lucene.Net.Store Namespace


LockObtainFailedException Class

[image]

Lucene.Net Class Libraries
LockObtainFailedException Class
Members See Also Send Feedback
This exception is thrown when the
CopyC#
write.lock
 could not be acquired. This happens when a writer tries to open an index that another writer already has open.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class LockObtainFailedException : IOException
Visual Basic
<SerializableAttribute> _
Public Class LockObtainFailedException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class LockObtainFailedException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Lucene.Net.Store..::..LockObtainFailedException

See Also

LockObtainFailedException Members
Lucene.Net.Store Namespace
[!:Lock.obtain(long)]


LockObtainFailedException Members

[image] [image]

Lucene.Net Class Libraries
LockObtainFailedException Members
LockObtainFailedException Class Constructors Methods Properties Events See Also Send Feedback

The LockObtainFailedException type exposes the following members.

Constructors

 | Name | Description
Public method | LockObtainFailedException(String) | Initializes a new instance of the LockObtainFailedException class
Public method | LockObtainFailedException(String, Exception) | Initializes a new instance of the LockObtainFailedException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LockObtainFailedException Class
Lucene.Net.Store Namespace


LockObtainFailedException Constructor

[image] [image]

Lucene.Net Class Libraries
LockObtainFailedException Constructor
LockObtainFailedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LockObtainFailedException(String) | Initializes a new instance of the LockObtainFailedException class
Public method | LockObtainFailedException(String, Exception) | Initializes a new instance of the LockObtainFailedException class

See Also

LockObtainFailedException Class
LockObtainFailedException Members
Lucene.Net.Store Namespace


LockObtainFailedException Constructor (String)

[image]

Lucene.Net Class Libraries
LockObtainFailedException Constructor (String)
LockObtainFailedException Class See Also Send Feedback
Initializes a new instance of the LockObtainFailedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LockObtainFailedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
LockObtainFailedException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Store.LockObtainFailedException.#ctor(System.String)"]

See Also

LockObtainFailedException Class
LockObtainFailedException Overload
Lucene.Net.Store Namespace


LockObtainFailedException Constructor (String, Exception)

[image]

Lucene.Net Class Libraries
LockObtainFailedException Constructor (String, Exception)
LockObtainFailedException Class See Also Send Feedback
Initializes a new instance of the LockObtainFailedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LockObtainFailedException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New ( _
    message As String, _
    ex As Exception _
)
Visual C++
public:
LockObtainFailedException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Store.LockObtainFailedException.#ctor(System.String,System.Exception)"]

ex
Type: System..::..Exception

[Missing <param name="ex"/> documentation for "M:Lucene.Net.Store.LockObtainFailedException.#ctor(System.String,System.Exception)"]

See Also

LockObtainFailedException Class
LockObtainFailedException Overload
Lucene.Net.Store Namespace


LockObtainFailedException Methods

[image] [image]

Lucene.Net Class Libraries
LockObtainFailedException Methods
LockObtainFailedException Class See Also Send Feedback

The LockObtainFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LockObtainFailedException Class
Lucene.Net.Store Namespace


LockObtainFailedException Properties

[image] [image]

Lucene.Net Class Libraries
LockObtainFailedException Properties
LockObtainFailedException Class See Also Send Feedback

The LockObtainFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LockObtainFailedException Class
Lucene.Net.Store Namespace


LockObtainFailedException Events

[image] [image]

Lucene.Net Class Libraries
LockObtainFailedException Events
LockObtainFailedException Class See Also Send Feedback

The LockObtainFailedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LockObtainFailedException Class
Lucene.Net.Store Namespace


LockReleaseFailedException Class

[image]

Lucene.Net Class Libraries
LockReleaseFailedException Class
Members See Also Send Feedback
This exception is thrown when the
CopyC#
write.lock
 could not be released.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class LockReleaseFailedException : IOException
Visual Basic
<SerializableAttribute> _
Public Class LockReleaseFailedException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class LockReleaseFailedException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Lucene.Net.Store..::..LockReleaseFailedException

See Also

LockReleaseFailedException Members
Lucene.Net.Store Namespace
[!:Lock.release()]


LockReleaseFailedException Members

[image] [image]

Lucene.Net Class Libraries
LockReleaseFailedException Members
LockReleaseFailedException Class Constructors Methods Properties Events See Also Send Feedback

The LockReleaseFailedException type exposes the following members.

Constructors

 | Name | Description
Public method | LockReleaseFailedException | Initializes a new instance of the LockReleaseFailedException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LockReleaseFailedException Class
Lucene.Net.Store Namespace


LockReleaseFailedException Constructor

[image]

Lucene.Net Class Libraries
LockReleaseFailedException Constructor
LockReleaseFailedException Class See Also Send Feedback
Initializes a new instance of the LockReleaseFailedException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LockReleaseFailedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
LockReleaseFailedException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Store.LockReleaseFailedException.#ctor(System.String)"]

See Also

LockReleaseFailedException Class
Lucene.Net.Store Namespace


LockReleaseFailedException Methods

[image] [image]

Lucene.Net Class Libraries
LockReleaseFailedException Methods
LockReleaseFailedException Class See Also Send Feedback

The LockReleaseFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LockReleaseFailedException Class
Lucene.Net.Store Namespace


LockReleaseFailedException Properties

[image] [image]

Lucene.Net Class Libraries
LockReleaseFailedException Properties
LockReleaseFailedException Class See Also Send Feedback

The LockReleaseFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LockReleaseFailedException Class
Lucene.Net.Store Namespace


LockReleaseFailedException Events

[image] [image]

Lucene.Net Class Libraries
LockReleaseFailedException Events
LockReleaseFailedException Class See Also Send Feedback

The LockReleaseFailedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LockReleaseFailedException Class
Lucene.Net.Store Namespace


LockStressTest Class

[image]

Lucene.Net Class Libraries
LockStressTest Class
Members See Also Send Feedback
Simple standalone tool that forever acquires & releases a lock using a specific LockFactory. Run without any args to see usage.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class LockStressTest
Visual Basic
Public Class LockStressTest
Visual C++
public ref class LockStressTest

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockStressTest

See Also

LockStressTest Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..VerifyingLockFactory
Lucene.Net.Store..::..LockVerifyServer


LockStressTest Members

[image] [image]

Lucene.Net Class Libraries
LockStressTest Members
LockStressTest Class Constructors Methods See Also Send Feedback

The LockStressTest type exposes the following members.

Constructors

 | Name | Description
Public method | LockStressTest | Initializes a new instance of the LockStressTest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockStressTest Class
Lucene.Net.Store Namespace


LockStressTest Constructor

[image]

Lucene.Net Class Libraries
LockStressTest Constructor
LockStressTest Class See Also Send Feedback
Initializes a new instance of the LockStressTest class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LockStressTest()
Visual Basic
Public Sub New
Visual C++
public:
LockStressTest()

See Also

LockStressTest Class
Lucene.Net.Store Namespace


LockStressTest Methods

[image] [image]

Lucene.Net Class Libraries
LockStressTest Methods
LockStressTest Class See Also Send Feedback

The LockStressTest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockStressTest Class
Lucene.Net.Store Namespace


Main Method

[image]

Lucene.Net Class Libraries
LockStressTest..::..Main Method
LockStressTest Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.LockStressTest.Main(System.String[])"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Store.LockStressTest.Main(System.String[])"]

See Also

LockStressTest Class
Lucene.Net.Store Namespace


LockVerifyServer Class

[image]

Lucene.Net Class Libraries
LockVerifyServer Class
Members See Also Send Feedback
Simple standalone server that must be running when you use {@link VerifyingLockFactory}. This server simply verifies at most one process holds the lock at a time. Run without any args to see usage.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class LockVerifyServer
Visual Basic
Public Class LockVerifyServer
Visual C++
public ref class LockVerifyServer

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockVerifyServer

See Also

LockVerifyServer Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..VerifyingLockFactory
Lucene.Net.Store..::..LockStressTest


LockVerifyServer Members

[image] [image]

Lucene.Net Class Libraries
LockVerifyServer Members
LockVerifyServer Class Constructors Methods See Also Send Feedback

The LockVerifyServer type exposes the following members.

Constructors

 | Name | Description
Public method | LockVerifyServer | Initializes a new instance of the LockVerifyServer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockVerifyServer Class
Lucene.Net.Store Namespace


LockVerifyServer Constructor

[image]

Lucene.Net Class Libraries
LockVerifyServer Constructor
LockVerifyServer Class See Also Send Feedback
Initializes a new instance of the LockVerifyServer class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public LockVerifyServer()
Visual Basic
Public Sub New
Visual C++
public:
LockVerifyServer()

See Also

LockVerifyServer Class
Lucene.Net.Store Namespace


LockVerifyServer Methods

[image] [image]

Lucene.Net Class Libraries
LockVerifyServer Methods
LockVerifyServer Class See Also Send Feedback

The LockVerifyServer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockVerifyServer Class
Lucene.Net.Store Namespace


Main Method

[image]

Lucene.Net Class Libraries
LockVerifyServer..::..Main Method
LockVerifyServer Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.LockVerifyServer.Main(System.String[])"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:Lucene.Net.Store.LockVerifyServer.Main(System.String[])"]

See Also

LockVerifyServer Class
Lucene.Net.Store Namespace


MMapDirectory Class

[image]

Lucene.Net Class Libraries
MMapDirectory Class
Members See Also Send Feedback
File-based {@link Directory} implementation that uses mmap for reading, and {@link SimpleFSDirectory.SimpleFSIndexOutput} for writing.

NOTE: memory mapping uses up a portion of the virtual memory address space in your process equal to the size of the file being mapped. Before using this class, be sure your have plenty of virtual address space, e.g. by using a 64 bit JRE, or a 32 bit JRE with indexes that are guaranteed to fit within the address space. On 32 bit platforms also consult {@link #setMaxChunkSize} if you have problems with mmap failing because of fragmented address space. If you get an OutOfMemoryException, it is recommened to reduce the chunk size, until it works.

Due to this bug in Sun's JRE, MMapDirectory's {@link IndexInput#close} is unable to close the underlying OS file handle. Only when GC finally collects the underlying objects, which could be quite some time later, will the file handle be closed.

This will consume additional transient disk usage: on Windows, attempts to delete or overwrite the files will result in an exception; on other platforms, which typically have a "delete on last close" semantics, while such operations will succeed, the bytes are still consuming space on disk. For many applications this limitation is not a problem (e.g. if you have plenty of disk space, and you don't rely on overwriting files on Windows) but it's still an important limitation to be aware of.

This class supplies the workaround mentioned in the bug report (disabled by default, see {@link #setUseUnmap}), which may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality. {@link #UNMAP_SUPPORTED} is

CopyC#
true
, if the workaround can be enabled (with no guarantees).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MMapDirectory : FSDirectory
Visual Basic
Public Class MMapDirectory _
    Inherits FSDirectory
Visual C++
public ref class MMapDirectory : public FSDirectory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..FSDirectory
Lucene.Net.Store..::..MMapDirectory

See Also

MMapDirectory Members
Lucene.Net.Store Namespace


MMapDirectory Members

[image] [image]

Lucene.Net Class Libraries
MMapDirectory Members
MMapDirectory Class Constructors Methods Fields Properties See Also Send Feedback

The MMapDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | MMapDirectory(DirectoryInfo) | Create a new MMapDirectory for the named location and the default lock factory.
Public method | MMapDirectory(FileInfo) | Obsolete. Create a new MMapDirectory for the named location and the default lock factory.
Public method | MMapDirectory(DirectoryInfo, LockFactory) | Create a new MMapDirectory for the named location.
Public method | MMapDirectory(FileInfo, LockFactory) | Obsolete. Create a new MMapDirectory for the named location.

Methods

Name | Description
Public method ClearLock
Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
(Inherited from Directory.)
Public method Close
Closes the store to future operations.
(Inherited from FSDirectory.)
Public method CreateOutput
Creates an IndexOutput for the file with the given name.
(Overrides FSDirectory..::..CreateOutput(String).)
Public method DeleteFile
Removes an existing file in the directory.
(Inherited from FSDirectory.)
Public method Dispose
.NET
(Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method FileExists
Returns true iff a file with the given name exists.
(Inherited from FSDirectory.)
Public method FileLength
Returns the length in bytes of a file in the directory.
(Inherited from FSDirectory.)
Public method FileModified(String)
Returns the time the named file was last modified.
(Inherited from FSDirectory.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetDirectory()()()() | (Inherited from FSDirectory.)
Public method | GetFile | Obsolete. (Inherited from FSDirectory.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLockFactory
Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
(Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Public method GetMaxChunkSize
Returns the current mmap chunk size.
Public method GetReadChunkSize
The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}.
(Inherited from FSDirectory.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUseUnmap
Returns
CopyC#
true
, if the unmap workaround is enabled.
Protected method InitOutput
Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}.
(Inherited from FSDirectory.)
Public method | List | Obsolete. (Inherited from FSDirectory.)
Public method ListAll()()()()
Lists all files (not subdirectories) in the directory.
(Inherited from FSDirectory.)
Public method MakeLock
Construct a {@link Lock}.
(Inherited from Directory.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method OpenInput(String, Int32)
Creates an IndexInput for the file with the given name.
(Overrides FSDirectory..::..OpenInput(String, Int32).)
Public method RenameFile Obsolete.
Renames an existing file in the directory. Warning: This is not atomic.
(Inherited from FSDirectory.)
Public method SetLockFactory
Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
(Inherited from Directory.)
Public method SetMaxChunkSize
Sets the maximum chunk size (default is {@link Integer#MAX_VALUE} for 64 bit JVMs and 256 MiBytes for 32 bit JVMs) used for memory mapping. Especially on 32 bit platform, the address space can be very fragmented, so large index files cannot be mapped. Using a lower chunk size makes the directory implementation a little bit slower (as the correct chunk must be resolved on each seek) but the chance is higher that mmap does not fail. On 64 bit Java platforms, this parameter should always be {@link Integer#MAX_VALUE}, as the adress space is big enough.
Public method SetReadChunkSize
Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE};

This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size.

Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory.

NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size.

(Inherited from FSDirectory.)
Public method SetUseUnmap
This method enables the workaround for unmapping the buffers from address space after closing {@link IndexInput}, that is mentioned in the bug report. This hack may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality.

NOTE: Enabling this is completely unsupported by Java and may lead to JVM crashs if

CopyC#
IndexInput
is closed while another thread is still accessing it (SIGSEGV).
Public method | Sync | (Inherited from FSDirectory.)
Public method ToString
For debug output.
(Inherited from FSDirectory.)
Public method TouchFile
Set the modified time of an existing file to now.
(Inherited from FSDirectory.)

Fields

Name | Description
Protected field directory
The underlying filesystem directory
(Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Protected field lockFactory
Holds the LockFactory instance (implements locking for this Directory instance).
(Inherited from Directory.)
UNMAP_SUPPORTED
CopyC#
true
, if this platform supports unmapping mmaped files.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


MMapDirectory Constructor

[image] [image]

Lucene.Net Class Libraries
MMapDirectory Constructor
MMapDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MMapDirectory(DirectoryInfo) | Create a new MMapDirectory for the named location and the default lock factory.
Public method | MMapDirectory(FileInfo) | Obsolete. Create a new MMapDirectory for the named location and the default lock factory.
Public method | MMapDirectory(DirectoryInfo, LockFactory) | Create a new MMapDirectory for the named location.
Public method | MMapDirectory(FileInfo, LockFactory) | Obsolete. Create a new MMapDirectory for the named location.

See Also

MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace


MMapDirectory Constructor (DirectoryInfo)

[image]

Lucene.Net Class Libraries
MMapDirectory Constructor (DirectoryInfo)
MMapDirectory Class See Also Send Feedback
Create a new MMapDirectory for the named location and the default lock factory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MMapDirectory(
    DirectoryInfo path
)
Visual Basic
Public Sub New ( _
    path As DirectoryInfo _
)
Visual C++
public:
MMapDirectory(
    DirectoryInfo^ path
)

Parameters

path
Type: System.IO..::..DirectoryInfo
the path of the directory

See Also

MMapDirectory Class
MMapDirectory Overload
Lucene.Net.Store Namespace


MMapDirectory Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
MMapDirectory Constructor (FileInfo)
MMapDirectory Class See Also Send Feedback
Create a new MMapDirectory for the named location and the default lock factory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public MMapDirectory(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Sub New ( _
    path As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
MMapDirectory(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo
the path of the directory

See Also

MMapDirectory Class
MMapDirectory Overload
Lucene.Net.Store Namespace


MMapDirectory Constructor (DirectoryInfo, LockFactory)

[image]

Lucene.Net Class Libraries
MMapDirectory Constructor (DirectoryInfo, LockFactory)
MMapDirectory Class See Also Send Feedback
Create a new MMapDirectory for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MMapDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
Visual Basic
Public Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
Visual C++
public:
MMapDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System.IO..::..DirectoryInfo
the path of the directory
lockFactory
Type: Lucene.Net.Store..::..LockFactory
the lock factory to use, or null for the default.

See Also

MMapDirectory Class
MMapDirectory Overload
Lucene.Net.Store Namespace


MMapDirectory Constructor (FileInfo, LockFactory)

[image]

Lucene.Net Class Libraries
MMapDirectory Constructor (FileInfo, LockFactory)
MMapDirectory Class See Also Send Feedback
Create a new MMapDirectory for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public MMapDirectory(
    FileInfo path,
    LockFactory lockFactory
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Sub New ( _
    path As FileInfo, _
    lockFactory As LockFactory _
)
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
MMapDirectory(
    FileInfo^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System.IO..::..FileInfo
the path of the directory
lockFactory
Type: Lucene.Net.Store..::..LockFactory
the lock factory to use, or null for the default.

See Also

MMapDirectory Class
MMapDirectory Overload
Lucene.Net.Store Namespace


MMapDirectory Fields

[image] [image]

Lucene.Net Class Libraries
MMapDirectory Fields
MMapDirectory Class See Also Send Feedback

The MMapDirectory type exposes the following members.

Fields

Name | Description
Protected field directory
The underlying filesystem directory
(Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Protected field lockFactory
Holds the LockFactory instance (implements locking for this Directory instance).
(Inherited from Directory.)
UNMAP_SUPPORTED
CopyC#
true
, if this platform supports unmapping mmaped files.

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


UNMAP_SUPPORTED Field

[image]

Lucene.Net Class Libraries
MMapDirectory..::..UNMAP_SUPPORTED Field
MMapDirectory Class See Also Send Feedback
CopyC#
true
, if this platform supports unmapping mmaped files.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool UNMAP_SUPPORTED
Visual Basic
Public Shared UNMAP_SUPPORTED As Boolean
Visual C++
public:
static bool UNMAP_SUPPORTED

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


MMapDirectory Methods

[image] [image]

Lucene.Net Class Libraries
MMapDirectory Methods
MMapDirectory Class See Also Send Feedback

The MMapDirectory type exposes the following members.

Methods

Name | Description
Public method ClearLock
Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use.
(Inherited from Directory.)
Public method Close
Closes the store to future operations.
(Inherited from FSDirectory.)
Public method CreateOutput
Creates an IndexOutput for the file with the given name.
(Overrides FSDirectory..::..CreateOutput(String).)
Public method DeleteFile
Removes an existing file in the directory.
(Inherited from FSDirectory.)
Public method Dispose
.NET
(Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method FileExists
Returns true iff a file with the given name exists.
(Inherited from FSDirectory.)
Public method FileLength
Returns the length in bytes of a file in the directory.
(Inherited from FSDirectory.)
Public method FileModified(String)
Returns the time the named file was last modified.
(Inherited from FSDirectory.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetDirectory()()()() | (Inherited from FSDirectory.)
Public method | GetFile | Obsolete. (Inherited from FSDirectory.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetLockFactory
Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation.
(Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Public method GetMaxChunkSize
Returns the current mmap chunk size.
Public method GetReadChunkSize
The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}.
(Inherited from FSDirectory.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUseUnmap
Returns
CopyC#
true
, if the unmap workaround is enabled.
Protected method InitOutput
Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}.
(Inherited from FSDirectory.)
Public method | List | Obsolete. (Inherited from FSDirectory.)
Public method ListAll()()()()
Lists all files (not subdirectories) in the directory.
(Inherited from FSDirectory.)
Public method MakeLock
Construct a {@link Lock}.
(Inherited from Directory.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method OpenInput(String, Int32)
Creates an IndexInput for the file with the given name.
(Overrides FSDirectory..::..OpenInput(String, Int32).)
Public method RenameFile Obsolete.
Renames an existing file in the directory. Warning: This is not atomic.
(Inherited from FSDirectory.)
Public method SetLockFactory
Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories).
(Inherited from Directory.)
Public method SetMaxChunkSize
Sets the maximum chunk size (default is {@link Integer#MAX_VALUE} for 64 bit JVMs and 256 MiBytes for 32 bit JVMs) used for memory mapping. Especially on 32 bit platform, the address space can be very fragmented, so large index files cannot be mapped. Using a lower chunk size makes the directory implementation a little bit slower (as the correct chunk must be resolved on each seek) but the chance is higher that mmap does not fail. On 64 bit Java platforms, this parameter should always be {@link Integer#MAX_VALUE}, as the adress space is big enough.
Public method SetReadChunkSize
Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE};

This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size.

Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory.

NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size.

(Inherited from FSDirectory.)
Public method SetUseUnmap
This method enables the workaround for unmapping the buffers from address space after closing {@link IndexInput}, that is mentioned in the bug report. This hack may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality.

NOTE: Enabling this is completely unsupported by Java and may lead to JVM crashs if

CopyC#
IndexInput
is closed while another thread is still accessing it (SIGSEGV).
Public method | Sync | (Inherited from FSDirectory.)
Public method ToString
For debug output.
(Inherited from FSDirectory.)
Public method TouchFile
Set the modified time of an existing file to now.
(Inherited from FSDirectory.)

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
MMapDirectory..::..CreateOutput Method
MMapDirectory Class See Also Send Feedback
Creates an IndexOutput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.MMapDirectory.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.MMapDirectory.CreateOutput(System.String)"]

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


GetMaxChunkSize Method

[image]

Lucene.Net Class Libraries
MMapDirectory..::..GetMaxChunkSize Method
MMapDirectory Class See Also Send Feedback
Returns the current mmap chunk size.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetMaxChunkSize()
Visual Basic
Public Overridable Function GetMaxChunkSize As Integer
Visual C++
public:
virtual int GetMaxChunkSize()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.MMapDirectory.GetMaxChunkSize"]

See Also

MMapDirectory Class
Lucene.Net.Store Namespace
[!:setMaxChunkSize]


GetUseUnmap Method

[image]

Lucene.Net Class Libraries
MMapDirectory..::..GetUseUnmap Method
MMapDirectory Class See Also Send Feedback
Returns
CopyC#
true
, if the unmap workaround is enabled.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetUseUnmap()
Visual Basic
Public Overridable Function GetUseUnmap As Boolean
Visual C++
public:
virtual bool GetUseUnmap()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.MMapDirectory.GetUseUnmap"]

See Also

MMapDirectory Class
Lucene.Net.Store Namespace
[!:setUseUnmap]


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
MMapDirectory..::..OpenInput Method
MMapDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides FSDirectory..::..OpenInput(String, Int32).)

See Also

MMapDirectory Class
MMapDirectory Members
Lucene.Net.Store Namespace


OpenInput Method (String, Int32)

[image]

Lucene.Net Class Libraries
MMapDirectory..::..OpenInput Method (String, Int32)
MMapDirectory Class See Also Send Feedback
Creates an IndexInput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.MMapDirectory.OpenInput(System.String,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.MMapDirectory.OpenInput(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.MMapDirectory.OpenInput(System.String,System.Int32)"]

See Also

MMapDirectory Class
OpenInput Overload
Lucene.Net.Store Namespace


SetMaxChunkSize Method

[image]

Lucene.Net Class Libraries
MMapDirectory..::..SetMaxChunkSize Method
MMapDirectory Class See Also Send Feedback
Sets the maximum chunk size (default is {@link Integer#MAX_VALUE} for 64 bit JVMs and 256 MiBytes for 32 bit JVMs) used for memory mapping. Especially on 32 bit platform, the address space can be very fragmented, so large index files cannot be mapped. Using a lower chunk size makes the directory implementation a little bit slower (as the correct chunk must be resolved on each seek) but the chance is higher that mmap does not fail. On 64 bit Java platforms, this parameter should always be {@link Integer#MAX_VALUE}, as the adress space is big enough.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetMaxChunkSize(
    int maxBBuf
)
Visual Basic
Public Overridable Sub SetMaxChunkSize ( _
    maxBBuf As Integer _
)
Visual C++
public:
virtual void SetMaxChunkSize(
    int maxBBuf
)

Parameters

maxBBuf
Type: System..::..Int32

[Missing <param name="maxBBuf"/> documentation for "M:Lucene.Net.Store.MMapDirectory.SetMaxChunkSize(System.Int32)"]

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


SetUseUnmap Method

[image]

Lucene.Net Class Libraries
MMapDirectory..::..SetUseUnmap Method
MMapDirectory Class See Also Send Feedback
This method enables the workaround for unmapping the buffers from address space after closing {@link IndexInput}, that is mentioned in the bug report. This hack may fail on non-Sun JVMs. It forcefully unmaps the buffer on close by using an undocumented internal cleanup functionality.

NOTE: Enabling this is completely unsupported by Java and may lead to JVM crashs if

CopyC#
IndexInput
is closed while another thread is still accessing it (SIGSEGV).
is
CopyC#
false
 and the workaround cannot be enabled.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetUseUnmap(
    bool useUnmapHack
)
Visual Basic
Public Overridable Sub SetUseUnmap ( _
    useUnmapHack As Boolean _
)
Visual C++
public:
virtual void SetUseUnmap(
    bool useUnmapHack
)

Parameters

useUnmapHack
Type: System..::..Boolean

[Missing <param name="useUnmapHack"/> documentation for "M:Lucene.Net.Store.MMapDirectory.SetUseUnmap(System.Boolean)"]

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


MMapDirectory Properties

[image] [image]

Lucene.Net Class Libraries
MMapDirectory Properties
MMapDirectory Class See Also Send Feedback

The MMapDirectory type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

MMapDirectory Class
Lucene.Net.Store Namespace


NativeFSLockFactory Class

[image]

Lucene.Net Class Libraries
NativeFSLockFactory Class
Members See Also Send Feedback

Implements {@link LockFactory} using native OS file locks. Note that because this LockFactory relies on java.nio.* APIs for locking, any problems with those APIs will cause locking to fail. Specifically, on certain NFS environments the java.nio.* locks will fail (the lock can incorrectly be double acquired) whereas {@link SimpleFSLockFactory} worked perfectly in those same environments. For NFS based access to an index, it's recommended that you try {@link SimpleFSLockFactory} first and work around the one limitation that a lock file could be left when the JVM exits abnormally.

The primary benefit of {@link NativeFSLockFactory} is that lock files will be properly removed (by the OS) if the JVM has an abnormal exit.

Note that, unlike {@link SimpleFSLockFactory}, the existence of leftover lock files in the filesystem on exiting the JVM is fine because the OS will free the locks held against these files even though the files still remain.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NativeFSLockFactory : FSLockFactory
Visual Basic
Public Class NativeFSLockFactory _
    Inherits FSLockFactory
Visual C++
public ref class NativeFSLockFactory : public FSLockFactory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..FSLockFactory
Lucene.Net.Store..::..NativeFSLockFactory

See Also

NativeFSLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..LockFactory


NativeFSLockFactory Members

[image] [image]

Lucene.Net Class Libraries
NativeFSLockFactory Members
NativeFSLockFactory Class Constructors Methods Fields See Also Send Feedback

The NativeFSLockFactory type exposes the following members.

Constructors

 | Name | Description
Public method | NativeFSLockFactory()()()() | Create a NativeFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a {@link FSDirectory} subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | NativeFSLockFactory(DirectoryInfo) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:
Public method | NativeFSLockFactory(FileInfo) | Obsolete. Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:
Public method | NativeFSLockFactory(String) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockDir | Retrieve the lock directory. (Inherited from FSLockFactory.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetLockDir | Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

NativeFSLockFactory Class
Lucene.Net.Store Namespace


NativeFSLockFactory Constructor

[image] [image]

Lucene.Net Class Libraries
NativeFSLockFactory Constructor
NativeFSLockFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NativeFSLockFactory()()()() | Create a NativeFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a {@link FSDirectory} subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | NativeFSLockFactory(DirectoryInfo) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:
Public method | NativeFSLockFactory(FileInfo) | Obsolete. Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:
Public method | NativeFSLockFactory(String) | Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

See Also

NativeFSLockFactory Class
NativeFSLockFactory Members
Lucene.Net.Store Namespace


NativeFSLockFactory Constructor

[image]

Lucene.Net Class Libraries
NativeFSLockFactory Constructor
NativeFSLockFactory Class See Also Send Feedback
Create a NativeFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a {@link FSDirectory} subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NativeFSLockFactory()
Visual Basic
Public Sub New
Visual C++
public:
NativeFSLockFactory()

See Also

NativeFSLockFactory Class
NativeFSLockFactory Overload
Lucene.Net.Store Namespace


NativeFSLockFactory Constructor (DirectoryInfo)

[image]

Lucene.Net Class Libraries
NativeFSLockFactory Constructor (DirectoryInfo)
NativeFSLockFactory Class See Also Send Feedback
Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NativeFSLockFactory(
    DirectoryInfo lockDir
)
Visual Basic
Public Sub New ( _
    lockDir As DirectoryInfo _
)
Visual C++
public:
NativeFSLockFactory(
    DirectoryInfo^ lockDir
)

Parameters

lockDir
Type: System.IO..::..DirectoryInfo
where lock files are created.

See Also

NativeFSLockFactory Class
NativeFSLockFactory Overload
Lucene.Net.Store Namespace


NativeFSLockFactory Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
NativeFSLockFactory Constructor (FileInfo)
NativeFSLockFactory Class See Also Send Feedback
Create a NativeFSLockFactory instance, storing lock files into the specified lockDir:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public NativeFSLockFactory(
    FileInfo lockDir
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Sub New ( _
    lockDir As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
NativeFSLockFactory(
    FileInfo^ lockDir
)

Parameters

lockDir
Type: System.IO..::..FileInfo
where lock files are created.

See Also

NativeFSLockFactory Class
NativeFSLockFactory Overload
Lucene.Net.Store Namespace


NativeFSLockFactory Constructor (String)

[image]

Lucene.Net Class Libraries
NativeFSLockFactory Constructor (String)
NativeFSLockFactory Class See Also Send Feedback
Create a NativeFSLockFactory instance, storing lock files into the specified lockDirName:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NativeFSLockFactory(
    string lockDirName
)
Visual Basic
Public Sub New ( _
    lockDirName As String _
)
Visual C++
public:
NativeFSLockFactory(
    String^ lockDirName
)

Parameters

lockDirName
Type: System..::..String
where lock files are created.

See Also

NativeFSLockFactory Class
NativeFSLockFactory Overload
Lucene.Net.Store Namespace


NativeFSLockFactory Fields

[image] [image]

Lucene.Net Class Libraries
NativeFSLockFactory Fields
NativeFSLockFactory Class See Also Send Feedback

The NativeFSLockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

NativeFSLockFactory Class
Lucene.Net.Store Namespace


NativeFSLockFactory Methods

[image] [image]

Lucene.Net Class Libraries
NativeFSLockFactory Methods
NativeFSLockFactory Class See Also Send Feedback

The NativeFSLockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockDir | Retrieve the lock directory. (Inherited from FSLockFactory.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetLockDir | Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NativeFSLockFactory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
NativeFSLockFactory..::..ClearLock Method
NativeFSLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.NativeFSLockFactory.ClearLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ClearLock(
    string lockName
)
Visual Basic
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.NativeFSLockFactory.ClearLock(System.String)"]

See Also

NativeFSLockFactory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
NativeFSLockFactory..::..MakeLock Method
NativeFSLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.NativeFSLockFactory.MakeLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Lock MakeLock(
    string lockName
)
Visual Basic
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.NativeFSLockFactory.MakeLock(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.NativeFSLockFactory.MakeLock(System.String)"]

See Also

NativeFSLockFactory Class
Lucene.Net.Store Namespace


NIOFSDirectory Class

[image]

Lucene.Net Class Libraries
NIOFSDirectory Class
Members See Also Send Feedback
Not implemented. Waiting for volunteers.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NIOFSDirectory : FSDirectory
Visual Basic
Public Class NIOFSDirectory _
    Inherits FSDirectory
Visual C++
public ref class NIOFSDirectory : public FSDirectory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..FSDirectory
Lucene.Net.Store..::..NIOFSDirectory

See Also

NIOFSDirectory Members
Lucene.Net.Store Namespace


NIOFSDirectory Members

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory Members
NIOFSDirectory Class Constructors Methods Fields Properties See Also Send Feedback

The NIOFSDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | NIOFSDirectory()()()() | Initializes a new instance of the NIOFSDirectory class
Public method | NIOFSDirectory(DirectoryInfo, LockFactory) | Initializes a new instance of the NIOFSDirectory class

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations. (Inherited from FSDirectory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. In 3.0 this method will become abstract. (Inherited from FSDirectory.)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | .NET (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory()()()() | (Inherited from FSDirectory.)
Public method | GetFile | Obsolete. (Inherited from FSDirectory.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Public method | GetReadChunkSize | The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}. (Inherited from FSDirectory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}. (Inherited from FSDirectory.)
Public method | List | Obsolete. (Inherited from FSDirectory.)
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract. (Inherited from FSDirectory.)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. Warning: This is not atomic. (Inherited from FSDirectory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SetReadChunkSize | Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE}; This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size. Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory. NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size. (Inherited from FSDirectory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)

Fields

 | Name | Description
Protected field | directory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

NIOFSDirectory Class
Lucene.Net.Store Namespace


NIOFSDirectory Constructor

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory Constructor
NIOFSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NIOFSDirectory()()()() | Initializes a new instance of the NIOFSDirectory class
Public method | NIOFSDirectory(DirectoryInfo, LockFactory) | Initializes a new instance of the NIOFSDirectory class

See Also

NIOFSDirectory Class
NIOFSDirectory Members
Lucene.Net.Store Namespace


NIOFSDirectory Constructor

[image]

Lucene.Net Class Libraries
NIOFSDirectory Constructor
NIOFSDirectory Class See Also Send Feedback
Initializes a new instance of the NIOFSDirectory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NIOFSDirectory()
Visual Basic
Public Sub New
Visual C++
public:
NIOFSDirectory()

See Also

NIOFSDirectory Class
NIOFSDirectory Overload
Lucene.Net.Store Namespace


NIOFSDirectory Constructor (DirectoryInfo, LockFactory)

[image]

Lucene.Net Class Libraries
NIOFSDirectory Constructor (DirectoryInfo, LockFactory)
NIOFSDirectory Class See Also Send Feedback
Initializes a new instance of the NIOFSDirectory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NIOFSDirectory(
    DirectoryInfo dir,
    LockFactory lockFactory
)
Visual Basic
Public Sub New ( _
    dir As DirectoryInfo, _
    lockFactory As LockFactory _
)
Visual C++
public:
NIOFSDirectory(
    DirectoryInfo^ dir,
    LockFactory^ lockFactory
)

Parameters

dir
Type: System.IO..::..DirectoryInfo

[Missing <param name="dir"/> documentation for "M:Lucene.Net.Store.NIOFSDirectory.#ctor(System.IO.DirectoryInfo,Lucene.Net.Store.LockFactory)"]

lockFactory
Type: Lucene.Net.Store..::..LockFactory

[Missing <param name="lockFactory"/> documentation for "M:Lucene.Net.Store.NIOFSDirectory.#ctor(System.IO.DirectoryInfo,Lucene.Net.Store.LockFactory)"]

See Also

NIOFSDirectory Class
NIOFSDirectory Overload
Lucene.Net.Store Namespace


NIOFSDirectory Fields

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory Fields
NIOFSDirectory Class See Also Send Feedback

The NIOFSDirectory type exposes the following members.

Fields

 | Name | Description
Protected field | directory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

See Also

NIOFSDirectory Class
Lucene.Net.Store Namespace


NIOFSDirectory Methods

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory Methods
NIOFSDirectory Class See Also Send Feedback

The NIOFSDirectory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations. (Inherited from FSDirectory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. In 3.0 this method will become abstract. (Inherited from FSDirectory.)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | .NET (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory()()()() | (Inherited from FSDirectory.)
Public method | GetFile | Obsolete. (Inherited from FSDirectory.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Public method | GetReadChunkSize | The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}. (Inherited from FSDirectory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}. (Inherited from FSDirectory.)
Public method | List | Obsolete. (Inherited from FSDirectory.)
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract. (Inherited from FSDirectory.)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. Warning: This is not atomic. (Inherited from FSDirectory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SetReadChunkSize | Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE}; This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size. Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory. NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size. (Inherited from FSDirectory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)

See Also

NIOFSDirectory Class
Lucene.Net.Store Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory..::..OpenInput Method
NIOFSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. In 3.0 this method will become abstract. (Inherited from FSDirectory.)

See Also

NIOFSDirectory Class
NIOFSDirectory Members
Lucene.Net.Store Namespace


NIOFSDirectory Properties

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory Properties
NIOFSDirectory Class See Also Send Feedback

The NIOFSDirectory type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

NIOFSDirectory Class
Lucene.Net.Store Namespace


NIOFSDirectory.NIOFSIndexInput Class

[image]

Lucene.Net Class Libraries
NIOFSDirectory..::..NIOFSIndexInput Class
NIOFSDirectory Class Members See Also Send Feedback
Not implemented. Waiting for volunteers.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NIOFSIndexInput
Visual Basic
Public Class NIOFSIndexInput
Visual C++
public ref class NIOFSIndexInput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..NIOFSDirectory..::..NIOFSIndexInput

See Also

NIOFSDirectory..::..NIOFSIndexInput Members
Lucene.Net.Store Namespace


NIOFSDirectory.NIOFSIndexInput Members

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory..::..NIOFSIndexInput Members
NIOFSDirectory..::..NIOFSIndexInput Class Constructors Methods See Also Send Feedback

Not implemented. Waiting for volunteers.

The NIOFSDirectory..::..NIOFSIndexInput type exposes the following members.

Constructors

 | Name | Description
Public method | NIOFSDirectory..::..NIOFSIndexInput | Initializes a new instance of the NIOFSDirectory..::..NIOFSIndexInput class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NIOFSDirectory..::..NIOFSIndexInput Class
Lucene.Net.Store Namespace


NIOFSDirectory.NIOFSIndexInput Constructor

[image]

Lucene.Net Class Libraries
NIOFSDirectory..::..NIOFSIndexInput Constructor
NIOFSDirectory..::..NIOFSIndexInput Class See Also Send Feedback
Initializes a new instance of the NIOFSDirectory..::..NIOFSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NIOFSIndexInput()
Visual Basic
Public Sub New
Visual C++
public:
NIOFSIndexInput()

See Also

NIOFSDirectory..::..NIOFSIndexInput Class
Lucene.Net.Store Namespace


NIOFSDirectory.NIOFSIndexInput Methods

[image] [image]

Lucene.Net Class Libraries
NIOFSDirectory..::..NIOFSIndexInput Methods
NIOFSDirectory..::..NIOFSIndexInput Class See Also Send Feedback

The NIOFSDirectory..::..NIOFSIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NIOFSDirectory..::..NIOFSIndexInput Class
Lucene.Net.Store Namespace


NoLockFactory Class

[image]

Lucene.Net Class Libraries
NoLockFactory Class
Members See Also Send Feedback
Use this {@link LockFactory} to disable locking entirely. This LockFactory is used when you call {@link FSDirectory#setDisableLocks}. Only one instance of this lock is created. You should call {@link #GetNoLockFactory()} to get the instance.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class NoLockFactory : LockFactory
Visual Basic
Public Class NoLockFactory _
    Inherits LockFactory
Visual C++
public ref class NoLockFactory : public LockFactory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..NoLockFactory

See Also

NoLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..LockFactory


NoLockFactory Members

[image] [image]

Lucene.Net Class Libraries
NoLockFactory Members
NoLockFactory Class Constructors Methods Fields See Also Send Feedback

The NoLockFactory type exposes the following members.

Constructors

 | Name | Description
Public method | NoLockFactory | Initializes a new instance of the NoLockFactory class

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
 | GetNoLockFactory |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


NoLockFactory Constructor

[image]

Lucene.Net Class Libraries
NoLockFactory Constructor
NoLockFactory Class See Also Send Feedback
Initializes a new instance of the NoLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NoLockFactory()
Visual Basic
Public Sub New
Visual C++
public:
NoLockFactory()

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


NoLockFactory Fields

[image] [image]

Lucene.Net Class Libraries
NoLockFactory Fields
NoLockFactory Class See Also Send Feedback

The NoLockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


NoLockFactory Methods

[image] [image]

Lucene.Net Class Libraries
NoLockFactory Methods
NoLockFactory Class See Also Send Feedback

The NoLockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
 | GetNoLockFactory |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
NoLockFactory..::..ClearLock Method
NoLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.NoLockFactory.ClearLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ClearLock(
    string lockName
)
Visual Basic
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.NoLockFactory.ClearLock(System.String)"]

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


GetNoLockFactory Method

[image]

Lucene.Net Class Libraries
NoLockFactory..::..GetNoLockFactory Method
NoLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.NoLockFactory.GetNoLockFactory"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static NoLockFactory GetNoLockFactory()
Visual Basic
Public Shared Function GetNoLockFactory As NoLockFactory
Visual C++
public:
static NoLockFactory^ GetNoLockFactory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.NoLockFactory.GetNoLockFactory"]

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
NoLockFactory..::..MakeLock Method
NoLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.NoLockFactory.MakeLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Lock MakeLock(
    string lockName
)
Visual Basic
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.NoLockFactory.MakeLock(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.NoLockFactory.MakeLock(System.String)"]

See Also

NoLockFactory Class
Lucene.Net.Store Namespace


NoSuchDirectoryException Class

[image]

Lucene.Net Class Libraries
NoSuchDirectoryException Class
Members See Also Send Feedback
This exception is thrown when you try to list a non-existent directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class NoSuchDirectoryException : FileNotFoundException
Visual Basic
<SerializableAttribute> _
Public Class NoSuchDirectoryException _
    Inherits FileNotFoundException
Visual C++
[SerializableAttribute]
public ref class NoSuchDirectoryException : public FileNotFoundException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
System.IO..::..FileNotFoundException
Lucene.Net.Store..::..NoSuchDirectoryException

See Also

NoSuchDirectoryException Members
Lucene.Net.Store Namespace


NoSuchDirectoryException Members

[image] [image]

Lucene.Net Class Libraries
NoSuchDirectoryException Members
NoSuchDirectoryException Class Constructors Methods Properties Events See Also Send Feedback

The NoSuchDirectoryException type exposes the following members.

Constructors

 | Name | Description
Public method | NoSuchDirectoryException | Initializes a new instance of the NoSuchDirectoryException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the file name and additional exception information. (Inherited from FileNotFoundException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified name of this exception and possibly the error message, the name of the inner exception, and the stack trace. (Inherited from FileNotFoundException.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FileName | Gets the name of the file that cannot be found. (Inherited from FileNotFoundException.)
Public property | FusionLog | Gets the log file that describes why loading of an assembly failed. (Inherited from FileNotFoundException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message that explains the reason for the exception. (Inherited from FileNotFoundException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NoSuchDirectoryException Class
Lucene.Net.Store Namespace


NoSuchDirectoryException Constructor

[image]

Lucene.Net Class Libraries
NoSuchDirectoryException Constructor
NoSuchDirectoryException Class See Also Send Feedback
Initializes a new instance of the NoSuchDirectoryException class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public NoSuchDirectoryException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
NoSuchDirectoryException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lucene.Net.Store.NoSuchDirectoryException.#ctor(System.String)"]

See Also

NoSuchDirectoryException Class
Lucene.Net.Store Namespace


NoSuchDirectoryException Methods

[image] [image]

Lucene.Net Class Libraries
NoSuchDirectoryException Methods
NoSuchDirectoryException Class See Also Send Feedback

The NoSuchDirectoryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the file name and additional exception information. (Inherited from FileNotFoundException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified name of this exception and possibly the error message, the name of the inner exception, and the stack trace. (Inherited from FileNotFoundException.)

See Also

NoSuchDirectoryException Class
Lucene.Net.Store Namespace


NoSuchDirectoryException Properties

[image] [image]

Lucene.Net Class Libraries
NoSuchDirectoryException Properties
NoSuchDirectoryException Class See Also Send Feedback

The NoSuchDirectoryException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FileName | Gets the name of the file that cannot be found. (Inherited from FileNotFoundException.)
Public property | FusionLog | Gets the log file that describes why loading of an assembly failed. (Inherited from FileNotFoundException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message that explains the reason for the exception. (Inherited from FileNotFoundException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoSuchDirectoryException Class
Lucene.Net.Store Namespace


NoSuchDirectoryException Events

[image] [image]

Lucene.Net Class Libraries
NoSuchDirectoryException Events
NoSuchDirectoryException Class See Also Send Feedback

The NoSuchDirectoryException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NoSuchDirectoryException Class
Lucene.Net.Store Namespace


RAMDirectory Class

[image]

Lucene.Net Class Libraries
RAMDirectory Class
Members See Also Send Feedback
A memory-resident {@link Directory} implementation. Locking implementation is by default the {@link SingleInstanceLockFactory} but can be changed with {@link #setLockFactory}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class RAMDirectory : Directory
Visual Basic
<SerializableAttribute> _
Public Class RAMDirectory _
    Inherits Directory
Visual C++
[SerializableAttribute]
public ref class RAMDirectory : public Directory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..RAMDirectory

See Also

RAMDirectory Members
Lucene.Net.Store Namespace


RAMDirectory Members

[image] [image]

Lucene.Net Class Libraries
RAMDirectory Members
RAMDirectory Class Constructors Methods Fields Properties See Also Send Feedback

The RAMDirectory type exposes the following members.

Constructors

Name Description
Public method RAMDirectory()()()()
Constructs an empty {@link Directory}.
Public method RAMDirectory(FileInfo) Obsolete.
Creates a new
CopyC#
RAMDirectory
 instance from the {@link FSDirectory}.
Public method RAMDirectory(String) Obsolete.
Creates a new
CopyC#
RAMDirectory
 instance from the {@link FSDirectory}.
Public method RAMDirectory(Directory)
Creates a new
CopyC#
RAMDirectory
 instance from a different
CopyC#
Directory
 implementation. This can be used to load a disk-based index into memory.

This should be used only with indices that can fit into memory.

Note that the resulting

CopyC#
RAMDirectory
instance is fully independent from the original
CopyC#
Directory
 (it is a complete copy). Any subsequent changes to the original
CopyC#
Directory
 will not be visible in the
CopyC#
RAMDirectory
 instance.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations, releasing associated memory. (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file. (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff the named file exists in this directory. (Overrides Directory..::..FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory..::..FileLength(String).)
Public method | FileModified | Returns the time the named file was last modified. (Overrides Directory..::..FileModified(String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete. (Overrides Directory..::..List()()()().)
Public method | ListAll | (Overrides Directory..::..ListAll()()()().)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file. (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}. (Inherited from Directory.)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. (Overrides Directory..::..RenameFile(String, String).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SizeInBytes | Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory..::..TouchFile(String).)

Fields

 | Name | Description
Protected field | fileMap |
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | sizeInBytes |

Properties

 | Name | Description
Public property | fileMap_ForNUnit |
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | sizeInBytes_ForNUnitTest |

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


RAMDirectory Constructor

[image] [image]

Lucene.Net Class Libraries
RAMDirectory Constructor
RAMDirectory Class See Also Send Feedback

Overload List

Name Description
Public method RAMDirectory()()()()
Constructs an empty {@link Directory}.
Public method RAMDirectory(FileInfo) Obsolete.
Creates a new
CopyC#
RAMDirectory
 instance from the {@link FSDirectory}.
Public method RAMDirectory(String) Obsolete.
Creates a new
CopyC#
RAMDirectory
 instance from the {@link FSDirectory}.
Public method RAMDirectory(Directory)
Creates a new
CopyC#
RAMDirectory
 instance from a different
CopyC#
Directory
 implementation. This can be used to load a disk-based index into memory.

This should be used only with indices that can fit into memory.

Note that the resulting

CopyC#
RAMDirectory
instance is fully independent from the original
CopyC#
Directory
 (it is a complete copy). Any subsequent changes to the original
CopyC#
Directory
 will not be visible in the
CopyC#
RAMDirectory
 instance.

See Also

RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace


RAMDirectory Constructor

[image]

Lucene.Net Class Libraries
RAMDirectory Constructor
RAMDirectory Class See Also Send Feedback
Constructs an empty {@link Directory}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMDirectory()
Visual Basic
Public Sub New
Visual C++
public:
RAMDirectory()

See Also

RAMDirectory Class
RAMDirectory Overload
Lucene.Net.Store Namespace


RAMDirectory Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
RAMDirectory Constructor (FileInfo)
RAMDirectory Class See Also Send Feedback
Creates a new
CopyC#
RAMDirectory
 instance from the {@link FSDirectory}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use RAMDirectory(Directory) instead")]
public RAMDirectory(
    FileInfo dir
)
Visual Basic
<ObsoleteAttribute("Use RAMDirectory(Directory) instead")> _
Public Sub New ( _
    dir As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use RAMDirectory(Directory) instead")]
public:
RAMDirectory(
    FileInfo^ dir
)

Parameters

dir
Type: System.IO..::..FileInfo
a
CopyC#
File
 specifying the index directory

See Also

RAMDirectory Class
RAMDirectory Overload
Lucene.Net.Store Namespace
RAMDirectory..::..RAMDirectory(Directory)


RAMDirectory Constructor (String)

[image]

Lucene.Net Class Libraries
RAMDirectory Constructor (String)
RAMDirectory Class See Also Send Feedback
Creates a new
CopyC#
RAMDirectory
 instance from the {@link FSDirectory}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use RAMDirectory(Directory) instead")]
public RAMDirectory(
    string dir
)
Visual Basic
<ObsoleteAttribute("Use RAMDirectory(Directory) instead")> _
Public Sub New ( _
    dir As String _
)
Visual C++
[ObsoleteAttribute(L"Use RAMDirectory(Directory) instead")]
public:
RAMDirectory(
    String^ dir
)

Parameters

dir
Type: System..::..String
a
CopyC#
String
 specifying the full index directory path

See Also

RAMDirectory Class
RAMDirectory Overload
Lucene.Net.Store Namespace
RAMDirectory..::..RAMDirectory(Directory)


RAMDirectory Constructor (Directory)

[image]

Lucene.Net Class Libraries
RAMDirectory Constructor (Directory)
RAMDirectory Class See Also Send Feedback
Creates a new
CopyC#
RAMDirectory
 instance from a different
CopyC#
Directory
 implementation. This can be used to load a disk-based index into memory.

This should be used only with indices that can fit into memory.

Note that the resulting

CopyC#
RAMDirectory
instance is fully independent from the original
CopyC#
Directory
 (it is a complete copy). Any subsequent changes to the original
CopyC#
Directory
 will not be visible in the
CopyC#
RAMDirectory
 instance.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMDirectory(
    Directory dir
)
Visual Basic
Public Sub New ( _
    dir As Directory _
)
Visual C++
public:
RAMDirectory(
    Directory^ dir
)

Parameters

dir
Type: Lucene.Net.Store..::..Directory
a
CopyC#
Directory
 value

Exceptions

Exception | Condition
[!:IOException] | if an error occurs

See Also

RAMDirectory Class
RAMDirectory Overload
Lucene.Net.Store Namespace


RAMDirectory Fields

[image] [image]

Lucene.Net Class Libraries
RAMDirectory Fields
RAMDirectory Class See Also Send Feedback

The RAMDirectory type exposes the following members.

Fields

 | Name | Description
Protected field | fileMap |
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)
Protected field | sizeInBytes |

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


fileMap Field

[image]

Lucene.Net Class Libraries
RAMDirectory..::..fileMap Field
RAMDirectory Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.RAMDirectory.fileMap"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Hashtable fileMap
Visual Basic
Protected Friend fileMap As Hashtable
Visual C++
protected public:
Hashtable^ fileMap

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


sizeInBytes Field

[image]

Lucene.Net Class Libraries
RAMDirectory..::..sizeInBytes Field
RAMDirectory Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.RAMDirectory.sizeInBytes"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal long sizeInBytes
Visual Basic
Protected Friend sizeInBytes As Long
Visual C++
protected public:
long long sizeInBytes

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


RAMDirectory Methods

[image] [image]

Lucene.Net Class Libraries
RAMDirectory Methods
RAMDirectory Class See Also Send Feedback

The RAMDirectory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations, releasing associated memory. (Overrides Directory..::..Close()()()().)
Public method | CreateOutput | Creates a new, empty file in the directory with the given name. Returns a stream writing this file. (Overrides Directory..::..CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Overrides Directory..::..DeleteFile(String).)
Public method | Dispose | .NET (Overrides Directory..::..Dispose()()()().)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff the named file exists in this directory. (Overrides Directory..::..FileExists(String).)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Overrides Directory..::..FileLength(String).)
Public method | FileModified | Returns the time the named file was last modified. (Overrides Directory..::..FileModified(String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | Return a string identifier that uniquely differentiates this Directory instance from other Directory instances. This ID should be the same if two Directory instances (even in different JVMs and/or on different machines) are considered "the same index". This is how locking "scopes" to the right index. (Inherited from Directory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Obsolete. (Overrides Directory..::..List()()()().)
Public method | ListAll | (Overrides Directory..::..ListAll()()()().)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | Returns a stream reading an existing file. (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}. (Inherited from Directory.)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. (Overrides Directory..::..RenameFile(String, String).)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SizeInBytes | Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.
Public method | Sync | Ensure that any writes to this file are moved to stable storage. Lucene uses this to properly commit changes to the index, to prevent a machine/OS crash from corrupting the index. (Inherited from Directory.)
Public method | ToString | (Inherited from Directory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Overrides Directory..::..TouchFile(String).)

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..Close Method
RAMDirectory Class See Also Send Feedback
Closes the store to future operations, releasing associated memory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..CreateOutput Method
RAMDirectory Class See Also Send Feedback
Creates a new, empty file in the directory with the given name. Returns a stream writing this file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.CreateOutput(System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


DeleteFile Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..DeleteFile Method
RAMDirectory Class See Also Send Feedback
Removes an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void DeleteFile(
    string name
)
Visual Basic
Public Overrides Sub DeleteFile ( _
    name As String _
)
Visual C++
public:
virtual void DeleteFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.DeleteFile(System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


Dispose Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..Dispose Method
RAMDirectory Class See Also Send Feedback
.NET

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::..Dispose()()()()

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


FileExists Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..FileExists Method
RAMDirectory Class See Also Send Feedback
Returns true iff the named file exists in this directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool FileExists(
    string name
)
Visual Basic
Public Overrides Function FileExists ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool FileExists(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.FileExists(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.FileExists(System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


FileLength Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..FileLength Method
RAMDirectory Class See Also Send Feedback
Returns the length in bytes of a file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileLength(
    string name
)
Visual Basic
Public Overrides Function FileLength ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileLength(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.FileLength(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.FileLength(System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


FileModified Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..FileModified Method
RAMDirectory Class See Also Send Feedback
Returns the time the named file was last modified.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long FileModified(
    string name
)
Visual Basic
Public Overrides Function FileModified ( _
    name As String _
) As Long
Visual C++
public:
virtual long long FileModified(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.FileModified(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.FileModified(System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


List Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..List Method
RAMDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMDirectory.List"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public override string[] List()
Visual Basic
<ObsoleteAttribute("Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")> _
Public Overrides Function List As String()
Visual C++
[ObsoleteAttribute(L"Lucene.Net-2.9.1. This method overrides obsolete member Lucene.Net.Store.Directory.List()")]
public:
virtual array<String^>^ List() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.List"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


ListAll Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..ListAll Method
RAMDirectory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMDirectory.ListAll"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string[] ListAll()
Visual Basic
Public Overrides Function ListAll As String()
Visual C++
public:
virtual array<String^>^ ListAll() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.ListAll"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
RAMDirectory..::..OpenInput Method
RAMDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | Returns a stream reading an existing file. (Overrides Directory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | Returns a stream reading an existing file, with the specified read buffer size. The particular Directory implementation may ignore the buffer size. Currently the only Directory implementations that respect this parameter are {@link FSDirectory} and {@link Lucene.Net.Index.CompoundFileReader}. (Inherited from Directory.)

See Also

RAMDirectory Class
RAMDirectory Members
Lucene.Net.Store Namespace


OpenInput Method (String)

[image]

Lucene.Net Class Libraries
RAMDirectory..::..OpenInput Method (String)
RAMDirectory Class See Also Send Feedback
Returns a stream reading an existing file.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string name
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.OpenInput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.OpenInput(System.String)"]

See Also

RAMDirectory Class
OpenInput Overload
Lucene.Net.Store Namespace


RenameFile Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..RenameFile Method
RAMDirectory Class See Also Send Feedback
Renames an existing file in the directory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute]
public override void RenameFile(
    string from,
    string to
)
Visual Basic
<ObsoleteAttribute> _
Public Overrides Sub RenameFile ( _
    from As String, _
    to As String _
)
Visual C++
[ObsoleteAttribute]
public:
virtual void RenameFile(
    String^ from,
    String^ to
) override

Parameters

from
Type: System..::..String

[Missing <param name="from"/> documentation for "M:Lucene.Net.Store.RAMDirectory.RenameFile(System.String,System.String)"]

to
Type: System..::..String

[Missing <param name="to"/> documentation for "M:Lucene.Net.Store.RAMDirectory.RenameFile(System.String,System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


SizeInBytes Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..SizeInBytes Method
RAMDirectory Class See Also Send Feedback
Return total size in bytes of all files in this directory. This is currently quantized to RAMOutputStream.BUFFER_SIZE.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long SizeInBytes()
Visual Basic
Public Function SizeInBytes As Long
Visual C++
public:
long long SizeInBytes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMDirectory.SizeInBytes"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


TouchFile Method

[image]

Lucene.Net Class Libraries
RAMDirectory..::..TouchFile Method
RAMDirectory Class See Also Send Feedback
Set the modified time of an existing file to now.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void TouchFile(
    string name
)
Visual Basic
Public Overrides Sub TouchFile ( _
    name As String _
)
Visual C++
public:
virtual void TouchFile(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.RAMDirectory.TouchFile(System.String)"]

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


RAMDirectory Properties

[image] [image]

Lucene.Net Class Libraries
RAMDirectory Properties
RAMDirectory Class See Also Send Feedback

The RAMDirectory type exposes the following members.

Properties

 | Name | Description
Public property | fileMap_ForNUnit |
Public property | isOpen_ForNUnit | (Inherited from Directory.)
Public property | sizeInBytes_ForNUnitTest |

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


fileMap_ForNUnit Property

[image]

Lucene.Net Class Libraries
RAMDirectory..::..fileMap_ForNUnit Property
RAMDirectory Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.RAMDirectory.fileMap_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Hashtable fileMap_ForNUnit { get; }
Visual Basic
Public ReadOnly Property fileMap_ForNUnit As Hashtable
    Get
Visual C++
public:
property Hashtable^ fileMap_ForNUnit {
    Hashtable^ get ();
}

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


sizeInBytes_ForNUnitTest Property

[image]

Lucene.Net Class Libraries
RAMDirectory..::..sizeInBytes_ForNUnitTest Property
RAMDirectory Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.RAMDirectory.sizeInBytes_ForNUnitTest"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long sizeInBytes_ForNUnitTest { get; set; }
Visual Basic
Public Property sizeInBytes_ForNUnitTest As Long
    Get
    Set
Visual C++
public:
property long long sizeInBytes_ForNUnitTest {
    long long get ();
    void set (long long value);
}

See Also

RAMDirectory Class
Lucene.Net.Store Namespace


RAMFile Class

[image]

Lucene.Net Class Libraries
RAMFile Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.RAMFile"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class RAMFile
Visual Basic
<SerializableAttribute> _
Public Class RAMFile
Visual C++
[SerializableAttribute]
public ref class RAMFile

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..RAMFile

See Also

RAMFile Members
Lucene.Net.Store Namespace


RAMFile Members

[image] [image]

Lucene.Net Class Libraries
RAMFile Members
RAMFile Class Constructors Methods Fields Properties See Also Send Feedback

The RAMFile type exposes the following members.

Constructors

 | Name | Description
Public method | RAMFile()()()() | Initializes a new instance of the RAMFile class
Public method | RAMFile(RAMDirectory) | Initializes a new instance of the RAMFile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBuffer |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength |
Public method | GetSizeInBytes |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewBuffer | Expert: allocate a new buffer. Subclasses can allocate differently.
Public method | NumBuffers |
Public method | SetLength |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffers |

Properties

 | Name | Description
Public property | directory_ForNUnit |
Public property | length_ForNUnit |
Public property | sizeInBytes_ForNUnit |

See Also

RAMFile Class
Lucene.Net.Store Namespace


RAMFile Constructor

[image] [image]

Lucene.Net Class Libraries
RAMFile Constructor
RAMFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RAMFile()()()() | Initializes a new instance of the RAMFile class
Public method | RAMFile(RAMDirectory) | Initializes a new instance of the RAMFile class

See Also

RAMFile Class
RAMFile Members
Lucene.Net.Store Namespace


RAMFile Constructor

[image]

Lucene.Net Class Libraries
RAMFile Constructor
RAMFile Class See Also Send Feedback
Initializes a new instance of the RAMFile class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMFile()
Visual Basic
Public Sub New
Visual C++
public:
RAMFile()

See Also

RAMFile Class
RAMFile Overload
Lucene.Net.Store Namespace


RAMFile Constructor (RAMDirectory)

[image]

Lucene.Net Class Libraries
RAMFile Constructor (RAMDirectory)
RAMFile Class See Also Send Feedback
Initializes a new instance of the RAMFile class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMFile(
    RAMDirectory directory
)
Visual Basic
Public Sub New ( _
    directory As RAMDirectory _
)
Visual C++
public:
RAMFile(
    RAMDirectory^ directory
)

Parameters

directory
Type: Lucene.Net.Store..::..RAMDirectory

[Missing <param name="directory"/> documentation for "M:Lucene.Net.Store.RAMFile.#ctor(Lucene.Net.Store.RAMDirectory)"]

See Also

RAMFile Class
RAMFile Overload
Lucene.Net.Store Namespace


RAMFile Fields

[image] [image]

Lucene.Net Class Libraries
RAMFile Fields
RAMFile Class See Also Send Feedback

The RAMFile type exposes the following members.

Fields

 | Name | Description
Protected field | buffers |

See Also

RAMFile Class
Lucene.Net.Store Namespace


buffers Field

[image]

Lucene.Net Class Libraries
RAMFile..::..buffers Field
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.RAMFile.buffers"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected ArrayList buffers
Visual Basic
Protected buffers As ArrayList
Visual C++
protected:
ArrayList^ buffers

See Also

RAMFile Class
Lucene.Net.Store Namespace


RAMFile Methods

[image] [image]

Lucene.Net Class Libraries
RAMFile Methods
RAMFile Class See Also Send Feedback

The RAMFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBuffer |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength |
Public method | GetSizeInBytes |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewBuffer | Expert: allocate a new buffer. Subclasses can allocate differently.
Public method | NumBuffers |
Public method | SetLength |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RAMFile Class
Lucene.Net.Store Namespace


GetBuffer Method

[image]

Lucene.Net Class Libraries
RAMFile..::..GetBuffer Method
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMFile.GetBuffer(System.Int32)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] GetBuffer(
    int index
)
Visual Basic
Public Function GetBuffer ( _
    index As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetBuffer(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Store.RAMFile.GetBuffer(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMFile.GetBuffer(System.Int32)"]

See Also

RAMFile Class
Lucene.Net.Store Namespace


GetLength Method

[image]

Lucene.Net Class Libraries
RAMFile..::..GetLength Method
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMFile.GetLength"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetLength()
Visual Basic
Public Overridable Function GetLength As Long
Visual C++
public:
virtual long long GetLength()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMFile.GetLength"]

See Also

RAMFile Class
Lucene.Net.Store Namespace


GetSizeInBytes Method

[image]

Lucene.Net Class Libraries
RAMFile..::..GetSizeInBytes Method
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMFile.GetSizeInBytes"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long GetSizeInBytes()
Visual Basic
Public Overridable Function GetSizeInBytes As Long
Visual C++
public:
virtual long long GetSizeInBytes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMFile.GetSizeInBytes"]

See Also

RAMFile Class
Lucene.Net.Store Namespace


NewBuffer Method

[image]

Lucene.Net Class Libraries
RAMFile..::..NewBuffer Method
RAMFile Class See Also Send Feedback
Expert: allocate a new buffer. Subclasses can allocate differently.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual byte[] NewBuffer(
    int size
)
Visual Basic
Public Overridable Function NewBuffer ( _
    size As Integer _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ NewBuffer(
    int size
)

Parameters

size
Type: System..::..Int32
size of allocated buffer.

Return Value

allocated buffer.

See Also

RAMFile Class
Lucene.Net.Store Namespace


NumBuffers Method

[image]

Lucene.Net Class Libraries
RAMFile..::..NumBuffers Method
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMFile.NumBuffers"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int NumBuffers()
Visual Basic
Public Function NumBuffers As Integer
Visual C++
public:
int NumBuffers()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMFile.NumBuffers"]

See Also

RAMFile Class
Lucene.Net.Store Namespace


SetLength Method

[image]

Lucene.Net Class Libraries
RAMFile..::..SetLength Method
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMFile.SetLength(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetLength(
    long length
)
Visual Basic
Public Overridable Sub SetLength ( _
    length As Long _
)
Visual C++
public:
virtual void SetLength(
    long long length
)

Parameters

length
Type: System..::..Int64

[Missing <param name="length"/> documentation for "M:Lucene.Net.Store.RAMFile.SetLength(System.Int64)"]

See Also

RAMFile Class
Lucene.Net.Store Namespace


RAMFile Properties

[image] [image]

Lucene.Net Class Libraries
RAMFile Properties
RAMFile Class See Also Send Feedback

The RAMFile type exposes the following members.

Properties

 | Name | Description
Public property | directory_ForNUnit |
Public property | length_ForNUnit |
Public property | sizeInBytes_ForNUnit |

See Also

RAMFile Class
Lucene.Net.Store Namespace


directory_ForNUnit Property

[image]

Lucene.Net Class Libraries
RAMFile..::..directory_ForNUnit Property
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.RAMFile.directory_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMDirectory directory_ForNUnit { get; set; }
Visual Basic
Public Property directory_ForNUnit As RAMDirectory
    Get
    Set
Visual C++
public:
property RAMDirectory^ directory_ForNUnit {
    RAMDirectory^ get ();
    void set (RAMDirectory^ value);
}

See Also

RAMFile Class
Lucene.Net.Store Namespace


length_ForNUnit Property

[image]

Lucene.Net Class Libraries
RAMFile..::..length_ForNUnit Property
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.RAMFile.length_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long length_ForNUnit { get; }
Visual Basic
Public ReadOnly Property length_ForNUnit As Long
    Get
Visual C++
public:
property long long length_ForNUnit {
    long long get ();
}

See Also

RAMFile Class
Lucene.Net.Store Namespace


sizeInBytes_ForNUnit Property

[image]

Lucene.Net Class Libraries
RAMFile..::..sizeInBytes_ForNUnit Property
RAMFile Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.RAMFile.sizeInBytes_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long sizeInBytes_ForNUnit { get; }
Visual Basic
Public ReadOnly Property sizeInBytes_ForNUnit As Long
    Get
Visual C++
public:
property long long sizeInBytes_ForNUnit {
    long long get ();
}

See Also

RAMFile Class
Lucene.Net.Store Namespace


RAMInputStream Class

[image]

Lucene.Net Class Libraries
RAMInputStream Class
Members See Also Send Feedback
A memory-resident {@link IndexInput} implementation.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class RAMInputStream : IndexInput,
    ICloneable
Visual Basic
Public Class RAMInputStream _
    Inherits IndexInput _
    Implements ICloneable
Visual C++
public ref class RAMInputStream : public IndexInput,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Store..::..RAMInputStream

See Also

RAMInputStream Members
Lucene.Net.Store Namespace


RAMInputStream Members

[image] [image]

Lucene.Net Class Libraries
RAMInputStream Members
RAMInputStream Class Constructors Methods See Also Send Feedback

The RAMInputStream type exposes the following members.

Constructors

 | Name | Description
Public method | RAMInputStream | Initializes a new instance of the RAMInputStream class

Methods

 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


RAMInputStream Constructor

[image]

Lucene.Net Class Libraries
RAMInputStream Constructor
RAMInputStream Class See Also Send Feedback
Initializes a new instance of the RAMInputStream class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMInputStream(
    RAMFile f
)
Visual Basic
Public Sub New ( _
    f As RAMFile _
)
Visual C++
public:
RAMInputStream(
    RAMFile^ f
)

Parameters

f
Type: Lucene.Net.Store..::..RAMFile

[Missing <param name="f"/> documentation for "M:Lucene.Net.Store.RAMInputStream.#ctor(Lucene.Net.Store.RAMFile)"]

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


RAMInputStream Methods

[image] [image]

Lucene.Net Class Libraries
RAMInputStream Methods
RAMInputStream Class See Also Send Feedback

The RAMInputStream type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a clone of this stream. Clones of a stream access the same data, and are positioned at the same point as the stream they were cloned from. Expert: Subclasses must ensure that clones may be positioned at different points in the input from each other and from the stream they were cloned from. (Inherited from IndexInput.)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilePointer | (Overrides IndexInput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | (Overrides IndexInput..::..ReadByte()()()().)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Overrides IndexInput..::..Seek(Int64).)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
RAMInputStream..::..Close Method
RAMInputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMInputStream.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
RAMInputStream..::..GetFilePointer Method
RAMInputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMInputStream.GetFilePointer"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMInputStream.GetFilePointer"]

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


Length Method

[image]

Lucene.Net Class Libraries
RAMInputStream..::..Length Method
RAMInputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMInputStream.Length"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMInputStream.Length"]

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


ReadByte Method

[image]

Lucene.Net Class Libraries
RAMInputStream..::..ReadByte Method
RAMInputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMInputStream.ReadByte"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override byte ReadByte()
Visual Basic
Public Overrides Function ReadByte As Byte
Visual C++
public:
virtual unsigned char ReadByte() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMInputStream.ReadByte"]

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
RAMInputStream..::..ReadBytes Method
RAMInputStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexInput..::..ReadBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | Reads a specified number of bytes into an array at the specified offset with control over whether the read should be buffered (callers who have their own buffer should pass in "false" for useBuffer). Currently only {@link BufferedIndexInput} respects this parameter. (Inherited from IndexInput.)

See Also

RAMInputStream Class
RAMInputStream Members
Lucene.Net.Store Namespace


ReadBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
RAMInputStream..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32)
RAMInputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMInputStream.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub ReadBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.RAMInputStream.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.RAMInputStream.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Store.RAMInputStream.ReadBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

RAMInputStream Class
ReadBytes Overload
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
RAMInputStream..::..Seek Method
RAMInputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMInputStream.Seek(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.RAMInputStream.Seek(System.Int64)"]

See Also

RAMInputStream Class
Lucene.Net.Store Namespace


RAMOutputStream Class

[image]

Lucene.Net Class Libraries
RAMOutputStream Class
Members See Also Send Feedback
A memory-resident {@link IndexOutput} implementation.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class RAMOutputStream : IndexOutput
Visual Basic
Public Class RAMOutputStream _
    Inherits IndexOutput
Visual C++
public ref class RAMOutputStream : public IndexOutput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexOutput
Lucene.Net.Store..::..RAMOutputStream

See Also

RAMOutputStream Members
Lucene.Net.Store Namespace


RAMOutputStream Members

[image] [image]

Lucene.Net Class Libraries
RAMOutputStream Members
RAMOutputStream Class Constructors Methods Properties See Also Send Feedback

The RAMOutputStream type exposes the following members.

Constructors

 | Name | Description
Public method | RAMOutputStream()()()() | Construct an empty output buffer.
Public method | RAMOutputStream(RAMFile) | Initializes a new instance of the RAMOutputStream class

Methods

 | Name | Description
Public method | Close | (Overrides IndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides IndexOutput..::..Flush()()()().)
Public method | GetFilePointer | (Overrides IndexOutput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets this to an empty buffer.
Public method | Seek | (Overrides IndexOutput..::..Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | SizeInBytes | Returns byte usage of all buffers.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | (Overrides IndexOutput..::..WriteByte(Byte).)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteTo | Copy the current contents of this buffer to the named output.
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

Properties

Name | Description
BUFFER_SIZE_ForNUnit |

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


RAMOutputStream Constructor

[image] [image]

Lucene.Net Class Libraries
RAMOutputStream Constructor
RAMOutputStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RAMOutputStream()()()() | Construct an empty output buffer.
Public method | RAMOutputStream(RAMFile) | Initializes a new instance of the RAMOutputStream class

See Also

RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace


RAMOutputStream Constructor

[image]

Lucene.Net Class Libraries
RAMOutputStream Constructor
RAMOutputStream Class See Also Send Feedback
Construct an empty output buffer.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMOutputStream()
Visual Basic
Public Sub New
Visual C++
public:
RAMOutputStream()

See Also

RAMOutputStream Class
RAMOutputStream Overload
Lucene.Net.Store Namespace


RAMOutputStream Constructor (RAMFile)

[image]

Lucene.Net Class Libraries
RAMOutputStream Constructor (RAMFile)
RAMOutputStream Class See Also Send Feedback
Initializes a new instance of the RAMOutputStream class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RAMOutputStream(
    RAMFile f
)
Visual Basic
Public Sub New ( _
    f As RAMFile _
)
Visual C++
public:
RAMOutputStream(
    RAMFile^ f
)

Parameters

f
Type: Lucene.Net.Store..::..RAMFile

[Missing <param name="f"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.#ctor(Lucene.Net.Store.RAMFile)"]

See Also

RAMOutputStream Class
RAMOutputStream Overload
Lucene.Net.Store Namespace


RAMOutputStream Methods

[image] [image]

Lucene.Net Class Libraries
RAMOutputStream Methods
RAMOutputStream Class See Also Send Feedback

The RAMOutputStream type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides IndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides IndexOutput..::..Flush()()()().)
Public method | GetFilePointer | (Overrides IndexOutput..::..GetFilePointer()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides IndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets this to an empty buffer.
Public method | Seek | (Overrides IndexOutput..::..Seek(Int64).)
Public method | SetLength | Set the file length. By default, this method does nothing (it's optional for a Directory to implement it). But, certain Directory implementations (for (Inherited from IndexOutput.)
Public method | SizeInBytes | Returns byte usage of all buffers.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | (Overrides IndexOutput..::..WriteByte(Byte).)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteTo | Copy the current contents of this buffer to the named output.
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..Close Method
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


Flush Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..Flush Method
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.Flush"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


GetFilePointer Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..GetFilePointer Method
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.GetFilePointer"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long GetFilePointer()
Visual Basic
Public Overrides Function GetFilePointer As Long
Visual C++
public:
virtual long long GetFilePointer() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMOutputStream.GetFilePointer"]

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


Length Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..Length Method
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.Length"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMOutputStream.Length"]

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


Reset Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..Reset Method
RAMOutputStream Class See Also Send Feedback
Resets this to an empty buffer.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..Seek Method
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.Seek(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.Seek(System.Int64)"]

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


SizeInBytes Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..SizeInBytes Method
RAMOutputStream Class See Also Send Feedback
Returns byte usage of all buffers.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long SizeInBytes()
Visual Basic
Public Overridable Function SizeInBytes As Long
Visual C++
public:
virtual long long SizeInBytes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.RAMOutputStream.SizeInBytes"]

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


WriteByte Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..WriteByte Method
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteByte(System.Byte)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void WriteByte(
    byte b
)
Visual Basic
Public Overrides Sub WriteByte ( _
    b As Byte _
)
Visual C++
public:
virtual void WriteByte(
    unsigned char b
) override

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteByte(System.Byte)"]

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


WriteBytes Method

[image] [image]

Lucene.Net Class Libraries
RAMOutputStream..::..WriteBytes Method
RAMOutputStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | (Overrides IndexOutput..::..WriteBytes(array<Byte>[]()[][], Int32, Int32).)

See Also

RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace


WriteBytes Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..WriteBytes Method (array<Byte>[]()[][], Int32, Int32)
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void WriteBytes(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub WriteBytes ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void WriteBytes(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

RAMOutputStream Class
WriteBytes Overload
Lucene.Net.Store Namespace


WriteChars Method

[image] [image]

Lucene.Net Class Libraries
RAMOutputStream..::..WriteChars Method
RAMOutputStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)

See Also

RAMOutputStream Class
RAMOutputStream Members
Lucene.Net.Store Namespace


WriteTo Method

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..WriteTo Method
RAMOutputStream Class See Also Send Feedback
Copy the current contents of this buffer to the named output.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void WriteTo(
    IndexOutput out_Renamed
)
Visual Basic
Public Overridable Sub WriteTo ( _
    out_Renamed As IndexOutput _
)
Visual C++
public:
virtual void WriteTo(
    IndexOutput^ out_Renamed
)

Parameters

out_Renamed
Type: Lucene.Net.Store..::..IndexOutput

[Missing <param name="out_Renamed"/> documentation for "M:Lucene.Net.Store.RAMOutputStream.WriteTo(Lucene.Net.Store.IndexOutput)"]

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


RAMOutputStream Properties

[image] [image]

Lucene.Net Class Libraries
RAMOutputStream Properties
RAMOutputStream Class See Also Send Feedback

The RAMOutputStream type exposes the following members.

Properties

Name | Description
BUFFER_SIZE_ForNUnit |

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


BUFFER_SIZE_ForNUnit Property

[image]

Lucene.Net Class Libraries
RAMOutputStream..::..BUFFER_SIZE_ForNUnit Property
RAMOutputStream Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.RAMOutputStream.BUFFER_SIZE_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int BUFFER_SIZE_ForNUnit { get; }
Visual Basic
Public Shared ReadOnly Property BUFFER_SIZE_ForNUnit As Integer
    Get
Visual C++
public:
static property int BUFFER_SIZE_ForNUnit {
    int get ();
}

See Also

RAMOutputStream Class
Lucene.Net.Store Namespace


SimpleFSDirectory Class

[image]

Lucene.Net Class Libraries
SimpleFSDirectory Class
Members See Also Send Feedback
A straightforward implementation of {@link FSDirectory} using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use {@link NIOFSDirectory} or {@link MMapDirectory} instead.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleFSDirectory : FSDirectory
Visual Basic
Public Class SimpleFSDirectory _
    Inherits FSDirectory
Visual C++
public ref class SimpleFSDirectory : public FSDirectory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..Directory
Lucene.Net.Store..::..FSDirectory
Lucene.Net.Store..::..SimpleFSDirectory

See Also

SimpleFSDirectory Members
Lucene.Net.Store Namespace


SimpleFSDirectory Members

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory Members
SimpleFSDirectory Class Constructors Methods Fields Properties See Also Send Feedback

The SimpleFSDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFSDirectory(DirectoryInfo) | Create a new SimpleFSDirectory for the named location and the default lock factory.
Public method | SimpleFSDirectory(FileInfo) | Obsolete. Create a new SimpleFSDirectory for the named location and the default lock factory.
Public method | SimpleFSDirectory(DirectoryInfo, LockFactory) | Create a new SimpleFSDirectory for the named location.
Public method | SimpleFSDirectory(FileInfo, LockFactory) | Obsolete. Create a new SimpleFSDirectory for the named location.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations. (Inherited from FSDirectory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. (Overrides FSDirectory..::..CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | .NET (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory()()()() | (Inherited from FSDirectory.)
Public method | GetFile | Obsolete. (Inherited from FSDirectory.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Public method | GetReadChunkSize | The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}. (Inherited from FSDirectory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}. (Inherited from FSDirectory.)
Public method | List | Obsolete. (Inherited from FSDirectory.)
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides FSDirectory..::..OpenInput(String, Int32).)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. Warning: This is not atomic. (Inherited from FSDirectory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SetReadChunkSize | Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE}; This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size. Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory. NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size. (Inherited from FSDirectory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)

Fields

 | Name | Description
Protected field | directory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

SimpleFSDirectory Class
Lucene.Net.Store Namespace


SimpleFSDirectory Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory Constructor
SimpleFSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleFSDirectory(DirectoryInfo) | Create a new SimpleFSDirectory for the named location and the default lock factory.
Public method | SimpleFSDirectory(FileInfo) | Obsolete. Create a new SimpleFSDirectory for the named location and the default lock factory.
Public method | SimpleFSDirectory(DirectoryInfo, LockFactory) | Create a new SimpleFSDirectory for the named location.
Public method | SimpleFSDirectory(FileInfo, LockFactory) | Obsolete. Create a new SimpleFSDirectory for the named location.

See Also

SimpleFSDirectory Class
SimpleFSDirectory Members
Lucene.Net.Store Namespace


SimpleFSDirectory Constructor (DirectoryInfo)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory Constructor (DirectoryInfo)
SimpleFSDirectory Class See Also Send Feedback
Create a new SimpleFSDirectory for the named location and the default lock factory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSDirectory(
    DirectoryInfo path
)
Visual Basic
Public Sub New ( _
    path As DirectoryInfo _
)
Visual C++
public:
SimpleFSDirectory(
    DirectoryInfo^ path
)

Parameters

path
Type: System.IO..::..DirectoryInfo
the path of the directory

See Also

SimpleFSDirectory Class
SimpleFSDirectory Overload
Lucene.Net.Store Namespace


SimpleFSDirectory Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory Constructor (FileInfo)
SimpleFSDirectory Class See Also Send Feedback
Create a new SimpleFSDirectory for the named location and the default lock factory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public SimpleFSDirectory(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Sub New ( _
    path As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
SimpleFSDirectory(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo
the path of the directory

See Also

SimpleFSDirectory Class
SimpleFSDirectory Overload
Lucene.Net.Store Namespace


SimpleFSDirectory Constructor (DirectoryInfo, LockFactory)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory Constructor (DirectoryInfo, LockFactory)
SimpleFSDirectory Class See Also Send Feedback
Create a new SimpleFSDirectory for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSDirectory(
    DirectoryInfo path,
    LockFactory lockFactory
)
Visual Basic
Public Sub New ( _
    path As DirectoryInfo, _
    lockFactory As LockFactory _
)
Visual C++
public:
SimpleFSDirectory(
    DirectoryInfo^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System.IO..::..DirectoryInfo
the path of the directory
lockFactory
Type: Lucene.Net.Store..::..LockFactory
the lock factory to use, or null for the default.

See Also

SimpleFSDirectory Class
SimpleFSDirectory Overload
Lucene.Net.Store Namespace


SimpleFSDirectory Constructor (FileInfo, LockFactory)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory Constructor (FileInfo, LockFactory)
SimpleFSDirectory Class See Also Send Feedback
Create a new SimpleFSDirectory for the named location.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public SimpleFSDirectory(
    FileInfo path,
    LockFactory lockFactory
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Sub New ( _
    path As FileInfo, _
    lockFactory As LockFactory _
)
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
SimpleFSDirectory(
    FileInfo^ path,
    LockFactory^ lockFactory
)

Parameters

path
Type: System.IO..::..FileInfo
the path of the directory
lockFactory
Type: Lucene.Net.Store..::..LockFactory
the lock factory to use, or null for the default.

See Also

SimpleFSDirectory Class
SimpleFSDirectory Overload
Lucene.Net.Store Namespace


SimpleFSDirectory Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory Fields
SimpleFSDirectory Class See Also Send Feedback

The SimpleFSDirectory type exposes the following members.

Fields

 | Name | Description
Protected field | directory | The underlying filesystem directory (Inherited from FSDirectory.)
Protected field | isOpen | (Inherited from Directory.)
Protected field | lockFactory | Holds the LockFactory instance (implements locking for this Directory instance). (Inherited from Directory.)

See Also

SimpleFSDirectory Class
Lucene.Net.Store Namespace


SimpleFSDirectory Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory Methods
SimpleFSDirectory Class See Also Send Feedback

The SimpleFSDirectory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | Attempt to clear (forcefully unlock and remove) the specified lock. Only call this at a time when you are certain this lock is no longer in use. (Inherited from Directory.)
Public method | Close | Closes the store to future operations. (Inherited from FSDirectory.)
Public method | CreateOutput | Creates an IndexOutput for the file with the given name. (Overrides FSDirectory..::..CreateOutput(String).)
Public method | DeleteFile | Removes an existing file in the directory. (Inherited from FSDirectory.)
Public method | Dispose | .NET (Inherited from FSDirectory.)
Public method | EnsureOpen | (Inherited from Directory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Returns true iff a file with the given name exists. (Inherited from FSDirectory.)
Public method | FileLength | Returns the length in bytes of a file in the directory. (Inherited from FSDirectory.)
Public method | FileModified(String) | Returns the time the named file was last modified. (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectory()()()() | (Inherited from FSDirectory.)
Public method | GetFile | Obsolete. (Inherited from FSDirectory.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | Get the LockFactory that this Directory instance is using for its locking implementation. Note that this may be null for Directory implementations that provide their own locking implementation. (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Public method | GetReadChunkSize | The maximum number of bytes to read at once from the underlying file during {@link IndexInput#readBytes}. (Inherited from FSDirectory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitOutput | Initializes the directory to create a new file with the given name. This method should be used in {@link #createOutput}. (Inherited from FSDirectory.)
Public method | List | Obsolete. (Inherited from FSDirectory.)
Public method | ListAll()()()() | Lists all files (not subdirectories) in the directory. (Inherited from FSDirectory.)
Public method | MakeLock | Construct a {@link Lock}. (Inherited from Directory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides FSDirectory..::..OpenInput(String, Int32).)
Public method | RenameFile | Obsolete. Renames an existing file in the directory. Warning: This is not atomic. (Inherited from FSDirectory.)
Public method | SetLockFactory | Set the LockFactory that this Directory instance should use for its locking implementation. Each * instance of LockFactory should only be used for one directory (ie, do not share a single instance across multiple Directories). (Inherited from Directory.)
Public method | SetReadChunkSize | Sets the maximum number of bytes read at once from the underlying file during {@link IndexInput#readBytes}. The default value is {@link #DEFAULT_READ_CHUNK_SIZE}; This was introduced due to Sun JVM Bug 6478546, which throws an incorrect OutOfMemoryError when attempting to read too many bytes at once. It only happens on 32bit JVMs with a large maximum heap size. Changes to this value will not impact any already-opened {@link IndexInput}s. You should call this before attempting to open an index on the directory. NOTE: This value should be as large as possible to reduce any possible performance impact. If you still encounter an incorrect OutOfMemoryError, trying lowering the chunk size. (Inherited from FSDirectory.)
Public method | Sync | (Inherited from FSDirectory.)
Public method | ToString | For debug output. (Inherited from FSDirectory.)
Public method | TouchFile | Set the modified time of an existing file to now. (Inherited from FSDirectory.)

See Also

SimpleFSDirectory Class
Lucene.Net.Store Namespace


CreateOutput Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..CreateOutput Method
SimpleFSDirectory Class See Also Send Feedback
Creates an IndexOutput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.CreateOutput(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.CreateOutput(System.String)"]

See Also

SimpleFSDirectory Class
Lucene.Net.Store Namespace


OpenInput Method

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..OpenInput Method
SimpleFSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | (Inherited from FSDirectory.)
Public method | OpenInput(String, Int32) | Creates an IndexInput for the file with the given name. (Overrides FSDirectory..::..OpenInput(String, Int32).)

See Also

SimpleFSDirectory Class
SimpleFSDirectory Members
Lucene.Net.Store Namespace


OpenInput Method (String, Int32)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..OpenInput Method (String, Int32)
SimpleFSDirectory Class See Also Send Feedback
Creates an IndexInput for the file with the given name.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override IndexInput OpenInput(
    string name,
    int bufferSize
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String, _
    bufferSize As Integer _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name,
    int bufferSize
) override

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.OpenInput(System.String,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.OpenInput(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.OpenInput(System.String,System.Int32)"]

See Also

SimpleFSDirectory Class
OpenInput Overload
Lucene.Net.Store Namespace


SimpleFSDirectory Properties

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory Properties
SimpleFSDirectory Class See Also Send Feedback

The SimpleFSDirectory type exposes the following members.

Properties

 | Name | Description
Public property | isOpen_ForNUnit | (Inherited from Directory.)

See Also

SimpleFSDirectory Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Class

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Class
SimpleFSDirectory Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleFSIndexInput : BufferedIndexInput,
    ICloneable
Visual Basic
Public Class SimpleFSIndexInput _
    Inherits BufferedIndexInput _
    Implements ICloneable
Visual C++
public ref class SimpleFSIndexInput : public BufferedIndexInput,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexInput
Lucene.Net.Store..::..BufferedIndexInput
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexInput
Lucene.Net.Store..::..FSDirectory..::..FSIndexInput

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Members
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Members

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Members
SimpleFSDirectory..::..SimpleFSIndexInput Class Constructors Methods Fields Properties See Also Send Feedback

A straightforward implementation of {@link FSDirectory} using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use {@link NIOFSDirectory} or {@link MMapDirectory} instead.

The SimpleFSDirectory..::..SimpleFSIndexInput type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFSDirectory..::..SimpleFSIndexInput(FileInfo) | Obsolete. Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class
Public method | SimpleFSDirectory..::..SimpleFSIndexInput(FileInfo, Int32) | Obsolete. Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class
Public method | SimpleFSDirectory..::..SimpleFSIndexInput(FileInfo, Int32, Int32) | Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class

Methods

 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput..::..Clone()()()().)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize | (Inherited from BufferedIndexInput.)
Public method | GetFilePointer | (Inherited from BufferedIndexInput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | IndexInput methods (Overrides BufferedIndexInput..::..ReadInternal(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | (Overrides BufferedIndexInput..::..SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Protected field | chunkSize |
Protected field | file |

Properties

 | Name | Description
Public property | isClone_ForNUnit |

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Constructor
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleFSDirectory..::..SimpleFSIndexInput(FileInfo) | Obsolete. Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class
Public method | SimpleFSDirectory..::..SimpleFSIndexInput(FileInfo, Int32) | Obsolete. Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class
Public method | SimpleFSDirectory..::..SimpleFSIndexInput(FileInfo, Int32, Int32) | Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
SimpleFSDirectory..::..SimpleFSIndexInput Members
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Constructor (FileInfo)
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback
Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use ctor taking chunkSize ")]
public SimpleFSIndexInput(
    FileInfo path
)
Visual Basic
<ObsoleteAttribute("Please use ctor taking chunkSize ")> _
Public Sub New ( _
    path As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Please use ctor taking chunkSize ")]
public:
SimpleFSIndexInput(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.#ctor(System.IO.FileInfo)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
SimpleFSDirectory..::..SimpleFSIndexInput Overload
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Constructor (FileInfo, Int32)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Constructor (FileInfo, Int32)
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback
Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Please use ctor taking chunkSize ")]
public SimpleFSIndexInput(
    FileInfo path,
    int bufferSize
)
Visual Basic
<ObsoleteAttribute("Please use ctor taking chunkSize ")> _
Public Sub New ( _
    path As FileInfo, _
    bufferSize As Integer _
)
Visual C++
[ObsoleteAttribute(L"Please use ctor taking chunkSize ")]
public:
SimpleFSIndexInput(
    FileInfo^ path,
    int bufferSize
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.#ctor(System.IO.FileInfo,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.#ctor(System.IO.FileInfo,System.Int32)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
SimpleFSDirectory..::..SimpleFSIndexInput Overload
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Constructor (FileInfo, Int32, Int32)

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Constructor (FileInfo, Int32, Int32)
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback
Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSIndexInput(
    FileInfo path,
    int bufferSize,
    int chunkSize
)
Visual Basic
Public Sub New ( _
    path As FileInfo, _
    bufferSize As Integer, _
    chunkSize As Integer _
)
Visual C++
public:
SimpleFSIndexInput(
    FileInfo^ path,
    int bufferSize,
    int chunkSize
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.#ctor(System.IO.FileInfo,System.Int32,System.Int32)"]

bufferSize
Type: System..::..Int32

[Missing <param name="bufferSize"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.#ctor(System.IO.FileInfo,System.Int32,System.Int32)"]

chunkSize
Type: System..::..Int32

[Missing <param name="chunkSize"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.#ctor(System.IO.FileInfo,System.Int32,System.Int32)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
SimpleFSDirectory..::..SimpleFSIndexInput Overload
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Fields
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput type exposes the following members.

Fields

 | Name | Description
Protected field | buffer | (Inherited from BufferedIndexInput.)
Protected field | chunkSize |
Protected field | file |

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


chunkSize Field

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..chunkSize Field
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.chunkSize"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int chunkSize
Visual Basic
Protected Friend chunkSize As Integer
Visual C++
protected public:
int chunkSize

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


file Field

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..file Field
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.file"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor file
Visual Basic
Protected Friend file As SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Visual C++
protected public:
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor^ file

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Methods
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides BufferedIndexInput..::..Clone()()()().)
Public method | Close | (Overrides IndexInput..::..Close()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBufferSize | (Inherited from BufferedIndexInput.)
Public method | GetFilePointer | (Inherited from BufferedIndexInput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFDValid | Method used for testing. Returns true if the underlying file descriptor is valid.
Public method | Length | (Overrides IndexInput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NewBuffer | (Inherited from BufferedIndexInput.)
Public method | ReadByte | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)
Public method | ReadChars | Obsolete. Reads Lucene's old "modified UTF-8" encoded characters into an array. (Inherited from IndexInput.)
Public method | ReadInt | Reads four bytes and returns an int. (Inherited from IndexInput.)
Public method | ReadInternal | IndexInput methods (Overrides BufferedIndexInput..::..ReadInternal(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadLong | Reads eight bytes and returns a long. (Inherited from IndexInput.)
Public method | ReadString | Reads a string. (Inherited from IndexInput.)
Public method | ReadStringStringMap | (Inherited from IndexInput.)
Public method | ReadVInt | Reads an int stored in variable-length format. Reads between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | ReadVLong | Reads a long stored in variable-length format. Reads between one and nine bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexInput.)
Public method | Seek | (Inherited from BufferedIndexInput.)
Public method | SeekInternal | (Overrides BufferedIndexInput..::..SeekInternal(Int64).)
Public method | SetBufferSize | Change the buffer size used by this IndexInput (Inherited from BufferedIndexInput.)
Public method | SetModifiedUTF8StringsMode | Call this if readString should read characters stored in the old modified UTF8 format (length in java chars and java's modified UTF8 encoding). This is used for indices written pre-2.4 See LUCENE-510 for details. (Inherited from IndexInput.)
Public method | SkipChars | Obsolete. Expert Similar to {@link #ReadChars(char[], int, int)} but does not do any conversion operations on the bytes it is reading in. It still has to invoke {@link #ReadByte()} just as {@link #ReadChars(char[], int, int)} does, but it does not need a buffer to store anything and it does not have to do any of the bitwise operations, since we don't actually care what is in the byte except to determine how many more bytes to read (Inherited from IndexInput.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


Clone Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Clone Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Clone"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Clone"]

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Close Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


IsFDValid Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..IsFDValid Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback
Method used for testing. Returns true if the underlying file descriptor is valid.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsFDValid()
Visual Basic
Public Overridable Function IsFDValid As Boolean
Visual C++
public:
virtual bool IsFDValid()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.IsFDValid"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


Length Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Length Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Length"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Length"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


ReadBytes Method

[image] [image]

Lucene.Net Class Libraries
SimpleFSIndexInput..::..ReadBytes Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | (Inherited from BufferedIndexInput.)
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32, Boolean) | (Inherited from BufferedIndexInput.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
SimpleFSDirectory..::..SimpleFSIndexInput Members
Lucene.Net.Store Namespace


ReadInternal Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..ReadInternal Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback
IndexInput methods

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ReadInternal(
    byte[] b,
    int offset,
    int len
)
Visual Basic
Public Overrides Sub ReadInternal ( _
    b As Byte(), _
    offset As Integer, _
    len As Integer _
)
Visual C++
public:
virtual void ReadInternal(
    array<unsigned char>^ b,
    int offset,
    int len
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.ReadInternal(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.ReadInternal(System.Byte[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.ReadInternal(System.Byte[],System.Int32,System.Int32)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


SeekInternal Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..SeekInternal Method
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.SeekInternal(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SeekInternal(
    long position
)
Visual Basic
Public Overrides Sub SeekInternal ( _
    position As Long _
)
Visual C++
public:
virtual void SeekInternal(
    long long position
) override

Parameters

position
Type: System..::..Int64

[Missing <param name="position"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.SeekInternal(System.Int64)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput Properties

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput Properties
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput type exposes the following members.

Properties

 | Name | Description
Public property | isClone_ForNUnit |

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


isClone_ForNUnit Property

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..isClone_ForNUnit Property
SimpleFSDirectory..::..SimpleFSIndexInput Class See Also Send Feedback

[Missing <summary> documentation for "P:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.isClone_ForNUnit"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool isClone_ForNUnit { get; }
Visual Basic
Public ReadOnly Property isClone_ForNUnit As Boolean
    Get
Visual C++
public:
property bool isClone_ForNUnit {
    bool get ();
}

See Also

SimpleFSDirectory..::..SimpleFSIndexInput Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Class

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
SimpleFSDirectory..::..SimpleFSIndexInput Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Descriptor"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal class Descriptor : BinaryReader
Visual Basic
Protected Friend Class Descriptor _
    Inherits BinaryReader
Visual C++
protected public ref class Descriptor : public BinaryReader

Inheritance Hierarchy

System..::..Object
System.IO..::..BinaryReader
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor
Lucene.Net.Store..::..FSDirectory..::..FSIndexInput..::..Descriptor

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Members
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Members

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Members
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class Constructors Methods Fields Properties See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor | Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor class

Methods

 | Name | Description
Public method | Close | (Overrides BinaryReader..::..Close()()()().)
Public method | Dispose()()()() | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from BinaryReader.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from BinaryReader.)
Public method | Read()()()() | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Public method | Read(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)
Protected method | Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from BinaryReader.)
Public method | ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from BinaryReader.)
Public method | ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from BinaryReader.)
Public method | ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from BinaryReader.)
Public method | ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | isOpen |

Properties

 | Name | Description
Public property | BaseStream | Exposes access to the underlying stream of the BinaryReader. (Inherited from BinaryReader.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Constructor

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Constructor
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback
Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Descriptor(
    FileInfo file,
    FileAccess mode
)
Visual Basic
Public Sub New ( _
    file As FileInfo, _
    mode As FileAccess _
)
Visual C++
public:
Descriptor(
    FileInfo^ file,
    FileAccess mode
)

Parameters

file
Type: System.IO..::..FileInfo

[Missing <param name="file"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Descriptor.#ctor(System.IO.FileInfo,System.IO.FileAccess)"]

mode
Type: System.IO..::..FileAccess

[Missing <param name="mode"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Descriptor.#ctor(System.IO.FileInfo,System.IO.FileAccess)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Fields
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor type exposes the following members.

Fields

 | Name | Description
Protected field | isOpen |

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


isOpen Field

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor..::..isOpen Field
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Descriptor.isOpen"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal bool isOpen
Visual Basic
Protected Friend isOpen As Boolean
Visual C++
protected public:
bool isOpen

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Methods
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides BinaryReader..::..Close()()()().)
Public method | Dispose()()()() | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from BinaryReader.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from BinaryReader.)
Public method | Read()()()() | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Public method | Read(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)
Protected method | Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from BinaryReader.)
Public method | ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from BinaryReader.)
Public method | ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from BinaryReader.)
Public method | ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
Public method | ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from BinaryReader.)
Public method | ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from BinaryReader.)
Public method | ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from BinaryReader.)
Public method | ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from BinaryReader.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor..::..Close Method
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Descriptor.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


Dispose Method

[image] [image]

Lucene.Net Class Libraries
Descriptor..::..Dispose Method
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Members
Lucene.Net.Store Namespace


Finalize Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor..::..Finalize Method
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.Descriptor.Finalize"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


Read Method

[image] [image]

Lucene.Net Class Libraries
Descriptor..::..Read Method
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read()()()() | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Public method | Read(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Members
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexInput.Descriptor Properties

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Properties
SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Exposes access to the underlying stream of the BinaryReader. (Inherited from BinaryReader.)

See Also

SimpleFSDirectory..::..SimpleFSIndexInput..::..Descriptor Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexOutput Class

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput Class
SimpleFSDirectory Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleFSIndexOutput : BufferedIndexOutput
Visual Basic
Public Class SimpleFSIndexOutput _
    Inherits BufferedIndexOutput
Visual C++
public ref class SimpleFSIndexOutput : public BufferedIndexOutput

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..IndexOutput
Lucene.Net.Store..::..BufferedIndexOutput
Lucene.Net.Store..::..SimpleFSDirectory..::..SimpleFSIndexOutput
Lucene.Net.Store..::..FSDirectory..::..FSIndexOutput

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Members
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexOutput Members

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput Members
SimpleFSDirectory..::..SimpleFSIndexOutput Class Constructors Methods See Also Send Feedback

A straightforward implementation of {@link FSDirectory} using java.io.RandomAccessFile. However, this class has poor concurrent performance (multiple threads will bottleneck) as it synchronizes when multiple threads read from the same file. It's usually better to use {@link NIOFSDirectory} or {@link MMapDirectory} instead.

The SimpleFSDirectory..::..SimpleFSIndexOutput type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFSDirectory..::..SimpleFSIndexOutput | Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexOutput class

Methods

 | Name | Description
Public method | Close | (Overrides BufferedIndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written. (Inherited from BufferedIndexOutput.)
Public method | FlushBuffer | output methods: (Overrides BufferedIndexOutput..::..FlushBuffer(array<Byte>[]()[][], Int32, Int32).)
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur. (Inherited from BufferedIndexOutput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides BufferedIndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Random-access methods (Overrides BufferedIndexOutput..::..Seek(Int64).)
Public method | SetLength | (Overrides IndexOutput..::..SetLength(Int64).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte. (Inherited from BufferedIndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexOutput Constructor

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput Constructor
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback
Initializes a new instance of the SimpleFSDirectory..::..SimpleFSIndexOutput class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSIndexOutput(
    FileInfo path
)
Visual Basic
Public Sub New ( _
    path As FileInfo _
)
Visual C++
public:
SimpleFSIndexOutput(
    FileInfo^ path
)

Parameters

path
Type: System.IO..::..FileInfo

[Missing <param name="path"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.#ctor(System.IO.FileInfo)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


SimpleFSDirectory.SimpleFSIndexOutput Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput Methods
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback

The SimpleFSDirectory..::..SimpleFSIndexOutput type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides BufferedIndexOutput..::..Close()()()().)
Public method | CopyBytes | Copy numBytes bytes from input to ourself. (Inherited from IndexOutput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any buffered output to be written. (Inherited from BufferedIndexOutput.)
Public method | FlushBuffer | output methods: (Overrides BufferedIndexOutput..::..FlushBuffer(array<Byte>[]()[][], Int32, Int32).)
Public method | GetFilePointer | Returns the current position in this file, where the next write will occur. (Inherited from BufferedIndexOutput.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | (Overrides BufferedIndexOutput..::..Length()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | Random-access methods (Overrides BufferedIndexOutput..::..Seek(Int64).)
Public method | SetLength | (Overrides IndexOutput..::..SetLength(Int64).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte. (Inherited from BufferedIndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteInt | Writes an int as four bytes. (Inherited from IndexOutput.)
Public method | WriteLong | Writes a long as eight bytes. (Inherited from IndexOutput.)
Public method | WriteString | Writes a string. (Inherited from IndexOutput.)
Public method | WriteStringStringMap | (Inherited from IndexOutput.)
Public method | WriteVInt | Writes an int in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)
Public method | WriteVLong | Writes an long in a variable-length format. Writes between one and five bytes. Smaller values take fewer bytes. Negative numbers are not supported. (Inherited from IndexOutput.)

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


Close Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput..::..Close Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.Close"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


FlushBuffer Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput..::..FlushBuffer Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback
output methods:

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void FlushBuffer(
    byte[] b,
    int offset,
    int size
)
Visual Basic
Public Overrides Sub FlushBuffer ( _
    b As Byte(), _
    offset As Integer, _
    size As Integer _
)
Visual C++
public:
virtual void FlushBuffer(
    array<unsigned char>^ b,
    int offset,
    int size
) override

Parameters

b
Type: array< System..::..Byte >[]()[][]

[Missing <param name="b"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.FlushBuffer(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.FlushBuffer(System.Byte[],System.Int32,System.Int32)"]

size
Type: System..::..Int32

[Missing <param name="size"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.FlushBuffer(System.Byte[],System.Int32,System.Int32)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


Length Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput..::..Length Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.Length"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override long Length()
Visual Basic
Public Overrides Function Length As Long
Visual C++
public:
virtual long long Length() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.Length"]

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


Seek Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput..::..Seek Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback
Random-access methods

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Seek(
    long pos
)
Visual Basic
Public Overrides Sub Seek ( _
    pos As Long _
)
Visual C++
public:
virtual void Seek(
    long long pos
) override

Parameters

pos
Type: System..::..Int64

[Missing <param name="pos"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.Seek(System.Int64)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


SetLength Method

[image]

Lucene.Net Class Libraries
SimpleFSDirectory..::..SimpleFSIndexOutput..::..SetLength Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.SetLength(System.Int64)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void SetLength(
    long length
)
Visual Basic
Public Overrides Sub SetLength ( _
    length As Long _
)
Visual C++
public:
virtual void SetLength(
    long long length
) override

Parameters

length
Type: System..::..Int64

[Missing <param name="length"/> documentation for "M:Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexOutput.SetLength(System.Int64)"]

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
Lucene.Net.Store Namespace


WriteBytes Method

[image] [image]

Lucene.Net Class Libraries
SimpleFSIndexOutput..::..WriteBytes Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteBytes(array<Byte>[]()[][], Int32) | Writes an array of bytes. (Inherited from IndexOutput.)
Public method | WriteBytes(array<Byte>[]()[][], Int32, Int32) | Writes an array of bytes. (Inherited from BufferedIndexOutput.)

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
SimpleFSDirectory..::..SimpleFSIndexOutput Members
Lucene.Net.Store Namespace


WriteChars Method

[image] [image]

Lucene.Net Class Libraries
SimpleFSIndexOutput..::..WriteChars Method
SimpleFSDirectory..::..SimpleFSIndexOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteChars(array<Char>[]()[][], Int32, Int32) | Obsolete. Writes a sub sequence of characters from char[] as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)
Public method | WriteChars(String, Int32, Int32) | Obsolete. Writes a sub sequence of characters from s as the old format (modified UTF-8 encoded bytes). (Inherited from IndexOutput.)

See Also

SimpleFSDirectory..::..SimpleFSIndexOutput Class
SimpleFSDirectory..::..SimpleFSIndexOutput Members
Lucene.Net.Store Namespace


SimpleFSLockFactory Class

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory Class
Members See Also Send Feedback

Implements {@link LockFactory} using {@link File#createNewFile()}.

NOTE: the javadocs for

CopyC#
File.createNewFile
contain a vague yet spooky warning about not using the API for file locking. This warning was added due to this bug, and in fact the only known problem with using this API for locking is that the Lucene write lock may not be released when the JVM exits abnormally.

When this happens, a {@link LockObtainFailedException} is hit when trying to create a writer, in which case you need to explicitly clear the lock file first. You can either manually remove the file, or use the {@link org.apache.lucene.index.IndexReader#unlock(Directory)} API. But, first be certain that no writer is in fact writing to the index otherwise you can easily corrupt your index.

If you suspect that this or any other LockFactory is not working properly in your environment, you can easily test it by using {@link VerifyingLockFactory}, {@link LockVerifyServer} and {@link LockStressTest}.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleFSLockFactory : FSLockFactory
Visual Basic
Public Class SimpleFSLockFactory _
    Inherits FSLockFactory
Visual C++
public ref class SimpleFSLockFactory : public FSLockFactory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..FSLockFactory
Lucene.Net.Store..::..SimpleFSLockFactory

See Also

SimpleFSLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..LockFactory


SimpleFSLockFactory Members

[image] [image]

Lucene.Net Class Libraries
SimpleFSLockFactory Members
SimpleFSLockFactory Class Constructors Methods Fields See Also Send Feedback

The SimpleFSLockFactory type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleFSLockFactory()()()() | Create a SimpleFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a {@link FSDirectory} subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | SimpleFSLockFactory(DirectoryInfo) | Instantiate using the provided directory (as a File instance).
Public method | SimpleFSLockFactory(FileInfo) | Obsolete. Instantiate using the provided directory (as a File instance).
Public method | SimpleFSLockFactory(String) | Instantiate using the provided directory name (String).

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockDir | Retrieve the lock directory. (Inherited from FSLockFactory.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetLockDir | Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

SimpleFSLockFactory Class
Lucene.Net.Store Namespace


SimpleFSLockFactory Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleFSLockFactory Constructor
SimpleFSLockFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleFSLockFactory()()()() | Create a SimpleFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a {@link FSDirectory} subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!
Public method | SimpleFSLockFactory(DirectoryInfo) | Instantiate using the provided directory (as a File instance).
Public method | SimpleFSLockFactory(FileInfo) | Obsolete. Instantiate using the provided directory (as a File instance).
Public method | SimpleFSLockFactory(String) | Instantiate using the provided directory name (String).

See Also

SimpleFSLockFactory Class
SimpleFSLockFactory Members
Lucene.Net.Store Namespace


SimpleFSLockFactory Constructor

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory Constructor
SimpleFSLockFactory Class See Also Send Feedback
Create a SimpleFSLockFactory instance, with null (unset) lock directory. When you pass this factory to a {@link FSDirectory} subclass, the lock directory is automatically set to the directory itsself. Be sure to create one instance for each directory your create!

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSLockFactory()
Visual Basic
Public Sub New
Visual C++
public:
SimpleFSLockFactory()

See Also

SimpleFSLockFactory Class
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace


SimpleFSLockFactory Constructor (DirectoryInfo)

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory Constructor (DirectoryInfo)
SimpleFSLockFactory Class See Also Send Feedback
Instantiate using the provided directory (as a File instance).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSLockFactory(
    DirectoryInfo lockDir
)
Visual Basic
Public Sub New ( _
    lockDir As DirectoryInfo _
)
Visual C++
public:
SimpleFSLockFactory(
    DirectoryInfo^ lockDir
)

Parameters

lockDir
Type: System.IO..::..DirectoryInfo
where lock files should be created.

See Also

SimpleFSLockFactory Class
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace


SimpleFSLockFactory Constructor (FileInfo)

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory Constructor (FileInfo)
SimpleFSLockFactory Class See Also Send Feedback
Instantiate using the provided directory (as a File instance).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public SimpleFSLockFactory(
    FileInfo lockDir
)
Visual Basic
<ObsoleteAttribute("Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")> _
Public Sub New ( _
    lockDir As FileInfo _
)
Visual C++
[ObsoleteAttribute(L"Use the constructor that takes a DirectoryInfo, this will be removed in the 3.0 release")]
public:
SimpleFSLockFactory(
    FileInfo^ lockDir
)

Parameters

lockDir
Type: System.IO..::..FileInfo
where lock files should be created.

See Also

SimpleFSLockFactory Class
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace


SimpleFSLockFactory Constructor (String)

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory Constructor (String)
SimpleFSLockFactory Class See Also Send Feedback
Instantiate using the provided directory name (String).

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleFSLockFactory(
    string lockDirName
)
Visual Basic
Public Sub New ( _
    lockDirName As String _
)
Visual C++
public:
SimpleFSLockFactory(
    String^ lockDirName
)

Parameters

lockDirName
Type: System..::..String
where lock files should be created.

See Also

SimpleFSLockFactory Class
SimpleFSLockFactory Overload
Lucene.Net.Store Namespace


SimpleFSLockFactory Fields

[image] [image]

Lucene.Net Class Libraries
SimpleFSLockFactory Fields
SimpleFSLockFactory Class See Also Send Feedback

The SimpleFSLockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockDir | Directory for the lock files. (Inherited from FSLockFactory.)
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

SimpleFSLockFactory Class
Lucene.Net.Store Namespace


SimpleFSLockFactory Methods

[image] [image]

Lucene.Net Class Libraries
SimpleFSLockFactory Methods
SimpleFSLockFactory Class See Also Send Feedback

The SimpleFSLockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockDir | Retrieve the lock directory. (Inherited from FSLockFactory.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetLockDir | Set the lock directory. This method can be only called once to initialize the lock directory. It is used by {@link FSDirectory} to set the lock directory to itsself. Subclasses can also use this method to set the directory in the constructor. (Inherited from FSLockFactory.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleFSLockFactory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory..::..ClearLock Method
SimpleFSLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSLockFactory.ClearLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ClearLock(
    string lockName
)
Visual Basic
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.SimpleFSLockFactory.ClearLock(System.String)"]

See Also

SimpleFSLockFactory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
SimpleFSLockFactory..::..MakeLock Method
SimpleFSLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SimpleFSLockFactory.MakeLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Lock MakeLock(
    string lockName
)
Visual Basic
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.SimpleFSLockFactory.MakeLock(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SimpleFSLockFactory.MakeLock(System.String)"]

See Also

SimpleFSLockFactory Class
Lucene.Net.Store Namespace


SingleInstanceLockFactory Class

[image]

Lucene.Net Class Libraries
SingleInstanceLockFactory Class
Members See Also Send Feedback
Implements {@link LockFactory} for a single in-process instance, meaning all locking will take place through this one instance. Only use this {@link LockFactory} when you are certain all IndexReaders and IndexWriters for a given index are running against a single shared in-process Directory instance. This is currently the default locking for RAMDirectory.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SingleInstanceLockFactory : LockFactory
Visual Basic
Public Class SingleInstanceLockFactory _
    Inherits LockFactory
Visual C++
public ref class SingleInstanceLockFactory : public LockFactory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..SingleInstanceLockFactory

See Also

SingleInstanceLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..LockFactory


SingleInstanceLockFactory Members

[image] [image]

Lucene.Net Class Libraries
SingleInstanceLockFactory Members
SingleInstanceLockFactory Class Constructors Methods Fields See Also Send Feedback

The SingleInstanceLockFactory type exposes the following members.

Constructors

 | Name | Description
Public method | SingleInstanceLockFactory | Initializes a new instance of the SingleInstanceLockFactory class

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

SingleInstanceLockFactory Class
Lucene.Net.Store Namespace


SingleInstanceLockFactory Constructor

[image]

Lucene.Net Class Libraries
SingleInstanceLockFactory Constructor
SingleInstanceLockFactory Class See Also Send Feedback
Initializes a new instance of the SingleInstanceLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SingleInstanceLockFactory()
Visual Basic
Public Sub New
Visual C++
public:
SingleInstanceLockFactory()

See Also

SingleInstanceLockFactory Class
Lucene.Net.Store Namespace


SingleInstanceLockFactory Fields

[image] [image]

Lucene.Net Class Libraries
SingleInstanceLockFactory Fields
SingleInstanceLockFactory Class See Also Send Feedback

The SingleInstanceLockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

SingleInstanceLockFactory Class
Lucene.Net.Store Namespace


SingleInstanceLockFactory Methods

[image] [image]

Lucene.Net Class Libraries
SingleInstanceLockFactory Methods
SingleInstanceLockFactory Class See Also Send Feedback

The SingleInstanceLockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleInstanceLockFactory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
SingleInstanceLockFactory..::..ClearLock Method
SingleInstanceLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SingleInstanceLockFactory.ClearLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ClearLock(
    string lockName
)
Visual Basic
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.SingleInstanceLockFactory.ClearLock(System.String)"]

See Also

SingleInstanceLockFactory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
SingleInstanceLockFactory..::..MakeLock Method
SingleInstanceLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.SingleInstanceLockFactory.MakeLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Lock MakeLock(
    string lockName
)
Visual Basic
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.SingleInstanceLockFactory.MakeLock(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.SingleInstanceLockFactory.MakeLock(System.String)"]

See Also

SingleInstanceLockFactory Class
Lucene.Net.Store Namespace


VerifyingLockFactory Class

[image]

Lucene.Net Class Libraries
VerifyingLockFactory Class
Members See Also Send Feedback
A {@link LockFactory} that wraps another {@link LockFactory} and verifies that each lock obtain/release is "correct" (never results in two processes holding the lock at the same time). It does this by contacting an external server ({@link LockVerifyServer}) to assert that at most one process holds the lock at a time. To use this, you should also run {@link LockVerifyServer} on the host & port matching what you pass to the constructor.

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class VerifyingLockFactory : LockFactory
Visual Basic
Public Class VerifyingLockFactory _
    Inherits LockFactory
Visual C++
public ref class VerifyingLockFactory : public LockFactory

Inheritance Hierarchy

System..::..Object
Lucene.Net.Store..::..LockFactory
Lucene.Net.Store..::..VerifyingLockFactory

See Also

VerifyingLockFactory Members
Lucene.Net.Store Namespace
Lucene.Net.Store..::..LockVerifyServer
Lucene.Net.Store..::..LockStressTest


VerifyingLockFactory Members

[image] [image]

Lucene.Net Class Libraries
VerifyingLockFactory Members
VerifyingLockFactory Class Constructors Methods Fields See Also Send Feedback

The VerifyingLockFactory type exposes the following members.

Constructors

 | Name | Description
Public method | VerifyingLockFactory | Initializes a new instance of the VerifyingLockFactory class

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

VerifyingLockFactory Class
Lucene.Net.Store Namespace


VerifyingLockFactory Constructor

[image]

Lucene.Net Class Libraries
VerifyingLockFactory Constructor
VerifyingLockFactory Class See Also Send Feedback
Initializes a new instance of the VerifyingLockFactory class

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public VerifyingLockFactory(
    sbyte id,
    LockFactory lf,
    string host,
    int port
)
Visual Basic
Public Sub New ( _
    id As SByte, _
    lf As LockFactory, _
    host As String, _
    port As Integer _
)
Visual C++
public:
VerifyingLockFactory(
    signed char id,
    LockFactory^ lf,
    String^ host,
    int port
)

Parameters

id
Type: System..::..SByte
should be a unique id across all clients
lf
Type: Lucene.Net.Store..::..LockFactory
the LockFactory that we are testing
host
Type: System..::..String
host or IP where {@link LockVerifyServer} is running
port
Type: System..::..Int32
the port {@link LockVerifyServer} is listening on

See Also

VerifyingLockFactory Class
Lucene.Net.Store Namespace


VerifyingLockFactory Fields

[image] [image]

Lucene.Net Class Libraries
VerifyingLockFactory Fields
VerifyingLockFactory Class See Also Send Feedback

The VerifyingLockFactory type exposes the following members.

Fields

 | Name | Description
Protected field | lockPrefix | (Inherited from LockFactory.)

See Also

VerifyingLockFactory Class
Lucene.Net.Store Namespace


VerifyingLockFactory Methods

[image] [image]

Lucene.Net Class Libraries
VerifyingLockFactory Methods
VerifyingLockFactory Class See Also Send Feedback

The VerifyingLockFactory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | (Overrides LockFactory..::..ClearLock(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockPrefix | Get the prefix in use for all locks created in this LockFactory. (Inherited from LockFactory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeLock | (Overrides LockFactory..::..MakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLockPrefix | Set the prefix in use for all locks created in this LockFactory. This is normally called once, when a Directory gets this LockFactory instance. However, you can also call this (after this instance is assigned to a Directory) to override the prefix in use. This is helpful if you're running Lucene on machines that have different mount points for the same shared directory. (Inherited from LockFactory.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VerifyingLockFactory Class
Lucene.Net.Store Namespace


ClearLock Method

[image]

Lucene.Net Class Libraries
VerifyingLockFactory..::..ClearLock Method
VerifyingLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.VerifyingLockFactory.ClearLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void ClearLock(
    string lockName
)
Visual Basic
Public Overrides Sub ClearLock ( _
    lockName As String _
)
Visual C++
public:
virtual void ClearLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.VerifyingLockFactory.ClearLock(System.String)"]

See Also

VerifyingLockFactory Class
Lucene.Net.Store Namespace


MakeLock Method

[image]

Lucene.Net Class Libraries
VerifyingLockFactory..::..MakeLock Method
VerifyingLockFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Store.VerifyingLockFactory.MakeLock(System.String)"]

Namespace: Lucene.Net.Store
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Lock MakeLock(
    string lockName
)
Visual Basic
Public Overrides Function MakeLock ( _
    lockName As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ lockName
) override

Parameters

lockName
Type: System..::..String

[Missing <param name="lockName"/> documentation for "M:Lucene.Net.Store.VerifyingLockFactory.MakeLock(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Store.VerifyingLockFactory.MakeLock(System.String)"]

See Also

VerifyingLockFactory Class
Lucene.Net.Store Namespace


Lucene.Net.Util Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Util Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Util"]

Classes

Class | Description
Public class ArrayUtil
Methods for manipulating arrays.
Public class AttributeImpl
Base class for Attributes that can be added to a {@link Lucene.Net.Util.AttributeSource}.

Attributes are used to add data in a dynamic, yet type-safe way to a source of usually streamed objects, e. g. a {@link Lucene.Net.Analysis.TokenStream}.

Public class AttributeSource
An AttributeSource contains a list of different {@link AttributeImpl}s, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the {@link #AddAttribute(Class)}, which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.
Public class AttributeSource..::..AttributeFactory
An AttributeFactory creates instances of {@link AttributeImpl}s.
Public class AttributeSource..::..State
This class holds the state of an AttributeSource.
Public class AverageGuessMemoryModel
An average, best guess, MemoryModel that should work okay on most systems.
Public class BitUtil
A variety of high efficiencly bit twiddling routines.
Public class BitVector
Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:
  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
  • store and load, as bit set or d-gaps, depending on sparseness;
Public class CloseableThreadLocal
Java's builtin ThreadLocal has a serious flaw: it can take an arbitrarily long amount of time to dereference the things you had stored in it, even once the ThreadLocal instance itself is no longer referenced. This is because there is single, master map stored for each thread, which all ThreadLocals share, and that master map only periodically purges "stale" entries. While not technically a memory leak, because eventually the memory will be reclaimed, it can take a long time and you can easily hit OutOfMemoryError because from the GC's standpoint the stale entries are not reclaimaible. This class works around that, by only enrolling WeakReference values into the ThreadLocal, and separately holding a hard reference to each stored value. When you call {@link #close}, these hard references are cleared and then GC is freely able to reclaim space by objects stored in it.
Public class Constants
Some useful constants.
Public class DocIdBitSet
Simple DocIdSet and DocIdSetIterator backed by a BitSet
Public class FieldCacheSanityChecker
Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Public class FieldCacheSanityChecker..::..Insanity
Simple container for a collection of related CacheEntry objects that in conjunction with eachother represent some "insane" usage of the FieldCache.
Public class FieldCacheSanityChecker..::..InsanityType
An Enumaration of the differnet types of "insane" behavior that may be detected in a FieldCache.
Public class IndexableBinaryStringTools
Provides support for converting byte sequences to Strings and back again. The resulting Strings preserve the original byte sequences' sort order. The Strings are constructed using a Base 8000h encoding of the original binary data - each char of an encoded String represents a 15-bit chunk from the byte sequence. Base 8000h was chosen because it allows for all lower 15 bits of char to be used without restriction; the surrogate range [U+D8000-U+DFFF] does not represent valid chars, and would require complicated handling to avoid them and allow use of char's high bit. Although unset bits are used as padding in the final char, the original byte sequence could contain trailing bytes with no set bits (null bytes): padding is indistinguishable from valid information. To overcome this problem, a char is appended, indicating the number of encoded bytes in the final content char. This class's operations are defined over CharBuffers and ByteBuffers, to allow for wrapped arrays to be reused, reducing memory allocation costs for repeated operations. Note that this class calls array() and arrayOffset() on the CharBuffers and ByteBuffers it uses, so only wrapped arrays may be used. This class interprets the arrayOffset() and limit() values returned by its input buffers as beginning and end+1 positions on the wrapped array, resprectively; similarly, on the output buffer, arrayOffset() is the first position written to, and limit() is set to one past the final output array position.
Public class MapOfSets<(Of <(<'T, V>)>)>
Helper class for keeping Listss of Objects associated with keys. WARNING: THIS CLASS IS NOT THREAD SAFE
Public class MemoryModel
Returns primitive memory sizes for estimating RAM usage.
Public class NumericUtils
This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the

CopyC#
shift
value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: {@link #doubleToSortableLong}, {@link #floatToSortableInt}. You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: {@link java.util.Date#getTime}).

For easy usage, the trie algorithm is implemented for indexing inside {@link NumericTokenStream} that can index

CopyC#
int
,
CopyC#
long
,
CopyC#
float
, and
CopyC#
double
. For querying, {@link NumericRangeQuery} and {@link NumericRangeFilter} implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according {@link String#compareTo(String)}) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.

Public class NumericUtils..::..IntRangeBuilder
Expert: Callback for {@link #splitIntRange}. You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.

Public class NumericUtils..::..LongRangeBuilder
Expert: Callback for {@link #splitLongRange}. You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.

Public class OpenBitSet
An "open" BitSet implementation that allows direct access to the array of words storing the bits.

Unlike java.util.bitset, the fact that bits are packed into an array of longs is part of the interface. This allows efficient implementation of other algorithms by someone other than the author. It also allows one to efficiently implement alternate serialization or interchange formats.

CopyC#
OpenBitSet
is faster than
CopyC#
java.util.BitSet
 in most operations and *much* faster at calculating cardinality of sets and results of set operations. It can also handle sets of larger cardinality (up to 64 * 2**32-1)

The goals of

CopyC#
OpenBitSet
are the fastest implementation possible, and maximum code reuse. Extra safety and encapsulation may always be built on top, but if that's built in, the cost can never be removed (and hence people re-implement their own version in order to get better performance). If you want a "safe", totally encapsulated (and slower and limited) BitSet class, use
CopyC#
java.util.BitSet
.

Performance Results

Test system: Pentium 4, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 3.36 | 3.96 | 1.44 | 1.46 | 1.99 | 1.58
1% full | 3.31 | 3.90 |  | 1.04 |  | 0.99

Test system: AMD Opteron, 64 bit linux, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 2.50 | 3.50 | 1.00 | 1.03 | 1.12 | 1.25
1% full | 2.51 | 3.49 |  | 1.00 |  | 1.02
Public class | OpenBitSetDISI
Public class OpenBitSetIterator
An iterator to iterate over set bits in an OpenBitSet. This is faster than nextSetBit() for iterating over the complete set of bits, especially when the density of the bits set is high.
Public class Parameter
A serializable Enum class.
Public class PriorityQueue
A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.

NOTE: This class pre-allocates a full array of length

CopyC#
maxSize+1
, in {@link #initialize}.
Public class RamUsageEstimator
Estimates the size of a given Object using a given MemoryModel for primitive size information. Resource Usage: Internally uses a Map to temporally hold a reference to every object seen. If checkIntered, all Strings checked will be interned, but those that were not already interned will be released for GC when the estimate is complete.
Public class ReaderUtil
Common util methods for dealing with {@link IndexReader}s.
Public class ScorerDocQueue
A ScorerDocQueue maintains a partial ordering of its Scorers such that the least Scorer can always be found in constant time. Put()'s and pop()'s require log(size) time. The ordering is by Scorer.doc().
Public class SimpleStringInterner
Simple lockless and memory barrier free String intern cache that is guaranteed to return the same String instance as String.intern() does.
Public class SmallFloat
Floating point numbers smaller than 32 bits.
Public class SortedVIntList
Stores and iterate on sorted integers in compressed form in RAM.
The code for compressing the differences between ascending integers was borrowed from {@link Lucene.Net.Store.IndexInput} and {@link Lucene.Net.Store.IndexOutput}.

NOTE: this class assumes the stored integers are doc Ids (hence why it extends {@link DocIdSet}). Therefore its {@link #Iterator()} assumes {@link DocIdSetIterator#NO_MORE_DOCS} can be used as sentinel. If you intent to use this value, then make sure it's not used during search flow.

Public class SorterTemplate
Borrowed from Cglib. Allows custom swap so that two arrays can be sorted at the same time.
Public class StringHelper
Methods for manipulating strings. $Id: StringHelper.java 801344 2009-08-05 18:05:06Z yonik $
Public class StringInterner
Subclasses of StringInterner are required to return the same single String object for all equal strings. Depending on the implementation, this may not be the same object returned as String.intern(). This StringInterner base class simply delegates to String.intern().
Public class ToStringUtils
Helper methods to ease implementing {@link Object#toString()}.
Public class UnicodeUtil
Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

Public class | UnicodeUtil..::..UTF16Result
Public class | UnicodeUtil..::..UTF8Result
Public class Version
Use by certain classes to match version compatibility across releases of Lucene.

WARNING: When changing the version parameter that you supply to components in Lucene, do not simply change the version at search-time, but instead also adjust your indexing code to match, and re-index.

Interfaces

 | Interface | Description
Public interface | Attribute | Base interface for attributes.


ArrayUtil Class

[image]

Lucene.Net Class Libraries
ArrayUtil Class
Members See Also Send Feedback
Methods for manipulating arrays.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class ArrayUtil
Visual Basic
Public NotInheritable Class ArrayUtil
Visual C++
public ref class ArrayUtil sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..ArrayUtil

See Also

ArrayUtil Members
Lucene.Net.Util Namespace


ArrayUtil Members

[image] [image]

Lucene.Net Class Libraries
ArrayUtil Members
ArrayUtil Class Constructors Methods See Also Send Feedback

The ArrayUtil type exposes the following members.

Constructors

 | Name | Description
Public method | ArrayUtil | Initializes a new instance of the ArrayUtil class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextSize |
 | GetShrinkSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Grow(array<Byte>[]()[][]) |
 | Grow(array<Int32>[]()[][]) |
 | Grow(array<Int64>[]()[][]) |
 | Grow(array<Byte>[]()[][], Int32) |
 | Grow(array<Int32>[]()[][], Int32) |
 | Grow(array<Int64>[]()[][], Int32) |
 | HashCode(array<Byte>[]()[][], Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
 | HashCode(array<Char>[]()[][], Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseInt(array<Char>[]()[][]) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.
 | ParseInt(array<Char>[]()[][], Int32, Int32) | Parses a char array into an int.
 | ParseInt(array<Char>[]()[][], Int32, Int32, Int32) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.
 | Shrink(array<Byte>[]()[][], Int32) |
 | Shrink(array<Int32>[]()[][], Int32) |
 | Shrink(array<Int64>[]()[][], Int32) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArrayUtil Class
Lucene.Net.Util Namespace


ArrayUtil Constructor

[image]

Lucene.Net Class Libraries
ArrayUtil Constructor
ArrayUtil Class See Also Send Feedback
Initializes a new instance of the ArrayUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ArrayUtil()
Visual Basic
Public Sub New
Visual C++
public:
ArrayUtil()

See Also

ArrayUtil Class
Lucene.Net.Util Namespace


ArrayUtil Methods

[image] [image]

Lucene.Net Class Libraries
ArrayUtil Methods
ArrayUtil Class See Also Send Feedback

The ArrayUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextSize |
 | GetShrinkSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Grow(array<Byte>[]()[][]) |
 | Grow(array<Int32>[]()[][]) |
 | Grow(array<Int64>[]()[][]) |
 | Grow(array<Byte>[]()[][], Int32) |
 | Grow(array<Int32>[]()[][], Int32) |
 | Grow(array<Int64>[]()[][], Int32) |
 | HashCode(array<Byte>[]()[][], Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
 | HashCode(array<Char>[]()[][], Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseInt(array<Char>[]()[][]) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.
 | ParseInt(array<Char>[]()[][], Int32, Int32) | Parses a char array into an int.
 | ParseInt(array<Char>[]()[][], Int32, Int32, Int32) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.
 | Shrink(array<Byte>[]()[][], Int32) |
 | Shrink(array<Int32>[]()[][], Int32) |
 | Shrink(array<Int64>[]()[][], Int32) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArrayUtil Class
Lucene.Net.Util Namespace


GetNextSize Method

[image]

Lucene.Net Class Libraries
ArrayUtil..::..GetNextSize Method
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.GetNextSize(System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetNextSize(
    int targetSize
)
Visual Basic
Public Shared Function GetNextSize ( _
    targetSize As Integer _
) As Integer
Visual C++
public:
static int GetNextSize(
    int targetSize
)

Parameters

targetSize
Type: System..::..Int32

[Missing <param name="targetSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.GetNextSize(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.GetNextSize(System.Int32)"]

See Also

ArrayUtil Class
Lucene.Net.Util Namespace


GetShrinkSize Method

[image]

Lucene.Net Class Libraries
ArrayUtil..::..GetShrinkSize Method
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.GetShrinkSize(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetShrinkSize(
    int currentSize,
    int targetSize
)
Visual Basic
Public Shared Function GetShrinkSize ( _
    currentSize As Integer, _
    targetSize As Integer _
) As Integer
Visual C++
public:
static int GetShrinkSize(
    int currentSize,
    int targetSize
)

Parameters

currentSize
Type: System..::..Int32

[Missing <param name="currentSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.GetShrinkSize(System.Int32,System.Int32)"]

targetSize
Type: System..::..Int32

[Missing <param name="targetSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.GetShrinkSize(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.GetShrinkSize(System.Int32,System.Int32)"]

See Also

ArrayUtil Class
Lucene.Net.Util Namespace


Grow Method

[image] [image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method
ArrayUtil Class See Also Send Feedback

Overload List

Name | Description
Grow(array<Byte>[]()[][]) |
Grow(array<Int32>[]()[][]) |
Grow(array<Int64>[]()[][]) |
Grow(array<Byte>[]()[][], Int32) |
Grow(array<Int32>[]()[][], Int32) |
Grow(array<Int64>[]()[][], Int32) |

See Also

ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace


Grow Method (Byte[])

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method (array<Byte>[]()[][])
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[])"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Grow(
    byte[] array
)
Visual Basic
Public Shared Function Grow ( _
    array As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Grow(
    array<unsigned char>^ array
)

Parameters

array
Type: array< System..::..Byte >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[])"]

See Also

ArrayUtil Class
Grow Overload
Lucene.Net.Util Namespace


Grow Method (Int32[])

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method (array<Int32>[]()[][])
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[])"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int[] Grow(
    int[] array
)
Visual Basic
Public Shared Function Grow ( _
    array As Integer() _
) As Integer()
Visual C++
public:
static array<int>^ Grow(
    array<int>^ array
)

Parameters

array
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[])"]

See Also

ArrayUtil Class
Grow Overload
Lucene.Net.Util Namespace


Grow Method (Int64[])

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method (array<Int64>[]()[][])
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[])"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long[] Grow(
    long[] array
)
Visual Basic
Public Shared Function Grow ( _
    array As Long() _
) As Long()
Visual C++
public:
static array<long long>^ Grow(
    array<long long>^ array
)

Parameters

array
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[])"]

See Also

ArrayUtil Class
Grow Overload
Lucene.Net.Util Namespace


Grow Method (Byte[], Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method (array<Byte>[]()[][], Int32)
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Grow(
    byte[] array,
    int minSize
)
Visual Basic
Public Shared Function Grow ( _
    array As Byte(), _
    minSize As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Grow(
    array<unsigned char>^ array,
    int minSize
)

Parameters

array
Type: array< System..::..Byte >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[],System.Int32)"]

minSize
Type: System..::..Int32

[Missing <param name="minSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Byte[],System.Int32)"]

See Also

ArrayUtil Class
Grow Overload
Lucene.Net.Util Namespace


Grow Method (Int32[], Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method (array<Int32>[]()[][], Int32)
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[],System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int[] Grow(
    int[] array,
    int minSize
)
Visual Basic
Public Shared Function Grow ( _
    array As Integer(), _
    minSize As Integer _
) As Integer()
Visual C++
public:
static array<int>^ Grow(
    array<int>^ array,
    int minSize
)

Parameters

array
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[],System.Int32)"]

minSize
Type: System..::..Int32

[Missing <param name="minSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int32[],System.Int32)"]

See Also

ArrayUtil Class
Grow Overload
Lucene.Net.Util Namespace


Grow Method (Int64[], Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Grow Method (array<Int64>[]()[][], Int32)
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[],System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long[] Grow(
    long[] array,
    int minSize
)
Visual Basic
Public Shared Function Grow ( _
    array As Long(), _
    minSize As Integer _
) As Long()
Visual C++
public:
static array<long long>^ Grow(
    array<long long>^ array,
    int minSize
)

Parameters

array
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[],System.Int32)"]

minSize
Type: System..::..Int32

[Missing <param name="minSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Grow(System.Int64[],System.Int32)"]

See Also

ArrayUtil Class
Grow Overload
Lucene.Net.Util Namespace


HashCode Method

[image] [image]

Lucene.Net Class Libraries
ArrayUtil..::..HashCode Method
ArrayUtil Class See Also Send Feedback

Overload List

Name | Description
HashCode(array<Byte>[]()[][], Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)
HashCode(array<Char>[]()[][], Int32, Int32) | Returns hash of chars in range start (inclusive) to end (inclusive)

See Also

ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace


HashCode Method (Byte[], Int32, Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..HashCode Method (array<Byte>[]()[][], Int32, Int32)
ArrayUtil Class See Also Send Feedback
Returns hash of chars in range start (inclusive) to end (inclusive)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int HashCode(
    byte[] array,
    int start,
    int end
)
Visual Basic
Public Shared Function HashCode ( _
    array As Byte(), _
    start As Integer, _
    end As Integer _
) As Integer
Visual C++
public:
static int HashCode(
    array<unsigned char>^ array,
    int start,
    int end
)

Parameters

array
Type: array< System..::..Byte >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Byte[],System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Byte[],System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Byte[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Byte[],System.Int32,System.Int32)"]

See Also

ArrayUtil Class
HashCode Overload
Lucene.Net.Util Namespace


HashCode Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..HashCode Method (array<Char>[]()[][], Int32, Int32)
ArrayUtil Class See Also Send Feedback
Returns hash of chars in range start (inclusive) to end (inclusive)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int HashCode(
    char[] array,
    int start,
    int end
)
Visual Basic
Public Shared Function HashCode ( _
    array As Char(), _
    start As Integer, _
    end As Integer _
) As Integer
Visual C++
public:
static int HashCode(
    array<wchar_t>^ array,
    int start,
    int end
)

Parameters

array
Type: array< System..::..Char >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Char[],System.Int32,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Char[],System.Int32,System.Int32)"]

end
Type: System..::..Int32

[Missing <param name="end"/> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.HashCode(System.Char[],System.Int32,System.Int32)"]

See Also

ArrayUtil Class
HashCode Overload
Lucene.Net.Util Namespace


ParseInt Method

[image] [image]

Lucene.Net Class Libraries
ArrayUtil..::..ParseInt Method
ArrayUtil Class See Also Send Feedback

Overload List

Name | Description
ParseInt(array<Char>[]()[][]) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.
ParseInt(array<Char>[]()[][], Int32, Int32) | Parses a char array into an int.
ParseInt(array<Char>[]()[][], Int32, Int32, Int32) | Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.

See Also

ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace


ParseInt Method (Char[])

[image]

Lucene.Net Class Libraries
ArrayUtil..::..ParseInt Method (array<Char>[]()[][])
ArrayUtil Class See Also Send Feedback
Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int ParseInt(
    char[] chars
)
Visual Basic
Public Shared Function ParseInt ( _
    chars As Char() _
) As Integer
Visual C++
public:
static int ParseInt(
    array<wchar_t>^ chars
)

Parameters

chars
Type: array< System..::..Char >[]()[][]
a string representation of an int quantity.

Return Value

int the value represented by the argument

See Also

ArrayUtil Class
ParseInt Overload
Lucene.Net.Util Namespace


ParseInt Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..ParseInt Method (array<Char>[]()[][], Int32, Int32)
ArrayUtil Class See Also Send Feedback
Parses a char array into an int.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int ParseInt(
    char[] chars,
    int offset,
    int len
)
Visual Basic
Public Shared Function ParseInt ( _
    chars As Char(), _
    offset As Integer, _
    len As Integer _
) As Integer
Visual C++
public:
static int ParseInt(
    array<wchar_t>^ chars,
    int offset,
    int len
)

Parameters

chars
Type: array< System..::..Char >[]()[][]
the character array
offset
Type: System..::..Int32
The offset into the array
len
Type: System..::..Int32
The length

Return Value

the int

See Also

ArrayUtil Class
ParseInt Overload
Lucene.Net.Util Namespace


ParseInt Method (Char[], Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..ParseInt Method (array<Char>[]()[][], Int32, Int32, Int32)
ArrayUtil Class See Also Send Feedback
Parses the string argument as if it was an int value and returns the result. Throws NumberFormatException if the string does not represent an int quantity. The second argument specifies the radix to use when parsing the value.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int ParseInt(
    char[] chars,
    int offset,
    int len,
    int radix
)
Visual Basic
Public Shared Function ParseInt ( _
    chars As Char(), _
    offset As Integer, _
    len As Integer, _
    radix As Integer _
) As Integer
Visual C++
public:
static int ParseInt(
    array<wchar_t>^ chars,
    int offset,
    int len,
    int radix
)

Parameters

chars
Type: array< System..::..Char >[]()[][]
a string representation of an int quantity.
offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Util.ArrayUtil.ParseInt(System.Char[],System.Int32,System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Util.ArrayUtil.ParseInt(System.Char[],System.Int32,System.Int32,System.Int32)"]

radix
Type: System..::..Int32
the base to use for conversion.

Return Value

int the value represented by the argument

See Also

ArrayUtil Class
ParseInt Overload
Lucene.Net.Util Namespace


Shrink Method

[image] [image]

Lucene.Net Class Libraries
ArrayUtil..::..Shrink Method
ArrayUtil Class See Also Send Feedback

Overload List

Name | Description
Shrink(array<Byte>[]()[][], Int32) |
Shrink(array<Int32>[]()[][], Int32) |
Shrink(array<Int64>[]()[][], Int32) |

See Also

ArrayUtil Class
ArrayUtil Members
Lucene.Net.Util Namespace


Shrink Method (Byte[], Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Shrink Method (array<Byte>[]()[][], Int32)
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Byte[],System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static byte[] Shrink(
    byte[] array,
    int targetSize
)
Visual Basic
Public Shared Function Shrink ( _
    array As Byte(), _
    targetSize As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Shrink(
    array<unsigned char>^ array,
    int targetSize
)

Parameters

array
Type: array< System..::..Byte >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Byte[],System.Int32)"]

targetSize
Type: System..::..Int32

[Missing <param name="targetSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Byte[],System.Int32)"]

See Also

ArrayUtil Class
Shrink Overload
Lucene.Net.Util Namespace


Shrink Method (Int32[], Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Shrink Method (array<Int32>[]()[][], Int32)
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int32[],System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int[] Shrink(
    int[] array,
    int targetSize
)
Visual Basic
Public Shared Function Shrink ( _
    array As Integer(), _
    targetSize As Integer _
) As Integer()
Visual C++
public:
static array<int>^ Shrink(
    array<int>^ array,
    int targetSize
)

Parameters

array
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int32[],System.Int32)"]

targetSize
Type: System..::..Int32

[Missing <param name="targetSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int32[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int32[],System.Int32)"]

See Also

ArrayUtil Class
Shrink Overload
Lucene.Net.Util Namespace


Shrink Method (Int64[], Int32)

[image]

Lucene.Net Class Libraries
ArrayUtil..::..Shrink Method (array<Int64>[]()[][], Int32)
ArrayUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int64[],System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long[] Shrink(
    long[] array,
    int targetSize
)
Visual Basic
Public Shared Function Shrink ( _
    array As Long(), _
    targetSize As Integer _
) As Long()
Visual C++
public:
static array<long long>^ Shrink(
    array<long long>^ array,
    int targetSize
)

Parameters

array
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="array"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int64[],System.Int32)"]

targetSize
Type: System..::..Int32

[Missing <param name="targetSize"/> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int64[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ArrayUtil.Shrink(System.Int64[],System.Int32)"]

See Also

ArrayUtil Class
Shrink Overload
Lucene.Net.Util Namespace


Attribute Interface

[image]

Lucene.Net Class Libraries
Attribute Interface
See Also Send Feedback
Base interface for attributes.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public interface Attribute
Visual Basic
Public Interface Attribute
Visual C++
public interface class Attribute

See Also

Lucene.Net.Util Namespace


AttributeImpl Class

[image]

Lucene.Net Class Libraries
AttributeImpl Class
Members See Also Send Feedback
Base class for Attributes that can be added to a {@link Lucene.Net.Util.AttributeSource}.

Attributes are used to add data in a dynamic, yet type-safe way to a source of usually streamed objects, e. g. a {@link Lucene.Net.Analysis.TokenStream}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class AttributeImpl : ICloneable,
    Attribute
Visual Basic
<SerializableAttribute> _
Public MustInherit Class AttributeImpl _
    Implements ICloneable, Attribute
Visual C++
[SerializableAttribute]
public ref class AttributeImpl abstract : ICloneable,
    Attribute

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeImpl
Lucene.Net.Analysis..::..Token
Lucene.Net.Analysis.Tokenattributes..::..FlagsAttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..OffsetAttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..PayloadAttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..PositionIncrementAttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..TermAttributeImpl
Lucene.Net.Analysis.Tokenattributes..::..TypeAttributeImpl
Lucene.Net.Analysis..::..TokenWrapper

See Also

AttributeImpl Members
Lucene.Net.Util Namespace


AttributeImpl Members

[image] [image]

Lucene.Net Class Libraries
AttributeImpl Members
AttributeImpl Class Constructors Methods See Also Send Feedback

The AttributeImpl type exposes the following members.

Constructors

 | Name | Description
Protected method | AttributeImpl | Initializes a new instance of the AttributeImpl class

Methods

Name Description
Public method Clear
Clears the values in this AttributeImpl and resets it to its default value. If this implementation implements more than one Attribute interface it clears all.
Public method Clone
Shallow clone. Subclasses must override this if they need to clone any members deeply,
Public method CopyTo
Copies the values from this Attribute into the passed-in target attribute. The target implementation must support all the Attributes this implementation supports.
Public method Equals
All values used for computation of {@link #hashCode()} should be checked here for equality. see also {@link Object#equals(Object)}
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Subclasses must implement this method and should compute a hashCode similar to this:
            public int hashCode() {
            int code = startOffset;
            code = code * 31 + endOffset;
            return code;
            }
see also {@link #equals(Object)}
(Overrides Object..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Overrides Object..::..ToString()()()().)

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


AttributeImpl Constructor

[image]

Lucene.Net Class Libraries
AttributeImpl Constructor
AttributeImpl Class See Also Send Feedback
Initializes a new instance of the AttributeImpl class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected AttributeImpl()
Visual Basic
Protected Sub New
Visual C++
protected:
AttributeImpl()

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


AttributeImpl Methods

[image] [image]

Lucene.Net Class Libraries
AttributeImpl Methods
AttributeImpl Class See Also Send Feedback

The AttributeImpl type exposes the following members.

Methods

Name Description
Public method Clear
Clears the values in this AttributeImpl and resets it to its default value. If this implementation implements more than one Attribute interface it clears all.
Public method Clone
Shallow clone. Subclasses must override this if they need to clone any members deeply,
Public method CopyTo
Copies the values from this Attribute into the passed-in target attribute. The target implementation must support all the Attributes this implementation supports.
Public method Equals
All values used for computation of {@link #hashCode()} should be checked here for equality. see also {@link Object#equals(Object)}
(Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Subclasses must implement this method and should compute a hashCode similar to this:
            public int hashCode() {
            int code = startOffset;
            code = code * 31 + endOffset;
            return code;
            }
see also {@link #equals(Object)}
(Overrides Object..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.
(Overrides Object..::..ToString()()()().)

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


Clear Method

[image]

Lucene.Net Class Libraries
AttributeImpl..::..Clear Method
AttributeImpl Class See Also Send Feedback
Clears the values in this AttributeImpl and resets it to its default value. If this implementation implements more than one Attribute interface it clears all.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Clear()
Visual Basic
Public MustOverride Sub Clear
Visual C++
public:
virtual void Clear() abstract

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


Clone Method

[image]

Lucene.Net Class Libraries
AttributeImpl..::..Clone Method
AttributeImpl Class See Also Send Feedback
Shallow clone. Subclasses must override this if they need to clone any members deeply,

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeImpl.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


CopyTo Method

[image]

Lucene.Net Class Libraries
AttributeImpl..::..CopyTo Method
AttributeImpl Class See Also Send Feedback
Copies the values from this Attribute into the passed-in target attribute. The target implementation must support all the Attributes this implementation supports.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void CopyTo(
    AttributeImpl target
)
Visual Basic
Public MustOverride Sub CopyTo ( _
    target As AttributeImpl _
)
Visual C++
public:
virtual void CopyTo(
    AttributeImpl^ target
) abstract

Parameters

target
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="target"/> documentation for "M:Lucene.Net.Util.AttributeImpl.CopyTo(Lucene.Net.Util.AttributeImpl)"]

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


Equals Method

[image]

Lucene.Net Class Libraries
AttributeImpl..::..Equals Method
AttributeImpl Class See Also Send Feedback
All values used for computation of {@link #hashCode()} should be checked here for equality. see also {@link Object#equals(Object)}

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool Equals(
    Object other
)
Visual Basic
Public MustOverride Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) abstract override

Parameters

other
Type: System..::..Object

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.AttributeImpl.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeImpl.Equals(System.Object)"]

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
AttributeImpl..::..GetHashCode Method
AttributeImpl Class See Also Send Feedback
Subclasses must implement this method and should compute a hashCode similar to this:
            public int hashCode() {
            int code = startOffset;
            code = code * 31 + endOffset;
            return code;
            }
see also {@link #equals(Object)}

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetHashCode()
Visual Basic
Public MustOverride Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() abstract override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeImpl.GetHashCode"]

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


ToString Method

[image]

Lucene.Net Class Libraries
AttributeImpl..::..ToString Method
AttributeImpl Class See Also Send Feedback
The default implementation of this method accesses all declared fields of this object and prints the values in the following syntax:
            public String toString() {
            return "start=" + startOffset + ",end=" + endOffset;
            }
This method may be overridden by subclasses.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeImpl.ToString"]

See Also

AttributeImpl Class
Lucene.Net.Util Namespace


AttributeSource Class

[image]

Lucene.Net Class Libraries
AttributeSource Class
Members See Also Send Feedback
An AttributeSource contains a list of different {@link AttributeImpl}s, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the {@link #AddAttribute(Class)}, which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class AttributeSource
Visual Basic
Public Class AttributeSource
Visual C++
public ref class AttributeSource

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource
Lucene.Net.Analysis..::..TokenStream

See Also

AttributeSource Members
Lucene.Net.Util Namespace


AttributeSource Members

[image] [image]

Lucene.Net Class Libraries
AttributeSource Members
AttributeSource Class Constructors Methods See Also Send Feedback

The AttributeSource type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeSource()()()() | An AttributeSource using the default attribute factory {@link AttributeSource.AttributeFactory#DEFAULT_ATTRIBUTE_FACTORY}.
Public method | AttributeSource(AttributeSource) | An AttributeSource that uses the same attributes as the supplied one.
Public method | AttributeSource(AttributeSource..::..AttributeFactory) | An AttributeSource using the supplied {@link AttributeFactory} for creating new {@link Attribute} instances.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
Public method GetAttributeFactory
returns the used AttributeFactory.
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

AttributeSource Class
Lucene.Net.Util Namespace


AttributeSource Constructor

[image] [image]

Lucene.Net Class Libraries
AttributeSource Constructor
AttributeSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttributeSource()()()() | An AttributeSource using the default attribute factory {@link AttributeSource.AttributeFactory#DEFAULT_ATTRIBUTE_FACTORY}.
Public method | AttributeSource(AttributeSource) | An AttributeSource that uses the same attributes as the supplied one.
Public method | AttributeSource(AttributeSource..::..AttributeFactory) | An AttributeSource using the supplied {@link AttributeFactory} for creating new {@link Attribute} instances.

See Also

AttributeSource Class
AttributeSource Members
Lucene.Net.Util Namespace


AttributeSource Constructor

[image]

Lucene.Net Class Libraries
AttributeSource Constructor
AttributeSource Class See Also Send Feedback
An AttributeSource using the default attribute factory {@link AttributeSource.AttributeFactory#DEFAULT_ATTRIBUTE_FACTORY}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AttributeSource()
Visual Basic
Public Sub New
Visual C++
public:
AttributeSource()

See Also

AttributeSource Class
AttributeSource Overload
Lucene.Net.Util Namespace


AttributeSource Constructor (AttributeSource)

[image]

Lucene.Net Class Libraries
AttributeSource Constructor (AttributeSource)
AttributeSource Class See Also Send Feedback
An AttributeSource that uses the same attributes as the supplied one.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AttributeSource(
    AttributeSource input
)
Visual Basic
Public Sub New ( _
    input As AttributeSource _
)
Visual C++
public:
AttributeSource(
    AttributeSource^ input
)

Parameters

input
Type: Lucene.Net.Util..::..AttributeSource

[Missing <param name="input"/> documentation for "M:Lucene.Net.Util.AttributeSource.#ctor(Lucene.Net.Util.AttributeSource)"]

See Also

AttributeSource Class
AttributeSource Overload
Lucene.Net.Util Namespace


AttributeSource Constructor (AttributeSource.AttributeFactory)

[image]

Lucene.Net Class Libraries
AttributeSource Constructor (AttributeSource..::..AttributeFactory)
AttributeSource Class See Also Send Feedback
An AttributeSource using the supplied {@link AttributeFactory} for creating new {@link Attribute} instances.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AttributeSource(
    AttributeSource..::..AttributeFactory factory
)
Visual Basic
Public Sub New ( _
    factory As AttributeSource..::..AttributeFactory _
)
Visual C++
public:
AttributeSource(
    AttributeSource..::..AttributeFactory^ factory
)

Parameters

factory
Type: Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

[Missing <param name="factory"/> documentation for "M:Lucene.Net.Util.AttributeSource.#ctor(Lucene.Net.Util.AttributeSource.AttributeFactory)"]

See Also

AttributeSource Class
AttributeSource Overload
Lucene.Net.Util Namespace


AttributeSource Methods

[image] [image]

Lucene.Net Class Libraries
AttributeSource Methods
AttributeSource Class See Also Send Feedback

The AttributeSource type exposes the following members.

Methods

Name | Description
Public method AddAttribute
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)
Public method AddAttributeImpl
Adds a custom AttributeImpl instance with one or more Attribute interfaces.
Public method CaptureState
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.
Public method ClearAttributes
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.
Public method CloneAttributes
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetAttribute
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
Public method GetAttributeClassesIterator
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys
Public method GetAttributeFactory
returns the used AttributeFactory.
Public method GetAttributeImplsIterator
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasAttribute
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)
Public method HasAttributes
Returns true, iff this AttributeSource has any attributes
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method RestoreState
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

AttributeSource Class
Lucene.Net.Util Namespace


AddAttribute Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..AddAttribute Method
AttributeSource Class See Also Send Feedback
The caller must pass in a Class<? extends Attribute> value. This method first checks if an instance of that class is already in this AttributeSource and returns it. Otherwise a new instance is created, added to this AttributeSource and returned. Signature for Java 1.5:
CopyC#
public <T extends Attribute> T addAttribute(Class<T>)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Attribute AddAttribute(
    Type attClass
)
Visual Basic
Public Overridable Function AddAttribute ( _
    attClass As Type _
) As Attribute
Visual C++
public:
virtual Attribute^ AddAttribute(
    Type^ attClass
)

Parameters

attClass
Type: System..::..Type

[Missing <param name="attClass"/> documentation for "M:Lucene.Net.Util.AttributeSource.AddAttribute(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.AddAttribute(System.Type)"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


AddAttributeImpl Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..AddAttributeImpl Method
AttributeSource Class See Also Send Feedback
Adds a custom AttributeImpl instance with one or more Attribute interfaces.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddAttributeImpl(
    AttributeImpl att
)
Visual Basic
Public Overridable Sub AddAttributeImpl ( _
    att As AttributeImpl _
)
Visual C++
public:
virtual void AddAttributeImpl(
    AttributeImpl^ att
)

Parameters

att
Type: Lucene.Net.Util..::..AttributeImpl

[Missing <param name="att"/> documentation for "M:Lucene.Net.Util.AttributeSource.AddAttributeImpl(Lucene.Net.Util.AttributeImpl)"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


CaptureState Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..CaptureState Method
AttributeSource Class See Also Send Feedback
Captures the state of all Attributes. The return value can be passed to {@link #restoreState} to restore the state of this or another AttributeSource.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual AttributeSource..::..State CaptureState()
Visual Basic
Public Overridable Function CaptureState As AttributeSource..::..State
Visual C++
public:
virtual AttributeSource..::..State^ CaptureState()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.CaptureState"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


ClearAttributes Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..ClearAttributes Method
AttributeSource Class See Also Send Feedback
Resets all Attributes in this AttributeSource by calling {@link AttributeImpl#Clear()} on each Attribute implementation.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void ClearAttributes()
Visual Basic
Public Overridable Sub ClearAttributes
Visual C++
public:
virtual void ClearAttributes()

See Also

AttributeSource Class
Lucene.Net.Util Namespace


CloneAttributes Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..CloneAttributes Method
AttributeSource Class See Also Send Feedback
Performs a clone of all {@link AttributeImpl} instances returned in a new AttributeSource instance. This method can be used to e.g. create another TokenStream with exactly the same attributes (using {@link #AttributeSource(AttributeSource)})

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual AttributeSource CloneAttributes()
Visual Basic
Public Overridable Function CloneAttributes As AttributeSource
Visual C++
public:
virtual AttributeSource^ CloneAttributes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.CloneAttributes"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


Equals Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..Equals Method
AttributeSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AttributeSource.Equals(System.Object)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Util.AttributeSource.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.Equals(System.Object)"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


GetAttribute Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..GetAttribute Method
AttributeSource Class See Also Send Feedback
The caller must pass in a Class<? extends Attribute> value. Returns the instance of the passed in Attribute contained in this AttributeSource Signature for Java 1.5:
CopyC#
public <T extends Attribute> T getAttribute(Class<T>)
Attribute. It is recommended to always use {@link #addAttribute} even in consumers of TokenStreams, because you cannot know if a specific TokenStream really uses a specific Attribute. {@link #addAttribute} will automatically make the attribute available. If you want to only use the attribute, if it is available (to optimize consuming), use {@link #hasAttribute}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Attribute GetAttribute(
    Type attClass
)
Visual Basic
Public Overridable Function GetAttribute ( _
    attClass As Type _
) As Attribute
Visual C++
public:
virtual Attribute^ GetAttribute(
    Type^ attClass
)

Parameters

attClass
Type: System..::..Type

[Missing <param name="attClass"/> documentation for "M:Lucene.Net.Util.AttributeSource.GetAttribute(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.GetAttribute(System.Type)"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


GetAttributeClassesIterator Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..GetAttributeClassesIterator Method
AttributeSource Class See Also Send Feedback
Returns a new iterator that iterates the attribute classes in the same order they were added in. Signature for Java 1.5:
CopyC#
public Iterator<Class<? extends Attribute>> getAttributeClassesIterator()
 Note that this return value is different from Java in that it enumerates over the values and not the keys

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IEnumerable<Type> GetAttributeClassesIterator()
Visual Basic
Public Overridable Function GetAttributeClassesIterator As IEnumerable(Of Type)
Visual C++
public:
virtual IEnumerable<Type^>^ GetAttributeClassesIterator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.GetAttributeClassesIterator"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


GetAttributeFactory Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..GetAttributeFactory Method
AttributeSource Class See Also Send Feedback
returns the used AttributeFactory.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual AttributeSource..::..AttributeFactory GetAttributeFactory()
Visual Basic
Public Overridable Function GetAttributeFactory As AttributeSource..::..AttributeFactory
Visual C++
public:
virtual AttributeSource..::..AttributeFactory^ GetAttributeFactory()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.GetAttributeFactory"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


GetAttributeImplsIterator Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..GetAttributeImplsIterator Method
AttributeSource Class See Also Send Feedback
Returns a new iterator that iterates all unique Attribute implementations. This iterator may contain less entries that {@link #getAttributeClassesIterator}, if one instance implements more than one Attribute interface. Signature for Java 1.5:
CopyC#
public Iterator<AttributeImpl> getAttributeImplsIterator()

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IEnumerable<AttributeImpl> GetAttributeImplsIterator()
Visual Basic
Public Overridable Function GetAttributeImplsIterator As IEnumerable(Of AttributeImpl)
Visual C++
public:
virtual IEnumerable<AttributeImpl^>^ GetAttributeImplsIterator()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.GetAttributeImplsIterator"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..GetHashCode Method
AttributeSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AttributeSource.GetHashCode"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.GetHashCode"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


HasAttribute Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..HasAttribute Method
AttributeSource Class See Also Send Feedback
The caller must pass in a Class<? extends Attribute> value. Returns true, iff this AttributeSource contains the passed-in Attribute. Signature for Java 1.5:
CopyC#
public boolean hasAttribute(Class<? extends Attribute>)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool HasAttribute(
    Type attClass
)
Visual Basic
Public Overridable Function HasAttribute ( _
    attClass As Type _
) As Boolean
Visual C++
public:
virtual bool HasAttribute(
    Type^ attClass
)

Parameters

attClass
Type: System..::..Type

[Missing <param name="attClass"/> documentation for "M:Lucene.Net.Util.AttributeSource.HasAttribute(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.HasAttribute(System.Type)"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


HasAttributes Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..HasAttributes Method
AttributeSource Class See Also Send Feedback
Returns true, iff this AttributeSource has any attributes

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool HasAttributes()
Visual Basic
Public Overridable Function HasAttributes As Boolean
Visual C++
public:
virtual bool HasAttributes()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.HasAttributes"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


RestoreState Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..RestoreState Method
AttributeSource Class See Also Send Feedback
Restores this state by copying the values of all attribute implementations that this state contains into the attributes implementations of the targetStream. The targetStream must contain a corresponding instance for each argument contained in this state (e.g. it is not possible to restore the state of an AttributeSource containing a TermAttribute into a AttributeSource using a Token instance as implementation). Note that this method does not affect attributes of the targetStream that are not contained in this state. In other words, if for example the targetStream contains an OffsetAttribute, but this state doesn't, then the value of the OffsetAttribute remains unchanged. It might be desirable to reset its value to the default, in which case the caller should first call {@link TokenStream#ClearAttributes()} on the targetStream.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void RestoreState(
    AttributeSource..::..State state
)
Visual Basic
Public Overridable Sub RestoreState ( _
    state As AttributeSource..::..State _
)
Visual C++
public:
virtual void RestoreState(
    AttributeSource..::..State^ state
)

Parameters

state
Type: Lucene.Net.Util..::..AttributeSource..::..State

[Missing <param name="state"/> documentation for "M:Lucene.Net.Util.AttributeSource.RestoreState(Lucene.Net.Util.AttributeSource.State)"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


ToString Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..ToString Method
AttributeSource Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AttributeSource.ToString"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.ToString"]

See Also

AttributeSource Class
Lucene.Net.Util Namespace


AttributeSource.AttributeFactory Class

[image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory Class
AttributeSource Class Members See Also Send Feedback
An AttributeFactory creates instances of {@link AttributeImpl}s.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class AttributeFactory
Visual Basic
Public MustInherit Class AttributeFactory
Visual C++
public ref class AttributeFactory abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource..::..AttributeFactory

See Also

AttributeSource..::..AttributeFactory Members
Lucene.Net.Util Namespace


AttributeSource.AttributeFactory Members

[image] [image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory Members
AttributeSource..::..AttributeFactory Class Constructors Methods Fields See Also Send Feedback

An AttributeSource contains a list of different {@link AttributeImpl}s, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the {@link #AddAttribute(Class)}, which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.

The AttributeSource..::..AttributeFactory type exposes the following members.

Constructors

 | Name | Description
Protected method | AttributeSource..::..AttributeFactory | Initializes a new instance of the AttributeSource..::..AttributeFactory class

Methods

Name Description
Public method CreateAttributeInstance
returns an {@link AttributeImpl} for the supplied {@link Attribute} interface class.

Signature for Java 1.5:

CopyC#
public AttributeImpl createAttributeInstance(Class%lt;? extends Attribute> attClass)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name Description
DEFAULT_ATTRIBUTE_FACTORY
This is the default factory that creates {@link AttributeImpl}s using the class name of the supplied {@link Attribute} interface class by appending
CopyC#
Impl
 to it.

See Also

AttributeSource..::..AttributeFactory Class
Lucene.Net.Util Namespace


AttributeSource.AttributeFactory Constructor

[image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory Constructor
AttributeSource..::..AttributeFactory Class See Also Send Feedback
Initializes a new instance of the AttributeSource..::..AttributeFactory class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected AttributeFactory()
Visual Basic
Protected Sub New
Visual C++
protected:
AttributeFactory()

See Also

AttributeSource..::..AttributeFactory Class
Lucene.Net.Util Namespace


AttributeSource.AttributeFactory Fields

[image] [image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory Fields
AttributeSource..::..AttributeFactory Class See Also Send Feedback

The AttributeSource..::..AttributeFactory type exposes the following members.

Fields

Name Description
DEFAULT_ATTRIBUTE_FACTORY
This is the default factory that creates {@link AttributeImpl}s using the class name of the supplied {@link Attribute} interface class by appending
CopyC#
Impl
 to it.

See Also

AttributeSource..::..AttributeFactory Class
Lucene.Net.Util Namespace


DEFAULT_ATTRIBUTE_FACTORY Field

[image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory..::..DEFAULT_ATTRIBUTE_FACTORY Field
AttributeSource..::..AttributeFactory Class See Also Send Feedback
This is the default factory that creates {@link AttributeImpl}s using the class name of the supplied {@link Attribute} interface class by appending
CopyC#
Impl
 to it.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly AttributeSource..::..AttributeFactory DEFAULT_ATTRIBUTE_FACTORY
Visual Basic
Public Shared ReadOnly DEFAULT_ATTRIBUTE_FACTORY As AttributeSource..::..AttributeFactory
Visual C++
public:
static initonly AttributeSource..::..AttributeFactory^ DEFAULT_ATTRIBUTE_FACTORY

See Also

AttributeSource..::..AttributeFactory Class
Lucene.Net.Util Namespace


AttributeSource.AttributeFactory Methods

[image] [image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory Methods
AttributeSource..::..AttributeFactory Class See Also Send Feedback

The AttributeSource..::..AttributeFactory type exposes the following members.

Methods

Name Description
Public method CreateAttributeInstance
returns an {@link AttributeImpl} for the supplied {@link Attribute} interface class.

Signature for Java 1.5:

CopyC#
public AttributeImpl createAttributeInstance(Class%lt;? extends Attribute> attClass)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

AttributeSource..::..AttributeFactory Class
Lucene.Net.Util Namespace


CreateAttributeInstance Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..AttributeFactory..::..CreateAttributeInstance Method
AttributeSource..::..AttributeFactory Class See Also Send Feedback
returns an {@link AttributeImpl} for the supplied {@link Attribute} interface class.

Signature for Java 1.5:

CopyC#
public AttributeImpl createAttributeInstance(Class%lt;? extends Attribute> attClass)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract AttributeImpl CreateAttributeInstance(
    Type attClass
)
Visual Basic
Public MustOverride Function CreateAttributeInstance ( _
    attClass As Type _
) As AttributeImpl
Visual C++
public:
virtual AttributeImpl^ CreateAttributeInstance(
    Type^ attClass
) abstract

Parameters

attClass
Type: System..::..Type

[Missing <param name="attClass"/> documentation for "M:Lucene.Net.Util.AttributeSource.AttributeFactory.CreateAttributeInstance(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.AttributeFactory.CreateAttributeInstance(System.Type)"]

See Also

AttributeSource..::..AttributeFactory Class
Lucene.Net.Util Namespace


AttributeSource.State Class

[image]

Lucene.Net Class Libraries
AttributeSource..::..State Class
AttributeSource Class Members See Also Send Feedback
This class holds the state of an AttributeSource.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class State : ICloneable
Visual Basic
Public NotInheritable Class State _
    Implements ICloneable
Visual C++
public ref class State sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..AttributeSource..::..State

See Also

AttributeSource..::..State Members
Lucene.Net.Util Namespace
[!:captureState]
[!:restoreState]


AttributeSource.State Members

[image] [image]

Lucene.Net Class Libraries
AttributeSource..::..State Members
AttributeSource..::..State Class Constructors Methods See Also Send Feedback

An AttributeSource contains a list of different {@link AttributeImpl}s, and methods to add and get them. There can only be a single instance of an attribute in the same AttributeSource instance. This is ensured by passing in the actual type of the Attribute (Class<Attribute>) to the {@link #AddAttribute(Class)}, which then checks if an instance of that type is already present. If yes, it returns the instance, otherwise it creates a new instance and returns it.

The AttributeSource..::..State type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeSource..::..State | Initializes a new instance of the AttributeSource..::..State class

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributeSource..::..State Class
Lucene.Net.Util Namespace


AttributeSource.State Constructor

[image]

Lucene.Net Class Libraries
AttributeSource..::..State Constructor
AttributeSource..::..State Class See Also Send Feedback
Initializes a new instance of the AttributeSource..::..State class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public State()
Visual Basic
Public Sub New
Visual C++
public:
State()

See Also

AttributeSource..::..State Class
Lucene.Net.Util Namespace


AttributeSource.State Methods

[image] [image]

Lucene.Net Class Libraries
AttributeSource..::..State Methods
AttributeSource..::..State Class See Also Send Feedback

The AttributeSource..::..State type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributeSource..::..State Class
Lucene.Net.Util Namespace


Clone Method

[image]

Lucene.Net Class Libraries
AttributeSource..::..State..::..Clone Method
AttributeSource..::..State Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AttributeSource.State.Clone"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AttributeSource.State.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

AttributeSource..::..State Class
Lucene.Net.Util Namespace


AverageGuessMemoryModel Class

[image]

Lucene.Net Class Libraries
AverageGuessMemoryModel Class
Members See Also Send Feedback
An average, best guess, MemoryModel that should work okay on most systems.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class AverageGuessMemoryModel : MemoryModel
Visual Basic
Public Class AverageGuessMemoryModel _
    Inherits MemoryModel
Visual C++
public ref class AverageGuessMemoryModel : public MemoryModel

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..MemoryModel
Lucene.Net.Util..::..AverageGuessMemoryModel

See Also

AverageGuessMemoryModel Members
Lucene.Net.Util Namespace


AverageGuessMemoryModel Members

[image] [image]

Lucene.Net Class Libraries
AverageGuessMemoryModel Members
AverageGuessMemoryModel Class Constructors Methods See Also Send Feedback

The AverageGuessMemoryModel type exposes the following members.

Constructors

 | Name | Description
Public method | AverageGuessMemoryModel | Initializes a new instance of the AverageGuessMemoryModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArraySize | (Overrides MemoryModel..::..GetArraySize()()()().)
Public method | GetClassSize | (Overrides MemoryModel..::..GetClassSize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrimitiveSize | (Overrides MemoryModel..::..GetPrimitiveSize(Type).)
Public method | GetReferenceSize | (Overrides MemoryModel..::..GetReferenceSize()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


AverageGuessMemoryModel Constructor

[image]

Lucene.Net Class Libraries
AverageGuessMemoryModel Constructor
AverageGuessMemoryModel Class See Also Send Feedback
Initializes a new instance of the AverageGuessMemoryModel class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public AverageGuessMemoryModel()
Visual Basic
Public Sub New
Visual C++
public:
AverageGuessMemoryModel()

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


AverageGuessMemoryModel Methods

[image] [image]

Lucene.Net Class Libraries
AverageGuessMemoryModel Methods
AverageGuessMemoryModel Class See Also Send Feedback

The AverageGuessMemoryModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArraySize | (Overrides MemoryModel..::..GetArraySize()()()().)
Public method | GetClassSize | (Overrides MemoryModel..::..GetClassSize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrimitiveSize | (Overrides MemoryModel..::..GetPrimitiveSize(Type).)
Public method | GetReferenceSize | (Overrides MemoryModel..::..GetReferenceSize()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


GetArraySize Method

[image]

Lucene.Net Class Libraries
AverageGuessMemoryModel..::..GetArraySize Method
AverageGuessMemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetArraySize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetArraySize()
Visual Basic
Public Overrides Function GetArraySize As Integer
Visual C++
public:
virtual int GetArraySize() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetArraySize"]

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


GetClassSize Method

[image]

Lucene.Net Class Libraries
AverageGuessMemoryModel..::..GetClassSize Method
AverageGuessMemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetClassSize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetClassSize()
Visual Basic
Public Overrides Function GetClassSize As Integer
Visual C++
public:
virtual int GetClassSize() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetClassSize"]

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


GetPrimitiveSize Method

[image]

Lucene.Net Class Libraries
AverageGuessMemoryModel..::..GetPrimitiveSize Method
AverageGuessMemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetPrimitiveSize(System.Type)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetPrimitiveSize(
    Type clazz
)
Visual Basic
Public Overrides Function GetPrimitiveSize ( _
    clazz As Type _
) As Integer
Visual C++
public:
virtual int GetPrimitiveSize(
    Type^ clazz
) override

Parameters

clazz
Type: System..::..Type

[Missing <param name="clazz"/> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetPrimitiveSize(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetPrimitiveSize(System.Type)"]

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


GetReferenceSize Method

[image]

Lucene.Net Class Libraries
AverageGuessMemoryModel..::..GetReferenceSize Method
AverageGuessMemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetReferenceSize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetReferenceSize()
Visual Basic
Public Overrides Function GetReferenceSize As Integer
Visual C++
public:
virtual int GetReferenceSize() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.AverageGuessMemoryModel.GetReferenceSize"]

See Also

AverageGuessMemoryModel Class
Lucene.Net.Util Namespace


BitUtil Class

[image]

Lucene.Net Class Libraries
BitUtil Class
Members See Also Send Feedback
A variety of high efficiencly bit twiddling routines.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class BitUtil
Visual Basic
Public Class BitUtil
Visual C++
public ref class BitUtil

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..BitUtil

See Also

BitUtil Members
Lucene.Net.Util Namespace


BitUtil Members

[image] [image]

Lucene.Net Class Libraries
BitUtil Members
BitUtil Class Constructors Methods Fields See Also Send Feedback

The BitUtil type exposes the following members.

Constructors

 | Name | Description
Public method | BitUtil | Initializes a new instance of the BitUtil class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPowerOfTwo(Int32) | returns true if v is a power of two or zero
 | IsPowerOfTwo(Int64) | returns true if v is a power of two or zero
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextHighestPowerOfTwo(Int32) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | NextHighestPowerOfTwo(Int64) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | Ntz(Int32) | Returns number of trailing zeros in a 32 bit int value.
 | Ntz(Int64) | Returns number of trailing zeros in a 64 bit long value.
 | Ntz2 | returns 0 based index of first set bit (only works for x!=0) This is an alternate implementation of ntz()
 | Ntz3 | returns 0 based index of first set bit This is an alternate implementation of ntz()
 | Pop | Returns the number of bits set in the long
 | Pop_andnot | Returns the popcount or cardinality of A & ~B Neither array is modified.
 | Pop_array | Returns the number of set bits in an array of longs.
 | Pop_intersect | Returns the popcount or cardinality of the two sets after an intersection. Neither array is modified.
 | Pop_union | Returns the popcount or cardinality of the union of two sets. Neither array is modified.
 | Pop_xor |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ntzTable | table of number of trailing zeros in a byte

See Also

BitUtil Class
Lucene.Net.Util Namespace


BitUtil Constructor

[image]

Lucene.Net Class Libraries
BitUtil Constructor
BitUtil Class See Also Send Feedback
Initializes a new instance of the BitUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BitUtil()
Visual Basic
Public Sub New
Visual C++
public:
BitUtil()

See Also

BitUtil Class
Lucene.Net.Util Namespace


BitUtil Fields

[image] [image]

Lucene.Net Class Libraries
BitUtil Fields
BitUtil Class See Also Send Feedback

The BitUtil type exposes the following members.

Fields

Name | Description
ntzTable | table of number of trailing zeros in a byte

See Also

BitUtil Class
Lucene.Net.Util Namespace


ntzTable Field

[image]

Lucene.Net Class Libraries
BitUtil..::..ntzTable Field
BitUtil Class See Also Send Feedback
table of number of trailing zeros in a byte

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly sbyte[] ntzTable
Visual Basic
Public Shared ReadOnly ntzTable As SByte()
Visual C++
public:
static initonly array<signed char>^ ntzTable

See Also

BitUtil Class
Lucene.Net.Util Namespace


BitUtil Methods

[image] [image]

Lucene.Net Class Libraries
BitUtil Methods
BitUtil Class See Also Send Feedback

The BitUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPowerOfTwo(Int32) | returns true if v is a power of two or zero
 | IsPowerOfTwo(Int64) | returns true if v is a power of two or zero
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextHighestPowerOfTwo(Int32) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | NextHighestPowerOfTwo(Int64) | returns the next highest power of two, or the current value if it's already a power of two or zero
 | Ntz(Int32) | Returns number of trailing zeros in a 32 bit int value.
 | Ntz(Int64) | Returns number of trailing zeros in a 64 bit long value.
 | Ntz2 | returns 0 based index of first set bit (only works for x!=0) This is an alternate implementation of ntz()
 | Ntz3 | returns 0 based index of first set bit This is an alternate implementation of ntz()
 | Pop | Returns the number of bits set in the long
 | Pop_andnot | Returns the popcount or cardinality of A & ~B Neither array is modified.
 | Pop_array | Returns the number of set bits in an array of longs.
 | Pop_intersect | Returns the popcount or cardinality of the two sets after an intersection. Neither array is modified.
 | Pop_union | Returns the popcount or cardinality of the union of two sets. Neither array is modified.
 | Pop_xor |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitUtil Class
Lucene.Net.Util Namespace


IsPowerOfTwo Method

[image] [image]

Lucene.Net Class Libraries
BitUtil..::..IsPowerOfTwo Method
BitUtil Class See Also Send Feedback

Overload List

Name | Description
IsPowerOfTwo(Int32) | returns true if v is a power of two or zero
IsPowerOfTwo(Int64) | returns true if v is a power of two or zero

See Also

BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace


IsPowerOfTwo Method (Int32)

[image]

Lucene.Net Class Libraries
BitUtil..::..IsPowerOfTwo Method (Int32)
BitUtil Class See Also Send Feedback
returns true if v is a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool IsPowerOfTwo(
    int v
)
Visual Basic
Public Shared Function IsPowerOfTwo ( _
    v As Integer _
) As Boolean
Visual C++
public:
static bool IsPowerOfTwo(
    int v
)

Parameters

v
Type: System..::..Int32

[Missing <param name="v"/> documentation for "M:Lucene.Net.Util.BitUtil.IsPowerOfTwo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.IsPowerOfTwo(System.Int32)"]

See Also

BitUtil Class
IsPowerOfTwo Overload
Lucene.Net.Util Namespace


IsPowerOfTwo Method (Int64)

[image]

Lucene.Net Class Libraries
BitUtil..::..IsPowerOfTwo Method (Int64)
BitUtil Class See Also Send Feedback
returns true if v is a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool IsPowerOfTwo(
    long v
)
Visual Basic
Public Shared Function IsPowerOfTwo ( _
    v As Long _
) As Boolean
Visual C++
public:
static bool IsPowerOfTwo(
    long long v
)

Parameters

v
Type: System..::..Int64

[Missing <param name="v"/> documentation for "M:Lucene.Net.Util.BitUtil.IsPowerOfTwo(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.IsPowerOfTwo(System.Int64)"]

See Also

BitUtil Class
IsPowerOfTwo Overload
Lucene.Net.Util Namespace


NextHighestPowerOfTwo Method

[image] [image]

Lucene.Net Class Libraries
BitUtil..::..NextHighestPowerOfTwo Method
BitUtil Class See Also Send Feedback

Overload List

Name | Description
NextHighestPowerOfTwo(Int32) | returns the next highest power of two, or the current value if it's already a power of two or zero
NextHighestPowerOfTwo(Int64) | returns the next highest power of two, or the current value if it's already a power of two or zero

See Also

BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace


NextHighestPowerOfTwo Method (Int32)

[image]

Lucene.Net Class Libraries
BitUtil..::..NextHighestPowerOfTwo Method (Int32)
BitUtil Class See Also Send Feedback
returns the next highest power of two, or the current value if it's already a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int NextHighestPowerOfTwo(
    int v
)
Visual Basic
Public Shared Function NextHighestPowerOfTwo ( _
    v As Integer _
) As Integer
Visual C++
public:
static int NextHighestPowerOfTwo(
    int v
)

Parameters

v
Type: System..::..Int32

[Missing <param name="v"/> documentation for "M:Lucene.Net.Util.BitUtil.NextHighestPowerOfTwo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.NextHighestPowerOfTwo(System.Int32)"]

See Also

BitUtil Class
NextHighestPowerOfTwo Overload
Lucene.Net.Util Namespace


NextHighestPowerOfTwo Method (Int64)

[image]

Lucene.Net Class Libraries
BitUtil..::..NextHighestPowerOfTwo Method (Int64)
BitUtil Class See Also Send Feedback
returns the next highest power of two, or the current value if it's already a power of two or zero

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long NextHighestPowerOfTwo(
    long v
)
Visual Basic
Public Shared Function NextHighestPowerOfTwo ( _
    v As Long _
) As Long
Visual C++
public:
static long long NextHighestPowerOfTwo(
    long long v
)

Parameters

v
Type: System..::..Int64

[Missing <param name="v"/> documentation for "M:Lucene.Net.Util.BitUtil.NextHighestPowerOfTwo(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.NextHighestPowerOfTwo(System.Int64)"]

See Also

BitUtil Class
NextHighestPowerOfTwo Overload
Lucene.Net.Util Namespace


Ntz Method

[image] [image]

Lucene.Net Class Libraries
BitUtil..::..Ntz Method
BitUtil Class See Also Send Feedback

Overload List

Name | Description
Ntz(Int32) | Returns number of trailing zeros in a 32 bit int value.
Ntz(Int64) | Returns number of trailing zeros in a 64 bit long value.

See Also

BitUtil Class
BitUtil Members
Lucene.Net.Util Namespace


Ntz Method (Int32)

[image]

Lucene.Net Class Libraries
BitUtil..::..Ntz Method (Int32)
BitUtil Class See Also Send Feedback
Returns number of trailing zeros in a 32 bit int value.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int Ntz(
    int val
)
Visual Basic
Public Shared Function Ntz ( _
    val As Integer _
) As Integer
Visual C++
public:
static int Ntz(
    int val
)

Parameters

val
Type: System..::..Int32

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.BitUtil.Ntz(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Ntz(System.Int32)"]

See Also

BitUtil Class
Ntz Overload
Lucene.Net.Util Namespace


Ntz Method (Int64)

[image]

Lucene.Net Class Libraries
BitUtil..::..Ntz Method (Int64)
BitUtil Class See Also Send Feedback
Returns number of trailing zeros in a 64 bit long value.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int Ntz(
    long val
)
Visual Basic
Public Shared Function Ntz ( _
    val As Long _
) As Integer
Visual C++
public:
static int Ntz(
    long long val
)

Parameters

val
Type: System..::..Int64

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.BitUtil.Ntz(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Ntz(System.Int64)"]

See Also

BitUtil Class
Ntz Overload
Lucene.Net.Util Namespace


Ntz2 Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Ntz2 Method
BitUtil Class See Also Send Feedback
returns 0 based index of first set bit (only works for x!=0)
This is an alternate implementation of ntz()

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int Ntz2(
    long x
)
Visual Basic
Public Shared Function Ntz2 ( _
    x As Long _
) As Integer
Visual C++
public:
static int Ntz2(
    long long x
)

Parameters

x
Type: System..::..Int64

[Missing <param name="x"/> documentation for "M:Lucene.Net.Util.BitUtil.Ntz2(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Ntz2(System.Int64)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Ntz3 Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Ntz3 Method
BitUtil Class See Also Send Feedback
returns 0 based index of first set bit
This is an alternate implementation of ntz()

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int Ntz3(
    long x
)
Visual Basic
Public Shared Function Ntz3 ( _
    x As Long _
) As Integer
Visual C++
public:
static int Ntz3(
    long long x
)

Parameters

x
Type: System..::..Int64

[Missing <param name="x"/> documentation for "M:Lucene.Net.Util.BitUtil.Ntz3(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Ntz3(System.Int64)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Pop Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Pop Method
BitUtil Class See Also Send Feedback
Returns the number of bits set in the long

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int Pop(
    long x
)
Visual Basic
Public Shared Function Pop ( _
    x As Long _
) As Integer
Visual C++
public:
static int Pop(
    long long x
)

Parameters

x
Type: System..::..Int64

[Missing <param name="x"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Pop(System.Int64)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Pop_andnot Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Pop_andnot Method
BitUtil Class See Also Send Feedback
Returns the popcount or cardinality of A & ~B Neither array is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long Pop_andnot(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Visual Basic
Public Shared Function Pop_andnot ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Visual C++
public:
static long long Pop_andnot(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)

Parameters

A
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="A"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_andnot(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

B
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="B"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_andnot(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

wordOffset
Type: System..::..Int32

[Missing <param name="wordOffset"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_andnot(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_andnot(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Pop_andnot(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Pop_array Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Pop_array Method
BitUtil Class See Also Send Feedback
Returns the number of set bits in an array of longs.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long Pop_array(
    long[] A,
    int wordOffset,
    int numWords
)
Visual Basic
Public Shared Function Pop_array ( _
    A As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Visual C++
public:
static long long Pop_array(
    array<long long>^ A,
    int wordOffset,
    int numWords
)

Parameters

A
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="A"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_array(System.Int64[],System.Int32,System.Int32)"]

wordOffset
Type: System..::..Int32

[Missing <param name="wordOffset"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_array(System.Int64[],System.Int32,System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_array(System.Int64[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Pop_array(System.Int64[],System.Int32,System.Int32)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Pop_intersect Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Pop_intersect Method
BitUtil Class See Also Send Feedback
Returns the popcount or cardinality of the two sets after an intersection. Neither array is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long Pop_intersect(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Visual Basic
Public Shared Function Pop_intersect ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Visual C++
public:
static long long Pop_intersect(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)

Parameters

A
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="A"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_intersect(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

B
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="B"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_intersect(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

wordOffset
Type: System..::..Int32

[Missing <param name="wordOffset"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_intersect(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_intersect(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Pop_intersect(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Pop_union Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Pop_union Method
BitUtil Class See Also Send Feedback
Returns the popcount or cardinality of the union of two sets. Neither array is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long Pop_union(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Visual Basic
Public Shared Function Pop_union ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Visual C++
public:
static long long Pop_union(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)

Parameters

A
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="A"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_union(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

B
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="B"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_union(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

wordOffset
Type: System..::..Int32

[Missing <param name="wordOffset"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_union(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_union(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Pop_union(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


Pop_xor Method

[image]

Lucene.Net Class Libraries
BitUtil..::..Pop_xor Method
BitUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.BitUtil.Pop_xor(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long Pop_xor(
    long[] A,
    long[] B,
    int wordOffset,
    int numWords
)
Visual Basic
Public Shared Function Pop_xor ( _
    A As Long(), _
    B As Long(), _
    wordOffset As Integer, _
    numWords As Integer _
) As Long
Visual C++
public:
static long long Pop_xor(
    array<long long>^ A,
    array<long long>^ B,
    int wordOffset,
    int numWords
)

Parameters

A
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="A"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_xor(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

B
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="B"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_xor(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

wordOffset
Type: System..::..Int32

[Missing <param name="wordOffset"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_xor(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.BitUtil.Pop_xor(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitUtil.Pop_xor(System.Int64[],System.Int64[],System.Int32,System.Int32)"]

See Also

BitUtil Class
Lucene.Net.Util Namespace


BitVector Class

[image]

Lucene.Net Class Libraries
BitVector Class
Members See Also Send Feedback
Optimized implementation of a vector of bits. This is more-or-less like java.util.BitSet, but also includes the following:
  • a count() method, which efficiently computes the number of one bits;
  • optimized read from and write to disk;
  • inlinable get() method;
  • store and load, as bit set or d-gaps, depending on sparseness;

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class BitVector : ICloneable
Visual Basic
Public NotInheritable Class BitVector _
    Implements ICloneable
Visual C++
public ref class BitVector sealed : ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..BitVector

See Also

BitVector Members
Lucene.Net.Util Namespace


BitVector Members

[image] [image]

Lucene.Net Class Libraries
BitVector Members
BitVector Class Constructors Methods See Also Send Feedback

The BitVector type exposes the following members.

Constructors

Name Description
Public method BitVector(Int32)
Constructs a vector capable of holding
CopyC#
n
 bits.
Public method BitVector(Directory, String)
Constructs a bit vector from the file
CopyC#
name
 in Directory
CopyC#
d
, as written by the {@link #write} method.

Methods

Name | Description
Public method Clear
Sets the value of
CopyC#
bit
 to zero.
Public method | Clone
Public method Count
Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Get
Returns
CopyC#
true
 if
CopyC#
bit
 is one and
CopyC#
false
 if it is zero.
Public method GetAndSet
Sets the value of
CopyC#
bit
 to true, and returns true if bit was already set
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetRecomputedCount
For testing
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Set
Sets the value of
CopyC#
bit
 to one.
Public method Size
Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
Public method Subset
Retrieve a subset of this BitVector.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method Write
Writes this vector to the file
CopyC#
name
 in Directory
CopyC#
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

See Also

BitVector Class
Lucene.Net.Util Namespace


BitVector Constructor

[image] [image]

Lucene.Net Class Libraries
BitVector Constructor
BitVector Class See Also Send Feedback

Overload List

Name Description
Public method BitVector(Int32)
Constructs a vector capable of holding
CopyC#
n
 bits.
Public method BitVector(Directory, String)
Constructs a bit vector from the file
CopyC#
name
 in Directory
CopyC#
d
, as written by the {@link #write} method.

See Also

BitVector Class
BitVector Members
Lucene.Net.Util Namespace


BitVector Constructor (Int32)

[image]

Lucene.Net Class Libraries
BitVector Constructor (Int32)
BitVector Class See Also Send Feedback
Constructs a vector capable of holding
CopyC#
n
 bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BitVector(
    int n
)
Visual Basic
Public Sub New ( _
    n As Integer _
)
Visual C++
public:
BitVector(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Util.BitVector.#ctor(System.Int32)"]

See Also

BitVector Class
BitVector Overload
Lucene.Net.Util Namespace


BitVector Constructor (Directory, String)

[image]

Lucene.Net Class Libraries
BitVector Constructor (Directory, String)
BitVector Class See Also Send Feedback
Constructs a bit vector from the file
CopyC#
name
 in Directory
CopyC#
d
, as written by the {@link #write} method.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BitVector(
    Directory d,
    string name
)
Visual Basic
Public Sub New ( _
    d As Directory, _
    name As String _
)
Visual C++
public:
BitVector(
    Directory^ d,
    String^ name
)

Parameters

d
Type: Lucene.Net.Store..::..Directory

[Missing <param name="d"/> documentation for "M:Lucene.Net.Util.BitVector.#ctor(Lucene.Net.Store.Directory,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Util.BitVector.#ctor(Lucene.Net.Store.Directory,System.String)"]

See Also

BitVector Class
BitVector Overload
Lucene.Net.Util Namespace


BitVector Methods

[image] [image]

Lucene.Net Class Libraries
BitVector Methods
BitVector Class See Also Send Feedback

The BitVector type exposes the following members.

Methods

Name | Description
Public method Clear
Sets the value of
CopyC#
bit
 to zero.
Public method | Clone
Public method Count
Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method Get
Returns
CopyC#
true
 if
CopyC#
bit
 is one and
CopyC#
false
 if it is zero.
Public method GetAndSet
Sets the value of
CopyC#
bit
 to true, and returns true if bit was already set
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetRecomputedCount
For testing
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Set
Sets the value of
CopyC#
bit
 to one.
Public method Size
Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.
Public method Subset
Retrieve a subset of this BitVector.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method Write
Writes this vector to the file
CopyC#
name
 in Directory
CopyC#
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

See Also

BitVector Class
Lucene.Net.Util Namespace


Clear Method

[image]

Lucene.Net Class Libraries
BitVector..::..Clear Method
BitVector Class See Also Send Feedback
Sets the value of
CopyC#
bit
 to zero.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Clear(
    int bit
)
Visual Basic
Public Sub Clear ( _
    bit As Integer _
)
Visual C++
public:
void Clear(
    int bit
)

Parameters

bit
Type: System..::..Int32

[Missing <param name="bit"/> documentation for "M:Lucene.Net.Util.BitVector.Clear(System.Int32)"]

See Also

BitVector Class
Lucene.Net.Util Namespace


Clone Method

[image]

Lucene.Net Class Libraries
BitVector..::..Clone Method
BitVector Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.BitVector.Clone"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitVector.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

BitVector Class
Lucene.Net.Util Namespace


Count Method

[image]

Lucene.Net Class Libraries
BitVector..::..Count Method
BitVector Class See Also Send Feedback
Returns the total number of one bits in this vector. This is efficiently computed and cached, so that, if the vector is not changed, no recomputation is done for repeated calls.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Count()
Visual Basic
Public Function Count As Integer
Visual C++
public:
int Count()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitVector.Count"]

See Also

BitVector Class
Lucene.Net.Util Namespace


Get Method

[image]

Lucene.Net Class Libraries
BitVector..::..Get Method
BitVector Class See Also Send Feedback
Returns
CopyC#
true
 if
CopyC#
bit
 is one and
CopyC#
false
 if it is zero.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool Get(
    int bit
)
Visual Basic
Public Function Get ( _
    bit As Integer _
) As Boolean
Visual C++
public:
bool Get(
    int bit
)

Parameters

bit
Type: System..::..Int32

[Missing <param name="bit"/> documentation for "M:Lucene.Net.Util.BitVector.Get(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitVector.Get(System.Int32)"]

See Also

BitVector Class
Lucene.Net.Util Namespace


GetAndSet Method

[image]

Lucene.Net Class Libraries
BitVector..::..GetAndSet Method
BitVector Class See Also Send Feedback
Sets the value of
CopyC#
bit
 to true, and returns true if bit was already set

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool GetAndSet(
    int bit
)
Visual Basic
Public Function GetAndSet ( _
    bit As Integer _
) As Boolean
Visual C++
public:
bool GetAndSet(
    int bit
)

Parameters

bit
Type: System..::..Int32

[Missing <param name="bit"/> documentation for "M:Lucene.Net.Util.BitVector.GetAndSet(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitVector.GetAndSet(System.Int32)"]

See Also

BitVector Class
Lucene.Net.Util Namespace


GetRecomputedCount Method

[image]

Lucene.Net Class Libraries
BitVector..::..GetRecomputedCount Method
BitVector Class See Also Send Feedback
For testing

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int GetRecomputedCount()
Visual Basic
Public Function GetRecomputedCount As Integer
Visual C++
public:
int GetRecomputedCount()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitVector.GetRecomputedCount"]

See Also

BitVector Class
Lucene.Net.Util Namespace


Set Method

[image]

Lucene.Net Class Libraries
BitVector..::..Set Method
BitVector Class See Also Send Feedback
Sets the value of
CopyC#
bit
 to one.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Set(
    int bit
)
Visual Basic
Public Sub Set ( _
    bit As Integer _
)
Visual C++
public:
void Set(
    int bit
)

Parameters

bit
Type: System..::..Int32

[Missing <param name="bit"/> documentation for "M:Lucene.Net.Util.BitVector.Set(System.Int32)"]

See Also

BitVector Class
Lucene.Net.Util Namespace


Size Method

[image]

Lucene.Net Class Libraries
BitVector..::..Size Method
BitVector Class See Also Send Feedback
Returns the number of bits in this vector. This is also one greater than the number of the largest valid bit number.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.BitVector.Size"]

See Also

BitVector Class
Lucene.Net.Util Namespace


Subset Method

[image]

Lucene.Net Class Libraries
BitVector..::..Subset Method
BitVector Class See Also Send Feedback
Retrieve a subset of this BitVector.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public BitVector Subset(
    int start,
    int end
)
Visual Basic
Public Function Subset ( _
    start As Integer, _
    end As Integer _
) As BitVector
Visual C++
public:
BitVector^ Subset(
    int start,
    int end
)

Parameters

start
Type: System..::..Int32
starting index, inclusive
end
Type: System..::..Int32
ending index, exclusive

Return Value

subset

See Also

BitVector Class
Lucene.Net.Util Namespace


Write Method

[image]

Lucene.Net Class Libraries
BitVector..::..Write Method
BitVector Class See Also Send Feedback
Writes this vector to the file
CopyC#
name
 in Directory
CopyC#
d
, in a format that can be read by the constructor {@link #BitVector(Directory, String)}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Write(
    Directory d,
    string name
)
Visual Basic
Public Sub Write ( _
    d As Directory, _
    name As String _
)
Visual C++
public:
void Write(
    Directory^ d,
    String^ name
)

Parameters

d
Type: Lucene.Net.Store..::..Directory

[Missing <param name="d"/> documentation for "M:Lucene.Net.Util.BitVector.Write(Lucene.Net.Store.Directory,System.String)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Util.BitVector.Write(Lucene.Net.Store.Directory,System.String)"]

See Also

BitVector Class
Lucene.Net.Util Namespace


CloseableThreadLocal Class

[image]

Lucene.Net Class Libraries
CloseableThreadLocal Class
Members See Also Send Feedback
Java's builtin ThreadLocal has a serious flaw: it can take an arbitrarily long amount of time to dereference the things you had stored in it, even once the ThreadLocal instance itself is no longer referenced. This is because there is single, master map stored for each thread, which all ThreadLocals share, and that master map only periodically purges "stale" entries. While not technically a memory leak, because eventually the memory will be reclaimed, it can take a long time and you can easily hit OutOfMemoryError because from the GC's standpoint the stale entries are not reclaimaible. This class works around that, by only enrolling WeakReference values into the ThreadLocal, and separately holding a hard reference to each stored value. When you call {@link #close}, these hard references are cleared and then GC is freely able to reclaim space by objects stored in it.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class CloseableThreadLocal
Visual Basic
Public Class CloseableThreadLocal
Visual C++
public ref class CloseableThreadLocal

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..CloseableThreadLocal

See Also

CloseableThreadLocal Members
Lucene.Net.Util Namespace


CloseableThreadLocal Members

[image] [image]

Lucene.Net Class Libraries
CloseableThreadLocal Members
CloseableThreadLocal Class Constructors Methods See Also Send Feedback

The CloseableThreadLocal type exposes the following members.

Constructors

 | Name | Description
Public method | CloseableThreadLocal | Initializes a new instance of the CloseableThreadLocal class

Methods

 | Name | Description
Public method | Close |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitialValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


CloseableThreadLocal Constructor

[image]

Lucene.Net Class Libraries
CloseableThreadLocal Constructor
CloseableThreadLocal Class See Also Send Feedback
Initializes a new instance of the CloseableThreadLocal class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CloseableThreadLocal()
Visual Basic
Public Sub New
Visual C++
public:
CloseableThreadLocal()

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


CloseableThreadLocal Methods

[image] [image]

Lucene.Net Class Libraries
CloseableThreadLocal Methods
CloseableThreadLocal Class See Also Send Feedback

The CloseableThreadLocal type exposes the following members.

Methods

 | Name | Description
Public method | Close |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitialValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


Close Method

[image]

Lucene.Net Class Libraries
CloseableThreadLocal..::..Close Method
CloseableThreadLocal Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.Close"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


Get Method

[image]

Lucene.Net Class Libraries
CloseableThreadLocal..::..Get Method
CloseableThreadLocal Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.Get"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Get()
Visual Basic
Public Overridable Function Get As Object
Visual C++
public:
virtual Object^ Get()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.Get"]

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


InitialValue Method

[image]

Lucene.Net Class Libraries
CloseableThreadLocal..::..InitialValue Method
CloseableThreadLocal Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.InitialValue"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object InitialValue()
Visual Basic
Public Overridable Function InitialValue As Object
Visual C++
public:
virtual Object^ InitialValue()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.InitialValue"]

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


Set Method

[image]

Lucene.Net Class Libraries
CloseableThreadLocal..::..Set Method
CloseableThreadLocal Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.Set(System.Object)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Set(
    Object object
)
Visual Basic
Public Overridable Sub Set ( _
    object As Object _
)
Visual C++
public:
virtual void Set(
    Object^ object
)

Parameters

object
Type: System..::..Object

[Missing <param name="object"/> documentation for "M:Lucene.Net.Util.CloseableThreadLocal.Set(System.Object)"]

See Also

CloseableThreadLocal Class
Lucene.Net.Util Namespace


Constants Class

[image]

Lucene.Net Class Libraries
Constants Class
Members See Also Send Feedback
Some useful constants.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class Constants
Visual Basic
Public NotInheritable Class Constants
Visual C++
public ref class Constants sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Constants

See Also

Constants Members
Lucene.Net.Util Namespace


Constants Members

[image] [image]

Lucene.Net Class Libraries
Constants Members
Constants Class Methods Fields See Also Send Feedback

The Constants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
JAVA_1_1 | True iff this is Java version 1.1.
JAVA_1_2 | True iff this is Java version 1.2.
JAVA_1_3 | True iff this is Java version 1.3.
JAVA_VENDOR |
JAVA_VERSION | The value of System.getProperty("java.version"). *
JRE_IS_64BIT |
LINUX | True iff running on Linux.
LUCENE_MAIN_VERSION |
LUCENE_VERSION |
OS_ARCH |
OS_NAME | The value of System.getProperty("os.name"). *
OS_VERSION |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.

See Also

Constants Class
Lucene.Net.Util Namespace


Constants Fields

[image] [image]

Lucene.Net Class Libraries
Constants Fields
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Fields

Name | Description
JAVA_1_1 | True iff this is Java version 1.1.
JAVA_1_2 | True iff this is Java version 1.2.
JAVA_1_3 | True iff this is Java version 1.3.
JAVA_VENDOR |
JAVA_VERSION | The value of System.getProperty("java.version"). *
JRE_IS_64BIT |
LINUX | True iff running on Linux.
LUCENE_MAIN_VERSION |
LUCENE_VERSION |
OS_ARCH |
OS_NAME | The value of System.getProperty("os.name"). *
OS_VERSION |
SUN_OS | True iff running on SunOS.
WINDOWS | True iff running on Windows.

See Also

Constants Class
Lucene.Net.Util Namespace


JAVA_1_1 Field

[image]

Lucene.Net Class Libraries
Constants..::..JAVA_1_1 Field
Constants Class See Also Send Feedback
True iff this is Java version 1.1.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly bool JAVA_1_1
Visual Basic
Public Shared ReadOnly JAVA_1_1 As Boolean
Visual C++
public:
static initonly bool JAVA_1_1

See Also

Constants Class
Lucene.Net.Util Namespace


JAVA_1_2 Field

[image]

Lucene.Net Class Libraries
Constants..::..JAVA_1_2 Field
Constants Class See Also Send Feedback
True iff this is Java version 1.2.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly bool JAVA_1_2
Visual Basic
Public Shared ReadOnly JAVA_1_2 As Boolean
Visual C++
public:
static initonly bool JAVA_1_2

See Also

Constants Class
Lucene.Net.Util Namespace


JAVA_1_3 Field

[image]

Lucene.Net Class Libraries
Constants..::..JAVA_1_3 Field
Constants Class See Also Send Feedback
True iff this is Java version 1.3.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly bool JAVA_1_3
Visual Basic
Public Shared ReadOnly JAVA_1_3 As Boolean
Visual C++
public:
static initonly bool JAVA_1_3

See Also

Constants Class
Lucene.Net.Util Namespace


JAVA_VENDOR Field

[image]

Lucene.Net Class Libraries
Constants..::..JAVA_VENDOR Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Constants.JAVA_VENDOR"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string JAVA_VENDOR
Visual Basic
Public Shared ReadOnly JAVA_VENDOR As String
Visual C++
public:
static initonly String^ JAVA_VENDOR

See Also

Constants Class
Lucene.Net.Util Namespace


JAVA_VERSION Field

[image]

Lucene.Net Class Libraries
Constants..::..JAVA_VERSION Field
Constants Class See Also Send Feedback
The value of System.getProperty("java.version"). *

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string JAVA_VERSION
Visual Basic
Public Shared ReadOnly JAVA_VERSION As String
Visual C++
public:
static initonly String^ JAVA_VERSION

See Also

Constants Class
Lucene.Net.Util Namespace


JRE_IS_64BIT Field

[image]

Lucene.Net Class Libraries
Constants..::..JRE_IS_64BIT Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Constants.JRE_IS_64BIT"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static bool JRE_IS_64BIT
Visual Basic
Public Shared JRE_IS_64BIT As Boolean
Visual C++
public:
static bool JRE_IS_64BIT

See Also

Constants Class
Lucene.Net.Util Namespace


LINUX Field

[image]

Lucene.Net Class Libraries
Constants..::..LINUX Field
Constants Class See Also Send Feedback
True iff running on Linux.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly bool LINUX
Visual Basic
Public Shared ReadOnly LINUX As Boolean
Visual C++
public:
static initonly bool LINUX

See Also

Constants Class
Lucene.Net.Util Namespace


LUCENE_MAIN_VERSION Field

[image]

Lucene.Net Class Libraries
Constants..::..LUCENE_MAIN_VERSION Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Constants.LUCENE_MAIN_VERSION"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string LUCENE_MAIN_VERSION
Visual Basic
Public Shared ReadOnly LUCENE_MAIN_VERSION As String
Visual C++
public:
static initonly String^ LUCENE_MAIN_VERSION

See Also

Constants Class
Lucene.Net.Util Namespace


LUCENE_VERSION Field

[image]

Lucene.Net Class Libraries
Constants..::..LUCENE_VERSION Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Constants.LUCENE_VERSION"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string LUCENE_VERSION
Visual Basic
Public Shared LUCENE_VERSION As String
Visual C++
public:
static String^ LUCENE_VERSION

See Also

Constants Class
Lucene.Net.Util Namespace


OS_ARCH Field

[image]

Lucene.Net Class Libraries
Constants..::..OS_ARCH Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Constants.OS_ARCH"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string OS_ARCH
Visual Basic
Public Shared ReadOnly OS_ARCH As String
Visual C++
public:
static initonly String^ OS_ARCH

See Also

Constants Class
Lucene.Net.Util Namespace


OS_NAME Field

[image]

Lucene.Net Class Libraries
Constants..::..OS_NAME Field
Constants Class See Also Send Feedback
The value of System.getProperty("os.name"). *

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string OS_NAME
Visual Basic
Public Shared ReadOnly OS_NAME As String
Visual C++
public:
static initonly String^ OS_NAME

See Also

Constants Class
Lucene.Net.Util Namespace


OS_VERSION Field

[image]

Lucene.Net Class Libraries
Constants..::..OS_VERSION Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Constants.OS_VERSION"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly string OS_VERSION
Visual Basic
Public Shared ReadOnly OS_VERSION As String
Visual C++
public:
static initonly String^ OS_VERSION

See Also

Constants Class
Lucene.Net.Util Namespace


SUN_OS Field

[image]

Lucene.Net Class Libraries
Constants..::..SUN_OS Field
Constants Class See Also Send Feedback
True iff running on SunOS.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly bool SUN_OS
Visual Basic
Public Shared ReadOnly SUN_OS As Boolean
Visual C++
public:
static initonly bool SUN_OS

See Also

Constants Class
Lucene.Net.Util Namespace


WINDOWS Field

[image]

Lucene.Net Class Libraries
Constants..::..WINDOWS Field
Constants Class See Also Send Feedback
True iff running on Windows.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly bool WINDOWS
Visual Basic
Public Shared ReadOnly WINDOWS As Boolean
Visual C++
public:
static initonly bool WINDOWS

See Also

Constants Class
Lucene.Net.Util Namespace


Constants Methods

[image] [image]

Lucene.Net Class Libraries
Constants Methods
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constants Class
Lucene.Net.Util Namespace


DocIdBitSet Class

[image]

Lucene.Net Class Libraries
DocIdBitSet Class
Members See Also Send Feedback
Simple DocIdSet and DocIdSetIterator backed by a BitSet

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class DocIdBitSet : DocIdSet
Visual Basic
Public Class DocIdBitSet _
    Inherits DocIdSet
Visual C++
public ref class DocIdBitSet : public DocIdSet

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Util..::..DocIdBitSet

See Also

DocIdBitSet Members
Lucene.Net.Util Namespace


DocIdBitSet Members

[image] [image]

Lucene.Net Class Libraries
DocIdBitSet Members
DocIdBitSet Class Constructors Methods See Also Send Feedback

The DocIdBitSet type exposes the following members.

Constructors

 | Name | Description
Public method | DocIdBitSet | Initializes a new instance of the DocIdBitSet class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitSet | Returns the underlying BitSet.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocIdBitSet Class
Lucene.Net.Util Namespace


DocIdBitSet Constructor

[image]

Lucene.Net Class Libraries
DocIdBitSet Constructor
DocIdBitSet Class See Also Send Feedback
Initializes a new instance of the DocIdBitSet class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public DocIdBitSet(
    BitArray bitSet
)
Visual Basic
Public Sub New ( _
    bitSet As BitArray _
)
Visual C++
public:
DocIdBitSet(
    BitArray^ bitSet
)

Parameters

bitSet
Type: System.Collections..::..BitArray

[Missing <param name="bitSet"/> documentation for "M:Lucene.Net.Util.DocIdBitSet.#ctor(System.Collections.BitArray)"]

See Also

DocIdBitSet Class
Lucene.Net.Util Namespace


DocIdBitSet Methods

[image] [image]

Lucene.Net Class Libraries
DocIdBitSet Methods
DocIdBitSet Class See Also Send Feedback

The DocIdBitSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitSet | Returns the underlying BitSet.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocIdBitSet Class
Lucene.Net.Util Namespace


GetBitSet Method

[image]

Lucene.Net Class Libraries
DocIdBitSet..::..GetBitSet Method
DocIdBitSet Class See Also Send Feedback
Returns the underlying BitSet.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual BitArray GetBitSet()
Visual Basic
Public Overridable Function GetBitSet As BitArray
Visual C++
public:
virtual BitArray^ GetBitSet()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.DocIdBitSet.GetBitSet"]

See Also

DocIdBitSet Class
Lucene.Net.Util Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
DocIdBitSet..::..IsCacheable Method
DocIdBitSet Class See Also Send Feedback
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCacheable()
Visual Basic
Public Overrides Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.DocIdBitSet.IsCacheable"]

See Also

DocIdBitSet Class
Lucene.Net.Util Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
DocIdBitSet..::..Iterator Method
DocIdBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.DocIdBitSet.Iterator"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSetIterator Iterator()
Visual Basic
Public Overrides Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.DocIdBitSet.Iterator"]

See Also

DocIdBitSet Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker Class

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker Class
Members See Also Send Feedback
Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class FieldCacheSanityChecker
Visual Basic
Public NotInheritable Class FieldCacheSanityChecker
Visual C++
public ref class FieldCacheSanityChecker sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..FieldCacheSanityChecker

See Also

FieldCacheSanityChecker Members
Lucene.Net.Util Namespace
Lucene.Net.Search..::..FieldCache
Lucene.Net.Util..::..FieldCacheSanityChecker..::..Insanity
Lucene.Net.Util..::..FieldCacheSanityChecker..::..InsanityType


FieldCacheSanityChecker Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker Members
FieldCacheSanityChecker Class Constructors Methods See Also Send Feedback

The FieldCacheSanityChecker type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCacheSanityChecker | Initializes a new instance of the FieldCacheSanityChecker class

Methods

 | Name | Description
Public method | Check | Tests a CacheEntry[] for indication of "insane" cache usage. NOTE:FieldCache CreationPlaceholder objects are ignored. (:TODO: is this a bad idea? are we masking a real problem?)
 | CheckSanity(array<CacheEntry>[]()[][]) | Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntry[]
 | CheckSanity(FieldCache) | Quick and dirty convenience method
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRamUsageEstimator | If set, will be used to estimate size for all CacheEntry objects dealt with.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCacheSanityChecker Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker Constructor

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker Constructor
FieldCacheSanityChecker Class See Also Send Feedback
Initializes a new instance of the FieldCacheSanityChecker class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheSanityChecker()
Visual Basic
Public Sub New
Visual C++
public:
FieldCacheSanityChecker()

See Also

FieldCacheSanityChecker Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker Methods
FieldCacheSanityChecker Class See Also Send Feedback

The FieldCacheSanityChecker type exposes the following members.

Methods

 | Name | Description
Public method | Check | Tests a CacheEntry[] for indication of "insane" cache usage. NOTE:FieldCache CreationPlaceholder objects are ignored. (:TODO: is this a bad idea? are we masking a real problem?)
 | CheckSanity(array<CacheEntry>[]()[][]) | Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntry[]
 | CheckSanity(FieldCache) | Quick and dirty convenience method
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRamUsageEstimator | If set, will be used to estimate size for all CacheEntry objects dealt with.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCacheSanityChecker Class
Lucene.Net.Util Namespace


Check Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Check Method
FieldCacheSanityChecker Class See Also Send Feedback
Tests a CacheEntry[] for indication of "insane" cache usage.

NOTE:FieldCache CreationPlaceholder objects are ignored. (:TODO: is this a bad idea? are we masking a real problem?)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheSanityChecker..::..Insanity[] Check(
    CacheEntry[] cacheEntries
)
Visual Basic
Public Function Check ( _
    cacheEntries As CacheEntry() _
) As FieldCacheSanityChecker..::..Insanity()
Visual C++
public:
array<FieldCacheSanityChecker..::..Insanity^>^ Check(
    array<CacheEntry^>^ cacheEntries
)

Parameters

cacheEntries
Type: array< Lucene.Net.Search..::..CacheEntry >[]()[][]

[Missing <param name="cacheEntries"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Check(Lucene.Net.Search.CacheEntry[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Check(Lucene.Net.Search.CacheEntry[])"]

See Also

FieldCacheSanityChecker Class
Lucene.Net.Util Namespace


CheckSanity Method

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..CheckSanity Method
FieldCacheSanityChecker Class See Also Send Feedback

Overload List

Name | Description
CheckSanity(array<CacheEntry>[]()[][]) | Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntry[]
CheckSanity(FieldCache) | Quick and dirty convenience method

See Also

FieldCacheSanityChecker Class
FieldCacheSanityChecker Members
Lucene.Net.Util Namespace


CheckSanity Method (CacheEntry[])

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..CheckSanity Method (array<CacheEntry>[]()[][])
FieldCacheSanityChecker Class See Also Send Feedback
Quick and dirty convenience method that instantiates an instance with "good defaults" and uses it to test the CacheEntry[]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheSanityChecker..::..Insanity[] CheckSanity(
    CacheEntry[] cacheEntries
)
Visual Basic
Public Shared Function CheckSanity ( _
    cacheEntries As CacheEntry() _
) As FieldCacheSanityChecker..::..Insanity()
Visual C++
public:
static array<FieldCacheSanityChecker..::..Insanity^>^ CheckSanity(
    array<CacheEntry^>^ cacheEntries
)

Parameters

cacheEntries
Type: array< Lucene.Net.Search..::..CacheEntry >[]()[][]

[Missing <param name="cacheEntries"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.CheckSanity(Lucene.Net.Search.CacheEntry[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.CheckSanity(Lucene.Net.Search.CacheEntry[])"]

See Also

FieldCacheSanityChecker Class
CheckSanity Overload
Lucene.Net.Util Namespace
[!:check]


CheckSanity Method (FieldCache)

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..CheckSanity Method (FieldCache)
FieldCacheSanityChecker Class See Also Send Feedback
Quick and dirty convenience method

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static FieldCacheSanityChecker..::..Insanity[] CheckSanity(
    FieldCache cache
)
Visual Basic
Public Shared Function CheckSanity ( _
    cache As FieldCache _
) As FieldCacheSanityChecker..::..Insanity()
Visual C++
public:
static array<FieldCacheSanityChecker..::..Insanity^>^ CheckSanity(
    FieldCache^ cache
)

Parameters

cache
Type: Lucene.Net.Search..::..FieldCache

[Missing <param name="cache"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.CheckSanity(Lucene.Net.Search.FieldCache)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.CheckSanity(Lucene.Net.Search.FieldCache)"]

See Also

FieldCacheSanityChecker Class
CheckSanity Overload
Lucene.Net.Util Namespace
[!:check]


SetRamUsageEstimator Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..SetRamUsageEstimator Method
FieldCacheSanityChecker Class See Also Send Feedback
If set, will be used to estimate size for all CacheEntry objects dealt with.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetRamUsageEstimator(
    RamUsageEstimator r
)
Visual Basic
Public Sub SetRamUsageEstimator ( _
    r As RamUsageEstimator _
)
Visual C++
public:
void SetRamUsageEstimator(
    RamUsageEstimator^ r
)

Parameters

r
Type: Lucene.Net.Util..::..RamUsageEstimator

[Missing <param name="r"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.SetRamUsageEstimator(Lucene.Net.Util.RamUsageEstimator)"]

See Also

FieldCacheSanityChecker Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker.Insanity Class

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity Class
FieldCacheSanityChecker Class Members See Also Send Feedback
Simple container for a collection of related CacheEntry objects that in conjunction with eachother represent some "insane" usage of the FieldCache.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class Insanity
Visual Basic
Public NotInheritable Class Insanity
Visual C++
public ref class Insanity sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..FieldCacheSanityChecker..::..Insanity

See Also

FieldCacheSanityChecker..::..Insanity Members
Lucene.Net.Util Namespace


FieldCacheSanityChecker.Insanity Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity Members
FieldCacheSanityChecker..::..Insanity Class Constructors Methods See Also Send Feedback

Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

The FieldCacheSanityChecker..::..Insanity type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCacheSanityChecker..::..Insanity | Initializes a new instance of the FieldCacheSanityChecker..::..Insanity class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheEntries | CacheEntry objects which suggest a problem
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMsg | Description of hte insane behavior
Public method | GetType | Type of insane behavior this object represents
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Multi-Line representation of this Insanity object, starting with the Type and Msg, followed by each CacheEntry.toString() on it's own line prefaced by a tab character (Overrides Object..::..ToString()()()().)

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker.Insanity Constructor

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity Constructor
FieldCacheSanityChecker..::..Insanity Class See Also Send Feedback
Initializes a new instance of the FieldCacheSanityChecker..::..Insanity class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Insanity(
    FieldCacheSanityChecker..::..InsanityType type,
    string msg,
    CacheEntry[] entries
)
Visual Basic
Public Sub New ( _
    type As FieldCacheSanityChecker..::..InsanityType, _
    msg As String, _
    entries As CacheEntry() _
)
Visual C++
public:
Insanity(
    FieldCacheSanityChecker..::..InsanityType^ type,
    String^ msg,
    array<CacheEntry^>^ entries
)

Parameters

type
Type: Lucene.Net.Util..::..FieldCacheSanityChecker..::..InsanityType

[Missing <param name="type"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.#ctor(Lucene.Net.Util.FieldCacheSanityChecker.InsanityType,System.String,Lucene.Net.Search.CacheEntry[])"]

msg
Type: System..::..String

[Missing <param name="msg"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.#ctor(Lucene.Net.Util.FieldCacheSanityChecker.InsanityType,System.String,Lucene.Net.Search.CacheEntry[])"]

entries
Type: array< Lucene.Net.Search..::..CacheEntry >[]()[][]

[Missing <param name="entries"/> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.#ctor(Lucene.Net.Util.FieldCacheSanityChecker.InsanityType,System.String,Lucene.Net.Search.CacheEntry[])"]

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker.Insanity Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity Methods
FieldCacheSanityChecker..::..Insanity Class See Also Send Feedback

The FieldCacheSanityChecker..::..Insanity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheEntries | CacheEntry objects which suggest a problem
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMsg | Description of hte insane behavior
Public method | GetType | Type of insane behavior this object represents
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Multi-Line representation of this Insanity object, starting with the Type and Msg, followed by each CacheEntry.toString() on it's own line prefaced by a tab character (Overrides Object..::..ToString()()()().)

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


GetCacheEntries Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity..::..GetCacheEntries Method
FieldCacheSanityChecker..::..Insanity Class See Also Send Feedback
CacheEntry objects which suggest a problem

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public CacheEntry[] GetCacheEntries()
Visual Basic
Public Function GetCacheEntries As CacheEntry()
Visual C++
public:
array<CacheEntry^>^ GetCacheEntries()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.GetCacheEntries"]

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


GetMsg Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity..::..GetMsg Method
FieldCacheSanityChecker..::..Insanity Class See Also Send Feedback
Description of hte insane behavior

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public string GetMsg()
Visual Basic
Public Function GetMsg As String
Visual C++
public:
String^ GetMsg()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.GetMsg"]

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


GetType Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity..::..GetType Method
FieldCacheSanityChecker..::..Insanity Class See Also Send Feedback
Type of insane behavior this object represents

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public FieldCacheSanityChecker..::..InsanityType GetType()
Visual Basic
Public Function GetType As FieldCacheSanityChecker..::..InsanityType
Visual C++
public:
FieldCacheSanityChecker..::..InsanityType^ GetType()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.GetType"]

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..Insanity..::..ToString Method
FieldCacheSanityChecker..::..Insanity Class See Also Send Feedback
Multi-Line representation of this Insanity object, starting with the Type and Msg, followed by each CacheEntry.toString() on it's own line prefaced by a tab character

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.Insanity.ToString"]

See Also

FieldCacheSanityChecker..::..Insanity Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker.InsanityType Class

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType Class
FieldCacheSanityChecker Class Members See Also Send Feedback
An Enumaration of the differnet types of "insane" behavior that may be detected in a FieldCache.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class InsanityType
Visual Basic
Public NotInheritable Class InsanityType
Visual C++
public ref class InsanityType sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..FieldCacheSanityChecker..::..InsanityType

See Also

FieldCacheSanityChecker..::..InsanityType Members
Lucene.Net.Util Namespace
FieldCacheSanityChecker..::..InsanityType..::..SUBREADER
FieldCacheSanityChecker..::..InsanityType..::..VALUEMISMATCH
FieldCacheSanityChecker..::..InsanityType..::..EXPECTED


FieldCacheSanityChecker.InsanityType Members

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType Members
FieldCacheSanityChecker..::..InsanityType Class Methods Fields See Also Send Feedback

Provides methods for sanity checking that entries in the FieldCache are not wasteful or inconsistent.

Lucene 2.9 Introduced numerous enhancements into how the FieldCache is used by the low levels of Lucene searching (for Sorting and ValueSourceQueries) to improve both the speed for Sorting, as well as reopening of IndexReaders. But these changes have shifted the usage of FieldCache from "top level" IndexReaders (frequently a MultiReader or DirectoryReader) down to the leaf level SegmentReaders. As a result, existing applications that directly access the FieldCache may find RAM usage increase significantly when upgrading to 2.9 or Later. This class provides an API for these applications (or their Unit tests) to check at run time if the FieldCache contains "insane" usages of the FieldCache.

EXPERIMENTAL API: This API is considered extremely advanced and experimental. It may be removed or altered w/o warning in future releases of Lucene.

The FieldCacheSanityChecker..::..InsanityType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
EXPECTED | Indicates an expected bit of "insanity". This may be useful for clients that wish to preserve/log information about insane usage but indicate that it was expected.
SUBREADER | Indicates an overlap in cache usage on a given field in sub/super readers.
VALUEMISMATCH | Indicates entries have the same reader+fieldname but different cached values. This can happen if different datatypes, or parsers are used -- and while it's not necessarily a bug it's typically an indication of a possible problem. PNOTE: Only the reader, fieldname, and cached value are actually tested -- if two cache entries have different parsers or datatypes but the cached values are the same Object (== not just equal()) this method does not consider that a red flag. This allows for subtle variations in the way a Parser is specified (null vs DEFAULT_LONG_PARSER, etc...)

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker.InsanityType Fields

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType Fields
FieldCacheSanityChecker..::..InsanityType Class See Also Send Feedback

The FieldCacheSanityChecker..::..InsanityType type exposes the following members.

Fields

Name | Description
EXPECTED | Indicates an expected bit of "insanity". This may be useful for clients that wish to preserve/log information about insane usage but indicate that it was expected.
SUBREADER | Indicates an overlap in cache usage on a given field in sub/super readers.
VALUEMISMATCH | Indicates entries have the same reader+fieldname but different cached values. This can happen if different datatypes, or parsers are used -- and while it's not necessarily a bug it's typically an indication of a possible problem. PNOTE: Only the reader, fieldname, and cached value are actually tested -- if two cache entries have different parsers or datatypes but the cached values are the same Object (== not just equal()) this method does not consider that a red flag. This allows for subtle variations in the way a Parser is specified (null vs DEFAULT_LONG_PARSER, etc...)

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


EXPECTED Field

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType..::..EXPECTED Field
FieldCacheSanityChecker..::..InsanityType Class See Also Send Feedback
Indicates an expected bit of "insanity". This may be useful for clients that wish to preserve/log information about insane usage but indicate that it was expected.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldCacheSanityChecker..::..InsanityType EXPECTED
Visual Basic
Public Shared ReadOnly EXPECTED As FieldCacheSanityChecker..::..InsanityType
Visual C++
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ EXPECTED

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


SUBREADER Field

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType..::..SUBREADER Field
FieldCacheSanityChecker..::..InsanityType Class See Also Send Feedback
Indicates an overlap in cache usage on a given field in sub/super readers.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldCacheSanityChecker..::..InsanityType SUBREADER
Visual Basic
Public Shared ReadOnly SUBREADER As FieldCacheSanityChecker..::..InsanityType
Visual C++
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ SUBREADER

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


VALUEMISMATCH Field

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType..::..VALUEMISMATCH Field
FieldCacheSanityChecker..::..InsanityType Class See Also Send Feedback

Indicates entries have the same reader+fieldname but different cached values. This can happen if different datatypes, or parsers are used -- and while it's not necessarily a bug it's typically an indication of a possible problem.

PNOTE: Only the reader, fieldname, and cached value are actually tested -- if two cache entries have different parsers or datatypes but the cached values are the same Object (== not just equal()) this method does not consider that a red flag. This allows for subtle variations in the way a Parser is specified (null vs DEFAULT_LONG_PARSER, etc...)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly FieldCacheSanityChecker..::..InsanityType VALUEMISMATCH
Visual Basic
Public Shared ReadOnly VALUEMISMATCH As FieldCacheSanityChecker..::..InsanityType
Visual C++
public:
static initonly FieldCacheSanityChecker..::..InsanityType^ VALUEMISMATCH

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


FieldCacheSanityChecker.InsanityType Methods

[image] [image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType Methods
FieldCacheSanityChecker..::..InsanityType Class See Also Send Feedback

The FieldCacheSanityChecker..::..InsanityType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


ToString Method

[image]

Lucene.Net Class Libraries
FieldCacheSanityChecker..::..InsanityType..::..ToString Method
FieldCacheSanityChecker..::..InsanityType Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.InsanityType.ToString"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.FieldCacheSanityChecker.InsanityType.ToString"]

See Also

FieldCacheSanityChecker..::..InsanityType Class
Lucene.Net.Util Namespace


IndexableBinaryStringTools Class

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools Class
Members See Also Send Feedback
Provides support for converting byte sequences to Strings and back again. The resulting Strings preserve the original byte sequences' sort order. The Strings are constructed using a Base 8000h encoding of the original binary data - each char of an encoded String represents a 15-bit chunk from the byte sequence. Base 8000h was chosen because it allows for all lower 15 bits of char to be used without restriction; the surrogate range [U+D8000-U+DFFF] does not represent valid chars, and would require complicated handling to avoid them and allow use of char's high bit. Although unset bits are used as padding in the final char, the original byte sequence could contain trailing bytes with no set bits (null bytes): padding is indistinguishable from valid information. To overcome this problem, a char is appended, indicating the number of encoded bytes in the final content char. This class's operations are defined over CharBuffers and ByteBuffers, to allow for wrapped arrays to be reused, reducing memory allocation costs for repeated operations. Note that this class calls array() and arrayOffset() on the CharBuffers and ByteBuffers it uses, so only wrapped arrays may be used. This class interprets the arrayOffset() and limit() values returned by its input buffers as beginning and end+1 positions on the wrapped array, resprectively; similarly, on the output buffer, arrayOffset() is the first position written to, and limit() is set to one past the final output array position.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class IndexableBinaryStringTools
Visual Basic
Public Class IndexableBinaryStringTools
Visual C++
public ref class IndexableBinaryStringTools

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..IndexableBinaryStringTools

See Also

IndexableBinaryStringTools Members
Lucene.Net.Util Namespace


IndexableBinaryStringTools Members

[image] [image]

Lucene.Net Class Libraries
IndexableBinaryStringTools Members
IndexableBinaryStringTools Class Methods See Also Send Feedback

The IndexableBinaryStringTools type exposes the following members.

Methods

 | Name | Description
 | Decode(List<(Of <<'(Char>)>>)) | Decodes the given char sequence, which must have been encoded by {@link #Encode(java.nio.ByteBuffer)} or {@link #Encode(java.nio.ByteBuffer, java.nio.CharBuffer)}.
 | Decode(List<(Of <<'(Char>)>>), List<(Of <<'(Byte>)>>)) | Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling {@link #GetDecodedLength(java.nio.CharBuffer)}.
 | Encode(List<(Of <<'(Byte>)>>)) | Encodes the input byte sequence.
 | Encode(List<(Of <<'(Byte>)>>), List<(Of <<'(Char>)>>)) | Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling {@link #GetEncodedLength(java.nio.ByteBuffer)}.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDecodedLength | Returns the number of bytes required to decode the given char sequence.
 | GetEncodedLength | Returns the number of chars required to encode the given byte sequence.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexableBinaryStringTools Class
Lucene.Net.Util Namespace


IndexableBinaryStringTools Methods

[image] [image]

Lucene.Net Class Libraries
IndexableBinaryStringTools Methods
IndexableBinaryStringTools Class See Also Send Feedback

The IndexableBinaryStringTools type exposes the following members.

Methods

 | Name | Description
 | Decode(List<(Of <<'(Char>)>>)) | Decodes the given char sequence, which must have been encoded by {@link #Encode(java.nio.ByteBuffer)} or {@link #Encode(java.nio.ByteBuffer, java.nio.CharBuffer)}.
 | Decode(List<(Of <<'(Char>)>>), List<(Of <<'(Byte>)>>)) | Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling {@link #GetDecodedLength(java.nio.CharBuffer)}.
 | Encode(List<(Of <<'(Byte>)>>)) | Encodes the input byte sequence.
 | Encode(List<(Of <<'(Byte>)>>), List<(Of <<'(Char>)>>)) | Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling {@link #GetEncodedLength(java.nio.ByteBuffer)}.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDecodedLength | Returns the number of bytes required to decode the given char sequence.
 | GetEncodedLength | Returns the number of chars required to encode the given byte sequence.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexableBinaryStringTools Class
Lucene.Net.Util Namespace


Decode Method

[image] [image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..Decode Method
IndexableBinaryStringTools Class See Also Send Feedback

Overload List

Name | Description
Decode(List<(Of <<'(Char>)>>)) | Decodes the given char sequence, which must have been encoded by {@link #Encode(java.nio.ByteBuffer)} or {@link #Encode(java.nio.ByteBuffer, java.nio.CharBuffer)}.
Decode(List<(Of <<'(Char>)>>), List<(Of <<'(Byte>)>>)) | Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling {@link #GetDecodedLength(java.nio.CharBuffer)}.

See Also

IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace


Decode Method (List(Char))

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..Decode Method (List<(Of <(<'Char>)>)>)
IndexableBinaryStringTools Class See Also Send Feedback
Decodes the given char sequence, which must have been encoded by {@link #Encode(java.nio.ByteBuffer)} or {@link #Encode(java.nio.ByteBuffer, java.nio.CharBuffer)}.
array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static List<byte> Decode(
    List<char> input
)
Visual Basic
Public Shared Function Decode ( _
    input As List(Of Char) _
) As List(Of Byte)
Visual C++
public:
static List<unsigned char>^ Decode(
    List<wchar_t>^ input
)

Parameters

input
Type: System.Collections.Generic..::..List <(Of <(<' Char >)>)>
The char sequence to decode

Return Value

A byte sequence containing the decoding result. The limit is set to one past the position of the final char.

See Also

IndexableBinaryStringTools Class
Decode Overload
Lucene.Net.Util Namespace


Decode Method (List(Char), List(Byte))

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..Decode Method (List<(Of <(<'Char>)>)>, List<(Of <(<'Byte>)>)>)
IndexableBinaryStringTools Class See Also Send Feedback
Decodes the input char sequence into the output byte sequence. Before calling this method, ensure that the output ByteBuffer has sufficient capacity by calling {@link #GetDecodedLength(java.nio.CharBuffer)}.
is not backed by an array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Decode(
    List<char> input,
    List<byte> output
)
Visual Basic
Public Shared Sub Decode ( _
    input As List(Of Char), _
    output As List(Of Byte) _
)
Visual C++
public:
static void Decode(
    List<wchar_t>^ input,
    List<unsigned char>^ output
)

Parameters

input
Type: System.Collections.Generic..::..List <(Of <(<' Char >)>)>
The char sequence to decode
output
Type: System.Collections.Generic..::..List <(Of <(<' Byte >)>)>
Where the byte sequence decoding result will go. The limit is set to one past the position of the final char.

See Also

IndexableBinaryStringTools Class
Decode Overload
Lucene.Net.Util Namespace


Encode Method

[image] [image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..Encode Method
IndexableBinaryStringTools Class See Also Send Feedback

Overload List

Name | Description
Encode(List<(Of <<'(Byte>)>>)) | Encodes the input byte sequence.
Encode(List<(Of <<'(Byte>)>>), List<(Of <<'(Char>)>>)) | Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling {@link #GetEncodedLength(java.nio.ByteBuffer)}.

See Also

IndexableBinaryStringTools Class
IndexableBinaryStringTools Members
Lucene.Net.Util Namespace


Encode Method (List(Byte))

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..Encode Method (List<(Of <(<'Byte>)>)>)
IndexableBinaryStringTools Class See Also Send Feedback
Encodes the input byte sequence.
array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static List<char> Encode(
    List<byte> input
)
Visual Basic
Public Shared Function Encode ( _
    input As List(Of Byte) _
) As List(Of Char)
Visual C++
public:
static List<wchar_t>^ Encode(
    List<unsigned char>^ input
)

Parameters

input
Type: System.Collections.Generic..::..List <(Of <(<' Byte >)>)>
The byte sequence to encode

Return Value

A char sequence containing the encoding result. The limit is set to one past the position of the final char.

See Also

IndexableBinaryStringTools Class
Encode Overload
Lucene.Net.Util Namespace


Encode Method (List(Byte), List(Char))

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..Encode Method (List<(Of <(<'Byte>)>)>, List<(Of <(<'Char>)>)>)
IndexableBinaryStringTools Class See Also Send Feedback
Encodes the input byte sequence into the output char sequence. Before calling this method, ensure that the output CharBuffer has sufficient capacity by calling {@link #GetEncodedLength(java.nio.ByteBuffer)}.
is not backed by an array

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void Encode(
    List<byte> input,
    List<char> output
)
Visual Basic
Public Shared Sub Encode ( _
    input As List(Of Byte), _
    output As List(Of Char) _
)
Visual C++
public:
static void Encode(
    List<unsigned char>^ input,
    List<wchar_t>^ output
)

Parameters

input
Type: System.Collections.Generic..::..List <(Of <(<' Byte >)>)>
The byte sequence to encode
output
Type: System.Collections.Generic..::..List <(Of <(<' Char >)>)>
Where the char sequence encoding result will go. The limit is set to one past the position of the final char.

See Also

IndexableBinaryStringTools Class
Encode Overload
Lucene.Net.Util Namespace


GetDecodedLength Method

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..GetDecodedLength Method
IndexableBinaryStringTools Class See Also Send Feedback
Returns the number of bytes required to decode the given char sequence.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetDecodedLength(
    List<char> encoded
)
Visual Basic
Public Shared Function GetDecodedLength ( _
    encoded As List(Of Char) _
) As Integer
Visual C++
public:
static int GetDecodedLength(
    List<wchar_t>^ encoded
)

Parameters

encoded
Type: System.Collections.Generic..::..List <(Of <(<' Char >)>)>
The char sequence to be encoded. Must be backed by an array.

Return Value

The number of bytes required to decode the given char sequence

See Also

IndexableBinaryStringTools Class
Lucene.Net.Util Namespace


GetEncodedLength Method

[image]

Lucene.Net Class Libraries
IndexableBinaryStringTools..::..GetEncodedLength Method
IndexableBinaryStringTools Class See Also Send Feedback
Returns the number of chars required to encode the given byte sequence.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int GetEncodedLength(
    List<byte> original
)
Visual Basic
Public Shared Function GetEncodedLength ( _
    original As List(Of Byte) _
) As Integer
Visual C++
public:
static int GetEncodedLength(
    List<unsigned char>^ original
)

Parameters

original
Type: System.Collections.Generic..::..List <(Of <(<' Byte >)>)>
The byte sequence to be encoded. Must be backed by an array.

Return Value

The number of chars required to encode the given byte sequence

See Also

IndexableBinaryStringTools Class
Lucene.Net.Util Namespace


MapOfSets(T, V) Class

[image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)> Class
Members See Also Send Feedback
Helper class for keeping Listss of Objects associated with keys. WARNING: THIS CLASS IS NOT THREAD SAFE

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class MapOfSets<T, V>
Visual Basic
Public Class MapOfSets(Of T, V)
Visual C++
generic<typename T, typename V>
public ref class MapOfSets

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Lucene.Net.Util.MapOfSets`2"]

V

[Missing <typeparam name="V"/> documentation for "T:Lucene.Net.Util.MapOfSets`2"]

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..MapOfSets<(Of <(<'T, V>)>)>

See Also

MapOfSets<(Of <(<'T, V>)>)> Members
Lucene.Net.Util Namespace


MapOfSets(T, V) Members

[image] [image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)> Members
MapOfSets<(Of <(<'T, V>)>)> Class Constructors Methods See Also Send Feedback

The MapOfSets<(Of <(<'T, V>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | MapOfSets<(Of <(<'T, V>)>)> | Initializes a new instance of the MapOfSets<(Of <(<'T, V>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMap |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Adds val to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | PutAll | Adds multiple vals to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapOfSets<(Of <(<'T, V>)>)> Class
Lucene.Net.Util Namespace


MapOfSets(T, V) Constructor

[image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)> Constructor
MapOfSets<(Of <(<'T, V>)>)> Class See Also Send Feedback
Initializes a new instance of the MapOfSets<(Of <(<'T, V>)>)> class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public MapOfSets(
    IDictionary<T, Dictionary<V, V>> m
)
Visual Basic
Public Sub New ( _
    m As IDictionary(Of T, Dictionary(Of V, V)) _
)
Visual C++
public:
MapOfSets(
    IDictionary<T, Dictionary<V, V>^>^ m
)

Parameters

m
Type: System.Collections.Generic..::..IDictionary <(Of <(<' T, Dictionary <(Of <(<' V, V >)>)>>)>)>
the backing store for this object

See Also

MapOfSets<(Of <(<'T, V>)>)> Class
Lucene.Net.Util Namespace


MapOfSets(T, V) Methods

[image] [image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)> Methods
MapOfSets<(Of <(<'T, V>)>)> Class See Also Send Feedback

The MapOfSets<(Of <(<'T, V>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMap |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Adds val to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | PutAll | Adds multiple vals to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapOfSets<(Of <(<'T, V>)>)> Class
Lucene.Net.Util Namespace


GetMap Method

[image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)>..::..GetMap Method
MapOfSets<(Of <(<'T, V>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.MapOfSets`2.GetMap"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual IDictionary<T, Dictionary<V, V>> GetMap()
Visual Basic
Public Overridable Function GetMap As IDictionary(Of T, Dictionary(Of V, V))
Visual C++
public:
virtual IDictionary<T, Dictionary<V, V>^>^ GetMap()

Return Value

direct access to the map backing this object.

See Also

MapOfSets<(Of <(<'T, V>)>)> Class
Lucene.Net.Util Namespace


Put Method

[image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)>..::..Put Method
MapOfSets<(Of <(<'T, V>)>)> Class See Also Send Feedback
Adds val to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Put(
    T key,
    V val
)
Visual Basic
Public Overridable Function Put ( _
    key As T, _
    val As V _
) As Integer
Visual C++
public:
virtual int Put(
    T key,
    V val
)

Parameters

key
Type: T

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.MapOfSets`2.Put(`0,`1)"]

val
Type: V

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.MapOfSets`2.Put(`0,`1)"]

Return Value

the size of the Set associated with key once val is added to it.

See Also

MapOfSets<(Of <(<'T, V>)>)> Class
Lucene.Net.Util Namespace


PutAll Method

[image]

Lucene.Net Class Libraries
MapOfSets<(Of <(<'T, V>)>)>..::..PutAll Method
MapOfSets<(Of <(<'T, V>)>)> Class See Also Send Feedback
Adds multiple vals to the Set associated with key in the Map. If key is not already in the map, a new Set will first be created.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int PutAll(
    T key,
    Dictionary<V, V> vals
)
Visual Basic
Public Overridable Function PutAll ( _
    key As T, _
    vals As Dictionary(Of V, V) _
) As Integer
Visual C++
public:
virtual int PutAll(
    T key,
    Dictionary<V, V>^ vals
)

Parameters

key
Type: T

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.MapOfSets`2.PutAll(`0,System.Collections.Generic.Dictionary{`1,`1})"]

vals
Type: System.Collections.Generic..::..Dictionary <(Of <(<' V, V >)>)>

[Missing <param name="vals"/> documentation for "M:Lucene.Net.Util.MapOfSets`2.PutAll(`0,System.Collections.Generic.Dictionary{`1,`1})"]

Return Value

the size of the Set associated with key once val is added to it.

See Also

MapOfSets<(Of <(<'T, V>)>)> Class
Lucene.Net.Util Namespace


MemoryModel Class

[image]

Lucene.Net Class Libraries
MemoryModel Class
Members See Also Send Feedback
Returns primitive memory sizes for estimating RAM usage.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class MemoryModel
Visual Basic
Public MustInherit Class MemoryModel
Visual C++
public ref class MemoryModel abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..MemoryModel
Lucene.Net.Util..::..AverageGuessMemoryModel

See Also

MemoryModel Members
Lucene.Net.Util Namespace


MemoryModel Members

[image] [image]

Lucene.Net Class Libraries
MemoryModel Members
MemoryModel Class Constructors Methods See Also Send Feedback

The MemoryModel type exposes the following members.

Constructors

 | Name | Description
Protected method | MemoryModel | Initializes a new instance of the MemoryModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArraySize |
Public method | GetClassSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrimitiveSize |
Public method | GetReferenceSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoryModel Class
Lucene.Net.Util Namespace


MemoryModel Constructor

[image]

Lucene.Net Class Libraries
MemoryModel Constructor
MemoryModel Class See Also Send Feedback
Initializes a new instance of the MemoryModel class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected MemoryModel()
Visual Basic
Protected Sub New
Visual C++
protected:
MemoryModel()

See Also

MemoryModel Class
Lucene.Net.Util Namespace


MemoryModel Methods

[image] [image]

Lucene.Net Class Libraries
MemoryModel Methods
MemoryModel Class See Also Send Feedback

The MemoryModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArraySize |
Public method | GetClassSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrimitiveSize |
Public method | GetReferenceSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoryModel Class
Lucene.Net.Util Namespace


GetArraySize Method

[image]

Lucene.Net Class Libraries
MemoryModel..::..GetArraySize Method
MemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.MemoryModel.GetArraySize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetArraySize()
Visual Basic
Public MustOverride Function GetArraySize As Integer
Visual C++
public:
virtual int GetArraySize() abstract

Return Value

size of array beyond contents

See Also

MemoryModel Class
Lucene.Net.Util Namespace


GetClassSize Method

[image]

Lucene.Net Class Libraries
MemoryModel..::..GetClassSize Method
MemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.MemoryModel.GetClassSize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetClassSize()
Visual Basic
Public MustOverride Function GetClassSize As Integer
Visual C++
public:
virtual int GetClassSize() abstract

Return Value

Class size overhead

See Also

MemoryModel Class
Lucene.Net.Util Namespace


GetPrimitiveSize Method

[image]

Lucene.Net Class Libraries
MemoryModel..::..GetPrimitiveSize Method
MemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.MemoryModel.GetPrimitiveSize(System.Type)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetPrimitiveSize(
    Type clazz
)
Visual Basic
Public MustOverride Function GetPrimitiveSize ( _
    clazz As Type _
) As Integer
Visual C++
public:
virtual int GetPrimitiveSize(
    Type^ clazz
) abstract

Parameters

clazz
Type: System..::..Type
a primitive Class - bool, byte, char, short, long, float, short, double, int

Return Value

the size in bytes of given primitive Class

See Also

MemoryModel Class
Lucene.Net.Util Namespace


GetReferenceSize Method

[image]

Lucene.Net Class Libraries
MemoryModel..::..GetReferenceSize Method
MemoryModel Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.MemoryModel.GetReferenceSize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract int GetReferenceSize()
Visual Basic
Public MustOverride Function GetReferenceSize As Integer
Visual C++
public:
virtual int GetReferenceSize() abstract

Return Value

size of reference

See Also

MemoryModel Class
Lucene.Net.Util Namespace


NumericUtils Class

[image]

Lucene.Net Class Libraries
NumericUtils Class
Members See Also Send Feedback
This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the

CopyC#
shift
value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: {@link #doubleToSortableLong}, {@link #floatToSortableInt}. You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: {@link java.util.Date#getTime}).

For easy usage, the trie algorithm is implemented for indexing inside {@link NumericTokenStream} that can index

CopyC#
int
,
CopyC#
long
,
CopyC#
float
, and
CopyC#
double
. For querying, {@link NumericRangeQuery} and {@link NumericRangeFilter} implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according {@link String#compareTo(String)}) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class NumericUtils
Visual Basic
Public NotInheritable Class NumericUtils
Visual C++
public ref class NumericUtils sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..NumericUtils

See Also

NumericUtils Members
Lucene.Net.Util Namespace


NumericUtils Members

[image] [image]

Lucene.Net Class Libraries
NumericUtils Members
NumericUtils Class Methods Fields See Also Send Feedback

The NumericUtils type exposes the following members.

Methods

Name Description
DoubleToPrefixCoded
Convenience method: this just returns: longToPrefixCoded(doubleToSortableLong(val))
DoubleToSortableLong
Converts a
CopyC#
double
 value to a sortable signed
CopyC#
long
. The value is converted by getting their IEEE 754 floating-point "double format" bit layout and then some bits are swapped, to be able to compare the result as long. By this the precision is not reduced, but the value can easily used as a long.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
FloatToPrefixCoded
Convenience method: this just returns: intToPrefixCoded(floatToSortableInt(val))
FloatToSortableInt
Converts a
CopyC#
float
 value to a sortable signed
CopyC#
int
. The value is converted by getting their IEEE 754 floating-point "float format" bit layout and then some bits are swapped, to be able to compare the result as int. By this the precision is not reduced, but the value can easily used as an int.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IntToPrefixCoded(Int32)
This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToInt}.

IntToPrefixCoded(Int32, Int32)
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link IntRangeBuilder}.
IntToPrefixCoded(Int32, Int32, array<Char>[]()[][])
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.
LongToPrefixCoded(Int64)
This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToLong}.

LongToPrefixCoded(Int64, Int32)
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link LongRangeBuilder}.
LongToPrefixCoded(Int64, Int32, array<Char>[]()[][])
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
PrefixCodedToDouble
Convenience method: this just returns: sortableLongToDouble(prefixCodedToLong(val))
PrefixCodedToFloat
Convenience method: this just returns: sortableIntToFloat(prefixCodedToInt(val))
PrefixCodedToInt
Returns an int from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
PrefixCodedToLong
Returns a long from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
SortableIntToFloat
Converts a sortable
CopyC#
int
 back to a
CopyC#
float
.
SortableLongToDouble
Converts a sortable
CopyC#
long
 back to a
CopyC#
double
.
SplitIntRange
Expert: Splits an int range recursively. You may implement a builder that adds clauses to a {@link Lucene.Net.Search.BooleanQuery} for each call to its {@link IntRangeBuilder#AddRange(String,String)} method.

This method is used by {@link NumericRangeQuery}.

SplitLongRange
Expert: Splits a long range recursively. You may implement a builder that adds clauses to a {@link Lucene.Net.Search.BooleanQuery} for each call to its {@link LongRangeBuilder#AddRange(String,String)} method.

This method is used by {@link NumericRangeQuery}.

Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Fields

Name Description
BUF_SIZE_INT
Expert: The maximum term length (used for
CopyC#
char[]
 buffer size) for encoding
CopyC#
int
 values.
BUF_SIZE_LONG
Expert: The maximum term length (used for
CopyC#
char[]
 buffer size) for encoding
CopyC#
long
 values.
PRECISION_STEP_DEFAULT
The default precision step used by {@link NumericField}, {@link NumericTokenStream}, {@link NumericRangeQuery}, and {@link NumericRangeFilter} as default
SHIFT_START_INT
Expert: Integers are stored at lower precision by shifting off lower bits. The shift count is stored as
CopyC#
SHIFT_START_INT+shift
 in the first character
SHIFT_START_LONG
Expert: Longs are stored at lower precision by shifting off lower bits. The shift count is stored as
CopyC#
SHIFT_START_LONG+shift
 in the first character

See Also

NumericUtils Class
Lucene.Net.Util Namespace


NumericUtils Fields

[image] [image]

Lucene.Net Class Libraries
NumericUtils Fields
NumericUtils Class See Also Send Feedback

The NumericUtils type exposes the following members.

Fields

Name Description
BUF_SIZE_INT
Expert: The maximum term length (used for
CopyC#
char[]
 buffer size) for encoding
CopyC#
int
 values.
BUF_SIZE_LONG
Expert: The maximum term length (used for
CopyC#
char[]
 buffer size) for encoding
CopyC#
long
 values.
PRECISION_STEP_DEFAULT
The default precision step used by {@link NumericField}, {@link NumericTokenStream}, {@link NumericRangeQuery}, and {@link NumericRangeFilter} as default
SHIFT_START_INT
Expert: Integers are stored at lower precision by shifting off lower bits. The shift count is stored as
CopyC#
SHIFT_START_INT+shift
 in the first character
SHIFT_START_LONG
Expert: Longs are stored at lower precision by shifting off lower bits. The shift count is stored as
CopyC#
SHIFT_START_LONG+shift
 in the first character

See Also

NumericUtils Class
Lucene.Net.Util Namespace


BUF_SIZE_INT Field

[image]

Lucene.Net Class Libraries
NumericUtils..::..BUF_SIZE_INT Field
NumericUtils Class See Also Send Feedback
Expert: The maximum term length (used for
CopyC#
char[]
 buffer size) for encoding
CopyC#
int
 values.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int BUF_SIZE_INT
Visual Basic
Public Const BUF_SIZE_INT As Integer
Visual C++
public:
literal int BUF_SIZE_INT

See Also

NumericUtils Class
Lucene.Net.Util Namespace
NumericUtils..::..IntToPrefixCoded(Int32, Int32, array<Char>[]()[][])


BUF_SIZE_LONG Field

[image]

Lucene.Net Class Libraries
NumericUtils..::..BUF_SIZE_LONG Field
NumericUtils Class See Also Send Feedback
Expert: The maximum term length (used for
CopyC#
char[]
 buffer size) for encoding
CopyC#
long
 values.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int BUF_SIZE_LONG
Visual Basic
Public Const BUF_SIZE_LONG As Integer
Visual C++
public:
literal int BUF_SIZE_LONG

See Also

NumericUtils Class
Lucene.Net.Util Namespace
NumericUtils..::..LongToPrefixCoded(Int64, Int32, array<Char>[]()[][])


PRECISION_STEP_DEFAULT Field

[image]

Lucene.Net Class Libraries
NumericUtils..::..PRECISION_STEP_DEFAULT Field
NumericUtils Class See Also Send Feedback
The default precision step used by {@link NumericField}, {@link NumericTokenStream}, {@link NumericRangeQuery}, and {@link NumericRangeFilter} as default

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int PRECISION_STEP_DEFAULT
Visual Basic
Public Const PRECISION_STEP_DEFAULT As Integer
Visual C++
public:
literal int PRECISION_STEP_DEFAULT

See Also

NumericUtils Class
Lucene.Net.Util Namespace


SHIFT_START_INT Field

[image]

Lucene.Net Class Libraries
NumericUtils..::..SHIFT_START_INT Field
NumericUtils Class See Also Send Feedback
Expert: Integers are stored at lower precision by shifting off lower bits. The shift count is stored as
CopyC#
SHIFT_START_INT+shift
 in the first character

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static char SHIFT_START_INT
Visual Basic
Public Shared SHIFT_START_INT As Char
Visual C++
public:
static wchar_t SHIFT_START_INT

See Also

NumericUtils Class
Lucene.Net.Util Namespace


SHIFT_START_LONG Field

[image]

Lucene.Net Class Libraries
NumericUtils..::..SHIFT_START_LONG Field
NumericUtils Class See Also Send Feedback
Expert: Longs are stored at lower precision by shifting off lower bits. The shift count is stored as
CopyC#
SHIFT_START_LONG+shift
 in the first character

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static char SHIFT_START_LONG
Visual Basic
Public Shared SHIFT_START_LONG As Char
Visual C++
public:
static wchar_t SHIFT_START_LONG

See Also

NumericUtils Class
Lucene.Net.Util Namespace


NumericUtils Methods

[image] [image]

Lucene.Net Class Libraries
NumericUtils Methods
NumericUtils Class See Also Send Feedback

The NumericUtils type exposes the following members.

Methods

Name Description
DoubleToPrefixCoded
Convenience method: this just returns: longToPrefixCoded(doubleToSortableLong(val))
DoubleToSortableLong
Converts a
CopyC#
double
 value to a sortable signed
CopyC#
long
. The value is converted by getting their IEEE 754 floating-point "double format" bit layout and then some bits are swapped, to be able to compare the result as long. By this the precision is not reduced, but the value can easily used as a long.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
FloatToPrefixCoded
Convenience method: this just returns: intToPrefixCoded(floatToSortableInt(val))
FloatToSortableInt
Converts a
CopyC#
float
 value to a sortable signed
CopyC#
int
. The value is converted by getting their IEEE 754 floating-point "float format" bit layout and then some bits are swapped, to be able to compare the result as int. By this the precision is not reduced, but the value can easily used as an int.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IntToPrefixCoded(Int32)
This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToInt}.

IntToPrefixCoded(Int32, Int32)
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link IntRangeBuilder}.
IntToPrefixCoded(Int32, Int32, array<Char>[]()[][])
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.
LongToPrefixCoded(Int64)
This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToLong}.

LongToPrefixCoded(Int64, Int32)
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link LongRangeBuilder}.
LongToPrefixCoded(Int64, Int32, array<Char>[]()[][])
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
PrefixCodedToDouble
Convenience method: this just returns: sortableLongToDouble(prefixCodedToLong(val))
PrefixCodedToFloat
Convenience method: this just returns: sortableIntToFloat(prefixCodedToInt(val))
PrefixCodedToInt
Returns an int from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
PrefixCodedToLong
Returns a long from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
SortableIntToFloat
Converts a sortable
CopyC#
int
 back to a
CopyC#
float
.
SortableLongToDouble
Converts a sortable
CopyC#
long
 back to a
CopyC#
double
.
SplitIntRange
Expert: Splits an int range recursively. You may implement a builder that adds clauses to a {@link Lucene.Net.Search.BooleanQuery} for each call to its {@link IntRangeBuilder#AddRange(String,String)} method.

This method is used by {@link NumericRangeQuery}.

SplitLongRange
Expert: Splits a long range recursively. You may implement a builder that adds clauses to a {@link Lucene.Net.Search.BooleanQuery} for each call to its {@link LongRangeBuilder#AddRange(String,String)} method.

This method is used by {@link NumericRangeQuery}.

Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

NumericUtils Class
Lucene.Net.Util Namespace


DoubleToPrefixCoded Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..DoubleToPrefixCoded Method
NumericUtils Class See Also Send Feedback
Convenience method: this just returns: longToPrefixCoded(doubleToSortableLong(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string DoubleToPrefixCoded(
    double val
)
Visual Basic
Public Shared Function DoubleToPrefixCoded ( _
    val As Double _
) As String
Visual C++
public:
static String^ DoubleToPrefixCoded(
    double val
)

Parameters

val
Type: System..::..Double

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.DoubleToPrefixCoded(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.DoubleToPrefixCoded(System.Double)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace


DoubleToSortableLong Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..DoubleToSortableLong Method
NumericUtils Class See Also Send Feedback
Converts a
CopyC#
double
 value to a sortable signed
CopyC#
long
. The value is converted by getting their IEEE 754 floating-point "double format" bit layout and then some bits are swapped, to be able to compare the result as long. By this the precision is not reduced, but the value can easily used as a long.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long DoubleToSortableLong(
    double val
)
Visual Basic
Public Shared Function DoubleToSortableLong ( _
    val As Double _
) As Long
Visual C++
public:
static long long DoubleToSortableLong(
    double val
)

Parameters

val
Type: System..::..Double

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.DoubleToSortableLong(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.DoubleToSortableLong(System.Double)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace
[!:sortableLongToDouble]


FloatToPrefixCoded Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..FloatToPrefixCoded Method
NumericUtils Class See Also Send Feedback
Convenience method: this just returns: intToPrefixCoded(floatToSortableInt(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string FloatToPrefixCoded(
    float val
)
Visual Basic
Public Shared Function FloatToPrefixCoded ( _
    val As Single _
) As String
Visual C++
public:
static String^ FloatToPrefixCoded(
    float val
)

Parameters

val
Type: System..::..Single

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.FloatToPrefixCoded(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.FloatToPrefixCoded(System.Single)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace


FloatToSortableInt Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..FloatToSortableInt Method
NumericUtils Class See Also Send Feedback
Converts a
CopyC#
float
 value to a sortable signed
CopyC#
int
. The value is converted by getting their IEEE 754 floating-point "float format" bit layout and then some bits are swapped, to be able to compare the result as int. By this the precision is not reduced, but the value can easily used as an int.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int FloatToSortableInt(
    float val
)
Visual Basic
Public Shared Function FloatToSortableInt ( _
    val As Single _
) As Integer
Visual C++
public:
static int FloatToSortableInt(
    float val
)

Parameters

val
Type: System..::..Single

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.FloatToSortableInt(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.FloatToSortableInt(System.Single)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace
[!:sortableIntToFloat]


IntToPrefixCoded Method

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..IntToPrefixCoded Method
NumericUtils Class See Also Send Feedback

Overload List

Name Description
IntToPrefixCoded(Int32)
This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToInt}.

IntToPrefixCoded(Int32, Int32)
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link IntRangeBuilder}.
IntToPrefixCoded(Int32, Int32, array<Char>[]()[][])
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.

See Also

NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace


IntToPrefixCoded Method (Int32)

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntToPrefixCoded Method (Int32)
NumericUtils Class See Also Send Feedback
This is a convenience method, that returns prefix coded bits of an int without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToInt}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string IntToPrefixCoded(
    int val
)
Visual Basic
Public Shared Function IntToPrefixCoded ( _
    val As Integer _
) As String
Visual C++
public:
static String^ IntToPrefixCoded(
    int val
)

Parameters

val
Type: System..::..Int32

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.IntToPrefixCoded(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.IntToPrefixCoded(System.Int32)"]

See Also

NumericUtils Class
IntToPrefixCoded Overload
Lucene.Net.Util Namespace


IntToPrefixCoded Method (Int32, Int32)

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntToPrefixCoded Method (Int32, Int32)
NumericUtils Class See Also Send Feedback
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link IntRangeBuilder}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string IntToPrefixCoded(
    int val,
    int shift
)
Visual Basic
Public Shared Function IntToPrefixCoded ( _
    val As Integer, _
    shift As Integer _
) As String
Visual C++
public:
static String^ IntToPrefixCoded(
    int val,
    int shift
)

Parameters

val
Type: System..::..Int32
the numeric value
shift
Type: System..::..Int32
how many bits to strip from the right

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.IntToPrefixCoded(System.Int32,System.Int32)"]

See Also

NumericUtils Class
IntToPrefixCoded Overload
Lucene.Net.Util Namespace


IntToPrefixCoded Method (Int32, Int32, Char[])

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntToPrefixCoded Method (Int32, Int32, array<Char>[]()[][])
NumericUtils Class See Also Send Feedback
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int IntToPrefixCoded(
    int val,
    int shift,
    char[] buffer
)
Visual Basic
Public Shared Function IntToPrefixCoded ( _
    val As Integer, _
    shift As Integer, _
    buffer As Char() _
) As Integer
Visual C++
public:
static int IntToPrefixCoded(
    int val,
    int shift,
    array<wchar_t>^ buffer
)

Parameters

val
Type: System..::..Int32
the numeric value
shift
Type: System..::..Int32
how many bits to strip from the right
buffer
Type: array< System..::..Char >[]()[][]
that will contain the encoded chars, must be at least of {@link #BUF_SIZE_INT} length

Return Value

number of chars written to buffer

See Also

NumericUtils Class
IntToPrefixCoded Overload
Lucene.Net.Util Namespace


LongToPrefixCoded Method

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..LongToPrefixCoded Method
NumericUtils Class See Also Send Feedback

Overload List

Name Description
LongToPrefixCoded(Int64)
This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToLong}.

LongToPrefixCoded(Int64, Int32)
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link LongRangeBuilder}.
LongToPrefixCoded(Int64, Int32, array<Char>[]()[][])
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.

See Also

NumericUtils Class
NumericUtils Members
Lucene.Net.Util Namespace


LongToPrefixCoded Method (Int64)

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongToPrefixCoded Method (Int64)
NumericUtils Class See Also Send Feedback
This is a convenience method, that returns prefix coded bits of a long without reducing the precision. It can be used to store the full precision value as a stored field in index.

To decode, use {@link #prefixCodedToLong}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string LongToPrefixCoded(
    long val
)
Visual Basic
Public Shared Function LongToPrefixCoded ( _
    val As Long _
) As String
Visual C++
public:
static String^ LongToPrefixCoded(
    long long val
)

Parameters

val
Type: System..::..Int64

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.LongToPrefixCoded(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.LongToPrefixCoded(System.Int64)"]

See Also

NumericUtils Class
LongToPrefixCoded Overload
Lucene.Net.Util Namespace


LongToPrefixCoded Method (Int64, Int32)

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongToPrefixCoded Method (Int64, Int32)
NumericUtils Class See Also Send Feedback
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link LongRangeBuilder}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string LongToPrefixCoded(
    long val,
    int shift
)
Visual Basic
Public Shared Function LongToPrefixCoded ( _
    val As Long, _
    shift As Integer _
) As String
Visual C++
public:
static String^ LongToPrefixCoded(
    long long val,
    int shift
)

Parameters

val
Type: System..::..Int64
the numeric value
shift
Type: System..::..Int32
how many bits to strip from the right

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.LongToPrefixCoded(System.Int64,System.Int32)"]

See Also

NumericUtils Class
LongToPrefixCoded Overload
Lucene.Net.Util Namespace


LongToPrefixCoded Method (Int64, Int32, Char[])

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongToPrefixCoded Method (Int64, Int32, array<Char>[]()[][])
NumericUtils Class See Also Send Feedback
Expert: Returns prefix coded bits after reducing the precision by
CopyC#
shift
 bits. This is method is used by {@link NumericTokenStream}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int LongToPrefixCoded(
    long val,
    int shift,
    char[] buffer
)
Visual Basic
Public Shared Function LongToPrefixCoded ( _
    val As Long, _
    shift As Integer, _
    buffer As Char() _
) As Integer
Visual C++
public:
static int LongToPrefixCoded(
    long long val,
    int shift,
    array<wchar_t>^ buffer
)

Parameters

val
Type: System..::..Int64
the numeric value
shift
Type: System..::..Int32
how many bits to strip from the right
buffer
Type: array< System..::..Char >[]()[][]
that will contain the encoded chars, must be at least of {@link #BUF_SIZE_LONG} length

Return Value

number of chars written to buffer

See Also

NumericUtils Class
LongToPrefixCoded Overload
Lucene.Net.Util Namespace


PrefixCodedToDouble Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..PrefixCodedToDouble Method
NumericUtils Class See Also Send Feedback
Convenience method: this just returns: sortableLongToDouble(prefixCodedToLong(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static double PrefixCodedToDouble(
    string val
)
Visual Basic
Public Shared Function PrefixCodedToDouble ( _
    val As String _
) As Double
Visual C++
public:
static double PrefixCodedToDouble(
    String^ val
)

Parameters

val
Type: System..::..String

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToDouble(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToDouble(System.String)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace


PrefixCodedToFloat Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..PrefixCodedToFloat Method
NumericUtils Class See Also Send Feedback
Convenience method: this just returns: sortableIntToFloat(prefixCodedToInt(val))

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float PrefixCodedToFloat(
    string val
)
Visual Basic
Public Shared Function PrefixCodedToFloat ( _
    val As String _
) As Single
Visual C++
public:
static float PrefixCodedToFloat(
    String^ val
)

Parameters

val
Type: System..::..String

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToFloat(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToFloat(System.String)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace


PrefixCodedToInt Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..PrefixCodedToInt Method
NumericUtils Class See Also Send Feedback
Returns an int from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
not correctly prefix encoded.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int PrefixCodedToInt(
    string prefixCoded
)
Visual Basic
Public Shared Function PrefixCodedToInt ( _
    prefixCoded As String _
) As Integer
Visual C++
public:
static int PrefixCodedToInt(
    String^ prefixCoded
)

Parameters

prefixCoded
Type: System..::..String

[Missing <param name="prefixCoded"/> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToInt(System.String)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace
NumericUtils..::..IntToPrefixCoded(Int32)


PrefixCodedToLong Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..PrefixCodedToLong Method
NumericUtils Class See Also Send Feedback
Returns a long from prefixCoded characters. Rightmost bits will be zero for lower precision codes. This method can be used to decode e.g. a stored field.
not correctly prefix encoded.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long PrefixCodedToLong(
    string prefixCoded
)
Visual Basic
Public Shared Function PrefixCodedToLong ( _
    prefixCoded As String _
) As Long
Visual C++
public:
static long long PrefixCodedToLong(
    String^ prefixCoded
)

Parameters

prefixCoded
Type: System..::..String

[Missing <param name="prefixCoded"/> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToLong(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.PrefixCodedToLong(System.String)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace
NumericUtils..::..LongToPrefixCoded(Int64)


SortableIntToFloat Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..SortableIntToFloat Method
NumericUtils Class See Also Send Feedback
Converts a sortable
CopyC#
int
 back to a
CopyC#
float
.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float SortableIntToFloat(
    int val
)
Visual Basic
Public Shared Function SortableIntToFloat ( _
    val As Integer _
) As Single
Visual C++
public:
static float SortableIntToFloat(
    int val
)

Parameters

val
Type: System..::..Int32

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.SortableIntToFloat(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.SortableIntToFloat(System.Int32)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace
[!:floatToSortableInt]


SortableLongToDouble Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..SortableLongToDouble Method
NumericUtils Class See Also Send Feedback
Converts a sortable
CopyC#
long
 back to a
CopyC#
double
.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static double SortableLongToDouble(
    long val
)
Visual Basic
Public Shared Function SortableLongToDouble ( _
    val As Long _
) As Double
Visual C++
public:
static double SortableLongToDouble(
    long long val
)

Parameters

val
Type: System..::..Int64

[Missing <param name="val"/> documentation for "M:Lucene.Net.Util.NumericUtils.SortableLongToDouble(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.NumericUtils.SortableLongToDouble(System.Int64)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace
[!:doubleToSortableLong]


SplitIntRange Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..SplitIntRange Method
NumericUtils Class See Also Send Feedback
Expert: Splits an int range recursively. You may implement a builder that adds clauses to a {@link Lucene.Net.Search.BooleanQuery} for each call to its {@link IntRangeBuilder#AddRange(String,String)} method.

This method is used by {@link NumericRangeQuery}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SplitIntRange(
    NumericUtils..::..IntRangeBuilder builder,
    int precisionStep,
    int minBound,
    int maxBound
)
Visual Basic
Public Shared Sub SplitIntRange ( _
    builder As NumericUtils..::..IntRangeBuilder, _
    precisionStep As Integer, _
    minBound As Integer, _
    maxBound As Integer _
)
Visual C++
public:
static void SplitIntRange(
    NumericUtils..::..IntRangeBuilder^ builder,
    int precisionStep,
    int minBound,
    int maxBound
)

Parameters

builder
Type: Lucene.Net.Util..::..NumericUtils..::..IntRangeBuilder

[Missing <param name="builder"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitIntRange(Lucene.Net.Util.NumericUtils.IntRangeBuilder,System.Int32,System.Int32,System.Int32)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitIntRange(Lucene.Net.Util.NumericUtils.IntRangeBuilder,System.Int32,System.Int32,System.Int32)"]

minBound
Type: System..::..Int32

[Missing <param name="minBound"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitIntRange(Lucene.Net.Util.NumericUtils.IntRangeBuilder,System.Int32,System.Int32,System.Int32)"]

maxBound
Type: System..::..Int32

[Missing <param name="maxBound"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitIntRange(Lucene.Net.Util.NumericUtils.IntRangeBuilder,System.Int32,System.Int32,System.Int32)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace


SplitLongRange Method

[image]

Lucene.Net Class Libraries
NumericUtils..::..SplitLongRange Method
NumericUtils Class See Also Send Feedback
Expert: Splits a long range recursively. You may implement a builder that adds clauses to a {@link Lucene.Net.Search.BooleanQuery} for each call to its {@link LongRangeBuilder#AddRange(String,String)} method.

This method is used by {@link NumericRangeQuery}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void SplitLongRange(
    NumericUtils..::..LongRangeBuilder builder,
    int precisionStep,
    long minBound,
    long maxBound
)
Visual Basic
Public Shared Sub SplitLongRange ( _
    builder As NumericUtils..::..LongRangeBuilder, _
    precisionStep As Integer, _
    minBound As Long, _
    maxBound As Long _
)
Visual C++
public:
static void SplitLongRange(
    NumericUtils..::..LongRangeBuilder^ builder,
    int precisionStep,
    long long minBound,
    long long maxBound
)

Parameters

builder
Type: Lucene.Net.Util..::..NumericUtils..::..LongRangeBuilder

[Missing <param name="builder"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitLongRange(Lucene.Net.Util.NumericUtils.LongRangeBuilder,System.Int32,System.Int64,System.Int64)"]

precisionStep
Type: System..::..Int32

[Missing <param name="precisionStep"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitLongRange(Lucene.Net.Util.NumericUtils.LongRangeBuilder,System.Int32,System.Int64,System.Int64)"]

minBound
Type: System..::..Int64

[Missing <param name="minBound"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitLongRange(Lucene.Net.Util.NumericUtils.LongRangeBuilder,System.Int32,System.Int64,System.Int64)"]

maxBound
Type: System..::..Int64

[Missing <param name="maxBound"/> documentation for "M:Lucene.Net.Util.NumericUtils.SplitLongRange(Lucene.Net.Util.NumericUtils.LongRangeBuilder,System.Int32,System.Int64,System.Int64)"]

See Also

NumericUtils Class
Lucene.Net.Util Namespace


NumericUtils.IntRangeBuilder Class

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder Class
NumericUtils Class Members See Also Send Feedback
Expert: Callback for {@link #splitIntRange}. You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class IntRangeBuilder
Visual Basic
Public MustInherit Class IntRangeBuilder
Visual C++
public ref class IntRangeBuilder abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..NumericUtils..::..IntRangeBuilder

See Also

NumericUtils..::..IntRangeBuilder Members
Lucene.Net.Util Namespace


NumericUtils.IntRangeBuilder Members

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder Members
NumericUtils..::..IntRangeBuilder Class Constructors Methods See Also Send Feedback

This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the

CopyC#
shift
value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: {@link #doubleToSortableLong}, {@link #floatToSortableInt}. You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: {@link java.util.Date#getTime}).

For easy usage, the trie algorithm is implemented for indexing inside {@link NumericTokenStream} that can index

CopyC#
int
,
CopyC#
long
,
CopyC#
float
, and
CopyC#
double
. For querying, {@link NumericRangeQuery} and {@link NumericRangeFilter} implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according {@link String#compareTo(String)}) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.

The NumericUtils..::..IntRangeBuilder type exposes the following members.

Constructors

 | Name | Description
Protected method | NumericUtils..::..IntRangeBuilder | Initializes a new instance of the NumericUtils..::..IntRangeBuilder class

Methods

 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.
Public method | AddRange(Int32, Int32, Int32) | Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericUtils..::..IntRangeBuilder Class
Lucene.Net.Util Namespace


NumericUtils.IntRangeBuilder Constructor

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder Constructor
NumericUtils..::..IntRangeBuilder Class See Also Send Feedback
Initializes a new instance of the NumericUtils..::..IntRangeBuilder class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected IntRangeBuilder()
Visual Basic
Protected Sub New
Visual C++
protected:
IntRangeBuilder()

See Also

NumericUtils..::..IntRangeBuilder Class
Lucene.Net.Util Namespace


NumericUtils.IntRangeBuilder Methods

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder Methods
NumericUtils..::..IntRangeBuilder Class See Also Send Feedback

The NumericUtils..::..IntRangeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.
Public method | AddRange(Int32, Int32, Int32) | Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericUtils..::..IntRangeBuilder Class
Lucene.Net.Util Namespace


AddRange Method

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder..::..AddRange Method
NumericUtils..::..IntRangeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.
Public method | AddRange(Int32, Int32, Int32) | Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).

See Also

NumericUtils..::..IntRangeBuilder Class
NumericUtils..::..IntRangeBuilder Members
Lucene.Net.Util Namespace


AddRange Method (String, String)

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder..::..AddRange Method (String, String)
NumericUtils..::..IntRangeBuilder Class See Also Send Feedback
Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical range (inclusive) queries from them.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddRange(
    string minPrefixCoded,
    string maxPrefixCoded
)
Visual Basic
Public Overridable Sub AddRange ( _
    minPrefixCoded As String, _
    maxPrefixCoded As String _
)
Visual C++
public:
virtual void AddRange(
    String^ minPrefixCoded,
    String^ maxPrefixCoded
)

Parameters

minPrefixCoded
Type: System..::..String

[Missing <param name="minPrefixCoded"/> documentation for "M:Lucene.Net.Util.NumericUtils.IntRangeBuilder.AddRange(System.String,System.String)"]

maxPrefixCoded
Type: System..::..String

[Missing <param name="maxPrefixCoded"/> documentation for "M:Lucene.Net.Util.NumericUtils.IntRangeBuilder.AddRange(System.String,System.String)"]

See Also

NumericUtils..::..IntRangeBuilder Class
AddRange Overload
Lucene.Net.Util Namespace


AddRange Method (Int32, Int32, Int32)

[image]

Lucene.Net Class Libraries
NumericUtils..::..IntRangeBuilder..::..AddRange Method (Int32, Int32, Int32)
NumericUtils..::..IntRangeBuilder Class See Also Send Feedback
Overwrite this method, if you like to receive the raw int range bounds. You can use this for e.g. debugging purposes (print out range bounds).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddRange(
    int min,
    int max,
    int shift
)
Visual Basic
Public Overridable Sub AddRange ( _
    min As Integer, _
    max As Integer, _
    shift As Integer _
)
Visual C++
public:
virtual void AddRange(
    int min,
    int max,
    int shift
)

Parameters

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:Lucene.Net.Util.NumericUtils.IntRangeBuilder.AddRange(System.Int32,System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:Lucene.Net.Util.NumericUtils.IntRangeBuilder.AddRange(System.Int32,System.Int32,System.Int32)"]

shift
Type: System..::..Int32

[Missing <param name="shift"/> documentation for "M:Lucene.Net.Util.NumericUtils.IntRangeBuilder.AddRange(System.Int32,System.Int32,System.Int32)"]

See Also

NumericUtils..::..IntRangeBuilder Class
AddRange Overload
Lucene.Net.Util Namespace


NumericUtils.LongRangeBuilder Class

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder Class
NumericUtils Class Members See Also Send Feedback
Expert: Callback for {@link #splitLongRange}. You need to overwrite only one of the methods.

NOTE: This is a very low-level interface, the method signatures may change in later versions.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class LongRangeBuilder
Visual Basic
Public MustInherit Class LongRangeBuilder
Visual C++
public ref class LongRangeBuilder abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..NumericUtils..::..LongRangeBuilder

See Also

NumericUtils..::..LongRangeBuilder Members
Lucene.Net.Util Namespace


NumericUtils.LongRangeBuilder Members

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder Members
NumericUtils..::..LongRangeBuilder Class Constructors Methods See Also Send Feedback

This is a helper class to generate prefix-encoded representations for numerical values and supplies converters to represent float/double values as sortable integers/longs.

To quickly execute range queries in Apache Lucene, a range is divided recursively into multiple intervals for searching: The center of the range is searched only with the lowest possible precision in the trie, while the boundaries are matched more exactly. This reduces the number of terms dramatically.

This class generates terms to achive this: First the numerical integer values need to be converted to strings. For that integer values (32 bit or 64 bit) are made unsigned and the bits are converted to ASCII chars with each 7 bit. The resulting string is sortable like the original integer value. Each value is also prefixed (in the first char) by the

CopyC#
shift
value (number of bits removed) used during encoding.

To also index floating point numbers, this class supplies two methods to convert them to integer values by changing their bit layout: {@link #doubleToSortableLong}, {@link #floatToSortableInt}. You will have no precision loss by converting floating point numbers to integers and back (only that the integer form is not usable). Other data types like dates can easily converted to longs or ints (e.g. date to long: {@link java.util.Date#getTime}).

For easy usage, the trie algorithm is implemented for indexing inside {@link NumericTokenStream} that can index

CopyC#
int
,
CopyC#
long
,
CopyC#
float
, and
CopyC#
double
. For querying, {@link NumericRangeQuery} and {@link NumericRangeFilter} implement the query part for the same data types.

This class can also be used, to generate lexicographically sortable (according {@link String#compareTo(String)}) representations of numeric data types for other usages (e.g. sorting).

NOTE: This API is experimental and might change in incompatible ways in the next release.

The NumericUtils..::..LongRangeBuilder type exposes the following members.

Constructors

 | Name | Description
Protected method | NumericUtils..::..LongRangeBuilder | Initializes a new instance of the NumericUtils..::..LongRangeBuilder class

Methods

 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.
Public method | AddRange(Int64, Int64, Int32) | Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericUtils..::..LongRangeBuilder Class
Lucene.Net.Util Namespace


NumericUtils.LongRangeBuilder Constructor

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder Constructor
NumericUtils..::..LongRangeBuilder Class See Also Send Feedback
Initializes a new instance of the NumericUtils..::..LongRangeBuilder class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected LongRangeBuilder()
Visual Basic
Protected Sub New
Visual C++
protected:
LongRangeBuilder()

See Also

NumericUtils..::..LongRangeBuilder Class
Lucene.Net.Util Namespace


NumericUtils.LongRangeBuilder Methods

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder Methods
NumericUtils..::..LongRangeBuilder Class See Also Send Feedback

The NumericUtils..::..LongRangeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.
Public method | AddRange(Int64, Int64, Int32) | Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericUtils..::..LongRangeBuilder Class
Lucene.Net.Util Namespace


AddRange Method

[image] [image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder..::..AddRange Method
NumericUtils..::..LongRangeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRange(String, String) | Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.
Public method | AddRange(Int64, Int64, Int32) | Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).

See Also

NumericUtils..::..LongRangeBuilder Class
NumericUtils..::..LongRangeBuilder Members
Lucene.Net.Util Namespace


AddRange Method (String, String)

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder..::..AddRange Method (String, String)
NumericUtils..::..LongRangeBuilder Class See Also Send Feedback
Overwrite this method, if you like to receive the already prefix encoded range bounds. You can directly build classical (inclusive) range queries from them.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddRange(
    string minPrefixCoded,
    string maxPrefixCoded
)
Visual Basic
Public Overridable Sub AddRange ( _
    minPrefixCoded As String, _
    maxPrefixCoded As String _
)
Visual C++
public:
virtual void AddRange(
    String^ minPrefixCoded,
    String^ maxPrefixCoded
)

Parameters

minPrefixCoded
Type: System..::..String

[Missing <param name="minPrefixCoded"/> documentation for "M:Lucene.Net.Util.NumericUtils.LongRangeBuilder.AddRange(System.String,System.String)"]

maxPrefixCoded
Type: System..::..String

[Missing <param name="maxPrefixCoded"/> documentation for "M:Lucene.Net.Util.NumericUtils.LongRangeBuilder.AddRange(System.String,System.String)"]

See Also

NumericUtils..::..LongRangeBuilder Class
AddRange Overload
Lucene.Net.Util Namespace


AddRange Method (Int64, Int64, Int32)

[image]

Lucene.Net Class Libraries
NumericUtils..::..LongRangeBuilder..::..AddRange Method (Int64, Int64, Int32)
NumericUtils..::..LongRangeBuilder Class See Also Send Feedback
Overwrite this method, if you like to receive the raw long range bounds. You can use this for e.g. debugging purposes (print out range bounds).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AddRange(
    long min,
    long max,
    int shift
)
Visual Basic
Public Overridable Sub AddRange ( _
    min As Long, _
    max As Long, _
    shift As Integer _
)
Visual C++
public:
virtual void AddRange(
    long long min,
    long long max,
    int shift
)

Parameters

min
Type: System..::..Int64

[Missing <param name="min"/> documentation for "M:Lucene.Net.Util.NumericUtils.LongRangeBuilder.AddRange(System.Int64,System.Int64,System.Int32)"]

max
Type: System..::..Int64

[Missing <param name="max"/> documentation for "M:Lucene.Net.Util.NumericUtils.LongRangeBuilder.AddRange(System.Int64,System.Int64,System.Int32)"]

shift
Type: System..::..Int32

[Missing <param name="shift"/> documentation for "M:Lucene.Net.Util.NumericUtils.LongRangeBuilder.AddRange(System.Int64,System.Int64,System.Int32)"]

See Also

NumericUtils..::..LongRangeBuilder Class
AddRange Overload
Lucene.Net.Util Namespace


OpenBitSet Class

[image]

Lucene.Net Class Libraries
OpenBitSet Class
Members See Also Send Feedback
An "open" BitSet implementation that allows direct access to the array of words storing the bits.

Unlike java.util.bitset, the fact that bits are packed into an array of longs is part of the interface. This allows efficient implementation of other algorithms by someone other than the author. It also allows one to efficiently implement alternate serialization or interchange formats.

CopyC#
OpenBitSet
is faster than
CopyC#
java.util.BitSet
 in most operations and *much* faster at calculating cardinality of sets and results of set operations. It can also handle sets of larger cardinality (up to 64 * 2**32-1)

The goals of

CopyC#
OpenBitSet
are the fastest implementation possible, and maximum code reuse. Extra safety and encapsulation may always be built on top, but if that's built in, the cost can never be removed (and hence people re-implement their own version in order to get better performance). If you want a "safe", totally encapsulated (and slower and limited) BitSet class, use
CopyC#
java.util.BitSet
.

Performance Results

Test system: Pentium 4, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 3.36 | 3.96 | 1.44 | 1.46 | 1.99 | 1.58
1% full | 3.31 | 3.90 |  | 1.04 |  | 0.99

Test system: AMD Opteron, 64 bit linux, Sun Java 1.5_06 -server -Xbatch -Xmx64M
BitSet size = 1,000,000
Results are java.util.BitSet time divided by OpenBitSet time.
 | cardinality | intersect_count | union | nextSetBit | get | iterator
50% full | 2.50 | 3.50 | 1.00 | 1.03 | 1.12 | 1.25
1% full | 2.51 | 3.49 |  | 1.00 |  | 1.02

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class OpenBitSet : DocIdSet, ICloneable
Visual Basic
<SerializableAttribute> _
Public Class OpenBitSet _
    Inherits DocIdSet _
    Implements ICloneable
Visual C++
[SerializableAttribute]
public ref class OpenBitSet : public DocIdSet,
    ICloneable

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Util..::..OpenBitSet
Lucene.Net.Util..::..OpenBitSetDISI

See Also

OpenBitSet Members
Lucene.Net.Util Namespace


OpenBitSet Members

[image] [image]

Lucene.Net Class Libraries
OpenBitSet Members
OpenBitSet Class Constructors Methods Fields See Also Send Feedback

The OpenBitSet type exposes the following members.

Constructors

 | Name | Description
Public method | OpenBitSet()()()() | Initializes a new instance of the OpenBitSet class
Public method | OpenBitSet(Int64) | Constructs an OpenBitSet large enough to hold numBits.
Public method | OpenBitSet(array<Int64>[]()[][], Int32) | Constructs an OpenBitSet from an existing long[]. The first 64 bits are in long[0], with bit index 0 at the least significant bit, and bit index 63 at the most significant. Given a bit index, the word containing it is long[index/64], and it is at bit number index%64 within that word. numWords are the number of elements in the array that contain set bits (non-zero longs). numWords should be <= bits.length, and any existing words in the array at position >= numWords should be zero.

Methods

 | Name | Description
Public method | And |
Public method | AndNot |
 | AndNotCount | Returns the popcount or cardinality of "a and not b" or "intersection(a, not(b))". Neither set is modified.
 | Bits2words | returns the number of 64 bit words it would take to hold numBits
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit)
Public method | Cardinality |
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size.
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clone |
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call.
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call.
Public method | Equals | returns true if both sets have the same bits set (Overrides Object..::..Equals(Object).)
Protected method | ExpandingWordNum |
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | Get(Int32) | Returns true or false for the specified bit index.
Public method | Get(Int64) | Returns true or false for the specified bit index
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size
Public method | GetBits | Expert: returns the long[] storing the bits
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetNumWords | Expert: gets the number of longs in the array that are in use
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | this = this AND other
 | IntersectionCount | Returns the popcount or cardinality of the intersection of the two sets. Neither set is modified.
Public method | Intersects | returns true if the sets have any elements in common
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | IsEmpty | Returns true if there are no set bits
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | Or |
Public method | Remove | Remove all elements set in other. this = this AND_NOT other
Public method | Set(Int64) | sets a bit, expanding the set size if necessary
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary
Public method | SetBits | Expert: sets a new long[] to use as the bit storage
Public method | SetNumWords | Expert: sets the number of longs in the array that are in use
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to {@link #cardinality}
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words.
Public method | Union | this = this OR other
 | UnionCount | Returns the popcount or cardinality of the union of the two sets. Neither set is modified.
Public method | Xor | this = this XOR other
 | XorCount | Returns the popcount or cardinality of the exclusive-or of the two sets. Neither set is modified.

Fields

 | Name | Description
Protected field | bits |
Protected field | wlen |

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


OpenBitSet Constructor

[image] [image]

Lucene.Net Class Libraries
OpenBitSet Constructor
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenBitSet()()()() | Initializes a new instance of the OpenBitSet class
Public method | OpenBitSet(Int64) | Constructs an OpenBitSet large enough to hold numBits.
Public method | OpenBitSet(array<Int64>[]()[][], Int32) | Constructs an OpenBitSet from an existing long[]. The first 64 bits are in long[0], with bit index 0 at the least significant bit, and bit index 63 at the most significant. Given a bit index, the word containing it is long[index/64], and it is at bit number index%64 within that word. numWords are the number of elements in the array that contain set bits (non-zero longs). numWords should be <= bits.length, and any existing words in the array at position >= numWords should be zero.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


OpenBitSet Constructor

[image]

Lucene.Net Class Libraries
OpenBitSet Constructor
OpenBitSet Class See Also Send Feedback
Initializes a new instance of the OpenBitSet class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSet()
Visual Basic
Public Sub New
Visual C++
public:
OpenBitSet()

See Also

OpenBitSet Class
OpenBitSet Overload
Lucene.Net.Util Namespace


OpenBitSet Constructor (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet Constructor (Int64)
OpenBitSet Class See Also Send Feedback
Constructs an OpenBitSet large enough to hold numBits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSet(
    long numBits
)
Visual Basic
Public Sub New ( _
    numBits As Long _
)
Visual C++
public:
OpenBitSet(
    long long numBits
)

Parameters

numBits
Type: System..::..Int64

[Missing <param name="numBits"/> documentation for "M:Lucene.Net.Util.OpenBitSet.#ctor(System.Int64)"]

See Also

OpenBitSet Class
OpenBitSet Overload
Lucene.Net.Util Namespace


OpenBitSet Constructor (Int64[], Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet Constructor (array<Int64>[]()[][], Int32)
OpenBitSet Class See Also Send Feedback
Constructs an OpenBitSet from an existing long[].
The first 64 bits are in long[0], with bit index 0 at the least significant bit, and bit index 63 at the most significant. Given a bit index, the word containing it is long[index/64], and it is at bit number index%64 within that word.

numWords are the number of elements in the array that contain set bits (non-zero longs). numWords should be <= bits.length, and any existing words in the array at position >= numWords should be zero.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSet(
    long[] bits,
    int numWords
)
Visual Basic
Public Sub New ( _
    bits As Long(), _
    numWords As Integer _
)
Visual C++
public:
OpenBitSet(
    array<long long>^ bits,
    int numWords
)

Parameters

bits
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="bits"/> documentation for "M:Lucene.Net.Util.OpenBitSet.#ctor(System.Int64[],System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.OpenBitSet.#ctor(System.Int64[],System.Int32)"]

See Also

OpenBitSet Class
OpenBitSet Overload
Lucene.Net.Util Namespace


OpenBitSet Fields

[image] [image]

Lucene.Net Class Libraries
OpenBitSet Fields
OpenBitSet Class See Also Send Feedback

The OpenBitSet type exposes the following members.

Fields

 | Name | Description
Protected field | bits |
Protected field | wlen |

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


bits Field

[image]

Lucene.Net Class Libraries
OpenBitSet..::..bits Field
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.OpenBitSet.bits"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal long[] bits
Visual Basic
Protected Friend bits As Long()
Visual C++
protected public:
array<long long>^ bits

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


wlen Field

[image]

Lucene.Net Class Libraries
OpenBitSet..::..wlen Field
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.OpenBitSet.wlen"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal int wlen
Visual Basic
Protected Friend wlen As Integer
Visual C++
protected public:
int wlen

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


OpenBitSet Methods

[image] [image]

Lucene.Net Class Libraries
OpenBitSet Methods
OpenBitSet Class See Also Send Feedback

The OpenBitSet type exposes the following members.

Methods

 | Name | Description
Public method | And |
Public method | AndNot |
 | AndNotCount | Returns the popcount or cardinality of "a and not b" or "intersection(a, not(b))". Neither set is modified.
 | Bits2words | returns the number of 64 bit words it would take to hold numBits
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit)
Public method | Cardinality |
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size.
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clone |
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call.
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call.
Public method | Equals | returns true if both sets have the same bits set (Overrides Object..::..Equals(Object).)
Protected method | ExpandingWordNum |
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | Get(Int32) | Returns true or false for the specified bit index.
Public method | Get(Int64) | Returns true or false for the specified bit index
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size
Public method | GetBits | Expert: returns the long[] storing the bits
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetNumWords | Expert: gets the number of longs in the array that are in use
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | this = this AND other
 | IntersectionCount | Returns the popcount or cardinality of the intersection of the two sets. Neither set is modified.
Public method | Intersects | returns true if the sets have any elements in common
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | IsEmpty | Returns true if there are no set bits
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | Or |
Public method | Remove | Remove all elements set in other. this = this AND_NOT other
Public method | Set(Int64) | sets a bit, expanding the set size if necessary
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary
Public method | SetBits | Expert: sets a new long[] to use as the bit storage
Public method | SetNumWords | Expert: sets the number of longs in the array that are in use
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to {@link #cardinality}
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words.
Public method | Union | this = this OR other
 | UnionCount | Returns the popcount or cardinality of the union of the two sets. Neither set is modified.
Public method | Xor | this = this XOR other
 | XorCount | Returns the popcount or cardinality of the exclusive-or of the two sets. Neither set is modified.

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


And Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..And Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.And(Lucene.Net.Util.OpenBitSet)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void And(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub And ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void And(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.And(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


AndNot Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..AndNot Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.AndNot(Lucene.Net.Util.OpenBitSet)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void AndNot(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub AndNot ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void AndNot(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.AndNot(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


AndNotCount Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..AndNotCount Method
OpenBitSet Class See Also Send Feedback
Returns the popcount or cardinality of "a and not b" or "intersection(a, not(b))". Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long AndNotCount(
    OpenBitSet a,
    OpenBitSet b
)
Visual Basic
Public Shared Function AndNotCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Visual C++
public:
static long long AndNotCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)

Parameters

a
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="a"/> documentation for "M:Lucene.Net.Util.OpenBitSet.AndNotCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

b
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.OpenBitSet.AndNotCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.AndNotCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Bits2words Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Bits2words Method
OpenBitSet Class See Also Send Feedback
returns the number of 64 bit words it would take to hold numBits

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int Bits2words(
    long numBits
)
Visual Basic
Public Shared Function Bits2words ( _
    numBits As Long _
) As Integer
Visual C++
public:
static int Bits2words(
    long long numBits
)

Parameters

numBits
Type: System..::..Int64

[Missing <param name="numBits"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Bits2words(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Bits2words(System.Int64)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Capacity Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Capacity Method
OpenBitSet Class See Also Send Feedback
Returns the current capacity in bits (1 greater than the index of the last bit)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long Capacity()
Visual Basic
Public Overridable Function Capacity As Long
Visual C++
public:
virtual long long Capacity()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Capacity"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Cardinality Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Cardinality Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.Cardinality"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long Cardinality()
Visual Basic
Public Overridable Function Cardinality As Long
Visual C++
public:
virtual long long Cardinality()

Return Value

the number of set bits

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Clear Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..Clear Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size.
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set.
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


Clear Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Clear Method (Int64)
OpenBitSet Class See Also Send Feedback
clears a bit, allowing access beyond the current set size without changing the size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Clear(
    long index
)
Visual Basic
Public Overridable Sub Clear ( _
    index As Long _
)
Visual C++
public:
virtual void Clear(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Clear(System.Int64)"]

See Also

OpenBitSet Class
Clear Overload
Lucene.Net.Util Namespace


Clear Method (Int32, Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Clear Method (Int32, Int32)
OpenBitSet Class See Also Send Feedback
Clears a range of bits. Clearing past the end does not change the size of the set.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Clear(
    int startIndex,
    int endIndex
)
Visual Basic
Public Overridable Sub Clear ( _
    startIndex As Integer, _
    endIndex As Integer _
)
Visual C++
public:
virtual void Clear(
    int startIndex,
    int endIndex
)

Parameters

startIndex
Type: System..::..Int32
lower index
endIndex
Type: System..::..Int32
one-past the last bit to clear

See Also

OpenBitSet Class
Clear Overload
Lucene.Net.Util Namespace


Clear Method (Int64, Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Clear Method (Int64, Int64)
OpenBitSet Class See Also Send Feedback
Clears a range of bits. Clearing past the end does not change the size of the set.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Clear(
    long startIndex,
    long endIndex
)
Visual Basic
Public Overridable Sub Clear ( _
    startIndex As Long, _
    endIndex As Long _
)
Visual C++
public:
virtual void Clear(
    long long startIndex,
    long long endIndex
)

Parameters

startIndex
Type: System..::..Int64
lower index
endIndex
Type: System..::..Int64
one-past the last bit to clear

See Also

OpenBitSet Class
Clear Overload
Lucene.Net.Util Namespace


Clone Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Clone Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.Clone"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


EnsureCapacity Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..EnsureCapacity Method
OpenBitSet Class See Also Send Feedback
Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void EnsureCapacity(
    long numBits
)
Visual Basic
Public Overridable Sub EnsureCapacity ( _
    numBits As Long _
)
Visual C++
public:
virtual void EnsureCapacity(
    long long numBits
)

Parameters

numBits
Type: System..::..Int64

[Missing <param name="numBits"/> documentation for "M:Lucene.Net.Util.OpenBitSet.EnsureCapacity(System.Int64)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


EnsureCapacityWords Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..EnsureCapacityWords Method
OpenBitSet Class See Also Send Feedback
Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void EnsureCapacityWords(
    int numWords
)
Visual Basic
Public Overridable Sub EnsureCapacityWords ( _
    numWords As Integer _
)
Visual C++
public:
virtual void EnsureCapacityWords(
    int numWords
)

Parameters

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.OpenBitSet.EnsureCapacityWords(System.Int32)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Equals Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Equals Method
OpenBitSet Class See Also Send Feedback
returns true if both sets have the same bits set

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Equals(System.Object)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


ExpandingWordNum Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..ExpandingWordNum Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.ExpandingWordNum(System.Int64)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual int ExpandingWordNum(
    long index
)
Visual Basic
Protected Friend Overridable Function ExpandingWordNum ( _
    index As Long _
) As Integer
Visual C++
protected public:
virtual int ExpandingWordNum(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.ExpandingWordNum(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.ExpandingWordNum(System.Int64)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


FastClear Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..FastClear Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size.
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


FastClear Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastClear Method (Int32)
OpenBitSet Class See Also Send Feedback
clears a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FastClear(
    int index
)
Visual Basic
Public Overridable Sub FastClear ( _
    index As Integer _
)
Visual C++
public:
virtual void FastClear(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastClear(System.Int32)"]

See Also

OpenBitSet Class
FastClear Overload
Lucene.Net.Util Namespace


FastClear Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastClear Method (Int64)
OpenBitSet Class See Also Send Feedback
clears a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FastClear(
    long index
)
Visual Basic
Public Overridable Sub FastClear ( _
    index As Long _
)
Visual C++
public:
virtual void FastClear(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastClear(System.Int64)"]

See Also

OpenBitSet Class
FastClear Overload
Lucene.Net.Util Namespace


FastFlip Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..FastFlip Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size.
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


FastFlip Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastFlip Method (Int32)
OpenBitSet Class See Also Send Feedback
flips a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FastFlip(
    int index
)
Visual Basic
Public Overridable Sub FastFlip ( _
    index As Integer _
)
Visual C++
public:
virtual void FastFlip(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastFlip(System.Int32)"]

See Also

OpenBitSet Class
FastFlip Overload
Lucene.Net.Util Namespace


FastFlip Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastFlip Method (Int64)
OpenBitSet Class See Also Send Feedback
flips a bit. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FastFlip(
    long index
)
Visual Basic
Public Overridable Sub FastFlip ( _
    index As Long _
)
Visual C++
public:
virtual void FastFlip(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastFlip(System.Int64)"]

See Also

OpenBitSet Class
FastFlip Overload
Lucene.Net.Util Namespace


FastGet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..FastGet Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


FastGet Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastGet Method (Int32)
OpenBitSet Class See Also Send Feedback
Returns true or false for the specified bit index. The index should be less than the OpenBitSet size

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool FastGet(
    int index
)
Visual Basic
Public Overridable Function FastGet ( _
    index As Integer _
) As Boolean
Visual C++
public:
virtual bool FastGet(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastGet(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.FastGet(System.Int32)"]

See Also

OpenBitSet Class
FastGet Overload
Lucene.Net.Util Namespace


FastGet Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastGet Method (Int64)
OpenBitSet Class See Also Send Feedback
Returns true or false for the specified bit index. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool FastGet(
    long index
)
Visual Basic
Public Overridable Function FastGet ( _
    index As Long _
) As Boolean
Visual C++
public:
virtual bool FastGet(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastGet(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.FastGet(System.Int64)"]

See Also

OpenBitSet Class
FastGet Overload
Lucene.Net.Util Namespace


FastSet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..FastSet Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


FastSet Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastSet Method (Int32)
OpenBitSet Class See Also Send Feedback
Sets the bit at the specified index. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FastSet(
    int index
)
Visual Basic
Public Overridable Sub FastSet ( _
    index As Integer _
)
Visual C++
public:
virtual void FastSet(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastSet(System.Int32)"]

See Also

OpenBitSet Class
FastSet Overload
Lucene.Net.Util Namespace


FastSet Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FastSet Method (Int64)
OpenBitSet Class See Also Send Feedback
Sets the bit at the specified index. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void FastSet(
    long index
)
Visual Basic
Public Overridable Sub FastSet ( _
    index As Long _
)
Visual C++
public:
virtual void FastSet(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FastSet(System.Int64)"]

See Also

OpenBitSet Class
FastSet Overload
Lucene.Net.Util Namespace


Flip Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..Flip Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


Flip Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Flip Method (Int64)
OpenBitSet Class See Also Send Feedback
flips a bit, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Flip(
    long index
)
Visual Basic
Public Overridable Sub Flip ( _
    index As Long _
)
Visual C++
public:
virtual void Flip(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Flip(System.Int64)"]

See Also

OpenBitSet Class
Flip Overload
Lucene.Net.Util Namespace


Flip Method (Int64, Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Flip Method (Int64, Int64)
OpenBitSet Class See Also Send Feedback
Flips a range of bits, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Flip(
    long startIndex,
    long endIndex
)
Visual Basic
Public Overridable Sub Flip ( _
    startIndex As Long, _
    endIndex As Long _
)
Visual C++
public:
virtual void Flip(
    long long startIndex,
    long long endIndex
)

Parameters

startIndex
Type: System..::..Int64
lower index
endIndex
Type: System..::..Int64
one-past the last bit to flip

See Also

OpenBitSet Class
Flip Overload
Lucene.Net.Util Namespace


FlipAndGet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..FlipAndGet Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


FlipAndGet Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FlipAndGet Method (Int32)
OpenBitSet Class See Also Send Feedback
flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool FlipAndGet(
    int index
)
Visual Basic
Public Overridable Function FlipAndGet ( _
    index As Integer _
) As Boolean
Visual C++
public:
virtual bool FlipAndGet(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FlipAndGet(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.FlipAndGet(System.Int32)"]

See Also

OpenBitSet Class
FlipAndGet Overload
Lucene.Net.Util Namespace


FlipAndGet Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..FlipAndGet Method (Int64)
OpenBitSet Class See Also Send Feedback
flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool FlipAndGet(
    long index
)
Visual Basic
Public Overridable Function FlipAndGet ( _
    index As Long _
) As Boolean
Visual C++
public:
virtual bool FlipAndGet(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.FlipAndGet(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.FlipAndGet(System.Int64)"]

See Also

OpenBitSet Class
FlipAndGet Overload
Lucene.Net.Util Namespace


Get Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..Get Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(Int32) | Returns true or false for the specified bit index.
Public method | Get(Int64) | Returns true or false for the specified bit index

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


Get Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Get Method (Int32)
OpenBitSet Class See Also Send Feedback
Returns true or false for the specified bit index.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Get(
    int index
)
Visual Basic
Public Overridable Function Get ( _
    index As Integer _
) As Boolean
Visual C++
public:
virtual bool Get(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Get(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Get(System.Int32)"]

See Also

OpenBitSet Class
Get Overload
Lucene.Net.Util Namespace


Get Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Get Method (Int64)
OpenBitSet Class See Also Send Feedback
Returns true or false for the specified bit index

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Get(
    long index
)
Visual Basic
Public Overridable Function Get ( _
    index As Long _
) As Boolean
Visual C++
public:
virtual bool Get(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Get(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Get(System.Int64)"]

See Also

OpenBitSet Class
Get Overload
Lucene.Net.Util Namespace


GetAndSet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..GetAndSet Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


GetAndSet Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..GetAndSet Method (Int32)
OpenBitSet Class See Also Send Feedback
Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetAndSet(
    int index
)
Visual Basic
Public Overridable Function GetAndSet ( _
    index As Integer _
) As Boolean
Visual C++
public:
virtual bool GetAndSet(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.GetAndSet(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.GetAndSet(System.Int32)"]

See Also

OpenBitSet Class
GetAndSet Overload
Lucene.Net.Util Namespace


GetAndSet Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..GetAndSet Method (Int64)
OpenBitSet Class See Also Send Feedback
Sets a bit and returns the previous value. The index should be less than the OpenBitSet size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool GetAndSet(
    long index
)
Visual Basic
Public Overridable Function GetAndSet ( _
    index As Long _
) As Boolean
Visual C++
public:
virtual bool GetAndSet(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.GetAndSet(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.GetAndSet(System.Int64)"]

See Also

OpenBitSet Class
GetAndSet Overload
Lucene.Net.Util Namespace


GetBit Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..GetBit Method
OpenBitSet Class See Also Send Feedback
returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetBit(
    int index
)
Visual Basic
Public Overridable Function GetBit ( _
    index As Integer _
) As Integer
Visual C++
public:
virtual int GetBit(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.GetBit(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.GetBit(System.Int32)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


GetBits Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..GetBits Method
OpenBitSet Class See Also Send Feedback
Expert: returns the long[] storing the bits

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long[] GetBits()
Visual Basic
Public Overridable Function GetBits As Long()
Visual C++
public:
virtual array<long long>^ GetBits()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.GetBits"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


GetHashCode Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..GetHashCode Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.GetHashCode"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.GetHashCode"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


GetNumWords Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..GetNumWords Method
OpenBitSet Class See Also Send Feedback
Expert: gets the number of longs in the array that are in use

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetNumWords()
Visual Basic
Public Overridable Function GetNumWords As Integer
Visual C++
public:
virtual int GetNumWords()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.GetNumWords"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Intersect Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Intersect Method
OpenBitSet Class See Also Send Feedback
this = this AND other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Intersect(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub Intersect ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void Intersect(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Intersect(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


IntersectionCount Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..IntersectionCount Method
OpenBitSet Class See Also Send Feedback
Returns the popcount or cardinality of the intersection of the two sets. Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long IntersectionCount(
    OpenBitSet a,
    OpenBitSet b
)
Visual Basic
Public Shared Function IntersectionCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Visual C++
public:
static long long IntersectionCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)

Parameters

a
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="a"/> documentation for "M:Lucene.Net.Util.OpenBitSet.IntersectionCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

b
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.OpenBitSet.IntersectionCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.IntersectionCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Intersects Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Intersects Method
OpenBitSet Class See Also Send Feedback
returns true if the sets have any elements in common

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Intersects(
    OpenBitSet other
)
Visual Basic
Public Overridable Function Intersects ( _
    other As OpenBitSet _
) As Boolean
Visual C++
public:
virtual bool Intersects(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Intersects(Lucene.Net.Util.OpenBitSet)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Intersects(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..IsCacheable Method
OpenBitSet Class See Also Send Feedback
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCacheable()
Visual Basic
Public Overrides Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.IsCacheable"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


IsEmpty Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..IsEmpty Method
OpenBitSet Class See Also Send Feedback
Returns true if there are no set bits

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool IsEmpty()
Visual Basic
Public Overridable Function IsEmpty As Boolean
Visual C++
public:
virtual bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.IsEmpty"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Iterator Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.Iterator"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSetIterator Iterator()
Visual Basic
Public Overrides Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Iterator"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


NextSetBit Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..NextSetBit Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


NextSetBit Method (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..NextSetBit Method (Int32)
OpenBitSet Class See Also Send Feedback
Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int NextSetBit(
    int index
)
Visual Basic
Public Overridable Function NextSetBit ( _
    index As Integer _
) As Integer
Visual C++
public:
virtual int NextSetBit(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.NextSetBit(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.NextSetBit(System.Int32)"]

See Also

OpenBitSet Class
NextSetBit Overload
Lucene.Net.Util Namespace


NextSetBit Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..NextSetBit Method (Int64)
OpenBitSet Class See Also Send Feedback
Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long NextSetBit(
    long index
)
Visual Basic
Public Overridable Function NextSetBit ( _
    index As Long _
) As Long
Visual C++
public:
virtual long long NextSetBit(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.NextSetBit(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.NextSetBit(System.Int64)"]

See Also

OpenBitSet Class
NextSetBit Overload
Lucene.Net.Util Namespace


Or Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Or Method
OpenBitSet Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSet.Or(Lucene.Net.Util.OpenBitSet)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Or(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub Or ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void Or(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Or(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Remove Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Remove Method
OpenBitSet Class See Also Send Feedback
Remove all elements set in other. this = this AND_NOT other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Remove(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub Remove ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void Remove(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Remove(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Set Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSet..::..Set Method
OpenBitSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Int64) | sets a bit, expanding the set size if necessary
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary

See Also

OpenBitSet Class
OpenBitSet Members
Lucene.Net.Util Namespace


Set Method (Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Set Method (Int64)
OpenBitSet Class See Also Send Feedback
sets a bit, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Set(
    long index
)
Visual Basic
Public Overridable Sub Set ( _
    index As Long _
)
Visual C++
public:
virtual void Set(
    long long index
)

Parameters

index
Type: System..::..Int64

[Missing <param name="index"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Set(System.Int64)"]

See Also

OpenBitSet Class
Set Overload
Lucene.Net.Util Namespace


Set Method (Int64, Int64)

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Set Method (Int64, Int64)
OpenBitSet Class See Also Send Feedback
Sets a range of bits, expanding the set size if necessary

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Set(
    long startIndex,
    long endIndex
)
Visual Basic
Public Overridable Sub Set ( _
    startIndex As Long, _
    endIndex As Long _
)
Visual C++
public:
virtual void Set(
    long long startIndex,
    long long endIndex
)

Parameters

startIndex
Type: System..::..Int64
lower index
endIndex
Type: System..::..Int64
one-past the last bit to set

See Also

OpenBitSet Class
Set Overload
Lucene.Net.Util Namespace


SetBits Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..SetBits Method
OpenBitSet Class See Also Send Feedback
Expert: sets a new long[] to use as the bit storage

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetBits(
    long[] bits
)
Visual Basic
Public Overridable Sub SetBits ( _
    bits As Long() _
)
Visual C++
public:
virtual void SetBits(
    array<long long>^ bits
)

Parameters

bits
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="bits"/> documentation for "M:Lucene.Net.Util.OpenBitSet.SetBits(System.Int64[])"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


SetNumWords Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..SetNumWords Method
OpenBitSet Class See Also Send Feedback
Expert: sets the number of longs in the array that are in use

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void SetNumWords(
    int nWords
)
Visual Basic
Public Overridable Sub SetNumWords ( _
    nWords As Integer _
)
Visual C++
public:
virtual void SetNumWords(
    int nWords
)

Parameters

nWords
Type: System..::..Int32

[Missing <param name="nWords"/> documentation for "M:Lucene.Net.Util.OpenBitSet.SetNumWords(System.Int32)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Size Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Size Method
OpenBitSet Class See Also Send Feedback
Returns the current capacity of this set. Included for compatibility. This is *not* equal to {@link #cardinality}

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual long Size()
Visual Basic
Public Overridable Function Size As Long
Visual C++
public:
virtual long long Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.Size"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


TrimTrailingZeros Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..TrimTrailingZeros Method
OpenBitSet Class See Also Send Feedback
Lowers numWords, the number of words in use, by checking for trailing zero words.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void TrimTrailingZeros()
Visual Basic
Public Overridable Sub TrimTrailingZeros
Visual C++
public:
virtual void TrimTrailingZeros()

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Union Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Union Method
OpenBitSet Class See Also Send Feedback
this = this OR other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Union(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub Union ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void Union(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Union(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


UnionCount Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..UnionCount Method
OpenBitSet Class See Also Send Feedback
Returns the popcount or cardinality of the union of the two sets. Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long UnionCount(
    OpenBitSet a,
    OpenBitSet b
)
Visual Basic
Public Shared Function UnionCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Visual C++
public:
static long long UnionCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)

Parameters

a
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="a"/> documentation for "M:Lucene.Net.Util.OpenBitSet.UnionCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

b
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.OpenBitSet.UnionCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.UnionCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


Xor Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..Xor Method
OpenBitSet Class See Also Send Feedback
this = this XOR other

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void Xor(
    OpenBitSet other
)
Visual Basic
Public Overridable Sub Xor ( _
    other As OpenBitSet _
)
Visual C++
public:
virtual void Xor(
    OpenBitSet^ other
)

Parameters

other
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.OpenBitSet.Xor(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


XorCount Method

[image]

Lucene.Net Class Libraries
OpenBitSet..::..XorCount Method
OpenBitSet Class See Also Send Feedback
Returns the popcount or cardinality of the exclusive-or of the two sets. Neither set is modified.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static long XorCount(
    OpenBitSet a,
    OpenBitSet b
)
Visual Basic
Public Shared Function XorCount ( _
    a As OpenBitSet, _
    b As OpenBitSet _
) As Long
Visual C++
public:
static long long XorCount(
    OpenBitSet^ a,
    OpenBitSet^ b
)

Parameters

a
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="a"/> documentation for "M:Lucene.Net.Util.OpenBitSet.XorCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

b
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.OpenBitSet.XorCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSet.XorCount(Lucene.Net.Util.OpenBitSet,Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSet Class
Lucene.Net.Util Namespace


OpenBitSetDISI Class

[image]

Lucene.Net Class Libraries
OpenBitSetDISI Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Util.OpenBitSetDISI"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public class OpenBitSetDISI : OpenBitSet
Visual Basic
<SerializableAttribute> _
Public Class OpenBitSetDISI _
    Inherits OpenBitSet
Visual C++
[SerializableAttribute]
public ref class OpenBitSetDISI : public OpenBitSet

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Util..::..OpenBitSet
Lucene.Net.Util..::..OpenBitSetDISI

See Also

OpenBitSetDISI Members
Lucene.Net.Util Namespace


OpenBitSetDISI Members

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI Members
OpenBitSetDISI Class Constructors Methods Fields See Also Send Feedback

The OpenBitSetDISI type exposes the following members.

Constructors

 | Name | Description
Public method | OpenBitSetDISI(Int32) | Construct an OpenBitSetDISI with no bits set, and a given maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.
Public method | OpenBitSetDISI(DocIdSetIterator, Int32) | Construct an OpenBitSetDISI with its bits set from the doc ids of the given DocIdSetIterator. Also give a maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.

Methods

 | Name | Description
Public method | And | (Inherited from OpenBitSet.)
Public method | AndNot | (Inherited from OpenBitSet.)
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit) (Inherited from OpenBitSet.)
Public method | Cardinality | (Inherited from OpenBitSet.)
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size. (Inherited from OpenBitSet.)
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clone | (Inherited from OpenBitSet.)
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | Equals | returns true if both sets have the same bits set (Inherited from OpenBitSet.)
Protected method | ExpandingWordNum | (Inherited from OpenBitSet.)
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | Get(Int32) | Returns true or false for the specified bit index. (Inherited from OpenBitSet.)
Public method | Get(Int64) | Returns true or false for the specified bit index (Inherited from OpenBitSet.)
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | GetBits | Expert: returns the long[] storing the bits (Inherited from OpenBitSet.)
Public method | GetHashCode | (Inherited from OpenBitSet.)
Public method | GetNumWords | Expert: gets the number of longs in the array that are in use (Inherited from OpenBitSet.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InPlaceAnd | Perform an inplace AND with the doc ids from a given DocIdSetIterator, leaving only the bits set for which the doc ids are in common. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceNot | Perform an inplace NOT with the doc ids from a given DocIdSetIterator, clearing all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceOr | Perform an inplace OR with the doc ids from a given DocIdSetIterator, setting the bit for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceXor | Perform an inplace XOR with the doc ids from a given DocIdSetIterator, flipping all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | Intersect | this = this AND other (Inherited from OpenBitSet.)
Public method | Intersects | returns true if the sets have any elements in common (Inherited from OpenBitSet.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Inherited from OpenBitSet.)
Public method | IsEmpty | Returns true if there are no set bits (Inherited from OpenBitSet.)
Public method | Iterator | (Inherited from OpenBitSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | Or | (Inherited from OpenBitSet.)
Public method | Remove | Remove all elements set in other. this = this AND_NOT other (Inherited from OpenBitSet.)
Public method | Set(Int64) | sets a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | SetBits | Expert: sets a new long[] to use as the bit storage (Inherited from OpenBitSet.)
Public method | SetNumWords | Expert: sets the number of longs in the array that are in use (Inherited from OpenBitSet.)
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to {@link #cardinality} (Inherited from OpenBitSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words. (Inherited from OpenBitSet.)
Public method | Union | this = this OR other (Inherited from OpenBitSet.)
Public method | Xor | this = this XOR other (Inherited from OpenBitSet.)

Fields

 | Name | Description
Protected field | bits | (Inherited from OpenBitSet.)
Protected field | wlen | (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


OpenBitSetDISI Constructor

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI Constructor
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenBitSetDISI(Int32) | Construct an OpenBitSetDISI with no bits set, and a given maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.
Public method | OpenBitSetDISI(DocIdSetIterator, Int32) | Construct an OpenBitSetDISI with its bits set from the doc ids of the given DocIdSetIterator. Also give a maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


OpenBitSetDISI Constructor (Int32)

[image]

Lucene.Net Class Libraries
OpenBitSetDISI Constructor (Int32)
OpenBitSetDISI Class See Also Send Feedback
Construct an OpenBitSetDISI with no bits set, and a given maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSetDISI(
    int maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Integer _
)
Visual C++
public:
OpenBitSetDISI(
    int maxSize
)

Parameters

maxSize
Type: System..::..Int32

[Missing <param name="maxSize"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.#ctor(System.Int32)"]

See Also

OpenBitSetDISI Class
OpenBitSetDISI Overload
Lucene.Net.Util Namespace


OpenBitSetDISI Constructor (DocIdSetIterator, Int32)

[image]

Lucene.Net Class Libraries
OpenBitSetDISI Constructor (DocIdSetIterator, Int32)
OpenBitSetDISI Class See Also Send Feedback
Construct an OpenBitSetDISI with its bits set from the doc ids of the given DocIdSetIterator. Also give a maximum size one larger than the largest doc id for which a bit may ever be set on this OpenBitSetDISI.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSetDISI(
    DocIdSetIterator disi,
    int maxSize
)
Visual Basic
Public Sub New ( _
    disi As DocIdSetIterator, _
    maxSize As Integer _
)
Visual C++
public:
OpenBitSetDISI(
    DocIdSetIterator^ disi,
    int maxSize
)

Parameters

disi
Type: Lucene.Net.Search..::..DocIdSetIterator

[Missing <param name="disi"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.#ctor(Lucene.Net.Search.DocIdSetIterator,System.Int32)"]

maxSize
Type: System..::..Int32

[Missing <param name="maxSize"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.#ctor(Lucene.Net.Search.DocIdSetIterator,System.Int32)"]

See Also

OpenBitSetDISI Class
OpenBitSetDISI Overload
Lucene.Net.Util Namespace


OpenBitSetDISI Fields

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI Fields
OpenBitSetDISI Class See Also Send Feedback

The OpenBitSetDISI type exposes the following members.

Fields

 | Name | Description
Protected field | bits | (Inherited from OpenBitSet.)
Protected field | wlen | (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


OpenBitSetDISI Methods

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI Methods
OpenBitSetDISI Class See Also Send Feedback

The OpenBitSetDISI type exposes the following members.

Methods

 | Name | Description
Public method | And | (Inherited from OpenBitSet.)
Public method | AndNot | (Inherited from OpenBitSet.)
Public method | Capacity | Returns the current capacity in bits (1 greater than the index of the last bit) (Inherited from OpenBitSet.)
Public method | Cardinality | (Inherited from OpenBitSet.)
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size. (Inherited from OpenBitSet.)
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clone | (Inherited from OpenBitSet.)
Public method | EnsureCapacity | Ensure that the long[] is big enough to hold numBits, expanding it if necessary. getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | EnsureCapacityWords | Expand the long[] with the size given as a number of words (64 bit longs). getNumWords() is unchanged by this call. (Inherited from OpenBitSet.)
Public method | Equals | returns true if both sets have the same bits set (Inherited from OpenBitSet.)
Protected method | ExpandingWordNum | (Inherited from OpenBitSet.)
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | Get(Int32) | Returns true or false for the specified bit index. (Inherited from OpenBitSet.)
Public method | Get(Int64) | Returns true or false for the specified bit index (Inherited from OpenBitSet.)
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetBit | returns 1 if the bit is set, 0 if not. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | GetBits | Expert: returns the long[] storing the bits (Inherited from OpenBitSet.)
Public method | GetHashCode | (Inherited from OpenBitSet.)
Public method | GetNumWords | Expert: gets the number of longs in the array that are in use (Inherited from OpenBitSet.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InPlaceAnd | Perform an inplace AND with the doc ids from a given DocIdSetIterator, leaving only the bits set for which the doc ids are in common. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceNot | Perform an inplace NOT with the doc ids from a given DocIdSetIterator, clearing all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceOr | Perform an inplace OR with the doc ids from a given DocIdSetIterator, setting the bit for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | InPlaceXor | Perform an inplace XOR with the doc ids from a given DocIdSetIterator, flipping all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.
Public method | Intersect | this = this AND other (Inherited from OpenBitSet.)
Public method | Intersects | returns true if the sets have any elements in common (Inherited from OpenBitSet.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Inherited from OpenBitSet.)
Public method | IsEmpty | Returns true if there are no set bits (Inherited from OpenBitSet.)
Public method | Iterator | (Inherited from OpenBitSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | Or | (Inherited from OpenBitSet.)
Public method | Remove | Remove all elements set in other. this = this AND_NOT other (Inherited from OpenBitSet.)
Public method | Set(Int64) | sets a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | SetBits | Expert: sets a new long[] to use as the bit storage (Inherited from OpenBitSet.)
Public method | SetNumWords | Expert: sets the number of longs in the array that are in use (Inherited from OpenBitSet.)
Public method | Size | Returns the current capacity of this set. Included for compatibility. This is *not* equal to {@link #cardinality} (Inherited from OpenBitSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimTrailingZeros | Lowers numWords, the number of words in use, by checking for trailing zero words. (Inherited from OpenBitSet.)
Public method | Union | this = this OR other (Inherited from OpenBitSet.)
Public method | Xor | this = this XOR other (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


Clear Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..Clear Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear(Int64) | clears a bit, allowing access beyond the current set size without changing the size. (Inherited from OpenBitSet.)
Public method | Clear(Int32, Int32) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)
Public method | Clear(Int64, Int64) | Clears a range of bits. Clearing past the end does not change the size of the set. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


FastClear Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..FastClear Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastClear(Int32) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastClear(Int64) | clears a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


FastFlip Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..FastFlip Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastFlip(Int32) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastFlip(Int64) | flips a bit. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


FastGet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..FastGet Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastGet(Int32) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size (Inherited from OpenBitSet.)
Public method | FastGet(Int64) | Returns true or false for the specified bit index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


FastSet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..FastSet Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FastSet(Int32) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FastSet(Int64) | Sets the bit at the specified index. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


Flip Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..Flip Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Flip(Int64) | flips a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Flip(Int64, Int64) | Flips a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


FlipAndGet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..FlipAndGet Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FlipAndGet(Int32) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | FlipAndGet(Int64) | flips a bit and returns the resulting bit value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


Get Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..Get Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(Int32) | Returns true or false for the specified bit index. (Inherited from OpenBitSet.)
Public method | Get(Int64) | Returns true or false for the specified bit index (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


GetAndSet Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..GetAndSet Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAndSet(Int32) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)
Public method | GetAndSet(Int64) | Sets a bit and returns the previous value. The index should be less than the OpenBitSet size. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


InPlaceAnd Method

[image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..InPlaceAnd Method
OpenBitSetDISI Class See Also Send Feedback
Perform an inplace AND with the doc ids from a given DocIdSetIterator, leaving only the bits set for which the doc ids are in common. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void InPlaceAnd(
    DocIdSetIterator disi
)
Visual Basic
Public Overridable Sub InPlaceAnd ( _
    disi As DocIdSetIterator _
)
Visual C++
public:
virtual void InPlaceAnd(
    DocIdSetIterator^ disi
)

Parameters

disi
Type: Lucene.Net.Search..::..DocIdSetIterator

[Missing <param name="disi"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.InPlaceAnd(Lucene.Net.Search.DocIdSetIterator)"]

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


InPlaceNot Method

[image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..InPlaceNot Method
OpenBitSetDISI Class See Also Send Feedback
Perform an inplace NOT with the doc ids from a given DocIdSetIterator, clearing all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void InPlaceNot(
    DocIdSetIterator disi
)
Visual Basic
Public Overridable Sub InPlaceNot ( _
    disi As DocIdSetIterator _
)
Visual C++
public:
virtual void InPlaceNot(
    DocIdSetIterator^ disi
)

Parameters

disi
Type: Lucene.Net.Search..::..DocIdSetIterator

[Missing <param name="disi"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.InPlaceNot(Lucene.Net.Search.DocIdSetIterator)"]

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


InPlaceOr Method

[image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..InPlaceOr Method
OpenBitSetDISI Class See Also Send Feedback
Perform an inplace OR with the doc ids from a given DocIdSetIterator, setting the bit for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void InPlaceOr(
    DocIdSetIterator disi
)
Visual Basic
Public Overridable Sub InPlaceOr ( _
    disi As DocIdSetIterator _
)
Visual C++
public:
virtual void InPlaceOr(
    DocIdSetIterator^ disi
)

Parameters

disi
Type: Lucene.Net.Search..::..DocIdSetIterator

[Missing <param name="disi"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.InPlaceOr(Lucene.Net.Search.DocIdSetIterator)"]

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


InPlaceXor Method

[image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..InPlaceXor Method
OpenBitSetDISI Class See Also Send Feedback
Perform an inplace XOR with the doc ids from a given DocIdSetIterator, flipping all the bits for each such doc id. These doc ids should be smaller than the maximum size passed to the constructor.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void InPlaceXor(
    DocIdSetIterator disi
)
Visual Basic
Public Overridable Sub InPlaceXor ( _
    disi As DocIdSetIterator _
)
Visual C++
public:
virtual void InPlaceXor(
    DocIdSetIterator^ disi
)

Parameters

disi
Type: Lucene.Net.Search..::..DocIdSetIterator

[Missing <param name="disi"/> documentation for "M:Lucene.Net.Util.OpenBitSetDISI.InPlaceXor(Lucene.Net.Search.DocIdSetIterator)"]

See Also

OpenBitSetDISI Class
Lucene.Net.Util Namespace


NextSetBit Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..NextSetBit Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSetBit(Int32) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)
Public method | NextSetBit(Int64) | Returns the index of the first set bit starting at the index specified. -1 is returned if there are no more set bits. (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


Set Method

[image] [image]

Lucene.Net Class Libraries
OpenBitSetDISI..::..Set Method
OpenBitSetDISI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Int64) | sets a bit, expanding the set size if necessary (Inherited from OpenBitSet.)
Public method | Set(Int64, Int64) | Sets a range of bits, expanding the set size if necessary (Inherited from OpenBitSet.)

See Also

OpenBitSetDISI Class
OpenBitSetDISI Members
Lucene.Net.Util Namespace


OpenBitSetIterator Class

[image]

Lucene.Net Class Libraries
OpenBitSetIterator Class
Members See Also Send Feedback
An iterator to iterate over set bits in an OpenBitSet. This is faster than nextSetBit() for iterating over the complete set of bits, especially when the density of the bits set is high.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class OpenBitSetIterator : DocIdSetIterator
Visual Basic
Public Class OpenBitSetIterator _
    Inherits DocIdSetIterator
Visual C++
public ref class OpenBitSetIterator : public DocIdSetIterator

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSetIterator
Lucene.Net.Util..::..OpenBitSetIterator

See Also

OpenBitSetIterator Members
Lucene.Net.Util Namespace


OpenBitSetIterator Members

[image] [image]

Lucene.Net Class Libraries
OpenBitSetIterator Members
OpenBitSetIterator Class Constructors Methods Fields See Also Send Feedback

The OpenBitSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | OpenBitSetIterator(OpenBitSet) | Initializes a new instance of the OpenBitSetIterator class
Public method | OpenBitSetIterator(array<Int64>[]()[][], Int32) | Initializes a new instance of the OpenBitSetIterator class

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
bitlist |

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


OpenBitSetIterator Constructor

[image] [image]

Lucene.Net Class Libraries
OpenBitSetIterator Constructor
OpenBitSetIterator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenBitSetIterator(OpenBitSet) | Initializes a new instance of the OpenBitSetIterator class
Public method | OpenBitSetIterator(array<Int64>[]()[][], Int32) | Initializes a new instance of the OpenBitSetIterator class

See Also

OpenBitSetIterator Class
OpenBitSetIterator Members
Lucene.Net.Util Namespace


OpenBitSetIterator Constructor (OpenBitSet)

[image]

Lucene.Net Class Libraries
OpenBitSetIterator Constructor (OpenBitSet)
OpenBitSetIterator Class See Also Send Feedback
Initializes a new instance of the OpenBitSetIterator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSetIterator(
    OpenBitSet obs
)
Visual Basic
Public Sub New ( _
    obs As OpenBitSet _
)
Visual C++
public:
OpenBitSetIterator(
    OpenBitSet^ obs
)

Parameters

obs
Type: Lucene.Net.Util..::..OpenBitSet

[Missing <param name="obs"/> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.#ctor(Lucene.Net.Util.OpenBitSet)"]

See Also

OpenBitSetIterator Class
OpenBitSetIterator Overload
Lucene.Net.Util Namespace


OpenBitSetIterator Constructor (Int64[], Int32)

[image]

Lucene.Net Class Libraries
OpenBitSetIterator Constructor (array<Int64>[]()[][], Int32)
OpenBitSetIterator Class See Also Send Feedback
Initializes a new instance of the OpenBitSetIterator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public OpenBitSetIterator(
    long[] bits,
    int numWords
)
Visual Basic
Public Sub New ( _
    bits As Long(), _
    numWords As Integer _
)
Visual C++
public:
OpenBitSetIterator(
    array<long long>^ bits,
    int numWords
)

Parameters

bits
Type: array< System..::..Int64 >[]()[][]

[Missing <param name="bits"/> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.#ctor(System.Int64[],System.Int32)"]

numWords
Type: System..::..Int32

[Missing <param name="numWords"/> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.#ctor(System.Int64[],System.Int32)"]

See Also

OpenBitSetIterator Class
OpenBitSetIterator Overload
Lucene.Net.Util Namespace


OpenBitSetIterator Fields

[image] [image]

Lucene.Net Class Libraries
OpenBitSetIterator Fields
OpenBitSetIterator Class See Also Send Feedback

The OpenBitSetIterator type exposes the following members.

Fields

Name | Description
bitlist |

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


bitlist Field

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..bitlist Field
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.OpenBitSetIterator.bitlist"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal static readonly uint[] bitlist
Visual Basic
Protected Friend Shared ReadOnly bitlist As UInteger()
Visual C++
protected public:
static initonly array<unsigned int>^ bitlist

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


OpenBitSetIterator Methods

[image] [image]

Lucene.Net Class Libraries
OpenBitSetIterator Methods
OpenBitSetIterator Class See Also Send Feedback

The OpenBitSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Advance | (Overrides DocIdSetIterator..::..Advance(Int32).)
Public method | Doc | Obsolete. (Overrides DocIdSetIterator..::..Doc()()()().)
Public method | DocID | (Overrides DocIdSetIterator..::..DocID()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Obsolete. (Overrides DocIdSetIterator..::..Next()()()().)
Public method | NextDoc | (Overrides DocIdSetIterator..::..NextDoc()()()().)
Public method | SkipTo | Obsolete. (Overrides DocIdSetIterator..::..SkipTo(Int32).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


Advance Method

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..Advance Method
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Advance(System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int Advance(
    int target
)
Visual Basic
Public Overrides Function Advance ( _
    target As Integer _
) As Integer
Visual C++
public:
virtual int Advance(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Advance(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Advance(System.Int32)"]

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


Doc Method

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..Doc Method
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Doc"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use DocID() instead.")]
public override int Doc()
Visual Basic
<ObsoleteAttribute("use DocID() instead.")> _
Public Overrides Function Doc As Integer
Visual C++
[ObsoleteAttribute(L"use DocID() instead.")]
public:
virtual int Doc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Doc"]

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


DocID Method

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..DocID Method
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.DocID"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int DocID()
Visual Basic
Public Overrides Function DocID As Integer
Visual C++
public:
virtual int DocID() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.DocID"]

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


Next Method

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..Next Method
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Next"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use NextDoc() instead.")]
public override bool Next()
Visual Basic
<ObsoleteAttribute("use NextDoc() instead.")> _
Public Overrides Function Next As Boolean
Visual C++
[ObsoleteAttribute(L"use NextDoc() instead.")]
public:
virtual bool Next() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.Next"]

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


NextDoc Method

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..NextDoc Method
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.NextDoc"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override int NextDoc()
Visual Basic
Public Overrides Function NextDoc As Integer
Visual C++
public:
virtual int NextDoc() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.NextDoc"]

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


SkipTo Method

[image]

Lucene.Net Class Libraries
OpenBitSetIterator..::..SkipTo Method
OpenBitSetIterator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.SkipTo(System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Advance(int) instead.")]
public override bool SkipTo(
    int target
)
Visual Basic
<ObsoleteAttribute("use Advance(int) instead.")> _
Public Overrides Function SkipTo ( _
    target As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use Advance(int) instead.")]
public:
virtual bool SkipTo(
    int target
) override

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.SkipTo(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.OpenBitSetIterator.SkipTo(System.Int32)"]

See Also

OpenBitSetIterator Class
Lucene.Net.Util Namespace


Parameter Class

[image]

Lucene.Net Class Libraries
Parameter Class
Members See Also Send Feedback
A serializable Enum class.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public abstract class Parameter
Visual Basic
<SerializableAttribute> _
Public MustInherit Class Parameter
Visual C++
[SerializableAttribute]
public ref class Parameter abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Documents..::..Field..::..Index
Lucene.Net.Documents..::..Field..::..Store
Lucene.Net.Documents..::..Field..::..TermVector
Lucene.Net.QueryParsers..::..QueryParser..::..Operator
Lucene.Net.Search..::..BooleanClause..::..Occur
Lucene.Net.Search..::..CachingWrapperFilter..::..DeletesMode
Lucene.Net.Util..::..Version

See Also

Parameter Members
Lucene.Net.Util Namespace


Parameter Members

[image] [image]

Lucene.Net Class Libraries
Parameter Members
Parameter Class Constructors Methods See Also Send Feedback

The Parameter type exposes the following members.

Constructors

 | Name | Description
Protected method | Parameter | Initializes a new instance of the Parameter class

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Parameter Class
Lucene.Net.Util Namespace


Parameter Constructor

[image]

Lucene.Net Class Libraries
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Parameter(
    string name
)
Visual Basic
Protected Friend Sub New ( _
    name As String _
)
Visual C++
protected public:
Parameter(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Util.Parameter.#ctor(System.String)"]

See Also

Parameter Class
Lucene.Net.Util Namespace


Parameter Methods

[image] [image]

Lucene.Net Class Libraries
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Parameter Class
Lucene.Net.Util Namespace


Equals Method

[image]

Lucene.Net Class Libraries
Parameter..::..Equals Method
Parameter Class See Also Send Feedback
Resolves the deserialized instance to the local reference for accurate equals() and == comparisons.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Util.Parameter.Equals(System.Object)"]

Return Value

a reference to Parameter as resolved in the local VM

See Also

Parameter Class
Lucene.Net.Util Namespace


ToString Method

[image]

Lucene.Net Class Libraries
Parameter..::..ToString Method
Parameter Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Parameter.ToString"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Parameter.ToString"]

See Also

Parameter Class
Lucene.Net.Util Namespace


PriorityQueue Class

[image]

Lucene.Net Class Libraries
PriorityQueue Class
Members See Also Send Feedback
A PriorityQueue maintains a partial ordering of its elements such that the least element can always be found in constant time. Put()'s and pop()'s require log(size) time.

NOTE: This class pre-allocates a full array of length

CopyC#
maxSize+1
, in {@link #initialize}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class PriorityQueue
Visual Basic
Public MustInherit Class PriorityQueue
Visual C++
public ref class PriorityQueue abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..PriorityQueue
Lucene.Net.Search..::..FieldSortedHitQueue
Lucene.Net.Search..::..FieldValueHitQueue
Lucene.Net.Search..::..FuzzyQuery..::..ScoreTermQueue
Lucene.Net.Search..::..HitQueue

See Also

PriorityQueue Members
Lucene.Net.Util Namespace


PriorityQueue Members

[image] [image]

Lucene.Net Class Libraries
PriorityQueue Members
PriorityQueue Class Constructors Methods Fields See Also Send Feedback

The PriorityQueue type exposes the following members.

Constructors

 | Name | Description
Protected method | PriorityQueue | Initializes a new instance of the PriorityQueue class

Methods

Name Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
Public method Clear
Removes all entries from the PriorityQueue.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
Public method LessThan
Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
Public method Top
Returns the least element of the PriorityQueue in constant time.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);

Fields

 | Name | Description
Protected field | heap |

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


PriorityQueue Constructor

[image]

Lucene.Net Class Libraries
PriorityQueue Constructor
PriorityQueue Class See Also Send Feedback
Initializes a new instance of the PriorityQueue class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected PriorityQueue()
Visual Basic
Protected Sub New
Visual C++
protected:
PriorityQueue()

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


PriorityQueue Fields

[image] [image]

Lucene.Net Class Libraries
PriorityQueue Fields
PriorityQueue Class See Also Send Feedback

The PriorityQueue type exposes the following members.

Fields

 | Name | Description
Protected field | heap |

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


heap Field

[image]

Lucene.Net Class Libraries
PriorityQueue..::..heap Field
PriorityQueue Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.PriorityQueue.heap"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal Object[] heap
Visual Basic
Protected Friend heap As Object()
Visual C++
protected public:
array<Object^>^ heap

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


PriorityQueue Methods

[image] [image]

Lucene.Net Class Libraries
PriorityQueue Methods
PriorityQueue Class See Also Send Feedback

The PriorityQueue type exposes the following members.

Methods

Name Description
Public method Add
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.
Public method AdjustTop Obsolete.
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);
Public method Clear
Removes all entries from the PriorityQueue.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetSentinelObject
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method Initialize
Subclass constructors must call this.
Public method Insert Obsolete.
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).
Public method InsertWithOverflow
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.
Public method LessThan
Determines the ordering of objects in this priority queue. Subclasses must define this one method.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least element of the PriorityQueue in log(size) time.
Public method Put Obsolete.
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Public method Size
Returns the number of elements currently stored in the PriorityQueue.
Public method Top
Returns the least element of the PriorityQueue in constant time.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method UpdateTop
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Add Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Add Method
PriorityQueue Class See Also Send Feedback
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize an {@link ArrayIndexOutOfBoundsException} is thrown.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Add(
    Object element
)
Visual Basic
Public Function Add ( _
    element As Object _
) As Object
Visual C++
public:
Object^ Add(
    Object^ element
)

Parameters

element
Type: System..::..Object

[Missing <param name="element"/> documentation for "M:Lucene.Net.Util.PriorityQueue.Add(System.Object)"]

Return Value

the new 'top' element in the queue.

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


AdjustTop Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..AdjustTop Method
PriorityQueue Class See Also Send Feedback
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.adjustTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use UpdateTop() which returns the new top element and saves an additional call to Top()")]
public void AdjustTop()
Visual Basic
<ObsoleteAttribute("use UpdateTop() which returns the new top element and saves an additional call to Top()")> _
Public Sub AdjustTop
Visual C++
[ObsoleteAttribute(L"use UpdateTop() which returns the new top element and saves an additional call to Top()")]
public:
void AdjustTop()

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Clear Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Clear Method
PriorityQueue Class See Also Send Feedback
Removes all entries from the PriorityQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


GetSentinelObject Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..GetSentinelObject Method
PriorityQueue Class See Also Send Feedback
This method can be overridden by extending classes to return a sentinel object which will be used by {@link #Initialize(int)} to fill the queue, so that the code which uses that queue can always assume it's full and only change the top without attempting to insert any new object.
Those sentinel values should always compare worse than any non-sentinel value (i.e., {@link #LessThan(Object, Object)} should always favor the non-sentinel values).
By default, this method returns false, which means the queue will not be filled with sentinel values. Otherwise, the value returned will be used to pre-populate the queue. Adds sentinel values to the queue.
If this method is extended to return a non-null value, then the following usage pattern is recommended:
            // extends getSentinelObject() to return a non-null value.
            PriorityQueue pq = new MyQueue(numHits);
            // save the 'top' element, which is guaranteed to not be null.
            MyObject pqTop = (MyObject) pq.top();
            <...>
            // now in order to add a new element, which is 'better' than top (after
            // you've verified it is better), it is as simple as:
            pqTop.change().
            pqTop = pq.updateTop();
NOTE: if this method returns a non-null value, it will be called by {@link #Initialize(int)} {@link #Size()} times, relying on a new object to be returned and will not check if it's null again. Therefore you should ensure any call to this method creates a new instance and behaves consistently, e.g., it cannot return null if it previously returned non-null.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual Object GetSentinelObject()
Visual Basic
Protected Friend Overridable Function GetSentinelObject As Object
Visual C++
protected public:
virtual Object^ GetSentinelObject()

Return Value

the sentinel object to use to pre-populate the queue, or null if sentinel objects are not supported.

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Initialize Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Initialize Method
PriorityQueue Class See Also Send Feedback
Subclass constructors must call this.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal void Initialize(
    int maxSize
)
Visual Basic
Protected Friend Sub Initialize ( _
    maxSize As Integer _
)
Visual C++
protected public:
void Initialize(
    int maxSize
)

Parameters

maxSize
Type: System..::..Int32

[Missing <param name="maxSize"/> documentation for "M:Lucene.Net.Util.PriorityQueue.Initialize(System.Int32)"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Insert Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Insert Method
PriorityQueue Class See Also Send Feedback
Adds element to the PriorityQueue in log(size) time if either the PriorityQueue is not full, or not lessThan(element, top()).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use InsertWithOverflow(Object) instead, which encourages objects reuse.")]
public virtual bool Insert(
    Object element
)
Visual Basic
<ObsoleteAttribute("use InsertWithOverflow(Object) instead, which encourages objects reuse.")> _
Public Overridable Function Insert ( _
    element As Object _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use InsertWithOverflow(Object) instead, which encourages objects reuse.")]
public:
virtual bool Insert(
    Object^ element
)

Parameters

element
Type: System..::..Object

[Missing <param name="element"/> documentation for "M:Lucene.Net.Util.PriorityQueue.Insert(System.Object)"]

Return Value

true if element is added, false otherwise.

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


InsertWithOverflow Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..InsertWithOverflow Method
PriorityQueue Class See Also Send Feedback
insertWithOverflow() is the same as insert() except its return value: it returns the object (if any) that was dropped off the heap because it was full. This can be the given parameter (in case it is smaller than the full heap's minimum, and couldn't be added), or another object that was previously the smallest value in the heap and now has been replaced by a larger one, or null if the queue wasn't yet full with maxSize elements.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual Object InsertWithOverflow(
    Object element
)
Visual Basic
Public Overridable Function InsertWithOverflow ( _
    element As Object _
) As Object
Visual C++
public:
virtual Object^ InsertWithOverflow(
    Object^ element
)

Parameters

element
Type: System..::..Object

[Missing <param name="element"/> documentation for "M:Lucene.Net.Util.PriorityQueue.InsertWithOverflow(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.PriorityQueue.InsertWithOverflow(System.Object)"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


LessThan Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..LessThan Method
PriorityQueue Class See Also Send Feedback
Determines the ordering of objects in this priority queue. Subclasses must define this one method.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool LessThan(
    Object a,
    Object b
)
Visual Basic
Public MustOverride Function LessThan ( _
    a As Object, _
    b As Object _
) As Boolean
Visual C++
public:
virtual bool LessThan(
    Object^ a,
    Object^ b
) abstract

Parameters

a
Type: System..::..Object

[Missing <param name="a"/> documentation for "M:Lucene.Net.Util.PriorityQueue.LessThan(System.Object,System.Object)"]

b
Type: System..::..Object

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.PriorityQueue.LessThan(System.Object,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.PriorityQueue.LessThan(System.Object,System.Object)"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Pop Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Pop Method
PriorityQueue Class See Also Send Feedback
Removes and returns the least element of the PriorityQueue in log(size) time.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Pop()
Visual Basic
Public Function Pop As Object
Visual C++
public:
Object^ Pop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.PriorityQueue.Pop"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Put Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Put Method
PriorityQueue Class See Also Send Feedback
Adds an Object to a PriorityQueue in log(size) time. If one tries to add more objects than maxSize from initialize a RuntimeException (ArrayIndexOutOfBound) is thrown.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("use Add(Object) which returns the new top object, saving an additional call to Top().")]
public void Put(
    Object element
)
Visual Basic
<ObsoleteAttribute("use Add(Object) which returns the new top object, saving an additional call to Top().")> _
Public Sub Put ( _
    element As Object _
)
Visual C++
[ObsoleteAttribute(L"use Add(Object) which returns the new top object, saving an additional call to Top().")]
public:
void Put(
    Object^ element
)

Parameters

element
Type: System..::..Object

[Missing <param name="element"/> documentation for "M:Lucene.Net.Util.PriorityQueue.Put(System.Object)"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Size Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Size Method
PriorityQueue Class See Also Send Feedback
Returns the number of elements currently stored in the PriorityQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.PriorityQueue.Size"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


Top Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..Top Method
PriorityQueue Class See Also Send Feedback
Returns the least element of the PriorityQueue in constant time.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object Top()
Visual Basic
Public Function Top As Object
Visual C++
public:
Object^ Top()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.PriorityQueue.Top"]

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


UpdateTop Method

[image]

Lucene.Net Class Libraries
PriorityQueue..::..UpdateTop Method
PriorityQueue Class See Also Send Feedback
Should be called when the Object at top changes values. Still log(n) worst case, but it's at least twice as fast to
            pq.top().change();
            pq.updateTop();
instead of
            o = pq.pop();
            o.change();
            pq.push(o);

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Object UpdateTop()
Visual Basic
Public Function UpdateTop As Object
Visual C++
public:
Object^ UpdateTop()

Return Value

the new 'top' element.

See Also

PriorityQueue Class
Lucene.Net.Util Namespace


RamUsageEstimator Class

[image]

Lucene.Net Class Libraries
RamUsageEstimator Class
Members See Also Send Feedback
Estimates the size of a given Object using a given MemoryModel for primitive size information. Resource Usage: Internally uses a Map to temporally hold a reference to every object seen. If checkIntered, all Strings checked will be interned, but those that were not already interned will be released for GC when the estimate is complete.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class RamUsageEstimator
Visual Basic
Public NotInheritable Class RamUsageEstimator
Visual C++
public ref class RamUsageEstimator sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..RamUsageEstimator

See Also

RamUsageEstimator Members
Lucene.Net.Util Namespace


RamUsageEstimator Members

[image] [image]

Lucene.Net Class Libraries
RamUsageEstimator Members
RamUsageEstimator Class Constructors Methods See Also Send Feedback

The RamUsageEstimator type exposes the following members.

Constructors

 | Name | Description
Public method | RamUsageEstimator()()()() | Constructs this object with an AverageGuessMemoryModel and checkInterned = true.
Public method | RamUsageEstimator(Boolean) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel, Boolean) | Initializes a new instance of the RamUsageEstimator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EstimateRamUsage |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HumanReadableUnits | Return good default units based on byte size.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RamUsageEstimator Class
Lucene.Net.Util Namespace


RamUsageEstimator Constructor

[image] [image]

Lucene.Net Class Libraries
RamUsageEstimator Constructor
RamUsageEstimator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RamUsageEstimator()()()() | Constructs this object with an AverageGuessMemoryModel and checkInterned = true.
Public method | RamUsageEstimator(Boolean) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel) | Initializes a new instance of the RamUsageEstimator class
Public method | RamUsageEstimator(MemoryModel, Boolean) | Initializes a new instance of the RamUsageEstimator class

See Also

RamUsageEstimator Class
RamUsageEstimator Members
Lucene.Net.Util Namespace


RamUsageEstimator Constructor

[image]

Lucene.Net Class Libraries
RamUsageEstimator Constructor
RamUsageEstimator Class See Also Send Feedback
Constructs this object with an AverageGuessMemoryModel and checkInterned = true.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RamUsageEstimator()
Visual Basic
Public Sub New
Visual C++
public:
RamUsageEstimator()

See Also

RamUsageEstimator Class
RamUsageEstimator Overload
Lucene.Net.Util Namespace


RamUsageEstimator Constructor (Boolean)

[image]

Lucene.Net Class Libraries
RamUsageEstimator Constructor (Boolean)
RamUsageEstimator Class See Also Send Feedback
Initializes a new instance of the RamUsageEstimator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RamUsageEstimator(
    bool checkInterned
)
Visual Basic
Public Sub New ( _
    checkInterned As Boolean _
)
Visual C++
public:
RamUsageEstimator(
    bool checkInterned
)

Parameters

checkInterned
Type: System..::..Boolean
check if Strings are interned and don't add to size if they are. Defaults to true but if you know the objects you are checking won't likely contain many interned Strings, it will be faster to turn off intern checking.

See Also

RamUsageEstimator Class
RamUsageEstimator Overload
Lucene.Net.Util Namespace


RamUsageEstimator Constructor (MemoryModel)

[image]

Lucene.Net Class Libraries
RamUsageEstimator Constructor (MemoryModel)
RamUsageEstimator Class See Also Send Feedback
Initializes a new instance of the RamUsageEstimator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RamUsageEstimator(
    MemoryModel memoryModel
)
Visual Basic
Public Sub New ( _
    memoryModel As MemoryModel _
)
Visual C++
public:
RamUsageEstimator(
    MemoryModel^ memoryModel
)

Parameters

memoryModel
Type: Lucene.Net.Util..::..MemoryModel
MemoryModel to use for primitive object sizes.

See Also

RamUsageEstimator Class
RamUsageEstimator Overload
Lucene.Net.Util Namespace


RamUsageEstimator Constructor (MemoryModel, Boolean)

[image]

Lucene.Net Class Libraries
RamUsageEstimator Constructor (MemoryModel, Boolean)
RamUsageEstimator Class See Also Send Feedback
Initializes a new instance of the RamUsageEstimator class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public RamUsageEstimator(
    MemoryModel memoryModel,
    bool checkInterned
)
Visual Basic
Public Sub New ( _
    memoryModel As MemoryModel, _
    checkInterned As Boolean _
)
Visual C++
public:
RamUsageEstimator(
    MemoryModel^ memoryModel,
    bool checkInterned
)

Parameters

memoryModel
Type: Lucene.Net.Util..::..MemoryModel
MemoryModel to use for primitive object sizes.
checkInterned
Type: System..::..Boolean
check if Strings are interned and don't add to size if they are. Defaults to true but if you know the objects you are checking won't likely contain many interned Strings, it will be faster to turn off intern checking.

See Also

RamUsageEstimator Class
RamUsageEstimator Overload
Lucene.Net.Util Namespace


RamUsageEstimator Methods

[image] [image]

Lucene.Net Class Libraries
RamUsageEstimator Methods
RamUsageEstimator Class See Also Send Feedback

The RamUsageEstimator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EstimateRamUsage |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HumanReadableUnits | Return good default units based on byte size.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RamUsageEstimator Class
Lucene.Net.Util Namespace


EstimateRamUsage Method

[image]

Lucene.Net Class Libraries
RamUsageEstimator..::..EstimateRamUsage Method
RamUsageEstimator Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.RamUsageEstimator.EstimateRamUsage(System.Object)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public long EstimateRamUsage(
    Object obj
)
Visual Basic
Public Function EstimateRamUsage ( _
    obj As Object _
) As Long
Visual C++
public:
long long EstimateRamUsage(
    Object^ obj
)

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Lucene.Net.Util.RamUsageEstimator.EstimateRamUsage(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.RamUsageEstimator.EstimateRamUsage(System.Object)"]

See Also

RamUsageEstimator Class
Lucene.Net.Util Namespace


HumanReadableUnits Method

[image]

Lucene.Net Class Libraries
RamUsageEstimator..::..HumanReadableUnits Method
RamUsageEstimator Class See Also Send Feedback
Return good default units based on byte size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string HumanReadableUnits(
    long bytes,
    IFormatProvider df
)
Visual Basic
Public Shared Function HumanReadableUnits ( _
    bytes As Long, _
    df As IFormatProvider _
) As String
Visual C++
public:
static String^ HumanReadableUnits(
    long long bytes,
    IFormatProvider^ df
)

Parameters

bytes
Type: System..::..Int64

[Missing <param name="bytes"/> documentation for "M:Lucene.Net.Util.RamUsageEstimator.HumanReadableUnits(System.Int64,System.IFormatProvider)"]

df
Type: System..::..IFormatProvider

[Missing <param name="df"/> documentation for "M:Lucene.Net.Util.RamUsageEstimator.HumanReadableUnits(System.Int64,System.IFormatProvider)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.RamUsageEstimator.HumanReadableUnits(System.Int64,System.IFormatProvider)"]

See Also

RamUsageEstimator Class
Lucene.Net.Util Namespace


ReaderUtil Class

[image]

Lucene.Net Class Libraries
ReaderUtil Class
Members See Also Send Feedback
Common util methods for dealing with {@link IndexReader}s.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ReaderUtil
Visual Basic
Public Class ReaderUtil
Visual C++
public ref class ReaderUtil

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..ReaderUtil

See Also

ReaderUtil Members
Lucene.Net.Util Namespace


ReaderUtil Members

[image] [image]

Lucene.Net Class Libraries
ReaderUtil Members
ReaderUtil Class Constructors Methods See Also Send Feedback

The ReaderUtil type exposes the following members.

Constructors

 | Name | Description
Public method | ReaderUtil | Initializes a new instance of the ReaderUtil class

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GatherSubReaders
Gathers sub-readers from reader into a List.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
SubIndex
Returns index of the searcher/reader for document
CopyC#
n
 in the array used to construct this searcher/reader.
SubReader(Int32, IndexReader)
Returns sub IndexReader that contains the given document id.
SubReader(IndexReader, Int32)
Returns sub-reader subIndex from reader.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ReaderUtil Class
Lucene.Net.Util Namespace


ReaderUtil Constructor

[image]

Lucene.Net Class Libraries
ReaderUtil Constructor
ReaderUtil Class See Also Send Feedback
Initializes a new instance of the ReaderUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ReaderUtil()
Visual Basic
Public Sub New
Visual C++
public:
ReaderUtil()

See Also

ReaderUtil Class
Lucene.Net.Util Namespace


ReaderUtil Methods

[image] [image]

Lucene.Net Class Libraries
ReaderUtil Methods
ReaderUtil Class See Also Send Feedback

The ReaderUtil type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GatherSubReaders
Gathers sub-readers from reader into a List.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
SubIndex
Returns index of the searcher/reader for document
CopyC#
n
 in the array used to construct this searcher/reader.
SubReader(Int32, IndexReader)
Returns sub IndexReader that contains the given document id.
SubReader(IndexReader, Int32)
Returns sub-reader subIndex from reader.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ReaderUtil Class
Lucene.Net.Util Namespace


GatherSubReaders Method

[image]

Lucene.Net Class Libraries
ReaderUtil..::..GatherSubReaders Method
ReaderUtil Class See Also Send Feedback
Gathers sub-readers from reader into a List.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void GatherSubReaders(
    IList allSubReaders,
    IndexReader reader
)
Visual Basic
Public Shared Sub GatherSubReaders ( _
    allSubReaders As IList, _
    reader As IndexReader _
)
Visual C++
public:
static void GatherSubReaders(
    IList^ allSubReaders,
    IndexReader^ reader
)

Parameters

allSubReaders
Type: System.Collections..::..IList

[Missing <param name="allSubReaders"/> documentation for "M:Lucene.Net.Util.ReaderUtil.GatherSubReaders(System.Collections.IList,Lucene.Net.Index.IndexReader)"]

reader
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="reader"/> documentation for "M:Lucene.Net.Util.ReaderUtil.GatherSubReaders(System.Collections.IList,Lucene.Net.Index.IndexReader)"]

See Also

ReaderUtil Class
Lucene.Net.Util Namespace


SubIndex Method

[image]

Lucene.Net Class Libraries
ReaderUtil..::..SubIndex Method
ReaderUtil Class See Also Send Feedback
Returns index of the searcher/reader for document
CopyC#
n
 in the array used to construct this searcher/reader.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int SubIndex(
    int n,
    int[] docStarts
)
Visual Basic
Public Shared Function SubIndex ( _
    n As Integer, _
    docStarts As Integer() _
) As Integer
Visual C++
public:
static int SubIndex(
    int n,
    array<int>^ docStarts
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:Lucene.Net.Util.ReaderUtil.SubIndex(System.Int32,System.Int32[])"]

docStarts
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="docStarts"/> documentation for "M:Lucene.Net.Util.ReaderUtil.SubIndex(System.Int32,System.Int32[])"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ReaderUtil.SubIndex(System.Int32,System.Int32[])"]

See Also

ReaderUtil Class
Lucene.Net.Util Namespace


SubReader Method

[image] [image]

Lucene.Net Class Libraries
ReaderUtil..::..SubReader Method
ReaderUtil Class See Also Send Feedback

Overload List

Name | Description
SubReader(Int32, IndexReader) | Returns sub IndexReader that contains the given document id.
SubReader(IndexReader, Int32) | Returns sub-reader subIndex from reader.

See Also

ReaderUtil Class
ReaderUtil Members
Lucene.Net.Util Namespace


SubReader Method (Int32, IndexReader)

[image]

Lucene.Net Class Libraries
ReaderUtil..::..SubReader Method (Int32, IndexReader)
ReaderUtil Class See Also Send Feedback
Returns sub IndexReader that contains the given document id.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader SubReader(
    int doc,
    IndexReader reader
)
Visual Basic
Public Shared Function SubReader ( _
    doc As Integer, _
    reader As IndexReader _
) As IndexReader
Visual C++
public:
static IndexReader^ SubReader(
    int doc,
    IndexReader^ reader
)

Parameters

doc
Type: System..::..Int32
id of document
reader
Type: Lucene.Net.Index..::..IndexReader
parent reader

Return Value

sub reader of parent which contains the specified doc id

See Also

ReaderUtil Class
SubReader Overload
Lucene.Net.Util Namespace


SubReader Method (IndexReader, Int32)

[image]

Lucene.Net Class Libraries
ReaderUtil..::..SubReader Method (IndexReader, Int32)
ReaderUtil Class See Also Send Feedback
Returns sub-reader subIndex from reader.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static IndexReader SubReader(
    IndexReader reader,
    int subIndex
)
Visual Basic
Public Shared Function SubReader ( _
    reader As IndexReader, _
    subIndex As Integer _
) As IndexReader
Visual C++
public:
static IndexReader^ SubReader(
    IndexReader^ reader,
    int subIndex
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
parent reader
subIndex
Type: System..::..Int32
index of desired sub reader

Return Value

the subreader at subINdex

See Also

ReaderUtil Class
SubReader Overload
Lucene.Net.Util Namespace


ScorerDocQueue Class

[image]

Lucene.Net Class Libraries
ScorerDocQueue Class
Members See Also Send Feedback
A ScorerDocQueue maintains a partial ordering of its Scorers such that the least Scorer can always be found in constant time. Put()'s and pop()'s require log(size) time. The ordering is by Scorer.doc().

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ScorerDocQueue
Visual Basic
Public Class ScorerDocQueue
Visual C++
public ref class ScorerDocQueue

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..ScorerDocQueue

See Also

ScorerDocQueue Members
Lucene.Net.Util Namespace


ScorerDocQueue Members

[image] [image]

Lucene.Net Class Libraries
ScorerDocQueue Members
ScorerDocQueue Class Constructors Methods See Also Send Feedback

The ScorerDocQueue type exposes the following members.

Constructors

 | Name | Description
Public method | ScorerDocQueue | Create a ScorerDocQueue with a maximum size.

Methods

Name | Description
Public method AdjustTop
Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to
            { pq.top().change(); pq.adjustTop(); }
instead of
            { o = pq.pop(); o.change(); pq.push(o); }
Public method Clear
Removes all entries from the ScorerDocQueue.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Insert
Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.
Public method Put
Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Public method Size
Returns the number of scorers currently stored in the ScorerDocQueue.
Public method Top
Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method TopDoc
Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method | TopNextAndAdjustElsePop
Public method | TopScore
Public method | TopSkipToAndAdjustElsePop
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


ScorerDocQueue Constructor

[image]

Lucene.Net Class Libraries
ScorerDocQueue Constructor
ScorerDocQueue Class See Also Send Feedback
Create a ScorerDocQueue with a maximum size.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ScorerDocQueue(
    int maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Integer _
)
Visual C++
public:
ScorerDocQueue(
    int maxSize
)

Parameters

maxSize
Type: System..::..Int32

[Missing <param name="maxSize"/> documentation for "M:Lucene.Net.Util.ScorerDocQueue.#ctor(System.Int32)"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


ScorerDocQueue Methods

[image] [image]

Lucene.Net Class Libraries
ScorerDocQueue Methods
ScorerDocQueue Class See Also Send Feedback

The ScorerDocQueue type exposes the following members.

Methods

Name | Description
Public method AdjustTop
Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to
            { pq.top().change(); pq.adjustTop(); }
instead of
            { o = pq.pop(); o.change(); pq.push(o); }
Public method Clear
Removes all entries from the ScorerDocQueue.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Insert
Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Pop
Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.
Public method Put
Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a RuntimeException (ArrayIndexOutOfBound) is thrown.
Public method Size
Returns the number of scorers currently stored in the ScorerDocQueue.
Public method Top
Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method TopDoc
Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.
Public method | TopNextAndAdjustElsePop
Public method | TopScore
Public method | TopSkipToAndAdjustElsePop
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


AdjustTop Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..AdjustTop Method
ScorerDocQueue Class See Also Send Feedback
Should be called when the scorer at top changes doc() value. Still log(n) worst case, but it's at least twice as fast to
            { pq.top().change(); pq.adjustTop(); }
instead of
            { o = pq.pop(); o.change(); pq.push(o); }

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void AdjustTop()
Visual Basic
Public Sub AdjustTop
Visual C++
public:
void AdjustTop()

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


Clear Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..Clear Method
ScorerDocQueue Class See Also Send Feedback
Removes all entries from the ScorerDocQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


Insert Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..Insert Method
ScorerDocQueue Class See Also Send Feedback
Adds a Scorer to the ScorerDocQueue in log(size) time if either the ScorerDocQueue is not full, or not lessThan(scorer, top()).

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual bool Insert(
    Scorer scorer
)
Visual Basic
Public Overridable Function Insert ( _
    scorer As Scorer _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Scorer^ scorer
)

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Util.ScorerDocQueue.Insert(Lucene.Net.Search.Scorer)"]

Return Value

true if scorer is added, false otherwise.

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


Pop Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..Pop Method
ScorerDocQueue Class See Also Send Feedback
Removes and returns the least scorer of the ScorerDocQueue in log(size) time. Should not be used when the queue is empty.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Scorer Pop()
Visual Basic
Public Function Pop As Scorer
Visual C++
public:
Scorer^ Pop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.Pop"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


Put Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..Put Method
ScorerDocQueue Class See Also Send Feedback
Adds a Scorer to a ScorerDocQueue in log(size) time. If one tries to add more Scorers than maxSize a RuntimeException (ArrayIndexOutOfBound) is thrown.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void Put(
    Scorer scorer
)
Visual Basic
Public Sub Put ( _
    scorer As Scorer _
)
Visual C++
public:
void Put(
    Scorer^ scorer
)

Parameters

scorer
Type: Lucene.Net.Search..::..Scorer

[Missing <param name="scorer"/> documentation for "M:Lucene.Net.Util.ScorerDocQueue.Put(Lucene.Net.Search.Scorer)"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


Size Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..Size Method
ScorerDocQueue Class See Also Send Feedback
Returns the number of scorers currently stored in the ScorerDocQueue.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
int Size()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.Size"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


Top Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..Top Method
ScorerDocQueue Class See Also Send Feedback
Returns the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Scorer Top()
Visual Basic
Public Function Top As Scorer
Visual C++
public:
Scorer^ Top()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.Top"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


TopDoc Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..TopDoc Method
ScorerDocQueue Class See Also Send Feedback
Returns document number of the least Scorer of the ScorerDocQueue in constant time. Should not be used when the queue is empty.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int TopDoc()
Visual Basic
Public Function TopDoc As Integer
Visual C++
public:
int TopDoc()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopDoc"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


TopNextAndAdjustElsePop Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..TopNextAndAdjustElsePop Method
ScorerDocQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopNextAndAdjustElsePop"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool TopNextAndAdjustElsePop()
Visual Basic
Public Function TopNextAndAdjustElsePop As Boolean
Visual C++
public:
bool TopNextAndAdjustElsePop()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopNextAndAdjustElsePop"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


TopScore Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..TopScore Method
ScorerDocQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopScore"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public float TopScore()
Visual Basic
Public Function TopScore As Single
Visual C++
public:
float TopScore()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopScore"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


TopSkipToAndAdjustElsePop Method

[image]

Lucene.Net Class Libraries
ScorerDocQueue..::..TopSkipToAndAdjustElsePop Method
ScorerDocQueue Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopSkipToAndAdjustElsePop(System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool TopSkipToAndAdjustElsePop(
    int target
)
Visual Basic
Public Function TopSkipToAndAdjustElsePop ( _
    target As Integer _
) As Boolean
Visual C++
public:
bool TopSkipToAndAdjustElsePop(
    int target
)

Parameters

target
Type: System..::..Int32

[Missing <param name="target"/> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopSkipToAndAdjustElsePop(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ScorerDocQueue.TopSkipToAndAdjustElsePop(System.Int32)"]

See Also

ScorerDocQueue Class
Lucene.Net.Util Namespace


SimpleStringInterner Class

[image]

Lucene.Net Class Libraries
SimpleStringInterner Class
Members See Also Send Feedback
Simple lockless and memory barrier free String intern cache that is guaranteed to return the same String instance as String.intern() does.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleStringInterner : StringInterner
Visual Basic
Public Class SimpleStringInterner _
    Inherits StringInterner
Visual C++
public ref class SimpleStringInterner : public StringInterner

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..StringInterner
Lucene.Net.Util..::..SimpleStringInterner

See Also

SimpleStringInterner Members
Lucene.Net.Util Namespace


SimpleStringInterner Members

[image] [image]

Lucene.Net Class Libraries
SimpleStringInterner Members
SimpleStringInterner Class Constructors Methods See Also Send Feedback

The SimpleStringInterner type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleStringInterner | Initializes a new instance of the SimpleStringInterner class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intern(String) | (Overrides StringInterner..::..Intern(String).)
Public method | Intern(array<Char>[]()[][], Int32, Int32) | Returns a single object instance for each equal string. (Inherited from StringInterner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleStringInterner Class
Lucene.Net.Util Namespace


SimpleStringInterner Constructor

[image]

Lucene.Net Class Libraries
SimpleStringInterner Constructor
SimpleStringInterner Class See Also Send Feedback
Initializes a new instance of the SimpleStringInterner class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleStringInterner(
    int tableSize,
    int maxChainLength
)
Visual Basic
Public Sub New ( _
    tableSize As Integer, _
    maxChainLength As Integer _
)
Visual C++
public:
SimpleStringInterner(
    int tableSize,
    int maxChainLength
)

Parameters

tableSize
Type: System..::..Int32
Size of the hash table, should be a power of two.
maxChainLength
Type: System..::..Int32
Maximum length of each bucket, after which the oldest item inserted is dropped.

See Also

SimpleStringInterner Class
Lucene.Net.Util Namespace


SimpleStringInterner Methods

[image] [image]

Lucene.Net Class Libraries
SimpleStringInterner Methods
SimpleStringInterner Class See Also Send Feedback

The SimpleStringInterner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intern(String) | (Overrides StringInterner..::..Intern(String).)
Public method | Intern(array<Char>[]()[][], Int32, Int32) | Returns a single object instance for each equal string. (Inherited from StringInterner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleStringInterner Class
Lucene.Net.Util Namespace


Intern Method

[image] [image]

Lucene.Net Class Libraries
SimpleStringInterner..::..Intern Method
SimpleStringInterner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Intern(String) | (Overrides StringInterner..::..Intern(String).)
Public method | Intern(array<Char>[]()[][], Int32, Int32) | Returns a single object instance for each equal string. (Inherited from StringInterner.)

See Also

SimpleStringInterner Class
SimpleStringInterner Members
Lucene.Net.Util Namespace


Intern Method (String)

[image]

Lucene.Net Class Libraries
SimpleStringInterner..::..Intern Method (String)
SimpleStringInterner Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SimpleStringInterner.Intern(System.String)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override string Intern(
    string s
)
Visual Basic
Public Overrides Function Intern ( _
    s As String _
) As String
Visual C++
public:
virtual String^ Intern(
    String^ s
) override

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Util.SimpleStringInterner.Intern(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SimpleStringInterner.Intern(System.String)"]

See Also

SimpleStringInterner Class
Intern Overload
Lucene.Net.Util Namespace


SmallFloat Class

[image]

Lucene.Net Class Libraries
SmallFloat Class
Members See Also Send Feedback
Floating point numbers smaller than 32 bits.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SmallFloat
Visual Basic
Public Class SmallFloat
Visual C++
public ref class SmallFloat

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..SmallFloat

See Also

SmallFloat Members
Lucene.Net.Util Namespace


SmallFloat Members

[image] [image]

Lucene.Net Class Libraries
SmallFloat Members
SmallFloat Class Constructors Methods See Also Send Feedback

The SmallFloat type exposes the following members.

Constructors

 | Name | Description
Public method | SmallFloat | Initializes a new instance of the SmallFloat class

Methods

 | Name | Description
 | Byte315ToFloat | byteToFloat(b, mantissaBits=3, zeroExponent=15)
 | Byte52ToFloat | byteToFloat(b, mantissaBits=5, zeroExponent=2)
 | ByteToFloat | Converts an 8 bit float to a 32 bit float.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FloatToByte | Converts a 32 bit float to an 8 bit float. Values less than zero are all mapped to zero. Values are truncated (rounded down) to the nearest 8 bit value. Values between zero and the smallest representable value are rounded up.
 | FloatToByte315 | floatToByte(b, mantissaBits=3, zeroExponent=15) smallest non-zero value = 5.820766E-10 largest value = 7.5161928E9 epsilon = 0.125
 | FloatToByte52 | floatToByte(b, mantissaBits=5, zeroExponent=2) smallest nonzero value = 0.033203125 largest value = 1984.0 epsilon = 0.03125
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmallFloat Class
Lucene.Net.Util Namespace


SmallFloat Constructor

[image]

Lucene.Net Class Libraries
SmallFloat Constructor
SmallFloat Class See Also Send Feedback
Initializes a new instance of the SmallFloat class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SmallFloat()
Visual Basic
Public Sub New
Visual C++
public:
SmallFloat()

See Also

SmallFloat Class
Lucene.Net.Util Namespace


SmallFloat Methods

[image] [image]

Lucene.Net Class Libraries
SmallFloat Methods
SmallFloat Class See Also Send Feedback

The SmallFloat type exposes the following members.

Methods

 | Name | Description
 | Byte315ToFloat | byteToFloat(b, mantissaBits=3, zeroExponent=15)
 | Byte52ToFloat | byteToFloat(b, mantissaBits=5, zeroExponent=2)
 | ByteToFloat | Converts an 8 bit float to a 32 bit float.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FloatToByte | Converts a 32 bit float to an 8 bit float. Values less than zero are all mapped to zero. Values are truncated (rounded down) to the nearest 8 bit value. Values between zero and the smallest representable value are rounded up.
 | FloatToByte315 | floatToByte(b, mantissaBits=3, zeroExponent=15) smallest non-zero value = 5.820766E-10 largest value = 7.5161928E9 epsilon = 0.125
 | FloatToByte52 | floatToByte(b, mantissaBits=5, zeroExponent=2) smallest nonzero value = 0.033203125 largest value = 1984.0 epsilon = 0.03125
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmallFloat Class
Lucene.Net.Util Namespace


Byte315ToFloat Method

[image]

Lucene.Net Class Libraries
SmallFloat..::..Byte315ToFloat Method
SmallFloat Class See Also Send Feedback
byteToFloat(b, mantissaBits=3, zeroExponent=15)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float Byte315ToFloat(
    byte b
)
Visual Basic
Public Shared Function Byte315ToFloat ( _
    b As Byte _
) As Single
Visual C++
public:
static float Byte315ToFloat(
    unsigned char b
)

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.SmallFloat.Byte315ToFloat(System.Byte)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SmallFloat.Byte315ToFloat(System.Byte)"]

See Also

SmallFloat Class
Lucene.Net.Util Namespace


Byte52ToFloat Method

[image]

Lucene.Net Class Libraries
SmallFloat..::..Byte52ToFloat Method
SmallFloat Class See Also Send Feedback
byteToFloat(b, mantissaBits=5, zeroExponent=2)

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float Byte52ToFloat(
    byte b
)
Visual Basic
Public Shared Function Byte52ToFloat ( _
    b As Byte _
) As Single
Visual C++
public:
static float Byte52ToFloat(
    unsigned char b
)

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.SmallFloat.Byte52ToFloat(System.Byte)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SmallFloat.Byte52ToFloat(System.Byte)"]

See Also

SmallFloat Class
Lucene.Net.Util Namespace


ByteToFloat Method

[image]

Lucene.Net Class Libraries
SmallFloat..::..ByteToFloat Method
SmallFloat Class See Also Send Feedback
Converts an 8 bit float to a 32 bit float.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static float ByteToFloat(
    byte b,
    int numMantissaBits,
    int zeroExp
)
Visual Basic
Public Shared Function ByteToFloat ( _
    b As Byte, _
    numMantissaBits As Integer, _
    zeroExp As Integer _
) As Single
Visual C++
public:
static float ByteToFloat(
    unsigned char b,
    int numMantissaBits,
    int zeroExp
)

Parameters

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:Lucene.Net.Util.SmallFloat.ByteToFloat(System.Byte,System.Int32,System.Int32)"]

numMantissaBits
Type: System..::..Int32

[Missing <param name="numMantissaBits"/> documentation for "M:Lucene.Net.Util.SmallFloat.ByteToFloat(System.Byte,System.Int32,System.Int32)"]

zeroExp
Type: System..::..Int32

[Missing <param name="zeroExp"/> documentation for "M:Lucene.Net.Util.SmallFloat.ByteToFloat(System.Byte,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SmallFloat.ByteToFloat(System.Byte,System.Int32,System.Int32)"]

See Also

SmallFloat Class
Lucene.Net.Util Namespace


FloatToByte Method

[image]

Lucene.Net Class Libraries
SmallFloat..::..FloatToByte Method
SmallFloat Class See Also Send Feedback
Converts a 32 bit float to an 8 bit float.
Values less than zero are all mapped to zero.
Values are truncated (rounded down) to the nearest 8 bit value.
Values between zero and the smallest representable value are rounded up.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static sbyte FloatToByte(
    float f,
    int numMantissaBits,
    int zeroExp
)
Visual Basic
Public Shared Function FloatToByte ( _
    f As Single, _
    numMantissaBits As Integer, _
    zeroExp As Integer _
) As SByte
Visual C++
public:
static signed char FloatToByte(
    float f,
    int numMantissaBits,
    int zeroExp
)

Parameters

f
Type: System..::..Single
the 32 bit float to be converted to an 8 bit float (byte)
numMantissaBits
Type: System..::..Int32
the number of mantissa bits to use in the byte, with the remainder to be used in the exponent
zeroExp
Type: System..::..Int32
the zero-point in the range of exponent values

Return Value

the 8 bit float representation

See Also

SmallFloat Class
Lucene.Net.Util Namespace


FloatToByte315 Method

[image]

Lucene.Net Class Libraries
SmallFloat..::..FloatToByte315 Method
SmallFloat Class See Also Send Feedback
floatToByte(b, mantissaBits=3, zeroExponent=15)
smallest non-zero value = 5.820766E-10
largest value = 7.5161928E9
epsilon = 0.125

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static sbyte FloatToByte315(
    float f
)
Visual Basic
Public Shared Function FloatToByte315 ( _
    f As Single _
) As SByte
Visual C++
public:
static signed char FloatToByte315(
    float f
)

Parameters

f
Type: System..::..Single

[Missing <param name="f"/> documentation for "M:Lucene.Net.Util.SmallFloat.FloatToByte315(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SmallFloat.FloatToByte315(System.Single)"]

See Also

SmallFloat Class
Lucene.Net.Util Namespace


FloatToByte52 Method

[image]

Lucene.Net Class Libraries
SmallFloat..::..FloatToByte52 Method
SmallFloat Class See Also Send Feedback
floatToByte(b, mantissaBits=5, zeroExponent=2)
smallest nonzero value = 0.033203125
largest value = 1984.0
epsilon = 0.03125

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static sbyte FloatToByte52(
    float f
)
Visual Basic
Public Shared Function FloatToByte52 ( _
    f As Single _
) As SByte
Visual C++
public:
static signed char FloatToByte52(
    float f
)

Parameters

f
Type: System..::..Single

[Missing <param name="f"/> documentation for "M:Lucene.Net.Util.SmallFloat.FloatToByte52(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SmallFloat.FloatToByte52(System.Single)"]

See Also

SmallFloat Class
Lucene.Net.Util Namespace


SortedVIntList Class

[image]

Lucene.Net Class Libraries
SortedVIntList Class
Members See Also Send Feedback
Stores and iterate on sorted integers in compressed form in RAM.
The code for compressing the differences between ascending integers was borrowed from {@link Lucene.Net.Store.IndexInput} and {@link Lucene.Net.Store.IndexOutput}.

NOTE: this class assumes the stored integers are doc Ids (hence why it extends {@link DocIdSet}). Therefore its {@link #Iterator()} assumes {@link DocIdSetIterator#NO_MORE_DOCS} can be used as sentinel. If you intent to use this value, then make sure it's not used during search flow.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SortedVIntList : DocIdSet
Visual Basic
Public Class SortedVIntList _
    Inherits DocIdSet
Visual C++
public ref class SortedVIntList : public DocIdSet

Inheritance Hierarchy

System..::..Object
Lucene.Net.Search..::..DocIdSet
Lucene.Net.Util..::..SortedVIntList

See Also

SortedVIntList Members
Lucene.Net.Util Namespace


SortedVIntList Members

[image] [image]

Lucene.Net Class Libraries
SortedVIntList Members
SortedVIntList Class Constructors Methods See Also Send Feedback

The SortedVIntList type exposes the following members.

Constructors

 | Name | Description
Public method | SortedVIntList(BitArray) | Create a SortedVIntList from a BitSet.
Public method | SortedVIntList(array<Int32>[]()[][]) | Create a SortedVIntList from all elements of an array of integers.
Public method | SortedVIntList(DocIdSetIterator) | Create a SortedVIntList.
Public method | SortedVIntList(OpenBitSet) | Create a SortedVIntList from an OpenBitSet.
Public method | SortedVIntList(array<Int32>[]()[][], Int32) | Create a SortedVIntList from an array of integers.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByteSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortedVIntList Class
Lucene.Net.Util Namespace


SortedVIntList Constructor

[image] [image]

Lucene.Net Class Libraries
SortedVIntList Constructor
SortedVIntList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortedVIntList(BitArray) | Create a SortedVIntList from a BitSet.
Public method | SortedVIntList(array<Int32>[]()[][]) | Create a SortedVIntList from all elements of an array of integers.
Public method | SortedVIntList(DocIdSetIterator) | Create a SortedVIntList.
Public method | SortedVIntList(OpenBitSet) | Create a SortedVIntList from an OpenBitSet.
Public method | SortedVIntList(array<Int32>[]()[][], Int32) | Create a SortedVIntList from an array of integers.

See Also

SortedVIntList Class
SortedVIntList Members
Lucene.Net.Util Namespace


SortedVIntList Constructor (BitArray)

[image]

Lucene.Net Class Libraries
SortedVIntList Constructor (BitArray)
SortedVIntList Class See Also Send Feedback
Create a SortedVIntList from a BitSet.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedVIntList(
    BitArray bits
)
Visual Basic
Public Sub New ( _
    bits As BitArray _
)
Visual C++
public:
SortedVIntList(
    BitArray^ bits
)

Parameters

bits
Type: System.Collections..::..BitArray
A bit set representing a set of integers.

See Also

SortedVIntList Class
SortedVIntList Overload
Lucene.Net.Util Namespace


SortedVIntList Constructor (Int32[])

[image]

Lucene.Net Class Libraries
SortedVIntList Constructor (array<Int32>[]()[][])
SortedVIntList Class See Also Send Feedback
Create a SortedVIntList from all elements of an array of integers.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedVIntList(
    int[] sortedInts
)
Visual Basic
Public Sub New ( _
    sortedInts As Integer() _
)
Visual C++
public:
SortedVIntList(
    array<int>^ sortedInts
)

Parameters

sortedInts
Type: array< System..::..Int32 >[]()[][]
A sorted array of non negative integers.

See Also

SortedVIntList Class
SortedVIntList Overload
Lucene.Net.Util Namespace


SortedVIntList Constructor (DocIdSetIterator)

[image]

Lucene.Net Class Libraries
SortedVIntList Constructor (DocIdSetIterator)
SortedVIntList Class See Also Send Feedback
Create a SortedVIntList.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedVIntList(
    DocIdSetIterator docIdSetIterator
)
Visual Basic
Public Sub New ( _
    docIdSetIterator As DocIdSetIterator _
)
Visual C++
public:
SortedVIntList(
    DocIdSetIterator^ docIdSetIterator
)

Parameters

docIdSetIterator
Type: Lucene.Net.Search..::..DocIdSetIterator
An iterator providing document numbers as a set of integers. This DocIdSetIterator is iterated completely when this constructor is called and it must provide the integers in non decreasing order.

See Also

SortedVIntList Class
SortedVIntList Overload
Lucene.Net.Util Namespace


SortedVIntList Constructor (OpenBitSet)

[image]

Lucene.Net Class Libraries
SortedVIntList Constructor (OpenBitSet)
SortedVIntList Class See Also Send Feedback
Create a SortedVIntList from an OpenBitSet.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedVIntList(
    OpenBitSet bits
)
Visual Basic
Public Sub New ( _
    bits As OpenBitSet _
)
Visual C++
public:
SortedVIntList(
    OpenBitSet^ bits
)

Parameters

bits
Type: Lucene.Net.Util..::..OpenBitSet
A bit set representing a set of integers.

See Also

SortedVIntList Class
SortedVIntList Overload
Lucene.Net.Util Namespace


SortedVIntList Constructor (Int32[], Int32)

[image]

Lucene.Net Class Libraries
SortedVIntList Constructor (array<Int32>[]()[][], Int32)
SortedVIntList Class See Also Send Feedback
Create a SortedVIntList from an array of integers.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SortedVIntList(
    int[] sortedInts,
    int inputSize
)
Visual Basic
Public Sub New ( _
    sortedInts As Integer(), _
    inputSize As Integer _
)
Visual C++
public:
SortedVIntList(
    array<int>^ sortedInts,
    int inputSize
)

Parameters

sortedInts
Type: array< System..::..Int32 >[]()[][]
An array of sorted non negative integers.
inputSize
Type: System..::..Int32
The number of integers to be used from the array.

See Also

SortedVIntList Class
SortedVIntList Overload
Lucene.Net.Util Namespace


SortedVIntList Methods

[image] [image]

Lucene.Net Class Libraries
SortedVIntList Methods
SortedVIntList Class See Also Send Feedback

The SortedVIntList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByteSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCacheable | This DocIdSet implementation is cacheable. (Overrides DocIdSet..::..IsCacheable()()()().)
Public method | Iterator | (Overrides DocIdSet..::..Iterator()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Size |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortedVIntList Class
Lucene.Net.Util Namespace


GetByteSize Method

[image]

Lucene.Net Class Libraries
SortedVIntList..::..GetByteSize Method
SortedVIntList Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SortedVIntList.GetByteSize"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int GetByteSize()
Visual Basic
Public Overridable Function GetByteSize As Integer
Visual C++
public:
virtual int GetByteSize()

Return Value

The size of the byte array storing the compressed sorted integers.

See Also

SortedVIntList Class
Lucene.Net.Util Namespace


IsCacheable Method

[image]

Lucene.Net Class Libraries
SortedVIntList..::..IsCacheable Method
SortedVIntList Class See Also Send Feedback
This DocIdSet implementation is cacheable.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool IsCacheable()
Visual Basic
Public Overrides Function IsCacheable As Boolean
Visual C++
public:
virtual bool IsCacheable() override

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SortedVIntList.IsCacheable"]

See Also

SortedVIntList Class
Lucene.Net.Util Namespace


Iterator Method

[image]

Lucene.Net Class Libraries
SortedVIntList..::..Iterator Method
SortedVIntList Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SortedVIntList.Iterator"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override DocIdSetIterator Iterator()
Visual Basic
Public Overrides Function Iterator As DocIdSetIterator
Visual C++
public:
virtual DocIdSetIterator^ Iterator() override

Return Value

An iterator over the sorted integers.

See Also

SortedVIntList Class
Lucene.Net.Util Namespace


Size Method

[image]

Lucene.Net Class Libraries
SortedVIntList..::..Size Method
SortedVIntList Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SortedVIntList.Size"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual int Size()
Visual Basic
Public Overridable Function Size As Integer
Visual C++
public:
virtual int Size()

Return Value

The total number of sorted integers.

See Also

SortedVIntList Class
Lucene.Net.Util Namespace


SorterTemplate Class

[image]

Lucene.Net Class Libraries
SorterTemplate Class
Members See Also Send Feedback
Borrowed from Cglib. Allows custom swap so that two arrays can be sorted at the same time.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class SorterTemplate
Visual Basic
Public MustInherit Class SorterTemplate
Visual C++
public ref class SorterTemplate abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..SorterTemplate

See Also

SorterTemplate Members
Lucene.Net.Util Namespace


SorterTemplate Members

[image] [image]

Lucene.Net Class Libraries
SorterTemplate Members
SorterTemplate Class Constructors Methods See Also Send Feedback

The SorterTemplate type exposes the following members.

Constructors

 | Name | Description
Protected method | SorterTemplate | Initializes a new instance of the SorterTemplate class

Methods

 | Name | Description
Protected method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MergeSort |
Public method | QuickSort |
Protected method | Swap |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


SorterTemplate Constructor

[image]

Lucene.Net Class Libraries
SorterTemplate Constructor
SorterTemplate Class See Also Send Feedback
Initializes a new instance of the SorterTemplate class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected SorterTemplate()
Visual Basic
Protected Sub New
Visual C++
protected:
SorterTemplate()

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


SorterTemplate Methods

[image] [image]

Lucene.Net Class Libraries
SorterTemplate Methods
SorterTemplate Class See Also Send Feedback

The SorterTemplate type exposes the following members.

Methods

 | Name | Description
Protected method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MergeSort |
Public method | QuickSort |
Protected method | Swap |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


Compare Method

[image]

Lucene.Net Class Libraries
SorterTemplate..::..Compare Method
SorterTemplate Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SorterTemplate.Compare(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract int Compare(
    int i,
    int j
)
Visual Basic
Protected Friend MustOverride Function Compare ( _
    i As Integer, _
    j As Integer _
) As Integer
Visual C++
protected public:
virtual int Compare(
    int i,
    int j
) abstract

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Util.SorterTemplate.Compare(System.Int32,System.Int32)"]

j
Type: System..::..Int32

[Missing <param name="j"/> documentation for "M:Lucene.Net.Util.SorterTemplate.Compare(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.SorterTemplate.Compare(System.Int32,System.Int32)"]

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


MergeSort Method

[image]

Lucene.Net Class Libraries
SorterTemplate..::..MergeSort Method
SorterTemplate Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SorterTemplate.MergeSort(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal virtual void MergeSort(
    int lo,
    int hi
)
Visual Basic
Protected Friend Overridable Sub MergeSort ( _
    lo As Integer, _
    hi As Integer _
)
Visual C++
protected public:
virtual void MergeSort(
    int lo,
    int hi
)

Parameters

lo
Type: System..::..Int32

[Missing <param name="lo"/> documentation for "M:Lucene.Net.Util.SorterTemplate.MergeSort(System.Int32,System.Int32)"]

hi
Type: System..::..Int32

[Missing <param name="hi"/> documentation for "M:Lucene.Net.Util.SorterTemplate.MergeSort(System.Int32,System.Int32)"]

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


QuickSort Method

[image]

Lucene.Net Class Libraries
SorterTemplate..::..QuickSort Method
SorterTemplate Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SorterTemplate.QuickSort(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual void QuickSort(
    int lo,
    int hi
)
Visual Basic
Public Overridable Sub QuickSort ( _
    lo As Integer, _
    hi As Integer _
)
Visual C++
public:
virtual void QuickSort(
    int lo,
    int hi
)

Parameters

lo
Type: System..::..Int32

[Missing <param name="lo"/> documentation for "M:Lucene.Net.Util.SorterTemplate.QuickSort(System.Int32,System.Int32)"]

hi
Type: System..::..Int32

[Missing <param name="hi"/> documentation for "M:Lucene.Net.Util.SorterTemplate.QuickSort(System.Int32,System.Int32)"]

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


Swap Method

[image]

Lucene.Net Class Libraries
SorterTemplate..::..Swap Method
SorterTemplate Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.SorterTemplate.Swap(System.Int32,System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected internal abstract void Swap(
    int i,
    int j
)
Visual Basic
Protected Friend MustOverride Sub Swap ( _
    i As Integer, _
    j As Integer _
)
Visual C++
protected public:
virtual void Swap(
    int i,
    int j
) abstract

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:Lucene.Net.Util.SorterTemplate.Swap(System.Int32,System.Int32)"]

j
Type: System..::..Int32

[Missing <param name="j"/> documentation for "M:Lucene.Net.Util.SorterTemplate.Swap(System.Int32,System.Int32)"]

See Also

SorterTemplate Class
Lucene.Net.Util Namespace


StringHelper Class

[image]

Lucene.Net Class Libraries
StringHelper Class
Members See Also Send Feedback
Methods for manipulating strings. $Id: StringHelper.java 801344 2009-08-05 18:05:06Z yonik $

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class StringHelper
Visual Basic
Public MustInherit Class StringHelper
Visual C++
public ref class StringHelper abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..StringHelper

See Also

StringHelper Members
Lucene.Net.Util Namespace


StringHelper Members

[image] [image]

Lucene.Net Class Libraries
StringHelper Members
StringHelper Class Methods Fields See Also Send Feedback

The StringHelper type exposes the following members.

Methods

 | Name | Description
 | BytesDifference | Compares two byte[] arrays, element by element, and returns the number of elements common to both arrays.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Intern | Return the same string object for all equal strings
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StringDifference | Compares two strings, character by character, and returns the first position where the two strings differ from one another.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
interner | Expert: The StringInterner implementation used by Lucene. This shouldn't be changed to an incompatible implementation after other Lucene APIs have been used.

See Also

StringHelper Class
Lucene.Net.Util Namespace


StringHelper Fields

[image] [image]

Lucene.Net Class Libraries
StringHelper Fields
StringHelper Class See Also Send Feedback

The StringHelper type exposes the following members.

Fields

Name | Description
interner | Expert: The StringInterner implementation used by Lucene. This shouldn't be changed to an incompatible implementation after other Lucene APIs have been used.

See Also

StringHelper Class
Lucene.Net.Util Namespace


interner Field

[image]

Lucene.Net Class Libraries
StringHelper..::..interner Field
StringHelper Class See Also Send Feedback
Expert: The StringInterner implementation used by Lucene. This shouldn't be changed to an incompatible implementation after other Lucene APIs have been used.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static StringInterner interner
Visual Basic
Public Shared interner As StringInterner
Visual C++
public:
static StringInterner^ interner

See Also

StringHelper Class
Lucene.Net.Util Namespace


StringHelper Methods

[image] [image]

Lucene.Net Class Libraries
StringHelper Methods
StringHelper Class See Also Send Feedback

The StringHelper type exposes the following members.

Methods

 | Name | Description
 | BytesDifference | Compares two byte[] arrays, element by element, and returns the number of elements common to both arrays.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Intern | Return the same string object for all equal strings
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StringDifference | Compares two strings, character by character, and returns the first position where the two strings differ from one another.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringHelper Class
Lucene.Net.Util Namespace


BytesDifference Method

[image]

Lucene.Net Class Libraries
StringHelper..::..BytesDifference Method
StringHelper Class See Also Send Feedback
Compares two byte[] arrays, element by element, and returns the number of elements common to both arrays.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int BytesDifference(
    byte[] bytes1,
    int len1,
    byte[] bytes2,
    int len2
)
Visual Basic
Public Shared Function BytesDifference ( _
    bytes1 As Byte(), _
    len1 As Integer, _
    bytes2 As Byte(), _
    len2 As Integer _
) As Integer
Visual C++
public:
static int BytesDifference(
    array<unsigned char>^ bytes1,
    int len1,
    array<unsigned char>^ bytes2,
    int len2
)

Parameters

bytes1
Type: array< System..::..Byte >[]()[][]
The first byte[] to compare
len1
Type: System..::..Int32

[Missing <param name="len1"/> documentation for "M:Lucene.Net.Util.StringHelper.BytesDifference(System.Byte[],System.Int32,System.Byte[],System.Int32)"]

bytes2
Type: array< System..::..Byte >[]()[][]
The second byte[] to compare
len2
Type: System..::..Int32

[Missing <param name="len2"/> documentation for "M:Lucene.Net.Util.StringHelper.BytesDifference(System.Byte[],System.Int32,System.Byte[],System.Int32)"]

Return Value

The number of common elements.

See Also

StringHelper Class
Lucene.Net.Util Namespace


Intern Method

[image]

Lucene.Net Class Libraries
StringHelper..::..Intern Method
StringHelper Class See Also Send Feedback
Return the same string object for all equal strings

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string Intern(
    string s
)
Visual Basic
Public Shared Function Intern ( _
    s As String _
) As String
Visual C++
public:
static String^ Intern(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Util.StringHelper.Intern(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.StringHelper.Intern(System.String)"]

See Also

StringHelper Class
Lucene.Net.Util Namespace


StringDifference Method

[image]

Lucene.Net Class Libraries
StringHelper..::..StringDifference Method
StringHelper Class See Also Send Feedback
Compares two strings, character by character, and returns the first position where the two strings differ from one another.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static int StringDifference(
    string s1,
    string s2
)
Visual Basic
Public Shared Function StringDifference ( _
    s1 As String, _
    s2 As String _
) As Integer
Visual C++
public:
static int StringDifference(
    String^ s1,
    String^ s2
)

Parameters

s1
Type: System..::..String
The first string to compare
s2
Type: System..::..String
The second string to compare

Return Value

The first position where the two strings differ.

See Also

StringHelper Class
Lucene.Net.Util Namespace


StringInterner Class

[image]

Lucene.Net Class Libraries
StringInterner Class
Members See Also Send Feedback
Subclasses of StringInterner are required to return the same single String object for all equal strings. Depending on the implementation, this may not be the same object returned as String.intern(). This StringInterner base class simply delegates to String.intern().

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class StringInterner
Visual Basic
Public Class StringInterner
Visual C++
public ref class StringInterner

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..StringInterner
Lucene.Net.Util..::..SimpleStringInterner

See Also

StringInterner Members
Lucene.Net.Util Namespace


StringInterner Members

[image] [image]

Lucene.Net Class Libraries
StringInterner Members
StringInterner Class Constructors Methods See Also Send Feedback

The StringInterner type exposes the following members.

Constructors

 | Name | Description
Public method | StringInterner | Initializes a new instance of the StringInterner class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intern(String) | Returns a single object instance for each equal string.
Public method | Intern(array<Char>[]()[][], Int32, Int32) | Returns a single object instance for each equal string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringInterner Class
Lucene.Net.Util Namespace


StringInterner Constructor

[image]

Lucene.Net Class Libraries
StringInterner Constructor
StringInterner Class See Also Send Feedback
Initializes a new instance of the StringInterner class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public StringInterner()
Visual Basic
Public Sub New
Visual C++
public:
StringInterner()

See Also

StringInterner Class
Lucene.Net.Util Namespace


StringInterner Methods

[image] [image]

Lucene.Net Class Libraries
StringInterner Methods
StringInterner Class See Also Send Feedback

The StringInterner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intern(String) | Returns a single object instance for each equal string.
Public method | Intern(array<Char>[]()[][], Int32, Int32) | Returns a single object instance for each equal string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringInterner Class
Lucene.Net.Util Namespace


Intern Method

[image] [image]

Lucene.Net Class Libraries
StringInterner..::..Intern Method
StringInterner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Intern(String) | Returns a single object instance for each equal string.
Public method | Intern(array<Char>[]()[][], Int32, Int32) | Returns a single object instance for each equal string.

See Also

StringInterner Class
StringInterner Members
Lucene.Net.Util Namespace


Intern Method (String)

[image]

Lucene.Net Class Libraries
StringInterner..::..Intern Method (String)
StringInterner Class See Also Send Feedback
Returns a single object instance for each equal string.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Intern(
    string s
)
Visual Basic
Public Overridable Function Intern ( _
    s As String _
) As String
Visual C++
public:
virtual String^ Intern(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Util.StringInterner.Intern(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.StringInterner.Intern(System.String)"]

See Also

StringInterner Class
Intern Overload
Lucene.Net.Util Namespace


Intern Method (Char[], Int32, Int32)

[image]

Lucene.Net Class Libraries
StringInterner..::..Intern Method (array<Char>[]()[][], Int32, Int32)
StringInterner Class See Also Send Feedback
Returns a single object instance for each equal string.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual string Intern(
    char[] arr,
    int offset,
    int len
)
Visual Basic
Public Overridable Function Intern ( _
    arr As Char(), _
    offset As Integer, _
    len As Integer _
) As String
Visual C++
public:
virtual String^ Intern(
    array<wchar_t>^ arr,
    int offset,
    int len
)

Parameters

arr
Type: array< System..::..Char >[]()[][]

[Missing <param name="arr"/> documentation for "M:Lucene.Net.Util.StringInterner.Intern(System.Char[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Util.StringInterner.Intern(System.Char[],System.Int32,System.Int32)"]

len
Type: System..::..Int32

[Missing <param name="len"/> documentation for "M:Lucene.Net.Util.StringInterner.Intern(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.StringInterner.Intern(System.Char[],System.Int32,System.Int32)"]

See Also

StringInterner Class
Intern Overload
Lucene.Net.Util Namespace


ToStringUtils Class

[image]

Lucene.Net Class Libraries
ToStringUtils Class
Members See Also Send Feedback
Helper methods to ease implementing {@link Object#toString()}.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class ToStringUtils
Visual Basic
Public Class ToStringUtils
Visual C++
public ref class ToStringUtils

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..ToStringUtils

See Also

ToStringUtils Members
Lucene.Net.Util Namespace


ToStringUtils Members

[image] [image]

Lucene.Net Class Libraries
ToStringUtils Members
ToStringUtils Class Constructors Methods See Also Send Feedback

The ToStringUtils type exposes the following members.

Constructors

 | Name | Description
Public method | ToStringUtils | Initializes a new instance of the ToStringUtils class

Methods

 | Name | Description
 | Boost | for printing boost only if not 1.0
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToStringUtils Class
Lucene.Net.Util Namespace


ToStringUtils Constructor

[image]

Lucene.Net Class Libraries
ToStringUtils Constructor
ToStringUtils Class See Also Send Feedback
Initializes a new instance of the ToStringUtils class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public ToStringUtils()
Visual Basic
Public Sub New
Visual C++
public:
ToStringUtils()

See Also

ToStringUtils Class
Lucene.Net.Util Namespace


ToStringUtils Methods

[image] [image]

Lucene.Net Class Libraries
ToStringUtils Methods
ToStringUtils Class See Also Send Feedback

The ToStringUtils type exposes the following members.

Methods

 | Name | Description
 | Boost | for printing boost only if not 1.0
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToStringUtils Class
Lucene.Net.Util Namespace


Boost Method

[image]

Lucene.Net Class Libraries
ToStringUtils..::..Boost Method
ToStringUtils Class See Also Send Feedback
for printing boost only if not 1.0

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static string Boost(
    float boost
)
Visual Basic
Public Shared Function Boost ( _
    boost As Single _
) As String
Visual C++
public:
static String^ Boost(
    float boost
)

Parameters

boost
Type: System..::..Single

[Missing <param name="boost"/> documentation for "M:Lucene.Net.Util.ToStringUtils.Boost(System.Single)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.ToStringUtils.Boost(System.Single)"]

See Also

ToStringUtils Class
Lucene.Net.Util Namespace


UnicodeUtil Class

[image]

Lucene.Net Class Libraries
UnicodeUtil Class
Members See Also Send Feedback
Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class UnicodeUtil
Visual Basic
Public NotInheritable Class UnicodeUtil
Visual C++
public ref class UnicodeUtil sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..UnicodeUtil

See Also

UnicodeUtil Members
Lucene.Net.Util Namespace


UnicodeUtil Members

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil Members
UnicodeUtil Class Constructors Methods Fields See Also Send Feedback

The UnicodeUtil type exposes the following members.

Constructors

 | Name | Description
Public method | UnicodeUtil | Initializes a new instance of the UnicodeUtil class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UTF16toUTF8(array<Char>[]()[][], Int32, UnicodeUtil..::..UTF8Result) | Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.
 | UTF16toUTF8(array<Char>[]()[][], Int32, Int32, UnicodeUtil..::..UTF8Result) | Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.
 | UTF16toUTF8(String, Int32, Int32, UnicodeUtil..::..UTF8Result) | Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.
 | UTF8toUTF16 | Convert UTF8 bytes into UTF16 characters. If offset is non-zero, conversion starts at that starting point in utf8, re-using the results from the previous call up until offset.

Fields

Name | Description
UNI_REPLACEMENT_CHAR |
UNI_SUR_HIGH_END |
UNI_SUR_HIGH_START |
UNI_SUR_LOW_END |
UNI_SUR_LOW_START |

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UnicodeUtil Constructor

[image]

Lucene.Net Class Libraries
UnicodeUtil Constructor
UnicodeUtil Class See Also Send Feedback
Initializes a new instance of the UnicodeUtil class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public UnicodeUtil()
Visual Basic
Public Sub New
Visual C++
public:
UnicodeUtil()

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UnicodeUtil Fields

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil Fields
UnicodeUtil Class See Also Send Feedback

The UnicodeUtil type exposes the following members.

Fields

Name | Description
UNI_REPLACEMENT_CHAR |
UNI_SUR_HIGH_END |
UNI_SUR_HIGH_START |
UNI_SUR_LOW_END |
UNI_SUR_LOW_START |

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UNI_REPLACEMENT_CHAR Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UNI_REPLACEMENT_CHAR Field
UnicodeUtil Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UNI_REPLACEMENT_CHAR"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int UNI_REPLACEMENT_CHAR
Visual Basic
Public Const UNI_REPLACEMENT_CHAR As Integer
Visual C++
public:
literal int UNI_REPLACEMENT_CHAR

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UNI_SUR_HIGH_END Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UNI_SUR_HIGH_END Field
UnicodeUtil Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UNI_SUR_HIGH_END"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int UNI_SUR_HIGH_END
Visual Basic
Public Const UNI_SUR_HIGH_END As Integer
Visual C++
public:
literal int UNI_SUR_HIGH_END

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UNI_SUR_HIGH_START Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UNI_SUR_HIGH_START Field
UnicodeUtil Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UNI_SUR_HIGH_START"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int UNI_SUR_HIGH_START
Visual Basic
Public Const UNI_SUR_HIGH_START As Integer
Visual C++
public:
literal int UNI_SUR_HIGH_START

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UNI_SUR_LOW_END Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UNI_SUR_LOW_END Field
UnicodeUtil Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UNI_SUR_LOW_END"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int UNI_SUR_LOW_END
Visual Basic
Public Const UNI_SUR_LOW_END As Integer
Visual C++
public:
literal int UNI_SUR_LOW_END

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UNI_SUR_LOW_START Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UNI_SUR_LOW_START Field
UnicodeUtil Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UNI_SUR_LOW_START"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public const int UNI_SUR_LOW_START
Visual Basic
Public Const UNI_SUR_LOW_START As Integer
Visual C++
public:
literal int UNI_SUR_LOW_START

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UnicodeUtil Methods

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil Methods
UnicodeUtil Class See Also Send Feedback

The UnicodeUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UTF16toUTF8(array<Char>[]()[][], Int32, UnicodeUtil..::..UTF8Result) | Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.
 | UTF16toUTF8(array<Char>[]()[][], Int32, Int32, UnicodeUtil..::..UTF8Result) | Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.
 | UTF16toUTF8(String, Int32, Int32, UnicodeUtil..::..UTF8Result) | Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.
 | UTF8toUTF16 | Convert UTF8 bytes into UTF16 characters. If offset is non-zero, conversion starts at that starting point in utf8, re-using the results from the previous call up until offset.

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UTF16toUTF8 Method

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16toUTF8 Method
UnicodeUtil Class See Also Send Feedback

Overload List

Name | Description
UTF16toUTF8(array<Char>[]()[][], Int32, UnicodeUtil..::..UTF8Result) | Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.
UTF16toUTF8(array<Char>[]()[][], Int32, Int32, UnicodeUtil..::..UTF8Result) | Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.
UTF16toUTF8(String, Int32, Int32, UnicodeUtil..::..UTF8Result) | Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.

See Also

UnicodeUtil Class
UnicodeUtil Members
Lucene.Net.Util Namespace


UTF16toUTF8 Method (Char[], Int32, UnicodeUtil.UTF8Result)

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16toUTF8 Method (array<Char>[]()[][], Int32, UnicodeUtil..::..UTF8Result)
UnicodeUtil Class See Also Send Feedback
Encode characters from a char[] source, starting at offset and stopping when the character 0xffff is seen. Returns the number of bytes written to bytesOut.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void UTF16toUTF8(
    char[] source,
    int offset,
    UnicodeUtil..::..UTF8Result result
)
Visual Basic
Public Shared Sub UTF16toUTF8 ( _
    source As Char(), _
    offset As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
Visual C++
public:
static void UTF16toUTF8(
    array<wchar_t>^ source,
    int offset,
    UnicodeUtil..::..UTF8Result^ result
)

Parameters

source
Type: array< System..::..Char >[]()[][]

[Missing <param name="source"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

result
Type: Lucene.Net.Util..::..UnicodeUtil..::..UTF8Result

[Missing <param name="result"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

See Also

UnicodeUtil Class
UTF16toUTF8 Overload
Lucene.Net.Util Namespace


UTF16toUTF8 Method (Char[], Int32, Int32, UnicodeUtil.UTF8Result)

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16toUTF8 Method (array<Char>[]()[][], Int32, Int32, UnicodeUtil..::..UTF8Result)
UnicodeUtil Class See Also Send Feedback
Encode characters from a char[] source, starting at offset for length chars. Returns the number of bytes written to bytesOut.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void UTF16toUTF8(
    char[] source,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result result
)
Visual Basic
Public Shared Sub UTF16toUTF8 ( _
    source As Char(), _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
Visual C++
public:
static void UTF16toUTF8(
    array<wchar_t>^ source,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result^ result
)

Parameters

source
Type: array< System..::..Char >[]()[][]

[Missing <param name="source"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

result
Type: Lucene.Net.Util..::..UnicodeUtil..::..UTF8Result

[Missing <param name="result"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.Char[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

See Also

UnicodeUtil Class
UTF16toUTF8 Overload
Lucene.Net.Util Namespace


UTF16toUTF8 Method (String, Int32, Int32, UnicodeUtil.UTF8Result)

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16toUTF8 Method (String, Int32, Int32, UnicodeUtil..::..UTF8Result)
UnicodeUtil Class See Also Send Feedback
Encode characters from this String, starting at offset for length characters. Returns the number of bytes written to bytesOut.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void UTF16toUTF8(
    string s,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result result
)
Visual Basic
Public Shared Sub UTF16toUTF8 ( _
    s As String, _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF8Result _
)
Visual C++
public:
static void UTF16toUTF8(
    String^ s,
    int offset,
    int length,
    UnicodeUtil..::..UTF8Result^ result
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.String,System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.String,System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.String,System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

result
Type: Lucene.Net.Util..::..UnicodeUtil..::..UTF8Result

[Missing <param name="result"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16toUTF8(System.String,System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF8Result)"]

See Also

UnicodeUtil Class
UTF16toUTF8 Overload
Lucene.Net.Util Namespace


UTF8toUTF16 Method

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8toUTF16 Method
UnicodeUtil Class See Also Send Feedback
Convert UTF8 bytes into UTF16 characters. If offset is non-zero, conversion starts at that starting point in utf8, re-using the results from the previous call up until offset.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static void UTF8toUTF16(
    byte[] utf8,
    int offset,
    int length,
    UnicodeUtil..::..UTF16Result result
)
Visual Basic
Public Shared Sub UTF8toUTF16 ( _
    utf8 As Byte(), _
    offset As Integer, _
    length As Integer, _
    result As UnicodeUtil..::..UTF16Result _
)
Visual C++
public:
static void UTF8toUTF16(
    array<unsigned char>^ utf8,
    int offset,
    int length,
    UnicodeUtil..::..UTF16Result^ result
)

Parameters

utf8
Type: array< System..::..Byte >[]()[][]

[Missing <param name="utf8"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF8toUTF16(System.Byte[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF16Result)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF8toUTF16(System.Byte[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF16Result)"]

length
Type: System..::..Int32

[Missing <param name="length"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF8toUTF16(System.Byte[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF16Result)"]

result
Type: Lucene.Net.Util..::..UnicodeUtil..::..UTF16Result

[Missing <param name="result"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF8toUTF16(System.Byte[],System.Int32,System.Int32,Lucene.Net.Util.UnicodeUtil.UTF16Result)"]

See Also

UnicodeUtil Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Class

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result Class
UnicodeUtil Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Util.UnicodeUtil.UTF16Result"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class UTF16Result
Visual Basic
Public NotInheritable Class UTF16Result
Visual C++
public ref class UTF16Result sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..UnicodeUtil..::..UTF16Result

See Also

UnicodeUtil..::..UTF16Result Members
Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Members

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result Members
UnicodeUtil..::..UTF16Result Class Constructors Methods Fields See Also Send Feedback

Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

The UnicodeUtil..::..UTF16Result type exposes the following members.

Constructors

 | Name | Description
Public method | UnicodeUtil..::..UTF16Result | Initializes a new instance of the UnicodeUtil..::..UTF16Result class

Methods

 | Name | Description
Public method | CopyText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLength |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | length |
Public field | offsets |
Public field | result |

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Constructor

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result Constructor
UnicodeUtil..::..UTF16Result Class See Also Send Feedback
Initializes a new instance of the UnicodeUtil..::..UTF16Result class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public UTF16Result()
Visual Basic
Public Sub New
Visual C++
public:
UTF16Result()

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Fields

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result Fields
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

The UnicodeUtil..::..UTF16Result type exposes the following members.

Fields

 | Name | Description
Public field | length |
Public field | offsets |
Public field | result |

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


length Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result..::..length Field
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UTF16Result.length"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int length
Visual Basic
Public length As Integer
Visual C++
public:
int length

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


offsets Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result..::..offsets Field
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UTF16Result.offsets"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int[] offsets
Visual Basic
Public offsets As Integer()
Visual C++
public:
array<int>^ offsets

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


result Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result..::..result Field
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UTF16Result.result"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public char[] result
Visual Basic
Public result As Char()
Visual C++
public:
array<wchar_t>^ result

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF16Result Methods

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result Methods
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

The UnicodeUtil..::..UTF16Result type exposes the following members.

Methods

 | Name | Description
Public method | CopyText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLength |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


CopyText Method

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result..::..CopyText Method
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16Result.CopyText(Lucene.Net.Util.UnicodeUtil.UTF16Result)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void CopyText(
    UnicodeUtil..::..UTF16Result other
)
Visual Basic
Public Sub CopyText ( _
    other As UnicodeUtil..::..UTF16Result _
)
Visual C++
public:
void CopyText(
    UnicodeUtil..::..UTF16Result^ other
)

Parameters

other
Type: Lucene.Net.Util..::..UnicodeUtil..::..UTF16Result

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16Result.CopyText(Lucene.Net.Util.UnicodeUtil.UTF16Result)"]

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


SetLength Method

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF16Result..::..SetLength Method
UnicodeUtil..::..UTF16Result Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16Result.SetLength(System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetLength(
    int newLength
)
Visual Basic
Public Sub SetLength ( _
    newLength As Integer _
)
Visual C++
public:
void SetLength(
    int newLength
)

Parameters

newLength
Type: System..::..Int32

[Missing <param name="newLength"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF16Result.SetLength(System.Int32)"]

See Also

UnicodeUtil..::..UTF16Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Class

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result Class
UnicodeUtil Class Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Util.UnicodeUtil.UTF8Result"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public sealed class UTF8Result
Visual Basic
Public NotInheritable Class UTF8Result
Visual C++
public ref class UTF8Result sealed

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..UnicodeUtil..::..UTF8Result

See Also

UnicodeUtil..::..UTF8Result Members
Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Members

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result Members
UnicodeUtil..::..UTF8Result Class Constructors Methods Fields See Also Send Feedback

Class to encode java's UTF16 char[] into UTF8 byte[] without always allocating a new byte[] as String.getBytes("UTF-8") does.

WARNING: This API is a new and experimental and may suddenly change.

The UnicodeUtil..::..UTF8Result type exposes the following members.

Constructors

 | Name | Description
Public method | UnicodeUtil..::..UTF8Result | Initializes a new instance of the UnicodeUtil..::..UTF8Result class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLength |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | length |
Public field | result |

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Constructor

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result Constructor
UnicodeUtil..::..UTF8Result Class See Also Send Feedback
Initializes a new instance of the UnicodeUtil..::..UTF8Result class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public UTF8Result()
Visual Basic
Public Sub New
Visual C++
public:
UTF8Result()

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Fields

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result Fields
UnicodeUtil..::..UTF8Result Class See Also Send Feedback

The UnicodeUtil..::..UTF8Result type exposes the following members.

Fields

 | Name | Description
Public field | length |
Public field | result |

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


length Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result..::..length Field
UnicodeUtil..::..UTF8Result Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UTF8Result.length"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public int length
Visual Basic
Public length As Integer
Visual C++
public:
int length

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


result Field

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result..::..result Field
UnicodeUtil..::..UTF8Result Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.UnicodeUtil.UTF8Result.result"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public byte[] result
Visual Basic
Public result As Byte()
Visual C++
public:
array<unsigned char>^ result

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


UnicodeUtil.UTF8Result Methods

[image] [image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result Methods
UnicodeUtil..::..UTF8Result Class See Also Send Feedback

The UnicodeUtil..::..UTF8Result type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLength |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


SetLength Method

[image]

Lucene.Net Class Libraries
UnicodeUtil..::..UTF8Result..::..SetLength Method
UnicodeUtil..::..UTF8Result Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF8Result.SetLength(System.Int32)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public void SetLength(
    int newLength
)
Visual Basic
Public Sub SetLength ( _
    newLength As Integer _
)
Visual C++
public:
void SetLength(
    int newLength
)

Parameters

newLength
Type: System..::..Int32

[Missing <param name="newLength"/> documentation for "M:Lucene.Net.Util.UnicodeUtil.UTF8Result.SetLength(System.Int32)"]

See Also

UnicodeUtil..::..UTF8Result Class
Lucene.Net.Util Namespace


Version Class

[image]

Lucene.Net Class Libraries
Version Class
Members See Also Send Feedback
Use by certain classes to match version compatibility across releases of Lucene.

WARNING: When changing the version parameter that you supply to components in Lucene, do not simply change the version at search-time, but instead also adjust your indexing code to match, and re-index.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[SerializableAttribute]
public sealed class Version : Parameter
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class Version _
    Inherits Parameter
Visual C++
[SerializableAttribute]
public ref class Version sealed : public Parameter

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util..::..Parameter
Lucene.Net.Util..::..Version

See Also

Version Members
Lucene.Net.Util Namespace


Version Members

[image] [image]

Lucene.Net Class Libraries
Version Members
Version Class Constructors Methods Fields See Also Send Feedback

The Version type exposes the following members.

Constructors

 | Name | Description
Public method | Version | Initializes a new instance of the Version class

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnOrAfter |
Public method | ToString | (Inherited from Parameter.)

Fields

Name | Description
LUCENE_20 | Match settings and bugs in Lucene's 2.0 release.
LUCENE_21 | Match settings and bugs in Lucene's 2.1 release.
LUCENE_22 | Match settings and bugs in Lucene's 2.2 release.
LUCENE_23 | Match settings and bugs in Lucene's 2.3 release.
LUCENE_24 | Match settings and bugs in Lucene's 2.3 release.
LUCENE_29 |
LUCENE_CURRENT | Obsolete. WARNING: if you use this setting, and then upgrade to a newer release of Lucene, sizable changes may happen. If precise back compatibility is important then you should instead explicitly specify an actual version. If you use this constant then you may need to re-index all of your documents when upgrading Lucene, as the way text is indexed may have changed. Additionally, you may need to re-test your entire application to ensure it behaves as expected, as some defaults may have changed and may break functionality in your application.

See Also

Version Class
Lucene.Net.Util Namespace


Version Constructor

[image]

Lucene.Net Class Libraries
Version Constructor
Version Class See Also Send Feedback
Initializes a new instance of the Version class

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public Version(
    string name,
    int v
)
Visual Basic
Public Sub New ( _
    name As String, _
    v As Integer _
)
Visual C++
public:
Version(
    String^ name,
    int v
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Lucene.Net.Util.Version.#ctor(System.String,System.Int32)"]

v
Type: System..::..Int32

[Missing <param name="v"/> documentation for "M:Lucene.Net.Util.Version.#ctor(System.String,System.Int32)"]

See Also

Version Class
Lucene.Net.Util Namespace


Version Fields

[image] [image]

Lucene.Net Class Libraries
Version Fields
Version Class See Also Send Feedback

The Version type exposes the following members.

Fields

Name | Description
LUCENE_20 | Match settings and bugs in Lucene's 2.0 release.
LUCENE_21 | Match settings and bugs in Lucene's 2.1 release.
LUCENE_22 | Match settings and bugs in Lucene's 2.2 release.
LUCENE_23 | Match settings and bugs in Lucene's 2.3 release.
LUCENE_24 | Match settings and bugs in Lucene's 2.3 release.
LUCENE_29 |
LUCENE_CURRENT | Obsolete. WARNING: if you use this setting, and then upgrade to a newer release of Lucene, sizable changes may happen. If precise back compatibility is important then you should instead explicitly specify an actual version. If you use this constant then you may need to re-index all of your documents when upgrading Lucene, as the way text is indexed may have changed. Additionally, you may need to re-test your entire application to ensure it behaves as expected, as some defaults may have changed and may break functionality in your application.

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_20 Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_20 Field
Version Class See Also Send Feedback
Match settings and bugs in Lucene's 2.0 release.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Version LUCENE_20
Visual Basic
Public Shared ReadOnly LUCENE_20 As Version
Visual C++
public:
static initonly Version^ LUCENE_20

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_21 Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_21 Field
Version Class See Also Send Feedback
Match settings and bugs in Lucene's 2.1 release.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Version LUCENE_21
Visual Basic
Public Shared ReadOnly LUCENE_21 As Version
Visual C++
public:
static initonly Version^ LUCENE_21

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_22 Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_22 Field
Version Class See Also Send Feedback
Match settings and bugs in Lucene's 2.2 release.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Version LUCENE_22
Visual Basic
Public Shared ReadOnly LUCENE_22 As Version
Visual C++
public:
static initonly Version^ LUCENE_22

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_23 Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_23 Field
Version Class See Also Send Feedback
Match settings and bugs in Lucene's 2.3 release.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Version LUCENE_23
Visual Basic
Public Shared ReadOnly LUCENE_23 As Version
Visual C++
public:
static initonly Version^ LUCENE_23

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_24 Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_24 Field
Version Class See Also Send Feedback
Match settings and bugs in Lucene's 2.3 release.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Version LUCENE_24
Visual Basic
Public Shared ReadOnly LUCENE_24 As Version
Visual C++
public:
static initonly Version^ LUCENE_24

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_29 Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_29 Field
Version Class See Also Send Feedback

[Missing <summary> documentation for "F:Lucene.Net.Util.Version.LUCENE_29"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static readonly Version LUCENE_29
Visual Basic
Public Shared ReadOnly LUCENE_29 As Version
Visual C++
public:
static initonly Version^ LUCENE_29

See Also

Version Class
Lucene.Net.Util Namespace


LUCENE_CURRENT Field

[image]

Lucene.Net Class Libraries
Version..::..LUCENE_CURRENT Field
Version Class See Also Send Feedback

WARNING: if you use this setting, and then upgrade to a newer release of Lucene, sizable changes may happen. If precise back compatibility is important then you should instead explicitly specify an actual version. If you use this constant then you may need to re-index all of your documents when upgrading Lucene, as the way text is indexed may have changed. Additionally, you may need to re-test your entire application to ensure it behaves as expected, as some defaults may have changed and may break functionality in your application.

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
[ObsoleteAttribute("Use an actual version instead.")]
public static readonly Version LUCENE_CURRENT
Visual Basic
<ObsoleteAttribute("Use an actual version instead.")> _
Public Shared ReadOnly LUCENE_CURRENT As Version
Visual C++
[ObsoleteAttribute(L"Use an actual version instead.")]
public:
static initonly Version^ LUCENE_CURRENT

See Also

Version Class
Lucene.Net.Util Namespace


Version Methods

[image] [image]

Lucene.Net Class Libraries
Version Methods
Version Class See Also Send Feedback

The Version type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Resolves the deserialized instance to the local reference for accurate equals() and == comparisons. (Inherited from Parameter.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnOrAfter |
Public method | ToString | (Inherited from Parameter.)

See Also

Version Class
Lucene.Net.Util Namespace


OnOrAfter Method

[image]

Lucene.Net Class Libraries
Version..::..OnOrAfter Method
Version Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Version.OnOrAfter(Lucene.Net.Util.Version)"]

Namespace: Lucene.Net.Util
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public bool OnOrAfter(
    Version other
)
Visual Basic
Public Function OnOrAfter ( _
    other As Version _
) As Boolean
Visual C++
public:
bool OnOrAfter(
    Version^ other
)

Parameters

other
Type: Lucene.Net.Util..::..Version

[Missing <param name="other"/> documentation for "M:Lucene.Net.Util.Version.OnOrAfter(Lucene.Net.Util.Version)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Version.OnOrAfter(Lucene.Net.Util.Version)"]

See Also

Version Class
Lucene.Net.Util Namespace


Lucene.Net.Util.Cache Namespace

[image]

Lucene.Net Class Libraries
Lucene.Net.Util.Cache Namespace
Send Feedback

[Missing <summary> documentation for "N:Lucene.Net.Util.Cache"]

Classes

 | Class | Description
Public class | AbstractSegmentCache | Root custom cache to allow a factory to retain references to the custom caches without having to be aware of the type.
Public class | Cache | Base class for cache implementations.
Public class | SegmentCache<(Of <(<'T>)>)> | Custom cache with two levels of keys, outer key is the IndexReader with the inner key being a string, commonly a field name but can be anything. Refer to the unit tests for an example implementation. The type that is being cached.
Public class | SimpleLRUCache |
Public class | SimpleMapCache | Simple cache implementation that uses a HashMap to store (key, value) pairs. This cache is not synchronized, use {@link Cache#SynchronizedCache(Cache)} if needed.


AbstractSegmentCache Class

[image]

Lucene.Net Class Libraries
AbstractSegmentCache Class
Members See Also Send Feedback
Root custom cache to allow a factory to retain references to the custom caches without having to be aware of the type.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract class AbstractSegmentCache
Visual Basic
Public MustInherit Class AbstractSegmentCache
Visual C++
public ref class AbstractSegmentCache abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util.Cache..::..AbstractSegmentCache
Lucene.Net.Util.Cache..::..SegmentCache<(Of <(<'T>)>)>

See Also

AbstractSegmentCache Members
Lucene.Net.Util.Cache Namespace


AbstractSegmentCache Members

[image] [image]

Lucene.Net Class Libraries
AbstractSegmentCache Members
AbstractSegmentCache Class Constructors Methods See Also Send Feedback

The AbstractSegmentCache type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractSegmentCache | Initializes a new instance of the AbstractSegmentCache class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Warm | Used to warm up the cache.

See Also

AbstractSegmentCache Class
Lucene.Net.Util.Cache Namespace


AbstractSegmentCache Constructor

[image]

Lucene.Net Class Libraries
AbstractSegmentCache Constructor
AbstractSegmentCache Class See Also Send Feedback
Initializes a new instance of the AbstractSegmentCache class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected AbstractSegmentCache()
Visual Basic
Protected Sub New
Visual C++
protected:
AbstractSegmentCache()

See Also

AbstractSegmentCache Class
Lucene.Net.Util.Cache Namespace


AbstractSegmentCache Methods

[image] [image]

Lucene.Net Class Libraries
AbstractSegmentCache Methods
AbstractSegmentCache Class See Also Send Feedback

The AbstractSegmentCache type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Warm | Used to warm up the cache.

See Also

AbstractSegmentCache Class
Lucene.Net.Util.Cache Namespace


Warm Method

[image]

Lucene.Net Class Libraries
AbstractSegmentCache..::..Warm Method
AbstractSegmentCache Class See Also Send Feedback
Used to warm up the cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract void Warm(
    IndexReader reader,
    string key
)
Visual Basic
Public MustOverride Sub Warm ( _
    reader As IndexReader, _
    key As String _
)
Visual C++
public:
virtual void Warm(
    IndexReader^ reader,
    String^ key
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The reader to warm the cache for.
key
Type: System..::..String
The inner key.

See Also

AbstractSegmentCache Class
Lucene.Net.Util.Cache Namespace


Cache Class

[image]

Lucene.Net Class Libraries
Cache Class
Members See Also Send Feedback
Base class for cache implementations.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract class Cache
Visual Basic
Public MustInherit Class Cache
Visual C++
public ref class Cache abstract

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util.Cache..::..Cache
Lucene.Net.Util.Cache..::..SimpleMapCache

See Also

Cache Members
Lucene.Net.Util.Cache Namespace


Cache Members

[image] [image]

Lucene.Net Class Libraries
Cache Members
Cache Class Constructors Methods See Also Send Feedback

The Cache type exposes the following members.

Constructors

 | Name | Description
Protected method | Cache | Initializes a new instance of the Cache class

Methods

 | Name | Description
Public method | Close | Closes the cache.
Public method | ContainsKey | Returns whether the given key is in this cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Returns the value for the given key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts a (key, value)-pair into the cache.
 | SynchronizedCache | Returns a thread-safe cache backed by the specified cache. In order to guarantee thread-safety, all access to the backed cache must be accomplished through the returned cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


Cache Constructor

[image]

Lucene.Net Class Libraries
Cache Constructor
Cache Class See Also Send Feedback
Initializes a new instance of the Cache class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
protected Cache()
Visual Basic
Protected Sub New
Visual C++
protected:
Cache()

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


Cache Methods

[image] [image]

Lucene.Net Class Libraries
Cache Methods
Cache Class See Also Send Feedback

The Cache type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the cache.
Public method | ContainsKey | Returns whether the given key is in this cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Returns the value for the given key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts a (key, value)-pair into the cache.
 | SynchronizedCache | Returns a thread-safe cache backed by the specified cache. In order to guarantee thread-safety, all access to the backed cache must be accomplished through the returned cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


Close Method

[image]

Lucene.Net Class Libraries
Cache..::..Close Method
Cache Class See Also Send Feedback
Closes the cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Close()
Visual Basic
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


ContainsKey Method

[image]

Lucene.Net Class Libraries
Cache..::..ContainsKey Method
Cache Class See Also Send Feedback
Returns whether the given key is in this cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract bool ContainsKey(
    Object key
)
Visual Basic
Public MustOverride Function ContainsKey ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool ContainsKey(
    Object^ key
) abstract

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.Cache.ContainsKey(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.Cache.ContainsKey(System.Object)"]

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


Get Method

[image]

Lucene.Net Class Libraries
Cache..::..Get Method
Cache Class See Also Send Feedback
Returns the value for the given key.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract Object Get(
    Object key
)
Visual Basic
Public MustOverride Function Get ( _
    key As Object _
) As Object
Visual C++
public:
virtual Object^ Get(
    Object^ key
) abstract

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.Cache.Get(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.Cache.Get(System.Object)"]

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


Put Method

[image]

Lucene.Net Class Libraries
Cache..::..Put Method
Cache Class See Also Send Feedback
Puts a (key, value)-pair into the cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public abstract void Put(
    Object key,
    Object value_Renamed
)
Visual Basic
Public MustOverride Sub Put ( _
    key As Object, _
    value_Renamed As Object _
)
Visual C++
public:
virtual void Put(
    Object^ key,
    Object^ value_Renamed
) abstract

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.Cache.Put(System.Object,System.Object)"]

value_Renamed
Type: System..::..Object

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Util.Cache.Cache.Put(System.Object,System.Object)"]

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


SynchronizedCache Method

[image]

Lucene.Net Class Libraries
Cache..::..SynchronizedCache Method
Cache Class See Also Send Feedback
Returns a thread-safe cache backed by the specified cache. In order to guarantee thread-safety, all access to the backed cache must be accomplished through the returned cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public static Cache SynchronizedCache(
    Cache cache
)
Visual Basic
Public Shared Function SynchronizedCache ( _
    cache As Cache _
) As Cache
Visual C++
public:
static Cache^ SynchronizedCache(
    Cache^ cache
)

Parameters

cache
Type: Lucene.Net.Util.Cache..::..Cache

[Missing <param name="cache"/> documentation for "M:Lucene.Net.Util.Cache.Cache.SynchronizedCache(Lucene.Net.Util.Cache.Cache)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.Cache.SynchronizedCache(Lucene.Net.Util.Cache.Cache)"]

See Also

Cache Class
Lucene.Net.Util.Cache Namespace


SegmentCache(T) Class

[image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Custom cache with two levels of keys, outer key is the IndexReader with the inner key being a string, commonly a field name but can be anything. Refer to the unit tests for an example implementation. The type that is being cached.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public abstract class SegmentCache<T> : AbstractSegmentCache
Visual Basic
Public MustInherit Class SegmentCache(Of T) _
    Inherits AbstractSegmentCache
Visual C++
generic<typename T>
public ref class SegmentCache abstract : public AbstractSegmentCache

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Lucene.Net.Util.Cache.SegmentCache`1"]

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util.Cache..::..AbstractSegmentCache
Lucene.Net.Util.Cache..::..SegmentCache<(Of <(<'T>)>)>

See Also

SegmentCache<(Of <(<'T>)>)> Members
Lucene.Net.Util.Cache Namespace


SegmentCache(T) Members

[image] [image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)> Members
SegmentCache<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The SegmentCache<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | SegmentCache<(Of <(<'T>)>)> | Initializes a new instance of the SegmentCache<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | CreateValue | Value creation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Get the item from the cache.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Warm | Warm the cache - simply calls Get and ignores the return value. (Overrides AbstractSegmentCache..::..Warm(IndexReader, String).)

Properties

 | Name | Description
Public property | KeyCount | The number of outermost keys in the collection.

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


SegmentCache(T) Constructor

[image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)> Constructor
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the SegmentCache<(Of <(<'T>)>)> class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected SegmentCache()
Visual Basic
Protected Sub New
Visual C++
protected:
SegmentCache()

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


SegmentCache(T) Methods

[image] [image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)> Methods
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback

The SegmentCache<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | CreateValue | Value creation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Get the item from the cache.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Warm | Warm the cache - simply calls Get and ignores the return value. (Overrides AbstractSegmentCache..::..Warm(IndexReader, String).)

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


CreateValue Method

[image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)>..::..CreateValue Method
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback
Value creation.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
protected abstract T CreateValue(
    IndexReader reader,
    string key
)
Visual Basic
Protected MustOverride Function CreateValue ( _
    reader As IndexReader, _
    key As String _
) As T
Visual C++
protected:
virtual T CreateValue(
    IndexReader^ reader,
    String^ key
) abstract

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The reader.
key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.SegmentCache`1.CreateValue(Lucene.Net.Index.IndexReader,System.String)"]

Return Value

The value.

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


Get Method

[image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)>..::..Get Method
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback
Get the item from the cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public virtual T Get(
    IndexReader reader,
    string key
)
Visual Basic
Public Overridable Function Get ( _
    reader As IndexReader, _
    key As String _
) As T
Visual C++
public:
virtual T Get(
    IndexReader^ reader,
    String^ key
)

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The IndexReader the cache is from.
key
Type: System..::..String
The key of the item under the reader.

Return Value

The item from cache.

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


Warm Method

[image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)>..::..Warm Method
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback
Warm the cache - simply calls Get and ignores the return value.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public override void Warm(
    IndexReader reader,
    string key
)
Visual Basic
Public Overrides Sub Warm ( _
    reader As IndexReader, _
    key As String _
)
Visual C++
public:
virtual void Warm(
    IndexReader^ reader,
    String^ key
) override

Parameters

reader
Type: Lucene.Net.Index..::..IndexReader
The index reader to warm up.
key
Type: System..::..String
The key of the item under the reader.

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


SegmentCache(T) Properties

[image] [image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)> Properties
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback

The SegmentCache<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | KeyCount | The number of outermost keys in the collection.

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


KeyCount Property

[image]

Lucene.Net Class Libraries
SegmentCache<(Of <(<'T>)>)>..::..KeyCount Property
SegmentCache<(Of <(<'T>)>)> Class See Also Send Feedback
The number of outermost keys in the collection.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net.Contrib.Core (in Lucene.Net.Contrib.Core.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public int KeyCount { get; }
Visual Basic
Public ReadOnly Property KeyCount As Integer
    Get
Visual C++
public:
property int KeyCount {
    int get ();
}

See Also

SegmentCache<(Of <(<'T>)>)> Class
Lucene.Net.Util.Cache Namespace


SimpleLRUCache Class

[image]

Lucene.Net Class Libraries
SimpleLRUCache Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Lucene.Net.Util.Cache.SimpleLRUCache"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleLRUCache : SimpleMapCache
Visual Basic
Public Class SimpleLRUCache _
    Inherits SimpleMapCache
Visual C++
public ref class SimpleLRUCache : public SimpleMapCache

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util.Cache..::..Cache
Lucene.Net.Util.Cache..::..SimpleMapCache
Lucene.Net.Util.Cache..::..SimpleLRUCache

See Also

SimpleLRUCache Members
Lucene.Net.Util.Cache Namespace


SimpleLRUCache Members

[image] [image]

Lucene.Net Class Libraries
SimpleLRUCache Members
SimpleLRUCache Class Constructors Methods See Also Send Feedback

The SimpleLRUCache type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleLRUCache | Initializes a new instance of the SimpleLRUCache class

Methods

 | Name | Description
Public method | Close | (Inherited from SimpleMapCache.)
Public method | ContainsKey | (Inherited from SimpleMapCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | (Overrides SimpleMapCache..::..Get(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeySet | Returns a Set containing all keys in this cache. (Inherited from SimpleMapCache.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | (Overrides SimpleMapCache..::..Put(Object, Object).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleLRUCache Class
Lucene.Net.Util.Cache Namespace


SimpleLRUCache Constructor

[image]

Lucene.Net Class Libraries
SimpleLRUCache Constructor
SimpleLRUCache Class See Also Send Feedback
Initializes a new instance of the SimpleLRUCache class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleLRUCache(
    int Capacity
)
Visual Basic
Public Sub New ( _
    Capacity As Integer _
)
Visual C++
public:
SimpleLRUCache(
    int Capacity
)

Parameters

Capacity
Type: System..::..Int32

[Missing <param name="Capacity"/> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.#ctor(System.Int32)"]

See Also

SimpleLRUCache Class
Lucene.Net.Util.Cache Namespace


SimpleLRUCache Methods

[image] [image]

Lucene.Net Class Libraries
SimpleLRUCache Methods
SimpleLRUCache Class See Also Send Feedback

The SimpleLRUCache type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from SimpleMapCache.)
Public method | ContainsKey | (Inherited from SimpleMapCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | (Overrides SimpleMapCache..::..Get(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeySet | Returns a Set containing all keys in this cache. (Inherited from SimpleMapCache.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | (Overrides SimpleMapCache..::..Put(Object, Object).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleLRUCache Class
Lucene.Net.Util.Cache Namespace


Get Method

[image]

Lucene.Net Class Libraries
SimpleLRUCache..::..Get Method
SimpleLRUCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.Get(System.Object)"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Get(
    Object Key
)
Visual Basic
Public Overrides Function Get ( _
    Key As Object _
) As Object
Visual C++
public:
virtual Object^ Get(
    Object^ Key
) override

Parameters

Key
Type: System..::..Object

[Missing <param name="Key"/> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.Get(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.Get(System.Object)"]

See Also

SimpleLRUCache Class
Lucene.Net.Util.Cache Namespace


Put Method

[image]

Lucene.Net Class Libraries
SimpleLRUCache..::..Put Method
SimpleLRUCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.Put(System.Object,System.Object)"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Put(
    Object Key,
    Object Value
)
Visual Basic
Public Overrides Sub Put ( _
    Key As Object, _
    Value As Object _
)
Visual C++
public:
virtual void Put(
    Object^ Key,
    Object^ Value
) override

Parameters

Key
Type: System..::..Object

[Missing <param name="Key"/> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.Put(System.Object,System.Object)"]

Value
Type: System..::..Object

[Missing <param name="Value"/> documentation for "M:Lucene.Net.Util.Cache.SimpleLRUCache.Put(System.Object,System.Object)"]

See Also

SimpleLRUCache Class
Lucene.Net.Util.Cache Namespace


SimpleMapCache Class

[image]

Lucene.Net Class Libraries
SimpleMapCache Class
Members See Also Send Feedback
Simple cache implementation that uses a HashMap to store (key, value) pairs. This cache is not synchronized, use {@link Cache#SynchronizedCache(Cache)} if needed.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public class SimpleMapCache : Cache
Visual Basic
Public Class SimpleMapCache _
    Inherits Cache
Visual C++
public ref class SimpleMapCache : public Cache

Inheritance Hierarchy

System..::..Object
Lucene.Net.Util.Cache..::..Cache
Lucene.Net.Util.Cache..::..SimpleMapCache
Lucene.Net.Util.Cache..::..SimpleLRUCache

See Also

SimpleMapCache Members
Lucene.Net.Util.Cache Namespace


SimpleMapCache Members

[image] [image]

Lucene.Net Class Libraries
SimpleMapCache Members
SimpleMapCache Class Constructors Methods See Also Send Feedback

The SimpleMapCache type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleMapCache()()()() | Initializes a new instance of the SimpleMapCache class
Public method | SimpleMapCache(IDictionary) | Initializes a new instance of the SimpleMapCache class

Methods

 | Name | Description
Public method | Close | (Overrides Cache..::..Close()()()().)
Public method | ContainsKey | (Overrides Cache..::..ContainsKey(Object).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | (Overrides Cache..::..Get(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeySet | Returns a Set containing all keys in this cache.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | (Overrides Cache..::..Put(Object, Object).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


SimpleMapCache Constructor

[image] [image]

Lucene.Net Class Libraries
SimpleMapCache Constructor
SimpleMapCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleMapCache()()()() | Initializes a new instance of the SimpleMapCache class
Public method | SimpleMapCache(IDictionary) | Initializes a new instance of the SimpleMapCache class

See Also

SimpleMapCache Class
SimpleMapCache Members
Lucene.Net.Util.Cache Namespace


SimpleMapCache Constructor

[image]

Lucene.Net Class Libraries
SimpleMapCache Constructor
SimpleMapCache Class See Also Send Feedback
Initializes a new instance of the SimpleMapCache class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleMapCache()
Visual Basic
Public Sub New
Visual C++
public:
SimpleMapCache()

See Also

SimpleMapCache Class
SimpleMapCache Overload
Lucene.Net.Util.Cache Namespace


SimpleMapCache Constructor (IDictionary)

[image]

Lucene.Net Class Libraries
SimpleMapCache Constructor (IDictionary)
SimpleMapCache Class See Also Send Feedback
Initializes a new instance of the SimpleMapCache class

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public SimpleMapCache(
    IDictionary map
)
Visual Basic
Public Sub New ( _
    map As IDictionary _
)
Visual C++
public:
SimpleMapCache(
    IDictionary^ map
)

Parameters

map
Type: System.Collections..::..IDictionary

[Missing <param name="map"/> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.#ctor(System.Collections.IDictionary)"]

See Also

SimpleMapCache Class
SimpleMapCache Overload
Lucene.Net.Util.Cache Namespace


SimpleMapCache Methods

[image] [image]

Lucene.Net Class Libraries
SimpleMapCache Methods
SimpleMapCache Class See Also Send Feedback

The SimpleMapCache type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Overrides Cache..::..Close()()()().)
Public method | ContainsKey | (Overrides Cache..::..ContainsKey(Object).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | (Overrides Cache..::..Get(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeySet | Returns a Set containing all keys in this cache.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | (Overrides Cache..::..Put(Object, Object).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


Close Method

[image]

Lucene.Net Class Libraries
SimpleMapCache..::..Close Method
SimpleMapCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Close"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


ContainsKey Method

[image]

Lucene.Net Class Libraries
SimpleMapCache..::..ContainsKey Method
SimpleMapCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.ContainsKey(System.Object)"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override bool ContainsKey(
    Object key
)
Visual Basic
Public Overrides Function ContainsKey ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool ContainsKey(
    Object^ key
) override

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.ContainsKey(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.ContainsKey(System.Object)"]

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


Get Method

[image]

Lucene.Net Class Libraries
SimpleMapCache..::..Get Method
SimpleMapCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Get(System.Object)"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override Object Get(
    Object key
)
Visual Basic
Public Overrides Function Get ( _
    key As Object _
) As Object
Visual C++
public:
virtual Object^ Get(
    Object^ key
) override

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Get(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Get(System.Object)"]

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


KeySet Method

[image]

Lucene.Net Class Libraries
SimpleMapCache..::..KeySet Method
SimpleMapCache Class See Also Send Feedback
Returns a Set containing all keys in this cache.

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public virtual ICollection KeySet()
Visual Basic
Public Overridable Function KeySet As ICollection
Visual C++
public:
virtual ICollection^ KeySet()

Return Value

[Missing <returns> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.KeySet"]

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


Put Method

[image]

Lucene.Net Class Libraries
SimpleMapCache..::..Put Method
SimpleMapCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Put(System.Object,System.Object)"]

Namespace: Lucene.Net.Util.Cache
Assembly: Lucene.Net (in Lucene.Net.dll) Version: 2.9.4.1

Syntax

C#
public override void Put(
    Object key,
    Object value_Renamed
)
Visual Basic
Public Overrides Sub Put ( _
    key As Object, _
    value_Renamed As Object _
)
Visual C++
public:
virtual void Put(
    Object^ key,
    Object^ value_Renamed
) override

Parameters

key
Type: System..::..Object

[Missing <param name="key"/> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Put(System.Object,System.Object)"]

value_Renamed
Type: System..::..Object

[Missing <param name="value_Renamed"/> documentation for "M:Lucene.Net.Util.Cache.SimpleMapCache.Put(System.Object,System.Object)"]

See Also

SimpleMapCache Class
Lucene.Net.Util.Cache Namespace


SF.Snowball Namespace

[image]

Lucene.Net Class Libraries
SF.Snowball Namespace
Send Feedback

[Missing <summary> documentation for "N:SF.Snowball"]

Classes

 | Class | Description
Public class | Among |
Public class | SnowballProgram |
Public class | TestApp |


Among Class

[image]

Lucene.Net Class Libraries
Among Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.Among"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class Among
Visual Basic
Public Class Among
Visual C++
public ref class Among

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..Among

See Also

Among Members
SF.Snowball Namespace


Among Members

[image] [image]

Lucene.Net Class Libraries
Among Members
Among Class Constructors Methods Fields See Also Send Feedback

The Among type exposes the following members.

Constructors

 | Name | Description
Public method | Among | Initializes a new instance of the Among class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | method |
Public field | methodobject |
Public field | result |
Public field | s |
Public field | s_size |
Public field | substring_i |

See Also

Among Class
SF.Snowball Namespace


Among Constructor

[image]

Lucene.Net Class Libraries
Among Constructor
Among Class See Also Send Feedback
Initializes a new instance of the Among class

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public Among(
    string s,
    int substring_i,
    int result,
    string methodname,
    SnowballProgram methodobject
)
Visual Basic
Public Sub New ( _
    s As String, _
    substring_i As Integer, _
    result As Integer, _
    methodname As String, _
    methodobject As SnowballProgram _
)
Visual C++
public:
Among(
    String^ s,
    int substring_i,
    int result,
    String^ methodname,
    SnowballProgram^ methodobject
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:SF.Snowball.Among.#ctor(System.String,System.Int32,System.Int32,System.String,SF.Snowball.SnowballProgram)"]

substring_i
Type: System..::..Int32

[Missing <param name="substring_i"/> documentation for "M:SF.Snowball.Among.#ctor(System.String,System.Int32,System.Int32,System.String,SF.Snowball.SnowballProgram)"]

result
Type: System..::..Int32

[Missing <param name="result"/> documentation for "M:SF.Snowball.Among.#ctor(System.String,System.Int32,System.Int32,System.String,SF.Snowball.SnowballProgram)"]

methodname
Type: System..::..String

[Missing <param name="methodname"/> documentation for "M:SF.Snowball.Among.#ctor(System.String,System.Int32,System.Int32,System.String,SF.Snowball.SnowballProgram)"]

methodobject
Type: SF.Snowball..::..SnowballProgram

[Missing <param name="methodobject"/> documentation for "M:SF.Snowball.Among.#ctor(System.String,System.Int32,System.Int32,System.String,SF.Snowball.SnowballProgram)"]

See Also

Among Class
SF.Snowball Namespace


Among Fields

[image] [image]

Lucene.Net Class Libraries
Among Fields
Among Class See Also Send Feedback

The Among type exposes the following members.

Fields

 | Name | Description
Public field | method |
Public field | methodobject |
Public field | result |
Public field | s |
Public field | s_size |
Public field | substring_i |

See Also

Among Class
SF.Snowball Namespace


method Field

[image]

Lucene.Net Class Libraries
Among..::..method Field
Among Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.Among.method"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public MethodInfo method
Visual Basic
Public method As MethodInfo
Visual C++
public:
MethodInfo^ method

See Also

Among Class
SF.Snowball Namespace


methodobject Field

[image]

Lucene.Net Class Libraries
Among..::..methodobject Field
Among Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.Among.methodobject"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public SnowballProgram methodobject
Visual Basic
Public methodobject As SnowballProgram
Visual C++
public:
SnowballProgram^ methodobject

See Also

Among Class
SF.Snowball Namespace


result Field

[image]

Lucene.Net Class Libraries
Among..::..result Field
Among Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.Among.result"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public int result
Visual Basic
Public result As Integer
Visual C++
public:
int result

See Also

Among Class
SF.Snowball Namespace


s Field

[image]

Lucene.Net Class Libraries
Among..::..s Field
Among Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.Among.s"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public string s
Visual Basic
Public s As String
Visual C++
public:
String^ s

See Also

Among Class
SF.Snowball Namespace


s_size Field

[image]

Lucene.Net Class Libraries
Among..::..s_size Field
Among Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.Among.s_size"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public int s_size
Visual Basic
Public s_size As Integer
Visual C++
public:
int s_size

See Also

Among Class
SF.Snowball Namespace


substring_i Field

[image]

Lucene.Net Class Libraries
Among..::..substring_i Field
Among Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.Among.substring_i"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public int substring_i
Visual Basic
Public substring_i As Integer
Visual C++
public:
int substring_i

See Also

Among Class
SF.Snowball Namespace


Among Methods

[image] [image]

Lucene.Net Class Libraries
Among Methods
Among Class See Also Send Feedback

The Among type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Among Class
SF.Snowball Namespace


SnowballProgram Class

[image]

Lucene.Net Class Libraries
SnowballProgram Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.SnowballProgram"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class SnowballProgram
Visual Basic
Public Class SnowballProgram
Visual C++
public ref class SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..DanishStemmer
SF.Snowball.Ext..::..DutchStemmer
SF.Snowball.Ext..::..EnglishStemmer
SF.Snowball.Ext..::..FinnishStemmer
SF.Snowball.Ext..::..FrenchStemmer
SF.Snowball.Ext..::..German2Stemmer
SF.Snowball.Ext..::..GermanStemmer
SF.Snowball.Ext..::..HungarianStemmer
SF.Snowball.Ext..::..ItalianStemmer
SF.Snowball.Ext..::..KpStemmer
SF.Snowball.Ext..::..LovinsStemmer
SF.Snowball.Ext..::..NorwegianStemmer
SF.Snowball.Ext..::..PorterStemmer
SF.Snowball.Ext..::..PortugueseStemmer
SF.Snowball.Ext..::..RomanianStemmer
SF.Snowball.Ext..::..RussianStemmer
SF.Snowball.Ext..::..SpanishStemmer
SF.Snowball.Ext..::..SwedishStemmer
SF.Snowball.Ext..::..TurkishStemmer

See Also

SnowballProgram Members
SF.Snowball Namespace


SnowballProgram Members

[image] [image]

Lucene.Net Class Libraries
SnowballProgram Members
SnowballProgram Class Constructors Methods Fields See Also Send Feedback

The SnowballProgram type exposes the following members.

Constructors

 | Name | Description
Protected method | SnowballProgram | Initializes a new instance of the SnowballProgram class

Methods

 | Name | Description
Protected method | assign_to |
Protected method | copy_from |
Protected method | eq_s |
Protected method | eq_s_b |
Protected method | eq_v |
Protected method | eq_v_b |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among |
Protected method | find_among_b |
Public method | GetCurrent | Get the current string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping |
Protected method | in_grouping_b |
Protected method | in_range |
Protected method | in_range_b |
Protected method | insert(Int32, Int32, String) |
Protected method | insert(Int32, Int32, StringBuilder) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping |
Protected method | out_grouping_b |
Protected method | out_range |
Protected method | out_range_b |
Protected method | replace_s |
Public method | SetCurrent | Set the current string.
Protected method | slice_check |
Protected method | slice_del |
Protected method | slice_from(String) |
Protected method | slice_from(StringBuilder) |
Protected method | slice_to |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra |
Protected field | current |
Protected field | cursor |
Protected field | ket |
Protected field | limit |
Protected field | limit_backward |

See Also

SnowballProgram Class
SF.Snowball Namespace


SnowballProgram Constructor

[image]

Lucene.Net Class Libraries
SnowballProgram Constructor
SnowballProgram Class See Also Send Feedback
Initializes a new instance of the SnowballProgram class

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal SnowballProgram()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
SnowballProgram()

See Also

SnowballProgram Class
SF.Snowball Namespace


SnowballProgram Fields

[image] [image]

Lucene.Net Class Libraries
SnowballProgram Fields
SnowballProgram Class See Also Send Feedback

The SnowballProgram type exposes the following members.

Fields

 | Name | Description
Protected field | bra |
Protected field | current |
Protected field | cursor |
Protected field | ket |
Protected field | limit |
Protected field | limit_backward |

See Also

SnowballProgram Class
SF.Snowball Namespace


bra Field

[image]

Lucene.Net Class Libraries
SnowballProgram..::..bra Field
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.SnowballProgram.bra"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal int bra
Visual Basic
Protected Friend bra As Integer
Visual C++
protected public:
int bra

See Also

SnowballProgram Class
SF.Snowball Namespace


current Field

[image]

Lucene.Net Class Libraries
SnowballProgram..::..current Field
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.SnowballProgram.current"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal StringBuilder current
Visual Basic
Protected Friend current As StringBuilder
Visual C++
protected public:
StringBuilder^ current

See Also

SnowballProgram Class
SF.Snowball Namespace


cursor Field

[image]

Lucene.Net Class Libraries
SnowballProgram..::..cursor Field
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.SnowballProgram.cursor"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal int cursor
Visual Basic
Protected Friend cursor As Integer
Visual C++
protected public:
int cursor

See Also

SnowballProgram Class
SF.Snowball Namespace


ket Field

[image]

Lucene.Net Class Libraries
SnowballProgram..::..ket Field
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.SnowballProgram.ket"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal int ket
Visual Basic
Protected Friend ket As Integer
Visual C++
protected public:
int ket

See Also

SnowballProgram Class
SF.Snowball Namespace


limit Field

[image]

Lucene.Net Class Libraries
SnowballProgram..::..limit Field
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.SnowballProgram.limit"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal int limit
Visual Basic
Protected Friend limit As Integer
Visual C++
protected public:
int limit

See Also

SnowballProgram Class
SF.Snowball Namespace


limit_backward Field

[image]

Lucene.Net Class Libraries
SnowballProgram..::..limit_backward Field
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "F:SF.Snowball.SnowballProgram.limit_backward"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal int limit_backward
Visual Basic
Protected Friend limit_backward As Integer
Visual C++
protected public:
int limit_backward

See Also

SnowballProgram Class
SF.Snowball Namespace


SnowballProgram Methods

[image] [image]

Lucene.Net Class Libraries
SnowballProgram Methods
SnowballProgram Class See Also Send Feedback

The SnowballProgram type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to |
Protected method | copy_from |
Protected method | eq_s |
Protected method | eq_s_b |
Protected method | eq_v |
Protected method | eq_v_b |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among |
Protected method | find_among_b |
Public method | GetCurrent | Get the current string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping |
Protected method | in_grouping_b |
Protected method | in_range |
Protected method | in_range_b |
Protected method | insert(Int32, Int32, String) |
Protected method | insert(Int32, Int32, StringBuilder) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping |
Protected method | out_grouping_b |
Protected method | out_range |
Protected method | out_range_b |
Protected method | replace_s |
Public method | SetCurrent | Set the current string.
Protected method | slice_check |
Protected method | slice_del |
Protected method | slice_from(String) |
Protected method | slice_from(StringBuilder) |
Protected method | slice_to |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SnowballProgram Class
SF.Snowball Namespace


assign_to Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..assign_to Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.assign_to(System.Text.StringBuilder)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual StringBuilder assign_to(
    StringBuilder s
)
Visual Basic
Protected Friend Overridable Function assign_to ( _
    s As StringBuilder _
) As StringBuilder
Visual C++
protected public:
virtual StringBuilder^ assign_to(
    StringBuilder^ s
)

Parameters

s
Type: System.Text..::..StringBuilder

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.assign_to(System.Text.StringBuilder)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.assign_to(System.Text.StringBuilder)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


copy_from Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..copy_from Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.copy_from(SF.Snowball.SnowballProgram)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    SnowballProgram other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As SnowballProgram _
)
Visual C++
protected public:
virtual void copy_from(
    SnowballProgram^ other
)

Parameters

other
Type: SF.Snowball..::..SnowballProgram

[Missing <param name="other"/> documentation for "M:SF.Snowball.SnowballProgram.copy_from(SF.Snowball.SnowballProgram)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


eq_s Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..eq_s Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.eq_s(System.Int32,System.String)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool eq_s(
    int s_size,
    string s
)
Visual Basic
Protected Friend Overridable Function eq_s ( _
    s_size As Integer, _
    s As String _
) As Boolean
Visual C++
protected public:
virtual bool eq_s(
    int s_size,
    String^ s
)

Parameters

s_size
Type: System..::..Int32

[Missing <param name="s_size"/> documentation for "M:SF.Snowball.SnowballProgram.eq_s(System.Int32,System.String)"]

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.eq_s(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.eq_s(System.Int32,System.String)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


eq_s_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..eq_s_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.eq_s_b(System.Int32,System.String)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool eq_s_b(
    int s_size,
    string s
)
Visual Basic
Protected Friend Overridable Function eq_s_b ( _
    s_size As Integer, _
    s As String _
) As Boolean
Visual C++
protected public:
virtual bool eq_s_b(
    int s_size,
    String^ s
)

Parameters

s_size
Type: System..::..Int32

[Missing <param name="s_size"/> documentation for "M:SF.Snowball.SnowballProgram.eq_s_b(System.Int32,System.String)"]

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.eq_s_b(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.eq_s_b(System.Int32,System.String)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


eq_v Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..eq_v Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.eq_v(System.Text.StringBuilder)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool eq_v(
    StringBuilder s
)
Visual Basic
Protected Friend Overridable Function eq_v ( _
    s As StringBuilder _
) As Boolean
Visual C++
protected public:
virtual bool eq_v(
    StringBuilder^ s
)

Parameters

s
Type: System.Text..::..StringBuilder

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.eq_v(System.Text.StringBuilder)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.eq_v(System.Text.StringBuilder)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


eq_v_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..eq_v_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.eq_v_b(System.Text.StringBuilder)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool eq_v_b(
    StringBuilder s
)
Visual Basic
Protected Friend Overridable Function eq_v_b ( _
    s As StringBuilder _
) As Boolean
Visual C++
protected public:
virtual bool eq_v_b(
    StringBuilder^ s
)

Parameters

s
Type: System.Text..::..StringBuilder

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.eq_v_b(System.Text.StringBuilder)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.eq_v_b(System.Text.StringBuilder)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


find_among Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..find_among Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.find_among(SF.Snowball.Among[],System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual int find_among(
    Among[] v,
    int v_size
)
Visual Basic
Protected Friend Overridable Function find_among ( _
    v As Among(), _
    v_size As Integer _
) As Integer
Visual C++
protected public:
virtual int find_among(
    array<Among^>^ v,
    int v_size
)

Parameters

v
Type: array< SF.Snowball..::..Among >[]()[][]

[Missing <param name="v"/> documentation for "M:SF.Snowball.SnowballProgram.find_among(SF.Snowball.Among[],System.Int32)"]

v_size
Type: System..::..Int32

[Missing <param name="v_size"/> documentation for "M:SF.Snowball.SnowballProgram.find_among(SF.Snowball.Among[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.find_among(SF.Snowball.Among[],System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


find_among_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..find_among_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.find_among_b(SF.Snowball.Among[],System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual int find_among_b(
    Among[] v,
    int v_size
)
Visual Basic
Protected Friend Overridable Function find_among_b ( _
    v As Among(), _
    v_size As Integer _
) As Integer
Visual C++
protected public:
virtual int find_among_b(
    array<Among^>^ v,
    int v_size
)

Parameters

v
Type: array< SF.Snowball..::..Among >[]()[][]

[Missing <param name="v"/> documentation for "M:SF.Snowball.SnowballProgram.find_among_b(SF.Snowball.Among[],System.Int32)"]

v_size
Type: System..::..Int32

[Missing <param name="v_size"/> documentation for "M:SF.Snowball.SnowballProgram.find_among_b(SF.Snowball.Among[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.find_among_b(SF.Snowball.Among[],System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


GetCurrent Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..GetCurrent Method
SnowballProgram Class See Also Send Feedback
Get the current string.

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual string GetCurrent()
Visual Basic
Public Overridable Function GetCurrent As String
Visual C++
public:
virtual String^ GetCurrent()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.GetCurrent"]

See Also

SnowballProgram Class
SF.Snowball Namespace


in_grouping Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..in_grouping Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.in_grouping(System.Char[],System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool in_grouping(
    char[] s,
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function in_grouping ( _
    s As Char(), _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool in_grouping(
    array<wchar_t>^ s,
    int min,
    int max
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.in_grouping(System.Char[],System.Int32,System.Int32)"]

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.in_grouping(System.Char[],System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.in_grouping(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.in_grouping(System.Char[],System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


in_grouping_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..in_grouping_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.in_grouping_b(System.Char[],System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool in_grouping_b(
    char[] s,
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function in_grouping_b ( _
    s As Char(), _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool in_grouping_b(
    array<wchar_t>^ s,
    int min,
    int max
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.in_grouping_b(System.Char[],System.Int32,System.Int32)"]

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.in_grouping_b(System.Char[],System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.in_grouping_b(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.in_grouping_b(System.Char[],System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


in_range Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..in_range Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.in_range(System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool in_range(
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function in_range ( _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool in_range(
    int min,
    int max
)

Parameters

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.in_range(System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.in_range(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.in_range(System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


in_range_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..in_range_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.in_range_b(System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool in_range_b(
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function in_range_b ( _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool in_range_b(
    int min,
    int max
)

Parameters

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.in_range_b(System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.in_range_b(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.in_range_b(System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
SnowballProgram..::..insert Method
SnowballProgram Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) |
Protected method | insert(Int32, Int32, StringBuilder) |

See Also

SnowballProgram Class
SnowballProgram Members
SF.Snowball Namespace


insert Method (Int32, Int32, String)

[image]

Lucene.Net Class Libraries
SnowballProgram..::..insert Method (Int32, Int32, String)
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.String)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void insert(
    int c_bra,
    int c_ket,
    string s
)
Visual Basic
Protected Friend Overridable Sub insert ( _
    c_bra As Integer, _
    c_ket As Integer, _
    s As String _
)
Visual C++
protected public:
virtual void insert(
    int c_bra,
    int c_ket,
    String^ s
)

Parameters

c_bra
Type: System..::..Int32

[Missing <param name="c_bra"/> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.String)"]

c_ket
Type: System..::..Int32

[Missing <param name="c_ket"/> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.String)"]

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.String)"]

See Also

SnowballProgram Class
insert Overload
SF.Snowball Namespace


insert Method (Int32, Int32, StringBuilder)

[image]

Lucene.Net Class Libraries
SnowballProgram..::..insert Method (Int32, Int32, StringBuilder)
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.Text.StringBuilder)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void insert(
    int c_bra,
    int c_ket,
    StringBuilder s
)
Visual Basic
Protected Friend Overridable Sub insert ( _
    c_bra As Integer, _
    c_ket As Integer, _
    s As StringBuilder _
)
Visual C++
protected public:
virtual void insert(
    int c_bra,
    int c_ket,
    StringBuilder^ s
)

Parameters

c_bra
Type: System..::..Int32

[Missing <param name="c_bra"/> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.Text.StringBuilder)"]

c_ket
Type: System..::..Int32

[Missing <param name="c_ket"/> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.Text.StringBuilder)"]

s
Type: System.Text..::..StringBuilder

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.insert(System.Int32,System.Int32,System.Text.StringBuilder)"]

See Also

SnowballProgram Class
insert Overload
SF.Snowball Namespace


out_grouping Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..out_grouping Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.out_grouping(System.Char[],System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool out_grouping(
    char[] s,
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function out_grouping ( _
    s As Char(), _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool out_grouping(
    array<wchar_t>^ s,
    int min,
    int max
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.out_grouping(System.Char[],System.Int32,System.Int32)"]

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.out_grouping(System.Char[],System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.out_grouping(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.out_grouping(System.Char[],System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


out_grouping_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..out_grouping_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.out_grouping_b(System.Char[],System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool out_grouping_b(
    char[] s,
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function out_grouping_b ( _
    s As Char(), _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool out_grouping_b(
    array<wchar_t>^ s,
    int min,
    int max
)

Parameters

s
Type: array< System..::..Char >[]()[][]

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.out_grouping_b(System.Char[],System.Int32,System.Int32)"]

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.out_grouping_b(System.Char[],System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.out_grouping_b(System.Char[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.out_grouping_b(System.Char[],System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


out_range Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..out_range Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.out_range(System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool out_range(
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function out_range ( _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool out_range(
    int min,
    int max
)

Parameters

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.out_range(System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.out_range(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.out_range(System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


out_range_b Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..out_range_b Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.out_range_b(System.Int32,System.Int32)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual bool out_range_b(
    int min,
    int max
)
Visual Basic
Protected Friend Overridable Function out_range_b ( _
    min As Integer, _
    max As Integer _
) As Boolean
Visual C++
protected public:
virtual bool out_range_b(
    int min,
    int max
)

Parameters

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:SF.Snowball.SnowballProgram.out_range_b(System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:SF.Snowball.SnowballProgram.out_range_b(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.out_range_b(System.Int32,System.Int32)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


replace_s Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..replace_s Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.replace_s(System.Int32,System.Int32,System.String)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual int replace_s(
    int c_bra,
    int c_ket,
    string s
)
Visual Basic
Protected Friend Overridable Function replace_s ( _
    c_bra As Integer, _
    c_ket As Integer, _
    s As String _
) As Integer
Visual C++
protected public:
virtual int replace_s(
    int c_bra,
    int c_ket,
    String^ s
)

Parameters

c_bra
Type: System..::..Int32

[Missing <param name="c_bra"/> documentation for "M:SF.Snowball.SnowballProgram.replace_s(System.Int32,System.Int32,System.String)"]

c_ket
Type: System..::..Int32

[Missing <param name="c_ket"/> documentation for "M:SF.Snowball.SnowballProgram.replace_s(System.Int32,System.Int32,System.String)"]

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.replace_s(System.Int32,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.replace_s(System.Int32,System.Int32,System.String)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


SetCurrent Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..SetCurrent Method
SnowballProgram Class See Also Send Feedback
Set the current string.

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual void SetCurrent(
    string value_Renamed
)
Visual Basic
Public Overridable Sub SetCurrent ( _
    value_Renamed As String _
)
Visual C++
public:
virtual void SetCurrent(
    String^ value_Renamed
)

Parameters

value_Renamed
Type: System..::..String

[Missing <param name="value_Renamed"/> documentation for "M:SF.Snowball.SnowballProgram.SetCurrent(System.String)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


slice_check Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..slice_check Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.slice_check"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void slice_check()
Visual Basic
Protected Friend Overridable Sub slice_check
Visual C++
protected public:
virtual void slice_check()

See Also

SnowballProgram Class
SF.Snowball Namespace


slice_del Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..slice_del Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.slice_del"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void slice_del()
Visual Basic
Protected Friend Overridable Sub slice_del
Visual C++
protected public:
virtual void slice_del()

See Also

SnowballProgram Class
SF.Snowball Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
SnowballProgram..::..slice_from Method
SnowballProgram Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) |
Protected method | slice_from(StringBuilder) |

See Also

SnowballProgram Class
SnowballProgram Members
SF.Snowball Namespace


slice_from Method (String)

[image]

Lucene.Net Class Libraries
SnowballProgram..::..slice_from Method (String)
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.slice_from(System.String)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void slice_from(
    string s
)
Visual Basic
Protected Friend Overridable Sub slice_from ( _
    s As String _
)
Visual C++
protected public:
virtual void slice_from(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.slice_from(System.String)"]

See Also

SnowballProgram Class
slice_from Overload
SF.Snowball Namespace


slice_from Method (StringBuilder)

[image]

Lucene.Net Class Libraries
SnowballProgram..::..slice_from Method (StringBuilder)
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.slice_from(System.Text.StringBuilder)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void slice_from(
    StringBuilder s
)
Visual Basic
Protected Friend Overridable Sub slice_from ( _
    s As StringBuilder _
)
Visual C++
protected public:
virtual void slice_from(
    StringBuilder^ s
)

Parameters

s
Type: System.Text..::..StringBuilder

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.slice_from(System.Text.StringBuilder)"]

See Also

SnowballProgram Class
slice_from Overload
SF.Snowball Namespace


slice_to Method

[image]

Lucene.Net Class Libraries
SnowballProgram..::..slice_to Method
SnowballProgram Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.SnowballProgram.slice_to(System.Text.StringBuilder)"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual StringBuilder slice_to(
    StringBuilder s
)
Visual Basic
Protected Friend Overridable Function slice_to ( _
    s As StringBuilder _
) As StringBuilder
Visual C++
protected public:
virtual StringBuilder^ slice_to(
    StringBuilder^ s
)

Parameters

s
Type: System.Text..::..StringBuilder

[Missing <param name="s"/> documentation for "M:SF.Snowball.SnowballProgram.slice_to(System.Text.StringBuilder)"]

Return Value

[Missing <returns> documentation for "M:SF.Snowball.SnowballProgram.slice_to(System.Text.StringBuilder)"]

See Also

SnowballProgram Class
SF.Snowball Namespace


TestApp Class

[image]

Lucene.Net Class Libraries
TestApp Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.TestApp"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class TestApp
Visual Basic
Public Class TestApp
Visual C++
public ref class TestApp

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..TestApp

See Also

TestApp Members
SF.Snowball Namespace


TestApp Members

[image] [image]

Lucene.Net Class Libraries
TestApp Members
TestApp Class Constructors Methods See Also Send Feedback

The TestApp type exposes the following members.

Constructors

 | Name | Description
Public method | TestApp | Initializes a new instance of the TestApp class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestApp Class
SF.Snowball Namespace


TestApp Constructor

[image]

Lucene.Net Class Libraries
TestApp Constructor
TestApp Class See Also Send Feedback
Initializes a new instance of the TestApp class

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public TestApp()
Visual Basic
Public Sub New
Visual C++
public:
TestApp()

See Also

TestApp Class
SF.Snowball Namespace


TestApp Methods

[image] [image]

Lucene.Net Class Libraries
TestApp Methods
TestApp Class See Also Send Feedback

The TestApp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestApp Class
SF.Snowball Namespace


Main Method

[image]

Lucene.Net Class Libraries
TestApp..::..Main Method
TestApp Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.TestApp.Main(System.String[])"]

Namespace: SF.Snowball
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:SF.Snowball.TestApp.Main(System.String[])"]

See Also

TestApp Class
SF.Snowball Namespace


SF.Snowball.Ext Namespace

[image]

Lucene.Net Class Libraries
SF.Snowball.Ext Namespace
Send Feedback

[Missing <summary> documentation for "N:SF.Snowball.Ext"]

Classes

 | Class | Description
Public class | DanishStemmer | Generated class implementing code defined by a snowball script.
Public class | DutchStemmer | Generated class implementing code defined by a snowball script.
Public class | EnglishStemmer | Generated class implementing code defined by a snowball script.
Public class | FinnishStemmer | Generated class implementing code defined by a snowball script.
Public class | FrenchStemmer | Generated class implementing code defined by a snowball script.
Public class | German2Stemmer | Generated class implementing code defined by a snowball script.
Public class | GermanStemmer | Generated class implementing code defined by a snowball script.
Public class | HungarianStemmer |
Public class | ItalianStemmer | Generated class implementing code defined by a snowball script.
Public class | KpStemmer | Generated class implementing code defined by a snowball script.
Public class | LovinsStemmer | Generated class implementing code defined by a snowball script.
Public class | NorwegianStemmer | Generated class implementing code defined by a snowball script.
Public class | PorterStemmer | Generated class implementing code defined by a snowball script.
Public class | PortugueseStemmer |
Public class | RomanianStemmer |
Public class | RussianStemmer | Generated class implementing code defined by a snowball script.
Public class | SpanishStemmer | Generated class implementing code defined by a snowball script.
Public class | SwedishStemmer | Generated class implementing code defined by a snowball script.
Public class | TurkishStemmer |


DanishStemmer Class

[image]

Lucene.Net Class Libraries
DanishStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class DanishStemmer : SnowballProgram
Visual Basic
Public Class DanishStemmer _
    Inherits SnowballProgram
Visual C++
public ref class DanishStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..DanishStemmer

See Also

DanishStemmer Members
SF.Snowball.Ext Namespace


DanishStemmer Members

[image] [image]

Lucene.Net Class Libraries
DanishStemmer Members
DanishStemmer Class Constructors Methods Fields See Also Send Feedback

The DanishStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | DanishStemmer | Initializes a new instance of the DanishStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(DanishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

DanishStemmer Class
SF.Snowball.Ext Namespace


DanishStemmer Constructor

[image]

Lucene.Net Class Libraries
DanishStemmer Constructor
DanishStemmer Class See Also Send Feedback
Initializes a new instance of the DanishStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public DanishStemmer()
Visual Basic
Public Sub New
Visual C++
public:
DanishStemmer()

See Also

DanishStemmer Class
SF.Snowball.Ext Namespace


DanishStemmer Fields

[image] [image]

Lucene.Net Class Libraries
DanishStemmer Fields
DanishStemmer Class See Also Send Feedback

The DanishStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

DanishStemmer Class
SF.Snowball.Ext Namespace


DanishStemmer Methods

[image] [image]

Lucene.Net Class Libraries
DanishStemmer Methods
DanishStemmer Class See Also Send Feedback

The DanishStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(DanishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DanishStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
DanishStemmer..::..copy_from Method
DanishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(DanishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

DanishStemmer Class
DanishStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (DanishStemmer)

[image]

Lucene.Net Class Libraries
DanishStemmer..::..copy_from Method (DanishStemmer)
DanishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.DanishStemmer.copy_from(SF.Snowball.Ext.DanishStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    DanishStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As DanishStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    DanishStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..DanishStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.DanishStemmer.copy_from(SF.Snowball.Ext.DanishStemmer)"]

See Also

DanishStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
DanishStemmer..::..insert Method
DanishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

DanishStemmer Class
DanishStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
DanishStemmer..::..slice_from Method
DanishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

DanishStemmer Class
DanishStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
DanishStemmer..::..Stem Method
DanishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.DanishStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.DanishStemmer.Stem"]

See Also

DanishStemmer Class
SF.Snowball.Ext Namespace


DutchStemmer Class

[image]

Lucene.Net Class Libraries
DutchStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class DutchStemmer : SnowballProgram
Visual Basic
Public Class DutchStemmer _
    Inherits SnowballProgram
Visual C++
public ref class DutchStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..DutchStemmer

See Also

DutchStemmer Members
SF.Snowball.Ext Namespace


DutchStemmer Members

[image] [image]

Lucene.Net Class Libraries
DutchStemmer Members
DutchStemmer Class Constructors Methods Fields See Also Send Feedback

The DutchStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | DutchStemmer | Initializes a new instance of the DutchStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(DutchStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

DutchStemmer Class
SF.Snowball.Ext Namespace


DutchStemmer Constructor

[image]

Lucene.Net Class Libraries
DutchStemmer Constructor
DutchStemmer Class See Also Send Feedback
Initializes a new instance of the DutchStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public DutchStemmer()
Visual Basic
Public Sub New
Visual C++
public:
DutchStemmer()

See Also

DutchStemmer Class
SF.Snowball.Ext Namespace


DutchStemmer Fields

[image] [image]

Lucene.Net Class Libraries
DutchStemmer Fields
DutchStemmer Class See Also Send Feedback

The DutchStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

DutchStemmer Class
SF.Snowball.Ext Namespace


DutchStemmer Methods

[image] [image]

Lucene.Net Class Libraries
DutchStemmer Methods
DutchStemmer Class See Also Send Feedback

The DutchStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(DutchStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DutchStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
DutchStemmer..::..copy_from Method
DutchStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(DutchStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

DutchStemmer Class
DutchStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (DutchStemmer)

[image]

Lucene.Net Class Libraries
DutchStemmer..::..copy_from Method (DutchStemmer)
DutchStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.DutchStemmer.copy_from(SF.Snowball.Ext.DutchStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    DutchStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As DutchStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    DutchStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..DutchStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.DutchStemmer.copy_from(SF.Snowball.Ext.DutchStemmer)"]

See Also

DutchStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
DutchStemmer..::..insert Method
DutchStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

DutchStemmer Class
DutchStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
DutchStemmer..::..slice_from Method
DutchStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

DutchStemmer Class
DutchStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
DutchStemmer..::..Stem Method
DutchStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.DutchStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.DutchStemmer.Stem"]

See Also

DutchStemmer Class
SF.Snowball.Ext Namespace


EnglishStemmer Class

[image]

Lucene.Net Class Libraries
EnglishStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class EnglishStemmer : SnowballProgram
Visual Basic
Public Class EnglishStemmer _
    Inherits SnowballProgram
Visual C++
public ref class EnglishStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..EnglishStemmer

See Also

EnglishStemmer Members
SF.Snowball.Ext Namespace


EnglishStemmer Members

[image] [image]

Lucene.Net Class Libraries
EnglishStemmer Members
EnglishStemmer Class Constructors Methods Fields See Also Send Feedback

The EnglishStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | EnglishStemmer | Initializes a new instance of the EnglishStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(EnglishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

EnglishStemmer Class
SF.Snowball.Ext Namespace


EnglishStemmer Constructor

[image]

Lucene.Net Class Libraries
EnglishStemmer Constructor
EnglishStemmer Class See Also Send Feedback
Initializes a new instance of the EnglishStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public EnglishStemmer()
Visual Basic
Public Sub New
Visual C++
public:
EnglishStemmer()

See Also

EnglishStemmer Class
SF.Snowball.Ext Namespace


EnglishStemmer Fields

[image] [image]

Lucene.Net Class Libraries
EnglishStemmer Fields
EnglishStemmer Class See Also Send Feedback

The EnglishStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

EnglishStemmer Class
SF.Snowball.Ext Namespace


EnglishStemmer Methods

[image] [image]

Lucene.Net Class Libraries
EnglishStemmer Methods
EnglishStemmer Class See Also Send Feedback

The EnglishStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(EnglishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnglishStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
EnglishStemmer..::..copy_from Method
EnglishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(EnglishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

EnglishStemmer Class
EnglishStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (EnglishStemmer)

[image]

Lucene.Net Class Libraries
EnglishStemmer..::..copy_from Method (EnglishStemmer)
EnglishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.EnglishStemmer.copy_from(SF.Snowball.Ext.EnglishStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    EnglishStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As EnglishStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    EnglishStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..EnglishStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.EnglishStemmer.copy_from(SF.Snowball.Ext.EnglishStemmer)"]

See Also

EnglishStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
EnglishStemmer..::..insert Method
EnglishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

EnglishStemmer Class
EnglishStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
EnglishStemmer..::..slice_from Method
EnglishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

EnglishStemmer Class
EnglishStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
EnglishStemmer..::..Stem Method
EnglishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.EnglishStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.EnglishStemmer.Stem"]

See Also

EnglishStemmer Class
SF.Snowball.Ext Namespace


FinnishStemmer Class

[image]

Lucene.Net Class Libraries
FinnishStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class FinnishStemmer : SnowballProgram
Visual Basic
Public Class FinnishStemmer _
    Inherits SnowballProgram
Visual C++
public ref class FinnishStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..FinnishStemmer

See Also

FinnishStemmer Members
SF.Snowball.Ext Namespace


FinnishStemmer Members

[image] [image]

Lucene.Net Class Libraries
FinnishStemmer Members
FinnishStemmer Class Constructors Methods Fields See Also Send Feedback

The FinnishStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | FinnishStemmer | Initializes a new instance of the FinnishStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(FinnishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

FinnishStemmer Class
SF.Snowball.Ext Namespace


FinnishStemmer Constructor

[image]

Lucene.Net Class Libraries
FinnishStemmer Constructor
FinnishStemmer Class See Also Send Feedback
Initializes a new instance of the FinnishStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public FinnishStemmer()
Visual Basic
Public Sub New
Visual C++
public:
FinnishStemmer()

See Also

FinnishStemmer Class
SF.Snowball.Ext Namespace


FinnishStemmer Fields

[image] [image]

Lucene.Net Class Libraries
FinnishStemmer Fields
FinnishStemmer Class See Also Send Feedback

The FinnishStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

FinnishStemmer Class
SF.Snowball.Ext Namespace


FinnishStemmer Methods

[image] [image]

Lucene.Net Class Libraries
FinnishStemmer Methods
FinnishStemmer Class See Also Send Feedback

The FinnishStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(FinnishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FinnishStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
FinnishStemmer..::..copy_from Method
FinnishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(FinnishStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

FinnishStemmer Class
FinnishStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (FinnishStemmer)

[image]

Lucene.Net Class Libraries
FinnishStemmer..::..copy_from Method (FinnishStemmer)
FinnishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.FinnishStemmer.copy_from(SF.Snowball.Ext.FinnishStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    FinnishStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As FinnishStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    FinnishStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..FinnishStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.FinnishStemmer.copy_from(SF.Snowball.Ext.FinnishStemmer)"]

See Also

FinnishStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
FinnishStemmer..::..insert Method
FinnishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

FinnishStemmer Class
FinnishStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
FinnishStemmer..::..slice_from Method
FinnishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

FinnishStemmer Class
FinnishStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
FinnishStemmer..::..Stem Method
FinnishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.FinnishStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.FinnishStemmer.Stem"]

See Also

FinnishStemmer Class
SF.Snowball.Ext Namespace


FrenchStemmer Class

[image]

Lucene.Net Class Libraries
FrenchStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class FrenchStemmer : SnowballProgram
Visual Basic
Public Class FrenchStemmer _
    Inherits SnowballProgram
Visual C++
public ref class FrenchStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..FrenchStemmer

See Also

FrenchStemmer Members
SF.Snowball.Ext Namespace


FrenchStemmer Members

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer Members
FrenchStemmer Class Constructors Methods Fields See Also Send Feedback

The FrenchStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | FrenchStemmer | Initializes a new instance of the FrenchStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(FrenchStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

FrenchStemmer Class
SF.Snowball.Ext Namespace


FrenchStemmer Constructor

[image]

Lucene.Net Class Libraries
FrenchStemmer Constructor
FrenchStemmer Class See Also Send Feedback
Initializes a new instance of the FrenchStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public FrenchStemmer()
Visual Basic
Public Sub New
Visual C++
public:
FrenchStemmer()

See Also

FrenchStemmer Class
SF.Snowball.Ext Namespace


FrenchStemmer Fields

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer Fields
FrenchStemmer Class See Also Send Feedback

The FrenchStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

FrenchStemmer Class
SF.Snowball.Ext Namespace


FrenchStemmer Methods

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer Methods
FrenchStemmer Class See Also Send Feedback

The FrenchStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(FrenchStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FrenchStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer..::..copy_from Method
FrenchStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(FrenchStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

FrenchStemmer Class
FrenchStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (FrenchStemmer)

[image]

Lucene.Net Class Libraries
FrenchStemmer..::..copy_from Method (FrenchStemmer)
FrenchStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.FrenchStemmer.copy_from(SF.Snowball.Ext.FrenchStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    FrenchStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As FrenchStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    FrenchStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..FrenchStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.FrenchStemmer.copy_from(SF.Snowball.Ext.FrenchStemmer)"]

See Also

FrenchStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer..::..insert Method
FrenchStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

FrenchStemmer Class
FrenchStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
FrenchStemmer..::..slice_from Method
FrenchStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

FrenchStemmer Class
FrenchStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
FrenchStemmer..::..Stem Method
FrenchStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.FrenchStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.FrenchStemmer.Stem"]

See Also

FrenchStemmer Class
SF.Snowball.Ext Namespace


German2Stemmer Class

[image]

Lucene.Net Class Libraries
German2Stemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class German2Stemmer : SnowballProgram
Visual Basic
Public Class German2Stemmer _
    Inherits SnowballProgram
Visual C++
public ref class German2Stemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..German2Stemmer

See Also

German2Stemmer Members
SF.Snowball.Ext Namespace


German2Stemmer Members

[image] [image]

Lucene.Net Class Libraries
German2Stemmer Members
German2Stemmer Class Constructors Methods Fields See Also Send Feedback

The German2Stemmer type exposes the following members.

Constructors

 | Name | Description
Public method | German2Stemmer | Initializes a new instance of the German2Stemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(German2Stemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

German2Stemmer Class
SF.Snowball.Ext Namespace


German2Stemmer Constructor

[image]

Lucene.Net Class Libraries
German2Stemmer Constructor
German2Stemmer Class See Also Send Feedback
Initializes a new instance of the German2Stemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public German2Stemmer()
Visual Basic
Public Sub New
Visual C++
public:
German2Stemmer()

See Also

German2Stemmer Class
SF.Snowball.Ext Namespace


German2Stemmer Fields

[image] [image]

Lucene.Net Class Libraries
German2Stemmer Fields
German2Stemmer Class See Also Send Feedback

The German2Stemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

German2Stemmer Class
SF.Snowball.Ext Namespace


German2Stemmer Methods

[image] [image]

Lucene.Net Class Libraries
German2Stemmer Methods
German2Stemmer Class See Also Send Feedback

The German2Stemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(German2Stemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

German2Stemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
German2Stemmer..::..copy_from Method
German2Stemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(German2Stemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

German2Stemmer Class
German2Stemmer Members
SF.Snowball.Ext Namespace


copy_from Method (German2Stemmer)

[image]

Lucene.Net Class Libraries
German2Stemmer..::..copy_from Method (German2Stemmer)
German2Stemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.German2Stemmer.copy_from(SF.Snowball.Ext.German2Stemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    German2Stemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As German2Stemmer _
)
Visual C++
protected public:
virtual void copy_from(
    German2Stemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..German2Stemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.German2Stemmer.copy_from(SF.Snowball.Ext.German2Stemmer)"]

See Also

German2Stemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
German2Stemmer..::..insert Method
German2Stemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

German2Stemmer Class
German2Stemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
German2Stemmer..::..slice_from Method
German2Stemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

German2Stemmer Class
German2Stemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
German2Stemmer..::..Stem Method
German2Stemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.German2Stemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.German2Stemmer.Stem"]

See Also

German2Stemmer Class
SF.Snowball.Ext Namespace


GermanStemmer Class

[image]

Lucene.Net Class Libraries
GermanStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class GermanStemmer : SnowballProgram
Visual Basic
Public Class GermanStemmer _
    Inherits SnowballProgram
Visual C++
public ref class GermanStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..GermanStemmer

See Also

GermanStemmer Members
SF.Snowball.Ext Namespace


GermanStemmer Members

[image] [image]

Lucene.Net Class Libraries
GermanStemmer Members
GermanStemmer Class Constructors Methods Fields See Also Send Feedback

The GermanStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | GermanStemmer | Initializes a new instance of the GermanStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(GermanStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

GermanStemmer Class
SF.Snowball.Ext Namespace


GermanStemmer Constructor

[image]

Lucene.Net Class Libraries
GermanStemmer Constructor
GermanStemmer Class See Also Send Feedback
Initializes a new instance of the GermanStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public GermanStemmer()
Visual Basic
Public Sub New
Visual C++
public:
GermanStemmer()

See Also

GermanStemmer Class
SF.Snowball.Ext Namespace


GermanStemmer Fields

[image] [image]

Lucene.Net Class Libraries
GermanStemmer Fields
GermanStemmer Class See Also Send Feedback

The GermanStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

GermanStemmer Class
SF.Snowball.Ext Namespace


GermanStemmer Methods

[image] [image]

Lucene.Net Class Libraries
GermanStemmer Methods
GermanStemmer Class See Also Send Feedback

The GermanStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(GermanStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GermanStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
GermanStemmer..::..copy_from Method
GermanStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(GermanStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

GermanStemmer Class
GermanStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (GermanStemmer)

[image]

Lucene.Net Class Libraries
GermanStemmer..::..copy_from Method (GermanStemmer)
GermanStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.GermanStemmer.copy_from(SF.Snowball.Ext.GermanStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    GermanStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As GermanStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    GermanStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..GermanStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.GermanStemmer.copy_from(SF.Snowball.Ext.GermanStemmer)"]

See Also

GermanStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
GermanStemmer..::..insert Method
GermanStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

GermanStemmer Class
GermanStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
GermanStemmer..::..slice_from Method
GermanStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

GermanStemmer Class
GermanStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
GermanStemmer..::..Stem Method
GermanStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.GermanStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.GermanStemmer.Stem"]

See Also

GermanStemmer Class
SF.Snowball.Ext Namespace


HungarianStemmer Class

[image]

Lucene.Net Class Libraries
HungarianStemmer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.Ext.HungarianStemmer"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class HungarianStemmer : SnowballProgram
Visual Basic
Public Class HungarianStemmer _
    Inherits SnowballProgram
Visual C++
public ref class HungarianStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..HungarianStemmer

See Also

HungarianStemmer Members
SF.Snowball.Ext Namespace


HungarianStemmer Members

[image] [image]

Lucene.Net Class Libraries
HungarianStemmer Members
HungarianStemmer Class Constructors Methods Fields See Also Send Feedback

The HungarianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | HungarianStemmer | Initializes a new instance of the HungarianStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

HungarianStemmer Class
SF.Snowball.Ext Namespace


HungarianStemmer Constructor

[image]

Lucene.Net Class Libraries
HungarianStemmer Constructor
HungarianStemmer Class See Also Send Feedback
Initializes a new instance of the HungarianStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public HungarianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
HungarianStemmer()

See Also

HungarianStemmer Class
SF.Snowball.Ext Namespace


HungarianStemmer Fields

[image] [image]

Lucene.Net Class Libraries
HungarianStemmer Fields
HungarianStemmer Class See Also Send Feedback

The HungarianStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

HungarianStemmer Class
SF.Snowball.Ext Namespace


HungarianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
HungarianStemmer Methods
HungarianStemmer Class See Also Send Feedback

The HungarianStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HungarianStemmer Class
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
HungarianStemmer..::..insert Method
HungarianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

HungarianStemmer Class
HungarianStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
HungarianStemmer..::..slice_from Method
HungarianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

HungarianStemmer Class
HungarianStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
HungarianStemmer..::..Stem Method
HungarianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.HungarianStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public bool Stem()
Visual Basic
Public Function Stem As Boolean
Visual C++
public:
bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.HungarianStemmer.Stem"]

See Also

HungarianStemmer Class
SF.Snowball.Ext Namespace


ItalianStemmer Class

[image]

Lucene.Net Class Libraries
ItalianStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class ItalianStemmer : SnowballProgram
Visual Basic
Public Class ItalianStemmer _
    Inherits SnowballProgram
Visual C++
public ref class ItalianStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..ItalianStemmer

See Also

ItalianStemmer Members
SF.Snowball.Ext Namespace


ItalianStemmer Members

[image] [image]

Lucene.Net Class Libraries
ItalianStemmer Members
ItalianStemmer Class Constructors Methods Fields See Also Send Feedback

The ItalianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | ItalianStemmer | Initializes a new instance of the ItalianStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(ItalianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

ItalianStemmer Class
SF.Snowball.Ext Namespace


ItalianStemmer Constructor

[image]

Lucene.Net Class Libraries
ItalianStemmer Constructor
ItalianStemmer Class See Also Send Feedback
Initializes a new instance of the ItalianStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public ItalianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
ItalianStemmer()

See Also

ItalianStemmer Class
SF.Snowball.Ext Namespace


ItalianStemmer Fields

[image] [image]

Lucene.Net Class Libraries
ItalianStemmer Fields
ItalianStemmer Class See Also Send Feedback

The ItalianStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

ItalianStemmer Class
SF.Snowball.Ext Namespace


ItalianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
ItalianStemmer Methods
ItalianStemmer Class See Also Send Feedback

The ItalianStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(ItalianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItalianStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
ItalianStemmer..::..copy_from Method
ItalianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(ItalianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

ItalianStemmer Class
ItalianStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (ItalianStemmer)

[image]

Lucene.Net Class Libraries
ItalianStemmer..::..copy_from Method (ItalianStemmer)
ItalianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.ItalianStemmer.copy_from(SF.Snowball.Ext.ItalianStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    ItalianStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As ItalianStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    ItalianStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..ItalianStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.ItalianStemmer.copy_from(SF.Snowball.Ext.ItalianStemmer)"]

See Also

ItalianStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
ItalianStemmer..::..insert Method
ItalianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

ItalianStemmer Class
ItalianStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
ItalianStemmer..::..slice_from Method
ItalianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

ItalianStemmer Class
ItalianStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
ItalianStemmer..::..Stem Method
ItalianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.ItalianStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.ItalianStemmer.Stem"]

See Also

ItalianStemmer Class
SF.Snowball.Ext Namespace


KpStemmer Class

[image]

Lucene.Net Class Libraries
KpStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class KpStemmer : SnowballProgram
Visual Basic
Public Class KpStemmer _
    Inherits SnowballProgram
Visual C++
public ref class KpStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..KpStemmer

See Also

KpStemmer Members
SF.Snowball.Ext Namespace


KpStemmer Members

[image] [image]

Lucene.Net Class Libraries
KpStemmer Members
KpStemmer Class Constructors Methods Fields See Also Send Feedback

The KpStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | KpStemmer | Initializes a new instance of the KpStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(KpStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

KpStemmer Class
SF.Snowball.Ext Namespace


KpStemmer Constructor

[image]

Lucene.Net Class Libraries
KpStemmer Constructor
KpStemmer Class See Also Send Feedback
Initializes a new instance of the KpStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public KpStemmer()
Visual Basic
Public Sub New
Visual C++
public:
KpStemmer()

See Also

KpStemmer Class
SF.Snowball.Ext Namespace


KpStemmer Fields

[image] [image]

Lucene.Net Class Libraries
KpStemmer Fields
KpStemmer Class See Also Send Feedback

The KpStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

KpStemmer Class
SF.Snowball.Ext Namespace


KpStemmer Methods

[image] [image]

Lucene.Net Class Libraries
KpStemmer Methods
KpStemmer Class See Also Send Feedback

The KpStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(KpStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KpStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
KpStemmer..::..copy_from Method
KpStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(KpStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

KpStemmer Class
KpStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (KpStemmer)

[image]

Lucene.Net Class Libraries
KpStemmer..::..copy_from Method (KpStemmer)
KpStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.KpStemmer.copy_from(SF.Snowball.Ext.KpStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    KpStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As KpStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    KpStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..KpStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.KpStemmer.copy_from(SF.Snowball.Ext.KpStemmer)"]

See Also

KpStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
KpStemmer..::..insert Method
KpStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

KpStemmer Class
KpStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
KpStemmer..::..slice_from Method
KpStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

KpStemmer Class
KpStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
KpStemmer..::..Stem Method
KpStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.KpStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.KpStemmer.Stem"]

See Also

KpStemmer Class
SF.Snowball.Ext Namespace


LovinsStemmer Class

[image]

Lucene.Net Class Libraries
LovinsStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class LovinsStemmer : SnowballProgram
Visual Basic
Public Class LovinsStemmer _
    Inherits SnowballProgram
Visual C++
public ref class LovinsStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..LovinsStemmer

See Also

LovinsStemmer Members
SF.Snowball.Ext Namespace


LovinsStemmer Members

[image] [image]

Lucene.Net Class Libraries
LovinsStemmer Members
LovinsStemmer Class Constructors Methods Fields See Also Send Feedback

The LovinsStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | LovinsStemmer | Initializes a new instance of the LovinsStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(LovinsStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

LovinsStemmer Class
SF.Snowball.Ext Namespace


LovinsStemmer Constructor

[image]

Lucene.Net Class Libraries
LovinsStemmer Constructor
LovinsStemmer Class See Also Send Feedback
Initializes a new instance of the LovinsStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public LovinsStemmer()
Visual Basic
Public Sub New
Visual C++
public:
LovinsStemmer()

See Also

LovinsStemmer Class
SF.Snowball.Ext Namespace


LovinsStemmer Fields

[image] [image]

Lucene.Net Class Libraries
LovinsStemmer Fields
LovinsStemmer Class See Also Send Feedback

The LovinsStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

LovinsStemmer Class
SF.Snowball.Ext Namespace


LovinsStemmer Methods

[image] [image]

Lucene.Net Class Libraries
LovinsStemmer Methods
LovinsStemmer Class See Also Send Feedback

The LovinsStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(LovinsStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LovinsStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
LovinsStemmer..::..copy_from Method
LovinsStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(LovinsStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

LovinsStemmer Class
LovinsStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (LovinsStemmer)

[image]

Lucene.Net Class Libraries
LovinsStemmer..::..copy_from Method (LovinsStemmer)
LovinsStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.LovinsStemmer.copy_from(SF.Snowball.Ext.LovinsStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    LovinsStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As LovinsStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    LovinsStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..LovinsStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.LovinsStemmer.copy_from(SF.Snowball.Ext.LovinsStemmer)"]

See Also

LovinsStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
LovinsStemmer..::..insert Method
LovinsStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

LovinsStemmer Class
LovinsStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
LovinsStemmer..::..slice_from Method
LovinsStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

LovinsStemmer Class
LovinsStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
LovinsStemmer..::..Stem Method
LovinsStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.LovinsStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.LovinsStemmer.Stem"]

See Also

LovinsStemmer Class
SF.Snowball.Ext Namespace


NorwegianStemmer Class

[image]

Lucene.Net Class Libraries
NorwegianStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class NorwegianStemmer : SnowballProgram
Visual Basic
Public Class NorwegianStemmer _
    Inherits SnowballProgram
Visual C++
public ref class NorwegianStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..NorwegianStemmer

See Also

NorwegianStemmer Members
SF.Snowball.Ext Namespace


NorwegianStemmer Members

[image] [image]

Lucene.Net Class Libraries
NorwegianStemmer Members
NorwegianStemmer Class Constructors Methods Fields See Also Send Feedback

The NorwegianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | NorwegianStemmer | Initializes a new instance of the NorwegianStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(NorwegianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

NorwegianStemmer Class
SF.Snowball.Ext Namespace


NorwegianStemmer Constructor

[image]

Lucene.Net Class Libraries
NorwegianStemmer Constructor
NorwegianStemmer Class See Also Send Feedback
Initializes a new instance of the NorwegianStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public NorwegianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
NorwegianStemmer()

See Also

NorwegianStemmer Class
SF.Snowball.Ext Namespace


NorwegianStemmer Fields

[image] [image]

Lucene.Net Class Libraries
NorwegianStemmer Fields
NorwegianStemmer Class See Also Send Feedback

The NorwegianStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

NorwegianStemmer Class
SF.Snowball.Ext Namespace


NorwegianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
NorwegianStemmer Methods
NorwegianStemmer Class See Also Send Feedback

The NorwegianStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(NorwegianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NorwegianStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
NorwegianStemmer..::..copy_from Method
NorwegianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(NorwegianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

NorwegianStemmer Class
NorwegianStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (NorwegianStemmer)

[image]

Lucene.Net Class Libraries
NorwegianStemmer..::..copy_from Method (NorwegianStemmer)
NorwegianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.NorwegianStemmer.copy_from(SF.Snowball.Ext.NorwegianStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    NorwegianStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As NorwegianStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    NorwegianStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..NorwegianStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.NorwegianStemmer.copy_from(SF.Snowball.Ext.NorwegianStemmer)"]

See Also

NorwegianStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
NorwegianStemmer..::..insert Method
NorwegianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

NorwegianStemmer Class
NorwegianStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
NorwegianStemmer..::..slice_from Method
NorwegianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

NorwegianStemmer Class
NorwegianStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
NorwegianStemmer..::..Stem Method
NorwegianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.NorwegianStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.NorwegianStemmer.Stem"]

See Also

NorwegianStemmer Class
SF.Snowball.Ext Namespace


PorterStemmer Class

[image]

Lucene.Net Class Libraries
PorterStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class PorterStemmer : SnowballProgram
Visual Basic
Public Class PorterStemmer _
    Inherits SnowballProgram
Visual C++
public ref class PorterStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..PorterStemmer

See Also

PorterStemmer Members
SF.Snowball.Ext Namespace


PorterStemmer Members

[image] [image]

Lucene.Net Class Libraries
PorterStemmer Members
PorterStemmer Class Constructors Methods Fields See Also Send Feedback

The PorterStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | PorterStemmer | Initializes a new instance of the PorterStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(PorterStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

PorterStemmer Class
SF.Snowball.Ext Namespace


PorterStemmer Constructor

[image]

Lucene.Net Class Libraries
PorterStemmer Constructor
PorterStemmer Class See Also Send Feedback
Initializes a new instance of the PorterStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public PorterStemmer()
Visual Basic
Public Sub New
Visual C++
public:
PorterStemmer()

See Also

PorterStemmer Class
SF.Snowball.Ext Namespace


PorterStemmer Fields

[image] [image]

Lucene.Net Class Libraries
PorterStemmer Fields
PorterStemmer Class See Also Send Feedback

The PorterStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

PorterStemmer Class
SF.Snowball.Ext Namespace


PorterStemmer Methods

[image] [image]

Lucene.Net Class Libraries
PorterStemmer Methods
PorterStemmer Class See Also Send Feedback

The PorterStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(PorterStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PorterStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
PorterStemmer..::..copy_from Method
PorterStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(PorterStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

PorterStemmer Class
PorterStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (PorterStemmer)

[image]

Lucene.Net Class Libraries
PorterStemmer..::..copy_from Method (PorterStemmer)
PorterStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.PorterStemmer.copy_from(SF.Snowball.Ext.PorterStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    PorterStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As PorterStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    PorterStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..PorterStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.PorterStemmer.copy_from(SF.Snowball.Ext.PorterStemmer)"]

See Also

PorterStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
PorterStemmer..::..insert Method
PorterStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

PorterStemmer Class
PorterStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
PorterStemmer..::..slice_from Method
PorterStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

PorterStemmer Class
PorterStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
PorterStemmer..::..Stem Method
PorterStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.PorterStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.PorterStemmer.Stem"]

See Also

PorterStemmer Class
SF.Snowball.Ext Namespace


PortugueseStemmer Class

[image]

Lucene.Net Class Libraries
PortugueseStemmer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.Ext.PortugueseStemmer"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class PortugueseStemmer : SnowballProgram
Visual Basic
Public Class PortugueseStemmer _
    Inherits SnowballProgram
Visual C++
public ref class PortugueseStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..PortugueseStemmer

See Also

PortugueseStemmer Members
SF.Snowball.Ext Namespace


PortugueseStemmer Members

[image] [image]

Lucene.Net Class Libraries
PortugueseStemmer Members
PortugueseStemmer Class Constructors Methods Fields See Also Send Feedback

The PortugueseStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | PortugueseStemmer | Initializes a new instance of the PortugueseStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

PortugueseStemmer Class
SF.Snowball.Ext Namespace


PortugueseStemmer Constructor

[image]

Lucene.Net Class Libraries
PortugueseStemmer Constructor
PortugueseStemmer Class See Also Send Feedback
Initializes a new instance of the PortugueseStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public PortugueseStemmer()
Visual Basic
Public Sub New
Visual C++
public:
PortugueseStemmer()

See Also

PortugueseStemmer Class
SF.Snowball.Ext Namespace


PortugueseStemmer Fields

[image] [image]

Lucene.Net Class Libraries
PortugueseStemmer Fields
PortugueseStemmer Class See Also Send Feedback

The PortugueseStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

PortugueseStemmer Class
SF.Snowball.Ext Namespace


PortugueseStemmer Methods

[image] [image]

Lucene.Net Class Libraries
PortugueseStemmer Methods
PortugueseStemmer Class See Also Send Feedback

The PortugueseStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PortugueseStemmer Class
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
PortugueseStemmer..::..insert Method
PortugueseStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

PortugueseStemmer Class
PortugueseStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
PortugueseStemmer..::..slice_from Method
PortugueseStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

PortugueseStemmer Class
PortugueseStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
PortugueseStemmer..::..Stem Method
PortugueseStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.PortugueseStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public bool Stem()
Visual Basic
Public Function Stem As Boolean
Visual C++
public:
bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.PortugueseStemmer.Stem"]

See Also

PortugueseStemmer Class
SF.Snowball.Ext Namespace


RomanianStemmer Class

[image]

Lucene.Net Class Libraries
RomanianStemmer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.Ext.RomanianStemmer"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class RomanianStemmer : SnowballProgram
Visual Basic
Public Class RomanianStemmer _
    Inherits SnowballProgram
Visual C++
public ref class RomanianStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..RomanianStemmer

See Also

RomanianStemmer Members
SF.Snowball.Ext Namespace


RomanianStemmer Members

[image] [image]

Lucene.Net Class Libraries
RomanianStemmer Members
RomanianStemmer Class Constructors Methods Fields See Also Send Feedback

The RomanianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | RomanianStemmer | Initializes a new instance of the RomanianStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

RomanianStemmer Class
SF.Snowball.Ext Namespace


RomanianStemmer Constructor

[image]

Lucene.Net Class Libraries
RomanianStemmer Constructor
RomanianStemmer Class See Also Send Feedback
Initializes a new instance of the RomanianStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public RomanianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
RomanianStemmer()

See Also

RomanianStemmer Class
SF.Snowball.Ext Namespace


RomanianStemmer Fields

[image] [image]

Lucene.Net Class Libraries
RomanianStemmer Fields
RomanianStemmer Class See Also Send Feedback

The RomanianStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

RomanianStemmer Class
SF.Snowball.Ext Namespace


RomanianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
RomanianStemmer Methods
RomanianStemmer Class See Also Send Feedback

The RomanianStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RomanianStemmer Class
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
RomanianStemmer..::..insert Method
RomanianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

RomanianStemmer Class
RomanianStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
RomanianStemmer..::..slice_from Method
RomanianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

RomanianStemmer Class
RomanianStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
RomanianStemmer..::..Stem Method
RomanianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.RomanianStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public bool Stem()
Visual Basic
Public Function Stem As Boolean
Visual C++
public:
bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.RomanianStemmer.Stem"]

See Also

RomanianStemmer Class
SF.Snowball.Ext Namespace


RussianStemmer Class

[image]

Lucene.Net Class Libraries
RussianStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class RussianStemmer : SnowballProgram
Visual Basic
Public Class RussianStemmer _
    Inherits SnowballProgram
Visual C++
public ref class RussianStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..RussianStemmer

See Also

RussianStemmer Members
SF.Snowball.Ext Namespace


RussianStemmer Members

[image] [image]

Lucene.Net Class Libraries
RussianStemmer Members
RussianStemmer Class Constructors Methods Fields See Also Send Feedback

The RussianStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | RussianStemmer | Initializes a new instance of the RussianStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(RussianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

RussianStemmer Class
SF.Snowball.Ext Namespace


RussianStemmer Constructor

[image]

Lucene.Net Class Libraries
RussianStemmer Constructor
RussianStemmer Class See Also Send Feedback
Initializes a new instance of the RussianStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public RussianStemmer()
Visual Basic
Public Sub New
Visual C++
public:
RussianStemmer()

See Also

RussianStemmer Class
SF.Snowball.Ext Namespace


RussianStemmer Fields

[image] [image]

Lucene.Net Class Libraries
RussianStemmer Fields
RussianStemmer Class See Also Send Feedback

The RussianStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

RussianStemmer Class
SF.Snowball.Ext Namespace


RussianStemmer Methods

[image] [image]

Lucene.Net Class Libraries
RussianStemmer Methods
RussianStemmer Class See Also Send Feedback

The RussianStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(RussianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RussianStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
RussianStemmer..::..copy_from Method
RussianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(RussianStemmer) |
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)

See Also

RussianStemmer Class
RussianStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (RussianStemmer)

[image]

Lucene.Net Class Libraries
RussianStemmer..::..copy_from Method (RussianStemmer)
RussianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.RussianStemmer.copy_from(SF.Snowball.Ext.RussianStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    RussianStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As RussianStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    RussianStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..RussianStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.RussianStemmer.copy_from(SF.Snowball.Ext.RussianStemmer)"]

See Also

RussianStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
RussianStemmer..::..insert Method
RussianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

RussianStemmer Class
RussianStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
RussianStemmer..::..slice_from Method
RussianStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

RussianStemmer Class
RussianStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
RussianStemmer..::..Stem Method
RussianStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.RussianStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.RussianStemmer.Stem"]

See Also

RussianStemmer Class
SF.Snowball.Ext Namespace


SpanishStemmer Class

[image]

Lucene.Net Class Libraries
SpanishStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class SpanishStemmer : SnowballProgram
Visual Basic
Public Class SpanishStemmer _
    Inherits SnowballProgram
Visual C++
public ref class SpanishStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..SpanishStemmer

See Also

SpanishStemmer Members
SF.Snowball.Ext Namespace


SpanishStemmer Members

[image] [image]

Lucene.Net Class Libraries
SpanishStemmer Members
SpanishStemmer Class Constructors Methods Fields See Also Send Feedback

The SpanishStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | SpanishStemmer | Initializes a new instance of the SpanishStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | copy_from(SpanishStemmer) |
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

SpanishStemmer Class
SF.Snowball.Ext Namespace


SpanishStemmer Constructor

[image]

Lucene.Net Class Libraries
SpanishStemmer Constructor
SpanishStemmer Class See Also Send Feedback
Initializes a new instance of the SpanishStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public SpanishStemmer()
Visual Basic
Public Sub New
Visual C++
public:
SpanishStemmer()

See Also

SpanishStemmer Class
SF.Snowball.Ext Namespace


SpanishStemmer Fields

[image] [image]

Lucene.Net Class Libraries
SpanishStemmer Fields
SpanishStemmer Class See Also Send Feedback

The SpanishStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

SpanishStemmer Class
SF.Snowball.Ext Namespace


SpanishStemmer Methods

[image] [image]

Lucene.Net Class Libraries
SpanishStemmer Methods
SpanishStemmer Class See Also Send Feedback

The SpanishStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | copy_from(SpanishStemmer) |
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpanishStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
SpanishStemmer..::..copy_from Method
SpanishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | copy_from(SpanishStemmer) |

See Also

SpanishStemmer Class
SpanishStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (SpanishStemmer)

[image]

Lucene.Net Class Libraries
SpanishStemmer..::..copy_from Method (SpanishStemmer)
SpanishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.SpanishStemmer.copy_from(SF.Snowball.Ext.SpanishStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    SpanishStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As SpanishStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    SpanishStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..SpanishStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.SpanishStemmer.copy_from(SF.Snowball.Ext.SpanishStemmer)"]

See Also

SpanishStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
SpanishStemmer..::..insert Method
SpanishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

SpanishStemmer Class
SpanishStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
SpanishStemmer..::..slice_from Method
SpanishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

SpanishStemmer Class
SpanishStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
SpanishStemmer..::..Stem Method
SpanishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.SpanishStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.SpanishStemmer.Stem"]

See Also

SpanishStemmer Class
SF.Snowball.Ext Namespace


SwedishStemmer Class

[image]

Lucene.Net Class Libraries
SwedishStemmer Class
Members See Also Send Feedback
Generated class implementing code defined by a snowball script.

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class SwedishStemmer : SnowballProgram
Visual Basic
Public Class SwedishStemmer _
    Inherits SnowballProgram
Visual C++
public ref class SwedishStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..SwedishStemmer

See Also

SwedishStemmer Members
SF.Snowball.Ext Namespace


SwedishStemmer Members

[image] [image]

Lucene.Net Class Libraries
SwedishStemmer Members
SwedishStemmer Class Constructors Methods Fields See Also Send Feedback

The SwedishStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | SwedishStemmer | Initializes a new instance of the SwedishStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | copy_from(SwedishStemmer) |
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

SwedishStemmer Class
SF.Snowball.Ext Namespace


SwedishStemmer Constructor

[image]

Lucene.Net Class Libraries
SwedishStemmer Constructor
SwedishStemmer Class See Also Send Feedback
Initializes a new instance of the SwedishStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public SwedishStemmer()
Visual Basic
Public Sub New
Visual C++
public:
SwedishStemmer()

See Also

SwedishStemmer Class
SF.Snowball.Ext Namespace


SwedishStemmer Fields

[image] [image]

Lucene.Net Class Libraries
SwedishStemmer Fields
SwedishStemmer Class See Also Send Feedback

The SwedishStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

SwedishStemmer Class
SF.Snowball.Ext Namespace


SwedishStemmer Methods

[image] [image]

Lucene.Net Class Libraries
SwedishStemmer Methods
SwedishStemmer Class See Also Send Feedback

The SwedishStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | copy_from(SwedishStemmer) |
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SwedishStemmer Class
SF.Snowball.Ext Namespace


copy_from Method

[image] [image]

Lucene.Net Class Libraries
SwedishStemmer..::..copy_from Method
SwedishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | copy_from(SnowballProgram) | (Inherited from SnowballProgram.)
Protected method | copy_from(SwedishStemmer) |

See Also

SwedishStemmer Class
SwedishStemmer Members
SF.Snowball.Ext Namespace


copy_from Method (SwedishStemmer)

[image]

Lucene.Net Class Libraries
SwedishStemmer..::..copy_from Method (SwedishStemmer)
SwedishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.SwedishStemmer.copy_from(SF.Snowball.Ext.SwedishStemmer)"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
protected internal virtual void copy_from(
    SwedishStemmer other
)
Visual Basic
Protected Friend Overridable Sub copy_from ( _
    other As SwedishStemmer _
)
Visual C++
protected public:
virtual void copy_from(
    SwedishStemmer^ other
)

Parameters

other
Type: SF.Snowball.Ext..::..SwedishStemmer

[Missing <param name="other"/> documentation for "M:SF.Snowball.Ext.SwedishStemmer.copy_from(SF.Snowball.Ext.SwedishStemmer)"]

See Also

SwedishStemmer Class
copy_from Overload
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
SwedishStemmer..::..insert Method
SwedishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

SwedishStemmer Class
SwedishStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
SwedishStemmer..::..slice_from Method
SwedishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

SwedishStemmer Class
SwedishStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
SwedishStemmer..::..Stem Method
SwedishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.SwedishStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public virtual bool Stem()
Visual Basic
Public Overridable Function Stem As Boolean
Visual C++
public:
virtual bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.SwedishStemmer.Stem"]

See Also

SwedishStemmer Class
SF.Snowball.Ext Namespace


TurkishStemmer Class

[image]

Lucene.Net Class Libraries
TurkishStemmer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SF.Snowball.Ext.TurkishStemmer"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public class TurkishStemmer : SnowballProgram
Visual Basic
Public Class TurkishStemmer _
    Inherits SnowballProgram
Visual C++
public ref class TurkishStemmer : public SnowballProgram

Inheritance Hierarchy

System..::..Object
SF.Snowball..::..SnowballProgram
SF.Snowball.Ext..::..TurkishStemmer

See Also

TurkishStemmer Members
SF.Snowball.Ext Namespace


TurkishStemmer Members

[image] [image]

Lucene.Net Class Libraries
TurkishStemmer Members
TurkishStemmer Class Constructors Methods Fields See Also Send Feedback

The TurkishStemmer type exposes the following members.

Constructors

 | Name | Description
Public method | TurkishStemmer | Initializes a new instance of the TurkishStemmer class

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

TurkishStemmer Class
SF.Snowball.Ext Namespace


TurkishStemmer Constructor

[image]

Lucene.Net Class Libraries
TurkishStemmer Constructor
TurkishStemmer Class See Also Send Feedback
Initializes a new instance of the TurkishStemmer class

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public TurkishStemmer()
Visual Basic
Public Sub New
Visual C++
public:
TurkishStemmer()

See Also

TurkishStemmer Class
SF.Snowball.Ext Namespace


TurkishStemmer Fields

[image] [image]

Lucene.Net Class Libraries
TurkishStemmer Fields
TurkishStemmer Class See Also Send Feedback

The TurkishStemmer type exposes the following members.

Fields

 | Name | Description
Protected field | bra | (Inherited from SnowballProgram.)
Protected field | current | (Inherited from SnowballProgram.)
Protected field | cursor | (Inherited from SnowballProgram.)
Protected field | ket | (Inherited from SnowballProgram.)
Protected field | limit | (Inherited from SnowballProgram.)
Protected field | limit_backward | (Inherited from SnowballProgram.)

See Also

TurkishStemmer Class
SF.Snowball.Ext Namespace


TurkishStemmer Methods

[image] [image]

Lucene.Net Class Libraries
TurkishStemmer Methods
TurkishStemmer Class See Also Send Feedback

The TurkishStemmer type exposes the following members.

Methods

 | Name | Description
Protected method | assign_to | (Inherited from SnowballProgram.)
Protected method | copy_from | (Inherited from SnowballProgram.)
Protected method | eq_s | (Inherited from SnowballProgram.)
Protected method | eq_s_b | (Inherited from SnowballProgram.)
Protected method | eq_v | (Inherited from SnowballProgram.)
Protected method | eq_v_b | (Inherited from SnowballProgram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | find_among | (Inherited from SnowballProgram.)
Protected method | find_among_b | (Inherited from SnowballProgram.)
Public method | GetCurrent | Get the current string. (Inherited from SnowballProgram.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | in_grouping | (Inherited from SnowballProgram.)
Protected method | in_grouping_b | (Inherited from SnowballProgram.)
Protected method | in_range | (Inherited from SnowballProgram.)
Protected method | in_range_b | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | out_grouping | (Inherited from SnowballProgram.)
Protected method | out_grouping_b | (Inherited from SnowballProgram.)
Protected method | out_range | (Inherited from SnowballProgram.)
Protected method | out_range_b | (Inherited from SnowballProgram.)
Protected method | replace_s | (Inherited from SnowballProgram.)
Public method | SetCurrent | Set the current string. (Inherited from SnowballProgram.)
Protected method | slice_check | (Inherited from SnowballProgram.)
Protected method | slice_del | (Inherited from SnowballProgram.)
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)
Protected method | slice_to | (Inherited from SnowballProgram.)
Public method | Stem |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TurkishStemmer Class
SF.Snowball.Ext Namespace


insert Method

[image] [image]

Lucene.Net Class Libraries
TurkishStemmer..::..insert Method
TurkishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | insert(Int32, Int32, String) | (Inherited from SnowballProgram.)
Protected method | insert(Int32, Int32, StringBuilder) | (Inherited from SnowballProgram.)

See Also

TurkishStemmer Class
TurkishStemmer Members
SF.Snowball.Ext Namespace


slice_from Method

[image] [image]

Lucene.Net Class Libraries
TurkishStemmer..::..slice_from Method
TurkishStemmer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | slice_from(String) | (Inherited from SnowballProgram.)
Protected method | slice_from(StringBuilder) | (Inherited from SnowballProgram.)

See Also

TurkishStemmer Class
TurkishStemmer Members
SF.Snowball.Ext Namespace


Stem Method

[image]

Lucene.Net Class Libraries
TurkishStemmer..::..Stem Method
TurkishStemmer Class See Also Send Feedback

[Missing <summary> documentation for "M:SF.Snowball.Ext.TurkishStemmer.Stem"]

Namespace: SF.Snowball.Ext
Assembly: Lucene.Net.Contrib.Snowball (in Lucene.Net.Contrib.Snowball.dll) Version: 2.0.0.1

Syntax

C#
public bool Stem()
Visual Basic
Public Function Stem As Boolean
Visual C++
public:
bool Stem()

Return Value

[Missing <returns> documentation for "M:SF.Snowball.Ext.TurkishStemmer.Stem"]

See Also

TurkishStemmer Class
SF.Snowball.Ext Namespace


Similarity.Net Namespace

[image]

Lucene.Net Class Libraries
Similarity.Net Namespace
Send Feedback

[Missing <summary> documentation for "N:Similarity.Net"]

Classes

 | Class | Description
Public class | MoreLikeThis |
Public class | SimilarityQueries | Simple similarity measures.


MoreLikeThis Class

[image]

Lucene.Net Class Libraries
MoreLikeThis Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Similarity.Net.MoreLikeThis"]

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public sealed class MoreLikeThis
Visual Basic
Public NotInheritable Class MoreLikeThis
Visual C++
public ref class MoreLikeThis sealed

Inheritance Hierarchy

System..::..Object
Similarity.Net..::..MoreLikeThis

See Also

MoreLikeThis Members
Similarity.Net Namespace


MoreLikeThis Members

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Members
MoreLikeThis Class Constructors Methods Fields See Also Send Feedback

The MoreLikeThis type exposes the following members.

Constructors

 | Name | Description
Public method | MoreLikeThis | Constructor requiring an IndexReader.

Methods

 | Name | Description
Public method | DescribeParams | Describe the parameters that control how the "more like this" query is formed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnalyzer | Returns an analyzer that will be used to parse source doc with. The default analyzer is the {@link #DEFAULT_ANALYZER}.
Public method | GetFieldNames | Returns the field names that will be used when generating the 'More Like This' query. The default field names that will be used is {@link #DEFAULT_FIELD_NAMES}.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxNumTokensParsed |
Public method | GetMaxQueryTerms | Returns the maximum number of query terms that will be included in any generated query. The default is {@link #DEFAULT_MAX_QUERY_TERMS}.
Public method | GetMaxWordLen | Returns the maximum word length above which words will be ignored. Set this to 0 for no maximum word length. The default is {@link #DEFAULT_MAX_WORD_LENGTH}.
Public method | GetMinDocFreq | Returns the frequency at which words will be ignored which do not occur in at least this many docs. The default frequency is {@link #DEFALT_MIN_DOC_FREQ}.
Public method | GetMinTermFreq | Returns the frequency below which terms will be ignored in the source doc. The default frequency is the {@link #DEFAULT_MIN_TERM_FREQ}.
Public method | GetMinWordLen | Returns the minimum word length below which words will be ignored. Set this to 0 for no minimum word length. The default is {@link #DEFAULT_MIN_WORD_LENGTH}.
Public method | GetStopWords | Get the current stop words being used.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBoost | Returns whether to boost terms in query based on "score" or not. The default is {@link #DEFAULT_BOOST}.
Public method | Like(Int32) | Return a query that will return docs like the passed lucene document ID.
Public method | Like(FileInfo) | Return a query that will return docs like the passed file.
Public method | Like(Stream) | Return a query that will return docs like the passed stream.
Public method | Like(StreamReader) | Return a query that will return docs like the passed Reader.
Public method | Like(Uri) | Return a query that will return docs like the passed URL.
 | Main | Test driver. Pass in "-i INDEX" and then either "-fn FILE" or "-url URL".
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrieveInterestingTerms | Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.
Public method | RetrieveTerms |
Public method | SetAnalyzer | Sets the analyzer to use. An analyzer is not required for generating a query with the {@link #Like(int)} method, all other 'like' methods require an analyzer.
Public method | SetBoost | Sets whether to boost terms in query based on "score" or not.
Public method | SetFieldNames | Sets the field names that will be used when generating the 'More Like This' query. Set this to null for the field names to be determined at runtime from the IndexReader provided in the constructor.
Public method | SetMaxNumTokensParsed |
Public method | SetMaxQueryTerms | Sets the maximum number of query terms that will be included in any generated query.
Public method | SetMaxWordLen | Sets the maximum word length above which words will be ignored.
Public method | SetMinDocFreq | Sets the frequency at which words will be ignored which do not occur in at least this many docs.
Public method | SetMinTermFreq | Sets the frequency below which terms will be ignored in the source doc.
Public method | SetMinWordLen | Sets the minimum word length below which words will be ignored.
Public method | SetStopWords | Set the set of stopwords. Any word in this set is considered "uninteresting" and ignored. Even if your Analyzer allows stopwords, you might want to tell the MoreLikeThis code to ignore them, as for the purposes of document similarity it seems reasonable to assume that "a stop word is never interesting".
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DEFALT_MIN_DOC_FREQ | Ignore words which do not occur in at least this many docs.
DEFAULT_ANALYZER | Default analyzer to parse source doc with.
DEFAULT_BOOST | Boost terms in query based on score.
DEFAULT_FIELD_NAMES | Default field names. Null is used to specify that the field names should be looked up at runtime from the provided reader.
DEFAULT_MAX_NUM_TOKENS_PARSED | Default maximum number of tokens to parse in each example doc field that is not stored with TermVector support.
DEFAULT_MAX_QUERY_TERMS | Return a Query with no more than this many terms.
DEFAULT_MAX_WORD_LENGTH | Ignore words greater than this length or if 0 then this has no effect.
DEFAULT_MIN_TERM_FREQ | Ignore terms with less than this frequency in the source doc.
DEFAULT_MIN_WORD_LENGTH | Ignore words less than this length or if 0 then this has no effect.
DEFAULT_STOP_WORDS | Default set of stopwords. If null means to allow stop words.

See Also

MoreLikeThis Class
Similarity.Net Namespace


MoreLikeThis Constructor

[image]

Lucene.Net Class Libraries
MoreLikeThis Constructor
MoreLikeThis Class See Also Send Feedback
Constructor requiring an IndexReader.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public MoreLikeThis(
    IndexReader ir
)
Visual Basic
Public Sub New ( _
    ir As IndexReader _
)
Visual C++
public:
MoreLikeThis(
    IndexReader^ ir
)

Parameters

ir
Type: Lucene.Net.Index..::..IndexReader

[Missing <param name="ir"/> documentation for "M:Similarity.Net.MoreLikeThis.#ctor(Lucene.Net.Index.IndexReader)"]

See Also

MoreLikeThis Class
Similarity.Net Namespace


MoreLikeThis Fields

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Fields
MoreLikeThis Class See Also Send Feedback

The MoreLikeThis type exposes the following members.

Fields

Name | Description
DEFALT_MIN_DOC_FREQ | Ignore words which do not occur in at least this many docs.
DEFAULT_ANALYZER | Default analyzer to parse source doc with.
DEFAULT_BOOST | Boost terms in query based on score.
DEFAULT_FIELD_NAMES | Default field names. Null is used to specify that the field names should be looked up at runtime from the provided reader.
DEFAULT_MAX_NUM_TOKENS_PARSED | Default maximum number of tokens to parse in each example doc field that is not stored with TermVector support.
DEFAULT_MAX_QUERY_TERMS | Return a Query with no more than this many terms.
DEFAULT_MAX_WORD_LENGTH | Ignore words greater than this length or if 0 then this has no effect.
DEFAULT_MIN_TERM_FREQ | Ignore terms with less than this frequency in the source doc.
DEFAULT_MIN_WORD_LENGTH | Ignore words less than this length or if 0 then this has no effect.
DEFAULT_STOP_WORDS | Default set of stopwords. If null means to allow stop words.

See Also

MoreLikeThis Class
Similarity.Net Namespace


DEFALT_MIN_DOC_FREQ Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFALT_MIN_DOC_FREQ Field
MoreLikeThis Class See Also Send Feedback
Ignore words which do not occur in at least this many docs.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const int DEFALT_MIN_DOC_FREQ
Visual Basic
Public Const DEFALT_MIN_DOC_FREQ As Integer
Visual C++
public:
literal int DEFALT_MIN_DOC_FREQ

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#getMinDocFreq]
[!:#setMinDocFreq]


DEFAULT_ANALYZER Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_ANALYZER Field
MoreLikeThis Class See Also Send Feedback
Default analyzer to parse source doc with.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public static readonly Analyzer DEFAULT_ANALYZER
Visual Basic
Public Shared ReadOnly DEFAULT_ANALYZER As Analyzer
Visual C++
public:
static initonly Analyzer^ DEFAULT_ANALYZER

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#getAnalyzer]


DEFAULT_BOOST Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_BOOST Field
MoreLikeThis Class See Also Send Feedback
Boost terms in query based on score.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const bool DEFAULT_BOOST
Visual Basic
Public Const DEFAULT_BOOST As Boolean
Visual C++
public:
literal bool DEFAULT_BOOST

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#isBoost]
[!:#SetBoost]


DEFAULT_FIELD_NAMES Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_FIELD_NAMES Field
MoreLikeThis Class See Also Send Feedback
Default field names. Null is used to specify that the field names should be looked up at runtime from the provided reader.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public static readonly string[] DEFAULT_FIELD_NAMES
Visual Basic
Public Shared ReadOnly DEFAULT_FIELD_NAMES As String()
Visual C++
public:
static initonly array<String^>^ DEFAULT_FIELD_NAMES

See Also

MoreLikeThis Class
Similarity.Net Namespace


DEFAULT_MAX_NUM_TOKENS_PARSED Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MAX_NUM_TOKENS_PARSED Field
MoreLikeThis Class See Also Send Feedback
Default maximum number of tokens to parse in each example doc field that is not stored with TermVector support.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const int DEFAULT_MAX_NUM_TOKENS_PARSED
Visual Basic
Public Const DEFAULT_MAX_NUM_TOKENS_PARSED As Integer
Visual C++
public:
literal int DEFAULT_MAX_NUM_TOKENS_PARSED

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#getMaxNumTokensParsed]


DEFAULT_MAX_QUERY_TERMS Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MAX_QUERY_TERMS Field
MoreLikeThis Class See Also Send Feedback
Return a Query with no more than this many terms.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const int DEFAULT_MAX_QUERY_TERMS
Visual Basic
Public Const DEFAULT_MAX_QUERY_TERMS As Integer
Visual C++
public:
literal int DEFAULT_MAX_QUERY_TERMS

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:BooleanQuery#getMaxClauseCount]
[!:#getMaxQueryTerms]
[!:#setMaxQueryTerms]


DEFAULT_MAX_WORD_LENGTH Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MAX_WORD_LENGTH Field
MoreLikeThis Class See Also Send Feedback
Ignore words greater than this length or if 0 then this has no effect.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const int DEFAULT_MAX_WORD_LENGTH
Visual Basic
Public Const DEFAULT_MAX_WORD_LENGTH As Integer
Visual C++
public:
literal int DEFAULT_MAX_WORD_LENGTH

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#getMaxWordLen]
[!:#setMaxWordLen]


DEFAULT_MIN_TERM_FREQ Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MIN_TERM_FREQ Field
MoreLikeThis Class See Also Send Feedback
Ignore terms with less than this frequency in the source doc.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const int DEFAULT_MIN_TERM_FREQ
Visual Basic
Public Const DEFAULT_MIN_TERM_FREQ As Integer
Visual C++
public:
literal int DEFAULT_MIN_TERM_FREQ

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#getMinTermFreq]
[!:#setMinTermFreq]


DEFAULT_MIN_WORD_LENGTH Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_MIN_WORD_LENGTH Field
MoreLikeThis Class See Also Send Feedback
Ignore words less than this length or if 0 then this has no effect.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public const int DEFAULT_MIN_WORD_LENGTH
Visual Basic
Public Const DEFAULT_MIN_WORD_LENGTH As Integer
Visual C++
public:
literal int DEFAULT_MIN_WORD_LENGTH

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#getMinWordLen]
[!:#setMinWordLen]


DEFAULT_STOP_WORDS Field

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DEFAULT_STOP_WORDS Field
MoreLikeThis Class See Also Send Feedback
Default set of stopwords. If null means to allow stop words.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public static readonly Hashtable DEFAULT_STOP_WORDS
Visual Basic
Public Shared ReadOnly DEFAULT_STOP_WORDS As Hashtable
Visual C++
public:
static initonly Hashtable^ DEFAULT_STOP_WORDS

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#setStopWords]
[!:#getStopWords]


MoreLikeThis Methods

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis Methods
MoreLikeThis Class See Also Send Feedback

The MoreLikeThis type exposes the following members.

Methods

 | Name | Description
Public method | DescribeParams | Describe the parameters that control how the "more like this" query is formed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnalyzer | Returns an analyzer that will be used to parse source doc with. The default analyzer is the {@link #DEFAULT_ANALYZER}.
Public method | GetFieldNames | Returns the field names that will be used when generating the 'More Like This' query. The default field names that will be used is {@link #DEFAULT_FIELD_NAMES}.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxNumTokensParsed |
Public method | GetMaxQueryTerms | Returns the maximum number of query terms that will be included in any generated query. The default is {@link #DEFAULT_MAX_QUERY_TERMS}.
Public method | GetMaxWordLen | Returns the maximum word length above which words will be ignored. Set this to 0 for no maximum word length. The default is {@link #DEFAULT_MAX_WORD_LENGTH}.
Public method | GetMinDocFreq | Returns the frequency at which words will be ignored which do not occur in at least this many docs. The default frequency is {@link #DEFALT_MIN_DOC_FREQ}.
Public method | GetMinTermFreq | Returns the frequency below which terms will be ignored in the source doc. The default frequency is the {@link #DEFAULT_MIN_TERM_FREQ}.
Public method | GetMinWordLen | Returns the minimum word length below which words will be ignored. Set this to 0 for no minimum word length. The default is {@link #DEFAULT_MIN_WORD_LENGTH}.
Public method | GetStopWords | Get the current stop words being used.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBoost | Returns whether to boost terms in query based on "score" or not. The default is {@link #DEFAULT_BOOST}.
Public method | Like(Int32) | Return a query that will return docs like the passed lucene document ID.
Public method | Like(FileInfo) | Return a query that will return docs like the passed file.
Public method | Like(Stream) | Return a query that will return docs like the passed stream.
Public method | Like(StreamReader) | Return a query that will return docs like the passed Reader.
Public method | Like(Uri) | Return a query that will return docs like the passed URL.
 | Main | Test driver. Pass in "-i INDEX" and then either "-fn FILE" or "-url URL".
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrieveInterestingTerms | Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.
Public method | RetrieveTerms |
Public method | SetAnalyzer | Sets the analyzer to use. An analyzer is not required for generating a query with the {@link #Like(int)} method, all other 'like' methods require an analyzer.
Public method | SetBoost | Sets whether to boost terms in query based on "score" or not.
Public method | SetFieldNames | Sets the field names that will be used when generating the 'More Like This' query. Set this to null for the field names to be determined at runtime from the IndexReader provided in the constructor.
Public method | SetMaxNumTokensParsed |
Public method | SetMaxQueryTerms | Sets the maximum number of query terms that will be included in any generated query.
Public method | SetMaxWordLen | Sets the maximum word length above which words will be ignored.
Public method | SetMinDocFreq | Sets the frequency at which words will be ignored which do not occur in at least this many docs.
Public method | SetMinTermFreq | Sets the frequency below which terms will be ignored in the source doc.
Public method | SetMinWordLen | Sets the minimum word length below which words will be ignored.
Public method | SetStopWords | Set the set of stopwords. Any word in this set is considered "uninteresting" and ignored. Even if your Analyzer allows stopwords, you might want to tell the MoreLikeThis code to ignore them, as for the purposes of document similarity it seems reasonable to assume that "a stop word is never interesting".
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MoreLikeThis Class
Similarity.Net Namespace


DescribeParams Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..DescribeParams Method
MoreLikeThis Class See Also Send Feedback
Describe the parameters that control how the "more like this" query is formed.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public string DescribeParams()
Visual Basic
Public Function DescribeParams As String
Visual C++
public:
String^ DescribeParams()

Return Value

[Missing <returns> documentation for "M:Similarity.Net.MoreLikeThis.DescribeParams"]

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetAnalyzer Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetAnalyzer Method
MoreLikeThis Class See Also Send Feedback
Returns an analyzer that will be used to parse source doc with. The default analyzer is the {@link #DEFAULT_ANALYZER}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Analyzer GetAnalyzer()
Visual Basic
Public Function GetAnalyzer As Analyzer
Visual C++
public:
Analyzer^ GetAnalyzer()

Return Value

the analyzer that will be used to parse source doc with.

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#DEFAULT_ANALYZER]


GetFieldNames Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetFieldNames Method
MoreLikeThis Class See Also Send Feedback
Returns the field names that will be used when generating the 'More Like This' query. The default field names that will be used is {@link #DEFAULT_FIELD_NAMES}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public string[] GetFieldNames()
Visual Basic
Public Function GetFieldNames As String()
Visual C++
public:
array<String^>^ GetFieldNames()

Return Value

the field names that will be used when generating the 'More Like This' query.

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetMaxNumTokensParsed Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMaxNumTokensParsed Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Similarity.Net.MoreLikeThis.GetMaxNumTokensParsed"]

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public int GetMaxNumTokensParsed()
Visual Basic
Public Function GetMaxNumTokensParsed As Integer
Visual C++
public:
int GetMaxNumTokensParsed()

Return Value

The maximum number of tokens to parse in each example doc field that is not stored with TermVector support

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#DEFAULT_MAX_NUM_TOKENS_PARSED]


GetMaxQueryTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMaxQueryTerms Method
MoreLikeThis Class See Also Send Feedback
Returns the maximum number of query terms that will be included in any generated query. The default is {@link #DEFAULT_MAX_QUERY_TERMS}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public int GetMaxQueryTerms()
Visual Basic
Public Function GetMaxQueryTerms As Integer
Visual C++
public:
int GetMaxQueryTerms()

Return Value

the maximum number of query terms that will be included in any generated query.

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetMaxWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMaxWordLen Method
MoreLikeThis Class See Also Send Feedback
Returns the maximum word length above which words will be ignored. Set this to 0 for no maximum word length. The default is {@link #DEFAULT_MAX_WORD_LENGTH}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public int GetMaxWordLen()
Visual Basic
Public Function GetMaxWordLen As Integer
Visual C++
public:
int GetMaxWordLen()

Return Value

the maximum word length above which words will be ignored.

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetMinDocFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMinDocFreq Method
MoreLikeThis Class See Also Send Feedback
Returns the frequency at which words will be ignored which do not occur in at least this many docs. The default frequency is {@link #DEFALT_MIN_DOC_FREQ}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public int GetMinDocFreq()
Visual Basic
Public Function GetMinDocFreq As Integer
Visual C++
public:
int GetMinDocFreq()

Return Value

the frequency at which words will be ignored which do not occur in at least this many docs.

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetMinTermFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMinTermFreq Method
MoreLikeThis Class See Also Send Feedback
Returns the frequency below which terms will be ignored in the source doc. The default frequency is the {@link #DEFAULT_MIN_TERM_FREQ}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public int GetMinTermFreq()
Visual Basic
Public Function GetMinTermFreq As Integer
Visual C++
public:
int GetMinTermFreq()

Return Value

the frequency below which terms will be ignored in the source doc.

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetMinWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetMinWordLen Method
MoreLikeThis Class See Also Send Feedback
Returns the minimum word length below which words will be ignored. Set this to 0 for no minimum word length. The default is {@link #DEFAULT_MIN_WORD_LENGTH}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public int GetMinWordLen()
Visual Basic
Public Function GetMinWordLen As Integer
Visual C++
public:
int GetMinWordLen()

Return Value

the minimum word length below which words will be ignored.

See Also

MoreLikeThis Class
Similarity.Net Namespace


GetStopWords Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..GetStopWords Method
MoreLikeThis Class See Also Send Feedback
Get the current stop words being used.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Hashtable GetStopWords()
Visual Basic
Public Function GetStopWords As Hashtable
Visual C++
public:
Hashtable^ GetStopWords()

Return Value

[Missing <returns> documentation for "M:Similarity.Net.MoreLikeThis.GetStopWords"]

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#setStopWords]


IsBoost Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..IsBoost Method
MoreLikeThis Class See Also Send Feedback
Returns whether to boost terms in query based on "score" or not. The default is {@link #DEFAULT_BOOST}.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public bool IsBoost()
Visual Basic
Public Function IsBoost As Boolean
Visual C++
public:
bool IsBoost()

Return Value

whether to boost terms in query based on "score" or not.

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#SetBoost]


Like Method

[image] [image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method
MoreLikeThis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Like(Int32) | Return a query that will return docs like the passed lucene document ID.
Public method | Like(FileInfo) | Return a query that will return docs like the passed file.
Public method | Like(Stream) | Return a query that will return docs like the passed stream.
Public method | Like(StreamReader) | Return a query that will return docs like the passed Reader.
Public method | Like(Uri) | Return a query that will return docs like the passed URL.

See Also

MoreLikeThis Class
MoreLikeThis Members
Similarity.Net Namespace


Like Method (Int32)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (Int32)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed lucene document ID.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Query Like(
    int docNum
)
Visual Basic
Public Function Like ( _
    docNum As Integer _
) As Query
Visual C++
public:
Query^ Like(
    int docNum
)

Parameters

docNum
Type: System..::..Int32
the documentID of the lucene doc to generate the 'More Like This" query for.

Return Value

a query that will return docs like the passed lucene document ID.

See Also

MoreLikeThis Class
Like Overload
Similarity.Net Namespace


Like Method (FileInfo)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (FileInfo)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed file.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Query Like(
    FileInfo f
)
Visual Basic
Public Function Like ( _
    f As FileInfo _
) As Query
Visual C++
public:
Query^ Like(
    FileInfo^ f
)

Parameters

f
Type: System.IO..::..FileInfo

[Missing <param name="f"/> documentation for "M:Similarity.Net.MoreLikeThis.Like(System.IO.FileInfo)"]

Return Value

a query that will return docs like the passed file.

See Also

MoreLikeThis Class
Like Overload
Similarity.Net Namespace


Like Method (Stream)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (Stream)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed stream.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Query Like(
    Stream is_Renamed
)
Visual Basic
Public Function Like ( _
    is_Renamed As Stream _
) As Query
Visual C++
public:
Query^ Like(
    Stream^ is_Renamed
)

Parameters

is_Renamed
Type: System.IO..::..Stream

[Missing <param name="is_Renamed"/> documentation for "M:Similarity.Net.MoreLikeThis.Like(System.IO.Stream)"]

Return Value

a query that will return docs like the passed stream.

See Also

MoreLikeThis Class
Like Overload
Similarity.Net Namespace


Like Method (StreamReader)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (StreamReader)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed Reader.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Query Like(
    StreamReader r
)
Visual Basic
Public Function Like ( _
    r As StreamReader _
) As Query
Visual C++
public:
Query^ Like(
    StreamReader^ r
)

Parameters

r
Type: System.IO..::..StreamReader

[Missing <param name="r"/> documentation for "M:Similarity.Net.MoreLikeThis.Like(System.IO.StreamReader)"]

Return Value

a query that will return docs like the passed Reader.

See Also

MoreLikeThis Class
Like Overload
Similarity.Net Namespace


Like Method (Uri)

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Like Method (Uri)
MoreLikeThis Class See Also Send Feedback
Return a query that will return docs like the passed URL.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public Query Like(
    Uri u
)
Visual Basic
Public Function Like ( _
    u As Uri _
) As Query
Visual C++
public:
Query^ Like(
    Uri^ u
)

Parameters

u
Type: System..::..Uri

[Missing <param name="u"/> documentation for "M:Similarity.Net.MoreLikeThis.Like(System.Uri)"]

Return Value

a query that will return docs like the passed URL.

See Also

MoreLikeThis Class
Like Overload
Similarity.Net Namespace


Main Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..Main Method
MoreLikeThis Class See Also Send Feedback
Test driver. Pass in "-i INDEX" and then either "-fn FILE" or "-url URL".

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public static void Main(
    string[] a
)
Visual Basic
Public Shared Sub Main ( _
    a As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ a
)

Parameters

a
Type: array< System..::..String >[]()[][]

[Missing <param name="a"/> documentation for "M:Similarity.Net.MoreLikeThis.Main(System.String[])"]

See Also

MoreLikeThis Class
Similarity.Net Namespace


RetrieveInterestingTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..RetrieveInterestingTerms Method
MoreLikeThis Class See Also Send Feedback
Convenience routine to make it easy to return the most interesting words in a document. More advanced users will call {@link #RetrieveTerms(java.io.Reader) retrieveTerms()} directly.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public string[] RetrieveInterestingTerms(
    StreamReader r
)
Visual Basic
Public Function RetrieveInterestingTerms ( _
    r As StreamReader _
) As String()
Visual C++
public:
array<String^>^ RetrieveInterestingTerms(
    StreamReader^ r
)

Parameters

r
Type: System.IO..::..StreamReader
the source document

Return Value

the most interesting words in the document

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#RetrieveTerms(java.io.Reader)]
[!:#setMaxQueryTerms]


RetrieveTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..RetrieveTerms Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Similarity.Net.MoreLikeThis.RetrieveTerms(System.IO.StreamReader)"]

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public PriorityQueue RetrieveTerms(
    StreamReader r
)
Visual Basic
Public Function RetrieveTerms ( _
    r As StreamReader _
) As PriorityQueue
Visual C++
public:
PriorityQueue^ RetrieveTerms(
    StreamReader^ r
)

Parameters

r
Type: System.IO..::..StreamReader

[Missing <param name="r"/> documentation for "M:Similarity.Net.MoreLikeThis.RetrieveTerms(System.IO.StreamReader)"]

Return Value

[Missing <returns> documentation for "M:Similarity.Net.MoreLikeThis.RetrieveTerms(System.IO.StreamReader)"]

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetAnalyzer Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetAnalyzer Method
MoreLikeThis Class See Also Send Feedback
Sets the analyzer to use. An analyzer is not required for generating a query with the {@link #Like(int)} method, all other 'like' methods require an analyzer.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetAnalyzer(
    Analyzer analyzer
)
Visual Basic
Public Sub SetAnalyzer ( _
    analyzer As Analyzer _
)
Visual C++
public:
void SetAnalyzer(
    Analyzer^ analyzer
)

Parameters

analyzer
Type: Lucene.Net.Analysis..::..Analyzer
the analyzer to use to tokenize text.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetBoost Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetBoost Method
MoreLikeThis Class See Also Send Feedback
Sets whether to boost terms in query based on "score" or not.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetBoost(
    bool boost
)
Visual Basic
Public Sub SetBoost ( _
    boost As Boolean _
)
Visual C++
public:
void SetBoost(
    bool boost
)

Parameters

boost
Type: System..::..Boolean
true to boost terms in query based on "score", false otherwise.

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:#isBoost]


SetFieldNames Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetFieldNames Method
MoreLikeThis Class See Also Send Feedback
Sets the field names that will be used when generating the 'More Like This' query. Set this to null for the field names to be determined at runtime from the IndexReader provided in the constructor.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetFieldNames(
    string[] fieldNames
)
Visual Basic
Public Sub SetFieldNames ( _
    fieldNames As String() _
)
Visual C++
public:
void SetFieldNames(
    array<String^>^ fieldNames
)

Parameters

fieldNames
Type: array< System..::..String >[]()[][]
the field names that will be used when generating the 'More Like This' query.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetMaxNumTokensParsed Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMaxNumTokensParsed Method
MoreLikeThis Class See Also Send Feedback

[Missing <summary> documentation for "M:Similarity.Net.MoreLikeThis.SetMaxNumTokensParsed(System.Int32)"]

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetMaxNumTokensParsed(
    int i
)
Visual Basic
Public Sub SetMaxNumTokensParsed ( _
    i As Integer _
)
Visual C++
public:
void SetMaxNumTokensParsed(
    int i
)

Parameters

i
Type: System..::..Int32
The maximum number of tokens to parse in each example doc field that is not stored with TermVector support

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetMaxQueryTerms Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMaxQueryTerms Method
MoreLikeThis Class See Also Send Feedback
Sets the maximum number of query terms that will be included in any generated query.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetMaxQueryTerms(
    int maxQueryTerms
)
Visual Basic
Public Sub SetMaxQueryTerms ( _
    maxQueryTerms As Integer _
)
Visual C++
public:
void SetMaxQueryTerms(
    int maxQueryTerms
)

Parameters

maxQueryTerms
Type: System..::..Int32
the maximum number of query terms that will be included in any generated query.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetMaxWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMaxWordLen Method
MoreLikeThis Class See Also Send Feedback
Sets the maximum word length above which words will be ignored.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetMaxWordLen(
    int maxWordLen
)
Visual Basic
Public Sub SetMaxWordLen ( _
    maxWordLen As Integer _
)
Visual C++
public:
void SetMaxWordLen(
    int maxWordLen
)

Parameters

maxWordLen
Type: System..::..Int32
the maximum word length above which words will be ignored.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetMinDocFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMinDocFreq Method
MoreLikeThis Class See Also Send Feedback
Sets the frequency at which words will be ignored which do not occur in at least this many docs.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetMinDocFreq(
    int minDocFreq
)
Visual Basic
Public Sub SetMinDocFreq ( _
    minDocFreq As Integer _
)
Visual C++
public:
void SetMinDocFreq(
    int minDocFreq
)

Parameters

minDocFreq
Type: System..::..Int32
the frequency at which words will be ignored which do not occur in at least this many docs.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetMinTermFreq Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMinTermFreq Method
MoreLikeThis Class See Also Send Feedback
Sets the frequency below which terms will be ignored in the source doc.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetMinTermFreq(
    int minTermFreq
)
Visual Basic
Public Sub SetMinTermFreq ( _
    minTermFreq As Integer _
)
Visual C++
public:
void SetMinTermFreq(
    int minTermFreq
)

Parameters

minTermFreq
Type: System..::..Int32
the frequency below which terms will be ignored in the source doc.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetMinWordLen Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetMinWordLen Method
MoreLikeThis Class See Also Send Feedback
Sets the minimum word length below which words will be ignored.

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetMinWordLen(
    int minWordLen
)
Visual Basic
Public Sub SetMinWordLen ( _
    minWordLen As Integer _
)
Visual C++
public:
void SetMinWordLen(
    int minWordLen
)

Parameters

minWordLen
Type: System..::..Int32
the minimum word length below which words will be ignored.

See Also

MoreLikeThis Class
Similarity.Net Namespace


SetStopWords Method

[image]

Lucene.Net Class Libraries
MoreLikeThis..::..SetStopWords Method
MoreLikeThis Class See Also Send Feedback
Set the set of stopwords. Any word in this set is considered "uninteresting" and ignored. Even if your Analyzer allows stopwords, you might want to tell the MoreLikeThis code to ignore them, as for the purposes of document similarity it seems reasonable to assume that "a stop word is never interesting".

Namespace: Similarity.Net
Assembly: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1

Syntax

C#
public void SetStopWords(
    Hashtable stopWords
)
Visual Basic
Public Sub SetStopWords ( _
    stopWords As Hashtable _
)
Visual C++
public:
void SetStopWords(
    Hashtable^ stopWords
)

Parameters

stopWords
Type: System.Collections..::..Hashtable
set of stopwords, if null it means to allow stop words

See Also

MoreLikeThis Class
Similarity.Net Namespace
[!:StopFilter.makeStopSet()]
[!:#getStopWords]


SimilarityQueries Class

[image]

Lucene.Net Class Libraries
SimilarityQueries Class
Members See Also Send Feedback
Simple similarity measures.

Namespace: Similarity.Net
Assemblies: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1
Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public sealed class SimilarityQueries
Visual Basic
Public NotInheritable Class SimilarityQueries
Visual C++
public ref class SimilarityQueries sealed

Inheritance Hierarchy

System..::..Object
Similarity.Net..::..SimilarityQueries

See Also

SimilarityQueries Members
Similarity.Net Namespace
Similarity.Net..::..MoreLikeThis


SimilarityQueries Members

[image] [image]

Lucene.Net Class Libraries
SimilarityQueries Members
SimilarityQueries Class Methods See Also Send Feedback

The SimilarityQueries type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormSimilarQuery |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimilarityQueries Class
Similarity.Net Namespace


SimilarityQueries Methods

[image] [image]

Lucene.Net Class Libraries
SimilarityQueries Methods
SimilarityQueries Class See Also Send Feedback

The SimilarityQueries type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormSimilarQuery |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimilarityQueries Class
Similarity.Net Namespace


FormSimilarQuery Method

[image]

Lucene.Net Class Libraries
SimilarityQueries..::..FormSimilarQuery Method
SimilarityQueries Class See Also Send Feedback

[Missing <summary> documentation for "M:Similarity.Net.SimilarityQueries.FormSimilarQuery(System.String,Lucene.Net.Analysis.Analyzer,System.String,System.Collections.Hashtable)"]

Namespace: Similarity.Net
Assemblies: Lucene.Net.Contrib.Similarity (in Lucene.Net.Contrib.Similarity.dll) Version: 2.0.0.1
Lucene.Net.Contrib.Queries (in Lucene.Net.Contrib.Queries.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public static Query FormSimilarQuery(
    string body,
    Analyzer a,
    string field,
    Hashtable stop
)
Visual Basic
Public Shared Function FormSimilarQuery ( _
    body As String, _
    a As Analyzer, _
    field As String, _
    stop As Hashtable _
) As Query
Visual C++
public:
static Query^ FormSimilarQuery(
    String^ body,
    Analyzer^ a,
    String^ field,
    Hashtable^ stop
)

Parameters

body
Type: System..::..String

[Missing <param name="body"/> documentation for "M:Similarity.Net.SimilarityQueries.FormSimilarQuery(System.String,Lucene.Net.Analysis.Analyzer,System.String,System.Collections.Hashtable)"]

a
Type: Lucene.Net.Analysis..::..Analyzer

[Missing <param name="a"/> documentation for "M:Similarity.Net.SimilarityQueries.FormSimilarQuery(System.String,Lucene.Net.Analysis.Analyzer,System.String,System.Collections.Hashtable)"]

field
Type: System..::..String

[Missing <param name="field"/> documentation for "M:Similarity.Net.SimilarityQueries.FormSimilarQuery(System.String,Lucene.Net.Analysis.Analyzer,System.String,System.Collections.Hashtable)"]

stop
Type: System.Collections..::..Hashtable

[Missing <param name="stop"/> documentation for "M:Similarity.Net.SimilarityQueries.FormSimilarQuery(System.String,Lucene.Net.Analysis.Analyzer,System.String,System.Collections.Hashtable)"]

Return Value

[Missing <returns> documentation for "M:Similarity.Net.SimilarityQueries.FormSimilarQuery(System.String,Lucene.Net.Analysis.Analyzer,System.String,System.Collections.Hashtable)"]

See Also

SimilarityQueries Class
Similarity.Net Namespace


System.Runtime.CompilerServices Namespace

[image]

Lucene.Net Class Libraries
System.Runtime.CompilerServices Namespace
Send Feedback

[Missing <summary> documentation for "N:System.Runtime.CompilerServices"]

Classes

 | Class | Description
Public class | ExtensionAttribute | Indicates that a method is an extension method, or that a class or assembly contains extension methods.


ExtensionAttribute Class

[image]

Lucene.Net Class Libraries
ExtensionAttribute Class
Members See Also Send Feedback
Indicates that a method is an extension method, or that a class or assembly contains extension methods.

Namespace: System.Runtime.CompilerServices
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public sealed class ExtensionAttribute : Attribute
Visual Basic
Public NotInheritable Class ExtensionAttribute _
    Inherits Attribute
Visual C++
public ref class ExtensionAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
System.Runtime.CompilerServices..::..ExtensionAttribute

See Also

ExtensionAttribute Members
System.Runtime.CompilerServices Namespace


ExtensionAttribute Members

[image] [image]

Lucene.Net Class Libraries
ExtensionAttribute Members
ExtensionAttribute Class Constructors Methods Properties See Also Send Feedback

The ExtensionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ExtensionAttribute | Initializes a new instance of the ExtensionAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ExtensionAttribute Class
System.Runtime.CompilerServices Namespace


ExtensionAttribute Constructor

[image]

Lucene.Net Class Libraries
ExtensionAttribute Constructor
ExtensionAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionAttribute class.

Namespace: System.Runtime.CompilerServices
Assembly: Lucene.Net.FastVectorHighlighter (in Lucene.Net.FastVectorHighlighter.dll) Version: 2.9.2.0 (2.9.2)

Syntax

C#
public ExtensionAttribute()
Visual Basic
Public Sub New
Visual C++
public:
ExtensionAttribute()

See Also

ExtensionAttribute Class
System.Runtime.CompilerServices Namespace


ExtensionAttribute Methods

[image] [image]

Lucene.Net Class Libraries
ExtensionAttribute Methods
ExtensionAttribute Class See Also Send Feedback

The ExtensionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtensionAttribute Class
System.Runtime.CompilerServices Namespace


ExtensionAttribute Properties

[image] [image]

Lucene.Net Class Libraries
ExtensionAttribute Properties
ExtensionAttribute Class See Also Send Feedback

The ExtensionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ExtensionAttribute Class
System.Runtime.CompilerServices Namespace